Инструментарий пользователя Internet. Браузер Internet Explorer 6.0. Спмоучитель.

Самоучитель по Microsoft Internet Explorer 6.0

Часть I. Быстрый старт

    • Глава 1. Установка обозревателя Microsoft Internet Explorer 6.0
    • Глава 2. Знакомство с обозревателем Microsoft Internet Explorer 6.0
    • Глава 3. Начало работы с Интернетом
    • Глава 4. Печать и сохранение информации
    • Глава 5. Панели в Microsoft Internet Explorer 6.0
    • Глава 6. Рабочий стол Active Desktop

Часть II. Выбор оптимальной конфигурации

    • Глава 7. Настройка внешнего вида обозревателя
    • Глава 8. Выбор оптимальной конфигурации Internet Explorer 6.0
    • Глава 9. Конфигурирование службы FTP

Часть III. Основы безопасной работы с ресурсами сети

    • Глава 10. Безопасный обмен данными через Интернет
    • Глава 11. Защита компьютера от несанкционированного доступа
    • Глава 12. Ограничение доступа к нежелательным для просмотра ресурсам

Часть IV. Microsoft Outlook Express

    • Глава 13. Первое знакомство с Microsoft Outlook Express
    • Глава 14. Создание и отправка почтовых сообщений
    • Глава 15. Работа с группами новостей
    • Глава 16. Автономная работа
    • Глава 17. Настройка
    • Глава 18. Выбор оптимальной конфигурации Microsoft Outlook Express
    • Приложение 1. Рекомендуемые программы, упрощающие работу с Интернетом и Internet Explorer
    • Приложение 2. Интернет-протоколы
    • Приложение 3. Плагины


  • ЧАСТЬ I. БЫСТРЫЙ СТАРТ
    • Глава 1. Установка обозревателя Microsoft Internet Explorer 6.0
    • Установка


Часть I.

Быстрый старт

  • Глава 1. Установка обозревателя Microsoft Internet Explorer 6.0
  • Глава 2. Знакомство с обозревателем Microsoft Internet Explorer 6.0
  • Глава 3. Начало работы с Интернетом
  • Глава 4. Печать и сохранение информации
  • Глава 5. Панели в Microsoft Internet Explorer 6.0
  • Глава 6. Рабочий стол Active Desktop


ГЛАВА 1

Установка обозревателя Microsoft Internet Explorer 6.0

Пользователи компьютера под управлением операционной системы Windows ХР могут пропустить эту главу, т. к. Microsoft Internet Explorer 6.0 уже установлен.

Минимальные требования для установки и работы с Microsoft Internet Explorer 6.0 таковы.

  • Процессор 486 с частотой 66 МГц (рекомендуется Pentium).
  • Для операционной системы Windows 98 или Windows 98 SE:
    • 16 Мбайт оперативной памяти (минимум);
    • 25,8 Мбайт на жестком диске для полной установки Microsoft Internet Explorer 6.0 и его компонентов.
    • О Для операционной системы Windows NT 4.0 (пакетом обновлений):
    • 32 Мбайт оперативной памяти (минимум);
    • 75 Мбайт на жестком диске для полной установки Microsoft Internet Explorer 6.0 и его компонентов.
  • Для операционной системы Microsoft Windows 2000:
    • 32 Мбайт оперативной памяти (минимум);
    • 75 Мбайт на жестком диске для полной установки Microsoft Internet Explorer 6.0 и его компонентов.
  • Для операционной системы Microsoft Windows Millennium Edition:
    • 32 Мбайт оперативной памяти (минимум);
    • 11,6 Мбайт на жестком диске для полной установки Microsoft Internet Explorer 6.0 и его компонентов.
  • Привод CD-ROM (при установке Microsoft Internet Explorer 6.0 с компакт-диска).
  • Некоторые компоненты Microsoft Internet Explorer 6.0 могут потребовать дополнительных системных ресурсов.

Замечание

Microsoft Internet Explorer 6.0 не будет работать на компьютере под управлением операционной системы Microsoft Windows 95.

Программа инсталляции Microsoft Internet Explorer 6.0 устанавливает большинство файлов на тот же диск, на котором находится операционная система Windows, вне зависимости от выбранного пути инсталляции (места, куда устанавливается Microsoft Internet Explorer 6.0). При нехватке места на диске установка браузера не состоится.


Установка

Вне зависимости от типа установки (сетевого или с компакт-диска), все инсталляционные файлы копируются на жесткий диск вашего компьютера. Это позволяет переустановить программу (если это потребуется) несколько быстрее.

Если вам нужно освободить место на диске, вы можете удалить каталог с файлами установки Microsoft Internet Explorer 6.0. Обычно он располагается в папке Windows и называется Windows Update Setup Files.

До начала установки нужно выбрать ее тип: П установка с компакт-диска; П сетевая установка.

При установке с компакт-диска время, затрачиваемое на инсталляцию Microsoft Internet Explorer 6.0 сильно сокращается, т. к. нет необходимости ожидать полной загрузки файлов на жесткий диск вашего компьютера из локальной сети или из Интернета.

Дальнейший ход установки аналогичен установке из сети Интернет.

При выборе второго типа установки необходимо иметь соединение с Интернетом.

Первым делом, нужно посетить страницу Microsoft и скачать файл ie6setup.exe. Размер файла невелик (около 60 килобайт). Это программа установки, которая сама загрузит и установит браузер и необходимые для его работы компоненты.

Сохраните файл ie6setup.exe на рабочем столе. После того как файл загрузился, запустите его, и перед вашими глазами появится следующее изображение (рис. 1.1).

Здесь вам предлагается согласиться или не согласиться с условиями лицензии (рис. 1.2, 1.3).

Рис. 1.1. Диалоговое окно Windows Update: Internet Explorer и средства Интернета, лицензионное соглашение

Рис. 1.2. Согласиться с условиями лицензии

Рис. 1.3. Фрагмент текста лицензионного соглашения

Рекомендуется прочитать или хотя бы просмотреть лицензионное соглашение, т. к., возможно, вы увидите там что-то, с чем будете не согласны.

Если вы не принимаете условия лицензии, установка будет прервана.

При нажатии кнопки Справка (Help) вы сможете увидеть краткую справку (рис. 1.4).

Рис. 1.4. Диалоговое окно Справка Windows Update

Для продолжения инсталляции Microsoft Internet Explorer 6.0 необходимо согласиться с условиями лицензии и нажать кнопку Далее (Next). Кнопки, позволяющие управлять ходом установки, представлены на рис. 1.5.

Рис. 1.5. Кнопки управления ходом установки

После нажатия кнопки Далее (Next) появится сообщение (рис. 1.6), в котором вас попросят подождать. Время ожидания зависит от скорости вашего персонального компьютера, установленной операционной системой, и еще ряда факторов.

Через несколько секунд появится окно, изображенное на рис. 1.7.

Здесь вас попросят сделать выбор между обычной установкой с типичным набором компонентов — браузер Internet Explorer 6.0, Outlook Express, Windows Media Player и другими программами (рис. 1.8) — и сокращенной установкой с выбором компонентов (рис. 1.9).

  • При выборе обычной установки программа сразу же попросит соединиться с Интернетом (если соединение еще не установлено) и начнет загрузку файлов с сайта Microsoft.

Рис. 1.6. Диалоговое окно Windows Update: Internet Explorer и средства Интернета, подготовка к установке

Рис. 1.7. Диалоговое окно Windows Update: Internet Explorer и средства Интернета, выбор типа установки

Рис. 1.8. Обычная установка

Рис. 1.9. Сокращенная или выборочная установка

При возникновении каких-либо проблем при установке соединения со страницей Microsoft или с сетью целиком появится диалоговое окно. Кнопка Повтор (Retry) позволяет попробовать соединиться еще раз. Нажатие на кнопку Отмена (Cancel) прерывает установку. Кнопка Дополнительно (Advanced) вызывает окно настройки дополнительных параметров соединения. В диалоговом окне Установка Windows Update (рис. 1.10) вы можете указать прокси-сервер, при помощи которого вы соединяетесь с Интернетом. Для этого нужно установить флажок Подключить через прокси-сервер (Connect using a proxy server), указать его адрес в поле Адрес (Address) и его порт в поле Порт (Port). Если вы не знаете адрес прокси-сервера, проконсультируйтесь с администратором вашей сети.

Рис. 1.10. Диалоговое окно Установка Windows Update

Минимальная установка с выбором компонентов рассчитана на более опытных пользователей. Она занимает чуть больше времени, но зато вы загрузите и установите только то, что вам нужно. Соответственно размер, время установки может варьироваться. Вам необходимо сначала выбрать переключатель Сокращенная или выборочная (Install minimal) в диалоговом окне Windows Update: Internet Explorer и средства Интернета, выбор типа установки (см. рис. 1.7), а затем нажать кнопку Далее (Next). Перед вами появится следующее окно (рис. 1.11).

Рис. 1.11. Диалоговое окно Windows Update: Internet Explorer и средства Интернета, страница Параметры компонента

Рассмотрим его содержимое по порядку.

  • Вначале вам предстоит выбрать папку, в которую нужно установить Microsoft Internet Explorer 6.0. По умолчанию, браузер устанавливается в папку C:\Program Files\Internet Explorer. Вы имеете возможность выбрать любую другую. Это можно сделать двумя способами:
    • набрать в поле Папка для установки Internet Explorer путь к папке;
    • нажать кнопку Обзор (Browse) и выбрать нужную папку из списка (рис. 1.12).
  • Далее остается выбрать тип установки: Сокращенная (Minimal), Обычная (Typical) или Полная (Full). Это можно сделать при помощи раскрывающегося списка. В зависимости от выбора набор компонентов будет различен.

Возьмем для примера тип установки Сокращенная (Minimal). Из названия ясно, что Microsoft Internet Explorer 6.0 будет установлен с минимальным набором приложений.

Кстати, вы сами можете выбирать компоненты. Для этого достаточно установить флажок перед названием компонента. То, что выделено жирным шрифтом, не нуждается в установке/обновлении.

Справа дается описание выделенного компонента.

Рис. 1.12. Диалоговое окно Обзор папок

Нажав кнопку Дополнительно (Advanced), вы можете установить некоторые специфические параметры (рис. 1.13).

Рис. 1.13. Диалоговое окно Windows Update: Internet Explorer и средства Интернета, дополнительные установки

Как, например, не создавать ассоциации файлов с обозревателем Internet Explorer (веб-страницы, интернет-адреса, медиа-файлы с Internet Explorer 6.0 и Media Player) и/или загрузить файлы, необходимые для установки браузера, но не устанавливать их.

Дальнейший ход установки идет аналогично установке с обычным набором компонентов. Единственное отличие — время, затрачиваемое на загрузку. При обычной установке вам потребуется около двух с половиной часов (при соединении с Интернетом на скорости, не превышающей 33,6 Кбит/с) на загрузку компонентов.

При установке с минимальным набором компонентов вам потребуется около часа на загрузку необходимых файлов.

Во время загрузки и установки компонентов на экране выводится статус загрузки (рис. 1.14).

Рис. 1.14. Диалоговое окно Windows Update: Internet Explorer и средства Интернета, страница Ход выполнения

В группе Подробности (Details) выводится информация о текущем состоянии. В первой строке — то, что загружается. Во второй строке — откуда загружается. В третьей строке — количество загруженных килобайт, а также примерное время до окончания загрузки.

По окончании загрузки начинается инсталляция. Установка занимает около 5—10 минут, в зависимости от скорости работы вашего компьютера. По окончании инсталляции появится следующее окно (рис. 1.15).

В нем вас просят закрыть все открытые приложения перед тем, как продолжить.

После нажатия кнопки Готово (Finish) компьютер будет перезапущен. Загружаться в этот раз он будет несколько дольше, чем обычно, т. к. производится обновление системных файлов. Некоторое время ПК может не подавать признаков жизни, т. е. не будет загружен Windows (или будет, но не полностью). Это нормально. Через несколько минут все заработает как обычно.

Рис. 1.15. Окно Windows Update: Internet Explorer и средства Интернета, страница Установка завершена

Все. Интернет-браузер Microsoft Internet Explorer 6.0 установлен на вашем компьютере.

Перейдем к главе 2.


  • ЧАСТЬ III. ОСНОВЫ БЕЗОПАСНОЙ РАБОТЫ С РЕСУРСАМИ СЕТИ
    • Глава 10. Безопасный обмен данными через Интернет
      • Возможности Microsoft Internet Explorer
      • Использование безопасного соединения с интернет-сайтами
      • Использование сертификатов
      • Принцип работы сертификатов
      • Получение персонального сертификата
      • Сертификат компании GlobalSign
      • Работа с сертификатом
      • Сертификаты
      • Мастер импорта сертификатов
      • Мастер экспорта сертификатов
      • Персональная информация
      • Вкладка Имя
      • Вкладка Домашние
      • Вкладка Служебные
      • Вкладка Личные
      • Вкладка Другие
      • Вкладка NetMeeting
      • Вкладка Сертификаты
      • Защита информации
      • Cookies
      • Назначение cookies
      • Работа с cookies
      • Настройка обозревателя для работы с cookies
      • Термины


Часть III.

Основы безопасной работы с ресурсами Сети

  • Глава 10. Безопасный обмен данными через Интернет
  • Глава 11. Защита компьютера от несанкционированного доступа
  • Глава 12. Ограничение доступа к нежелательным для просмотра ресурсам


ГЛАВА 10.

Безопасный обмен данными через Интернет

Безопасность — отсутствие опасности. С первого взгляда, кажется, что путешествие по сайтам дело безопасное. Ведь вроде бы никто не может посмотреть, что вы делаете и где. Но это только с первого взгляда. Связано это с реализацией протоколов РРР и TCP/IP. Дело в том, что в них данные передаются в открытом виде. Соответственно прочитать передаваемую информацию становится делом техники.

Возможно, первая мысль, которая вам придет, это - "Ведь я же ничего (почти ничего) не передаю, а только принимаю". Да, в большинстве случаев это так и происходит. Буквально, вы делаете запрос на получение информации, и веб-сервер передает ее на ваш компьютер. Передает опять же в открытом виде.

Ранее эти аспекты могли не так тревожить пользователя. Ведь торговля через Интернет была практически не развита, отсутствовали механизмы перевода секретных данных, денег через Интернет. Сейчас все это делается сплошь и рядом. В Интернете существуют специальные биржи, магазины, системы доступа к платной информации и т. д.

Все это привело к созданию систем защиты доступа к информации.

Для начала каждый пользователь должен для себя сам определить, что для него ценно, а что нет. Например, личные данные — имя и фамилия, адрес или номер банковского счета, или кредитной карты.

Передача такой информации, как имя, фамилия, адрес и некоторой другой в большинстве случаев незащищена. Это означает, что информация передается в открытом виде и любой злоумышленник с легкостью сможет ее перехватить. Поэтому одной из основных рекомендаций для пользователей, часто публикующих свои личные данные на популярных ресурсах, — не писать правду о себе. Нет, вы не должны придумывать неправдивые истории из жизни или создавать какой-то специальный образ. Просто-напросто не говорите, как вас звать, никогда не пишите ваш номер телефона или кредитной карточки. Придумайте псевдоним (NickName), который вы будете использовать в Интернете.

В последнее время публиковать даже свой адрес электронной почты стало небезопасным делом. Всевозможные спаммеры закидают вас письмами с ненужной информацией, рекламой. Поэтому создайте как минимум два ящика электронной почты — один для деловой переписки и общения с определенным, замкнутым кругом людей, а другой — для публики: знакомых из чата и конференций. Сделать это достаточно просто — воспользуйтесь службами, предоставляющими бесплатные почтовые ящики. Например, Mail.ru, Pochtamt.ru и др.

С вероятностью 200% в начале своего путешествия по Интернету вы попадете на сайт, где вам будут обещать "золотые горы" - всевозможную халяву, начиная от бесплатного доступа в сеть Интернет и заканчивая миллионами долларов. И от вас может потребоваться всего лишь ввести номер своей кредитной карточки или счета в банке, или кошелька WM и пароль к нему. Причем будут придумываться такие поводы, которые просто не покажутся подозрительными. Так вот, никогда не делайте этого. Те, кто предлагают сделать деньги из воздуха — простые жулики. Узнав номер вашей кредитной карточки, они смогут совершать покупки в интернет-магазинах или получать доступ к платным ресурсам, оплачивать услуги интернет-провайдеров. И все за ваш счет. Поэтому не верьте тем, кто предлагает что-то большое и дорогое за маленькие деньги или вообще бесплатно.

Приведу небольшую историю из личной практики. Когда-то давно, мой друг, только что купив сотовый телефон, решил, что платить за него надо много, а не хочется. И решил он поискать решение в Интернете. И как вы думаете? Нашел. Набрав в поисковой системе "Бесплатные разговоры по мобильному телефону", перед его глазами предстал огромный список сайтов, обещающих это. Итак, многие из них были просто безобидны. На других же предлагалось скачать всевозможные программы, позволяющие сгенерировать номер" как будто бы реальной, действующей карточки экспресс-оплаты. Мой друг позарился на такое богатство, да и авторы убеждали в том, что это все действительно работает. Он скачал два совершенно разных генератора. Первый в итоге оказался обыкновенным трояном — программой, ворующей личные данные (например, пароли для доступа в Интернет). Над вторым автор поработал на славу. Итак, предлагалось ввести номер действующей 10-ти долларовой карточки. Он был успешно введен. Далее программа попросила соединиться с Интернетом (!!!), пообещав через специальный веб-скрипт выполнить операцию по увеличению номинала карточки. Естественно, что ничего не произошло. Впоследствии оказалось, что такая программа действительно позволяла увеличить баланс на счете, только не вашем, а хозяина программы. После соединения с Интернетом номер карточки отправлялся создателю приложения.

Вывод напрашивается сам собой: не доверяйте тем, кто обещает значительно дешевле, чем другие (или вообще бесплатно) услугу.

Из вышесказанного становится понятно, что самая большая ценность -личные данные, в особенности номера кредитных карточек и банковских счетов.

Для совершения банковских трансакций покупок в интернет-магазинах и т. д. были придуманы специальные методы шифрования информации.


Возможности Microsoft Internet Explorer

В Microsoft Internet Explorer 6.0 есть ряд функций, которые позволяют защитить вашу приватность и сделать ваш компьютер и личную информацию более защищенной.

Применение этих функций позволяет вам понять то, как веб-сайты, которые вы просматриваете, могут ее использовать, тем самым указать настройки безопасности: разрешать или нет сохранение файлов cookies на вашем компьютере.

Функции, позволяющие повысить анонимность:

  • установки приватности, которые указывают вашему компьютеру механизм работы с файлами cookies. Cookies — файлы, создаваемые вебсервером, которые хранят информацию на вашем компьютере. Например, ваши предпочтения при визите на тот или иной ресурс. В cookies также может содержаться ваша личная информация, например, имя или адрес электронной почты;
  • сигналы приватности, которые предупреждают вас о том, что вы запрашиваете данные с сайта, не подходящего под ваши критерии;
  • возможность просматривать политику приватности РЗР веб-ресурса.

Функции безопасности помогают предотвратить доступ к информации, которую вы не разрешали афишировать. Например, информацию о кредитной карте. Также вы можете быть защищены от небезопасного программного обеспечения.

Возможности Internet Explorer в области безопасности:

  • использование сертификатов, которые позволяют идентифицировать человека или защищенный веб-сайт;
  • 128-битное безопасное соединение для использования с безопасными веб-узлами;
  • технология Authenticode от Microsoft, позволяющая идентифицировать программные продукты, которые вы загружаете.


Использование безопасного соединения с интернет-сайтами

Многие интернет-сайты настроены так, чтобы предотвратить несанкционированный доступ к информации, посылаемой или принимаемой с такого веб-узла. Подобные сайты называются безопасными. Обозреватель Microsoft Internet Explorer 6.0 поддерживает практически все наиболее распространенные протоколы передачи информации в зашифрованном виде. Вот почему вы можете с уверенностью передавать личные данные, такие как номер кредитной карты или счета в банке.

При посещении безопасного сайта, он автоматически посылает вам сертификат, и в статусной строке обозревателя Microsoft Internet Explorer 6.0 появится специальный значок — lock icon. Сертификат — документ, подтверждающий данные о человеке или веб-узле. Более подробно о сертификатах, работе с ними вы узнаете ниже.

Если вы попытаетесь отправить личную информацию (например, номер кредитной карты) небезопасному сайту, обозреватель предупредит вас об этом. Если сайт утверждает, что он безопасен, но его цифровая подпись необычна или поддается сомнению, Internet Explorer может предупредить вас о том, что сертификат сайта либо просрочен, либо сайт не тот, за кого себя выдает.


Использование сертификатов

Вы можете использовать сертификаты для того, чтобы защитить вашу персональную информацию в Интернете, а также чтобы обезопасить свой компьютер от программного обеспечения, вызывающего подозрения. Сертификат — специальное электронное удостоверение, подтверждающее личность обладателя.

Обозреватель Microsoft Internet Explorer может работать с двумя видами сертификатов:

  1. Персональный сертификат — это удостоверение в том, что вы это тот, кто говорит, что вы это вы. Эта информация используется тогда, когда вы посылаете ваши данные в Интернете на веб-сайт, требующий сертификат для подтверждения личности. Вы можете контролировать использование ваших персональных данных, применяя специальный ключ, известный только вам и вашему компьютеру. При использовании с e-mail программами (например, Outlook Express) сертификаты безопасности с личными ключами также называют цифровыми идентификаторами.
  2. Сертификат, выданный веб-сайту, подтверждает, что ресурс безопасен, а также, что никакой другой веб-узел не может получить удостоверение оригинального сайта. При отсылке персональной информации через Интернет, неплохо было бы проверить сертификат веб-узла, который вы используете для того, чтобы удостовериться в сохранности, безопасности вашей личной информации. При загрузке программного обеспечения вы также можете использовать сертификаты, чтобы удостовериться в том, что оно подлинное и не содержит вирусов.


Принцип работы сертификатов

Сертификат безопасности, в независимости от того, какого он типа — персональный или выданный веб-узлу — ассоциируется со специальным "личным ключом". Только владелец сертификата знает соответствующий "личный ключ". Он дает возможность владельцу создать цифровую подпись, либо расшифровать данные, зашифрованные публичным ключом. При отправлении сертификата другим людям, вы в действительности отсылаете свой публичный ключ. Таким образом, они могут посылать вам защищенную информацию, которую расшифровать можете только вы -- владелец "личного ключа".

Цифровая подпись — компонент сертификата, является вашим универсальным электроннйш удостоверением, подтверждающим вашу личность. Можно провести аналогию с паспортом в реальной жизни. Цифровая подпись показывает принимающей стороне, что информация была отправлена вами и только вами.

Перед тем как посылать зашифрованные или подписанные документы, вы должны получить персональный сертификат и научить Microsoft Internet Explorer работе с ним. При посещении защищенной веб-страницы узел автоматически отсылает вам свой сертификат.


Получение персонального сертификата

Сертификат можно получить у одной из независимых организаций. Существуют различные типы цифровых сертификатов.

Для примера разберем получение временного персонального цифрового удостоверения у компании GlobalSign (http://www.globalsign.net).

Итак, набрав в адресной строке обозревателя http://www.globalsign.net , вы оказываетесь на сайте компании (рис. 10.1).

Выберите команду Get demo certificate. Это позволит вам получить временное цифровое удостоверение, имеющее некоторые ограничения. Через несколько секунд (минут) — в зависимости от скорости соединения — появится следующее окно (рис. 10.2).

Вам предлагается установить программное обеспечение компании Global-Sign. Раз уж речь идет о сертификатах, посмотрите повнимательнее на окно. Вы можете убедиться в том, что программа, предлагаемая для установки, имеет сертификат безопасности, что подтверждает ее подлинность и делает

Рис. 10.1. Окно GlobalSign — Microsoft Internet Explorer

Рис. 10.2. Шаг 1

ее установку менее рискованной. Если вы доверяете компании-поставщику — можете установить флажок в специальном поле, и это окно в дальнейшем появляться не будет. Правда при установке программы другого разработчика, имеющего сертификат, окно появится снова. Итак, нажмите кнопку Да (Yes). За несколько секунд специальный пакет программ будет установлен (рис. 10.3).

Рис. 10.3. Шаг 2

Вам нужно (уже в окне обозревателя) ввести ваш текущий (используемый) адрес e-mail, пароль, а также контрольный вопрос, который вам будет предложено ввести в случае утери пароля. К выбору контрольного вопроса стоит подойти серьезно. Во-первых, не вводите слово наобум, которое можете забыть через несколько минут. Рекомендуется ввести то, что запомнилось и с чем-то у вас ассоциируется. Например, у меня это одно из мест отдыха. После выполнения предыдущих действий, перейдите к следующему шагу — 3.

Далее вам будет предложено проверить ваш почтовый ящик на наличие сообщения e-mail от компании GlobalSign. В 90% случаев письмо доходит примерно за 20—40 секунд (довольно быстро). Многие начинающие пользователи задаются вопросом — как же так быстро успевают ответить. Все очень просто. Существуют специальные роботы e-mail, которые умеют peaгировать на запросы веб-сервера, пользователя и связаны в единую сеть. В итоге, сообщение e-mail вы получаете такого содержания:

Dear user,

То proceed with your certificate request, please click on the hyperlink below:

https://secure.globalsign.net/en/request/user/classldemo/index.cfm?pin=**

This hyperlink is valid for 30 days.

If you are unable to continue your request within this period

feel free to revisit the request page to get a new hyperlink.

Thank you for trusting GlobalSign! GlobalSign, Your Trust Provider

где ****** — присваиваемый каждому индивидуальный номер.

В сообщении вас призывают нажать на ссылку. Если ваша программа e-mail не умеет работать со ссылками, сделайте следующее:

  1. Выделите ссылку. Для этого подведите курсор к тексту и, нажав левую кнопку мыши, выделите ссылку.
  2. Далее, в контекстном меню, которое можно вызвать нажатием правой кнопки мыши, подведя курсор на выделенный фрагмент текста, выберите команду Копировать (Сору).
  3. Теперь раскройте окно обозревателя Microsoft Internet Explorer 6.0. Подведите курсор к адресной строке и в контекстном меню выберите команду Вставить (Paste).
  4. Нажмите клавишу <Enter> на клавиатуре, либо кнопку Переход (Go) в окне обозревателя.

Загрузится новая веб-страница с единственной формой — ввода пароля (рис. 10.4).

"Зачем?" - спросите вы. Все это нужно для того, чтобы удостовериться, что вы это вы, что никто случайно не пришел по этой ссылке. Поэтому и ввод пароля делается в двух формах — на шаге 2 и шаге 3.

На пятом шаге вас попросят ввести личную информацию, а также выбрать провайдера для ключей, защиту публичного ключа (рис. 10.5).

При переходе к шестому шагу вас попросят проверить e-mail. В письме вы получите не только рекомендации по использованию пары ключей, но и путь к их инсталлятору.

Ко мне сообщение e-mail шло на протяжении 4—5 минут. Это неудивительно, ведь на сервере компании GlobalSign за это время создавалась пара ключей, что тоже не так быстро.

Рис. 10.4. Шаг 4

Рис. 10.5. Шаг 5

Поэтому, во время ожидания, давайте изучим сертификат самого сайта GlobalSigrt.


Сертификат компании GlobalSign

Как вы можете увидеть, соединение с сервером компании происходит по безопасному соединению. Это можно заметить, как по названию протокола https (в адресной строке вместо стандартного fttрs://адрес_сайта.домен имеется fttрs://адрес_сайта.домен), так и по статусной строке, где имеется значок, напоминающий по форме замок (рис. 10.6).

Рис. 10.6. Шаг 6

Итак, чтобы посмотреть сертификат (цифровую подпись сайта), дважды щелкните по значку-замку. Появится следующее окно — информация о сертификате (рис. 10.7).

В окне имеется несколько вкладок — Общие (General), Состав (Details), Путь сертификации (Certification Path).

  • Общие (General) — в данной вкладке дается общая информация о сертификате, в частности для чего он нужен, кому выдан, срок его годности.

Рис. 10.7. Окно Сертификат, вкладка Общие

Итак, сертификат:

  • Обеспечивает получение идентификации от удаленного компьютера (Guarantee the identity of a remote computer) — гарантирует, что удаленный компьютер является тем, кем представляется. В итоге, вы можете быть уверены в том, что не посылаете информацию постороннему лицу, представляющемуся компанией GlobalSign;
  • Подтверждает, что письмо пришло от конкретного отправителя (Ensure e-mail came from the sender) — гарантирует, что сообщений e-mail, полученное от веб-сайта, пришло от отправителя, а не от какой-то другой структуры или сетевого объединения. Эти данные должны уверить вас — пользователя в том, что все точно, честно и без подвохов, "подводных камней";
  • Защищает электронную почту от подделки (Protect e-mail from tampering) — защита электронного письма от вмешательства. Имеется в виду, что по пути следования в сообщение e-mail не будут добавлены или, наоборот, удалены какие-то данные, важная или не очень информация. Дается 100%-ная гарантия того, что письмо дойдет до получателя таким, каким оно было отправлено — без изменений, осуществленными посторонними лицами;
  • Позволяет запретить другим лицам просматривать (Ensure the content of e-mail cannot be viewed by others) — гарантируется невозможность просмотра, прочтение сообщения e-mail посторонними лицами. То есть, увидеть, изучить, прочитать сможете вы и только вы.

Далее идет следующая графа. Она разделена с предыдущей вертикальной полосой:

  • Кому выдан (Issued to) и Кем выдан (Issued by). Изучаемый сертификат как выдавался, так и получался одной и той же компанией — GlobalSign. Это вполне логично.
  • Далее идет Действителен с **.**.** по **.**.** (Valid from **.**.** to **.**.**). Здесь дается информация о сроке годности сертификата, т. е. с к&кое по какое время он действителен.

После изучения вкладки Общие (General) уже можно прийти к предварительным выводам — компания та, за кого себя выдает. Но пока e-mail еще не пришел, продолжаем изучение сертификата.

  • Состав (Details) — здесь можно узнать более подробную информацию о сертификате. Например, его версию или серийный номер. Одним из немаловажных данных является срок годности сертификата — здесь его можно узнать с точностью до секунд. Также вас может заинтересовать длина публичного ключа — она составляет 1024 бита. Стоит напомнить, что чем длиннее ключ, тем выше безопасность (рис. 10.8).

Данные, находящиеся во вкладке Состав (Details), вы можете скопировать в файл. Для этого достаточно нажать кнопку Копировать в файл (Copy to File).

  • Путь сертификации (Certification path) — на рис. 40.9 представлен путь сертификации данного ресурса. Итак, главным сервером является GlobalSign Root CA. Далее идет GlobalSign Primary Secure Server CA. Haпрашивается вывод: если есть Primary, значит есть и Secondary и т. д. После Primary идет просто GlobalSign Secure Server CA, а уже потом сертифицированный ресурс — secure.globalsign.net.

За время изучения вами сертификатов GlobalSign уже прошло достаточно времени для генерации и получения ссылки на вашу персональную электронную подпись. Проверьте почтовый ящик.

Пришло письмо следующего содержания:

Dear Sir, Madam,

You have requested a GlobalSign digital certificate. We are certain that you will enjoy the advantages!

In order to download your certificate, please use the hyperlink below: http://secure.globalsign.net/en/receive/index.cfm?id=4272140124

Рис. 10.8. Окно Сертификат, вкладка Состав

Рис. 10.9. Окно Сертификат, вкладка Путь сертификации

For an optimal use we would like to inform you that:

- You have to notify GlobalSign immediately if there i s an error in your certificate. Without reaction from your side within, 15 days after receipt you have accepted the certificate.

- When data are changed in your certificate, you have to revoke your certificate.

- By accepting a certificate, the subscriber assumes a duty to retain control of the subscriber's private key, to use a trustworthy system, and to take reasonable precautions

to prevent its loss, disclosure or unauthorized use.

If you experience any technical problems, please visit our support center for further help at http://support.globalsign.net

Good luck with your certificate!

Do not hesitate to contact us for any information: info@globalsign.net

Kind regards, GlobalSign.

Для тех, кто не понимает по-английски, привожу перевод:

Дорогой сэр, мадам!

Вы сделали запрос на получение цифрового сертификата GlobalSign. Мы уверены, что вам понравятся наши преимущества.

Для того чтобы загрузить ваш сертификат, пожалуйста, следуйте по ссылке:

http://secure.globalsign.net/en/receive/index.cfm?id=*******

Для оптимального использования, мы бы хотели вас проинформировать:

  • Вы должны немедленно сообщить об ошибке в вашем сертификате. Не получив никакой реакции от вас в течение 15 дней, мы решаем, что вы приняли сертификат.
  • При изменении информации в вашем сертификате, вы должны его отозвать.

Принимая сертификат, подписчик понимает обязанность следить за "личным ключом", использовать надежную систему, и не создавать ситуаций, ведущих к потере ключа.

  • При возникновении каких-либо технических проблем, пожалуйста, посетите страницу технической поддержки, расположенную по адресу http:// support.globalsign.net.

Удачи с вашим сертификатом!

Теперь дважды щелкните по ссылке, загрузится веб-страница с единственной кнопкой — Install (рис. 10.10).

Нажатие на кнопку Install вызовет диалоговое окно, в котором будет сообщено об успешной или неуспешной инсталляции сертификата.

Рис. 10.10. Шаг 7


Работа с сертификатом

После того как сертификат успешно установлен, вы можете использовать его в качестве цифровой подписи. Например, для сообщений e-mail. О том, как настроить Microsoft Outlook Express для работы с сертификатом, будет рассказано в третьей части книги.

Сейчас же вы узнаете о том, как получить дополнительную информацию о сертификатах, установленных на вашем компьютере, а также о мастерах экспорта и импорта.

Итак, запустите обозреватель Microsoft Internet Explorer. Далее из раскрывающегося меню Сервис (Tools) выберите команду Свойства обозревателя (Internet Options). В появившемся окне нас интересует вкладка Содержание (Content) (рис. 10.11). Подведите курсор к вкладке Содержание (Content) и щелкните по нему.

Здесь есть группа параметров Сертификаты (Certificates) с двумя кнопками — Сертификаты (Certificates) и Издатели (Publishers).


Сертификаты

Менеджер сертификатов можно вызвать нажатием кнопки Сертификаты (Certificates). В появившемся окне вы можете выбрать одну из вкладок —

Рис. 10.11. Окно Свойства обозревателя, вкладка Содержание

Личные (Personal), Другие пользователи (Other people), Промежуточные центры сертификации (Intermediate Certificate Authorities), Доверенные корневые центры сертификации (Trusted Root Certification Authorities).

  • Вкладка Личные (Personal) — здесь хранится информация об имеющихся у вас личных сертификатах. Личные — те, которые выданы именно вам, электронные подписи. Если вы уже создали себе персональный сертификат (о том, как это сделать, говорилось выше), то он будет иметься в списке. Список разделен на:
    • Кому выдан (Issued To) — в данном примере, идентификация пользователя идет по адресу e-mail. Соответственно в этом поле написано: wiz@pop3.ru;
    • Кем выдан (Issued By) — в поле дается информация о компании, выдавшей сертификат, ее имени;
    • Срок дей... (Expiration — дата окончания действия) — представляется в формате: число.месяц.год;
    • Понятное имя (Friendly Name).

Чуть ниже, под списком располагаются кнопки:

    • Импорт (Import) — запускает Мастер импорта сертификата;
    • Экспорт (Export) — запускает Мастер экспорта сертификата;
    • Удалить (Remove) — удалить сертификат. При нажатии этой кнопки появляется диалоговое окно, в котором вас информируют о том, что при удалении вы больше не сможете расшифровывать послания, зашифрованные вашим публичным ключом. Если вы согласны, нажмите кнопку ОК;
    • Дополнительно (Advanced) — дополнительные опции для продвинутых пользователей. Вызывается специальное окно, в котором вы можете указать "формат экспортируемого сертификата: Der Encoded Binary Х.509, Base64 Encoded X509, PKCS #7 Certificates. По умолчанию -Der Encoded Binary Х.509. При желании, вы можете включать все сертификаты в путь сертификации.
  • То, что стоит указывать во вкладке Дополнительные возможности (Advanced Purposes), можно установить в этом же окне. Для этого достаточно снять/установить флажок:
    • Проверка подлинности сервера (Server Authentication);
    • Проверка подлинности клиента (Client Authentication);
    • Подписывание кода (Code Signing);
    • Защищенная электронная почта (Secure Email);
    • Установка штампа времени (Time Stamping);
    • Подписывание списка доверия (Microsoft) (Microsoft Trust List Signing);
    • Установка штампа времени (Microsoft) (Microsoft Time Stamping);
    • Конечная система IP-безопасности (IP security end system);
    • Окончание туннеля IP-безопасности (IP security tunnel termination);
    • Пользователь IP-безопасности (IP security user);
    • Шифрованная файловая система (Encrypting File System);
    • Проверяет драйверы аппаратуры Windows (Windows Hardware Driver Verification);
    • Проверяет системные компоненты Windows (Windows. System Component Verification).

Для того чтобы просмотреть сертификат, нажмите кнопку Просмотр (View) в окне Диспетчера сертификатов (Certificate Manager). Будет вызвано стандартное окно с тремя вкладками — Общие (General), Состав (Details), Путь сертификации (Certification Path).

Вкладка Другие пользователи (Other people) в окне Диспетчер сертификатов (Certificate Manager) позволяет посмотреть на сертификаты, выданные другим пользователям. Точнее, на их публичные версии (рис. 10.12).

Рис. 10.12. Окно Диспетчер сертификатов


Мастер импорта сертификатов

Для того чтобы запустить программу Мастер импорта сертификатов (Certificate Manager Import Wizard), нажмите кнопку Импорт (Import), расположенную в окне Диспетчера сертификатов (Certificate Manager). Через несколько мгновений появится окно Мастер импорта сертификатов (Certificate Manager Import Wizard).

В приветственном окне дается краткая информация о том, что такое сертификат, а также о хранилище для сертификатов. Позволю себе привести определения.

Сертификат — подтверждение вашей личности, выданное сертифицирующей организацией. В сертификатах (цифровых подписях) содержится информация, позволяющая защитить данные, либо установить защищенное сетевое соединение.

Хранилище сертификатов — системная зона, в которой находятся сертификаты, листы доверяемых и отвергнутых сертификатов.

Чтобы начать импорт цифровой подписи, нажмите кнопку Далее (Next) (рис. 10.13).

Рис. 10.13. Окно Мастер импорта сертификатов

Здесь вы должны ввести путь к файлу-сертификату. Сделать это можно двумя способами (либо сделать это вручную). Например, если вы помните точный путь. Скажем, C:\cert\certificate.cer. Либо найти импортируемый сертификат при помощи специальной графической оболочки, активизируемой при нажатии кнопки Обзор (Browse). Здесь же даются некоторые замечания.

Более одного сертификата может храниться в одном файле одного из этих стандартов:

  • Personal Information Exchange- PKCS #12 (.PFX);
  • Cryptographic Message Syntax Standard- PKCS #7 Certificates (.p7b);
  • Microsoft Serialized Certificate Store (.sst).

Для продолжения нажмите кнопку Далее (Next). В новом окне вас просят выбрать хранилище для сертификатов:

  • либо автоматически выбрать, основываясь на типе сертификата — Автоматически выбрать хранилище на основе типа сертификата (Automatically select the certificate store based on the type of certificate);
  • либо указать путь вручную — поместить все сертификаты в следующее хранилище (Place all certificates into the following store).

Нажмите кнопку Далее (Next) для продолжения. В новом окне будет дана информация об импорте сертификата. Нажмите кнопку Готово (Finish) и импорт сертификата будет осуществлен.


Мастер экспорта сертификатов

Для того чтобы экспортировать сертификат, выделите его и нажмите кнопку Экспорт (Export) (располагается справа от кнопки Импорт (Import)).

Пройдет несколько секунд и загрузится сама программа (рис. 10.14). Нажмите кнопку Далее (Next) для продолжения.

Рис. 10.14. Окно Мастер экспорта сертификатов

В следующем окне вам будет предложен выбор: экспортировать личный ключ или нет. В случае положительного ответа, вам нужно будет ввести пароль. Итак, выберите переключатель Да, экспортировать закрытый ключ (Yes, export the private key), если вы хотите экспортировать ваш личный ключ. В противном случае — Нет, не экспортировать закрытый ключ (No, do not export the private key). В зависимости от ответа — дальнейший ход экспорта ключа будет различным.

  • При экспорте личного ключа файл будет сохранен в формате PKCS #1.2 (расширение pfx). При желании, вы можете добавить все сертификаты в путь сертификации, если это возможно. Для этого установить флажок

Включить по возможности все сертификаты в путь сертификата (Include all certificates in the certification path if possible). Если на компьютере используется операционная система Microsoft Windows NT 5.0 (Windows 2000), a также обозреватель Internet Explorer версии 5.0 и выше, вы можете ис-пользовать сильную защиту. Для этого установите флажок Включить усиленную защиту (Enable strong protection). В следующем окне вас попросят ввести пароль, используемый в личном ключе. Не забудьте повторить ввод пароля в поле Подтверждение (Confirm Password). Пароль специально представлен в виде звездочек — чтобы никто не смог "подсмотреть" его. Если вы сделали ошибку, воспользуйтесь клавишей <Backspace> для удаления последнего набранного символа. После успешного ввода пароля нажмите кнопку Далее (Next). В новом окне вам предстоит ввести имя для экспортируемого сертификата. По умолчанию файл будет сохранен на рабочем столе. Вы также можете ввести путь к папке самостоятельно, вручную либо при помощи графической оболочки, активизируемой нажатием кнопки Обзор (Browse). Нажмите кнопку Далее (Next). Появившееся окно станет последним. Здесь приведена достаточно детальная информация о сертификате: имя файла, экспортируется ли ключ, формат файла. Для завершения процесса экспорта нажмите кнопку Готово (Finish).

  • Без экспорта личного ключа. В данном случае ключ экспортируется несколько быстрее. Вам нужно всего лишь выбрать формат и подтвердить создание файла экспорта сертификата нажатием кнопки Готово (Finish).


Персональная информация

Ваше время и деньги может сохранить Профиль (Profile Assistant). Дело в том, что в Интернете довольно часто приходится заполнять всевозможные формы (например, при регистрации какой-нибудь услуги). И, в конце концов, это очень сильно надоедает — каждый раз вводить одни и те же данные. В этом случае вам может пригодиться Профиль (Profile Assistant) от корпорации Microsoft. Эта очень удобная программа уже встроена в обозреватель, поэтому никаких дополнительных инсталляций не потребуется.

Чтобы настроить Профиль (Profile Assistant), запустите Microsoft Internet Explorer 6.0. Из меню Сервис (Tools) выберите команду Свойства обозревателя (Internet Options). В появившемся окне выберите вкладку Содержание (Content) и нажмите кнопку Профиль (My Profile). Появится новое окно (рис. 10.15).

Здесь вам предстоит ввести личные данные, которые впоследствии будут использоваться для автозаполнения всевозможных форм. Вы можете вводить данные как на русском языке, так и на английском. Это зависит от того, с каким языком в Интернете вы чаще всего имеете дело.

Рис. 10.15. Окно Главная идентификационная запись — свойства, вкладка Имя


Вкладка Имя

Здесь вам предстоит ввести ваши личные данные, а именно:

  • Имя (First);
  • Отчество (Middle);
  • Фамилия (Last);
  • Должность (Title);
  • Псевдоним (Nickname), Псевдонимы повсеместно используются в Интернете. Вы можете придумать себе какой-нибудь особенный, либо просто написать имя;
  • Отображать (Display) — что именно отображать: Имя, Отчество и фамилию или псевдоним;
  • Адреса электронной почты (E-mail Addresses). Здесь вам предстоит ввести все имеющиеся почтовые интернет-адреса. Для этого в форме Адреса электронной почты (E-mail Addresses) введите один, затем второй и т. д. адреса, не забывая после каждого нажимать кнопку Добавить (Add). Если вы сделали ошибку, воспользуйтесь клавишей <Backspace>. Один из e-mail вы можете установить как адрес по умолчанию. Для этого нажмите кнопку Использовать по умолчанию (Set as Default). Если e-mail изменился или вы сделали ошибку, выделите его и нажмите кнопку Изменить (Edit). В случае если вы решите удалить адрес e-mail из списка, воспользуйтесь кнопкой Удалить (Remove), предварительно выделив нужный.


Вкладка Домашние

Во вкладке Домашние (Ноте) вам предстоит ввести информацию, связанную с вашим домашним адресом, а именно:

  • Адрес (Street Address) — адрес, по которому вы проживаете. Здесь вы должны указать улицу., номер дома, а также номер вашей квартиры. Например, улица Зеленая, дом 3, квартира 87. Порядок может быть другим;
  • Город (City) — город, в котором вы живете, например, Санкт-Петербург;
  • Область, край (State/Province) — Штат/провинция. Вы можете ввести либо город, в котором вы живете, либо область, например, Ленинградская или Московская;
  • Индекс (Zip Code). Например, 125698;
  • Страна, регион (Country/Region). Например, Россия;
  • Телефон (Phone) — ваш телефонный номер. Можно вводить в любом формате. Но рекомендуется в международном: код страны — код города — номер абонента. Например, 7-095-1234567;
  • Факс (Fax);
  • Мобильный (Mobile) — номер мобильного телефона. Так же, как и телефонный номер, рекомендуется вводить в международном формате. Если у вашего сотового телефона федеральный номер, то вводите так: код страны — номер абонента. Например, 7-903-5551111;
  • Веб-страница (Web Page) — адрес домашней веб-страницы.


Вкладка Служебные

В этой вкладке вам предстоит ввести информацию, связанную с вашей работой, бизнесом (рис. 10.16). А именно:

  • Организация (Company) — название компании, фирмы, в которой вы работаете. Например, Microsoft;
  • Адрес (Street Address) — физический адрес фирмы. Здесь вы должны указать улицу, номер дома, а также номер офиса. Например, улица Зеленая, дом 3, офис 87. Порядок может быть другим;
  • Город (City) — город, в котором находится ваша компания;
  • Область, край (State/Province). Вы можете ввести либо город, в котором вы живете, либо область. Например, Ленинградская или Московская;
  • Индекс (Zip Code);
  • Страна, регион (Country/Region) — страна, где физически расположена ваша компания;
  • Должность (Job Title) — ваша должность. Например, менеджер или генеральный директор;
  • Отдел (Department) — отдел, в котором вы работаете;
  • Комната (Office);
  • Телефон (Phone);
  • Факс (Fax);
  • Пейджер (Pager) — номер пейджера. Рекомендуется ввести также номер телефона операторской службы;
  • IP-телефон (Ip Phone) — номер вашего IP телефона;
  • Служебная веб-страница (Web Page) — URL странички предприятия.

Рис. 10.16. Окно Главная идентификационная запись — свойства, вкладка Служебные


Вкладка Личные

В этой вкладке вы можете ввести информацию о вашей семье и детях. А именно:

  • Имя (Name) — имя ребенка. Например, Александр;
  • Пол (Gender): Female или Male, т. е. мужской или женский;
  • День рождения (Birthday). Для того чтобы указать дату рождения, установите флажок День рождения (Birthday);
  • Годовщина (Anniversary).


Вкладка Другие

Во вкладке Другие (Other) вы можете указать дополнительную информацию о себе. Например, о том, что вы любите и что ненавидите. Для этого существует поле Примечания (Notes).


Вкладка NetMeeting

Здесь вы можете указать имя сервера конференции — Сервер конференции (Conferencing Server) и его адрес Адрес конференции (Conferencing Address). Стоит это делать только при том условии, если вы используете программу NetMeeting.


Вкладка Сертификаты

Здесь вы можете указать ваши цифровые удостоверения — сертификаты. О том, как с ними работать, говорилось выше.


Защита информации

Многие веб-узлы могут автоматически запрашивать информацию о вас. Она черпается из созданного профиля. В предыдущих версиях Microsoft Internet Explorer как-то запретить доступ к ней или хотя бы проконтролировать не представлялось возможным.

С выходом Microsoft Internet Explorer 6.0 эта проблема решена. Теперь о запросах веб-сайтов вы можете узнать все:

  • интернет-адрес веб-узла, запрашивающего вашу личную информацию; П какую информацию веб-сайт запрашивает;
  • как эта информация будет использоваться;
  • используется ли безопасное соединение. В случае положительного ответа, вы сможете проверить сертификаты, выданные веб-узлу.


Cookies

Историю возникновения термина cookie или "печенье" никто достоверно не знает. Считается, что во времена зарождения UNIX-подобных операционных систем существовало сочетание Magic Cookies — ими обменивались программы.

Возникновение cookie является решением одной из проблем протокола HTTP — непостоянство соединения между клиентом и веб-сервером. Как, например, при FTP или Telnet сессиях для каждого загружаемого документа посылается отдельный запрос. Итак, с появлением cookies проблема была частично решена.

Работая с cookies, удается эмулировать сессию по протоколу HTTP. Принцип такой: на первом запросе выдается соответствующее значение cookie, a при каждом последующем запросе это значение читается из переменной окружения HTTP_COOKIE и соответствующим образом обрабатывается.

Cookie — небольшая порция текстовой информации, передаваемая сервером браузеру, например Microsoft Internet Explorer. Обозреватель будет хранить эту информацию с каждым запросом как часть HTTP-заголовка. Существует несколько типов cookies. Одни — сессионные, хранятся в течение сессии и при закрытии браузера удаляются. Другие — хранятся установленное время в специальной папке.


Назначение cookies

Сами по себе cookies ничего из себя не представляют. В них содержится обыкновенная текстовая информация. Однако сервер может, считывая определенную информацию из файла cookies, выполнять некие действия. Например, в случае доступа к какому-нибудь ресурсу, требующего авторизации, в файле cookie сохранится имя входа (login) и пароль, что позволит не вводить их .снова и снова при повторном заходе на веб-узел.

Также во многих интернет-магазинах используется механизм работы с cookies. Например, при оформлении заказов.

В Интернете уже достаточно давно существуют ресурсы, которые можно настроить на собственный лад, т. е. изменить порядок вывода информации или, например, настроить цветовую палитру. Опять же для этого используются cookies.

Самая последняя по счету и, скорее, самая первая по распространенности — использование механизма cookies в рекламном бизнесе в Интернете. Например, для таргетинга рекламы — определения целевой аудитории по географическому положению и т. п., отслеживания интересов пользователей, учета количества показов и т. д.


Работа с cookies

Обозреватель Microsoft Internet Explorer 6.0 позволяет работать с cookies. Начиная с 6-й версии браузера, вы имеете возможность изменения настроек приватности, чтобы обозреватель предупреждал вас о приеме cookie. Вы также можете отказаться от приема. Существует опция отключения приема cookies вообще. Правда, это может сильно осложнить работу с веб-узлами, т. к. большинство из них сейчас требует поддержки cookies.

Вы можете использовать настройки приватности в Internet Explorer, чтобы указать браузеру принцип работы с cookies с индивидуальными веб-сайтами, либо со всеми. Вы также можете настроить приватность, импортировав файл, содержащий установки, либо сделав это самостоятельно.

Настройки приватности работают только с зоной Интернета.


Настройка обозревателя для работы с cookies

Запустите обозреватель Microsoft Internet Explorer. Из меню Сервис (Tools) выберите команду .Свойства обозревателя (Internet Options). В появившемся окне выберите вкладку Конфиденциальность (Privacy) (рис. 10.17).

Рис. 10.17. Окно Свойства обозревателя, вкладка Конфиденциальность

Итак, вы видите ползунок, позволяющий довольно быстро изменить настройки приватности. Он имеет 6 положений.

  • Блокировать все "cookie" (Block all cookies). Это самый защищенный режим работы с веб. Просто-напросто все получаемые cookies отвергаются. Уже существующие cookies на вашем компьютере не смогут быть прочитаны веб-узлами.
    • Блокируются файлы "cookie" от любых веб-узлов (Cookies from all Web sites will be blocked).
    • Уже имеющиеся на компьютере "cookie" недоступны для веб-узлов (Existing cookies on your computer cannot be read by Web sites).
  • Высокий (High). Высокий уровень безопасности. В данном режиме отвергаются все cookies, не имеющие компактной политики приватности, а также те, которые используют вашу личную информацию, не спросив вас об этом.
    • Блокируются все "cookie", не удовлетворяющие политике конфиденциальности (Blocks cookies that do not have a compact privacy policy).
    • Блокируются все "cookie", использующие личную информацию без вашего личного согласия (Blocks cookies that use personally identifiable information without your explicit consent).
  • Умеренно высокий (Medium High). В данном режиме все третичные cookies, не имеющие политики приватности, блокируются. Точно также блокируются cookies третичные, использующие вашу персональную информацию, не спросив об этом вас. Аналогичные cookies, полученные от веб-узла, на котором вы сейчас находитесь, отвергаются.
    • Блокируются сторонние "cookie", не удовлетворяющие политике конфиденциальности (Blocks third-party cookies that do not have a compact privacy policy).
    • Блокируются все "cookie", использующие личную информацию без вашего личного согласия (Blocks cookies that use personally identifiable information without your explicit consent).
  • Средний (Medium). Это наиболее универсальный уровень безопасности, позволяющий работать с ресурсами сети эффективно и безопасно. В данном режиме отвергаются третичные cookies, не имеющие политику приватности, а также использующие персональную информацию без вашего согласия. Также первичным cookies запрещено использовать вашу личную информацию без особого разрешения.
    • Блокируются сторонние "cookie", не удовлетворяющие политике конфиденциальности (Blocks third-party cookies that do not have a compact privacy policy).
    • Ограничиваются основные "cookie", использующие личную информацию без вашего явного согласия (Restricts first-party cookies that use personally identifiable information without implicit consent).
  • Низкий (Low). Низкий уровень безопасности. Ограничиваются права третичных cookies, не имеющих политику приватности, а также использующие персональную информацию без вашего согласия.
    • Ограничиваются сторонние "cookie", не удовлетворяющие политике конфиденциальности (Restricts third-party cookies that do not have a compact privacy policy).
    • Ограничиваются основные "cookie", использующие личную информацию без вашего явного согласия (Restricts first-party cookies that use personally identifiable information without implicit consent).
  • Принимать все "cookie" (Accept all cookies). При включении этого режима, все Cookies будут приниматься, а уже существующие смогут быть прочитаны любыми веб-узлами.
    • Сохраняются все файлы "cookie" от любых веб-узлов (All cookies will be saved on this computer).
    • Уже имеющиеся на компьютере "cookie" доступны для создавших их узлов (Existing cookies on this computer can be read by the Web sites that created them).

Нажатие кнопки Дополнительно (Advanced) вызывает окно настройки дополнительных параметров.

Здесь вы можете изменить правила работы с cookies. Для этого сначала нужно установить флажок Перекрыть автоматическую обработку файлов "cookie" (Override automatic cookie handling). Станут доступны Основные "cookie" (First-party Cookies) и Сторонние "cookie" (Third-party Cookies). Итак, вы можете разрешить, запретить или установить режим, когда вас спрашивают перед приемом cookie.

Также установив флажок Всегда разрешать сеансовые "cookie" (Always allow session cookies), вы разрешите обозревателю принимать все сессионные cookies.

Для того чтобы настроить работу с cookies с отдельными веб-сайтами, воспользуйтесь кнопкой Изменить (Edit) в появившемся окне (рис. 10.18)

В поле вы можете ввести адрес веб-узла. В зависимости от того, хотите ли вы блокировать или наоборот разрешить прием cookies с него, нажмите кнопку Блокировать (Block) или Разрешить (Allow).

Чуть ниже представлен лист веб-сайтов, cookies с которых либо блокируются, либо принимаются полностью, вне зависимости от настроек приватности. Если вы решите удалить какой-либо веб-узел из списка, выделите его и

нажмите кнопку Удалить (Remove). При желании удалить весь список целиком, воспользуйтесь кнопкой Удалить все (Remove All).

Рис. 10.18. Окно Конфиденциальность для отдельных веб-узлов


Термины

Первичные cookies — cookies с сайта, который вы сейчас просматриваете.

Третичные cookies — cookies с сайта, отличного от просматриваемого в данный момент. Чаще всего — это баннерные сети.

Многие веб-узлы требуют cookies. При выключении их приема вы, возможно, не сможете работать с такими сайтами.

При изменении настроек приватности установки могут не .повлиять на cookies, уже находящиеся на вашем компьютере. Если вы хотите, чтобы все cookies соответствовали текущему уровню безопасности, предварительно удалите все cookies, имеющиеся на вашем жестком диске.


  • Глава 11. Защита компьютера от несанкционированного доступа
    • Программы-Трояны
    • Борьба
    • Настройка сети
    • Настройки безопасности для определенной зоны
    • Интернет
    • ActiveX
    • Загрузка
    • Java
    • Разное
    • Сценарии
    • Проверка подлинности пользователя
    • Местная интрасеть
    • Узлы
    • Надежные узлы
    • Ограниченные узлы


ГЛАВА 11

Защита компьютера от несанкционированного доступа

Windows 98 — самая распространенная операционная система для домашних персональных компьютеров. Самая распространенная не значит лучшая.

Основной ее проблемой была и остается безопасность. Windows 98 не сильно защищена от хакерских атак, а также не предоставляет достойного программного обеспечения, позволяющего уменьшить или вовсе их прекратить.

Начинающий пользователь может подумать, что атаковать его незачем. На самом деле жертвами таких хакеров как раз становятся только осваивающие компьютер люди. Ведь им проще всего предложить скачать программу, которая, например, сделает бесплатный доступ в Интернет или позволит выиграть в лотерею. Итак, доверчивые пользователи, попадаясь на удочку, загружают обыкновенные троянские программы, которые отправляют их создателям всевозможные данные о компьютере жертвы, а также имена входа (login) и пароли для доступа в Интернет и другую секретную информацию.


Программы-Трояны Виды

Существует несколько типов вирусов, каждый из которых рассчитан на определенную цель — причинить некий урон пользователю. Наиболее распространенные в Интернете — так называемые троянские кони. Это программы, которые под видом того или иного приложения "обосновываются" на вашем компьютере и начинают доставлять информацию о вас своим создателям. Троянские кони (или просто трояны) можно поделить на два типа:

  • Трояны e-mail.
  • Системы удаленного администрирования.

Трояны e-mail до недавнего времени являлись наиболее распространенными. Их действия сводились к банальной краже ваших личных данных и отправке "хозяину". На первый взгляд, это кажется достаточно безобидным. На самом деле это совсем не так. Ведь такой вирус может украсть пароли для доступа к Интернету или определенным "закрытым" ресурсам. И это еще не все. Подобные Трояны могут удалить некоторые системные файлы или даже антивирусы, позволяющие с ними бороться. Такие вирусы посылают данные чаще всего по e-mail, иногда через ICQ, не видны в окне завершения работы программы. Таким образом, они практически невидимы для начинающего пользователя. Чаще всего программы такого рода крадут пароли. Вот почему крайне не рекомендуется сохранять их, например, при доступе в сеть.

Системы удаленного администрирования — это относительно новый вид троянских коней. Это новое название. Они позволяют полноценно управлять компьютером под управлением операционной системы Windows. Например, перезагрузить компьютер или посмотреть и по возможности скачать содержимое винчестера, наблюдать за тем, что делает пользователь в данный момент. Правда здесь есть некоторые ограничения. Например, жертва и хакер должны одновременно находиться в сети. Иначе у хакера просто не будет возможности что-то сделать с компьютером жертвы. Как и везде, технический прогресс и здесь налицо. Если ранее, для того чтобы подсоединиться к жертве нужно было знать ее IP-адрес, что было крайне сложно для хакера, при условии что жертва подключается к Интернету через телефонную линию, с помощью модема, то теперь этого уже не требуется. При таком подключении IP в 90% случаев динамический, т. е. меняется от сессии к сессии. И для того чтобы и эта проблема была решена, были придуманы новые алгоритмы работы. Например, теперь многие такие Трояны посылают e-mail или ICQ сообщения хакерам тогда, когда жертва оказывается online, указывая ее IP-адрес. И для пославшего Троян не составит труда подключиться к компьютеру жертвы.


Борьба

Как известно, болезнь лучше пресечь на стадии зарождения. Аналогично и с программами -троянцами.

Итак, первый и главный совет — не загружайте файлы сомнительного содержания. В особенности, имеющие расширения exe, vbs, scr, pif, com и некоторые другие. Понять, есть ли вирус или нет, удаленно нельзя. Поэтому, если вы уже загрузили файл, обязательно проверьте его антивирусной программой. Не забывайте обновлять вирусную базу. Скачивайте файлы только с известных, проверенных сайтов типа download.com. Чаще всего в программах, расположенных на серверах бесплатного хостинга, типа Narod.ru имеются вирусы. Поэтому их загрузка и последующее использование также крайне нежелательны. Не всегда верьте тому, что написано ("на заборе тоже написано"). Так, если на каком-нибудь сайте вы увидите программу, которая позволит пожизненно бесплатно пользоваться Интернетом или разговаривать по межгороду, или, например, генератор работающих карточек экспресс-оплаты чего-либо — не верьте. Такого просто не может быть. Поэтому напрашивается единственно правильный вывод — это не что иное, как вирус. Вы используете систему обмена короткими сообщениями, типа ICQ, и вдруг незнакомая девушка (молодой человек) предлагает вам получить ее фотографию, причем имеющую какое-то странное расширение. Например, ехе. Вы, естественно, спрашиваете, почему оно такое. Вам могут доходчиво объяснить причину, которая сначала покажется достаточно реальной. Уверяю, вас обманывают и хотят передать вам вирус.

Кстати, не забывайте, что не все вирусы такие "безобидные". Существует огромное количество таких, которые могут отформатировать вам винчестер или просто сделать его непригодным для использования. Поэтому обязательно используйте антивирусы.

Но, что если вы все-таки загрузили и запустили программу, которая оказалась троянским вирусом, вы можете от нее избавиться достаточно легко. Наиболее простой и действенный способ — использовать антивирус. Если же он отсутствует, можно поступить следующим образом. Выберите в меню кнопки Пуск команду Выполнить. В появившейся форме наберите msconfig. Загрузится программа настройки системы (рис. 11.1).

Рис. 11.1. Окно Программа настройки системы

Дело в том, что большинство троянцев автоматически загружаются с Windows. Соответственно, они прописываются либо в реестре, либо в System.ini, либо в автозагрузке через стартовое меню. Так делает большинство, но существуют более умные программы, которые представленным ниже методом удалить нельзя.

Итак, программа настройки системы позволяет посмотреть на те приложения, которые загружаются вместе с Windows. Для этого нужно выбрать вкладку Автозагрузка. У приложений, запускаемых с Windows, установлен флажок в специальном поле. Но как же понять, какая программа вирус? Очень просто, посмотрите на путь к ней (если он не указан, значит она находится в папке WINDOWS, SYSTEM или SYSTEM32). Программа-Троян может иметь странное название типа Windos или, например, internut. Далее попробуйте найти ее и посмотреть на свойства. Иногда принадлежность к Трояну можно определить по дате создания файла. Также, если вы будете раз-два в неделю просматривать лист загружаемых вместе с Windows приложений, вы обязательно заметите новое, вызывающее подозрение.


Настройка сети

К сожалению, программы-Трояны это еще не предел. Дело в том, что в операционную систему Windows встроена возможность открытия для доступа посторонних лиц жестких дисков компьютера, определенных папок. По статистике "открытых" компьютеров больше в локальных сетях. Итак, вы, наверное, знаете, как сделать доступной определенную папку. Существует также вариант с парольной защитой. Теоретически,* пароль должно быть очень сложно сломать. На самом деле это далеко не так. Около года назад был обнаружен серьезный дефект в защите операционной системы Windows. от атак на локальный компьютер. Итак, если у вас есть открытые ресурсы, даже защищенные паролем, знайте, что сломать его сможет даже ребенок чуть-чуть разбирающийся в компьютерах. Но обо всем по порядку.

Предположим, у вас открыт диск С: (на нем практически всегда установлена операционная система). Но открыт он только для "избранных", знающих пароль. Так вот оказывается", что практически любой желающий сможет "покопаться" у вас на винчестере. "Как?" - удивленно воскликните вы. Очень просто. В теории взломать пароль можно только долгим перебором символов. Например, пароль из 6 символов можно сломать на современной машине за достаточно большой промежуток времени. Но оказалось, что пароль можно подобрать побуквенно. Например, вы задали пароль "Explorer". Хакер попытается его взломать. Первый минус для вас и плюс для хакера: в паролях нет разницы между ЗАГЛАВНЫМИ и строчными буквами. Тем самым задача существенно упрощается для взломщика. Далее, пароль Windows можно сломать банальным перебором. Причем, не целого слова, а по буквам. Например, сначала будет разгадана первая — е, потом вторая х и так до конца. Уже существуют программы, делающие это автоматически. Причем занимает это всего несколько минут, если не секунд.

Итак, напрашивается вывод: не стоит доверять Windows свои секреты, не открывайте для свободного доступа диски и папки.

Как проверить? Во-первых, запустите в Панели управления утилиту Сеть. В данном окне (рис. 11.2) можно задать специфические параметры соединения, используемые протоколы, а также разрешить или запретить доступ к файлам и принтерами.

Рис. 11.2. Окно Сеть

Для этого нажмите кнопку Доступ к файлам и принтерам. В появившемся окне снимите флажки в обоих полях. Тем самым доступ к файлам и принтерам будет отключен. Далее, чтобы полностью обезопасить себя, удалите все компоненты, установленные в системе, кроме TCP/IP и контроллера удаленного доступа. Также в свойствах соединения нужно отключить вход в сеть.


Настройки безопасности для определенной зоны

Выше было рассмотрено, как можно обезопасить себя от хакеров-непрофессионалов, использующих общеизвестные ошибки Windows, а также неопытность пользователей. Но существуют более умные хакеры, которые встраивают специальные элементы в веб-страницы, позволяющие тем или иным образом получить доступ к вашему компьютеру. К сожалению, каждый раз просматривать веб-сайты на подозрительное содержимое каждый раз не представляется возможным. Поэтому была придумана специальная система, позволяющая вполне обезопасить себя — система зон. Смысл в том, что в зависимости от зоны уровень безопасности различен.

Итак, запустите Microsoft Internet Explorer 6.0. Выберите команду Свойства обозревателя (Internet Options) из меню Сервис (Tools). Далее выберите вкладку Безопасность (Security).


Интернет

Итак, по умолчанию задан средний уровень безопасности: безопасный брау-зинг и функциональность, запросы перед загрузкой непроверенного содержимого, неподписанные элементы ActiveX не будут загружаться. Это подходит для 80 процентов пользователей. Но, возможно, на некоторых сайтах может что-то не функционировать. Поэтому, если такое происходит, выберите уровень Ниже среднего (Low): минимальный уровень защиты, большинство файлов и компонентов загружаются без подтверждения. Выбор осуществляется при помощи ползунка. Чем он выше, тем ваша защищенность больше. Вы также можете настроить уровень безопасности под ваши личные требования. Учтите, это рассчитано на более подготовленного пользователя. Для этого выберите Другой (Custom level). В новом окне (рис. 11.3) вы уже вручную можете указать, что может работать, а что нет.


ActiveX

  • Выполнять сценарии элементов ActiveX, помеченных как безопасные (Download signed ActiveX controls) — загружать подписанные элементы ActiveX. Вы можете:
    • Отключить (Disable) — отключить загрузку компонентов;
    • Разрешить (Enable) — разрешить загрузку компонентов без дополнительных вопросов (диалоговых окон);
    • Предлагать (Prompt) — спрашивать каждый раз перед загрузкой. Наиболее рекомендована последняя опция.

Рис. 11.3. Окно Параметры безопасности

  • Загрузка неподписанных элементов ActiveX (Download unsigned ActiveX controls) — загружать неподписанные компоненты. Вообще это крайне не рекомендовано.
  • Использование элементов ActiveX, не помеченных как безопасные (Initialize and script ActiveX not marked as safe) — инициализировать и запускать элементы управления ActiveX, не подписанные как безопасные. В данном случае, многие компоненты могут не запускаться.
  • Запуск элементов ActiveX и модулей подключения (Run ActiveX controls and plug-ins) — запускать элементы управления ActiveX и плагины. По умолчанию, эта функция включена. Иначе, при ее выключении, вы, например, не сможете просмотреть видео прямо в браузере. Также вы можете указать опцию Одобрен администратором (Administrator approved) — если компонент, плагин одобрен администратором, то загружаться он будет, иначе — нет.
  • Использование элементов ActiveX, помеченных как безопасные (Script ActiveX controls marked safe for scripting) — выполнять элементы управления ActiveX, помеченные как безопасные. Лучше, чтобы это было включено.


Загрузка

  • Загрузка файла (File download) — загрузка файлов. Если будет установлено Disable — ни один файл из Интернета загружен не будет.
  • Загрузка шрифта (Font download) — загрузка шрифтов. На данный момент это еще не полностью реализовано. В теории, если шрифта, указанного на веб-странице у вас нет, то он будет загружен. Рекомендовано установить опцию Prompt, т. е. спрашивать о загрузке шрифта при каждой загрузке.


Java

  • Разрешение Java — по умолчанию стоит высокая безопасность. Стоит это так и оставить.


Разное

  • Достун к источникам данных за пределами домена (Allow МЕТА REFRESH) — разрешить МЕТА REFRESH. Включите эту функцию.
  • Отображать смешанное содержимое (Display mixed content) -- например, содержимое, получаемое через безопасное и небезопасное соединение. Если вы хотите, чтобы смешанное содержимое отображалось автоматически, без лишних вопросов установите Enable.
  • Перетаскивание или копирование и вставка файлов (Drag and drop or copy and paste files) — использовать механизм drag-and-drop или копировать и вставлять файлы. Скорее всего, это может понадобится, поэтому рекомендуется активизировать данную функцию.
  • Установка элементов рабочего стола (Installation of desktop items) — установка объектов Рабочего стола. Имеется в виду стол Active Desktop (активный рабочий стол). Разрешите загрузку и установку без предварительных вопросов.
  • Запуск программ и файлов в окне IFRAME (Launching programs and files in an IFRAME) — рекомендуется установить запрос перед запуском.
  • Переход между кадрами через разные домены (Navigate sub-frames across different domains) — просматривать страницы, расположенные в других доменах во фреймах. Если данный пункт активизирован, вы сможете работать с веб-страницами, использующими фреймы для ссылок на другие ресурсы.
  • Передача незашифрованных данных форм (Submit nonencrypted form data) — отсылать данные через небезопасное соединение. По умолчанию, каждый раз при отправке таких данных перед вами будет появляться диалоговое окно, в котором спрашивается Данные передаются по небезопасному соединению, ОК?. В случае положительного ответа — информация будет передана. К сожалению, в большинстве случаев используется именно такое соединение, и теоретически ваши личные данные могут стать доступными другим лицам. Вся проблема в протоколе передачи данных, который автоматически передает их напрямую, т. е. незашифрованно. При использовании специальных программ — снифферов, они могут быть спокойно перехвачены. Об этом подробнее написано в приложении.


Сценарии

Чаще всего используется для более удобной, интерактивной работы с формами. Поэтому по умолчанию все опции включены.

  • Активные сценарии (Active scripting) — включено по умолчанию.
  • Разрешить операции вставки из сценария (Allow paste operations via script) — разрешить вставку данных скриптом. По умолчанию включено.
  • Выполнять сценарии приложений Java (Scripting of Java applets) — скриптование Java-апплетов. Также стоит активизировать.


Проверка подлинности пользователя

Logon-подключение:

  • Анонимный вход (Anonymous logon) — подключение без имени пользователя и пароля — анонимное.
  • Автоматический вход в сеть только в зоне интрасети (Automatic logon only in Intranet zone) — автоматическое подключение только в локальной сети. Эта опция активизирована по умолчанию.
  • Автоматический вход в сеть с текущим именем пользователя и паролем (Automatic logon with current username and password) — автоматическое подключение с именем входа (login) и паролем текущей сессии.
  • Запрос имени пользователя и пароля (Prompt for user name and password) — спрашивать имя входа (login) и пароль. Если не только вы работаете за компьютером — целесообразно активизировать.

В окне Правила безопасности (Security settings) есть кнопка Восстановить (Reset), которая позволяет вернуться к настройкам по умолчанию. Для этого с помощью раскрывающегося меню выберите уровень безопасности, например Средний (Medium), и нажмите кнопку Возобновить (Reset). В появившемся диалоговом окне вам будет предложено согласиться или отказаться от текущих действий.


Местная интрасеть

Для установки параметров работы в локальной сети выберите значок Местная интрасеть (Local intranet). Итак, по умолчанию уровень безопасности стоит Ниже среднего (Medium-low), что ниже чем в Интернете. Это и понятно, в локальной сети сложнее "подцепить" вирус, а если даже такое произойдет, не так уж сложно будет найти виновника.


Узлы

Вы можете задать сайты, которые находятся в вашей локальной сети. Для этого нажмите кнопку Узлы (Sites).

Как видно из рис. 11.4, все флажки установлены. А если флажок установлен, то, значит, функция активизирована.

Рис. 11.4. Окно Местная интрасеть

  • Все узлы интрасети, не перечисленные в других зонах (Include all local sites not listed in other zones) — если флажок установлен, все сайты, выделенные вашим системным администратором как локальные, будут иметь настройки безопасности не как для интернет-сайтов.
  • Все узлы, подключаемые минуя прокси-сервер (Include all sites that bypass the proxy server) — включать все сайты, доступ к которым осуществляется без прокси-сервера.
  • Все сетевые пути (UNC) (Include all network paths) — включать все сетевые адреса (в локальной сети).

Для того чтобы включить сайты в эту зону безопасности, нажмите кнопку Дополнительно (Advanced). Появится окно, в котором вы вручную можете вводить URL веб-серверов. Если установлен флажок Для всех узлов этой зоны требуется проверка серверов (require server verification for all sites in this zone), то перед тем как подключиться к веб-узлу, будет осуществлена попытка проверить его безопасность.


Надежные узлы

Здесь указаны сайты, которым вы доверяете. Соответственно настройки безопасности могут быть самыми низкими. Для того чтобы добавить веб-узел в данную группу, нажмите кнопку Узлы (Sites) (рис. 11.5).

В специальной форме наберите его адрес. Причем он должен начинаться с https — защищенная версия протокола HTTP. He все веб-сайты могут ра-

ботать в данном режиме. И нажмите кнопку Добавить (Add). Для того чтобы удалить сайт из группы, выделите его и нажмите кнопку Удалить (Remove).

Рис. 11.5. Окно Надежные узлы


Ограниченные узлы

В данной группе стоит указывать сайты, которые вызывают опасения. Например, из-за небезопасного содержания или еще по какой-либо причине.

Чтобы добавить веб-узел в эту группу, достаточно воспользоваться специальной формой, вызываемой нажатием кнопки Узлы (Sites).


  • Глава 12. Ограничение доступа к нежелательным для просмотра ресурсам
    • Общая информация о системах рейтинга содержимого
    • Что такое ICRA?
    • Система RSACi
    • Использование RSACi и ICRA
    • Настройка системы рейтинга сайтов
    • Элементы ICRA
    • Особенности ICRA


ГЛАВА 12

Ограничение доступа к нежелательным для просмотра ресурсам

У вас есть дети или, может быть, вы хотите ограничить доступ ваших подчиненных к некоторым ресурсам? Если ответ положительный, то вам стоит внимательно прочитать эту главу.

Итак, ранее не существовало возможности ограничить доступ детей к определенным сайтам. Были- созданы некоторые программы, но, к сожалению, работали они очень неэффективно. С недавних пор в Microsoft Internet Explorer встроена рейтинговая система, позволяющая запретить доступ к ресурсам, несанкционированным вами для просмотра.

Интернет предоставляет возможность доступа к огромному количеству ресурсов. Некоторая информация может не подходить, быть опасной для пользователя. Например, вы можете захотеть ограничить доступ вашим детям к сайтам, содержащим элементы насилия.

Программа Ограничение доступа (Content Advisor) предоставляет вам эту возможность. После включения программы только рейтинговые сайты, подходящие под ваши требования, могут быть просмотрены.

С ее помощью вы можете:

  • контролировать доступ к настройкам программы. Вы включаете Ограничение доступа (Content Advisor) и просматриваете установки при помощи пароля. Вам нужен пароль, чтобы в любое удобное для вас время изменить установки;
  • просматривать и устанавливать настройки просмотра для того, что вы считаете достойным просмотра;
  • устанавливать типы содержимого, которое пользователи компьютера смогут просматривать без вашего разрешения;
  • создать список веб-сайтов, которые другие люди никогда не смогут просмотреть вне зависимости от их рейтинга;
  • создать список веб-узлов, разрешенных для просмотра вне зависимости от их содержания;
  • просматривать и изменять системы рейтинга.

Для начала, давайте разберемся в том, что из себя представляет эта система. Итак, при установке параметров отображения тех или иных страниц (о том, как это сделать, написано ниже), будет производиться запрос в ICRA. В случае, если сайт подходит под указанные рамки, он будет загружен. Иначе — нет.


Общая информация о системах рейтинга содержимого

Что такое ICRA?

ICRA — Internet Content Rating Association или Ассоциация рейтинга содержимого Интернета (дословный перевод). Она независима, некоммерческая. Была основана весной 1999 года группой ведущих мировых интернет-компаний и ассоциаций. Цель ICRA — разработать, внедрить и управлять международными системами рейтинга информации, позволяющими пользователям по всему миру ограничить доступ к сайтам, содержимое которых может нанести моральный урон, в особенности детям.

Система рейтинга сайтов ICRA была построена на базе уже существующей RSACi, является результатом усилий многих мировых компаний.


Система RSACi

RSACi — The Recreational Software Advisory Council (Региональный консультативный совет по программам). RSAC была первой независимой, некоммерческой организацией. Ее целью было информировать публику, в особенности родителей, для того чтобы они принимали правильные решения в области медиа-ресурсов по средствам открытой, объективной системы контроля содержимого. Система RSACi предоставляла пользователям информацию о количестве секса, насилия, грубого языка на веб-сайтах. Система была встроена в обозреватель Microsoft Internet Explorer и еще некоторые другие.


Использование RSACi и ICRA

В браузер Microsoft Internet Explorer система RSACi встроена по умолчанию. Но новая система пока не устанавливается по умолчанию. Ее нужно установить. Для этого требуется скачать файл, находящийся по адресу http:// www.rsac.org/_en/support/icra.rat. Далее сохраните его в папке SYSTEM (C:\WINDOWS\SYSTEM).

Для того чтобы установить новый файл rat, выберите из меню Сервис (Tools) команду Свойства обозревателя (Internet Options). Выберите вкладку Содержание (Content) (рис. 12.1).

Рис. 12.1. Окно Свойства обозревателя, вкладка Содержание

Нажмите кнопку Включить (Enable). Загрузится новое окно (рис. 12.2).

Проигнорируйте настройку этих параметров — просто нажмите кнопку ОК. Вам будет предложено ввести пароль.

Пароль должен быть легко запоминаем для вас и в тоже время ваши дети, сотрудники не должны его угадать.

Компании ICRA и Microsoft постоянно получают письма от пользователей, потерявших пароль. ICRA, как и Microsoft, не могут вам помочь в данной ситуации. Поэтому будьте крайне внимательны при вводе пароля. После того как он введен, нажмите кнопку ОК.

Нажмите кнопку Настройка (Settings). Выберите вкладку Общие (General). Внизу окна есть кнопка Системы оценок (Rating Systems). Нажатие ее вызовет следующее окно (рис. 12.3).

Рис. 12.2. Окно Ограничение доступа

Рис. 12.3. Окно Системы оценок

Нажмите кнопку Добавить (Add). Выберите файл ICRA.rat и нажмите кнопку Открыть (Open) в окне Открытие файла системы оценок. ICRA будет находиться в меню. Теперь нажмите кнопку ОК, чтобы закрыть окно. Обновление системы рейтинга было произведено успешно, и теперь вы можете перейти к следующей стадии установки.


Настройка системы рейтинга сайтов

В данном разделе мы разберемся в том, как работать с Content Advisor.

  • Если окно Ограничение доступа (Content Advisor) еще не открыто, выберите из меню Сервис (Tools) пункт Свойства обозревателя (Internet Options) и вкладку Содержание (Content).
  • Во вкладке Содержание (Content) выберите кнопку Настройка (Settings). О Введите ваш пароль и нажмите кнопку ОК.
  • Выберите вкладку Оценки (Ratings), где вы увидите установленные элементы ICRA.


Элементы ICRA

  • Chat (Чат)
    • Chat (Чат)
    • Chat — Only moderated and suitable for children or teens (Чат — только модерируемый, подходящий для детей)
  • Language (Язык)
    • Language — Crude words or profanity (Язык — Жестокие слова)
    • Language — Explicit sexual language (Язык — Употребление сексуальной лексики)
    • Language — Mild exoletives (Язык — Жаргон)
  • Nudity & Sexual Material (Обнаженность и Сексуальный материал)
    • Nudity & Sexual Material — Bare buttocks (Обнаженность и Сексуальный материал — Голые ягодицы)
    • Nudity & Sexual Material — Context Variable — Artistic (Обнаженность и Сексуальный материал — Художественный)
    • Nudity & Sexual Material - Context Variable — Educational (Обнаженность и Сексуальный материал — Образовательный)
    • Nudity & Sexual Material — Context Variable — Medical (Обнаженность и Сексуальный материал — Медицинский)
    • Nudity & Sexual Material — Erections or female genitals in detail (Обнаженность и Сексуальный материал — Эрекция или органы гениталий в деталях)
    • Nudity & Sexual Material — Explicit sexual acts (Обнаженность и Сексуальный материал — Половые акты)
    • Nudity & Sexual Material — Female breasts (Обнаженность и Сексуальный материал — Женские груди)
    • Nudity & Sexual Material — Female genitals (Обнаженность и Сексуальный материал — Женские половые органы)
    • Nudity & Sexual Material — Male genitals (Обнаженность и Сексуальный материал — Мужские половые органы)
    • Nudity & Sexual Material - Obscured or implied sexual acts (Обнаженность и Сексуальный материал - Затененные или подразумеваемые половые акты)
    • Nudity & Sexual Material — Passionate kissing (Обнаженность и Сексуальный материал — Чувственные поцелуи)
    • Nudity & Sexual Material - Visible sexual touching (Обнаженность и Сексуальный материал — Сексуальные поглаживания)
    • Other topics (Другие темы)
    • Otber topics — Gambling (Другие темы — Азартные игры)
    • Other topics — Material that might be perceived as setting a bad example for young children (Другие темы -- Материал, который может быть воспринят как плохой пример для маленьких детей)
    • Other topics — Material that might disturb young children (Другие темы -Материал, который может расстроить маленьких детей)
    • Other topics — Promotion of alcohol use (Другие темы -- Поощрение употребления алкоголя)
    • Other topics — Promotion of discrimination or harm against people (Другие темы — Поощрение дискриминации или причинения ущерба людям)
    • Other topics — Promotion of drug use (Другие темы — Поощрение употребления наркотиков)
    • Other topics — Promotion of tobacco use (Другие темы — Поощрение курения)
    • Other topics — Promotion of weapon use (Другие темы -- Поощрение применения атомного оружия) Violence (Насилие)
    • Violence — Blood and gore, animals (Насилие — Кровь и битвы, животные)
    • Violence — Blood and gore, fantasy characters (including animation) (Насилие — Кровь и битвы, фэнтезийные персонажи (включаю анимацию))
    • Violence — Blood and gore, human beings (Насилие — Кровь и битвы, люди)
    • Violence — Context Variable — Artistic (Насилие — Различные ситуации — Художественный)
    • Violence — Context Variable — Educational (Насилие — Различные ситуации — Образовательный)
    • Violence — Context Variable — Medical (Насилие — Различные ситуации — Медицинский)
    • Violence — Context Variable — Sports (Насилие — Различные ситуации — Спортивный)
    • Violence — Deliberate injury to animals (Насилие — Сильные увечья животных)
    • Violence - Deliberate injury to fantasy characters (including animation) (Насилие — Сильные увечья у фэнтезийных персонажей (включая анимацию))
    • Violence — Deliberate injury to human beings (Насилие — Сильные увечья у людей)
    • Violence — Killing of animals (Насилие — Убийство животных)
    • Violence — Killing of fantasy characters (including animation Violence -Killing of human beings) (Насилие — Убийство фэнтезийных персонажей (включая насилие в анимации — убийство людей))
    • Violence — Sexual violence/rape (Насилие — Сексуальное насилие/изнасилование)

Итак, выбрав один из элементов, переместите ползунок вправо для того, чтобы включить фильтрацию.

Внимательно читайте текст в поле Описание (Description). Это может помочь вам сэкономить много времени.

Будущие версии смогут разрешить доступ, например, к картинам, таким как "Рождение Венеры" Ботичелли, даже если там присутствуют обнаженные части тела. Для того чтобы активизировать фильтрацию определенного содержимого, передвиньте ползунок вправо.

Итак, во вкладке Оценки (Ratings) вы можете указать, какой материал стоит отображать на веб-страницах, а какой нет. Как уже было сказано выше, не все сайты поддерживают данный механизм. Поэтому может случиться так, что ваш ребенок получит доступ к такому ресурсу, которому вы бы не хотели. Поэтому существует данная опция — просмотр сайтов, не имеющих рейтинга. При установленном флажке пользователи смогут просматривать веб-узлы без рейтинга. А при снятом флажке доступ будет запрещен. К сожалению, не все солидные, нормальные ресурсы поддерживают систему рейтинга. Вот почему некоторые ресурсы могут стать просто недоступными. Следовательно, вам решать — полностью ограничить ребенка, либо нет.

Именно во вкладке Общие (General) есть это поле. Если вы часто находитесь рядом с компьютером, во время того, как ваш ребенок, подчиненный работает на нем, то вы можете установить флажок Разрешить ввод пароля для просмотра запрещенных узлов (Supervisor can type a password to allow users to view restricted content). Тем самым при запросе какого-либо недоступного ресурса, будет предложен ввод пароля. При правильном пароле доступ будет открыт.

Если вы вдруг решите изменить пароль, воспользуйтесь специальной кнопкой Смена пароля (Change Password), которая вызовет окно изменения пароля (рис. 12.4). В самой верхней части окна расположена подсказка, созданная вами и позволяющая вспомнить пароль. В поле Старый пароль (Old password) введите текущий пароль. В поле Новый пароль (New Password) требуется ввести новый пароль, ввод которого позволит получить доступ к настройке системы. Не забудьте подтвердить его в поле Подтверждение (Confirm new password). В небольшом текстовом поле, расположенном чуть выше кнопок ОК и Отмена (Cancel), вы можете указать секретный вопрос, который поможет вам вспомнить пароль. И помните, что ваш ребенок не должен угадать его.

Рис. 12.4. Окно Изменение пароля-допуска

Во вкладке Разрешенные узлы (Approved Sites) вы можете указать веб-сайты, доступ к которым всегда разрешен или всегда запрещен, вне зависимости от их рейтинга. Сделать это очень просто. Для начала в первой строке (расположена после слов Разрешать просмотр следующего узла (Allow this Web site) введите URL веб-страницы. Например, http://ww.microsoft.com . Далее, если вы хотите всегда разрешать доступ к ресурсу, нажмите кнопку Всегда (Always). В противном случае — кнопку Никогда (Never). Сайт будет помещен в-список, расположенный чуть ниже. При желании удалить страницу из списка — выделите ее и нажмите кнопку Удалить (Remove).


Особенности ICRA

Представьте себе такую ситуацию — вы нашли веб-сайт, метка, рейтинг, которого отсутствует, а содержимое его может причинить вред. Вы задаетесь вопросом: "Как же такое могло произойти?". Ответ прост. Дело в том, что The Internet Content Rating Association не рейтингует сайты (!). Авторы, создатели веб-ресурсов используют систему ICRA для оценки собственных сайтов. ICRA — не цензор, не делает никаких выводов, заключений по сайтам. Система позволяет авторам добавлять объективные метки на сайты, которые говорят об их содержимом. Вследствие того, что установка метки — дело добровольное, она есть не на всех интернет-ресурсах.


  • ЧАСТЬ IV. MICROSOFT OUTLOOK EXPRESS
    • Глава 13. Первое знакомство с Microsoft Outlook Express
      • Создание учетных записей
      • Протокол РОРЗ
      • Протокол IMAP
      • Работа с сервером
      • Настройка программы для корректной работы
      • Работа с почтой
      • Окно Outlook Express
      • Входящие сообщения
      • Блокировка нежелательных сообщений (спам)


Часть IV.

Microsoft Outlook Express

  • Глава 13. Первое знакомство с Microsoft Outlook Express
  • Глава 14. Создание и отправка почтовых сообщений
  • Глава 15. Работа с группами новостей
  • Глава 16. Автономная работа
  • Глава 17. Настройка
  • Глава 18. Выбор оптимальной конфигурации Microsoft Outlook Express


ГЛАВА 13.

Первое знакомство с Microsoft Outlook Express

Microsoft Outlook Express - программа для отправки сообщений e-mail. Она поставляется вместе с Microsoft Internet Explorer 6.0. Outlook Express является одним из лучших почтовых клиентов. И это неспроста. Программа обладает практически неограниченными возможностями для работы с сообщениями e-mail.


Создание учетных записей

Протокол РОРЗ

Для начала запустите программу Microsoft Outlook Express. Это можно сделать из меню быстрого доступа (расположено справа от кнопки Пуск), либо из самого меню Пуск выберите Outlook Express. После загрузки программы появится Мастер подключения к Интернету (Internet Connection Wizard).

Итак, сначала вам нужно ввести ваше имя и фамилию. Сделать это можно в специальной форме (рис. 13.1). Нажмите кнопку Далее (Next). В следующем окне вы сможете ввести ваш адрес e-mail. Например, ваше_имя@сайт.ру. Стоит учитывать, что ящик у вас уже должен иметься. Чаще всего он предоставляется вашим интернет-провайдером. Либо вы можете его создать на одном из серверов — Mail.ru, Pochtamt.ru и др. После ввода адреса e-mail нажмите кнопку Далее (Next). В новом окне (рис. 13.2) вам будет предложено ввести адреса серверов исходящей и входящей почты, а также протоколы работы с ними.

Для начала выберите протокол работы с сервером входящей почты — РОРЗ, ШАР или HTTP. Наиболее распространенные, поддерживаемые практически всеми почтовыми серверами на Земле, — РОРЗ. Если протокол работы не указан — значит это РОРЗ.

Рис. 13.1. Окно Мастер подключения к Интернету

Рис. 13.2. Окно Мастер подключения к Интернету: указание серверов входящей и исходящей почты

В поле Сервер исходящих сообщений (Outgoing mail server) укажите адрес SMTP-сервера вашего интернет-провайдера. Именно через него отправляемые вами почтовые сообщения будут доставляться. Наиболее рекомендуемый — сервер вашего интернет-провайдера. В этом случае скорость отправки e-mail будет наибольшей. Нажмите кнопку Далее (Next) для- продолжения работы с мастером создания учетных записей.

В следующем окне вам будет предложено ввести имя пользователя и пароль. Если вы не желаете каждый раз при получении и отправке почты вводить пароль, установите флажок Запомнить пароль (Remember password). Microsoft Outlook Express 6.0 поддерживает технологию SPA — Secure Password Authentication. Поэтому, если ваш провайдер требует безопасной проверки пароля, установите флажок Использовать безопасную проверку пароля (Log on using Secure Password Authentication (SPA)). Нажмите кнопку Далее (Next) для продолжения.

Финальным шагом создания учетной записи является окно с поздравлениями. В нем вам сообщают о том, что вся необходимая информация для создания учетной записи введена. Для подтверждения и сохранения введенных сведений нажмите кнопку Готово (Finish). He стоит забывать, что при желании отменить создание, вы в любое время можете нажать на кнопку Отмена (Cancel).


Протокол IMAP

Часто вы тратите много времени и денег на прием почты, а в результате нужных сообщений оказывается минимум, остальное — спам (рекламные письма). А иногда связь просто рвется и загрузку сообщений приходится повторять заново.

Microsoft Outlook Express дает возможность работы с относительно новым протоколом приема электронных писем — ШАР. Удобство его использования очевидно. Вместо того чтобы загружать все письма с сервера, вы загружаете только их заголовки. А затем, выборочно, получаете нужную почту. Остальную удаляете прямо с сервера, не загружая к вам на компьютер. Таким образом, вы экономите не только время, но и деньги.

Ваш почтовый сервер должен поддерживать работу по этому протоколу. Для начала работы с почтовым ящиком, нужно создать учетные записи.

Запустите программу Microsoft Outlook Express. В меню Сервис (Tools) выберите команду Учетные записи (Accounts). В появившемся окне выберите Почта | Добавить (Add | Mail).

Появится Мастер подключения к Интернету (Internet Connection Wizard). В специальной форме введите ваше имя и фамилию, желательно латинскими буквами. Для продолжения нажмите кнопку Далее (Next).

В новом окне введите ваш адрес электронной почты. Например, ilya@pop3.ru. Нажмите кнопку Далее (Next) для продолжения.

В новом окне вам предстоит указать серверы для работы с входящей и исходящей почтой. Не забудьте указать протокол работы — ШАР. После этого нажмите кнопку Далее (Next).

В появившемся окне (рис. 13.3) вам будет предложено ввести имя пользователя и пароль для работы с сервером.

Настройка учетной записи закончена.

Рис. 13.3. Окно Мастер подключения к Интернету: ввод имени пользователи и пароля


Работа с сервером

В списке папок появилась новая — pop3.ru (1) (рис. 13.4).

Для начала работы с сервером вам потребуется перейти в эту папку. Для этого достаточно щелкнуть по ней. Через несколько мгновений появится диалоговое окно Загрузить папки с добавленного почтового сервера? (There are not any folders to show for this account. Would you like to view a list of available folders now). Нажмите кнопку Да (Yes) для загрузки списка папок с сервера (вы должны быть подключены к Интернету).

Появится окно статуса (рис. 13.5), в котором будет выводиться информация о том, что сейчас делает программа. Например, загружает список папок или соединяется с сервером.

Рис. 13.4. Список папок

Рис. 13.5. Окно Загрузка папок из pop3.ru (1)

Через несколько секунд список папок будет загружен, и появится следующее окно — Отображение и скрытие папок IMAP

По умолчанию папки Sent и Trash, имеющиеся на сервере, не показываются. Правда, если вы хотите изменить порядок отображения, нажмите кнопку Отобразить (Show) или Скрыть (Hide).

Во вкладке Вывод на экран (Visible) вы можете посмотреть список папок, отображаемых в Outlook Express.

Нажмите кнопку ОК для продолжения.

Теперь пора перейти к настройке параметров для заголовков. В списке папок появится одна или несколько новых. Перейдите в папку Входящие (Inbox). Далее, подведите курсор к этой папке и нажмите правую кнопку мыши. Появится контекстное меню. Из него нужно выбрать команду Свойства (Properties).

Затем перейдите во вкладку Синхронизация (Synchronize) (рис. 13.6).

Рис. 13.6. Окно Свойства: Входящие, вкладка Синхронизация

В свойствах синхронизации следует выбрать переключатель новые заголовки (New headers). Установка этого параметра говорит программе загружать только заголовки сообщений.

Во вкладке Локальный файл (Local) вы можете производить некоторые манипуляции над сообщениями, а именно:

  • сжать (Compact);
  • удалить сообщения (Remove Messages);
  • удалить (Delete).

Сжать (Compact) — сжать сообщения. Это позволит несколько увеличить место на вашем винчестере. Прирост будет почти незаметен.

Удалить сообщения (Remove Messages). Выбрав данный пункт, все тела сообщений, имеющиеся в папке Inbox, будут удалены.

Удалить (Delete). Нажатие этой кнопки позволяет полностью стереть все заголовки и сами сообщения из папки.

Далее следует указать, какие сообщения загружать — все или только новые. Для этого в контекстном меню выберите Параметры синхронизации | Только заголовки (Synchronization Settings | Headers Only).


Настройка программы для корректной работы

Перейдите в меню Сервис (Tools), выберите команду Параметры (Options). Появится новое окно. Перейдите во вкладку Обслуживание (Maintenance) (рис. 13.7)

Рис. 13.7. Окно Параметры, вкладка Обслуживание

Для корректной работы требуется установить флажки в следующих полях.

  • Очищать папку "Удаленные" перед выходом (Empty messages from the "Deleted Items" folder on exit).
  • Уничтожать удаленные сообщения при выходе из папок IMAP (Purge deleted messages when leaving IMAP folders).

Таким образом, папка Удаленные (Deleted) будет очищаться при каждом выходе из программы, а также удаляться с ШАР-сервера.

Теперь перейдите во вкладку Чтение (Read). Там снимите флажок Автоматически загружать сообщение при отображении в области просмотра (Automatically download message when viewing in the Preview Pane). Это позволит не загружать изображения при просмотре сообщений в панели предварительного просмотра.


Работа с почтой

Все необходимые настройки уже сделаны. Посмотрим повнимательнее на принципы работы с заголовками письма. Дело в том, что заголовок — малая часть письма. Следовательно, времени на его загрузку требуется очень мало.

При переходе в папку Inbox произойдет загрузка сообщений по установленному правилу — Только заголовки (Headers Only). В результате чего вы сможете просмотреть заголовки сообщений (рис. 13.8).

Рис. 13.8. Просмотр заголовков

Для того чтобы прочитать содержимое письма, вам достаточно лишь щелкнуть по заголовку дважды. Появится новое окно и вскоре сообщение загрузится.

Если вы хотите загрузить все сообщения, требуется нажать клавишу <Ctrl> на клавиатуре и, удерживая ее, нажать клавишу <А> (в латинской раскладке).

Для того чтобы письмо было сохранено у вас на компьютере, достаточно воспользоваться командой Переместить в папку (Move to Folder) контекстного меню. В появившемся окне требуется указать папку для перемещения.

Если вы хотите удалить сообщение, достаточно щелкнуть по нему и из контекстного меню выбрать команду Удалить (Delete). Правда это не приведет к полному удалению. При использовании специальной команды вы с легкостью сможете восстановить его. Для окончательного удаления воспользуйтесь меню Правка (Edit), выберите команду Очистить папку Удаленные (Purge Deleted messages). Это приведет к удалению письма с сервера.


Окно Outlook Express

На рис. 13.9 изображено основное окно программы. Оно имеет несколько составных частей. В самом верху расположена панель с текстовыми раскрывающимися меню. Чуть ниже находятся кнопки, позволяющие сделать работу с сообщениями более удобной. Слева расположены две панели — Папки (Folders) и Контакты (Contacts). В панели Папки (Folders) вы можете посмотреть на список доступных папок: Входящие (Inbox), Исходящие (Outbox), Отправленные (Sent), Удаленные (Trash), Черновики (Drafts).

Рис. 13.9. Окно Outlook Express

Папка Входящие (Inbox) — сюда сохраняются приходящие сообщения. В папке Входящие (Inbox) находятся письма e-mail, подлежащие отправке. Соответственно в папке Отправленные (Sent) — сообщения, которые были уже отправлены. Стоит заметить, что сортировка сообщений происходит автоматически. Например, все приходящие электронные письма помещаются в папку Входящие (Inbox), а не в какую-нибудь другую. На панели Контакты находится список людей, с которыми вы уже общались. Но главным, наиболее информативным является окно, расположенное справа от панелей Папки и Контакты. В зависимости от выбранного режима, здесь отображается различная информация. Например, на рис. 13.9, в главном окне отображено приветственное сообщение. Итак, в поле Электронная почта (e-mail) вы можете узнать о количестве непрочитанных (новых) сообщений, выбрать команду Чтение почты (Read Mail), для того чтобы переместиться в папку Входящие (Inbox). А также создать новое сообщение, выбрав Создать почтовое сообщение (Create a new Mail message). Чуть ниже расположено поле Группы новостей (Newsgroups). Если вы планируете работать с ними, выберите поле Настройка учетной записи групп новостей (Set up a Newsgroup account) (о том, как создать его, будет рассказано чуть позже). Далее располагается панель Контакты (Contacts). Выбрав одну из команд, вы можете Открыть адресную книгу (Open the Address Book) или осуществить поиск людей — Найти людей (Find People). При каждом запуске программы будет загружаться именно это окно. Если вы хотите, чтобы автоматически открывалась палка Входящие (Inbox), установите флажок При запуске программы Outlook Express открывать папку 'Входящие' (When Outlook Express starts, go directly to my Inbox). Справа расположена панель Полезный совет (Tip of the Day). Из нее вы можете узнать тонкости работы с программой. Выбрав Поиск сообщения (Find a Message), вы можете запустить поиск сообщения.


Входящие сообщения Чтение

Для того чтобы загрузить все имеющиеся на сервере сообщения на ваш компьютер, нажмите кнопку с изображением двух писем. Она расположена на основной панели и имеет подпись Доставить (Send\Recv). To же самое можно сделать при помощи раскрывающегося меню. Для этого выберите меню Сервис | Доставить почту | Получить почту (Tools Send and Receive | Receive All). При этом появится небольшое окно (рис. 13.10), в котором вы можете следить за статусом проверки почты.

В окне есть несколько вкладок и кнопок:

  • Скрыть (Hide) — спрятать окно;
  • Остановить (Stop) — прекратить проверку почты;
  • Подробно (Details) — отображение деталей проверки. Именно после нажатия этой кнопки, вы сможете получить доступ к вкладкам Tasks и Errors;
  • Tasks — в дословном переводе — Задачи. Вы сможете посмотреть на статус выполнения поставленных задач;
  • Ошибки (Errors) — информация о допущенных ошибках. Например, Невозможно соединиться с сервером.

После того как письма загрузились на ваш компьютер, перейдите в папку Входящие (Inbox). Для этого на панели Папки выберите папку Входящие (Inbox) (рис. 13.11).

Рис. 13.10. Окно Outlook Express: загрузка почты

Рис. 13.11. Окно Входящие — Outlook Express

В данном примере у нас имеется два сообщения — одно прочитанное, другое — нет (непрочитанные выделены жирным шрифтом). Для того чтобы его просмотреть, требуется подвести курсор к сообщению и нажать на левую кнопку мыши. В окне предпросмотра загрузится сообщение. Если вы хотите посмотреть его в полной форме, дважды щелкните по названию сообщения. Появится новое окно (рис. 13.12).

Рис. 13.12. Окно Re: О книге "Internet Explorer 6"

Окно также разделено на несколько частей. Главной из которых является нижняя. Именно там вы можете просматривать сообщение. Используйте полосу прокрутки для перемещения по странице. Чуть выше располагается специальная панель, в которой вы можете узнать некоторую информацию о письме:

  • От
  • Дата
  • Кому
  • Тема

От кого оно пришло — поле От (From). В данном примере отправителем является Microsoft Outlook Express Team msoe@microsoft.com.

Поле Дата (Date). Например, 22 июля 2001 г. 0:45.

Поле Кому (То). Например, New Outlook Express User <New Outlook Express UserX

Поле Тема (Subject). В данном примере — Welcome to Outlook Express 6.

Чуть выше располагается основная панель. На ней представлены такие кнопки:

  • Ответить (Reply)
  • Удалить (Delete)
  • Ответить... (Reply All)
  • Предыду... (Previous)
  • Переслать (Forward)
  • Следующее (Next)
  • Печать (Print)
  • Адреса (Addresses)

Ответить (Reply) — ответить отправителю. Нажав эту кнопку, вы можете ответить на сообщение. При этом появится новое окно, в котором вы сможете набрать текст. А ниже будет находиться текущее сообщение — цитирование.

Ответить... (Reply All) — ответить всем. В данном случае копия ответа на сообщение будет отправлена не только автору, но и всем, кому оно еще посылалось, и даже вам.

Переслать (Forward) — перенаправить. Нажав эту кнопку, вы сможете перенаправить это сообщение. При этом содержимое не будет нисколько изменено.

Печать (Print) — распечатать. При нажатии кнопки Печать письмо будет напечатано (если принтер установлен и правильно настроен).

Предыду... (Previous) — предыдущее. Если нажать эту кнопку, то предшествующее этому письму сообщение будет отображено.

Следующее (Next). Следующее по счету сообщение будет загружено.

Адреса (Addresses) — адресная книга. Нажатие этой кнопки вызывает окно с адресной книгой.

Нажмите кнопку X, если вы хотите закрыть это окно.

Из главного окна программы вы также можете воспользоваться контекстным меню, позволяющим выполнить некоторые действия с сообщением.

Контекстное меню активизируется при нажатии правой кнопки мыши на выделенном сообщении.

Содержимое меню:

  • Открыть (Open)
  • Печать (Print)
  • Ответить отправителю (Reply to Sender)
  • Ответить всем (Reply to All)
  • Переслать (Forward)
  • Переслать как вложение (Forward As Attachment)
  • Пометить как прочитанное (Mark as Read)
  • Пометить как непрочитанное (Mark as Unread)
  • Переместить в папку... (Move to Folder...)
  • Копировать в папку... (Copy to Folder...)
  • Удалить (Delete)
  • Добавить отправителя в адресную книгу (Add Sender to Address Book)
  • Свойства (Properties)

Открыть (Open). При выборе этой команды, сообщение будет открыто в отдельном окне, что позволит ознакомиться с его содержанием в более удобной форме.

Печать (Print) — распечатать.

Ответить отправителю (Reply to Sender). Таким образом, вы можете ответить отправителю, цитируя его сообщение и, возможно, внося некоторые комментарии.

Переслать (Forward) — перенаправить. Эта команда может использоваться в том случае, если вы хотите переслать это сообщение кому-либо в том виде, в котором оно пришло к вам. Единственное отличие — сверху будет указано, что сообщение перенаправлено.

Переслать как вложение (Forward As Attachment) — перенаправить как вложение. В данном случае сообщение будет отправлено вложенным, а в основном окне вы сможете написать свои комментарии, возможно, какие-то замечания для того, кто прочитает его.

Пометить как прочитанное (Mark as Read). Стандартное время, за которое сообщение становится прочитанным, — 5 секунд. Если вы не хотите ждать, выберите Пометить как прочитанное (Mark as Read).

Копировать в папку... (Copy to Folder...). При этом сообщение будет выделено жирным шрифтом. Также вы можете установить эту метку только для сообщения, которое уже было прочитано.

Переместить в папку... (Move to Folder...) — переместить в папку. Выбрав эту команду, появится новое окно (рис. 13.13), с помощью которого вы сможете с легкостью переместить текущее сообщение в другую папку. Для этого достаточно выбрать из списка требуемую папку. Если же она отсутствует, создайте ее нажатием кнопки Новая папка (New Folder).

Рис. 13.13. Окно Переместить

Рис. 13.14. Окно свойства сообщения

Удалить (Delete). При этом сообщение будет перемещено в папку Удаленные (Trash). Поэтому вы всегда сможете его восстановить.

Свойства (Properties). При выборе данного пункта меню появляется новое окно (рис. 13.14), в котором можно узнать некоторые подробности о письме, а также служебную информацию.


Блокировка нежелательных сообщений (спам)

Спам — нежелательные сообщения, приходящие к вам на e-mail. В большинстве случаев являются рекламными письмами, иногда программами-Троянами. Сначала вы можете не обращать на них внимания. Но позже вы поймете, что они сильно вам мешают. И вот почему: вам приходится просматривать все, даже не самые нужные письма, тратится время на загрузку и выборку писем. К счастью, в Microsoft Outlook Express 6.0 встроена достаточно неплохая система борьбы со спамом. В данном разделе подробно описана работа с ней.

Предположим, вы часто получаете сообщения, которые вам не хочется читать, тратить время и деньги на их загрузку. Причем, приходят они от одного адреса. Заблокировать получение таких писем очень легко:

  1. Выберите сообщение от адресата, которого вы хотите заблокировать.
  2. Из раскрывающегося меню Сообщение (Message) выберите команду Блокировать отправителя (Block Sender).
  3. В появившемся диалоговом окне вам будет предложено удалить все сообщения от этого адресата, находящиеся в выбранной папке. Если вы не хотите этого делать — выберите Нет (No).

Таким образом, получение писем от этого адресата будет заблокировано. Например, с сервера они не будут загружаться. Это позволит вам сократить время, проводимое в Интернете, а также деньги.

Выше был рассмотрен пример достаточно безопасного спама. То есть ненужные письма принимаются от одного адресата. Соответственно заблокировать его довольно легко. К сожалению, большинство спаммеров используют более изощренные методы. Вот почему может пригодиться улучшенная система фильтрации писем, которая также имеется в программе. Также она позволяет упростить, ускорить работу с сообщениями. Например, помещать письма, выбранные по критерию, в другую папку и т. д.

Итак, выберите из меню Сообщение (Message) команду Создать правило из сообщения (Create rule from message). Появится новое окно (рис. 13.15).

Окно разделено на 4 части.

  1. Выберите условия для данного правила (Select the Conditions for your rule).
  2. Выберите действия для данного правила (Select the Actions for your rule).
  3. Описание правила ( Rule Description).
  4. Название правила (Name of the rule). Рассмотрим некоторые из них.
  • Выберите условия для данного правила (Select the Conditions for your rule):
  • Искать сообщения, содержащие адресатов в поле От (Where the From line contains people) — если поле От содержит этот (эти) адрес. Итак, если вы хотите заблокировать получение почты от какого-то человека, выберите этот пункт. Далее вам нужно решить, что делать с письмом от этого адресата. В зависимости от решения выбрать действие из 2-го пункта. Например, Удалить с сервера (Delete it from server). Из поля Удалить с сервера (Delete it from server) вы также можете добавить адресатов. Для этого достаточно щелкнуть по выделенной ссылке. Появится новое окно, в котором вы сможете с легкостью добавить e-mail адреса для данного условия;
  • Искать сообщения, содержащие заданные слова в поле Тема (Where the Subject line contains specific words) — если поле Тема содержит некоторые слова. Эти некоторые слова вы задаете вручную. Сделать это также несложно; в третьем поле выберите ссылку содержит заданные слова (contains specific words). В появившемся окне, в специальной форме, введите слова (слово), присутствие которых в теме письма позволит провести над ним действия. После ввода нажмите кнопку Добавить (Add);

Рис. 13.15. Окно Создать правило для почты

Искать сообщения, содержащие заданные слова (Where the message body contains specific words) — если в теле сообщения содержатся специфические слова. Функция аналогична предыдущей. Преимущество только в том, что прежде чем произвести действие над сообщением, программа просмотрит его содержание, а не только тему или адрес отправителя;

  • Искать сообщения, содержащие адресатов в поле Кому (Where the To line contains people). Добавление определенных e-mail происходит так же, как и в предыдущих пунктах;
  • Искать сообщения, содержащие адресатов в поле Копия (Where the CC line contains people). Их добавление можно осуществить при помощи специального окна, работа с которым была рассмотрена в одном из предыдущих пунктов;
  • Искать сообщения, содержащие адресатов в поле Кому и Копия (Where the To or CC line contains people) — если в поле Кому или Копия содержится указанный e-mail;
  • Искать сообщения с пометкой важности (Where the message is marked as priority) — если задан приоритет сообщения. Например, при высоком приоритете сообщение может быть перемещено в специальную папку;
  • Искать сообщения, полученные с определенной учетной записи (Where the message is from the specified account) — если сообщение отправлено со специфического ящика;
  • Искать сообщения, размер которых превышает заданный размер (Where the message size is more than size) — если размер сообщения превышает указанный. Эта функция может быть полезна, если вы оплачиваете дорогостоящий трафик и не хотите скачивать сообщения большого размера. Например, превышающие 200 Кбайт. Максимальный размер письма вы можете указать, щелкнув по ссылке в окне 3;
  • Искать сообщения с вложениями (Where the message has an attachment). Вложен может быть любой файл, начиная от HTML-документа и заканчивая программой. Вы можете создать специальную папку, в которую будут перемещаться сообщения с вложениями;
  • Искать безопасные сообщения (Where the message is secure);
  • Все сообщения (For all messages) — правило для всех сообщений.

Вышеперечисленные условия ничего из себя не представляют без действий. Под каждое из них вы можете создать специальное действие.

  • Выберите действия для данного правила (Select the Actions for your rule):
    • Переместить в заданную папку (Move it to the specified folder) — переместить в папку. Может использоваться для упорядочивания входящей почты. Например, если вы общаетесь с человеком, имеющим e-mail адрес man@man.com, вы имеете возможность перемещать все письма в одноименную папку;
    • Скопировать в заданную папку (Copy it to the specified folder). Аналогично предыдущему пункту. Единственное отличие — сообщение будет сохранено, как в папке Входящие, так и в специальной. Например, man@man.com;
    • Удалить (Delete it). Используется в том случае, если не подходит под заданные условия;
    • Переслать адресатам (Forward it to people) — перенаправлять на адреса. Их вы можете задать в специальном окне;
    • Выделить цветом (Highlight it with color). Например, сообщения от вашего начальника, можно выделять красным цветом; Пометить (Flag it) — устанавливать флажок; Пометить как прочитанное (Mark it as read);
    • Пометить сообщение как просмотренное или пропущенное (Mark the message as watched or ignored);
    • Ответить заданным сообщением (Reply with message). Вообще это очень полезная функция. Например, от отправителя Иванова вы получили письмо. Если Ответить заданным сообщением (Reply with message) установлено, то он получит ответное письмо, в котором будет говориться, что его сообщение получено или то, что вы пожелаете; Прекращение выполнения дополнительных правил (Stop processing more rules);
    • He загружать с сервера (Do not Download it from the server); Удалить с сервера (Delete it from server). При этом все сообщения, которые подходят под созданную маску, будут удаляться.


  • Глава 14. Создание и отправка почтовых сообщений
    • Интерфейс программы
    • Меню Файл
    • Меню Правка
    • Меню Вид
    • Меню Вставка
    • Меню Формат
    • Меню Сервис
    • Создание сообщения из шаблона


ГЛАВА 14.

Создание и отправка почтовых сообщений

В предыдущей главе было рассказано о том, как читать, работать с входящими сообщениями. В этой главе будет подробнейшим образом разобрана процедура создания, управления исходящими сообщениями.

Итак, Microsoft Qutlook Express, как и любая другая почтовая программа, позволяет не только работать с входящей почтой, но также и создавать, отправлять письма e-mail. В приложение встроен очень хороший движок, делающий работу с сообщениями очень простой и в тоже время функциональной. В отличие от своих конкурентов, Microsoft Outlook Express может корректно работать не только со входящей почтой с HTML-разметкой, но также и с исходящей. Проще говоря, в создаваемых вами сообщениях вы можете использовать всевозможные HTML-теги.

Запустите программу Microsoft Outlook Express. Затем на основной панели нажмите кнопку Создать п...(Create Mail). Кстати, кнопка состоит из двух частей. Одна — находится слева, большая по размеру, другая — маленькая. Итак, при нажатии большой кнопки появится новое окно (рис. 14.1).

В самом верху расположена панель с раскрывающимися меню. Стоит заметить, что многие команды дублируются. Например, на основной панели есть кнопка Отправить (Send), а также на панели с раскрывающимися меню есть такая команда.


Интерфейс программы

Меню Файл

В данном меню находятся перечисленные ниже команды.

  • Создать (New)
    • Почтовое сообщение (Mail Message) — новое сообщение e-mail. При выборе данной команды открывается новое окно, в котором вы можете составить сообщение.

Рис. 14.1. Окно Создать сообщение

    • Сообщение группы новостей (News Message) - новое сообщение в группу новостей. Если вы уже настроили группы новостей — указали сервер, и т. д., то тогда откроется практически идентичное данному окно, в котором вы сможете составить, а затем отправить сообщение в группу новостей. В противном случае будет запущен мастер настройки групп новостей.
  • Отправить (Send Message) — отправить текущее сообщение. Если не указан адресат или тема, Outlook Express предложит ее ввести.
  • Отправить позже (Send Later) — при выборе этой команды сообщение будет помещено в папку Исходящие (Outbox). Вы сможете его отправить при первой представившейся возможности.
  • Сохранить (Save) — выбрав эту команду, сообщение будет сохранено в папку Черновики (Drafts). При этом появится диалоговое окно, поясняющее это.
  • Сохранить как (Save as) — при выборе этой команды меню появится окно, в котором вы сможете выбрать папку для сохранения, а также формат — Mail (*.eml), Text file (*.txt), Unicode Text file (*.txt), Html files (*.htm, *.html). He забудьте указать имя файла.
  • Сохранить как бланк (Save as Stationery) — сохранить в качестве шаблона. Например, вы создали какое-то сообщение с определенным форматированием, которое хочется применять в дальнейшем. У вас есть возможность сохранить это сообщение в качестве шаблона.
  • Копировать в папку (Copy to folder) — в появившемся окне вы можете выбрать папку для копирования этого сообщения. Например, Черновики.
  • Свойства (Properties) — свойства сообщения. Можно, например, узнать его тип, размер, приоритет и еще ряд параметров.
  • Работать автономно (Work Offline) — т. е. без подключения к сети Интернет. В данном режиме вы не сможете принимать и отправлять почту.
  • Закрыть (Close) — закрытие окна.


Меню Правка

В данном меню находятся перечисленные ниже команды.

  • Отменить (Undo). Команда позволяет отменить последнее действие. Например, вы случайно стерли часть сообщения. Восстановить ее можно при помощи команды Отменить (Undo).
  • Вырезать (Cut). Выделите фрагмент текста, который хотите удалить. И выберите команду Вырезать (Cut). Альтернативой Вырезать (Cut) может послужить клавиша <Backspace> на клавиатуре.
  • Копировать (Сору). Выделите фрагмент текста и нажмите кнопку Копировать (Сору). Он будет помещен в буфер обмена. Существует также комбинация клавиш <Ctrl>+<C> на клавиатуре, которая выполняет то же самое действие — копирует выделенный фрагмент в буфер обмена.
  • Вставить (Paste). Данная команда позволяет вставить текст, изображение из буфера обмена. Не стоит забывать, что он должен быть туда предварительно скопирован.
  • Выделить все (Select All). Команда позволяет выделить все сообщение целиком. Это может быть нужно, например, для копирования в буфер обмена.
  • Найти (Find). При выборе этой команды появится новое окно, представленное на рис. 14.2.
    • Сообщение (Message).
    • Людей (People).
    • Текст в сообщении (Text in the message).

Для того чтобы осуществить поиск, следует ввести критерий. Например, если вы помните адрес e-mail отправителя, введите его в поле От (From).

Удалить гиперссылку (Remove Hyperlink). Outlook Express автоматически создает гиперссылки. Например, если вы указали адрес сайта http:// www.microsoft.com. Он автоматически будет сделан гиперссылкой. Чтобы убрать - выделите адрес и выберите команду Удалить гиперссылку (Remove Hyperlink).

Рис. 14.2. Окно Поиск сообщения


Меню Вид

В данном меню находятся перечисленные ниже команды.

  • Все заголовки (All Headers). В частности появится строка для ввода Скрытая (Вес).
  • Панели инструментов (Toolbars)
    • Обычные кнопки (Standard Buttons)
    • Панель форматирования (Formatting Bar)

Сняв флажок с Обычные кнопки (Standard Buttons), панель с основными кнопками управления не будет показываться.

  • Строка состояния (Status Bar). Для того чтобы панель статуса отображалась, флажок должен быть установлен.
  • Изменение источника (Source Edit). Выполняет редактирование исходного кода сообщения. Выбрав эту команду, появится новая панель, располагающаяся над строкой состояния (рис. 14.3). Итак, на ней есть три вкладки.
  • Изменить (Edit) — редактировать. Выбрав эту вкладку, редактирование сообщения будет происходить в обычном, графическом режиме.
  • Источник (Source). Выбрав данную вкладку, вы можете просмотреть исходный код сообщения, со всеми HTML-тегами (рис. 14.3).
  • Просмотр (Preview). Данная команда позволяет просмотреть сообщение в том виде, в котором оно будет видно получателю.

Рис. 14.3. Окно Создать сообщение: просмотр исходного кода


Меню Вставка

В данном меню находятся перечисленные ниже команды.

  • Вложение файла (File Attachment). Из диалогового окна, вы можете выбрать любой файл для вложения в сообщение e-mail. Например, программу или аудиофайл.
  • Текст из файла (Text from file). Например, у вас есть какой-то текстовый файл, и информацию из него вы хотите вставить в текущее сообщение. Для этого уже не нужно открывать текстовый редактор, выделять текст и вставлять его в сообщение e-mail. Процесс полностью автоматизирован. Выберите текстовый файл, и информация будет автоматически вставлена в сообщение.
  • Рисунок (Picture). Если вы хотите вставить картинку в сообщение, выберите эту команду. Появится новое окно (рис. 14.4), с помощью которого вставить картинку не составит труда. В поле Источник рисунка (Picture Source) нужно указать расположение изображения. Это может быть как интернет-адрес, так и локальный. Причем, для того чтобы упростить поиск требуемой картинки на вашем компьютере, воспользуйтесь кнопкой Обзор (Browse). В поле Текст для замены (Alternate Text) вы можете ввести текстовое сообщение, комментирующее картинку. Оно появляется автоматически при наведении на нее. В поле Толщина границы (Border Thickness) вы можете задать толщину границы, т. е. линии, окаймляющей изображение. По умолчанию — 0.

Рис. 14.4. Окно Рисунок

  • Горизонтальная линия (Horizontal line). Вставляется линия. Может использоваться для отделения нескольких частей сообщения.
  • Гиперссылка (Hyperlink). Появится новое окно (рис. 14.5).

Рис. 14.5. Окно Гиперссылка

В поле Тип (Туре) вы можете указать тип гиперссылки:

  • File
  • mailto
  • Ftp
  • news
  • Gopher
  • Telnet
  • Http
  • wais
  • Https

А в поле URL будет подставлен протокол, например, HTTP. А дальше вы можете ввести сам адрес.


Меню Формат

Меню Формат (Format) имеет достаточно много пунктов, часть из которых продублирована кнопками на панели. Наиболее интересные перечислены ниже.

  • Кодировка (Encoding). В принципе кодировка текста выбирается автоматически. Но в связи с тем, что существует несколько типов кодировки русскоязычных символов. Наиболее распространенная и рекомендованная — КОИ8-Р. Но если вы предпочитаете использовать, например, Windows-1251, то и это возможно. Для этого из меню Дополнительно (More) выберите требуемую кодировку.
  • Формат HTML (HTML) или Обычный текст (Plain Text). Итак, Microsoft Outlook Express 6.0 позволяет создавать, отправлять сообщения двух типов. Это текст с разметкой — HTML, либо обычный текст. У HTML существует много плюсов — можно изменять шрифт, его размер, создавать таблицы и т. д. Главный минус — размер сообщения значительно растет. Также по нормам сетевого этикета писать HTML-письма — плохой тон. Поэтому рекомендуется выбрать Обычный текст (Plain Text).
  • Использовать бланк (Apply Stationery). Например, Поздравление.


Меню Сервис

В данном меню находятся перечисленные ниже команды.

  • Правописание (Spelling). Данная команда запускает проверку орфографии в тексте.
  • Проверить имена (Check Names). Кнопка с аналогичным действием имеется и на основной панели (называется Правопис...(Check)). Команда позволяет проверить правильность указания имен, адресов получателей. Алгоритм работы таков: программа сверяется с именами, адресами e-mail, имеющимися в адресной книге. Если такой адресат не найден, появится следующее окно (рис. 14.6).

Рис. 14.6. Окно Проверка имен

Итак, в данном примере программа сообщает нам, что ничего не найдено. Нажатие кнопки Другие имена (Show More Names) вызывает новое окно (рис. 14.7).

Рис. 14.7. Окно Проверка имен: другие имена

В данном окне программа просит вас выбрать того, с кем адресат ассоциируется. Если это новый получатель, вы имеете возможность создать учетную запись для него. Для этого нажмите кнопку Создать контакт (New Contact).

  • Выбрать получателей (Select Recipients). При выборе этого пункта появляется новое окно (рис. 14.8).

Слева расположена панель, в которой вы можете выбрать контакты из адресной книги. Используйте кнопки Кому (То), Копия (Сс), Скрытая копия (Вес), чтобы добавить адресатов.

Рис. 14.8. Окно Выбрать получателей

  • Адресная книга (Address Book) — запуск адресной книги.
  • Зашифровать (Encrypt) — зашифровать сообщение. У вас должен иметься личный и публичный ключ.
  • Цифровая подпись (Digitally Sign). У вас должно быть действительное цифровое удостоверение. О том, как его получить, было рассказано ранее.

Составление сообщения не представляет трудностей. В специальном .поле наберите текст. Так как Microsoft Outlook Express позволяет использовать HTML-теги, вы можете менять шрифт, его размер, жирность и многое друroe. Все это можно сделать при помощи панели, расположенной над полем для ввода (рис. 14.9).

Из раскрывающегося меню вы можете выбрать шрифт. Стоит учитывать, что вместе с Windows по умолчанию распространяются только MS Sans Serif, Times New Roman и Arial. Следовательно, выбрав какой-нибудь экстравагантный шрифт, другой пользователь, на другом компьютере, скорее всего не сможет прочитать текст. Справа от меню выбора шрифта есть раскрывающееся меню, в котором вы можете установить его размер. Стандартным является размер 8—12. Для заголовков используется 14—16.

Рис. 14.9. Создание сообщения

Кнопка Стиль абзаца (Paragraph Style) позволяет выбрать стиль текста. Выбор довольно-таки большой (рис. 14.10).

Кстати пользоваться этим меню намного удобнее, чем задавать размер шрифта самому.

Кнопки позволяют сделать текст жирным, наклонным или подчеркнутым шрифтом. Нажатие кнопки А вызывает список цветов, которыми можно окрасить текст.

Правее расположены кнопки дать:

  • нумерованный список; с помощью которых можно созмаркированный список, он выглядит примерно так же, как и этот;
  • сдвинуть вправо строку;
  • сдвинуть влево строку.

Используя кнопки вы можете изменить положение текста. Например, форматировать по центру.

Рис. 14.10. Выбор стиля абзаца

Кнопки позволяют [image]:

  • создать горизонтальную полоску. Например, для разделения нескольких частей сообщения;
  • создать гиперссылку. При этом нужно выделить фрагмент текста, который будет использоваться в качестве гиперссылки;
  • вставить картинку в письмо.

После того как текст набран, требуется указать адрес получателя (получателей), а также тему сообщения. Это можно сделать в специальной форме (рис. 14.11).

Рис. 14.11. Указание получателя и темы

Вы также можете задать приоритет сообщения. Для удобства кнопка, позволяющая сделать это, вынесена на основную панель (рис. 14.12).

Рис. 14.12. Основная панель

Нажатие ее увеличивает приоритет сообщения до уровня Высокий (High). Повторное нажатие — Низкий (Low). Нажав кнопку Важность (Priority) третий раз, приоритет станет опять Средний (Medium).

Если у вас на компьютере установлен комплект офисных программ Microsoft Office, то вы можете воспользоваться функцией проверки орфографии. Для этого достаточно нажать кнопку Правопис... (Spelling). Для примера был набран текст с явными ошибками: "Это теставое саобщение". Функция проверки орфографии сработала достаточно неплохо. Появилось окно, представленное на рис. 14.13.

Рис. 14.13. Окно Правописание

В нем предлагается заменить слово "Теставое" на "Тестовое" или "Теста". Для того чтобы согласиться с изменениями, требуется нажать кнопку Изменить (Change). Если вы уверены, что слово набрано верно, a Microsoft Outlook Express выдает ошибку, вы можете либо добавить слово в словарь — нажатием кнопки Добавить (Add), либо просто проигнорировать — Пропустить (Ignore). Кнопки Пропустить все (Ignore All) и Заменить все (Change All) позволяют проигнорировать или заменить слово по всему тексту (если оно встречается не один раз).


Создание сообщения из шаблона

Нажмите кнопку Создать п... (Create Mail) — маленькую. Из предложенного списка вы можете выбрать понравившийся шаблон. Например, Извещение (рис. 14.14).

Рис. 14.14. Окно Создать сообщение


  • Глава 15. Работа с группами новостей
    • Что такое группы новостей
    • Создание учетной записи
    • Настройка
    • Чтение сообщений
    • Создание сообщений
    • Рекомендации


ГЛАВА 15.

Работа с группами новостей

Что такое группы новостей

Группа новостей — коллекция сообщений, опубликованных обыкновенными пользователями на специальном сервере — News.

Вы можете найти newsgroup практически любой направленности. Некоторые группы новостей модерируются, другие — нет. Модерируемые принадлежат пользователям, которые обладают правами удаления, изменения сообщений, опубликованных другими пользователями. Каждый может участвовать в группах новостей — не требуется платы за вступление, пользование.

Для того чтобы работать с группами новостей в Microsoft Outlook Express, ваш интернет-провайдер должен предоставлять доступ на специальные серверы. После создания учетной записи для каждого сервера вы сможете читать, опубликовывать сообщения в группы новостей, имеющиеся на сервере.

Если вы найдете newsgroup, пришедшуюся вам по вкусу, вы можете подписаться на нее. Соответственно она будет в папке News.


Создание учетной записи

Выберите из меню Сервис (Tools) команду Учетные записи (Accounts). В появившемся окне (рис. 15.1) выберите вкладку Новости (News).

Затем нажмите кнопку Добавить (Add). Из появившегося меню выберите команду Новости (News). Загрузится новое окно — Мастер подключения к

Интернету. Для начала требуется ввести ваше имя и фамилию. Вы можете вводить как кириллицей, так и латиницей. Но все же латиница рекомендована. Например, если ваше имя Иван Петров, то в транслите оно будет таким: Ivan Petrov. Нажмите кнопку Далее (Next) для продолжения. В следующей форме вам предлагается ввести ваш адрес e-mail. Далее вам пред-

стоит ввести адрес сервера новостей, а также указать некоторые параметры (рис. 15.2).

Рис. 15.1. Окно Учетной записи в Интернете, вкладка Новости

Рис. 15.2. Окно Мастер подключения к Интернету

В поле Сервер новостей (NNTP) (News (NNTP) server) требуется ввести адрес сервера новостей. Некоторые интернет-провайдеры требуют авторизации для доступа к серверу новостей. Поэтому, если у вас есть логин и пароль для доступа к серверу, установите флажок Требуется вход на сервер новостей (My news server requires me to log on). Для продолжения нажмите кнопку Далее (Next).

В следующем окне вам будет предложено запомнить настройки. Нажмите кнопку Готово (Finish) для продолжения.


Настройка

В окне (см. рис. 15.1) появилась новая строка— news.demos.su. Нажмите кнопку Свойства (Properties) для указания дополнительных параметров. Появится новое окно (рис. 15.3).

Рис. 15.3. Окно свойств сервера новостей

Во вкладке Общие (General) вы можете изменить имя (не адрес) сервера. Например, сервер новостей. В графе Сведения о пользователе (User Information) вы имеете возможность изменить свои данные:

  • Имя (Name) — имя пользователя. Например, Vasya Pupkin. В принципе вы не обязаны указывать ваше полное имя.
  • Организация (Organization). Вы можете указать название компании, в которой вы работаете.
  • Электронная почта (E-mail address) — вы можете изменить адрес e-mail. Например, при создании нового почтового ящика.
  • Обратный адрес (Reply address) — адрес для ответа. Например, у вас есть два адреса e-mail. Один — основной, для деловой корреспонденции, а другой — для знакомых из чатов, форумов и т. д. Здесь стоит указать именно его.

Установив флажок Использовать эту запись при проверке новых сообщений (Include this account when checking for new messages), проверка новых сообщений будет осуществляться автоматически при проверке почтовых ящиков.

На вкладке Сервер (Server) вы можете изменить адрес сервера, а также указать имя пользователя и пароль для доступа, если требуется.

На вкладке Подключение (Connections) вы можете указать соединение, используемое для данной учетной записи. Для этого установите флажок Подключаться, используя (Always connect using this account) и из раскрывающегося меню выберите соединение.

На вкладке Дополнительно (Advanced) (рис. 15.4) вы можете указать дополнительные параметры соединения с сервером новостей.

Рис. 15.4. Окно Свойства, вкладка Дополнительно

Если соединение с сервером новостей происходит по нестандартному порту, вы можете указать его в специальной форме. Для возвращения к настройкам по умолчанию нажмите кнопку По умолчанию (Use Default). Некоторые серверы новостей поддерживают работу только в защищенном режиме. Microsoft Outlook Express обладает возможностью работы с ними. Для этого установите флажок перед Подключаться через безопасное соединение (SSL) (This server requires a secure connection (SSL)). Многие news-серверы достаточно медленны в работе. Поэтому вы имеете возможность установить тайм-аут работы с сервером — от 30 секунд до 5 минут.

Здесь же можно указать параметры публикации сообщений. Например, разбивать большие сообщения на части или посылать сообщения в формате Plain Text (просто текст).

Для сохранения настроек нажмите кнопку Применить (Apply), а затем кнопку ОК. В списке папок появилась новая — news.demos.su. Выберите ее.

Рис. 15.5. Диалоговое окно Outlook Express

Появится диалоговое окно (рис. 15.5), в котором вам сообщают о том, что вы не подписаны на получение групп новостей. Предлагается просмотреть список доступных news-групп. Для этого нажмите кнопку Да (Yes). Если вы хотите сделать это позднее, нажмите кнопку Нет (No).

Появляется новое окно (рис. 15.6).

Рис. 15.6. Окно Загрузка групп новостей из...

В нем выводится информация о текущем состоянии соединения. Например, в окне, изображенном на рис. 15.6, говорится о том, что соединение с сервером установлено. Стоит заметить, что на популярных news-серверах существует огромное количество групп новостей. Соответственно при невысокой скорости соединения с Интернетом загрузка даже их названий может занять достаточно много времени.

Через несколько минут вы сможете просмотреть список доступных групп новостей. Он представлен в очень удобной форме - по алфавиту. На рис. 15.7 представлено окно со списком news-групп.

Рис. 15.7. Окно Подписка на группу новостей

Выбрать группу новостей вам поможет ее название. Например, fido7.hip-hop. mp3 — группа новостей, принадлежащая к российскому сегменту Фидо (об этом говорит цифра 7), здесь собираются люди, интересующиеся хип-хоп-композициями в формате МРЗ. В связи с тем, что количество групп новостей огромно, не удобно искать группу вручную. Поэтому была придумана специальная форма поиска. Она располагается вверху окна, под словами Отобразить группы новостей, содержащие (Display newsgroups which contain). В ней вы можете ввести параметры поиска. Например, auto. Через несколько секунд из списка будут удалены (временно) группы новостей, названия которых не содержат auto.

Некоторые серверы позволяют загружать не только названия групп новостей, но и их описания. Если news-сервер, с которым вы работаете, поддерживает данную функцию, то вы можете искать ключевые слова и в поле Описание (Description).

Выберите группу или группы новостей, которые вам интересны и нажмите кнопку Подписаться (Subscribe). Группа(ы) будет помечена специальным значком

Чтобы посмотреть на группы новостей, на которые вы подписаны, выберите вкладку Выписанные (Subscribed). Там представлен список в алфавитном порядке. Нажмите кнопку ОК для продолжения.

Нажмите кнопку Синхронизировать учетную запись (Synchronize) для приема сообщений, имеющихся в выбранных группах новостей. В новом окне (рис. 15.8) вы сможете просмотреть информацию о загрузке сообщений.

Рис. 15.8. Загрузка сообщений

В связи с тем, что на сервере хранится достаточно большое количество сообщений, их загрузка может занять довольно-таки долгое время. Поэтому Outlook Express имеет два режима работы с группами новостей. В первом -программа загружает только заголовки сообщений, а сами сообщения загружаются по мере обращения. Второй способ — загружать все (или все новые). На это требуется больше времени. Первый режим работы удобен прежде всего тем, кто платит за трафик. Соответственно нет нужды загружать то, что не нужно. Второй же преимущественен для пользователей, платящих за время соединения с Интернетом -- dial-up пользователи. Получается, в независимости от количества загруженных мегабайт, пользователь платит за время, проведенное во Всемирной паутине.

Выбрать режим загрузки можно при помощи кнопки Параметры (Settings). Сначала выберите группы новостей, а затем нажмите кнопку Параметры (Settings). Вы сможете выбрать:

  • Не синхронизировать (Don't Synchronize). Выбрав данную команду, обновление сообщений в группе не будет производиться даже при общей команде синхронизации.
  • Все сообщения (All messages). Все сообщения с сервера будут загружаться всегда.
  • Только новые сообщения (New messages only). Только сообщения, которых нет у вас на компьютере, будут загружаться.
  • Только заголовки (Headers only). В данном режиме сами сообщения загружаться не будут. Правда при выборе сообщения из списка, его содержимое будет скачиваться автоматически (необходимо иметь постоянное соединение с Интернетом).

Через некоторое время сообщения будут загружены. Появилось несколько новых папок в newsgroups. Их количество зависит от количества подписанных групп.


Чтение сообщений

При помощи мыши выберите заинтересовавшую вас группу новостей. В правом окне загрузится список сообщений (рис. 15.9)

Рис. 15.9. Окно Outlook Express, просмотр сообщений из групп новостей

Просмотр, чтение сообщений аналогично просмотру электронных писем. Итак, непрочитанные сообщения выделены жирным шрифтом. В связи со спецификой групп новостей, практически в каждом сообщении вы увидите цитирование. Некоторые детали вас могут удивить.

Из заголовка сообщения вы можете узнать (по порядку): его тему, отправителя, а также дату отправки. По умолчанию сообщения отсортированы по возрастанию даты. То есть самое старое сообщение находится сверху. Сортировку легко изменить. Для этого щелкните, например, по полю Отправлено (Sent) — сообщения будут пересортированы в обратном порядке, т. е. самое новое сообщение будет находиться вверху. Аналогично можно расположить сообщения по алфавиту, имени автора. Как можно заметить из рис. 15.9, вы можете предварительно просматривать сообщения в специальной панели. Там же можно посмотреть адрес отправителя (поле От (From)), а также тему (Тема (Subject)). Для того чтобы просмотреть сообщение в отдельном окне, дважды щелкните по его названию. Новое окно (рис. 15.10) позволяет с большим удобством читать сообщение.

Рис. 15.10. Окно просмотра сообщения

Одним их преимуществ такого просмотра является возможность узнать дополнительную информацию о сообщении:

  • От (From). В данном поле можно узнать, увидеть полное имя отправителя (если он его указал).
  • Организация (Organization), в которой работает отправитель. Замечу, что указывать название организации и других данных о себе — дело добровольное.
  • Дата (Date) — дата отправки сообщения.
  • Группы новостей (Newsgroups), в которое данное сообщение было отправлено.
  • Тема (Subject) — тема сообщения.

Также в данном режиме вы можете изменить параметры просмотра сообщения.

Для того чтобы изменить размер шрифта, воспользуйтесь меню Вид (View). В нем выберите Шрифт (Text size). Самый большой по размеру шрифт находится сверху, самый маленький — снизу. Из меню Вид (View) вы также можете поменять кодировку сообщения. Например, на Windows 1251. Хотя стандартом де-факто для сети FIDO является КОИ8-Р, попадаются определенные люди, пишущие в альтернативных кодировках. Поэтому смена ее (кодировки) может оказаться кстати.

Outlook Express позволяет осуществить мониторинг флейма -- разговора. Для этого из меню Сообщение (Message) выберите команду Посмотреть обсуждение (Watch conversation).

Из основного окна вы можете выбрать сообщение или флейм, а затем пометить его как прочитанный. Для этого воспользуйтесь контекстным меню.


Создание сообщений

Для создания нового сообщения нажмите кнопку Создать (New Post) на основной панели Microsoft Outlook Express. В новом-окне (рис. 15.11) вы можете ввести текст сообщения.

Для начала выберите формат. Рекомендовано использовать Обычный текст (Plain Text), т. к. не все news-клиенты поддерживают отображения сообщений с HTML-разметкой. Чтобы изменить формат на простой текст, из меню Формат (Format) выберите команду Обычный текст (Plain Text). В том же меню вы можете задать кодировку текста. Настоятельно рекомендую -КОИ8-Р.

В поле Группы новостей (Newsgroup) вы должны ввести группу или несколько групп новостей. Вы можете сделать это вручную. Если текст печатать не хочется, можно воспользоваться функцией автоматического ввода имени. Для этого нажмите кнопку Группы новостей (Newsgroup). В появившемся окне (рис. 15.12) вы можете выбрать группы новостей, в которые данное сообщение будет отправлено. Для этого из списка слева выберите нужные news-группы и нажмите кнопку Добавить (Add). По умолчанию в списке

Рис. 15.11. Окно Создать сообщение

Рис. 15.12. Окно Выбор групп новостей...

слева отображаются только те группы новостей, на которые вы подписаны. Нажмите кнопку Отображать только те группы... (Show only subscribed groups), для того чтобы все имеющиеся группы новостей были отображены.

В поле Копия (СС) вы также можете указать адреса e-mail. Соответственно сообщение будет автоматически отправлено и в группу новостей, и обладателям e-mail. Одним из важнейших полей является Тема (Subject). Стоит правильно и корректно формулировать вопрос, реплику, что поможет сохранить и ваше время, и время другим пользователям. Например, сообщение, не имеющее темы, будет скорее всего проигнорировано.

В режиме работы с сообщениями для групп новостей вы можете воспользоваться стандартными функциями Outlook Express. Например, проверкой орфографии.

Рис. 15.13. Окно ответа на сообщение

В некоторых группах новостей принято обмениваться не только текстовой информацией, а, например, картинками или программами. Вот почему функция приложения файла, имеющаяся в Outlook Express, кажется далеко не лишней. Например, для того чтобы приложить файл к сообщению, достаточно нажать кнопку Вложить (Attach) на основной панели почтового клиента. Затем при помощи специальной оболочки найти файл, который вы хотите приложить, и нажать кнопку Вложить (Attach).

Для отправки сообщения достаточно нажатия кнопки Отправить (Send) (самая левая на основной панели).

Outlook Express также позволяет отвечать на сообщение других пользователей. Причем вы можете написать как письмо отправителю, так и сообщение в ветку, т. е. адресатам, относящимся к одной группе.

Для того чтобы отправить ответ в ветку, в окне просмотра сообщения нажмите кнопку Ответить в группу (Reply Group). В появившемся окне (рис. 15.13) вы видите текст предыдущего сообщения и как Ъы продолжаете участие в обсуждении. Например, вы можете вставить свои комментарии между строк, либо разместить их вверху или внизу сообщения. При желании, можно также изменить тему. Для отправки сообщения нажмите кнопку Отправить (Send).


Рекомендации

Здесь я решил привести некоторые рекомендации по работе с сообщениями, на что стоит обратить внимание перед отправкой сообщения.

  • Прочитайте правила соответствующих групп новостей Chartas/Netiquette)! Правила для MS-групп находятся на сайте www.eu.microsoft.com/germany /support/userhuser/netikette.htm: общепринятые во всем Usenet, например, здесь: http://home.pages.de/ ~gerlo/dni/ или в группах: news:de.newusers.mfos и news:de.newusers.questions.
  • Сначала осмотритесь, что происходит в группе.
  • Проверьте, перед тем, как повторять вопрос, не поступил ли уже на него ответ.
  • Задавайте вопрос, не относящийся к обсуждаемой теме, не в цепочке сообщений (Thread или Diskussionsfaden), а начинайте новый Thread.
  • По возможности, задавайте только один вопрос в сообщении. Если вы хотите задать несколько вопросов, создавайте для каждого вопроса отдельное сообщение.
  • Задавайте вопрос только в одной группе — избегайте одновременной отправки вопроса в несколько групп (crossposting).
  • Если в исключительных случаях кросспостинга не избежать, устанавливайте флажок Отвечать в... (Follow-Up To) только в одну группу. Это правило действует и при ответах. В открытом сообщении из меню Вид нужно выбрать команду Все заголовки и в поле Отвечать в... (Follow-Up То) выбрать или внести "одну" группу новостей, В конце сообщения указывайте, что установлен флажок Отвечать в... (Follow-Up To).
  • Квотируйте (цитируйте) не все сообщения, а только пункт, на который отвечаете. Ответ пишите "под" цитируемым вопросом/высказыванием.
  • Перепроверьте в папке Исходящие (Outbox) "перед" окончательной отправкой сообщений, правильно ли программа Outlook Express перенесла строки, и исправьте при необходимости. Ни в коем случае не посылайте прикрепленные файлы (графика, программы) в дискуссионную группу! Для этого существуют специальные группы, например news:de.alt.dateien.misc.


  • Глава 16. Автономная работа
    • Настройка IMAP-ящика
    • Настройка групп новостей
    • Работа с сообщениями
    • Чтение e-mail
    • Создание сообщений


ГЛАВА 16.

Автономная работа

Режим работы без подключения к сети Интернет называется автономным. В этом случае вы можете читать, писать сообщения. Но вы не будете иметь возможность, например, отправить или принять почту. Но зачем же нужен такой режим — можете спросить вы. Дело в том, что при использовании подключения к Интернету по телефонной линии, вы платите не за количество загруженных мегабайт, а за время на линии. Следовательно, проще и дешевле потратить 10 минут на загрузку сообщений, чем 30 на чтение в режиме online.

Поэтому возможность автономной работы является одной из важнейших в Microsoft Outlook Express.

К сожалению, в зависимости от протокола работы с почтовым сервером, настроек и т. п. автономная работа не всегда возможна без задания дополнительных параметров.

Основные проблемы могут возникнуть при работе с IMAP-ящиками и news-серверами, т. к. в Outlook Express по умолчанию установлено загружать только заголовки сообщений.


Настройка IMAP-ящика

Перейдите в папку с названием IMAP-ящика. Например, imap.mail.ru. Вы увидите следующее изображение (рис. 16.1).

Выберите папку. Например, Входящие (Inbox). Кнопка Параметры (Settings), находящаяся чуть выше, станет активной. Нажмите ее. В раскрывающемся меню вы можете выбрать:

  • Не синхронизировать (Don't Synchronize). При выборе этой команды указанная папка не будет проверяться при запуске общей команды проверки почты.

Рис. 16.1. Окно Outlook Express, IMAP-ящик

  • Все сообщения (All Messages). Все сообщения, имеющиеся в папке, будут каждый раз загружаться к вам на компьютер.
  • Только новые сообщения (New Messages Only).
  • Только заголовки (Headers Only). В данном режиме только заголовки сообщений будут загружаться. А сами сообщения — автоматически, при обращении к ним.

Для режима автономной работы наиболее хорошо подходит режим Все сообщения (All Messages) или Только новые сообщения (New Messages Only). При этом все сообщения, имеющиеся на сервере, будут загружаться на локальный компьютер. Это позволит работать с ними в режиме автономной работы.

Папки или сообщения, которые не загружены, выделены светло-серым шрифтом. Но если вы все-таки выберите сообщение, которое не загружено на ваш компьютер, появится следующее предупреждение (рис. 16.2).


Настройка групп новостей

Перейдите в папку Новости (News). Настройка синхронизации производится аналогично IMAP. Выберите группу новостей из списка подписанных. Щелкните по ней правой кнопкой мыши. Из контекстного меню выберите команду Параметры синхронизации | Только новые сообщения (Synchronization settings | New Messages Only) (рис. 16.3).

Таким образом, все новые сообщения, имеющиеся на news-сервере, будут загружаться на компьютер. Для обновления нажмите кнопку Синхронизировать учетную запись (Synchronize).

Рис. 16.2. Окно Outlook Express, просмотр сообщения

Рис. 16.3. Настройка синхронизации


Работа с сообщениями

Чтение e-mail

Чтение сообщений e-mail не должно вызвать проблем. Если вышесказанное вы выполнили, то все сообщения будут доступны в режиме автономной работы.

Итак, загрузите все сообщения с сервера. Это можно сделать нажатием кнопки Доставить (Send\Recv). Отключитесь от Интернета и перейдите в режим автономной работы. Для этого из меню Файл (File) выберите команду Работать автономно (Work Offline). В статусной строке появится специальный значок — Автономная работа


Создание сообщений

Создание, написание сообщений ничем не отличается в режиме автономной работы. Единственная деталь — сообщение не будет отправлено, пока вы не подключитесь к сети Интернет. Выберите из меню Файл (File) команду Отправить позже (Send Later) (рис. 16.4). Сообщение будет перемещено в папку Исходящие (Оutboх) и готово к отправке.

Рис. 16.4. Отложенная отправка сообщений

Для того чтобы отослать сообщение, вам потребуется выйти в сеть и воспользоваться кнопкой Доставить (Send\Recv).

Аналогичная ситуация и с отправкой сообщений в группы новостей.


  • Глава 17. Настройка
    • Настройка интерфейса
    • Стандартные настройки
    • Общие
    • Отправка и получение сообщений
    • Установки
    • Почтовые программы, используемые по умолчанию
    • Чтение
    • Чтение сообщений
    • Новости
    • Шрифты
    • Уведомления
    • Отправка сообщений
    • Отправка сообщений
    • Формат отправляемых сообщений
    • Формат отправляемых в группы новостей сообщений
    • Создание сообщения
    • Подписи
    • Обслуживание
    • Подключение
    • Безопасность
    • Правописание


ГЛАВА 17.

Настройка

Настройка интерфейса

Microsoft Outlook Express, как и большинство новых программных продуктов от Microsoft, поддерживает возможность изменения интерфейса (внешнего вида). Причем сделать это может даже самый неподготовленный пользователь.

По умолчанию, Outlook Express выглядит так (рис. 17.1).

Рис. 17.1. Окно Outlook Express, внешний вид по умолчанию

Рис. 17.2. Окно Outlook Express, внешний вид после изменения

Слева — панель папок. Чуть ниже — контакты. А справа — основное окно.

С помощью простых манипуляций можно изменить окно Outlook Express до неузнаваемости (рис. 17.2).

Итак, самое простое действие — изменение положения панелей. Как видно из рис. 17.1 и 17.2, в левом краю каждой панели имеется специальная полоска. Наведите курсор на нее и он примет форму горизонтальной, двусторонне направленной стрелки. Теперь нажмите и удерживайте левую кнопку мыши и передвигайте панель.

Если вы хотите оптимизировать пространство на экране, вы можете изменить размер, текст кнопок. Для этого подведите курсор к основной панели и в контекстном меню выберите команду Настройка (Customize). В появившемся окне - Настройка панели инструментов (Customize Toolbar) (рис. 17.3) — вы можете добавить или удалить кнопки, изменить их размер.

Слева располагается список имеющихся кнопок, которые в данный момент отсутствуют на панели инструментов. Справа — те, которые есть. Для того чтобы добавить — выделите кнопку из панели слева и нажмите кнопку Добавить (Add). Удаление происходит аналогично.

Как и в Microsoft Internet Explorer 6.0, вы имеете возможность изменить размер и подписи к кнопкам.

Рис. 17.3. Окно Настройка панели инструментов

Для того чтобы изменить размер кнопок, воспользуйтесь раскрывающимся меню Размер значка (Icon Options). Вы можете выбрать:

  • мелкие значки (Small Icons) — маленькие значки. Размер значков будет уменьшен примерно в 3 раза;
  • крупные значки (Large Icons) — большие значки. По умолчанию, эта опция установлена. Наиболее хорошо подходит для начинающих пользователей, которые еще не привыкли к символике программы.

Для того чтобы изменить текст, воспользуйтесь раскрывающимся меню Текст кнопки (Text Options):

  • выводить подписи (Show Text Labels) — отображать текстовые подписи к кнопкам. По умолчанию установлен этот режим;
  • выборочно текст справа (Selective Text on Right) — текстовые надписи будут располагаться справа от кнопки (а не под ней). Причем только рядом с некоторыми, наиболее важными кнопками;
  • не выводить подписи (No Text Labels) — текстовые подписи отсутствуют. Этот режим подходит, прежде всего, профессионалам, хорошо знающим символику Outlook Express, не нуждающимся в пояснительных надписях. Но даже если вы случайно поставили этот режим, вы все равно сможете увидеть текстовую подсказку. Для этого подведите курсор к кнопке и подождите несколько секунд.

При помощи механизма перетаскивания вы можете изменить положение только нескольких. Для того чтобы добавить или удалить панели, воспользуйтесь специальным приложением Настройка окна (Windows layout) (рис. 17.4).

Рис. 17.4. Окно Свойства: Настройка окна

Для того чтобы запустить его, из меню Вид (View) выберите команду Раскладка (Layout). В появившемся окне (рис. 17.4) вы можете добавить или удалить панели нажатием всего одной клавиши.

Панели, доступные для отображения:

  • контакты (Contacts) — панель контактов. В ней вы можете посмотреть на список, людей, имеющихся в вашей адресной книге;
  • панель папок (Folder Bar) — панель, на которой отображается название папки;
  • список папок (Folder List). На ней представлены все папки, подпапки и т. д.;
  • панель Outlook (Outlook Bar). На панели также представлен список папок, но в несколько другой форме. К сожалению, при наличии нескольких почтовых ящиков работать с этой панелью очень сложно;
  • строка состояния (Status Bar). В ней выводится информация о текущем состоянии программы. Например, Автономная работа (Working Offline);
  • панель инструментов (Toolbar) — основная панель. На ней представлены кнопки для наиболее удобного управления программой;
  • панель представлений (Views Bar). При активизации появляется раскрывающееся меню, в котором вы можете выбрать параметры отображения сообщений.
    • Отобразить все сообщения (Show All Messages) — отображать все сообщения, в независимости от их статуса.
    • Скрыть прочитанные или пропущенные сообщения (Hide Read or Ignored Messages) — не отображать прочитанные или игнорируемые сообщения. В этом режиме будут показываться только новые, непрочитанные сообщения, не имеющие статус игнорируемые.
    • Скрыть прочитанные сообщения (Hide Read Messages) — не отображать прочитанные сообщения. Следовательно, в этом режиме будут показываться все сообщения, кроме прочитанных.

Для того чтобы та или иная панель отображалась, установите флажок перед ее названием и нажмите кнопку ОК.

В этом же окне вы можете изменить настройки панели предварительного просмотра.

Если снять флажок Область просмотра (Show preview pane), панель предварительного просмотра просто не будет отображаться. При установленном флажке, вы можете изменить ее положение.

  • под сообщениями (Below Messages). To есть сверху находится список электронных писем, а под ним — панель предварительного просмотра.
  • рядом с сообщениями (Beside Messages) — в данном режиме панель предварительного просмотра находится справа от списка сообщений. По моему мнению, данный режим работы очень неудобен.

По умолчанию, в панели предварительного просмотра отображается заголовок сообщения — от кого пришел, тема, кому предназначается. Если вы не хотите, чтобы он показывался, снимите флажок Отображать заголовок области просмотра (Show preview pane header).


Стандартные настройки

Для того чтобы получить доступ к стандартным настройкам из меню Сервис (Tools), выберите команду Параметры (Options). Появится новое окно. Выберите вкладку Общие (General) — Общие настройки (рис. 17.5).

Вкладка разделена на несколько частей: Общие (General), Отправка и получение сообщений (Send/Receive Messages arrive) и Почтовые программы, используемые по умолчанию (Default Messaging programs).

Рис. 17.5. Окно Параметры, вкладка Общие


Общие

Здесь вы можете указать параметры работы программы при запуске и не только.

  • При запуске сразу открывать папку "Входящие" (When starting, go directly to my 'Inbox' folder). При установленном флажке, каждый раз при загрузке будет осуществляться автоматический переход в папку Входящие (Inbox).
  • Уведомлять о наличии новых групп новостей (Notify me if there are any new newsgroups). Программа будет изредка проверять news-сервер на наличие новых групп новостей.
  • Автоматически показывать папки с непрочитанными сообщениями (Automatically display folders with unread messages). Это относится как к электронной почте, так и группам новостей.


Отправка и получение сообщений

В этой части вы можете установить параметры работы программы при получении, отправлении электронной корреспонденции. Например, вы можете установить звуковое сопровождение при приеме нового сообщения.


Установки

  • Звуковое уведомление при получении новых сообщений (Play sound when new messages arrive) — проигрывать звуковой файл при получении нового сообщения e-mail. К сожалению, вы не можете установить, собственный звуковой сигнал.
  • Доставлять почту в начале работы (Send and receive messages at startup). При снятом флажке сообщения не будут ни отправляться, ни приниматься при открытии программы. Это может быть нужно, если вы часто читаете сообщения в режиме автономной работы.
  • Проверять новые сообщения каждые ... мин (Check for new messages every). Проверять почтовый ящик на наличие новых сообщений каждые хх минут, где хх — количество минут. Если вам часто приходят письма, рекомендуемым может стать значение из диапазона 5—7.
  • Если компьютер в это время не подключен к сети (If my computer is not connected at this time:) — что делать, если компьютер не подключен к Интернету:
    • Не соединять (Do not connect);
    • Соединять, если не выбран режим автономной работы (Connect only when not working offline);
    • Подключать даже в автономном режиме (Connect even when working offline). При выборе данной команды, даже в режиме offline, программа будет пытаться соединиться с Интернетом.


Почтовые программы, используемые по умолчанию

В данной части вы можете сделать Outlook Express почтовым и news-клиентом по умолчанию.

Для того чтобы сделать Microsoft Outlook Express почтовым клиентом, нажмите кнопку Использовать по умолчанию (Make Default), расположенную рядом с кнопкой Данная программа НЕ является основной программой обработки (This application is NOT the default Mail handler).

Если вы хотите сделать почтовую программу от Microsoft программой для чтения новостей, также нажмите кнопку Использовать по умолчанию (Make Default).

Возможно, вы зададитесь вопросом, зачем это нужно. Все очень просто, многие программы, при обращении к некоторым ссылкам, ресурсам, могут автоматически запускать программу, предназначенную для работы с ними. Вот почему это может оказаться полезным.


Чтение

Во вкладке Чтение (Read) (рис. 17.6) вы можете установить параметры чтения сообщений.

Рис. 17.6. Окно Параметры, вкладка Чтение


Чтение сообщений

Вы можете, задать некоторые параметры работы с сообщениями.

Например, вас всегда раздражало время, за которое сообщение становилось прочитанным — 5 секунд. В данной вкладке вы можете это с легкостью изменить — воспользуйтесь полем Сообщения помечать как прочитанные после просмотра в течение ... сек (Mark message read after displaying for ... seconds). Таким образом, вместо ... введите нужное время.

Другие параметры:

  • Автоматически загружать сообщение при отображении в области просмотра (Automatically download message when viewing in the Preview Pane). При снятом флажке сообщение будет загружаться только в том случае, если оно открыто в собственном окне — двойной щелчок по его названию;
  • Отображать подсказки в списке сообщений для присоединенных файлов (Show ToolTips in the message list for clipped items). Если флажок установлен при наведении курсора на сообщение, будет отображаться всплывающая подсказка с его названием, датой приема и т. д.;
  • Выделять просмотренные сообщения следующим цветом (Highlight watched messages). Из раскрывающегося меню вы можете выбрать цвет. Например, красный.


Новости

В пункте Новости (News) вы можете указать параметры работы с группами новостей. Например, количество заголовков сообщений, получаемых в единицу времени — поле Загружать (Get). Если вы хотите, чтобы пометка о чтении устанавливалась на всех сообщениях каждый раз при выходе из группы новостей, установите флажок Пометить все сообщения при выходе как прочитанные (Mark all messages as read when exiting a newsgroup).


Шрифты

Одним из важнейших параметров является шрифт. Ведь всегда приятно читать сообщения, а еще приятнее, когда они выглядят так, как вам хочется. В данном пункте вы можете изменить не только шрифт, но также его кодировку, размер.

Чтобы это сделать нажмите кнопку Шрифты (Fonts). В появившемся окне вы можете указать необходимый шрифт для каждой языковой группы, а также его размер и кодировку. Например, для Кириллицы вы имеете возможность установить четыре различных типа кодировки:

  • КОИ8-Р;
  • КОИ8-У;
  • ISO;
  • Windows.

Рекомендуется установить кодировку КОИ8-Р.

Нажатие на кнопку Выбор языка (International Settings) вызывает окно, в котором вы можете указать кодировку по умолчанию для всех исходящих сообщений. В противном случае она устанавливается автоматически.


Уведомления

В Microsoft Outlook Express вы имеете возможность создать уведомление о доставке. Например, вы пишете сообщение и хотите узнать, прочитал ли его (после отправки) получатель или нет. В зависимости от установок, уведомление о прочтении будет вам выслано.

Итак, если вы хотите получать уведомления о прочтении, установите флажок Запрашивать уведомление о прочтении для всех отправляемых сообщений (Requesting Read Receipts).

Естественно, что не только вы можете требовать уведомление о прочтении, но и другие пользователи. Поэтому при получении сообщения с запросом о прочтении вы можете либо автоматически его отправлять, либо не отправлять вообще, либо программа будет спрашивать вас.


Отправка сообщений

Во вкладке Отправка сообщений (Send) (рис. 17.7) вы можете задать параметры для исходящих сообщений.

Рис. 17.7. Окно Параметры, вкладка Отправка сообщений


Отправка сообщений

Параметры отсылки сообщений можно задать здесь. Вы можете задать следующие настройки:

  • Сохранять копию в папке "Отправленные" (Save copy of sent messages in the 'Sent Items' folder). Если флажок снят — исходящие сообщения будут автоматически удаляться после отсылки.
  • Сразу отправлять сообщения (Send messages immediately). Если флажок снят — сообщения будут помещаться в папку Исходящие (Outbox). Для того чтобы отправить их, нужно будет воспользоваться кнопкой Доставить (Send\Recv).
  • Автоматически подставлять адреса при создании сообщения (Automatically complete e-mail addresses when composing). Это возможно, только если адрес уже был единожды набран. Например, вы написали сообщение user@user.ru. В следующий раз при вводе user вторая часть адреса уже будет дописана автоматически.
  • Включать в ответ текст исходного сообщения (Include message in reply). При установленном флажке в конце исходящего сообщения будет вставлен текст оригинала.
  • Отвечать в формате исходных сообщений (Reply to messages using the format in which they were sent). Например, письмо было отправлено в формате HTML, ответ будет создан также с HTML-разметкой.


Формат отправляемых сообщений

В данном поле вы можете указать формат сообщений e-mail — HTML, либо Обычный текст (Plain Text).

Вы можете изменить настройки для HTML-писем. Нажмите на кнопку Настройка HTML (HTML settings). Появится новое окно — рис. 17.8.

Рис. 17.8. Окно Настройка HTML

Вы имеете возможность изменить способ кодирования текста:

  • Нет (None);
  • Допущено к печати (Quoted Printable);

Если выбрать Нет (None) — кодировка текста производиться не будет. Некоторые почтовые сервера не поддерживают восьмибитные символы в заголовках. Поэтому рекомендуется снять флажок Разрешить использование 8-битовых знаков в заголовках (Allow 8-bit characters in headers).

Вы также можете установить другие параметры:

  • Отправлять рисунки вместе с сообщениями (Send pictures in headers). Если, получатель не имеет возможности получить доступ к изображению, например, в сети Интернет, установите флажок в этом поле;
  • Отступ текста сообщения при ответе (Indent message on reply). Задание смещения текста исходного сообщения при включении его в ответ. Если смещение не выбрано, все сообщение будет выровнено по левому краю.

Нажмите кнопку ОК для продолжения.

Если вы выбрали в качестве формата исходящих сообщений Обычный текст (Plain Text), стоит указать некоторые параметры. Для этого нажмите на кнопку Настройка обычного текста (Plain Text settings). В новом окне (рис. 17.9) вы получите доступ к расширенным настройкам параметров работы с Обычным текстом (Plain Text).

Рис. 17.9. Окно Настройка обычного текста

Для начала вам стоит выбрать формат текстовых сообщений — MIME или UUEncode. По умолчанию установлен MIME, кодировка текста также отсутствует. Я бы не рекомендовал использовать, например UUencode или MIME с кодировкой, так как нет никакой гарантии, что почтовая программа получателя сможет корректно обработать текстовое сообщение.

При ответе на сообщение с цитированием используется специальный символ. Его вы можете выбрать из раскрывающегося меню — Отступ исходного текста на > знаков при ответе и пересылке (Indent the original text with). Если же вы хотите, чтобы цитирование вообще никак не помечалось — снимите флажок в соответствующем поле.


Формат отправляемых в группы новостей сообщений

В данной графе вы можете выбрать формат сообщений, отправляемых в группы новостей — HTML или Обычный текст.


Создание сообщения

Во вкладке Создание сообщения (Compose) (рис. 17.1.0) вы можете указать основные шрифты, используемые в сообщениях e-mail. Например, в группе параметров Шрифт нового сообщения (Compose Font) вы указываете шрифт, применяемый в исходящих e-mail и news-сообщениях. На мой взгляд, наилучшим можно назвать Tahoma.

Многие пользователи предпочитают использовать собственный стиль, внешний вид сообщений. Для этого применяются шаблоны. В комплекте с Microsoft Outlook Express 6.0 имеется достаточно неплохая коллекция. Если же не один из них вам не подошел, вы можете создать новый, отвечающий всем вашим требованиям. Чтобы в дальнейшем использовать шаблон при отправке почтовых и news-сообщений, укажите его в группе параметров Бланк (Stationery). Итак, установите флажок Почта (Mail) и/или Новости (News), а далее выберите необходимый из списка.

Outlook Express позволяет отправлять вашу бизнес-карту с каждым исходящим сообщением. Правда, по умолчанию данная опция отключена. Воспользуйтесь группой параметров Визитные карточки (Business Cards), для того чтобы научить программу прикладывать бизнес-карту к каждому сообщению.


Подписи

Возможности Outlook Express практически безграничны (в отношении работы с электронными письмами). Программа обладает возможностью создавать подписи под каждым сообщением. Чтобы создать, настроить их, воспользуйтесь вкладкой Подписи (Signatures).

Для начала стоит создать подпись. Для этого нажмите кнопку Создать (New) в поле Подписи (Signatures). Появится надпись Подпись #1 Основная подпись(Signature #1 Default signature). Вы можете в любое время ее переименовать.

Теперь стало доступно поле Изменить подпись (Edit signature). В специальном поле Текст (Text) вы можете набрать текст. Например/"С наилучшими пожеланиями". Если у вас есть текстовый файл с вашей подписью, укажите путь к нему в поле Файл (File).

Рис. 17.10. Окно Параметры, вкладка Создание сообщения

Создав или настроив подпись, вы захотите, чтобы она появлялась в конце каждого сообщения. Для этого требуется установить флажок Добавлять подпись ко всем исходящим сообщениям (Add signatures to all outgoing messages). При установленном флажке Не добавлять подпись к ответам и пересылаемым сообщениям (Don't add signatures to Replies and Forwards) подпись не будет добавлять в ответные или переадресовываемые сообщения.

Программа позволяет создать неограниченное число подписей. Но не делайте их слишком много — сообщение сильно потяжелеет, отправка станет медленнее, как и прием.


Обслуживание

К сожалению, даже почтовой программе требуется обслуживание. Во вкладке Обслуживание (Maintenance) вы можете сделать именно это (рис. 17. 11).

Если ваша система итак перегружена приложениями и размер дискового пространства невелик, вы можете задать, например, сжатие сообщений e-mail или, скажем, удаление из папки Удаленные (Trash) и т. д. Для этого воспользуйтесь соответствующими полями, кнопками.

  • Очищать папку "Удаленные" перед выходом (Empty messages from the 'Deleted Items' folder on exit). Таким образом, вы сможете сэкономить некоторое дисковое пространство.
  • Уничтожать удаленные сообщения при выходе из папок IMAP (ШАР Purge deleted messages when leaving IMAP folders). При снятом флажке все сообщения, помеченные как удаленные, так и останутся помеченными. В противном случае — они будут навсегда уничтожены.
  • Сжимать сообщения в фоновом режиме (Compact messages in the background). При установленном флажке все сообщения будут сжиматься незаметно для пользователя, прямо во время работы.
  • Удалять прочитанные сообщения из групп новостей (Delete read message bodies in newsgroups). Может использоваться как для экономии дискового пространства, так и для более рациональной работы.
  • Удалять сообщения групп новостей (Delete news messages) — удалять новости сообщения через ** дней после загрузки, где ** — количество дней. Если флажок снят, сообщения вообще удаляться не будут (автоматически).

Рис. 17.11. Окно Параметры, вкладка Обслуживание

  • Сжимать сообщения (Compact messages) — сжимать сообщения, при указанном проценте. Опять же рекомендуется при ограниченных системных ресурсах.
  • Очистить (Clean Up). Нажатие этой кнопки может разом удалить все имеющиеся на компьютере сообщения. Прежде чем удалять, подумайте, нужно ли это вам.
  • Банк сообщений (Store Folder). Вы можете изменить его положение. Это может потребоваться в случае переустановки операционной системы и желании сохранить имеющуюся базу сообщений.

Программа обладает возможностью вести статистику всех соединений, что позволит выявить причины ошибок и т. д. В графе Устранение неполадок (Troubleshooting) укажите протоколы, работу по которым вы хотите просмотреть.


Подключение

Во вкладке Подключение (Connection) вы можете задать параметры соединения с Интернетом, работы с почтой (рис.17.12).

Рис. 17.12. Окно Параметры, вкладка Подключение

Часто вы заходите в Интернет только для того, чтобы проверить почту, сообщения в группах новостей. Ранее вам приходилось вручную соединяться/отсоединяться после получения необходимой информации. Новая версия программы Outlook Express позволяет сделать это автоматически — получив сообщения, приложение отсоединится от Интернета. Для этого достаточно установить флажок Разрывать связь после отправки и получения сообщений (Hang up after sending and receiving).

Microsoft Internet Explorer и Outlook Express имеют общие сетевые настройки. Поэтому, изменив, например, настройки в обозревателе, они изменятся и в Outlook Express.


Безопасность

Как любая современная программа, работающая с конфиденциальной информацией, Outlook Express позволяет задать уровень безопасности. Для того чтобы воспользоваться специальными настройками, откройте вкладку Безопасность (Security).

В первой группе параметров — Защита от вирусов (Virus protection), вы можете выбрать зоны безопасности.

  • Зона Интернета (Internet zone). В данном случае функциональность повышается, но безопасность понижается. В этом режиме вам будут доступны все сайты, ссылки на которые имеются в почтовых сообщениях.
  • Зона ограниченных узлов (Restricted sites zone). Этот режим рекомендован, т. к. является более безопасным.

Иногда программы пытаются воспользоваться вашей наивностью — послать одно или несколько сообщений от вашего имени. Outlook Express позволяет пресечь это — достаточно установить флажок Предупреждать, если приложения пытаются отправить почту от моего имени (Warn me when other applications try to send mail as me). Таким образом, при попытке отправки несанкционированного сообщения появится специальное окно, оповещающее вас об этом.

Интернет — небезопасное место. Многие хакеры, узнав ваш адрес e-mail, могут попытаться отправить вам письмо с вложенным файлом. В тексте вас будут всячески убеждать открыть этот файл, говоря, что это или картинка, или ускоритель Интернета, или еще что-то очень ценное. Outlook Express обладает возможностью приостановить открытие таких файлов, а также сохранение их на жесткий диск. Для того чтобы активизировать данную функцию, установите флажок Не разрешать сохранение или открытие вложений, которые могут содержать вирусы (Do not allow attachments to be saved or opened that could potentially be a virus).

Outlook Express, как и Microsoft Internet Explorer, позволяет работать с цифровыми удостоверениями. О том, как получить цифровую- подпись, было рассказано в предыдущей части. Итак, вы имеете возможность не только отправлять подписанные письма, но также и зашифрованные. Для того чтобы включить данную функцию, установите флажок Шифровать содержимое и вложения всех исходящих сообщений (Encrypt contents and attachments for all outgoing messages). А если вы хотите подписывать сообщения, установите флажок Подписывать все отправляемые сообщения (Digitally sign all outgoing messages).

Для продвинутых пользователей существуют специальные настройки. Нажмите кнопку Дополнительно (Advanced) для открытия специального окна (рис. 17.13).

Рис. 17.13. Окно Дополнительные параметры безопасности

В группе параметров Шифрованные сообщения (Encrypted messages) вы можете установить предупреждение о невысокой степени шифровании. Например, при длине ключа 56 бит. Установив флажок Шифровать при отправке шифрованной почты самому себе (Always encrypt to myself when sending encrypted mail), программа будет автоматически шифровать все исходящие сообщения.

В группе параметров Сообщения с цифровой подписью (Digitally Signed certificates) вам представляется возможность установить автоматическое вложение персональной цифровой подписи в каждое сообщение — Добавлять мой сертификат при отправлении сообщений с подписью (Always encrypt to myself when sending encrypted mail).

Другие поля:

  • Кодировать сообщения перед подписыванием (непрозрачная подпись) (Encode message before signing (opaque signing)). Это позволит избежать деформации персонального сертификата. К сожалению, пользователи почтовых программ, не поддерживающих S/MIME, не смогут прочитать это сообщение.
  • Автоматически добавлять сертификат отправителя в адресную книгу (Add sender's certificates to my address book)

Outlook Express позволяет автоматически проверять подлинность сертификатов. Вы можете установить проверку подлинности в двух режимах: когда вы находитесь в Интернете или никогда.


Правописание

Outlook Express обладает возможностью проверки орфографии. Перейдите во вкладку Правописание (Spelling) для настройки данной функции.

Для того чтобы проверка орфографии осуществлялась автоматически перед отправкой сообщения, установите флажок Всегда проверять правописание перед отправкой (Always check spelling before sending). Программа также может предлагать замены для ошибочных слов. Если вы не хотите, чтобы они появлялись, снимите флажок Предлагать замену слов с ошибками (Suggest replacements for misspelled words).

При проверке орфографии, вы можете установить игнорирование следующих ошибок:

  • слова, набранные ПРОПИСНЫМИ БУКВАМИ (Words in UPPERCASE).

При снятом флажке, программа будет говорить об ошибке;

  • слова, содержащие цифры (Words with numbers), например, Windows 98;
  • исходный текст (при ответе и пересылке) (The original text in a reply or forward), в данном случае текст оригинального сообщения проверяться не будет;
  • адреса Интернета (Internet Addresses), например, http://www.microsoft.com .


  • Глава 18. Выбор оптимальной конфигурации Microsoft Outlook Express
    • "Горячие" клавиши
    • Значки списка сообщений Outlook Express
    • Защита данных


ГЛАВА 18.

Выбор оптимальной конфигурации Microsoft Outlook Express

"Горячие" клавиши

Для того чтобы ускорить доступ к некоторым функциям программы, стоит использовать так называемые "горячие" клавиши (табл.18.1—18.5).

Таблица 18.1. Основное окно, окно отображения сообщения и окно отправки сообщения

Действие | Клавиши
Открытие разделов справки Выделение всех сообщений | <F1> <Ctrl>+<A>

Таблица 18.2. Основное окно и окно отображения сообщения

Действие | Клавиши
Печать выделенного сообщения | <Ctrl>+<P>
Отправка и получение почты | <Ctrl>+<M>
Удаление сообщения | <Del> или <Ctrl>+<D>
Открытие или создание сообщения | <Ctrl>+<N>
Открытие адресной книги | <Ctrl>+<Shift>+<B>
Ответ автору сообщения | <Ctrl>+<R>
Пересылка сообщения | <Ctrl>+<F>
Ответ всем | <Ctrl>+<Shift>+<R> или <Ctrl>+<G>, (только новости)

Действие | Клавиши
Переход в папку "Входящие" Переход к следующему сообщению в списке Переход к предыдущему сообщению в списке Просмотр свойств выделенного сообщения Обновление заголовков и сообщений новостей Переход к следующему непрочитанному сообщению Переход к следующему непрочитанному обсуждению группе новостей Переход в папку | <Ctrl>+<I> <Ctrl>+ или <Ctrl>+<Shift> <Ctrl>+ или <Ctrl>+<Shift> <Alt>+<Enter> <F5> <Ctrl>+<U> <Ctrl>+<Shift>+<U> <Ctrl>+<Y>

Таблица 18.3. Основное окно

Действие | Клавиши
Открытие выделенного сообщения | <Ctrl>+<O> или <Enter>
Пометка сообщения как прочитанного | <Ctrl>+<Enter> или <Ctrl>+<Q>
Переход от списка папок (если включен) к списку сообщений, области просмотра и списку контактов (если включен) | <Tat>
Пометка всех новостей как прочитанных | <Ctrl>+<Shift>+<A>
Переход в группу новостей | <Ctrl>+<W>
Раскрытие обсуждения в группе новостей (отображение всех ответов на сообщение) | Стрелка влево или знак "плюс" (+)
Свертывание обсуждения в группе новостей (скрытие сообщений) | Стрелка вправо или знак "минус" (-)
Переход к следующей непрочитанной группе новостей или папке | <Ctrl>+<J>
Загрузка новостей для чтения в автономном режиме | <Ctrl>+<Shift>+<M>

Таблица 18.4. Окно сообщения — просмотр или отправка

Действие | Клавиши
Закрытие сообщения Поиск текста | <Esc> <F3>

Действие | Клавиши
Поиск сообщения Переход между вкладками Правка, Источник и Просмотр | <Ctrl>+<Shift>+<F> <Ctrl>+<Tab>

Таблица 18.5. Окно сообщения — только отправка

Действие | Клавиши
Проверка имен | <Ctrl>+<K> или <Alt>+<K>
Проверка правописания | <F7>
Вставка подписи | <Ctrl>+<Shift>+<S>
Отправка (размещение) сообщения | <Ctrl>+<Enter> или <Alt>+<S>


Значки списка сообщений Outlook Express

В Outlook Express используются специальные значки. В следующей таблице приводится их значение (табл. 18.6).


Защита данных

Электронная почта все сильнее и сильнее входит в нашу жизнь. Причин много — отправка и прием сообщений e-mail занимают считанные секунды. О том, как настроить почту, говорилось в предыдущих главах.

Идеальный вариант, когда вы ведете личную переписку с домашнего компьютера, а деловую — с офисного. К сожалению, в большинстве случаев это не так. Есть много разных ситуаций, при которых работа с электронной почтой оказывается не так проста, как кажется. Предположим, вы заболели, и вам приходится вести деловую переписку с домашнего компьютера. Этот вариант еще ничего.

Но если вы ведете личную переписку с офисного компьютера, это уже намного хуже. Все дело в том, что такой компьютер является собственностью компании, которая в свою очередь имеет полное право просматривать, изменять, удалять файлы, корреспонденцию и т. д. И вот если выяснится, что на рабочем компьютере вы выполняли работу, не имеющую отношение к работодателю, вас, вероятно, уволят. Причем данный вариант будет еще не самым худшим.

На отдыхе, в командировке, вам, возможно, понадобится получить доступ к своему почтовому ящику. И, скорее всего, вы пойдете в интернет-кафе. Необходимо помнить, что при неаккуратной работе ваши личные данные могут стать известны разным людям. Поэтому требуется быть чрезвычайно осторожным.

Обязательно заведите себе почтовый ящик на одном из серверов, типа Mail.ru. Это позволит вам иметь возможность работы со своей почтой не только при помощи почтового клиента, но и через веб-интерфейс.


  • Глава 2. Знакомство с обозревателем Microsoft Internet Explorer 6.0
    • Зачем разрабатывался Internet Explorer 6.0
    • Работа с Интернетом никогда не была такой легкой
    • IntelliSense ускоряет работу
    • Гибкость при использовании
    • Выгодное решение для интернет-путешествий


ГЛАВА 2

Знакомство с обозревателем Microsoft Internet Explorer 6.0

Чтобы просматривать веб-страницы, нужна специальная программа — браузер (browser). В Интернете находятся миллионы веб-страниц, и программа просмотра — ваш ключ к поиску необходимой информации. Умея пользоваться этой программой, вы сможете получить даже ту информацию, о существовании которой не подозревали. Но если вы не знаете, как управлять данными, то можете немало времени потратить впустую.

Любой браузер предназначен для того, чтобы интерпретировать коды HTML и выводить страницу на экран. При использовании различных браузеров внешний вид страницы может быть разным. Это связано с тем, что коды HTML не определяют точный вид страницы. Оформление страниц описывается лишь в общих чертах, а сам браузер отвечает за ее отображение. Но, несмотря на это, браузеры на совершенно разнородных компьютерах могут обеспечить вполне адекватные отображения одной и той же страницы.

Итак, браузер — это WWW-клиент, предназначенный для интерактивной работы с пользователем. Насчитывается несколько десятков браузеров, полный список которых вы можете увидеть по адресу http://www.browserwatch.com . Наиболее распространенными браузерами являются Microsoft Internet Explorer и Netscape Navigator.

Браузером Netscape пользуются менее 20% сетевого населения. Это пакет, вобравший в себя полный набор средств связи с Интернетом, а также предоставляющий очень широкую поддержку HTML и других важных веб-технологий.

Браузер Microsoft Internet Explorer используют порядка 80% людей. Этот программный продукт поставляется вместе с популярной операционной системой Windows и является наиболее серьезным конкурентом Netscape. Браузер поддерживает многие из новшеств, введенных Netscape, а также содержит собственные передовые технологии, поддерживает все уровни HTML. Интерфейс этого браузера очень удобен для тех, кто уже знаком с другими продуктами Microsoft. Internet Explorer версии 6.0 включает наиболее современные методы поиска, просмотра и управления информацией, поступающей из Интернета.

Рост популярности Интернета и его быстрая эволюция от возможности обыкновенного просмотра статического содержимого, т. е. типичных вебстраниц, до богатой платформы для публикации документов, мультимедиа-приложений, коммерции и т. д. привела к необходимости создания браузеров, которые бы отвечали требованиям времени. Интернет-обозреватели играли ключевую роль в эволюции сети. С каждым новым браузером появлялось все больше и больше возможностей для создания наиболее интересных сайтов, с удивительным мультимедийным содержанием. С каждым появлением удачного браузера пользователи замечали как минимум одну новую деталь, которую было бы необходимо иметь в программе, чтобы полностью соответствовать веяниям времени. Корпорация Microsoft всегда следила за тем, чтобы ее продукты отвечали стандартам времени, а иногда даже обгоняли пожелания пользователей.

Первый сдвиг в требованиях к браузерам произошел тогда, когда пользователи и технологи увидели потенциал веб как платформы для интерактивных, динамических презентаций различных типов контента (содержания). Пользователям хотелось видеть больше интерактива, работать с "живыми" веб-страницами, а не просто статичными серыми сайтами, выполненными в минималистской манере.

Дело в том, что и пользователи, и люди, создававшие веб-сайты, хотели, чтобы технологии создания, публикации веб-страниц были основаны на открытых интернет-стандартах. Это было нужно, чтобы каждый обладатель браузера мог видеть страницу именно в том виде, в каком она была задумана и создана автором. Вот для чего были созданы такие организации, как World Wide Web Consortium (W3C) и Internet Engineering Task Force (IETF) которые регулировали использование тех или иных стандартов для создание веб-страниц.

С появлением Microsoft Internet Explorer 2 компания Microsoft первой создала поддержку открытых интернет-стандартов, таких как HTML (HyperText Markup Language) и HTTP (HyperText Transfer Protocol). И с каждым последующим поколением Internet Explorer компания Microsoft значительно увеличила свою роль в создании и поддержке интернет-стандартов, также плотно работая с W3C и IETF.

Как только браузер начал поддерживать интернет-стандарты, стало появляться все больше и больше веб-сайтов. Пользователи хотели использовать веб-технологии, а также получить наиболее легкий доступ к веб при помощи приложений, например программ для работы с документами или e-mail-клиентами. Интернет имел огромный потенциал для обеспечения работы стандартных программ. Однако для разработки интернет-технологий с нуля требовалось много времени. Пользователи же хотели получить все сразу и быстро.

Компания Microsoft потратила немало времени для того, чтобы сделать Интернет более дружелюбным и удобным для конечного пользователя. Все свои идеи, заготовки были реализованы в Microsoft Internet Explorer 3.0. В новом браузере использовалась модульная архитектура, что давало возможность разработчикам использовать технологии Internet Explorer в собственных приложениях.

На сегодняшний день пользователи имеют возможность работать с различными веб-технологиями при помощи приложений, которые в принципе не были предназначены для работы с Интернетом, а также могут выбирать между различными браузерами.

Тысячи разработчиков программного обеспечения до сих пор используют технологии Microsoft Internet Explorer, для того чтобы доставить радость людям по всему миру.

Технический прогресс вынуждает разработчиков создавать новые приложения, тесно связанные с Интернетом. До недавнего времени между работой с Интернетом и вашим персональным компьютером была большая разница. Чтобы работа с Интернетом не сильно отличалась от работы с приложениями на ПК, нужна была новая платформа.

И она появилась. Был создан Microsoft Internet Explorer 4.0, который был интегрирован в операционную систему Windows 98. Тем самым интернет-технологии стали больше использоваться в операционной системе. Это позволило пользователям работать с ОС более продуктивно, а если появлялась необходимость что-либо найти или улучшить, предлагалась работа с Интернетом, в котором "найдется все".

Позднее компания Microsoft создала и выпустила браузер Microsoft Internet Explorer 5.0, который мало чем отличался от своего предшественника.


Зачем разрабатывался Internet Explorer 6.0

Программисты из Microsoft осознали, что браузеры на сегодняшний день не позволяют пользователю быстро и надежно найти то, что он ищет, организовать Избранное, работать с Журналом и интерактивным контентом, работать с интернет-приложениями. Также в Microsoft считали, что необходимо достичь полной интеграции с Интернетом.


Работа с Интернетом никогда не была такой легкой

Пользователи требовали от Microsoft упростить использование браузера, убрать ненужные шаги и т. д. Корпорация Microsoft, понимая, что действительно может понадобиться пользователю, разработала технологию IntelliSense. Она существенно упрощает работу с веб, например поиск информации. Для

, упрощения доступа к сайтам были усовершенствованы Избранное и Журнал. Эти коренные изменения позволяют пользователю еще более комфортно работать в Интернете.


IntelliSense ускоряет работу

Интернет используется как дома, так и на работе. Поэтому повторения тех же самых операций может стать достаточно занудным делом. В Microsoft Internet Explorer 6.0 включена технология IntelliSense, которая позволяет автоматизировать большинство задач, поставляемых пользователем. Автозаполнение было впервые представлено n Internet Explorer 4.0. К версии 6.0 эта функция претерпела значительные изменения в лучшую сторону. Теперь работа с формами, ввод паролей, веб-адресов можно полностью автоматизировать, что существенно сокращает время, затрачиваемое па выполнение данного рода задач.


Гибкость при использовании

На сегодняшний день браузер стал такой же необходимой программой, как, например, текстовый редактор Microsoft Word. Вот почему он должен полностью удовлетворять потребности пользователя. Для многих причиной приобретения персонального компьютера стала необходимость работы с Интернетом. Естественно, что люди все разные, у них разные потребности, цели и задачи. Браузер же, как и любая другая программа, должна удовлетворять потребности различных пользователей, быть гибкой в использовании. Сейчас существует огромное количество сайтов в Интернете. Некоторые из них — это обыкновенные домашние ^страницы, другие — огромные порталы. Microsoft Internet Explorer не принуждает вас использовать тот или иной сайт в качестве домашней страницы. Вы всегда можете изменить ее с легкостью.

Сегодня важно, чтобы браузер отвечал потребностям не только домашнего пользователя, но и бизнесмена, служащего. Internet Explorer 6.0 позволяет работать с прогрессивными технологиями. Теперь можно работать с электронными биржами без использования дополнительного программного обеспечения. Смотреть результаты торгов, работать с интерактивным контентом. И все это без использования дополнительных программ. Internet Explorer 6.0 имеет, например, технологию SmartEdit, которая позволяет редактировать HTML-документы "на лету", достаточно лишь выбрать меню Правка (Edit) на панели браузера.


Выгодное решение для интернет-путешествий

Пользователям не нравился большой размер дистрибутива, который приходилось долго загружать, да и тратить на это деньги. Пользователям и разработчикам требовалось больше контроля над браузером, количеством компонентов и т. д. Теперь они это имеют. При загрузке дистрибутива из Интернета вы можете выбрать компоненты. Например, загружать или не загружать Microsoft Outlook Express или же поддержку китайского языка. На первый взгляд, это кажется мелочью. Но именно из таких мелочей складывается впечатление о программном продукте, и именно эти (и многие другие) сделали Microsoft Internet Explorer браузером номером один.

Internet Explorer прошел большой путь, начиная от маленького неудобного браузера и заканчивая таким великолепным программным продуктом, как Internet Explorer 6.0.


  • Глава 3. Начало работы с Интернетом
    • Подключение к Интернету при помощи Мастера подключения.
    • Подключение к Интернету с помощью модема
    • Первый способ
    • Второй способ
    • Подключение вручную или при наличии локальной сети
    • Удаленный доступ
    • Создание соединения
    • Соединение с Интернетом
    • Настройка параметров соединения
    • Установка соединения с Интернетом
    • Удаленный доступ
    • Программа дозвона
    • Начало работы с Microsoft Internet Explorer 6.0
    • Навигационные кнопки
    • Адресная строка
    • Адрес
    • Работа с адресной строкой
    • Просмотр веб-страниц
    • Перемещение по веб-странице при помощи клавиатуры
    • Размер шрифта
    • Контекстное меню
    • Просмотр страницы на полном экране
    • Настройка отображения страниц
    • Выбор шрифта
    • Выбор цветовой палитры
    • Выбор языка
    • Дополнительные параметры
    • Установка домашней страницы
    • Первое путешествие по Интернету
    • Использование автозаполнения
    • "Горячие" клавиши


ГЛАВА 3

Начало работы с Интернетом

Подключение к Интернету при помощи Мастера подключения

Вместе с Microsoft Internet Explorer 6.0 распространяется программа, которая позволяет создать и настроить соединение с Интернетом — Мастер подключения к Интернету (Internet Connection Wizard). Используя ее, можно наладить доступ в сеть наиболее легко и безошибочно. Поэтому работа с этой программой разобрана очень подробно, объяснены все нюансы и детали.

Для того чтобы запустить Мастер подключения к Интернету, достаточно щелкнуть по значку, находящемуся на рабочем столе (рис. 3.1).

Рис. 3.1. Значок Мастер подключения к Интернету

Если значка там не оказалось, то придется воспользоваться меню Пуск. Ссылка на Мастер подключения к Интернету (Internet Connection Wizard) имеется в группе программ Стандартные (Пуск | Программы | Стандартные).

Через несколько секунд загрузится программа, которая поможет вам настроить соединение с Интернетом (рис. 3.2).

Существует несколько вариантов подключения к сети Интернет. Наиболее распространенных два — через телефонную линию при использовании модема и через локальную сеть. В этой программе учтены все варианты. Первые два пункта рассчитаны на тех, кто пользуется модемом для доступа в Интернет. Последний — для тех, кто использует альтернативные способы подключения.

  1. Первый позволяет создать новое соединение с Интернетом, создать новую учетную запись и т. д. Этот вариант подходит для тех, кто еще не имеет учетной записи у интернет-провайдера.
  2. Второй дает возможность создать соединение с Интернетом с учетной записью, которая была создана на другом компьютере. Проще говоря, если у вас уже есть имя входа и пароль для работы в Интернете, то нужно выбирать этот пункт.
  3. Третий позволяет настроить соединение с Интернетом вручную. Это может быть полезно, если вы используете локальную сеть или нестандартный способ подключения. Например, при помощи модема ADSL.

Рис. 3.2. Окно Мастер подключения к Интернету, выбор пути установки

Нажатие кнопки Учебник (Tutorial) способствует ВЫВОДУ на Экран информации о сети Интернет.


Подключение к Интернету с помощью модема

Первый способ

Данное руководство рассчитано на пользователей, еще не имеющих учетных . записей у интернет-провайдеров. Те, у кого она есть, должны использовать второй способ.

Для этого выбираем первый пункт и нажимаем кнопку Далее (Next). Загружается новое окно (рис. 3.3) и модем начинает набирать номер.

Рис. 3.3. Окно Мастер подключения к Интернету, страница

Шаг 1 из 3. Выбор поставщика услуг Интернета

Замечание

Интересная деталь — теперь в России существует единый номер Microsoft. Номер доступен из любого города страны и по непроверенным данным бесплатен. Номер имеет такой формат 8 — 800 и цифры центра Microsoft.

После того как соединение установлено, Мастер подключения к Интернету

(Internet Connection Wizard) загружает список интернет-провайдеров, предоставляющих услуги доступа в сеть в выбранном регионе.

Слева представлены интернет-провайдеры, работающие в регионе.

Замечание

На время написания этой книги был доступен только Гласнет (ныне Россия online).

Справа дается подробная информация о поставщике услуг, тарифных планах и номерах доступа.

Поскольку информации о других интернет-провайдерах не предоставлено, был выбран Гласнет. Нажатие кнопки Далее (Next).

В ней предлагается ввести ваши персональные данные, т. е. фамилию, имя, номер телефона и т. д. Вводим информацию и переходим к следующему окну, нажав опять кнопку Далее (Next). В новом окне предлагается выбрать форму оплаты. К сожалению, оплаты по кредитным картам нет. Единственный способ заплатить — прийти в банк с заявлением и перечислить деньги на счет интернет-провайдера, что сделать не так уж сложно.


Второй способ

Вам уже нужно знать номер модемного пула интернет-провайдера, а также иметь имя входа (login) и пароль для доступа к ресурсам сети Интернет. При неимении одного из перечисленных, работать со Всемирной паутиной вы не сможете.

В первом случае (подключение к Интернету при помощи модема) вас попросят ввести телефонный номер модемного пула вашего интернет-провайдера. При желании вы можете указать дополнительные особенности соединения, нажав кнопку Дополнительно (Advanced). Вы увидите окно, изображенное на рис. 3.4.

Рис. 3.4. Окно Дополнительные свойства соединения

Здесь предлагается указать протокол, по которому будет осуществляться работа в Интернете. В большинстве случаев это РРР (Point to Point Protocol). Далее вам предстоит выбрать процедуру проверки имени входа (login) и пароля. Есть три варианта.

  • Процедура проверки отсутствует. Это значит, что используется стандартная процедура (Pap/Chap).
  • П Процедура проверки ручная, т. е. каждый раз, соединяясь с Интернетом, вы будете вынуждены вручную вводить имя входа (login) и пароль. Не все провайдеры это поддерживают.
  • Использование сценария для соединения. Это наиболее быстрый и удобный метод проверки пароля. Попросите вашего провайдера предоставить вам сценарий соединения или напишите его сами. Сделать это достаточно легко. Подробнее об этом вы сможете узнать из приложения.

Во вкладке Адреса (Addresses) вы можете сделать выбор между динамическим и статическим IP-адресами.

IP-адрес — специальный номер, присваиваемый вам интернет-провайдером. IP-адрес аналогичен почтовому адресу. Ведь те, кто хотят вам написать письмо, направляют его на ваш почтовый ящик. В Интернете все несколько сложнее. IP-адрес нужен вам, чтобы получать данные. Допустим, вы хотите посмотреть некий веб-сайт. Сделать это достаточно просто для пользователя. Но техническая сторона данного вопроса такова: при отсылке запроса на веб-сайт, который вы хотите посмотреть, информация отсылается на ваш IP-адрес, а далее преобразуется в удобочитаемую форму. Проще говоря, если у вас нет IP-адреса, работать в Интернете вы просто не сможете. Но волноваться по этому вопросу не стоит. Тот, кто предоставляет услуги доступа во Всемирную паутину, уже позаботился о вас.

В зависимости от типа подключения IP бывают различными. При подключении к Интернету через локальную сеть вероятность наличия динамического IP очень низка. При модемном подключении ситуация полностью обратная. Иногда интернет-провайдеры предоставляют своим пользователям возможность иметь статический IP-адрес. Но если вы заранее не подписывались на эту услугу или просто не знаете какой IP-адрес присваивается вашему компьютеру во время работы в сети, то, скорее всего, он динамический. Следовательно, вам не нужно ничего менять в установках IP-адреса.

Замечание

Возможно, вам следует проконсультироваться с вашим интернет-провайдером по данному вопросу.

В том же окне вы можете указать адреса DNS-серверов.

DNS-сервер — специальный сервер, который преобразовывает имена вебсайтов в цифры. Дело в том, что человеку проще запомнить текст, а компьютеру легче работать с цифрами. Поэтому все веб-сайты имеют как текстовый, так и цифровой вариант. Например, адрес сайта Васи Пупкина www.vasya_pupkin.ru в понятной компьютеру форме может выглядеть примерно так: 123.321.345.21. И при запросе пользователя DNS-серверы переводят www.vasyajupkin.ru в 123.321.345.21.

Несколько лет назад любой, кто хотел работать с Интернетом, должен был вручную прописывать адреса DNS-серверов. Теперь, с обновлением программного обеспечения, это уже необязательно. При входе в сеть DNS прописываются автоматически. Если вы не уверены, что ваш интернет-провайдер работает с данной методикой, узнайте адреса DNS и впишите их в специальную форму.

После того как установки сделаны, нажмите кнопку ОК. Они будут сохранены. Нажатие кнопки Далее (Next) открывает новое окно, где вам предлагается указать имя пользователя и пароль. При вводе пароля вместо символов (букв, цифр и т. д.) будут высвечиваться звездочки. Это сделано специально для того, чтобы кто-то, находящийся рядом с вами, не мог подглядеть его.

После указания имени входа (login) и пароля нажмите кнопку Далее (Next). В появившемся окне (рис. 3.5) вас просят придумать название соединению.

Рис. 3.5. Окно Мастер подключения к Интернету, страница Шаг 3 из 3. Настройка компьютера

Для удобства работы, наглядности рекомендуется делать имя соединения аналогичным имени провайдера или же тарифного плана. Это поможет вас уберечь от случайных трат,

Введя его имя, нажмите кнопку Далее (Next). В следующем окне вас спрашивают: "Хотите ли настроить e-mail программу?" Выберите кнопку Нет (No).

Финалом станет появление этого окна — рис. 3.6.

Рис. 3.6. Окно Мастер подключения к Интернету, страница Завершение работы

Если вы хотите сразу же соединиться с Интернатом, установите флажок Для подключения к Интернету ... (То connect to the Internet...) И нажмите КНОПКУ Готово (Finish). В противном случае снимите флажок.


Подключение вручную или при наличии локальной сети

Выбрав данный способ и нажав кнопку Далее (Next), появляется окно (рис. 3.7).

Здесь вам предлагается выбрать технологию подключения к Интернету:

  • с помощью модема;
  • с помощью локальной сети.

В зависимости от выбора установка пойдет по-разному.

Для того чтобы настроить подключение к Интернету с использованием локальной сети, выберите второй переключатель (рис. 3.7) и нажмите кнопку Далее (Next).

Рис. 3.7. Окно Мастер подключения к Интернету, страница Установка подключения к Интернету

Замечание

Ваша локальная сеть должна быть подключена к Интернету, иначе работать со Всемирной паутиной вы не сможете.

Появляется новое окно (рис. 3.10), в котором вам предлагается настроить подключение.

Была разработана специальная методика, которая позволяет установить соединение с Интернетом. Чаще всего в локальных сетях используются прокси-серверы.

Прокси-сервер — специальная машина, которая является как бы экраном, разделяющим Всемирную паутину и вашу локальную сеть. При загрузке какой-либо информации из Интернета, ваш запрос проходит через прокси-сервер, который эту информацию загружает, передает вам, а также сохраняет у себя. Тем самым можно существенно снизить время ожидания При повторном доступе к тем же самым данным. Еще одна причина использования — плата за трафик. Пока что она очень высокая, и просто не имеет смысла несколько раз загружать то же самое из Интернета, платить за трафик, когда можно использовать прокси-сервер.

При помощи Мастера подключения к Интернету (Internet Connection Wizard) ваш компьютер может быть настроен для работы с прокси-сервером автоматически.

Для этого нужно установить флажок Автоматическое определение прокси-сервера (рекомендуется) (Automatic discovery of proxy server). Если ваш прокси-сервер имеет сценарий автонастройки, то нужно прописать путь к нему в специальной строке. Чтобы узнать, есть ли сценарий автонастройки, проконсультируйтесь с администратором вашей сети. В случае положительного ответа, узнайте его адрес (сценарий).

Вы также можете указать адрес прокси-сервера вручную. Для этого установите флажок Ручная настройка прокси-сервера (Manual Proxy Configuration) и нажмите кнопку Далее (Next).

Замечание

При этом все остальные флажки должны быть сняты. Иначе могут возникнуть проблемы с работой в сети Интернет.

Рис. 3.8. Окно Мастер подключения к Интернету, страница Параметры Интернета для локальной сети

Появится следующее окно, в поле ввода нужно указать адрес и порт.

Если вы используете один и тот же прокси-сервер для работы по всем доступным протоколам (HTTP, FTP, POP3 и т. д.), установите флажок Один прокси-сервер для всех протоколов (Use the same proxy-server for all protocols). После указания адреса(ов) прокси-сервера(ов) нажмите кнопку Далее (Next). В окне Мастер подключения к Интернету на странице Параметры Интернета для локальной сети (рис. 3.9) вам остается указать адреса, для которых прокси-сервер не используется, если таковые имеются.

Рис. 3.9. Окно Мастер подключения к Интернету, указание неиспользуемых прокси-сервером адресов

Чаще всего это адреса компьютеров в локальной сети. Нажимаем кнопку Далее (Next). В следующем окне вам предлагается настроить записи электронной почты. О том, как это сделать, написано в четвертой части книги.


Удаленный доступ

Выше было рассказано о том, как создать соединение с Интернетом при помощи Мастера. Это хороший и проверенный способ, но можно сделать то же самое несколько быстрее.


Создание соединения

Выберите значок Мой компьютер на рабочем столе и дважды щелкните на нем. Появится окно проводника Windows. Нас интересует папка Удаленный доступ к сети. Открыв ее, вы увидите значок с надписью Новое соединение. Запустив мастер создания соединения, появляется следующее окно (рис. 3.10).

Рис. 3.10. Окно Новое соединение

В нем предлагается придумать имя создаваемому соединению, а также выбрать используемый для данного соединения модем. Нажав кнопку Далее, появится новая форма, в которой предлагается ввести телефонный номер модемного пула вашего интернет-провайдера. В следующем окне остается только подтвердить, что все установлено верно, нажатием кнопки Готово.


Соединение с Интернетом

Теперь в папке Удаленный доступ к сети появился новый значок. Выбрав его двойным щелчком, появится окно Установка связи (рис. 3.11).

В нем есть два специальных поля — Имя пользователя и Пароль. Соответственно в полях ввода имени пользователя и пароля введите имя входа (login) и пароль, полученные от вашего интернет-провайдера. Вы также можете сохранить пароль на вашем жестком диске в зашифрованном виде. Это позволит соединяться с Интернетом несколько быстрее, т. к. не будет необходимости каждый раз вводить его. Правда, это не очень безопасно. Давно было доказано, что компьютеры под управлением операционных систем Windows плохо защищены от атак хакеров. Следовательно, украсть ваш па-

роль представляется возможным. Чтобы обезопасить себя, не сохраняйте его на жестком диске вашего компьютера, постарайтесь запомнить его и не ленитесь вводить его каждый раз, когда вы соединяетесь с Интернетом.

Рис. 3.11. Окно Установка связи


Настройка параметров соединения

Для настройки параметров соединения, выберите из контекстного меню команду Свойства. Появится новое окно. В первой вкладке вы можете изменить номер модемного пула провайдера. Вторая вкладка — Тип сервера (рис. 3.12).

Для обеспечения безопасности ваших данных сбросьте флажки Войти в сеть, NetBEUI и IPX/SPX-совместимый. NetBEUI и IPX/SPX — специальные протоколы. С использованием протокола NetBEUI происходит основное количество хакерских атак, нацеленных на воровство вашей личной информации.

Кнопка Настройка TCP/IP вызывает окно настройки параметров TCP/IP. Здесь вы можете указать IP-адрес, если он не динамический, т. е. не присваивается вам каждый раз при входе в сеть, а также адреса DNS-серверов.

Следующая вкладка — Сценарии. Здесь вы можете указать файл сценария соединения.

Замечание

Сценарий может быть предоставлен вашим интернет-провайдером, либо написан вами.

Рис. 3.12. Окно Test, вкладка Тип сервера

Последняя вкладка - Подключения. Тут можно указать дополнительные устройства, использующиеся для данного соединения. Например, если у вас есть два модема и две телефонных линии, и ваш провайдер поддерживает одновременное подключение устройств. Таким образом, можно существенно увеличить скорость работы с Интернетом.


Установка соединения с Интернетом

После того как соединение создано, т. е. указан телефон, имя входа и па-роль, нам предстоит позвонить провайдеру. Это можно сделать двумя способами:

  1. Использовать соединение из папки Удаленный доступ к сети.
  2. Использовать программу дозвона, встроенную в Microsoft Internet Explorer 6.0.


Удаленный доступ

Для того чтобы установить соединение с Интернетом, у вас уже должны быть имя входа (login) и пароль, полученные от поставщика услуг Интернета. О том, как создать соединение, было написано в предыдущем разделе. Тут же мы поподробнее разберемся в том, как его осуществить.

Выберите в папке Удаленный доступ к сети соединение. Дважды щелкните по его значку. Появится окно Установка связи. После указания имени пользователя и пароля для данного соединения нажмите кнопку Подключиться. Сразу же появится небольшое окно, в котором вы можете наблюдать за тем, что сейчас делает модем. Сначала он набирает номер, потом идет проверка имени пользователя и пароля, а далее, если они указаны верно, будет происходить вход в сеть. После того как соединение установлено, появится значок с изображением двух компьютеров в системной панели. Если щелкнуть по нему дважды, появится окно статуса соединения. В нем будут показаны скорость, на которой соединились модемы (например, 28 800 Кбит/с), количество загруженных и отправленных байт, а также сведения о процедуре проверки пароля.

Только что была рассмотрена практически утопическая ситуация. Дело в том, что к большинству интернет-провайдеров не получается дозвониться с первого раза. Поэтому приходится использовать автодозвон. По умолчанию он выключен. Для того чтобы его активизировать, выберите из меню Соединения пункт Настройка. Нас интересует графа Повтор попыток соединения. Здесь можно указать общее число повторных звонков (максимум 100), а также интервал времени между попытками. Рекомендованное значение -5 секунд.

Теперь, если номер занят, программа автоматически перезвонит.


Программа дозвона

В Microsoft Internet Explorer 6.0 интегрирована программа дозвона, которая обладает достаточно большими возможностями. Окно программы изображено на рис. 3.13.

Для того чтобы начать работу с ней, нужно сначала ее настроить. Для этого запустите обозреватель, из меню Сервис (Tools) выберите пункт Свойства обозревателя (Internet Options). Перейдите на вкладку Подключения (Connections). Здесь вы можете как настроить программу дозвона, так и настроить параметры работы в Интернете при использовании локальной сети.

В небольшой по размеру графе представлены все соединения, имеющиеся у вас в папке Удаленный доступ к сети. Для начала выберите соединение, используемое в данный момент, и установите по умолчанию. Для этого нажмите кнопку По умолчанию (Set Default). Под листом доступных соединений есть поля: Не использовать (Never dial a connection), Использовать при отсутствии подключения к сети (Dial whenever a network connection is not present) и Всегда использовать принятые по умолчанию (Always dial my default connection).

  • Не использовать (Never dial a connection) — никогда не звонить. Это означает, что для того чтобы установить соединение с Интернетом или подключиться к Интернету при помощи локальной сети, вам будет нужно использовать удаленный доступ.
  • Использовать при отсутствии подключения к сети (Dial whenever a network connection is not present). Если выбрать этот пункт, то программа будет автоматически соединяться с Интернетом, когда это необходимо. Например, вы вводите URL в адресной строке и нажимаете клавишу <Enter>. Если активизирована эта функция, то появится программа-дозвона, которая все сделает за вас и требуемый интернет-ресурс будет загружен. В противном случае, загрузится веб-страница (с жесткого диска), где вам будет предложено проверить настройки сети.
  • Всегда использовать принятые по умолчанию (Always dial my default connection) — при необходимости работы во Всемирной паутине программа дозвона будет автоматически соединяться с выбранным по умолчанию поставщиком услуг Интернета. Вам даже не придется нажимать кнопку Подключиться.

Рис. 3.13. Окно Подключение удаленного доступа

Для удобства работы прямо в Microsoft Internet Explorer 6.0 вы можете добавить, а также настроить соединение. Для того чтобы создать его, нажмите кнопку Добавить (Add), а для того чтобы удалить — кнопку Удалить (Remove). Нажатие кнопки Настройка (Settings) вызывает окно настройки выбранного соединения. Здесь можно указать прокси-сервер, а также установить автоматическое определение настроек сети. В поле Настройка удаленного доступа (Dial-up settings) вы указываете имя пользователя и пароль, а также при необходимости домен (в большинстве случаев это не нужно). Вы имеете возможность настроить дополнительные параметры. Для этого нажмите кнопку Дополнительно (Advanced). В появившемся окне настраивается количество повторных звонков, если соединиться сразу не получается, и время между попытками.

Бывает так, что вы работаете в Интернете и вдруг отходите от компьютера на некоторое время. А время — деньги. Для того чтобы деньги не уходили напрасно, в Microsoft Internet Explorer 6.0 встроена функция автоматического отключения. Чтобы ее активизировать, установите флажок Отсоединяться при простое в течение ... минут (Disconnect if idle for ... minutes). Здесь также можно указать время, через которое соединение с Интернетом будет разорвано.

Активизация опции Отсоединяться, когда не требуется подключение к интернет (Disconnect when connection may not be needed) позволяет отключаться от Интернета в случае, если .соединение уже не используется. Например, после проверки почты или загрузки того или иного веб-сайта. .


Начало работы с Microsoft Internet Explorer 6.0

Для того чтобы начать работу с Microsoft Internet Explorer 6.0, необходимо его запустить. Найдите на рабочем столе значок обозревателя. И щелкните по нему. Через несколько секунд загрузится браузер, откроется домашняя страничка. По умолчанию, это http://www.microsoft.com . На рис. 3.16 представлено окно Microsoft Internet Explorer.

Рис. 3.14. Окно Microsoft в России — Microsoft Internet Explorer

Для начала работы с Интернетом нужно изучить сам браузер. Сейчас будет рассказано о назначении и использовании навигационных кнопок.


Навигационные кнопки

Навигационных кнопок (рис. 3.15) в Microsoft Internet Explorer 6.0 всего четыре. Это Назад (Back), Вперед (Forward), Остановить (Stop) и Обновить (Refresh).

Каждая из этих кнопок играет важную роль в веб-серфинге.

Рис. 3.15. Навигационные кнопки

Нажатие кнопки Назад (Back) возвращает вас к предыдущему просматриваемому документу. Например, вы просматривали одну страничку, а потом по баннеру случайно перешли на другую. Для того чтобы вернуться обратно, нужно нажать кнопку Назад (Back).

Но иногда вам необходимо вернуться не на одну, а на несколько страниц назад. Возможно, вы думаете, что придется нажимать кнопку Назад (Back) несколько раз. Да, это возможно, но, как вы понимаете, неудобно. Поэтому была придумана данная функция: нажав маленькую кнопку рядом с кнопкой Назад (Back) (на рис. 3.15 она слева) вы сможете выбрать одну из предыдущих страниц, а также посмотреть в Журнале.

Замечание

О том, как работать с Журналом будет рассказано позже.

Следующая навигационная кнопка — Вперед (Forward). Кнопка имеет значение, противоположное кнопке Назад (Back). Например, вы зашли на страничку по баннеру, но решили вернуться на предыдущую, т. к. не досмотрели. После того как вы дочитали (досмотрели), вы решаете перейти на страницу, на которую пришли по баннеру. Вот здесь вам и понадобится кнопка Вперед (Forward). По своему опыту могу сказать, что кнопка Вперед (Forward) довольно-таки редко используется. Например, при обычном веб-серфинге, если кнопка Назад (Back) используется 10 раз, то кнопка Вперед (Forward) — только 1 раз.

Кнопка Остановить (Stop) является одной из самых часто используемых. Как следует из названия, Остановить (Stop) останавливает загрузку страницы. Это может быть нужно, если вы передумали загружать какую-то страничку, или загружаете ее случайно.

Кнопка Обновить (Refresh) позволяет перезагрузить (обновить) страницу. Данная функция очень полезна, часто используется при просмотре новостных сайтов, когда вам необходимо получать оперативную информацию ежеминутно. А для этого понадобится перегружать страничку.

Кнопка Домой (Ноте) позволяет в любом месте сети Интернет вернуться на домашнюю страничку.

Замечание

О том, как установить домашнюю страницу, будет рассказано ниже.


Адресная строка

Адресная строка — специальное текстовое поле для ввода URL (адреса вебстраницы) (рис. 3.16).

Рис. 3.16. Адресная строка


Адрес

Для начала стоит разобраться в том, что из себя представляет адрес вебсайта (URL). Возьмем для примера такой адрес http://www.microsoft.com

Первые четыре буквы, т. е. http — это протокол, по которому браузер будет загружать данные с веб-страницы. Аббревиатура http расшифровывается как HyperText Transfer Protocol. В переводе на русский язык — Протокол передачи гипертекста, т. е. HTML-документов. Ранее так и было. Но теперь протокол стал поистине универсальным: по нему пересылаются изображения, бинарные файлы, ведутся конференции видео/аудио и еще много чего. Одним из самых распространенных убеждений является то, что Интернет состоит только из веб-сайтов. На самом деле это не так. Существует множество протоколов, позволяющих работать с различными типами данных. Например, при помощи РОРЗ принимаются сообщения e-mail, a News позволяет работать с группами новостей.

Далее идет www, что расшифровывается как World Wide Web. Так иногда называют Интернет. Вы, наверное, слышали, что сеть Интернет иногда называют Всемирной паутиной. Так вот этот термин является обычным переводом английского World Wide Web. До не давнего времени адреса сайтов должны были иметь приставку www. Теперь это необязательно, и получить доступ к веб-странице можно и без набора этой аббревиатуры.

После www ставится точка и идет собственно само имя сайта (домен). В нашем случае, это Microsoft. Домен выбирается самостоятельно компанией. Причем его использование не бесплатно (около 20$ в год).

Последнее — принадлежность сайта к одной из групп. Например, если в адресе страницы стоит ги после имени домена, то эта страница имеет некую принадлежность к русскому Интернету (хотя необязательно).


Работа с адресной строкой

По умолчанию адресная строка располагается под основной панелью (на ней расположены навигационные кнопки). Из себя она представляет поле для ввода текста и, возможно, кнопку Переход (Go). Для доступа к какому-либо веб-ресурсу нужно набрать его адрес. Начиная с Microsoft Internet Explorer 3.0, отпала необходимость набирать название протокола, т. е. http вы уже можете не набирать. Также, если сайт расположен в зоне Net, Com или Org, вы имеете возможность набрать только название сайта, например Yahoo, и нажать клавишу <Enter>, либо кнопку Переход (Go), находящуюся в правом углу адресной строки. Браузер автоматически соединится с веб-узлом и начнет загрузку материалов.

При помощи адресной строки можно осуществить поиск веб-страниц. Для этого нужно ввести поисковый запрос, например search Корпорация Microsoft, и нажать клавишу <Enter>. Через некоторое время загрузится веб-сайт с результатами поиска.


Просмотр веб-страниц

Разобравшись с азами работы с браузером, можно приступать к просмотру веб-страниц. Для начала нужно разобраться в том, что из себя представляет веб-страница. Как уже было сказано ранее, веб-страница — специальный текст с тегами, который браузер преобразовывает в удобочитаемую форму.

Например, исходный код веб-сайта Microsoft занимает около 15 страниц формата А5.

Удивительно, не правда ли? Главное, что создать страничку может каждый, а язык HTML достаточно легок в изучении.

Страничка — это интерактивный контент. Для работы с ним была придумана система ссылок. Нажатие на ссылку загружает новый документ.

Ссылки имеют специальное обозначение. Чаще всего текст ссылки подчеркнуты. А при наведении мыши курсор меняется на руку. Пример ссылки можно посмотреть на рис. 3.17.

Рис. 3.17. Пример ссылки

Подведя стрелку к обыкновенному тексту, ее форма меняется на символ, напоминающий латинскую букву I.

Иногда на странице нужно вводить данные (например, e-mail для подписки на рассылку). Чтобы это сделать, достаточно подвести курсор к специальной форме и ввести текст (набирать на клавиатуре). Также возможно его вставить из буфера обмена. Для этого необходимо сначала скопировать нужный фрагмент, а далее выбрать команду Вставить (Paste) из контекстного меню, как показано на рис. 3.18

Рис. 3.18. Вставка текста

В большинстве случаев страничка занимает много места, т. е. необходимо посмотреть, что там внизу. Сделать это очень просто. Для этого придумана специальная полоса прокрутки. По умолчанию она находится в правой части экрана. Также новая полоса прокрутки может появиться внизу, если в ширину веб-страница больше размера окна браузера. Для того чтобы переместиться вниз по странице, можно использовать несколько способов работы с полосой прокрутки:

  • использовать саму полосу — подведите курсор к полосе, зажмите левую кнопку мыши и передвигайте полосу верх или вниз (влево или вправо);
  • использовать маленькие кнопки сверху и снизу — нажав кнопку с изображением стрелочки вниз, страница будет чуть-чуть опущена.

Преимущество использования первого метода — плавное перемещение по странице, нет рывковых движений.

В 6-й версии обозревателя Microsoft Internet Explorer появилась возможность поменять положение полосы прокрутки. Напомню, что по умолчанию во всех программах она расположена справа. Теперь же вы можете сдвинуть ее в левую часть экрана. Сделать это можно почему-то из меню Кодировка (Encoding).


Перемещение по веб-странице при помощи клавиатуры

Перемещение по веб-странице возможно осуществить двумя-тремя способами. Первый и, наверное, самый простой, — использовать мышь или мышь со скроллером (полосой прокрутки), что совсем облегчает работу с веб-страницей. Но может возникнуть такая ситуация, что нет возможности ис-пользовать мышь. В этом случае работайте с клавиатурой. Причем, как оказывается, это не очень сложно. Подробнее с "горячими" клавишами можно ознакомиться в таблице 3.1.

Таблица 3.1. Перемещение по веб-странице при использовании клавиатуры

Клавиши | Значение
<Page Up> | Пролистывает веб-страницу к началу с большим шагом
<Раде Down> | Пролистывает веб-страницу к концу с большим шагом
<Home> | Осуществляет переход к началу веб-страницы
<End> | Осуществляет переход в конец веб-страницы
<Ctrl>+<Tab> | Перемещение между ссылками вперед
<Shift>+<Ctrl>+<Tab> | Перемещение между ссылками назад
<вверх> | Пролистывает веб-страницу к началу
«вниз» | Пролистывает веб-страницу к концу


Размер шрифта

В Microsoft Internet Explorer 6.0 вы можете изменить размер шрифта. Иногда на веб-страницах указанный по умолчанию шрифт оказывается слишком мелким, сложно читаемым. Чтобы сделать веб-серфинг еще более приятным, была придумана данная функция. Из меню Вид (View) выберите команду Размер шрифта (Text size) и укажите желаемый размер шрифта.


Контекстное меню

При нажатии правой кнопки мыши в любой области экрана (кроме рисунка, о рисунках позднее) появляется контекстное меню (рис. 3.19).

Структура меню частично повторяет содержание ОСНОВНОЙ панели. Опишем команды контекстного меню.

  • Назад (Back) — аналогична навигационной кнопке Назад (Back), т. е. позволяет вернуться на предыдущую страницу. Иногда удобнее использовать именно это контекстное меню для навигации. Например, когда страничка просматривается в полноэкранном режиме, т. е. навигационные кнопки отсутствуют, или при появлении окошек pop-up. Окно pop-up появляется автоматически на некоторых сайтах. Чаще всего в нем содержится реклама.

Рис. 3.19. Контекстное меню в Microsoft Internet Explorer 6.0

  • Вперед (Forward) — имеет характеристики, аналогичные навигационной кнопке Вперед (Forward).
  • Выделить все (Select All) — использование данной команды позволяет выделить весь текст, все картинки, т. е. всю веб-страницу целиком. При использовании механизма drag-and-drop (перетащить и бросить) страница может быть встроена в документ MS Word или в любую другую программу, поддерживающего его.
  • Создать ярлык (Create Shortcut) — позволяет создать ярлык для страницы. Выберите эту команду, и появится следующее диалоговое окно (рис. 3.20), в котором будет написано Ярлык этой страницы будет помещен на ваш рабочий стол. Нажмите кнопку ОК, и ярлык будет создан. Чтобы зайти на эту страницу, теперь достаточно щелкнуть по значку на рабочем столе.

Рис. 3.20. Диалоговое окно Microsoft Internet Explorer

  • Добавить в избранное (Add to favorites) — таким образом можно добавить веб-сайт, на котором вы находитесь, в Избранное (Favorites). Также, если подвести курсор к любой ссылке и выбрать этот пункт меню, в Избранное будет добавлен документ по ссылке.
  • Просмотр HTML-кода (View Source) — позволяет посмотреть исходный код страницы. Эта функция, прежде всего, полезна веб-мастерам, т. к. позволяет посмотреть структуру страницы, механизм, с помощью которого сайт создан. По умолчанию просмотр будет происходить в блокноте. Если размер документа превышает 40 Кбайт, то исходный код будет показан в Wordpad.
  • Кодировка (Encoding) — позволяет выбрать кодировку документа.
  • Печать (Print) — как понятно из названия, выбрав эту команду можно распечатать документ (принтер должен быть подключен к компьютеру). Причем, если выделить некоторый фрагмент текста и выбрать команду Печать (Print), распечатан будет именно фрагмент, а не страница целиком.
  • Обновить (Refresh) — позволяет перезагрузить страницу. Это используется при просмотре новостных сайтов, когда необходима самая свежая информация.

Рис. 3.21. Окно Свойства

  • Свойства (Properties) — при выборе данной команды появляется окно, в котором можно посмотреть информацию о странице (рис. 3.21). Например, ее размер (Размер (Size)) или дату создания (Создан (Created)). Также, если вы работаете с сайтом через безопасное соединение, посмотреть информацию о степени секретности, длине ключа, а также удостовериться в правильности сертификата.

Замечание

Более подробная информация по вопросам безопасности дана в третьей части книги.


Просмотр страницы на полном экране

Microsoft Internet Explorer 6.0 имеет очень удобную функцию — просмотр веб-страницы на полном экране. Это позволяет работать с веб-сайтом, не отвлекаясь на посторонние окна и другую ненужную в этот момент информацию. Такой режим также предпочтителен при просмотре видеопрезентаций через Интернет.

Чтобы запустить просмотр страницы на всем экране, нужно нажать кнопку с изображением экрана на основной панели. Есть другой способ — выбрать в меню Вид (View) команду Во весь экран (Full Screen) или же просто нажать на клавишу <F11>. На рис. 3.22 можно посмотреть пример отображения страницы на полном экране.

Панель можно скрыть, или, наоборот, добавить дополнительные кнопки, или даже адресную строку. Чтобы это сделать, наведите курсор на нее и нажмите правую кнопку мыши. Появится новое меню.

Меню состоит из нескольких команд.

  • Строка меню (Menu Bar) — панель меню. С помощью нее можно производить основные операции с веб-страницей. Например, вернуться назад или сохранить.
  • Адресная строка (Address Bar) — адресная строка. Поле для ввода URL веб-сайта. Может понадобиться, если вы постоянно работаете в режиме полноэкранного просмотра.
  • Ссылки (Links) — панель ссылок.
  • Автоматически убирать с экрана (Auto-hide) — автоматически скрывать. При включении данной функции панель будет автоматически исчезать сразу же после отвода курсора от нее.
  • Настройка (Customize) — настроить панель. Позволяет добавить или удалить кнопки, а также настроить отображение кнопок на ней.

Чтобы добавить или удалить новую панель, нужно щелкнуть по ее названию.

С помощью контекстного меню можно включить автоскрывание панели, также добавить дополнительные панели, кнопки. Для этого в контекстном меню выберите команду Настройка (Customize). Появится небольшое окно, в котором можно добавить/удалить некоторые кнопки. Например, удалить кнопку Вырезать (Cut) или добавить кнопку, вызывающую панель Медиа (Media Bar).

Рис. 3.22. Просмотр страницы на полном экране

Настройка отображения страниц

В Microsoft Internet Explorer есть возможность настройки отображения страниц. Во-первых, можно выбирать шрифт для страниц, в которых шрифт не указан.

Замечание

Использование дополнительных HTML-тегов позволяет устанавливать шрифты для просмотра. Например, веб-мастер решает, что шрифт Verdana как раз под-ходит к дизайну сайта. Он использует специальный тег и вместо шрифта, который вы указали, по умолчанию (например, Times New Roman) используется шрифт Verdana.

Во-вторых, можно выбрать цветовую гамму. В-третьих, настроить отображение страницы в соответствии с вашим шаблоном. В-четвертых, указать предпочтительный язык отображения.

Разберем каждую функцию по порядку.


Выбор шрифта

Для того чтобы изменить шрифт, нужно сначала вызвать окно настройки Microsoft Internet Explorer. Для этого откройте меню Сервис (Tools), а в нем выберите команду Свойства обозревателя (Internet options) и нажмите левую кнопку мыши. Появится окно, в котором вы можете настроить параметры Internet Explorer (рис. 3.23).

Рис. 3.23. Окно Свойства обозревателя, вкладка Общие

Нажатие кнопки Шрифты (Fonts) открывает новое окно, в котором можно настроить параметры отображения шрифтов на веб-страницах (рис. 3.24).

В раскрывающемся списке Набор знаков (Language script) выбирается язык, для которого производится настройка шрифтов. В нашем случае, это Cyrillic. Далее вы можете выбрать шрифт для веб-страниц, где он не задан. По умолчанию, это Times New Roman. Наиболее предпочтительными являются Arial, Verdana. Ниже можно выбрать шрифт для отображения в формах. Например, в форме поиска или ввода e-mail. Технически такой шрифт называется Plain Text font. По умолчанию — это Courier New. К сожалению, Plain Text шрифтов совсем немного. Вот почему здесь вы можете выбирать только между Lucida Console и Courier New.

Рис. 3.24. Окно Шрифты

После того как выбор сделан, нажмите кнопку ОК. Если вы не хотите сохранять изменения, достаточно нажать кнопку Отмена.


Выбор цветовой палитры

Как уже было сказано выше, вы можете выбрать не только шрифт, но и цветовую гамму. Для этого нажмите кнопку Цвета в окне Свойства обозревателя, вкладка Общие. Появится новое окно (рис. 3.25), в котором вы можете настроить отображения цветов.

Рис. 3.25. Окно Цвета

По умолчанию, в Internet Explorer используется та же цветовая гамма, что и в Windows. По желанию, можно указать другую цветовую палитру. Для этого нужно снять флажок Использовать цвета, установленные в Windows. А далее выбрать предпочтительные цвета для фона и текста. Чтобы выбрать цвет, нажмите кнопку после слова Текст или Фон соответственно. В появившемся окне вы можете выбрать цвет из предлагаемого набора или же определить

цвет лично. Чтобы это сделать, нажмите кнопку Определить цвет. В новом окне вы можете создать собственный цвет, а затем установить его в качестве цвета текста или фона.

Есть возможность выбрать цвет ссылок. Все делается аналогично выбору цвета текста или фона. Поэтому писать об этом подробно не имеет смысла.

После того как вы настроили цветовую палитру, нажмите кнопку ОК. Чтобы изменения не вступили в силу, нажмите кнопку Отмена.


Выбор языка

Далее вы можете настроить языки, предпочтительные для отображения вебстраниц. Сейчас все больше и больше сайтов рассчитаны на пользователей из различных стран мира. Следовательно, контент также представлен на различных языках. Ярким примером может служить поисковая система Google.com. Для работы с поисковиком на родном языке вы можете либо указать язык в самой системе (ваши настройки будут сохранены в файле Cookie), либо в окне Выбор языка (Language Preferences) (рис. 3.26), что значительно проще.

Рис. 3.26. Окно Выбор языка

Итак, Microsoft Internet Explorer позволяет указать предпочтительные языки отображения веб-страниц. Чтобы добавить языки, нажмите кнопку Добавить (Add language), а для того чтобы удалить — кнопку Удалить (Remove). При указании нескольких языков вы можете указать наиболее предпочтительные. Для этого воспользуйтесь кнопкой Выше (Move Up) или Ниже (Move Down). Наиболее предпочтительные должны находиться выше.

Нажав кнопку Изменить (Change), вы можете установить язык Internet Explorer, т. е. указать язык отображения меню, окон и т. д. Если у вас в системе уже имеется языковой модуль, то выбор можно сделать из раскрывающегося меню. В противном случае Microsoft Internet Explorer попросит соединиться с Интернетом. Далее будет загружена веб-страница корпорации Microsoft, где можно выбрать необходимый языковой модуль. Для Internet Explorer эта функция достаточно нова. В предыдущих версиях такого сделать было нельзя. Например, иметь одновременно английскую и русскую версию обозревателя просто не представлялось возможным. Теперь же, если случайно была загружена английская, а не русская версия браузера, язык вы всегда сможете легко поменять.

Чтобы сохранить изменения, нажмите кнопку ОК.


Дополнительные параметры

Нажав кнопку Оформление (Accessibility) в диалоговом окне Свойства обозревателя, появится новое окно, изображенное на рис. 3.27.

Рис. 3.27. Окно Оформление

Здесь вы можете установить параметры работы с веб-страницами. Например, игнорирование цветов, шрифтов или их размеров на страницах.

  • Не учитывать цвета, указанные на веб-страницах (Ignore colors specified on Web pages) — установите флажок, если вы хотите, чтобы цветовая палитра сайта была проигнорирована.
  • Не учитывать шрифты, указанные на веб-страницах (Ignore font styles specified on Web pages) — установите флажок в том случае, если вам хочется чтобы все шрифты были одного типа, указанные вами в окне Шрифты (Fonts).
  • Не учитывать размеры шрифтов, указанные на веб-страницах (Ignore font sizes specified on Web pages).

Вы также можете форматировать страницу по вашему усмотрению. Это делается при помощи файла CSS. Для этого достаточно выбрать файл с установками CSS и нажать кнопку ОК. Все настройки будут сохранены.


Установка домашней страницы

Домашняя страница — сайт, с которого начинается работа в Интернете. По умолчанию Microsoft.com установлена в качестве Home Page. Многих этот выбор устраивает, а многих нет. Поэтому в Microsoft Internet Explorer вы можете установить любую страницу в качестве домашней. Рекомендуется сделать домашней страницей ту, которую вы чаще всего посещаете. Это позволит уменьшить время, затрачиваемое на набор URL, а также несколько сократить расходы на доступ в Интернет. Для этого:

  1. Запустите браузер.
  2. Выберите из меню Сервис (Tools) команду Свойства обозревателя (Internet Options).
  3. В появившемся окне (см. рис. 3.25) есть поле Адрес (Address). Именно1 здесь и указывается домашняя страница.

Есть несколько способов задания домашней страницы.

  • Самому указать сайт в адресной строке и нажать на кнопку ОК.
  • Нажать кнопку С текущей (Use Current). Это позволит использовать в качестве домашней страницы сайт, на котором вы сейчас находитесь.
  • Нажать кнопку С исходной (Use Default) — использовать страницу по умолчанию (т. е. сайт Microsoft).
  • Нажать кнопку С пустой (Use Blank) — использовать пустую страницу.


Первое путешествие по Интернету

И вот мы подобрались к самому интересному — работе с веб-страницами. В данном разделе будет рассказано о том, куда лучше пойти в первый раз и о том, как найти требуемую информацию.

Итак, начнем.

Первое путешествие по сети Интернет -- процесс удивительный, и очень познавательный. Во многих самоучителях этому не уделяют должного внимания. А зря. Ведь недостаточно научить пользователя работе с браузером, нужно ему также показать, чем хорош Интернет, за что его любят и ненавидят, чем он может быть полезен, как может навредить.

Первое путешествие по Интернету стоит начать с каталога ресурсов. В Интернете каталог — собрание ссылок на сайты, с кратким их описанием. Каталогов в Интернете сейчас предостаточно. Но в большинстве случаев они созданы как приложения к поисковым системам. Каталог list.ru в своем роде уникален. На протяжении нескольких лет он держит лидирующие позиции в Рунете.

Что ж, для того чтобы начать интернет-серфинг, надо первым делом купить себе доступ в Интернет. Затем позвонить провайдеру. И загрузить Internet Explorer.

Рис. 3.28. Окно Яndex

При запуске браузера загрузится домашняя страница. В 90% случаев это Microsoft.com. Чтобы перейти на другую страницу в адресной строке, нужно набрать адрес какого-нибудь сайта. Для тех, кто впервые оказывается в Интернете, это становится серьезной проблемой. Ведь фактически пользователь не знает, что ему делать, куда идти. Сначала человек должен определиться в том, что ему интересно. Например, анекдоты или политические новости. Далее можно, конечно, наобум набирать интернет-адреса в стиле novosti.ru или anekdoti.ru, но, как оказывается, на практике чаще всего это ни к чему действительно интересному не приводит. Остается еще два варианта: первый — зайти на любую поисковую систему (например, rambler.ru или yandex.ru) и ввести в поле запроса то, что вас интересует. Второй вариант — зайти на сайт с каталогом (что это такое, было сказано выше) и найти интересующий раздел. В нашем примере мы будем работать с каталогом yandex.ru. Значит, после того как в адресной строке набран адрес http://www.yandex.ru (регистр значения не имеет) и нажата клавиша <Enter>, загружается сайт (рис. 3.28).

Теперь предстоит выбрать интересующую тематику. В нашем случае — это Отдых. Для того чтобы выбрать категорию, нужно подвести курсор к интересующему названию. Стрелочка изменится на руку. Чтобы пойти по ссылке, нажмите левую кнопку мыши один раз (именно один, а не два). Новая страница загрузится в том же окне. Выбираем категорию развлечения. В загрузившемся окне нам дается лист ссылок на сайты с тематикой развлечения. Выбираем понравившийся ресурс и щелкаем по его названию. Теперь загружается сам сайт. Ну а теперь уже вам предстоит выбрать то, что интересно. Если сайт вам понравился и вы захотите побывать на нем еще раз, целесообразно будет добавить его в Избранное.


Использование автозаполнения

В Microsoft Internet Explorer есть очень удобная функция, которая существенно повышает скорость работы с различными формами — автозаполнение. Оно используется как при работе с всевозможными формами, так и при работе с адресной строкой. Разберем автозаполнение более подробно.

Рис. 3.29. Окно Свойства обозревателя, вкладка Содержание

Рис. 3.30. Окно Настройка автозаполнения

Сначала нужно задать параметры автозаполнения. Для этого из меню Сервис (Tools) выберите команду Свойства обозревателя (Internet Options). В появившемся окне выберите вкладку Содержание (Content) (рис. 3.29).

Нас интересует кнопка Автозаполнение (AutoComplete). Нажмите кнопку с этой надписью. В появившемся окне (рис. 3.30) вам предстоит выбрать параметры автозаполнения, т. е. то, с чем его использовать.

По умолчанию в группе параметров установлены все флажки. В первой строке предлагается использование данной функции для веб-адресов (рекомендуется оставить), а во второй строке — для всевозможных форм. Например, для ввода адреса e-mail или имени. Третья строка — сохранять пароли. Как мне кажется, стоит от этого избавиться, т. к. операционная система Windows слишком незащищена от всевозможных хакеров, а следовательно, файл с паролями может быть легко украден.

В окне есть две специальных кнопки: Очистить формы (Clear Forms) и Очистить пароли (Clear Passwords). Нажатие первой удаляет все данные, которые вы заполняли в формах.


"Горячие" клавиши

"Горячие" клавиши или Hot keys позволяют работать с браузером несколько быстрее, без использования мыши.

Например, чтобы остановить загрузку страницы, можно просто нажать клавишу <Esc>. Вместо кнопки Назад (Back) на панели Microsoft Internet Explorer 6.0 вы имеете шанс использовать сочетание клавиш на клавиатуре <Alt>+<<->, а вместо кнопки Вперед (Forward) — <Alt>+<-»>.

Таким образом, использование "горячих" клавиш может ускорить работу с веб-страницами.

Специально для этого здесь приводится таблица "горячих" клавиш — табл. 3.2.

Таблица 3.2. "Горячие" клавиши

Действие | Нажать
Справка Internet Explorer | <F1>
Переключение между просмотром на всем экране и в окне | <F11>
Передвижение вперед по объектам на веб-странице | <Tab>
Передвижение назад по объектам на веб-странице | <Shift>+<Tab>
Переход на домашнюю страницу | <Alt>+<Home>
Переход на следующую страницу | <Alt>+<->>
Переход на предыдущую страницу | <Alt>+<<-> или <Backspace>
Отображение контекстного меню | <Shift>+<F10>
Переход вперед между фреймами | <Ctrl>+<Tab> или<Р6>
Переход назад между фреймами | <Shift>+<Ctrl>+<Tab >
Переход наверх(вниз) | <вверх> <вниз>
Переход наверх с большей скоростью | <Page Up>
Переход вниз с большей скоростью | <Page Down>
Переход к началу документа | <Home>
Переход к концу документа | <End>
Поиск на странице | <Ctrl>+<F>
Перезагрузить страницу | <F5> или <Ctrl>+<R>
Перезагрузить сохраненную веб-страницу | <Ctrl>+<F5>
Остановить загрузку | <Esc>
Переход к новому сайту | <Ctrl>+<0> или <Ctrl>+<L>
Открыть новое окно | <Ctrl>+<N>
Закрыть окно | <Ctrl>+<W>
Сохранить страницу | <Ctrl>+<S>

Действие | Нажать
Распечатать текущую страницу | <Ctrl>+<P>
Пойти по ссылке | <Enter>
Открыть поисковую панель | <Ctrl>+<E>
Открыть панель Избранное | <Ctrl>+<I>
Открыть панель Журнал | <Ctrl>+<H>
В панели Журнал или Избранное открыть несколько папок | <Сtrl>+щелчок


  • Глава 4. Печать и сохранение информации
    • Сохранение веб-страниц
    • Сохранение рисунков
    • Печать веб-страниц, отдельных фрагментов текста
    • Просмотр веб-страниц без соединения с Интернетом. Понятие Cache (кэш)


ГЛАВА 4

Печать и сохранение информации

Сохранение веб-страниц

Большинство пользователей Интернета в России соединяются с сетью при помощи модема. Данный вид подключения — самый простой и вообщем-то самый дешевый. Но есть одно "но". Практически все провайдеры, предоставляющие доступ dial-up в сеть, требуют оплачивать время на линии, а не количество загруженных мегабайт. Для активного пользователя, загружающего большие объемы информации, да к тому же имеющему новую электронную АТС, — это только на руку. Но для тех, кто заходит в сеть, чтобы найти какой-то документ или статью, данный вид подключения не удобен: оплачивается время на линии. Вот для чего была придумана такая функция, как сохранение информации.

В Microsoft Internet Explorer 6.0 она реализована достаточно хорошо, хотя имеются некоторые недочеты (о них позднее).

Предположим, вы зашли на страницу Microsoft, вас заинтересовали данные на странице, но, чтобы изучить ее, вам потребуется много времени. А время, как известно, деньги. Вот здесь вам и пригодится функция сохранения веб-сайта.

Чтобы сохранить страницу, выберите из меню Файл (File) команду Сохранить как (Save as). Появится диалоговое окно Сохранение веб-страницы (рис. 4.1).

Стоит разобраться поподробнее, как работать с этим окном.

  1. Из раскрывающегося списка Папка вы можете выбрать папку для сохранения веб-страницы. По умолчанию — это Мои документы. Я бы порекомендовал создать в ней подпапку специально для веб-сайтов, скажем с названием Сайты или Сохраненные веб-страницы. Стоит учитывать, что хотя Windows и поддерживает длинные имена файлов, при переустановке системы могут возникнуть проблемы с ними.

Рис. 4.1. Диалоговое окно Сохранение веб-страницы

  2. Кнопка на панели инструментов Internet Explorer 6.0 позволяет подняться на уровень вверх. Скажем, структура каталога такова: Мои документы\Сайты\Картинки, и вы находитесь в папке Картинки. Нажатие этой кнопки поднимет вас на уровень вверх, т. е. в папку Сайты.
  3. Кнопка Обзор рабочего стола (рис. 4.2) позволяет переместиться на рабочий стол, а кнопка с изображением папки — создать новую папку.

Рис. 4.2. Кнопка Обзор рабочего стола

  4. Кнопки, расположенные справа, дают возможность изменять вид отображения папок.
  5. В поле Имя файла (File name) вам предлагается придумать собственно название сохраняемой веб-страницы. Имя по умолчанию — то, которое находится в заголовке.
  6. Раскрывающийся список Тип файла (File type) очень важен. Вы должны выбрать, как сохранять страничку:
    • полностью, т. е. сам HTML-файл, а также картинки — Веб-страница, полностью (*.htm;*.html) (Web Page, complete);
    • полностью, но как веб-архив — Веб-архив, один файл (*.mht) (Web archive, single file), т. е. всю страницу с картинками в один файл. Правда тогда сайт выглядит несколько странно: нет ни нормального текста, ни картинок, он не готов для нормального просмотра;
    • если выбрать пункт Веб-страница, только HTML (*.htm;*.html) (Web page, HTML only), то страница будет сохранена без картинок, анимации и т. д.;
    • последний пункт — Текстовый файл (*.txt) (Text file) — позволяет сохранить страницу в формате обычного текста. Кстати, при выборе последнего пункта, страница может быть просмотрена в любом текстовом редакторе, например Блокнот. Стоит учитывать, что в данном виде страница потеряет начальное форматирование, нельзя будет пойти по ссылке, страница потеряет все преимущества HTML-файла.. Правда и занимать будет меньше места на диске.
  7. Далее из раскрывающегося списка Кодировка (Encoding) вы выбираете кодировку документа.
  8. После этого нажимаете кнопку Сохранить (Save), и страничка начнет загружаться и будет сохранена у вас на винчестере.

В предыдущих версиях Microsoft Internet Explorer, а также в альтернативных браузерах, картинки и HTML-файлы сохранялись в одну папку. В 6-й версии браузера от Microsoft картинки сохраняются в отдельную папку, что очень удобно. В итоге получается так: картинки -- в одной, HTML -в другой. Таким образом, можно избежать мусора и непонятно откуда взявшихся файлов на винчестере.

Но иногда нужно сохранить страницу не целиком, а только ее часть. В Microsoft Internet Explorer 6.0 эта функция, как таковая, не реализована. Поэтому приходится пользоваться подручными средствами. Наиболее простой и эффективный метод, которым пользуются многие пользователи по всему миру, я называю "copy&paste".

Загрузив нужную вам веб-страницу, выделите интересующий текст (рис. 4.3).

В контекстном меню выберите команду Копировать (Сору). Тем самым, выделенный фрагмент текста будет скопирован в буфер обмена. Далее создайте текстовый документ на рабочем столе. Для этого из контекстного меню выберите команду Создать | Текстовый документ. Присвойте имя файлу. Например, имя веб-страницы. Далее дважды щелкните на значке документа. Загрузится программа Блокнот. Вот теперь вторая часть — Вставить (Paste). Для этого из контекстного меню выберите команду Вставить (Paste). Фрагмент текста, ранее скопированный в буфер обмена, окажется в Блокноте. Остается только сохранить его. Для этого из меню Файл (File) выберите команду Сохранить (Save).

Рис. 4.3. Выделение фрагмента текста


Сохранение рисунков

По сравнению с предыдущими версиями, в данном аспекте Microsoft Internet Explorer 6.0 претерпел значительные изменения. Причем в лучшую сторону. Теперь работать, сохранять, отправлять по электронной почте картинки стало еще легче. Также появилась новая функция, при помощи которой можно автоматически масштабировать картинки под разрешение экрана, размер окна и т. д.

Теперь обо всем по порядку.

Для примера был сделан моментальный снимок (screen shot) окна Microsoft Internet Explorer. Файл был сохранен в формате JPEG, а далее загружен через Internet Explorer. Изображение было автоматически уменьшено для того, чтобы соответствовать размерам окна. Чтобы картинка опять приняла нормальную форму, нужно подвести курсор к правому нижнему углу изображения и нажать на появившуюся кнопку (рис. 4.4).

Размер изображения изменится, станет таким, каким он должен быть.

Данная функция очень удобна при просмотре больших по размеру изображений на мониторе с маленьким разрешением (например, 640x480). Стоит заметить, что изображение несколько деформируется. Особенно это заметно

при просмотре картинок, содержащих какую-либо текстовую информацию. Текст становится просто нечитаемым. Правда это несущественный минус, т. к. в большинстве изображений текст никакой смысловой нагрузки не несет. Да и потом можно посмотреть картинку в натуральной величине.

Рис. 4.4. Увеличение размера картинки

Сохранение изображения стало еще легче. Теперь вы можете использовать как старый способ, так и более удобный — новый.

  1. Выбрав картинку, которую вы хотите сохранить, наведите курсор на нее и, используя контекстное меню, выберите команду Сохранить картинку как (Save picture as). Далее выберите папку, куда будете ее сохранять, имя файла, а также формат. Вы можете сохранить ее в родном формате, т. е. в том, в каком она была опубликована в Интернете, или же в формате Windows Bitmap. Для начинающего пользователя отличия между форматами не видны, да и это не должно вас волновать. Единственное, что стоит учитывать, так это размер файла. В формате BMP он намного больше, чем скажем в GIF или JPEG.
  2. Если изображение большое по размеру, то можно использовать второй способ.
    • Для этого переведите курсор мыши в левый верхний угол. На панели инструментов (рис. 4.5) выберите кнопку с изображением дискеты и нажмите на нее.

Рис. 4.5. Панель инструментов

Появится окно, аналогичное тому, которое появляется при использовании первого метода. Процесс сохранения также аналогичен. Структура панели инструментов частично повторяет содержание контекстного меню. Так что каждый вправе выбрать наиболее удобный способ работы с изображениями. На панели — четыре кнопки. Естественно, что каждая несет свою смысловую нагрузку. Кстати, эти четыре кнопки в контекстном меню также представлены (рис. 4.6).

Рис. 4.6. Контекстное меню

Рассматривать отдельно те же самые команды не имеет смысла. Поэтому разберем работу с картинками при помощи контекстного меню.

  • Отправить рисунок по почте (e-mail picture) -- позволяет при помощи программы электронной почты отправить картинку тому, кому вы захотите. Для этого выберите этот пункт. Загрузится программа для работы с почтовыми сообщениями. По умолчанию это Microsoft Outlook Express, работа с которым будет описана ниже.
  • Печать рисунка (print picture) — позволяет распечатать картинку на принтере. Здесь все просто: нажимаете на надпись или кнопку с изображением принтера и картинка распечатывается. Правда, у вас должен быть установлен принтер, иметься бумага и чернила для принтера.
  • Перейти к папке "Мои рисунки" (Go to pictures) — позволяет переместиться в папку с идентичным названием. В ней вы по идее должны сохранять картинки, хотя это необязательно.
  • Сделать фоновым рисунком (Set as background) — сделать картинку фоном для рабочего стола В данном примере изображение несколько сжато. Все из-за того, что (5но больше, чем сам рабочий стол. Выбрав команду Свойства из контекстного меню рабочего стола, можно задать параметры отображения фона для рабочего стола. Хотя это и относится к Microsoft Internet Explorer 6.0 только косвенно, но рассказать о том, как это сделать, стоит.

Чтобы задать параметры отображения фона, в контекстном меню рабочего стола выберите команду Свойства. В появившемся диалоговом окне на вкладке Фон вы можете установить параметры отображения фона. Для этого из раскрывающегося списка Поместить выберите один из параметров:

  • По центру (Center) — центрировать фон;
  • Рядом (Tile) — расположить рядом, используя истинный размер;
  • Растянуть (Stretch) — расширить под размер рабочего стола.


Печать веб-страниц, отдельных фрагментов текста

Печать веб-сайта не должна вызывать затруднений. Но сначала нужно ее, т. е. печать, оптимально настроить под ваш принтер. Необходимо настроить разрешение, параметры страницы. Для этого мы используем меню Файл (File). В нем выбираем команду Параметры страницы (Page Setup). В появившемся диалоговом окне (рис. 4.7) нужно указать параметры страницы.

Рис. 4.7. Диалоговое окно Параметры страницы

  1. Из группы параметров Бумага выберите раскрывающийся список Размер (Size). Самый распространенный размер листа бумаги — формат А4. Но на больших офисных принтерах есть возможность использовать большие или меньшие по формату листы. Именно в этом поле задается формат. В раскрывающемся списке Подача (Source) вы можете выбрать параметры подачи бумаги.
  2. Группа параметров Колонтитулы (Headers & Footers) не менее важна, чем предыдущие. Здесь вы задаете дополнительные параметры печати. Например, отображать ли дату (&d) или количество страниц (&Р). Полный список обозначений приведен в табл. 4.1.
  3. Группа параметров Ориентация (Orientation) позволяет задать ориентацию страницы — альбомную или книжную.
  4. В группе параметров Поля (мм) (Margins) вы задаете размер полей страницы.

Таблица 4.1. Форматирование текста

Символ | Значение
&W | Заголовок окна
&U | Адрес страницы
&d | Дата в кратком формате
&D | Дата в полном формате
&t | Время в формате, заданном в окне Язык и стандарты панели управления
&Т | Время в 24-часовом формате
&р | Текущий номер страницы
&Р | Количество страниц
&Ь | Центрированный текст, следующий сразу за указанными символами
&b&b | Форматированный текст: после первого символа &Ь выводится центрированный текст, после второго &Ь — текст, выровненный по правому полю
&& | Одиночный амперсанд

После того как параметры страницы установлены, нужно нажать кнопку ОК.

Теперь стоит посмотреть страницу в том виде, в каком она будет на листе бумаги. Нет, нам не обязательно распечатывать ее, чтобы это увидеть. Существует очень удобная команда Предварительный просмотр (Print Preview) (рис. 4.8). Активизируется она из того же меню Файл (File).

Как видно из рис. 4.8, веб-страница выглядит не совсем так, как хотелось бы. Обрезана правая часть, чуть сдвинуты некоторые надписи и присутствуют некоторые недочеты. К сожалению, с этим особенно ничего сделать нельзя. Правда есть два решения, которые покажутся вам не совсем удобными. Первое — это изменить формат страницы на больший. Скажем A3 вместо А4. Но как ни печально, для этого нужен другой принтер. Значит, этот вариант в 90% случаев отпадает. Второй вариант — поменять ориентацию страницы, т. е. вместо книжной сделать альбомную. Для этого воспользуемся кнопкой которая находится на панели инструментов окна

Предварительный просмотр (Print Preview). Теперь страница выглядит так, как она должна выглядеть (рис. 4.9).

Правда теперь потребуется два листа формата А4 вместо одного. Вы можете использовать кнопки + (плюс) и - (минус) на панели инструментов, чтобы просмотреть макет веб-страницы в желаемом виде.

Рис. 4.8. Окно Предварительный просмотр

Рис. 4.9. Окно Предварительный просмотр, измененная ориентация страницы

Для того чтобы распечатать веб-страницу, нажмите кнопку Печать (Print) на панели инструментов или воспользуйтесь командой Файл | Печать (File Print).

Но иногда требуется распечатать не веб-страницу целиком, а только фрагмент текста. В Microsoft Internet Explorer 6.0 такая возможность тоже предусмотрена. Чтобы это сделать, нужно выделить необходимый фрагмент текста, а затем выбрать в контекстном меню команду Печать (Print) (рис. 4.10).

Рис. 4.10. Диалоговое окно Печать

Здесь можно выбрать принтер, с помощью которого будет распечатываться данный фрагмент текста, а также настроить его. Окно настройки принтера может быть вызвано при нажатии на кнопку Свойства (Properties). Распечатать данный фрагмент текста можно также в файл. Для этого нужно установить флажок Печать в файл (Print to file).

Группа параметров Диапазон печати (Print Range) имеет большое значение. Если указать неверные параметры, то страница может быть распечатана целиком. Чтобы этого не случилось, нужно понимать, что делать. Для того чтобы распечатать фрагмент, выделенный нами ранее, нужно выбрать переключатель Выделенный фрагмент (Selection). При выборе одного из первых, двух переключателей веб-сайт будет либо распечатан целиком (1-й переключатель), либо с какой-то по какую-то страницу (2-й переключатель). Вы также можете задать число копий. Это можно сделать в группе параметров Копии (Copies). Число копий можно ввести с клавиатуры или с помощью полосы прокрутки. Если установить флажок Разобрать по копиям (Collate), то печать документа будет происходить с разборкой по копиям.

Для того чтобы все документы, ссылки на которые имеются на данном вебсайте, также были распечатаны, нужно установить флажок Печатать таблицу ссылок (Print table of links) — распечатать таблицу ссылок. При установленном флажке, в конце документа будут приводиться все ссылки, имеющиеся на этой веб-странице.

После того, как все настроено, нажмите кнопку ОК. Документ будет распечатан.


Просмотр веб-страниц без соединения с Интернетом. Понятие Cache (кэш)

Просмотр веб-страниц без соединения с Интернетом очень удобная опция, присущая браузеру Microsoft Internet Explorer 6.0. Есть несколько вариантов просмотра веб-страниц в автономном режиме.

  • Вы сохранили страницу способом, описанным выше, а теперь хотите изучить ее более подробно. Нет ничего проще. Достаточно дважды щелкнуть на значке HTML-документа, который вы сохранили. Загрузится окно браузера и перед вами предстанет тот самый веб-сайт. Важно учитывать, что кроме него самого зайти вы никуда не сможете.
  • Второй способ — сделать страницу доступной автономно. Эта функция реализована очень хорошо, и подробное описание создания таковых страниц дано в предыдущей главе.
  • Третий способ — просмотр веб-страниц, сохраненных в кэш. Сохранение в кэш делается автоматически для ускорения повторного доступа к сайту. Например, чтобы не загружать большие по размеру изображения снова. В Microsoft Internet Explorer 6.0 есть возможность автономной работы. Чтобы запустить данный режим, воспользуйтесь меню Файл (File). В нем нужно выбрать команду Работать автономно (Work Offline). Теперь запустите просмотр журнала при помощи кнопки Журнал на панели инструментов. Слева предстанет лист сайтов, посещенных вами за некоторый период времени. Сайты, которые доступны автономно, будут выделены черным цветом (остальные — серым). Теперь, щелкнув на значке одного из таких сайтов, вы сможете его просмотреть. Стоит отметить, что доступна может быть только одна страница сайта, недоступны изображения и т. д. На сайте вы, возможно, сможете нажимать на ссылки. Но если они будут недоступны автономно, вам будет предложено соединиться с Интернетом.


  • Глава 5. Панели в Microsoft Internet Explorer 6.0
    • Панель Медиа
    • Избранное
    • Панель Избранное
    • Поиск
    • Критерии поиска
    • Работа с панелью Поиск
    • Журнал
    • Работа с Журналом


ГЛАВА 5.

Панели в Microsoft Internet Explorer 6.0

Панель Медиа

Следуя по пути полной медиализации Интернета, компания Microsoft встроила в Microsoft Internet Explorer 6.0 панель Медиа (Media Bar). В ранних версиях браузера панель была названа Personal Bar и имела намного больше функций, чем теперешняя панель Медиа (Media Bar). Например, была поддержка MSN Messenger, а также контакт-листа из Microsoft Outlook Express и еще несколько приятных функций. Но, к сожалению, к выходу финальной версии все это стало недоступно.

Для того чтобы запустить панель Медиа (Media Bar), нужно нажать на соответствующую кнопку на панели инструментов Microsoft Internet Explorer 6.0. Также вы можете из меню Вид (View) выбрать команду Панели обозревателя (Explorer Bar), Медиа (Media). К сожалению, клавиша быстрого доступа не предусмотрена.

Слева появится новая панель, которая носит название Медиа (Media) (рис. 5.1).

Она разделена на две части. Снизу располагается плейер, а сверху — интерактивная панель.

Для начала нужно разобраться в том, что из себя представляет интерактивная панель. В принципе это обыкновенная веб-страница, которая сделана специально под размер панели Медиа. Название Медиа полностью оправдывается. Здесь вы не увидите заголовков новостных агентств мира, а только новости из мира музыки, кино или радио. В общем все, что связано с шоу-бизнесом. Правда, на английском языке. Судя по опыту предыдущих версий, на русском это выходить никогда и не будет. А жаль. Теперь разберемся поподробнее с тем, как весь этот медиа-контент получить, и собственно для чего он нужен.

Рис. 5.1. Панель Медиа

При запуске панели по умолчанию загружаются новости из мира шоу-бизнеса. Если вас что-то заинтересовало, достаточно щелкнуть по одной из ссылок, и справа, в основном окне браузера, загрузится дополнительная информация. Например, группа Blink 182. Щелкнув по Blink 182 в окне Медиа (Media), в основном окне обозревателя загружается информация о группе, о том, что можно послушать или посмотреть с их участием, узнать новости о них и т. д. Итак, можно, например, посмотреть интервью группы, данное специально для Launch.com, или приобрести их компакт-диск.

Стоит учитывать, что размер окна будет несколько не тем, которое предполагалось. Вам придется прокручивать список не только сверху вниз, но и слева направо. Вообще это сильно зависит от разрешения экрана.

На данный момент 800x600 уже не является основным стандартом. Все больше и больше веб-сайтов, да и самих программ, делается под разрешение экрана 1024x768. Поэтому при работе с браузером Microsoft Internet Explorer 6.0, а также дополнительными модулями (например, панелью Медиа (Media Bar)), рекомендуемое разрешение 1024x768.

Рис. 5.2. Окно Microsoft Internet Explorer 6.0 с панелью Медиа

При помощи панели Медиа можно не только узнать новости шоу-бизнеса, но также и найти сетевую радиостанцию. Для этого существует специальный пункт — Radio. Чтобы получить доступ к нему, нужно закрыть сегодняшние новости (Today). Появится список разделов. Мы выбираем Radio. Здесь дается хит-лист самых популярных интернет-радиостанций. Стоит учитывать, что сейчас, чтобы прослушать одну из них, уже может быть недостаточно скорости 33 600 бит/с. Стандартом становится как минимум 56 000 бит/с, хотя до сих пор многие радиостанции вещают на скорости 28 800 бит/с. Стоит учитывать, что в этом случае вы сможете слушать только радио, т. е. если вам захочется еще и попутешествовать по сайтам, то сделать это будет сложновато. "Тормозить" начнет как радио, так и загрузка сайтов. Торможение радио состоит в том, что звук будет либо прерываться, либо будет слышно некое металлическое звучание. Чтобы обеспечить приемлемое качество звука, а также хорошую скорость работы с веб-сайтами, нужно иметь высокоскоростной доступ в Интернет (как минимум 128 Кбит/с). К сожалению, на данный момент это слишком дорого для рядового пользователя, поэтому приходится пользоваться модемом за 40$, плохо держащим связь и не обеспечивающим возможность работы с высококачественными контент-сайтами, позволяющими не только прослушивать аудиокомпозиции, но также и просматривать видеоклипы и даже фильмы.

Ранее для прослушивания потокового аудио вам приходилось загружать еще одну программу — Проигрыватель Windows Media (Windows Media Player). В 6-й версии Microsoft Internet Explorer это неудобство снято. Теперь аудиоплейер встроен в сам браузер. Да, вы не ослышались, это действительно так. Плейер работает сам по себе, нет необходимости устанавливать Проигрыватель Windows Media (Windows Media Player). Он располагается в панели Медиа (Media Bar) снизу. Работать с ним чрезвычайно просто.

В первый раз, при попытке прослушать какой-либо медиа-файл из Интернета, появится диалоговое окно (рис. 5.3).

Рис. 5.3. Диалоговое окно Настройка панели медиа

В нем вам предлагается выбрать программу, с помощью которой будет проигрываться данный медиа-файл. Нажав кнопку Нет (No), файл будет ассоциироваться с программой по умолчанию. Например, Проигрывателем Windows Media (Windows Media Player). Если вы нажмете кнопку Да (Yes), то файлы выбранного формата будут теперь и всегда проигрываться при помощи встроенного в Internet Explorer плейера. Если установить флажок Запомнить мой выбор (Remember my preferences), то это окно появляться больше не будет, ваши предпочтения будут сохранены, и в соответствии с ними медиа-файлы будут проигрываться тем или иным способом.

Рекомендуется использовать встроенный в Microsoft Internet Explorer 6.0 Медиа-плейер (Media Player), т. к. это намного удобнее. Поэтому в окне мы нажимаем кнопку Да (Yes). Тем самым делаем его плейером по умолчанию.

Работа с плейером интуитивно понятна. Управление осуществляется при помощи кнопок. Кнопка [image] идентична кнопке Play на обыкновенном, аналоговом плейере. Нажав на нее, начинается воспроизведение. Повторное нажатие приводит к приостановке воспроизведения, но только на время. Это аналогично нажатию кнопки Pause на музыкальном центре. Следующая кнопка - Stop. Нажатие на нее приостанавливает воспроизведение и "освобождает" звуковую карту.

Замечание

Дело в том, что на старых или дешевых звуковых картах возможно воспроизведение только одного музыкального потока в одно время. Значит, если вы являетесь обладателем такой звуковой карточки, вы не сможете, например, слушать одновременно музыкальную композицию, а также общаться в голосовом чате.

Кнопки [image] выполняют роль перемотки назад или вперед на аудиоплейере. Нажатие кнопки [image] позволяет временно отключить звук. Повторное нажатие его включает. Регулировать громкость можно при помощи ползунка

На плейере есть кнопка Параметры медиа (Media Options), нажатие на которую вызывает дополнительное меню. В нем первые два поля — ссылки на веб-сайты с медиа-контентом. Последнее поле — Параметры (Settings) позволяет вызвать команды, при помощи которых вы можете настроить проигрывание композиций. Чтобы все аудиофайлы, загружаемые из Интернета проигрывались этим плейером, установите флажок Воспроизводить веб-медиа в панели (Play Web media in the bar). При установленном флажке в следующем пункте, каждый раз при открытии медиа-файла вас будут спрашивать, при помощи чего его открыть. Последний пункт позволяет сбросить все предпочтения.

Появления панели Медиа (Media Bar) для Internet Explorer является хорошим сигналом. Наконец-то можно слушать радио, просматривать видео без особого труда. Работать с медиа-контентом стало легче. Так что плюсы, как говорится, на лицо.


Избранное

Избранное — специальная папка, куда вы можете помещать ссылки на определенные веб-сайты, которые вам захочется посетить снова и снова.

Чтобы поместить сайт в Избранное, вы можете воспользоваться одним из представленных ниже методов.

Рис. 5.4. Диалоговое окно Добавление в избранное

Во-первых, использовать меню Избранное (Favorites) в окне обозревателя. Выберите команду Добавить в избранное (Add to Favorites). Появится диалоговое окно Добавление в избранное (Add Favorite) (рис. 5.4). Придумайте имя сайту, выберите папку и нажмите кнопку ОК. Ссылка на веб-сайт будет добавлена в Избранное.

Во-вторых, для того чтобы сайт был доступен в режиме автономной работы, нужно установить флажок Сделать доступной автономно (Make available online).


Панель Избранное

На панели инструментов обозревателя Microsoft Internet Explorer 6.0 есть кнопка Избранное. Она изображена как папка. Нажатие на нее активизирует левую панель окна обозревателя (рис. 5.5). На ней представлены все сайты, добавленные в Избранное. Там же можно производить некоторые манипуляции с ними.

Рис. 5.5. Панель Избранное

При активной панели вы можете мгновенно добавить сайт, на котором вы сейчас находитесь, в список избранных страниц. Для этого нажмите кнопку Добавить (Add) на панели Избранное. В появившемся диалоговом окне нажмите кнопку ОК, и страница будет добавлена. Здесь же есть кнопка Упорядочить (Organize), которая вызывает диалоговое окно Упорядочить избранное (рис. 5.6).

Рис. 5.6. Диалоговое окно Упорядочить избранное

Как видно из рис. 5.6, в окне есть 5 кнопок, а также специальное поле с веб-сайтами, добавленными в Избранное.

  • Создать папку (Create Folder) — создать новую папку. Это может быть нужно для того, чтобы упорядочить Избранное. Например, ссылки по тематике "Спорт" переместить в только что созданную папку Спорт и т. д.
  • Переместить (Move to folder) — переместить в папку. Для того чтобы переместить сайт в другую папку, сделайте следующее:
    • выберите сайт;
    • нажмите кнопку Переместить (Move to folder);
    • в появившемся окне выберите папку, куда вы хотите переместить ссылку на сайт;
    • нажмите кнопку ОК.
  • Переименовать (Rename). Для того чтобы дать другое имя выбранному веб-сайту, нажмите эту кнопку и введите новое имя. Нажмите клавишу <Enter>.
  • Удалить (Delete) — удалить сайт из Избранного. Для этого выделите сайт, который хотите удалить, и нажмите кнопку Удалить (Delete). В диалоговом окне выберите кнопку ОК. Сайт будет удален.


Поиск

Возможность поиска информации — одна из важнейших особенностей Интернета. Для этого были созданы целые поисковые системы. Основываются они на различных механизмах, имеют всяческие возможности. На сегодняшний день работа с поисковыми системами упростилась. Теперь даже самый неподготовленный пользователь в состоянии найти интересующую его информацию. Для этого достаточно ввести поисковый запрос, т. е. то, что вас интересует, в специальную форму и нажать кнопку Поиск (Search).

В Рунете самыми популярными поисковыми системами являются: Рамблер, Яндекс и Апорт. Недавно появилась русская версия поисковика Google, a буквально несколько месяцев назад состоялась презентация русскоязычного варианта Lycos, который держит лидирующие позиции в Европе.

Итак, для того чтобы что-то найти, нужно знать: во-первых, адрес поисковой системы, во-вторых, точно сформулировать запрос. Но есть способ проще — использовать встроенную в Microsoft Internet Explorer 6.0 панель Поиск (Search).


Критерии поиска

К заданию критериев поиска следует подойти достаточно серьезно. Ведь неправильно сформулированный запрос может привести к тому, что ничего не будет найдено или найдено совсем не то, что вам нужно. Поэтому при первой попытке рекомендуется использовать как можно больше ключевых слов, а также возможности расширенного поиска, предоставляемые практически любой поисковой системой.

Для примера воспользуемся поисковой системой Яндекс. Например, нас интересуют результаты матча Торпедо (Москва) и ЦСКА. Для этого вводим в специальном поле "результаты матча Торпедо (Москва) и ЦСКА" и нажимаем кнопку Поиск (Search). Загружается новая веб-страница, где имеется огромное количество ссылок на результаты матчей. Но нас же интересует самый последний. Есть два пути — поставить сортировку по дате, т. е. последний проиндексированный сайт будет находиться вверху, или же воспользоваться расширенным поиском. Выбираем второе, т. к. это более надежно и экономит массу времени. Здесь можно задать интервал времени, в котором осуществляется поиск, а также дополнительные параметры. Тем самым результатов будет меньше, но они будут более похожи на то, что нам именно надо. Соответственно время, затрачиваемое на поиск, существенно сокращается.


Работа с панелью Поиск

Для того чтобы активизировать панель Поиск (Search), нажмите кнопку с изображением глобуса и лупы на основной панели обозревателя. Кстати, запустить Поиск (Search) можно еще и другим способом — при помощи "горячих" клавиш или из меню Вид (View). Комбинация клавиш <Ctrl>+<E> открывает панель Поиск (Search). А меню Вид (View) имеет древовидную структуру. Соответственно для запуска выберите команду Вид | Панели обозревателя | Поиск (View | Explorer Bar | Search).

Итак, панель открыта. Теперь посмотрим на то, что она из себя представляет (рис. 5.7).

Рис. 5.7. Панель Поиск

На самой верхней строчке располагается ее название, а также кнопка, позволяющая закрыть панель. Кнопка имеет форму крестика (или буквы X). Далее, на строчке ниже есть кнопки Создать (New), Следующий (Next) и Настроить (Customize).

П Создать (New) — нажав эту кнопку, в панели появится форма для ввода поискового запроса, кнопка Поиск (Search). Разберемся в этом поподробнее. Для того чтобы что-то найти, нужно всего лишь ввести запрос и нажать на кнопку отправки. Через несколько секунд (время ожидания зависит от производительности вашего компьютера, а также скорости, с которой вы подключаетесь к Интернету) в том же окне (поисковой панели) появится ответ сервера на ваш запрос. Он будет представлен в удобном для чтения и разбора виде. В зависимости от используемой поисковой машины, результаты будут выглядеть по-разному: различная релевантность, отличные друг от друга сайты, неповторимое оформление и т. д. После того, как вы убедились, что найденная страничка это именно то, что вам нужно, достаточно выбрать ссылку и щелкнуть по ней один раз. В соседнем, т. е. основном окне обозревателя загрузится именно этот веб-сайт.

Следующий (Next) — использовать другую поисковую систему для того же самого запроса. Причем вы можете выбрать наиболее приглянувшийся поисковик из списка. Его можно активизировать, нажав на правый край кнопки Следующий (Next). Результаты повторного поиска будут представлены все там же.

Настроить (Customize) — вызывает окно, в котором вы можете настроить параметры поиска (рис. 5.8), т. е. указать предпочтительные поисковые системы и выбрать механизм работы панели.

Рис. 5.8. Окно Настройка параметров поиска

Там же возможно настроить приоритет использования различных поисковиков. Самый используемый должен находиться сверху, а самый неупотребляемый — снизу. Чтобы поменять приоритет, используйте функциональные кнопки вверх (UP), вниз (Down), которые присутствуют в окне настройки параметров поиска. Имеется также возможность сохранить предыдущие поисковые запросы (до 10). Для этого нужно установить флажок в соответствующем поле. Там же можно задать страницу, с которой открывается панель Поиск — с Поиска веб-страницы (Web-page search) или с Предыдущего поиска (Last search).

Теперь разберем на примере, как работать с этой функцией браузера. Предположим, нас интересует какая-то информация по обозревателю Microsoft Internet Explorer. Значит, поисковый запрос у нас будет выглядеть так "Microsoft Internet Explorer". Вводим эту фразу в специальное поле ввода и нажимаем кнопку с надписью Поиск (Search). В зависимости от приоритета поисковых систем, результаты будут разными-. Например, у меня первым был установлен Яндекс. Значит, поиск осуществлялся машиной Яндекса. Результаты меня удовлетворили, и использовать какой-либо еще поисковик для меня не имеет смысла. Поэтому на этом работа с панелью Поиск (Search) у меня прекращается. Для тех же, кого итоги поиска не устроили, существует возможность нахождения информации при помощи другой поисковой системы. Для этого достаточно нажать кнопку Следующий (Next), и через несколько секунд перед вашими глазами предстанут результаты поиска, которые, возможно^ вас удовлетворят. Если этого не произошло, попробуйте сформулировать запрос по-другому. Например, убрать некоторые слова/буквы или же просто перефразировать запрос.

К этому моменту следует подойти достаточно серьезно. Ведь неправильно сформулированный запрос может привести к тому, что ничего не будет найдено или найдено совсем не то, что вам нужно. Поэтому при первой попытке рекомендуется использовать как можно больше ключевых слов, а также использовать возможности расширенного поиска.

Преимущества использования поисковой панели очевидны. Нет необходимости открывать много окон, в каждом из которых будет загружаться определенная поисковая система, а затем найденные сайты. Таким образом, нагрузка на процессор снижается, результаты поиска предстают в более удобной, лаконичной форме, что позволяет затрачивать меньше времени на поиск необходимой информации и, соответственно, уменьшить время нахождения в сети.


Журнал

Часто в Интернете можно встретить интересные сайты. Причем встретить по-разному: то придя по баннеру, то по ссылке в поисковой системе. И подчас бывает сложно запомнить его адрес. И иногда хочется вернуться на страницу. А как это сделать, если URL не запомнился, а в Избранное сайт добавлен не был? Вот тут-то вам на помощь приходит Журнал. Это система, которая позволяет посмотреть на ход вашего путешествия по Интернету. Иногда это бывает очень интересно. Использование Журнала дает возможность найти "потерянные" веб-сайты без особых усилий.

Для того чтобы вызвать его, существует несколько способов.

  • Первый, и, наверное, самый простой — нажать кнопку с изображением солнечных часов и надписью Журнал на главной панели браузера.
  • Еще один вариант — использование "горячих" клавиш. В данном случае это комбинация клавиш <Ctrl>+<H>. To есть для запуска панели Журнал на клавиатуре нужно одновременно нажать комбинацию клавиш <Ctrl>+<H>.
  • Третий способ — в меню Вид (View) выбрать команду Панели обозревателя (Explorer Bar), а уже там выбрать Журнал (History).


Работа с Журналом

Журнал представляет из себя специальную панель, которая располагается в левой части окна обозревателя Microsoft Internet Explorer 6.0 (рис. 5.9).

Рис. 5.9. Панель Журнал

Здесь представлены сайты, сгруппированные по определенным признакам. В зависимости от того, как давно вы используете браузер, количество папок в панели может варьироваться. На неделе, каждый день появляется новая папка с именем дня. Далее, по окончании недели, те 7 папок превращаются в одну большую, которая носит название Прошлая неделя (Last week). Соответственно через 7 дней папка будет переименована в 2 недели назад (2 weeks ago) и т. д.

Работать с Журналом (History) достаточно легко. Для начала нужно настроить параметры отображения информации в нем. Это можно сделать из меню Вид (View). Там вы можете выбрать порядок сортировки веб-сайтов: по дате (Date), по веб-узлу (Web-site), по количеству посещений (times visited), по порядку посещения (date visited).

  • по дате (Date) — это означает, что сайты будут отсортированы по времени посещения. Это может быть полезно, если вы вдруг захотите посмотреть страницу, отобранную вами скажем три дня назад, а адреса ее не помните.
  • по веб-узлу (Web-site) -- данный способ позволяет посмотреть вебстраницы, посещенные на определенном сайте.
  • по количеству посещений (times visited) — как понятно из названия, сортировка будет происходить по количеству посещений. Самая популярная страница будет находиться вверху, а самая непривлекательная соответственно внизу.
  • по порядку посещения (date visited) — по-моему, самый интересный и познавательный способ просмотра Журнала. При его помощи вы сможете отследить порядок вашего следования по сети Интернет. И, наконец, разобраться в том, прчему вы все время попадаете туда, куда не желаете.

Но на этом возможности панели Журнал (History) не заканчиваются. Одной из самых привлекательных его функций является возможность поиска определенной веб-страницы, посещенной вами, по ключевым словам. Ими могут быть какие-то буквы, сочетания букв, содержащиеся в адресе веб-сайта или, например, в его имени.

Для того чтобы запустить Поиск (Search), нажмите кнопку с изображением солнечных часов и лупы, которая располагается справа от кнопки Вид (View). В панели появится новое поле — Искать (Search) (рис. 5.10).

Рис. 5.10. Поиск в Журнале

Для того чтобы начать поиск, нужно ввести ключевые слова в поле ввода и нажать кнопку с надписью Искать (Search Now). Чтобы остановить поиск, нажмите кнопку Остановить (Stop). Если вы сразу не нашли сайт, который ищете, не отчаивайтесь, попробуйте вспомнить его название или что-то, что у вас с ним ассоциировалось и может содержаться в имени страницы.

Закрыть панель Журнал (History) очень легко. Вы можете воспользоваться одним из представленных выше способов открытия (закрытие аналогично), либо закрыть ее по-другому. Для этого найдите на панели Журнал (History) кнопку, напоминающую букву X, и нажмите ее. Панель будет закрыта.

Стоит заметить, что вам, возможно, просто не хватает места на экране, а закрывать Журнал не хочется. Тогда вы можете уменьшить размер панели. Для этого подведите курсор к границе окна веб-страницы и* панели Журнал (History), нажмите левую кнопку мыши и потяните границу панели влево. Таким же образом можно увеличить размер панели. Только тогда потянуть надо будет вправо.


  • Глава 6. Рабочий стол Active Desktop
    • Работа с Active Desktop
    • Шаблоны с сайта Microsoft


ГЛАВА 6.

Рабочий стол Active Desktop

Рабочий стол Active Desktop делает возможной настройку рабочего стола, запуск программ, переключение между файлами и отслеживание последних мировых новостей замечет объединения веб и рабочего стола пользователя. Рабочий стол Active Desktop позволяет преобразовывать элементы веб в элементы рабочего стола и обновлять их в любое время.

На сегодняшний день рабочий стол Active Desktop практически не используется. Причин для этого несколько, основными из которых является медленная скорость работы в сети и тот факт, что сайты практически не поддерживают данную функцию. Главным же минусом является невозможность постоянного доступа в сеть для большинства пользователей. А рабочий стол как раз требует этого. Например, чтобы оперативно обновлять новости.


Работа с Active Desktop

Для начала нужно настроить рабочий стол Active Desktop под ваши персональные требования. Чтобы вызвать окно настройки, необходимо* воспользоваться контекстным меню на рабочем столе. Выберем команду Свойства ( Properties). В появившемся диалоговом окне выберите вкладку Интернет (Web) (рис. 6.1).

Для начала нужно сделать так, чтобы рабочий стол стал активным. Для этого установите флажок Отображать Active Desktop как веб-страницу.

Теперь нам стали доступны некоторые кнопки. Нажимаем кнопку Создать (New). Появляется диалоговое окно, в котором вам предлагается либо выбрать элемент активного рабочего стола из имеющихся на сайте корпорации Microsoft, либо из имеющихся у вас на компьютере. Рассмотрим каждый из этих вариантов.

Рис. 6.1. Диалоговое окно Свойства: Экран


Шаблоны с сайта Microsoft

В диалоговом окне нажимаем кнопку Да (Yes). Окно свойства закрывается и загружается браузер Microsoft Internet Explorer 6.0. В этот момент нужно быть подключенным к Интернету. Иначе ничего не получится. Через несколько секунд загрузится веб-страница с галереями для рабочего стола Active Desktop (рис. 6.2).

На момент написания книги их было совсем немного. Нас заинтересовала галерея, которая позволяет просматривать движение некоторых спутников по орбите. Чтобы установить ее, достаточно лишь нажать картинку с надписью Add to Active Desktop. Сразу же появится диалоговое окно (рис. 6.3), в котором нас спрашивают, хотим ли мы установить этот компонент.

Нажимаем кнопку Да (Yes). Элемент начинает загружаться. Далее остается только настроить его и посмотреть на то, что получилось. Для того чтобы настроить обновление и тому подобное, необходимо опять запустить окно настройки рабочего стола. В этот раз мы сделаем это другим способом — при помощи контекстного меню. Выбираем команду меню Настроить рабочий стол Active Desktop, и загружается уже знакомое окно, правда, с некоторыми изменениями. Теперь нужно настроить работу компонента активного рабочего стола — J-Track. Для этого выделяем его и нажимаем кнопку Свойства (Properties). В появившемся окне (рис. 6.4) мы можем посмотреть параметры данного элемента.

Рис. 6.2. Выбор элемента активного рабочего стола, окно Microsoft Internet Explorer

Рис. 6.3. Диалоговое окно Internet Explorer

Например, адрес веб-страницы, с которой происходит обновление или количество визитов на нее. Немаловажным полем является Сделать эту страницу доступной автономно (Make the page available offline). Установите флажок здесь. В противном случае этот элемент будет правильно работать только, если вы подключены к Интернету.

Рис. 6.4. Окно Свойства: J-Track: Satellite Tracking

Выбрав вкладку Расписание (Schedule), вы можете настроить параметры обновления данной веб-страницы. Вы можете либо обновлять ее тогда, когда происходит запуск обновления из меню Сервис (Topis), либо автоматически — при помощи мастера планировщика. Выбрав второй вариант, вы можете установить время обновления, количество обновлений в неделю и т. д. Для этого нужно выбрать J-Track и нажать на кнопку Изменить (Edit). В появившемся окне вы можете выбрать имя для данного веб-сайта в мастере планировки. Во второй вкладке можно задать соединения, при помощи которых будут происходить обновления.

Вкладка Загрузка (Download) в окне свойства представляет некий интерес. Здесь вы можете указать специфические параметры обновления этого элемента рабочего стола, а также "можете указать, что загружать, в каких объемах. Первое поле — Все содержимое, указанное поставщиком канала (All contents, specified by content-provider), оставляет за вашим контент-провайдером право выбирать то, что нужно скачать. Флажок установлен по умолчанию. Если пометить второе поле, то загружаться будет только основная страница сайта, а также список ссылок. Последнее поле позволяет ограничить количество загружаемых килобайт. Это может быть нужно при нехватке свободного места на жестком диске или при высокой стоимости трафика. Нажатием кнопки Дополнительно (Advanced) вы сможете установить дополнительные параметры. В новом окне можно установить, что загружать.

Например, изображения, или java-апплеты и элементы ActiveX. Интересная группа параметров — Загрузка ссылок (Download through links) — позволяет загружать все документы, на которые имеются ссылки. После того как все настроено, остается нажать кнопку ОК в этом и предыдущем окне. Теперь можно запустить элемент рабочего стола.

Начинает загружаться апплет (рис. 6.5).

Окно можно передвигать и даже задавать некоторые параметры. Возможно, кому-то это понравится. Но лично мне кажется, что такие вот апплеты занимают достаточно много места на рабочем столе и не имеют особо никакого назначения. Проще говоря, они не полезны.

Рис. 6.5. Рабочий стол

Рассмотрим второй случай — когда вы сами выбираете веб-страницу, которая будет использоваться в качестве элемента рабочего стола. Для этого в контекстном меню рабочего стола выбираем команду Свойства, вкладка Интернет, и нажимаем кнопку Создать. В появившемся диалоговом окне Новый элемент рабочего стола нажимаем кнопку Нет (No). Появляется новое окно, в котором предлагается ввести адрес веб-страницы, которая будет использоваться в качестве элемента рабочего стола, либо выбрать какой-либо документ при помощи кнопки Обзор (Browse). Нажав кнопку Обзор (Browse), появится окно, в котором предлагается выбрать веб-сайт из представленных в Избранном (или любой другой папке, содержащей ссылки на веб-сайты). После того как выбор сделан, остается нажать кнопку Открыть (Open). Далее -- кнопку ОК. Появится окно, в котором вам предлагается либо согласиться с текущими настройками, либо дополнить их (об этом будет рассказано во второй части книги). В большинстве случаев дополнительных настроек не требуется, поэтому просто нужно нажать кнопку ОК. В следующем окне даются сведения о том, сколько информации уже загружено, т. е. синхронизировано. После того как все вышесказанное выполнено, вы можете смело нажимать кнопку ОК в окне Свойства (Properties) контекстного меню рабочего стола. И вот элемент создан.

В данной главе была рассмотрена работа с рабочим столом, который впервые появился с выходом Microsoft Internet Explorer 4.0. В Microsoft ожидали, что Active Desktop станет революционным изобретением. Ведь, действительно, идея очень и очень интересная — создать среду, которая бы позволяла работать с веб, как с домашним компьютером. Но на тот момент пользователи были просто не готовы к этому. Стоимость подключения к Интернету была достаточно высока, да и скорость оставляла желать лучшего. На сегодняшний день ситуация немного изменилась в лучшую сторону, но все равно пока это нельзя использовать в полной мере. Не так давно мир узнал о планах Microsoft о создании революционно новой операционной системы, полностью интегрированной с Интернетом. Звучит знакомо, не правда ли? То же самое говорили и про Windows 98. В компании понимают, что сейчас рядовой пользователь опять же не готов к таким нововведениям, поэтому релиз новой ОС отложен на неопределенный срок. Ранее планировался ее выпуск после Windows XP, но уже сейчас стало известно, что этого не будет. Придуман промежуточный вариант под кодовым названием BlaekComb, о котором также мало известно. Как говорится, поживем — увидим.

А сейчас пора переходить ко второй части Самоучителя — выбор оптимальной конфигурации.


  • ЧАСТЬ II. ВЫБОР ОПТИМАЛЬНОЙ КОНФИГУРАЦИИ
    • Глава 7. Настройка внешнего вида обозревателя
      • Интерфейс Microsoft Internet Explorer 6.0
      • Контекстное меню
      • Установка дополнительных панелей
      • Кнопки
      • Удаление и установка новых кнопок
      • Внешний вид кнопок
      • Советы для пользователей Netscape и Opera
      • Netscape
      • Избранное
      • Opera
      • Правильное отображение веб-страниц в кодировке любого языка
      • Кодировки
      • Кодовая страница
      • Русские кодировки
      • Выбор кодировки вручную
      • Автоматический выбор кодировки


Часть II.

Выбор оптимальной конфигурации

  • Глава 7. Настройка внешнего вида обозревателя
  • Глава 8. Выбор оптимальной конфигурации Internet Explorer 6.0
  • Глава 9. Конфигурирование службы FTP


ГЛАВА 7.

Настройка внешнего вида обозревателя

Внешний вид программы имеет огромное значение. От этого зависит ее популярность.

Основным критерием выбора программы за последнее время стало так называемое в западной компьютерной прессе usability, т. е. удобство использования. Как известно, то, что красиво, не всегда удобно, и наоборот. Поэтому программисты пытаются создать привлекательный и в то же время удобный для использования вид приложения.

Интерфейсы программ для Windows можно поделить на стандартные и нестандартные. Под стандартным понимается вид, аналогичный интерфейсу операционной системы. Например, Блокнот или Калькулятор. Нестандартный же никак не похож на операционную систему, чаще всего имеется возможность менять оболочки, использовать собственные цветовые решения и т. д.

Интерфейс Microsoft Internet Explorer — стандартный. В нем нет ничего выдающегося, экстраординарного. Вообще об обозревателе от Microsoft сложно говорить, как о каком-то произведении дизайнера. Все те же стандартные кнопки, те же меню. Его облик полностью соответствует облику операционной системы. Но, несмотря на это, вы можете изменять его вид. Может быть не так значительно, как в программах, принадлежащих ко второй группе, но все же. Вообще все изменения интерфейса программы рассчитаны на упрощение работы с ней. Поэтому из того, "что было", каждый сможет "слепить" что-то для себя.


Интерфейс Microsoft Internet Explorer 6.0

Впервые запустив обозреватель, перед вашими глазами предстанет такое изображение — рис. 7.1.

Рис. 7.1. Окно Microsoft Internet Explorer

Сверху располагается панель с раскрывающимися меню. Чуть ниже — панель инструментов. Далее — адресная строка с кнопкой Переход (Go) и панель ссылок.

Сейчас они расположены в том порядке, в котором программисты, дизайнеры из Microsoft посчитали нужным. По статистике большинство пользователей что-либо хотят изменить во внешнем виде браузера, чтобы он соответствовал их потребностям. Понимая это, программисты из Microsoft сделали возможным передвижение, уменьшение или увеличение, удаление и настройку панелей браузера.

Прежде всего, вы можете передвинуть любую панель туда, куда вам заблагорассудится. Для этого достаточно подвести курсор к тому, что вы собираетесь подвинуть. Затем нужно нажать левую кнопку мыши. Курсор примет форму крестика — рис. 7.2.

Далее, все также при нажатой левой кнопке мыши, передвигайте ту или иную панель туда, куда вам нравится. Например, адресную строку можно переместить на панель инструментов (рис. 7.3).

Рис. 7.2. Форма курсора при передвижении панелей

Рис. 7.3. Панель инструментов после преобразования

В предыдущих версиях Microsoft Internet Explorer нельзя было зафиксировать панель на одном месте. То есть в любом случае вы могли ее случайно передвинуть. В 6-й версии обозревателя эта проблема решена. Теперь, настроив внешний вид браузера, выберите команду Закрепить панели инструментов (Lock the Toolbars) из контекстного меню.


Контекстное меню

Контекстное меню позволяет выполнять операции с интерфейсом браузера быстрее и эффективнее. Для того чтобы открыть его, подведите курсор к одной из панелей обозревателя и нажмите правую кнопку мыши. Появится следующее меню — рис. 7.4.

Рис. 7.4. Контекстное меню

Панели, которые сейчас активизированы, помечены флажком. Для того чтобы убрать или активизировать новую панель, достаточно снять или установить флажок соответственно.

  • Обычные кнопки (Standard Buttons) — панель инструментов, там, где расположены навигационные и другие кнопки.
  • Адресная строка (Address Bar) — адресная строка, место для ввода URL веб-страницы.
  • Ссылки (Links) — панель ссылок.
  • Закрепить панели инструментов (Lock the Toolbars) — зафиксировать панели.
  • Кнопка Переход (Go button) — кнопка переход. Можно использовать вместо нажатия на клавишу <Enter>.


Установка дополнительных панелей

Начиная с версии 5.0, вы можете установить дополнительные панели для обозревателя Microsoft Internet Explorer. Эти панели могут иметь разное назначение. Но в большинстве случаев они обеспечивают наиболее быстрый доступ к поисковым системам, каталогам и т. д. В англоязычном Интернете такие модули уже давно пользуются заслуженной популярностью. В Рунете до недавних пор ни один портал не предоставлял такой возможности. Не так давно популярный интернет-портал Яндекс представил на суд пользователей Яндекс.Бар (yandex.bar) — надстройку для браузера Microsoft Internet Explorer (рис. 7.5).

Ее использование повышает эффективность интернет-серфинга, а также предоставляет уникальные возможности за счет использования сервисов Яндекса. Вы также можете осуществлять поиск. Для этого в специальной строке введите запрос, а затем выберите поисковую систему.

Положение Яндекс.Бар (yandex.bar), как и любой другой панели, можно менять. Это поможет наиболее рационально распределить пространство. Особенно это нужно при маленьком разрешении экрана.

Рис. 7.5. Окно Яндекс.Бар: Справка по использованию — Microsoft Internet Explorer


Кнопки

Как известно, на панели инструментов представлены наиболее используемые кнопки. Например, Вперед (Forward), Назад (Back), Остановить (Stop). Дело в том, что теперь любая устанавливаемая программа может добавить свою кнопку на панель. Будь то менеджер загрузки или медиа-плейер. И иногда эти появившиеся кнопки оказываются совершенно не к месту. Для этих и для других целей была придумана возможность установки/удаления кнопок. Чтобы это сделать, наведите курсор на панель инструментов и нажмите правую кнопку мыши. Появится контекстное меню. В нем выберите пункт Настройка (Customize). Появится новое окно — Настройка панели инструментов (Customize Toolbar).


Удаление и установка новых кнопок

Окно Настройка панели инструментов (Customize Toolbar) поделено на две части. Слева располагаются доступные кнопки, т. е. еще не установленные на панели. А справа — те, которые уже есть. Для добавления той или иной кнопки используется кнопка Добавить (Add). Допустим, мы хотим, чтобы на панели имелась кнопка Печать (Print). Для этого нужно выделить строку со значком принтера и надписью Печать (Print) в левой части окна и нажать на кнопку Добавить (Add). В нашем примере кнопка Печать (Print) будет идти сразу за кнопкой Правка (Edit). В том случае, если вы захотите удалить ту или иную кнопку, сделайте следующее:

О В правой части окна выберите ту кнопку, которую хотите удалить. П Нажмите кнопку Удалить (Remove).

Возможно, вам захочется перераспределить положение кнопок. Для этого сначала удалите все имеющиеся, а после добавляйте новые по своему усмотрению. Вы также можете использовать элемент списка Разделитель (Separator) для разделения кнопок по смысловым нагрузкам, например навигационные кнопки.


Внешний вид кнопок

В обозревателе Microsoft Internet Explorer 6.0 вы можете не только изменить внешний вид панели, но и вид самих кнопок. Для этого используется все то же окно Настройка панели инструментов (Customize Toolbar).

Внизу есть два раскрывающихся списка: Текст кнопки (Text options) и Размер значка (Icon options).

С помощью раскрывающегося списка Текст кнопки (Text options) вы можете установить один из параметров отображения текста.

  • Отображать подписи к кнопкам (Show text labels) — эта опция установлена по умолчанию. В данном режиме кнопки имеют законченный вид — сверху значок, снизу надпись. Это может быть удобно при начале использовании браузера, когда еще не запомнилось какая кнопка что означает (помогают текстовые подписи).
  • Выборочно текст справа (Selective text on right) — текстовые пояснения только для некоторых кнопок. Таким образом, можно оптимизировать отображение панели инструментов, уменьшить ее размер, но в то же время сделать ее вид более приятным для просмотра. Стоит также отметить, что размер кнопок уменьшается, следовательно больше может поместиться. На рис. 7.6, изображена панель в данном режиме.

Рис. 7.6. Панель инструментов в режиме отображения избранного текста

  • Без подписей к кнопкам (No text labels) — режим отображения кнопок без подписей. Он подходит прежде всего для тех, кому нужно поместить много кнопок на панель, кто помнит, что каждая из них обозначает и не нуждается в текстовых подписях. Режим также подходит обладателям старых мониторов, не позволяющих поставить высокое разрешение экрана.

Раскрывающийся список Размер значка (Icon options) определяет два режима отображения значков:

  • крупные значки (Large icons) — большие значки. По умолчанию указан именно этот режим;
  • мелкие значки (Small icons) — маленькие значки.


Советы для пользователей Netscape и Opera

На сегодняшний день Microsoft Internet Explorer держит лидирующие позиции на рынке браузеров. Но еще несколько лет назад Netscape Navigator был прямым конкурентом обозревателя от Microsoft. Еще тогда Netscape Navigator продавался, не был бесплатен как сейчас. В те времена шла настоящая война между производителями. Разрабатывались всевозможные плагины (надстройки) для браузеров, шла живая конкуренция. Она шла на пользу пользователям. Ведь за небольшой промежуток времени очень сильно менялась сеть, становилась доступнее, красивее и информативнее, браузеры учились понимать все больше и больше стандартов. С выходом операционной системы Windows 98 Netscape начал терять свои позиции. Ведь Microsoft Internet Explorer был встроен в ОС. Причем так удачно, что пользователю даже не приходило в голову покупать и устанавливать альтернативный браузер. Кстати с тех же времен идет борьба Microsoft и антимонопольного законодательства. Но сейчас пользователя это не очень интересует.

Этот раздел посвящен тем пользователям, кто работал с браузерами Netscape Navigator и Opera.


Netscape

Обозреватель Netscape Navigator версии 4.11 внешне очень похож на Internet Explorer. Та же адресная строка, та же панель инструментов. Для обыкновенного пользователя отличия только внешние. Профессионал же понимает, что работают браузеры с веб-страницами по-разному. Это означает, что одни и те же сайты отображаются по-разному. Веб-дизайнерам и прочей интернет-общественности это не очень нравится. Ведь приходится создавать, тестировать и настраивать-сайт под несколько разных браузеров. Для этого создавались всевозможные интернет-консорциумы, которые пытались создать общие для браузеров стандарты. Но даже сейчас им этого полностью достичь не удается.

Для конечного пользователя отличия в браузерах заключаются в разных названиях одного и того же. С ними можно ознакомиться в табл. 7.1.

Таблица 7.1. Различия в терминах

Выполнить | В Netscape Navigator | В Internet Explorer
Добавить в избранное | Bookmarks | Favorites
Переход на веб-страницу | Location field | Address bar
Перезагрузить веб-страницу | Reload | Refresh
Добавить ссылки на веб-страницы | Personal Toolbar | Links bar
Создать календарь обновлений веб-страниц, доступных автономно | Netcaster, subscribing, automatic delivery, channels | Making favorites available offline


Избранное

Если вы уже достаточное время используете Netscape Navigator, то у вас уже могло накопиться большое количество ссылок на ваши любимые сайты в закладках. Перенос их в Internet Explorer вручную может занять много времени, да и сильно утомить. Создатели обозревателя от Microsoft учли эту проблему. Все закладки Netscape автоматически импортируются в Избранное Internet Explorer. Импортированные закладки находятся в Избранном, в специально созданной папке Импортированные закладки. Теперь для доступа к вашему любимому веб-узлу просто щелкните по его названию.


Opera

Opera — относительно новый программный продукт, приобретший значительную популярность среди пользователей Интернета. С самого своего появления Opera позиционировал как альтернативный браузер, не пытаясь конкурировать с такими гигантами, как Netscape и Microsoft. Главными преимуществами Opera авторы считают скорость ее работы, маленький размер дистрибутива, удобство использования и многооконный интерфейс. Соответственно главным, неоспоримым преимуществом перед Microsoft Internet Explorer является многооконность.

Именно с ней и связаны основные проблемы у пользователей, работавших ранее с этим интернет-браузером. Она располагается внизу. В самих окнах отсутствуют навигационные кнопки. Они расположены на панели инструментов, как и в Microsoft Internet Explorer. Правда адресная строка есть в каждом окне. Терминология в Opera используется почти та же, что и в

Netscape Navigator. Соответственно, для того чтобы понять, что где находится и как называется, используйте табл. 7.1


Правильное отображение веб-страниц в кодировке любого языка

Кодировки

За последние несколько лет стандартной кодировкой русских символов становится Win-1251. Но многие пользователи до сих пор предпочитают использовать альтернативы -- КОИ-8, DOS cp866 и др. Поэтому возникает проблема работы с ними. Также существует огромное количество вебсайтов, на которых текст представлен, например, в КОИ-8.


Кодовая страница

Текстовая информация кодируется компьютером в последовательность символов из 8 бит (1 байт). Соответственно, 1 байт — 1 символ. Получается, что для записи одного символа (например, собачки @) используется последовательность из восьми нулей и единиц. Для того чтобы программа могла понять и правильно отобразить символы, была придумана таблица символов, в которой показано, какой символ соответствует какой последовательности. Таблицу символов также иногда называют кодовой страницей.

Она может храниться как в самой программе, работающей с текстом, так и быть встроенной в операционную систему. Во втором случае она автоматически представляется при каждом запросе программы. Итак, получив последовательность из 8 нулей и единиц, приложение сверяется с таблицей символов, чтобы определить, какому символу она соответствует.

Ясно, что таблица символов должна быть неким стандартом. Иначе текст просто будет нельзя прочитать. Для латиницы это так и есть. Во всех существующих таблицах символов каждая латинская буква кодируется одной последовательностью бит, строго определенной международным стандартом.

С помощью восьми бит можно закодировать до 256 символов. Действительно, каждый бит — это 0 или 1. Восьмибитных последовательностей может быть 28. 28x8=256. В английском алфавите 26 букв. В таблице символов есть как заглавные, так и строчные буквы. Поэтому под буквы отводится 52 значения. Далее, служебные символы, цифры занимают около 50 мест. В итоге под латиницу отводится 128 мест. Остаются еще 128 — специально для локализации. Например, под русский алфавит.

Коды первых 128 символов кодовых страниц получили название ASCII. По международным стандартам они должны присутствовать во всех кодовых страницах. Дело в том, что они могут кодироваться также семью битами. Первые 32 кода — управляющие символы (например, Backspace). Остальными кодировались латинские буквы (как прописные, так и заглавные), а также цифры, знаки препинания и математические операции. Коды второй половины (после 127) стали называться "расширенным" стандартом ASCII. Следовательно, ими кодировались локальные алфавиты, а также специальные символы других языков.

Тем самым была создана возможность локализации любых программ. Итак, новые таблицы символов различались только второй половиной. А в латинской кодовой странице после 127 места были подставлены гласные с надстрочными символами, используемые в некоторых языках Европы, а также символы псевдографики. В региональных таблицах они отсутствовали — там располагались символы алфавитов, отличных от латиницы. Например, русский.


Русские кодировки

Россия, впрочем, как и всегда, пошла впереди планеты всей. У нас ведь всегда брали не качеством, а количеством. Итак, было создано несколько кодировок символов русского языка. А в большинстве стран была создана единая кодовая страница для своего алфавита, чтобы избежать путаницы.

С самого начала программное обеспечение, поставляемое в Россию из-за рубежа, не умело работать с русскими символами. То есть вместо того, чтобы написать "Привет Вася" приходилось "Privet Vasya". Итак, чтобы решить эту проблему была создана русская кодовая страница, получившая название ISO-8859-5. Как следует из вышесказанного, после 127 кода следовали русские буквы — всего 66 (33 прописных и 33 строчных). Поэтому оставалось еще достаточно места для псевдографики, которая тогда использовалась крайне широко, ведь графических оболочек еще не существовало.

Примерно в это же время появилась еще одна кодовая страница — ср866. Она отличалась от ISO-8859-5 порядком следования русских букв до строчной "р", а символы псевдографики кодировались теми же кодами, что и в латинице. Соответственно, ее использование могло существенно упростить работу с нелокализованными версиями программ западных разработчиков, работающих с графикой. Например, для отображения таблицы. Поэтому, если в системе была установлена эта кодировка, графические объекты отражались верно. В противном случае, например, при установленной ISO-8859-5 рисовалась бы русская буква, вместо символа псевдографики, и такое изображение было бы неудобно просматривать.

Первой локализованной операционной системой стала MS-DOS 4.1 от корпорации Microsoft. При создании кодовой страницы была взята альтернативная ISO-8859-5 кодировка, впоследствии названная ср866. И так как все большее и большее распространение получали персональные компьютеры, кодировка ср866 стала самой популярной.

Дальше был Windows. И появилась еще одна кодировка Win-1251. Зачем? Отпала необходимость использования псевдографики. Поэтому вместо нее были встроены специальные символы: @, *, &,^ и т. д. Но возникла новая проблема. Текст, набранный в кодировке ср866, уже нельзя было прочитать. Поэтому появились программы-перекодировщики.

На персональных компьютерах повсеместно была установлена операционная система MS-DOS с кодовой страницей 866. На сетевых операционных системах все было иначе. В те годы начала свое победоносное шествие UNIX. А в ней кодировкой по умолчанию стала КОИ-8.

Зарождение Интернета происходило в Америке. Соответственно все веб, почтовые серверы предназначались для англоязычных пользователей. Так как использование графики (псевдографики) в почтовых сообщениях тогда не требовалось, расчет делался на первую половину таблицы символов (от О до 127) — семибитную кодировку.

В связи с этим, сообщения, содержащие символы с кодами, большими 127, которые было невозможно закодировать семью битами, такими почтовыми серверами обрабатываться не могли. Итак, для того чтобы решить эту проблему, придумали приводить такие сообщения к семибитному виду. Сам процесс был достаточно прост — обнулялся первый бит, указывавший на половину их кодовой страницы. И вот что получалось при таком преобразовании: русская буква "е" превращалась в "Г и т. д.

Выход был — сделать так, чтобы все почтовые серверы поддерживали восьмибитную кодировку символов. Но, к сожалению, осуществить это не представлялось возможным. Можно, конечно, было писать письмо не русскими символами, а транслитом. Но такое письмо было бы неудобочитаемым. Поэтому была придумана новая кодировка символов, которая впоследствии получила название КОИ-8. Итак, в ней на места, соответствующие кодам символов, большим 127, были поставлены русские символы, похожие по звучанию, произношению, на английские буквы. Например, "а" "б" "ц" и т. д., которые при семибитном преобразовании перешли бы в латинские "а" "b" "с".

Эта кодировка стала стандартом для UNIX-подобных операционных систем (Linux и т. д.) и используется по сегодняшний день.

Естественно, что пользователь обыкновенного персонального компьютера не мог или не хотел устанавливать ОС UNIX. Поэтому были созданы специальные программы, умеющие работать с различными кодировками. В дальнейшем эта способность была встроена практически во все приложения, тем или иным образом, связанные с сетью.

Кодировка КОИ-8 стала наиболее рекомендованной для переписки, поэтому любая почтовая программа должна была уметь работать с ней. То есть правильно отображать текст, набранный в ней.

Сейчас наиболее распространенные кодировки русскоязычного текста в Интернете — это КОИ-8 и Win. КОИ-8 — кодировка, используемая преимущественно в UNIX-подобных операционных системах. Например; Linux. Win же используется в ОС под управлением Microsoft Windows. Вы можете спросить: "А мне то что?" А все дело в том, что некоторые серверы расположены на компьютерах под управлением Windows, а некоторые — под управлением UNIX-подобной операционной системы. Соответственно кодировка русскоязычных символов различна.

К счастью, Microsoft Internet Explorer 6.0 обладает возможностью отображать веб-страницы, сохраненные в любой кодировке. Начиная с 5-й версии, обозреватель сам распознает и отображает в правильной кодировке веб-сайты.

В контекстном меню браузера (рис. 7.7) вы можете выбрать кодировку двумя способами:

  • вручную;
  • автоматически

Рис. 7.7. Выбор кодировки


Выбор кодировки вручную

На многих сайтах есть возможность выбора кодировки вручную. Например, Win-1251 или КОИ8-Р. Это делается для тех браузеров, которые не могут автоматически определять ее. Несмотря на то, что Internet Explorer имеет эту возможность, выбор кодировки не всегда происходит верно. Поэтому, если вы вдруг увидите нечитаемый текст, отключите автоматический выбор кодировки и попробуйте поставить кодировку вручную. Для этого из контекстного меню браузера выберите команду Вид кодировки (Encoding). Снимите флажок Автоматический выбор (Auto-select). Выберите команду Дополнительно (Advanced) и установите переключатель на другую кодировку, например, Кириллица КОИ8-Р или ISO. Это может помочь. Если все вышеперечисленное так и не привело к тому, что страница отображается нормально, скорее всего, это проблема на сервере.


Автоматический выбор кодировки

Microsoft Internet Explorer 6.0 обладает возможностью автоматического выбора кодировки текста. Для того чтобы эта функция работала, ее надо включить. Это можно сделать из контекстного меню: выбрать команду Вид кодировки (Encoding), установить флажок Автоматический выбор (Auto-select). Либо из меню Вид (View) выбрать команду Вид кодировки (Encoding) и проделать те же самые операции.


  • Глава 8. Выбор оптимальной конфигурации Internet Explorer 6.0
    • Оптимальные настройки соединения dial-up
    • Оптимизация модемного соединения
    • Работа с реестром
    • МТU
    • Определение MTU вручную
    • Другие параметры
    • Ускорение загрузки веб-страниц за счет отключения графики
    • Увеличение места под временные файлы


ГЛАВА 8

Выбор оптимальной конфигурации Internet Explorer 6.0

Оптимальная конфигурация — что это? И зачем? Можете спросить вы. Ведь "все работает" нормально. На самом деле это не предел.


Оптимальные настройки соединения dial-up

Да, не удивляйтесь, скорость соединения можно увеличить даже на 50%. И сделать это не так сложно. Резонный вопрос: "Почему по умолчанию скорость так низка?" Все дело в том, что настройки соединения для компьютеров под управлением операционных систем семейства Windows оптимизированы для LAN, т. е. для локальной сети. Но ведь тысячи людей подключаются к Интернету с помощью телефонной линии и модема. Соответственно для таких пользователей есть что оптимизировать.

Сразу стоит заметить, что визуально скорость соединения будет та же. Как вы соединялись на скорости 33 600 бит/с со своим интернет-провайдером, так и будете. Прирост будет виден в особенности при работе с сайтами: текст и изображения станут загружаться значительно быстрее.

К сожалению, в Windows изначально не встроена программа, позволяющая любому, даже самому неподготовленному пользователю с легкостью изменить эти параметры. Поэтому существует два пути:

  1. Работать с реестром.
  2. Использовать программы сторонних производителей.

Хочется отметить, что работать с реестром не так просто, как может показаться на первый взгляд. Неопытный пользователь может сделать что-то не то, и система, возможно, даже не будет загружаться. Поэтому описываемый ниже способ рассчитан только на хорошо подготовленных пользователей персонального компьютера.

Для "чайников" же больше подойдет второй способ — использование программы стороннего разработчика.


Оптимизация модемного соединения

Работа с реестром

Пока в Европе и Америке уже вовсю работают на высоких скоростях с Интернетом, используя ADSL, ISDN-подключения, в России эти способы подключения остаются слишком дорогими. Поэтому пользователи предпочитают использовать относительно дешевый способ доступа в Интернет — модемный. На наших телефонных линиях качество связи оставляет желать лучшего, поэтому не получается работать даже на таких низких скоростях, как 33 600 бит/с.

Однако многим пользователям уже давно известно, что скорость работы с Интернетом можно значительно увеличить, настроив некоторые недокументированные параметры. Настройка параметров TCP/IP для многих уже стала догмой. Но что именно делать, пользователи не всегда представляют. Поэтому в некоторых случаях вместо улучшения работы они получают значительное ухудшение. В итоге, винят в этом всех, кого только можно — некачественные телефонные линии, Билла Гейтса, придумавшего Windows, и т. д.

Сейчас существуют тысячи(!) программ, позволяющих оптимизировать скорость работы с Интернетом. Главное же, что для этого не нужно учиться работе с реестром, обладать какими-либо феноменальными способностями, учиться программированию или знать основы Интернета. Существует огромное множество программ, делающих все за вас. Одним из главных их лозунгов стало: "Нажмите одну кнопку, и скорость соединения возрастет в несколько раз". Конечно, это не соответствует действительности. Скорость загрузки возрастет не более чем на 50%, что тоже не мало. В Интернете опубликованы десятки статей, в которых даются рекомендации по установке параметров соединения. Слепо следовать таким советам нельзя. Это может привести к обратным результатам, т. е. скорость загрузки наоборот может упасть.

Но, оставить все как есть тоже бессмысленно. Ведь при неправильной настройке параметров соединения теряется ваше время, ваши деньги. Поэтому все это нужно оптимизировать.


MTU

Первым делом, конечно, необходимо разобраться в MTU, о котором наслышаны уже почти все, кто когда-либо сталкивался с Интернетом. MTU — Maximum Transmission Unit.

В реестре он задается таким образом:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Class \NetTrans\000x "MaxMTU"="1500"

Это максимальный размер пакета данных, который может быть передан за один физический кадр по протоколу TCP/IP. Дело в том, что данные от компьютера к компьютеру в Интернете идут не сплошным потоком, а этими самыми кадрами. Кадр — это пакет определенного размера. Казалось бы, все очень просто, но нет. Самым оптимальным вариантом был бы следующий. Предположим, что все компании, в той или иной мере связанные с Интернетом, договорились о едином стандарте (размере) этих пакетов, то можно было бы по максимуму использовать каналы связи, отсутствовал бы так называемый "пакетный" мусор.

К сожалению, это невозможно. Еще одна проблема состоит в том, что при установке соединения два компьютера должны согласовать размер пакетов, но еще и по пути следования их размеры могут меняться, т. к. кадр на пути к месту назначения преодолевает целый ряд промежуточных серверов и маршрутизаторов, настройки MTU которых могут быть совершенно различными. Следовательно, чем больше пакет, тем больше вероятность того, что он по пути следования будет разбит и заполнен "мусором".

Так, если ваш провайдер имеет установки MTU=576, а у вас в Windows задано MTU=1500, то каждый ваш пакет будет им разбиваться на три по 576 байт: 576+576+576=1728 — т. е. 228 байт балласта будут добавляться к каждому вашему пакету. Но даже если провайдер тоже поставил у себя MTU=1500, то при связи с удаленным сервером вполне может попасться маршрутизатор с меньшим значением MTU, и пакеты опять-таки будут фрагментироваться, замедляя передачу данных.

В Microsoft Windows есть функция автоматического определения MTU. Она включена по умолчанию и несколько спасает ситуацию. Но есть и минус: процедура вычисления MTU для каждого соединения требует немало времени, что чуть тормозит работу при прокачке небольших файлов и веб-серфинге. Да и в случае несогласования ваших параметров c параметрами интернет-провайдера эта функция вряд ли вам поможет. Конечно, существуют некие более или менее общепринятые стандарты для данного параметра: так, например, для Ethernet MTU равен 1500 байт, для SLIP — 1006, для РРРоЕ -1492, для РРР (т. е. модемной связи с Интернетом) — 576.

На деле ваш интернет-провайдер мог выставить любые другие значения по своему усмотрению. В результате чего отправляются либо совсем маленькие кадры, которые не позволяют в полной мере загрузить канал связи, либо слишком большие, которые интернет-провайдер разбивает на меньшие. Тем самым ухудшается качество связи, скорость работы во Всемирной паутине.

На самом деле каждый пакет состоит еще из нескольких сегментов. Это заголовки и фактические данные. Та часть, где содержатся только фактические данные, называется MSS или Maximum Segment Size, что является еше одним параметром протокола TCP/IP, определяющим самый большой сегмент, теперь уже данных, передаваемых в единицу времени. В действительности MTU состоит из MSS и заголовков TCP/IP.

В реестре MSS задается так:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\MSTCP "DefaultMSS"="Bame число"

Заголовок также имеет стандартный размер — 40 байт. 20 байт под IP и 20 байт под TCP. Следовательно, размер MSS составляет разность MTU и заголовка, т. е. 40 байт. Вот почему в определении оптимального размера MTU есть некоторые тонкости.

Для примера, стоит изучить передачу данных при разном размере MTU по широкополосной линии Т1 (пропускная способность- 1544000 бит/с), используя следующую формулу:

[(MSS + заголовок) х 8 бит/байт] / [1 544 000 бит/с] = задержка на один хоп (т. е. на каждый компьютер в Сети по пути нашего пакета).

Используя в этой формуле разные величины MTU, мы можем вычислить задержку одного пакета. Если MTU=1500, тогда

задержка = (1460+40) х 8/1 544 000 = 7,772 мс.

Если же MTU=576, то

задержка = (536+40) х 8/1 544 000 = 2,984 мс.

Предположим, что по пути пакета встречается 10 серверов, тогда при MTU=1500 получим задержку 77,72 мс, а при MTU=576 — 29,84 мс — разница весьма заметна.

Поэтому, очевидно, что пакеты меньшего размера будут передаваться быстрее из-за небольшой пропускной способности линии. Однако не все так просто. Используя ту же формулу, давайте посчитаем, за какой промежуток времени будет передан файл размером 1 Мбайт по той же широкополосной линии Т1. Один мегабайт равен 1024 Кбайт или 1 048 576 байт. Если MTU = 1500, то, как мы выяснили, задержка на один хоп составит 7,772 мс.

1 Мбайт/MSS = 1 048 576/1460 = 718,2, т. е. всего требуется 719 эффективных пакетов, чтобы передать 1 мегабайт данных. Далее, умножаем 719 пакетов на 7,772 мс, получаем 5588,083 мс, или 5,588 секунд задержки на один хоп. Если же мы передаем свой файл через 10 хопов, что встречается чаще, чем один, то получаем 55,88 сек — это время, которое мы (вернее, поставщик услуг, доступа в Интернет, имеющий линию Т1) потратим на передачу файла в 1 Мбайт при идеальной связи. Если же MTU=576, то: 1 Мбайт/MSS = = 1 048 576/536 = 1956,300, т. е. при таком MTU нужно 1957 пакетов, чтобы передать 1 Мбайт.

Далее, умножаем количество пакетов на задержку каждого из них: 1957 х 2,984 = 5840,580 мс, или 5,841 секунды на один хоп. Ну и соответственно на 10 хопов придется 58,41 сек. Как видим, из-за того, что при использовании больших пакетов передается меньше заголовков, реальная скорость передачи файла получается выше.

Для того чтобы передать 1 мегабайт при использовании MTU = 1500, нужно переслать "довесок" заголовков из 28 760 байт, тогда как при использовании MTU = 576 получаем аж 1957x40 = 78 280 байт, т. е. дополнительные 49 520 байт заголовков на каждый мегабайт полезной информации. Для нашей 10-хоповой передачи это выливается в лишних 2,52 секунды при передаче каждого мегабайта даже при сверхбыстрой связи.

Эта разница, возможно, будет еще немного выше на практике, т. к. современные реализации TCP/IP стремятся использовать еще большие заголовки (например, дополнительные 12 байтов заголовка для отметок времени). Если же провести аналогичные расчеты для связи по модему на скорости 33 600 Кбит/с, то получим, что на передачу мегабайта информации на расстояние одного хопа^, т. е. непосредственно вашему провайдеру, будет потрачено в идеале 256 секунд при MTU=1500 и 268 секунд при MTU=576.

Разница на одном переходе 12 секунд или около 4,5%! Но не следует забывать, что эти цифры получатся при условии отсутствия фрагментации пакетов, т. е. если у вашего провайдера MTU=1500. Если же это не так, то, разумеется, больший, чем нужно, пакет будет фрагментироваться — разбиваться на несколько пакетов и даже разбавляться "воздухом", и связь ухудшится на 10—50%.

Таким образом, логично считать, что большие пакеты в итоге все-таки предпочтительнее. И если ваш провайдер настроил свои серверы и маршрутизаторы на большие пакеты, то надо стремиться использовать это на всю катушку, но не забывать и о том, что в Интернете встречаются серверы с MTU=576 (об этом чуть ниже мы еще поговорим). Тем не менее, если чистая производительность не является окончательной целью, то меньшие пакеты будут более "быстрыми", поскольку они требуют меньше времени для своих путешествий по Сети.

Этот эффект может перевешивать все другие достоинства больших пакетов в некоторых интернет-приложениях и онлайновых играх за счет уменьшения времени отклика удаленного сервера при передаче небольших объемов информации.

В Интернете по пути следования ваших пакетов, вероятно, встретятся самые разные серверы с самыми разными настройками, но для начала все-таки желательно определить наилучшее значение MTU при связи только с вашим провайдером, поскольку именно оно может оказать решающее значение при оптимизации вашего доступа в Сеть.

В Windows 95 разработчиками по умолчанию было выбрано MTU=1500, что якобы не соответствует оптимальному для модемного соединения значению, которое всеми считается равным 576. В Windows 98 корпорация Microsoft уже исправила этот недостаток, и теперь по умолчанию при соединениях ниже 128 килобит в секунду мы имеем МТU=576, что вроде бы должно чаще оказываться наилучшим вариантом. Попробуем разобраться, так ли оно на самом деле.

Итак, есть несколько способов определить значение MTU, оптимальное для связи с вашим интернет-провайдером.

  1. Послать письмо с вопросом в службу технической поддержки провайдера. Тут в принципе все понятно — если работники провайдера сами в курсе своих собственных настроек, то они дадут вам квалифицированный ответ, который, впрочем, не помешает все-таки и проверить лично на практике.
  2. Подключиться к Интернету в терминальном режиме — иногда при осуществлении регистрации пользователя в одной из строк появляется рекомендуемое значение MTU. Для этого войдите в папку Удаленный доступ к сети, найдите там значок своего соединения и, щелкнув на нем правой кнопкой мыши, выберите команду Свойства (Properties).

    На вкладке Общие (General) открывшегося окна нажмите кнопку Настройка (Settings) возле строки с названием вашего модема. В диалоговом окне Свойства: тип модема (Properties: Modem Type) выберите вкладку Параметры (Options), где установите флажок Открыть окно терминала после набора номера (Show terminal window after connection). Теперь соединяйтесь с провайдером и при появлении окна терминала вводите вручную имя пользователя и пароль по соответствующим запросам. Если после этого вы увидите что-то типа "Entering PPP mode. Your IP address is xxx.xxx.xxx.xxx. MaxMTU is 1524", то вам повезло — вы получили MTU провайдера. Но и тут нелишним будет проверить это значение лично.

  3. И, наконец, ручное определение MTU.


Определение MTU вручную

Для точного определения MTU нужно указать значение по умолчанию — 1500.

Существует огромное количество утилит, которые позволяют это сделать (да и не только это). Наиболее распространенные - Internet Tweak 2001 (http://www.magellass.com/), NetBoost 99 (http://www.download.ru/), iSpeed (http://www.hms.com/), MTUSpeed (http://www.mjs.u-net.com/), BlazeNET (http://www.indeavour.com/html_about_blazenet.htm). Если же у вас нет. возможности запустить одну из вышеперечисленных программ, сделайте это вручную — с помощью реестра Windows.

В разделе

HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Class \NetTrans\OOOx.

Если там есть параметр MaxMTU — удалите его. Далее, в Панели управления запустите утилиту Сеть, на вкладке Конфигурация выберите элемент списка Контроллер удаленного доступа и нажмите кнопку Свойства. Откроется диалоговое окно Свойства: Контроллер удаленного доступа. На вкладке Дополнительно в группе параметров Свойство выберите элемент списка Размер пакета IP, а в группе параметров Значение — большой (рис. 8.1).

Рис. 8.1. Диалоговое окно Свойства: Контроллер удаленного доступа

Тем самым MTU становится равным 1500. Для того чтобы изменения вступили в силу, перезагрузите компьютер.

Чтобы проверить, будут ли фрагментироваться пакеты, нужно установить соединение с Интернетом. Для этого можно использовать программу Ping, входящую в состав любой операционной системы семейства Windows.

В ней. нужно задать такие параметры:

ping -f -1 1500 ххх.ххх.ххх.ххх

где ххх. ххх. ххх. ххх — IP-адрес тестируемого сервера.

Для тестирования MTU гораздо удобнее использовать современные программы с графическим интерфейсом. Существует огромное количество таких программ. Например, IP Tools. Для начала нужно определить IP-адрес тестируемого сервера, чтобы избежать потери времени, отводимого на запрос DNS.

Для этого воспользуйтесь командой Traceroute. Нажмите кнопку Пуск в левом нижнем углу экрана, выберите команду Выполнить и в появившемся окне наберите <tracert> и URL веб-сайта. Появится окно приложения MS DOS. Например, введя любой адрес, через некоторое время появится его IP в квадратных скобках. Теперь воспользуйтесь программой Ping. Запустите ее с такими параметрами

ping -f -I 1500 ххх.ххх.ххх.ххх

где ххх.ххх.ххх.ххх — IP-адрес тестируемого сервера. Наиболее благоприятное время для проверки MTU для коммутируемого соединения — ночь. Тогда нагрузка на линии связи наименьшая.

В случае если никакого ответа не получено — пакет потерян. Причем потому, что фрагментировать мы его запретили, а размер слишком велик для оборудования провайдера. Начинайте постепенно уменьшать размер пакета. Например, вместо значения MTU 1500 установите 1480 и т. д., до тех пор, пока ответ не будет получен.

Возможно, ваш интернет-провайдер использует меньшее значение. Например, 1524, 1152, 1024, 1006, 576, 568, 560, 552, 548, 536, 528, 520, 512.

Этот эксперимент подтвердил нашу догадку — интернет-провайдер может использовать любой размер пакета, вплоть до 1500. Если вам еще не надоело экспериментировать — попробуйте загрузить файл размером в 500 Кбайт с одного и того же сервера при различных значениях MTU.

Скорее всего, вы поймете, что скорость больше при использовании больших

пакетов. Повторюсь, что это только, если ваш провайдер может принимать их, не фрагментируя. Также, если "пинговать" многие ваши любимые сайты нефрагментируемым пакетом, вы увидите, что почти все нормально принимают пакеты размером 1500.

И что? Вы можете спросить: "Где же тот самый рекомендуемый MTU, равный 576?" А его, как оказывается на деле, почти нигде и нет. Поэтому лучшим советом может стать — не следовать чужим рекомендациям, проводить собственные исследования, которые могут дать реальные результаты.

Действительно, на качество и скорость работы в Сети сильное влияние оказывает фрагментация пакетов, которая происходит, если большой пакет проходит через сеть, имеющую MTU меньше, чем длина вашего пакета.

Можно, конечно, перестраховаться и выбрать самый минимальный размер MTU, при котором пакеты наверняка не будут фрагментироваться, но это может сказаться на быстродействии вашей системы еще более пагубно, чем использование больших пакетов. На самом же деле, главное — чтобы ваш MTU не превосходил MTU провайдера, при включенной же функции

PMTU система сама найдет для ваших пакетов такой путь в Сети, при котором они не будут фрагментироваться.

Кстати, если вы обнаружите, что у провайдера установлено MTU=512 и менее, то есть смысл подумать о его смене — слишком много шлака будет передаваться вместе с вашими данными.


Другие параметры

Естественно, что не только от одного MTU зависит скорость. Существует еще много составляющих протокола TCP/IP, которые влияют на нее. Опять же слепо следовать рекомендациям западных специалистов не стоит. Это может привести к неожидаемым результатам.

Поэтому и здесь собственный эксперимент не помешает. Это поможет определить, что действительно сможет ускорить работу, а что затормозить на зашей системе. Многие из этих параметров легко выставляются с помощью зсе тех же незамысловатых утилит, что и MTU.

  • RWIN (receive window, окно приема) — размер буфера, в котором накапливается содержимое области данных (MSS) нескольких полученных пакетов, прежде чем передается дальше, например, в браузер. При недостаточном размере этого буфера иногда происходит его переполнение, и поступающие пакеты отвергаются и теряются. Размер RWIN обязательно должен быть кратен MSS и обычно для лучшей эффективности модемного соединения кратность рекомендуется устанавливать равной 4—8. Однако чрезмерно большой размер буфера также нежелателен, особенно на плохих линиях: при потере всего одного пакета в случае сбоя на линии будет повторно затребован не один потерянный пакет, а все пакеты из этого буфера, что займет некоторое время. В реестре тот параметр находится здесь:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP

  • "DefaultRcvWindow"="Bauie значение" TTL (time to live, время жизни) — количество хопов, т. е. промежуточных серверов, через которые может пройти ваш пакет в поисках своего места назначения. Каждый такой сервер добавляет единицу к специальному счетчику в заголовке вашего пакета, и, когда счетчик достигает максимально разрешенного значения, пакет считается заблудившимся и прекращает свое существование. По умолчанию TTL равен 32, что сегодня явно недостаточно для разросшегося Интернета: нередки случаи, когда удаленный сервер находится более чем в 32 переходах, поэтому TTL следует увеличить как минимум до 64:

HKEY_LOCAL_MACHINE\System\CurrentControlSet

\aervices\VxD\MSTCP "DefaultTTL"="64"

  • IPMTU (Internet Protocol MTU) — в Windows 98, по сути, это то же самое, что и MTU, но применительно только к контроллеру удаленного доступа. В реестре он упоминается несколько раз:

HKEY_LOCAL_MACHINE\System\CurrentControlSet

\Services\Class\Net\OOOx"I? MTU"="1500"

HKEY_LOCAL_MACHINE\System\CurrentControlSet

\Services\Class\Net\OOOx\Nc i\params\IPMTU

  • PMTU (Path MTU, путевое значение MTU) ("default"=" 1500" @="1500") -этот параметр разрешает Windows самой определять оптимальное значение MTU при организации соединения с каждым сервером. При этом серверу посылается ряд нефрагментируемых пакетов разного, постепенно уменьшающегося размера, и как только очередной пакет достигнет сервера, его размер считается оптимальным. На эту процедуру, разумеется, требуется некоторое время, и по умолчанию она включена, в связи с чем часто советуют ее деактивизироватъ, что, пожалуй, все-таки довольно спорно — потерять на этом времени можно больше из-за того, что наилучший размер блока данных определен не будет и пакеты пойдут фрагментированными. Выключается же этот режим так:

HKEY_LOCAL_MACHINE\System\CurrentControlSet

\Services\VxD\MSTCP "PMTUDiscovery"="0"

  • PMTUBlackHole Detect (обнаружение "черных дыр") — установка этого параметра разрешает протоколу TCP пытаться обнаружить никуда не ведущие роутеры и те, что не возвращают ICMP-сообщений о необходимости фрагментации при определении наилучшего MTU. Это так же, как и любая дополнительная процедура, может замедлять работу в Интернете — попробуйте поэкспериментировать с ее отключением:

HKEY_LOCAL_MACHINE\System\CurrentControlSet

\Services\VxD\MSTCP "PMTUBlackHoleDetect"="0"

  • SessionKeepAlive (поддержание соединения) — определяет, как часто будут посылаться специальные пакеты информации, предотвращающие отключение вас сервером в случае отсутствия активности в Сети с вашей стороны. Минимум — одна минута, по умолчанию — один час в Windows МЕ/9х и два часа в Windows 2000. Рекомендуемый интервал — 10 минут, параметр задается в секундах:

HKEY_LOCAL_MACHINE\System\CurrentControlSet

\Services\VxD\MSTCP "SessionKeepAlive"="600"

  • SlowNet — отключение этой функции может сократить задержки в передаче данных, но на сей раз визуально это будет не сильно заметно.

HKEY_LOCAL_MACHINE\System\CurrentControlSet

\Services\Class\Net\OOOx "SLOWNET"=hex:00

  • NDI Cache (Network Device Interface Cache) — кэш, в котором хранятся данные о маршрутах движения пакетов, по умолчанию его размер равен нулю. Чтобы его задействовать наиболее оптимально, необходимо установить его размер равным 16 при модемном соединении или 32 при более высоких скоростях подключения:

HKEY_LOCAL__MACHINE\System\CurrentControlSet

\Services\VxD\NWLink\Ndi\ paramsXcachesize @="16"

В реестре обычно рекомендуется выставить еще некоторые параметры, влияние которых на качество связи проследить вообще чрезвычайно сложно, но попробовать поэкспериментировать с их значениями можно:

  • HKEY_LOCAL_MACHINE\System\Current

    ControlSet\Services\VxD\NWLink\Ndi \

    params\maxconnect @="64" "max"="128" "min"="2"

  • HKEY_LOCAL_MACHINE\System\Current

    ControlSet\Services\VxD\NWLink\Ndi \params

    \maxsockets @="255" "тах"="1020" "min"="32"

  • HKEY_LOCAL_MACHINE\System\Current

    ControlSet\Services\VxD\NETBEUI\Ndi

    \params\ncbs "default"="32" "max"="255" "min"="8"

  • HKEY_LOCAL__MACHINE\System\Current

    ControlSet\Services\VxD\NETBEUI\Ndi

    \paramsXsessions "default"="32" "max"="117" "min"="4"

Нижеследующие параметры устраняют, по заверениям Microsoft, некоторые ошибки Windows и увеличивают скорость работы вашего браузера:

HKEY_LOCAL_MACHINE\System\Current

ControlSet\Services\VxD\MSTCP "BSDUrgent"="l"

"Tcpl3230pts"=dword:00000003 "SackOpts"="l"

Вот так вы увеличите количество одновременных подключений к серверу, что часто бывает весьма полезно:

[HKEY_USERS\.DEFAULT\Software\Microsoft

\Windows\CurrentVersion\Internet Settings]

"MaxConnectionsPerl_

OServer"=dword:OOOOOOOa=10 "

MaxConnectionsPerServer"=dword:00000008 =8

Оптимизировать интернет-соединения не так легко, как кажется. Несмотря на огромное количество программ, позволяющих увеличить скорость якобы в два раза. И тут, как мы выяснили, совсем не факт, что MTU-576, которое везде рекомендуется западными программистами и экспертами, будет оптимальным и для нас в России. Наши провайдеры сплошь и рядом выбирают для себя MTU=1500, а при "пинговании" удаленных серверов мы обнаруживаем, что пакет такого размера, вопреки всем утверждениям, проходит чаще всего нефрагментированным. При этом, как видно из наших вычислений, чем больше MTU, тем эффективнее используется ваш интернет-доступ.

Возможно, наши рассуждения несколько спорны и противоречат общепринятым догмам на этот счет, поэтому, для того чтобы настроить вашу систему на максимальную производительность, вам придется лично:

  • выяснить действительное значение MTU своего провайдера;
  • выбрав это значение, убедиться, что пакеты такого размера при связи с чаще всего вами посещаемыми серверами не будут фрагментироваться;
  • провести эксперименты с загрузкой одного и того же файла при разных значениях MTU;
  • проверить, как сказывается изменение MTU на сетевых играх, если вас они, конечно, интересуют.

Исходя из итогов этих опытов и стоит решать, какой размер максимального неделимого пакета вам следует в результате выбрать.

То, что везде рекомендуется, для вас может оказаться наихудшим вариантом. Аналогично наберитесь терпения и проверьте влияние и других параметров на быстродействие системы. При этом можно даже проверять MTU провайдера регулярно — раз в месяц, в два — не изменилось ли оно.


Ускорение загрузки веб-страниц за счет отключения графики

Скорость работы с Интернетом по телефонным линиям оставляет желать лучшего. Выше было рассказано о том, как можно оптимизировать скорость за счет настройки скрытых параметров соединения. Возможно, было достигнуто некоторое увеличение скорости. Но и это не предел. Если вы готовы пожертвовать красотой ради скорости, то этот метод для вас. В противном случае, сделать еще что-либо не представляется возможным.

Самый простой и самый действенный способ ускорения работы с веб-сайтами — отключение загрузки всевозможных изображений, видео- и аудио-содержимого, а также выполнения Java и прочих апплетов.

Чтобы это сделать, нужно запустить окно настройки параметров Microsoft Internet Explorer 6.0. Можно воспользоваться описываемым ранее методом (из меню Сервис (Tools) выбрать команду Свойства обозревателя (Internet Options), а можно по-другому. Существует еще два альтернативных способа настройки.

Мало кто знает, что значок Microsoft Internet Explorer, расположенный на рабочем столе, — это не просто значок, а ссылка на программу. Его можно назвать элементом рабочего стола, как, впрочем, и сетевое окружение, о котором будет рассказано позже.

Если щелкнуть правой кнопкой мыши на значке с изображением буквы "е" и вызвать контекстное меню, там есть команда Свойства (Properties), кото-

рая вызывает окно настройки Microsoft Internet Explorer. Кстати запустить его можно даже без открытия окна обозревателя.

Также окно настройки можно активизировать из Панели управления. Для этого дважды щелкните на значке Мой компьютер и в появившемся окне выберите Панель управления. В ней есть значок Свойства обозревателя, который вызывает окно настройки Internet Explorer.

Итак, запустив окно настройки обозревателя, выберите вкладку Дополнительно (рис. 8.2).

Рис. 8.2. Окно Свойства обозревателя

Нас интересует группа параметров Мультимедиа. Здесь можно установить или снять флажок возле каждого параметра.

  • Не отображать оперативное медиа-содержимое на панели медиа — не показывать медиа-файлы в панели Медиа. В итоге получится, что панель будет не интерактивной.
  • Включить автоматическую подгонку размеров изображения — автоматическое изменение размера изображений. Если флажок установлен, все большие картинки, не помещающиеся в окне обозревателя, будут автоматически уменьшены. Для того чтобы восстановить размер картинки, будет нужно нажать на специальную кнопку, которая появляется при подведении курсора к правому нижнему углу изображения. Если флажок снят — картинки будут отображены в реальном формате.
  • Включить панель изображений — специальная панель, появляющаяся в левом верхнем углу картинки при подведении курсора. На панели располагаются четыре кнопки — распечатать, послать по e-mail, сохранить картинку, перейти в папку MY IMAGES. При снятом флажке панель не будет появляться.
  • Воспроизводить анимацию — проигрывать анимационные ролики. Иногда страницы, содержащие такого рода контент, очень долго загружаются. Тем самым теряется время и деньги. Чтобы этого не произошло, вы можете снять флажок у этого параметра. Следовательно, такие ролики уже не будут загружаться автоматически. Но если вы вдруг захотите посмотреть его, достаточно будет в контекстном меню выбрать Show picture и он загрузится, правда через некоторое время.
  • Воспроизводить звуки — проигрывать музыку, звуки. Если деактивизиро-вать данную функцию, любая музыка, любые звуковые фрагменты не будут проигрываться. Этим можно ускорить загрузку веб-страниц, а также снять нагрузку с процессора (особенно на старых ПК).

Замечание

Если у вас установлен Real Player, звук все равно будет проигрываться.

  • Воспроизводить видео — проигрывать видео. Дело в том, что размер ви-деофайлрв значительно больше, чем любого изображения или HTML-страницы. Соответственно времени на загрузку требуется больше. Поэтому иногда целесообразно бывает отключить загрузку видео. Но, если вы вдруг передумали, вы всегда можете посмотреть видео: выберите в контекстном меню Show picture.
  • Отображать рисунки — показывать изображения. Если флажок снят — изображения не будут загружаться. Зато существенное увеличение скорости будет достигнуто.
  • Улучшенная передача цветовых оттенков — улучшение качества изображений. При установленном флажке изображения более "гладкие", но менее четкие.


Увеличение места под временные файлы

Этот способ может подойти для тех, кто постоянно посещает много сайтов, в которых практически не меняется оформление, а только текст. Поэтому из кэша будут достаточно быстро загружаться картинки, анимации, а сам текст — из Интернета. Этим можно существенно ускорить скорость загрузки. Стоит отметить, что места под временные файлы итак выделяется немало. Но, если для вас этого недостаточно, вы можете его увеличить. Для этого вызовите окно настройки Microsoft Internet Explorer (рис. 8.3).

Рис. 8.3. Увеличение места под временные файлы

Выберите вкладку Параметры диалогового окна Свойства обозревателя.

В появившемся окне с помощью ползунка вы можете установить размер дискового пространства, выделяемого под временные файлы. По умолчанию это 96 мегабайт, чего вполне хватает для размеренного веб-серфинга.

Здесь же можно установить частоту проверки на наличие обновленных вебстраниц:

  • при каждом посещении страницы -- каждый раз при посещении вебстраницы. Это наиболее надежный, проверенный метод. Но, к сожалению, он несколько "тормозит" процесс загрузки веб-сайтов;
  • при каждом запуске обозревателя — очень сомнительная опция. Каждый раз при запуске обозревателя будет проверяться каждая страница, имеющаяся в кэше, на наличие обновления. Это может сильно замедлить скорость работы с веб-сайтами. Не рекомендуется ее устанавливать;
  • автоматически — автоматически. Internet Explorer будет сам решать, когда страницу проверять, когда нет. Эта опция установлена по умолчанию. Рекомендуется так ее и оставить;
  • никогда — никогда. Странички будут постоянно загружаться из кэша, даже если их содержимое в Интернете обновилось.

В этом же окне вы можете изменить местоположение папки с временными файлами. Например, перенести на другой диск.

Итак, все вышеперечисленные рекомендации могут помочь вам ускорить скорость работы с Интернетом. Но не стоит слепо следовать тому, что написано. Попробуйте протестировать все лично. Тем самым вы обезопасите себя от неверных действий, и не будете обвинять автора в том, что даны были неправильные советы.


  • Глава 9. Конфигурирование службы FTP
    • Протокол FTP
    • Доступ к FTP-серверу через CERN прокси-сервер
    • Доступ к FTP-серверу напрямую
    • Работа с FTP-серверами
    • Подключение, загрузка файлов с сервера
    • Работа с файлами и каталогами


ГЛАВА 9.

Конфигурирование службы FTP

Протокол FTP

FTP (File Transfer Protocol)- протокол передачи файлов. Он появился практически тогда, когда зародилась сеть Интернет. Протокол предназначался для передачи файлов с компьютера на компьютер. Главным его достоинством была возможность приема/передачи файла с любого компьютера, под управлением любой операционной системы. Также не играет никакой роли, где используется FTP — в локальной сети или в Интернете.

Одной из особенностей протокола передачи файлов является то, что он использует не одно, а целых два TCP-соединения для передачи одного файла. Первое — для передачи файла, второе — управляет процессом.

Интернет-адрес (URL) FTP-сервера практически не отличается от адреса веб-сайта. К примеру, корпорация Microsoft имеет анонимный FTP-сервер, расположенный по адресу ftp://ftp.Microsoft.com . Оттуда любой желающий может загрузить всевозможные патчи (файлы обновления), новые драйверы, а также техническую документацию.

Уровень доступа к файлам и каталогам на FTP-сервере зависит от типа соединения: через CERN прокси-сервер или напрямую, а также от разрешения владельца.


Доступ к FTP-серверу через CERN прокси-сервер

При доступе к FTP-серверу при использовании CERN прокси-сервера вы можете только просматривать содержимое каталогов, а также загружать файлы. Вы не имеете возможности переименовать, загружать файлы на сервер, удалять папки и/или файлы.

Для того чтобы зайти на сервер, наберите в адресной строке его URL. Например, ftp://ftp.microsoft.com .

В том случае, если требуется авторизация, его адрес будет выглядеть следующим образом: ftp://имя пользователя:пароль@ftр.microsоft.соm.


Доступ к FTP-серверу напрямую

При доступе к FTP-серверу напрямую вы можете работать с файлами и папками практически точно так же, как на собственном компьютере. Вы можете: просматривать, загружать с/на сайт, переименовывать и удалять. Если для этого может потребоваться разрешение, вам будет предложено ввести имя входа (login) и пароль.

Для доступа к серверу введите его URL в адресной строке. Например, ftp://ftp.Microsoft.com . Для того чтобы загрузить файл с сайта, выберите в контекстном меню обозревателя команду Копировать в папку (Copy to Folder). Чтобы войти под другой учетной записью, выберите команду Файл | Войти как (File | Login As) и введите имя входа (login) и пароль.

Скорее всего вам придется столкнуться с этим протоколом в двух случаях:

  • загрузка файлов;
  • создание собственного сайта.

С первой ситуацией, вы, скорее всего уже сталкивались, хотя ничего не знали о существовании FTP. Дело в том, что файлы чаще всего загружают, щелкая по ссылке на веб-странице. И где-то в пятидесяти процентах случаев загрузка происходит с FTP-сервера, т. е. по протоколу FTP. В этом случае, браузер вам предложит сохранить файл в выбранный вами каталог. Иногда, в процессе странствия по сети, вам может попасться ссылка на РТР-каталог, в котором будут представлены файлы, документы точно так же, как и на вашем компьютере.

Во второй ситуации — создание веб-сайта — вам будет нужно загрузить ваши файлы на сервер провайдера. С выходом 6-й версии Microsoft Internet Explorer вам уже не придется пользоваться программами сторонних разработчиков, т. к.теперь вы можете работать с каталогами, файлами на FTP-серверах точно так же, как на вашем компьютере. Об этом позднее.

Замечания

  • На некоторых FTP-сайтах вы можете лишь просматривать и загружать файлы. Только те, кому принадлежит сервер, могут удалять, переименовать каталоги и файлы.
  • На многие FTP-серверы вы автоматически заходите, как анонимный пользователь. При этом вы можете только просматривать и загружать файлы. Чтобы загрузить файл, каталог, переименовать или удалить, вам может потребоваться имя входа (login) и пароль. Также стоит учитывать, что различные папки могут иметь разные права доступа. То есть под одним и тем же именем входа (login) и паролем вас могут пустить в один каталог, но не пустить в другой.

Вы не можете перемещать файлы с одного FTP-сайта на другой. Чтобы переместить их на другой сервер, потребуется сначала скачать файлы на локальный компьютер или сетевой диск, а оттуда загрузить их на требуемый FTP.

Некоторые программы поддерживают открытие и сохранение файлов на FTP-серверах напрямую, т. е. введя адрес FTP-сайта в диалоговых окнах Открыть файл и Сохранить.


Работа с РТР-серверами

FTP-сервер представляет из себя некий файловый архив, где файлы распределены по особым признакам в специальные каталоги, аналогично тому, как это делается на вашем компьютере.

Существует несколько типов FTP-серверов. Наиболее распространенные и известные — те, которые позволяют загружать файлы, не требуя авторизации. Чаще всего на них представлены архивы программного обеспечения, которое распространяется как бесплатное или условно-бесплатное. Стоит отметить, что приложения, которые продаются, никогда не появляются на общедоступных FTP-серверах. Самый большой российский FТР — ftp.chg.ru.

Некоторые серверы требуют авторизации, т. к. рассчитаны только на определенную группу пользователей. Например, сотрудников той или иной компании. То есть для того, чтобы получить доступ к ним, нужно иметь имя входа (login) и пароль.

Последний вид — серверы, которые не позволяют вам загрузить информацию с них, пока вы сами им чего-нибудь не загрузите. Чаще всего такие РТР принадлежат частным лицам, которые не хотят просто так отдавать имеющееся. На такого типа серверах находятся всевозможные МРЗ, нелегальное программное обеспечение и т. д. Также существует такое понятие "ратио" - отношение количества загруженных на сервер к количеству загруженных с сервера килобайт. Чаще всего "ратио" бывает где-то один к трем. То есть, для того чтобы загрузить с сервера 3 мегабайта информации, вам будет нужно загрузить на сервер 1 мегабайт.

Предыдущие версии Microsoft Internet Explorer не позволяли в полной мере использовать возможности протокола РТР. Даже появилось понятие WebFTP — способ отображения файлов и папок в браузере.

Шестая версия обозревателя от Microsoft позволяет работать с РТР-серверами, как с папками на локальном компьютере. Теперь можно копировать и удалять, используя все тот же привычный интерфейс Проводника Windows.


Подключение, загрузка файлов с сервера

Как говорилось выше, многие FTP-серверы позволяют загружать файлы, не имея имя входа (login) и пароля. Сейчас о них пойдет речь.

Итак, в адресной строке обозревателя вводим заветный URL. Мы выбрали Chg.ru. Через некоторое время загружается содержимое сервера.

Рис. 9.1. Окно Microsoft Internet Explorer в режиме работы с FТР-сервером

Первые заметные изменения — панель инструментов браузера преобразилась. Она стала очень сильно напоминать панель Проводника. Теперь на ней расположены следующие кнопки.

  • Назад (Back) -- вернуться на предыдущую страницу. Интересная деталь — если вы пришли на FTP-сервер с обычной HTML-страницы, то при возвращении на нее панель опять станет привычной.
  • Вперед (Forward) — перейти на следующую страницу.
  • Вверх (Up) — подняться на уровень вверх. Предположим, вы находитесь в каталоге X, который в свою очередь находится в каталоге Y. Чтобы перейти в каталог Y, нужно нажать кнопку Вверх (Up).

Замечание

Сначала складывается впечатление, что кнопки Назад (Back) и Вверх (Up) — практически одно и то же. На самом деле это не так. Приведем пример. Предположим, вы находитесь в папке ftp://ftp.microsoft.ru/bin . Причем, пришли по прямой ссылке, т. е.ftp://ftp.microsoft.ru/bin .Нажав кнопку Вверх (Up), вы попадете в корневой каталог— ftp://ftp.microsoft.ru/bin . , а если кнопку Назад (Back), то тогда будет загружена предыдущая страница. Как видите, разница огромная. Поэтому не стоит путать две, казалось бы, очень похожие кнопки.

  • Вырезать (Cut) — вырезать файл или каталог, а затем переместить его в другую папку командой Вставить.
  • Копировать (Сору) — копировать файл или каталог.
  • Вставить (Paste) — вставить скопированный файл или каталог.
  • Отменить (Undo) — отменить копирование, вырезание или удаление.
  • Удалить (Delete) — уничтожить файл или каталог.
  • Свойства (Properties).
  • Вид (View) — изменить параметры отображения каталога:
    • Крупные значки — такой режим просмотра установлен по умолчанию (см. рис. 9.1).
    • Мелкие значки — аналогично предыдущему режиму. Единственное отличие — размер значков в 2 раза меньше.
    • Список — тот же размер значков, что и в предыдущем режиме.
    • Таблица — маленькие значки, а также даются дополнительные сведения. Например, размер файла, дата его создания, изменения.

Итак, окно обозревателя поделено на две части. Слева дается информация о FTP-сервере: его адрес, приветственное сообщение, а также имя входа (login), под которым был осуществлен вход. Справа — собственно сами папки и файлы


Работа с файлами и каталогами

Итак, чтобы войти в какой-нибудь каталог, нужно дважды щелкнуть на значке. Работа с файлами аналогична. Вообще многие действия выполняют ся так же, как и в Проводнике Windows.

Некоторые операции с файлами и каталогами можно осуществить с помощью контекстного меню.

  • Открыть (Open) — открыть файл или папку.
  • Проводник (Explore) — открыть Проводник Windows и уже с его помощью производить операции над файлами и папками (рис. 9.2).

Тем самым можно упростить выполнение операций копировать, удалить; проводить действия над файлами, папками на сервере быстрее и удобнее. Слева теперь находятся ссылки на папки на FTP-сервере, а также можно посмотреть содержимое папки Мой компьютер.

Рис. 9.2. Окно Проводника Windows: работа с-FТР-сервером

Копировать в папку (Copy to Folder) — скопировать файл в папку. При выборе этой команды появится специальное окно, в котором можно с легкостью выбрать папку для копирования. Вырезать (Cut). Копировать (Сору).

  • Удалить (Delete) — удалить файл или папку. Правда для этого нужно иметь необходимые права доступа. При анонимном соединении в 99% случаев сделать это нельзя.
  • Переименовать (Rename) — переименовать файл или папку. Также, если нет прав доступа, сделать это не представляется возможным.
  • Свойства (Properties) — свойства. Вызывается окно (рис. 9.3), в котором можно посмотреть на свойства файла, каталога, а также права доступа, изменить их.

Вверху дается имя файла, которое вы можете изменить. Далее информация о размере, дате изменения архива. В поле Permissions вы можете посмотреть информацию о том, что разрешено делать с файлом и кому:

  • Владелец (Owner) — собственно владелец файла. И делать с ним он может что хочет: считывать, удалять, перезаписывать и т. д.
  • Группа (Group) — специальная группа пользователей, которая наделяется определенными полномочиями. Например, загружать файлы на сервер.
  • Все пользователи (All Users) — все пользователи, которые не входят в две предыдущие группы. Чаще всего они могут только загружать файлы с сервера на локальный компьютер.

Рис. 9.3. Окно Свойства: FTP

Загрузка файлов на сервер

Загрузка файлов на сервер может быть нужна в нескольких случаях. Первый — самый распространенный случай — когда вы создаете свой веб-сайт и хотите загрузить файлы на сервер.

При этом вы уже должны иметь имя входа (login) и пароль для доступа к FTP, знать его адрес и параметры работы с ним. Все это должен предоставить вам ваш хостинг-провайдер. Итак, зная все вышеперечисленное, вы набираете в адресной строке его адрес.

Через некоторое время появится окно авторизации (рис. 9.4), где вам будет предложено ввести имя входа (login) и пароль.

Если ваш сервер поддерживает анонимную работу, т. е. для пользователя, Не имеющего собственной учетной записи, установите флажок Анонимный вход (Login Anonymously). Таким образом, вход на сервер будет осуществлен.

Рис. 9.4. Окно Вход

Если пароль труден для запоминания, или просто не хочется каждый раз вводить его, установите флажок Сохранить пароль (Save Password). Он будет сохранен.

Далее нажмите кнопку Вход (Login). Если все указано верно, вы будете допущены на сервер.

Дело в том, что даже FTP-клиент, встроенный в Microsoft Internet Explorer 6.0 поддерживает механизм drag-and-drop (перетащить и бросить). Поэтому копировать файлы на сервер очень легко. Достаточно выбрать файл, группу файлов или каталог и перетащить их в окно обозревателя. Сразу же появится небольшое окно, в котором будет сообщаться о том, сколько уже загружено на сервер, какое время на это потребовалось.


  • Приложение 1. Рекомендуемые программы, упрощающие работу с Интернетом и Internet Explorer
    • Плейер
    • Менеджер загрузки
    • Чат
    • Что такое ICQ?
    • Безопасность


ПРИЛОЖЕНИЕ 1

Рекомендуемые программы, упрощающие работу с Интернетом и Internet Explorer

Многие пользователи ограничиваются двумя программами - Outlook Express и Internet Explorer, считая остальные просто ненужным хламом. Здесь я расскажу о программах, которые позволят повысить эффективность, скорость работы в Интернете.


Плейер

Для некоторых Windows Media Player — верх совершенства. На деле программа оказывается громоздкой и практически бесполезной, нет возможности проигрывать некоторые форматы, неудобное устройство. Вот почему все больше и больше пользователей переходят к так называемым альтернативным проигрывателям. Самый известный — Winamp. За счет использования плагинов вы можете прослушать или просмотреть музыкальную видеокомпозицию, записанную практически в любом формате. Но обо всем по порядку.

В первой части книга было достаточно коротко рассказано о работе с медиа-файлами в сети Интернет. Здесь я попытаюсь восполнить это упущение.

Итак, в Интернете вы можете найти все что угодно. Начиная от новостей и заканчивая последними киноновинками. Все больше и больше пользователей предпочитают смотреть видео, аудиоклипы и фильмы через сеть Интернет. Единственным серьезным ограничением является пропускная способность канала, ну и деньги, естественно. Если ни то, ни другое для вас не проблема, вы сможете ощутить все прелести Интернета. Но для начала вам придется установить медиа-плейер.

Одним из самых распространенных форматов передачи потоковой аудио- и видеоинформации является Real Audio/Real Video. Windows Media Player не поддерживает данный стандарт. Вот почему вам придется загрузить и установить на вашем компьютере Real Audio Player. К счастью, существует две его версии — бесплатная и платная. Одним из главных различий является невозможность записи потоковых данных в бесплатной версии. В остальном она практически не уступает. Итак, на странице Real.com выберите Download. Ответив на несколько вопросов, вам представится возможность загрузить эту программу.

После загрузки и установки перед вашими глазами предстанет дружелюбный интерфейс RealPlayer (рис. П1.1).

Рис. П1.1. Интерфейс Winamp

Слева расположена так называемая Content-панель. В действительности на ней представлены ссылки на веб-сайты. При нажатии, например, на Cnn.com, начнется буферизация данных, и через некоторое время, в главном окне (где сейчас написано real), вы сможете просмотреть интерактивную презентацию. На основной панели располагаются кнопки управления:

  • Play
  • Pause
  • Stop
  • Rewind
  • Forward

С помощью них вы можете управлять ходом показа. Например, приостановить — кнопка Pause.

Программа позволяет работать практически через любой прокси-сервер или брандмауэр. Имеет богатые настройки. К сожалению, тематика данной книги не позволяет полностью рассказать о возможностях программы. Стоит лишь указать форматы, с которыми RealPlayer будет ассоциироваться. Для этого из меню View выберите пункт Preferences. В появившемся окне нас интересует вкладка Upgrade. Нажмите на кнопку Re-associate. В новом окне вы сможете указать форматы, с которыми программа будет ассоциироваться (кроме RA, RM).


Менеджер загрузки

Интернет-пользователей можно разделить условно на три категории — серферы, качалыцики и нечто среднее. Для тех, кто часто загружает большие объемы информации из Интернета, будь то музыка или программы, одной из основных проблем остается качество соединения. В связи с тем, что в России большинство использует модем и аналоговую телефонную линию для соединения с Интернетом, качество оставляет желать лучшего.

У неопытных пользователей нередко возникает такая ситуация: загрузив 90% данных, связь рвется и приходится загружать заново. На это тратится не только время, но и деньги. Чтобы избежать этих потерь, были придуманы специальные программы — менеджеры загрузок. Главной, наиболее полезной их чертой является возможность докачки, т. е. при обрыве связи вы все равно сможете продолжить загрузку с того же места.

Сейчас самыми распространенными являются GolZilla и GetRight, на третьем месте Download Accelerator. Первые две программы хороши по-своему, но принципиально не отличаются. Download Accelerator" — это совсем другое дело. Эта маленькая программа (размер инсталляционного файла всего 1,5 Мбайт) сильно превосходит их. Сразу хочется отметить то, что этот менеджер загрузки бесплатен. Конечно, не абсолютно — поддерживается за счет баннеров, но трафик это сильно не снижает, а любители "халявы" всегда смогут найти "улучшалку". Теперь расскажу поподробнее о программе.

Download Accelerator — отличный менеджер загрузки, который поддерживает дозагрузку (что естественно, ведь какой смысл в менеджере загрузки, который не поддерживает дозагрузку), но кардинальным отличием от ВСЕХ его конкурентов (GolZilla, ReGet, GetRight, Flashget) является возможность дозагрузки с сайтов, не поддерживающих дозагрузку. По сути, вы имеете возможность дозагрузить любой файл с любого сайта. Технология, используемая при этом, поистине революционна и эксклюзивна, ведь ни одна подобная программа не использует ее. Разработчики держат технологию в секрете, и не зря, ведь последнее время Download Accelerator стал занимать первые места в рейтингах самого популярного компьютерного портала Download.com.

Теперь о том, что программа может помимо загрузки файлов. Есть возможность работы по расписанию, отключения от Интернета по окончании закачки, отключения компьютера. Кстати, функция отключения компьютера очень важна, ведь не редко многие из нас оставляют свой ПК на ночь — загружать файлы, музыку, картинки, вообще то, что нам интересно, и не редко все это добро скачивается достаточно быстро, ведь ночью связь лучше, т. е. грузится все быстрее. Даже у меня со средней скоростью соединения 26 400 (я использую обычный аналоговый модем), ночью скорость соединения доходит до 33 600 и выше, а качается и вообще со скоростью 4,2 Кбит в секунду. Но функция отключения компьютера больше всего подходит для обладателей современных компьютеров с питанием АТХ. Для тех, кто не знает, АТХ-питание позволяет отключать компьютер автоматически, т. е. выполнив "завершение работы", вам не придется руками нажимать на кнопку Power и отключать монитор. При покупке компьютера эта функция кажется довольно незначительной, но впоследствии она оказывается очень нужной.

Ладно, продолжим с Download Accelerator. Программа имеет достаточно симпатичный интерфейс, с которым разберется даже самый неподготовленный пользователь компьютера. Единственным минусом является отсутствие русификации (в официальной версии). Конечно, загрузить патч (от англ, patch — заплатка) можно, но он может содержать вирус или вообще не работать.

В программу включена функция поиска интересующей вас информации через Интернет. Вы можете найти файлы в формате МРЗ, а также всевозможные программы. Поиск осуществляется через известные поисковые системы и через собственный поисковик SpeedBit. Причем, если вы ищете МРЗ-файлы, то загрузка упрощается очень сильно. Ведь чаще всего МРЗ размещены на серверах бесплатного хостинга, где запрещено их размещение. И пользователи меняют расширения файлов на gif, jar и т. п, т. е. скачивать вам пришлось бы эти файлы, а потом переименовывать их в МРЗ, но Download Accelerator автоматически делает это за вас.

Еще одной приятной особенностью программы является возможность поиска зеркал для загрузки файлов. Хочется отметить, что поиск производится очень быстро и эффективно. Главной особенностью программы можно назвать загрузку файла по частям, т. е. вы загружаете одновременно сразу несколько частей файла, что по уверениям авторов существенно ускоряет время загрузки. Мне это ускорение было почти незаметно, при использовании dial-up соединения с Интернетом, но, попробовав эту программу в интернет-кафе, где скорость связи с Интернетом составляла около 128 Кбит/с я был приятно удивлен: вместо базового (для этой скорости соединения) времени загрузки файла — 8 Кбит/с я получил 30 Кбит/с. Да, это действительно огромный прирост скорости. Так что очень рекомендую Download Accelerator пользователям Интернета, использующим высокоскоростной доступ в сеть и желательно с неограниченным трафиком, а то платить придется слишком много.

Программа может работать через прокси или брандмауэр, что тоже очень важно, ведь многие используют эти системы для доступа в сеть. Download Accelerator можно интегрировать в Internet Explorer или Netscape Navigator, т. е. при попытке загрузить файл с определенным расширением (которое задается в настройках программы) автоматически открывается менеджер загрузки, и загружаете файл вы уже через него. Приятным отличием от ReGet является отдельное окошко загрузки для каждого файла, т. е. вам не придется всматриваться в таблицу с загружаемыми файлами, а все предстанет в достаточно удобном виде, где показана нынешняя скорость загрузки файла, время, оставшееся до завершения загрузки.

Никаких особых требований к системе не нужно: операционная система Windows 9x/ME/2000/XP, 16 Мбайт оперативной памяти и соединение с Интернетом.

Сайт производителя www.speedbit.com.


Чат

Неотъемлемой частью Интернета является чат. Многие проводят в них долгие часы. И все для того, чтобы завести виртуальных друзей. Иногда, правда, такие знакомства перерастают в реальные.

Чаты можно классифицировать — HTML-чаты, и программные. Доступ в HTML-чаты может получить любой обладатель современного браузера. Например, Internet Explorer 6.0. К сожалению, в таких вот комнатах все чаще и чаще стали собираться так называемые хулиганы, псевдо-хакеры. Выучив основы HTML, они, пытаясь показать свою "крутость", пишут запрещенными шрифтами большого размера или матерят всех. Вот почему такие чаты становятся все менее и менее популярны. На их смену пришли так называемые Instant Messenger или интернет-пейджеры. Работа с ними проста. А механизм такой — вы находите себе приятеля, добавляете его в контакт-лист и разговариваете.

Самой распространенной и, наверное, одной из самых первых программ подобного рода является ICQ.


Что такое ICQ?

В ноябре 1996 года произошло поистине революционное событие: была выпущена первая версия программы для прямого межпользовательского общения в сети Интернет, получившая легко запоминающееся название ICQ (читается "аи си кью").

"Так уж и революционное", — пожмут плечами скептики.

"Именно!" - воскликнут поклонники. Ведь в отличие от завоевавшей многомиллионную популярность IRC, новая программа:

  • позволяет одновременно находиться в режиме online любому количеству пользователей с одинаковыми именами;
  • позволяет в любой момент времени видеть, находятся ли ваши друзья в сети;
  • соединяет компьютеры пользователей напрямую, без использования промежуточных серверов. А это значит, что общение происходит в реальном времени, да так быстро, что не успеваешь нажать кнопку Send, как уже получаешь ответ;
  • предоставляет возможность вести поиск среди пользователей по любому из основных или по совокупности дополнительных признаков;
  • позволяет отправлять сообщение неактивному пользователю и быть уверенным, что тот его получит, как только подключит ICQ;
  • не вынуждает постоянно "сидеть" на канале — вы ведь можете переговариваться с друзьями время от времени или в паузах, фактически не отвлекаясь от основных дел;
  • предоставляет возможность общаться только с избранными пользователями (даже среди общего списка друзей) или даже сохранять полную конфиденциальность;
  • позволяет организовать мини-чат с одним или несколькими пользователями по выбору;
  • позволяет занести назойливых контактеров в "черный список" и таким образом навсегда забыть о них.

ICQ — можно прочесть как "I Seek You", то есть "Я ищу тебя".

Название отражает самое важное отличие от прочих програм общения в Интернете. Да-да! ICQ на самом деле позволяет "видеть" всех ваших друзей и знакомых, как только они появляются в сети Интернет в режиме online.

Отныне вам не придется плутать по чатам, чтобы найти друзей и пообщаться с ними, потому что появилась новая программа, ласково именуемая "аськой". ICQ чудесным образом заставляет забыть о расстояниях, она предоставляет вам возможность мгновенно связаться со своими знакомыми или деловыми партнерами в любое время.

ICQ позволяет обмениваться сообщениями, посылать файлы и URL, играть по сети в различные игры или просто болтать в мини-чате с приятелями. Удобная и несложная система настроек позволяет самостоятельно выбрать требуемый уровень конфиденциальности — от простейшего до самого "засекреченного", когда вы видите всех, а вас не видит никто. Также ICQ поддерживает ряд популярных внешних интернет-приложений (варианты интернет-телефонов, сетевые игры и пр.).

Программа выполняется в фоновом режиме, используя минимум памяти и ресурсов сети. Вы можете заниматься чем угодно, потому что ICQ предупредит, когда поступит новое сообщение.

Каждый пользователь ICQ имеет свой личный номер, который можно помещать на визитных карточках и иных деловых бумагах — ведь прямые контакты намного эффективнее, чем длительная переписка (даже и по электронной почте).

На сегодняшний день количество пользователей превышает 135 миллионов человек. К сожалению, не так давно компания Mirabilis была перекуплена AOL, которая в свою очередь "вставила" назойливые баннеры и вообще сделала программу не столь удобной, очень громоздкой, требующую больших системных ресурсов. В связи с этим, наиболее распространенной, уважаемой является версия ICQ99B.

Также существует приличное количество клонов программы. Наиболее пригодным для использования, я считаю Miranda ICQ. Программа имеет небольшой размер — около 500 Кбайт и возможность подключения дополнительных модулей — плагинов.

В отличие от своего прототипа, Miranda ICQ (рис. П1.2) является бесплатной в полном смысле этого слова — отсутствуют баннеры, рекламные объявления и т. д., а также имеет открытые исходные коды.

Сайт разработчика — Miranda-icq.sourceforge.net.


Безопасность

Интернет — небезопасное место. Всевозможные хакеры норовят украсть вашу информацию, стереть файлы на вашем компьютере и т. д. Вот почему стоит использовать персональные брандмауэры — программы, следящие за трафиком, позволяющие ограничить или запретить выполнение сетевых задач определенных приложений.

На мой взгляд, самым простым в использовании персональным брандмауэром можно назвать ZoneAlarm.

Первым делом хочется заметить абсолютную бесплатность программы (для личного использования). Теперь о самом приложении. При запуске программы в память загружается драйвер, который фильтрует все соединения вашего компьютера с Интернетом. Основное окно программы выглядит следующим образом (рис. П1.3).

Достаточно просто, но очень информативно. Первым делом требуется поставить уровень защиты. В предустановках их всего 6: три для локальной сети и три для Интернета. По умолчанию стоит высший уровень защищенности для Интернета и средний для локальной сети. 3-й уровень защиты просто прячет вас от всевозможных атак, т. е. вы становитесь практически невидимым для хакеров и остальных "охотников за информацией". Этот уровень блокирует использование сервисов Windows (доступ к файлам принтерам) и запрещает применение сомнительных портов.

ZoneAlarm ведет довольно подробную статистику соединений с указанием портов, IP-адресов, времени атаки и т. д. Вы также можете узнать дополнительную информацию о произведенной атаке, нажав кнопку More info. Причем метод получения информации достаточно интересен: на сервер ZoneLabs www.zonelabs.com посылается запрос, а после отображается вебстраница, на которой дается информация об атаке, ее виде, программе, которая ее произвела и еще некоторые другие параметры.

Интересной особенностью программы является возможность блокирования доступа в Интернет нажатием всего одной(!) кнопки. Причем все действительно работает: байтики перестают бежать и в ту и в другую сторону.

Очень удобно реализована опция разрешения/запрета доступа в Интернет той или иной программы.

Главной особенностью, преимуществом программы является криптографическая подпись для тех приложений, которым пользователь доверяет выход в сеть. Эта функция делает невозможным маскировку одной программы под другую (как часто делают Трояны). Например, Троян, попавший к вам на компьютер, пытается получить доступ в сеть, но на вашем ПК стоит брандмауэр. Тогда Троян пытается сделать себе "липовое" разрешение на доступ в сеть, т. е. программа может "замаскироваться" под Internet Explorer и без проблем пользоваться Интернетом. Но-при использовании ZoneAlarm такого просто не может произойти. Все потому, что программа подписывает все приложения, получающие доступ в сеть. Проще говоря, каждая программа получает свой идентификационный номер, который к тому же шифруется.


  • Приложение 2. Интернет-протоколы
    • Протокол межсетевого взаимодействия — IP
    • Формат пакета IP
    • Протокол доставки пользовательских дейтаграмм UDP
    • Формат сообщений UDP
    • Протокол надежной доставки сообщений TCP
    • Формат сообщений TCP
    • Протокол обмена управляющими сообщениями ICMP
    • Формат сообщений протокола ICMP
    • Протоколы обмена маршрутной информацией стека TCP/IP


ПРИЛОЖЕНИЕ 2

Интернет-протоколы

Протокол межсетевого взаимодействия— IP

Основу транспортных средств стека протоколов TCP/IP составляет протокол межсетевого взаимодействия — Internet Protocol (IP). К основным функциям протокола IP относятся:

  • перенос между сетями различных типов адресной информации в унифицированной форме;
  • сборка и разборка пакетов при передаче их между сетями с различным максимальным значением длины пакета.


Формат пакета IP

Пакет IP состоит из заголовка и поля данных. Заголовок пакета имеет следующие поля.

  • Поле "Номер версии" (VERS) указывает версию протокола IP. Сейчас повсеместно используется версия 4 и готовится переход на аерсию 6, называемую также IPng (IP next generation).
  • Поле "Длина заголовка" (HLEN) пакета IP занимает 4 бита и указывает значение длины заголовка, измеренное в 32-битовых словах. Обычно заголовок имеет длину в 20 байт (пять 32-битовых слов), но при увеличении объема служебной информации эта длина может быть увеличена за счет использования дополнительных байт в поле Резерв (IP OPTIONS).
  • Поле "Тип сервиса" (SERVICE TYPE) занимает 1 байт и задает приоритетность пакета и вид критерия выбора маршрута. Первые три бита этого поля образуют подполе приоритета пакета (PRECEDENCE). Приоритет может иметь значения от 0 (нормальный пакет) до 7 (пакет управляющей информации). Маршрутизаторы и компьютеры могут принимать во внимание приоритет пакета и обрабатывать более важные пакеты в первую очередь. Поле "Тип сервиса" содержит также три бита, определяющие критерий выбора маршрута. Установленный бит D (delay) говорит о том, что маршрут должен выбираться для минимизации задержки доставки данного пакета, бит Т — для максимизации пропускной способности, а бит R — для максимизации надежности доставки.
  • Поле "Общая длина" (TOTAL LENGTH) занимает 2 байта и указывает общую длину пакета с учетом заголовка и поля данных.
  • Поле "Идентификатор пакета" (IDENTIFICATION) занимает 2 байта и используется для распознавания пакетов, образовавшихся путем фрагментации исходного пакета. Все фрагменты должны иметь одинаковое значение этого поля.
  • Поле "Флаги" (FLAGS) занимает 3 бита, оно указывает на возможность фрагментации пакета (установленный бит Do not Fragment — DF — запрещает маршрутизатору фрагментировать данный пакет), а также на то, является ли данный пакет промежуточным или последним фрагментом исходного пакета (установленный бит More Fragments — MF — говорит о том, что пакет переносит промежуточный фрагмент).
  • Поле "Смещение фрагмента" (FRAGMENT OFFSET) занимает 13 бит, оно используется для указания в байтах смещения поля данных этого пакета от начала общего поля данных исходного пакета, подвергнутого фрагментации. Используется при сборке/разборке фрагментов пакетов при передачах их между сетями с различными величинами максимальной длины пакета.
  • Поле "Время жизни" (TIME TO LIVE) занимает 1 байт, и указывает предельный срок, в течение которого пакет может перемещаться по сети. Время жизни данного пакета измеряется в секундах и задается источником передачи средствами протокола IP. На шлюзах и в других узлах сети по истечении каждой секунды из текущего времени жизни вычитается единица; единица вычитается также при каждой транзитной передаче (даже если не прошла секунда). По истечении времени жизни пакет аннулируется.
  • Поле "Идентификатор Протокола верхнего уровня" (PROTOCOL) занимает 1 байт и указывает, какому протоколу верхнего уровня принадлежит пакет (например, это могут быть протоколы TCP, UDP или RIP).
  • Поле "Контрольная сумма" (HEADER CHECKSUM) занимает 2 байта, она рассчитывается по всему заголовку.
  • Поля "Адрес источника" (SOURCE IP ADDRESS) и Адрес назначения (DESTINATION IP ADDRESS) имеют одинаковую длину — 32 бита, и одинаковую структуру.
  • Поле "Резерв" (IP OPTIONS) является необязательным и используется обычно только при отладке сети. Это поле состоит из нескольких подполей, каждое из которых может быть одного из восьми предопределенных типов. В этих подполях можно указывать точный маршрут прохождения маршрутизаторов, регистрировать проходимые пакетом маршрутизаторы, помещать данные системы безопасности, а также временные отметки. Так как число подполей может быть произвольным, то в конце поля Резерв должно быть добавлено несколько байт для выравнивания заголовка пакета по 32-битной границе.

Максимальная длина поля данных пакета ограничена разрядностью поля, определяющего эту величину, и составляет 65 535 байтов, однако при передаче по сетям различного типа длина пакета выбирается с учетом максимальной длины пакета протокола нижнего уровня, несущего IP-пакеты. Если это кадры Ethernet, то выбираются пакеты с максимальной длиной в 1500 байтов, умещающиеся в поле данных кадра Ethernet.


Протокол доставки пользовательских дейтаграмм UDP

Задачей протокола транспортного уровня UDP (User Datagram Protocol) является передача данных между прикладными процессами без гарантий доставки, поэтому его пакеты могут быть потеряны, продублированы или прийти не в том порядке, в котором они были отправлены.


Формат сообщений UDP

Единица данных протокола UDP называется UDP-пакетом или пользовательской дейтаграммой (user datagram). UDP-пакет состоит из заголовка и поля данных, в котором размещается пакет прикладного уровня. Заголовок имеет простой формат и состоит из четырех двухбайтовых полей:

  • UDP source port — номер порта процесса-отправителя;
  • UDP destination port — номер порта процесса-получателя;
  • UDP message length — длина UDP-пакета в байтах;
  • UDP checksum — контрольная сумма UDP-пакета.

Не все поля UDP-пакета обязательно должны быть заполнены. Если посылаемая дейтаграмма не предполагает ответа, то на месте адреса отправителя могут помещаться нули. Можно отказаться и от подсчета контрольной суммы, однако следует учесть, что протокол IP подсчитывает контрольную сумму только для заголовка IP-пакета, игнорируя поле данных.


Протокол надежной доставки сообщений TCP

В стеке протоколов TCP/IP протокол TCP (Transmission Control Protocol) работает так же, как и протокол UDP, на транспортном уровне. Он обеспечивает надежную транспортировку данных между прикладными процессами путем установления логического соединения.


Формат сообщений TCP

Сообщения протокола TCP называются сегментами и состоят из заголовка и блока данных. Заголовок сегмента имеет следующие поля:

  • поле "Порт источника" (SOURS PORT) занимает 2 байта, идентифицирует процесс-отправитель;
  • поле "Порт назначения" (DESTINATION PORT) занимает 2 байта, идентифицирует процесс-получатель;
  • поле "Последовательный номер" (SEQUENCE NUMBER) занимает 4 байта, указывает номер байта, который определяет смещение сегмента относительно потока отправляемых данных;
  • поле "Подтвержденный номер" (ACKNOWLEDGEMENT NUMBER) занимает 4 байта, содержит максимальный номер байта в полученном сегменте, увеличенный на единицу; именно это значение используется в качестве квитанции;
  • поле "Длина заголовка" (HLEN) занимает 4 бита, указывает длину заголовка сегмента TCP, измеренную в 32-битовых словах. Длина заголовка не фиксирована и может изменяться в зависимости от значений, устанавливаемых в поле "Опции";
  • поле "Резерв" (RESERVED) занимает 6 бит, поле зарезервировано для последующего использования;
  • поле "Кодовые биты" (CODE BITS) занимают 6 бит, содержат служебную информацию о типе данного сегмента, задаваемую установкой в единицу соответствующих бит этого поля:
    • • URG — срочное сообщение;
    • • АСК — квитанция на принятый сегмент;
    • • PSH — запрос на отправку сообщения без ожидания заполнения буфера;
    • • RST — запрос на восстановление соединения;
    • • SYN — сообщение, используемое для синхронизации счетчиков переданных данных при установлении соединения;
    • • FIN— признак достижения передающей стороной последнего байта в потоке передаваемых данных.
  • поле "Окно" (WINDOW) занимает 2 байта, содержит объявляемое значение размера окна в байтах;
  • поле "Контрольная сумма" (CHECKSUM) занимает 2 байта, рассчитывается по сегменту;
  • поле "Указатель срочности" (URGENT POINTER) занимает 2 байта, используется совместно с кодовым битом URG, указывает на конец данных, которые необходимо срочно принять, несмотря на переполнение буфера;
  • поле "Опции" (OPTIONS) — это поле имеет переменную'длину и может вообще отсутствовать, максимальная величина поля 3 байта; используется для решения вспомогательных задач, например, при выборе максимального размера сегмента;
  • поле "Заполнитель" (PADDING) может иметь переменную длину, представляет собой фиктивное поле," используемое для доведения размера заголовка до целого числа 32-битовых слов.


Протокол обмена управляющими сообщениями ICMP

Протокол обмена управляющими сообщениями ICMP (Internet Control Message Protocol) позволяет маршрутизатору сообщить конечному узлу об ошибках, с которыми маршрутизатор столкнулся при передаче какого-либо IP-пакета от данного конечного узла.

Управляющие сообщения ICMP не могут направляться промежуточному маршрутизатору, который участвовал в передаче пакета, с которым возникли проблемы, так как для такой посылки нет адресной информации пакет несет в себе только адрес источника и адрес назначения, не фиксируя адреса промежуточных маршрутизаторов.

Протокол ICMP — это протокол сообщения об ошибках, а не протокол коррекции ошибок. Конечный узел может предпринять некоторые действия для того, чтобы ошибка больше не возникала, но эти действия протоколом ICMP не регламентируются.

Каждое сообщение протокола ICMP передается по сети внутри пакета IP. Пакеты IP с сообщениями ICMP маршрутизируются тдчно так же, как и любые другие пакеты, без приоритетов, поэтому они могут теряться. Кроме того, в загруженной сети они могут вызывать дополнительную загрузку маршрутизаторов. Для того чтобы не вызывать лавины сообщений об ошибках, потерях пакетов IP, переносящие сообщения ICMP об ошибках не могут порождать новые сообщения ICMP.


Формат сообщений протокола ICMP

Существует несколько типов сообщений ICMP. Каждый тип сообщения имеет свой формат, при этом все они начинаются с общих трех полей: 8-битного целого числа, обозначающего тип сообщения (TYPE), 8-битного поля кода (CODE), который конкретизирует назначение сообщения, и 16-битного поля контрольной суммы (CHECKSUM). Кроме того, сообщение ICMP всегда содержит заголовок и первые 64 бита данных пакета IP, который вызвал ошибку. Это делается для того, чтобы узел-отправитель смог более точно проанализировать причину ошибки, так как все протоколы прикладного уровня стека TCP/IP содержат наиболее важную информацию для анализа в первых 64 битах своих сообщений.

Поле типа может иметь следующие значения (табл. П2.1).

Таблица П2.1. Значения

Значение | Тип сообщения
0 1 | Эхо-ответ (Echo Replay)
3 | Узел назначения недостижим (Destination Unreachable)
4 | Подавление источника (Source Quench)
5 | Перенаправление маршрута (Redirect)
8 | Эхо-запрос (Echo Request)
11 | Истечение времени дейтаграммы (Time Exceeded for a Datagram)
12 | Проблема с параметром пакета (Parameter Problem on a Datagram)
13 | Запрос отметки времени (Timestamp Request)
14 | Ответ отметки времени (Timestamp Replay)
17 | Запрос маски (Address Mask Request)
18 | Ответ маски (Address Mask Replay)

Как видно из используемых типов сообщений, протокол ICMP представляет собой некоторое объединение протоколов, решающих свои узкие задачи.


Протоколы обмена маршрутной информацией стека TCP/IP

Все протоколы обмена маршрутной информацией стека TCP/IP относятся к классу адаптивных протоколов, которые в свою очередь делятся на две группы, каждая из которых связана с одним из следующих типов алгоритмов:

  • дистанционно-векторный алгоритм (Distance Vector Algorithms, DVA); ГП алгоритм состояния связей (Link State Algorithms, LSA).
  • дистанционно-векторных алгоритмах каждый маршрутизатор периодически и широковещательно рассылает по сети вектор расстояний от себя до всех известных ему сетей. Под расстоянием обычно понимается число промежуточных маршрутизаторов, через которые пакет должен пройти прежде, чем попадет в соответствующую сеть. Может использоваться и другая метрика, учитывающая не только число перевалочных пунктов, но и время прохождения пакетов по связи между соседними маршрутизаторами. Получив вектор от соседнего маршрутизатора, каждый маршрутизатор добавляет к нему информацию об известных ему других сетях, о которых он узнал непосредственно (если они подключены к его портам) или из аналогичных объявлений других маршрутизаторов, а затем снова рассылает новое значение вектора по сети. В конце концов, каждый маршрутизатор узнает информацию об имеющихся в интерсети сетях и о расстоянии до них через соседние маршрутизаторы.

Дистанционно-векторные алгоритмы хорошо работают только в небольших сетях. В больших сетях они засоряют линии связи интенсивным широковещательным трафиком, к тому же изменения конфигурации могут отрабатываться по этому алгоритму не всегда корректно, так как маршрутизаторы не имеют точного представления о топологии связей в сети, а располагают только обобщенной информацией — вектором дистанций, к тому же полученной через посредников. Работа маршрутизатора в соответствии с дистанционно-векторным протоколом напоминает работу моста, так как точной топологической картины сети такой маршрутизатор не имеет.

Наиболее распространенным протоколом, основанным на дистанционно-векторном алгоритме, является протокол RIP.

Алгоритмы состояния связей обеспечивают каждый маршрутизатор информацией, достаточной для построения точного графа связей сети. Все маршрутизаторы работают на основании одинаковых графов, что делает процесс маршрутизации более устойчивым к изменениям конфигурации. Широковещательная рассылка используется здесь только при изменениях состояния связей, что происходит в надежных сетях не так часто.

Для того чтобы понять, в каком состоянии находятся линии связи, подключенные к его портам, маршрутизатор периодически обменивается короткими пакетами со своими ближайшими соседями. Этот трафик также широковещательный, но он циркулирует только между соседями и поэтому не так засоряет сеть.

Протоколом, основанным на алгоритме состояния связей, в стеке TCP/IP является протокол OSPF.


  • Приложение 3. Плагины
    • Оболочки
    • Панели
    • Менеджеры закладок
    • Менеджер кэша
    • Оригинальные


Приложение 3

Плагины

К большому сожалению, разработчики программного обеспечения просто не могут предусмотреть все желания пользователей. И вот часто можно услышать недовольные фразы типа "ну надо же, этого не сделали". И вот тут выхода может быть три:

  1. Самый простой — просто попытаться не обращать внимания на недостаток.
  2. Написать плагин самостоятельно.
  3. Найти и загрузить плагин из Интернета.

В данном случае очень хорошо подходит поговорка: кто ищет, тот всегда найдет.

Разработчики обозревателя Microsoft Internet Explorer предусмотрели это. Таким образом, поддержка плагинов существует и широко используется.

Плагины для браузера можно условно разделить на несколько частей.


Оболочки

Не очень давно появилась возможность использования особых оболочек для браузера. Таким образом, его вид становится абсолютно другим.

  • Самой популярной надстройкой является Neoplanet (www.neoplanet.com). В сравнении с "чистым" Internet Explorer, Neoplanet является полноценным браузером. Имеется даже клиент e-mail. Очень удобно организованы панели закладок.
  • Еще одной популярной оболочкой можно назвать Netcaptor. Программа уже не нова. Текущая версия — шестая. Главным ее преимуществом перед Internet Explorer является многооконность. Таким образом, вы можете работать сразу с несколькими сайтами в одном окне. Одним из существенных недостатков является невозможность изменения размера окон. С каждым новым билдом появляются дополнительные функции.
  • На сегодняшний день одной из самых лучших добавок можно назвать CaptorGroups. Их очень удобно использовать, если вы часто посещаете одну группу сайтов. Вы помещаете ссылки на них в CaptorGroups и при нажатии на определенную кнопку они автоматически открываются.


Панели

В последнее время особой популярностью стали пользоваться специальные панели, встраиваемые в оболочку. Одной из лучших считается Yandex.Bar, распространяемый Яндексом. С его помощью вы можете с легкостью получить доступ к сервисам портала, а также осуществить поиск.

Еще-один представитель такого рода плагинов — DeltaBar. После установки он автоматически помещается под адресной строкой браузера. Его функция - поиск. Таким образом, при просмотре какой-либо веб-страницы, DeltaBar ищет аналогичные по тематике. Далее появляется сообщение о количестве найденных сайтов. Для того чтобы вызвать их список, достаточно нажать на специальную кнопку.


Менеджеры закладок

Хотя в Microsoft Internet Explorer встроена возможность редактирования Избранного, все же она не так хороша реализована, как хотелось бы пользователю. Вот почему существует достаточно приличное количество менеджеров избранного. Ярким представителем можно назвать Compass.


Менеджер кэша

Чего в Microsoft Internet Explorer нет, так это менеджера кэша. Ну не позаботились программисты об этом. И здесь фантазиям сторонних разработчиков есть где разыграться. На сегодняшний день существует как минимум 40 аналогичных программ. Стоит обратить внимание на About My Cache — прекрасная, функциональная программа, вполне оправдывающая свое название.


Оригинальные

Оригинальных и интересных плагинов, к сожалению, не так много. Но все же они есть.

LinkPilot позволяет создавать визуальные закладки в виде изображения. Все очень просто: LinkPilot создает свой собственный список Избранное не по принципу "описание+ссылка", как делает Internet Explorer, а помещает вместо описания уменьшенное в десятки раз графическое изображение сайта -значок. Такой способ каталогизации подходит для пользователей с хорошо развитой зрительной памятью — навигация по списку происходит очень быстро. Редактировать папки таких закладок также очень легко, а доступ к некоторым папкам можно закрыть паролем. Например, для того, чтобы предотвратить несанкционированный доступ к некоторым ресурсам. Одним из основных недостатков программы является ее автономность - она не встраивается в оболочку браузера, а болтается поверх всех окон. Некоторых это может раздражать.