Фонограммные технологии. Синтезаторы речи. Интерактивные формы обучения. Тренажер-демонстратор типовых возможностей. Модуль SP 1.0 (beta)

Тренажер-демонстратор синтеза речи

Кисонька

Остановка

Правотворчество

Система ДЭИР

Философмя м теология

Диджей

Господин Ау

Экзамен

Утренняя молитва

Вечерняя молитва

Статья по электротехнике

Ввеление к сборнику рассказов

Говорилка - это рабочая лошадка, способная делать много и быстро не претендуя на высшее качество озвучивания текстов. Есть и более мощные средства для создания еоворящих книг и других произведений. Правильно используйте эту программу и вы получите превосходный результат. Перед созданием больших фонограммы надо настроить и проверить программу на небольших контрольных примерах из 6 - 10 строк. Перед созданием больших фонограммы надо настроить и проверить программу на небольших контрольных примерах из нескольких строк. Фонограмма получается из текстов, которые несут определенную смысловую нагрузку и она есть главное в произведениях подобного рода. Это значит, что прежде следует продумать содержание текста во всех его деталях, составить развернутые тезисы или конспекты и лишь затем садиться за уомпьютер и напрягать этк программу. Понятно, что такой основательный подход требует значительных усилий и вряд ли оправдан при выполнени текущих рутинных работ. Использовать говорилку уместно тогда, когда необходимо озвучить готовые тексты и пользоваться фонограммой при изучении содержания в пути с помощью плеера или смартфона, через наушники и репродукторы, не напрягапая зрение и не нося с собой громоздкие планшетники. Фонограммы могут пригодится при изучениии иностранного языка или множества понятий по дсциплине или теме, Они могут быть составлены изх конспектов, состоящих их множества цитат, скопированных из объемистого учебника, с веб-страниц или из множества других источников, полученных через Интернет. Быстрая подготовка таких конспектов, их озвучивание и многократное прослушивание фоногррамм пиводит к прочному запоминанию материалов без особых усилий и заслуженной хорошей оценке. Фонограммы тезисов доклада, презентации или отчета о практике может быть представлена для оценки вместо устного выступления, присоединяться к исходному тексту для усиления эффекта и многократно прослушиваться перед выступлением, заменяя традиционные репетиции и предзащиту. Хорошая фонограмма может быть размещена в интернете как ценное авторское произведение и упоминаться в различгных документах с указанием адресов, включая регистрацию такого изделия в персональном портфолио достижений. . . Эта фонограмма подготовлена в рамках изучения возможностей данной программы и других синтезаторов речи. доцентом кафедры автоматизации и информационных систем сибирского медустриального гос университета Новокрещиным Борисом Георгиевичем который желает всем творческих и деловых успехов на тернистом пути образования. Автор просит не судить его скорбный труд слишком строго, поскольку для лучших результатов тркбуется больше времени, чем он в состоянии себе позволить. К тому же черновой вариант позволяет легче обнаружить недостатки и поискать средства их профилактики, не делая своих ошибок. Несколько слов о коллоквиуме Для подавляющего большинства студентов экзамен есть ничтоо иное как тестирование и проверка понимания прослушанных лекций, которые записываются почти дословно в еонспектах. Но как быть если курс наполнен творчеством и не с чем сравнивать оригинальные его результаты, каждый сделал что-то свое и этим интересен. Получается тупик и дать объективную оценку традиционными методами не получится. Нужны какие то другие формы контроля и оценки достижений. . Для этих целей используется экспертиза информационной продукции разного рода предоставленная автором экзаменатору или группе компетентных специалистов Это может быть доклад презентация отчет или иные материалы, максимально полно отражающие сущность и особенности проделанной работы. Давно увлекаюсь оцифровкой текстов книжек Говорилкой (Digalo). Дорога на работу, с работы и т.д. стала удовольствиемsmile.gif Главная проблема была с ударением в именах и названиях. Сложилась четкая технология, которая уверен многим пригодится: 1. проставляю ударения, для чего написал программку, которая просматривает текст и предлагает слова с заглавной буквы и длинные для проставки ударения (естественно один раз каждый корень). Например, в слове "Максимом" нужно стереть 2 последние буквы и поставить ударение, получив "Макси<м". Программа проставляет ударения, удаляет ссылки, нечитаемые знаки и латинские буквы, имеет импорт/экспорт словарей в формате Говорилки. Осторожнее с короткими словами - с них могут начинаться другие длинные... 2. оцифровываю Говорилкой в mp3 с потоком 64Мбит (если текстовый файл длинный - лучше разделить на куски не более 300Кб); 3. Усиливаю звук до 400% с помощью Sound Forqe (иначе - тихо!) 4. Режу на куски по 20 минут (около 9Мб) с помощью mp3DirectCut и все готово! Ну почему, почему вы не используете спец. программы для записи аудиокниг (когда читает сам компьютер)? Никаких всхлипов, чавков, щелчков. Хочешь - мужчина прочитает, да еще любым голосом, хочешь - женщина. Голос и интонации почти не отличаются от живого. А какая экономия времени! Мастера и Маргариту за 15 минут сделала! Ткнул кнопочку на компьютере - и он тебе тихо мирно текст озвучивает, результат сохраняет. Тексты в интернет-библиотеках живут, есть и бесплатные библиотеки. Потом можно и в телефон и в плеер файл загнать. Я уже где-то писала, что лично я начинала с Aboo, сейчас подсела на MP3book2005. Существует еще куча таких программ, на любой вкус. И оборудование никакое не требуется. Книжки сохраняй в любом формате, выкладывай куда хочешь, если финансы позволяют. 21 век на дворе! А вообще здорово, что есть аудиокниги! Лично меня безумно раздражают потуги непрофессианальных чтецов изобразить настроение произведения или придать тексту выразительность. Да честно говоря и профессиональных тоже, создается впечатление "вбивания" в тебя своего прочтения произведения, привнесение личного. Мне больше по душе аудиокниги, записанные компьютерными программами. Там, по крайней мере, самому можно задать темп, голос, выражение и кучу всего другого. Голоса там обычные, человеческие. Я начинала с Aboo, сейчас подсела на MP3book2005. Ну объясните мне, какие преимущества у книг, записанных вживую? Я могу скачать любой текст, озвучить - и вуаля! А могла бы сидеть и тупо ждать, когда кто-нибудь озвучит книгу для меня, да еще может и не понравиться результат. Почему здесь никто не говорит о компьютерном синтезе речи? Народ, мы с вами живем в 21 веке! От многообразия приложений, использующих технологию синтеза речи и умеющих проговаривать вслух любую текстовую информацию, разбегаются глаза, и голова идет кругом даже у бывалых пользователей Интернета. Но рано или поздно выбирать все равно приходится, и посильную помощь в этом нелегком деле может отказать наша подборка программных говорунов, интересных не только с теоретической, но и с практической точки зрения. Govorilka, ABoo и TextSound 2.0 - набор программ для конвертирования текстовых данных в звуковой формат и создания аудиокниг. Благодаря широкой доступности портативных мультимедийных плееров, такие говорящие издания удобно использовать во время поездок в транспорте, на прогулке и на отдыхе, при выполнении рутинной работы и в любых других ситуациях, когда традиционное чтение затруднительно либо невозможно. Перечисленные утилиты практически идентичны по возможностям, за тем лишь исключением, что Govorilka и ABoo (расшифровывается как Audio Book) являются бесплатными продуктами, а TextSound - коммерческим. Все они используют модуль синтеза речи Speech API (SAPI). Если такового в операционной системе не обнаружится, то потребуется скачать и установить недостающие компоненты с сайта Microsoft. ABM Subtitles Reader - несложный в использовании инструмент для озвучивания субтитров в заморских фильмах и записи произнесенного текста в отдельный аудиофайл формата WAV. Последняя функция позволяет создать отдельную звуковую дорожку для всего фильма и впоследствии наслаждаться кинопросмотром без использования текстовых подсказок. Опять-таки, чтобы созданный Антоном Рязановым продукт заработал как часы, потребуется убедиться в том, что в системе установлены модуль синтеза речи Microsoft Speech API (SAPI) и какой-нибудь русскоязычный голосовой движок. В случае отсутствия оных обзавестись ими всегда можно либо на сайте Microsoft, либо на странице разработчика ABM Subtitles Reader. Cool Reader - чтец электронных книг с функцией голосового воспроизведения текста и опцией преобразования читаемых книг в формат MP3. Программа умеет плавно прокручивать демонстрируемый на мониторе компьютера текст, сглаживать экранные шрифты, менять их размер и цвет, а также текстуру фона. Достоинством приложения является то, что оно понимает форматы большинства изданий, которые можно скачать из электронных библиотек, поддерживает распаковку книг из архивов ZIP, RAR, ARJ, HA, LZH и автоматически распознает распространенные русские кодировки. В настоящее время Вадим Лопатин, автор Cool Reader, работает над третьей версией программы, полностью переписанной с нуля и функционирующей на различных платформах. SmartButler. С помощью этого чудо-приложения не составит труда научить разговаривать интернет-мессенджеры, редактор Word и пакет Outlook, предназначенный для работы с почтовой корреспонденцией и организации личных дел. В процессе установки программа автоматически инсталлирует в систему все необходимые компоненты и тем самым освобождает пользователя от поиска тех или иных библиотек в Сети. В качестве говорунов в SmartButler выступают различные анимационные персонажи, виртуальный голос которых можно всячески корректировать в настройках программы. На выбор доступны мужской и женский голоса, регулировка скорости, тона и громкости речи. Советуем сразу тщательно поработать с этими опциями и настроить синтезатор на нужный вам лад, потому что с параметрами по умолчанию синтезируемая приложением речь очень сильно насыщена режущим слух китайским акцентом. Остается лишь добавить, что SmartButler - коммерческий продукт, стоимость которого составляет 15 долларов США. В течение трех недель после установки пользоваться программой можно бесплатно. Internet Explorer Page-Reader Bar. Название этой программы говорит само за себя - предназначена она для озвучивания компьютером веб-страниц, открытых в окне майкрософтовского обозревателя. После инсталляции приложения в панели инструментов браузера появляется блок с управляющими клавишами, нажатие на которые заставляет IE проговаривать вслух либо весь текст на странице, либо выделенную его часть. Увы и ах, но Internet Explorer Page-Reader Bar за свою творческую работу просит денег, поэтому тем, кому приглянулась программа, следует заранее приготовиться к тому, что через 15 дней работы она попросит перечислить авторам 100 рублей. Для владельцев сайтов и блогов в Интернете также предусмотрены поддерживающие синтез речи решения. Так, к примеру, американская компания Oddcast предлагает веб-мастерам услуги дизайна говорящих анимированных персонажей, которых можно размещать в Сети. На созданном сотрудниками фирмы сайте Sitepal.com можно в специальном онлайновом конструкторе собрать виртуальных говорунов в формате Flash, которые будут при открытии сайта в браузере воспроизводить записанный текст. Опять же, пользоваться услугами сервиса можно пятнадцать дней бесплатно, а по истечении данного срока придется определиться с подходящим тарифным планом и отстегнуть разработчикам энную сумму "зеленых". Куда более оригинальными и забавными выглядят два других говорящих сервиса, также реализованных на базе технологии Flash, - Acapela.tv и Ms. Dewey. Первый позволяет создавать веселые флэшовые открытки, озвучивающие набранный текст на разных языках, включая русский, а второй представляет собой поисковый промо-сайт на основе движка Live.com, пару лет назад запущенный корпорацией Microsoft. Особенностью разработки редмондского гиганта является мисс Дьюи (ее роль сыграла американская актриса Янина Гаванкар), которая нетерпеливо стучит рукой по стеклу, подталкивает пальцем слишком медленный индикатор загрузки и предлагает сидящему перед монитором пользователю что-нибудь напечатать (при промедлении - весьма настойчиво). После некоторой паузы, сопровождающейся надписью "Ms. Dewey думает", в правой части экрана появляется список результатов поиска, а дива отпускает короткий комментарий. Вряд ли получится использовать проект Ms. Dewey в качестве инструмента для поиска в Интернете, а вот забавы ради - вполне. Немного о подготовке текста. Как я писал уже ранее есть два варианта работы,это качественный и быстрый. Если вы готовы мирится с некоторыми неправильными произношениями отдельных слов или вас лимитирует время просто загрузите в программу текстовый файл,подключите имеющиеся словари и запустите запись.Я бы рекомендовал писать только в wav.После этого вы сможете сделать из него аудиофайл любого необходимого вам формата в стороннем кодировщике,а wav можно заархивировать с самым большим уровнем сжатия и хранить если это необходимо,как исходник с которым при необходимости можно потом работать. Качественный вариант работы представляет из себя несколько этапов. Первый-это подготовка текстового файла.Что я рекомендую. Используем редактор Texter2 для приведедия текста в более компактный и лучше усваиваемый вид для голосового движка.Здесь нам потребуются функции- вкладка Текст-Регистр-Нижний регистр(это обязательно при работе с моими словарями),заменить табуляцию на пробелы,удалить лишние пробелы,удалить переводы строк,иногда полезна функция удалить красную строку. Вообще я давно хотел написать автору,просьбу включить это в программу,но вот как-то неполучается. Далее используем Bred,как более скоростной при выполнении следующих операций.Конечно можно использовать и саму программу для этого(там есть такая функция или MS Offiсе или что либо другое). Нам надо будет произвести поиск и замену - кавычек,апостофов,скобок()[] (и если содержащаяся в скобках инфа не сильно важна для контекста,то и ее),а также - <>/\ «» и всего остального,что вы посчитаете ненужным.Замена всех этих частей призводится на "ничего",то есть в поле-ввода 'заменить' вы просто щелкаете мышью ничего не вводя. Можно также удалить ненужные пробелы после/перед запятой,точкой,тире-например " ," на "," " - " на "-" ". " на "." " . " на "." По времени при достаточной сноровке 10 минут.(600-700 кб файл) Второй-загрузив подготовленный таким образом текст в программу,мы продолжим подготовку его при помощи встроенного редактора омографов.Как это работает думаю вы разберетесь,хочу только отметить,если вы работаете с моими словарями,то будете,у одного из слов выпавших для выбора,видеть звездочку,это значит что это слово по умолчанию будет звучать так, и оно внесено в словарь 01_hmg.dic.Скажу,что сразу вы вряд ли осилите весь 600-700 кб тестовый файл,поэтому разбейте его например на куски по 50 кб(это будет соответствовать примерно часу звучания и работайте.По времени очень зависит от содержания и сноровки,может занимать от 5 мин до 1 часа и более.(600-700 кб файл). Хотя мои словари достаточно объемные, в любом случае они не охватываеют всё и вся и в каждом тексте могут оказаться слова которые движок произносит неправильно,в большей мере это будут имена собственные и специфические названия и термины.Тут уж решайте сами(вносите в словарь произношений или пропускайте,если опираясь на мои словари вы будете достаточно плотно работать с каждой записываемой книгой,то с каждым разом вам будет это легче и легче). Я наверно провторюсь,но при должном желании можно записать вполне слушаемую книгу. Для тех кто привык к одному клику это не подходит,лучше возмите готовую и слушайте. Какие удобства и проблемы несут с собою электронные книги? Говорилка Маркиза Поставьте свою оценку: (0) голосов Размер текста Версия для печати Электронные книги сегодня медленно, но уверенно отвоёвывают всё новые и новые позиции у традиционных, бумажных книг. Многие зрячие сегодня предпочитают, скачав из Интернета текст интересующей их книги, прочесть её на экране монитора. Но особенно актуален сей вопрос для незрячих и слабовидящих пользо Для чтения электронных книг незрячие и слабовидящие пользователи персонального компьютера используют как скринридеры (программы, позволяющие им работать с ПК, в возможности которых входит и озвучивание текстовых файлов, электронных писем, веб-страничек и т. д.), так и программы, специально предназначенные для чтения электронных книг. Использование последних представляется более целесообразным и приемлемым, ибо позволяет пользоваться некоторыми дополнительными сервисами и возможностями, которых нет в скринридерах, рассчитанных на более широкое применение. На сегодняшний день есть два вида таких программ. К первому виду относятся программы, позволяющие пользователю лишь читать и, в случае необходимости, редактировать текст. Одна из таких программ – Говорилка, написанная Антоном Рязановым. Программа поддерживает синтезаторы человеческой речи, работающие на голосовых движках sapi 4 и sapi 5. В более ранних версиях Говорилки, поддерживающей лишь синтезаторы, работающие с голосовым движком sapi 4, существовала возможность выбора чтеца лишь из трёх возможных голосов: Борис и Светлана, идущие в едином синтезаторе от L&H, и Digalo-Николай. В более поздних версиях программы с реализацией возможности использовать синтезаторы, работающие на голосовом движке sapi 5, выбор синтезаторов существенно увеличился. Первые версии Говорилки позволяли одновременно читать не более трёх книг, открытых в трёх окнах программы. В более поздних версиях число окон увеличилось до десяти. Хотя, по большому счёту, и наличие трёх окон давало неплохие возможности. Например, при желании отдохнуть от чтения научной литературы, переключившись на чтение чего-нибудь художественного, совершенно не обязательно запоминать место нахождения курсора или удалять уже прочитанный текст; достаточно, нажав Ctrl и цифру от 1-го до 3-х, переключиться в следующее окно, где и открыть нужный текст, загрузив его в программу. Даже ранние версии Говорилки позволяют открывать довольно крупные по размеру текстовые файлы. Мною были неоднократно загружены в программу многомегабайтные словари и энциклопедии и даже десятимегабайтное собрание сочинений Александра Сергеевича Пушкина. Правда, стоит отметить, что открытие столь крупных файлов происходит не моментально. На это уходит до нескольких минут времени. При этом в ранних версиях программы в момент открытия файла нет никаких таймеров, что не работающего ранее с программой пользователя может ввести в заблуждение: пользователь может решить, что программа попросту зависла. Однако это не так. Спустя от нескольких десятков секунд, до двух десятков минут (в зависимости от размера текстового файла) программа оживает, на экране появляется текст. При последующей загрузке программы и перехода в то окно, в котором во время предыдущего использования Говорилки был открыт крупный файл, уже не нужно ждать так долго. Программа загружается практически моментально. Не обязательно также и хранить загруженные в программу файлы на жёстком диске. После открытия текста в Говорилке, файлы можно удалить, что никоим образом не отразится на их чтении. Программа позволяет при необходимости менять кодировку текста, размер и цвет шрифта, цвет подсветки, выбирать синтезатор, тембр и скорость звучания голоса. Она проста и легка в эксплуатации. Из наиболее распространённых аналогов Говорилки можно отметить следующие приложения: Бalabolka, Bookse, Speech, Tom и другие. Все они, по большому счёту, похожи друг на друга, имея не столь уж значительные исключения и отличия. Но главный их недостаток на сегодняшний день – это либо полное отсутствие возможности переконвертации текста в mp3, либо очень низкая скорость данного процесса. Некоторые из этих программ способны конвертировать текст в аудиофайлы лишь в реальном времени, то есть на переконвертацию уходит столько же времени, сколько и на прочтение текста, что фактически сводит к нулю все достоинства данной возможности. Сегодня же, когда столь популярны mp3-плееры и флэш-плееры, многие из незрячих и слабовидящих пользователей ПК предпочитают слушать книжки не на компьютере, а на одном из таких плееров. Это и удобней, так как нет необходимости быть привязанным к компьютеру: можно, надев наушники, выйти во двор или, подключив к плееру колонки, поудобней разместиться на диване или кровати. Это и безопасней для здоровья, так как плееры не подвергают пользователя столь большому облучению и прочим негативным воздействиям. По материалам сайта http://shkolazhizni.ru


Методы инженерного творчества. Психологические основы. Эмоциональный интеллект(EQ-методология). Видеокластер EQ 1.0 (Демо-версия)

"И выстраданный стих, пронзительно унылый,
Ударит по сердцам с невиданною силой."
А.С.Пушкин

Обращение к справке о речи м слухе человека
Речь Инсайт Медитация Эйфория Логичность Общение Эпитеты Блиц-доклад Спичрайтер Фонограмма Фонотека Диктофон Микрофон Интонации Темп речи Фразеологизмы Эмоции Акценты Риторика Дикция Тезисы Метафоры Неологизмы Жаргон Дискурсы Дискуссии Аффект Настроение Полемика Трюизмы Аргументация Внушение Зомбирование Ментальность Гипноз Воображение Идеи Ступор НЛП Аудитория Ремарки Тропы Рефлексия Сарказм Ирония Темперамент НЛП Юмор Гиперболы Гротески Аллегории Пародии Критика Аплодисменты Конфликты Регламент Протокол Стенограмма Оратор Цитаты Сюжеты Фабулы Рефрейминг Фразы Брифинг Тембр Слова-паразиты Присловья Оксюмороны Фобии Экстаз Бренд Образ Ассоциации Суждения Ложь Истина Алогизмы Иллюзии Оппоненты Анакруза Мистификация Автор Презентация Преамбулы Шутки Реплики Призывы Девизы Лозунги Голос Эпиграммы

Обращение к сайту разработчика для получения справок и дополнительных модулей, если в этом есть нужда

"Говорилка" - распространенное средство синтеза речи из предложенных ей текстов, простое и удобное в обращении, пригодное для быстрого создания целевых фонограмм м даже обширных фонотек по определенной тематике. Это средство надо знать и активно использовать всем, кто так или иначе связан с деловыми аудио-технологиями, начиная с простых упражнений.

Обращение к сайту разработчика для получения справок и дополнительных модулей, если в этом есть нужда

При должном качестве и полезном содержании синтезированные фонограммы целесообразно распространить в гуще народной, чтобы получить в итоге наибольшую полезную отдачу от трудов своих праведных, создать благолепный имидж и пополнить портфолио достижений. В наше время есть немало способов и каналов продвижения такой информационной продукции и неплохо бы их освоить с видами на будущее.

Справка о программе

Govorilka - это небольшая программа для чтения текста голосом. Она может прочитать вслух любой текст, который Вы ей дадите на любом языке, любым установленным голосом. Программа не новая и не лучшая среди подобных, но прошла испытание временем, все еще распространена и исправно делает свое дело.

Основные возможности:

  • Запись речи в звуковой файл (*.WAV, *.MP3) с повышенной скоростью.
  • Регулировка скорости чтения и высоты голоса.
  • Автоматически прокручивает текст на экране, чтобы всегда был виден читаемый фрагмент (слежение за речью). При этом читаемый текст может подсвечиваться цветом.
  • Пополняемые словари произношений, которые позволяют легко корректировать произношение отдельных слов и словосочетаний.
  • Открывает большие файлы в DOS и Windows кодировке. Размер читаемого текста практически неограничен.
  • Открывает тексты из файлов MS Word и HTML.
  • Голосовое озвучивание текста, набираемого в любых Windows-программах, а так же чтение текста из буфера обмена.
  • Запоминается текст и позиция курсора при выходе из программы.

Govorilka нужна тому, кто больше любит слушать тексты, чем читать их с экрана монитора или бережет свое зрение и хочет читать тексты электронных книг сидя подальше от монитора, кто хочет узнать как звучат слова и фразы на иностранном языке. Говорилка нужна всем, кто хочет научить свой компьютер говорить.

Если у Вас Windows 2000, то Вам достаточно скачать и запустить Говорилку, а если у вас Windows 9x/ME/NT4/XP, то могут понадобиться дополнительнве файлы - должен быть установлен хотя бы один голосовой движок и SpeechAPI:

  • Lernout&Hauspie Text-To-Speech (2929Кб) мужской и женский голос (русский).
  • Microsoft SpeechAPI 4.0 (827 Кб.)
На домашней страничке программы можно скачать дополнительные голосовые движки и словари к программе.

Примеры фонограмм:

  • Про Федота-стркльца
  • Ёжик в тумане
  • Фонотека эрхац-записей
  • Адрес
  • Адрес
    Что делать если "Говорилка" не работает.
    Есть достойная замена! TextAloud от компании Digalo.
    Все тоже самое.Видео для тех, у кого проблемы с программой.
    Вот ссылка
  • Адрес
    Вот ссылка на Digalo Nicolai Russian -
  • Адрес

    • Перед созданием больших фонограммы надо настроить и проверить программу на небольших контрольных примерах из нескольких строк. Фонограмма получается из текстов, которые несут определенную смысловую нагрузку и она есть главное в произведениях подобного рода. Это значит, что прежде следует продумать содержание текста во всех его деталях, составить развернутые тезисы или конспекты и лишь затем садиться за уомпьютер и напрягать этк программу. Понятно, что такой основательный подход требует значительных усилий и вряд ли оправдан при выполнени текущих рутинных работ. Они могут быть составлены изх конспектов, состоящих их множества цитат, скопированных из объемистого учебника, с веб-страниц или из множества других источников, полученных через Интернет. Быстрая подготовка таких конспектов, их озвучивание и многократное прослушивание фоногррамм пиводит к прочному запоминанию материалов без особых усилий и заслуженной хорошей оценке. Фонограммы тезисов доклада, презентации или отчета о практике может быть представлена для оценки вместо устного выступления, присоединяться к исходному тексту для усиления эффекта и многократно прослушиваться перед выступлением, заменяя традиционные репетиции и предзащиту. Хорошая фонограмма может быть размещена в интернете как ценное авторское произведение и упоминаться в различгных документах с указанием адресов, включая регистрацию такого изделия в персональном портфолио достижений. . . Эта фонограмма подготовлена в рамках изучения возможностей данной программы и других синтезаторов речи. доцентом кафедры автоматизации и информационных систем сибирского медустриального гос университета Новокрещиным Борисом Георгиевичем который желает всем творческих и деловых успехов на тернистом пути образования. Автор просит не судить его скорбный труд слишком строго, поскольку для лучших результатов тркбуется больше времени, чем он в состоянии себе позволить. К тому же черновой вариант позволяет легче обнаружить недостатки и поискать средства их профилактики, не делая своих ошибок. Несколько слов о коллоквиуме Для подавляющего большинства студентов экзамен есть ничтоо иное как тестирование и проверка понимания прослушанных лекций, которые записываются почти дословно в еонспектах. Но как быть если курс наполнен творчеством и не с чем сравнивать оригинальные его результаты, каждый сделал что-то свое и этим интересен. Получается тупик и дать объективную оценку традиционными методами не получится. Нужны какие то другие формы контроля и оценки достижений. . Для этих целей используется экспертиза информационной продукции разного рода предоставленная автором экзаменатору или группе компетентных специалистов Это может быть доклад презентация отчет или иные материалы, максимально полно отражающие сущность и особенности проделанной работы. Разберемся вначале с базовым понятием СИНТЕЗ РЕЧИ, используя открытые публикации по теме. В обиходе Вам наверняка приходилось сталкиваться с различными системами синтеза речи. Вот несколько примеров. Служба Московской городской телефонной сети, сообщающая по телефону текущее время, использует синтезатор речи. Диктор наговаривает цифры и такие слова, как «часов», «минут» и «секунд», а компьютер формирует речевое представление текущего времени. Технологии синтеза речи применяются в метро при объявлении остановок. Владельцы мобильных телефонов могут общаться с автоматической сервисной службой для определения остатка средств на счету, переключения тарифных планов, подключения или отключения услуг и пр. Сервисная служба общается голосом с применением технологий синтеза речи. Выпущено немало детских игрушек, «говорящих» человеческим голосом. В этих игрушках также применяются простейшие синтезаторы речи или цифровые магнитофоны. Синтезаторы речи применяются в различных голосовых системах предупреждения, устанавливаемых в автомобилях и самолетах. Такие системы позволяют привлечь внимание человека к возникновению той или иной критической ситуации, не отвлекая его от процесса управления автомобилем, самолетом или другим аналогичным средством. Также разработано немало компьютерных программ, способных читать голосом содержимое текстовых файлов или текст, расположенный в окнах приложений. Эти системы могут оказаться полезными тем, у кого ослаблено или полностью отсутствует зрение. Системы автоматического синтеза речи по тексту находят широкое применение в человекомашинных интерфейсах с устным вводом выводом информации; при речевом управлении различными техническими устройствами; для организация информационно справочных служб; для создания устройств приема и озвучивания различных сообщений, например, писем электронной почты по телефону; при разработке приспособлений и компьютерных систем для помощи незрячим и слабовидящим; как помощь в обучении иностранному языку и во многих других сферах деятельности человека. В блогах и форумах можно встретить немало разноречивых суждений о синтезе речи: от ярых противников до фанатов приверженцев речевых синтезаторов. И каждый из них по своему прав, выдвигая свои доводы в пользу занимаемой позиции и выступая с разгромной критикой оппонентов. Истина же не зависит от личных пристрастий и понимается лишь в контексте более общих явоений и процессов, о которых подчас забывают пламенные ораторы. Злесь, как и в других случаях требуется панорамное мышление и системный подход, ясное понимание места и роли, смысла и значения синтезаторов и полученнных с их помощью фонограмм в общественной жизни Посмотрим же о чем и как думают эти люди. Казалось, такая очевидная вещь: три РАЗНЫХ способа восприятия печатной информации: текст, дикторская запись, синтез! Различие между художественной дикторской записью и синтезированной речью фундаментальное: В первом случае ситуация такая же как с текстом книги и просмотром экранизации может понравиться (или нет) художественное исполнение (нехудожественное дикторское исполнение в топку) Во втором случае имеем дело с "побитовой" предачей информации(с помощью речи) Основной критерий качества здесь ясное, четкое донесение этой самой информации, все остальное читатель сам расцветит эмоционально, в случае нужды(так же как и с печатными буковками). Привыкнуть к такому способу усвоения информации непросто, зато в результате получаем ПОЛНОЦЕННОЕ восприятие текста. То же самое происходит у детей, с овладением навыком чтения. Тонны художественных произведний, научных статей и журналов не будут озвучены никогда. Тем более не будут озвучены так называемые "произведения" знакомых и друзей.. Да, глазом быстрее схватываешь, но что поделать - и глаза устают, и руки-ноги частенько нуждаются в свободе. Один из авторов излагает свое мнение так: Хочу заметить,что основное достоинство этой связки(голосовой движок+программа) прослушать,то,что вам хочется(нравится) и даже огромное количество начитанных живыми дикторами книг не позволяет некоторым в полной мере слушать именно,то,что интересно.Конечно основной недостаток синтезированной речи это произношение.Но Сделать качественную аудио книгу с живым голосом самому достаточно сложно, не правда ли. Сделать озвучку синтезированным голосом,кажется нет ничего легче... А вот здесь-то и неправы те ,кто так думает. Поверьте можно сделать корректную(в смысле произношения)аудио книгу тем же Николаем,однако надо так же потрудится и знать достаточное количество нюансов,чтобы добится желаемого(начиная с правильной подготовки текстового файла). В данный момент многое,что,когда-то делалось вручную,могут программы формата "говорилки".Как вам например такая функция,как почти автоматический поиск и редактирование омографов(за<мок,замо<к).В общем говорить можно долго и много.А в общем то если не слишком заморачиваться и хочется послушать не озвученную никем книгу,то голосовые движки это то,что надо.А за быстроту и возможность слушать ВСЁ,платим,слушая некорректное произношением отдельных слов...но это не смертельно. А вот еще одно суждение Лично меня безумно раздражают потуги непрофессианальных чтецов изобразить настроение произведения или придать тексту выразительность. Да честно говоря и профессиональных тоже, создается впечатление "вбивания" в тебя своего прочтения произведения, привнесение личного. Мне больше по душе аудиокниги, записанные компьютерными программами. Там, по крайней мере, самому можно задать темп, голос, выражение и кучу всего другого. Голоса там обычные, человеческие. Ну объясните, какие преимущества у книг, записанных вживую? Я могу скачать любой текст, озвучить и вуаля! А могла бы сидеть и тупо ждать, когда кто-нибудь озвучит книгу для меня, да еще может и не понравиться результат. И еще насчет процесса чтения, цитата не моя, но эту точку зрения я полностью разделяю: "Вслушайтесь в себя, когда вы читаете про себя. Разве вы читаете с выражением? Вы впитываете информацию напрямую, включая выраженные автором эмоции и уже в воображении текст складывается с эмоциями генерируя образы. Когда профессионал читает художественно текст, он подсознательно пытается создать свое произведение своего искусства, кроме доставки вам собственно авторской информации. Когда вы слушаете книгу без купюр, а не инсценировку "по мотивам", вам это надо? Когда слушаешь аудиокниги, традиционное художественное чтение только мешает (искажает эмоции первоисточника), да еще крайне раздражает медленный темп чтения, который обусловлен этой пресловутой художественностью, потому что в этом случае это есть пустая трата времени, так как при чтении интересной книжки, при котором вы полностью поглощены процессом, возможности восприятия количества информации гораздо выше и определяет в это время вашу потребность в ее интенсивности. В программах синтеза речи конечно есть еще проблемы с качеством, но зато вопрос с темпом воспроизведения не стоит - выбирай, какой нравится. А после полного погружения в процесс, и интонации и дефекты синтеза в значительной степени остаются вне вашего поля зрения и перестают восприниматься, становятся безразличны. Призываю производителей аудиокниг подумать об этом." Кое кто делится своим опытом и результатами Как это делаю я. Скачала программу и голосовой движок. Установила. Скачиваю книги из электронных библиотек одна книга в среднем 800 килобайт. Открываю прогу, нажимаю кнопочку и занимаюсь своими делами. При этом комп почти не грузится. Озвученную книгу можно сохранить в разных форматах. Также настраивается голос мужсклй или женский, скорость прочтения, тембр голоса, длинна пауз на знаках препинания что очень помогает для учебной литературы. Настройки можно сохранять в различных профилях задаешь один раз а потом просто выбираешь нужный профиль для классики, фантастики и научной литературы. Только что взяла Мастера и Маргариту весом 837 Килобайт и секундомер. Записала аудиокнигу в формате wav и это заняло ровно 3 минуты 29 секунд. Записала в mp3 за 10 мин. 42 сек. А теперь слушаю звукозапись не отвлекаясь от домашних дел, вкушая информацию и наслаждаясь ходом мысли автора. Вот такая цена вопроса и конечный смысл моих упражнений. И в заключение еще одна реплика из рядов сторонников режима. . . Давно увлекаюсь оцифровкой текстов книжек Говорилкой (Digalo). Дорога на работу, с работы и т.д. стала удовольствиемsmile.gif Главная проблема была с ударением в именах и названиях. Сложилась четкая технология, которая уверен многим пригодится: 1. проставляю ударения, для чего написал программку, которая просматривает текст и предлагает слова с заглавной буквы и длинные для проставки ударения (естественно один раз каждый корень). Например, в слове "Максимом" нужно стереть 2 последние буквы и поставить ударение, получив "Макси<м". Программа проставляет ударения, удаляет ссылки, нечитаемые знаки и латинские буквы, имеет импорт/экспорт словарей в формате Говорилки. Осторожнее с короткими словами. с них могут начинаться другие длинные. 2. оцифровываю Говорилкой в mp3 с потоком 64 Мегабит (если текстовый файл длинный лучше разделить на куски не более 300 Килобайт); 3. Усиливаю звук до 400 % с помощью Sound Forge (иначе звучит тихо) 4. Режу файл на куски по 20 минут (около 9 Мегабайт) с помощью утилиты mp3DirectCut для облегчения выбора частей записи и все готово! На этом остановимся, хотя сказать можно еще многое.. Впрочем, каждый вправе иметь свое мнение на сей счет исходя из своего опыта, ценностей и предпочтений. И пусть будет мирное небо над нашими головами. Аминь! Материал собрал и озвучил Борис НовокрЕщин, сторонник и друг детей, которых все еще гнобят и калечат прннудительным изучением горы литературы и прочей классики, которую можно бы и послушать в охотку, не слишком напрягаясь и с бОльшим успехом Цирульник пишет в своей статье следующее: Автоматический синтез речи процесс генерации речевого сигнала. Понятие синтеза речи используется в двух смыслах: как процесс восстановления речевого сигнала по его параметрам называемый также ресинтезом сигнала и как процесс генерации речевого высказывания по произвольному тексту(в этом случае говорят о системах синтеза речи по тексту. При рЕсинтезе речевого сигнала осуществляется восстановление ограниченного количества речевых образцов, хранящихся в компьютере в цифровой форме. По сложившейся традиции устройства, с помощью которых речевой сигнал в компрессированном и параметризованном виде записывается сначала в цифровую память компьютера, а затем по необходимости воспроизвОдится, называют синтезАторами речи. Однако в этом случае о синтезе речи можно говорить только условно. Система синтеза речи по тексту осуществляет преобразование произвольного, не известного заранее текста в звучащую речь. В идеале такая система должна имитировать деятельность человека, читающего письменное сообщение любой степени сложности. Человеку такая задача кажется естественной и простой. В реальности же для автоматического синтеза речи по тексту необходимо решить ряд лингвистических задач, основными из которых являются фонетическое транскрибИрование , например, написание и произношение слов молоко, лесница, пюре и интонационная разметка, которая учитывает тип предложения: повествовательное, вопросительное или восклицательное, а также эмоции, выражаемые через интонацию высказывания. При синтезе речи по тексту решаются также задачи аккустической обработки сигнала. Таким образом, система синтеза речи по тексту содержит два основных блока. Блок лингвистической обработки текста, с помощью которого строится фонетическая транскрипция, а также вычисляются необходимые интонационные характеристики; Блок генерации и цифровой обработки речевого сигнала, в котором на основании созданной фонетической транскрипции и интонационной разметки формируется речевой сигнал. Генерация и цифровая обработка сигнала в современных синтезаторах речи может осуществляться параметрическим методом(артикуляторным или формантным) или конкатенативным(компиляционным) методом. Оба этих способа синтеза требуют значительных вычислительных ресурсов и стали возможны благодаря развитию и широкому использованию компьютерной техники. Интересно, что первые попытки создания «говорящей машины» делались задолго до появления компьютеров. Такие машины были механическими и основывались на моделировании голосового аппарата человека. Так, в конце XVIII века учёный Санкт Петербургского университета Кранценштейн сконструировал механическую машину, способную произносить пять гласных звуков русского языка: а, о, у, и, э. Наиболее известный механический синтезатор речи создал австрийский учёный Фон Кампелен, дополнив синтезатор Кратценштейна моделями легких, голосовых связок и ротовой полости. С помощью такой машины можно было произвести около 20 речевых звуков. Машина Кемпелена управлялась человеком оператором, действия которого напоминали игру органиста самого высокого уровня. В современных параметрических синтезаторах моделируются физические процессы образования речи либо результат этих процессов: акустические характеристики речевой волны. Характеристики речеобразования артикуляторные либо акустические) задаются определёнными правилами, описывающими значение и изменение параметров речевого аппарата человека. На основе указанных параметров формируется цифровая версия речевой волны, которая затем озвучивается. В синтезаторах, использующих компиляционный метод, генерация речевого сигнала осуществляется на основе выбора из акустической базы данных и последующей компиляции «склейки» коротких отрезков речевого сигнала. Полученный непрерывный сигнал затем при необходимости обрабатывается для того, чтобы придать речевому высказыванию нужную интонацию. Качество синтезированной речи в компиляционных синтезаторах, как правило, выше качества параметрического синтеза, поскольку в первом случае не моделируются сложные процессы акустики речеобразования, а используются готовые отрезки речевой волны. Все существующие в настоящее время методы синтеза человеческой речи основаны на использовании двух моделей модели компилятивного синтеза и формантно голосовой модели. Рассмотрим вкратце особенности этих моделей. Модель компилятивного синтеза предполагает синтез речи путем конкатенации (составления) записанных образцов отдельных звуков, произнесенных диктором. При использовании этой модели составляется база данных звуковых фрагментов, из которых в дальнейшем будет синтезироваться речь. На первый взгляд этот подход не должен вызывать особых затруднений. Действительно, пользуясь микрофоном и звуковым редактором, например, редактором GoldWave , Вы можете создать набор файлов различных звуковых фрагментов, а затем сохранить их содержимое в базе данных. Создавая звуковые WAV файлы с текстовыми сообщениями, можно озвучить операционную систему Microsoft Windows и многие ее приложения, такие как почтовые программы, инструментальные средства разработки и пр. Если Вы умеете создавать программы, то для Вас не составит труда сделать простейший синтезатор речи, составляющий фразы из отдельных фрагментов. Информацию, необходимую для составления программ, работающих со звуком, можно найти в библиотеке M S D N. Модель компилятивного синтеза подходит, главным образом, только в простейших случаях, когда синтезатор должен произносить относительно небольшой и заранее известный набор фраз. При этом обеспечивается довольно высокое качество речи. Впрочем, этот факт не слишком удивителен, если вспомнить, что для синтеза используется естественная человеческая речь. Тем не менее, на стыке составляемых звуковых фрагментов возможны интонационные искажения и разрывы, заметные на слух. Кроме того, создание крупной базы данных звуковых фрагментов, учитывающей все особенности произношения фонем и аллофонов с разными интонациями, представляет собой сложную и кропотливую работу. Формантно-голосовая модель основана на моделировании речевого тракта человека и может быть реализована с применением нейронных сетей и допускает самообучение. К сожалению, ввиду сложности точного моделирования особенностей речевого тракта, а также учета интонационной модуляции речи формантно-голосовая модель обладает относительно низкой точностью синтезируемых звуков речи. Тем не менее, современные программы синтеза речи, построенные с использованием этой модели, синтезируют вполне разборчивую речь и могут применяться в ряде случаев. Заметим, что системы голосового предупреждения о возникновении аварийных ситуаций лучше строить с использованием модели компилятивного синтеза, так как разборчивость речи в таких системах выходит на передний план. Что же касается «бытовых» синтезаторов речи, то в них можно с успехом применять и форманто-голосовую модель. При построении модели использовались данные об артикуляционном аппарате человека, а также данные фонетики и лингвистики. Как видите, в качестве исходного сигнала применяется комбинация голосового источника и генератора шума. Прерыватель и резонансное устройство моделирует работу речевого тракта. В результате этого моделирования образуется излучаемый звук речи. При этом для достижения компромисса между качеством модели и ее сложностью были выбраны следующие основные параметры исследуемой системы: частота основного тона; частота шума; количество формант; центральная частота каждой форманты; вклад каждой форманты. Частота основного тона определяет высоту голоса. Этот параметр не должен вызывать у Вас никаких вопросов. Что же касается частоты шума, то здесь нужно сделать пояснение. Образование шума представляет собой достаточно сложный процесс, зависящий от многих факторов, таких как давление и скорость воздушной струи, геометрической формы воздушного тракта, акустических свойств материала и прочее. Чтобы полностью смоделировать шум речи на физическом уровне, необходимо создать точную модель речевого аппарата человека, что представляет собой очень сложную задачу. В качестве альтернативы использует белый шум, спектр которого распределен по некоторому закону (например, по Гауссу) относительно некоторой центральной частоты. При этом закон распределения подбирается экспериментально, а частотой шума в этом случае является упомянутая выше центральная частота. Количество активных формант, участвующих в образовании речи, выбирается экспериментально, причем в качестве ориентировочного значения используется 4. Так как форманта представляет собой резонанс в речевом тракте, у неё есть частота резонанса и огибающая. Вид огибающей также определяется экспериментально, в первом приближении это Гауссово распределение. Вклад каждой форманты определяет, насколько сильно форманта воздействует на основной сигнал. Все приведенные выше параметры, кроме количества формант, изменяются в процессе образования речи для получения различных звуков. Хотя для более качественного синтеза речи необходимо строить более детальную модель, приведенные параметры достаточны для того, чтобы синтезированные звуки были разборчивы. Синтез речи с помощью нейронной сети Для исследования формантно-голосовой модели синтеза речи был создан инструмент Модель синтеза, в котором ручным заданием параметров можно синтезировать практически любой гласный или шипящий звук. Процесс синтеза речи выглядит следующим образом. Уровни выходов нейронов эффекторного слоя нейросети при помощи карты эффекторов преобразуются в значения выбранных параметров модели синтеза. Карта эффекторов определяет соответствие между каждым нейроном эффекторного слоя и конкретным параметром модели синтеза, а также предельные значения каждого параметра. Число эффекторов и число параметров модели может не совпадать. Если параметру не соответствует ни один эффектор, используется некоторое фиксированное значение (значение по умолчанию). Далее по текущему состоянию модели синтезируется сигнал в пространстве частот: генерируется линейка частот, представляющих голосовой источник. На эту линейку частот накладывается формантная структура (резонансы). Для синтеза шума используется генератор случайной амплитуды и фазы. На последнем этапе выполняется обратное преобразование Фурье для получения звуков речи. При обучении системы формировались нейронные ансамбли для каждого звука из обучающей последовательности а, б, в, г, д. Затем проводилось обучение синтезу. В результате в эффекторном слое установились правильные связи с символьным слоем. Система успешно обучилась синтезу синтезируемые звуки в точности соответствуют тонам из обучающей выборки. х проведения экспериментов Вы найдете в литературе. Ограничения использованного алгоритма. В этом алгоритме узким местом является размер окна дискретного преобразования ФурьЕ ДПФ. В данной модели синтезируются статичные звуки, при этом не происходит изменение параметров в процессе синтеза. В реальной же речи параметры звука меняются при переходе от одного звука к другому, причем меняются непрерывно. Очевидно, при использовании окон ДПФ такой результат получить невозможно в пределах окна параметры звука меняться не будут. Теоретически благодаря полной обратимости дискретного преобразования Фурье возможно получить спектр для любого сигнала, в том числе и с динамически меняющимися параметрами. Поэтому для генерации звука с изменяющимися параметрами нужно сокращать размер окна ДПФ или брать не весь сгенерированный кадр, а только его часть (не забывая при этом синхронизировать фазу сигнала). В идеале размер кадра можно свести к одному отсчету дискретизации по времени. Этот способ генерации речи дает лучшие результаты по сравнению с ДПФ, но работает гораздо медленнее ДПФ. В системе SAS можно выбрать используемый способ генерации. . . Обзор подготовил и озвучил Борис Новокрещин, уроженец Кузбасса Небольшой обзор опубликованных в Интернет материалов, посвященных синтезаторам речи. Синтез речи осуществляется специализированными программами и утилитами, входящими в состав операционных систем. Синтезаторы речи это программы, на вход которых подаётся текст, а на выходе синтезируется человеческая речь. Эти программы имеют широкое применение в телефонии, электронных ассистентах, для телефонного доступа к веб приложениям, в образовательных целях, в колл центрах и так далее. Рассмотрим распространенные в народе инструментальных средствах, которые прошли довольно долгий путь развития и представлены в наше время рядом конкурентных программных продуктов. Способность синтезировать человеческий голос имел еще ZX Spectrum в 1992 году. С появлением персоналок компьютеры утратили эту способность, и только в 96 году появилась утилита DOS под названием S P P, которая работала с командными бат файлами, озвучивая текст на русском языке через встроенный динамик или, как его тогда называли, бипер. Качество синтеза было преотвратным, и, тем не менее, это было очень полезное приложение. Свист и шипение быстро утомляли слушателя, однако с его помощью можно было как-то озвучить происходящие в машине процессы. В 1995 году появился российский синтезатор «Говорящая мышь для дома». Его создатели, «Клуб голосовых технологий» превзошли самые смелые ожидания и выпустили не только синтезатор с набором голосов и множеством дополнительных функций, но практически сформировали мультимедийный конструктор, сравнимый разве что с Power Point. К чести программистов следует отметить невероятный такт и терпение, с которым создавался программный продукт. "мышь" защитили от копирования, и так облизали, что это развило в создателях паранойю. Версия 4.5 оказалась самой удачной, Дальнейшие разработки компании большим успехом не отличались. Версия 5.0 оказалась хуже предыдущей, а давно ожидаемая частотная фильтрация и женский голос так и не появились в розничной продаже. Большим недостатком синтезатора осталась его привязанность к приводу компакт дисков, чтение маленьких по размеру файлов и достаточно сиплый синтез. Существенным преимуществом перед другими синтезаторами стал режим слежения, комментирующий все, что происходит в системе, а также загрузка текста клавишей Scroll. Подстраивать процесс в широких пределах оказалось невозможным, и для того чтобы наслаждаться чтением, пришлось привыкать к монотонному голосу. Вероятность заснуть под монотонное бубнение слишком высока, поэтому если вы собираетесь слушать книги в синтезе первое время начните с самых коротких сеансов. Сегодня от многообразия приложений, использующих технологию синтеза речи и умеющих проговаривать вслух любую текстовую информацию, разбегаются глаза, и голова идет кругом даже у бывалых пользователей Интернета. Но рано или поздно выбирать все равно приходится, и посильную помощь в этом нелегком деле может отказать подборка программных говорунов, интересных не только с теоретической, но и с практической точки зрения. Govorilka, ABoo и TextSound 2.0 это набор программ для конвертирования текстовых данных в звуковой формат и создания аудиокниг. Благодаря широкой доступности портативных мультимедийных плееров, такие говорящие издания удобно использовать во время поездок в транспорте, на прогулке и на отдыхе, при выполнении рутинной работы и в любых других ситуациях, когда традиционное чтение затруднительно либо невозможно. Перечисленные утилиты практически идентичны по возможностям, за тем лишь исключением, что Govorilka и ABoo (расшифровывается как Audio Book) являются бесплатными продуктами, а TextSound - коммерческим. Все они используют модуль синтеза речи Speech API (SAPI). Если такового в операционной системе не обнаружится, то потребуется скачать и установить недостающие компоненты с сайта Microsoft или русский движок речи "Digalo" , выпущенный неизвестной компанией. Большим разнообразием российский рынок синтеза пока не располагает. И принципиально делится на синтезаторы фирменного исполнения и так называемые движки. Технология Texts to Speech это открытая система, позволяющая использовать ее в любых приложениях, таких как OLE технология или обмен D D E. На основе этой системы уже российские программисты понастроили оболочек из разряда читалок, которые также не отличаются многообразием. Трудно понять, почему зарубежные компании производят российское программное обеспечение. ABM Subtitles Reader несложный в использовании инструмент для озвучивания субтитров в заморских фильмах и записи произнесенного текста в отдельный аудиофайл формата WAV. Последняя функция позволяет создать отдельную звуковую дорожку для всего фильма и впоследствии наслаждаться кинопросмотром без использования текстовых подсказок. Опять-таки, чтобы созданный Антоном Рязановым продукт заработал как часы, потребуется убедиться в том, что в системе установлены модуль синтеза речи Microsoft Speech API или SAPI и какой-нибудь русскоязычный голосовой движок. В случае отсутствия оных обзавестись ими всегда можно либо на сайте Microsoft, либо на странице разработчика ABM Subtitles Reader. Cool Reader чтец электронных книг с функцией голосового воспроизведения текста и опцией преобразования читаемых книг в формат MP3. Программа умеет плавно прокручивать демонстрируемый на мониторе компьютера текст, сглаживать экранные шрифты, менять их размер и цвет, а также текстуру фона. Достоинством приложения является то, что оно понимает форматы большинства изданий, которые можно скачать из электронных библиотек, поддерживает распаковку книг из архивов ZIP, RAR, ARJ, HA, LZH и автоматически распознает распространенные русские кодировки. В настоящее время Вадим Лопатин, автор Cool Reader, работает над третьей версией программы, полностью переписанной с нуля и функционирующей на различных платформах. SmartButler. С помощью этого чудо-приложения не составит труда научить разговаривать интернет мессенджеры, редактор Word и пакет Outlook, предназначенный для работы с почтовой корреспонденцией и организации личных дел. В процессе установки программа автоматически инсталлирует в систему все необходимые компоненты и тем самым освобождает пользователя от поиска тех или иных библиотек в Сети. В качестве говорунов в SmartButler выступают различные анимационные персонажи, виртуальный голос которых можно всячески корректировать в настройках программы. На выбор доступны мужской и женский голоса, регулировка скорости, тона и громкости речи. Советуем сразу тщательно поработать с этими опциями и настроить синтезатор на нужный вам лад, потому что с параметрами по умолчанию синтезируемая приложением речь очень сильно насыщена режущим слух китайским акцентом. Остается лишь добавить, что SmartButler коммерческий продукт, стоимость которого составляет 15 долларов США. В течение трех недель после установки пользоваться программой можно бесплатно. Internet Explorer Page-Reader Bar. Название этой программы говорит само за себя предназначена она для озвучивания компьютером веб страниц, открытых в окне майкрософтовского обозревателя. После инсталляции приложения в панели инструментов браузера появляется блок с управляющими клавишами, нажатие на которые заставляет IE проговаривать вслух либо весь текст на странице, либо выделенную его часть. Увы и ах, но Internet Explorer PageReader Bar за свою творческую работу просит денег, поэтому тем, кому приглянулась программа, следует заранее приготовиться к тому, что через 15 дней работы она попросит перечислить авторам 100 рублей. Для владельцев сайтов и блогов в Интернете также предусмотрены поддерживающие синтез речи решения. Так, к примеру, американская компания Oddcast предлагает веб мастерам услуги дизайна говорящих анимированных персонажей, которых можно размещать в Сети. На созданном сотрудниками фирмы сайте Sitepal.com можно в специальном онлайновом конструкторе собрать виртуальных говорунов в формате Flash, которые будут при открытии сайта в браузере воспроизводить записанный текст. Опять же, пользоваться услугами сервиса можно пятнадцать дней бесплатно, а по истечении данного срока придется определиться с подходящим тарифным планом и отстегнуть разработчикам энную сумму "зеленых". Куда более оригинальными и забавными выглядят два других говорящих сервиса, также реализованных на базе технологии Flash, Acapela.tv и Ms. Dewey. Первый позволяет создавать веселые флэшовые открытки, озвучивающие набранный текст на разных языках, включая русский, а второй представляет собой поисковый промо сайт на основе движка Live.com, пару лет назад запущенный корпорацией Microsoft. Особенностью разработки редмондского гиганта является мисс Дьюи (ее роль сыграла американская актриса Янина Гаванкар), которая нетерпеливо стучит рукой по стеклу, подталкивает пальцем слишком медленный индикатор загрузки и предлагает сидящему перед монитором пользователю что нибудь напечатать (при промедлении - весьма настойчиво). После некоторой паузы, сопровождающейся надписью "Ms. Dewey думает", в правой части экрана появляется список результатов поиска, а дива отпускает короткий комментарий. Вряд ли получится использовать проект Ms. Dewey в качестве инструмента для поиска в Интернете, а вот забавы ради вполне. С вами как всегда Борис Новокрещин, любитель и популяризатор новых информационных технологий


Миграционная карта.

Экстрим-задача

"В жизни всегда есть место для подвига."

Освоение средств речевого синтеза может осуществляться по необходимости или в охотку, без ощутимых результатов или со впечатляющим успехом, с реализацией банальных возможностей или всего потенциала информационных технологий, беспорядочно или со знанием дела, профессионально и высокопродуктивно. Здесь, как и во многих других ситуациях, у каждого есть выбор и шанс совершить нечто значимое и важное для будущей карьеры, общественного признания и личного душевного комфорта. Из множества возможных вариантов каждый выбирает то, на что способен и к чему стремится, действуя в рамках реальных ограничений и руководствуясь своими принципами.

За 15 дней, отводимых для свободного использования речевого движка, каждый может создать внушительную фонотеку озвученных произведений разного рода, имеющую свою ценность и значение для определенного круга пользователей, достойную упоминания в персональном портфолио автора и других официальных документах. Результат зависит от выбора конкретной стратегии, состава и структуры обрабатываемых произведений, их конкурентных свойств и стилистических особенностей, мест размещения и свособов доставки конечным пользователям, а также от множества других факторов, так или иначе влияющих на успешность дела. Опыт показывает, что итоги разных исполнителей в составе одгородной группы могут отличаться в разы и на порядки, в зависимости от качества предварительной подготовки производственного процесса.


Миграционная карта.

google


Миграционная карта.

Виртуальная школа имиджмейкеров
Средства самопрезентации

Фонограммные произведения

Синтезаторы речи

Пособие

© Б.Новокрещин

Новокузнецк
2013


Фонограммные технологии. Синтезаторы речи. Интерактивные формы обучения. Тренажер-демонстратор типовых возможностей. Модуль SP 1.0 (beta)

Тренажер-демонстратор синтеза речи

Для оценки возмоэностей синтезаторов речи вводите образцы текстов и слушайте варианты их звукового исполнения, меняя значения параметров настройки. Текст можно дополнять типичными для печатных изданий цифрами и символами, аббревиатурами и сокращениями, чтобы понять как они воспринимаются программой и учесть затем при подготовке озвучиваемых материалов. Результаты экспериментов с контрольными примерами фиксируются в типовом протоколе и пояснительной записке, раскрывающей сущность решаемых задач и особенности полученных результатов, как это предусмотрено действующими стандартами и общими правилами предварительных испытаний информационных систем подобного рода.

Говорит Говорилка

"Подзовем-ка ее, да расспросим:
Как дошла ты до жизни такой?"
Н.А.Некрасов

Примеры синтеза речи из различных текстов со своей грамматикой, котрая отражается на качестве фонограммы. Дефекты звучания и другие недостатки нетрудно обнаружить при внимательной прослушивании звукозаписей, чтобы изылечь опыт и не допускать ошибок в скоей работе. На качество фонограммы влияет выбор голосовых движков, настройка программы-синтезатора, очистка и специальная разметка исходного текста. Последнее осуществляется по правилам, установленным разработчикам и изложеннми в руководстве пользователя программы.

файлообменник rghost