Наглядные материалы

Визуализация структуризуемых знаний

www.openet.ru

Еще в XVII веке Ян Коменский сформулировал принцип наглядности: «…все, что только можно, предоставлять для восприятия чувствами». Чувственное восприятие означает восприятие изучаемых объектов, их макетов или моделей и их личное наблюдение учащимися. А вот как определял принцип наглядности К.Д.Ушинский: «Что такое наглядное обучение? Да это такое ученье, которое строится не на отвлеченных представлениях и словах, а на конкретных образах... Педагог, желающий что-нибудь прочно запечатлеть в юношеской памяти, должен позаботиться о том, чтобы как можно больше органов чувств – ухо, глаз, голос, чувство мускульных движений и даже, если возможно, обоняние и вкус, приняли участие в акте запоминания».

Первоначально наглядность понималась как предъявление конкретных (видимых) объектов, например: реальных предметов и явлений в их натуральном виде, модели машин, муляжи и некоторые графические пособия, учебные кинофильмы и т.д. В современной же дидактике утверждается, что принцип наглядности – это систематическая опора не только на конкретные визуальные предметы (люди, животные, предметы и т.п.) и их изображения, но и на модели.

А что же такое модель? В чем ее принципиальное отличие от традиционной наглядности? Модель – это условный образ какого-либо объекта или системы объектов. Натуральные предметы и их изображения дают, прежде всего, представление о внешнем облике изучаемого объекта в целом. Модели воспроизводят лишь отдельные, наиболее существенные стороны явления или процесса.

Однако эти стороны должны быть отражены правильно, адекватно, то есть быть изоморфны изучаемому явлению. Для того чтобы сделать средства обучения наглядными, необходимо выделить основные свойства изучаемого явления (то есть превратить его в модель), правильно, адекватно отразить эти свойства (то есть сделать модель изоморфной изучаемому явлению) и, кроме того, обеспечить доступность этой модели для учащихся. Таким образом, изоморфизм и простота рассматриваются как отличительные признаки наглядности.

Роль учебных моделей (как вид иллюстраций) в формировании теоретических понятий как основы научного мышления убедительно раскрыта В.В.Давыдовым. Он характеризует учебные модели как своеобразный сплав наглядности и понятия, конкретного и абстрактного, предлагает даже рассматривать моделирование как дидактический принцип, дополняющий наглядность. Соотношение этих принципов В.В.Давыдов определяет следующим образом: «…Там, где содержанием обучения выступают внешние свойства вещей, принцип изобразительной наглядности себя оправдывает. Но там, где содержанием обучения становятся связи и отношения предметов, – там наглядность далеко не достаточна. Здесь вступает в силу принцип моделирования» .

Очевидно, более правомерно говорить о моделировании как составной части принципа наглядности, то есть о расширении содержания данного принципа. Это, в свою очередь, означает расширение арсенала средств наглядности (использование не только конкретно-образного материала, но и моделей) и расширение сферы их применения (формирование не только представлений, но и понятий, не только знаний, но и умений, навыков).

Благодаря современным компьютерным технологиям, мультимедийным возможностям компьютера можно не только во всех подробностях реализовать статические модели иллюстрации, но и представить эти модели в динамике, то есть в движении.

Все это позволяет говорить о том, что средства наглядности обретают новую функцию – управление познавательной деятельностью учащихся. С их помощью можно подводить учащихся к необходимым обобщениям, учить применять полученные знания.

Одним из требований эффективной методики использования иллюстративных средств обучения является, таким образом, реализация их дидактических и воспитательных возможностей. Использование форм наглядности, которые не только дополняют словесную информацию, но и сами выступают носителями информации, должно способствовать повышению степени мыслительной активности учащихся.

Уникальные возможности человеческого зрения по переработке и распознаванию изображений еще недостаточно используются как в обычных, так и компьютерных учебниках.

Изобразительные и условно-графические средства наглядности (таблицы, схемы, рисунки, графики, диаграммы, репродукции картин, фотографии ученых, живопись, аудиовизуальные средства и т.д.), являющиеся составными элементами печатных и электронных учебных материалов, играют существенную роль в интеллектуальной познавательной деятельности учащихся. От наглядности, доходчивости, смысловой полноты и других полезных свойств теоретического материала зависит скорость восприятия учебной информации, понимание ее, усвоение и закрепление полученных знаний.

Широкое использование того или иного вида иллюстраций в трудных для понимания фрагментах текста, требующих наглядного разъяснения, иллюстрирования понятий и определений, а также для оживления всего курса лекций (как печатного, так электронного), позволят улучшить восприятие, понимание и усвоение сложного учебного материала, сократить время обучения студента, повысить эффективность учебно-познавательной деятельности в целом.

Но привлекательность и эффективность обучающих мультимедийных программ может снизиться, если в целом не будут соблюдены следующие дидактические принципы обучения.

Принцип наглядности обучения в дидактике – это ориентация на использование в процессе обучения разнообразных средств наглядного представления соответствующей учебной информации.

Какое же новое качество приобретает принцип наглядности обучения при использовании компьютерных информационных технологий, в том числе и электронного учебника? Ответ на вопрос можно свести к следующим положениям:

1) средства современных информационных технологий существенно повышают качество самой визуальной информации, она становится ярче, красочнее, динамичнее. Огромными возможностями обладают в этом плане технологии мультимедиа;

2) в связи с тем, что при использовании современных информационных технологий коренным образом изменяются способы формирования визуальной информации, становится возможным создание "наглядной абстракции". Если традиционная наглядность обучения подразумевала конкретность изучаемого объекта (об этом говорилось выше), то при использовании компьютерных технологий становится возможной интерпретация существенных свойств не только тех или иных реальных объектов, но и научных закономерностей, теорий, понятий, причем в динамике, если это необходимо.

Если первое преимущество, касающееся реализации принципа наглядности обучения, а именно – высокое качество компьютерной визуализации, как бы лежит на поверхности и всеми признано, то второе преимущество, заключающееся в возможности наглядно-образного представления абстрактных, сущностных, наиболее значимых сторон и свойств изучаемых явлений, закономерностей, систем, устройств, пока еще не в должной мере осознано. Но именно в нем скрывается большой резерв повышения эффективности процесса обучения. Благодаря этому преимуществу облегчается переход к дедуктивной логике учебного процесса.

Таким образом, требования обеспечения наглядности в случае использования электронного учебного материала могут и должны быть реализованы на принципиально новом, более высоком уровне. В перспективе, когда получат большее распространение системы виртуальной реальности, обеспечивающие воздействие на зрение, слух, осязание и даже обоняние, по-видимому, целесообразнее будет говорить не только о наглядности, но и о полисенсорности обучения, т.е. чем больше органов чувств участвует в процессе восприятия информации, тем успешнее процесс познания. Вместе с тем, несмотря на всеобщее признание высокой значимости принципа наглядности обучения, в науке практически отсутствуют теоретические основы создания педагогически эффективных наглядно-образных представлений для электронных учебников.

Цель разработки учебного материала СУМИК – сохранить не только все достоинства печатного учебного материала, но и, используя возможности компьютера, включить в него соответствующий арсенал наглядных средств. Естественно возникает вопрос, по какому же принципу отбирать виды и количество необходимого иллюстративного материала?

Иллюстрации рекомендуется использовать в местах:

  • трудных для понимания учебного текста, требующих дополнительных иллюстраций;
  • для обобщений и систематизации тематических смысловых блоков;
  • для общего оживления всего учебного материала и рассредоточенного по всему полю текста как печатного, так электронного (гипертекста).

    Нецелесообразно предоставлять студенту "неограниченную" свободу передвижения (за счет средств навигации) по всему полю гипертекста к другим объектам ссылок, не сообразуясь с педагогическими методами и способами преподавания предмета, а также с правилами целесообразности и разумности. В результате таких бессмысленных и частых переходов: то на картинку, то на словарь, то на какой-то другой объект гипертекста – в голове учащегося остается лишь "гипертекстовый сумбур, каша", а вовсе не стройная система знаний.

    Студента, безусловно, нельзя лишать свободы навигации (маршрутов движения) по учебному материалу. Необходим разумный компромисс, основывающийся на таких ключевых педагогических понятиях из области методики преподавания, как линейное прохождение материала, или линейно-концентрическое, или модульное (о чем прекрасно осведомлены преподаватели соответствующих дисциплин).

    Нежелательно, когда в гипертексте рябит от подвижных картинок (анимация-изображение иллюстрации в динамике), которые часто расположены не к месту, но зато создают эффект красочного "фейерверка". Такая анимация ничего не дает для понимания учебного материала, в отличие от разумной развлекательности. Но та, которая работает на повышение эффективности изучения теоретического материала, – сокращает временные трудозатраты студента.

    Так сколько должно быть иллюстраций, например, в одной теме? Все диктуется содержанием и характером теоретического учебного материала. Если автор в состоянии заменить, например, какой-то теоретический абзац соответствующим видом иллюстрации, то это хорошо; а если сможет переложить все словесно-теоретическое изложение курса на одни картинки, то еще лучше (если такое возможно). Перефразируя пословицу, можно сказать и так: "Лучше увидеть один раз иллюстрацию, чем долго читать скучный печатный или электронный текст".

    Конкретное количество иллюстраций для страницы, темы или для всего курса лекций, таким образом, специально не устанавливается, а определяется следующими факторами:

  • содержанием и характером учебного текста;
  • выбранной методикой обучения;
  • возможностями организации (учреждения).

    Существует большое многообразие видов наглядности и типов их классификаций по различным признакам. Чаще всего методисты обращаются к классификации по содержанию и характеру изображаемого, выделяя три группы:

    1. Изобразительная наглядность, в которой значительное место занимают:

  • репродукции картин;
  • фоторепродукции памятников архитектуры и скульптуры;
  • учебные картины, специально созданные художниками или иллюстраторами для учебных текстов;
  • рисунки и аппликации;
  • видеофрагменты;
  • аудиофрагменты;
  • видеофильмы (в т.ч. аудио- и видеосюжеты).

    2. условно-графическая наглядность, которая представляет собой своеобразное моделирование:

  • таблицы;
  • схемы;
  • блок-схемы;
  • диаграммы;
  • графики;
  • карты;
  • картосхемы;
  • планшеты.

    3. Предметная наглядность (для компьютерного учебника будет называться видеофрагментом или фотографией предметных объектов):

  • музейные экспонаты;
  • макеты;
  • модели.

    Приведем классификацию используемых наглядных средств по признаку восприятия учащимися учебного материала.

    Под понятием «восприятие информации» подразумевается факт подключения к процессу познания или только уха, или только зрения, или уха и зрения одновременно, а также при подключении чувственно-эмоциональной стороны познания человека.

    Действительно, овладение учебным материалом начинается с его восприятия. Вот почему педагоги стремятся задействовать различные органы чувств (анализаторы): слуховые, зрительные, двигательные и др. И чем больше органов чувств участвуют в восприятии учебной информации, тем легче она усваивается. Конечно, кроме наличия иллюстративного материала, для активизации процесса осмысления учебного материала важно, чтобы он был доступным, логически взаимосвязанным, правильно понятым, актуализированным. В этих целях лучше использовать яркие и точные формулировки, таблицы, схемы, репродукции картин, рисунки, аудио- и видеофрагменты.

    Хорошо оформленный, понятный, богато иллюстрированный учебный материал вызывает определенные положительные эмоции, оказывает влияние на его общее состояние. Положительные эмоции повышают интерес к предмету. При наличии интереса, потребности в овладении учебной информацией активизируется вся психическая деятельность: усиливается концентрация и интенсивность внимания, обостряются чувствительность и наблюдательность, повышается готовность памяти и обеспечивается легкость протекания мыслительных процессов, а, следовательно, и восприятия учебного материала. При отсутствии положительной мотивации учебная деятельность замедляется, возникают барьеры на пути восприятия и понимания учебного текста.

    Различают следующие виды восприятия и познания (см. рис.):

    Рис. 7.5. Виды восприятия и познания

    Нагрузка, таким образом, падает и на органы зрения. Психологи уже давно доказали, что преобладающую часть информации человек воспринимает зрительно, что сам механизм мозговой информации настроен на "зрительную модальность".

    Рассмотрим один из видов условно-графических наглядных средств – таблицы, которые существенно облегчают восприятие текста.

    Таблица – это самое простое графическое изображение материала, в котором основными элементами графики являются линии и колонки. Число столбцов и строк, в которых располагается учебный материал, может быть различное. Таблицы легко создать, и они просты в использовании. Они могут занимать часть экранной страницы, целую страницу или даже несколько экранных страниц электронного учебника (или несколько печатных страниц).

    Располагая разнообразным арсеналом графических средств (при переводе таблиц в электронный учебник), таблицы можно оформить с помощью, например:

    разнообразной палитры цветов;

    рисунков (здесь рисунок как элемент оформления таблицы);

    набора шрифтов;

    различных средств обрамления таблиц;

    установления определенного количества столбцов и строк;

    реализации эффекта движения таблиц (анимация) и др.

    Таблицы широко используются как в печатных, так и электронных учебных материалах, реализующих зрительную наглядность. Текстовая и числовая информация, представленная в форме таблицы, значительно легче воспринимается.

    Главный признак и критерий создания таблиц – это использование их в тех местах текста, где требуется:

    · повысить зрительную наглядность и облегчить восприятие того или иного смыслового фрагмента текста;

    · осуществить определенное сравнение двух и более объектов (таких содержательных элементов текста, как события, факты, явления, персоналии, предметы, фрагменты текстов и др.);

    · осуществить группировку ряда объектов;

    · произвести систематизацию тех или иных объектов.

    В самой табличной форме, таким образом, заложены возможности:

    · широкого использования наглядного разъяснения смысла в определенном месте текста;

    · приема сравнения двух или более элементов;

    · раскрытия отношений противопоставления или аналогии.

    Поэтому таблицы по выполнению их функциональной роли разделяют на три вида.

    1. Разъяснительные таблицы – в сжатом виде облегчают понимание изучаемого теоретического материала, способствуют сознательному его усвоению и запоминанию.

    2. Сравнительные таблицы – осуществляют сопоставление и противопоставление материала и являются одним из видов его группировки, то есть отражают специфику табличной формы. Сравниваться могут любые элементы: существенные сопоставимые признаки исторических, социальных, экономических и политических объектов, типы хозяйств, типы темперамента человека и т.п. При сравнении выделяют у них общее, особенное, единичное и т.д.

    3. Обобщающие или тематические таблицы – подводят итог изученному теоретическому материалу, способствуют формированию понятий. Обобщая что-либо, в логической последовательности перечисляют основные черты явлений, событий, процессов и т.п., самое существенное в них.

    Таблицы систематизируют изучаемый материал, облегчают возвращение к ранее пройденному материалу и могут быть размещены в форме выводов в конце параграфа или темы.

    Наглядность таблицы во многом определяется компактным расположением материала, облегчающим сопоставление и противопоставление сравниваемых объектов (признаков, фактов, явлений, событий, персоналий, документов, героев, темпераментов, процессов, тем и др.). При этом сопоставляемые элементы таблицы желательно располагать друг под другом (в столбик), противопоставляемые – рядом (по горизонтали).

    Продуманное расположение материала особенно важно при его схематической подаче. Удачная компоновка в таблице учебного материала должна помочь учащимся в восприятии и понимании текста. Эффективность использования таблиц повышается, когда они совмещаются с другими графическими средствами, например, со схемами, рисунками, картинами и т.д.

    При разработке таблицы реально существует опасность ее перегруженности, что, конечно, затрудняет зрительное восприятие материала, снижает ценность таблицы как средства наглядности, а поэтому здесь следует быть осторожным. Компактное размещение материала, лаконичные условные обозначения позволяют разгрузить таблицу.

    При разработке таблиц необходимо соблюдать следующие требования:

    · как можно меньше комментирующих слов в таблице;

    · верхние, нижние и боковые поля должны иметь отступы;

    · цветная палитра цветов не должна приводить к пестроте, так как это будет утомлять глаза;

    · количество выбранных ячеек таблицы должно соответствовать содержанию и характеру выделенного фрагмента текста и т.п.

    Таблицы являются простым, но очень эффективным средством иллюстрации в том или ином месте текста. С помощью таблиц можно выделить, основное в изучаемом фрагменте текста или всей темы, облегчить понимание учебного материала, способствовать запоминанию выделенной мысли, понятия и определения, произвести сравнение разных объектов, систематизировать или обобщить изученное и т.д.

    Различают две группы таблиц: статичные и динамичные (анимационные) таблицы:

    текстовые таблицы;

    числовые таблицы;

    таблицы-рисунки;

    текстовые таблицы-рисунки;

    таблицы-схемы;

    текстовые таблицы-схемы;

    таблицы–рисунки-схемы;

    таблицы-круги;

    таблицы–круги-схемы;

    текстовые таблицы-круги.

    Так, таблицы-круги – особый композиционный вариант таблиц, основным графическим элементом которых служит круг. Важная методическая ценность данной табличной формы состоит в том, что она композиционно облегчает систематизацию материала, зрительное объединение и одновременное его разграничение. Конечно, указанное свойство присуще всем другим видам таблиц.

    Динамичные (или анимационные) таблицы (анимация – реализация эффекта движения объекта) позволяют составлять самые различные варианты статичных таблиц. Основное преимущество динамичных таблиц - подача материала по частям, небольшим порциями, возможность видоизменять содержание таблицы, заменять одни элементы другими. Эти особенности подвижных таблиц и схем могут быть полезны не только при изучении учебного текста, но и на этапе закрепления (тренинга) изученного материала, поскольку облегчают понимание и запоминание его.

    Конечно, от автора потребуется небольшая подготовительная работа, которая заключается в разработке и описании сценария подачи или порций учебной информации, или частей графических иллюстрированных объектов с целью реализации эффекта движения. Компьютерные технологии позволяют реализовать любой прием порционной подачи учебного материала, предложенный автором.

    Рассмотрим другой вид условно-графической иллюстрации – схемы.

    Схема – это графическое изображение материала, где отдельные элементы или свойства явления обозначаются условными знаками (квадратами, кружками), а отношения и связи – взаимным расположением частей и использованием двунаправленных стрелок. Схемы, как и таблицы, бывают разноформатными. Они могут занимать часть экранной страницы, целую страницу или даже несколько экранных страниц электронного учебника (или несколько печатных страниц).

    Располагая мощными компьютерными графическими средствами (при переводе схем в электронный учебник), схемы можно оформить с помощью:

    · разнообразной палитры цветов;

    · рисунков (здесь рисунок как элемент оформления схемы или блок-схемы);

    · разнообразного набора шрифтов;

    · разнообразных средств обрамления схем;

    · установления определенного количества составных частей и связей схем;

    · реализации эффекта движения схем (анимация) и др.

    К условно-графической наглядности относятся не только схемы, но и графики, диаграммы, аппликации, схематические рисунки. Они используются как для выявления существенных признаков, связей и отношений явлений, событий, процессов и т.п., так и для формирования локального образного представления фрагмента текста. При помощи схематического изображения автор раскрывает явления в его логической последовательности, обеспечивает наглядное сравнение двух или более объектов, а также обобщает и систематизирует знания.

    По функциональному признаку схемы делятся на следующие типы:

    · сущностные, отражающие составные части понятий, явлений, процессов и т.п.;

    · логические, устанавливающие логическую последовательность между частями;

    · образные, улучшающие понимание трудных мест в тесте.

    Для создания у пользователя реалистического образа в ряде случаев целесообразно сопоставление схематического изображения с другими видами иллюстраций.

    Разумеется, схема может быть дополнена текстовым материалом, но объем его желательно ограничить, так как существует опасность перегруженности схемы, что затруднит зрительное восприятие материала, снизит ценность схемы.

    Компактное размещение материала, лаконичные условные обозначения позволяют разгрузить схему или блок-схему, привести ее в соответствие с гигиеническими нормами.

    Не только таблицы, но и схемы, блок-схемы позволяют акцентировать внимание учащихся на главном в изучаемом материале, подводят их к осмыслению той или иной закономерности, но не дают готовых выводов, формулировок, а требуют определенной мыслительной активности, самостоятельности, развивают абстрактное мышление учащихся.

    При разработке схем и блок-схем необходимо соблюдать следующие требования:

    · как можно меньше комментирующих слов в схеме;

    · верхние, нижние и боковые поля должны иметь отступы;

    · цветная палитра цветов не должна приводить к пестроте, так как это будет утомлять глаза;

    · количество выбранных составных частей схемы и их связей должно соответствовать содержанию и характеру выделенного фрагмента текста.

    Различают статические и подвижные (анимационные) типы схемы:

    схемы;

    блок-схемы;

    текстовые схемы;

    текстовые блок-схемы;

    схемы-таблицы;

    схемы-рисунки;

    блок-схемы–круги;

    схемы-рисунки–таблицы-круги.

    Необходимо обратить внимание на то, что вопрос о целесообразном использовании схем, блок-схем, таблиц или их комбинации надо решать в каждом конкретном случае отдельно.

    Что собой представляет динамическая иллюстрация (анимация)?

    Электронный учебник не только сохраняет все достоинства печатного учебного материала, но и в полной мере использует современные технологии, мультимедийные возможности, предоставляемые компьютером. К таким возможностям относят, например, и представление статических иллюстраций в динамическое изображение ("оживление" графических и других видов иллюстрации). Процесс реализации эффекта движения иллюстративного объекта называется анимацией.

    Анимация позволяет представить в динамике:

    · процесс "порционной" подачи текстовой информации (эффект "электронного лектора");

    · процесс имитации движения частей иллюстрации;

    · имитацию движения рисунка;

    · имитацию движений исторических сражений;

    · физические и химические процессы;

    · технологические процессы;

    · техническое конструирование;

    · процесс природных явлений;

    · процесс социальных явлений;

    · процесс политических событий и т.д.

    Анимация представляет практически неограниченные возможности по имитации ситуаций и демонстрации движения объектов.

    Для реализации зрительной наглядности с помощью динамичных таблиц, схем и рисунков используют разные приемы. Остановимся только на тех приемах, которые должен знать автор при создании и оформлении эскиза иллюстрации (а не реализации его на компьютере), касаясь в основном методической стороны дела.

    Существует несколько приемов реализации эффекта анимации:

    1. Прием типа "наложение". Суть этого приема заключается в том, что автор, выбрав статичную иллюстрацию, разбивает ее на составные части, а затем описывает последовательность наложения этих частей друг на друга. Так реализуется эффект динамичного изображения и для рисунков. Заметим, что объект не движется в пространстве, но "живет".

    Динамические иллюстрации, полученные по такому принципу, уместно использовать для такого текста, где необходимо проиллюстрировать в компактной и образной форме суть процесса построения какого-то ряда, изложить последовательность происходящего (или происходившего) события, явления, изменение человека и т.д.

    Этот прием успешно применяется для реализации подачи теоретического материала по частям (например, постепенно составить таблицу, а не давать ее сразу заполненной, что особенно важно при объяснении сложного теоретического материала). Такие таблицы очень эффективны на этапе обобщения и систематизации учебного материала в конце темы, раздела и курса в целом.

    Порционную подачу материала можно осуществить и с помощью другого приема – "каширования".

    2. Прием "каширование". Суть этого приема заключается в том, что заполненная текстом таблица сначала закрыта (т.е. замаскирована), а затем происходит постепенное ее раскрытие. Создается иллюзия, что какая-то невидимая "черная бумага", передвигаясь по таблице, как бы раскрывает ее таблицу по частям (объектами могут быть схемы, блок-схемы или просто "порционные" части текста).

    3. Прием "движение в пространстве". Отличие его от приема "наложения" заключается в том, что в этом случае надо описать последовательность шагов, которые "будет совершать" по пространству экрана выбранный объект для иллюстрирования (эффект мультипликации).

    Основу зрительного ряда составляют рисунки, репродукции картин, учебные картины и видеофрагменты. Рисунки и видеофрагменты обеспечивают особый эффект при сочетании красочности и анимации. Иллюстрированный экран концентрирует внимание учащихся на изображении, поскольку ограничивает поле наблюдения.

    В анимационном фрагменте или видеофрагменте кадры взаимосвязаны, расположены в определенной последовательности, относительно самостоятельны и автономны. Кроме того, отдельные кадры лишены подписей, что позволяет комбинировать их, давать в разном сочетании, варьировать методику работы с одним и тем же изображением.

    Возможность выборочного использования фрагментов анимации или видеокадров очень удобна для пояснения теоретических положений учебного материала. Предположим, имеется фрагмент анимации, состоящий из трех рисуночных кадров, иллюстрирующих смысловое содержание какого-нибудь абзаца. В ходе чтения данного абзаца последовательно вызываются на экран три рисуночных кадра. В случае необходимости обучаемый может приостановить на любое время тот или иной анимационный кадр. По ходу изучения теоретического материала обучаемому можно в качестве иллюстрации выдавать из арсенала анимационных кадров или видеоряда проблемные вопросы, сравнительные таблицы, блок-схемы, две фотографии (для сравнения) и т.д.

    Иллюстрации, находящиеся во фрагментах анимации (или в видеофрагментах), могут сопровождаться лаконичным комментарием, то есть таким комментарием, который направляет внимание только на изображение, или без сопроводительного текста. Комментирующий текст должен присутствовать в анимации или видеофрагменте при использовании в качестве иллюстраций, к примеру, репродукций картин.

    Таким образом, анимация представляет практически неограниченные возможности по имитации ситуаций и демонстрации движения объектов. Красочно оформленный иллюстративный учебный материал с элементами анимации и звуковым сопровождением облегчает восприятие изучаемого материала, способствует пониманию и запоминанию его, дает более яркое и емкое представление о предметах, явлениях, ситуациях, стимулирует познавательную активность студентов.

    Понятно, что далеко не все авторы по объективным причинам имеют возможность воспользоваться услугами компьютера для подготовки иллюстраций, да этого и не требуется, так как существуют специалисты по компьютерной графике и анимации. Но, тем не менее, авторы должны приобрести некоторые знания в этой области. Ведь именно они осуществляют подборку иллюстративного материала, определяют перечень статичных и динамичных объектов, предоставляют сценарий (алгоритм) на подвижные иллюстрации.

    При получении от авторов курсов эскизных материалов на статичные и динамичные иллюстрации специалист продолжит дальнейшую их обработку.

    Эскизы-формы на статические условно-графические иллюстрации можно выполнять в любом удобном для преподавателя виде. Выполнение эскиза – это описание и построение небольшой модели (в форме таблицы, схемы, рисунка). А идея любой модели сводится к тому, чтобы выделить, воспроизвести только те свойства и характеристики выбранной иллюстрации, которые необходимы и достаточны для решения поставленной задачи в конкретном месте учебного материала.

    Для динамических иллюстраций-моделей необходимо еще написать небольшой сценарий "движения", т.е. алгоритм его перемещения по экрану. Алгоритм – это предписание, точным образом фиксирующее способ выполнения чего-либо. Требуется строгое определение каждого промежуточного шага к достижению решения. Конечно, алгоритм – менее универсальное средство, чем прием написания сценария. Для описания простых анимационных иллюстраций достаточно и алгоритма. Но при описании сложных динамических объектов необходимо прибегнуть к сценарию. Сценарий, в отличие от алгоритма, описывает не только части графической иллюстрации, но и взаимосвязи между его частями, место расположения учебной информации на экране монитора, указывает цвет, звук, размер символов, шрифт и многое другое.

    Для условно-графических иллюстраций необходимо также иметь в виду следующее:

    1) схемы и блок-схемы:

    · именуются рисунками;

    · должны быть пронумерованы, иметь соответствующее название и подпись под рисунком, например:

    · чтобы привязать рисунок к тексту, на полях печатного учебного материала следует указать его номер (в том месте, где следует поместить рисунок);

    · все рисунки должны быть упомянуты в перечне иллюстраций;

    · для динамичных схем и блок-схем прилагается сценарий с кратким описанием;

    · текстовая информация (слова, словосочетания и предложения) внутри прямоугольников, кружков схем и блок-схем начинается с прописной буквы, а в конце ее знаки препинания не ставятся;

    2) таблицы:

    · именуются таблицами;

    · должны иметь краткий тематический заголовок, который помещается над таблицей, а справа указывается ее порядковый номер, например:

    Таблица 1

    Рост национального дохода

    · заголовок таблицы и ее подзаголовки (названия граф) пишутся с прописной буквы, а слова строк в информационной части таблицы – со строчной в том случае, если они составляют одно предложение с названием графы (подзаголовок). Если же они имеют самостоятельное значение, то пишутся с прописной буквы; заголовки даются в форме единственного числа;

    · в конце заголовков, подзаголовков и строк знаки препинания не ставятся.

    В усвоении учебного материала велика роль чувственного и наглядного отражения, то есть соблюдения дидактического принципа наглядности – предметной, изобразительной и условно-графической. Именно правильная организация восприятия материала во многом обеспечивает его понимание, осмысление, предупреждение возможного последующего зазубривания. Иллюстрации, выраженные в репродукциях, таблицах, схемах, блок-схемах, картосхемах, диаграммах, а также в виде анимации, аудио- и видеоряда и т.д., помогают создавать мысленные образы, способствующие пониманию учебного текста и запоминанию необходимых сведений.

    Учащийся, читая текст и видя обозначаемый в нем предмет, явление в форме иллюстрации, усваивает этот фрагмент текста быстрее и лучше запоминает содержание, ибо оно входит в его сознание, наполненное ассоциированными образами, которые остаются в памяти надолго. В этом и заключается единство мысли, слова и образа.

    Отличие электронного учебника от обычного печатного учебного материала состоит в более строгом дозировании (порции) изучаемого материала. Каждая порция должна снабжаться (где необходимо) хорошо продуманной иллюстрацией, набором вопросов и заданий, на которые заранее подготавливается серия возможных ответов.

    Вопросы для самоконтроля

    1. В чем Вы видите цель разработки электронного учебника?

    2. Перечислите виды наглядности, используемые в учебных электронных изданиях.

    3. Для чего требуется вставлять в текст таблицы, схемы?

    4. Назовите основные требования при разработке таблиц.

    5. Назовите основные требования при разработке схем и блок-схем.

    6. Чем отличаются статичные и динамичные иллюстрации?


Основы дистанционного обучения

"Дома новы, да предрассудки стары."
А.С.Грибоедов

Дистанционное обучение все энергичне распространяется в российской системе образования, основываясь на использовании современных телекоммуникаций, открытых информационных ресурсов и сервисов Internet, определяющиъ совокупный потенциал новых технологий и предельный уровень достижений учащихся. Но инновации такого рода зачастую сохраняют рудименты прошлого, которые могут сводить эффект информатизации к ничтожным результатам, подрывая тем самым саму идею и веру в нее людей. Надо понимать, что дистанционные образовательные технологии - это революционные преобразования, еоторые не оставляют места закостеневшим привычкамм и традициям, от которых настоящим новаторам следует отмежеваться как можно раньше, энергично осваивая и применяя новый арсенал средств...

При дистанционном обучении человек избавляется от мелочной опеки педагогов и других ограничений, и будучи предоставленным самому себе может рационально использовать весь арсенал доступных ему средств и методов для достижения предельно высоких целей, далеко за рамками банальных зачетов и прочих "показателей зрелости". Не пренебрегая помощью вуза, инициативный студент использует также и другие источники для форсированного наращивания своей системы знаний и других заделов, активной пробы сил и расширения жизненного пространства, создания персональной инфраструктуры и реализации бизнес-процессов разного рода. В последние годы становится все больше тех, кто еще в период обучения основал свой бизнес и наладил связи с деловыми партнерами, воплощая знания в благие дела безотлагательно и с высокой отдачей, не дожидаясь получения вожделенных "корочек" и присуждения "высшего статуса".

Особое значение при традиционном обучении имеет практика, когда полученные знания проходят испытания и воплощаются в жизнь, полезные навыки и готовые продукты. К практике, помимо прочего, относятся и лабораторные работы разного рода, широко распространенние в сфере образования и призванные формировать у обучаемых, наряду со Знаниями, также Умения и Навыки(=ЗУН)- важнешие атрибуты всякого специалиста. На создание и оснащение учебных лабораторий, проведение в них занятий и оценку результатов тратятся немалы средства, время и силы, приводя в конечном счете к какому-то эффекту. Однако заорганизованный процесс традиционной практики обычно не оставляет места для творчества и получения оригинальных результатов, делающих честь и славу их авторам. А при дистанционном обучении подобные занятия исключены (по определению) вообще и требуется равноценная компенсация такой потери через трудоустройство туда, где есть все необходимое, или иными приемлемыми для заинтересованных сторон способами.

В наше время каждый в состоянии создать свое "киберпространство" с определенным набором технических и программных средств, позволяющих решать широкий спектр разнообразных задач для личных нужд и в интересах общества. Какие-то сегменты этого пространства могут играть первоначально роль "персональных лабораторий" для проверки и закрепления получаемых в вузе знаний, а также для создания, развития и распространения различных интеллектуальных продуктов (программ,иллюстраций, баз данных и т.п.). Помимо достижения сугубо учебных целей, такие лаборатории могут со временем переводиться в качественно новое состояние, обретая свойства и признаки полноценных средств производства, способствуя бизнесу и росту производительности труда своих создателей.

Виртуальные лаборатории инженерии знаний могут быть успешно исполльзованы в ходе самостоятельной работы студентов, когда требуется систематизация получаемых знаний и их трансформация в нечто осязаемое, пригодное для оценки способностей и достижений авторов. Знания, приобретающие логически завершенную форму и практическое значение, обладают реальной ценностью и средоформирующей силой, становятся важным производственным фактором и условием профессионального успеха выпускника вуза...


Пример моделирования знаний

Куликова О.В.(2006), Геронимус Ю.Л.(2007) В качестве примера здесь приведен пример извлечения и структурирования знаний для базы знаний персональной среды обучения (размещения и наполнения ячеек

1. Определение входных и выходных данных.

I – Книга с данными.

О – Книга с данными с форматированными ячейками.

B – Базовые (исходные) знания для данного этапа обучения:

· владение клавиатурой;

· работа с интерфейсом WINDOWS;

· вызов EXCEL;

· выход из EXCEL;

· главное меню EXCEL;

· панели инструментов EXCEL;

· понятие «горячие клавиши»;

· контекстное меню;

· создание новой книги;

· ввод данных;

· сохранение книги.

2. Составление словаря терминов и наборов ключевых слов.

Рабочий лист | Лист, на котором расположена рабочая таблица ячеек.
Диапазон ячеек | Две или более ячейки. Ячейки диапазона могут быть как смежными, так и не смежными.
Строка | Горизонтальный элемент листа.
Столбец | Вертикальный элемент листа.
Заголовок (строки или столбца) | Идентификатор строки или столбца (числа или буквы соответственно), расположенный по левому краю для строк и по верхнему краю для столбцов.
Ячейка | Единичный элемент рабочего листа. Ячейка образуется пересечением столбца и строки.
Размер ячейки | Высота и ширина ячейки.
Ширина ячейки | Горизонтальный размер ячейки.
Высота ячейки | Вертикальный размер ячейки.
Активная ячейка | Выделенная ячейка, в которую будут вводить данные. Активная ячейка ограничена жирной линией.
Объединенная ячейка | Ячейка, созданная объединением двух и более ячеек. Ссылка на объединенную ячейку должна использовать самую верхнюю, левую ячейку в диапазоне ячеек, использовавшемся для слияния.
Формат ячейки | Выравнивание текста в ячейке, шрифт текста, цвет и т.п.
Формат по умолчанию | Формат, который установлен для ячеек по умолчанию. Текст выровнен по левому краю, числа, даты и время – по правому.
Автоформат | Встроенный набор форматов, например размер шрифта, узоры и выравнивание, которые можно быстро применить к диапазону данных. MS Excel автоматически определяет уровень данных в выделенном диапазоне и соответственно применяет форматирование.
Данные | Вводимый в ячейку какой-либо текст.
Тип данных | Тип введенных в ячейку данных, например число, дата, текст, время и т.п.
Выравнивание | Расположение текста внутри ячейки, например по центру, по левому краю, по правому краю. Выравнивание так же может быть вертикальным.
Ориентация | Ориентация текста в ячейке, наклон текста относительно горихонтальной оси.
Переносить по словам | Отображение нескольких строк текста внутри ячейки
Объединение ячеек | Объединение содержимого выделенных смежных ячеек из одной строки в одну ячейку
Разбиение ячеек | Разбиение объединенных ранее ячеек на несколько ячеек.
Копирование форматов одних ячеек на другие | Перенос параметров выравнивания текста с выбранной ячейки на другие.
Выравнивание текста | Расположение текста внутри ячеек определенным образом.
Вращение текста | Расположение текста под углом к горизонтальной оси.

3. Выявление связей между понятиями. Выявление метапонятий

4. Построение пирамиды знаний.

5. Определение отношений между понятиями. Концептуальная составляющая поля знаний Sk

Цветами указано соответствие между понятиями концептуальной и функциональной составляющими.

6. Функциональная составляющая поля знаний Sf.

Практическое задание

Выполните анализ и структуризацию поля знаний предметной области для Вашего варианта.

Задание должно быть согласовано с преподавателем во время лабораторной работы.


Кафедра UNESCO КемГУ

ВВЕДЕНИЕ

"Краткость - сестра таланта"
Народное

Основное содержание любого издания хорошо воспринимается при надлежащей подготовке к этому потенциальных читателей посредством небольшого вводного раздела, несущего немалую функциональную нагрузку и играющего важную роль в формировании сознания и отношения читателей к обсуждаемому предмету. Здесь же формируются связи данного издания с внешними объектами и обстоятельствами, имеющими какое-то отношение к обсуждаемому предмету. Введение несет и другие функциональные нагрузки, с которыми полезно ознакомиться и разобраться...

По ГОСТ 7.32-2001 "Отчет о НИР" введение должно содержать оценку современного состояния решаемой научно-технической проблемы, основание и исходные данные для разработки темы, обоснование необходимости проведения НИР, сведения о планируемом научно-техническом уровне разработки, о патентных исследованиях и выводы из них, сведения о метрологическом обеспечении НИР. Во введении должны быть показаны актуальность и новизна темы, связь данной работы с другими научно-исследовательскими работами. Во введении промежуточного отчета по этапу НИР должны быть приведены цели и задачи этапа исследований, их место в выполнении НИР в целом. Во введении заключительного отчета о НИР помещают перечень наименований всех подготовленных промежуточных отчетов по этапам и их инвентарные номера.

Понятно, что в рамках лабораторной практики добиться многого не получится, но имитация серьезной НИР здесь уместна и возможна, как и попытка сочинить впечатляющее введение.

5 РЕФЕРАТ

5.1 Структура реферата

5.1.1 Реферат включает следующие аспекты содержания исходного документа:

  • предмет, тему, цель работы;
  • метод или методологию проведения работы;
  • результаты работы;
  • область применения результатов;
  • выводы;
  • дополнительную информацию.

    Оптимальная последовательность аспектов содержания зависит от назначения реферата. Например, для потребителя, заинтересованного в получении новых научных знаний, наиболее удобным является изложение результатов работы и выводов в начале текста реферата.

    5.1.2 Предмет, тема, цель работы указываются в том случае, если они не ясны из заглавия документа.

    5.1.3 Метод или методологию проведения работы целесообразно описывать в том случае, если они отличаются новизной или представляют интерес с точки зрения данной работы. Широко известные методы только называются. В рефератах документов, описывающих экспериментальные работы, указывают источники данных и характер их обработки.

    5.1.4 Результаты работы описывают предельно точно и информативно. Приводятся основные теоретические и экспериментальные результаты, фактические данные, обнаруженные взаимосвязи и закономерности. При этом отдается предпочтение новым результатам и данным долгосрочного значения, важным открытиям, выводам, которые опровергают существующие теории, а также данным, которые по мнению автора документа имеют практическое значение. Следует указать пределы точности и надежности данных, а также степень их обоснования. Уточняют, являются ли цифровые значения первичными или производными, результатом одного наблюдения или повторных испытаний.

    5.1.5 Область применения результатов важно указывать для патентных документов.

    5.1.6 Выводы могут сопровождаться рекомендациями, оценками, предложениями, гипотезами, описанными в исходном документе.

    5.1.7 Дополнительная информация включает данные, не существенные для основной цели исследования, но имеющие значение вне его основной темы. Кроме того, можно указывать название организации, в которой выполнена работа, сведения об авторе исходного документа, ссылки на ранее опубликованные документы и т.п. При наличии в исходном документе серьезных ошибок и противоречий могут даваться примечания автора реферата и редактора.

    5.2 Особенности текста реферата

    5.2.1 Текст реферата не должен содержать интерпретацию содержания документа, критические замечания и точку зрения автора реферата (кроме положений, указанных в 5.1.7), а также информацию, которой нет в исходном документе.

    5.2.2 Текст реферата должен отличаться лаконичностью, четкостью, убедительностью формулировок, отсутствием второстепенной информации.

    5.2.3 Текст реферата начинают фразой, в которой сформулирована главная тема документа. Сведения, содержащиеся в заглавии и библиографическом описании, не должны повторяться в тексте реферата. Следует избегать лишних вводных фраз (например, «автор статьи рассматривает...»). Исторические справки, если они не составляют основное содержание документа, описание ранее опубликованных работ и общеизвестные положения, в реферате не приводятся.

    5.2.4 В тексте реферата следует употреблять синтаксические конструкции, свойственные языку научных и технических документов, избегать сложных грамматических конструкций.

    5.2.5 В тексте реферата следует применять стандартизованную терминологию. В рефератах по общественным наукам допускается использование терминологии исходного документа. Следует избегать употребления малораспространенных терминов или разъяснять их при первом упоминании в тексте. Необходимо соблюдать единство терминологии в пределах реферата.

    5.2.6 В тексте реферата следует применять значимые слова из текста исходного документа для обеспечения автоматизированного поиска.

    5.2.7 Сокращения и условные обозначения, кроме общеупотребительных в научных и технических текстах, применяют в исключительных случаях или дают их определения при первом употреблении.

    5.2.8 Единицы физических величин следует приводить в международной системе СИ по ГОСТ 8.417. Допускается приводить в круглых скобках рядом с величиной в системе СИ значение величины в системе единиц, использованной в исходном документе.

    5.2.9 Имена собственные (фамилии, наименования организаций, изделий и др.) приводят на языке первоисточника. Допускается транскрипция (транслитерация) собственных имен или перевод их на язык реферата с добавлением в скобках при первом упоминании собственного имени в оригинальном написании.

    5.2.10 Географические названия следует приводить в соответствии с последним изданием «Атласа мира». При отсутствии данного географического названия в «Атласе мира» его приводят в той же форме, что и в исходном документе.

    5.2.11 Таблицы, формулы, чертежи, рисунки, схемы, диаграммы включаются только в случае необходимости, если они раскрывают основное содержание документа и позволяют сократить объем реферата. Формулы, приводимые неоднократно, могут иметь порядковую нумерацию, причем нумерация формул в реферате может не совпадать с нумерацией формул в оригинале.

    5.2.12 Объем текста реферата определяется содержанием документа (количеством сведений, их научной ценностью и/или практическим значением), а также доступностью и языком реферируемого документа.

    Рекомендуемый средний объем текста реферата 850 печатных знаков.

    В информационных изданиях по общественным наукам объем реферата не регламентируется.

    В экспресс-информации допускается публикация расширенных рефератов в соответствии с ГОСТ 7.23.

    5.3 Оформление и расположение текста реферата

    5.3.1 Текст реферата может публиковаться вместе с реферируемым документом или входить в состав библиографической записи реферируемого документа.

    5.3.1.1 Библиографическая запись, составной частью которой является текст реферата, включает также:

  • заглавие реферата (в соответствии с 5.3.2);
  • библиографическое описание реферируемого документа (обязательный элемент) в соответствии с ГОСТ 7.1;
  • элементы информационно-поискового языка, используемого для индексирования реферируемого документа в соответствии с ГОСТ 7.59 и ГОСТ 7.66.

    5.3.2 Заглавие реферата обычно совпадает с заглавием реферируемого документа в том случае, когда реферат составляется на языке оригинала. Заглавие реферата отличается от заглавия реферируемого документа в тех случаях, когда:

  • реферат составляют на языке, отличающемся от языка реферируемого документа, тогда заглавие реферата приводят в переводе на язык реферата;
  • реферат составляют на часть документа, тогда реферату присваивают заглавие данной части документа на языке реферата; заглавие документа не отражает содержания документа, тогда реферату присваивают новое заглавие на языке реферата;
  • составляют сводный реферат на несколько документов, тогда реферату присваивают новое заглавие на языке реферата.

    5.3.3 В информационных изданиях текст реферата помещают после библиографического описания исходного документа.

    В сводных рефератах допускается помещать текст реферата между заглавием реферата и библиографическим описанием исходных документов.

    5.3.4 Издательское оформление и расположение рефератов, публикуемых в изданиях, по ГОСТ 7.4 и ГОСТ 7.5.

    5.3.5 Оформление и расположение рефератов на отчеты о НИР - по ГОСТ 7.32.

    6 АННОТАЦИЯ

    6.1 Аннотация включает характеристику основной темы, проблемы объекта, цели работы и ее результаты. В аннотации указывают, что нового несет в себе данный документ в сравнении с другими, родственными по тематике и целевому назначению.

    6.2 Аннотация может включать сведения об авторе первичного документа и достоинствах произведения, взятые из других документов.

    6.3 Аннотация также содержит сообщение об изменениях заглавия документа или авторского коллектива и год выпуска предыдущего издания (при переиздании), год, с которого начат выпуск многотомного издания, указание о принадлежности автора к стране (на документы, переведенные с иностранных языков).

    6.4 Особенности текста аннотации на научно-технические документы в соответствии с 5.2.4 - 5.2.10.

    6.5 В аннотации на произведения художественной литературы должны быть указаны сведения о литературном жанре, период, к которому относится творчество автора, основная тема и проблема произведения, место и время действия описываемых событий. Аннотация на произведения художественной литературы в соответствии с 6.3.

    6.6 Аннотация на периодические и продолжающиеся издания включает данные о задачах, целях, характере издания, об объединении, разделении, возобновлении или прекращении выпуска и других изменениях в издании.

    6.7 Рекомендуемый средний объем аннотации 500 печатных знаков.

    6.8 Оформление аннотации в информационных изданиях в соответствии с 5.3.1.1.

    6.9 Издательское оформление и расположение аннотации, публикуемой в издании, по ГОСТ 7.4 и ГОСТ 7.5.


Основы инженерии знаний

"Я знаю, что ничего не знаю,
а другие не знают и этого."
Сократ

Инженерия знаний предназначена для систематизации и материализации знаний разного рода в экспертных системах и иных интеллектуальных продуктах, получает все более широкое распространение и новые направления. Вполне уместно какие-то достижения этой прикладной науки использовать в сфере образования, где знания являются основным предметом труда и конечным результатом обучения, которые пока что далеки от идеала. Качество образования во многом определяется качеством знаний, используемых для их формирования методов и средств, ресурсов и технологий. Очевидно и другое - кто владеет методами, у того больше шансов на успех, меньше всяческих издердек и проблем...

Инженерия знаний может пониматься и применяться широко, но для студентов и преподавателей она особенно важна при изучении конкретных дисциплин (разделов, тем, курсов), когда необходимо наводить порядок в голове и конспектах.


Лабораторная практика инженерии знаний. Оформления результатов самостоятенльной работы. Электронный гипертекстовый отчет.

Кафедра автоматизации и информационных систем

"Мы все учились понемногу
Чему-нибудь и как-нибудь."
А.С.Пушкин

Дистанционная образовательная технология
Отчет по лабораторной практике
ИНЖЕНЕРИЯ ЗНАНИЙ

Аннотация
Запишись, изучай и радуйся!

Для возврата используйте BackSpace

© Б.Новокрещин

Новокузнецк
2006


Кафедра UNESCO КемГУ

ОСНОВНАЯ ЧАСТЬ ОТЧЕТА

"Какая смесь одежд и лиц,
Имен, наречий, состояний"
А.С.Пушкин

Основнная информационная нагрузка издания ложится, очевидно, на разделы, расу\крывающие суть обсуждаемого предмета. Для отчетов такие разделы могут быть построены единообразно, если описывается множесто сходных объектов и операций. В других случаях требуется большее разнообразие стилей и жанров, больший их синкретизм и необходимость в дополнительных творческих усилиях. Конструирование разделов инженерно-технического произведения может выполняться с привлечением разных методов структуризации и формализации знаний, разных языковых форм и форматов представоения знаний.

По ГОСТ 7.9-95 (ИСО 214-76) реферат и(или) аннотация приводятся практически во всех солидных изданиях, играя определенную роль и вклюяая немалую часть полезной для читателей информации. Задача данной практики заключается в изучении данного стандарта и грамотной подготовке соответсвующих разделов отчета, пуликация его в социальных сетях и иных местах по усмотрению авторов. Более сложной инженерной задачей является разработка шаблонов документов такого типа или удобных прошграмм-генераторов, каталогизаторов и т.п.

5 РЕФЕРАТ

5.1 Структура реферата

5.1.1 Реферат включает следующие аспекты содержания исходного документа:

  • предмет, тему, цель работы;
  • метод или методологию проведения работы;
  • результаты работы;
  • область применения результатов;
  • выводы;
  • дополнительную информацию.

    Оптимальная последовательность аспектов содержания зависит от назначения реферата. Например, для потребителя, заинтересованного в получении новых научных знаний, наиболее удобным является изложение результатов работы и выводов в начале текста реферата.

    5.1.2 Предмет, тема, цель работы указываются в том случае, если они не ясны из заглавия документа.

    5.1.3 Метод или методологию проведения работы целесообразно описывать в том случае, если они отличаются новизной или представляют интерес с точки зрения данной работы. Широко известные методы только называются. В рефератах документов, описывающих экспериментальные работы, указывают источники данных и характер их обработки.

    5.1.4 Результаты работы описывают предельно точно и информативно. Приводятся основные теоретические и экспериментальные результаты, фактические данные, обнаруженные взаимосвязи и закономерности. При этом отдается предпочтение новым результатам и данным долгосрочного значения, важным открытиям, выводам, которые опровергают существующие теории, а также данным, которые по мнению автора документа имеют практическое значение. Следует указать пределы точности и надежности данных, а также степень их обоснования. Уточняют, являются ли цифровые значения первичными или производными, результатом одного наблюдения или повторных испытаний.

    5.1.5 Область применения результатов важно указывать для патентных документов.

    5.1.6 Выводы могут сопровождаться рекомендациями, оценками, предложениями, гипотезами, описанными в исходном документе.

    5.1.7 Дополнительная информация включает данные, не существенные для основной цели исследования, но имеющие значение вне его основной темы. Кроме того, можно указывать название организации, в которой выполнена работа, сведения об авторе исходного документа, ссылки на ранее опубликованные документы и т.п. При наличии в исходном документе серьезных ошибок и противоречий могут даваться примечания автора реферата и редактора.

    5.2 Особенности текста реферата

    5.2.1 Текст реферата не должен содержать интерпретацию содержания документа, критические замечания и точку зрения автора реферата (кроме положений, указанных в 5.1.7), а также информацию, которой нет в исходном документе.

    5.2.2 Текст реферата должен отличаться лаконичностью, четкостью, убедительностью формулировок, отсутствием второстепенной информации.

    5.2.3 Текст реферата начинают фразой, в которой сформулирована главная тема документа. Сведения, содержащиеся в заглавии и библиографическом описании, не должны повторяться в тексте реферата. Следует избегать лишних вводных фраз (например, «автор статьи рассматривает...»). Исторические справки, если они не составляют основное содержание документа, описание ранее опубликованных работ и общеизвестные положения, в реферате не приводятся.

    5.2.4 В тексте реферата следует употреблять синтаксические конструкции, свойственные языку научных и технических документов, избегать сложных грамматических конструкций.

    5.2.5 В тексте реферата следует применять стандартизованную терминологию. В рефератах по общественным наукам допускается использование терминологии исходного документа. Следует избегать употребления малораспространенных терминов или разъяснять их при первом упоминании в тексте. Необходимо соблюдать единство терминологии в пределах реферата.

    5.2.6 В тексте реферата следует применять значимые слова из текста исходного документа для обеспечения автоматизированного поиска.

    5.2.7 Сокращения и условные обозначения, кроме общеупотребительных в научных и технических текстах, применяют в исключительных случаях или дают их определения при первом употреблении.

    5.2.8 Единицы физических величин следует приводить в международной системе СИ по ГОСТ 8.417. Допускается приводить в круглых скобках рядом с величиной в системе СИ значение величины в системе единиц, использованной в исходном документе.

    5.2.9 Имена собственные (фамилии, наименования организаций, изделий и др.) приводят на языке первоисточника. Допускается транскрипция (транслитерация) собственных имен или перевод их на язык реферата с добавлением в скобках при первом упоминании собственного имени в оригинальном написании.

    5.2.10 Географические названия следует приводить в соответствии с последним изданием «Атласа мира». При отсутствии данного географического названия в «Атласе мира» его приводят в той же форме, что и в исходном документе.

    5.2.11 Таблицы, формулы, чертежи, рисунки, схемы, диаграммы включаются только в случае необходимости, если они раскрывают основное содержание документа и позволяют сократить объем реферата. Формулы, приводимые неоднократно, могут иметь порядковую нумерацию, причем нумерация формул в реферате может не совпадать с нумерацией формул в оригинале.

    5.2.12 Объем текста реферата определяется содержанием документа (количеством сведений, их научной ценностью и/или практическим значением), а также доступностью и языком реферируемого документа.

    Рекомендуемый средний объем текста реферата 850 печатных знаков.

    В информационных изданиях по общественным наукам объем реферата не регламентируется.

    В экспресс-информации допускается публикация расширенных рефератов в соответствии с ГОСТ 7.23.

    5.3 Оформление и расположение текста реферата

    5.3.1 Текст реферата может публиковаться вместе с реферируемым документом или входить в состав библиографической записи реферируемого документа.

    5.3.1.1 Библиографическая запись, составной частью которой является текст реферата, включает также:

  • заглавие реферата (в соответствии с 5.3.2);
  • библиографическое описание реферируемого документа (обязательный элемент) в соответствии с ГОСТ 7.1;
  • элементы информационно-поискового языка, используемого для индексирования реферируемого документа в соответствии с ГОСТ 7.59 и ГОСТ 7.66.

    5.3.2 Заглавие реферата обычно совпадает с заглавием реферируемого документа в том случае, когда реферат составляется на языке оригинала. Заглавие реферата отличается от заглавия реферируемого документа в тех случаях, когда:

  • реферат составляют на языке, отличающемся от языка реферируемого документа, тогда заглавие реферата приводят в переводе на язык реферата;
  • реферат составляют на часть документа, тогда реферату присваивают заглавие данной части документа на языке реферата; заглавие документа не отражает содержания документа, тогда реферату присваивают новое заглавие на языке реферата;
  • составляют сводный реферат на несколько документов, тогда реферату присваивают новое заглавие на языке реферата.

    5.3.3 В информационных изданиях текст реферата помещают после библиографического описания исходного документа.

    В сводных рефератах допускается помещать текст реферата между заглавием реферата и библиографическим описанием исходных документов.

    5.3.4 Издательское оформление и расположение рефератов, публикуемых в изданиях, по ГОСТ 7.4 и ГОСТ 7.5.

    5.3.5 Оформление и расположение рефератов на отчеты о НИР - по ГОСТ 7.32.

    6 АННОТАЦИЯ

    6.1 Аннотация включает характеристику основной темы, проблемы объекта, цели работы и ее результаты. В аннотации указывают, что нового несет в себе данный документ в сравнении с другими, родственными по тематике и целевому назначению.

    6.2 Аннотация может включать сведения об авторе первичного документа и достоинствах произведения, взятые из других документов.

    6.3 Аннотация также содержит сообщение об изменениях заглавия документа или авторского коллектива и год выпуска предыдущего издания (при переиздании), год, с которого начат выпуск многотомного издания, указание о принадлежности автора к стране (на документы, переведенные с иностранных языков).

    6.4 Особенности текста аннотации на научно-технические документы в соответствии с 5.2.4 - 5.2.10.

    6.5 В аннотации на произведения художественной литературы должны быть указаны сведения о литературном жанре, период, к которому относится творчество автора, основная тема и проблема произведения, место и время действия описываемых событий. Аннотация на произведения художественной литературы в соответствии с 6.3.

    6.6 Аннотация на периодические и продолжающиеся издания включает данные о задачах, целях, характере издания, об объединении, разделении, возобновлении или прекращении выпуска и других изменениях в издании.

    6.7 Рекомендуемый средний объем аннотации 500 печатных знаков.

    6.8 Оформление аннотации в информационных изданиях в соответствии с 5.3.1.1.

    6.9 Издательское оформление и расположение аннотации, публикуемой в издании, по ГОСТ 7.4 и ГОСТ 7.5.


Что такое лабораторная работа и как к ней готовиться?

www.pandia.ru

Лабораторные занятия в высшей школе предназначены для углубленного изучения теоретических вопросов изучаемой дисциплины и овладения современными экспериментальными методами науки, умением решать практические задачи путем постановки опыта. Эксперимент в высшей школе отличается от такового в средней школе значительным сближением методов обучения с методами изучаемой науки, и чаще всего носит комплексный проблемный характер. Но, как и в школе, предполагает усвоение нового знания через этап материального действия.

Лабораторные занятия проводятся в специально оборудованных лабораториях. В отличие от практических, они проводятся преподавателем в подгруппах. Эксперимент также предполагает работу небольшими группами (2-3 человека).

Основная роль лабораторного практикума в высшей школе заключается в развитии у студентов научного мышления, в формировании умений интеллектуального проникновения в сущность изучаемых явлений, в приобщении к научному поиску. Поэтому важнейшим элементом лабораторного практикума является ведение рабочей тетради (рабочего журнала) и составление отчета по выполненной работе. Несмотря на коллективный характер выполнения лабораторной работы, ведение рабочей тетради и составление отчета по лабораторной работе должно проходить строго индивидуально.

Методических пособия к лабораторному практикуму содержат краткие теоретические сведения, методику эксперимента, варианты контрольных задач для самостоятельного решения, справочные данные, литературу, требования к составлению отчета.

Организация работы по самостоятельной подготовке студентов к лабораторным занятиям

Кафедрой (лектором по дисциплине) в соответствии с рабочей учебной программой дисциплины доводятся до студентов: перечень лабораторных работ, последовательность их выполнения, рекомендуемые учебно-методические пособия, руководства и другая информация, необходимая для подготовки к практическому выполнению предусмотренных программой дисциплины лабораторных работ.

При подготовке к лабораторным работам студент использует рекомендованные учебники и учебные пособия, руководства по выполнению лабораторных работ, инструкции по пользованию измерительной аппаратурой, а также специальные указания по особенностям выполнения отдельных пунктов лабораторных работ.

Подготовка к лабораторным работам осуществляется студентами самостоятельно заблаговременно.

В процессе такой подготовки студент должен усвоить теоретический материал, относящийся к данной лабораторной работе, изучить и ясно представить себе содержание и порядок выполнения лабораторной работы, знать принципы действия и правила работы с измерительными приборами, методы измерений, особенности конструкции лабораторной установки и правила техники безопасности, знать ответы на приведенные в методическом руководстве контрольные вопросы, а также выполнить необходимый по заданию объем предварительных расчетов, заготовить необходимые таблицы и рисунки.

Студент, не выполнивший домашнее задание, к выполнению лабораторной работы не допускается.

Выполнение лабораторных работ

В начале первого занятия подгруппы в лаборатории преподаватель знакомит студентов с лабораторными установками, измерительной аппаратурой, правилами поведения в лаборатории и правилами техники безопасности. Во время этого занятия преподаватель организует из студентов бригады по 2-3 человека в каждой, если это необходимо для рационального использования лабораторного оборудования, знакомит с последовательностью выполнения лабораторных работ, правилами оформления отчета по работе, оформляет журнал проведения лабораторных работ, инструктирует студентов по правилам техники безопасности при работе в данной лаборатории и оформляет журнал по технике безопасности, где должна быть подпись студента о прохождении инструктажа.

В случае, если график лекционного курса отстает от графика выполнения лабораторных работ, в результате чего теоретические разделы, относящиеся к лабораторным работам оказываются к этому времени еще не рассмотренными на лекциях, преподаватель разъясняет всей группе наиболее важные теоретические вопросы. Допускается выдача студентам домашнего задания и его проверка, с целью организации подготовительных работ, связанных с выполняемой лабораторной работой.

Фронтальные занятия используются также для индивидуального или группового контроля готовности студентов к выполнению ближайшей по времени лабораторной работы и для защиты ранее выполненной работы. Контроль проводится в устной, письменной форме или с использованием соответствующей программы на ПЭВМ. По его итогам принимается решение о допуске или не допуске каждого студента к выполнению лабораторной работы.

Неготовность студента, и как следствие не допуск к выполнению лабораторной работы, рассматривается как нарушение им графика учебного процесса и учитывается при ежемесячной аттестации по показателям текущей успеваемости.

В процессе выполнения лабораторных работ студент должен:

Строго соблюдать порядок проведения практической части лабораторной работы, описанный в методических указаниях к ней.

Вести необходимые рабочие записи, которые по окончанию работы предъявляются преподавателю.

После выполнения лабораторных работ студенты предъявляют преподавателю результаты выполнения задания. По выполнению лабораторной работы оформляется отчет.

Оформление отчета и защита лабораторных работ

Требования к оформлению отчета изложены в методических пособиях к лабораторному практикуму.

Отчет по выполненной работе оформляется самостоятельно и индивидуально во внеаудиторное учебное время. К отчету предъявляются требования, максимально приближенные к требованиям оформления научной статьи.

В отчете по каждому пункту должны быть даны: анализ, сравнения полученных результатов с теоретическими положениями, конкретные выводы.

Чтобы выполнение опытов не сводилось только к техническим приемам работы, а могло быть представлено как самостоятельное исследование студента, помимо постановки задачи эксперимента, ее теоретического обоснования и экспериментальной проверки, необходимо грамотное построение письменного сообщения на задание эксперимента. Дополнительные вопросы в конце каждого опыта призваны помочь студентам освоить методологию анализа результатов работы при оформлении отчета. Ответы на них обязательны. Оформление отчета — важный этап в формировании у студентов научного типа мышления.

Соответствующие типовые формы, а также конкретизация требований по структуре и оформлению отчетов, если таковые необходимы, разрабатываются кафедрой.

Отчёт о проделанной лабораторной работе должен быть представлен к сдаче на следующем занятии и является необходимым, но не единственным условием защиты темы данной лабораторной работы.

Защита лабораторных работ производится по каждой работе в отдельности в виде индивидуального собеседования с каждым студентом по теоретической и практической частям выполненной работы, а также по данным и результатам оформленного отчета. Ответы на поставленные вопросы студент дает в устной или письменной форме.

Ликвидация задолженностей по лабораторным работам

Студент обязан ликвидировать задолженность по выполнению и защите предусмотренных учебной программой лабораторных работ до начала сессии.

Отработка пропущенных лабораторных занятий может проводиться в составе другой подгруппы или группы на основании заявления студента по согласованию с преподавателем, заведующим кафедрой и деканатом.

Студент, не защитивший две лабораторные работы, не допускается к выполнению очередной работы до ликвидации задолженности хотя бы по одной из них.

Студенты, не ликвидировавшие задолженности по лабораторным работам, не допускаются к экзаменационной сессии деканом факультета на основе представления кафедры, которая обеспечивает дисциплину, в виде докладной записки на имя декана факультета на момент начала экзаменационной сессии.


Кафедра UNESCO КемГУ

Метаописание основной части отчета

"Краткость - сестра таланта"
Народное

Для быстрого ознакомления потенциальных читателей издания с основным его содержанием а практике обычно используются назвапния и оглавления, аннотации и рефераты, а также другие виды и формы метаинформации. Для авторов составление таких разделов полезно как способ систематизации своих знаний и поиска лаконичных и информативных формулировок. Такие документы могут быть исполдьзованы в наше время также для оповещения через Internet широкой целевой аудитории о подготовке соответсвующего издания и для иных целей...

По ГОСТ 7.9-95 (ИСО 214-76) реферат и(или) аннотация приводятся практически во всех солидных изданиях, играя определенную роль и вклюяая немалую часть полезной для читателей информации. Задача данной практики заключается в изучении данного стандарта и грамотной подготовке соответсвующих разделов отчета, пуликация его в социальных сетях и иных местах по усмотрению авторов. Более сложной инженерной задачей является разработка шаблонов документов такого типа или удобных прошграмм-генераторов, каталогизаторов и т.п.

5 РЕФЕРАТ

5.1 Структура реферата

5.1.1 Реферат включает следующие аспекты содержания исходного документа:

  • предмет, тему, цель работы;
  • метод или методологию проведения работы;
  • результаты работы;
  • область применения результатов;
  • выводы;
  • дополнительную информацию.

    Оптимальная последовательность аспектов содержания зависит от назначения реферата. Например, для потребителя, заинтересованного в получении новых научных знаний, наиболее удобным является изложение результатов работы и выводов в начале текста реферата.

    5.1.2 Предмет, тема, цель работы указываются в том случае, если они не ясны из заглавия документа.

    5.1.3 Метод или методологию проведения работы целесообразно описывать в том случае, если они отличаются новизной или представляют интерес с точки зрения данной работы. Широко известные методы только называются. В рефератах документов, описывающих экспериментальные работы, указывают источники данных и характер их обработки.

    5.1.4 Результаты работы описывают предельно точно и информативно. Приводятся основные теоретические и экспериментальные результаты, фактические данные, обнаруженные взаимосвязи и закономерности. При этом отдается предпочтение новым результатам и данным долгосрочного значения, важным открытиям, выводам, которые опровергают существующие теории, а также данным, которые по мнению автора документа имеют практическое значение. Следует указать пределы точности и надежности данных, а также степень их обоснования. Уточняют, являются ли цифровые значения первичными или производными, результатом одного наблюдения или повторных испытаний.

    5.1.5 Область применения результатов важно указывать для патентных документов.

    5.1.6 Выводы могут сопровождаться рекомендациями, оценками, предложениями, гипотезами, описанными в исходном документе.

    5.1.7 Дополнительная информация включает данные, не существенные для основной цели исследования, но имеющие значение вне его основной темы. Кроме того, можно указывать название организации, в которой выполнена работа, сведения об авторе исходного документа, ссылки на ранее опубликованные документы и т.п. При наличии в исходном документе серьезных ошибок и противоречий могут даваться примечания автора реферата и редактора.

    5.2 Особенности текста реферата

    5.2.1 Текст реферата не должен содержать интерпретацию содержания документа, критические замечания и точку зрения автора реферата (кроме положений, указанных в 5.1.7), а также информацию, которой нет в исходном документе.

    5.2.2 Текст реферата должен отличаться лаконичностью, четкостью, убедительностью формулировок, отсутствием второстепенной информации.

    5.2.3 Текст реферата начинают фразой, в которой сформулирована главная тема документа. Сведения, содержащиеся в заглавии и библиографическом описании, не должны повторяться в тексте реферата. Следует избегать лишних вводных фраз (например, «автор статьи рассматривает...»). Исторические справки, если они не составляют основное содержание документа, описание ранее опубликованных работ и общеизвестные положения, в реферате не приводятся.

    5.2.4 В тексте реферата следует употреблять синтаксические конструкции, свойственные языку научных и технических документов, избегать сложных грамматических конструкций.

    5.2.5 В тексте реферата следует применять стандартизованную терминологию. В рефератах по общественным наукам допускается использование терминологии исходного документа. Следует избегать употребления малораспространенных терминов или разъяснять их при первом упоминании в тексте. Необходимо соблюдать единство терминологии в пределах реферата.

    5.2.6 В тексте реферата следует применять значимые слова из текста исходного документа для обеспечения автоматизированного поиска.

    5.2.7 Сокращения и условные обозначения, кроме общеупотребительных в научных и технических текстах, применяют в исключительных случаях или дают их определения при первом употреблении.

    5.2.8 Единицы физических величин следует приводить в международной системе СИ по ГОСТ 8.417. Допускается приводить в круглых скобках рядом с величиной в системе СИ значение величины в системе единиц, использованной в исходном документе.

    5.2.9 Имена собственные (фамилии, наименования организаций, изделий и др.) приводят на языке первоисточника. Допускается транскрипция (транслитерация) собственных имен или перевод их на язык реферата с добавлением в скобках при первом упоминании собственного имени в оригинальном написании.

    5.2.10 Географические названия следует приводить в соответствии с последним изданием «Атласа мира». При отсутствии данного географического названия в «Атласе мира» его приводят в той же форме, что и в исходном документе.

    5.2.11 Таблицы, формулы, чертежи, рисунки, схемы, диаграммы включаются только в случае необходимости, если они раскрывают основное содержание документа и позволяют сократить объем реферата. Формулы, приводимые неоднократно, могут иметь порядковую нумерацию, причем нумерация формул в реферате может не совпадать с нумерацией формул в оригинале.

    5.2.12 Объем текста реферата определяется содержанием документа (количеством сведений, их научной ценностью и/или практическим значением), а также доступностью и языком реферируемого документа.

    Рекомендуемый средний объем текста реферата 850 печатных знаков.

    В информационных изданиях по общественным наукам объем реферата не регламентируется.

    В экспресс-информации допускается публикация расширенных рефератов в соответствии с ГОСТ 7.23.

    5.3 Оформление и расположение текста реферата

    5.3.1 Текст реферата может публиковаться вместе с реферируемым документом или входить в состав библиографической записи реферируемого документа.

    5.3.1.1 Библиографическая запись, составной частью которой является текст реферата, включает также:

  • заглавие реферата (в соответствии с 5.3.2);
  • библиографическое описание реферируемого документа (обязательный элемент) в соответствии с ГОСТ 7.1;
  • элементы информационно-поискового языка, используемого для индексирования реферируемого документа в соответствии с ГОСТ 7.59 и ГОСТ 7.66.

    5.3.2 Заглавие реферата обычно совпадает с заглавием реферируемого документа в том случае, когда реферат составляется на языке оригинала. Заглавие реферата отличается от заглавия реферируемого документа в тех случаях, когда:

  • реферат составляют на языке, отличающемся от языка реферируемого документа, тогда заглавие реферата приводят в переводе на язык реферата;
  • реферат составляют на часть документа, тогда реферату присваивают заглавие данной части документа на языке реферата; заглавие документа не отражает содержания документа, тогда реферату присваивают новое заглавие на языке реферата;
  • составляют сводный реферат на несколько документов, тогда реферату присваивают новое заглавие на языке реферата.

    5.3.3 В информационных изданиях текст реферата помещают после библиографического описания исходного документа.

    В сводных рефератах допускается помещать текст реферата между заглавием реферата и библиографическим описанием исходных документов.

    5.3.4 Издательское оформление и расположение рефератов, публикуемых в изданиях, по ГОСТ 7.4 и ГОСТ 7.5.

    5.3.5 Оформление и расположение рефератов на отчеты о НИР - по ГОСТ 7.32.

    6 АННОТАЦИЯ

    6.1 Аннотация включает характеристику основной темы, проблемы объекта, цели работы и ее результаты. В аннотации указывают, что нового несет в себе данный документ в сравнении с другими, родственными по тематике и целевому назначению.

    6.2 Аннотация может включать сведения об авторе первичного документа и достоинствах произведения, взятые из других документов.

    6.3 Аннотация также содержит сообщение об изменениях заглавия документа или авторского коллектива и год выпуска предыдущего издания (при переиздании), год, с которого начат выпуск многотомного издания, указание о принадлежности автора к стране (на документы, переведенные с иностранных языков).

    6.4 Особенности текста аннотации на научно-технические документы в соответствии с 5.2.4 - 5.2.10.

    6.5 В аннотации на произведения художественной литературы должны быть указаны сведения о литературном жанре, период, к которому относится творчество автора, основная тема и проблема произведения, место и время действия описываемых событий. Аннотация на произведения художественной литературы в соответствии с 6.3.

    6.6 Аннотация на периодические и продолжающиеся издания включает данные о задачах, целях, характере издания, об объединении, разделении, возобновлении или прекращении выпуска и других изменениях в издании.

    6.7 Рекомендуемый средний объем аннотации 500 печатных знаков.

    6.8 Оформление аннотации в информационных изданиях в соответствии с 5.3.1.1.

    6.9 Издательское оформление и расположение аннотации, публикуемой в издании, по ГОСТ 7.4 и ГОСТ 7.5.


Методы извлечения и структурирования знаний

По книгам Гавриловой Т.А., Хорошевского В.Ф. Базы знаний интеллектуальных систем.: Питер», 2001. и
Частикова А.П., Гавриловой Т.А., Белова Д.Л. Разработка экспертных систем. Среда CLIPS.-СПб.: БХВ – Петербург, 2003.

Семиотический подход к представлению знаний

Язык описания поля знаний

Инженерия знания — достаточно молодое направление искусственного интеллекта, появившееся тогда, когда практические разработчики столкнулись с весьма нетривиальными проблемами трудности «добычи» и формализации знаний.

Данный раздел посвящен проектированию баз знаний — получению и структурированию знаний специалистов для последующей разработки баз знаний. Центральным понятием на стадиях получения и структурирования является так называемое поле знаний.

Поле знаний — это условное неформальное описание основных понятий и взаимосвязей между понятиями предметной области, выявленных из системы знаний эксперта, в виде графа, диаграммы, таблицы или текста.

Поле знаний, как первый шаг к формализации, представляет модель знаний о предметной области, в том виде, в каком ее сумел выразить аналитик на некотором «своем» языке. Что это за язык? Известно, что словарь языка конкретной науки формируется путем пополнения общеупотребительного языка специальными терминами и знаками, которые либо заимствуются из повседневного языка, либо изобретаются. Назовем этот язык L и рассмотрим его желаемые свойства, учитывая, что стандарта этого языка пока не существует, а каждый инженер по знаниям вынужден сам его изобретать.

Во-первых, как и в языке любой науки, в нем должно быть как можно меньше неточностей, присущих обыденным языкам. Частично точность достигается более строгим определением понятий. Идеалом точности, конечно, является язык математики. Язык L, видимо, занимает промежуточное положение между естественным языком и языком математики.

Во-вторых, желательно не использовать в нем терминов иных наук в другом, то есть новом, смысле. Это вызывает недоразумения.

В-третьих, язык L, видимо, будет либо символьным языком, либо языком графическим (схемы, рисунки, пиктограммы).

Представители естественных наук еще не до конца осознали достоинства семиотики только из-за того, что имеют дело с достаточно простыми и «жесткими» предметными областями. Им хватает аппарата традиционной математики. В инженерии знаний, однако, мы имеем дело с «мягкими» предметными областями, где явно не хватает выразительной адекватности классического математического аппарата и где большое значение имеет эффективность нотации (ее компактность, простота модификации, ясность интерпретации, наглядность и т. д.).

Языки семиотического моделирования как естественное развитие языков ситуационного управления являются первым приближением к языку инженерии знаний. Именно изменчивость и условность знаков делают семиотическую модель применимой к сложным сферам реальной человеческой деятельности. Поэтому главное на стадии концептуализации — сохранение естественной структуры поля знаний, а не выразительные возможности языка.

Традиционно семиотика включает (рис. 1.):

  • синтаксис (совокупность правил построения языка или отношения между знаками);
  • семантику (связь между элементами языка и их значениями или отношения между знаками и реальностью);
  • прагматику (отношения между знаками и их пользователями).

    Рис. 1. Структура семиотики

    Модель поля знаний

    Поле знаний Pz является некоторой семиотической моделью, которая может быть представлена как граф, рисунок, таблица, диаграмма, формула или текст в зависимости от вкуса инженера по знаниям и особенностей предметной области.

    Особенности предметной области могут оказать существенное влияние на форму и содержание компонентов структуры .

    Рассмотрим соответствующие компоненты Pz (рис. 2.).

    Рис. 2.Структура поля знаний

    Синтаксис. Обобщенно синтаксическую структуру поля знаний можно представить как

    П = ( I,О, М),

    где I — структура исходных данных, подлежащих обработке и интерпретации в экспертной системе;

    О — структура выходных данных, то есть результата работы системы;

    М — операциональная модель предметной области, на основании которой происходит модификация I в О.

    Включение компонентов I и О в Р обусловлено тем, что составляющие и структура этих интерфейсных компонентов имплицитно (то есть неявно) присутствуют в модели репрезентации в памяти эксперта. Операциональная модель М может быть представлена как совокупность концептуальной структуры Sk, отражающей понятийную структуру предметной области, и функциональной структуры Sf, моделирующей схему рассуждений эксперта:

    Sk выступает как статическая, неизменная составляющая Р, в то время как Sf представляет динамическую, изменяемую составляющую. Формирование Sk основано на выявлении понятийной структуры предметной области. Структура Sf включает понятия предметной области А, и моделирует основные функциональные связи RA или отношения между понятиями, образующими Sk. Эти связи отражают модель или стратегию принятия решения в выбранной ПО. Таким образом, Sf образует стратегическую составляющую М.

    Семантика, придающая определенное значение предложениям любого формального языка, определяется на некоторой области. Фактически это набор правил интерпретации предложений и формул языка. Семантика L должна быть композиционной, то есть значение предложения определяется как функция значений его составляющих.

    Семантика языка L зависит от особенностей предметной области, она обладает свойством полиморфизма, то есть одни и те же операторы языка в разных задачах могут иметь свои особенности.

    Семантику поля знаний Pz можно рассматривать на двух уровнях. На первом уровне PiZg есть семантическая модель знаний эксперта i о некоторой предметной области Og. На втором уровне любое поле знаний Pz является моделью некоторых знаний, и, следовательно, можно говорить о смысле его как некоторого зеркала действительности. Рассматривать первый уровень в отрыве от конкретной области нецелесообразно, поэтому остановимся подробнее на втором.

    Схему, отображающую отношения между реальной действительностью и полем знаний, можно представить так, как показано на рис.3.

    Рис.3. «Испорченный телефон» при формировании поля знаний

    Как следует из рисунка, поле PijZg — это результат, полученный «после 4-й трансляции» (если говорить на языке информатики).

    • 1-я трансляция (Ii) — это восприятие и интерпретация действительности О предметной области gi-м экспертом. В результате Ii в памяти эксперта образуется модель Mgi, как семантическая репрезентация действительности и его личного опыта по работе с ней.

    • 2-я трансляция (Vi) — это вербализация опыта i-ro эксперта, когда он пытается объяснить свои рассуждения Si и передать свои знания Zi инженеру по знаниям. В результате Vt образуется либо текст Ti либо речевое сообщение Сi,.

    • 3-я трансляция (Ij) — это восприятие и интерпретация сообщений Ti или Сi j-м инженером по знаниям. В результате в памяти инженера по знаниям образуется модель мира Mgi.

    • 4-я трансляция (Kj) — это кодирование и вербализация модели Mgi в форме поля знаний PijZg

    Перед инженером по знаниям стоит труднейшая задача — добиться максимального соответствия Mgi и PijZg.

    В качестве прагматической составляющей семиотической модели следует рассматривать технологии проведения структурного анализа ПО, пользуясь которым инженер по знаниям может сформировать Pz по результатам стадии извлечения знаний.

    Таким образом, под прагматикой будем понимать практические аспекты разработки и использования поля, то есть как от хаоса черновиков и стенограмм сеансов извлечения знаний перейти к стройной или хотя бы ясной модели.

    Однако поле знаний, несмотря на все старания инженера по знаниям и эксперта, всегда будут лишь бледным отпечатком реально существующей предметной области, ведь окружающий нас мир так изменчив, сложен и многообразен, а то, что хранится в нашем сознании, так плохо поддается вербализации. Тем не менее, с точки зрения научной методологии без продуманного, четкого, и красивого поля знаний не может идти и речи о создании базы знаний образовательного ресурса.

    «Пирамида» знаний

    Иерархичность понятийной структуры сознания подчеркивается в работах многих психологов. Поле знаний можно рассматривать на различных уровнях абстракции понятий. В «пирамиде знаний» каждый следующий уровень служит для восхождения на новую ступень обобщения и углубления знаний в предметной области. Таким образом, возможно наличие нескольких уровней понятийной структуры Sk

    Естественно, что и стратегии принятия решений, то есть функциональные структуры Sf , на различных уровнях будут существенно отличаться.

    Анализ методов структурирования знаний

    Методы извлечения знаний, рассмотренные выше, являются непосредственной подготовкой к структурированию знаний. Рассмотрим практические методы структурирования знаний.

    Простые методы структурирования знаний

    В качестве простейшего прагматического подхода к формированию поля знаний начинающему инженеру по знаниям можно предложить следующий алгоритм.

    Определение входных {X} и выходных {Y} данных. Этот шаг совершенно необходим, так как он определяет направление движения в поле знаний — от X к Y. Кроме того, структура входных и выходных данных существенно влияет на форму и содержание поля знаний. На этом шаге определение может быть достаточно размытым, в дальнейшем оно будет уточняться.

    Составление словаря терминов и наборов ключевых слов N. На этом шаге проводится текстуальный анализ всех протоколов сеансов извлечения знаний и выписываются все значимые слова, обозначающие понятия, явления, процессы, предметы, действия, признаки и т. п. При этом следует попытаться разобраться в значении терминов. Важен осмысленный словарь.

    Выявление объектов и понятий {А}. Производится «просеивание» словаря N и выбор значимых для принятия решения понятий и их признаков. В идеале на этом шаге образуется полный систематический набор терминов из какой-либо области знаний.

    Выявление связей между понятиями. Все в мире связано. Но определить, как направлены связи, что ближе, а что дальше, необходимо на этом этапе. Таким образом, строится сеть ассоциаций, где связи только намечены, но пока не поименованы. Например, понятия «день», «ночь», «утро» и «вечер» явно как-то связаны, связаны также и понятия «красный флаг» и «красный галстук», но характер связи тут существенно отличен.

    Выявление метапонятий и детализации понятий. Связи, полученные на предыдущем шаге, позволяют инженеру по знаниям структурировать понятия и как выявлять понятия более высокого уровня обобщения (метапонятия), так и детализировать на более низком уровне.

    Построение пирамиды знаний. Под пирамидой знаний мы понимаем иерархическую лестницу понятий, подъем по которой означает углубление понимания и повышения уровня абстракции (обобщенности) понятий. Количество уровней в пирамиде зависит от особенностей предметной области, профессионализма экспертов и инженеров по знаниям.

    Определение отношений {RA}. Отношения между понятиями выявляются как внутри каждого из уровней пирамиды, так и между уровнями. Фактически на этом шаге даются имена тем связям, которые обнаруживаются на шагах 4 и 5, а также обозначаются причинно-следственные, лингвистические и другие виды отношений.

    Определение стратегий принятия решений (Sf). Определение стратегий принятия решения, то есть выявление цепочек рассуждений, связывает все сформированные ранее понятия и отношения в динамическую систему поля знаний. Именно стратегии придают активность знаниям, именно они «перетряхивают» модель М в поиске от X к Y.

    Однако на практике при использовании данного алгоритма можно столкнуться с непредвиденными трудностями, связанными с ошибками на стадии извлечения знаний и с особенностями знаний различных предметных областей. Тогда возможно привлечение других, более «прицельных» методов структурирования. При этом на разных этапах схемы (рис.4.) возможно использование различных методик.

    Рис.4. Стадии структурирования знаний

    Сложные методы структурирования знаний

    Используя представленный на рис.4. алгоритм, инженер по знаниям может испытывать необходимость в применении специальных методов структурирования на разных шагах алгоритма. При этом, естественно, для таких простых и очевидных шагов, как определение входных и выходных понятий или составление словаря, никаких искусственных методов предлагаться не будет.

    Методы выявления объектов, понятий и их атрибутов.

    Понятие или концепт — это обобщение предметов некоторого класса по их специфическим признакам. Обобщенность является сквозной характеристикой всех когнитивных психических структур, начиная с простейших сенсорных образов.

    Так, понятие «автомобиль» объединяет множество различных предметов, но все они имеют четыре колеса, двигатель и массу других деталей, позволяющих перевозить на них грузы и людей. Существует ряд методов выявления понятий предметной области в общем словаре терминов, который составлен на основании сеансов извлечения знаний. При этом важно выявление не только самих понятий, но и их признаков.

    На этом этапе определяются также интенсионалы и экстенсионалы понятий предметной области. Интенсионал очерчивает понятие через взаимосвязь значимых признаков, а экстенсионал — через перечисление конкретных экземпляров объекта.

    Если задача выделения реальных объектов А связана только с наблюдательностью и лингвистическими способностями эксперта и инженера по знаниям, то определение метапонятий В требует от них умения проводить операции обобщения и классификации, которые никогда не считались тривиальными.

    Поспелов Д. А. предложил ряд подходов к созданию основ теории обобщения и классификации применительно к ситуационному управлению и искусственному интеллекту в целом, а также выделил ряд особенностей задач формирования понятий. Среди них особое место занимает выявление прагматически значимых признаков для формирования понятий, способствующих решению задачи.

    Сложность заключается в том, что для многих понятий практически невозможно однозначно определить их признаки, это связано с различными формами репрезентации понятий в памяти человека.

    Все методы выявления понятий мы разделили на:

    • традиционные, основанные на математическом аппарате распознавания образов и классификации;

    • нетрадиционные, основанные на методологии инженерии знаний. Если первые достаточно хорошо освещены в литературе, то вторые пока менее известны.

    Методы выявления связей между понятиями.

    Концепты не существуют независимо, они включены в общую понятийную структуру с помощью отношений. Выявление связей между понятиями при разработке баз знаний доставляет инженеру по знаниям немало проблем. То, что знания в памяти — это некоторые связные структуры, а не отдельные фрагменты, общеизвестно и очевидно. Тем не менее основной упор в существующих моделях представления знаний делается на понятия, а связи вводят весьма примитивные (в основном причинно-следственные).

    В последних работах по теории искусственного интеллекта все больше внимания уделяется взаимосвязанности структур знаний. Введено понятие сценария как некоторой структуры представления знаний. Основу сценария составляет КОП (концептуальная организация памяти) и мета-КОПы — некоторые обобщающие структуры.

    Сценарии, в свою очередь, делятся на фрагменты — или сцены. Связи между фрагментами — временные или пространственные, внутри фрагмента — самые различные: ситуативные, ассоциативные, функциональные и т. д.

    Все методы выявления таких связей можно разделить на две группы:

    • Формальные

    • Неформальные (основаны на дополнительной работе с экспертом). Неформальные методы выявления связей придумывает инженер по знаниям для того, чтобы вынудить эксперта указать явные и неявные связи между понятиями. Наиболее распространенным является метод «сортировка карточек» в группы, широко применяемый и для формирования понятий. Другим неформальным методом является построение замкнутых кривых. В этом случае эксперта просят обвести замкнутой кривой связанные друг с другом понятия. Этот метод может быть реализован как на бумаге, так и на экране дисплея. В этом случае можно говорить о привлечении элементов когнитивной графики. После того как определены связи между понятиями, все понятия как бы распадаются на группы. Такого рода группы представляют собой метапонятия, присвоение имен которым происходит на следующей стадии процесса структурирования.

    Методы выделения метапонятий и детализация понятий (пирамида знаний)

    Процесс образования метапонятий, то есть интерпретации групп понятий, полученных на предыдущей стадии, как и обратная процедура — детализация (разукрупнение) понятий, — видимо, принципиально не поддающиеся формализации операции. Они требуют высокой квалификации экспертов, а также наличия способностей к «наклеиванию» лингвистических ярлыков. Если на рис. 6 показаны схемы обобщения и детализации на тривиальных примерах, то в реальных предметных областях эта задача оказывается весьма трудоемкой. При этом независимо от того, формальными или неформальными методами были выявлены понятия или детали понятий, присвоение имен которым или интерпретация их — всегда неформальный процесс, в котором инженер по знаниям просит эксперта дать название некоторой группе понятий или отдельных признаков.

    Это не всегда удается. Это связано с тем, что формальные методы иногда выделяют «искусственные» концепты, в то время как неформальные обычно — практически используемые и потому легко узнаваемые понятия.

    Рис. 5. Обобщение и детализация понятий

    Методы построения пирамиды знаний обязательно включают использование наглядного материала — рисунков, схем, кубиков. Уровни пирамиды чаще возникают в сознании инженера по знаниям именно как некоторые образы. Построение пирамиды знаний может быть основано и на естественной иерархии предметной области, например связанной с организационной структурой предприятия или с уровнем компетентности специалистов (рис. 6.).

    Рис.6. Пирамиды знаний

    Методы определения отношений

    Если на стадии 4 (см. рис. 4.) мы выявили связи между понятиями и использовали их на стадиях 5 и 6 для получения пирамиды знаний, то на стадии 7 мы даем имена связям, то есть превращаем их в отношения.

    Существует более 200 базовых видов различных отношений, существующих между понятиями. Предложены различные классификации отношений. Следует только подчеркнуть, что помимо универсальных отношений (пространственных, временных, причинно-следственных) существуют еще и специфические отношения, присущие той или иной предметной области.

    Интересные возможности к структурированию знаний добавляют системы когнитивной графики. Так, в системе OPAL эксперт может манипулировать на экране дисплея изображениями простейших понятий и строить схемы лечения заболеваний, обозначая отношения явными линиями, которые затем именуются.

    Предлагаемая в данном учебнике методология структурирования опирается на современные представления о структуре человеческой памяти и формах репрезентации информации в ней.

    Скудность методов структурирования объясняется тем, что методологическая база инженерии знаний только закладывается, а большинство инженеров по знаниям проводит концептуализацию, руководствуясь наиболее дорогими и неэффективными способами — «проб и ошибок» и «по наитию», то есть исходя из соображений здравого смысла.


Кафедра UNESCO КемГУ

Структура отчета по лабораторной работе

Составными частями итогового отчета являются:
Кафедра ЮНЕСКО по информационным технологиям в КемГУ, Кемерово 1. титульный лист;
2. формулировка задания;
3. основная часть;
4. заключение;
5. список источников;
6. приложения (при наличии таковых). 1. Титульный лист является первой страницей отчета и должен содержать наименования вуза и кафедры(лаборатории), название лабораторной работы (темы), сведения об исполнителе(ях) лабораторной работы и о преподавателе, наименование места и год подготовки(издания) отчета. После проверки очета здесь также приводяся сведения об аттестации работы и авторов.
2. Формулировка задания содержит конкретное задание руководителя практики или типовое задание для данного вида работы.
3. Основная часть должна содержать краткое описание работы и данные, отражающие сущность, методику и отдельные результаты работы, достигнутые в ходе ее выполнения, включая освещение следующих вопросов каждого занятия:
  • Формулировка темы лабораторной работы (занятия);
  • содержательная постановка задачи(комплекса задач) с указанием цели;
  • перечень методов, способов, приемов, использованных в ходе выполнения задания;
  • требования к описанию экспериментально-исследовательских работ;
  • описание условий и порядка проведения экспериментов;
  • использованное при проведении эксперимента оборудование, материалы и программное обеспечение;
  • по каждому проведенному эксперименту должно быть указано:
    • цель эксперимента (какие зависимости или параметры предполагалось исследовать);
    • состав и способ генерации/предоставления исходных и выходных данных;
    • методика, сценарий или алгоритм, который исследовался или применялся в эксперименте;
    • суть эксперимента - гипотеза и условия ее проверки, параметры исходных данных, расходы памяти, времени и т.д.;
    • при исследовании программного обеспечения приводятся также:
      • характеристика программного обеспечения;
      • анализ возможностей, выявленных в процессе выполнения лабораторной работы;
      • требования к программному обеспечению;
    • результаты эксперимента в наглядной форме (таблиц, графиков, экранных форм, Web-страниц, презентаций и т.д.);
4. В заключении приводятся выводы, характеризующие итоги проделанной работы и, возможно, рекомендации.
5. Список источников - упорядоченные в хронологической последовательности библиографические описания использованных материалов по теме выполненной работы. В списке следует указывать автора, наименование источника, издательство, год издания и другие сведения по ГОСТ Р 7.0.5-2008 СИБИД.
6. Приложения, полученные в ходе работы и дополняющие основные разделы отчета, помещаются в конце отчета, должны начинаться с новой страницы и иметь содержательный заголовок. Приложения нумеруются арабскими цифрами в правом верхнем углу над заголовком со словом "ПРИЛОЖЕНИЕ". На все приложения в основной части "Отчета" должны быть пояснения и ссылки по тексту основной части.
Примечание. 1. По согласованию с преподавателем лабораторную работу и оформление отчетности могут выполнять несколько человек с предварительнымм планированием операций и рациональным распределением обязанностей в творческом коллективе, что отражается в материалах отчета (задании, авторских справках и т.п.).
2. По отдельным экспериментам обычно в рамках амостоятельной работы формируются типовые разделы отчета, предъявляемые преподавателю для проверки, согласования и оценки по мере их готовности.