Основы современного делопроизводства. Инструментальные средства верстки изданий. Популярные издательские системы. Обзор Microsoft Publisher.

Настольная издательская система
Microsoft Publisher

"Корпорация Майкрософт: девиз — универсальность"

Фирма Microsoft предлагает свою версию настольной издательской системы(НИС), согласованную по основным параметрам с приложениями MS Offise и имеющую другие достинства. Для тех, кто стоит перед выбором конкретной НИС на долгие времена, ознакомление с этой программой верстки крайне желательно, чтобы иметь некую базу для сравнения.

Изучение программы полезно совместить с созданием практически полезного информационного продукта (брошюры, газеты и т.п.), воплощающего как можно больше эффектов, создаваемых данной НИС. Концепцию такого издания целесообразно надлежаще оформить и согласовать заблаговременно со всеми заинтересованными сторонами (преподавателем, спонсорами и др.) для профилактики ошибок и изучения реакции экспертов на предложенную идею.

Продуманный выбор содержания и вида издания, его архитектоники и дизайнерских решений позволяет добиться наивысших результатов и полезной отдачи полученных знаний. Реальную ценность такой продукт приобретает при его публикации на одном или нескольких сайтах для максимально широкой целевой аудитории, к чему надо стремиться изначально, планируя свою работу с данным пособием и самой программой.

Телефон: (3843)74-88-06
Б.Г.Новокрещин

  • О корпорации Майкрософт
  • Введение в Microsoft Publisher 2002 XP
  • Microsoft Publisher: основы верстки
  • Практическая работа в Microsoft Publisher
  • Приложение


Глава 1

Часть первая:
Корпорация Майкрософт: девиз — универсальность
  • Windows XP, детище Microsoft
  • Пакет приложений Windows XP - Microsoft Office XP
  • Средства Microsoft Office XP
  • Microsoft Word 2002 XP
  • Давайте условимся


Глава 1

Windows XP, детище Microsoft

Вот уже несколько десятков лет Корпорация Майкрософт, начинавшая свое существование как малюсенькая фирма Билла Гейтса, изобретателя машинного языка Basic, является главным и чуть ли не единственным законодателем «моды» в программном обеспечении компьютера. Подавляющее большинство пользователей ПК (персонального компьютера) всего мира, независимо от их желания, используют в своей работе операционную систему Windows и многие программы-приложения, созданные той же Корпорацией Microsoft.

Кстати сказать, и прежняя операционная среда, которая зовется MS-DOS и в которой ПК работали двадцать-тридцать лет (а многие пользователи предпочитают и теперь в ней трудиться), тоже детище Билла Гейтса, как и альтернативная Windows операционная система OS/2. Лишь две другие операционные системы — BeOS и Linux — сумели «пробиться» сквозь авторитет Майкрософта и отвоевали себе некоторое количество пользователей. Число ПК, работающих в системах BeOS и Linux, пока не превышает 10 процентов от общего числа ПК конструкции IBM. Станции Macintosh фирмы Apple основаны на системе Мае изначально и конкурируют не столько с Корпорацией Майкрософт, сколько с принципами IBM. К тому же, в последнее время, вот уже лет пять Apple усиленно сближается с Microsoft и не выпускает никаких своих приложений и версий без согласования с Биллом Гейтсом.

Однако операционная среда Windows, о которой мы начали говорить, в отличие от MS-DOS, за десять лет своего существования претерпевала и претерпевает значительные изменения. К примеру, в последней, которая носит имя Windows XP и для обыкновенных, рядовых пользователей существует в двух похожих друг на друга вариантах — Windows XP Professional и Windows XP Home Edition, — трудно разглядеть черты Windows 3.1 (3.11), с которой началась пользовательская революция. Если вы не остались незыблемыми принципы операционной программы Windows, о которых смешно говорить, поскольку вес их давно знают, можно было бы подумать, что версии 3.1 и ХР созданы совершенно разными фирмами — настолько отличаются эти версии внешне.

А принципы — их несколько — просты:

1. Для удобства пользователя все виды работ в Windows начинаются с кнопки «Пуск» или «Старт», расположенной на Панели задач интерфейса Windows.

2. Все виды работ начинаются с вызова меню. Меню — это виртуальный объект-таблица, в котором собраны все необходимые для работы команды. Главным меню ПК является Стартовое меню, которое открывается кнопкой «Пуск». Все остальные меню подразделяются на Командные и Функциональные. В свою очередь, Функциональные меню могут располагаться и в Строке Командных меню и вызываться так же, как и Командные, но могут быть скрытыми, то есть вызываться лишь по необходимости и без поиска их в списке, который может оказаться длинным и неудобным. Такие меню называются еще Контекстными. Отличие собственно Функционального меню от меню Контекстного в том, что часто Контекстное меню содержит не только опции, но и команды, то есть является Функционально-командным.

Вызов того или иного меню происходит при помощи ручного манипулятора, и чаще всего для этой цели используется компьютерная мышь. Но возможна работа и только с клавиатуры: этот пережиток системы MS-DOS не только остался в Windows, но и является первичным, то есть до сих пор приоритетным для ПК. Вероятно, это сделано потому, что до сих пор многие пользователи, стаж которых исчисляется десятками лет, предпочитают общаться с ПК старым испытанным способом.

Новейшая и революционная во многих отношениях Windows XP специально для таких пользователей имеет в числе Стандартных программ-приложений утилиту по имени Командная Строка. Эта утилита открывает для пользователя пустое окно с черным фоном, в котором, как в MS-DOS, пользователь имеет возможность назначать ПК свои команды и выполнять их только с клавиатуры.

Впрочем, пользователь должен учитывать, что Командная строка — это не чистый MS-DOS, a MS-DOS, вызванный через Windows. На самом деле если вы пожелаете что-то сделать с вашей Windows XP из ДОСа, то пользоваться Командной строкой не должны. Чтобы попасть в чистый DOS, перезагрузите компьютер в режиме DOS.

3. Главный принцип, из-за которого операционная система и получила свое имя, — это Окна (Windows). Для общения с пользователем программа выбрасывает так называемые «окна». Интерфейсы почти всех программ и утилит, основанных на Windows, используют в качестве своего интерфейса (лица) ОКНО, изобретенное Корпорацией Майкрософт. Окно может быть как программным, так и диалоговым.

Программное окно — бывает весьма сложным, но не по конструкции. Конструктивно оно всегда состоит из одинаковых элементов. Мы рассмотрим его, когда перейдем к программе, заявленной в этой книге. Сложным в программных окнах бывает содержание, но и то универсальность Windows настолько высока, что многое и многое из того, что знакомо вам по другим приложениям, здесь тоже не вызовет вопросов — к примеру, имена командных меню, перечень знакомых опций самих меню и так далее. Вам могут быть знакомы многие, большинство или все до единой кнопки Панели управления. Из интерфейса Windows приложения заимствуют способы прокрутки, Строку состояния, Панели инструментов и так далее.

Диалоговые окна бывают простыми и сложными. В сложном диалоговом окне вы можете встретить несколько подокон, которые скрываются за кнопками-опциями, то есть самостоятельных диалоговых окон, специфика и вид которых зависят от решаемых ими вопросов (функций). Также в сложном диалоговом окне вы можете наблюдать несколько вкладок, то есть других окон такого же типа, вложенных в одно окно. Вкладки вызываются проще, чем вложенные диалоги (подокна): они открываются просто щелчком на имени вкладки. Кроме того, полный список вкладок может не уместиться в Строке вкладок, и потому Строка может быт снабжена кнопкой прокрутки — влево (тогда она расположена справа) и вправо (она — слева).

Отдельный специфический вид окна, относящийся к сложным, это Окно-Навигатор. Навигатор — специальная утилита, которая действует по принципу известного всем эмэсдосовского навигатора по имени Нортон Коммандер (Nc). В свое время фирма Нортон изобрела это окно вместо скучного черного или синего поля Ms-DOS, и этим окном пользователи пользовались на протяжении полутора и более десятков лет, пока его не стала вытеснять Windows, предложившая свои виды окон, которыми мы и пользуемся теперь.

Простое диалоговое окно решает, как правило, какую-то одну проблему. Бывает, оно задает вам один-единственный вопрос, на который предлагает или два варианта ответа по типу «да — нет», или три варианта: «да — нет — отмена». Вариант «Отмена» — это значит, не решать вопрос никак, а на время или навсегда снять проблему. Это бывает очень часто — случаев, когда вы ошиблись, или раздумали, или не хотите начинать длинную цепочку каких-то операций в программе — бывает великое множество. Windows через свои окна снимает ваши проблемы одну за другой или, наоборот, помогает вам идти и дальше по пути каких-то манипуляций с объектами или текстом, или таблицей и т. д. по пути их усовершенствования, изменения или заполнения (заливки) и тому подобное. То есть помогают вам работать. Работа в Windows состоит в чередовании операций с окнами, меню и инструментами. С помощью этих элементов программы (операционной системы) вы можете осуществить все виды работы в необходимой вам области.

4. Один из важнейших принципов работы операционной системы (среды) — его узнаваемость и повторяемость. То есть программа на 100 процентов поступит именно так, как вы ожидаете. Дальше — решать вам. Все решения принимаются вами с помощью системы: они в ней заложены уже сами по себе. И даже в альтернативных вариантах.

5. В Windows существуют гениальные ОТМЕНЫ прошлого действия. Это своеобразный Предохранитель на тот случай, если вы все же не вняли предупреждениям диалоговых окон и сказали «Да», то есть осуществили какое-то важное действие-изменение в какой-либо из программ-приложений. Не с программой, конечно, а с документом, в котором работаете.

Следующих беспрерывно друг за другом отмен в разных программах разное количество. К примеру, в верстальных программах PageMaker и QuarkXPress — только одна отмена. В графической CorelDRAW — 99 отмен... В Microsoft Word — 299.

6. В Windows впервые принят принцип расстановки ярлыков используемых программ, папок и документов — на Рабочем столе. Рабочий стол — отличительная черта операционной системы. Говорить про него нет особого смысла, ибо наверняка нет пользователя, который не представлял бы себе, как выглядит Рабочий стол Windows. Самой главной его особенностью является наличие в нижней части окна Панели задач, с которой при любых возникших с приложением проблемах можно дать команду закрыть программу или перезагрузить компьютер.

Есть и еще принципы, рожденные в операционной среде Windows, но мне кажется, перечисление основных дает представление о том, что и другие принципы тоже повторяются от версии к версии, а отличие каждой новой версии Windows от предыдущих — лишь в том, что добавляются и совершенствуются ее функции. Не названные здесь принципы работы, присущие операционной среде, обязательно повторяются в прикладных программах (программах-приложениях), и соответственно о них мы также станем говорить, когда займемся непосредственно заявленным в теме книги приложением (Microsoft Publisher XP).

Прошло всего 10 лет, и после первой революции Билл Гейтс за десять лет подготовил вторую: в ноябре 2001 года состоялась презентация Windows XP.

Внешне эта операционная система поменяла свой интерфейс. Правда, принципиально для пользователя ничего не произошло — изменились визуальные настройки. А по большому счету Windows XP стала «умнее» прежних версий (Windows 98 и Windows 2000): она, к примеру, не отдает на откуп специалисту свое собственное состояние, а лечит его сама. Эта функция заложена в утилите «Восстановление системы» в директории программ «Стандартные». Windows XP помнит свое состояние с момента своей инсталляции на каждый день. Соответственно, если с нею что-то произошло по чьей-то вине — будь это внезапное отключение питания или грозовой разряд за окном, — вы вполне можете вызвать Мастера по восстановлению системы (это виртуальный Мастер), и он, предлагая вам ответить на несколько вопросов, в том числе и назначить некоторое прошлое число календаря, восстановит состояние системы на определенный час этого числа. То есть программа запоминает и раскладывает по полочкам (составляет реестр) все свои прошлые состояния. Правда, следует оговориться, что помнит она не всякие текущие состояния (хотя их — тоже), но некие вехи — к примеру, моменты, когда установили на ваш ПК какую-либо новую программу-приложение или дали системе новые настройки и так далее. Несколько минут работы — и ХР приведет самое себя в состояние, бывшее хотя бы до того момента, как вы внесли эти изменения. Фактически, не прибегая к переустановке, вы в 99 случаях из 100 сможете восстановить ХР силами самой ХР. Это новое слово в программном обеспечении.

Вторым отличием версии ХР является значительное расширение интерактивности (то есть услуги Интернет): ХР считает Интернет приоритетной сетью по сравнению с.любой другой, в которой участвует ваш ПК. Даже окна Windows ХР теперь работают на принципе гиперсвязей — то есть любое действие, которое вы желаете осуществить, в том числе и сугубо внутренняя команда, «на всякий случай» происходит по интернетовскому принципу — вызову команды гиперссылкой.

Третье существенное отличие. Окно-навигатор Проводник, яркий отличительный признак всех прежних версий Windows, теперь в значительной степени потерял свое значение. Почему? Да потому что практически все основные окна Windows ХР стали теперь окнами-навигаторами, причем навигация осуществляется по умолчанию гиперссылками.

Прикладные функции ХР расширились. К примеру, Универсальный проигрыватель Windows теперь может не только проигрывать для вас аудиозаписи, но и демонстрировать видео. ХР предлагает вам не только монтировать, но и самостоятельно снимать видеоклипы. Перевод аудио и WAV-файлов из формата в формат на Проигрывателе ХР происходит настолько легко и безболезненно, что эти превращения не снились ни одной из музыкальных программ-редакторов. Искажения практически исключены. Есть только небольшие затруднения с записыванием аудиодис-ков: ХР ловит шумы старого «железа». Требует лишь Пентиума IV. Прогресс... кусается.

И так далее. О расширенных возможностях Windows ХР можно говорить долго. Мы еще вернемся к этому, поскольку нам предстоит изучить также новые возможности Офиса — пакета приложений Майкрософт. Здесь и в самом деле наблюдается если не сама революция или начало ее.


Глава 1

Пакет приложений Windows XP - Microsoft Office XP

Фирма Microsoft позаботилась о том, чтобы свести под единый конструктивный наряд несколько программ, необходимых для жизнедеятельности как рядового домашнего пользователя, в том числе домохозяйки, пишущей стихи (к примеру), так и могучего офисного коллектива, занятого разработкой и распространением разного рода документации. Все это было названо универсальным офисным пакетом, и его имя (оно поблагородней какой-нибудь неуместной аббревиатуры) — Microsoft Office. В тот самый, первый момент к этому названию присоединили число 95. Так что первый пакет был разработан восемь лет назад и получил широкое распространение в 1995 году.

Не прошло и двух лет, а фирма усовершенствует свой пакет и выпускает в свет замечательный набор программ под именем Microsoft Office 97. Правда, в среде компьютерщиков, как это часто бывает, имя фирмы осталось за бортом, и пакет в обиходе назвали просто «Офис 97».

«Офис», особенно 97-й, действительно универсальный пакет программ. Он занимает не много места, зато может совершать чудеса. Им могут пользоваться как писатели и издатели, инженеры и ученые, художники и музыканты, так и начинающие пользователи.

Прошло еще два года, и вышел замечательный во всех отношениях пакет Microsoft Office 2000! Честно говоря, при всех достоинствах прежнего пакета как-то уже и не думалось о том, что так быстро может появиться совсем новая разработка. Тем не менее, она не замедлила заполнить компьютерный рынок, и тут же поблек и устарел прежний вариант по имени Офис 97.

И вы думаете, Корпорация Майкрософт остановилась? Оказывается, ведущая мировая фирма по программному компьютерному обеспечению работала над уникальной Windows XP и параллельно готовила новейший пакет Office 2002 ХР (теперь просто Office XP).

Посмотрим, что же за набор программ входит в новый пакет?

Первое. Это замечательный во многих, если не во всех, отношениях пользовательский Word 2002. Сейчас эта программа называется Microsoft Word 2002 ХР. По номерам версий «Ворд» теперь не различают. Последний из различимых назывался Ворд 7,0. Теперь к нему, кстати, обязательно добавляют уточнение: «для Windows 95». Именно так он, этот «Ворд», и числится, как устаревший, в разделе сохранения документов, в окне расширений: Word 6,0/7,0 для Windows 95.

Второе. Microsoft Excel 2002 ХР. Программа существует для построения электронных таблиц. Она самая математическая из всего пакета (может быть, если не считать совсем уж «крутую» Microsoft Access, рассчитанную на пользователей-профессионалов, создателей баз данных). Программа Excel 2002 ХР не претерпела почти никаких изменений по сравнению с той ее версией, которая входила в состав «Офиса 2000».

Третье. Замечательная программа для создания презентаций Microsoft PowerPoint 2002 ХР. Ее удивительные возможности мы тоже немного рассмотрим.

Вот три «зубра», очень необходимые вам в вашей работе. Вернее, два: что-то не знаком я до сих пор с пользователем, которому нужны электронные таблицы. Для того чтобы суметь работать во всех трех программах, достаточно изучить хотя бы одну из них.

Остается лишь упомянуть, что, помимо указанных, пакет содержит и некоторые специфические программы, которые иногда могут вам понадобиться для работы. Это такие программы, как Microsoft FrontPager (программа служит изготовлению HTML-документов для Интернета); Microsoft Outlook (дневники, записные книжки, электронная почта, работа с факсом и пр.). Также большой набор приложений и утилит под общим именем Средства Microsoft Office. Эти утилиты и приложения являются естественным продолжением утилит и приложений ХР и основаны на использовании ХР, поэтому разумнее всего было бы сразу же поговорить именно о них.

Со Средств Microsoft Office мы и начнем разговор.

Следующая глава будет посвящена интереснейшим вопросам знакомства с утилитами, входящими в папку «Средства Microsoft Office», где Помощник, может быть, был бы лишним.

Очень уж утилитарны задачи этих самых утилит, которым, по-хорошему, следовало бы находиться в основном наборе программ Стандартные Windows ХР, ибо в Средствах проявляются, и в очень большой степени, именно достоинства этой новой операционной системы-среды. А те недостатки ее, о которых говорилось, вполне устранимы в новых, улучшенных версиях ХР.

Итак, перейдем к Средствам Microsoft Office 2002 ХР.


Глава 1

Средства Microsoft Office XP

Говоря о папке, название которой вынесено в заголовок этой главы, требуется припомнить, что до последнего времени мы имели возможность пользоваться многими и многими приложениями сторонних фирм, решающими задачи, с которыми, возможно, лучше всего справились бы специалисты «материнской» фирмы, разработавшие саму операционную систему. Ведь именно им, знающим многие нюансы программистам и функционалистам, гораздо легче заставить свою среду пристроиться к самым распространенным в мире прикладным задачам. Однако нет: всегда что-то мешало (думаю, отсутствие времени на разработку, а может, и отсутствие конкретного заказа: о «социальном заказе» смешно говорить — они что, не снимали своих детей на цифровую камеру? не сканировали картинки?..). Правда, тут могли быть и административные причины — допустим, та, что Билл Гейтс поделил с другими фирмами функции обслуживания пользователя: ему, наверняка, программное обеспечение, а другим — любые приложения — кроме Word, поскольку здесь опять же кроме него мало кто по-настоящему преуспел.

Ну, да ладно. Перейдем к самим утилитам.

Папка «Средства Microsoft Office» находится в подменю «Все программы» Стартового меню Windows XP.

Из подменю «Средства Microsoft Office» нас интересуют три верхние опции — именно они-то и являются самыми ценными во всем этом пакете утилит.

Во-первых, это утилита сканирования документов по имени «Microsoft Office Document Imaging» (программа сканирования изображений); во-вторых, это утилита сканирования текстов «Microsoft Office Document Scanning»; а третья — это «Microsoft Photo Editor» — пусть не самый выдающийся, но Фоторедактор Офиса. Ему вполне под силу провести достаточно квалифицированную обработку (редактуру) отсканированных изображений.

Если не для высшего профессионала, работающего с изображениями и документами текстового характера, то уж для среднего пользователя эти утилиты вполне подходят, и соответственно отпадает большая необходимость в графическом редакторе Photoshop и в пресловутом FineReader, создатели которого так замечательно «закрыли» свою программу, что взломать ее, как ни пытаются многие, не могут. Взлом программ в России идет не по причине, кажущейся основной на Западе (той, что мы все воры и бандиты), а только потому, что наш труд оплачивается неадекватно, примерно в 10 раз ниже того, чего стоит средний работник. Кто же может купить программное обеспечение за 300 долларов? Это выложить (в лучшем случае) две зарплаты? За что? За приложение, которое еще до истечения двух последующих месяцев устареет? Шутите, господа. А Майкрософт делает нам этот подарок!!! Плевали мы на FineReader (для тех, кто не знает, поясню, что это приложение для сканирования текстов — очень, кстати сказать, хорошее приложение и очень удобное для работы, настроив которое, можно горя не знать, но...).

В Фотошопе (программе фирмы Adobe) есть инструменты, с помощью которых можно работать с изображением — что-то стереть (инструмент Ластик) или замалевать (Кистью, Карандашом, Аэрографом) и т. д., то есть имеется полный набор всех опций и инструментов, а также эффектов для того, чтоб работа над изображением была поистине профессиональной. А в ФотоРедакторе Майкрософт нет инструментов! Поэтому ФотоРедактор больше «читалка», чем истинный редактор. Но из него вполне можно загружать изображения в верстальные программы. В том числе и в QuarkXPress, и в PageMaker, и в Microsoft Publisher... Тем более что с изображениями работают все же художники, а верстальщику чаще всего достаточно и функций Photo Editor, поскольку чаще всего в его задачу входит лишь поместить рисунок в книгу, газету, журнал и так далее.

Идем дальше.

Из других функций, содержащихся в опциях подменю «Средства Microsoft Office» — опция «Восстановление приложений Microsoft Office», «Языковые параметры Microsoft Office XP», «Мастер сохранения настроек» и «Коллекция картинок (Office)». Коллекция картинок — это само собой понятно, Офисный пакет не забывал пользователя и в своих прежних версиях: картинки в пакете были на все случаи жизни, теперь картинкам Офиса посвящен целый лазерный диск объемом 650 Мб, и картинок на нем и вправду великое множество. Многие повторяются из прежних версий, но в основном они все новые. Этот запас изображений, я считаю, не подходит для профессионального верстальщика, ибо чаще всего картинки там представлены с очень слабым разрешением — 72 dpi, то есть годны лишь для оформления странички Интернета, но все же...

«Мастер сохранения настроек» предлагает вам не автоматически, по умолчанию, а как бы специально, «вручную» настроить Офисный пакет. Это делается опять же с той целью, чтобы вы не использовали для восстановления лишь чуть-чуть испорченной программы полной переустановки Офиса, а обратились бы к Мастеру.

То же касается «Восстановления приложений Офиса». Но если в первом случае, случае с Мастером сохранения вы должны будете перед началом настроек отключить все действующие приложения, то здесь восстановление происходит при работающем приложении.

В моей прошлой книге, посвященной Windows ХР и Microsoft Word 2002 ХР, я ошибочно заявил, что Майкрософт включила наконец верстальную программу-приложение Microsoft Publisher в число программ Офисного пакета. Это не так. Сейчас исправляюсь и скажу, что Корпорация Майкрософт оставила эту программу несколько в стороне, ее можно считать как бы началом второго тома Офисного пакета ХР. Она до сих пор распространяется отдельно и на всякий случай при установке подгружает еще один, идентичный основному, набор «Средств Microsoft Office», с помощью которого ее также можно восстанавливать, если возникнет необходимость.

Прежде чем на этом беглом и поверхностном знакомстве с Офисом ХР завершить небольшую вступительную первую часть книги, хотелось бы слегка коснуться программы-приложения Microsoft Word, поскольку именно Word необходим нам всегда, когда мы имеем дело с версткой — в каком бы приложении мы ни верстали.

Итак, обратимся к Microsoft Word, но поговорим о нем также совсем немного.


Глава 1

Microsoft Word 2002 XP

Word 2002 ХР теперь, несомненно, самая сильная программа для набора, редактирования и экспорта текста. Экспорт — в смысле возможности отправить ваш документ по назначению. Как правило, этим назначением являются либо сеть Интернет, где, превращенный в файл HTML, ваш документ становится доступным для «мирового паука» (теряя, правда, при этом некоторые свои атрибуты форматирования), либо какая-то из верстальных программ, где документ, бывший прежде «вордовским», становится принадлежащим совсем иному семейству, из которого иногда вернуть его в прежнюю, «вордо векую» личину представляется достаточно трудным, а то и невозможным. Впрочем, это не все. В любую офисную программу, занимающуюся, так или иначе, текстом, «вордовский» документ отправить тоже не так уж сложно. При желании документы Word (расширение .doc, .rtf, .txt и др.) могут быть доступны многим другим программам, нуждающимся в них. Поэтому я и говорю о важности и об универсальности пакета «Офис».

Важным недостатком Microsoft Word, начиная с его ранних версий и заканчивая последней, о которой ведем разговор, является то, что он частенько сильно мешает пользователю работать в нем. Чем же? А тем, что постоянно проверяет сам себя, подсчитывая страницы, независимо от того, много их (400) или мало (две). Если вы вдруг заметили (вполне самостоятельно) ошибку на предыдущей строке и, поставив в это место курсор, щелкаете мышкой, чтобы исправить — убрать одну букву и поставить вместо нее другую, — это вовсе не означает, что вам это легко удастся сделать. Word тасует еще и строчки, и буквы. Он все время что-то подсчитывает, не давая пользователю опомниться. Вот щелкнули, убрали букву и впечатали вместо нее другую... Смотрите, что получилось, и приходите в ужас: вы поставили еще одну неправильную букву! Почему? A Word в это время «мигнул» в своих подсчетах, строчка шевельнулась (они имеют свойство постоянно двигаться без вашего участия), и курсор попал на пробел между прошлым словом и словом, которое вы собирались исправить. Затем вы преспокойненько убрали вместо неправильной буквы этот пробел, а на его место впечатали дополнительную, неправильную конечно же, букву. Именно это программа и воспроизвела — самым честнейшим образом, тем более что связь с клавиатурой в ней работает как часы. Если вы не посмотрите, что сделали, и двинетесь дальше, в вашем тексте вместо одной опечатки или ошибки будет две, а то и три сразу. В отличие от других наборных или верстальных программ, Word требует излишнего внимания. И все равно потом вылезают опечатки и ошибки: человек — не машина, быстро утомляется.

А сейчас хотелось бы сказать о главном достоинстве Microsoft Word, еще с версии 2000. Лично мне очень давно хотелось нововведения, которое, наконец, возникло в этой версии, хотя она теперь тоже стала прошлой. Речь идет о «Буфере обмена».

Прежде, если вы желали перенести какой-либо материал в другую программу, вы давали команду «Копировать» (или «Вырезать»), и этот выделенный вами материал (допустим, абзац) попадал в так называемый OLE-файл, то есть файл, который нигде, кроме оперативной памяти, не фиксируется, его нельзя запомнить (сохранить) ни в каком виде до тех пор, пока вы не открыли другой документ или программу с документом (публикацией и т. д.) и не скомандовали «Вклеить» («Вставить»). Только попав в конкретную форму (в виде текста или изображения), этот материал становился опять доступным для сохранения в качестве официального файла с именем и расширением, свойственным той программе, в какой вы его запоминаете. А буферный временный файл так и повисал в буфере до следующего момента, когда вам придет в голову воспользоваться им. Но вставлять все тот же текст куда-либо второй раз вам наверняка не придется (если это не термин какой-нибудь, повторяющийся в тексте буквально через слово — только тогда это удобно, вы вклеиваете его из буфера бесконечно, вместо того чтобы всякий раз набирать это одно и то же). Вставка большого куска дважды — очень редкий и почти невозможный случай. Но вы продолжаете работать, у вас и так большой файл, который «оперативка» держит в своем уме (памяти), да тут еще и переполненный буфер с ненужным и уже отработанным текстом.,.

Так вот прежде, чтобы освободить буферную область, приходилось прибегать к уловкам. Лучше всего было бы в старой программе «Ворд» выйти из него («Ворда»), и тогда он задавал такой вопрос: «Буфер обмена содержит большой отрывок текста. Вы хотите, чтобы он был доступен другим приложениям?» И тогда вы мужественно отвечали «Нет», а «Ворд» сам стирал все то, что в буфере. Я прибегал к другой, менее трудо- и времяемкой уловке: я выделял курсором какую-нибудь запятую или какое-нибудь тире и командовал «Копировать». Тогда вместо громадного куска текста в буфер попадал малюсенький значок размером в 8 бит. Практически вся оперативная память разгружалась от своего ненужного груза: теперь в «голове» «Ворда» сидела всего лишь какая-то запятая, — скорость работы программы повышалась, она переставала следить за тем, что там у нее содержится в буфере. Тогда и при выходе из нее эта программа не задавала никаких лишних вопросов и преспокойно закрывалась по первому требованию.

Все-таки по многим показателям для пользователя этот способ не был удобным. Приходилось припоминать какие-то условности, постоянно держать в уме, что буфер желательно освободить от чего-то и т. д.

Совсем не так теперь! Весь Буфер обмена в прошлой версии был поделен на 12 ячеек (по умолчанию). При повторном копировании в буфер перед вами возникало диалоговое окошко «Буфер обмена» (хотя отчего-то буфер числился среди панелей, а не диалогов), и вы видели, что в одной ячейке уже сидит некий кусок, который вы «бросили» в буфер час назад и благополучно забыли о нем, а в другую ячейку скопировалось то, что вы скопировали только что. Представляете, сколько бывало прежде накладок? Теперь — вы застрахованы от ошибок. А количество ячеек буфера по сравнению с версией Word 2000 теперь увеличилось вдвое! В «2002 ХР» вы сможете скопировать в буфер 24 разных материала.

Отличительной особенностью Word 2002 является та, что буфер обмена теперь не выглядит и панелью-диалогом: теперь это ДОКЕР в правой части рабочего поля, очень схожий с докерами CorelDRAW, к которым многие успели привыкнуть. Правда, авторы докероа называют его иначе — Область задач. Тоже неплохо, но по привычке, выработавшейся за несколько лет пользования CorelDRAW, я, с вашего позволения, стану называть Область задач все же Докером.

И второй замечательный сюрприз, родившийся еще в 2000-й версии: внедрение «плавающих» панелей управления и инструментов и столь же «плавающих» командных меню. Это достоинство не сразу будет оценено вами, но когда оцените, скажете разработчикам спасибо. Если, конечно, вы еще не оценили его в то время, когда поменяли свой Word 97 на Word 2000.

Прежде когда вам, после многих часов, дней и месяцев работы на ПК в любимой вашей программе Word приходило в голову самостоятельно исправить не совсем удобный для вас интерфейс программы (вы выбрасывали кое-какие кнопки, а вместо них вводили кое-какие свои, необходимые вам), то есть вы настраивали его «под себя», гонясь за собственным комфортом или удобством ради скорости, то теперь всего несколько дней работы на ПК в программе «2002 ХР» приведут к тому, что это приложение настроит свой интерфейс «под вас» независимо от вашего желания и нимало не ожидая вашей инициативы: те кнопки и команды, которыми вы чаще всего пользуетесь, постепенно «выскочат» на панель, а те, которыми редко (или вовсе не пользуетесь), уйдут в режим вечного ожидания. Он будет скрыт за значком », под которым расположен треугольничек вершиной вниз (наконечник стрелки). Если щелкнуть на этой узенькой кнопке, то развернется дополнительная панель, на которой будут собраны по умолчанию все кнопки и заключенные под ними соответствующие команды, до которых вам прежде не было никакого дела. И как вы только щелкнете на любой из них, она" самостоятельно и немедленно переместится на рабочую панель, в основной интерфейс. Это удивительное свойство нового поколения «Ворда» многого стоит и затмевает некоторые недостатки даже самого этого способа. В сравнении с Word 2000 состав упрятанных под узкую кнопку команд и кнопок панели вбирает в себя все возможности как Стандартной панели, так и панели Форматирования. Обе панели теперь собраны также в одну строку (но это было еще в прошлой версии) по умолчанию, и две / кнопки, находящиеся на ней, носят одно и то же имя «Параметры панелей инструментов» — это для тех, кто уже привык работать в Word 2000 и машинально достает необходимые команды и кнопки из-под первой или из-под второй узкой кнопки с этим именем, поскольку раньше под первой были собраны параметры Стандартной Панели, а под второй — панели Форматирования. Единственное неудобство, которое возникло по этому поводу в Word 2002 ХР, это то, что кнопки верхнего и нижнего индексов исчезли из этого раскрывающегося дополнительного меню, и когда они понадобятся, их приходится доставать из опции «Настройка...» меню «Сервис».

Впрочем, если говорить о последнем обстоятельстве, то авторы программы сочинили более близкий ход. Именно в этом большом меню и существует подопция «Настройка...». Считаю, что такое дублирование, против которого, помнится, выступал, говоря о Windows ХР, и которое, до сих пор считаю, там неуместно, здесь как раз оправдано и облегчает общение с программой-приложением.

Мало того, в зависимости от типа монитора, кнопок в панели инструментов может быть и гораздо больше, чем на моем или вашем экране.. Речь идет о разрешающей способности монитора: чем выше разрешающая способность, тем больше «проявлено» кнопок. Прежде было очень неудобно: мне, к примеру, позарез нужно окошко масштаба просмотра документа, а оно-то и не вмещалось в экран, соответственно повисая где-то в небытии. Много времени прошло, прежде чем я сообразил — вместо того чтобы вытаскивать окно масштаба из меню «Вид» и вызывать диалоговые окошки, не лучше ли просто выбросить с этой панели «Стандартная» ненужные кнопки, которыми я вовек не пользуюсь? Так и сделал, и окошко просмотра масштаба тут же проявилось. Вот что значит не подумать хорошенько, а впасть в уныние. А ведь о том, что можно сформировать свой собственный, только «под себя» интерфейс, я знал давным-давно, да все как-то не пользовался этим удобством... К сожалению, многими советами, которые даешь читателю, сам тоже не пользуешься.

Те же процессы «плавания» (другого термина не подберу) заложены в раскрывающихся ниспадающих командных меню. Меню содержат теперь набор лишь самых необходимых команд, использующихся чаще всего. Но это не значит, что другие команды, которыми вам тоже очень захочется пользоваться, хотя и реже, теперь недоступны. Любое меню в программе «2002 ХР» заканчивается строкой с той же двойной стрелочкой, направленной вниз. Можете щелкнуть на ней, а можете не щелкать: через две секунды меню в своем полном виде предстанет вам. Правда, в отличие от Word 2000, вы теперь не сможете визуально определить, какая из открывшихся команд употребляема вами чаще, а какая реже. Ведь прежде наименее часто используемые команды были изображены в виде, несколько отличном от часто употребляемых, — их строки были светлее и как бы поглубже, в сравнении с основными, вдавлены (визуальный, естественно, эффект). Зато в Word 2002 ХР недостаток этой информации, к которой многие, возможно, привыкли, работая с «Вордом 2000», компенсируется столь же веселым фоном, на котором выплывает меню и какой использован в построении общих принципов интерфейса в Windows XP. Теперь это белого цвета полотнище, и только левая полоса на нем серого цвета, но и этот серый цвет, часто содержащий пиктограммы или квадратного вида поля ввода флажков, гораздо светлее прежнего, пусть и неплохого, но уже скучного серого фона.

Есть способ еще проще. Если вы хотите, чтобы меню вам открылось сразу же и в полном виде, надо на его имени щелкнуть не один раз, а два (двойной щелчок мышки).

Поработав в Word 2002 ХР, могу утверждать, что новая «раскраска» интерфейса благоприятно влияет на зрение: глаза меньше устают, чем прежде. Правда, о голубом фоне Строки заголовка и Панели задач могу сказать: именно этот цвет не бьется с цветом страницы и рабочего поля. Как, собственно, разработчики ошиблись и с «цветом Windows», ибо на нем глаза устают в пять минут. Еще и по этой причине очень не хочется возвращаться на Рабочий стол, с которого час назад я выбросил все значки, оставив только корзину. Начнем работать по-новому — через Стартовое меню!..

Хочу упомянуть и еще об одном важнейшем обстоятельстве: о СИМВОЛАХ. Это бесценный подарок, надо признать прямо. Я много раз говорил, что когда речь идет о кириллице, особенно о старой кириллице (к примеру, Cyrillic Old или Izhitsa), то уж никак не обойтись без такой важной части старославянского (особенно церковно-славянского) шрифта, как ТИТЛО. Наконец-то сбылось: Word 2002 ХР содержит титло! Титло в числе первых символов по умолчанию вписано в число наиболее употребимых. Так же, как и УДАРЕНИЕ. Наконец-то русский писатель сможет набрать в «Ворде» книгу о древнем языке, поставить ударение в трудном или необычном слове над буквами ы, э, я, ю, и. Это не фантастика, а реальность.

Мне могут возразить: ведь есть же шрифты, где все буквы, отражающие гласные звуки, снабжены ударениями. Да, но мне нужно, чтоб все было стандартно. Мне нужно поставить ударение в три часа ночи, а в десять, утра, когда я пойду за диском со шрифтами, я уже забуду, в каком месте моей объемной книги мне нужно было ударение. Оно должно постоянно быть под рукой.

Сбылось: теперь есть ударение. И оно заложено в таблицу символов. Обычных символов. И ставится очень просто: этот символ достается из таблицы командой «Символ...» в меню «Вставка» и вставляется сразу следом за той буквой, на которую он должен падать. Тогда ударение попадет именно по назначению. Это гениально.

Так же точно ставится титло. Оно, может быть, на миллиметр-другой не достигает последующей буквы, но это уже настолько мелкая придирка, что и говорить о ней не надо.

В Word 2002 ХР по сравнению с Word 2000, который можно бы назвать, в отличие от ХР, именно первоначально-экспериментальным, появился крестик отключения документа у второго и последующих документов, открываемых в той же программе. Эксперимент с запрятыванием документов (трех-четырех и даже больше) под кнопки на Панели задач — можно, выходит, признать не совсем удавшимся. Не жалко: в этой придумке действительно было мало удобства. Зато прятать под одну кнопку на Панели задач множество документов, с последующим изъятием их оттуда через коротенькое меню, считаю очень даже веселым изобретением. Это красиво! На кнопке нарисован номер документа! — это также замечательно. Документ находится сверху. Остальные — ниже.

И еще заметим, что Word 2002 ХР, как и предыдущие версии «Ворда», наиболее употребляемая в мире программа — теми, конечно, кто работает не в допотопных MS-DOS, а в системе Windows. Лучшего текстового редактора, кто бы что ни говорил, не существует. Хотя есть, может быть, сотни всевозможных «Бордов», но они все уступают фирме Microsoft.


Глава 1

Давайте условимся

Я не упускаю этого объяснения, кажется, ни в одной книжке. Однажды встретив это простое решение у американца Рика Олтмана, я повторяю вослед за ним предупреждение, которое должно вам объяснить два простых термина. Речь идет о кнопках мыши.

В литературе о компьютерах и программах мы привыкли (а визуально так и есть) читать: «левая кнопка мыши», «правая кнопка мыши». Как и Рик Олтман, я применяю другие два термина — первая кнопка и вторая кнопка. Здесь снимается вопрос о том, левая она или правая. Потому что около четверти пользователей ПК — левши, a Windows в опции настройки мышки дает возможность выбрать — «левая» у вас будет мышка или «правая». Соответственно, чтоб не было разночтений ни у правшей, ни у левшей, и говорим: первая кнопка или вторая кнопка. Первая, соответственно, для большинства — левая, вторая — правая. Для левши — наоборот.

Еще вы заметили, что вместо словосочетания, к примеру, «диалоговое окно» я говорю просто — «диалог».

И еще. Опять же вы уже, вероятно, обратили внимание, что иногда я пишу слово Word по-русски. То же относится и к другим именам программ-приложений и, возможно, чего-либо другого. Дело в том, что, формулируя мысль, иногда просто необходимо поименовать ту или иную программу по-русски, дабы использовать какой-то падеж. К примеру, если произнести:

— Не следует увлекаться другими «Вордами»! —
вы, конечно, сразу же поймете: речь идет о том, что Word 2002 ХР предпочтительнее всех других текстовых приложений с таким же именем. А что было бы, если б я произнес:

— Не увлекайтесь другими Word!

Скорее всего, вы бы не поняли меня.

Конечно, практически все программы, которыми мы пользуемся, носят нерусские имена, но это наша беда, и только. Когда-нибудь (думаю, скоро) и мы получим не русифицированную версию того или иного приложения, а самую что ни на есть русскую. Но ее пока нет в природе. Поэтому прошу вас привыкнуть и к склонению иностранных слов, потому что так удобнее. Да и среди пользователей уже давно распространено именно такое отношение ко всем иностранным терминам, именам программ и «железа». Кстати, слово «железо» пишу в кавычках последний раз, потому что о настоящем железе, как химическом элементе, на этих страницах, конечно же, разговаривать не собираюсь. Значит, вы можете встретить здесь это слово только в известном компьютерщикам и пользователям контексте и смысле — компьютерное железо.

Вот, пожалуй, кратенько и все.

Если дальше встретится что-нибудь этакое, о чем сейчас, в этой главке забыл сказать, объяснюсь отдельно.

Вперед?


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Feb 2003 16:40:54 -0000 vti_extenderversion:SR|5.0.2.2623 vti_author:SR|HOME\\Женя vti_modifiedby:SR|HOME\\Женя vti_timecreated:TR|11 Nov 2002 15:56:12 -0000 vti_title:SR| Глава 1 vti_lineageid:SR|{089B584E-E969-4C96-B084-FD3E056D7E7D} vti_backlinkinfo:VX|index.htm vti_nexttolasttimemodified:TW|13 Feb 2003 16:31:38 -0000 vti_cacheddtm:TX|13 Feb 2003 16:40:56 -0000 vti_filesize:IR|2250 vti_cachedtitle:SR| Глава 1 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|../index.html S|Menu.gif H|Index1.htm H|Index2.htm H|Index3.htm H|Index4.htm H|Index5.htm H|../index.html S|Menu.gif vti_cachedsvcrellinks:VX|NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index1.htm FHUS|Часть1/Index2.htm FHUS|Часть1/Index3.htm FHUS|Часть1/Index4.htm FHUS|Часть1/Index5.htm NHUS|index.html FSUS|Часть1/Menu.gif vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Feb 2003 16:28:01 -0000 vti_extenderversion:SR|5.0.2.2623 vti_author:SR|HOME\\Женя vti_modifiedby:SR|HOME\\Женя vti_timecreated:TR|11 Nov 2002 15:56:38 -0000 vti_title:SR| Глава 1 vti_lineageid:SR|{83A190DD-5597-4F4E-A2D3-AB526315E08F} vti_backlinkinfo:VX|Часть1/Index2.htm Часть1/Index.htm vti_nexttolasttimemodified:TW|11 Nov 2002 15:56:38 -0000 vti_cacheddtm:TX|13 Feb 2003 16:28:02 -0000 vti_filesize:IR|14637 vti_cachedtitle:SR| Глава 1 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|../index.html S|Menu.gif H|Index2.htm S|For.gif S|Index2.htm H|../index.html S|Menu.gif H|Index2.htm S|For.gif S|Index2.htm vti_cachedsvcrellinks:VX|NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index2.htm FSUS|Часть1/For.gif FSUS|Часть1/Index2.htm NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index2.htm FSUS|Часть1/For.gif FSUS|Часть1/Index2.htm vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Feb 2003 16:29:10 -0000 vti_extenderversion:SR|5.0.2.2623 vti_author:SR|HOME\\Женя vti_modifiedby:SR|HOME\\Женя vti_timecreated:TR|11 Nov 2002 15:57:16 -0000 vti_title:SR| Глава 1 vti_lineageid:SR|{D98E6F3C-0350-4137-8E83-2B810BD0623A} vti_backlinkinfo:VX|Часть1/Index3.htm Часть1/Index1.htm Часть1/Index.htm vti_nexttolasttimemodified:TW|11 Nov 2002 15:57:16 -0000 vti_cacheddtm:TX|13 Feb 2003 16:29:12 -0000 vti_filesize:IR|6135 vti_cachedtitle:SR| Глава 1 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|Index1.htm S|Back.gif H|../index.html S|Menu.gif H|Index3.htm S|For.gif H|Index1.htm S|Back.gif H|../index.html S|Menu.gif H|Index3.htm S|For.gif vti_cachedsvcrellinks:VX|FHUS|Часть1/Index1.htm FSUS|Часть1/Back.gif NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index3.htm FSUS|Часть1/For.gif FHUS|Часть1/Index1.htm FSUS|Часть1/Back.gif NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index3.htm FSUS|Часть1/For.gif vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Feb 2003 16:29:47 -0000 vti_extenderversion:SR|5.0.2.2623 vti_author:SR|HOME\\Женя vti_modifiedby:SR|HOME\\Женя vti_timecreated:TR|11 Nov 2002 15:57:48 -0000 vti_title:SR| Глава 1 vti_lineageid:SR|{2571F18D-5C01-426E-9886-8FD38C4C9522} vti_backlinkinfo:VX|Часть1/Index4.htm Часть1/Index2.htm Часть1/Index.htm vti_nexttolasttimemodified:TW|11 Nov 2002 15:57:48 -0000 vti_cacheddtm:TX|13 Feb 2003 16:29:48 -0000 vti_filesize:IR|7793 vti_cachedtitle:SR| Глава 1 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|Index2.htm S|Back.gif H|../index.html S|Menu.gif H|Index4.htm S|For.gif S|Index4.htm H|Index2.htm S|Back.gif H|../index.html S|Menu.gif H|Index4.htm S|For.gif S|Index4.htm vti_cachedsvcrellinks:VX|FHUS|Часть1/Index2.htm FSUS|Часть1/Back.gif NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index4.htm FSUS|Часть1/For.gif FSUS|Часть1/Index4.htm FHUS|Часть1/Index2.htm FSUS|Часть1/Back.gif NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index4.htm FSUS|Часть1/For.gif FSUS|Часть1/Index4.htm vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Feb 2003 16:30:31 -0000 vti_extenderversion:SR|5.0.2.2623 vti_author:SR|HOME\\Женя vti_modifiedby:SR|HOME\\Женя vti_timecreated:TR|11 Nov 2002 16:54:40 -0000 vti_title:SR| Глава 1 vti_lineageid:SR|{0DED2B42-5C90-4AC0-9DD1-4D1AA5C3713A} vti_backlinkinfo:VX|Часть1/Index5.htm Часть1/Index6.htm Часть1/Index3.htm Часть1/Index4.htm Часть1/Index.htm vti_nexttolasttimemodified:TW|11 Nov 2002 16:54:40 -0000 vti_cacheddtm:TX|13 Feb 2003 16:30:32 -0000 vti_filesize:IR|17398 vti_cachedtitle:SR| Глава 1 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|Index3.htm S|Back.gif H|../index.html S|Menu.gif H|Index5.htm S|For.gif S|Index4.htm H|Index3.htm S|Back.gif H|../index.html S|Menu.gif H|Index5.htm S|For.gif S|Index4.htm vti_cachedsvcrellinks:VX|FHUS|Часть1/Index3.htm FSUS|Часть1/Back.gif NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index5.htm FSUS|Часть1/For.gif FSUS|Часть1/Index4.htm FHUS|Часть1/Index3.htm FSUS|Часть1/Back.gif NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index5.htm FSUS|Часть1/For.gif FSUS|Часть1/Index4.htm vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Feb 2003 16:31:21 -0000 vti_extenderversion:SR|5.0.2.2623 vti_author:SR|HOME\\Женя vti_modifiedby:SR|HOME\\Женя vti_timecreated:TR|11 Nov 2002 16:55:12 -0000 vti_title:SR| Глава 1 vti_lineageid:SR|{D99D014E-CC6A-489F-A953-BB3614E06974} vti_backlinkinfo:VX|Часть1/Index6.htm Часть1/Index4.htm Часть1/Index.htm vti_nexttolasttimemodified:TW|11 Nov 2002 16:55:12 -0000 vti_cacheddtm:TX|13 Feb 2003 16:31:22 -0000 vti_filesize:IR|3991 vti_cachedtitle:SR| Глава 1 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|Index4.htm S|Back.gif H|../index.html S|Menu.gif H|Index4.htm S|Back.gif H|../index.html S|Menu.gif vti_cachedsvcrellinks:VX|FHUS|Часть1/Index4.htm FSUS|Часть1/Back.gif NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index4.htm FSUS|Часть1/Back.gif NHUS|index.html FSUS|Часть1/Menu.gif vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|11 Nov 2002 16:56:08 -0000 vti_extenderversion:SR|5.0.2.2623 vti_author:SR|HOME\\Женя vti_modifiedby:SR|HOME\\Женя vti_timecreated:TR|11 Nov 2002 16:56:08 -0000 vti_cacheddtm:TX|11 Nov 2002 16:56:08 -0000 vti_filesize:IR|1334 vti_cachedtitle:SR| Глава 1 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|Index5.htm S|Back.gif H|../index.html S|Menu.gif H|Index6.htm S|For.gif S|Index4.htm H|Index5.htm S|Back.gif H|../index.html S|Menu.gif H|Index6.htm S|For.gif S|Index4.htm vti_cachedsvcrellinks:VX|FHUS|Часть1/Index5.htm FSUS|Часть1/Back.gif NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index6.htm FSUS|Часть1/For.gif FSUS|Часть1/Index4.htm FHUS|Часть1/Index5.htm FSUS|Часть1/Back.gif NHUS|index.html FSUS|Часть1/Menu.gif FHUS|Часть1/Index6.htm FSUS|Часть1/For.gif FSUS|Часть1/Index4.htm vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0 vti_title:SR| Глава 1 vti_lineageid:SR|{274E3377-05D8-412E-85CD-B5B950D8849E} vti_backlinkinfo:VX|Часть1/Index6.htm


Глава 1

Часть вторая.
Введение в Microsoft Publisher 2002 XP
  • Верстальная программа — ее свойства и задачи
  • Интерфейс №1 Microsoft Publisher (I)
  • Интерфейс №1 Microsoft Publisher (II)
  • Командное меню «Файл» (I)
  • Командное меню «Файл» (II)
  • Командное меню «Правка» (I)
  • Командное меню «Правка» (II)
  • Командное меню «Вид» (I)
  • Командное меню «Вид» (II)
  • Цветовые системы
  • Командное меню «Вставка» (I)
  • Командное меню «Вставка» (II)


Глава 1

Верстальная программа - ее свойства и задачи

Начнем издалека.

Еще несколько лет назад, работая над книгой «Домашний компьютер», я высказал нечто вроде прогноза, что если унификация пакета Office пойдет и дальше такими темпами, то Билл Гейтс придумает и графическую программу, и программу верстки. Верстать, как уже говорилось, можно и в «Ворде», но Word, он хоть и напичкан всевозможными параметрами форматирования, для верстки все же не приспособлен или, скажем, приспособлен плоховато. Он не умеет держать на месте строчки, особенно если у вас получилось, независимо от вашего желания, так, что абзац, начинавшийся на одной странице, последние свои строки (парочку-троечку) перебросил на следующую. Вот эти следующие строчки и начинают издеваться над вами: то они все перепрыгнут на прошлую страницу, то потянут за собой с той страницы одну-две строки. И так далее. Неприспособленность Word к верстальным делам выматывает пользователя, который, не умея работать в истинно верстальной MS Publisher программе, захотел выполнить в «Ворде» какой-нибудь буклетик к столетию любимого шефа или для чего-нибудь соответствующего. Редкость занятий версткой подсказывает пользователю, что один раз и так сойдет, что авось все образуется... В результате можно заработать нервный срыв, гипертонию, инвалидность.

Когда-то я тоже сверстал в Word несколько материалов, в том числе книги, газеты, буклеты, журнал. Но происходило это от бедности: я все никак не мог модернизировать свой ПК, ему катастрофически не хватало памяти. Представьте себе пользователя, пишущего компьютерную книгу (в смысле, книгу о домашнем компьютере), вынужденного весь текст набирать и верстать в «Ворде» (вставляя в текст все те картинки, что существуют и в этой книге, — то есть не обкрадывая читателя по части изобразительного ряда), потому что у него на диске осталось свободного пространства всего 30 мегабайт, на которые не только ни одна уважающая себя программа не установится, но и с которыми вообще опасно работать: того и гляди накроется хард-диск. Технологически же это выглядело и вовсе смешно. Напишу на 5 мегов, заархивирую — и, перебросив это на дискету, бегу к посреднику, сбрасываю на его ПК весь материал. Там проверяю материал вторично, правлю (после разархивирования Word может запросто потерять все свои форматы, да и картинки частенько терялись), временами кое-что дописываю на месте, переделываю картинки и так далее. Приезжаю домой, бросаюсь к своему аппарату и с радостью неописуемой выбрасываю с него все 5 мегабайт, которые с таким трудом наработаны в течение долгого времени. И у меня опять остается 30 Мб свободного пространства. А ведь всем давно известно, что операционная система работает стабильно и уверенно, если на жестком диске есть по меньшей мере треть чистого пространства от общего его объема. Представьте: Windows 98 занимает примерно 650 Мб, Офис 97 еще 150 Мб (уже 800), а кроме того нужны Фотошоп (50-60 Мб), CorelDRAW (100-120 Мб), еще что-то... У меня к тому времени набралось работ бесчисленное множество по разным поводам и на разные темы, из них одна книга размером в 100 Мб (там были составные «вордовские» картинки — каждая размером от 7 до 11 Мб, и всего их было 8-9 штук). Вот и получается, что «мощный» диск размером в 1,1 Гб у меня был перегружен, хотя еще за год до того момента я считал, что теперь эта модернизация на всю жизнь.

Кажется, именно в той книге и была высказана мной мысль о том, что Майкрософт пойдет по пути устранения конкурентов не экономическим, а технологическим путем. Правда, пока Майкрософт занималась разработкой новой операционной системы (сначала Windows 95, потом 98, потом 2000, не считая NT, потом 2002...), фирмы Corel, Adobe, Quark и другие преспокойно занимались себе единственной версией одной-единственной программы-приложения. Правда, и это не так: Corel разрабатывала блестящий пакет CorelDRAW, да и была первой, кто начал работать в окнах Windows! Adobe также напридумывала не только программ для верстки, но и выпустила великолепный «Иллюстратор» (близкая к CorelDRAW программа, не ставшая популярной лишь из-за серенького невзрачного интерфейса, в то время как в CorelDRAW интерфейс всегда веселый, жизнерадостный, как бы только что из баньки), сверхвеликолепный Adobe Photoshop, которому и сейчас почти нет равных... Ну, и прочие утилиты и приложения.

Некогда было Корпорации Майкрософт заниматься частностями, но начиная с Офиса 95 фирма находит силы и, главное, время, чтоб конкурировать. И успешно! Непревзойденный пакет Microsoft Office, куда, конечно, входит всегда самый последний Word, стал вторым крючком, на который Майкрософт зацепила пользователя, кажется, настолько основательно, что очень скоро не станет и вовсе никаких альтернатив.

Это, конечно, плохо, когда монополист начинает диктовать всему миру свою волю. От этого не в выигрыше ни конкуренты, уже перестающие таковыми быть, ни пользователи. Но одно дело быть монополистом, к примеру, в угольной промышленности (клиенту все равно, кто добывает и доставляет ему уголек: самое главное, чтоб доставили), где качество угля зависит от месторождения, и только, а совсем иное дело — держать монополию в области ПК. Пользователь не дурак, ему нужно, чтобы все программные решения соответствовали его пользовательским задачам. Если этого нет, он немедленно переключится на другую фирму, пусть даже непопулярную, но которая в своем приложении решила все пользовательские проблемы и пользоваться которым гораздо проще, чем продуктом монополиста. Именно эти нюансы должны учитывать монополисты Майкрософт, создавая очередной шедевр.

Прямо надо сказать, работа над ХР не прошла даром: получилась операционная среда, которая, несмотря на недоработки, выглядит очень и очень привлекательно, задавила многие приложения, отодвинув их на второй план. К примеру, FineReader, как говорилось, стал в одночасье неактуальным. Фирма, его производящая, наступила на свои же грабли: она так беспокоилась о своей программе, такие поставила замки против взлома, так доняла всех своей серьезностью отношения к самой себе, что многие российские хакеры еще несколько лет назад посчитали своим долгом расправиться с этой чопорностью и выпустили на рынок массу взломанных версий FineReader 3,0, потом 4,0, а теперь, совсем недавно, версию 5,0. Взломаны они разными способами, но все работоспособны. Правда, учреждения и организации платили и платят и за лицензированные версии, но ведь программа сканирования текста необходима прежде всего не в офисе, а домашнему пользователю! Ну, какой дурак в офисе станет сканировать текст документа (его потом надо еще править), когда под руками всегда есть ксерокс? Дома же работает над своими собственными произведениями масса литературных, научных и технических работников, других пользователей, которым отсканировать текст, причем быстро и качественно, гораздо важнее. Есть множество мелких коллективчиков, выпускающих буклеты, брошюрки, газетки и газетенки, которым также необходим FineReader...

И вот Майкрософт выпускает пакет Средства Microsoft Office, где есть программы сканирования картинок и текста!

Причем Microsoft Office Document Scanning (и Imaging, конечно, утилита сканирования изображений) сканирует текст нисколько не хуже, чем FineReader. А может быть, и лучше! Со временем — всего-то через месяц работы со Средствами Майкрософт — стало ясно: сканирование и распознавание идет лучше!

У FineReader есть одна сомнительная услуга: возможность правки отсканированного текста прямо на месте — здесь же, в программе FineReader. Это серьезно, этого нет в майкрософтовекой программе (хотя беру свои слова обратно, — возможно, и есть, не пробовал). Но только представьте себе: зачем это нужно!..

Допустим, FineReader установлен в офисе, на мощном компьютере, на котором ежеминутно что-нибудь сканируется. Станет человек, который сидит на сканере и на этой программе, заниматься правкой на месте? — Конечно, нет! Он сбросит на дискету отсканированный материал, и сбросит его не в формате пакета FineReader (99%!), а в формате ТХТ или Word. Или еще в каком-нибудь приемлемом для заказчика формате. Если у заказчика нет своего сканера, то у него нет и программы FineReader. Значит, править он будет на своем ПК, в другой программе, скорее всего, Word. Необходимость в правке на месте отпадает: просто нет физических предпосылок для этого.

Теперь представьте, что сканер у вас дома, вы отсканировали текст на своем сканере и можете править этот текст сколько душе угодно прямо в программе FineReader!.. Однако и дома, на кухне, вы этого делать не станете. Во-первых, вся ваша деятельность заключается далеко не в сканировании текстов, а в их производстве. То есть вы сами набираете свой текст, или набираете текст чужой, или сканируете его. Но весь комплект существующих у вас текстов сохранен не в пакете же FineReader, а скорее всего в Microsoft Word какой-либо версии. Логично было бы сразу же перебросить текст в формат *.doc и заняться привычным вам делом в знакомой, исхоженной вдоль и поперек и, к тому же, любилюй программе. Любимой при всех ее недостатках. Значит, опция правки текста, навязываемая нам програм!-мой FineReader, практически не нужна.

Теперь припомним, в каком виде FineReader экспортирует текст. Как только отсканированные двадцать страниц попадают в Word и вы начинаете править текст, вам это вполне удается, пока вы находитесь в разделе текста, отсканированного с первой страницы оригинала. Но вот вы доходите до начала второй страницы оригинала (в документе, полученном от сканирования, назначено другое форматирование, потому что оригиналом может быть абсолютно любой текст — хоть с пишущей машинки, — а у вас всегда строгое решение Word), и начинаются проблемы: то этот текст не хочет присоединяться к первому, то, все же сумев его присоединить, вы обнаруживаете, что форматирование исправленного начала вдруг поменялось: текст приобрел вид необработанной второй страницы и последующих страниц. К тому же, громадные куски пустого пространства между одной отсканированной страницей и другой — они в скором времени способны привести вас в бешенство. Еще и потому, что, всякий раз испытывая проблемы с присоединением кусков, вы теряете форматирование уже обработанного текста.

Чем ближе к концу документа, тем это раздражает все больше: частенько весь исправленный текст делается неудобоваримым, вам постоянно приходится скакать по всему документу, исправляя начало, которое все вырастает и вырастает... Да что говорить, намучался я с этой замечательной программой FineReader предостаточно.

Совсем не то в Средствах Майкрософт. Когда я отсканировал две странички, промежутка между первой и второй страницей не оказалось. То есть править можно, приложение (всего-навсего утилита!) ведет себя вполне корректно. И на что мне FineReader? Тем более что Майкрософт делает ничуть не больше (а то и меньше) явных ошибок, — когда букву «н», к примеру, воспринимает как «i-i». Ни одна из программ сканирования не сканирует на сто процентов правильно русский текст, поскольку все программы нерусские. Камень в огород отечественных программистов (или изготовителей сканеров).

А для чего вообще Майкрософт придумала свои Средства Microsoft Office? He отмазка ли это? Не липа ли?.. По большому счету они, эти Средства, могут быть, а Могут и не быть. Понимание этого и некое недоумение преследовало меня целый месяц. В чем дело? Где высший смысл этой придумки по имени «Средства Microsoft Office»?.. Там пользователя непосредственно касаются всего-то 2-3 опции.

Оказывается, смысл, в том числе и высший, есть. Безусловно есть.

Дело в том, что Корпорация Майкрософт прибирает к рукам все сферы деятельности крупнейших фирм, которые производят мощные программы-приложения, основанные на Windows. He пощадили никого! Только Corel вроде бы осталась на плаву. Да и то под вопросом...

Мировое господство Майкрософт неуклонно наступает.

Мне кажется, что в течение этого прошедшего года, пока государство (США) нападает на Microsoft, остальные фирмы, радуясь «неуспехам» Майкрософт, почивали на лаврах, только следя за тем, как побивается нехороший (он с Тотошей и Кокошей по аллеям не проходил) Билл Гейтс. А в результате Майкрософт говорит новое слово в программном обеспечении (т. е. выпускает Windows XP), а конкуренты выпускают просто версии известных программ. Майкрософт выпускает операционную систему нового поколения (очень важное событие!), а конкуренты — жалкие римейки прошлого. Что ж, виват Билл Гейтс!

Мне предстоит описать еще новую версию PageMaker 7,0. Я смотрел, версия замечательная. Там прибавилась Панель управления (в отличие от прошлых нескольких версий, общее имя которым — 6,5), прибавились некоторые или даже многие частности, но назвать это громким именем «революция» — очень сложно. А вот Windows ХР — действительно революция. Это — круто! Несмотря на все недостатки, которые, впрочем, обязательно ликвидируются в «Update» — добавлениях и исправлениях, а может быть — в новых прибавлениях к имени программы, как это было с Windows 98 (Windows 98SE, SE2 и так далее, вплоть до Миллениума), — то есть как бы в новых версиях. Фирмы проспали свой взлет, не проспала только побиваемая Корпорация Майкрософт, честь ей и хвала! Тем более что в это время ее как раз только одну и дергало американское правительство со своим пресловутым анти монопольным законом. Слава Богу, монополия оказалась Корпорацией Майкрософт, которой нельзя отказать в интеллигентности...

Жизнь доказала: выживает сильнейший, в данном конкретном случае — монополия. Видимо, в процессе Майкрософт поступала еще и по принципу «всем сеет рам по серьгам». Кто не «катил на нее бочку» (возможно, Corel), тот и остался хотя бы при своих. Остальные получили по заслугам...

Фокус оказался весьма прост. Но не банален: Microsoft приготовила мощны» удар по конкурентам — придумала-таки верстальную программу Microsoft Publisher 2002!

Как почему-то и все верстальные программы, программа Publisher официально не ставит своей целью верстать полноценную книжку или газету или журнал, но говорит о том, что она способна помочь пользователю «сделать небольшое представление с картинками», «рекламный листок» или «несколько страниц оформленного текста с оригинальными шрифтами». На самом деле, поверьте мне, это не что иное, как полновесный верстальный продукт. А скромность, на которую можно и купиться, говорит лишь об опасении, что вдруг да и не получится по-настоящему выдержать весь процесс верстки? Не краснеть же перед пользователем, когда дело малоосвоенное... Нет, прекрасная верстальная программа, в своем лице совместившая многие достоинства и QuarkXPress, и PageMaker. Есть здесь и мотивы «Иллюстратора», и приемы Adobe InDesigh... В общем, как в свое время IBM постаралась и из известных продуктов сформировала то, что мы ныне называем ПК открытой архитектуры, так Майкрософт унифицировала верстальные программы, совместив их в одну. Куда там Apple со своими сложнейшими назначениями и скучнейшей рутинной работой! Хотя наверняка Майкрософт позаимствовала приемы и там.

Итак, верстка. Что такое — верстать?

Верстка включает в себя искусство правильно разместить на странице (полосе) тексты, изображения, логотипы, другие знаки, а также (особенно это касается текста) привести текст средствами верстальной программы в такой вид, чтобы он полностью соответствовал принципам верстки.

Принципы эти заложены, слава Богу, еще до изобретения компьютерного изготовления книжек, соответственно в верстке участвовали и до сих пор участвуют опытные специалисты прошлого, то есть тех времен, которые отмечены принципами высокой печати и, конечно же, ручным (только кое в чем автоматизированным) набором текстов Соответственно гранки — это и сейчас гранки, хотя и сильно отличающиеся от тех, что были прежде. Обработка свинцовых пластов или барабанов с текстом нас не касается, да я точно и не знаю, назывались ли они матрицами или штампами, какова была точно та технология, но теперь для нас, готовящих на домашнем компьютере целиком всю; I. книгу, вплоть до вывода типографских пленок, это и не столь важно. Программа верстки должна выдерживать самое главное — все принципы верстки, которые, если от них не отступать, позволяют сделать все не только красиво, но и правильно. Добавлю только то, о чем упустил сказать раньше. Для верстальной программы практически безразлично, насколько текст, находящийся в буфере, отформатирован. Все настройки форматирования текста мы назначаем опять же в самом приложении. Задачи форматирования — это переносы, выравнивание текста, шрифт и его размер. Все это мы увидим в опциях командных меню. Но она невозможна и без кое-каких других настроек.

Идем дальше. Жидкая строка получается в книге очень часто — чаще чем плотная. Это происходит от того обстоятельства, что программа, восприняв словарный язык русский, разбивая строки переносами, игнорирует иностранные слова. Именно длина этих непонятых программой слов и порождает жидкие строки: на всякий случай программа выбрасывает какое-нибудь длинное русское слово в следующую строку (хотя перенос ему вполне можно было назначить) или оставляет его на предыдущей. Тут вступает в силу опция назначения переноса. То есть мы можем назначить длинному русскому слову ручной перенос, и слово попадет частично на прошлую строку, таким образом ликвидировав ее «жидкость». Плотные же строки практически не могут родиться при работе верстальной программы без прилагаемых со стороны пользователя усилий, то есть по умолчанию. Плотная строка образуется, как правило, когда мы ее доводим до этого состояния своими действиями — например, стараясь убрать небольшой «хвостик» текста из последней строки абзаца. Или загоняя тире, выскочившее в начало строки (этого делать категорически нельзя!), в предыдущую строку... ,

Теперь что касается висячих строк. Здесь понятие висячей строки от незыблемого уже несколько ушло в «демократичное». Что такое висячая строка! Это понятно из самого определения: строка, которая повисла. Чаще всего это одна из строк предыдущего абзаца, которая из-за длины фразы попала с предыдущей страницы на ту, где она теперь (с колонками в газете то же самое). Строка может оказаться полной, то есть содержащей то число знаков, на которое как раз разбита книжная строка. Тогда некоторые издатели уже считают, что строка не висит, и пропускают ее. На самом деле это по старым канонам все равно висячая строка, поскольку она — всего лишь одна строка от предыдущего абзаца, и с нею надо что-то делать. Но подобное обстоятельство еще не может быть самым страшным. Самый непрофессиональный вариант в данном случае тот, когда от этой строки на новую страницу попало всего несколько знаков. То есть, по сути, образовался «хвост».

И здесь издатели поступают по-разному. Есть такие, которые разжижают предыдущую строку, добавляя в висячую еще какое-то количество знаков. Это делается за счет трекинга — межсимвольного интервала. Тогда для них строка получается как бы и не висячей. Но это как раз все еще крайний, непрофессиональный вариант. Если считать правильно, то такая строка вовсе не должна находиться на этой новой странице (или строке). То есть соответственно ее нужно было бы, наоборот, уплотнить: тогда она целиком уместилась бы на предыдущей странице, и вопрос бы снялся.

Особенно неприятным моментом является перескок строки с предыдущей нечетной страницы на последующую четную. То есть, как вы понимаете, на стадии перелистывания книги! Такую строку в XIX и начале XX века типографы звали вовсе, извините за выражение, «блядской». Это не ругательство, хотя слово и ругательное, но на старом типографском языке (взгляните в словари уважаемых авторов) оно было чисто профессиональным. Потому что описанного нонсенса в типографиях прошлого не должно было быть, а работников, допустивших это, увольняли. Мне кажется, слово пришло из далекого, очень далекого прошлого, со времен Ивана Федорова (а может быть, еще от переписчиков рукописных книг), когда этим словом пользовались даже в житиях святых, поскольку оно было просто легкоругательным, типа слова «собака», когда мы произносим его в сердцах. А житие протопопа Аввакума и вовсе изобилует этим словом.

Ну, да ладно, я отвлекся. Идем дальше.

Столь же висячей строкой является и строка последующего абзаца, которая оказалась на предыдущей странице. Однако многие издатели допускают ее присутствие на предыдущей странице, вовсе не считая ее висячей по той причине, что она полная. Ну, во-первых, она всегда как раз формально неполная, поскольку абзац начинается с красной строки.,.

А что страшного в том, спросите вы, что строка оказалась там, где она оказалась? Неужели эстетика (возможно, и ложная) перебьет сам смысл того, что напечатано в той строке? Ведь если книга интересная, мы и не заметим никаких висячих строк, увлекшись содержанием...

Нет, не все так просто. Вопрос возникал, кажется, с самого начала не из-за эстетики текста. Мешала технология изготовления типографских форм. По этой технологии положено было каждой верхней строке каждой страницы быть полной. Исключением было, кажется, лишь то, когда бы эта строка начиналась с абзаца, то есть с наличия в полной строке красной строки.

Специально я не выяснял, но мне думается, что и последняя строка страницы также должна была быть полной. Тогда бы здесь сам собою и возник вопрос о неполности строки из-за присутствия в ней красной строки. Вполне возможно, что именно поэтому такая строка считалась висячей.

Возникновением колонтитула мы обязаны, думаю, как раз этому обстоятельству. То есть колонтитул вполне мог родиться как решение избежать первой (а то и последней) висячей, неполной строки. Тогда форма в типографии изготавливалась уже более-менее правильно. Впрочем, вопрос эстетики здесь тоже нельзя сбрасывать со счетов. О колонтитуле мы еще поговорим, сейчас же хочу лишь добавить, что издатели, которым хочется не обращать внимания на висячую верхнюю и нижнюю строку, пользуются для своего оправдания как раз наличием нижнего и верхнего колонтитула, что, конечно, очень удручает.

Вернемся к жидким и плотным строкам: я не сказал о маленьких нюансах, когда приходится все же применять трекинг, даже если строки и не отмечены программой как плотные или жидкие. Почему?

Потому что опять же традиция верстки требует, чтобы строчка не начиналась с тире, не начиналась с короткого остатка слова от предыдущей фразы, не кончалась коротким словом с заглавной буквы (началом нового предложения) типа предлога «О» во фразе «О бедном гусаре замолвите слово». Это, может быть, и слишком изысканная верстка, но именно ею пользуются и ее отстаивают самые приличные издательства. Поэтому искусственно плотные и искусственно жидкие строки есть в каждом тексте, почти на каждой странице. Назначая в переносах (по умолчанию) три знака для предыдущей и два знака для последующей строки, авторы никак не рекомендуют вам оставлять два или три знака от нового предложения, будь оно даже и внутри абзаца. Все это называется среди верстальщиков «хвостами» и должно быть также ликвидировано. Потому верстка и есть работа кропотливая, не для непосед.

Во время сжатия нам не столь важна короткость фраз, сколь короткость абзацев. А в некоторых текстах бывает именно множество коротких абзацев — от половины строки до полутора строк. Если эта строка — из короткого абзаца, мы не сможем ужать текст почти на 30 процентов: абсурд! Значит, прежде всего убеждаемся, не принадлежит ли данная висячая строка короткому абзацу. Но даже если абзац обширный, строк в пять, и то нам придется ужимать эту висячую строку на 6—7 процентов, а это также большая величина для трекинга.

Или, если строка занимает примерно лишь треть целой, нас она все же не устроит. Почему? Потому что в уважающих себя издательствах строка, занятая менее чем на половину, тоже считается висячей. Я не склонен считать это блажью и стараюсь также следовать этому принципу. Правда, такой строгий принцип касается все же объемных абзацев — по 10 и более строк, где ничего не стоит придать или целому абзацу, или только части абзаца — всего 0, 01 дополнения к круглой шпации. Это термин типографский, он обозначает стандартный интервал между знаками.

И еще: верстка всегда должна начинаться с самой первой строки текста

Потом мы должны завершить первый этап работы на первом абзаце и уж только после этого перейти ко второму. И так далее. Это первое правило верстальщика. Иначе будете постоянно перевёрстывать!

И еще. Нельзя верстальщику решать за автора: если у автора всего 70 знаков в абзаце, приходится лишь попытаться получше выглядеть. Не ему, а вам. Ведь чтобы ужать строку, представьте, вам надо ужать ее на 4/70-х, то есть почти на 6 процентов. А это уже очень и очень заметно читателю, так что, возможно, лучше всего оставить все, как оно есть, и с вас не спросит никто. Да и невозможно спросить с верстальщика ни за Пушкина, ни за академика Иванова-Панкратова: когда они писали сказку или научную книгу, они вовсе не обязаны были думать о ваших законах полиграфии, — им было важно донести до своего читателя мысль, причем в том ритме, в котором они ее хотели донести.

«Хвостики» в пару знаков с точкой все же обязательно убираются. Или вожмите их, или растяните до шести-семи знаков. Я, к примеру, начинаю работать с подобного рода абзацами лишь тогда, когда сам абзац составляет но менее 4-х строк в книге и не менее 7—8 строк в газетной колонке. Нельзя решать за автора разбивку на абзацы только j для того, чтоб вам было полегче.

Обычно значения трекинга, которые вы встретите в верстке книги, которую читаете, не больше 0,04 либо в ту, либо в другую сторону. Только иногда приходится увеличивать значения его до уровня примерно 0,08: это бывает тогда, когда на странице расположен очень важный для читателя (или издателя) рисунок, а количества текста от одного рисунка до второго (следующего) не хватает, чтоб абзац заполнил остаток страницы. Так искусственно растягивается не только строка, но чаще всего абзац. Соответственно и ужимается. Однако сжатие больше чем на 0,05 вообще очень не рекомендуется, ибо текст становится трудночитаемым. То есть соответственно при сжатии более плотном обязательно требуется и участие других опций — к примеру, интерлиньяжа или кернинга. А то и того и другого вместе. Но разрядка, если она очень жидкая, не особенно прибавит красоты вашему тексту. Собственно как и сжатие символов.

Но можно сжать текст, уменьшив значение интерлиньяжа. При величине кегля 11 одинарный, нормальный интерлиньяж, установленный программой по умолчанию, составляет 13,2 пункта. Можно ужать его не более чем до 12,0. Допустимо, конечно, и значение 11,0, при котором текст себя еще неплохо чувствует. А иногда бывает просто необходимо опустить межстрочный интервал до величины 10,0 и даже ниже. Однако несколько строк, подвергнутых такому насилию, сразу отличимы от тех строк текста, которых экзекуция не коснулась. Поэтому интерлиньяжем лучше работать очень и очень умеренно.

Теперь немного поговорим о терминах.

Трекинг — межсимвольный сдвиг шпации, а что такое кернинг? Кернинг — это ситуация, когда не только отсутствует межсимвольный интервал, но и имеет отрицательное значение. Когда это происходит?

Существуют символы, у которых, как у буквы У, свободен правый нижний угол. У Т он посвободнее, а у Г, например, самый свободный. Почти то же у Р, Ф. Закон зрительного восприятия говорит о том, что если после таких знаков стоит строчный знак с незаполненным левым верхним углом (к примеру, буква л), то прописная буква как бы отрывается от слова. Соответственно трекинг здесь не нужен. При определенных обстоятельствах можно варьировать кернингом, задавая и его значения.

Интерлиньяж — это межстрочный интервал от одной базовой линии до другой. По базовой линии выстраиваются все знаки строки — и прописные, и строчные. При этом нижний выносной элемент (буквы у, р, д, щ и т. д.) находится ниже базовой линии. Злоупотребление уменьшением интерлиньяжа может привести к тому, что эти нижние выносные элементы могут «сесть на голову» верхним выносным элементам других знаков или прописным буквам.

Вот, кажется, все основное, что касается принципов текстовой верстки.

Если говорить об иллюстрациях, то здесь практически нет единых законов, кроме художественной целесообразности и эстетического результата. Есть некоторые принципы, да и то традиционные для верстальных издательских программ, в том числе те опции, о которых мы поговорим: если, к примеру, растянуть иллюстрацию до блока, то может получиться так, что иллюстрация утеряет свои пропорции. Поэтому лучше растянуть блок до размера иллюстрации. Но это может привести к тому, что иллюстрация окажется не на том месте, который устроил бы читателя по эстетическим соображениям.

В каждом конкретном случае верстальщику приходится быть еще и художником, дизайнером. Впрочем, это творчество, а творчество всегда интересно.

История вопроса компьютерной верстки уходит в уже достаточно далекое прошлое, о котором хотелось бы немного сказать.

В середине 80-х годов я, инженер-проектировщик, учившийся в начале 70-х и твердо знающий, что ЭВМ — это очень сложно и скорее всего не для меня (не люблю электронику, хотя сам довольно близок к ней — инженер-электрик по специальности «светотехника»), весьма уважительно относился к вычислительным центрам, обладавшим мощными машинами и содержавшим приличный штат обслуживающего персонала, который я также воспринимал с трепетом: еще бы! — ведь они знали какие-то «фортраны», какие-то «бейсики»... (я и не догадывался, что это Basic Билла Гейтса). К ним на ВЦ стояли в очередь НИИ и другие организации, которым очень требовалось что-то срочно и сложно рассчитать, и программа «машинных часов» (так называлось время пользования электронно-вычислительной машиной) была расписана вперед на много месяцев. Важность этих работников и самой ЭВМ была для меня несомненной, я не мог представить, что когда-нибудь вдруг возникнет время иное — время невостребованности громадной ЭВМ, что когда-нибудь эти работники, большие специалисты в своей узкой области — программисты и операторы ЭВМ — станут никому не нужными и едва ли не пойдут по миру с протянутой рукой. Увы, такое время тогда, в 1985-м году, было уже не за горами.

А в Америке оно уже наступило: сотни и тысячи программистов с начала восьмидесятых годов становились все более ненужными. Почему? Потому что с 1981 года, как вы помните, стали поступать на рынок и пользоваться популярностью персональные компьютеры. Фактически каждый из этих аппаратов заменял собой те громадные ЭВМ на вычислительных центрах, о которых я говорил. Естественно, спрос на ЭВМ мгновенно спал, и спецы остались не у дел. Многих и многих программистов по увольняли или, по крайней мере, предупредили, что скоро в их услугах перестанут нуждаться. Минимум несколько тысяч людей остались наедине со своей профессией. Прогресс — он всегда достаточно жесток, а особенно сейчас, когда все стало меняться молниеносно.

Однако не о плохом я хотел вам поведать. Группа безработных программистов одного из ВЦ в США была отпущена в последний на этой фирме отпуск и предупреждена, что по возвращении получит полный расчет. Невеселым выдался отпуск. Один из приятелей предложил:

— Кто знает, как сложится дальше жизнь! Давайте-ка посвятим этот наш мрачный отпуск путешествию по стране?

Друзья нехотя, но согласились. Вскоре они отправились в путь. Заезжали, забредали в самое захолустье. Вероятно, делалось это нарочно — чтоб на девственной природе забыться и не вспоминать, что вскоре их всех ждет безработица, неизвестность... Собственно, все то, что мы теперь и сами знаем не понаслышке.

Но тут вдруг... Точно в сказке, безработным программистам улыбнулась удача. Пришла она в виде мистического знака.

Дело было так. Они забрели в какую-то очень старую и очень далекую деревушку, а там был небольшой католический храм, и в нем по счастливой случайности сохранилась одна древняя церковная книга XIV века. Священник позволил, и друзья открыли эту книгу...

— Что-то я не припомню такого шрифта, — сказал один.

— О, это давний шрифт! — ответил священник. — Его изобрел Элдас Манатиус, и называется он Italic.

Друзья переглянулись... Да, что-то похожее на знак они уже почувствовали, только вот не могли сформулировать. Задумчивые, покинули они храм и решили заночевать в этой деревне. Простенькая гостиница раскрыла им свои объятья.

Конечно, никто из них не сомкнул глаз. Но только у одного родилась идея. Правда, история умалчивает его имя.

Наутро они переговорили и... решили открыть собственную фирму. Какую?

Они уже поняли, что как в Англии паровая сила в свое время вытеснила с фабрик сотни тысяч рабочих, так и их вытеснил с их рабочих мест — компьютер. Не использовать ли его вытесняющую силу себе во благо? — решили они.

Да, фирма была программистская. Да, она ориентировалась на ПК, которые с каждым днем становились все популярнее. Но... Они решили создать громадную по сложности для тогдашнего времени программу, которая бы не только вставляла в документ какой угодно шрифт, но и делала вёрстку его. Это было, сами понимаете, озарение, хотя причины его можно назвать невеселыми...

Так через месяц родилась первая верстальная программа. Ее закупила фирма Apple, и в 1985 году под маркой этой фирмы вышла в свет издательская верстальная программа PageMaker для «Макинтоша». Так родились на Apple издательские станции «Макинтош». Они работают и приносят пользу до сих пор, хотя и на других версиях верстальных программ, в том числе и на QuarkXPress для Мае.

Фирма Adobe позднее выпустила свой Adobe PageMaker, но он получил большее распространение, поскольку работал в IBM-совместимых компьютерах, которые заполонили мир. Первой же была программа, с которой началась революция в издательском деле, и называлась эта программа Aldus PageMaker. Вот чем закончилось для безработных друзей путешествие по Америке. Имя итальянского монаха — Элдас — было зафиксировано в имени фирмы и программы.

Такая вот легенда из новейшей, если можно так выразиться, истории.

Но «адобовский» PageMaker не был первой верстальной программой в компьютерных системах IBM. Первой была Ventura Publisher, вышедшая не намного позже, чем программа «Макинтоша». Видимо, идея уже носилась в воздухе. К тому же эта программа, разработанная фирмой Xerox, многое учла из недоработок Aldus PageMaker и стала на долгое время лучшей (многие и сейчас вспоминают ее с теплотой и искренним уважением, а есть и работающие в ней, за что им честь и хвала). Ventura лучше форматировала текст и была годной не только для буклетов, газет и небольших журналов, но и для того, чтобы верстать книги громадного объема.

Постепенно и издательства стали переходить на новый способ верстки и распечатывания книг.

Помогли ведущие фирмы, начавшие выпускать высококачественные офсетные машины, фотонаборные автоматы цифровой печати высокого качества, основой которых стали компьютерные разработки: ведь только на компьютере можно было добиться высокой степени разрешения изображений.

Так журнальная продукция (не говоря уж о книжной) сделала решительный скачок.

Некоторые фирмы стали выпускать относительно дешевые мини-типографии, которые при желании можно было разместить даже в квартире. Стоили они от 50 до 100 тысяч долларов. К 1995 году высококачественная мини-типография с большой производительностью стоила уже около 40 000 $.

Но мы все говорим и говорим. А где же сама программа?

Вот ее интерфейс, на рисунке 1.

Рис. 1. Интерфейс программы Microsoft Publisher


Глава 1

Интерфейс №1 Microsoft Publisher (I)

Как вы видите из рисунка 1, все принципы Windows здесь соблюдены. Окно традиционное. Ну, еще бы: ведь автор приложения не кто-нибудь, а сама Корпорация Майкрософт.

Все элементы рабочего окна программы-приложения здесь налицо.

Вот они, сверху вниз: Строка заголовка, Строка командных меню, Строка (в две строки) Панелей управления.

Рабочее пространство, на котором мы пока видим только шаблоны, заготовленные фирмой на все случаи жизни.

Не забыли и докер Здесь он исполняет, в отличие от MS Word 2002 ХР, роль левого окна Навигатора.

Что ж, все очень современно, изобилует гиперссылками...

Потом мы увидим и то, что в Строке состояния, расположенной в нижней части интерфейса, с предельной точностью отражаются координаты курсора.

Вечные майкрософтовские Линейки (горизонтальная и вертикальная) появятся, когда мы вызовем один из вариантов, предлагаемых в работу.

Они, основные линейки, будут серого цвета. Но как только мы нарисуем фрейм (область для впечатывания текста или вставки картинки), на серых линейках высветятся окна, и в пределах этих окон линейки станут активными, черно-белыми. И «оборудованными» движками. А также всеми теми средствами для создания отформатированного текста, что и в Word — знаками табуляции, отступов, выступов, границ текста.

Все в программе предусмотрено.

Программа существует пока отдельно от пакета Офис ХР, но все явно указывает на то, что она станет в него входить. Мало того, она и устанавливается именно в папку Офиса! Это по умолчанию, — я, как пользователь, путей приложению при установке не назначал. Кстати сказать, комплектование Офиса с каждой версией становится сложнее: он уже не помещается на компакт-диск, а тут и еще одна дополнительная программа! Вот и приходится пока оставлять его за бортом.

До каких пор за бортом? Видимо, до тех самых, пока уплотнение (архивация) файлов и дисков не достигнет необходимого уровня. Пока не приостановится бессмысленная, на мой взгляд, гонка за все более мощным железом. Нет, никто не против большего объема, но смешно, если половину из него займет новая программа.

Кстати, программа существует давно, и нам сейчас досталась совсем не первая ее версия. То есть с того момента, как в ней возникла необходимость, возникла и сама программа.

А скорее всего, начиная с новых версий, верстальная майкрософтовская Microsoft Publisher будет входить непосредственно в пакет «Office N», где N — имя версии.

На рисунке 2 мы видим уже целиком рабочий интерфейс приложения. Это значит, что мы вызвали к жизни не шаблон, с которым иногда работать уже почти нет смысла, ибо он сам почти все за вас сделал, а — пустой документ (в программе он называется, как вы заметили, Публикацией).

Рис. 2. Интерфейс № 2 Microsoft Publisher

Ну, взглянули на интерфейс — и все?

Нет. Попробуем что-нибудь сверстать в этой незнакомой, но столь же знакомой нам программе. Однако прежде еще несколько слов.

Поскольку борьба корпораций не затрагивает почти никак интересов российского пользователя и российского пользовательского пространства (говорить о программистском пространстве глупо: мы вовсе никому не конкуренты, хотя через пять-десять лет, я считаю, все в корне изменится), Майкрософт выпустила верстального монстра как бы втихаря. А то, что Publisher не вошел непосредственно в пакет, оставило российского пользователя еще и без русского интерфейса. Последнее вовсе непростительно: российский пользователь ПК — самый благодарный пользователь. Он всегда старается быть на острие прогресса (так мы воспитаны) и не собирается, как многие американцы, все еще работающие в ДОСе, пренебрегать новыми версиями передовых программ. Теперь он вынужден копаться не в программе, а в англо-русском словаре, где американского жаргона (тем более компьютерного) нет и в помине.

Осваивать Publisher, таким образом, весьма затруднительно.

Но в ближайшее же время приложение станет востребовано. Это произойдет по одной очень важной причине: лучше, один раз сходить в ларек и купить комплект дисков с программами одной фирмы, тем более разработавшей саму операционную систему, чем еженедельно мчаться туда с вопросом: а не выпустила ли фирма Adobe совместимую с ХР новую версию верстального PageMaker? A не выпустила ли фирма Quark новые Update? — ведь проблем куча: то это не работает, то то, а то и вовсе русификатор для верстающегося текста забыли заложить ...

Это происходит, как нарочно, практически со всеми новыми версиями известных верстальных программ. В опции подбора языка для работы (не для интерфейса, ладно уж, а для верстки!) можно встретить какой угодно язык, хоть мумбу-юмбу, — но только не русский.

Здесь же один раз приобрести программу — даже с английским интерфейсом, научимся как-нибудь, — и проблема решена. Конечно, Publisher удобнее, вне всяких сомнений.

Недоработка наших хакеров, брокеров и киллеров состоит в том, что для «виндоусовской» верстальной программы у них не нашлось сил и времени для перевода интерфейса, то есть для запуска русификатора, которые, как я подозреваю, похожи один на другой и требуют лишь некоторых строчек новых назначений.

Не любят взломщики русского пользователя!

Вероятно, в этой очень интеллектуальной (по смыслу занятий) среде все же нет теоретика-стратега, который бы заботился о русских (ну, пусть российских) интересах и ставил бы их превыше всего.

Однако перейдем же непосредственно к программе.

Конечно, недостаток этого верстального продукта в том, что он с английским интерфейсом.

Но будем приспосабливаться и изучать.

Начнем с Панели инструментов. Она находится, вполне стандартно, в левой части экрана, левее рабочего поля.

Внизу, ниже всех кнопок Панели, находится кнопочка со стрелкой, очень похожая на те кнопки, что знакомы нам по Word. За ней скрывается меню настройки Панели — исключения и добавления кнопок. Принцип Офиса ХР выдерживается: вы видите на рисунке 3 эти подменю.

Рис. З. Подменю настройки Панели инструментов

Здесь вы видите полный список всех инструментов, заложенных в Панель инструментов. Перед каждым стоит свой флажок — это говорит о том, что все инструменты у нас имеются и активны. Последняя строка Reset Toolbar (Восстановить Панель) фактически закрывает все меню и подменю, которые мы с вами открыли. Но если вы в свое время отказались от того или иного инструмента, эта команда, закрыв меню и подменю, восстановит все исключенные вами инструменты, и кнопки этих инструментов опять будут присутствовать на Панели.

Но перечислим все инструменты Панели инструментов, сверху вниз: Select Objects (Выбор Объектов, или часто инструмент называют просто Стрелка), Text Box (Текстовый Блок, Фрейм), Insert Table... (Вставка Таблицы...), WordArt... (Вставка объекта WordArt), Picture Frame (Фрейм Изображения), Clip Organizer Frame (Фрейм Мастера Клипов), Line (Линия), Arrow (Стрелка), Oval (Овал, Эллипс), Rectangle (Прямоугольник), AutoShapes (Автофигуры), Hot Spot (Горячая Вставка, Вставка Ссылки), Form Control (Управление Формами), HTML Code Fragment... (Фрагмент Ко да HTML...) и Design Gallery Object... (Объект из Галереи Дизайнов).

Бросается в глаза, что в Microsoft Publisher, в отличие от других верстальных программ, вставка таблицы заложена внутрь самой программы, нет необходимости отыскивать другую утилиту той же фирмы, которая может оказаться несовместимой с новой версией или, к примеру, станет ошибаться при экспорте таблицы в основную программу. .. Здесь таблица делается на месте. А наличие многоточия после имени инструмента (опции) говорит о том, что при вызове активизации этой кнопки мы получим диалог выбора параметров таблицы.

Рис. 4. Диалог «Параметры...»

Что ж, многолетние наработки Microsoft по обеспечению офисных приложений опцией Вставки Таблицы здесь сказались весьма положительно на разработке верстального приложения. Соответственно можно надеяться, что мы станем иметь в лице Publisher полнокровную программу для верстки и макетирования.

Обратите внимание на второе подменю, из которого «растет» подменю с опциями инструментов: в том подменю всего две опции — Objects, подменю которой мы только что бегло-перечислительно рассмотрели, и Customize... (Параметры...). Вызовем эту строку.

Как видите, открылся знакомый нам по Microsoft Word диалог настройки Параметров панелей (рис. 4). Открылся он на вкладке «Опции».

Здесь определено то, что, как и в Word, является отличительным для этой версии Офиса. К примеру, если вы внимательно взглянете на рисунок, то обнаружите, что Панель управления, о которой речь впереди, разделилась на две части, и вторая, совсем небольшая часть расположилась на нашем рабочем поле второй строкой. Так же точно в два столбца почему-то стала располагаться и Панель инструментов. Этот первый визуальный признак говорит о том, что Офис предполагает: раз вы взялись за настройки, то непременно захотите в первую очередь разместить панели так, как вы давно привыкли, работая с прошлыми версиями Офиса — особенно Офис 97, где панели не смешивались, и Стандартная была в своей строке, а Форматирование — в своей. Относительно Панели инструментов ничего не могу сказать, поскольку в Офисе 97 такой панели, кажется, не наблюдалось вовсе.

Впрочем, Офис 97, разработанный для Windows 98, который содержал Word не 7-й, а 8-й версии, наверное, уже имел в качестве дополнения возможность установки версии Publisher, разработанной для Windows 98. Потом была версия 2000, и вот теперь, наконец, версия 2002 ХР. Надо сказать, программа Microsoft Publisher все эти несколько лет держалась в тени, но теперь уверенно вышла, как говорится, «на большую дорогу».

Но обратимся ко вкладке Options диалога Customize.

В первом же, верхнем поле Индивидуальные Настройки Меню и Панелей (Personalized Menus and Toolbars) мы видим по умолчанию флажок перед опцией Show Standard and Formatting toolbars on two rows (Показать Панели Стандартную и Форматирования в два ряда), то есть изначальная настройка Publisher пока предполагает следование принципам Офиса 97.

Что ж, тогда снимем этот флажок и дадим Офису 2002 «разгуляться на воле». То, что у нас получится после того, как скажем ОК, вы видите на рисунке 5.

Рис. 5. Размещение панелей управления Стандартная и Форматирования в одну строку

Здесь кое-что поменялось по сравнению с рисунком 2.

Вы видите, что некоторые кнопки спрятались за знакомой нам по Word XP узкой кнопкой, и под ней следует ожидать ровно такое же меню с какими-нибудь подменю, как это было в Word.

Посмотрим.

При вызове этой кнопки мы получаем достаточно знакомую по Офису ХР картину. С той только разницей, что кроме панелей Стандартная и Форматирование в подменю числится и еще одна, установленная в Publisher по умолчанию.

Это Панель Connect Frames с ее подменю, которое как раз открыто для обозрения.

Рис. 6. Открыли кнопку и получили каскад подменю

При вызове этой кнопки мы получаем достаточно знакомую по Офису ХР картину. С той только разницей, что кроме панелей Стандартная и Форматирование в подменю числится и еще одна, установленная в Publisher по умолчанию. Это Панель Connect Frames с ее подменю, которое как раз открыто для обозрения.

Обратите внимание: в основном меню, скрывающемся за узкой кнопкой Toolbar Options (Параметры Панелей), которую мы только что нажали, содержится полный набор кнопок, не вошедших в число показанных на Панели. Щелкнув любую из них, мы будем иметь возможность тут же наблюдать ее в числе тех, что на однострочной Панели. Правда, за счет какой-то другой кнопки: программа сама сортирует их, пользуясь данными о частоте вашего обращения к той или иной кнопке. Ровно так же, как в любой программе, входящей в Офис ХР, всего за несколько сеансов работы Панель будет содержать лишь те кнопки, которыми вы пользуетесь, и сбросит в «архив», то есть отправит на «скамейку запасных» не нужные вам кнопки. Специально настраивать Панель «под себя», таким образом, в программе Publisher тоже не обязательно: все получается само собой. Здесь же опять для вас есть опция Show Buttons on Two Rows — Показать Кнопки в Два Ряда. Этой командой вы всегда сможете воспользоваться.

Отличие рассматриваемого приложения от иных, входящих в пакет Office, в том, что здесь в подменю Add or Remove Buttons (Установить или Сместить Кнопки) есть не две панели, как мы привыкли (Стандартная и Форматирование), а три: есть еще, как я сказал в позапрошлом абзаце, Connect Frames (Связывание Фреймов). В ее подменю четыре опции — Create Text Box Link (Создать Связь Текстового Блока), Break Forward Link (Разорвать Прежнюю Связь), Previos Text Box (Предыдущий Текстовый Блок) и Next Text Box (Следующий Текстовый Блок).

Если вы заметили, на нашем рисунке эти опции включены — кругом стоят флажки. Но кнопки в основном меню не активны. Дело в том, что хоть и есть у нас на странице несколько текстовых блоков (я нарочно создал их, чтоб не на голом листке происходила добыча опций из меню или с Панелей), но они не выделены, и соответственно кнопки, отвечающие за связи текстовых блоков, «молчат». Более того. Если текстовый блок выделить в режиме Стрелка, опции связи так и останутся неактивными. Дело в том, что в Microsoft Publisher, как и в QuarkXPress, связи между текстовыми блоками работают лишь в режиме текстового блока (когда активна вторая кнопка Панели инструментов Text Box), а если активен режим Выбор Объекта, мы запросто можем добиться того, что программа подумает, будто мы хотим, чтоб она считала наш текстовый блок за объект или за блок изображения.

Здесь, и не в последний раз, мы сталкиваемся с удивительным сплавом майкрософтовских свойств программы и заимствованных у фирмы Quark свойств верстально-графической программы. Понятие и опции связей Microsoft добросовестно внесла в свою разработку. В PageMaker тоже есть режим Стрелка и режим Текст, но фреймы (блоки) там, как таковые, не сильно различаются. И вставка рисунков не нуждается в подготовке кадра — рисунок в PageMaker гораздо свободнее себя чувствует, чем в QuarkXPress. Посмотрим, как-то будет обстоять дело в Publisher...

Но вернемся к диалогу Customize (рис. 4). Мы видим в Индивидуальных Настройках строку Always show full menus (Всегда показывать полные меню). Это значит, что в программе Publisher, как и в Word, и в других приложениях Офиса ХР, показаны усеченные, «плавающие» меню.

Не станем ставить флажок против этой опции. Нас вполне устроит то, что мы в

открывшемся меню увидим лишь те опции и команды, которыми привыкнем пользоваться или которые для нас будут командами первейшей необходимости. Если же понадобится что-то менее употребляемое, более редкое, мы всегда или дождемся, когда меню развернется, или щелкнем на стрелке в низу меню, или просто, зная, что в коротеньком меню нашей опции нет, щелкнем при его вызове на имени меню двойным щелчком мышки — меню откроется в полном виде. Так что специально назначать полное раскрытие меню, думаю, излишне. Оставим все по умолчанию.

Тем более что стоит флажок напротив строки Show full menus after a short delay (Показывать полные меню после короткой задержки).

Кнопку Reset my usage data (Восстановить мои обычные данные) мы трогать лучше не станем. Она, как в видите, никакого диалога нам предлагать не собирается, то есть сразу же после щелчка на ней начнет выполнять свое дело, а мы только пошутили... Оставим ее в покое. Кто ее знает, эту опцию, какие такие данные она принимает за «обычные»...

Идем на поле Дополнительно (Other). Там предлагается поменять размер значков (к примеру). То есть мы можем назначить Large icons (Крупные значки). Или по умолчанию отмечена флажком строка List font names in their font (Отображать имена шрифтов тем же шрифтом). Это здорово: до Office 2000 такой услуги не было. Теперь мы не нуждаемся и в шрифтовых навигаторах. А ведь в верстальной программе это очень и очень важно, — чтоб не тратить уйму времени на поиски какого-нибудь примитивного шрифта, который понравился начальству, зато вы его ни разу в глаза, этот шрифт, не видали. Эта строка, да еще и представленная флажком по умолчанию, очень важна как создатель внутреннего Навигатора шрифтов. Другая строка Show Screen Tips on toolbars (Показывать подсказки для кнопок; Панелей) содержит, как вы сами понимаете, опцию, которая давно распространена в разработках Майкрософт. Наоборот, от этих подсказок, всплывающих везде и в самый неожиданный момент, уже, пожалуй, деваться некуда... Часто хочешь щелкнуть по кнопке, а она — загорожена подсказкой.

И в самом низу находится поле выбора способа раскрытия меню Menu animations:. Здесь собраны способы (эффекты) — Случайный выбор (Random), Развертывание (Unfold), Соскальзывание (Slide), Угасание (Fade). Есть еще малопонятный эффект — По Умолчанию (System default), который я и оставил, поскольку никогда в эти опции не вмешивался. Вероятно, есть пользователи, для которых очень важно и принципиально — как именно станет появляться на экране то или иное меню. Может быть, в этом и есть какой-то смысл... Попробуйте. Вам ничего не грозит. В противном случае, если вам не нравится ни один из эффектов, вы всегда в том же окошке выбора сможете переназначить эффект при выводе меню на прежний, по умолчанию. По умолчанию, насколько я понимаю, это вовсе без эффектов — включается, точно свет в маяке, и все.

Но теперь перейдем к другой вкладке диалога настройки параметров. Возьмем вкладку Toolbars (Панели).

Рис. 7. Вкладка Toolbars

Здесь собраны все возможные в Microsoft Publisher типы панелей. Все, против имени которых стоят флажки, существуют на экране по умолчанию. Четыре из них весьма знакомы нам, хотя с одной из них, Связыванием Фреймов, мы познакомились на этих страницах. Но есть и пятый флажок, который стоит против строки Menu Bar (Строка Меню). Снять этот флажок, сколько бы вы ни пытались, вам не удастся. Речь ведь идет о присутствии или отсутствии в интерфейсе программы Строки Командных Меню! Выходит, программа не позволяет вам вмешаться в эту опцию и убрать Строку Меню. И правда: как вы станете работать, если уберете абсолютно все флажки? Что останется? И потом, когда не сможете работать, еще и погрешите на Microsoft.. Правильно, должны же быть какие-то незыблемые вещи.

Здесь есть непонятная мне строка по имени Header and Footer (Головное и Ножное? или Вверху и Внизу?). Если эта строка не вызывает Панель для инвалидов, пожелавших работать в программе верстки и макетирования, то можно сказать, что мы столкнулись с компьютерным приколом невысокого вкуса. Кстати, флажок против этой опции не хочет устанавливаться: звуковые колонки на ваш щелчок в поле для установки флажка выдают запрещающий звук. Возможно, такая Панель и существует в природе, но поскольку у нас при установке Windows не были установлены «Специальные возможности» (расширенные возможности программы для больных и инвалидов), и флажку просто не на чем зафиксироваться?.. Но я все же склонен считать эта каким-то розыгрышем авторов. Или неправильно перевожу смысл названия Панели?

Может быть, это и неудачная шутка, но тем не менее оставляю ее на своей совести. А речь тут идет во о чем: «В Головах» и «В Ногах» — такой вот веселый жаргон придумали в Америке в процессе порчи английского языка. На самом деле речь идет о Колонтитулах! Первый из них — это Верхний Колонтитул, второй — Нижний, только и всего. Впрочем, непонятно, отчего не вызывается Панель Колонтитулов, почему не хочет ставиться флажок против имени этой панели?.. Ведь из меню опция прекрасно вызывается и даже дает сразу же Панель Колонтитулов.

Идем дальше. Вы можете назначить Панель Measurement (Панель Размеров), как она существует и в QuarkXPress (да и в PageMaker тоже). Впрочем, там я называл ее Панелью Реквизитов, потому что с этой панели было можно назначать множество и множество всевозможных параметров материалу, над которым вы работаете при верстке и макетировании. Мы обязательно вызовем эту панель к жизни, но позже. Пока же я убеждаюсь, что панелька выглядит довольно куце в сравнении с такими же панелями двух указанных верстальных программ.

И еще нам предлагаются знакомые нам до слез панели Picture (Изображение) и WordArt (Объекты WordArt).

Обе панели ничуть не отличаются от таковых же в любом другом приложении, входящем в Office XP, и потому идем дальше.

Рис. 8. Вкладка Commands

Раскроем вкладку Commands (Команды).

И увидим, что здесь собраны, как и в диалоге «Настройка...» любого майкрософтовского приложения, в поле Категории — все виды категорий команд. Они, в основном, группируются по имени тех меню, в которые входят. Но есть списки команд и под именами категорий, которые нам редко встречаются или не встречаются никогда.

Выбранная в поле Категории тема тут же в правом окне Команды отображает пиктограммы ко всем командам, которые существуют в списке.

Смысл этих двух списков в том, что, выбрав команду, которая вас интересует, вы сможете поместить ее кнопку на Панель управления.

Это делается очень просто. Взяв значок команды мышкой (первой кнопкой) не отпуская донести его до самой Панели управления (или инструментов) и там, выбрав для нее место, отпустить кнопку мышки. Кнопка команды сама встанет на Панель.

Но происходит это лишь в тот момент, когда вокруг вашего курсора возникнет характерная черная черта, напоминающая текстовый курсор, только высотой с высоту кнопки на Панели. Вы, конечно, ни с чем этот импульс не спутаете и поймете, что пора отпустить кнопку мышки.

Можете не отпускать, а поискать вашей будущей кнопке более подходящее место: подвигайте черту по Панели, нащупайте ей место, которое вас наиболее устраивает — к примеру, между такой-то и такой-то кнопкой. Там и можно кнопку зафиксировать.

Чаще всего получается очень долго искать ту или иную команду.

Потому что мы в большом числе случаев можем ошибиться, к какой именно категории отнести эту команду. Можно провозиться с поиском очень долго.

Если в распространенных приложениях типа Microsoft Word существует категория «Все команды», и там простым визуальным просмотром вам легче найти свое,то здесь наиболее распространенные для вставок команды собраны, кажется, в двух меню — Insert (Вставка) и Format (Формат).

Также для больших любителей строить интерфейс программы «под себя» существует категория New Menu (Новое Меню), где вы в силах сформировать свое из только свое меню, добавив его в Строку Командных Меню программы, чтобы только с ним и работать. Разработчиками заложена довольно большая свобода общения с Publisher.

Ниже полей Категории и Команды находятся две кнопки в поле Selected Command: (Выбранная Команда:).

Кнопка Description (Описание) вызовет всплывающую подсказку, которая подробнее, чем обычно, расскажет вам, что представляет собой та или иная команда, которую вы выбрали.

Для этого надо выделить команду и нажать кнопку Описание.

Вот что получится:

Рис. 9. Подсказка о выбранной команде

Обратите внимание: На рисунке 9 вы видите всплывшую подсказку, которая, в отличие от имен команд и опций Publisher, вдруг возникла на русском языке, и нам все делается ясно. Возникает даже недоумение — отчего бы тогда и всю программу не перевести на русский язык? Вот было бы здорово работать русскому пользователю...

Но — увы. Подсказка виндоусовская. Как и сама опция подсказок. Так что к Publisher русская Windows имеет отношение лишь косвенное. Да и подсказки, честно говоря, здесь редко есть по-русски. Как только подсказка относится к опции, которой нет в других приложениях Офиса, так—плохо наше дело.

О второй кнопке ничего не могу сказать, потому что не понимаю, что такое Modify Selection (Выбор Изменений? или Изменить Выделенное?). Как бы то ни было, сколько я ни выделял, как ни старался сделать это еще в иных приложениях, кнопка оставалась неактивной. Загадку эту доношу и до вас, дорогой читатель.

В самом низу Диалога вы видите кнопку со знаком вопроса. Это известная все! Справка. Щелкнем на этой кнопке...

Рис. 10. Наш старый знакомый — Помощник (Assistant)

Да, знакомая всем Скрепка тут как тут. На всякий случай скроем ее. Большого смысла в справочной опции в Publisher не вижу: во-первых, вся Справка по-английски, а во-вторых, по сути там мало что найдете.

Закрываем наш замечательный диалог и идем дальше.

Поднимемся взглядом до Строки Командных меню и посмотрим, что она собой представляет.

Список меню не вызывает у нас удивления — все стандартно, как и принято в приложениях Windows. Вот эти меню: File (Файл), Edit (Редактировать), View (Вид), Insert (Вставка), Format (Формат), Tools (Инструменты), Table (Таблица), Arrange (Порядок), Window (Окно) и Help (Помощь, Справка).

Рассматривать меню пока не станем, у нас будет отдельное время подробно поговорить обо всех командных меню. Тогда мы их каждое рассмотрим подробно.

Идем дальше.


Командное меню «Файл» (I)

Откроем полное меню и посмотрим, какие опции-команды оно содержит.

Как понятно, это приложение ничуть не исключение из других. Поэтому первые опции меню, как и везде, это New... (Новый...), Open... (Открыть...), Close (Закрыть). В опции «Закрыть» речь идет о закрытии документа (публикации), но не программы. Выход из программы, как вы знаете из других приложений, заключен в последней строчке меню по имени Exit (Выход).

Рис. 1. Командное меню File (Файл)

Как понятно, это приложение ничуть не исключение из других. Поэтому первые опции меню, как и везде, это New... (Новый...), Open... (Открыть...), Close (Закрыть). В опции «Закрыть» речь идет о закрытии документа (публикации), но не программы. Выход из программы, как вы знаете других приложений, заключен в последней строчке меню по имени Exit (Выход).

А вот следующая за командой Close строка — уже функциональная опция Microsoft Publisher. Ее имя Import Word Document... (Импорт Документа Word...). Вызвав эту опцию, мы получим диалог вставки документа (не показываю, ибо мы много раз будем еще проделывать это), где, выбрав соответствующий документ Word, говорим Insert, и остальное программа сделает за нас. На рисунке 2 вы видите, что я выбрал небольшой двухстраничный документ, и профамма сама поместила его на страницы Publisher.

Рис. 2. Импортирован документ Word

Здесь есть один существенный нюанс. В открытый вами документ программа ничего не вставила. Обратите внимание на строку заголовка она открыла для этой цели новую публикацию по имени Публикация!. Это означает только то, что в меню File мы находимся на самой начальной стадии работы в программе. Из первых строк меню File можно «добыть» лишь самые первые результаты, с помощью этих строк можно совершить лишь самые первые шаги. Соответственно импорт вордовского документа означает лишь то, что мы не прочь поработать с ним в программе Publisher. К примеру, для того, чтоб довести его до ума и потом сохранить как публикацию Publisher. Импорт происходит напрямую, без всяких сложностей, поскольку и та, и другая программы — приложения Офиса.

Обратите внимание, во время импорта в левой части Рабочего пространства возникает Докер Word Import Options (Параметры Импорта Word).

Взглянем на этот Докер поближе.

В верхнем поле — четыре гиперссылки, которыми можно вызвать еще три других Докера — это Publication Designs (Дизайны Публикаций), Color Schemes (Цветовые Схемы) и Font Schemes (Стили Шрифтов). Эти докеры нам не особенно нужны, но разработчики программы на всякий случай дают нам разные возможности достичь чего-либо желаемого нескодькими способами. Из одного Докера можно попасть в другой, чтоб не искать эти опции по меню или кнопкам Панели управления. Все построено на гиперссылках.

Если вас не очень устраивает работа на гиперсвязях, вам предоставлена другая возможность найти необходимый Докер: откройте в Строке заголовка Докера меню, в котором полный список докеров. Вы видите его на рисунке 3.

Рис. 3. Меню для поиска Докера

Здесь наглядно продемонстрирована универсальность подхода к проблеме, которой придерживается, особенно в ХР, Корпорация Майкрософт. Но вернемся к Докеру Параметры Импорта Word.

Поле ниже первого называется One- or two-sided printing (Одно- или двухсторонняя печать). По умолчанию (я не имел никакого касательства к этим назначениям и показываю все, как оно есть) программа сама выбрала двухстороннюю печать и ориентацию листа Портретную. В программе Word, как вы знаете, ориентация страницы называется слегка иначе — Книжная или Альбомная. Здесь, как и положено в верстальной программе — Портретная или Ландшафтная (Пейзажная). Это мы выяснили вопрос с полем, расположенным ниже поля стиля печати.

Следующее поле — Title Page (Титульный Лист) также с двумя вариантами назначения — Include (Содержится) и None (Нет), давайте установим для нашего документа первый вариант и посмотрим, что произойдет.

Рис. 4. «Рождается» титульный лист

На рисунке 4 вы видите, что, едва отметив в поле назначение Include, мы получили реакцию программы: как видно, она сообщает нам анимацией, что идет Работа (Working) по созданию титульного листа. Это происходит достаточно быстро, и вот перед нами уже иной документ — с титульным листом. Все , содержание наших двух страничек сдвинулось на вторую и третью страницы (это и есть вордовский файл Содержания для какой-то из моих книг, я его выбрал случайно — из-за его малого объема).

Рис. 5. Титульный лист готов, и страницы сдвинулись, освободив для него место

Теперь взглянем на первую страницу, которую нам программа отвела под титульный лист. Там может скрываться некая загадка... И действительно: взгляните на рисунок 6 — Publisher самостоятельно определила для нас место для титула, начертание его, установила даты, имя автора (в самом низу, оно не уместилось), а также вы, возможно, разглядите, она определила и фирму, которой принадлежит титульный лист и весь документ в целом. Правда, в моем случае это записано как Свободный Художник, но при установке я это написал именно в графе «Организация».

Рис. 6. А вот и сам Титульный Лист

Здесь вы можете известным способом изменить любой заголовок, любую подпись, но факт есть факт: программа постаралась.

Самое нижнее поле — поле Columns (Колонки). Вы видите, что для документа могут быть предусмотрены три варианта размещения текста на странице — в одну колонку, как в книге, в две колонки и в три. Не станем трогать этой опции, оставим наши разбивки на колонки на потом, как и договаривались в еще не успевшей остынуть главе.

Что ж, идем дальше.

Дальше — группа опций, которые тоже могут быть названы вполне стандартными для меню «Файл». Это — Save (Сохранить) и Save as... (Сохранить как...). Первая опция сохраняет публикацию под тем именем, под каким она фигурирует в Строке заголовка. Это делается по умолчанию, без всякого вашего участия (кроме того, что вы щелкнули на этой строке меню мышкой). Эта строка предполагает, что документ существует давно, он лежит в соответствующей папке, то есть путь программе известен. Поскольку вы вашу публикацию не переименовываете, не изменяете кардинально (то есть не желаете сделать из нее какой-нибудь шаблон и тому подобное, не помышляете отправить ее на дискету и т. д.), она преспокойно сохраняет ее в той же самой папке, под тем же именем. А вот опция Сохранить как... предполагает прежде всего, что вы самостоятельно собираетесь назначить публикации расширение, папку или диск, имя и тому подобное. Тогда вызов этой опции вызывает на экран и диалог. Вы видите его на рисунке 31.

Рис. 7. Диалог Сохранить как.

Здесь я раскрыл окно Save as type: (Тип файла:), чтоб показать, в каких примерно расширениях можно сохранить публикацию Publisher. Даже в этом неполном списке вы видите, что публикацию можно сохранят как публикацию последней версии, или версии 98, или версии 2000. Еще, как видите, она вполне сохраняется и как шаблон, только надо не забыть дать ему имя. Всего возможных способов сохранить Publisher дает 30. Здесь и несколько версий Word, и RTF-формат, и файл PostScript (это важно, запомним), и даже Word для «Макинтошей». Так что, видите, фильтров для экспорта в программе предостаточно.

В графе File name: (Имя файла:) вы сможете дать публикации подходящее имя, а в окнах Навигатора выбрать файлу подходящий путь.

К тому же, при помощи мелкой кнопки с треугольником, открывающей небольшое меню прямо рядом с кнопкой Save, вы умеете сохранить документ и как копию публикации. Все в ваших силах.

Идем дальше. Следующая опция — Pack and Go (Упаковать и Отправить) с небольшим подменю, где две опции — Take to Another Computer... (Отправить на Другой Компьютер...) и Take to a Commercial Printing Service... (Отправить для Печатного Сервисного Бюро...).

Для примера упакуем и «отправим» файл для другого компьютера.

Опция подменю после щелчка вызовет не диалог, а Мастера упаковки (Pack and Go Wizard).

Для простоты я назначил этому Мастеру тот же путь, что и для самого файла публикации — то есть ту же папку, где числится публикация.

После нескольких стадий общения со мною, когда я говорил лишь Next (Далее), Мастер наконец выдал последнее окно, в котором мне осталось щелкнуть лишь по кнопке Finish.

Потом открыл свою папку, содержащую Публикацию!, и обнаружил в ней другую папку по имени PublicationlPNG (Pack and Go?), открыл эту папку и нашел в ней четыре файла, которые вам предъявляю. Вы видите их на рисунке 32. Один из них, как видно, файл распаковки, называется он unpack. С его помощью на месте, т. е. на другом компьютере можно будет распаковать файл, не прибегая для этого к включению отдельно установленных программ упаковки и распаковки, которые сейчас, после распространения ХР, становятся все более неактуальными, поскольку Windows ХР любит все делать сама — от надевания галош до шлепанья по лужам. «А что, вы за меня и пирожные есть будете?» — «Ага!» («Вовка в Тридевятом царстве», Союзмультфильм).

Рис. 8. Это содержимое упакованной папки

Раскроем текстовый файл readme, который частенько сопровождает теперь упаковку той или иной программы, того или иного файла и так далее. Даже если он не особенно нужен, упаковочный Мастер рождает этот файл все равно.

Вообще относительно файлов такого типа (не помню, говорил ли уже об этом) следует сказать, что они весьма и весьма необходимы. Они часто фигурируют — именно файлы с таким именем — в сопроводительной папке при установке новых программ, игр, каких-то развлечений. Из этого файла вы можете неожиданно узнать секреты относительно программы. Или секреты относительно установки этой программы. Возможно, там будет содержаться адрес папки, где можно найти папку Crack, без которой, может оказаться, вы не сумеете ступить шагу. Как правило, файл Readme предназначен для глубокого его изучения пользователем.

Рис. 9. Текстовый файл, сопровождающий упаковку

Как видите, здесь вся информация об упакованном файле. Что, зачем и почему — обо всем здесь сказано. Сказано, как распаковать запакованный файл.

Отправка в Сервисное Бюро тоже требует разговора с Мастером. Здесь я покажу этот диалог подробнее, потому что с Сервисным Бюро, особенно когда дело касается файлов верстальных программ, шутить нельзя: вся ваша работа и состоит в том, чтобы приготовить файл для полноценной и качественной публикации книги (газеты, журнала) в типографии.

Итак, выбираем опцию, с помощью которой файл можно без проблем перенести на некий носитель — чаще всего гибкий диск — и на этом носителе доставить в другую точку планеты — типографию на соседней улице, где есть отдел (он теперь существует самостоятельно, но все еще в том же коридоре), который и станет заниматься вашим файлом.

Рис. 10. Мастер Упаковки и отправки для Сервисного Бюро

Говорим Next.

Но прежде обратим внимание на то, сколько нам предлагает условий Мастер: Split large publications across multiple disks (Разделить большую публикацию по числу дискет), Embed TrueType fonts (Встроить TrueType-шрифты), Include linked graphics (Включить связанную графику), Create links for embedded graphics (Создать связи для встроенной графики), Print composite and separation proofs (Принтерная компоновка и разделение гранок).

Сделаю небольшое отступление и извинюсь перед читателем за то, что привожу свой убогий перевод с жаргонного американского, но у меня нет русского аналога программы, и потому — что уж получается, то получается. Еще раз извините.

Зато всем очевидно, насколько русскому пользователю нужен хороший русификатор.

Итак, говорим Next (Далее).

Мастер выбрасывает следующее по порядку окошко утилиты упаковки, где предлагает выбрать, на какой диск мы станем все это писать. В качестве диска по умолчанию, как я и говорил, он предлагает диск А: (гибкий диск 3,5 дюйма).

Это видно из рисунка 11.

Рис. 11. Следующий шаг Мастера

Рис. 12. Выбираем ту же папку, потому что никуда ничего сейчас отправлять не собираемся

На рисунке 12 вы видите, что я выбрал тот же путь, что и в прошлом случае — с другим компьютером. Так это происходило и там, в той опции. Говорим Next... Программа забеспокоилась: она говорит:

Рис. 13. Вопрос Microsoft Publisher, адресованный пользователю

Что ж, ни Windows ХР, ни Publisher не дремлют. Вопрос: «The following file already exists. Do you want to replace it?» (Такой файл уже существует. Вы хотите заменить его?).

Вспомним про то, что только что упаковали этот файл для другого компьютера. Он существует в той же папке, что мы назначаем и сейчас. Что ж, он нам все равно не нужен, мы согласны и заменить. А у вас, если это происходит не в качестве примера, а на самом деле, возникнет небольшая проблема — надо сказать «Нет» и назначить файлу другой путь. Мы же говорим «Да» (Yes) или даже Yes to АН (Да для Всех) и смотрим, что будет дальше.

Рис. 14. Следующее окно Мастера

Программа выбрасывает следующее окно (рис. 14) и говорит вам то-то и то-то (не стану переводить). В общем-то, рассказывает, что она сделает со шрифтами и графикой (то есть встроит и завяжет). Говорим Next.

Рис. 15. И вот — Финиш!

Да, вот мы и добрались до финиша. Говорим Finish.

Сказали, и на экране возникает анимация — это для нашего спокойствия, чтоб мы знали, что программа всегда начеку, всегда работает и успешно завершит все, что вами задумано. И наконец завершает (рис. 17).

Рис. 16. Анимация процесса

Сказали, и на экране возникает анимация — это для нашего спокойствия, чтоб мы знали, что программа всегда начеку, всегда работает и успешно завершит все, что вами задумано. И наконец завершает:

Рис. 17. Все закончилось

Вот так. «Ваша публикация успешно упакована» — говорит Мастер большими буквами. Print a composite (Скомпонована для принтера) — говорит нам флажок. Разделения не произошло — потому, вероятно, что у нас не цветная, а черно-белая публикация. Кажется, речь шла о цветоделении?..

Говорим ОК.

Оказывается, это не все. Программа хочет знать имя файла, поскольку происходит (как это и должно происходить с сервисным бюро) Печать в Файл.

Рис. 18. Требуется имя файлу

Вносим имя. Вам лучше знать, какое выбрать имя для публикации, когда она печатается в файл. Даем ему имя, к примеру, Петя. Это мне просто в голову пришло. Потому что Вася, кажется, где-то уже был. И опять — анимация:

Рис. 19. Процесс пошел...


Глава 1

Командное меню «Правка» (I)

Для начала неплохо бы взглянуть на полное содержание меню Edit (Правка), уж потом подробно, насколько это можно, поговорить о каждой опции.

Рис. 1. Командное меню Edit (Правка)

Меню внушительное, немногим меньше, чем меню File. Чтобы почти все опции этого меню (Edit) стали активными, мне пришлось перед тем, как показать вам это меню, создать лишний блок и выбросить его. А также выделить существующий текстовый блок. Иначе вторая группа команд была бы точно неактивной.

Итак, опции меню Правка.

Как и во всех приложениях Windows, первой строкой меню идет Отмена предыдущего действия (отмен в Publisher, как вы помните, всего 20). Команда звучит как Undo (Отменить, Уничтожить). Но в каждом конкретном случае идет уточнение — что именно Отменить: в нашем случае это Отменить Удаление Объекта. Давайте попробуем отменить это удаление, как и предлагает строка меню. Это делать никак не обязательно, просто есть такая возможность. Эта возможность сохранится для вас еще на протяжении девятнадцати функциональных действий, которые вы сможете осуществить в программе Publisher. После двадцать первого действия программа уже не сможет отменить удаление именно этого конкретного объекта, о котором сейчас идет речь. Скомандуем Отменить и взглянем на меню после этого действия:

Рис. 2. Отменили Удаление Объекта

Как видите, Publisher тут же предлагает вам Повторить Удаление Объекта (Redo Delete Object). Строка Redo выделена мною с помощью мышки. А в строке Отменить, заметьте, возникла другая запись — Отменить Вставку Текстового Блока — мое предыдущее действие.

Если следовать этим двум командам, можно бесконечно удалять и вставлять этот блок. Потому что команда Redo действует как Отменить Отмену. В некоторых программах, кроме этой команды, существует истинная команда Повторить, которая не затрагивает понятия Отмены Отмены, но здесь этого не нужно, программа легка в пользовании и не засоряет сознание пользователя близкими и едва различимыми между собой опциями.

Идем далее. Вот ниже указанной команды существует группа команд, которая, не будь у нас ничего выделено, была бы неактивной. Это, во-первых, команда Cut (Вырезать). Она символизируется пиктограммой, в которой очень хорошо узнаются обычные ножницы. Она действует, как и все команды подобного содержания во всех виндоусовских приложениях, и уж тем более в приложении, разработанном самой Корпорацией Майкрософт. У нас выделен тот самый Текстовый Блок, который мы обратно вставили с помощью команды Отменить. Вот его и вырежем.

Команда Вырезать вырезает выделенный объект в Буфер Обмена. Вырежем его, этот не нужный нам Текстовый Блок. Затем вызовем другую опцию, которую нам дарит Microsoft, — это Office Clipboard... (Буфер Обмена Офиса...). Как видно из рисунка 3, это Докер Буфера Обмена, в котором есть даже просмотр того что содержит Буфер.

Рис. 3. В Буфере Обмена имеется Текстовый Блок

О Докерах мы отдельно, вероятно, говорить не станем, потому что по мере смотрения меню и опций программы нам приходится сталкиваться со всеми Док рами, существующими в Publisher. Мы уже видели несколько Докеров, увидим еще. Здесь ценно то, что впервые по-настоящему, начиная с Office XP, мы можем просматривать содержимое Буфера.

Буфер Обмена настолько важная составляющая Windows, что возникает справедливый вопрос — отчего же прежде мы не имели возможности вмешиваться в Буфер? Когда-то программа AutoCAD включила в свои опции интересную команду — Очистить Буфер Обмена. Понятно, зачем. Ведь, единожды вставив что-нибудь из Буфера, вы бы хотели, чтоб в дальнейшем в буфере не содержалось ничего. Не для того, чтобы освободить место для последующих копирований и вырезании в Буфер, а ради того, чтобы освободить оперативную память вашего ПК, которая занята не только тем, что она работает вместе с вами, держа «в голове» несколько программ и доставая по необходимости с жесткого диска все, что вам заблагорассудится, но и постоянно помнит содержимое буфера, о котором давно пора забыть, ибо вам оно не нужно. Я уже говорил, как уничтожал содержимое Буфера до того, как были изобретены опции очистки или просмотра Буфера. Я копировал в Буфер какую-нибудь запятую, и вместо громадного рисунка в несколько мегабайт Буфер помнил одну лишь запятую.

Майкрософт разделила Буфер сначала на двенадцать ячеек, это было замечательное изобретение (Офис 2000). Теперь она поделила Буфер Обмена уже на двадцать четыре ячейки. Соответственно возникла потребность просматривать содержимое.

Просмотр содержимого Буфера — тоже не изобретение Майкрософт. Фирма Quark в программе QuarkXPress уже применяла опцию просмотра содержимого. А Корпорация Corel давным-давно изобрела Докер — дополнительное окно программы, существующее рядом с Рабочим окном. Из Докера можно осуществлять работу, при этом наблюдая результаты ее. Правда, в CorelDRAW, где появился Докер впервые, этот Докер, как и прежний Свиток, можно свернуть, сдвинуть на новое место и т. д. Докеры Microsoft Office устанавливаются незыблемо, их можно лишь расширять. В Word это делается влево, поскольку Докер располагается справа от Рабочего окна, а в Publisher можно таким же образом расширять Докер вправо, ибо он существует в левой части экрана.

Есть еще одна незыблемость Windows: Докер можно расширить лишь до середины экрана. Как бы вы ни старались сдвинуть их дальше середины, границы Докера останутся на месте.

Но обеспечить Докер гиперссылками — это уже чистое изобретение Microsoft. И просмотр в Докере Буфера Обмена происходит мгновенный: не успели вы скопировать объект (особенно важно для изображений), как он тут же в миниатюре появляется в списке Докера Обмена, в окне просмотра. Даже не в окне: Докер содержит деление на ячейки, и изображение (или текст) появляется в области очередной ячейки.

Еще одно изобретение Windows ХР и Офиса ХР: последнее копирование появляется в ячейке, расположенной в списке первой, то есть в верхней ячейке, как самое насущное.

Обратимся к этой ячейке и посмотрим, что там происходит в Докере.

Рис. 4. Открыли меню ячейки Буфера

Если щелкнуть по стрелочке в правой части области Ячейки, то выскочит н большое меню из двух команд. Это команды Paste (Вставить) и Delete (Удалить Таким образом можно либо вставить в документ что-то из той или иной ячейки или уд лить из ячейки переставшую быть нужной информацию.

Если же вам необходимо очистить весь Буфер или вставить все из этого Буфера ( примеру, у вас собрано 24 главы романа, и осталось только вставить их в документ (ил публикацию), то к вашим услугам основное меню Докера. Оно выражено не в форм меню, а в форме небольшой панельки, существующей прямо под Строкой заголовке Докера Clipboard. Это две кнопки — Paste All и Clear All. Первое означает — Вставить Все, второе — Очистить Все.

Нам уже не нужен в буфере тот самый Текстовый Блок, который мы вырезали. Скомандуем Очистить Все. И получаем пустой Буфер с такой вот записью:

Рис. 5. Буфер чист!

Программа сообщает нам, что Буфер Обмена чист. Истинное содержание длинного сообщения такое: «Буфер обмена пуст. Выполните копирование или удаление в буфер для сбора объектов».

Рассмотрим еще и кнопку в самом низу Докера. Это кнопка Параметры (Options). Нам откроется меню:

Рис. 6. Меню под кнопкой Параметры

В этом меню — четыре опции. Это — Show Office Clipboard Automatical (Показывать Буфер Обмена Офиса Автоматически), Collect Wit hoi Showing Office Clipboard (Собирать данные без Показа Буфера Обмен Офиса), Show Office Clipboard Icon on Taskbar (Показывать Иконку Буфер Обмена Офиса на Панели задач) и Show Status Near Taskbar When Copyin (Показывать Состояние около Панели Задач при Копировании, или — больше по-русски: Показывать процесс копирования в Строке состояния).

Из перечисленных опций, сами видите, флажки стоят против трех. Вторая (без показа Буфера) имеется в виду в качестве возможной, но по умолчанию предусматривается показ.

С легким сердцем закрываем Докер Буфера Обмена и идем дальше.

Мы остановились на команде Cut (Вырезать) и рассмотрели ее весьма подробно Попутно же коснулись команды Вставка из Буфера и самого Докера Буфера Обмена Теперь бегло можно сказать о команде Копировать (Сору). С помощью этой команда выделенные данные тоже попадают в Буфер, но с того поля, где они взяты, не исчезают. Только и отличие от команды Вырезать.

Вставка (Paste) соответственно вставляет из Буфера содержимое в ту точку, которую вы прежде, чем выполнить эту команду, обозначили курсором. Как правило, это текст вставляется таким способом. В программах QuarkXPress и PageMaker текст вставляется примерно так же, а вот с рисунками там сложнее. Хотя для того, чтоб рисунок имел незыблемую привязку, и в той, и в другой программе вставляют изображения в режиме Теста. В PageMaker этот способ используется реже, в Кварке — чаще. Здесь этот способ привязки программой Publisher рассматривается как несущественный.

Попробуем вставить рисунок — хотя бы тот же знакомый нам по прежним главам и по обложке книге портрет девочки. Сделаем это не через Фрейм Изображения (мы до этой вставки еще дойдем), а через буфер, скопировав туда фото в программе Фотошоп, а потом в текстовом режиме скомандовав Paste. И вот что получается:

Как видите, размер изображения «сориентировался» под кегль шрифта, в котором пульсировал курсор. Соответственно мы получили не большую фотографию, а фото размером с парочку букв, да и то по ширине. Обратите внимание: мы просматриваем страницу в масштабе 400%!

Так что вставка изображений в Publisher должна осуществляться через опцию Вставки Изображения. Но это рассмотрим позже, а пока идем дальше.

Рис. 7. Вставка изображения в текстовом режиме

Следующая опция Paste Special... (Специальная Вставка). Чем она отличается от простой вставки, осуществляемой командой Paste? Тем, что при этой вставке обязательно учитывается, в каком именно формате происходит вставка содержимого.

Взглянем на рисунок 8. Здесь показан диалог, вызванный опцией Специальная Вставка.

В окне перечислен список форматов, которые можно придать изображению того же портрета» содержащегося в Буфере. Наиболее предпочтительный для программы отмечен по умолчанию строкой выделения.

Это — просто Picture. Именно в таком виде и хочет Publisher вставить в публикацию изображение из Буфера.

Рис. 8. Диалог Специальная Вставка

Для чего программе необходимо учитывать формат вставки?

Для того, чтобы между рисунком и программой, в которой он порожден, оставалась связь.

Это необходимо для редактирования рисунка прямо из верстальной программы: двойной щелчок на изображении, вставленном в конкретном формате, вызовет появление программы-родителя, в которой изображение будет корректироваться.

Надо учесть одну существенную деталь относительно того, как программа ведет себя в отношении вставок адобовских рисунков — кстати, независимо от того, рожден рисунок в Фотошопе или в иной фотопрограмме. Чаще всего вставляются картинки формата TIFF. Верстальная программа понимает лишь то приложение, в котором рисунок открывался, пока не попал в Буфер. Так вот: неадаптированный под ХР Photoshop Паблишер понимать не хочет. И потому по умолчанию предлагается вставка Picture, понимаемая и любимая ХР.

Рис. 9. Выбрали Picture и вставили портрет

Как видите, портрет появился в своем истинном размере.

Также Publisher, как видно из рисунка 8, любит точечные рисунки своего собственного или, иным словом, майкрософтовского производства.


Глава 1

Командное меню «Вид» (I)

От меню View (Вид) в любой программе очень многое зависит. Даже самочувствие пользователя. Я, например, очень не люблю работать с документом, который не разбит на страницы. В Word этот вид представления документа на экране носит странное имя Обычный. Обычный для MS-DOS, что ли? Когда нет разбивок ни на строчки, ни на страницы?.. Сплошная «кишка» меня не устраивает.

Подход к Виду в программе Publisher несколько иной — он более конкретный, более функциональный. Понятное дело: программа-то для верстки!

Взглянем на само меню, охватим его взглядом:

Рис. 1. Командное меню View (Вид)

Теперь посмотрим, что это такое. Посмотрим поближе.

Первая строка: Two-Page Spread (Двухстраничный Разворот). Против этой строки стоит флажок. И правильно: мы назначили именно книжный разворот. В этом можно наглядно убедиться: на экране присутствуют сразу две страницы — вторая и третья. А первая всего одна лишь по той причине, что книга всегда начинается с нечетной страницы.

Вторая, и важнейшая, опция — это Master Page (Мастер-Страница). Это тот самый незыблемый для документа шаблон, который определяет лицо всей книги.

Если, к примеру, поместить на Страницу-Мастер какую-то картинку, она непременно отпечатается сразу на всех страницах публикации. Мастер-Страницу мы видим на рисунке 2.

Рис. 2. Мастер-Страница Publisher

Она была пуста. Я поместил на нее первую попавшуюся картинку, чтоб засвидетельствовать, что шаблон «держит» на себе всю публикацию. Поместил я изображение автомобиля. Смотри что произошло на рабочих страницах.

А произошло то, что и ожидалось: на каждой странице появилось изображение автомобиля. В том самом уголке, в который я его поместил. Текстовые фреймы сам сдвинул правее этого изображения, чтоб авто не закрывало текста. Наперед кто захочет что-то подобное проделать с полосой газеты или книги (журнала), дует знать, что непосредственно на рабочей странице не подредактируешь изображения, которые «сидят» в Мастер-Странице. Поэтому учитывайте при верстке эти обстоятельства.

Рис. 3. Автомобиль на всех страницах

Вот он, автомобиль, проявился везде. Автомобиль есть, — не хватает только скрипки и собаки Кляксы.

На шаблоне Мастер-Страницы назначаются номера страниц, колонтитулы, прочие общие для всех страниц решения. Пользуйтесь.

Следующая опция весьма интересна. Ее нет ни в Кварке, ни в PageMaker. Это опция Ignore Master Page (Игнорировать Мастер-Страницу). На рисунке 4 вы видите диалог, который появляется, когда мы ставим флажок против этой опции. Кстати, «ставить флажок» не получается: он появляется автоматически — сразу после того, как мы щелкнули на строке (при этом меню закрывается, и флажок можно разглядеть лишь при следующем открытии меню).

Рис. 4. Диалог Ignore Master Page

Нам предлагается выбрать — для каких именно страниц Игнорировать Мастер-Страницу — для левых или для правых? Можно не ставить никаких флажков, можно и поставить, если есть такая необходимость или обусловленное какими-то причинами подобное решение. То есть поле для деятельности программа обеспечивает.

Еще трудно сказать, сила ли в этой опции или слабость. Ведь, к примеру, Шаблон в PageMaker — он двойной, и назначения в нем делаются отдельно для левой для правой страницы. А здесь, получается, если у меня отличаются колонтитулы левой и правой страницы, придется публикацию запоминать дважды — то есть! иметь две совершенно идентичных верстки: одну — для четных, другую — для нечетных страниц. И печатать соответственно из первого варианта — четные, а из второго — нечетные страницы, а уж потом их складывать по результату печати одни вперемежку с другими... До конца в этой позиции я пока не разобрался.

Идем дальше. Следующая опция Task Pane (Панорама Задач).

Рис. 5. А это — Task Pane

Оказывается, щелчком на этой опции мы открываем Окно номер 1 Publisher. Здесь в разделе Quick Publication (Быстрая, Готовая Публикация) мы сможем выбрать близкую к желаемой публикацию и взять ее, к примеру, за основу.

Самое верхнее поле Докера, уже вполне знакомого нам, говорит: «Start from a design:», то есть «Начать с оформления:», и в окошке поля ввода или лучше в поле списка предлагается три варианта:

1. By Publication Type (типовой публикации);
2. By Design Sets (дизайна, формы) и
3. By Blank Publications (бланка публикации). Второй пункт под вопросом. Возможно, там имеется в виду не просто декорация вашей работы, а непосредственно оформление интернетовской странички (хотя тогда присутствовало бы слово Web). Ну, неважно, разберемся.

Кстати, справа от поля списка есть замечательная гиперссылка в виде значка с упирающейся в него стрелкой, и когда мы подводим туда курсор, который, как в Интернете, тут же приобретает вид оттопыренного пальчика, готового нажать на эту «кнопку», всплывает подсказка о том, что именно скрывается за гиперссылкой:

«Hides Publication Gallery» (скрыто поле публикации). Но едва мы щелкнем по » тем самым пальчиком, на рабочем поле программы появляется пустая первая стр ница вашей новой публикации, а кнопка-гиперссылка превращается в страничку стрелкой, направленной в сторону рабочего поля. Теперь стрелка и кнопка именяются как «Shows Publication Gallery» (показано, открыто поле публикации).

Но нам не надо открывать никакой новой публикации, дай Бог со старой справиться. Однако сейчас есть хорошая возможность в перечислительном ключе, галопом по Европам разобраться с этим Докером, одним из самых насыщенных.

А здесь должны скрываться богатые возможности для истинного полета фантазии.

Рассмотрим меню, открывшееся при щелчке на стрелке вниз, расположенно справа в строке заголовка докера, имя которого New Publication.

Однако прежде чем его разглядеть по-хорошему, пробежимся взглядом по рабе чему пространству программы. В правом окне навигатора мы видим заголовок «Quick Publications» («Готовые публикации», или что-то близкое по духу). Он вполне соответствует начальной записи в том большом списке, который идет ниже списка «С чего начать?».

Но вот опции меню на рисунке 92: New Publication (Новая публикация, Создать) Clipboard (Буфер обмена), Insert Clip Art (Вставка картинки, клипа), Quid) Publication Options (Опции готовых публикаций), Publication Designs (Диза публикаций), Color Schemes (Цветовые схемы), Font Schemes (Схемы шрифтов), — скорее всего, должно звучать примерно так: Палитры цветов, Палитры шрифтов, — если уж это верстальная программа, то тут уместны палитры, как извечно принято Styles and Formatting (Стили и форматирование) и Mail Merge (Почтовый ящик).

Рис. 6. Меню Докеров (Областей Задач)

Все опции — имена Докеров, которые возможно открыть из этого меню. Из опций меню Докеров активны лишь те, которых в данную минуту может касаться вид рабочего пространства. Открытая страница документа дает возможность пользоваться всеми докерами, как на рисунке 6 они все активны. Но когда в рабочем пространстве находятся только шаблоны готовых публикаций (Quick Publication), активны лишь первые три опции. Это имейте в виду и не впадайте в таких случаях в панику.

Но мы уже щелкнули на гиперссылке Докера, которая скрывала рабочее поле публикации, и это рабочее поле Новая публикация открылось. В нем наша пустая страница — без текста, без картинок и без номера страницы.

Но вернемся к нашей публикации, потому что пока нет смысла открывать новую.

Кстати, если речь зашла о нумерации страниц. В этом приложении номера страниц устанавливаются так же, как и в программе Word. В меню «Вставка» (Insert) выбирается Page Numbers... и в диалоге назначается, в каком месте будет номер страницы.

Рис. 7. Диалог Нумерации страниц

Кстати, в отличие от других верстальных программ, здесь используется имущество «Ворда»: если помните, в Word при назначении номера стран можно отменить номер на первой странице (как правило, в книге или даже те на первой полосе номер не ставится — и там, и там первая полоса посвящена титулу, так что нумеровать эту полосу излишне). Вторая страница точно так же вполне обходится без номера, потому что на ней сообщаются (в книге) выходные данные, ставятся копирайты (©), имена художников, аннотации и прочие дежурные материалы, в том числе государственное и международное кодирование (ББК, УДК, ISBN). Фактически только с третьей полосы для полиграфии нумеруются публикации. Но программа-приложение на второй странице, как вы понимаете, номер вам все равно проставит... Что ж делать-то?

А делать вот что. Как и в других верстальных программах, здесь мы тоже нарисуем прямоугольник, который своими размерами (они очень небольшие) перекрыл бы но страницы, а линии прямоугольника назначим или бесцветные, или белые. Ни но» страницы не станет, ни перекрытия (самого прямоугольника или квадрата).

Но это я забежал вперед. Идем далее. Правда, теперь уж договорим о нумерации страниц. В диалоге Нумерация страниц в верхнем поле выбирается месте положение номера страницы — вверху (Header) или внизу (Footer). Это видно на рисунке 7. К тому же, на рис. 8 вы сможете увидеть, что в нижнем поле диалога выбирается местоположение номера страницы по горизонтали — слева, справа или центру. Переводить не стану — кто ж не знает английских терминов: Left — «попер< Right — «послезавтра»; и Center — «от забора и до пяти вечера»? Всем, конечно, становится понятно...

Рис. 8. Можно выбрать местоположение номера страницы

Таким образом выбираем правильное расположение номера страницы на самой странице и идем дальше.

Вернемся все-таки в то меню, о котором шла речь, в меню Вид.

Следующая опция — Toolbars (Панели Инструментов) со своим подменю. Вы видите это подменю на рисунке 9.

Рис. 9. Меню View, подменю Toolbars

В этом подменю нам многое знакомо. Во-первых, флажки стоят перед строками с незыблемыми для данного приложения панелями — Стандартная, Форматирование, Связывание Фреймов и Панель Инструментов (Объекты). Во-вторых, нам обязательно пригодится для верстки Палитра Размеров (так она зовется в QuarkXPress) или, как я ее называю, Палитра Реквизитов (Measurement). Важна Палитра 3D Settings (3D Назначения). . Палитра вызывается или с Панели Управления, когда мы назначаем Перспективу какой-то примитивной фигуре, или из меню View, как это мы сейчас сделали, или из контекстного меню при щелчке второй кнопкой на свободном поле Панели управлении

Интересно рассмотреть действие кнопок-опций этой панельки, но мы оставим на конец главы, а пока посмотрим, что еще скрылось от нашего внимания.

Панель (Палитру) Measurement (Размеры) мы видели, поэтому пропустил опцию и обратимся к другой — Picture (Изображение).

Рис. 10. Палитра Picture (Изображение)

Когда мы коснемся изображения, эта панель нам пригодится. Еще увидим ее. А посмотрим на Панель Назначения Тени (Shadow Setting),

И знакомая нам панель Вставки Объектов WordArt (она так и зовется — просто WordArt). Панель-то знакома нам не только по начальным страницам этой книги, но и по известной всем программе Word.

Рис. 11. Назначение представления изображений

И теперь остается опция Customize... (Настройка Параметров). Мы ее рассматривали, говоря о Панелях инструментов, и потому теперь с легким сердцем пропустим.

Идем дальше.

Опция Rulers (Линейки), включенная по умолчанию, если щелкнуть на эк строке меню View, отключается. Соответственно исчезают с экрана Линейки. При повторном щелчке на той же опции Линейки появляются.

То же и с опцией Status Bar (Строка Состояния). Она по умолчанию включена, но ее можно и убрать из рабочего пространства программы. Однако вернуть можно также в любую минуту.

Опция Special Characters (Специальные Значки, Непечатаемые Символы) та же включается и выключается из меню «Вид». Но и про них мы говорили в связи с Панелью инструментов управления. Опция по умолчанию отключена.

Опция Boundaries and Guides (Границы и Направляющие). Речь идет о мага новой и синей линиях, которые ограничивают на странице область текста, то ее отмечают поля. При желании можно их убрать щелчком на этой строке или восстановить повторным щелчком.

При назначении или удалении всех последних описанных подряд элементов меню открывается лишь ради одного действия. После щелчка меню View исчезает экрана. Если вы передумали, можете восстановить утраченное только в меню Viw то есть его надо вызвать еще раз и опять щелкнуть на отмененной строке. Опщ Undo из меню Edit здесь не работает, назначения и удаления происходят только» меню View (Вид).

Идем дальше.

Опция Picture... (Изображение...). Опция замечательна не только своей функцией, но и простотой. Функция — в представлении изображений на экране (и cooтветственно в оперативной памяти ПК). Вы можете назначить изображениям полис) их представление, то есть нагрузить оперативную память полным разрешением каждого рисунка, что в работе над версткой публикации чаще всего и не нужно... вы можете представить (на время, лишь для процесса работы) рисунки и в низком разрешении, что, конечно же, улучшит быстродействие процессов, осуществляем! в программе Publisher, и очень разгрузит оперативную память. Наконец, вы моя приказать программе вовсе не вырисовывать для вас рисунки, которые уже получли свою долю редактирования. Вместо них будет лишь обозначение изображен (кадры).

Представим диалог, в котором происходят эти назначения. Достаточно выбрать что-то одно из трех назначений, и вопрос будет решен. Диалог вызывается, как уже сказал, строкой Picture... в меню Вид.

Для того, чтоб убедиться, что это так, взглянем на другой рисунок — когда мы уже назначили Скрыть изображение:

Рис. 12. Вместо изображений — лишь их обозначения

Я уже говорил, да по рисунку 11 и так видно, что вариантов всего три — Detailed Display (Деталированный Показ), Fast resize and zoom (Скудная Прорисовка в Масштабе — простите, умнее не сумел перевести из-за недостатка всех значений слов), и Hide pictures (Скрыть рисунки). Возможно, мы еще вернемся к этой опции, поскольку нам придется делать в этой книге какие-то конкретные работы — исключительно для того, чтобы показать, как эта программа ведет себя на практике и можно ли ею свободно пользоваться.

Рис. 13. Диалог выбора Специальной Бумаги (Дизайна)

Следующая опция — Special Paper... (Специальная Бумага...). Здесь через диалог программа предлагает вам, если пожелаете, принять к дизайну вашей страницы некий заранее разработанный специалистами и дизайнерами разработчик Publisher набор готовый подложек для страницы в виде определенного характерной фона или рамки и т. д. Они называются достаточно интересно — стиль Аристократ, к примеру. Я выбрал стиль Брошюра — Энтерпрайз. И вот что получилось:

Рис. 14. Вот так теперь выглядит наша публикация

Можно принимать или не принимать то, что вам предлагается, но видно, что разработчики очень поработали. Они придумали варианты едва ли не на все случаи жизни.

Следующая опция — вот она, наконец-то — Колонтитулы. Правда, здесь она называется Header and Footer (Верхний и Нижний, В Головах и В Ногах...). И вот она, та самая Панель, которая все никак не хотела у нас получать свой флажок в списке панелей, когда мы рассматривали диалог Настройки Параметров панелей. Оказывается, она преспокойно появляется, когда ее вызовешь опцией Header and Footer из меню View.

Рис. 15. Назначение Колонтитула


Глава 1

Глава 6 Цветовые системы

Из школьного курса физики каждый российский человек несомненно наслышан о природе и физических свойствах света. Он распространяется, как вы помните, прямолинейно, скорость его в воздушной среде, в которой, хочется верить, мы с вами все еще пребываем, постоянна и в земной атмосфере не составляет трехсот тысяч километров в секунду, как в космическом вакууме, но все же — что-то около того.

Еще Ломоносов открыл двоякую природу света — корпускулярно-волновую. Это означает, что мельчайшая частица света — квант — ведет себя и как частица, и как волна одновременно.

Свойства частицы проявляются хотя бы в том, что, если вы находитесь в потоке света, на вас оказывается материальное давление. Световые частицы (корпускулы, кванты) непрерывно бомбардируют наш организм, когда бы и где мы ни находились. Впрочем, этого давления мы, конечно, не замечаем. Но знаем о нем. Даже ночью, в темнице, в пространстве блуждают отдельные (и ощутимые, кстати, человеческим глазом) зазевавшиеся световые кванты. Еще до второй мировой войны советскими учеными было доказано, что человеческий глаз — настолько тонкий инструмент, что в силах реагировать и на эти отдельные кванты: на сетчатке глаза периодически возникают незначительные, но видимые всплески света длительностью в доли секунды.

Волновая природа света легче доказуема. Хотя бы тем обстоятельством, что мы имеем возможность различать цвета. Цвет — особенно различия в цвете — это есть способность организма реагировать на разные длины электромагнитных волн. А длина волны непосредственно связана с частотой колебаний (чаще всего имеется в виду количество колебаний в секунду). Так вот различная длина волны (или частота) определяет именно цвет направленного на вас света. Из семи основных цветов спектра — Красный, Оранжевый, Желтый, Зеленый, Голубой, Синий, Фиолетовый («Как Однажды Жак-Звонарь Городской Свалил Фонарь») — у красного наибольшая длина волны, у фиолетового — наименьшая. И наоборот, частота фиолетового — наибольшая, а красного — наименьшая. Все остальные цвета по порядку располагаются между этими замечательными фиксированными цветами. Составив палитру из ста цветов, мы всегда будем вынуждены расположить их между этими крайними цветами спектра.

Белый цвет — это очень важно — содержит в своем составе все цвета спектра.

Сэр Исаак Ньютон при исследовании свойств света пропускал солнечный луч через малюсенькую дырочку в сплошном черном экране, а на установленном напротив белом экране наблюдал, как падающий в отверстие белый луч разлагается на семь основных составляющих и проецируется на экран как составное пятно, в котором есть и красный, и оранжевый, и желтый... и так далее. Великий физик использовал в этом своем блестящем опыте явление дифракции, свойственное свету, — преломляться на объектах, сопоставимых с длиной его волны. Причем, в зависимости от длины волны, коэффициент дифракции разный, потому и цвета выстраиваются в ряд. В случае с биноклем (часто при большом увеличении виден радужный ореол вокруг объектов) мы наблюдаем почти то же самое, но это называется уже рефракцией — свойством отражаться от шероховатостей (тоже сопоставимых) под разным углом.

Собственно, и от идеальной — с нашей, а не физической — точки зрения, зеркальной поверхности различные цвета света отражаются под разными углами, но их можно зафиксировать специальными приборами.

Как видите, мы уже настолько вдались в физический процесс распространения света, что теперь никак не можем обойти важнейшее из свойств света — свойство отражаться.

Учителям физики очень нравится, когда у вас от зубов отскакивает формула: угол отражения равен углу падения.

Заметили? Фраза звучит как-то неудобоваримо. Знаете почему?

А потому что причина и следствие были перепутаны: с нас требовали говорить кругло и неправильно: «Угол падения луча равен углу отражения», — будто луч падает на гладкую плоскую поверхность только потому, что затем отражается от нее...

Но это детали. Важно другое. Когда мы говорим о законе отражения света, мы говорим, имея в виду идеальную отражающую поверхность. В природе она вовсе не встречается, а самая близкая к идеальной зеркальная поверхность обладает некоторыми свойствами, которые, строго говоря, тоже надо учитывать.

Возьмем наиболее близкое для нас — чистый белый лист бумаги. Он вроде бы идеально белый — так? На него падает свет от электрической лампочки (пусть не от солнца). Но попробуйте без боли взглянуть на электрическую лампочку незащищенным взглядом (при условии, что она горит)... Нет, у вас ничего не получится. Вы тут же прикроете глаза, да и то потом долго еще на вашей сетчатке будет реакция — след от воздействия на нее прямого попадания света нити накаливания. А на лист бумаги, освещенный этой самой лампочкой, вы смотрите нормально — не болят глаза, процесс может длиться почти сколь угодно долго.

Дело в том, что бумага не только отражает свет. Она его еще и рассеивает, и поглощает. А немного — и пропускает (взгляните сквозь этот лист на ту же электролампу). Кстати, именно благодаря этому весь наш мир наполнен цветами, пронизан мягким светом, сквозь который то и дело простреливают резкие играющие радугами лучи — то солнечный зайчик от ветрового стекла автомобиля, то заманчивая сетка отражений от играющей воды, то лунная дорожка... А часть света лампы (правда, вовсе незначительная) отражается, рассеивается и поглощается той толщиной воздушной прослойки, что находится между нею и листом бумаги. Все это в сумме и дает вам возможность безболезненно смотреть на окружающий вас мир, при этом радуясь тому, что умеете различать цвета и оттенки.

Счастливая возможность видеть мир цветным — дана нам законом, по которому все цвета по-разному отражаются, рассеиваются, пропускаются и поглощаются разными поверхностями предметов, окружающих нас.

А глаз устроен так, что видит мир как та самая камера-обскура, с помощью которой Ньютон разглядывал солнечный луч. Хрусталик — отверстие с линзой, а сетчатка — «белый» экран. Сигналы от различных по длине волны лучей распределяются по поверхности сетчатки, и каждая точка дает мозгу свой отдельный сигнал. Специальные клетки, отвечающие за различение цветов — так называемые «палочки» и «колбочки», — говорят мозгу: в этой точке сетчатки отражение объекта, покрашенного в синий цвет. Или нечто иное.

Мозгу же ничего не остается делать, как, восприняв все сведения от всех точек сетчатки, сложить общую картину и любоваться ею, пока не зайдет солнце, а все окружающее не окрасится в темные и почти непроницаемые цвета.

Множество ученых, исследовавших природу света, в том числе и наш гениальный Михайло Васильевич Ломоносов, открыли всевозможные законы излучения, распространения, а потом и перераспределения, света, разработали очень близко согласующуюся с действительностью цветовую теорию, и мы с вами застали науку в тот момент, когда она почти все знает о свете и цвете. «Почти все» — конечно, лишь в том объеме, каким мы имеем возможность воспользоваться.

Ради удобства была изобретена цветовая модель, с помощью которой можно рассчитать и построить на бумаге любой цвет и оттенок (гениальный «локус», утвержденный Международной Осветительной Комиссией — МОК много десятков лет назад). Формулы, конечно, упрощены, но это упрощение уже почти не сказывается на точности расчетов. Принцип работы локуса: составлять любой цвет не из семи цветов радуги, а всего из трех — красного, зеленого и синего (КЗС).

Вы резонно спросите: откуда такая странность? Ведь наверняка во времена изобретения локуса еще не было не только цветного телевидения, но и цветного кино!..

Да, не было. Но ученые основывались на свойствах... биологического (человеческого) приемника света — глаза. Дело в том, что нам вполне достаточно трех этих основных цветов, чтобы из их сочетания увидеть любой другой цвет палитры. Так работает глаз — его «палочки» и «колбочки».

Если этого сочетания вполне достаточно такому сложному аппарату, как человеческое зрение, то науке — особенно прикладной, каковою является светотехника, — и подавно.

Так родилась система (модель) цветового решения, основанная на трех цветах — Красном, Зеленом и Синем. Впрочем, по большому счету это не синий, а Голубой. Но даже не столь важно.

На этом принципе сконструированы многие и многие приборы, для которых цвет — очень важная характеристика. К примеру, тот же цветной телевизор.

... Время шло. Уже возникли телевизоры, они становились цветными...

А в громадной по важности отрасли — цветной полиграфии — никак не сводились концы с концами. Цветные книжки не желали передавать тот цвет, какой задумали авторы-иллюстраторы. Цветные журналы имитировали действительность, но очень приблизительно. В общем, с цветом — даже в самой развитой на то время технике цветной фотографии — накопились многие и многие проблемы. Передать с достаточной точностью все оттенки Рафаэлевой «Мадонны» полиграфия была не в силах.

Множество инженеров сразу многих фирм принялись за решение наболевших проблем. И пришли к выводу, что без калибровки дело не сдвинется. И придумали эрзац — замену техническому решению (хотя на то время, да и по сей день это решение тоже было полутехническим): ввести в оборот типографской деятельности цветовые атласы, — по ним «вручную» выбирается тот или иной оттенок того или иного цвета, а затем по таблицам отыскивается, какие краски накладывать друг на друга при печати или смешивать их в баке, а затем выкрашивать на чистый лист.

Полиграфисты, изощряясь, повели себя как художники, а художники, устав от проблем типографий, слегка сделались полиграфистами, приближая свои шедевры к тому виду, который удобен для средней руки типографии. Все это продолжалось до тех пор, пока...

Пока не объявились па мировом рынке новые технологии, основанные на компьютерных программах.

Вот так от Ломоносова мы пришли к тому, чтобы заявить о том, что для нас теперь вовсе не все равно, что существуют такие признанные мировые авторитеты, как фирмы «PANTONE», «Candela», «TruMatch», «Eastman Kodak» и, конечно, «Corel», с помощью которых мы сближаем разработанное, сочиненное нами изображение на экране компьютера (пусть на бумаге, как привыкли художники, или на фотобумаге, как фотографы... перевести это в компьютерный вид сегодня не составляет никакого труда) — с тем, которое получится после выхода листка из печатного станка.

Постойте-постойте, спросите вы, поскольку забыли или постеснялись задать этот вопрос школьному учителю физики: «Если белый цвет — сумма всех цветов, то что же тогда есть черный цвет?»

Ах, какой замечательный вопрос! Я им тоже мучился, пока не отправился учиться на светотехника.

Черный цвет — это тоже сумма всех цветов. Только с нулевой интенсивностью. А это то же самое, что отсутствие всех цветов.

Вы меня, надеюсь, простите за экскурс в науку, но без короткого (очень короткого!) напоминания, заключенного здесь, невозможно было бы объяснить некоторые вещи из тех цветовых моделей или систем, которыми пользуемся мы. Теперь, восстановив в памяти давние школьные знания, пойдем дальше.

Два принципа формирования цвета

Разговор о лампочке (источнике света) и чистом листе бумаги (освещаемой поверхности) у нас возник хоть и спонтанно, но далеко не спроста.

Обратите внимание на ваш — пусть замечательный из распрекрасных — монитор. Это не просто аппарат для отражения вашего рабочего стола, мольберта. Прежде всего — он источник света.

Ваш монитор (как и телевизор) дает вам изображение, формируя его цвет при помощи трех составляющих это изображение цветов.

Модель, на основе которой осуществляется работа монитора, имеет в распоряжении только три составляющих — Красную, Зеленую и Синюю (Голубую). По-русски многие годы это называлось — КЗС.

RGB-модель

Вот вам точная английская ее транскрипция: RGB — Red (R), Green (G) и Blue (В). Без учета специфики работы монитора мы можем сказать о нем: монитор — это довольно сложный источник света, он в процессе работы создает различные оттенки цветов, складывая их из сочетания трех простых основных — красного, зеленого и синего. В зависимости от яркости (интенсивности) того, другого и третьего формируется сумма, включающая в себя довольно много вариантов — многие палитры, которые при хорошем обслуживании аппарата можно на нем получить и различить.

Кстати, для сведения, глаз простого человека в силах различить до 4000 оттенков. Желательно, чтобы монитор выдавал хотя бы такое количество возможностей по цвету. А глаз простого художника-ремесленника видит оттенков в десять раз больше. О гениальных художниках говорят, что они различают оттенков в десять раз больше по сравнению со средним художником... Способна ли на сегодняшний день на это наша техника?

Скажем откровенно: увы, нет, не способна.

Но в настоящую минуту компьютерная техника стоит на порядок выше, телевизионной по степени цветопередачи и степени разрешающей способности — в первую очередь мониторов. Поэтому не стоит, во-первых, удивляться тому, что хороший монитор по цене превышает цену телевизора (тоже вроде бы не совсем плохого) в несколько раз. И невозможно пояснить этого людям, которые по обывательски сетуют на то, что монитор, при такой-то цене, даже ни одной телепрограммы «не ловит». Он предназначен для других целей. Кстати, и для воспроизведения транслируемых телепрограмм тоже! — но для этого нужен соответствующе настроенный телеприемник или модем. В нашей действительности все подряд привыкли называть «декодером». Ну, значит, декодер.

Итак, RGB-модель является моделью цветопередачи «источниковой», то есть активной, генераторной, суммирующей.

Так ее и надо воспринимать, на это и ориентироваться, когда речь идет о RGB-модели.

Модель CMYK

Принтер, каким бы он ни был мощным, умным, разрешающеспособным и так далее, строит свое изображение по совершенно иному принципу. Ведь что такое цвет, выходящий из печати? Это цвет, видимый нами на бумаге.

А как мы сможем увидеть цвет, полученный на бумаге?

Только если этот лист бумаги — освещен. Либо сложным солнечным светом, в который входит весь непрерывный спектр (бесконечное множество оттенков почти одинаковой интенсивности), складывающийся в белый цвет, либо — упрощенным заменителем солнца (ну, пусть это будет не лампа накаливания — «свеча Яблочкова», а лампа дневного света — люминесцентная, изобретенная тоже русским ученым — Вавиловым).

Следовательно, цвет, видимый нами на листе бумаги — это цвет, возникающий при отражении, попадающем, в свою очередь, в наш глаз.

Система CMYK, строящая свое цветоформирование на отраженном свете, является, в отличие от модели RGB, вычитающей. Почему?

Да потому, что, если мы видим, что при освещении листа бумаги (условно неизвестного нам цвета) белым светом от листа отражается, допустим, только желтый, это значит, что лист полностью поглотил все остальные составляющие подаваемого на него белого цвета, а отразил без поглощения только желтый. Следовательно, видимый нами желтый цвет можно получить только одним путем — белый минус все остальные, кроме желтого.

Именно поэтому, из-за формулы вычитания, мы и назвали систему CMYK моделью вычитающей, приемниковой, пассивной. Можно добавить термин: «экранной». На системе CMYK построены замечательные цветовые атласы точного воспроизведения цветов для типографии.

Слово «экранная» применил я тоже не так уж спроста. Для того чтобы этот термин сработал в полную силу, представьте себе кинопроектор и киноэкран, а еще — обязательно темный кинозал (это немаловажно). Так строится специфика работы и типографии — в других измерениях, но именно так.

Кинопроектор — это источник света, работающий, условно говоря (хотя так оно и есть), по модели RGB. Экран (или лист бумаги), получая на свою поверхность освещение от кинопроектора, отражает в наш глаз цвета — уже по системе CMYK. To есть он отражает те цвета, которые не поглотил. Плюс... Плюс???

Да-да, именно плюс. Плюс — черный (не забудьте, пока не включился проектор, экран был столь же черным, как и мы сами, сидящие в темном кинозале).

А физически CMYK тоже пользуется как раз тремя основными красками -— плюс черным цветом. Поэтому в аббревиатуре этой модели не три, а четыре буквы. Правда, в сравнении с RGB ее цвета несколько смещены по спектру:

CMYK — Cyan (бирюзовый), Magenta (лиловый), Yellow (желтый) и Black (черный).

Догадайтесь, отчего же вместо В в аббревиатуре стоит К?

Чтобы не спутать с «В» от RGB, где под этой буквой давным-давно числится голубой цвет. В CMYK взяли не первую букву из имени цвета, а последнюю. Вот такой хитрый народ эти разработчики цветомоделей.

Итак, мы ознакомились поближе с двумя противоположными по смыслу моделями цветоформирования — суммирующей (RGB) и вычитающей (CMYK).

Нам осталось сказать совсем немного. Поговорим о других цветовых моделях.

HSB и HLS

Вариантом, похожим на RGB, является цветовая модель HSB. Только ее три компонента, в отличие от Красного, Зеленого и Синего, совсем другие. Это: Hue (тон), Saturation (насыщенность) и Brightness (яркость).

Вместо смешивания чистых цветов ради получения истинных промежуточных эти промежуточные цвета представлены тремя названными составляющими.

Если вы думаете, что эта модель работает хуже RGB, то ошибетесь. Это две как бы равновеликие модели. А обе они по своей точности не уступают четырехкомпонентной CMYK.

Специфика применения компьютерной или прежней фотографической или телевизионной техники вызывала (а возможно, и вызывает) к жизни специфические или специальные, специализированные модели. Такие модели применяются, например, только в одной определенной отрасли промышленности (а возможно, и всего на нескольких специализированных предприятиях).

Такой моделью является модель HLS — (Hue, Lightness, Saturation), — использующая в своей принципиальной работе Тон, Светимость и Насыщенность.

Для того чтобы понять разницу между яркостью и светимостью — а в остальном модель не отличается от модели HSB, — мы должны просто знать, что в основной модели HSB имеется в виду собственная яркость объекта (как бы принимаем его за источник света), а в разновидности первой модели по имени HLS учитывается светимость объекта (яркость отраженного от него света). Иными словами, в HSB «источник» — Солнце, а в HLS — Луна...

Lab-модель

Авторы программ и интерпретаторы программ, рассказывая о цветовой модели Lab (LAB), любят повторять, что она является аппаратно-независимой. Что это значит?

Дело в том, что любая используемая нами модель зависит от того, на каком аппарате она воспроизводится. Даже на принтерах одной и той же модели (номера серии, даты и часа выпуска) изображение с одного и того же файла может воспроизвестись с таким большим разбросом параметров, что это явно сказывается на цветовом решении. А оно для нас — самое основное: ведь мы издатели!

Взять усредненное значение аппаратных данных мы не можем: это невозможно охватить никакой статистикой. Поэтому расхождения столь велики, поэтому в цветной (особенно полноцветной) печати применяются различные способы калибровки, до калибровки, подгонки, проб и так далее.

Моделью, кок бы исключающей эти неудобства, является модель Lab. Она вбирает в себя модели RGB и CMYK, то есть соответственно равновнимательно относится .и к параметрам источника, и к параметрам приемника. Специфика же модели Lab состоит в том, что она больше подходит все-таки светотехникам, для которых важны параметры особого приемника — человеческого глаза.

В том состоит и сложность работы с такой моделью — и в компьютерной программе, и в полиграфии. Ведь, в конце концов, типография — это не кабинет офтальмолога. К тому же идеальный биологический приемник не работает от микросхем и заключен в систему человеческого организма, а не в компьютерную конфигурацию.

Вероятно, это модель для будущего, когда вместо знакомых нам дисплеев станут применяться технические повторители человеческого глаза (имитаторы). Впрочем, пути развития техники неисповедимы: кто ж мог предположить, что ПК займут вовсе не то место в нашей жизни, какое прочили им самые лучшие фантасты?

Человеческий глаз — тоже, как говорится, «величина переменная», не такая уж и стабильная.

Однако в рамках этой модели все-таки можно кое-что сделать. К примеру, ученые долго разводили полемику на тему: «Что такое насыщенность света?» Вопрос этот далеко не праздный: ведь наступала эра широкого использования технических расчетов светотехнического характера — хотя бы для безупречного проектирования концертных залов или дворцов спорта. Ведь телетрансляция, которую из-за плохой освещенности сцены или площадки невозможно было осуществить, требовала введения в обиход новых параметров, годных не только для зрителя в зале, но и для техники съемок.

И вот для того, чтобы остановиться на значениях насыщенности света и ввести эти показатели в математические формулы, которые учитывали бы насыщенность в связи с другими параметрами — светимостью, к примеру, — умные головы избрали очень простой и дешевый способ. Они выбрали большое число статистов (случайно, с улицы, не заходя в школы подводников или космонавтов) и каждому из них «прокручивали» на сцене освещенные объекты, меняя при этом те или иные параметры. А человек говорил — «насыщенно», «не совсем насыщенно», «наполовину насыщенно» и так далее.

Подведя итог, ученые вывели статистику и для определенных значений поставили показатель 100%, а для определенных — 50% (или 0%).

Так родилась замечательная характеристика Насыщенность Света, которой мы любим теперь пользоваться, и использование ее расширяет свои сферы приложения.

Будьте, пожалуйста, внимательны к модели Lab, ибо она поддерживается не всеми программами.

Так что ж она, в конце концов, представляет собой?

L — это светимость; показатель с условным именем А — варьируется от зеленого до красного и наоборот; показатель В — от желтого до синего.

YIQ-модель

Довольно похожа на предыдущую — модель YIQ, использующаяся в североамериканских телевизионных системах. Разница только в том, что светимость здесь использована черно-белая (для черно-белого телевидения это очень правильно: на экран не «лезут» цветные недостатки-глюки КЗС, как у нас), она заключена в параметре Y.

Два других параметра — I и Q — отвечают за сочетание цветов.

Вот здесь к нашим системам действительно необходимо завести декодер!

Multi-Ink-модель

Эта модель является одновременно, и наиболее простой, и наиболее сложной, поскольку использует суммы готовых цветов. Здесь имеются в виду уже цвета типографских красок, то есть те цвета, краски для которых произведены. Модель напрямую не связана с теорией формирования цвета, кроме локусной общедоступной,, причем упрощенной. Как правило, по этому методу формируется новый цвет из двух готовых красок, реже — трех.

Синтез цветов в этой модели происходит на основе цветов, которые могут быть созданы в разных цветовых моделях, но поскольку задача Multi-Ink-модели заключается лишь в производстве конкретной новой краски для печати, то никаких противоречий между цветами из разных систем и моделей не происходит.

* * *

При том, что фирма Pantone является законодателем и использует около 220 различных цветов и 3000 их сочетаний, при том, что она появилась на полиграфическом рынке задолго до того, как возникли компьютерные системы подготовки к печати, она прочно удерживает первенство в условиях жесточайшей конкуренции. Она же первая стала применять свою систему соответствия между экранным и типографским цветом. Цветовые атласы Pantone Coated самые распространенные в мире.

Кроме того существует еще несколько сильных фирм, использующих свои системы соответствия, в том числе цветовые атласы. Это фирмы и системы Focoltone, Pantone Uncoated, DIG, TOYO, Hexachrome Coated, Hexachrome Uncoated, Pantone Solid to Process, Pantone Process, Trumatch и др.

Самое интересное для того, кто радуется подобной обширной конкуренции, состоит в том, что, оказывается, большинство из названных систем соответствия разработаны... фирмой Pantone!.. А система Hexachrome — ее достаточно свежее нововведение. Эта система использует не четыре цвета, а шесть цветов. И из-за сложности сведения этих цветов при печати печать с использованием шести цветов вместо общепринятых четырех — очень удорожает производство. Это самая дорогая на сегодня цветная печать.

Мне кажется, мы все же немного отдохнули от меню и опций. Но придется возвращаться к ним. У нас впереди разговор о меню Вставка. Это четвертое меню. А всего их в Publisher — 10.


Глава 1

Командное меню «Вставка» (I)

Меню «Вставка» не менее важно, чем меню «Правка» или «Вид». Это уже чисто функциональное меню, хотя некоторые его функции без большой натяжки можно было бы отнести и к командам меню «Вид». Хотя бы ту, которую вы видите на рисунке 1. Впрочем, здесь речь идет о неких дополнительных назначениях, связанных не столько с тем, как это будет выглядеть на экране, сколько тоже функциональных. Потому что вклеивание в страницу, к примеру, полос прокрутки текста или изображения не исчезнет, если мы перекинем файл на другой компьютер и даже в другую операционную среду (допустим, это будет Windows 98): и Windows XP, и Office XP очень лояльны к прошлым нескольким версиям своего же имени — Windows 98, 2000 или Office 2000. Эти способы вставки прокрутки или счетчика — часто применяются при создании Web-публикаций.

Рис. 1. Командное меню Insert (Вставка) и подменю Form Control (Управление Формами)

но начнем рассматривать опции меню Insert по порядку.

Первой опцией является опция вставки страницы. Надо сказать, в приложениях офиса есть одна особенность, знакомая вам еще по Word. Меню «Вставка» содержит опции, которые не называются полным именем. Полное имя опции состоит из ух слов — имени меню и имени опции. Например, вот первая, которая называется ge... (Страница...)

На самом деле имя ее звучит как Insert Page... (Вставка Страницы,..). И так с едой опцией.

Вставку Страницы мы уже рассматривали прежде, по необходимости. Но не грех рассмотреть и подробнее. На рисунке 2 вы видите диалог Вставки страницы.

Рис. 2. Диалог Вставка страницы

В верхнем поле Number of new page: (Число новых страниц) по умолчанию, как в PageMaker, заложено количество — 2. Как правило, больше и не нужно.

Почему? Потому что при последующей вставке в эту публикацию большого объема текста (как правило, страницы вставляют не ради иллюстраций, а чтобы разместить дополнительное количество текстового материала) остальные страниц вставятся автоматически.

Даже независимо от того, сколько будет этих дополнительных страниц — пять . или двести пятьдесят две.

Теперь нам важно, в какое именно место публикации вставить страницы. Ниже поля ввода количества вставляемых страниц есть строки, требующие, чтобы мы конкретно отметили, куда вставляются страницы. Это строки: Before left page (Перед левой страницей), After right page (После правой страницы) и Between pages (Между страницами).

Ниже существует поле Options (Параметры).

В нем — строки. Insert blank pages (Вставка пустых страниц), Create one text frame on each page (Создать страницы с текстовым фреймом каждую), Duplicate all objects on page (Сдублировать на странице все объекты).

Что выбрать из предлагаемого?

Ну, чистую страницу, конечно, сделать можно, но ведь мы же вставляем страницы не для просто так, а для того, чтоб поместить на них не уместившийся или, лучше, дополнительный текст.

Значит, нам нужны на новых страницах такие же фреймы, как и на тех, что уже существуют в нашей публикации. Но у нас есть и блоки изображения (правда, в данной ситуации их нет, но теоретически рисуночные фреймы есть), их бы тоже как-то застолбить...

Выбираем третью строку — Сдублировать на вставляемых страницах все объекты. Текст, кстати сказать, как и рисунок, это не объекты, а содержимое, и потому на новых страницах будут присутствовать только сами фреймы. Заодно выберем Вставить страницы перед левой страницей.

Таким вот образом и получаем то, что получаем: на рисунке 118 видно, что вставленные страницы заняли у нас место второй и третьей, бывшие вторая и третья сдвинулись на место четвертой и пятой, а на их месте на экране появились две пустые страницы под номерами 2 и 3, на которых имеются готовые фреймы.

Забегая несколько вперед, скажу, что Билл Гейтс, в отличие от известных авторов верстанных программ, которыми занимались давние фирмы, конечно, как верстальный мастер ниже упомянутых. Несмотря на универсальность Publisher, программа многого не умет или делает это в ненадлежащих объемах. Так, Майкрософт и представить не могла, к примеру, что кому-то захочется вставить в публикацию не парочку, а сразу сто страниц... Нет, сделать это возможно, но работа получается трудоемкой. Программа выигрывает в другом: верстать почти не надо!

Рис. 3. Вставили две страницы

Вам понятно, что заданное по умолчанию количество страниц (2) я не стал менять.

А можно было бы вставить и сто пятьдесят страниц, и двести восемьдесят восемь...

Ну, со вставкой страниц вроде бы разобрались. Теперь идем дальше по меню sert.

Следующая опция — Insert Section... (Вставка Раздела...). Эта опция существует для очень больших работ — к примеру, толстой книги.

Здесь каждый новый раздел (новая часть, новая повесть и так далее) может начинаться с новых настроек. Все возможности осуществить эти настройки у опции Вставка Раздела... есть.

Вызывая эту опцию, получаем диалог:

Рис. 4. Диалог Вставки Раздела

Строки диалога: Begin a section with this page (Начать раздел с данной страницы), Show headers and footers on the first page of this section (Показ колонтитулов на первой странице для этого раздела).

Как правило, для первой страницы книги или раздела книги колонтитулы не показываются. Хотя здесь по умолчанию против этой строки стоит флажок, его можно даже нужно отменить. Впрочем, если вы не отмените колонтитулы для первой страницы данного раздела, это не так страшно. Мы уже научены несовершенством других приложений, а потому доморощенными способами избавляемся от таких колонтитулов Я уже, кажется, говорил об этом: создаем прямоугольник, который перекрывал бы полностью весь колонтитул, назначаем ему белый цвет, и при этом не забываем такой у. белый цвет назначить границам этого прямоугольника. Тогда он перекроет ненужный текст, а сам не будет виден. Потом его останется только скопировать и вклеить его копию для того, чтоб передвинуть ее на нижний колонтитул, чтоб закрыть и его.

Ниже в диалоге находится поле Page Numbering (Нумерация Страниц). Верхняя строка с полем ввода Number format: (Формат номеров:) существует для выбора способа нумерации. Из открытого списка поля ввода вы видите (рис. 5), что можете пронумеровать страницы и цифрами, и римскими цифрами, и буквами...

Рис. 5. Открыт список Number format:

Следующая строка — Continue from previous section (Продолжить формат нумерации с прежнего раздела). Вы можете не следовать этой строке и изобрести для нового раздела не только новый вид нумерации, но и начать нумерацию опять с первой страницы: видов книг множество, есть и модернистские штучки, — здесь можно выбрать любой вариант на любой вкус.

А новая нумерация начнется, когда вы в строке (и в ее поле) Start at: (Начать с:) проставите флажок и укажете номер, с которого должен начинаться раздел.

С этой опцией, кажется, все тоже выяснили. Переходим к следующей.

Это — Insert Page Numbers... (Вставка Номеров Страниц...). Вы можете резонно спросить: как, а разве мы не вставили номера страниц в Мастер-Странице?

Да, мы уже вставили номера страниц, и новых номеров, дублирующих прежние, нам не нужно. Однако Publisher такая программа, которая дает нам возможность вставлять номера страниц нравящимся нам способом — либо с Мастер-Страницы, либо Через диалог, который близок офисному (вернее, это он и есть). Publisher использует давние разработки, которыми давным-давно пользуется пакет программ Офис, в том числе давний наш знакомый Microsoft Word. Этот диалог — копия вор до некого.

Но взглянем на него:

Рис. 6. Диалог Вставки Номеров Страниц

В верхней строке Position (Позиция) мы выбираем место, где должны находиться номера страниц. По умолчанию нам выпадает строка Current text box (Текущий текстовый блок). Это означает, что программа вставит ваши страницы именно в поле текущего текстового блока. Не отдельно от него, как это делается с помощью Мастер-Страницы, а именно в сам блок.

Поэтому нужно крепко подумать, нужно ли вам это удовольствие, и не следует ли вставить номера страниц через Мастер-Страницу. Тем более что на каждом новом развороте (так делает программа) вам опять придется вызывать диалог Вставки Номеров Страниц, и опять говорить ОК, чтобы номер страницы возник в вашем блоке. Правда, впечатывать эти номера вручную вам все же не придется, но предусмотреть лишнюю строчку для номера — придется на каждом развороте, в каждом блоке. Автоматически впечатывается только сам номер, а предварительная работа должна будет проводиться для каждой из 1778 страниц книги.

Смотрим дальше. В списке выбора позиции мы видим и еще две строки: первая Top of page (Header) — Вверху страницы; вторая — Bottom of page (Footer) — Внизу страницы. Обе эти опции предполагают включение номеров страниц на место верхнего или нижнего колонтитулов. При таком назначении вам не придется ни впечатывать номера, ни назначать их на каждый разворот. Номера преставятся на протяжении всего раздела или всей книги (если вы не разбивачи публикацию на разделы с помощью предыдущей опции) — автоматически и будут соответствовать истинной нумерации. В этом отношении данная опция Вставка Номеров Страниц целиком дублирует функции Мастер-Страницы. Именно в этом отношении они и являются дублирующими друг друга. Или, если хотите, поддерживающими друг друга. А на самом-то деле — друг другу альтернативными.

Но смотрим дальше. Если вы выберете одну из указанных двух строк (Вверху... или Внизу...), делается активным строка поля ввода и открывается поле ввода Alignment, где в списке поля ввода есть три позиции — Left (Слева), Center (По Центру) и Right (Справа). Это уже выбор конкретной точки, в которой будут проставлены номера страниц. Выбирайте то, что вам нужно.

Ниже всех назначений существует строка Show page number on first page (Показать номер страницы на первой странице). По умолчанию здесь стоит флажок, но мы его, конечно снимем. На титульном листе нам не нужно никаких номеров. А флажок, да еще по умолчанию, стоит здесь по самой простой причине: ведь книга бывает одна, а разделов в ней много (по крайней мере два), то есть нам чаще может понадобиться, чтобы номер на первой странице раздела оставался. Это не обязательно цифра 1. Раздел может начинаться и с 79-й страницы, и со 193-й... Как вы помните, в предыдущем диалоге в поле Start at: мы могли указать номер страницы начала раздела — хоть 2887-й...

Впрочем, нет, я зарвался. Я совсем забыл сказать вам одну важную вещь: при назначении разделов номер первой страницы раздела в программе Publisher не может быть больше 1000. Если QuarkXPress позволяет нумеровать последний раздел книги номером первой страницы 9999, то в Publisher эта функция ограничена все же разумными пределами. Сами понимаете, книгу с числом страниц больше 1000, конечно же, не только тяжело читать, но и даже брать в руки. Будь я на месте читателя или покупателя такой книги, я бы даже интересоваться ее содержанием не стал. Психологически читатель лучше купить среднего качества многотомник, чем возьмется за непреподъемный однотомник — будь это даже полное собрание сочинений Пушкина в одном томе...

Рис. 7. Вот, кажется, выбрали — вверху страницы и слева

Итак, с назначением номеров страниц мы тоже вроде бы все выяснили. Пора двигаться дальше.

На рисунке 8 вы видите диалог Date and Time (Дата и время). Он вызывается строкой Insert Date and Time... (Вставка Даты и Времени).

Здесь комментировать фактически нечего. В двух списках вы видите: в первом (Available formats — Имеющиеся форматы) кучу способов записать дату и время, выбирайте любой, а во втором (Language — Язык) — язык, на котором эта запись будет осуществлена. Из последнего списка мне особенно нравится возможность сделать эти записи на турецком и на греческом.

Рис. 8. Вставка Даты и Времени

Следующая опция — Insert Symbol... (Вставка Символа...).

Рис. 9. Диалог Вставки Символа

На рисунке 9 вы видите этот диалог Вставки Символа. Он целиком повторяет вордовский диалог того же содержания. Говорить о нем было бы просто неуместно, ибо кто ж из пользователей не пользовался таким диалогом (из знатоков программы Word). Однако нельзя не упомянуть одного важнейшего обстоятельства.

Оно состоит в том, что начиная с Office XP Майкрософт ввела несколько новых символов — к примеру, титло и ударение. Кстати, в нижнем поле Recently used symbols (Символы недавнего применения) ударение фигурирует как одно из первоочередных символов по умолчанию. В сравнении с последним Офисом, где диалоговое окно Symbol было представлено в прежнем виде, не менявшемся на протяжении нескольких версии, здесь, в Офисе ХР, к основному окну просмотра символов добавилось дополнительное (то самое нижнее поле, где вы видите 16 знаков в одну строчку — Символы недавнего использования, применения).

Изменилась кодировка символов для обмена информацией в файлах с применением неформатированного текста. Теперь Майкрософт применяет кодирование Unicode вместо прежнего ASCII (American Standard Code for Information Interchange — Американский Стандартный Код для Обмена Информацией).

Офис ХР по умолчанию применяет коды Unicode, и упомянутые символы ударения и титла существуют только при этом кодировании. Соответственно если вы набрали текст в «Ворде» и перебрасываете его, к примеру, в PageMaker, то там эти символы не будут правильно интерпретированы, поскольку в PageMaker и в QuarkXPress применяется прежний код ASCII. Здесь и заключается то важнейшее обстоятельство, что при передаче текста для верстки в верстальное приложение — только Publisher воспримет текст корректно.

Вставка символа осуществляется известным способом, и потому мы не станем рассматривать этот процесс подробно. Идем дальше.

Опция Insert Design Gallery Objects... (Вставка Объектов из Галереи Дизайнов...). Эта опция открывает диалог Галерея Дизайнов:

Рис. 10. Галерея Дизайнов

Здесь множество готовых решений, хотя, конечно, сколько бы их ни было, они узнаваемы и потому, судя по нашему менталитету, неприменимы. Но Запад есть Запад...

На рисунке 10 вы видите лишь один тип дизайнов — Mastheads (я бы перевел это как Профессиональные Заголовки).

В списке Categories (Категории) есть такие же заголовки для Web, знаки для Web-навигации, логотипы, аксессуары, рамочки, календари и так далее, и так далее.

На рисунке 11 вы видите, к примеру, категорию Picture Captions (дословный перевод — Изображения-Каверзы, но что оно на самом деле, теряюсь в догадках). Но все-таки взгляните:

Рис. 11. Категория Picture Captions

Думаю, со вставкой этих объектов у вас не будет проблем. Поэтому идем дальше.

Нам интересна другая опция — та, что идет следом за рассмотренной. Она называется Add Selection to Design Gallery... (Включить Избранное в Галерею Дизайнов...). Что и попытаемся мы сделать с картинкой, которая вам уже намозолила глаза — тот самый автомобиль, который мы поместили на Мастер-Страницу. Вот он, на рисунке 12. Выделим его.

Рис. 12. Этот объект вставим в Галерею Дизайнов

Итак, выделили и вызываем опцию Add.... Вот его изображение уже в окне просмотра диалога (рис. 13). В верхнюю строку (поле ввода) введем имя нашего рисунка— пусть это будет Mashinka (Автомобильчик).

Потом выберем Категорию.

Впишем известную нам — Изображения-Каверзы.

Рис. 13. Диалог вставки с изображением вставляемой картинки

Рис. 14. Сделали все назначения

И говорим ОК. И открываем эту Галерею с помощью хотя бы той же команды Вставить Объект из Галереи Дизайнов:

Рис. 15. Взгляните сами...

Да, вот он, наш Автомобильчик — на вкладке Your Objects (Ваши, Твои, Свои Объекты).

Мы вполне удовлетворены...

Идем дальше.

Мы добрались до Вставки Управления Формами (Insert Form Control).

Взгляните на это подменю еще раз. Посмотрим, что оно собой представляет, хотя сомневаюсь, что оно нам понадобится в издательской работе по макетированию и верстке.

Рис. 16. Подменю Form Control

Первая строка этого подменю — Insert Textbox (это не вставка текстового блока в привычном верстальщику понимании — это Вставка Поля Ввода Текста).

Вот оно, это поле, вставилось у нас (рис. 17) в то место текста титула, где пульсировал курсор.

Эти Поля Ввода существуют в специальных программах для сочинения интерфейсов новых приложений, баз данных и прочих премудростей, касающихся программ.

Но в нашем случае, я считаю, они существуют для создания Web-страниц и; электронных версий публикаций.

Для того, чтобы поле можно было передвигать, варьировать его местоположение, надо вставлять Поле Ввода просто в режиме Стрелка.

Но оставим, как есть. Мы же просто экспериментируем...

Рис. 17. Вставили Поле Ввода Текста

Дважды щелкнув курсором в Поле Ввода (куда ничто не вводится, пока мы его создаем), получим диалог его настроек:

Рис. 18. Диалог Настройки Параметров Поля Ввода

Обратите внимание, из опций этого диалога мы черпаем кое-какие сведения о настройках и самой программы. К примеру, для тех, кто не знал, какое число символов способно принять Поле Ввода, при взгляде на строчку Number of characters allowed (Число принимаемых знаков) становится совершенно ясным, что по умолчанию — это 255 символов. Это число давно и неизменно фигурирует в Windows (это опция именно из настроек операционной системы), здесь оно не изменилось. Впрочем, вы можете поменять его, именно для этой цели и расположен счетчик со своим полем ввода. Но поменять его вы можете только в меньшую сторону, ибо старше 255 этот счетчик чисел не знает — так ему задано. Обратимся к верхнему полю — Appearance (Видимое), в которое входит и счетчик. В поле ввода выше него вы, в зависимости от задач, можете внести текст, который должно содержать ваше Поле Ввода, которое вы вставили. Оно станет содержать этот текст по умолчанию (Default text:). Ну, не зная, зачем нам это нужно, все-таки введем что-нибудь. К примеру, «Огурцы 40 руб» (сегодня в Москве они, кажется, в такую цену).

Ниже счетчика расположена строка Hide sensitive text with asterisks (***) — Скрыть воспринимаемый текст за звездочками (***). Мы можем вставить флажок в поле флажка, и вы станете вставлять текст в Поле Ввода на принципах Пароля. Но нам этого не нужно, идем по диалогу далее.

Нижнее поле — Data processing (Обработка данных) и поле ввода в нем Return data with this label: (Ярлык данных отчета, если я правильно перевел).

Теперь откроем то, что под кнопкой Form Properties... (Свойства Форм...) и убедимся, что эти опции все же относятся к лепке Web-страниц и Web-сайтов. Взгляните на рисунок 19:

Рис. 19. Диалог Form Properties. Без комментариев

Когда мы закроем все диалоги (сказав, естественно, ОК), увидим, что наши Огурцы уже вписаны в Поле Ввода.

Посмотрим, каким образом (хотя и так понятно) вставляется Text Area (Текстовое Поле). На рисунке 20 вы видите, что Поле Текста преспокойно вставилось, едва я щелкнул на команде в строке Text Area рассматриваемого подменю. Заодно убедитесь, что Огурцы на месте:

Рис. 20. Вставка Текстового Поля

Так же дважды щелкнем на нем мышкой, и возникнет диалог, который я ни комментировать, ни рассматривать не буду. Таким же образом вставляется и Счетчик (List Box), и Checkbox (Окошко для Флажка) Option Button («Пуговица» для Флажка), и Submit (Связь, Подчинение). Все это не для издательского дела, как мы привыкли его понимать, а для публикаций в Интернете.

Взглянем только на диалог Вставки Текстового Поля, прежде чем распрощаться с подменю Form Control.

Рис. 21. Диалог Multiline Text Box Properties

Идем дальше.

На рисунке 21 изображен диалог, который возникает при вызове опции! Insert HTML Code Fragment (Вставка Фрагмента с HTML-кодом).

Больше ничего существенного сказать об этой опции не берусь.

Все это для Интернета. Как и следующая опция, подменю которой изображено на рисунке 22 — Индивидуальная Информация (Personal Information) — для впечатывания каких-то своих данных в информацию на сайте или на Web-странице.

Я уже говорил, что Windows XP и Офис ХР значительно повысили свою интерактивность. Вплоть до того, что не моги задать справочной системе простенького вопроса — тут же отсылает на сайт Майкрософта. Везде — сплошная регистрация.

Рис. 22. Диалог Вставки Фрагмента с HTM

Рис. 23. Подменю Персональной Информации пользователя

Оставим в покое эту группу команд. Перейдем к следующей группе, которая функционально для нас очень важна.

Первой в числе опций этой группы значится Insert Picture (Вставка Изображения).

Рис. 24. Подменю Picture и подменю AutoShape меню Insert

Как видите, вставки всех видов изображений собрались в одном подменю, принадлежащем меню «Вставка». Здесь и Картинки (Clip Art), и Файлы (From File) и изображения со Сканера или Камеры (From Scanner or Camera), и Автофигуры (AutoShape), и Объекты WordArt.

В случае вставки рисунков (изображений) программа Publisher так же дублирует опции, как и с текстом, и с номерами страниц. В этом нельзя усматривать какое-то сверхдостижение разработчиков. Объяснение очень просто. В верстальной программе все вставки подобного рода очень функциональны и требуют иной механики, иной технологии импорта, чем просто рисовальная или просто текстовая программа. Соответственно здесь и разработаны чисто верстальные способы помещения на страницы публикации текста, номеров страниц, колонтитулов и изображений.

Если вы помните, мы очень легко помещали на страницу изображение: при помощи кнопки-инструмента с Панели инструментов (кнопка называется Picture Frame) обозначали Фрейм Изображения, и на экран вызывался диалог вставки изображения, где мы столь же легко находили в соответствующей папке соответствующее изображение и говорили Insert (кнопкой в диалоговом окне, носящей это имя). Потом изображение появлялось на странице.

Это работала верстальная программа. Вернее, работали принципы вставки изображения в верстальных программах, которыми Publisher, естественно, владеет.

Здесь, в меню Insert (Вставка), мы встретились с иными принципами — теми, что были разработаны давным-давно той же Корпорацией Майкрософт для решения задач текстовых и графических программ, входящих в пакет приложений Офиса. Эти принципы использовались и в программе Word, и в программе Power Point. Они используются и сейчас в тех же программах, они никуда не подевались.

Вы можете пользоваться либо «верстальными» принципами вставки, либо вордовскими — кому как понравится. Publisher для этого годится. Тем более что качеству вашей работы это никак не повредит.

Начнем с Insert Clip Art (Вставка Картинки). Вызвав опцию, получаем Докер Insert Clip Art. Можно найти картинку в поле Search in: (Искать в:), где записано: Selected collections (Избранные коллекции).

Рис. 25. Организатор Картинок

А можно искать картинку через Clip Organizer (Организатор Картинок), используя эту гиперссылку в нижней части Докера. Этого Организатора вы и видите на рисунке 25. В указанных в окне навигатора Организатора Картинок папках (Мои коллекции и Web-коллекции) отыскиваем картинку и вставляем ее. Вставка эта в Publisher равносильна такой же вставке картинки в Word. После вставки картинка ведет себя, как обычный объект. С ним можно проделывать все те операции, которые возможно проделывать с объектами в верстальной программе.

Беда в том, что картинки Microsoft (а это именно они, множество картинок, входящих в коллекцию) настолько просты, настолько даже примитивны (это еще пол беды), настолько узнаваемы, что пропадает всякое желание их вставлять. Я не шучу. Вот уже множество лет — по крайней мере лет семь — эти картинки в том или ином варианте всплывают в массе документов, рекламных уголков всевозможных газет и даже журналов, что становится признаком плохого тона пользоваться этими; расхожими объектами. Не спасает и количество: нарисуй хоть сто тысяч картинок, стиль их ни с каким не спутаешь. По образу своему они напоминают кадры из комиксов, которые, я считаю, никогда у нас не приживутся. Их пытались внедрить в наше сознание, когда мне было 6-7 лет, в годы той, первой, хрущевской! «перестройки» («оттепели»), а теперь — сейчас. Ну, не по-нашему это все сделано, не на нашем менталитете замешено.


Глава 1

Интерфейс №1 Microsoft Publisher (II)

Идем дальше.

Для удобства рассмотрения Панелей назначим в уже знакомом вам диалоге — Показывать Панели Инструментов в два ряда. Результат — на рисунке 11.

Рис. 11. Панели управления в два ряда

Панель по имени Стандартная находится в верхней строке.

Вот ее кнопки — New (Новая Публикация), Open (Открыть), Save (Сохранить), E-mail (Электронная почта E-mail), Search (Поиск, Найти), Print (Печать), Print Preview (Просмотр Печати), Spelling (Правописание).

Это не все.

Здесь перечислены лишь опции, содержащиеся в меню «Файл», но не все, конечно, а те, команду которым можно задать с Панели управления, то есть которые можно исполнить, не прибегая к назначениям в диалогах.

Просмотр печати, например, отдельно стоящая утилита, открывающая свое окно, но оно не является диалоговым, потому что работает как программа.

Вероятно, это самая значительная (объемная, по содержащемуся за нею смыслу) из утилит.

Впрочем, кнопка «Открыть» также обязательно покажет вам диалог — именно диалог, где вы найдете в окне-навигаторе тот файл, который вам необходимо открыть.

Кнопка, отвечающая за электронную почту, откроет для вас не диалог и не программу, а Мастера Outlook 2002.

А кнопка поиска Search — вызовет Докер Поиска, который вы видите на рисунке 12.

Рис. 12. Докер Поиска Search

Рассмотрим его кратко, этот Докер. Полностью он называется Basic Search (Обычный поиск). Верхнее поле Search for: (Искать:) содержит поле ввода текста (Search text:), который необходимо отыскать. А также кнопки внизу, под этим полем ввода — Search и Restore (Найти и Восстановить). Ниже этих кнопок мы видим гиперссылку Search Tips... (Найти подсказки...).

Ниже расположено поле Other Search Options: (Дополнительные Параметры Поиска), где соответственно в полях ввода есть возможность ввести область поиска в поле Search in: (Найти в:) (рис. 13) в любой из папок, которые годны для вашего поиска. Начинается все, естественно с Моего Компьютера. В поле Типы Файлов Результатов: (Results should be:) можно выбрать из каких типов файлов вы хотите найти искомое. Перечень серьезный, как видно из рисунка 14: это и файлы Word, и файлы Power Point, и файлы Publisher...

Рис. 13. Поиск в поле Найти в:

Рис. 14. Поиск в поле Типы Файлов Результатов:

Кроме того, внизу, под этим полем ввода вы видите строку Fast searching u currently disabled (Быстрый поиск отключен) и внизу гиперссылку Search options... (Параметры поиска...), вызвав которую, сможете получить диалог, в котором есть включение быстрого поиска. Быстрый поиск, в отличие от обычного, позволяет искать по параметрам, которые при отключении быстрого режима не используются. К таким параметрам относятся такие, как имя автора, ключевые слова заголовков, типы (стили) заголовков и т. д.

Все эти вместе взятые опции такой функции, как Поиск, целесообразно использовать где-нибудь в больших издательствах, особенно в общей издательской сети, когда, к примеру, необходимо найти какую-нибудь цитату или что-то в этом роде в какой-то давно прошедшей подготовку книжке. Потому и дается возможность заказывать такие, на первый взгляд, странные параметры поиска.

Кроме того, есть еще и Расширенный Поиск (Advanced Search...) — гиперссылка в поле See also: (См. также:).

Рис. 15. Докер Расширенного Поиска

При этом расширится верхнее поле «Искать:», где будут учтены новые параметры поиска — приоритеты, адреса, ссылки и прочие.

Но быстрого поиска в обычных условиях нам вполне достаточно, поэтому с расширенным поиском сильно подождем. Вернемся к быстрому и вызовем гиперссылку Параметры поиска..., и в ответ получим диалог, предлагающий нам на будущее включить службу индексирования (есть такая услуга в Офисе ХР, а точнее — в Windows ХР). Соответственно по результатам действия этой службы мы и сумеем включить быстрый поиск, который нам (на пять минут) сэкономит время, хотя для того, чтоб индексирование работало должным образом, подозреваю, мы должны будем поступиться быстродействием ПК, поскольку Windows ХР нас наедине с нашим аппаратом тогда уж точно не оставит. Вчитайтесь в то, что предлагается в диалоге, и вам это станет совершенно ясно. Для удобства привожу тот же диалог по-русски, вызванный из программы Word ХР:

Рис. 16. Диалог относительно быстрого поиска

Вот что говорится в справке программы о Службе индексирования:

«Служба индексирования извлекает сведения из набора документов и собирает их в структуру, обеспечивающую быстрый и удобный доступ к этим сведениям с помощью команды поиска Windows ХР, формы запроса службы индексирования или обозревателя. Эти сведения могут включать текст (содержимое) документа, характеристики и параметры (свойства) документа — такие, как имя автора. После создания индекса можно искать (или запросить) в нем документы, содержащие ключевые слова, фразы или свойства. Например, можно запросить все документы содержащие слово «продукт», либо все документы Microsoft Office, созданные определенным автором. Служба индексирования возвращает список всех документов, соответствующих указанным условиям поиска. Сведения о различных способах создания запросов содержатся в разделе Использование языка запросов службы индексирования.

Служба индексирования, используя фильтр документа, извлекает из документов текст и свойства и передает их механизму индексирования. Этот процесс называется индексированием. Дополнительные сведения об индексировании содержатся разделе Индексирование.

Все данные индекса автоматически сохраняются службой индексирования в каталогах System и Web. Дополнительные сведения о каталогах содержатся в разделе) Каталоги.

Служба индексирования выполняет индексирование документов следующих типов:

  • HTML;
  • текст;
  • Microsoft Office 95 и более поздние версии;
  • почты Интернета и новостей;

все остальные документы, для которых имеются фильтры.

Служба индексирования работает непрерывно и почти не нуждается в обслуживании. После ее настройки все операции, включая создание и обновление индекса, аварийное восстановление в случае сбоя питания, выполняются автоматически. Сведения об администрировании службы индексирования содержатся в разделе Администрирование службы индексирования.

Примечание

Администраторы и разработчики приложений могут обеспечивать поддержку! других документов, создавая фильтры, использующие открытый интерфейс IFilter.j Дополнительные сведения о применении интерфейса IFilter содержатся в пакете «Microsoft Platform Software Development Kit».».

Итак, с поиском разобрались. Остальные вопросы, связанные с кнопками инструментов управления Панели Управления Стандартная, какие мы успели перечислить, будут подниматься и рассматриваться, тем или иным образом, дальше по ходу повествования.

Продолжим перечислять кнопки Панели: Cut (Вырезать), Сору (Копировать) и Paste (Вставить). По поводу этих кнопок вряд ли у пользователя, добравшегося в своих занятиях до верстки и макетирования, возникнут какие-то вопросы. Далее: Format Painter (Формат по образцу), Undo (Отменить), Redo (Повторить).

Повтор в программах-приложениях, как правило, всего один — у нас это выглядело бы Повторить только что отмененную операцию. А вот отмен — слава Биллу Гейтсу! — в Publisher целых двадцать!

Для верстальной программы, считаю, этого более чем достаточно.

Не одна, как в Кварке или в PageMaker, что, согласитесь, катастрофически мало.

Но Publisher готовит и еще один сюрприз: оказывается, ровно столько же раз действует и команда Redo!

То есть сделав последовательно двадцать отмен, вы вдруг обнаруживаете, что все это ошибка, и что все надо вернуть до самой первой отмены, то есть вы очнулись и решили, что все прежние назначения вам очень и очень нужны...

Что ж, точно так же последовательно вы сможете восстановить положение, щелкнув двадцать раз команду Redo (Повторить то-то и то-то).

Вот, пожалуй, и все, что в качестве кнопок управления вошло в Панель из меню Edit.

Далее. Кнопка Bring to Front (Поместить Впереди Всех). Она содержит подпанельку-подменю, где есть еще команды: Send to Back (Отнести Ниже Всех), Bring Forward (Перенести вперед) и Send Backward (Отнести назад).

Это касается объектов (слоев), то есть порядка, в котором мы видим их. Объекты, перекрывающие друг друга, должны выстраиваться по каким-то приоритетам, и нам дано решать, по каким. Поместить один объект поверх другого или, наоборот, ниже всех объектов — мы вполне можем, воспользовавшись этой кнопкой и даже забыв о том, что именно эти же опции находятся совсем недалеко — в меню Arrange (Порядок).

Далее — кнопки Insert Hyperlink (Вставка Гиперссылки, это опция из меню Insert), Web Page Preview (Просмотр Web-страницы — из меню File), Columns (Колонки).

Последняя из названных не имеет опций ни в одном из меню (или я не наше; как ни старался), кроме Докера. Да, собственно, назначать колонки легче с Панели чем из меню. Впрочем, тогда непонятно, каким образом мы станем задавать правильные размеры — к примеру, важнейший размер расстояния между соседним колонками, которое на профессиональном языке называется гаттером. Поживем — увидим.

Следом идет кнопка Special Characters (назовем это — Специальные Значки, хотя везде их называют Непечатаемыми Символами). Здесь речь идет о( известных нам и по другим приложениям знаках конца абзаца и интервала между словами. Один из них, первый, представляет собой довольно неэстетичнук кривулину на палочке (впрочем, узнаваемую за версту), второй же — точка посреди строки (если бы она стояла в одной ячейке с двоеточием, то располагалась бы как раз между двумя точками, символизируя собою третью). Ни тот, ни другой значки не печатаются при выводе документа на печать, они нужны лишь для визуального контроля верстальщику.

Впрочем, как я уже неоднократно говорил, опытный верстальщик прекрасно видит лишний интервал, а конец абзаца разглядит, если придется один абзац соединять по каким-то причинам с другим. Лишние интервалы при этом также убираются. Я стараюсь такими значками не пользоваться, чего и вам желаю. Эта опция пришла на Панель из меню View.

Далее вы видите окошко масштаба просмотра. Тут говорить и не о чем, и незачем. Следующие кнопки относятся также к Масштабу и содержат одна — изображение лупы со знаком минус (уменьшить), другая — со знаком плюс (увеличить).

Отличие Publisher от других программ в том, что, щелкнув на той или второй кнопке, вы тут же, не перенося курсора на страницу документа, получаете изменение масштаба. Еще отличие от других программ-приложений: изменение масштаба в Publisher происходит не в два и не в один с четвертью раза, а пошагово — согласно существующей градации списка масштабов просмотра — от 400% до 10%. Последний вполне соответствует позиции «Монтажный стол» из PageMaker и для того и используется.

Сам вид масштабного стола не такой ядовитый, как в указанной верстальной; программе, — соответственно в Publisher и работать приятнее.

Монтажный стол здесь — светло-серый на темно-сером фоне, а не желтый!

На Монтажный стол вы можете сложить на время — изображения, мелкие блоки рубрик, логотипы и так далее. На Монтажный стол на длительное время можно отправить (вручную) даже громадные объемы текста (заключенные в Текстовые Блоки, естественно).

Рис. 17. Страничка публикации в масштабе просмотра 10%

Далее фигурирует только кнопка «Справка» со знаком вопроса.

Она вызовет вам Помощника, и он ответит, если сможет, на все интересующие вас глобальные и текущие вопросы. Но предупрежу заранее: так же, как почти во всех приложениях Майкрософт, спрашивать... ну, не нужно.

Вот и закончилась Панель Стандартная.

Далее идет кнопка Toolbar Options (Параметры Панелей Инструментов), которую мы рассматривали — правда, вызывая меню и подменю из другого места рабочего окна программы — такой же кнопкой с Панели Инструментов.

Впрочем, давайте взглянем, какие кнопки остались за бортом Панели. Какие же из них не поместились на Панель?

Рис. 18. Вот меню под кнопкой Toolbar Options

Да, не повезло одной-единственной кнопочке — Повернуть (Rotate). Хотя нет: мы видим, что рядом с кнопкой еще и открывающий треугольничек. И открывает он тоже подпанельку-подменю, в котором содержатся достаточно серьезные опции — Free Rotate (Свободное Вращение, или Повернуть, о чем мы уже говорили), Rotate Left (Повернуть Влево), Rotate Right (Повернуть Вправо), а также Flip Horozontal (Отразить по Горизонтали) и Flip Vertical] (Отразить по Вертикали). Что ж, ценная кнопочка. И касаются ли эти команды только объектов, или еще и фреймов, это мы посмотрим дальше.

Следом за Стандартной Панелью расположены кнопочки Панели Связывания Фреймов. Их, как помните, немного, но они очень нам важны.

В Publisher нет специальных назначений, как в PageMaker, — к примеру, того xoef Автоматического заполнения. То есть связывание страницы со страницей здесь происходит без нашего участия, по умолчанию. Но для связывания фреймов на одной странице с фреймами, расположенными на другой странице, эти опции незаменимы. Даже связь фреймов на одной странице может быть (особенно в газете) какая угодно.

Вот эти кнопки: Create Text Box Link (Создать Связь Текстового Блока), Break Forward Link (Разорвать Прежнюю Связь), Previos Text Box (Предыдущий Текстовый Блок) и Next Text Box (Следующий Текстовый Блок).

Вот и вся Панель Connect Frames. Щелкнем по кнопочке Параметры Панелей Инструментов, которая идет последней в этом первом ряду... И убедимся, что на этот первый ряд одна лишь кнопка Free Rotate не уместилась. То есть и на эту Панель, и на Панель Стандартная — всего одна «лишняя» кнопка.

Идем на вторую строку, второй ряд, на Панель Форматирования.

Вот ее опции и кнопки: самая первая, с двойной буквой А на поверхности — кнопка, посредством которой можно вызвать Докер Стилей. Называется она Styles and Formatting (Стили и Форматирование). Взглянем на этот Докер на рисунке 19. Он так полностью и называется — Стили и Форматирование.

Рис. 19. Докер Стили и Форматирование. Открыт диалог Новый Стиль

Действительно, чтобы вам не рассматривать скучную страницу публикации, с которой мы еще не начали работать, я сразу же открыл кнопкой New Style диалог создания Нового Стиля.

Вы видите, что здесь, в диалоге, есть возможность назначить любой стиль и зафиксировать его.

В списке, как тоже видно из рисунка, у нас фактически всего один стиль — стиль Normal. Строка над ним Clear Formatting (Очистить Форматирование) означает то, что, если применить ее к выделенному фрагменту, то он, если имел какое-то форматирование, назначенное то ли по ходу работы над ним, то ли непосредственно назначив ему имя стиля, теперь все эти виды форматирования утеряет.

Опция не лишена смысла, поскольку часто бывает, что одному и тому же куску текста (а чаще — заголовку, подзаголовку и т. д.) несколько раз назначается тот или иной формат, тот или иной стиль.

Когда вы наконец приходите к выводу, что соответствующие друг другу строки или абзацы должны иметь иное форматирование и иной стиль, вы перед назначением их очищаете текст от прежних назначений.

Итак, с полем Pick formatting to apply (Выбор форматирования для применения) вроде бы разобрались.

Но не совсем.

Вы видите, что здесь, кроме стиля Normal, нет никаких других стилей. Одно дело, что через диалог создания стилей мы можем самостоятельно применить и назначить практически любой стиль, но ведь в программе по умолчанию должно же быть что-то существенное? Ну, хоть стилей пять-шесть?

Оказывается, разработчики Publisher не поленились. Они прекрасно знали, что мы с вами, взявшись за эту верстальную программу, уже собаку съели на других приложениях, особенно текстовых (Word), и, хочешь, не хочешь, привыкли к форматированию и назначению всевозможных стилей там.

Над кнопкой Create new style (Создать новый стиль) существует другая кнопка — Import styles (Импорт стилей).

Взглянем на диалог открытия документа, из которого Publisher может импортировать стили.

Стиль не обязательно сочинять на месте или каждый раз для идентичных и однохарактерных строк, абзацев, списков, названий рисунков, заголовков, имен глав, частей, разделов... Когда-то где-то в прежних работах вы уже задавали тот или иной стиль, так что здесь вполне можно воспользоваться вашим же стилем, сочиненным ранее.

Так посмотрим на предлагаемый диалог, который мы видим на рисунке 20.

Рис. 20. Диалог Импортирования Стилей

В списке возможных расширений файлов, который я для вас нарочно открыл и немного продвинул вверх при помощи вертикальной прокрутки, видно, что в принципе, установив соответствующие конвертеры, можно загрузить (импортировать) в программу любой стиль из любого приложения.

Здесь отсутствуют лишь PageMaker и QuarkXPress.

Но оно и понятно: зачем верстальной программе Publisher конвертировать файлы конкурентов?

Кстати, есть одно небольшое сообщение, приводя которое, я забегаю вперед, ибо нужно было бы донести его до вас лишь в следующем разделе книги, который будет посвящен новой версии PageMaker...

Но сообщение такое: PageMaker 7,0, последняя версия верстальной программы фирмы Adobe, уже преспокойно конвертирует файлы Microsoft Publisher!

То есть, выходит, Adobe вполне сознает, какого уровня идет конкурентная борьба, и соответственно принимает меры и предпринимает шаги для того, чтобы пользователь, который, в основном, и не должен быть в курсе этих экономических боев, не пострадал и имел возможность в лице PageMaker продолжать сохранять альтернативу майкрософтовской программе верстки.

Чего не скажешь о последней, пятой версии QuarkXPress: она существует как бы сама в себе и видимых шагов с ее стороны навстречу пользователю не наблюдается.

Более того, QuarkXPress 5,0, версия, готовившаяся к выпуску на фоне давно заявленной Корпорацией Майкрософт Windows XP, не содержит некоторых пристроек к Windows XP, и соответственно перекладывает на пользователя гигантские проблемы, которые сама фирма Quark не захотела (а может, не сумела???) решить.

Однако сейчас мы ничего импортировать не станем, я только показал вам, что это можно сделать.

Идем дальше.

В нижнем поле See also (См. также) мы видим гиперссылку, отсылающую нас к Докеру Font Schemes (Стили Шрифтов).

На рисунке 21 вы видите, что содержит этот список рекомендуемых в Применение Шрифтовых Стилей (Apply a font scheme:).

Очень любопытно, что в программе есть устойчивые, разработанные специалистами сочетания шрифтов, где указан больший (Major) и меньший (Minor), — чтоб мы, выбирая самостоятельно, поменьше блуждали в потемках и не эпатировали будущего читателя тех опусов, что мы наверстаем, — тем, что наши шрифты могут не сочетаться друг с другом, а это бывает и у опытных верстальщиков, и особенно у неопытных.

Скажете: подумаешь, шрифт! Лишь бы читалось...

Нет. Одну книгу приятно взять в руки и не выпускать ее, а другую, как бы ни было интересно содержание, хочется поскорее дочитать до конца и сбагрить куда-нибудь. А чаще — вовсе не дочитывать, потому что и глаза устают, и в животе неизвестно откуда тяжесть какая-то...

Рис. 21. Докер Font Schemes

По этому докеру можно назначать шрифты парами.

Обратите внимание, как именуются сочетания шрифтов — верх художественности. Стили: Литейный, Экономический, Слияние, Индустриальный, Гранка... Кажется, в зобу дыханье сперло, кислорода не хватает.

Но оставим пока восхищения и двинемся далее.

Следом за кнопкой Стили и Форматирование Панель Форматирования содержит само поле стилей, где указан по умолчанию стиль Normal. Открыв этот список, в скором времени мы сможем выбирать из него соответствующий нашим задачам стиль абзаца.

Следующей строчкой списка, которая записана как More... (Больше...), после щелчка на ней мы откроем тот же Докер Стили и Форматирование.

Следом вы увидите поля списков — шрифта (Гарнитура) и размера шрифта (Кегль).

Далее — кнопки характерного начертания шрифта.

Нормальное начертание не указано, поскольку исполняется по умолчанию.

Зато вы видите кнопки Полужирный, Курсив и Подчеркнутый. Далее видим несколько кнопок выравнивания текста. Это Align Left (Выравнивание по левому краю), Align Right (Выравнивание по правому краю), Justify (Выравнивание по формату, или Правильное). Наперед кажу, что почему-то в запасе осталась кнопка Выравнивания по центру (Center).

Но мы ведь еще и не пользовались программой по-хорошему, то есть она ещё не вынесла на Панель все наиболее используемые кнопки.

Далее. Numbering (Нумерованный список). Маркированный список (Bullets) отчего-то проигнорирован и остался также за узкой кнопочкой, то бишь на «скамье запасных».

Следом — две кнопки — Уменьшить отступ (Decrease Indent) и Увеличить отступ (Increase Indent). Чистое форматирование абзаца.

Дальше — две кнопки: Decrease Font Size (Уменьшить Размер Шрифта) и Increase Font Size (Увеличить Размер Шрифта). Здесь тоже все понятно.

Далее идут уже, как говорится, «цветные» кнопки: Fill Color (Заливка Цветом) — заливается либо объект, либо фрейм; Line Color (Цвет Линии); Font Color (Цвет Шрифта).

Далее — три кнопки, касающиеся выбора типа линии, типа границы, типа стрелки. Это: Line/Border Style (Стиль Линии/Границы), Dash Style (Стиль Штриха), Arrow Style (Стиль Стрелки).

Ну, и оставшиеся на Панели две кнопки: Shadow Style (Тип, Стиль Тени) и 3D Style (Стиль 3D)

Эти кнопки практически все знакомы нам по Word или Power Point — давним приложениям Офиса.

Ничего особенно нового Publisher не вносит в старые проверенные опции. Можно нарисовать фигуру (не обязательно правильную) и придать ей тень или перспективу. Причем здесь уже различаются — параллельная перспектива (схожая с изометрией) и удаляющаяся перспектива (естественная, принятая в изобразительном искусстве, когда взаимно параллельные ребра параллелепипеда изображаются сходящимися в отдаленной точке схода.

Посмотрим, что у нас осталось в запасе, под кнопкой Toolbar Options.

Что ж, как видно из рисунка 22, лишь две кнопки не поместились в общий ряд — это Выравнивание по Центру и Маркированный список.

Смотрим дальше. О Линейках я уже говорил. А на рисунке 22 вы и сами видите, что выделенный фрейм тут же «отпечатался» на Линейке (Горизонтальной) своими размерами.

Но вот он, рисунок 22:

Рис. 22. Hе поместившиеся кнопки Панели Форматирования

О Рабочем поле документа говорить не имеет смысла — и так понятно, что ниже Линеек уже начинается Рабочее пространство, где мы работаем непосредственно над документом.

Смотрим дальше. Справа, как это водится, расположена Полоса Вертикальной Прокрутки страницы. Ниже Рабочего пространства Строка Полосы Горизонтальной Прокрутки. А ниже нее — Строка состояния. Но половину этой строки занимает Навигатор Страниц.

Для того, чтобы продемонстрировать, что он существует, я специально для рисунка 23 поместил в Публикацию тот самый текст, который вы читаете. Я его не верстал, практически ничего еще с ним не делал, только поместил.

После парочки вопросов программа сама разместила этот текст и сама назначила ему число страниц, в которое он вписался. У нас, если помните, была всего одна страница, теперь —- сорок семь. Прокрутка номеров страниц, как вы видите, в программе тоже имеется.

Рис. 23. Публикация разрослась!

Ну, и пару слов о самой Строке состояния.

Справа в Строке вы видите два значка, рядом с которыми присутствуют некие цифры. Значок номер один, который ближе к Навигатору Страниц, определяет Позицию Объекта (Object Position). Это 2,500 см слева от края листа и 2,500 см сверху от края листа. Значок номер два, располагающийся правее, определяет размеры фрейма. Он называется Object Size (Размер объекта) и составляет в нашем варианте 16,000 см ширины и 24,700 см высоты.

Соответственно величина полей, как можно вычислить, на всем листе составила по 2,5 см от каждого края листа. На деле по умолчанию — 2,54 см.

Но вот мы поместили на пятую страницу Публикации изображение из нашей коллекции, использовав для этого кнопку Панели инструментов Picture Frame. На рисунке 24 вы, возможно, разглядите, что теперь Строка состояния отражает размеры этого изображения и его позицию на листе.

Рис. 24. Поместили иллюстрацию

Ну, наверное, на этом и закончим говорить об интерфейсе программы Microsoft Publisher. Как любая программа-приложение, это приложение, созданное еще и фирмой Майкрософт, неисчерпаемо. Возможности, заложенные авторами, часто множатся, как в CorelDRAW или в эффектах того же Фотошопа.

Перейдем непосредственно к меню программы. Основным из них уделим по главе, а другие — другие, вероятно, станем объединять по два-три в одну главу.

Там видно будет.

Итак, меню File (Файл).


Командное меню «Файл» (II)

Наконец, все «успокаивается», и на экране остается опять одна только наша первая страница публикации, которая, как вы помните, является титульным листом.

И вот он, наш файл, в папке «Мои документы». Хотя, насколько мне помнится, я назначал ему несколько иной путь... Он последний в первом ряду — видите? — «Петя. Файл». Правда, у него слишком общий значок, и вряд ли его можно успешно назвать файлом .ps. Но тем не менее. По крайней мере понятно, как осуществляется процесс.

Рис. 20. Файл «Петя» в папке «Мои документы»

Если нас постигла неудача, у нас, как всегда в ХР, есть несколько обходных маневров. Печать в файл — не исключение. Мы обратимся к этой опции позже, когда пройдем этапы верстки и всерьез возникнет вопрос о передаче публикации в типографию.

Движемся дальше по меню «Файл» (File).

Пропущенная мною опция Export as Web Page... (Экспорт как Web-страницы...) вызовет диалог, где следует выбрать ваш файл. После этого внести его имя в поле Имя фай-ia: (File name:) и тогда щелкнуть кнопкой Save (Сохранить). Собственно, на этом и не на-(0 было заострять внимания, потому что команда дублирует гораздо более простой и при-ъиный способ сохранения файлов HTML — содержащийся в диалоге Save as... Сохранить как...). Там расширение выбирается из списка типов файлов, потом публикация сохраняется... и файл готов.

Опцию Search... (Найти...) мы рассматривали достаточно основательно в прошлой лаве, поэтому со спокойной совестью вызов этого Докера пропускаем.

Рис. 21 Диалог после вызова Просмотра Web-страниц

А вот на рисунке 21показан диалог, который возникает после щелчка на опции Web Page Preview (Просмотр Web-страницы). Ответив на вопрос, конечно, положительно (только при этом выбрав, что вы хотите просмотреть — Web-сайт или текущую страницу), вы получите программу Microsoft Internet Explorer — и просматривайте. Заниматься этим не будем, идем дальше.

Нас ждет интереснейшая опция Page Setup... (Установка, Параметры Страницы...). Откроем эту опцию...

Рис. 22. Диалог Page Setup

Здесь мы по умолчанию попадаем на вкладку Layout (Схема, План). В ней три верхних поля — Publication type (Тип публикации), Page size (Размер страницы) и Preview (Просмотр). С последним все совершенно ясно: в зависимости от назначений вкладки мы будем наблюдать, как изменяется в поле просмотра вид страницы, которую назначаем. С Размером страницы, кажется, тоже все в порядке: каков размер, такова и страница. А вот по Типам публикаций программа Publisher далеко обставила всех конкурентов. Здесь страницы и публикации действительно на все случаи жизни. Только в CorelDRAW я наблюдал аналогичный подход, но там типе изображений значительно меньше. Ведь тут и внутри изображения кроется больше количество вариантов, и каждый программой зафиксирован, каждый имеет мест быть, под него существуют шаблонные разработки!

По умолчанию нам предложен первый вариант — Full page (Полная стран» ца). Это первый тип публикации в длинном списке всевозможного.

Кроме указанных полей, есть и поля Printing options (Опции печати) и Orientatioi (Ориентация страницы). В качестве ориентации страницы, как уже говорилось, на предложено два варианта — Портретная (Portrait) и Пейзажная (Landscape). Послед нюю мы тоже не станем рассматривать, это всем понятно и по другим приложениям Если страница расположена вертикально — значит, ориентация Книжная, Портретная Если страница горизонтальная, то, естественно, ориентация Альбомная, Ландшафтная.

А вот к Опциям печати относится только кнопка, которая, забегая вперед, скажу, называется по-разному, а здесь — Change Page Order... (Изменение Поряди Страниц...). Откроем и ее, эту кнопку.

Рис. 23. Диалог Изменение Порядка Страниц

На этом рисунке вы видите возникающий диалог Изменения Порядка Страниц. Он называется Параметры Книжной Печати (Book Print Options). Здесь два поля: Options (Параметры) и Sample (Образец). По умолчанию установлен флажок в строке Print one page per sheet (Печать одной страницы на листе). Соответственно Образец, он же Просмотр, так нам и показывает. А вот на рисунке 24 — другая опция: Print as book (Печатать как книгу) — фактически печать книжного разворота. Обратите внимание, ниже поля строк параметров запись также меняется: там отражается, в каком порядке печатаются страницы. Именно здесь порядок интересный — разворот листа с двух сторон так и печатается — 4,1,2 и 3 страницы (это указаны номера страниц).

Рис. 24. Печатать как Книжный Разворот

В первом варианте (рис. 23) лист для печати выбирается по размеру страницы (стандартный формат А4), во втором же (рис. 24) — лист двойной (A3). А вот третья опция Print one page centered on a large sheet of paper (Печать одной страницы по центру большего листа бумаги).

Рис. 25. Опция Печати по центру большого листа

Как видите, размер, листа бумаги для печати здесь тоже большой (A3).

Идем дальше. Мы рассмотрели только один тип публикации — полную страницу. Это может быть и листовка, и газетный лист, и афиша, и книга (если страниц много).

А вот тип Banner (Знамя, Стяг), а по-нашему, насколько я понимаю, Полоса. Если же печать на этой полосе, которую вы видите на рисунке 26, осуществить с двух сторон и по тому порядку, чтоб сложить ее в детскую Книжку-гармошку, ев) можно назвать еще Раскладушкой.

Но здесь речь идет именно о печати флагов и плакатов!!!

Тогда точно это тот вариант, который в рекламе (эстрадной и театральной) называется Растяжкой. Знаете, на улицах над проезжей частью администраторы театров с помощью техники вывешивают растяжки — рекламу спектаклей? Очень похоже.

Печать идет пошагово — на очередной странице лишь часть того, что потом будет в целом.

Потом, отпечатав эти части, их придется совмещать и подгонять друг к другу. Для этого нужна соответствующая область перекрытия.

Рис. 26. Тип публикации Banner

Взгляните теперь на размеры этой растяжки — они внушительны.

В поле Параметров Печати указано: Overlap sheets of paper by 0,635 cm (Перекрытие листов бумаги на 0,635 см).

Кнопка в этом поле называется теперь Change Overlap... (Изменение Перекрытия...).

Технология печати такого размера публикаций мне не совсем понятна, но из плохого перевода опций все же можно выудить некий смысл, который не расходился бы с логикой. Думаю, те, кому придется делать подобную работу, поневоле разберутся с опциями досконально.

Рис. 27. Печать всей «страницы»

Рис. 28. Печать одного листа

На рисунках 27 и 28 вы видите два разных назначения — Print Entire Page (Печать Всей Полосы, Страницы) и Print One Sheet (Печать Одного Листа). В

первом случае Наложения (Перекрытия) имеют место, а во втором их нет, поскольку, как я понимаю, печатается только часть. Второй вариант, на мой взгляд, предусмотрен на тот случай, если полная полоса Стяга не цельная, а разрезная — то есть дается разбег для стыковки. Во втором случае этого быть, естественно, не может, и печатается, наверное, подряд — начало, продолжение 1, продолжение 2 и так далее.

Все это рассматривалось нами для одного лишь варианта длины Стяга — состоящего из 9 листов, сложенных друг к другу по ширине (общая длина 1,5м).

Следующий тип публикации — Буклет (Booklet).

Рис. 29. Буклет

Из рисунка 29 видно, что никаких опций в поле Параметры Печати не предусмотрено. Буклет, так буклет.

Рис. 30. Business card (Визитка)

В случае с Визитной карточкой могут быть варианты, но в основном это, конечно, некая стандартная визитка, применяющаяся теперь, с развитием компьютерной печати, повсеместно. Правда, сейчас их раздают направо и налево и совсем забыли что прежде, приходя в приличный дом, не разговаривали с лакеями, а бросали на поднос свою визитку и ждали решения хозяев, которые, как правило, почти на сто процентов «принять не могут-с».

Под кнопкой Параметров Печати скрываются варианты большего или меньшего числа визиток на странице.

Но то же кроется и в поле Ориентации Страницы. На рисунке 31 вы это видите. Грубо говоря, слишком шикарно — размещать на страничке не 8, как Портретном варианте, а всего 4, как при Пейзажном варианте ориентации печатного принтерного листа. Экономия бумаги вообще бич последних столетий. Бумага в XIX веке была на вес золота, но бюрократы умудрялись и тогда расходавать ее тоннами. Уж о нашем времени молчу...

Рис. 31. Ландшафтная ориентация страницы

Откроем же кнопку Change, Copies Per Sheet... (Изменить число копий на листе...) и получим диалог Параметры Печати Мелких Публикаций (Small Publication Print Options).

На рисунке 56 показана опция Множество отпечатков на листе (Print multiple copies per sheet).

Она установлена по умолчанию для этого рода печатной продукции.

Рассматривать случай, когда одна мелкая визитка теряется в громадном по сравнению с ее размерами пространстве листа, мы не станем — уж очень жалкое будет зрелище. Опять к тому же вопрос об экономии бумаги... Вообще техника производства бумажной продукции в наше время настолько возросла, настолько качественными и белыми получаются бумажные листы, что становится просто неудобно и жалко тратить их впустую — на какие-то обрезки.

Перейдем к другому типу публикации — Folded card (Складная Карточка).

Рис. 32. Много копий на листе

Рис. 33. Тип публикации — Folded card

На рисунке 33, где изображена Складная Карта, вы видите Портретную ориентацию страницы. И подтип этого вида карты — Палатка (Tent card). Я бы назвал — Шалаш.

На рисунке 34 — такая же карточка, но подтип иной — Top-fold card (Высокая складка, Высокий узкий шалаш, Карточный Домик).

Рис. 35. Top-fold card

Ту, что в списке между ними, я пропустил. Идем дальше.

Кстати, пропуски, которые я делаю, они не должны вас беспокоить. Просто шаблоны предусмотрены на все случаи жизни, и охватить все целиком не представляется возможным. Здесь и конверты разных форматов, используемые в мире (ведь кому-то придется в программе макетировать эти конверты), и карточки и наклейки совершенно немыслимых форм, не нужных нам. . . К примеру:

Рис. 36. Это — тип Label (Этикетка)

Изображенная на рисунке 36 этикетка — вы видите это по списку — предназначена для дискеты.

Рис. 37. А это — Почтовая Карточка, причем японская.

Ну, на этом перестанем углубляться в рассмотрение первой вкладки, поскольку есть еще и вторая — Printer & Paper (Принтер и Бумага).

Рис. 38. Вкладка Принтер и Бумага

Останавливаться на этой вкладке мы не станем, потому что нам еще предстоит ознакомиться с печатью в Publisher гораздо серьезнее, чем сейчас. Просто повторюсь и скажу то, о чем не раз говорил. В верстальной программе, да и в неверстальной тоже, опция Печать все же, думаю, должна стоять где-то особняком, а не в меню «Файл». Это меню больше подходит для начала работы, а не для ее завершения. А печать — для любого вида работы на ПК есть завершающая стадия. Но раз уж так размещены опции, спорить не станем, но и разговаривать прежде времени на темы печати не будем. Так что серьезный диалог Print... (Печать...) пропускаем. Просто знаем, что эта опция содержится в меню File, и все.

А вот на Print Preview (Просмотр Печати) взглянем.

Рис. 39. Окно Просмотр Печати

Просмотр, как и в любой другой программе, где используется опция «Просмотр» или «Предварительный просмотр» (или «Просмотр печати») здесь содержит очень узнаваемый интерфейс (кстати, в верстальных программах это, на мой взгляд, совершенна лишняя опция, предварительных просмотров в этих приложениях просто не нужно здесь, вероятно, сработала инерция).

При просмотре печати, как и в Word, по умолчанию включен курсор «Масштаб», традиции сохранены. Окна утилиты Просмотра Печати идентичны во всех майкрософтовских приложениях. Понятно: они слеплены с единого шаблона.

Здесь, как видите, нет никаких меню, отсутствует, естественно, и Строка командных меню. Зато есть Панель инструментов. Она общая, в ней собрались понемногу все свойства и функции — и навигации, и масштабирования, и правки, и даже печати. Кнопки, которые стоят в ряду самыми первыми, листают страницы: с предыдущей на последующую и наоборот. Просмотр — по желанию, без назначения конкретного масштаба, может быть грубо изменен. К примеру, вы можете назначить Whole Page (Вся Страница) — соответственно просмотрите только одну страницу. Или — Multiple Pages (Несколько Страниц). Это удобно, чтоб окинуть взором, как одна страница сочетается с другой, и нет ли где композиционных промахов, которых, пока рассматриваешь каждую страницу журнала (к примеру), можно не заметить. Страница на рисунке 62 — это «Вся Страница», просмотр по умолчанию. Назначим Несколько Страниц и взглянем, что получится.

Рис. 40. Просмотр Нескольких Страниц

Я назначил из выпавшей из-под кнопки панельки-меню показать три страницы, а можно назначить до шести страниц (одну, две, три, четыре или шесть: пять никак не назначишь — квадратики назначения расположены в два ряда по три в каждом ряду, и потому либо четыре, либо уже шесть). Что ж, наглядность здесь налицо, и она радует.

А еще через кнопку Change Page Order... (Изменить Порядок Печати...) можно вызвать диалог, который вызывался в диалоге Установка Страницы кнопкой в поле Параметры Печати и который дает возможность назначить, сколько и на каких листах мы будем печатать страниц. Вот он, этот диалог, знакомый нам:

Рис. 41. Диалог Параметры Книжной Печати

Кнопка Печать (Print) на Панели говорит сама за себя. На этом с Просмотров Печати распрощаемся. Выйти из него просто — щелкнуть по кнопке Close на той же Панели.

Следующая строка меню File — Send To (Отправить В) со своим небольшим подменю, где две опции — Mail Recipient (Получателю Почты) и Mail Recipie (as Attachment) —Получателю Почты (как Вложение). За последний перевод в скобках не ручаюсь, потому что не пользовался электронной почтой.

И у нас остается одна рабочая опция — Properties (Свойства).

Это, как видите, обычный виндоусовский диалог Свойства. Рассматривать его не станем, поскольку атрибутика у него все та же, что и в стандартном виндоусовском диалоге. Как и все имеющиеся в нем вкладки. Рассмотрение этого диалога затрудняется еще и тем, что в нем все по-английски. В отличие от подобного же диалога в Windows XP, где вы вполне разберетесь с ним и самостоятельно, поскольку там ничего сложного нет (это замечание для начинающих) Открыть его тоже просто. В папке, где содержится ваш файл публикации, имени этого файла, не раскрывая его, щелкнуть второй кнопкой мышки, и появится контекстное меню, в котором последней строкой будет строка Свойства. Открывайте ее и изучайте ваш файл — там все про него написано — когда создан, когда изменялся, кто автор и так далее.

Рис. 42. Диалог Properties (Свойства)

Следующая группа из четырех (или меньше) строчек с именами файлов — это Область данных, через которую можно открыть файл (если он содержится в списке), не прибегая ни к поискам его в папках, ни к строке меню Открыть, ни к кнопке Открыть на Панели Стандартная. Достаточно щелчка на имени файла, и он откроется, тем более что вы читали или изменяли его именно в этой программе. Publisher, как и Word, содержит по умолчанию те же четыре последних имени файла — из тех файлов, с которыми работал в последнее время. Понятие «последнее время» растяжимо, но программа запомнит имя файла и тогда, если вы не пользовались ею и полгода. Тем более ценно: вы уже забыли, что этот файл существует, а программа не только помнит его, но и готова открыть файл для вас (при условии, конечно, что с того давнего, времени вы его никуда не перемещали, не удаляли и не меняли ему имя).

И последней строкой меню File мы увидим строчку Exit (Выход). Щелкнув по этой строке, вы или сразу выходите из программы, если публикация сохранена и не внесено с тех пор никаких изменений, или отвечаете на вопросы, возникающие в дежурных диалогах — «Сохранить перед закрытием ваш файл?», — и уж потом программа закрывается.


Глава 1

Командное меню «Правка» (II)

Кстати сказать, в продаже появились диски с полным набором картинок для Publisher и сделанных или экспортированных в Publisher. Диск прилагается к пакету «Офис» и называется Microsoft Publisher 2002 ХР — то есть именно так, как именуется программа, которую мы рассматриваем. Так что при покупке или проверяйте второй CD, или приходите в магазин со специалистом, хорошо знающим, что вы хотите приобрести — только ли картинки, или только программу.

Ну, со Специальной Вставкой тоже более-менее все ясно. Смотрим, что нас ждет дальше в этом меню.

На рисунке 10 вы видите то же меню Edit с активной строкой Delete Text (Удалить Текст).

Строка стала активной после того, как я выделил текст на странице публикации. Также активны Delete Object (Удалить Объект) и Delete Page... (Удалить Страницу...).

Рис. 10. Меню Edit при выделенном тексте

В общем-то, понятно, что такое Удалить Текст и Удалить Объект.

В качестве Объекта в этом случае, насколько нам понятно, фигурирует Текстовый Блок, который выделен вместе с частью текста.

При этом тот текст, который заполняет удаляемый текстовый Блок, не исчезает: он перемещается в следующий за удаленным Текстовый Блок.

А вот место на странице останется пустым.

С этим мы разберемся позже, а пока посмотрим все же, что такое Удалить Страницу....

Очень часто в процессе работы некоторые страницы остаются лишними (по разным причинам), и от них следовало бы избавиться. Манипуляции со страницами существуют в других верстальных программах, и там эти опции универсальны, особенно в QuarkXPress. А здесь?

Рис. 11. Диалог Удаления Страницы

Выбрав опцию Удалить Страницу..., мы получим небольшой диалог, в котором есть три варианта выбора страницы. Первый — Both pages (Обе страницы), второй — Left page only (Только левую страницу), и третий — Right page only (Только правую страницу).

Выберем, к примеру, Только правую.

Рис. 12. Правая страница удалена

Теперь взглянем, сохранился ли сам текст, который содержался на правой странице публикации (правые страницы — нечетные, это была третья). В Навигаторе страниц мы видим, что страниц у нас теперь всего две.

Для того, чтобы проверить, есть ли текст далее того, что содержит текстовый фрейм, растянем его (фрейм) вниз, используя стрелку изменения размеров Блока (только нижнюю).

Рис. 13. Растянули блок и видим, что текст существует

Из рисунка 13 ясно, что текст никуда не делся, он существует, просто нет страницы, на которой бы он «культурно» разместился.

Из этого удаления можно сделать вывод, что Publisher, в отличие от PageMaker, не запрашивает, удалять ли вместе со страницей и ее содержимое. Программа по умолчанию оставляет вам лично разбираться с тем, что вы станете делать с содержимым, то есть с оставшимся текстом. Значит, для полного удаления страницы с текстом придется выделить сначала текст и удалить его, а потом уж удалять страницу. Или, если уж страница удалена, растянуть блок, выделить ненужную часть текста и удалить ее, а потом размеры блока вернуть на место.

Или если текст остается необходимым, следует выбрать другую страницу (если она есть) или вставить ее (если ее нет) и, построив на ней Текстовый Блок, задать Связывание существующего блока с новым, и во время назначения Связывания текст преспокойно ляжет в новый Текстовый Блок. Как произошло у меня после назначения удаления страницы. Результат мы видим на рисунке 14. Но о процессе, как это сделать, будет рассказано позднее, когда мы станем рассматривать процесс вставки

Рис. 14. Вставили страницу и Связали Блок с Блоком

А пока идем дальше по меню Edit.

Следующая опция — Select All (Выделить Все). Имея разворот страниц (как у нас, вторую и третью), вы этой командой выделите и ту, и другую. Но не больше! Опция не работает на всю публикацию и выделяет лишь то, что видно на экране (независимо от масштаба, конечно). Как в PageMaker, программа видит лишь то, что лежит на Монтажном столе. Остальные страницы (последующие, если они есть) лежат ниже этого разворота и перекрываются им. А те, что предшествуют этому развороту, находятся как бы у пользователя за спиной. Виртуально их здесь, в Рабочем поле, нет. Нет нигде, кроме... Навигатора страниц. Там они существуют, и потому их всегда можно вызвать на экран монитора.

Чтоб доказать именно такой порядок существования страниц в программ Publisher, захватим мышкой текстовый блок со страницы номер 3 и отнесем его на право, за пределы страницы. Вы это видите на рисунке 15.

Рис. 15. Текстовый блок вместе с содержимым сдвинут в сторону, на Монтажный стол

Сдвинули текстовый блок и можем, как в PageMaker, надолго забыть о нем. Зато когда блок понадобится, не надо его разыскивать ни по директориям, ни по папкам.

Есть непременное условие: сдвинутый на Монтажный стол блок должен целиком на нем находиться, ни одним краешком не касаясь страницы, с которой сюда попал. Иначе будет вам не виден, продолжая как бы пребывать на прежнем своем месте.

Теперь откроем совсем другую страницу (у нас такая всего одна — первая). И увидим (рис. 81), что наш текстовый блок с текстом преспокойно лежит на Монтажном столе как раз рядом с правой страницей, нечетной, то есть первой.

Рис. 16. Текстовый блок остался на Монтажном столе, и он видим

Чтобы сделать видимым содержание того или иного блока (в том числе и блока изображения), можно вынести его на Монтажный стол, откуда удобно потом перемещать блок в нужную нам точку. Это чаще всего касается верстки, и в частности — газетной, когда приходится в процессе работы менять местами материалы.

Запомним это обстоятельство и пойдем дальше.

Следующая группа команд — Найти..., Заменить... и Перейти на Страницу... (Find..., Replace... и Go to Page...). Это известная нам троица, которая во многих программах имеет место быть. А уж в Офисе — и подавно. Она ведь знакома нам, в основном, по программе Word, в которой чаще всего работают пользователи. Там, если вы помните, все эти три команду собраны в один диалог и участвуют в нем в качестве вкладок.

Здесь не так. Вот команда Find... (Найти) — она вызвала следующий диалог:

Рис. 17. Диалог Find...

В верхнем поле ввода по имени Find What: (Что найти:) вы вписываете слов или осмысленную группу слов, которые необходимо найти в текущем докумея При этом, вписав искомое, вы должны назначить поиску некоторые условия, соде жащиеся здесь же, в диалоге. Флажок по умолчанию стоит в строке Down (Ниже) поле Direction (Путь). Это означает, что программа станет искать слово или словосочетание в последующем тексте. Можно установить флажок в строчке Up (Вьн Вверх). Тогда она будет искать в предыдущем.

Две строки без флажков предлагают или пользоваться этими указаниями, нет. Посмотрим, что это такое. Первая строка — это Match whole word onl; (Соответствие только по целому слову), вторая строка — Match cas (Соответствие случайное).

Именно при назначении флажка на вторую опцию я и нашел только что слов «ключ» в слове... «заключительный». Такой поиск тоже бывает иногда полезным.

Посмотрим на команду Replace... (Заменить...), но заменять ничего не станем. Нам важно взглянуть на диалог.

Рис. 18. Диалог Replace...

Если быть честным, я подшутил и записал предполагаемую замену слову «ключ», которое выскочило в этом диалоге из диалога прошлого (Найти...). Значит, все-таки общий абрис у этих вкладок остался, хотя и выступают они теперь почти самостоятельными диалоговыми окнами. Назначения, как вы видите, остались те же, что и в прошлом диалоге. А кнопки — Заменить и Заменить Все — также знакомы пользователям, которые наверняка работали с этими опциями.

Последняя из этой серии команда — команда Go to Page... (Перейти на Страницу...). Откроем и этот диалог.

Рис. 19. Диалог Go to Page...

В поле ввода необходимо ввести номер страницы, на которую нужно перейти. Программа умна и сама написала предположительный номер (2), объясняя мне: «Your publication has 3 pages, numbered 1 through 3» (В вашей публикации З страницы, нумерация начиная с 1 по 3).

Ну, на вторую страничку как-то неудобно переходить — она и так у нас перед! глазами. Перейдем на первую? Вписываем в диалог цифру 1 и — переходим. Уж не; стану приводить этот смешной пример в качестве иллюстрации. Поверьте на слово: Publisher работает как часы.

Следующая опция — Links... (Связи...). К сожалению (а вообще-то к счастью), у нас нет никаких связанных файлов внутри нашей публикации, и эту опцию придется пропустить.

Чем хороша верстальная программа Publisher, — это еще тем, что она напрямую (через Офис) связана с программой Word. К примеру, то, что к нам в документ пришло из шаблонного решения (вы помните — титульный лист), вполне может редактироваться в Microsoft Word. С этим приложением связь прямая и отдельно не устанавливается, а просто существует по умолчанию. Вот и опция Edit Story in Microsoft Word (Редактирование Материала в Microsoft Word). Выделенный текст с именем публикации на титульном листе, поверьте, никак больше не исправляется, как с использованием только этой команды. Тут же открывается Word, и в нем текст доступен редактированию. Когда вы написали вместо Document Title что-то более для вас подходящее, достаточно лишь закрыть этот временный вордовский документ, и имя титула — уже на первой странице вашей публикации. Как у меня на рисунке 20.

Рис. 20. Титул теперь настоящий

Ничего не смогу сказать об опции Object (Объект) и ее подменю, потому что она сейчас неактивна. Надеюсь, что опция станет активной в процессе наших занятий с программой Publisher, и мы сумеем рассмотреть ее.

Осталась всего одна строка — Personal Information... (Индивидуальная Информация...). Она должна вынести на экран диалоговое окно.

Вы видите этот диалог на рисунке 21.

Рис. 21. Теперь вы все про меня знаете...

Комментировать этого ничего не стану. Просто констатирую: меню Edit, (Правка, Редактирование) подошло к концу. Стали мы немного больше знать о программе? Безусловно. Тогда идем к следующему меню.


Командное меню «Вид» (II)

Рассмотрим сначала саму Панель Header and Footer. К сожалению, Publisher не стала сильно утруждаться и предлагает нам те же неприемлемые варианты колонтитулов. Я не против того, чтобы вставить в колонтитул номер страницы (так оно часто и происходит), но вставлять дату или время — для чего??? Возможно, это западный менталитет сыграл с нами такую шутку. Я даже не собираюсь вам внушать, что у нас книг с такими колонтитулами просто не бывает. А если, допустим, речь идет о каком-то документе (текущем документе офиса некой фирмы), и если там действительно необходимо проставить не только номер страницы, но и дату, и час создания документа, то это можно проделать и без опции Колонтитулы. Достаточно лишь первую строку (или последнюю строку) документа посвятить этим проблемам и напечатать все, не выходя из общего текста. А если документ большой и делался, к примеру, неделю, то какое число и время ставить? Особенно если это надо зафиксировать на всех страницах документа...

Следующая кнопка на Панели переводит нас с верхнего колонтитула на нижний наоборот. А последняя кнопка — Close (Закрыть). Ею закрывается не только Панель но и Мастер-Страница, на которую мы автоматически попадаем, как только рискнем потревожить рассматриваемую опцию. Так же автоматически, как вы видите, мы попа даем по умолчанию и в возникший Текстовый Блок на месте верхнего колонтитула. Остается только сочинить его.

Обратите внимание на колонтитула книги, которую вы держите в руках. Можно с подобной Панели организовать такие колонтитулы? Наверное, нет.

Однако не все так плохо: слава Богу, мы, оказывается, вольны не пользоваться кнопками Панели Header and Footer и можем вписать в колонтитул все, что душе будет угодно. Что и видите вы на рисунке 16.

Рис. 16. Пусть будет такой вот колонтитул

Итак, с колонтитулом тоже разобрались. А вот номера страниц — пока не ставили.

Перейдем на нижний колонтитул. Теперь нам как раз понадобится предпоследняя кнопка этой Панели. Зададим выравнивание по центру и щелкнем кнопкой по имени Insert Page Number (Вставка Номера Страницы). И получим результат:

Рис. 103. Вставили номера страниц

На рисунке 17, едва появился значок # на месте номера страницы, возникла всплывающая подсказка. К сожалению, она написана опять по-английски — и что им дался этот странный непонятный язык?.. Попробуем расшифровать. Во-первых, восстановим запись фразы (не по памяти, естественно, а заглядывая в публикацию): «Publisher has inserted a # sign to automatically display the correct page number on the foreground». По-русски это может звучать и не очень красиво, но, кажется, довольно правильно: «Publisher (уж извините, без перевода) вставил знак # для автоматического показа истинного номера страницы на подлинном плане (переднем плане — дословно)».

Давайте взглянем на этот значок # без подсказки. Для лучшей видимости я увеличил кегль значка.

Рис. 17. Вот он, значок

Ну, что ж, посмотрим, что там с нашим истинными номерами страниц на подлинных страницах книги, а не на Мастер-Странице.

Рис. 18. А вот он, номер страницы

Убедимся, что и колонтитул на месте:

Рис. 19. И колонтитул на месте

С колонтитулами, кажется, почти разобрались. Перейдем к последней опции — Zoom (Масштаб). С масштабом просмотра мы уже сталкивались, но не грех взглянуть на полное подменю Масштаба как опции меню Вид. Вы видите это подменю на рисунке 20.

Рис. 20. Подменю Zoom (Масштаб)

Среди опций Масштаба все градации просмотра в процентах нас не удивляют, тем более что мы уже знаем: масштаб в Publisher изменяется пошагово, хотя интересно, нельзя ли назначить, как мы это привыкли делать в Word, произвольный масштаб просмотра? К примеру, не 75 процентов, а 85? Взглянем.

Если вы помните или знаете из других приложений, масштаб вписывается прямо в поле ввода, а для того, чтоб программа показала ваш документ именно в этом заданном масштабе, нужно нажать на клавиатуре клавишу Enter. Пробуем:

Рис. 21. Нестандартный масштаб тоже можно назначить

Да, действует и такой подход. Так что, как видите, все в порядке.

Нельзя только назначить масштаб меньше 10 процентов — он «не сработает».

А мы взглянем на опции, записанные словами. Это: Whole Page (Целая Страница) и Page Width (По Ширине Страницы), а также Selected Objects (Выделенные Объекты).

Первая опция покажет вам вашу страницу целиком, вторая — часть страницы, поскольку ширина страницы совпадет с шириной рабочей зоны окна программы.

А третья опция организует вид по выделенному — то есть какого бы размера ни был объект или группа объектов, они поместятся от края до края окна.

С первыми двумя все ясно, так что давайте проверим, как будет выглядеть масштаб По Выделенным Объектам (или По Выделенному Объекту). Выделим объект (тот же титул) и взглянем.

Рис. 22. Масштаб По Выделенному Объекту

Как видите, этот масштаб регулируется по высоте объекта. Следовательно, если выделить два или три объекта, в рабочем окне мы увидим выделенные объекты в том масштабе, который предполагает просмотр от верха верхнего объекта до низа нижнего. Убедимся:

Рис. 23. Масштаб По Выделенным Объектам

Видите, так оно и есть.

Обратите внимание, ниже выделенных объектов притулилась в правой чае! некая прозрачная кнопка с характерной пиктограммой. Что это?

Это Контекстная Кнопка Раз уж выделено три объекта (три Текстовых Блока), на всякий случай программа выдает вам возможность совершить дальнейший шаг. Кнопка называется Group Objects (Сгруппировать Объекты). Эта кнопка — вполне рабочая, и ее; щелкнуть на ней мышкой, то все объекты, которые выделены, сгруппируются. При это кнопка приобретет совсем иное значение (и вид). Она станет кнопкой Разгруппирован» Объектов (Ungroup Objects).

Контекстные меню или кнопки или панели — вещь очень любопытная и необходимая. Мы с ними еще столкнемся.

Ну, что ж, на этом наше меню View (Вид) закончилось.

Если помните, я обещал немного поразбираться с Панелью 3D Setting (Трехмерные Назначения). Вызовем ее и перейдем на свободное место на третье странице, потому что немного там порисуем.

Кстати сказать, переходя на третью страницу со страницы первой, где мы толь ко что были, мы увидим: программа показывает нам третью страницу в том же точно масштабе, что мы рассматривали первую. В этом отличие Publisher от PageMakei где общий для всех страниц масштаб надо задавать специально, иначе каждая страница сохраняется в том масштабе, в котором ее в последний раз посматривали ил правили. Здесь это неудобство ликвидировано. То есть, наоборот, его здесь и не существовало.

Итак, перейдем на третью страницу и нарисуем на ней овал.

Рис. 24. Нарисовали Овал на третьей странице

Как видите, панель активная целиком — активны все ее кнопки.

Прежде чем использовать ту или иную кнопку Панели 3D, рассмотрим назначение каждой из них.

Первая кнопка — это кнопка 3D On/Off (Сделать/Ликвидировать). Первым щелчком на этой кнопке вы производите над объектом действие, а другим щелчком на той же кнопке — отменяете это действие. В нашем конкретном случае — вы придаете объекту перспективу или отменяете ее.

Вторая кнопка — Tilt Down (Наклонять, Вращать Вниз), третья — Tilt Up (Наклонять, Вращать Вверх). Обе эти кнопки работают уже с трехмерным объектом, созданным первой кнопкой. Вращение происходит вокруг горизонтальной оси, лежащей в плоскости экрана.

Четвертая кнопка — Tilt Left (Вращать Влево), пятая кнопка — Tilt Right (Вращать Вправо). Вращение происходит вокруг вертикальной оси, лежащей в плоскости экрана.

Шестая кнопка — это кнопка Глубины Перспективы (Depth). Вы видите открытое под нею меню, где существует шесть назначений Перспективы — от 0 pt до 288 pt (через 36, 72 и 144 pt) и шестая — Infinity (Бесконечность).

Седьмая кнопка — Direction (Направление). На самом деле, вид на трехмерный объект может быть назначен с различный точек. Правда, этому же принципу служат и кнопки, вращающие объект. Но здесь, под седьмой кнопкой, много фиксированных назначений направления.

Восьмая кнопка — Lighting (Освещение).

Эта опция Освещение очень интересна.

Она была давно уже решена в других программах, особенно в пакете графических программ фирмы Corel. Там это сделано блестяще.

Здесь, как и положено в верстальной программе, не претендующей на слишком большую графическую составляющую, решено проще, но тоже ярко.

Все опции, собранные в панели-меню для Освещения, создают разные характерные ступени этого Освещения.

Я не стану демонстрировать возможности этой опции. Попробуйте построить такой же эллипс, придайте ему перспективы и покрасьте. Потом испробуйте самостоятельно все или наиболее характерные параметры, собранные в этом меню-панельке.

Девятая кнопка — это кнопка Surface (Поверхность).

Речь идет о фактуре поверхности трехмерного тела (объекта).

В меню, как видите, всего четыре опции — Wire Frame (Проволочный Каркас), Matte (Вещество, Предмет? — ни то, ни другое не подходит, но подходит созвучное — Матовая), Plastic (Пластиковая) и Metal (Металлическая).

Эти опции не всегда дают необходимый эффект. Но, много работая над текстурой (в другой программе), я знаю, насколько бывает полезна эта опция. Очень часто происходит так, что вы никак не можете добиться настоящего эффекта, пользуясь различными назначениями Эффектов (в Фотошопе, например), и вдруг неожиданно приходит решение в элементарной опции — типа той, что вы видите.

Наконец, последняя, десятая кнопка в этой панели — Color (Цвет).

С помощью меню Color вы сможете назначить вашему трехмерному объекту Цвет. И Тон (Опция Fill Effects... — Эффекты Заливки...)!

Верхняя строка меню Цвет — Automatic (Автоматический). Строго говоря, это не автоматическая заливка, а заливка по умолчанию. По умолчанию в Publisher выбрана черная заливка.

Зато вторая строка того же меню позволяет вам выбрать для заливки любой из предлагаемых стандартных плашечных цветов. Вы их видите на рисунке, а у себя сможете разглядеть и на экране. У меня выбран синий цвет.

Ниже существует строка More 3D Color... (Больший выбор 3D Цвета). Эта опция открывает для вас палитру цветов. Здесь вы сможете осуществить более тонкий выбор — то есть пройтись по оттенкам любимого выбранного цвета. Здесь, включая стандартные из прошлой опции, всего собрано пошагово 129 различных цветов и оттенков. Это палитра Windows, палитра Office, с которой мы сталкивались и в других приложениях. Именно ее вы видите на вкладке диалога на рисунке 25. Вкладка носит имя Стандартные (Стандартные Офиса).

Рис. 25. Диалог под командой More 3D Color... Вкладка Standard

Для более плавного (или точного) выбора существует другая палитра — Палитра Обычная (Custom), по умолчанию в системе RGB.

Рис. 26. Тот же диалог, вкладка Custom

Это вторая вкладка того же диалога. Вы видите ее на рисунке 26. Здесь вы сможете в полях ввода (вручную) или на сплошной палитре в верхнем окне, или в поле ввода Color model: (Цветовая модель:) выбрать практически любой цвет. А имея прекрасный неповторимый цветовой атлас фирмы PANTONE, и вовсе назначить точнейший цвет. Палитра PANTONE содержится в строке поля Цветовых моделей и изображена на рисунке 27.

Рис. 27. Цветовой атлас (набор всех цветов) PANTONE

Таким образом, как видите, программа Publisher в этом отношении может являться шедевром. С цветовым выбором здесь настолько все в порядке, что и представить себе трудно. Кроме RGB и PANTONE еще используются цветовые модели CMYK и HLS.

Раз уж зашла о цвете речь, предлагаю вам отдохнуть пока от рассмотрения командных меню Publisher и припомнить все, что мы знаем о свете и цвете, прямо в следующей же главе. Она будет посвящена нашим современным представлениям в этой области и, конечно же, конкретике относительно цветовых моделей.

Но пока взглянем на последнюю опцию меню Color. Это Fill Effects... (Эффекты Заливки...). Правда, трудно назвать это уж очень большими эффектами. Скорее речь идет просто о Тоне выбранного цвета. Градацию тонов и соответственно возможность выбрать соответствующий вашим задачам тон цвета вы видите на рисунке 28.

Рис. 28. Диалог Fill Effects

Здесь открыт мною список Base Color: (Базовый цвет:). В нем всего две строки — шнимальный набор стандартных плашечных цветов Publisher и строке More Color... Другие Цвета..., Больший Выбор Цветов...).

Пожалуйста, вы можете открыть эту опцию, чтобы просто убедиться: перед вами откроются тот же самый диалог, что мы уже видели на рисунке 25.

Теперь давайте для примера все-таки что-то проделаем с нашим овалом.

Правда, пока я включал последние команды, пришлось придать ему и перспективу (721), и цвет (Blue), иначе не сработали бы те опции, о которых рассказывал.

Но рассмотрим парочку примеров на ЗD-вращение и особенно Освещение. Как ни хотелось обойти этот эффект, и даже предупреждал об этом, все же наглядности хочется. Мало и что вы подумаете, если просто прочтете о том, как замечательно работает программа: вот ели увидите на примере, как это хорошо, тогда уж совсем другое дело...

Теперь повернем ту же трехмерную фигуру (я придал ей каркасную форму для большей наглядности) вокруг вертикальной оси.

Теперь вернем объекту цвет. Пусть цвет будет не такой, каким был, а какой-нибудь оранжевый, с легким оттенком (то есть не очень густой, иначе будет трудноразличимым).

Этот эффект, как вы видите, уже сам по себе эффект. А ведь что у нас было? Какой-то каркас, пусть даже трехмерного тела, но ведь каркас. И вдруг, покрасив его, то есть создав плотную поверхность и всего-навсего осветив ее.

Теперь выберем другой способ освещения — к примеру, снизу справа.

Конечно, возможностей здесь гораздо меньше, чем в CorelDRAW. Там мы вольны передвигать источники освещения (из может быть и два, и даже три) куда нам заблагорассудится. Но ведь Publisher и не претендует на то, чтобы быть графической программой! Приложение дает нам минимум тех услуг, без которых не обойтись. Да и этот минимум с лихвой перекрывается тем числом вариантов, что предложен.

Ну, кажется, пора завершать разговор, потому что и наглядностей достаточно, и преставление о работе меню View мы получили, на мой взгляд, достаточное тоже.


Глава 1

Командное меню «Вставка» (II)

Идем дальше. Insert From File (Вставка из Файла). Опция вызывает не Докер а диалог поиска-вставки:

Рис. 26. Диалог Вставки From File

Выбрав рисунок (остановимся на «Закате» — стандартном рисунке из коллекции Windows), говорим Insert. И рисунок преспокойно попадает на страницу! публикации.

Рис. 27. ...И вот рисунок уже на странице!

Я был не прав. Оказалось, в процессе вызова рисунка сам собой возник тот же Докер. Другое дело, что из его опций мы никакими назначениями не пользовались, но по умолчанию он, выходит, что-то проделывал сам, независимо от нашего желания.

Идем дальше. Я не стану проделывать с рисунком никаких манипуляций. У нас будет отдельный разговор и об этом. Пока оставим рисунок в покое. А лучше — отменим эту операцию вставки, чтоб прийти к состоянию «до того».

Теперь наступил черед вставить Со Сканера или с Камеры (From Scanner or Camera).

После щелчка на этой опции возникает драйвер сканера (там у нас есть картинка, которую придется сканировать: это рисунок с обложки газеты Союза театральных деятелей, посвященной фестивалю «Золотая маска». Но после анонса драйвера сканера возникает диалог программы Publisher:

Рис. 28. Диалог сканирования

Здесь мы видим, что нужно осуществить кое-какие назначения. В верхнем поле ввода вы видите имя драйвера сканера. В строке Resolution: (Решения:) по умолчанию стояло Web Quality (Качество Web). Этого нам явно мало. Поставим флажок в другую «пуговицу» — Print Quality (Качество Печати). Заметьте еще, что по умолчанию стоит флажок в строке Add Pictures to Clip Organizer (Включить Рисунки в Организатор Клипов). И говорим Insert.

Рис. 29. Процесс, как говорилось известным деятелем, пошел.

Процесс из Publisher, несмотря на то что он «пошел», идет довольно долго. Но все-таки завершается! И вот на странице публикации возникает отсканированный рисунок. Вы его видите:

Рис. 30. Рисунок с первой полосы газеты

Я сделал маленькую хитрость. Все-таки рисунок с примитивного сканера получился такого низкого качества, что я не представил его вам в том виде, в каком он оказался на странице 2. Я обработал и обрезал его в программе Photoshop. Но суть ясна: опция работает. Хотя, конечно, она нужна больше для того, чтоб читать и вставлять с цифровой камеры, а не со сканера. Просто настройки и принцип у этих аппаратов одинаковый.

Дальше. — требуется мастерство художника, чтоб обработать рисунок до удобоваримого состояния.

Обратимся к Автофигурам (AutoShapes).

Рис. 31. Выбрали такую Автофигуру

Выбор большой, практически на все случаи. Выбираем, и все меню и подмени закрываются. Но фигуры на странице нет как нет. Где она?

Для начинающих и не очень знакомых с принципом рисования офисных авто-фигур скажу: если вам все равно, какими пропорциями будут обладать фигуры, вы рисуете просто мышкой, отпуская кнопку тогда, когда вы сочтете, что фигура достигла своих необходимых размеров. Если же это круглая (не овальная, а имен круглая) фигура, то рисовать надо, удерживая клавишу Shift. Рисование происходит до тех же пор, как вы сочтете необходимое нарисованным. Но при этом, нарисовать сначала нужно отпустить кнопку мыши, а уж потом клавишу Shift. Во время такого рисования (с клавишей) вам неважно, в какую точку направляется курсор. Чем дальше от точки нажатия кнопки мышки, тем крупнее будет вырисовываться автофигура. В этом случае курсор можно двигать не по диагонали, а просто немного в cтopону. Причем если вы рисуете слева направо, то получается фигура, которую вы выбирали в меню. А если протащить курсор справа налево, рисуется обратная фигура. То же будет, и если вы не нажимали Shift.

А если в момент рисования удерживать клавишу Ctrl, фигура станет рисоваться из центра. Когда нарисовали, опять же сначала надо отпустить кнопку мыши, a потом — клавишу клавиатуры.

Теперь смотрим: фигурка скучновата. Надо ее залить красочкой. Для этого, вы помните еще по Word, выбираем кнопку Панели управления по имени Fill Colo (Цвет Заливки).

Рис. 32. ...И залили красной заливкой

Ну, пожалуй, с автофигурами закончим. Перейдем к Вставке Объектов WordArt.

Рис. 33. Галерея WordArt

Многим очень знакома эта Галерея вставок WordArt. Смущать может лишь одно — та же, и даже больше, чем в Собрании Картинок, узнаваемость стандартны: майкрософтовских решений. Лишь вовсе тупой не использовал хоть раз эти стиле вые решения для заголовков или текстов объявлений, рекламы и пр. Хотелось бы попенять Биллу Гейтсу, что, начиная с Word 6.0, WordArt пребывает в своем прежнем обличьи: не убавлено и не прибавлено ничего. Это удручает.

Но выбираем, за неимением иного, какой-то из предложенных тридцати вариантов. И получаем диалог, в котором вместо слов Your Text Here (Введите Ваш текст) вы впечатываете только вам известный тест.

Рис. 34. Диалог редактирования текста WordArt

Пусть, к примеру, этот тест будет таким же, который придуман мной для условного титула книги:

Рис. 35. Впечатали текст Word Art в диалог Редактирования Текста WordArt

И скажем ОК.

Но прежде обратите внимание на само диалоговое окно и его опции.

В верхних полях списков Font: (Шрифт:) и Size: (Размер:), которые входят в своеобразную строку Панели управления, вы можете выбрать любой из шрифтов, установленных в Windows ХР, и любой доступный размер шрифта (по умолчанию это 36 pt).

Рядом — две кнопки, отвечающие за начертание шрифта — Bold (Полужирный) и Italic (Курсив).

Допустим, выбрали.

Теперь-то и говорим ОК.

Рис. 36. Объект WordArt — вставлен

Вы видите, все получилось. Теперь остается лишь определить заголовок на какое-нибудь ему положенное место. К примеру, куда-нибудь на верх второй страницы. Что и проделаем, при этом поместив Объект в размеры фрейма.

Рис. 37. Вот теперь заголовок на месте

Как и в «Ворде», вы имеете полную возможность вызвать диалог Редактирование Объекта WordArt двойным щелчком на Объекте или нажатием кнопки Edit WordArt... (Редактировать WordArt...) с Панели WordArt, которая возникла тут же, в момент вставки Объекта. Кстати, все манипуляции с Word Art, какие только мыслимо проделать, собраны на этой Панели. Покажем лишь один вариант, обратившись опять к Галерее и выбрав другой тип Объекта WordArt при помощи кнопки Панели WordArt Gallery.

Рис. 38. Другой тип объекта WordArt (замена предыдущему)

На этом прекратим экспериментировать со вставкой изображений и перейдем дальше по меню Insert (Вставка).

Следующая опция — Insert Text Box (Вставить Текстовый Блок).

На рисунке 39 вы видите, как на страницу публикации вставлен Текстовый Блок (Фрейм). Сделано это просто: я щелкнул на опции Insert Text Box и, переведя курсор на страницу, протянул мышкой от одной точки до другой — от желаемой точки верхнего левого угла фрейма до нижнего правого, теперь Текстовый Блок попал туда, где мы его якобы ждали, осталось лишь впечатать или вставить сам текст (содержимое).

Рис. 39. Вставили Текстовый Блок

Идем дальше. Следующая опция — Insert Text File... (Вставка Текстового Файла...). Для того нам и пригодится Текстовый Блок.

Рис. 40. Процесс Вставки Текстового Файла

На этом рисунке, вы видите, удачно произошло «склеивание» окошка Процесса и уже вставленного Текста.

Эти «фокусы» происходят, вероятно, из-за некоторых недоработок Windows XP: я заметил уже несколько случаев, когда ХР показывает на экране монитора одну картинку, а «в уме» держит уже совсем другую.

Она-то, другая картинка, и фотографируется в буфер, и когда я вставляю это изображение в кадр в программе Фотошоп, картинка не совпадает с той, какую фотографировал.

После того, как файл вставился, возникает окно-сообщение, изображенное на рисунке 41.

Я не стану приводить английского текста и его точного перевода, просто поясню, что это за текст.

Рис. 41. Программа предупреждает и спрашивает

Программа говорит нам о том, что вставленный текст значительно превышает размеры Текстового Блока. И спрашивает, не связать ли этот блок с другими блоками?

Говорим «Да».

И — новый вопрос: «Autoflow to this box?» (Сделать автоперетекание текста из этого блока?).

Говорим «Да».

Конечно, в который раз мы сталкиваемся с этим неудобством: ну, как было бы прекрасно, если тексты диалогов были переведены на русский! Иногда ответишь по догадке «Да» и лишишься всей наработанной за несколько часов продукции. Было у меня такое. Все-таки недостаточно работают наши интерпретаторы. Или их очень мало?..

Рис. 42. Вопрос, касающийся автоперетекания из этого блока

Теперь программа задает еще один вопрос:

Рис. 43. Следующий вопрос программы

Этот вопрос звучит так: «Do you want Publisher to automatically create text boxes?» (Вы хотите, чтобы Publisher автоматически создавал текстовые блоки?).

Конечно! Говорим «Да» (Yes).

И получаем последнее, наконец, сообщение о том, что программа в соответствии с нашими ответами поступила настолько разумно, что вставила в публикацию несколько недостающих страниц.

Рис. 44. Последнее сообщение, касающееся вставки текстового файла

Правда, нашего текста там было всего на полторы страницы... Откуда Publisher взяла лишних две?

Но я думаю, что в отсутствие эксперимента, когда вам по-настоящему понадобится вставка текстового файла, будет достаточно просто все выяснить и привести в соответствие с настройками, необходимостью, вкусом и функцией. Перейдем к следующей опции меню Insert.

А следующая опция — это Insert Object...(Вставка Объекта...). Объектом мо гут считаться многие вставки, получаемые из различных приложений или утилит ПК многофункционален, он может выполнять разные задачи на многие темы. В том числе, к примеру, вставка чужих таблиц (чужих — в смысле их происхождения: программах-приложениях иных фирм) или вставка формул... Откроем опцию взглянем на диалоговое окно.

Рис. 45. Диалоговое окно Вставки Объекта

Как видите, в списке возможных (далеко не всех!) объектов могут фигурировать и изображения из Adobe Photoshop, и объекты Corel BARCODE (штрих-коды для обложек или этикеток), и изображения Corel PHOTO-PAINT, и таблицы Adobe Table, и графические изображения CorelDRAW, и (взгляните на продолжение списка на рисунке 46) видеоклипы, и файлы мультимедиа, и диаграммы... И так далее. Фильтров в Офисе, в том числе в Publisher, достаточно много.

Рассмотрим же мы один или два примера вставки объектов. Для верности увидим, как вставляются самые малораспространенные, но достаточно важные объекты, без которых часто просто не обойтись.

Начнем со вставки формул. Да-да, именно формул! Потому что, несмотря на замечательную возможность переходить на клавиатуре с кириллицы на латиницу, клавиатура не может охватить всех необходимых для написания формул значков. С записью типа «а» плюс «бэ» она еще справится, но с высшей математикой — извините. Все возможности такого рода собраны в утилите Microsoft Equation 3.0. Вызов этой утилиты также предусмотрен в диалоговом окне. Вы видите ее имя на рисунке 45. Вот ее-то и вызовем.

Рис. 46. Есть даже вставка видеозаписи и звука

Рис. 47. Утилита Microsoft Equation

А это вставка формулы. Замечательная опция, без которой не обойтись при работе над научной книгой.

Формулы, которые записываются в Microsoft Office, могут иметь до 150 знаков, Это не значит, что нельзя записать формулу с числом знаков более 150. Можно, но она будет состоять уже не из одного объекта, а из двух и более. Вставка очередного объекта идет тем же способом.

Для примера я постараюсь описать вставку лишь одной небольшой формулы разряда, возможно, несуществующих. Я бы мог вставить и какую-то реальную формулу из светотехники, но, к сожалению, прожекторное освещение, где такие формулы есть, не штудировал уже более 25 лет, а в других разделах светотехники формулы настолько не используют высшую математику, что становится даже немного неудобно за то, что ты инженер (хоть и в далеком уже прошлом).

Формула, сами понимаете, ведет себя двояко — и как текст (когда мы ее записываем), и как объект (когда мы ее вставляем).

Если мы выбираем приложение Equation и вставляем его продукцию в текст, формула устанавливается поверх текста, как картинка или объект WordArt. Однако если требуется, то можно вставить формулу и непосредственно в текст: тогда это осуществляется вклейкой (вставкой) не из меню Вставка, и из меню Edit (Правка) с помощью команды Paste (Вставить, Вклеить) или команды Paste Special... (Специальная Вставка...).

Говорим ОК, и на странице появляется область ввода (похожая на область вставки Надписи или объекта WordArt), где пульсирует курсор, готовый к впечатыванию знаков. Кроме того, появляется Панель «Формула» — та самая, с применением опций которой мы и собираемся вписывать формулу.

Панель состоит из двух рядов кнопок, под которыми скрываются: верхний ряд — символы, нижний ряд — шаблоны.

Перечень кнопок первого, верхнего ряда (слева направо):

  • «Символы отношений»
  • «Пробелы и многоточия»
  • «Надстрочные знаки»
  • «Операторы»
  • «Стрелки»
  • «Логические символы»
  • «Символы теории множеств»
  • «Разные символы»
  • «Греческие буквы (строчные)»
  • «Греческие буквы (прописные)».

Рис. 48. Меню под кнопкой «Разные символы»

Перечень кнопок второго (нижнего) ряда. Это Шаблоны:

  • скобок;
  • дробей и радикалов;
  • верхних и нижних индексов;
  • сумм;
  • интегралов;
  • надчеркиваний и подчеркиваний;
  • стрелок с текстом;
  • произведений и символов;
  • теории множеств;
  • матриц.

Если вдруг в вашем списке нет строки Microsoft Equation 3,0 или не возникла и не хочет возникать Панель «Формула», вам придется переустановить Microsoft Office XP.

Весь Офис устанавливать не надо, просто в Мастере установки вы выберите верхнюю строчку для установки (не помню точно, как она называется, но там должны фигурировать слова «добавить» или «изменить») и в последующем диалоге с Мастером установки из предлагаемых компонентов обязательно не пропустите и подтвердите выбор Microsoft Equation для установки на ваш ПК.

Опция этой утилиты находится в списке фильтров и конвертеров, которые либо доступны Windows и Офису, либо сами являются разработкой Корпорации Майкрософт. Вообще надо сказать, что Майкрософт так же, как и фирма Corel, до последнего времени была очень лояльна к чужим разработкам, и потому явная неприязнь (слово неточное: скорее всего неприятие) к некоторым разработчикам приложений и утилит ныне объясняется не столько экономическими, сколько психологическими факторами: скорее всего эти фирмы поучаствовали в том, что называется борьбой с монополизмом...

Но вернемся к нашим баранам: вряд ли у вас нет утилиты, обычно Офис устанавливается сам и полностью, и лишь потом можно, наоборот, выбросить описанным способом некоторые компоненты.

Итак, поле страницы готово к восприятию нашей формулы. Только вот какую бы формулу-то вписать?

Честно говоря, я думал долго. Даже ПК перешел на экономичный режим, отключив экран.

Однако вот результат:

Рис. 49. Вставили формулу

После вставки формулы, когда она набрана правильно и дальше нет проблем, мы можем щелкнуть в чистом месте листа, и приложение Microsoft Equation, вместе со своей Панелью «Формула», растворится, как не бывало.

Останется лишь формула

Формулу можно подвергнуть редактированию. Для этого достаточно щелкнуть на ней мышкой два раза, и появится приложение, в котором ее записывали — Microsoft Equation 3,0. Тогда она полностью готова к редактированию.

Однако кое-какие важные вещи с формулой можно делать и без всяких приложений. Например, я говорил о том, что формула ведет себя как объект. Для удобного размещения на странице (особенно в книге) формулу можно либо чуть-чуть поджать, либо чуть-чуть растянуть. Это делается при помощи маркеров выделения. Так же точно, как и фотоизображение, автофигуру и так далее.

Обратимся теперь, как и обещали, к еще одному объекту, без которого сейчас, к примеру, ни один товар, произведенный и расфасованный, даже ни одна обложка книги не обходится. Я говорю о штрих-коде.

В Publisher, как и в других приложениях Офиса, есть возможность (фильтр) вставляя в свои публикации штрих-код. Конечно, внутри документа штрих-код не совсем нужен, а вдруг вы делаете картинку-этикетку для какого-нибудь товара? Вдруг вы печатаете коротенькую бумажку, чтоб вложить ее в упаковку какой-нибудь селедки под шубой?
Тогда опять вызываем опцию Insert Object... и выбираем...

Из списка выбираем Corel BARCODE 10,0. Это приложение к CorelDRAW, верно одно из приложений графического пакета CorelDRAW. Там Мастер штрих-кода гор нужнее, потому что все этикетки (ну, не вес, а половина) делаются именно в CorelDRAW.

Выбрали эту строчку и говорим ОК.

Рис. 50. Мастер штрих-кода к вашим услугам

Мы знаем множество международных кодов кодирования товаров различного профиля. Впрочем, мы-то знаем, что они, эти коды, есть. А вот что они такое в самом деле, я, например, не имею представления. Кроме одного кода — штрих-кода, основанного на ISBN (единый международный код для книги). На каждую книгу выдается свой отдельный номер, больше не повторяющийся.

Вот как на основе других универсальных кодов, так и на основе универсального ISBN — формируется штрих-код (тоже индивидуальный для каждого товара). Мы станем строить свой штрих код именно на ISBN. В списке в окне выбора формата кода (там, где вы видите по умолчанию слово CodaBar) находим ISBN.

Нижнее окошко поменяло свой внешний вид и ждет от вас записи вашего ISBN-кода. Вписываем и говорим «Далее».

Рис. 51. Вписали свой номер ISBN

И на рисунке 52 вы видите появившееся вслед за этим окно.

Рис. 52. Выбираем параметры

В окне показано, с каким разрешением и другими параметрами Мастер штрих-кода сформирует ваш код, который должен после всех манипуляций появиться на странице.

Как видите, разрешение 300 dpi — это по умолчанию. Значит, для считывающего устройства худшего разрешения давать нельзя. С помощью списка пей кнопкой вы сможете выбрать лучшее, но при общем разрешении в 300 точек нет смысла этого делать. Также установлены высота и ширина символов, масштаб изображения кода.

Обратите внимание: тот якобы код, что видите вы в окне просмотра, это вовсе не ваш код. В окне показано, как код выглядит, и больше ничего.

С ISBN есть проблемы, поэтому щелкаем большой длинной кнопкой Advanced... (Дополнительно...), находящейся справа в диалоге.. Получаем другое диалоговое окно.

Рис. 53. Дополнительные параметры

Здесь (рис. 53) по умолчанию стоит флажок в строке «Без приложений». Нам же надо приложение (сам штрих-код). Щелкаем ту строчку (ставим флажок), где написано «978». Книжные коды, насколько я знаю, предваряются тремя цифрами дополнительного кода «978». Он необходим для аппарата как сигнал к тому, что следом за ним аппарат считывания кода прочтет штрих-код самой продукции, в котором первая цифра (5) обозначает нашу страну, Россию. Щелкаем и говорим «ОК».

Рис. 54. Выбрали полновесный штрих-код

И видим, что кнопка «Далее» превратилась в кнопку «Готово». Что ж, щелкаем по ней. Программа выбрасывает вопрос:

Рис. 55. Вопрос программы к вам

Вопрос такой: «Do you want to copy bar code to clipboard?» — «Вам нужно скопировать штрих-код в Буфер Обмена?». Говорим «Да». И после этого известным способом вставляем этот штрих-код на страницу.

Рис. 56. Штрих-код уже в публикации

И... на нашей страничке появляется не чей-то, а только наш штрих-код!

В вашем варианте может не быть вопроса, который я описал из рисунка 55. Вопрос возник только в моем случае, потому что у меня установлена CorelDRAW 10 без утилиты BARCODE, и эту утилиту пришлось вызывать прямо с диска с пакетом программ CorelDRAW. Кстати, если у вас та же ситуация, смогу вам показать путь:

Диск: папка Corel\ папка Grарhic10\папка Programs\файл приложения barcode.

Вопрос исчерпан.

Это интернетовские штучки, я покажу лишь диалог, возникающий при вызове этой опции, а дальше не пойду.

Рис. 57. Диалог Вставки Гиперсвязи

Здесь вы должны указать адрес и путь выбранного в качестве гиперсвязи объем та (или текста, или рисунка). В общем, ответить на все вопросы, что задаст программа через этот диалог. Для темы верстки эта гиперсвязь никак не подходит, и потопе пропускаем ее.

Итак, мы завершили рассматривать один из важнейших вопросов — меня Вставка (Insert). В ходе этого разговора научились осуществлять кое-какие вставки, с которыми кому-то прежде не приходилось сталкиваться. Переходим к другому важному меню — Format (Формат)...

Хотя нет. Прежде чем рассмотреть меню «Формат», надо уяснить специфические вопросы работы на версткой книги. Не только книги, но и газеты, журнала, часто и простой листовки. Поэтому следующая глава будет посвящена опять некоторой доле теории, поскольку меню Format, которое дальше мы собираемся расе сматривать, затрагивает многие функции.


Глава 1

Часть третья.
Microsoft Publisher: основы верстки

  • Что такое верстать
  • Меню «Формат» (I)
  • Меню «Формат» (II)
  • Меню «Инструменты»
  • Командное меню «Таблица»
  • Командное меню «Порядок»
  • Меню «Окно» и «Помощь»


Глава 1

Глава 8 Что такое верстать

В этой главе, может быть, я во многом повторюсь, скажу то, о чем уже говорил прежде. Думаю, это все равно не будет лишним: впереди меню «Формат»!..

Программа Publisher соблюдает, как уже говорилось, главное — все принципы верстки, которые, если их придерживаться, позволяют сделать все не только красиво, но и правильно.

Добавлю то, о чем упустил сказать раньше. Для Publisher, как для Кварка и для PageMaker, практически безразлично, насколько текст, находящийся в буфере, отформатирован. Многие задачи форматирования здесь решены — переносы, выравнивание текста, шрифт и его размер. Но, в отличие от перечисленных верстальных программ, прежде чем поместить текст на страницу, Publisher придает ему по умолчанию свои параметры. Соответственно текст, принятый программой на страницу публикации, получается менее «сырой», чем в других программах верстки. Publisher многое как бы делает за вас, и вам остается лишь подправлять ту обработку которую программа сотворила с текстом. Дальше мы убедимся, что, работая в Publisher, человеку иногда нет необходимости вмешиваться в верстку. Посудите сами: если текст пришел из майкрософтовского приложения, то есть из Word, WordPad и др., программе даже не нужно объяснять, что текст русский (или английский) — она сразу же расставляет переносы. Кстати, впервые я встретил приложение, которое преспокойно переносит и русский, и английский текст.

Не удивляйтесь: практически все программы переносят слова и по-русски, и по-английски, но если текст смешанный (как, кстати, в той книге, которую вы читаете), то такого не происходит, по-моему, нигде, кроме Publisher, да еще, может быть, Word 2002 ХР. Именно такие переносы вы встречаете в этой книге.

Идем дальше. Жидкая строка получается в книге обыкновенно очень часто — чаще чем плотная. И в первой главе раздела мы поговорили об этом. Но из-за снятия вопроса о разноязычных переносах, о которых мы только что говорили, в Publisher практически отсутствуют и жидкие, и плотные строки. А если что-то и появляется, то программа справляется с «жидкостью» и «плотностью» самостоятельно.

Теперь коснемся висячих строк.

Что такое висячая строка; Это видно из самого определения: строка, которая повисла. Строка может оказаться полной, то есть содержащей то число знаков, на которое как раз разбита книжная строка. Тогда некоторые издатели уже считают, что строка не висит, и пропускают ее. На самом деле это по старым канонам все равно висячая строка, поскольку она — всего одна строка от предыдущего абзаца на новой странице (или всего одна строка из абзаца следующей страницы, попавшая на предыдущую), и с нею надо что-то делать. Но подобное обстоятельство еще не может быть самым страшным. Самый непрофессиональный вариант в данном случае тот, когда от этой строки на новую страницу попало всего несколько знаков.

И здесь издатели поступают по-разному. Есть такие, которые разжижают предыдущую строку, добавляя в висячую еще какое-то количество знаков. Это делается за счет трекинга — межсимвольного интервала. Тогда для них строка получается как бы и не висячей. Но это как раз все еще крайний, непрофессиональный вариант. Если считать правильно, то такая строка вовсе не должна находиться на этой новой странице (или строке). То есть соответственно ее нужно было бы, наоборот, уплотнить: тогда она целиком уместилась бы на предыдущей странице, и вопрос бы снялся.

Ну, да ладно, я отвлекся. Идем дальше.

Столь же висячей строкой является и одна строка последующего абзаца, которая оказалась на предыдущей странице. Однако многие издатели допускают ее присутствие на предыдущей странице, вовсе не считая ее висячей — опять же по той причине, что она полная. Ну, во-первых, она всегда как раз формально неполна поскольку абзац начинается с красной строки...

И еще повторюсь: верстка всегда должна начинаться с самой первой строки текста!

Завершив работу над первой строкой, переходим ко второй, потом третьей и та далее. Завершив первый абзац, переходим ко второму... Нельзя верстать с середины книги. Этого нельзя делать даже в том случае, если вы заметили при пролистывании какую-нибудь явную ошибку. В отличие от правки текста, верстка идет только о начала до конца. Возвращаться к верстке на первых страницах тоже губительно если сверстана вся книга. Потому верстальщики — народ очень нервный: представьте, к нему пришли на последней стадии верстки и поправили два-три слова; начале книги... Конечно, книга стала лучше с точки зрения автора и редактора (и забудем и о читателе), но каково при этом верстальщику?

Об иллюстрациях мы тоже говорили. Множество способов поместить иллюстрацию в текст, множество принципов обработки иллюстрации не дают возможное выработать какие-то единые правила верстки иллюстраций. Здесь все основывается в основном, на художественном чувстве или чутье.

Скажу о некоторых своих наблюдениях при работе с Publisher. Когда вы вставляете иллюстрацию через Буфер Обмена, необходимо сделать так, чтобы никакой из объектов на странице не был выделен. Иначе программа примет это выделение я рамку, в которую следует вставить иллюстрацию. Особенно это касается таких иллюстраций, которые уже существуют на странице: выделенную иллюстрация Publisher понимает как Блок Изображения, куда надо поместить новую иллюстрацию, и потому намертво вклеивает ее туда. В результате вы лишаетесь прежней иллюстрации и вместо нее получаете новую. Ни вам, ни программе это не нужно.

Если выделен Текстовый Блок, иллюстрация на него не покушается. Но лучше все же следить за тем, чтобы никаких выделений на странице не было (кроме тая рамки, которую вы для этой иллюстрации определили, если, конечно, сделали этой Рисунки в данную книгу я вставляю без предварительных кадров: так иллюстрация ведет себя свободнее, и верстка книги, где очень много рисунков, таким образом облегчается.

Раз уж мы заговорили об иллюстрациях, то, пользуясь случаем, хочу похвалить разработчиков Microsoft Publisher за то, что они очень экономят объем вашего жесткого диска (правда, при этом утруждая оперативную память). Книга одного и тощ же объема в Publisher получается в три-четыре раза «дешевле», чем в PageMakai там расходовалось, к примеру, 20-25 мегабайт, а в Publisher — только 6-7. Проверяется это очень просто: когда идет превращение в PS-файл, при кодировке в постскрипт-формат программа набирает сэкономленные мегабайты.

Однако хотелось бы и посетовать на авторов Publisher: так же, как Word, программа излишне, на мой взгляд, занимается страницами текстом. Не спорю, с текстом она справляется великолепно, но... очень часто делает это страшно медленно.

Иногда подумаешь: пусть уж лучше ошибается (поправим) и забирает большим объем (сбросим на лазерный диск), но ждать, глядя, как медленно шевелите Publisher при оперативной памяти 65 (!), очень неинтересно и очень утомительно.

Что ж, немного отвлеклись.

Приступим к важнейшему функциональному меню. Оно ждет нас, не дождется.


Глава 1

Меню «Формат» (I)

Рис. 1. Меню «Формат». Открыто подменю AutoFit Text

В самом деле меню «Формат» очень важно. Особенно в программе верстки! Без назначений форматов документ не документ. Все возможности форматирования в Publisher, как и в других приложениях Офиса, собраны в командном меню «Формат».

На рисунке 1 вы видите, что у меню «Формат» есть одно небольшое подменю, которое относится к опции AutoFit Text (Автоматически Растянуть Текст). Эта опция имеет три подопции — None (Нет, Не Действует), Best Fit (Растянуть по Максимуму) и Shrink Text On Overflow (Сжать Текст для Перетекания).

Но возьмемся за опции меню Format (Формат) по порядку, начиная с самой первой строки. А это — строка Font (Шрифт). Щелкнув по этой опции, мы получим диалоговое окно назначений почти всех атрибутов шрифта. Взгляните:

Рис. 2. Диалоговое окно Font

Здесь в верхних полях списков в поле General (Общие) назначаются гарнитура (список Font:), Стиль Шрифта (Font style:) и Размер его (Size:) А в нижних полях Underline: (Подчеркивание) и Color: (Цвет:) — подчеркивание и шрифта.

Интересно второе поле. Оно называется Effects (Эффекты). Первой группой столбик) вдут Верхний Индекс (Superscript) и Нижний Индекс (Subscript). — Outline (Контур) и Emboss (не могу перевести, но выглядит это так: к начертанию шрифта добавляется снизу и справа дополнительный контур на полутоне — есть при цвете шрифта черном этот полутон — серый). На контур желательно был бы взглянуть — это достаточно ярко для Офиса.

Рис. 3. Опция Outline, текст как Контур

Впечатляет. Это услуга Офиса, в Word назначения примерно те же. Идем дальше.

Следующий столбик опций — Small caps и All caps (Малые прописные и Все прописные). Это понятно также. И последний столбик — Shadow (С тенью) и Engrave (Гравирование). Текст с тенью — это всем понятно, а вот Гравирование — оказывается, почти то же, что Emboss, только добавка контура идет сверху и слева.

Нижнее поле — Сэмпл, Sample (Образец). В нем осуществляется просмотр того, что может произойти с вашим текстом при назначении той или иной опции. Все это происходит со словом «Образец» (или Sample — в зависимости от того, какая из двух левых стрелочек-кнопок вами будет назначена).

Мы коснулись того, какой формат вы можете назначить вашему шрифту. Дальше он подвергнется форматированию иного рода.

Рис. 4. Диалог назначений Character Spacing

Следующая опция — Character Spacing... (Характер Шпаций). Шпация — типографский термин, означающий промежуток (интервал) между соседним знаками в строке и между строками. Фактически это межсимвольный интервал.

Рассмотрим же опции диалогового окна Характер Шпаций.

В верхнем поле, которое называется Scaling (Масштабирование, Масштабность), указана ширина символа и в поле ввода по имени Shrink or stretch selected text: (Сжать или растянуть выделенный текст) указана величина 100%. Иногда: даже в параграфном тексте (в абзаце) приходится или сжимать (чаще) или растягивать ширину символов. Это преследует задачу что-то с чем-то сровнять, сделать строку не висячей и так далее. Впрочем, абзац редко подвергают такому насилию. А вот в заголовках подобный подход практикуется очень широко. Но уменьшать, как и увеличивать ширину символа можно до определенного предела. К примеру, величина 90% или 110% от стопроцентной ширины уже заметна. Она менее заметна, если каждый символ абзаца подвергся изменению в равной мере, а если такое проделать с одним-двумя символами, становится очевидным и гораздо раньше. Посмотрите хотя бы на слово ПРИРОДЕ с шириной символов 95% на рисунке 5 оно уже отличается от «стопроцентного» слова КНИГА.

Рис. 5. Изменена ширина символов (Scaling 95%)

В поле ввода вы сможете назначить вручную с клавиатуры любое значение для ширины символа, а если станете назначать эти значения при помощи счетчика, то характер изменений будет скачкообразным: после 100% сразу 90% и так далее. Такое возможно только для текста в афише, но не для классической верстки книги или газеты.

Поле, расположенное ниже, является полем Трекинга (Tracking). Здесь два поля списка — один с именами Трекинга, другой с процентным назначением. Шаг здесь тоже скачкообразный, но поменьше — по пять процентов. Впрочем, если помните из прошлой главы, трекинг 0,04 (четыре процента) уже бросается в глаза.

Грубые разделения Трекинга на Нормальный — Normal (100% шпации), Очень Плотный — Very Tight (75%) и Плотный — Tight (87,5%); Жидкий, Свободный — Loose (112,5%), Очень Жидкий — Very Loose (125%) и Обычный — Custom (тоже 112,5%) дают лишь ту область, вокруг которой, при желании, можно найти некоторые другие значения Трекинга, используя или счетчик, или вводя данные вручную.

Значения Кернинга в поле Кернинг по тому же принципу меняются в трех вариантах — от Нормального — Normal (0 pt) до Свободного — Expand (3 pt) и Плотного — Condensed (1,5 pt). Свободный Кернинг предполагает наличие почти нормального межсимвольного интервала, то есть практически отсутствие кернинга, как такового. Плотный — перекрывает символы на 1,5 точки, а Нормальный — это просто отсутствие межсимвольного интервала (шпации).

Последнее поле — Automatic pair kerning (Автоматический кернинг пар). При значении 14 pt и выше назначает кернинг автоматически для тех пар, где кернинг возможен.

В самом низу диалога есть кнопка Show Toolbar — Показать Палитру Размеров. Если щелкнуть на ней, в рабочем поле появится Палитра (Панель) Размеров — Measures. Вы видите ее на рисунке 6.

Рис. 6. Панель Measures

На этом закончим выяснения с этой опцией и перейдем к другой Spacing... (Межстрочная Шпация...). А ее диалог показан на рисунке 7.

Рис. 7. Диалог Межстрочной Шпации (Интерлиньяжа)

В левом поле Line spacing: (Межстрочная шпация) здесь в списке поля ввода Between lines: (Между строчками) по умолчанию записана одна шпация — 1 sp. В правом поле Sample (Образец) очень хорошо видно, насколько заметно изменяется состояние текста, если назначить межстрочный интервал вместо одной шпации в две.

Рис. 8. Интерлиньяж в две шпации

Два другие поля ввода, где фигурируют нули, назначают интерлиньяж До абзаца (Before paragraphs) и После абзаца (After paragraphs). Интерлиньяж измеряется в пунктах — так же, как и размер шрифта. На рисунке 9 видно, что я назначил Интерлиньяж между настоящим и предыдущим абзацем в 15 пунктов! и точно такой же — между настоящим и последующим абзацами.

Рис. 9. Межстрочный интервал до и после абзаца

Ну, вроде бы и все. Теоретизировали по этому поводу мы достаточно в прошлой главе.

Да, а кнопка Показать Палитру Размеров (Show Toolbar) не активна. Почему?.

Да потому что Палитра уже на месте. Если ее убрать, кнопка активизируется.

Кстати сказать, а зачем здесь кнопка? — Понятно: нижней строкой в Палитре Размеров (я ее называю Панелью Реквизитов, хотя для Publisher это менее правильно,! чем для PageMaker и QuarkXPress) находится Интерлиньяж.

Что ж, спасибо опции. Идем дальше.

Опция Indents and Lists (Отступы и Списки). Ее диалог вы видите на рисунке 10.

Рис, 10. Диалог Отступы и Списки

Вглядимся в этот диалог. Он нам достаточно знаком по Word. Правда, дизайн здесь не вордовский, но все угадывается. Вот было бы еще все по-русски — цены бы не было этой программе, а то все время приходится продираться сквозь американский жаргон английского...

Так вглядимся. Верхнее поле — Indent settings (Установка отступов). Здесь три позиции — Normal (Обычный), Bulleted list (Маркированный список) и Numbered list (Нумерованный список).

Рассмотрим сначала первый, с его назначениями. Впрочем, назначения почти те же и в двух других — просто выглядят они по-разному. В поле Indents (Отступы) в строке Preset (Назначение) по умолчанию указан Flush Left (Отступ Слева), равный, судя по Образцу, нулю. Впрочем в других строка с полями ввода можно это! исправить. Следующая строка — Слева: (Left:) — в поле вписан 0. Следующая строка: First line: (Первая строка:), здесь тоже 0. И последняя — Right: (Справа:), где все тот же ноль. В зависимости от всевозможных задач верстки мы можем значить и другие значения для каждого поля.

И наконец внизу — поле списка Alignment (Выравнивание). Список стандартен, но все же взгляните: он кроется за кнопкой открытия списка (рис. 11).

Рис. 11. Открыт список Alignment

Как видите, здесь выравнивание на всякого любителя — и по левому краю, и по правому, и по центру, и по ширине (Justified — Правильное).

Кнопкой Line Spacing... (Интерлиньяж) из этого диалога открывается предыдущий диалог. Так что не только в Палитре Measures, но и в этом диалоге Интерлиньяж и параметры Трекинга и Кернинга связаны. Назначения делаются легко и удобно.

Посмотрим на второй вариант, предлагаемый полем Indent setting (Установка отступов) — Bulleted list (Маркированный список).

Рис. 12. Назначен Маркированный список

Мы видим, как преобразился Образец в своем поле просмотра. Нам такие списки знакомы. В поле Bullet type (Типы маркеров) из ряда кнопок с пиктограммами можно выбрать тот тип маркера, какой нас наиболее устроит. Их несколько. Тут и стрелка, и ромб, и звездочка... Можно пощелкать, это даже интересно. Все манипуляции с кнопками отражаются в поле Sample.

Если вас не устраивает ни один из предлагаемых вариантов маркера, вы можете выбрать совсем другой, нажав в поле Button type кнопку New button... (Новый Маркер...). Откроется полный список символов, из которых вы сможете выбрать любой, используя полновесное диалоговое окно вставки символов (рис. 13).

Рис. 13. Диалог Вставки Символа

В том же поле регламентированы Размер (Size) маркера — 10 pt и Отступ его} от списка (Indent list by:) — 1 см.

Рис. 14. Другой тип списка — Нумерованный Список

Вместо поля Типы маркеров для Нумерованного Списка возникает поле Number (Номер). В поле четыре опции — Format: (Формат:), Separator: (Разделитель:), Startat: (Начать с:) и тот же знакомый нам по Маркированному Списку Indent list by: (Отступ текста:). В первой строке вы сможете выбрать Формат маркировки — то ли это будут цифры, то ли буквы (есть список возможного). Под Разделителем понимается точка, стоящая после цифры номера. Из списка Разделителя вы можете выбрать скобку, квадратную скобку и т. д. Третья строка дает нам возможность начать нумерацию не с единицы, хотя по умолчанию стоит единица. Это важно, так как очень часто в документах и в книгах возникают в тексте разрывы подобных списков. В разрывах авторы предлагают свои комментарии к очередному пункту, а комментарии могут быть и очень объемными. Когда же вы возвращаетесь к списку, он может опять начать нумероваться с первого номера. Опция существует как раз на такой случай — избежать накладки.

Вот, кажется, и все с этой опцией меню. Пойдем далее.

Следующая опция — Tabs... (Табуляция...). Здесь все просто, приведем лишь сам диалог.

Рис. 15. Диалог установки Табуляции

Честно говоря, уже много лет являясь пользователем ПК, зная много программ-приложений, ни в одной из них я не нашел большой необходимости пользоваться кнопкой Табуляции. Вероятно, нужно быть уж слишком математическим изнутри, чтобы скакать по тексту, используя заданные интервалы. Польза от Табуляции просматривается мною лишь в заполнении пустых таблиц, когда с использованием этой кнопки легко перескакивать курсором из ячейки в ячейку. Может быть, я и не совсем прав, может быть, я не улавливаю какого-то высшего смысла, но откровенно говорю об этом и прошу читателя не обижаться на эту мою позицию.

Идем дальше.

Рис. 16. Подменю AutuFit Text

Мы добрались до того самого подменю AutoFit Text (Авторастянуть Текст). Пользу второй по счету опции (Растянуть до границ Блока) мы усвоим. Посмотрим, как она действует.

Рис. 17. Растянули текст с помощью опции Best Fit

Это вполне годится для верстки, особенно, может быть, не для абзацев, а для заголовков.

Кстати сказать, для того чтобы растянуть текст до границ фрейма, не обязательно выделять сам текст. Достаточно щелкнуть курсором для выделения блока. Точно так, как показано у меня на рисунке 17. Хотя и при выделении текста известным вам способом опция срабатывает.

Раз уж заговорили о выделении текста, хотелось бы напомнить о способах этого выделения. Вы можете, как делает это большинство, щелкнуть мышкой в начале текста и, не отпуская, потянуть курсор до той точки, до которой желаете выделить текст. Текст при этом выделяется. Но часто получается так, что выделить одно лишь слово — затруднительно. Работа становится слишком тонкой, особенно если у вас малый масштаб.

Тогда применяются щелчки мышки. Два щелчка на слове — выделяется слово. Три щелчка — выделяется абзац. К сожалению, в Publisher, как и в Word, нельзя щелкнуть четыре раза, чтоб выделить страницу (как в Кварке) или пять раз, чтоб! выделить все (там же). Но уже одного того, что мы сумеем быстро выделить абзац, мне кажется, достаточно.

Специфика верстальных задач помешала придумать для Publisher что-то близкое к возможностям Word. Там можно выделить строчку или строчки, не ставя курсор на текст. Из-за левого поля текста, когда курсор представляет собой право-наклонную стрелку, можно щелкнуть ею на месте, и выделится строка текста, против которой оказалась стрелка курсора. А если протянуть, не отпуская, то выделится ровно столько строк текста, сколько пройдет курсор до тех пор, пока вы не отпустите его. Жаль еще, что в Publisher отсутствует дополнительный способ перелистывания, о котором не забыли в Кварке: там можно переходить со страницы на страницу и с помощью навигатора страниц, и с помощью вертикальной прокрутки (как в Word). Здесь этого нет.

Опция Сжать Текст для Перетекания альтернативна второй (Best Fit). Потому не может стоять двух флажков в этом подменю. Каждая из опций, в том числе и первая, взаимно исключают друг друга.

Следующая опция — Horizontal Rules... (Горизонтальные Линии...).

Здесь нас ждет диалог назначения Горизонтальных Линий между абзацами. Это важно, к примеру, в газете.

Рис. 18. Диалог назначения Горизонтальных Линий

Из диалога все ясно. Ставя флажок в строке До Абзаца, мы назначим линию до абзаца. Ставя флажок в строке После Абзаца — получим линию после абзаца. Другие строки в верхнем и нижнем полях регламентируют свойства этой линии — цвет и способ начертания. Линия может быть сплошной или штриховой, двойной и так далее. Так же определяется ее толщина. В правых полях назначаются позиции этой линии.

Для примера назначим линию после абзаца. Вот она, на рисунке 19.

Рис. 19. Назначили Линию После Абзаца.

Как видите, все просто. Но не просто избавиться от нее. Поэтому важно выбрать — каким способом вы станете рисовать линию. Ведь ее можно нарисовать и вручную, используя инструмент Line. По всем статьям, я считаю, это гораздо надежней, ибо в любой момент линию можно передвинуть, удалить... Как, например, вы удалите линию, созданную с помощью этого диалога форматирования? Практически никак. Если вы опомнились до того, как совершили после назначения линии двадцать операций с публикацией, то вам повезло. А если было уже тридцать манипуляций? Или двадцать одна?.. Или ни одной, но вы сохранили публикацию, используя команду Save?

Способ только один. Надо вызвать тот же диалог и назначить уже существуй щей линии белый цвет.

Заметьте еще одну важную деталь: рисование инструментом Line создает странице Объект Линию. А назначение линий из рассмотренной опции относится) сфере Форматирования Текста. Отсюда и сложности.

Прежде чем говорить о следующей опции, вставим Объект из Галер Publisher. К примеру, такой:

Рис. 20. Объект из Галереи Publisher

Вы видите, что я вставил первый попавшийся вариант дизайна в ту публикацию, которая нам служит для экспериментального рассмотрения команд и от программы. Потому не смотрите на то, что объект оказался вставлен где-то не у места, посредине другого объекта и так далее. Для нас сейчас важно, что он активен. Потому что только для собственных объектов из Галереи Дизайнов программа! «держит» опцию Wizard For This Object... (Мастер для Данного Объекта...).

Опция открывается строкой меню того же названия. Откроем этого Мастера и взглянем, что он предложит нам.

Строка открывает Докер Мастера, в котором в поле Apple a design (Применить дизайн) собран весь список такого рода Объектов, который нами использован. Мастер не может показать вам Объекты другого дизайна (из другого списка, который можно открыть лишь из Докера Галереи). Зато здесь вы можете применительно к вашему избранному Объекту выбрать другой тип дизайна.

Ну и что? — спросите вы. С таким же успехом можно было выбрать другой объект из самой Галереи и не вызывать никаких Мастеров.

Рис. 21. Новый Объект, старый дизайн

Можно было. Но дизайн у того Объекта, который вы видите на рисунке 21, отличается от того, который возник на странице публикации. Именно для того и существует этот Мастер. Я выбрал форму, которую вы видите на рисунке 20, но меня не устроило кое что — форматирование, цвет и т. д. Оставив объект на месте, выбираю другое форматирование (например), но Мастер, меняя форматирование «под новый объект», не затрагивает дизайна старого, с рисунка 20. В результате сине-белый дизайн нового объекта остается при нем, а на наш старый объект переходит только Форма. По крайней мере гамма моего Объекта осталась прежней.

Обратите внимание еще на одно обстоятельство. Взгляните на рисунок 20. Под Объектом вы видите кнопку и всплывшую подсказку к ней. Так вот вызывать Мастера можно не из меню Format, а просто щелкнув по этой кнопке. Мастер инициируется.

Еще скажу, что дизайны Галереи Дизайнов сами по себе не являются незыблемыми блоками, в которые нельзя вмешиваться. Они прекрасно редактируются да! частям и целиком.

Идем далее. Нас ждет опция Publication Options... (Параметры Публикации...).

Рис. 22. Докер Word Import Options

Это уже знакомый нам Докер. В нем мы «исходили» все поля. И обратите внимание: среди гиперссылок, собранных в верхней части Докера, как раз те, чьи опции следуют за рассматриваемой в меню Format. Это опции Publication Designs... (Дизайны Публикаций...), Color Schemes... (Цветовые Стили...) и Font Schemes... (Стили Шрифтов...). Каждая из этих гиперссылок откроет нам соответствующий Докер. Вот они, на предлагаемых вам рисунках 23-25.

Рис. 23. Докер Дизайнов Публикаций

Рис. 24. Докер Цветовых Стилей с диалогом Выбора Цвета

Диалог Выбора цвета вызывается другой гиперссылкой — Custom colo scheme... (Обычная цветовая схема...). В нем собраны плашечные цвета. К вашим услугам две вкладки — Standard и Custom.

Рис. 25. Докер Стилей Шрифтов

Что ж, нам еще, возможно, предстоит вернуться к этим опциям, когда мы займемся конкретно версткой материала. А сейчас идем дальше.

Следующая опция меню Формат — Background... (Фон...). Вызвав ее, мы откроем Докер Background, где подобраны несколько вариантов градиентной заливки! фона. Первый из них, самый распространенный — это отсутствие всякой заливки. Честно говоря, он наиболее предпочтителен в большинстве работ, которые можно осуществлять в программе. Но бывают и случаи, когда просто необходимо придать полосе некий фон, в том числе даже функциональный — к примеру, для того, чтобы разнообразить заголовки — делать их белым или иным цветом, поскольку серый фон, серый цвет у большинства художников считается «добрым», то есть лояльным к остальным цветам, чего не скажешь о «цветных» цветах.

Рис. 26. Докер Background

Возьмем для эксперимента отмеченный в Докере на рисунке 27 вариант градиентной заливки. Кнопка справа от ячейки с образцом заливки открывает меню из двух опций. Его же можно открыть, если щелкнуть на образце второй кнопкой мыши (это контекстное меню). Опции меню такие: Apply to the Page (Залить эту Страницу) и Apply to All Pages (Залить все Страницы). Выбираем первое и заливаем первую страницу.

Рис. 27. Выбираем градиентную легкую заливку

Титульный лист получает эту легонькую заливку, и качество, хоть оно и так невысокое, не только не страдает, но, по-моему, даже выигрывает. Взгляните:

Рис. 28. Залита одна страница

Смотрим, какие возможности у коллекции заливок Докера.

При помощи полосы горизонтальной прокрутки просматриваем этот набор заливок и видим, что среди них есть и текстурные заливки, и изображения (к примеру, Закат).

Или вот такая скрученная в спирали вермишель: когда ее много, заливка такого рода изображением похожа на какую-то изощренную текстуру, весьма удачно сфабрикованную художником. И никому не придет в голову, что это фотопортрет настоящей вермишели...

Вы видите этот вариант на рисунке 29.

Рис. 29. Сколько лапши!

Попробуем еще что-нибудь из коллекции. Назначим, к примеру, Пергамент (текстура)...

Рис. 30. Извините, это не Пергамент, я Мятая бумага

Пока я рассуждал, нашел заливку получше. Вы видите ее на рисунке 30.

Хотя Пергамент из всех испробованных мною текстур выглядит благородие остальных.

Но с коллекцией ясно. Я хочу рассказать, что можно сделать еще. К примеру, на том же рисунке вы видите, что среди градиентной заливки затесалась текстура Мятая бумага.

Мы ее вставили помимо коллекции, из другого собрания. Оно скрывается под гиперсвязью More backgrounds... (Кроме того, Более, Другие фоновые планы...).

Эта гиперссылка вызывает диалог, который вы видите на рисунке 31. Вглядимся в него. По умолчанию он открывает вкладку Градиентная заливка (Gradient).

Рис. 31. Диалог Fill Effects

Честно говоря, разглядывать и выбирать варианты можно часами. Можно забыть и о работе, настолько богаты возможности Publisher в этом отношении. Богаты не в смысле того, чтоб забыть о работе, а в смысле создания разного рода заливок, используя настройки лишь одной вкладки диалога. Во-первых, во вкладке существует верхнее поле Colors (Цвета). На рисунке пока все неактивно, но поставим флажок в верхней строчке One color (Один цвет) и увидим, что в поле появились новые настройки — Colorl и движок Темно — Светло.

Рис. 32. Вкладка с назначением One color

Здесь уже, можно сказать, неограниченное число возможностей: во-первых можно назначить любой из цветов, предлагаемых программой, во-вторых — варьировать яркостью. Не забудем, что градиентных заливок очень много (по типу), еще и поворот заливки меняется...

Но есть и еще вариант — Two Colors (Два цвета).

Рис. 33. Вкладка та же, назначение Two Colors

Видите, здесь нет переходов Темный — Светлый, но есть второй цвет черный. Таким образом, если есть выбор уже двух цветов, то вариантов тоже! множество. Не станем их перебирать, вы это проделаете сами в своей программе.

А вот назначение Preset (думаю, переводится как Выбор).

Рис. 34. Та же вкладка, назначение Preset

Здесь много вариантов, каждый имеет имя. Сейчас мы видим Early Sunset (Ранний Закат).

Вот еще вариант — Horizon (Горизонт):

Рис. 35. Вариант Horizon


Глава 1

Меню «Инструменты»

Вообще-то, по-хорошему, это меню должно бы называться, как оно и называется в майкрософтовских приложениях — «Сервис». Потому что Сервис — более широкое понятие, чем просто Tools (Инструменты). Очень сложно систему назначения Тезауруса назвать Инструментом. Или того же Языка... Но это все же детали.

Как бы то ни было, откроем меню Tools и взглянем на него.

Рис. 1. Меню Tools, подменю Commercial Printing Tools и подменю Trapping

Меню Tools решает многие вопросы. Достаточно важный — это Орфография, Правописание (Spelling). Подменю этой опции вы видите на рисунке 2.

Рис. 2. Подменю Spelling

В этом подменю три опции.

Это собственно Spelling... (Правописание, Орфография...), Hide Spelling Errors (Скрыть Ошибки Орфографии...) и Spelling Options... (Параметры Орфографии...).

Откроем первую опцию и взглянем, что она собою представляет в Publisher.

Дело в том, что практически все пользователи хорошо знакомы с проверкой правописания в Microsoft Word и даже свыклись с этой опцией, которая работает не только тогда, когда ее просят об этом, но и тогда, когда о ней забывают: она включена по умолчанию и анализирует текст на предмет поиска в нем дефектов с точки зрения грамматики и синтаксиса.

Что здесь?

Рис. 3. Диалог Проверки Орфографии

Как видите, здесь все точно так же. И диалог, по-моему, совсем тот же. Программа нисколько не затруднилась вычислить, что странное слово QuarkXPress надо рассматривать с точки зрения английского, а не русского языка, и потому с него и начала нас учить жить. Что ж, мы готовы пообщаться с Publisher и на эту тему.

Разберемся с диалогом. Not in dictionary: (Нет в словаре:) — это поле, в которое по порядку программа станет вбрасывать слово за словом, а мы должны станем отвечать на ее вопросы. Кнопок для ответов, как видите, много, но тут надо не ошибиться. Либо Ignore (Игнорировать), либо Ignore All (Игнорировать Все). Это важно: либо мы создаем литературный художественный текст, либо литературный научный — в зависимости от задач и можно, к примеру, проигнорировать пару раз «исчо» и оставить его вместо «ещё» на страницах публикации, либо исправить. Дело в том, что в художественном тексте так может разговаривать герой, и такое слово имеет право на существование. А в научном тексте пишет или уважаемый автор, или целый коллектив уважаемых авторов, — там это «исчо» (даже если автор именно так и написал) совершенно не к месту. Придется заменять его.

На что заменить слово? В строке Change to: (Заменить на:) программа предлагает замену для неправильного слова. В нашем случае она написала Quark Press. Что ж, возможно, мы согласимся на замену. Тогда что делать?

К нашим услугам кнопка Change (Заменить). А еще лучше — Change АН (Заменить Все). А может случиться так, что нам не нужно менять слова, что мы абсолютно правы, а программа или врет, или не знает. Тогда говорим Add (Добавить), и слово, которое только что было подчеркнуто, записывается в словарь программы и перестает вам надоедать своими красными волнистыми подчеркиваниями. В любом случае вы вольны наплевать на эту опцию и закрыть на ошибки глаза. Можно щелкнуть Close (Закрыть) и действительно закрыть программу проверки ошибок.

В диалоге осталось два поля, которые мы не освоили. Это поле Suggestions (Предложения) и строка, ждущая флажка: Check АН Stories (Проверить Весь Текст). В этой строчке вообще-то не грех бы поставить флажок, потому что береженого Бог бережет. А в поле Предложения мы найдем то, что программа предлагает в качестве рекомендуемого варианта. Там тоже вписано Quark Press. Программа вольна делать что хочет и как знает и умеет.

Идем дальше. Как только мы щелкнем в подменю на опции Hide Spelling Errors (Скрыть Ошибки Орфографии), тут же исчезнут все подчеркивания, но вместо опции Hide... появится опция Show Spelling Errors (Показать Ошибки Орфографии). Вообще строка и в том, и в другом смысле звучит двусмысленно: можно подумать, что программа за вас постарается и скроет все ошибки, самостоятельно их исправив. Нет, исправлять в каждом конкретном случае приходится самому.

Правда, в Word ХР уже возникла услуга — писать правильно вместо вас. Но она ни к чему хорошему не приводит. Писал я историческую книжку, где упоминал про асов и ванов — это два древних народа, воевавших между собой. Кстати, именно от них мы с вами и происходим. Но вопрос не в этом. Word, не знакомый с работами Тура Хейердала (который сейчас, к сожалению, находится в ужасно больном состоянии, да и возраст сказывается — 79 лет) и Владимира Щербакова, преспокойно заменил асов и ариев на фамилии Асов и Ариев, а из ванов кругом сделал ванны. При этом программа была искренне рада, что сумела мне, неразумному и безграмотному, так здорово помочь. Приложения, господа, еще очень далеки от совершенства, мы находимся в самом начале пути. Ну, да ладно. Мы отвлеклись.

Итак, вторую опцию тоже прошли. Взглянем на третью. Это Spellings Options... (Параметры Орфографии...).

Рис. 4. Опция Параметры Орфографии

Здесь собрались строки с флажками: Check spelling as you type (Проверять орфографию по вашим настройкам), Flag repeated words (Повторно демонстрировать слова), Ignore words in UPPERCASE (Игнорировать слова из прописных букв), Ignore words with numbers (Игнорировать слова с цифрами), Ignore Internet and file addresses (Игнорировать интернетовские адреса и адреса файлов); и строка, в которой не проставлен флажок — Suggest from main dictionary only (Предлагать только из основного словаря). На мой взгляд, по умолчанию эта последняя опция не задействована только по той причине, что бывают и вспомогательные словари, и специфические научные или жаргонные словари, которые могут использоваться в работе. Не всякое лыко в строку, но и без лыка строк не бывает. Сколько пользователей, столько и задач.

Переходим на вторую опцию меню Tools — это Language (Язык). Я не стану показывать подменю этой опции, просто перечислю, что там есть. А есть там — Set Language... (Определить Язык...), Thesaurus... (так Тезаурус... и будет) и Hyphenation... (Переносы...).

Откроем Определение Языка:

Рис. 5. Диалог Определения Языка

Как видите, здесь, как и во многих приложениях, по умолчанию, конечно же, установлен английский язык. Это обидно: самый благодарный пользователь приложений, особенно Корпорации Майкрософт, русский пользователь. Вернее, даже не русский, а бывший советский. Потому что, насколько я знаю, в бывших республиках бывшего СССР также интенсивно идет компьютеризация, а менталитет у пользователя — все тот же, бывший наш.

Ну, я отвлекся. Выбираем язык.

Рис. 6. Выбрали язык — Русский (Россия)

Я недаром написал Русский (Россия): рядом, вы видите, есть Русский (Молдавия). Я уже рассуждал на эту тему. Выходит, зря я рассуждал насчет менталитета. Всего за 10-12 лет родился язык, которого не существовало на планете: молдаване родили свой русский язык! Честь и хвала столь талантливому народу.

Ну, выбрали язык и говорим ОК. Теперь проверка орфографии пойдет у нас с русским словарем. Не перепутать бы: не с молдавским русским, а с русским русским!

Идем дальше. Тезаурус. Я редко пользуюсь этой опцией. Практически никогда не пользуюсь. Но возможно, есть любители подыскать какой-нибудь синоним с помощью этой опции. Откроем ее. Но прежде выделим какое-то слово. К примеру, слово «способ».

Рис. 7. Диалог Тезауруса

Я не стану комментировать ничего. Здесь и так все понятно. Программа постаралась и выискала в анналах множество синонимов для нашего «способа». Скажем Replace...

Рис. 8. Заменилось слово на слово

Посмотрим, что там в смысле переносов. Откроем диалог Hyphenation. (Переносы...).

Рис. 9. Диалог Hyphenation

Как видим, здесь определено не два или три знака от слова, которые должны остаться на прежней строчке или перекочевать на новую строку, как это устроено в QuarkXPress, а назначена область переноса, как это проделано в Word. Область переноса в Publisher по умолчанию — 0,639 см. Ставим флажок в верхнем окошке для флажка против строки Automatically hyphenate this story (Автоматическая расстановка переносов в материале). Жаль, что нет строки «Максимальное число переносов подряд», которая есть в Microsoft Word. Некрасиво, если все строчки в книге состоят из переносов. Жаль, что такой опции нет в Publisher: где ж ей быть, как не в верстальной программе?

Ну, да ладно. Обратим внимание на кнопку Manual... (Ручной..., в Word это называется Принудительный...). А, теперь понятно (учитывая то, как это называется в Word), что такое мануальная терапия...

Итак, выделим какое-нибудь слово поближе к границе текста и щелкнем кнопкой Manual...:

Рис. 10. Вручную можно перенести выделенное слово

Надо поставить курсор куда необходимо и сказать Yes. Но мы этого делать не будем. Мы же еще не назначили сам автоматический перенос. Отменяем принудительный и возвращаемся к автоматическому.

Назначаем флажок в окошке Автоматического переноса. И говорим ОК.

Рис. 11. Назначаем Автоматический перенос

Рис. 12. Вот и перенос!

Правильно я не стал переносить выделенное слово: видите, оно теперь далеко от границы текста. Кстати сказать, ручные переносы очень редкое явление. Об этом мы уже немного поговорили перед тем, как рассматривать меню Format.

Ну, идем дальше.

Вот любопытная опция, с которой я сталкиваюсь, наверное, впервые. Называется она Контролер Дизайна... (Design Checker...). Он вызывает простенький диалог, в котором определяет свои полномочия:

Рис. 13. Это Мастер Дизайна Страниц

В верхней строке — вопрос: Check which pages? (Какие страницы контролировать?). Следующие строки — ответ на этот вопрос: АН (Все) или Pages: ... from: ...— to: ... Вместо многоточий — номера страниц. Также стоит флажок в строке Check master page(s) Мастер контроля страниц(ы).

Рис. 14. Диалог Options

Из перечисленных опций, которыми владеет Мастер контроля, две не имеют флажков по умолчанию. Напротив остальных стоят эти самые флажки. Главная «флажковая» опция: Check selected features (Контролировать выбранные характеристики). Альтернативна ей другая: Check all problems (Контролировать все проблемы). Это две основные опции, остальные же собраны в отдельное поле. Вот их перечисление: Text in overflow area (Текст за границей блока), Disproportional pictures (Диспропорциональные рисунки), Empty frames (Пустые фреймы), Covered objects (Скрытые объекты), Objects partially off page (Объекты как часть страницы), Objects in nonprinting region (Объекты в непечатаемой области), Blank space at top of page (Пространство листа сверху страницы), Spacing between sentences (Интервал меяеду предложениями). Это все опции с флажками. И напротив одной опции предлагается или предполагается поставить флажок: Page unreachable by hyperlinks (Страница, не переданная в гиперсвязь).

Не знаю, точно ли я все перевел (хотя бы по дословности). Просто изматывает эта английская версия! Она отнимает время и силы. Вместо того чтоб вовсю трудиться в верстке, нет-нет да и забудешь что-нибудь — и лезешь в словарь. Просто не книга, а автор-переводчик какой-то.

Идем дальше. Говорим ОК, и вот появляется Мастер и работает. Вот его сообщение:

Рис. 15. Мастер поработал и сообщает...

Вот он нашел проблему: Problem: This frame is empty (У вас найден пустой фрейм). И сообщает дальше: Suggestions: Delete the empty frame. For more information click Explain. (Предложения: Удалить пустой фрейм. Для дополнительной информации кликните Explain.). Мастер говорит про кнопку, которая находится в диалоге ниже всех.

Ну, попробуем и эту кнопку щелкнуть.

Рис. 16. А вот и дополнительная информация

Дополнительная информация — это, оказывается, Справка Microsoft Publisher.

Не станем в нее вдаваться, потому что теоретически и так ясно, о чем идет речь.

Теперь по самой информации от Мастера Контроля. Он предлагает удалить пустой фрейм. Логично.

Но в рабочей верстке такого быть не может. У меня специально в файле публикации все не так, как надо, чтоб работали и отвечали за свои функции некоторые опции. Может быть, в том числе и эта.

Судя по последнему диалогу, мы можем щелкнуть кнопки Ignore или Continue. Вторую не тронем, а первую можем щелкнуть. И как только щелкнули, получаем другое сообщение Мастера:

Рис. 17. Контролер Дизайна нашел еще одну проблему: некоторый текст вышел за край

В новую проблему вдаваться не станем, щелкнем Close.

Но становится ясным: такого Мастера в верстальных программах еще не бывало.

Следующая опция — Mail Merge (Почтовая Связь).

Взглянем на это подменю и пойдем дальше, потому что, как я уже сказал, все, что касается «мирового паука», здесь мы рассматривать не станем, ибо в ограниченном объеме книги нам дай Бог справиться с издательско-верстальной тематикой.

Согласен, что интернетовские публикации играют немаловажную роль, и что Publisher на это очень рассчитанная программа, но...

Рис. 18. Подменю Mail Merge Следующая опция — Add-Ins... (Добавить-Включить...).

Рис. 19. Диалог Включить в имеющееся

Кажется, и этот диалог нам не нужен и относится к интернетовским сайтам. Вернемся к пропущенному подменю Macro (Макросы).

Рис. 20. Подменю Macro

Речь идет о макросах, знакомых многим уже давно и часто эффективным для выполнения разного рода задач. Макрос — последовательный сценарий функциональных действий в программе, записанный один раз, но использовать его можно множество раз для исполнения сходных или тех же самых действий. Можно, к примеру (очень упрощаю), нарисовать квадрат, залить его красным цветом и переместить в правый верхний угол страницы. Записав эти три действия в отдельный сценарий (макрос) и «проиграв» его для нового, чистого документа, получим тот же самый квадрат и в том же месте страницы. Это объяснение примитивное, но примерно соответствует действительности.

Итак, Макрос обязательно сначала записывается, а потом «проигрывается». Мы не станем ничего записывать, по взглянем, как это делается.

Вызываем опцию Macros... (Макрос...).

Рис. 21. Диалог Macros

Фактически мы имеем в лице этого диалога «чистый лист», в который, во-первых, вы это видите на рисунке, вписываем имя Макроса («Вася»). И говорим Create (Создать).

И программа вызывает... Утилиту Microsoft Visual Basic, в которой и собирается записывать Макрос.

Рис. 22. Утилита Microsoft Visual Basic

Насколько я понимаю, Макрос будет записываться не по нашим действиям, а по нашим тэгам — командам, набор которых станет этим самым Макросом. Причем Макрос будет писаться, скорее всего, нами же вручную.

То есть все преимущества Макроса как инструмента, весьма полезные в Word или CorelDRAW, здесь как-то уходят в тень. Программа, выходит, ничего на нами, повторять не собирается, а предоставляет возможность записать тэгами любую комбинацию действий, которую потом сама готова выполнить, возможно и безоговорочно.

Весь фокус тэгов состоит в том, что вы, прежде чем подать ваш материал в программу, кодируете его.

Кодируете в тэгах, придавая, к примеру, абзацу тот вид, какой хотите видеть в результате верстки.

Когда такая работа над текстом будет совершена, вы сможете подать текст вместе с тэгами в Publisher, и он в соответствии с этой кодировкой самостоятельно отверстает его. Может показаться, что тэги — то же самое, что макросы, но на самом деле они гораздо более консервативнее макросов и сценариев: ведь макрос записывает сама программа на основе вашей ручной работы с объектом — будь то текст или картинка, а здесь вы все выполняете вручную, с клавиатуры, да еще и становитесь при этом как бы программистом, то есть возвращаетесь в приснопамятное время ДОСа.

Все коды записываются на языке HTML (именно на языке, а не в расширении, что не одно и то же!). Бесконечные строчки этих записей, может быть, кого-то и обрадуют, но не простого верстальщика, желающего творческой работы в избранной программе.

На рисунке в окне записи Макроса вы видите, что программа записала лишь начало его и предусмотрительно поставила два слова в конце (End Sub), которым для ПК завершается набор команд.

Честно говоря, лучше уж открыть новую публикацию и быстренько проделать в ней при помощи традиционных команд Publisher и присущих ей инструментов все то, что требуется. Не бывает сложностей настолько сложных, чтобы привлекать к исполнению работы командную строку. Думаю, все это устроено лишь на любителя или экспериментатора, не нашедшего какой либо услуги в программе.

Пойдем дальше.

Следующей опцией мы видим Security... (Безопасность...).

Откроем ее.

Рис. 23. Диалог Security

Понятно. Это также относится к Макросу, как все подменю целиком. Но раз мы не собираемся заниматься макросами, как таковыми, пропускаем и эту опцию. Можно, конечно, полюбопытствовать, что такое Visual Basic Editor (третья строка, вызывающая утилиту)...

Рис. 24. Вызвали утилиту Visual Basic Editor

Это, оказывается, все то же самое, что мы уже проигнорировали. И даже окно совершенно то же. Разницу вы можете уловить лишь в правой нижней части, на панели задач: время на прошлом изображении и на этом — разное.

Оставляем подменю Macro неудовлетворенными. Таких подарков простому, рядовому пользователю не нужно.

Следующая опция — Customize... (Настройка...). Вы вспомнили этот диалог с тремя вкладками, который мы рассматривали в разговоре о Панелях управления?! Именно он и появился после вызова опции, вы видите его на рисунке 25.

Рис. 25. Диалог Customize

Идем дальше, поскольку мы об этом диалоге Настройки все существенное сказали.

Теперь строка Options... (Параметры...). Этот диалог с многими вкладками изображен на рисунке 26. Его-то и станем сейчас рассматривать.

Рис. 26. Диалог Параметры

Фактически в этом диалоге собраны все существенные параметры программы. Они, как правило, заданы по умолчанию. Многие из них желательно не менять, потому что разрабатывали их все же истинные специалисты своего дела, согласуй все настройки параметров с пользовательскими интересами.

По умолчанию диалог открывается на вкладке General (Главные, Общие). Взглянем на опции (подопции) этой вкладки. В самой верхней строке мы видим назначение по умолчанию Единиц измерения: Measurement units: Sentimeters (Сантиметры). Ниже этого назначения вы видите две строчки с окнами для флажков, и в нижнем этот флажок проставлен. Вот эти строки: верхняя Show basic colors in color palette (Показывать базовые цвета в цветовой палитре) и вторая Use New Publication task pane at startup (Использовать для создания Новой Публикации Панораму задач). Помните эту Панораму задач если затрудняетесь вспомнить, я напомню: это Окно номер 1 программы Publisher. Здесь записано, что всегда при открытии новой публикации на экране в первую очередь будет появляться Окне номер 1, и вы станете выбирать лицо вашей публикации из возможного готового. Если нет, то самостоятельно закроете это окошко и начнете с чистого листа. Впрочем, вы можете и снять флажок против этой строки. Тогда каждую новую публикацию будете начинать с нуля. Я наверняка так и сделаю, потому что в Галерее Publisher всегда успею вернуться. Ее недолго вызвать из окна программы.

Смотрим дальше. Ниже находится поле File locations (Размещения файлов). В окне поля списка файлов вы видите и типы файлов, и их размещение (пути). Впрочем, пути неполные. Windows XP настолько усложнила проникновение к конкретной папке, что путь теряется за длинными названиями самых первых директорий. Тем более что по-русски они чаще всего называются длиннее, чем по-английски. В этом смысле хотелось бы посетовать на большую непродуманность этого вопроса в смысле удобства для пользователя.

Но движемся далее по вкладке General. В том же поле существует кнопка Modify... (Изменить...). Вызовем эту кнопку.

Рис. 27. Диалог Изменения Размещения

Это дежурный виндоусовский диалог, в котором мы сможем переадресовать файлы куда нам вздумается.

Ниже рассмотренного поля во вкладке General находится кнопка Web Options..., которую благополучно пропускаем.

На этом вкладка закончилась. Переходим на другую — Edit (Редактирование, Правка).

Рис. 28. Вкладка Edit

В самом верху вкладки — поле Text editing (Редактирование Текста). В этом поле собраны строки: Drag-and-Drop text editing (Перетаскивать и Вставлять текст для правки), When selecting, automatically select entire word (При выделении автоматически выбирать все слова), When formatting, automatically format entire word (При форматировании автоматически форматировать все слова), без флажка — Prompt to update styles (Быстрое добавление стилей), Use font linking (Пользоваться связыванием шрифтов) и без флажка — Auto-Keyboard switching (Автовключение Клавиатуры).

Ниже — строка Show Paste Options buttons (Показывать Вставку Опций значками). Напротив нее стоит флажок.

Ниже мы видим поле Переносов (Hyphenation). В нем те же назначения, что мы знаем. Впрочем, вместо 0,639 почему-то указано 0,64 см... Переживем. Еще в поле стоит флажок перед опцией Автоматическая установка переносов в новых текстовых блоках.

Ниже располагается всего одна строчка, касающаяся стрелок: Arrow keys nudge objects by: (Клавиши-стрелки сдвигают объекты на:). В окошке указана величина шага сдвига — 0,32 см. Поставив флажок против этой опции, вы сможете изменить величину шага, но лишь в пределах от 0,003 до 5,08 см — так устроены незыблемые настройки программы.

С этой вкладкой тоже разобрались. Идем на следующую.

Это — вкладка User Assistance (Помощник Пользователя).

Рис. 29. Вкладка Помощник Пользователя

Первое, что бросается в глаза при взгляде на вкладку, это окошко с перечнем (наглядным, со значками) типов курсора, используемых в программе. Их немного, из шести видов четыре существуют в одной опции — Растянуть (Resize).

Курсор вида Move (Внести) появляется, пожалуй, чаще всего. А последним изображен курсор Crop (Обрезать).

Так что прошу прощения, я оказался неправ, когда говорил об отсутствии в программе Publisher возможности ручной обрезки объектов. И даже скажу теперь, где он находится, в числе инструментов Панели Настройка Изображения. На некоторых рисунках у меня эта Панель присутствует. Зарапортовался...

Все виды курсоров относятся к строке Use helpful mouse pointers (Использовать виды курсоров мышки).

Но давайте рассмотрим опции по порядку, сверху.

Первая строка — Use Quick Publication Wizard for blank publications (Использовать Мастера Быстрых Публикаций для создания публикации с пустого листа).

Дальше идет кнопка со значком. И рядом с нею — строка: Click to reset wizard synchronizing (Щелкните для восстановления синхронизации). Не преминем щелкнуть!

...Ну, щелкнули, и ничего не произошло.

Видимо, программа ограничивается внутренними настройками и лишь сама любуется этими процессами.

Следующая строка — Update personal information when saving (Прибавлять индивидуальную информацию при сохранении). Как видите, флажка здесь нет, вы вольны проставить его.

Дальше — строка Show tippages (Показывать подсказки).

Следующая — Show Screen Tips on objects (Показывать скрытые данные об объектах). И последняя строка — уже знакомая нам строка с видами курсора мышки.

Кроме перечисленного существует кнопка Reset Tips (Восстановить Данные).

Ну, для равновесия щелкнем и на ней...

Опять не повезло. Программа после щелчка что-то подумала про себя и успокоилась. Как была невозмутима, точно индеец, так и осталась.

Следующая вкладка — Print (Печать).

Рис. 30. Вкладка Print

С этой вкладкой нам тоже не очень-то повезло: у меня установлен только один принтер Linotronic (для скрытой печати в файл), и потому никаких опций печати мы здесь не увидим. Взглянули на вкладку — и пойдем дальше.

Рис. 31. Вкладка Save

Последняя вкладка — Save (Сохранение). Здесь всего две опции — Allow background saves (Допускать фоновое сохранение) и Save AutoRecover info every: 10 min (Автосохранение камедые 10 минут).

Вот мы и закончили рассматривать опцию Options.... Перейдем к другой.

Опция Tools on the Web... вызывает утилиту Microsoft Office Tools, но у меня она просто не вызывается из-за того, что нет связи с Интернетом. Даже на интерфейс этого чуда программистской мысли мы взглянуть сейчас никак не сможем. Идем далее.

У нас осталась одна опция Commercial Printing Tools (Коммерческие Печатные Средства). Она содержит свои подменю:

Рис. 32. Меню Commercial Printing Tools и его подменю

Верхней строкой подменю идет Color Printing (Цветная печать...).

Рис. 33. Меню Color Printing

Здесь в верхнем поле, которое называется Print all colors as: (Печатать все цвета как:), перечислены все способы представления цветов и цветовые системы, которые используются программой Publisher.

По умолчанию указана система RGB. Это и понятно: мы работали на мониторе и все цвета выбирали по тому, как они представлены нашим дисплеем. Строка с цветами RGB озаглавлена. Composite RGB (Составные цвета RGB). Эти цвета не представлены на просмотр хотя бы по той причине, что они действительно составные и должны показываться как сумма трех цветов в различных пропорциях. Тем более что никакого конкретного цвета мы не выбрали.

Вторая строчка представления — Process colors (CMYK) — Цвета печати (CMYK). Это действительно цвета обработанные, типографские, потому что система CMYK рассчитана для печати. Здесь цвета выбираются не только из трех возможных, но и к каждому (теоретически, да и практически) добавляется некоторая доля черного цвета.

Следующая опция — Spot color(s) — Плашечные цвета. Это цвета в одну краску, которые широко применяются в верстальных программах, потому что распространены в полиграфии.

О плашечных цветах в верстальных программах (и в полиграфии) мы немного говорили в главе о цветовых системах.

Следующая строчка — Single color publication (Одноцветная публикация). И последняя из этого поля — Process color (CMYK) plus Spot color(s) — Составные цвета CMYK и Плашечные цвета.

В среднем окне просмотра рядом с кнопками добавления, удаления или изменения цветов появляются выбранные плашечные цвета. В нижнем окне показан Color to be used in publication (Цвет для использования в публикации).

На этом диалог исчерпан. Переходим на другую опцию подменю.

Это Trapping (Треппинг) с подменю, где две опции — Preferences... (Предпочтения...) и Per Object Trapping... (Треппинг для объектов...).

Пока отвлечемся на то, чтобы немного поговорить о том, что такое Треппинг.

В целом, да и по смыслу, это понятие обозначает сведение гнетов. В цветной печати треппинг существует для улучшенной печати цветных элементов и подбирается в программах верстки.

Речь идет, собственно, о некачественном наложении красок одна на другую. Печать в четырех цветах (CMYK, полноцветная печать) предполагает идеально точную прогонку одного и того же листа через четыре стадии печати — сначала одним цветом, потом другим, третьим...

В итоге треппинг, сведение цветов получается безобразным. Часто вы видите некачественную цветную печать, и виновата в ней, при всех других, возможно, идеальных параметрах, неправильная система сведения цветов, то есть треппинг. Из-за неправильного и неточного сведения цветов по краям рисунка вы наблюдаете нечто вроде дополнительного контура, часто радужного.

Ошибки наложения красок можно частично и даже в достаточно большой степени компенсировать в опции Треппинг. На бумагу, точность ее движения в станке влияют не только установки, точность которых, допустим, высокая. При печати станок все равно каким-то образом смещает бумагу из-за вибрации, влажности воздуха в помещении цеха, температуры... Несмотря на то, что вы собираетесь печатать журнал или книгу на станке высокого качества, вы не застрахованы от ошибок при наложении красок. Любой способ — штамповка, литография, шелкография, офсетная печать — может подвести вас в сведении цветов.

Большие цветные изображения меньше подвержены ошибкам, чем мелкие, где требования качества фактически те же (к примеру, плакат и листовка с одинаковым рисунком: плакат на том же станке выйдет гораздо качественней).

Проверку сведения цветов осуществляют цветоделением.

То есть практически всегда необходимы пробы, прежде чем документ пойдет в тираж.

Принцип Треппинга незыблем: для более точного наложения цветов применяется небольшое растяжение светлых объектов.

От самого светлого объекта оператор движется к менее светлому и так до самого темного.

Таким образом на границе между светлым и темным объектом должна фактически появиться лишняя светлая полоса, которая при наложении цветов скрадывается более темным цветом. Это так называемый простой Треппинг, или Треппинг с растяжением.

В первом случае растяжение совсем небольшое, во втором существенное. Однако при печати по результату трудно выяснить, какой из двух методов треппинга применялся. Если, конечно, печать получается качественной.

Применяется и такой метод (это касается достаточно правильных объектов, особенно если они расположены на разных слоях): часть более темного объекта, лежащего внизу, обрезается по размеру верхнего, более светлого, причем верхний объект слегка растягивается. Этот метод называется вытеснением.

Есть еще Треппинг с наложением. Это когда краски нижнего и верхнего объектов смешиваются.

Правда, при этом получается третья краска, которая часто нежелательна и вносит в изображение мешающий эффект.

Впрочем, иногда это же самое обстоятельство может привести к оригинальным и непредсказуемым результатам, от чего качество не только не страдает, но и выигрывает.

Но обратимся к первой опции подменю Треппинга — Preferences... (Предпочтения...).

Рис. 34. Диалог Preferences (для Треппинга)

306 В верхнем поле по имени Trapping settings (Установки треппинга) мы видим, что по умолчанию Автоматический треппинг (Automatic trapping) не включен. Поставим флажок против этой опции и посмотрим, что изменилось. Но прежде, чем это сделать, взглянем на сам диалог без этой установки. Ниже «молчит» поле Spot color options (Параметры плашечных цветов). По умолчанию активно лишь нижнее поле — Black overprinting (Черная печать с наложением), то есть только здесь установлены параметры по умолчанию. Мы видим, что в окошке Text below: (Текст ниже:) программа говорит, что старается сохранять форму для шрифта теста ниже 24 pt. Как правило, фактически эта величина не ниже 10 pt. Дальше — уже никакая программа не справляется с искажением, если идет наложение цветов. В окошке Overprint threshold: (Порог наложения:) вы видите число 95. Это не пункты, это проценты. Наложение допустимо по уровень объекта до 95 процентов от линейной его длины. Или толщины, если это касается линии или шрифта.

Еще вы видите, что по умолчанию в поле имеются назначения только для Линий (Line) и Imported pictures (Импортированных рисунков). Для Заливок (Fill) треппинг не предусматривается или назначается в более «вольных» вариантах.

Но включим верхнее поле:

Рис. 35. Включили Автоматический треппинг

Вы видите, стали активными также заложенные по умолчанию, но до поры не действующие параметры — Ширина треппинга (Width) 0,25 pt и Неопределенный (Indeterminate) 0,25 pt. Понятие Неопределенный родилось из ситуации, когда трудно определить истинный цвет объекта, окрашенного в составные цвета, да еще и яркость каждого примерно одинакова.

Рядом активизировалась кнопка Thresholds... (Пороги...) — откроем ее.

Рис. 36. Открыли кнопку Thresholds

Нам открылись все пороги треппинга, заложенные в программе на тот случай, если активизирована опция Автоматического треппинга.

Внимательно прочтите о каждом, и если что-то не устроит вас в том или другом, вы можете поменять значения порогов. Впрочем, не думаю, что это нужно делать.

Обратимся к опции, которая лежит ниже всех в поле Automatic trapping. Это опция Only allow spread traps on text glyphs (Допускается только треппинг с растяжением для текстов). Введя флажок в ее окошко, вы ограничите Автоматический треппинг.

Идем далее.

Откроем опцию Per Object Trapping... (Треппинг Объектов...).

Рис. 37. Диалог Per Object Trapping

Вы видите: активна здесь одна только строка Contents to background: (Содержимое фона:). В окне вписано, что избран тип содержимого По Умолчанию (Default).

Откроем этот список и вдруг увидим, что там собраны несколько типов треппинга — Overprint (С наложением), Knockout (С вытеснением) и Custom (Специальный). Выберем последний и взглянем, что получится.

Рис. 38. Назначили треппинг Специальный

Вы видите результат. Все бы ничего, да никак не могу перевести слово Choke. Все у меня получается то Удушье, то (техн.) Дроссель.

Поневоле пожалеешь, что когда-то пошел — сам ведь, дурак! — на немецкий... А надо было предвосхитить события и в 1965 году выбрать американский жаргон.

Откроем еще кнопку Details... (Подробно...) — она как раз активна:

Рис. 39. Открыли кнопку Details

Если у вас будет желание, вы сможете не торопясь прочесть, что вам такое сообщает программа «Подробно...» и о чем. Я же иду дальше.

Ниже опции Trapping в подменю существует опция Graphics Manager... (Менеджер Графики...). Откроем его «лицо»:

Рис. 40. Менеджер Графики и диалог Create Link

Этот Менеджер, насколько я понимаю, умеет манипулировать графическими объектами и их характеристиками. Открыв его диалог, который показался мне скудным и непонятным, я тут же щелкнул единственной активной функциональной кнопкой Create Link (Создать Связь). И сдвинул этот появившийся диалог вниз, чтоб вы увидели сразу два. Так они и появились на рисунке 40.

Взглянем на содержание того, что предлагает нам диалог Создать Связь.

В строк возле «пуговицы», где стоит точка-флажок, написано: Browse to locate the original file and link to it (Найти размещение оригинала файла и связать с ним).

Заодно прочтем и вторую запись, против которой нет флажка: Create a file from the full-resolution graphic stored in the publication and link to that (Создать файл для полной резолюции графического содержания в этой публикации и связать с ним).

А сам диалог Create Link спрашивает нас, хотим ли мы создать новую связь или восстановить старую. Эти два варианта есть ответы диалога, которые мы должны выбрать. Если это нам, конечно, важно. Вернемся к Менеджеру и посмотрим, что у него есть.

А в его поле записан файл нашего автомобиля, который мы. точно в гараж, вогнали на Мастер-страницу. Показано, где он размещен, как называется и так далее.

Насколько я понимаю, когда в нашем документе будет около трехсот рисунков, как ко времени той страницы книги, которую вы читаете, Менеджер нам покажет полный список этих рисунков. И укажет, какой из них на которой странице найти. Уже неплохо.

Идем дальше. Из подменю у нас осталась только опция Fonts... (Шрифты...). Вот диалог — на рисунке 41.

Рис. 41. Диалог Fonts

Здесь, мы видим, нам предлагается полный список использованных по разным поводам в этой публикации шрифтов (их немного) и рекомендуется встроить их в наш файл. Это удобно тем, что в Сервисном бюро или в Типографии, куда попадет публикация, не возникнет вопросов, поскольку все шрифты, которых там вдруг может не оказаться, вы принесете вместе с файлом. Услуга великолепная. Правда, программы-приложения так делают давно, но вот разглядеть полный список использованных шрифтов, кажется, больше ни одна программа, кроме CorelDRAW, не дает. Еще одно удобство Publisher.

Ну, вот и все про меню Tools. Нас ждет следующее меню.


Глава 1

Командное меню «Таблица»

Я уже говорил о том, что верстальным программам очень не хватает опции-команды Вставка Таблицы.

Это не просто команда, это отдельный мир задач, которые решаются на стыке текстовых и графических задач. Таблица, как и диаграмма, некая смесь текстово-графических параметров, слитых воедино. Это очень необходимая функция, поскольку издатели издают не столько художественную литературу, сколько специальную, где фигурируют и статистика, и математические выкладки, и сравнительные графики, и таблицы.

Из-за своей специфика параметры таблицы могут собраться даже в отдельную утилиту, как это сделала фирма Adobe. Неискушенный пользователь, особенно самоучка, может не иметь представления о том, что кроме верстальной программы PageMaker существует утилита Adobe Table, в которой можно строить таблицу и потом экспортировать ее в PageMaker. Таблицы из других приложений, например Word, при вставке в верстальную программу начинают капризничать, терять форматирование или графику. Например, из Word в PageMaker может прийти таблица без вертикальных или горизонтальных линий... Конечно, верстальщик постарается их восстановить, то есть дорисовать уже в PageMaker с помощью инструмента Линия, но это не выход. Особенные трудности представлял кроссворд — его картинка, где множество линий и черных заливок. Таблица сканворда тоже страдала, потому что PageMaker то хочет, то не хочет вставлять стрелки (а они в сканворде, как помните, еще и сложные).

Многие задачи решились утилитой Adobe Table, но тем не менее пользователю несомненно удобнее иметь инструмент построения таблиц под рукой, в качестве отдельных опций самой программы, а не подгружать какие-то утилиты, которые частенько приходится еще и доставать незнамо где.

В Publisher проблема с введением в текст таблицы решается просто: для Таблицы, как в Microsoft Word, отведено отдельное меню. Именно его-то мы сейчас и рассмотрим. Такое решение Корпорацией Майкрософт готовилось давно и подспудно. Пригодились старые наработки (приложения Office). Авторы шли по проторенному пути и лишь только вырубали просеку пошире. В результате появилось достойное решение, за которое не стыдно.

Итак, меню Table (Таблица).

Рис. 1. Командное меню Table

Вы видите, что большинство опций этого меню не желают быть активными Только три верхние опции еще более-менее живы, остальные пребывают в летаргическом сне. Почему?

Да потому что большинство опций этого меню будут готовы к нашим услугах лишь после того, как мы вставим саму Таблицу. Решение с Таблицей принимаете; на самом первом этапе, в момент ее вставки. Это очень похоже на то, как в верстальных программах рождается новый документ: публикация должна получить почти все свои настройки «на берегу».

На рисунке 296 открыто подменю Insert (Вставить) — не путать с одноименным командным меню, которое нами рассмотрено и служит иным целям. В подменю активна всего лишь первая строка по имени Table (Таблицу). Вот ее-то и щелкнем мышкой.

Рис. 2. Диалог Вставки Таблицы

Получили вроде бы стандартный диалог Вставки Таблицы, но те, кто знает вордовскую Таблицу, конечно, обратят внимание, что диалог здесь далеко не вордовский! Тот простенький, он запрашивает у вас, сколько в вашей таблице столбцов и строк, и больше ничего. Да вот он, для примера:

Рис. 3. Диалог Вставки Таблицы в Microsoft Word

Как видите, никаких громадных полей списков здесь не предвидится. Тем более полей просмотра. Диалог Publisher, таким образом, вполне оригинален.

Заодно, если вы внимательно посмотрите на рисунок 3, вы обнаружите, как именно пишется эта книга: она набирается в программе Word и только потом будет верстаться. Возможно, в приложении Publisher.

Но обратимся к диалоговому окну Вставка Таблицы (здесь это называется Create Table — Создать Таблицу). Сравним два диалога: в Word предлагается по умолчанию создать таблицу из двух строк и пяти столбцов, здесь же по умолчанию добавили один столбец — 6 столбцов (колонок) и 2 строки (ряда).

Мне бы хотелось показать, как в программе Publisher создать Картинку кроссворда. Заодно это будет, думаю, полезно и для тех, кто бы желал такими композициями заняться. Текста вам не обещаю, но таблицу построить можно. Ибо кроссворд лучше всего получается из Таблицы.

Потому назначаем... к примеру, 9 столбцов и 9 строк. Почему не 8? Или не 10? Потому что кроссворд традиционно симметричен, значит, у него должны быть лишний (центральный, осевой) столбец и лишняя (осевая, центральная) строка.

Заглянем в поле Table format: (Формат Таблицы:) — на что он нам?

Оказывается, вот на что. По умолчанию мы попали в строку None (Нет), а вообще-то там, в списке форматов, собраны, как и в Галерее Дизайнов, многие разработки авторов программы — едва ли не на любой вкус и случай. Взглянем для примера на парочку — виды меняются в окошке Sample (Образец). Вот, например, такой формат-дизайн:

Рис. 4. Формат Таблицы по имени Checkbook Register

Или такой:

Рис. 5. Формат зовется Numbers 3

Мы не станем пользоваться этими наработками, хотя, конечно, примем во внимание, что они есть: в случае чего — почему бы не воспользоваться? Сэкономите время.

Итак, делаем наши назначения: 9 и 9.

Говорим ОК...

Рис. 6. Таблица уже в публикации!

Как видите, она не вставилась в текстовый блок, который я предварительно выделил. Она вставилась в самую середину разворота. Значит, таблица в Publisher воспринимается программой как объект,

Взглянем на Таблицу и решим, что она для нас не очень-то подходит. Почему? Ее прямоугольные ячейки никак не годятся для того, чтоб считать их клетками кроссворда. Надо что-то сделать.

Ширина Таблицы избрана не нами: программа создала ее по умолчанию по ширине формата того листа, который заложен как формат страницы публикации. Высота ячейки определяется текстовыми настройками. По умолчанию высота строки соответствует высоте шрифта Times New Roman величиной 10 pt. He забудьте, что сюда же прибавляется интерлиньяж — сверху и снизу, то есть от границ ячейки строка отделена соответствующими стандартными интервалами. Если помните, это 1 sp (одна шпация). Так что с высотой ячеек давайте исходить из этого.

Что сделаем?

Если нас устраивает ширина таблицы (равная ширине формата страницы), значит, надо увеличивать высоту ячейки. Это можно сделать известным по Word способом. Увеличить, к примеру, кегль шрифта. Или сделать высоту ячейки в две строки. И то, и другое подходит. Выберем второе. И первое в придачу, потому что экспериментально я знаю, что две строки кегля 10 маловато (ячейка так и останется прямоугольной), а три строки — многовато (она будет вытянутой вверх), на нужен четкий квадрат.

Рис. 7. Назначим кегль 14

Пока не станем видоизменять Таблицу, эта задача у нас впереди. Взглянем на то, как изменилось меню, потому что мы ведь уже ввели в публикацию новый элемент — Таблицу.

Рис. 8. Многие опции стали активными

Если выделить Таблицу, как на рисунке 7, то активными сделаются почти все опции меню и подменю. Взглянем, что нам предлагает подменю Insert, из которого мы вставляли Таблицу.

Активны все четыре строки — Columns to the Left (Колонки Слева), Columns to the Right (Колонки Справа), Rows Above (Ряд Выше) и Rows Below (Ряд Ниже). Суть этих команд станет нам совершенно ясна, если к имени команды впереди подставить слово Insert (Вставить). То есть мы сможем вставить один ряд (строку) до и после той, в которой находится курсор, или столбец левее или правее того, в котором курсор.

Идем дальше. В меню есть ценная команда Delete со своим подменю: там собрались опции (не тану показывать отдельным рисунком) — Table (Таблицу), Colomns (Колонки) и Rows (Ряды). Читать эти команды надо так же: Удалить — то, другое или третье.

Если курсор стоит в ячейке, то удаляется либо этот ряд, либо эта колонка, в зависимости от того, какую строку вы выбрали. Теперь задумаемся: а почему строки содержат эти имена во множественном числе?.. Очень просто. Если вы выберите два ряда или две колонки, то столько и будет удалено. Единственное число — лишь вариант множественного. Лишь сама Таблица удаляется в единственном числе — вся целиком, что и отражено в строке команды.

Идем дальше. Подменю Select (Выбрать, Выделить).

Рис. 9. Подменю Select

Здесь собрались четыре опции — Table (Таблицу), Column (Колонку), Row (Ряд) и Cell (Ячейку). Объяснять и вовсе нечего. Выделить — то, другое, третье или четвертое. Нам очень пригодится именно это подменю.

Идем далее. Опция Merge Cells (Слить Ячейки). Из всех выделенных вами ячеек можно сделать одну. И делается это именно с помощью этой команды. Правда, для того, чтобы команда стала активной, необходимо прежде именно выделить то, над чем вы собираетесь «командовать».

Обратна описанной команда Split Cells (Разделить Ячейки). Естественно, она все время находится в сонном состоянии, и только после слияния ячеек команда Разделить Ячейки делается активной. Но и то лишь тогда, когда ваш курсор попадает в ячейку, которая когда-то подвергалась слиянию и слита с какой-нибудь до сих пор. При этом команда Разделить Ячейки становится активной независимо от того, выделена ячейка или нет. Главное, чтоб в нее попал курсор.

Следующая опция — Cell Diagonals... (Диагонали Ячейки...). Ее диалог вы видите на рисунке 305.

Рис. 10. Диалог Cell Diagonals

Действительно, очень полезная опция. Нам очень часто необходимы диагонали внутри ячеек таблицы. Не перечислить примеров, когда это крайне необходимо. Но посмотрим на диалог. Здесь три опции, и по умолчанию — No Division (Нет Разделения). Две другие — Divide down (Делить вниз) и Divide up (Делить вверх), это понятно. А вот на что нам первая?

А первая нам для того, что не всегда мы сможем применить команду Undo (Отменить) из меню Edit (Правка). Убрать диагональ из конкретной ячейки нам, возможно, понадобится лишь через неделю или еще того больше. С помощью назначения диалога мы это сделаем без проблем.

Не стану вам демонстрировать эти диагонали: и так все ясно. Единственное, что нужно тут знать и помнить: когда мы разделили ячейку на две полуячейки, текст мы можем вписывать и в ту, и в другую. Правда, при этом должны соотносить размер текста и кегля шрифта с фактической величиной получившегося треугольника: много в него не впишешь, это не прямоугольник, тем более что получившийся треугольник с очень острым углом, в который не влезает ни один кегль. В таких ячейках может поместиться лишь какое-нибудь число, буква...

Рис. 11. Диалог Автоформат Таблицы

И еще одно важное обстоятельство: два треугольника, получившиеся из од ной ячейки, не лежат в одной плоскости (слое), это два независимых слоя, причем когда вы разделили ячейку вниз, верхний треугольник будет находиться в верхнем слое, а нижний — под ним. Если в нижнем будет слишком большой текст, часть его скроется под Слева внизу мы видим кнопку Options со стрелкой-кавычкой. Такого вида стрелки означают, что при нажатии на кнопку диалог расширится вниз, что там, в нижней (или боковой, как бывает) части, собраны некоторые назначения, которые авторы предпочли в видимый вариант не включать, считая, что для большинства пользователей достаточно назначений видимой части. Откроем же кнопку и взглянем на скрытые опции:

Рис. 12. Полный диалог

Здесь, как видите, скрывалось целое поле Formats to apply (Примененные Форматы). В нем собрались назначения: Text formatting (Форматирование текста), Text alignment (Выравнивание текста), Patterns and shading (Модели и оттенки) и Borders (Границы).

Поскольку все опции помечены флажками, они уже назначены, так что можно хотя бы не волноваться относительно форматирования автотаблицы. Попробуем для эксперимента назначить какую-нибудь из предлагаемых таблиц. Вдруг она нам очень пригодится?

Рис. 13. Назначили Автоформат

Как видите, эксперимент не смертельный. Правда, я не помню, на какой строке списка щелкнул и не могу назвать вам номера или «марки» этого варианта. Что ж, Автоформатом вполне можно пользоваться, это полезно.

Но вернемся к нашей Таблице.

В Таблице точно так же, как в приложении Word, можно вручную сдвигать границы ячеек. Надо подвести курсор к границе и дождаться, когда он приобретет вид обоюдоострой стрелки, разделенной двумя близко расположенными прямыми, напоминающими изображение на схеме электрического конденсатора. В этот момент, который уловить иногда очень сложно, надо щелкнуть кнопкой мышки и, не отпуская, протянуть в желаемом направлении. Вся граница подвинется на необходимый шаг.

Выделить вручную строку или столбец также не представляется сложным. Для этого с внешней стороны Таблицы вы подводите курсор мышки к самой границе выделения и дожидаетесь, когда курсор приобретет вид горизонтальной стрелки (когда выделяете строку) или вертикальной стрелки (когда выделяете столбец). Одним щелчком мышки вы выделите либо строку, либо столбец.

Что касается многих других параметров, то они редактируются или назначаются в диалоге Format Table (Форматирование Таблицы). Он вызывается двойным щелчком мышки на границе выделения Таблицы (блока). Курсор при этом имеет вид крестообразной стрелки (под нею, как водится, куда-то мчится автомобиль-фургон с надписью Move на борту. Вот этот диалог Форматирования:

Рис. 14. Диалог Format Table

Собственно, это знакомый нам диалог Форматирования из меню Format. Оттуда его также можно вызвать строкой Table..., не прибегая к манипуляциям с мышкой, если для вас это сложно (табличка мелкая или крупный масштаб) или проблематично (бывают пользователи, у которых мышка вызывает стойкое чувство дискомфорта).

Но посмотрим. Нам этот диалог сейчас очень важен. С ним придется общаться, заливая ячейки для кроссворда (помните, там масса черных клеточек?). С остальными назначениями мы более-менее разбирались, поэтому рассмотрим лишь важные для нас.

С заливки и начнем. Эта опция располагается вверху диалога, на той имение вкладке, которая открылась по умолчанию.

Рис. 15. В строке Color выбран синий цвет

Рис. 16. Вся Таблица синяя. Выберем четыре ячейки.

Вот Таблица приобрела синий цвет заливки ячеек. Теперь (вы видите по рисунку 16) я выбрал четыре ячейки из центрального ряда, чтоб назначить им отсутствие заливки. Можно поступить и наоборот — заливать только те ячейки, которые нужно. И тот и другой способ вырисовывания кроссворда подходит. Итак, назначаем симметрично пустые ячейки:

Рис. 17. Так назначаем не залитые ячейки

Этим процессом занимаемся долго и скрупулезно и наконец получаем общий рисунок кроссворда, который нас мог бы удовлетворить. Форма—произвольная.

Попутно скажу о двух опциях меню Table. Это опции Fill Down (Залить Вниз) и Fill Right (Залить Вправо). Они становятся активными, когда вы выделяете несколько ячеек. Выделить несколько ячеек можно простым путем — тем, каким позволяет это сделать Windows. Ставите курсор в одну из ячеек столбца и щелкаете им. Потом переносите курсор в последнюю из тех ячеек, которые необходимо выделить из столбца. Но прежде, чем щелкнуть там, нажимаете и удерживаете при щелчке клавишу Shift. Таким образом выделяется несколько ячеек подряд из одного столбца. С выделением нескольких ячеек подряд в строке — то же самое: ставите в крайнюю (первую из выделяемых) курсор и потом, удерживая Shift, щелкаете в последней (из тех, которые необходимо выделить) ячейке.

Таким способом я и отменил заливку во всех ячейках, которые вы видите белыми на рисунке 18.

Рис. 18. Заготовка для кроссворда

Из рисунка ясно, что нас не устраивает толщина линий в Таблице. Слишком они тонкие, такой кроссворд трудно разглядеть, не то что разгадывать. Выделяем полностью Таблицу (чтоб все ячейки выделились черным, как текст), вызываем из меню Format опцию Table..., в диалоге, уже очень знакомом вам, назначаем Цвет Линии — черный, толщину линии 2 pt, а потом, переходя на кнопки границ, размещенные.вокруг поля Образца, щелкаем на кнопке с полным квадратом и перекрестьем.

Получаем заготовку с необходимой нам толщиной линий, ограничивающих ячейки.

Теперь предстоит освободиться от лишних ячеек.

Это делать сложнее, потому что кропотливее. Выделяем, во-первых, те ячейки, которые являются идентичными. Например, все четыре угла Таблицы преспокойно по отдельности выделяются: четыре ячейки слева вверху (две рядом и две под ними). Им назначаем отсутствие заливки. Когда это проделаем, останется всего ничего — убрать линии, ограничивающие этот квадрат (пока у нас это скорее прямоугольник, но потом размер поменяем — растянем готовый полуфабрикат).

Линии убираются тоже очень просто. И даже не теми кнопками обрамления, которые существуют вокруг поля Образца. Просто в самом Образце щелкаем на той линии, которую нужно удалить, и потом в поле назначения цвета линии выбираем No Fill (He Залита). И так с каждой линией, ограничивающей ячейку. Вернее, мы не убираем линии, а только делаем их невидимыми. Таблица сама по себе так и остается Таблицей, и на рисунке 19, где я показал уже получившуюся графическую заготовку кроссворда, убранные линии прекрасно просматриваются. Но это лишь на мониторе. При печати этих линий не будет.

Рис. 19. Заготовка готова, осталось вписать цифры

Я слукавил и растянул Кроссворд вручную. Не захотелось ставить курсор в каждую из 9 строк и говорить Enter. Еще не учел, что Текстовый Блок на страницах с изображением автомобиля сделал поуже, чем он мог быть согласно формату. Потому пришлось так же вручную немного сжать Кроссворд с боков, а значит, кеглем 1 не получилось бы сделать ячейки квадратными, как мы хотели в начале эксперимента. Надеюсь, что вы простите меня за то, что обошелся с Таблицей так по графически.

Ну, теперь впишем цифры — и задача выполнена. Можно будет сочинять под этот шаблон слова и подписи к ним. Но это уже другая работа, кстати, неплохо оплачиваемая. Ставим курсор в первую ячейку, где будет номер 1 по вертикали. Потом либо мышкой щелкаем в той ячейке, где будет цифра 2, потом — где 3 и так далее. А можно это делать с помощью кнопок Табуляции и Стрелок Вверх-Вниз-Влево-Вправо. Как бы то ни было, и эту работу я выполнил, тем более что у нас Кроссворд маленький по числу слов, чего не скажешь о его размерах.

Наконец, все цифры вписаны, и — вот он, Кроссворд:

Рис. 20. Кроссворд готов

Получился он нисколько не хуже, чем у художников, которые все это разрисовывают с помощью пера и рейсфедера.

Чтоб убедиться, что нигде не наврал, открываю опцию Просмотр Печати (Print Preview) в меню File (Файл) и проверяю, все ли в порядке. Результат вы тоже видите на рисунке 21.

Рис. 21. Просмотрим, чтоб убедиться

Кроссворд нормальный. Без вопросов, правда, и без ответов. Но сгодится.

По-хорошему-то, нам надо было бы отверстать страничку, но сами помните, что текст был экспериментальный, случайный, Кроссворд, собственно, тоже. И машинка не на месте, и колонтитул надо подчеркнуть хорошей нестандартной чертой, вокруг номера страницы создать какой-нибудь вензель... Обязательно в итоге займемся подобной работой. А пока...

А пока у нас осталась одна опция — Grow to Fit Text (Увеличить Готовы! Текст). Но здесь я терплю фиаско: я так и не расшифровал, что значит эта опция Визуально в программе ничего не меняется, если снять флажок с этой команды. И с текстом ничего не происходит, если его выделить и установить этот флажок (проще говоря, щелкнуть по строке). Строка осталась для меня загадкой. Но могу лишь предположить, что, возможно, она относится к заготовкам и шаблонам из Галере программы Publisher. Возможно, она действует на таблицы, содержащиеся в шаблонах? Честно, не знаю.


Глава 1

Командное меню «Порядок»

Это меню, или его опции, нам знакомо по графическим или верстальным программам. Здесь речь идет об элементарных понятиях для верстальщика: что ниже, что выше, что соединить, что разъединить, что раньше, а что позже и так далее. Порядок есть порядок.

Рис. 1. Меню Arrange

Вот и меню Arrange (Приводить в Порядок). Оно нам очень пригодится.

Рассмотрим, из чего оно состоит. Кстати сказать, для экономии бумаги на рисунках я заодно с этим меню показал и первое из подменю, которых собралось в этом меню предостаточно. Мы скоро дойдем до этого подменю, которое называется Ruler Guides (Мерные Направляющие). А пока — первая опция.

Первой опцией этого меню фигурирует опция Layout Guides... (Плановые Направляющие, Руководящие...). Я недаром применил слово «руководящие»: в 9-й версии CorelDRAW направляющие линии так и назывались. Это перевели составители русификатора, но их оправдывает то, что они были не очень сильными знатоками русского языка, поскольку, как я подозреваю, интерфейс CorelDRAW был переведен на русский самой фирмой Corel Corp. Но откроем эту опцию. Тогда что-то и увидим.

Рис. 2. Диалог Layout Guides

Что ж, это диалог, так диалог. Здесь все ясно.

В верхнем поле Margin Guides (Линии Полей) мы видим установки по умолчанию Границ Полей. Inside (Внутри), Outside (Снаружи), Тор (Верхнее) и Bottom (Нижнее). Все значения по умолчанию выбраны 1,27 см, кроме последнего, Bottom (1,676 см). Линии Границ Полей в программе установлены малинового цвета.

В правом поле просмотра показан или один лист, или разворот — в зависимое от того, как вы установите эту опцию. Она устанавливается проставлением или снятием флажка внизу этого поля просмотра против опции Create Two Master Page: Mirrored Guides (Установить Две Мастер-Страницы с Зеркальными Граница ми). Именно потому, что я проставил флажок в этой опции, мы и получили в пере численных назначениях Внутреннюю границу и Внешнюю границу, в то врем как по умолчанию программа не предполагает книжных разворотов (застарелая убежденность, проистекающая из «Ворда») и имеет в виду всего лишь одну Мастер страницу, где поля именуются Левое и Правое (Left и Right).

Итак, мы выяснили одну важную, причем наиважнейшую вещь: в меню Arrange в опции Layout Guides скрыты назначения, которые нам жизненно необходимы, если мы готовимся верстать книгу. Нам просто о-о-чень нужен книжный разворот!!! Вы помните, что когда мы делали назначения на Мастер-Странице, и она была одна-одинешенька, я высказывал крамольную мысль о том, что, если мы не найдем Разворота, придется публикацию разбить на две части — одной дать одни назначения, а другой (по тексту и картинкам идентичной) — другие. Потому хотя бы, что левая и правая страницы книги, конечно же, отличаются друг от друга.

Представьте себе, если бы опции Разворот не было в верстальной программе. Мы не смогли бы назначить номера страниц на внешней стороне листа, близкой к обрезу, а не к корешку. Пришлось бы ставить номера страниц (автоматические) только по центру. Или вручную, на каждой из семи тысяч страниц... Мы не смогли бы установить надлежащие колонтитулы, какие вы видите в той книге, что держите в руках. Колонтитул левой и правой страниц не отличались бы друг от друга, — а в книге ведь это не так! Да и изображение автомобиля, извините, на внутренней части правой страницы нам не нужно. Хотелось разместить его ближе к обрезу книги. И так далее и тому подобное.

Итак, прежде чем заниматься назначениями, общими для всех страниц книги, то есть прежде чем общаться с Мастер-Страницей, мы обязательно должны сделать важное назначение в рассматриваемом диалоге. И это важное назначение — всего-то на всего проставить флажок в одной опции!.. Но вещь необходимая.

Вот и стало все на свои места. А вот и Мастер-Страница (теперь двойная):

Рис. 3. Мастер-Разворот

Видите, из-за того, что я назначил Зеркальность поздно, под эту Зеркальность попал даже автомобиль — он развернут по горизонтали. Чтоб не шокировать вас, с левой страницы я убрал другие несуразности: пусть лучше на рисунке будет пустой. Правильные назначения мы сделаем в практикуме по настоящей верстке.

Но зато как здорово видеть, что у нас есть и левая (L), и правая (R) страницы!

А вот что получается внутри книги:

Рис. 4. Разворот второй и третьей страниц

Видите, здесь появилась даже какая-то эстетика. Правда, автомобиль не на месте, два изображения, хоть они и зеркальны друг другу, все же сходятся к внутренней части книги, к корешку, а не к обрезу. Но это уже детали, мы постараемся избежать этих накладок в подлинной, настоящей верстке.

Но досмотрим, что там есть еще, в диалоге План Направляющих.

Ниже поля Линий Границ находится поле Линий Сетки. Что это такое?

Оказывается не что иное, как разбивка страницы на колонки и даже ряды. К примеру, назначим вместо одной колонки и одного ряда по умолчанию — две колонки и два ряда. Назначим эти цифры с помощью счетчика. Взглянем не на само! публикации, а только в поле Просмотра самого диалога.

Рис. 5. Новые назначения

Нет, на Просмотре в диалоге это смотрится не так. Взглянем все-таки, что получилось на истинных страницах.

Рис. 6. А так это смотрится на странице книги

На этом наш диалог закончился, можно переходить к следующей опции. Правда, осталось еще самое нижнее поле Design Tip (Конструктивный Совет), но там ничего конструктивного, кроме бесполезного сообщения программы в наш адрес, нет. А сообщает она о том, что пользоваться разделением страниц на левую и правую — это хорошо, и что это может нам помочь в размещении (позиционировании) объектов. Только и всего.

Следующая опция — Send to Master Pages (Отправить на Мастер-Страницу). Она очень может понадобиться в том случае, если вдруг на рабочей странице публикации вы нашли некое замечательное решение (допустим, по дизайну) и захотели распространить его на все страницы публикации. Вы тогда выделите то, что собираетесь отправить на Мастер-Страницу, и отправите с помощью этой опции. Только перед тем, как сделать эту отправку, программа сообщит вам во всплывшем диалоге, что такой-то и такой-то элемент, отправляясь на Мастер-Страницу, займет на ней такое-то место. Вы, мол, все еще хотите его туда отправить? Скажете «Да», и этот элемент окажется на Мастер-Странице.

Если же с Мастер-Страницы (это, согласитесь, некий особый режим) вызвать ту же опцию-диалог из меню Arrange, она там зовется совсем по-другому — Send to Foreground (Отправить на Передний План). Фактически — это отправка обратно И не на Передний План, а на Первоначальное Место.

Но идем дальше. Взглянем на опцию, которая фигурирует со своим подменю на рисунке 1 и которая называется Мерные Направляющие (Ruler Guides). У этой опции есть подменю, в котором три опции — Add Horizontal Ruler Guide (Добавить Горизонтальную Мерную Направляющую), Add Vertical Ruler Guide (Добавить Вертикальную Мерную Направляющую) и Clear All Ruler Guides (Убрать Все Мерные Линии).

Использовав команды Добавить — и Горизонтальную, и Вертикальную, — я получил то, что вы видите на рисунке 7.

Рис. 7. Добавили Мерные Направляющие

Если вам видно, вы заметите, что Направляющие возникли как раз посредине экрана монитора. Это происходит независимо от того, в каком положении на экране находится страница и в каком масштабе мы ее рассматриваем. Мерные Направляющие зависят только от параметров экрана и встают раз и навсегда. Их невозможно передвинуть, отодвинуть и задвинуть.

Мерные Направляющие, в отличие от Линий Границ, зеленого цвета. Они неподвижны, как соляные столбы...

Однако не столь уж и неподвижны. Попробуем переместить нашу страницу с помощью Вертикальной и Горизонтальной полос прокрутки: вы увидите, что теперь они движутся вместе со страницей. Следовательно, с их помощью можно ИЗМЕРЯТЬ. А на рисунке 8 они сдвинулись только благодаря тому, что изменен масштаб просмотра публикации.

Рис. 8. Направляющие сдвинулись!

Кстати сказать, в Publisher, как и во многих приложениях, идет постоянная работа по слежению за координатами курсора. Эти координаты отражаются в Строке состояния программы (нижняя строка рабочего окна) с точностью до сотых долей миллиметра — выражаются в сантиметрах с тремя знаками после запятой. Что касается сетки координат, бегунок, движущийся по Горизонтальной и Вертикальной линейкам, может отмечать точные значения, совпадающие с делениями линейки: как только он совмещается с черточкой на линейке, так и он, и черта как бы компенсируют друг друга, и отметка деления становится белой на сером фоне линейки. Это и означает, что мы находимся в точке, соответствующей этому точному значению по горизонтали или по вертикали. Таким образом при масштабе изображения страницы 33% мы имеем возможность отмерять длину или высоту с точностью до 5 мм, а при масштабе 400% — с точностью до 0,5 мм. Визуальные возможности еще больше: экран оставляет нам «запас точности», и мы можем на глаз делать замеры до 0,1 мм с небольшой погрешностью. В верстальной программе этого больше чем достаточно, и потому можно сказать, что программа Publisher предельно точна в плане координат.

Мы можем получить какое угодно число Мерных Направляющих, если станем сдвигать страницу и при этом еще варьировать масштаб. На рисунке 9 вы видите несколько назначенных таким образом Линий.

Рис. 9. Множество Ruler Guides

Они ведут себя именно как Направляющие. Любой объект, край которого оказывается в пределах Линии, стремится «приклеиться» к ней ближайшей своей стороной. Именно так произошло с нашим Кроссвордом, когда я его попытался переместить. Результат— на рисунке 10.

Рис. 10. Кроссворд «приклеился»

Чтобы оторвать объект от линии с помощью кнопки мыши (перетаскиванием), приходится приложить некоторое усилие (объект отрывается с запаздыванием).

Команда Clear All Ruler Guides — снимает с публикации все наложенные на нее Мерные Линии. Достаточно щелкнуть на строке команды.

Оговорюсь: снимаются только те линии, которые имеются на данном развороте публикации. Назначенные на других страницах Ruler Guides преспокойно остаются на своем законном месте.

Идем дальше. Команда Group (Сгруппировать).

Если выделено более одного объекта — как у меня на рисунке 11: Текстовый Блок и Кроссворд, — активизируется команда Group. Группирование объектов — одна из важнейших опций в макетировании и верстке.

Рис. 11. Команда Group

Щелкаем на этой строке меню и получаем сгруппированный объект, который ведет себя теперь как вполне самостоятельный объект.

Рис. 12. Сгруппированный объект

Как видно на рисунке 11, у этого сгруппированного объекта нет уже маркер выделения, присущих каждому из них — есть только общие маркеры. С помои этих маркеров мы можем поменять размеры объекта. Именно результат такого действия вы видите на рисунке 12: изменены размеры общего объекта. Изменение было пропорциональным — при сжатии объекта с помощью углового маркера удерживалась нажатой клавиша Shift.

Рис. 12. Изменены размеры сгруппированного объекта

Внизу под объектом вы видите контекстную кнопку Ungroup Objects (Разгруппировать Объекты). Это достаточно новый подход Microsoft к контекстной теме. Мне кажется, что здесь, особенно в опции группировки и разгруппировки объектов, авторы программы правы. Ведь если мы сгруппировали несколько объектов, значит у нас есть какая-то конкретная задача — передвинуть их все вместе, изменить размеры и так далее. После этих манипуляций нам захочется в 99 случаях из 100 вернуть состояние объектов в прежние, привычные условия. И тут к нашим услугам — кнопка Разгруппировать. Очень удобно.

Обратите внимание на существенную деталь: мы сгруппировали между собой лишь Текстовые Блоки — Фреймы. А содержимое в них не группируется. Оно существует в каждом блоке отдельно от другого. То есть содержимое каждого блока принадлежит лишь этому конкретному блоку, а не новому общему, возникшему в результате сгруппирования. Мало того: при изменении размеров Блока — на примере Кроссворда это прекрасно видно — содержимое не меняется, его настройки остались те же.

На рисунке 12 вы видите, как непропорционально «возросла» толщина линий, а цифры, вписанные в левый верхний уголок ячеек, теперь занимают всю ячейку таблицы.

Если уменьшить сгруппированный Блок еще немного, цифры или размеры ячеек «поплывут»...

Говоря о кнопке Разгруппировать, мы уже затронули следующую опцию меню Arrange — Ungroup (Разгруппировать).

С помощью этой команды сгруппированные объекты снова становятся самими собой. Но разгруппирование, которое происходит мгновенно после щелчка на команде, осуществляется не полностью. Еще некоторое время, пока мы не отменили выделение (выделенными остаются все объекты, участвовавшие в прежней группе), объекты имеют свойство изменяться как группа. Стоит лишь щелкнуть мышкой где-нибудь в стороне, и объекты «оторвутся» друг от друга окончательно.

Тогда можно будет опять выделять их по отдельности и изменять, если это необходимо.

Но в этой серии команд, отвечающих за группировку, есть и еще одна — Regroup (Регруппировать).

Она идет в меню следом за командой Ungroup. Команда Regroup уместна в том случае, если мы только что разгруппировали объекты, но вдруг передумали это делать. Впрочем, в этом конкретном случае у нас есть и иная, более скоростная возможность вернуть группу: под нижним из объектов появляется контекстная кнопка Сгруппировать Объекты (Group Objects).

Так или иначе, используя команду Regroup, мы восстанавливаем утраченную группу.

Следующей идет серия команд, собранная в подменю Order (Порядок).

Рис. 13. Подменю Order

Здесь вы видите важнейшие команды, касающиеся в первую очередь визуального ряда. Вы можете один объект поместить выше другого (по слою). Это часто необходимо делать при работе с надписями, значками, заголовками, всевозможными визуальными эффектами. Бывает, и очень часто, что вы создали заголовок раньше, чем придумали для него объект в качестве фона. Этот объект станет загораживать заголовок, если не скроет его совсем. Прежде всего это касается наименований всяких рубрик (если речь идет о газете). Эти рубрики для эффекта помещаются на темной или черной плашке и написаны белым или цветным шрифтом. Эту-то надпись и надо вытащить на свет и поместить ее над плашкой. Для этого применяются команды Order (по порядку, сверху вниз) — Bring to Front (Вынести по Фронту), Send to Back (Отправить Ниже Всех), Bring Forward (Вынести Вперед) и Send Backward (Поместить Сзади).

Эти команды используются, во-первых, как команды-решения. То есть как способствующие художественному решению публикации. Родил такого-то вида сочетание объектов и текста — и это ушло в типографию, то есть в тираж. Но эти же команды используются и как функциональные для текущей работы над публикацией. К примеру, если вам нужно отредактировать элемент, находящийся ниже всех, который еле виден, потому что его заслоняют другие, — вы примените одну из двух перечисленных команд — первую или третью — и отредактируете его. Потом примените вторую или четвертую команду — и элемент вернется на свое законное место.

Первые две команды используются чаще всего, если объектов множество, а вторые две — если объектов всего два.

Сейчас не станем приводить примеры, поскольку наши примеры впереди — когда рассмотрим конкретную верстку конкретной публикации. Пока идем дальше.

Подменю Snap (не расшифровал перевода, потому что в английском языке масса значений этого слова — от ухватиться и огрызнуться до щелкнуть, сфотографировать, застегнуть, не считая уже глагола лопнуть, понятий хрустящее печенье, внезапное похолодание, детская карточная игра и опять глаголов

— наброситься и укусить) с его тремя командами. Команды такие: То Ruler Marks (Маркировки Линейки, Разметки Линейки), То Guides (Направляющие) и То Objects (Объекты). Можно было бы по догадке вычислить, что означает Snap, если при вызове хотя бы одной из этих трех команд хоть что-либо в программе поменялось...

Это еще раз доказывает неудобство английской версии для русского пользователя.

По опыту общения с подобными программами (имеется в виду не верстальная их сущность, а английский интерфейс) я могу сказать, что значит опция Snap. Это Привязка. Первая опция подменю привяжет ваш объект к Маркерам Линейки, вторая — к Направляющим. А третья — к стороне или узлу другого Объекта или фигуры. Вот что такое Snap.

Дальше — яснее: подменю Nudge (Подтолкнуть) с его недвусмысленными командами Up (Вверх), Down (Вниз) Left (Влево) и Right (Вправо). Это .известные нам передвижения объектов в указанных направлениях с шагом 0,32 см (диалог Параметры меню Tools, если помните). Подталкивание идет на один шаг.

Следующая опция — Align or Distribute (Выравнивание или Распределение). Здесь речь идет не о выравнивании текста, а об Объектах. Объекты также подвергаются выравниванию. Для выравнивания Объектов или Блоков используются границы страницы публикации, то есть Линии Границ. Если ваша публикация строится на шаблоне одной страницы, то Выравнивание происходит относительно Границ Полей этой страницы. Если же у вас Книжный Разворот, программа выравнивает, учитывая правую Margin Guide правой страницы и левую Margin Guide левой страницы. Взгляните на это подменю:

Рис. 14. Подменю Align or Distribute

Как видите, почти все опции этого подменю не активны. Для того, чтоб они подали признаки жизни, нам надо щелкнуть на команде Relative to Margin Guides (Связать с Границами Полей). Тогда тут же все опции станут доступными, как на рисунке 15.

Рис. 16. To же подменю, команды активны

Рис. 17. Кроссворд «выровнялся» по границе между страницами

Здесь речь идет скорее не об одном Объекте, который, что уж тут сложного, можно и вручную подвинуть к Границам. Речь о выравнивании нескольких объектов. Потому и пиктограммы, сопутствующие командам, отражают множественность объектов.

Взглянем на эти команды. Верхняя группа команд — выравнивание по ширине (по горизонтали): Align Left (Выравнивание по Левому Краю), Align Center (Выравнивание по Центру) и Align Right (Выравнивание по Правому Краю). Взглянем на действие одной из них — хотя бы второй (По Центру).

Обратите внимание: часть Кроссворда оказалась невидимой. Эта левая часть «вползла» под Текстовый Блок, который был помещен на страницу позже Кроссворда, поэтому оказался в верхнем слое, а Кроссворд — в нижнем. Вот поле деятельности для команд подменю Order!

Смотрим дальше. Следующая группа команд — это команды выравнивания по высоте (по вертикали): Align Top (Выравнивание по Верхнему Краю), Align Middle (Выравнивание по Середине) и Align Bottom (Выравнивание по Нижнему Краю) Взглянем и на одну опцию из этой группы команд:

Рис. 18. Выравнивание Кроссворда по Верхней Границе

Не удивляйтесь, что сквозь ячейки Кроссворда просвечивают назначенные на Мастер-Странице автомобильчики: если помните, мы ведь назначали ячейкам Отсутствие Заливки, а вовсе не Белую Заливку (которую, естественно, тоже можно было назначить).

Больше вроде бы ничего примечательного не скажешь. Опция работает, все другие опции — тоже.

Смотрим на следующую группу команд. Это: Distribute Horizontally (Горизонтальное Распределение) и Distribute Vertically (Вертикальное Распределение). Сразу ясно, что команды относятся к группе объектов. Хотя могут распределить и одиночный объект. К примеру, если выбрать Кроссворд и проигнорировать другой объект (у нас это Текстовый Блок), то при команде Распределение по Горизонтали программа поместит Кроссворд в середине страницы (только по горизонтали, высота в расчет приниматься не будет, и объект «распределится» по горизонтали на отметке той высоты, какую занимал до момента вызова команды. Он только подвинется куда-то. То же касается Вертикальных назначений.

Гораздо полезнее иметь дело с группой объектов (хотя бы парочкой). Тогда эти команды приобретают значительность, доказывая необходимость их в программе.

Давайте распределим по горизонтали наши объекты. Результат вы видите на рисунке 19.

Рис. 19. Распределение по Горизонтали

Заметьте, здесь по законам геометрической симметрии распределены два объекта. Программа делает это замечательно. Впрочем, в середине страницы (после выравнивания по вертикали) Кроссворд оказался случайно, потому вроде как правильно и распределен. На самом деле программа нисколько не заботится, выровнены или нет объекты по вертикали. В опции Распределения по Горизонтали программа занимается только этим. Так же, как и в опции Распределения по Вертикали:

Рис. 20. Распределение по Вертикали

Я нарочно сократил Текстовый Блок, чтоб было видно, что программа трудится. Если бы я оставил Блок такого же размера, то есть от верха до низа страницы, то нам было бы непонятно назначение опции (в смысле результата). Теперь же ясно. Publisher распределяет объекты по Вертикали так, как если бы они были нанизаны на одну вертикальную ось. На самом деле, как видите, они остаются каждый на своей незримой вертикальной оси.

Итак, это подменю также закончилось. Идем дальше.

Следующая опция (и подменю) — Rotate or Flip (Поворот или Отражение). Впрочем, второе слово не переводится как Отражение. Оно переводится как Щелчок. То есть перекидывание объекта из одного состояния в другое на американском жаргоне может иметь значение — Перещелкиванье.

Но смотрим по порядку:

Рис. 337. Подменю Rotate or Flip

Мы неудачно выбрали Кроссворд в качестве подопытного объекта: видите, две последние опции не приобрели активности. Это как раз «флип» — Отражение по Горизонтали и Вертикали. Кроссворд не может оказаться отраженным зеркально, поэтому он не активизирует эти две строки. Возьмем другой объект — он есть у нас только на Мастер-Странице. Это автомобиль. Откроем для него это подменю и увидим, что теперь все опции активны:

Рис. 21. Теперь все активно, только объект иной

Первая опция — это Free Rotate (Свободное Вращение). На рисунке вы видите, какой вид приобрели маркеры Блока Кроссворда: теперь по углам фрейма — четыре зеленых маркера, потянув за любой из которых, мы можем! вращать объект, визуально выбирая угол его поворота относительно прежнего! положения. Честно говоря, не вижу особого смысла в такой опции, потому что) Publisher и так любое выделение объекта уже предполагает его ручной поворот, дело в том, что здесь к маркерам выделения обязательно добавлен, как и в случае с объектами в Word и других приложениях Офиса, зеленого цвета маркер поворота. Он расположен несколько выше всех и по центральной вертикальной оси объекта. Потянув за него, можно не вызывая никакой опции повернуть на глазок объект. Здесь же тоже Поворот на глазок... Ну, авторам виднее.

Рис. 22. Маркеры Свободного Вращения объекта

Следующая опция — Поворот Влево (Rotate Left). И еще одна — Rotate Right (Поворот Вправо). И в том, и в другом случае это фиксированный Поворот — на 90 градусов. Ну, давайте положим наш Кроссворд на правый бочок.

Рис. 23. Положили Кроссворд на правый бок

Ничего, лежит.

Ради последних двух опций уходим на Мастер-Страницу, чтоб совершить пар манипуляций с автомобилем.

Вот мы его Отразили по Горизонтали (Flip Horizontal):

Рис. 24. Отражение изображения по Горизонтали

А вот Отразили его же, следом, и по Вертикали (Flip Vertical):

Рис. 25. Отражение по Вертикали

Хорошо, так и оставим. Так интереснее.

Действие последних двух опций — мгновенное. Почти не раздумывая, программа отражает изображение и вокруг вертикальной оси (то есть По Горизонтали), и вокруг оси горизонтальной (то есть По Вертикали). Поистине Flip, Щелчок.

Но подменю наше исчерпано. Надо двигаться вперед.

Следующая опция — Text Wrapping (Обтекание Текстом).

Мы уже, помнится, рассматривали это обтекание. Рассматривали в смысле Стилей Обтекания. Теперь посмотрим на конкретном примере, как действует опция в меню Arrange.

Надо сказать, универсальность и многовариантность, положенная в основу Windows и Office Корпорацией Майкрософт, здесь тоже проявляется в полной своей мере. Те же Обтекания можно назначить и с Панели Изображения, которая не замедлит появиться, едва мы вставим в текст рисунок.

Отличительная особенность Publisher в отношении этой опции — в том, что при вставке рисунка он мгновенно по умолчанию приобретает обтекаемость текстом. По умолчанию это Обтекание со Всех Сторон (Square, Квадратное). Эта специфика (по умолчанию) отражена и в подменю: едва мы его откроем, тут же видим, что верхняя опция Square отмечена, выделена.

Рис. 26. Подменю Обтекание Текстом

Вставим рисунок и посмотрим. До того, как вставить рисунок, я уже заполнил Текстовый Фрейм случайным текстом из этой же книги. Столь же случайно этот текст оказался недавним текстом, посвященным рассмотрению опции Обтекания. Как раз тот, где мы рассматривали Стили Обтекания, говоря о Параметрах.

Ну, а с рисунком долго носиться не станем. Выберем тоже автомобиль, но другой.

Рис. 27. Вставили рисунок. Обтекание по умолчанию

Учитывая, что мы как раз поговорили на тему Стилей Обтекания достаточно вразумительно, здесь только перечислим основные способы обтекания, собранные в подменю. Потом нам все равно придется обтекать текстом картинки, когда займемся непосредственно версткой и макетированием.

Кроме той, "которая по умолчанию (Square, Co Всех Сторон), здесь есть строки: Tight (Поджатое), Through (Насквозь) Top and Bottom (Сверху и Снизу) и None (Нет). Последней строкой идет Edit Wrap Points (Редактировать Узлы Обтекания).

На примере обтекания нашего автомобиля и откроем эту опцию, то есть щелкнем по этой строке.

Рисунок тут же делается выделенным красными контурами (по обрезу), узлы из обычных круглых без заполнения — делаются мелкими черными квадратными маркерами. Курсор, который мы подносим к красному контуру, тут же приобретает вид большего, чем по углам рисунка, квадратного черного маркера с надписью ADD ниже маркера.

В графических программах, как известно, такого рода курсором осуществляется щелчок в той точке контура или кривой, в которой вы желаете создать дополнительный узел.

Узлы — важнейшая часть, важнейший элемент для графических объектов ж только в графических программах типа CorelDRAW, но и, к примеру, в верстальной — QuarkXPress. Там тоже обтекание по контуру рисунка создается вручную с применением принципа порождения новых узлов и достройки и подгонки контура обтекания.

Здесь курсором вы можете щелкать хоть до посинения. На прямой линии красного контура не образуется никакой дополнительной точки, никакого дополнительного узла.

Но не торопитесь. Для того, чтоб на контуре возник дополнительный узел, котором этот контур должен преломиться, надо не щелкать, а захватить в желаемой точке этот контур и потянуть его. Тут же под стрелкой курсора образуется на красном контуре новая точка с признаками узла. Впрочем, это не совсем узел, потому что контур так и остается прямолинейным, хотя и ломаным. Кривой не возникает. Но зато наделать узлов (вернее, точек схождения двух лучей, прямы? можно сколько угодно, и поэтому замкнутая ломаная линия с бесконечным числом вершин может условно считаться кривой. Соответственно точки схождения двух прямых, образующих ребра и вершину неправильного многоугольника, могут считаться не вершинами многоугольника, а узлами замкнутой кривой. Эту «кривую», которую вы видите на рисунке 345, можно как угодно более точно подогнать к абрису, который необходимо Обтечь Текстом. На рисунке эта подгонка очень неточная и почти условная. Однако для Обтекания этого, как правил вполне достаточно, ибо текст имеет свой определенный размер и не может обтекать несоизмеримые с его величиной детали.

Рис. 28. Обтекание по ломаному контуру

Больше не станем сейчас заниматься Обтеканием. Перейдем к другой опции. Пропустим Edit Points (Редактировать Узлы) и рассмотрим опцию Cha AutoShape (Изменить Автофигуру).

Однако прежде, чем Изменить Автофигуру, надо ее Вставить или Нарисовать. Это можно сделать и из меню Insert (Вставка), и с Панели Инструментов (кнопка, выбор, рисование). Что я и сделал одним из этих способов. Вот она, Автофигура, и вот она, опция Изменить Автофигуру.

Рис. 29. Подменю Change AutoShape

Это полезная опция. Вызвав любую другую, касающуюся Автофигур, вы сможете изменить параметры Автофигуры (можно сделать это и просто мышкой, через выделение и манипуляции с растягиванием и сжатием), но не саму Автофигуру. Здесь можно выбрать другую одним мановением пальца. К примеру, вот такую:

Рис. 30. Новая Автофигура

Простота этой опции может показаться примитивной. Но Автофигуры — это настолько разработанная Корпорацией область услуг, что сложностей для пользователя там и быть не должно. Автофигуры теперь не только прерогатива Microsoft. Они в качестве инструмента Панели инструментов вошли даже в CorelDRAW 10...

Ну, а теперь вернемся к опции Edit Points (Редактировать Узлы), которую мы пропустили. Она была пропущена по той причине, что не была активной.

Здесь уместно небольшое отступление, касающееся того, как понимаются в приложениях Узлы (или Точки).

Сама природа изначально не любит полной симметрии, и в данном случае мы относим к асимметрии — понятие кривых, как основы работы в CorelDRAW и QuarkXPress.

А уж по логике становятся значимыми и ее компоненты: узел, путь.

В любом варианте прямая линия всего лишь частный случай кривой, которых великое множество, называемое бесконечностью.

Кривая имеет путь. Это также важнейшее понятие, о котором нельзя забывать, работая с программой, где используются кривые. Путь начинается в начальной точке рисования и заканчивается в той точке, где вы решили отпустить первую кнопку мыши. Нарисованная вами кривая будет иметь начало и конец, а движение от первой точки до последней и есть тот самый путь.

Замкнутая фигура также имеет путь, как и разомкнутая. Только есть разница: в замкнутой фигуре путь начинается и завершается в одной и той же точке.

Если вы не захотели или не сумели дорисовать замкнутую фигуру (если это не стандартная фигура, а целиком нарисованная вами с применением инструментов), Publisher, как и Quark, как и CorelDRAW, мысленно дорисовывает ее и даже показывает вам на вашей странице значок: вы попали в точку. Этот значок некое окошечко, активизирующееся, когда вы пришли в зону начала кривой. Зона эта небольшая, но достаточная для того, чтобы попасть в нее при масштабе 100%.

При недостаточном масштабе просмотра (а вам он кажется вполне сносным) вы, конечно, не попадете в нужную точку, и мучиться вам до скончания сего файла. Publisher дорисует кривую и сам замкнет ее, чтоб вам не мучиться.

Участки пути, отдельные его отрезки есть отдельные и как бы самостоятельные кривые. Точки, между которыми они прорисованы, принято называть узлами.

Работа с узлами, к примеру, в Кварке — отдана на откуп инструменту Элемент.. Активизируйте его, подведите курсор к любому узлу, щелкните и потяните, — вы увидите, как странно и часто непредсказуемо меняется картинка. Многих раздражает именно непредсказуемость. Что делать?

Из-за этой самой непредсказуемости поведения узла даже хорошие художники не очень охотно пользуются инструментом свободного рисования, существующим в графических программах, не говоря уж о Кривой Безье. Кроме как в Автофигурах, в Publisher этот инструмент отсутствует. Но и в Автофигурах это не инструмент, а готовое решение Microsoft, позволяющее вам нарисовать кривую линию, в том числе замкнутую, как у нас.

Скажем относительно узлов. Один узел кривой не равнозначен другому. Хотя все участки, по сути, понимаются программой одинаково, то есть как кривые Безье (именно по такой формуле они рисуются), узлы графическая программа не желает воспринимать одинаково.

Дело в том, что узлы воспринимаются графическими программами и делятся соответственно на три категории: острые, гладкие и симметричные. Названия эти очень условны, ибо острыми в геометрии мы привыкли называть только углы. А гладких углов, к примеру, и вовсе не существует в природе. Симметричный угол мы еще как-то можем себе представить (допустим, угол, симметричный другому углу, то есть находящийся на другой вершине многоугольника), но гладкий... Сглаженный, что ли?

Да, оказывается, «Сделать узел сглаженным» — термин, знакомый программе CorelDRAW. Но не Кварку. И уж тем более не Publisher.

А чем же узлы отличны друг от друга?

Оказывается, симметричный узел, если мы вмешиваемся в него и начинаем править при помощи инструмента Элемент, меняет положение и форму кривой соответственно и в ту, и в другую стороны (подпути изменяются одновременно, а вспомогательные маркеры симметрично удаляются или приближаются к основному маркеру узла и друг к другу).

Изменять форму кривой можно многими способами:

  • двигая в ту или иную сторону по странице сам узел;
  • двигая один из вспомогательных маркеров;
  • задавая решения непосредственно кнопками Панели Реквизитов.

Есть и другие способы, но нам достаточно хотя бы потому, что никакой Панели Реквизитов в Publisher не наблюдается.

Гладкие узлы меняются более лояльно, чем симметричные. Вспомогательные маркеры предшествующий и последующий не равноудаляются (равноприближаются), а каждый ведет себя более свободно, чем симметричные маркеры. Однако при этом они постоянно находятся на одной прямой, что очень важно: таким образом, узел гладкий никогда (если не будет на то вашего отдельного решения) не превратится в острый или симметричный.

Другой тип узла. Потянем за предшествующий (левый) маркер такого узла и увидим, что правый маркер остается на месте. Следовательно, на изменения предыдущего пути остальная кривая никак не реагирует. То же произойдет и с правым маркером. Так ведет себя острый узел.

В Publisher все принципы понимания узлов, конечно, те же, что и в других приложениях, но авторы не захотели «нагружать» этой информацией пользователя и решили проще — превратили все узлы изначально в гладкие. Только узел называется Точкой (Point). Вероятно, и кривая, как в Кварке, называется Сегментом...

Вот, пожалуй, и вся теория узлов и путей. Буду рад, если вам эта информация хоть в чем-то пригодится.

Итак, мы остановились на Редактировании Узлов.

Теперь эта опция стала активной: вместо Автофигуры я нарисовал Автолинию. Получилась замкнутая кривая, у которой, конечно же, есть узлы. Эту кривую и опцию Редактировать Узлы меню Arrange вы видите на рисунке 31.

Рис. 31. Опция Edit Points меню Arrange

Вызовем эту опцию и получим изображение кривой, на которой возникли все имеющиеся узлы.

Рис. 32. Это узлы, имеющиеся на кривой

Принцип редактирования узлов тот же. Подводим курсор к точке, на которой нет узла, и, захватив мышкой эту кривую, тянет в сторону. После первого мгновения можно отпустит мышь. И вы увидите, что родился новый узел. Таким вот образом меняя форму кривой, я и получил в итоге то изображение, которое вы видите на рисунке 33.

Рис. 33. Новое число узлов кривой

Как видите, не только форма кривой поменялась: изменилось, в лучшую сторону, количество узлов кривой. И еще, насколько я успел заметить, графические сложности с узлами в Publisher преодолены: авторы отказались от множества типов узлов и оставили только один — гладкий. А режим изменения формы кривой — тоже один, эластичный.

Во всяком случае нигде не проглядывается Панель Реквизитов, с которой пользователь имеет дело и в CorelSRAW, и в «навороченном» QuarkXPress, где бы имелись назначения для разного типа узлов. Даже Панель Measurement, которая в QuarkXPress является Контекстной Панелью, здесь находится в своем незыблемом варианте, она существует в основном только для прямолинейных объектов и верстки текста (чего, собственно, и ждешь от верстальной программы). Что касается объектов непрямолинейных типа нашей замкнутой кривой — что ж, для нее можно уточнить координаты и общие размеры по горизонтали и вертикали. А этого уже достаточно. Остальное, как вы только что видели, делается из назначений меню Arrange.

И у нас осталась всего одна нерассмотренная опция — Reroute Connectors (Переназначить Маршрут Размерным Линиям). Возможно, эта опция малосущественна, Размерные Линии (в-Word их называют Соединительными линиями) проставляются редко, да и вообще их можно вполне заменить простыми стрелками (Arrow), чтоб не мучаться. Но раз уж опция есть, значит, есть ее пользователи.

В Publisher назначение Connectors происходит из других источников — либо из меню Insert (Вставка), либо с Панели инструментов (кнопка Автофигуры). У назначения Размерных Линий есть одна специфика. Эту линию можно нарисовать и в пустом пространстве, когда Линию не к чему привязать. Она нарисуется, будет существовать и даже редактироваться. Но по большому счету размерная линия в черчении показывает расстояние от одной определенной точки до другой (чтоб потом над нею указать истинный размер) и, соответственно, должна иметь жесткие привязки с той (начало ее) и другой (конец) стороны. Если вы рисуете Connector на чистом листе, крайним точкам Линии деваться некуда, они ни к чему не привязаны, поэтому простое выделение такой Линии даст возможность тут же поменять ее Маршрут (Путь), поскольку начальная и конечная точка обозначены зелеными круглыми маркерами. Но если вы Линию привязали...

Для того, чтоб показать, как это делается (к сожалению, без промежуточного рисунка), я нарисовал еще одну автофигуру (ромбик) и условно провел между двумя автофигурами Размерную Линию. Вы видите это на рисунке 34.

Рис. 34. Connector между двумя автофигурами

Привязывается она к контуру очень просто. Курсор подводится к одной автофигуре — и ее контур принудительно выделяется, причем на нем обозначаются синим цветом все узлы. Точка начала рисования Размерной Линии притягивается к ближайшему узлу, и если это тот самый узел, который вам нужен, вы щелкаете в этом месте кнопкой мышки. Потом без всяких щелчков и протягиваний (впрочем, и протягивание не повредит, хотя оно и будет лишним) ведете курсор к другой фигуре, и на ней тоже вспыхивают узлы. Ваша задача — подвести вспомогательную штриховую линию, которая возникает в процессе этих манипуляций, к тому узлу второй фигуры, который нужен вам. Там-то и состоится второй щелчок мышки. Перед вами появится Размерная Линия — именно такая, как на рисунке 34. Оба маркера этой Размерной Линии приобретают красный цвет. Это значит, что они сейчас «заперты» и не могут редактироваться: Путь Линии определен. Вы никуда не сдвинете эту Размерную Линию, даже если бы захотели.

Именно для такой ситуации существует команда Reroute Connectors (Переназначить Маршрут Размерной Линии). Выделив Размерную Линию, вы активизируете эту команду меню Arrange и можете щелкнуть на ней. Оба маркера Размерной Линии становятся подвижными. Это значит, что вы можете переназначать их Путь. Причем по мере того, как вы переназначили один маркер, потом другой (перенесли их в другие точки-узлы, даже другой фигуры, как это проделан мною на рисунке 35), они точно так же имеют свойство притягиваться узлами лк бой фигуры, в том числе и не автофигуры, а, к примеру, Текстового Блока, Если в) какой-то маркер бросите на полпути и он повиснет на свободной части рисунка, о так и останется зеленым, пока вы не подведете его хоть к какому-то узлу.

Рис. 35. Переназначили Размерную Линию

Теперь, если вы в который раз перерешите, вам опять придется выделять мерную Линию и вызывать команду Reroute Connectors.

Ну, вот, кажется, и закончилось меню Arrange. Впереди — меню Window и Help (Окно и Помощь).


Глава 1

Меню «Окно» и «Помощь»

Это два стандартных меню, применяемых в Windows. Программа Publisher не стала исключением и предлагает нам так же, как и любое приложение, и стандартную Помощь, и манипуляцию с окнами.

Откроем меню Window (Окно).

Рис. 1. Меню Window

Вы видите, что здесь фактически всего две опции. Третья, с именем нашей публикации, существует для того, чтоб мы не забыли, в каком именно окне сейчас работаем — на тот случай, если у нас одновременно открыты не одна, а несколько публикаций. Впрочем, для того же случая и обе первые опции меню — Arrange All (Упорядочить Все) и Cascade (Каскад, Все Окна разместить Каскадом). На рисунке 354 вы видите действие как раз второй опции — Каскад.

Вы видите, что здесь фактически всего две опции. Третья, с вменен нашей публикация, существует для того, чтоб мы не забыли, в какой именно окне сейчас работаем — на тот случай, если у нас одновременно открыты не одна, а несколько публикаций Впрочем, для того же случая и обе первые опции меню — Arrange All Упорядочить Все) н Cascmlf (Каскад, Все Окно разместить Каскадам).

Рис. 2. Окна Каскадом

Упорядочение будет видно только тогда, когда мы откроем еще что-нибудь. У нас есть на этот случай Публикация 2. Ее и откроем, чтоб убедиться в том хотя бы, что опция Упорядочить Все в программе Publisher находится в рабочем состоянии.

Рис. 3. Упорядочили Все, и все в порядке

Как видите, окно разделилось на две равные части — одна для одной Публикации, вторая — для другой. Все, что не умещается в ширину окна (допустим, Строка меню), стало в два ряда. Так что меню Окно все равно доступно.

Такое Упорядочение бывает нужно часто — ибо вы одновременно открывает две публикации не для того, чтоб одна из них ждала своего часа, а чтобы работать одновременно с двумя.

Обратите внимание (рис. 4): теперь в меню Window уже не три строчки, а четыре. Добавилась строка с именем Публикации 2. Флажок напротив имени публикации говорит о том, как я уже сказал, что вы в данном окне находитесь в Публикации номер 2, а не номер 1.

Рис. 4. Меню Окно после открытия Публикации 2

После выключения одного из документов исчезает и второе окно. Однако первое окно так и продолжает оставаться в половину экрана. Что делать?

Опять вызовите команду Упорядочить Все, и ваше окно распространится на весь экран монитора.

Ну, на этом наше короткое знакомство с меню Window и заканчивается. Перейдем к меню Help (Помощь, Справка).

Рис. 5. Меню Help

Видите, оно тоже небольшое. Вызовем первую опцию — Microsoft Publisher Help (переводить нечего, и так все ясно). Однако вместо привычного окна Справки. как мы давно уже привыкли, начиная с Office 2000 перед нами является — как бы избавиться-то от него? — пресловутый Помощник Скрепка. Хорошо хоть вопрос задать не забыл (такой своеобразный Диалог предлагает нам Корпорация Майкрософт — говорю только для начинающих).

Рис. 6. Вызвали первую опцию

Вопрос его (рис. 6) звучит так: «What would you like to do?» (примерно. «Что вы желаете найти?»). И ниже, в поле ввода запись, которая исчезнет, едва вы начнете писать необходимое вам слово. Запись такая: «Type your question here and then click Search» (Введите ваш вопрос и нажмите кнопку Search — Найти).

Вот здесь нас ждет разочарование. Уж не знаю, кто и зачем составлял эту Справку, но программа, кажется, ни одного слова из своего же арсенала не знает. Как вы догадываетесь, искал я совсем недавно слово Snap (о загадке этой опции я уже говорил). Нет, программа не знает собственной же команды. Давайте убедимся: я опять ввел слово Snap и занялся поиском, сказав Найти. Вот что предлагает теперь Помощник:

Рис. 7. Предложение Помощника

Да-да, он попал в точку. Именно все, что касается «Снапа» (или Снупа?) в отношении объектов и направляющих, нас и интересовало. Впрочем, Помощник предлагает три варианта поиска: первый — Turn on and off the Snap to Commands (Вернуться к Snap как команде — ? — не везет мне все же со Снапом, не могу и это перевести), второй — Snap objects to guides (Снап объектов на направляющих), или третий — поискать ответ в Интернете. Третье — полная чушь, поэтому рассмотрим первый и второй варианты. Щелкаем на втором варианте, и...

Рис. 8. Пустое окно Справки и Помощник с теми же гиперссылками в зубах

Щелкнем по первому варианту — может, повезет?

Рис. 9. Справка девственно пуста

Нет. не повезло.

Вообще я достаточно много всегда говорил о Справке, потому что дебильное построение Справочной системы — это видимо, некая национальная черта разработчиков программ-приложений. За всю историю пользования ПК я видел только одну приемлемую Справку — в программе CorelDRAW, да и то это была аж шестая еще версия.

И вы можете не биться головой о стену: преспокойно щелкайте всеми возможными кнопками закрытия этой опции и больше не возвращайтесь к ней. Правда, в Указателе еще можно найти какие-то штук двадцать несущественных понятий и получить на них невразумительные ответы, но не больше. В Интернете, клянусь, вы также ничего не найдете: просто программа усиленно внушает пользователю, что без Интернета ему — никуда. Кроме лишнего хождения по сети (а это денег стоит!) и траты нервов вы ничего не получите.

Перейдем ко второй опции. Это... Ох, это же Show the Office Assistant (Показать Офисного Помощника)! Ну, ладно, только для вас я щелкну на этой опции:

Рис. 10. Офисный Помощник и его контекстное меню

В Офисе Помощник существует давно, с какой-то версии Office 97. У него изначально есть некоторая специфическая черта — щелчком по Помощнику первой кнопкой вы вызываете функциональный диалог по поиску ответов на вопросы, а щелчком второй кнопкой — Контекстное меню, в котором четыре опции — Hide (Скрыть Помощника) — слава Богу, разработчики понимают, что он скорее раздражает, чем помогает, — Options (Параметры), Choose Assistant (Выбрать Помощника) и Animate! (Мотор!). Скрывается Помощник бесследно, Параметры... и Выбрать... вызывают один и тот же диалог, где действительно можно выбрать Помощника из числа других изображений (прежде, на мой взгляд, было поинтересней, хотя все, кроме Скрепки, плохо). Команда Мотор! заставляет существующего Помощника исполнять всевозможные превращения, о которых я уже много говорил, рассказывая в разных книгах — и об Офисе, и конкретно о «Ворде». Оставим на сейчас эту тему.

Опции Office on the Web... (Офис на Web...) и Activate Product... (Активизировать Программу...) — чистой воды надувательство, заставляющее вас лишний раз засветится в Интернете и заполучить на свой лоб клеймо. Кроме вреда, никакой пользы две эти опции для вас не несут.

А вот опция Detect and Repair... (Поиск и Восстановление...) — опция, судя по задумке, очень хорошая. Программа сама, без вашего вмешательства, проверит самое себя и восстановит свои же настройки. При этом не забудьте закрыть все файлы, созданные в этой программе, потому что если Publisher станет выполнять опцию на открытом файле, он может пострадать. Впрочем, это услуга не Publisher, a Office, и идет она еще глубже — у нее «ноги растут» из Windows XP. Это, в общем-то, ее «революционные» услуги.

И последняя опция — About Microsoft Publisher (О Microsoft Publisher). Она выдает диалог с общими сведениями о программе. Ради интереса взглянем.

Ну, вот, кажется, и все. Строку командных меню мы осилили, причем, как мне кажется, не без пользы для дела: пока мы бродили по опциям меню, мы выяснили, зачем и как работает та или иная опция, где ее, в конце концов, искать. Во всяком случае, изучив меню, вы сможете вполне ориентироваться в приложении, не прибегая почти не прибегая к поискам желаемого инструмента или необходимой команды. Теперь вы знаете, где что найти.

Меню иссякли, но не иссякла наша жажда работать в программе Publisher.

Впереди — некоторый практикум, который мы постараемся в подробностях не обижать, по крайней мере не скупиться в них.

Итак, практическая верстка.


Глава 1

Меню «Формат» (II)

Ну, и взглянем уж еще на один вариант, поскольку здесь каждая строчка со своим именем. Сколько еще останется вне этой книжки! Но — взглянем:

Рис. 35. Вариант Fire (Огонь)

В поле Вариантов, если вы заметили, в назначении Preset присутствует и обратный, негативный вариант, как отдельно взятая заливка.

А поле Sample тало активным, как только мы сделали самое первое назначение. На протяжении всех рисунков, что мы просматривали, Образец показывал нам, какая приблизительно заливка ждет нашу страницу.

Это, не совсем все. Мы не обращали внимания на нижнее поле, где вариант градиентной заливки собраны по геометрическому принципу — горизонтальна вертикальная, диагональная и т. д. Понятно, что направление, поворот и так далее иногда помогают и художественному решению, и макетированию. Но откроем вторую вкладку — Текстура (Texture).

Рис. 36. Открыта вкладка Текстура

Надо ли говорить, что чаще всего в качестве фона для страницы подходит именно какая-нибудь неброская, но благородная текстура. Причем благородство не в том, чтоб она была похожа на мрамор или изумруд. Наоборот, как в театре мешковина смотрится самой настоящей парчой, так и в полиграфии иногда что-нибудь вроде Мятой бумаги решает большие эстетические задачи.

Откроем вкладку Pattern (Модель).

Рис. 37. Вкладка Модель (Pattern)

Не знаю, отчего все то, что мы видим, назвали Моделями. Скорее это образчики разного рода штриховки и геометрических сочетаний. Впрочем, возможно, образчик и Модель в Америке называются одним словом. Для нас слово Модель при обрело уже иное звучание — это что-то изысканное. Или, второе значение, то, уменьшено, но сделано так, что все пропорции соблюдены. К примеру, авиамодели которыми, наверное, и посейчас увлекается какая-то доля школьников, хотя давя перестали существовать Дома пионеров. Ну, да не о этом речь и забота. Назвали так назвали.

Для фона страницы, мне кажется, отсюда мало что можно выбрать. Хотя назначить очень небольшой процент цветовой насыщенности (они не только черв белые, можно назначить и другие цвета), возможно применять и для фона. Во всяком случае вкладка не лишняя.

Рис. 38. Вкладка Picture

На вкладке ничего нет — пустая... Пока не щелкнули кнопкой Select Picture... (Выбрать Изображение).

Тогда появляется диалог поиска и вставки рисунка. В нем с помощью Навигатора или одного лишь Адресного окна вы найдете тот рисунок, который пожелаете вставить. Программа не заготовила рисунков отдельно для этой вкладки. С помощью диалога вы найдете лишь свою собственную коллекцию, которой, кстати, может и не оказаться — в зависимости от того, занимались вы или нет коллекционированием ценных (на ваш вкус) изображений. Но есть несколько изображений Windows XP. Вот одно из них я и поместил, использовав кнопку Insert диалога поиска и вставки, в окно просмотра вкладки Текстура. Вот оно, изображение, на рисунке 39.

Рис. 39. Наш рисунок (фото) в окне просмотра и в Образце

Не могу удержаться, чтоб не показать вам его на странице в качестве фона 40). Попутно выясняем важную деталь: мостить поверхность изображением программа начинает сверху. Об этом можно судить по тому, что нижняя часть нижнего рисунка обрезана, поскольку не поместилась на лист.

Рис. 40. Изображение— на страницах

У нас осталась последняя вкладка диалога: Tint (Оттенок). Это градуированный одноцветный фон. Выбор — пошаговый. Выбор же самого цвета, оттенки которого назначаются, осуществляется в поле списка Base Color: (Базовый цвет:).

Рис. 41. Последняя вкладка — Tint (Оттенок)

Ну, с заливкой, кажется, покончено. Теперь мы можем смело сказать, что заливать страницу в целом научились. Идем дальше.

Ни за что не догадаетесь, какую опцию представляет гиперсвязь Background sound... (Фоновый звук...).

Оказывается, когда мы щелкнем на гиперсвязи Фоновый звук, возникнет диалоговое окно Web Options (Параметры Web).

Что ж, следовало ожидать. Еще бы в опции Заливка не найти пути к Web! Покажем лишь сам этот диалог, но ни вкладок, ни самого Фонового звука, который фигурирует-то там мимоходом, рассматривать не станем.

Рис. 42. Диалог Web Options

Ну, наконец с этой опцией — Докером и диалогами — покончено. Перейдем другой строке меню. Это не что иное, как Стили и Форматирование... (Styles Formatting...). Докер, который возникает при вызове этой опции, нам знаком, взглянем на него еще раз:

Рис. 43. Докер Стили и Форматирование

Что ж, конечно, Стиль, а особенно Форматирование — та самая опция, ко рой Бог велел содержаться в меню Format. Стиль и Формат определяют лицо, брошюры, журнала, газеты, листовки и так далее. Стиль служит и еще некоторым важным функциям, в частности созданию Оглавления, Списка, Комментария, Примечаний и так далее. Без Стиля невозможна верстка, потому что, назначая множество раз одно и то же для соответствующих друг другу по функциям элементов пользователь, не применяющий Стилей, рискует ошибиться. Возможно, исправлять ошибки будет уже поздно...

И последняя опция меню — Format Text Box... (Форматирование Текстовое Блока...).

Рис. 44. Диалоговое окно Format Text Box

Как видите, здесь решается полное «лицо» Текстового Блока. Назначается заливка блока, вид границы и так далее. Я вот«не удержался и, вместо того чтобы рассказывать все по порядку, решил показать вам хоть кусочек того, что может получиться при сочетании фона страницы и заливки Текстового Блока.

Рис. 45. Установили Фон для страницы и заливку Текстового Блока

To, что, вы видите, случилось с текстом КНИГА О ПРИРОДЕ, назначено мною — из опции Шрифт меню Формат. Я придал шрифту цвет (желтый), и он теперь смотрится на фоне заливки, мне кажется, достаточно солидно.

Но вернемся к диалогу Формат Текстового Блока. Обратите внимание на рисунок 44. В списке Color: (Цвет:) открывается не только меню с набором цветов. Там есть еще и опция Fill Background... (Заливка Фона.,.), уже очень знакомая нам. Тол ко теперь она относится уже к фону Текстового Блока. Вот с помощью этой-то опции назначил я фон для КНИГИ О ПРИРОДЕ. Взгляните на диалог — он тот же самый, которым мы только что расстались.

Рис. 46. Знакомый диалог

Возобновлять рассмотрение диалога мы не станем. Я показал его лишь для сведения. Идем дальше.

Ниже поля Цвета находится строка с бегунком для регулировки Прозрачности выбранного цвета (Transparency). На рисунке 47 я показал, что выбрал для примера красный цвет и движком установил Прозрачность 65%. Соответственно плотность оставшегося красного — 35%. Вы видите этот цвет в окне просмотра.

Рис. 47. Прозрачность красного цвета

Но нам не нужен никакой цвет, ибо мы не собираемся пока что расцвечивать наши текстовые блоки, поскольку не имеем перед собой никакой задачи, кроме задачи экспериментально изучить, как ведет себя опция. С Прозрачностью тоже вроде все ясно.

Ниже строки с Прозрачностью существует поле Line (Линия). У нас в поле списка Color: (для линии!) записано по умолчанию No Line (Линии Нет). Откроем список и найдем, что в меню с выбором цветов Линии есть строка Patterned Lines... (Модельные Линии...). Позовем этот диалог.

Рис. 48. Диалог Patterned Lines, вкладка Tint. Открыто поле Базовый Цвет:

По умолчанию диалог открывается на вкладке Tint (Оттенок). Здесь вы знакомый нам Список, или Палитру цветовых Оттенков. Впрочем, цветовыми оттенками это очень сложно назвать, ибо это оттенки только одного цвета — не палитры.

Линия Текстового Блока — очень важный параметр для верстки. Потому если уж существует Текстовый Блок, и у него есть границы, нет никакого смысла рисовать отдельную рамку, если она потребуется. Достаточно назначить формат линиям самого Текстового Блока:

Ну, кажется, больше на вкладке Tint нам делать нечего. Назначим лишь черный цвет линии. И перейдем на вкладку Pattern (Модель). Воронин «Универсальная программа вёрстки — Microsoft Publisher 2002 ХР

Рис. 49. Вкладка Pattern, открыт список Foreground

Здесь понятия Foreground и Background желательно вернуть к их дословному переводу — Передний План и Задний План. В списке-меню Передний План вы опять видите знакомую нам опцию Fill Effects... (Эффекты Заливки...). Но когда мы откроем ее, то получим знакомый нам диалог с одной только вкладкой Tint (Оттенок).

Рис. 50. Диалог Fill Effects с одной вкладкой Оттенок

Здесь не разгуляешься, да и не нужно. Заметьте, по умолчанию уже назначен оттенок 100% черного цвета. И Образец (Sample) нам тоже показывает его. То же мы обнаружим под списком Background. Только там — сто процентов белого.

Нам нет смысла придумывать для блока фигурно разрисованную границу, хотя теоретически это возможно. Ведь любая Модель при наших назначениях не может правильно и эффективно уместиться в толщине линии. Впрочем, линия может быть толщиной 10 пунктов, так что, глядишь, место найдется.

Не станем делать этого назначения, оставим No Line.

А в общем смысле, конечно, при выборе назначения мы должны были бы получить активной строку Dashed (Штрихованная) и соответственно стали бы подбирать характер штриха: Впрочем, к штриховой линии Модель никак не лепится: при назначении Штриха он, этот штрих, превращается в основную линию, и назначения Pattern уступают ей место.

Модельную линию границы Текстового Блока мы могли бы, к примеру, назначить такую:

Рис. 51. Возможная линия границы фрейма

Заметьте, вокруг окна просмотра разбросаны знакомые нам по Word кнопки назначения границ. Этими кнопками можно ведь и отменить границы: они могут быть назначены после тщательного выбора, и четырьмя кнопками той же программы низведены до нуля.

Хотел идти дальше, но вспомнил про кнопку BorderArt... (Художественное Окаймление). Откроем ее, эту кнопку... И получим диалог:

Рис. 52. Диалог Border Art

Этот диалог практически говорит сам за себя, и рассматривать его в больших подробностях не имеет смысла. Все назначения диалога понятны без специального заострения внимания. Так что не стану ни комментировать, ни подсказывать.

Идем дальше. Другая вкладка диалогового окна Text Box — Size (Размер).

Рис. 53. Вкладка Size (Размер)

Здесь, как видите, с точностью до тысячной доли сантиметра выведены размеры Текстового Блока. Поле Size and rotate (Размер и наклон, поворот) не только дает представление об истинных размерах блока, но и позволяет в поля ввода ввести! ваши точные значения. Причем с той же упомянутой точностью. Поворот можно осуществлять также введением в поле ввода своих конкретных значений. А можно и вручную, инструментом Стрелка, и лишь потом уточнять по вкладке правильность! поворота.

Можно изменить пропорции Блока, изменив одно из значений — Высоту (Height); или Ширину (Width) его в поле Scale (Масштаб). Если же поставить флажок в строке Lock aspect ratio (Соблюдать все пропорции), Блок станет изменяться пропорционально изменению одного лишь какого-то параметра.

Переходим ко вкладке Layout (Схема, План).

Рис. 54. Вкладка Layout

Здесь вы видите поле Wrapping Style (Стиль Обтекания), где на пиктограммах, работающих как ссылки-назначения, можно выбрать конкретный стиль обтекания текстом объекта. Возможности Publisher в этом смысле обширнее, чем у PageMaker, ибо назначения обтекания не по кадру, а по содержанию кадра (взгляните на условного пса, которого обтекает текст) в PageMaker просто не существует. Мало того: даже когда мы вручную настраиваем контур обтекания и добиваемся-таки подобного обтекания, все равно сталкиваемся с некоторыми сложностями. В QuarkXPress такой способ обтекания предусмотрен, но сопряжен с трудностями иного рода: там прежде надо назначить поиск пороговых значений плотности цвета, потом отделить «белое» от «черного», и уж потом можно назначать это обтекание. Здесь же, насколько я понимаю, все должно происходить автоматически. Тогда Publisher — программа, шагнувшая в этом отношении далеко вперед.

Выбрав Стиль Обтекания, мы можем перейти к полю Wrap text (Обойти, Обтечь текстом): по умолчанию — Both sides (С обеих сторон), далее — Left only (Только слева), Right only (Только справа) и Largest only (Только обшир ные). В последнем случае, вероятно, имеется в виду, что мелкие детали изображения программа может (и умеет?) игнорировать. Но такой точности я думаю, не нужно. И вообще в верстке этот случай достаточно редок. Как бы то ни было, если вы досконально и мастерски овладеете верстальной программой и вам все станет нипочем, и то, думаю, года два-три вам эта от не понадобится. Хотя кто ее знает...

В поле Distance from text (Отступ от текста) по умолчанию программа задает 0,1 см, то есть один миллиметр. Вы можете снять флажок Automatic (надеюсь, переводить не надо) и установить те дистанции по левому, правому краям, сверху и снизу, какие вам захочется или какие диктуются необходимостью.

В поле Position on page (Позиция на странице) отражаются координаты:) в нашем случае Horizontal — 6 см от левого края, Vertical — 1,27 см от верх« него края. Можно назначить и отсчет от правого края, и от центра. В каждой конкретном случае это зависит от задач и макета.

Вкладку Picture (Изображение) пропускаем: она неактивна, поскольку мы занимаемся текстом. Идем на вкладку Text Box — Текстовый Блок (рис. 55).

Обратите внимание: впервые в верстальных программах встречаю oпцию... Выравнивание текста по Вертикали! Это особенно относится к нашему фрейму, куда я забросил лишь парочку абзацев с предыдущей страницы книги, чтоб поговорить об обтекании текстом. Текстовый Блок имеет! большой размер, и текста двух абзацев явно не хватает, чтоб его заполнить. В этом случае, обратите внимание, в верхнем поле, которое называется! Vertical alignment (Вертикальное выравнивание) мы сумеем назначить тексту располагаться в самом верху фрейма (Тор), в самом низу (Bottom)! или в центре, середине (Middle). Все это сопровождается соответствующей! упрощенной анимацией, где изображенные линиями строчки не имеют непосредственного отношения к конкретному тексту и обозначают его условно.; На рисунке 55 вы видите выравнивание по самому верху.

Рис. 55. Вкладка Text Box

В поле Margins (Края) вы видите четыре одинаковых значения — 0,1005 см. Это отступы текста от границ Фрейма. Вы можете с помощью счетчиков или вручную задать требуемые отступы или оставить все по умолчанию.

Поле Text autofitting (Текстовые установки). В нем три позиции — None (Нет), имеющаяся по умолчанию, Resize text on overflow (Растянуть текст до краев — имеются в виду края фрейма) и Best fit (Подогнать наилучшим образом).

Я не знаю и не вижу разницы между второй и третьей опцией. Заметил только, что при пользовании второй (растянуть до границ фрейма) текст растягивается под самую нижнюю границу, а при использовании команды Best Fit — остается одна строчка до нижней границы. Как верстальщик я это хорошо понимаю. Ведь Наилучшим образом, на мой взгляд, как раз так и есть — оставить возможность впечатать начало продолжения текста, если он вдруг увеличился на значительное число строк. При Растягивании до границ текст может занять все свободное пространство, и мы не сможем вставить курсор, чтобы продолжить текст. Только этот принцип нашел я для определения разницы между опциями. Еще: и при том, и при другом назначении делается неактивно!) кнопка Columns... (Колонки...), которая расположена ниже.

Но идем на нижнее поле. Там три опции: Rotate text within AutoShape by (Наклонить текст на 90 градусов, как автофигуру), Include "Continued page..." (Включить «Продолжение на странице...») и Include "Continued fron page..." (Включить «Продолжение со страницы...»). Убей Бог, не пойму, что кое две последние опции. То ли это назначение, то ли это текст... Для меня эти две строчки остаются загадкой. Может быть, все выяснится в процессе верстки?..

По крайней мере действие первой опции вы видите на рисунке 56.

Рис. 56. Повернули текст на 90 градусов

Рис. 57. Диалог назначения колонок

В верхней строке Number (Число) можно назначить желаемое число колонок на полосе. Как правило, их не бывает больше 4-5, но и то если размер листа газетной полосы соответствует формату A3. Правда, в газете «Правда» в свое время было и по восемь колонок, но там ведь и формат листа А2! На формате А4 оптимально — 2-3 колонки, не больше. Взгляните на диалог: гаттер (интервал между колонками), который здесь именуется Spacing (Шпацингом) очень велик. Не бывает в профессиональных газетных и книжных изданиях такого гаттера. Ну, 1,0 см, ну, 0,8 см — еще ничего. Как правило, достаточно интервала 0,5 см. Газета «Мир новостей» и журнал «Отдохни», насилуя читателя, частенько устраивают гаттер 3, а то и 2 миллиметра (это тоже уж слишком).

Изменим Spacing и установим две колонки:

Рис. 58. Наши назначения

Говорим ОК. После этого говорим ОК и в диалоге Text Box. И наши колонки — на странице публикации. Правда, пришлось подтянуть ни Блока до нужного уровня, ибо текста на две колонки не хватало.

Рис. 59. Вот и колонки

Теперь остается совсем немного — отверстать эти колонки как следует. Именно для того программа и существует. Но мы пока что оставляем это занятие и спешим на последнюю вкладку диалога, чтобы...

Рис. 60. Последняя вкладка диалога

...чтобы отказаться от назначений в ней — это же Интернет!

Итак, мы вроде бы добрались до конца меню Format.

Но это не все. Помните вкладку Picture? Мы не сумели ее рассмотреть, потому что...

Обратите внимание: когда вы выделяете не Текстовый Блок, а Рисунок, то и в меню строка Text Box... автоматически исчезает и появляется вместо нее строка Picture....

Рис. 61. Меню Format со строкой Picture... (Изображение...)

И это не все. Если мы нарисуем автофигуру, вместо этой строчки появится строка AutoShape... (Автофигура...).

Но обратимся к строке Picture... и откроем диалог Форматирования Изображения.

Рис. 62. Диалог Форматирования Изображения

Вы видите, диалог открылся на вкладке Picture. Хотя другие вкладки не менее важны. Но рассмотрим, конечно же, сначала эту вкладку.

Сверху же получаем поле Crop from: (Обрезать с:). И указаны, конечно же, все четыре стороны рисунка, с которых его можно обрезать. Во всех четырех .окошках полей ввода (Left, Right, Top, Bottom) вписано по умолчанию, слава Богу, по нулю. Хоть рисунки и приходится довольно часто обрезать, я стараюсь это сделать до вставки. А тот случайный портрет девочки, который я использую для примера, обрезан в Фотошопе именно для того, чтоб сам портрет носил некий характер художественного произведения, и обрезать его дальше просто некуда.

Еще вы, наверное, заметили, что в программе Publisher отсутствует такой важный инструмент, как инструмент Обрезки Изображений. Теперь нам ясно, что обрезка рисунков осуществляется только из меню Format. Или еще найдем этот инструмент?

Обрезать не станем, смотрим дальше. Ниже находится поле Image control (Управление изображением). На самом деле его можно назвать не Управлением, а Редактированием. Строка Color: (Цвет:) со своим полем ввода или списка редактирует цвет изображения. Откроем список:

Рис. 63. Открыли список Color:

Да, в самом деле. Кроме строки Automatic (Автоматически), здесь есть и Graysc (В серых тонах, восьмибитовый), и Black & White (Черно-белый, однобитовый), Washout (Размытый, в дымке — но цвет не исчезает).

Рис. 64. Так выглядит изображение с назначением Washout

Кстати, дословно Washout — Полный неудачник.

Ниже находятся два движка с полями ввода — это Brightness (Яркость) и Contrast (Контрастность). Здесь можно менять и то и другое. Заметьте, по умолчанию установлено на ту и другую опцию по 50%. То есть, на мой взгляд, сделано гораздо удобнее, чем в Photoshop, где изменения яркости и контрастности начинаются каждый раз с нуля. Это мешает ориентироваться в абсолютных величинах, и никогда не знаешь, достаточно ли яркости или контрастности, пока не выведешь изображение на принтер. Здесь применен принцип старого черно-белого телевизора, когда мы регулировали то и другое ручками резисторов и твердо знали, на какую долю вправо или влево повернуть ту и другую. Психологически «побольше» и «поменьше», на мой взгляд, ассоциируется именно с 50 процентами, «золотой серединой»,а никак не с нулем.

Ниже есть две кнопки. Нажав первую — Recolor... (Исправление цвета...), мы вызываем диалог, изображенный на рисунке 250.

Рис. 65. Диалог Recolor

Вы можете открыть список-меню Color: (Цвет:), уже очень известный нам, и внести в цвет свои коррективы. Широкая кнопка Restore Original Color (Восстановить подлинный цвет) после щелчка на ней восстановит все, над чем вы поиздевались всласть. Это в диалоге Recolor.

В диалоге же Picture есть другая кнопка. Кнопка Reset (Восстановить) ликвидирует все те же издевательства в большом диалоге. Достаточно щелкнуть на ней, и состояние всех настроек придет к тому, что было по умолчанию.

Ну, эта вкладка нами пройдена. Давайте пройдемся по диалогу справа налево. Web не трогаем. Следующая вкладка — Layout (План, Схема). Здесь все почти так же, как в случае с текстовым блоком. За исключением того, что стала активной опция Object Position (Позиция Объекта). В поле списка вписано Exact (Точная) и Inline (Неточная, «Не в линию»). Конечно, оставим Точную: если мы вставляем рисунок, то уж наверняка знаем, куда и зачем.

Рис. 66. Вкладка Layout

Идем на другую вкладку — Size (Размер).

Рис. 67. Вкладка Размер

Здесь, кажется, все ясно. И радует кнопка Reset для восстановления всего того, что было, в лучшем виде.

Идем на вкладку Color and Lines (Цвет и Линии).

Рис. 68. Вкладка Color and Lines

Заливать рисунок мы, конечно же, не станем, хотя это и можно было бы проделать. Во всяком случае, не каждое изображение не может подвергнуться такой экзекуции. Правда, по умолчанию, слава Богу, указано, что никакой заливки нет (No Fill).

А вот с линиями вокруг рисунка вы столкнетесь часто. В PageMaker такой опции нет, и когда необходимо установить вокруг иллюстрации тонкий контур, приходится изощряться. Неудобство там главное состоит в том, что, как только вручную нарисуешь очень точный прямоугольник, а сделать это можно лишь прямо по контуру рисунка, то выделить и контур, и рисунок — становится настоящей проблеме Не помогает увеличенный масштаб: маркеры выделения исчезают, остаются за кадром. А выделение нужно для того, чтоб сгруппировать рисунок с контуром — последующих изменений размеров, которые в верстке очень часты.

Для чего нужно оконтуривание рисунка?

Часто фотографии содержат очень светлые края, которые теряются в публикации. Это вопрос, в первую очередь, не к верстальщику, а к фотографу или художнику, но расквитываться за этот недостаток приходится именно верстальщику...

В Publisher все проще: достаточно назначить границу фрейма в виде тонкой (до 0,25 pt) линии, и линия уже никуда от рисунка не уйдет, не потеряется при разгруппировании всего. Команду разгруппирования всего также часто приходится выполнять, чтоб изъять что-то одно и потом на это место вклеить (вставить) что-то другoe. Особенно эти занятия изматывают верстальщика тогда, когда заказчик га или журнала стоит над душой и в тот момент, когда, как вы считаете, все готов говорит:

— Ой, а не переместить ли нам вот это вот сюда? Мне кажется, так буде лучше.

Вы-то видите, что ничего не лучше, образуется неоправданный перекос, дырка, или еще что-нибудь... Но хозяин — барин! Это уж потом он именно вас обвинит в той «дырке», а сейчас...

Очень полезный совет: никогда не верстайте при заказчике!!!

Во-первых, по той причине, о которой я сказал (также и по множеству других). А второе — и очень важное — это то, что, глядя, как вы ловко управляетесь опциями сложной программы, он может подумать, что это легко, а значит, он сильно переплачивает вам. 99,99% заказчиков не могут оценить вашего мастерства!!!

Поэтому никогда не позволяйте заказчику присутствовать при вашей работе. Сошлитесь на занятость и переложите его заказ в ящик, в дальний угол, при этом назначив срок хотя бы на денек попозже, чем вам самому хочется. Деньги подождут, а престиж сохраните.

Те же слова можно отнести и к начальству. Редкий начальник прошел ста дню верстки и вполне понимает, что это такое. А ваши проблемы, когда вы то хотите решить наилучшим образом и задумались, он поймет как непрофессионализм или отлынивание. Материальная зависимость — страшное дело. Советская власть если и была положительным в чем-то явлением, то только в то» что вас никто не мог обвинить в том, что вы получаете жалованье.

На этом закончим «лирическое отступление».

Беремся за Автофигуры.

Нарисуем автофигуру (любую) и вызовем тот же диалог из меню Format.

Рис. 69. Диалог Format AutoShape

Здесь активны все вкладки, кроме Text Box и Picture.

На рисунке 69 показана вкладка Color and Lines. Здесь кое-что изменилось в сравнении с прежними нашими путешествиями по этой вкладке. Для автофигуры, если ее залить цветом, активна вкладка Transparence (Прозрачность), движком которой можно регулировать эту самую прозрачность.

Две другие вкладки (третья Web, с нею и так ясно) — Size и Layout и разглядывать не станем — там все так же, как с форматированием Изображения. За тем только исключением, что кнопка Reset при форматировании Автофигуры не работает (не активна). Понятно: у автофигуры нет регламентированного размера, потому и восстанавливать нечего.

Ну, вот, кажется, меню Format рассмотрено до последней опции. Пора переходить к следующему.


Глава 1

Часть четвертая.
Практическая работа в Microsoft Publisher

  • Верстаем газету (I)
  • Верстаем газету (II)
  • Верстаем газету (III)
  • Верстаем газету (IV)
  • Печать в Microsoft Publisher


Глава 1

Верстаем газету (I)

С чего начать?

Сакраментальный вопрос. Один из трех сакраментальных вопросов русской истории. Правда, задавались они в обратном порядке — видимо, по мере приближения к практике. Сначала — «Кто виноват?», потом — «Что делать?», и уж потом — «С чего начать?». Ленин ответил на последний: «С создания марксистской газеты». Он был по-своему прав, но только по-своему, а нам марксистская газета ни к чему, поэтому начнем с просто газеты. Материала для нее я не подбирал, он будет разношерстный, но, думаю, нам это не столь важно. Важно то, какими средствами станет исполняться эта газета.

Возвращаясь к сакраментальным вопросам, хочу поведать вам одно мое наблюдение (не знаю, задумывался ли кто-нибудь об этом или я первооткрыватель?). Если вопросы в XIX веке стояли в обратном порядке, то начиная с 1917 года они задавались как раз в прямом порядке:

— С чего начать? Выполнили.

— Что делать?

Наделали. Выполнили и перевыполнили.

— Кто виноват?..

Этот вопрос, причем практически, с санкциями — решали весь XX век. В конце концов, и «судей» тоже свергли с пьедестала. Вот она, Россия-матушка. А последний вопрос до сих пор не сброшен со счетов, его решают многие твердолобые товарищи и господа. И всегда находят виноватых.

Но вернемся к газете.

Во-первых, выбираем ее формат. Если прежде полоса газеты была большого формата — А2, то сейчас наиболее популярные издания практически все имеют формат в два раза меньший — A3. Многие газеты приняли даже еще меньший формат — А4, в размер листа обыкновенной писчей бумаги, но это, думаю, неправильно.

Скорее всего, это происходит от бедности. Такие газеты больше похожи на кустарный доморощенный листок, сколько бы полос в них не содержалось.

Выбираем для нашей газеты формат A3. Не только, как оказалось, самый популярный, но и самый удобный. Кстати, одно с другим наверняка напрямую связано.

Пусть газета будет называться как-нибудь просто.

Не дай Бог, чтоб совпало с именем какой-нибудь существующей газеты, — будет неудобно, да и запросят с нас какой-нибудь компенсации за использование названия. От «Новостей», «Мира новостей», «Вестей» и так далее — сразу же отказываемся. Это нам не нужно. «Мегаполис» и прочие типа «Третьего глаза» тоже обойдем стороной. Надо такое название, чтоб оно несло свет разума, просвещения и прочих ценностей общечеловеческого характера.

В свое время было такое издание (правда, оно было журналом) — «Огонек». Чтоб не совпало, можно бы назвать «Фонарь», но это двусмысленно — ассоциируется с «красным фонарем». «Прожектор» успел дискредитировать сам себя, поскольку напрямую связан с прежним режимом. А вот «Светильник» вроде получше. Впрочем, техницизмом отдает. Лампа? «Зеленая лампа» — вроде неплохо... Но тоже ассоциируется уже не с литературой, а с «лампочкой Ильича»...

А может, так и назвать — «Свет разума»?..

В газете можно поместить всевозможные материалы и по истории, и по науке, и по поводу будущего человечества. Этакий, возможно, дайджест... Нет, у нас хватит и оригинальных материалов, ниоткуда не заимствованных.

Правда, кое-какие из них будут не первой свежести: они все же выходили (но очень маленькими тиражами) в последние годы. Это не страшно — ведь я сам их верстал, так что в плагиате (хотя бы по части верстки) меня уже не обвинят.

Итак, пусть газета будет называться «Свет разума».

Будет в ней всего четыре полосы...

Остальное решим по ходу.

Перво-наперво откроем программу Microsoft Publisher. И получим...

Рис. 1. Окно Publisher сразу после открытия программы

Получим Галерею Дизайнов. Она открывается по умолчанию вместе с Докером New Publication.

Договоримся, что все будем делать сами, и поэтому вызываем гиперссылку Blank Publication (Чистая Публикация).

Появилась чистая страница нашей публикации. Но она нас не устраивает. Во-первых, потому, что программа по умолчанию создала для нас страницу формата А4, а нам нужен формат A3. Его размер (точный) — 297 на 420 миллиметров.

Откроем в меню File (Файл) опцию Page Setup... (Установки Страницы...) и исправим положение.

Рис. 2. Чистая страница Blank Publication

Рис. 3. Диалог Page Setup

Вкладка Layout (Схема) этого диалога нам не особенно подойдет, потому здесь нет выбора размера бумаги. Идем на вкладку Printer & Paper (Принтер Бумага), которую вы и видите на рисунке 3. Именно здесь в поле Size (Разме выбираем A3. Ориентацию листа оставим по умолчанию — Portrait (Портрета Книжная).

В верхнем поле выбора принтера оставим все как есть. То есть все назначен для несуществующего в нашем распоряжении принтера Linotronic 930. Он нам (вернее, не он сам, а его параметры) для того, чтобы в самом конце работы печатать в файл (EPS) нашу работу и затем с помощью программы Adobe Acrob Distiller превратить файл публикации в файл PDF, и чтобы с него в типографии печатали пленки и выпустили тираж.

Сделав эти нехитрые назначения во вкладке Принтер и Бумага, возвращаемо на вкладку Layout, открывшуюся по умолчанию и проигнорированную нами пои чалу, там смотрим размеры нашего листа: программа сама при назначении форл A3 выбрала из списка стандартных предложений Publisher, который содержится вкладке Layout, ту строчку, которая нам более всего подходит — Custon (Обычный) и его размеры: 29,704 см и 42,016 см. Такой точности я не знал, проработав много лет проектировщиком, очень знакомым с форматами. Ну, да. но, чем точнее, тем оно надежнее.

Рис. 4. Вкладка Layout

Говорим ОК. И получаем нашу публикацию в тех назначениях, которые сделали только что:

Рис. 5. Чистый лист будущей газеты

Теперь взглянем повнимательней на этот лист и посмотрим, что нас в нем не устраивает.

А не устраивает вот что. Поля! Чем они не устраивают? Тем, что они, во-первых, большие — по 2,5 см каждое. Если верхнее и нижнее поля можно оставить такими, поскольку в газете обязательно существует какой-то колонтитул, то вот внешнее и внутреннее поля должны подвергнуться корректировке. Оставим внешнее поле не 2,5, а 2,0 см — это для газеты будет нормально. А вот внутреннее поле должно быть поменьше — пусть это будет 1,5 см.

Для чего внутреннее поле нужно делать поменьше? Для компенсации визуального эффекта. Если оставить поле 2,5 см, то на развороте он будет 2,5 + 2,5 = 5 см.

Это вызовет эффект непропорционально большого промежутка между полосами, эффект визуального «разбегания» полос, стремления их как бы вырваться за границы газеты. По-хорошему внутреннее поле вовсе можно сделать 1 см, что в сумме даст 2 см — величину, равную внешнему полю, и тогда выдерживается симметричность и пропорциональность. Но не станем доводить публикацию до таких крайностей. Почему? Потому что, бывает, и обрезку сделают неточно, так что кое-какой запас должен все-таки быть. К тому же не забудем, что газету складывают из одного листа, который в два раза большего формата, чем наша полоса (А2), — могут сложить неровно... По полтора сантиметра с той и другой стороны — в самый раз.

Итак, изменяем поля. Вызовем опцию Layout Guides... (Схема Направляющих...) из меню Arrange (Упорядочить, Порядок).

Рис. 6. Меню Layout Guides

Мы видим, что поля здесь назначены по умолчанию по 2,5 см. И поля не Внутреннее и Внешнее, а Левое и Правое (Left и Right). О Верхнем и Нижнем, договорились, разговора нет. Назначаем, как вы помните, в первую очередь флажок перед опцией Create Two Master Pages With Mirrored Guides (Создать Две Мастер-Страницы с Зеркальными Полями).

Рис. 7. Назначили зеркальные поля и их размеры

Теперь появились правильные имена полей — Inside и Outside (Внутреннее и Внешнее). Назначаем размеры полей, о которых говорили.

Теперь очередь колонок. В газете, как вы помните, всегда есть колонки — на то она и газета. Поле колонок дает нам возможность назначить их здесь же (Columns). Выберем для нашей газеты пять колонок и проставим тут же в поле Колонки это число. О рядах речи быть не может — мы не на празднике канцелярщины. Газета делится только на колонки. Нельзя материалы подбирать строго по линиям разделения — квадратно-гнездовой способ в газете неуместен, она и хороша своей художественной несимметричностью. Так что в поле Rows оставляем единицу, заложенную там по умолчанию.

Рис. 8. Назначили число колонок

На рисунке вы видите, что в поле просмотра на развороте появилось обозначение колонок. Именно все эти линии перекочуют и на страницу в рабочем поле рабочего окна программы. Говорим ОК и видим — так оно и есть:

Рис. 9. Все назначения отразились на газетной полосе

Здесь колонки могут назначаться как для каждой отдельной страницы, так и для всех страниц в целом (если они назначаются на Мастер-Странице). Отличие одного назначения от другого — только в количестве колонок (кто бы мог подумать???). На текущей странице, как в Word, мы можем назначить колонки инструментом Колонки с Панели управления. Но их не больше четырех,

И с колонками, которые назначаются с Панели управления, происходит парадокс (недостаток Publisher): если в Word они назначаются с разумным гаттером, то здесь, хоть тресни, интервала между колонками нет. Приходится пользоваться условными колонками, назначаемыми с Мастер-Страницы.

Почему я сказал «условными»? Потому что для изображения колонок на рабочей странице (ведь мы не можем повлиять с рабочей страницы на Мастер-Страницу) не действует опция автоматического заполнения текстом. Впрочем, она и на Мастер-Странице не действует. Вот такой парадокс, решения которого мною не найдено.

Если мы обозначим на рабочей странице Текстовый Блок и назначим ему четыре (три, две — все равно) колонки, Текстовый Блок без проблем разбивается на четыре колонки, но не имеющих интервала! Если вставить текст в это текстовый блок, текст преспокойно ложится в четыре колонки, но гатгера—нет как нет.

Что делать? Еще один сакраментальный вопрос русской истории.

А делать вот что.

Надо набраться терпения и на первой странице публикации (пока она еще одна) аккуратно создать инструментом Текстовый Блок ровно столько текстовых блоков, сколько нарисовано на странице колонок, и сделать это по границам колонок.

А потом — выбрать опцию Insert Page... (помните: слово Вставка — из названия меню, а Страница — из имени опции). Получаем диалог вставки страниц:

Рис. 10. Диалог Вставки Страниц

По умолчанию здесь записано 2 страницы. Если у нас существует только одна, первая, то и опция вставки Before current page (Перед текущей страницей) пуста. Зато флажок стоит в опции After current page (После текущей страницы).

Выбираем, сколько нам вставить страниц. Впрочем, нам-то выбирать нечего: нам не хватает еще трех газетных полос. Соответственно вместо цифры 2 ставим цифру 3.

Наиболее интересны нижние опции — они-то нам и нужны. Вот они, по порядку: Insert blank pages (Вставить чистые страницы), Create one text frame on each page (Создать один текстовый блок на каждой странице) и Duplicate all objects on page (Сдублировать все объекты на странице) и в окошке ввода стоит неактивная цифра 1.

Нас, конечно, интересует последняя опция: мы бы хотели, чтобы все вставленные страницы уже имели такие же текстовые блоки, какие имеются на первой странице. Потому что если у нас вдруг окажется очень длинный текст, он должен автоматически перетекать из колонки в колонку, каждая из которых должна быть уже занята текстовым Блоком. Иначе наш текст по кусочкам придется вставлять множество раз.

Итак, отмечаем флажком в «пуговице» третью опцию (Сдублировать все объекты) и убеждаемся, что цифра 1 стала активной. Это значит, что скопируются объекты со страницы номер один. При необходимости там или будет стоять другая цифра (или число), или нам самим придется проставить ее.

Назначили — и говорим ОК.

Рис. 11. Возникли новые страницы с текстовыми блоками. Мы видим вторую

Однако взгляните: наши текстовые блоки сместились относительно Направляющих, обозначающих поля. Зеркальность выходит боком. Ведь страницы 1 и 2 оказались симметричными относительно оси, то есть относительно корешка, и придется сдвигать текстовые блоки вручную.

Выделяем текстовые блоки. Это делается планомерно — с первого по (пять колонок), при этом не забывайте удерживать Shift.

Рис. 12. Выделили все блоки на странице...

И теперь сдвигаем блоки — или вручную, или с помощью стрелок Right) клавиатуры.

То же самое проделаем и со страницей 4.

Честно говоря, иного способа при зеркальных страницах я не знаю. Если отменить зеркальность... Но тогда это будет противоречить принципах газе и книжной) верстки.

Двигать вручную можно за любую точку из числа выделенных контуров, только нельзя браться за маркеры выделения. Двигать блоки можно тогда, когда выглядит как четырехострая стрелка (и автомобиль с именем MOVE на борту изображен тут же).

Итак, передвинули:

Рис. 13. Все выглядит как надо

Подумаем, что нам еще необходимо проделать.

Вроде бы вся «подложка» сделана, осталось только начать верстку.

Оформление

Тогда возвращаемся... на Мастер-Страницы. Назначаем там Колонтитулы. В газете, если вы заметили, колонтитула тоже разные для левой и правой страницы. Или, по крайней мере, зеркальные.

Что у нас должно быть на колонтитуле? Во-первых, конечно, имя газеты — «Свет Разума». Во-вторых, обязательно год издания: 2002. В-третьих, номер газеты. У нас он Первый. Соответственно он первый и вообще, и первый номер 2002 года. Значит, впишем: «1 (1)». Не забудем и подзаголовок: «Газета для всех», к примеру.

Так и распределим: имя газеты и номер ее — на Левом Колонтитуле, подзаголовок и год издания — на Правом. Кроме того не забудем, что если рубрика занимает целую полосу, ее удобнее всего также расположить в Колонтитуле.

Как будет выглядеть Колонтитул? То есть каков его дизайн!

386 Давайте подумаем. Многие газеты изощряются, делая очень составные Колонтитулы. Подкладка из какого-нибудь орнамента или просто из вычурно заштрихованной полосы, по ней — имя рубрики, логотипы и прочее. Думаю, на какой-нибудь логотип тоже не помешает, но он не обязателен: ведь мы не представляем никакой фирмы, никакого сообщества, которое с остервенением билось за «свои цвета». Не дай Бог стать фанатиком чего-нибудь, или, упаси Боже, фанатом. Поскольку, как выясняется и как сказал Екклезиаст — «Все суета». Можно взять какой-то нейтральный логотип, не обязывающий ни к чему. Я поищу, но попозже.

Выберем лицо Колонтитула классическое — черта, а над нею — все то, о чем мы говорили. Номер страницы (полосы) отнесем вниз, где будет свой Колонтитул, состоящий также из какой-нибудь черты и этого номера страницы.

Кстати, забегая несколько вперед, скажу: ведь по сути у нас только на страницах 2 и 3 будут проставлены номера страниц. Ну, возможно, еще на четвертой полосе, если позволит область выходных данных, которая там, как правило, помещается. Посмотрим. Пока же назначим сами Колонтитулы, а потом станем думать.

Итак, открыли Мастер-Страницу и вносим Верхний и Нижний Колонтитулы

Рис. 14. Провели черту и назначаем ей толщину и форму

Вы видите, что я провел сразу две линии — и для Левого, и для Правого Колонтитулов. Потом выделил обе, и возникла контекстная кнопка Сгруппировать. Воспользуемся ею, чтоб никуда не мчаться и не искать эту команду по разным меню (иногда бывает, что и забудешь, действительно, где искать команду). На рис. 14 вы видите сгруппированные линии и кнопку Разгруппировать, поскольку команду Сгруппировать я уже назначил.

Теперь выбираем форму и толщину линий.

На рисунке 378 вы видите диалог Format AutoShape (Форматирование Авт фигуры), в котором очень основательно можно выбрать все, что касается линий назначений их дизайна. Диалог вызывается двойным щелчком мышки на самой линии. Но можно сделать назначение и попроще, не вдаваясь в частности, поскольку нам из этих частностей, существующих в указанном диалоге, нужно лишь немногое. Приведем оба рисунка:

Рис. 15. Диалог Format AutoShape

Рис. 16. Меню выбора толщины и формы Линии

Но мы воспользуемся все же диалогом. Назначим Линию в нем. На рисунке 17 вы видите, как выбиралась фигура Линии в поле Style: (Стиль:).

Рис. 17. Выбираем Стиль Линии

И смотрим, что у нас получилось. Вы видите заданную Линию на рисунке 18.

Рис. 18. Получились вот такие Линии

Из рисунка видно, что Линии, возможно, располагаются слишком близко к, будущему тексту (верхняя граница текста видна). Значит, нем необходимо поднять обе линии на несколько миллиметров. Миллиметра на три-четыре. Что и проделаем. Выделим Линии и вручную перенесем их чуть выше. Не станем утруждать вас разглядывать, как это получилось: в следующих манипуляциях успеете разглядеть и это.

Теперь надо бы выбрать стиль надписей — имени, номера, года и подзаголовка. Этим займемся через Панель управления — самое милое дело, когда все назначения под рукой. Но прежде назначим... Да, вызовем опцию Колонтитулы. В меню View вызываем Header and Footer (Колонтитулы):

Рис. 19. Получили область внесения Верхнего Колонтитула

Область получилась немного узка для нашего Колонтитула, поскольку, как вы помните и видите на рисунке, мы немного подняли Линии Колонтитула Расширим Текстовый Блок Колонтитула, чтобы имена и номера преспокойно вписались в него.

Текст привязывается к верхней границе Текстового Блока, и потому между Линией и Текстом образовался необходимый воздух (на рисунке 19 мы уже приподняли границу Текстового блока Колонтитула).

А вот теперь пришла пора назначить стиль шрифта Колонтитула. Причем, насколько нам ясно, 6н не может быть единым. Заголовок газеты пишется одним шрифтом, номер ставится совсем другим. Подзаголовок может быть сделан третьи стилем. Номер года делается почти всегда таким же кеглем и той же гарнитурой что и порядковый номер газеты.

Рис. 20. Выбираем гарнитуру шрифта

Выбирать с Панели управления через список Гарнитур Шрифта удобнее потому, что, начиная с Офиса 2000, Майкрософт стала строить этот список как Навигатор шрифтов.

Это освобождает от необходимости поиска стороннего какого-нибудь Навигатора.

Скоро надобность в такого рода Навигаторах, думаю, сама собой отпадет, если автор операционной системы и самого мощного из существующих пакетов приложений предлагает такую удобную систему поиска и выбора шрифта.

Шрифтов у меня установлено много, и потому я потрачу, наверно, много времени на поиск. Но все равно найду, потому что есть из чего выбирать. К примеру, вот этот:

Рис. 21. He подойдет ли такой шрифт?

Да, выберем его. Имя шрифта — AdverGothicC, кегль 18.

Панель Колонтитулы, которая выявляется немедленно следом за выбором опции, нам практически не нужна, но она должна присутствовать на экране, иначе мы ничего не сможем впечатать в текст Колонтитула. Можно не пользоваться назначениями Панели, но она инициализирует Тестовый Блок Колонтитула, и для нас это очень важно.

К тому же, Панель понадобится, по меньшей мере, один раз — когда мы станем переходить с Верхнего Колонтитула на Нижний. Кнопка перехода с верха на низ и обратно — к нашим услугам.

Итак, заголовок написали.

Теперь идем в правую часть Верхнего Колонтитула, чтобы проставить номер газеты.

Рис. 22. Проставили номер газеты

Теперь наша задача — не забыть о рубрике. Для нее выберем какую-нибудь плашку. В качестве таковой подойдем черный прямоугольник. Примерную длину текста рубрики вы знаете (начиная газету, вы уже собрали материал и назначили рубрики в эскизе макета).

С Панели инструментов добываем инструмент Rectangle (Прямоугольник) и! рисуем над Колонтитулом прямоугольник известной нам примерно длины. И вызываем опцию Заливка кнопкой с Панели управления. Меню плашечных цветов заливки вы видите. Нам для верстки и макетирования нашей газеты изысканных цветов не надо, потому что ради дешевизны (или по эстетическим соображениям) газета будет черно белая. К тому же, вы все равно не увидите ни одного цвета, поскольку книга, которую вы держите в руках, к сожалению, черно-белая.

Рис. 23. Нарисовали плашку и выбираем ее заливку

По умолчанию линии Прямоугольника черного цвета, поэтому толщина этих линий нас не должна беспокоить. В противном случае следовало бы не заливать фигуру с Панели управления, а также двойным щелчком на ней вызвать такой же диалог, каким мы пользовались для назначения Линий Колонтитулов. Там произошла бы заливка Прямоугольника (или, кстати, любой другой фигуры — их набор велик в опции Автофигуры) и назначение цвета его линий.

Наконец, все назначения сделаны, захватим Прямоугольник мышкой и поставим на его законное место — по центру полосы в ряд с Колонтитулом...

Нет! Не нравится мне эта плашка. Слишком она не гармонирует с заголовком газеты. Придется поменять фигуру на Прямоугольник с Закругленными Углами. Так, думаю, будет получше. Выделяем Прямоугольник и вызываем опцию Change AutoShape (Изменить Автофигуру) меню Arrange. Там и выбираем Прямоугольник с Закругленными Углами.

Рис. 24 а. Выбрали Прямоугольник с Закругленными Углами

Желтый ромбик у левого угла фигуры, который просматривается на рисунке, служит для того, чтобы менять радиус кривизны угла. Манипулируя сдвижениями этого ромбика туда-сюда, выбираем приемлемое закругление всех углов (они изменяются одновременно).

Кстати сказать, как только вы поместили Прямоугольник на то место, где он будет всегда, меняется расположение текста в Колонтитуле. Вы помните, что по умолчанию в программе Publisher помещение любого объекта в текстовую строку или абзац вызывает сразу же Обтекание текстом в режиме Со Всех Сторон. У меня именно это и произошло. Тогда я вызвал опцию Text Wrapping из меню Arrange и назначил опцию None (Нет Обтекания). Тогда текст номера газеты, который вдруг подскочил к самой Автофигуре, благополучно вернулся на место.

Рис. 24 б. Так, кажется, получше

Теперь копируем этот Прямоугольник в Буфер Обмена и Вставляем его из Буфера.

Взяв мышкой вставленный Прямоугольник (который теперь уже почти не прямоугольник), несем его на второй Верхний Колонтитул, на Правую страницу. Там вставляем его в Колонтитул тем же способом, что и на Левой странице. Технологию выбора шрифтов и растяжения Текстового Блока Колонтитула уже не описываю — за ненадобностью, поскольку все идентично, только шрифты разные.

Кстати, при Вставке Прямоугольника с Закругленными Краями во второй Верхний Колонтитул уже не происходит несуразностей с текстом, потому что копиров ли и вставляли мы Прямоугольник с правильными назначениями, и программа запомнила. Честь и хвала приложению Publisher!

Рис. 25. Плашка на Колонтитуле Левой страницы

Теперь обратимся к Нижним Колонтитулам. Там тоже желательно провести какую-нибудь черточку — может быть, менее весомую, чем наверху, но все же. Во-первых, таким образом выдержится некий общий стиль, во-вторых... то же самое, что во-первых.

Нарисовав две Линии и назначив им форму и размеры, поместим их наилучшим образом на полосу. После этого включим Нижний Колонтитул и нарисуем номера Страниц (полос). Как это делать, вы помните?

Да, щелкаем кнопкой Номера Страниц на Панели Колонтитула, и Номер в виде значка # появляется там. где он должен появиться по умолчанию. По умолчанию — это по левом краю Колонтитула. Переназначаем выравнивание — делаем Выравнивание По Центру. Это легче всего сделать кнопкой Выравнивание По Центру с Панели управления. Значок соответственно назначению перемещается.

Но вот во втором Нижнем Колонтитуле Номера страниц программа не даст вам установить. Номер страницы с Панели Колонтитула назначается лишь один раз. Второе назначение придется делать с помощью меню Insert (Вставка). Там вы выбираете опцию Page Numbers... (Номера Страниц...) и назначаете номер в диалоге. Такова специфика. Если вы попытаетесь сделать это с Панели Колонтитула. Publisher забросает вас диалогами, где докажет вам, что Номера Страниц с Панели лучше не задавать, поскольку они уже заданы.

Кстати сказать, это происходит оттого, что мы ведь еще в начале работы с Колонтитулами по их оформлению объединили и Левый и Правый, чтоб они были с одинаковыми характеристиками.

Как бы то ни было, Номера страниц мы назначили. Теперь надо их оформить тоже.

Во-первых, назначаем размер шрифта — примерно 18. Нет, точно 18. Во-вторых, копируем наш Прямоугольник с Закругленными Углами в Буфер Обмена и Вставляем его в Нижний Колонтитул. Подгоняем мышкой его размер под размер Номера страницы и накладываем на этот Номер.

Номер, естественно, исчезает под черным Овалом. Овал выделен, поэтому в меню Arrange, подменю Order, выбираем команду Send to Back (Поместить Ниже Всех). После этого выделяем курсором (протаскиванием) невидимый Номер страницы и открываем на Панели управления меню Цвет Шрифта (вы видите его на рисунке 390). Там назначаем Цвет Шрифта — Белый. ТО же самое проделываем с Номером Страницы на второй странице Мастер-Страницы. И, кажется, все.

Рис. 26. Назначаем Цвет Шрифта для Номера Страницы


Глава 1

Печать в Microsoft Publisher

Печать в верстальной программе очень важна. Она важна, конечно, везде, но здесь особенно.

Многие газеты (речь пока о ней) выпускаются по упрощенной технологии. Все мы знаем, что без пленок в типографии уже нигде не обходятся, что времена высокой печати канули в лету. Но пленки иногда делаются все еще фотографическим способом. Вы приносите в типографию свою высококачественную распечатку, и эта распечатка полос служит основой для изготовления пленок. То есть ваша работа над газетой заканчивается выводом публикации на принтер и отнесением того, что получилось, в типографию.

Рассмотрим этот вопрос мельком. Потому что печать на принтере в Publisher ничем не отличается от такой же операции в «Ворде» или другом приложении.

В меню File (Файл) вызываем команду Print... (Печать...). Появляется диалог (рис. 1), где выбираем принтер, на котором будем печатать (у меня вы видите Canon, струйный, после которого, конечно, никаких пленок делать нельзя).

Рис. 1. Диалог Печати

Выбираем здесь все необходимые нам параметры и установки. Речь идет о номерах страниц, какие следует напечатать, и о числе копий. Кнопка Properties... (Свойства...) откроет нам диалог с принтером. Поскольку принтеры у всех пользователей разные, нет большого смысла открывать этот диалог. Но я открою, чтобы показать, что он под кнопкой есть.

Рис. 2. Диалог с принтером. Вкладка Бумага/Качество

Сделав все необходимые назначения, можете сказать ОК. и принтер распечатает вам вашу публикацию.

Нас же волнует больше всего другое. Для того, чтоб сделать качественные пленки, нам необходимо поучаствовать в создании и превращении скрытого EPS-файла. Это специальные файлы для точного и качественного отображения публикации в тираже (для типографии или для сервисного бюро). Эти файлы изобретены фирмой Adobe, изобретателем и этих файлов, и пост-скрипт-шрифтов, и самой PostScript-системы. Можно, конечно, сделать пленки и на вашем ПК, если к нему подсоединить высококачественную фотонаборную машину. Но она очень дорога и многим не по карману. Поэтому лучше всего (и надежнее всего) отдать в типографию готовый EPS-или PDF-файл. Файлы EPS (Encapsulated PostScript) превращают все страницы вашего документа из того вида, в котором они существуют (здесь и текст, и рисунки, и надписи, и объекты другого типа — возможно, формулы, и так далее), в один общий изобразительный ряд — проще говоря, в рисунок векторного типа, который уже не понимает ни шрифтов, ни формул, ни изображений для него вся публикация, какую бы смысловую ценность она ни несла, воспринимается как постраничный набор картинок, не больше. Это создает удобство для печати пленок и тиража. Во-первых, такой файл можно отдать на любого типа печатную машину (PostScript-машину), и она не ошибется при печати. Вы знаете, что высококачественный принтер обязательно имеет в своей памяти некий набор шрифтов и другие настройки, которые постоянно сверяет с тем, что подается ему в работу. А тут никаких встроенных шрифтов и настроек не надо — кроме настроек самой печати (концентрации цвета, яркости и т. д.).

Собственно, язык описания публикации PostScript тоже не очень-то и интересует и типографскую машину, и нас с вами. Он состоит в кодировании каждой точки каждой страницы и довольно скучен, хотя и обладает высокой точностью передачи всех характеристик. Этот файл, повторяю, скрыт, и для того, чтоб превратить его в видимый, требуются некоторые усилия. К примеру, необходимо открыть его в программе Adobe Acrobat Distiller, чтобы превратить в тот вид, который годен для чтения. А именно — в формат PDF (Portable Document Fonnat), который именно может открыть нам, как выглядит наша публикация. То есть процесс превращения вашей публикации в точную интерпретацию для печати, как видите, имеет некоторую сложность и этапы.

Для распечатки публикации в EPS-формате используются чаще не файлы .eps (этот файл «рисует» лишь одну страницу и годен для афиш, плакатов и т. д.), а файлы .ps — стандартные пост-скрипт-файлы, интерпретирующие всю публикацию, страница за страницей.

Есть еще так называемые файлы печати (файлы формата PRN) — это обыкновенные файлы для принтера, с которых принтер может осуществить печать. Такой файл нужен тогда, когда у вас под рукой нет приличного принтера высокого качества и вы хотите сделать печать где-то на стороне. Превратив вашу публикацию в такой файл (напечатав в файл), вы относите этот файл на каком-либо носителе в бюро и там распечатываете все, что нужно.

Но вернемся к пост-скрипт-файлам. Стандартный PS-файл также превращается Акробатом в файл PDF (.pdf), и чаще всего именно он-то и интересует типографию ради изготовления пленок для печати тиража. Здесь типография снимает с себя все претензии по содержанию, ибо векторная картинка вашей публикации не может быть ею искажена (кроме, конечно, случая, когда типография сделает некачественную или бракованную пленку). Соответственно эти файлы, выгодные и вам, и типографии, устраивают всех, в том числе и читателя.

Еще одна немаловажная деталь: как правило, PDF-изображение необходимо выполнить зеркально по отношению к истинному изображению публикации. Эти настройки следует делать при превращении вашего файла в PostScript-файл. То есть до того, как он превратится в PDF-файл. Все необходимые настройки можно сделать в диалоге печати, который мы и рассматриваем.

Но при назначениях зеркальности и прочего мы не сможем пользоваться указанным к списке принтеров именем Canon. Здесь мы не найдем необходимых нам настроек. Что делать?

Необходимо в Windows XP установить известным вам способом новый принтер (даже если у вас его нет, то есть виртуально) — принтер с PostScript-настройками. У меня это принтер марки Linotronic. Его и вызовем в списке:

Рис. 3. Выбираем виртуальный принтер

Вы видите, что я выбрал этот принтер в списке принтеров. Но мы не видим никаких дополнительных настроек. Откроем кнопку Свойства... (Properties...).

Рис. 4. Диалог «Свойства принтера»

Мы видим, что и здесь никаких настроек не существует, кроме стандартных. Значит, Publisher не расценивает Linotronic как безупречную PostScript-машину и считает ее обыкновенным принтером? Возьмем для настроек стопроцентно фотонаборный PostScript-аппарат — Acrobat Distiller:

Вскроем диалог под кнопкой Properties... и увидим, — там настройки существуют: на рисунке 5 вы видите, что в диалоге есть вкладка Adobe PDF Settings (PDF-установки). Ее-то и откроем.

Рис. 5. Диалог принтера Acrobat Distiller

В этой вкладке с проставленными перед ними по умолчанию флажками. Это строки Do not send fonts to Distiller (He отправлять шрифты в Дистиллер), View Result In Acrobat (Показывать результат в Акробате), Prompt for the PDF Filename (Подсказывать имена файлов для PDF), Delete log files for successful jobs (Удалить дерево файлов для успешной работы) и Ask to Replace existing PDF file (Запрашивать путь для PDF-файла). Перед последней строкой флажка нет, поскольку запрашивать путь нужно только тогда, когда мы собрались поместить PDF-файл не в одну папку с основным файлом, а куда-то отдельно.

Это лишь основные требования. А настройки скрываются за длинной кнопкой Edit Conversion Settings... (Правка Установок Конвертирования...).

Мы попали на вкладку General (Общая), но есть еще Compression (Сжатие), Fonts (Шрифты), Color (Цвет) и Advanced (Другие, Дополнительно). Взглянем сначала на первую. В верхнем окошке Compatibility (Совместимость) указана программа, в которой будет читаться будущий PDF-файл. И вы видите, что прочесть его в прежнем Акробате версии 3,0 мы не сможем (нужен не ниже 4,0, а лучше — последний версии 5,0). Далее есть опция Optimize for Fast Web View (Оптимизировать для Устойчивого Просмотра Web) . Ничего удивительного: файлы PDF появились не ради нас с вами, а исключительно по причине существования мирового паука (Интернета). В опции Embed Thumbnails (Встроить Гиперсвязи) флажка нет — вы можете поставить его или все оставить без изменений. В опции Auto-Rotate Pages: (Авто-Разворот Страниц:) флажок существует, и в поле списка вы видите по умолчанию назначение Collectively by File (Все подряд для этого Файла), а есть еще Individually (По Одной).

Далее (ниже) вы видите обычную опцию Page Range (Порядок Страниц), где можете выбрать, все или выборочно печатать страницы в файле PDF, но не беспорядочно, а только От: (From:) и До: (То:). Опция Binding (Переплет) предполагает левый или правый переплет вашей книги (журнала, да и газеты иногда тоже). Также вы видите опцию Resolution: (Разрешение:) и значение разрешения — 600 dpi. Это очень приличное значение: в основном хватает и 300 точек, а 600 применимы для цветной печати; впрочем, теперь, при возрастании возможностей техники и запросов читателя журналов и даже газет, 600 точек — уже мало.

В нижнем поле Default Page Size (Размер Страницы по Умолчанию) вы видите фактически размер страницы на вашем мониторе. Не задавайте сюда никаких значений: если вы хотите получить файл газеты, вам все равно, какой размер задан для Web-страницы.

Здесь указаны все параметры для Сжатия по категориям — для цветной публикации, для публикации черно-белой в серых тонах и для чисто черно-белой. Ничего сложного, кажется, в этой вкладке нет, а назначения всякий раз индивидуальны. Скажу только, что заданные по умолчанию 150 точек для цветных и серых публикаций — это мало. Это годится только для Интернета и никак не подходит для конкретной газеты, журнала или книги, если вы собираетесь пускать их на типографский станок. Это и учтите.

Здесь вы видите поле Embedding (Встраивание). И список 14 базовых шрифтов, которые можно встроить в файл прямо сейчас, не занимаясь никакими поисками. Но вы можете в поле списка обнаружить и виндоусовские шрифты, имеющиеся на вашем ПК (уже давно установленные), которыми вы пользовались при создании публикации. Этот список я преспокойно открыл из верхнего окошка списка, потом выделил один из шрифтов (это оказался шрифт Verdana, Arial, Helvetica, sans-serif) и правой кнопкой со стрелкой адресовал этот шрифт в число тех 14-ти базовых. Вы видите его под первым номером в окне Never Embed (насколько я понял — Никогда не Встраивать, то есть нет необходимости, поскольку базовые встроятся и так).

А вверху имеется поле Always Embed (Всегда Встраивать). То есть, выходит, я переводом я был прав.

Кроме этой функции, которую мы бегло рассмотрели, во вкладке есть опции, по умолчанию отмеченные флажками: Embed All Fonts (Встраивать Все Шрифты) и длинное имя — Subset embedded fonts when percent of characters used is less than (Подстановка встроенных шрифтов в процентах к используемым символам), и по умолчанию в последней опции в окошке дано 100%.

Ниже вы видите опцию When Embedding Fails (насколько мне кажется, можно перевести как Отсутствие Встраивания, то есть если встраивания не происходит). И в окошке списка видим запись: Warn and Continue (Предупреждать и Продолжать). В том же списке есть строки Ignore (Игнорировать) и Cancel Job (Отменить Действие). Назначайте то, что вам необходимо.

Теперь мы прошлись по всем вкладкам и можем запомнить все наши настройки под определенным именем (шаблоном). Такие шаблоны уже есть в папке Settings программы Publisher. Кнопка Save As... (Сохранить Как...) откроет нам диалог сохранения.

В случае, если вы сохраните сделанные настройки, можете найти имя этого шаблона в поле вкладки Adobe PDF Settings диалога принтера.

Теперь взглянем еще на вкладку Бумага/Качество этого диалога и скажем ОК.

Рис. 6. Вкладка Бумага/Качество диалога принтера

А вот что скрыто за кнопкой Дополнительно... этого диалога:

Рис. 7. Настройки под кнопкой Дополнительно...

Теперь мы возвращаемся в диалог Печати. Что ж, и здесь говорим ОК. Не забудем сделать назначение Print to File (Печать в Файл).

Рис. 8. Диалог назначения имени файлу

Возникнет совсем небольшой диалог, в нем вы впишете в предложенную строку имя файла, в который печатаете. Вписываем «Вася» (найдите лучше). И говорим ОК.

Рис. 9. Анимация процесса

На этом все диалоги исчезли. Перед вами опять ваша публикация. Боже, как я был неправ! Я нарочно не переписываю эту часть книги, чтоб вы убедились, что вас чуть не обманули.

Да, занимаясь глупой работой по переводу с английского, не зная самого языка, я чуть было не наврал вам, дорогой читатель.

Поставим все на места. То, чем я только что занимался, это всего-навсего ПЕЧАТЬ В ФАЙЛ, и больше ничего.

У нас возник этот самый файл «Вася», который действительно можно отнести туда, где есть машина Акробат, и Акробат нам просто распечатает файл, как обыкновенную публикацию. Потому что в результате всех манипуляций родился не PDF-файл, как мне думалось, а обычный файл для передачи в другую контору. А все мои действия (тоже, кстати, не напрасные, потому и оставим эти страницы, как все равно полезные) были следствием того, что этот алгоритм применяется в других верстальных программах — PageMaker и QuarkXPress. Именно там через диалог печати получается виртуальный пост-скрипт-файл, который затем в программе Acrobat Distiller превращается (конвертируется) в PDF-файл. Этот полученный файл читается уже в программе Acrobat Reader (у меня тоже новая, пятая версия).

Теперь — о том, как действительно в программе Publisher получить PDF-файл публикации. Оказывается, очень и очень просто.

Во-первых, вызываем в меню File (Файл) команду Save As... (Сохранить Как...). И в нижнем поле Тип Файла (Save as type) выбираем PostScript. Щелкаем кнопку Save. При этом, конечно, предварительно выбрав папку, в которую попадет PS-файл.

Рис. 10. Диалог сохранения Save As...

После того, как мы сказали Сохранить, возникнет следующий диалог:

Рис. 11. Диалог сохранения PostScript-файла

Именно здесь-то за кнопкой Properties... (Свойства...) скрываются все те назначения, что нам уже знакомы по последним рисункам:

Рис. 12. Знакомый диалог вызван из другой опции

Не стану повторяться, просто вы просмотрите все те же вкладки и сделайте свои установки для вашей публикации. И скажем Save (кнопка в нашем диалоге из рисунка 11). И пошло превращение нашей публикации в пост-скрипт-версию:

Рис. 13. И анимация знакома

Сообщение гласит буквально следующее: «Publisher создал PostScript-версию вашей публикации». И дальше еще какие-то пояснения, вдаваться в которые мне не хочется, а вы сможете, думаю, перевести, если это интересно. Говорим ОК.

Итак, PS-файл создан. Найдем его. Он там, в той самой папке, где мы сказали Save. У меня это — папка «Мои документы».

Рис. 14. Вот он, этот файл — в нижней строке: «Газета»

Теперь мы можем вызвать программу Adobe Acrobat Distiller и оттуда открыть этот файл. Или щелкнуть прямо на значке файла, и тогда все равно появится программа Акробат. Эта программа не спрашивает вас, что делать с файлом — она сразу начинает его превращать.

Вы видите, что процесс превращения идет полным ходом. Акробат перекодирует скрытый файл в понятные ему одному другие коды — чтоб мы смогли воочию убедиться в том, что наша публикация существует в непригодной для вмешательств PDF-форме.

Вы видите, что Акробат не только создал сам файл, но и рядом приготовил текстовый файл по имени «Газета». Что там? А там тот самый отчет, что был в нижнем поле программы. На всякий случай. Если вы захотите убедиться в том, как шел процесс.

Новая верстальная программа глубоко не изучена, но, как видите, практически все вопросы в ней разрешимы. Важно лишь потихоньку привыкнуть.

Еще раз повторюсь: в детище Билла Гейтса достаточно недостатков и непроясненностей, не все так хорошо, как хотелось (то есть можно сказать, что выстрелил он не в яблочко, а в девятку, — впрочем, стрелком оказался отменным).

Говоря о печати в Publisher, можно добавить, что, конечно, Майкрософт опять оказалась фирмой, смотрящей в будущее: не очень-то внимателен Publisher к струйным принтерам, кое-как терпит лазерные и тяготеет в фотонаборным, фотоцифровым машинам с высокой разрешимостью печати. А что? Недалек тот день, когда у каждого приличного или даже рядового макетировщика и верстальщика в домашнем кабинете будет стоять не лазерный принтер, и уж тем более не струйный, а именно — цифропечатный аппарат. Вспомните время, когда Windows 95 казалась нам программой на века. Сколько лет прошло?

Программа Microsoft Publisher хороша. Долгой ей жизни.

А вам — прекрасных минут и часов работы в Microsoft Publisher.


Глава 1

Верстаем газету (II)

Теперь можем взглянуть, правильно ли мы сработали. Откроем разворот 2-й 3-й страницы и полюбуемся, все ли так, как хотелось бы. Но прежде опять выделю! значки номеров страниц (каждый в отдельности) и назначим им другой шрифт — примеру, BernhardC. А теперь откроем разворот.

Рис. 27. Разворот газеты

Нет, вроде бы ничего.

Теперь отдельно взглянем, как смотрится номер страницы на фоне овальной плашки, получившейся из прямоугольной с закругленными углами.

Рис. 28. Действительно вроде бы ничего

Ну, тогда идем дальше. Теперь наша задача — дать газете правильный заголовок. Не в смысле назвать ее (мы уже поименовали), а «родить» Первую полосу — лицо газеты. Это самое порой сложное из всего, что связано с производством печатного органа. В ходе вашей работа по макетированию и верстке, если вы собираетесь этим заниматься всерьез, вы множество раз убедитесь в этом.

Заголовок

Все известные нам десятилетиями газеты — независимо от того, нравились они нам или нет по содержанию — носили запоминаемые заголовки. И не по содержанию, а визуально. «Правда» и «Известия», «Комсомольская правда» и «Социалистическая индустрия», «Труд» и «Советский спорт» — все они отличались характерными, броскими, очень узнаваемыми заголовками, набранными великолепными шрифтами. Вернее, это были уже не наборы, а— логотипы. Вот почему еще я сказал о логотипе осторожно — чтобы вставить в лицо газеты эту «мушку», «родинку», надо пережить множество бессонных ночей. Не ошибиться — главная и часто, бывает, невыполнимая задача, когда вы ищете лицо газеты.

Конечно, сейчас я не стану думать на эту тему: бессмысленно. В качестве логотипа мы выберем нечто условное, какое-нибудь изображение, может быть, вовсе не имеющее отношения к содержанию или направлению газеты. Просто необходимо заполнить вакуум.

Но еще посмотрим, возможно, никакого вакуума и не будет — в зависимости от того, как именно ляжет на полосу заголовок.

Теперь поговорим о конкретном месте этого заголовка.

Если помните, заголовки газет советского времени, несмотря на то что были важными и очень ценимыми, не особенно бросались в глаза при продаже их в киосках. Это, может быть, и не нужно было: все знали пять-шесть центральных газет и могли узнать их без всяких заголовков.

Теперь задача для имени газеты — броситься в глаза. Не в том распространенном переносном смысле, что, мол, переплюнуть других (хотя и доля этого тоже есть), а в смысле — буквально показаться на глаза покупателю. Зная нынешнюю перенасыщенность книжно-газетных развалов и лотков, вы, думаю, поймете, о чем речь. Надо вычислить, как чаще всего раскладывает газетный торговец номера всевозможных газет — только ли названия у него лежат, перекрывая друг друга, или хватает места выставить хотя бы половину первой полосы, куда входит и заголовок. Все надо предусмотреть.

Заголовок должен быть виден сразу и как можно лучше. Было бы глупо прятать заголовок в самый низ первой полосы (часто книги выходят с такими заголовками-названиями, но то книги, да и уже не сейчас, потому что многие книгоиздатели давно используют стереотип, помещая название книги в самый верх обложки). Еще глупее — понадеяться на то, что кто-то из покупателей возьмет номер в руки и внимательно рассмотрит первую полосу, убедится, есть ли кроссворд на последней так далее. Броско, коротко, заманчиво — вот девиз издания, если оно желает стать популярным. Ну, пусть не популярным, но хотя бы распроданным. Итак, обращаемся непосредственно к первой полосе.

Рис. 29. Пустая первая полоса

Взглянем, что прежде всего надо сделать.

А сделать надо вот что: избавиться от Верхнего и Нижнего Колонтитулов и от номера страницы. Совсем не назначать их было бы накладно: у нас ведь может (и чаще всего) оказаться не четыре полосы, а 16, 32, 48 и даже больше. Потому Колонтитул и назначается общий сразу на все полосы.

Рисуем большой длинный (в ширину полосы) Прямоугольник и назначаем ему белый контур и белый цвет заполнения. Этим Прямоугольником закрываем весь Верхний Колонтитул.

Рис. 30. «Вот и нету великана!»

Это не все. Теперь копируем Прямоугольник в Буфер и опять вклеиваем его. Этим вторым возникшим Прямоугольником закрываем, занавешиваем весь Нижний Колонтитул.

Рис. 31. Закрыли Нижний Колонтитул

Вот теперь вся страница похожа на ту, на которой стоит поработать. Тем бол что это первая полоса.

Какого размера должно быть название газеты? Конечно, большого, конечно, хотя бы в шестую часть высоты первой полосы, тем более что имя из двух слов можно поместить в «два этажа». Это связано опять же с тем, что газету формата A31 торговцы складывают вдвое, и от привлекательной картинки на первой полосе практически ничего не остается, но зато кладут газету на прилавок так, что видно название. Если оно мелкое, покупатель (потенциальный читатель) ничего не разглядит: слишком все теперь пестро.

Значит, не думать о броской картинке. Значит, думать только о том, как «сыграет» заголовок.

Мы помним шрифт, каким писали название газеты в Колонтитуле. Это - AdverGothicC. Вот этим шрифтом и напишем.

Рис. 32. Подложка под заголовок

Прежде всего выберем соответствующую собственным вкусам или пристрастиям подложку, подкладку под заголовок. Это уже художественное решение. Кстати, по таким вот деталям иногда легко расшифровать, какому верстальщику была заказана газета. Если разобраться, по-настоящему хороших верстальщиков мало. Себя к ним, упаси Боже, не отношу, но хочу сказать о почерке. Опытный верстальщик обязательно обладает отличимым от всех почерком — как высококлассный радист. Лучше всего почерк определяется по новому изданию, где в первом номере мастеру дали «отвязаться», потому что заказчик, как правило, начиная новое дело, сам не очень хорошо знает, чего он хочет. Тем более что начинают или дилетанты в газетном деле (предприниматели, захотевшие прославиться, издавая или спонсируя некоторый печатный орган), или дилетанты в журналистике и полиграфии (к примеру, писатели), или люди, очень желающие донести до читателя какие-то животрепещущие вопросы и знающие, как это делать, но люди, совершенно не знакомые со спецификой технологии подачи материала. Здесь номер делает почти в 100 процентах из 100 — верстальщик. Тем более что все три категории таких издателей не имеют представления, что у газеты, кроме главного редактора, обязательно должен быть главный художник. Или скупятся на оплату его работы...

Очень жаль. А ведь главный художник, который решит лицо газеты, можно сказать, сделает половину дела, а то и больше. Первоначальные затраты на разработку первого макета или пилотного номера обязательно окупятся. А уж если художник на этом деле собаку съел... Но в жизни не так.

Большую роль играет привычка. Когда-то, лет пять-восемь назад вышел первый номер газеты «Мир новостей». Тогда это была необычная газета, освещающая многие вопросы повседневности и ведущая несколько популярных рубрик. Но лицо газеты по сей день практически не изменилось, хотя техника, которой делается газета, давным-давно шагнула далеко вперед. Возникают и исчезают программы, меняется операционная среда... До сих пор в «Мире новостей» не научились ставить вместо дефисов тире. Из-за этого резко снижается доверие к изданию: они заявляют, что у них тираж 800 тысяч экземпляров, а я вижу, что набор осуществляется до сих пор в MS-DOS. Или, на худой конец, в примитивном «Ворде». Конечно, при периодичности один раз в неделю никакой верстальщик не угонится заменить все дефисы, проставленные вместо тире, на само тире. Вот наконец-то совсем недавно, с полгодика, появились в газете приличные и узнаваемые по почерку заголовки. Ну, думаю, хорошего верстальщика нашли, но ему не доверяют материал, сидит на заголовках. И что же? Недавно просматриваю газету и читаю: «Газете «Мир новостей» требуется верстальщик»... Прискорбно. Как привыкли работники газеты к такому-то типу работы с макетом, так и не собираются отвыкать. Скоро может получиться так, что «Мир новостей» перестанет кого-либо интересовать, тем более что теперь половина номера или больше — отдается рекламе.

Опытному верстальщику очень трудно в таких условиях проявить себя и стать по-настоящему полезной единицей в коллективе издательской группы. «Нет, мы так не делаем, нам так не надо», — скажут ему те, кто, сам того не желая, тянет ев издание на задворки. А он-то делал так, как надо для того, чтобы остаться плаву...

Но мы отвлеклись. Речь шла о подложке для заголовка. Нарисовали прямоугольник, закрасили его серым цветом, назначили некоторую линию вместо скучной а линии контура, скруглили углы (опять путем изменения автофигуры: оказалось, что прямые углы с колючими вершинами не очень подходят для этой газеты, хотя она у нас и чисто теоретическая). Потом я подумал и нарисовал еще один контур — внутренний. Это еще один Прямоугольник со Скругленными Углами, которые немного заострены по сравнению с тем, что рисуется по умолчанию. Этот второй Прям угольник пришлось обесцветить (назначил в меню Move Fill Colors или в поле диалога Format AutoShape опцию No Fill — Нет Заливки). Пока все.

Рис. 33. Написали имя газеты

Затем (рис. 33) назначили в поле подложки Текстовый Блок и шрифтом, о котором говорили, написали заголовок газеты. В первой строке, как вы видите, пришлось поработать опциями трекинга и ширины символа. Все это легко находится на Панели Measurement.

Пока тоже все.

Теперь скопируем написанный текст в Буфер Обмена. Делается это выделением самого текста, а не блока. Если выделить текстовый блок, то лишь блок и скопируется. Особенно учтите это обстоятельство на тот случай, когда вам придется что-нибудь вырезать, чтобы потом вставить. Может так получиться, что вы долго работали над содержимым, а потом в одну секунду его потеряли. Вставляете из Буфера, а вставляется только пустой блок... Выделяйте тест мышкой — либо протаскиванием, либо тремя щелчками. И уж тогда копируйте в Буфер. Все скопируется с теми настройками, какими обладает данный текст.

Потом я нарисовал Тестовый Блок ниже серого поля. После того, как вы нарисовали текстовый блок, в нем обязательно запульсирует курсор. Это значит, что блок готов принимать текст. Что ж, дадим ему текст. Командуем Вставить — или в меню Edit, или с Панели управления. И наш «Свет разума» в виде почти идентичного дубликата появляется в поле Текстового Блока. Почему «почти»? Потому что не рисовал я новый Текстовый Блок с точным приближением к первому. Рисовал на глазок.

Рис. 34. Дубликат названия газеты

После этого совершаем следующие действия. Выделяем текст в новом Текстовом Блоке и через кнопку Панели управления Цвет Текста назначаем цвет — белый. Затем открываем кнопку Заливка (рядом на той же Панели) и назначаем Fill, то есть полную прозрачность фрейма.

Берем Блок с белым текстом и, принеся на серое поле, оставляем там — вы: видите на рисунке 35. Получился белый текст и его тень, причем резкая, черная.

Рис. 35. Заготовка заголовка

Дальше. Я придумал вставить в серое поле заголовка вместо логотипа — фото Стоунхенджа, древнейшего памятника на территории Англии, авторов которого никто всерьез не знает. Стоунхендж, как доказал Дж. Хокинс еще в 1963 году, использовался как древнейшая обсерватория и одна из самых древних вычислительных машин. Что это, как не разум? А разум — свет. Кстати сказать, я выбрал фото именно поэтому: Стоунхендж умнее нас всех, с нашей продвинутой! наукой. Как бы мы ни пыжились, наука и техника наши очень здорово умеют лишь... убивать. На пользу работают плохо. Заразить атмосферу, выпустить наружу опасный вирус — это мы умеем. Лечить не научились, а выпускаем...

Рис. 36. Стоунхендж с высоты птичьего полета (аэрофотосъемка)

Как видите, заголовок обошелся без логотипа. К тому же, когда вставили, оказалось, что черная линия внутреннего контура не гармонирует с фотографией. Пришлось не только назначить белую линию, но и поменять ее толщину — вместо % pt теперь 4 pt.

Еще я все то, что нарисовал и вставил, приподнял повыше, чтобы край серого фона совпадал с верхним краем назначенного мною же прежде на Мастер-Странице Верхнего Колонтитула. В момент передвижения был такой момент, когда белые буквы заголовка отстали от черных, мне это показалось симпатичным, и потому вы видите сейчас примерно ту картину, которую я хотел бы оставить.

Дальнейшие действия не нуждаются в объяснениях. Написано и поставлено на свое место (Газета для всех» и «№1 (1) 2002 г.». Потом к изображению Стоунхенджа я пририсовал один вертикальный, а другой горизонтальный тонкие прямоугольники и назначил им градиентную заливку.

Вот что получилось:

Рис. 37. Кажется, заголовок готов

Чтобы убедиться в его готовности и посмотреть, как все это смотрится, когда нет отвлекающих линий, особенно штриховых, которыми изобилует программа, я включил опцию Предварительного Просмотра (Print Preview).

Рис. 38. Предварительный Просмотр

Что ж, на этом работа с заголовком заканчивается. Идем дальше.

Так называемая передовица

Хотим мы или не хотим, а Слово редактора или передовая статья — почти в каждой газете есть. Это не дань старому времени. Просто газеты без позиции быть не может. Даже независимая позиция (в коей сильно-сильно сомневаюсь) — и то позиция. Эта «независимость» приводит, в конце концов, к тому, что газета начинает ругать всех подряд — и правых, и левых, и синих, и зеленых, и даже голубых, которых недавно хвалила.

В общем, что тут рассуждать: пора действовать.

Передовая статья располагается, как правило, на первой полосе, слева — это самый первый материал газеты. У нее, как правило, или броский заголовок типа «Доколе!..», или, наоборот, совсем нейтральный — как я уже говорил, «Слово редактора» или что-то в том же духе. Так и назовем нашу передовицу — «Слово редактора». Для нее используется всегда строгий деловой стиль — от заголовка до шрифта текста. Ее подкрашивают (фрейм частенько нейтрального серого цвета), статья или заметка забирается в рамочку.

Величина передовой статьи колеблется. Обычно это первая колонка (часто захватывающая поле в две колонки). В случае, если колонки две, они на колонки не разбиваются — текст идет одной колонкой и широкой строкой. Так солидно. Так лицом в грязь не ударишь.

У передовицы нет продолжения. Поэтому ее фрейм можно ни с каким другим не связывать. Он может быть независимым, стоящим на полосе отрешенно от других. Путь это будет даже не на первой полосе, а на второй (дальше передовице грех забираться— не так поймут).

Вторая полоса для передовицы избирается не из скромности редактора, а поневоле. Например, газета «Мир новостей», посвятившая первую полосу заголовку и анонсам, вынуждена помещать передовые статьи, в которых, кстати, не любит некоего В.В. и очень любит какого-то Ю.М., на второй полосе, в левом верхнем углу. То есть опять — первым номером. Это принципиально.

Обратимся к публикации.

Вынужденное отступление

Вот открыл я свою газету, над заголовком которой просидел всю ночь, и ужаснулся. Если помните, на Мастер-Странице в Колонтитуле мы написали название газеты шрифтом AdverGothicC (как и основной заголовок, что на первой полосе). Теперь взгляните, что нам показывает Мастер-Страница:

Рис. 39. Такой «родился» шрифт

Это не все. Главный ужас ожидал меня на первой полосе:

Рис. 40. А это первая полоса

Я кинулся восстанавливать шрифт. Ведь всякое бывает, от сбоев ни один аппарат не застрахован. Ну, сместилось что-то. Сейчас выделю шрифт и назначу ему его истинное имя...

Я даже и не обратил в расстройстве внимания на то, что в графе Имя шрифта на Панели управления, в окошке списка шрифтов стоит имя AdverGoticC...

Вопрос оказался гораздо серьезнее: что-то из-за электрических сетевых или каких-то иных причин сместилось настолько, что добиться того, чтоб вместо шрифта, который вы видите в заголовке на первой полосе (это АппаС, я узнал его, хотя написано имя того, что мы назначали), установить тот. что был прежде, не представляется возможным.

Мне так жалко то «лицо» Но ничего не поделаешь. Пусть останется так, как сейчас есть. Вы же помните, как было? Слава Богу, остались рисунки — хоть на них полюбоваться...

Мы не станем восстанавливать и добиваться «справедливости», чтоб не задерживаться с рассказом об этапах верстки.

Тем более что вы видите: на Мастер-Странице наш шрифт приобрел совсем иное начертание, хотя ведь назначался один и тот же и там, и там. На Мастер-Странице, если не ошибаюсь, вы видите заголовок, исполненный в шрифте то ли Boyarsky, то ли Breeze... а на первой полосе — в шрифте АппаС...

То есть «глюк» произошел, на мой взгляд, бессистемный. Оставим его. Наши торжественные заголовки самой лучшей в мире газеты остались хотя бы на тех рисунках из последней подглавки, которые уже вошли в книгу.

Идем дальше.

Продолжение разговора о передовице

Итак, передовица.

Откроем первую полосу и построим Текстовый Блок для Слова редактора. На рисунке 41 вы его видите. Это Блок, построенный сразу на две колонки. Но колонки, заданные в Мастер-Странице, как мы помним, не разбивают тест на реальные колонки — они символизируют границы колонок, чтоб мы не ошиблись при назначении или построении конкретных текстовых блоков на конкретных страницах.

Так что текст, который мы собираемся загружать в качестве содержимого в Текстовый Блок, не станет разделяться и «упадет» на место как одноколоночный.

Рис. 41. Создали Текстовый Блок для передовицы

Напишем в этом блоке имя публикации.

Здесь сразу возникает некоторое неудобство. Если написать заголовок заодно текстом статьи, мы все время останемся связанными этим назначением, как он 6удет связан с текстом. Сами знаете, заголовки в газете — очень важная вещь, в первую очередь важная по смыслу (чтоб оценить содержание), во вторую — по дизайну. Часто приходится заголовок статьи перемещать, раздвигать, ломать, сжимал так далее. Это, конечно же, влияет на верстку текста. Чтобы такого не происходи давайте сразу же отделим заголовок от текста.

Что для этого надо? Для этого надо написать заголовок в отдельном Текстов Блоке.

Аккуратно берем мышкой маркер верхней границы готового Блока, который тол что построили, и оттягиваем его вниз. Сокращаем наш Текстовый Блок на высоту, которую предполагаем занять заголовком. После этого рисуем Текстовый Блок той же ширины и той самой высоты на этом свободном месте.

Рис. 42. Блок для заголовка готов

Теперь вписываем в этот блок название статьи. Ну, пусть это будет «Доколе!..»

Рис. 43. Заголовок статьи на месте

Теперь осталось поработать с текстом статьи. Он у нас уже где-то набран.; говорю условно: никакого текста, естественно, у меня для передовицы нет и быть может. А если есть, то это текст для других газет — для тех, что верстаются ми для заработка. Поэтому не могу предложить сюда никакого конкретного текс кроме того, который когда-то или совсем недавно написал сам. Впрочем, текс именно такого содержания у меня все равно нет, поэтому для рабочего приме можно взять любой. Возьмем, если не возражаете, начало этой книги. Там как нет рисунков, там голый текст. Визуально две колонки текста в нашей га (конкретные, куда вставляем содержимое) занимают площадь, примерно равную 0,1 листа формата А4. Учтем еще, что текст в Word набирается кеглем 11-12 и больше, а в газете такой большой кегль смотрится некрасиво и глупо. Газетный шрифт имеет величину не больше 10 pt. Часто выходят целые насыщенные номер газет, набранные, в основном, «восьмеркой» (кегль 8 pt) и редко «девяткой» (9 рt Хотя, конечно, самые приемлемые размеры — это 9-10. Если ориентироваться «десятку» (передовица вполне может быть представлена крупным кеглем — на она и передовица), то это уже примерно три четверти листа формата А4. Во столько текста и загрузим.

Откроем файл, в котором набиралась первая половина книги (книга большая, файлы у меня разделены), и выделим ровно столько текста, чтоб хватило и не был лишнего. Копируем выделенный текст в Буфер известными вам способами — и во вращаемся в Publisher. Документ, из которого забирался текст, можно закрыть, программу Word закрывать не надо, иначе будут проблемы с буфером. Есть приложения, которые по умолчанию оставляют при своем закрытии Буфер неприкосновенным, но не Word: он обязательно спросит, сохранить ли в Буфере для других! приложений тот текст, который вы туда скопировали. Чтоб избежать этих проблем, оставьте окно программы и переключитесь в верстальную.

И вот мы в верстальной программе. Выделим наш Блок, в котором должен будет! существовать экспортируемый текст, и убедимся, что курсор пульсирует в начале! Блока. После этого можно давать команду Вставить.

В операционной среде Windows это проделывается множеством способов. Первый и самый простой — нажать на Панели управления кнопку с нарисованным на ней Портфелем. Текст должен вставиться. Второй способ — найти в меню Edit команду Paste (Вставить) и щелкнуть на ней. Третий способ — вставить текст через команду Paste Special... (Специальная Вставка...). При такой вставке вы из диалога, который появится следом за вызовом команды, выбираете, в каком формате желаете вставить текст. Это может быть и формат Документов Microsoft Word, и, формат RTF, и формат ТХТ, и другие. Важно выбрать, какой вам угоден. Прежняя вставка (второй способ) имела в виду по умолчанию формат RTF — достаточно хорошо отработанный по качествам буферный формат текстов, не теряющий основных настроек текста. При выборе ТХТ вы рискуете лишиться всех тире (по меньшей мере) — та самая старинная система, по которой вставляют тексты в «Мире новостей». Мы выберем, конечно, Документы Word.

Специальная Вставка — это вставка, после которой файл остается связанным с программой, породившей его. В верстальной программе, куда попал текст, если возникнет необходимость в его правке, текст можно не править, а вызвать Word и исправить там. Особенно хорошо Специальная Вставка действует для изображений, вызывая в случае надобности программы Photoshop или Photo Editor, или какую-то иную, в которой была создана картинка.

Или та программа, из которой картинка попала на те страницы, где верстаются наши (ваши) материалы.

Четвертый способ — вставка командой с клавиатуры. Это так называемые «горячие» клавиши.

«Горячими» клавишами для вставки в Publisher, как, собственно, и PageMaker, являются Ctrl + V.

Пятый способ — вставка с использованием таких же «горячих» клавиш Windows (в том числе и Windows ХР) — Shift + Insert.

Воспользуйтесь любым из этих способов, результат будет одинаковым, за исключением случая Специальной Вставки.

Впрочем, программа Publisher очень щедра на возможности для вар: даже если вы вставите без команды Специальной Вставки, у нее, если помните, в меню Edit есть опция Правки Текста в Microsoft Word.

То есть она вас туда все равно благополучно отошлет, когда в этом возникнет надобность и независимо от того, каким из пяти способов вы вставляли текст.

Таким образом в программе Publisher, в отличие от того же PageMaker, нет отдельного Текстового режима, ибо он ей практически не нужен, поскольку она пользуется офисными настройками, то есть «Вордом».

Кстати, и набирать в Publisher можно почти с тем же успехом, что в Word, ибо она такое же детище Майкрософт.

Заметьте, я здесь говорил только о вставке из Буфера и не затрагивал, к примеру, опции Import Word Document... (Импортировать Документ Word...)...

Но как бы то ни было, выделим Текстовый Блок, убедимся в пульсации в нем курсора— и Вставим.

Рис. 44. Вставили текст в Текстовый Блок

Как видите, программа Publisher сохраняет в тексте, существующем в Буфере, почти все настройки «Ворда». Правда, я копировал текст, набранный кеглем 12, а он вставил «десяткой». Но деление на абзацы и все кранные строки сохранились. Сохранились бы и выделенные полужирным, курсивом или подчеркиванием слова. И это не все. В отличие от других верстальных программ, Publisher не только оставит в неприкосновенности, но и скрупулезно перенесет из Word все символы, вставленные в кодовой системе Unicode (из-за этого несовпадения с Word мучаются верстальщики, работающие в PageMaker и QuarkXPress. Особенно важно, что наконец-то можно преспокойно перенести ударение, титло и градусы, минуты и секунды (угловые единицы измерения).

Но взглянем на конкретный текст. Вы видите, что его не много, даже чуть-чуть не хватило. Но это еще не значит, что у нас возникнут какие-то проблемы. Наоборот, некоторый воздух для верстальщика всегда лучше, чем недостаток его. Впрочем, с небольшим недостатком места всегда можно справиться. К тому же, некоторый воздух внизу нужен нам для подписи автора.

И еще одно обстоятельство. Уверяю вас, текст, который набирался мною в Word, не был в некоторой своей части отформатированным. К примеру, я нарочно не проставил переносов. Потому что и в PageMaker, и в QuarkXPress назначение переносов при импорте текста теряется за бортом, там надо снова почти все назначать. Здесь же программы Publisher и Word так хорошо понимают друг друга, что Publisher не составило никакого труда самостоятельно, по умолчанию установить переносы в тексте. Убедитесь:

Рис. 45. Переносы текста существуют


Глава 1

Верстаем газету (III)

Вас может смутить, откуда появилась в рабочем поле Панель Measurement (Размеры). Поясню: я вызывал ее тогда, когда растягивал ширину символов в слове «Доколе!...». Обратите внимание, на каком-то из рисунков должны быть эти значения, которые получил заголовок передовицы.

Что ж, теперь наша задача — отверстать текст передовицы. Пока что он сыроват, хотя может оказаться, что и вполне приемлем для публикации.

Еще обращаю ваше внимание: на рисунке 45 видно, что текст разместился с некоторыми отступами от границ Блока. Плохо это или хорошо? А если хорошо, то для чего это нужно?

При верстке часто используются всевозможные рамки, в которые забирается; текст, создать рамку — не проблема. Но поместить ее на готовую верстку — мученье. Как правило, уже после того как вы отверстали всю газету, заказчик тычет пальцем в громадную статью, где вы, применив все свое мастерство, еле-еле! уместили в десять колонок текст, рассчитанный на пятнадцать:

— Сюда вот еще две фотографии нужно — я как раз вчера нашел. А саму статью — в красивую рамочку!..

Вы скрипите зубами, но хозяин — барин.

Фото — понятно, но чем вам рамочка не угодила?

А вот чем. PageMaker не учитывает таких заказчиков и по умолчанию автоматически размещает текст по колонкам от границы до границы. Если вы захотите по границам пустить хоть небольшой контур, придется корректировать ширину колонки в сторону уменьшения. Но поскольку это касается только крайних колонной, то и корректировка идет не автоматически, а вручную. Но едва вы сократили ширину первой колонки текста на два миллиметра, как тут же, мгновенно ломается верстка всех десяти колонок! Верстка — «это не только ценный мех...» и так далее. Верстка — это и «хвосты», возникающие неизбежно, если речь идет о переделке ширины текста. Это и висячие строки, и тире в начале строки, и много чего другого, что для вас, специалиста, отвечающего за качество своей работы, неприемлемо. Возьмет читатель газету в руки: «А ну посмотрим, кто ее верстал...»

В Publisher запас ширины заложен по умолчанию. И за рамкой вы можете не бегать, а назначить границы фрейма видимыми и какой угодно формы, в том числе и художественные рамки, которые мы с вами видели в опции BorderArt (Художественные Границы) диалога Format Text Box (Форматирование Текстового Блока), который можно контекстно вызвать двойным щелчком мышки на границе Блока, подлежащего такого рода (иного тоже) форматированию.

Запомним это — то, что рамку всегда можно назначить. А сами пока займемся версткой. Начинается она, как известно, с первой строки. Возможно, с первого слова.

Верстка

Есть еще одно существенное отличие программы Publisher от других верстальных программ. Это то, что текст в Publisher, как бы ни был он мелок, представляется не плашками, а текстом.

Верстальщикам, привыкшим верстать в плашечном представлении, будет на первых порах непривычно. Дело не в том, что плашечный текст удобнее или неудобнее верстать, а в том, что непривычность получается чисто психологическая.

Ведь верстка в плашечном режиме — это для верстальщика первый этап верстки, после которого обязательно наступает второй — с истинно представленным текстом. Первый этап (плашечный) — это грубая верстка, второй — тонкая, когда ликвидируются все ошибки первого, о которых мы уже говорили.

Образно говоря, если первый этап — это, в основном, как говорится, ликвидация хвостов и висячих строк, то второй этап — подвижка единичных знаков (тире, одной буквы из начала предложения в предыдущей строке, двух знаков из конца предложения на последующей строке) и ликвидация «блядских» строк... А тут — как бы сразу тебе и первый, и второй этап «в одном сосуде»!

Но потом это впечатление у пользователя быстро проходит, и отсутствие плашек нисколько не мешает работать.

Итак, начнем рассматривать текст с первой строки...

Ничего из перечисленного, то есть никаких безобразий мною не обнаружен. Такое ощущение, что текст верстался сам собой.

Единственное, что я нашел — это хвостик в последнем абзаце. Поджимать строки при помощи уменьшения интервала между знаками в строке невыгодно: строчка подберется в абзац, и мы получим еще больший воздух в самом низу, чем было прежде. Поэтому нам надо растянуть ненамного этот абзац, чтобы последняя строка приблизилась к полной. Идеальной можно считать ту неполную строку, которая длиннее середины полной строки. Так и сделаем.

Абзац до назначения трекинга вы видите на рисунке 46, а тот же абзац после назначения трекинга — на рисунке 47.

Рис. 46. Таким был абзац

Рис. 47. Теперь абзац стал таким

Учитывая, что даже если проставить имя автора статьи, все равно останется воздух, передвигаем весь текст вниз клавишей Enter. Поставив курсор, естественно, перед самым первым абзацем. И записываем фамилию автора, назначив выравнивание по правому краю. Вы видите это событие на рисунке 48.

Рис. 48. Записана фамилия автора статьи

При верстке газеты верстальщика подстерегает и еще одно коварное обстоятельство. Мы с вами пока что лишь приблизительно отверстали текст (правда, можно сказать, почти не верстали) лишь одного материала. А рядом будут другие или другой. Выравнивание по краю или по ширине, которого достаточно для того, чтобы материал выглядел прилично, еще не все, что нужно сделать с этим материалом. Надо выровнять его так, чтоб он соответствовал и выравниванию соседних материалов. С большим материалом проще — все последующие колонки его непосредственно связаны с первой колонкой и выравнивание идет чаще всего автоматически. Но как сделать соответствующими друг другу соседние не связанные между собой материалы?

Как мы помним, в диалоге Format Text Box имеется вкладка Text Box, а там есть опция Vertical alignment (Выравнивание по вертикали). Она нам и нужна. Не спутайте с таким же выравниванием объектов. Хотя Текстовые Блоки тоже надо выровнять с помощью этой опции меню Arrange, и даже прежде всего.

При подборе нескольких (или двух) разных материалов выравнивание их блоков и содержимого (текста) легче всего поводить по нижнему краю, то есть назначать вариант Bottom (По Низу). Выравнивание По Верху (Тор) применимо как раз для другого случая — для соседних (или всех) колонок одного и того же текста.

В нашем случае мы выравниваем по низу. Верха практически нет: он занят не только Заголовком газеты (кстати, мне горько было смотреть на несуразный заголовок, получившийся не по моей вине, и я все же назначил несколько иной шрифт, по своим формам более-менее подходящий, но, конечно, не тот), но и заголовком статьи. Я выровнял тест по нижнему краю Блока.

Потом охватил границами нашего Текстового Блока и верхний Текстовый Блок, в котором содержится заголовок статьи. Потому что следующим моим шагом будет назначение для передовицы приличной, но не вычурной рамки. Что я благополучно и сделал в том же диалоге (вкладка Colors and Lines). Вот результат:

Рис. 49. Это верх передовицы

Рис. 50. ...И ее низ

Ну, вот, кажется, пока и все с передовицей. Двинемся дальше.

Обратите внимание: все наиболее ценные для привлечения покупателя газеты заголовки, сообщения и так далее — должны находиться в верхней половине первой полосы, потому что нижняя половина подвернута под верхнюю: ведь газета, когда лежит на лотке, обращена к покупателю в лучшем случае лишь верхней половиной полосы, где есть имя газеты.

Правую часть полосы, пока пустую, лучше всего занять какой-нибудь интригующей информацией. Чаще всего это может быть анонс материалов, которые содержатся в этом номере. А можно так не делать — ведь у нас всего четыре полосы. Можно дать интригу другим способом. Поместить, допустим, интересную фотографию, чтобы, увидев хотя бы часть которой, потенциальный читатель захотел купить этот номер газеты. Именно этот номер. Именно этой газеты. Не забудьте, что для привлечения читателя у вас осталось не так много места на полосе: ведь все, что ниже середины листа, человек не увидит, пока не купит экземпляр. Надо угадать, что показать. Может быть, это будет фотография Президента. Может быть, фото известного актера или шахматиста. Может быть... чем черт не шутит, может быть, и эротическая фотография. Хотя с таким приемом я категорически не согласен по множеству разных причин.

Ну, оставим этот вопрос для решения автору газеты, а не верстальщику. Верстальщику главное — представить все, что выбрано редакционной группой, в выгодном свете, только и всего.

Сойдемся на том (условно), что помещенная мною на первую полосу фотография очень заинтересует покупателя газеты. Хотя на самом деле многие и многие издатели газет отдали бы год жизни за то, чтобы в их газете на первой полосе была интригующая фотография, но их катастрофически мало, а если и есть, то не у нас, а у конкурентов...

Поместим любую фотографию, сделав вид, что она — та самая. Выберем портрет девочки — той, что на обложке книги.

Вставка рисунка происходит, как вы помните, очень просто. Не обязательно из меню Insert (Вставка). Выберем на Панели инструментов кнопку Picture Frame (Фрейм Изображения) и нарисуем квадрат в том месте, где должен быть рисунок (инструмент рисует только квадрат, а рисунок потом вставляется по ширине этого квадрата — независимо от высоты самого изображения.

Рисуя квадратный фрейм, захватываем верх всех трех свободных колонок.

Рис. 51. Нарисовали Фрейм Изображения, но кнопку мыши еще не отпустили

Отщелкиваем кнопку мыши — и исчезает квадрат, будто его не было. Через мгновенье появляется диалог вставки рисунка:

Рис. 52 а. Диалог выбора изображения

Отметим необходимый файл и скажем кнопкой — Insert (Вставить). И рисунок (фото) — на полосе:

Рис. 52 б. Вставили рисунок

Видим, что рисунок вставился в середину квадрата, которого теперь уже нет. Теперь Блок изображения ограничен рамками самого фотоснимка.

Местоположение изображения нас не устраивает. Подтягиваем его к самому верху, под область заголовка.

Рис. 53. Подняли фото до заголовка

Теперь понятно, что фото пришлось по своим пропорциям как нельзя лучше, и наши задачи этой вставкой вполне решаются. Почти все изображение оказывается в верхней части полосы. Правда, идеально оно должно было нижней границей попадать на точно на середину листа. Когда перегибается портрет — это больно. По законам изобразительного искусства есть линии, по которым можно резать человеческую фигуру, а есть — по которым нельзя. «Больно», — говорил Евгений Алексеевич Ноздрин, замечательный художник и педагог детской художественной школы. Мне посчастливилось поучиться у него. Взгляните на рисунок 54: фотография выступает вниз на каких-нибудь парочку сантиметров, а всего ее высота 12-13 см.

Рис. 54. Общий вид полосы

Теперь нам предстоит заполнить полосу до конца...

(Что-то происходит у меня со шрифтами. Я выключил ПК и теперь, когда опять включил для продолжения работы, вновь наша газета вставила в заголовок шрифт АnnаС. Больше не стану исправлять — ведь вы видели, как изначально выглядела первая полоса. Теперь не стану обращать на заголовок внимания.)

Идем дальше. Нужен материал на первую полосу, чтобы она была окончательно заполнена. Можно поместить некоторую рекламу — самого главного рекламодателя, например. Но она должна быть маленькой и не перебивать ни в коем случае самого содержания. Можно, к примеру, поместить ее вдоль всего свободного низа узким прямоугольником. Так и сделаем.

Что и как проделывать с фреймами, вы знаете. Не стану заострять внимания ни на назначениях фрейма, ни на назначениях его контура. Также не вызовет затруднений и заполнение блока, и изготовление той надписи (вместо истинного рекламного текста), которую я сделал.

Рис. 55. Вставили рекламу

Осталось место для небольшого материала под портретом. Не забудем и про заголовок.

Но пока повнимательней взглянем на вставленный Блок с Рекламой. Что-то в нем не так. Нет изюминки. Может, сделать не сплошную заливку, а градиентную? Сделаем.

Рис. 56. Сделали градиентную заливку

Как сделать такую заливку, вам рассказывать не надо. Можно лишь напомни что из того же диалога Форматирования, который можно вызвать двойным щелчком мышки на Блоке. Назначения идут в поле Color: (Цвет:) из последней строки открывающегося меню, которая касается Эффектов Заливки... (Fill Effects...).

Но опять чего-то не хватает... Может, что-нибудь повернуть, развернуть? Выделим Текстовый Блок со словом «Реклама» и попробуем потянуть за зеленый маркер...

Рис. 57 а. Вот теперь вроде бы ничего

Итак, обращаемся к свободному месту на полосе. Что можно вставить сюда? Я, кажется, нашел. Чтобы доказать с первой же полосы, что мы выпускаем серьезную газету, поместим на первую полосу фрагмент из новеллы хорошего писателя! Александра Лисина «Певец Серебряного века». Фрагмент вполне законченный, думаю, и сам Лисин не обидится, если встретит кусочек из своей новеллы в качестве примера для этой книжки. Впрочем, чтобы обезопасить тылы, фрагмент я подам так, что прочесть его будет или невозможно, или с огромным трудом. То есть постараюсь сделать так, чтоб автор не запросил с меня гонорара за публикацию. Наоборот, если такой вопрос возникнет, платить придется ему — за рекламу его имени и имени его произведения. Шутка, но доля истины в ней наверное имеется. Итак, взгляните сначала, как это получилось:

Рис. 57 б. Поместили фрагмент новеллы

А теперь я вкратце расскажу, как и что делал.

Сначала я создал узкий длинный Текстовый Блок, в который вписал имя автора, название новеллы и подзаголовок — «Фрагменты из новеллы». Потом назначил шрифты и кегли так, чтобы следующим шагом повернуть все это на 90 градусов. Правда, такой способ подачи материала практикуется больше в журналах, но никто не запрещал делать это и для газетной полосы.

Такой способ мне понадобился для того, чтоб отделить сам фрагмент от скучной длинной полоски передовицы. Таким образом страница газеты (полоса) приобрела некий дизайн.

Повернул я весь Текстовый Блок, используя зеленый его маркер, который для того и существует, чтобы за него вращать блоки. Сделать это легко, так как, едва

431 блок принял вертикальное положение и был сдвинут на первую колонку (с которой предварительно за ненадобностью удален прежний текстовый блок размером с колонку), он сам как бы прилип одной своей стороной к направляющей. Выравнивать по этому поводу (вращение) в программе не приходится. В отличие, кстати, от PageMaker, где текстовые блоки не очень желают «прилипать».если их приходится поворачивать на 90 градусов.

Затем я удалил и последний текстовый блок (из пятой колонки), а блок четвертой колонки выделил и сжал до размеров таких, чтобы он поместился между портретом и рекламой. Потом растянул этот Блок по ширине — до конца пятой колонки и. захватив часть третьей, поближе к заголовку. Таким образом и из этих двух колонок я сделал одну. Это не обязательно проделывать в каком-либо другом случае, но мне показалось, что здесь такой подход уместен.

И в новый блок вставил известным вам способом сам фрагмент текста. Он поначалу не уместился, тогда пришлось его выделить и назначить другой кегль («девятку»), а также открыть диалог Line Spacing... (Интерлиньяж...) и назначить другой интерлиньяж вместо установленного по умолчанию (0,9 sp вместо Isp). Текст прекрасно уместился и не оставил желать лучшего. Потом осталось только просмотреть его и где надо подправить по части верстки.

Сейчас взглянем, как стала смотреться законченная полоса.

Рис. 58. Что ж, вроде бы ничего.

В черно-белом варианте, если вы заметили, возникает иллюзия того, что прямоугольник, по которому наискосок записано слово «Реклама», завалился правым утлом вниз. Но это иллюзия (я никуда его не вращал), он четко привязан своим нижним краем к горизонтальной направляющей, определяющей границу нижнего поля. Думаю, впечатление усугубляется и тем, что у прямоугольника скруглены углы.

Вторая и третья полосы

Итак, первая полоса, будем считать, у нас получилась. Открываем вторую и третью.

Здесь у нас располагается материал историка, атлантолога, писателя и вообще замечательного человека Владимира Ивановича Щербакова. Статья В. Щербакова посвящена открытию в Туркмении древнего Асгарда — города богов. Пересказывать ее я не стану, но кое-что вам удастся прочесть по рисункам. Статья уже была опубликована в газете «Высший свет»,но, как я говорил, тираж ее настолько мал, что не грех частично и воспроизвести ее в нашей условной газете, которая имеет удивительно малый тираж — один экземпляр, да и то он пока в перспективе, поскольку находится в непосредственной работе, и вы посильно в ней участвуете.

Для той газеты я сочинил в CorelDRAW заголовок и превратил это свое сочинение в изображение формата TIFF. О том, как это можно сделать, читайте мою книгу того же издательства «CorelDRAW 10 — художнику».

Сейчас я достану это изображение и помещу на полосу газеты. Технология вставки рисунков вам ясна, поэтому просто взглянем на то, что получилось:

Рис. 59. Вставили название статьи

Чтобы не мешать последующему размещению текста, я уберу пока этот заголовок на монтажный стол (за пределы страниц) — это делается простым захвати мышкой и перемещением.

Теперь займемся текстом. С ним тоже все в порядке, вы уже знаете, как он попадает на полосу газеты.

Щербаковскому тексту предпослана авторская врезка, которая идет как бы отдельно, но без нее статья выглядит (выглядела бы) неполной. Поэтому с врезки начнем.

Да, но прежде — совсем забыл — надо над заголовком проставить имя автора, чтобы не забыть. Иногда верстальщики впрямь забывают это сделать.

Для того, чтоб имя автора было рядом с заголовком, рисуем там, над изображением заголовка (я уже говорил, что это не текст, а растровое изображение, сделанное в CorelDRAW и экспортированное в TIFF), узкий длинный горизонтальный Текстовый Блок. В него и вписываем: «Владимир Щербаков».

Рис. 60. Имя автора и заголовок материала

На рисунке вы видите, что я выделил и Текстовый Блок, и изображение. Это значит, что я хочу привязать их друг к другу, чтоб имя автора ни в коем случае не потерялось. А связать их можно очень даже просто — скомандовать Group (Сгруппировать) из меню Arrange (Порядок, Упорядочить). Тогда оба блока приобретают общие свойства и границу. Они воспринимаются программой как объект (единый блок), а значит, соответственно и унаследуют от Блока все черты. Теперь и текст, и изображение вместе воспринимаются как новый рисунок.

Рис. 61. Сгруппировали два блока...

Рис. 62. ...и унесли на монтажный стол

Теперь находим врезку. Она — в материалах той газеты. Слава Богу, они уничтожены, поскольку память ПК позволяет их пока что хранить.

Рисуем Текстовый Блок размером с эту врезочку и роняем в него текст. Потом вызываем диалог Форматирование Текстового Блока и назначаем цвет блоку и контур. Оставим контур толщиной 0,75 pt — просто чтоб он был. Цвет — примерно 65 процентов черного, то есть темно-серый. Проценты вы не увидите, но в системе RGB все три показателя составляют по 122. Выбирается чаще всего на глаз, по окошку просмотра того, что у нас может получиться. А получилось вот что:

Рис. 63. Врезка для статьи

Да, темновато. Как же на таком фоне будет смотреться текст?

Не огорчаемся: ведь я нарочно сделал темный фон для врезки — во-первых, для того чтобы врезка выделялась, чтобы заголовок не забил ее. Во-вторых, я еще не назначил цвет текста — белый. Назначение делается просто — с Панели управления, кнопка — Цвет Текста.

Рис. 64. Кажется, врезка готова

Идем дальше.

Теперь наша задача — «посадить» на полосу текст. Возвращаемся в файл текста, выделяем его и копируем в Буфер Обмена.

Возвращаемся в публикацию «Газета».

Теперь подправим длину первой и второй колонок, ибо верх сейчас занят врезкой.

Выделяем Текстовые Блоки первой и второй колонок и сжимаем их рост. Он должен получиться одинаковым, потому что каждый Блок уменьшится на равное число шагов. При масштабе 66%.это легко сделать на глазок.

После этого Вставляем текст в первую колонку. Как только текст вставится, программа задаст по-английски вопрос, надо ли продолжить вставку текста в следующие блоки.

Рис. 65. Нет, даже не спросила

Программа задает такие вопросы тогда, когда мы создаем совсем новый блок. А когда пользуемся давно созданными и уже связанными (помните, мы связывали все блоки в начале работы?), вставляет текст по умолчанию.

Теперь вставим приготовленные для статьи иллюстрации. Одна из них — та, которую вы видите на рисунке 432. Это бог Один, его изображение, найденное в Туркменистане, о чем как раз идет речь во врезке.

Рис. 66. Вставили одну иллюстрацию

Пока я не поставил иллюстрацию в текст. Она помещена на свободную третью полосу, ожидая своего часа. Дело в том, что там есть еще две иллюстрации, которые очень важны для статьи. Их мы также вставим. И тоже отнесем в сторону, ибо над ними надо совершить еще некоторые манипуляции.

Рис. 67. Все три иллюстрации попали на страницы публикации

Теперь сохраним публикацию. Как вы помните, Publisher, как и все приложения Office автосохраняется каждые 10 минут, но на всякий случай обязательно сохраняйте публикацию после осуществленной операции, ибо береженого Бог бережет.

Но раз все наши «картинки» на месте, займемся черновой версткой текста.

Назначим ему все параметры форматирования, которых он, может быть, лишен. Потом дадим выравнивание, абзацы и так далее. Это обязательно надо сделать, чтобы потом знать, в какой части текст должен подвергаться верстке.

Я похвалил Publisher за то, что текст, экспортированный в него из Word, будто по мановению волшебной палочки получает все свои назначения и даже почти не требует не то что форматирования, а и верстки... Но с этой статьей вышла промашка. Текст, в Word бывший строго отформатированным, здесь почему-то только сохранил шрифт и разбиение на абзацы. А вот выравнивание по формату (ширине) и переносы потерял.

Выравнивание я задал здесь, в Publisher, но переносы так и не появились. Пришлось подумать...

И я нашел причину этого. Я вспомнил, что набор делал прямо в PageMaker, когда версталась газета «Высший свет», а потом, поскольку мне этот файл в программе PageMaker был уже не нужен, я выделил текст и, вставив его из буфера в Word, сохранил как вордовский документ. Вероятно, в тексте сохранились кое-какие специфические черты адобовских настроек, и теперь Publisher не воспринимает этот текст как русский.

Так и оказалось. Открыв в меню Tools (Инструменты) опцию Set Language... (Назначение Языка...) в подменю Language (Язык), я обнаружил, что диалог Назначения Языка считает, что язык для этого материала не назначен (no proofing). Тогда я выбрал русский (Россия) — вы видите это на рисунке 434.

Рис. 68. Выбираем язык

После того как я сказал ОК, переносы сами собой появились:

Рис. 69. Переносы тут как тут

Итак, текст готов к предварительной верстке. Мы станем заниматься практически только висячими строками, потому что, обратите внимание: текст уже выровнен без нашего участия. Это видно и на рисунке 69, и на рисунке 70 (выравнивание по нижним направляющим). Верх также выровнен.

Рис. 70. Выровнено без нашего участия!

Но перейдем пока к трем иллюстрациям, что ждут нас на третьей полосе. Как вы успели заметить, заголовок с привязанным к нему именем автора я уже поставил примерно на место.

Что нам нужно от тех иллюстраций? Во-первых, точно подогнать их по размеру колонки. Во-вторых, под каждой сделать подпись. Потому что не ясно, что каждая иллюстрация означает.

Начнем по порядку, с первой — скульптурного изображения бога Одина. Так и напишем:

Рис. 71. Подписали первую иллюстрацию

Теперь привяжем эту подпись к рисунку точно так же, как это сделали с именем автора, когда привязали его к картинке заголовка. То же проделаем и с двумя другими рисунками. Вы видите на рис. 72, что они готовы к тому, чтоб их транспортировать в текст. Все три иллюстрации, завязанные с их подписями, я нарочно выделил, чтоб вы убедились в том, что подписи связаны.

Рис. 72. Все рисунки готовы к помещению в текст

Теперь аккуратно вставим рисунки в текст, чтоб получилась приемлемая полоса. После долгих или недолгих манипуляций вот что у меня получилось:

Рис. 73. Рисунки уже в тексте

Текст чуть вылез за пределы полосы. Это не страшно, такое превышение объёма для верстальщика не представляет проблемы, с ним легко справиться. Иногда эта можно решить за счет ликвидации хвостов, которые так или иначе все равно придется убирать. Вот это и попробуем сделать.


Глава 1

Верстаем газету (IV)

Но прежде надо сделать то, о чем я как будто забыл. Пока что мы ведь расставили рисунки условно, без учета Их изобразительного «веса». Речь идет об эстетике полосы. Сейчас полоса, можно сказать, просто напичкана рисунками, и все. Нет художественного баланса. Попробуем приблизиться к нему. Обсуждать эту тему бесполезно, потому что сколько художников, столько и мнений. Чувство композиции одного художника не обязательно совпадает с таковым же другого. Я имею возможность придерживаться лишь собственной интуиции. С ее позиций и поменяю распределение рисунков. К рисункам же ведь относится и заголовок, и даже врезка.

Врезка останется на месте, потому что по логике она должна там быть. От нее, значит, и надо плясать, от нее строить баланс, выдерживать равновесие.

И вот что у меня получилось (не самый лучший вариант, может быть, но все же, думаю, лучше, чем было):

Рис. 74. Подправленное расположение рисунков

Вот теперь, приняв это распределение картинок за аксиому, и начнем верстать. Верстка, как я уже говорил, сводится в Publisher почти исключительно к «отсекновению хвостов». Начинаем, естественно, с первого абзаца, с чего и должна начинаться верстка.

Рис. 75. Этот абзац исправим

Последнюю строчку первого абзаца можно посчитать за «хвост», хотя и с долей натяжки. В принципе, если не нужда (поиск нескольких строк для того, чтоб уместился весь текст), такие «хвосты» — вовсе не хвосты, их можно оставлять, тем более в газетной публикации. Но выделим и подожмем. Для этого достаточно щелкнуть в счетчике опции Трекинга на Панели Measurement всего один разочек на нижней кнопке. Оказалось, что у нас был положительный Трекинг (104,1), а стал нулевой — 100. Если помните, все значения Трекинга подаются в процентах. Отрицательный трекинг — это менее сотни. Сто — это, как говорится, полная (или круглая) шпация.

Итак, поджали одну строчку. Обязательно просмотрели внимательно всю первую колонку, чтобы убедиться, удачно ли все произошло. Убедились. Во второй тоже.

А вот начало третьей колонки — выше слова «Владимир» в имени автора статьи. Как видите, ужатие на одну строку пришлось как нельзя кстати: как раз над этим словом заканчивается абзац, то есть у нас нет теперь этой висячей строки. Так одним назначением решили сразу две проблемы.

Рис. 76. Абзац удачно заканчивается — как раз над заголовком

Идем дальше. С третьей колонкой тоже все нормально, с четвертой тоже. А вот в пятой, в самом верху — явный хвост. Его-то и ликвидируем.

Рис. 77. Пятая колонка: обратите внимание, осталась только одна лишняя строчка

Рис. 78. Ликвидируем этот хвост

Рис. 79. Верстка статьи закончена

Что ж, верстка завершена. Вторая полоса почти готова.

Чего на ней не хватает? — Рубрики.

Впишем: «Писатель и сенсация». Создадим Текстовый Блок и впишем. Здесь не будет никакого обтекания текстом, Блок Прямоугольник с Закругленными Краям не повлияет на текст Рубрики потому, что Прямоугольник находится на Мастер Странице.

Создав Текстовый Блок, впишем в него этот текст и назначим белый шрифт поскольку подкладка для рубрики — черная.

Потом соответственно выберем гарнитуру этого шрифта. С этим мы уже непосредственно сталкивались (особенно весьма яркий пример с именем шрифта для заголовка газеты).

Рис. 80. Создали Текстовый Блок для Рубрики

Сначала впишем обычным шрифтом, который в программе установлен по умолчанию — это наш знакомый-перезнакомый Тайме.

Рис. 81. Вписали имя Рубрики, теперь назначим шрифт и кегль

Я не стану называть имя шрифта, поскольку, как мы убедились с заголовком газеты, у меня что-то, случилось со шрифтами. Кегль же — 16-й. Впрочем, имя шрифта вы тоже можете прочесть в окне Имя Шрифта на Панели управления.

Рис. 82. Назначили кегль и гарнитуру шрифта

Теперь сделаем шрифт белым и поместим его на черную плашку, приготовленную нарочно для рубрики в самом начале работы над газетой.

Рис. 83. Рубрика на месте

Итак, Рубрика готова. Переходим на третью полосу.

Материалом третьей полосы выберем стихи. В моих запасниках их найдется не мало. Но не забудем и прозу. Пусть эта полоса будет чисто литературной. Чтобы забыть, сразу же вставим Рубрику — «Поэзия и проза».

Рис. 84. Рубрика третьей полосы

Для того чтобы страница поэзии смотрелась внушительно, не надо разбрасываться и в одну обойму вставлять «много поэтов хороших и разных». Каждый из «хороших и разных» достоин своей странички. Лучше взять одного поэта и посвятить ему большую площадь.

Кстати, я, кажется, догадался, зачем существует опция Колонки на Панели управления. Конечно же, для стихов! Ведь стихи выравниваются по левому краю, и гаттер им вовсе не нужен. Более того: часто верстая стихи, в верстальных программах я сталкивался как раз с неудобством по назначению Колонок. Мне мешал интервал между колонками. В случае, если сохраняется этот интервал, стихи размещаются очень далеко друг от друга, возникает много ненужного воздуха, полоса смотрится некрасиво. Кстати, верстать стихи — это, считаю, не просто верстка, а верстка с элементом искусства. Пропорция там играет большую роль.

Простите, мне придется на секундочку отступить. Я вспомнил, что не сделал важного дела. Рисунки на второй полосе не все хорошо смотрятся. У двух из них — изображений древних монгольских и исландских рун — отсутствуют внешние контуры. Такие рисунки, как правило, очень невыгодно смотрятся. Особенно посреди текста. Если бы они располагались на странице книги, да еще отдельно от текста, из можно было бы не оконтуривать, а здесь это надо сделать. Назначения эти простенькие, поэтому скажу только пару слов.

Рис. 85. Оконтурили оба рисунка древних рун

Линия должна быть тонкой — всего в половину пункта: 0,5 pt. Это назначение мы найдем под кнопкой Line/Border Style (Стиль Линии/Границы). Только когда выделяете сгруппированные изображения, щелкайте на самом рисунке, то есть выше области подписи под рисунком, иначе образуется контур и вокруг подписи, по границам Текстового Блока Это ни к чему. Правда, можно оконтурить рисунок вместе с текстом, но тогда придется вручную рисовать прямоугольник инструментом Прямоугольник с Панели инструментов и уже потом делать то же назначение, касающееся стиля и толщины Линии.

Возвращаемся на третью полосу. В качестве автора стихов выбираем Анатолия Брагина, замечательного поэта, о котором не кричат на каждом углу, но он один из немногих — настоящий.

На рисунке 86 вы видите врезку, которую я поместил тем же способом, что и врезку Щербакова на второй полосе. Но контур пришлось рисовать отдельно с помощью инструмента Автофигуры. Дело в том, что если назначить границы Текстового Блока видимыми, их нельзя редактировать по части скругления углов. Менять можно только Автофигуру.

Рис. 86. Врезка в стихам Анатолия Брагина

Почему я поместил врезку на то место, где вы ее видите, станет ясно позже.

Врезка не моя. Врезку (и подборку стихов) сделала литературный критик Ирина Шевелева. Я только верстал эти материалы когда-то.

Теперь настал черед вставить на полосу фотографию поэта (она у меня тоже есть). Эти материалы я беру из программы PageMaker, в которой тогда осуществлялась верстка газеты.

Рис. 87. Поместили фотографию

Фото вставляется по всем правилам вставки изображений в верстальных приложениях. Оно попадает точно в середину экрана. Потом его ладо переносить на то место, которое для него предполагается. Вот и перенесем. Придется еще несколько увеличить фотографию, чтоб получше гармонировала с полосой номер 2. И вставим известным вам способом имя автора.

Рис. 88. Фото и имя — на месте

Подборка стихов называется «Царь-колокол». Теперь вставим этот заголовок. Он займет у нас всю верхнюю часть полосы. Вот для чего я сдвинул врезку.

Рис. 89. Имя подборки стихов

Наступила очередь самой верстки. Вставляем теперь текст подборки стихотворений. Определим область Текстового Блока, потому что заготовленные нами ранее колонки не пойдут. Как это уже было у нас и на первой, и на второй полосе, ужимаем колонки (не выбрасываем!) вниз. Верх всех колонок должен быть ниже нижней границы нового Текстового Блока, который вставляем.

Рис. 90. Сжали колонки и выше них назначили Текстовый Блок

Обратите внимание: я сжал не все колонки, а только четыре. Кстати, надо сейчас сжать и пятую, но на меньшую величину: вы видите, что нельзя оставлять неоправданный воздух правее врезки. Именно на пятой колонке этот воздух и будет, если мы включим ее в общий список. Пятая колонка (пятая колонна...) будет начинаться выше этих четырех (на четыре колонки разобьем только что нарисованный Текстовый Блок). Она станет начинаться сразу после заголовка — с небольшим, естественно, отступом по вертикали.

Еще успеем сжать пятую колонку. Лучше, чтоб не забыть, сразу установить связь между этими Текстовыми Блоками. Она нужна для того, чтобы текст не поверил умолчанию и вставился ровно туда, куда ему укажут.

На Панели управления выбираем кнопку Связывание (Create Text Box Link — буквально: Создать Связь Текстового Блока). При этом тот Блок, который мы только что нарисовали, надо выделить. Щелкнув по кнопке Связывания, вы сможете связать выделенный блок с любым другим — вплоть до марсианских пирамид. Надо только курсором, который принял вид кружки с чем-то жидким, щелкнуть в пределах пятой колонки. И связь установится.

Рис. 91. Связь «налажена»

Над выделенным Текстовым Блоком пятой колонки вы видите знак, который не уже видели на приводимых рисунках. Это некая плашка с зеленой стрелкой Стрелка показывает влево или вправо. В лею стрелка показывает в плашке, расположенной выше блока при выделении связанных блоков: таким образом мы имеем знак того что этот рассматриваемый блок связан с каким-то более ранним. Щелкнув на этой плашке со стрелкой, вы обнаружите, что это не что иное, как гиперсвязь, потому что после щелчка этот блок перестает быть выделенным, а выделяется тот, из которого тест перетек в этот блок.

Чтобы вернуться обратно, достаточно ниже того блока, в который мы попали, найти точно такую же плашку со стрелкой вправо. Щелкнув по ней, попадаем в следующий по очереди связывания блок, то есть в нашем случае — в предыдущий выделенный.

Если блок ни с каким другим блоком не связан, стрелок в плашках не будет. Такую плашку мы также видели на рисунках в данной книге.

Разделим наш широкий Блок на четыре колонки и вставим в первую текст. Он должен автоматически заполнить не только все эти четыре колонки, но и пятую, в) том Текстовом Блоке, с которым мы связали этот, широкий. А связали мы этот Блок с Текстовым Блоком пятой колонки. Итак, вставляем текст известным вам и наиболее нравящимся способом.

Рис. 92. Текст благополучно попал на полосу

Да, со вставками проблем практически никаких. С версткой, насколько я в ней понимаю, тоже.

Действительно, с версткой не возникло практически никаких проблем. Вот она, готовая, на рисунке 93. Вы видите уже результат, но я расскажу на словах, что и как проделывал.

Рис. 94. Стихи отверстаны

Во-первых, вы обратили внимание, что стихи поместились на верхнюю половину полосы вчерне с некоторым воздухом в конце материала. Воздух ничего не значит — ведь верстать нам все равно надо с первой строчки.

Первое стихотворение, которое не имеет заглавия, состоит из коротких строк, и оно практически не правилось. Такая правка, о которой я говорю, не означает, что мы правим самого поэта. Просто в газете из-за узкой колонки допускается стихотворную строку автора без его согласия (хотя согласие, конечно, лучше получить) разбить на две и даже больше. Это газета, и здесь поэт не станет предъявлять претензии, ибо в газете многие стихи получают непривычную для самого автора графику. Чем длиннее строчка, тем более вероятно, что после верстки она окажется подрезана. Если это происходит в книге (в моей такое было — в поэме «Городская поэма»), то технический редактор издательства просто обязан вызвать автора для согласования таких «подрезок». Если автор не согласен, издательству придется решать — не назначить ли книге другой формат. Это происходит редко, но все же бывает.

Но идем дальше. Строки второго стихотворения уже должны подрезаться: многие не уместились в колонку, хотя и не все. Вообще-то подрезку решает не один человек, и уж конечно не верстальщик. В моем конкретном случае автору «повезло» — я еще и редактор (образование Высших литературных курсов при Литинституте имени М. Горького). Дело в том, что строка может быть подрезана не на каждом первом попавшемся слове, а на сочетании слов, не подрывающем смысл. Например, строка «Мы виноваты перед божьим миром...» не может быть подрезана таким образом: «Мы виноваты перед. ..» Или таким: «Мы виноваты перед божьим...» Вариант один: «Мы виноваты перед божьим миром». И так далее. Здесь должно срабатывать и чувство слова, и логика словосочетаний, да и художественное чутье, наконец. Однако даже при самой высокой «художественности» такого действа, как разбиение строки «лестницей» разбиение это не идет на пользу стихам. Хотя бы даже в том смысле, что почти каждого поэта таким образом можно уличить в «маяковщине», чего за ним, как правило, не водится. А уж за Анатолием Брагиным — точно не водится.

Вот не подрезке-то мы и добавляем в колонки некоторый визуальный интервал, которого на самом деле при таком назначении колонок (с Панели управления) в Текстовом Блоке нет. Хотя небольшой гатгер, конечно, есть. Он здесь, в Publisher, называется шпацингом. Обратите внимание на рисунок 95.

Рис. 95. Так можно назначить гаттер

Да, конечно, смешно было бы от верстальной программы получить «неделимые» колонки. Само собой разумеется, такого типа назначения колонок тоже корректируются.

Из рисунка 460 видно, что по умолчанию здесь тоже есть небольшой гаттер — 0,199 см, то есть фактически 2 мм. Счетчиком мы можем увеличить интервал между колонками с определенным, заданным по умолчанию шагом. Следом за 0,199 см идет величина 0,449 см, то есть почти те самые приемлемые для верстки 5 мм. Следующий шаг — 0,699 см. Но вы вполне можете вписать и «нешаговый» интервал 5 мм (0,5 см) и щелкнуть клавишей Enter. Назначение произойдет обязательно. Впрочем, для стихов, как говорилось, частенько невыгодно назначать интервалы. Но назначить их можно, если есть такая необходимость, из того же диачога Format Text Box (Форматирование Текстового Блока), в диалоге, который скрывается под кнопкой Columns... (Колонки...). А сам диалог Форматирование Текстового Блока, как вы помните, вызывается двойным щелчком на границе этого Текстового Блока,

Что еще можно сказать?

Правила верстки стихов предполагают не оставлять на прошлой странице название стихотворения и всего две строчки начала. Лучше подверстать так, чтобы все стихотворение, в том числе и заглавие, начиналось на следующей странице или в следующей колонке. Нельзя переносить на следующую страницу две последние строки из стихотворения, — лучше их подобрать, поджать к прошлой странице. Это можно сделать интерлиньяжем. Такая настоятельная необходимость возникла у меня в четвертой колонке. Если приглядеться, строки в ней стоят плотнее, чем в других колонках.

Лучшим переносом окончания стихотворения на следующую страницу будет перенос шести строк — стандартной строфы и половины предпоследней строфы. Впрочем, пи этом предполагается, что на предыдущей странице осталось не меньше строк плюс заглавие. Все это касается, конечно, тех случаев, когда, как у нас, в подбор пущены стихи одного автора. Со многими авторами ситуация усложняется, тут надо будет втискивать в колонку, которая по длине равна самому длинному стихотворению какого- нибудь из авторов, по два, скажем, автора с короткими стихотворениями. Или разбрасывать авторов и стихотворения в произвольном порядке (в художественном беспорядке), но ни в коем случае не перенося ни начал, ни окончаний стихотворений. Допускается длинное стихотворение какого-нибудь отдельно взятого автора поместить в/Две колонки под общим заглавием. Как видите, вариантов много.

Но и в нашем случае идеальным вариантом был бы тот, когда каждое стихотворение умудрилось бы занять свою, отдельную колонку. При числе колонок 5 и стихотворений должно быть 5. Впрочем, такая идиллия вряд ли осуществима. Да и сама по себе скучна, потому что скучно смотреть на пять стихотворений абсолютно одинакового объема и, к тому же, вполне может возникнуть вопрос о нормальности автора: трудно представить, что кто-то усердно кропает стихи величиной, допустим, в двадцать четыре строки, не более и не менее.

Что еще? Да вроде ничего, вроде все ясно.

Верстка закончилась, мы подтянули за низ пятую колонку (вернее, Текстовый Блок пятой колонки), поджав ее до нижнего уровня первого Текстового Блока.

Теперь в нижней части пятой колонки, как вы понимаете, возник вакуум — в этом месте полосы нет никаких текстовых блоков. Устраним этот недочет: нарисуем на месте пустоты Текстовый Блок. Таким образом у нас внизу находится пять пустых колонок (текстовых блоков), готовых воспринять в себя как содержимое — прозу, какую мы назначим. Обратите внимание на рисунок 461: я подтянул верхние границы всех четырех нижних колонок до уровня пятой. Известным способом четвертую колонку свяжем с новой пятой (ведь ее на этом месте не было, а та, что прежде была, подтянута вверх, и с нею связь нам не нужна.

Для работы я выбрал рассказ замечательного современного писателя Виктора Зуева Это рассказ «Мальчик Ваня и Бог». Поместим его в низ третьей полосы.

Рис. 96. Колонки готовы

Но нам предстоит еще отделить стихи от прозы. В газете не бывает, чтоб не было разделения. Без него неудобно, некрасиво. Нарисуем просто линию между низом верхних Текстовых Блоков и верхом нижних.

Рис. 97. Линия посреди полосы

Вот теперь вплотную займемся прозой. Достанем этот рассказ В. Зуева и «кинем» на страницу. Делать это мы уже умеем.

Рис. 98. Текст рассказа уже на месте

Теперь наша задача этот текст средствами верстки, предлагаемыми программой, ужать до удобоваримого состояния. Вы чувствуете, что часть текста не вошла в пять колонок? Это безобразие надо поправить. Кстати сказать, составители газет и даже опытные верстальщики как правило завышают возможности вместимости полосы. Как это произошло и со мной только что. Я-то считал, что придется еще выкручиваться, чтоб заполнить чем-нибудь пустоту, а получилось — вон как.

Выделяем весь текст и пытаемся воздействовать на ситуацию через интерлиньяж. Вызываем опцию в меню формат и назначаем вместо одной шпации по умолчанию -0,75 шпации. Получаем почти то или совсем то, что нужно:

Рис. 99. Текст уместился всего в четыре неполные колонки

Теперь с текстом можно работать. Во-первых, конечно, сдвигаем его, освобождая верхнюю часть колонок. Не всех, а —- трех из пяти. Возможно, даже двух из пяти. Это можно увидеть тогда, когда мы из существующего заголовка рассказа сделаем тот, который нас устроит. Освободив колонки (пока три), вырезаем текст названия и вклеиваем его заново в новый Текстовый Блок, нарисованный в верхней части освобожденных колонок — он шириной в три колонки. Вот что получается, если назначить тексту названия все необходимые параметры — гарнитуру, кегль, ширину символов (рис. 100)...

Рис. 100. Потихоньку цивилизуем рассказ по-газетному

Что-то вырисовывается. Не считая того, что текст рассказа следует еще верстать, внешне, кажется, все нормально. Надо лишь найти место для фото или рисунка. К прозе больше подходит рисунок — рисунок карандашом.

Где-то у меня был такой. Да, рисунок Уфы времен Великой Отечественной войны, исполненный рукою Люциана Шитова — тогда учащегося Московской художественной школы, эвакуированного из столицы в глубинку вместе со школой. Его-то и поместим:

Рис. 101. Рисунок только поместили, место для него еще не выбрали

Как видите, рисунок вытеснил часть текста за пределы. Опять «играть» интерлиньяжем мы не станем, попробуем чуть изменить кегль. Из рисунка 102 вы видите, что мы выделили весь текст рассказа и, выбрав опцию Font... (Шрифт...) и вызвав таким образом диалог, назначили в нем кегль размером 9,7 вместо 10 pt, бывшего прежде. Текст поджался почти по размеру, как надо. Остальное можно сделать трекингом — при ликвидации хвостов.

Рис. 102. Текст почти вместился

Теперь поищем место для рисунка, все еще не верстая (до точности) текст.

Рис. 103. Кажется, это место — в самый раз

Теперь видим, что карандаш очень бледно смотрится по сравнению с другими иллюстрациями этого разворота. Выделяем рисунок и с Панели изображения исправляем рисунок — убавляем яркость и прибавляем контрастность. Итог — на рисунке 104.

Рис. 104. Исправили рисунок

Из рисунка 104 видно, что наш текст (текст рассказа В. Зуева) оказался разнородным. То он набран нормальным шрифтом, то полужирным. Приведем же его в порядок и теперь-то и отверстаем, как уже умеем делать.

Рис. 105. Текст рассказа отверстали

В пятой колонке я нарочно оставил несколько хвостиков, чтобы показать, что в газете можно и такой вид верстки считать окончательным. В газете страшны только конкретные хвосты — по 3 знака (считая вместе с точкой). Наконец, разворот готов:

Рис. 106. Разворот второй и третьей полос

Считаем, что дело сделали. Впереди — последняя, четвертая полоса.

Четвертая полоса

Приступим. Откроем нашу пустую четвертую полосу.

Рис. 107. Четвертая полоса пуста

Нам предстоит заполнить и ее. Мы уже знаем, что будет на четвертой полосе. Это — кроссворд (как же без него?), познавательная статья и — выходные данные. Если останется место, можно поместить или юмореску, или анекдот, или юмористический рисунок, которым находиться на последней полосе будет как раз впору.

Начнем с определения места для выходных данных.

Для газеты формата A3 область размещения выходных данных занимает высоту примерно 5 сантиметров и ширину — в ширину полосы. Сразу отделим эту область, чтобы не касаться ее больше. Мы не станем ее даже заполнять, потому что высасывать из пальца имя Главного редактора, членов редколлегии, состав редакции и так далее — дело абсолютно ненужное, ибо эту газету мы с вами только что сделали без всякой редакционной группы. У газеты бывает редсовет — он состоит из уважаемых и заслуженных людей. В литературных изданиях в редсовет любят вписывать Валентина Распутина, Василия Белова, присной памяти Виктора Астафьева или Петра Проскурина... Чаще всего это делается для престижа. В выходные данные входят и номер лицензии, и какие-нибудь льготы. Также впечатываются учредители, спонсоры, прочие лица, отчего-либо имеющие отношение к газете. Потом — тираж, цена (прежде была обязательна, теперь — едва ли не по желанию). И еще, что очень важно: адрес редакции, телефоны, факсы, возможно, адрес электронной почты. И, наконец, адрес и контактные телефоны типографии, где печатался тираж.

Все то, о чем я только что говорил, вы можете внимательно прочесть или рассмотреть, взяв в руки любой реальный номер любой реальной газеты. Оставим эту область пустой, только зальем ее, чтоб согласовать с дизайном первой полосы.

Рис. 108. Создали область выходных данных

Теперь подумаем о кроссворде. Но прежде поднимем нижние границы Текстовых Блоков всех пяти колонок — им под закрашенной областью делать нечего.

А кроссворд возьмем тот самый, который мы с вами построили, когда говорили о таблицах.

Рис. 109. Кроссворд на месте

Кроссворд-то на месте, но вместо заданий к кроссворду (по горизонтали, по вертикали...) я вклеил в нижнюю часть области кроссворда просто текст, взятый опять же из той самой книги, что вы читаете. Не придумывать же, действительно, к опытному экземпляру килограмм документации!

Ну, кроссворд готов. А в качестве статьи на популярную тему хочу предложить вам отрывок из моей же статьи про Стоунхендж. Тем более что этот исторический мегалитический памятник вынесен у нас в заголовок газеты. Заодно приведем еще парочку иллюстраций — фотографий Стоунхенджа (в переводе — Висячие Камни), расположенного в Солсберийской долине в Англии.

Делаем известным вам способом заголовок статьи. Если возникают какие-то вопросы, они имеют ответы в технологии написания заголовка газеты. Никаких новых приемов я здесь, пожалуй, не применял.

Рис. 110. Заголовок

Дальше уже почти совсем не интересно. Пишем фамилию автора (то есть мою) и вставляем сам текст статьи, которую верстаем. Но взгляните, что собою представляет полоса, пока на нее не лег текст.

Рис. 111. Четвертая полоса с кроссвордом и заголовком статьи

Теперь достаем в имеющейся папке текст статьи и «роняем» его в первую колонку четвертой полосы. Текст, конечно, ложится так, как он отформатирован (фактически — как хочет).И ложится во все колонки. Результат вы видите на рисунке 112.

Рис. 112. Текст попал в колонки

Кстати сказать, все те подчеркивания, что вы видите в тексте, который сейчас неразличим, относятся к проверке орфографии, которая неизменно сама по себе возникает в Publisher — по умолчанию. Эти же подчеркивания вы видели и в других рисунках, но я как-то не удосужился уточнить их происхождение, за что прошу прощения.

Теперь, как говорилось, пишем фамилию автора. В газетных публикациях это очень часто делается в конце статьи. Играя интерлиньяжем и кеглем шрифта, добиваемся того, чтобы у нас освободились две последние колонки — во-первых, они усеченные, во-вторых, отстоят от основного текста, и это не совсем красиво с точки зрения верстки. Тем более что нам это место еще и понадобится для фото: в статье, как вы помните, речь идет о Стоунхендже — мегалитическом памятнике древности.

Итак, вписываем имя автора:

Рис. 113. Имя автора вписано

Если вы вчитаетесь в текст, можете удивиться — а где же там про Стоунхендж? Действительно, про Стоунхендж в тексте написано мало. Дело в том, что ту самую статью я не нашел, и пришлось забросить на полосу текст из книги о компьютерах. Там тоже шла речь о Стоунхендже, как первой вычислительной машине. Дело в том, что Дж. Хокинс, исследователь Стоунхенджа, в 1963 году обнаружил это свойство памятника и доказал, что лунки Обри (часть конструкции мегалита) использовались древними для вычислений лунных затмений. Принципиально нам неважно, какой именно текст верстать — хоть детектив. Важно, чтоб он был отверстан правильно.

Теперь — как раз верстка, освобождение от хвостов и выполнение всех иных верстальных принципов, касающихся текста. В том числе и выравнивание по нижнему краю. Я не особенно стану стараться это делать, потому что мы такой работой уже занимались. Важно то, что ее в любом случае в реальной газете нужно сделать.

Переходим к вставке фотографии. Находим рисунок (как правило это изображения в формате TIFF). Открываем его. Лучше всего, конечно, заниматься экспортом рисунков через программу Adobe Photoshop — специальную профессиональную фотопрограмму. Но можно и через Microsoft Photo Editor XP (последней версии), как уже говорилось прежде. Единственным недостатком майкрософтовского Фоторедактора считаю; тот, что он при транспортировке рисунков из буфера не выдерживает размеров изображения. Фотошоп же преспокойно сохраняет размеры рисунка. Если рисунок имеет габариты пять на пять сантиметров, то именно в таких габаритах он и возникнет на полосе. Те же пять на пять из Фоторедактора (Майкрософт) могут появиться в таком громадном виде, что перекроют не только формат полосы, но и монтажный стол. Придется уменьшать, при этом меняя масштаб, занимаясь ненужной работой, а это, согласитесь, хотя бы неудобно — не говорю уже о лишней трате времени. Итак, открываем рисунок в Фотошопе:

Рис. 114. Открыли рисунок в программе Photoshop

Выделяем изображение и копируем через меню «Правка» (команда Копировать). Возвращаемся в Publisher и командуем Paste Special... (Специальная Вставка...). В диалоге, возникшем после щелчка на этой команде, выбираем формат Picture (Изображение) — тот самый формат, который для себя придумала Корпорация Майкрософт как самый удобный. Говорим ОК, и — рисунок на полосе. Повторяю, в своих истинных размерах-габаритах.

Рис. 115. Рисунок вставлен

Изображение попадает всегда в самый центр экрана. Нам же надо сдвинуть его туда, куда мы желаем поместить его. Кстати сказать, оба Текстовых Блока последних колонок я удалил за ненадобностью. На место этих удаленных блоков и переносим рисунок мышкой.

Рис. 116. Перенесли рисунок

Теперь при нажатой клавише Shift (чтоб сохранить пропорции) изменяем размеры изображения — растягиваем до размера двух колонок (по ширине).

Рис. 117. Рисунок — в необходимых размерах

Теперь осталось лишь сделать подпись под рисунком.

Рисуем Текстовый Блок и вписываем в него то, что считаем необходимым.

Рис. 118. Текст под рисунком

Наконец можно считать, что все наши усилия по верстке газеты, вся работа подошла к концу. Взглянем на то, как выглядит четвертая полоса в окне Предварительного Просмотра:

Рис. 119. Выглядит сносно

Что ж, на этом все. Практикум по верстке завершен.

Все остальные ваши действия в программе Publisher так или иначе будут идентичными тем, что мы предпринимали в этой главе.

Качество верстки будет в конечном итоге зависеть не от программы, а от вашего вкуса и умения. В соответствии с проявлениями именно этих качеств вы и станете востребованы как мастер макетирования и верстки. Или того или другого. Или — вовсе ничего. Все в ваших руках.

Вот теперь и правда все, остальное — ваш опыт.

Переходим к самой последней главе и рассмотрим ту проблему, которую я нарочно отложил на потом, если помните. Это проблема печати.


Глава 1

Приложение

  • Небольшое вступление к Приложению с анализом существа Приложений
  • Средства Microsoft Office 2002 XP


Глава 1

Небольшое вступление к Приложению с анализом существа Приложений

Как-то неудобно не снабдить компьютерную книгу ни одним Приложением. Я долго думал, что же предложить читателю в качестве дополнительного материала, который был бы ну просто необходим ему, как воздух.

В книге всегда чего-то не договоришь, о чем-то забудешь. Но впоследствии появляются какие-нибудь Второе... Шестое издание (переработанное и дополненное), где автор исправляется и восполняет пробелы и ликвидирует ошибки. С книгой о компьютерной программе так не поступишь: уж очень скоро она устаревает и дорога (с ударением на последнем слоге) как то яичко — к празднику. Соответственно и хотелось бы припомнить и преподнести что-либо уж очень полезное.

Пришлось подумать, что это такое могло бы быть. «Горячие» клавиши? Нет. Тем более что я придерживаюсь того мнения, что вскоре они «отомрут». Ну, может быть, не совсем, но все же. Тем более что напротив каждой мало-мальски важной команды в меню или справке любой программы эти клавиши проставлены. Может быть, привести Словарь? Или, как его у нас теперь модно называть английским словом, не переводя его: Глоссарий?

Какую компьютерную книгу ни возьми, в глазах рябит от «глоссариев», только толку-то от них ни на грош. Как правило, там приведены слова, которые или вовсе не встречаются в тексте книги («Трек — трэк — отдельная дорожка для записи цифрового звука...» Вопрос: а если не цифрового? Уже не трэк?.. Да и к чему эта информация в книге о... программе QuarkXPress?), или всем известны: Константа, Компьютерный вирус, Шрифт и т. д. — глупостей сколько угодно. Нет только тех пояснений, какие читателю действительно нужны, поскольку книги, особенно компьютерные (в смысле, о компьютерных программах) пишут, как правило, очень продвинутые программисты, умеющие складывать длинные фразы из чуждых слов, представляющие для простого пользователя длиннейшую и пренеприятную загадку: «Без кайфа нет лайфа — хоть фейсом об тэйбл». Таким образом человек, купивший книгу и возмечтавший научиться по ней работать на компьютере, еще больше понимает свою никчемность, отсталость и утверждается в уверенности, что ПК ему никогда не осилить. Наплюйте, просто не покупайте таких книг.

Но я отвлекся.

Итак, что добавить?

Конечно же, то, что появилось новенького от Майкрософт вместе с Publisher. Я решил включить в Приложение достаточно редкую тему и поговорить о некоторых Средствах Microsoft Office XP, тем более что с той версией Паблишера, о которой шла речь, они устанавливаются параллельно и, как уже говорилось, лежат в той же директории, что и весь Офис, и дублируют такую же папку Средства Microsoft Office XP, что уже установилась у вас вместе с пакетом Офиса. Раз авторам это важно, то важно и нам.

И правда: ведь в Средствах впервые появились такие утилиты, как утилиты СКАНИРОВАНИЯ. А это в первую очередь касается проблем макетирования и верстки, ради которых создан Publisher.

В разговоре о Средствах Майкрософт Офиса вы встретите повторы, но они неизбежны, поскольку часто я произносил что-то к слову, не вдаваясь в подробности. Здесь хочу выстроить небольшой, но последовательный рассказ о вспомогательных работах ради верстки.


Глава 1

Средства Microsoft Office 2002 XP

Говоря о папке, название которой вынесено в заголовок, требуется припомнить, что до последнего времени мы имели возможность пользоваться многими и многими приложениями сторонних фирм, решающими задачи, с которыми, возможно, лучше всего справились бы специалисты «материнской» фирмы, разработавшие саму операционную систему. Ведь именно им, знающим многие нюансы программистам и функционалистам, гораздо легче заставить свою среду пристроиться к самым распространенным в мире прикладным задачам. Однако нет: всегда что-то мешало (думаю, отсутствие времени на разработку, а может, и отсутствие конкретного заказа: о «социальном заказе» смешно говорить — они что, не снимали своих детей на цифровую камеру? не сканировали картинки?..). Правда, тут могли быть и административные причины — допустим, та, что Билл Гейтс поделил с другими фирмами функции обслуживания пользователя: ему, наверняка, программное обеспечение, а другим — любые приложения. Кроме, естественно, Word, поскольку здесь опять же кроме него мало кто по-настоящему преуспел.

Ну, да ладно. Перейдем к самим утилитам.

Папка «Средства Microsoft Office» находится в подменю «Все программы» Стартового меню Windows XP.

Из подменю «Средства Microsoft Office», состав которого вы видите на рисунке 518, нас интересуют три верхние опции — именно они-то и являются самыми ценными во всем этом пакете утилит.

Во-первых, это утилита сканирования документов по имени «Microsoft Office Document Imaging» (программа сканирования изображений); во-вторых, это утилита сканирования текстов «Microsoft Office Document Scanning»; а третья — это «Microsoft Photo Editon, и если признать здраво, — пусть не самый выдающийся, не навороченный, но Фоторедактор Офиса. Ему вполне под силу провести достаточно квалифицированную обработку (редактуру) отсканированных изображений.

Если не для высшего профессионала, работающего с изображениями и документами текстового характера, то уж для среднего пользователя эти утилиты вполне подходят, и соответственно отпадает большая необходимость в графическом редакторе Photoshop и в пресловутом FineReader, создатели которого так замечательно «закрыли» свою программу, что взломать ее, как ни пытаются многие, не могут. Взлом программ в России идет не по причине, кажущейся основной Западу (той, что все русские воры и бандиты), а только потому, что наш труд оплачивается неадекватно, примерно в 10 раз ниже того, чего стоит средний работник Запада, ничего выдающегося собой не представляющий. Кто же может в России купить программное обеспечение за 300 долларов? Это выложить (в лучшем случае) две зарплаты? За что? За приложение, которое еще до истечения двух последующих месяцев устареет? Шутите, господа.

А Майкрософт делает нам этот подарок!!! Плевали русские пользователи теперь на FineReader (для тех, кто не знает, поясню, что это приложение для сканирования текстов — очень, кстати сказать, хорошее приложение и очень удобное для работы, настроив которое, можно горя не знать, но...)

Рис. 1. Подменю «Средства Microsoft Office»

Начнем с самой первой утилиты.

Но прежде обязательно надо сказать: самым первым шагом, не забудьте, следует установить сканер. Что значит установить? Пройти программу установки вашего сканера, который вы приобрели и тут же подключили. Если вы брали его не с рук, то есть не подержанный, внутри упаковки обязательно будет диск с драйвером сканера. Чем лучше фирма, тем объемней драйвер, иногда (особенно в HP-сканерах, аппаратах фирмы Hewlett Packard) даже работающий и как отдельная утилита для сканирования изображений и текстов. А потом — сканируйте.

Вызываем программу Microsoft Office Document Imaging:

Рис. 2. Появилось окно программы

После этого возникает окно программы (вы видите его на рисунке 2). Щелкнем по кнопке на панели управления, кнопка эта называется «Сканировать» или примерно так. Она третья слева и спутать ее с другой трудно: на ней изображен сканер.

Рис. 3. Окно сканирования программы Document Imaging

В окне щелкаем по большой квадратной кнопке по имени «Сканировать».

Рис. 4. Возникло окно сканера с прежней работой

Но прежде чем щелкнуть, обратите внимание на окошко слева: там надо выбрать, какого типа изображение вы хотите получить — в оттенках серого, цветное, черно-белое (битовое, только черный и белый цвет), или есть еще опция «черно-белый с цветной страницы». Это уж слишком, но ладно...

То, что выскочило на экране в окне драйвера, не ошибка. Это не наше сканирование, которым мы сейчас занимаемся. Просто программа драйвера помнит прошлое сканирование и заносит его в свою память независимо 'от нас. Мы же отсканируем обложку книги «Самоучитель работы на персональном компьютере», вышедшей несколько лет назад. Обложка сделана замечательными художниками, а потому как нельзя более подходит нам для того, чтобы поговорить о цветном сканировании и некоторых других вещах.

Итак, мы положили на стекло сканера (включенного сканера — иначе драйвер не загрузится) том книги обложкой вниз, к стеклу, а не к экрану. И говорим Prewiew (видимо, Просмотр). Сканер инициализируется при помощи драйвера. Он начинает некий процесс просмотра того, что у него отразится на экране (в окне). Этот процесс не очень быстр, вы успеете передумать много достойных мыслей.

Наконец просмотр закончен. На экране сканера появится изображение книги «Самоучитель». Она сделана в темных тонах, и потому просмотр затруднителен. Ибо мой сканер, в отличие от HP-сканеров, снабжен не белым, а черным экраном. Но это выгодно в другом случае — когда мы станем сканировать текст на белой бумаге.

Итак, перед нами обложка книги. Но в центре ее вы видите выделенный белыми «муравьями» прямоугольник или квадрат. Это область выделения, предлагаемая нам сканеровским драйвером (об ХР-программе сканирования сейчас забудьте, она ушла в тень, мы работаем пока лишь с драйвером).

Область выделения (что сканировать) очень и очень важная инструментальная часть драйвера. К примеру, вам нужно отсканировать только кусочек картинки. Вы перемещаете область выделения мышкой, хватая за любую часть внутреннего пространства ее. Подведя примерно, грубо, вы сможете установить область поточнее, растягивая или сжимая ее края, делать это можно тогда, когда подведете курсор мышки и обнаружите, что он превратился в обоюдоострую стрелку. Мы в нашем случае сканируем всю обложку.

Рис. 5. Просмотр того, что на стекле сканера

Итак, растянем область до необходимой нам величины:

Рис. 6. Растянули область выделения

Теперь нажимаем клавишу «Scan». И опять ждем. Долго, потому что установили цветное сканирование (правда, на 300 точек, но все же!).

Кстати сказать, как это сделать, я не стану рассказывать: любые установки сканера в разных ситуациях делаются по-разному, здесь ничем не могу вам помочь, читайте инструкцию фирмы-изготовителя. Ведь у вас не обязательно же будет мой сканер!

Итак, долгий процесс сканирования заканчивается новым появлением изображения окна программы Microsoft Office Document Imaging. Перед этим отсканированная страница долго повисает в окне сканирования.

Рис. 7. Наша картинка уже в окне программы-утилиты

Теперь обратите внимание: программа выполнена также по принципу навигатора. В правом, большом окне изображена сама отсканированная картинка, а слева — ее условное уменьшенное изображение, рассказывающее нам, что отсканирована одна страница (под изображением цифра 1). Мы отсканировали, что хотели. Номера страниц проставляются ради того условия, когда мы будем сканировать текст. Не удивляйтесь: программы-утилиты ХР универсальны, и в той и в другой можно делать и то, и другое.

Теперь нам осталось лишь сохранить эту картинку в том формате, в каком желаем. Вы можете пересмотреть все меню программы сканирования и кое-что сделать с картинкой и здесь, но для этого больше подходят программы-приложения для редактирования картинок, в том числе и утилита Microsoft Photo Editor. Она читает файлы прежде всего «интернетовских» форматов изображений (JPEG, GIF), но и обычных, «тифовских» картинок (TIFF), которые чаще всего используются при иллюстрации книг, журналов и газет и т. д. Вот меню «Файл», где мы «Сохраняем Как...»:

Рис. 8. Сохраним здесь картинку в формате TIFF

После того как мы щелкнули на опции «Сохранить Как...», выскочит обычное окно сохранения, где выберем имя файлу, формат (расширение), в котором сохраняем, и скажем «ОК». Больше нам утилита сканирования пока не нужна. Настал черед редактировать картинку в программе Photo Editor. Или, по привычке, можно заняться этим в Фотошопе. По большому-то счету, Photo Editor Фотошопу все же не очень-то сильный конкурент, но лиха беда начало.

Рис. 9. Результат сканирования в ФотоРедакторе

Есть возможность немного поговорить о программе ФотоРедактора Майкрософта.

Вместо того чтобы разглядывать картинку, сразу откроем опцию «Настройка...» в меню «Рисунок». И вы увидите инструменты управления яркостью, контрастностью и гаммой (процентное соотношение цветов) изображения.

Я прибавил слегка яркости и чуть-чуть контрастности, а гамму оставил практически такой же.

Все это мной проделано никак не с целью испортить рисунок обложки, но только для того, чтобы показать вам, дорогой читатель, что ползунки вполне подвижны изменения на проглядывающем рисунке видны сразу же (так устроена программа Photo Editor), и мы можем всласть «поиздеваться» над рисунком, а потом, если изменения нас не устраивают, вернуть все в первоначальное состояние.

Признаюсь вам еще, что я уже поменял размер картинки (в том же меню опция «Изменить размер...»), поскольку большая (почти А4) цветная картинка пожирает очень много памяти и с нею при этом нелегко справляться.

Рис. 10. Настройка изображения

Рис. 11. Поворот

Мы можем задать какой угодно поворот нашему изображению. Хоть 360 градусов. Переставляя флажок, выбираем наиболее удобоваримое. При этом отражающий будущий поворот Велосипед (картинка-подсказка справа) станет принимать разные положения (но поворачиваться не менее чем на 45 градусов — так в программе по умолчанию). Вот и назначим поворот 45 градусов, хотя сам-то рисунок, вы не думайте, может повернуться с точностью до 1 градуса. То есть это не голословное мое утверждение, а проверенный факт. Для наглядности повернем на 45 градусов:

Рис. 12. Повернули картинку

Вернем все, как было: на том же рисунке видно, что я выбрал в меню «Правка» опцию «Отменить». К сожалению, в этой программе только одна отмена предыдущего действия а не 99, как в CorelDRAW. Сколько этих отмен в Word 2002 ХР, и вовсе предсказывать не берусь, если уже в Word 97 (исключительно для читателя проделав эксперимент, потому что так и не нашел ни в одной из вкладок «Параметров» опцию отмен) я насчитал 299 отмен! Это уже бесконечность и совершенно не нужная роскошь. Итак, отменим поворот. И взглянем на диалог изменения размера:

Рис. 13. Диалог изменения размера изображения

Здесь, меняя размер только по одной позиции, вы получите соответствующее изменение (пропорционально) в другой. Независимо от того, ширину или высоту рисунка вы меняете.

И еще одна из многих возможностей изменения изображения. Вы видите ее на рисунке 14 — это инверсия с помощью опции «Негатив» (меню «Эффекты»). Такая возможность есть даже в примитивном Paint всех версий Windows (по крайней мере начиная 95-й). Наиболее распространенная услуга приложения для деятельного пользователя.

Рис. 14. Негатив

Ну, что ж, остальные эффекты рассмотрите сами, многие повторяют «фотошоповские». В Фотошопе, который мы тоже слегка рассмотрим, есть инструменты, с помощью которых можно работать с изображением — что-то стереть (инструмент Ластик) или замалевать Кистью, Карандашом, Аэрографом) и т. д. А в ФотоРедакторе нет инструментов! Поэтому ФотоРедактор больше «читалка», чем истинный редактор. Но из него вполне можно загружать изображения в верстальные программы. В том числе и в QuarkXPress, в MS Publisher. Идем дальше.

Раз уж мы заговорили о фоторедакторах, покажем парочку эффектов из Microsoft Photo Editor и парочку из Photoshop 7,0.

Открываем нашу "Обложка" и посмотрим какие есть эффекты в ФотоРедакторе.

Естественно, все они должны быть собраны в меню «Эффекты». Однако не станем огульно судить и проверим, не затерялось ли что-нибудь и в других меню. И находим: в меню «Сервис» есть три опции — «Размытие», «Резкость» и «Прозрачный цвет». Размытие я попробовал, — не произвело впечатления, резкость тоже как-то не вдохновила. А вот открыв диалог «Прозрачный цвет», я выбрал непонятную мне опцию «Прозрачность: внутри 1%» и, передвинув ползунок, превратил один процент в три. После того, как сделан такой выбор, надо щелкнуть кнопкой «Применить» (или «ОК» не помню, но вы разберетесь). И на экране монитора в считанные секунды возникает любопытная картина, изображенная на рисунке 15:

Рис. 15. Прозрачность для черного цвета

Рис. 16. Прозрачность для красного цвета

На рисунке 16 вы видите, как я назначил такую же прозрачность для красного цвета. Ибо и в первом, и втором случае прежде чем назначить, вы щелкаете курсором там, где пожелаете. Курсор имеет вид примерно как пипетка со стрелочкой, которой и укажете.

Но оставим меню «Сервис» и обратимся все же в меню «Эффекты». Эффект «Негатив» мы с вами уже видели. Выберем эффект по имени «Гравюра...». Судя по рисунку 17, это самый настоящий Graphic Pen — «фотошоповский» эффект рисования углем.

Рис. 17. Эффект «Гравюра»

Посмотрим, нет ли еще чего интересного.

Есть. И тоже один к одному. Это эффект «Мозаика». Только вчера я пробовал этот эффект с той же картинкой в Photoshop 7,0 и хорошо помню его: получается один и тот же рисунок!

Вы видите этот эффект на рисунке 18, и поверьте, если бы в Строке заголовка была другая программа (Фотошоп), то зрительно все было бы точно так же. Только в ФотоРедакторе изображение всегда возникает в центре рабочего пространства, а в Фотошопе — в левом углу, рядом с Панелью инструментов.

В ФотоРедакторе, в отличие от графических программ других компаний и от Фотошопа, когда вы вставляете из буфера какой-нибудь скопированный прямоугольник (только так можно что-нибудь замазать, перекрыть), он всегда появляется в верхнем левом углу. Не щелкайте мимо, а сразу захватите его мышкой и притащите на то место, которое он должен перекрыть. Иначе, едва вы щелкнули где-нибудь, этот прямоугольник прирастет к изображению, и достать его уже будет нельзя. Придется вставлять еще раз. В CorelDRAW, например, копия вставляется на свое же места откуда копировалась, только с небольшим отклонением, дабы вы увидели, что это вставка. Она так и будет находиться там, пока вам не понадобится, ее в любую минуту можно активизировать и перетащить, куда желаете. То же происходит, к примеру, в верстальной программе Adobe PageMaker. В Фотошопе вставка появляется на своем месте, но тоже надо ее сдвигать в первые секунды. Правда, там вы просто можете ее потерять за какими-нибудь эффектами, поскольку она может слиться с фоном. Однако Фотошоп принимает вставку за новый слой и так с ним и обходится, пока вы не объедините слои.

Рис. 18. Эффект «Мозаика»

Ну, и последний эффект, хотя говорить об эффектах можно было бы долго. Дело в том, что все (или практически все) эффекты в фоторедакторах назначаются с массой настроек. Эффект может быть легким, а может быть решающим и не только весьма ярким, но и настолько сложным что программе приходится очень долго вычислять его. К примеру эффект Фотошопа Radial Blur в параметре Best. Результата даже в операционной среде Windows XP я ожидал тридцать четыре минуты.

Рис. 19. Эффект «Оттиск»

Этот эффект также разительно похож на тот, что в Фотошопе называется «Штамп». Его тоже не станем повторять. Взглянем теперь как поведет себя картинка в Фотошопе и сильно ли отличается Фотошоп от ФотоРедактора Windows (Office).

Итак, Adobe Photoshop 7,0.

Для наглядности выбираем ту же "Обложка", если она вам еще не приелась. Но даже если и приелась, выбираем все равно — важно сравнивать.

Цветных эффектов я делать не стану, потому что в черно-белом варианте их будет плохо видно. Однако сами понимаете, что графические и фотопрограммы существуют не только для работы с изображениями в серых тонах, но и, в основном, для редактирования цветных изображений. Впрочем, большинство эффектов Фотошопа все же черно-белые. Только цветовой маской можно их превратить в цветные, но уже после того, как эффект належится. Впрочем, много и цветных — та же «Мозаика»...

«Мышка», вы ее помните, тоже сделана с применением многих эффектов. Из них мне нравятся Световые (может, оттого, что сам светотехник), Художественные, «Мануфактурные» (это я их так называю, хотя перевод их, кажется, звучит как «Ремесленнические»), эффекты трансформации изображения (взглянем и на такие). Ну, и все. Собственно, верстальщику издательства достаточно знать малую часть Фотошопа, чтобы вполне справиться с работой. Всерьез же программой пользуется художник, и на тему Adobe Photoshop написаны тонны специальной литературы. Для верстки требуется немного: получить в программе готовое изображение и суметь поместить его в материал, который верстается.

Эффекты в Фотошопе не разбросаны, а собраны в меню «Фильтр». Правда, есть и другие, которые можно обнаружить в таком меню, о котором и не подумать, что они могут там быть. В меню «Слой» есть опция «Эффекты слоя», где также имеется подменю со своими эффектами. Их тоже коснемся. Кроме того, в том же меню имеются и другие трансформации. Вообще Photoshop программа очень и очень интересная, можно не удержаться и бесконечно рассказывать о ней.

Перво-наперво открываем наш файл. Открыли и... И, обратившись к меню «Фильтр», увидели, что все его опции молчат. Что с ними такое?

Фокус в том, что мы сохранили нашу картинку в формате TIFF, но в другой цветовой системе, которую условно можно назвать системой с индексированными цветами.

Тогда перво-наперво открываем меню «Изображение», выбираем опцию «Режим» и из его подменю выбираем RGB-цвета.

И тогда открываем меню «Фильтр». Как видите, все активно.

Рис. 20. Меню «Фильтр» программы Photoshop 7,0

Выбираем из этого меню поначалу то, что там выписано по-русски.

Вообще говоря, нравятся мне эти все русификаторы! Они русифицируют только интерфейс, который, говоря по большому счету, можно бы и не русифицировать. А вот опции меню, особенно специфические — как их понимать без русификации? И на что мне простенький перевод известных и навязших в зубах английских имен меню, когда вся суть русификации должна заключаться в русских опциях меню и подменю и особенно диалогах!

Но применим наконец какой-нибудь эффект. Выберем, к примеру, «Шум».

В прежних версиях было в подменю следующее: «Убрать шум», «Добавить шум»... Кстати, последняя — очень важная опция, ибо пользоваться ею полезно для рисунков, которые вы исполнили в векторной графике — допустим, в CorelDRAW. Там очень видна прилизанность рисунка, несмотря на то что вы его уже превратили в растровое (точечное) изображение. Следует хоть как-то подпортить рисунок, чтоб он был больше похож на нарисованный. Собственно, для того-то и существуют все эффекты фотопрограмм: приблизить изображение к естественному.

Теперь в Фотошопе подменю «Шум» содержит опции: «Добавить шум...», «Пыль и помехи...» (кто бы мог догадаться, что это всего-навсего прежняя «Убрать шум»? — результат работы приглашенных переводчиков, очень далеких от пользования программой, или автопереводчиков утилит-приложений, переводящих все буквально), «Серединный» и «Убрать пятна». Кстати, сколько ни пользовался последней опцией, результата практически не было. Лучше «Убрать шум». Шум, как вы сами понимаете, это зернистость, от которой прежде, наоборот, все фотографы старались избавиться и получить изображение, как тогда считалось, «очень высокого качества». Времена меняются, меняются запросы.

«Пыль и помехи» расшифровывается как «Шум (зернистость), пыль (на пленке, перед печатью, на стекле объектива и т. д.), помехи (царапины от пленкопротяжного механизма)». Все это, конечно, надо убирать очень часто, но потом столь же часто приходится и добавлять шум, что мы сейчас и проделаем, выбрав параметры шума. Иногда бывает необходимо добавить очень сильную зернистость (ради художественного эффекта).

Итак, выбираем «Фильтр» — «Шум» — «Добавить шум...».

На экране возникает диалог (больше я не стану приводить диалогов, а этот — для ознакомления, откуда и что мы выбираем), из которого видно, что по умолчанию нам предлагается «Количество» шума — 12,5 %, «Распределение» — «Универсальное (Униформа)», но можно выбрать и «По Гауссу» (беспорядочное, со всеми имеющимися цветами). Внизу в строке с отсутствующим флажком можно выбрать и одноцветный шум. Выбираем как дано, за исключением того, что указанные проценты доведем сразу же, для наглядности, до 50%. Это уже перебор, но для эффекта будет яснее.

Рис. 21. Назначаем шум в диалоге

Рис. 22. А вот и шум!

Как видно, шум весьма хорошо проявляется и можно бы его, как говорится, и поменьше. Кстати, я не договорил относительно диалогового окна: на рисунке видно, что в верхней его части есть опция «Предпросмотр», и напротив стоит галочка. Если вы желаете видеть, какого примерно эффекта добьетесь, если примените опцию, вам как раз и надо заглянуть в небольшое окошечко просмотра внутри диалога. Хотя некоторые эффекты, для программы довольно простые, проявляются еще во время выбора прямо на изображении. Если эффект вам не нужен, обязательно отмените его сразу же после применения или еще в диалоге, потому что Фотошоп тоже отменяет всего один шаг ваших действий.

Вернувшись к предпросмотру, скажу, что число 100%, которое виднеется, и кнопочки с плюсом и минусом дают вам возможность выбрать масштаб просмотра, чтоб не ошибиться с эффектом. Масштаб меняется в ту и другую сторону сразу в два раза. То есть можно сделать 50% или 200% и т. д.

Но возьмемся за какой-нибудь другой эффект. Посмотрим, уйдет ли навязанный нами шум, если применить опцию «Пыль и помехи», то есть «Убрать шум». Рисунок 23.

Рис. 23. Вот и «Убрали шум»...

Что ж, убрать собственные помехи программа не может. Правда, может, но только одним путем: немедленной отменой проделанного. А здесь она предлагает опять подбирать параметры, что, конечно же, не способствует правильному подбору этих самых параметров, и результат вы видите на рисунке. Не удивляйтесь, были варианты и похуже. Так что запомните мой совет об отмене действия.

Откроем опять ту самую "Обложка", над которой «издевались». И посмотрим на другие эффекты.

Но сначала отвлечемся и посмотрим, как и откуда в Фотошопе включается сканер. Откроем меню «Файл» и увидим, что в подменю «Импорт» содержится знакомый нам «MiraScan 3,42». У вас это может быть и что-то другое (другой драйвер или адрес TWAIN32, или что-то примерно такое). Здесь я просто припомнил, что мы в Приложении занимаемся программами-средствами Microsoft Office, а не «сторонней» программой Photoshop. Вернемся к эффектам и на том закруглимся.

Рис. 24. Здесь найдем включение сканера

Итак, разберемся с эффектами другого сорта.

Опция «Смазывание» нас сейчас не очень-то может заинтересовать, но в работе она часто необходима для разных эффектов. А сейчас она как бы и не нужна — потому что у нас уже произошло громадного размера смазывание при восстановлении картинки после назначения шума, вы уже наблюдали примерно равный смазыванию или размытию эффект. Больше всего и в компьютерной графике, и в жизни профессиональными фотографами ценится смазывание изображения во время движения. Это когда репортер или фотохудожник, следя объективом за конькобежцем или мотогонщиком, из-за скорости движения, которая быстрее установленной им выдержки снимка, вынужден продолжить объективом движение следом за объектом, который снимает. В результате все, что вокруг неподвижно, на фотопленке частично смазывается, а лицо гонщика остается в фокусе. Здесь четко фиксируются не только азарт гонки и психология самого гонщика, но и психология движения, что очень ценно. Вернее, не психология, а эффект, атмосфера движения. Когда-то лет в 12-13 у меня получился отличный снимок немецкой овчарки Дика, когда я, даже не зная о законах фотоискусства, интуитивно продержал Дика «подольше» в кадре. До сих пор у престарелых родителей в Саранске где-то есть этот снимок, который считаю маленьким шедевром.

Но сейчас нам «смазывать» нечего, нет подходящих кадров, а есть данная обложка, над которой, да простят меня ее авторы, я нагло экспериментирую.

А вот другие эффекты, обозначенные по-русски, мне не показались важными для показа вам. Возьмемся за английские. К примеру. Sketch и из списка Note Paper Relief. Вы видите его изображение на рисунке 25. Чтоб достичь такого эффекта, надо очень и очень хорошо поработать с настоящей фотографией. Часть эффекта отдать печати, в смысле какому-то наложению, может быть, изображений друг на друга, а часть отдать химическим реактивам, да еще прекрасно быть осведомленным — что, чем, как и зачем делать. Прежде это был бы высший пилотаж, а теперь... Запустил опцию одной-единственной кнопкой мышки, подождал четыре-пять секунд — и нате вам, эффект готов. А потом вдруг не понравилось, — взял да отменил, делов-то!

Получается, таким образом можно делать и чеканку, не покупая ни материала, ни инструментов. Можно создать несуществующие в природе эффекты, да и вообще, в зависимости от изображения, какое здесь поле для художественного творчества!

Это мы еще не касались эффектов «Художественные» (Artistic).

Рис. 25. Note Paper

Но посмотрим, что там есть еще. В этом меню содержатся и тот самый Graphic Pen (уголь рисовальный, насколько мне кажется), и Stamp (штамп, оттиск), и даже Photocopy (светокопия, эффект недавнего прошлого, когда от фотографии на светокопировальном аппарате РЭМ или Ксерокс получались одни только контуры содержащихся на фото изображении). Есть даже эффект «Сырая бумага» акварельного письма «по сырому», как говорится в среде художников. Не знаю, есть ли такой термин сейчас, но во времена моего детства и юности, когда я учился в художественной школе у замечательного живописца-портретиста Евгения Алексеевича Ноздрина и не менее замечательного живописца-лирика Виктора Ивановича Петряшова, именно такой термин и существовал. Евгений Алексеевич еще предупреждал: ни в коем случае не говорите по мокрому», иначе очень уж похоже на «мокрое дело».

Итак, выберем эффект. Вернемся к руссконазванным и выберем «Стилизация» — «Выпуклый рисунок». Это почти то же, что и на рисунке 26. но с некоторыми отличиями, которые могут показаться вам предпочтительными.

Рис. 26. «Выпуклый рисунок»... Хорошо, что не «впуклый»

Посмотрим еще только на два эффекта и закончим с Фотошопом. В Sketch выберем эффект по имени Plaster и, глядя на рисунок 27, порассуждаем на тему о том, как рождаются дутые сенсации.

Рис. 27. Эффект Plaster

Летчик из Новой Зеландии Агафон Тришкин, пролетая как-то на своем «кукурузнике» над заброшенными пустынными районами Австралии, сделал снимок удивительного озера, которого нет ни на одной карте. Озеро имеет логически правильную форму, хотя и трудно ее объяснить с позиций современного жителя Земли. Обратите внимание на этот уникальный кадр: он получился всего один, потому что, как назло, в фотоаппарате ФЭД у Агафона Пафнутьевича закончилась пленка. Ученые, заинтересовавшиеся снимком, облетевшим весь мир за два дня, предполагают, что на нем изображен древний затопленный город — вернее, то, что от него осталось. Вглядимся же в фотографию. Вы видите, что почти посредине озера проходит дамба явно искусственного происхождения: природа не строит ровных скал с четкими, будто высеченными резцом скульптора, гранями. Дамба соединяет два берега, которые тоже, как видно, искусственно и наверняка очень искусно укреплены. Заводь в правой нижней части озера предназначалась, вероятно, для отстоя кораблей, когда на озере разыгрывался шторм. Обратите внимание: на том берегу озера которое мы назвали бы южным (к сожалению, Агафон Пирамидонович не оставил указании относительно сторон света), явно проглядывают развалины регулярно расположенных сооружений, напоминающих дома. Природа так не строит! В правой части, под заводью, мы видим на фоне городского массива, окруженного стеной, черное круглое очертание еще одного сооружения — вероятно, это ритуальный колодец, куда бросались жертвы кровавых языческих оргий, устраиваемых жрецами неведомого нам племени. Впрочем, племенем его назвать трудно: налицо явные признаки высокой цивилизации. Городу предположительно не менее 15 тысяч лет.

Не была ли Австралия той самой Атлантидой, которую так долго и тщетно разыскивают энтузиасты вот уже более двух тысячелетий? Знает ли об этом снимке Владимир Иванович Щербаков?..

Вот так просто. Компьютерная графика вполне способна породить сенсацию. Многие шутники так и делают.

Кстати, если очень умело и весьма умеренно применить несколько эффектов друг за другом, то уже никто не докопается, откуда у этой фальсификации растут ноги.

Ну, и еще один эффект, который я потерял и сейчас поищу — где, за какой опцией он мог бы скрываться...

Нет, не один. Приведу еще несколько своеобразных неповторимых эффектов, о которых иногда забываю. Ведь сами понимаете, что применение одного и того же эффекта часто — все равно притупляет впечатление от его воздействия не только на зрителя (не дай Бог), а и на самого автора. Применив единожды, стараешься на дольше забыть, каким образом у тебя получилась та или иная картинка.

На рисунке 28 вы видите эффект Chrome. Я назвал его «Хромирование» или «Металлизация». Может, я и не прав с таким переводом, но думаю, что по впечатлению это достаточно близко к истине.

Да взгляните/сами: где и как можно добиться столь разительного эффекта, схожего с компьютерными эффектами «Терминатора-2»? А ведь этот фильм уже давно далекое прошлое подобных эффектов. Сейчас с подобной задачей справится любой первоклассник, у которого крутой ПК

Рис. 28. «Хромирование»

Здесь также можно на придумывать чего угодно про отпечатки на древних скалах... Но поищем еще.

Вот эффект Pinch, вы видите его на рисунке 29. Примененный два раза, но с выделением только центральной области обложки, он привел к тому эффекту, что монитор, из которого вылезала рука, превратился скорее в шляпу, а рука, исказившись, в малюсенького человечка с тоненькими ножками, утонувшего в этой шляпе. А мышка заулыбалась и слегка расширилась в объеме.

Подобные искажения очень хороши в пародийной фотографии, когда можно взять обыкновенное фото и так исказить его, чтобы и сходство сохранилось, и вылезли какие-то смешные черты, которые в каждом, самом классическом лице или фигуре есть. Что-то вроде кривого зеркала...

Рис. 29. Эффект Pinch, центральной впадины

Но не он меня тревожил, не этот эффект. Мне хотелось показать вам...

Для справедливости покажем и обратный эффект искажения — не впадину, а выпуклость. На рисунке этот самый эффект вы и видите. Лучше всего он проявляется тогда, когда касается изображений, содержащих много пересекающихся горизонтальных и вертикальных линий. Рисунка, похожего на план строго расчерченных городских кварталов, к примеру.

Эффект называется Scherize, вы видите его на рисунке 30.

Вот уже никакого человечка, раздулся экран монитора, мышка и рука отхлынули к краям невидимого, но очень ощущаемого шара, который как будто забрался под обложку книги — этакого пузыря, который, кажется, продолжает вздуваться. Отметим про себя и этот эффект, который в любую секунду может понадобиться.

Рис. 30. Выпуклость в центре

Рис. 31. Это эффект «Водоворот»

Ну, вот наконец нашел! Это в самом верхнем подменю, называемом Render. Опция «Световые эффекты»:

Рис. 32. Световые эффекты

Вот что я хотел показать вам. Как видите, на рисунке источник освещения картинки. В окне выбора параметров, очень насыщенном различными параметрами и их вариациями, в том числе списком стандартных световых установок, можно выбрать практически все, что душе угодно. Мне кажется, это диалоговое окно следовало бы использовать для обучения будущих театральных и эстрадных художников по свету. Буду счастлив, если до подобного тренинга додумались и в ЗD-программах.

Есть один нюанс: опция «Световые эффекты» будет неактивна, если вы попытаетесь применить ее к изображению черно-белому. Обязательно назначьте рисунку цвет, и световые эффекты — к вашим услугам.

Ну, теперь покидаем Фотошоп и начинаем заниматься сканированием текста. Это интересно тем, что вам практически не нужен теперь FineReader, хотя бы и такой замечательный, каким он стал в последних версиях. Правда, сразу предупреждаю: FineReader уже давно сохраняет форматирование оригинала, стараясь как бы «сфотографировать» сканируемый текст в том же виде, дабы не потерять изобразительной его прелести. Microsoft Office XP этого не делает, но во всем остальном — практически не уступает известной программе сканирования текстов. И, поверьте, превосходит в другом: если ХР не понимает знак, он его не покажет, то есть после сканирования текста вам почти не придется исправлять никакой псевдографики, которую тащит в текст FineReader, если чего-то не «разглядел» и не распознал, — здесь останется практически лишь допечатать оставленные пробелы. Не распознано слово «меценат» — программа оставит лишь «ме»... И так далее.

Итак, открываем Microsoft Office Document Scanning. При этом не забудьте, конечно, включить сканер и положить на него лицом вниз (на стекло) страничку текста!

Чтобы не быть ни для кого обидным, как это было со сканированием обложки, я решил положить на стекло сканера собственный рассказ-пародию, который опубликован только что в журнале «Московский вестник» Московской писательской организации. Не бойтесь, весь рассказ мы сканировать не станем, но две странички обязательно отсканируем.

Сразу хочу вас предупредить: если вы собираетесь сканировать многостраничный текст, задавайте это условие программе на первом же вашем шаге. Это очень важно, иначе программа станет рассматривать каждую страничку за отдельный документ. Как бы не пришлось вам потом собирать ваши 33 файлов в один (это очень утомительно даже в ХР).

Итак, открываем окно программы и внимательно смотрим, какие опции нам предлагает диалоговое окно.

Рис. 33. Диалоговое окно Microsoft Office Document Scanning

Для того, чтобы программа воспринимала весь ваш текст за единый, следует поставить галочку в окошке строки «Запрашивать дополнительные страницы», как это показано на рисунке — только и всего!

Потом выбирайте из окна конфигурации сканирования «Черно-белый» (даже если ваш текст напечатан синим по желтому. И щелкаем на большой квадратной кнопке «Сканировать». Процесс дальнейший идентичен тому процессу, когда сканировалась фотография (картинка). Программа выбросит несколько диалогов, где вы скажете «ОК», потом возникнет заставка драйвера сканера, которая^ как вы помните, не фотографируется клавишей «Print Screen», и появится окно сканера. Там вы обязательно выберите правильную конфигурацию сканируемого изображения. У меня это происходит в окне, где из списка я выбрал Line Art. Уровень разрешения 300 точек, который применялся мной для сканирования картинки, вполне можно оставить и для текста, потому что те самые 100 dpi, которых бывает достаточно для хороших сканеров, для сканеров из глубокой провинции Китая или Тайваня может не хватить. Говорю не в обиду этим провинциям, а констатирую факт.

Вот, кажется, и все. Щелкаем кнопкой «Preview» и получаем предварительное изображение того, что увидел сканер на своем экране.

Рис. 34. Диалоговое окно сканера

После того как изображение появилось в поле просмотра сканера, инструментом «Выбрать область сканирования» аккуратно обозначаем область текста и нажимаем" «Scan». Подождем, пока работает сканер...

А пока он работает, объясню, почему поменялся вид рабочего окна (Рабочего стола) моего ПК. Вероятно потому, что на моем ЦК все же бета-версия ХР, она дает сбои. Приходится восстанавливать систему, что я позавчера и сделал. В результате ХР, как ни хвалилась, забыла все настройки, но зато восстановила свои собственные свойства. Я решил оставить пока все так и больше, пока не напишу эту книгу, не экспериментировать.

После сканирования странички возникает первое наше окно, перекрытое новым окном, предлагающим, раз отсканирована страница 1, продолжить сканирование. Заряжаем в аппарат вторую страницу и щелкаем «Продолжить». Дальнейший процесс будет происходить идентично. За исключением только вашего выбора настроек сканера (так и останется 300 и Line Art). После сканирования второй страницы опять возникает тот же диалог.

Теперь, когда наши странички обе отсканированы, говорим в этом диалоге «Готово». И программа тут же начинает распознавать текст. Процесс этот происходит быстро, поэтому я успел заснять самый его поздний «край». Сообщения и анимацию распознавания вы видите на рисунке 35.

Рис. 35. Идет распознавание текста

Что такое вообще распознавание? Для чего оно нужно?

Программы сканирования, даже самые лучшие (к каковым отношу теперь обязательно и Средства Microsoft Office), пользуются лишь своими командами для запуска сканера, несмотря на то что мы вроде бы ясно говорим им: сканируем текст, а не картинку. На самом деле это все больше условность, чем истинные настройки. Просто эти настройки помогают не брать во внимание многие нюансы. Если б мы заставили программу сканировать наш текст как цветную картинку, то в результате вы получили бы в вашем отсканированном и распознанном тексте много лишнего. Об этом уже сказано. Всевозможные неровности или черточки могут показаться прежнему распознавателю текста какими-нибудь значками, а здесь программа, к счастью, умнее. Кроме того освещенная лампой сканера страница очень хорошо просвечивается, и на изображение вылез бы зеркальный текст с обратной стороны страницы. Это ведь тоже значки! Слава Богу, ХР его игнорирует. Иначе была бы полная неразбериха. И драйвер сканера отключил все лишнее, выдал вам почти чистый текст (впрочем, даже самое чистое сканирование потом надо сверять). Программа наконец «вглядывается» в те картинки, которые отсканированы по ее командам и с ее помощью. Теперь фотографии (съемка идет в «тифах» — расширении TIFF) она должна превратить в текст, и это важно.

В момент распознавания происходит вычленение из TIFF самого текста, который становится доступным для экспорта его в текстовый редактор. Технология, как именно это происходит, мне неизвестна, да ведь и фирма, выпускающая программное обеспечение FineReader, также тщательно скрывает, каким образом происходит превращение одного в другое. Но нам это не так важно: они зарабатывают деньги, а нам просто надо, чтоб отсканировался наш текст, потолгу что завтра сдавать его в редакцию (или что-нибудь в таком же практическом роде).

Итак, процесс распознавания завершается, и на экране... автоматически появляется знакомое нам окно программы Microsoft Office Document Imaging!

Любопытно! Оказывается, программа сканирования текста для сохранения текста в файл пользуется помощью другой, но своей же утилиты — весьма родственной и разработанной той же самой Корпорацией Майкрософт. Замечательно. Посмотрим, как же нам превратить теперь текст в такой вид и формат, чтоб его можно было править. В навигаторе программы на рисунке 36 вы видите в левой части значки обеих страниц — и первой, и второй. А в правом большом окне — вид первой страницы, которую при желании даже можно прочесть, хотя и мелковато.

Рис. 36. Появилось знакомое окно программы

Теперь поясню, как так получилось, что в левом окне вы видите две страницы, а не большую одну, как было при сканировании нами обложки книги.

В обыкновенно применяемом для сканирования и распознавания текстов могучем FineReader значки в навигаторе возникают автоматически, ибо там есть мощный Мастер настроек сканирования. Им можно восхищаться и восхищаться, но на самом деле он вряд ли нужен, когда есть умная и все предусмотревшая Windows XP. А уж назначить значок поменьше, чтобы видеть все отсканированные страницы (правда, если их 1533, то вряд ли вы их увидите все заодно), можно и вручную.

Что мы и сделали для наглядности. А меню, команды и опции, где ставился флажок, вы видите из рисунка 37. Как видите, в Средствах Майкрософт Офис все происходит достаточно просто и, конечно, фантастично.

Рис. 37. Так назначается очень мелкий значок

Теперь взглянем, что нам предлагает сделать программа с распознанным текстом. Видеть текст на картинке, конечно, очень приятно, особенно если это твой собственный рассказ, вышедший из печати, но долго смотреть утомительно: надо ведь и применить его куда-то практически. Программа, как мы помним, сохраняет файлы только в формате Tagged Image File Format, то есть в формате TIFF. Значит, «Сохранить как...» у нас не получится.

Смотрим, что еще есть в меню «Файл». Обратите внимание: в меню «Файл» содержатся опции, которые являются очень специфическими — например, та же «Распознать текст». Правда, распознавание, как мы видели, происходит автоматически,. с нажатием кнопки «Готово». Здесь путь один. Мы экспортируем файл... в Microsoft Word! Этот экспорт осуществляется из того же меню «Файл».

Вот эту опцию и щелкнем: «Отправить текст в Microsoft Word...».

Убедимся, что, щелкнув на опции «Отправить...», действительно отправили отсканированный текст в программу Word. Именно его-то мы и видим на рисунке 556. Впрочем, простите, это пока лишь вопрос:

Рис. 38. Все экспортировать?

Однако, как я уже говорил, программа не сохраняет форматирования оригинала. Вы видите на рисунке 38, что страница отформатирована программой так, как заложено в ней по умолчанию — то есть по левому краю.

Но это не страшно, потому что идентифицировать или подгонять под журнальную публикацию никому не нужно. Можем заявить лишь о том, что программа прекрасно справляется со сканированием текста. Правда, ошибается не меньше, чем FineReader, только по-другому.

Сохраним наш файл под каким-нибудь именем и закроем Word.

Теперь закроем программу сканирования. Перед закрытием она спрашивает нас: сохранить ли в формате TIFF то, что отсканировано?

Рис. 39. Вопрос программы

Нет, конечно. Или сохраним. Как захотим, так и сделаем.

При закрытии исчезают оба диалога — и Document Imaging, и виднеющийся краешком Microsoft Office Document Scanning. Спасибо. Удачи вам в работе.


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|14 Feb 2003 19:42:42 -0000 vti_extenderversion:SR|5.0.2.2623 vti_author:SR|HOME\\Женя vti_modifiedby:SR|HOME\\Женя vti_timecreated:TR|11 Nov 2002 15:56:12 -0000 vti_title:SR| Глава 1 vti_lineageid:SR|{089B584E-E969-4C96-B084-FD3E056D7E7D} vti_backlinkinfo:VX|index.htm vti_nexttolasttimemodified:TW|13 Feb 2003 16:40:54 -0000 vti_cacheddtm:TX|14 Feb 2003 19:42:44 -0000 vti_filesize:IR|1177 vti_cachedtitle:SR| Глава 1 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|../index.html S|Menu.gif H|Index1.htm H|Index2.htm H|../index.html S|Menu.gif vti_cachedsvcrellinks:VX|NHUS|index.html FSUS|Часть/Menu.gif FHUS|Часть/Index1.htm FHUS|Часть/Index2.htm NHUS|index.html FSUS|Часть/Menu.gif vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|14 Feb 2003 19:44:26 -0000 vti_extenderversion:SR|5.0.2.2623 vti_author:SR|HOME\\Женя vti_modifiedby:SR|HOME\\Женя vti_timecreated:TR|11 Nov 2002 15:56:38 -0000 vti_title:SR| Глава 1 vti_lineageid:SR|{83A190DD-5597-4F4E-A2D3-AB526315E08F} vti_backlinkinfo:VX|Часть1/Index2.htm Часть1/Index.htm vti_nexttolasttimemodified:TW|13 Feb 2003 16:28:01 -0000 vti_cacheddtm:TX|14 Feb 2003 19:44:28 -0000 vti_filesize:IR|4576 vti_cachedtitle:SR| Глава 1 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|../index.html S|Menu.gif H|Index2.htm S|For.gif S|Index2.htm H|../index.html S|Menu.gif H|Index2.htm S|For.gif S|Index2.htm vti_cachedsvcrellinks:VX|NHUS|index.html FSUS|Часть/Menu.gif FHUS|Часть/Index2.htm FSUS|Часть/For.gif FSUS|Часть/Index2.htm NHUS|index.html FSUS|Часть/Menu.gif FHUS|Часть/Index2.htm FSUS|Часть/For.gif FSUS|Часть/Index2.htm vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|14 Feb 2003 19:50:12 -0000 vti_extenderversion:SR|5.0.2.2623 vti_author:SR|HOME\\Женя vti_modifiedby:SR|HOME\\Женя vti_timecreated:TR|11 Nov 2002 15:57:16 -0000 vti_title:SR| Глава 1 vti_lineageid:SR|{D98E6F3C-0350-4137-8E83-2B810BD0623A} vti_backlinkinfo:VX|Часть1/Index3.htm Часть1/Index1.htm Часть1/Index.htm vti_nexttolasttimemodified:TW|13 Feb 2003 16:29:10 -0000 vti_cacheddtm:TX|14 Feb 2003 19:50:14 -0000 vti_filesize:IR|48385 vti_cachedtitle:SR| Глава 1 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|Index1.htm S|Back.gif H|../index.html S|Menu.gif H|Index1.htm S|Back.gif H|../index.html S|Menu.gif vti_cachedsvcrellinks:VX|FHUS|Часть/Index1.htm FSUS|Часть/Back.gif NHUS|index.html FSUS|Часть/Menu.gif FHUS|Часть/Index1.htm FSUS|Часть/Back.gif NHUS|index.html FSUS|Часть/Menu.gif vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0