Инструментальные средства документалистики. Настольные издательские системы. Классическая НИС PageMaker.

Настольная издательская система
PageMaker

"Поэтом можешь ты не быть,
А гражданином быть обязан."
 Некрасов

Классическая настольная издательская система PageMaker предназначена для деловых людей с их скрормными требованиями к оформлению публикаций, избавлена от излишеств и удобна в обращении, позволяет создавать при этом довольно сложные документы при минимальных затратах. Знакомство с этой системой позволяет получить довольно полное представление о программах этого класса и определить для себя фронт издательских работ на обозримую перспективу.

Данный сборник предназначен для ознакомлеенния начинающих редакторов с общими возможностями программ класс НИС и особенностями PageMaker, формируя достаточно полные представления об этом арсенале инструментальных средств и обеспечивая уверенное освоение рассматриваемой НИС за короткое время. По тексту рассматриваются базовые понятия издательского дела и некоторые профессиональные приесмы, необходимые для успешной работы с системой.

При необходимости в Internet нетрудно найти и установить желаемую версию PageMaker для реализации полученных знаний в полезных произведениях по профилю деятельности. Такой инструментарий будет полезен обладателю многие годы, а его освоение существенно отражается на профессионализме и карьерном росте пользователя.

Телефон: (3843)74-88-06
Б.Г.Новокрещин

    • Введение
ЧАСТЬ I. НАЧАЛА
    • Глава 1. Интерфейс пользователя
    • Глава 2. Подготовка публикации
    • Глава 3. Установки PageMaker
ЧАСТЬ II. ТЕКСТ
    • Глава 4. Форматирование символов
    • Глава 5. Форматирование абзацев
    • Глава 6. Глобальное форматирование
    • Глава 7. Импорт текста
    • Глава 8. Редактирование текста
ЧАСТЬ III. ГРАФИКА
    • Глава 9. Рисование средствами PageMaker
    • Глава 10. Импорт графики
    • Глава 11. Связывание файлов
ЧАСТЬ IV. ВЕРСТКА
    • Глава 12. Создание новой публикации
    • Глава 13. Структура публикации
    • Глава 14. Компоновка текста и графики
    • Глава 15. Специальные эффекты
    • Глава 16. Верстка таблиц и бланков
    • Глава 17. Верстка книг
    • Глава 18. Электронные публикации
ЧАСТЬ V. ЦВЕТ
    • Глава 19. Определение цветов
    • Глава 20. Использование цвета
    • Глава 21. Управление цветом и треппинг
ЧАСТЬ VI. ОРИГИНАЛ-МАКЕТ
    • Глава 22. Корректура
    • Глава 23. Вывод оригинал-макета
    • Глава 24. Сотрудничество с типографией
ЧАСТЬ VII. ПРИЛОЖЕНИЯ
    • Приложение 1. Работа над ошибками
    • Приложение 2. Комбинации клавиш в PageMaker


  • ЧАСТЬ I. НАЧАЛА
    • Глава 1. Интерфейс пользователя
      • Главное окно программы
      • Окна документов
      • Контекстное меню
      • Комбинации клавиш
      • Палитры
        • Палитра инструментов
          • Масштаб отображения страницы
          • Инструмент Hand
          • Инструменты рисования
          • Обрезка изображений
          • Поворот изображений
          • Инструменты Pointer и Text
          • Управляющая палитра
        • Прочие палитры
      • Измерительные линейки и направляющие
      • Резюме


ЧАСТЬ I.

Начала

  • Глава 1. Интерфейс пользователя
  • Глава 2. Обзор процесса подготовки публикации
  • Глава 3. Установки PageMaker


ГЛАВА 1.

Интерфейс пользователя

В этой главе описан интерфейс программы, а именно:

  • Главное окно программы и меню.
  • Окна документов. Режимы отображения документов и масштабирование.
  • Линейки и направляющие.
  • Инструменты PageMaker.
  • Управляющая палитра (ускоренный доступ к функциям форматирования).
  • Управляющая панель (кнопки быстрого доступа к командам меню).
  • Специализированные палитры.
  • Ускорение работы с помощью клавиатурных сокращений и контекстного меню.

Описание издательской системы PageMaker 7.0 мы начнем с интерфейса пользователя. Предполагается, что на вашем компьютере программа уже установлена. В противном случае установите программу, сообразуясь с рекомендациями, приведенными в руководстве пользователя.


Главное окно программы

По умолчанию программа установки PageMaker создает в главном меню группу Adobe, если она уже не создана программами установки других продуктов Adobe — TypeManager 4.0, Photoshop, Illustrator и др. В эту группу помещаются ярлычки указателей на установленные компоненты пакета PageMaker. Среди них непременно будет ярлычок PageMaker (рис. 1.1).

Примечание

Если в главном меню нет ярлычка PageMaker, это означает, что либо программа не установлена на вашем компьютере, либо перенесена в другую группу меню.

Рис. 1.1. Ярлык программы PageMaker

После запуска программы на экране появится главное окно (рис. 1.2) со строкой меню и управляющей панелью в верхней части. Управляющая панель, новый элемент интерфейса для PageMaker, содержит кнопки с пиктограммами, соответствующие наиболее часто используемым командам. Щелчок на кнопке приводит к немедленному выполнению команды, избавляя от необходимости разыскивать и выбирать ее в меню. Главное окно можно сворачивать, разворачивать во весь экран, перемещать и масштабировать с помощью системного меню, кнопок в правом верхнем углу, а также используя стандартные клавиатурные сокращения.

Рис. 1.2. Главное окно PageMaker 7.0

Если вы не меняли установки программы по умолчанию, то после запуска в главном окне появятся четыре палитры: инструментов, Templates, Colors и узкая палитра без названия, которую в дальнейшем мы будем называть управляющей. Основная площадь окна окрашена в стандартный фоновый цвет и не может быть использована. Для начала работы нужно либо открыть существующую публикацию, либо создать новую.

Выбрав команду Open (Открыть) меню File (Файл) (комбинация клавиш <Ctrl>+<O>), вы откроете стандартное диалоговое окно выбора файлов (рис. 1.3).

Рис. 1.3. Диалоговое окно Open Publication

Рис. 1.4. Диалоговое окно Document Setup

Чтобы создать новую, пустую публикацию, выберите команду New (Новый) меню File (Файл) (комбинация клавиш <Ctrl>+<N>). В диалоговом окне Document Setup (Параметры документа) (рис. 1.4), укажите: формат публикации, ориентацию листов, использование двусторонней печати, отображение на экране разворота публикации или одиночных страниц, количество страниц, номер первой страницы, размеры полей, предполагаемое устройство вывода, разрешающую способность устройства вывода. Эта информация абсолютно необходима PageMaker, и если вы не ввели какое-либо значение из приведенного списка, будут приняты значения по умолчанию (см. гл. 3).

Для создания нового документа можно также воспользоваться готовыми шаблонами из палитры Templates. По умолчанию эта палитра уже открыта при загрузке программы. Выберите необходимую группу шаблонов из раскрывающегося списка, затем выделите требуемый шаблон и перетащите его в область главного окна. Будет создан новый документ, содержащий все элементы, входящие в шаблон. Подробно о работе с шаблонами документов см. гл. 12.

В управляющей панели для создания нового документа служит крайняя левая кнопка с изображением пустой страницы. Рядом находится кнопка с рисунком открытой папки, она предназначена для открытия существующей публикации.


Окна документов

После того как вы задали параметры нового документа и щелкнули на кнопке OK, PageMaker создаст окно документа (публикации) и разместит его внутри главного окна (рис. 1.5). Можно открыть одновременно несколько публикаций, и каждой из них будет отведено отдельное окно в пределах главного окна программы. Окна документов можно сворачивать, разворачивать, перемещать и масштабировать так же, как и главное окно программы. Для упорядочения положения развернутых окон документов в меню Window (Окно) предусмотрены команды Tile (Мозаика) и Cascade (Каскад). Первая располагает окна документов так, чтобы они не перекрывали друг друга, вторая размещает их друг за другом так, чтобы были видны только заголовки каждого. Обмен информацией между окнами документа возможен как через буфер обмена (Clipboard), так и методом Drag-and-Drop (перетаскивание элементов макета мышью из окна одной публикации в окно другой).

В окне документа показана первая страница публикации. Пустое пространство вокруг нее называют рабочим столом. Элементы макета должны располагаться в пределах страницы, чтобы их можно было напечатать. Элементы, целиком располагающиеся на рабочем столе, на печать не выводятся. Рабочий стол удобен в качестве временного места расположения элементов макета при его создании и для их переноса между страницами публикации. Вы можете перелистывать страницы публикации, и они будут отображаться в поле листа, а содержимое рабочего стола при этом не изменится. Если необходимо переместить элемент с текущей страницы на другую, то проще всего сначала убрать его на рабочий стол, затем перелистнуть документ на нужную страницу и поместить на нее элемент, взяв его с рабочего стола. Эта процедура выглядит так же, как и в реальности — ведь если вы перелистываете книгу, лежащую у вас на столе, сам стол при этом не меняется!

Рис. 1.5. Вид окна документа PageMaker

Для перехода от одной страницы к другой служат пиктограммы с номерами страниц, в нижней левой части окна документа (слева от полосы прокрутки) (рис. 1.6, а). Щелкните мышью на пиктограмме с номером страницы, и она будет открыта. Если пиктограмма нужной страницы не видна на экране, до нее можно добраться с помощью полос прокрутки, расположенных слева и справа от списка.

Рис. 1.6. Ярлыки страниц и шаблон-страниц публикации для односторонней и оборотной печати

Если публикация создана для оборотной печати, то ее четные и нечетные страницы могут различаться, a PageMaker для удобства может демонстрировать не отдельные страницы, а развороты. В этом случае в окне документа посередине рабочего стола вы увидите две страницы. Пиктограммы с номерами страниц будут сгруппированы в пары, содержащие четную и нечетную страницы (рис. 1.6, б). Четные страницы изображаются прямоугольниками с "загнутыми" левыми верхними уголками, а нечетные — с правыми верхними.

Левее пиктограмм с номерами страниц находится пиктограмма шаблон-страниц. При оборотной печати показаны отдельно пиктограммы шаблонов для четных и нечетных страниц (рис. 1.6, б). Шаблон-страницы задают расположение на всех страницах публикации стандартных элементов, например колонок и колонцифр, модульную сетку. Все, что находится на шаблон-страницах, будет присутствовать на каждой странице публикации. Более подробно об элементах шаблона см. гл. 13.

Для перехода между страницами пользуются также командой Go To Page (Перейти к странице) меню Layout (Макет). При выборе команды появляется диалоговое окно с единственным полем ввода, в котором и задают номер страницы (рис. 1.7).

Рис. 1.7. Диалоговое окно Go to Page

На поле страницы документа видны цветные линии — границы полей и колонок (см. рис. 1.5).

Розовыми линиями отмечаются границы полосы набора. Они отстоят от краев страницы на величину полей, указанную в диалоговом окне Document Setup (Параметры документа). Размеры страниц и полей, как правило, задаются при создании публикации и впоследствии не меняются, поскольку это приводит к необходимости полной переделки всего макета. Тем не менее на ранних этапах работы может потребоваться корректировка параметров страницы. Новые значения вводятся в диалоговом окне Document Setup (Параметры документа), вызываемом одноименной командой меню File (файл) (см. рис. 1.4).

Примечание

Очень важно еще до начала работы над макетом точно знать эти основные параметры. PageMaker 7.0 располагает специальной функцией Adjust Layout (Настройка макета) для сокращения количества ручной работы при изменении параметров страницы (см. гл. 13), но, к сожалению, во многих случаях это ее вовсе не исключает.

Голубыми линиями отмечаются границы колонок. После создания новой публикации они совпадают с границами полей. Поскольку линии колонок отображаются поверх линий полей, их цвета накладываются и образуют фиолетовые линии по правому и левому полям. Для определения числа колонок выберите команду Column Guides (Границы колонок) меню Layout (Макет). В диалоговом окне Column Guides (Границы колонок) (рис. 1.8) введите требуемое число колонок и величину расстояния между колонками. При оборотной печати можно отдельно задать параметры колонок для четной и нечетной страниц.

Зачастую расположение колонок в публикации одинаково на всех страницах, тогда разумно задать этот параметр на шаблон-странице. Чтобы перейти на нее, щелкните мышью на соответствующей пиктограмме в левом нижнем углу окна документа. Подробно о работе с шаблон-страницами рассказывается в гл. 13.

Рис. 1.8. Диалоговое окно Column Guides

Границы колонок и полей можно изменять и простым перетаскиванием с помощью мыши. Этот способ подойдет для предварительного размещения, но при создании окончательного макета задание численных значений параметров предпочтительнее. Точные значения колонок придают публикации профессиональный вид и обеспечивают соответствие требованиям типографии.


Контекстное меню

Щелчок правой кнопкой мыши открывает контекстное меню. В зависимости от текущего режима работы и положения курсора это меню принимает разный вид и ускоряет доступ к функциям программы, которые, скорее всего, будут использованы в данной ситуации.

Примечание

В ранних версиях PageMaker правая клавиша мыши тоже использовалась. При ее нажатии происходило переключение с масштаба отображения страницы Fit in Window (Целая страница) в масштаб 100% Size (Реальный размер) и обратно. Это было весьма удобно, т. к. при верстке приходится часто переключаться от общего вида страницы к рассматриванию деталей. Возможность эта не утрачена и теперь. Смена масштабов происходит щелчком, правой кнопкой мыши при нажатой клавише <Ctrl>.


Комбинации клавиш

Для тех, кто предпочитает в процессе работы не выпускать из рук мышь, есть плохая новость: вы теряете драгоценное рабочее время ни на что! Процесс перемещения мыши в нужную позицию на экране занимает секунды, но они складываются в часы непроизводительной работы. То же действие любитель использовать комбинации клавиш выполнит одним нажатием клавиш, сэкономив драгоценные секунды. Работа с клавиатуры практически всегда быстрее. Авторы настоятельно рекомендуют постепенно запоминать клавиатурные эквиваленты команд меню PageMaker, если вы заинтересованы в ускорении работы. В PageMaker есть, что запоминать — комбинаций клавиш и специальных команд свыше 250! Некоторые важнейшие функции вообще доступны только через клавиатурные команды. Это, например, команды расстановки колонцифр, ручного кернинга и т. п.

Список всех клавиатурных команд PageMaker 7.0 вызывается отдельной командой Shortcuts (Комбинации клавиш) меню Help (Помощь).


Палитры

Палитры — это небольшие немодальные окна, в которых собраны элементы управления программой или отображается какая-либо текущая информация.

Палитры можно размещать произвольным образом и в любой момент можно убрать любую из них с экрана и вернуть обратно. Отображение палитр включается соответствующими командами Show <имя палитры> (Показать <имя палитры>) из меню Window (Окно). Если палитра уже отображается на экране, то имени палитры предшествует слово Hide (Спрятать). Выбрав этот пункт, вы уберете соответствующую палитру с экрана. PageMaker запоминает положение палитр на экране, и палитры в момент открытия программы появляются в тех местах, в которых они находились в момент закрытия (более подробно об этом см. гл. 3). Быстро убрать все палитры с экрана можно клавишей табуляции при активном инструменте Pointer (Стрелка) (об инструментах см. разд. "Палитра инструментов" данной главы). Комбинация клавиш <Shift>+<Tab> также убирает все палитры, кроме палитры инструментов.

В PageMaker используются следующие палитры:

  • палитра инструментов. Определяет тип выполняемой работы;
  • управляющая палитра. Дает быстрый доступ к функциям форматирования абзацев и символов;
  • палитра цветов. Позволяет назначать цвет элементам макета и определять цвета;
  • палитра стилей. Ускоряет доступ к функциям форматирования абзацев с помощью стилей;
  • палитра слоев. Позволяет создавать многослойные макеты и управлять слоями;
  • палитра шаблон-страниц. Предназначена для создания шаблон-страниц и назначения их страницам публикации;
  • палитра гиперссылок. Позволяет создавать перекрестные ссылки внутри и между элементами публикации, а также ссылки на внешние документы, находящиеся на локальных или сетевых устройствах.

Дополнительные палитры, собранные в списке Plug In Palettes (Дополнительные плитры) меню Window (Окно):

  • палитра шаблонов документов. Библиотека готовых шаблонов документов на любой вкус. Шаблоны документов используются как основа для создания собственных публикаций. В палитре эти шаблоны распределяются по тематическим группам. Палитру шаблонов можно пополнять новыми образцами и редактировать уже имеющиеся;
  • палитра изображений. Пополняемая палитра, в которой по умолчанию собраны ссылки на изображения с диска Photoshop — как векторные, так и растровые. Вы можете помещать изображения в публикацию и производить поиск по базе изображений;
  • палитра библиотек. В библиотеках PageMaker могут храниться любые элементы — текстовые блоки, изображения, совокупности элементов и пр. Библиотека представляет собой особый файл с расширением pml. Наличие библиотеки очень удобно — вы можете собрать в ней нужные вам для данного проекта элементы и использовать их во всех публикациях проекта;
  • палитра сценариев. Обеспечивает быстрый доступ к сценариям PageMaker и управляет их исполнением;
  • палитра внедрения данных. В новой версии программы появилась возможность внедрять в публикацию данные из файлов, создаваемых в базах данных, поддерживать связь с подобными базами, внедряя в документ поля ссылок и при необходимости переводить созданные поля ссылок в обычный текст. Управление связью с файлами базы данных производится в палитре Data Merge (Внедрение данных).

Особые функции в PageMaker имеют палитра инструментов и управляющая палитра.


Палитра инструментов

При верстке макета необходимо сообщать PageMaker о том, какого рода операции вы собираетесь делать: размещать элементы макета, редактировать текст, рисовать линии и фигуры и т. п. Сообщить это вы можете, выбрав соответствующий инструмент в палитре инструментов (рис. 1.9).

Палитра инструментов, скорее всего, уже находится на экране. Если вы ее не видите, то включите ее отображение командой Show Tools (Показать инструменты) из меню Window (Окно).

Рис. 1.9. Палитра инструментов

Палитра содержит следующие инструменты (рис. 1.9):

  • Pointer (Стрелка). Используется при размещении элементов макета (см. гл. 14).
  • Text (Текст). Используется для локального форматирования текста (см. гл. 4).
  • Rotating Tool (Поворот). Предназначен для поворота элементов макета (см. гл. 9 и 10).
  • Cropping Tool (Рамка). Позволяет производить обрезку имеющихся в публикации изображений (см. гл. 10).
  • Line (Линия). Используется для рисования линий с произвольным углом наклона (см. гл. 9).
  • Constrained Line (Перпендикуляр). То же, что и Line (Линия), но для создания вертикальных и горизонтальных линий.
  • Rectangle (Прямоугольник). Предназначен для рисования прямоугольников.
  • Ellipse (Эллипс). Служит для рисования эллипсов.
  • Polygon (Многоугольник). Предназначен для рисования многоугольников.
  • Rectangle Frame (Прямоугольный фрейм). Создает прямоугольный фрейм (см. гл. 14).
  • Ellipse Frame (Овальный фрейм). Предназначен для создания овального фрейма.
  • Polygon Frame (Многоугольный фрейм). Создает многоугольный фрейм.
  • Hand (Рука). Позволяет перемещать изображение страницы внутри окна документа при работе в крупном масштабе.
  • Zoom (Масштаб). Изменяет масштаб отображения страницы.


Масштаб отображения страницы

Если вы не меняли установок программы, вновь созданная страница документа отображается на экране в таком масштабе, чтобы полностью поместиться в окне документа. Этот масштаб удобен для предварительного размещения элементов макета. Для окончательного позиционирования, редактирования и форматирования текста, рисования мелких элементов и т. п. требуется увеличение масштаба. Если необходимо осмотреть рабочий стол на предмет поиска затерявшегося элемента или чтобы освободить его от ненужных кусков текста и изображений, масштаб придется уменьшить. Масштабирование проводят командами меню View (Просмотр), с помощью контекстного меню или инструментом Zoom (Масштаб). Есть несколько очень удобных клавиатурных комбинаций.

В меню View (Просмотр) предлагаются следующие варианты масштаба отображения: Actual Size (Реальный размер), Fit in Window (Целая страница), Entire Pasteboard (Монтажный стол) или один из шести предопределенных масштабов подменю Zoom To (Масштаб): 25, 50, 75, 100, 200, 400%. Первые три варианта есть и в контекстном меню, вызываемом правой кнопкой мыши при выбранном инструменте Pointer (Стрелка) (рис. 1.10). В контекстном меню при любом выбранном инструменте присутствует команда Other View (Заказной масштаб). Выбрав ее, вы откроете диалоговое окно, позволяющее задать любую величину масштаба в пределах от 14 до 731% (рис. 1.11).

Рис. 1.10. Контекстное меню при активном инструменте Pointer

При выбранном инструменте Zoom (Масштаб) указатель мыши имеет вид увеличительного стекла со знаком "+" внутри. Если теперь щелкнуть левой кнопкой мыши на любом месте страницы или рабочего стола, масштаб отображения страницы увеличится на одну градацию. Так же действует и команда Zoom In (Увеличить) меню View (Просмотр). Инструмент Zoom (Масштаб) позволяет также точно определить тот участок страницы или рабочего стола, который вы хотите рассмотреть подробнее. Поместите указатель в левый верхний угол участка, нажмите левую кнопку мыши и перетащите указатель в правый нижний угол участка (рис. 1.12). За указателем тянется пунктирная рамка. Когда вы отпустите кнопку мыши, выбранный фрагмент увеличится до размеров окна документа.

Для уменьшения масштаба предусмотрены аналогичные команды. В меню View (Просмотр) это команда Zoom Out (Уменьшить), уменьшающая масштаб отображения на одну градацию. Если вы пользуетесь инструментом Zoom (Масштаб), то нажмите и не отпускайте клавишу <Ctrl>. Знак "+" внутри курсора инструмента изменится на "-" и каждый щелчок мышью будет приводить к уменьшению масштаба.

Рис. 1.11. Диалоговое окно Other View Size

Рис. 1.12. Увеличение фрагмента страницы с помощью инструмента Zoom

Масштабирование — очень частая операция, и для нее удобно применять комбинации клавиш, полный их список приведен в приложении 2. Наиболее необходимы следующие комбинации клавиш:

  • <Ctrl>+<5> — для масштаба 50%;
  • <Ctrl>+<7> — для масштаба 75%;
  • <Ctrl>+<1> — для масштаба 100%;
  • <Ctrl>+<2> — для масштаба 200%;
  • <Ctrl>+<4> — для масштаба 400%;
  • <Ctrl>+<+> — для команды Zoom In (Увеличить);
  • <Ctrl>+<-> — для команды Zoom Out (Уменьшить).

При одновременном нажатии комбинации клавиш <Ctrl>+<Space> PageMaker делает активным инструмент Zoom (Масштаб) в режиме увеличения масштаба. С помощью мыши вы можете либо увеличить масштаб на несколько градаций, либо определить фрагмент, подлежащий увеличению. Стоит только вам отпустить клавиши <Ctrl>+<Space>, активным снова станет предыдущий инструмент. Если же добавить еще и клавишу <Alt>, то временно активный Zoom (Масштаб) будет находиться в режиме уменьшения.

В управляющей панели для масштабирования предназначены четыре кнопки. Первая увеличивает масштаб, вторая уменьшает, третья приводит масштаб отображения к реальному размеру документа, четвертая устанавливает его таким, чтобы страница документа была видна целиком.


Инструмент Hand

Этот инструмент предназначен для прокручивания содержимого окна документа, чаще всего он используется при работе под увеличением. При выбранном инструменте указатель приобретает вид руки. Поместите его в любое место страницы и нажмите левую кнопку мыши. При перетаскивании указателя публикация будет прокручиваться в окне документа.

На инструмент Hand (Рука) также можно временно переключиться с любого другого инструмента, нажав клавишу <Alt>. Как только вы отпустите клавишу <Alt>, текущим снова станет предыдущий инструмент.

Перемещать содержимое окна можно и с помощью полос прокрутки находящихся у правого и нижнего краев окна документа, но инструмент Hand (Рука) значительно удобнее и естественнее для пользователя, а главное — позволяет действовать быстрее и точнее.

Со второй функцией инструмента Hand (Рука) — тестированием гиперссылок — мы познакомимся позже, в гл. 18.


Инструменты рисования

Графические примитивы — линейки, прямоугольники, многоугольники и эллипсы настолько широко используются в полиграфическом дизайне, что являются неотъемлемыми инструментами всех издательских систем. Они и составляют большую часть палитры инструментов. Эти примитивы также могут служить рамками при использовании фреймов или масок. Более подробно данный вопрос рассмотрен в гл. 9 и 14.


Обрезка изображений

С помощью инструмента Cropping Tool (Рамка) можно кадрировать импортированные в публикацию изображения. Хотя этот инструмент, несомненно, очень прост и удобен в работе, используйте его только пока размер изображений в процессе верстки не определился окончательно. После того как это произойдет, кадрируйте изображение средствами того приложения, в котором оно создано, что приведет не только к ускорению отрисовки страницы в PageMaker, но и сократит размер публикации и скорость ее вывода. Более подробно инструмент рассмотрен в гл. 10.


Поворот изображений

Поворот изображений и особенно текста, если им не злоупотреблять, очень оживит дизайн публикации. Поворот может быть осуществлен либо на глаз с помощью инструмента Rotating Tool (Поворот) из палитры инструментов, либо вводом численного значения угла поворота в управляющей палитре. С помощью этого инструмента можно поворачивать и графику, изготовленную средствами рисования PageMaker.


Инструменты Pointer и Text

Это два наиболее часто используемых инструмента палитры инструментов. Первый применяется для выделения элементов йгакета, в том числе текстовых блоков, а второй — для локального форматирования текста.

Для того чтобы проделать любую операцию с элементом макета (перемещение, масштабирование, поворот и т. п.), необходимо сначала указать издательской системе объект этих преобразований, выделить его. Для выделения используют инструмент Pointer (Стрелка). Указатель этого инструмента имеет форму стрелки. Этой стрелкой нужно щелкнуть на нужном объекте.

Чтобы выделить объект, закрытый сверху другим объектом, используйте инструмент при нажатой клавише <Ctrl>. Комбинация клавиш <Ctii>+<A> выделяет все объекты на странице и рабочем столе, а комбинация клавиш <Ctrl>+<Shift>+<A> отменяет все сделанные выделения.

В процессе верстки постоянно возникает задача размещения текста в строго отведенном для него месте. Чтобы достичь желаемого размещения, параметры текста (кернинг, трекинг, ширину символов, межстрочные интервалы и т. п.) меняют в определенных текстовых блоках или абзацах. Прежде чем изменить параметры, необходимо выделить проблемный фрагмент. Инструмент Text (Текст) служит именно для выделения и набора текста внутри блока, тогда как с помощью инструмента Pointer (Стрелка) выделяют весь блок текста целиком, как единый объект. Указатель инструмента Text (Текст) курсор мыши имеет форму I. После того как вы щелкните им на странице (на свободном месте или внутри блока), появляется текстовый курсор (вертикальная черта). В этом состоянии программы (текстовом режиме) можно набирать и выделять символы.

Использование инструмента Text (Текст) и локальное форматирование подробно обсуждаются в гл. 4.


Управляющая палитра

Эта палитра, как правило, находится на экране, поскольку работать с ее помощью исключительно удобно. Она предоставляет быстрый доступ к большинству функций программы. Кроме того, в управляющей палитре отображается информация о параметрах выделенных элементов. Поскольку значения в палитре вводятся численно, вы можете быть спокойны за точность установок. Для вывода этой палитры на экран служит команда Show Control Palette (Показать управляющую палитру) из меню Window (Окно) или комбинация клавиш <Ctrl>+<'>. В зависимости от того, какой инструмент активен и что конкретно, выделено, управляющая палитра предоставляет для просмотра и изменения соответствующие параметры (рис. 1.13 и 1.14).

Рис. 1.13. Вид управляющей палитры при активном инструменте Pointer и выделенном текстовом блоке

Рис. 1.14. Вид управляющей палитры при активном инструменте Text и выделенном фрагменте текста

Устройство управляющей палитры довольно сложно, ее вид и функции различаются для локального, глобального форматирования, работы с объектами и пр. Мы будем рассматривать применение этого "пульта управления" по мере изучения материала.


Прочие палитры

Устройство других палитр стандартно для приложений Adobe (рис. 1.15). Вывод плавающей палитры на экран осуществляется с помощью команды Show <имя палитры> (Показать <имя палитры>) меню Window (Окно).

Рис. 1.15. Палитры слоев: Adobe PageMaker

Плавающая палитра Adobe PageMaker 7.0 (рис. 1.16) содержит следующие элементы.

  • Заголовок окна палитры с кнопками сворачивания и закрытия. Если свернуть палитру, останется виден лишь ее заголовок и название, щелчок на кнопке с крестом совсем убирает палитру с экрана. Это действие эквивалентно соответствующей команде Hide <имя палитры> (Спрятать <имя палитры>) меню Window (Окно). Заголовок палитры также используется для перемещения палитры по экрану — просто установите указатель на заголовок и перетащите палитру на нужное место

Рис. 1.16. Палитра цветов — стандартная палитра программы

  • Закладка с указанием имени палитры. Одно окно палитры может содержать и несколько разных палитр. Их имена указываются на закладках непосредственно под заголовком окна палитры.
  • Меню команд палитры. С каждой палитрой связан по смыслу определенный набор команд PageMaker. Эти команды находятся в меню палитры. Для открытия меню служит кнопка со стрелкой в правой верхней части палитры.
  • Основное окно палитры. В нем в виде списка отображается информация, соответствующая назначению палитры. Например, в палитре цветов там находится список цветов, а в палитре стилей — список стилей, определенных в публикации. Одинарный щелчок мышью на элементе списка позволяет придать выделенному объекту соответствующий атрибут (цвет, стиль и т. п.), а двойной щелчок — переопределить сам элемент. Кроме названия элемента, в списке палитры может отображаться дополнительная информация о нем: видимость для слоя, четность для шаблон-страницы и т. п. Если список не помещается в основном окне полностью, то справа от него появляется полоса прокрутки, позволяющая получить доступ к оставшимся за пределами окна элементам.

Чтобы изменить размер палитры, поместите указатель в ее нижний правый угол и перетаскивайте его до тех пор, пока палитра не достигнет требуемого размера.

  • Строка статуса. Нижняя строка палитры, которая может отображать дополнительную информацию о выбранном элементе списка, например соотношение цветовых компонентов для цвета, выбранного в палитре.
  • Пиктограммы создания и удаления элемента списка. Щелкнув на значке "чистая страница", вы создадите новый элемент списка (новый цвет, стиль, слой, шаблон и т. п.), щелчок на значке "мусорная корзина" удалит выбранный в списке элемент. Перетаскивание мышью элемента списка на одну из этих пиктограмм создает в списке копию этого элемента или, соответственно, удаляет его.

Также в палитре могут находиться дополнительные элементы. Например, список оттенков цвета и кнопки заливки и обводки в палитре цветов. Не забывайте, что некоторые функции PageMaker доступны только при использовании соответствующей палитры.


Измерительные линейки и направляющие

При построении макета координаты размещаемых объектов очень важны. Для приблизительного размещения и измерения элементов очень удобно использовать линейки (рис. 1.17). Если они отсутствуют на экране, выберите команду Show Rulers (Показать линейки) меню View (Просмотр) или включите показ линеек с помощью комбинации клавиш <Ctrl>+<R>.

Рис. 1.17. Окно документа PageMaker с измерительными линейками и направляющими

Единицы измерения, в которых градуированы измерительные линейки, легко определить из контекстного меню. Щелкните правой кнопкой мыши на линейке и выберите нужную единицу измерения в открывшемся списке. Единицы определяются отдельно для вертикальной и горизонтальной линеек.

По умолчанию началом координат является левый верхний угол страницы или верхняя точка середины разворота при оборотной печати. Для изменения положения начала координат поместите указатель в пределы квадрата, образованного пересечением вертикальной и горизонтальной измерительных линеек; нажмите левую кнопку мыши и перетащите указатель в нужную вам точку. Когда вы отпустите кнопку мыши, координаты начнут отсчитываться с определенной вами позиции. При перетаскивании точки начала координат положение указателя отмечается пересечением вертикальной и горизонтальной пунктирных линий.

После того как начало координат задано, имеет смысл защитить его от случайного смешения командой-переключателем Zero Lock (Закрепить ноль) меню View (Просмотр). Когда начало координат блокировано, команда в меню помечена галочкой. Чтобы снова изменить положение начала координат, следует разблокировать его той же командой. Для точного размещения объектов можно использовать команду-переключатель Snap to Rulers (Выровнять по линейкам) меню View (Просмотр).

Гораздо чаще, чем линейки, для размещения и выравнивания объектов используют направляющие. Это вспомогательные линии, не выводимые на печать. Направляющие можно наделить особым свойством — способностью "примагничивать" объект, если при перетаскивании он оказался близко от направляющей линии. Наличие такого качества облегчает точное размещение и выравнивание объектов. "Магнетизм" можно разрешить/запретить командой Snap to Guides (Выровнять по направляющим) меню View (Просмотр).

Для создания направляющей поместите указатель мыши на измерительную линейку и перетащите его во внутреннюю область окна, на страницу. За курсором тянется тонкая синяя линия. Это и есть направляющая. Из вертикальной линейки "вытягивается" вертикальная, из горизонтальной — горизонтальная направляющая линия.

На странице может присутствовать любое количество вертикальных и горизонтальных направляющих. Если направляющая находится на шаблон-странице, она будет отображаться на каждой странице публикации. Размещение сетки направляющих на шаблон-странице позволяет создать модульную сетку публикации для придания единого стиля всем ее страницам. Подробное рассмотрение работы с направляющими линиями вы найдете в гл. 13.


Резюме

На этом мы завершим обзор PageMaker. Рассмотрены основные элементы пользовательского интерфейса (меню, палитры, окна). Информация, приведенная в этой главе, очень важна и понадобится вам при изучении всех последующих глав данной книги. Основным отличием PageMaker от текстового редактора является свободное размещение объектов на странице публикации, поэтому инструментарий и способы работы во многом напоминают графические приложения: наличие палитры инструментов и других палитр, возможность выделения и трансформации объектов в публикации. Богатые возможности программы в области обработки текста станут ясны из последующих глав.


  • Глава 10. Импорт графики
    • Векторная графика
    • Точечная графика
    • Точки, разрешение
    • Типы изображений
      • Черно-белые штриховые изображения
      • Градации серого
      • Индексированный цвет
      • RGB и CMYK
    • Размещение графики
      • Установки фильтров импорта
      • Импортирование свободно размещаемой графики
      • Замена имеющегося в публикации изображения импортированным
      • Помещение в текст вложенных изображений
      • Хранение изображений в публикации
      • Редактирование оригинала
      • Графика и системный буфер обмена (Clipboard)
      • Использование библиотек
    • Масштабирование импортированных изображений
    • Кадрирование изображения
    • Просмотр графики
    • Сжатие изображений
    • Редактирование растровых изображений средствами PageMaker
    • Использование фильтров Photoshop в PageMaker
    • Резюме


ГЛАВА 10.

Импорт графики

Для того чтобы поместить какое-либо изображение на страницу публикации PageMaker, его необходимо импортировать специализированным фильтром импорта. Фильтр представляет собой программу представления графической информации, созданной в стороннем приложении в виде, понятном PageMaker.

Самый общий принцип импорта заключается в том, что все, с чем может работать компьютер, в том числе и изображение, должно быть превращено в цифровую форму (закодировано). Цифровая компьютерная графика по способу кодирования может быть разделена на две: векторную и точечную.


Векторная графика

В векторной графике все изображения описываются в виде математических объектов — контуров. Каждый контур представляет собой независимый объект, который можно перемещать, масштабировать, изменять до бесконечности. Векторную графику часто называют также объектно-ориентированной графикой. Рассмотренная в предыдущей главе графика, создаваемая средствами PageMaker, тоже должна быть отнесена к этому типу.

У векторной графики много достоинств.

  • Она экономна в плане объемов дискового пространства, необходимого для хранения изображений: это связано с тем, что сохраняется не само изображение, а только некоторые основные данные, используя которые программа всякий раз воссоздает изображение заново. Кроме того, описание цветовых характеристик почти не увеличивает размера файла,
  • Объекты векторной графики легко трансформируются и модифицируются, что не оказывает практически никакого влияния на качество изображения.

Рис. 10.1. Трансформация векторного рисунка

  • Векторные объекты используют все преимущества разрешающей способности любого выводного устройства (изображение всегда будет выглядеть настолько качественно, насколько способно вывести его данное устройство).
  • Важным преимуществом программ векторной графики являются развитые средства интеграции изображений и текста, единый подход к ним и, как следствие, возможность создания конечного продукта. Поэтому программы векторной графики используются в области дизайна, технического рисования, для чертежно-графических и оформительских работ.

Однако, с другой стороны, векторная графика может показаться чрезмерно жесткой, "фанерной". Она действительно ограничена в чисто живописных средствах, в программах векторной графики практически невозможно создавать фотореалистические изображения.

Кроме того, векторный принцип описания изображения не позволяет автоматизировать ввод графической информации, как это делает сканер для точечной графики.


Точечная графика

Принцип кодирования графической информации в точечной графике принципиально отличается от векторной. Все точечные изображения представляют из себя не совокупность отдельных объектов, а мозаику из очень мелких элементов — пикселов.

Достоинств у точечной графики, как ни странно, не слишком много.

Основным является простота и, как следствие, техническая реализуемость автоматизации ввода (оцифровки) изобразительной информации. Для получения изображений используют сканеры и цифровые камеры — статические и для записи видеофайлов.

Не менее важными достоинствами точечной графики являются легкость и неограниченные возможности модификации изображения.

Однако точечной графике присущи и существенные недостатки. При ее масштабировании неминуемы искажения, порой катастрофические. Редактирование сложнее и более трудоемко. Она требует большого дискового пространства и системных ресурсов компьютера.


Точки, разрешение

Для ввода растрового изображения в компьютер его необходимо оцифро-вать. Оцифровка плоского изображения производится, как правило, сканером. Принцип работы сканера на примере черно-белого изображения таков: картинка делится на очень маленькие клетки (ячейки). Каждая клетка обозначается единицей или нулем в зависимости от того, попало в нее изображение или нет (черная она или белая). Полученные данные заносятся в таблицу той же размерности (такое же количество ячеек по ширине и по высоте). В результате вы получите матрицу из единиц и нулей.

Полученная матрица или таблица называется битовой картой (Bitmap). Слово "карта" — синоним слова "таблица", а слово "бит" — это минимальная единица информации (она имеет два состояния: 1 или 0).

Битовая карта для компьютера — это массив цифровых значений, которые заносятся в ячейки памяти (память в известном смысле тоже таблица) и могут быть подвергнуты обработке. Физический размер ячейки выражается через разрешение: количество точек изображения на единицу длины, обычно дюйм (сокращается как точек/дюйм, или dots/inch).

а

б

Рис. 10.2. Рисунки одинакового размера с низким (а) и высоким (б) разрешением

На рис. 10.2 представлены два изображения с одинаковыми размерами, но с разным разрешением. При выводе на экран изображения с меньшим разрешением, чем у экрана, программа "старается" сохранить размер изображения, поэтому для отображения каждого элемента изображения используется несколько пикселов экрана. Похожая картина будет наблюдаться на любом устройстве вывода (принтер, фотонаборный автомат и т. п.), если разрешение изображения недостаточно для него. Поскольку у выводных устройств (принтера или фотонаборного аппарата) разрешение во много раз больше, чем у экрана — от 300 до 3000 dpi, и выше, то и разрешение изображений для этих устройств должно быть выше (см. гл. 23).


Типы изображений

Другим существенным параметром точечного изображения является глубина цвета. Установка этого параметра определяет тип изображения.


Черно-белые штриховые изображения

Если у вас в качестве оригинала служит рисунок, выполненный тушью на белой бумаге (или иллюстрации, логотипы, которые репродуцируются без полиграфического растрирования), то при его сканировании вы, скорее всего, определите режим сканирования как Black and White Drawing, или Line Art (в программном обеспечении разных сканеров режим называется по-разному), что означает одно и то же — однобитовую глубину цвета.

На каждый пиксел такого изображения отводится один бит, а одним битом, как вы знаете, можно закодировать только два состояния — два цвета: черный или белый. Промежуточных состояний не бывает. Такой режим еще называется Bitmap (битовая карта).


Градации серого

Если каждый пиксел кодировать не одним битом, как в штриховом изображении, а 8 битами (8 бит составляют 1 байт), то можно получить 256 градаций серого, так называемую серую шкалу (grayscale). Каждый пиксел характеризуется значением яркости, которое изменяется в диапазоне от 0 (черный) до 255 (белый). Значение яркости можно так же интерпретировать, как процентное содержание черной краски в диапазоне от 0 (белый) до 100% (черный).

Такого числа уровней вполне достаточно, чтобы правильно отобразить черно-белое полутоновое изображение, например черно-белую фотографию.

Практически любой сканер имеет специальный режим для ввода черно-белых полутоновых изображений — Black and White Photo или Grayscale (название может отличаться в программах разных сканеров).


Индексированный цвет

Первые цветные мониторы работали с ограниченной цветной гаммой: сначала 16, затем 256 цветов. Они кодировались 4 битами (16 цветов) или 8 битами (256 цветов). Такие цвета называются индексированными. Работать

с полноцветной, фотореалистической графикой, имея в своем распоряжении только 16 (или даже, 256) цветов из 16,7 миллиона возможных, конечно, досадно, но именно таким количеством цветов располагают файлы данного формата. По этой причине в полиграфии они не используются, однако широко применяются для электронных публикаций (см. гл. 18).


RGB и CMYK

Для работы с полноцветным изображением используются цветовые модели RGB и CMYK, в которых на каждый пиксел отводится 24 или 32 бита соответственно. Это дает возможность закодировать 16,7 миллиона оттенков. Каждый пиксел кодируется 8 битами на каждую цветовую составляющую, принятую в этой модели. О цветовых моделях см. гл. 19.

Именно этот тип используется в полиграфии для работы с цветными растровыми изображениями.

Форматы файлов растровых изображений

Растровые изображения получаются сканированием слайдов или бумажных оригиналов. Adobe PageMaker с версии 6.0 имеет возможность непосредственного обращения к сканеру по интерфейсу TWAIN для сканирования изображений с немедленным их помещением в публикацию. Несмотря на кажущееся удобство этого пути, мы не рекомендуем его использование, т. к. изображения за редчайшим исключением требуют предварительной обработки (обрезка, поворот, тональная и цветовая коррекция и т. п.), которую все равно придется проводить в другой программе, например Adobe Photoshop.

Все перечисленные типы растровых изображений могут быть закодированы в графическом файле разными способами. Таких способов (форматов) существует довольно много, хотя широко применяется ограниченное количество. PageMaker располагает обширным набором фильтров импорта графических файлов "на все случаи жизни", но рассмотрим мы только те, которые часто применяются в практике верстки, и наоборот, предостережем от использования непригодных или неудобных для полиграфического процесса форматов.

Форматы PSD и TIFF для RGB

Формат PSD (adobe PhotoShop Document), собственный формат Adobe Photoshop, позволяет хранить все мыслимые типы растровых изображений, включая многоканальные, многослойные и дуплексные. Файлы этого формата имеют очень большие размеры. Как правило, PSD-файлы не импортируют в публикацию непосредственно, а предварительно переводят в формат TIFF.

Формат TIFF (Tagged Image File Format) был создан в качестве универсального формата для хранения сканированных изображений с цветовыми каналами (файл с расширением tif). Важным достоинством этого формата является его переносимость на разные платформы (при сохранении вы можете создать документ, доступный для чтения на компьютерах, совместимых с IBM PC или Macintosh), он импортируется во всех программах настольных издательских систем, его можно открыть и работать с ним практически в любой программе точечной графики.

Этот формат имеет широкий диапазон передачи цветов: от монохромного до 24-битовой модели RGB (TrueColour) и 32-битовой цветоделенной модели CMYK.

Кроме того, формат включает схемы сжатия для уменьшения размера файла (при сохранении доступна опция LZW Compression (LZW Уплотнение)), что является немаловажным параметром для работы с полноцветными изображениями большого размера.

Значительной особенностью TIFF является возможность хранения в файле обтравочных контуров. Это позволяет импортировать изображения непрямоугольной формы.

Формат DCS

DCS (Desktop Colour Separation) был разработан фирмой Quark Corp. специально для представления цветоделенных файлов, предназначенных для вывода на фотонаборном автомате. При сохранении изображения в этом формате получается не один файл, а пять. Четыре из них содержат отдельные каналы CMYK-изображения, а пятый — небольшую картинку с экранным представлением (preview) цветного изображения. В Photoshop файлы DCS можно получить экспортированием цветоделенного CMYK-изображения в формат EPS. В соответствующем диалоговом окне можно определить параметры DCS-файлов. Файлы этого формата могут быть созданы в Photoshop 4.0 и импортированы в PageMaker. На стадии вывода цветоделения файл с экранным изображением автоматически заменяется на файлы с компонентами. Последние могут иметь очень большие размеры.

Преимуществом формата является возможность работы с файлами низкого разрешения в программе верстки, в то время как необходимые файлы высокого разрешения может хранить сервис-бюро или локальный ОРI-сервер. Выигрывается при этом не только место на жестком диске верстальщика, но и высокая скорость работы PageMaker, которому не надо при изменении вида страницы перечитывать огромные файлы.

С другой стороны, используя встроенный в PageMaker механизм связывания (см. гл. 11), можно добиться тех же результатов и без использования формата DCS.

Формат PCX

Формат, разработанный фирмой Z-Soft для программы PC PaintBrush, является одним из самых известных, и практически любое приложение, работающее с графикой, легко импортирует его. Он не позволяет хранить цвето-деленные CMYK-изображения и данные цветокоррекции, что делает невозможным его применение при создании цветных публикаций.

Формат BMP

Формат предназначен для Windows и поэтому поддерживается всеми приложениями, работающими в этой среде. Он использует только индексированные цвета, независим от платформы. Из-за того, что этот формат поддерживает только индексированный цвет, он не применяется в издательстве.

Формат JPEG

Формат JPEG (Joint Photographic Experts Group) предназначен для сохранения точечных файлов со сжатием. Сжатие по этому методу уменьшает размер файла от десятых долей процента до ста раз (практически диапазон: от 5 до 15 раз), но сжатие в этом формате происходит с потерями качества (в большинстве случаев эти потери находятся в пределах допустимых). Распаковка JPEG-файла происходит автоматически во время его открытия.

Потери, о которых идет речь, не существенны при верстке электронных публикаций и для принтерных распечаток, но катастрофически сказываются на качестве типографской продукции. Поэтому использование данного формата в полиграфии не рекомендуется. Поскольку файлы JPEG имеют очень малые размеры, данный формат стал стандартом для публикаций на WWW.

Формат Scitex CT

Формат Scitex CT (Continuous Tone) применяется для высококачественной обработки цветных изображений в моделях RGB или CMYK, а также изображений в градациях серого цвета. Применяется на компьютерах Scitex — Hi-End для вывода фотооригиналов. Файлы этого формата предназначаются для вывода с помощью патентованного растеризатора Scitex, обеспечивающего высочайшее качество растрирования, требующееся только в случаях исключительной важности. Файлы этого формата, как правило, получают не конвертированием формата, а напрямую, с помощью сканеров Scitex.

Формат PCD

Формат Photo CD первоначально разрабатывался как часть технологии беспленочной фотографии. Наряду с этой областью применения, он начал играть заметную роль в практике использования настольных редакционно-издательских систем, став обычным способом хранения большого числа изображений — особенно, при издании всевозможных каталогов.

Рис. 10.3. Диалоговое окно управления процессом импорта файла в формате Photo CD

В составе PageMaker имеется фильтр для импорта изображений в формате Photo CD (рис. 10.3), упрощающий работу с этим форматом в промышленных условиях.

В поле предварительного просмотра, расположенном в левом верхнем углу диалогового окна фильтра, можно выделить прямоугольный фрагмент изображения для импорта (перетаскиванием указателя мыши по его диагонали).

Как правило, на одном компакт-диске имеются несколько вариантов одного и того же изображения с различными значениями разрешения. Вы можете выбрать подходящий размер и разрешение. Для этого служит область Output (Параметры). Если вы точно не знаете, какие параметры должны быть у вашего изображения, можно использовать раскрывающийся список Device type (Тип устройства). Тогда программа подставит значения разрешения автоматически. Например, если в качестве устройства вывода задать Laser printer (Лазерный принтер), то в поле Device res (Разрешение устройства) будет проставлена величина 300 (Разрешение офисных лазерных принтеров), в поле Line screen (Линиатура) — 75, а в поле Image res (Разрешение изображения) — 150 ppi. Данные величины являются стандартом для вывода на офисный лазерный принтер. Про выбор линиатуры и разрешения читайте в гл. 23.

В диалоговом окне имеются элементы управления для регулировки резкости изображения, настройки цветового баланса и преобразования изображения в монохромное полутоновое. Вариант повышения резкости выбирается в раскрывающемся списке. Настройка цветового баланса выполняется в предположении, что самая светлая область изображения соответствует чистому белому цвету. Используйте этот режим только в том случае, когда самая светлая область в изображении изначально действительно была белой. Если белый цвет в изображении отсутствует, этим режимом не следует пользоваться.

Изображения в формате Photo CD всегда представляются в альбомной ориентации. Для поворота изображения можно воспользоваться раскрывающимся списком Orientation (Ориентация).

Установка флажка Save to CIELAB TIFF file (Сохранить как CIELAB TIFF) позволяет создать копию изображения в формате TTFF, которая может потребоваться для передачи в сервисное бюро. Преобразование изображений в формат TIFF позволяет при передаче публикации вместо всего компакт-диска включить в комплект всего лишь несколько файлов (правда, большого размера). Кроме того, сохранение изображения в виде файла позволяет задать ему мнемоническое имя вместо принятого в системе именования Photo CD имени вроде 248012.PCD.

Наряду с выбором разрешения в окне импорта задается и требуемый размер файла в области Size (Размер).

В правой части окна фильтра расположены кнопки управления. При щелчке на кнопке Preview (Просмотр) программа демонстрирует в отдельном окне вид файла после импорта. Остальные кнопки управляют цветовым профилем изображения. Об управлении цветом и профилях читайте в гл. 21.

Форматы файлов векторных изображений

Файлы иллюстраций для каждой векторной программы имеют свой собственный формат, т. к. каждая программа обладает набором специфических инструментов и операций с контурами. Поэтому перекодирование из формата в формат обязательно сопряжено с искажениями или потерями. Тем важнее сразу сориентироваться на ту программу, которая будет использоваться для окончательной верстки. Наибольшее предпочтение среди профессионалов отдано Adobe Illustrator и Macromedia Freehand. Эти программы обладают широкими возможностями и необходимыми для полиграфиста функциями (цветоделение, корректная работа с PostScript, цветокоррекция, поддержка всех цветовых моделей и палитр плашечных цветов и т. п.). Для отображения на экране содержимого файлов иллюстраций PageMaker использует небольшое растровое изображение, хранящееся в этих же файлах.

Как правило, для публикаций, предназначенных к выводу на фотонаборном автомате, не используют изображения в формате CorelDRAW по причине ненадежности. Если ваше изображение создано именно в CorelDRAW, перед импортом в PageMaker преобразуйте его в растровое с высоким разрешением.

Существуют два формата, используемых всеми программами подготовки иллюстраций, — WMF и EPS. PageMaker имеет фильтры импорта для обоих.

Формат WMF

Все графические приложения, работающие в среде Windows, могут импортировать файлы в формате WMF (Windows MetaFile, или метафайлы Windows). Однако этот формат имеет ограничения и недостатки. Он не поддерживает именованных цветов, контуры, преобразованные в этот формат, имеют избыточную сложность и пр.

Формат EPS

Отдельного обсуждения достоин формат EPS (Encapsulated PostScript). Этот формат представляет собой описание изображения на языке PostScript, предпочтительном для полиграфических целей. В рамках данного формата возможно хранение векторной и растровой графики, шрифтов, растриро-ванных изображений и информации о растрировании, контуров обтравки и кривых калибровок. Как и сам язык PostScript, формат EPS является универсальным форматом описания не только изображений, но и текстовой информации, и макета в целом.

При отображении на экране импортированных файлов EPS также используется растровое экранное изображение (preview), хранящееся в заголовках этих же файлов. Действительное их содержимое обнаруживается только при выводе на PostScript-принтер. Если принтер не имеет интерпретатора PostScript, то на него будет выведено это самое растровое изображение, что не позволит достоверно судить о качестве макета. Это одна из важнейших причин, по которым для вывода корректуры следует использовать именно PostScript-принтер.

Экранные изображения в EPS-файлах хранятся в форматах WMF и TIFF на компьютерах PC и в форматах PICT и TIFF — на Macintosh. Так что, если вам приходится переносить файлы между компьютерами этих платформ, предпочтительнее изображение TIFF, т. к. оно будет использовано на обеих платформах. В противном случае, вместо изображения содержимого EPS-файла в программе верстки будет виден лишь серый габаритный прямоугольник, хотя при распечатке на PostScript-принтере изображение будет выведено правильно.

Резюмируя приведенные выше сведения о графических форматах, скажем, что для верстки предпочтительно использование формата TIFF для растровых изображений и EPS — для векторных и комбинированных.


Размещение графики

Для импорта графики используется команда Place (Поместить) меню File (Файл). Диалоговое окно импорта выглядит несколько по-разному в зависимости от того, какой инструмент был активен перед выбором команды: Pointer или Туре.

На рис. 10.4 представлен вид этого окна при выбранном инструменте Pointer (Стрелка). При выделении в окне импортируемого файла ниже будет отображаться информация о его типе, размере и дате последней модификации. Внизу окна расположена группа переключателей, управляющая режимом импортирования файлов. В любом случае часть из них будет недоступна, поскольку не имеет смысла для данного случая. Рассмотрим функции этих переключателей и варианты импорта более подробно.

Рис. 10.4. Окно Place при выбранном инструменте Pointer


Установки фильтров импорта

Единственный переключатель, который доступен при импорте любого материала (в том числе и текстового), — это Show filter preferences (Показать установки фильтра). Многие фильтры могут работать в нескольких режимах или требуют дополнительной информации для своей работы. На рис. 10.5 приведены примеры установок фильтров импорта для форматов EPS (DCS-файл, созданный из Photoshop) и AI (Adobe Illustrator). Для фильтров импорта графических форматов эта информация в основном касается разрешения и цветности создаваемой миниатюры, а также вариантов импорта именованных цветов из импортируемого файла (см. гл. 19).

Рис. 10.5. Установки фильтров импорта для форматов EPS и AI


Импортирование свободно размещаемой графики

На рис. 10.4 представлено окно, возникающее при импортировании свободно размещаемой графики. Никаких специфических вариантов в этом случае окно Place (Поместить) не предлагает. После щелчка на кнопке ОК указатель принимает вид одной из приведенных выше пиктограмм в зависимости от формата импортируемого файла. Далее следует установить указатель в то место на странице публикации, где должен располагаться верхний левый угол изображения, и щелкнуть левой кнопкой мыши. Изображение появится на странице публикации. Если оно имеет неверную цветопередачу (в случае CMYK-изображений цвета могут измениться до полной неузнаваемости), то следует включить систему цветокоррекции и установить профайлы для той аппаратуры, которая использовалась для их получения и обработки (см. гл. 21). Если же изображение выглядит грубо, как "мозаика" из цветных квадратов, то измените установки отображения импортированной графики (см. гл. 3) или поместите файл еще раз, изменив параметры миниатюры (для импорта EPS- и AI-файлов).

Помещенное изображение можно переместить в любое место страницы, изменить его габариты (см. разд. "Масштабирование импортированных изображений" данной главы), повернуть и исказить (см. гл. 14). При верстке изображение может быть обрамлено текстом. Свободно размещаемому изображению можно задать атрибут обтекания текстом (см. гл. 14).


Замена имеющегося в публикации изображения импортированным

Если перед выбором команды Place (Поместить) на странице было выделено графическое изображение, то при импорте открывается новая возможность — заменить выделенное изображение импортируемым.

Рис. 10.6. Диалоговое окно Place при выделенном в публикации графическом изображении

Для замены имеющегося изображения переключатель Place (Поместить) должен находиться в положении Replace entire graphic (Вместо выделенного изображения), а переключатель Retain cropping Data (Сохранить кадрирование) должен отражать ваши пожелания относительно кадрирования импортируемого изображения. Если выделенное изображение было кадрировано инструментом Cropping Tool (Рамка), то при включенном переключателе Retain cropping Data (Сохранить кадрирование) импортированное изображение сохранит исходные размеры и будет кадрировано справа и снизу до точно такого же размера. В противном случае изображение будет отмасшта-бировано до размеров кадрирующей рамки.

При замене изображения без кадрирования или в случае, когда размер "помещаемого изображения меньше, чем размер выделенного, PageMaker, пытаясь сохранить размеры изображения по обоим измерениям, нарушает соотношение вертикального и горизонтального размеров изображения (aspect ratio), искажая его. Пример действия такого режима представлен на рис. 10.7.

а

б

Рис. 10.7. Нарушение пропорций импортируемого изображения при отключенном сохранении кадрирования

Примечание

Режим Retain Cropping Data (Сохранить кадрирование) не имеет никакого отношения к импорту уже кадрированных во внешних программах изображений. Он лишь сохраняет кадрирование, выполненное средствами PageMaker. Для импорта кадрированных изображений никаких особых действий в самом PageMaker совершать не нужно — все должно делаться во внешнем приложении.

Да простит нас читатель за небольшой экскурс в Photoshop для объяснения механизма кадрирования изображений. Мы уделяем здесь место этой проблеме, поскольку задача помещения в публикацию изображений непрямоугольной формы встречается исключительно часто и столь же часто вызывает трудности у начинающих верстальщиков.

Для того чтобы получить на странице изображение неправильной формы, необходимо импортировать изображение вместе с информацией о его контуре (контур обтравки). Для передачи обоих видов информации годится далеко не любой формат файлов, поскольку в этом случае необходимо совместное нахождение в одном файле и растрового, и векторного изображений. Как мы уже отмечали выше, этому условию удовлетворяют форматы EPS и TIFF версии 6.0 и выше.

Для того чтобы создать такое изображение в Photoshop, необходимо создать в его документе обтравочный контур с помощью инструмента Реп (Перо) или путем конвертации в контур границы выделенной средствами Photoshop области (Selection). Далее следует, выбрав команду Save Path (Сохранить контур) из меню палитры Paths (Контуры), сохранить контур. Следующим шагом будет выполнение команды Clipping Paths (Обтравочный контур) «из того же меню, которая позволяет выбрать контур, который требуется определить как обтра вочный. И в заключение остается сохранить файл в формате TIFF или Photoshop EPS.

После импортирования такого файла командой Place (Поместить) PageMaker в публикации появится обтравленное изображение. Если изображение таково, что обтравку приходится делать вручную, для этого можно воспользоваться средствами PageMaker: маскированием или фреймами (см. гл. 15).

Рис. 10.8. Обтравленное изображение на странице публикации


Помещение в текст вложенных изображений

Если графическое изображение помещается в публикацию при текущем инструменте Text (Текст), оно будет привязано к точке вставки (месту в тексте, где находился текстовый курсор). В этом случае изображение можно рассматривать как один из символов текста. При перемещении текстового блока или текста внутри текстового блока вложенное изображение тоже перемещается, всегда находясь в положении, заданном при импорте. Прочие варианты помещения изображений не дают такой возможности: при перемещении текста изображение остается на том же месте.

Для того чтобы разместить изображение как вложенное, перед помещением следует выбрать инструмент Text и установить курсор в то место текста, к которому необходимо привязать изображение. Затем вызвать окно импорта. При этом его вид будет таким, как показано на рис. 10.9.

Помещенное изображение можно смещать относительно базовой линии строки, в которой оно находится. Для этого выберите инструмент Pointer (Стрелка) и перемещайте изображение вверх или вниз, как делали это для графики, созданной средствами PageMaker (см. предыдущую главу). Курсор при этом примет вид двунаправленной стрелки в прямоугольной рамке (рис. 10.10).

Помещение вложенных изображений, размерами превышающих автоматический интерлиньяж текста, вызывает увеличение значения интерлиньяжа для строки, в которой находится место привязки. В данном случае происходит то же, что и при увеличении кегля отдельного символа в строке — автоматический интерлиньяж рассчитывается по нему. Чтобы избежать некрасивого изменения интерлиньяжа, его необходимо задать специально, а не довольствоваться автоматическим (см. гл. 4).

Рис. 10.9. Диалоговое окно Place при размещении вложенного изображения

Рис. 10.10. Смещение вложенного изображения относительно базовой линии текста

Ниже, на рис. 10.11, приведены примеры использования вложенной графики.

Для построения выворотного заголовка в примере использовано импортированное растровое изображение. Изображение помещено на предшествующую заголовку строку, а интерлиньяж между ней и строкой заголовка сделан очень небольшим (2 пункта). Затем вложенное изображение смещено вниз относительно базовой линии своей строки — так, чтобы оно оказалось за текстом заголовка.

Второе и третье вложенные изображения использованы в качестве графического маргинала. Пезиции табуляции и отступы определены в стиле абзаца.

Рис. 10.11. Примеры использования вложенной графики

Еще один пример использования вложенного изображения представлен на рис. 10.10, где вложенные изображения пиктограмм предназначены для чисто информационной цели.

Возможности использования вложенной графики чрезвычайно широки. Более подробно о них рассказано в части IV. Кроме того, в гл. 15 рассмотрено множество других примеров, а в гл. 14 описаны специальные приемы точного размещения графики.


Хранение изображений в публикации

В процессе импорта графики на экране может появиться сообщение, аналогичное представленному на рис. 10.12.

В нем содержится вопрос о месте хранения изображения — в публикации или вне ее. В публикации изображение хранится в несжатом виде, для чего требуется в несколько раз больше дискового пространства (большинство графических форматов используют сжатие данных). Кроме того, оно будет храниться на жестком диске в двух копиях: в виде отдельного файла и внут-ри'публикации (оригинал ведь стирать нельзя, т. к. в любой момент он должен быть готов для редактирования). С другой стороны, хранение изображений внутри публикации делает ее самодостаточной и несколько ускоряет ее перерисовку на экране.

Рис. 10.12. Диалоговое окно, позволяющее выбрать место хранения изображения

Преимущества использования обоих вариантов хранения изображений можно сочетать, храня в публикации изображения маленького размера (не тратя много лишнего дискового пространства) и оставляя внешними большие файлы. Отслеживание выполнения данного подхода можно поручить PageMaker. Единственное, что для этого требуется — проставить значение поля Alert when storing graphics over (Предупреждать, если объем превысит) в окне Preferences (Установки) (см. гл. 3). Это значение определяет максимальный размер изображения, который вы разрешаете хранить внутри файла публикации. При импорте файла, превышающего данный размер, на экране появится то самое диалоговое окно, которое представлено на рис. ЮЛ2.

По опыту авторов хранение файлов вне публикации надежнее. Значительная часть ошибок в файлах публикаций при сбоях связана именно с графикой, помещенной внутрь публикации или внедренной.

PageMaker поддерживает связь с внешними файлами по одному из механизмов: PageMake Links или OLE. Обе технологии связывания подробно рассматриваются в гл. 11.


Редактирование оригинала

Если графический файл был помещен в публикацию командой Place (Поместить), то в большинстве случаев его можно отредактировать командой Edit Original (Редактировать оригинал) из меню Edit (Редактирование). При этом PageMaker запустит ассоциированное с типом изображения приложение и загрузит изображение в него. По окончании сеанса редактирования и выхода из графического приложения с сохранением файла PageMaker автоматически обновит экранную копию изображения, хранящуюся в публикации, и данные о его размерах и типе.

Заметьте, что при исполнении этой команды изображение загружается не в то приложение, в котором оно было создано, а в то, которое ассоциировано с данным типом файла системой Windows. Например, художник создавал изображение в Photoshop на своем компьютере, а при выполнении команды Edit Original (Редактировать оригинал) на компьютере верстальщика этот файл может открыться, например, в программе Wang Imageln или вообще не открыться. Это говорит о том, что на компьютере верстальщика этот тип файла ассоциирован не с Photoshop, а с Imageln (при этом Photoshop может быть и установлен, а может и отсутствовать), или вообще не имеет ассоциированного приложения. В последнем случае вам будет предложено диалоговое окно, позволяющее выбрать приложение для редактирования этого типа файлов. Очень похоже на события, происходящие после двойного щелчка мышью на пиктограмме файла в Windows Explorer, не правда ли?

Команда Edit Original (Редактировать оригинал) очень удобна при работе с графикой, в то время как для редактирования текста она не используется. Дело в том, что при повторном импортировании отредактированного текстового материала утрачиваются все настройки текста, сделанные в PageMaker, т. е. вся работа верстальщика. Поскольку PageMaker не имеет средств для редактирования внешней графики, для последней эта операция абсолютно безопасна.


Графика и системный буфер обмена (Clipboard)

Импортировать графические и текстовые файлы в PageMaker можно и с помощью системного буфера обмена (Clipboard). Делается это стандартным для Windows способом: из графического приложения изображение копируется в буфер обмена командой Сору (Копировать), а затем вставляется в PageMaker командой Paste (Вклеить) из меню Edit (Редактирование). При работе с системным буфером обмена PageMaker сам пытается определить формат, в котором следует представить графическое изображение в публикации. Как правило, у него имеется выбор, и иногда очень широкий. Этот процесс настолько основательно скрыт от пользователя, что он зачастую и не задумывается о том, в каком виде представлена графическая информация, помещенная в PageMaker через буфер обмена. Несмотря на то, что все "делается само собой", иметь представление об этом очень важно для оптимизации работы и при передаче публикации в сервис-бюро.

Процессом вставки информации из системного буфера можно управлять. Для того чтобы самому выбрать формат, в котором они будут храниться, воспользуйтесь командой Paste Special (Вклеить в формате) из меню Edit (Редактирование). Предполагается, что в буфере обмена уже присутствует графика, скопированная туда из другого приложения. При выполнении этой команды выдается диалоговое окно, позволяющее выбрать формат представления данных. Как правило, первым выбором будет "родной" формат приложения, в котором был создан файл, а последним — формат WMF (мета-файл Windows). Вставленные в публикацию через системный буфер обмена изображения в "родном" формате внешнего приложения связываются с публикацией средствами OLE со всеми вытекающими преимуществами и недостатками этого метода. Прочие варианты помещают изображение, делая его частью публикации, не подлежащей редактированию и даже экспорту в ином, чем растровый, формате.

PageMaker поддерживает технологию Drag-and-Drop, т. е. изображения можно перетаскивать мышью из окна внешнего приложения в окно публикации. Эта операция является вариантом импорта через системный буфер обмена командой Paste (Вклеить) и приводит к тем же результатам.

Таким образом, использовать импорт через буфер обмена следует только в том случае, если вы действительно хотите получить OLE-связанное изображение или в дальнейшем не собираетесь его изменять.


Использование библиотек

Графические материалы можно помещать в публикацию не только из внешнего приложения, но и из палитры библиотеки. Некоторые аспекты работы с палитрой библиотеки для текстовых материалов уже обсуждались нами в гл. 6. Общие принципы работы сохраняются и для изображений. В палитру можно поместить любое, имеющееся в публикации изображение и затем вставлять его в эту же или любую другую публикацию. Поместить изображение в палитру можно, нажав пиктограмму с изображением плюса в нижней строке палитры при выделенном изображении (рис. 10.13). Элементы библиотеки отображаются в палитре в виде миниатюр, заголовков или того и другого в зависимости от выбора, сделанного в меню палитры: Display images (Показать миниатюры), Display names (Показать имена) или Display both (Показать все). После того

Рис. 10.13. Палитра Library и меню палитры

Рис. 10.14. Окно свойств элемента библиотеки

Рис. 10.15. Окно поиска по библиотеке

как изображение добавлено в библиотеку, ему можно присвоить название, автора, ключевые слова и описание. Первоначально изображение помещается в палитру с названием Untitled # (# — порядковый номер) и именем автора, совпадающим с именем пользователя, определенным в Windows, и незаполненными остальными полями. Эти данные можно изменить в любой момент, сделав двойной щелчок мышью на миниатюре элемента в палитре библиотеки (рис. 10.14). Командой Edit item after adding (Редактировать новые элементы) можно включить режим, в котором окно редактирования атрибутов элемента библиотеки открывается автоматически сразу после добавления нового изображения.

По этим атрибутам в любой момент можно осуществлять поиск. Диалог параметров поиска открывается командой Search Library (Найти элементы) из меню палитры (рис. 10.15). В нем можно задать поиск по автору, заголовку и одному или двум ключевым словам, сочетающимися основными логическими операциями: AND (и), OR (или) и XOR ("исключающее или", т. е. "не"). После запуска поиска кнопкой Search (Искать) элементы, не удовлетворяющие критериям поиска, перестанут отображаться в палитре библиотеки.

Чтобы снова включить отображение всех элементов, воспользуйтесь пунктом Show all items (Показать все элементы) меню палитры.

И наконец, ненужные элементы палитры удаляются из нее командой Remove Item (Удалить элемент) меню палитры при выделенном в палитре элементе, подлежащем удалению. Способ связывания для элементов, помещенных в палитру, сохранится (см. гл. 11).

Для создания новых библиотек и подключения альтернативных имеются команды New Library (Новая библиотека) и Open Library (Открыть библиотеку).


Масштабирование импортированных изображений

Разрабатывая дизайн макета, приходится рассматривать множество вариантов компоновки текста и графики. При этом неминуемо изменение размеров изображений. PageMaker располагает возможностью масштабирования импортированных изображений. Точное масштабирование рассмотрено в гл. 14, а сейчас мы познакомимся с масштабированием "на глазок".

Собственно изменение размера изображения выполняется точно так же, как и масштабирование графики, созданной инструментами рисования PageMaker (см. гл. 9), т. е. достаточно перетащить одну из его восьми активных точек с помощью инструмента Pointer (Стрелка). Но все-таки у импортированных изображений существуют и свои особенности. Для них наиболее важным является сохранение пропорций изображения, поэтому, если удерживать при масштабировании клавишу <Shift>, PageMaker не приводит форму изображения к квадрату, как в случае с масштабированием прямоугольников, а масштабирует его с сохранением соотношения вертикального и горизонтального размеров, т. е. пропорций (рис. 10.16).

а

б

Рис. 10.16. Масштабирование изображения с сохранением (а) и без сохранения пропорций (б)

Особого внимания заслуживают монохромные (Bitmap) растрированные изображения. Изображения этого формата, будучи уже растрированными, не подвергаются растрированию при выводе на принтер (фотонаборный автомат), а печатаются в исходном виде. Такие изображения создаются с учетом разрешения выводного, устройства таким образом, чтобы их разрешение совпадало с разрешениями, поддерживаемыми устройства вывода, или было кратно им. В противном случае растровая точка изображения может потребовать своего присутствия в том месте, где она физически не может быть напечатана принтером.

Самым простым из возможных случаев может быть такой. Монохромное изображение, созданное под максимальное разрешение принтера, уменьшается в два раза. При этом точки его растра следуют в два раза чаще, чем их может вывести принтер, что приведет к фатальному искажению растра.

Подобные же ситуации возникают при увеличении изображения в некратное число раз или его Непропорциональном искажении. Возможные варианты искажений представлены на рис. 10.17.

а

б

в

г

д

Рис. 10.17. Оригинал (а) и возможные искажения растра при неверном масштабировании растрированных монохромных изображений (б—д)

Если вам все-таки нужно изменить размеры такого изображения, делать это следует, удерживая клавишу <Ctrl>. При этом разрешение изображения изменяется на величину, кратную разрешению устройства вывода. Последнее определяется значением, проставленным в поле Target output resolution (Скомпоновать для принтера) окна Document Setup (Параметры документа), поэтому очень важно указать в нем реальное значение.


Кадрирование изображения

В PageMaker можно не только изменить размеры изображения, но и обрезать его края (рис. 10.18). Для этого предназначен инструмент Cropping Tool (Рамка) палитры инструментов.

Рис. 10.18. Кадрирование изображения

Рис. 10.19. Перемещение изображения внутри кадрирующей рамки

Кадрирование изображения сводится к заключению его в прямоугольное окно, размеры которого можно менять, не выходя за рамки размеров импортированной графики. Для кадрирования перемещайте инструментом Cropping Tool одну из активных точек изображения, как при его масштабировании. Разумеется, изображение должно быть предварительно выделено инструментом Pointer (Стрелка) или этим же инструментом Cropping Tool.

Кадрированное изображение можно перемещать внутри кадрирующей рамки, открывая различные его фрагменты (рис. 10.19). Для этого при выбранном инструменте Cropping Tool поместите курсор мыши в любое место изображения, нажмите левую кнопку мыши и, не отпуская ее, перемещайте мышь. При этом курсор примет форму руки, а изображение внутри рамки будет перемещаться. После того как вы добьетесь требуемого положения изображения внутри кадрирующей рамки, кнопку мыши можно отпустить.

Размеры кадрированного изображения можно менять точно так же, как и некадрированного. При этом сохраняют свое действие клавиши <Ctrl> и <Shift>.

Примечание

Всю обработку изображений предпочтительнее производить во внешнем редакторе растровых изображений. Чтобы избежать ошибок при выводе и не хранить в публикации лишние данные, разумно пользоваться инструментами масштабирования и кадрирования на стадии разработки макета, а когда размеры изображений будут определены окончательно, привести их к этим значениям, пользуясь внешней программой, например Photoshop.


Просмотр графики

По умолчанию, созданному разработчиками, PageMaker отображает на экране импортированную растровую графику с очень низким разрешением. Это сделано специально, для того чтобы увеличить скорость отрисовки страниц. Когда же вы закончите макетирование насыщенной графикой страницы и, откинувшись в кресле, захотите оценить плоды своих трудов в максимально близком к реальности виде, имеет смысл включить отображение страниц с высоким разрешением. Правда, если размеры файлов достаточно велики, то время отрисовки страницы позволит вам выпить кофе в соседнем кафе.

Режимы отображения графики устанавливаются в диалоговом окне Preferences (Установки). Переключатель Graphics Display (Изображения на экране), выполняющий эту функцию, имеет три положения (см. гл. 3).

Примечание

Если публикация печатается на PostScript-принтере, то разрешение экранной версии EPS-файла не играет никакой роли, поскольку печатается не она, а реальное содержимое файла. Если же публикация выводится не на PostScript-принтер, то начинает играть роль разрешение самой миниатюры EPS-файла, т. к. в данном случае именно она выводится на печать. То, что вы видите на экране, то и будет отпечатано на принтере. Поэтому важно следить, чтобы экранное изображение в этом случае также имело разрешение, достаточное для печати приличной копии на принтере. О задании разрешения миниатюры при импорте EPS изображений см. разд. "Формат EPS" данной главы.


Сжатие изображений

Как мы уже неоднократно замечали, большинство графических форматов предполагают возможность сжатия данных по алгоритмам, сходным с применяющимися в независимых архиваторах (PkZip, ARJ, ARC и др.). Причем один и тот же формат может использовать различные алгоритмы сжатия в зависимости от типа изображения и вашего пожелания. Например, формат

TIFF может использовать сжатие по алгоритмам LZW, RLE, Zip, JPEG, CCITT GrouplGroup 4 или вообще не иметь сжатия. Программа, открывающая сжатый файл, сама определяет использованный алгоритм сжатия и автоматически распаковывает файл при чтении, так что пользователь может вообще не подозревать о том, что файл сжат (упакован).

Примечание

Сжатие графических файлов не приводит к потере их качества. Исключение составляет только сжатие по алгоритму JPEG.

Обратите внимание, что сжатие графических файлов имеет смысл только для файлов, хранящихся вне публикации, т. к. внутри публикации графика всегда хранится в распакованном виде. Этот факт не обусловлен никакими объективными ограничениями, а просто "так решили разработчики". Надеемся, что в последующих версиях PageMaker это решение будет изменено.

Хотя любой графический редактор, который может сохранять файлы в формате TIFF, может одновременно производить их сжатие, PageMaker может проделать эту работу при импорте. Понадобиться эта возможность может только в том случае, если PageMaker отказывается понимать сжатые файлы, созданные в графическом приложении. Это экзотическая ситуация, но, тем не менее, рассмотрим данную функцию .

Для того чтобы сжать изображение, в процессе импортирования файла TIFF воспользуйтесь одной из комбинаций клавиш, приведенных в табл. 10.1.

Таблица 10.1. Комбинации клавиш и суффиксы имен файлов при сжатии и распаковке изображений в формате TIFF

Тип изображения | Обычное сжатие <Ctrl>+<Alt> | Максимальное сжатие <Ctrl>+<Alt>+<Shift> | Распаковка <Ctrl>*
Монохромное | _Р | _L | _U
Индексированное | _Р | _L | _U
Полутоновое и цветное | _D | _M | _U

* Если изображение уже размещено, его следует выделить.

Например, для того чтобы уплотнить с максимальным сжатием цветное изображение IMAGE.TIF, надо одновременно со щелчком на кнопке ОК диалогового окна Place (Поместить) нажать комбинацию клавиш <Ctrl>+ +<Alt>+<Shift>. В результате на диске появится файл с именем IMAGE_M.TIF, который будет сжатым. Для уплотнения TIFF-файлов используется стандартный алгоритм LZW, и созданные PageMaker файлы могут быть открыты любым приложением, работающим с растровой графикой, например Photoshop.

Для обеспечения совместимости с DOS и Windows 3.1 PageMaker создает уплотненные файлы с короткими, не более восьми символов, именами. Длинные имена файлов при этом усекаются до шести символов, а последние два занимает суффикс. Например, сильно сжатая копия RGB файла VERYLONGNAME.TIF получит имя VERYLO_M.TIF.

Примечание

PageMaker работает и с другими сжатыми форматами, но не имеет встроенных средств сжатия для них. Такие файлы должны быть предварительно сжаты во время сохранения в той программе, в которой созданы. Некоторые форматы, например JPEG, вообще не имеют распакованного вида.


Редактирование растровых изображений средствами PageMaker

Арсенал средств для редактирования растровых изображений, которыми располагает PageMaker, весьма невелик. Это возможность изменять яркость, контрастность и параметры растрирования. Такое элементарное редактирование осуществляется в диалоговом окне Image Control (Корректировка изображения), открывающемся командой Image Control (Корректировка) из вложенного меню Image (Изображение) меню Element (Элемент), при выделенном растровом изображении. Вид его представлен на рис. 10.20.

Рис. 10.20. Диалоговое окно Image Control

Функции корректировки изображений работают, к сожалению, только для монохромных и полутоновых изображений.

Изменяя положение движков Lightness (Яркость) и Contrast (Контраст), можно менять, соответственно, яркость и контрастность изображения как в сторону их уменьшения, так и увеличения. При открытии диалогового окна эти параметры установлены в 0 и 50% и могут варьироваться в пределах -100+100 и 0...100, соответственно. Для предварительного просмотра результагов корректировки без изменения параметров изображения предназначена кнопка Apply (Контроль), которую следует нажимать после каждого изменения яркости или контрастности. Вернуться к умалчиваемым значениям можно нажатием кнопки Default (По умолчанию). Когда вы будете удовлетворены результатом, щелкните на кнопке ОК, и изображение будет откорректировано. Важно, что изменения самого файла изображения при этом не происходит, поэтому вы всегда можете еще раз изменить измененные параметры изображения или вернуть их в первоначальное состояние, вызвав диалоговое окно Image Control (Корректировка изображения) и изменив параметры еще раз или нажав кнопку Default (По умолчанию).

В этом же диалоговом окне можно установить линиатуру растра, с .которой будет напечатано изображение, и угол растрирования. Эти установки работают только для PostScript-принтеров. Данные величины вводятся в поля Screen frequency (Линиатура растра) и Screen angle (Угол наклона растра), соответственно. Несмотря на имеющуюся возможность изменять параметры растрирования, мы не рекомендуем это делать, если в этом нет особой необходимости. Данные параметры лучше установить уже при печати для всех изображений одновременно в диалоговом окне Print (Печатать). Изменять параметры растрирования можно только в том случае, когда вы абсолютно твердо уверены в том, что они могут быть использованы при фотовыводе и в типографии. Например, нет смысла ставить высокие значения линиатуры, если такой растр не может быть отпечатан на купленной для печати бумаге или растрирование с такой линиатурой на фотонаборном автомате обеспечит передачу лишь десятка полутонов. Более подробно эти вопросы обсуждены в гл. 23.

Примечание

Иногда задание параметров растрирования полезно и для одиночного изображения, если оно обладает какими-либо особенностями, позволяющими повысить качество отпечатка с помощью изменения линиатуры. Например, диаграмма, в которой присутствует всего несколько оттенков серого, может быть отпечатана с более высокой линиатурой, чем фотографии в другой части публикации. И наоборот, оригинал, предназначенный для размножения на ризографе, может потребовать более грубого растра для темного изображения.


Использование фильтров Photoshop в PageMaker

Еще с версии 6.0 PageMaker поддерживает интерфейс фильтров Photoshop и в комплект его поставки включены художественные фильтры из коллекции Adobe Gallery Effects (коллекция первоначально разработана фирмой Aldus). Для их использования надо выделить изображение Инструментом Pointer (Стрелка) и выбрать команду Photoshop Effects (Эффекты Photoshop) из вложенного меню Image (Изображение) меню Element (Элемент). Эта команда меню работает только со связанными изображениями в формате TIFF.

В этом диалоговом окне следует выбрать подходящий эффект и имя файла, в котором предполагается сохранить обработанное изображение. После того как эти параметры установлены и нажата кнопка OK, PageMaker считывает файл и выводит диалоговое окно соответствующего эффекта, в котором можно установить его параметры. Далее обработанный файл записывается под указанным именем и связывается с публикацией, замещая исходный.

Преимущество, даваемое встроенными эффектами (нет нужды загружать Photoshop, затем файл), пренебрежимо по сравнению с сопутствующими неудобствами: отсутствие возможности отменить это действие, невозможность оценить результат до внесения изменений, длительное время работы (сравнимое с потраченным на запуск Photoshop), возможность применить фильтр только ко всему изображению. Единственный случай, когда такая возможность может показаться привлекательной — это использование спецэффектов и коррегирующих фильтров третьих фирм-производителей: Alien Skin (фильтры Eye Candy), KPT (Convoler), CSI (фильтры PhotoLab) и некоторые другие. Они могут, например, компенсировать отсутствие инструментов цветокоррекции для цветных изображений, обеспечить тонирование полутоновых фотографий и т. п.


Резюме

В данной главе мы уже касались вопросов связывания файлов с публикацией, но эта тема заслуживает более подробного рассмотрения. Особенно это касается совсем не упоминавшихся средств PageMaker для поддержания актуальности информации об изображениях в составе публикации, поскольку уже в процессе верстки изображения частенько приходится редактировать. PageMaker обладает развитыми средствами обновления связей, позволяющими быть уверенным, что в публикации находится версия изображения самой первой свежести.


  • Глава 11. Связывание файлов
    • Для чего используются связи?
      • Экономия места на диске
      • Удобство внесения изменений
      • Верстка в рабочих группах
    • Методы связывания
      • Почему существуют разные методы связывания?
    • PageMaker Links
      • Связывание и команда Place
      • Drag-and-Drop
      • Управление связями
      • Редактирование оригинала
      • Связывание объектов по технологии OLE
      • OLE и системный буфер обмена (Clipboard)
      • OLE и Drag-and-Drop
      • Преимущества и недостатки OLE
    • Резюме


ГЛАВА 11 .

Связывание файлов

Импортируя в документ PageMaker графическое изображение или текст, вы формируете связь — программно реализованное отношение между исходным материалом и публикацией. Связи позволяют PageMaker находить внешние файлы при отображении публикации и выводе ее на принтер, а также следить за ее версиями, обновляя сведения о них в публикации всякий раз, когда изменяется содержимое связанных файлов.

В настоящей главе обсуждаются следующие вопросы:

  • Понятие связанных файлов
  • Преимущества работы со связанными файлами
  • OLE и Links — альтернативные методы связывания
  • Управление связями


Для чего используются связи?

Говоря о связях с импортированными в публикацию файлами, мы будем почти всегда иметь в виду связи с графическими файлами. Связи с текстовыми файлами используются значительно реже, т, к. при их обновлении происходит повторный импорт в публикацию и, как следствие, — потеря настроек, выполненных средствами PageMaker.

Чаще всего, напротив, верстальщик стремится оградить сверстанный текст от автоматического обновления при изменении связанного текстового файла. Для этого он либо разрывает связь сразу после помещения материала в публикацию, либо отказывается от автоматического обновления материала.

Обработку графических файлов выполняют во внешних приложениях. Поэтому в данном случае обновление связи не приводит к потере какой-либо настройки. При обновлении связи программа сохраняет размеры, обрезку и размещение изображений в публикации.


Экономия места на диске

При импорте изображения в публикацию мы храним его на диске в двух копиях: в исходном файле и внутри публикации. Наличие исходного файла позволяет редактировать изображение и повторно использовать его в другой или в той же публикации, а вставленная в публикацию копия необходима для отображения материала в PageMaker. Полного дублирования можно избежать, если использовать механизм связей PageMaker. Он позволяет PageMaker при печати публикации пользоваться внешним файлом, а для экранного отображения использует хранящуюся в публикации миниатюру изображения. При этом экономится место на диске, равное разности размеров полного изображения и миниатюры. Если публикация предназначена для типографской печати (разрешение графических файлов около 300 точек/дюйм), то эта разница настолько велика, что размером миниатюры можно просто пренебречь.

Использование связей дает экономию места на диске и при многократном использовании одинаковых изображений. Представьте себе, что в макете 300-страничного тома документации с сотней разделов вы используете в качестве фоновой графики для заголовков разделов некую графическую подложку. Без использования связей публикация будет содержать этот графический файл в сотне копий. При размере графического файла 250 килобайт размер публикации возрастет на 25 мегабайт! В то же время, используя связи, вы можете вообще не включать графический файл в публикацию.


Удобство внесения изменений

Содержание многих изданий динамично. Например, при верстке рекламного журнала, каждая страница которого состоит из десятка рекламных модулей, часто приходится "на ходу" производить замены модулей и перестановки. Без использования связей верстальщику пришлось бы постоянно контролировать, последняя ли версия модуля находится в публикации, открывая его в той программе, где он был создан. Если, как в нашем примере, таких модулей сотни, то избежать ошибки просто невозможно.

PageMaker с помощью механизмов связывания сам следит за актуальностью ссылок на внешние файлы и автоматически обновляет их при изменении содержания этих файлов. Даже если вы не хотите целиком полагаться на PageMaker и "терять контроль" над процессом обновления публикации, PageMaker окажет большую услугу, просто показывая те связи, которые требуют обновления. Само обновление вы сможете сделать в любой момент вручную и даже выборочно.


Верстка в рабочих группах

Для выполнения сложной, срочной работы (скажем, верстка иллюстрированного журнала), как правило, организуется группа, состоящая из художников, дизайнеров, корреспондентов, фотографов, ретушеров и верстальщиков. В этом случае очень пригодится способность PageMaker поддерживать связи как между публикацией и внешними файлами иллюстраций, так и между частями публикации (см. гл. 17). Художник может неоднократно изменять вид иллюстраций, а верстальщик всегда будет использовать в макете последние их версии.


Методы связывания

У пользователей PageMaker, работающих в среде Windows, есть выбор между двумя методами связывания файлов. Один из этих типов — собственный механизм PageMaker, который носит название PageMaker Links (связи PageMaker). Связь этого типа возникает всякий раз, когда для импорта файлов используется команда Place (Поместить) меню File (Файл). В этом случае импорт осуществляется специализированными фильтрами, программами перекодировки файлов в формат PageMaker из других форматов. Иным типом связывания является стандартный для Windows механизм OLE (Object Linking and Embedding), реализуемый средствами операционной системы, а не PageMaker.


Почему существуют разные методы связывания?

Более десяти лет тому назад, когда появилась первая версия программы PageMaker и компьютеры стали использоваться в редакционно-издательской практике, не приходилось особенно беспокоиться о совместимости форматов файлов, в которых хранились данные. Теперь ситуация радикально изменилась, и издатели теперь заботятся об удобстве обмена данными практически со всем миром.

В те далекие времена больших файлов с графическими изображениями просто не существовало. Как это ни странно, но тогда никто не рассматривал всерьез идею об использовании компьютеров как инструмента для работы с цветными изображениями и уж тем более — как орудия художника-графика, творения которого потребуют огромное количество места на диске.

Но по мере того как мир вокруг нас менялся, компьютерная графика развилась в целую индустрию.

"Голь на выдумки хитра" — одним из подтверждений этого тезиса может служить появление механизма связи файлов в ранних версиях программы PageMaker. Разработчикам фирмы Aldus (которая занималась программой PageMaker до слияния с фирмой Adobe) не оставалось никакого другого выхода, как только реализовать ту или иную схему связывания файлов. Пользователи программы PageMaker работали с мегабайтовыми файлами, а в таких условиях экономия места на диске становится первостепенным фактором успеха. Именно поэтому первый механизм, реализующий связывание объектов, появился в настольной редакционно-издательской системе. Лишь намного позже, когда необходимость связывания объектов возникла и в остальных прикладных областях, появились первые разработки механизма связывания и встраивания объектов, работавшие на уровне операционной системы, а не отдельного приложения.

Теперь эти механизмы вышли из стадии экспериментов и доступны практически в любом новом приложении. В операционной среде Windows это механизм OLE, на платформе MAC — Publish/Subscribe.


PageMaker Links

Связывание и команда Place

Связи с применением PageMaker Links возникают при импорте в публикацию файлов с помощью команды Place (Поместить).

Смысл образования связи состоит в том, что в публикацию помешается не сам файл, а лишь данные о его положении на диске, имени и дате последней модификации. Разумеется, ссылка практически не занимает места в публикации. Для графических файлов это дает очень серьезный выигрыш места на диске. Для отображения файла внутри публикации используется не сам файл, а его миниатюра, копия файла с низким разрешением. Миниатюра занимает во много раз меньше места, чем исходный файл и во столько же раз быстрее перерисовывается в PageMaker при перемещениях, поворотах, масштабировании и искажении. Чтобы увидеть, как будет выглядеть изображение в макете при максимальном разрешении, допускаемом монитором, включите режим отрисовки High resolution (С высоким разрешением), и PageMaker, используя данные связывания, перерисует изображение в высоком разрешении, используя внешний файл. Впрочем, технология PageMaker Links предполагает возможность включения и полной копии внешнего файла в публикацию. Более того, место хранения изображения (в публикации или во внешнем файле) можно в любой момент изменить.

Для импорта изображения необходимо наличие подходящего фильтра. Список всех установленных фильтров (рис. 11.1) для вашей конфигурации PageMaker можно просмотреть, выбрав команду About PageMaker (О программе PageMaker) меню Help (Помощь) при нажатой клавише <Ctrl>.

Если вы работаете с приложением, для основного формата которого PageMaker не имеет фильтр импорта, попробуйте сохранить материал из внешнего приложения в нестандартном формате, но таком, который может быть импортирован PageMaker. Например, вы подготовили иллюстрацию в программе Corel Xara. PageMaker не имеет фильтра импорта файлов формата XAR, но можно воспользоваться фильтрами экспорта самой программы Хаrа, чтобы сохранить иллюстрацию в формате Adobe Illustrator (AI),

CorelDRAW Presentation Exchange (CMX) или в формате метафайла Windows. Для данных форматов PageMaker располагает фильтрами импорта. Этот непрямой путь имеет много подводных камней, особенно острых при перекодировках объектных форматов графики. Как мы уже отмечали в предыдущей главе, каждая программа подготовки иллюстраций имеет не только свой собственный формат, но и некоторые особенные возможности. В приведенном выше примере иллюстрация, будучи пересохраненной в формате Adobe Illustrator, изменит свой вид далеко не в лучшую сторону, потеряв специфические для формата прозрачности и заливки, Так что, при подготовке иллюстраций обязательно убедитесь, что PageMaker располагает фильтром импорта для формата того приложения, в котором вы их создаете. В противном случае, ни за что не используйте в иллюстрации особых эффектов, которые пропадут при конвертировании ее файлов в другой формат.

Рис. 11.1. Окно со списком установленных фильтров импорта и дополнений

Проще обстоит дело с импортом текста. Перекодировка файлов, созданных в текстовых процессорах, редко приводит к потере форматирования, да и все равно большую часть форматирования придется осуществлять в PageMaker. Фильтры для приложений, появившихся после выхода текущей версии PageMaker, можно найти на сайте фирмы Adobe в Интернете: http://www.adobe.com.


Drag-and-Drop

Технология перетаскивания мышью объектов из окна одного приложения в окно другого появилась еще в Windows 3.1, а в Windows 95 она стала неотъемлемой чертой любой сколь-либо серьезной программы. Не является исключением и PageMaker. Вы можете не только перетаскивать мышью связанные объекты из одной публикации в другую (при этом связи с внешними файлами сохраняются), но и перемещать в окно публикации объекты из других приложений. В подавляющем большинстве случаев это приводит к образованию OLE-связывания, но в некоторых случаях образуются связи типа PageMaker Links. Примером такого случая является перетаскивание пиктограмм графических файлов из папки.

Выяснить тип связи, который образуется при перетаскивании мышью, можно лишь опытным путем, т. к. он зависит не только от PageMaker, но и от внешнего приложения.


Управление связями

После того как связи созданы, может возникнуть необходимость просмотреть список связанных файлов, обновить все связи или выборочно заменить связь с одним файлом на связь с другим. Все эти возможности предоставляет технология PageMaker Links.

Для того чтобы узнать, с каким файлом связано какое-либо изображение, надо выделить его в публикации с помощью инструмента Pointer (Стрелка) и выбрать команду Link Info (Информация о связи) из меню Element (Элемент) или контекстного меню. В открывшемся диалоговом окне Link Info (Информация о связи) (рис. 11.2) отобразится информация о связи изображения с внешним файлом.

Рис. 11.2. Диалоговое окно с информацией о связи

В поле Location (Доступ) присутствует полное имя файла, включая путь, в поле Kind (Тип) указан формат и/или тип связанного файла, а в поле Size (Объем) — размер связанного файла, в полях Placed (Помещен), Document modified (Документ модифицирован), Internal copy modified (Внутренняя копия модифицирована) отображается информация о времени создания связи, последнего изменения внешнего файла и его внутренней копии.

С помощью диалогового окна Link Info можно обновить связь, если она устарела, просто нажав кнопку Open. Можно и связать другой файл с изображением в публикации. Для этого следует выбрать новый файл в окне запроса имени файла и щелкнуть на кнопке Open. После этого PageMaker прочтет новый файл и создаст миниатюру, которую включит в публикацию вместо старой. При этой операции новое изображение будет вписано в те же габаритные рамки, что и замещаемое...

На рис. 11.2 в поле Internal copy modified (Внутренняя копия модифицирована) стоит N/A — Not Available (Недоступна), т. е. внутренней копии просто нет, а связь указывает только на внешний файл. Для того чтобы определить, должна ли сохраняться копия файла внутри публикации, используйте диалоговое окно Link Options (Режим связи), открываемое одноименной командой меню Element (Элемент), или контекстное меню (рис. 11.3).

Рис. 11.3. Диалоговое окно Link Options

Флажок Store copy in publication (Хранить копию в публикации) указывает, хранить ли копию связанного файла в публикации, флажок Update automatically (Обновлять автоматически) — производить ли автоматическое обновление, а флажок Alert before updating (Предупреждать перед обновлением) — выдавать ли запрос на подтверждение обновления связи. Режим связи меняется соответственно выбору при изменении состояния этих флажков.

Примечание

Если вы сняли флажок Store copy in publication (Хранить копию в публикации), это не означает, что PageMaker сразу удалит копию связанного файла из файла публикации на диске. Более того, если переключатель Save option (Сохранение) диалогового окна Preferences (Установки) находится в своем обычном положении Faster (Быстро), даже сохранение публикации командой Save (Сохранить) не приведет к желаемому результату (см. гл. 3). Внутренняя копия связанного файла будет физически удалена из файла публикации только после выполнения команды Save As (Сохранить как). Сохранять файл при этом можно под тем же самым именем.

Когда вы приняли решение о режиме связи, разумно задать его в виде умолчания. Для этого надо открыть диалоговое окно Link Options (Режим связи), не выделяя при этом в публикации графических объектов, но при текущем инструменте Pointer (Стрелка). Откроется окно Link Options: Defaults (Режим связи по умолчанию), дающее возможность установить режим связи для вновь включаемых в публикацию текстовых и графических материалов (рис. 11.4).

Рис. 11.4. Режимы связи по умолчанию

Для текстовых материалов режим Store copy in publication (Хранить копии в публикации) всегда включен, иначе текст невозможно было бы редактировать. Остальные переключатели имеют тот же смысл, что и для изображений. Как мы уже говорили, оставлять включенным режим автоматического обновления текста очень опасно (а вдруг файл действительно кто-нибудь случайно изменит или хотя бы пересохранит?), поэтому стоит снять флажок Update automatically (Обновлять автоматически) для текстовых материалов.

Диалоговые окна Link Info (Информация о связи) и Link Options (Режим связи) предоставляют все необходимые функции для управления связями. Однако, если с публикацией связаны сотни файлов, придется открывать эти диалоговые окна для каждого изображения и проверять их содержимое. Это конечно, неудобно.

Для работы с большим числом связей используют диалоговое окно Links Manager (Связанные файлы) (рис. 11.5). Оно открывается одноименной командой меню File (Файл) и позволяет получать информацию обо всех связях в публикации и изменять их свойства.

В области просмотра окна находится список всех связанных с публикацией файлов, независимо от способа связи (PageMaker Links или OLE) и места хранения (внутри публикации или в виде внешнего файла). В окне также отображаются формат и/или тип файла, страница публикации, на которой он находится, и самое главное — информация о состоянии связи (строка состояния находится в нижней части диалогового окна). Местонахождение изображения и состояние связи обозначаются PageMak&c специальными кодами, полный список которых приведен в табл. 11.1.

Рис. 11.5. Диалоговое окно Links Manager

Таблица 11.1. Коды, используемые в диалоговом окне Links Manager

Код | Определение
UN (HM) | Связанный текстовый материал или его часть не размещены, поэтому номер страницы не определен
Имя шаблона | Связанный объект расположен на странице-шаблоне
РВ (МС) | Связанный объект расположен на монтажном столе
OV (ПП) | Связанный объект размещен в тексте, который еще не размещен в публикации
> | Документ содержит связь, установленную в версии PageMaker для Macintosh, не поддерживаемую в PageMaker для Windows
NA(H) | Связь с внешним файлом отсутствует. Объект либо перенесен в публикацию через системный буфер, либо встроен в файл публикации с помощью OLE
0 | Связь с графическим изображением в формате EPS нарушена, поскольку файл EPS содержит ссылки, которые не удалось разрешить
? | Связь нарушена, PageMaker не может найти связанный файл
+ | Внешний файл был модифицирован после последнего обновления связи. Связь будет обновлена после щелчка мышью на кнопке Update (Обновить) или Update all (Обновить все) или при следующем открытии публикации
- (минус) | Внешний файл был модифицирован после последнего обновления связи, а автоматическое обновление связи запрещено
X | Связь указывает на внешний файл, который был изменен
? перевкрнутый | Скорее всего, связанный графический объект не удастся напечатать с высоким разрешением (отсутствие связанных файлов, недоступность фильтра программы PageMaker или OLE, перенос с другой аппаратной платформы)
! | Встроенный объект был модифицирован в обеих версиях — внешней и встроенной в публикацию PageMaker. При последующем обновлении связи изменения, сделанные во встроенной версии, будут утрачены

Кроме того, с правой стороны окна находятся кнопки, позволяющие управлять связями и получать о них дополнительную информацию. Прежде чем использовать средние четыре кнопки, необходимо выбрать конкретную связь в окне слева. Для этого нужно просто щелкнуть на ней мышью. При этом строка, представляющая эту связь, будет подсвечена синим.

Кнопки Info (Информация) и Options (Режим) открывают уже знакомые нам диалоговые окна Link Info (Информация о связи) и Link Options (Режим связи). Они выглядят точно так же, как если бы вы открыли их соответствующей командой из меню Element (Элемент) при выделенном изображении.

Кнопка Unlink (Исключить) разрывает связь между изображением, находящимся в публикации, и внешним файлом. Этой кнопкой стоит воспользоваться, например, когда вы хотите оградить копию изображения, находящуюся в файле публикации, от изменений при редактировании внешнего файла или разорвать связь с текстовым файлом.

Последние две кнопки выполняют обновление информации, хранящейся в публикации о выбранном и обо всех связанных файлах, соответственно. Понадобится такое "ручное" обновление файлов может в том случае, если некоторые изображения не имеют атрибута Update automatically (Обновлять автоматически) или вы, не закрывая PageMaker, отредактировали изображение в связанном файле. Во всех остальных случаях PageMaker автоматически обновляет связи при открытии файла публикации.

Примечание

Изменив на диске местоположение файла, связанного с публикацией, вы тем самым разрываете его связь с публикацией. После того как вы заново установите связь с одним из целой группы связанных файлов, перенесенных в другую папку, программа PageMaker добавляет имя этой папки в свой список поиска и автоматически переустанавливает связи с остальными файлами группы. Если вы не хотите, чтобы связи переустанавливались автоматически, в момент щелчка мышью на кнопке ОК нажмите клавишу <Ctrl>.

Правильность и актуальность всех ссылок на внешние ффйлы публикации исключительно важна, т. к. даже нормально отображаясь на экране, публикация не будет правильно отпечатана при утере связей с внешними файлами. Если публикация-целика, то обязательно периодически заглядывайте в окно Links Manager (Связанные файлы), чтобы вовремя заметить перенесенный в другую папку или случайно стертый файл. На стадии печати PageMaker обязательно предупредит вас о том, что часть внешних файлов недоступна, открыв диалоговое окно, представленное на рис. 11.6.

Несмотря на весь сервис, предоставляемый диалоговым окном Links Manager (Связанные файлы), когда требуется изменить режим связывания для всех связанных файлов публикации, придется выбирать все файлы по очереди и переустанавливать режим для каждого из них отдельно. Инструмент Global Link Options (Глобальные параметры связи), оформленный в виде дополнения, решает подобные задачи одним махом. Для начала работы в этом окне (рис. 11.7) выберите одноименную команду подменю Plug-ins (Дополнения) меню Utilities (Сервис).

Рис. 11.6. Предупреждение об отсутствии связанных файлов

Рис. 11.7. Окно дополнения Global Link Options

Переключатели, находящиеся в этом диалоговом окне, ничем не отличаются от тех, которые вы видели в диалоговом окне Link Options Defaults (Режим связи по умолчанию), кроме верхнего, имеющего два положения — Current page (Текущая страница) и All pages (Все страницы). Данный переключатель определяет, будет ли переопределен режим связи внешних файлов для всей публикации или только для файлов, связанных с текущей ее страницей. Установите его в нужное положение и щелкните на кнопке ОК. Режим связи будет изменен для каждого уже помещенного в публикацию файла, в то время как, используя диалоговое окно Link Options Defaults (Режим связи по умолчанию), можно задать режим связи только для файлов, которые будут помещены.


Редактирование оригинала

Возможность редактировать оригинал при помощи приложения, которым он был создан, — одна из основных причин, делающих целесообразным применение связей. Закончив сеанс редактирования, сохраните исходный файл и завершите работы приложения. После этого автоматически возобновляется сеанс работы с программой PageMaker, а связь с отредактированным объектом автоматически обновляется. Рассказ об этом приеме занимает больше времени, чем его выполнение.

Просто выделите связанный объект и выберите команду Edit Original (Редактировать оригинал) меню Edit (Редактирование) или сделайте двойной щелчок на объекте при нажатой клавише <Alt>. Чтобы отредактировать связанный объект с помощью приложения, отличного от того, в котором он создавался, при выборе команды держите нажатой комбинацию клавиш <Shift>+<Alt>. Тогда перед переходом в сеанс редактирования программа PageMaker предложит вам выбрать приложение в специальном диалоговом окне. Помимо прочего, в этом окне отображается информация о том, имеется ли возможность редактирования выделенного объекта с помощью выбранного в настоящий момент в списке приложения.


Связывание объектов по технологии OLE

Связывание объектов производится с помощью команды Insert Object (Вставить объект). Она открывает диалоговое окно, представленное на рис. 11.8.

Рис. 11.8 . Диалоговое окно Insert Object в режиме Create New

Центр окна занимает список приложений, установленных на вашем компьютере и являющихся OLE-серверами. Естественно, этот список на вашем компьютере отличается от приведенного на рисунке. Переключатель слева имеет два положения: Create New (Создать новый) и Create from File

(Создать из файла). Если изображение надо еще создать или отредактировать, воспользуйтесь первым его положением. В данном случае будет открыто указанное приложение с открытым в нем пустым документом. Именно этот документ и будет вставлен в публикацию. В приложении-сервере вы можете открывать и другие документы, осуществлять копирование, вклейку и сохранение, но помните, что только один из открытых документов будет вставлен в публикацию — первый.

Примечание

При обработке файла OLE-сервером команда закрытия документа преобразуется в команду возвращения в OLE-клиентскую программу, команда сохранения заменяется на команду обновления связи, а команда сохранения под другим именем превращается в команду сохранения копии файла (рис. 11.9).

Рис. 11.9. Меню File OLE-сервера для связанного документа

После того как объект создан или отредактирован, можно вернуться в PageMaker, выполнив в приложении-сервере команду Exit and Return (Закрыть и вернуться). После того как приложение закроется, перед вами окажется публикация с выделенным внедренным OLE-объектом. Для того чтобы его отредактировать, нужно либо выбрать пункт меню Edit Original (Редактировать оригинал), либо просто сделать двойной щелчок мышью на объекте при текущем инструменте Pointer (Стрелка).

Примечание

Когда PageMaker запускает программу-сервер, он некоторое время ждет от нее ответа по протоколу OLE. Если за это время сервер не отзовется, то PageMaker решит, что он недоступен. Чтобы избежать такой проблемы, запускайте программу-сервер до того, как вы дадите PageMaker команду вставить из нее объект.

Если перевести переключатель в окне Insert Object (Вставить объект) в положение Create from File (Создать из файла), то окно примет вид, представленный на рис. 11.10.

Рис. 11.10. Окно Insert Object в режиме Create from File

Рядом с переключателем появляется строка ввода, в которую вводится имя файла, созданного внешним приложением. Напомним, что это приложение обязательно должно быть установлено и должно являться OLE-сервером. С помощью кнопки Browse (Путь) можно избежать ввода полного имени файла, выбрав его в стандартном диалоговом окне. Весьма интересен флажок Link (Связь). Его установка — это единственный в PageMaker способ создания связанного OLE-объекта. Обычно OLE-объекты никак не связаны с исходным файлом, т. е. изменение исходного файла никак не сказывается на копии объекта в публикации. Если же при создании OLE-объекта из файла установить флажок Link (Связь), созданный в публикации объект будет изменяться при изменении содержимого файла.


OLE и системный буфер обмена (Clipboard)

Другим способом внедрения OLE-объектов является их вклеивание в публикацию через системный буфер обмена. Предварительно изображение должно быть помещено туда командой Сору (Копировать) из программы-сервера. Вставлять объект в PageMaker следует не командой Paste (Вклеить), а командои Paste Special (Вклеить в формате). Использовать последнюю команду надо для того, чтобы выбрать собственный формат программы-сервера, а не тот, который выберет PageMaker. Команда Paste Special (Вклеить в формате) открывает диалоговое окно, изображенное на рис. 11.11.

В этом окне можно из предлагаемого списка выбрать собственный формат приложения-сервера. Он, как правило, находится в первой строке. После нажатия кнопки ОК в публикации появится внедренный OLE-объект. Он, как и в первом рассмотренном нами случае, не будет связан с исходным файлом, и для его редактирования следует выполнить на нем двойной щелчок мышью. При этом откроется приложение-сервер с документом, содержащим редактируемый объект.

Рис. 11.11. Диалоговое окно Paste Special

Если вклеивать изображение из буфера обмена просто командой Paste (Вклеить) или выбрать в диалоговом окне Paste Special (Вклеить в формате) формат, отличный от собственного формата программы-сервера, то OLE-объект не будет создан, а в публикации появится изображение в выбранном формате. При этом изображение будет полностью находиться в публикации, и не будет связано ни с каким внешним файлом, т. е. отредактировать его будет невозможно.


OLE и Drag-and-Drop

Простое перетаскивание изображения мышью из окна приложения-сервера в окно публикации эквивалентно вклейке через системный буфер. Разница только в том, что у вас нет контроля над форматом, в котором вклеивается изображение, т. е. вы не можете быть уверены даже в том, что перетащенное мышью изображение будет OLE-объектом. Наоборот, вероятность такого события невелика. Мы не советуем использовать такой метод импортирования объектов, поскольку полный контроль над публикацией важнее экономии нескольких секунд на открытии диалогового окна.


Преимущества и недостатки OLE

Теперь, когда мы подробно рассмотрели оба метода импорта и связывания, можно сделать выводы о недостатках и преимуществах каждого из них. Поскольку авторы являются консервативными приверженцами традиционной технологии Links и не скрывают этого факта, начнем с рассмотрения недостатков технологии OLE.

  1. Внедрение объектов OLE приводит к значительным затратам дискового пространства.

Примечание

Готовя материал для этой книги, авторы были просто поражены значительностью этих затрат. В качестве эксперимента мы поместили в две пустые публикации один и тот же довольно сложный рисунок (547 килобайт), подготовленный в Adobe Illustrator. В одну публикацию он был импортирован с помощью команды Place (Поместить), т. е. по технологии PageMaker Links, в другую — с помощью команды Insert Object (Вставить объект), т. е. по технологии OLE. Затем обе публикации были сохранены и закрыты. Первая из них занимала 125 килобайт, вторая — 6767 килобайт (т. е. в 54 раза больше!).

  2. Редактирование OLE-объекта возможно средствами только одного приложения — OLE-сервера. Если вы перенесли публикацию на компьютер, где не установлен Adobe Illustrator, то отредактировать внедренный из него в публикацию OLE-объект будет невозможно. Если же использовалась технология PageMaker Links, то внешний файл можно отредактировать любой другой программой, понимающей формат AI.
  3. Поскольку OLE работает только с графическим представлением объекта, он не может занимать в публикации более одной страницы/разворота. То, насколько серьезно это ограничение, становится очевидно при редактировании таблиц с помощью Adobe TableEditor 3.0 (см. гл. 16).
  4. Встраивание объектов требует одновременной работы и программы-сервера и программы-клиента, что требует больших затрат оперативной памяти компьютера и вашего терпения. Кроме того, объект при этом находится в оперативной памяти в трех (!) копиях: в приложении-сервере, приложении-клиенте и в буфере обмена. Если изображение достаточно велико, то нехватка памяти может привести не только к очень продолжительному времени внедрения объекта, но и к краху системы.
  5. Изображение не может быть помещено в публикацию при отсутствии программы-сервера. Если бы не существовала технология PageMaker Links, то вам пришлось бы установить на своем компьютере отдельные программы для каждого из форматов файлов, с которыми приходится работать. Фильтры же позволяют импортировать изображения и без открытия их в какой-либо другой программе.
  6. Поскольку OLE-объект должен целиком храниться в публикации, при многократном его\использовании размеры файла публикации возрастают катастрофически.
  7. OLE-объекты иногда вызывают проблемы при выводе на печать, да и время их обработки принтером (фотонаборным автоматом) существенно дольше.
  8. И наконец, "где тонко, там и рвется". По нашему опыту заметим, что публикации с внедренными объектами обладают, значительно меньшей устойчивостью к программным и аппаратным сбоям. Используя их, вы во много раз увеличиваете риск потерять всю публикацию.

Надеемся, что приведенных доводов достаточно, чтобы склонить вас к использованию технологии Links там, где это возможно. В последней оговорке заключается единственное преимущество технологии OLE: с ее помощью можно помещать в публикацию изображения в форматах, для которых не существует специализированных фильтров импорта. Впрочем, при ближайшем рассмотрении это ограничение технологии PageMaker Links не должно затруднить вашу работу благодаря огромному количеству фильтров импорта и возможности перекодировок форматов с помощью внешних приложений.

Еще раз подчеркнем, что многочисленные недостатки механизма OLE могут быть в будущем преодолены развитием этого механизма и ситуация может повернуться в его пользу. Но это дело будущего, а пока подведем небольшие итоги.


Резюме

Этой главой заканчивается рассмотрение тех "кубиков", из которых состоит публикация: текстовых материалов и изображений. Вооружившись знаниями о том, в каком виде они находятся в публикации и какие операции с ними можно производить, надо перейти к самому большому и важному разделу — верстке публикаций.


  • ЧАСТЬ IV. ВЕРСТКА
    • Глава 12. Создание новой публикации
      • Задание установок по умолчанию
      • Новая публикация
        • Разработка шаблонов страниц и модульной сетки
        • Описание документа в диалоговом окне Document Setup
      • Работа с шаблонами
        • Содержимое палитры шаблонов
        • Создание публикации на базе шаблона
        • Шаблоны-сценарии
      • Изменение параметров документа
        • Автоматическая настройка макета
        • Режим автоматической настройки макета
        • Диалоговое окно Layout Adjustment Preferences
        • Изменения элементов макета при настройке
        • Перемещение "привязанных" объектов при автоматической настройке макета
        • Нежелательные изменения параметров документа
      • Резюме


ЧАСТЬ IV.

Верстка

  • Глава 12. Создание новой публикации
  • Глава 13. Структура публикации
  • Глава 14. Компоновка текста и графики
  • Глава 15. Специальные эффекты
  • Глава 16. Верстка таблиц и бланков
  • Глава 17. Верстка книг
  • Глава 18. Электронные публикации


ГЛАВА 12.

Создание новой публикации

Процесс верстки — сбора публикации из разрозненных "кубиков" (текстовых файлов, рисунков, фотографий) — начинается с создания публикации. В настоящей главе рассматриваются следующие вопросы:

  • Задание параметров публикации
  • Шаблоны публикаций
  • Автоматическая настройка макета
  • Изменение параметров документа и его возможные последствия


Задание установок по умолчанию

Перед тем как приступать, собственно, к созданию нового документа, настройте глобальные умолчания программы в окне Preferences (Установки) и умолчания меню в соответствии с вашими привычками и особенностями публикации. Если вы зададите умолчания PageMaker в отсутствие открытых файлов, то действие их распространится на все впоследствии создаваемые публикации (глобальные умолчания). Если же вы сначала создадите документ, а потом зададите умолчания для него, то они будут действовать только на данный документ (локальные умолчания). Итак, в зависимости от того, какой уровень умолчания вы собираетесь задавать, делайте это при открытой или закрытой публикации. Общие принципы организации системы умолчаний изложены в гл. 3.

В диалоговом окне Preferences (Установки) вы сможете изменить следующие элементы интерфейса и режимы работы.

  • Единицы измерения. Если вы не имеете полиграфического образования или богатого опыта работы, то, скорее всего, это будут Миллиметры. Необходимо отметить, что вам все равно придется время от времени делать измерения в полиграфических единицах. В этом случае пригодится возможность временной замены системы единиц PageMaker (см. гл. 3). Если применяется невидимая сетка для выравнивания строк по вертикали (см. гл. 13), необходимо будет дополнительно настроить систему измерения. Это можно сделать и позже.
  • Выделение погрешностей верстки. Если предстоит окончательная верстка, обязательно активизируйте этот режим. Отслеживание дефектов верстки строк станет заметно легче. Во время предварительной верстки выделение дефектных строк является совершенно лишней информацией.
  • Разрешение графики на экране. Для начала, вероятно, есть смысл поставить стандартный режим отображения, чтобы представлять себе примерный вид публикации. Затем, когда графика размещена, замените режим на отображение плашками. При окончательной доводке можно включить режим высокого разрешения экранной графики.
  • Положение направляющих — на переднем или заднем плане рабочего пространства документа. Обычно используется первый режим, но если на странице много объектов, можно переместить направляющие на задний план, чтобы не мешали работе по размещению.
  • Режим сохранения — быстрый или компактный. В зависимости от размера свободного пространства на рабочем диске, общей устойчивости работы компьютера и степени вашей склонности к рискованным операциям устанавливается нужный режим (см. гл. 3).
  • Шаг смещения параметров объектов при нажатии на кнопки настройки управляющей палитры. Эта величина зависит от необходимой точности работы и от размера страницы публикации. Чем меньше этот размер, тем меньшее значение должно быть введено в этом поле.
  • Выравнивание по линейкам и направляющим. Часто изменяемый параметр, для начала установите данный флажок во включенное положение.
  • Предельный размер импортированного изображения, сохраняемого внутри публикации (см. гл. 3). Напомним, что чем больше результирующий файл, тем больше вероятность сбоя. Кроме того, при хранении объектов внутри публикации они дублируются. С другой стороны, при хранении внутри файла PageMaker ускоряется доступ к странице с данной графикой.
  • Преобразование кавычек из прямых в типографские. Если вы верстаете сколько-нибудь важную работу, данный режим должен быть включен.
  • Замена текста малого кегля на экране плашками. Назначение наименьшего кегля для этого режима. Вы можете и не пользоваться этим режимом, если ваш компьютер достаточно мощный, поскольку его повсеместное использование исходит не от хорошей жизни. Этот режим сильно снижает время перерисовки страницы публикации на экране. Обычно наименьший кегль, после которого текст имеет вид плашек при уменьшении масштаба, — 9 для обычных мониторов и 4—6 для больших.

Редактор материалов. Выберите кегль и гарнитуру для отображения текста в редакторе материалов. Если при верстке вы хотите видеть служебные символы и имена стилей абзацев, включите соответствующие флажки.

Примечание

Кроме умолчаний, в окне Preferences (Установки) можно задавать умолчания командами меню. При задании глобальных умолчаний это целесообразно для выбора режима размещения текста — автоматического или ручного. Дальнейшие умолчания лучше проводить в локальном режиме, после открытия документа.

Умолчания палитр. Можно задать по умолчанию палитры, которые будут впоследствии выводиться на экран сразу после открытия PageMaker, и их расположение. Работа с палитрами повышает скорость верстки, однако то, какие палитры вам понадобятся, зависит от конкретной задачи. Рекомендуем в любом случае расположить на экране палитру стилей. Если вы собираетесь пользоваться библиотекой, оставьте и ее. Палитра шаблонов нужна лишь при наличии в документе дополнительных шаблон-страниц. То же можно сказать и о палитре цветов — необходимость в ней возникает только при подготовке цветной публикации. Поскольку палитры закрывают собой часть полезного рабочего пространства, не оставляйте на экране лишних.

Умолчания текста и графики. Разработайте систему стилей для вашего документа. Об этом этапе рассказано в гл. 6. Если в публикации вы собираетесь неоднократно пользоваться инструментами рисования, введите умолчания для каждого из них. Разработайте цвета документа, хотя бы приблизительно, и тоже определите их умолчаниями. Определение умолчаний описано в гл. 3. Приемы работы с графическими объектами и команды меню Element (Элемент) рассмотрены в гл. 9.


Новая публикация

Когда вам требуется начать работу с новой публикацией, первый вопрос, который нужно решить — собираетесь ли вы создавать абсолютно новый документ, задавая все параметры с самого начала, или воспользуетесь имеющимся шаблоном документа, в котором уже определены параметры форматирования. В первом случае, вы примените команду New (Новый), во втором — откроете шаблон. Шаблоны публикаций хранятся в особой палитре-библиотеке Templates. В комплект программы входит довольно много готовых шаблонов документов, вы можете пользоваться ими (и совершенствовать по желанию) или создавать новые (см. раздУ'"Работа с шаблонами" данной главы).


Разработка шаблонов страниц и модульной сетки

Обычно на каждой странице публикации есть повторяющиеся элементы: направляющие, колонки, графика, колонтитулы, колонцифры и др. Они могут и должны быть вынесены на шаблон-страницу. В PageMaker есть возможность создавать несколько шаблон-страниц в дополнение к основной, если структура документа этого требует. Кроме того, дополнение Guide Manager (Модульная сетка) позволяет создавать модульные сетки — наборы направляющих, располагающихся под страницами документа. С помощью модульной сетки создается базовая структура страницы и обеспечивается единообразие страниц (например, одинаковое число, расположение и размеры колонок текста). Такие шаблоны можно сохранять в отдельных файлах и потом применять к любым страницам в любой публикации.

В гл. 13 подробно рассмотрены приемы построения модульной сетки и связанные с ними команды меню Layout (Макет). С помощью страницы-шаблона действие набора направляющих, размещенных на одной странице, можно распространить на последовательность смежных страниц.


Описание документа в диалоговом окне Document Setup

После того как вы определились с глобальными умолчаниями, выберите команду New (Новый) меню File (Файл). Перед вами откроется диалоговое окно Document Setup (Параметры документа), в котором и задается описание формата страницы будущего документа. Это диалоговое окно изображено на рис. 12.1.

Рис. 12.1. Диалоговое окно Document Setup

В этом диалоговом окне определяют параметры страницы публикации и режима печати. Формат страницы задается в раскрывающемся списке Page size (Формат). Если вы собираетесь верстать публикацию для распечатки на принтере, выберите размер А4 (стандартный формат для России). Если вашу публикацию предполагается печатать в типографии, то для нее нужно создать свой размер бумаги. Для этого перейдите в область численных размеров страницы Dimensions (Размер) и введите нужные значения (ширину и длину) в соответствующие поля. В списке размеров при выборе произвольных размеров страницы появляется пункт Custom (Заказной).

Примечание

Перед определением формата будущей книги обязательно узнайте требования к параметрам полосы набора в той типографии, в которой вы, возможно, будете печатать свою книгу, и точно выясните, возможна ли печать на задуманном вами формате. Бумага для печати, купленная вами, тоже имеет совершенно определенный размер, выясните, может быть, слегка изменив формат публикации, вы сможете сэкономить кучу бумаги, а то и отпечатать тираж на обрезках, оставшихся от предыдущего заказа. Таким образом вы можете сильно снизить себестоимость издания. Если речь идет о цветных публикациях, то учтите, что только за цветоделение, не считая цветопроб, каждого листа А4, в том числе и неполного, сервис-бюро возьмет в среднем 30$. Поэтому при верстке цветных изданий имеет смысл особенно тщательно подсчитывать миллиметры, это может обернуться солидной экономией.

Переключатель Orientation (Ориентация) задает расположение страницы. В положении Tall (Книжная) вертикально размещается длинная сторона страницы, в положении Wide (Альбомная) — короткая. При переключении положений числа в полях Dimensions (Размер) меняются местами.

Включенный режим Double-sided (Двусторонняя) позволяет создавать документы типа книги — с печатью на обеих сторонах бумаги. Если включить и флажок Facing pages (Разворот), то на экране будут отображены одновременно обе страницы каждого разворота, и внешний вид окна публикации будет напоминать книгу, раскрытую на определенной паре страниц.

Число страниц устанавливается в поле Number of pages (Количество страниц). Если точно известна эта цифра, проставьте ее в соответствующей строке ввода. Данное значение в любой момент легко изменить. В поле Start page# (Номер первой страницы) введите нужное значение — номер колонцифры на первой по счету странице. В публикации PageMaker может быть не более 999 страниц, но при задании арабской нумерации можно использовать числа от 1 до 9999.

Если вы собираете несколько документов в единую публикацию, например объединяете главы книги, для установки правильной нумерации страниц поставьте флажок Restart page numbering (Новая нумерация страниц) (см. гл. 17).

Примечание

Чтобы на титульном листе не было колонцифры, разместите его не там, где ему положено быть, а в конце документа. Назначьте титулу страницу-шаблон без номера страницы. Находясь в конце публикации, он не повлияет на правильность нумерации. Другой способ создания титульного листа без колонцифры — создайте для титульных листов отдельный документ без нумерации страниц. Затем для сбора публикации воспользуйтесь командой Book (Книга) (см. гл. 17).

Примечание

Комбинация клавиш <Ctrl>+<Shift>+<'> (апостроф) добавляет одну страницу в конец публикации

Данные о размере полей (т. е. расстояния от краев листа до запечатанной области (полосы набора) вводятся в область Margins (Поля), в соответствующие поля ввода: Left (Левое), Right (Правое), Тор (Верхнее), Bottom (Нижнее). Если в параметрах документа указано отображение разворота, то поля Left (Левое) и Right (Правое) заменяются на Inside (Внешнее) и Outside (Внутреннее).

Примечание

При определении внешнего и внутреннего полей не забывайте включать в них допуск на обрезку и подшивку (см. гл. 24).

В нижней части диалогового окна Document Setup указываются параметры окончательного вывода. В раскрывающемся списке Compose to printer (Скомпоновать для принтера) необходимо выбрать устройство окончательного вывода, обычно это конкретный фотонаборный автомат или принтер, на котором предполагается печатать беловой вариант публикации (при печати в типографии — пленки). Разумеется, что в списке будут указаны только устройства, драйверы которых установлены на вашем компьютере. Рядом в строке ввода Resoution (Разрешение) укажите разрешение для вывода, это число вы должны будете уточнить в сервис-бюро и типографии. Обратите внимание, что данная характеристика не зависит от назначения принтера в окне Print Document (Печатать: Документ). Указание устройств для компоновки (промежуточных оттисков) и вывода (окончательной печати) разнесено—в диалоговом окне Document Setup (Параметры документа) вы задаете разрешение устройства для вывода оригинал-макета, а в окне Print Document (Печатать: Документ) — тип принтера, на котором печатаются промежуточные копии.

Для выбора стиля нумерации страниц обратитесь к вложенному диалоговому окну Page Numbering (Нумерация страниц) (рис. 12.2), открывающемуся щелчком на кнопке Numbers (Номера) окна Document Setup (Параметры документа).

В этом окне определяют нужный стиль нумерации — арабские цифры, малые или большие римские, малые или большие литеры латинского алфавита. PageMaker нумерует литерами от А до Z страницы публикации с первой по 26 и далее сдвоенными буквами АА—ZZ страницы с 27 по 52. Если число страниц в публикации превышает 52, остальные страницы нумеруются арабскими цифрами. Если вы организуете сбор окончательной публикации из различных файлов командой Book (Книга), разные части могут иметь разную нумерацию, например в основном тексте — арабскую, в приложениях — римскую. Раздельную нумерацию страниц можно организовать, введя в поле ТОС and index prefix (Префикс) необходимое сочетание символов и установив флажок Restart page numbering (Новая нумерация страниц) в основном диалоговом окне Document Setup (Параметры документа) (см. гл. 17).

Рис. 12.2. Диалоговое окно Page Numbering

Задав все необходимые параметры, щелкните на кнопке ОК. На экране появится чистая страница нового документа. Теперь вы можете задать для него локальные умолчания, которые обсуждались в предыдущем разделе этой главы — и вперед, принимайтесь за верстку!


Работа с шаблонами

Часто в повседневной работе вам приходится создавать похожие публикации, например стандартные документы, брошюры одной и той же серии, номера журналов и т. д. В этом случае большую помощь вам может оказать комплект шаблонов на все случаи жизни. При этом не нужно специально готовить элементы вашей библиотеки шаблонов — достаточно просто не забывать сохранять публикации, оформление которых еще понадобится, в качестве шаблонов. Таким образом, после работы над документом будет оставаться заготовка для следующего такого же.

Для работы с шаблонами документов в программе есть удобная палитра Templates (Шаблоны). Открыв ее одноименной командой подменю Plug-In Palettes (Подключаемые палитры) меню Window (Окно), вы обнаружите довольно большую коллекцию готовых шаблонов. В коллекцию входят заготовки для визитных карточек, открыток, брошюр, рекламных объявлений, упаковки и пр. Использование шаблонов в любом случае ускорит работу, а если вы новичок — поможет сделать даже самума первую публикацию вполне профессиональной, лишенной грубых ошибок.


Содержимое палитры шаблонов

Основную часть палитры (рис. 12.3) занимает поле просмотра. В верхней части палитры — раскрывающийся список групп шаблонов. Выберите один из его пунктов — и в поле просмотра будут показаны миниатюры шаблонов данной группы. На рисунке выбрана группа Business cards (Визитки) и в области просмотра показаны образцы верстки визитных карточек.

Рис. 12.3. Палитра шаблонов

В комплект программы входят следующие группы шаблонов:

  • Ads (Рекламные объявления);
  • Brochures (Обложки брошюр, в основном в три сложения);
  • Business Cards (Визитки);
  • Business Sets (Деловые документы);
  • Cards (Поздравительные открытки);
  • Certificates (Сертификаты);
  • Flyers (Листовки);
  • Label Sets (Ярлыки и наклейки);
  • Menus (Меню);
  • Miscellaneous (Разные шаблоны);
  • Newsletters (Газеты);
  • Postcards (Почтовые открытки);
  • Posters (Плакаты);
  • Presentation Folders (Папки для презентаций);
  • Presentations (Презентации);
  • Programs (Программки);
  • Reports (Обложки отчетов);
  • TriPack (Шаблоны фирмы TriPack).

Для управления шаблонами служит меню палитры. Команда New Category (Создать категорию) открывает окно задания имени новой категории шаблонов (рис. 12.4). Новая категория немедленно появляется в списке палитры. Командой Delete Category (Удалить категорию) удобно воспользоваться для удаления ненужной группы шаблонов. Следует учесть, что в категориях хранятся не сами файлы шаблонов, а ссылки на них, поэтому удаление категории не приведет к удалению файлов с диска. Выбрав команду Edit Category (Редактировать категорию), вы получаете возможность переименовать активную групп шаблонов.

Щелкнув на шаблоне один раз, вы сделаете его активным. Миниатюра активного шаблона обведена рамочкой. Активизировать можно одновременно несколько шаблонов, выбрав их при нажатой клавише <Shift> или <Ctrl>.

Выбрав пункт меню Move Templates to (Переместить шаблон), вы откроете список категорий. Щелчок на одной из них переместит активный в данный момент шаблон в данную категорию. Команда Copy Templates to (Копировать шаблон) устроена также, но активный шаблон копируется в выбранную категорию.

Команда Palette Options (Свойства палитры) открывает окно выбора размера миниатюр (рис. 12.5) — можно выбрать маленькие, средние или большие образцы.

Рис. 12.4. Диалоговое окно New Category

Рис 12.5. Диалоговое окно Template Palette Options

Команда Delete Template, (или щелчок на кнопке с пиктограммой мусорной корзины) удаляет миниатюру шаблона из группы, причем делает это без дополнительного запроса. Удаляется лишь миниатюра, ссылка, сам файл шаблона с диска не исчезают.

Наконец, команда предназначена для добавления миниатюры шаблона в группу. Выбрав эту команду (или щелкнув на пиктограмме чистого листа . в нижнем правом углу палитры), вы откроете окно, показанное на рис. 12.6.

Рис. 12.6. Диалоговое окно Add a Template

В окне Add a Template (Добавить шаблон) следует ввести название для миниатюры. Затем, используя переключатель Get The Template (Определить шаблон) определите собственно файл, который будет связан с данной миниатюрой. В положении Create from the currently active document (Создать из текущего документа) программа создаст на основе активного документа файл шаблона, поместит его в ту же папку, где лежат остальные файлы шаблонов данной категории, а затем сгенерирует миниатюру для этого шаблона. Заметим, что текущий файл должен быть обязательно сохранен. В положении Add an existing PageMaker template file (Добавить готовый шаблон PageMaker) становится активной кнопка Browse (Путь). Щелкните на ней и определите путь и имя существующего файла шаблона для внесения его миниатюры в категорию. В данном случае создаются только ссылка и миниатюра, файл шаблона не копируется и никуда не переносится.

Примечание

Сохранить публикацию как шаблон можно и не прибегая к палитре Templates (Шаблоны). Для этого выберите команду Save (Сохранить) и в списке Save as type (Сохранить как тип) укажите Template (Шаблон). Созданный шаблон не будет автоматически включен в палитру.


Создание публикации на базе шаблона

Для того чтобы создать публикацию на базе шаблона, выберите подходящий шаблон из палитры и сделайте двойной щелчок на нем или щелкните на кнопке Create Publication (Создать публикацию). После этого будет создана новая безымянная публикация, содержащая все элементы выбранного шаблона. Если в шаблоне были использованы шрифты, не установленные в данный момент на вашем компьютере, PageMaker выдаст стандартное окно предупреждения о замене шрифтов (см. гл. 3).

Созданная на основе стандартного шаблона публикация, кроме собственно макета, содержит фрейм (см. гл. 15) с описанием (рис. 12.7). В описание входят: категория, название файла шаблона, описание документа (количество цветов, особенности печати и пр.), использованные шрифты, советы верстальщику по подготовке, код продукта по классификации Avery (используется для стандартных этикеток, наклеек, визиток и пр.) и категория сложности.

Рис. 12.7. Новая публикация, созданная на основе шаблона

После создания новой публикации сохраните ее под нужным именем и внесите желаемые исправления.

Примечание

Для того чтобы открыть не публикацию на основе шаблона, а сам шаблон для редактирования, выберите команду Open (Открыть) меню File (Файл). Выберите шаблон для редактирования. В нижней части окна Open (Открыть) поставьте переключатель Open As (Открыть как) в позицию Original (Оригинал).


Шаблоны-сценарии

Сценарии представляют собой небольшие программы, написанные на языке макропрограммирования PageMaker. При запуске сценария программа выполняет описанные в нем действия. Сценарии хранятся в специальной палитре Scripts (Сценарии). Для открытия этой палитры (рис. 12.8) выберите одноименную команду подменю Plug-In Palettes (Дополнительные палитры) меню Window (Окно).

Рис 12.8. Палитра Scripts

В палитре Scripts перечислено несколько групп сценариев. Щелкнув на группе, вы откроете ее. Щелкнув на любом из сценариев группы, вы запустите выполнение программы. В виде сценариев выполнены разнообразные серии команд. В настоящей версии производители программы оставили всего два шаблон-сценария — создание календаря и стилизация разворота под скрепленную пружинкой записную книжку. PageMaker имеет высокоразвитый внутренний язык программирования, открытый для пользователя. Поэтому вы, при желании, сможете научиться создавать шаблоны такого рода самостоятельно. Применение макроязыка в работе поможет вам также на всех этапах работы над публикацией — вы можете создать свой сценарий "чистки" текста (о чистке текста см. гл. 8), свои шаблоны публикаций, сценарии для размещения текста и графики, можете даже придумать средство для автоматического разверстывания висячих строк и верстки сносок и т. п. Попробуйте входящие в комплект программы сценарии самостоятельно.


Изменение параметров документа

В настоящем разделе мы рассмотрим еще один важный вопрос, связанный с параметрами документа, а именно — что случится, если в данном диалоговом окне Параметры документа (Document Setup) изменить то или иное значение. Вообще говоря, сверстанный документ — это зона неустойчивого равновесия, любые вмешательства в него, зачастую даже добавление или изъятие одного слова, могут вызвать непредсказуемые последствия для его внешнего вида. Поэтому основной принцип, которым руководствуются дизайнеры после размещения текстовых и графических объектов на страницах публикации — руками не трогать! Если вы все же решились на изменение параметров сверстанного документа, обязательно создайте резервную копию файла или сохраните документ непосредственно перед изменением параметров.

В то же время, зачастую изменение параметров документа вызвано суровой необходимостью. К тому же, жесткие ограничения на изменение параметров сковывают творчество дизайнера, не позволяют экспериментировать. Как хочется, чтобы, скажем, изменение ориентации страницы не приводило к необходимости вручную переверстывать всю публикацию. И вот, в новой версии PageMaker появился наконец подходящий инструмент. Теперь эксперименты с параметрами страницы уже готовой публикации все еще нежелательны, но возможны.


Автоматическая настройка макета

Применение режима автоматической настройки макета поможет вам изменить структуру отдельных страниц или целой публикации — размер полей, формат и ориентацию страниц, число колонок и т. д. если не в одно движение, то значительно быстрее, чем просто вручную. В режиме автоматической настройки предусмотрена коррекция расположения и размеров текстовых и графических объектов в соответствии с новыми параметрами страниц или документа. Кроме того, режим автоматической настройки макета дает возможность переоформить существующие страницы с помощью новой шаблон-страницы в автоматическом режиме (о шаблон-страницах см. гл. 13).

При оформлении макета следует обратить внимание, насколько легко его можно будет автоматически переверстать с другими параметрами страницы. При настройке макета программа PageMaker использует некоторые правила, приведенные ниже, и именно их следует учесть при верстке. В общем случае, чем более структурирован макет и чем меньшее изменение вы производите, тем точнее будет настройка. Чем больше в публикации нестандартных элементов оформления и чем сильнее отличается окончательный макет от предыдущего, тем больше ручной работы по доводке макета вам предстоит. В зависимости от исходных параметров и оформления публикации можно изменять параметры настройки, добиваясь адекватных результатов.


Режим автоматической настройки макета

Базовой характеристикой при настройке для PageMaker является относительное положение направляющих и границ колонок на странице. Положение объектов верстки вычисляется относительно направляющих, границ колонок, полей и границ страницы. То есть при изменении параметров макета сначала производится вычисление нового положения вспомогательных линий, а затем по образовавшейся сетке строится страница, на которой положение объектов относительно сетки было аналогично исходному. При этом изменениям подвергаются лишь объекты, "привязанные" к элементам сетки. Область, в пределах которой объект считается "привязанным" к направляющей или границе колонки, может быть различной и задается, как и другие параметры настройки, в окне Layout Adjustment Preferences (Установки: Настройка макета), вызываемом командой Layout Adjustment (Настройка макета) подменю Preferences (Установки) меню File (Файл). Для включения режима настройки нужно поставить флажок Layout Adjustment (Настройка макета) в диалоговых окнах, позволяющих изменять параметры публикации — Document Setup (Параметры документа), Column Guides (Границы колонок). Кроме того, настройку макета можно проводить для шаблон-страниц, в этом случае необходимо включить режим настройки в меню палитры Master Pages (Шаблоны). Программа PageMaker выполняет корректировку макета в зависимости от параметров, установленных в диалоговом окне Layout Adjustment Preferences (Установки: Настройка макета). Для иллюстрации этих правил рассмотрим приведенный на рис. 12.9 пример настройки макета страницы, проведенной при изменении ее ориентации (заданы установки по умолчанию).

До настройки макета (рис. 12.9, а):

  1. Несвязанный текстовый объект— заголовок-шапка— размещен в трех колонках.
  2. Связанные текстовые объекты размещены в колонках.
  3. Объект заходит за границу страницы на 20 мм.
  4. Иллюстрация, созданная средствами PageMaker (серый эллипс), выровнена по направляющим.
  5. Импортированное изображение выровнено по границам полей страницы и направляющим.
  6. Линейка делит страницу на две равные части.
  7. Повернутый текстовый блок (эпиграф) выровнен по границе поля.

После настройки макета (рис. 12.9, б):

  1. Ширина текстового объекта увеличена, чтобы сохранить выравнивание по границам тех же колонок.
  2. Текст переразмещен в соответствии с новыми размерами колонок.
  3. Объект перемещен, но он по-прежнему заходит за край страницы на 20 мм.
  4. Размеры иллюстрации, созданной в PageMaker, изменены без сохранения исходных пропорций; иллюстрация по-прежнему выровнена по тем же вспомогательным линиям.

а

б

Рис. 12.9. Настройка макета, проведенная при изменении ориентации с книжной (а) на альбомную (б)

  5. Импортированное изображение (логотип с человеком в лодке) перемещено, масштабировано с сохранением исходных пропорций и выровнено только по направляющим слева и справа.
  6. Линейка, как и прежде, делит страницу на две равные части (ее абсолютное расположение изменилось); вспомогательные линии, выровненные по границам колонок, переместились вместе с колонками.
  7. Повернутый текстовый блок переместился вместе с границей поля.


Диалоговое окно Layout Adjustment Preferences

Для определения параметров настройки макета выберите команду Layout Adjustment (Настройка макета) вложенного меню Preferences (Установки) меню File (Файл). Описываемое диалоговое окно изображено на рис. 12.10.

Рис. 12.10. Диалоговое окно Layout Adjustment Preferences

В этом диалоговом окне можно задать следующие характеристики.

  • Snap-to zone (Зона настройки). Строка ввода, в которой указывается размер области настройки. В ее пределах объекты считаются "привязанными" к границам страниц и вспомогательным линиям. Чем больше заданный размер, тем больше вероятность перемещения объекта вместе с границами страниц и вспомогательными линиями.
  • Группа Adjust page elements (Настройка элементов страницы), в которой можно проставить следующие флажки, в зависимости от вида исходной публикации и требований к ней:
    • OK to resize groups and imported graphics (Изменять размеры групп и импортированных изображений). Если этот режим включен, то при изменении формата страниц и ширины колонок размеры сгруппированных объектов и изображений меняются. При этом PageMaker старается разместить их аналогично исходному варианту, однако изменение размеров программа производит только параметрически, не допуская искажения пропорций;
    • Ignore object and layer locks (Игнорировать закрепление объектов и слоев). В гл. 14 мы будем обсуждать прием закрепления объектов на странице и слоев публикации. Пока лишь отметим, что закрепленный объект или слой невозможно перемещать, удалять и изменять его размеры так, чтобы корректировка влияла на объекты, закрепленные командой Lock Position (Закрепить) из меню Element (Элемент) или расположенные на закрепленных слоях; необходимо предварительно снять закрепление;
    • Ignore ruler guide alignments (Игнорировать выравнивание по направляющим). По умолчанию объекты при настройке выравниваются по всем элементам модульной сетки — направляющим, границам колонок и полей. При включенном режиме Ignore ruler guide alignments (Игнорировать выравнивание по направляющим) при корректировке учитывается выравнивание объектов только по границам колонок и полей.
  • В группе Adjust ruler guides (Настройка вспомогательных линий) выбирается режим корректирования направляющих в зависимости от требований макета:
    • Allow ruler guides to move (Разрешить смещение направляющих). При включенном режиме направляющие (в том числе и закрепленные) переразмещаются на странице, сохраняя свое положение относительно полей и границ колонок, если того требуют изменения макета. Тем самым при корректировке макета модульная сетка перестраивается соответствующим образом. В противном случае абсолютное положение направляющих остается неизменным, зато их размещение относительно страницы меняется;
    • Keep column and margin alignment (Сохранить выравнивание по границам колонок и полей). Этот флажок действует в случае, когда направляющие совпадают с границами вышеуказанных элементов. Если режим включен, то при настройке они остаются выровненными по границам колонок и полей страницы.

В следующем разделе мы более подробно обсудим изменения, происходящие в публикации при изменении тех или иных ее параметров.


Изменения элементов макета при настройке

PageMaker изменяет элементы макета различным образом, в зависимости от того, какие параметры страницы подвергаются коррекции. В табл. 12.1 приведены некоторые изменения макета и последствия их при включенном режиме автоматической настройки макета.

Таблица 12.1. Изменение параметров документа и их влияние на результат автоматической настройки

Изменяемый атрибут, способ управления им | Особенности автоматической настройки
Размер /ориентация страницы Диалоговое окно Document Setup (Параметры документа) | Поля перемещаются на новое место, но их ширина остается прежней. Ширина и высота колонок изменяются в соответствии с новыми размерами страницы. По умолчанию направляющие перемещаются таким образом, чтобы сохранилось их относительное положение на странице (например, направляющая, проходящая посередине страницы, устанавливается на середине новой страницы). В диалоговом окне Layout Adjustment Preferences (Установки: Настройка макета) существует возможность отмены редактирования направляющих, сбросив флажок Allow ruler guides to move (Разрешить смещение направляющих)
Поля Диалоговое окно Document Setup (Параметры документа) | В соответствии с новой шириной полей изменяются ширина и высота колонок. По умолчанию направляющие, совпадающие с границами колонок и полей, перемещаются вместе с ними. В диалоговом окне Layout Adjustment Preferences (Установки: Настройка макета) этот режим отменяется сбросом флажка Keep column and margin alignment (Сохранить выравнивание по границам колонок и полей)
Ширина колонки или средника (промежутка между колонками) Диалоговое окно Column Guides (Границы колонок) Диалоговое окно Master Page Options (Параметры страницы-шаблона) | Изменяется ширина всех колонок. Автоматическая настройка макета происходит только в том случае, когда размеры колонок изменяются через диалоговые окна. Если вы вручную "перетаскиваете" направляющие колонок, автоматической настройки макета не происходит. По умолчанию направляющие, совпадающие с границами колонок и полей, перемещаются вместе с ними. В диалоговом окне Layout Adjustment Preferences (Установки: Настройка макета) этот режим отменяется сбросом флажка Keep column and margin alignments (Сохранить выравнивание по границам колонок и полей)
Количество колонок Диалоговое окно Column Guides (Границы колонок) Диалоговое окно Master Page Options (Параметры страницы-шаблона) | Колонки добавляются и убираются с правой стороны страницы. Ширина всех колонок перенастраивается. Текст переразмещается во вновь образовавшихся колонках. При добавлении колонок, если в предыдущем макете последняя (самая правая) колонка содержала текстовый блок (а не фрейм), текст перетекает в новые колонки. Все объекты (кроме текста), выровненные по самой правой колонке, остаются выровненными по ней же и перемещаются вместе с ней. При удалении колонок, если в предыдущем макете самая правая колонка содержала текстовый блок (а не фрейм), этот блок исчезает, а текст материала перетекает в другой сцепленный текстовый блок. Все остальные объекты, в том числе несвязанные текстовые блоки, выровненные по самой правой колонке, остаются на своих местах относительно границ страницы


Перемещение "привязанных" объектов при автоматической настройке макета

Перемещение "привязанных" объектов вместе с их направляющими при настройке макета включено по умолчанию в диалоговом окне Layout Adjustment Preferences (Установки: Настройка макета). Для отмены привязывания объектов по направляющим при настройке поставьте соответствующий флажок — Ignore ruler guide alignments (Игнорировать выравнивание по направляющим).

Если же режим выравнивания по направляющим активен, то расположение объектов относительно вспомогательных линий после пересмотра макета зависит от количества направляющих, по которым выровнен объект.

  • Выровненные в одну сторону объекты перемещаются вместе со своей вертикальной или горизонтальной направляющей.
  • Объекты, выровненные по соседним сторонам, перемещаются вертикально или горизонтально. Это происходит для того, чтобы сохранить выравнивание по обеим сторонам по направляющим изменившейся модульной сетки.
  • Выровненные по противоположным сторонам объекты (текст и изображения) для сохранения привязки по обеим сторонам перемещаются одновременно с изменением их размеров. Это правило справедливо всегда только для объектов, созданных в программе PageMaker. Размеры групп и импортированных изображений можно изменять без искажения пропорций. Для этого задайте соответствующий параметр в диалоговом окне Layout Adjustment Preferences (Установки: Настройка макета). Размер изображения или группы при этом будет вычисляться>.,исходя из измерения, ограниченного направляющими.
  • Выровненные по трем или четырем сторонам объекты (текст и изображения, созданные в программе PageMaker) перемещаются одновременно с изменением их размеров. При этом сохраняется выравнивание по направляющим. Размеры групп и импортированных изображений изменяются пропорционально и выравниваются по левой и правой сторонам, но только если задан соответствующий параметр в диалоговом окне Layout Adjustment Preferences (Установки: Настройка макета).
  • Не выровненный по направляющим объект перемещается только при изменении формата страницы с сохранением его расположения относительно краев страницы. При этом размеры объекта не меняются.

а

б

в

г

д

е

Рис. 12.11 . Автокоррекция (верхний ряд рисунков — зона настройки объекта 1 мм, нижний ряд — зона настройки 100 мм): а — исходный объект на странице, б — коррекция полей, в — возвращение исходных параметров полей

Если объект не выровнен по направляющей, но находится близко от нее (в зоне настройки, задаваемой в строке ввода Snap-to zone (Зона настройки) в диалоговом окне Layout Adjustment Preferences (Установки: Настройка макета)), то при настройке макета объект будет выровнен по ближайшей направляющей и после изменений останется "привязан" к ней. Вид макета после настройки зависит от величины зоны настройки. Поля страницы уменьшены с 20 до 10 мм (рис. 12.11, а и б), а затем увеличены до первоначальных (рис. 12.11, в). Для объекта в верхнем ряду зона настройки была задана 1 мм, в нижнем —100 мм. В первом случае окружность не "прикреплена" ни к одному из элементов модульной сетки и при смене размера полей не подвергается никаким изменениям. Во втором случае зон'а настройки увеличена, окружность становится привязанной к границе колонки, поскольку ближе никакой направляющей нет. Если увеличить поля до первоначального, окружность не примет исходный вид, а останется "привязана" к границам колонки.


Нежелательные изменения параметров документа

Режим автоматической настройки макета способен выполнить корректировку при таких изменениях параметров публикации, которые еще в предыдущей версии вели к ужасающим последствиям для макета. Это, прежде всего, переразмещение объектов верстки при изменении размеров и ориентации страницы. Раньше этот процесс приводил к вытеснению объектов верстки из пределов страницы на монтажный стол, т. е. к полному исчезновению макета. Также крайне опасными были операции по изменению размера полей документа, в частности замена односторонней печати двусторонней и наоборот, связанная с преобразованием левого и правого полей документа во внешнее и внутреннее. В настоящей версии PageMaker автоматически настраивает макет в соответствии с изменившимися границами страницы, полями и колонками. Тем не менее некоторые операции и в этой версии PageMaker ведут к нежелательным последствиям. В табл. 12.2 представлен список этих действий и их нежелательные последствия.

Таблица 12.2. Нежелательные изменения параметров макета

Если вы измените | Возможны следующие (чаще, крайне нежелательные) последствия
Число страниц | Изменение этого значения добавляет или убирает страницы только в конце публикации. При удалении сверстанных страниц из конца документа имеется вероятность их безвозвратной утраты
Четные номера страниц на нечетные, нечетные номера страниц на четные, номер первой страницы, оборотную печать на обычную | Некоторые изменения значений в диалоговом окне Document Setup (Параметры документа) могут полностью нарушить воспроизведение графики, размещенной одновременно на двух смежных страницах (графика в разворот). Избегайте любых изменений, приводящих к превращению четных страниц в нечетные К наоборот. Если это происходит, программа PageMaker пытается сохранить привязку такого графического объекта к странице с исходно четным номером (левой в развороте). Но после изменения она становится правой в развороте (нечетный номер) и графическое изображение примерно наполовину выходит за ее правый край, на монтажный стол
Номер первой страницы (при режиме двусторонней печати) | Если публикация сверстана для режима двусторонней печати, программа PageMaker определяет, левой или правой будет страница в развороте по ее номеру. Если номер первой страницы будет изменен с четного на нечетный или наоборот, все страницы публикации поменяют свое положение в разворотах — левые станут правыми, а правые — левыми
Стиль нумерации страниц | Изменение стиля нумерации приводит к изменению вида номеров страниц. То же касается и изменения строки в поле TOС and index prefix (Префикс). В отличие от размеров полей, изменение стиля нумерации распространяется и на уже готовые страницы. Для отмены изменения достаточно восстановить прежний стиль нумерации
Разрешение окончательного вывода на печать | Изменение значения разрешения не влияет на уже размещенные черно-белые изображения, но учитывается при всех последующих изменениях размеров графики такого типа. Поэтому иногда оказывается необходимым вернуться к ранее размещенной графике и повторно выполнить параметрически ограниченное изменение ее размеров


Резюме

Из материала этой главы очевидно, что при создании новой публикации недостаточно просто нажать кнопку New (Новый). Для последующей плодотворной работы приходится в самом начале продумать множество параметров, в частности работу со стилями будущего проекта, параметры страницы, модульную сетку макета, систему умолчаний. Таким образом, для работы вам понадобится материал соответствующих глав — гл. 3, 6, 13. Не забывайте об аппарате шаблонов публикаций, который может заметно облегчить вашу работу при создании стандартных документов.


  • Глава 13. Структура публикации
    • Вспомогательные линии PageMaker
    • Модульная сетка документа
      • Границы полей
      • Границы колонок
      • Направляющие линии
      • Размещение направляющих
      • Закрепление и режим показа направляющих
      • Автоматическая установка направляющих
    • Шаблоны
      • Основной шаблон документа
      • Дополнительные шаблон-страницы
      • Выбор и применение шаблона
      • Создание и редактирование страниц-шаблонов
      • Шаблон на основе страницы публикации
      • Удаление шаблонов. Страница без шаблона
    • Стандартные элементы страницы-шаблона
      • Колонтитулы и линейки
      • Автоматическая нумерация страниц
    • Слои
      • Что представляют собой слои
      • Палитра слоев
      • Выбор активного слоя
      • Атрибуты слоя
      • Создание нового слоя
      • Удаление и объединение слоев
    • Объекты на слоях
      • Размещение объектов страницы-шаблона
      • Группы объектов
      • Выбор и операции с объектами
      • Перемещение и копирование с помощью палитры слоев
    • Настройка текста по вертикали
      • Сетка интерлиньяжа
      • Разметка линеек и создание сетки направляющих
      • Вертикальная выключка с кратными отбивками
    • Баланс колонок
    • Применение модульных сеток
      • Одноколоночные сетки
      • Двухколоночные сетки
      • Трехколоночные сетки
    • Резюме


ГЛАВА 13.

Структура публикации

В настоящей главе рассмотрены следующие вопросы:

  • Вспомогательные линии PageMaker — направляющие, границы колонок и полей
  • Модульная сетка страницы
  • Установка полей страницы
  • Задание числа и размера колонок
  • Работа с направляющими. Режимы выравнивания
  • Измерение расстояний в макете: настройка линеек и начала отсчета
  • Точное размещение направляющих
  • Слои PageMaker
  • Страницы-шаблоны
  • Баланс колонок
  • Вертикальная настройка текста
  • Применение модульных сеток

Данная глава описывает построение "скелета публикации" — модульной сетки страниц, шаблон-страниц, сетки интерлиньяжа. Затем, в процессе верстки на него будут наращиваться текстовые блоки, фреймы, графика. Построение модульной сетки можно рассматривать как наиболее творческий аспект верстки. Тщательно продуманная сетка вспомогательных линий определяет внешний вид каждой из страниц будущего документа, сообщая конечному продукту верстки необходимую целостность. Поэтому при построении модульной сетки шаблона документа постарайтесь учесть все особенности страниц публикации. Тогда вы сможете сделать шаблон достаточно гибким для любой страницы. Если же в публикации предполагается несколько типов оформления страниц, PageMaker дает возможность создавать модульную сетку и дополнительные шаблоны для разных страниц публикации. Итак, модульная сетка определяет композицию будущего документа. Если она удачна, то построенный по ней документ, даже очень скромный по графическому и шрифтовому оформлению, будет выглядеть гармонично и профессионально, а выделенные объекты (не вписывающиеся в сетку) привлекут внимание читателя. Если же модульная сетка документа разработана плохо, то в результате получится некрасивая, разваливающаяся страница, производящая впечатление неряшливой работы. Положение не спасут ни оригинальные фотографии, ни броские надписи. Напротив, будучи "не на месте" они потеряют большую часть своей выразительности.


Вспомогательные линии PageMaker

Вспомогательные линии представляют собой тонкие линии, которые не выводятся на печать, но отображаются на экране. Их положение на странице документа можно изменять. Совокупность вспомогательных линий на странице образует модульную сетку. Она используется для выравнивания и точного размещения объектов верстки. Модульная сетка любой страницы PageMaker строится из трех типов вспомогательных линий. Все они уже знакомы вам, и ниже мы лишь обобщим особенности каждого вида.

  • Границы полей. Ограничивают полосу набора страницы, обозначая поля. Границы полей — наименее подвижные из вспомогательных линий. Их вообще нельзя сдвинуть курсором, изменить их положение можно лишь, задав другие значения полей документа в странице-шаблоне. На цветном мониторе границы полей обозначаются тонкими линиями розового цвета, образующими на странице прямоугольник — полосу набора.
  • Границы колонок. Вертикальные вспомогательные линии, образующие колонки. Особое свойство границ колонок в том, что они при размещении направляют текст по образованным ими колонкам. Границы колонок можно смещать курсором, изменять их количество и положение на странице в соответствующих диалоговых окнах. Границы колонок обозначаются на цветном мониторе тонкими линиями синего цвета.
  • Направляющие. Специальные линии, произвольно располагаемые на странице. Направляющие перетаскиваются на страницу с линеек и могут быть как вертикальными, так и горизонтальными. Положение направляющих может определяться вручную или в диалоговом окне. На экране они отображаются тонкими линиями бирюзового цвета.

Все вспомогательные линии отображаются только в режиме Layout (Макет), и это вполне логично. Операции с ними также доступны только в режиме макетирования.


Модульная сетка документа

Все три типа линий образуют модульную сетку, каркас документа. На рис. 13.1 представлена модульная сетка страницы и сверстанный по ней документ.

а

б

Рис. 13.1. Модульная сетка и сверстанный по ней документ

В полиграфии каждый из элементов образовавшейся модульной сетки имеет определенное название и предназначение. На рис. 13.2 представлены следующие элементы сетки:

  1. Рубрика
  2. Заголовок
  3. Подзаголовок
  4. Поднятая буквица
  5. Элемент под обрез
  6. Окно под иллюстрацию
  7. Подрисуночная подпись
  8. Основной текст
  9. Отточие
  10. Средник
  11. Обтекающий текст
  12. Колонцифра
  13. Внутреннее поле
  14. Растрированный фон
  15. Рамка
  16. Нижнее поле
  17. Нижний колонтитул
  18. Строка продолжения
  19. Обрез страницы
  20. Внешнее поле
  21. Верхний колонтитул
  22. Верхнее поле
  23. Врезка
  24. Вставка
  25. Опущенная буквица
  26. Линейка

При подготовке издания вам придется общаться с редакторами, корректорами и работниками типографии — знание полиграфических терминов вам не повредит.

Рис. 13.2. Основные элементы страницы публикации


Границы полей

Основными вспомогательными линиями на странице являются границы полей, образующие полосу набора. Границы полей для главной страницы-шаблона определяются в диалоговом окне Document Setup (Параметры документа). Для дополнительных страниц-шаблонов границы полей задаются в диалоговом окне Master Page Options (Параметры страницы-шаблона), открываемом отдельно для каждого из шаблонов.

Если вы посмотрите на чистую страницу документа, то обнаружите, что верхняя и нижняя границы колонки отмечены розовой линией, а боковые — почему-то синей, такой же, как границы колонок. В действительности это и есть границы единственной колонки, совпадающей по размерам с полосой. Если вы ухватите синюю линию инструментом Pointer Tool (Стрелка), то можно перетащить ее на другое место страницы. При этом становится видна розовая граница поля, ранее закрытая границей колонки. Рис. 13.3 иллюстрирует эту операцию.

Рис. 13.3. Смещение границы колонки инструментом Pointer

Границы полей можно установить только для шаблон-страниц документа — основного и дополнительных. Поля для основного шаблона устанавливаются в диалоговом окне Document Setup (Параметры документа), это окно описано в гл. 12. Поля для дополнительных шаблонов задаются в диалоговом окне Master Page Options (Параметры страницы-шаблона), открываемом из палитры шаблон-страниц. О палитре шаблон-страниц рассказывается в разд. "Шаблоны" данной главы. Поля нельзя смещать вручную, но можно менять в любой момент работы над документом, обращаясь для этого к необходимым диалоговым окнам. С изменением размера полей должно изменяться и размещение текстовых и графических блоков. Этот процесс называется настройкой макета и описан в предыдущей главе.


Границы колонок

Границы колонок направляют размещаемый текст в колонку. Если при размещении текста на странице с несколькими колонками щелкнуть курсором с пиктограммой размещения текста в пределах первой колонки, текст сначала заполняет ее, затем переходит на следующую колонку и т. д. до конца страницы. При размещении текста в режиме автозаполнения следующий фрагмент размещается в первой колонке следующей страницы. Границы колонок для каждой страницы можно задавать отдельно. Для этого предназначено диалоговое окно Column Guides (Границы колонок) (рис. 13.4). Для установки положения и числа колонок в шаблон-странице документа также используется названное диалоговое окно. Колонки на шаблон-страницах задаются и в диалоговом окне Master Page Options (Параметры страницы-шаблона), рассмотренном в разд. "Шаблоны" данной главы.

Для установки числа и положения колонок перейдите на нужную страницу публикации или на шаблон-страницу (см. разд. "Шаблоны"этой главы).

Рис. 13.4. Диалоговое окно Column Guides. Задание границ колонок для обеих страниц разворота.

Выбрав нужную страницу или основной шаблон, откройте диалоговое окно Column Guides (Границы колонок) соответствующей командой меню Layout (Макет). Задайте нужное число колонок в строке ввода Number of columns (Количество колонок). В строке Space between columns (Средник) задается расстояние между колонками. В случае двусторонней печати число колонок и средник можно задавать либо для обеих полос разворота, либо для каждой страницы отдельно. На рис. 13.4, а показан вид окна со снятым флажком Set left and right pages separately (Раздельная установка для левых и правых страниц). В этом случае в полях Number of columns (Число колонок) и Space between columns (Расстояние между колонками) задают количество колонок и средники для обеих страниц разворота. Если установить названный флажок (рис. 13.4, б), появится возможность задать эти параметры отдельно для левой и правой страниц, соответственно, в полях Left (Левая) и Right (Правая).

Созданные колонки можно смещать вручную, инструментом Pointer (Стрелка). При этом смешении средник остается неизменным, как на рис. 13.5.

Если необходимо настроить макет в соответствии с изменившимися колонками или средником, установите флажок Adjust layout (Настройки макета). Изменение числа и положения колонок из диалогового окна влияет на размещение текста только в случае включенного режима настройки макета. Если колонки смещаются вручную, автоматическая настройка макета не производится.


Направляющие линии

Наиболее свободным типом вспомогательных линий являются направляющие. Они никак не влияют на размещение текста и графики, если не включен режим выравнивания по направляющим. В этом случае направляющие

Рис. 13.5. Смещение границы колонки вручную

наделяются некоторыми "магнитными" свойствами и начинают притягивать объекты, располагаемые вблизи них. Если направляющих на странице много, перемещение объектов становится скачкообразным, от одной направляющей к другой. Такой режим работы пригодится при выравнивании объектов и подробно рассмотрен в гл. 14. Режим выравнивания по направляющим включается командой меню Snap to Guides (Выровнять по направляющим) меню View (Просмотр). Если этот режим включен, соответствующий пункт меню помечен галочкой. Комбинация клавиш для включения/выключения выравнивания по направляющим — <Shift>+<Ctrl>+<;>. Переключение режима выравнивания по направляющим не оказывает никакого воздействия на уже размещенные объекты.


Размещение направляющих

Расположение направляющих может быть разным на каждой странице. Расставлять их можно вручную, перетаскивая с линеек, или с помощью дополнения модульная сетка. Направляющие можно задавать для страниц документа или для шаблон-страницы. В этом случае, прежде чем задавать направляющие, перейдите на шаблон-страницу документа. Для установки вертикальной направляющей щелкните мышью на вертикальной линейке и,

Рис. 13.6. Установка вертикальной направляющей

не отпуская левую клавишу, протащите курсор в поле страницы документа. За курсором потянется тонкая бирюзовая линия — направляющая. Ориентируясь по отметке положения курсора на горизонтальной линейке, установите направляющую в нужное место страницы. Описанная операция представлена на рис. 13.6. Аналогичным образом расставляются горизонтальные направляющие линии. На монтажном столе направляющие не отображаются.

Примечание

Прежде чем расставлять направляющие, настройте линейки на привычные единицы измерения, выберите и закрепите точку отсчета.

Для перемещения направляющей достаточно щелкнуть на ней мышью и перетащить на нужное место. Если оттащить направляющую за пределы страницы документа, она исчезнет. Если вам необходимо удалить все направляющие, расположенные на текущей странице или развороте, это можно сделать командой Clear Ruler Guides (Удалить направляющие) меню View (Просмотр).


Закрепление и режим показа направляющих

Когда направляющие (модульная сетка страницы) расставлены надлежащим образом, имеет смысл запретить их перемещение. В противном случае можно по ошибке передвинуть вместо объекта одну из тщательно установленных линий. Для закрепления направляющих существует команда Lock Guides (Закрепить направляющие) меню View (Просмотр). Если направляющие уже закреплены, рядом с этой командой стоит галочка. При включенном режиме закрепления сместить направляющую курсором становится невозможно.

Направляющие могут отображаться в двух режимах — впереди и позади объектов. Переключение этих режимов можно производить из диалогового окна Preferences (Установки). (Подробно об этом см. в гл. 3.) Кроме того, данная операция может быть выполнена командой Send Guides to Back (Направляющие назад). Если направляющие уже располагаются позади объектов, название команды меню изменяется на Bring Guides to Front (Направляющие вперед).

Часто возникает желание посмотреть на страницу публикации без вспомогательных линий, искажающих ее внешний вид. Для этого примените команду Hide Guides (Спрятать направляющие). (Подробнее см. гл. 14.)

Работа с применением направляющих линий повышает точность размещения объектов и ускоряет верстку сложных макетов. В комплект PageMaker входит великолепное средство автоматизации работы — дополнение Guide Manager (Модульная сетка). С его помощью можно легко создавать и редактировать сложные модульные сетки, состоящие из направляющих и колонок. Кроме того, вы сможете создавать библиотеки часто используемых модульных сеток. Работа в этом дополнении описана в следующем разделе.


Автоматическая установка направляющих

С помощью дополнения Grid Manager (Модульная сетка) удобно размещать на странице равноотстоящие друг от друга направляющие, создавать вертикальные и горизонтальные секции (своеобразные "псевдоколонки"), с высокой точностью устанавливать одиночные направляющие, и создавать заказные колонки. При этом вместо перетаскивания направляющих с линеек достаточно ввести значения в поля диалогового окна (рис. 13.7). Кроме того, имеется возможность сохранения модульных сеток в отдельных файлах и их загрузки.

Главное окно дополнения состоит из поля просмотра со строкой статуса, полей ввода и списков, где определяется вид создаваемой сетки и кнопок управления.

Рис. 13.7. Главное окно дополнения Grid Manager

В поле просмотра показана страница документа (или разворот, в зависимости от режима печати) с созданными в данном сеансе работы направляющими. Внизу, под изображением страницы, расположена информационная строка, в которой указывается характеристика колонки, в пределах которой находится курсор (в поле просмотра, не в документе). При двойном щелчке мышью в поле страницы открывается окно редактирования соответствующей колонки или секции направляющих (рис. 13.8). В нем можно изменять ширину колонки, высоту ряда в соответствующей строке ввода и способ выравнивания изменившейся секции относительно краев страницы.

Рис. 13.8. Окно редактирования размера колонки и ряда

Рассмотрим две группы элементов главного окна дополнения Grid Manager (Модульная сетка).

  • Define grid (Определить сетку) — группа управляющих элементов, расположенная под полем предварительного просмотра страницы. В раскрывающемся списке Guide type (Тип направляющих) выбирается тип вспомогательных линий, которые будут редактироваться. Имеется возможность редактирования числа и расположения колонок (Columns), пар направляющих (Rulers) и базовых линий (Baseline). В списке Fit to (Выровнять по) выбирается область размещения вспомогательных линий — по размеру страницы или полей. Число секций вспомогательных линий (направляющих и колонок) и средники можно задавать отдельно для каждой страницы разворота в полях ввода области Columns (Колонки), помеченных пиктограммами с изображением левой и правой страницы. В случае направляющих можно также задавать число горизонтальных секций и расстояние между ними в поле Rows.
  • Apply (Применение) — группа элементов, которая управляет режимами применения созданной модульной сетки. В списке То masters (К шаблон-страницам) выбирается шаблон-страница, к которой нужно применить данную сетку. Если модульная сетка не применяется к шаблон-странице, проставьте в этом списке значение No Master Pages (Нет).

В строке ввода То pages (К страницам) указываются страницы документа, к которым применяется модульная сетка.

  • Флажки группы Options (Режимы) управляют параметрами переноса созданных в дополнении направляющих на страницу. Предлагаются следующие режимы: Apply column guides (Применять колонки), Apply ruler guides (Применять пары направляющих), Apply baseline guides (Применять сетку направляющих), Apply independent guides (Применять независимые направляющие). Подчеркнем, что в пределах дополнения нельзя создавать независимые направляющие, для их последующего применения к шаблонам или к группе страниц направляющие необходимо предварительно скопировать в дополнение (о копировании см. ниже в этом же разделе). Установив флажок Remove existing ruler and baseline before applying (Удалять вспомогательные линии перед применением), вы зададите режим предварительного удаления всех вспомогательных линий со страницы перед установкой новых, созданных в дополнении.

Кнопка Mirror/Clone (Отразить/Дублировать) позволяет задать режим копирования созданной модульной сетки на вторую страницу разворота. Щелчок на ней открывает вложенное окно Mirror and Clone (Отражение и дублирование) (рис. 13.9) с единственным элементом управления — переключателем режима копирования. Возможны следующие режимы копирования модульной сетки:

  • Right to left with mirroring (Зеркало справа налево) и Left to right with mirroring (Зеркало слева направо) — копирование сетки, соответственно, с правой на левую и с левой на правую страницу с зеркальным отражением.
  • Right to left (Справа налево) и Left to right (слева направо) — дублирование направляющих без зеркального отражения.

Рис. 13.9. Вложенное окно Grid Maneger

В правой нижней части окна дополнения расположена группа управляющих кнопок:

  • Load grid (Загрузить сетку) — открыть для редактирования сохраненную модульную сетку;
  • Save grid (Сохранить сетку) — сохранить сетку в файл;
  • Copy guides (Скопировать направляющие) — скопировать направляющие со страницы документа для редактирования и применения средствами дополнения (окно, открываемое при щелчке на этой кнопке, показано на рис. 13.10);
  • Clear (Очистить) — удалить построенные направляющие из окна просмотра (но не со страниц документа);
  • Apply (Применить) — применить созданную модульную сетку к страницам документа без закрытия названного диалогового окна.

Рис. 13.10. Вложенное окно Copy Guides


Шаблоны

В любом документе есть элементы, повторяющиеся от страницы к странице. К таким элементам, например, относятся границы полей и колонок, сетка направляющих, колонцифры, колонтитулы, повторяющиеся графические элементы (рамки, логотипы и т. д.). Можно, конечно, расставить перечисленные элементы вручную. Если публикация велика, подобная механическая работа займет довольно много времени. Для того чтобы избежать этого, в PageMaker имеется механизм распространения действия модульной сетки и других повторяющихся элементов макета на последовательность страниц публикации — страницы-шаблоны (Master Pages). Применение страниц-шаблонов, кроме солидной экономии времени, способствует точному размещению элементов на страницах. Упрощается и внесение изменений в оформление — вместо того чтобы вручную изменять дизайн каждой страницы, можно просто внести коррективы в шаблон-страницу, и они будут переданы каждой странице публикации.

При создании шаблона учтите, что все элементы, которые вы поместите на страницу-шаблон, автоматически появятся на всех страницах публикации, связанных с ней, если, конечно, вы не запретите их отображение, отключив режим Display Master Items (Показать элементы шаблона) в меню View (Просмотр). Если в публикации есть несколько стилей оформления страниц, каждой группе можно задать свой шаблон.

Таким образом, шаблон-страницы являются носителями модульных сеток и повторяющихся элементов страницы. С помощйо шаблонов создается общий стиль документа.


Основной шаблон документа

Как уже отмечалось, в публикации PageMaker может быть использовано несколько шаблон-страниц. Основная шаблон-страница организуется автоматически при создании нового документа. Этому основному шаблону придаются атрибуты, заданные в диалоговом окне Document Setup (Параметры документа). Это формат страницы публикации, способ печати (односторонняя или разворот), поля, умалчиваемое число колонок. Первая страница вновь созданного документа по умолчанию строится по основной шаблон-странице. Действие основного шаблона распространяется на все страницы публикации. Если не указывается явно другой вариант, все вновь создаваемые страницы публикации форматируются по умолчанию в соответствии с основным шаблоном (Document Master).

При создании в публикации страниц при помощи диалогового окна команды Document Setup (Параметры документа) к новым страницам автоматически применяется основной шаблон.

При добавлении в публикацию страниц при помощи команды Insert Pages (Вставить страницы) у вас имеется возможность явным образом выбрать шаблон, который будет применяться ко вновь создаваемым страницам, но и в этом случае основной шаблон выбирается по умолчанию.


Дополнительные шаблон-страницы

В текущей публикации можно создать дополнительные шаблон-страницы. Любой странице документа можно определить любой шаблон — основной или один из дополнительных. В левом нижнем углу главного окна PageMaker

а

б

Рис. 13.11. Пиктограммы страниц-шаблонов для односторонней и двусторонней печати и соответствующие шаблоны

непосредственно перед пиктограммами пронумерованных страниц расположены пиктограммы страниц-шаблонов, описанные в гл. 1. Если документ настроен на одностороннюю печать, страница-шаблон изображается в виде одной странички, в случае двусторонней печати пиктограмма представляет собой маленький разворот (рис. 13.11). Пиктограмма дает доступ к текущему шаблону данной страницы документа.


Выбор и применение шаблона

Для того чтобы получить список всех имеющихся в публикации страниц-шаблонов, следует щелкнуть правой кнопкой мыши на пиктограмме страницы-шаблона и выбрать нужный шаблон из открывшегося списка. Он отображается на экране, и вы можете его отредактировать (см. разд. "Создание новой страницы-шаблона и редактирование шаблонов" данной главы).

Выбор и применение шаблона производятся в палитре шаблонов, которая выводится на экран командой Show Master Pages (Показать страницы-шаблоны) меню Window (Окно). Комбинация клавиш, осуществляющая эту операцию, — <Ctrl>+<Shift>+<8>. Палитра шаблонов является обычной палитрой PageMaker и содержит все стандартные элементы палитр (рис. 13.12), описанные в гл. 1.

Для того чтобы применить страницу-шаблон, щелкните на соответствующей строке в палитре. На странице публикации появится все, что вы поместили на выбранную вами шаблон-страницу.

Режим подтверждения применения шаблона пригодится при работе с документом, содержащим много страниц-шаблонов. Для его установки откройте меню палитры Master Pages (Шаблоны) щелчком на кнопке со стрелкой в правой верхней части и включите режим Prompt on Apply (Подтверждать применение). После установки этого режима PageMaker станет спрашивать подтверждение каждой операции присвоения шаблонов.

Рис. 13.12. Палитра страниц-шаблонов — главный пульт управления страницами-шаблонами

К страницам одного разворота можно применить различные шаблоны. Если при выполнении щелчка мышью на пиктограмме, расположенной слева от названия шаблона на палитре страниц-шаблонов, удерживать нажатой клавишу <Alt>, то выделенная страница-шаблон будет применена только к одной из страниц разворота. К которой из сторон будет применена страница-шаблон, зависит от того, в правой или левой стороне пиктограммы был выполнен щелчок. По пиктограммам, представленным на рис. 13.13 в левой части палитры, видно, что к левой и правой страницам разворота применены различные страницы-шаблоны.

Рис. 13.13. Применение различных страниц-шаблонов к сторонам разворота

Для быстрого применения страницы-шаблона ко многим страницам служит команда меню палитры Apply (Применить), позволяющая указать список страниц. На рис. 13.14 представлено диалоговое окно Apply Master (Применить страницу-шаблон). В нижней части диалогового окна имеется флажок Set left and right pages separately (Раздельная установка для левых и правых страниц), включающий режим раздельного применения страницы-шаблона к левым и правым страницам разворота. В поле Page range (Диапазон страниц) можно указать произвольное количество страниц. Страницы указываются тем же способом, что и в диалоговом окне Print Document (Печатать: Документ). Список составляется с помощью тире и запятых. Например, список 1-4, 6, 8- означает применение шаблона к страницам с первой по четвертую, шестой странице и всем страницам, начиная с восьмой и до конца документа. Преимущество применения шаблонов с помощью команды Apply (Применить) состоит еще и в возможности автоматической настройки макета. При простом выборе из списка шаблонов палитры настройки размещенного текста и изображений не происходит.

Рис. 13.14. Применение страницы-шаблона к нескольким страницам


Создание и редактирование страниц-шаблонов

Палитра шаблонов используется не только для применения шаблон-страниц, но и для создания новых шаблонов и редактирования уже имеющихся. Для создания и редактирования страниц-шаблонов используются диалоговые окна Master Page Options (Параметры страницы-шаблона) и New Page Options (Новая страница-шаблон). Кроме того, при создании и редактировании бывает необходимо выполнить некоторые действия непосредственно в открытом шаблоне.

Чтобы открыть это диалоговое окно для новой страницы-шаблона, выберите в меню палитры команду New Master Page (Новая страница-шаблон) или дважды щелкните на строке палитры [None] ([Без шаблона]). (Вместо двойного щелчка мышью можно выполнить одинарный с нажатой клавишей <Ctrl>.) Для создания нового шаблона можно также щелкнуть на пиктограмме внизу палитры, изображающей чистый лист бумаги. На экране раскроется диалоговое окно, представленное на рис. 13.15, с помощью которого вы сможете выполнить все основные действия по созданию страницы-шаблона. В нем совмещаются некоторые элементы управления диалоговых окон Document Setup (Параметры страницы) и Column Guides (Границы колонок) — задание полей страницы, границ колонок и средников. Если документ предполагает печать разворотов, можно задавать шаблон либо для одной страницы, либо для разворота. После задания основных характеристик шаблон-страницы в диалоговом окне щелкните на кнопке ОК. PageMaker автоматически откроет для редактирования вновь созданную страницу-шаблон, чтобы вы сразу могли ввести нужные элементы и создать модульную сетку.

Отредактировать шаблон можно и впоследствии, непосредственно перейдя на страницу-шаблон и выполнив на ней все необходимые действия. Такой способ редактирования использовался в предыдущих версиях программы PageMaker, он позволяет изменить большинство элементов страницы-шаблона: от границ колонок до номера страницы и графических объектов.

При необходимости можно отредактировать основные параметры шаблона, заданные в диалоговом окне Master Page Options (Параметры страницы-шаблона). Для этого выберите нужный шаблон в палитре и дважды щелкните мышью на соответствующей строке (или один раз нажмите клавишу <Ctrl>). Открывшееся диалоговое окно будет подобно изображенному на рис. 13.14, но в строке имени уже будет присутствовать имя редактируемого шаблона.

Установка направляющих и границ колонок на странице-шаблоне имеет свои особенности. Собственно установка ничем не отличается от таковой для страниц документа, но перенос направляющих с шаблон-страниц на страницы документа зависит от режима отображения страниц.

  • Если страницы публикации пусты, набавляющие автоматически копируются на них с шаблон-страницы.

Рис. 13.15. Диалоговое окно создания шаблон-страницы

  • Если на страницах документа уже размещены объекты, автоматическое копирование происходит в единственном случае: масштаб отображения страницы-шаблона и страницы публикации установлен в положении Fit in Window (Целая страница). При любом другом масштабе отображения автоматического копирования направляющих с шаблона не происходит.
  • При изменении направляющих и границ колонок на странице-шаблоне данные изменения передаются на страницы документа только в том случае, если эти страницы не были изменены. Страница считается измененной, если изменен ее масштаб, передвинуты границы колонок или направляющие. Для передачи изменений, выполненных на шаблоне на измененную страницу, предварительно скопируйте на нее направляющие с шаблон-страницы (это можно сделать принудительно в любой момент работы). Для этого предназначена команда Copy master guides (Скопировать направляющие шаблона) из меню Layout (Макет). Она становится доступна в случае несовпадения положения направляющих шаблона и текущей страницы и выполняется для каждой страницы документа отдельно. После ее выполнения все локально расставленные направляющие на странице автоматически удаляются и расставляются новые, такие же как на шаблон-странице. Этот прием очень удобен для восстановления стандартной модульной сетки после продолжительной работы по размещению объектов на странице, потребовавшей установки большого числа направляющих.

Сразу же по окончании редактирования на всех страницах, связанных с данным шаблоном, воспроизводятся сделанные изменения. Изменения размеров полей и колонок оказывают воздействие только на текст, размещаемый после редактирования страницы-шаблона. Для того чтобы воздействие распространилось на уже размещенные объекты, при изменении шаблона с помощью диалогового окна Master Page Options (Параметры страницы-шаблона) включите режим автоматической настройки макета. Все объекты, размещенные ранее, будут настроены в соответствии с изменившимися параметрами. При редактировании шаблона вручную настройки макета не происходит. Подробно о настройке макета см. гл. 12.

Способы редактирования шаблона из диалогового окна и непосредственного редактирования не полностью дублируют друг друга. В табл. 13.1 представлены элементы форматирования страницы-шаблона и возможность редактирования этими двумя способами.

Таблица 13.1. Возможность форматирования элементов страницы-шаблона

Элементы страницы-шаблона | Диалоговое окно | Редактирование в странице-шаблоне
Размер и ориентация страницы | Нельзя | Нельзя
Поля страницы | Можно | Нельзя
Число колонок и размер средника | Можно | Можно
Размеры колонок | Нельзя | Можно
Размещение направляющих | Нельзя | Можно
Графические и текстовые элементы | Нельзя | Можно
Автоматическая настройка макета | Есть | Нет


Шаблон на основе страницы публикации

Построить новую страницу-шаблон можно не только "с нуля", но и на основе ранее подготовленной страницы-шаблона. Для этого выберите исходный шаблон, а затем перейдите в меню палитры и задайте команду Duplicate <имя шаблона> (Создать копию <имя шаблона>). Такой прием очень удобен для быстрого создания варианта страницы-шаблона. Например, его можно использовать, если потребовалось разместить на странице журнала модуль рекламных объявлений.

Можно создать страницу-шаблон из страницы публикации — для этого служит команда меню палитры Save Page As (Сохранить страницу как). Это очень удобно, если, например, вы удачно скомпоновали страницу публикации вручную и хотите распространить ее модульную сетку и прочие элементы на другие страницы публикации. Закончите компоновку страницы, затем выберите команду Save Page As (Сохранить страницу как) и задайте имя для нового шаблона.


Удаление шаблонов. Страница без шаблона

Для удаления шаблона нужно либо воспользоваться командой меню палитры шаблонов Delete <имя шаблона> (Удалить <имя шаблона>), либо просто перетащить строку с удаляемым шаблоном к изображению мусорной корзинки внизу палитры. PageMaker запрашивает подтверждение удаления шаблона. При удалении шаблона со страниц исчезают все графические и текстовые элементы шаблона. Остаются вспомогательные линии — границы полей, колонок, направляющие.

Первая строка списка шаблонов в палитре [None] ([Без шаблона]) применяется для отмены действия каких-либо шаблонов на текущую страницу. Для того чтобы страница перестала соответствовать шаблону, выполните щелчок мыши на строке [None] ([Без шаблона]) списка палитры. Элементы шаблона будут удалены со страницы. В зависимости от того, какие клавиши были нажаты в момент выполнения щелчка мышью, результаты действия могут быть различными:

  • Просто щелчок удаляет со страницы публикации все элементы страницы-шаблона, оставляя границы колонок и направляющие.
  • Щелчок при нажатой клавише <Shift> удаляет все — объекты, границы колонок, направляющие.
  • Щелчок при нажатых клавишах <Alt>+<Shift> удаляет все, кроме направляющих.
  • Если вы хотите, чтобы вспомогательные линии и элементы были удалены только с одной из страниц разворота, при выполнении описанных выше приемов удерживайте нажатой клавишу <Аlt> и выполняйте щелчок мышью на пиктограмме страницы напротив строки [None] ([Без шаблона]). В результате на пиктограмме появится буква R или L, указывающая, какая из двух страниц разворота затрагивается изменениями (правая или левая).
  • Комбинация клавиш <Ctrl>+<Shift> удаляет все, кроме границ колонок. Этот прием всегда воздействует на обе страницы разворота.

Размер полей является исключением. В результате отмены действия шаблона полоса набора остается такой же, какой она была определена в соответствующем шаблоне. Если ее нужно изменить, создайте на основе изменяемой страницы временный шаблон и измените его поля в диалоговом окне Master Page Options (Параметры страницы-шаблона), затем удалите временный шаблон.


Стандартные элементы страницы-шаблона

Построение страницы-шаблона обычно начинается с формирования модульной сетки. После того как полностью определились положения всех вспомогательных линий, можно приступить к размещению стандартных элементов на странице-шаблоне. На рис. 13.16 представлены верхний и нижний колонтитулы, колонцифра (номер страницы) и верхняя линейка (линия, выделяющая страницу сверху) — некоторые из элементов, обычно размещаемых на странице-шаблоне.

Рис. 13.16. Стандартные элементы страницы-шаблона, размещенные на своих местах по модульной сетке


Колонтитулы и линейки

В верхней части рис. 13.16 расположены линейка и верхний колонтитул, которые переходят со страницы-шаблона на все страницы публикации. Обычно ширина линейки составляет 8 пунктов. В состав верхнего колонтитула, как правило, входят название книги и заголовок верхнего уровня. Линейка и колонтитул размещаются в верхней части всех страниц публикации, и их введение в состав страницы-шаблона экономит много времени и позволяет обеспечить единообразие. Представьте себе, каково было бы размещать эти элементы вручную на всех 600 страницах книги — лучше даже не думать об этом и сразу воспользоваться услугами страницы-шаблона. Можно также предусмотреть отдельные колонтитулы для колонок в пределах границ колонки. В программе PageMaker можнадюльзоваться дополнительными страницами-шаблонами и можно предусмотреть все варианты верст-

ки, сопоставив каждому свою страницу-шаблон. Например, одна страница-шаблон может соответствовать внутренним страницам глав с набором в две колонки, линейкой и колонтитулом, другая — с линейкой и колонтитулом другой структуры и одной колонкой для верстки оглавления и т. д.


Автоматическая нумерация страниц

Размещаемые на странице-шаблоне колонтитулы технически представляют собой обычный текстовый материал. Постройте на странице-шаблоне текстовый блок. Установите внутри текстового блока точку вставки и нажмите комбинацию клавиш <Ctrl>+<Shift>+<3> — в тексте появится символ колонцифры, представленный на рис. 13.17. (Поскольку пример взят из публикации с оборотной печатью, этот символ выглядит как LM (ЛШ), указывающий, что данная колонцифра размещена на левой странице разворота страницы-шаблона.) Колонцифру можно разместить на любой странице публикации, но обычно ее размещают на странице-шаблоне. Возможно, перед колонцифрой должен появиться префикс (номер раздела или главы), введенный в соответствующее поле диалогового окна параметров публикации при ее создании. Это — важный момент, поскольку данный префикс не вставляется перед колонцифрой автоматически, его необходимо ввести с клавиатуры. Позаботьтесь о том, чтобы это был тот же префикс, что и в диалоговом окне параметров, иначе номера, напечатанные на страницах, не будут соответствовать номерам в предметном указателе и оглавлении.

Рис. 13.17. Символ колонцифры в нижнем колонтитуле левой стороны страницы-шаблона


Слои

Слои применяются в подавляющем большинстве программ для иллюстрирования, обработки изображений и верстки. Их можно сравнить с листами прозрачной пленки, сложенными в стопку друг на друга. Вы можете видеть сквозь слой другие слои (непрозрачные объекты, расположенные на слое, могут закрывать частично или полностью объекты нижних слоев). В растровых графических процессорах слои используют для организации псевдообъектной структуры изображения. Фрагменты, находящиеся на разных слоях, можно свободно передвигать, искажать, применять к ним различные эффекты. При этом воздействие будет ограничено только данным "объектом", остальные части изображения останутся незатронутыми. Таким образом, на порядок упрощается редактирование растровой графики, особенно компоновка текста с графикой и изготовление коллажей. Слои применяются и в объектных графических процессорах для редактирования сложных изображений, для упрощения работы с многократно наложенными изображениями, для организации сложных систем вспомогательных линий, ремарок и т. д.

В программах верстки, таких как PageMaker, слои выполняют сходные функции. Они дают возможность создавать и редактировать отдельные объекты публикации независимо от других объектов. Слои можно применить во многих случаях сложных макетов. Например, разместив текст на одном слое, а изображения — на другом, вы можете временно сделать слой с изображениями невидимым, что значительно облегчит работу с текстом. При создании публикаций, имеющих несколько языковых версий, слои предоставляют удобный способ размещения каждого варианта перевода на отдельном слое. При наличии наложенных объектов удобно помещать различные их группы на разных слоях с целью упорядочения.


Что представляют собой слои

Слои — это части документа PageMaker, имеющие следующие особенности.

  • Каждый слой существует на всех страницах документа, в том числе на страницах-шаблонах. Слои могут быть видимыми или невидимыми на экране и редактируемыми или закрепленными.
  • На слоях могут находиться любые объекты верстки, кроме вспомогательных линий, образующих отдельный слой, свойства которого здесь не обсуждаются.
  • Слои документа накладываются друг на друга. Для каждого документа можно задать любое количество и порядок следования слоев. Порядок наложения слоев можно свободно менять. Слои можно создавать, переименовывать и удалять.
  • По умолчанию все новые публикации, а также публикации, созданные в более ранних версиях программы PageMaker, состоят из единственного слоя с именем [Default] ([Базовый слой]), который можно перемещать относительно других слоев, но нельзя ни удалить, ни переименовать.
  • В любой момент в публикации есть активный или целевой слой, на котором и размещаются все вновь созданные в документе объекты. Одновременно может быть активен только один слой.
  • Объекты можно переносить и копировать с одного слоя на другой по определенным правилам.


Палитра слоев

Все операции со слоями производятся с понршью одного инструмента — палитры Layers (Слои). Она используется для создания, редактирования, закрепления и удаления слоев. В палитре находятся элементы управления атрибутами отдельных слоев. С ее помощью определяется порядок их взаимного наложения. Наконец, палитра слоев служит и для перемещения объектов между слоями.

Чтобы открыть палитру Layers (Слои), выберите команду Show layers (Показать слои) меню Window (Окно). Комбинация клавиш для вызова палитры слоев — <Ctrl>+<8>. На экране появится палитра, изображенная на рис. 13.18. О принципах работы и об элементах стандартной палитры можно прочитать в гл. 1.

Рис. 13.18. Палитра слоев с открытым меню


Выбор активного слоя

Активный (целевой) слой публикации — это тот слой, на котором будут создаваться и редактироваться объекты. Для выбора целевого слоя щелкните мышью на его названии в палитре слоев. Как видно из рисунка, целевой слой при этом выделяется в палитре подсветкой; в строке активного слоя появляется значок "карандаш". В нижней части палитры приводится короткая справка об активном слое. Если выбрать объект на странице, то слой, на котором он находится, автоматически станет целевым. Справа от имени слоя при этом появляется цветная точка. На рис. 13.18 активным является слой Layer 3 (Слой 3).


Атрибуты слоя

В палитре слоев в каждой строке указаны атрибуты слоя в виде пиктограмм (рис. 13.19). Если вы щелкните дважды на строке любого слоя, откроется окно Layer Options (Параметры слоя) (рис. 13.20), в котором также указаны эти атрибуты. В диалоговое окно параметров можно войти и командой меню палитры Layer Options (Параметры слоя). Меню палитры Layers (Слои) изображено на рис. 13.18.

Атрибуты слоя можно изменять в этом диалоговом окне. Некоторые из них можно менять и непосредственно в строке палитры.

Рис. 13.19. Пиктограммы атрибутов слоя

Рис. 13.20. Окно параметров слоя

Каждый из слоев документа может иметь следующие атрибуты.

  • Имя слоя. Оно задается при его создании и показано в средней части строки слоя в палитре. В окне свойств слоя можно изменить его имя. СлоиБазовый слой, имяБазовый слой публикации нельзя переименовать.
  • Видимость/Невидимость. Индикатор видимости слоя представляет собой пиктограмму в крайнем столбце палитры слева от имени слоя. Если на кнопке есть изображение глаза, слой виден на экране. Невидимый слой нельзя отредактировать и напечатать. Чтобы сделать слой видимым или невидимым, щелкните мышью на пиктограмме видимости. Появившийся значок "глаз" будет указывать на то, что слой является видимым. Щелкните мышью еще раз, чтобы спрятать значок и сделать слой невидимым. Данный режим отображения можно изменить и в диалоговом окне Layer Options (Параметры слоя), используя флажок Show layer (Показать слой) в нижней части окна.

Примечание

Если протащить курсор через несколько строк вверх или вниз по палитре, режим отображения всех слоев, через строки которых прошел курсор, изменится также, как для того слоя, с которого вы начали протаскивание.

Примечание

Чтобы сделать невидимыми все слои, кроме выбранных, выделите в палитре один или несколько слоев, которые вы хотите оставить на экране, затем выберите из меню палитры Layers (Слои) команду Hide Others (Спрятать остальные) либо нажмите клавишу <Alt> и щелкните мышью на любом значке "глаз".

Если необходимо отменить невидимость для всех слоев документа, выберите из меню палитры Layers (Слои) команду Show All (Показать все) либо нажмите клавишу <Alt> и щелкните мышью в первом столбце палитры напротив имени любого из слоев.

Обратите внимание на то, что атрибуты слоя существуют одновременно для всех страниц документа. Поэтому, если, находясь на странице 4, вы сделали слой 1 невидимым, объекты, относящиеся к нему, станут невидимыми не только на стр. 4, но и на остальных страницах документа.

  • Закрепленность/Незакрепленность. Объекты, расположенные на закрепленных слоях, не могут быть выделены или отредактированы. Таким образом, имеет смысл закрепить слой по окончании редактирования находящихся на нем объектов. Если на странице много мелких или перекрывающихся объектов, можно временно вынести те из них, которые пока не нужно редактировать, на отдельный слой и закрепить его. В противном случае иногда бывает очень трудно выбрать редактируемый объект из "кучи" на странице.

Наличие закрепления отображается на кнопке во втором слева столбце напротив имени слоя пиктограммой с изображением перечеркнутого карандаша. Если на этом месте нет пиктограммы, значит, слой не закреплен.

Чтобы закрепить слой или отменить его закрепление, щелкните мышью на кнопке закрепления. На ней появится "перечеркнутый карандаш" — слой закреплен. Щелкните мышью еще раз, чтобы убрать значок и отменить закрепление слоя. Чтобы задать или отменить закрепление нескольких слоев, вы должны протащить курсор через несколько строк вверх или вниз по палитре. В диалоговом окне Layer Options (Параметры слоя) режим закрепления переключается флажком Lock layer (Закрепить слой). Если флажок установлен, слой закреплен.

Чтобы закрепить все слои, кроме одного (целевого), отмените закрепление всех слоев и щелкните мышью на имени нужного слоя. Затем войдите в меню палитры Layers (Слои) и выберите команду Lock Others (Закрепить остальные) или нажмите клавишу <АН> и щелкните мышью во втором столбце палитры напротив имени любого слоя.

Чтобы отменить закрепление всех слоев, выберите из меню палитры Layers (Слои) команду Unlock All (Освободить все) либо нажмите клавишу <Alt> и щелкните мышью на значке "перечеркнутый карандаш" слева от имени любого слоя.

  • Цвет (вспомогательный атрибут). Задав для каждого слоя документа собственный цвет, вы можете легко определять, на каком слое расположен тот или иной выделенный объект. При выделении объекта его маркеры-ограничители окрашиваются в цвет, назначенный соответствующему слою. Цвет слоя отображается слева от имени в палитре Layers (Слой). Цвет меняют в окне свойств слоя.
  • Расположение относительно других слоев. Как уже отмечалось в этом разделе выше, слои можно представить как прозрачные пленки, содержащие объекты верстки и наложенные один на другой. В такой виртуальной стопке, как и в реальной, будет определенный порядок наложения слоев.

    Разумеется, при этом объекты, расположенные на слоях, будут перекрываться в соответствии с расположением слоев, т. е. объекты верхнего слоя будут перекрывать объекты нижнего. Наложение объектов, расположенных на разных слоях, иллюстрирует рис. 13.21.

Рис. 13.21. Наложение объектов, находящихся на разных слоях

а

б

в

г

Рис. 13.22. Изменение порядка наложения объектов при перестановке слоя

Порядок наложения слоев в вашем документе может быть произвольным. В палитре Layers (Слои) отображаются все слои документа; самому верхнему из которых соответствует верхняя строка палитры.

В любой момент можно изменить данный порядок. Для этого с помощью мыши переместите слой по палитре Layers (Слои) на новое место. При удержании клавиши <Ctrl> можно выделить одновременно несколько слоев, а затем переместить их одновременно на новую позицию. При этом взаимное расположение перемещенных слоев будет сохранено.

После изменения порядка следования слоев изменится порядок наложения объектов, на них находящихся (рис. 13.22, а — до изменения, б — после).

Напомним, что атрибуты слоя едины для всех страниц документа, поэтому при изменении порядка слоев перекрывание объектов изменится на всех страницах, где есть объекты, расположенные на затронутых перестановкой слоях.


Создание нового слоя

Для создания слоя щелкните на пиктограмме чистой страницы внизу палитры слоев или выберите команду New Layer (Новый слой) меню палитры. Окно New Layer (Новый слой) позволяет задать свойства нового слоя (рис. 13.23) — имя, цвет, невидимость и закрепление. Впоследствии все эти атрибуты легко могут быть изменены.

Рис. 13.23. Окно создания нового слоя


Удаление и объединение слоев

Поскольку каждый слой существует на всех страницах публикации, а не только на одной определенной странице, рекомендуем вам перед удалением слоя сделать все остальные слои невидимыми и просмотреть каждую страницу публикации. Это позволит вам увидеть все объекты, которые вы собираетесь удалить.

Чтобы удалить слой, выделите имя слоя в палитре и выберите из меню палитры команду Delete <имя слоя> (Удалить слой <имя слояУ). Вместо выбора команды удаления можно щелкнуть мышью на значке "мусорная корзинка" в нижней части палитры или просто перетащить удаляемый слой к значку "мусорная корзинка". PageMaker откроет диалоговое окно Delete Layer (Удалить слой), в котором необходимо уточнить, как именно вы собираетесь удалять ненужный слой. В предложенном окне выберите один из следующих вариантов:

  • Вариант Move items to (Перенести элементы на) позволяет вам указать имя слоя, на который будут перемещены все объекты с удаляемого слоя. Результат этой команды показан схемой на рис. 13.24, а.

    Это действие, как и все действия со слоями, распространяется на все страницы и может изменить порядок наложения объектов в публикации. Рекомендуем вам тщательно проверить все страницы после объединения слоев, выполненного данным способом.

  • Вариант Delete items on all pages from layer(s) (Удалить элементы слоя со всех страниц) приводит к удалению всех объектов на указанном слое со всех страниц публикации, как показано в схеме на рис. 13.24, б.

а

б

Рис. 13.24. Удаление слоев: а — в режиме Move items to, б— в режиме Delete items on all pages from layer(s)

Если вы абсолютно уверены, что на данном слое ничего полезного нет, PageMaker дает, возможность быстро удалить выделенный слой со всеми объектами (без открытия диалогового окна Delete Layer (Удалить слой)). Для этого при удалении слоя любым из описанных способов держите нажатой клавишу <Alt>.

Если в публикации накопилось много слоев, имеет смысл удалить пустые, т. е. не содержащие никаких объектов. Можно, конечно, сделать это вручную, однако в таком случае велик шанс потерять данные — может оказаться, что на считавшемся пустым слое по ошибкё-размещены объекты, и при быстром удалении они пропадут. При автоматическом же удалении пустых слоев программа сама анализирует наличие объектов на слоях и удаляет только те, которые действительно являются пустыми.

Автоматическое удаление пустых слоев производится командой Delete Unused Layers (Удалить пустые слои) меню палитры слоев. В открывшемся диалоговом окне PageMaker предложит подтвердить удаление первого из пустых слоев. В зависимости от вашего решения щелкните на кнопке Yes (Да) для подтверждения удаления или No (Нет) — для отмены удаления данного слоя. PageMaker предложит подобное окно запроса для каждого из удаляемых файлов. Чтобы удалить пустые слои без лишних запросов, нажмите кнопку Yes to all (Да для всех). Кнопка No to all (He для всех) отменяет операцию удаления. Для быстрого удаления пустых слоев без запроса подтверждения выберите команду меню Delete Unused Layers (Удалить пустые слои) с нажатой клавишей <Alt>.

При работе вы можете создать временные слои. По окончании работы с временными слоями их нужно либо удалить, либо объединить с основными слоями публикации. Это необходимо для упорядочения структуры публикации и снижения вероятности ошибки программы из-за избыточной сложности документа.

Для объединения слоев используется команда Merge Layers (Объединить слои) из меню палитры. Перед тем как выбрать эту команду из меню, выберите в палитре слои, которые вы собираетесь объединять. Для выделения нескольких слоев при выборе держите нажатой клавишу <Ctrl>. Слой, который был выделен первым, становится целевым. Объекты будут перемещены на него с остальных слоев. Все остальные выделенные слои будут удалены из публикации.


Объекты на слоях

Объекты могут располагаться либо на одном слое, либо на разных. В пределах одного слоя объекты размещаются в соответствии с порядком наложения. Если объекты расположены на разных слоях, то дополнительно к наложению объектов на странице присутствует наложение слоев. Один или несколько объектов можно выделять, вырезать, копировать и вклеивать независимо от того, находятся они на одном слое или на разных.


Размещение объектов страницы-шаблона

На странице-шаблоне, как и на любой странице документа, имеются все созданные слои. На любом из них вы можете расположить объекты страницы-шаблона. Однако вне зависимости от расположения слоя, на котором вы разместите объекты шаблона, на страницах публикации все они будут отображаться позади объектов, находящихся непосредственно на страницах. Это удивительное правило иллюстрируется схемой рис. 13.25.

а

б

в

г

Рис. 13.25. Шаблон-страница и страница документа. Взаимное расположение объектов на слоях


Группы объектов

Группа объектов всегда располагается на одном слое. Если вы выделите несколько объектов на разных слоях и объедините их в группу, все объекты будут перенесены на верхний из задействованных слоев. Эта команда не отменяется. Если непосредственно после группировки нажать комбинацию клавиш <Ctrl>+<Z>, группа распадется на отдельные объекты, но все они останутся на одном слое.


Выбор и операции с объектами

Если на активном слое выделить объект, то справа от имени слоя, на котором он расположен, появится цветная точка. После перехода на другой слой выделение объекта не снимается.

Вы можете выделить любое число объектов, находящихся на разных слоях, теми же способами, какие описаны в гл. 9 для выделения объектов одного слоя. Выделив, вы можете скопировать или вырезать данные объекты, а затем вклеить их на нужное место. Также вы можете переносить объекты с одного слоя на другой.

Результат вклеивания объектов из буфера обмена с помощью команды Paste (Вклеить) зависит от состояния переключателя Paste Remembers Layering (Вклеивать на прежние слои) меню палитры слоев. Если он активен (помечен птичкой), все объекты вклеиваются на свои исходные слои, если не активен — на целевой слой.

Эта закономерность распространяется и на перенос объектов со страницы на страницу. Так, если со слоя 3 первой страницы документа был скопирован объект и его необходимо вклеить на тот же слой страницы 2, активизируйте команду-переключатель Paste Remembers Layering (Вклеивать на прежние слои). В противном случае объект будет вклеен на активный слой страницы 2.


Перемещение и копирование с помощью палитры слоев

Перемещать и копировать объекты с одного слоя на другой удобно с помощью палитры Layers (Слои). Для этого используется индикатор выделения объектов на строках палитры (цветные точки рядом с именем слоя).

Выделите нужные объекты. В палитре слоев справа от имени слоя, содержащего выделенные объекты, появится цветная точка — индикатор наличия выделения. Щелкните на ней мышью и перетащите к тому слою, на который вы хотите переместить выделенные объекты. Если вы выделили объекты, расположенные на разных слоях, выполните эту операцию для всех задействованных слоев.

Для копирования объектов между слоями при перетаскивании индикатора держите нажатой клавишу <Ctrl>.


Настройка текста по вертикали

Одним из требований качества публикации является выравнивание строк в колонках и на страницах. На рис. 13.26, а представлен текст двух смежных колонок, выровненный по базовым линиям строк. Базовые линии помечены тонкими серыми штрихами. Такое выравнивание в идеальном варианте текста осуществляется автоматически, поскольку все строки текста имеют одинаковую высоту. Таким образом, если выровнять верхние границы текстовых блоков — первые строки, все остальные должны лечь на одном уровне. К сожалению, в реальном тексте такое размещение не получается само собой. В результате действия разных факторов происходит смещение строк текста относительно друг друга. Пример такого смещения показан на рис. 13.26, б.

Ниже перечислены параметры документа, изменение любого из них может привести к смещению строк в смежных колонках.

  • Кегль
  • Интерлиньяж
  • Отбивки перед абзацами и после них
  • Линии перед абзацами и после них
  • Вложенная в текст графика
  • Кегль и интерлиньяж стиля форматирования абзацев основного текста

Перед верстальщиком встает задача добиться правильности вертикальной выключки. При большом объеме документа эта работа может занять недели, а при каждом изменении макета придется перепроверять выравнивание текста.

а

б

Рис. 13.26. Нормальное выравнивание текста (а). Смещение базовых линий строк в смежных колонках (б)

Частично можно автоматизировать процесс вертикальной настройки текста, используя сетку интерлиньяжа и режимы выравнивания программы PageMaker по направляющим и линейкам.


Сетка интерлиньяжа

Текстовый материал внутри блоков выравнивается по сетке интерлиньяжа. Это последовательность горизонтальных линий, первая из которых проводится по верхнему краю текстового блока, а последующие размещаются на равном расстоянии друг от друга с определенным шагом, задаваемым произвольно. Если текст выровнен по сетке интерлиньяжа, базовые линии строк совпадают с линиями сетки. Именно таким образом и достигается вертикальное выравнивание.

Сетка интерлиньяжа невидима. Для ее установки откройте диалоговое окно Paragraph Specifications (Параметры абзаца), щелкните на кнопке Rules Линейки), а затем— на кнопке Options (Свойства). В открывшемся окне Paragraph Rules Options (Свойства линеек абзаца) и находится поле Grid Size Шаг сетки). Задайте в этом поле число, кратное интерлиньяжу основного текста.

Для того чтобы выровнять по установленной сетке текст абзаца, следующего за данным, установите флажок Align next paragraph to grid (Выровнять следующий абзац по сетке). Базовая линия первой строки следующего абзаца принудительно совмещается с ближайшей линией невидимой сетки.

Рис. 13.27. Элементы управления сеткой интерлиньяжа в управляющей палитре

Флажок также присутствует на управляющей палитре в режиме Paragraph (Абзац) (рис. 13.27). В строке ввода задается размер сетки интерлиньяжа в пунктах, а кнопки под строкой ввода включают/выключают режим выравнивания.

Невидимая сетка отсчитывается от верхней границы текстового блока. Поэтому нет никакого смысла пользоваться выравниванием по базовым линиям, если верхние границы колонок или смежных текстовых блоков не выровнены по одной линии. Проще всего это сделать, установив режим Snap То Rulers (Выровнять по линейкам) меню View (Вид).


Разметка линеек и создание сетки направляющих

При выравнивании текста по вертикали рекомендуем разметить в соответствии с сеткой интерлиньяжа вертикальную линейку. Для этого откройте с помощью одноименной команды диалоговое окно Preferences (Установки) и установите заказную разметку вертикальной линейки с шагом, равным значению интерлиньяжа (в нашем примере 12 пунктов). На рис. 13.28 представлен фрагмент заказной разметки вертикальной линейки, в которой основные деления отстоят друг от друга на 12 пунктов (оцифровка линейки соответствует расстоянию в основных делениях от начала отсчета). Основные деления указывают расположение линий сетки, по которым выравниваются базовые линии текста. Они разбиты более мелкими вспомогательными на три равные части. Подчеркнем, что линии сетки невидимы и показаны на рисунке лишь для вящей доходчивости.

Рис. 13.28. Заказная разметка вертикальной линейки

Для того чтобы вам было проще отслеживать результаты работы по выравниванию, авторы рекомендуют установить сетку базовых линий с помощью дополнения Grid Manager (Модульная сетка). Шаг сетки базовых линий установите таким же, как и шаг сетки интерлиньяжа. В результате страница покроется сеткой горизонтальных направляющих. Поместите их позади объектов командой Send Guides to Back (Направляющие назад), чтобы случайно не сдвинуть. Можно также блокировать доступ к направляющим командой Lock Guides (Закрепить направляющие).

Примечание

Задайте режим выравнивания по сетке для всех стилей абзацев, отличающихся по вертикальным размерам от основного текста. Если это так, попробуйте уменьшить или отменить отбивку в стиле абзаца или только в данном абзаце. Может помочь соблюдение принципа кратности интерлиньяжу, хотя бы локально для абзаца. Если текст разбит на множество рубрик с заголовками и подзаголовками, то добиться вертикального выравнивания в нем очень сложно. В некоторых случаях можно уменьшить вдвое сетку интерлиньяжа. Тогда отбивки станут больше соответствовать стилям, а абзацы текста в соседних колонках будут либо выровнены, либо смещены на половину интерлиньяжа относительно друг друга. Это все же лучше, чем совсем не структурированный текст...


Вертикальная выключка с кратными отбивками

В случае очень простой верстки (основной текст с однострочными заголовками одного уровня вложенности) используют выключку с кратными отбивками. Это очень просто: все вертикальные размеры должны быть кратны интерлиньяжу основного текста. Тогда выключка по вертикали будет автоматической, без применения специальных режимов.

Прежде чем задавать размеры текста, отрегулируйте соотношение кегля и интерлиньяжа основного текста. Если впоследствии кегль или интерлиньяж изменятся, отбивки могут стать неподходящими. Мы будем рассматривать пример для интерлиньяжа 12 пунктов (кегль 10). Размер всех строк текста, включая интерлиньяж, отбивки и т. д., должен быть кратен 12 пунктам. Пример текста, отформатированного таким образом, приведен на рис. 13.29.

Обратите внимание на интерлиньяж заголовка (12) в примере (а) — он меньше кегля (16). При наличии двух и более строк в заголовке такой интерлиньяж непригоден. Альтернативой является задание интерлиньяжа 24 (пример (б)), но в этом случае расстояние между строками заголовка излишне велико. Можно также вводить отбивки до и после заголовка, но результирующая строка с отбивками тоже должна быть кратна интерлиньяжу. На рис. 13.29, в показан вариант установки кратных отбивок.

Метод вертикальной выключки с использованием кратных размеров не требует дополнительного выравнивания текста по вертикали (за исключением случая, когда использована отбивка перед заголовком, а данный заголовок находится вверху колонки), но о творческом подходё-к верстке при таком методе говорить не приходится. Тем не менее кратнрсть вертикальных

Рис. 13.29. Варианты оформления текста с кратными вертикальными размерами

размеров интерлиньяжу в разумных пределах используется при верстке. Так, за основу построения сетки интерлиньяжа (Grid) действительно берется интерлиньяж основного текста. Если абзацы основного текста набраны с отбивками, они в большинстве случаев составляют половину интерлиньяжа. Тогда смещение абзацев происходит регулярно, т. е. все нечетные абзацы выровнены, все четные смещены. При этом сохраняется четкость размещения текста в колонках.


Баланс колонок

Если публикация оформлена в несколько колонок (например, журнал), в идеальном случае колонки должны быть приведены к одинаковой длине. Некоторую помощь в этом непростом деле может оказать диалоговое окно одноименного дополнения Balance columns (Баланс колонок), запускающееся одноименной командой вложенного меню Plug-ins (Дополнения) меню Utilities (Сервис). Диалоговое окно этого дополнения представлено на рис. 13.30.

Рис. 13.30. Диалоговое окно дополнения Balance columns

Выделите колонки, которые следует сбалансировать, при помощи инструмента Pointer (Стрелка). Для того чтобы выровнять верхний или нижний край выделенных колонок, щелкните мышью на соответствующей желаемому варианту пиктограмме. Как правило, выравниваются нижние края колонок.

Если вы хотите, чтобы остаточные строки были размещены в левой колонке, щелкните мышью на левой нижней пиктограмме. Если эти строки следует разместить в правой колонке, щелкните мышью на правой нижней пиктограмме.

После щелчка мышью на кнопке ОК дополнение определяет длины всех выделенных колонок и вычисляет их среднее арифметическое. Затем предпринимается попытка сверстать все выделенные колонки по этой длине. Правда, вертикальная выключка с увеличением интерлиньяжа при этом не производится — все ограничивается делением строк, содержащихся во всех колонках, поровну. Результат почти всегда требует дополнительной настройки, но после отработки дополнения ее выполнить проще, чем "с нуля". Все атрибуты абзацев, управляющие следованием текста (выравнивание по сетке, устранение висячих строк), имеют приоритет перед действиями дополнения Balance columns (Баланс колонок).


Применение модульных сеток

После рассмотрения основы любого документа — модульной сетки и элементов структуры (шаблонов и слоев документа) не будет лишним кратко остановиться на применении всех этих знаний на практике.

В заключение приведены примеры использования модульных сеток и структурированных документов при организации публикаций разного размера, стиля и назначения.


Одноколоночные сетки

Чем меньше колонок расположено на странице, тем легче работать с сеткой. В простом одноколоночном макете работа дизайнера часто вовсе не видна. Простота стиля присуща официальным документам (рис. 13.31), публикациям для распространения внутри фирмы, многостраничным документам — книгам и журналам. В то же время и одноколоночная сетка может быть основой привлекательного макета. Обратите внимание на присутствие горизонтальной структуры в некоторых сетках. Горизонтальное выравнивание элементов для одноколоночных сеток не всегда необходимо, но с увеличением числа колонок горизонтальная структура модульной сетки имеет все большее значение для гармонизации расположения объектов верстки.

Официальный документ (рис. 13.31). Большие поля и широкий интерлиньяж делают эту страницу хорошо читаемой. Строгий шрифт (Verdana, Arial, Helvetica, sans-serif) сочетается с текстом. Горизонтальные линии вверху и внизу страницы структурируют публикацию. Такие линии создают иллюзию неизменности макета при изменении объема текста между ними. Текст выключен по формату, поэтому страница выглядит строгой и уравновешенной. Расположение логотипа и заголовка можно свободно менять. Формат стандартный для документов — А4.

Свободный интерлиньяж и короткие строки основного текста (рис. 13.32) способствуют легкости чтения — ведь на странице размещена рекламная информация, и ваша цель — донести ее даже до самого занятого читателя.

Элементарная сетка публикации с широкими полями показана на рис. 13.33. Текст левой страницы набран шрифтом Futuris крупного кегля, белым и песочным цветом на черном фоне, выравнивание отсутствует. В правой части приглашения шрифт коричневый и выдержан в классическом духе (Академия), но текст набран шрифтом пяти различных кеглей с расширенным интерлиньяжем. Подложкой служит тонированная в песочный цвет фотография мебельного гарнитура. Таким образом, коричневая гамма объединяет

Рис. 13.31. Трудовой договор фирмы

Рис. 13.32. Рекламный листок, посвященный обзорной экскурсии по Петербургу

Рис. 13.33. Пригласительный билет на выставку мебели

две противоположных тенденции дизайна — классический и авангардный. Традиции качества и современный дизайн — что может быть важнее?!

Как вы могли убедиться, макет красив, когда в нем есть "воздух" — широкие поля, просторный интерлиньяж. Шрифт для одноколоночных макетов не должен быть слишком мелким, т. к. длинные строки неудобочитаемы.


Двухколоночные сетки

Двухколоночные сетки позволяют создать более сложный и элегантный макет, но и верстка в них сложнее. Они удобны для оформления самых разных изданий — журналов, справочников, каталогов и т. д. (рис. 13.34, а и б). Расположение текста в двух колонках позволяет набирать мелким кеглем на большом формате, что очень важно для многостраничных публикаций. Двух-колоночный макет более экономичен, чем одноколоночный за счет уменьшения кегля и интерлиньяжа. Страница обычно выглядит более темной и плотной. Однако и здесь важно не перегружать страницу материалом, не сужать до предела поля и средники, не уменьшать интерлиньяж с целью "впихнуть" еще пару абзацев. Такой уплотненный макет будет производить впечатление нехватки бумаги и, как следствие, безуспешности вашей фирмы.

Рис. 13.34. Рассказ, помещенный в журнале

Два этих документа (рис. 13.44) оформлены по единой сетке, текст размещен в них весьма экономно. Свободное пространство в верхней части страницы и очень простой дизайн позволяют сделать узкие поля и средник. Первый пример (рассказ) должен быть легко читаемым и неофициальным. Поэтому текст выровнен по левому краю (страница при этом становится светлее). Фотография обтекается текстом, слегка повернута, как будто она просто лежит на странице. Это придает материалу убедительность (здесь напечатан биографический очерк). Шрифт в заголовке аналогичен шрифтовому логотипу группы. Во втором примере дизайн страницы предельно экономичен и функционален. Текст словно свисает с линии под заголовком. Переменная высота колонок позволяет упростить верстку. Все детали макета ориентированы на легкость чтения. Шрифт Academy создает впечатление старого документа или книги.

Пример утонченного и холодного дизайна— рис. 13.35. Здесь и речи нет о симпатии к читателю. Все: и абстрактный рисунок на авантитуле, и расположение теста, и шрифт — направлено на удивление и подавление зрителя. Расположение текста по горизонтальным и вертикальным осям устанавливает равновесие всех текстовых элементов на странице. Мелкий кегль основного текста усиливает впечатление отстраненной элегантности.

Рис. 13.35. Авантитул и титульный лист отчета о работе научной лаборатории

Не правда ли, остроумное решение представлено на рис. 13.36? Расположение текста и фотографий подчеркивает, с одной стороны, факт соавторства этих людей, а с другой — обособляет каждого из них как отдельную личность.

Рис. 13.36. Биографии соавторов из предисловия к книге


Трехколоночные сетки

Этот тип сеток весьма распространен в полиграфии. Печать в три, колонки незаменима при верстке публикаций большого формата — журналов, каталогов и т. д. Популярность трехколоночных сеток вызвана тем, что они обеспечивают большую свободу маневра, позволяя размещать иллюстрации, врезки, небольшие рекламные объявления в пределах одной, двух, трех колонок. Для трехколоночной сетки обязательна горизонтальная структура страницы. Как правило, она определяется параметрами преобладающего шрифта — в каждую ячейку сетки должно помещаться определенное целое число строк. Горизонтальное структурирование страницы весьма облегчает работу дизайнера.

Пример горизонтально-ориентированной публикации показан на рис. 13.37. В ней основную линию образует ряд строго выровненных по сетке фотографий. Подписи под ними расположены на одном уровне и выполнены шрифтом Verdana, Arial, Helvetica, sans-serif, легким для чтения и строгим. Однако комментарии к рисункам имеют разную длину и выровнены по левому краю. Эта особенность верстки, а также сочные цвета иллюстраций придают публикации неформальный вид. Широкое нижнее поле разлиновано легкими светло-серыми линиями и предназначено для записей по ходу работы. Ясная последовательность изложения и мелкий, но легко читаемый шрифт, поля для записи, цветной обрез страницы, пружинный переплет и плотная бумага свидетельствуют о том, что перед нами образец учебного пособия, предназначенного для частого использования учащимся.

Рис. 13.37. Страница из учебного пособия по PhotoShop (разворот)

На рис. 13.38 представлена страница из научно-популярного журнала. Выровненный по формату текст, строгий шрифт, скромный иллюстративный материал, простые рамки, черно-белое цветовое решение — все это свидетельствует о некоторой академичности издания. Элементы оформления — рамки, графические выделения заголовков, выворотные колонтитулы и колонцифры — повторяются от страницы к странице. Заголовок несколько увеличен и набран Bodoni Condensed, шрифтом изящным и строгим. Осветленный рисунок Российского герба во врезке (его фрагмент повторен в оформлении заголовка) несколько оживляет дизайн страницы и подчеркивает тематику статьи.

Особенность документа, представленного на рис. 13.39, — смешанная сетка, организующая элементы публикации по степени важности для читателя. Текст, набранный в одну колонку, образует шапку. Он имеет теплый коричнево-золотистый цвет; фразы набраны крупным кеглем и интерлиньяжем и будут прочитаны первыми. В этом фрагменте текста помещены наиболее привлекательные моменты предвыборной программы кандидата. Выравнивание по формату упорядочило текст. Мелкий текст набран темно-зеленым; он содержит биографию кандидата и другую информацию. Фотография помещена в соответствии с модульной сеткой. Общее впечатление — доступность и надежность.

Кроме вышеперечисленных, в газетах, журналах и буклетах встречаются многоколоночные сетки. Многоколоночные сетки допускают изменения в оформлении внутри одной и той же публикации и позволяют применять графические элементы разных размеров. Они хорошо подходят для документов, содержащих много мелких материалов — рубрик, заметок и т. д. Заметку из 30 слов сложно разместить в однок6*лоночном макете, она будет выглядеть куцей. В узкой же колонке малый материал образует вполне приличный столбик текста. Для узких колонок выбирайте шрифт малого кегля, но удобочитаемый. Ест строка состоит из двух-трех слов, следите, чтобы не было лишних переносов. Узкие колонки трудно выравнивать по формату, приходится все время следить, чтобы не было жидких строк. Равный край также будет менее ровным, чем в широкой колонке. Многоколоночные стеки требуют значительного внимания, т. к. вам все время нужно будет принимать различные решения при макетировании. Большая свобода действий по размещению объектов должна ограничиваться соображениями равновесия и пропорциональности.

Рис. 13.38. Статья из научно-популярного журнала

Рис. 13.39. Предвыборная листовка


Резюме

Мы закончили рассмотрение элементов структуры документа — модульных сеток, шаблонов, слоев. С помощью развитой системы структурирования публикации вы сможете в значительной степени ускорить и совершенствовать работу над своими проектами. Приведенные в конце главы примеры публикаций возможно дадут вам свежую идею. В следующей главе мы обсудим окончательную верстку документа с учетом описанных приемов и инструментов.


  • Глава 14. Компоновка текста и графики
    • Координаты объектов
    • Выравнивание объектов
      • Выравнивание по линейкам
      • Выравнивание по направляющим и границам колонок
      • Выравнивание заданием координат
      • Выравнивание объектов относительно друг друга командой Align Objects
    • Группировка объектов
    • Масштабирование объектов
    • Наклон
    • Отражение объекта
    • Поворот
      • Поворот при помощи управляющей палитры
      • Поворот объекта при помощи инструмента Rotating Tool
    • Многократное вклеивание
    • Операция специального вклеивания
    • Обтекание объектов текстом
    • Вложенные изображения
    • Маскирование
    • Резюме


ГЛАВА 14.

Компоновка текста и графики

Частично вопросы размещения текста и графики уже обсуждались в главах, посвященных импорту этих материалов (см. соответствующие разделы гл. 7 и 10). Кроме размещения "на глазок", которое мы там использовали, PageMaker позволяет размещать как текстовые, так и графические материалы с высокой точностью. При точном размещении графических и текстовых материалов используются ввод цифровых значений в управляющей палитре, направляющие, колонки, линейки, команда Align Objects (Разместить объекты) из меню Element (Элемент). Такие элементы интерфейса, как линейки, направляющие и управляющая палитра уже упоминались в гл. 1. Там же приведена информация о масштабе отображения страниц публикации в окне документа, которая очень пригодится при чтении этой главы.

Настоящая глава посвящена рассмотрению следующих вопросов:

  • Координаты объектов
  • Методы выравнивания объектов
  • Операции с объектами — масштабирование, наклон, поворот, отражение
  • Группы объектов
  • Команды вклеивания
  • Обтекание объектов текстом
  • Вложенные изображения
  • Маскирование


Координаты объектов

Любому элементу верстки в PageMaker, размещенному на странице или рабочем столе, соответствуют точные координаты. Изменение этих координат приводит к перемещению элемента в заданное ими новое положение. Определить и изменить координаты объекта можно, используя линейки или управляющую палитру.

PageMaker использует прямоугольную систему координат, начало которой по умолчанию находится либо в левом верхнем углу страницы, либо в середине разворота при отображении страниц разворотами. Умалчиваемое положение начала координат можно изменить и заблокировать (см. гл. 1). Координату любой точки документа можно визуально определить по измерительным линейкам. Предварительно следует включить их отображение командой Show Rulers (Показать линейки) из меню View (Просмотр). Единицы измерения координат и масштаб линеек могут быть определены пользователем с помощью диалогового окна Preferences (Установки) (см. гл. 3).

Каждому объекту, будь он графический или текстовый, сопоставляются одна координата и линейные размеры — высота и ширина. Для непрямоугольных объектов в качестве высоты и ширины принимаются измерения описывающего объект прямоугольника, так называемого габаритного прямоугольника. При выделении объекта инструментом Pointer (Стрелка) вокруг объекта появляются черные квадратики, называемые ограничителями. Ограничители располагаются по углам и серединам сторон габаритного прямоугольника. Перемещая ограничители с помощью инструмента Pointer (Стрелка), можно масштабировать объекты (см. ниже). Координатой объекта считается координата его якорной точки. В локализованной версии PageMaker она имеет название активная точка, но мы будем придерживаться более традиционной терминологии. Якорной точкой может быть любой угол, середина стороны или центр описывающего прямоугольника. Какую из этих точек считать якорной, можно определить с помощью управляющей палитры. При выделенном объекте справа от кнопки модификации в управляющей палитре находится переключатель, символически изображающий описанный прямоугольник, на котором маленькими квадратиками отмечены варианты расположения якорной точки, а большим квадратом — ее текущая позиция. Щелчок мышью на любом маленьком квадратике определяет точку как якорную (рис. 14.1). При изменении якорной точки изменяются и цифры, находящиеся в полях X и Y управляющей палитры. Это, соответственно, горизонтальная и вертикальная координаты объекта. При переопределении якорной точки изменяются и координаты объекта.

Рис. 14.1. Определение якорной точки объекта

Для отрезка линии, в отличие от всех остальных фигур, существуют всего три варианта расположения якорной точки: концы и средняя точка.


Выравнивание объектов

Задать положение объектов, графических материалов и текстовых блоков в рамках программы можно различным образом. В зависимости от задачи выбирают тот или иной способ выравнивания и распределения объектов.


Выравнивание по линейкам

При перемещении объектов координаты сторон их габаритных прямоугольников отмечаются на линейках пунктирными линиями. Это позволяет точно разместить объект на странице публикации. Точность размещения значи-тельно возрастает при включении режима выравнивания командой Snap to Rulers (Выровнять по линейкам) меню View (Просмотр). Разумеется, предварительно должно быть включено отображение линеек командой Show Rulers (Показать линейки) того же меню. При включенном режиме выравнивания по линейкам объект может быть размещен только таким образом, чтобы две стороны его габаритного прямоугольника совпадали с делениями линеек (рис. 14.2).

Рис. 14.2. Выравнивание объекта по линейкам

Выравнивание по линейкам приходится производить при большом увеличении, чтобы деления линейки отстояли друг от друга на достаточное расстояние. В противном случае, выравнивание может произойти не по тому делению линейки, которое вы предполагаете.

Примечание

Выравнивание по линейкам тождественно выравниванию по координатной сетке, которое является непременным атрибутом всех графических редакторов, в том числе Photoshop и Illustrator. Разница заключается лишь в том, что в этих программах шаг сетки задается независимо от разметки линеек.


Выравнивание по направляющим и границам колонок

Этот способ используется наиболее широко, особенно на первых этапах создания макета. Точность размещения объектов относительно направляющих обеспечивается за счет притяжения к ним объектов. Если объект находится достаточно близко к направляющей или границе колонки, PageMaker автоматически перемещает объект таким образом, чтобы сторона соответствующая габаритного прямоугольника совпала с направляющей. Для того чтобы использовать выравнивание по направляющим, необходимо включить отображение направляющих командой Show Guides (Показать направляющие) из меню View (Просмотр) и режим выравнивания — командой Snap to Guides (Выровнять по направляющим) того же меню. Направляющие могут быть защищены от случайных перемещений командой Lock Guides (Закрепить направляющие) и разблокированы повторным выбором этой команды. Если направляющие расположены слишком часто, они могут лишь мешать восприятию макета. Это неудобство можно устранить, переместив направляющие вниз, под все элементы макета командой Send Guides to Back (Направляющие назад). И наконец, если в направляющих отпала необходимость, они могут быть удалены с текущей страницы или разворота командой Clear Ruler Guides (Удалить направляющие) этого же меню.

Примечание

Не используйте команду Clear Ruler Guides (Удалить направляющие) для того, чтобы посмотреть на макет без мешающей разметки. Вместо этого отключите режим Display Master Items (Показать элементы шаблона), если направляющие являются элементами шаблона, или выберите команду Hide Guides (Спрятать направляющие), если они нанесены непосредственно на текущую страницу.

Направляющие могут быть помещены на страницу с абсолютной точностью с помощью дополнения Grid Manager (Модульная сетка). При этом объект, будучи выровнен по таким направляющим, займет на странице положение со строго определенными координатами. С помощью направляющих можно точно также размещать объекты друг относительно друга, если выровнять их относительно одной направляющей.

Рис. 14.3. Выравнивание объектов по направляющим

Особого разговора заслуживают линии и многоугольники, созданные соответствующими инструментами PageMaker. Эти фигуры могут иметь достаточно толстую обводку. Чтобы вопрос о том, по внутренней или внешней ее стороне выравниваются данные объекты, не показался праздным, горизонтальные и вертикальные линии выравниваются по одной из сторон с учетом обводки. Наклонные линии выравниваются геометрически, т. е. без учета обводки.

Примечание

Для точного относительного размещения линий необходимо соблюдать единообразие в их выравнивании по направляющим. Поскольку линия может "прилипнуть" к направляющей любой своей стороной, помещайте их к направляющим все время с одной стороны (например, вертикальные слева, а горизонтальные сверху).

Для многоугольников габаритный прямоугольник может не совпадать с положением ограничителей. Они могут находиться как внутри, так и снаружи обводки. Это зависит от того, рисовали вы прямоугольник, двигаясь по часовой стрелке (рис. 14.4, справа) или против (рис. 14.4, слева).

В поставку PageMaker входит специальный сценарий, позволяющий переопределить сторону (внутреннюю или внешнюю), с которой находится обводка многоугольника. Размеры многоугольника при выполнении этого сценария не изменяются. В любом случае выравнивание многоугольников по направляющим происходит по внешней стороне с учетом обводки (рис. 14.5).

Рис. 14.4. Положение ограничителей многоугольников

Рис. 14.5. Выравнивание многоугольников по направляющим


Выравнивание заданием координат

Кроме позиционирования объектов перетаскиванием мышью, вы можете непосредственно задать их координаты на странице, используя управляющую палитру.

Значение координат объекта в полях X и Y управляющей палитры можно изменять, либо введя новое значение в поле ввода, либо нажимая на расположенные рядом с Мим (слева) кнопки с треугольными стрелками. Шаг, с которым при этом будет меняться координата, соответствует установленному в полях Horizontal nudge (Горизонтальная настройка) и Vertical nudge (Вертикальная настройка). При нажатой клавише <Shift> координата изменяется с большим в 10 раз шагом. Изменять координаты объектов с таким же шагом можно и просто нажимая клавиши стрелок на клавиатуре. Клавиша <Shift> при этом выполняет ту же функцию.

Разумеется, непосредственным заданием координат можно выравнивать объекты относительно друг друга — достаточно задать для них одинаковые координаты. При этом надо постоянно помнить о том, что координата объекта задается положением его якорной точки.


Выравнивание объектов относительно друг друга командой Align Objects

Самым простым и мощным средством выравнивания объектов относительно друг друга является команда Align Objects (Разместить объекты) меню Element (Элемент). Для ее вызова также можно воспользоваться комбинацией клавиш <Ctrl>+<Shift>+<E>. Она выводит на экран диалоговое окно Align Objects (Разместить объекты), в котором могут быть выбраны варианты выравнивания или распределения (рис. 14.6). Команда становится доступной, только если на странице выделено не менее двух любых объектов, поскольку для одного объекта команда не имеет смысла.

Рис. 14.6. Диалоговое окно Align Objects

Выравнивание осуществляется внутренним, примыкающим к окну предварительного просмотра, рядом кнопок. Кнопки, находящиеся справа от окна, задают вертикальное выравнивание, а расположенные снизу — горизонтальное. Наборы кнопок для вертикального и горизонтального выравнивания абсолютно одинаковые и выполняют те же функции. В табл. 14.1 приведены их функции.

Манипулируя этими кнопками, можно одновременно задать тип выравнивания по вертикали и горизонтали или только по одному из измерений, включив для другого кнопку "без выравнивания". После щелчка на кнопке ОК диалоговое окно будет закрыто, а к выделенным объектам будет применено заданное выравнивание. К сожалению, при выравнивании по средней линии нет способа задать "верно расположенный" объект, чтобы все остальные выравнивались по нему. Выравнивание же происходит по средней линии "всей компании" выделенных объектов. Таким образом, ни один из выравниваемых объектов, как правило, не остается на прежнем месте (если он по редчайшей случайности не оказался на линии выравнивания). Выравнивание по границам объектов оставляет на месте самый крайний объект, выравнивая остальные по нему.

Не менее полезной возможностью команды Align Objects (Разместить объекты) является распределение объектов. В табл. 14.2 приведены вид и функции кнопок распределения.

При выборе режима распределения справа от кнопок появляется переключатель, имеющий два положения: Distibute within bounds (В границах области) и Distribute fixed amount (С заданным интервалом). Если он находится в первом положении, то объекты распределяются таким образом, чтобы расстояние между заданными их границами или промежутки между ними были одинаковыми. При этом объекты, находящиеся по краям, не изменяют своего положения, а остальные распределяются между ними (рис. 14.7).

Рис. 14.7. Фигуры до и после горизонтального распределения по средним линиям

Второе положение переключателя открывает поле Space (Расстояние), позволяющее в явном виде задать расстояние между распределяемыми объектами или их границами.

Выравнивание и распределение по разным измерениям может быть проведено одной командой. Например, горизонтальное выравнивание и вертикальное распределение или наоборот. Выравнивание и распределение по одному измерению не могут быть заданы, т. к. это не имеет смысла.

Окно предварительного просмотра всегда демонстрирует новое положение трех простых объектов после выполнения команды. Название типа выравнивания также всегда отображается в текстовых полях правой части окна.

PageMaker 7.0 позволяет использовать мощную команду Align Objects (Разместить объекты) из макроязыка, что существенно добавляет возможностей сценариям.

Состояние диалогового окна Align Objects (Разместить объекты) сохраняется вплоть до следующего открытия. Причем состояться оно может даже в следующем сеансе работы с PageMaker, т. е. установки этого окна создают глобальное умолчание.

Примечание

К сожалению, операция выравнивания и распределения не оставляет возможности отмены командой Undo (Отменить исправления). Суррогатом этого является предварительное мини-сохранение с последующим восстановлением. Создание мини-сохранения перед выполнением команды Align Objects (Разместить объекты) включается установкой флажка Do mini-save (slow) (Сохранить промежуточную версию) в ее диалоговом окне. Если результат команды не устраивает вас, можно его отменить, выполнив команду Revert (Восстановить) при нажатой клавише <Shift>. Эта операция является стандартной для загрузки последнего мини-сохранения.


Группировка объектов

Часто операции перемещения, масштабирования, выравнивания и пр. необходимо проделать не над отдельным объектом, а над совокупностью объектов. В большинстве случаев для этого недостаточно выделить группу объектов, поскольку все операции, кроме перемещения, определены только для одного объекта. PageMaker, не предлагая возможностей работы над несколькими выделенными объектами одновременно, имеет команду определения их как группы, которая является объектом. Просто такой объект состоит из нескольких. Так как группа является объектом, к ней применимы все операции перемещения, масштабирования, наклона, вращения и т. п. Причем в ходе этих операций относительное положение и размеры составляющих группу объектов поддерживаются постоянными.

Примечание

Включение в группу текстовых блоков не делает возможным масштабирование содержащегося в них текста. При масштабировании такой группы изменяются только размеры самого текстового блока, а кегль шрифта остается постоянным (рис. 14.8).

Для "настоящего" масштабирования текстовых блоков написаны сценарии, а также эта функция присутствует в наборе дополнений PageTools 2.1 фирмы Extensis. Демонстрационная версия этого замечательного набора инструментов может быть получена на WWW-сервере фирмы http://www.extensis.com .

а

б

Рис. 14.8. Масштабирование группы, содержащей текстовый блок

Группировка осуществляется командой Group (Сгруппировать) меню Element (Элемент) или комбинацией клавиш <Ctrl>+<G>. Объединение объектов в группу не лишает возможности отдельного редактирования каждого объекта. Для этого объект необходимо предварительно выделить, удерживая клавишу <Ctrl>. Если надобность в объединении объектов отпала, то группу можно расформировать обратной командой Ungroup (Разгруппировать) или комбинацией клавиш <Ctrl>+<Shift>+<G>.

Далее при рассмотрении операций с объектами мы будем подразумевать, что речь может идти не только об отдельных объектах, но и об объектах-группах, если специально не оговорено обратное.


Масштабирование объектов

Точное масштабирование графических объектов осуществляется с помощью управляющей палитры. При этом используются поля Н (В) и W (Ш), задающие размеры объекта в абсолютных единицах или процентах от текущих размеров. При выделенном на странице объекте в этих полях отображаются текущие размеры объекта, что само по себе является не лишней информацией. Ввод новых значений в них приведет к изменению размеров объекта. На масштабирование оказывает влияние положение якорной точки и переключателей пропорционального масштабирования и масштабирования "под принтер".

При операциях масштабирования объект оказывается как бы "приколотым" к странице в якорной точке. Размеры объекта изменяются таким образом, чтобы положение якорной точки оставалось постоянным (рис. 14.9).

а

б

Рис. 14.9. Масштабирование объекта с помощью управляющей палитры

Если включен режим пропорционального масштабирования, то при изменении размеров объекта поддерживается постоянное соотношение сторон его габаритного прямоугольника. Это позволяет масштабировать изображения с сохранением пропорций.

Примечание

Действие кнопки пропорционального масштабирования идентично действию клавиши <Shift> при изменении размеров объекта с помощью мыши (см. гл. 9). Исключение при этом только одно. Нажатая клавиша <Shift> при масштабировании графических примитивов, созданных в PageMaker, вместо пропорционального изменения их размеров преобразовывала прямоугольники в квадраты, эллипсы в круги и т. п. Включенная кнопка пропорционального масштабирования заставляет графические примитивы менять размеры действительно пропорционально!

Для постепенного изменения размеров выделенного объекта не обязательно каждый раз вводить в поля размеров новые значения — можно воспользоваться расположенными рядом (слева) кнопками с изображенными на них треугольными стрелками. Эти кнопки изменяют координату объекта на величину шага, заданного в диалоговом окне Preferences (Установки), обсуждавшемся в гл. 3. Так же, как и при позиционировании объекта, нажатая клавиша <Shift> увеличивает этот шаг в 10 раз.

К масштабированию следует отнести и перемещение объекта в режиме смещения якорной точки. Названный режим включается щелчком мыши на пиктограмме якорной точки в управляющей палитре. При этом квадратик, изображающий на ней якорную точку, меняется на двунаправленную стрелку или две перпендикулярные стрелки, если активная точка в центре (рис. 14.10).

Рис. 14.10. Якорная точка в режиме смещения

Изменение координат объекта в режиме смещения якорной точки приводит не к изменению положения объекта на странице, а к его масштабированию! Вводимая новая координата действительно применяется к якорной точке, но противолежащие ей точки габаритного прямоугольника остаются на месте. Это дает такой же эффект, как если бы вы перемещали данную точку габаритного прямоугольника мышью (рис. 14.11) к заданной координате. Такое перемещение приводит к искажению объекта. Включенная кнопка пропорционального масштабирования заставляет PageMaker не искажать его, а пропорционально изменять размер. Если якорная точка находится в центре объекта, то никаких отличий в режимах ее фиксации и смещения нет.

а

б

Рис. 14.11. Перемещение объекта в режиме смещения якорной точки

При выделенном растровом изображении в управляющей палитре появляется кнопка масштабирования с учетом разрешения принтера. То, какие неприятные последствия вызывает произвольное масштабирование растриро-ванных черно-белых изображений, мы уже рассматривали в гл. 10. Если при масштабировании таких изображений не учитывать разрешающую способность устройства вывода, неминуемо произойдет сбивка растра с появлением муара на отпечатках или пленках. Тем не менее масштабирование уже растрированных изображений возможно, но с единственным условием — размер должен изменяться на кратную разрешению устройства величину. Можно поручить следить за соблюдением этого условия PageMaker, включив кнопку масштабирования "под принтер". Значение разрешения принтера PageMaker берет из установок окна Document Setup (Параметры документа), обсуждавшихся в гл. 3. Собственно это значение используется PageMaker только при масштабировании нерастрированной графики.


Наклон

Иногда эту операцию называют перекашиванием (Leaning) объекта. Суть операции наклона наиболее точно проясняет следующая аналогия: при фиксации нижней стороны габаритного прямоугольника объекта смещается вправо или влево его верхняя сторона, после чего объект "наклоняется", соответственно, вправо или влево.

Рис. 14.12. Наклон объекта в режиме (фиксации якорной точки

На рис. 14.12 представлены результаты наклона объекта с активной точкой в верхнем левом углу в режиме фиксации. На рис. 14.13 представлены результаты выполнения того же действия в режиме смещения активной точки (активная точка обозначена двуглавой стрелкой).

При наклоне объекта с зафиксированной активной точкой последняя остается на месте, как приклеенная к странице, а все остальные точки объекта смещаются относительно нее, формируя результат наклона в соответствии с параметром (см. рис. 14.13). Смещение отсчитывается от активной точки. При наклоне объекта со смещающейся активной точкой она меняет свое положение, а противоположная точка объекта остается на месте (рис. 14.13).

Рис. 14.13. Наклон объекта в режиме смещения активной точки

В обоих примерах угол наклона составил 20 градусов. Отрицательные значения угла наклона соответствуют наклону влево, положительные — вправо.


Отражение объекта

Это преобразование позволяет заменить объект на его зеркальное отражение относительно горизонтальной или вертикальной оси. Отражения строятся с помощью двух кнопок управляющей палитры, назначение которых иллюстрируется изображенными на них парами литер "F" (от слова Flip) до и после отражения.

На рис. 14.14 показано вертикальное, а на рис. 14.15 — горизонтальное отражение объекта.

Рис. 14.14. Вертикальное отражение объекта

Рис. 14.15. Горизонтальное отражение объекта


Поворот

Элементы управления поворотом позволяют разворачивать объект на угол, не кратный 90 градусам, как при построении отражений. Поворот при помощи инструмента Rotating Tool (Поворот) выполняется интуитивно более понятным приемом, а поворот при помощи элементов управляющей палитры обеспечивает более высокую точность выполнения операции.


Поворот при помощи управляющей палитры

Кнопки настройки поворота управляющей палитры позволяют поворачивать объект с шагом 1/10 градуса (или 1 градус при одновременно нажатой клавише <Ctrl>). При вводе значения угла поворота в поле индикатора поворота допустима еще большая точность — до 1/100 градуса.

Если значение угла поворота, введенное в соответствующее поле управляющей палитры, отрицательно, выделенный объект поворачивается по часовой стрелке. Положительные значения угла соответствуют повороту объекта против часовой стрелки, что может показаться не очень естественным, но этому есть объяснение. Причина кроется в языке PostScript. Невозможно вращать что-либо, не задав центр вращения (центр воображаемого циферблата). Большинство пользователей склонны считать, что начальное направление поворота, соответствующее его нулевому значению, следовало бы совместить с 12 часами этого циферблата, но в PageMaker, пользующемся для вывода страниц на печать языком PostScript, это не так. В PostScript поворот объекта отсчитывается от горизонтальной оси, которая соответствует на ци-ф'ерблате не 12, а 3 часам. Проверьте сами. Постройте горизонтальную линию и начните поворачивать ее при помощи инструмента Rotating Tool (Поворот) против часовой стрелки. В начале угол поворота в индикаторе управляющей панели будет равен нулю, а затем начнет увеличиваться.

Примечание

В приложениях Freehand, Illustrator и QuarkXPress используется та же схема измерения углов поворота объектов. Во всех этих графических приложениях применяется четырехквадрантная модель координатной плоскости Декарта. При построении графиков мы пользуемся правым верхним квадрантом плоскости, предполагая, что значения, которые мы откладываем в нем по осям координат, положительны. Следовательно, координаты точек, лежащих в правом нижнем квадранте, положительны по оси X и отрицательны по оси Y. Такая же система координат часто применяется в картографии.

На рис. 14.16 и 14.17 представлены различия результатов вращения объекта при фиксированной и смещающейся активных точках. В режиме фиксированной активной точки объект поворачивается вокруг активной точки, обозначенной на схеме увеличенным по сравнению с остальными квадратиком. В режиме смещения активной точки активная точка, обозначенная двуглавой или четырехглавой стрелкой, поворачивается сама. При выборе активной точки в центре объекта результаты поворота в обоих режимах совпадают. Обратите внимание на то, что в процессе поворота объекта синхронно с ним поворачивается и схема на управляющей палитре.

Рис. 14.16. Поворот объекта в режиме фиксации активной точки

Рис. 14.17. Поворот объекта в режиме смещения активной точки


Поворот объекта при помощи инструмента Rotating Tool

Вместо того чтобы вводить угол поворота в поле управляющей палитры или щелкать мышью на кнопках настройки поворота, вы можете выбрать инструмент Rotating Tool (Поворот) в левом нижнем углу палитры инструментов и выполнить поворот объектов от руки.

На рис. 14.18 представлена схема работы этим инструментом. Вначале выберите инструмент Rotating Tool (Поворот), а затем нажмите кнопку мыши где-нибудь вблизи от объекта, который следует повернуть. В той точке, где была нажата кнопка, будет расположен центр вращения, отмеченный тонким перекрестьем. Не отпуская кнопку мыши, отодвиньте ее указатель от объекта. За ним потянется тонкая линия — тот рычаг, при помощи которого вы будете поворачивать объект. Чем длиннее рычаг, тем точнее можно управлять поворотом объекта. Обратите внимание на то, что в поле индикатора поворота управляющей палитры отображается текущий угол поворота объекта. '

Как в большинстве случаев, при выполнении перемещения объекта в программе PageMaker существует возможность параметрического ограничения поворота. В этом случае параметрическое ограничение сводится к принудительному повороту объекта вокруг его центра. Вместо того чтобы устанавливать активную точку в центре объекта, можно просто удерживать нажатой клавишу <Ctrl> в процессе работы инструментом Rotating Tool (Поворот) (рис. 14.19). Отметим, что при этом центр вращейия совмещается с центром поворачиваемого объекта.

Рис. 14.18. Поворот объекта с помощью инструмента Rotating Tool

Рис. 14.19. Поворот вокруг центра объекта при помощи инструмента Rotating Tool при нажатой клавише <Ctrl>

Редактирование текста, подвергнутого преобразованиям поворота, наклона или отражения, не имеет каких-либо особенностей. Выберите инструмент Text (Текст), щелчком мыши на тексте установите в нем точку вставки и редактируйте обычными приемами. Все они действуют на преобразованный текст. Каким образом редактировать — в режиме макета или в редакторе материалов (после тройного щелчка мышью на тексте), — выбирайте по обстоятельствам.


Многократное вклеивание

При распределении или выравнивании нескольких копий одного объекта альтернативой команде Align Objects (Разместить объекты) может служить операция многократного вклеивания по команде Paste Multiple (Вклеить многократно), диалоговое окно которой представлено на рис. 14.20. Скопируйте объект в системный буфер и выберите команду Paste Multiple (Вклеить многократно).

Рис. 14.20. Диалоговое окно Paste Multiple

Задайте в диалоговом окне необходимое количество копий объекта, помещенного в системный буфер. Введите в соответствующие поля диалогового окна смещения по горизонтали и вертикали для размещения объектов. Если объекты должны быть выровнены по горизонтали или вертикали, введите в одно из этих полей нулевое значение смещения. На рис. 14.21 представлены четыре объекта, вклеенные на одном расстоянии друг от друга с выравниванием по горизонтали. Как видите, одной командой была выполнена операция, которая традиционными средствами выполняется в несколько этапов копирования с последующим распределением. В определенных условиях этот прием может сэкономить довольно значительное время.

Отрицательные значения смещения задают размещение копий сверху и слева от исходного положения объекта, а положительные — справа и снизу от него.

Рис. 14.21. Многократное вклеивание и выравнивание объектов

Команду Paste Multiple (Вклеить многократно)-можно повторить несколько раз с однократным заданием параметров в диалоговом окне. При повторном выборе команды удерживайте нажатой клавишу <Shift>, и команда будет выполнена с ранее заданными параметрами без раскрытия диалогового окна.

Примечание

Многократное вклеивание невозможно отменить командой Undo (Отменить исправления). Поэтому не забывайте сохранять промежуточную копию публикации, которая понадобится вам, если результаты вклеивания будут неудовлетворительными.

Примечание

Команда многократного вклеивания одинаково хорошо справляется с объектами и с текстами. Скопируйте подлежащий размножению текст или вложенное графическое изображение в системный буфер и установите точку вставки в том месте текста, где должны появиться копии. После выбора команды Paste Multiple (Вклеить многократно) указанное количество копий будет вставлено в текст. Таким приемом удобно пользоваться, например, при копировании строк бланка, образованных подчеркнутыми символами табуляции или линиями абзацев. В этом случае в системный буфер копируется абзац целиком, вместе с признаком конца абзаца. Когда в системном буфере находится текстовый объект, поля смещений при вклеивании отсутствуют в диалоговом окне.


Операция специального вклеивания

Операция специального вклеивания предназначена для копирования и переноса объектов с одной страницы на другую в то же самое место, которое они занимали на исходной странице.

Вот как это работает. Скопируйте выбранный объект в системный буфер и перейдите на страницу, на которую хотите поместить его копию. Вместо обычной команды вклеивания воспользуйтесь комбинацией клавиш <Alt>+ +<Ctrl>+<V>. Можно также выбрать команду Paste (Вклеить) в меню при нажатой клавише <Alt>.

Для распределения объектов при помощи команды специального вклеивания надо вначале скопировать исходный объект в системный буфер. Затем, однократно выполнив команду специального вклеивания, перетащить мышью копию объекта на новое место с желаемым смещением от исходного положения. При повторном выполнении команды специального копирования вторая копия объекта будет так же смещена относительно первой, как первая копия — относительно исходного объекта. Каждая последующая копия, построенная приемом специального копирования, будет смещена тем же-образом относительно предыдущей копии. Новая операция копирования в системный буфер сбрасывает параметры специального копирования.


Обтекание объектов текстом

Теперь, когда мы рассмотрели все средства редактирования и размещения текстовых и графических элементов макета, самое время перейти к их компоновке. Простейшей ситуацией является обособленное размещение элементов. В этом случае графические объекты и текстовые блоки просто располагаются в секциях заранее определенной модульной сетки и по ней же выравниваются. Данный случай настолько элементарен, что не требует особого рассмотрения.

Существуют также ситуации, когда изображение или его часть должны находиться внутри текстового блока и текст должен "обтекать" изображение. Особенно часты они при верстке многоколоночных документов — журналов и газет. Для задания режима обтекания изображений текстом PageMaker располагает специальной командой.

Режим обтекания задается для каждого изображения публикации отдельно. Это позволяет задавать различные варианты обтекания в зависимости от требований макета для любых его элементов. Режим обтекания текстом задается в диалоговом окне Text Wrap (Обтекание текстом). Это окно (рис. 14.22) вызывают командой Text Wrap меню Element (Элемент) или контекстного меню. Разумеется, тот элемент макета, для которого вы хотите задать режим обтекания текстом, должен быть предварительно выделен инструментом Pointer (Стрелка).

Рис. 14.22. Диалоговое окно Text Wrap

Пиктограммы группы Wrap option (Вариант обтекания) включают и отключают режим обтекания. Если щелкнуть на второй пиктограмме, режим обтекания будет включен, а если на первой — то отключен. Третья пиктограмма не является кнопкой. Она подсвечивается, если объекту задан непрямо-угольный контур обтекания. Ряд пиктограмм Text |low (Размещение текста) управляет размещением текста вокруг объекта, размеренного внутри текстового блока. Первая пиктограмма запрещает размещение текста в колонке ниже объекта; вторая — справа и слева от объекта; третья задает размещение текста со всех сторон объекта. Примеры всех этих вариантов приведены на рис. 14.23.

а

б

в

Рис. 14.23. Обтекание объекта текстом в зависимости от положения переключателя Wrap option

Для того чтобы текст не касался объекта, который он обтекает, диалоговое окно Text Wrap (Обтекание текстом) дает возможность определения расстояния от текста до объекта. Это расстояние вводится в поля отступов группы Standoff in inches (Отступы в мм). Наличие четырех полей — Left, Right, Top, Bottom (Слева, Справа, Сверху, Снизу) — дает возможность установить различные расстояния от габаритного прямоугольника объекта до текста с любой его стороны (рис. 14.24).

а

б

Рис. 14.24. Различные расстояния до текста с разных сторон объекта

Примечание

Переключатель Wrap text on same layer only (Текст только с одного слоя) диалогового окна Text Wrap (Обтекание текстом) используется, если публикация содержит несколько слоев (см. гл. 13). Когда он включен, параметры обтекания, устанавливаемые в данном окне, применяются только к тексту, находящемуся на том же слое, что и объект. Это полезно, если на различных слоях расположены варианты макета: например, разные варианты дизайна страницы.

Контур обтекания может быть задан вручную и может отличаться от прямоугольного. Если для объекта уже включен режим обтекания текстом, то при выделении его инструментом Pointer (Стрелка), кроме уже знакомых вам ограничителей, вокруг габаритного прямоугольника появляется пунктирная рамка с черными' точками в углах. Эта рамка и является контуром обтекания текстом: размешенный вокруг объекта текст касается его. Контур обтекания текстом может быть отредактирован вручную, причем эта процедура очень похожа на редактирование многоугольника, описанное в гл. 9, т. к. контур обтекания является замкнутым многоугольником. Отличие заключается только в том, что все операции перемещения, создания и удаления вершин многоугольника следует применять к контуру обтекания. Щелчок мышью на контуре создает дополнительный узел контура, 1ч, е. вершину многоугольника, представляющего собой контур обтекания. Щелчок на уже существую-

щем узле удаляет его. Узлы и стороны контура перемещаются перетаскиванием их курсором мыши. Непрямоугольный контур обтекания текстом является мощным средством и выразительным элементом дизайна, особенно при использовании обтравленных изображений. Помещение в публикацию обтравленных изображений уже обсуждалось в гл. 10 и еще будет обсуждаться в гл. 15.

Примечание

Если для объекта задано нулевое расстояние до контура обтекания, то становится невозможным с помощью мыши захватить его узлы, т. к. вместо них выбираются ограничители объекта, имеющие более высокий приоритет. Для того чтобы в такой ситуации добраться до контура обтекания при манипуляциях с ним, удерживайте клавишу <Ctrl>.

Если после редактирования контура обтекания заглянуть в диалоговое окно Text Wrap (Обтекание текстом) для этого объекта, то в группе Wrap option (Вариант обтекания) подсвеченной окажется последняя пиктограмма, показывающая, что для объекта назначен непрямоугольный контур обтекания.

При необходимости отмены редактирования контура обтекания и приведения его к прямоугольной форме достаточно щелкнуть мышью на средней пиктограмме в группе Wrap option (Вариант обтекания) диалогового окна Text Wrap (Обтекание текстом).

Обычно используются прямоугольные контуры обтекания, а расстояние от объекта до контура обтекания, как правило, одинаково. В этом случае еще до помещения графики в публикацию имеет смысл установить локальное умолчание для обтекания текстом. Для этого отмените все выделения на странице и выполните команду Text Wrap (Обтекание текстом). В открывшемся диалоговом окне установите параметры обтекания, которые используются для большинства элементов публикации. Теперь при помещении изображения в публикацию или при создании графических примитивов средствами PageMaker им автоматически будут назначены эти параметры обтекания. (Подробнее об умолчаниях см. гл. 3.)

Примечание

В PageMaker нельзя напрямую задать режим обтекания текстом текстового блока. Для задания блоку текста режима обтекания необходимо выделить его инструментом Pointer (Стрелка), создать группу из единственного элемента (текстового блока) и назначить для нее режим обтекания. Более элегантным способом является использование для этой цели фреймов (см. гл. 15).

Когда положение графического объекта или текстового блока на странице окончательно определилось, разумно зафиксировать его командой Lock Position (Закрепить) меню Element (Элемент) или комбинацией клавиш <Ctrl>+<L>. При этом графические и текстовые элементы ведут себя по-разному.

Свободно размещенные закрепленные графические объекты и любые группы обладают следующими свойствами.

  • Закрепленные графические объекты не могут быть перемещены в другое место страницы, удалены или отмасштабированы.
  • Они не могут быть сгруппированы с другими объектами. При попытке группировки PageMaker выдаст предупредительное сообщение, предлагающее либо разгруппировать объект, либо закрепить получившуюся группу (рис. 14.25).
  • Закрепленные графические объекты могут быть перемещены на другой слой (см. гл. 13).
  • Для них могут быть переопределены цвета заливки и обводки.
  • Некоторые примитивы, созданные в PageMaker, могут быть отредактированы его командами: скругление углов прямоугольника командой Rounded Corners (Скругленные углы) и переопределение их числа у многоугольников командой Polygon Settings (Многоугольник) с сохранением размеров габаритного прямоугольника.
  • Для растровых изображений могут быть изменены параметры цветопередачи командой CMS Source (Источник CMS).
  • Полутоновые растровые изображения могут быть отредактированы командой Image Control (Корректировка).
  • Цветные растровые изображения могут быть отредактированы командой Photoshop Effects (Эффекты Photoshop).
  • Для этих объектов могут быть переопределены режимы обтекания текстом и отредактирован контур обтекания текстом.
  • Закрепленные объекты могут быть скопированы в буфер обмена, причем копия, если ее создать потом, не будет закреплена.

Рис. 14.25. Окно запроса при попытке группировки закрепленного объекта

Закрепленные текстовые блоки обладают следующими свойствами.

  • Они не могут быть перемещены в другое место страницы, удалены или отмасштабированы.
  • Закрепленные текстовые блоки не могутхбыть сгруппированы с другими объектами. При попытке группировки PageMaker выдаст предупредительное сообщение, предлагающее либо разгруппировать объект, либо закрепить полупившуюся группу.
  • Текст внутри закрепленного блока может быть отредактирован с помощью инструмента Text (Текст) или в редакторе материалов.
  • При увеличении размеров текста внутри блока его размер остается постоянным, если он связан с незакрепленным текстовым блоком (текст перетекает в него), и увеличивается, если блок не связан ни с какими другими.

Чтобы снять фиксацию объекта, воспользуйтесь командой Unlock (Снять закрепление) меню Element (Элемент) или комбинацией клавиш <Alt>+ +<Ctrl>+<L>.


Вложенные изображения

Графические объекты могут быть помещены в публикацию не только как свободно размещаемые, но и как вложенные (см. гл. 10). Вложенная графика обладает существенным преимуществом перед свободно размещаемой — она всегда расположена рядом с текстом, который иллюстрирует независимо от его перемещений в процессе верстки. С другой стороны, для вложенной графики не может быть определен режим обтекания текстом, что делает необходимым резервирование для нее отдельной строки. Если графический материал занимает лишь колонку с небольшими полями, то использование вложенной графики полностью оправдано. Вложенная графика обеспечит замечательную легкость корректировки макета при изменении объема и расположения текста. Напомним, что вложенная графика обладает свойствами как свободно размещаемой графики, так и текста. С одной стороны, можно обычным образом изменять ее размеры, вращать, обрезать и т. п., а с другой — настраивать для нее интерлиньяж, кернинг и трекинг.

При размещении вложенной графики возможны два случая. В первом вертикальный размер вложенных графических элементов меньше интерлиньяжа строки, в которой расположена графика. При этом лучше всего задать интерлиньяж текста в явном виде, используя локальное форматирование или абзацные стили. Это предупредит изменение интерлиньяжа для строки, содержащей графику, возможное при автоматическом интерлиньяже. Подобная же проблема возникает при наличии в строке символов разного кегля и решается тем же способом (см. гл. 4). Положение вложенного графического объекта относительно базовой линии, содержащей его строки, можно настроить, используя его "текстовые" и "графические" свойства. Работая с "текстовыми" свойствами объекта, выделите его инструментом Text (Текст) и задайте нужное смещение базовой линии, воспользовавшись управляющей палитрой или диалоговым окном Character Specifications (Параметры шрифта), как описано для символов шрифта в гл. 4. "Графические" свойства объекта позволяют перемещать его с помощью инструмента Pointer (Стрелка). При этом допускается только вертикальное перемещение (рис. 14.26).

Рис. 14.26. Изменение положения вложенного графического объекта относительно базовой линии строки

В другом случае вложенное графическое изображение больше интерлиньяжа текста, расположенного вокруг. Такая графика требует отвести под нее отдельную строку текста. Удобно при этом создать для вложенной графики специальный стиль, что позволит легко задавать параметры ее размещения. Очевидно, в этом случае задание какого-либо определенного интерлиньяжа для строк с вложенными изображениями нецелесообразно, т. к. они могут иметь разные вертикальные размеры, что требует различного интерлиньяжа. Выходом из подобной ситуации является установка для таких строк автоматического определения интерлиньяжа. Как вы помните, он рассчитывается исходя из высоты наибольшего по размерам символа в строке. Это свойство, делающее его малопригодным для верстки текста, оформленного символами различного кегля, выручает при использовании вложенных изображений. Вложенные изображения для PageMaker — тоже символы текста, и для них имеют смысл все характерные для текста параметры: вертикальный размер (тождествен кеглю), интерлиньяж, трекинг, кернинг и т. п. При автоматическом определении интерлиньяжа для строки, содержащей вложенную графику, PageMaker возьмет за основу высоту самого большого символа этой строки, т. е. графического элемента и обеспечит резервирование необходимого для него места, независимо от размеров. Дополнительное пространство сверху и снизу графического элемента можно создать отбивками абзаца. Вертикальная выключка текста позволит совместить нижний край изображения (его "базовую линию") с базовыми линиями текста в соседних колонках, что придаст странице профессиональный вид (см. гл. 13).

Вложенная графика может быть закреплена на странице так же, как и свободно размещаемая. Имеет она и следующие особенности.

  • Вложенная графика не может быть удалена при выделении инструментом Pointer (Стрелка), не может быть отмасштабирована.
  • Она удаляется в текстовом режиме при активном инструменте Text (Текст).
  • Такая графика не может быть смещена относительно базовой линии строки и сгруппирована с другими объектами.
  • Для графики могут быть переопределены цвета заливки и обводки.
  • Некоторые примитивы, созданные в PageMaker, могут быть отредактированы его командами: скругление углов прямоугольника и переопределение их числа у многоугольников с сохранением размеров габаритного прямоугольника.
  • Для растровых изображений могут быть изменены параметры цветокоррекции командой CMS Source (Источник CMS).
  • Полутоновые растровые изображения могут быть отредактированы командой Image Control (Корректировка).
  • Цветные растровые изображения могут быть отредактированы командой Photoshop Effects (Эффекты Photoshop).
  • Вложенная графика может быть скопирована в буфер обмена, причем копия не будет закреплена.

Закрепление вложенной графики отменяется так же, как и свободно размещаемой.


Маскирование

Любая из геометрических фигур, построенных графическими инструментами программы PageMaker, может использоваться для маскирования любого другого объекта. В качестве маскируемого объекта может выступать текстовый блок PageMaker, другой графический объект PageMaker или импортированное графическое изображение. На рис. 14.27 представлена операция маскирования, в которой графический объект программы PageMaker (окружность) маскирует импортированное графическое изображение. Можно представить себе маскирование как разновидность кадрирования.

Рис. 14.27. Маскирование окружностью

На рис. 14.28, а представлены три объекта, принимающие участие в операции маскирования. Если для маскирования выбрано несколько объектов (как в этом примере), маской всегда является самый верхний из них (лежащий на верхнем слое). В данном случае это окружность.

На рис. 14.28, б один из замаскированных объектов смещен относительно маскирующего с помощью инструмента Pointer (Стрелка).

На рис. 14.28, в показан эффект, возникающий при задании фона маскирующего объекта. Фон виден только сквозь прозрачные участки маскированного объекта.

а

б

с

Рис. 14.28. Вариации на тему маскирования

Редкая операция маскирования обходится без сопутствующего группирования маскирующего и маскируемого объектов. Если в момент вызова меню Element (Элемент) для выбора команды Mask (Применить маску) держать нажатой клавишу <Shift>, обе операции будут выполнены одновременно. Отмена маскирования с сопутствующим разгруппированием выполняется при помощи команды Unmask and Ungroup (Отменить маску и разгруппировать), появляющейся в меню Element (Элемент) ггри его раскрытии с нажатой клавишей <Shift>. К сожалению, клавиша <Shift> не оказывает никакого воздействия на комбинацию клавиш, эквивалентную команде маскирования, — <Ctrl>+<6>


Резюме

Правильное и точное размещение текста и изображений, как ни что иное, придает публикации профессиональный вид. Погрешность в десятые доли миллиметра не только может быть заметна, но и просто будет бросаться в глаза. Рассмотренные приемы позволят вам быстро и точно размещать материалы на странице, не жертвуя при этом "мобильностью" публикации при необходимости внесения корректив. Приведенными операциями не исчерпываются все возможности компоновки разнородных материалов. Более сложные случаи требуют специального рассмотрения. Именно им отведены гл. 15 и 16, посвященные специальным эффектам и верстке табличной информации.


  • Глава 15. Специальные эффекты
    • Разная выключка в пределах абзаца
    • Висячие текст и графика
      • Висячие знаки пунктуации
      • Создание висячего отступа
      • Графика в висячих отступах
    • Оформление заголовков
      • Метод множественных текстовых блоков
      • Использование текста в висячих отступах
      • Использование графики в висячих отступах
      • Противоположно направленные отступы в сочетании с линейками
      • Оформление смещением базовых линий
      • Заголовки в подбор
    • Украшение заголовков
      • Использование линеек
      • Использование вложенной графики
    • Буквицы
      • Поднятые буквицы
      • Опущенные буквицы
      • Висячие буквицы
    • Шрифтовые эффекты
      • Поворот и наклон
      • Смещение базовой линии и кернинг
      • Имитация тени
    • Специальные эффекты с использованием фреймов
      • Фреймы
      • Фигурный текст
      • Обтравка изображений
      • Рамки
    • Резюме


ГЛАВА 15.

Специальные эффекты

В этой главе речь пойдет об особых эффектах, которые можно получить, пользуясь стандартными средствами PageMaker. Использование этих приемов придаст публикации привлекательный и профессиональный вид, а необычные элементы станут той изюминкой, без которой страница выглядит пресной. Новая версия PageMaker предоставляет пользователю новый инструмент — фреймы. Они стали стандартным и удобным средством создания тех эффектов, которых в предыдущих версиях программы приходилось добиваться сложными ухищрениями. Значительное место в данной главе будет уделено этому новому инструменту.

В настоящей главе рассмотрены специальные приемы работы с PageMaker, а именно:

  • Особенности взаимодействия выключки текста и позиций табуляции
  • Применение висячего отступа для размещения графики и текста
  • Оформление заголовков-"фонариков"
  • Приемы работы с заголовками в подбор
  • Использование линеек и вложенной графики для оформления заголовков
  • Создание буквиц
  • Шрифтовые эффекты
  • Специальные эффекты с использованием фреймов


Разная выключка в пределах абзаца

Довольно часто возникает необходимость задания различных типов выравнивания в пределах одной строки текста. Особенно это относится к колонтитулам, которые могут включать, например, выключенный по левому краю заголовок книги, выключенный по центру номер или название главы и выключенный по правому краю номер страницы. Применение описанной ниже "маленькой хитрости" позволяет добиться такого, на первый взгляд невозможного, выравнивания.

Способ основан на установке в строке символа табуляции в сочетании с выключкой всей строки по правому краю. При этом текст справа от символа табуляции занимает не позицию, соответствующую табулоотступу по умолчанию, а просто выравнивается по правому краю! Если, как в данном примере, требуется еще выровнять часть строки по центру, сделайте это, установив дополнительные позиции табуляции (рис. 15.1).

Рис. 15.1. Разные типы выключки в одном абзаце


Висячие текст и графика

Термин "висячий" употребляется в издательском деле для обозначения элементов, расположенных слева от основной колонки текста. Элементы такого рода служат великолепным средством выделения и структурирования текста, позволяя читателю легко в нем ориентироваться. К висячим элементам относятся отдельные символы (висячие знаки пунктуации и буквицы), маркеры пунктов перечней (bullets), маргинальные заголовки и графические элементы. PageMaker имеет простые средства создания маргинальных элементов, занимающих одну строку колонки. Если требуется создать многострочный маргинальный заголовок, приходится прибегать к разнообразным ухищрениям.

Макет, созданный с использованием висячих элементов, производит впечатление многоколоночного, хотя в действительности имеет только одну колонку текста (рис. 15.2).

Зачем же прибегать к специальным приемам, когда можно сделать две настоящих колонки и разместить маргинальные элементы в левой колонке, а основной текст — в правой? Ответ очевиден: маргинальные элементы по смыслу привязаны к определенным строкам основного текста и при изменении размещения основного текста не должны утрачивать этой привязки. Если расположить их в отдельной колонке, то вам бы пришлось настраивать положение маргинальных элементов относительно основного текста вручную и каждый раз делать это заново при малейшем изменении форматирования основного текста. Оформление маргинальных элементов как висячих позволяет не заботиться об их расположении относительно соответствующих строк основного текста, т. к. они включены в эти строки. В данном случае изменение форматирования и добавление или удаление основного текстового материала не приведет к необходимости ручного размещения маргинальных элементов.

Рис. 15.2. Одноколоночный макет с маргинальными элементами


Висячие знаки пунктуации

Самыми простыми висячими элементами являются отдельные символы. Необходимость в создании таких элементов вызвана либо более тонкой настройкой выключки заголовков, либо желанием создать особый эффект. В обоих случаях можно использовать один и тот же прием.

На рис. 15.3 представлены два образца заголовков, выключенных по формату. Первый образец оставляет впечатление плохо выровненного. Дело в том, что знаки препинания зрительно практически не занимают места и не должны принимать участие в выключке. Это верно, разумеется, только для текста, привлекающего повышенное внимание читателя, т. е. для заголовков крупным кеглем. Это свойство знаков препинания учтено во втором образце, где знаки препинания оформлены 1$ак висячие. Смещение их относительно границ колонки сделано с помощью ручного кернинга. Поскольку кернинг для первого и последнего символа в строке не имеет смысла, перед кавычками и последних был вставлен пробел в круглую шпацию, а уже затем выполнен кернинг пар "пробел-кавычка".

Рис. 15.3. Получение висячих знаков пунктуации с помощью ручного кернинга

Для осуществления кернинга точка вставки инструмента Text (Текст) была помещена между открывающей кавычкой и пробелом. Затем нажатием комбинации клавиш <Аlt>+<стрелка влево> символ кавычек был смещен влево. Аналогичным образом был выполнен кернинг для закрывающей кавычки, только смещение производилось вправо, с помощью комбинации клавиш <Аlt>+<стрелка вправоХ


Создание висячего отступа

Для создания висячих элементов их размещают в строке, имеющей висячий отступ. Мы уже рассматривали создание висячих отступов в гл. 5. Для размещения маргинальных элементов, кроме смещения границы колонки, используется табулоотступ, находящийся в позиции начала колонки (рис. 15.4).

Рис. 15.4. Создание висячего отступа

Процедура создания висячего отступа производится следующим образом. С помощью инструмента Text (Текст) в один из абзацев, который должен включать маргинальные элементы, первым символом вставляется символ табуляции. Потом тройным щелчком тем же инструментом внутри абзаца он выделяется полностью. Командой Indents/Tabs (Отступы/Табуляция) меню Туре (Текст) вызывается линейка табуляции. Нижний маркер левой границы колонки мышью при нажатой клавише <Alt> перетаскивается вправо на расстояние, соответствующее ширине колонки, отведенной для маргинальных элементов. Как вы помните, верхний маркер отмечает левую границу первой строки абзаца, а нижний — границу его остальных строк. Переместив только нижний маркер, вы тем самым уменьшили ширину полосы текста в абзаце за исключением его первой строки. Первая строка при этом будет по-прежнему занимать всю ширину колонки. Помещение табулоот-ступа в положение левого края уменьшенной полосы текста в абзаце заставит и текст в первой строке занять положение в пределах полосы остального текста абзаца. Кнопка ОК уберет с экрана линейку табуляции и применит сделанные установки к выделенному абзацу. Если это не единственный абзац, в котором вы собираетесь разместить маргинальные элементы, то имеет смысл запомнить сделанные установки в виде стиля абзаца.

Отформатированный таким образом абзац выглядит просто как абзац с отступом слева, но в его первой строке у самого левого края колонки существует позиция, в которую можно поместить текстовый курсор. В нее можно вставить графический элемент или короткий текст. При этом основной текст по-прежнему будет занимать отдельную "колонку" справа.


Графика в висячих отступах

После того как висячий отступ создан, в него может быть помещен любой графический элемент. Очевидно, что этот элемент будет вложенным. Такие висячие графические элементы служат великолепным средством выделения и оригинальным элементом дизайна. Они могут использоваться как маркеры элементов перечня или небольших фрагментов текста (рис. 15.5).

Как и для любого вложенного графического изображения, положение висячего графического элемента по вертикали может быть настроено смещением базовой линии или просто перетаскиванием с помощью мыши при активном инструменте Pointer (Стрелка).

Рис. 15.5. Использование висячих графических элементов

Примечание

Проделывать такую настройку для каждого висячего изображения в публикации довольно хлопотно. Этот процесс можно в значительной степени автоматизировать, используя команду Find (Найти).

В каждый висячий ртступ вместо изображения помещается уникальный набор символов, который можно легко обнаружить в публикации посредством команды Find (Найти), например $$$, %%% и т. п. Затем требуемое изображение помещается только в один абзац и его смещение настраивается относительно базовой линии строки. Инструментом Text (Текст) выбирается настроенное изображение и копируется в системный буфер. После этого командой Find (Найти) отыскиваются все вхождения заданной вами комбинации символов в текст, т. е. те места, где должна располагаться висячая графика. После отыскания очередного вхождения в публикацию с помощью команды Paste (Вклеить) вставляется содержимое системного буфера. При этом настройка положения базовой линии для вклеенного графического элемента сохраняется.

Примечание

Для того чтобы прием сработал абсолютно, необходимо выделять копируемое изображение инструментом Text (Текст), а не Pointer (Стрелка). В последнем случае настройка базовой линии не сохранится, т. к. при этом используется "графическая сущность" вложенного изображения, для которой понятие базовой линии не имеет смысла. При использовании инструмента Text (Текст) вложенное изображение трактуется как символ текста, для которого могут быть заданы соответствующие атрибуты, в том числе и смещение базовой линии. Подробнее о вложенных изображениях см. гл. 14.

Наиболее часто в качестве маркеров элементов перечней используются не вложенные графические изображения, а значки из символьных шрифтов Windings, ZapfDingbats и т. п. Вы можете поместить эти символы в заранее созданные висячие отступы вклеиванием из буфера обмена, но легче воспользоваться дополнением Bullets and numbering (Нумерация абзацев). Это дополнение уже подробно нами рассматривалось в гл. 5.


Оформление заголовков

Графические и текстовые элементы в висячих отступах иногда используются для создания заголовков. В первую очередь, это "фонарики", т. е. заголовки, расположенные в отдельной колонке, слева от колонки основного текста. Разумеется, заголовок-"фонарик" должен находиться рядом с первой строкой соответствующего материала в правой колонке. Оформление текстового материала заголовками-"фонариками" является широко распространенным приемом. Оно дает возможность очень легкой ориентации в больших объемах материала. Поскольку все заголовки оказываются вынесенными в отдельную колонку, их легко "пробежать" глазами и найти требуемый раздел.

Несмотря на частоту использования фонариков, PageMaker не располагает специальными средствами для их создания. Главной проблемой в этом случае является привязка блока заголовка к определенному месту основного текста. Тем не менее использование висячих отступов и некоторая изобретательность позволяют решить эту проблему. Решений может быть несколько, и выбор между предлагаемыми в этой главе вариантами зависит от особенностей публикации.


Метод множественных текстовых блоков

Этот метод применяется достаточно редко. Мы приводим его здесь преимущественно для того, чтобы читатель прочувствовал, какая работа предстоит тому, кто возьмется за решение проблемы создания "фонариков" без использования специальных приемов. Такое решение предполагает создание отдельных текстовых блоков с заголовками-"фонариками" и размещение каждого из них во вспомогательной левой колонке, а положение их относительно основного текста устанавливается вручную. При такой организации заголовков изменение длины текста в основной колонке нарушает соответствие "фонариков" тексту. Поскольку фонарики оказываются никак не связаны с основным текстом, приходится размещать их заново, что для многостраничных документов представляет собой весьма длительную и столь же утомительную процедуру.

Тем не менее, если публикация насчитывает десяток страниц, этот метод может привлечь ваше внимание. Попробуйте упростить работу по размещению "фонариков" следующими приемами.

  • Оформляйте "фонарики" не в виде отдельных материалов, а просто выделяйте заголовки в отдельные текстовые блоки и располагайте их во вспомогательной колонке. В этом случае весь размещаемый текст оказывается в одном непрерывном материале, состоящем из связанных в цепочку блоков, что значительно облегчает его редактирование. П Значительно упрощает вертикальное выравнивание "фонариков" относительно основного текста правильно заданная сетка интерлиньяжа (см. гл. 13).
  • Для того чтобы при редактировании основного текста он не перетекал в блоки, отведенные для "фонариков", задайте принудительный переход на новую колонку в стиле заголовков.

Метод множественных текстовых блоков имеет два преимущества перед прочими: в редакторе материалов всегда доступен весь размещаемый текст и отсутствуют ограничения на его форматирование внутри "фонариков". Эти преимущества сводятся на нет многократным ручным размещением "фонариков" при переформатировании или изменении основного текста. Так что, использовать данный метод можно только прн очень небольшом объеме публикации или если существует уверенность, что основной текст не будет многократно редактироваться. Впрочем, если вы уже занимались версткой, то вряд ли способны испытывать такую уверенность.


Использование текста в висячих отступах

Размещение текста в висячих отступах также используется для создания за-головков-"фонариков". К сожалению, размер висячего отступа накладывает очень строгие ограничения на размер размещаемого в нем заголовка. Используйте этот прием, если можете позволить себе отвести под вспомогательную колонку достаточно большое пространство, а заголовки при этом состоят не более чем из двух-трех коротких слов.

Рис. 15.6. Использование текста в висячих отступах для создания "фонариков"

Рис. 15.7. Установка дополнительной позиции табуляции для выравнивания заголовков-"фонариков" по правому краю

Данный прием предполагает установку дополнительной позиции табуляции для выравнивания "фонариков" по правому краю (рис. 15.7). В этом случае одинаковые расстояния между "фонариками" и основной колонкой текста формируют вертикальный интервал, неотличимый от средника между "настоящими" колонками.


Использование графики в висячих отступах

В этом случае текст заголовка копируется в любую программу подготовки иллюстраций (например, Adobe Illustrator или Macromedia FreeHand) и форматируется там. Затем он сохраняется в отдельном файле и импортируется в PageMaker. В PageMaker он размещается в висячем отступе первого абзаца соответствующего заголовку раздела. Если вам не нравится использование в публикации большого количества внешних связанных файлов, то вставляйте заголовки-"фонарики" по механизму OLE (см. гл. 11). Данный метод создания "фонариков" достаточно трудоемок на этапе создания таких заголовков, но отсутствие проблем при редактировании основного текста с лихвой окупает затраченные усилия. Положение такого "фонарика" относительно базовой линии строки основного текста легко регулируется стандартными для вложенных изображений средствами. Облегчит размещение "фонариков" и описанный выше прием с вклеиванием вложенных изображений из буфера обмена.

Рис. 15.8. Использование вложенных изображений для создания фонариков


Противоположно направленные отступы в сочетании с линейками

Если вы можете примириться с тем, что озаглавленный "фонариком" абзац будет отделен от предыдущего увеличенной на одну-две строки отбивкой, можно воспользоваться менее сложным приемом.

Опишите два стиля с противоположно направленными отступами: один — для абзацев основного текста, второй — для "фонариков". Оформленные по этому методу "фонарики" всегда располагаются выше озаглавленных ими абзацев, как показано на рис. 15.9.

Рис. 15.9. Противоположно направленные отступы для оформления "фонариков" и основного текста

Граница правого отступа абзаца "фонарика" согласована по ширине страницы с границей левого отступа абзаца основного текста. Например, расстояние между границами полей на странице равно 190 мм. Вы хотите разместить "фонарики" во вспомогательной колонке шириной 50 мм со средником, отделяющим ее от колонки основного текста, шириной 5 мм. В описании стиля абзаца "фонарика" задайте величину правого отступа — 135 мм (что оставляет 50 мм по ширине страницы для размещения вспомогательной колонки).

В описании стиля абзацев основного текста задайте величину левого отступа — 55 мм (на 5 мм больше ширины вспомогательной колонки). В результате колонка основного текста будет иметь ширину 130 мм плюс 5 мм средника. Позиции табуляции устанавливать не нужно.

Так же, как в примере с размещением "фонариков" в висячем отступе, текст "фонариков" выровнен по правому краю. Различие состоит в том, что в данном варианте позиция табуляции с выравниванием по правому краю отсутствует. Поскольку "фонарик" располагается в отдельном абзаце, выключку вправо можно задать в стиле оформления этого абзаца.

На форматирование абзаца с "фонариком" не накладывается почти никаких ограничений. В рассматриваемом примере линия (линейка) под абзацем зрительно объединяет "фонарик" с озаглавленным им текстом. Приемы построения асимметричных линеек рассматриваются в разд. "Украшение заголовков " данной главы.

Примечание

В описании стиля абзаца "фонарика" непременно установите флажок Keep with next ... lines (Удержать ... строк следующего абзаца) и задайте количество удерживаемых строк следующего абзаца во избежание отрыва "фонарика" от текста при переходе на следующую страницу.


Оформление смещением базовых линий

Если вы хотите, чтобы "фонарики" были выровнены по отношению к первым строкам озаглавливаемого ими текста, воспользуйтесь приемом противоположно направленных отступов в сочетании со смещением базовой линии текста заголовка. Эффект достигается созданием специального описания стиля абзаца "фонарика", предусматривающего смещение текста абзаца вниз на величину, необходимую для его выравнивания с основным текстом (рис. 15.10).

Для того чтобы определить величину смещения базовой линии, выберите абзац "фонарика" целиком и поэкспериментируйте с элементами индикатора положения базовой линии на управляющей палитре. (Величина смещения должна быть примерно равна значению интерлиньяжа абзаца "фонарика".) Затем полученное в ходе эксперимента отрицательное число следует ввести в описание стиля оформления абзацев "фонариков" с помощью вложенного диалогового окна четвертого уровня Character Options (Дополнительные параметры шрифта).

На иллюстрации (рис. 15.10, а) выделена строка абзаца заголовка, остающаяся над абзацем основного текста. Текст заголовка сместился вниз, но признак конца абзаца остался на месте. Основное преимущество описанного приема оформления "фонариков" состоит в том, что текст вместе с заголовками остается единым материалом. Однако редактировать его лучше все-таки редактором материалов, поскольку при редактировании в режиме макета можно замучиться с выделением текста.

Примечание

Если текст на экране пропадает или воспроизводится не целиком, это говорит об ошибках перерисовки экрана. Большая часть ошибок в этой части PageMaker уже устранена, но не все. Чтобы увидеть текст целиком, форсируйте перерисовку экрана. Для этой цели можно воспользоваться комбинацией клавиш <Ctrl>+<Shift>+<F12> или переключением, режима отображения направляющих с помощью комбинации клавиш <Ctrl>+<J>. Большинство проблем при перерисовке возникает из-за того, что экран перерисовывается по одной строке за раз.

Если вы решите воспользоваться приемом оформления "фонариков" как нижних индексов, вы столкнетесь еще с несколькими проблемами.

а

б

Рис. 15.10. Проблемы с размещением "фонариков" на верху страницы и многострочных "фонариков" решаются при помощи специальных стилей абзацев

Во-первых, если абзац "фонарика" приходится на верх колонки, текст основного абзаца отрывается от ее верхней границы на высоту заголовка (см. рис. 15.10, а), что не всегда допустимо. В обычной ситуации программа PageMaker автоматически корректирует расположение верхних абзацев в колонке, однако в данном случае мы сместили базовую линию заголовка вниз, но признак конца абзаца при этом остался на своем месте и интерлиньяж рассчитывается по его положению.

Для решения этой проблемы необходимо создать специальный стиль для оформления "фонариков" на верху колонки. В описании этого стиля установите интерлиньяж равным одной десятой пункта. Кроме того, необходимо, чтобы все "фонарики", приходящиеся на верх колонки, были однострочными (рис. 15.10, б). (Программа PageMaker позволяет задавать нулевое значение интерлиньяжа, но при этом текст абзаца на экране не воспроизводится. Так что, одна десятая пункта — наименьшее из возможных значений интерлиньяжа, при котором вы видите на экране результаты своих действий.)

Если в публикации имеются двух- и трехстрочные "фонарики", отбивка между "фонариком" и предшествующим ему абзацем будет увеличена в два или три раза (см. рис. 15.10, я). Это означает, что необходимы дополнительные стили для оформления многострочных "фонариков".

Принцип остается тем же, что и для размещения заголовка наверху колонки. Заголовок разбивается по строкам на два абзаца, каждому из которых назначается свой стиль. Стиль для абзаца с первой строкой назначает интерлиньяж 1/10 пункта, а стиль для абзаца со второй строкой — обычный интерлиньяж. Остается только настроить положение базовых линий, и задача решена.

Прием размещения многострочных заголовков срабатывает только в том случае, если строк всего две. Для трех строк этот прием не подходит, поскольку при задании сверхмалого интерлиньяжа, как минимум, две из них будут перекрываться. Единственный выход — избегать трехстрочных "фонариков". Можно либо отредактировать текст заголовка, либо увеличить ширину вспомогательной колонки, если трехстрочные "фонарики" встречаются слишком часто. В любом случае не следует забывать, что заголовки предназначены для структурирования текста, а не для его подмены, и, возможно, ограничить себя двухетрочными "фонариками".

Примечание

Размещение "фонариков" методом смещения базовой линии в сочетании с включенными режимами выравнивания по сетке и линейкам — весьма неудобная процедура. Если вы все-таки решили использовать одновременно эти два приема, сначала поэкспериментируйте как следует и добейтесь, чтобы все заработало, и только после этого зафиксируйте значения всех важных атрибутов и сохраните документ в качестве шаблона. Поверите, делать это второй раз "с нуля" вам не захочется.


Заголовки в подбор

На рис. 15.11 представлен текст, набранный с заголовками в подбор. Такие заголовки, как правило, применяются для низшего уровня подчиненности или для именованных перечней, каждый пункт которых достаточно пространен и имеет свой заголовок.

Рис. 15.11. Текст с заголовками в подбор

Заголовок в подбор чаще всего представляет собой особо отформатированное первое предложение абзаца. Особое форматирование (полужирное или курсивное начертание) внутри абзаца есть локальное форматирование, которое в PageMaker нельзя задать с помощью стиля абзаца. Не располагает PageMaker и специальным инструментом типа стили символов как QuarkXPress 4.O. Тем не менее мы предлагаем несколько способов полуавтоматического создания заголовков в подбор и даже их отдельного переформатирования.

Примечание

Аналогом палитры стилей символов являются дополнения, запоминающие атрибуты форматирования выделенного фрагмента текста и способные впоследствии применить его к другому фрагменту. На этом основано дополнение РадеТуре фирмы Extensis, входящее в великолепный набор дополнений PageTools, и свободно распространяемый сценарий CharStyles, созданный Марком Зидаром.

В исходном состоянии заголовки; которые планируется печатать в подбор, занимают отдельный абзац, имеющий известный стиль, например LocalHeader. Также предполагается, что всем остальным абзацам публикации назначен какой-либо стиль.

Чтобы иметь возможность идентификации символов, входящих в заголовок, набранный в подбор, необходимо пометить их особым атрибутом, который не может быть изменен в процессе верстки. Впоследствии, если возникнет необходимость изменить форматирование таких заголовков, мы сможем с помощью команды Change (Заменить) посимвольно заменить текущие атрибуты символов заголовков на желаемые. С другой стороны, выбранный атрибут не должен сильно искажать внешний вид текста. Самым лучшим выбором, удовлетворяющим этим условиям, является цвет! Если определенным фрагментам текста придать уникальный цвет, их всегда можно будет обнаружить по данному признаку и задать любые атрибуты локального форматирования автоматически. Поэтому первым шагом этого рецепта будет придание заголовкам в подбор уникального цвета. Проще всего это сделать, задав цвет в стиле абзацев таких заголовков. Для того чтобы ни на экране, ни при печати цвет заголовков не отличался от цвета основного текста, определите их цвет как 100%-ный оттенок цвета основного текста (о том, как создавать новые цвета см. гл. 19).

Кроме цвета, на этом этапе разумно задать все требуемые параметры форматирования заголовков в подбор: гарнитуру, кегль, начертание и т. п.

В дальнейшем мы планируем присоединить отдельные абзацы заголовков к следующим за ними абзацам основного текста. При этом те параметры форматирования, которые определяются стилями абзацев заголовков, необратимо исчезнут. Для того чтобы предотвратить такую невосполнимую потерю, нам придется перевести все атрибуты стиля абзацев в атрибуты локального форматирования. Локальное форматирование имеет приоритет над стилями абзацев и не будет утрачено при их изменении. Эта цель достигается назначением абзацам стиля [No Style] ([Без стиля]). Все форматирование символов при этом сохранится, но станет локальным (см. гл. 6).

Эта операция элементарно проделывается с помощью команды Change (Заменить). В качестве шаблона поиска и замены указывается признак конца абзаца " А р". Во вложенном диалоговом окне Change Paragraph Attributes (Изменить атрибуты абзаца) шаблоном поиска задается стиль заголовка LocalHeader, а замены — [No Style] ([Без стиля]). Выполнение замены по этим параметрам отменит стиль всех найденных абзацев.

Теперь можно безбоязненно перенести заголовки в начало следующих за ними абзацев. Для этого достаточно убрать разделяющий их признак нового абзаца и вставить на его место требуемый разделитель — точку, двоеточие, тире и т. п. Поможет нам в этом также команда Change (Заменить). Поиск следует осуществлять по признаку абзаца — "^р" и менять его на выбранный разделитель. В окне Change Paragraph Attributes (Изменить атрибуты абзаца) следует задать стиль объединенных абзацев —^ стиль основного текста. Указать его следует в группе Change to (Заменить на), а в группе Find what (Найти) необходимо выбрать [No Style] ([Без стиля]).

После выполнения замены вы должны увидеть желаемый результат — заголовки, набранные в подбор. Поскольку их символам предусмотрительно присвоен уникальный цвет, при желании вы всегда можете изменить их форматирование или даже удалить. Как мы уже говорили, для этого опять потребуется команда Change (Заменить). Допустим, вы захотите изменить курсивное начертание заголовков в подбор на полужирное. Для этого выберите во вложенном диалоговом окне Change Character Attributes (Изменить атрибуты шрифта) команду Change (Заменить) и цвет заголовков в соответствующем списке группы Find what (Найти), а в группа. Change to (Заменить на) — тот же цвет и атрибут Bold (Полужирный). Выполнение замены приведет к желаемому результату — все заголовки в подбор станут полужирными.

Примечание

Часть локального форматирования не сохраняется при изменении стиля, например позиции отступов и табуляции. Если в заголовке в подбор используется один из этих атрибутов, такой же атрибут нужно задать и в стиле форматирования основного текста.


Украшение заголовков

После того как мы рассмотрели нестандартные способы оформления заголовков, поговорим о нескольких способах украшения традиционных заголовков. Для того чтобы заголовки не только структурировали текст, но и служили средством привлечения к нему внимания читателя, их лучше снабдить графическими элементами. Ниже мы отдельно рассмотрим использование для этой цели линеек и вложенной графики.


Использование линеек

Поскольку декоративные элементы заголовков должны быть привязаны к заголовкам, т. е. должны смещаться относительно них при переформатировании текста, оптимальным средством украшения являются абзацные линейки. Дополнительным преимуществом таких элементов является возможность определения их в стиле самих заголовков, что убережет от ручной работы при необходимости их изменения.

Текст в PageMaker всегда находится "выше" абзацных линеек, что позволяет использовать их в качестве фонового элемента, как на рис. 15.12.

В этом примере задана нижняя линейка шириной немного больше кегля, с одинаковыми отступами от правого и левого краев колонки. Тексту были заданы цвет Paper (Бумага) и положительное смещение относительно базовой линии. Последнее потребовалось для того, чтобы расположить текст точно посередине линейки, т. к. нижняя линейка не может быть смещена вверх относительно базовой линии. Использование второй верхней линейки дает возможность создания дополнительных эффектов (рис. 15.13).

Рис. 15.12. Использование абзацной линейки как фона для заголовка

Рис. 15.13. Оформление заголовка с помощью двух абзацных линеек

Совместное использование разнообразных абзацных отступов, висячих элементов и абзацных линеек различной длины и толщины открывает широкие возможности оживления дизайна публикации. Несколько примеров такого использования приведено на рис. 15.14.

Рис. 15.14. Различные варианты оформления заголовков и основного текста с помощью линеек

Для оформления заголовков можно использовать абзацные линейки не только абзаца, содержащего заголовок, но и соседних абзацев. Примером может служить оформление заголовка-"фортрчки", приведенное на рис. 15.15.

Рис. 15.15. Оформление заголовка-"форточки" с помощью линеек двух абзацев


Использование вложенной графики

Поскольку декоративные элементы заголовка должны быть привязаны к самому заголовку, внешние изображения и иллюстрации необходимо помещать как вложенные. Такие графические элементы делают варианты оформления заголовков неисчерпаемыми. Можно использовать текстуры, виньетки, фотографии и т. п. Примеры подобного оформления заголовков приведены на рис. 15.16.

Примечание

При украшении заголовков не слишком увлекайтесь. Избыток графики затрудняет восприятие текста, несущего главную смысловую нагрузку. Объемные графические фоны используйте только для оформления заголовков верхнего уровня, а для подчиненных заголовков ограничивайтесь линейками или небольшими графическими элементами.

Рис. 15.16. Примеры оформления заголовков вложенными иллюстрациями


Буквицы

Традиции применения буквиц восходят ко временам рукописных манускриптов, когда монахи-переписчики превращали первую прописную букву на странице буквально в произведение искусства, маленький шедевр искусства книжной миниатюры. Выполнить буквицу сегодня при помощи программы PageMaker значительно проще.

Различают три основных типа буквиц: поднятые (raised cap), висячие (hanging cap) и опущенные (drop cap). Буквицы любого из перечисленных типов могут быть дополнительно взяты в рамку.


Поднятые буквицы

Нет ничего проще в смысле технического исполнения, чем поднятая буквица. У первой буквы абзаца просто-напросто увеличивают кегль, как представлено на рис. 15.17.

Рис. 15.17. Поднятая буквица

При создании поднятой буквицы обязательно задавайте фиксированное значение интерлиньяжа. Кроме того, следует иметь в виду, что поднятая буквица зрительно увеличивает отбивку от предыдущего абзаца. Впрочем, обычно буквицей выделяется логически мотивированный разрыв в тексте — чаще всего они встречаются в верхней строке колонки или страницы, в заголовках, в цитатах, размещенных в "форточках", так что видимое увеличение отбивки перед абзацем обычно вполне допустимо.


Опущенные буквицы

Опущенные буквицы "врезаны" в основной текст, как показано на рис. 15.18. Если буквица оформляется гарнитурой и нет необходимости введения окружающего текста в ее оптическое поле, используйте для ее создания дополнение Drop cap (Создать буквицу).

Выделите первую букву абзаца и воспользуйтесь меню Utilities (Сервис). При этом вы можете автоматически перемещаться к предыдущему и последующему абзацам, что очень удобно при необходимости оформить сразу не- сколько буквиц. В диалоговом окне дополнения имеются также кнопки Remove (Удалить) и Apply. (Контроль), сильно упрощающие работу с ним.

Рис. 15.18. Создание опущенной буквицы

Вам достаточно указать, насколько глубоко следует опустить буквицу (т. е. чему будет равна ее высота в строках), а остальное берет на себя дополнение. На рис. 15.18 представлен результат его работы. Буквица выглядит как графическое изображение, но на самом деле это — символ одной из декоративных гарнитур, специально предназначенных для оформления заголовков прописными.

При использовании в оформлении буквиц специальных гарнитур выполните форматирование первой буквы абзаца этой гарнитурой до запуска дополнения. Также имейте в виду, что, поскольку дополнение вставляет в строки абзаца признаки перехода на новую строку, режим переноса слов отключается и при необходимости ввести переносы в строки первого абзаца это придется делать вручную, расстановкой дефисов.

Дополнение Drop cap (Создать буквицу) автоматизирует выполнение целого ряда действий. Ниже приводится их перечень, с которым полезно ознакомиться для того, чтобы потом настраивать буквицу вручную. Итак, дополнение выполняет следующие действия.

  • Увеличивает кегль буквицы до величины, кратной значению интерлиньяжа. Если задана высота буквицы 4 строки, кегль составит учетверенное значение интерлиньяжа.
  • Смещает базовую линию буквицы вниз на величину вновь заданного кегля.
  • Устанавливает позицию табуляции справа от правой границы буквицы.
  • Вставляет в концах строк, следующих за буквицей, признак перехода на новую строку (комбинация клавиш <Shift>+<Enter>) и символ табуляции, приводящий начало следующей строки на новую позицию табуляции. (Отметим, что признак перехода на новую строку, оказавшийся на середине слова, переносит его остаток на новую строку без вставки дефиса, поэтому не забудьте проверить текст за буквицей и вставить вручную дефисы там, где они необходимы.)

Пользуясь этим перечнем, вы можете, при желании, выполнить все действия вручную, если хотите внести какие-либо дополнительные настройки. Например, если вам кажется, что новая позиция табуляции расположена слишком близко или, наоборот, слишком далеко от правой границы буквицы. Ее положение можно откорректировать при помощи линейки диалогового окна Indents/Tabs (Отступы/Табуляция). Этот перечень также понадобится вам при оформлении опущенной буквицы с применением комбинированного метода.


Висячие буквицы

Висячие буквицы, изображенные на рис. 15.19, получены тем же приемом, что и висячие знаки пунктуации, рассмотренные выше. Перед первым символом абзаца был вставлен пробел. Далее выполнялся кернинг для пары "пробел-символ" с помощью комбинации клавиш <Аlt>+<стрелка влево>, и символ оказался "вытянутым" из абзаца. Кегль символа был увеличен, а во втором примере еще использовалось смещение базовой линии вниз.

а

б

Рис. 15.19. Висячие буквицы


Шрифтовые эффекты

Символы текста также могут выступать как художественный инструмент. PageMaker предлагает широкие возможности размещения символов текста относительно друг друга (кернинг, трекинг, смещение относительно базовой линии) и на странице публикации (поворот, отражение, наклон). Использование этих возможностей позволяет добиваться интересных эффектов, которые рассмотрены далее.


Поворот и Наклон

Несколько эффектов, созданных посредством наклона и поворота, приведено на рис. 15.20.

В первом примере строка заголовка просто повернута на 20 градусов. Во втором примере тексту дополнительно придан такой же наклон, чтобы символы располагались вертикально. Такой текст удобнее читать. В сочетании с линейками и графикой можно добиться эффектов, представленных на рис. 15.21.

Рис. 15.20. Поворот и наклон текста

Рис. 15.21. Поворот и наклон текста в сочетании с линейками

Наклон символов в сочетании с асимметричными двойными линейками в первом примере придает заголовку дополнительную динамичность. Одновременное использование прямого и курсивного начертаний в сочетании с наклоном во втором примере привлекает к себе внимание. В третьем примере, кроме линейки, использовано зеркальное отражение, имитирующее тень, отбрасываемую буквами.

Рис. 15.22. Поворот текстовых блоков как средство выделения

Поворот текстовых блоков является очень действенным способом выделения (рис. 15.22). Он может пополнить ваш дизайнерский арсенал, разбивая унылую прямолинейность модульных сеток. Как и любым мощным приемом выделения, поворотом текста не стоит увлекаться, т. к. большое количество выделенного материала приводит к противоположному эффекту — распылению внимания читателя, да и ухудшает читаемость.


Смещение базовой линии и кернинг

Примеры, приведенные на рис. 15.23, получены смещением базовой линии текста и кернингом.

Рис. 15.23. Смещение базовой линии и кернинг позволяют добиваться замысловатого эффекта

Для каждого из символов первого примера было задано различное положительное и отрицательное смещение базовой линии. Вся работа проделана с помощью управляющей палитры. Кегль шрифта взят достаточно крупный, соответствующий заголовку, т. к. большинство шрифтовых эффектов хорошо выглядят только в крупном кегле.

Во втором и третьем примерах одновременно используются смещение базовой линии (за счет этого символы перемещаются по вертикали) и ручной кернинг, смещающий их по горизонтали. Рассмотренный прием также очень хорош для применения в заголовках.


Имитация тени

Самый простой способ имитировать тень, отбрасываемую шрифтом, — подложить под него немного смещенную и менее темную копию (рис. 15.24).

Очевидно, такая тень не выглядит убедительно, т. к. "настоящие" тени имеют мягкие края с переходом от темного к светлому. Имитировать "мягкую тень" можно, дополнив простейшую схему несколькими дополнительными копиями текста с различной плотностью серого (рис. 15.25).

Рис. 15.24. Простейшая имитация тени

Рис. 15.25. Имитация "мягкой тени"

Даже такая тень, к сожалению, далека от реализма, но PageMaker не располагает сложными изобразительными средствами. Для достижения более натуральных эффектов следует обратиться к программам подготовки иллюстраций и фотореалистических изображений.


Специальные эффекты с использованием фреймов

Для получения текстовых блоков непрямоугольной формы в предыдущих версиях PageMaker приходилось прибегать к разнообразным, порой очень сложным, ухищрениям. В настоящей версии эта задача получила легкое решение — фрейм. С их помощью можно очень просто и быстро создавать текстовые блоки любой формы. Как и обычные текстовые блоки, фреймы могут быть связаны в цепочку, по которой текст может перетекать при изменении размеров отдельных фреймов.

Фреймы в издательских программах и текстовых редакторах появились и используются уже очень давно. Для большинства издательских систем (QuarkXPress, Adobe FrameMaker и др.) они являются основным средством размещения графических и текстовых материалов. PageMaker по сравнению с другими издательскими системами имеет иную организацию, основанную на текстовых блоках, обладающую множеством достоинств. Однако фреймы предоставляют очень интересные возможности. Поэтому разработчики PageMaker решили ввести поддержку фреймов в последнюю версию программы. Будучи "чуждой" идеологией, фреймы потребуют от разработчиков неординарных решений по их интеграции с традиционными текстовыми блоками PageMaker. Пока разработчики уклонились от решения проблемы интеграции, сделав фреймы независимым инструментом. Совместное использование их с традиционными текстовыми блоками ограничивается только обтеканием текстом, т. е. фреймы для текстовых блоков представляются графикой. Невозможность связывания текста между фреймами и текстовыми блоками или включения фреймов в текст как вложенной графики ограничивает широчайшие потенциальные возможности фреймов сферой специальных эффектов. Авторы очень надеются, что PageMaker 7.0 органично интегрирует фреймы в свою среду и это на порядок расширит его возможности, очень сильно облегчив жизнь дизайнерам и верстальщикам, т. е. нам с вами.


Фреймы

Фрейм очень напоминает обычный графический объект PageMaker: прямоугольник, эллипс или многоугольник (рис. 15.26 и 15.27). Он также может иметь заполнение, цвет и обводку. Разница заключается в том, что фрейм имеет содержимое — изображение или текст. Фреймы, содержащие текст, могут быть связаны как текстовые блоки. При этом текст, составляющий один материал, может перетекать из одного фрейма в другой. Эта возможность позволяет легко создавать шаблоны для размещения текстов на страницах и заполнять их по необходимости различными материалами. Родственные отношения графических примитивов и фреймов подчеркивают возможность их взаимного преобразования соответствующей командой Change to Frame (Заменить на фрейм) или Change to Graphic (Заменить на изображение) меню Element (Элемент) подменю Frame (Фрейм). Для фреймов эта команда работает, только если фрейм пуст. Другим способом создания фрейма является его непосредственное рисование с помощью инструментов Rectangle frame (Прямоугольный фрейм), Ellipse frame (Овальный фрейм), Polygon frame (Многоугольный фрейм) палитры инструментов. Рисование фреймов ничем не отличается от рисования графических примитивов, рассмотренного в гл. 9.

Рис. 15.26. Создание фрейма

Рис. 15.27. Готовые фреймы

Текстовое или графическое содержание помещается во фрейм с помощью команды Attach Content (Добавить содержимое), входящей в состав вложенного меню Frame (Фрейм) из меню Element (Элемент), или комбинации клавиш <Ctrl>+<F> (рис. 15.28). Текст и фрейм должны быть предварительно выделены. Обратная операция выполняется той же комбинацией клавиш или командой Separate Content (Отделить содержимое) из того же меню Element. Поместить текст во фрейм можно также вклеиванием его из буфера обмена. Перед вклеиванием необходимо щелкнуть курсором инструмента Text (Текст) во внутренней области фрейма. Если текст или изображение помещаются в публикацию из внешнего текстового или графического файла, то для размещения их внутри фрейма можно либо предварительно выделить фрейм, либо щелкнуть на нем при появлении пиктограммы загрузки (рис. 15.29).

Операция связывания фреймов с текстом в цепочку аналогична размещению текстовых блоков. После выделения фрейма инструментом Pointer (Стрелка) в середине его верхней и нижней границ появляются уже знакомые нам индикаторы (рис. 15.30).

Если во фрейме помещается не весь вставленный в него текст, нижний индикатор будет иметь красный цвет и изображение треугольной стрелки, показывающие, что фрейм содержит неразмещенный текст. Щелчок мышью на этом индикаторе включает режим связывания фреймов. Курсор при этом приобретет вид трех звеньев цепочки с черной треугольной стрелкой. Теперь достаточно щелкнуть им во внутренней области предварительно созданного пустого фрейма, чтобы тот оказался связанным с первым. При этом неразмещенный текст появится в связанном фрейме. Если размеров второго фрейма недостаточно для размещения всего материала, следует создать новый фрейм и повторить операцию связывания фреймов.

Рис. 15.28. Изображение и текст внутри фреймов

Примечание

Если при рисовании фрейма одним из соответствующих инструментов удерживать клавишу <Ctrl>, новый фрейм окажется связанным с последним созданным фреймом.

Рис. 15.29. Связывание фреймов

Рис. 15.30. Связанные фреймы

Связи между фреймами могут быть в любой момент разорваны. Для разрыва связей между фреймами достаточно, удерживая комбинацию клавиш <Ctrl>+<Shift>, щелкнуть на нижнем индикаторе первого фрейма или верхнем индикаторе второго. В результате данной операции размещенный во втором фрейме материал перемещается в первый и текст больше не может перетекать между этими фреймами. Второй фрейм в таком случае окажется пустым. Впрочем, разорванную связь можно восстановить, действуя тем же способом, что и при первоначальном связывании фреймов с размещением текста. Исключить отдельный фрейм из цепочки связанных фреймов проще всего командой Remove from Threads (Исключить) подменю Frame (Фрейм) меню Element (Элемент). Исключенный фрейм оказывается пустым, а находившийся в нем материал перемещается в следующий фрейм, если таковой существовал.

Положение материала во фрейме можно задать в диалоговом окне Frame Options (Параметры фрейма), вызываемом одноименной командой из того же меню или комбинацией клавиш <Alt>+<Ctrl>+<F> (рис. 15.31). Разумеется, перед вызовом данного диалогового окна фрейм, для которого вы хотите задать параметры, должен быть выделен инструментом Pointer (Стрелка).

В этом диалоговом окне можно задать вертикальное и горизонтальное выравнивание содержимого относительно границ фрейма, отступы от границы фрейма, параметры обрезки содержимого или масштабирования фрейма. Для каждого фрейма доступна только часть параметров. Если это прямоугольный текстовый фрейм, то предоставляется возможность выбора вертикальной выключки текста и отступы от границ фрейма. Для непрямоугольного фрейма нельзя определить вертикальную выключку в поле Vertical alignment (Вертикальная выключка), а отступ от границ фрейма должен быть одинаковым со всех сторон. Он задается в поле Inset (Отступ).

Если фрейм содержит изображение, поля ввода отступа от краев становятся недоступны, но открывается возможность определить, как следует поступать

Рис. 15.31. Диалоговое окно Frame Options с изображением, находящимся внутри фрейма. При этом предлагаются такие варианты.

  • Clip content to fit frame (Обрезать содержимое по размеру фрейма). Если размер изображения превышает размер содержащего его фрейма, видимой остается только та его часть, которая помещается во фрейм. Фрейм становится "окном", через которое можно рассматривать фрагменты изображения. Переместить изображение, находящееся за этим окном, можно, перетащив его инструментом Cropping Tool (Рамка). Очевидно сходство этого режима с функцией кадрирования (см. гл. 10).
  • Size frame to fit content (Настроить размер фрейма по содержимому). Фрейм по этой команде принимает размеры содержащегося в нем изображения. При последующем изменении размеров фрейма он ведет себя так, будто включен первый режим. Для изменения размеров изображения придется проделать многоступенчатую процедуру отделения изображения от фрейма, масштабирования его и помещения обратно во фрейм. Для того чтобы опять настроить размер фрейма по размеру содержащегося в нем отмасштабированного изображения, вам придется снова воспользоваться командой из диалогового окна Frame Options (Параметры фрейма). Более простой метод одновременного масштабирования изображения и фрейма дает следующий режим.
  • Scale content to fit frame (Масштабировать содержимое по размеру фрейма). Этот вариант поведения фрейма является режимом, а не однократной командой, как предыдущий. При изменении размеров фрейма будет отмасштабировано и содержащееся в нем изображение. Переключатель Maintain aspect ratio (Сохранять пропорции) обеспечивает поддержание постоянного соотношения сторон изображения. Если фрейм масштабируется непропорционально, внутри него остается пустое место, которое может быть удалено предыдущей командой. Масштабирование фрейма абсолютно аналогично масштабированию графических примитивов. Как вы помните, удерживание клавиши <Shift> в процессе масштабирования приводит не к пропорциональному изменению размеров примитивов, а к превращению их в правильные фигуры (см. гл. 9). То же самое происходит и с фреймами. Поэтому добиться пропорционального масштабирования фрейма с помощью клавиши <Shift> не удается. В результате такого масштабирования получается фрейм правильной формы. Тем не менее пропорциональное масштабирование фрейма возможно. Так же, как и в случае с графическими примитивами, оно может быть осуществлено с помощью управляющей палитры при включенном в ней режиме пропорционального масштабирования. В соответствующих полях палитры инструментов необходимо ввести либо новые размеры фрейма, либо коэффициент масштабирования.


Фигурный текст

После нашего краткого описания фреймов способ создания фигурного текста очевиден — проще всего вставить текст во фрейм нужной формы. На рис. 15.32 приведены примеры фигурного текста, созданного с помощью прямоугольного, эллиптического и многоугольных фреймов.

Рис. 15.32. Примеры фигурного текста, созданного с помощью фреймов

Как видите, с помощью многоугольных фреймов можно создавать очень сложные контуры. Более того, они могут быть даже незамкнутыми или самопсресекающимися (рис. 15.33).

Рис. 15.33. Незамкнутые и самопересекающиеся фреймы

Примечание

Даже если фрейму не задан цвет обводки, на экране серым контуром отображается его граница. Эта граница служит только для визуализации положения и размеров фрейма, а на печать не выводится. Если вы хотите взглянуть на страницу без отображения границ фреймов, выполните команду Hide rulers (Спрятать направляющие) меню View (Просмотр). Разумеется, при этом с экрана исчезнут поля, направляющие и границы колонок. Для того чтобы снова вернуться в режим отображения границ фреймов, выполните команду Show rulers (Показать направляющие) того же меню.

Наклон фрейма приводит к тем же результатам, что и наклон текстового блока: при этом изменяется и наклон шрифта. Для того чтобы, например, получить текст, вписанный в параллелограмм, следует не наклонять прямоугольный фрейм, а создать фрейм такой формы с помощью инструмента Polygon frame (Многоугольный фрейм) (рис. 15.34).

а

б

Рис. 15.34. Многоугольный фрейм и наклоненный прямоугольный фрейм со вставленным в них текстом


Обтравка изображений

Фреймы позволяют создавать не только фигурный текст, но и фигурные изображения. Для этого можно поместить изображение внутрь многоугольного фрейма и отредактировать контур фрейма тем же самым способом, которым вы редактировали многоугольники, нарисованные PageMaker (см. гл. 9). Тем не менее нам представляется, что такой способ годится только для изображений с правильными контурами. Для качественной обтравки вам неминуемо придется включить режим отображения графики в высоком разрешении, т. к. в противном случае не будет видна четкая граница обтравливаемого объекта. При перемещении любой точки контура PageMaker перерисовывает изображение, что в высоком разрешении занимает существенное время. Кроме того, PageMaker 7.0 не поддерживает кривых Безье как границ контуров, что не позволяет создавать в нем достаточно плавные контуры обтравки (рис. 15.35). Эти доводы говорят в пользу обтравки во внешних программах подготовки иллюстраций или фотоизображений. Об импортировании в PageMaker обтравленных изображений уже говорилось в гл. 10.

Заметим, что помещение изображения во фрейм эквивалентно его маскированию. Эффекта, приведенного на рисунке, можно добиться, нарисовав обтравочный контур инструментом Polygon (Многоугольник), а затем маскировав им фотоизображение.

Рис. 15.35. Обтравочный контур создан в PageMaker


Рамки

Фреймы представляют собой весьма удобный инструмент для создания рамок. Фрейму, как уже отмечалось выше, может быть задан любой тип и цвет обводок и заполнений. Для выделения фрагментов текста широко применяются врезки и форточные заголовки (рис. 15.36).

Рис. 15.36. Врезка и форточный заголовок, созданные с помощью фреймов

PageMaker трактует фрейм как графический примитив и для него также может быть определен контур обтекания текстом. Редактирование контура обтекания осуществляется тем же способом, что и для графических примитивов (см. гл. 14).

К сожалению, фреймы не могут быть вложены в текст для фиксации их положения в определенном фрагменте текста. Это не дает возможности использовать их для создания выделений фрагментов основного текста. При необходимости создания такого эффекта мы рекомендуем применить один старый прием. Рамка рисуется с помощью инструмента Rectangle (Прямоугольник), а затем помещается в текст как вложенное изображение. Рамку следует размещать на отдельной строке, которой назначен нулевой интерлиньяж. После того как рамка помещена, с помощью инструмента Pointer (Стрелка) можно придать ей требуемые размеры и положение относительно выделяемого текста. Еще более сильного выделения фрагмента текста можно достичь, задав рамке какой-либо цвет или заполнение (рис. 15.37).

Рис. 15.37. Рамки как вложенные изображения

Если текст, помещаемый в рамку, находится в отдельном текстовом блоке, то для создания рамки вокруг него можно воспользоваться дополнением Fill and Stroke . Главное диалоговое окно этого дополнения изображено на рис. 15.38.

В нем можно определить, куда следует помещать созданную рамку — перед или сзади текстового блока; задать увеличенный или уменьшенный размер рамки относительно блока; включить маскирование рамкой нижележащих объектов. Заполнение и обводка рамки задаются во вложенном диалоговом окне Fill and Stroke (Фон и линия), открывающемся кнопкой Attributes (Атрибуты). Это окно аналогично окну Fill and Stroke (Фон и линия), вызываемому одноименной командой меню Element (Элемент) (см. гл. 9).

Рис. 15.38. Дополнение Fill and Stroke

Примечание

Такое использование дополнения Keyline (Создать рамку) не является его высшим и единственным предназначением. Рамки часто требуется создавать, чтобы избежать треппинга. (Подробнее об этом см. гл. 21.)

В предыдущих версиях PageMaker дополнение Keyline (Создать рамку) было самым простым и удобным способом проделать эту работу. Фреймы представляют собой еще более совершенный инструмент, способный справиться с этой задачей. При использовании фреймов отпадает необходимость заботиться о поддержании соответствия размера текста внутри рамки и размеру самой рамки, т. к. текст не может покинуть ее пределы. Это одна из многих причин, по которым предпочтение в таких случаях все же следует отдавать фреймам.


Резюме

В этой главе мы описали наиболее часто встречающиеся случаи верстки, которые требуют нестандартных решений или знания специальных возможностей PageMaker. Безусловно, приведенные примеры не исчерпывают всего многообразия "хитростей", употребляющихся для придания публикации привлекательного и оригинального вида. Если вы обладаете достаточной изобретательностью и знанием программы, то обязательно пополните этот перечень своими находками, без которых ваша публикация будет выглядеть слишком "стандартно".

Кроме особых приёмов, рассмотренных в данной главе, есть еще обширный класс публикаций, требующих оригинальных подходов к верстке, — таблицы и бланки. Эти часто встречающиеся типы документов описаны в следующей главе.


  • Глава 16. Верстка таблиц и бланков
    • Верстка таблиц с помощью Adobe Table 3.0
      • Создание новой таблицы
      • Помещение таблицы в публикацию
      • Размещение длинных таблиц
      • Построение таблицы
      • Ввод данных
      • Операции с ячейками
      • Форматирование текста в таблице
      • Установка параметров линеек и фона
      • Установка умолчаний в Adobe Table
    • Импорт таблиц
      • Общие замечания об импорте таблиц
      • Импорт таблиц из текстовых файлов
      • Импорт электронных таблиц и баз данных
      • Импорт таблиц из файлов текстового процессора
    • Форматирование таблиц и бланков
      • Стили предварительного форматирования
      • Разметка стилей в текстовом файле без форматирования
      • Обработка данных после импорта
      • Разметка колонок
      • Линейки в таблицах
    • Оформление бланков
      • Расстановка полей для отметки
      • Верстка полей для вписывания
    • Печать с переменными данными
      • Создание файла базы данных
      • Создание шаблона публикации с переменными данными
      • Помещение данных
    • Резюме


ГЛАВА 16.

Верстка таблиц и бланков

Материал этой главы содержит информацию по следующим вопросам:

  • Табличный редактор Adobe Table
  • Способы помещения сверстанной таблицы в публикацию
  • Размещение длинных таблиц
  • Работа по созданию и форматированию таблицы
  • Установка умолчаний в Adobe Table
  • Форматирование таблиц средствами PageMaker
  • Импорт таблиц из порождающих приложений
  • Форматирование таблиц
  • Оформление бланков
  • Печать с переменными данными

PageMaker, к сожалению, до сих пор не имеет специального средства для верстки таблиц, как, например, Microsoft Word. Это упущение разработчиков не назовешь иначе как весьма досадным. В какой-то мере отсутствие встроенного инструмента компенсируется отдельной программой Adobe Table 3.0, поставляемой с PageMaker 7.0. Несмотря на достаточно широкие возможности по настройке текста, Adobe Table имеет несколько настолько существенных недостатков, что отказ от ее использования при достаточно большом размере таблиц неизбежен.

При необходимости верстки многостраничных таблиц мы рекомендуем пользоваться не какими-либо внешними программами, а просто богатейшими возможностями форматирования текста, которые предоставляет PageMaker. Если вы выбираете этот путь, то даваемые в настоящей главе рекомендации сослужат вам хорошую службу. Особенностям верстки таблиц средствами PageMaker посвящена вторая часть данной главы.


Верстка таблиц с помощью Adobe Table 3.0

Таблица, созданная Adobe Table, как правило, помещается в публикацию посредством OLE, т. е. таблица для PageMaker является внедренным изображением. Изображение занимает большое количество ресурсов и времени на печать и отрисовку. Adobe Table также имеет возможность экспортировать сверстанную таблицу в формат EPS.

В пределах табличного редактора не поддерживается многостраничность. Для верстальщика это означает, что для каждой страницы, скорее всего, придется создавать отдельную таблицу, даже если это просто одна длинная таблица. Неудобства такого способа работы очевидны.

Примечание

Таблица, при стандартном использовании редактора, существует в публикации в единственном экземпляре как внедренный объект и хранится в ее файле. Для сохранения таблицы отдельно от файла публикации нужно осуществить специальные шаги, о которых речь пойдет ниже.


Создание новой таблицы

Для помещения таблицы в публикацию в качестве внедренного объекта откройте диалоговое окно Insert Object (Вставить объект), оно вызывается одноименной командой меню Edit (Редактирование) (рис. 16.1).

Рис. 16.1. Диалоговое окно Insert Object

В списке Object Type (Тип объекта) следует выбрать Adobe Table 3.0 и щелкнуть на кнопке ОК. После этого будет" загружен табличный редактор, в котором и будет сверстана таблица. Когда "верстка закончится, вы можете закрыть Adobe Table — на странице публикации при этом останется изображение таблицы. С ним можно манипулировать как с внедренным графическим изображением: перемещать, масштабировать, поворачивать, наклонять или кадрировать. Редактирование таблицы, как и любого внедренного OLE-объекта, возможно только во внешнем приложении. Двойной щелчок на нем мышью вызовет загрузку Adobe Table с уже открытой в нем таблицей, готовой для редактирования. Двойному щелчку соответствует команда Edit Adobe Table Object (Редактирование Adobe Table Object) из меню Edit (Редактирование). В процессе редактирования можно не беспокоиться о ее обновлении в публикации — это происходит автоматически.

Adobe Table может быть открыта и как самостоятельное приложение. Программа установки PageMaker создает для него в главном меню (start menu) отдельный ярлык. После запуска в ней верстается требуемая таблица, которая затем сохраняется в файле табличного редактора, имеющем расширение tbl. Созданная таблица может быть помещена в публикацию как OLE-объект либо через буфер обмена, либо созданием из файла.

Примечание

Даже если вы запускаете Adobe Table как OLE-сервер командой Insert Object (Вставить объект), сохраняйте сверстанную таблицу в отдельном TBL-файле. Это не приводит к значительным затратам дискового пространства, зато гарантирует от переверстки в случае сбоя PageMaker.


Помещение таблицы в публикацию

Сверстанную таблицу помещают в публикацию по механизму OLE или PageMaker Links. Если таблица была создана командой Insert Object (Вставить объект), то она уже при создании была внедрена в публикацию. В остальных случаях для внедрения таблицы требуется осуществить специальные действия.

Если таблица была создана в Adobe Table, запущенной отдельно, перенести ее на страницу PageMaker можно и через буфер обмена. Таблица, вставленная через буфер, также является внедренным OLE-объектом.

OLE-объект может быть создан из файла таблицы без ее открытия в редакторе таблиц. Диалоговое окно Insert Object (Вставить объект) имеет переключатель, который в положении Create from File (Создать из файла) позволяет выбрать файл с таблицей, которая должна быть помещена в публикацию (рис. 16.2).

Нажатие кнопки Browse (Путь) открывает стандартное файловое диалоговое окно Windows, избавляющий вас от ввода имени файла и пути к нему. Обратите внимание на флажок Link (Связь). Он позволяет определить таблицу в качестве связанной. В этом случае она может быть отредактирована не только из публикации, но и отдельно. При открытии публикации, содержащей такую таблицу, PageMaker автоматически обновит ее. Если редактирование производилось при открытом файле публикации, обновить таблицу можно, воспользовавшись командой Links Manager (Связанные файлы) меню File (Файл), так, как это описано в гл. 11.

Рис. 16.2. Помещение в публикацию файла табличного редактора

На наш взгляд предпочтительным является использование механизма PageMaker Links при связывании с публикацией графических файлов, созданных во внешних приложениях. Поскольку PageMaker не имеет фильтров импорта файлов Adobe Table 3.0, приходится экспортировать таблицы в файлы EPS командой Graphic (Изображение) вложенного меню Export (Экспортировать) меню File (Файл). Получившийся PostScript-файл может быть помешен в публикацию обычным фильтром импорта PageMaker по команде Place (Поместить) из меню File (Файл). Единственное неудобство такого способа заключается в необходимости хранения и TBL- и EPS-файлов для каждой таблицы, но преимуществ, перекрывающих этот недостаток, много. (Подробнее они также приведены в гл. 11.)

Примечание

Помещайте таблицы как вложенные в текст. Это позволит вам зафиксировать положение таблицы относительно сопровождающего ее текста. Для этого следует выполнить команду Insert Object (Вставить объект) или Place (Поместить) при активном инструменте Text (Текст) и курсоре, расположенном в соответствующем месте текста.


Размещение длинных таблиц

Хотя Adobe Table не позволяет создавать таблицы, занимающие несколько страниц, обходные пути разбивки длинной таблицы ~я.о страницам публикации есть. Таких приемов несколько.

  • Разбиение таблицы на фрагменты, соответствующие длине страниц публикации. В этом случае для каждой страницы создается отдельная таблица и размещается одним из приведенных выше способов. Недостаток такого пути очевиден. При редактировании таблицы разбивку придется производить снова. Данный путь следует выбирать, только если вы уверены, что корректура не затронет разбиения таблицы по страницам.
  • Кадрирование таблицы по размерам страницы. Согласно этому методу таблица копируется целиком на каждую страницу публикации, которую она должна занимать. Затем с помощью кадрирования инструментом Cropping Tool (Рамка) на страницах оставляется только та часть таблицы, которой отведена данная страница. Такой метод тоже не лишен недостатков. Главные из них — большое потребление дискового пространства и сильное возрастание времени печати. Дело в том, что PostScript-принтеры обрабатывают изображение целиком: сначала в память принтера загружается все изображение, а затем отсекаются не попавшие в кадр части. В результате таблица будет загружена в принтер столько раз, сколько страниц она занимает. Возникнут проблемы и с таблицами, длина которых превышает размеры рабочего стола.
  • Комбинированный метод, предполагающий и разбиение таблицы на страницы с некоторым "запасом", и кадрирование фрагментов. Поскольку фрагменты перекрываются, это обеспечивает резерв для корректуры.

Ни один метод не представляет собой строгого решения проблемы верстки таблиц. Как мы уже говорили, она вообще неразрешима средствами PageMaker существующих версий. Но верстать-то приходится.


Построение таблицы

Независимо от способа создания таблицы, работа с ней начинается с диалогового окна New Table (Новая таблица), где указываются ее общие параметры. По сути, это окно напоминает окно Document Setup (Параметры документа) PageMaker, которое также неизбежно возникает при создании новой публикации. Окно параметров вызывается по команде New (Новый) из меню File (Файл) или Format Cells (Формат ячеек) меню Format (Формат). Или комбинациями клавиш, служащими эквивалентами этих команд, соответственно <Ctrl>+<N> и <Ctrl>+<F> (рис. 16.3). Разница между окнами, открываемыми названными командами, заключается лишь в названии и в том, что окно New Table (Новая таблица) имеет дополнительную кнопку More (Еще), которая позволяет задать дополнительные параметры.

Если при создании таблицы точно не известно, сколько строк и столбцов может потребоваться, то в полях группы Layout (Структура) введите их приблизительное число. Эти цифры могут быть изменены в любой момент командами вставки строк и столбцов, а также командой Format Cells (Формат ячеек). Таблица с параметрами, представленными на рис. 16.3, приведена на рис. 16.4. В настоящей версии табличного редактора присутствует контекстное меню, открываемое щелчком правой кнопки мыши в окне редактора. Из контекстного меню можно легко получить доступ к наиболее часто используемым функциям форматирования таблицы, таким как размер отображения таблицы на экране, вырезание и вклеивание текста, формат ячеек и текста, операции группирования ячеек и др. На рис. 16.4 приведено контекстное меню вновь созданной таблицы.

Рис. 16.3. Диалоговое окно New Table

Рис. 16.4. Новая таблица и контекстное меню

Если у вас имеется опыт работы с электронными таблицами или редактором таблиц в составе текстового процессора, то вы увидите, что все работает вполне логичным образом. Некоторые особенности работы редактора приводятся ниже.

  • В диалоговом окне New Table (Новая таблица) ширина и высота ячеек таблицы определяются по заданным габаритным размерам и количествам строк и столбцов в таблице.
  • Предельные размеры таблиц, с которыми работает Adobe Table, составляют 40x40 дюймов, с количеством столбцов и строк не более 100.
  • Группа элементов управления Table gutters (Интервалы между ячейками) задает размеры средников — свободного пространства, отделяющего столбцы и строки друг от друга.

Изменения, внесенные в палитры Adobe Table, становятся видны на экране после нажатия клавиши <Enter>.

Пример макета таблицы, выполненного в Adobe Table, представлен на рис. 16.5.

Рис. 16.5. Макет таблицы в Adobe Table


Ввод данных

Ввод данных в ячейки таблицы выполняется с клавиатуры. Проще не бывает. Хотя в большинстве случаев вы будете вводить данные в ячейки таблицы вручную, альтернатива все-таки имеется. Есть возможность импортировать в таблицу данные в текстовом формате (не путать с форматом документов текстового процессора). Выберите в меню File (Файл) команду Import Text (Импортировать текст) и укажите способ разделения значений в пределах строки текста — символами табуляции или запятыми.

В процессе ввода данных вам придется переходить по макету из одной ячейки в другую. В табл. 16.1 перечислены клавиши и комбинации клавиш, с помощью которых осуществляется переход в таблице.

Таблица 16.1. Клавиши и комбинации клавиш для управления курсором в Adobe Table 3.0

Действие | Клавиши | Примечание
Переход на один символ вправо | <Стрелка вправо> | После правого крайнего символа в ячейке эквивалентно переходу на одну ячейку вправо
Переход на один символ влево | <Стрелка влево> | Перед левым крайним символом в ячейке эквивалентно переходу на одну ячейку влево
Переход на одну ячейку вправо | <Таb> | В правой нижней ячейке таблицы эквивалентно добавлению строки таблицы
Переход на одну ячейку влево | <Shift>+<Tab> | Не действует в крайней левой ячейке
Переход на одну строку или ячейку вверх | <Стрелка вверх> | Не действует в ячейке верхнего ряда
Переход на одну строку или ячейку вниз | <Стрелка вниз> | Не действует в ячейке нижнего ряда
Переход в левую верхнюю ячейку таблицы | <Ноmе> | —
Переход в правую нижнюю ячейку таблицы | <End> | —
Вставка признака конца абзаца в текст ячейки (не вводит данные) | <Enter> | —
Вставка символа табуляции в текст ячейки (без перехода к соседней ячейке) | <Ctrl>+<> |

Для форматирования текста и линеек необходимо выделять отдельные ячейки, фрагменты текста в ячейках, строки, столбцы, а иногда — всю таблицу.

  • Чтобы выделить ячейку (перед вводом данных или заданием линеек), щелкните на ней мышью или перейдите в нужную ячейку одной из комбинаций клавиш, приведенных в табл. 16.1.
  • Текст в ячейке выделяют так же, как в обычном текстовом редакторе: перетаскиванием указателя мыши, клавишами курсора при нажатой клавише <Shift>. Двойной щелчок на слове выделяет его целиком.
  • Для выделения всего текста внутри ячейки щелкните мышью на ее среднике или выберите команду Select All (Выделить все) в меню Edit (Редактирование) или нажмите комбинацию клавиш <Ctrl>+<A>.

Для выделения группы ячеек выполните одно из следующих действий:

  • протащите курсор по диагонали группы выделяемых ячеек;

  • нажмите клавишу <Shift> и выполните один щелчок мышью в верхней левой ячейке выделяемой области. Затем, не отпуская клавишу <Shift>, выполните щелчок мышью в правой нижней ячейке выделяемой области;
  • для того чтобы выделить несмежные ячейки, держите нажатой клавишу <Ctrl> и выделите ячейки по очереди щелчками мыши;
  • для выбора строк и колонок щелкайте мышью на серых кнопках, расположенных слева и сверху от таблицы. Чтобы выбрать таблицу целиком, щелкните мышью на квадратной серой кнопке в верхнем левом углу таблицы.


Операции с ячейками

По мере ввода данных в таблицу вам могут потребоваться новые столбцы или строки, или, наоборот, возникнет необходимость удалить ранее созданные столбцы или строки. После ввода всех данных в таблицу необходимо оформить ее внешний вид, меняя ширину и высоту ячеек с данными.

Если в процессе ввода данных вам не хватит ячеек, редактор таблиц автоматически добавит новую строку после нажатия клавиши <ТаЬ> в правой нижней ячейке таблицы. При добавлении новых строк и колонок таблицы их ячейки принимают атрибуты форматирования соседних с ними ячеек. Новые строки или колонки можно добавить при помощи команд меню. Для этого перейдите в соответствующую ячейку таблицы и выберите в меню Cell (Ячейка) команду Insert Row Above (Вставить строку над) или Insert Row Below (Вставить строку под) для вставки строк и команду Insert Columns Before (Вставить столбец до) или Insert Columns After (Вставить столбец после) для вставки столбцов.

Примечание

Если перед выбором команды вставки строк или столбцов выделить несколько строк или столбцов, количество вставляемых структурных единиц таблицы будет равно количеству структурных единиц выделенных. Например, если в момент выбора команды вставки строк было выделено восемь строк, то и новых строк будет вставлено восемь.

Наращивать число строк и столбцов в таблице можно также в диалоговом окне Format Cells (Формат ячеек). Строки добавляются снизу, а столбцы — справа от ранее созданных. Доступ к названной операции можно осуществить и из контекстного меню. Для изменения числа строк или столбцов предварительно установите указатель мыши на одной из серых кнопок, расположенных в начале столбца или строки таблицы. Затем щелкните правой кнопкой мыши и выберите нужную команду в открывшемся меню. Вид меню показан на рис. 16.6.

Рис. 16.6. Контекстное меню Adobe Table 3.0

Выделенные строки или столбцы удаляются из таблицы командой Delete (Удалить). Удалять разрешается только смежные группы структурных элементов таблицы. В зависимости от того, что было выделено, команда удаления будет удалять либо строки, либо столбцы. Удаление можно производить с помощью контекстного меню так же, как и вставку столбцов и строк.

При формировании шапок и заголовков возникает задача объединения нескольких смежных ячеек в одну. Для этого достаточно выделить все ячейки, подлежащие объединению, и выбрать в меню Cell (Ячейка) команду Group (Сгруппировать) (комбинация клавиш <Ctrl>+<G>). На рис. 16.7 представлен внешний вид макета таблицы до (а) и после (б) группирования ячеек.

а

б

Рис. 16.7. Объединение ячеек таблицы командой Group

Для того чтобы разгруппировать ранее сгруппированные ячейки, используйте команду Ungroup (Разгруппировать) того же меню. Создание и разбиение группы ячеек также можно производить из контекстного меню, предварительно выбрав нужные для этой операции ячейки.

Наиболее часто высоту строки таблицы регулируют наполнением ее ячеек текстом — по мере свертки строк текста высота строки таблицы растет. Причем увеличивается высота не только той ячейки, в которой находится многострочный текст, но и других ячеек той же строки таблицы.

Для регулировки размеров ячеек вручную существует четыре способа. Сфера действия любого из них распространяется либо на строки в целом, либо на столбцы в целом, либо на всю таблицу. (Регулирование размера отдельной ячейки возможно только за счет ее группирования с соседними ячейками.)

  • Самый простой способ изменения ширины столбца или высоты строки состоит в перетаскивании смежного средника при помощи мыши. Этот прием позволяет визуально контролировать размещение текста в ячейках. Для начала перетаскивания указатель мыши следует установить на линию, разделяющую серые кнопки выделения строк или колонок, — при этом он примет форму двуглавой стрелки, как показано на рис. 16.8.

    Отметим, что в процессе осуществления данного приема можно зафиксировать общие размеры таблицы. Обычно при перетаскивании средника меняется размер только одной колонки или строки, а остальные структурные элементы таблицы сохраняют свои размеры. Как следствие, габаритные размеры таблицы меняются. Если в процессе перетаскивания средника удерживать нажатой клавишу <Shift>, размеры смежной строки или смежного столбца будут изменяться в противоположном направлении, компенсируя общее изменение размеров. В результате габаритные размеры таблицы останутся неизменными.

Рис. 16.8. Изменение ширины колонки перетаскиванием средника

  • Изменять размеры столбцов и строк таблицы можно также при помощи команды меню Row/Column Size (Размер строк/столбцов) меню Cell (Ячейки). Выделите любую ячейку столбца или строки, размеры которых следует отрегулировать, и выберите названную команду. В открывшемся диалоговом окне введите значение размера и щелкните мышью на кнопке ОК. Команда удобна тем, что позволяет изменять ширину столбца и высоту строки, содержащей активную ячейку как порознь, так и одновременно. Кроме того, перед выбором команды можно выделить более чем одну строку или несколько столбцов.

    Если вы хотите визуально контролировать изменение размеров структурных элементов таблицы, воспользуйтесь палитрой таблицы, которая раскрывается по команде Show Table Palette (Показать палитру "Таблица") меню Window (Окно) или с помощью комбинации клавиш <Ctrl>+<8>. Для регулировки размеров можно либо воспользоваться кнопками настройки, представленными на рис. 16.9, либо ввести требуемые значения размеров в соответствующие поля индикаторов. Для того чтобы введенные в поля значения повлияли на размеры структурных элементов, необходимо перевести активность на другой элемент управления палитры, нажав клавишу <Таb> или <Enter>. При работе с кнопками настройки одновременное нажатие клавиши <Ctrl> увеличивает значение шага настройки в десять раз.

Рис. 16.9. Палитра Table Attributes

  • Размеры строк и столбцов можно задать для всей таблицы сразу в диалоговом окне Format Cells (Формат ячеек) (комбинация клавиш <Ctrl>+ +<F>). На экране появится диалоговое окно с предупреждением о том, что возможные преобразования могут сильно изменить макет таблицы. Введите габаритные размеры таблицы в соответствующие поля. Приращение или сокращение габаритного размера будет распределено по отдельным строкам и столбцам. Если размеры столбцов или строк были одинаковыми до изменения габаритного размера, то и после него они останутся одинаковыми. Если размеры структурных элементов до изменения габаритного размера таблицы были различными, они останутся различными, но приращение или сокращение габаритного размера будет распределено по ним в равных долях. Если необходимо визуально проконтролировать результаты изменения габаритных размеров, щелкните мышью на кнопке Apply (Применить). После этого изменения отразятся на экране, но пока не будет выполнен щелчок мышью на кнопке ОК, изменение размеров таблицы можно отменить.

    Как и предыдущие операции, размер строк и столбцов можно изменять, пользуясь контекстным меню. Предварительно необходимо выделить нужный элемент таблицы.

    Еще один параметр оказывает косвенное воздействие на размер столбцов и колонок. Это размер средников — внутренних полей, разделяющих ячейки таблицы. Средники определяют размеры активных частей ячеек. Их задают и корректируют в диалоговом окне Format Cells (Формат ячеек) и в палитре Table Attributes (Свойства таблицы).


Форматирование текста в таблице

В табличном редакторе существуют свои инструменты форматирования текста, которые намного уступают средствам форматирования PageMaker, однако в большинстве случаев для оформления текста их возможностей оказывается достаточно.

В составе Adobe Table имеются уже знакомые нам по программе PageMaker инструменты форматирования текста, с помощью которых легко придать тексту желаемый вид. На рис. 16.10 представлена палитра текста. Кроме нее, форматирование текста можно выполнять при помощи диалогового окна Format Text (Формат текста). С помощью контекстного меню можно вырезать и копировать текст из ячейки в ячейку.

У этих двух инструментов имеются аналоги в PageMaker, только в PageMaker функции форматирования символов и абзацев разнесены по отдельным диалоговым окнам и режимам работы управляющей палитры.

Рис. 16.10. Палитра текста

Основные понятия, использующиеся при форматировании текста в таблице (кернинг, интерлиньяж, гарнитура, кегль, выключка, индексы и др.), уже рассматривались в главах, посвященных программе PageMaker.

Специфика редактора таблиц проявляется в двух важных исключениях.

  • Adobe Table выполняет выключку текста не только по горизонтали, но и по вертикали. Вертикальные режимы выключки могут располагать текст посередине высоты ячейки (по умолчанию), в ее нижней и верхней части.
  • В дополнение к стандартным вариантам выключки по горизонтали (влево, вправо, по формату и по центру) введен режим выравнивания по десятичной точке.

В Adobe Table нет возможности расставлять позиции табуляции (строго говоря, при наличии колонок без них нетрудно обойтись). Поэтому при необходимости выровнять материал в столбце с числами выделите колонку и установите для нее выключку по десятичной точке. Кроме того, перед началом текста в каждой из ячеек с этим типом выключки следует вставить символ табуляции при помощи комбинации клавиш <Ctrl>+<>.

При необходимости откорректировать положение позиции табуляции выберите в меню View (Просмотр) команду Show Tab Markers (Показать маркеры табуляции), переключающую соответствующий режим. Маркеры табуляции видны также при включенном режиме Show If (Показать Tf), одноименная команда переключения которого расположена в том же меню. Перетаскивая мышью расположенные на кнопках выделения столбцов маркеры табуляции, вы можете регулировать местоположение десятичной точки чисел по ширине колонки.


Установка параметров линеек и фона

Для указания размещения и параметров линеек (линий, разграничивающих ячейки) таблицы и фона используют два инструмента — диалоговое окно Format Cells (Формат ячеек) и палитру Table Attributes (Свойства таблицы). С помощью диалогового окна задают значение параметров для всех линеек таблицы сразу, включая внешние и внутренние.

Подобное форматирование линеек можно выполнить при создании таблицы или в процессе дальнейшей работы над ее макетом. Причем, если диалоговое окно открывается для ранее созданной таблицы, в нем появляются два дополнительных элемента управления, отсутствующие в диалоговом окне при создании новой таблицы.

Кнопка Apply (Применить) позволяет увидеть результаты изменения параметров таблицы без закрытия диалогового окна. Если они вас не устроят, операцию, изменившую таблицу, можно Ътменить кнопкой Cancel (Отменить).

Задавать значения параметров линеек и фона для выделенных ячеек удобнее всего при помощи палитры Table Attributes (Свойства таблицы). При работе с палитрой Table Attributes (Свойства таблицы) можно предварительно выделить отдельную ячейку, прямоугольную группу ячеек или несмежный диапазон ячеек. После выделения ячеек необходимо сообщить Adobe Table, с какими из линеек, относящихся к выделенным ячейкам, вы собираетесь работать. Это можно сделать при помощи схемы. Схема в палитре Table Attributes (Свойства таблицы) работает по тому же принципу, что и схема в управляющей палитре программы PageMaker. Для того чтобы выделить категорию линеек или отменить это выделение, достаточно выполнить щелчок мышью на соответствующей линейке схемы. Обратите внимание на то, что в зависимости от формы совокупности выделенных ячеек структура схемы меняется следующим образом.

  • Если выделена одна ячейка, в схеме присутствуют только линейки, окружающие ячейку с четырех сторон.
  • Если выделено две или больше ячеек, составляющих смежную прямоугольную область, в схеме присутствуют как линейки, отделяющие выделенную область от остальной таблицы, так и внутренние линейки, разделяющие ячейки группы.
  • При выделении несмежного диапазона ячеек на схеме представляются только линейки, относящиеся к границам ячеек, но не к границе выделенного диапазона.

Для того чтобы задать фон в выделенных ячейках, выберите оттенок черного цвета в раскрывающемся списке или введите значение (с точностью до одного процента) в поле этого списка. Сплошному черному фону соответствует значение 100%. Фон цвета бумаги [Paper] ([Бумага]) означает, что в сверстанном в PageMaker макете все объекты, расположенные под таблицей, будут не видны. Если выбрано значение [None] ([Без фона]), ячейка таблицы будет прозрачной.

Для того чтобы отобразить данные ячейки в инверсном начертании, задайте темный фон (оттенок не менее 80%) и установите белый цвет символов текста при помощи диалогового окна Format Text (Формат текста) или палитры текста. Adobe Table 3.0 поддерживает определение цветов. Механизм определения цветов полностью совпадает с таковым принятым в PageMaker (см. гл. 19), поэтому мы не будем его подробно описывать в данном разделе.


Установка умолчаний в Adobe Table

В Adobe Table имеется механизм глобальных (на уровне программы) и локальных (на уровне документа) умолчаний, аналогичный механизму умолчаний PageMaker, описанному в гл. 3. Глобальные умолчания задаются при помощи меню и палитр в отсутствие открытой таблицы. Локальные умолчания устанавливаются в процессе выполнения последней операции с ячейками, строками или столбцами открытой таблицы.


Импорт таблиц

Если вы не являетесь сторонником верстки таблицы в Adobe Table, а это может быть вызвано несколькими причинами (большое число таблиц в публикации, многостраничные таблицы, таблицы легко исполнить внутри PageMaker), предлагаем вам следующий метод работы.

Во-первых, лучше не проводить набор табличных данных в PageMaker. Воспользуйтесь для этого специальными средствами (редактором электронных таблиц, текстовым редактором со встроенными таблицами, базой данных). Проверьте качество фильтра импорта. Корректно ли импортируется созданный табличный материал в PageMaker?

Когда вы определитесь с порождающим приложением, рассмотрите все таблицы и выберите самую сложную. Наберите ее, импортируйте в PageMaker и проведите необходимые эксперименты. Добейтесь хорошего внешнего вида таблицы на странице.

Во-вторых, сопоставьте готовый макет с остальными таблицами. Продумайте средства автоматизации работы — какие из элементов оформления будут повторяться в остальных таблицах? Разработайте стили таблицы и продумайте средства выделения. Если это возможно, разработайте сетку линеек.

В-третьих, наберите весь материал в порождающем приложении. Выполните, если это необходимо, предварительную подготовку материала. Импортируйте материал в PageMaker и настройте полученные таблицы.


Общие замечания об импорте таблиц

При подготовке таблиц вы можете использовать различные приложения — текстовые процессоры, редакторы электронных таблиц. Наконец, данные для таблицы могут быть собраны в рабочих базах данных, как универсальных, так и специальных. При подготовке данных для импорта в PageMaker лучше исходить из сформулированной ниже предпосылки.

В программе PageMaker столбцы таблицы разделяются табуляторами, а строки — признаками конца абзаца. Таким образом, для того чтобы автоматизировать верстку таблицы в PageMaker, нужно заранее привести к данному виду импортируемый материал. Это делается, во-первых, с помощью средств порождающего приложения. В нем можно разметить таблицу тэгами (о языке тэгов см. гл. 7) для сохранения локального форматирования (см. далее в этой главе). В некоторых случаях нужно провести преобразование формата данных в приложении. Затем приступайте к импорту. Если приложение имеет фильтр импорта в PageMaker, то при импорте можно настроить установки фильтра в соответствии с требованиями, предъявляемыми к таблице. Многие приложения дают возможность сохранения файла не только в своем, но и в универсальном текстовом формате. Если материал набран в базе данных, то она может и не иметь фильтра импорта в PageMaker. Сохранение базы данных как текстового материала (таблицы) также может быть невозможно. При обновлении базы было бы неплохо иметь возможность динамической связи между ней и публикацией PageMaker. Это не представляется возможным при промежуточном сохранении данных в текстовом формате. Для импорта базы данных существует общий способ доступа к данным — ODBC (Open DataBase Connectivity — Открытый доступ к данным). Вам также необходимо установить библиотеки ODBC (они находятся в папке \TechInfo\ODBC дистрибутивного диска PageMaker) и соответствующие драйверы для вашей базы, которые позволяют обрабатывать запросы к ней. Кроме того, необходимо установить фильтр импорта и дополнение ODBC из стандартного набора PageMaker.


Импорт таблиц из текстовых файлов

ASCII-файлы представляют собой наиболее простой тип текстовых файлов. О них подробно рассказывалось в гл. 7. Каждый раз при выполнении операции импорта текста без форматирования в PageMaker на экране открывается диалоговое окно Text Import Options (Параметры импорта текста) (см. рис. 7.11).

При импорте данных, которые уже разделены на поля символами табуляции, установите в окне импорта флажок No Conversion, Import As Is (Импортировать без изменений). После помещения файла в публикацию вы увидите на экране (в режиме редактора материалов) текст примерно в таком виде, как показано на рис. 16.11.

Текст подготовлен к обработке в PageMaker. В последующих разделах мы уделим внимание собственно процессу обработки текста и настройке таблицы.

Рис. 16.11. Текстовый файл после импорта в PageMaker в окне редактора материалов


Импорт электронных таблиц и баз данных

Для того чтобы успешно импортировать данные в программу PageMaker, большинство из традиционных форматов их представления придется предварительно преобразовать в текстовый формат. В большинстве приложений, работающих с данными, имеются средства их экспортирования в текстовый формат. После осуществления преобразования в текстовый формат процедура импорта электронных таблиц аналогична рассмотренной выше процедуре импорта текста.

В дополнение к средствам приложений специально для программы PageMaker были разработаны фильтры импорта данных, представленных в некоторых наиболее распространенных форматах баз данных и электронных таблиц. Набор фильтров и их возможности меняются при появлении новых версий приложений.

В качестве примера рассмотрим импорт в программу PageMaker файлов электронных таблиц приложения Microsoft Excel. Соответствующий фильтр импорта — один из самых надежных в комплекте поставки программы PageMaker. Для импорта электронной таблицы в формате Excel выберите команду Place (Поместить) точно так же, как при импорте текстового материала. Программа автоматически определит, что вы импортируете электронную таблицу в формате Excel, выберет нужный фильтр, и на экране появится диалоговое окно, представленное на рис. 16.12.

Рис. 16.12. Диалоговое окно фильтра импорта данных в формате Excel

При необходимости электронную таблицу можно импортировать целиком, но, как правило, вам требуется только та ее часть, в которой содержатся данные, подлежащие включению в публикацию. Фильтр выполняет поиск в пределах файла и формирует списки содержащихся в нем электронных таблиц, а также всех именованных диапазонов, их ячеек. Диапазон ячеек можно задать, указав в поле Cell range (Область) ссылку на область таблицы. Для этого введите обозначения верхней левой и лижней правой ячеек области, разделив их двоеточием (например, А4:Н10). Правда, более разумно подготовить заранее электронную таблицу к импорту в программу PageMaker, соответствующим образом организовав ее листы и выделив диапазоны ячеек, подлежащие импорту, с присвоением каждому из них символьного имени.

Если вы заранее подготовите данные в стороннем приложении, большая часть работы по форматированию будет выполнена автоматически в момент импорта. При импорте таблиц в формате Excel можно сохранить тип выравнивания колонок: тип позиций табуляции в полученном тексте будет соответствовать типу выравнивания записей исходной таблицы.

Примечание

Выравнивание сохраняется только в случае присвоения данным в исходной электронной таблице стиля форматирования Number (Число).

В большинстве случаев целесообразно импортировать поля таблицы с сохранением типа выравнивания, заданного в электронной таблице (вариант, принимаемый фильтром импорта по умолчанию), но можно принудительно задать выравнивание всех импортированных полей по левому краю, по центру, по правому краю или по десятичной точке. При задании выравнивания по десятичной точке можно также указать количество отображаемых дробных разрядов (например, для денежных сумм это количество обычно равно двум).

Фильтр импорта данных в формате электронных таблиц Excel позволяет импортировать за один прием не более сорока полей (столбцов электронной таблицы). При импорте данных в абзацах позиции табуляции располагаются по ширине столбцов электронной таблицы.

В диалоговом окне импорта данных предлагаются два дополнительных режима, управляемых флажками. Если установить флажок Apply default spreadsheet style (Применить стиль таблицы по умолчанию), то абзацам, соответствующим импортированным записям, назначается стиль форматирования (в данном случае — с именем XLS). Впоследствии этим стилем можно пользоваться для изменения атрибутов форматирования импортированных данных.

Установка флажка Truncate at cell boundary (Отсечь по границе ячейки) отбрасывает в процессе импорта все символы, выходящие за пределы границ ячейки исходной электронной таблицы. Это удобно, когда в поле примечаний расположены длинные тексты, из которых вам нужны только несколько первых слов.

Примечание

Если на вашем компьютере установлены версии продуктов Microsoft, выпущенные позже, чем версия 7 PageMaker, то файлы Word и Excel не импортируются.

В таком случае вам необходимо установить новый фильтр импорта. Фильтры импорта для новых версий программного обеспечения можно найти, например, на сайте Adobe http://www.adobe.com

В программе существует возможность импорта данных из специализированных баз. Для этого используется технология ODBC. Общая идея ODBC заключается в унификации механизма запросов и получения информации из разнородных баз данных средствами языка SQL. Приведенный ниже краткий обзор дает представление о возможностях работы PageMaker с базами данных.

Перед созданием запроса к базе данных необходимо настроить ODBC на работу с вашей базой. Для этого воспользуйтесь приложением 32bit ODBC в панели управления Windows 95. Там вы должны увидеть список установленных драйверов ODBC. Если среди них отсутствует драйвер используемой базы, необходимо его установить. Драйвер базы входит в комплект ее поставки.

Далее на вкладке File DSN с помощью кнопки Configure вызовите диалоговое окно конфигурации требуемого драйвера. При этом драйвер должен быть выделен в находящемся слева списке. Вид диалогового окна зависит от выбранного драйвера, но во всех случаях он позволяет указать файл вашей базы данных. Без этой предварительной настройки интерфейс ODBC не будет работать, "не зная", откуда следует брать данные и куда посылать запросы.

После такой подготовки вы можете воспользоваться дополнением ODBC для получения данных из базы. Дополнение построено по принципу "мастеров" (wizards), широко используемому в современных программах.

Оно позволяет выбрать тип размещения импортированного материала. В зависимости от выбора изменится и вид последних диалоговых окон дополнения, позволяющих задать оформление материала. Для примера мы рассмотрим только второй вариант размещения — табличный.

После щелчка на кнопке Next (Следующий) откроется список, позволяющий выбрать источник данных ODBC. Следующее диалоговое окно — Select Content (Выбрать содержимое) — предназначено для определения выборки полей исходя из имен, объявленных в базе данных. Если вы знакомы с SQL, то можете создать более сложный запрос, щелкнув на кнопке Edit SQL (Редактировать SQL). Она открывает одноименное диалоговое окно, где вы можете ввести текст запроса. Сложные запросы легче создавать в специализированной программе, например Microsoft Query, входящей в комплект поставки Microsoft Office. Эти запросы импортируются дополнением ODBC. Для просмотра списка запросов и импорта созданных ранее запросов служит вложенное диалоговое окно Edit Query List (Редактировать лист запросов), открывающееся одноименной кнопкой окна Edit SQL. Благодаря списку запросов можно импортировать одновременно все необходимые выборки из базы данных.

Когда запрос создан, дополнение предоставит вам возможность задать заголовки столбцов получаемой таблицы, их выравнивание, используемые шрифты и их кегли в диалоговых окнах Table Title and Headers (Название и заголовки таблицы) и Column tuning (Настройка столбцов).

После того как все описанные действия будут проделаны, PageMaker создаст новый материал, содержащий отформатированную выборку. Окно материала будет немедленно им закрыто, после чего вы увидите окно макета и курсор в виде пиктограммы размещения текста. Далее вы можете работать с выборкой как с обычным текстом в PageMaker.

Дополнение ODBC окажет вам неоценимую помощь при верстке прайс-листов, технической документации, статистической информации, которая, как правило, хранится в специализированных базах данных.


Импорт таблиц из файлов текстового процессора

Фильтры программы PageMaker для импорта текстового материала позволяют настраивать процедуру импорта таблиц, созданных при помощи встроенных редакторов таблиц текстового процессора. Выбор фильтров импорта для форматов данных различных текстовых процессоров даже шире, чем для форматов баз данных и электронных таблиц. Например, фильтр для текстового процессора Microsoft Word, рассмотренный в гл. 7.

Флажок разрешения импорта таблиц не позволяет импортировать отформатированные таблицы с линейками, средниками и другими элементами, как, например, при импорте из Adobe Table. Импортируется только текст с сохранением локального форматирования и стилей абзацев. Этого достаточно, чтобы полученный текст соответствовал требованиям к табличному материалу в PageMaker — столбцы разделены табуляторами, а строки таблицы — признаками конца абзаца.


Форматирование таблиц и бланков

Независимо от происхождения текста, помещенного в публикацию, его необходимо форматировать. Для приведения в порядок таблиц можно пользоваться любыми приемами, описанными ранее. Ниже рассматриваются специальные приемы форматирования. Все они связаны с одними и теми же элементами: линейками, позициями табуляции, отточиями, стилями, шаблонами.

Как уже было сказано ранее, сначала выберите наиболее сложную таблицу во всей публикации. Импортируйте ее и на ее основе определите параметры и позиции линеек, позиций табуляции, опишите стили абзацев. В ходе работы с этой таблицей вы определите, как должны разбиваться строки в отдельных полях и как следует форматировать поля локальным способом. После этого можно реализовать это форматирование средствами текстового процессора, и тогда уже данные будут импортированы в программу PageMaker не в "сыром", а в частично отформатированном виде, готовые к тонкой настройке в составе таблицы. Правда, это дело вкуса. Для большинства таблиц неважно, в текстовом процессоре или в PageMaker будет сделано форматирование. Исключением являются операции с вертикальными столбцами. Если приложение может выделять столбцы, Твд предварительное форматирование имеет смысл. Например, один из столбцов таблицы должен быть набран курсивом. Выполнить это форматирование в PageMaker довольно сложно, поскольку в нем невозможно выделять столбцы шириной менее колонки текста. Если же текстовый процессор или электронная таблица позволяют работать со столбцами текста, задание курсива выполняется довольно просто. Если приложение не поддерживает форматирования начертанием и стилями, можно разметить текст будущей публикации тэгами стилей. Предварительная обработка материала таблиц может пригодиться и в случае работы с очень большими таблицами. При правильном подходе большая часть форматирования может быть выполнена уже к моменту появления данных на странице публикации.


Стили предварительного форматирования

Некоторые из фильтров импорта переносят данные в публикацию с сохранением многих элементов форматирования. Так, таблицы, из Microsoft Word, импортируются с сохранением стилей абзацев и локального форматирования.

Word позволяет выделять отдельно столбцы таблицы и назначать им стиль форматирования символов, гарнитуру, стиль абзаца и любые другие атрибуты. Воспользуйтесь этой возможностью и назначьте для различных столбцов, скажем, различные гарнитуры, которые затем можно будет отыскивать и заменять при помощи команды контекстного поиска и замены. При помещении обработанной таким образом таблицы в публикацию установите флажок Retain Format (Импортировать формат) в диалоговом окне импорта.

На рис. 16.13 представлен результат импорта таблицы, подготовленной в текстовом процессоре Microsoft Word. Поля были отформатированы необычными гарнитурами, что дает возможность выделять значение полей при контекстном поиске и заменять их форматирование.

Рис. 16.13. Форматирование столбцов таблицы необычными гарнитурами


Разметка стилей в текстовом файле без форматирования

Если приложение или его фильтр не могут воспроизвести форматирование таблицы стилями и начертаниями, предварительную разметку можно выполнить с помощью тэгов. Не забудьте установить флажок Read tags (Читать стилевую разметку) в диалоговом окне Place (Поместить). При этом можно придать всей таблице один стиль (в данном случае тэг ставится только в начале таблицы). Если же различным записям назначаются разные стили абзацев, тэги стилей вставляются в начале каждой строки. Пример подобного форматирования — "полосатые" таблицы, в которых фон строк раскрашен попеременно в два цвета. Для достижения нужного размещения тэгов в порождающем приложении добавьте к данным спереди еще одну колонку и разместите в ней тэги стилей.

Если же в вашем распоряжении нет приложения, работающего с таблицами, можно расставить подобные тэги стилей с помощью команды поиска и замены. Поиск выполняется по признаку конца абзаца, который заменяется на такой же признак, вслед за которым вставляется тэг стилевой разметки следующего абзаца.

Новый язык тэгов предоставляет пользователю широчайшие возможности в части описания форматирования таблицы в исходном тексте данных. Принцип разметки остается тот же, что при работе с тэгами стилей. Только теперь дополнительные колонки следует вставлять не только перед первым полем данных, но и перед всеми полями. Эти дополнительные колонки можно рассматривать как поля описания форматирования. В каждое поле форматирования следует скопировать соответствующий текст на языке тэгов, описывающий форматирование расположенного справа поля данных. Таким образом, вы получаете доступ практически ко всем средствам форматирования, имеющимся в программе PageMaker.

Примечание

Начните работу по разметке данных тэгами с импорта неразмеченных данных (вполне достаточно десятка записей). Отформатируйте записи вручную, экспериментируя с оформлением, пока все атрибуты не будут определены окончательно: цвета, линейки абзацев, гарнитуры, стили. После этого экспортируйте отформатированный фрагмент таблицы в файл типа Tagged Text (Текст с тэгами разметки). Вы получите корректное описание таблицы со стилевой разметкой. Скопируйте имеющиеся в созданном файле описания форматирования на языке тэгов в поля описания форматирования средствами системы управления базами данных, программы работы с электронными таблицами или текстового процессора.


Обработка данных после импорта

После того как данные импортированы в программу PageMaker, как правило, требуется их предварительная обработка. Основным инструментом такой обработки являются приемы контекстного поиска и замены, описанные в гл. 8.

На рис. 16.14 представлена часть таблицы, импортированной из формата Word. Как видите, в начале и в конце каждой строки вставлены символы табуляции. Чтобы их удалить, выберите команду Change (Заменить) и задайте в качестве маски поиска сочетание ^t^p^t, а в качестве замены — ^р. Обратите внимание, что при замене следует указать имя стиля для заменяющего образца (кнопка Para attributes (Атрибуты абзаца)). В противном случае, удаление признака конца абзаца с его последующей вставкой приведет к установке атрибута форматирования абзаца [No style] ([Без стиля]). Просмотреть кодировку метасимволов и непечатаемых символов PageMaker можно в файле помощи.

а

б

Рис. 16.14. Удаление лишних символов табуляции


Разметка колонок

После того как предварительная обработка освободила массив импортированных данных от лишних символов табуляции, пробелов и другого "мусора", можно приступать к пробному форматированию таблицы. Для этого необходима целая страница записей, первую из которых следует выделить (рис. 16.15). Откройте диалоговое окно Indents/Tabs (Отступы/Табуляция) с помощью комбинации клавиш <Ctrl>+<I> и определите местоположение позиций табуляции, проверяя внешний вид строки данных нажатием кнопки Apply (Контроль).

Рис. 16.15. Размещение табулостопов и висячего отступа в таблице

Первый столбец таблицы иногда удобно оформить как висячий отступ. Задайте необходимую величину отступа. Отформатированная запись может послужить в качестве основы для описания нового стиля абзаца или переопределения уже имеющегося (см. гл. 6).

Висячие отступы часто применяются в таблицах с неравномерным размещением текста в колонках. Первая колонка таблицы на рис. 16.16 образована висячим отступом, а вторая представляет собой многострочное поле, выровненное по табулятору, совпадающему с висячим отступом. Внутри каждой ячейки строки разбиты признаками перехода на новую строку.

Рис. 16.16. Висячий отступ как средство форматирования таблицы с многострочным полем

Перед расстановкой позиций табуляции для колонок таблицы разбейте страницу на вертикальные секции с помощью направляющих. Их можно

расставить вручную или с помощью дополнения Guide Manager (Модульная сетка). Полученная сетка поможет вам оценить ширину столбцов таблицы и даст видимые ориентиры для первоначальной расстановки позиций табуляции.


Линейки в таблицах

Табличный материал часто предполагает оформление с помощью линий и заливок. Если установить эти элементы выделения вручную с помощью инструмента Line (Линия), при переверстке линии перестанут соответствовать положению таблицы и их придется снова переставлять вручную. Если вы все же предпочитаете рисовать линии таблицы вручную, то в случае работы с большой таблицей их можно разместить на вспомогательной странице-шаблоне и применять ее только к страницам публикации, содержащим таблицы. Это особенно касается вертикальных линеек. В вертикальных средниках таблиц часто размещают линейки, зрительно разграничивающие поля данных.

Рис. 16.17. Вертикальная линейка является вложенным изображением

Представленная на рис. 16.17 вертикальная линейка оформлена как вложенное изображение в абзаце, соответствующем первой записи таблицы. Приемы работы с вложенными изображениями описаны в гл. 15. При настройке изображения линии были использованы смещение базовой линии и корректировка ее длины по фактической высоте таблицы. Для фиксации положения линейки по горизонтали в первом абзаце установлена позиция табуляции.

Если ввести позицию табуляции, управляющую положением вложенного изображения по горизонтали, в стиль абзаца, данный стиль можно будет использовать при форматировании нескольких таблиц.

Что касается горизонтальных линеек, используемых для отделения строк таблиц и выделения отдельных полей, то наиболее рациональным представляется использование абзацных линеек соответствующего вида в стиле форматирования таблицы. В гл. 5 и 15 были рассмотрены приемы построения разнообразных линеек. Здесь мы только приведем несколько примеров их использования в таблице.

На рис. 16.18 текст внутри строки таблицы разбит на строчки признаками перехода на новую строку так, что каждая строка таблицы представляет собой единый абзац. Этому абзацу задана линейка по ширине колонки и небольшая отбивка. Таким образом, строки таблицы зрительно обособлены.

На рис. 16.19 продемонстрировано более изящное использование линеек. Стиль форматирования абзаца включает в себя горизонтальную линейку оттенка 80% серого цвета. Поле имен набрано инверсным шрифтом полужирного начертания, поэтому буквы выглядят белыми на сером фоне. При описании линейки задан отступ вправо, достаточный для того, чтобы она доходила почти до следующего поля.

На рис. 16.20 тот же прием использован для оформления номеров записей. Сами номера были сформированы дополнением Bullets and numbering (Нумерация абзацев). В этом примере оттенок линейки установлен равным 20% серого цвета.

Горизонтальными и вертикальными линейками можно пользоваться одновременно. На рис. 16.21 показан наиболее простой пример такой верстки. Вертикальная линейка является вложенным изображением, а горизонтальные — абзацными линейками.

Горизонтальные линейки — это текст, вертикальные — вложенная графика; текстовые элементы всегда перекрывают графические. На рис. 16.22 приведен пример использования этого принципа для форматирования таблицы. Текст в наиболее значимом поле таблицы выделен серой верхней линейкой абзаца с широким правым отступом. Нижняя линейка абзаца цвета бумаги перекрывает вертикальную линию в точности под записью, автоматически разбивая ее на отрезки различной длины в соответствии с числом строк в абзаце записи.

Рис. 16.18. Горизонтальная абзацная линейка по ширине колонки для разграничения строк в таблице

Рис. 16.19. Линейка абзаца по ширине текста колонки с отступом вправо использована для выделения наиболее значимого поля таблицы

Рис. 16.20. Номера записей выделены при помощи серых линеек абзацев с правым отступом

Рис. 16.21. Оформление элементарной сетки таблицы

Рис. 16.22. Сочетание горизонтальных и вертикальных линеек для оформления таблицы


Оформление бланков

Программа PageMaker — очень удобный инструмент для верстки всевозможных бланков и форм: накладных, анкет для поступления на работу, даже регистрационных листков службы знакомств.

При оформлении бланков можно воспользоваться всеми стандартными приемами и специальными эффектами, описанными в предыдущих главах. Но при верстке бланков приходится иметь дело с двумя специфичными элементами публикации — полями для заполнения и полями для отметки.

Примечание

Как правило, бланки обладают жесткой внутренней структурой, которая достигается фиксацией интерлиньяжа и позиций табуляции в пределах всего бланка. Постарайтесь подчеркнуть внутреннюю логику бланка модульной сеткой верстки, по которой будут выровнены его элементы. За исключением самых простых случаев, нарушение этого правила усложнит заполнение формы.


Расстановка полей для отметки

В качестве поля для отметки удобно использовать один из символов какой-либо символьной гарнитуры Zapf Dingbats. Регулярное размещение полей на бланке достигается размещением висячего отступа. На рис. 16.23 приведен пример выравнивания полей для отметок при помощи позиций табуляции.

Рис. 16.23. Поля для отметок, представленные символом гарнитуры Zapf Dingbats , выровнены по позициям табуляции


Верстка полей для вписывания

Приведенные ниже приемы создания полей для вписывания от руки при помощи форматирования подчеркиванием и отточий позиций табуляции можно рекомендовать при работе с любыми бланками и формами.

В принципе, можно использовать для этой цели и абзацные линейки, однако их возможности в плане оформления полей для вписывания сильно ограничены. Как правило, перед полем для вписывания имеется какой-либо текст. При этом необходимо вручную задавать левый отступ, чтобы текст не был подчеркнут. Такой прием не годится и для оформления двух полей для вписывания в пределах одной строки, поскольку абзацная линейка не может прерываться.

Не советуем пользоваться графическими линиями для построения бланков, поскольку их сложно выравнивать. Последовательности символов подчеркивания могут сыграть с вами злую шутку, превратившись на печати в пунктир вместо сплошной линии. Кроме того, их труднее форматировать, чем отточия.

Рис. 16.24. Верстка бланка по пятиколонной сетке с табуляторами и отточиями

На рис. 16.24 представлен способ верстки сложного бланка при помощи позиций табуляции по пятиколонной сетке. Совмещение материала бланка с линиями сетки выполнено посредством символов табуляции. Перед названиями полей для вписывания вставлен символ табуляции, приводящий их на позицию табуляции с выравниванием по правому краю, совмещенную с вертикальной линией модульной сетки. Для следующей позиции табуляции установлено отточие, причем в качестве символа отточия в списке выбран символ подчеркивания. В строках, где имеются два поля для вписывания, установлены две пары позиций табуляции с выравниванием по правому краю и отточием. Всем типам строк бланка сопоставлены стили абзацев.

Форматирование символа табуляции определяется форматированием предшествующего символа. Поля для вписывания на рис. 16.24 можно было бы оформить, вставив перед соответствующими символами табуляции пробел шириной в тонкую шпацию (комбинация клавиш <Shift>+<Ctrl>+<T>) и задав для него начертание с подчеркиванием. В этом случае задавать отточие нет необходимости, поскольку расстояние между позициями табуляции будет оформлено подчеркиванием. Для формирования заказного отточия произвольного кегля, гарнитуры и цвета воспользуйтесь приемами, описанными в гл. 5.

Примечание

Для того чтобы специальные стили, применяемые только в таблицах, не усложняли выбор наиболее часто применяющихся стилей, подбирайте их имена так, чтобы они размещались в конце списка стилей (например, начинайте все имена с символа "z").


Печать с переменными данными

Часто возникает необходимость создания серии публикаций со стандартным набором сведений. Например, это может быть каталог изделий, на каждой странице которого должны располагаться фотография, название, данные о производителе и цена. Другой пример — нужно сверстать публикацию для адресной рассылки так, чтобы вверху страницы располагались имя, фамилия, адрес, телефон адресата, далее помещалось обращение, а основное поле страницы было заполнено стандартным для всех адресатов текстом. Для создания такого рода публикаций используют функцию внедрения полей базы данных.


Создание файла базы данных

Для того чтобы PageMaker мог импортировать файл базы, его следует сохранить в текстовом формате с разделителем — запятой (CSV или ТХТ). Этот тип файлов можно экспортировать из любой базы данных. При отсутствии готовой базы вы можете просто создать ее в текстовом редакторе. Правила форматирования файла данных несложные.

  • Первая строка — это обозначения полей. Они записываются через запятую, без пробелов. Если в состав поля входит картинка, его название должно, начинаться с символа @. Если вы собираетесь организовать базу, содержащую следующие поля: название товара, производитель, цена, фотография, первая строка файла базы будет иметь следующий вид:

    Name,manufacturer,price,@picture.

  • Каждая строка базы отделена возвратом каретки. Если в содержимом поля есть пробел, все поле целиком берется в кавычки. Это правило не распространяется на имена файлов в полях изображений. Приведем пример нескольких строчек базы:

    "Digital Camera",Canon,$580,С:\Му Documents\goods\camera.tif;

    Phone, Panasonic, $100, C:\My Documents\goods\phone.tif;

    CD-player,Sony,$634,C:\My Documents\goods\Cdplayer.tif.

  • Все изображения, которые предполагается использовать в публикации, непременно должны иметь одинаковые соотношения ширины и высоты. Формат их произволен — важно только, чтобы программа могла его импортировать.


Создание шаблона публикации с переменными данными

После того как исходные данные приведены к описанному виду, необходимо открыть PageMaker и создать в программе шаблон для последующего его заполнения сведениями из полей базы данных. Продумайте интерфейс страницы, поместите текст, который будет повторяться в каждом входе (например, информация о правилах и способах покупки изделия). Создайте или импортируйте всю информацию, которая будет одинаковой для входов (графические примитивы, изображения, фреймы и пр.).

Затем откройте палитру Data Merge (Помещение данных) одноименной командой подменю Plug-In palettes (Дополнительные палитры) меню Window (Окно). В момент открытия палитра пуста (рис. 16.25, а).

а

б

Рис. 16.25. Палитра Data Merge: a — пустая, б — с помещенными полями базы и открытым меню

Откройте меню палитры и выберите команду Select Data Source (Выбрать источник данных). В системном окне выберите файл с базой. После нажатия кнопки ОК в палитре появятся строки, соответствующие полям базы (рис. 16.25, б).

Выбрав инструмент Text (Текст), установите точку ввода там, где вы предполагаете появление информации из поля. Указателем мыши щелкните на нужном поле. Таким же образом поместите все поля базы в надлежащие места в шаблоне публикации (рис. 16.26, а).

а

б

Рис. 16.26. Шаблон с полями (а) и с временно помещенными, отформатированными данными (б)

Для просмотра заполненных полей в палитре Data Merge (Помещение данных) существует флажок Preview (Просмотр). Установите его, и данные будут показаны вместо названий полей (рис. 16.26, б). Чтобы просмотреть другие входы базы, щелкните на кнопках со стрелками в нижней части палитры. Чтобы перейти к конкретному входу, используйте команду палитры Go To Record (Перейти к записи) и введите номер входа в открывшемся окне.

Масштабируйте изображение, "доведите" текст. Задайте всем элементам нужные размеры, например, если вы собираетесь размещать записи в несколько колонок, то размер текстовых блоков по горизонтали необходимо уменьшить так, чтобы они могли поместиться друг за другом с требуемым интервалом.


Помещение данных

Но вот шаблон готов и пора начинать создание публикации. Для этого следует выбрать команду Merge Data (Помещение данных) меню палитры. В диалоговом окне Merge Records (Помещение записей) (рис. 16.27) определяют параметры размещения данных.

Переключатели All Records (Все входы), Current Record (Текущий вход) и Ranges (Диапазон) задают диапазон записей, подлежащих внедрению. Если включен третий переключатель, в поле ввода необходимо через запятую указать номера входов. Диапазоны входов (скажем, с пятого по двадцатый) вводятся через дефис.

В списке Records per page (Записей на страницуХвыберите один из способов размещения записей: Manual Layout (Размещение вручную) и One record per page (Одна запись на страницу). Выбрав первый пункт списка, вы обязаны ввести расстояния между записями по горизонтали и вертикали в полях ввода под списком. При установке флажка Remove Blank Lines for Empty Fields (Удалять пустые строки) строки записи, оставшиеся при заполнении входов пустыми, будут удалены.

Рис. 16.27. Окно параметров размещения

Рис. 16.28. Готовая публикация с размещенными записями

Последние два флажка позволяют внедрить в публикацию изображения (по умолчанию создаются только ссылки) и отрегулировать число страниц в создаваемой публикации. Если база большая, рекомендуется разбить публикацию на несколько частей. Например, введя в строку Start New Publication After ... Pages (Начать новую публикацию после ... страниц) число 50, вы даете программе команду создавать публикации по 50 страниц.

Когда все установки сделаны, остается щелкнуть на кнопке ОК. Программа создает безымянную публикацию, в которую помещает записи с данными из базы (рис. 16.28).


Резюме

Применяя рекомендации этой главы, вы упростите работу по верстке таблиц, бланков и каталогов. Скорее всего, при изучении данной главы вам придется оживить в памяти материал, связанный с расстановкой и редактированием табуляторов, отступов и линеек. Эта информация содержится в гл. 5. Если ваши таблицы имеют объем в не одну сотню страниц, для вас окажется полезным изучение следующей главы книги. Если в таблице использован цвет, воспользуйтесь советами, данными в части V.


  • Глава 17. Верстка книг
    • Методы работы со страницами публикации
      • Вставка страниц
      • Удаление страниц
      • Перемещение по страницам публикации
      • Сортировка страниц
    • Организация работы с составной публикацией
    • Сбор книги из отдельных частей
      • Составление структурного списка
      • Автонумерация страниц
      • Имена файлов составной публикации
    • Раздельная пагинация глав
    • Оглавление публикации
      • Определение входов оглавления
      • Сбор элементов оглавления
      • Размещение оглавления и его настройка
      • Настройка оглавления
      • Проверка номеров страниц в готовом оглавлении
      • Специальные оглавления
    • Составление предметного указателя книги
      • Два типа указателей
    • Порядок построения предметного указателя
      • Кодирование входов указателя
      • Настройка сортировки элементов указателя
      • Виды адресных ссылок
      • Форматирование номеров страниц в указателе
      • Перекрывающиеся темы
      • Быстрое добавление новой темы из текста
      • Перекрестные ссылки
      • Автоматическое кодирование ссылок
      • Именной указатель
      • Ссылки на все вхождения имени в текст
    • Редактирование предметного указателя
      • Работа с командой Show Index
      • Редактирование входа предметного указателя
      • Добавление перекрестной ссылки
      • Промежуточное сохранение результатов
      • Удаление входов
      • Коды ссылок, размещаемых не на страницах материала
      • Написание тем указателя
      • Проверка входов командой повторного поиска
    • Сбор, размещение и стилевое оформление предметного указателя
      • Сбор предметного указателя
      • Форматирование предметного указателя
      • Размещение и настройка стилей предметного указателя
      • Проверка ссылок в собранном предметном указателе
    • Комбинации клавиш для работы в предметном указателе
    • Специальные элементы многостраничных публикаций
      • Скользящие колонтитулы
      • Дополнение Running Headers & Footers
      • Предварительный просмотр и создание колонтитулов
      • Удаление колонтитулов
    • Перекрестные ссылки в основном тексте
    • Примечания и сноски
    • Резюме


ГЛАВА 17.

Верстка книг

Мы рассмотрим в этой главе особенности верстки многостраничных публикаций. К ним относятся:

  • Методы работы со страницами публикации — перемещение по страницам, удаление и добавление страниц. Сортировка страниц.
  • Команда Book (Книга) — основной инструмент для работы с большими публикациями.
  • Специальные элементы оформления — оглавление книги, скользящие колонтитулы.
  • Пагинация страниц — общая и раздельная, размещение и префикс колонцифры.
  • Предметный и алфавитный указатели.

Для подготовки книги вам потребуется сверстать и разместить несколько десятков или даже сотен страниц. Такой объем работы необходимо четко организовать. Выпускаемая книга должна быть единой по оформлению, все необходимые материалы должны быть расположены в строгой последовательности. Кроме того, в книгах есть и особые элементы верстки — оглавление, предметный указатель, сплошная или раздельная пагинация, иногда — скользящие колонтитулы. О том, как правильно организовать структуру публикации большого объема, и пойдет речь в данной главе.

В общем случае любой многостраничный документ должен быть разбит на несколько более мелких. В книге разбиение чаще всего осуществляется по главам. Такая организация работы дает пользователю ряд преимуществ. В первую очередь, это повышение устойчивости работы PageMaker. Чем больше файл, тем больше вероятность внутреннего сбоя в нем. Разбиение большого файла публикации на несколько файлов меньшего объема снижает эту вероятность. Кроме того, в отдельные файлы выносятся оглавление и предметный указатель. Эти два компонента книги составляются автоматически. Рекомендуется оставлять их в отдельном файле для ускорения доступа к ним из любой публикации. При разбиении книги на файлы глав вы сможете автоматизировать ее сбор с помощью команды Book (Книга), в том числе оформить сплошную пагинацию, оглавление и предметный указатель для всей книги. Наконец, при таком структурировании материала книги возможна раздельная пагинация, например для основного текста и приложений.

Несмотря на то, что большие документы принято разбивать на части, каждый из файлов частей может насчитывать десятки страниц. Особенно это касается книг, где простота верстки дает возможность хранить большой объем текста в файле вполне допустимого размера.


Методы работы со страницами публикации

В этом разделе описаны приемы добавления и удаления страниц, а также быстрого перехода на любую страницу независимо от их общего количества. Иногда необходимо переменить порядок страниц в публикации.


Вставка страниц

В PageMaker существует четыре способа добавления страниц в публикацию.

  • Автоматический режим размещения текста добавляет страницы автоматически в процессе размещения текста в колонках (см. гл. 7).
  • Диалоговое окно Document Setup (Параметры документа). В этом окне можно добавлять в конец публикации любое количество страниц.
  • Комбинация клавиш <Ctrl>+<Alt>+<Shift>+<G> используется для вставки одной страницы. Она вставляется после текущего разворота.
  • Диалоговое окно Insert Pages (Вставить страницы) (рис. 17.1), которое открывается одноименной командой меню Layout (Макет) или выбором из контекстного меню, вызываемого щелчком правой кнопкой мыши на пиктограммах страниц внизу главного окна документа. Из этого диалогового окна вы сможете вставить или удалить нужное число страниц в любом месте публикации, задав для них любой из имеющихся шаблонов.

Новые страницы вставляются пустыми, на них присутствуют только элементы, перенесенные со страницы-шаблона. По умолчанию вновь вставляемые страницы форматируются в соответствии с основной страницей-шаблоном, если обратное не указано с помощью списка в диалоговом окне команды вставки. На рис. 17.1 для левой и правой стЪроны разворота страницы-шаблоны назначаются раздельно, следовательно, они могут не совпадать.

Рис. 17.1. Диалоговое окно Insert Pages

В раскрывающемся списке указывается расположение вставляемых страниц: до текущей, после текущей, между страницами активного разворота. Если в диалоговом окне Document Setup (Параметры документа) установлен флажок Facing pages (Разворот), программа PageMaker по умолчанию предлагает вставить две страницы. Если новые страницы вставляются в середину цепочки страниц материала, целостность цепочки сохраняется, но новые страницы не включаются в нее.

Особая осторожность требуется при вставке страниц, если в диалоговом окне Document Setup (Параметры документа) установлен флажок Facing pages (Разворот). При вставке в этом режиме нечетного числа страниц четные страницы публикации станут нечетными и наоборот. Если вам необходимо вставить страницы именно таким образом, не забудьте включить флажок Adjust layout (Настройка макета). В этом случае PageMaker автоматически изменит поля и нумерацию всех последующих страниц; он также скорректирует расположение всех элементов, чтобы таким образом компенсировать разницу в ширине внутренних и внешних полей. Если же режим настройки макета выключен, ваша публикация может просто превратиться в беспорядочную кучу текстовых и графических блоков. После вставки нечетного числа страниц в публикацию с двусторонней печатью обязательно проверьте состояние макета страниц, затронутых перестановкой (все страницы публикации после вставки), чтобы убедиться в правильности автоматической настройки.

Рис. 17.2. Контекстное меню пиктограмм страниц документа

Наличие нескольких способов вставки страниц позволяет использовать именно тот из них, который удобнее в данный момент работы. Самый быстрый способ для большинства случаев — с использованием контекстного меню (рис. 17.2), с помощью которого можно быстро добавить две страницы после текущего разворота (без открытия диалогового окна). Если же нужно добавить иное число страниц, из того же контекстного меню откройте окно Insert Pages (Вставить страницы). Это гораздо быстрее, чем вызывать его командой главного меню.


Удаление страниц

Удалить страницы в PageMaker можно с помощью следующих диалоговых окон.

  • Диалоговое окно Document Setup (Параметры документа), строка ввода Number of pages (Количество страниц). Если ввести в эту строку число, меньшее количества страниц в документе, будут удалены все страницы документа, превышающие новое значение. Лишние страницы удаляются, начиная с конца документа. При этом PageMaker не запрашивает подтверждение удаления страниц, даже если на них присутствуют объекты. Понятно, что с этой возможностью нужно обращаться осторожно, чтобы не потерять данные в конце публикации.
  • Диалоговое окно Remove Pages (Удалить страницы) (рис. 17.3). Оно вызывается одноименной командой меню Layout (Макет) или контекстного меню пиктограмм.

Работа с этим диалоговым окном очень проста. Достаточно ввести в поля номера нежелательных страниц. Перед удалением программа PageMaker запросит подтверждение.

Рис. 17.3. Диалоговое окно Remove Pages

Текстовые блоки материалов, располагавшиеся на удаленных страницах, пропадают, но текстовые блоки на страницах, находящихся перед и после удаленных, остаются связанными.


Перемещение по страницам публикации

Перемещаться по страницам публикации можно разными способами. Выберите наиболее подходящий к ситуации.

  • Щелкните мышью в нижней части окна публикации на пиктограмме с номером нужной страницы. (Если строка пиктограмм не вместила номер нужной вам страницы, воспользуйтесь кнопкой-стрелкой.)
  • Выберите из меню Layout (Макет) команду Go to Page (Перейти к странице) и введите номер нужной страницы. Аналог этой команды — комбинация клавиш <Alt>+<Ctrl>+<G>.
  • Чтобы перейти к предыдущей странице (или развороту), нажмите клавишу <Page Up>; чтобы перейти к следующей странице (или развороту) — клавишу <Page Down>.
  • В текстовом режиме, в пределах разворота перемещайтесь от строки к строке клавишами управления курсором. Дойдя до последнего (первого) символа на странице, курсор не будет двигаться ниже (выше). Нажмите клавишу <Page Down> (<Page Up>), и вы перейдете на следующую (предыдущую) страницу или разворот. При этом курсор окажется в позиции первого символа следующего разворота, если блоки на соседних страницах связаны (в случае работы с книгой так оно и будет).
  • Нажмите клавишу <Shift> и, не отпуская ее, выберите команду Go to Page (Перейти к странице) меню Layout (Макет). Страницы пролистываются начиная с первой. Изображение каждой из них некоторое время задерживается на экране. Чтобы остановить пролистывание, щелкните кнопкой мыши или нажмите любую клавишу на клавиатуре.


Сортировка страниц

В случае необходимости вы можете перекомпоновать публикацию, переставив страницы прямо в режиме макета. На рис. 17.4 представлено диалоговое окно Sort Pages (Сортировать страницы). Оно открывается одноименной командой меню Layout (Макет). Под каждой из страниц расположена ее же пиктограмма, на которой помечена ориентация страницы (четная или нечетная) и ее порядковый номер.

Для перемещения страницы на новое место достаточно ее выделить и перетащить мышью. В процессе перетаскивания указатель мыши принимает форму стопки страниц, а в диалоговом окне появляется черная полоса, указывающая текущее местоположение перетаскиваемой страницы. Для того чтобы выделить несколько страниц, выполните щелчок мышью на второй и последующих страницах при нажатой клавише <Shift>.

Рис. 17.4. Диалоговое окно Sort Pages

Для того чтобы выделить одну из страниц разворота, в момент щелчка мышью на ней удерживайте нажатой клавишу <Ctrl>. Если вы хотите вставить выделенную совокупность страниц между двумя страницами разворота, нажмите клавишу <Ctrl> до начала ее перетаскивания. Размеры диалогового окна Sort Pages (Сортировать страницы) можно увеличивать или уменьшать перетаскиванием любого из углов или любой из сторон. Для того чтобы миниатюрное представление выделенных страниц стало более информативным (с отображением строк текста и графики), щелкните мышью на кнопке Detail (Содержимое). После перетаскивания вид пиктограмм страниц изменяется. Теперь под каждой перемещенной страницей находится двойная пиктограмма. На ней показаны ориентация и номер страницы до перестановки (страничка обведена пунктиром) и после нее (миниатюра имеет сплошную обводку).

Кнопка Options (Варианты) открывает вложенное диалоговое окно, представленное на рис. 17.5. Режим показа содержимого всех страниц включается флажком Show detailed thumbnails (Показать содержимое страниц). Сделанные в диалоговом окне Options (Варианты) изменения запоминаются в качестве локального умолчания.

Рис. 17.5. Вложенное диалоговое окно Options

Перед сортировкой страниц обязательно сохраните публикацию, чтобы в случае необходимости можно было восстановить ее исходное состояние.

При перекомпоновке страниц цепочки текстовых блоков сохраняются нетронутыми. Поэтому в результирующей публикации сцепленными могут оказаться блоки, находящиеся на удаленных друг от друга страницах, а блоки соседних страниц вообще могут принадлежать к разным материалам. Нежелательные последствия этой расстановки объектов верстки могут выражаться в непредсказуемом перетекании текста между удаленными блоками. Сортировка страниц, таким образом, — это скорее заключительная операция верстки, когда известно, что никакие изменения в макет уже не будут вноситься.

Как и другие изменения макета, перекомпоновка, в особенности если переносится только одна страница из разворота, может привести к изменению четности страниц. Поэтому такое действие обязательно должно проводиться при включенном флажке автоматической настройки макета в диалоговом окне Document Setup (Параметры документа). В противном случае изменение четности страницы может повлечь за сЪбой смещение объектов из-за разницы между внутренним и внешним полями страницы.


Организация работы с составной публикацией

При работе с публикацией, состоящей из нескольких частей, рекомендуем вам еще до начала верстки стандартизировать приемы верстки для всех частей.

Необходимо разработать шаблон глав книги, включающий размер и ориентацию страницы, систему стилей, единые элементы оформления. Об организации шаблона документа см. гл. 12, о стилях абзацев — гл. 6. На основе этого шаблона продумайте и создайте дополнительные шаблоны для приложений, предметного указателя и других частей, отличающихся по оформлению от основного текста книги. Стили абзацев заголовков первого и второго уровня шаблона должны включать, кроме атрибутов текста, и регистрацию входов оглавления (см. разд. "Оглавление публикации" данной главы). В шаблоне документа следует указать тип пагинации (если он будет различным для разных частей) и префикс колонцифры.

Примечание

Применение шаблонов ускоряет работу над книгой. Воспользовавшись шаблоном, вы сразу получаете в распоряжение структуру книги и можете переходить к менее глобальным аспектам верстки. В комплект поставки программы PageMaker входят несколько шаблонов больших публикаций (например, шаблон технического руководства). Приемы использования шаблонов публикаций рассмотрены в гл. 12.

Затем начинайте импорт текста каждой из глав и верстку. Некоторые редакторы предпочитают проводить обработку текста (чистку и проверку орфографии) в каждой главе отдельно, другие импортируют текст во все главы книги, а затем производят обработку текста всех глав одновременно. На этапе обработки текста проводят кодирование входов предметного указателя (см. разд. "Порядок построения предметного указателя" данной главы).

По окончании верстки глав книги рекомендуется еще раз импортировать систему стилей шаблона в каждую из глав, чтобы быть уверенным в неизменности стилей абзацев во всех файлах книги. После этого каждая глава книги проверяется на правильность верстки.

По окончании работы над частями необходимо собрать книгу командой Book (Книга). В книгу войдут все главы основного текста и приложения. На этом этапе уточняется пагинация.

В последнюю очередь проводятся сбор и обработка оглавления книги, предметного указателя, расставляются скользящие колонтитулы и завершается окончательная доработка оформления книги.

Все этапы работы на книгой мы и рассмотрим в этой главе.


Сбор книги из отдельных частей

Сбор книги из отдельных частей проводится командой Book (Книга) меню Utilities (Сервис). После выбора этой команды на экране открывается диалоговое окно, представленное на рис. 17.6.

Рис. 17.6. Диалоговое окно для сбора составной публикации


Составление структурного списка

Список файлов (мы будем их условно называть главами), которые войдут в публикацию (книгу), составляется при помощи двух списков с линейками прокрутки, расположенных в средней части диалогового окна. Файл, который вносится в составную публикацию, сначала выделяется в левом списке файлов, а затем двойным щелчком мыши или при помощи кнопки Insert (Вставить) вносится в структурный список книги справа. Кнопка Remove (Удалить) удаляет файлы из списка публикаций книги.

Порядок следования файлов в правом списке определяет содержание оглавления и ссылки на номера страниц в предметном указателе, из чего следует необходимость упорядочения последовательности файлов книги в списке публикаций книги. Порядок следования файлов в структурном списке можно менять при помощи кнопок Move up (Вверх) и Move down (Вниз).


Автонумерация страниц

В диалоговом окне Book Publication List (Структурный список книги) можно задать сквозную автоматическую нумерацию страниц образовавшейся книги. При этом все страницы публикаций, входящих в состав книги, получают новые номера в соответствии с порядком следования в книге. Группа переключателей Auto renumbering (Автонумерация) регулирует порядок перенумерации страниц:

  • None (Нет). Выбор данного переключателя выключает автоматическую корректировку номеров страниц. В публикации номера страниц остаются теми же, что и в файлах, включенных в структурный список книги. Новые страницы не добавляются.
  • Next page (Следующая). При выборе этой позиции выполняется сквозная пагинация всех файлов из структурного списка последовательными номерами. Если первая глава заканчивается на странице 29, то на первой странице второй главы автоматически будет подставлена колонцифра 30. Новые страницы в книгу не добавляются.
  • Next odd page (Следующая нечетная). При выборе данного переключателя программа PageMaker принудительно совмещает начало каждого файла с правой стороной разворота, присваивая ей нечетный номер. Если первая глава заканчивается на странице 29, то PageMaker автоматически добавляет в первую главу еще одну страницу, так, чтобы вторая глава начиналась со страницы 31. Страница 30 остается пустой (на ней присутствуют только элементы публикации, размещенные на странице-шаблоне, но ее вставка смещает начало второй главы на нечетную страницу.
  • Next even page (Следующая четная). При выборе настоящего переключателя программа PageMaker поступает так же, как при выборе предыдущего, за исключением того, что первая страница каждой главы принудительно приводится на страницу с четным номером (левую половину разворота), с добавлением пустой страницы в конец предыдущего файла по мере необходимости.

Отметим, что автонумерация воздействует только на страницы публикации, в пределах которых имеется символ колонцифры (размещенный там непосредственно или перенесенный со страницы-шаблона). Обычно символ колонцифры помещают в текстовый блок верхнего или нижнего колонтитула на странице-шаблоне (см. гл. 16).

Примечание

Обычно структурный список книги размещается в одной из входящих в ее состав публикаций. Есть смысл скопировать его во все публикации книги. Это позволит получить доступ к общему предметному указателю из любой главы книги. Кроме того, вы сможете напечатать структурный список книги из любого ее файла. Для того чтобы скопировать структурный список во все публикации, нажмите клавишу <Ctrl> в момент выбора команды Book (Книга) в публикации, где изначально находится структурный список. Программа PageMaker немедленно скопирует структурный список книги во все файлы, входящие в данный список. Это копирование выполняется однократно. Если впоследствии вам придется вносить изменения в структурный список книги, его придется повторить, поскольку в процессе копирования списка никаких связей файлов не устанавливается и внесенные изменения не переносятся в копии структурного списка.


Имена файлов составной публикации

В гл. 1 уже говорилось о необходимости давать файлам публикаций мнемонические имена. Если же публикация состоит из множества файлов, кроме этого требования предъявляется еще одно: при отображении файлов книги в диалоговых окнах Windows упорядочение файлов по именам должно соответствовать структуре книги, что значительно упрощает визуальный контроль при сборе публикации и передаче материалов в сервисное бюро или в типографию.

Рекомендуем начинать имена файлов книги с порядкового номера. Число разрядов номера должно соответствовать числу разрядов в, максимальном номере файла публикации. Обозначение номера файла несколькими цифрами гарантирует правильный порядок сортировки имен. Если опустить передние нули, то при лексикографическом упорядочении глава 10 встанет после главы 1, но впереди главы 2, поскольку упорядочение ведется по одному символу, поочередно слева направо. Перед номером введите некий уникальный идентификатор группы, например, совпадающий с названием. Включение в состав имени идентификатора гарантирует, что имена файлов будут образовывать компактную группу даже в больших списках диалоговых окон. Вид списка файлов публикации будет примерно таким:

Моя_книга00а Обложка Моя_книга00b Титульный лист Моя_книга00с Предисловие Моя_книга00с1 Оглавление Моя_книга01 Первая глава Моя_книга02 Вторая глава Моя_книга03 Третья глава Моя_книга04а Приложение Моя_книга04b Предметный указатель

Такая система именования гарантирует правильный порядок перечисления файлов в любом списке с лексикографическим упорядочением (например, в левом списке диалогового окна Book Publication List (Структурный список книги)). В то же время алфавитная часть имени файла раскрывает его содержание.


Раздельная пагинация глав

При организации документов с развернутой стркутурой возможна раздельная пагинация. Например, основной тест книги может иметь арабскую нумерацию страниц, введение — нумерацию строчными латинскими буквами, а приложение будет пронумеровано римскими цифрами. Стиль нумерации для такой публикации задается отдельно в каждой части (см. гл. 12). Затем в книгу сводятся главы основного текста и проводится их сквозная перенумерация (см. предыдущий раздел). Затем в книгу включаются части с раздельной нумерацией страниц. После этого автоматическая перенумерация не производится.

Иногда используется специальный прием пагинации с включением в номер страницы префикса. Например, страницы третьей главы нумеруются 3.1, 3.2, 3.3 и т. д. Для пагинации приложений применяются буквенные префиксы — А.1.А.2, А.З.

Раздельная пагинация страниц оказывается очень удобной при необходимости внесения изменений (в технической документации, например, это приходится делать очень часто). Пагинация каждой главы начинается с ее первой страницы и не связана с пагинацией других глав. Таким образом, предотвращается эффект "падающего домино", когда внесение изменения в середину книги вызывает сдвиг номеров страниц до самого конца публикации. Сквозная пагинация всех страниц книги может потребовать повторного вывода на печать всех ее страниц, начиная с той, в которую были внесены изменения. Например, удаление страницы 19 в книге из 200 страниц потребует перепечатки более чем 180 страниц только из-за того, что на них сменился номер. Это намного более накладно, чем перепечатка остатка измененной главы.

Для включения режима пагинации с префиксами необходимо изменить состояние элементов управления программы PageMaker в двух местах. Откройте диалоговое окно Document Setup (Параметры документа) и щелкните мышью на кнопке Numbers (Номера). На экране откроется диалоговое окно Page Numbering (Нумерация страниц), представленное на рис. 17.7. Введите в поле префикс и выберите стиль пагинации.

Диалоговое окно Page Numbering (Нумерация страниц) задает префикс только для оглавления и предметного указателя. Необходимо дополнительно изменить нумерацию страниц в самой главе. Для этого префикс просто вводится с клавиатуры на странице-шаблоне в текстовом блоке нижнего колонтитула, непосредственно перед символом колонцифры (см. рис. 17.7).

Рис. 17.7. Пагинация с префиксами в колонтитулах


Оглавление публикации

Создание оглавления производится командой Create TOC (Создать оглавление) меню Utilities (Сервис). Более точно функцию команды создания оглавления можно определить как сбор оглавления из абзацев публикации, имеющих соответствующий атрибут форматирования. Команда Create TOC (Создать оглавление) занимается объединением абзацев с атрибутом Include in table of contents (Включить в оглавление) в единый блок оглавления. Каждый раз, когда этот атрибут абзацев текста публикации меняется, оглавление приходится собирать заново.

Создание оглавления публикации, таким образом, осуществляется в три этапа:

  1. Определение абзацев, вводимых в оглавление. Каждый из таких абзацев необходимо отформатировать специальным образом, установив в диалоговом окне Paragraph Specifications (Параметры абзаца) флажок Include in table of contents (Включить в оглавление). Как правило, этот атрибут форматирования вводится в состав стиля абзаца. Например, его целесообразно внести в описания стилей форматирования заголовков и подзаголовков, которые обязательно будут включены в оглавление.
  2. Сбор оглавления командой Create TOC (Создать оглавление), которая просмотрит публикацию (или все публикации структурного списка книги). В результате работы этой команды создается новый текстовый материал (story), составленный из абзацев, имеющих атрибут включения в оглавление. Всем элементам оглавления назначаются специальные стили абзацев оглавления. Эти дочерние стили сохраняют атрибуты родительских стилей абзацев.
  3. Материал с оглавлением следует разместить в публикации, желательно в отдельной, и выполнить окончательное оформление оглавления — настроить стили оглавления, убрать лишние детали и т. д.


Определение входов оглавления

На рис. 17.8 представлено диалоговое окно Paragraph Specifications (Параметры абзаца) и выделен флажок, управляющий входом абзаца в оглавление.

Как правило, структура оглавления встраивается в список стилей публикации. Например, можно задать включение в оглавление всех заголовков первого, второго и третьего уровней. Кроме заголовков в оглавление могут включаться и другие элементы публикации (например, подрисуночные подписи, аннотации глав и др.). Командой Create TOC (Создать оглавление) можно пользоваться для сбора специальных оглавлений (например, списка иллюстраций).

Рис. 17.8. Диалоговое окно Paragraph Specifications с флажком режима включения абзаца в оглавление

Примечание

Иногда возникает необходимость включения в оглавление таких элементов, которым не может быть назначен абзацный стиль (например, заголовки в подбор, "фонарики" в висячем отступе и т. п.). Для решения этой проблемы могут использоваться непечатные элементы. Для того чтобы создать невидимый в основном тексте элемент оглавления, поместите его текст в отдельный текстовый блок и определите его как непечатный в меню Element (Элемент). Для того чтобы он не мешал на странице, выключите режим отображения непечатных элементов или переместите текстовый блок за пределы страницы. Достаточно, чтобы лишь небольшая часть текстового блока располагалась на странице, все остальное может находиться на монтажном столе. При таком размещении программа PageMaker будет обрабатывать текстовый блок в процессе сбора оглавления. К сожалению, подобное решение несовершенно, поскольку текст такого непечатного элемента не может быть вложен в конкретное место основного текста и остается в исходном положении даже тогда, когда относящийся к нему текст в результате редактирования сместится вверх или вниз на несколько страниц. Это может привести к ошибкам в номерах страниц, приведенных в оглавлении.


Сбор элементов оглавления

По окончании верстки публикации, когда разбиение текста на страницы представляется окончательным, рекомендуем вам собрать публикации в книгу, если это необходимо, и отладить пагинацию, после чего можно будет приступать к сбору оглавления. Оглавление не обновляется само после переверстки, поэтому его сбор должен осуществляться по окончании верстки. Диалоговое окно Create Table of Contents (Создать оглавление) представлено на рис. 17.9.

Рис. 17.9. Диалоговое окно Paragraph Rule Options

В этом окне можно выбрать различные режимы сбора оглавления:

  • Название оглавления. С этого заголовка будет начинаться текстовый материал оглавления. Заголовок может быть любым. Абзацу заголовка будет назначен стиль ТОС Title (Название оглавления).
  • Обновление оглавления. Если оглавление ранее уже собиралось, можно обновить его, установив соответствующий флажок Replace existing table of contents (Заменить существующее оглавление). Если этот флажок снят, то будет создано новое оглавление в дополнение к старому.
  • Единое оглавление книги. Флажок Include book publications (Общее для всех публикаций книги) управляет режимом сбора оглавления во всех файлах книги. Если он включен, общее оглавление собирается для всех файлов книги. Может быть открыт только один из файлов книги. При составлении оглавления PageMaker сам откроет нужные файлы по порядку, проанализирует их содержимое и закроет, создав общее оглавление для всех включенных в публикацию файлов. При сборе содержания главы область сбора ограничивается отдельным файлом, для чего следует сбросить флажок Include book publications (Общее для всех публикаций книги) в диалоговом окне сбора оглавления.

Примечание

Если один из файлов книги после ее составления перенесен в другой каталог, переименован или уничтожен при попытке работы с целой книгой (в данном случае при сборе оглавления), PageMaker, не найдя файла на прежнем месте, откроет диалоговое окно Find Pub (Найти публикацию) (рис. 17.10). В нем можно указать местонахождение искомого файла (его полное имя написано в заголовке диалогового окна), выбрать тот файл, который будет включен в публикацию вместо потерянного, или пропустить данный и перейти к следующему файлу книги, нажав кнопку Skip (Пропустить).

Формат оглавления. При помощи переключателя Format (Формат) можно задать подавление номеров страниц в оглавлении, размещение номеров страниц перед элементами оглавления или после них.

Рис. 17.10. Диалоговое окно Find Pub

  • Разделитель элемента и номера страницы. Наконец, расположенное в нижней части диалогового окна поле Between entry and page number (Между входом и номером страницы) управляет форматированием элементов оглавления. По умолчанию между темой оглавления и номером страницы вставляется символ табуляции, но это умолчание можно изменить. В поле допускается вставлять до семи обычных или специальных символов. Например, перед символом табуляции можно вставить узкий пробел для последующего форматирования отточия. Форматирование отточий при помощи предшествующего пробела описано в гл. 5.


Размещение оглавления и его настройка

После того как вы щелкните мышью на кнопке ОК диалогового окна Create Table of Contents (Создать оглавление), программа PageMaker приступит к работе и выведет на экран полосковый индикатор, под которым высветятся номера просматриваемых страниц и имена публикаций (рис. 17.11). После завершения сбора оглавления указатель мыши превратится в пиктограмму размещения текста. Теперь можно разместить материал с оглавлением в публикации.

Имеется два варианта размещения оглавления — его можно включить в книгу как отдельную публикацию или в состав имеющейся публикации.

Оглавление можно ввести в состав книги как отдельную публикацию, которая войдет в структурный список книги (см. разд. "Составление структурного списка" данной главы). Этот способ позволяет назначить страницам оглавления любой тип пагинации — как сплошной, так и особый, например строчными римскими цифрами. Оглавление в качестве отдельной публикации будет представлять собой очень маленький файл. Объем памяти, им занимаемый, гораздо меньше, чем для многостраничной главы. Его при необходимости можно держать открытым и обращаться к нему из любого материала книги.

Рис. 17.11. Идет сбор оглавления

С другой стороны, оглавление можно ввести в состав одной из публикаций книги. Это приемлемо при работе с публикациями, в которых нет формального деления на главы. При размещении оглавления в начале книги со сквозной нумерацией необходимо составить оглавление, затем поместить его в публикацию. Страницы оглавления, вставленные в начало, сместят нумерацию. После окончательного размещения оглавления соберите его еще раз в режиме обновления. Номера страниц в новом оглавлении будут адекватны.


Настройка оглавления

PageMaker при сборе оглавления создает для каждого стиля абзаца, входящего в оглавление, парный стиль. Он имеет то же имя, что и родительский, но перед именем прибавляется префикс [ТОС] ([О]). Для нового стиля устанавливается позиция табуляции с выравниванием по правому краю, совмещенная с границей правого поля материала оглавления.

Поскольку стили элементов оформления абзацев оглавления строятся на основе стилей абзацев заголовка, в оглавлении появляется все то, чему там не место — линейки абзацев, капители, позиции табуляции и многое другое. Кроме того, гарнитура, кегль, интерлиньяж и другие атрибуты текста тоже могут абсолютно не соответствовать своему назначению. Поэтому после сбора оглавления его стили практически всегда необходимо перенастраивать. В частности, на этом этапе можно отредактировать вид отточия (см. гл. 5).

Описание стиля оглавления можно редактировать произвольным образом. При этом имя стандартного стиля меняться не должно. Если вы измените имя стиля абзаца оглавления, программа PageMaker при повторном сборе оглавления вновь сформирует стиль со стандартным именем и вы потеряете результаты настройки оглавления.

После настройки оглавления просмотрите его в редакторе материалов на предмет устранения лишних символов. Чаще всего такими символами оказываются признаки перехода на новую строку, которые вы вставили в заголовки при верстке, добиваясь их красивого разбиения на строки. Не исключено, что в оглавлении могут оказаться символы графического выделения пунктов перечней и даже вложенные изображения. Для нахождения и удаления нежелательных символов можно воспользоваться контекстным поиском и заменой.

Примечание

На этом этапе оглавление может оказать существенную пЬмощь в проверке наличия и правильности расположения всех материалов книги. Проверьте, все ли необходимые элементы присутствуют в оглавлении. Если какие-то из них отсутствуют, войдите в публикацию и проверьте их наличие там. Если в публикации эти абзацы есть, значит, вы просто забыли установить для них флажок включения в оглавление.

Наконец, удалите из оглавления все лишние элементы. Такая необходимость возникает, когда заголовки включались в оглавление до нижних уровней и оказались избыточными в укрупненном оглавлении книги в целом. В результате вы получите окончательное оглавление, например такое, как показано на рис. 17.12.

Рис. 17.12. Вид оглавления после сбора


Проверка номеров страниц в готовом оглавлении

Правильность сбора оглавления можно легко проверить по готовому оглавлению. Каждая строка оглавления представляет собой источник гиперссылки, а ее привязкой является данный абзац в основном тексте. В режиме макета инструмент Hand Tool (Рука) используется для проверки гиперссылок. Каждая строка оглавления при выбранном инструменте Hand Tool (Рука) обведена тонкой синей рамкой, говорящей о том, что перед нами не просто текст, а список гиперссылок. Щелкнув курсором (подведенный к ссылке, он принимает форму "указующего перста") на строке, вы отдаете PageMaker команду перейти к данному абзацу в тексте. Таким образом можно проверить все элементы оглавления. Если необходимо проверить указатель книги, щелчок на теме приводит к открытию нужной публикации и переходу на требуемую страницу. В любом случае искомый фрагмент текста (адрес) расположится в средней части главного диалогового окна программы.


Специальные оглавления

Оглавлений может быть и несколько. Например, можно предпослать каждой из глав ее детализированное содержание, как это делал Жюль Берн. Команда сбора оглавлений очень удобна для сбора списка иллюстраций или специальных замечаний, включенных в публикацию.

Примечание

В процессе подготовки этой книги авторы пользовались следующим приемом: в наборе подрисуночные подписи форматировались специальным стилем, который был единственным стилем, включаемым в оглавление. В публикации собиралось оглавление из подрисуночных подписей. Таким списком удобно пользоваться для оформления иллюстраций (поскольку в подрисуночной подписи содержится информация о рисунке) и контроля правильности нумерации рисунков. После обработки рисунков вход в оглавление отключался в стиле подписей. Затем включение в оглавление придавалось стилям абзацев, нужным уже для настоящего оглавления, и весь каталог стилей копировался во все публикации книги.

Начать следует, конечно, с определения элементов. Содержание главы может быть сколь угодно подробным. Если оглавление книги может включать в себя, например, заголовки первого и второго уровней, то в содержание главы вполне можно включить и заголовки последующих уровней, заголов-ки-"фонарики" и подрисуночные подписи. Затем создайте столько материалов оглавления, сколько вам потребуется (например, собственно оглавление, список иллюстраций и перечень специальных замечаний), в результате чего у вас получится несколько идентичных текстовых материалов.

Затем выполняется доработка построенных оглавлений. Поскольку программа PageMaker не позволяет включать в оглавления только требуемые элементы, необходимо удалить из оглавлений большое количество нежелательных абзацев. Например, в главном оглавлении придется удалить десятки, а может быть, и сотни нежелательных подзаголовков и элементов списка иллюстраций. С другой стороны, и в списке иллюстраций будет масса элементов, которым в нем абсолютно не место. Эта проблема решается буквально в несколько движений. Сбор оглавления выполняется по абзацам, каждому из которых вы уже назначили стиль оформления. Для удаления нежелательных абзацев выполните операцию контекстного поиска и замены абзацев с "чуждыми " стилями, оставив поле замены пустым. Это устранит из оглавления все нежелательные абзацы. Выполните эти предварительные действия, после чего откорректируйте стили оглавления.

Следующим этапом будет размещение нужных материалов в соответствующих местах. Основное оглавление и список иллюстраций могут располагаться в начале книги, а содержания глав — перед соответствующими главами. Таким образом, нумерация страниц изменится. Теперь разбиение текста на страницы в вашей публикации приведено в окончательный вид. Если оглавление не предполагает нумерации страниц (содержания глав, иногда списки иллюстраций), то его верстка завершена. Для общих оглавлений с нумерацией страниц придется собрать абзацы заново в отдельном материале и еще раз провести их очистку от нежелательных элементов. Выполните настройку и замените предварительное оглавление в тексте книги на окончательное. Следите за пагинацией! Оглавление, если оно находится не в конце книги, должно оставаться в пределах отведенных для него страниц. В противном случае, работу придется переделывать из-за смещения абзацев.


Составление предметного указателя книги

Составление предметного указателя — это очень кропотливая работа. Однако для большинства специальных изданий такой указатель просто необходим, ведь этими книгами пользуются как учебниками и справочниками. Предметный указатель книги не может быть составлен автоматически, поскольку для его составления обязательно логическое осмысление материала. Тем не менее PageMaker предоставляет мощный комплекс средств автоматизации этого процесса. Ваша задача будет заключаться в определении общей структуры алфавитного указателя, самую тяжелую работу — отслеживание и обновление ссылок при изменении номеров страниц — программа берет на себя. С помощью PageMaker вы можете создать не только простейший указатель для поиска по ключевым словам, но и развитый справочник по всей содержащейся в книге информации.


Два типа указателей

Вы можете снабдить вашу книгу указателем одного из двух типов — простейшим алфавитным или предметным.

Алфавитный указатель (Concordance) представляет собой список основных терминов книги (ключевых слов), встречающихся в ней имен названий и личных имен с приведением номеров страниц, на которых они упоминаются.

Предметный указатель (Index) — это упорядоченный по алфавиту список тем, рассмотренных в книге, названий и имен, упоминающихся в ней, с приведением номеров страниц, на которых они упоминаются или обсуждаются. В таком указателе темы организованы в иерархическую структуру, между темами при необходимости установлены перекрестные ссылки. Конечно же, в предметном указателе представлены все важные темы, рассмотренные в книге, вне зависимости от того, обозначается ли их предмет одним словом или нет (темы могут обозначаться одним словом или описываться целым предложением).

С точки зрения читателя, предметный указатель предоставляет намного более удобный способ поиска информации в книге. В идеале составитель предметного указателя старается руководствоваться в работе логикой читателя, стремящегося найти в книге те или иные сведения. Наличие полного логически обоснованного списка тем и перекрестных ссылок позволит читателю найти нужные ему сведения, спрятанные в пространном тексте, отталкиваясь от различных предпосылок. Если вы располагаете временем, настоятельно рекомендуем вам снабдить книгу предметным указателем, это значительно повысит ее ценность для читателя.


Порядок построения предметного указателя

Принцип работы. Элемент предметного указателя состоит из двух частей — темы и входов ссылки. Тема — это собственно пункт указателя. Вход ссылки — это место в тексте книги, где упоминается или обсуждается данная тема. Это место в тексте помечается специальным маркером, видимым только в режиме текстового редактора (это действие называется кодированием входа ссылки). Маркер является вложенным спецсимволом и предназначен для хранения информации о конкретном входе указателя. На основании расположения маркеров в тексте PageMaker устанавливает точные адресные ссылки. В процессе генерации алфавитного указателя PageMaker выбирает из публикации входы указателя и сортирует их в алфавитном порядке.

Темы указателя собраны в базу данных и могут иметь три уровня подчинения. Вводя маркер входа, вы указываете, на какую тему будет данная ссылка. Список тем можно обновлять и перестраивать.

Итак, ваша задача состоит в составлении списка тем и кодировании входов ссылок на них посредством маркеров. Предметный указатель можно составлять как по готовой рукописи, так и в процессе ее написания, кодируя входы указателя по мере набора текста. Первый вариант предполагает предварительное составление списка тем, а затем кодирование входов. Второй способ основан на постепенном пополнении списка тем и одновременно — кодировании их входов. Первый вариант проще для начинающих составителей, поскольку в руках у вас уже есть готовая рукопись, а значит, и список тем будет более полным и адекватным.

Список тем. Советуем вам заранее составить список тем указателя. Это позволит вам подойти к работе по кодированию входов более методично, наличие списка позволит вам сверяться с ним в процессе кодирования входов. Вы сможете сразу организовывать темы нескольких уровней, собранные в гнезда.

При непоследовательном кодировании образовавшийся указатель нуждается в серьезной редакции входов. Чаще всего причиной непоследовательности в кодировании тем выступает эволюция взглядов писателя на предмет в процессе работы над книгой (в случае организации указателя в процессе написания книги). Список тем, заготовленный заранее, обеспечивает хотя бы минимальную последовательность в кодировании входов. При необходимости в дальнейшем изменить тему это можно сделать с минимальной затратой усилий, поскольку относящиеся к ней ссылки были закодированы в соответствии со списком тем, что обеспечивает удобство их поиска и замены.

Если вы решили составлять предметный указатель средствами программы PageMaker, составьте список тем при помощи любого текстового процессора, а затем импортируйте его в PageMaker. Темы будут внесены в список предметного указателя публикации PageMaker, что даст впоследствии возможность кодировать новые входы указателя выбором названий тем из списка.

Примечание

Если предметный указатель составляется по готовой рукописи, имеется возможность частично автоматизировать составление списка тем. Фирмой Virginia Systems разработано дополнение Sonar Bookends, которое автоматически составляет алфавитный указатель слов, использованных в тексте, на основе частоты их употребления. Затем этот список можно отредактировать, дополнить и использовать в качестве списка тем предметного указателя. Кроме того, в дополнении Sonar Bookends есть средства для определения номеров страниц и замены слов, так что им вполне можно пользоваться для составления алфавитного указателя.

Кодирование входов. Непосредственное кодирование входов указателя — самая простая (и самая утомительная) часть работы по составлению предметного указателя. При ее выполнении средствами программы PageMaker достаточно выделить местоположение темы в тексте и воспользоваться комбинацией клавиш для того, чтобы внести топографическую ссылку на нее в базу данных предметного указателя. Могут создаваться простые темы, вложенные темы, топографические ссылки на отдельные страницы и на диапазон страниц, а также несколько типов перекрестных ссылок. Более подробно о кодировании см. в разд. "Кодирование входов указателя" данной главы. Для кодирования можно воспользоваться операциями поиска и замены, что существенно снижает трудозатраты.

Сбор, размещение и доработка предметного указателя. После того как все входы тем закодированы, сбор указателя не составит особого труда. Команда Create Index (Создать указатель) просматривает текст публикации, из него выделяются все входы, которые затем организуются в предметный указатель правильной структуры. После сбора программа показывает пиктограмму размещения текста. Щелкните на странице, и собранный указатель "материализуется". Текстовый материал предметного указателя размещается в соответствующем месте публикации. На этом этапе построение предметного указателя ничем не отличается от сбора оглавления.

Теперь можно приступать в корректуре предметного указателя, для чего рекомендуем отпечатать его на бумаге. Устраните дублирование входов, опечатки и другие ошибки, настройте стили предметного указателя, генерированные PageMaker.

Разберем каждый этап построения указателя подробнее. Подчеркнем, что указатель работает только с английским языком, поэтому некоторые примеры в последующих разделах будут даны по-английски.


Кодирование входов указателя

Кодируя входы тем, вы создаете элементы указателя. Элемент указателя — это строка, например, такого вида:

"Effel Tower 2, 5, 79—83, see also Paris".

Первая часть в этом элементе — тема, вторая — входы ссылок на тему. Таким образом, ваша задача состоит в том, чтобы найти места в тексте, в которых встречается тема, отметить их специальным маркером и задать этому маркеру соответствие данной теме.

Как и все вспомогательные операции, кодирование входов лучше выполнять в окне редактора материалов. В этом режиме вы можете быстрее перемещаться по тексту и видеть местоположение установленных маркеров входа (рис. 17.13). Маркеры входов не занимают места на странице, поэтому их расстановка не вызывает смещения текста и иных нарушений верстки страниц. Кроме того, вы можете пользоваться инструментами поиска и замены для частичной автоматизации работы.

Рис. 17.13. Вид маркеров входа в окне редактора материалов

Для того чтобы установить маркер входа, поставьте точку вставки в нужное место текста или выделите текст, относящийся к теме. Затем выберите в меню Utilities (Сервис) команду Index Entry (Вход указателя). Откроется диалоговое окно Add Index Entry (Добавить вход указателя), в котором вы можете задать свойства проставляемого входа указателя. Это диалоговое окно изображено на рис. 17.14.

Рис. 17.14. Диалоговое окно Add Index Entry

В верхней части списка находятся два переключателя Туре (Тип ссылки), соответствующие двум типам ссылок:

  • Page reference (Прямая), ссылка на конкретное место в книге (страницу или группу страниц), в котором упоминается данная тема. В примере, приведенном выше, прямой ссылкой являются номера страниц после темы.
  • Cross-reference (Перекрестная), ссылка на другую тему предметного указателя, в которой, в свою очередь присутствуют ссылки на первую. В приведенном примере пример перекрестной ссылки — "see also Paris". Это означает, что в теме Paris также есть ссылки на материал, связанный с Эйфелевой башней. Перекрестные ссылки будут рассмотрены в соответствующем разделе этой главы.

    Сейчас мы рассмотрим прямые ссылки. При этом переключатель должен быть установлен в положение Page reference (Прямая).

Ниже в диалоговом окне Add Index Entry (Добавить вход указателя) расположены три поля темы ссылки, соответствующие трем уровням ссылки. Если перед началом создания входа указателя вы выделили фрагмент текста, то этот текст пй умолчанию появится в верхнем поле в качестве темы верхнего уровня. Вы можете отредактировать текст темы или совсем изменить его. Если вы заполните только поле темы верхнего уровня, образуется адресная ссылка верхнего уровня. Если заполните первое и второе поля — образуется ссылка второго уровня, если же заполните все три поля уровней темы, в указателе образуется ссылка третьего уровня. При этом номера страниц в адресной ссылке будут помещены после названия темы самого нижнего уровня.

Для примера рассмотрим фрагмент предметного указателя с разным числом уровней тем и соответствующее расположение тем в строках ввода диалогового окна (рис. 17.15):

а

б

в

Рис. 17.15. Разное число уровней тем в указателе менять местами с помощью

Темы, определенные для данного входа, можно менять местами с помощью кнопки Move (Подвинуть) с пиктограммой (две встречные стрелки). При нажатии этой кнопки темы движутся по кругу — первая на место второй, вторая на место третьей, третья на место первой. Соответственно меняются и уровни этих тем в предметном указателе. Пример изменения уровней тем приведен на рис. 17.16.

а

б

Рис. 17.16. Результат изменения уровней тем

Вы можете вводить темы указателя с клавиатуры, а можете воспользоваться заранее составленным списком. Для того чтобы выбрать темы из ранее составленного списка, щелкните мышью на кнопке Topic (Тема). На экране откроется диалоговое окно Select Topic (Выбрать тему), внешний вид которого показан на рис. 17.17.

Рис. 17.17. Выбор темы из имеющегося списка

Это диалоговое окно представляет собой базу данных по всем темам, которые уже введены в материал настоящей книги. Любую из тем, импортированных из текстового процессора или созданных прежде при. кодировании входов, можно выбрать в этом диалоговом окне. Темы сгруппированы в разделы по первой букве. Для перехода к другому разделу можно воспользоваться раскрывающимся списком Topic section (Алфавитный раздел) или кнопкой Next section (Следующий).

Если вы работаете с книгой, в структурном списке которой указано несколько публикаций, щелкните мышью на кнопке Import (Импорт). После этого программа PageMaker просмотрит файлы всех публикаций, перечисленных в структурном списке, и отобразит все найденные в них темы всех уровней в диалоговом окне выбора темы. Таким образом, кнопка Import (Импорт) служит для синхронизации обозначения тем в различных главах книги. Это — очень важный момент, пренебрежение которым может привести к непоследовательности кодирования тем.

После выбора темы щелкните мышью на кнопке ОК. На экране останется открытое диалоговое окно Add Index Entry (Добавить вход указателя), но теперь его поля уровней темы будут уже заполнены.

Выбор тем в диалоговом окне Select Topic (Выбрать тему) приводит к полному стиранию всех уровней тем, введенных ранее. Однако если в момент выполнения щелчка мышью на кнопке ОК была нажата клавиша <Ctrl>, то тема, выбранная в диалоговом окне Select Topic (Выбрать тему), будет только скопирована в пустые поля уровней тем диалогового окна Add Index Entry (Добавить вход указателя), а его заполненные" поля сохранят свои значения.

Например, вы выделили в тексте слово Paris и кодируете для него вход указателя. В открывшемся диалоговом окне Add Index Entry (Добавить вход указателя) выделенное слово будет помещено в поле темы верхнего уровня. Предположим, что на самом деле это слово соответствует третьему уровню темы, а темы первого и второго уровня необходимо выбрать из списка тем. Двукратным щелчком мыши на кнопке Move (с двумя встречными стрелками) переместите слово в поле темы третьего уровня и щелкните мышью на кнопке Topic (Тема). Выберите в открывшемся диалоговом окне тему первого и второго уровня и щелкните мышью на кнопке ОК, удерживая нажатой клавишу <CtrI>.

Теперь поля тем первого и второго уровня диалогового окна Add Index Entry (Добавить вход указателя) заполнены только что выбранными темами, а в поле темы третьего уровня осталось находившееся там ранее слово Paris. Если бы вы забыли нажать клавишу <Ctrl> перед щелчком мышью на кнопке ОК, это слово было бы стерто.


Настройка сортировки элементов указателя

PageMaker упорядочивает предметный указатель лексикографически, в соответствии с порядком следования символов в кодовой таблице ASCII. Вначале темы упорядочиваются по первому символу, затем — по второму и т. д. Пробелы, специальные символы и цифры в кодовой таблице ASCII предшествуют буквам алфавита.

При сортировке чисел PageMaker расположит рядом такие числа, как 1, 100 и 1000, и только вслед за последним из них поместит числа 2, 20 и 2 000 000. Это — издержки лексикографического метода сортировки. Тема St. John будет расположена по соседству с темами state и straight, а не рядом с темой Saint Joseph, что было бы, на первый взгляд, логичнее.

Для правильной сортировки элементов указателя предназначены поля ввода Sort (Сортировать), расположенные параллельно строкам ввода уровней тем. В них можно задавать порядок сортировки тем для каждой темы индивидуально. Изменить порядок сортировки элементов в целом невозможно. В строки поля Sort (Сортировать) вводится соответствующая тема, таким образом, чтобы при сортировке указателя она была расположена в нужном месте. Введенная строка становится атрибутом темы и перемещается вместе с ней при смещении уровня тем.

Присутствие текстовой строки в каком-либо поле Sort (Сортировать) говорит программе PageMaker о том, что данную тему следует вставлять в указатель не в соответствии с ее фактическим написанием, а в соответствии с написанием этой текстовой строки.

Для того чтобы темы St. John и Saint Joseph разместились в предметном указателе рядом, следует в поле Sort (Сортировать) для темы St. John напечатать Saint John. После этого в результате сортировки обе темы будут расположены рядом (рис. 17.18).

Рис. 17.18. Настройка положения элемента указателя


Виды адресных ссылок

В большинстве случаев адресная ссылка должна указывать на единственную страницу, на которой и упоминается тема. Однако, в случае подробного обсуждения темы в тексте, в предметном указателе встречаются ссылки на последовательность страниц (Paris 3—5). Для определения радиуса действия ссылки в диалоговом окне Add Index Entry (Добавить вход указателя) предназначена группа переключателей Page range (Диапазон). Устанавливая подходящее значение диапазона страниц, упоминаемых в ссылке, вы добьетесь точного соответствия ссылок тексту публикации. Ниже приводится список переключателей группы Page range (Диапазон) и область применения каждого из них.

  • Current page (Текущая страница). Как можно было предположить, этот переключатель соответствует формированию ссылки на одну страницу, привязанной к местоположению точки вставки на момент выбора команды Index Entry (Вход указателя). Применяется наиболее часто. В больших публикациях используется для кратких упоминаний.
  • То next style change (До первого изменения стиля). Данный переключатель соответствует формированию ссылки на диапазон страниц до первой смены стиля абзацев. Это очень удобно в ситуациях, естественным образом связанных со стилевым форматированием (например, ссылка на примечание, отформатированное специальным стилем, по окончании которого восстанавливается стиль основного текста). Таким образом легко установить ссылку на фрагмент основного текста, начинающийся в точке вставки и заканчивающийся следующим подзаголовком любого уровня. Если весь диапазон укладывается в пределы одной страницы, в указателе будет оформлена обычная ссылка.
  • То next use of style (До следующего появления стиля). Этот переключатель соответствует формированию ссылки на диапазон страниц до следующего применения заданного стиля абзаца. Если вы хотите, чтобы топографическая ссылка указывала диапазон всех страниц, озаглавленных заголовком какого-либо уровня, установите настоящий переключатель и выберите в раскрывающемся списке имя стиля, назначенного таким заголовкам.
  • For next ... paragraphs (Для следующих ... абзацев). Если вы знаете, что та или иная тема раскрывается в нескольких следующих абзацах, данный переключатель позволяет вам задать число таких абзацев (например, 16), которые и сформируют диапазон ссылки. PageMaker сформирует вход указателя со ссылкой на диапазон, начало которого соответствует положению точки вставки, а конец располагается на 16 абзацев ниже. Это наиболее точный метод задания диапазона ссылки.
  • Suppress page range (Без указания диапазона страниц). В некоторых случаях необходимо создание входа указателя без ссылки. Чаще всего данный переключатель используется при предварительной работе с указателем, когда еще до конца не ясно, каким окажется в окончательном варианте диапазон страниц ссылки.


Форматирование номеров страниц в указателе

Для номера страницы в ссылке любого элемента предметного указателя можно назначить специальное форматирование символов при помощи флажков, входящих в группу Page # override (Начертание номера страницы), расположенных в нижней части диалогового окна Add Index Entry (Добавить вход указателя) (см. рис. 17.18). Как воспользоваться этой возможностью? Можно, например, выделить ссылки на страницы с иллюстрациями курсивным начертанием. Можно выделить ссылку на страницу, наиболее полно раскрывающую содержание темы, полужирным начертанием.

Флажки, входящие в группу Page # override (Начертание номера страницы), в установленном состоянии инвертируют локальное и стилевое форматирование ссылок, заданное стилями абзацев указателя, в части соответствующих им атрибутов. Поэтому, если стиль абзаца предметного указателя предполагает его форматирование курсивным начертанием, установка флажка Italic (Курсив) приведет к противоположному эффекту — номер страницы будет выведен прямым начертанием.

Сделанный выбор состояния флажка запоминается и используется по умолчанию до тех пор, пока не будет изменен пользователем. Все входы указателя, созданные после установки флажка, будут форматироваться в соответствии с включенным режимом специального форматирования. Если после создания входа с курсивным номером страницы вы случайно забудете сбросить флажок Italic (Курсив), это может привести к нежелательному форматированию множества определенных после этого входов указателя. С другой стороны, если в нескольких входах, определяемых непосредственно друг за другом, необходимо вывести номер страницы курсивом, нет необходимости каждый раз менять установку этого флажка — он остается установленным.


Перекрывающиеся темы

Под термином перекрывающиеся темы (overlapping topics) подразумевается ситуация, в которой несколько единиц предметного указателя ссылаются на один и тот же участок текста. Например, на фрагмент текста об Эйфелевой башне может быть ссылка в темах Architecture, Paris, Universal exposition a Paris и т. д. При работе с перекрывающимися темами вам точно понадобится определять по несколько входов предметного указателя с общей ссылкой.

Для того чтобы связать с одним и тем же местом текста несколько входов предметного указателя, нет необходимости выходить из диалогового окна Add Index Entry (Добавить вход указателя) для установки дополнительных маркеров в редакторе материалов. Можно просто щелкнуть мышью на кнопке Add (Добавить). После этого на экране появляется диалоговое окно Add Index Entry для нового входа. В нем необходимо проделать все обычные действия по созданию нового входа предметного указателя. После каждого" щелчка мышью на кнопке Add (Добавить) в окне редактора материалов автоматически появляется новый маркер.

Информация в полях диалогового окна сохраняется, так что при создании дополнительного входа вы можете воспользоваться ее частью, но во избежание возникновения полностью совпадающих единиц указателя кнопка Add (Добавить) остается недоступной до тех пор, пока вы не измените обозначение тем хотя бы на одном из уровней.

Кнопка смены уровня темы (две встречные стрелки), которая сдвигает уровни тем по кругу (см. предыдущий раздел), позволит ускорить процесс создания таких единиц указателя. Представьте себе, что вам необходимо составить предметный указатель для книги "Развитие архитектуры стран Западной Европы". Естественно, что в нем будет множество тем, соответствующих различным стилям архитектуры.

Например, предположим, что вы только что создали вход для темы Paris, Architectural installations, art noveau. Учитывая общую тематику книги, вы можете предположить, что отдельные читатели захотят найти информацию, отталкиваясь от архитектурного стиля. Щелкните мышью на кнопке смены уровня темы. Каждый раз, когда вы выполняете щелчок на ней, происходит циклическая перестановка тем по уровням. В результате исходная тема превращается в тему Architectural installations, art noveau, Paris, что, собственно, и требовалось. Осталось только создать вход щелчком на кнопке ОК.


Быстрое добавление новой темы из текста

Список тем можно в случае необходимости оперативно пополнять фрагментами из текста. Если вы уверены, что никаких корректировок темы не потребуется, операцию можно выполнить и без открытия диалогового окна. Для этого достаточно выделить фрагмент текста и воспользоваться комбинацией клавиш <Ctrl>+<Shift>+<Y>. В этом случае перед выделенным фрагментом сразу появится маркер указателя и диалоговое окно Add Index Entry (Добавить вход указателя) открываться не будет. Вход предметного указателя создается с учетом значений по умолчанию, действующих на момент нажатия названной комбинации клавиш. Темой в данном случае будет выделенный фрагмент текста. Вы всегда можете затем отредактировать созданный вход, выделив его и нажав комбинацию клавиш <Ctrl>+<Y>.

Примечание

Не исправляйте начальные буквы тем указателя на прописные вручную — PageMaker может сделать это автоматически. При настройке тем, созданных по фрагментам текста, нет необходимости корректировать в них первую букву, заменяя ее на прописную (если этого требует принятая вами система форматирования предметного указателя). В диалоговом окне команды Show Index (Просмотр указателя) имеются средства для автоматического форматирования прописных. Подробнее о них см. в разд. "Редактирование предметного указателя" данной главы.


Перекрестные ссылки

Входы предметного указателя с перекрестными ссылками не содержат колонцифр. Перекрестная ссылка устанавливает связь двух родственных тем при помощи словесной ремарки типа "см. также". Например, за темой "Архитектурные сооружения" могут идти перекрестные ссылки на темы "Стили архитектуры", "Карта Парижа". В каждой из этих тем должна быть встречная перекрестная ссылка на тему "Архитектурные сооружения". На рис. 17.19 приведено несколько типов перекрестных ссылок.

Рис. 17.19. Фрагмент предметного указателя с перекрестными ссылками

При выборе перекрестного типа ссылки диалоговое окно Add Index Entry (Добавить вход указателя) несколько меняется по сравнению с вариантом для прямой ссылки (рис. 17.20).

Рис. 17.20. Создание входа предметного указателя с перекрестной ссылкой

Некоторые из элементов управления диалогового окна присутствуют в нем независимо от выбранного типа ссылки. Это касается кнопки смены уровня тем (две встречные стрелки), полей группы Sort (Сортировать) и группы Topic (Тема), а также кнопки Topic (Тема), открывающей список тем указателя, в котором можно выбрать нужную тему из существующих. Группа флажков X-ref override (Начертание Х-ссылки) аналогична группе флажков Page # override (Начертание номера страницы), за исключением того, что специальное форматирование, задаваемое ими, относится не к номеру страницы ссылки, а к тексту темы в составе перекрестной ссылки.

Кнопка X-ref (Х-ссылка) работает точно так же, как кнопка Topic (Тема), открывая аналогичное диалоговое окно (рис. 17.21). Однако назначение этого диалогового окна совершенно другое.

Рис. 17.21. Выбор темы для перекрестной ссылки

Напомним, что диалоговое окно Select Topic (Выбрать тему), открываемое кнопкой Topic (Тема), предоставляет возможность выбора темы, в которой будет располагаться ссылка.

Кнопка же X-ref (Х-ссылка) открывает диалоговое окно Select Cross-Reference Topic (Выбрать тему для Х-ссылки), в котором вы должны выбрать тему, на которую будете ссылаться в вашей перекрестной ссылке. На рис. 17.21 это art noveau.

Перекрестная ссылка не имеет привязки к конкретному диапазону страниц, поэтому группа переключателей Page range (Диапазон) отсутствует. Вместо нее здесь находится группа переключателей Denoted by (Вид ссылки), каждый из которых соответствует тому или иному варианту словесной ремарки, связывающей две темы в перекрестной ссылке. Ниже рассматривается отдельно каждый переключатель.

  • See [also] (См. [Также]). Эта позиция соответствует автоматизированному выбору варианта ремарки: see или see also. Программа PageMaker делает выбор по своему усмотрению и обычно справляется с этим настолько хорошо, что большинство пользователей никогда не работают с другими переключателями.

    Принцип выбора между двумя названными ремарками прост — когда тема входа с перекрестной ссылкой совпадает с темой какой-либо единицы предметного указателя и в этой единице имеются прямые ссылки, программа PageMaker выбирает вариант see also. Иными словами, в книге имеются два места, куда следует заглянуть в поисках сведений: первое из них соответствует теме входа с перекрестной ссылкой, а второе — теме, на которую отсылает перекрестная ссылка. Читателю рекомендуется ознакомиться с обоими фрагментами текста. Такую перекрестную ссылку можно рассматривать как симметричную, поскольку в теме, на которую отсылает перекрестная ссылка, скорее всего, должен быть вход с перекрестной ссылкой на исходную тему, т. е. "в обратном направлении".

    Если тема входа с перекрестной ссылкой не совпадает ни с одной другой темой предметного указателя и в ней нет входов с прямыми ссылками, необходимые сведения в книге следует искать только в одном месте, В таком случае PageMaker вставляет ремарку see. Такая перекрестная ссылка несимметрична, она указывает в одном направлении — на тему, в которой имеются прямые ссылки, по которым и следует искать нужные сведения. При выборе ремарки программа PageMaker просматривает только один уровень тем.

    See (См.). Если по той или иной причине вам необходимо обойти автоматический выбор ремарки перекрестной ссылки и установить несимметричную перекрестную ссылку, используйте названный переключатель.

  • See also (См. также). Этим переключателем можно воспользоваться тогда, когда есть уверенность в том, что впоследствии в единице указателя, соответствующей данной теме, появятся входы с прямыми ссылками.
  • See herein (См. далее) и See also herein (См. также далее). Эти два переключателя работают так же, как переключатели See (См.) и See also (См. также), за одним исключением. Ими пользуются при установлении перекрестной ссылки на тему, не имеющую подтемы. Это делается для того, чтобы читатель не пропустил важной информации в той части указателя, где он насыщен большим числом подтем. Например, в уже упоминавшейся книге об архитектурном развитии стран Европы единица предметного указателя, соответствующая одиночной теме первого уровня Architectural styles, может занимать целую страницу, а то и несколько страниц, поскольку в ее состав входят подтемы, соответствующие господствующим стилям архитектуры, сменявшим друг друга в Европе на протяжении веков.

Примечание

Если в единице предметного указателя теме соответствуют двадцать подтем, не стоит дублировать эти подтемы в другой теме сходного содержания — лучше воспользуйтесь перекрестными ссылками. Рассмотрим этот метод на примере. Пусть темой первого уровня будет "Исторические памятники Парижа", а темой второго уровня — "Архитектурные сооружения". Если на третьем уровне рубрикации в теме "Архитектурные сооружения" появляется 15 тем третьего уровня с названиями конкретных сооружений, есть смысл вставить вместо них перекрестную ссылку типа See. Тема "Архитектурные сооружения" в таком варианте дублируется на первом уровне, а названия конкретных сооружений выступают в ней как темы второго уровня. Для создания перекрестной ссылки используют переключатели See (См.) и See also (См. также).


Автоматическое кодирование ссылок

После определения первого вхождения темы в текст удобно сразу кодировать все ссылки на эту тему так, чтобы каждому упоминанию того или иного термина соответствовала прямая топографическая ссылка в предметном указателе. Такой подробный предметный указатель незаменим в учебниках. Операцию кодирования ссылок на все вхождения темы в текст можно автоматизировать, если воспользоваться командой контекстной замены. Рассмотрим этот прием на примере (рис. 17.22).

Рис. 17.22. Установка прямых ссылок командой Change

Введите слово или словосочетание, на которое следует установить ссылки (в нашем примере — "Эйфелева башня"), в поле Find what (Найти текст) диалогового окна команды замены. В поле Change to (Заменить на) достаточно ввести только символы ^; , не дублируя само словосочетание. Присутствие в поле замены символов ^; распознается как специальный код, или метасимвол, соответствующий маркеру входа предметного указателя, контекстные поиск и замена выполняются в особом режиме, в результате чего каждое вхождение слова или словосочетания будет отмечено маркером входа.

Если ваша публикация такова, что специальные термины употребляются группами, и на одной странице термин может встретиться не единожды, каждый вход термина будет помечен маркером входа. В процессе сбора предметного указателя PageMaker устраняет дубликаты ссылок на одну и ту же страницу. В результате, сколько бы маркеров, соответствующих одной и той же теме указателя, ни было установлено на странице, в окончательном варианте указателя все они сведутся к одному входу с единственной прямой ссылкой на данную страницу. Впрочем, имеет,смысл фиксировать все случаи использования приема маркировки вхождений контекста — эти заметки могут понадобиться, на этапе заключительного редактирования указателя. Например, некоторые из созданных таким образом входов можно затем преобразовать, откорректировав ссылку и указав в ней диапазон страниц.


Именной указатель

В тексте обычно сначала пишут имя человека, потом фамилию. При создании именного указателя необходимо установить сортировку по фамилиям, для чего следует поменять местами имя и фамилию лица в строке темы или сортировки. В PageMaker возможно частично автоматизировать операцию сортировки именного списка по фамилиям. Для этого предусмотрена специальная комбинация клавиш. Если в тексте встречаются имя и фамилия лица в обычном порядке, например "Александр Эйфель", следует выделить это сочетание и воспользоваться специальной комбинацией клавиш <Ctrl>+ +<Alt>+<Y>. Ее действие практически не отличается от действия ранее рассмотренной комбинации клавиш для быстрого создания темы по выделенному тексту <Ctrl>+<Shift>+<Y>. Перед выделенным текстом появляется маркер входа. Если вы выделите маркер и нажмете комбинацию клавиш <Ctrl>+<Y>, вы увидите результат действия команды — создана обычная ссылка с темой из выделенного текста, но первое и второе слово (имя и фамилия) меняются местами. В именном указателе появилась тема "Эйфель, Александр", автоматически подготовленная к сортировке по фамилиям.

Рассмотренная операция является автоматической перестановкой первого и второго слова. Если в тексте встретилось сочетание "Эйфель Александр" (правда, такой порядок имени и фамилии в основном тексте встречается намного реже), то с помощью комбинации клавиш <Ctrl>+<Alt>+<Y> будет создана ссылка с темой "Александр, Эйфель". PageMaker решил, что "Александр" — это фамилия, а "Эйфель" — имя человека (в самом деле, каких только имен не бывает!). Таким образом, при инверсном написании имени и фамилии лица в основном тексте для ввода ссылки воспользуйтесь обычным приемом быстрого создания входа указателя с помощью комбинации клавиш <Ctrl>+<Shift>+<Y>.

Программа PageMaker не может без вашей помощи справиться с преобразованием в тему имени, состоящего более чем из двух слов, даже если порядок имен и фамилий обычный. Если вы хотите, чтобы тема именного указателя, созданная по тексту Alexander Gustave Eiffel, была помещена в раздел каталога, связанный с буквой Е, вам придется заменить обычный пробел между словами Alexander и Gustave на неразрывный (комбинация клавиш <Ctrl>+ +<Shift>+<H>). В этом случае первые два слова имени будут рассмотрены PageMaker как одно слово и она правильно преобразует текст в тему именного указателя.

Примечание

Если вы заменили пробел между частями двойного имени или фамилии на нераздельный, необходимо проверить, не повлияло ли это на разбиение текста на страницы, для чего временно перейдите в режим макета, нажав комбинацию клавиш <Ctrl>+<E>.


Ссылки на все вхождения имени в текст

Если вы хотите автоматически сформировать прямые ссылки на все упоминания о лице, воспользуйтесь описанным выше приемом контекстного поиска и замены. Только теперь вам придется ввести в поле Change to (Заменить на) не ^; , a ^z. После этого метасимвола обязательно введите то же имя, которое было введено и в поле образца поиска.


Редактирование предметного указателя

Некоторую часть работы по редактированию предметного указателя можно выполнить еще до его сбора, проверив правильность ссылок в соответствующем диалоговом окне. Затем рекомендуется собрать указатель и распечатать его. Тщательно проверьте бумажный оригинал, пометьте ошибки и последовательно исправьте их в основном тексте.


Работа с командой Show Index

PageMaker располагает великолепным инструментом для редактирования предметного указателя. Все темы и ссылки публикации (в том числе и составной) объединены в базу данных, доступ к которой осуществляется в специальном диалоговом окне Show Index (Просмотр указателя). В нем можно просматривать по очереди все прямые и перекрестные ссылки, определенные для каждой темы, редактировать вход указателя, изменяя тему и ее уровень, добавлять перекрестные ссылки и удалять ненужные, автоматически устанавливать написание тем указателя с прописной буквы, т. е. выполнять все действия по редактированию указателя.

При выборе команды Show Index (Просмотр указателя) на экране появляется диалоговое окно со списком входов предметного указателя (рис. 17.23).

Каждая запись в этой базе данных (в списке диалогового окна) соответствует одному маркеру входа предметного указателя, вставленному в текст публикации, с указанием номера страницы или темы (для перекрестной ссылки). Для выбора конкретного входа в этом окне используются те же приемы, что и при работе с диалоговым окном Select Topic (Выбрать тему). В окне демонстрируются все темы со ссылками (в том чисде с перекрестными) на одну букву алфавита, т. е. один раздел указателя. Для перехода к другой букве необходимо выбрать ее из алфавитного списка Index section (Раздел указателя) или перейти к следующему по алфавиту разделу нажатием кнопки Next section (Следующий).

Рис. 17.23. Диалоговое окно Show Index

Диалоговое окно Show Index (Просмотр указателя) — идеальный инструмент для предварительного просмотра входов предметного указателя на предмет устранения очевидных ошибок (например, наличия двух различных написаний одной и той же темы) перед размещением указателя в публикации.


Редактирование входа предметного указателя

Как вы уже поняли, в процессе редактирования входов предметного указателя нет необходимости просматривать весь текст публикации. Любой из маркеров входов предметного указателя можно отредактировать непосредственно из диалогового окна Show Index (Просмотр указателя). Для этого щелкните мышью на кнопке Edit (Редактировать) или дважды — на строке, соответствующей входу. Откроется диалоговое окно Edit Index Entry (Редактировать вход указателя), аналогичное по структуре диалоговому окну Add Index Entry (Добавить вход указателя), рассматривавшемуся ранее. Отличие этих окон заключается в невозможности поменять тип ссылки (прямая или перекрестная) и невозможности воспользоваться кнопкой Add (Добавить) для добавления ссылки в текст. Все остальное выглядит и работает таким же образом: диапазоны страниц, типы перекрестных ссылок и специальное форматирование номеров страниц и ремарок.


Добавление перекрестной ссылки

Поскольку при составлении предметных указателей часто приходится добавлять перекрестные ссылки на другие темы, в диалоговом окне Show Index (Просмотр указателя) для этой цели предусмотрена кнопка Add x-ref (Добавить х-ссылку). Щелчок мышью на этой кнопке раскрывает диалоговое окно Add Index Entry (Добавить вход указателя), ориентированное только на работу с перекрестными ссылками (тип ссылки Page reference (Прямая) недоступен). О создании перекрестной ссылки см. соответствующий раздел данной главы.


Промежуточное сохранение результатов

Используйте кнопку Accept (Принято) для промежуточного сохранения. Действие этой кнопки в какой-то мере аналогично действию кнопки Apply (Применить) в диалоговом окне Indents/Tabs (Отступы/Табуляция). База данных предметного указателя не хранится как физическая единица. При открытии диалогового окна Show Index (Просмотр указателя) PageMaker каждый раз просматривает документ и создает ее заново. В случае большой книги, состоящей из нескольких глав, этот процесс может потребовать достаточно много времени. При щелчке мышью на кнопке ОК или Cancel (Отменить) PageMaker закрывает названное диалоговое окно, и для продолжения работы с предметным указателем приходится собирать его базу заново. Кнопка Accept (Принято) сохраняет каждое сделанное изменение без выхода из диалогового окна. Если вы при редактировании регулярно нажимаете на эту кнопку, изменения будут постоянно записываться в базу. Если теперь по ошибке вы выйдете из диалогового окна кнопкой Cancel (Отменить), все изменения указателя, кроме последнего, нежелательного, будут сохранены.

Примечание

Для отмены неправильного изменения необязательно выходить из диалогового окна. Если необходимо удалить только те входы, которые были внесены в предметный указатель после того, как вы в последний раз щелкнули мышью на кнопке Accept (Принято) или ОК (заметьте, что это могут быть только входы перекрестных ссылок), щелкните мышью на кнопке Add x-ref (Добавить х-ссылку), удерживая нажатой клавишу <Alt>. Сделанное удаление можно отменить (до первого щелчка на кнопке Accept (Принято) или ОК) щелчком мыши на кнопке Remove (Удалить) при одновременном нажатии клавиши <Alt>.


Удаление входов

Удаление любого входа осуществляется щелчком мыши на кнопке Remove (Удалить). Для того чтобы удалить все входы предметного каталога без различия типов, воспользуйтесь комбинацией клавиш <Ctrl>+<Alt>+<Shift> одновременно со щелчком мыши на кнопке Remove (Удалить). Все входы с прямыми ссылками удаляются комбинацией клавиш <Ctrl>+<Alt> со щелчком мыши на кнопке Remove (Удалить). Для удадения входов с перекрестными ссылками одновременно со щелчком мыши на кнопке Remove (Удалить) нажмите-комбинацию клавиш <Ctrl>+<Shift>.


Коды ссылок, размещаемых не на страницах материала

Входы ссылок, по ошибке или намеренно, могут располагаться не только на страницах публикации, но и в самых неожиданных местах — на шаблонах, монтажном столе и т. д. В этом случае вместо номеров страниц ссылки вы увидите странные двухбуквенные коды:

  • код РВ означает, что маркер входа указателя установлен в тексте, размещенном не на странице, а на монтажном столе;
  • коды LM и RM указывают, что маркер каким-то необъяснимым образом попал на страницу-шаблон, соответственно на его левую или правую часть;
  • код OV означает, что маркер расположен в несверстанном тексте, наличие которого обозначается сплошным треугольником, расположенным в середине нижней границы текстового блока;
  • код UN указывает на то, что маркер находится в неразмещенном тексте, в окне редактора материалов;
  • код ? означает, что прямая ссылка могла измениться со времени сбора базы при открытии диалогового окна Show Index (Просмотр указателя);
  • код HI указывает на то, что вход размещен на невидимом слое.

Номер страницы, заключенный в скобки, означает, что при создании входа указателя было задано подавление диапазона страниц в ссылке.


Написание тем указателя

Как уже упоминалось в разд. "Быстрое добавление новой темы из текста" данной главы, PageMaker позволяет автоматически устанавливать режим написания прописных букв в темах предметного указателя. Кнопка Capitalize (Написание), расположенная в диалоговом окне Show Index (Просмотр указателя), открывает вложенное диалоговое окно Capitalize (С прописной буквы), изображенное на рис. 17.24. Выберите переключатель This selected topic (Выделенную тему), All Level 1 entries (Все входы первого уровня) или All entries (Все входы). Чаще всего используется второй вариант написания тем.

Кнопка Capitalize (Написание) недоступна, когда в публикации присутствует структурный список книги. Для того чтобы воспользоваться этой командой в случае составной публикации, удерживайте нажатой клавишу <Ctrl> в момент выбора команды Show Index (Просмотр указателя). В результате база входов будет составлена только для входов предметного указателя, соответствующих маркерам активной публикации. Кнопка Capitalize (Написание) доступна, и вы можете задать соответствующий режим. После установки режима написания нужно закрыть и повторно открыть диалоговое окно Show Index (Просмотр указателя) для дальнейшей работы со входами предметного указателя.

Рис. 17.24. Установка написания входов указателя с прописной буквы


Проверка входов командой повторного поиска

При редактировании входа в диалоговом окне Show Index (Просмотр указателя) текст, в котором располагается соответствующий ему маркер, недоступен. Любая ссылка на страницу может быть как адекватной, так и ошибочной, не соответствующей тексту, расположенному на этой странице. Для полной проверки предметного указателя необходимо открыть указанную страницу и прочитать текст, примыкающий к нему, сопоставляя его с темой предметного указателя.

Для подобного контекстного редактирования входов предметного указателя можно воспользоваться командой контекстного поиска. Откройте окно редактора материалов, установите точку вставки в начале материала и откройте диалоговое окно команды Find (Найти). В поле Find what (Найти текст) введите два символа: л и ;. Щелкните мышью на кнопке Find (Найти), и программа PageMaker выделит в тексте первый маркер входа предметного указателя. Не закрывая окна поиска, щелкните мышью на заголовке окна редактора материалов. При этом окно редактора материалов должно находиться в нормальном положении (не максимизировано). Маркер входа остается выделен. Затем изучите контекст и с помощью комбинации клавиш <Ctrl>+<Y> откройте окно входа указателя для проверки соответствия темы контексту. Для того чтобы найти следующий маркер, выполните команду поиска вхождения, образца с помощью комбинации клавиш <Ctrl>+<G>. Просмотрите таким образом весь текст.


Сбор, размещение и стилевое оформление предметного указателя

Преобразование маркеров входов и тем в текстовщй материал (сбор указателя) выполняется при помощи команды Create Index (Создать указатель) меню Utilities (Сервис). PageMaker просматривает весь текст книги, включая публикации, указанные в структурном списке, и формирует список единиц предметного указателя, состоящих из тем и ссылок. Действие названной команды похоже на действие команды Create TOC (Создать оглавление). Как и в случае с оглавлением, образующийся указатель является обычным текстовым материалом и связей между темами указателя и маркерами входов в основном тексте не образуется. При изменении расположения маркеров входов указателя или текста тем необходимо повторно собрать его командой Create Index (Создать указатель), так же как приходится повторно собирать оглавление после редактирования текста.


Сбор предметного указателя

Диалоговое окно Create Index (Создать указатель) (рис. 17.25) — инструмент для сбора указателя. Вы можете задать свое название указателя в строке ввода Title (Название). Оно будет отформатировано в соответствии со стандартным стилем абзаца Index Title (Название указателя). По умолчанию название для указателя — Index (Алфавитный указатель).

Рис. 17.25. Диалоговое окно Create Index

Ниже перечислены режимы создания указателя, задаваемые с помощью следующих флажков.

  • Replace existing index (Заменить существующий указатель). Если ранее уже выполнялся сбор предметного указателя и материал с ним был размещен в публикации, целесообразно заменить предыдущую версию, включив этот флажок.
  • Include book publications (Общий для всех публикаций книги). Флажок включает режим создания общего указателя составной публикации.
  • Remove unreferenced topics (Удалить темы без ссылок). Устранение из предметного указателя тем без ссылок. На предварительной стадии работы с предметным указателем такие темы допустимы (возможно, что вы забыли установить маркер входа темы). Сбор предметного указателя с установленным флажком Remove unreferenced topics (Удалить темы без ссылок) безвозвратно удаляет все темы без ссылок. Его не следует устанавливать до тех пор, пока вы не будете твердо уверены, что завершаете работу с предметным указателем.

Примечание

Наличие входа с подавлением диапазона страниц в теме — надежный способ резервирования тем. Просматривая темы без ссылок и удаляя лишние, можно необходимые темы снабжать входами с подавлением диапазона страниц, защищая их тем самым от автоматического удаления из предметного указателя.

  • Include entries on hidden layers (Включить входы со скрытых слоев). При установке данного флажка в указатель включаются все входы публикации, в том числе и содержащиеся на невидимых слоях документа.


Форматирование предметного указателя

Кнопка Format (Формат) диалогового окна Create Index (Создать указатель) дает доступ к режимам автоматического форматирования указателя. Это форматирование задается во вложенном диалоговом окне Index Format (Формат указателя), представленном на рис. 17.26.

Рис. 17.26. Диалоговое окно Index Format

В верхней части диалогового окна находятся два флажка.

  • Include index section headings (Включить заголовки разделов). По умолчанию этот флажок включен. В качестве заголовков разделов предметного указателя используются буквы алфавита, выделенные начертанием и спусками с обеих сторон. Единицы указателя, чьи темы начинаются с цифры, знака препинания или специальных символов, сводятся в раздел Characters (Символы). Иностранные термины также сводятся в соответствующий раздел. Если темы должны следовать без указания разделов, отключите флажок.
  • Include empty index sections (Включить пустые разделы). Если в разделе предметного указателя нет ни одного элемента предметного указателя, PageMaker не включает заголовок данного раздела в текст. Режим подавления заголовков пустых разделов можно выключить, включив этот флажок.

Два переключателя Format (Формат) определяют стиль форматирования указателя — Nested (Ступенчатый) или Run-in (Сплошной). Стиль Nested предусматривает выделение уровней тем отступами, каждой теме соответствует отдельный абзац. Стиль Run-in также предусматривает выделение уровней рубрикации отступами, но все темы одного уровня объединяются в один абзац. В нижней части диалогового окна приводится пример фрагмента предметного указателя, отформатированного в соответствии с выбранным стилем.

Поля ввода в средней части диалогового окна позволяют настраивать внешний вид указателя, определяя форматирование его основных частей. В эти строки вводятся символы (в том числе и специальные, вводимые с помощью таблицы метасимволов), автоматически вставляемые в текст указателя:

  • Following topic (После темы). Символы, вставляемые между темой и первой ссылкой на всех трех уровнях тем.
  • Page range (Диапазон страниц). Разделитель номеров страниц в ссылке на диапазон. В изданиях типографского качества для этого используют узкий дефис шириной в полукруглую шпацию, соответствующий метасимволу ^=.
  • Between page #s (Между номерами страниц). Разделитель ссылок на страницы внутри темы. В качестве разделителя в списке ссылок на страницы используют запятую, двоеточие или точку с запятой. После запятой можно поставить не обычный, а узкий неразрывный пробел Шириной в полукруглую шпацию, тогда колонка указателя станет гораздо уже. В качестве разделителей можно также использовать переход на новую строку — все ссылки в этом случае будут построены в столбик.
  • Before x-ref (Перед х-ссылкой). Разделитель перед перекрестной ссылкой. Обычно перекрестные ссылки размещают с новой строки, чтобы не смешивать их с прямыми. По умолчанию в этой строке стоит метасимвол перехода на новую строку, переносящий остаток текста абзаца на новую строку.
  • Between entries (Между входами). Разделитель входов второго и третьего уровня тем в сплошном указателе. Entry end (Конец входа). Вход состоит из темы, за которой следует прямая или перекрестная ссылка. По умолчанию это поле остается пустым, поскольку PageMaker автоматически вставляет признак конца абзаца после каждого входа.

Как видите, окно форматирования указателя имеет довольно сложную структуру. В то же время, состояния по умолчанию и значения его элементов управления годятся для большинства ситуаций, и нет необходимости их изменять.


Размещение и настройка стилей предметного указателя

Так же, как и в случае с оглавлением, предметный указатель лучше размещать как отдельный документ, который включается в структурный список книги и почти всегда размещается в конце книги.

Потенциально PageMaker способен автоматически создавать до пяти стандартных стилей форматирования абзацев предметного указателя. Потенциально — потому, что он не создает стилей, реально не применяющихся в конкретном указателе. Первый стиль соответствует абзацу заголовка всего указателя, второй — заголовку раздела, третий, четвертый и пятый — стилям абзацев тем соответствующего уровня вложенности. Все они имеют соответствующие названия. Вы можете как угодно корректировать описания стилей предметного указателя, оставляя в неприкосновенности их имена (так же, как при корректировке стилей оглавления). Как правило, темы и ссылки предметного указателя оформляют тем же кеглем (9 или 10), что и основной текст публикации.

Примечание

После редактирования собранного указателя, при повторном сборе, все изменения будут потеряны. Чтобы этого не случилось, производите все исправления в основном тексте и в базе данных указателя.


Проверка ссылок в собранном предметном указателе

Размещенный предметный указатель можно дополнительно проверить на корректность ссылок в режиме макета с помощью инструмента Hand Tool (Рука). Так же, как и в случае проверки оглавления, размещенные в публикации темы предметного, указателя являются внутренними гиперссылками. Их адреса соответствуют положению соответствующих маркеров указателей. Вы можете последовательно проверить все темы указателя. В этом случае ссылки действительно будут идеальными. О гипертексте и, в частности, об использовании инструмента Hand Tool (Рука) для проверки ссылок подробно рассказывается в следующей главе.


Комбинации клавиш для работы в предметном указателе

Использование комбинации клавиш при составлении и редактировании предметного указателя, как и в других случаях оформления публикации, в PageMaker существенно ускоряет работу. В табл. 17U приводится список этих сокращений и их функции.

Таблица 17.1. Комбинации клавиш для работы с предметным указателем

Действие | Комбинация клавиш | Примечание
Добавление входа | <Ctrl>+<Y> | Открывает диалоговое окно Add Index Entry (Добавить вход указателя). Если в публикации был выделен текст, он становится темой первого уровня
Быстрое добавление входа | Выделение текста + +<Ctrl>+<Shift>+<Y> | Выделенный текст становится входом указателя, диалоговое окно Add Index Entry (Добавить вход указателя) не открывается
Просмотр входа | Выделение маркера указателя + <Ctrl>+<Y> | Открывает диалоговое окно Edit Index Entry (Редактировать вход указателя) для выделенного маркера указателя
Поиск |  | Данная комбинация вводится в строку поиска диалогового окна Find (Найти) для поиска маркера входа в режиме редактора материалов
Вход именного указателя | Выделение имени и фамилии + +<CtrlxAlt>+<Y> | Выделенный текст становится входом рубрики. Первое и второе слова (имя и фамилия) меняются местами
Просмотр указателя только активной публикации | Клавиша <Ctrl>+ меню Utilites ->Show Index | Показывает темы указателя только текущей публикации, а не всего структурного списка книги. В диалоговом окне Show Index (Просмотр указателя) становится доступной кнопка Capitalize (Написание)
Удаление несохраненных входов | В диалоговом окне Show Index (Просмотр указателя) клавиша <Alt> + кнопка Add x-ref (Добавить х-ссылку) | Удаляет входы, внесенные в указатель после последнего нажатия кнопки Apply (Применить) в диалоговом окне Show Index (Просмотр указателя)
Восстановление входов | В диалоговом окне Show Index (Просмотр указателя) клавиша <Alt> + кнопка Remove (Удалить) | Отменяет действие предыдущей команды, если еще не была нажата кнопка ОК или Apply (Применить)
Удаление всех входов всех типов | В диалоговом окне Show Index (Просмотр указателя) комбинация клавиш <Ctrl>+<Alt>+<Shift> + + кнопка Remove | Удаляет все входы ссылок
Действие | Комбинация клавиш | Примечание
Удаление прямых ссылок | В диалоговом окне Show Index (Просмотр указателя) Комбинация клавиш <Ctrl>+<Alt> + кнопка Remove (Удалить) | Удаляет все адресные ссылки
Удаление перекрестных х-ссылок | В диалоговом окне Show Index (Просмотр указателя) Комбинация клавиш <Ctrl>+ +<Shift> + кнопка Remove | Удаляет все перекрестные ссылки


Специальные элементы многостраничных публикаций

Скользящие колонтитулы

В многостраничных публикациях справочного характера (телефонных книгах, словарях, каталогах и пр.) и даже в некоторых художественных изданиях применяют скользящие колонтитулы. Читатель может легко отследить содержание страницы, посмотрев на колонтитул. Обычно в нем пишется название первого и последнего элемента страницы. На рис. 17.27 приведены примеры колонтитулов.

Рис. 17.27. Примеры колонтитулов

В программе PageMaker построение скользящих колонтитулов автоматизировано. Для выполнения этой операции используется дополнение Running Headers & Footers (Скользящие колонтитулы), возможности которого рассмотрены ниже.

Колонтитул каждой страницы строится исходя из tee содержания. Затем колонтитулы помещаются отдельными текстовыми блоками на каждую страницу публикации, на каждой странице содержание колонтитула определяется результатами поиска в основном тексте. Параметры поиска могут быть заданы пользователем. Связи между колонтитулом и содержанием страницы не образуется. Если в вашей публикации предполагаются колонтитулы, зарезервируйте для них место в модульной сетке макета, после чего завершите макетирование. Размещение текста на страницах публикации должно быть окончательным, в противном случае при подвижках текста придется собирать колонтитулы еще раз, чтобы привести их в соответствие с содержанием страницы.

Образовавшиеся колонтитулы можно редактировать произвольным образом, однако при повторном сборе редактирование будет утрачено. Скользящие колонтитулы можно разместить только в пределах текущей публикации. Невозможно собрать колонтитулы для всей книги одновременно по структурному списку.


Дополнение Running Headers & Footers

В списке дополнений PageMaker имеется команда вызова дополнения Running Headers & Footers (Скользящие колонтитулы). Главное диалоговое окно этого дополнения представлено на рис. 17.28.

Рис. 17.28. Диалоговое окно Running Headers & Footers

Перед вызовом названного дополнения необходимо выделить нужный материал инструментом Pointer (Стрелка). Порядок установки колонтитулов с помощью диалогового окна Running Headers & Footers следующий:

  1. Установка модульной сетки, по которой размещаются колонтитулы. Модульная сетка выбирается отдельно для каждой страницы разворота с помощью двух раскрывающихся списков в левой верхней части окна над полем просмотра страниц. Можно выбрать один из шаблонов документа или собственно страницу публикации. Во втором случае в строке ввода рядом с раскрывающимся списком следует указать номер конкретной страницы.
  2. Размещение колонтитулов и установка их размеров. Для этой операции используется кнопка Place (Поместить) с изображением текстового блока. Для размещения колонтитула щелкните на ней дважды или нажмите на пиктограмму и перетащите текстовый блок на нужное место страницы. Установите положение и размеры текстовых блоков с помощью группы кнопок положения и ширины блока, для чего воспользуйтесь кнопками настройки (с треугольными стрелками). Кнопки настройки со стрелками, упирающимися в линию, позволяют выровнять положение блока по вспомогательным линиям или по краю страницы.
  3. Установка критерия поиска и форматирования содержания колонтитулов. Для выбора критерия поиска установите стиль в раскрывающемся списке Search Style (Искать стиль). PageMaker будет помещать в колонтитул содержимое абзацев, помеченных именно этим стилем. Для книги это может быть стиль Chapter (Глава) или Story Name (Название рассказа). Для справочника подойдет критерий Any style (Любой стиль). В раскрывающемся списке Content Style (Стиль содержимого) установите стиль форматирования содержимого колонтитулов. Обычно это специально созданный для этой цели стиль.
  4. Выбор области действия дополнения. Группа элементов Apply To (Страницы материала) определяет, на каких страницах следует установить колонтитулы. Включение переключателя All Pages in Story (Все страницы материала) приводит к размещению колонтитулов на каждой странице. Установка флажка Exclude First Page (Кроме первой страницы) приводит к установке колонтитулов на всех страницах, кроме первой, например, если на ней расположено название публикации. При включении переключателя Range (Номера) можно задать номера страниц, на которых будут установлены колонтитулы.
  5. Задание содержимого колонтитулов. В группе элементов управления Content (Содержимое) задается принцип отбора содержания каждого колонтитула. Для задания содержания выделите нужный текстовый блок мышью. В нижней части группы Content (Содержимое) ч появится надпись Соп-tence required (Определите содержимое). В списке, расположенном в группе элементов Content (Содержимое), выберите один из стандартных вариантов колонтула (или иначе — селектор), например первое слово первого абзаца страницы. При этом просматриваются только абзацы стиля, указанного в критерии поиска. Щелчком мыши на кнопке Add (Добавить) или двойным щелчком на имени стандартного варианта колонтитула он копируется в поле содержимого колонтитула, расположенное справа. В этом же поле можно ввести любой текст или еще какой-либо вариант колонтитула. На этом процесс задания колонтитула закончен. Если же вас не устраивает ни один из стандартны вариантов, PageMaker позволяет определить заказной вариант содержимого колонтитула.
  6. Задание заказного содержимого колонтитулов. Щелкните мышью на кнопке Define (Описание), и на экране откроется диалоговое окно, представленное на рис. 17.29.

Рис. 17.29. Диалоговое окно выбора варианта колонтитула в дополнении Running Headers & Footers

Описание заказного содержимого колонтитула можно построить как на стандартных селекторах (вариантах колонтитулов), встроенных в программу PageMaker, так и на ранее заданных заказных селекторах. Чтобы исключить порчу стандартных селекторов, рекомендуется редактировать только пользовательские.

Для построения нового селектора выберите наиболее близкий из стандартных, и щелкните на кнопке New Selector (Новый селектор). В открывшемся вложенном окне Edit Selector (Редактировать селектор) (рис. 17.30) вновь создаваемый селектор имеет характеристики выбранного в предыдущем окне. Задайте имя нового селектора и составьте его определение из представленных элементов. Имеется возможность извлекать символы, слова, строки (или предложения в раскрывающемся списке) и абзацы — любые из структурных элементов текстового материала, которым назначен стиль, указанный ранее в главном окне дополнения.

Особо отметим, что определители символов и слов позволяют исключать из колонтитула символы и слова или ограничивать их число. Из колонтитула можно также исключать числа и символы иностранных алфавитов.

Рис. 17.30. Определение пользовательского селектора


Предварительный просмотр и создание колонтитулов

Для того чтобы предварительно просмотреть результаты создания колонтитулов, щелкните мышью на кнопке Preview (Просмотр) диалогового окна Running Headers & Footers.

Рис. 17.31. Предварительный просмотр результатов построения колонтитулов

В открывшемся диалоговом окне Preview (Просмотр) (рис. 17.31), с помощью которого и осуществляется предварительный просмотр результатов создания колонтитулов, кроме выбора страницы для просмотра при помощи пиктограмм страниц в нижней части диалогового окна, имеется также возможность перехода к последующему колонтитулу при помощи кнопки Next H/F (Следующий колонтитул). Изменять масштаб предварительного просмотра можно при помощи кнопки с изображением лупы и связанных с ней кнопок прокрутки. После щелчка мыши на кнопке Done (Готово) будет осуществлено окончательное построение колонтитулов. После первого формирования скользящих колонтитулов дополнение можно вызвать еще раз, когда понадобится их обновление.


Удаление колонтитулов

Для того чтобы удалить ранее построенные колонтитулы, снова выберите текстовый материал и вызовите дополнение Running Headers & Footers (Скользящие колонтитулы). Затем в поле предварительного просмотра с помощью мыши перетащите ненужные колонтитулы за пределы страницы. После того как вы отпустите кнопку мыши, текстовые блоки колонтитулов исчезнут.


Перекрестные ссылки в основном тексте

Перекрестные ссылки в основном тексте используются для того, чтобы отослать читателя на другую страницу книги за дополнительной информацией (например, дополнительные данные см. на стр. 101). В некоторых изданиях таких ссылок очень много. В отличие от текстовых процессоров, многие из которых обладают механизмом верстки перекрестных ссылок с поддержанием динамической связи ссылки с адресом, свободное размещение текста в блоках делает такую функцию слишком сложной для осуществления. Поэтому, к сожалению, PageMaker не располагает средствами для автоматической верстки подобного рода элементов. Ссылки приходится устанавливать и корректировать вручную.

Тем не менее, используя в качестве вспомогательного средства базу предметного указателя, возможно частично автоматизировать этот процесс. Предлагается следующая последовательность действий:

  1. Определение стандарта ссылки и уникального идентификатора. Ремарка перекрестной ссылки должна оформляться одинаково для всех ссылок, а в ее состав должен входить уникальный символ подстановки, например (См. стр. [*]). Единообразие оформления перекрестных ссылок дает возможность автоматически отыскивать их в тексте. Оформите все ссылки надлежащим образом и создайте резервную копию документа. Если при расстановке вместо идентификаторов номеров страниц произойдет ошибка, то для второй попытки можно будет вернуться в исходное состояние. В противном случае ссылки с уже уничтоженными идентификаторами будет трудно разыскать в основном тексте.
  2. Кодирование ссылок входами указателя. В редакторе материалов задайте образец для поиска ссылок и выберите команду Find (Найти) (комбинация клавиш <Ctrl>+<G>). Далее воспользуйтесь тем же приемом, который был описан в разд. "Кодирование входов указателя" данной главы, поскольку для того, чтобы указать правильный номер страницы в перекрестной ссылке, без контекста не обойтись. В каждом вновь найденном месте вхождения символа подстановки установите маркер входа предметного указателя. В поле темы первого уровня введите какое-нибудь стандартное название, скажем Reference (Ссылка). В качестве темы второго уровня введите уникальное число (например, порядковый номер ссылки) в форме, которая будет правильно сортироваться в лексикографическом порядке (скажем, в виде трехзначного числа с ведущими нулями). Это число поможет вам впоследствии установить соответствие между ссылкой и страницей, на которую она указывает. В поле темы третьего уровня введите характеристику контекста данной ссылки.
  3. Сбор списка ссылок. После того как все ссылки в основном тексте размечены как входы предметного указателя, соберите этот указатель и напечатайте его. Каждая ссылка в списке снабжена уникальным номером, контекстной характеристикой и номером страницы.
  4. Разметка адресов ссылок. Теперь отыщите все фрагменты текста, на которые указывают перекрестные ссылки. В каждом из таких мест установите маркер входа предметного указателя, в качестве рубрики первого уровня задав одно и то же слово (например, Address (Адрес)). В поле рубрики второго уровня введите уникальный номер ссылки, которая указывает на это место. Контекстная характеристика адреса не нужна.
  5. Общий список перекрестных ссылок. После разметки адресов еще раз соберите предметный указатель и снова напечатайте его. Вырежьте из него элементы, соответствующие рубрикам Reference и Address, и расклейте их в две колонки, совместив по горизонтали строки с одинаковыми номерами в рубрике второго уровня вложенности, так, чтобы каждой ссылке из одного списка соответствовал бы адрес из другого списка.
  6. Внесение номеров страниц в ссылки. Еще раз просмотрите текст книги при помощи команды поиска, отыскивая на этот раз идентификаторы. По мере нахождения заменяйте их соответствующим номером страницы, взятым из полученного на предыдущем шаге параллельного списка.
  7. Очистка предметного указателя от вспомогательных ссылок. По завершении работы с перекрестными ссылками удалите единицы Reference (Ссылка) и Address (Адрес) из предметного указателя.


Примечания и сноски

Можно попытаться частично автоматизировать в PageMaker и работу с примечаниями. Если вы имеете дело с затекстовыми примечаниями, на которые есть явные ссылки в основном тексте, воспользуйтесь предыдущим рецептом. В художественных изданиях часто встречается способ оформления за-текстовых примечаний, при котором в основном тексте вообще нет ремарки ссылки, а в конце книги имеются комментарии такого вида: "К стр. 209. "Лечь бы на дно как подводная лодка" — стихотворение В. С. Высоцкого". Для верстки такого рода примечаний воспользуйтесь следующим приемом:

  1. Распечатайте текст затекстовых примечаний. Обычно комментарии поступают в готовом виде без указания номеров страниц.
  2. Введите каждую тему ссылки (фрагмент текста в кавычках), естественно без кавычек, в качестве образца поиска в основном тексте. Если тема длинная, можно ввести характерные слова (в нашем примере — "подводная лодка").
  3. Найдя нужное место в тексте, сверьте основной текст с темой в примечании. Внесите правку в распечатку комментариев.
  4. Затем выделите тему комментария в основном тексте и поставьте вход указателя. В качестве темы первого уровня поставьте слово Reference (Ссылка), темой второго уровня станет номер ссылки, а сам текст ремарки будет темой третьего уровня. Это действие аналогично кодированию ссылок в предыдущем разделе.
  5. Соберите и распечатайте список ссылок. В текст примечаний внесите требуемые исправления и номера страниц из списка ссылок.

А как быть, если вместо затекстовых нужны подстрочные примечания? Эта задача гораздо сложнее, поскольку наличие и размер ссылки оказывают влияние на разбиение текста по страницам. Сплошь и рядом встречаются ситуации, когда при размещении текста примечания ссылка уходит на следующую страницу. Однако ссылка и соответствующее примечание обязательно должны находиться на одной странице. Переносим примечание на следующую страницу, вслед за ссылкой, а она "уползает" обратно, поскольку на предыдущей странице освободилось место. Эти неприятности можно разрешить только вручную. Разместите текст ссылок на монтажном столе и отформатируйте его специальным стилем. Обычно такой стиль включает в себя кегль на две единицы меньше основного, размещение с выравниванием по левому краю, висячий отступ для номера ссылки или указателя-"звездочки". Просматривая страницы основного текста, найдите ссылку. Сократите размеры текстового блока данной страницы снизу, чтобы образовалось место для текста ссылки. Вырежьте примечание и поместите его на страницу. Для стандартизации вида страниц проведите направляющие на шаблон-странице для размещения ссылок наиболее часто встречающейся длины, по ним можно устанавливать размер блока основного текста. Если вам не повезло и ссылка "поехала" относительно своего примечания, воспользуйтесь приемами выгонки и вгона строк (см. гл. 5 и 6). Если примечание велико, допустимо размещать его в подвалах нескольких страниц. К сожалению, это все полезные советы, которые можно дать в подобной тяжелой ситуации.


Резюме

Рассмотренные в этой главе аспекты работы с многостраничными публикациями помогут вам успешно организовать работу по подготовке большого издания, начиная с разработки структуры будущей книги и заканчивая специальными элементами ее оформления. Данная глава тесно связана с предыдущей, поскольку при издании книги вам обязательно придется предварительно продумать ее структуру. Если вы предполагаете использовать в книге иллюстрации и таблицы, обратитесь к гл. 9, 14 и 16. Сделать книгу оригинальной по стилю возможно с использованием приемов, описанных в гл. 15. У вашего клиента есть лишние деньги? Замечательно, значит, вы имеете возможность выполнить публикацию в цвете! В этом вам помогут главы части V.


  • Глава 18. Электронные публикации
    • Гипертекст в PageMaker. Ссылки
      • Как определяется ссылка
      • Создание привязок
      • Определение источников
      • Установки PageMaker для работы с WWW
      • Импортирование Web-страниц
      • Проблемы переноса верстки в формат HTML
    • Экспорт публикации в формат HTML
    • Экспорт публикации в формат PDF
      • Подготовка к экспорту в формат PDF
      • Фильтр экспорта PDF
      • Экспорт страниц
      • Экспорт гипертекстовых ссылок
      • Создание закладок
      • Создание статей
      • Информация о документе
      • Защита PDF-документа
      • Параметры PDF-документа
      • Размер PDF-файла
      • Внедрение шрифтов
      • Управление цветом в PDF-документах
      • Дополнительные настройки Acrobat Distiller
      • Сохранение настроек
      • Экспорт PDF
    • Резюме


ГЛАВА 18.

Электронные публикации

Интернет в последние годы стал одной из основных тем публикаций в самых разнообразных средствах массовой информации — от специальных "компьютерных" изданий до журналов для домохозяек. Эта тема становится близка всем, т. к. за это время стало ясно, что Интернет не просто игрушка для небольшого количества посвященных, а явление, существенно изменившее нашу жизнь. Совсем не далеки те времена, когда отсутствие доступа к Интернету у частного лица будет восприниматься как отсутствие телефона или телевизора сейчас. Уже становится очевидным то, что еще лет десять назад только угадывалось наиболее прозорливыми специалистами: Интернет стал самым популярным средством доставки всех информационных услуг. Под информационными услугами понимаются в первую очередь средства массовой информации (телевидение, радио, печать), телекоммуникации (почта, телефония) и доступ к базам данных и знаний (библиотеки, гуманитарная, техническая и финансовая информация). Интернет объединяет эти разобщенные источники, позволяя легко находить и быстро получать доступ к интересующей вас информации. Связь со средствами телекоммуникации обеспечивает наиболее быстрое, надежное и удобное общение. Более того, присущая Интернету интерактивность придает информационным услугам новое качество (интерактивное телевидение, интернет-телефония, IRC и т. п.). Растет и объем финансовых операций в Интернете. Подавляющее большинство крупных банков поддерживают оплату услуг и операции со счетами через Интернет.

Интернет никому не принадлежит, поскольку является объединением огромного числа независимых глобальных и корпоративных сетей. Он не имеет ни политических, ни территориальных границ. Интернет делает информацию доступной вне зависимости от того, где вы находитесь, где живете, какова ваша национальность и каких взглядов вы придерживаетесь. Разумеется, первыми оценили перспективы этой области те, кто так или иначе связан с информационными технологиями — производители компьютеров, программного обеспечения, телекоммуникационные компании. Они непременно включают в свою продукцию поддержку Интернета. Особенно очевидным проявлением этого является включение поддержки Интернета во все современные операционные системы. Не являются исключением и операционные системы корпораций Microsoft и Apple: Windows и MacOS. Для этих систем существует множество программ, позволяющих не только получать информацию из Интернета, но и публиковать ее там. Основной язык публикаций в Интернете — HTML (Hypertext Markup Language, язык разметки гипертекста). Он используется наиболее популярным сервисом Интернета — WWW (World Wide Web).

Для просмотра публикаций в WWW применяют специальные программы просмотра — браузеры (от английского browse — "просматривать"). Поддержка "перевода" электронной публикации на язык HTML стала серьезным критерием выбора при покупке программ. Существует почти неисчерпаемое, количество специализированных программ для верстки WWW-страниц — от простейших текстовых редакторов, адаптированных для удобного ввода управляющих кодов HTML, до сложнейших систем поддержки огромных сайтов со специальными средствами верстки, программирования, доступа к локальным и глобальным базам данных. Их чаще всего используют для создания публикаций, которые изначально предназначены для распространения в Интернете. Кроме того, существует большое количество публикаций, которые должны присутствовать в обеих формах — бумажной и электронной. Очень часто уже после выхода издания, отпечатанного типографским способом, появляется необходимость подготовить его для электронного распространения как через Интернет, так и на дискетах, компакт-дисках и т. п. Эта необходимость заставляет разработчиков издательских систем включать в свои продукты инструменты, позволяющие преобразовывать сверстанную публикацию в электронную форму. Последняя предполагает возможность просмотра публикации на компьютере, где не установлена издательская система, в которой она сверстана. Это требование может быть реализовано дву- • мя принципиально разными способами.

Первый способ состоит в переводе макета публикации в формат HTML. В этом случае любой пользователь, располагающий программой просмотра WWW-страниц (т. е. практически любой пользователь Интернета), имеет возможность познакомиться с публикацией. Главный недостаток такого способа заключается в ограниченных возможностях описания макета средствами HTML, т. е. при преобразовании макет неминуемо будет "упрощен". Это упрощение может полностью разрушить дизайн публикации, сделав его унылым и непривлекательным. Таким образом, данный способ предполагает либо перевод достаточно простых публикаций, либо ручную "доводку" полученного макета.

Второй способ предполагает перевод публикации в специальный формат, который, позволяя использовать "электронные возможности" (гипертекст, мультимедиа и т. п.), полностью сохраняет вид макета, но требует специального средства его просмотра. В электронных публикациях данного вида также используется гипертекстовое представление материала. Недостаток такого метода очевиден — для просмотра публикации вам надо предварительно найти и установить программу просмотра. Далеко не все пользователи настолько упорны, чтобы только ради просмотра вашей публикации размером в десяток килобайтов искать и перекачивать трехмегабайтовую программу просмотра. Поэтому при представлении публикации в таком виде вы должны быть уверены, что большинство читателей, на которых вы рассчитываете, уже имеют эту программу, или при распространении прилагать ее к публикации на CD-ROM. Таких форматов существует несколько, но наиболее популярен разработанный Adobe Systems формат PDF (Portable Document Format). Пользователям PageMaker названный формат наиболее близок еще и потому, что он непосредственно им поддерживается. Кроме того, в комплект PageMaker 7.0 входят программы создания таких файлов и их просмотра, что избавляет от необходимости их покупки.

Оба эти способа можно реализовать, используя PageMaker 7.O. Более того, разработчики обратили пристальное внимание на возможность создания электронных публикаций именно в данной версии. Это заставляет и нас обсудить создание электронных публикаций средствами PageMaker самым подробным образом.

В настоящей главе рассматриваются вопросы, связанные с электронным распространением сверстанных в PageMaker публикаций:

  • Гипертекст и гипертекстовые ссылки
  • Организация гипертекста в PageMaker
  • Ссылки на ресурсы Интернета
  • Подготовка к переводу верстки в формат HTML и соответствующий фильтр экспорта
  • Отличия дизайна Web-страниц от полиграфического дизайна
  • Формат переносимых документов PDF
  • Экспорт публикации в формат PDF с помощью Adobe Acrobat
  • Особые возможности и ограничения электронных публикаций


Гипертекст в PageMaker. Ссылки

Как мы уже говорили, главным инструментом гипертекста являются ссылки. В этом разделе мы рассмотрим, как с помощью PageMaker организовывать гипертекстовые ссылки внутри публикации, а также на внешние файлы и ресурсы Интернета.


Как определяется ссылка

PageMaker 7.0 имеет фильтр экспорта в формат HTML, а для создания и редактирования ссылок предназначена отдельная палитра — Hyperlinks (Гиперсвязи). Как и любая палитра PageMaker, она всегда перед глазами и ее инструменты позволяют организовывать все типы гипертекстовых ссылок, делая верстку гипертекста столь же удобной и наглядной, как и обычную (рис. 18.1).

Рис. 18.1. Палитра Hyperlinks и меню палитры

Для определения ссылки необходима пара элементов: источник (source) и привязка (anchor). Источник — это элемент макета, щелкнув на котором мышью, вы инициируете гиперссылку. Привязка — это тот элемент макета, который появится на экране по этой гиперссылке. Соответствие между источником и привязкой устанавливается гипертекстовой ссылкой (гиперссылкой). Одной привязке могут соответствовать несколько источников, но не наоборот.

Расстановка гиперссылок, как правило, является завершающей фазой подготовки электронного документа. К этому времени все элементы макета уже заняли свои места, и расстановка ссылок заключается в определении пар источник-привязка. Источником или привязкой может быть любой элемент макета, в том числе фрагмент текста.

Примечание

Сразу оговоримся, что если публикация будет преобразована в документ HTML, то этот элемент не должен исчезнуть при экспорте. Например, для организации ссылок нельзя использовать фигуры, созданные средствами рисования PageMaker.


Создание привязок

Первыми создаются привязки. Для определения привязки необходимо сначала выделить фрагмент текста (как правило, несколько слов) инструментом Type Tool (Текст) или графический элемент инструментом Pointer Tool (Стрелка). Далее в палитре Hyperlinks (Гиперсвязи) необходимо нажать пиктограмму создания новой привязки или выбрать пункт New anchor (Новая привязка) из меню палитры. При этом откроется окно с запросом имени привязки (рис. 18.2).

Рис. 18.2. Назначение имени привязке

Имя, назначаемое привязке, не будет использовано внутри электронного документа и необходимо только для удобства последующего определения источников. Новая привязка появится в окне палитры Hyperlinks (Гиперсвязи) в виде отдельной строки с именем привязки и пиктограммы в виде якоря (anchor) (рис. 18.3). Если выделить какую-либо из показанных в палитре гиперсвязей привязок, то в строке статуса палитры будет отображен номер страницы публикации, на которой находится привязка.

Рис. 18.3. Привязки в палитре Hyperlinks

Целесообразно определить сразу все привязки в документе, а уже потом заниматься определением источников. Это не только избавит вас от постоянного перелистывания страниц, но и добавит систематичности в работу. Особым образом определяются привязки, находящиеся вне публикации, которые в терминологии PageMaker называются URL-привязки. Эти привязки могут быть определены либо простым вводом с клавиатуры, либо импортом из какого-нибудь HTML-документа.

С помощью первого способа обычно вводятся ссылки на локальные ресурсы. Если, например, необходимо сослаться на существующий HTML-документ, можно выбрать команду New URL (Новый URL) из меню палитры Hyperlinks (Гиперсвязи) и в появившемся диалоговом окне (рис. 18.4) ввести относительную ссылку на файл этого документа.

Рис. 18.4. Ввод URL-привязки

Командой New URL (Новый URL) можно воспользоваться и для ввода ссылки на ресурс Интернета, указав в диалоговом окне New URL (Новый URL) абсолютную ссылку (URL) на этот ресурс. URL ресурса можно скопировать из окна браузера через буфер обмена. Пользователи Netscape Navigator могут перетащить мышью выделенный фрагмент текста, содержащего ссылку, из окна браузера в окно публикации. При этом ссылка сохранится и появится в палитре гиперсвязей. Значок, соответствующий такой ссылке в палитре гиперсвязей, выглядит иначе, чем значок привязки внутри публикации. Он изображает земной шар, что указывает на внешний характер этой привязки. Данная привязка, как и внутренние, может быть сколько угодно раз использована для ссылок из публикации. При перетаскивании содержимого страницы, открытой в окне Microsoft Internet Explorer, в публикацию помещается только текст, а ссылки не переносятся. Вводимый URL может указывать не только на ресурсы WWW, но и на любые, поддерживаемые PageMaker, типы ресурсов.

Примечание

Двойным щелчком мыши на строке с именем привязки вы можете отредактировать ее имя. Для привязок, находящихся внутри публикации, изменение имени не изменит самой привязки, т. к. ее имя не содержит данных о том, где она находится. Внешние привязки имеют имя, соответствующее URL, которое нельзя менять, т. к. только оно однозначно определяет местонахождение данной привязки. Редактирование имени внешней привязки имеет смысл только тогда, когда вы действительно хотите поменять ресурс, содержащий привязку.

Внешние привязки могут быть также импортированы в публикацию из любого HTML- документа, находящегося как в локальном файле, так и в Интернете. Для импорта ссылок из локального файла выберите пункт Import URLs from File (Импортировать URL из файла) меню палитры Hyperlinks (Гиперсвязи). Эта команда открывает стандартное диалоговое окно запроса имени файла. В нем можно выбрать любой локальный HTML-файл. Все имеющиеся в нем ссылки будут добавлены в^палитру Hyperlinks (Гиперсвязи) как привязки. Импорт ссылок со страницы WWW, находящейся в

Интернете, осуществляется командой Import URLs from Web (Импортировать URL из ceти Web) меню палитры Hyperlinks. Команда выводит окно ввода Web-страницы, ссылки которой вы хотите использовать как привязки. Разумеется, в качестве URL могут вводиться не только ресурсы WWW, но и имена файлов FTP, ресурсы Gopher и т. п. Все найденные по этому URL ссылки будут помещены в палитру Hyperlinks (Гиперсвязи) для последующей организации ссылок из публикации. Лишние привязки, появившиеся в палитре гиперсвязей при импорте из файла или из Интернета, могут быть удалены нажатием на пиктограмме удаления в палитре при выбранной привязке. Также можно удалить выбранную привязку перетаскиванием привязки на эту пиктограмму или командой Delete <имя привязки> (Удалить <имя привязки>) из меню палитры. Удаление привязки к графическому объекту приводит к удалению самого графического объекта. При этом удаляются все ведущие к нему гиперсвязи. В данном случае PageMaker выдаст диалоговое окно с предупреждением об удалении гиперсвязей (рис. 18.5). При удалении текста, определенного как привязка, удаления самой привязки, как ни странно, не происходит. Такая "пустая" привязка представляет собой "пустое место", оставшееся после удаления текста. Обнаружить его можно, лишь поставив текстовый курсор в то место текста, где ранее помещался удаленный фрагмент. Для удаления "пустой" привязки необходимо воспользоваться палитрой Hyperlinks.

Рис. 18.5. Предупреждение об удалении гиперсвязей, ассоциируемых с удаляемым объектом


Определение источников

Теперь, когда в публикации созданы внутренние и внешние привязки, можно приступить к организации собственно гипертекстовых ссылок. Для этого необходимо определить элемент-источник для каждой привязки. Сначала следует выделить любой графический элемент инструментом Pointer Тool (Стрелка). или фрагмент текста инструментом Text Tool (Текст). Далее следует выбрать привязку щелчком мыши на ее пиктограмме в палитре гиперсвязей. Эта последовательность действий откроет диалоговое окно с запросом имени гиперсвязи. Имя гиперсвязи может быть любым, т. к. оно используется только для удобства ориентации в гипертексте и не будет фигурировать в получаемом после экспорта электронном варианте публикации. В палитре гиперсвязей под именем привязки появится имя гиперссылки, указывающей на нее. Как уже отмечалось выше, одной привязке могут соответствовать несколько гиперссылок. В данном случае под именем привязки будут находиться несколько строк с именами гиперссылок. Редактирование имени гиперссылки не приводит к ее изменению.

Таким простым способом можно определить все гиперссылки в публикации. Если поместить текстовый курсор на текст, связанный гиперссылкой, в палитре гиперсвязей автоматически подсветится строка с именем этой гиперссылки и в правой ее части появится квадратик, свидетельствующий о том, что выбрана именно эта гиперссылка. Посмотрев на имя привязки, соответствующей гиперссылки, можно легко определить, куда данная гиперссылка ведет. Таким образом, палитра гиперссылок представляет собой весьма удобную базу данных по всем гиперсвязям, имеющимся в публикации.


Установки PageMaker для работы с WWW

Проследить, куда ведут гиперссылки, можно не только по базе данных о них в палитре гиперсвязей, но и непосредственно, как в окне браузера. Гипертекстовые ссылки становятся активными при выбранном инструменте Hand Tool (Рука). На их отображение в режиме просмотра влияют установки, сделанные в диалоговом окне Online Preferences (Установки: Контроль HTML) (рис. 18.6). Это диалоговое окно вызывается командой Online (Контроль HTML) подменю Preferences (Установки) меню File (Файл).

Переключатель Outline link sources when hand tool is selected (Выделять гиперссылки в режиме просмотра) заставляет PageMaker выделять элементы-источники синими рамками. В противном случае гиперссылку можно обнаружить, только подведя к ней курсор мыши, который меняет свой вид с просто "руки" на "указующий перст". Переключатель Center upper-left of anchor when testing hyperlinks (Показывать привязки при проверке гиперсвязей) далеко не всегда удобно держать включенным. В этом его положении при выборе ссылки точка привязки отображается на экране отцентрованной. Масштаб отображения страницы при этом не изменяется (остается тем, каким он был при последнем просмотре страницы), а страница смещается в окне документа так, чтобы привязка находилась в его центре.

В группе URL information (Информация URL) находятся поля, в которые вводятся установки Proxy-сервера, через который вы подключены к Интернету, и умалчиваемый каталог для импорта Web-страниц. Доступ к Интернету через Proxy-сервер является очень часто применяемым способом доступа. Он используется в корпоративных локальных сетях, когда необходимо обеспечить безопасный выход в Интернет для всех пользователей сети через один внешний канал, или для организации кэширования Web-страниц на сервере поставщика" услуг Интернета. В поле Proxies (Прокси) следует ввести доменное имя или IP-адрес Proxy-сервера, а в поле Port (Порт) — порт, через который он работает. В поле No proxies (Без прокси) введите имена тех серверов, которые требуют прямого обращения. Это, как правило, имена серверов, установленных в локальной сети, и сервера — поставщика услуг Интернета. Поле Download to folder (Загрузить в папку) определяет каталог, в который PageMaker помещает импортированные из Интернета Web-страницы.

Рис. 18.6. Диалоговое окно Online Preferences


Импортирование Web-страниц

Импортирование Web-страниц происходит при перетаскивании их содержимого из окна браузера в публикацию или при помещении их в нее посредством команды Place (Поместить). Вид диалогового окна команды Place (Поместить) представлен на рис. 18.7, а,

С помощью этой команды можно поместить в публикацию как локальные HTML-документы, так и находящиеся в Интернете. При импорте обязательно включайте флажок Show filter preferences (Показать установки фильтра), который открывает диалоговое окно с установками фильтра импорта HTML, приведенное на рис. 18.8.

Рис. 18.7. Импорт HTML -документов командой Place

Рис. 18.8. Установки Фильтра импорта HTML

Списки HTML style (Стиль HTML) и PageMaker style (Стиль PageMaker определяют соответствия между стилями HTML и стилями публикации. Для того чтобы задать стиль публикации, в который преобразуется стиль HTML. надо щелкнуть мышью на его строке в списке PageMaker style (Стиль PageMaker). Этот щелчок откроет меню, содержащее стили, определенные в публикации. Выбранный в данном меню стиль отобразится в списке PageMaker style (Стиль PageMaker) напротив соответствующего стиля в окне HTML style (Стиль HTML). Пункты группы Graphics (Изображения) определяют режим их импорта. Переключатель Include images (Включить изображения) разрешает их импорт, а переключатель Inline graphic/Independent Graphic (Вложенные/Свободные) определяет, какой из этих типов будет употреблять PageMaker при помещении в публикацию. Флажок Keep hyper-links (Сохранить гиперсвязи) позволяет вместе с содержимым страницы импортировать находящиеся на ней гипертекстовые ссылки. Импортированные ссылки помещаются в палитру Hyperlinks (Гиперсвязи), как и при их импорте с Web-страницы, командой Import URLs From Web (Импортировать URL из сети Web). Эту возможность следует использовать, если страница импортируется в PageMaker для редактирования с целью создания новой электронной публикации. Если же целью является бумажное издание, флажок Keep Hyperlinks (Сохранить гиперсвязи) можно сбросить.

Теперь вернемся к режиму просмотра гиперссылок в PageMaker. При установленном переключателе Outline link sources when hand tool is selected (Выделять гиперссылки в режиме просмотра) и текущем инструменте Hand Tool (Рука) они будут обведены синей рамкой. Теперь достаточно щелкнуть мышью в пределах рамки, чтобы на экране появились страница и то ее место, на котором находится соответствующая ссылке привязка. Не лишней представляется проверка всех ссылок публикации. Ее можно проделать как в PageMaker, так и потом, когда публикация будет переведена в формат HTML, вручную или с помощью специальных программ проверки правильности ссылок.

На этом завершается самый большой и сложный этап подготовки электронной публикации. Далее она должна быть переведена из формата PageMaker в тот формат, в котором она будет распространяться. Этому и посвящены два следующих раздела.


Проблемы переноса верстки в формат HTML

Фильтр экспорта HTML PageMaker поддерживает весьма раннюю спецификацию этого языка, не включающую CSS (Cascading Style Sheets). Фильтр экспорта поддерживает таблицы HTML, которые представляют собой, по существу, единственный мощный инструмент организации макета. PageMaker не имеет встроенного инструмента для создания таблиц, но при переводе публикации в HTML он может попытаться максимально сохранить макет, используя при этом форматирование с помощью таблиц. HTML-код, генерируемый PageMaker в этом случае, далек от оптимального, но главная цель — максимальное соответствие исходному макету — при этом достигается!

Тем не менее, даже при использовании таблиц весьма значительная часть элементов макета в принципе не может быть перенесена на Web-страницу.

  • При экспорте в формат HTML теряются настройки гарнитуры, интерлиньяжа, трекинг, кернинг, позиции табуляции и другие характеристики текста.
  • Поддерживаются только графические форматы GIF и JPEG. PageMaker автоматически преобразует копии импортированных изображений (как вложенных, так и независимых) в формат GIF или JPEG. Объекты, построенные с помощью рисующих инструментов программы PageMaker (за исключением горизонтальных линий), не экспортируются в HTML.
  • Объекты, трансформированные (повернутые, наклоненные или зеркально отраженные) в программе PageMaker, экспортируются в формат HTML без трансформации.
  • Объекты, накладывающиеся друг на друга в программе PageMaker, при экспорте в HTML разделяются, что может дать неудовлетворительный результат.
  • Даже приблизительно не воспроизводится обтекание текста вокруг непрямоугольных границ. Если оно использовано в макете, при экспорте это обычно приводит к смещению объектов.
  • Содержимое фреймов PageMaker экспортируется, а сам фрейм — нет. Непрямоугольные фреймы становятся прямоугольными. Изображения, выходящие за границы видимой области фреймов, кадрируются в соответствии с оригинальным дизайном.
  • Маскирование объектов отменяется.

Особой оговорки заслуживает первый пункт этого списка. HTML имеет тэг, позволяющий в явном виде задать гарнитуру шрифта, но PageMaker не использует этой возможности. Дело в том, что он "заботится" о том, чтобы созданный документ хорошо смотрелся не только на вашем, но и на других компьютерах. При электронном распространении документов шрифт представляет собой очень существенную проблему. Во-первых, далеко не у всех есть те шрифты, которыми располагаете вы. Во-вторых, большинство гарнитур имеют множество "близнецов" (особенно на других платформах) с другими названиями, что не позволит браузеру подставить даже установленный шрифт, но имеющий другое имя. В-третьих, вы не имеете права свободно распространять коммерческие шрифты. Единственный способ обойти эти проблемы — не употреблять прямое задание гарнитуры в HTML-документе.

Самое главное для верстальщика отличие Web-страницы от бумажной заключается в том, что Web-страница не имеет строго определенных размеров. Экран браузера может прокручиваться вниз и вправо, делая страницу сколь угодно длинной или широкой. Кроме того, количество материала, помещающегося на экран, напрямую зависит от разрешения экрана, установленного у просматривающего. Такая "неопределенность" главного параметра публикации — ее формата — крайне непривычна для верстальщика и дизайнера бумажных изданий. Это и неудивительно, поскольку Web-страница обладает своими, только ей присущими средствами выразительности, вследствие чего ее дизайн очень сильно отличается от книжного. При переводе публикации в HTML вам наверняка придется ее адаптировать не только для того, чтобы удалить или преобразовать непереводимые элементы, но и для того, чтобы дополнить ее специфическими "электронными" элементами дизайна.

Несмотря на неопределенность формата Web-страницы все-таки существуют размеры, на которые следует ориентироваться. Ширина страницы не должна превышать размеров экрана компьютера пользователя. Поскольку вы работаете с издательскими системами, наверняка монитор вашего компьютера имеет большую диагональ (19 или 21 дюйм), но далеко не все пользователи так "удачливы". Еще достаточно велик парк 15-дюймовых мониторов, на которых невозможно или неудобно устанавливать разрешение больше 800x600 пикселов (привыкайте к новым единицам измерения!). Это разрешение сейчас наиболее часто встречается, и рассчитывать лучше всего на него. Чтобы не заставлять вас переводить пикселы в сантиметры или дюймы, разработчики PageMaker ввели размеры страниц публикаций для разных разрешений мониторов в качестве стандартных форматов страницы. При создании новой публикации в диалоговом окне Document Setup (Параметры документа) можно установить один из таких размеров:

  • 500x335 Browser-small;
  • 600x450 Browser-large;
  • 640x480;
  • 800x600 SVGA;
  • 1024x768.

Поскольку при просмотре неудобно открывать окно браузера во весь экран, даже при ориентации на разрешение 800x600, мы рекомендуем второй вариант размера для Web-страницы. В длину страница не должна занимать больше двух-трех экранов, т. к. это затруднит ориентацию в ней. Если вы не создаете публикацию "с нуля", а хотите перевести в HTML уже сверстанный макет, то значение горизонтального размера страницы вам придется ввести при экспорте (см. следующий раздел).

HTML бурно развивается. PageMaker работает далеко не с самой последней его спецификацией — 3.2. Впрочем, даже в рамках этой спецификации он использует далеко не все возможности. Разработчики PageMaker также решили отказаться от сохранения дизайна публикации в пользу совместимости с подавляющим большинством браузеров.


Экспорт публикации в формат HTML

Перевод публикации в формат HTML осуществляется соответствующим фильтром экспорта, вызываемым по команде HTML (HTML) подменю Export (Экспортировать) меню File (Файл). Она открывает диалоговое окно, представленное на рис. 18.9.

Рис. 18.9. Диалоговое окно фильтра экспорта публикации в формат HTML

В этом окне можно определить, сколько отдельных HTML-документов необходимо создать из файла публикации и какие ее страницы или материалы должны войти в каждый документ. Перечень документов находится в списке HTML Document Titlte (Название документа), а страницы или материалы публикации, входящие в этот документ, — в списке Contents (Содержание). Группа элементов Export Files To Location (Экспортировать файлы в папку) определяет папки, в которые будут экспортированы HTML-документы и графические файлы. Часто при создании сайта графические файлы для всех его страниц размещают в отдельной папке. Отдельно устанавливаемые папки для графических и текстовых материалов в этом случае принесут большую пользу. Более того, для каждого экспортируемого документа могут быть назначены отдельные папки. Флажок View HTML (Просмотр HTML) включает немедленную загрузку экспортированной страницы в браузер для контроля правильности экспорта. Ниже переключателя находится кнопка, позволяющая выбрать браузер, который вы используете для просмотра Web-страниц.

Изначально в списке экспортируемых документов находится единственный документ — Untitled1, в который входят все страницы публикации. Для того чтобы предусмотреть создание нескольких документов (Web-страница не должна быть чересчур длинной), воспользуйтесь диалоговым окном Export HTML: New Document (Экспорт HTML: Новый документ), открывающимся кнопкой New (Новый) из главного окна фильтра экспорта. Внешний вид этого окна показан на рис. 18.10.

Рис. 18.10. Создание нового документа при экспорте публикации в формате HTML

Большую часть окна занимают два списка. В левом находится список всех страниц или материалов публикации, в правом — список тех страниц, которые должны войти в новый документ. Если для публикации важна разбивка на страницы, переместите переключатель, расположенный над списками, в положение Assign PageMaker Pages (Включить страницы публикации). Если же важнее представляется сохранение целостности текстовых материалов независимо от их расположения в макете (частый случай для газетных публикаций, в которых статья может быть раскидана по нескольким полосам), установите режим Assign PageMaker Stories (ignore layout) (Включить материалы (игнорировать макет)). Как явствует из названия режима, макет в этом случае не сохраняется, а в результате получается сплошной текстовый материал с включенной в него вложенной графикой, если таковая была.

В первом случае в левом списке отображаются все страницы публикации, во втором — все материалы. Щелкая мышью на элементах этого списка, выберите те страницы/материалы, которые должны войти в HTML-документ. Для одновременного выбора нескольких элементов удерживайте клавишу <Ctrl>. После того как содержание документа таким образом определено, щелкните на кнопке Add (Добавить). Если вы хотите, чтобы в документ вошли все страницы/материалы публикации, можно, не выделяя их все по очереди, просто воспользоваться кнопкой Add All (Добавить все). При необходимости убрать страницу/материал из документа выберите в правом окне лишние страницы/материалы и щелкните на кнопке Remove (Удалить). Если вы раздумали вообще создавать этот документ, воспользуйтесь кнопкой Rem All (Удалить все). Частенько трудно вспомнить, какой материал находится на каждой странице публикации, особенно если она достаточно объемна. Не выходя из диалогового окна, вы имеете возможность просмотреть любую страницу публикации. Для этого выберите требуемую страницу в любом из списков и нажмите кнопку View (Просмотр). Часть страницы, закрытую диалоговым окном, можно рассмотреть, перемещая его.

В самом верху данного диалогового окна находится поле Document Title (Название документа), позволяющее ввести ту информацию, которая будет помещена в поле <title></title> экспортированного HTML-документа. Как мы уже упоминали, оно несет важную нагрузку, и мы настоятельно рекомендуем не забывать правильно заполнять это поле.

Последний элемент диалога — кнопка Background (Задний план). Щелчок на ней открывает стандартное файловое диалоговое окно Windows, в котором можно указать имя файла с фоновой текстурой для экспортируемого документа. Текстура, как правило, имеет небольшой размер и используется браузером для заполнения фона. При этом браузер "размножает" текстуру, заполняя все неограниченное пространство страницы мозаикой из элемента, находящегося в файле. Web-страница может иметь не только текстурный фон, но и произвольный заливочный. Для того чтобы придать странице заливочный цвет, необходимо еще при редактировании публикации задать этот цвет в качестве цвета бумаги, используя палитру Colours (Цвета) (см. гл. 19).

Для перехода обратно в главное окно фильтра экспорта нажмите кнопку Done (Готово) или Cancel (Отменить), если вы передумали создавать документ. Содержание созданных документов вы можете в любой момент переопределить, если нажмете кнопку Edit (Редактировать) при выбранном в главном окне документе или просто дважды щелкнете мышью на его имени. В результате откроется диалоговое окно Export HTML: Edit Contents (Экспорт HTML: Редактировать содержимое), как две капли воды похожее на только что рассмотренное окно создания нового документа.

На экспорт публикации в формат HTML влияют установки фильтра экспорта, настроить которые можно, открыв диалоговое окно Options (Установки) значком на одноименной кнопке в главном окне фильтра (рис. 18.11).

Рис. 18.11. Установки фильтра экспорта публикации в формат HTML

Первый переключатель Approximate layout using HTML tables when exporting pages (Сохранять макет с помощью HTML-таблиц при экспорте страниц) определяет, будет ли PageMaker пытаться сохранить размещение элементов публикации в HTML-документе. Как мы уже говорили, без специальной адаптации макета, подготовленного для типографской печати, результат вряд ли будет удовлетворительным. Если переключатель отключен, то результатом экспорта будет сплошная страница текста со всеми графическими элементами, вложенными в него, причем, наиболее вероятно, совсем не в тех местах, где требуется по содержанию. При создании документа на основе материалов PageMaker (см. выше в этом же разделе) положение переключателя не имеет значения, т. к. при экспорте материалов сохранение макета невозможно.

В режиме сохранения макета становится доступным поле Exported page width (Ширина экспортированной страницы). Обязательно проследите, чтобы в этом поле стояла разумная цифра (см. предыдущий раздел). PageMaker при экспорте пропорционально отмасштабирует макет таким образом, чтобы в браузере он имел ширину в указанное количество пикселов. При неправильной установке этого значения вы либо получите пустую страницу, либо для ее просмотра придется долго прокручивать окно браузера.

В диалоговом окне установок расположена уже знакомая нам таблица соответствия стилей PageMaker стилям HTML. Мы обсуждали ее при рассмотрении импорта HTML-документов в публикацию. Несмотря на то, что теперь мы выполняем обратную задачу, соответствие стилей все равно придется определить.

Примечание

Значительную помощь в этом деле оказывает предварительная разметка публикации стилями HTML. Для того чтобы добавить эти стили в существующую публикацию, воспользуйтесь командой Add HTML Styles (Добавить стили HTML) меню палитры Styles (Стили). Названная команда добавит в палитру стилей все стили HTML. После этого серией поисков и замен по атрибутам абзацев (см. гл. 8) можно присвоить всем абзацам публикации стили HTML.

Переключатель Preserve character attributes (Сохранять атрибуты символов) определяет, будет ли сохраняться при экспорте локальное форматирование (увеличенный/уменьшенный кегль, начертание, позиции над- и подиндексов). Как правило, этот переключатель оставляют включенным.

Элементы управления группы Graphics (Изображения) управляют режимом преобразования графики в пригодный для WWW вид. -Как уже упоминалось выше, браузеры "понимают" изображения только в форматах GIF и JPEG, потому что файлы этих форматов имеют небольшие размеры. Размер файлов очень критичен при их передаче по сети, т. к. прямо пропорционален времени их загрузки. Поэтому всю графику, содержащуюся в публикации, необходимо преобразовать в названные форматы. Кроме того, разрешение изображений, используемых в WWW, значительно ниже, чем в полиграфии (72 точки на дюйм для WWW против 300 для фотонаборного автомата). Обе эти задачи — пересчет разрешения и сохранение в других форматах — за вас может сделать фильтр экспорта PageMaker. Формат (GIF или JPEG) можно определить, явно задав его одним из переключателей группы Export as (Формат) (переключатель All to GIF (Все в GIF) или All to JPEG (Все в JPEG)), а можно доверить выбор PageMaker, установив переключатель PageMaker chooses (Выбирает PageMaker). Пересчет разрешения изображений включается установкой флажка Downsample to 72 dpi (Снизить разрешение до 72 dpi). Кроме того, вы можете отказаться от сохранения длинных имен файлов Windows 95 и пользоваться старым форматом DOS (8 символов — имя и 3 символа — расширение). Короткие имена могут пригодиться для совместимости с Windows З.хх. Формат имен определяется группой переключателей File Names (Имена файлов), в которую входят два переключателя — Use long name (Использовать длинные имена) и Use short name (Использовать короткие имена).

Вернуться в главное окно фильтра экспорта позволяют кнопки ОК и Cancel (Отменить). Первая делает произведенные установки текущими, вторая отменяет их.

После того как определено содержание всех HTML-документов, каталоги для экспорта и его параметры, можно дать PageMaker команду создать эти документы (кнопка Export HTML (Экспорт HTML)), отказаться от экспорта и сделанных установок (кнопка Cancel (Отменить)) или отложить экспорт с сохранением всех настроек фильтра (кнопка Done (Готово)). Последний выбор предоставляет вам замечательную возможность вернуться к редактированию публикации без необходимости снова производить настройки фильтра экспорта, которые могут занять довольно много времени, особенно в части определения содержания экспортируемых документов.

Полученные при экспорте документы часто требуют дополнительного "причесывания", для которого недостаточно средств PageMaker. He исключено, что вам потребуется какой-нибудь специализированный редактор HTML. Скорее всего, это должен быть визуальный редактор, позволяющий не вникать в детали языка HTML. Среди них особо хотелось бы отметить Adobe Page Mill, разработанный Adobe Systems Inc. и хорошо совместимый с другими продуктами Adobe: PageMaker, Photoshop, Illustrator.

Примечание

К сожалению, локализация PageMaker не затрагивает кода программы. Поэтому фильтр экспорта PageMaker не правильно "понимает" русский язык, заменяя его символы соответствующим цифровым кодом, что в пять раз увеличивает размер экспортированного документа. Для приведения экспортированных документов в подобающий вид вам придется либо воспользоваться специальным перекодировщиком, либо пересохранить их в каком-нибудь редакторе HTML, поддерживающем кириллические кодовые таблицы.

Если вы не специалист в подготовке страниц для WWW, не исключено, что доводка экспортированных публикаций приведет к весьма нерациональным затратам вашего времени. Попытайтесь еще до начала реализации проекта договориться с Web-мастером вашего узла о возможности осуществления такой работы силами его группы.


Экспорт публикации в формат PDF

Для создания, редактирования и просмотра файлов формата PDF используется пакет программ Adobe Acrobat, разработанный фирмой Adobe. Изначально пакет был создан для переноса сверстанных документов между компьютерами разных платформ для их последующей распечатки (так называемой "печати по требованию" — print on demand). Подобный метод распространения технической информации очень удобен и дешев как для ее производителя, так и потребителей. Вторую жизнь Adobe Acrobat дало развитие Интернета. В его рамках перенос сверстанных документов является задачей номер один. WWW с его скромными возможностями HTML не в состоянии решить эту задачу в сколь-либо удовлетворительном виде. С ростом скоростей на магистральных каналах Интернета и на "последней миле" (xDSL, кабельный Интернет) внешний вид передаваемых документов перестал быть роскошью, а стал информативной частью самого документа. Средствами Adobe Acrobat пользуется все большее число профессиональных коммерческих поставщиков информации. Если вы относите себя к таковым, то Adobe Acrobat — ваш выбор.

Примечание

То, что Acrobat Reader не превратился в браузер Интернета, обусловлено и историческими и техническими причинами. Тем не менее в процессе установки Acrobat Reader помещает свои модули (plugins) в соответствующие каталоги двух наиболее популярных браузеров: Microsoft Internet Explorer и Netscape Navigator/Communicator. Эти модули позволяют просматривать PDF-документы прямо в окне браузера. При этом оно дополняется палитрой инструментов Adobe Acrobat Reader, обеспечивающей навигацию в PDF-документах (рис. 18.12).

Серьезным достоинством формата HTML является загрузка документов "по требованию". Для того чтобы просмотреть несколько страниц на сайте, вам не потребуется загружать его как целый документ. Начиная с версии 3.0, Adobe Acrobat позволяет также создавать PDF-документы, страницы которых загружаются, только если они выбраны для просмотра. Для такой оптимизации PDF-документов необходима программа Adobe Acrobat Exchange, которая имеется только в отдельной "коробочной" версии Adobe Acrobat 3.0.

Рис. 18.12. Вид PDF-документа в окне браузера

Adobe Acrobat состоит из набора программ, основными из которых являются Adobe Acrobat Distiller, собственно Adobe Acrobat и Adobe Acrobat Reader.

Первая предназначена для создания документов в формате PDF из PostScript-файлов. Вторая позволяет их редактировать, создавать оглавления, индексы, помещать в PDF-файлы мультимедийные ресурсы и т. п. Acrobat Reader, в отличие от остальных программ пакета, является свободно распространяемой программой, предназначенной для просмотра PDF-документов. Программа Acrobat Reader выпускается для большого числа различных платформ: DOS, Windows, Macintosh, UNIX и др. Это дает гарантию того, что документ, созданный с помощью Adobe Acrobat, может быть прочтен практически на любом компьютере. Если у вас нет программы Acrobat Reader, она может быть свободно получена с сайта Adobe в Интернете по адресу: http://www.adobe.com/acrobat .

В поставку PageMaker входят Acrobat Distiller и Acrobat Reader последней на момент издания этой книги коммерческой версии — 5.0. Чтобы установить Acrobat Distiller, нажмите на кнопку Acrobat Distiller 5.0 в окне автозапуска дистрибутивного компакт-диска PageMaker. Чтобы установить Acrobat Reader, нажмите кнопку Adobe Acrobat Reader 5.0 в том же диалоговом окне. Сами программы находится в одноименных папках дистрибутивного CD-ROM PageMaker.

Acrobat Distiller, поставляемый с PageMaker, тождествен таковому, входящему в отдельный продукт Adobe Acrobat 5.0. Он тесно взаимодействует с фильтром экспорта PDF-файлов, входящим в комплект PageMaker. Итак, какими основными возможностями обладает формат PDF и в чем его отличие от рассмотренного выше формата HTML?

PDF-документ значительно ближе к бумажной публикации, чем HTML. Он сохраняет практически все ее особенности: формат страницы, любую (в том числе и векторную) графику, гарнитуры, обтравки, обтекание изображений текстом, маски, фреймы, типографику (настройки трекинга, кернинга, переносов, цветов, цветовых моделей, параметры цветоделения и растрирования и т. п.). Кроме бережного отношения к дизайну публикации, PDF дополняет его чисто "электронными" возможностями: гипертекстом, закладками, аудио- и видеоматериалами, интерактивными формами, инструментами поиска и навигации, возможностью изменения масштаба отображения. Использование совершенных методов сжатия данных с возможностью выбора наиболее подходящего алгоритма делает файлы в этом формате зачастую более компактными, чем аналогичные HTML-документы. Всеми перечисленными уникальными возможностями формат PDF обязан языку PostScript, который лежит в его основе. Уже этот факт показывает, насколько близок PDF к издательским программам.


Подготовка к экспорту в формат PDF

Поскольку при экспорте в формат PDF публикация не претерпевает таких катастрофических изменений, как при использовании HTML, предварительная ее подготовка значительно проще. По сути, она состоит из трех элементарных операций.

  • Для стабильной передачи цветов, независимо от платформы компьютера, используйте цвета, определенные в палитре Online.
  • Если публикация разбита на несколько файлов PageMaker, создайте их список командой Book (Книга). (Подробнее об этом см. гл. 17).
  • Перенумеруйте страницы публикации или книги (см. гл. 17) арабскими цифрами, начиная со страницы 1. Adobe Acrobat поддерживает только такой способ нумерации страниц. В противном случае перекрестные ссылки могут дать неверный результат.

Как видите, ограничение на нумерацию страниц при переводе публикации в формат PDF — единственное! Все остальные манипуляции, связанные с изображениями и параметрами ссылок, можно определить уже на стадии экспорта публикации. К его рассмотрению мы и приступим немедленно.


Фильтр экспорта PDF

Гибкость формата PDF обуславливает огромное количество настроек фильтра экспорта. Фильтр не создает PDF-документов сам по себе — он является интерфейсом программы Acrobat Distiller, которая обязательно должна быть установлена для осуществления экспорта. Поэтому в фильтре экспорта находятся как настройки, отвечающие за преобразование специфических элементов верстки PageMaker (например, материалов), так и настройки программы Acrobat Distiller. Последовательность действий фильтра по команде экспорта такова:

  1. Фильтр печатает публикацию в PostScript-файл на жестком диске.
  2. Фильтр запускает программу Acrobat Distiller (если пользователь не указал обратного).
  3. Фильтр переопределяет установки Acrobat Distiller в соответствии со своими.
  4. Acrobat Distiller обрабатывает PostScript-файл публикации и создает PDF-файл.
  5. Фильтр стирает ненужный более PostScript-файл (если не указано обратное).
  6. Фильтр запускает Acrobat Reader и загружает в него PDF-документ. Главное окно фильтра изображено на рис. 18.13.

Все элементы управления диалогового окна PDF Options (Параметры PDF) можно разделить на две группы. Первая связана с переносом в формат PDF структуры публикации PageMaker, вторая— с самой ''программой Acrobat Distiller и особенностями ее работы.

Рис. 18.13. Главное окно фильтра экспорта PDF


Экспорт страниц

В группе Pages (Страницы) вкладки General (Общие) диалогового окна PDF Options (Параметры PDF) задают часть публикации, которую следует экспортировать в формат PDF. Если установлен переключатель All Pages in Current Publication (Все страницы в текущей публикации), будет экспортировано все содержимое текущего документа, а если переключатель All Pages in Book (Все страницы книги) — все документы, входящие в книгу (см. гл. 17). И наконец, если включен переключатель Ranges (Выборочно), в соседнем поле ввода должен быть задан диапазон страниц текущего документа, подлежащих экспорту. Номера страниц указываются тем же способом, что и в диалоговом окне печати PageMaker.


Экспорт гипертекстовых ссылок

Вкладка Hyperlinks (Гиперсвязи) (рис. 18.14) управляет преобразованием гиперсвязей, определенных в публикации гиперсвязи PDF-документа. Можно определить отдельно, сохранять ли автоматически созданные связи оглавления, связи автоматически собранного указателя и связи, определенные вами вручную (внутри публикации и с внешними ресурсами, в том числе с ресурсами Интернета).

Рис. 18.14. Вкладка Hyperlinks диалогового окна PDF Options

Чтобы ссылки сохранили свою функциональность в PDF-документе, установите флажки Internal links (Внутренние связи) и External links (Внешние связи). То, как будут выглядеть ссылки в PDF-документе, определяется элементами управления группы Default Appearance (Внешний вид по умолчанию). В списке Туре (Тип) выберите вариант Visible (Видимые), если хотите, чтобы ссылки в документе выделялись своим внешним видом. В противном случае выберите вариант Invisible (Невидимые). Тогда обнаружить, что текст или изображение являются ссылкой, можно будет, только наведя на них курсор мыши (рис. 18.15).

Примечание

На практике невидимые ссылки используются очень часто. Если в документе PageMaker вы заранее предусмотрели элементы навигации, то нет смысла их дополнительно выделять в PDF-документе. Их назначение и так очевидно.

В списке Style (Стиль) выберите стиль оформления видимых ссылок. Доступны только два стиля: сплошная и пунктирная рамки. В списке Width (Ширина) выберите толщину рамки, а в списке Color (Цвет) — ее цвет.

Рис. 18.15. Невидимая закладка в PDF-документе

В списке Highlight (Выделение) выберите внешний вид ссылки в момент щелчка мышью.

  • None (He определен). Оформление ссылки не изменяется.
  • Invert (Инверсия). Ссылка оформляется инверсными цветами.
  • Outline (Обводка). Ссылка обводится прямоугольной рамкой.
  • Inset (Врезка). Ссылка представляется в виде нажатой кнопки.

Выделение ссылки в момент щелчка мышью работает как для видимых, так и для невидимых ссылок.

При просмотре PDF-документа в Acrobat Reader удобным способом навигации по объемному документу являются закладки. Их внешний вид показан на рис. 18.16.

Рис. 18.16. Закладки в PDF-документе

Кроме ссылок, определенных вручную, фильтр экспорта способен преобразовать в ссылки такие стандартные структуры публикации, как оглавление и предметный указатель. В PDF-документе щелчок на элементе оглавления откроет страницу с соответствующим разделом, а на элементе указателя — на соответствующем входе. Чтобы включить преобразование, установите флажки Table of Contents Links (Гиперсвязи оглавления) и Index links (Гиперсвязи указателя). Оформление ссылок указателя и оглавления будет таким же, как у остальных ссылок.

В списке Magnification (Увеличение) выберите масштаб, в котором будет отображаться страница, открытая по гипертекстовой ссылке.

  • Fit Page (Вся страница). На экране помещается вся страница.
  • Fit Page Contents (Все содержимое страницы). На экране помещается все содержимое страницы (за исключением полей).
  • Fit Contents (Все содержимое). Видимо, создатели программы имели в виду Fit Context (По контексту). Этот вариант работает так же, как и предыдущий, но якорь, к которому ведет ссылка, помещается в левый верхний угол экрана.
  • Fit Top Left Page (Верхний левый угол страницы). Верхний левый угол страницы помещается в левый верхний угол экрана. Масштаб отображения страницы при этом задается в соседнем списке в процентах. Вы можете выбрать одно из предопределенных значений масштаба или задать его произвольно, выбрав в списке вариант Other (Другой). Он открывает диалоговое окно со строкой ввода масштаба.
  • Fit Top Left (Верхний левый угол). То же, что и предыдущий вариант, только в левый верхний угол экрана помещается якорь соответствующей ссылки.


Создание закладок

Закладки в большинстве случаев тождественны оглавлению. Поскольку они всегда находятся на экране независимо от просматриваемой страницы, вы можете щелкнуть мышью на любой закладке, и соответствующая страница окажется перед вами.

Примечание

Этот способ навигации по многостраничным документам хорошо знаком пользователям Интернета. Страница HTML-документа может быть разбита на несколько независимых окон — фреймов. Можно определить связи между фреймами таким образом, что выбор гиперссылки в одном фрейме отобразит привязку в другом. К сожалению, фильтр экспорта HTML PageMaker 6.5 не поддерживает фреймовых структур. Для их создания необходимо воспользоваться специализированным редактором HTML, например Adobe GoLive.

Закладки могут быть созданы как для элементов оглавления, так и для элементов указателя. Разумеется, только автоматически собранные командами Create TOC (Создать оглавление) и Create Index (Создать указатель) оглавления и указатели могут быть преобразованы в закладки. Если эти элементы создавались вручную, PageMaker не отличит их от обыкновенных материалов и гиперсвязи оглавления и указателя с соответствующими страницами публикации вам придется создавать также вручную. Создание закладок включается флажками Create Index Bookmarks (Создать закладки из оглавления) и Create TOC Bookmarks (Создать закладки указателя) (рис. 18.17) на вкладке Articles/Bookmarks (Статьи/Закладки) диалогового окна PDF Options (Параметры PDF).

Рис. 18.17. Вкладка Articles/Bookmarks диалогового окна PDF Options

Для закладок так же, как и для ссылок, можно определить масштаб отображения страницы. Для этого предназначен список Magnification (Увеличение) и соседнее поле ввода масштаба.


Создание статей

Аналогично материалам PageMaker, Adobe Acrobat делит публикацию На статьи. Если документ содержит множество обособленных материалов, которые могут располагаться на нескольких страницах не заполняя их при этом целиком (газеты, журналы), определение их как статей позволит читателю легче в них ориентироваться. При просмотре документа в программе чтения Acrobat Reader можно выбрать пункт Articles (Статьи) из меню View (Просмотр). Эта команда открывает диалоговое окно со списком определенных в документе статей. Двойной щелчок мышью на названии требуемой статьи выбирает ее для просмотра. При этом Acrobat Reader помещает на экран начало статьи. С помощью полос прокрутки легко просмотреть статью целиком, независимо от страниц, которые она занимает, т. к. если продолжение статьи находится на другой странице, Acrobat Reader автоматически "перелистывает" ее и помещает на экран.

Создание статей включается переключателем Export Articles (Создать статьи) на вкладке Articles/Bookmarks (Статьи/Закладки) диалогового окна PDF Options (Параметры PDF). Если этот переключатель установлен, становится доступной кнопка Define (Определить), открывающая диалоговое окно Define Articles (Определить статьи).

Статья может состоять из одного или нескольких материалов PageMaker. Определению того, какие материалы PageMaker должны войти в каждую статью Adobe Acrobat, служат это и вложенное в него диалоговые окна. Способ определения статей схож с определением страниц/материалов для HTML-документа.

В диалоговом окне Define Articles (Определить статьи) нажатием кнопки New (Новый) открывается диалоговое окно (рис. 18.19), основную часть которого занимают два списка: внизу находится*-список всех материалов публикации PageMaker, вверху — список материалов, отобранных для статьи.

Рис. 18.19. Определение состава статей PDF-документа

Выделив элемент нижнего списка и нажав кнопку Add (Добавить), вы указываете, что данный материал является частью настоящей статьи. Если выбрать добавленную статью в верхнем окне и нажать кнопку Remove (Удалить), он выйдет из состава статьи. Если из названия не понятно, какой материал имеется в виду, то нажатие кнопки Preview (Просмотр) выведет окно с текстом материала (рис. 18.20). Переключатель List stories in (Показывать только материалы) определяет, будут ли использоваться при создании статьи материалы текущей публикации (вариант Current publication only (Текущей публикации)) или всей книги (вариант Entire book (Всей книги)). Разумеется, текущая публикация должна содержать список публикаций всей книги (см. гл. 17). В поле List only stories over ... characters long (Показывать только материалы длиннее ... символов) вводится минимальный размер материала, который может быть включен в статью. Ввод верного значения символов в это поле позволяет исключить из статьи лишние материалы, например сноски, колонтитулы, шрифтовые элементы дизайна и т. п. Если в списке материалов все-таки оказались лишние, слишком короткие, увеличьте число в поле List only stories over ... characters long (Показывать только материалы длиннее ... символов) и нажмите кнопку Relist (Обновить). В нижнем списке окажутся только материалы, удовлетворяющие новому минимуму символов.

Рис. 18.20. Окно просмотра материала Preview Article

Кнопка OK открывает диалоговое окно Article Properties (Свойства статьи), позволяющее задать следующие параметры (рис. 18.21).

  • Title (Название). Название статьи. Это поле должно быть заполнено обязательно. В него вводится то имя, под которым будет фигурировать статья в общем списке статей Acrobat Reader.
  • Subject (Тема). Тема статьи.
  • Author (Автор). Автор статьи.
  • Keywords (Ключевые слова). Произвольный набор ключевых слов, характеризующий содержание статьи. Все параметры статьи, кроме названия, призваны упростить поиск статьи в PDF-документе.

Рис. 18.21. Диалоговое окно Article Properties

Кнопка OK в диалоговом окне Article Properties (Свойства статьи) возвращает вас в диалоговое окно Define Articles (Определить статьи) с сохранением информации о новой статье. При этом название созданной статьи будет отображено в списке статей.

Повторяя описанные манипуляции, создайте требуемое количество статей. Разбивку материалов публикации по статьям можно в любой момент изменить, выделив подлежащую редактированию статью и нажав кнопку Edit (Редактировать). Она открывает точно такое же диалоговое окно, как и при создании новой статьи.

При создании статей можно установить фильтрацию не только коротких материалов, но и материалов, состоящих из малого числа блоков. Цель такого "ценза" та же самая — автоматически исключить несодержательные материалы. Фильтрация материалов по числу текстовых блоков включается флажком One per story over ... text block(s) (Каждый материал занимает более ... блоков). После изменения минимального количества блоков нажмите кнопку List (Перечислить), чтобы обновить список статей.

Когда все статьи будут верно определены, нажмите кнопку ОК, которая вернет вас к диалоговому окну PDF Options (Параметры PDF).


Информация о документе

Фильтр экспорта PDF в PageMaker способен автоматически поместить в PDF-файл одну заметку (note), содержащую произвольную информацию о документе. Заметка появляется на странице в раскрытом или закрытом виде (рис. 18.22) в зависимости от состояния переключателя Display (Показывать) на вкладке Doc. Info (Информация о документе). Текст заметки вводится в расположенном ниже многострочном поле ввода.

Для облегчения поиска нужного PDF-документа среди большого их числа заполните остальные поля на названной вкладке диалогового окна PDF Options (Параметры PDF). Все эти данные доступны в диалоговом окне Document Summary (Характеристика документа) в программе Acrobat Reader.


Защита PDF-документа

Формат PDF предполагает возможность защиты документов от несанкционированного использования. Защита имеет два уровня и включается вводом на вкладке Security (Защита) диалогового окна PDF Options (Параметры PDF) двух независимых паролей. Если введен пароль в поле User Password (Пароль пользователя), то Acrobat Distiller шифрует документ. Это нижний и весьма стойкий уровень защиты. Acrobat Reader сможет расшифровать и отобразить документ только в том случае, если ему дать тот же самый пароль. В Acrobat 4.0 использовался 40-битный алгоритм шифрования RC4, который оказался недостаточно криптостойким перед вычислительной мощностью современных компьютеров. В новой версии программы введено 128-битное шифрование.

Второй уровень защиты включается вводом пароля Master Password (Пароль создателя). Открыв документ в Adobe Acrobat (не Reader!) и введя этот пароль, вы сможете изменить права доступа к файлу, включая и изменение самого пароля. Изначально права доступа определяются при экспорте публикации.

Рис. 18.22. Заметка в PDF-документе (а, б) и ввод информации на вкладке Doc. Info диалогового окна PDF Options (s)

Для Acrobat 3.0 и 4.0 на вкладке Security (Защита) (рис. 18.23) задаются перечисленные далее варианты ограничения доступа к PDF-документу.

  • No Printing (Запретить печать). Открытый документ невозможно распечатать.

Рис. 18.23. Вкладка Security диалогового окна PDF Options

  • No Changing the Document (Запретить изменения). Adobe Acrobat допускает ограниченное редактирование PDF-документов: небольшое редактирование текста, создание гипертекстовых ссылок, закладок и т. п. Установка этого флажка запрещает внесение в документ любых изменений.
  • No Content Copying or Extraction, Disable Accessibility (Запретить копирование документа). Запрещено копирование любой информации из PDF-документа в буфер обмена.
  • No Adding or Changing Comments and Form Fields (Запретить изменение комментариев и полей форм). Пользователю дозволяется заполнять поля форм, но не редактировать их. Также запрещено создание комментариев.

Задайте требуемый набор ограничений доступа, установите соответствующие флажки. Для Acrobat 5.0 предлагаются расширенные возможности защиты документов (рис. 18.24).

  • Enable Content Access for the Visually Impaired (Разрешить доступ пользователям с дефектами зрения). Флажок позволяет использовать набор специальных функций Adobe Acrobat/Acrobat Reader для людей с ослабленным зрением (особые цветовые схемы и т. п.).

Рис. 18.24. Настройки прав доступа для файлов Adobe Acrobat 5.x

  • Allow Content Copying and Extraction (Разрешить копирование документа). Флажок разрешает копирование информации из PDF-документа в буфер обмена.
  • Changes Allowed (Допустимые изменения). В списке выберите один из вариантов, соответствующий требуемому уровню доступа:
    • None (Запрещены). Запрещаются любые изменения в PDF-документе;
    • Only Document Assembly (Только сборка документа). Допускается дополнение документа новыми страницами, их удаление, поворот, а также создание и удаление закладок и миниатюр страниц;
    • Only Form Field Fill-in or Signing (Только заполнение полей и электронная подпись). Допускается заполнение полей и внедрение в документ электронной подписи;
    • Comment Authoring, Form Fill-in or Signing (Создание комментариев, заполнение форм, электронная подпись). То же, что и предыдущий вариант, но разрешается создание и редактирование форм и комментариев;
    • General Editing, Comment and Form Field Authoring (Общее редактирование, создание форм). Разрешаются любые изменения в документе.
  • Printing (Печать). Выберите один из следующий вариантов ограничения прав печати документа:
    • Not Allowed (Запрещена). Печать документа запрещена;
    • Low Resolution (Низкое разрешение). Разрешена печать документа только с пониженным разрешением. На печать выводится растеризованная с низким разрешением версия документа. Позволяет предотвратить повторное создание документа печатью в новый PDF-файл;
    • Fully Allowed (Полностью разрешена). Печать полностью разрешена.

Отметим, что второй уровень защиты не столь надежен как первый, поскольку не предполагает шифрования. Его теоретически можно обойти, внеся изменения в код Adobe Acrobat, ведь именно программа ответственна за соблюдение всех ограничений. По крайней мере, авторам известен подобный способ взлома защиты Acrobat 4.x. Существуют и другие способы, продемонстрированные программистами ElcomSoft http://www.elcomsoft.ru .

Версия формата PDF (соответственно, и Adobe Acrobat), в которую экспортируется документ, задается в настройках Acrobat Distiller. К их рассмотрению мы и перейдем в следующем разделе.


Параметры PDF-документа

Кнопка Edit Job Options (Редактировать параметры задания) на вкладке General (Общие) диалогового окна PDF Options (Параметры PDF) дает доступ к настройкам программы Acrobat Distiller. Она открывает диалоговое окно Job Options (Параметры задания), содержащее пять вкладок. Первая вкладка General (Общие) содержит общие настройки Acrobat Distiller (рис. 18.25).

Самая существенная из них — Compatibility (Совместимость). В этом списке выберите версию формата PDF, с которой необходимо обеспечить совместимость. На текущий момент PDF 1.3 (Acrobat 4.0) можно считать самым разумным выбором.

Флажок Optimize for Fast Web View (Оптимизировать для быстрого просмотра в Web) включает оптимизацию PDF-документа, допускающую постраничную загрузку файла в браузер. Флажок Embed Thumbnails (Внедрить миниатюры) заставляет Distiller внедрять в PDF-документ миниатюры каждой его страницы. Они видны в докере Thumbnails (Миниатюры) Adobe Acrobat/Acrobat Reader (рис. 18.26). Миниатюры облегчают ориентацию в небольших документах, но в то же время слегка увеличивают размер файла. Если он предназначен для распространения через Интернет, генерацию миниатюр лучше отключить.

Флажок Auto-Rotate Pages (Автоматически поворачивать страницы) включает автоматический поворот страницы в PDF-документе, основываясь на ориентации текста или внедренных комментариях DSC (Document Structure

Рис. 18.25. Вкладка General диалогового окна Job Options

Рис. 18.26. Миниатюры в Adobe Acrobat

Convention). Устанавливайте этот флажок, если макет имеет разную ориентацию на разных страницах или если ее просто надо изменить. В первом случае выберите в соседнем с флажком списке вариант Individually (Индивидуально), а во втором — Collectively by File (Для всего файла).

Переключатель и поля группы Page Range (Диапазон страниц) дублируют те, что находятся на вкладке General (Общие) диалогового окна PDF Options (Параметры PDF). Они позволяют определить диапазон страниц, экспортируемых в формат PDF. В списке Binding (Скрепление) выберите сторону сшивки при оборотной печати. Это повлияет только на отображение документа в Adobe Acrobat/Acrobat Reader при включенных режимах Facing Pages (Разворот) и миниатюр разворотов.

Параметр Resolution (Разрешение) задает разрешение растровых изображений в PDF-документе. Устанавливайте разрешение исходя из предполагаемого устройства вывода. Если это экран монитора, то достаточно разрешения 72 dpi. Для печати на принтере, как правило, требуется 120—150 dpi, для типографской печати — 225—300 dpi. Подробнее об этом написано в гл. 23.

Группа полей Default Page Size (Размер страниц по умолчанию) позволяет задать размер страницы PDF-документа, отличающийся от размера страниц публикации. Настройка этого параметра требуется очень редко.


Размер PDF-файла

На вкладке Compression (Уплотнение) задаются параметры включенных в документ растровых изображений (рис. 18.27). Напомним, что векторные изображения, созданные в программах подготовки иллюстраций, включаются в PDF-документ в исходном виде и не переводятся в растровые. Параметры растровых изображений задаются отдельно для цветных, полутоновых и монохромных изображений: это алгоритм и степень уплотнения графических данных, а также целевое разрешение. Оба параметра призваны снизить размер получаемого файла.

Создавая PDF-файл, необходимо представлять себе способ его распространения или использования. Если он предназначен только для просмотра на экране, нет смысла включать в него изображения высокого разрешения. Если же публикация была создана для типографской печати, то в нее будут включены изображения высокого разрешения. При экспорте в формат PDF вы сможете установить требуемое разрешение растровых изображений и за счет этого получить несколько версий документа: для экранного просмотра, для распечатки и для типографского тиражирования. В каждом случае необходимо будет установить первый флажок в каждой группе элементов управления, соответствующей типам изображений; выбрать алгоритм пересчета разрешений в соседнем списке; ввести целевое разрешение в поле справа; ввести минимальное разрешение, требующее пересчета. Если разрешение изображения не выше минимального значения, то Distiller не будет его изменять. Последний параметр позволяет обрабатывать только те изображения, которые имеют завышенное разрешение.

Примечание

Acrobat Distiller не может увеличивать разрешение изображений. Если целевое разрешение оказывается выше текущего разрешения изображения, оно игнорируется.

Рис. 18.27. Вкладка Compression диалогового окна Job Options

Алгоритмы уменьшения разрешения отличаются точностью и скоростью. Если располагать их в порядке увеличения точности, получится такой ряд:

Subsampling -> Average Downsampling to -> Bicubic Downsampling to.

Скорость работы алгоритмов растет в обратном направлении. Мы рекомендуем пользоваться только последним методом, т. к. в большинстве случаев качество является более критичным фактором, чем время. Да и разница во времени обработки файлов со средним количеством графики не слишком существенна.

Дальнейшее сокращение размеров файлов достигается за счет уплотнения графических данных. В одном из списков Compression (Уплотнение) выбирают алгоритм сжатия, а в списке Quality (Качество) — приемлемое качество получающихся изображений.

Для первых двух можно доверить Adobe Acrobat определять, каким методом сжатия воспользоваться (установлен флажок Automatic compression (Автоматическое сжатие)) или определить это напрямую, выставив тип JPEG или ZIP при установленном рядом флажке. Непосредственный выбор может оказаться необходимым, если растровый графический материал содержит рисунки, текст, снимки экрана и т. п. В этом случае следует установить уплотнение по алгоритму LZW, который не снижает качества графики (об особенностях графических форматов и алгоритмов сжатия см. гл. 10). Монохромные изображения требуют явного задания алгоритма уплотнения. Алгоритм влияет на размер сжатых файлов и на скорость их распаковки в программе просмотра. По плотности упаковки алгоритмы располагаются в таком порядке:

CCITT Group 4 -> LZW -> CCITT Group 3 -> RunLength.

Установите флажок Anti-Alias to gray (Сгладить до полутонового), если требуется сгладить "рваные" линии монохромных изображений низкого разрешения. В соседнем списке выберите глубину цвета получающегося сглаженного изображения. Чем выше глубина цвета, тем более гладкими будут линии, но и больше места займет изображение. Учтите, что очень тонкие линии могут после сглаживания выглядеть нечеткими, размытыми. Если вы готовите макет для типографского тиражирования, сглаживанием лучше не пользоваться. Вместо этого следует сканировать изображение с достаточно высоким разрешением. Практически всегда достаточно разрешения 800—900 dpi при размере 1:1.

Флажок Compress Text and Line Art (Уплотнять текст и векторные объекты) следует устанавливать всегда. Сжатие векторных объектов никогда не приводит к потере качества, зато часто приносит очень существенный выигрыш в размере файла.


Внедрение шрифтов

Самая сложная проблема при переносе файлов публикаций между компьютерами — это правильная передача шрифтов. Adobe Acrobat решает эту проблему двумя способами: встраивает шрифт в PDF-документ либо пытается создать очень похожий шрифт, используя технологию Multiple Master. Создать похожий шрифт он может только для обычных наборных шрифтов. Для передачи декоративных шрифтов используется встраивание их в PDF-документ. Причем для уменьшения размеров документа шрифт включается в него не целиком, а только те символы, которые действительно в нем используются. Обычно решение о том, будет шрифт встроен в PDF-файл или сгенерирован Adobe Acrobat, принимает сама программа. Но, если вы очень щепетильно относитесь к точной передаче рисунка наборного шрифта, а размер получающегося документа не очень важен (например, при распространении его на CD-ROM), вы можете заставить Acrobat Distiller встраивать в документ все шрифты публикации, установив флажок Embed All Fonts (Внедрить все шрифты) на вкладке Fonts (Шрифты) диалогового окна Job Options (Параметры задания) (рис. 18.28).

Рис. 18.28. Вкладка Fonts диалогового окна Job Options

Флажок Subset embedded fonts when percent of characters used is less than (Внедрять шрифты, если используется более ... символов) включает частичное внедрение шрифтов. В соседнем поле вводится максимальный процент задействованных символов шрифта, достаточный для внедрения только его части. Если задана величина 100%, шрифты никогда не внедряются в PDF-документ целиком. Если же установить в нем 0%, то, наоборот, все шрифты будут внедряться целиком, независимо от того, какая часть их символов действительно использована в документе.

Лицензионная политика части производителей шрифтов запрещает их внедрение в документы. Сведения об этом содержатся в самом файле шрифта. Такие шрифты Acrobat Distiller не сможет внедрить в PDF-документ. Список When Embedding Fails (Если шрифт не внедряется) позволяет задать поведение программы в отношении шрифтов с запретом на внедрение:

  • Ignore (Игнорировать). Обрабатывать файл, несмотря на невозможность внедрения шрифта. В результате часть шрифтов в документе могут оказаться неверными. Узнать об этом можно будет, только внимательно просмотрев документ в Adobe Acrobat/Acrobat Reader. Мы не рекомендуем пользоваться такой политикой.
  • Warn and Continue (Предупредить и продолжать). То же, что и предыдущий вариант, только с выдачей предупреждения о проблемной ситуации. Режим хорош для диагностирования проблем с внедрением шрифтов.
  • Cancel Job (Отменить задание). Наиболее строгий выбор, заставляющий Acrobat Distiller прекратить создание PDF-файла, если хотя бы один шрифт не удается внедрить. Такая политика не допускает создания "неправильного" PDF-файла.

В области Embedding (Внедрение) выбирают те шрифты, которые следует (список Always Embed (Всегда внедрять)) и не следует (список Never Embed (Никогда не внедрять)) внедрять в документы. Чтобы внести шрифт в один из этих списков, нажмите кнопку >>, расположенную слева от списка. Шрифты, выделенные в левом длинном списке, заносятся в соответствующий раздел. Раскрывающийся список в верхнем левом углу области содержит перечень всех папок жесткого диска, в которых находятся шрифты. Выберите требуемую папку, и ниже отобразится список всех имеющихся в ней шрифтов. Чтобы удалить шрифт из списка внедряемых или запрещенных к внедрению, выделите его в соответствующем списке и нажмите кнопку Remove (Удалить).


Управление цветом в PDF-документах

Формат PDF поддерживает внедрение профилей и управление цветом (рис. 18.29). В списке Settings File (Файл настроек) находятся несколько предустановленных вариантов стратегии управления цветом. Вариант Color Management Off (Управление цветом отключено) отключает управление цветом, т. е. запрещает внедрение цветовых профилей в файлы PDF. Вариант None (He определен) позволяет задать пользовательскую стратегию управления цветом и активизирует остальные настройки CMS.

В области Color Management Policies (Политика управления цветом) задается политика управления цветом в PDF-документе:

  • Leave Color Unchanged (Оставить цвета без изменений). Аппаратно-зави-симые цвета публикации остаются без изменений. Все установки управления цветом, сделанные в PageMaker, сохраняются в PDF-файле.

Рис. 18.29. Вкладка Color диалогового окна Job Options

Примечание

Файлы PostScript не содержат внедренных цветовых профилей. Если управление цветом в PageMaker было включено, то цвета в файле PostScript хранятся в аппаратно-независимом цветовом пространстве Lab. Acrobat Distiller может оставить информацию из PostScript-файла как есть, а может снабдить цвета соответствующими цветовыми профилями.

  • Tag Everything for Color Management (Управление цветом для всех объектов). В этом режиме CMS активна и делает цвета в PDF-документе аппа-ратно-независимыми за счет перевода их в модель Lab.
  • Tag Only Images for Color Management (Управление цветом изображений). To же, что и предыдущий вариант, только управление цветом разрешено исключительно для импортированных растровых изображений.
  • Convert All Colors to RGB (Преобразовать все цвета в RGB). Переводит все цвета документа в калиброванное цветовое пространство sRGB.

Если вы выбрали один из трех последних варцантов, цвета публикации будут преобразованы в "рабочие пространства", заданные в области Working Spaces (Рабочие пространства). Три списка этой области соответствуют трем рабочим пространствам для разных типов изображений: полутоновых, RGB и CMYK. Установите их, исходя из предполагаемых устройств вывода. Заметьте, что вы можете отказаться от преобразования одного или нескольких типов, установив в соответствующем списке вариант None (He определен).

В списке Intent (Метод) выберите способ преобразования цветовых охватов, соответствующий характеру публикации. Дело в том, что система управления цветом выполняет преобразование цветов для устройств с разным цветовым охватом. Часть цветов, имеющихся в публикации, могут не существовать в цветовом пространстве устройства вывода. Это делает принципиально невозможной точную передачу цветов на печати. Выбор в списке Intent (Метод) говорит системе управления цветом, как она должна обрабатывать такие цвета:

  • Perceptual (Перцептивный). Если в документе есть цвета, выходящие за цветовой охват "рабочего пространства", весь диапазон цветов при этом пропорционально сокращается. Изменяются все цвета, в том числе входящие в "рабочее пространство", но зато сохраняется соотношение цветов, близкое к исходному.
  • Saturation (По насыщенности). При переводе сохраняется насыщенность цветов. Этот способ применим, только если яркие цвета — единственная цель, например в деловой графике.
  • Relative Colorimetric (Относительный колориметрический). Цвета, выходящие за цветовой охват "рабочего пространства", заменяются на ближайшие входящие. Этот способ может привести к тому, что цвета, изначально разные, в "рабочем пространстве" станут одинаковыми, а соотношение цветов изменится.
  • Absolute Colorimetric (Абсолютный колориметрический). Цвета передаются в исходном виде, в исходном пространстве, без поправки черной и белой точек, что может привести к изменению яркости. Применяется только при необходимости соблюдения отдельных точных цветов, например "фирменных".

Если управление цветом включено не для всех элементов публикации, следует настроить Acrobat Distiller для обработки аппаратно-зависимых цветов. Флажок Preserve Overprint Settings (Сохранять настройки печати с наложением) позволяет сохранить информацию о печати с наложением заливок и обводок объектов PageMaker. Если в публикации размещены цветоделенные изображения и вы хотите сохранить установки генерации черного, установите флажок Preserve UnderColor Removal and Black Generation Settings (Сохранять установки UCR и генерации черного). Чтобы сохранить установки растрирования (например, особо заданные для отдельных изображений линиатуры и углы растрирования), установите флажок Preserve Halftone Information (Сохранять информацию о растрировании).

В списке Transfer Functions (Функции переноса) выберите один из вариантов поведения Acrobat Distiller по отношению к изображениям со встроенными функциями переноса:

  • Remove (Удалить). Функция переноса игнорируется.
  • Preserve (Сохранить). Функция переноса сохраняется и в PDF-документе.
  • Apply (Применить). Функция переноса применяется к изображению, т. е. значения пикселов изменяются согласно функции переноса.

Примечание

В общем случае не следует пользоваться функциями переноса. Они широко использовались в те времена, когда управление цветом еще не поддерживалось столь широко и на системном уровне. По существу функция переноса — это управление цветом в обход CMS.


Дополнительные настройки Acrobat Distiller

На вкладку Advanced (Дополнительно) диалогового окна Job Options (Параметры задания) попали все настройки, не относящиеся к описанным выше разделам (рис. 18.30). Мы не будем разбирать их подробно, т. к. они редко требуют изменения.

  • Use Prologue.ps and Epilogue.ps (Использовать Prologue.ps и Epilogue.ps). Использовать PostScript-файлы пролога и эпилога. В названных файлах могут содержаться дополнительные настройки интерпретатора Acrobat Distiller. Если данный флажок установлен, оба файла должны существовать и находиться в одной папке с Acrobat Distiller.
  • Allow PostScript file to Override Job Options (Разрешить PostScript смену настроек). Если флажок установлен, то настройки в PostScript-файле получают приоритет над настройками, сделанными в диалоговом окне Job Options (Параметры задания).
  • Preserve Level 2 copypage Semantics (Сохранять семантику Copypage Level 2). Обеспечивает совместимость с некоторыми интерпретаторами PostScript Level 2,
  • Save Portable Job Ticket inside PDF file (Сохранять задание печати в файле PDF). Сохраняет в PDF-файле описание установок печати PageMaker и Acrobat Distiller. Информация может использоваться разнообразным программным обеспечением для предпечатной подготовки.
  • Illustrator Overprint Mode (Режим Illustrator для печати с наложением). Разрешает печать триадных красок с наложением.
  • Convert gradients to smooth shades (Преобразовать градиенты в оттенки). Преобразует перетекания в плавные градиенты. Установка флажка уменьшает размер файла и повышает качество изображения. Параметр совместим с Acrobat 4.x и 5.х, а также с программами Adobe Illustrator, Macromedia FreeHand, CorelDRAW, QuarkXPress и Microsoft PowerPoint; не совместим с Adobe PageMaker.
  • ASCII Format (Формат ASCII). Создает PDF-файл в текстовом формате. Устанавливайте флажок при возникновении проблем интерпретации PDF-файла устройством печати.

Рис. 18.30. Вкладка Advanced диалогового окна Job Options

Остальные настройки связаны с соблюдением конвенций о структуре документа (DSC — Document Structuring Conventions). Они требуют понимания того, "как устроен" PostScript и как происходит его преобразование в PDF. Более подробную информацию можно получить из спецификации PostScript и формата PDF. Они свободно доступны на сайте Adobe в Интернете.

Из настроек DSC вам могут пригодиться следующие:

  • Preserve OPI Comments (Сохранить комментарии OPI). Установка флажка сохраняет связи с изображениями высокого разрешения и у файла PDF.
  • Preserve Document Information from DSC (Сохранять информацию о документе). Информация о документе, введенная в PageMaker, сохраняется и в PDF-файле. Ее впоследствии можно просмотреть в диалоговом окне Document Summary (Характеристика документа) Adobe Acrobat/Acrobat Reader.


Сохранение настроек

Как вы уже успели убедиться, процесс экспорта в формат PDF имеет множество настроек. Чтобы не выставлять их все заново при каждом экспорте, сохраните необходимые настройки в файл стиля, для чего нажмите кнопку Save Style (Сохранить стиль) в диалоговом окне PDF Options (Параметры PDF). Она открывает диалоговое окно Save PDF Style (Сохранить стиль PDF), изображенное на рис. 18.31.

Просмотрите содержимое текстового поля и убедитесь, что все настройки сделаны верно. Затем введите имя файла настроек и нажмите кнопку Save (Сохранить). Новый стиль появится в списке PDF Style (Стиль PDF) диалогового окна PDF Options (Параметры PDF).

Рис. 18.31. Диалоговое окно Save PDF Style


Экспорт PDF

После того как установлены все настройки, нажмите кнопку Export (Экспортировать) в диалоговом окне фильтра PDF Options. Она откроет стандартное, и на этот раз последнее, диалоговое окно с запросом имени файла. Введите произвольное имя и нажмите кнопку Save (Сохранить). При отсутствии ошибок вы должны получить готовый PDF-файл с выбранным именем. При появлении ошибки интерпретации Acrobat Distiller завершит обработку документа, и вместо PDF-файла вы обнаружите текстовый файл с сообщением об ошибке и ее причинах. В некоторых случаях определить причину ошибки, не зная языка PostScript, бывает сложно, но в большинстве случаев она связана со шрифтами или слишком сложными контурами. За дальнейшей информацией по этому вопросу мы рекомендуем обратиться к спецификации PostScript или к замечательному сайту Лоренса Лерса Ргеpressure (бывш. Prepress Panik) по адресу: http://users.belgacom.net/prepresspanic/ . На нем вы обнаружите достаточно полный список ошибок PostScript, описание их причин и способов их предотвращения.


Резюме

Мы рассмотрели способы создания электронных публикаций с помощью Adobe PageMaker 7.0 с той степенью подробности, которой они заслуживают. Какой из них больше подходит для ваших публикаций — выбирать вам. Заметим только, что сделать профессионально выглядящую электронную публикацию столь же не просто, как и бумажную. Она требует нешаблонного мышления и умелого использования технических возможностей, особенно мультимедийных. Если электронные публикации играют для вас вспомогательную роль, то материалов этой главы хватит для выпуска несложных "электронных изданий". Если же электронные средства распространения для вас столь же важны, что и традиционные, средств PageMaker вам явно будет недостаточно.

Инструментальные средства разработки Web-публикаций в изобилии имеются в Интернете вместе со всей информацией об их использовании, самом языке HTML и программировании для Интернета. Для выпуска броских публикаций в формате PDF вам понадобятся еще только полная отдельная версия пакета программ Adobe Acrobat, включающая еще Acrobat Exchange (позволяет редактировать PDF-документы, определять пользовательские элементы управления, использовать мультимедийные средства, переопределять и создавать связи, оптимизировать документы для WWW, устанавливать ограничения доступа к документам), Acrobat PDF Writer (дает возможность быстрого и удобного создания документов PDF из любого приложения), а также полезные дополнительные утилиты каталогизации (Acrobat Catalogue) и перевода в PDF-формат больших количеств бумажных документов (Acrobat Capture).

Выпуск электронных публикаций — особый "жанр", и серьезное овладение им требует серьезных же затрат времени. При эпизодической необходимости создания электронных публикаций мы рекомендуем переложить работу по их окончательной доводке на плечи специалистов.


  • ЧАСТЬ V. ЦВЕТ
    • Глава 19. Определение цветов
      • Описание цвета
        • Цветовой охват
        • Модель RGB
        • Модель HSB
        • Модель CMYK
        • Плашечные цвета
        • Lab — аппаратно-независимая модель
      • Палитра цветов в PageMaker
      • Работа в окне Color Options
        • Плашечный цвет
        • Триадный цвет
        • Оттенки цветов
      • Определение цветов в диалоговом окне
      • Обеспечение единообразия определения цветов
        • Слияние цветов
        • Удаление цветов
      • Импорт цветов из другой публикации
      • Цвета импортированных объектов
      • Создание личных библиотек
      • Резюме


ЧАСТЬ V.

Цвет

  • Глава 19. Определение цветов
  • Глава 20. Использование цвета
  • Глава 21. Управление цветом и треппинг


ГЛАВА 19.

Определение цветов

В настоящей главе обсуждаются вопросы планирования цветного оформления публикации. В ней рассматриваются следующие вопросы:

  • Способ формирования изображения на экране монитора и на бумаге. Излучаемые и отражаемые цвета.
  • Калибровка оборудования и ее возможности.
  • Способы цветовоспроизведения. Цветовые модели.
  • Печать плашечным цветом.
  • Триадный цвет.
  • Точность цветовоспроизведения. Способы ее повышения.
  • Планирование цветового оформления публикации, выбор способа цветовоспроизведения.
  • Палитра цветов PageMaker. Организация библиотеки цветов для публикации.

В данной главе рассматривается первый этап работы с цветной публикацией в PageMaker — определение цветов. Перед тем как цветом можно будет воспользоваться для оформления объектов в публикации, его необходимо определить. Для правильного определения цвета следует обсудить некоторые теоретические вопросы.


Описание цвета

Цвет в понимании физика — это синоним длины волны света в видимой области. Однако для художника или полиграфиста этот гипотетический цвет совершенно не важен. Для нас принципиально, как будет выглядеть цвет для наблюдателя, т. е. физическая величина связывается с биологическим процессом цветного зрения. В глазу человека есть-цветочувствительные элементы, воспринимающие отдельные компоненты цвета объектов. Затем в головном мозге данные обрабатываются и синтезируется цвет. У разных людей чувствительность этих элементов различна. Обработка также происходит по-разному.

Однако задача точного описания цвета, тем не менее, существует. В производстве полиграфической продукции, при выпуске фильмов и телепередач, вообще везде, где конечный продукт имеет окраску, необходимо соответствие этого цвета неким образцам. Во многих случаях к корректности цветопередачи предъявляются жесткие требования, например в высококачественной полиграфии. Для того чтобы использовать-цвет в процессе работы над изображениями и публикациями, необходимо его описать в цифровом виде, т. е. кодировать. Ведь только в этом случае программа графического приложения поймет, в какой цвет вы хотите раскрасить данный объект.

Кодирование цвета — очень непростая задача. В каких единицах измерить цвет? Что взять за точку отсчета? Как выразить бесконечное число видимых цветов с помощью небольшого числа переменных? Существует несколько способов математического описания цвета, называемых цветовыми моделями. Описание цвета на основе цветовой модели основано на следующем положении: путем смешивания нескольких базовых или основных цветов можно получить остальные цвета, называемые составными. Таким образом, цвет можно математически описать как соотношение базовых компонентов (создать модель цвета).

Примером составления сложного цвета на основе базовых является рисование красками. Из тюбиков выдавливаются краски базовых цветов (например, синий и желтый). После смешения их на палитре или на бумаге образуется краска смешанного (зеленого) цвета. В зависимости от соотношения базовых компонентов варьируются оттенки зеленого.

Параметры цвета могут быть выражены с помощью многих цветовых моделей, в зависимости от того, какие компоненты цвета считать базовыми. Наиболее часто для работы в графических пакетах и для передачи данных применяются цветовые модели RGB, CMYK, Lab. Иногда в процессе создания цветов используется и приблизительное описание цвета HSB.


Цветовой охват

Диапазон цветов, который может быть воспроизведен, зафиксирован или описан каким-либо способом, называется цветовым охватом. Определенный цветовой охват имеют электронно-лучевые трубки мониторов и полиграфические краски (диапазон цветов, который они могут воспроизвести), цветовые модели (диапазон цветов, который они могут описать) и, конечно, человеческий глаз (диапазон воспринимаемых им цветов). Многое из того, что воспринимает глаз, может передать монитор (на экране нельзя точно передать, например, чистый голубой и чистый желтый цвет). Часть того, что передает монитор, можно напечатать (например, при полиграфическом исполнении совсем не передаются цвета, составляющие которых имеют очень низкую плотность). Разность цветовых охватов представлена схемой на рис. 19.1. На этом рисунке показан охват человеческого глаза (соответствует модели цвета Lab), монитора, отображающего цвета в модели RGB, и офсетного станка, являющегося CMYK-устройством.

Рис. 19.1. Цветовой охват

Цвета образуются в природе по-разному. С одной стороны, источники света (солнце, лампочки, экраны компьютеров и телевизоров) излучают световые волны различной длины, воспринимаемые глазом как цветной свет. Попадая на поверхности несветящихся предметов, свет частично поглощается, а частично отражается. Отраженное излучение воспринимается глазом как окраска предметов. Таким образом, цвет объекта возникает в результате излучения или отражения. В первом и во втором случае описание цвета объекта отличается, т. е. для его описания применяются разные модели цвета.

Увидеть и определить цвет и параметры моделей можно на палитре Color (Цвет).


Модель RGB

Эта модель описывает излучаемые цвета. Модель RGB основана на трех базовых цветах — Red (Красный), Green (Зеленый), Blue (Синий). Остальные цвета образуются при смешивании этих трех основных. При сложении (смешении) двух лучей основных цветов результат светлее составляющих. Цвета этого типа-называются аддитивными (рис. 19.2).

При смешении красного и зеленого получается желтый, при смешении зеленого и синего — голубой, синий и красный дают пурпурный. Заметим, что речь идет именно о цветных лучах света, а не о привычных нам отраженных цветах. Смешение лучей обязательно даст в результате более светлый луч, чем исходные лучи (усиливается освещение). Если смешиваются все три цвета, образуется белый цвет. Смешав три базовых цвета в разных пропорциях, можно получить все многообразие оттенков. Базовые цвета иначе называются компонентами, или каналами. RGB — трехканальная цветовая модель. В модели RGB кодирует изображение сканер, отображает монитор и воспринимает человеческий глаз, поэтому можно считать ее основной моделью.

Рис. 19.2. Аддитивная цветовая модель RGB

Рис. 19.3. Модель RGB

Модель RGB можно представить себе в виде трехмерного куба, по трем осям которого откладываются значения компонентов (рис. 19.3). В начале координат все составляющие равны нулю, излучение отсутствует (черный цвет). В точке, противоположной началу координат, все составляющие имеют максимальное значение (белый цвет). На линии, соединяющей эти точки по диагонали, три составляющих одинаковы и располагаются в диапазоне от нуля до максимального значения. Они образуют серые оттенки от черного до белого — серую шкалу. Три вершины куба отображают чистые исходные цвета, остальные три — двойные смешения исходных цветов.

Количество каждого компонента RGB выражается либо в процентах (реже), либо числами от 0 до 255. Всего получается 256 оттенков каждого компонента и 256 оттенков серого.

Почему 256 оттенков?

На каждый канал изображения в памяти компьютера отводится какое-то количество бит. Для монохромного достаточно 1 бита, в этом случае максимально возможное число цветов 2 (2 1 =2). Для описания полутонового изображения отводится 8 бит. 256 — максимально возможное число значений восьмибитного канала (2 8 =256). Этого достаточно, чтобы передать оттенки серого. Каждый канал полноцветного изображения представляет собой восьмибитное полутоновое изображение; максимальное число градаций канала, таким образом, составляет те же 256.

Модель RGB аппаратно-зависима. Когда цвет в модели RGB отображается на экране монитора, значения компонентов — это, практически, напряжение, подаваемое на каждую из лучевых трубок. Результат зависит от характеристик устройства. На цвет, который вы увидите, оказывают влияние оттенки люминофора, его яркость и пр. Цвета, имеющие одни и те же характеристики, будут выглядеть по-разному на двух мониторах. При сканировании наблюдается та же ситуация — один и тот же цветной оригинал при сканировании разными сканерами дает цвета с различными характеристиками.

Примечание

Чтобы убедиться в аппаратной зависимости модели RGB, подкрутите движок яркости вашего монитора. Не правда ли, цвета изменились? А между тем, вы не меняли их характеристики!


Модель HSB

Последней из моделей, которые мы опишем в данной главе, является HSB. Это очень понятная и удобная в работе модель. Она, теоретически, описывает как аддитивные, так и субтрактивные цвета. Метод описания похож на тот, которым пользуется художник. Он берет яркую краску из банки. Чтобы сделать краску светлее, он добавит белил, для затемнения краски — сажи. Все понятно и просто. Именно поэтому модель исключительно популярна среди компьютерных художников. Базовые компоненты модели — цветовой тон (Hue), насыщенность (Saturation), яркость (Brightness).

  • Цветовой тон характеризует положение энергетического максимума излучения в спектре. Все цветовые тона часто графически изображают в виде круга. Красный цвет принят за нулевое значение, положение остальных цветов характеризуется величиной угла между данным тоном и красным и может изменяться в пределах от 0 до 360. Для чистых спектральных цветов цветовой тон (Hue) является исчерпывающей характеристикой. Однако цвет может быть осветлен (уменьшена его насыщенность) или затемнен (уменьшена яркость).
  • Насыщенность является мерой чистоты цвета. Чем ближе излучение к монохроматическому, тем выше его насыщенность. Для чистых спектральных цветов параметр Saturation имеет максимальное значение. Насыщенность может изменяться от максимума (100 или 255 градаций) до нуля. Чем меньше насыщенность, тем светлее цвет. При нулевой насыщенности чистый спектральный цвет становится белым.
  • Яркость характеризует энергию излучения. Спектральные цвета имеют максимальную яркость (100% или 255 градаций). При снижении яркости цвет становится темнее. Если параметр Brightness равен нулю, любой цвет превращается в черный. Уменьшение яркости цвета можно сравнить с добавлением к нему черной краски.

Поскольку в основе модели находится цветовой круг; в котором начало и конец совпадают, цветовое пространство HSB удобнее всего представить в виде цилиндра (рис. 19.4). Спектральные цвета расположены по верхнему радиусу. К центру круга убывает насыщенность цвета. По высоте цилиндра убывает яркость цветов. Нижняя плоскость цилиндра — черная. Каждый срез цилиндра — это спектральный круг с уменьшающейся яркостью. Серая шкала — линия, соединяющая середины верхнего и нижнего оснований цилиндра.

Рис. 19.4. Представление модели HSB

Несмотря на интуитивную ясность и удобство применения, HSB в настоящее время используется только как вспомогательная модель. Этому есть очень серьезные причины. Математически эта модель основана на компонентах модели RGB, что делает выражение цвета в модели неточным, поскольку RGB аппаратно-зависима. Кроме того, HSB неверно трактует яркость пикселов. В этой модели расчет исходит из предпосылки, что основные аддитивные цвета имеют одинаковую яркость. Таким образом, яркость оценивается по формуле

Y = R/3 + G/3 + В/3,

где каждый из компонентов вносит в суммарную яркость точки одинаковый вклад. Поскольку разные базовые цвета имеют разную воспринимаемую яркость, данная формула не отражает реального положения вещей.

Примечание

В действительности воспринимаемая яркость описывается следующей эмпирической формулой:

Y=0,2126R+0,7125G+0,0722B.

PageMaker позволяет создавать цвета в модели HLS (Hue, Lightness, Saturation), близкой родственнице более распространенной HSB. HLS присущи все те же достоинства и недостатки, что и HSB. Если вам нужен точный и предсказуемый цвет, избегайте использовать эти цветовые модели.


Модель CMYK

Несветящиеся объекты поглощают часть спектра белого света, освещающего их, и отражают оставшееся излучение. В зависимости от того, в какой области спектра происходит поглощение, объекты отражают разные цвета и представляются ими окрашенными. Цвета, которые образуются отражением части спектра белого цвета, называются субтрактивными ("вычитательными") (рис. 19.5).

Рис. 19.5. Субтрактивные цвета. Модель CMY

Рис. 19.6. Цветовая модель CMY

Для их описания используется модель CMY. В этой модели основные цвета образуются путем вычитания из белого цвета основных аддитивных цветов модели RGB. Понятно, что в таком случае и основных субтрактивных цветов будет три: голубой (белый минус красный), пурпурный (белый минус зеленый), желтый (белый минус синий). При смешениях двух субтрактивных составляющих результирующий цвет затемняется (поглощено больше света, положено больше краски). Таким образом, при смешении максимальных значений всех трех компонентов должен получиться черный цвет. При полном отсутствии краски (нулевые значения составляющих) получится белый цвет (белая бумага). Смешение трех компонентов в равных количествах даст оттенки серого. Модель CMY (рис. 19.6) можно представить себе в виде куба, аналогичного представлению RGB с перемещенным началом координат.

Данная модель используется для печати цветных изображений. Пурпурный, голубой, желтый цвета составляют так называемую, полиграфическую триаду. При печати этими красками довольно большая часть видимого цветового спектра может быть репродуцирована на бумаге. Ясно, что модель CMYK аппаратно-зависима — ведь в образовании цвета участвуют краски и бумага. В зависимости от их свойств, цвет, имеющий одни и те же характеристики, будет выглядеть по-разному.

Описание цвета с помощью CMY приводит к возникновению нескольких серьезных проблем.

Во-первых, реальные краски имеют примеси и оттенки посторонних цветов. Смешение трех основных красок в результате дает неопределенный грязно-коричневый, а не черный цвет. Кроме того, для получения интенсивного черного необходимо положить на бумагу большое количество краски каждого цвета. Это приведет к переувлажнению бумаги, причем качество печати снизится. К тому же неэкономно расходуется краска. Для улучшения качества отпечатка в число основных полиграфических красок (и в модель) внесена черная. Именно по этой причине добавлена последняя буква в название модели CMYK, хотя и не совсем обычно: С — это Cyan (Голубой), М — это Magenta (Пурпурный), Y — Yellow (Желтый). Название черного компонента сокращено до буквы К (BlacK или Key — ключевая). Число компонентов (каналов) увеличилось до четырех. CMYK — четырехканальная цветовая модель. Как и для модели RGB, количество компонента может быть выражено в градациях от 0 до 255 или, реже, в процентах. Иллюстрации, содержащие большое количество цветов, печатаются четырьмя красками базовых цветов модели CMYK. Цвета, печатаемые таким способом, называются триадными.

Другая проблема заключается в узости цветового охвата CMYK. При печати этим способом невозможно адекватно передать оттенки яркого синего, оранжевого, зеленого цветов. Если изображение содержит описанные цвета, часто используют другие цветовые модели, с большим числом компонентов, например модель Hexachrome, в которую, кроме описанной триады и черного, входят зеленый и оранжевый цвета. Цветовой охват при печати в шесть красок значительно шире.


Плашечные цвета

Для передачи особых цветов (пастельные тона, бронза, серебро, светящиеся краски) используется плашечная печать — кроме базовых четырех красок, накладывается пятая (шестая, седьмая и т. д.). Оттенок этой краски подобран заранее, и она накладывается там, где встречается в публикации. Плашечные цвета обеспечивают довольно высокую точность воспроизведения, поэтому используются и тогда, когда нужно получить очень точный цвет (например, в логотипе компании). Плашечные цвета иначе называют простыми. Плашечные цвета широко используются и для печати публикаций, содержащих небольшое количество (до четырех, включая черный) отдельных цветов (визитки, бланки, прайс-листы, газеты и пр.). Это делается из соображений экономии.

С точки зрения печатника, различие между шашечными и триадными цветами очень существенно. Краски для плашечных цветов поставляются уже смешанными (в отдельных банках), а триадные цвета получаются смешением красок на листе отпечатка. Соответственно, и в компьютерных издательских системах краски для плашечных цветов выбираются из каталога, а триадные задаются пропорцией базовых компонентов. С помощью триадных красок можно передать любые цвета, а с помощью плашечных — только оттенки их собственного цвета. С другой стороны, плашечные цвета обеспечивают довольно высокую точность воспроизведения, поэтому используются и тогда, когда нужно получить очень точный цвет. Плашечные цвета иначе называют простыми.


Lab — аппаратно-независимая модель

В процессе подготовки изображения приходится конвертировать изображение из одной модели в другую (сканер — RGB-устройство; печатный станок работает с моделью CMYK). Чтобы уменьшить потери до приемлемого уровня, необходимо откалибровать все аппаратные средства: сканер (осуществляет ввод изображения), монитор (по нему судят о цвете), выводное устройство (создает оригиналы для печати), печатный станок (конечная стадия печати). Модели RGB и CMYK связаны друг с другом, однако их взаимные переходы друг в друга (конвертирование) не происходят без потерь, поскольку две эти модели имеют разный цветовой охват. Калибровка лишь несколько сглаживает проблему. Кроме того, RGB и CMYK аппаратно-зависимы. Если речь идет о RGB, то в зависимости от примененного в вашем мониторе люминофора будут различаться базовые цвета. Точка белого также зависит от устройства монитора. В результате на разных мониторах одно и то же изображение выглядит по-разному. Если обратиться к CMYK, то здесь различие еще более ощутимо, поскольку речь идет о реальных типографских красках, особенностях как самого печатного процесса, так и носителя.

Из этого можно сделать неутешительный вывод: оригинал, сканированное изображение и отпечаток могут очень сильно различаться между собой. Мало того, цвет двух отпечатков одного и того же изображения, полученных на разных принтерах, может быть совершенно разным.

Одной из основных задач при работе с цветными изображениями становится достижение предсказуемого цвета. Для этого создана система управления цветом (CMS). Это программная система, цель которой — адекватная цветопередача на всех этапах полиграфического процесса, от сканера до печатного станка. Заметим, что в полиграфический процесс входят системы, работающие на основе аппаратно-зависимых цветовых моделей — RGB (сканер, монитор) и CMYK (фотонаборная и печатная машины). Это значит, что необходим некий стандарт, к которому бы приводились цвета на всех этапах процесса.

В качестве стандарта используется цветовая модель Lab. Она была создана как аппаратно-независимая и соответствующая особенностям восприятия цвета глазом человека. Любой цвет данной модели определяется яркостью (L) и двумя хроматическими компонентами: параметром а, который изменяется в диапазоне от зеленого до красного, и параметром b, изменяющимся в диапазоне от синего до желтого (рис. 19.7). При изменении оба хроматических компонента проходят через серую точку, расположенную в середине шкалы. Параметры Lab изменяются от 0 до 255. Это также трехканальная модель.

Рис. 19.7. Модель Lab

Яркость в модели Lab полностью отделена от цвета. Это делает модель удобной для регулирования контраста, резкости и других тоновых характеристик изображения. Она является трехканальной. Цветовой охват модели Lab чрезвычайно широк. Он включает в себя охваты всех других цветовых моделей, используемых в полиграфическом процессе.

Суть процесса управления цветом заключается в следующем: для каждого устройства, участвующего в процессе, создается профиль, описывающий его цветовой охват. Изображение обрабатывается устройством ввода (сканером) и переводится в цветовую модель Lab. При этом программа делает поправку на особенности цветового охвата сканера (учитывает его профиль). Таким образом, получаются стандартные цвета изображения. Затем изображение передается устройству вывода (монитору или принтеру). При выводе оно снова переводится в цветовую модель устройства вывода таким образом, чтобы с учетом профиля устройства получить результат, как можно более близкий к идеальному, хранящемуся в Lab.

Цветовая модель Lab очень важна для полиграфии. Именно она используется при переводе изображений из одной цветовой модели в другую, между устройствами и даже между различными платформами. Можно сказать, что Lab является переводчиком, без которого взаимопонимание систем, участвующих в процессе подготовки цветной публикации, невозможно.


Палитра цветов в PageMaker

Основным инструментом работы с цветами в PageMaker является палитра цветов. Это стандартная палитра PageMaker. Цвета определяются путем их добавления в палитру, имеющимися на палитре цветами можно пользоваться для оформления графических объектов и текста на страницах публикации. В палитре производится определение, редактирование и удаление цветов, а также их назначение объектам. На рис. 19.8 представлена палитра цветов с основными элементами (а) и меню палитры (б). Кнопки в верхней части палитры управляют присвоением цвета обводке объекта, его заливке или одновременно и заливке, и обводке. Для изменения режима присвоения цвета достаточно нажать соответствующую кнопку. Рядом находится раскрывающийся список Tint (Оттенок). Любому из окрашенных объектов можно придать заливку или обводку оттенком цвета от 100 до 0%. При этом оттенок цвета не нужно определять как отдельный цвет. Если же оттенок цвета применяется часто, можно также определить его отдельной строкой. Все определенные цвета публикации перечислены в строках палитры. Рядом с названием цвета представлен его образец (приблизительный, разумеется). Справа от названия цвета находятся пиктограммы с обозначением статуса цвета — цветовая модель, по которой определен цвет (RGB, CMYK, HLS) и тип цвета — простой (плашечный), составной или оттенок цвета. На рис. 19.8, а расшифрованы значения пиктограмм. Пиктограммы отображаются лишь в том случае, если в меню палитры активизированы режимы отображения пиктограмм (два нижних пункта меню). На рис. 19.8, б эти режимы активизированы — напротив каждого из них стоит галочка. В нижней части палитры расположена строка статуса выбранного цвета и две стандартные пиктограммы образования нового цвета и удаления существующего.

а

б

Рис. 19.8. Определение цвета проводится в палитре цветов

Цвета [None] ([Безщвета]), [Paper] ([Бумага]), [Registration] ([Совмещение]) и [Black] ([Черный]) всегда находятся на палитре цветов. Они означают следующее:

  • [None] ([Без цвета]) — устранение ранее назначенного цвета PageMaker и возврат объекта в его исходное состояние.
  • [Paper] ([Бумага]) означает отсутствие какой-либо краски или выворотку (knockout). Объект является как бы "иллюминатором" в цветовом слое и сквозь него виден цвет бумаги.
  • [Registration] ([Совмещение]) применяется для печати технологических пометок и маркеров обрезки. Любой объект, которому назначен этот цвет, печатается на всех фотоформах. Для достижения такого эффекта данный цвет определяется как 100% всех триадных цветов и как плашеч-ный цвет. Редактировать этот цвет нельзя, однако можно задавать его оттенок для данного объекта в соответствующем раскрывающемся списке.
  • [Black] ([Черный]) также нельзя редактировать. Для черных объектов можно задавать оттенки, как и для любых других цветов. Цвет [Black] печатается исключительно черной краской.

Примечание

Самый быстрый способ создания нового цвета на базе определенного в публикации состоит в щелчке мышью на обозначении данного цвета в палитре при нажатой клавише <Ctrl>. Это действие открывает диалоговое окно Color Options (Параметры цвета) для нового цвета, при этом предлагаемые параметры тождественны исходному цвету. Это сокращение работает для любых цретов, в т. ч. базовых.

Примечание

Если необходимо разместить на фотоформах или деленных полосах публикации какие-либо замечания, оформляйте их цветом [Registration] ([Совмещение]). Создайте и разместите текстовый блок таким образом, чтобы он частично перекрывал страницу публикации, но не позволяйте размещенному на нем тексту попасть на страницу. Такой прием заставляет PageMaker рассматривать текст как элемент публикации, а не как объект, расположенный на монтажном столе. Если текст будет оформлен цветом [Registration] ([Совмещение]), он отпечатается на всех фотоформах. Для того чтобы текст примечания не выходил за размеры листа бумаги, его можно развернуть вдоль длинной стороны этого листа.

Кроме того, по умолчанию в палитре PageMaker расположены еще четыре базовых цвета CMYK. Обычно они не используются в работе, и перед началом работы их стирают, создавая новое глобальное умолчание.

Операции определения и редактирования цвета выполняются в диалоговом окне Color Options (Параметры цвета) (рис. 19.9).

Рис. 19.9. Основное средство определения цветов в PageMaker — диалоговое окно Color Options

Для добавления цвета в публикацию PageMaker выполните одно из следующих действий:

  • Щелкните мышью на пиктограмме "чистый лист" внизу палитры. Откроется диалоговое окно Color Options (Параметры цвета) с пустой строкой имени. Исходный цвет будет белый, исходная модель — RGB.
  • Щелкните мышью на имени любого цвета публикации, при этом удерживая клавишу <Ctrl>, или откройте меню палитры и выберите пункт New Color (Новый цвет). Открывшееся окно Color Options (Параметры цвета) будет иметь пустую строку имени. Параметры создаваемого цвета будут аналогичны параметрам исходного цвета, т. е. ранее выбранного в палитре.
  • Щелкните мышью на любом из определенных в публикации цветов и перетащите строку с выбранным цветом к пиктограмме "чистый лист" внизу палитры. Это приведет к открытию диалогового окна Color Options (Параметры цвета), в строке имени цвета которого будет стоять сочетание "<имя исходного цвета> копия". Цвет будет строиться исходя из того цвета, на котором был выполнен щелчок, т. е. будет иметь те же тип и цветовую модель.
  • Откройте меню палитры и выберите пункт New Color (Новый цвет). Окно Color Options (Параметры цвета) будет иметь пустую строку имени и исходный цвет, соответствующий ранее выбранному цвету в палитре.

Для редактирования существующего цвета можно дважды щелкнуть на имени цвета в палитре или выделить необходимый цвет ц, открыв меню палитры, выбрать пункт Color Options (Параметры цвета). Ив том и в другом случае откроется бкно Color Options (Параметры цвета), в котором вы сможете отредактировать выбранный цвет. Как уже было отмечено ранее, базовые цвета (их имена заключены в квадратные скобки) не редактируются.


Работа в окне Color Options

В поле имени цвета Name (Имя) вы можете изменить или назначить цвету любое имя. В случае выбора цвета из библиотеки в поле имени проставляется стандартное имя для выбранного цвета. Его также можно менять. При выборе цвета по образцу из библиотеки системы цветов имя цвета автоматически переносится в соответствующие поля диалоговых окон Color Options (Параметры цвета) или Define Colors (Определить цвета). При выпуске промежуточных технологических носителей это имя вместе с другими типографскими метками будет напечатано на фотоформе или деленной полосе. Если вы выбрали цвет из системы подбора цвета (PANTONE, TOYO. TRUMATCH или иной), не меняйте его имени во избежание ошибок. При выборе имени для цвета можно указать его назначение, например "Гербалайф зеленый".

Каждому цвету можно задать один из трех типов — простой (плашечный). составной (триадный) и оттенок в раскрывающемся списке Туре (Тип). Задание оттенка как отдельного цвета удобно, если данный оттенок часто употребляется в публикации.


Плашечный цвет

Использование плашечного цвета означает, что для всех объектов этого цвета должна будет изготавливаться отдельная печатная форма. Короче говоря. при выборе плашечного цвета вы не определяете сам цвет, а лишь изолируете раскрашенные им объекты на отдельной печатной форме, на которую в типографии будет нанесена заранее приготовленная краска стандартного цвета. Выбирайте плашечный цвет тогда, когда вы и ваша типография работаете с одной из систем плашечных цветов.


Триадный цвет

Выбор триадного цвета означает, что впоследствии придется выполнять процедуру цветоделения CMYK. Если вы знаете, что печать будет выполняться с применением триадных цветов, без заранее смешанных красок, щелкните мышью на элементе списка, соответствующем триадному цвету.

Время от времени возникает проблема преобразования плашечных цветов в составные. Провести это преобразование в PageMaker очень легко, однако оно не всегда приводит к нужному результату. Некоторые плашечные цвета вообще нельзя воспроизвести триадными красками. Просмотрите справочник, в котором указано соотношение триадных красок для воспроизведения плашечных цветов (например, PANTONE PROCESS). При подобном преобразовании старайтесь не ориентироваться по изображению на мониторе.

Превратить плашечный цвет в составной можно несколькими способами. Во-первых, изменив тип данного плашечного цвета на составной. Во-вторых, выбрав соответствующий цвет из библиотеки составных цветов, например PANTONE PROCESS, или PANTONE ProSim. В обоих случаях происходит реальное превращение цвета в публикации. Это становится очевидным при взгляде на палитру. Превращенный цвет имеет соответствующую пиктограмму составного цвета. Третий способ перевода плашечных цветов в составные состоит во включении режима All to process (Все триадными) в диалоговом окне Print Colors (Печать: Цвета) непосредственно перед печатью цветоделенных оттисков. При этом реального превращения цветов в публикации не происходит. Цветоделение производится программными средствами принтера. Третий способ является, таким образом, обратимым. Режим печати триадными красками плашечных цветов можно в любой момент отменить.


Оттенки цветов

Программа PageMaker позволяет назначать объектам оттенки базовых цветов без предварительного их определения, но если оттенок используется интенсивно, удобно задать его как отдельный цвет.

Оттенок определяется следующим образом. Во-первых, необходимо выбрать ранее определенный базовый цвет. Выделите его название в палитре цветов и откройте диалоговое окно для определения нового цвета. При выбранном типе цвета Tint (Оттенок) диалоговое окно Color Options (Параметры цвета) принимает вид, представленный на рис. 19.10. Процент оттенка устанавливается при помощи ползунка или вводом значения в соответствующее поле с клавиатуры. Поле просмотра делится пополам и в верхней половине отображается цвет, соответствующий сделанным установкам. По окончании редактирования щелкните мышью на кнопке ОК, и цвет появится на палитре цветов, причем перед его названием будет вставлен знак процента, говорящий о том, что это — оттенок другого цвета.

Большинство полиграфических машин не могут воспроизводить оттенки цветов с той точностью, с которой их можно задать в программе PageMaker. Обычно оттенки воспроизводятся с шагом в 5%, но это значение имеет смысл уточнить в типографии.

При именовании оттенков рекомендуется вводить в имя название базового цвета и процент оттенка. Это позволяет с одного взгляда на палитру цветов определить и базовый цвет, и то, насколько данный оттенок светлее его. Такой способ именования помогает также устранять последствия удаления того или иного цвета — дело в том, что при удалении базового цвета его оттенки превращаются в черный цвет. Оттенок можно определить только после того, как определен базовый цвет. Если цвету задан тип Tint (Оттенок), то при изменении базового цвета (процент которого задается) соответственно меняется и заданный оттенок. Цветовая модель и способ печати (плашечный или триадный) оттенка цвета аналогичны базовому цвету. Более подробно оттенки рассматриваются в гл. 20.

Рис. 19.10. Диалоговое окно Color Options в процессе определения оттенка цвета

Список Model (Модель) определяет цветовую модель, описывающую данный цвет — RGB, CMYK, HSB. Ее также можно свободно менять. Однако из-за разного представления цветов в различных системах при смене модели возможны нарушения цветовоспроизведения. Некоторую компенсацию дает использование системы управления цветом Kodak Color Management System (CMS). О проблемах перехода от одной цветовой модели к другой и системе управления цветом см. гл. 21.

Флажок Overprint (Наложение) регулирует способ печати данного цвета относительно других. Если задан режим наложения (флажок установлен), объекты данного цвета печатаются с наложением. Если флажок снят, объекты, окрашенные в данный цвет, маскируют объекты других цветов. Разница между режимами наложения и маскирования показана на схеме рис. 19.11.

Выворотная печать — это режим печати элементов макета, при котором на общую область перекрывания нескольких объектов наносится только краска, соответствующая объекту, расположенному выше остальных. Выворотка предотвращает смешивание красок непосредственно на странице.

В случае наложения все объекты печатаются друг поверх друга, что может привести к нежелательному появлению третьего цвета. Выворотка предотвращает появление третьего цвета, однако при плохой приводке цветов в публикации могут появиться нитевидные просветы, что приводит к полиграфическому браку. Для решения проблем наложения и приводки цветов существует прием треппинга, или цветовых ловушек (см. гл. 21).

а

б

Рис. 19.11. Наложение объектов при печати (а) и выворотка (б)

В центре окна находится группа ползунковых переключателей, с помощью которых вы можете плавно менять соотношение компонентов в данном цвете. Каждый ползунок относится к одному из компонентов цвета. Соответственно, названия и назначения их различны для разных цветовых моделей. Для CMYK это компоненты Cyan (Голубой), Magenta (Пурпурный), Yellow (Желтый), Black (Черный). Для модели HSB — Hue (Цвет), Saturation (По насыщенности), Brightness (Яркость). При помощи ползунков вы можете определить бесконечно много цветов, наблюдая, как они изменяются по мере перемещения ползунка в поле предварительного просмотра цвета, расположенном в правом нижнем углу диалогового окна (не забывайте, что на мониторе демонстрируется приблизительный цвет). Цвет в верхней части поля просмотра изменяется синхронно с перемещением ползунков, а в нижней части поля сохраняется образец исходного текста. Это дает возможность сравнивать результат редактирования цвета с его исходным видом.

В комплект поставки программы PageMaker входит несколько библиотек стандартных цветов, в том числе — полная библиотека системы PANTONE. Выбирая цвет из библиотеки с использованием фирменного каталога цветов, вы можете быть уверены в точности цвета. Если вы определяете цвет сами, нет гарантий, что монитор отобразит его корректно, т. е. что цвет на печати будет именно таким, как на мониторе. На рис. 19.12 представлен раскрывающийся список библиотек Libraries (Библиотека), доступных при работе с программой PageMaker.

Рис. 19.12. Выбор библиотек цветов

Примечание

При выборе библиотеки обратите внимание на систему цвета, по которой она составлена, и тип цветов библиотеки. И та и другая характеристика должна соответствовать применению цвета в публикации. Если публикация будет напечатана на бумаге, пользуйтесь библиотеками CMYK-цветов. При подготовке безбумажных публикаций можно взять цвета модели RGB. Тип цвета, взятого из библиотеки, менять нежелательно, поскольку это может привести к погрешностям цветопередачи. Кроме того, у вас обязательно должен быть каталог цветов выбранной библиотеки, а типография обязательно должна работать с такими цветами (это особенно касается плашечных цветов).

После того как был сделан выбор библиотеки, появится окно с цветовыми образцами и линейкой прокрутки, представленное на рис. 19.13. Для того чтобы выбрать образец цвета для переноса на палитру цветов программы PageMaker, достаточно щелкнуть мышью на нем, а затем — на кнопке ОК. На экране будет отображено диалоговое окно Color Picker (Параметры цвета) с управляющими элементами, установленными в соответствии с выбранным образцом. Окончательно цвет переносится на палитру после щелчка мышью на кнопке ОК в данном диалоговом окне. После этого цветом можно пользоваться, назначая его объектам и тексту.

Рис. 19.13. Один из множества списков с образцами цветов

После выбора одного образца цвета можно не закрывать диалоговое окно библиотеки. За один прием можно выбрать для переноса на палитру цветов PageMaker сразу несколько образцов. Для этого достаточно при щелчке мышью на втором и последующих образцах удерживать нажатой клавишу <Ctrl>. Если вместо щелчка мышью на образце цвета при нажатой клавише <Ctrl> протащить указатель мыши по нескольким образцам, все они будут выбраны для переноса на палитру цветов.

Примечание

Для выбора стандартного цвета из библиотеки можно пользоваться автоматическим способом подбора цвета по образцу. Установите ползунки таким образом, чтобы цвет в поле просмотра приблизительно соответствовал желаемому, раскройте список Libraries (Библиотека) и выберите в нем название системы цветов. Программа PageMaker постарается вывести на экран образцы стандартных цветов, наиболее близкие к заданному в окне просмотра.

Примечание

Задавайте цветам стандартные имена. Если вам нужно задать цвет из каталога, которого нет в PageMaker, определите цвет вручную, а затем при определении имени нового цвета в программе PageMaker впечатайте в поле имени номер нужного цвета из каталога вашей системы цветов. На фотоформе, соответствующей данному цвету, будет напечатано имя нужной краски (для печати меток установите флажок Markings (Типографские метки) в окне Print Paper (Печатать: Бумага), вложенном в диалоговое окно Print Document (Печатать: Документ). Типографская метка на фотоформе и печатной форме поможет избежать ошибки при заливке красок в печатную машину.

Тот же прием можно посоветовать, если плашечный цвет на экране не соответствует цвету в каталоге. Отредактируйте его, но не меняйте его имя. Отображение цвета на экране монитора не оказывает никакого влияния на внешний вид плашечного цвета на отпечатке, поскольку он образуется стандартной краской. Для корректировки и цветопередачи в PageMaker существует система управления цветом Kodak CMS.

Диалоговое окно, открываемое кнопкой CMS Source (Источник CMS), определяет источник изображения, т. е. цветовое пространство, в котором оно создано или отредактировано. Система управления цветом (CMS) и, в частности, названное диалоговое окно будут подробно рассмотрены в следующей главе. Система управления цветом позволяет добиться более полного соответствия цветопередачи для всех устройств вывода, настраивая систему отображения отдельно для каждого цвета и изображения в публикации, в зависимости от типа выводного устройства и источника изображения.

Примечание

Для того чтобы добиться наилучших результатов, систему управления цветом следует выбирать при создании публикации. Это можно сделать и из окна редактирования цветов, щелкнув мышью на кнопке CMS Source (Источник CMS), но лучше выбрать систему управления цветом в окне Preferences (Установки) при создании публикации — это обеспечит единообразие преобразований и определений цветов. В некоторых ситуациях могут потребоваться иные установки (например, при использовании TIFF-файлов, построенных другим скане ром), и в этом случае выполняются дополнительные настройки, но все цвета программы PageMaker должны определяться при одной и той же настройке монитора.


Определение цветов в диалоговом окне

Доступ ко всем функциям определения и редактирования цветов можно осуществлять и из специального диалогового окна PageMaker. Это окно Define Colors (Определить цвета), открываемое соответствующей командой меню Utilities (Сервис). Названное диалоговое окно изображено на рис. 19.14 и по структуре напоминает окно Define Styles (Определить стили). В левой его части находится список цветов публикации, в правой — кнопки, дающие доступ к диалоговым окнам работы с цветами, описанными выше. В диалоговом окне Define Colors (Определить цвета) удобнее, чем в палитре, выполнять организацию цветовой гаммы публикации — удалять лишние цвета, проводить переименование и слияние цветов. Механизм всех этих операций аналогичен работе со стилями в диалоговом окне Define Styles (Определить стили).

Рис.19.14. Работу по организации цветов удобно проводить в диалоговом окне Colors Option


Обеспечение единообразия определения цветов

В публикации каждый цвет должен быть определен только один раз. Иногда встречаются ситуации, когда один и тот же цвет (скажем, темно-зеленый) определен несколько раз. При этом вы считаете все темно-зеленые объекты имеющими один и тот же цвет и хотите, чтобы они выглядели одинаково, а в случае плашечной печати — располагались на одной форме. Избыточное определение цветов может происходить по двум причинам — либо импортированные в публикацию объекты уже содержали в себе определения цветов, либо над различными частями публикации работали разные люди, каждый из которых определял цвета по-своему. Первое случается особенно часто. Вот способы борьбы с избыточными цветами публикации.


Слияние цветов

В программе PageMaker удаление цвета с палитры цветов можно совместить с последовательным замещением удаленного цвета другим цветом. Идея та же, что и с заменой или слиянием стилей форматирования абзацев, правда, реализуется она несколько иным способом. В диалоговом окне Define Colors (Определить цвета) определите доминирующий цвет, остающийся после операции слияния. Затем выберите заменяемый цвет и щелкните мышью на кнопке Edit (Редактировать). В поле имени открывшегося диалогового окна введите имя доминирующего цвета, убедившись в правильном его написании. Щелкните мышью на кнопке ОК. На экране появится предупреждение с запросом подтверждения на замену цвета. Щелчок мышью на кнопке ОК в этом окне завершает операцию слияния цветов.


Удаление цветов

Удаление цвета с палитры цветов — еще более простая операция. Выделите цвет и щелкните мышью на кнопке с изображением мусорной корзины (или перетащите к ней удаляемый цвет). Если удаляемый цвет используется в публикации (пусть даже только как базовый для оттенков), PageMaker выдаст предупреждение о том, что все вхождения этого цвета (и построенных на его основе оттенков) будут преобразованы в черный цвет.

Неиспользуемые в публикации цвета лучше удалить автоматически. Как правило, такие цвета возникают на палитре цветов при применении в публикации графических объектов в формате EPS, импортированных из различных источников. Кроме того, что эти цвета загромождают палитру цветов (с чем можно было бы примириться), при цветоделении каждый из них породит свою деленную полосу (что неприемлемо). Для удаления неиспользуемых цветов выберите пункт Remove Unused Colors (Удалить неиспользованные цвета) меню палитры. Если не используется более одного цвета, программа PageMaker спросит вас, удалить их все сразу или по одному, с запросом подтверждения. После удаления выдается информационное окно, в котором указано количество удаленных цветов и красок (компонентов триадных цветов).


Импорт цветов из другой публикации

Копирование палитры цветов другой публикации выполняется примерно так же, как копирование списка стилей и может быть использовано для стандартизации палитры публикации. Для этого достаточно открыть диалоговое окно Define Colors (Определить цвета) и щелкнуть мышью на кнопке Import (Копировать) либо выбрать пункт меню палитры цветов Import Colors (Импортировать цвета). На экране откроется стандартное диалоговое окно открытия файла, в котором следует выделить публикацию, цветовую палитру которой необходимо скопировать в текущую публикацию. Затем щелкните мышью на кнопке Open (Открыть). Копируется только весь каталог цветов, скопировать один цвет нельзя.

Примечание

Объекты программы PageMaker, перенесенные в публикацию с помощью системного буфера, приносят с собой свои цвета. Это может использоваться для копирования одного цвета из другой публикации. Назначьте нужный вам цвет какому-нибудь наскоро построенному прямоугольнику, а затем вырежьте его в системный буфер. После вклеивания объекта в публикацию и появления цвета на палитре цветов объект-контейнер можно удалить. Здесь прослеживается полная аналогия с приемом копирования стиля.


Цвета импортированных объектов

Не только объекты PageMaker, но и импортируемые объекты в формате EPS, генерированные различными графическими процессорами, появляются в публикации в сопровождении определенных им цветов. При импорте файла можно управлять режимом импорта цветов с помощью установки соответствующей настройки фильтра. На рис. 19.15 представлено диалоговое окно импорта графического файла EPS, генерированного программой Adobe Illustrator. Режим импорта цветов можно задавать с помощью переключателей. Предлагается два варианта — импорт именованных простых цветов с добавлением их в палитру (при этом они остаются простыми) или перевод их в составные цвета.

Единообразие цветов, применяемых в графическом приложении и программе PageMaker, достигается именно импортом простых цветов в палитру. После импорта цвета появляются в палитре цветов с тем же именем, что и в приложении, рядом с именем цвета ставится пиктограмма PS, говорящая о том, что цвет является импортированным с PostScript-файлами. Импортированными цветами можно пользоваться так же, как и обычными, назначая их объектам. Если вы откроете окно редактирования плашечного импортированного цвета, в нем будут закрыты поле имени и список библиотеки. Вы можете редактировать плашечный цвет вручную, однако, как уже было сказано, это не повлияет на выводимые формы. В случае же композитного вывода, как это ни парадоксально, плашечный цвет изменится в соответствии с результатами редактирования цвета в публикации (PageMaker вносит изменения в файл изображения!!!). Импортированный простой цвет можно перевести в составной и обратно, и данное изменение затронет не только объекты PageMaker, окрашенные в этот цвет, но и импортированную графику.

Рис. 19.15. Диалоговое окно фильтра импортирования графических изображений в формате EPS

В случае импортированного составного цвета в диалоговом окне Color Options (Параметры цвета) закрыты имя цвета, библиотека и тип цвета, т. е. изменить способ его печати на простой нельзя. При редактировании составного цвета изменяется и его отображение при выводе форм. После импортирования цветов обязательно проведите "чистку" палитры — именно в результате импортирования в публикации появляются неиспользуемые цвета. О редактировании и назначении импортированных цветов подробно рассказывается в гл. 20.


Создание личных библиотек

Если вы хотите создать собственную библиотеку цветов на основе палитры цветов публикации, чтобы в дальнейшем использовать ее в других публикациях, это легко сделать с помощью дополнения Create Color Library (Создать библиотеку цветов). Для создания библиотеки цветов определите необходимые цвета в палитре. С этой целью вы можете использовать цвета из любых существующих библиотек, создавать новые цвета или копировать их из других публикаций (оттенки не могут храниться в библиотеке). Выберите из меню Utilities (Сервис) команду Plug-ins (Дополнения) и далее выберите в раскрывшемся меню команду Create Color Library (Создать библиотеку цветов). Диалоговое окно этого дополнения представлено на рис. 19.16.

В открывшемся диалоговом окне введите имя новой библиотеки, которое будет отражаться в ециске библиотек цветов окна Color Options (Параметры цвета). Имя файла, в котором будет храниться библиотека, также можно задать произвольно. Оно может не совпадать с именем самой библиотеки. В соответствующих полях ввода задайте число строк и столбцов библиотеки (эти значения не должны превышать 10). В поле Notes (Замечания) можно ввести необходимый комментарий, который будет находиться в информационном окне, открывающемся нажатием кнопки About (Инфо) диалогового окна библиотеки цветов. Все цветовые файлы должны располагаться в папке Color, вложенной в языковую папку. Чтобы сохранить библиотеку в файле с умалчиваемым именем CUSTOM.BCF (binary Color file), нажмите кнопку Save (Сохранить). Файл по умолчанию вносится в нужную папку. Чтобы сохранить библиотеку под другим именем или в другой папке, нажмите кнопку Browse (Обзор) и выберите нужные имя и папку.

Рис. 19.16. Диалоговое окно Import color

Примечание

Если вы работаете с несколькими заказчиками, каждый из которых имеет собственные цветовые предпочтения, можно организовать работу и без применения библиотек. Создайте шаблоны публикаций для каждого из проектов и организуйте в шаблоне нужный набор цветов. Если же вы постоянно работаете с одними и теми же цветами, то имеет смысл создать их набор в виде задания значений по умолчанию для палитры (см. гл. 3).


Резюме

Вы познакомились с основными принципами организации цветных публикаций. В следующей главе описываются приемы использования цвета в публикации, в том числе работа с импортированными цветными объектами.

Для того чтобы избежать неожиданностей, необходимо настроить все цветные элементы макета на конкретное оборудование — от сканера или камеры, с помощью которых получают изображение, до монитора и фотовывода, на которых его отображают. О системе управления цветом в PageMaker рассказывается в следующей главе. На этапах подготовки цветной публикации вы столкнетесь со множеством трудностей. Разрешению некоторых сложных вопросов также уделено внимание в гл. 20. Если же ваш документ уже готов к печати, в гл. 23 вы получите ответ на вопросы, связанные с окончательной подготовкой файла к печати в сервис-бюро и типографии.


  • Глава 2. Обзор процесса подготовки публикации
    • Планирование
      • Определение круга читателей публикации
      • Бюджет издания
      • Концепция издания
      • Утверждение плана издания
      • Выбор типографии и сервис-бюро
    • Верстка
      • Подготовка компонентов публикации
      • Определение структуры публикации
      • Компоновка текста и графики
      • Доводка, специальные эффекты, цветовое оформление
      • Создание оглавления и предметного указателя
      • Вывод подписной корректуры
    • Предпечатная подготовка
      • Высококачественное сканирование
      • Треппинг
      • Цветоделение
      • Цветопробы
      • Вывод пленок на фотонаборном автомате
    • Печать в типографии
      • Спуск полос
      • Пробные отпечатки
      • Печать тиража
    • Резюме


ГЛАВА 2.

Обзор процесса подготовки публикации

Любая публикация (книга, буклет, рекламная листовка и т. п.) проходит путь от первоначальной идеи до отпечатанного тиража. В этой главе мы кратко остановимся на каждом из этапов подготовки публикации:

  • Планирование публикации
  • Выбор партнеров — типографии и сервис-бюро
  • Выработка концепции публикации
  • Предпечатная подготовка
  • Печать в типографии

Небольшой объем этой главы может создать впечатление исключительной простоты всей цепочки. Действительно, будучи даже слегка знакомым с издательской системой можно сделать макет. На вас лежит только первый этап подготовки издания, а остальное, как правило, делается сторонними подрядчиками, которые являются профессионалами. Однако вы делаете самое главное — вы создаете то, ради чего затеян весь издательский процесс. Для успешного выпуска книги требуется, во-первых, сделать все от вас зависящее, чтобы макет был подготовлен профессионально. Но этого мало: необходимо правильно организовать работу на каждом этапе подготовки книги, от идеи до тиража. Итак, что же это за этапы?


Планирование

Верстка при помощи издательской системы является отнюдь не первым шагом при подготовке публикации. Началом этого многоэтапного процесса можно считать возникновение собственно идеи создания книги. Далее планируются бюджет и сроки, выбираются партнеры (художник, наборщик, сервис-бюро, типография), вырабатывается концепция издания. Именно на первом этапе закладываются успешность дальнейшей работы и прибыль, получаемая вами от издания.


Определение круга читателей публикации

Любое печатное издание служит для распространения информации и создается для того, чтобы его прочитали. Попробуйте с этим поспорить! Очень важно определить, кто именно будет читать ваше произведение, сколько таких людей и что это за люди. От того, кому адресовано издание, зависят и его тираж, и исполнение, и художественная концепция. Рекламный буклет нового стирального порошка будет иметь иной вид и тираж, чем томик стихов малоизвестного поэта или реклама фестиваля авангардной музыки.

Однако даже в случае рекламы стирального порошка необходимо уточнить — что именно будет рекламироваться: имидж производителя продукции, выдающиеся свойства продукта, доступность товара для мелкооптовых покупателей и пр. В каждом из этих случаев вы, наверняка, примете разные решения о содержании и внешнем виде будущего буклета. Если над созданием публикации вы работаете в группе, то необходимо добиться полного согласия с постановкой задачи между всеми участниками проекта.


Бюджет издания

Оценив важность проекта согласно информации, полученной на предыдущем этапе планирования, вы или ваш начальник должны определить, какие человеческие и технические ресурсы можно привлечь для реализации проекта. Чудес не бывает, проект должен приносить прибыль. Если ваша мечта — заняться изданием собрания сочинений в двадцати томах и вы предполагаете, что прибыль едва покроет расходы, вам необходимо подумать о поиске выгодного параллельного проекта.

Часто обеспечить прибыльность проекта можно только при соблюдении строгих временных рамок, определяемых самой идеей проекта (не стоит затягивать выпуск рождественских открыток до февраля) или заказчиком (ради вас не перенесут сроки выставки своей продукции). Определите, реальны ли поставленные условия по срокам реализации и не потребуют ли они излишней занятости сотрудников в ущерб другим, не менее важным проектам.

Если бюджет издания, определенный заказчиком, нереален или требует слишком больших затрат ресурсов, следует склонить заказчика либо к его увеличению, либо к снижению самих затрат. Затраты могут быть снижены за счет уменьшения объема издания, уменьшения количества цветных листов, выбора бумаги и типографии и т. п. Если заказчика не удается склонить к этим шагам, то браться за издание просто не стоит.


Концепция издания

Как мы уже говорили, творческая реализация зависит от идеи, целей и предполагаемой читательской аудитории планируемой публикации. Если в этих вопросах у вас имеется абсолютная ясность, то не составит труда найти ответы и на вопросы, касающиеся художественной концепции издания:

  • Какие материалы публикации будут зрительным центром?
  • Как выдержать единый стиль оформления публикации? Что будет связующей нитью графических и текстовых материалов?
  • Какой тип материалов, текстовый или графический, будет играть главную роль в публикации?
  • Соответствуют ли предлагаемые материалы целям публикации?
  • Нет ли у освещаемой темы какого-то броского графического выражения?

Отвечая на эти вопросы, вы, скорее всего, наткнетесь на интересную творческую идею, которую захочется немедленно воплотить. Подождите. Попробуйте взглянуть на свои идеи с другой стороны (лучше всего со стороны читателя), обсудите их с другими участниками проекта. Попробуйте найти альтернативные реализации этой творческой задачи — может быть, первое решение не самое удачное из возможных.


Утверждение плана издания

Теперь необходимо убедиться, что ваша работа понравится предполагаемым читателям. Для этого сделайте эскизный набросок публикации и покажите его нескольким людям, которые могут стать потенциальными читателями вашего издания. Соберите их мнения и внесите соответствующие коррективы в эскиз.

Далее следует очень важная процедура предварительного утверждения. Утверждающим лицом может быть ваш начальник или сам заказчик. Вам необходимо добиться подписи утверждающего лица на каждом эскизе с тем, чтобы по их капризу не пришлось переделывать уже почти готовую работу и, следовательно, терпеть убытки. В любом случае это должна быть официальная процедура, проводимая принятым в вашем издательстве порядком. Полученные утвержденные эскизы становятся официальным документом — вашим техническим заданием.


Выбор типографии и сервис-бюро

Еще до того, как вы принялись за верстку, необходимо точно определить затраты на издание. Вам предстоит выбрать типографию, в которой будет производиться печать, и сервис-бюро, которому вы закажете предпечатную подготовку публикации. Критериями выбора, безусловно, будут являться не только цены на предоставляемые ими услуги. Необходимо определить, могут ли они удовлетворить ваши технические требования. Особенно высокими они будут при необходимости цветной печати. В типографии следует выяснить:

  • Какой тип печати может предложить вам данная типография? Зачастую при печати книг с черно-белыми иллюстрациями или без иллюстраций и простых рекламных материалов можно отдать предпочтение более дешевому, хотя и менее качественному, чем офсет, методу высокой печати.
  • Сколько красок использует их офсетная машина? Не стоит пытаться печатать многокрасочные издания на однокрасочном офсетном станке. В этом случае потребуется несколько прогонов, что значительно снизит качество печати и увеличит ее сроки. Если ваша публикация предполагает четырехцветную печать и наличие дополнительного плашечного цвета (например, надпечатка золотом), то преимущество следует отдать типографии, имеющей пятикрасочный станок.
  • Каковы сроки изготовления тиража?
  • Имеет ли типография значительный опыт работы с компьютерными оригинал-макетами?

Попросите в типографии показать вам образцы их печати и убедитесь, что их качество удовлетворит вас и вашего заказчика.

В сервис-бюро выясните, в какой форме вам надо предоставить макет: в виде верстки или готового PostScript-файла. Поговорите с ними о предпочтительных форматах графических файлов, шрифтах, приложениях, в которых следует подготавливать графические материалы, формате фотонаборного автомата. Если вам понадобится высококачественное сканирование фотографических материалов, то определите, может ли сервис-бюро вам его предложить. Делает ли сервис-бюро цветопробные отпечатки?

Один из главных вопросов, которые следует поднять при выборе сервис-бюро, — это вопрос о том, могут ли они произвести треппинг, если в публикации есть элементы, требующие такой обработки.

После того как типография и сервис-бюро выбраны, не пожалейте времени на проведение совещания в типографии. К этому времени вы должны быть готовы ответить на такие вопросы:

  • Какой тип бумаги вы хотите использовать при печати тиража?
  • Сколько цветов будет использовано?
  • В какой форме будут предоставляться пленки для изготовления офсетных форм и какой монтаж потребуется от типографии?
  • Каковы размеры полосы набора?
  • Кто будет выполнять проверку правильности цветопередачи?

Совещание надо проводить именно с теми сотрудниками типографии, которые непосредственно работают на полиграфическом оборудовании или осуществляют монтаж. Их советы зачастую позволяют более эффективно организовать печать, снизить затраты или облегчить изготовление макета. Обсудите с ними вопросы контроля качества и ответственности за брак.

На этом этапе определяются ключевые технические параметры макета: размеры издания, цветность и используемые краски, линиатура растра для растровых графических изображений, параметры треппинга. учет растискива-ния точек и т. п. Эти параметры зависят именно от типографии, ее технических возможностей и типа бумаги.

Например, бесполезно выводить оригинал-макет с линиатурой 175 линий/дюйм для последующей печати на газетной бумаге. Это не только не приведет к увеличению качества, но и катастрофически его снизит. Напрасной будет в данном случае и работа по сканированию и обработке изображений с разрешением 350 точек/дюйм.

Некоторые вопросы, такие как треппинг или цветопередача, могут потребовать и трехстороннего совещания работников издательства, типографии и сервис-бюро. Технические детали, посвященные треппингу и затруднениям при работе с цветом, освещены в гл. 21. (Более подробное обсуждение вопросов, связанных с типографиями, можно найти в гл. 24.)


Верстка

Когда завершены все хлопоты с планированием и кончилась беготня по типографиям и сервис-бюро, наступает новый, "тихий" этап подготовки публикации — верстка. К сожалению, "тихим" он является только в идеале. Редкая публикация готовится не в режиме жестокого цейтнота, вызванного и недостатками планирования (вспомните закон Мерфи: "Всякая работа занимает больше времени, чем вы запланировали"), и отвлечением сотрудников на другие проекты, и несвоевременной подачей материала ответственными за это людьми и многими другими причинами.


Подготовка компонентов публикации

Издательская система, как уже говорилось в предыдущей главе, не позволяет создавать только с ее помощью все элементы публикации. Для верстки вам понадобятся и текстовые и графические материалы, подготовленные в других приложениях. Очень важно перед началом верстки договориться со всеми готовящими материалы сотрудниками о форме их представления для окончательной верстки.

С наборщиками текста необходимо согласовать формат файлов, в котором будет предоставляться текст. Заранее убедитесь, что этот тип файлов может быть импортирован программой без искажений. Особенно это касается служебных символов и символов национальных алфавитов. Заранее договоритесь о том, какое предварительное форматирование должен осуществлять наборщик, а какое останется за вами.

С сотрудниками, готовящими иллюстрации, также необходимо согласовать форматы графических файлов. Заранее убедитесь, что эти форматы импортируются PageMaker и поддерживают четырехцветные изображения (CMYK). Абсолютно необходимо заранее знать требуемое разрешение изображений и предполагаемые размеры. Если иллюстрация берется из готовых пленок, то вам нужно иметь ее точные размеры, чтобы зарезервировать в публикации соответствующее место.

Выполните корректуру текстовых материалов. С помощью специальных приложений отсканируйте фотографии, проделайте их коррекцию и смонтируйте коллажи; подготовьте рисунки; сформируйте таблицы и графики.


Определение структуры публикации

Наконец начинается собственно работа с PageMaker. Если аналогичные публикации вам уже доводилось выпускать (например, выпуск очередного номера журнала или квартального отчета), то можно воспользоваться готовыми шаблонами. В противном случае вам придется выполнить всю работу с нуля: задать размеры страниц и полей (см. гл. 12), создать модульную сетку (см. гл. 13), определить элементы шаблона, выбрать шрифты (см. гл. 4) и определить систему стилей абзацев (см. гл. 6), задать палитру цветов (см. гл. 19).

Для этих стандартных задач в книге приводятся пошаговые рецепты, которые сэкономят ваше время и не дадут упустить ничего существенного на этом этапе.


Компоновка текста и графики

Пользуясь средствами PageMaker, разместите текст и импортируйте графические изображения. После бесконечных перемещений и подгонок вы получите "вполне приличный" макет, который будет забракован начальством или заказчиком. После некоторого количества переделок вы, наконец, получите результат, удовлетворяющий всех.

Если над версткой публикации работают несколько человек, то особенно важно наладить их эффективное сотрудничество: разделение задач, очередность подготовки материалов (чтобы никто не тормозил работу других), договориться о единых параметрах публикации и пользоваться единой модульной сеткой, шаблонами, системой стилей. В протиЪном случае ваша публикация не будет производить впечатление единого издания.

В гл. 10, 14 вы найдете массу полезных сведений об импорте и размещении текста и графики, а в гл. 16 — методы верстки специфических макетов.


Доводка, специальные эффекты, цветовое оформление

На этом этапе верстки делается кернинг, уточняется разбиение текста на страницы и колонки, производятся обтекание текстом, поворот и транфор-мация изображений, создание буквиц, колонтитулов и т. п. Завершается основная работа по созданию макета.


Создание оглавления и предметного указателя

После того как расположение текста на страницах определилось окончательно, можно создать оглавление и сформировать предметный указатель, если они требуются. Лучше всего, если о создании оглавления вы подумали на ранних этапах верстки, при разработке системы стилей, и тогда же определили, абзацы каких стилей следует включить в оглавление. Заблаговременный учет особенно ценен при создании предметного указателя. Этот очень длительный и трудоемкий процесс значительно облегчается, если в тексте заранее были отмечены входы предметного указателя. (Подробно процесс создания оглавлений и указателей рассмотрен в гл. 17.)


Вывод подписной корректуры

Теперь, когда верстка закончена, пора показать ее результат заказчику. Для этого необходимо вывести макет публикации на лазерный или цветной принтер и представить заказчику на утверждение. В этом случае, как и при утверждении эскиза, нужно обязательно добиться от заказчика его подписи. Как правило, заказчик подписывает каждый лист корректуры. Получение официального согласия заказчика на выпуск публикации особенно важно, т. к. дальнейшие этапы технологического процесса от вас уже не зависят — публикация передается в сервис-бюро, а затем в типографию.


Предпечатная подготовка

Предпечатная подготовка макета производится в сервис-бюро и может включать разнообразные этапы: сканирование, треппинг, цветоделение, вывод пленок на фотонаборном автомате, цветопробы и т. п. Если выпускаемое издание включает иллюстрации более качественные, чем газетные, то стадии предпечатной подготовки не избежать. Дело в том, что технология изготовления форм для офсетной машины требует предоставления оригинал-макета в виде отпечатков на фотографической пленке (чаще всего позитивной) в натуральную величину. Если издание не предъявляет существенных требований к качеству, то этому условию удовлетворяют и пленки, отпечатанные на приличном лазерном принтере. В случае более высоких требований к качеству, и особенно для цветных публикаций, вам обязательно потребуется фотонаборный автомат. Фотонаборный автомат, по сути, является очень сложным лазерным принтером, печатающим на специальной пленке. Такие машины, как, впрочем и профессиональные сканеры, и цве-топробные принтеры, очень дороги. В большинстве издательств вывод цве-тоделенных форм требуется нечасто. Поэтому существуют сервис-бюро, которые получают на подобную работу заказы от многих издательств.


Высококачественное сканирование

Если в вашем издательстве нет качественного сканера, или заказчик предъявляет повышенные требования к качеству, сканирование лучше поручить сервис-бюро, которое располагает профессиональными сканерами. Для обработки полученных гигабайтных файлов в сервис-бюро также имеются мощные компьютеры.


Треппинг

При подготовке цветных изданий в большинстве случаев возникает необходимость треппинга. Упрощенно можно описать треппинг как взаимное перекрывание элементов на странице. Оно необходимо для компенсации погрешностей совмещения (приводки) печатных форм и клише на типографском станке. При отсутствии треппинга между соседними элементами могут возникать белые или цветные зазоры.

Кто должен делать треппинг? В простых случаях эту задачу можно решить самостоятельно. В PageMaker встроены средства автоматизации треппинга, но не забывайте об ответственности, которую вы в этом случае берете на себя. Если же у вас нет необходимого опыта или в публикации имеются сложные для треппинга элементы (см. гл. 21), эту работу лучше заказать сервисному бюро, которое располагает квалифицированными специалистами и профессиональными, очень сложными и дорогостоящими, программами растрового треппинга (типа Adobe TrapWise).


Цветоделение

В процессе цветоделения цветное изображение разбивается на цветные слои, соответствующие отдельным краскам. Каждому слою в свою очередь соответствует отдельная пленка, вышедшая из фотонаборного автомата, и отдельная форма для печатной машины. С появлением компьютерных издательских систем процесс цветоделения стал исключительно простым, но только при наличии опыта или посоветовавшись с работниками сервис-бюро и типографии, вы можете взяться за цветоделение сами (о цветоделении см. гл. 24).


Цветопробы

Услуги по изготовлению цветопроб предлагают большинство сервис-бюро и некоторые типографии, имеющие пробопечатное оборудование. Цветопробы могут изготавливаться по различным технологиям (из электронного варианта верстки, с уже выведенных пленок и т. п.) и позволяют с большой степенью достоверности судить о правильности подготовки макета и цветоделения. При печати ответственного тиража мы рекомендуем не пропускать эту стадию. Если требования заказчика к соблюдению цветов велики, то цвето-проба является просто необходимой. Кроме того, обязательно официально утвердите полученные цветопробы у заказчика. Не лишними будут цвето-пробы и в типографии в качестве образца цвета для печати на офсетной машине. В случае типографского брака, при наличии цветопроб вы скорее сможете убедить типографию в необходимости доработок или перепечаток.


Вывод пленок на фотонаборном автомате

Как мы уже говорили, фотонаборный автомат позволяет выводить не бумажные оригиналы, а особые пленки. Это не единственное его отличие от лазерного принтера. Даже самый хороший лазерный принтер не позволяет выдать отпечаток с разрешением 3600 точек/дюйм. Такое высокое разрешение необходимо для адекватной передачи полутонов и оттенков цвета (см. гл. 24). На этом этапе вам также понадобятся сведения, приведенные в гл. 20, 21.


Печать в типографии

Завершающая стадия подготовки издания — печать в типографии. Это наиболее ответственная и самая дорогостоящая часть технологического процесса.


Спуск полос

Спуском полос называется операция сборки страниц публикации в монтажные листы. Ее смысл в том, чтобы за один проход типографского листа через печатную машину отпечатывалось сразу несколько страниц публикации. Способ переплета публикации определяет размещение страниц на монтажных листах. Операция спуска полос достаточно сложна, и без соответствующего опыта в ней легко запутаться. Обычно спуск полос делается в типографии.


Пробные отпечатки

После спуска полос и изготовления форм печатаются пробные отпечатки. Они дают точное представление о том, как будет выглядеть основной тираж, т. к. их выпуск предназначен не только для утверждения вами или заказчиком, но и для настройки типографской машины (подача краски, приводка форм и т. п.). Просмотр пробных отпечатков лично вами особенно важен — ведь вы видите практически часть готового тиража. Если вы находите что-либо неудовлетворительное (плохое совмещение цветов, нарушение цветопередачи, "грязную" печать и т. п.), что может быть исправлено в типографии, об этом нужно обязательно сообщить типографским работникам и настоять на исправлении, поскольку это последний шанс что-либо скорректировать.

После того как вы останетесь довольны пробными отпечатками, вам предложат подписать их в печать для изготовления тиража. Это делается самым официальным образом, и подписывающей стороной можете являться вы, ваш начальник или заказчик, в общем, тот, кто оплачивает счета, или его представитель.


Печать тиража

Печать тиража производится немедленно после подписания его в печать, поскольку машина настроена на печать вашего тиража и не может быть использована для других работ без риска ее сбить.

Нелишним представляется и выборочный просмотр готового тиража на предмет соответствия пробным оттискам. Если соответствие неудовлетворительно, то вы имеете право требовать перепечатки тиража, т. к. брак был допущен именно типографией. Если вы уже достаточно долго работаете с этой типографией, то риск таких катастрофических ошибок со стороны типографии ничтожно мал.

После печати тиража типография может произвести и прочие работы, необходимые для конкретного издания: фальцовку, обрезку, переплет и т. п. Результат этих работ, как и любых типографских работ, желательно тщательно контролировать и сообщать работникам типографии о любом обнаруженном браке: коробление переплета, складки при фальцовке, неровный обрез и т. п.

И вот, после длительной подготовки издания вы наконец-то держите его в руках. На первых порах вы не будете абсолютно им довольны. Вы обнаружите и некоторые ошибки верстки, и неиспользованные возможности улучшения самого макета или повышения его технологичности. Это неизбежно, но не расстраивайтесь — издание состоялось, прибыль получена. Обязательно анализируйте причины неудач и отмечайте х упущенные возможности. Анализ поможет вам избежать таких накладок в следующий раз и подойти к выпуску публикации более рационально.


Резюме

К выпуску публикации, особенно если предполагается печать тиража в типографии, следует подойти серьезно. Заранее продумайте все этапы подготовки издания, от концепции до выбора типографии и сервис-бюро. Прислушайтесь к советам профессионалов, они, скорее всего, укажут вам потенциальные проблемы в вашей публикации и способы их устранения. В ходе изложения мы будем обращать ваше внимание на моменты, которых следует избегать.


  • Глава 20. Использование цвета
    • Назначение цвета тексту
    • Назначение цветов графическим объектам PageMaker
      • Палитра цветов
      • Диалоговое окно Fill and Stroke
      • Список Fill меню Element
    • Назначение оттенков цвета
    • Условные "цвета"
    • Наложение цветов
    • Импортированные цветные изображения
    • Выбор цветового решения публикации
    • Резюме


ГЛАВА 20.

Использование цвета

В этой главе, посвященной использованию цвета в публикациях, рассматриваются следующие вопросы:

  • Назначение цветов объектам программы PageMaker при помощи палитры и диалогового окна Fill and Stroke (Фон и линия).
  • Назначение объектам точечных заливок — узоров.
  • Особенности назначения оттенков цвета.
  • Условные цвета.
  • Установка наложения цветов на печати.
  • Цвета импортированных объектов. Возможности редактирования цветов в зависимости от типа файла.
  • Общие правила назначения цветов с точки зрения дизайна.

Вы приступаете в "раскрашиванию" публикации. Это сделать почти так же просто, как разрисовать цветными карандашами детскую раскраску. Кое-какие правила все же имеются, и они рассмотрены в данной главе. Особенно это касается импортированных изображений, при редактировании цветов которых нужно учитывать тип файлов. Кроме того, немаловажен художественный аспект проблемы цвета в публикациях. Цвет — отличный инструмент дизайна, однако цветовое оформление должно соответствовать назначению публикации, стилю работы фирмы, выпускающей ее, и финансовым возможностям издательства. Выбор цветов должен производиться в соответствии со здравым смыслом и хорошим вкусом.


Назначение цвета тексту

Цвет тексту можно назначить несколькими способами.

  • Непосредственное назначение. Выделите текст инструментом Text (Текст) и щелкните мышью на палитре цветов. При помощи раскрывающегося списка в правом верхнем углу палитры можно назначить оттенок цвета. Не забывайте о том, что оттенки на печати передаются растром, что снизит читаемость текста.
  • Параметры шрифта. В диалоговом окне форматирования символов Character Specifications (Параметры шрифта) можно назначить тексту один из определенных в публикации цветов. При помощи раскрывающегося списка Tint (Оттенок) можно выбрать оттенок с шагом 5% или ввести его значение с клавиатуры с точностью до 1%.
  • Стиль абзаца. Цвет символов можно определить как атрибут стиля абзаца. Эта операция производится с помощью диалогового окна Define Styles (Определить стили). Подробно об определении стилей абзаца говорится в гл. 6.


Назначение цветов графическим объектам PageMaker

Для назначения цветов обводок и заливок объектам PageMaker можно пользоваться различными способами. Все они рассмотрены в настоящем разделе.


Палитра цветов

Любому графическому объекту PageMaker — линии, ломаной, многоугольнику, эллипсу, фрейму любой формы — может быть назначен один из определенных в палитре цветов. При этом отдельно задается цвет для обводки, отдельно — для заливки объекта. Разумеется, у линии можно задать только цвет обводки. Для назначения цвета выделите объект, затем, нажав нужную кнопку в верхней части палитры, выберите, какой части объекта будет задан данный цвет — обводке, заливке, обводке и заливке одновременно (о кнопках режима задания цвета см. гл. 19). Щелкните мышью на имени подходящего цвета в палитре цветов.

Кроме того, цвет объекту можно задать из диалогового окна Fill and Stroke (Фон и линия).


Диалоговое окно Fill and Stroke

Данное диалоговое окно можно открыть одноименной командой меню Element (Элемент) или комбинацией клавиш <Ctrl>+<F3>. Элементы управления диалогового окна Fill and Stroke (Фон и линия) позволяют более точно управлять назначением цвета элементам графического объекта PageMaker, чем кнопки палитры цветов (рис. 20.1). В этом Диалоговом окне возможно одновременно выбрать разные цвета для фона и, контура в двух половинах диалогового окна, а также точнее задать оттенки (до 1%) посредством ввода значений в соответствующие поля. Возможна установка режима наложения для данного объекта (отдельно для фона и линии), для линии можно задать атрибут прозрачности и инверсного начертания.

Рис. 20.1. Назначение цветов при помощи диалогового окна Fill and Stroke


Список Fill меню Element

В меню Element (Элемент) находится вложенный список стандартных заливок Fill (Фон) (рис. 20.2). В нем приведены три основных цвета — Paper (Бумага), None (He определен), Solid (Сплошной). Выбор пункта Solid (Сплошной) приводит к заданию объекта сплошной заливки определенного ранее цвета. Кроме сплошной цветовой заливки, имеется возможность задавать графическому объекту точечные заливки-узоры (полоски, клеточки и т. д.).

Рис. 20.2. Значения заливок списка Fill

Примечание

Узоры, которые можно выбрать в раскрывающемся списке Fill (Фон) и в диалоговом окне Fill and Stroke (Фон и линия), — обычные точечные изображения, зависимые от разрешения. Если вы собираетесь выводить фотоформы на фотонаборном автомате с высоким разрешением, обязательно сделайте пробный вывод. При выводе с высоким разрешением точечные заливки становятся намного более компактными и, как следствие, выглядят иначе, чем на экране.


Назначение оттенков цвета

Назначение оттенка можно производить непосредственно в палитре цветов, выбирая значение оттенка данного цвета из раскрывающегося списка с шагом 5%, либо в диалоговом окне Fill and Stoke (Фон и линия). Оттенок можно определить и как отдельный элемент палитры, связанный с базовым цветом. О том, как это делается, написано в гл. 19. Наконец, можно определить оттенок цвета как отдельный, не связанный ни с каким другим, цвет. Это приемлемо в случае, если вы часто редактируете палитру, убирая из нее лишние цвета. При удалении базового цвета все оттенки, с ним связанные, обращаются в черный цвет. В случае, если оттенок определен как отдельный цвет, его эти изменения не коснутся.

Списки Tint (Оттенок) в диалоговом окне Fill and Stroke (Фон и линия) и в палитре Colors (Цвета) независимы. Если вы назначаете для фона объекта цвет, являющийся 60%-ным оттенком какого-либо базового цвета, а затем с помощью команды Fill (Фон) или палитры цветов определяете локально оттенок 50%, то базовый цвет будет "разбавлен" дважды и окончательный оттенок составит всего 30%. В конце данной главы приводится несколько советов по дизайну, касающихся назначения оттенков цвета.


Условные "цвета"

Кроме определенных пользователем цветов публикации, в палитре обязательно присутствуют четыре основных цвета, которые нельзя удалять и редактировать. Это стандартные цвета [None] ([Без цвета]), [Paper] ([Бумага]), [Black] ([Черный]) и [Registration] ([Совмещение]). Собственно говоря, из них только последние два действительно являются цветами, а первые — скорее, режимы работы программы с объектами.

  • [None] ([Без цвета]). Отменяет любые выполненные программой PageMaker назначения цвета выделенному объекту. Если задать этот атрибут объекту PageMaker, он станет прозрачным. Для импортированных объектов атрибут [None] отменяет присвоение объекту цветов средствами PageMaker и возвращает изображение в исходное состояние.
  • Отсутствием заполнения можно пользоваться при ошибочном присвоении цвета импортированному объекту. Для этого необходимо лишь применить пункт палитры [None] ([Без цвета]) к нужному объекту, и первоначальные цвета объекта будут восстановлены.
  • Если при импорте EPS-файла был установлен режим замены именованных цветов изображения на таковые из палитры PageMaker, назначение отсутствия

    заполнения возвратит изображение к исходному виду, отменив при этом назначенные в процессе импорта цвета PageMaker. Кроме того, возвратить исходные цвета файлу EPS можно и установив флажок Preserve EPS Colors (Сохранить цвета EPS) во вложенном диалоговом окне Print Color (Печатать, Цвет). [Paper] ([Бумага]) — это тоже "ненастоящий" цвет. С его помощью устанавливается режим поведения объекта при его перекрытии с другими объектами. Любой объект, которому назначен цвет [Paper] ([Бумага]), подавляет цвета всех лежащих ниже объектов. Область страницы, занятая объектом, которому назначен цвет бумаги, защищается от нанесения краски, даже в той части, где этот объект перекрывает объект другого цвета. Если публикацию предполагается печатать на цветной бумаге, целесообразно отредактировать определение цвета [Paper] ([Бумага]) таким образом, чтобы изображение на мониторе больше соответствовало внешнему виду страницы после печати. Но не забывайте, что этот цвет означает просто отсутствие краски.

  • [Registration] ([Совмещение]). Назначается объекту, после чего он печатается на всех деленных полосах и фотоформах. Для достижения такого эффекта цвет [Registration] определяется как 100%-ное заполнение всеми типографскими красками. Можно редактировать данный цвет, изменяя его оттенок (и только). Применяется для форматирования маркеров обрезки, меток совмещения, маркировки фотоформ и т. д.
  • [Black] ([Черный]). Объект всегда печатается черной краской оттенком 100%. Этому цвету также можно придать оттенок.


Наложение цветов

Наложение цветов означает, что печатаются оба перекрывающихся объекта и соответствующие им краски могут смешиваться на листе бумаги. Такая возможность иногда очень удобна, но пользоваться ею следует с крайней осмотрительностью — при смешивании красок возможно возникновение третьего цвета и превышение нормы расхода краски на единицу площади листа бумаги (переувлажнение). Существует одно исключение — по умолчанию черный текст кеглем мельче 24 пунктов всегда печатается с наложением. Однако наиболее квалифицированную консультацию по конкретным вопросам вы сможете получить в типографии, в которой будет печататься тираж вашего издания. PageMaker предполагает два способа задания режима печати объектов с наложением, т. е. поверх других объектов. Если вы хотите задать режим наложения только для выбранных объектов, установите флажок Overprint (Наложение) в диалоговом окне Fill and Stroke (Фон и линия). Если же печататься с наложением должны все элементы данного цвета, флажок Overprint (Наложение) следует установить в диалоговом окне Color Options (Параметры цвета).

Примечание

Если необходимо, чтобы одни объекты данного цвета печатались с наложением, а другие — в режиме подавления, можно определить обе версии цвета на палитре цветов. При этом они должны печататься с помощью одной и той же печатной формы. Такого эффекта можно достигнуть, определив один из цветов как 100% другого и установив для них разные режимы наложения. Базовый цвет можно печатать с наложением, оттенок — без наложения, или же наоборот.


Импортированные цветные изображения

Цветные импортированные изображения в PageMaker можно условно разделить на следующие группы:

  • Файлы, которым можно определять цвета внутри PageMaker, — это монохромные и полутоновые точечные изображения (TIFF, BMP и др.). Они не имеют собственных именованных цветов, являясь черно-белыми изображениями. Изменение цвета, производимое в PageMaker, сразу отражается на экранном представлении импортированного файла. При этом возможно применить цвет только к заливке, т. е. к черным точкам монохромного изображения. К монохромному изображению нельзя применить отмену заполнения. Для возвращения изображения в исходное, черно-белое состояние следует применить к нему черный цвет палитры.

Примечание

Задание цвета и оттенка монохромному и полутоновому изображению — великолепный инструмент дизайна. Вы можете легко тонировать фотографии, не выходя из PageMaker. Это очень удобно, в частности, для создания фоновых осветленных фотографий (ведь каждому цвету можно задать и оттенок).

  • Файлы, цвета которых не редактируются в PageMaker. К ним относится цветная растровая графика (TIFF, JPEG, PCX, DCS и др.), в том числе и импортированная через буфер обмена. Как растровые, они не имеют собственных цветов. Изменение цветов этих файлов внутри PageMaker не оказывает никакого влияния на отображение их на экране и на печати. К этому же типу можно отнести цветные растровые изображения, внедренные в EPS-файлы, и файлы векторных форматов, не поддерживающие именованных цветов (например, WMF).
  • Файлы EPS, AI и PDF. Файлы форматов EPS и PDF позволяют хранить именованные цвета. PageMaker способен импортировать эти цвета в публикацию и редактировать их. Формат AI — собственный формат программы Adobe Illustrator. До версии 8.0 включительно он представлял собой вариант EPS, а в новейших версиях 9.хх и 10.хх — PDF. Режим импортирования цвета задается при настройке фильтра импорта. На рис. 20.3 приведено окно импорта EPS-файла.

Режим импорта цветов можно настроить с помощью группы флажков Import options (Параметры импорта) и группы переключателей Spot color options (Включение параметров цвета). Если снять первый флажок Add process and

Рис. 20.3. Установки фильтра импорта файла EPS

high fidelity color names to palette (Добавить имена составных и Hi-Fi-цветов в палитру), импорта собственных триадных и высокоточных цветов в публикацию не произойдет и PageMaker при печати будет использовать для цветоделения стандартные триадные краски. Второй флажок регулирует импорт плашечных цветов. Если включен переключатель Add spot color names to palette (Включить имена простых цветов в палитру), происходит добавление плашечных цветов, определенных в графическом файле, в палитру PageMaker. Как заметили создатели фильтра, это делается for correct spot separations (для корректного вывода плашек). Второй переключатель — Exclude spot color names (Исключить имена простых цветов). В этом режиме импорта добавления плашечных цветов в палитру не происходит, в импортируемом изображении они заменяются на соответствующие триадные. Для точного цветоделения рекомендуется включать режимы копирования цветов изображения в публикацию. И вот EPS-файл скопирован в публикацию. Он имеет собственные именованные цвета, в палитре цветов PageMaker — атрибут [None] ([Без цвета]). В принципе, вы можете задавать данному объекту какой-либо из цветов PageMaker. При этом объект становится монохромным, цвета его передаются оттенками выбранного в PageMaker цвета. Если присвоенный цвет является плашечным, все изображение при цветоделении переносится на фотоформу соответствующего цвета. Необходимо отметить, что изменения цвета объекта не видны на экране, поскольку на мониторе демонстрируется не само EPS-изображение, а его миниатюра, создаваемая при импорте изображения и не редактируемая в процессе присвоения цветов. Как уже было сказано, при неправильном присвоении цвета EPS-файлу возвратить его в нормальное состояние можно, задав для него отсутствие заполнения в палитре цветов. При работе с импортированными EPS-файлами настоятельно советуем вам вообще не менять их цвет в пределах PageMaker. Делайте подготовительную работу в исходном приложении и там же окрасьте ваше изображение нужным цветом. Встроенные в файлы EPS цветные растровые изображения не могут быть изменены средствами PageMaker. При импорте EPS-файлов, содержащих подобные изображения, внимательно просмотрите установки фильтра. Так, при импорте DCS-изо-бражений, внедренных в состав EPS-файлов, установка флажка Import nested DCS images for separations (Импортировать DCS-элементы для цветоделения) означает, что вместе с EPS-файлом будут импортированы все цветовые и графические данные, необходимые программе PageMaker для цветоделения DCS-изображений, встроенных в EPS-изображение. Если это условие не будет задано, PageMaker напечатает DCS-изображения в одну краску, с низким разрешением.

Примечание

Перед экспортированием изображения в формат EPS удалите с палитры графического приложения все неиспользуемые цвета. В противном случае, на палитре цветов PageMaker может оказаться до сотни цветов, большая часть которых не используется и лишь загромождает список цветов. Устранить лишние цвета средствами графического приложения несложно, сложнее выяснить, какие цвета не используются. Для этого может понадобиться тщательное исследование изображения.

При размещении в публикации PDF-файлов импортирование определенных цветов происходит всегда.


Выбор цветового решения публикации

Здесь будет упомянуто только несколько моментов, которые следует учитывать при выборе цветового решения публикации. К сожалению, в данной книге невозможно было сделать цветные вклейки, а рассказывать о цветовом решении конкретных публикаций без цветных иллюстраций — неблагодарное занятие. Поэтому приведем лишь несколько общих рекомендаций.

  • Каждый цвет несет эмоциональную окраску. Цвета могут быть теплыми (красный и желтый) и холодными (синий и зеленый). Одни сочетания считаются детскими (оранжевый и ярко-зеленый) или младенческими (розовый и голубой), другие — мужественными (коричневый и темно-синий) или женственными (сиреневый и салатный).
  • При выборе цветов старайтесь предугадать эмоции зрителя на восприятие того или иного цвета. Помните, что многие цвета имеют устойчивую ассоциативную связь с каким-то явлением. Это не значит, что их нельзя употреблять, однако они могут усиливать впечатление от материала статьи или придавать ему двусмысленность. Смех вызовет, скажем, статья о Клинте Иствуде, оформленная с применением голубых и розовых тонов. Зато материал о сталинских репрессиях, выполненный в красно-коричневой гамме, будет выглядеть еще более зловещим.

Выбор цветов зависит от типа публикации. В публикациях неофициального характера можно использовать яркие, насыщенные цвета, если же публикация имеет академический характер, ее гамма будет более сдержанной, цвета — приглушенными, очень темными либо, наоборот, совсем светлыми и малозаметными. В изданиях рекламного характера существует неписаное правило — чем шикарнее вещь, тем спокойнее цветовое решение рекламного материала.

Примечание

Кроме цветной печати, цветовое решение публикации может быть создано с помощью тонированной бумаги. Материалы на тонированной бумаге производят совершенно иное впечатление, чем те же материалы на белой бумаге. Обязательно учитывайте цвет и оттенок бумаги при подготовке макета.

Поразительный эффект наблюдается при использовании бумаги розовых и желтых оттенков в качестве носителя при производстве дешевой рекламной продукции. При печати на ризографе полученные копии имеют очень скромное качество. И контрастность печати, и ее качество оставляют желать лучшего. Цветная бумага в данном случае заметно скрадывает эти недостатки и отпечатки выглядят более качественными.

Дешевая бумага обычно имеет желтоватый оттенок. При печати на ней голубым цветом результирующим оказывается грязноватый зелено-голубой. Поэтому при выпуске дешевых изданий на плохой бумаге лучше выдерживать гамму в теплых тонах. В этом случае влияние фона будет не столь заметно. В подобных изданиях лучше применять темные цвета, выделяя логотипы, буквицы и т. д. Темные краски лучше перекрывают фон и смотрятся чище. Светлые растровые заливки могут смотреться грязными, и применение их лучше ограничить. Рекомендации по выбору бумаги приведены в гл. 24.

  • Чем больше цветов использовано в публикации, тем труднее добиться стройности композиции. Не увлекайтесь назначением множества контрастных цветов. Как правило, достаточно двух контрастных цветов и их оттенков. Исключение составляют детские издания. Однако и в них лучше избегать аляповатого сочетания цветов. Ошибаются те издатели, которые думают, что детям чем ярче, тем лучше. Ведь книги для детей выбирают родители, а они руководствуются своим вкусом.

При работе с текстом в цветных публикациях придерживайтесь следующих правил:

  • Назначайте фону и тексту контрастные цвета. Речь идет о контрастности именно цвета, а не просто о различной яркости. Например, черные буквы на красном фоне читаются с большим трудом, так что такого сочетания следует, по возможности, избегать.
  • Проверяйте контрастность в монохромном изображении. Для проверки степени контрастности двух цветов переключите монитор в монохромный режим воспроизведения. Хотя этот прием срабатывает не всегда, но в большинстве случаев, если два цвета выглядят контрастно в монохромном изображении, они будут выглядеть контрастно и при цветной печати.
  • Обводите буквы. Если в силу тех или иных причин вам приходится пользоваться слабоконтрастными цветами фона и букв, воспользуйтесь для улучшения удобочитаемости обводкой символов текста. Обводку можно выполнить в таких графических приложениях, как Illustrator или FreeHand, преобразуя символы текста в последовательности кривых и назначая каждой из них свои атрибуты обводки и заливки фона. Другой вариант предполагает применение программы для работы с растровыми изображениями типа Photoshop и фильтров для усиления резкости контуров со сглаживанием (anti-aliasing) — приемом, позволяющим впоследствии не выполнять треппинг цветных штрихов.
  • Избегайте раздражающего сочетания цветовых тонов. Например, сочетание желтого с красным раздражает глаз. Это сочетание очень действенно, когда нужно привлечь внимание зрителя. Неслучайно ярлыки "New!" имеют такое цветовое решение. Для содержательного текста эта цветовая гамма неприменима.
  • Помните о треппинге. При печати цветными буквами по цветному фону может возникнуть искажение символов за счет треппинга, при котором размеры символов могут несколько измениться. Человеческий глаз очень чувствителен к искажениям формы литер шрифта, поэтому везде, где это возможно, откажитесь от совмещения по тексту с применением треппинга. Черный текст меньше 27 кегля всегда печатается с наложением. Если при треппинге размеры надпечатываемых объектов увеличиваются, засечки (серифы) и другие закругленные элементы литер сохраняют форму только в шрифте большого кегля. При большом кегле эффект расширения штрихов меньше воздействует на сокращение внутренних просветов в литерах (например, в буквах О и В). Общее правило состоит в том, что при треппинге гарнитуры без засечек лучше сохраняют форму, чем гарнитуры с засечками. О треппинге речь пойдет в гл. 21.
  • Избегайте слишком светлых и плохо различимых оттенков. Точные рекомендации по поводу воспроизведения оттенков при печати сможет дать только технолог типографии. Оттенки светлее 20% могут быть неудобны для воспроизведения при печати, вне зависимости от того, хорошо или плохо такой оттенок смотрится на фотоформе, выведенной на фотонаборной машине с высоким разрешением. Плохо воспроизводятся тонкие линии, которым задан светлый оттенок цвета. Может даже получиться так, что цветовой оттенок будет выглядеть просто как грязь на бумаге.

Печатные машины не могут воспроизводить разницу в оттенках в 1%. Как правило, минимальные расстояния между смежными оттенками одного цвета не должны быть менее 5%. Поэтому элементы раскрывающихся списков PageMaker выбраны именно с таким шагом.


Резюме

Работа с цветом — в высшей степени увлекательное занятие. Возможность компьютерной допечатной обработки значительно расширила круг цветных изданий. Теперь можно выполнять в цвете многие издания, которые раньше оформлялись исключительно в черно-белом варианте. Однако вы должны ясно представлять, что работая с цветом, берете на себя ответственность, которая раньше лежала на плечах профессионалов. Для подготовки цветных публикаций требуются навыки, которые формируются годами практической работы. В следующей главе будут рассмотрены некоторые трудные моменты в использовании цветов. О выводе публикации вы сможете прочитать в гл. 23. При работе с цветом неизбежен тесный контакт с типографией, иногда взаимодействие с полиграфистами из плодотворного сотрудничества превращается в пытку. В гл. 24 особое внимание уделяется способам повышения эффективности сотрудничества с работниками типографии, где выпускается публикация.


  • Глава 21. Управление цветом и треппинг
    • Этапы работы с цветным изданием
    • Цветопередача в публикации
    • Управление цветом
    • Система управления цветом и PageMaker
      • Типы цветовых профилей
      • Отображение цветов
      • Управление цветом и композитные цвета
      • Управление цветом и плашечные цвета
      • Управление цветом импортированных изображений
      • Установка профилей для отдельных изображений
      • Удаленная печать публикации
    • Профили устройств
      • Профиль сканера
      • Профиль монитора
      • Профиль принтера
    • Треппинг
    • Как сделать треппинг ненужным
    • Ситуации, когда треппинг невозможен
    • Автоматический треппинг объектов средствами программы PageMaker
      • Сбор технической информации
      • Схема треппинга средствами программы PageMaker
      • Установка параметров треппинга
    • Треппинг средствами растрового процессора
    • Резюме


ГЛАВА 21.

Управление цветом и треппинг

В этой главе рассматриваются следующие вопросы: О Организация работы с цветной публикацией.

  • Средства настройки цветопередачи. Система управления цветами Kodak Colour Management System (CMS).
  • Треппинг — большая проблема при печати цвета. Причины его использования, способы треппинга.
  • Выполнение треппинга в PageMaker.
  • Трудности в выполнении треппинга.
  • Как избежать необходимости треппинга.

Процесс производства цветного издания связан с репродуцированием изображений множеством различных машин, каждая из которых имеет свои характеристики. Если бы все эти машины, от сканера до офсетной машины, воспроизводили цвета правильно, а на печати идеально совмещали офсетные краски, никакого управления цветом не понадобилось бы. Однако, несмотря на бурное развитие технологии цветной полиграфии, она все еще очень несовершенна. Так, все устройства, задействованные на этапах подготовки тиража издания, имеют разный цветовой охват, работают исходя из разных цветовых моделей, а цвета, отображаемые ими, являются аппаратно-зависимыми. Как следствие, необходима система согласования цветопередачи для всех этапов производства. Она будет рассмотрена в первой части настоящей главы.

Кроме того, что устройства вывода отображают цвета не совсем точно, они еще иногда их криво печатают. Это связано со степенью износа офсетной машины, ее качеством (на эти показатели можно повлиять, выбрав типографию получше) и, наконец, с мастерством и ответственностью печатников. Для того чтобы недостатки приводки цветов "не бросались в глаза, и существует треппинг, или "цветовые ловушки". Треппинг публикации напоминает процесс закрашивания царапин на нарядных туфлях черным фломастером — красоты публикации он не добавляет, однако "замазывает недостатки". Как делается треппинг и как сделать так, чтобы он не понадобился, также описано в этой главе.


Этапы работы с цветным изданием

В гл. 2 и 24 приводятся методы организации работы по изданию публикации. Здесь мы лишь дадим вам советы, касающиеся подготовки цветного издания.

Прежде чем начинать работу, оцените ее стоимость. Цены на услуги бюро предпечатной подготовки и типографий сильно различаются в зависимости от качества продукции, способа печати и тиража. Составьте примерный план издания, в котором учтите вид издания (буклет, плакат, упаковка, книга и т. д.), необходимые характеристики носителя, число страниц с цветной печатью, число цветов, формат издания. Затем узнайте цены типографий и возможность скидок. В соответствии с ценовым диапазоном и характером издания выберите способ печати, число цветов, формат, тираж.

  • Выбор способа печати. Большинство изданий сегодня печатаются офсетным методом, но если вы подготовили к изданию упаковку, вам может понадобиться специальное флексографическое оборудование. Не исключено, что наилучший результат даст технология шелкографии. Технологические особенности печати должны обязательно учитываться при разработке дизайна и верстке издания. Советы специалистов типографии могут сэкономить уйму времени и средств, избавив вас от поиска оптимального варианта методом проб и ошибок.

Примечание

Не упускайте случая напечатать тираж вашей этикетки на краях формы. При печати крупноформатных изданий края печатного листа часто остаются незадействованными. Не выбрасывайте деньги на ветер — напечатайте на них необходимые мелкие цветные публикации — этикетки, открытки и т. д. Внимательно изучите зависимость цены на экземпляр от тиража в конкретной типографии. Если тираж можно реализовать, гораздо выгоднее напечатать тысячу экземпляров, чем пятьсот. Определите количество цветов. Необходимо выбрать стратегию использования цвета в издании. Возможно, вам потребуется работать с триадными цветами модели CMYK. He исключено, что удастся обойтись черным цветом и парой дополнительных плашечных цветов. Сколько цветов может воспроизвести печатная машина за один проход? Если для полной реализации ваших замыслов потребуется несколько проходов, это может снизить качество печати и точно поднимет цену издания.

  • Выбор бумаги. Многие из параметров цветного полиграфического" процесса (например, линиатура растра) сильно зависят от поглощающей способности и стабильности бумаги. Спросите у технологов типографии, на каких сортах бумаги можно отпечатать ваше издание с наилучшим цветовоспроизведением (это не обязательно должны быть более дорогие сорта). С выбором бумаги и особенностями печати на ней обязательно должен быть ознакомлен ваш клиент. Подробно о выборе бумаги рассказывается в гл. 24.
  • Определение параметров растрирования полутонов. В следующей главе уделено большое внимание параметрам растрирования. Линиатура растра и углы растра имеют огромное значение для качества издания. Обязательно посоветуйтесь с технологом, выясните, какие углы растрирования они предпочитают для своего оборудования и для данного сорта бумаги и какая линиатура растра должна быть в изображениях. В противном случае возможно возникновение полиграфического брака — муара и растискивания точек. Эти рекомендации должны быть получены обязательно, причем выяснение параметров растра должно предшествовать цветоделению. На цветоделение отправляются файлы с уже заданными характеристиками растрирования. В случае неправильно заданных параметров работу по цветоделению придется переделать.
  • Нанесение краски на бумагу. Спросите у технолога типографии про величину растискивания точек и предельное количество краски. Растис-киванием (Dot Gain) называется степень "расплывания" на бумаге точек полутонового растра за счет впитывающей способности бумаги. Лимитирование предельного количества краски позволяет предотвратить переувлажнение бумаги. Переувлажнение (Ink Buildup) возникает при нанесении чрезмерного количества краски на один участок листа (как правило, при перекрывании триадных цветов). Если ваш производственный цикл предполагает размещение в публикации уже цветоделенных изображений, то при их подготовке следует учитывать оба указанных параметра. В противном случае следует позаботиться о том, чтобы цветовой профиль печати в PageMaker соответствовал ее реальным условиям.
  • Выбор типа технологических носителей. Технолог типографии должен сам решить вопрос, в каком виде требуется представить публикацию — деленные полосы на бумаге, на пленке, с зеркалом или без и т. д. Выбор типа технологических носителей — очень важный момент совместной работы. Результат этих обсуждений должен быть представлен в сервис-бюро.
  • Треппинг. В российской полиграфии треппинг фотоспособом не делается и не делался никогда, типографы рассчитывают исключительно на точность приводки цветов. Если в публикации без треппинга не обойтись, делайте его сами или заказывайте в сервис-бюро. Если вы решили выполнить треппинг самостоятельно, вам потребуется согласовать параметры этой процедуры с технологом типографии.
  • Разделение ответственности. Вы должны твердо 'усвоить, что в процессе цветной печати, как в большинстве дел, связанных с денежным риском, никто не хочет брать на себя ответственность за неудачи. Для предотвращения брака следует сделать пробные отпечатки в сервис-бюро и представить их в типографию вместе с формами на пленках. Они будут служить образцом для технолога в процессе подбора цвета и доказательством хорошего качества пленок при конфликте. Желательно, чтобы вы лично присутствовали при печати тиража. (Подробнее об этом смотрите гл. 24.)

Определение способа работы с файлами цветных изображений. Файлы цветных изображений высокого разрешения очень велики. В сервис-бюро вам могут предложить верстать с использованием копий этих файлов с низким разрешением, а затем представить для цветоделения отдельно верстку и отдельно оригиналы для сканирования на профессиональных сканерах с высоким разрешением непосредственно перед выводом пленок. Однако, поскольку услуги сервис-бюро дороги, а оригиналы чаще всего нуждаются в обработке, вывод пленок часто заказывают и из готового PostScript-файла.

Примечание

Если все же вы решили заказать сканирование с высоким разрешением, помните, что точность воспроизведения цвета в результате сканирования может быть нарушена. Необходим выпуск пробных отпечатков отсканированных изображений. Узнайте в сервис-бюро, кто — вы или они — несет ответственность за точность воспроизведения цветных фотографий в данном случае.


Цветопередача в публикации

Проблема точной цветопередачи — ключевая при выпуске любого цветного печатного издания. Почему цветопередача является проблемой, должно быть очевидно: все устройства ввода и вывода передают цвета по-разному. Сравните цвета отсканированной фотографии с цветами на мониторе, а затем — с отпечатком на принтере. Они отличаются, и очень существенно. К сожалению, окончательного и однозначного решения этой проблемы не существует. Перечисленные устройства имеют разный диапазон передаваемых цветов (цветовой охват) и работают в разных цветовых моделях. Тем не менее добиться визуально удовлетворительной цветопередачи вполне можно. Не удивительно, что созданы специальные средства управления цветопередачей на всем протяжении технологической цепочки: от сканирования оригиналов до печати тиража. Ниже мы рассмотрим принципы функционирования и практическую реализацию управления цветом в PageMaker 7.0.

Хотя PageMaker имеет все необходимые функции для управления цветом, вы можете частично или полностью отказаться от их использования. Если, например, вы работаете с шишечными цветами, то система управления цветом просто не нужна, т. к. не даст никаких преимуществ. Для выбора цветов пользуйтесь каталогами на бумаге. Точность отражения цветов на мониторе не принципиальна, на процесс печати она не повлияет. Если вы не печатаете публикации на бумаге, а готовите их для распространения в электронном варианте, то вас совсем не интересует процесс печати.

Кроме перечисленных случаев, в которых применение системы управления цветом не имеет смысла, отказ может быть продиктован и субъективными причинами. Если вы имеете дело с публикациями одного типа, которые верстаются и печатаются на одном и том же оборудовании с хорошими результатами, нет смысла менять эту отлаженную схему.

Управление цветом может быть задействовано только на этапе печати. Вы можете размещать в публикации заранее цветоделенные изображения в форматах TIFF, EPS или DCS. Это дает вам дополнительную свободу в цветовой коррекции и возможность работать с каждым изображением индивидуально. Разумеется, чтобы ею воспользоваться, надо обладать достаточными знаниями и навыками работы с цветоделенными изображениями. Рассмотрение подготовки изображений выходит за рамки настоящей книги, и мы предлагаем вам обратиться за дальнейшей информацией к специальной литературе.

Даже если вы имеете дело только с цветоделенными изображениями, управление цветом можно использовать на этапе вывода. Оно обеспечит правильную цветопередачу при печати на разных устройствах (офсетная машина, цветопробный принтер, цветной принтер и т. п.) и отображении на мониторе.

Система управления цветом позволяет добиться адекватной и стабильной передачи цветов на любых устройствах вывода. Наибольшую пользу из нее можно извлечь только в том случае, если она охватывает все стадии создания публикации, от сканирования оригиналов до печати. При этом нельзя забывать, что система управления цветом не сделает из "плохих" цветов "хорошие". Она направлена только на точное репродуцирование. Чтобы получить при печати хорошие цвета, вам не обойтись без столь же хороших оригиналов или предварительной обработки изображений.


Управление цветом

Сохранить достоверность восприятия цветов на отпечатке позволяют системы управления цветом. Они выполняют преобразование цветовых пространств всех устройств, занятых в технологической цепочке (сканер, монитор, принтер, типографский станок), и обеспечивают одинаковое воспроизведение цветов на каждом из них. Система управления цветом Color Management System (CMS) учитывает, во-первых, принципиальное различие воспроизведения и восприятия цветов различными устройствами, а во-вторых, конкретные характеристики оборудования (сканера, монитора, фотонаборного автомата, принтера). Полностью устранить различия не удается, однако в результате действия программы цвета одного и того же изображения в представлении разных устройств становятся очень похожими на оригинал.

В компьютерах Macintosh управление цветом уже давно поддерживается на системном уровне. На платформе PC управление цветом включено в операционную систему Windows 98/2000, но PageMaker ее не использует. Вместо этого он комплектуется системой Precision Color Management System от фирмы Kodak (KPCMS). У пользователей Macintosh есть выбор: PageMaker поддерживает как KPCMS, так и ColorSync.

Системы управления цветом работают только с калиброванными устройствами. Под калибровкой понимается математическое описание цветопередачи устройства. Такое описание в терминах управления цветом называется цветовым профилем, или просто профилем устройства. Профиль устройства представляет собой таблицу, по которой цвета, зарегистрированные устройством ввода (сканеры, цифровые камеры, видеоплаты и т. п.) или отображаемые устройством вывода (монитор, принтер), преобразуются в одну цветовую модель. Эта аппаратно-независимая модель представления цветов — Profile Connection Space (PCS) — является ядром любой системы управления цветом. Название метко выражает сущность этого понятия. PCS служит тем цветовым пространством, которое вмещает цветовые пространства всех устройств, их "общим знаменателем". В системе ICC используется CIE Lab (Comission Internationale L'Enclairage). Это международный аппаратно-неза-висимый стандарт измерения цветов. Он обеспечивает однозначное представление цветов независимо от конкретного устройства, применяемого для создания или вывода изображения.

Таким образом, систему управления цветом формируют:

  • аппаратно-независимая цветовая модель — PCS, по отношению к которой строятся профили конкретных устройств;
  • профили устройств, в которых указаны все характеристики представления цвета конкретным устройством. Различают профили устройств ввода (сканера, цифровой камеры), профили монитора и профили выводных устройств — принтера, фотонаборного автомата, печатной машины. Каждое устройство имеет собственный профиль. Кроме того, профили имеют и различные типы файлов;
  • модули управления цветом — Color Management Modules (CMM), которые собственно интерпретируют данные о цвете и информацию профилей и формируют инструкции по коррекции для каждого из устройств.

Управление цветом можно выразить простой схемой (рис. 21.1). Система получает данные из устройства ввода в модели RGB. Данные преобразуются СММ в аппаратно-независимый формат в модели Lab с учетом поправок, получаемых из профиля устройства ввода. При выводе на монитор данные в независимой модели преобразуются СММ снова в RGB с учетом профиля монитора. Вывод на принтер предполагает преобразование в CMYK с учетом профиля принтера.

Рис. 21.1. Управление цветом

Важнейшим условием функционирования любой системы управления цветом является возможность хранения цветовых профилей в файлах изображений. Профиль служит своеобразным "цветовым паспортом". Он точно описывает то цветовое пространство, в котором изображение редактировалось (или просто было получено) и в котором оно имеет правильные цвета. Если импортируемое изображение не содержит внедренного профиля, то система управления цветом PageMaker не будет "знать" точные значения его цветов и не сможет их адекватно преобразовать для всех устройств вывода. Все современные профессиональные программы редактирования изображений позволяют внедрять цветовые профили в файлы сохраняемых изображений.

Таким образом, каждое импортированное в PageMaker изображение должно иметь ассоциированный с ним цветовой профиль. Отсутствие такого профиля или его несоответствие реальности приведет либо к непредсказуемым результатам на печати, либо заставит систему управления цветом игнорировать изображение.

Внедрение профилей в файлы позволяет системе управления цветом работать с изображениями, полученными из любых источников, отредактированными на разных компьютерах и в разных программах.


Система управления цветом и PageMaker

Настройки управления цветом находятся в диалоговом окне Color Management System Preferences (Параметры системы управления цветом) (рис. 21.2, а). Чтобы открыть это диалоговое окно, нажмите кнопку CMS Setup (Установки CMS) в диалоговом окне Preferences (Установки). А для того, чтобы включить систему управления цветом в PageMaker,выберите в списке Color Management (Управление цветом) вариант On (Включить).

Рис. 21.2. Профили устройств в диалоговом окне Color Management System Preferences

В левой нижней части окна находится список поддерживаемых систем управления цветом. На компьютерах Windows это единственная система Kodak ICC, а на компьютерах Macintosh еще и ColorSync (рис. 21.2, б). В последнем случае выберите желаемую систему управления цветом. Хотя PageMaker допускает использование нескольких систем одновременно (для разных изображений в одной публикации), мы не рекомендуем поступать таким образом. В зависимости от выбранной системы, нижняя область диалогового окна Color Management System Preferences (Параметры системы управления цветом) будет называться ColorSync Settings (Установки ColorSync) или Kodak ICC Settings (Установки Kodak ICC), соответственно.


Типы цветовых профилей

В области Kodak ICC Settings (Параметры Kodak ICC) диалогового окна Color Management System Preferences (Параметры Системы управления цветом) вы найдете списки профилей для всех устройств. Рассмотрим их.

  • Monitor (Монитор), профиль монитора. Используется для того, чтобы достичь верного отображения цветов на экране монитора. Если этот профиль не установлен или некорректен, система управления цветом не сможет обеспечить адекватное отображение цветов на экране.
  • RGB Image Source (RGB-источник), профиль сканера или иного источника растровых RGB-изображений. Предназначен для коррекции сканированных растровых изображений. Если коррекция изображений уже проводилась при сканировании (для этого программное обеспечение сканера должно поддерживать калибровку и профили ICM), то устанавливать профиль сканера не нужно. В противном случае коррекция будет проведена дважды, что только ухудшит результат.
  • CMYK Image Source (CMYK-источник), профиль сканера или иного источника цветоделенных изображений.
  • Composite printer (Композитный принтер), профиль цветного принтера. Используется для коррекции цвета при печати на цветном (цвето-пробном) принтере; также необходим для корректировки экранного представления иллюстрации, чтобы цвета на мониторе выглядели такими, какими они будут на отпечатке.
  • Separations printer (Печать цветоделения). Нужен для выполнения цветоделения. Задает все необходимые параметры генерации черного, предельного количества краски, растискивания и т. п. В соответствии с этим профилем выполняется любое преобразование в модель CMYK из других цветовых моделей при печати.

Если в списке нет профиля для какого-либо из ваших устройств, вам следует его установить, для чего необходимо получить файл цветового профиля от производителя оборудования или самим создать его посредством калибровки, а затем установить этот профиль средствами операционной системы. На компьютерах Macintosh скопируйте профиль в папку ColorSync, на компьютерах Windows 9х/МЕ — в папку Windows\System^Color, на компьютерах Windows NT/2000/XP — в папку Windows\System32\Color. Поскольку на компьютерах Windows PageMaker не поддерживает системного управления цветом, профили достаточно просто скопировать в указанные папки, даже не устанавливая их командой Install (Установить).

Если вы используете только цветной принтер, установите профили Monitor (Монитор) и Composite printer (Композитный принтер). Остальные профили применяются для работы над типографскими макетами.


Отображение цветов

Система управления цветом не делает чудес: поскольку цветовые охваты разных устройств существенно отличаются, далеко не все цвета, которые вы видите на мониторе, могут быть напечатаны. Она заботится только о том. чтобы обеспечить максимально возможное соответствие восприятия цветов человеческим глазом. Коррекция цветов, отображаемых монитором, включается выбором любого варианта в списке Monitor Simulates (Монитор имитирует), отличного от None (Ничего).

Для практической работы с цветными принтерами очень важно как можно большее соответствие цветов, видимых на экране монитора, цветам, которые будут получены на отпечатке. Качество имитации напрямую зависит от точности построения профилей. При этом вы можете задать имитацию отпечатка как с принтера (Composite printer (Цветной принтер)), так и с печатного станка (Separations printer (Печать цветоделения)).


Управление цветом и композитные цвета

Определяя триадные цвета в PageMaker, вы должны все время учитывать специфику предполагаемого устройства вывода. При создании цветов в модели CMYK убедитесь, что профили CMYK Image Source (CMYK-источник) и Separation printer (Печать цветоделения) совпадают.

Примечание

Триадные цвета во внедренных файлах EPS не доступны системе управления цветом PageMaker.

Вновь создаваемые RGB-объекты PageMaker (графические примитивы, линейки, текст) ассоциируются с профилями Monitor (Монитор) и Separation printer (Печать цветоделения), т. е. текущих устройств вывода. Получив профиль, они оказываются в ведении системы управления цветом, обеспечивающей правильное отображение их цветов на всех устройствах.

Если вы не хотите, чтобы PageMaker осуществлял управление цветом новых объектов, выберите в списке New Items Use (Новые объекты используют) диалогового окна Color Management System Preferences (Параметры системы управления цветом) вариант None (He определен).


Управление цветом и плашечные цвета

Управление цветом для плашечных цветов ограничивается только их приближенным отображением на мониторе. Поскольку каждый плашечный цвет печатается собственной краской с собственной формы, его представление на мониторе никак не скажется на отпечатке.

Примечание

PageMaker способен редактировать цвета в размещенных в публикации EPS-файлах. С этой функцией следует обращаться с повышенной осторожностью. Результаты редактирования не отображаются на экране монитора и проявятся только при печати.


Управление цветом импортированных изображений

Выше мы уже подчеркивали важность внедрения цветовых профилей во все импортируемые файлы изображений. В таком случае система управления цветом PageMaker автоматически преобразует их цвета для правильного отображения на мониторе и печати на принтере.

Если изображения не содержат внедренных цветовых профилей, то PageMaker автоматически присваивает им профили, установленные в списках RGB Image Source (RGB-источник) и CMYK Image Source (CMYK-источник) диалогового окна Color Management System Preferences (Параметры системы управления цветом). При этом забота о том, чтобы изображение действительно имело соответствующий профиль, лежит на ваших плечах. Иными словами, именно в этом цветовом пространстве следует редактировать изображение (например, в Adobe Photoshop) перед импортом в публикацию.

Когда изображение не содержит внедренных профилей, но вы точно знаете источник, из которого оно получено (например, другой сканер или Kodak Photo CD), ассоциируйте профиль данного источника с изображением. Это можно сделать из окна импорта файла. Выделите имя нужного файла и щелкните мышью на кнопке CMS Source (Источник CMS). В открывшемся окне задайте источник CMS и профиль устройства. Диалоговое окно CMS Source Profile (Профиль-источник для CMS) приведено на рис. 21.3.


Установка профилей для отдельных изображений

Доступ к диалоговому окну CMS Source Profile (Профиль-источник для CMS) (см. рис. 21.3) осуществляется для каждого изображения и для каждого из цветов публикации нажатием кнопки CMS Source (Источник CMS). Такие кнопки есть в диалоговых окнах определения цвета Define Color

Рис. 21.3. Задание параметров управления цветом для импортируемых изображений

(Параметры цвета) и импортирования изображений в формате Photo CD. Та же функция доступна с помощью меню Element (Элемент), вложенного меню Image (Изображение).

Вы можете менять профиль устройства вывода непосредственно из диалогового окна Print (Печатать). Если вы используете для вывода разные устройства, меняйте профили в системе управления цветом. Однако помните, что изменять профиль устройства для вывода фотоформ в момент печати крайне нежелательно. Вся цветокоррекция публикации основывалась именно на данном профиле, поэтому его замена в последний момент может повлечь за собой снижение точности цветопередачи.


Удаленная печать публикации

Зачастую вывод публикации на печать осуществляется не с компьютера верстальщика. Столь же типична и смена устройства вывода. Чтобы система управления цветом не потеряла своих настроек при переносе на другой компьютер, установите в диалоговом окне Color Management System Preferences флажок Embed profiles in documents (Встраивать профили в документ). Он позволяет перенести параметры системы управления цветом на другую систему вместе с файлами публикаций. Устанавливайте его только при сохранении файла для другого компьютера. Сразу после сохранения отключите флажок, поскольку установка этого параметра сильно снижает скорость работы программы.

Многие современные принтеры (PostScript Level 2 и PostScript Level 3) сами "знают" свои цветовые характеристики. Их цветовой профиль устанавливается в драйвере или на отдельном растровом процессоре. Если вы печатаете публикацию на таком принтере, то и управление цветом можно поручить ему. Для этого установите в том же диалоговом окне флажок Manage composites on printer (Обрабатывать оригиналы на принтере). Таким образом, вам не придется менять настройки системы управления цветом при смене устройства печати. Сбросьте флажок, если печатаете оригинал на композитном принтере другого типа, иначе вы не сможете задать нужный принтер в списке профилей принтера.


Профили устройств

Профиль устройства описывает то, как оно представляет цвета. Цветопередача не одинакова для всех устройств каждого типа. Она различается не только в пределах конкретной модели устройства, но и для отдельных экземпляров данной модели. По этой причине, строго говоря, следует строить индивидуальный цветовой профиль для каждого отдельного устройства, задействованного в технологической цепочке. Более того, цветовые параметры каждого экземпляра меняются со временем: стареет люминофор электронно-лучевой трубки, меняется спектральный состав источника света в сканерах. Поэтому профиль нельзя построить "раз и навсегда", его необходимо периодически обновлять.

Построение индивидуальных профилей требует специальной измерительной аппаратуры (спектрофотометров, денситометров и колориметров) и специального программного обеспечения. Эти приборы применяются для измерения цветов, отображаемых монитором и получаемых на печати. Программное обеспечение (обычно прилагается к аппаратуре) на основе данных измерений осуществляет построение цветовых профилей. К наиболее популярным из них можно отнести:

  • Heidelberg ColorOpen;
  • Agfa ColorTune;
  • Kodak ColorMatch;
  • Candela ColorSynergy.

Перечисленные программы могут строить цветовые профили всех типов при наличии необходимой аппаратуры.

Примечание

Даже если вы не имеете возможности построить профили, не обязательно отказываться от системы управления цветом полностью. Сейчас подавляющее большинство производителей сканеров, мониторов и принтеров предоставляют покупателям готовые профили для своего оборудования. Такой "общий" профиль содержит усредненные колориметрические данные для конкретной марки аппаратуры. Хотя цветовые характеристики отдельных экземпляров всегда отличаются от "общего" профиля, они уже обеспечивают существенное повышение качества цветопередачи. "Общие" профили вы можете найти либо в поставке драйверов к вашему оборудованию, либ>о на сайте производителя в Интернете.

Профиль сохраняется в файле с расширением icm, который затем следует установить в систему управления цветом. Например, чтобы установить цветовой профиль в Microsoft Windows 98, достаточно щелкнуть на его файле правой кнопкой мыши и в открывшемся контекстном меню выбрать команду Install (Установить). Файл профиля будет установлен и размещен в папке \Color, находящейся в системной папке Windows.


Профиль сканера

Сканеры являются RGB-устройствами. Профиль сканера характеризует преобразование его RGB-пространства в пространство PCS. Для создания профиля сканера вам потребуются стандартный эталон IT-8 (рис. 21.4) и программа калибровки. Многие производители сканеров включают оба этих (или только последний) компонента в стандартную поставку сканера. Эталон для сканирования можно приобрести отдельно у дилеров Agfa или Kodak.

Эталон представляет собой сетку цветных образцов, которые имеют точно известный цвет. В зависимости от типа сканера он может быть представлен в виде отпечатка на фотобумаге или слайда. Цвета образцов измерены их производителями на высококачественной аппаратуре и помещены в справочный файл, прилагаемый к эталону.

Рис. 21.4. Эталон для калибровки сканера

Построение профиля сканера сводится к сканированию эталона. На основе полученного изображения и справочного файла специальной программой строится профиль сканера. Современные программы сканирования могут внедрять этот профиль в сканируемые изображения, обеспечивая точное отображение цветов.

Если модуль сканирования для вашей модели сканера не может внедрять в изображения цветовые профили, PageMaker способен ассоциировать профиль автоматически (см. выше в этом же разделе).

Обновлять профиль сканера при интенсивном его использовании рекомендуется не реже, чем раз в месяц.


Профиль монитора

Прежде чем приступить к калибровке, необходимо стандартизировать освещение в рабочем помещении. Окружающая вас обстановка весьма сильно влияет на восприятие цветов. Для наилучшего цветовосприятия советуем вам придерживаться следующих принципов организации рабочей среды.

Отрегулируйте освещение. Оно должно иметь приблизительно ту же интенсивность, что и световой поток монитора. Благодаря этому вы сможете рассматривать отпечатки и изображения на экране в одном и том же режиме. Свет должен быть рассеянным. Цвет освещения должен быть настолько белым, насколько это возможно. Избегайте освещения комнаты прямыми лучами, особенно солнцем, поскольку солнечный цвет имеет большую интенсивность, а его сила и цвет постоянно меняются. Люминесцентные лампы придают печатным образцам оттенок — голубой или розовый, в зависимости от цвета лампы. При свете лампы накаливания образцы приобретают желтый цвет. Строго говоря, для освещения следует использовать специальные лампы, соответствующие стандартному источнику освещения D50.

Примечание

Как бы вы ни старались, отпечатки все равно будут более тусклыми, чем изображения на мониторе. Когда вы показываете неосведомленному в полиграфии клиенту иллюстрацию на мониторе, включите режим имитации композитного принтера и постарайтесь объяснить, что он никогда не получит таких ярких зеленых и синих оттенков, потому что люминофор светится, а краски на бумаге лишь отражают свет. В противном случае ожидания клиента будут обмануты.

На восприятие цвета большое влияние оказывает окружение. Чем оно более нейтрально, тем объективнее ваше восприятие цветов изображения. В соответствии с этим оборудуйте рабочее место. Отмените заставки (Wallpaper) и узоры (Pattern) на экране — они могут существенно исказить восприятие и понапрасну утомляют глаза. Задайте основному столу нейтральный цвет (например, серый, как фон в программе Photoshop). Постарайтесь не использовать для работы помещения с яркими занавесками, обоями или мебелью. Не зря мониторы и компьютеры красят в серый цвет — он считаете самым подходящим, потому что не искажает восприятие и не утомляет глаза за. В помещении, лишенном ярких красок, вы сможете правильно оценить цветовую гамму изображения на всех стадиях работы.

Для построения профиля монитора применяются колориметры, выполненные обычно в виде датчика-присоски, который крепится к экрану монитора (рис. 21.5). С помощью перечисленного выше или другого программного обеспечения, демонстрирующего на мониторе образцы цветов, строится цветовой профиль монитора. После получения файла icm с профилем монитора его необходимо, как обычно, установить.

Рис. 21.5. Колориметр, укрепленный на мониторе Barco Calibrator

Фирма Kodak разработала программу Kodak Monitor Installing для создания и установки профилей мониторов. Она находится в папке MonGen языковой папки программы. Запустите программу и выберите из списка нужный монитор.

В список входят многие мониторы всех известных производителей. Если вашего монитора нет в списке, можно установить новый профиль. Для этого необходимо знать характеристики своего монитора — WhitePoint (Точка белого), Phoshpor (Люминофор) и Gamma (Гамма). Эти характеристики должны быть приведены в руководстве пользователя к вашему монитору.

Примечание

В современных мониторах цветовые характеристики люминофора также записаны в их ПЗУ. Разумеется, это усредненные данные для конкретной модели, а не индивидуальные для вашего экземпляра. Чтобы прочесть ПЗУ монитора, воспользуйтесь либо программой, предлагаемой его производителем (например, DDCTest для мониторов ViewSonic), либо любой аналогичной. Мы, например, обнаружили такую на сайте фирмы Sequel Imaging ( http://www.sequelimaging.com /downloads/DACtesting.zip), производящей популярные калибраторы Sequel Chroma.

Ручкой или кнопкой регулировки установите на мониторе максимальный контраст. В PageMaker нарисуйте на странице черный прямоугольник и поместите в него еще один концентрический 95%-ный черный прямоугольник (управление цветом для этих объектов должно быть предварительно отключено). Ручкой или кнопкой яркости добейтесь того, чтобы разница в цвете между ними была еле заметна. Зафиксируйте положение регуляторов яркости и контраста с помощью кусочка липкой ленты.

Для приблизительной настройки монитора и построения его профиля еще лучше воспользоваться программой Adobe Gamma. Ее вы найдете на компакт-диске PageMaker, в папке Goodies. Чтобы установить Adobe Gamma, скопируйте файл Adobe Gamma.cpl в системную папку Windows, а остальные файлы — в папку \Program Files\Common Files\Adobe\Calibration. Также создайте ярлык на файл Adobe Gamma Loader.exe в группе автозапуска меню Windows. Если на вашем компьютере установлены другие издательские программы фирмы Adobe (Illustrator, Photoshop и пр.), то, скорее всего, Adobe Gamma тоже уже установлена.

Примечание

Если вы располагаете аппаратным калибратором (колориметром), ни в коем случае не используйте программу Adobe Gamma. Устройства нельзя калибровать двумя способами одновременно.

Построим профиль монитора с помощью программы Adobe Gamma.

  1. Откройте панель управления Windows (Control Panel) и дважды щелкните на пиктограмме апплета Adobe Gamma. Перед вами появится диалоговое окно, изображенное на рис. 21.6. В нем предлагается выбрать режим настройки: свободной установкой параметров в диалоговом окне или с помощью мастера. Первый раз советуем использовать мастер калибровки. Поэтому под вопросом Which version would you like to use? (Какую версию использовать?) установите переключатель Step By Step (Wizard) (Пошаговые инструкции (мастер)) и щелкните на кнопке Next (Дальше).
  2. В следующем окне мастера (рис. 21.7) вам предлагается загрузить готовый профиль монитора. Многие производители ''..мониторов предоставляют покупателям усредненные профили для каждой модели. Мы не рекомендуем использовать эти профили. Откалибруйте монитор с помощью Adobe Gamma, дающей гораздо более точный результат. Если вы уже успели установить усредненный профиль монитора, то перед запуском Adobe Gamma его следует непременно удалить. При этом в поле Description (Описание) должна быть введена строка Adobe Monitor Profile. Также не пытайтесь загрузить усредненный профиль нажатием кнопки Load (Загрузить).

Рис. 21.6. Первое окно мастера Adobe Gamma

Рис. 21.7. Загрузка профиля в мастере Adobe Gamma

  3. Следующее окно мастера (рис. 21.8) позволяет установить черную точку для вашего монитора. Черная точка характеризует полное отсутствие свечения люминофора. Во-первых, регулировками монитора выведите контраст на максимальное значение. Во-вторых, также регулировками монитора уменьшите яркость до минимума. Увеличивайте яркость до тех пор, пока в центре черного квадрата на образце не проступит более светлый квадрат. Увеличивайте яркость очень медленно, чтобы точно зафиксировать момент появления светлого квадрата. Затем нажмите кнопку Next (Дальше).

Рис. 21.8. Настройка черной точки монитора

  4. Очередное окно мастера (рис. 21.9) содержит список люминофоров, используемых в видеосистемах. Тип люминофора определяет хроматические характеристики монитора. Если вы знаете точные хроматические координаты х и у для RGB-люминофоров вашего монитора, то выберите в списке Phosphors (Люминофор) вариант Custom (Пользовательский) и введите их в открывшееся диалоговое окно Custom Phosphors (Пользовательский люминофор) (см. рис. 21.9). В мониторах компьютеров используется либо Trinitron, либо Р22. Установите один из них, если хроматические характеристики люминофора вам неизвестны. Затем нажмите кнопку Next (Дальше).
  5. Следующее окно мастера Adobe Gamma (рис. 21.10) характеризует собственно гамму. Это характеристика монитора, определяющая его яркость. Черной точке соответствует минимальное напряжение, белой — максимальное. Чем больше поданное напряжение, тем светлее точка. Однако зависимость яркости от напряжения не линейная, а логарифмическая. Основание логарифма и есть гамма. Она зависит от оборудования. На гамму также может оказывать влияние программное обеспечение — oneрационная система компьютера. Величина Gamma изменяется для разных мониторов от 0,75 до 3,75. Для определения гаммы пользуются сравнением 50%-ного растра из черных и белых точек с участком серого, добиваясь его 50%-ной яркости. Обычно гамма для некалиброванных мониторов в среде Windows составляет 2,2, для Мас — 1,8.

Рис. 21.9. Выбор типа люминофора в мастере Adobe Gamma и диалоговое окно Custom Phosphors для ввода пользовательских характеристик люминофора

Рис. 21.10. Установка гаммы в мастере Adobe Gamma

  6. Во-первых, вам предстоит определить текущую гамму вашего монитора. Для этого перемещайте ползунок под образцом с двумя серыми квадратами. Добейтесь такого положения ползунка, при котором разница между внешним и внутренним квадратом станет минимальной. Чтобы полоски на внешнем квадрате не мешали, отодвиньтесь от монитора на метр-полтора.
  7. Сбросьте флажок View Single Gamma Only (Только общая гамма), и вместо одного серого образца появятся три цветных (RGB). Убедитесь, что гамма для отдельных компонентов получилась верной. Если на каком-либо из образцов внутренний квадрат слишком отличается от внешнего, скорректируйте для него гамму с помощью расположенного под ним ползунка.
  8. Сообщив программе текущую гамму монитора, вы можете выбрать для работы любую другую. Выберите один из двух вариантов — Windows или Macintosh — из списка Now choose the desired gamma (Выберите желаемую гамму) или установите иное значение в поле справа. После установки желаемой гаммы монитора нажмите кнопку Next (Дальше).

Примечание

Желаемое значение гаммы, которое вы устанавливаете в апплете Adobe Gamma, будет записано в профиль монитора. Чтобы выбранное значение гаммы устанавливалось автоматически, в группе автозапуска (Startup) Windows должен быть ярлык программы Adobe Gamma Loader. Эта маленькая программа нерезидентна. Она только изменяет значения в GLUT (Color Look Up Table) монитора, устанавливая нужную гамму. Adobe Gamma Loader не может работать на Windows NT, т. к. ядро операционной системы не позволяет писать что-либо в GLUT монитора. Поэтому для калибровки Windows NT требуется калибруемая видеокарта, позволяющая вводить значения гаммы в драйвере.

  9. Следующее окно мастера Adobe Gamma предназначено для установки цветовой температуры монитора или его белой точки. Это точка, в которой максимально интенсивные лучи всех трех цветов монитора образуют самый яркий для данного монитора белый цвет. Устанавливаемое значение в кельвинах и есть цветовая температура. Для большинства некалиброванных мониторов ее значение составляет от 6300 до 9300 К. Современные мониторы имеют регулировку цветовой температуры. Выберите в списке установленное значение данного параметра.

    Странное словосочетание "цветовая температура" обязано своим происхождением физикам. Спектральный максимум излучения абсолютно черного тела (абстрактная физическая модель) при заданной температуре и называется цветовой температурой. Цветовая температура измеряется по абсолютной шкале температур. Например, белый свет, излуча^ый абсолютно черным телом, имеющим температуру 5000 К, соответствует дневному свету.

  10. В принципе, вы можете визуально оценить цветовую температуру монитора, если нажмете кнопку Measure (Измерить). Вам будут представлены три серых образца, из которых средний задает текущую цветовую температуру. Он должен иметь нейтральный серый цвет. Если он имеет более "теплый" тон, то щелкните мышью на образце слева. Если тон слишком "холодный", то щелкните справа. Повторяйте этот шаг до тех пор, пока средний образец не станет нейтральным серым. После этого щелкните на нем мышью, затем нажмите кнопку Next (Дальше) в окне мастера Adobe Gamma.

Примечание

Хроматические значения х и у белой точки можно ввести в численном виде в диалоговом окне Custom Hardware Point (Пользовательские характеристики). Если ваш монитор не имеет регулировки цветовой температуры, вы можете узнать его хроматические характеристики из документации или ПЗУ.

  11. Следующее окно мастера Adobe Gamma предлагает выбрать желаемую цветовую температуру. Оставьте в списке Adjusted (Установить) вариант Same as Hardware (Без изменения). Выбор целевой цветовой температуры вы сделаете позже.

Рис. 21.11. Панель управления Adobe Gamma

  12. Последнее окно мастера предлагает сравнить вид экрана до и после калибровки. Если вас это интересует, установите переключатель в очередном окне мастера. В противном случае щелкните на кнопке Finish (Завершить).
  13. Кнопка Finish (Завершить) открывает стандартное окно сохранения файла. В данном случае вы сохраняете готовый профиль монитора. Выберите для него имя и сохраните в папке \Color.

Все те же установки, но не по шагам, можно сделать в панели управления, если в первом окне мастера Adobe Gamma установить переключатель Control Panel (Контрольная панель). Панель управления изображена на рис. 21.11.

Профиль, сгенерированный Adobe Gamma, автоматически устанавливается в качестве активного профиля монитора в операционной системе. Таким образом, он становится текущим для всех приложений. Если вы работаете с Windows NT, профиль монитора автоматически устанавливается и для других приложений Adobe — Adobe Illustrator, Adobe InDesign.

Еще раз подчеркнем, что профиль, построенный Adobe Gamma, очень грубый. Для того чтобы получить точный профиль, следует воспользоваться аппаратным калибратором.


Профиль принтера

Для построения профиля принтера необходимо напечатать на нем специальный эталон IT8.7/3 (рис. 21.12). Как и эталон для сканирования, он состоит из цветных образцов известного цвета.

После того как эталон отпечатан на принтере, измерьте цвета цветных образцов на отпечатке с помощью денситометра (довольно нудное занятие) и введите результаты измерения в программу. На основании этих данных программа построит цветовой профиль, который следует установить обычным способом.

Если у вас нет денситометра, используйте усредненный профиль, которым поставщики комплектуют большинство принтеров.

На хорошо откалиброванном принтере можно сделать цифровую цвето-пробу. Наилучшие результаты для недорогих принтеров дают программные интерпретаторы PostScript, поддерживающие управление цветом, например Adobe PressReady или Birmy PowerRIP.

Учтите, что построенный профиль справедлив только для установленного в момент печати режима принтера и типа бумаги. Профили необходимо строить для каждого из применяемых сортов бумаги и режимов печати.

Это замечание относится не только к принтерам, но и к типографским машинам. Для них построение профиля выглядит еще более проблематичным и попадает в зависимость не только от типа, но и от марки бумаги, марки красок, условий печати, технологического режима. Ни одна типография не способна обеспечить такую же воспроизводимость цвета, как цветной принтер, 'но, тем не менее, она может быть очень хорошей. Если типография, с которой вы сотрудничаете, в состоянии добиться хорошей воспроизводимости цвета от тиража к тиражу и для печати используются одинаковые бумага и краски, то построение профиля имеет смысл. В противном случае создайте профили, отвечающие стандартным условиям печати.

Рис. 21.12. Эталон IT8.7/3

Одним из наиболее распространенных стандартов в этой области является SWOP (Standard Web Offset Printing, стандарт рулонной офсетной печати). В нем четко определены все основные характеристики красок, бумаги, технологии печати. В комплект PageMaker входят профили, построенные в соответствии со спецификациями SWOP для трех типов бумаги: обычной (uncoated), мелованной (coated) и газетной (newsprint). Выберите и установите профиль в соответствии с типом бумаги.


Треппинг

Треппинг — это вынужденная мера. Он применяется для улучшения качества печати даже на несовершенных печатных машинах. При прохождении печатного листа в машине он растягивается, деформируется при нанесении на него краски, может двигаться неравномерно, смещаться в стороны. Печатная машина является механическим устройством, и в ней возможны сбои. Все эти эволюции отразятся на качестве продукта. Это тем более плохо, что в каждом конкретном случае искажения при печати могут быть иными. Если вы проведете треппинг публикации, то возникшие дефекты будут не так заметны, а значит, ваша публикация не будет забракована.

При печати в две и более красок абсолютно необходимо, чтобы цвета располагались относительно друг друга точно, т. е. были приведены. Если по каким-то причинам этого не произошло, в тех местах, где объекты разных цветов касаются друг друга, возникнут нитевидные пробелы, в которые будет видна бумага. Если же публикация напечатана составными цветами, погрешности приводки выражаются в сдвиге цветовых компонентов объектов. В этом случае тоже возможно возникновение нитевидных пробелов на растрированием изображении. На рис. 21.13 показан результат неточной приводки цветов — нитевидные просветы (белый контур на рис. 21.13). Из-за этих просветов, собственно, и делается треппинг. Треппингом называется незначительное растягивание одного из смежных объектов разного цвета, так, что граничащие цвета слегка накладываются. Возникающий при наложении третий цвет будет ближе к более темному из них. Форма объекта может от этого слегка исказиться.

Рис. 21.13. Неточная приводка цветов — основная причина проведения треппинга в публикации

Самыми простыми приемами треппинга являются сжатие (Choking), или внутренний треппинг, и растяжение (Spreading), или внешний треппинг. Сжимается или растягивается цветовой объект, более светлый, в смысле меньшей нейтральной плотности. Нейтральная плотность — численная характеристика интенсивности цвета (равной эквиваленту в градациях серого), и именно по ее значению программа PageMaker принимает решение о том, какой цвет распространять при треппинге. Если перекрывающий объект светлее фона, делается внешний треппинг, а если фон светлее объекта, в фоновом цвете цвета немного стягиваются внутрь — внутренний треппинг. Если объекты имеют близкие значения нейтральной плотности, предпочтительнее совмещение обоих способов треппинга: расширение одного объекта и сжатие другого. В результате полоса треппинга появляется точно посередине их границы. Такой вид треппинга называют треппингом по средней линии (рис. 21.14).

а

б

в

Рис. 21.14. Виды треппинга: внешний, внутренний и по средней линии

В результате треппинга, во-первых, возникает третий цвет, а во-вторых, вокруг объекта появляется обводка. Иногда результат получается еще хуже, чем с нитевидным зазором. Однако, если для перекрывания выбран более светлый цвет, чаще всего эта обводка малозаметна.

PageMaker спсобен выполнять треппинг только собственных объектов (текста и фигур). Импортированные изображения, как растровые, так и векторные, недоступны для программы треппинга PageMaker. По этой причине их обработку следует выполнить еще до импорта, в той программе, в которой они созданы (например, Photoshop или Illustrator).

Если публикация содержит множество импортированной графики и предполагает большой объем треппинга, стоит подумать о том, чтобы перепоручить эту работу сервис-бюро. Такое решение имеет ряд преимуществ и недостатков. К преимуществам отнесем расширяющиеся возможности треппинга и отсутствие вашей личной ответственности за его результаты. В сервис-бюро используют специализированные сложные и дорогостоящие программы растрового треппинга (например, Luminous Trap Wise), не имеющие таких ограничений, какие имеет PageMaker. Недостатками же являются отсутствие контроля за качеством треппинга и дополнительные финансовые затраты. В большинстве случаев работники сервис-бюро не будут утруждаться специальной настройкой TrapWise для вашей публикации и обработают ее, используя наиболее типичные установки. Это может привести к низкому качеству треппинга.

Возможно, наилучшим решением будет выбор сервис-бюро, имеющего в распоряжении фотонаборный автомат с интерпретатором PostScript 3. Новая версия PostScript имеет встроенную подпрограмму растрового треппинга. Настройку его параметров вы можете выполнить самостоятельно, с помощью дополнения In-RIP Trapping. Его можно загрузить бесплатно, с сайта Adobe в Интернете.


Как сделать треппинг ненужным

Треппинга следует избегать везде, где это возможно. Проще всего предотвратить необходимость треппинга еще на стадии дизайна публикации. Создавая ее цветовое решение, всегда держите в голове перспективу треппинга и старайтесь соблюдать следующие правила, которые позволяют избежать треппинга.

  • Белая или черная обводка вокруг объекта позволяет полностью избежать его треппинга. Например, тонкая черная рамка вокруг изображения не создаст впечатления траурной и позволит не заботиться о треппинге по растру.
  • Совершенно излишен треппинг при печати с наложением. Однако при этом способе печати неизбежно возникновение третьего цвета и возможно переувлажнение бумаги (слишком много краски в одном месте). Поэтому с наложением печатается черный и очень темный текст не слишком крупного кегля или небольшие объекты по цветному фону. Обязательно посоветуйтесь с технологом относительно риска переувлажнения бумаги.
  • Кроме того, если два триадных цвета имеют минимум 10% одной и той же триадной составляющей, треппинг к окрашенным ими объектам не применяется. Неточности приводки выразятся в появлении нитевидного зазора не белого, а триадного цвета. Это не так заметно, как наличие белых полосок. В реальной жизни такая ситуация встречается сплошь и рядом, поскольку для страницы публикации выбираются цвета одной гаммы.


Ситуации, когда треппинг невозможен

PageMaker не может автоматически выполнить треппинг некоторых объектов.

  • Импортированные графические объекты. Программа PageMaker импортирует вместе с изображениями и уже выполненный треппинг, т. е. в принципе изготовить макет с выполненным треппингом, в котором бы присутствовали импортированные объекты, возможно. Однако производить треппинг внутри программы PageMaker нельзя. В свете этого опасайтесь изменять размеры импортированных объектов с выполненным треппин-гом. Ведь треппинг — это ни что иное, как обводка фрагментов изображения линиями (полосы треппинга). Ширина полос треппинга не выбирается произвольно, она должна соответствовать технологическим требованиям. При изменении размера изображения меняется и толщина линий, в том числе полос треппинга, а это недопустимо.

Примечание

При работе с постоянно повторяющимися изображениями (заставки, логотипы) вы наверняка уже используете библиотеку PageMaker. Еще один совет по составлению библиотеки объектов — внесенные в нее изображения уже могут иметь правильно выполненный треппинг. Тогда останется только перенести их в нужную публикацию, и можно будет выводить формы.

  • Соприкасающиеся цветовые растяжки и объект, наложенный на фотографию. Это очень непростой случай треппинга, и в PageMaker его невозможно выполнить корректно. В любом случае, если границы объекта не имеют стабильного цвета, то и полоса треппинга должна менять цвет (рис. 21.15). Иначе на изображении появится отчетливо видная полоса. Даже если она окрашена в общий компонент триадного цвета, она все равно хорошо видна. В этом вам поможет только треппинг по растру, выполняемый в сервис-бюро.

Рис. 21.15. Соприкасающиеся цветовые растяжки после треппинга объектов разделяются отчетливо видимой линией

  • Текст, напечатанный поверх текста. Шрифт как декоративный элемент применяется сейчас очень часто. PageMaker не может выполнить треппинг в этой ситуации. Выхода два — выполняйте шрифтовой дизайн в стороннем приложении, делайте треппинг и импортируйте в EPS или заказывайте треппинг в сервис-бюро.
  • Объект на фоне текста. Программа PageMaker может выполнять треппинг текста, расположенного поверх объекта, но бессильна перед обратной ситуацией (рис. 21.16).

а

б

Рис. 21.16. В первом случае треппинг осуществим средствами PageMaker, во втором — нет


Автоматический треппинг объектов средствами программы PageMaker

Треппинг объектов PageMaker может производиться автоматически при печати форм (или сохранении их в PostScript-файле). Программа рассматривает каждый объект по отдельности, определяет, нуждается ли он в треппинге, и выбирает подходящий способ — растяжение или сжатие. Иногда PageMaker применяет к одному объекту и растяжение, и сжатие. Если графический элемент или буква перекрывает одновременно и более темный и более светлый фон, то PageMaker расширяет часть элемента над темным фоном и стягивает под ним темный фон. В любом случае треппинг объектов PageMaker производится путем их обводки линией заданной толщины. Цвет линии треппинга определяется автоматически. Это всегда более светлый из граничащих цветов. При треппинге триадных цветов в результате выбора возможно возникновение пятен третьего цвета из-за наложения красок. При печати триадными цветами применяются особые приемы, позволяющие обойтись без треппинга. Они рассматриваются ниже.


Сбор технической информации

Поскольку треппинг относится скорее к типографскому процессу, чем к компьютерному дизайну, его характеристики определяются чисто производственными параметрами — например, нейтральной оптической плотностью красок, линиатурой растра или величиной растискивания точек растра, определяемой в основном сортом бумаги. Ваша задача — узнать все эти данные в вашей типографии, перед тем как начинать треппинг.

Самая важная характеристика треппинга — ширина полосы. Она зависит от сорта бумаги, погрешностей печатной машины и от других факторов.

Нейтральные оптические плотности красок определяются с помощью денситометра — прибора для измерения оптической плотности по отпечаткам чистых триадных цветов, выполненным в данной типографии. По умолчанию значения оптической плотности красок зависят от языковой версии программы PageMaker's равны значениям, принятым в данной стране в качестве промышленного стандарта. Для обычных триадных цветов нейтральная оптическая плотность может быть оставлена по умолчанию, либо ее значение вы можете узнать в типографии. Значение нейтральной оптической плотности является определяющим в процессе треппинга.

Особенности печати влияют на еще одну величину треппинга — определение черного цвета. Дело в том, что для черного и хроматических цветов применяются разные полосы треппинга. Для черного цвета ширина полосы обычно вдвое шире. Пороговое значение — это процентное содержание черной краски в цвете, после которого программа начинает применять к этому цвету параметры треппинга черного цвета. Если печать ведется на впитывающей бумаге, то растискивание точек растра велико, размеры точек увеличиваются, они сливаются, и в черный превращается цвет с количеством черной краски меньше 100%. Если предполагается сильное растискивание точек, значение порога можно уменьшить, т. е. применять параметры треппинга черного к цвету, который теоретически черным не является. На значение порога может влиять и использование в печати глубокого черного (подробнее см. ниже).

Примечание

Рекомендуем вам для разговора с типографом распечатать диалоговые окна Trapping Preferences (Параметры треппинга) и Ink Neutral Density Values (Нейтральная оптическая плотность). Заполните их вместе с технологом. Это будет служить гарантией, что все нужные данные для проведения треппинга получены.


Схема треппинга средствами программы PageMaker

Треппинг выполняется программой PageMaker в момент печати форм. В файле указаны только правила, по которым принтер, печатающий цветоделенные полосы, будет строить полосы треппинга. Поэтому на экране полосы треппинга нельзя ни увидеть, ни отредактировать. Сильной стороной программы треппинга в PageMaker является ее гибкость. Поскольку физически полосы треппинга не строятся в файле, описание треппинга можно менять произвольно и в любой момент. Когда отпечатки выводятся композитом, например пробные отпечатки на цветном принтере, полосы треппинга не видны.

При построении полос треппинга PageMaker использует данные о нейтральной оптической плотности цветов. Обычно он придерживается следующего порядка.

  • В случае треппинга плашечных цветов или плашечного и составного цвета PageMaker сравнивает нейтральные оптические плотности двух цветов и выбирает цвет с меньшей оптической плотностью, т. е. более светлый. Затем этим цветом строится полоса треппинга, т. е. светлый цвет растягивается, перекрывая темный.
  • При треппинге составных цветов PageMaker выбирает более светлый из них. Затем он строит полосу треппинга третьим цветом. Для третьего цвета он выбирает значения компонентов CMYK более светлого цвета, причем только те, которые больше, чем соответствующие компоненты более темного цвета. Полоса треппинга также смещена в сторону более темного цвета.
  • Если нейтральные плотности граничащих цветов одинаковы или близки, PageMaker строит третий цвет из CMYK-компонентов обоих цветов, выбирая наибольшие. При этом середина полосы треппинга совмещается с границей цветов, т. е. третий цвет одинаково перекрывает оба граничащих цвета.


Установка параметров треппинга

Установите режимы проведения треппинга в диалоговых окнах. Начните с установки значений нейтральной оптической плотности красок. Эти значения собраны в диалоговом окне Ink Neutral Density Values (Нейтральная оптическая плотность), изображенном на рис. 21.17, вызываемом кнопкой Ink setup (Краски) из окна Trapping Preferences (Параметры треппинга) меню File (Файл). Это диалоговое окно в свою очередь вызывается командой Trapping (Треппинг) из вложенного меню Preferences (Установки) меню File (Файл). Введите полученные вами в типографии значения оптических плотностей красок. Если вы собираетесь печатать обычными красками, значения их плотностей, вероятно, не будут сильно отличаться от стандартных.

Рис. 21.17. Установка значений нейтральной оптической плотности

Примечание

Обязательно задайте параметры нейтральной оптической плотности для особых красок. Если, например, вы решили воспользоваться металлизированными красками, обязательно проконсультируйтесь с технологом типографии по пово ду установки значений оптической плотности. Если вам никак не выяснить эти значения, воспользуйтесь следующим приемом. Металлические краски темнее своих CMYK-эквивалентов, а кроющие (непрозрачные) краски в большинстве случаев полностью перекрывают любые другие оказавшиеся под ними цвета Для того чтобы PageMaker всегда считал их темнее обычных, задайте для этих красок значения оптической плотности намного больше других цветов.

Пастельные краски, как правило, светлее своих CMYK-аналогов. Для них можно задать значение оптической плотности гораздо меньше всех остальных красок, чтобы они в любом случае распространялись под более темными цветами При печати нестандартными красками, приготовленными смешиванием разных красок, возможны случаи, когда смесь оказывается гораздо светлее или темнее, чем ее CMYK-аналог. Обязательно сравните напечатанные образцы сме-совой краски и ее CMYK-аналога.

Задание основных режимов треппинга производится в диалоговом окне Trapping Preferences (Параметры треппинга) (рис. 21.18). Рассмотрим основные элементы этого окна.

  • Два поля группы элементов Trap width (Ширина полосы треппинга). Необходимо отдельно задать ширину полосы треппинга для черного цвета и для хроматических цветов. Обычно она вдвое шире для черного.
  • Флажок Step limit (Чувствительность). Если цвета двух перекрывающихся объектов близки, треппинг можно не выполнять. В этом поле задается число, указывающее, насколько близкими должны быть цвета, чтобы программа PageMaker выполняла их треппинг. Чем меньше введенное значение, тем больше будет генерировано полос треппинга.
  • Флажок Centerline threshold (Треппинг по центральной линии). Этот параметр определяет, в каких случаях вместо растягивания более светлого объекта программа PageMaker должна выполнять треппинг по центральной линии. Значение 100% запрещает выполнение треппинга по центральным линиям, значение 0% форсирует размещение всех полос треппинга по центральной линии.

Рис. 21.18. Задание параметров треппинга

  • Поле Black limit (Порог) третьей группы элементов данного диалогового окна. Таким образом проводится определение черного цвета для треп-пинга. В этом поле задается значение черной составляющей, начиная с которого цвет считается черным в рамках процедуры треппинга. В некоторых случаях черный несколько ослабляется растрированием или используется глубокий черный, с добавлением хроматических базовых триад-ных компонентов и соответствующим уменьшением черной составляющей. В таких ситуациях можно задать порог, скажем, 95%, что означает, что любой цвет, в котором черная составляющая превышает 95%, будет при треппинге считаться черным. Auto-overprint black (Автоналожение). Таким образом задаются режимы автоматической печати с наложением черного цвета. Можно установить автоматическое наложение для текста кегля не свыше указанного значения, линий и черного фона, так что треппинг этих объектов не потребуется. Для текста кегля меньше 24 пунктов треппинг не рекомендуется. Причины этого приведены в предыдущем разделе. Искажение формы литер при треппинге может быть достаточным основанием для переделки макета, чтобы треппинг текста не понадобился.

Примечание

Треппинг непрозрачных линий (т. е. тех, для которых не установлен атрибут Transparent (Прозрачная)) не производится. Треппинг объектов, печатаемых с наложением, также не производится. Цвета и объекты, для которых уже установлен атрибут печати с наложением, не подлежат треппингу средствами PageMaker, поскольку маскирования нижележащих объектов в данном случае не происходит и треппинг просто не нужен.

  • Флажок Traps over imported objects (Треппинг над импортированными объектами) обычно снят. Режим треппинга над импортированными объектами употребляется для очень нестандартной ситуации — если между двумя перекрывающимися графическими объектами PageMaker расположен третий, импортированный, а вам нужно выполнить треппинг первых двух.
  • Флажок Enable trapping for publication (Выполнить треппинг в публикации). Установите режим выполнения треппинга перед тем, как начинать печать фотоформ.


Треппинг средствами растрового процессора

Интерпретатор PostScript 3 имеет встроенную программу растрового треппинга. Это дает пользователям возможность бесплатно делать высококачественный растровый треппинг и иметь полный контролцнад его параметрами. Настройки треппинга средствами фотонаборного автомата (In-RIP Trapping) хранятся в файле публикации и используются только в момент печати. PageMaker помещает в файл вывода инструкции для программы треппинга. Для ввода параметров треппинга откройте диалоговое окно дополнения In-RIP Trapping Information (Параметры In-RIP треппинга) (рис. 21.19). Дополнение можно бесплатно получить на сайте Adobe http://www.adobe.com .

Рис. 21.19. Диалоговое окно In-RIP Trapping Information

Чтобы включить треппинг растровым процессором, установите флажок Trapping enabled (Треппинг включен). До тех пор, пока флажок не установлен, треппинг выполняться не будет. Если треппинг необходим для всех страниц публикации и настройки для них одинаковы, установите также флажок Trap all pages (Треппинг всех страниц).

При выполнении треппинга важнейшими данными для интерпретатора PostScript являются нейтральные плотности красок, которые будут использоваться при печати публикации. На основе нейтральных плотностей (видимой яркости цветов) чистых красок RIP решает, к какому виду треппинга (внешнему или внутреннему), следует прибегнуть. Оптические плотности триадных красок стандартизированы и сразу приведены в диалоговом окне Inks (Краски) (рис. 21.20), открывающемся нажатием одноименной кнопки. Впрочем, даже для триадных красок существует несколько стандартов нейтральной плотности. Те значения, что приведены в диалоговом окне Trapping (Треппинг), соответствуют американскому стандарту рулонной офсетной печати SWOP (Standard Web Offset Printing). Наилучший результат треппинга обеспечит подстановка вместо стандартных значений результатов измерения нейтральной плотности с помощью денситометра. Как правило, в типографиях есть такой прибор, используемый для контроля процесса печати. Узнайте в типографии значения нейтральных оптических плотностей для используемых красок и типов бумаги.

Рис. 21.20. Диалоговое окно Inks

Если в публикации есть плашечные цвета, PageMaker автоматически проставит их нейтральные плотности, рассчитанные на основе CMYK-эквивалентов данных цветов. Более точные значения можно также получить непосредственным измерением, хотя расчетные значения практически всегда работают удовлетворительно.

Все используемые краски приведены в списке, занимающем большую часть диалогового окна Inks (Краски). В нем также указаны нейтральные плотности красок, их тип и порядок печати. При печати триадными красками, как правило, используется тот порядок, который фигурирует и в названии цветовой модели CMYK. To есть первой на бумагу наносится голубая краска, затем пурпурная, желтая и черная. Не изменяйте порядок печати триадных красок до тех пор, пока не будете уверены, что в типографии используется иной порядок.

При печати плашечными цветами порядок определяется исходя из оптической плотности красок и их кроющей способности (непрозрачности). Более светлые краски с меньшей кроющей способностью печатаются первыми. Определить порядок печати и задать оптические плотности для обычных плашечных красок не составляет труда. Сложнее обстоит дело со специальными красками: металлизированными, флуоресцентными, флексографиче-скими, пастельными, лаками и т. п. Для таких красок значение нейтральной плотности лучше измерить. Впрочем, иногда достаточно знать их характерные свойства.

  • Металлизированные и флексографические краски обладают очень высокой кроющей способностью. Поэтому при трепп-инге можно считать, что они запечатывают все краски, нанесенные ранее. Установите для этих красок нейтральную оптическую плотность выше, чем для черного цвета. Металлизированные краски всегда наносятся в последнюю очередь.
  • Оптическая плотность пастельных красок ниже, чем у их CMYK-эквивалентов.
  • Лаки следует исключить из треппинга.

Алгоритм треппинга позволяет обработать все специальные краски и особые случаи треппинга, если вы верно зададите тип краски:

  • Normal (Обычная). Этот тип соответствует большинству обычных пла-шечных красок. Например, таких, которые находятся в каталогах PANTONE Coated, Uncoated и Process.
  • Transparent (Прозрачная). Используется для полностью прозрачных красок (лаков) и форм для вырубки. Эти краски не подвергаются треппингу.
  • Opaque (Непрозрачная). Тип включает краски с высокой кроющей способностью, например металлизированные. Из треппинга исключаются области, запечатанные этими красками, но их края подвергаются внешнему треппингу.
  • Opaque Ignore (Игнорировать непрозрачную). Аналогичен предыдущему типу, но не допускает треппинга краев объектов, заполненных кроющими красками. Используется для красок, наложение которых на соседние дает нежелательное химическое взаимодействие.

Нейтральная плотность и тип краски задаются в диалоговом окне Current Ink (Текущая краска), открываемом с помощью кнопки Modify (Изменить) (рис. 21.21). Эти параметры для краски, выделенной в списке, находятся в полях Neutral density (Нейтральная плотность) и Туре (Тип), соответственно. При необходимости скорректируйте любой из этих параметров и перейдите к другой краске, закрыв диалоговое окно Current Ink (Текущая краска) нажатием кнопки ОК, после чего новые параметры краски вступят в силу. Порядок печати красок настраивается кнопками Move up (Вверх) и Move Down (Вниз) диалогового окна Inks (Краски). Верхние краски в списке печатаются первыми, нижние — последними.

Рис. 21.21. Диалоговое окно Current Ink

В диалоговом окне In-RIP Trapping Information (Параметры In-RIP треппинга) основное пространство занимает список зон треппинга. В терминах PageMaker зоной называется диапазон страниц со специфическими настройками параметров треппинга. Набор параметров треппинга объединен в стиль треппинга. Благодаря стилям треппинга вам не придется устанавливать многочисленные настройки для каждой зоны. Достаточно будет создать несколько типичных стилей треппинга и назначать их зонам.

Список уже определенных стилей треппинга (рис. 21.22) открывается нажатием кнопки Styles (Стили). Кроме списка Styles (Стили), в открывающемся этой кнопкой диалоговом окне находятся кнопки Create (Создать), Modify (Изменить) и Remove (Удалить). Они позволяют, соответственно, создавать, редактировать и удалять стили треппинга. В списке стилей всегда присутствует, по крайней мере, один стиль — Printer Default Settings (Установки принтера по умолчанию), соответствующий текущим настройкам треппинга в растровом процессоре. Если присвоить этот стиль зоне треппинга, то треппинг будет проделан в соответствии с теми настройками, которые задаст оператор фотонаборного автомата.

Рис. 21.22. Диалоговое окно Trap Styles

Суть создания нового стиля заключается в задании параметров треппинга. Нажатие кнопки Create (Создать) открывает диалоговое окно, приведенное на рис. 21.23. В поле Name (Имя) необходимо ввести имя создаваемого стиля. Старайтесь выбирать для стилей емкие имена, ведь вы будете их использовать не только для текущей публикации.

В области Trap width (Ширина треппинга) задается ширина полосы треппинга для хроматических цветов и черного цвета — в полях Default (По умолчанию) и Black width (Ширина черного), соответственно. Обычно для черного цвета ширина устанавливается в полтора-два раза больше, чем для остальных цветов. Не опасайтесь, что столь широкая полоса треппинга испортит тонкие линии в публикации. RIP автоматически отслеживает толщину линий и устанавливает ширину треппинга, не превышающую половину ширины линий.

Рис. 21.23. Диалоговое окно New Trap Style

Примечание

Часто для получения "глубокого черного" цвета объектам присваивают не чисто черный цвет (COMOYOK100), а с добавлением остальных красок. Теоретически использование глубокого черного цвета чревато появлением радужной каймы на границе черного объекта с выворотным или светлым объектом. И вы с этим действительно столкнетесь при выполнении треппинга вручную. Алгоритм треппинга в интерпретаторе PostScript 3 применяет для глубокого черного особый способ треппинга. Он заключается в том, что кромка объекта окрашивается в чисто черный цвет, а вся остальная площадь объекта заполняется глубоким черным (рис. 21.24). Это позволяет гарантированно избежать появления радужной кромки при нарушении приводки красок. Число, введенное в поле Black color limit (Предел черного) диалогового окна Edit Trapping Style (Редактирование стиля треппинга), задает цвет, который следует считать глубоким черным.

Настройки области Trapping thresholds (Порог треппинга) определяют, в каких случая будет делаться треппинг:

  • Step limit (Чувствительность). Задает минимальное различие между цветами смежных красок, достаточное для того, чтобы RIP стал делать на их границе треппинг. Различие задается в процентах от 0 до 100%. Меньшие значения соответствуют большей чувствительности алгоритма треппинга и, соответственно, приводят к большему количеству ловушек. Наилучшие результаты достигаются при значениях, лежащих в пределах от 8 до 20%.
  • Black color limit (Предел черного). Задает минимальное количество черной составляющей в триадном цвете, необходимое, чтобы RIP считал этот цвет черным. Для черного цвета, как сказано выше, размер полосы треппинга устанавливается большим. Поэтому до величины, введенной в это поле, для ширины полосы треппинга используется величина из поля

Рис. 21.24. Треппинг "глубокого черного"

Default (По умолчанию), а после — из поля Black width (Ширина черного). Чаше всего предел черного задают для компенсации растискивания точек на низкокачественной бумаге. Даже на газетной бумаге не стоит проставлять в поле Black color limit (Предел черного) значение меньше 70%.

  • Black density limit (Предельная плотность черного). Задает минимальную плотность краски, необходимую для того, чтобы RIP считал ее черной. По умолчанию в этом поле установлена плотность 1,6 (94% стандартной плотности черной краски). Варьируйте этот параметр для темных пла-шечных цветов, чтобы к ним применялся треппинг с большей шириной (равной значению поля Black width (Ширина черного)), чем к остальным краскам.
  • Sliding trap limit (Предел "скользящей ловушки"). "Скользящая ловушка" (sliding trap) предотвращает появление ступенчатости при треппинге градиентных заливок (рис. 21.25). "Ступенька" при треппинге возникает на том участке градиентной заливки, где ее нейтральная плотность сравнивается с нейтральной плотностью фона. При использовании "скользящей ловушки" на указанном участке не происходит смены внешнего треп-пинга на внутренний и наоборот. Вместо этого полоса треппинга постепенно смещается ("скользит") от положения, соответствующего одному типу треппинга, к другому.

    Число, введенное в поле Sliding trap limit (Предел скользящей ловушки), задает минимальное различие нейтральных оптических плотностей фона и градиента в процентах, при котором полоса треппинга начинает смещаться. 0% соответствует треппингу только по центральной линии; 100% вовсе отключает создание скользящих ловушек.

а

б

Рис. 21.25. Обычная ловушка (а) и "скользящая" (б) для градиентной заливки

Поле Color scaling (Снижение плотности) снижает плотность полосы треппинга на заданную в процентах величину. Снижение плотности полосы треппинга может потребоваться для светлых объектов, на границе которых треппинг даст сильно заметный темный контур.

Возможность треппинга с участием растровых изображений — бесценное преимущество треппинга средствами RIP перед ручным. Настройки треппинга по растру собраны в области Image settings (Параметры изображения) диалогового окна New Trap Style (Создать стиль треппинга). Список Image Trap Placement (Положение ловушки) задает размещение полосы треппинга относительно границы участвующих в нем объекта PageMaker и изображения:

  • Choke (Внутренний). Внутренний треппинг изображения. Полоса треппинга размещается на изображении.
  • Spread (Внешний). Внешний треппинг изображения. Полоса треппинга размещается на объекте.
  • Centerline (По средней линии). Треппинг по средней линии. Половина полосы треппинга находится на объекте, а половина — на изображении. Середина полосы треппинга находится точно на границе изображения и объекта.
  • Neutral Density (Нейтральная плотность). Треппинг с учетом нейтральных плотностей на границе объекта и изображения. Это тот же самый вариант треппинга, который используется для объектов PageMaker. В случае изображений он может дать неудовлетворительный результат (ступенчатую кайму) из-за частой смены внутреннего и внешнего треппинга вдоль границы объектов.

Флажок Trap images to object (Треппинг объектов поверх изображений) гарантирует выполнение треппинга между растровыми изображениями и объектами PageMaker. Сбросьте этот флажок, если в вашем макете объекты не перекрывают растровые изображения. Это существенно ускорит треппинг.

Средствами RIP можно выполнить и треппинг самих растровых изображений, как вы это делаете с помощью программы Photoshop. Он включается установкой флажка Internal images trapping (Треппинг растровых изображений). В большинстве случаев не стоит устанавливать указанный флажок, т. к. сами изображения редко требуют треппинга. Исключения составляют только очень контрастные изображения, например рисунки.

Поле Resolution задает значение разрешения растрового треппинга. В общем случае оно должно совпадать с разрешением печати, но иногда его можно уменьшить для ускорения растеризации.

Очевидно, для разных страниц публикации могут потребоваться разные настройки треппинга. Именно по этой причине настройки и объединены в стиль. Созданный стиль всегда можно отредактировать, нажав кнопку Modify (Изменить) в диалоговом окне Trap Styles (Стили треппинга). При этом в списке Styles (Стили) должна быть выделена строка с именем редактируемого стиля. Чтобы при создании стилей не начинать работу над каждым новым стилем "с нуля", создавайте новые стили на основании уже существующих. Выберите стиль-основу в списке Styles (Стили) и нажмите кнопку Create (Создать). В диалоговом окне New Trap Style (Новый стиль треппинга) все параметры треппинга будут автоматически выставлены такими, как в стиле-основе.

Когда все необходимые стили треппинга созданы, следует назначить их страницам публикации, сформировав зоны треппинга. Чтобы создать новую зону, нажмите в диалоговом окне In-RIP Trapping Information (Информация об In-RIP треппинге) кнопку Create (Создать).

Основная функция этого диалогового окна — задание диапазона страниц публикации для создаваемой зоны треппинга. В поле Page(s) (Страница(ы)) задаются номера страниц зоны треппинга, а в списке Style (Стиль) — имя стиля треппинга, который следует использовать. Флажок Trapping enabled (Включен) позволяет указать страницы, не требующие треппинга.

Все созданные зоны треппинга будут приведены в списке Trap zones (Зоны треппинга) диалогового окна In-RIP Trapping Information (Информация об In-RIP треппинге).

Примечание

Получив из типографии готовые оттиски, внимательно проверьте правильность треппинга. Если на какой-либо странице вы заметите ошибку, сразу исправьте соответствующий стиль треппинга. Тогда при повторном использовании этого стиля в другой публикации вы уже не повторите допущенной ошибки. Вскоре у вас обязательно составится библиотека из надежных, проверенных на практике стилей треппинга.


Резюме

Пусть трудности, возникающие при работе с цветными публикациями, не заставят вас отказаться от использования цветной печати. Основным правилом при работе с цветом является тщательная проверка результатов на каждом этапе, об этом рассказывается в гл. 22. Для лучшего понимания принципов работы обратите внимание на материал гл. 19, в которой рассмотрены цветовые модели. Не забывайте о необходимости постоянного контроля над процессом печати. Поддерживайте хорошие отношения с типографией, ее сотрудники могут дать вам множество ценных советов. Сотрудничеству с типографией посвящена гл. 24.


  • ЧАСТЬ VI. ОРИГИНАЛ-МАКЕТ
    • Глава 22. Корректура
      • Визирование
      • Подготовка текста
        • Стадии подготовки издания
        • Формальная процедура подписания в печать
      • Применение лазерного принтера для вывода контрольных отпечатков
        • Миниатюры
        • Печать композитных оттисков
        • Черновой режим печати
      • Проверка файлов перед передачей материала в сервис-бюро
        • Проверка PostScript-файла
        • Контрольный вывод файла на лазерный принтер
        • Проверка на наличие в макете потенциально аварийных ситуаций
        • Программа обработки ошибок PostScript
      • Корректура цветных изображений
        • Проверка результатов цветоделения при помощи лазерного принтера
        • Пробные оттиски на цветном принтере
        • Критерии оценки качества продукции
        • Композитные и деленные цветные контрольные оттицки
        • Условия для оценки цветовоспроизведения
      • Проверка цветоделенных пленок
      • Проверка публикации в типографии
        • Образцы краски и лака
        • Проверка фотоформ в типографии
        • Синьки
        • Пробные оттиски с печатной машины
        • Сигнальный экземпляр
      • Резюме


ЧАСТЬ VI.

Оригинал-макет

  • Глава 22. Корректура
  • Глава 23. Вывод оригинал-макета
  • Глава 24. Сотрудничество с типографией


ГЛАВА 22.

Корректура

В настоящей главе рассматриваются следующие вопросы:

  • Необходимость своевременной корректуры. Визирование.
  • Редакторская правка и корректура текстов. Виды корректуры.
  • Проверка правильности размещения текстов и графики на страницах публикации. Вывод пробных отпечатков на композитном принтере, особенности отпечатков на принтере. Формальная процедура подписания в печать.
  • Проба цветоделения на лазерном принтере. Проверка PostScript-файла в программе Adobe Acrobat. Использование специального программного обеспечения для проверки цветоделения.
  • Проверка фотоформ, полученных из сервис-бюро. Отпечатки на цвето-пробном автомате и оценка необходимости проведения цветопроб.
  • Анализ образцов печатных красок.
  • Пробный оттиск в типографии, его анализ. Наиболее распространенные виды брака при печати.

Этап подготовки издания, рассматриваемый в этой главе, необходим при издании любых публикаций — от офисной документации до газет и книг. Все готовящиеся к печати документы должны быть тщательно и неоднократно проверены. Нем дальше продвигается процесс издания, тем сложнее и дороже сделать исправления. Исправление незамеченной опечатки после вывода форм на фотоавтомате зачастую приводит к колоссальным временным и финансовым затратам.


Визирование

Здесь уместно подчеркнуть важность организаций, работы с заказчиком. Предъявление пробных отпечатков на лазерном принтере, предназначенных для целей корректуры, во многих случаях не влечет за собой никаких попыток проверки и исправления неточностей со стороны клиента. Он бывает очень доволен и благословляет публикацию в тираж. Однако, увидев пробные оттиски из типографии, а иногда и готовый тираж, этот же самый человек начинает тщательно проверять публикацию, а найдя в ней опечатки, погрешности верстки, другие ошибки, сделанные по вашей или по его вине, объявляет о необходимости их исправления. Последнее может быть проведено только путем перепечатки тиража за ваш счет. Описанной ситуации можно и нужно избегать. Сделать это, как ни странно, в большинстве случае весьма просто. Организуйте систему визирования любого пробного отпечатка заказчиком. Каждый пробный оттиск, от корректуры текста до цветопроб, должен иметь подпись клиента на каждой странице. На каждом оттиске должна стоять пометка вашей рукой: что именно заказчик утверждает — текст, расположение элементов верстки (макет), цветовое решение или оригинал-макет в целом. Заказчик должен быть ознакомлен с возможностями легкой погрешности цвета в типографии и с тем, что отпечаток на цветном принтере и даже цветопроба не дают абсолютно точной цветопередачи. Лучше, если это тоже будет где-то записано и подписано клиентом, например на конверте, куда вкладываются цветопробы и фотоформы. На первых порах работы по выпуску публикаций не делайте исключений ни для одного заказчика, требуйте визы даже со своих знакомых. Если вас обвинят в педантизме, можно сослаться на порядок, заведенный руководством фирмы. Вероятность того, что эти визы вам пригодятся, крайне низка. Зато в случае конфликта вы будете обладать оружием, по мощности сравнимым с ядерным. Как убедились авторы книги, факт подписания пробного оттиска весьма полезен и для общего дела — печати качественной публикации, поскольку заставляет клиента более ответственно отнестись к корректуре. А лишняя пара глаз, да еще таких заинтересованных, в любом случае не повредит.


Подготовка текста

Текст публикации, набранный без лексических, грамматических и пунктуационных ошибок и опечаток, — непременное требование к любому изданию. Даже если заказчик согласен с низким уровнем подготовки издания в пользу сокращения ее сроков, не пропускайте никаких стадий корректуры. По качеству подготовки текста и верстки о вашем издательстве будут судить другие потенциальные заказчики.

Набранный в текстовом процессоре текст публикации обработайте программой проверки грамматики. Такие программы есть в локализованных версиях текстовых процессоров, например Microsoft Word. Они несовершенны, однако обратят ваше внимание на грубые ошибки и явные ляпсусы. Проверку орфографии также можно организовать в текстовом процессоре. В PageMaker имеется встроенная программа проверки орфографии, а значит, проверить правописание можно и после импорта текста в PageMaker. Разумеется, что "проверка правописания должна предшествовать верстке, поскольку при исправлении ошибок возможны подвижки текста.

Наличие корректора не снимает необходимости проверки орфографии, а может быть, и грамматики. Если публикация велика, то такая проверка устранит грубые ошибки и впоследствии будет легче разобраться в первой корректуре. А если размер документа невелик или он не очень ответственный (документы для использования внутри фирмы, мелкая полиграфия — этикетки, открытки, визитки, брошюры и другие небольшие публикации), то вычитка текста корректором не производится и самостоятельная вычитка будет единственным методом подготовки текста перед выпуском. При вычитке придерживайтесь следующих правил.

  • Проверка текста делается по бумажному отпечатку. На бумаге опечатки и ошибки видны гораздо лучше, чем на экране. Для корректуры распечатайте публикацию.
  • Тот, кто делает набор, обязательно пропустит ошибки при вычитке. Для проверки текста нужен "свежий глаз". Подготовьте макет для проверки и отдайте его другому человеку, пусть почитает. Если публикация ответственная, лучше, чтобы проверяющих было двое — они проверят текст по очереди. Не забудьте о проверке оттиска клиентом и подписании в печать.

Примечание

Еще один способ проверки важных данных в публикации (например, таблиц) — проверка вдвоем: один из проверяющих читает оригинал вслух, другой вносит исправления.


Стадии подготовки издания

После представления авторского оригинала в издательство, его рецензирования и положительного решения о его издании рукопись должна проделать длинный путь до готовой книги. В разных издательствах принят различный порядок подготовки публикации. Однако в общем случае эта процедура такова:

  1. Сначала автор представляет рукопись редактору. Редактор производит наиболее серьезные изменения в произведении, относящиеся к структуре, методами изложения, стилю и другим основополагающим моментам публикации. Все изменения он обсуждает с автором, и последний осуществляет доработку в соответствии с рекомендациями редактора.
  2. После этого рукопись приходит в набор и профессиональные машинистки набирают текст в текстовом редакторе. Так возникает текст публикации. Часто стадия набора в издательстве вообще отсутствует, поскольку автор представляет рукопись в электронном варианте.
  3. Набор поступает на первую корректуру. Данная корректура представляет собой сверку набора с оригиналом и исправление замеченных опечаток.
  4. На следующей стадии редактор тщательно проверяет текст публикации на отсутствие противоречий, сверяет ссылки, исправляет погрешности стиля, составляет список личных имен, названий и сложных слов для корректора. Сам редактор или верстальщик вносит исправления в набор по согласованию с автором.
  5. Набор отправляется на корректуру. Для редакторской правки и корректуры необходима бумажная распечатка публикации, которая осуществляется до макетирования. Для первой и второй корректуры качество печати публикации роли не играет. Корректор исправляет ошибки, а также частично делает стилистическое редактирование, если что-либо было пропущено редактором.

Примечание

Для корректуры нужно нанять работника — профессионального корректора. Наем такого человека можно осуществить в машинописных бюро, крупных издательствах и типографиях. Профессионализм корректора очень важен для качества публикации, хороших корректоров не так уж много. С корректором обычно заключается договор, в котором обязательно указываются сроки, подробно описываются вид работы и ее стоимость. Стоимость корректуры колеблется в зависимости от типа и срочности. Различают простейшую корректуру — исправление орфографических и грамматических ошибок, стилистическую правку и сверку — сличение набора с оригиналом. Сверка обязательна в случае издания художественных, особенно классических произведений.

  6. После корректуры рукопись возвращается для внесения исправлений, перед которым редактор согласовывает те или иные исправления корректора, снимает его вопросы.
  7. После внесения исправлений верстается макет. Если работа заказная, самое время показать ее клиенту и утвердить текст будущей публикации.
  8. После этого публикацию печатают для второй корректуры (в случае обычного, не сокращенного процесса подготовки издания). Обратно возвращаются две пачки листочков — первая из них чистая, без исправлений, вторая требует внесения не замеченных или не внесенных в прошлый раз исправлений. Обратите внимание, что макет уже существует, и исправления желательно проводить без подвижек текста.
  9. Далее макет печатается целиком и отсылается на подписную корректуру. Подписная корректура должна быть отпечатана качественно. Обратно возвращаются чистые листы макета, без исправлений, и на каждом листе стоит подпись корректора. Это значит, что корректор проверил каждую букву публикации и гарантирует высокое качество публикации с точки зрения русского языка. Изменения в макете после подписной корректуры нежелательны.


Формальная процедура подписания в печать

О необходимости утверждения работы заказчиком было сказано в начале главы. Позаботьтесь о том, чтобы на каждой странице подписной корректуры публикации стояла подпись клиента. Обязательно сообщите ему о важности этого этапа подготовки издания и о том, что в дальнейшем внести исправления в публикацию будет очень трудно и делаться это будет за его счет. Вообще, чем более формализована будет процедура подписания в печать, тем лучше. В разделе, посвященном выпуску цветных публикаций, мы остановимся на особенностях утверждения пробных отпечатков при цветной печати.


Применение лазерного принтера для вывода контрольных отпечатков

В вашем распоряжении уже имеется недорогой и надежный инструмент для изготовления контрольных оттисков макета — лазерный принтер. В следующих разделах рассматриваются различные способы его применения для получения контрольных оттисков.


Миниатюры

Контрольный оттиск, на котором представлено по несколько страниц издания на листе в уменьшенном виде, дает возможность оценить внешний вид публикации в целом (см. гл. 23). Если вы воспользовались оборотной печатью, то на одну страницу пробного оттиска можно выводить разворот с двумя смежными страницами.


Печать композитных оттисков

Для получения общего представления о макете, даже многоцветном, можно отпечатать публикацию совмещенным оттиском на лазерном принтере.


Черновой режим печати

Если контрольный оттиск делается для корректуры текстовой части макета (переносов, кернинга, разбиения на строки), установите в диалоговом окне Print Document (Печатать документ) флажок'Proof (Черновик). В таком режиме вывода PageMaker заменяет все импортированные графические изо-

бражения перечеркнутыми косым крестом прямоугольниками, что значительно сокращает время вывода на печать (особенно — сложных макетов и объемных публикаций).


Проверка файлов перед передачей материала в сервис-бюро

При подготовке файла к передаче в сервисное бюро вам, разумеется, захочется посмотреть, как будет выглядеть страница публикации на пленках, отпечатанных на фотонаборном автомате. Такая информация может быть получена различными способами, с разной степенью достоверности.


Проверка PostScript-файла

Приблизительное представление о результатах может дать просмотр генерированного PageMaker PostScript-файла публикации с помощью пакета Adobe Acrobat. Полученный после генерации файл обработайте программой Adobe Acrobat Distiller, а затем просмотрите данный PDF-файл в программе просмотра Acrobat Reader. Обе эти программы входят в комплект PageMaker (см. гл. 18). Обязательно просмотрите полученный PostScript-файл на предмет правильности цветоделения, корректности макета, наличия служебной информации — меток обрезки, приводных крестов, сведений о форме и др. Этой цели служат приемы, описанные в последующих разделах.


Контрольный вывод файла на лазерный принтер

Вывод PostScript-файла на лазерный принтер преследует две цели. Во-первых, это дополнительная проверка качества цветоделения и правильности макета. Во-вторых, с помощью вывода на лазерный принтер производится проверка принципиальной возможности вывода файла на печать. Если ваш лазерный принтер не печатает макет, его необходимо переработать. Найдите причину отказа и добейтесь, чтобы макет выводился без ошибок. Если макет публикации не удается вывести на лазерный принтер с разрешением 300 или 600 dpi, можно почти с полной уверенностью утверждать, что точно так же, аварийно, закончится и его вывод на фотонаборный автомат с разрешением 3600 dpi.


Проверка на наличие в макете потенциально аварийных ситуаций

В гл. 23 дается перечень нежелательных ситуаций, которые могут привести к аварийному завершению вывода на печать. Проверьте макет публикации на экране в соответствии с этим перечнем, отыскивая в нем сложные графические изображения, маски обрезки, вложенные описания гарнитур и файлы в формате EPS, злоупотребления приемом поворота объектов средствами PageMaker и т. д. По мере возможности устраните эти "мины замедленного действия" до передачи материалов в сервисное бюро.


Программа обработки ошибок PostScript

В PageMaker имеется встроенная программа обработки ошибок PostScript (см. режим Options (Варианты) диалогового окна команды Print (Печатать)). Если в процессе предварительного вывода на лазерный принтер возникла аварийная ситуация, этой программой обязательно следует воспользоваться — она поможет обнаружить причину ошибки.

Перед выводом публикации в файл на диске узнайте в сервисном бюро, следует ли включать в его состав программу обработки ошибок PostScript. Возможно, сервисное бюро предоставит вам используемую ими программу обработки ошибок PostScript для включения в файл. Для того чтобы воспользоваться ею, необходимо скопировать файл программы в языковую папку, вложенную в папку РМ65. Имя файла программы следует изменить на P65ERROR.PS.


Корректура цветных изображений

Корректура цветных изображений до настоящего времени остается одной из самых сложных задач в издании публикации. Дело в том, что внешний вид будущей цветной публикации остается загадкой вплоть до пробных оттисков на офсетной машине. Любые пробные отпечатки дают лишь приблизительное представление о том, что вы увидите в тираже. Однако, кроме сюрпризов цветопередачи и приводки цветов, которыми вас может "порадовать" типография, возможны сбои и ошибки, которые вы можете и должны предотвратить. Очень важна корректность фотоформ, по которым будет осуществляться процесс печати. Для того чтобы формы были корректны, вы должны правильно осуществить цветоделение и создать верный PostScript-файл. Для осуществления правильного деления публикации на формы необходимо, чтобы правильно были заданы атрибуты цвета каждого цветного элемента публикации. Итак, начнем проверку публикации.


Проверка результатов цветоделения при помощи лазерного принтера

Выведите цветоделенные формы прямо из публикации на обычном лазерном принтере. Не забудьте включить отображение типографских меток и информации о странице. Установите режим цветоделения. Все эти параметры задаются в диалоговых окнах команды Print-(Печатать). О печати документа рассказывается в гл. 23.

По отпечаткам можно судить:

  • о правильности распределения объектов, окрашенных плашечными цветами, по соответствующим формам;
  • о наличии цветоделения объектов, окрашенных составными цветами, и импортированных объектов;
  • о корректности расположения элементов макета при выводе;
  • о правильности углов растра для составных цветов.

Если элементы простых цветов расположены неправильно, проверьте присвоение цветов еще раз. Не забудьте о том, что импортированные объекты в формате EPS нежелательно окрашивать внутри PageMaker. Если импортированный объект не подвергается цветоделению, а помещается в виде полутонового изображения на черную форму, то, скорее всего, для него в исходном приложении была выбрана цветовая модель RGB. В случае неправильного цветоделения откройте диалоговое окно Links Manager (Связанные файлы) (см. гл. 11) и проверьте, в какой цветовой модели описываются импортированные объекты. Выйдите в приложение и измените цветовую модель на CMYK, а затем обновите связь с графическими файлами. Об углах растра читайте в гл. 23.


Пробные оттиски на цветном принтере

Ваша работа может быть выведена совмещенным оттиском на струйном или лазерном цветном принтере. Такой оттиск стоит недорого и может быть сделан на разных этапах работы прямо в присутствии заказчика. Отпечаток может быть выполнен на качественной бумаге и выглядит очень привлекательно. Это немаловажно, если вы работаете по заказу. Такой оттиск, конечно, не будет полностью передавать цвета настоящей публикации, что связано, прежде всего, с узостью цветового охвата типографского станка. Тем не менее оттиск на цветном принтере весьма полезен для получения общего представления о том, как публикация будет выглядеть после печати. Если ваш принтер поддерживает управление цветом, воспользуйтесь его преимуществами для эмуляции типографского оттиска на цветном принтере.

Демонстрация пробного отпечатка на принтере должна завершать подготовку макета и предшествовать выводу PostScript-файла. Попросите клиента завизировать каждую страницу публикации. При демонстрации отпечатка клиенту обязательно объясните, что цветопередача при выводе нарушена и вы показываете лишь примерный вид издания.


Критерии оценки качества продукции

Изначально следует оговорить, по каким критериям будет оцениваться публикация. Необходима ли максимально точная цветопередача или достаточно добиться приятного для глаза сочетания цветов? В первом случае вам придется уделить публикации большее внимание, начиная от сканирования и заканчивая печатью. Обязательно проведите цветопробы в сервис-бюро.

При оценке результатов сканирования цветных фотографий уделите особое внимание хорошо знакомым и нейтрально-серым цветам: погрешность в их воспроизведении сразу бросается в глаза.

Важнейшими из цветов названной категории являются телесные цвета. Они традиционно считаются наиболее трудными для полиграфии. Особого внимания передача телесных цветов требует в тех случаях, когда на одной фотографии изображены представители различных рас. Не забудьте об этой особенности фотографии при сканировании и обработке. Обязательно присутствие при печати в типографии. В противном случае цвет всех лиц на фотографии печатники могут случайно отрегулировать по какому-то одному. Представляете, какого цвета в данном случае будут лица у клиентов?..

Кроме телесных, существует множество других хорошо знакомых цветов. Каждому известно, как выглядят металлическая поверхность, апельсин, яблоко, банан, этикетка пепси-колы. Такие предметы будут выглядеть реалистично только при точном цветовоспроизведении.


Композитные и деленные цветные контрольные оттиски

В сервис-бюро вам могут предложить два типа пробных отпечатков — композитные, выведенные из файла на высококачественном цветном принтере (лазерном, термодиффузионном или струйном), и деленные, которые выполняются на цветопробном аппарате с выведенных фотоформ.

Первые гораздо дешевле, однако дают лишь приблизительное представление о конечном результате. Цветопередача профессиональных цветных принтеров, разумеется, гораздо точнее, чем "домашних", дешевых. В этом смысле на них чаще всего можно положиться. Однако принтер для цветопроб печатает, как любой принтер, из файла. Полученный отпечаток никак не оценивает качество выведенных пленок, они просто не участвуют в образовании изображения.

Ниже перечислены три типа цветных принтеров, на которых получают композитные цветопробы.

  • Цветные лазерные принтеры и копиры, оснащенные интерпретаторами PostScript и поддерживающие управление цветом. Например, совместно с копирами DocuColor фирмы Xerox используются контроллеры Fiery фирмы EFI. Они способны имитировать цвета типографских триадных красок и плашечных цветов PANTONE Process для некоторых типов бумаги.
  • Термодиффузионные принтеры (например, ЗМ Rainbow) наносят краску на специальную глянцевую бумагу.
  • Высококачественные струйные принтеры распыляют цветную краску на бумагу микроскопическими каплями (точно так же, как недорогие струйные принтеры). В сервисных бюро чаще других используются модели Iris и Stork Bedford.

Цветные и струйные принтеры могут печатать на любой бумаге, в частности на той, которую вы выбрали для печати тиража (что положительно характеризует точность цветопробы). Для термодиффузионных принтеров требуется специальная бумага.

Более точное представление о результатах печати дают цветопробы, выполненные с готовых цветоделенных форм. В зависимости от фирмы-производителя, печать осуществляется на одной (Fuji Color Arts, DuPont Cromalin или ЗМ Matchprint) или нескольких (DuPont Chromacheck, 3M ColorKey) цветных прозрачных пленках. Такие "сухие" пробы позволяют адекватнее судить о цветах печати, правильности растрирования, цветоделения и треп-пинга. Тем не менее только печать на вашей бумаге покажет реальные цвета исходной печати.

Печатные цветопробы, т. е. деленные цветные оттиски, выполняемые с ваших фотоформ на дорогом и сложном оборудовании — цветопробном аппарате, — в настоящее время наиболее совершенный способ проверки фотоформ перед печатью в типографии. Оттиск производится офсетными красками на заказанной вами бумаге с ваших рабочих фотоформ. Таким образом, по отпечатку можно судить обо всех особенностях форм — цветопередаче, треппинге, качестве растрирования и прочих характеристиках. Именно так, как отпечатана цветопроба, должен быть отпечатан тираж, если в типографии ответственно отнесутся к своим обязанностям и не произойдет сбоя печатной машины. В принципе, вы получаете первую "настоящую" копию вашей публикации. Вот так она и будет выглядеть.

Эта технология очень дорога в связи с большими затратами времени и материалов на подготовку пробы и приладку форм. Советуем вам делать цветопробы на первых порах работы с сервис-бюро и типографией, пока вы не уверены в качестве их работы. Также можно сделать цветопробу в очень ответственном случае.


Условия для оценки цветовоспроизведения

Цветовосприятие очень сильно зависит от освещения. Оценку качества цветовоспроизведения следует производить при хорошем освещении, в некоторых сервис-бюро и типографиях имеются специальные колориметрические кабины со стандартным освещением. Как правило, условия освещения в колориметрической кабине соответствуют естественному свету в полдень.


Проверка цветоделенных пленок

Проверяя готовые цветоделенные пленки, обращайте внимание на следующее.

  • Общее качество пленок: отсутствие царапин, полос. Убедитесь, что прозрачные области действительно не содержат растра, а плотность сплошных заливок равномерна.
  • Проставлены все типы типографских меток и, при необходимости, дополнительные метки для разрезания малоформатных изданий (этикетки, билеты, листовки и т. п.).
  • Количество пленок точно соответствует предполагаемому количеству печатных красок. Все пленки маркированы и содержат информацию о цвете формы.
  • Правильность размеров страниц.
  • Объекты, печатающиеся навылет, действительно выходят за пределы меток обрезки.
  • Все объекты правильно разделены на формы.
  • Проверьте денситометром максимальную плотность черного.
  • Правильно ли сделаны выворотки.
  • Треппинг присутствует, и только там, где он предполагался. Поскольку на композитном оттиске не используется разделение цветов по слоям, границы цветовых объектов всегда стыкуются идеально и цветовые растяжки воспроизводятся без погрешностей. Отсутствие смешения красок на листе не позволяет выявить на композитном оттиске некоторые вызываемые этим явлением нежелательные эффекты.

Примечание

Если у вас есть полная версия Adobe Acrobat 5.0, то вы можете проверить качество треппинга, создав PDF-файл. Команда Overprint Preview (Просмотр наложения цветов) меню View (Просмотр) позволяет просмотреть результат треппинга в композитном оттиске.

Правильность углов растра и отсутствие муара. Муа р (см. гл. 21) — типографский брак на растрированием изображении, возникающий из-за некорректного цветоделения. Возникновение муара на цветных изображениях связано с наложением цветных растров при офсетной печати. Печать на принтере осуществляется другими -.методами, и проследить возникновение муара невозможно.


Проверка публикации в типографии

Когда публикация "выходит из-под контроля" и ею начинают заниматься печатники, не следует опускать руки и ждать тиража. Кое-что вы можете сделать для проверки подготовки публикации даже на заключительном этапе.


Образцы краски и лака

Да простят нас типографы за то, что мы еще раз подчеркнем необходимость лишней проверки их действий. Для полной уверенности в правильном подборе красок для публикации (особенно плашечных) соберите их образцы Вначале попросите нанести образец краски на лист бумаги, подготовленный для печати тиража. Это делается при помощи специального ножа или резинового валика. Такой образец дает полное представление о том, как краска сочетается с бумагой.

Рекомендуем подобрать те сорта бумаги, которыми вы постоянно пользуетесь в издательской деятельности, и выполнить такие пробы краски в типографии — они дадут более достоверное представление о результатах цветной печати, чем стандартные "веерные" образцы плашечных цветов. Можно специально для этого составить публикацию PageMaker, в которой будут использованы все цвета и оттенки, с которыми вам приходится чаще всего работать, и пропустить ее через сервисное бюро, получив фотоформы, после чего напечатать эту специальную публикацию. Можно напечатать такую пробную публикацию совместно с какой-либо другой, воспользовавшись свободными краями типографских печатных форм. Обязательно проверьте, каким образом нанесение лака на оттиск меняет его внешний вид. Если вы пользуетесь лаком для глянцевания издания, проверьте, насколько темнее смотрятся под лаком образцы краски.


Проверка фотоформ в типографии

Технолог типографии обладает всеми знаниями, необходимыми для компетентной проверки фотоформ, изготовленных в сервисном бюро. Даже если фотоформы уже проходили выходной контроль в сервисном бюро, в типографии их могут проверить люди, сотни, а может быть, тысячи раз сравнивавшие фотоформы с полученными по ним на данной печатной машине оттисками.


Синьки

Синьки предназначены для проверки правильности подготовки сигнатуры (см. гл. 23) к фальцовке и обрезке. Это — единственный тип контрольного оттиска, по которому можно проверить правильность соответствия страниц при оборотной печати. Важность такой проверки очевидна для книг, но она важна и для брошюр, складывающихся "гармошкой", и даже для почтовых открыток. Представьте, например, открытку, передняя сторона которой ориентирована по горизонтали, а задняя — по вертикали.

Синьки выпускают методом светокопирования. Фотоформы собираются в сигнатуры, после чего экспонируются на светочувствительную бумагу методом контактной печати. Эти сигнатуры используются в технологическом процессе подготовки печатных форм. Таким образом, синька — это последний контрольный оттиск перед печатью. Поскольку перед выпуском синьки сигнатуры, составленные из печатных форм, соответствующих различным цветам, собираются в пакет, по синьке судят о правильности спускового макета для всех цветов. Сами же синьки, как нетрудно догадаться из их названия, имеют синий цвет.


Пробные оттиски с печатной машины

Даже если вам не приходилось работать с публикациями, предъявляющими особые требования к качеству воспроизведения цвета, постарайтесь хотя бы однажды поприсутствовать при выдаче пробного оттиска печатной машиной. Это лучший способ познакомиться с процессом переноса изображений на бумагу печатной машиной.

Постарайтесь заранее настроиться на сотрудничество с бригадой, обслуживающей печатную машину: ваша общая цель — получение наилучшего результата.

Вас приглашают в печатный цех к тому времени, когда подготовка машины должна быть завершена, поэтому постарайтесь не опаздывать. После запуска машины обычно выполняются технологические оттиски, по которым производится окончательная настройка. Внешне это выглядит как выбрасывание в брак листа за листом (при работе машины с листовой подачей) или метра за метром (машины с рулонной подачей) бумаги.

По завершении настройки машина закрывается и выпускается пробный оттиск. Нет времена пытаться найти в нем опечатки — это должно быть сделано давным-давно. На данном этапе вам необходимо убедиться в том, что все цвета воспроизведены достаточно точно и на оттиске отсутствуют очевидные дефекты. Вы должны завизировать контрольный оттиск, и в дальнейшем по нему будут выполняться все последующие настройки при печати тиража.

Как следует работать с контрольным оттиском? Задавайте вопросы технологу типографии и очень внимательно рассматривайте лист, сошедший с печатной машины.

Внимательно просмотрите весь контрольный оттиск и убедитесь, что цветовоспроизведение соответствует ранее утвержденному критерию точности. Если на оттиске имеются объекты, цвет которых должен быть воспроизведен с высокой точностью (логотипы компаний, образцы цвета для каталога системы цветов), сравните их с эталонами в условиях стандартного освещения. Не доверяйте собственной памяти.

Постарайтесь отыскать физические дефекты, возникшие в процессе печати. Морщины на оттиске, просачивание краски с противоположной стороны страницы, смазанные места, вызванные попаданием волос или грязи на печатные формы, кляксы, следы не до конца высохшей краски, перешедшей с соседнего листа, — наиболее распространенные дефекты.

К проверке контрольного оттиска следует подходить очень ответственно. Постарайтесь максимально сконцентрироваться, чтобы не пропустить каких-либо ошибок. Помните, что грубая ошибка на этом этапе загубит весь тираж. Сосредоточьтесь на выявлении тех огрехов, которые может исправить печатник, таких как плотность красок, цветовой баланс и равномерность покрытия. При проверке ответственных изданий используйте денситометр.

Примечание

Имейте при себе образцы цвета для сравнения с контрольным оттиском. Если публикация предъявляет повышенные требования к качеству цветовоспроизведения, принесите с собой оригинал. Если на оттиске имеется фотография какого-либо изделия, лучше сравнить оттиск непосредственно с этим изделием. Обязательно имейте при себе ранее сделанные образцы красок. Если проверяется не первый контрольный оттиск, принесите ранее сделанные и завизированные контрольные оттиски.

Лучше всего, когда оригиналы или образцы предъявляются в типографию в самом начале сотрудничества с ней. На этапе передачи фотоформ и контрольных оттисков в типографию их предъявление просто обязательно. В идеальном варианте типография должна располагать собственным набором образцов.


Сигнальный экземпляр

При работе с многостраничными документами типографии выпускают сигнальные экземпляры — сфальцованные контрольные оттиски, позволяющие проверить спусковые макеты после фальцовки и обрезки. Это уже настоящая книжка, именно такой вид будет иметь весь тираж. Сигнальные экземпляры присылают в издательство. После проверки издательства на них ставятся печать типографии и подпись ответственного за выпуск. После утверждения сигнальных экземпляров печатается тираж книги.


Резюме

Более подробно с технологией выпуска печатной продукции вы можете ознакомиться в гл. 23 и 24. Разумеется, для проведения качественной корректуры цветных изданий необходимо изучить основы теории цвета, рассмотренные в гл. 19. При выпуске многостраничных публикаций вам понадобится материал гл. 17.

Важность этапа корректуры для публикации невозможно переоценить. При тщательно организованной системе всесторонней проверки качества продукции вы сэкономите массу времени, нервов и денег — своих, своего начальника и клиента.


  • Глава 23. Вывод оригинал-макета
    • PostScript или не-PostScript?
    • Драйверы принтеров и PageMaker
    • Печать на лазерном принтере и фотонаборном автомате
      • Установка параметров раздела Document
      • Установка параметров раздела Paper
      • Установка параметров раздела Options
      • Установка параметров раздела Features
      • Особенности He-PostScript-принтеров
      • Установка параметров раздела Color
    • Команда Print и стили печати
    • Растрирование и цветоделение
    • Зачем нужно растрирование
      • Зачем нужно цветоделение
      • Линейные растры
      • Параметры растра
        • Линиатура и количество градаций серого
        • Линиатура и качество бумаги
        • Цветоделение и растрирование
        • Линиатура и разрешение точечных изображений
      • Стохастические растры
      • Цветная печать
        • Цветоделение
        • Генерация черного
      • Особые предосторожности
        • Размеры растровой точки
        • Тонкие линии
        • Растяжки
    • Разработка спускового макета
      • Верстка спускового макета — непростое дело
      • Предварительные действия
      • Построение буклета
    • Предоставление макета в сервис-бюро
      • Передача верстки в сервис-бюро
      • Какие файлы требуются для печати в сервис-бюро
      • Вывод PostScript-файла
    • Профилактика неполадок на этапе вывода
      • Пользуйтесь советами специалистов
      • Устранение избыточной сложности выходного файла
      • Масштабирование и кадрирование до размещения изображений в публикации
      • Проблемы при выводе невидимых фигур
      • Сложности при выводе графических объектов
      • Сложности вывода при использовании маскирования
      • Текст, вложенный в файлы EPS
      • Поворот изображений в PageMaker
      • Шрифты TrueType и файлы WMF (EMF)
      • Количество переходов в цветовых растяжках
    • Резюме


ГЛАВА 23.

Вывод оригинал-макета

Одна из самых больших глав этой книги посвящена выводу оригинал-макета. Этот факт не случаен: данная стадия подготовки публикации очень ответственна, т. к. после вывода ничего "подправить" уже нельзя! Кроме того, на стадии вывода необходимо учитывать множество технологических аспектов типографской печати и фотонабора. Здесь мы обсудим следующие проблемы:

  • Возможности языка PostScript
  • Установку драйверов PostScript и их использование PageMaker
  • Линейные растры и параметры растрирования
  • Вывод макета на лазерный принтер и фотонаборный автомат
  • Профилактику брака на стадии вывода макета
  • Спусковые макеты

Невнимание к этим вопросам может катастрофически повлиять на выпуск публикации. Если вы новичок в издательском деле, то материал данной главы поможет избежать таких дорогостоящих ошибок, как повторный вывод макета или переделка тиража.


PostScript или не-PostScript?

Поскольку эта глава целиком посвящена выводу оригинал-макета, нельзя не сделать несколько общих замечаний относительно ее главного действующего лица — принтера. Под принтером мы подразумеваем любые принтеры и фотонаборные автоматы. В сущности, фотонаборный автомат является очень сложным и "интеллектуальным" принтером и вывод на нем ничем не отличается от вывода на офисный лазерный PostScript-принтер.

Как мы уже неоднократно отмечали, с точки зрения издательских систем принтеры подразделяются на две неравные категории — PostScript и не-PostScript. Во вторую попадают все матричные (помните такое слово?) и струйные принтеры, а также лазерные и термодиффузионные принтеры и плоттеры, не имеющие поддержки PostScript. Они составляют большую часть парка принтеров, используемых на сегодняшний день.

Речь при этом идет об аппаратной поддержке PostScript, т. е. в этих принтерах отсутствует интерпретатор PostScript, реализованный в виде электронной схемы. В последнее время с ростом вычислительной мощности персональных компьютеров происходит постепенный переход от аппаратной реализации интерпретаторов PostScript к программной. Наиболее часто программная интерпретация используется в фотонаборных автоматах. Это связано с очень высокой стоимостью аппаратного интерпретатора для устройств с таким огромным разрешением печати. Значительно дешевле оказывается приобрести отдельный мощный компьютер и запустить на нем программу растрового процессора (RIP— Raster Image Processor). Кроме.того, программная реализация позволяет включить в RIP дополнительные возможности, такие как предварительный просмотр PostScript-файлов на экране монитора, организация сетевых интерфейсов и очередей печати.

Программные растровые процессоры имеются и для He-PostScript-прин-теров, например интерпретаторы Freedom of Press (ColorAge Inc.), ZScript (Zenographics Inc.), Image Alchemy PS (Handmade Software) и др. Для лазерных принтеров стоимость аппаратного PostScript-интерпретатора пока не на много больше стоимости программных, что обуславливает их большую популярность. Аппаратная поддержка обыкновенных лазерных принтеров имеет и ряд преимуществ: высокая скорость работы, использование оригинальной технологии Adobe, освобождение процессора компьютера от задачи интерпретации PostScript.

В издательском деле PostScript-принтеры составляют большинство используемых устройств печати. PostScript предоставляет столь важные для издательских нужд возможности, такие как задание параметров растрирования, печать импортированных EPS-изображений, поддержка PostScript-шрифтов, точная обработка развернутых, кадрированных изображений и т. п. Если у вас нет PostScript-принтера, вы не сможете использовать весьма значительную часть возможностей любых издательских программ, в том числе и PageMaker. Поэтому, если ваш принтер не оборудован интерпретатором PostScript, мы настоятельно рекомендуем купить его. Как правило, интерпретаторы PostScript поставляются и отдельно в виде модуля (печатной платы с разъемами) с набором микросхем. Модуль может быть вставлен в слот расширения внутри принтера. За более подробными инструкциями обратитесь к руководству пользователя, которым ком-плектовался принтер, или к его продавцу.

Еще раз перечислим те возможности, которые имеют только PostScript-принтеры.

  • Задание параметров растрирования при печати: линеатуры и углов растрирования для каждой выводимой формы. PCL (Printer Control Language) позволяет задавать параметры растрирования только для композитной печати и не позволяет вывести цветоделение. Все цветоделенные формы будут иметь одинаковые линеатуры и углы растра.
  • Шрифты Туре 1 загружаются в принтер непосредственно. При печати на прочих принтерах будут преобразованы в контуры.
  • Инверсный текст отображается адекватно. Прочие принтеры требуют для этого печати шрифтов как графики, что значительно увеличивает время печати и требует больших ресурсов принтера.
  • Повернутые и искаженные изображения выводятся на печать без погрешностей с высокой точностью. PCL-принтеры редко столь успешно справляются с такими изображениями.
  • Импортированные EPS-изображения будут напечатаны с высоким качеством. Прочие принтеры, будучи не способны использовать информацию из внешних PostScript-файлов, печатают лишь ту же миниатюру, которую вы видите на экране. Чтобы напечатать такую графику на не-PostScript-принтере с более высоким качеством, нет иного выхода, как создать миниатюру с более высоким разрешением. PageMaker позволяет это сделать при импорте файлов формата EPS (см. гл. 10).


Драйверы принтеров и PageMaker

He-PostScript-принтеры используют свои особые драйверы. Если вы обладатель популярной модели принтера, то, скорее всего, вам не понадобится прилагаемый к нему драйвер: подходящий найдется в комплекте Windows. В противном случае, установите прилагаемый к принтеру драйвер, согласно руководству пользователя принтера. Поскольку аппаратные возможности принтеров и их конструкция сильно отличаются, драйверы также имеют различные настройки.

Драйвер PostScript в Windows, PSCRIPT.DRV, является универсальным. Он используется любым PostScript-принтером, будь то офисный принтер или фотонаборный автомат. Мы, вместе с фирмой Adobe, не рекомендуем использовать драйвер, входящий в комплект Windows. Он содержит довольно много коварных ошибок, которые могут привести к неожиданным результатам на выводе. Microsoft Corporation в сотрудничестве с Adobe Systems выпустили новый драйвер PostScript для Windows. На дистрибутивном CD-RQM PageMaker 7.0 в папке \Print Drivers находятся драйверы Adobe PostScript версии 4.5.1 (для Windows 9х/МЕ) и версии 5.0 (для Windows 2000/NT). Там же находится и руководство по этому драйверу.

Драйвер PostScript универсален и работает с любым принтером, поддерживающим PostScript Level 2 и PostScript Level 3. Чтобы учесть аппаратные особенности вашей модели принтера, драйверу необходим файл ее описания. Файлы описаний PostScript-принтеров имеют расширение PPD (PostScript Printer Defenition) и прилагаются к любому принтеру его производителем. Для печати на PostScript-принтер PageMaker требует обязательного наличия соответствующего ему PPD-файла в каталоге \<каталог PageMaker>\RSRC \<языковой каталог>\РРО4. После установки драйвера принтера обязательно поместите файл описания PPD в этот каталог.

Примечание

Драйвер PostScript, прилагаемый к PageMaker, не поддерживает PostScript Level 1. Поэтому обладателям старых принтеров следует пользоваться одной из старых версий драйвера, например 4.1.1.

Примечание

Драйвер Adobe PostScript не использует SPD-файлы описаний принтеров, поставляемые с Windows 95 и Windows NT. PPD-файлы представляют более развернутое описание PostScript-принтера, необходимое для работы издательских программ. Издательские программы, в т. ч. PageMaker, также изначально ориентированы именно на описания PPD. Они использовали эти описания еще в эпоху Windows З.хх.

Большинство из сказанного выше справедливо и для компьютеров Macintosh. На них тоже используется универсальный драйвер PostScript производства Adobe Systems. К PageMaker прилагается драйвер версии 8.7.1.

Если вы произвели модернизацию принтера, установив в нем дополнительную память или шрифтовые картриджи, то для того, чтобы программы могли использовать эти новые ресурсы, вам придется отредактировать PPD-файл самостоятельно. Для этого предназначена отдельная программа Update PPD, которая поставляется вместе с PageMaker. Для того чтобы она оказалась на жестком диске, надо разрешить установку этой программы при инсталляции PageMaker (см. приложение 1). Размещается она в подкаталоге Extras\Print каталога программы PageMaker.

Если вы, например, установили в принтер дополнительную память, выберите имя принтера в списке PPD to update (Обновляемый PPD) и нажмите кнопку Edit VM (Редактировать VM).

Кнопка Print (Печать) заставит принтер напечатать количество имеющейся у него свободной памяти. Эта цифра не соответствует размеру физической памяти принтера, а отражает ресурсы виртуальной машины (VM) интерпретатора PostScript. Полученную таким образом цифру следует ввести в поле

New VM setting (Новые установки VM) этого же диалогового окна. Нажатие кнопки ОК закроет окно Edit VM (Редактировать VM). Если теперь в главном окне программы нажать кнопку Save (Сохранить), то измененные параметры будут сохранены в файле, имя которого указано в поле Custom PPD file name (Имя файла PPD). Новый файл описания будет иметь псевдоним, который вы укажете в поле Custom PPD nickname (Имя файла PPD).

Примечание

Кроме обыкновенного имени, PPD-файлы имеют более информативные псевдонимы. PPD-файлы должны иметь имена в стандарте DOS (8 символов), что делает очень сложным их понимание. Информация о псевдониме находится внутри самого PPD-файла и используется приложениями для отображения в списке принтеров.

Откорректированный PPD-файл не является самодостаточным. Он является лишь дополнением к исходному, без которого не имеет смысла, поскольку хранит только внесенные изменения. Тем не менее при печати выбирать нужно именно его, а не исходный файл.

Полученные PPD-файлы используются при установке принтера. Программа установки Adobe PostScript после установки собственно драйвера принтера запрашивает имена PPD-файлов принтеров, которые необходимо установить. На основе этой информации она определяет в стандартной папке Windows (Printers) новые принтеры, обращение к которым производится стандартным для Windows способом — выбором нужного принтера из их списка в окне Print (Печатать) любого приложения. Издательские приложения, кроме выбора соответствующего принтера, требуют также указания PPD-файла, в котором хранится его описание. Это сделано с целью хранения в различных PPD-файлах разных настроек для одного устройства вывода. Данные настройки не ограничиваются приведенной выше установкой виртуальной памяти. Для более сложных настроек необходимо знание языка PostScript и документации по файлам описания принтеров.

Примечание

Принтер, для которого готовится публикация, должен быть определен до этапа верстки, т. к. PageMaker компонует текст с учетом устройства вывода. При изменении имени устройства вывода в диалоговом окне Document Setup (Параметры документа) PageMaker перекомпонует публикацию, что может привести к катастрофическим последствиям, чреватым полной переверсткой публикации.


Печать на лазерном принтере и фотонаборном автомате

Печать из PageMaker мало чем отличается от печати из любого приложения Windows. Но все просто до тех пор, пока дело не доходит до печати оригинал-макета. В этом случае существует множество тонкостей, знание которых необходимо для успешного вывода и тонкого управления устройством печати. Любой фотонаборный автомат является PostScript-устройством и далее, если прямо не указано противоположное, мы будем говорить именно о выводе на устройства, интерпретирующие PostScript. Диалоговое окно печати для He-PostScript-принтеров имеет существенные отличия, о которых мы расскажем в отдельном разделе. На рис. 23.3 представлено диалоговое окно Print Document (Печатать документ), которое открывается при выборе команды Print (Печатать).

Диалоговое окно имеет ряд кнопок, расположенных по правому краю окна, выбирающих разделы параметров настройки устройства вывода и открывающих соответствующие диалоговые окна или выполняющих действия:

  • Document (Документ). Определяется, какую часть публикации или книги следует вывести на печать; количество требуемых копий и последовательность печати страниц; ориентацию страницы на листе бумаги; устройство вывода и файл его описания.
  • Paper (Бумага). Задаются формат бумаги, масштабирование при печати, разбиение больших страниц (т. е. страниц, формат которых превышает формат бумаги) на фрагменты, помещающиеся на бумаге заданного формата; указывается необходимость печати обрезных и приводных крестов, а также типографских шкалок и информации о печатаемой странице.

Рис. 23.1. Диалоговое окно Print, раздел Document

  • Options (Варианты). Позволяет оптимизировать вывод шрифтовых и графических элементов, создавать PostScript-файлы для отложенной печати.
  • Features (Свойства). В этом разделе собраны установки специфических для данного устройства вывода аппаратных возможностей. Разумеется, вид настоящего окна различен для каждой марки устройства вывода.
  • Color (Цвет). Предназначено для настройки системы управления цветом, режима вывода композитных цветных изображений на черно-белых принтерах, печати зеркальных или негативных страниц; важнейшие настройки печати цветоделенных полос, параметры растрирования.
  • Reset (Восстановить). Устанавливает значения всех настроек в то состояние, в котором они были на момент открытия диалогового окна печати.
  • Print (Печатать). Запускает печать с учетом сделанных во всех разделах установок.
  • Cancel (Отменить). Отменяет печать документа и все сделанные в диалоговом окне установки.

Ниже мы подробно рассмотрим каждый элемент во всех разделах диалогового окна печати.


Установка параметров раздела Document

На рис. 23.1 изображено диалоговое окно Print (Печатать) при выбранном разделе настроек Document (Документ). Настройки, имеющиеся в этом окне, совпадают с таковыми большинства приложений Windows и определяют, какую часть документа следует вывести на печать и какое устройство вывода при этом необходимо использовать.

  • Printer (Принтер). Выбранный в списке панели управления принтер представлен в поле Printer (Принтер). В версии PageMaker 7.0 для Windows изменить выбор принтера можно не только в панели управления, но и непосредственно в диалоговом окне печати.
  • PPD. Обозначения, приведенные в поле PPD, зависят от того, разрешены псевдонимы файлов PPD или нет. Разрешить или запретить использование псевдонимов можно переключателем Display PPD name (Показать имена PPD-файлов) в диалоговом окне More Preferences (Дополнительные установки) (см. гл. 3).
  • Copies (Копий). В этом поле указывается число копий публикации, подлежащих выводу. Напечатать за один прием можно до 32 000 копий (если, конечно, емкость вашего картриджа позволяет засыпать в него цистерну тонера, и вы не против израсходовать несколько вагонов бумаги).

Примечание

Если вы печатаете за один прием несколько копий публикации, программа PageMaker печатает их в неразобранном виде — вначале печатается десять копий первой страницы, затем — десять копий второй и т. д.

  • Collate (Копии в подбор). Установите этот флажок, и копии будут отпечатаны с правильной последовательностью страниц. Правда, это потребует намного больше времени, что сведет на нет его экономию на разборке копий на автоматическом деколлаторе. Произойдет это потому, что каждая страница будет загружаться в память принтера столько раз, сколько копий печатается.
  • Reverse (Обратный порядок). Используется в том случае, когда требуется хотя бы бегло просмотреть каждую из печатаемых страниц. Тогда после проверки каждой из страниц ее можно будет положить в стопку лицом вверх, и по окончании печати копия оказывается подобранной в правильном порядке. Этот режим удобен также при работе с принтерами, укладывающими отпечатанные листы в выходной лоток лицевой стороной вверх. В некоторых принтерах есть возможность печати с прямолинейным трактом бумаги (для печати на картоне или конвертах). В данном случае отпечатанные листы выдаются через специальное отверстие в задней стенке принтера, также лицевой стороной вверх. Очень часто такой режим используется для оборотной печати на лазерном принтере, укладывающем готовые листы лицевой стороной вниз.
  • Proof (Черновик). При установке этого флажка графические изображения при печати выводятся в виде серых перечеркнутых прямоугольников. Это экономит очень много времени при выводе корректуры. Размеры прямоугольников совпадают с габаритами замещаемых ими изображений.

Примечание

Режим Proof (Черновик) очень удобен для диагностирования причины сбоев при печати страницы. Для того чтобы выяснить, из-за чего страница не выводится на печать (из-за текста или из-за графики), достаточно включить данный режим. Если после этого страница публикации отпечаталась нормально, виноваты импортированные графические изображения. Если страницу не отпечатать и в таком режиме, уделите внимание гарнитурам, используемым в публикации.

  • Ranges (Выборочно). В большинстве случаев на печать выводятся все страницы публикации (переключатель диапазона" находится в положении All (Все)). Если вам требуется вывести лишь некоторые страницы, введите в соответствующее поле список номеров страниц, подлежащих выводу. При этом переключатель диапазона автоматически займет положение Ranges (Выборочно).

Номера отдельных страниц и группы смежных страниц в этом списке разделяются запятыми, а номера начальной и конечной страницы в группе — дефисом, например "1, 3-5, 8, 7-20, 3". В обозначении группы смежных страниц страница с меньшим номером должна быть указана перед дефисом. Обратите внимание на то, что номера страниц могут входить в список более одного раза (в этом случае будут напечатаны копии).

  • Reader's spreads (Книжные развороты). При установке данного флажка на одном листе бумаги печатаются сразу две смежные страницы публикации, что, позволяет легко оценить качество верстки разворотов без утомительной возни с липкой лентой для склеивания отдельных страниц. В этом режиме автоматически включается режим масштабирования Reduce to Fit (Уменьшить по формату), а ориентация листа бумаги заменяется на альбомную. Очень часто режим книжных разворотов в два раза экономит бумагу при выводе корректуры публикаций небольшого формата.
  • Ignore "Non-Printing" setting (Игнорировать атрибут "Непечатный"). В программе PageMaker 7.0 имеется возможность блокировать вывод элементов на печать посредством специального атрибута (см. гл. 14). При помощи данного флажка их можно принудительно вывести на печать. Это удобно, когда к тексту и макету добавлялись замечания, отформатированные с таким атрибутом, и их желательно вывести на печать.
  • Print blank pages (Пустые страницы). Иногда для правильной балансировки разворотов или при оборотной печати в документ приходится вставлять пустые страницы. Для того чтобы эти страницы были выведены на печать, следует установить флажок Print blank pages (Пустые страницы) — в противном случае PageMaker пытается экономить бумагу, не выводя на печать страницы, на которых нет каких-либо элементов.

При подготовке к оборотной печати этот флажок обязательно следует установить — в противном случае может быть нарушен порядок следования страниц в публикации. При выводе на фотонаборный автомат или цветной принтер имеет смысл запретить вывод пустых страниц. Это позволит сэкономить время и деньги, но не забывайте, что в выполнении такого вывода всегда участвует человек, который может позаботиться о проверке правильности пагинации.

  • Print: Both Pages/Even Pages/Odd Pages (Печатать: Подряд/Четные/Нечетные). Используется при оборотной печати. В этом случае печатаются сначала нечетные страницы. Затем стопка отпечатанных страниц переворачивается и снова заправляется в лоток принтера. После этого печатаются четные страницы.

Не забудьте установить также флажок Print blank pages (Пустые страницы) и поставить в нужное положение флажок Reverse (Обратный порядок). Как мы уже говорили, положение последнего зависит от конструкции механизма протяжки бумаги вашего принтера.

  • Orientation (Ориентация). Предназначен для назначения книжной или альбомной ориентации листов бумаги при печати.
  • Print all publications in book (Печатать все публикации книги). Включает режим печати всех публикаций, указанных в структурном списке.активной публикации. Поэтому печатать в этом режиме всю публикацию следует из файла, содержащего полный структурный список книги.
  • Use paper settings of each publication (Бумага отдельно для каждой публикации). Используйте этот режим, если файлы публикации имеют различную ориентацию или формат бумаги. Когда данный флажок установлен, установки ориентации и форматов бумаги берутся из отдельных файлов публикации, а не из текущих установок диалогового окна Print Document (Печатать документ). Текущие установки в таком случае действуют только на открытый файл со структурным списком.

Режимы печати всех страниц или выборочной печати действуют только в активной публикации, а подряд печати только четных или только нечетных — во всех публикациях структурного списка.


Установка параметров раздела Paper

Внешний вид диалогового окна для этих установок представлен на рис. 23.2.

Далее описываются отдельные элементы управления данного диалогового окна:

  • Size (Формат). Позволяет выбрать размеры листа бумаги из раскрывающегося списка. Информация о форматах бумаги, поддерживаемых принтером, считывается из файла PPD, там же указаны и возможные источники подачи бумаги для конкретного принтера.

Рис. 23.2. Раздел Paper диалогового окна команды Print Paper

  • Source (Подача). Если в принтере предусмотрено более одного лотка подачи бумаги, источник можно выбрать из этого списка.

    Если в файле PPD указано, что принтер может работать с нестандартными размерами листов бумаги, выберите в списке размеров альтернативу Custom (Заказной) и задайте размеры во вспомогательном диалоговом окне. При выводе на лазерный принтер листы нестандартных размеров практически не используют, но их роль неизмеримо возрастает при передаче материалов в сервисное бюро, в котором на рулоне фотоматериала, загружаемом в фотонаборный автомат, обычно стараются уместить как можно больше страниц издания.

  • Printer's marks (Типографские метки) и Page information (Описание страницы). Типографские метки — приводные и обрезные кресты, шкалки — изображены на рис. 23.5.

    Для печати типографских меток требуется дополнительное пространство на странице шириной 16 мм с каждой стороны. Это означает, что на стандартном листе формата А4 можно будет напечатать с типографскими метками страницу с размерами, не превышающими 178x265 мм.

    Метки обрезки используются в типографиях для резки страниц публикации из листов бумаги более крупных размеров, на которых производилась печать. Шкала цветов дает возможность проверить качество цветовоспроизведения при печати в цвете, а шкала плотности — правильность воспроизведения полутонов серого цвета фотонаборным автоматом или печатной машиной. Метки приводки представляют собой миниатюрные круглые мишени (рис. 23.3), по которым в типографии выполняют приводку цветоделенных форм при многокрасочной печати.

Рис. 23.3. Размер страницы

При выводе на фотонаборный автомат формат бумаги устанавливается, как правило, таким, чтобы на нем точно умещалась печатаемая страница вместе с типографскими метками. Это значение можно получить и без расчетов, если включить печать типографских меток, а затем выбрать из списка Size (Формат) вариант Custom (Заказной). В открывшемся диалоговом окне будут проставлены размеры, в точности соответствующие минимальным требуемым для размещения страницы и типографских меток. Теперь остается только нажать кнопку ОК.

  • Page information (Описание страницы). Установка этого флажка включает режим печати на каждой странице имени файла, номера страницы, название цвета и дату вывода на печать. Для вывода этой информации необходима дополнительная горизонтальная полоса шириной 13 мм.
  • Center page in print area (Страница по центру). Страницы публикации размещаются посередине листов бумаги, заряженной в принтер.
  • Fit (Соотношение размеров). Если вы работаете с PostScript-принтером, то в области предварительного просмотра соотношения размеров, представленной на рис. 23.4, можно наглядно увидеть, как страница публикации вместе с типографскими метками и описанием страницы размещается на листе бумаги. Изображение строится на основе данных, приведенных в файле PPD. Численные значения форматов бумаги, поля печати и отступов можно одновременно увидеть, если\сделать двойной щелчок мышью в поле диаграммы.

    Расчет отступов производится либо от размера страницы, либо от печатной области. Вариант Paper size (По размеру бумаги) подразумевает, что печатная области покрывает весь лист бумаги или пленки; его следует использовать при выводе на фотоавтомат. Вариант Printable area (По печатной области) рассчитывает размеры отступов с учетом того, что часть листа бумаги (полоса вдоль его краев) может быть недоступна для выбранного принтера. Ширина этой полосы определена в соответствующем PPD-файле. Этот вариант используется в основном при выводе на настольные принтеры.

    Если размеры доступной для печати части листа превышены, то значения отступов будут выделены красным цветом. Если включен режим печати негатива, то изображение в поле предварительного просмотра будет негативным, а при включении режима печати зеркального отображения большая буква "Е" будет заменена своим зеркальным отражением.

Рис. 23.4. Два способа отображения соотношения размеров

  • Tiling (Разбиение) (см. рис. 23.2). При необходимости печатать страницы публикации с размерами, превышающими размеры бумаги, заложенной в принтер, можно воспользоваться раскрывающимся списком Tiling (Разбиение). Впоследствии страница публикации большого размера может быть собрана из фрагментов.

    Вариант Auto (Авто) предоставляет программе PageMaker автоматически выбирать вариант разбиения страницы публикации на фрагменты. При выборе варианта overlap (Перекрытие) можно ввести ширину области пересечения фрагментов друг с другом.

    При ручном разбиении страницы на фрагменты для вывода у пользователя есть возможность управлять процессом разбиения. Чаще всего применяется именно такой способ для того, чтобы избежать пересечения фрагментов на сюжетно важном месте страницы. В этом режиме при нажатии кнопки Print (Печатать) PageMaker выводит один фрагмент страницы. Верхний левый угол фрагмента определяется положением начала координат, а размер — форматом печатной области. Для печати очередного фрагмента следует переместить начало координат в верхний левый угол очередного фрагмента. При ручном разбиении ответственность за создание перекрывающихся областей фрагментов полностью ложится на ваши плечи.

  • Scale (Масштаб). Второй вариант печати публикации, страницы которой превышают размеры листов бумаги, — масштабирование. В процессе печати можно увеличить или уменьшить размер страницы публикации, задав коэффициент масштабирования в пределах от 5 до 1600%.
  • Reduce to fit (Уменьшить по формату). Если при печати страницы, не умещающейся на бумаге, вам не важен масштаб, важно лишь получить отпечаток, вы можете поручить PageMaker вычислить минимальное масштабирование, необходимое для того, чтобы страница поместилась на бумажном листе целиком. Именно такую команду дает этот флажок.
  • Thumbnails (Миниатюры). Если вам хочется оценить внешний вид публикации в самых общих чертах, установите переключатель масштабирования в положение Thumbnails (Миниатюры). В соответствующем этому положению переключателя поле задайте количество миниатюр, которое программа PageMaker будет печатать на одном листе. В результате получится нечто похожее, представленному на рис. 23.5.

а

б

в

Рис. 23.5. Миниатюры страниц публикации


Установка параметров раздела Options

В этом разделе собраны установки, определяющие режим воспроизведения графических изображений, интерпретации языка PostScript-принтером и использования памяти принтера (рис. 23.6).

Рис. 23.6. Диалоговое окно команды Print, раздел Options

  • Send image data (Графические данные). Определяет, какой объем данных пересылается в принтер при печати растровых изображений. По умолчанию установлен вариант Optimized subsampling (Оптимизировать). В этом режиме PageMaker посылает на принтер изображения с разрешением, необходимым для хорошего качества печати при заданной линиатуре растра (см. разд. "Параметры растра" данной главы). Режим удобен для вывода корректуры на лазерный принтер. Если публикация рассчитана на печать в типографии, то разрешение импортированных в публикацию изображений составляет величину около 300 точек/дюйм. При печати на лазерном принтере редко требуется разрешение более 150 точек/дюйм. При включенной оптимизации вывода графических файлов PageMaker автоматически пересчитает разрешение изображений на 150 точек/дюйм еще до засылки в принтер. Принтеры имеют гораздо менее мощные процессоры, чем современные компьютеры, поэтому такой пересчет экономит очень много времени.

Для печати на фотонаборном автомате лучше всего использовать файлы оригинального разрешения. Для этого следует выбрать вариант Normal (Без настройки).

Остальные варианты предназначены для вывода корректуры. Первый, Omit Images (Запретить), вместо изображений выводит серые прямоугольники, а второй, Low resolution (Низкое разрешение), — экранные версии графических файлов. Эти режимы сильно экономят время вывода публикации.

Примечание

При работе с PostScript-принтером можно увеличить объем памяти принтера, доступной для печати графических изображений, выполнив соответствующие установки. В диалоговом окне команды Preferences (Установки) щелкните мышью на кнопке More (Дополнительные), раскройте список Memory freed for grafphics (Объем памяти для вывода изображений) и выделите альтернативу Maximum (Максимальный). В этом режиме программа PageMaker может временно выгружать гарнитуры из памяти принтера, освобождая ее для изображения, что приводит к увеличению времени печати, но иногда — это единственный способ вывести насыщенную графикой страницу на печать.

  • Data encoding (Кодирование данных). Значительную часть времени печати занимает пересылка данных в принтер. Обычно при пересылке PostScript используется кодировка ASCII, т. е. текстовый формат. С точки зрения объемов данных этот формат очень не экономичен и его использование объясняется плохой поддержкой Windows более компактной, двоичной кодировки. Если ваш принтер поддерживает двоичное кодирование PostScript, мы рекомендуем им воспользоваться. Выбирать кодирование ACSII следует, если нет другого выбора, или в режиме двойного кодирования принтер работает неустойчиво. Двоичному кодированию соответствует вариант Send binary image data (В двоичных кодах), а текстовому — Send ASCII image data (В кодах ASCII).
  • Download fonts (Загружать шрифты). Список предоставляет выбор вариантов работы со шрифтами TrueType и Туре 1. PageMaker может передавать драйверу принтера шрифты как загружаемые или как графику. Последний вариант значительно увеличивает время печати, поэтому его следует использовать лишь в крайних случаях — когда иначе шрифт не выводится. Такой "отказ" принтера выводить шрифт, скорее всего, обусловлен плохим качеством самого шрифта, поэтому имеет смысл больше его не использовать. TrueType шрифты не поддерживаются некоторыми интерпретаторами PostScript, поэтому они преобразуются драйвером в контуры или заменяются согласно таблице подстановки, определенной в драйвере. Преобразование шрифтов, как и почти всякое преобразование, не обходится без потерь. Поэтому мы рекомендуем использовать при подготовке публикаций для PostScript-печати только шрифты Туре 1.

Не загружать шрифты можно лишь в том случае, если они уже загружены в принтер предварительно или являются встроенными. В современных принтерах имеется возможность заменять встроенные шрифты, т. к. они запоминаются в Flash-памяти принтера или на его винчестере. Мы советуем сделать наиболее часто используемые вами шрифты резидентными, что избавит вас от необходимости часто загружать их в память принтера и тратить время на их передачу.

Особое значение приобретает загрузка шрифтов при генерации PostScript-файлов для передачи в сервис-бюро. Как легко предположить, только те шрифты, которые вы пометили как загружаемые, окажутся в сгенерированном файле. Поэтому отменять загрузку шрифтов при печати в файл следует только, если вы абсолютно уверены в том, что эти шрифты имеются в сервис-бюро. Наш опыт говорит в пользу включения в PostScript-файл всех используемых в публикации шрифтов, хотя это и немного увеличивает объем файла и время печати.

  • Include PostScript error handler (Регистрация PostScript-ошибок). Если этот флажок установлен, PageMaker загружает в принтер программу, помогающую отыскать причины возникновения ошибок при выводе PostScript-файла. Использование такой возможности целесообразно при возникновении проблем с выводом корректуры на лазерный принтер. Если публикация печатается в файл при установленном флажке регистрации ошибок, то обработчик ошибок также записывается в файл. Появление обработчика в файле, предназначенном для сервис-бюро, как правило, очень нежелательно. Бюро предпечатной подготовки наверняка располагает более мощными программами диагностики ошибок, и включенный в файл обработчик может вызвать конфликт при выводе.
  • Write PostScript to file (Записать PostScript-файл). Наиболее часто возможность записи PostScript в файл используется для передачи верстки на фотовывод в бюро предпечатной подготовки. Такой способ удобен для обеих сторон. Вам не придется заботиться о наличии в бюро той же версии программы верстки и платформы компьютеров, наличии всех внешних связанных файлов, шрифтов и таблиц трекинга. Работникам бюро, в свою очередь, также не грозят проблемы, которые могут возникнуть при отсутствии чего-либо из вышеперечисленного. Им не придется тратить время на ту же самую работу по генерации PostScript для фотонаборного автомата — надо всего лишь поставить готовый файл в очередь печати. Чаще всего работники бюро осуществляют проверку правильности PostScript непосредственно на растровом процессоре (RIP). He последнюю роль при выводе на фотонаборный автомат играет и стоимость этой работы. Как правило, вывод из PostScript-файла на 10—30% дешевле, чем из верстки. Единственный недостаток такого способа в том, что вся ответственность за правильность настроек фотонаборного автомата ложится на вас и любая ошибка оборачивается испорченными пленками, которые вам придется оплачивать из своего кармана.

При установке флажка Write PostScript to file (Записать PostScript-файл) становятся доступными некоторые вспомогательные элементы управления диалогового окна, в частности поле для имени файла, в который будет записано описание публикации на языке PostScript. Кнопка Browse (Обзор) открывает стандартное диалоговое окно файла Windows, с помощью которого можно указать местоположение файла для вывода публикации.

При переводе переключателя в позицию Normal (Без настройки) PageMaker формирует имя файла вывода из имени файла публикации с заменой расширения на ps. Публикация выводится в многостраничный файл PostScript.

При переводе переключателя в позицию EPS-file (EPS-файл) каждая страница публикации выводится в отдельный файл, имя которого формируется из первых символов имени публикации, к которым добавляется номер страницы. Для таких файлов используется расширение EPS. (При просмотре такого файла на экране вы ничего не увидите, кроме серого прямоугольника, поскольку экранная версия изображения не формируется, но при выводе на PostScript-принтер страница будет отпечатана должным образом.) Настоящий вариант вывода удобен при передаче публикации на последующую обработку при помощи системы TrapWise или иного приложения, работающего с публикацией постранично. TrapWise автоматически выполняет процедуру растрового треппинга. Формат EPS удобен также в тех случаях, когда необходимо передать изображение сверстанной страницы в другую программу (например, Adobe Illustrator).

При переводе переключателя в позицию For prepress (Для допечатной обработки) формируются файлы с расширением sep. В этом случае в сервисное бюро передается композитный (цветной) файл, т. е. программа PageMaker не выполняет цветоделение (предполагается, что цветоделение будет выполнено в сервисном бюро).

Этот режим используется также при подготовке исходных данных для программ предпечатной обработки типа PrePrint или PressWise фирмы Adobe. PrePrint представляет собой мощную программу цветоделения с более широкими, чем у PageMaker, возможностями. PressWise — приложение, формирующее из страниц публикации спусковой макет, позволяющий печатать по несколько страниц на одном листе с последующей фальцовкой и брошюровкой. Необходимость предпечатной обработки определяется сотрудниками сервисного бюро.

  • Page independence (Каждая страница независимо). Этот флажок управляет режимом передачи гарнитур PostScript из программы PageMaker в принтер. При выводе публикации на бумагу этот флажок практически никогда не устанавливают. Но если вы подготавливаете файл для предпечатной обработки, то установка этого флажка заставит программу PageMaker включить описание загружаемых гарнитур в каждую страницу публикации. Это может понадобиться, если в сервисном бюро будут работать по отдельности с каждой страницей (например, при подготовке спускового макета). Проконсультируйтесь о необходимости такого режима с сотрудниками сервисного бюро.
  • Extra image bleed (Увеличить выход за обрез). Установка флажка требуется в особых ситуациях. По умолчанию программа PageMaker позволяет TIFF-изображению "высовываться" за край страницы не более чем на 3 мм, но при включении данного режима это расстояние увеличивается до 25 мм (при выводе в файл). Настоящий флажок доступен только когда переключатель находится в положениях EPS-file (EPS-файл) или For prepress (Для допечатной обработки).


Установка параметров раздела Features

Выбор особых аппаратных возможностей вашего принтера осуществляется в режиме Features (Свойства) диалогового окна команды Print (Печатать).

Например, некоторые принтеры могут работать в режиме оборотной печати, запечатывая одновременно обе стороны листа бумаги. Печать в таком режиме может привести к каким-либо недоразумениям — например, на нее оказывает влияние установка атрибута ориентации листа. Чтобы не ошибиться, рассматривайте ориентацию как атрибут, управляющий размещением поля для подшивки вдоль длинной или короткой стороны листа. Например, при выборе книжной ориентации и размещении поля для подшивки вдоль короткой стороны листа развороты будут печататься для последующей сшивки в виде высокого блокнота. При выборе альбомной ориентации и размещении поля для подшивки вдоль короткой стороны листа получается книга с широкими и низкими страницами.

Если в вашем распоряжении имеется цветной принтер, то в диалоговом окне появляются элементы управления, позволяющие, например, выбирать тип материала, на котором будет выполняться печать, или технологию улучшения цветовоспроизведения, обусловленную устройством принтера (рис. 23.7).

Рис. 23.7. Диалоговое окно Print, раздел Features

Короче говоря, режимы, доступные через элементы управления этого диалогового окна, определяются производителем принтера и описываются в файле PPD.


Особенности He-PostScript-принтеров

Предыдущий раздел описывает ситуацию, с которой вы сталкиваетесь при работе с наиболее широко распространенными лазерными PostScript-принтерами. Однако, если в качестве активного выбран не PostScript-принтер, форма многих описанных выше диалоговых окон меняется.

Во-первых, если выбран He-PostScript-принтер, то в главном диалоговом окне команды Print (Печатать) вместо кнопки Paper (Бумага) появляется кнопка Setup (Установка). Щелчок мышью на ней открывает то же диалоговое окно, которое используется в программе настройки принтера управляющей панели Windows.

После щелчка мышью на кнопке Features (Свойства) в раскрывшемся диалоговом окне нет ничего, кроме сообщения о возможности доступа к свойствам принтера после нажатия на кнопку Setup (Установка).

Рис. 23.8. Диалоговое окно свойств He-PostScript-принтера

После щелчка мышью на кнопке Setup (Установка) открывается диалоговое окно, форма которого меняется от принтера к принтеру, но, скорее всего, оно будет похоже на диалоговое окно, представленное на рис. 23.8. На рисунке видно, что диалоговое окно состоит из нескольких частей и оформлено в соответствии 6о стандартом диалоговых окон Windows 95 с множественными вкладками.


Установка параметров раздела Color

В сложившейся практике издательского дела с режимом Color (Цвет) диалогового окна команды Print (Печатать) (рис. 23.9) работают, в основном, сотрудники сервисного бюро. При этом вы передаете в сервисное бюро файл публикации в формате программы PageMaker для цветоделения и вывода фотоформ на фотонаборный автомат или деленных полос на репрографическую бумагу.

Рис. 23.9. Диалоговое окно команды Print, раздел Color

Однако до того, как вы передадите публикацию в сервисное бюро, вам также придется воспользоваться этим диалоговым окном для вывода цветных пробных отпечатков, предназначенных для корректуры и утверждения.

Кроме того, если вы передаете публикацию в сервисное бюро в формате PostScript после вывода публикации в файл (см. описание режима Options (Варианты) в разд. "Установка параметров раздела Options" данной главы), кое-какие установки, касающиеся режимов воспроизведения цвета, вам придется все-таки выполнить самим.

  • Composite (Совмещенный оттиск). В этом режиме на лазерный или цветной струйный принтер выводятся композитные (цветные) отпечатки. Композитный отпечаток дает возможность получить представление о пуб-" ликации в целом, поскольку на нем совмещены в единое изображение все деленные полосы.

    В подавляющем большинстве случаев подчиненный переключатель композитного режима устанавливается в положение Grayscale (Полутона) и для лазерных, и для цветных принтеров.

    Этот переключатель переводится в положение Print colors in black (Все цвета — черным) только в одном случае: при выводе пробного отпечатка публикации с использованием плашечных цветов, на котором PageMaker должен вывести все оттенки в соответствии с процентным содержанием в них базового цвета, вне зависимости от самих базовых цветов. Перед подготовкой материала для передачи в сервисное бюро узнайте, необходимо ли включать этот режим.

  • Mirror (Зеркало) и Negative (Негатив). С помощью этих режимов подготавливаются оригиналы для вывода на фотонаборный автомат. Различные фотоавтоматы требуют по-разному подготовленных оригиналов, кроме того, и фотоформы, передаваемые в типографию, могут принципиально отличаться друг от друга.

    Но лучше всего — проконсультируйтесь в типографии. Попросите технолога типографии четко определить характеристики фотоформ, необходимых для изготовления печатных форм. Получив от него указания, четко их придерживайтесь.

  • Режим Negative (Негатив) выводит изображение в инвертированном виде, оно выглядит как негатив черно-белой фотографии. Режим Mirror (Зеркало) выводит зеркальное отражение изображения. Термины прямое изображение и зеркальное изображение следует понимать буквально. Если на пленку выведено прямое изображение текста, вы можете легко прочесть его. Зеркальное изображение текста очень тяжело читать без помощи зеркала. Изменяя состояние флажка Mirror, вы одновременно изменяете положение пленки фотоформы по отношению к заготовке печатной формы — светочувствительной эмульсией вверх или эмульсией вниз.

    Самое важное, что следует запомнить в отношении флажков Negative и Mirror: их никогда не следует устанавливать без предварительной консультации с типографией и сервисным бюро.

    Невозможно подсчитать, сколько дорогой пленки загублено из-за неправильного задания этих режимов. Очень часто сервисные бюро выставляют их самостоятельно. Если вы передаете публикацию в сервисное бюро в виде PostScript-файла, оператор фотонаборного автомата выставит необходимые значения режимов в соответствии с вашими требованиями. Если публикация передается в форме файла в формате PageMaker, специалисты сервисного бюро сами установят необходимые состояния флажков в диалоговом окне команды Print (Печатать).

  • Preserve EPS colors (Сохранять цвета EPS)''-Как вам уже известно из гл. 19, PageMaker может изменять цвета, определенные в импортированных изображениях формата EPS, и использовать их для назначения графическим объектам PageMaker. Таким образом обеспечивается единообразие цветового оформления публикации. Впрочем, иногда, когда дело доходит до вывода на печать, возникает необходимость восстановить и отпечатать исходные цвета, определения которых содержались в импортированных графических изображениях формата EPS. Установка данного флажка предоставляет вам такую возможность.
  • Separations (Цветоделение). Это положение переключателя используется для вывода деленных полос или фотоформ для печати цветных оттисков в типографии. В этом режиме также готовятся файлы PostScript, предназначенные для передачи публикации в сервисное бюро. Но чаще всего этим режимом пользуются все-таки для проверки результатов цветоделения, в ходе которой выясняется, правильно ли были назначены цвета различным объектам.

    Раздел Color (Цвет) диалогового окна Print (Печатать) содержит список всех цветов, определенных в публикации. При печати любой из этих цветов может быть выведен на отдельную страницу. Кроме тех цветов, которые вы определили сами, список обязательно содержит стандартные три-адные цвета: голубой, пурпурный, желтый и черный. Это дает возможность выводить формы для печати триадными красками.

    Чтобы определить, какие цвета из приведенных в списке следует печатать, нужно выделить цвет щелчком мыши на его имени в списке и установить расположенный ниже флажок Print this ink (Печатать краску).

    Справа от списка красок расположен ряд кнопок.

  • CMS Setup (Параметры CMS). Открывает доступ ко всем возможностям системы управления цветом, подробно описанным в гл. 21.

Примечание

Н ачиная с версии 6.0, PageMaker может осуществлять цветоделение (для печати триадными красками) импортированных растровых RGB-изображений. До этого такие изображения перед печатью необходимо было переводить в модель CMYK. Данная возможность доступна, только если система управления цветом включена. Неверная ее настройка приведет к неадекватной цветопередаче. Если вы не используете систему управления цветом, воспользуйтесь старым способом — переведите все растровые изображения в модель CMYK с помощью графического редактора, например Adobe Photoshop.

Remove unused (Удалить ненужные). Эта кнопка удаляет из списка те цвета, которые были определены, но не применялись при оформлении публикации. Такого же результата можно достичь, воспользовавшись командой Remove unused Colors (Удалить неиспользованные цвета) меню палитры Colors (Цвета). Разница лишь в том, что в последнем случае определения цветов удаляются из всей публикации навсегда, а в первом — только на момент печати. Перед печатью обязательно воспользуйтесь одной из названных команд. Это будет хорошей страховкой от ошибочного вывода пустых листов или пленок, поскольку PageMaker при печати выводит даже те формы, на которых нет ни одного объекта.

  • All to process (Все триадными). Необдуманный щелчок на этой кнопке при работе над публикацией, в которой важно точное цветовоспроизведение, может поставить вас в весьма затруднительное положение. Как уже описывалось в гл. 20, при преобразовании плашечных цветов в триадные вы доверяете качество цветовоспроизведения публикации алгоритмам преобразования цветовых моделей, встроенным в программу PageMaker. В большинстве случаев преобразование будет выполнено вполне удовлетворительно. Однако преобразование цветовых моделей в принципе не может быть совершенным и к оценке его реаультатов следует подходить весьма критически. С другой стороны, это самый простой способ свести множество цветов, определенных в публикации, к триадным. Во всяком случае, после преобразования плашечных цветов в триадные обязательно следует выпустить пробный отпечаток публикации в цвете перед передачей ее в типографию.
  • Print all inks (Все краски) и Print no inks (Отменить выбор). Они позволяют быстро вносить изменения в перечень цветов, выбранных для вывода на печать. Например, для того чтобы вывести на печать только одну краску, проще отменить выбор всех красок кнопкой Print no inks, а затем выбрать требуемый цвет.
  • Optimized screen (Оптимальный растр). Определяет параметры растрирования при выводе. Если страницы печатаются композитом, то список содержит два варианта — значение Default (По умолчанию), заданное в драйвере принтера, и заказные параметры растрирования Custom (Произвольно). Если значения в соседних с этим списком полях Frequency (Линиатура) и Angle (Угол наклона) заданы вами вручную, то активным в списке автоматически становится элемент Custom (Произвольно).

Если печатается цветоделение, то список содержит несколько умалчиваемых, а значит, и наиболее удачных сочетаний разрешение/линиатура для выбранного устройства вывода. Эти значения PageMaker считывает из PPD-файла описания принтера. Оттуда же считываются и соответствующие значения выбранной базовой линиатуры и углы растрирования для отдельных красок. При высоких разрешениях устройств вывода линиатуры для отдельных компонентов совпадают с базовой, а углы растрирования имеют типичные величины: голубой — 15°, пурпурный — 75°, желтый — 0°, черный — 45°. Для устройств с низким разрешением рекомендуемые линиатуры и углы для отдельных красок отличаются от приведенных. Для того чтобы просмотреть умалчиваемые параметры растрирования для каждой краски, достаточно щелкнуть на ее имени в списке цветов. При этом в полях Frequency (Линиатура) и Angle (Угол наклона) появятся соответствующие значения. Вводя в данные поля новые значения, вы сами можете определить параметры для выбранных вами красок. Такой возможностью вы вынуждены будете воспользоваться при печати цветоделения по плашечным цветам. На этот случай PPD-файл не содержит рекомендуемых значений и в поля параметров растрирования помещаются значения, совпадающие с таковыми для черной составляющей.

Параметры растрирования зависят от многих факторов, и если вы недостаточно опытны, не устанавливайте их без предварительной консультации с типографией и бюро предпечатной подготовки. Суть этих параметров объясняется в разд. "Растрирование и цветоделение" данной главы.


Команда Print и стили печати

Теперь, когда установлены все параметры печати, у вас есть выбор: начинать печать немедленно или же запомнить установки печати в файле публикации или вне файла публикации. Последний способ создает так называемый стиль печати, который содержит всю информацию об установках, сделанных в диалоговых окнах команды Print (Печатать). Стиль печати можно использовать для печати других публикаций, подобно тому, как стилем, определенным по шаблону одного абзаца, можно отформатировать любое количество абзацев.

Для немедленного начала печати нужно просто щелкнуть на кнопке Print (Печатать). Если вы хотите отложить печать, но использовать для нее только что сделанные установки, нажмите на данную кнопку, удерживая при этом клавишу <Shift>. Название кнопки в таком случае изменится с Print (Печатать) на Done (Готово).

Для запоминания установок принтера как стиля печати нажмите кнопку Print (Печатать), удерживая клавишу <Ctrl>. При этом название кнопки изменится на Style (Стиль). Применить стиль печати означает открыть диалог команды Print (Печатать) с теми установками, которые содержатся в стиле. Это делается командой Printer Styles (Стили печати) из меню File (Файл). Команда предлагает выбрать требуемый стиль печати или определить новый. Если вы хотите создать стиль печати, то по команде Define (Определить) открывается окно, представленное на рис. 23.10.

Окно содержит список определенных ранее стилей печати. Кнопка New (Новый) справа от списка позволяет создать стиль печати, а кнопка Edit (Редактировать) — изменять установки печати, определенные в стиле. Кнопка Edit (Редактировать) открывает диалоговое окно команды Print (Печатать), с которым мы только что подробно ознакомились, только вместо кнопки Print (Печатать) в нем присутствует кнопка ОК. Данную кнопку следует нажать после того, как вы отредактировали установки стиля желаемым образом. При этом окно команды Print (Печатать) закрывается и текущим снова становится окно Define Printer Styles (Определить стили печати). В поле статуса под списком стилей отображаются установки выбранного стиля печати, что позволяет быстро оценить параметры, установленные в стиле, не пользуясь при этом сложным диалоговым окном команды Print (Печатать). Кнопка New (Новый) позволяет ввести имя определяемого стиля. Для задания параметров печати полученный стиль надо отредактировать. Ненужные стили печати легко удаляются кнопкой Remove (Удалить).

Рис. 23.10. Стили печати

Определения стилей печати сохраняются в файле PSTYLES.CNF, который можно передавать для использования на других компьютерах.


Растрирование и цветоделение

Процессы типографской печати требуют наличия в макете иллюстраций, обработанных специальным образом. Полутоновые одноцветные иллюстрации должны быть подвергнуты растрированию, а цветные еще и цветоделению. Для типографии макет должен быть представлен на прозрачной пленке в натуральную величину. Вывод документа на пленку осуществляется с помощью фотонаборных автоматов. В самом грубом приближении они похожи на лазерные принтеры, только лазер засвечивает не светочувствительный барабан, а фотопленку. Все фотонаборные автоматы "понимают" язык PostScript и имеют в несколько раз более высокое разрешение печати, чем самые хорошие принтеры (в среднем 3600 dpi). Фотонаборные автоматы — весьма дорогостоящие и сложные устройства, покупку которых может позволить себе далёко не каждое издательство. Для вывода оригинал-макетов, как правило, обращаются к услугам сервис-бюро, специализирующихся на допечатной подготовке.

Хотя процедура вывода на фотонаборный автомат абсолютно аналогична выводу на PostScript-принтер, последующий типографский процесс предъявляет к нему некоторые специфические требования. Прежде чем рассматривать возможности PageMaker в подготовке макетов для типографской печати, нам придется их обсудить.


Зачем нужно растрирование

Способы передачи полутонов в аналоговых (фотография) и цифровых (принтеры, типографские машины) процессах принципиально различаются. Хотя в обоих случаях изображение все равно состоит из очень маленьких элементов, разница заключается как в самих элементах, так и в их расположении. Черно-белое фотографическое изображение строится из точек, состоящих из разного количества молекулярного серебра в слое эмульсии, расположенных в случайном порядке. Эти точки могут иметь различную оптическую плотность, т. е. каждая точка имеет свой оттенок серого. В цифровых методах печати применение отдельных красок для передачи каждого оттенка серого невозможно. Представьте, сколько труда заняли бы настройка приводки и печать двухсот с лишним красок, и какой вид имела бы бумага уже после первых десяти! На практике для такой печати используется всего одна краска — черная. Полутона при этом передаются за счет растра. Если посмотреть на отпечатанное в типографии или на лазерном принтере изображение, то нетрудно заметить, что оно состоит из множества мелких точек, которые называются растровыми точками. Наиболее часто точки располагаются регулярно, на одинаковом расстоянии друг от друга, формируя линейный растр, или растровую сетку. В последнее время все большую популярность приобретает особый способ растрирования (частотно-модулированный), использующий нерегулярное расположение растровых точек. Формируемый ими растр называется нерегулярным, или стохастическим. На рис. 23.13 приведено растрированное изображение.

В отличие от фотографии, растровая точка не может иметь какой-либо оттенок — она может быть только черной. Для передачи оттенков в процессе растрирования формируются растровые точки разных размеров. Между более "жирными" точками, напечатанными в соседних ячейках растровой сетки, остается мало белого пространства. Это создает иллюзию темного оттенка цвета такой области. Наоборот, небольшие точки, напечатанные с тем же интервалом, оставляют большую часть бумаги в пространстве между ними белой. Это создает ощущение светлого оттенка (рис. 23.12).

Таким образом, воспроизведение полутонов серого типографским способом, дающим возможность печатать фотографии, целиком и полностью построено на оптическом обмане. Глаз воспринимает градации серого на изображении, при печати которого использовалась только черная краска, но не сплошной заливкой, а в виде отдельных точек.

а

б

Рис. 23.11. Растрированное изображение

Рис. 23.12. Имитация темных и светлых оттенков серого с помощью растра


Зачем нужно цветоделение

При печати цветных документов возникает технологическая проблема, сходная с той, которую ставила передача полутонов. Растрирование позволило избежать печати каждого оттенка цвета отдельной краской, но как же быть с печатью самих цветов? Количество цветов, имеющихся в любой фотографии, столь велико, что о применении отдельных красок не может идти и речи. Решение проблемы состоит в цветоделении. Под цветоделением понимают представление цветов изображения сочетанием базовых цветов, взятых в разных пропорциях. Такой путь выбрала и сама природа, создавая органы зрения животных, точнее тех немногих из них, которые обладают цветовым зрением. Фоторецепторы сетчатки воспринимают всего три базовых компонента цвета, а мозг объединяет их в полноцветное изображение. По этой причине для. передачи любого цвета достаточно всего трех базовых компонентов. Именно на основе трех базовых компонентов построены все теоретические цветовые модели, с которыми вы уже знакомы. По существу описание цвета в любой из них эквивалентно цветоделению.

а

б

в

г

д

Рис. 23.13. Композитное изображение (а) и цветоделенные формы: голубая (б), пурпурная (в), желтая (г) и черная (д)

Наиболее широкое технологическое применение нашли модели RGB и CMYK. Модель RGB применяется в сканерах, цифровых камерах, монитоpax, a CMYK — в процессах печати. Такое "разделение обязанностей" обусловлено различием принципов передачи цветов. Как аддитивная цветовая модель, RGB представляет излучаемые цвета: излучение люминофора, лампы сканера, реальных объектов. Краски описываются субтрактивной моделью CMYK. Именно представление цветов в модели CMYK обычно и называют цветоделением. Оно дает возможность вместо отдельной краски для каждого цвета использовать всего четыре, соответствующие базовым цветам CMYK: голубой, пурпурной, желтой и черной.

Результатом цветоделения являются четыре растрированные полутоновые формы, в которых плотность растра соответствует содержанию базовых (или триадных) красок (рис. 23.13).

На устройстве печати цветоделенные формы переносятся на бумагу каждая краской своего цвета. Таким образом, цветные устройства печати имеют дело не с одним, а с четырьмя полутоновыми растрами, которые выводятся отдельными красками.


Линейные растры

С линейными растрами вы неоднократно сталкивались как при подготовке иллюстраций, так и в повседневной жизни. Растрирование применяется практически всеми цифровыми устройствами вывода от мониторов до принтеров. Суть растрирования заключается в разбиении изображения на маленькие ячейки так называемой растровой сеткой. При этом каждая ячейка имеет сплошную заливку. Растровая сетка монитора разбивает изображение на пикселы, представляющие собой группу точек люминофора. Лазерный принтер или фотонаборный автомат разбивают изображение на черные точки разного размера. Цветные принтеры и офсетные машины оперируют несколькими монохромными растрами одновременно. Параметры растрирования имеют решающее значение при выводе на данные устройства, поскольку они тесно связаны с их аппаратными возможностями. Именно они определяют допустимые параметры растрирования и накладывают свои специфические ограничения.


Параметры растра

Изображение в лазерных принтерах и фотонаборных автоматах создается лазерным лучом. Луч не может иметь переменный размер для создания растровых точек изменяющегося размера. Поэтому процесс растрирования заключается в объединении "реальных" точек, создаваемых лазерным лучом, в группы, образующие растровые точки.

Растр представляет совокупность квадратных ячеек, на которые разбито изображение. Каждая ячейка отводится для одной растровой точки. Растровая точка состоит из группы "реальных" точек одинакового размера, создаваемых устройством вывода. Чем большая часть такой ячейки заполнена точками принтера, тем больший размер имеет формируемая ими растровая точка и более темный оттенок серого она передает. Например, для того чтобы добиться заливки участка изображения 50%-ным серым, программа растрирования (растеризатор) заполнит этот участок растровыми точками, каждая из которых будет собой представлять наполовину заполненную ячейку растра. При необходимости передать 25%-ный серый ячейки растра будут заполнены черным только на четверть (рис. 23.14).

а

б

Рис. 23.14. 25- и 50-процентные растры под увеличением

Точки принтера в ячейке растра могут занимать различные положения. От этого будет зависеть форма растровой точки. В полиграфии применяются различные формы растровых точек, но наиболее традиционная и широко распространенная — круглая. Для того чтобы приблизить форму растровой точки к кругу, при заполнении ячейки растра растеризатор пытается наносить "реальные" точки как можно ближе к центру ячейки. PageMaker не может управлять формой растровых точек. Если вам все-таки необходимо получить иную форму точки, чем круглую, сообщите об этом в сервис-бюро. Форму растровой точки можно установить на фотонаборном автомате. Примеры форм растровых точек приведены на рис. 23.15.

Какое же устройство выполняет функции растеризатора? В подавляющем большинстве случаев задача растеризации возлагается на само устройство вывода: принтер или фотонаборный автомат. Растеризатор "встроен" в интерпретатор языка описания страниц, используемый принтером. Наиболее совершенным растеризатором, применяемым во всех высококачественных устройствах вывода, является интерпретатор PostScript. Второй популярный язык описания страниц, созданный фирмой Hewlett Packard для своих лазерных принтеров, — PCL (Printer Control Language) — не позволяет управлять параметрами растрирования с требуемой для полиграфии точностью.

Заметьте, что цифра, указываемая в паспорте принтера как разрешение (например, 600 Ipi), представляет собой количество "реальных" точек, которое может напечатать принтер на единичном отрезке длиной 1 см, или 1 дюйм. Количество растровых точек, приходящихся на единицу длины (т. е. шаг сетки растра), также имеет свою единицу измерения, называемую" лшиатурой. Линиатура измеряется в так называемых линиях на дюйм (lines per inch, lpi) или линиях на сантиметр (lines per centimeter, lpc). Поскольку для формирования растровой точки требуется несколько реальных точек, линиатура растрового изображения всегда оказывается ниже разрешения принтера.

а

б

в

Рис. 23.15. Различные формы растровых точек: круглая (а); эллиптическая (б); квадратная (в);

Линиатура растра для печати полутоновых изображений может быть задана произвольно. Ограничено при этом только ее верхнее значение. Разумеется, им является разрешение принтера. О том, какое значение линиатуры нужно устанавливать, мы и поговорим в следующем разделе.


Линиатура и количество градаций серого

Отношение разрешающей способности устройства вывода к линиатуре растра дает размер стороны ячейки растра, измеренный в точках принтера. Максимальное количество точек принтера, образующих растровую точку, равно квадрату стороны ячейки. Так, например, если линиатура растра установлена в 100 lpi, а разрешение принтера — 600 lpi, сторона ячейки растра 600/100=6 тбчек. При этих условиях растровая точка формируется из 6x6 = 36 точек принтера. Эта цифра имеет очень большое значение для адекватной передачи фотографического изображения, т. к. определяет количество оттенков серого, которое способен передать растр с заданными параметрами. В общем случае количество оттенков N, передаваемое растром, определяется так:

N= (lpi/dpi) 2 +1,

где Ipi — разрешение устройства вывода, a Ipi — линиатура печати.

Прибавленная единица соответствует белому цвету, когда растровая ячейка вообще не заполнена. Практика показывает, что адекватность передачи полутонов зависит от тонального диапазона изображения, но даже в самом благоприятном случае для этого необходимо, как минимум, 150 оттенков серого. Высококачественная печать требует еще большего количества передаваемых полутонов. Наиболее часто параметры растрирования рассчитывают исходя из необходимости передачи всех оттенков, которые дает компьютерный оригинал, т. е. 256 оттенков при 8-битных полутоновых каналах.

Для примера попробуем рассчитать линиатуру растра, которая требуется для передачи 150 оттенков серого на офисном лазерном принтере, имеющем разрешение 600 Ipi. Несложное преобразование приведенной выше формулы приводит нас к следующему выражению:

lpi =dpi /(SQRT(N-1))

Если подставить в него цифры из нашей задачи, то получится

600 dpi / (SQRT(150-1))= 50 lpi.

Много это или мало? Чтобы было с чем сравнивать, скажем, что большинство газетных иллюстраций печатается растром в 75 lpi, журнальных — 133 lpi , а иллюстрации в хороших альбомах могут иметь линиатуру до 170 lpi и даже больше.

От линиатуры растра также зависит видимое качество иллюстраций. Чем выше линиатура, тем менее заметны образующие растр точки и отпечаток ближе к фотографическому оригиналу. Как видите, полученные нами 50 lpi — очень небольшое значение. Если отпечатать с такой линиатурой иллюстрацию размером с почтовую марку, то вряд ли вы сможете определить; что на ней изображено. Ведь каждая строка растровой сетки будет содержать всего 50 точек.

При печати на офисном принтере для увеличения линиатуры растра приходится жертвовать количеством передаваемых оттенков серого. В большинстве 600-точечных принтеров значение линиатуры растра по умолчанию равно 85 lpi . При такой линиатуре количество оттенков серого на изображениях не превышает

(600 dpi / 85 lpi ) 2 +1= 50.

Это в три раза меньше самого минимума, определенного выше в 150 оттенков. Так объясняется невысокое качество печати изображений на офисных лазерных принтерах (рис. 23.16).

а

б

в

Рис. 23.16. Изображение, отпечатанное с линиатурами 50 (а), 85 (б) и 100 (в) Ipi

Если вы хорошо уяснили материал этого раздела, то теперь для вас очевидно, почему фотонаборные автоматы, обеспечивающие качественную печать, обязаны иметь такое высокое разрешение. Это обуславливается механизмом цифрового растрирования и необходимостью передачи большого количества полутонов. Не составляет труда рассчитать, что для передачи всех 256 оттенков серого на обложке книги, отпечатанной с линиатурой в 150 lpi, требуется разрешение фотонаборного автомата в

150-SQRT(256-1) = 2395 dpi.

Сформулируем простое правило, по которому вы сможете определить разрешение фотонаборного автомата, необходимое для передачи всех полутонов: разрешение печати должно превышать линиатуру в 16 раз.


Линиатура и качество бумаги

Если у вас в распоряжении есть фотонаборный aвтомат с разрешающей способностью в 3600 dpi, вы практически абсолютно свободны в выборе линиатуры. Как мы уже говорили, отпечаток, сделанный с высокой линиатурой,

смотрится лучше, чем отпечаток с низкой. Может быть стоит все время использовать линиатуру в

3600 SQRT(256 - 1) = 255 lpi ?

К сожалению, качество отпечатка определяется не только оригинал-макетом, но и технологией печати. Бумага не является столь "хорошим" носителем, как фотопленка. При печати реальными красками имеет место так называемое растискивание точек. Растискивант — это расплывание точек из-за впитывания офсетной краски бумагой. Для получения доброкачественного отпечатка необходимо, чтобы точки-.растра не накладывались друг на друга. Если же линиатура растра велика, то растискивание приведет именно к этому, и, вопреки ожиданию, качество отпечатка не повысится, а ухудшится. Визуально этот дефект проявляется в появлении "грязи" на иллюстрации в тех местах, где есть локальные уменьшения плотности бумаги, ведь даже самая высококачественная бумага не абсолютно однородна.

Графические редакторы имеют специальный параметр настройки, призванный компенсировать этот эффект. Компенсация сводится к тому, что изображение печатается более светлым, чем требуется, и размер растровых точек уменьшается. Компенсация имеет и отрицательный эффект — ухудшается передача полутонов в светлых областях.

Чем выше качество бумаги и плотнее ее верхний слой, тем большую линиа-туру растра можно задать при печати. Высококачественную печать с линиа-турой 170 lpi вообще можно вести только на специально обработанной, мелованной бумаге. Разумеется, чем лучше бумага, тем она дороже. При выборе линиатуры этот фактор также приходится учитывать. Для выбора правильной линиатуры растра обязательно проконсультируйтесь с типографией. Работники типографии вам обязательно назовут ее оптимальное значение исходя из сорта применяемой бумаги и возможностей оборудования.


Цветоделение и растрирование

Цветные, документы представляют более сложный случай растрирования. Оригинал-макеты для них должны быть представлены в виде нескольких пленок: по одной для каждой наносимой краски. Разделение цветного изображения на отдельные краски (компоненты) называется цветоделением. Простейшим случаем является использование плашечных цветов, каждый из которых выводится на отдельную пленку. Концепция полутонового растра позволяет пользоваться оттенками при работе с плашечными цветами. В PageMaker оттенки определяются заранее при помощи палитры Colors (Цвета). При определении оттенка фактически задаются параметры растрирования, при котором интенсивность цвета уменьшается пропорционально размерам точек полутонового растра. Математически процентный параметр оттенка соответствует размеру соответствующих ему точек растра.

Более общим случаем является цветоделение полноцветных документов. При этом для представления всех цветов используются четыре краски модели CMYK, называемые также триадными. Следовательно, полноцветные документы выводятся с помощью фотонаборного автомата на четыре пленки, соответствующие базовым цветам этой модели. Каждый из них растри-руется отдельно с различными углами наклона растровой сетки.

При горизонтальном или вертикальном расположении линий растра подчеркивается линейная структура последнего, и визуально растр более заметен. Традиционно угол наклона при печати монохромных документов и печати плашечными цветами составляет 45° — это значение обеспечивает наилучшую маскировку линейной структуры растра и проверено временем.

Из-за чего приходится обсуждать углы наклона растра? Прежде всего, из-за того, что этот параметр может быть изменен средствами PageMaker. Наличие соответствующего элемента управления прямо-таки провоцирует изменить наклон растра и посмотреть, что получится. Да, действительно, наклон растра можно изменить, но делать этого не следует практически никогда. Углы наклона, установленные по умолчанию, определены путем многолетних практических экспериментов с цветной печатью и монохромной печатью полутоновых изображений. Кроме того, оптимальный угол наклона растра указан в файле описания выбранного вами принтера (PPD). Если у вас нет веских оснований для изменения наклона растра (и в типографии не возражают), не меняйте принятые по умолчанию значения. Если вы работаете с цветным документом, скорее всего, вывод окончательного оригинал-макета, деленных полос и фотоформ будет выполняться не вами, а в сервисном бюро. Изменив принятые по умолчанию углы наклона, вы готовите его сотрудникам хорошо замаскированную западню. Если же им удастся ее избежать, то в нее почти наверняка попадут в типографии.

С разными углами наклона растра приходится иметь дело почти исключительно при печати триадными цветами. Нанести триадные краски на лист без изменения угла наклона растра просто невозможно — в противном случае цветные точки, соответствующие базовым цветам, будут просто печататься поверх друг друга.

Углы наклона растров для базовых цветов должны быть подобраны так, чтобы были видны все точки, — без этого цвета не смогут смешаться в глазу читателя, образуя, нужный цвет. И тогда не обойтись без частичного перекрывания точек друг другом, но, поскольку триадные краски полупрозрачны, в этом нет большой беды. Тем не менее принятые по умолчанию углы наклона растров, соответствующих базовым триадным цветам, подобраны на основе многолетнего опыта, и для их изменения нужны очень весомые причины. Углы наклона растров должны быть подобраны так, чтобы точки базовых цветов группировались в виде розеток (рис. 23.17). Каждую такую розетку можно рассматривать как некую метаточку, л цветного растра, образующую цвет в данной точке изображения.

Рис. 23.17. Углы наклона растров базовых цветов при печати триадными красками и схема возникновения муара

Правое в&рхнее изображение на рис. 23.17 иллюстрирует еще одну причину, по которой углам наклона растров базовых цветов при печати триадными цветами приходится уделять столь существенное внимание. Если эти углы не согласованы, на изображении появляется муар — грязноватые волны. Муар — часто встречающийся брак цветовоспроизведения.


Линиатура и разрешение точечных изображений

После рассмотрения линейных растров правомерен вопрос о том, какое же разрешение должно иметь сканированное изображение для получения хорошего отпечатка. Разрешение, необходимое для сканированных изображений, связано не столько с разрешающей способностью устройства вывода, сколько с линиатурой печати. Так получается потому, что на отпечатке глаз воспринимает не "реальные" точки принтера, а растровые.

Сколько же растровых точек формируется на основе из одного пиксела изображения? Логично предположить, что одна, поскольку растровая точка и пиксел изображения содержат информацию об одном и том же (256) количестве оттенков серого. В действительности это не так. Разрешение сканированных изображений должно в полтора-два раза превышать заданную ли-ниатуру печати. Например, если вы планируете печатать изображение с линиатурой 150 lpi, разрешение исходного изображения должно находиться в пределах от 225 до 300 lpi. Если изображение имеет большее разрешение, растеризатор сам отбросит лишнюю информацию, содержащуюся в изображении. Разумеется, для этого ему понадобится время, иногда весьма значительное. Поэтому использование завышенного разрешения не только бесполезно, но и вредно, т. к. приводит к увеличению времени печати, не повышая качества отпечатка.

Дотошный читатель, наверное, все-таки задаст вопрос о том, какое разрешение изображений необходимо для печати — полтора или два? Ответ зависит от характера самого изображения. Если изображение изобилует мелкими деталями, то коэффициент должен быть большим.


Стохастические растры

Современные технологии растрирования практически полностью исключили опасность проявления муара при печати триадными красками, но создали и новые проблемы. Для печати стали совместно применяться триадные и смесовые краски, развивается шестикрасочная печать красками Hexahrome. При таком большом количестве красок различие между углами наклона растров теперь столь мало, что возникновение муара становится более вероятным. Тем не менее постоянно идет поиск новых решений, улучшающих структуру растра и передачу полутонов. Наиболее радикальный способ борьбы с муаром и видимой структурой растра принадлежит алгоритмам стохастического растрирования. Идея такого растрирования состоит в том, чтобы отказаться от линейности растра, сделав расположение точек случайным (рис. 23.18).

Примечание

Алгоритмы растрирования построены на том же математическом аппарате, что и передача радиосигналов. В этих терминах линейные и стохастические растры отличаются способом модуляции. У линейных растров плотность определяется размером точек, что характерно для амплитудной модуляции. Стохастические растры передают полутона плотностью размещения точек, т. е. модулированы частотно. Поэтому линейные растры часто называют АМ-растрами (AM — амплитудная мддуляция), а стохастические— ЧМ-растрами (ЧМ— частотная модуляция).

а

б

Рис. 23.18. Линейный и стохастический растр

ЧМ-растрирование позволяет применять сколько угодно красок, не боясь появления муара. Точки расположены случайно, и такая регулярная структура, как муар, просто не может возникнуть. ЧМ-растры оперируют не растровыми точками, а точками принтера, которые гораздо мельче. Поэтому на отпечатках точки менее заметны, а мелкие детали изображений оказываются проработанными гораздо лучше.

Технология ЧМ-растрирования еще достаточно молода и популярна только в кругу своих приверженцев, накопивших некоторый опыт работы с ней. Дело в том, что наряду с очевидными преимуществами она несет в себе ряд серьезных проблем. Главная из них связана с растискиванием точек. Для мелких точек стохастического растра оно плохо предсказуемо и очень сильно зависит от типа бумаги и режимов печати. Маленький размер точек предъявляет высокие требования также к процессам печати и получения фотоформ. Оптимальной для этого представляется технология прямого экспонирования — Computer To Plate (CTP), снижающая искажения, связанные с фотонабором и экспонированием с пленок. Не слишком хорошо выглядит ЧМ-растр на светлых участках изображений, где структура растра становится хорошо заметна.

PageMaker не позволяет работать только с ЧМ-растрами. Если вы хотите опробовать эту технологию в цветной печати, вам придется найти фотонаборный автомат, имеющий RIP с поддержкой ЧМ-растрирования, или предварительно выполнить растрирование в редакторе растровых изображений.


Цветная печать

Выше мы уже обсудили необходимость цветоделения для печати полноцветных документов. Где же происходит цветоделение? Ответ зависит от выбранной технологической цепочки. Она может быть организована двумя способами. Первый предполагает выполнение цветоделения самой программой обработки изображений или иллюстрирования. Второй способ передает решение этой задачи растровому процессору устройства печати, например фотонаборному автомату.


Цветоделение

Говоря о цветоделении в PageMaker, сразу разделим получение форм и собственно цветоделение. Программа действительно выполняет цветоделение при печати, но это справедливо только для объектов и импортированных изображений, находящихся в модели RGB. Объекты, находящиеся в модели CMYK, уже были подвергнуты цветоделению, ведь, как вы помните, цветоделение и заключается в представлении цветов изображения в модели CMYK. Как только объект PageMaker или импортированное изображение оказываются в этой модели — происходит цветоделение.

Мы рекомендуем выполнять цветоделение объектов PageMaker еще в процессе их создания. Это позволит избежать недоразумений (одни объекты цветоделенные, а другие нет) и даст дополнительные возможности при редактировании. Единственное, что совершенно необходимо при таком стиле работы — это предварительное твердое знание условий печати. Как вы увидите в дальнейшем, параметры цветоделения напрямую от них зависят.

Если говорить о векторных объектах PageMaker, то цветоделение можно выполнить сразу при создании таких объектов. Задав цвета заливок и обводок в модели CMYK, вы тем самым выполните их цветоделение. При печати плотность объектов на формах будет в точности соответствовать заданным величинам компонентов. То же относится и к изображениям. Изображения, уже находящиеся в модели CMYK, не подвергаются цветоделению повторно: при печати на формах окажутся их каналы CMYK.

Примечание

PageMaker выполняет цветоделение импортированных изображений при печати только в том случае, если включена система управления цветом. В противном случае все изображения будут преобразованы в полутоновые и окажутся на черной форме.

Для цветов векторных объектов и изображений, заданных в моделях отличных от CMYK, PageMaker автоматически выполнит цветоделение при печати. При цветоделении используется цветовой профиль Separations Printer (Печать цветоделения), заданный в диалоговом oкне Color Management System Preferences (Параметры системы управления цветом).


Генерация черного

Необходимо помнить о том, что черный цвет в модели CMYK избыточен и введен в нее из технологических, а не математических соображений. Для описания субтрактивных цветов было бы вполне достаточно только трех базовых компонент CMY. К сожалению, эти типографские краски не столь идеальны, чтобы их оказалось достаточно и на практике. Краски (особенно голубая) имеют примеси, вызывающие отклонение их цветов от "теоретических" значений. В результате сочетание всех трех красок в равных пропорциях не дает нейтрального серого цвета, а при наложении получается не черный, а "грязный", темно-коричневый цвет. Итак, первая причина введения черной краски в модель CMY состоит в трудности получения нейтральных серых тонов тремя базовыми красками. Второй причиной является предотвращение переувлажнения бумаги. Чтобы получить достаточно плотные темные цвета, нужно нанести на бумагу много цветных красок. Большое количество краски увеличивает время высыхания бумаги и влечет за собой множество проблем: краска на бумаге начинает расплываться, проникать сквозь бумагу, которая коробится, склеивается при складывании в блоки, дает отмарки на соседних оттисках, долго сушится. Черная краска уже в небольших количествах способна обеспечить достаточно высокую плотность.

Поскольку черный цвет не является "настоящим" компонентом цветовой модели, необходим алгоритм, указывающий, в каких цветах он должен присутствовать. Для генерации черного применяют три алгоритма, которые обозначаются загадочными аббревиатурами — UCR, GCR и UCA.

Исторически первым из них был метод Undercolor Removal (UCR). Он состоит в замене равного сочетания всех трех красок триады в тенях изображения на черную краску. Если в какой-либо области изображения содержание красок триады превышает заданный процент, то алгоритм UCR снижает их общее содержание и добавляет вместо этого некоторое количество черной краски. В результате действия этого алгоритма получается контурный черный канал, в котором видны только наиболее темные фрагменты изображения. В средних тонах изображения содержание черной краски оказывается совсем небольшим, а в светах полностью отсутствует. Этот метод хорош, если сюжетно важные и яркие объекты находятся в светах изображения. В противном случае лучше воспользоваться следующим способом, GCR.

Алгоритм Gray Component Replacement (GCR) работает несколько иным образом. Он основан на том, что практически каждый цвет содержит некоторое количество серого, как равного количества всех цветов триады. Например, цвет C20M42Y60 можно рассматривать как смесь COM22Y40 и 20%-ного серого. Таким образом, GCR может заменить цвет C20M42Y60 на COM22Y40K20. Эта несколько упрощенная модель GCR тем не менее хорошо передает идею метода. GCR обеспечивает более равномерную генерацию черного цвета, чем UCR. Очевидно, замена серого также действует наиболее сильно на тени изображения. Но при этом замена может происходить и в средних тонах, и даже в светах. Более того, количество заменяемого цвета можно регулировать. Так, цвет C20M42Y60 можно заменить на COM22Y40K20, C10M32Y50K10 или C15M37Y55K5.

Чтобы создать на отпечатке насыщенные тени, с хорошей проработкой деталей, совместно с GCR применяется обратный алгоритм, называемый Undercolor Addition (UCA). Дело в том, что при использовании GCR в тенях изображений убирается много триадных красок и эти участки становятся серыми, плоскими, с плохо проработанными деталями. Это хорошо заметно только на тех изображениях, где большая часть тонов смещена в область черного. UCA действует как "UCR наоборот": замещает плотную черную краску на сочетание триадных.

Чтобы избежать переувлажнения бумаги, в установки цветоделения вводятся ограничения на максимально допустимое количество наносимой на бумагу краски. Расчет количества красок прост. Если количество каждой краски может изменяться от 0 до 100%, то их максимальное общее количество составит 400%. Хотя теоретически это возможно (PageMaker не запретит вам создать цвет C100M100Y100K100), на практике никогда не используется. Установка максимально возможного значения дает полную гарантию того, что произойдут все перечисленные выше неприятности и тираж будет испорчен.

Максимальное количество краски зависит от типа бумаги. Чем хуже качество бумаги и больше ее впитывающая способность, тем сильнее нужно ограничивать количество наносимой краски. При печати на немелованной офсетной бумаге разумным будет 300%-ный предел. При печати на газетной бумаге понизьте предельное количество до 260—280%. При печати на высококачественной мелованной бумаге безопасно увеличить предельное количество до 310—320%. Приведенные цифры относятся только к наиболее распространенной, офсетной печати.

Примечание

Ограничивая максимальное количество краски при цветоделении, приходится тем самым ограничивать передаваемый цветовой диапазон. Чем меньше крас--ки наносится на бумагу, тем труднее передать яркие насыщенные цвета. С таким ограничением приходится мириться.

В любом случае, перед выполнением цветоделения стоит проконсультироваться в типографии относительно рекомендованного количества красок для выбранного типа бумаги. Кроме того, необходимо учитывать и тип печатной машины. Для рулонной печати обычно используют меньшее количество красок, чем для листовой.

PageMaker не позволяет устанавливать произвольные значения перечисленных параметров генерации черного, поскольку для цветоделения используется цветовой профиль. Все эти параметры оказываются "учтены" в цветовом профиле. Но теперь, зная о них, вы можете выбрать из множества профилей, поставляемых с программой и с разнообразным оборудованием, тот, который необходим для печати тиража в ваших условиях. Например, увидев в имени профиля Light GCR 280 US вы можете сказать, что это профиль стандарта SWOP с низкой генерацией черного методом GCR и предельным количеством краски 280%.


Особые предосторожности

Ограничения цифровых растров и технологий типографской печати влекут за собой некоторые потенциальные осложнения при печати. Их не стоит бояться, но надо учитывать.


Размеры растровой точки

Технология печати налагает ограничение на минимальную и максимальную плотность растра. Слишком светлые точки оказываются непропечатанными, а самые темные сливаются в сплошную заливку (растискивание). Результатом этого оказывается потеря деталей в тенях и белые или цветные пятна на светлых участках изображений.

Единственный способ избежать подобных неприятностей — это полностью отказаться от крайних участков тонового диапазона. Минимальная и максимальная плотность растра зависит от типа бумаги. Ориентировочные величины приведены в табл. 23.1.

Таблица 23.1. Минимальные и максимальные допустимые плотности растра

Тип бумаги | Минимум, % | Максимум, %
Мелованная | 5 | 95
Немелованная | 10 | 90
Газетная | 12 | 88

При подготовке изображений сужайте их тоновый диапазон до приведенных выше величин. Подходите к этому правилу разумно. Если, например, в самых светлых участках изображения и не должно быть деталей (световые блики, искры и т. п.), то в ограничении светов нет смысла. Напротив, появление растра на таких участках изображения сделает его "вялым".


Тонкие линии

Задавая толщину для линий и обводок, следует помнить о минимально допустимых значениях. На первый взгляд минимальная толщина линии должна совпасть с разрешением фотонаборного автомата (2400 dpi):

1" / 2400 dpi = 0,000417'=0,03 pt

К сожалению, это не так. Если учитывать сказанное в предыдущем разделе о минимальном размере растровой точки, то расчет будет иным:

( SQRT(dpi / lpi) 2 D min )/ dpi,

где dpi — разрешение печати, lpi — линиатура, D min — минимальная плотность растра. Числитель этой дроби представляет количество реальных точек принтера в растровой точке при заданной линиатуре и минимальной плотности растра. Например, для немелованной бумаги и линиатуры 133 lpi получим:

( SQRT(2400 dpi / 133 lpi) 2 0,1 )/ dpi=0,00238"=0,17pt,

Сравните эти два результата. Для приведенных условий минимальная толщина линий оказывается в шесть раз больше, чем позволяет разрешение фотонабора. Помните об этом и не делайте линии слишком тонкими, иначе в них появятся разрывы или они вообще не будут напечатаны.


Растяжки

Градиентные заливки, которые художники называют "растяжками", тоже представляют особую сложность при печати. Это вызвано ограниченным количеством оттенков, передаваемых растром. Создавая цветовую растяжку, вы предполагаете, что на отпечатке будет сделан плавный переход от начального полутона серого (или хроматического цвета) к конечному. Но из-за того, что переход полутонов реализуется механическими средствами, вместо плавного перехода получается ступенчатый. Это может быть практически незаметно, но может и сильно бросаться в глаза. Степень ступенчатости зависит от линиатуры растра, разрешения лазерного принтера или фотонаборного автомата, различия начального и конечного значений растяжки и длины растяжки. Вполне возможно такое сочетание значений этих параметров, при котором количество переходов тона будет явно недостаточным.

В этом случае каждый из переходов становится отчетливо отличим от соседних, как показано на рис. 23.19, — появляется "полосатость". На рисунке начальное и конечное значения цветовой растяжки одинаковы. Рис. 23.19, а отпечатан с разрешением 600 точек/дюйм, а рис. 23.19 — 300 точек/дюйм при одинаковой (75 линий/дюйм) линиатуре. При уменьшении разрешения растр той же линиатуры способен передать меньше оттенков серого. Поэтому во втором случае "полосатость" растяжки больше. Увеличивается она и при повышении линиатуры, о чем свидетельствует сравнение рис. 23.19 и рис. 23.19 . Оба напечатаны с одинаковым разрешением (300 точек/дюйм), но с разной линиатурой растра — 75 и 120 линий/дюйм, соответственно.

Рис. 23.19. Зависимость "полосатости" цветовой растяжки от линиатуры растра и разрешения печатающего устройства

К счастью, теперь большинство графических приложений автоматически рассчитывают необходимое количество переходов, поэтому "полосатость" растяжек стала менее распространенным дефектом. Однако понимание механизма образования цветовых растяжек поможет вам полностью избежать этого нежелательного эффекта.

Следует иметь в виду, что "полосатость", проявляющаяся на цветовых растяжках в контрольных отпечатках, полученных на лазерном принтере, может пропасть при выводе на фотонаборный автомат с высоким разрешением. С другой стороны, если окончательный оригинал-макет выпускается на лазерном принтере с разрешением 300 или 600 dpi, забывать о возможности возникновения "полосатости" нельзя.

"Полосатость" возникает, если количество оттенков, передаваемых устройством вывода, ограничено. В этом случае растяжка представляет собой набор полос, каждая из которых соответствует следующей промежуточной градации. При достаточной длине растяжки полосы становятся заметны.

Особенно явно видны полосы на растяжках при печати на лазерном принтере. Выше мы рассчитывали количество оттенков, передаваемых растром в 85 линий/дюйм на 600-точечном лазерном принтере. Оно составляет 50 оттенков. Если страница содержит растяжку от черного к белому длиной 200 мм, то на один передаваемый растром оттенок приходится 200:50 = 4 мм. Таким образом, растяжка будет напечатана не в виде плавного перехода, а в виде пятидесятичетырехмиллиметровых полос. При выводе этой же страницы на фотонаборном автомате с разрешением 2400 точек/дюйм количество оттенков, передаваемых растром 85 линий/дюйм, составит (2400:85) 2 + 1 = = 798. На один оттенок в этом случае придется 200:798 = 0,25 мм. Полосы такой толщины близкого оттенка не будут заметны, и растяжка будет производить впечатление плавной. Вообще, видимая плавность растяжки сохраняется, пока размер шага не превышает 0,75 мм.

В общем случае количество градаций в растяжке определяется по формуле:

N=(dpi / lpi) 2 D 2 -D 1 ,

где dpi — разрешение устройства вывода; lpi — линиатура печати; D 2 — плотность конечного цвета растяжки; D 1 — плотность начального значения растяжки.

Первый множитель представляет собой количество оттенков, передаваемое растром, а второй — долю градаций цвета в растяжке от общего их количества.

Как же получить плавную растяжку большой длины? Наилучшим решением будет применение RIP с интерпретатором PostScript 3. Новая версия PostScript поддерживает не 256, а 4096 градаций серого, что позволяет полностью исключить проявление "полосатости" растяжек. Если такой RIP недоступен, создавайте растяжки в программе обработки точечных изображений. После того как растяжка создана, добавьте к ней немного цветного шума. Это замаскирует четкие границы полос и создаст ощущение плавности перехода цветов.


Разработка спускового макета

Дополнение Build Booklet (Спуск полос) практически не претерпело изменений со времен PageMaker 5.O. Оно разработано на базе автономной (и очень дорогой) системы формирования спускового макета фирмы Adobe PressWise и предоставляет некоторые из ее возможностей пользователям PageMaker.

Дополнение Build Booklet (Спуск полос) позволяет разместить на одном развороте несколько страниц таким образом, чтобы потом их можно было собрать в брошюру. Кроме брошюр, возможно формирование книжных тетрадей для последующей сшивки. Дополнение не предполагает спуска полос в его "полновесном" виде, хотя бы уже потому, что не позволяет осуществлять вертикальное буклетирование. В любом случае, создание спускового макета лучше доверить типографии или бюро предпечатной подготовки, которые имеют опыт такого макетирования на монтажном столе или с помощью профессионального программного обеспечения.


Верстка спускового макета — непростое дело

Дополнение Build Booklet (Спуск полос) может работать с публикациями, в состав которых входит структурный список книги. С- одной стороны, это очень удобно, с другой — исключительно рискованно.. Несмотря на широкие возможности этого дополнения, вряд ли можно считать его пригодным для изготовления спускового макета, печатаемого на больших типографских листах. Тем не менее оно окажет вам неоценимую помощь при изготовлении оригиналов для малотиражной печати с помощью ризографа или ксерокса.

Построение даже простейшего буклета вручную — замысловатая операция. Главная сложность заключается в порядке следования страниц. Если вы печатаете по одному развороту (паре страниц) на листе и запечатываете лист с двух сторон, то для выпуска брошюры из 16 страниц вам понадобятся 4 листа бумаги. Но страницу с номером 1 при этом придется печатать второй, справа от страницы под номером 16, а на обратной стороне того же листа должны быть отпечатаны страницы с номерами 15 и 2. Достаточно замысловато, а ведь это — простейший вариант брошюровки. При необходимости печатать на одной стороне листа несколько страниц приходится решать самые настоящие головоломки.

Вторая проблема — учет так называемого сползания. Сползание вызвано тем, что бумага имеет ненулевую толщину. В результате этого внутренние листы буклета или тетради имеют меньшие размеры, чем внешние. Чтобы убедиться в этом, попробуйте согнуть пополам десяток сложенных в стопку листов одинакового размера. Внутренние листы неминуемо будут выступать из такой тетради. После обрезки тетради внутренние страницы будут иметь меньшие размеры, чем наружные. Очевидно, это уменьшение размеров страниц от внешних к внутренним происходит за счет внешних полей. Для того чтобы размер внешних полей был постоянен, необходимо их увеличение и уменьшение внутренних полей. При этом ширина полосы набора остается постоянной, только она "сползает" внутрь тетради.

При большом объеме публикации сшивка в скрепку оказывается невозможной не только по причине большого размера требующейся скрепки. Более важной причиной является как раз сползание, которое уже при толщине блока в четыре десятка страниц становится недопустимо большим. Решение проблемы — в разбивке публикации на тетради, так называемые сигнатуры, которые представляют собой отдельные буклеты, а затем скрепляются шитым или клеевым переплетом. Дополнение Build Booklet (Спуск полос) позволяет формировать из файла публикации требуемое количество сигнатур.


Предварительные действия

Прежде всего необходимо еще до начала верстки тщательно определить размеры страниц документа исходя из способа последующей брошюровки, а следовательно, и типа буклета. Например, если страницы публикации имеют размер А4, их никак не удастся печатать разворотами на листах стандартного формата Legal.

Очень важно, чтобы буклет начинался с нечетной страницы, поскольку вся логика работы дополнения Build Booklet (Спуск полос) основана на этом предположении.

Дополнение Build Booklet (Спуск полос) строит совершенно новую публикацию, сохраняя исходную в неприкосновенности, поэтому перед построением буклета публикацию обязательно надо сохранить. В противном случае первым, что сделает дополнение Build Booklet (Спуск полос), будет запрос на сохранение публикации.

Спусковой макет разрабатывается в последнюю очередь, после того как верстка публикации уже завершена и к ней добавлены оглавление и предметный указатель. Следует иметь в виду, что делать корректуру по отпечатанным листам спускового макета практически невозможно. Поэтому корректуру следует вносить в первоначальную верстку, а затем создать буклет снова.


Построение буклета

Если дополнение Build Booklet (Спуск полос) было установлено в процессе инсталляции приложения PageMaker, ему соответствует одноименная строка в меню Utilities (Сервис) во вложенном меню Plug-ins (Дополнения). После ее выбора на экране открывается диалоговое окно, представленное на рис. 23.20.

Рис. 23.20. Главное диалоговое окно дополнения Build Booklet

Вначале выберите вариант спускового макета в, раскрывающемся списке, представленном на рис. 23.21.

Рис. 23.21. Выбор варианта спускового макета

Вариант макета 2-up saddle stitch (Брошюра) предполагает печать двух страниц публикации на листе бумаги "бок о бок", с последующей сборкой листов в пачку, фальцовкой перегибом листов по средней линии и сшивкой брошюры или скреплением листов скрепками. Это — традиционный вариант печати и фальцовки брошюр.

Вариант макета 2-up perfect bound (Книга) предполагает формирование из публикации нескольких "частичных буклетов" — тетрадей, которые брошюруются отдельно, а затем собираются в общий переплет. При выборе этого спускового макета становится доступным поле Pages per group (Страниц в тетради). Задавая количество страниц в тетради, вы сообщаете дополнению исходные данные, необходимые для перестановки страниц исходной публикации таким образом, чтобы после сборки и фальцовки тетрадей номера страниц шли в верной последовательности.

Следующие типы спусковых макетов: 2-up consecutive (2-полосный буклет), 3-up consecutive (3-полосный буклет) и 4-up consecutive (4-полосный буклет) предполагают последовательное размещение с последующей фальцовкой "гармошкой".

После выбора типа спускового макета проверьте размеры листа, представленные в верхнем левом углу диалогового окна. Если эти размеры превышают размеры листов, заряженных в принтер, вам придется либо перейти на большие листы бумаги, либо уменьшить размеры страницы публикации.

Если выбран тип макета, предполагающий фальцовку сгибом листов по средней линии, можно задать параметры компенсации эффекта сползания. Для того чтобы определить численные значения этих параметров самостоятельно, не обойтись без эксперимента. Выведите пробную публикацию на бумагу, которую предполагаете использовать для печати реальной публикации. Согните полученные листы пополам и вложите их друг в друга, собирая тетрадь. Измерьте расстояние между кромками внешнего и внутреннего листов тетради. Оно будет равно величине накопленного сползания — припуску. Введите эту величину в поле Total creep (Припуск).

Как правило, корешковые поля (место для подшивки) учитываются при задании величины внутренних полей в макете страницы при установленном флажке Double-sided (Двухсторонняя) в диалоговом окне Document Setup (Параметры документа). Пространство для подшивки можно добавить к внутренним полям и в диалоговом окне дополнения Build Booklet (Спуск полос), задав его величину в поле Gutter space (Интервал).

Установка флажка Place guides in gutter (Направляющие в корешок) включает режим размещения направляющих по линиям раздела страниц исходной публикации, которые PageMaker объединяет в единую страницу.

Флажок Impose entire booklist (Все публикации книги) устанавливается в том случае, когда в спусковой макет необходимо включить все файлы, входящие в структурный список книги. Если в публикации, активной на момент вызова дополнения Build Booklet (Спуск полос), структурный список отсутствует, данный флажок остается недоступным.

Как правило, при необходимости переупорядочения страниц публикации прибегают к помощи команды Sort Pages (Сортировать страницы) меню Layout (Макет). Но дополнение Build Booklet (Спуск полос) также дает возможность переставить страницы публикации при формировании спускового макета (в списке в левой части диалогового окна). Выделите страницу (или группу страниц) щелчком мыши при одновременном нажатии клавиши <Alt> и перетащите ее на новое место. Для выделения группы смежных страниц выделите последнюю страницу группы щелчком мыши при одновременном нажатии клавиши <Shift>, несмежных страниц — щелчком мыши на каждой из них при одновременном нажатии клавиши <Ctrl>.

Вы не должны вручную определять порядок следования страниц в спусковом макете — это делается автоматически. В большинстве случаев данным механизмом пользуются для вставки пустых страниц между сигнатурами при верстке спускового макета по типу книги. Для того чтобы вставить в публикацию пустую страницу, перетащите горизонтальную стрелку на нужную позицию публикации и щелкните мышью на кнопке Blank page (Пустая страница). Для того чтобы удалить страницу публикации, достаточно выделить ее и щелкнуть мышью на кнопке Delete (Удалить). Имеется также возможность изменить порядок следования страниц на обратный — кнопка Invert pages (Обратный порядок).

Все заказанные изменения можно отменить щелчком мыши на кнопке Revert (Восстановить).

После того как сделаны все необходимые установки, щелкните мышью на кнопке ОК. PageMaker спросит, следует ли сохранить активную публикацию, а затем построит новую публикацию с порядком страниц, измененным в соответствии со сделанными установками.

Дополнение Build Booklet (Спуск полос) удаляет все элементы со страниц-шаблонов (в новой публикации они будут пустыми), копируя их на соответствующие страницы. Например, вместо автоматической нумерации на страницах будут представлены "жесткие" колонцифры, располагающиеся в соответствии с положением колонцифр на странице-шаблоне.

Примечание

Среди списка возможных типов спускового макета имеется вариант None (He определен). В полях Spread size (Размер листа) при этом значатся размеры

оригинального листа публикации. При построении буклета такого типа дополнение просто переносит элементы, находящиеся на шаблон-страницах, на соответствующие страницы публикации. Иногда перенос элементов шаблонов на страницы является самостоятельной задачей, независимой от организации спускового макета. Дополнение Build Booklet (Спуск полос) позволяет проделать эту рутинную и возможно длительную работу.


Предоставление макета в сервис-бюро

До сих пор мы говорили просто о "передаче макета в сервис-бюро" для вывода на фотонаборном автомате. Но для нас, практиков, весьма существенным является вопрос о том, в какой форме следует передавать макет. Для верстальщика макет — это набор файлов. Какие файлы следует взять с собой в сервис-бюро? Можно ли подобрать их автоматически? Как проверить все ли необходимые файлы имеются в публикации? На эти и многие другие вопросы вы найдете ответ в данном разделе.

Для начала скажем, что макет может быть предоставлен в бюро предпечат-ной подготовки в двух формах: в виде верстки и в виде готового для вывода PostScript-файла. Первый вариант предполагает передачу всех файлов PageMaker, на которые разбита публикация, всех связанных файлов, шрифтов и т. п. Во втором случае передается всего лишь один, но очень большой файл, который работникам сервис-бюро остается только поставить в очередь печати фотонаборного автомата. Оба способа имеют свои преимущества и недостатки. Ниже мы рассмотрим их только с позиции удобств для верстальщика, но предварительно сделаем одно немаловажное замечание. Если бюджет публикации ограничен, а полос для фотонабора много, вы можете сильно сэкономить, принеся в сервис-бюро готовые PostScript-файлы. Тогда в большинстве случаев работники сервис-бюро предоставляют весьма существенную (до 30%) скидку.


Передача верстки в сервис-бюро

При передачи в сервис-бюро верстки вы несете ответственность за правильность вывода только в той мере, в которой отвечаете за верстку. Все настройки фотонаборного автомата работники сервис-бюро выполняют сами, что гарантирует их правильность. Это является основным и существенным преимуществом такого способа предоставления макета. При выполнении в сервис-бюро дополнительной предпечатной подготовки (треппинг, создание спускового макета) верстка обеспечивает ему дополнительную свободу и является предпочтительной формой. На вашей совести остается только сборка всех внешних файлов макета для передачи и проверка их актуальности. Работа по сборке может быть упрощена и автоматизирована использованием дополнения Save for Service Provider (Сохранить для сервис-бюро).


Какие файлы требуются для печати в сервис-бюро

При передаче верстки в сервис-бюро необходимо предоставить все файлы, требующиеся для удаленной печати:

  • файлы публикации, т. е. все файлы PageMaker, на которые разбита публикация;
  • связанные внешние файлы, не хранящиеся внутри публикации. Во избежание путаницы мы вообще рекомендуем избегать хранения файлов внутри публикации или, по крайней мере, подходить к этому единообразно: либо все не хранить, либо, напротив, — хранить все. О связывании файлов и о том, как изменить место хранения для всех файлов публикации одновременно говорится в гл. 11;
  • использованные шрифты;
  • файл настроек трекинга TRAKVALS.BIN.

Все эти компоненты являются необходимым условием правильного вывода пленок. Если вы забудете что-либо из этого списка, то практически наверняка получите испорченные пленки, за которые сервис-бюро не будет нести никакой ответственности.

Не менее важным условием правильной печати публикации является актуальность связей с внешними файлами. Выполнение всех перечисленных требований облегчается использованием замечательного дополнения Save for Service Provider (Сохранить для сервис-бюро), входящего в комплект PageMaker 7.O. Главное окно этого дополнения представлено на рис. 23.22.

Первоначально вкладка Summary (Общие данные) представляет две кнопки, предназначенные для двух разных вариантов проверки: проверка публикации и проверка файла печати. Мы начнем описание дополнения с первого варианта.

Нажатие кнопки Preflight pub (Проверить) запускает программу проверки публикации на предмет связанных файлов и использованных шрифтов. После некоторого "размышления", длительность которого зависит от длины и сложности публикации, над кнопками появятся две квадратных пиктограммы с пояснительным текстом. Пиктограммы отображают результат проверки публикации: первая говорит о проверке доступности шрифтов, вторая — о доступности и актуальности связей с внешними файлами. Если пиктограмма содержит галочку зеленого цвета, то все в порядке — проверка прошла успешно. Если пиктограмма содержит красный крестик, то эти ресурсы следует проверить. Пояснительный текст содержит краткое описание типа найденных ошибок. Более подробную информацию об этих ошибках можно получить в других разделах диалогового окна. Большим достоинством дополнения является то, что оно также позволяет вносись коррективы в связи, определенные в публикации, добиваясь устранения найденных ошибок.

Щелчок мышью на каждой пиктограмме открывает соответствующую вкладку диалогового окна — Fonts (Шрифты) и Links/OPI (Связи/OPI).

Рис. 23.22. Окно дополнения Save for Service Provider, вкладка Summary

Вкладка Fonts (Шрифты) (рис. 23.23) открывает список использованных в публикации шрифтов. Если какой-либо шрифт недоступен, то в графе Installed (Установлен) появляется слово No (Нет). В этом случае следует открыть Adobe Type Manager или папку шрифтов Windows и установить данные шрифты. При повторной проверке публикации в графе Installed (Установлен) должно появиться Yes (Да). В графе Kind (Тип) содержится информация о типе использованного шрифта, что облегчает его поиск или напоминает о том, что в публикации встречаются шрифты разных типов. О предпочтительности применения шрифтов Туре 1 рассказано в гл. 4. Может оказаться полезной и информация о странице, на которой обнаружен неустановленный шрифт. Скорее всего, это погрешность верстки, и ее необходимо устранить, изменив гарнитуру, которой отформатирован фрагмент текста.

Вкладка Links/OPI (Связи/OPI) (рис. 23.24) содержит список всех связанных файлов публикации (наподобие диалогового окна Links Manager (Связанные файлы)), информацию об актуальности связи, типе файла и первам его местонахождении в публикации. Опираясь на эту информацию, легко идентифицировать утраченные и необновленные связи. Отметка No (Нет)

Рис. 23.23. Окно дополнения Save for Service Provider, вкладка Fonts

Рис. 23.24. Окно дополнения Save for Service Provider, вкладка Links/OPI

в графе Link (Связанный файл) говорит о том, что соответствующий файл отсутствует и его надо отыскать. Фраза The selected item is of date (Выбранный элемент устарел) в поле Info (Информация) и отметка Outdated (Устарел) в графе Link (Связанный файл) говорят о том, что элемент требует обновления связи. Обе ошибки могут быть исправлены нажатием кнопки Relink (Обновить). Если связь требует обновления, она будет обновлена, а если связь разорвана, дополнение откроет стандартное диалоговое окно файла Windows, которое позволит вам указать новое местоположение файла.

Оба упомянутых раздела содержат флажок List problems only (Показать только проблемы), который предотвращает вывод избыточной во время проверки информации об элементах, с которыми все в порядке.

Вкладка Printing (Печать) (рис. 23.25) содержит перечень всех установок, сделанных в диалоговых окнах команды Print (Печать). Будучи собранными в одном месте, они значительно легче контролируются.

Рис. 23.25. Окно дополнения Save for Service Provider, вкладка Printing

Столь же легкими для восприятия делает установки цветоделения и треппинга вкладка Inks (Краски). В PageMaker для Macintosh она называется Colors (Цвета) (рис. 23.26).

Вся информация, отображаемая в диалоговом окне Save for Service Provider (Сохранить для сервис-бюро), может быть распечатана в виде отчета нажатием на кнопку Print (Печать). При этом откроется диалоговое окно, изображенное на рис. 23.27. В нем необходимо определить PostScript-принтер, на котором будет напечатан отчет, и те разделы диалогового окна, которые должны в него попасть. Можно также с помощью флажка All (В файл) направить печать отчета в PostScript-файл печати для вывода его работниками сервис-бюро. Впрочем, дополнение Save for Service Provider (Сохранить для сервис-бюро) предлагает и более гибкий способ создания отчетов, о котором будет рассказано ниже.

Рис. 23.26. Окно дополнения Save for Service Provider, вкладка Colors

Рис. 23.27. Диалоговое окно Print report to

Рис. 23.28. Создание пакета файлов для передачи в сервис-бюро

После того как публикация еще раз проверена и ошибки не обнаружены, самое время "собрать в кучку" все файлы публикации для передачи в сервис-бюро. С помощью кнопки Package (Упаковать) откройте диалоговое окно (рис. 23.28), которое позволяет записать в отдельную папку все файлы, требуемые для печати (пакет). Установив флажок Copy fonts (Скопировать шрифты) и переведя соседний переключатель в положение То file (Все), вы даете указание скопировать в эту папку все шрифты, используемые в публикации. Флажок Update links in source pub before packaging (Обновить связи в исходной публикации перед формированием пакета) полезен при сохранении уже проверенной в прошлом сеансе работы с дополнением публикации. Все связанные внешние файлы помещаются в пакет автоматически.

Также в пакет может быть помещен файл отчета либо в формате PageMaker, либо в текстовом формате. Последний удобен для передачи в сервис-бюро. Если вы передаете отчет в виде распечатки, целесообразнее выбрать формат PageMaker. Формат отчета устанавливается выбором его из списка Report type (Тип отчета). Кнопка Notes (Замечания) открывает диалоговое окно Printer Instructions (Инструкции по печати) (рис. 23.29), позволяющее ввести в отчет дополнительную информацию о требованиях к выводу макета: установках ориентации эмульсии и негативного/позитивного отпечатков, ориентации бумаги и типе носителя (пленка/бумага/заказной тип), заказчике работ.

Нажатие кнопки Save (Сохранить) запускает формирование и сохранение пакета. Если был установлен флажок Auto open package report (Автоматическое открытие отчета) в окне на рис. 23.30, то по завершении этого будет открыт файл отчета для распечатки или редактирования. Флажок Include hidden layers (Включить скрытые слои) заставляет PageMaker учитывать и те элементы публикации, которые находятся на скрытых слоях многослойной публикации (см. гл. 13).

Рис. 23.29. Диалоговое окно Printer Instructions

Любопытные возможности предоставляет дополнение Save for Service Provider (Сохранить для сервис-бюро) для проверки файлов печати (о создании файла печати см. следующий раздел). Для проверки файла печати следует нажать кнопку Preflight .ps (Проверить .ps) в разделе Summary (Общие данные) названного дополнения. При этом открывается стандартное файловое диалоговое окно Windows, позволяющее указать файл для проверки. В результате проверки выводится практически вся информация, которая сообщалась бы при проверке файла публикации! Исключением является лишь информация о треппинге и положении переключателей Mirror (Зеркало) и Negative (Негатив), ведь принтер "не знает", что он печатает — негатив или позитив, прямое изображение или зеркальное. Такая проверка файла печати позволяет отловить не включенные в него шрифты и отсутствующие OPI-связи. Даже после проверки публикации мы рекомендуем дополнительно проверить и файл Печати, предназначенный для передачи в сервис-бюро. Осторожность редко бывает излишней...


Вывод PostScript-файла

При печати на PostScript-принтер его драйвер формирует описание страниц публикации на этом языке и посылает в принтер. Операционная система и PageMaker позволяют перенаправить эту информацию в файл вместо принтера. Впоследствии можно в любой момент послать такой файл на принтер, и он напечатает требуемые страницы публикации. При непосредственной печати на подключенный к вашему компьютеру принтер эта промежуточная операция не имеет смысла. Важной она становится при печати по сети на удаленном принтере (по сети передается уже готовый файл печати) или при передаче публикации в сервис-бюро. Поскольку на принтер посылается вся информация о страницах публикации (в том числе настройки текста, изображения и шрифты), в файле также оказывается вся информация для последующей печати. Следовательно, достаточно создать такой файл печати и послать его на фотонаборный автомат, чтобы-получить готовые пленки для печати в типографии.

Если вы намерены передавать в сервис-бюро файл печати, вы берете на себя некоторую часть их работы. Вам самим придется сделать все установки режимов печати на фотонаборном автомате, не имея опыта работы с ним. Но не стоит пугаться. Последовав приведенному ниже рецепту, вы наверняка сможете создать файл печати и даже частично удостовериться в его правильности.

  1. Установите драйвер фотонаборного автомата. Необходимо учитывать, что, как и принтеры, фотонаборные автоматы обладают различными аппаратными особенностями, которые необходимо учитывать при создании файла печати. Информация обо всех этих особенностях находится в PPD-файле описания PostScript-принтера. Следовательно, предварительно вам необходимо связаться с сервис-бюро и получить у них этот файл, поставляемый производителями фотонаборного автомата. Затем с помощью программы установки драйверов Adobe PostScript, находящейся на компакт-диске PageMaker, установить драйвер этого автомата, указав ей на полученный PPD-файл. При печати из PageMaker в поле Printer (Принтер) обязательно должен быть указан драйвер фотонаборного автомата, а в поле PPD — соответствующий файл его описания (см. рис. 23.3).
  2. Определите, какую часть публикации необходимо вывести на фотонаборный автомат. Часто на фотонаборный автомат выводится не вся публикация, а лишь несколько ее страниц. Определите номера этих страниц и введите их в поле Ranges (Выборочно) диалогового окна Print Document (Печатать документ). Снимите флажки Collate (Копии в подбор), Reverse (Обратный порядок), Proof (Черновик). Сбросьте флажок Print blank pages (Пустые страницы), ведь платить за эти страницы придется вам. Из списка Print (Печатать) выберите вариант Both Pages (Подряд).
  3. Проверьте правильность установки флажка Reader's spreads (Книжные развороты): чаще всего он включается только для вывода корректуры, а при выводе оригинал-макета не используется. Если публикация требует фальцовки и сшивки, то на страницах разворота будут находиться не соседние страницы спускового макета и их все равно придется разрезать при монтаже.
  4. Проверьте правильность установки флажка Ignore "Non-Printing" setting (Игнорировать атрибут "Непечатный"). Если вы специально не создавали объектов, не предназначенных для вывода на печать (ремарки, "скрытые" элементы оглавления и т. п.), установите этот флажок. В противном случае убедитесь, что данный атрибут имеют только такие объекты.

    Отключите переключатели группы Book (Книга). Во избежание путаницы с форматами страниц мы рекомендуем печатать страницы только текущего открытого файла. И вообще, вывод на фотонабор большой книги — пока еще очень большая редкость.

  5. Проставьте ориентацию листа. Если вы выводили корректуру разворотами, а фотонабор — отдельными страницами, ориентация страницы потребует изменения, которое PageMaker не сделает автоматически.
  6. Отключите масштабирование и разбиение. Эти установки могут оказаться включенными, если они использовались при выводе корректуры на принтер. Вывод на фотонабор, разумеется, производится в натуральную величину, и забытый флажок Reduce to fit (Уменьшить по формату) в диалоговом окне Print Paper (Печатать, Бумага) может привести к порче пленок. Переключатель Scale (Масштаб) обязательно должен находиться в верхнем положении, а в поле рядом с ним должно стоять значение 100%.
  7. Включите печать типографских меток. Для приводки форм и обрезки отпечатков на пленках обязательно должны быть приводные и обрезные метки ("кресты" и "мишени"). При печати работники типографии ориентируются также на шкалы с градациями цветов и серого. По шкалам можно судить о правильности установок подачи краски, равномерности протяжки бумаги, величине растискивания и пр. Все эти типографские метки автоматически выводятся на лист при включенном переключателе Printer's marks (Типографские метки) в диалоговом окне Print Paper (Печатать, Бумага). Типографские метки помещаются вне площади страниц и требуют дополнительного пространства при выводе.
  8. Установите формат "бумаги". Фотонаборные автоматы поддерживают произвольный формат вывода, находящийся в пределах максимальной ширины пленки, а также набор предопределенных значений, используемых наиболее часто. Устанавливая формат бумаги, не забывайте о дополнительном пространстве, занимаемом типографскими метками. Формат должен быть достаточно большим, чтобы вместить страницу вместе с метками. На каждый фиксированный формат бумаги драйвер фотонаборного автомата имеет соответствующий формат Extra, позволяющий разместить за пределами страницы типографские метки. Если публикация сверстана не на стандартный формат, выберите из списка форматов вариант Custom (Заказной). При установленном флажке Printer's marks (Типографские метки) в открывшемся диалоговом окне появятся оптимальные значения формата Листа, необходимые для печати страниц вместе с метками — вам останется только нажать кнопку ОК. Тем не менее нелишним будет убедиться, чтo формат вычислен верно. При правильной установке формата значения Offset using paper size (Отступы от краев бумаги) не должны быть подсвечены красным и будут составлять 1,6 мм.
  9. Установите печать служебной информации. Служебная информация необходима печатнику для идентификации форм. Она содержит имена компонентов или плашечных цветов и параметры растрирования, а также имя файла публикации и номер выводимой страницы. Это облегчит вам проверку выведенных пленок. Отсутствие служебной информации в худшем случае может привести к порче тиража.
  10. Выводите графику без оптимизации. В диалоговом окне Print Options (Печатать варианты) элементы группы TIFFs/Images (Изображения/TIFF) управляют выводом изображений. В списке Send image Data (Графические данные) должен быть выбран вариант Normal (Без настройки), а в списке Data encoding (Кодирование данных) — Send ASCII image data (В кодах ASCII).
  11. Укажите имя PostScript-файла и его тип. Включите флажок Write PostScript to file (Записать PostScript-файл) и введите его имя в находящееся рядом поле диалогового окна Print Options (Печатать варианты). Положение переключателя, задающего тип файла, определяется тем, предполагается ли предпечатная подготовка в сервис-бюро. Если вы поручаете ему растровый треппинг или подготовку спускового макета, то выберите положение for prepress (Для допечатной обработки). В остальных случаях используйте положение Normal (Стандартный файл).
  12. Включите загрузку шрифтов. Для того чтобы фотонаборный автомат мог использовать имеющиеся в файле печати шрифты, в списке Download fonts (Загружать шрифты) выберите варианты PostScript и TrueType.
  13. Выберите краски, выводимые на отдельных формах. В диалоговом окне Print Color (Печатать цвет) выберите цвета, по которым будет осуществляться цветоделение. Если сервис-бюро требует вывода композитного файла и намерено само проводить цветоделение, включите флажок Perform on printer (Выполнить на принтере). Включение этого флажка предпочтительнее, чем установка переключателя в положение Composite (Совмещенный оттиск), т. к. в последнем случае выбирать компоненты для цветоделения будут работники сервис-бюро и вам придется документировать и передавать его работникам эту информацию. Особенно нежелательны в данном случае избыточные определения цветов в публикации, которые могут внести путаницу при выборе компонентов цветоделения. Заблаговременно удалите из публикации все избыточные определения цветов с помощью команды Remove Unused Colors (Удалить неиспользованные цвета) меню палитры Colors (Цвета) или нажатием кнопки Remove Unused (Удалить ненужные) в диалоговом окне Print Color (Печатать цвет). Если в публикации определены плашечные цвета, которые не выводятся на отдельных формах, преобразуйте их в триад-ные командой Convert to Spot Color (Преобразовать в простой), находящейся в том же меню, но помните о погрешностях подобного преобразования. В идеале на момент печати список цветов должен содержать только имена цветов, предназначенных для вывода на отдельные формы.

Примечание

При печати исключительно триадными красками вы можете перевести все плашечные цвета в триадные нажатием кнопки All to process (Все триадными) в диалоговом окне Print Color (Печатать цвет), но не забывайте о возможных погрешностях преобразования. Если вы производите эту операцию впервые при выводе оригинал-макета, то не имеете над ними контроля. Поэтому лучше производить преобразование в самой публикации перед выводом макета. При этом желательно получить цветопробу, подтверждающую приемлемость проведенного преобразования.

  14. Определите цвета в импортированных EPS-файлах. PageMaker может изменять определения цветов в импортированных EPS-файлах. Если вы пользовались этой возможностью при назначении цветов другим объектам, но хотите чтобы EPS-файлы печатались оригинальными цветами, установите флажок Preserve EPS Colors (Сохранить цвета EPS).
  15. Проверьте установки системы управления цветом. Если вы используете систему управления цветом, PageMaker может сам производить цветоделение импортированных растровых RGB-изображений в момент печати. В противном случае все импортированные растровые изображения должны быть переведены в CMYK. Проверьте публикацию на наличие нецветоделенных изображений с помощью диалогового окна Links Manager (Связанные файлы), которое подробно описано в гл. 11. Если вы этого не сделаете, пленки будут испорчены, т. к. RGB-изображения при печати цветоделения с отключенной системой управления цветом будут переведены в полутоновые и помещены на черную форму.
  16. Определите параметры растрирования компонентов. В поле Optimised screen (Оптимальный растр) диалогового окна Print Color (Печатать цвет) выберите требуемое соотношение линиатура/разрешение печати. Значение линиатуры зависит от способа печати и сорта применяемой бумаги, разрешение печати — от разрядности каналов изображений. При обычных 8-битных каналах оно должно в 16 раз превосходить линиатуру. Это обеспечит передачу всех имеющихся в изображении оттенков.

Примечание

Углы растрирования при печати триадными красками без особого требования со стороны типографии изменять не стоит. При печати плашечными цветами значения углов следует установить, проконсультировавшись в типографии .

  17. Задайте параметры вывода компонентов. Значения параметров Mirror (Зеркало) и N egative (Негатив) определяются как требованиями типографии, так и правилами сервис-бюро. Очень часто эти параметры задаются работниками сервис-бюро исходя из переданной им спецификации. От вас же требуется прямое (флажок Mirror (Зеркало) сброшен) и позитивное (флажок Negative (Негатив) сброшен) изображение. В противном случае, установите эти флажки исходя из требований типографии. Чаще всего для изготовления офсетных форм используются зеркальные позитивные пленки.
  18. Установите в свойствах принтера значения по умолчанию. Внимательно ознакомьтесь со специальными свойствами фотонаборного автомата, на котором вы будете осуществлять цветоделение. Если какое-либо свойство, указанное в этом диалоговом окне, имеет установку типа "параметры принтера по умолчанию", выставите именно этот вариант, что позволит работникам сервис-бюро проставить конкретные значения данных настроек при выводе. Если список не предлагает такого варианта, обязательно проконсультируйтесь в сервис-бюро относительно его требуемого значения. При установке неверного значения R1P не сможет перекрыть своими настройками сделанных вами установок. В результате пленки могут быть либо испорчены, либо вообще не будут выведены.
  19. Создайте новый стиль печати. Если вы планируете вывод нескольких файлов со сходными настройками, имеет смысл сохранить сделанные установки в виде стиля печати. Это избавит вас от их многократного воспроизведения и, возможно, от связанных с этим ошибок.
  20. Сохраните файл печати на диске. Процесс печати запускается нажатием кнопки Save (Сохранить) в диалоговом окне команды Print (Печать). Перед печатью убедитесь в наличии свободного места на диске. PostScript-файл в кодировке ASCII занимает очень много дискового пространства. Для того чтобы приблизительно оценить, сколько места вам потребуется, умножьте величину пространства, занятого версткой со всеми внешними файлами, на четыре. Впрочем, если вы не располагаете носителем такого размера для переноски файла печати в сервис-бюро, воспользуйтесь любым архиватором для его сжатия. В сжатом виде файл печати займет примерно столько же места, сколько и верстка.
  21. Проверьте правильность полученного файла. Файл печати представляет собой некий "черный ящик". Вы не можете вывести его на ваш принтер, чтобы проверить правильность цветоделения, т. к. он создан для фотонаборного автомата. Убедиться в отсутствии ошибок при выводе можно, воспользовавшись дополнением PageMaker Save for Service Provider (Сохранить для сервис-бюро) и программами пакета Adobe Acrobat 4.0, входящими в комплект поставки PageMaker 7.O.

Для визуального просмотра содержимого файла печати обработайте его программой Adobe Acrobat Distiller. В результате будет создан PDF-файл, который может быть просмотрен программой Adobe Acrobat Reader. В нем вы увидите содержимое "черного ящика". О программах пакета Adobe Acrobat подробно рассказано в гл. 18. Заметим лишь, что отказ программы Acrobat Distiller интерпретировать файл печати является грозным предупреждением о проблемах, которые могут возникнуть при выводе на фотонаборном автомате. Используйте Adobe Acrobat как простое диагностическое средство правильности файла печати. По его сообщениям об ошибках часто можно идентифицировать объект, создающий трудности при выводе.

О дополнении Save for Service Provider (Сохранить для сервис-бюро) подробно рассказано в разд. "Передача верстки в сервис-бюро" данной главы.

Проблемы с выводом оригинал-макета на фотонаборном автомате могут возникнуть не только в результате неверных установок, сделанных вами при создании файла печати. Их возникновение столь же вероятно из-за погрешностей самого макета. Зачастую дают о себе знать и ошибки в самих программах верстки и подготовки изображений и иллюстраций. Напоминает о себе и проблема их совместимости. Подобные ошибки очень сложно идентифицировать и устранить. Приведенные ниже советы помогут вам избежать наиболее распространенных ошибок верстки, затрудняющих или делающих невозможным успешный вывод пленок на фотонаборном автомате.


Профилактика неполадок на этапе вывода

Этап вывода публикации на фотонаборном автомате тоже таит в себе множество подводных камней. Можно побиться об заклад, что вам случалось наблюдать "странности" в поведении своего PostScript-принтера. Если вы были при этом достаточно настойчивы, чтобы выяснить причину его "безобразного поведения", вы легко представите себе, какие сложные проблемы могут возникнуть при печати на таком "суперпринтере", как фотонаборная машина.

К сожалению, для неудачи при выводе макета существует неисчислимое множество причин, в то время как для успеха только одна — хорошая верстка, учитывающая особенности работы PostScript-интерпретаторов и использованных программ. Ниже мы приводим несколько достаточно общих рекомендаций, позввляющих избежать проблем на стадии вывода оригинал-макета.


Пользуйтесь советами специалистов

Большинство сервисных бюро и типографий выпускают всевозможные памятки и инструкции для своих заказчиков. Очень важно точно следовать им. В них, как правило, указаны программы, которое рекомендуется использовать для верстки и подготовки иллюстраций. Приводятся и настройки фотонаборного автомата, которые придется проставлять вам, если вы предоставляете готовый файл для печати.


Устранение избыточной сложности выходного файла

По мере работы над макетом вы выполняете массу всевозможных действий, многие из которых носят сугубо экспериментальный характер. В результате получается перегруженный всевозможными преобразованиями файл, который замечательно смотрится на экране монитора, но выводится на печать крайне медленно или вовсе не печатается. Причина — те скрытые "мины замедленного действия", которые накопились в файле публикации и "взрываются" в процессе вывода на печать, приводя в бесчувственное состояние фотонаборный автомат или ваш собственный лазерный принтер. Публикацию следует "отшлифовать". Просмотрите весь макет и устраните потенциально опасные ситуации, которые вполне могут сорвать сроки работы над публикацией.

Вот основные причины возникновения избыточной сложности выходного файла. Когда вы работаете с графическим изображением средствами программы PageMaker, само изображение при этом не меняется. Программа PageMaker импортирует изображение не повернутым, без изменения масштаба и размеров, без кадрирования и без наклона — все эти преобразования применяются лишь к экранной версии графики. Само же исходное изображение при этом остается неизменным. Во время вывода PageMaker пересылает в принтер не только исходное изображение, но и составленные в процессе верстки инструкции по его преобразованию, закодированные на языке PostScript, который интерпретируется фотонаборным автоматом или лазерным принтером. При этом в памяти устройства вывода должны поместиться и изображение, и инструкции по его преобразованию. Процедура преобразования может занять уйму времени и израсходовать все доступные ресурсы устройства вывода, приведя к аварийному завершению печати. В лучшем случае файлы, содержащие в себе преобразованные графические изображения, печатаются медленнее.

Перед передачей файла PostScript в сервисное бюро рекомендуется вывести его на печать на собственном лазерном принтере. Если принтер не справляется с поставленной задачей, есть веские основания задуматься о возможности упрощения файла. Да, конечно, встроенный в фотонаборный автомат компьютер намного мощнее встроенного компьютера лазерного принтера, но из этого вовсе не следует, что он обязательно справится с файлом, которым "захлебнулся" лазерный принтер, — ведь ему приходится выполнять намного больше вычислений. Объем вычислений, которые необходима осуществить для вывода на печать страницы с разрешением 2400 точек на дюйм на несколько порядков больше, чем при выводе той же страницы с разрешением лазерного принтера — 300 точек на дюйм. Процессор фотонаборного автомата намного больше загружен, чем его коллега в лазерном принтере, и его работа намного сложнее.

Кроме того, необходимо проверить все определения цветов и добиться их единообразия в рамках публикации. Если вы печатаете издание в два цвета, в палитре цветов должно быть ровно два определения (лишние вы можете удалить при помощи команды Remove unused Colors (Удалить неиспользованные цвета). Более подробно эта процедура описана в гл. 19.


Масштабирование и кадрирование до размещения изображений в публикации

По мере возможности выполняйте изменение размеров и кадрирование изображений до их импортирования в публикацию программы PageMaker. Если вам необходимо уменьшить размер отсканированной фотографии, сделайте это до ее импортирования в публикацию. Проверьте разрешения всех импортированных изображений и пересчитайте те, у которых оно избыточно. Не забывайте о том, что разрешение при сканировании не должно превышать линиатуру растра печати более чем в два раза, а многие специалисты считают, что вполне достаточно и полутора раз.


Проблемы при выводе невидимых фигур

Казалось бы, вполне естественный прием: если вам не нужна какая-либо часть изображения, просто постройте поверх нее прямоугольник и назначьте его фону белый цвет. Но опять приходится вспомнить о том, что устройство, интерпретирующее язык PostScript, "вычисляет" изображение, перемещаясь от нижних слоев к верхним. Несмотря на то, что вам не видно, что скрыто за белым прямоугольником, фотонаборный автомат или лазерный принтер обрабатывает все слои изображения и выполняет все необходимые вычисления — пусть даже при обработке следующего слоя только что построенное изображение будет целиком закрыто.

Конечно, существуют ситуации, в которых без белого прямоугольника не обойтись. Но все-таки стоит попробовать. До появления версии программы PageMaker 6.0 этим приемом часто пользовались для маскировки нежелательных элементов,- перенесенных на страницу со страницы-шаблона. Поскольку теперь можно воспользоваться дополнительными страницами-шаблонами, такая необходимость отпала, что очень хорошо.


Сложности при выводе графических объектов

Многократное вложение графических файлов EPS друг в друга — верный способ многократно увеличить нагрузку на лазерный принтер или фотонаборный автомат. По мере возможности такой ситуации следует избегать.

Размещая на одной странице десяток цветовых растяжек, вы определенно напрашиваетесь на неприятности при выводе на печать.

Если причиной аварийного завершения вывода на печать оказывается графическое изображение, откройте его в сеансе графического приложения, с помощью которого оно было создано, и попробуйте упростить кривые и маски. В графическом приложении можно уменьшить количество узлов кривой или повысить степень ее плавности — это приведет к снижению сложности графического элемента. Adobe Illustrator выдает предупреждение, если получившийся в результате какой-либо операции объект имеет слишком большое количество узлов и может вызвать проблемы при выводе. Не пренебрегайте этим предупреждением. Пользуйтесь соответствующими функциями упрощения объектов после трассировки в программе Adobe Streamline.


Сложности вывода при использовании маскирования

При использовании в импортированном изображении маскирования лазерному принтеру или фотонаборному автомату приходится вначале обрабатывать все изображения, а затем выполнять обрезку. Это — достаточно продолжительный процесс, который требует выполнения множества вычислений, что может привести к аварийному завершению вывода на печать. Из этого не следует, что подобным приемом нельзя пользоваться ни при каких обстоятельствах — просто необходимо рассматривать возможные альтернативы для достижения того же эффекта или варианты упрощения этого эффекта. В любом случае, перед передачей файла PostScript с контурами об-травки в сервисное бюро следует проверить надежность его вывода на лазерный принтер.


Текст, вложенный в файлы EPS

Одна из форм вложения EPS-файлов — вставка в них текстов. Иногда при выводе на печать принтер или фотонаборный автомат не могут распознать гарнитуру текста лишь потому, что он вложен в файл формата EPS, и текст выводится в выбираемой по умолчанию моноширинной гарнитуре Courier.

Конечно, избежать вложения текста в файл формата EPS удается не всегда. В таких случаях следует преобразовывать текст в совокупность кривых, после чего он рассматривается как графический объект. Такое преобразование целесообразно по двум причинам. Во-первых, отпадает проблема с отсутствием в сервис-бюро использованной вами редкой гарнитуры. Поскольку символы текста стали частью изображения, они перестали зависеть от описания гарнитуры. Во-вторых, все преобразования, которые вы выполняете над изображением и входящим в его состав текстом, выполняются заранее, упрощая вычисления в процессе вывода на печать. Правда, когда объем преобразованного текста велик, это преимущество утрачивается. Поэтому большой объем текста малого кегля (например, 12 пунктов) преобразовывать нецелесообразно, а заголовки крупным кеглем — можно и нужно.

Применение преобразования текста в кривые может дать эффект, прямо противоположный желаемому. Такое наблюдается при преобразовании в кривые большого объема текста или текста мелкого кегля. Дело в том, что подобное преобразование может несколько увеличить толщину штрихов символов и исказить межсимвольные интервалы. Кроме того, преобразование в кривые целой страницы текста — надежный способ повысить сложность страницы до уровня, неприемлемого для любого принтера и фотонаборного автомата.

Если это не противоречит вашему замыслу, размещайте текст поверх графического изображения, объединяя его с ним в группу. Это можно сделать непосредственно в программе PageMaker, не выходя в сеанс работы с графическим приложением, при помощи команды Group (Сгруппировать).


Поворот изображений в PageMaker

В PageMaker имеются мощные инструменты для поворота текстов и графических объектов, но все-таки, если эти операции выполнять вне PageMaker, сложность выходного файла существенно снижается. Если в публикации задан поворот графического изображения, то на принтер или фотонаборный автомат оно передается не в развернутом, а в исходном положении. Устройство вывода самостоятельно пересчитывает местоположение всех точек изображения при обработке страницы во встроенном компьютере. Как уже упоминалось выше, фактически поворот приходится выполнять два раза — так уж устроена технология PostScript. Особенно заметна разница во времени вывода для изображений в формате TIFF. Если изображение очень большое, необходимость его поворота в процессе печати может привести к аварийному завершению данного процесса. Постарайтесь выполнять повороты изображений в формате TIFF при помощи графических приложений для работы с точечными изображениями (например, Adobe Photoshop). Это касается также и файлов в формате EPS с вложенными изображениями в формате TIFF.


Шрифты TrueType и файлы WMF (EMF)

И то и другое — чужеродные объекты для технологии PostScript. В издательствах наблюдается постепенный рост применения гарнитур TrueType, но в большинстве сервисных бюро ими практически не пользуются.


Количество переходов в цветовых растяжках

Создавая цветовую растяжку, вы предполагаете, что на отпечатке будет сделан плавный переход от начального полутона серого (или хроматического цвета) к конечному. Но из-за того, что переход полутонов реализуется механическими средствами, вместо плавного перехода получается ступенчатый. Это может быть практически незаметно, но может и сильно бросаться в глаза. О том, как рассчитать количество ступеней в растяжке, уже было сказано в разд. "Растяжки " данной главы.

Примечание

Не задавайте цветовых растяжек, если начальное и конечное значения в них устанавливаются различными плашечными цветами. На экране все будет выглядеть прекрасно, но это — пример неадекватности цветовоспроизведения на экране и цветного отпечатка. Дело в том, что монитор воспроизводит цвета в соответствии с моделью RGB и не совсем правильно показывает, как плашеч-ные цвета будут выглядеть при реальном смешении красок на листе. Если вам не нравятся грязные отпечатки, будьте предельно осторожны! Цветовой переход невозможно выполнить без смешения красок. Другое дело — триадные цвета. Они специально предназначены для смешения на листе и представляют собой вполне надежный инструмент для создания цветовых растяжек с различными начальными и конечными цветами.


Резюме

Вот наконец наступает завершающий этап издания — печать в типографии. Теперь, когда уже позади верстки и переверстки, корректуры, беготня между издательством и сервис-бюро, утверждение у заказчика, особенно обидно было бы загубить при печати такими трудами созданный макет. Правильная работа по планированию, корректуре и цветокоррекции публикации уже гарантирует 50% успеха при печати. Как добиться успешной реализации остальных 50% процентов, рассказывается в следующей главе.


  • Глава 24. Сотрудничество с типографией
    • Предварительное совещание в типографии
      • Выбор типографии
      • Что нужно определенно знать к предварительному совещанию
      • Разработка тактики
      • Выбор бумаги
      • Выбор значения линиатуры растра
      • Фальцовка и переплетные работы
    • Проверка качества печати тиража
    • Резюме


ГЛАВА 24.

Сотрудничество с типографией

Вот, наконец, процесс создания публикации вышел на финишную прямую — изготовление тиража. Скоро в свежих, пахнущих типографской краской отпечатках воплотится труд многих людей, занимавшихся подготовкой материалов — фотографов, верстальщиков, редакторов, корректоров, технологов, работников студии предпечатной подготовки и типографии. Теперь, казалось бы, публикация выходит из сферы вашей деятельности и вам остается только со стороны наблюдать за чудесным превращением бестелесной информации в книгу, брошюру, журнал.

В действительности дело обстоит не совсем так. Готовя издание вам все время было необходимо учитывать эту завершающую стадию. Очень много раз в этой книге мы говорили: "проконсультируйтесь в типографии", "это решает технолог типографии", "возьмите образцы в типографии" и т. п. Высокий уровень издания зависит от правильной работы с типографией в неменьшей мере, чем живописное полотно от техники художника. В типографии даже удачный макет может обернуться испорченным тиражом и неудачный макет — вполне приличным изданием. Огромную роль в этом играет не только качество оборудования и профессионализм типографов, который легко оценить по чужим изданиям. Большинство проблем возникает из-за недоговоренности и несогласованности в работе издательств и типографий. Избежать проблем вам поможет постоянный контакт с сотрудниками типографии. С одной стороны, они подскажут вам как изготовить технологичный макет, а с другой — с пониманием и готовностью встретят ваши требования.

В главе рассматриваются следующие вопросы:

  • Выбор типографии
  • Стратегия и тактика работы с типографией
  • Выбор бумаги и способа печати
  • Требования, предъявляемые к макету
  • Контроль качества печати


Предварительное совещание в типографии

В идеальном варианте процесса подготовки издания такой разговор должен быть предусмотрен. К сожалению, в реальности это происходит не всегда, и даже не всегда возможно. В случае подготовки несложной публикции (рекламного листка, черно-белой брошюры и т. п.) он вовсе необязателен. При наличии же у вас опыта и налаженных связях с этой типографией, вам будет явно не о чем говорить. Если же публикация сложна и потребует больших затрат труда как с вашей стороны, так и со стороны типографии, ранний визит туда может сэкономить много времени и средств издательству, а то и вообще убережет вас от потерь и срыва сроков заказчика.


Выбор типографии

Разумеется, проводить подробный разговор в типографии имеет смысл после того, как вы определили, в какой типографии будет печататься издание. В свете сказанного выше важно определить это как можно раньше. Выбор может осуществляться не вами, а вашим начальством, но многие технические вопросы все равно лягут на ваши плечи. Выбирать типографию следует не по дешевизне печати, а исходя из требований заказчика к готовой продукции. Часто "дешевые" типографии располагают технически несовершенным или сильно изношенным оборудованием, которое не позволяет отпечатать тираж с требуемым качеством. Случается, что для привлечения клиентов типографы не торопятся сообщить им об этом. Поэтому оценивайте качество печати типографии по их продукции. Посмотрите не только те образцы печати, которые показывает вам администрация, но и те, которые только что сошли со станка.

Выясните, предоставляет ли типография полный цикл услуг, требующихся для печати вашей публикации. Возможно, вам понадобятся фальцовка, брошюровка, переплет, вырубка, печать на специальных носителях или специальными красками. Если что-либо из требуемого типография обеспечить не может, то вам придется подумать о поисках другой типографии или производстве этих работ у другого подрядчика. Не лишне и подумать о том, насколько обязательны эти работы для выполнения заказа. Не исключено, что хорошего результата можно достичь средствами макета. При печати пла-шечными цветами ознакомьтесь с каталогом цветов, имеющихся в типографии. Убедитесь, что в нем присутствуют необходимые цвета.


Что нужно определенно знать к предварительному совещанию

Перед тем как отправиться на предварительное совещание, необходимо проделать значительную подготовительную работу. В противном случае разговор окажется бесполезным.

К этому моменту вы должны уже очень четко представлять себе цель издания и его потенциального читателя. Хорошо также иметь предварительные эскизы и макеты. Они должны давать представление о формате издания, способах сшивки или фальцовки, используемых цветах.

Примечание

Создавая макет, вы вряд ли изобретете что-то новое. Собирайте характерные образцы печатной продукции. Они пригодятся вам в разговоре с работниками типографии. Он будет гораздо предметнее, если у вас в руках окажется образец бумаги, на которой вы хотели бы печатать публикацию, образец формата или фальцовки, образцы специальных красок или вида вырубки.

Как мы уже отмечали, качество является одним из главнейших критериев выбора типографии, наряду со стоимостью услуг. При. выборе типографии необходимо найти устраивающий вас и заказчика компромисс между стоимостью тиража и его качеством. Когда типография уже выбрана, предполагается что вы его уже нашли. Возможно, потребуются дополнительные переговоры с заказчиком, направленные на уменьшение типографских расходов путем упрощения макета. Может быть удастся обойтись плашечными цветами вместо триадных или избежать ламинирования подбором сорта бумаги для обложки.

Большое влияние на смету издания и качество печати оказывает выбор бумаги. Бумага выбирается, в первую очередь, исходя из способа использования издания. Если вы издаете учебное пособие, то стоит позаботиться о том, чтобы оно прослужило не один год при самых жестких условиях эксплуатации. Рекламные листовки, раздаваемые у метро и рассылаемые по почте, напротив, не требуют такого "долголетия". Выбор напрямую зависит и от требуемого качества публикации. Даже великолепный макет, отпечатанный в лучшей типографии, не позволит вам издать качественный иллюстрированный журнал на газетной бумаге.

Как правило, заказчик хочет получить тираж в очень сжатые сроки. Для того чтобы их не сорвать, следует заранее выяснить в типографии, за какой срок они могут изготовить тираж. Исходя из этого можно планировать работу по изготовлению макета. Может быть возможно сократить сроки выпуска проделав часть работы заранее, например загодя отпечатав обложку. Разумеется, решающим при выпуске издания всегда остается финансовый вопрос. Все расходы по печати и верстке вместе с прибылью издательства должны умещаться в бюджет издания. Размер бюджета оказывает непосредственное влияние на все аспекты издания: на выбор типографии, бумаги, красок, способов печати, сложность верстки, размер тиража и сроки выпуска. Размер тиража не должен быть слишком мал, т. к. различие в стоимости 1000 отпечатков и 2000 невелико и малый тир^рк, отпечатанный обычным способом, будет нерентабелен. На предварительном совещании в типографии самое время поднять вопрос о способах снижения стоимости тиража.

Практически наверняка работники типографии смогут дать вам несколько дельных советов на этот счет. Может быть удастся обойтись меньшим количеством красок, использовать бумагу другого сорта, печатать малоформатные издания на обрезках другого тиража, изменить формат печатного листа с тем, чтобы получить эффективный спусковой макет и т. п.

Уже на предварительном совещании хорошо сообщить типографам о всех особых требованиях, предъявляемых к изданию. Иногда требуется повышенная точность воспроизведения, особая фальцовка или вырубка. Может быть вы или заказчик имеете предубеждение против каких-либо технических приемов печати, связанное с предыдущим опытом. Раннее выяснение этих вопросов позволит избежать ситуации, когда при печати обнаруживается, что ваши требования технически не могут быть выполнены.

Не стесняйтесь высказать перед работниками типографии свои, пусть "безумные" идеи. Может быть они кажутся вам "безумными" потому, что вы не знаете как их реализовать. Не исключено, что вместе с работниками типографии вы сможете найти способ перевести их в разряд исполнимых. Попросите типографов указать вам на узкие места в проекте, что будет сложно реализовать при печати. Может быть незначительного изменения в макете будет достаточно для предотвращения потенциальных проблем.


Разработка тактики

Это — самый важный момент предварительного совещания в типографии. Не уходите из типографии, не договорившись с ее сотрудниками о путях дальнейшего сотрудничества. Обязательно добейтесь договоренности по следующим вопросам:

  • Управление цветом и стратегия выбора красок. Если вы собираетесь воспользоваться плашечными цветами, согласуйте с типографией используемую систему цветов. Если для вашей публикации необходима высокая верность передачи цвета, убедитесь, что в типографии имеется необходимое для этого оборудование.

    После выбора совместно с типографией системы цветов необходимо выбрать бумагу. Для обычной бумаги и бумаги с покрытием выпускаются различные веерные образцы цветов.

    Договоритесь с типографией о схеме применения красок. Например, если в вашей публикации совместно применяются триадные и плашечные цвета, целесообразно применить систему плашечных цветов, получаемых в результате смешивания базовых триадных цветов.

    Попросите технолога типографии рассказать о том, как и в каком порядке краски будут наноситься на бумагу. Это поможет вам выбрать правильную стратегию оформления издания в плане использования таких приемов, как выворотка, подавление подлежащего цвета и печать с наложением.

  • Линиатура растра. Располагая сведениями о печатном оборудовании, на котором будет отпечатан тираж, и образцами бумаги, можно выбрать оптимальную линиатуру растра. Эта величина будет играть определяющую роль при сканировании фотографий и выполнении цветовых растяжек (и еще во множестве случаев).

    Есть ли у технолога типографии какие-либо пожелания или рекомендации по режиму сканирования фотографий? Обсудите также вопросы компенсации растискивания точек, а для цветных фотографий — удаление перекрытого цвета и замену серого компонента.

  • Треппинг. Не подскажут ли вам в типографии, как при минимальных изменениях оригинал-макета вообще избавиться от необходимости заниматься треппингом?
  • Спусковые макеты. На предварительном совещании обязательно решите, кто будет выполнять подготовку спускового макета.

    В сервисном бюро фотоформы крупного формата выпускают при помощи приложений типа Adobe PressWise. В большинстве типографий, где имеются собственные фотонаборные автоматы, сборка спусковых макетов вручную на монтажном столе постепенно уходит в прошлое, поскольку с помощью компьютеров это обходится намного дешевле. Однако теперь возникает новый вопрос — об ответственности за неправильную разработку спускового макета. Кто должен платить за выполнение дополнительных операций по разрезке и подборке экземпляров издания, без которых не обойтись, если сигнатуры оказываются подобранными неверно? Более подробно о спусковых макетах и работе с ними рассказано в гл. 23.

  • Требования к оригинал-макету. В каком виде типография хотела бы получить оригинал-макет? Будет ли достаточно отпечатать его на лазерном принтере с высоким разрешением или потребуется вывод на фотонаборный автомат? В последнем случае отпечатки должны представляться в виде позитивов на фотобумаге со специальным покрытием или в виде негативов на пленке? При линиатуре растра свыше 100 lpi и для однокрасочных макетов вывод на фотонаборный автомат становится практически обязателен.

    Если фотоформы будут выпускаться в сервисном бюро, какие указания по их выпуску следует передать вместе с публикацией? Каким должно быть изображение на фотоматериале — негативным или позитивным, прямым или зеркальным, эмульсией вверх или эмульсией вниз? Если сервис-бюро находится при типографии, смогут ли они без вашего посредничества договориться по поводу треппинга, компенсации растискивания и спусковых макетов? Может быть, эти операции возьмет на себя типография, ликвидируя источник возможных нестыковок? Подробнее о выпуске оригинал-макетов рассказывается, в гл. 23.

  • Контрольные оттиски. Необходимость и порядок подготовки контрольных оттисков также обсуждаются на предварительном совещании. Будет ли выпускаться контрольный оттиск перед началом печати тиража? Примет ли типография цветопробы, выпущенные сервисным бюро? Необходимы ли контрольные оттиски для настройки печатных машин в типографии?


Выбор бумаги

Выбор бумаги для печати тиража — очень важный аспект в сотрудничестве с типографией. Выбор бумаги — основной фактор, определяющий линиатуру растра, и, конечно, себестоимость экземпляра издания.

Лучше всего выбрать бумагу для печати тиража уже на предварительном совещании, поскольку без него будет сложно обоснованно определить линиатуру растра.

Обычно бумага выбирается по образцам (примерно так, как выбирают обои или плашечные цвета Pantone). Однако бумагу нельзя выбирать по принципу "нравится — не нравится". Бумага — носитель любой публикации, и она должна обеспечить все физические и эстетические параметры, необходимые для достижения целей публикации.

Вот факторы, которые следует иметь в виду при выборе бумаги:

  • Впитывание краски. Это — одна из важнейших характеристик сорта бумаги, определяющая величину растискивания точек. На плотной бумаге со специальным покрытием типографская краска расплывается несравнимо меньше, чем, скажем, на газетной бумаге.
  • 7мл бумаги. В целлюлозно-бумажной промышленности и полиграфии принято достаточно традиционное деление бумаг на категории. Существуют четыре основные категории бумаги, внутри которых может насчитываться более десятка типов, технологические характеристики которых сильно меняются в зависимости от производителей.

Примечание

Типографской или писчей называется бумага, применяющаяся для письма, текстовых изданий, ксерокопирования. Такая бумага ориентирована, в основном, на письмо и печать с одной стороны листа.

Книжная или офсетная бумага специально приспособлена для прохождения через печатные машины.

Мелованная бумага покрывается специальным составом, повышающим ее плотность и придающим глянец. Хорошие механические и физические свойства такой бумаги обеспечивают ей наиболее широкое применение для цветной печати. Ее повышенная плотность делает ее менее прозрачной, и, следовательно, лучше приспособленной для оборотной печати.

Полукартон имеет увеличенную толщину, что позволяет использовать его, помимо прочего, для печати обложек брошюр.

Существует также бесчисленное множество специальных типов бумаг, перечислить которые здесь просто невозможно. В качестве примеров назовем лишь картографическую бумагу повышенной прочности и бумагу, позволяющую воспроизведение копий на пишущих машинках, принтерах и при письме от руки без прокладки копировальной бумаги.

Кроме того, существует более тридцати способов дополнительной обработки поверхности бумаги с целью придания ей требующихся физико-механических характеристик.

Для некоторых специальных типов изданий (например, воспроизведения графических художественных произведений) выпускается бумага с ворсистой поверхностью, напоминающей войлок.

При производстве офсетной бумаги часто применяют дополнительные технологические операции выравнивания поверхности. Чем ровнее поверхность бумаги, тем выше ее плотность. Наиболее распространен технологический процесс каландрирования, при котором поверхность листа бумаги разглаживается каландрами — металлическими цилиндрами.

В результате других технологических процессов получают пергаментную и веленевую бумагу.

  • Цвет. На сегодняшний день производится цветная бумага всех мыслимых цветов, и при выпуске некоторых изданий применение цветной бумаги может сократить число используемых цветов на единицу (если, конечно, цветная бумага не будет стоить чересчур дорого). Но и при печати на неокрашенной бумаге нельзя считать, что эта бумага — белая. Практически у каждого из сортов бумаги имеется свой специфический нацвет, и своя характеристика яркости, которые приходится учитывать при работе с системой управления цветом.
  • Вес и размер листов. Для определения веса бумаги в типографиях используются несколько достаточно сложных систем расчета по размерам листов и сортности. Для дизайнера гораздо важнее влияние веса и размера бумаги на параметры издания.

    Как следует продумайте назначение издания. Для некоторых из них нужна более плотная, и, соответственно, более тяжелая бумага. Но если тираж издания предполагается рассылать по почте, может оказаться необходимым выбрать более легкую бумагу во избежание перерасхода средств, запланированных на почтовую рассылку.

    Размер листов, на которых будет печататься тираж, сильно влияет на производственные затраты. Обязательно обсудите выбор плотности и размеров листов бумаги в типографии — возможно, вам предложат совершенно неочевидные для вас варианты, которые позволят добиться существенной экономии.

  • Непрозрачность. Положите лист выбранного вами сорта бумаги поверх книжной страницы. Если сквозь него видно хоть что-нибудь, то такая бумага, скорее всего, не годится для оборотной печати. В этом вопросе можете доверитьсякопыту технолога типографии.
  • Волокна. Бумага неоднородна, ее волокна обычно идут в одном направлении. Для вас это может показаться неважным, но при фальцовке это играет определенную роль. Сгиб поперек волокон редко бывает ровным, поэтому и в этом вопросе имеет смысл прислушаться к специалистам типографии.


Выбор значения линиатуры растра

Величина растискивания точек растра зависит от используемой краски, сорта бумаги и печатной машины. Сочетание этих факторов лучше всех может оценить технолог типографии, хорошо изучивший имеющееся в ней оборудование. Но в качестве отправной точки можно воспользоваться данными, приведенными в табл. 24.1.

Таблица 24.1. Выбор линиатуры растра в зависимости от сорта бумаги и состояния печатной машины

Бумага/Печатная машина | Линиатура, линий на дюйм
Газетная Стандартная с покрытием | от 65 до 85
Высококачественная с покрытием на более совершенной печатной машине | от 85 до 133
Высшие сорта бумаги с покрытием на самом совершенном оборудовании | от 133 до 175
 | 175 и выше


Фальцовка и переплетные работы

В большинстве случаев все операции по фальцовке, обрезке и переплетению изданий выполняются в той же типографии, где печатается тираж. Сегодня такой сервис предоставляют даже салоны оперативной полиграфии, используя собственное оборудование или услуги контрагентов.

В процессе фальцовки соответствующие сигнатурам листы складываются и обрезаются, образуя брошюру целиком или одну из составляющих ее тетрадок. Возможно скрепление отдельных листов в брошюре прошивкой тетрадей нитью, скреплением их металлическими скрепками или клеем. Отдельные листы или тетради издания могут склеиваться в книжный блок с последующей насадкой мягкого или твердого переплета, или скрепляться спиралью после нанесения перфорации.

В процессе переплетения в издание вкладываются вкладки (как правило, выпадающие из него по пути из магазина или от почтового ящика домой) и вклеиваются вклейки.

Последней операцией переплетного цикла является упаковка изданий.


Проверка качества печати тиража

При проверке качества печати тиража выполняются практически те же операции, что и при проверке контрольного типографского оттиска, описанной в гл. 22.

  • Проверьте соответствие цветов в издании контрольному типографскому оттиску (если он ранее выпускался) или образцам и оригиналам
  • Выберите наугад несколько экземпляров из различных частей тиража. Проверьте их на соответствие контрольному оттиску, оригинал-макету и друг другу
  • Проверьте отсутствие складок, просачивания краски сквозь страницы, грязи, клякс, смазывания изображения и пятен смазки, которые могут возникать при неаккуратном обслуживании механических частей печатной машины
  • Проверьте выравнивание элементов на страницах. Это не ограничивается проверкой приводки цветов — в монохромных изданиях, например, должны совпадать линейки, отделяющие верхние и нижние колонтитулы (на обеих сторонах страницы и на страницах разворота)
  • Проверьте правильность и качество упаковки тиража на соответствие спецификации (в коробки или пачки). Попробуйте оценить, весь ли тираж был напечатан


Резюме

Типографская печать завершила процесс подготовки издания, и дальнейшая его жизнь уже не зависит от вашей воли. Тем не менее не теряйте его из вида, если такая возможность существует. То, как оно было принято читателем, даст вам ценные сведения, как сделать макет более емким, броским, эффективным. Не менее важны уроки, которые можно извлечь из самого процесса создания публикации. Теперь, когда уже все позади, поразмышляйте о том, с какими проблемами вы столкнулись и как они были решены. Каких из них можно было избежать и что для этого требовалось? Достаточно ли согласована была работа всех принимавших участие в создании макета, что служило при этом лимитирующим фактором? В достаточно ли тесном контакте работали вы с сервис-бюро и типографией?

Даже если вы не испытываете удовлетворения от проделанной работы, постарайтесь думать конструктивно. Накопление опыта позволит вам избегать грубых ошибок, и вы все больше будете сосредотачиваться на творческом аспекте издания, а не на техническом.

Надеемся, что первый опыт принес вам не только заботы и разочарования. Вспомните те ни с чем не сравнимые чувства, которые вы испытали держа в руках только что сошедшую со станка книжку. Ведь ее создали вы!


  • Глава 3. Установки PageMaker
    • Типы умолчаний
      • Локальные умолчания
      • Глобальные умолчания
    • Задание умолчаний
      • Команды меню Preferences
      • Умолчания меню и палитр
      • Где хранятся умолчания
    • Диалоговое окно Preferences
      • Задание единиц измерения
      • Выделение дефектов размещения текста
      • Задание режима отображения графики
      • Настройка управляющей палитры
      • Режим сохранения файлов публикаций
      • Установка направляющих
    • Дополнительные установки
      • Отображение текста на экране
      • Настройка вида редактора материалов
      • Экранные копии и хранение файлов графики
      • Режимы печати по умолчанию
    • Замена шрифтов
    • Задание умолчаний командами меню
    • Резюме


ГЛАВА 3.

Установки PageMaker

Многие элементы интерфейса программы и все атрибуты элементов можно и нужно менять в соответствии с требованиями к создаваемой публикации и вашими привычками в работе. При загрузке PageMaker эти элементы уже имеют какое-то значение, принятое ими по умолчанию. Однако ваши задачи и ваши привычки могут отличаться от стандартных. PageMaker позволяет задать собственную систему умолчаний. Тогда программа будет соответствовать именно вашему стилю работы и требованиям текущей публикации.

Настоящая глава посвящена следующим понятиям, связанным с умолчаниями:

  • Глобальные и локальные умолчания
  • Команды группы Preferences (Установки)
  • Диалоговое окно Preferences (Установки)
  • Умолчания меню и палитр
  • Приоритеты умолчаний
  • Работа с наборами умолчаний


Типы умолчаний

Умолчание в PageMaker — неизменный или условно-неизменный набор значений параметров, управляющих функционированием программы.

По области действия умолчания PageMaker делятся на локальные (действующие в пределах документа) и глобальные (действующие на все публикации). Тип задаваемого умолчания в конечном счете определяется тем, что находится на экране в момент его задания.


Локальные умолчания

Если в момент задания умолчания открыта публикация, то действия, задаваемые умолчанием, будут распространяться только на эту публикацию. Заданное умолчание никак не повлияет на другие публикации — как созданные ранее, так и те, которые вы создадите впоследствии. Подобные умолчания называют локальными, или временными, поскольку они действуют только во время работы с конкретной публикацией.


Глобальные умолчания

Если в момент задания умолчания не было открыто ни одной публикации, то образуется глобальное умолчание, которое впоследствии будет оказывать воздействие на все публикации, с которыми вы будете работать. Глобальные умолчания называют также постоянными, поскольку их действие продолжается во всех последующих сеансах работы с любыми публикациями. Впрочем, любое умолчание, в том числе и глобальное, можно отменить в любой момент, когда это потребуется.

Примечание

Локальные умолчания имеют приоритет перед программными. В свою очередь, непосредственное задание атрибутов подавляет форматирование по умолчанию, при этом локальное форматирование (символов и абзацев) имеет приоритет над глобальным форматированием (стилей абзацев).


Задание умолчаний

Для задания умолчаний предназначены команды подменю Preferences (Установки) меню File (Файл). Каждой из этих команд соответствует диалоговое окно. Умолчания функций, связанных с форматированием и режимами работы, задаются с помощью меню и палитр.


Команды меню Preferences

Для многих элементов интерфейса и некоторых режимов работы задание умолчаний производится элементами управления диалоговых окон, созданных специально для задания умолчаний. Если команда Preferences (Установки) выбирается в меню при наличии открытой публикации, то задается локальное умолчание. Если команда выбирается в отсутствие открытой публикации, задается глобальное умолчание.

Список Preferences (Установки) меню File (Файл) включает несколько пунктов, каждый из которых открывает соответствующие диалоговые окна:

  • General (Основные). В окне, открываемом этой командой, задаются режимы отображения текста и графики, элементы интерфейса, параметры управления цветом и заменой шрифтов.
  • Online (Контроль HTML). Открывает окно установок для работы с электронными публикациями. PageMaker предоставляет широкий спектр возможностей для создания электронных публикаций, в частности для глобальных и локальных сетей. Подробно о создании электронных публикаций читайте в гл. 18.
  • Layout ajustment (Настройка макета). В программе есть возможность настраивать большие объемы текста и графики автоматически, корректируя размещение элементов после изменения параметров страницы. Установки для процесса автоматической коррекции сведены в окне, открываемом этой командой. Об этом процессе мы поговорим в гл. 13.
  • Trapping (Треппинг). Треппинг применяют для устранения дефектов совмещения цветов при печати. Эта операция выполняется только для цветных изображений. PageMaker имеет встроенную систему треппинга, умолчания для которой задаются в диалоговом окне, открываемом щелчком на данной кнопке. (О треппинге и его применении см. гл. 21.)


Умолчания меню и палитр

Если отменить все выделения объектов в документе и выбрать какой-либо режим или значение в меню, палитре, диалоговом окне, то заданное значение становится умолчанием. Если выбран хоть один объект, то действия выполняются с этим объектом и никакого умолчания не устанавливается. О пунктах меню и палитрах, которым можно задавать умолчания, рассказывается в разд. "Задание умолчаний командами меню" данной главы.

Примечание

Если перед выполнением операции форматирования случайно отменить выбор объекта, будет задано новое умолчание. Если PageMaker начинает выполнять странные действия (например, заново вводимый текст имеет зеленый цвет и выровнен по правому краю, хотя вы этого и не хотели), проверьте, не задано ли случайно вами (или кем-то еще) такое умолчание для текстового материала.

Чтобы задать локальное умолчание, при открытой публикации щелкните инструментом Pointer (Стрелка) в любой точке рабочего окна, свободной от объектов, или выберите команду Deselect АН (Снять выделение) меню Edit (Редактирование), или нажмите комбинацию клавиш для отмены выделения <Ctrl>+<Shift>+<A>. Для задания глобального умолчания следует предварительно закрыть все публикации. После этого вызовите нужные диалоговые окна или пункты меню и выполните необходимые изменения режимов.

Примечание

Для инструментов также очень полезно задать умолчания. Для этого сделайте двойной щелчок на пиктограмме инструмента в палитре Toolbox. Выделение объектов публикации (если таковое было) снимается и открывается соответствующее окно установок. Это происходит только для тех инструментов, для которых возможно задание умолчаний.


Где хранятся умолчания

Локальные умолчания не хранятся. Они существуют только пока открыт документ, где вы их задали. Все параметры, заданные вами в качестве глобальных умолчаний, программа PageMaker записывает в специальный файл PM70.CNF в языковой папке (имя ее будет зависеть от того, в какой папке установлена сама программа). Файл умолчаний может быть только один. Поэтому, если вы хотите создать несколько наборов умолчаний для работы с разными проектами, копируйте их по мере создания в папки соответствующих проектов и, когда начнете работу с одним из них, перенесите файл умолчаний обратно в языковую папку. Если вы испортили умолчания и хотите вернуться к комплексу умолчаний PageMaker в том виде, в котором он был после инсталляции, закройте PageMaker и удалите файл PM70.CNF. При начале следующего сеанса работы с программой будет автоматически создан новый файл PM70.CNF, причем в нем будут восстановлены первоначальные умолчания, встроенные в программу.

Теперь, когда вы примерно представляете себе устройство системы умолчаний программы, перейдем к их подробному рассмотрению.


Диалоговое окно Preferences

Это окно открывается (рис. 3.1) командой General (Общие) списка Preferences (Установки) меню File (Файл). В нем собраны элементы управления настройками интерфейса и режимами работы.

Чтобы быстро открыть диалоговое окно Preferences (Установки), нужно сделать двойной щелчок на инструменте Pointer (Стрелка) в палитре инструментов.

Рис. 3.1. Диалоговое окно Preferences


Задание единиц измерения

Два верхних раскрывающихся списка задают выбор основных единиц измерения. Для выбора достаточно развернуть список и щелкнуть мышью на названии требуемой единицы измерения.

Выбирая значение в списке Measurements in (Система измерения), вы устанавливаете единицу измерения, используемую далее в панели управления и во всех диалоговых окнах (см. рис. 3.1). Это единицы измерения по умолчанию.

Они также используются для разметки горизонтальной координатной линейки в верхней части окна публикации.

В списке Vertical ruler (Вертикальная линейка) выбирают единицы для разметки вертикальной координатной линейки, расположенной в левой части окна публикации. Различные единицы измерения могут понадобиться, например, когда вы предпочитаете измерять высоту символов и интерлиньяж в пунктах, а размеры страниц и ширину полей — в миллиметрах. В этом случае для горизонтальной линейки в качестве единиц измерения выбираем миллиметры, а для вертикальной — пункты.

В список допустимых единиц измерения для вертикальной координатной линейки, кроме названий единиц измерения, входит дополнительное значение — Custom (Заказная). При выборе этого значения вы можете нанести на нее деления, размер которых в пунктах задается дополнительным элементом управления — полем ввода points (пт). Особенно удобна такая разметка при включении режима выравнивания строк по модульной сетке. Подробно о вертикальной выключке и выравнивании по модульной сетке страницы рассказывается в гл. 13.

Примечание

Если вы задали единицу измерения непосредственно на линейке в окне документа, поле окна Preferences (Установки) соответственно изменится, образовав локальное умолчание для данного документа. После закрытия документа будет восстановлена система измерений в соответствии с глобальным умолчанием.


Выделение дефектов размещения текста

Если в строке текста, выровненного по формату, слишком большие или излишне узкие пробелы, это считается серьезным браком верстки, который необходимо вовремя исправлять. Другой головной болью верстальщика остаются висячие строки — первые и последние строки абзацев, расположенные на странице в отрыве от своего абзаца. Программа позволяет автоматически отслеживать указанные дефекты, что очень ускоряет^-работу. Установка флажков группы Layout problems (Выделять подсветкой) приводит

к визуальному выделению строк с нарушенными значениями пробелов — Show loose/tight lines (Жидкие/плотные строки) и висячих строк — Show "keeps" violations (Висячие строки). В зависимости от параметров монитора программа выделяет дефекты верстки серым или желтым цветом.

Примечание

Пороговые значения, определяющие степень плотности слов в пределах строки и условия разбиения абзацев с переходом на новую страницу, задаются в диалоговом окне Paragraph Specifications (Параметры абзаца) (см. гл. 5).


Задание режима отображения графики

При верстке иллюстрированных изданий в составе публикации, как правило, есть импортированная графика. Вы можете задать различные режимы ее показа на экране с помощью переключателя Graphics display (Изображения на экране), который позволяет выбирать следующие режимы:

  • Gray out (В виде плашек). Вместо графики изображается только серый прямоугольник, совпадающий с ней по размерам и местоположению. Этой опцией можно воспользоваться при работе с текстом, когда вы не занимаетесь изображениями в файле. Иногда в таком режиме можно просмотреть уже готовый документ на предмет корректности композиции.
  • Standard (Стандартные). Отображение с пониженным разрешением. Снижение разрешения снижает качество, но повышает скорость вывода. Более тонкую настройку качества отображения графики на экран можно выполнить с помощью группы элементов управления Graphics (Изображения) диалогового окна More Preferences (Дополнительные установки), раскрывающегося при помощи командной кнопки More (Дополнительные).
  • High resolution (С высоким разрешением). Отображается оригинал импортированного файла растрового графического изображения, например в формате TIFF. В некоторых случаях размеры такого файла могут быть очень огромными, что приводит к большим затратам времени на их отображение. Правда, при этом качество изображения получается высоким.

Несмотря на то, что это прописная истина, отметим еще раз, что печать PageMaker осуществляет из графических файлов, а не с экрана монитора, поэтому качество экранного изображения и режим отображения никоим образом не влияют на качество печати!

Примечание

Если графический файл вставлен по технологии OLE (Object Linking and Embedding), качество экранной версии будет зависеть и от особенностей работы OLE-сервера (приложения, из которого импортируется графический файл). (Об OLE см. гл. 10.)

Примечание

Можно временно улучшить качество отрисовки любого графического изображения в публикации, независимо от того, какая из опций качества отображения выбрана в качестве установки. Для этого запросите перерисовку экрана (например, измените масштаб страницы) и одновременно держите нажатой комбинацию клавиш <Ctrl>+<Shift>. Очень удобно для просмотра в высоком разрешении перерисовать всю страницу целиком, щелкнув на ее ярлыке. И в этом случае не забудьте нажать комбинацию клавиш <Ctrl>+<Shift>.


Настройка управляющей палитры

В поле Control Palette (Управляющая палитра) окна установок задаются весьма важные настройки управляющей палитры — единицы измерения и шаг изменения атрибута для кнопок настройки. Эти величины определяются в раскрывающихся списках Horizontal nudge (Горизонтальная настройка) и Vertical nudge (Вертикальная настройка). Введенные значения используются каждый раз при нажатии на кнопки настройки управляющей палитры. Те же установки применяются и при изменении размеров и расположения выбранных объектов при помощи клавиш управления курсором. При задании величины перемещения посредством кнопок настройки управляющей палитры можно указать, будут ли воздействовать на эти перемещения команды выравнивания. Для данной цели используется дополнительное поле Use "Snap to" constraints (Использовать команды выравнивания). Если вы хотите, чтобы настраиваемые элементы выравнивались по направляющим или по делениям линеек, задайте этот параметр. О работе управляющей палитры подробно рассказывается в главах, посвященных форматированию и работе с графикой.


Режим сохранения файлов публикаций

Положение переключателя Save option (Сохранение) определяет скорость сохранения и размер файла публикации. Первоначально активно положение Faster (Быстро). При выборе команды Save (Сохранить) старый файл остается нетронутым, а все изменения с момента последнего сохранения записываются в дополнительной секции файла. Такой способ обеспечивает быстроту сохранения публикации. Однако размер файла с каждым сохранением увеличивается, даже если данных в нем убавляется, ведь каждый раз в конец первоначального файла записывается информация об изменениях. Кроме того, при таком упрощенном методе записи велика вероятность накопления ошибок. Функцию быстрого сохранения можно отключить, для чего установите переключатель Save option (Сохранение) в положение Smaller (Компактно). Это приведет к тому, что программа PageMaker будет выполнять операции сохранения гораздо дольше, зато файлы будут гораздо меньше по размеру, и вы устраните один из факторов риска-— больше шансов, что файл останется корректным.

При работе с большими файлами компактное сохранение может длиться очень долго. Если вы предпочитаете быстрое сохранение, для надежной работы программы рекомендуем сохранять редактируемый файл компактно хотя бы в конце рабочего дня. Для этого выберите команду Save As (Сохранить как) меню File (Файл) и сохраните файл под тем же именем.


Установка направляющих

Переключатель Guides (Направляющие) определяет положение направляющих линий относительно объектов. В положении Front (Вперед) переключателя Guides (Направляющие) направляющие лежат поверх объектов документа. Если в документе много направляющих и есть трудности с выбором элементов макета, можно переставить переключатель в положение Back (Назад), тогда объекты будут закрывать направляющие. Более подробно о размещении направляющих на странице рассказывается в гл. 13.


Дополнительные установки

Щелчок мышью на кнопке More (Дополнительные) окна установок раскрывает вложенное диалоговое окно More Preferences (Дополнительные установки), в котором можно сделать еще некоторые настройки интерфейса, а также установить режим печати на PostScript-устройстве. Диалоговое окно More Preferences (Дополнительные установки) представлено на рис. 3.2.

Рис. 3.2. Диалоговое окно More Preferences


Отображение текста на экране

Группа Text (Экранный текст) содержит элементы управления отображением текста на экране монитора в режиме макета (главного окна PageMaker). Параметр Greek text below: ... pixels (Заменять плашками символы менее ... пикселов) задает наименьший кегль шрифта, который будет показан на экране. Все строки текста, имеющие меньший кегль, PageMaker отображает плашками — серыми полосками. Замена текста плашками существенно повышает скорость отображения макета на экране, однако, с другой стороны, такое упрощение не позволяет точно оценить результаты верстки. Замена символов любого кегля плашками выполняется при масштабе отображения макета менее 100%.

Рис. 3.3. Текст, замененный плашками

Флажок Turn pages when autoflowing (Листать страницы при автозаполнении) включает режим показа каждой из страниц публикации по мере их заполнения импортированным текстом. Когда этот флажок сброшен, PageMaker работает быстрее, но за процессом автозаполнения Страниц нельзя проследить.

Флажок Use typographer's quotes (Использовать типографские кавычки) включает режим замены прямых кавычек на "круглые". Этот режим распространяется на любой вновь вводимый текст. Смена состояния флажка не влияет на уже введенный в публикацию текст. Если вам необходимы прямые кавычки для обозначения величин, выраженных в футах и дюймах, воспользуйтесь приемами, описанными в гл. 15.

Переключатель TrueType display (TrueType-шрифты) позволяет настроить интерлиньяж или форму символов TrueType-шрифта для показа на экране. В положении Preserve line spacing (Сохранять интерлиньяж) межстрочные расстояния остаются неизменными, а при необходимости корректируется высота литер. Например, при вводе прописной буквы с верхним акцентом (скажем, Ё) PageMaker уменьшит общую высоту буквы таким образом, чтобы на экранном изображении акцент не выступал за верхнюю границу строки. В положении Preserve character shape (Сохранять высоту символов) рисунок и высота введенного знака не изменяются. В этом случае прописная буква с верхним акцентом будет показана на экране таким образом, что акцент выйдет за верхнюю границу строки. Эти настройки относятся только к TrueType-шрифтам (об этом формате см. гл. 4).


Настройка вида редактора материалов

Редактор материалов — компактный текстовый редактор в составе PageMaker для набора и первичной обработки текстов. В нем выполняют обработку больших объемов импортированных текстов, и как правило — ввод текста с клавиатуры. Набор функций редактора материалов ограничено, большая часть форматирования не отображается на экране — его используют только для набора и редактирования. Гл. S целиком посвящена работе с этим удобным компонентом программы. В области Story editor (Редактор материалов), пользуясь списком Font (Шрифт) и полем ввода Size (Кегль), выбирают шрифт и кегль, которым будет отображаться редактируемый текст в окне редактора материалов (не в публикации!). Можно, например, выбрать шрифт, используемый для форматирования основного текста в макете. Часто удобно определить для редактора материалов простой рубленый шрифт, чтобы не отвлекаться на внешний вид текста, а следить только за его содержанием. Кегль выбирают средним, порядка 12 пунктов, чтобы текст было легко читать и на экране помещался одновременно достаточно большой объем материала.

Флажки режимов позволяют показывать в окне редактора материалов дополнительную информацию. Флажок Display style names (Показать имена стилей) включает отображение имен стилей форматирования, флажок Display ТУ marks (Показать]!) устанавливает отображение специальных символов (признаков конца абзаца, табуляторов пробелов и пр.). Этот режим позволяет легко обнаруживать ошибки, например такие, как удвоенные возвраты каретки, лишние или недостающие табуляции, принудительные обрывы строки т. д.


Экранные копии и хранение файлов графики

В области Graphics (Изображения) определяют режим хранения и отображения экранных копий (миниатюр), а также предельный размер самих изображений, которые хранятся в составе файла публикации без специального подтверждения. Экранные изображения импортированной графики могут храниться внутри публикации PageMaker в различном режиме.

Переключатель Define standard display by (Стандарт для экранных версий) определяет метод расчета параметров экранной версии. В положении Size (Объем) программа при создании экранной копии исходит из размера файла. По умолчанию предельный размер равен 64 Кбайт. Это означает, что импортированные файлы размером меньше 64 Кбайт будут отображаться как таковые, а для файлов больше 64 Кбайт будут созданы экранные копии заданного размера.

В положении Resolution (Разрешение) программа рассчитывает вид экранной копии исходя из разрешения монитора. Если, скажем, в этом поле задать величину 100%, то будет создана экранная копия с разрешением 96 dpi (как у монитора).

Программа может хранить в публикации сами импортированные изображения или только экранные копии и ссылки на внешние файлы. Разумеется, что маленькие изображения лучше внедрять в публикацию, а на большие делать ссылки, поскольку в противном случае у вас на жестком диске окажется две копии — в публикации и в исходном файле. Поле Alert when storing graphics over (Предупреждать, если объем превысит...) и регулирует размер файла, внедряемого в публикацию без дополнительного запроса. Если импортируемое изображение имеет больший размер файла, то при импорте PageMaker будет запрашивать подтверждение операции, и вы сможете либо внедрить само изображение, либо создать экранную копию и ссылку. В гл. 10 и 11 подробно обсуждаются аспекты хранения и импорта графических файлов в PageMaker.


Режимы печати по умолчанию

Если вы собираетесь печатать публикации на PostScript-принтере (а к этому типу относятся все виды фотонаборных автоматов), вам придется установить умолчания в области PostScript printing (PostScript-печать).

В поле Memory freed for graphics (Объем памяти для вывода изображений) определяется режим управления памятью принтера при печати графики. Иногда документ, содержащий графику, невозможно напечатать, поскольку огромный файл картинки не помещается в память лазерного принтера или фотонаборного автомата. Здесь-то и пригодится данная опция. При выборе в списке пункта Maximum (Максимальный) PageMaker йременно выгружает из внутренней памяти принтера все неиспользуемые гарнитуры, печатает необходимую графику, затем загружает их вновь. Возможность предоставления максимального объема памяти — зачастую единственный способ напечатать нужное изображение. Без необходимости не следует оставлять этот переключатель в положении Maximum (Максимальный), это сильно снижает скорость работы принтера, которому необходимо снова и снова загружать одни и те же гарнитуры.

Флажок Display PPD name (Показать имена PPD-файлов) позволяет влиять на способ отображения имени файла описания принтера в диалоговых окнах PageMaker. По умолчанию флажок Display PPD name (Показать имена PPD-файлов) снят и на экран выводится не собственно имя этого файла, а псевдоним, в котором обычно указывается название принтера и его фирмы-производителя. Если этот режим активизирован, PageMaker отображает реальное имя файла PPD.


Замена шрифтов

Кнопка Map fonts (Шрифты) в диалоговом окне Preferences (Установки) предоставляет доступ к установкам интегрированной системы замены шрифтов PANOSE. Эта технология изобретена с целью автоматической замены отсутствующей на данной машине гарнитуры на другую, максимально похожую. Эта замена, по замыслу авторов, должна производиться путем сличения цифрового кода PANOSE, который придают гарнитуре ее разработчики. Код состоит из 10 цифр и составляется по классификации PANOSE. Каждая цифра отражает особенности начертания (наличие и вид серифов, жирность, величину очка, расположение наплывов, контрастность, область применения и др.). Классификация составлена весьма разумно, и следуя ей, несложно задать такой код любому шрифту, исключая, пожалуй, декоративные. В окне замен PANOSE Font Matching (PANOSE: Замена шрифтов) (рис. 3.4) можно активизировать процесс замены шрифтов флажком Allow font matching (Разрешить замену шрифтов). При активном режиме замены становится доступен второй флажок — Show mapping results (Показывать результаты замены). Если его включить, PageMaker будет показывать резуль-

Рис. 3.4. Диалоговое окно установки режима замены для отсутствующих гарнитур

таты замен и запрашивать подтверждение для замены шрифтов в публикации. Внизу окна расположена шкала Substitution tolerance (Степень соответствия), на которой с помощью ползунка можно установить точность замены, от высокой до низкой. В последней строке Default font (По умолчанию) можно выбрать из раскрывающегося списка гарнитуру, которая будет использоваться в качестве замены в случае, если ничего подходящего не найдено.

Кнопки в правой части окна дают доступ к дополнительным настройкам PANOSE. Кнопка Spellings (Написание) открывает вложенное диалоговое окно Alternate Spellings (Альтернативные варианты имен шрифтов) (рис. 3.5, а), в котором перечислены аналоги гарнитур для Windows и Macintosh, имеющие различное написание имен. Список аналогов можно дополнить, редактировать и при необходимости стирать ненужные пары. Вторая кнопка — Exceptions (Исключения) открывает список замен, установленных пользователем принудительно (рис. 3.5, б). Этот список также можно дополнять, редактировать и удалять ненужные элементы.

а

б

Рис. 3.5. Диалоговые окна аналогов гарнитур (а) и исключений при замене шрифтов (б)

К сожалению, функции, упомянутые в этом разделе, работают только в том случае, когда разработчики шрифтов снабжают свои гарнитуры описанным выше кодом PANOSE. А они в большинстве случаев этого не делают по причинам, авторам неизвестным. В результате машине замен нечего сравнивать, и результаты автоматической замены шрифтов не удовлетворяют даже самого невзыскательного пользователя. В настоящее время с помощью замены шрифтов можно лишь редактировать текст, но уж никак не выпускать оригиналы.


Задание умолчаний командами меню

Как уже упоминалось выше, умолчания можно задавать и для элементов меню PageMaker. Пункты меню, доступные в отсутствие открытого документа, позволяют задавать соответствующие умолчания. Ниже приведен полный перечень позиций меню, которым можно задавать значения по умолчанию — как локальные, так и глобальные.

  • Меню File (Файл)
    • Все управляющие элементы в диалоговых окнах, вызываемых из вложенного меню Preferences (Установки) командами General (Основные), Online (Контроль HTML), Trapping (Треппинг), Layout Ajustment (Настройка макета).
    • Все управляющие элементы диалогового окна Document Setup (Параметры документа) и вложенного в него диалогового окна Page Numbering (Нумерация страниц).
    • Диалоговое окно Select source (Выбрать источник), которое позволяет задать источник получения изображения в сеансе работы в PageMaker. Это диалоговое окно открывается одноименной командой меню Acquire (Получить).
    • Диалоговое окно Printer Styles (Стили печати), позволяющее разработать и определить по умолчанию стили печати документов.
  • Меню Layout (Макет)
    • Элементы управления диалогового окна команды Column Guides (Границы колонок).
    • Включение/выключение режима автоматического размещения текста Autoflow (Автозаполнение).
  • Меню Туре (Текст)
    • Все элементы меню Туре (Текст), кроме Expert Kerning (Заказной кернинг), поскольку последняя команда привязана к определенной гарнитуре набора.
    • Средства быстрого форматирования — команды Font (Гарнитура), Size (Кегль), Leading (Интерлиньяж), Horizontal Scale (Ширина символов), Type Style (Начертание), Expert Tracking (Трекинг), Alignment (Выключка) и Style (Стиль). Если на строке, соответствующей элементу меню, имеется стрелка, то все позиции вложенного меню способны задаваться по умолчанию.
    • Все управляющие элементы диалогового окна Character Specifications (Параметры шрифта) могут быть применены для создания мини-умолчаний. Мини-умолчания имеют приоритет перед умолчаниями, заданными с использованием позиций вложенных меню Туре (Текст), Font (Гарнитура), Size (Кегль) и Leading (Интерлиньяж).
    • Все управляющие элементы диалогового окна Paragraph Specifications (Параметры абзаца) могут использоваться для создания мини-умолчаний. Но если определен стиль, применяемый по умолчанию, его параметры имеют приоритет перед параметрами форматирования, заданными посредством мини-умолчания в диалоговом окне Paragraph Specifications (Параметры абзаца).
    • При помощи команды Define Styles (Определить стили) определяются стили оформления абзацев, которые будут появляться в списке палитры стилей вновь создаваемой публикации. После того как вы задали стили по умолчанию, есть возможность назначить стиль, задаваемый по умолчанию, первому абзацу набираемого текста на новом файле. Это делается в раскрывающемся списке пункта меню Style (Стиль).
  • Меню Element (Элемент)
    • Команды Fill (Фон), Stroke (Линия), Fill and Stroke (Фон и линия), дающие возможность определить умолчания для обводки и заливки графических объектов.
    • Параметры фреймов по умолчанию можно установить в диалоговом окне Frame Options (Параметры фрейма), вызываемом одноименной командой.
    • Команды Polygon Settings (Многоугольник) и Rounded Corners (Скругленные углы) — установка параметров многоугольников.
    • Команда Text Wrap (Обтекание текстом).
    • Команда Link Options (Режим связи) позволяет в открывшемся диалоговом окне Link Options: Defaults (Режим связи по умолчанию) установить режим связывания файлов.
    • Меню Service (Сервис)
    • Флажки диалогового окна, открываемого командой Create Index (Создать указатель).
    • Элементы управления диалогового окна, открываемого командой Create Table of Contents (Создать оглавление).
    • Элементы диалогового окна, открываемого командой Define Colors (Определить цвета). В нем определяются цвета, котерые впоследствии появятся в палитре цветов публикации.
  • Меню View (Вид)
    • Режим Display Non-Printing Items (Показать непечатные элементы) Режимы линеек: Show/Hide Rulers (Показать/Спрятать линейки), Snap to Rulers (Выровнять по линейкам), Zero Lock (Закрепить ноль).
    • Режимы направляющих: Show/Hide guides (Показать/Спрятать направляющие), Snap to guides (Выровнять по направляющим), Lock Guides (Закрепить направляющие).
    • Включение/выключение полос прокрутки в окне документа Show/Hide Scroll Bars (Показать/Спрятать полосы прогона).
  • Меню Window (Окно)
    • Наличие на экране в момент открытия PageMaker каждой палитры, включая собранные во вложенном меню Plug-in Palettes (Дополнительные).


Резюме

Задание параметров по умолчанию используется практически на всех этапах подготовки публикации с помощью программы PageMaker. В дальнейшем мы не раз будем обращаться к системе умолчаний, уточняя и расширяя сведения, полученные в этой главе.

Так, об использовании умолчаний диалогового окна Preferences (Установки) рассказывается в гл. 12 и 13. Там же вы найдете подробное описание умолчаний, задаваемых в окне Document Setup (Параметры документа).

Кто хоть раз выводил на печать цветные публикации, тот понимает, как важно добиться соответствия цветов изображения на мониторе и в отпечатанном экземпляре. В гл. 21 описываются умолчания для работы с цветными публикациями, задаваемые в окнах Color Management System Preferences (Параметры CMS) и Trapping Preferences (Параметры треппинга), а также во вложенных в них диалогах.

WWW-умолчания, доступ к которым осуществляется в диалоговом окне Online Preferences (Установки: контроль HTML), рассматриваются в гл. 18.

О работе со стилями и об использовании умолчаний в этой области мы расскажем в гл. 18.

В гл. 9 и 14 описана работа с "родной" и импортированной в PageMaker графикой. В этой работе также не последнюю роль играют установки по умолчанию.


  • ЧАСТЬ II. ТЕКСТ
    • Глава 4. Форматирование символов
      • Работа с инструментом Туре
      • Задание атрибутов форматирования
        • Форматирование выделенного текста
        • Форматирование текста в точке ввода
        • Задание атрибутов форматирования по умолчанию
      • Способы задания атрибутов форматирования
        • Диалоговое окно Character Specifications
        • Меню Туре
        • Управляющая палитра
      • Выбор гарнитуры
        • Выбор гарнитуры в диалоговом окне Character Specifications
        • Выбор гарнитуры с помощью меню Туре
        • Выбор гарнитуры в управляющей палитре
      • Выбор кегля
        • Выбор кегля в диалоговом окне Character Specifications
        • Выбор кегля в меню Туре
        • Выбор кегля при помощи управляющей палитры
      • Интерлиньяж
        • Выбор значения интерлиньяжа
        • Автоинтерлиньяж
      • Установка начертания символов
        • Начертания и внешний вид текста
      • Перевод в прописные. Капители
      • Межсимвольные интервалы и ширина символов
        • Кернинг
          • Автоматический кернинг пар
          • Ручной кернинг
          • Заказной кернинг
        • Трекинг
        • Настройка трекинга
      • Регулировка ширины символов
      • Предотвращение разбиения группы слов
      • Базовая линия, индексы
        • Смещение базовой линии
      • Индексы
      • Работа с управляющей палитрой
      • Резюм


ЧАСТЬ II.

Текст

  • Глава 4. Форматирование символов
  • Глава 5. Форматирование абзацев
  • Глава 6. Глобальное форматирование
  • Глава 7. Импорт текста
  • Глава 8. Редактирование текста


ГЛАВА 4.

Форматирование символов

Символы, составляющие текст документа, — это своеобразные "кирпичи", из которых строится любая, самая сложная публикация. Поэтому первая же глава части "Текст" посвящена именно им. Здесь будут освещены такие темы, как:

  • Шрифты и гарнитуры
  • Атрибуты и способы форматирования символов
  • Кегль
  • Интерлиньяж
  • Межсимвольные и межсловные интервалы
  • Кернинг и трекинг
  • Базовая линия строки

Для того чтобы усвоить материал, вы должны представлять себе, из чего состоит интерфейс PageMaker, как пользоваться управляющей палитрой, изменять масштаб изображения, переходить со страницы на страницу, выполнять операции создания, открытия, сохранения файлов публикаций.

Шрифт

При передаче информации в письменном виде принято, чтобы все буквы были чем-то похожи друг на друга, т. к. это облегчает восприятие текста. Если мы пишем послание от руки, то стиль начертания букв называется почерком. В напечатанном тексте характер и способ изображения литер называют шрифтом.

Каждый из шрифтов имеет свои художественные особенности. Несмотря на большое разнообразие, практически во всех шрифтах можно выделить общие элементы. На рис. 4.1 представлены основные элементы шрифта.

Рис. 4.1. Основные элементы шрифта

В компьютерной полиграфии шрифтом называют набор символов определенного рисунка. Несколько шрифтов, рисунок которых выполнен в одном и том же стиле, представляют собой гарнитуру. Например, гарнитура AvantGarde включает в себя шрифты AvantGarde, AvantGarde, AvantGarde и AvantGarde.

Начертание — это один из вариантов шрифтов в гарнитуре. Оно однозначно определяет вид шрифта. Начертания имеют стандартные названия, например курсивное начертание, полужирное или наклонное. Название начертания состоит из нескольких слов. Первое определяет насыщенность шрифта, второе — степень наклона, третье — дополняет определение начертания. В табл. 4.1 приведены примеры некоторых начертаний. Начертание включает в себя следующие характеристики:

  • насыщенность — относительная толщина штрихов символов;
  • пропорциональность — относительная ширина знаков шрифта. Обычно для точного определения выбирается литера М и определяется соотношение ее ширины и высоты. Различают сверхузкие, узкие, широкие и нормальные начертания;
  • кегль — вертикальный размер символов шрифта, включает в себя высоту литеры (очка) и свободного пространства над и под литерой (оплечиков). Подробнее о кегле см. статью "Типографские единицы измерения. Кегль" данной главы.

Таблица 4.1. Примеры различных начертаний гарнитуры Bodoni

Пример | Насыщенность | Наклон | Особенность
AaBbCeDd | Regular (Нормальный) |  |
AaBbCeDd | Regular (Нормальный) | Italic (Курсивный) |
A a B b C e D d | Regular (Нормальный) |  | Extended (Широкий)
A a B b C e D d | Regular (Нормальный) | Italic (Курсивный) | Extended (Широкий)
AaBbСсDd | SemiBold (Полужирный) |  |
AaBbCeDd | SemiBold (Полужирный) | Italic (Курсивный) |
Пример | Насыщенность | Наклон | Особенность
AuBbCcDd | Bold (Жирный) |  |
AuBbCcDd | Bold (Жирный) | Italic (Курсивный) |
AaBbCcDd | Bold (Жирный) |  | Condenced (Узкий)
AuBbCcDd | Bold (Жирный) | Italic (Курсивный) | Condenced (Узкий)
AaBbCcDd | Regular (Нормальный) |  | Condenced (Узкий)
AaBbCcDd | Regular (Нормальный) | Italic (Курсивный) | Condenced (Узкий)
AaBbCcDd | Light (Светлый) |  |
AaBbCcDd | Light (Светлый) | Italic (Курсивный) |
AuBbCcDd | Bold (Жирный) |  | Extended (Широкий)
AaBbCcDd | Bold (Жирный) | Italic (Курсивный) | Extended (Широкий)


Работа с инструментом Туре

В правом верхнем углу палитры инструментов находится инструмент Туре (Текст). Щелкните на нем мышью. Кнопка с изображением буквы Т становится выделенной, а курсор принимает форму стилизованной буквы I (он так и называется I-курсор). Программа перешла в текстовый режим. Теперь вы можете набирать, выделять и форматировать символы. Внешний вид 1-курсора вам уже знаком по текстовым редакторам. Приемы работы не слишком отличаются от того же Word. На рис. 4.2 представлен внешний вид палитры инструментов при работе в текстовом режиме и сам текстовый курсор.

Рис. 4.2. Внешний вид палитры инструментов в режиме Туре

Перейти к работе с текстом можно одним из трех способов:

  • выбрать инструмент Туре (Текст) с помощью мыши на палитре инструментов;
  • нажав комбинацию клавиш <Alt>+<Shift>+<Fl>. Обратите внимание, что клавиши вызова инструментов на клавиатуре расположены в том же порядке, что и сами инструменты на палитре. Подробнее об использовании палитры инструментов см. гл.1 ;
  • нажав комбинацию клавиш <Ctrl>+<Space>.


Задание атрибутов форматирования

Для тех, кто работал с любым, даже старым или слабым текстовым редактором, в этом разделе не будет почти ничего нового. Задание элементов форматирования для символов в PageMaker производится в трех режимах, в зависимости от того, какие действия были выполнены перед форматированием:

  • форматирование выделенного текста;
  • задание атрибутов текста в точке ввода;
  • задание атрибутов без выделения текста и при отсутствии точки ввода.


Форматирование выделенного текста

При наличии выделения все задаваемые атрибуты форматирования применяются только к выделенному тексту (рис. 4.3). Выделить нужный фрагмент можно несколькими способами. Во всех случаях предварительно следует перейти в текстовый режим.

  • Щелкните мышью в том месте текста, откуда нужно начать выделение, протащите курсор до окончания интересующего вас фрагмента. Таким образом можно выделять и отдельные символы, и большие объемы текста.
  • Выберите начало выделения, нажмите клавишу <Shift> и, удерживая ее, щелкните в месте окончания выделения. Весь текст между этими двумя точками окажется выделенным.
  • Для выделения используют и клавиши управления курсора. Поместите текстовый курсор в начало выделения, затем при нажатой клавише <Shift> перемещайте курсор клавишами со стрелками. Таким образом можно выбрать текст сверху, снизу, слева или справа от начала выделения. Если вы нажмете стрелку вниз (или вверх), то выделится часть текущей строки от курсора до конца и часть следующей, от начала до уровня, на котором располагается курсор. В PageMaker невозможно выделить колонку текста шириной меньше строки.

Рис. 4.3. Форматирование выделенного текста


Форматирование текста в точке ввода

Если вновь вводимый текст должен иметь другие параметры (атрибуты форматирования), можно отформатировать точку ввода:

  1. Выберите текстовый режим работы.
  2. Щелкните мышью в нужном текстовом блоке.
  3. Переведите текстовый курсор в позицию, с которой нужно начинать набор нового текста.
  4. Задайте необходимые параметры текста.

Вновь набираемый текст будет иметь эти параметры. Например, к тексту, набранному гарнитурой Times New Roman (14 кегль, обычное начертание) требуется заголовок гарнитурой Bahaus Light (18 кегль). После выбора точки вставки, а в данном случае это начало текста, задаются требуемые параметры (гарнитура, кегль). Заголовок будет иметь необходимый вид. Атрибуты, задаваемые в этом режиме, действуют только на вновь вводимый текст в данной точке ввода. Если выбрать другую точку ввода, то вновь вводимый текст будет отформатирован в соответствии со значениями, заданными по умолчанию.


Задание атрибутов форматирования по умолчанию

Если установить значения параметров текста без выделения и без точки ввода (инструмент Туре (Текст) вообще может быть неактивным), то заданные значения станут умолчаниями документа. Весь вновь набираемый текст будет иметь эти параметры до тех пор, пока вы снова не измените их. Пользуясь этим режимом форматирования, заранее задайте атрибуты форматирования по умолчанию именно такими (гарнитура, кегль, начертание и другие характеристики), какими вы хотите их видеть в готовом документе. Подробно о задании значений по умолчанию см. гл. 3.


Способы задания атрибутов форматирования

При работе над публикацией один из основных вопросов — выбор шрифтового оформления. В зависимости от назначения и характера публикации оно может сильно различаться. Например, вы хотите, чтобы текст был набран гарнитурой Bookman, имел кегль 10, был размещен на страницах с интерлиньяжем 12,5. Заголовки статей вы решили набрать шрифтом Avangarde, 14 кегль, причем хотите, чтобы первые буквы каждого слива имели инверсное написание (белым по черному). Таким образом, для работы необходимо задать тексту именно эти характеристики — атрибуты форматирования. В программе предусмотрено для этого несколько элементов управления:

  • диалоговое окно Character Specifications (Параметры шрифта);
  • меню Туре (Текст);
  • управляющая палитра.


Диалоговое окно Character Specifications

Диалоговое окно Character Specifications (Параметры шрифта) позволяет определить все без исключения атрибуты форматирования символов. Одновременно можно задать сколько угодно атрибутов. Некоторые из них (например, величина подстрочных и надстрочных индексов, размер капители) можно изменить только из диалогового окна Character Specifications (Параметры шрифта). Вызов диалогового окна Character Specifications (Параметры шрифта) производится командой Character (Шрифт) меню Туре (Текст) или с помощью комбинации клавиш <Ctrl>+<T> (рис. 4.4). На управляющей панели для вызова окна атрибутов шрифта находится кнопка с подсказкой Character Specs. На ней изображена большая буква А.

Рис. 4.4. Диалоговое окно Character Specifications

Рис. 4.5. Меню Type обеспечивает доступ к некоторым атрибутам форматирования


Меню Туре

Меню Туре (Текст) с системой подменю дает быстрый доступ к некоторым атрибутам форматирования символа (рис. 4.5). Этот способ задания параметров гораздо быстрее, чем использование окна Character Specifications.

Наиболее часто используемые команды форматирования имеют клавиатурные сокращения (они показаны в меню).


Управляющая палитра

Этот элемент интерфейса содержит команды управления большей частью атрибутов, задаваемых в программе. Форматирование с помощью управляющей палитры выполняется очень быстро. Палитра, в отличие от окна Character Specifications, остается на экране и после задания атрибута, и вы можете сколько угодно переключаться между ней и окном документа. Приемы переключения между палитрой и окном документа и способы форматирования символов с помощью управляющей палитры сведены в табл. 4.5.

Для вызова палитры выберите команду Show Control Palette (Показать управляющую палитру) меню Window (Окно) или воспользуйтесь комбинацией клавиш <Ctrl>+<'>.


Выбор гарнитуры

Вне зависимости от того, каким методом выбора вы воспользовались, вам предложат список гарнитур, из которых следует выбрать ту, которая вам требуется. PageMaker демонстрирует в списке только шрифты, установленные в Windows. Если в списке шрифтов присутствует, например, запись такого вида: Times New Roman [Verdana, Arial, Helvetica, sans-serif] — это означает, что часть вашей публикации набрана шрифтом, который не установлен на данной машине (в нашем случае это Times New Roman) и он временно заменен программой на другой (Verdana, Arial, Helvetica, sans-serif).


Выбор гарнитуры в диалоговом окне Character Specifications

Откройте диалоговое окно Character Specifications (Параметры шрифта) (см. рис. 4.4) командой Character (Символ) меню Туре (Текст) или комбинацией клавиш <Ctrl>+<T>. Активным будет как раз необходимый нам в данном случае раскрывающийся список Font (Гарнитура). Если при работе вы любите пользоваться мышью, раскройте список и, прокручивая его в нужном направлении, выберите гарнитуру, щелкнув мышью на его названии. Если вы в качестве основного инструмента предпочитаете клавиатуру, наберите первую букву имени нужной гарнитуры. В поле Font (Гарнитура) появится первый из шрифтов, имена которых начинаются на эту букву. Затем, нажимая клавишу со стрелкой вниз, перейдите к нужной гарнитуре. Последующие буквы имени шрифта для уточнения выбора вводить бесполезно, т. к. PageMaker в данном случае учитывает только одну, первую. (Скажем, вам нужен шрифт Bookman. Вы набираете букву В и видите в списке шрифтов первый шрифт на букву В — Bahaus Light. Если следом за буквой В вы введете букву О, то PageMaker покажет в списке не Bookman, а, скажем, OlgaC.)

В диалоговом окне Character Specifications (Параметры шрифта), как и в любом другом, можно пользоваться кнопкой табуляции для перевода активности с одного элемента диалога на другой.


Выбор гарнитуры с помощью меню Туре

Проще и быстрее иногда сделать необходимый выбор в меню Туре (Текст). Для этого выберите команду Font (Гарнитура) данного меню. Раскроется список установленных шрифтов. Набор установленных шрифтов на каждой машине разный, поэтому рис. 4.6 дает лишь примерное представление о том, что вы должны увидеть. Щелкните мышью на нужной гарнитуре.

Рис. 4.6. Выбор гарнитуры в меню Туре


Выбор гарнитуры в управляющей палитре

Для активизации управляющей палитры щелкните в любом ее месте мышью или нажмите комбинацию клавиш <Ctrl>+<'>. Затем щелкните на списке шрифтов. Прокручивая его, выберите необходимую гарнитуру. Если вы пользуетесь клавиатурой, то активизируйте список шрифтов клавишей табуляции, а затем начните набирать имя нужной гарнитуры. В отличие от диалогового окна Character Specifications (Параметры шрифта), в управляющей палитре возможен ввод имени шрифта с клавиатуры. Пока вы набираете имя, PageMaker подставляет подходящее значение в окно списка. Введя две-три буквы имени шрифта, вы увидите, что PageMaker уже догадался, какой шрифт вы имеете в виду, и подставил в окно списка гарнитур требуемое значение. Для того чтобы ваша установка начала действовать, нажмите клавишу <Enter> или табуляцией активизируйте другое поле управляющей палитры. Можно также нажать кнопку модификации (большая квадратная кнопка слева).

Для перехода обратно к редактированию макета необходимо щелкнуть мышью в любом месте окна документа.

Выбор гарнитуры

В какой-то мере шрифты являются произведением искусства. Поэтому их невозможно абсолютно строго классифицировать. По начертанию шрифты можно условно разделить на три большие группы: гарнитуры с засечками (внутри этой группы есть множество подгрупп), рубленые и декоративные. Кроме того, существует группа символьных шрифтов, предназначенных для набора специальных знаков. Примеры шрифтов, классифицированных таким образом, даны в табл. 4.2.

Таблица 4.2. Простейшая классификация шрифтов

С засечками | Рубленый | Декоративный
Times | Avantgarde | Decor
Bodoni | Verdana, Arial, Helvetica, sans-serif | Dolores
Souvenir | Futura | ANNA
Xenia | Hermes | Astson
Lazurski | Kabel | SASYTEETH
Courier | FreeSet | Ижица
Traktir | Optima | Betina Scripts

Засечки (серифы) — это горизонтальные штрихи, располагающиеся сверху и снизу основного штриха литеры (см. рис. 4.1). Серифы оттеняют силуэт литеры, делая шрифт более читаемым и менее суровым, чем рубленый шрифт.

Выбор гарнитуры — не такое простое дело, как может показаться. Теперь, с развитием технологии PostScript, существует огромный выбор гарнитур на все случаи жизни, и число их быстро растет. Дизайнер стал абсолютно свободен в выборе шрифтового оформления и связан лишь собственным (и клиента) вкусом и здравым смыслом. В такой ситуации можно подбирать гарнитуры по характеру публикации. Гарнитуры не только должны соответствовать типу издания, но и должны гармонично сочетаться между собой. Скажем, для текста детской книжки подойдет шрифт SchoolBook (он хорошо читается), а для заголовков — Dolores ("веселая" гарнитура). Для финансового отчета фирмы вы воспользуетесь абсолютно строгим Times в сочетании с несколько претенциозным Optima. Для туристского рекламного буклета по Москве подойдет Izhitsa (откровенный псевдорусский шрифт, похож на московский ГУМ) или Slavianic, а по Петербургу — Academy и Baltica. Описанные примеры представлены на рис. 4.7. Грамотно, со' вкусом выбранное сочетание гарнитур придает даже скромной публикации профессиональный вид, и наоборот, неподходящие или несовместимые шрифты вызывают у читателя раздражение.

В издательском деле существуют неписаные правила выбора гарнитур. В частности, рубленые обычно используются для заголовков, гарнитуры с засечками — для основного текста. Учтите, что рубленый текст хуже читается в мелком кегле, чем шрифты с серифами (исключения составляют такие шрифты, как News Gothics и Franklin Gothics, специально предназначенные для набора в мелком кегле).

Рис. 4.7. Примеры выбора гарнитуры в соответствии с содержанием публикации

Для основного текста следует использовать наиболее читаемый, а именно прямой светлый шрифт. Заголовок, занимающий менее трех строк, лучше набрать пожирнее, чем основной текст, если заголовок имеет три и более строки, то он и основной текст могут быть одинаковой жирности. Гарнитуры заголовка и основного текста должны быть совместимы, но одинаковых гарнитур одного начертания для текста и заголовка лучше избегать. Принято, чтобы на каждой странице использовалось не более трех (а лучше двух) гарнитур. При работе над публикацией не забывайте про главную цель любого документа — служить средством общения. Перед тем как принимать решение об окончательном дизайне, сделайте пробный отпечаток одной страницы и попробуйте прочитать его с расстояния вытянутой руки. Если это сделать трудно, то, возможно, придется изменить гарнитуры на более читабельные или поработать с интерлиньяжем, кеглем, трекингом текста. Учтите, что лазерный принтер печатает с разрешением в 5—10 раз меньшим, чем разрешение фотонабора. Поэтому при печати на принтере штрихи литер будут гораздо толще, чем на пленках, выводимых на фотонаборном автомате. Чем меньше разрешение принтера, тем толще будут буквы.

Поскольку фотонаборные аппараты используют язык описания страниц PostScript, для создания макетов, предназначенных к типографской печати, разумно использовать шрифты Туре 1, программы которых также написаны на PostScript. Это сильно снизит вероятность неправильной интерпретации документа на выводе. Того же правила лучше придерживаться и при печати на принтере с модулем PostScript. Если вы верстаете публикации, которые будут распечатываться только на принтере без поддержки PostScript, можно выбрать шрифт любого типа.


Выбор кегля

Кегль — это вертикальный размер шрифта. В программе PageMaker задаются значения кегля от 4 до 650 пунктов с точностью до одной десятой пункта. Для выбора кегля пользуются любым из описанных выше методов задания атрибутов форматирования — окном Character Specifications (Параметры шрифта), командами меню Туре (Текст) и управляющей палитрой. Подробно о кегле и единицах его измерения см. в статье "Типографские единицы измерения. Кегль" данной главы.


Выбор кегля в диалоговом окне Character Specifications

В диалоговом окне Character Specifications (Параметры шрифта) вводят с клавиатуры значение кегля с точностью до одной десятой кегля. Иногда удобно выбрать с помощью мыши или клавиш управления курсором одно из стандартных значений кегля из раскрывающегося списка (см. рис. 4.4).


Выбор кегля в меню Туре

Выбрав команду Size (Кегль) меню Туре (Текст), вы перейдете к списку стандартных значений кегля. Остается выбрать нужное из значений щелчком мыши (рис. 4.8). Если выбрать пункт списка Other (Другой), откроется диалоговое окно с единственным полем ввода, где можно ввести произвольную величину.

Рис. 4.8. Выбор кегля в меню Туре


Выбор кегля при помощи управляющей палитры

Поле ввода кегля есть, разумеется, и в управляющей палитре. Его следует активизировать с помощью клавиши <Таb> (рис. 4.9) или щелчком мыши. Затем введите нужное значение с клавиатуры или выберите из стандартных значений так же, как в окне Character Specifications (Параметры шрифта). Обратите внимание на то, что управляющая палитра доступна постоянно, в отличие от диалогового окна, которое нужно вызывать командой меню, что несколько замедляет работу.

Рис. 4.9. Выбор кегля с помощью управляющей палитры

Примечание

Комбинация клавиш <Crtl>+<Shift>+<>> увеличивает выделенный или вновь вводимый текст на один пункт, а клавиш <Ctrl>+<Shift>+<<> — уменьшает его. Этим сокращением можно пользоваться и при работе с управляющей палитрой, но в отличие от работы в макете, результаты изменения кегля становятся видны только при нажатии клавиши <Enter> (клавиши <ТаЬ> или кнопки модификации Apply). Если вы хотите проверить несколько значений кегля, удобнее воспользоваться комбинацией клавиш <Enter>+<Shift>. При этом фокус ввода остается в поле ввода кегля, а не передается окну документа. Такой способ изменения кегля незаменим, когда требуется быстро оценить, как влияет величина литер на внешний вид публикации. Для задания дробных величин эти клавиатурные сокращения не подходят. Для увеличения или уменьшения кегля с шагом в одну десятую предназначена пара кнопок на управляющей панели (на них изображена литера А со стрелками вверх и вниз.

Типографские единицы измерения. Кегль

Компьютерные издательские системы появились сравнительно недавно, как и сами персональные компьютеры. С другой стороны, книгопечатный станок изобретен Гутенбергом в 40-х годах XV века, а после изобретения в 1814 году офсетной машины полиграфический процесс, можно сказать, приобрел современные очертания. В полиграфии, как и в любой традиционной отрасли, сохраняется своя, часто абсолютно нелогичная терминология, а также система измерений, основанная на странных числах типа 72 или 1/1440. К сожалению, работники типографий и издательств привыкли к своей системе единиц, поэтому и дизайнеру, несмотря на то, что всю сознательную жизнь он старался пользоваться десятичной системой счисления, придется ее выучить, для того чтобы контакты с типографией и издательствами были дружескими и плодотворными. Кроме того, использование традиционных единиц измерения дает возможность сопоставить величину шрифта с остальными элементами публикации — полями, размером страницы и полосы набора и др.

Пики и пункты — традиционно использующиеся в полиграфии единицы измерения. Ширина и высота колонок и полос выражаются в пиках. Пика равна 4,236 мм или примерно 1/6 дюйма. Величина литер шрифта и интерлиньяж оцениваются в пунктах. В одной пике 12 пунктов, соответственно, в дюйме 72 пункта, или 6 пик. В системе СИ пункт равен 0,353 см. В европейских странах применяется такая единица, как цицеро. Она примерно равна пике (а именно 4,523 мм). В одном дюйме 5,62 цицеро. На рис. 4.10 даются сравнительные линейки, размеченные этими единицами.

Рис. 4.10. Сравнение миллиметров, дюймов и полиграфических единиц измерения

Кегль (величина символов текста), как уже было сказано, измеряется в пунктах. Принято считать, что в большинстве шрифтов величина кегля соответствует ширине прописной буквы М. Если набрать разными гарнитурами одного кегля строчку текста (как показано на рис. 4.11), очевидно, что видимая величина символов сильно разнится. Это происходит потому, что кегль задает не собственно размер букв, а высоту строки текста. Символы разных гарнитур могут иметь разное начертание, а -„конечный продукт (текст) должен смотреться гармонично. Поэтому величина символов сбалансирована художником, создавшим шрифт так, чтобы символы красиво заподняли строку, в данном случае, размером 24 пункта. Скажем, в шрифте Torhok очень маленькие строчные литеры потому, что создатель решил сделать изящный, очень легкий и светлый шрифт, с акцентом на прописные буквы. Если набрать таким шрифтом страницу, то на ней, во-первых, будет слишком пусто, т. к. большая часть строки не заполнена символами, а во-вторых, такой текст будет трудно читать. Этот шрифт служит для заголовков, буквиц и прочих декоративных элементов.

Рис. 4.11. Текст, набранный разными гарнитурами одного кегля

Программа PageMaker дает возможность применять любые единицы измерения (дюймы, пики, миллиметры). Кроме вышеперечисленных, в полиграфии используются дополнительные единицы измерения — круглая шпация, полукруглая шпация, тонкая шпация, характеризующие горизонтальные размеры шрифта. Традиционно они соответствуют ширине заглавных букв М, N и строчной буквы t. Поскольку все шрифты разные, то и ширина литеры М у них может различаться. Некоторые программы упрощают расчет шпации, приравнивая круглую к кеглю шрифта. Соответственно, полукруглая составляет 0,5 кегля, а тонкая — 0,25 кегля. Шпации применяются при измерениях абзацных отступов, кернинга и других перемещениях символов. Эти перемещения (в первую очередь кернинг) совершаются для улучшения зрительного восприятия текста, поэтому важны не точные значения смешений, а их отношение к величине символов в конкретной гарнитуре. В данном случае применение такой относительной единицы автоматически делает эти смещения пропорциональными размеру шрифта.


Интерлиньяж

Плотность строк на странице публикации характеризуется значением интерлиньяжа. Раньше, когда набор текстов производился вручную, для увеличения расстояния между строками текста по вертикали между строками прокладывались тонкие латунные полоски шириной в 2 пункта — шпоны. В традиционной полиграфии интерлиньяж (междустрочный пробел) означал количество пунктов между строками набора. Так, если между строками набора прокладывались два шпона, толщина каждого из которых составляла 2 пункта, общий интерлиньяж составлял 4 пункта.

В настоящее время в понятие интерлиньяжа вкладывается несколько иной смысл. Как это принято теперь, в PageMaker интерлиньяж складывается из размера кегля (вертикальный размер строки набора) и расстояния между смежными строками. Если текст набран кеглем 11/13, это значит, что его интерлиньяж равен 13 пунктам. При этом расстояние между смежными строками составляет 2 пункта. В PageMaker значение интерлиньяжа визуально можно отследить по вертикальному размеру выделения строки.

Интерлиньяж можно задавать числом (в диалоговом окне Character Specifications (Параметры шрифта), меню Туре (Текст) или управляющей палитре) или выбрать автоинтерлиньяж, задав в процентах расстояние между строками относительно кегля символов. В этом случае PageMaker сам рассчитает это значение автоматически.

Если значение интерлиньяжа относится к атрибутам символов, то параметры автоинтерлиньяжа — это атрибут абзаца. Так же к атрибутам абзаца относится и метод расчета интерлиньяжа. PageMaker предлагает производить расчет интерлиньяжа по трем разным схемам — интерлиньяж по базовой линии, по прописным буквам и пропорциональный интерлиньяж. О выборе метода расчета интерлиньяжа см. гл. 5.

И нечувствительно оказалось, что сижу я та своим столом, и синяя папка распахнут передо мною, п пальцы мои сами собой берут листок за листком п бережно перекладывают справа налево, оглаживают, выравнивают объемистую уже стопочку, п ужасно горько мне стало, что вчера почдно вечером дочитал я последнюю написанную строчку Л как хорошо было бы именно сегодня, сейчас вот. в }.пшуту неуверенности, в минуту паники, когда дорога моя неумолимо ведет к развилке, как хорошо было бы в эту минуту прочитать последнюю, еще неведомую мне, ненаписанную строчку п под нею слово "конец"

И нечувствительно оказалось, что сижу я за своим столом, п синяя папка распахнута передо мною, и пальцы мои сами собой берут листок зя листком п бережно перекладывают справа налево, оглаживают, выравнивают объемистую" уже стопочку, и ужасно горько мне стало, что вчера поздно вечером дочитал я последнюю написанную строчку А как хорошо было бы именно сегодня, сейчас вот, в минуту неуверенности, в минуту паники, когда дорога моя неумолимо ведет к развилке, как хорошо было бы в эту минуту прочитать последнюю, еще неведомую мне, ненаписанную строчку п под нею слово "конец"

И нечувствительно оказалось, что сижу я за своим столом, п синяя пайка распахнута передо мною, и пальцы мои сами собой берут листок за листком п бережно перекладывают справа налево, оглаживают, выравнивают объемистую уже стопочку, и ужасно горько мне стало, что вчера поздно вечером дочитал я последнюю написанную строчку А как хорошо было бы именно сегодня, сейчас вот, в минуту неуверенности, в минуту паники, когда дорога моя неумолимо ведет к развилке, как хорошо было бы в эту минуту прочитать последнюю, еще неведомую мне. ненаписанную строчку п под нею слово "конец".

а

б

в

Рис. 4.12. Примеры текстов с различным значением интерлиньяжа


Выбор значения интерлиньяжа

Интерлиньяж, как и гарнитуру, можно задавать тремя способами: в диалоговом окне Character Specifications (Параметры шрифта), в меню Туре (Текст) и с помощью управляющей палитры. В диалоговом окне Character Specifications (Параметры шрифта) можно задать числовое значение интерлиньяжа с точностью до одной десятой пункта или выбрать подходящее из раскрывающегося списка (PageMaker заполняет его подходящими значениями в зависимости от кегля выделенного текста). В управляющей палитре выбор интерлиньяжа осуществляется аналогичным образом с той же точностью, что и в диалоговом окне. В меню Туре (Текст) можно выбрать стандартное значение из списка или, выбрав пункт Other (Другой), ввести нужное число в открывшемся диалоговом окне.


Автоинтерлиньяж

Обратите внимание, что во всех окнах выбора интерлиньяжа имеется вариант Auto (Авто). С его помощью для текста задается режим автоинтерлиньяжа. Выбрать величину автоинтерлиньяжа можно в поле Autoloading: ... % of point size (Интерлиньяж: ... % от кегля), расположенном во внутреннем диалоговом окне, доступ к которому осуществляется при нажатии кнопки Spacings (Интервалы) в диалоговом окне Paragraph Specifications (Параметры абзаца). Если вы не меняли это значение, по умолчанию PageMaker определяет величину автоинтерлиньяжа равной 120%. Расчет конкретной величины межстрочного пробела производится так: PageMaker анализирует текст строки, выбирает литеру с наибольшим кеглем и увеличивает это число на 20%. Полученное значение и будет величиной интерлиньяжа. Величину автоинтерлиньяжа можно свободно менять, в зависимости от ваших требований к внешнему виду публикации. Если необходимо разместить большой объем текста в ограниченном пространстве, этого можно добиться, уменьшив автоинтерлиньяж. Полученный текст будет смотреться темным и массивным. Если же требуется добавить в публикацию "воздух" или попросту заполнить требуемый объем, а текста маловато, увеличьте автоинтерлиньяж. Блок текста станет более "легким" и займет заметно больше места. Сказанное в полной мере относится и к фиксированному интерлиньяжу.

Примечание

Несмотря на то, что автоинтерлиньяж очень упрощает работу, советуем вам избегать его, особенно в ответственных публикациях. Если в тексте встречаются литеры другого кегля или вложенная графика (см. гл. 14), то PageMaker установит автоинтерлиньяж по наибольшему элементу строки. На рис. 4.13 приведен пример такого неудачного расчета. Буквица набрана большим кеглем, чем текст, и PageMaker неоправданно отделил интерлиньяжем первую строку от остальных. Внутри абзаца (а в книжных публикациях и в пределах одной страницы) предпочтительно сохранять одинаковый интерлиньяж.

Рис. 4.13. Влияние автоинтерлиньяжа на внешний вид абзаца при наборе различным кеглем


Установка начертания символов

Три способа задания атрибутов форматирования остаются в силе и для задания начертания символов. PageMaker предусматривает независимое задание нескольких стилей начертания символов. Стандартные стили начертания приведены в табл. 4.3.

Таблица 4.3. Стили начертания символов и соответствующие клавиатурные сокращения

Стиль начертания символов | Комбинации клавиш
Полужирное | <Ctrl>+<Shifl>+<B> или F6
Курсивное | <Ctrl>+<Shift>+<|> или F7
Нормальное | <Ctrl>+<Shift>+<npo6eл> или F5
Перечеркнутое | <Ctrl>+<Shift>+</>
Подчеркнутое | <Ctrl>+<Shift>+<B>
Инверсное | <Ctrl>+<Shift>+<V>

В диалоговом окне Character Specifications (Параметры шрифта) есть возможность устанавливать флажки для каждого из стилей начертания. Аналогичные команды для независимой установки стилей начертания имеются и в меню, вызываемом с помощью команды Type Style (Начертание) меню Туре (Текст).

Если вы работаете с управляющей палитрой, кнопки, задающие различное начертание, находятся под полем ввода гарнитуры и помечены литерой соответствующего начертания. Переключаться с одной на другую можно клавишами управления курсором, а изменять состояние текущей клавиши — нажимая пробел. .

Как видно из табл. 4.3, стандартным стилям начертания символов соответствуют клавиатурные сокращения. Они приведены в подменю Type Style (Начертание) меню Туре (Текст) рядом с соответствующими командами.

Стиль Inverse (Инверсное) — это, разумеется, вовсе никакой не стиль начертания. Инверсия символов применяется для создания специальных эффектов. После выбора этого начертания буквы приобретают цвет бумаги. Если под строку текста подкладывается цветной прямоугольник, то буквы не печатаются поверх, а как бы прорезают подложку, и в просветы виден фон бумаги. При этом само начертание букв никак не изменяется. На экране такого же эффекта можно достичь, подложив цветной прямоугольник под текст белого цвета. Однако, если печать производится на цветной бумаге или в качестве типографской краски присутствует белая, возможны недоразумения. (Подробно о цветах см. соответствующий раздел гл. 9.)

Примечание

С печатью инверсного текста могут возникнуть сложности. Для воспроизведения его на He-PostScript-принтере нужна специальная настройка. Возможно, чтобы напечатать такой текст, в диалоговом окне свойств принтера вам придется включить режим воспроизведения текста как графических кривых.

Во многих шрифтах, особенно Туре 1, существует много больше стилей начертания, чем указано в табл. 4.1: такие, как очень светлый, узкий, очень жирный, широкий и др. Для выбора этих нестандартных стилей начертания следует обратиться к списку выбора гарнитур, где данные начертания фигурируют в качестве отдельных позиций.

Возможно, вас не удовлетворяет комплект нужной гарнитуры, скажем, хочется чуть-чуть изменить жирность штриха или величину и угол серифов или выбрать нечто среднее между прямым и наклонным начертанием. Изобретенная Adobe технология Multiple Master позволяет плавно изменять внешний вид шрифта. К сожалению, не любого, а того, который был написан в соответствии с этой технологией. Шрифты Multiple Master выпускаются уже несколько лет, русской раскладки они не имеют. В основном в таком формате выпускают шрифты для набора. Шрифт этого формата имеет один, два или более параметров, которые можно плавно изменять. Для управления таким шрифтом воспользуйтесь шрифтовой машиной Adobe Type Manager. Определив нужную модификацию, вы практически создадите полноценный новый шрифт в формате Type1.


Начертания и внешний вид текста

Пользоваться начертаниями следует с умом. Так, например, принято считать, что текст, набранный полужирным, сразу бросается в глаза, поэтому есть смысл набрать им заголовки статьи, а также основные тезисы публикации. Курсив, который смотрится легче, используйте там, где необходимо отделить части текста, не слишком привлекая внимание (подзаголовки, строчки с фамилиями авторов, цитаты). Перечеркнутый и инверсный текст применяется для создания специальных эффектов. В то же время, инверсный текст заголовков на темном фоне смотрится прекрасно и уместен не только в рекламном плакате, но и в деловых документах.

Следите за межсимвольными пробелами при смешивании прямого и курсивного начертания. Форматирование курсивом слова или группы слов внутри текста нормального начертания приводит к увеличению межсловного интервала в точке, где курсивный шрифт сменяется прямым, поскольку символы курсивного начертания отклонены вправо. Этот эффект может быть более или менее заметен в зависимости от выбора гарнитуры. Ниже приводятся способы, как можно избежать такой ошибки форматирования.

  • Часто достаточно отформатировать пробел после курсивного начертания прямым, чтобы межсловный просвет после курсива приобрел нормальный вид.
  • Иногда, при ответственных работах на тексте увеличенного кегля (в заголовках), оптимального пробела можно добиться кернингом. PageMaker позволяет выполнять кернинг пробела так же, как и любого символа текста (см. разд. "Межсимвольные интервалы и ширина символов" данной главы).
  • Если эти методы неэффективны, вставьте в нужной точке пробел фиксированной ширины вместо простого. Если пробел в полукруглую шпацию (комбинация клавиш <Ctrl>+<Shift>+<N>) все равно слишком велик, попробуйте тонкий пробел (комбинация клавиш <Ctrl>+<Shift>+<T>).

Подчеркивания как метода выделения старайтесь избегать. Выделение подчеркиванием — дань воспоминанию об эпохе пишущих машинок. Тексто-выделителей тогда не было, и единственным способом привлечь внимание к тексту было подчеркивание. Теперь в ваших руках есть мощный набор инструментов выделения — от элегантных, как курсив и легкая разрядка (увеличенный межбуквенный пробел), до таких мощных, как увеличение кегля и жирности, инверсное начертание или даже переход к более выразительной гарнитуре. Такие методы выглядят намного более профессионально.


Перевод в прописные. Капители

Иногда хорошим методом выделения является набор прописными, или ка-пителыо. Такое форматирование называется установкой регистра текста и показано на рис. 4.14.

Набирать прописными буквами можно, конечно, и прямоте клавиатуры. Удобство именно форматирования прописными заключается в его временном характере. Текст всегда легко можно вернуть к нормальному регистру. На регистр можно воздействовать из диалогового окна Character Specifications (Параметры шрифта). Выберите нужный регистр из раскрывающегося списка Case (Регистр) — Normal (Нормальный), All Caps (Все прописные), Small Caps (Капитель).

Рис. 4.14. Заголовок в подбор выполнен капителью, прописными и обычным набором

При работе с управляющей палитрой кнопки перевода регистра расположены там же, где и кнопки выбора начертания, под строкой выбора гарнитуры. Напомним, что перемещаться от кнопки к кнопке можно клавишами управления курсором, изменять состояние текущей клавиши — нажимая пробел. В подменю Type Style (Начертание) меню Туре (Текст) команды форматирования регистра отсутствуют. Комбинация клавиш для перевода в прописные — <Ctrl>+<Shift>+<K>. Капитель нечасто используется в наборе, для нее нет клавиатурного сокращения. Обычно капитель применяют в колонтитулах, иногда в заголовках, кроме того, это хороший способ создать специальный эффект. Параметры капители (размер строчных капителей по отношению к текущему кеглю) задаются в диалоговом окне Character Options (Дополнительные параметры шрифта), вызываемом из окна Character Specifications (Параметры шрифта) при нажатии кнопки Options (Другие). Если вы не изменяли это значение, оно равно 70%. При этом высота капители соответствует высоте букв нижнего регистра.

Капитель — изящный, "пижонский" прием. Пользоваться им нужно умеренно. К сожалению, PageMaker 6.5, как и предыдущие версии, некорректно переводит в капитель русский набор, упорно набирая крупным кеглем букву Ч, причем это касается и шрифтов Туре 1 и TrueType. Бороться с таким своеволием возможно только вручную, уменьшив кегль до необходимого (т. е. на столько же, на сколько уменьшается кегль капители в соответствии с установкой диалогового окна Character Options (Дополнительные параметры шрифта). Кроме того, зрительные пробелы между литерами в получившейся капители оставляют желать лучшего, строка смотрится рваной и приходится устанавливать кернинг вручную. Тем не менее иногда, особенно для создания публикаций типа рекламных брошюр, плакатов, при разработке логотипов, капитель применяется (рис. 4.15).

Рис. 4.15. Применение капители


Межсимвольные интервалы и ширина символов

При работе над публикацией место, которое должен занять массив текста, обычно более или менее строго определено. В этом разделе рассматриваются атрибуты форматирования, влияющие на объем, занимаемый символами текста на строке. А именно:

  • кернинг — регулирует расстояние между заданными парами символов, относительная величина, которая измеряется в частях круглой шпации;
  • трекинг — автоматически меняет значение межсимвольного интервала для всех символов текста пропорционально кеглю набора;
  • ширина символов — задает размер символов по горизонтали, в отличие от кегля не оказывая влияния на их высоту.


Кернинг

Установки кернинга сообщают выходному устройству (монитору, принтеру, фотонаборной машине), что между соответствующими парами символов следует увеличить или уменьшить расстояние. Это делается для того, чтобы строка набора смотрелась равномерно и глаз воспринимал видимые просветы между литерами как одинаковые. Все символы имеют разное написание, соответственно, разную ширину. Существуют пары литер (кернинговые пары), для которых различие в ширине приводит к нежелательному увеличению (значительно реже — к уменьшению) расстояния между ними. Создастся ощущение, что они принадлежат к разным словам, это сильно снижает читабельность текста. Если отрегулировать величину межсимвольного расстояния для такой пары символов (т. е. сделать кернинг), текст станет более равномерным и читать его будет легче. Выступающие элементы одной буквы должны заходить в просветы другой, но ни в коем случае не перекрываться. Кернинг может быть применен не только к буквам и знакам препинания, но и к пробелам, ширина которых наряду с другими символами определяется в каждом шрифте. На рис. 4.16 представлены пары букв без кернинга и с выполненным кернингом.

Рис. 4.16. Кернинговые пары (вверху— без кернинга, внизу — с кернингом)

Роль кернинга особенно велика для шрифтов большого кегля, скажем, для шрифтов заголовков. Чем крупнее шрифт, тем тщательнее он должен быть отформатирован, любой достаточно большой промежуток сразу бросается в глаза. Для набора мелким кеглем кернинг не так важен, поскольку при уменьшении литер уменьшаются и межсимвольные промежутки.

Кернинг позволяет регулировать межсимвольный промежуток с высокой точностью. Предельная точность кернинга пар в PageMaker 6.5 составляет 0,001 круглой шпации. PageMaker предусматривает три метода кернинга текста — автоматический, ручной и заказной.


Автоматический кернинг пар

Доступ к этой функции PageMaker осуществляется во вложенном диалоговом окне, которое вызывается из окна Paragraph Specifications (Параметры абзаца) кнопкой Spacings (Интервалы). Автоматический кернинг может быть включен или отменен. Кроме того, в этом диалоговом окне вводится наименьший кегль, для которого выполняется автоматический кернинг. По умолчанию автоматический кернинг выполняется для кегля, равного 4 пунктам и больше. Считается, что для более мелкого текста кернинг не имеет значения. Автокернинг в PageMaker увеличивает или уменьшает межсимвольный промежуток между кернинговыми парами на основе информации, заложенной при создании шрифта. Иными словами, в программу шрифта включается информация о том, для каких пар символов и каким образом делать кернинг (так называемые таблицы кернинга). Поскольку в вашем хозяйстве могут встретиться шрифты от разных производителей, результаты автоматического кернинга могут быть от отличных до совсем неудачных. Полнота и корректность таблиц кернинга — немаловажная характеристика качества шрифта. Редактировать таблицы кернинга внутри PageMaker, к большому сожалению, невозможно. Автоматический кернинг применяют очень часто, практически постоянно. Его наличие не оказывает заметного влияния на снижение скорости работы PageMaker, а качество публикации улучшается. Для многостраничных документов, таких как книги или толстые журналы, это единственно возможный тип кернинга (трудно себе представить книгу в 300 страниц, в которой кернинг настроен вручную).


Ручной кернинг

При обработке текстов большого кегля, например заголовков, многие пользователи предпочитают выполнять "ручной" кернинг. Используя клавиатурные сокращения или управляющую палитру, ручной кернинг можно произвести в любом фрагменте текста, начиная парой символов и кончая целым материалом.

При выполнении кернинга вручную необходимо видеть, что происходит во время работы с парами символов. Удобнее всего при этом использовать комбинации клавиш для ручного кернинга, которые указаны в табл. 4.4. Обратите внимание, что перемещения букв можно производить с различным шагом — от 0,01 до 0,04 круглой шпации, в зависимости от нужной точности.

Таблица 4.4. Клавиатурные сокращения для ручного кернинга

Действие (сдвиг указан в долях круглой шпации, em) | С помощью клавиш со стрелками | С помощью клавиш С помощью на цифровой клавиши пробела клавиатуре (клавиша <Num Lock> отключена)
Раздвинуть на 0,1 em | <Alt>+<->> | <Ctrl>+<Shift>+<+>
Сдвинуть на 0,1 em | <Alt>+<<-> | <Ctrl>+<Shift>+<->
Раздвинуть на 0,4 em | <Alt>+<Ctrl>+<->> | <Ctrl>+<Shift>+<Пробел> <Ctrl>+<+>
Сдвинуть на 0,4 em | <Alt>+<Crtl>+<<-> | <Сtrl>+<Пробел> <Ctrl>+<->

В управляющей палитре значение кернинга вводят в соответствующее поле с точностью до 0,001 круглой шпации или регулируют кнопками настройки. Кнопка со стрелкой вправо увеличивает межсимвольный пробел, со стрелкой влево— уменьшает (рис. 4.17). Шаг настройки с помощью кнопок — 0,01 круглой шпации.

Рис. 4.17. Поле ввода кернинга управляющей палитры и кнопки настройки

Результат кернинга становится виден при нажатии одной из клавиш — клавиши <Enter>, <Tab> или кнопки модификации. Если вы хотите проверить несколько значений кернинга, нажмите комбинацию клавиш <Enter>+<Shift>. При этом точка ввода остается в строке кернинга, а не передается окну документа. Это очень удобно, если нужно быстро проверить, ка,к влияют варианты кернинга на внешний вид строки.

Обычно кернинг выполняется для пары символов в положении точки ввода. Если выделить символ и применить к нему кернинг, изменится межсимвольное расстояние справа от символа. В PageMaker есть возможность с помощью управляющей палитры или комбинации клавиш изменять кернинг не только отдельной пары символов, но и выделенного фрагмента любой длины. Такой метод грубой силы применяется в верстке наряду с изменением трекинга и ширины символов в основном для размещения текста в заданной площади страницы, когда нужно увеличить (разогнать) фрагмент текста или, наоборот, уменьшить (вогнать строку). Какому из названных методов отдать предпочтение — дело вкуса. Разумеется, результирующий фрагмент должен остаться читаемым и как можно меньше отличаться от неизмененных частей текста. Подробнее о методах верстки см. гл. 14.


Заказной кернинг

По замыслу авторов PageMaker этот тип кернинга обеспечивает равномерную настройку интервалов между всеми символами выделенного текста с учетом формы конкретных символов и заданной плотности текста. Диалоговое окно Expert Kerning (Заказной кернинг) открывается одноименной командой меню Туре (Текст). Перед началом заказного кернинга нужно выделить фрагмент текста. Текст должен быть набран шрифтом Туре 1, а трекинг и автоматический кернинг выделенного фрагмента должны быть отключены. Внешний вид диалогового окна Expert Kerning (Заказной кернинг) показан на рис. 4.18.

Рис. 4.18. Диалоговое окно Expert Kerning

Откройте указанное диалоговое окно и введите нужное значение силы кернинга в строку ввода Kern strength (Плотность текста) или передвиньте ползунок на линейке прокрутки. Значение плотности текста можно изменять в диапазоне от 0,001 до 2,00 условных единиц с шагом 0,001, при этом тексту наибольшей плотности соответствует значение 0,001. По умолчанию кернинг равен 1,00 (средняя плотность текста). Выбор типа оформления из раскрывающегося списка Design class (Тип оформления) позволяет более точно настроить кернинг в соответствии с характером текста. Диалоговое окно Expert Kerning (Заказной кернинг) окончательно настраивает значения кернинга исходя из типа гарнитуры, которой набран текст. Таким образом, осуществляя выбор типа оформления — Text (Текст), Display (Экранный), Poster (Плакат), — нужно в первую очередь руководствоваться гарнитурой набора и уже затем кеглем. Если тип гарнитуры неизвестен, лучше выбрать тип Text (Текст). Кроме того, пункт Other (Другой) раскрывающегося списка Design class (Тип оформления) позволяет выбрать окончательную настройку кернинга исходя из кегля набора. В правой части диалогового окна есть демонстрационное поле, в котором изменения, вносимые в значения кернинга, сразу отражаются на примере кернинговой пары AW. Заказной кернинг дает отличные результаты при английском наборе, но работает исключительно медленно (процесс кернинга абзаца из 10 строк занимает 12 секунд, не считая времени на работу с диалоговым окном), поэтому пользоваться им имеет смысл для небольших объемов текста. К сожалению, с фирменными русскими шрифтами от фирмы "ПараГраф" эта утилита не работает.


Трекинг

В отличие от кернинга пар, можно выполнять трекинг любого объема текста. Трекингом обрабатываются большие объемы текста, от больших абзацев до целых публикаций. Трекинг не чувствителен к парам символов, и все интервалы при настройке трекинга изменяются на одну и ту же величину, кроме того, в отличие от кернинга, трекинг текста нельзя менять плавно. Вы имеете на выбор пять различных вариантов осуществления трекинга плюс шестой — отсутствие трекинга.

Чем же тогда хорош трекинг и почему такой грубый инструмент с успехом применяется? У трекинга есть одно замечательное с точки зрения полиграфиста свойство — каждое из значений трекинга является функцией кегля, и вид этой функции задается отдельно для каждой гарнитуры. Таким образом, если задать значение трекинга Very Loose (Очень жидкий) для текстов разного кегля гарнитуры Times, то вид полученных строчек будет различным. В очень мелком кегле (5—6 пунктов) расстояния между буквами увеличатся очень сильно, для лучшей читаемости текста. В среднем 'Кегле увеличение будет почти незаметно, в крупном — литеры даже станут плотнее, чем при отсутствии трекинга (в крупном кегле можно довольно сильно уменьшить межсимвольный интервал без ухудшения читаемости) (рис. 4.19).

а

б

в

Рис. 4.19. Влияние трекинга на внешний вид текста

Рис. 4.20. Трекинг Normal применен для текстов разного кегля

Таким образом, трекинг тоже является относительной величиной. Встроенная в программу PageMaker подсистема трекинга настраивает межсимвольные интервалы исходя из кегля, которым набран текст, пытаясь сохранить соответствие размера интервалов и символов (рис. 4.20). Варианты трекинга — от очень жидкого до очень плотного — можно выбрать из раскрывающегося списка Track (Трекинг) (окно Character Specifications (Параметры шрифта) или управляющая палитра) или установить флажок в списке значений трекинга меню Туре (Текст) подменю Expert Tracking (Трекинг).


Настройка трекинга

Трекинг индивидуально настраивается на каждую гарнитуру, настройки на большинство стандартных гарнитур входят в комплект PageMaker и образуют таблицу значений трекинга (файл Trackvals.bin). Для других гарнитур применяется обобщенная настройка. Возможно, вас не устраивает функция трекинга от кегля для данной гарнитуры или вы хотите создать настройку для гарнитуры, отсутствующей в таблице значений трекинга. Доступ к настройке трекинга осуществляется через диалоговое окно Edit tracks (Заказной трекинг ) (рис. 4.21), вызываемое через меню Туре (Текст) подменю Expert Tracking (Трекинг) командой Edit Tracks (Заказной).

Рис. 4.21. Диалоговое окно Edit tracks

Вверху диалогового окна расположен раскрывающийся список Font (Шрифт). Выберите в нем гарнитуру, настройки которой вы будете изучать.

Ось абсцисс приведенного графика соответствует изменению кегля в пунктах. По оси ординат откладывается смещение символов относительно положения No Track (Без трекинга) в процентах. Отрицательные значения соответствуют смещению влево и уменьшению интервалов, положительные — увеличению (смещению символов вправо). Для выбранной вами гарнитуры, как и для любой другой, существуют пять уровней плотности трекинга. На графике каждому из них соответствует кривая. Выберите нижнюю кривую с помощью мыши. В раскрывающемся списке значений трекинга (справа от списка гарнитур) вы увидите, что эта кривая отображает значение трекинга Very Tight (очень плотный). Выше расположены кривые Tight (плотный), Normal (нормальный), Loose (жидкий) и Very Loose (очень жцдкий). Можно выбирать кривые и прямо из раскрывающегося списка. Самому плотному трекингу соответствует наименьшее значение межсимвольного интервала. Обратите внимание, что в Кегле меньшего размера символы раздвигаются, а при увеличении кегля все начинают сближаться. По мере роста кегля коррекция межсимвольного интервала в сторону уменьшения становится все более значительной.

Настройка трекинга осуществляется перетаскиванием опорных точек (квадратных маркеров) на графиках. Выберите нужную кривую. Подведите курсор мыши к опорной точке. Когда он примет форму креста, нажмите кнопку мыши и, не отпуская ее, протащите опорную точку в нужном направлении. Перетаскивание в вертикальном направлении изменяет величину стандартного межсимвольного интервала; если смещать маркер по горизонтали, сместится соответствие опорной точки конкретному кеглю. Для аккуратной работы советуем пользоваться для перемещений не мышью, а клавишами управления курсором, предварительно щелкнув мышью на нужной точке.

Новая опорная точка создается, если щелкнуть мышью на кривой при нажатой клавише <Alt>. Удалить опорную точку можно, щелкнув мышью с нажатой клавишей <Alt> на соответствующем маркере.

Для перемещения по вертикали всей кривой выделите ее при нажатой клавише <Ctrl>, после чего ее можно будет двигать клавишами управления курсором с шагом 0,1%.

По окончании редактирования вы можете сохранить полученные результаты. Кроме того, предлагается создать контрольную публикацию с помощью диалогового окна, открываемого кнопкой Proof (Пример). Окно создания контрольной публикации представлено на рис. 4.22. В нем можно выбрать, какие значения трекинга и для каких кеглей будут присутствовать в контрольной публикации. Выбирается также пример текста (короткий или длинный). Каждый из этих примеров можно редактировать в полях ввода.

Таблица значений трекинга сохраняется в файле Trakvals.bin, расположенном в главной папке программы PageMaker, в папке \RSRC\USENGLSH. Заметьте — когда вы редактируете таблицу трекинга, PageMaker пишет ее в тот же файл. Сохранить отредактированную таблицу трекинга под другим именем невозможно. Для того чтобы сохранить стандартный файл Trakvals.bin и измененную таблицу трекинга для вашей публикации, создайте копию файла Trakvals.bin под другим именем, затем выполните редактирование трекинга и сохраните результат. По окончании работы перенесите отредактированный файл Trakvals.bin в папку с материалами публикации и восстановите стандартную таблицу из ранее сделанной копии.

Простота обращения с настройками трекинга искушает воспользоваться этой функцией PageMaker. И все же, если вы не обладаете большим опытом работы с публикациями или специальным образованием, результаты ручной настройки функций трекинга будут совершенно неудовлетворительными. PageMaker вполне качественно выполняет трекинг из стандартных таблиц, поэтому имеет смысл ими и пользоваться. Если вы все же собрались экспериментировать, не забудьте сохранить стандартный файл Trakvals.bin.

Рис. 4.22. Подготовка контрольной публикации для оценки результатов настройки трекинга

Примечание

Если при подготовке публикации вы изменяли настройки трекинга, включите в комплект, передаваемый в сервис-бюро, файл Trakvals.bin, созданный для данной публикации. Он автоматически копируется в папку с материалами публикации, если вы сохраните документ командой Save As (Сохранить как) и в открывшемся диалоговом окне выберете команду сохранения Files reqired for Remote Printing (Файлы для удаленной печати).


Регулировка ширины символов

PageMaker позволяет изменять начертание символов текста таким образом, что при неизменной высоте (кегле) ширина литеры может составлять от 5 до 250% стандартной ширины данного символа гарнитуры. Ширину символов можно задавать из диалогового окна Character Specifications (Параметры шрифта) в строке ввода Horiz scale (Ширина символов) (см. рис. 4.4) или из управляющей палитры с помощью строки ввода, помеченной очень широкой буквой Т, и соответствующих кнопок настройки (табл. 4.5). На рис. 4.23 представлены результаты изменения ширины символов в строке. Пробелы PageMaker тоже рассматривает как символы, следовательно, при изменении ширины символов фрагмента текста изменяются межсловные интервалы.

Рис. 4.23. Текст 14 кегля с различными значениями ширины символов

Примечание

Можно пользоваться этим приемом для вгона строки (как последним средством и очень осторожно, изменение не больше ± 3%). Изменения ширины в пределах 10% иногда применяют в заголовках. В общем же случае шрифт создан художником именно с данной шириной символов, если изменить ее, гармоничные прежде литеры приобретут некрасивые очертания, говорящие о низком уровне полиграфического образования у их создателя.


Предотвращение разбиения группы слов

Часто перед верстальщиком встает задача размещения текста именно данным образом, на заданном числе строк. Для ее решения пользуются кернингом, трекингом, установкой ширины символов. Этого же эффекта можно достичь с помощью функции предотвращения разбивки строк No Break (На одной строке). К ней также прибегают, если в тексте встречается группа слов, разбивать которую нежелательно. Такой группой может быть название журнала "Эс-Эф Магадзин", как на рис. 4.24, а. Для того чтобы запретить разбивку на строки группы слов, нужно сначала ее выбрать. Затем открыть окно Character Specifications (Параметры шрифта) (см. рис. 4.4) и выбрать в раскрывающемся списке Line end (Символы) установку No Break (На одной строке). Результат такого форматирования представлен на рис. 4.24, б.

Несмотря на простоту, эта функция форматирования крайне полезна. При переверстке вы всегда будете уверены, что на 234 странице в начале страницы не окажется одинокого "г." (т. е. год). Того же эффекта можно достичь с помощью установки фиксированных пробелов между нужными словами, PageMaker не делит группу слов, связанную такими пробелами. Комбинации клавиш для фиксированных ("неделимых") пробелов таковы:
<Ctrl>+<Shift>+<M> — пробел шириной в круглую шпацию; <Ctrl>+<Shift>+<N> — пробел шириной в полукруглую шпацию; <Ctrl>+<Shift>+<T> — пробел шириной в тонкую шпацию.

Рис. 4.24. Форматирование атрибутом No Break группы смежных символов


Базовая линия, индексы

Базовая линия — это воображаемая линия, проходящая по основаниям символов текста. Получается, что в строке текста сами символы стоят на базовой линии, а нижние выносные элементы текста как бы свисают с нее. Кроме нижних выносных элементов, ниже базовой линии располагаются подстрочные индексы, надстрочные же не опираются на нее, а находятся значительно выше.

Если в тексте изменить метод интерлиньяжа, базовая линия строки изменит свое положение и текст сместится по вертикали. Это надо учитывать при изменении параметров текста. Более подробно о выравнивании текста по базовым линиям см. гл. 14.


Смещение базовой линии

С помощью диалогового окна Character Specifications (Параметры шрифта) (см. рис. 4.4) или управляющей палитры можно смещать базовую линию относительно стандартной позиции, причем как для целой строки, так и для отдельных элементов. Именно таким способом создаются надстрочные и подстрочные индексы. Результат смещения базовой линии на различную величину для разных фрагментов строки представлен на рис. 4.25.

Рис. 4.25. Смещение базовой линии

В управляющей палитре строка ввода смещения базовой линии и соответствующие кнопки настройки расположены в правом нижнем углу и помечены двумя подчеркнутыми буквами А, смещенными относительно друг друга по вертикали. Смещение задается в диапазоне от -1600 до +1600 пунктов с шагом в 1 пункт. В диалоговом окне Character Specifications (Параметры шрифта) добраться до команды смещения базовой линии сложнее. Она находится во внутреннем окне Character Options (Дополнительные параметры шрифта), перейти к которому можно, нажав кнопку Options (Другие). Строка ввода смещения расположена в нижней части окна (рис. 4.26).

Примечание

Если вы работаете во вложенном диалоговом окне (а впоследствии вам встретятся окна даже четвертого уровня вложенности), нет никакой необходимости закрывать их одно за другим, это лишняя трата времени. Когда вы закончили работу с окном, нажмите и не отпускайте клавишу <Shift> и щелкните на кнопке ОК (Да) (или Cancel (Нет)). Такая комбинация закрывает все вложенные окна одновременно.

Рис. 4.26. Вложенное диалоговое окно дополнительных параметров шрифта


Индексы

Индексы встречаются в основном в технической и научно-популярной литературе. Верхние индексы можно увидеть в любых изданиях в качестве номеров примечаний или затекстовых комментариев, нижние используются в химических и математических формулах. Эти элементы макета оформляются путем смещения базовой линии в сочетании с уменьшением кегля. Для задания нужному символу или фрагменту текста атрибута Superscript (Над-индекс) или Subscript (Подиндекс) можно воспользоваться стандартными способами задания атрибутов в PageMaker — диалоговым окном Character Specifications (Параметры шрифта) или управляющей палитрой. В диалоговом окне выберите нужное положение текста из списка Position (Позиция), в управляющей палитре атрибут надстрочного и подстрочного индекса задается соответствующими кнопками форматирования символов под списком гарнитур. Кнопки помечены маленькой буквой S и треугольной стрелкой, направленной вверх (для надстрочного индекса) или вниз (для подстрочного). Настройку индексов можно легко менять. Для этого откройте вложенное диалоговое окно Character Options (Дополнительные параметры шрифта) (рис. 4.26) из диалогового окна Character Specifications (Параметры шрифта) с помощью кнопки Options (Другие). В строке Super/subscript size (Размер над/подиндекса) задайте нужный размер индекса. Следующие две строки Subscript position (Положение подиндекса) и Superscript Position (Положение надиндекса) управляют положением индексов относительно основного текста. Значения задаются в процентах от кегля набора.


Работа с управляющей палитрой

Управляющая палитра — мощный и очень удобный, как вы, вероятно, уже убедились, инструмент работы. Напомним основные ее элементы при работе в режиме Symbol (рис. 4.27).

Все описанные в этой главе приемы работы с управляющей палитрой в режиме Symbol приведены в табл. 4.5, представленной ниже. Перед началом ввода текста убедитесь, что управляющая палитра активна. В противном случае текст окажется засорен посторонними символами. Если ни один из элементов управляющей палитры не выделен, то она не активна.

Рис. 4.27. Элементы управляющей палитры в режиме Symbol

Таблица 4.5. Функции управляющей палитры в режиме Symbol

Действие | Способ управления Примечание
Активизация палитры | <Ctrl> +<'> Переводит фокус ввода с главного окна (документа) на управляющую палитру и обратно
Выбор элемента управления | <Tab> или <Shift>+<Tab> Активизирует следующий элемент управления (<Shift>+<Tab> — предыдущий элемент управления)
Модификация | <Таb> или <Shift>+<Tab>, Вносит выполненные <Enter> или <Shift>+<Enter> изменения в публикацию, при нажатии комбинации клавиш <Shift>+<Enter> фокус ввода остается в том же поле управляющей палитры
Действие | Способ управления | Примечание
Режим работы палитры | <Ctrl>+<Shift>+<'> | Работает при активном инструменте Туре, переключает режимы Symbol и Paragraph
Гарнитура | Выбор из списка или ввод имени с клавиатуры | По мере ввода символов имени гарнитуры PageMaker выделяет подходящее название из списка
Начертания, регистр, индексы | Клавиши управления курсором, пробел | Вариант форматирования выбирается клавишами управления курсором, текущий вариант включается и выключается пробелом
Кегль | Ввод числа с клавиатуры или выбор из списка, кнопки настройки | Значение от 4 до 650 пунктов с шагом 0,1 пункта. Кнопки настройки изменяют кегль на 0, 1 пункта
Интерлиньяж | Ввод числа с клавиатуры или выбор из списка, кнопки настройки | Значения от 0 до 1300 пунктов с шагом 0,1 пункта. Кнопки настройки меняют значение на 0,1 пункта
Трекинг | Выбор из списка или ввод с клавиатуры значения трекинга | По мере ввода PageMaker подставляет подходящее значение в строку ввода
Ширина символов | Ввод с клавиатуры или выбор из списка, кнопки настройки | Значение от 5 до 250%. 100% соответствует нормальной ширине символов. Кнопки изменяют ширину на 1%
Кернинг | Ввод с клавиатуры, кнопки настройки | Значение от -1 до +1 круглой шпации. Кнопки настройки изменяют значение кернинга на 0,01 круглой шпации
Смещение базовой линии | Ввод с клавиатуры, кнопки настройки | Значение от -1600 до +1600 пунктов, значение 0 соответствует отсутствию смещения. Единицы измерения те, которые выбраны в окне Preferences (Установки). Их можно менять вводом с клавиатуры условных обозначений (см. табл. 5.2). Кнопки настройки меняют смещение на 1


Резюме

В настоящей главе рассмотрены параметры символов, определяемые в программе. Наряду с символьными атрибутами внешний вид и размещение текста определяются и атрибутами абзаца, к рассмотрению которых мы перейдем в следующей главе. Форматирование символов можно производить конкретно в том или ином отрывке текста, задавая атрибуты в описанных диалоговых окнах, но удобнее и быстрее определить их в качестве стиля абзаца. Сохранению атрибутов в стиле посвящена гл. 6.


  • Глава 5. Форматирование абзацев
    • Задание атрибутов абзаца в программе
    • Выключка строк
      • Применение разных типов выключки
      • Установка выключки текста
    • Задание значений интервалов
      • Размер пробелов
      • Величина межсимвольных интервалов
      • Интервалы в тексте с рваным краем
      • Установка автоматического кернинга
    • Перенос слов
      • Диалоговое окно Hyphenation
      • Расстановка переносов вручную
      • Расстановка переносов с помощью словаря
      • Алгоритм переноса
    • Настройка выключки
      • Атрибуты, управляющие длиной строк текста
      • Последовательность выполнения функций, влияющих на длину строк
      • Полная выключка
    • Позиции табуляции
      • Работа с линейкой табуляции
      • Позиции табуляции и тип выключки
      • Установка позиций табуляции для таблиц
      • Отточия
      • Позиции табуляции по умолчанию
    • Отступы
      • Установка отступов
      • Дополнение PageMaker для установки нумерации и перечней
      • Работа с отступами в меню и управляющей палитре
    • Распределение строк и абзацев по страницам
      • Разрыв строки
      • Распределение абзацев в окне Paragraph Specifications
      • Висячие строки
    • Оформление абзацев: отбивки и линейки
      • Задание отбивок до и после абзацев
      • Отбивки или красные строки?
      • Отбивки при верстке стихов
      • Оформление абзацев: линейки
    • Выбор метода интерлиньяжа
      • Три метода интерлиньяжа
      • Выбор метода интерлиньяжа
    • Резюме


ГЛАВА 5.

Форматирование абзацев

Абзац — следующая после символа единица форматирования. Кроме разбиения на смысловые единицы, абзацная разбивка структурирует текст, он становится более выразительным и легким для чтения. В настоящей главе рассматриваются следующие аспекты форматирования абзацев:

  • Абзац как основная единица форматирования текста в PageMaker.
  • Выключка текста на странице. Настройка межсимвольных интервалов при выключке.
  • Переносы. Разные методы переноса и настройка переносов.
  • Выравнивание текста с помощью табуляции. Позиции табуляции. Заполнители.
  • Установка абзацных отступов.
  • Управление размещением абзацев. Признаки разрыва колонок и страниц.
  • Висячие строки и их предотвращение.
  • Стратегия интерлиньяжа.

Абзац в PageMaker

Абзац — это основной элемент форматирования PageMaker. Для того чтобы получить статус абзаца, последовательность набранных символов должна заканчиваться особым служебным символом— признаком конца абзаца. Каждый раз, когда вы нажимаете на клавишу <Enter>, вы вводите в текст признак конца абзаца. При этом текущая строка обрывается и весь текст, лежащий справа от точки ввода символа конца, перемещается на новую строку. Если вы работаете в редакторе материалов, встроенном текстовом редакторе PageMaker (см. гл. 8), вы можете включить режим отображения признаков конца абзаца в диалоговом окне Preferences (Установки). Внешний вид текущей публикации в этом случае будет примерно таким, как на рис. 5.1. Обратите внимание на значки в конце каждого абзаца. Это и есть признаки конца абзаца.

Рис. 5.1. Вид окна редактора материалов в PageMaker

Абзац является минимальной структурной единицей, к которой могут быть применены такие атрибуты, как выключка (выравнивание текста по горизонтали), красная строка, метод расчета интерлиньяжа, установка позиций табуляции, управление переносами, линейки, отбивки и др. Атрибуты форматирования абзаца задаются для всего абзаца в целом. Рассмотренные же в предыдущей главе атрибуты форматирования символа (начертание, кегль или кернинг) можно задать для любого числа литер.

Примечание

В признаке конца абзаца хранятся все атрибуты его форматирования. Если скопировать признак конца одного абзаца в конец другого, последнему будут приданы все атрибуты форматирования первого, т. е. абзацы станут одинаковыми.


Задание атрибутов абзаца в программе

Атрибуты абзаца настраиваются стандартными методами — в специальном диалоговом окне Paragraph Specifications (Параметры абзаца), а также с использованием меню, управляющей палитры (рис. 5.2) и кнопок панели управления. Окно атрибутов абзаца (рис. 5.3) открывается командой Paragraph (Абзац) меню Туре (Текст) или контекстного меню, или комбинацией клавиш <Ctrl>+<M>, или щелчком на кнопке Paragraph,Specifications панели управления (на кнопке нарисован символ конца абзаца).

Рис. 5.2. Управляющая палитра в режиме Paragraph

Рис. 5.3. Диалоговое окно Paragraph Specifications

Некоторые наиболее часто изменяемые атрибуты задаются командами меню Туре (Текст). Большинство атрибутов можно модифицировать, используя управляющую палитру.

Для того чтобы получить доступ к нужным атрибутам, переведите палитру в режим Paragraph нажатием кнопки с изображением признака конца абзаца или комбинацией клавиш <Ctrl>+<Shift>+<'>. Наконец, некоторые команды, связанные с форматированием абзацев, выведены в виде кнопок управляющей панели.


Выключка строк

Выключкой строк называется характер размещения текста на странице. На рис. 5.4 приводятся варианты выключки текста по горизонтали, выполняемые PageMaker.

Подробнее типы выключки рассмотрены ниже. В скобках указывается соответствующая комбинация клавиш.

Выключка по левому краю (<Ctrl>+<Shift>+<L>). Массив текста выравнивается по левой границе колонки. Первые символы каждой строки выстраиваются в строго вертикальную линию. Последние символы в строке располагаются свободно, образуя "рваный правый край".

Выключка по правому краю (<Ctrl>+<Shift>+<P>). При таком расположении символы выравниваются по правому краю колонки и прижимаются к нему.

Такая выключка называется "рваный левый край", это как бы зеркальное отражение выключки по левому краю.

Рис. 5.4. Варианты выключки текста в PageMaker

Выключка по центру (<Ctrl>+<Shift>+<C>). Текст располагается в середине строки. PageMaker вычисляет общую ширину всех символов данной строки с учетом межсловных и межсимвольных интервалов, делит эту величину пополам и совмещает найденную середину строки со средней линией текстового блока.

Выключка по формату (<Ctrl>+<Shift>+<J>). Такое размещение текста сочетает в себе выключку по правому и левому краю. Крайние символы в правой и левой части строки располагаются по вертикальной линии, совмещенной с границами текстового блока, а текст строки равномерно распределяется между этими крайними точками, кроме последней строки абзаца, которая не растягивается по формату, а остается неизменной. При этом, разумеется, PageMaker вынужден увеличивать межсимвольные интервалы и особенно пробелы. В программе предусмотрен комплекс настроек размещения текста — управление размерами межсимвольных интервалов и пробелов при выключке по формату ии настройка переносов. С помощью настроек абзаца можно добиться равномерного размещения выключенного по формату текста, что невозможно или очень трудно при использовании текстового процессора.

Полная выключка (<Ctrl>+<Shift>+<F>). Все строки абзаца, включая последнюю, растягиваются по формату. При этом межбуквенные пробелы в отдельных строках могут возрасти до нескольких сантиметров.


Применение разных типов выключки

При наличии нескольких вариантов неизбежна проблема выбора. Какую выключку предпочесть для того или иного массива текста? Ниже дано несколько рекомендаций.

Выключки по левому краю и по формату обеспечивают наилучшую читаемость текста. Все остальные типы выключек снижают удобочитаемость. Выключки по центру, по формату и по правому краю украшают массив текста, однако пользоваться ими следует умеренно. Избегайте набирать таким способом длинные абзацы и текст мелкого кегля. Что толку от оригинальной публикации, если ее трудно прочесть? Кроме того, любая выключка, кроме левой и по формату, придает публикации претенциозность, не всегда соответствующую содержанию документа. Выключка по левому краю придает тексту неформальный вид, разные просветы в конце строк создают ощущение рукописи.

Текст, выключенный по формату, смотрится однородным и более темным. Ровные края колонки придают такой публикации строгий официальный вид. Сравнение читаемости текста с рваным правым краем и выровненного по формату затруднительно. Приверженцы форматирования по левому краю говорят о том, что рваный край строки создает естественные опорные точки, своеобразные "ступеньки" для глаза читающего, упрощая ориентацию. Их противники утверждают, что при таком расположении текста глаз каждый раз в конце строки сталкивается с неожиданностью (ведь каждая строка заканчивается в другом месте), что замедляет чтение. В тексте же, выключенном по формату, где есть ровная граница колонки, схема движения глаза упрощается. Текст, выключенный по левому краю, не требует профессионализма верстки, его трудно испортить. Основное требование к тексту с рваным краем — этот край не должен быть слишком уж рваным. В идеале все строки в массиве текста должны быть одинаковой длины. В реальной верстке так не бывает, тем не менее можно добиться минимальных отклонений в длине невыключенньгх строк. При ручном наборе (до появления компьютерных систем верстки) рваный край подгоняли вручную, перераспределением знаков на строке или вставкой переносов. В PageMaker ровного края добиваются экспериментированием с атрибутами переноса: в основном регулированием зоны переноса и, кроме того, установкой режимов переноса и вставкой дискреционных переносов. Об установках переноса рассказывается далее в настоящей главе.

Текст, выключенный по формату, более требователен к обработке. Во многих случаях при работе с текстом, выключенным по формату, необходима тонкая настройка интервалов для получения однородного массива. Если же выключенный по формату текст некачественно обработать, в нем образуются жидкие строки с огромными пробелами, что сильно затруднит чтение и будет раздражать глаз. Таким образом, на удобство чтения текста, выключенного по формату, оказывает сильное влияние квалификация верстальщика. Кроме того, на выбор того или иного варианта выключки должны влиять другие атрибуты форматирования — ширина колонки, отбивки до и после абзаца, кегль, гарнитура, интерлиньяж и пр. От всех этих параметров также в большой степени зависит, какой текст будет лучше читаться. Словом, в этом случае нужно поэкспериментировать, проверить разные варианты форматирования и их влияние на конечный результат.

Полная выключка в наборе не используется. Она применяется в крупных заголовках, плакатах, буклетах. Например, если набрать текст рубленым жирным шрифтом с применением разных кеглей, а потом растянуть получившийся абзац по формату, получится плакат в стиле "Окон РОСТа". Для его усиления можно раскрасить текст черным и красным цветом.


Установка выключки текста

Для установки выключки воспользуйтесь любым из нижеперечисленных способов.

  • В диалоговом окне Paragraph Specifications (см. рис. 5.3) выберите нужный тип выключки из раскрывающегося списка Alignment (Выключка) или введите его с клавиатуры.
  • Выберите пункт Alignment (Выключка) меню Туре (Текст). В открывшемся вложенном меню выберите тип выключки. Рядом с пунктами приведены комбинации клавиш для данного типа выключки (рис. 5.5).

Рис. 5.5. Тип выключки задается из вложенного списка Alignment меню Туре

  • Нажмите на кнопку с соответствующей пиктограммой в управляющей палитре. Кнопки, управляющие выключкой, расположены в нижней части палитры слева (рис. 5.6).

Рис. 5.6. Управляющая палитра в режиме Paragraph позволяет задать тип выключки

Работа в PageMaker с интервалами

Благодаря прекрасным возможностям настройки интервалов в программе вы сможете добиться идеальной выключки строк в публикациях, а в книжных изданиях это 90% уровня качества продукции. Ниже перечислены способы воздействия на длину строк, а следовательно, и на качество выключки строк.

Кернинг, ручной и автоматический. Аспекты кернинга обсуждаются в гл. 4, автоматический кернинг рассматривается и в разд. "Установка автоматического кернинга" данной главы.

Трекинг, о котором вы уже прочитали в гл. 4.

Ширина символов, ее установка и применение также были рассмотрены в гл. 4.

Межсловные и межсимвольные интервалы — основной инструмент регулирования выключки строк, рассмотрением которого мы займемся в следующем разделе.

Параметры переноса слов, которые также будут рассмотрены в соответствующем разделе данной главы.

Далее в разд. "Настройка выключки" настоящей главы все эти атрибуты подробно будут рассмотрены в табл. 5.1.

Упомянутые свойства текста взаимосвязаны, и изменение одного вызывает необходимость корректировки другого. Параметры выключки, интервалов и атрибуты форматирования абзаца входят в систему стилей PageMaker, используя которую вы легко добьетесь единообразия внутри публикации и на порядок увеличите темп работы (см. гл. 6).


Задание значений интервалов

Значения пробелов и межсимвольных интервалов регулируют плотность текста в PageMaker не только в тексте, выключенном по формату, но и в тексте, выровненном по левому или правому краю. Эти атрибуты задаются во вложенном окне Spacing Attributes (Интервалы) (рис. 5.7), открывающемся кнопкой Spacings (Интервалы) диалогового окна Paragraph Specifications (Параметры абзаца).

Рис. 5.7. Диалоговое окно Spacing Attributes


Размер пробелов

Величина пробела является таким же полноправным атрибутом гарнитуры, как и рисунок литеры. С помощью диалогового окна Spacing Attributes (Интервалы) можно воздействовать на ширину пробела в наборе. Как видно из рис. 5.7, в правой части диалогового окна задается величина Word space (Межсловные). Она определяется тремя значениями, которым соответствуют три строки ввода — Minimum (Минимум), Desired (Желаемые) и Maximum (Максимум). По умолчанию эти величины равны, соответственно, 75, 100 и 150% от стандартного пробела шрифта. Это значит, что при выключке строк PageMaker старается сохранить величину пробела стандартной, если же это невозможно, он сокращает пробел не более чем на 1/4 или увеличивает его не больше чем на 1/2 стандартной ширины. Таким образом, значения Minimum (Минимум) и Maximum (Максимум) задают границы диапазона, в которых ширина реального пробела может отличаться от идеальной, а величина Desired (Желаемые) как раз и определяет это идеальное значение.

Изменение значений межсловного интервала сильно влияет как на объем текстового блока, так и на внешний вид текста. Убедитесь в этом сами. Отформатируйте два одинаковых абзаца таким образом: первому придайте значения атрибутов Maximum (Максимум), Desired (Желаемые) и Minimum (Минимум), соответственно, 50/75/100%, а второму — 100/125/200%. Результат будет примерно таким, как показано на рис. 5.8.

Примечание

Случается, что выполнить корректировку межсимвольных интервалов в данной строке просто невозможно. Так, бывает, если в тексте много длинных терминов, которых нет в словаре переносов (например, статься, посвященная свойствам этилендиаминтетрауксусной кислоты). Сложности с выключкой возникают и в случае выбора слишком крупного кегля для данной полосы набора. Наткнувшись на проблемный участок, PageMaker выполняет выключку как может — при этом интервалы могут стать безобразно большими (жидкая строка)!'-В диалоговом окне Preferences (Установки) в группе Layout problems (Выделять подсветкой) имеется флажок Show loose/tight lines (Жидкие/плотные строки). Если его включить, то проблемные участки текста будут выделены серой или желтой (в зависимости от типа монитора) подсветкой. Теперь вам достаточно одного взгляда на макет, чтобы оценить, где нужно подправить интервалы для повышения качества верстки. Напомним, что диалоговое окно Preferences (Установки) можно вызвать из меню File (Файл) командой Preferences (Установки) и далее из вложенного меню командой General (Основные) или комбинацией клавиш <Ctrl>+<K> (см. также гл. 3).

а

б

Рис. 5.8. Влияние атрибутов межсловного интервала на внешний вид абзаца (режим переноса и кернинг отключены)


Величина межсимвольных интервалов

При разработке шрифта, кроме рисунка литеры и диапазона пробела, задается и межсимвольное расстояние. Оно регулируется величиной оптического поля буквы. Оптическое поле состоит из ширины собственно символа и боковых просветов, примыкающих в нему (полуапрошей). Межсимвольное расстояние складывается, таким образом, из двух полуапрошей соседних букв.

Межсимвольные интервалы также задаются в диалоговом окне Spacing Attributes (Интервалы) (см. рис. 5.7), открывающемся кнопкой Spacings (Интервалы) диалогового окна Paragraph Specifications (Параметры абзаца). По умолчанию значения, управляющие межсимвольными интервалами, равны: Minimum (Минимум) -5%, Desired (Желаемые) 0%, Maximum (Максимум) 25%. Это значит, что в процессе выключки PageMaker старается выдержать стандартный межсимвольный интервал, а если это невозможно, то увеличивать его не более чем на 25% или уменьшать не более чем на 5%. Установки межсимвольного интервала можно изменять в зависимости от требований к конкретной публикации. Многие специалисты вообще советуют проставлять во всех трех строках ввода нулевые значения, в этом случае межсимвольный просвет будет жестко выдерживаться стандартным. Считается, что отступления от идеальной величины в межсимвольных расстояниях искажают оптическое поле литер и приводят к порче внешнего вида текста. Так это или нет — проверьте сами, подобные аспекты верстки — вещь субъективная. Влияние межсимвольного расстояния на внешний вид строки и объем, занимаемый текстом, довольно значительно (рис. 5.9). В первом отрывке задано межсимвольное расстояние -10/-5/0, во втором — 0/5/10.

Рис. 5.9. Влияние атрибутов межсимвольного расстояния на внешний вид и объем текста (автоматический кернинг, режим переносов отключен)


Интервалы в тексте с рваным краем

Значения Minimum (Минимум) и Maximum (Максимум) не влияют на внешний вид текста, не выключенного по формату, в нем все промежутки имеют стандартную ширину. Но атрибут Desired (Желаемые) регулирует значение как раз этой идеальной ширины межсимвольны-х и межсловных интервалов. Таким образом, для увеличения межсловного интервала в тексте нужно ввести в поле Desired (Желаемые) области Word space (Межсловные) число больше 100%, а для увеличения межсимвольного промежутка — ввести в поле Desired (Желаемые) области Letter space (Межбуквенные) число больше 0%. С помощью атрибута Desired (Желаемые) можно также регулировать объем, занимаемый текстом, как и с помощью трекинга, автоматического кернинга и регулировки ширины символов.


Установка автоматического кернинга

Внутри каждой гарнитуры имеется таблица кернинга, включающая десятки, сотни, а иногда и тысячи кернинговых пар. Изготовитель шрифта при этом рассчитывает, что программное средство, в котором будет применяться его детище, сможет обратиться к этой таблице и использовать ее для повышения качества набора. В случае текстовых процессоров данные о кернинге не используются. PageMaker же обладает великолепными возможностями в области автоматического кернинга, и при его осуществлении пользуется именно материалами таблиц кернинга. Правда, это происходит не всегда, а только при включенном флажке Pair kerning (Кернинг пар) вложенного диалогового окна Spacing Attributes (Интервалы).

На автоматический кернинг, разумеется, уходят ресурсы, и немалые. С другой стороны, при тексте мелкого кегля межбуквенные просветы становятся такими маленькими, что влияния кернинга не видно. В том же диалоговом окне Spacing Attributes (Интервалы) можно задать наименьший кегль, при котором выполняется автоматический кернинг пар. Данное значение задается в строке ввода Auto above ... points (свыше ... пунктов). По умолчанию это число равно 4 пунктам. Рекомендуем вам таким его и оставить.

Еще раз обратим ваше внимание на разницу между регулировкой межсимвольных расстояний и кернингом. Кернинг выполняется для улучшения зрительного восприятия пар символов, только в этих парах. Атрибуты межсимвольных расстояний в окне Spacing Attributes (Интервалы) меняются для всех символов данного абзаца одинаково, при этом их сочетаемость не рассматривается.


Перенос слов

В PageMaker можно выбрать метод переноса слов и настроить значения атрибутов переноса. Метод определяет, какую часть работы по переносу слов вы доверяете PageMaker, а что хотите сделать вручную. Настройки переноса определяют вид макета.


Диалоговое окно Hyphenation

Для управления переносами слов в PageMaker существует диалоговое окно Hyphenation (Перенос), приведенное на рис. 5.10. Оно открывается одноименной командой меню Туре (Текст). Ниже приведен список элементов управления этого окна.

Рис. 5.10. Диалоговое окно Hyphenation

  • Hyphenation: On/Off (Перенос: Да/Нет). С помощью этого переключателя включается и выключается режим разрешения переноса. Если переключатель поставлен в положение On (Да), PageMaker может переносить cлова. Если же этот переключатель находится в положении Off (Нет), переноса слов не происходит, причем запрет распространяется как на автоматические переносы, выполняемые с помощью словаря или соответствующего алгоритма, так и на мягкие (дискреционные) переносы, проставляемые вручную.

Примечание

Дискреционные переносы, в отличие от жестких, проставляемых знаком дефиса, видны, только если находятся в конце строки. Если слово, в котором есть мягкий перенос, попадает при переверстке в середину строки, оно, разумеется, никуда не переносится, и дискреционный перенос в нем не виден. Дискреционные переносы подробно рассматриваются ниже в настоящем разделе.

  • Manual only (Ручной). В этом режиме PageMaker выполняет только ручные (дискреционные) переносы, автоматический перенос при этом не осуществляется.
  • Manual plus dictionary (Ручной плюс словарь). Кроме ручных переносов, происходят и автоматические. Точки переноса в этом случае PageMaker выбирает в соответствии со встроенным словарем переносов.
  • Manual plus algorithm (Ручной плюс алгоритм). Если поставить этот режим, то в дополнение к дискреционным переносам и переносам по словарю PageMaker будет пытаться применить поиск допустимого переноса к тем словам, которых нет в словаре.
  • Limit consecutive hyphens to (Подряд не более). Если в текстовом блоке имеется несколько переносов подряд, один под другим, это выглядит некрасиво. Можно задать число подряд идущих строк, заканчивающихся знаком переноса. Это может быть число от 1 до 255. Если проблема "лестницы" (так называются переносы в смежных строках, действительно похожие на вертикальные пожарные лестницы) для вас неважна, можно поставить значение No limit (Без ограничений).
  • Hyphenation zone (Зона переноса). Правильнее, наверное, назвать этот атрибут "зоной запрета переноса". Так называется вертикальная полоса, примыкающая к правой границе колонки. Если слово находится левее зоны переноса, оно не переносится. Если часть слова попадает в эту зону, происходит перенос. Если слово целиком находится в зоне переноса, оно полностью переходит на следующую строку. Этот атрибут работает только в абзацах с рваным краем, в случае выключки по формату зона переноса не действует. На рис. 5.11 представлено влияние зоны переноса на длину строки. Все остальные атрибуты в этом абзаце одинаковые. В первом фрагменте установлена зона переноса 1 мм, во втором — 7 мм (возможна ширина зоны переноса от 0 до 12,7 мм с шагом 0,1 мм). Как видите, край в первом случае более ровный, чем во втором. Если задать зону переноса слишком узкой, PageMaker придется часто переносить слова, в этом случае на соседних строчках образуется "лестница".

Рис. 5.11. Влияние зоны переноса на длину строк и вид рваного края текста

Перенос действует на длину строки. PageMaker всегда предполагает, что вам хочется сделать все строки в абзаце одинаковыми по длине. Поэтому, чтобы добиться специального эффекта в размещении строк, нужно прибегать к различным хитростям.


Расстановка переносов вручную

Если вы не доверяете программе PageMaker автоматическую расстановку переносов, вам придется проделать это самим, для чего включите режим разрешения переноса Hyphenation: On (Перенос: Да) и поставьте переключатель методов переноса в положение Manual only (Ручной).

Основным инструментом при ручном переносе слов является дискреционный, или мягкий перенос. Это специальный символ, имеющий вид дефиса и вставляемый с помощью комбинации клавиш <Ctrl>+<Shift>+<->. Если слово выходит за границу текстового блока и в нем есть дискреционный перенос, оно будет перенесено в соответствующем месте. Если дискреционного переноса нет, слово будет целиком помещено на следующей строке. Дискреционные переносы имеют приоритет перед переносами по словарю и алгоритму. Если приходится редактировать строку, изменять ширину зоны переноса или текстового блока (после расстановки переносов это нежелательно), то слово, в котором есть позиции мягкого переноса, может сместиться и выйти из зоны переноса. В таком случае мягкий перенос перестает быть виден. Если слово опять переместится таким образом, что его необходимо будет переносить, мы снова увидим этот знак переноса.

Примечание

Если разбить слово обычным дефисом (минусом), видимый результат будет таким же. Но, к сожалению, очень часто приходится переверстывать уже готовый текст. При этом, разумеется, позиции переноса сместятся. В отличие от мягких переносов дефисы никуда не денутся, а будут разбросаны по всему тексту как раздражающие опечатки, и от них придется избавляться.

Можно запретить перенос того или иного слова с помощью мягкого переноса. Введите знак мягкого переноса перед нужным словом без пробела.

Внешний вид текста не изменился, но данное слово теперь не будет переноситься ни при каком методе переноса.

Если PageMaker поставил перенос в неудачном месте, можно отменить именно этот конкретный перенос, для чего установите точку вставки перед переносом и введите мягкий перенос. PageMaker запретит перенос данного слова в этом месте и, если это возможно, найдет для него другую позицию переноса.

Примечание

Запретить перенос слова или группы слов можно и с помощью атрибута No Break (На одной строке) раскрывающегося списка Line end (Символы) диалогового окна Character Specifications (Параметры шрифта) (см. рис. 4.4). Таким образом можно предотвратить разбиение слова или группы слов в конце данной строки. Об атрибуте No Break (На одной строке) читайте в гл. 4.


Расстановка переносов с помощью словаря

В этом случае PageMaker пользуется встроенным в него словарем переносов. Изначально это неспециализированный словарь, используемый как при переносе слов, так и для автоматической проверки орфографии. Если вы обнаружили, что PageMaker не знает какого-либо слова (это видно по отсутствию необходимых переносов такого слова), а оно в вашем тексте встречается часто, можно добавить его в словарь. Это полезно и потому, что PageMaker использует такие данные впоследствии и для проверки орфографии. Соответствующее диалоговое окно открывается кнопкой Add (Добавить) в окне Hyphenation (Перенос). Щелкнув на этой кнопке, вы увидите диалоговое окно, представленное на рис. 5.12.

Рис. 5.12. Диалоговое окно добавления слова в словарь пользователя

При внесении слова в словарь вы можете указать в нем возможные переносы и расположить их по степени желательности. Место переноса обозначается знаком тильды (~). Одной тильдой обозначаются наиболее приемлемые переносы, двумя — менее желательные и т. д. Таким образом, если слово необходимо перенести, PageMaker сначала попробует сделать это в позиции одной тильды, затем — двух, потом уже — в точке вставки трех тильд.

Для удобства работы можно перед открытием окна выделить в тексте нужное слово. Тогда оно сразу появится в строке ввода, причем с точками возможных переносов. Разумеется, можно вводить слова и точки переноса непосредственно и, клавиатуры. Бывает, что в словаре имеются неправильные переносы. Их можно изменить. Для этого в строке ввода введите нужное слово с корректными точками переноса. После запроса PageMaker запишет его поверх старого варианта. Обратите внимание на правописание слов, заносимых в словарь! Проверьте его лишний раз, иначе в словаре появится неграмотное слово и придется редактировать словарь специальной программой. Об этой программе (редакторе словарей) подробно рассказывается в гл. 8.

С помощью словаря переносов можно запретить перенос какого-либо слова вообще в любом месте текста. Для этого в строке ввода наберите данное слово с единственным знаком тильды перед первым символом слова. Теперь в любом тексте, использующем настоящий словарь, это слово не будет переноситься.

В PageMaker существует возможность работать с несколькими словарями в пределах одной публикации. Теоретически возможно для каждого абзаца использовать свой словарь. Это очень полезная функция. Вы сможете пользоваться различными словарями, например для редактирования текста с чередованием абзацев на разных языках. Также можно себе представить, скажем, научно-популярную книгу, в которой фрагменты, написанные литературным языком, чередуются с сугубо специальными. Выбрать нужный словарь можно в раскрывающемся списке Dictionary (Словарь) диалогового окна Paragraph Specifications (Параметры абзаца) (рис. 5.3). О составлении пользовательских словарей см. гл. 8.


Алгоритм переноса

Метод переноса по алгоритму сокращает время верстки, улучшая внешний вид публикации без дополнительной ручной настройки. PageMaker в дополнение к словарным переносам при необходимости разбивает переносами отсутствующие в словаре слова, руководствуясь встроенной программой разбиения слов. Однако, на взгляд авторов, алгоритм переносов в программе недостаточно корректен и содержит потенциальную возможность ошибки. Его использование оправдано для поиска возможных точек переноса. Например, если вам не удается разместить текст абзаца, включите перенос по алгоритму, и PageMaker покажет вам варианты переноса, улучшающие структуру абзаца, которых вы, возможно, не заметили.


Настройка выключки

Каждый верстальщик мечтает о публикации, в которой текст сам ложится ровными красивыми строчками на заданные участки, образуя элегантные колонки именно той длины, какую он задумал. К сожалению, в реальной жизни все не так и помещенный в публикацию текст, как правило, нуждается в настройке.


Атрибуты, управляющие длиной строк текста

В табл. 5.1 перечислены атрибуты форматирования, которые оказывают влияние на длину строк, и указан вид такого воздействия.

Таблица 5.1. Функции PageMaker, влияющие на длину строк

Функция | Область задания атрибута | Воздействие на длину строк
Регулировка ширины символов | Символы | Не меняет межсимвольные интервалы. Изменяет ширину символов, за счет чего меняется длина строки
Трекинг | Символы | Меняет значения межсимвольных интервалов для всех символов текста. Значение полученных интервалов зависит от режима трекинга и кегля текста
Ручной кернинг | Символы | Изменяет межсимвольные расстояния в парах или последовательностях выделенных символов
Автоматический кернинг | Абзац | Корректирует интервалы между кер-нинговыми парами шрифта
Регулировка межсловных пробелов | Абзац | Меняет величину пробелов. Величина желаемого пробела учитывается при любой выключке строк, кроме полной, значения максимального и минимального пробелов действуют только для текста с выключкой по формату
Регулировка межсимвольных интервалов | Абзац | Увеличивает или уменьшает межсимвольные расстояния, полученные в результате кернинга, трекинга и др. Значение желаемого интервала действует при любой выключке, величина максимального и минимального — только при выключке по формату
Перенос | Абзац | Разбивает слова для дополнительного выравнивания строк. Зона переноса имеет смысл только для абзацев с рваным краем

Как видно из этой таблицы, все перечисленные атрибуты тесно взаимосвязаны.


Последовательность выполнения функций, влияющих на длину строк

  1. Выполняя ваши пожелания относительно ширины и значений интервалов, а также осуществляя перенос слов при формировании блока текста, PageMaker придерживается строгой последовательности: в первую очередь выполняются автоматический кернинг, трекинг, ручной кернинг, изменение ширины символов.
  2. В соответствии со значениями, заданными в первом шаге, строка заполняется символами до тех пор, пока последнее слово не выйдет за границу текстового блока. В этом слове отыскиваются переносы (мягкие, словарные или найденные по алгоритму), причем как справа, так и слева от границы текстового блока. Затем временно отключается режим переносов.
  3. Пробелы уменьшаются, с целью втолкнуть последнее слово в строку целиком. Значение пробела меняется от стандартного до минимального. PageMaker уменьшает пробелы постепенно, малыми шагами, прекращая их уменьшение, как только будет достигнут результат — последнее слово поместится в строке. Если же этого не происходит, интервалы уменьшаются до заданного минимума.
  4. Если проблемное слово все равно не помещается, пробелы начинают увеличиваться постепенно, малыми приращениями, в диапазоне от стандартного до максимального, для того чтобы вытолкнуть последнее слово из строки.
  5. Если и это не помогает, то PageMaker восстанавливает режим переносов и начинает воздействовать на интервалы между словами с учетом возможных точек переноса.
  6. Во втором шаге для крайнего слова были найдены две позиции переноса — слева от границы текстового блока (внутри полосы) и справа (за пределами полосы). В последующих шагах PageMaker пытается использовать эти значения: пробелы сокращаются до минимума, чтобы вдавить часть слова, оставшуюся на строке после переноса и находящуюся правее границы текстового блока.
  7. Если это невозможно, выполняется следующий шаг: пробелы постепенно увеличиваются для переноса проблемного слова слева от границы текстового блока (т. е. внутри полосы).
  8. Если и эта мера неэффективна, PageMaker повторяет предыдущие два шага, при этом выполняя корректировку межсимвольных интервалов в дополнение к межсловным.
  9. И наконец, если ничего не помогло, проблемное слово помещается на следующую строку, а оставшиеся слова располагаются с максимальными межсимвольными интервалами. При необходимости межсловный интервал возрастает сверх заданного максимального значения. Таким образом, получается жидкая строка (рис. 5.13).

PageMaker почти никогда не нарушает ограничения на минимальные межсловные и межсимвольные интервалы. Единственное исключение — если в строке есть последовательность символов, отформатированная с запретом разбиения, а длина ее превышает ширину колонки, межсимвольное расстояние может стать меньше заданного минимального. Строка при таком форматировании может принять некорректный вид (рис. 5.13) — это плотная строка.

Рис. 5.13. Жидкая строка. Плотная строка

Если форматирование закончилось фиаско, PageMaker отмечает жидкие и плотные строки серым (или желтым, в зависимости от типа монитора) цветом.

Вот как быстро работает PageMaker! Он выполняет эту последовательность действий на много порядков быстрее, чем вы о ней прочитали.

Рецепт. Последовательность задания значений атрибутов выключки

Когда вы начинаете работу над новой публикацией, особенно если речь идет о крупном проекте, не пожалейте времени на эксперименты с выключкой. Стороннему наблюдателю ваши занятия наверняка покажутся игрой. Но лучше пусть сегодня начальник вскользь заявит вам, что вы бездельник, чем через месяц придирчивый клиент откажется от тиража, недовольный внешним видом своего рекламного буклета. Удачно заданные межсловные и межсимвольные интервалы окажут огромное положительное влияние на качество макета и удобство работы с ним. Некачественный подбор интервалов может повлечь за собой жуткий процесс — переверстку уже готовой публи-

кации. В настоящем разделе приведен пример работы по настройке интервалов. Руководствуясь данным рецептом, вы можете добиться во многих случаях вполне удовлетворительных результатов.

  1. Перед началом работы по выключке примите решение относительно основных элементов форматирования, как то ширина колонок, кегли набора, гарнитуры. Все эти параметры оказывают решающее влияние на размещение текста, и без их точного определения работа по настройке выключки не имеет смысла. Разумеется, все эти параметры могут измениться (хотя коренные изменения крайне нежелательны). В данном случае вы будете использовать сочетание основных атрибутов форматирования как некую отправную точку.
  2. Когда все основные параметры текста определены, можно приступать к пробной верстке. Выберите пробный текстовый материал, на котором вы будете проводить эксперименты. Этот блок текста должен быть достаточно длинным (примерно 170—200 слов). Характер текста в пробном материале должен быть таким же, как и в настоящей публикации. Особенно это касается длины слов, она оказывает огромное влияние на выключку. Если вы верстаете статью для популярного журнала, слова в ней будут наверняка короче, чем в научной статье такой же длины. Когда материал выбран, импортируйте его в PageMaker. Об импорте текстовых файлов см. гл. 7.
  3. Задайте начальные условия. Перед настройкой выключки приведите текст в исходный вид, т. е. отключите все атрибуты, влияющие на длину строк, или задайте им стандартные значения:
    • установите стандартную ширину символов и автоматический кернинг для кеглей крупнее 4 пунктов;
    • поставьте переключатель трекинга в положение No track (Без трекин-га) (не Normal (Нормальный), т. к. это тоже тип трекинга);
    • отключите функцию корректировки пробелов Word space (Межсловные), задав во всех трех полях значение 100%;
    • отключите таким же образом функцию корректировки межсимвольных интервалов Letter space (Межсимвольные), проставив везде 0%;
    • отключите режим переноса.
  4. Затем задайте полученному тексту нужный тип выключки и сделайте там, где нужно, абзацные отступы.

В результате всех этих манипуляций ваш текст приобретет примерно следующий вид (рис. 5.14).

Обратите внимание, что при таком форматировании текст выглядит чересчур свободным, или, как говорят полиграфисты, жидким. В данном примере использована гарнитура Times New Roman 12 кегля на полосе набора шириной 3,5 дюйма.

Рис. 5.14. Текст без настройки интервалов

  5. Настройте переносы и интервалы. Это самая важная часть работы. Чем свободнее PageMaker сможет переносить слова, тем легче выдерживать желаемую величину интервалов. С другой стороны, если заданы излишне жесткие рамки для интервалов, не обойтись без формирования "лестниц".

При настройке важно сбалансировать межсловные и межсимвольные интервалы. На рис. 5.15 представлены два варианта форматирования фрагмента текста. В первом из них текст плотный, в другом — более свободный.

а

б

Рис. 5.15. Два варианта форматирования текста с использованием разных значений атрибутов пробелов и переносов

Рассмотрим первый пример. В нем заданы значения межсимвольных интервалов -15/0/0% и межсловных интервалов— 65/100/110%. В диалоговом окне, управляющем переносом, задано количество переносов в смежных строках — не более трех. Это неизбежно, при таких жестких пробелах обязательно появятся "лестницы". Ограничение смежных переносов до трех вполне допустимо. Подобные "лестницы" встречаются практически в любой книге. Таким образом, жесткие ограничения интервалов дают темный плотный текст. Данный вариант форматирования дает большую экономию места и может использоваться для вгона строк.

Во втором примере запрещены смежные переносы, атрибуты межсловных интервалов равны 85/100/125%, а межсимвольных — 0/0/5%. За счет более свободного интервала значений достигается качественное межсимвольное расстояние и отсутствие смежных переносов. Объем текста при этом вырастает по сравнению с первым вариантом, но текст при этом читается легче.

Оба варианта форматирования далеки от идеала, тем не менее они дают представление о диапазоне возможностей рассмотренных инструментов.


Полная выключка

Полную выключку называют принудительной. При выборе такого варианта форматирования отключаются перенос и все атрибуты управления длиной строки. Затем ширина текстового блока делится на количество символов в строке, а эти символы равномерно распределяются по длине строки, причем большая часть избыточных интервалов добавляется к межсловным расстояниям. В результате первая буква строки выравнивается по левому, а последняя — по правому краю колонки (даже в том случае, если в строке всего две буквы), а остальные распределяются между ними. Читать такой текст трудно, и как уже было сказано, полная выключка используется для сильных спецэффектов. Пример такого текста представлен на рис. 5.16. В нем для усиления эффекта между символами вставлялись пробелы шириной в половину круглой шпации, а затем такие же пробелы были вставлены между точками (графическими символами перечня) и словами.

Рис. 5.16. Применение полной выключки при оформлении заголовка


Позиции табуляции

Задание позиций табуляции и отступов широко используется в PageMaker. С их помощью можно выполнять форматирование небольших таблиц. Для этого нужно задать позиции табуляции первой строке таблицы, после чего вводимые данные будут распределяться по аккуратным колонкам. Оформление абзацных отступов с помощью задания позиций табуляции упрощается, появляются новые возможности, такие как задание нестандартных отступов, в том числе висячих. Кроме того, абзацный отступ, в отличие от позиции табуляции, которую нужно вставлять каждый раз в начале абзаца, можно проставить один раз, после чего каждый следующий абзац будет отформатирован соответствующим образом. Основной инструмент для задания позиций табуляции — линейка табуляции.

Примечание

Система табуляции PageMaker применима для форматирования текстов и для создания очень простых таблиц. Не стоит пытаться создавать в этой программе сложные таблицы, скажем хронологические. Причина проста: в PageMaker, как и в большинстве программ, работающих с текстами, основным структурным элементом является строка. Таким образом, в нем невозможно выделить столбец символов шириной меньше строки. В то же время при форматировании таблицы естественный структурный элемент — это ячейка.

PageMaker комплектуется небольшим редактором таблиц Table Editor, довольно .удобным, но, к сожалению, рассчитанным на таблицу размером не более одной страницы. Работа со встроенным табличным редактором описана в гл. 16. Если же вашей задачей является построение больших, многостраничных таблиц, лучше воспользоваться специальным приложением. Таблицу, сделанную в том или ином приложении, можно затем импортировать в готовую публикацию. Способы импорта описаны в гл. 7 и 16.


Работа с линейкой табуляции

Определим два термина для характеристики табуляции. Первый — это символ табуляции, или табулятор. Табулятор вставляется в текст с помощью клавиши <Таb>. В окне редактора материалов (см. гл. 17) этот символ можно увидеть так же, как признак конца абзаца. Положение, в которое помещается текст при нажатии клавиши <Таb>, — это позиция табуляции (табулостоп). По умолчанию PageMaker расставляет табулостопы по всей ширине полосы набора, на равном расстоянии друг от друга (примерно 0,5 дюйма). Это значит, что при каждом вводе символа табуляции следующие за ним символы будут смещаться на это расстояние. Позиции табуляции можно свободно менять. Во-первых, можно задать по умолчанию иное размещение позиций табуляции. Во-вторых, можно смещать позиции табуляции для уже имеющегося абзаца или группы абзацев.

Кроме табуляции, на размещение текста в строках оказывают влияние отступы. Отступ — атрибут абзаца. Если в абзаце есть отступ слева, но начало каждой строки смещено относительно границы текстового блока, отступ справа смещает конец каждой строки. Смещение первой строки абзаца, служащее для оформления красной строки, в PageMaker носит название абзацного отступа. Величину отступов также можно произвольно менять.

Окно Indents/Tabs (Отступы/Табуляция), служащее для управления величиной отступов и позициями табуляции, открывают командой Indents/Tabs (Отступы/Табуляция) из меню Туре (Текст), комбинацией клавиш <Ctrl>+ +<!> или щелчком на кнопке с изображением табулятора на панели управления. Это диалоговое окно представляет собой линейку с делениями и очень похоже на соответствующий инструмент текстового процессора (рис. 5.17). При его вызове PageMaker пытается совместить нулевое значение на линейке с левым краем колонки, если он есть на экране в момент выбора команды. Разметка линейки производится с учетом коэффициента увеличения отображаемой страницы на момент вызова диалогового окна.

Рис. 5.17. Диалоговое окно Indents/Tabs

К сожалению, это окно модально, и его придется вызывать каждый раз, когда потребуется редактировать позицию табуляции.


Позиции табуляции и тип выключки

Рассмотрим устройство диалогового окна табуляции. Маленькие треугольники, располагающиеся на равном расстоянии друг от друга вдоль линейки, отмечают положение позиций табуляции по умолчанию. В левой части окна расположено четыре кнопки со стрелками. Они определяют режим выравнивания по позиции табуляции. На каждой из этих кнопок нарисована стрелка, вид которой соответствует типу выравнивания. Соответствие переключателей и вариантов форматирования позиции табуляции приведено на рис. 5.18. Щелкните на одной из кнопок, определив тип выравнивания будущей позиции.

Рис. 5.18. Варианты форматирования позиций табуляции и соответствующие им переключатели

После выбора типа табуляции щелкните мышью в том месте линейки, где вы задумали установить позицию табуляции. В этой точке появится маркер соответствующего вида, обозначающий положение новой позиции табуляции. Откорректировать его положение можно перетаскиванием мыши вдоль линейки. Когда вы устанавливаете маркер, позиции табуляции по умолчанию, слева от него пропадают.

Если вы не любите работать мышью или для вашей публикации необходима точность размещения табулостопа, то значение позиции табуляции можно ввести с клавиатуры в строке ввода Position (Позиция). Для этого введите координату новой позиции табуляции в поле Position (Позиция), а затем щелкните мышью на кнопке Position (Позиция). Откроется список, в котором выберите строку Add tab (Добавить). Если маркер уже установлен на линейке и требуется его передвинуть, выделите маркер щелчком мыши, затем введите в поле Position (Позиция) нужную координату и, щелкнув на кнопке Position (Позиция), выберите из списка Move tab (Сдвинуть).

Если вы неудачно установили маркер, проще всего мышью оттащить его вниз или вверх от линейки, после чего он исчезнет. Для удаления маркера используют и поле Position (Позиция). Выберите ненужный маркер, затем щелкните на кнопке Position (Позиция) и выберите из списка строку Delete tab (Удалить).

Для того чтобы отменить все установленные маркеры, щелкните на кнопке Reset (Восстановить) для восстановления позиций табуляции по умолчанию.

PageMaker позволяет проставить позиции табуляции с равным интервалом с высокой степенью точности. В одном абзаце можно задать до 40 позиций табуляции. Для расстановки повторяющихся позиций табуляции выберите первый маркер, который будет использоваться в качестве точки отсчета. Отрегулируйте его точное положение с помощью команды Move tab (Сдвинуть) из списка, открывающегося при нажатии кнопки Position (Позиция). Затем выберите в списке Position (Позиция) вариант Repeat tab (Повторить). Маркеры позиций табуляции будут расставлены вдоль всей полосы набора с шагом, заданным для первой позиции табуляции.

Любое изменение в позициях табуляции вступает в силу только после нажатия кнопки ОК или Apply (Контроль). Если нажать кнопку ОК, диалоговое окно установки табуляции закроется, а к данному фрагменту текста будут применены измененные значения позиций табуляции. Если же нажать Apply (Контроль), текст будет отформатирован в соответствии с установленными значениями табуляции, но при этом окно Indents/Tabs (Отступы/Табуляция) останется открытым. Наличие кнопки Apply (Контроль) очень удобно для проверки разных вариантов расстановки позиций табуляции, например при форматировании таблиц. Заметьте, однако, что если вы нажали кнопку Apply (Контроль), но потом закрыли диалоговое окно кнопкой Cancel (Отменить), то редактирование позиций табуляций не произойдет.


Установка позиций табуляции для таблиц

Если вы верстаете таблицы, состоящие из нескольких строк, то, разумеется, что для всей таблицы позиции табуляции должны быть одинаковыми. В противном случае не удастся добиться аккуратных колонок данных. Осуществить задание позиций табуляции в этом случае можно разными способами. П Первый из них наиболее прямолинеен. Он состоит в выделении всей таблицы и последующей регулировке позиций табуляции. Время от времени для контроля результатов нажимайте кнопку Apply (Контроль). Когда все данные расположились оптимальным образом, нажмите кнопку ОК, и таблица готова.

  • Более элегантным способом является задание позиций табуляции для стиля абзаца и последующее форматирование таблицы этим стилем (см. гл. 6).
  • Можно оформить таблицу с помощью приема расстановки по образцу. Для этого расставьте позиции табуляции для первой строки таблицы, уточнив их типы и позиции. Затем закройте окно Indents/Tabs (Отступы/Табуляция). После этого выделите все строки таблицы, начиная с первой, и откройте окно Indents/Tabs (Отступы/Табуляция). Позиции в окне будут теми, которые вы устанавливали для первой строки. Щелкните на кнопке ОК. Позиции табуляции, заданные для первой строки выделенной таблицы, автоматически перейдут на остальные строки таблицы. П Иногда можно отформатировать некоторые строки таблицы как один абзац. Для этого в конце каждой строки ставится не символ абзаца, а признак перехода на новую строку (принудительный перенос строки). Клавиатурное сокращение для него — <Shift>+<Enter>. Этот прием удобен, если строки таблицы разделяются линейками или в разных столбцах таблицы насчитывается разное количество строк. О форматировании таблиц и бланков см. также гл. 16.
  • Если же вам нужно отформатировать сложную или длинную таблицу, не рекомендуется пользоваться для этого установкой позиций табуляции. Просто создайте таблицу в специальном редакторе электронных таблиц или в подходящем для этой цели текстовом процессоре. Не забывайте и о том, что в PageMaker последующий абзац наследует атрибуты предыдущего. Если вы набираете таблицу внутри PageMaker, отформатируйте позиции табуляции после ввода первой строки. Последующие вновь набираемые абзацы — строки таблицы сохранят установленные позиции табуляции. Если же при наборе ширина последующих абзацев оказалась больше запланированной, необходимо провести некоторую корректировку. Если форматирование таблицы выполняется при помощи стиля, это упрощает любые видоизменения.


Отточия

В некоторых документах типа перечня (оглавления, списки товаров и услуг и пр.) между столбцами таблицы оставлен большой пробел. Для удобства чтения таких документов используются отточия. Примеры отточий представлены на рис. 5.19.

Рис. 5.19. Примеры отточий

Для того чтобы выбрать отточие, перейдите в диалоговое окно Indents/Tabs (Отступы/Табуляция), выберите маркер позиции табуляции, к которой будет вести отточие. Затем выберите кнопку Leader (Отточие) в левой части диалогового окна. В раскрывающемся списке можно выбрать вариант отточия из предложенных стандартных. Можно сформировать заказное отточие. Для этого выберите из списка пункт Custom (Заказное), а затем введите вид отточия в строке ввода рядом с кнопкой Leader (Отточие). Заказное отточие может состоять из одного или двух символов, например точки и пробела.

Рассмотрим, как сделаны отточия в приведенном примере. В первой строке задано стандартное отточие — точка. Во второй строке аналогичное отточие сделано символами более мелкого кегля и выглядит более изящно. Для того чтобы достичь такого эффекта, введите после последнего символа перед отточием тонкий пробел (<Shift>+<Ctrl>+<T>) и отформатируйте его меньшим кеглем. В данном случае кегль текста — 14, а для пробела выбран 9 кегль. Затем задайте отточие, оно примет атрибуты последнего символа.

В России при составлении оглавлений принято пользоваться отточиями с более редким расположением точек, примерно такими, как в третьей строке примера. Такого эффекта можно достичь, используя заказное отточие. Введите и отформатируйте пробел как в предыдущем варианте, затем перейдите в диалоговое окно Indents/Tabs (Отступы/Табуляция) и задайте в строке ввода рядом с кнопкой Leader (Отточие) сочетание "точка+пробел". Нажмите кнопку Apply (Контроль) и проконтролируйте вид отточия.

Кроме обычных, можно вводить и графические отточия, например, такое, как на рис. 5.19, в четвертой строчке. Введите и отформатируйте тонкий пробел нужным кеглем (необязательно меньшим, в данном случае кегль набора 14, а отточие набрано 16 кеглем). Затем задайте для тонкого пробела гарнитуру Windings. Войдите в диалоговое окно Indents/Tabs (Отступы/Табуляция) и введите в строке Leader (Отточие) символ N, соответствующий в гарнитуре Windings "Веселому Роджеру", и символ пробела. Нажав кнопку Apply (Контроль), посмотрите на результат работы. Напомню, что выяснить соответствие символов в разных гарнитурах, а также клавиатурные комбинации для набора символов, отсутствующих на клавиатуре, можно с помощью утилиты Character Map, входящей в комплект Windows.


Позиции табуляции по умолчанию

До тех пор, пока вы не установили ни одной позиции табуляции, PageMaker пользуется значениями по умолчанию, в этом случае, как уже было отмечено, позиции табуляции располагаются равномерно с интервалом 0,5 дюйма. Табулостопы по умолчанию можно изменить. Если нужно по умолчанию изменить позиции табуляции для данного документа, выберите инструмент Pointer (Стрелка) (а не Туре (Текст)), откройте окно Indents/Tabs (Отступы/Табуляция) и задайте в нем необходимые значения. Закройте окно и сохраните публикацию. Теперь заданные значения стали значениями по умолчанию для данной публикации.

Если требуется задать позиции табуляции по умолчанию для всех публикаций, то те же действия необходимо выполнить, закрыв предварительно все публикации. Данная логика умолчаний полностью соответствует таковой и для других атрибутов (см. гл. 3).

Обратите внимание, что нажатие кнопки Reset (Восстановить) приводит к первоначальной расстановке табуляторов с интервалом 0,5 дюйма, а не приводит к заданным вами умолчаниям.


Отступы

Для выделения красной строки, временного сокращения длины строки (например, для цитат и для верстки стихов, о которой подробно рассказывается в разд. "Оформление абзацев: отбивки и линейки" данной главы) используются отступы. Они также относятся к атрибутам форматирования абзацев и задаются с помощью линейки табуляции.


Установка отступов

Откройте диалоговое окно Indents/Tabs (Отступы/Табуляция). Отступы помечены на линейке черными треугольниками, направленными вершинами друг к другу и расположенными в начале и в конце строки. Вид отступов в диалоговом окне PageMaker похож на их изображение на линейке текстового процессора. Края текущего текстового блока обозначены на линейке тонкими вертикальными пунктирами. Когда правый и левый отступ совмещены с краями тестового блока, текст форматируется без отступов. Левый маркер состоит из двух частей. Их можно перемещать по отдельности, создавая красную строку или висячий отступ, или вместе, тогда первая строка абзаца форматируется так же, как и остальные. Для изменения позиции отступа выберите мышью правый или левый маркер (при перемещении левого отступа щелчок мышью производите в середине треугольника) и оттащите мышью на нужное место линейки. В строке ввода Position (Позиция) отражается величина смещения отступа. Нажмите кнопку Apply (Контроль) и убедитесь в том, что ширина текущего абзаца изменилась в соответствии с заданным форматированием.

В России принято оформлять абзацы основного текста с помощью красных строк. Таким образом абзацы текста отделяются друг от друга. Глаз читателя использует красные строки как опорные точки и легче воспринимает такой текст. Величина красной строки в публикациях разных издательств и особенно разных лет издания сильно меняется, в более старых изданиях красная строка была больше, ее величина доходила до двух круглых шпаций. В настоящее время стандартная величина абзацного отступа (красной строки) равна круглой шпации (о шпациях — относительных единицах измерения символов — можно прочитать в гл. 4; круглая шпация приблизительно равна кеглю). Пример оформления красной строки представлен на рис. 5.20.

Для формирования красной строки требуется переместить вправо верхнюю часть маркера левого отступа. Для этого щелкните мышью на верхнем маленьком треугольничке. Теперь при перемещении мыши будет двигаться только верхняя часть маркера. Ее позиция также отражается в строке ввода Position (Позиция). Таким образом вы можете сместить начало первой строки абзаца вправо на необходимую величину.

Рис. 5.20. Оформление красной строки с помощью абзацного отступа

Если верхняя часть левого маркера отступа регулирует смещение первой строки абзаца, то нижняя управляет позицией всех остальных строк. Иногда требуется сместить первую строку абзаца влево по отношению к остальным. Такое расположение текста называется висячим отступом. Оно используется в перечнях, нумерованных списках и просто как способ выделения. Абзацный отступ не может быть больше ширины колонки, поэтому для того, чтобы первая строка сдвинулась влево и как будто вышла за пределы текстового блока, нужно сдвинуть вправо все остальные строки абзаца. Для этого выберите маркер левого отступа, нажмите клавишу <Shift> и, удерживая ее, потяните маркер вправо. При этом будет перемещена нижняя часть маркера.

Рассмотрим пример задания висячего отступа, показанный на рис. 5.21. На рис. 5.21 приведен текст до формирования отступов. В этом перечне в начале каждого абзаца проставлен значок графического выделения перечня, за которым следуют табулятор и текст. Этот перечень стал бы более привлекательным и читаемым, если бы все строчки текста начинались на одном уровне, а символ табуляции и значок перечня были вынесены влево за пределы блока. Для этого, как видно на рис. 5.22, были сделаны следующие действия:

  • нижняя часть маркера левого отступа смещена вправо;
  • позиция табуляции с выравниванием по левому краю совмещена с нижней частью левого отступа.

Рис. 5.21. Вид текста без отступов

Рис. 5.22. Установка отступов

Рис. 5.23. Висячие отступы в тексте учебника

Аналогичным образом можно установить висячий отступ для нумерованного списка (рис. 5.23).

Примечания

Об использовании висячих отступов для специальных эффектов в тексте подробно рассказывается в гл. 15. Приведем здесь лишь простейший пример. Текст, смещенный за границу колонки, привлекает внимание, даже если его цвет и кегль остались неизменными. При этом он ненавязчив, не "лезет в глаза", поэтому прием выделения с висячим отступом очень хорош в учебниках. В начало каждого абзаца можно поместить его основную мысль, тезис или подзаголовок. Этот текст сделайте полужирным. В результате получится страница, которой ученик может пользоваться, как опорным конспектом — основные положения темы будут сразу бросаться в глаза. Пример такого макета приводится на рис. 5.23. То же можно сказать о применении висячих отступов в технической документации. О нумерации с висячими отступами см. следующий раздел.


Дополнение PageMaker для установки нумерации и перечней

Нумерованные списки и перечни с графическим выделением пунктов можно оформлять с помощью дополнения PageMaker Bullets and numbering (Нумерация абзацев). Для этого оформите висячие отступы так, как указано в предыдущем разделе. Установите точку вставки на первом абзаце с висячим отступом. Откройте меню Utilities (Сервис) и выберите в нем команду Plug-ins (Дополнения). В раскрывшемся списке дополнений PageMaker (его вид будет примерно таким, как на рис. 5.24) выберите строку Bullets and numbering (Нумерация абзацев) (рис. 5.25). Вызвать одноименное диалоговое окно можно также щелчком на кнопке Bullets and numbering панели управления (на кнопке нарисован маркированный список).

Рис. 5.24. Команда Plug-ins меню Utilities с раскрытым списком дополнений PageMaker

Рис. 5.25. Диалоговое окно Bullets and numbering

Режим окна (создание нумерованного или маркированного списка) переключается кнопками Numbers (Номера) и Bullets (Символы). Дополнение запоминает, с чем вы работали в прошлый раз — с нумерованным списком или перечнем, и открывает соответствующее диалоговое окно. Рассмотрим подробнее данное окно в режиме создания нумерованного списка.

В верхней части окна находятся переключатели типа нумерации Numbering style (Стиль номеров). По умолчанию выбраны арабские цифры. Ниже расположен раскрывающийся список Separator (Разделитель), в котором выбирается разделитель цифры и остального текста; по умолчанию он отсутствует. В строке ввода Start at (Начальный номер) вводится номер первого пункта списка. По умолчанию он, разумеется, равен единице, но вы вполне можете начать нумерацию с 78 или с XII.

В нижней части окна расположен переключатель Range (Диапазон). Определяющий число абзацев, подлежащих нумерации. В зависимости от того, какая позиция выбрана, вы можете:

  • задать число абзацев, следующих за текущим, которые будут нумерованы в строке ввода For next ... Paragraphs (Следующие ... абзацев);
  • пронумеровать все параграфы данного стиля (выберите стиль из раскрывающегося списка), поставив переключатель в положение All those with style (Все абзацы со стилем) (о стилях абзацев подробно рассказывается в следующей главе);
  • пронумеровать все абзацы в текущем материале. Для этого включите режим Every paragraph in story (Все абзацы материала). О понятии материала см. соответствующий раздел гл. 6;
  • пронумеровать только выделенные абзацы (положение переключателя Only selected paragraphs (Только выделенные абзацы);
  • в списке Separator (Разделитель) при необходимости выбирают символ, устанавливаемый между номером и остальным текстом абзаца, например точку. Поставьте переключатель в положение For next ... paragraphs (Следующие ... абзацев) и введите в строку необходимое число пунктов списка, скажем 3. Нажав кнопку ОК, вы увидите приблизительно такую картину, как показана на рис. 5.26.

а

б

Рис. 5.26. Текст до и после обработки дополнением Bullets and numbering

Для оформления совокупности абзацев в виде графического перечня опять откройте описываемое диалоговое окно и щелкните мышью на кнопке Bullets (Символы). Второе диалоговое окно дополнения Ballets and numbering (Нумерация абзацев) представлено на рис. 5.27.

Рис. 5.27. Окно создания графически выделенного перечня дополнения Bullets and numbering

Вид значка перечня задается щелчком мыши на одной из пяти кнопок с изображением соответствующего символа. Если ни один из них не подходит для вашего перечня, нажмите кнопку Edit (Заменить). Откроется вложенное диалоговое окно Edit bullet (Заменить символ) (рис. 5.28).

Рис. 5.28. Диалоговое окно Edit bullet

В этом окне можно выбрать сам символ перечня, гарнитуру, которой он будет набран (часто используются символьные шрифты, например Windings), кегль символа. В поле Example (Образец) выбранный значок представлен в реальном масштабе. Для того чтобы получше рассмотреть, что вы выбрали, на время поиска задайте кегль покрупнее (на рисунке он задан равным 48 пунктам). Когда нужный значок будет найден, измените кегль на тот, которым вы собираетесь его набрать и, нажав кнопку ОК, перейдите обратно в главное окно. Для перечня можно задавать диапазон действия так же, как и для нумерованного списка.


Работа с отступами в меню и управляющей палитре

В отличие от табулостопов, которые можно задавать только с помощью линейки табуляции, абзацные отступы задают и редактируют также в управляющей палитре и в окне Paragraph Specifications (Параметры абзаца). Этот способ не нагляден, но если величины отступов уже известны, то задание их в управляющей палитре гораздо оперативнее, чем в диалоговом окне Indents/Tabs (Отступы/Табуляция). Если же вам нужно задать несколько атрибутов форматирования для абзаца, для этого удобно воспользоваться диалоговым окном Paragraph Specifications (Параметры абзаца), задав в нем заодно и величину абзацных отступов. Строки ввода соответствующих отступов в управляющей палитре и в диалоговом окне приведены на рис. 5.29.

а

б

Рис. 5.29. Задание отстулов в диалоговом окне Paragraph Specifications и в управляющей палитре

Как уже отмечалось в гл. 4, диалоговое окно Paragraph Specifications (Параметры абзаца) вызывается клавиатурным сокращением <Ctrl>+<M>. Управляющая палитра открывается комбинацией клавиш <Ctrl>+<'>, передача управления с главного окна PageMaker на управляющую палитру и обратно осуществляется комбинацией клавиш <Ctrl>+<'>. Переключение режимов работы Туре и Paragraph производится нажатием комбинации клавиш <Ctrl>+<Shift>+<'>. Переход от одного поля к другому в управляющей палитре и в диалоговом окне Paragraph Specifications (Параметры абзаца) производится клавишей табуляции.


Распределение строк и абзацев по страницам

Программа PageMaker позволяет управлять распределением строк и абзацев по страницам и колонкам публикации и воздействовать на их положение на странице. Задав тип расположения конкретного абзаца на странице, вы избавите себя от лишней работы по переразмещению текста после редактирования. Группа элементов управления Options (Варианты), расположенная в окне Paragraph Specifications (Параметры абзаца) (см. рис. 5.3), позволяет принудительно разорвать строку в заданной точке, форсировать размещение смежных абзацев на одной странице, разместить абзац в начале новой страницы или следующей колонки текста и предотвратить появление висячих строк


Разрыв строки

Для того чтобы принудительно разделить строку в заданной точке, проще всего ввести в текст символ разрыва строки. Он вводится комбинацией клавиш <Shift>+<Enter>. Символ разрыва строки не отображается в главном окне публикации, но в окне редактора материалов он становится виден (сломанная стрелка) при включении режима показа непечатаемых символов (см. рис. 5.1).


Распределение абзацев в окне Paragraph Specifications

В нижней части диалогового окна (рис. 5.29) расположена группа элементов управления Options (Варианты). Представленные в ней режимы влияют на расположение абзаца на странице и способ разбиения абзаца на две страницы. Остановимся кратко на этих режимах.

  • Keep lines together (Все строки вместе). Включенный режим форсирует размещение данного абзаца на одной странице, абзац с таким атрибутом форматирования не разбивается. Подобный режим очень удобен для заголовков, скажем статей или таблиц.
  • Column break before (Новая колонка). При этом режиме форматирования происходит принудительный переход на новую колонку. Данный, абзац помещается в ее начале. Такой тип форматирования пригодится при верстке многостраничных журналов. Заголовки первого уровня (названия статей) автоматически будут расположены в начале колонок.
  • Page break before, (Новая страница). Режим, аналогичный предыдущему, с той разницей, что в данном случае происходит переход на новую страницу. Такой тип форматирования применяется в книгах. Заголовки первого уровня (названия глав или рассказов) автоматически начинаются с новой страницы.
  • Keep with next ... lines (Удержать ... строк следующего абзаца). При активизации этого режима можно задать минимальное число строк следующего абзаца, которые должны быть на той же странице, что и форматируемый. Это очень полезный режим. Задайте его для заголовка, установив число строк, скажем, 2, и вы никогда не увидите заголовка внизу страницы, оторванного от последующего текста.

Все вышеперечисленные режимы рассматриваются более детально при обсуждении системы стилей.

  • Orphan control (Висячие строки в начале абзаца) и Widow control (Висячие строки в конце абзаца) — режимы предотвращения висячих строк, соответственно, в начале и в конце абзаца. Этой животрепещущей для полиграфистов проблеме посвящен следующий раздел.
  • Include in table of contents (Включить в оглавление). Режим включения в оглавление. Об этой функции мы поговорим подробнее в гл. 17.


Висячие строки

Термин "висячая строка" каждый вправе толковать по-своему, т. к. точного определения нет, как и у большинства других полиграфических терминов. Разработчики PageMaker вложили в него следующий смысл:

  • Начальная висячая строка (Widow, вдова) — последняя строка абзаца, располагающаяся вверху страницы в отрыве от остальных строк, оставшихся на предыдущей странице.
  • Концевая висячая строка (Orphan, сирота) — это первая строка абзаца, располагающаяся внизу страницы или колонки и оторванная от своих собратьев, находящихся на следующей странице.

На рис. 5.30 представлены оба вида висячих строк. Бороться с ними можно несколькими способами. Самый радикальный — это редактирование текста, в ходе которого добавляется или удаляется несколько слов. Но чаще всего на этапе верстки об этом уже поздно говорить. Также это не представляется возможным, если вы издаете художественное произведение.

Контроль висячих строк можно производить вручную, регулируя объем, занимаемый абзацем текста с помощью атрибутов, управляющих длиной строки. О них подробно рассказывается в разд. "Выключка строк" данной главы. Некоторые аспекты регулирования объема текста рассмотрены в гл. 17. Ручной метод контроля висячих строк привлекателен своей гибкостью. С другой стороны, при любых подвижках текста, связанных с внесением корректуры, расположение строк на странице изменится, и работу придется выполнять заново. Если публикация занимает больше 10—15 страниц, на это уйдет много времени и сил.

Рис. 5.30. Висячие строки в публикации

Можно и практически всегда целесообразно поручить контроль висячих строк самой программе. Автоматический контроль включается при активизации режимов Orphan control (Висячие строки в начале абзаца) и Widow control (Висячие строки в конце абзаца) в поле Options (Варианты) диалогового окна Pafagraph Specifications (Параметры абзаца). При активизации этих режимов необходимо задать минимально допустимое число висячих строк (отдельно для концевых и для начальных) от 0 до 3. Контроль висячих строк с использованием автоматических режимов можно проводить двумя способами.

  • Просматривая текст, вводить нужный атрибут для тех абзацев, где это требуется; при изменении текста придется проверить его на предмет висячих строк еще раз, т. к. абзацы могут сместиться.
  • Задать необходимые функции контроля висячих строк для всего текста публикации; в этом случае вы устанавливаете нужные атрибуты один раз, после чего можете забыть о существовании висячих строк.

Рассмотрим, каким образом PageMaker регулирует расположение текста на странице при осуществлении контроля висячих строк. Предположим, вы задали наименее возможное число висячих строк абзацев равным 2.

Каждый раз, когда PageMaker, распределяя текст по страницам или колонкам, встречается с необходимостью разбить абзац, он анализирует, сколько висячих строк остается на странице. Если это число больше или равно 2, абзац разбивается. Если это условие не выполняется, PageMaker пробует сместить точку разбивки абзаца, т. е. разбить абзац на строчку ниже. Если это невозможно, абзац целиком переносится на следующую страницу.

Точно так же выполняется проверка концевых висячих строк. Когда PageMaker разбивает абзац с переходом на следующую страницу или колонку, он проверяет, сколько таких строк появилось на новой странице. Если их количество не меньше 2, абзац разбивается в данном месте, если меньше — PageMaker пытается выполнить условие, разбив абзац на строчку выше. При невозможности такого разбиения весь абзац помещается на текущей странице.

Автоматический контроль висячих строк в PageMaker — мягко говоря, не самая сильная сторона этой программы. Конечно, если включить флажки контроля Orphan control (Висячие строки в начале абзаца) и Widow control (Висячие строки в конце абзаца), висячих строк в публикации не будет. Но, как можно понять из приведенного выше алгоритма, предотвращение висячих строк производится путем грубого перемещения абзацев. Если, скажем, на данной странице (колонке) образовалась начальная висячая строка, PageMaker поместит весь абзац, к которому она относится, на текущую страницу. В результате на предыдущей странице (колонке) появится "дырка", текстовый блок не будет дотянут до конца полосы набора. Нижние края полосы набора должны находиться на одном уровне: если высота смежных полос набора отличается (да еще, как в нашем случае, на десятки миллиметров), это еще хуже, чем наличие висячей строки. Впрочем, и то и другое — абсолютно недопустимый типографский брак. Поэтому не рекомендуем вам пользоваться автоматическим контролем висячих строк — вы не только не выиграете время за счет автоматизации, а наоборот, потратите его еще больше на отслеживание и борьбу с "дырами" в тексте.

Тем не менее алгоритм предотвращения висячих строк иногда находит применение. Так, он используется при верстке качественной технической документации, руководств к программам и другой специальной литературы. Обычно такого рода публикации содержат очень много иллюстраций и разбиты на множество маленьких разделов. Правило об одинаковой длине полос набора в таких изданиях соблюдается нестрого.

Для того чтобы быстро обнаружить участки текста, для которых PageMaker не смог выполнить все режимы распределения абзацев, установите флажок Show "keeps" violations (Выделять подсветкой висячие строки) в диалоговом окне Preferences (Установки). После закрытия данного диалогового окна все нарушения в распределении абзацев по страницам будут выделены серой или желтой подсветкой, в зависимости от типа монитора на вашем компьютере. Найденные нарушения можно постараться исправить, настраивая атрибуты, влияющие на длину строки. В частности, вам в этом поможет табл. 5.1. Основные правила при подобной настройке таковы.

  • Если последняя строка абзаца занимает по длине менее четверти строки, можно попытаться уплотнить текст с целью уменьшейия объема и сокращения числа строк (вгон строки).
  • Если длина последней строки составляет более 3/4 длины колонки, попытайтесь разогнать текст (сделать его более свободным) и таким образом прибавить еще строку к данному абзацу (выгонка строки).
  • Задействуйте не только переносимый абзац. Может быть, необходимую строчку можно прибавить или убавить, работая с абзацами, предшествующими проблемному. Более подробно подгонка строк рассматривается в гл. 17.

Допустимое число висячих строк. Большинство полиграфистов в России придерживаются мнения, что это значение не должно быть меньше двух. Если же такое расположение невозможно (в книгах этого не случается, а вот в журналах с версткой в небольшие колонки бывает), то приходится определить, строку какой длины можно оторвать от последнего абзаца на странице и перенести на следующую страницу. Лучше всего, конечно, чтобы ее длина была 100% ширины колонки или страницы. Допустимо оставлять на начальной висячей строке до двух слов. Если висячая строка состоит всего из одного слова — это плохо. Строку, состоящую только из перенесенного окончания слова, немыслимо оставлять в качестве висячей. Те же требования предъявляют и вообще к последним строкам абзацев, необязательно висячим.

Для стилевого оформления публикации очень важно заранее принять решение о каждом из атрибутов форматирования и в дальнейшем придерживаться принятой стратегии. В результате полученная публикация будет единой по оформлению, что заметно улучшит впечатление будущего читателя. Следует добиваться наивысшего качества верстки с учетом временных и финансовых ограничений.


Оформление абзацев: отбивки и линейки

Абзац можно выделить в массиве текста разными способами. Наиболее широко в PageMaker для выделения абзацев применяются отбивки и линейки. Если абзацу задать величину отбивки, он будет отделяться от соседних абзацев свободным пространством. Линейки — это горизонтальные линии определенного вида, которые могут располагаться сверху или снизу абзаца. Отбивками выделяются заголовки, подписи под рисунками. Линейки используют реже, в основном для вычленения заголовков.


Задание отбивок до и после абзацев

Для задания отбивки можно воспользоваться диалоговым окном Paragraph Specifications (Параметры абзаца) или управляющей палитрой в режиме Paragraph (рис. 5.31).

В верхней правой части этого диалогового окна имеется группа Paragraph space (Отбивки), состоящая из двух полей ввода: Before (До) и After (После). В управляющей палитре поля ввода отбивок находятся в правой части окна и помечены пиктограммами со стилизованными изображениями абзаца и стрелочки вверх (верхняя отбивка) и вниз (нижняя отбивка). Величины отбивок задаются в единицах, которые определены для публикации в диалоговом окне Preferences (Установки) (о задании умолчаний см. гл. 3). На рис. 5.31 такие единицы — миллиметры.

а

б

Рис. 5.31. Поля задания отбивок в диалоговом окне Paragraph Specifications и в управляющей палитре

В любом числовом поле ввода программы вы можете вводить значения в единицах измерения, отличных от заданных в окне установок. Для этого после набора числа введите сокращенное обозначение единицы измерения. Например, если вам требуется ввести значение отбивки 0,5 дюйма, а заданные по умолчанию единицы измерения — миллиметры, введите в поле нужной отбивки число 0,5 и без пробела букву i. Открыв снова диалоговое окно, вы увидите, что введенное значение автоматически пересчитано в миллиметры. В поле ввода будет стоять число 12,7. Пересчет введенного значения в умалчиваемые единицы происходит сразу после нажатия клавиши табуляции. В табл. 5.2 указаны сокращенные обозначения для единиц измерения, используемых в PageMaker.

Таблица 5.2. Сокращенные обозначения единиц измерения PageMaker

Чтобы временно задать | Введите
Миллиметры | m после числового значения (25т означает 25 мм)
Пики | р после числового значения (18р означает 18 пик)
Пункты | р перед числовым значением (р6 означает 6 пунктов)
Пики и пункты | р между числовыми значениями (18р6 означает 18 пик и 6 пунктов)
Цицеро | с после числового значения (5с означает 5 цицеро)
Дюймы | i после числового значения (5.25i означает 51/4 дюйма)

На рис. 5.32 представлен пример текста, отформатированный без отбивок и с отбивками между абзацами по 1,5 мм сверху и снизу. Очевидно, наличие отбивок дополнительно подчеркивает структуру текста, делая его более читаемым.

а

б

Рис. 5.32. Текст без отбивок и с заданными отбивками по 1,5 мм над и под абзацем


Отбивки или красные строки?

Иногда выделение отбивками используется вместо красной строки, т. е. все строки абзаца начинаются без отступов и каждый из них отделен от других отбивкой с двух сторон (рис. 5.33). Публикация, сверстанная с использованием красных строк, смотрится более привычно для русскоязычного читателя, обычно таким образом верстают в настоящее время художественные книги. Это придает книге солидный, респектабельный вид, особенно если редактор не поленится и подберет подходящий шрифт (очень хорошо в таком случае пользоваться гарнитурами, принятыми в советской полиграфии — Академической, Литературной, Тайме). Тогда покупатель или клиент (потенциальный читатель), открыв книгу, увидит картину, знакомую с детства, когда все книги были интересными. Может быть, это обстоятельство дополнительно привлечет его и он купит выбранный экземпляр. Читая такую, сверстанную по классическому образцу книгу, вы не будете сталкиваться с непривычными элементами типа пустых пространств между абзацами и странного рисунка некоторых литер.

а

б

Рис. 5.33. Сравнение верстки с отбивками и с красными строками

С другой стороны, большинство редакторов придерживаются мнения, что система верстки с использованием отбивок придает более элегантный вид документу и текст тогда легче читается. Такой способ верстки уместен в технической литературе, учебниках. Их читают с намерением чему-то выучиться. Даже если способ верстки непривычен для читателя, он быстро освоится и будет вознагражден легкостью отыскивания нужного абзаца (ведь учебник — не роман, его иногда читают и не подряд). Часто верстка с применением отбивок между всеми абзацами основного текста актуальна в дорогих изданиях (например, в альбомах по искусству). Непривычное расположение абзацев может вызвать ощущение претенциозности, шика — в данном случае это то, что надо. "Пижонство" также можно усилить выбором соответствующей гарнитуры.


Отбивки при верстке стихов

Такого рода работа имеет свою специфику. PageMaker отлично приспособлен для верстки стихотворных произведений. В процессе верстки стихов используются отбивки, абзацные отступы и принудительный перенос строки. Если стихотворение состоит более чем из одной строфы, необходимо, чтобы строфы отделялись друг от друга отбивкой, кроме того, в некоторых стихах строфы располагаются лесенкой. Рассмотрим верстку стихотворения, приведенного на рис. 5.34. Как первая, так и вторая строфа представляют собой единые абзацы. Внутри строф между строками вставлены признаки перехода на новую строку (принудительный перенос строки, комбинация клавиш <Shift>+<Enter>). Каждому из абзацев-строф приданы значения отбивок до и после абзаца — 2 мм. Второй абзац сверстан с отступом 30 мм от левого края полосы для образования лесенки. Стихотворению предшествует виньетка, составленная из стандартных символов Windings и представляющая собой абзац с атрибутом Page break before (Новая страница). Таким образом достигается автоматическое размещение стихов по одному на странице. Для украшения и придания публикации соответствующего колорита для набора выбран изящный шрифт Lazurski (12 кегль), а первая буква отформатирована шрифтом Decor 36 кегля.

Рис. 5.34. Стихотворение сверстано с применением отбивок и отступов


Оформление абзацев: линейки

Горизонтальные линии над и под абзацем (линейки) привлекают внимание к содержанию абзаца. Поэтому их используют в основном для заголовков (рис. 5.35) и выделений типа передовиц и тезисов. В PageMaker построение линеек отлично автоматизировано.

Формирование линеек производится в диалоговом окне Paragraph Rules (Линии абзаца) (рис. 5.36). Это окно — вложенное, оно вызывается щелчком на кнопке Rules (Линии) диалогового окна Paragraph Specifications (Параметры абзаца).

Элементы управления окна поволяют задать вид, длину и расположение отдельно для верхней и нижней линеек абзаца. Для этого в окне Paragraph Rules (Линии абзаца) предусмотрены две независимых области — Rule above paragraph (Линия над абзацем) и Rule below paragraph (Линия под абзацем). Эти области имеют одинаковую систему команд.

Рассмотрим способ задания верхней линейки.

  1. Установите флажок Rule above paragraph (Линия над абзацем).
  2. Задайте внешний вид и ширину линейки в строке Line style (Стиль). Можно выбрать один из готовых вариантов линеек в раскрывающемся списке или пункт списка Custom (Заказная).

Рис. 5.35. Примеры абзацных линеек

Рис. 5.36. Диалоговое окно Paragraph Rules

  3. Откроется окно Custom Stroke (рис. 5.37), в котором следует установить вид линейки в списке Stroke style (Стиль линии) и ее толщину в пунктах в строке ввода Stroke weight (Толщина). Допустима толщина линейки от 0 до 800 пунктов с точностью до 0,1 пункта. Флажок Transparent background (Прозрачная основа) задает режим прозрачной подложки в случае пунктира или сложной (двойной или тройной) линии. При отключенном режиме Transparent background (Прозрачная основа) промежутки между штрихами пунктира или между частями линии принимают цвет бумаги (Paper). Подробнее о цветах None (Без цвета), Paper (Бумага) и о функции Transparent (Прозрачная) рассказывается в гл. 9. Там же, на рис. 9.22, представлено действие соответствующих атрибутов. После того как стиль линии определен, закройте окно Custom Stroke и продолжайте работать в окне Paragraph Rules (Линии абзаца).

В поле Line Colour (Цвет) выберите цвет линии из раскрывающегося списка. Ниже, в поле ввода Tint (Оттенок ), можно задать оттенок выбранного цвета в процентах (см. разд. "Назначение оттенков цвета" гл. 20).

Рис. 5.37. Диалоговое окно Custom Stroke

Переключатель Stroke width (Длина) устанавливает точку отсчета длины созданной линейки. В положении Width of text (По ширине текста) длина ее соответствует длине смежной с ней строки абзаца (в данном случае, первой строки). В режиме Width of column (По ширине колонки) длина линейки рассчитывается по ширине колонки. Линейка может и не доходить до краев смежной строки или колонки. Отступ от краев задается в следующей строке — Indent (Отступы). В ней можно задать левый и правый отступ для линейки (в единицах, заданных по умолчанию).

Линейка относительно текста может смещаться и по вертикали. Смещение задается относительно базовой линии. Значения вертикального смещения задаются отдельно для верхней и нижней линеек во вложенном окне Paragraph Rule Options (Расположение линий абзаца) (рис. 5.38). Это диалоговое окно открывается кнопкой Options (Варианты) диалогового окна Paragraph Rules (Линии абзаца). Кроме смешения линеек, во вложенном диалоговом окне можно включить флажок Align next paragraph to grid (Выровнять следующий абзац по сетке) и задать шаг сетки. О модульной сетке и вертикальном выравнивании текста будет рассказано в гл. 14.

Рис. 5.38. Задание вертикального смещения линеек во вложенном окне Paragraph Rule Options

Вторая половина диалогового окна посвящена заданию атрибутов линейки под абзацем. Она устроена аналогичным образом. Рассмотрим, как созданы линейки в приведенных на рис. 5.35 примерах. Во всех этих примерах текст размещен по центру, интерлиньяж установлен пропорционально.

В первом примере фраза "более 100.000.000 читателей" составляет отдельный абзац, которому придана верхняя линейка шириной 4 пункта, с автоматическим вертикальным смещением от базовой линии. Длина линейки задана по длине строки текста, цвет черный. Для слова "присоединяйтесь!" задана точно такая же нижняя линейка со смещением от базовой линии вниз на 2 мм, для того чтобы она не сливалась с нижними краями букв абзаца. Обратите внимание! Точно такого же эффекта можно добиться, если обе строки будут представлять собой один абзац (для этого надо разделить их не с помощью возврата каретки, а комбинацией клавиш <Shift>+<Enter>). Для получившегося большого абзаца нужно задать одновременно и верхнюю и нижнюю линейку.

Для второго примера задана заказная линейка снизу и сверху толщиной 2 пункта. Нижняя линейка смещена относительно базовой линии на 4 мм, верхняя — на 8 мм (кегль текста при этом равен 11). Вследствие этого между линейками и текстом образовалось свободное пространство. Длина линеек задана по ширине текстового блока, с горизонтальным смещением для верхней линейки 20 мм слева и для нижней линейки — 20 мм справа.

Третий пример иллюстрирует возможность создания выворотного текста с помощью линеек. Для фразы "синяя папка" выбрана линейка снизу абзаца толщиной 12 пунктов (той же, что и кегль текста). Она смещена относительно базовой линии на 4 мм. Длина линии задана по ширине колонки, с горизонтальным смещением слева на 15 мм. Тексту придан цвет бумаги.

В последнем примере тоже есть линии над и под абзацем. Он хорошо иллюстрирует возможности смещений линеек. Нижняя линейка толщиной 0,5 пункта расположена с автоматическим смещением относительно базовой линии. Ее длина измеряется шириной колонки. Верхней линии придано нулевое смещение от базовой линии, поэтому она совпала с последней. Нижняя линия — заказная, двойная, шириной 3 пункта. Ее длина равна длине строки; смещение от базовой линии составляет 1,2 мм.

Примечание

Абзацные линейки оказывают влияние на вертикальное размещение абзацев на странице. До тех пор, пока для смещения линеек абзаца относительно базовой линии задано значение Auto (Авто), PageMaker пытается разместить линейки в пространстве абзаца — верхняя линейка размещается в пространстве первой строки абзаца, нижняя — в пространстве последней строки. Разумеется, значение отбивок до и после абзацев остается в силе. Тем не менее при автоматическом размещении линеек расположение абзаца на странице не изменится. Но при замене значения Auto (Авто) на фиксированное значение смещения линейки от базовой линии характер действий PageMaker резко меняется. Это явление носит общий характер — при замене автоматических значений на фиксированные PageMaker начинает действовать более жестко (сравните, например, режимы автоинтерлиньяжа и интерлиньяжа с заданным значением). Если, скажем, задать значительное смещение верхней линейки, она будет проведена высоко над абзацем и будет оставлено много свободного места между линейкой и абзацем. Как следствие этого, данный абзац и последующие сместятся вниз. Такие смещения, как и отбивки абзацев, оказывают влияние на размещение абзацев по модульной сетке. О стратегии выравнивания абзацев по вертикали рассказывается в гл. 13.


Выбор метода интерлиньяжа

Метод интерлиньяжа, т. е. алгоритм, по которому рассчитывается расстояние между строками текста — это атрибут абзаца. Как правило, он устанавливается всего один раз в качестве глобального умолчанад, и больше вы к этому вопросу не возвращаетесь.


Три метода интерлиньяжа

При выделении символов в текстовом режиме инверсией показывается высота строки. В терминах PageMaker высота строки текста — это интерлиньяж, заданный для наибольшего из составляющих ее символов. Если высота строки равна 14 пунктам, то и интерлиньяж равен 14 пунктам. На рис. 5.39 показана базовая линия текста. Эта воображаемая линия соединяет нижние края символов строки, исключая нижние выносные элементы, которые она пересекает. Метод интерлиньяжа определяет положение базовой линии относительно строки набора. В PageMaker возможно визуально отследить, какой метод интерлиньяжа используется. При выделении символов инструментом Туре (Текст) инверсное выделение совпадает с положением строки относительно базовой линии.

  • Если, как в случае рис. 5.39, базовая линия делит строку набора по высоте в отношении 2:1, такой метод интерлиньяжа носит название пропорционального интерлиньяжа. При этом методе две трети высоты строки расположены сверху базовой линии, а одна треть — снизу. Данный метод интерлиньяжа принят в PageMaker по умолчанию. При работе с этим методом часто требуется высчитывать положение базовой линии для выравнивания по модульной сетке и для формирования заказной линейки абзаца.
  • Другой метод — интерлиньяж по базовым линиям. При этом нижний край строки совмещается с ее базовой линией. Данный метод активно применялся в традиционной полиграфии. Пример интерлиньяжа по базовой линии представлен на рис. 5.40. Размещение абзацев при таком интерлиньяже проще, считать нужно только одно смещение, а не два, поскольку базовая линия абзаца совмещена с нижней границей строки.

Рис. 5.39. Пропорциональный интерлиньяж

Рис. 5.40. Интерлиньяж по базовым линиям

Третьим методом интерлиньяжа, применяющимся в PageMaker, является интерлиньяж по прописным буквам. При этом методе верхний край строки совмещается с верхним краем самой высокой прописной буквы самого крупного шрифта, используемого в строке (независимо от ее наличия в данной строке). Базовая линия при этом располагается ниже верхнего края строки на расстоянии, равном высоте самой высокой буквы. Таким образом, положение базовой линии в общем-то становится неопределенным. Сам интерлиньяж также может слегка меняться от строки к строке. Этот метод наименее предсказуем, он встроен в настоящую версию PageMaker для совместимости его с ранними версиями.

Рис. 5.41. Интерлиньяж по прописным буквам


Выбор метода интерлиньяжа

В предыдущем разделе обсуждалось, как задается значение интерлиньяжа. Размер интерлиньяжа относится к параметрам символа и задается в меню Туре (Текст). Метод интерлиньяжа является атрибутом абзаца. Он выбирается во вложенном окне Spacing Attributes (Интервалы), вызываемом кнопкой Spacing (Интервалы) диалогового окна Paragraph Specifications (Параметры абзаца) (см. рис. 5.3). Для выбора метода интерлиньяжа нужно установить соответствующий флажок — Proportional (Пропорциональный), Top of caps (По прописным), Baseline (По базовым линиям) — в поле выбора Leading method (Интерлиньяж).

Скорее всего, вы предпочтете интерлиньяж по базовой линии. Обратите внимание на то, какой из методов применен в уже имеющихся публикациях. Когда вы выбрали подходящий для вас метод интерлиньяжа, зафиксируйте свой выбор в умолчании. Если вы выбрали в качестве базового пропорциональный интерлиньяж, то задание умолчания не потребуется, т. к. этот метод и так является методом по умолчанию. Если же ваш выбор пал на интерлиньяж по базовой линии, то, скорее всего, вы захотите пользоваться этим методом и для последующих документов. В таком случае следует задать глобальное умолчание.


Резюме

Рассмотренные в этой главе приемы форматирования абзацев применяются довольно редко, в основном для очень небольших публикаций и для заголовков первого уровня. Настраивать каждый абзац в книге из 400 страниц — занятие долгое и утомительное. Кроме того, немаловажной является стандартизация оформления публикаций внутри одного проекта. В PageMaker для автоматизации работы со стилями существует развитый механизм стилей абзацев. Одинаковые отформатированные абзацы помечаются признаком стиля. При изменении атрибутов стиля автоматически меняются соответствующие атрибуты всех абзацев этого стиля в публикации, какой бы большой она ни была. Применяя стили, вы получаете возможность верстать публикации на порядок быстрее, чем используя только местное форматирование. Система стилей будет рассмотрена в следующей главе.


  • Глава 6. Глобальное форматирование
    • Система стилей PageMaker
      • Применение стиля
      • Выбор стиля
      • Палитра стилей
      • Строка ввода стиля в управляющей палитре
      • Меню Style
      • Контекстное меню
      • Режим автоматического присвоения стиля
    • Глобальное и локальное форматирование
      • Взаимодействие начертания и глобального форматирования
      • Индикация стилей
      • Статус стиля
    • Создание нового стиля. Редактирование стилей
      • Диалоговое окно Define Styles
      • Диалоговое окно Style Options
      • Задание атрибутов символов и абзацев в стиле
      • Слияние двух стилей
    • Импорт стилей
      • Импорт из публикаций PageMaker
      • Импорт стилей из документов других программ
      • Работа с библиотекой стилей
    • Резюме


ГЛАВА 6.

Глобальное форматирование

Абзацные стили — главный инструмент форматирования текста в издательских системах. Любая публикация, насчитывающая больше пары страниц, как правило, выполняется с использованием стилей. Глобальное форматирование позволяет легко изменять параметры текста публикации и обеспечивает единство оформления.

В настоящей главе рассматриваются следующие вопросы:

  • Система стилей PageMaker
  • Выбор стиля
  • Глобальное и локальное форматирование
  • Создание нового стиля. Редактирование стилей
  • Импорт стилей
  • Рецепт. Создание каталога стилей публикации
  • Работа с палитрой библиотеки


Система стилей PageMaker

Вид каждого абзаца можно однозначно описать совокупностью элементов его форматирования. Для форматирования каждого абзаца нужно, таким образом, еще и еще раз повторять задание всех этих атрибутов. Совокупность атрибутов можно сохранить в качестве стиля — атрибута форматирования более высокого уровня. Применение созданного стиля к абзацу задает последнему одновременно весь сохраненный в стиле комплекс атрибутов. Использование стилей называется глобальным форматированием (относится ко всей публикации). Форматирование без применения стилей, когда атрибуты определяются отдельно для символов или абзацев, называют локальным. Сумма всех определенных в публикации стилей именуется каталогом стилей (Style sheet). B hero входят стили для оформления всех элементов публикации, включая иерархическое построение заголовков, таблицы, под-рисуночные подписи, оглавление и другие элементы верстки. Каталоги стилей хранятся в файлах своих публикаций.

Программа позволяет обращаться со стилями вполне свободно — создавать новые, редактировать, удалять, копировать из других файлов и импортировать из других приложений. При редактировании стиля весь текст данной публикации, отформатированный тем или иным стилем, принимает переопределенные атрибуты. Какой простор для творческой мысли! Если вы не пользуетесь стилями, то для изменения форматирования публикации (скажем, для смены интерлиньяжа или гарнитуры) придется переопределять каждый абзац. При наличии стилей же достаточно просто изменить атрибут стиля, и вы увидите результат сразу во всем тексте. Экспериментируйте сколько душе угодно.


Применение стиля

Стиль — это атрибут абзаца. Следовательно, можно задать стилем полужирное начертание заголовку. Но нельзя определить стилем полужирное начертание одному слову в этом заголовке, это можно сделать только локально. В PageMaker нет системы стилей символов, хотя существуют обходные пути для эмулирования этого инструмента (один из них рассмотрен в гл. 15). Стили символов поддерживаются также некоторыми дополнениями PageMaker.


Выбор стиля

Для задания абзацу существующего стиля выберите инструмент Туре (Текст) и установите точку ввода в форматируемом абзаце (не обязательно выделять абзац целиком). Чтобы одновременно задать стиль нескольким абзацам, их нужно выделить. Стиль выбирают из палитры Стили (Styles), из списка Стиль (Style) меню Текст (Туре), из аналогичного списка в управляющей палитре и в контекстном меню (в текстовом режиме).

Примечание

Перед выбором, изменением, редактированием стилей рекомендуем вам сохранить документ. На операции со стилями не действует команда Undo (Отменить исправления).


Палитра стилей

Палитра стилей вызывается на экран командой-переключателем Show Styles (Показать стили) меню Window (Окно) (комбинация клавиш <Ctrl>+<B>). Она имеет стандартное устройство. Каждая строчка палитры соответствует стилю публикации. Активный стиль (т. е. тот, которым отформатирован текущий абзац) помечен инверсией. Если абзацу не присвоен стиль, то при переходе на него текстового курсора выделяется первая строка палитры — [No style] ([Без стиля]). Для выбора стиля необходимо подвести текстовый курсор к требуемой строке (в пределах палитры курсор превращается в стрелку) и щелкнуть мышью (рис. 6.1). Если выполнить двойной щелчок на имени стиля или на строке [No style] ([Без стиля]), откроется окно редактирования Style Options (Описание стиля) (о редактировании стилей см. разд. "Задание атрибутов символов и абзацев в стиле" данной главы).

Рис. 6.1. Выбор стиля в палитре

Примечание

Для того чтобы палитра стилей присутствовала на экране сразу после запуска PageMaker, включите ее в глобальное умолчание. Разумно установить размер палитры таким образом, чтобы видеть одновременно все используемые стили, не прибегая к прокрутке.


Строка ввода стиля в управляющей палитре

Глобальное форматирование абзаца определяется и в управляющей палитре в режиме Paragraph. Раскройте список в верхней левой части и выберите необходимый стиль (рис. 6.2). Можно также, переместив точку ввода в строку стилей, набрать первые буквы имени. PageMaker сам подставит в строку ввода нужное значение. После нажатия клавиши <Enter> или комбинации

Рис. 6.2. Выбор стиля в управляющей

клавиш <Tab>+<Shift>+<Enter> выбранный стиль будет применен к выделенным абзацам (различие в действии клавиши <Enter> и комбинации клавиш <Tab>+<Shift>+<Enter> описано в гл. 4).


Меню Style

Для быстрого выбора стиля удобен список стилей документа в подменю Style (Стиль) меню Туре (Текст) (рис. 6.3). Как и в других случаях, необходимо до вызова команды меню выделить форматируемые абзацы или установить точку вставки.


Контекстное меню

Довольно удобно и также очень быстро определять стили в контекстном меню, вызываемом правой кнопкой мыши в текстовом режиме. На рис. 6.4 изображено контекстное меню с открытым списком стилей документа.

Рис. 6.3. Выбор стиля в меню Style

Рис. 6.4. Выбор стиля в контекстном меню


Режим автоматического присвоения стиля

При наборе текста в PageMaker существует возможность автоматического присвоения стилей вновь создаваемым абзацам. Стиль нового абзаца может присваиваться на основе стиля предыдущего абзаца двумя методами.

  • Наследование стилей. Если в стиле предыдущего абзаца поставлен режим наследования стиля, то последующий абзац будет отформатирован тем же стилем, что и предыдущий. Этот режим автоматического присвоения стилей используется при наборе основного текста.
  • Наследование стилей. В стиле форматирования предыдущего абзаца может быть задан иной стиль для последующего абзаца. Если, например, в стиле заголовка указано, что последующим будет стиль основного текста, то после набора заголовка и нажатия клавиши <Enter> образуется новый абзац со стилем основного текста.

Кроме того, существует режим отмены автоматического присвоения стиля последующему абзацу. В этом случае он будет отформатирован локально с использованием всех атрибутов стиля предыдущего абзаца, но собственно атрибут стиля ему не присваивается. О системе назначения стилей для последующего абзаца см. разд. "Создание нового стиля. Редактирование стилей" данной главы.


Глобальное и локальное форматирование

Применение глобального форматирования ни в коей мере не снимает необходимости локального или местного форматирования, которое заключается в присвоении атрибутов форматирования символам или даже абзацам в каком-то конкретном месте. Локальное форматирование применяется, например, для задания особого начертания некоторым символам или словам в тексте абзаца. При тонкой настройке выключки, борьбе с висячими строками также не обойтись без локального форматирования, которое в данном случае может даже затрагивать целые страницы текста. Как видите, применение стилей ни в коей мере не ограничивает вашу творческую свободу. На рис. 6.5 приведен пример локального форматирования символов в абзаце, отформатированном стилем.

Примечание

В PageMaker термин Style употребляется в двух разных значениях: Style (Стиль), атрибут абзаца, и Type style (Начертание), атрибут символа (подчеркнутое, полужирное и пр.).

Рис. 6.5. Локальное форматирование курсивным начертанием группы слов абзаца, отформатированного стилем


Взаимодействие начертания и глобального форматирования

Поскольку в состав стиля входит начертание символов абзаца, логично предположить, что при назначении стиля абзацу или при его замене все элементы абзаца примут атрибуты назначаемого стиля. Однако на некоторые атрибуты местного форматирования глобальное форматирование не действует. Это относится к начертанию символов (полужирное, курсив, подчеркнутое, инверсное, перечеркнутое), форматированию регистра и индексов. Все эти атрибуты сохраняются при изменении стиля абзаца, поэтому локальное форматирование иногда называют жестким. Атрибутам, обладающим таким свойством, соответствуют кнопки на управляющей палитре в режиме Туре (Текст) под строкой выбора гарнитуры.

Взаимодействие жесткого и глобального форматирования имеет следующую особенность. Если в составе стиля определено начертание символов, а в тексте уже имеются участки, отформатированные этим начертанием, то при задании абзацу этого стиля возникнет эффект повторного форматирования символов и данный атрибут отменяется. Например, тексту, изображенному на рис. 6.5, придан стиль, предусматривающий курсивное начертание. Но в абзаце уже были слова, отформатированные курсивом. В результате перед нами абзац, набранный курсивом с группой слов прямого начертания (рис. 6.6).

Рис. 6.6. Результат форматирования абзаца стилем курсивного начертания

Существует возможность вмешиваться в процесс взаимодействия глобального и локального форматирования с помощью тех или иных комбинаций клавиш.

  • Если при задании абзацу нужного стиля необходимо сохранить все элементы местного форматирования, выполните щелчок мышью на имени стиля с одновременным удержанием клавиши <Shift>.
  • Если при выборе стиля в палитре стилей нажать и удержать комбинацию клавиш <Shift>+<Ctil>+<Space>, текст форматируемого абзаца примет нормальное начертание, независимо от того, какое локальное форматирование было в нем применено. Заметьте, что текст принимает не начертание стиля, а именно нормальное начертание символов. Таким образом, если вам необходимо отменить локальное форматирование абзаца, это можно сделать в два приема — сначала задать абзацу нужный стиль с удержанием комбинации клавиш <Shift>+<Ctrl>+<Space>. Текст примет нормальное начертание. Если в стиле и предусмотрено таковое, дело сделано. В противном случае нужно повторно придать тексту необходимый стиль.

Комбинация клавиш <Shift>+<Ctrl>+<Space> воздействует на все виды форматирования, кроме форматирования регистра и индексов. Локальное форматирование такого рода можно отменить вручную. Если в тексте встречается много элементов подобного форматирования и их нужно отменить, советуем вам воспользоваться таким несложным приемом.

В стиле форматируемого абзаца задайте значение регистра, соответствующее тому, которое вы хотите отменить. Если это капитель, то задайте написание капителью в стиле. Вы получите текст, набранный капителью целиком. Затем снова войдите в диалоговое окно редактирования стилей и задайте нормальный регистр символов. Текст потеряет форматирование капителью. О редактировании стилей см. разд. "Задание атрибутов символов и абзацев в стиле" данной главы.

Примечание

Чтобы задать стиль для абзацев текста, расположенного в публикации фрагментами, например для заголовков, иногда можно воспользоваться инструментом поиска и замены. В качестве объекта поиска задайте некую уникальную последовательность символов, встречающуюся только в искомых фрагментах текста. Если такой последовательности нет — значит, вам не повезло и придется просматривать текст вручную. Например, вы хотите задать стиль для заголовков первого уровня, и в каждом из них встречается слово "Глава", написанное с большой буквы с предшествующим ему возвратом каретки. Последовательно находя в тексте эту комбинацию, вы быстро зададите стиль для всех заголовков. Такой прием экономит время при верстке материалов, набранных в текстовых процессорах без применения стилей. Подробно инструменты поиска и замены рассмотрены в гл. 8.


Индикация стилей

Имена стилей публикации сведены в список. Этот список показан в палитре стилей, управляющей палитре, подменю Style (Стиль) меню Туре (Текст) и в одноименном подменю контекстного меню.

В любой момент можно узнать, какой из стилей применен к текущему абзацу. В палитре активный стиль помечен инверсным выделением. Для определения стиля абзаца достаточно установить в нем точку ввода и посмотреть на список стилей. В управляющей палитре имя активного стиля появляется в строке выбора стилей. В меню Style (Стиль) и в списке контекстного меню стиль, назначенный текущему абзацу, помечен галочкой (см. рис. 6.3 и 6.4).


Статус стиля

Во всех инструментах выбора стилей существует индикация статуса. Если рядом с именем стиля в списке стоит знак плюс (в палитре стилей — серый крестик), это означает, что к данному абзацу было дополнительно применено локальное форматирование, которое можно при необходимости отменить в палитре стилей однократным щелчком мыши на крестике (разумеется, если данное локальное форматирование поддается автоматической отмене — см. предыдущий раздел).

Если рядом с именем стиля в палитре стилей стоит пиктограмма дискеты, а в других списках — звездочка, это значит, что данный стиль был импортирован вместе со своей публикацией из другого приложения. Импортированный стиль отображается и печатается корректно, но не считается "своим", пока он не будет отредактирован внутри PageMaker. Подробнее об этой теме см. разд. "Задание атрибутов символов и абзацев в стиле" данной главы.

Рис. 6.7. Активный, импортированный и измененный стили в палитре. Меню палитры стилей

В редакторе материалов PageMaker можно определить режим отображения имен стилей для каждого абзаца (см. рис. 8.7). Режим показа имен стилей Display style names (Показать имена стилей) включается во вложенном окне More Preferences (Дополнительные установки) окна Preferences (Установки).

Кнопка со стрелкой в верхнем правом углу палитры стилей открывает меню палитры (рис. 6.7). Две последние команды меню относятся к режиму отображения статуса стиля — Display Overridden Icons (Показать модифицированные стили) и Display Imported Icons (Показать импортированные стили). Если эти команды включены, в строках палитры отображается статус стиля, в противном случае отображения статуса не происходит. Остальные команды мы рассмотрим по мере изучения материала.


Создание нового стиля. Редактирование стилей

По умолчанию во вновь созданной публикации уже имеется несколько стилей. Однако подавляющее большинство пользователей предпочитает создавать собственные. Тщательная разработка стилевого листа обеспечивает удобство и быстроту работы, когда почти вся верстка "делается сама", а верстальщику остается лишь подправить получившуюся в результате глобального форматирования публикацию и навести окончательный глянец.

Для организации работы со стилями — редактированием, созданием, импортом — в PageMaker существуют два диалоговых окна, которые показаны на рис. 6.8.

Рис. 6.8. Диалоговые окна Style Options


Диалоговое окно Define Styles

Главный пульт управления стилями — диалоговое окно Define Styles (Определить стили) — открывается командой Define Styles (Определить стили) меню Туре (Текст). Комбинация клавиш — <Ctrl>+<3> (три). В левой части окна находится список стилей публикации, снабженный полосой прокрутки. Если выбрать один из стилей списка, ниже появится его определение — несколько строчек текста, описывающих все заданные в стиле атрибуты форматирования. В правой части окна, кроме стандартных кнопок ОК и Cancel (Отменить), расположены еще четыре кнопки управления стилями:

  • New (Новый) — кнопка создания нового стиля. Она открывает диалоговое окно Style Options (Описание стиля). В пустой строке .ввода Name (Имя) наберите название нового стиля, а затем определите его атрибуты во вложенных диалоговых окнах.

Примечание

Если перед нажатием кнопки New (Новый) в списке стилей была выбрана строка [No style] ([Без стиля]), то создаваемый стиль будет построен, исходя из атрибутов активного (выделенного) абзаца. Если же в списке было выделено имя стиля, новый стиль создается по его образцу, при этом вновь созданный стиль базируется на старом (о базировании стилей см. ниже разд. "Диалоговое окно Style Options" данной главы).

  • Edit (Редактировать) — кнопка вызова окна редактирования существующего стиля. При этом в окне Style Options (Описание стиля) в строке ввода Name (Имя) указывается название выбранного в списке стиля абзаца. Если стиль абзаца не выбран, кнопка закрыта.
  • Remove (Удалить) — кнопка удаления выбранного стиля из публикации. Абзацам, отформатированным этим стилем, присваивается атрибут No style (Без стиля). При этом все элементы форматирования абзацев остаются теми же, только переходят в локальное форматирование.

Примечание

Эт а операция необратима, как и все операции со стилями, на нее не действует команда Undo (Отменить). При удалении стиля PageMaker ничего не переспрашивает, просто стиль исчезает из списка. Предосторожности элементарны: перед началом любых операций по редактированию каталога стилей сохраните файл, чтобы в случае неудачи командой Revert (Восстановить) вернуться к сохраненной копии. Если вы заметили ошибку, еще находясь в диалоговом окне Define Styles (Определить стили), отменить удаление стиля, как и любое неудачное форматирование, можно нажав кнопку Cancel (Отменить).

  • Import (Импортировать) — кнопка загрузки стилей из другой публикации. После щелчка на этой кнопке открывается стандартное файловое окно Windows с заголовком Import styles (Импортировать стили). Выберите в нем нужный каталог и публикацию, из которой будут импортированы стили. (Подробнее см. разд. "Импорт стилей" данной главы.)


Диалоговое окно Style Options

Щелчок на кнопке New (Новый) или Edit (Редактировать) диалогового окна Define Styles (Определить стили) откроет вложенное окно описания стиля (см. рис. 6.8).

Это же окно открывается в режиме создания стиля щелчком на строке [No style] ([Без стиля]) палитры стилей, а в режиме редактирования — двойным щелчком на имени нуждающегося в исправлении стиля. В управляющей палитре для перехода к окну Style Options (Описание стиля) нажмите клавишу <Ctrl> и, не отпуская ее, щелкните мышью на имени стиля (для редактирования) или на строке [No style] ([Без стиля]) (для создания нового).

Примечание

Чтобы быстро перейти к окну создания стиля, щелкните на пиктограмме ) (чистый лист бумаги) в нижней части палитры стилей. Для быстрого удаления стиля перетащите его строку на пиктограмму (мусорная корзина).

Управляют стилями и с помощью команд меню палитры Style: команда New Style (Новый стиль) открывает окно создания (рис. 6.7), Duplicate <имя стиля> (Создать копию стиля <имя стиля>) служит для организации дубликата выбранного стиля, Delete <имя стиля> (Удалить стиль <имя стиля>) — для удаления стиля из публикации, а команда Style Options (Параметры стиля) открывает окно редактирования стиля.

Итак, если вы хотите создать новый стиль, введите его название в строке Name (Имя). Дальнейшие действия одинаковы как для создания, так и для редактирования существующего в публикации стиля.

В левой части диалогового окна, под строкой имени стиля, находятся следующие поля ввода:

  • Based on (Основан на). Стиль, заданный в этом списке, является родительским для редактируемого. Изменения в базовом стиле автоматически распространяются на все дочерние. Дочерний стиль в свою очередь способен быть базовым для еще одного стиля, и система базирования в публикации может быть древовидной. Например, в публикации есть три стиля — Заголовок, Подзаголовок, Основной текст. Первый является базой для второго, второй — для третьего. Изменение форматирования первого повлечет за собой аналогичные изменения во втором и третьем. Изменение второго отразится только на третьем. Последний стиль можно менять как угодно, на первых двух это никак не отразится. В дочернем стиле возможно задавать его отличия от базового, и они будут сохраняться при изменениях в базовом стиле.

Примечание

Если вы верстаете публикацию со множеством стилей, тем более с применением технологии базирования, хорошей идеей представляется распечатка копии каталога стилей с полным их описанием на бумаге.

  • Next style (Следующий). Указанный здесь стиль автоматически присваивается абзацу, который вы создадите по окончании набора абзаца, имеющего редактируемый стиль. Например, при редактировании стиля Заголовок выберите последующим стиль Подзаголовок. Теперь, если набрать текст стилем Заголовок, а затем создать новый абзац нажатием клавиши <Enter>, вновь набираемый текст второго абзаца автоматически примет стиль Подзаголовок. Последовательность стилей ширдко используется в стилевых листах.

Примечание

Этот атрибут действует только на вновь вводимый текст. Если в готовом тексте отформатировать один из абзацев стилем Заголовок, то с нижележащими абзацами ничего не случится. Также ничего не произойдет, если набрать абзац стилем Заголовок в существующей публикации.


Задание атрибутов символов и абзацев в стиле

В правой части диалогового окна Style Options (Описание стиля) находится ряд кнопок. Щелчок на каждой из них вызывает окно редактирования соответствующих атрибутов стиля.

  • Char (Шрифт) — открывает окно Character Specifications (Параметры символа), в котором задаются кегль, начертание, интерлиньяж, регистр и другие атрибуты. После определения они распространяются на все символы всех абзацев, которым присвоен данный стиль.
  • Para (Абзац) — открывает окно Paragraph Specifications (Параметры абзаца).
  • Tabs (Табуляция) — вызывает линейку табуляции (см. гл. 5).
  • Hyph (Перенос ) — открывает окно установок переноса слов, эти атрибуты также могут входить в стиль (см. гл. 5).

После нажатия кнопки ОК отредактированный или вновь созданный стиль включается в список стилей публикации.

Примечание

Быстрое создание стиля с помощью управляющей палитры осуществляется следующим образом:

  1. Отформатируйте абзац локально с теми значениями атрибутов, которые вы бы хотели увидеть в новом стиле.
  2. Переведите фокус ввода на строку стилей управляющей палитры и введите название для нового стиля.
  3. Переведите фокус ввода обратно в главное окно PageMaker.

Новый стиль автоматически присваивается выделенному абзацу. Если введенное имя совпадает с уже имеющимся, PageMaker предложит назначить выделенному тексту уже существующий стиль.


Слияние двух стилей

Если определены лишние стили, может возникнуть необходимость их слияния, т. е. назначения абзацам одного стиля вместо двух разных. При слиянии стилей укажите, какой из них будет определять атрибуты абзаца после слияния (будет доминирующим). Откройте окно редактирования для доминирующего стиля. В строке имени сотрите его название и введите название стиля, который должен быть с ним слит (подавляемый). Щелкните на кнопке ОК. Программа запросит подтверждение ваших действий, открыв соответствующее окно (рис. 6.9).

Рис. 6.9. Диалоговое окно запроса подтверждения замены старого стиля новым

Помните, что описываемая операция необратима. Если вы уверены в своих действиях, щелкните на кнопке ОК. Редактируемый (доминирующий) стиль получил новое имя, а подавляемый исчез совсем: все абзацы, им отформатированные, приняли доминирующий стиль.


Импорт стилей

Удачно организованным каталогом стилей вы можете пользоваться для самых разных целей, просто импортируя его в публикацию, а затем модифицируя по мере необходимости.


Импорт из публикаций PageMaker

Для того чтобы импортировать стили из другой публикации, щелкните на кнопке Import (Импортировать) окна Define Styles (Определить стили). В стандартном системном окне (рис. 6.10) выберите нужную публикацию и щелкните на кнопке Open (Открыть). Весь каталог стилей из выбранного файла будет скопирован в текущую публикацию. При этом PageMaker спросит,

Рис. 6.10. Окно Import styles

Рис. 6.11. Предупреждение PageMaker о копировании импортируемых стилей поверх стилей публикации

нужно ли копировать стили поверх существующих в публикации (рис. 6.11). Если вы ответили "Да", то при совпадении имени произойдет слияние стилей и импортируемый стиль станет доминирующим. Стили с уникальными именами просто прибавятся к списку стилей данного документа. При отрицательном ответе в публикацию вносятся только стили с уникальными именами. Из другой публикации считывается сразу весь каталог стилей. Ограничиться импортом одного какого-то стиля, к сожалению, невозможно.

Загрузку стилей из другой публикации можно проводить и из меню палитры стилей, выбрав в ее меню команду Import Styles (Импортировать стили). Если вы верстаете гипертекст, в меню палитры есть специальная команда для автоматического импорта стилей HTML в каталог стилей публикации.


Импорт стилей из документов других программ

Если вы получаете файлы для верстки, подготовленные в текстовом процессоре, поддерживающем идеологию стилей, вместе с материалами легко импортировать и стили текстового редактора. Для этого достаточно перетащить файл из окна процессора в окно PageMaker (это возможно, если текстовый процессор поддерживает подобную операцию). Аналогичным образом можно перетаскивать текст через палитру библиотеки. К тому же результату приведет копирование текста в процессоре и вклеивание его в публикацию PageMaker. Наконец, программа позволяет импортировать текстовый файл с помощью команды Place (Поместить) меню File (Файл). И в этом случае вместе с текстом в публикацию попадают стили, использованные для его форматирования. В любом случае в каталог стилей переносятся лишь стили, использованные в копируемом отрывке.

Примечание

Если перенос текста производился из файла PageMaker, новые стили сразу становятся полноправными стилями публикации. При переносе текста из другого приложения скопированные стили получают статус импортированных и помечаются в списке стилей значком дискеты или звездочкой. Для того чтобы новый стиль стал "родным" PageMaker, откройте окно его редактирования и, если в нем не нужно заменять никаких атрибутов, сразу закройте его.

В том случае, если в импортируемом тексте имеются стили, совпадающие по названию со стилями целевой публикации, они игнорируются, а текст, отформатированный ими, принимает одноименный стиль публикации.

Иными словами, при импорте текста доминирует стиль целевой публикации, а не импортируемой.

Примечание

Чтобы импортировать из текстового процессора лишь стили без текста, создайте в нем несколько абзацев, содержащих единственный символ пробела, и отформатируйте каждый из них нужным вам стилем. После переноса этого пустого фрагмента в PageMaker в публикации появятся все необходимые стили и текстовый блок, состоящий из пробелов. После переноса сотрите ненужный больше "контейнер".

Подробно об импорте текстовых файлов рассказывается в гл. 7.

Рецепт. Создание каталога стилей публикации

Основное правило, которого нужно придерживаться, состоит в том, что если вы работаете с использованием каталога стилей, необходимо задавать стиль каждому абзацу публикации. В этом случае преимущества работы с глобальным форматированием будут наиболее ощутимы. Перед началом работы над публикацией определитесь, хотите ли вы сразу организовать всю систему стилей или собираетесь вводить новые стили по мере надобности. Затем продумайте удобную систему именования и строго придерживайтесь ее. При формировании каталога не забывайте сразу определять базовые и последующие стили. Если каталог получился удачным, на его основе разумно создать библиотеку стилей.

В большинстве случаев система стилей готовится заранее для минимума стилей абзацев, а затем при необходимости каталог дополняется и изменяется. Если вы собрались верстать издание с заголовками двух уровней вложенности, колонцифрами и эпиграфами перед основным текстом, целесообразно сразу назначить стили всем этим элементам. Если понадобится дополнительный стиль для подрисуночных подписей, вы сможете создать его и позже.

Запишите на бумаге список основных стилей для заголовков, определив основные атрибуты форматирования для каждого. Для проверки создайте развернутое оглавление публикации и отформатируйте все его элементы локально так, как вы хотели бы видеть эти заголовки в публикации. Таким образом легче проследить сочетание оформления разных абзацев. После уточнения форматирования заголовков разместите под ними пример основного текста, продумав для него атрибуты форматирования. В последнюю очередь подумайте, стоит ли вводить дополнительные стили для подрисуночных подписей, колонцифр, колонтитулов, таблиц и других''специальных элементов. Если да, то придумайте и их тоже.

При определении имен стилям опытные верстальщики придерживаются следующих правила.

  • В имени стиля обязательно должна быть отражена область его применения. Название "Стиль4" менее удачно, чем "Заголовок 2 уровня".
  • Чем чаще применяется стиль в публикации, тем выше его нужно поместить в списке палитры стилей. Поскольку в списке они размещены по алфавиту, стилям форматирования основного текста и подзаголовков следует дать имена на первые буквы алфавита, а редко используемые стили назвать на последние буквы.

Примечание

Приведите названия стилей в соответствие со стандартными именами стилей вашего любимого текстового процессора. В этом случае при импорте файлов из текстового процессора у вас не будет никаких проблем — стандартные стили будут автоматически заменены одноименными стилями публикации PageMaker.

Перед началом работы авторы удаляют стили по умолчанию. Первыми создайте базовые стили, на которых будут основаны все остальные, чаще всего это основной текст и заголовок первого уровня. Кстати, наиболее удобен метод создания по образцу выделенного текста (образец можно взять из примера оглавления, сделанного ранее).

Для стилей заголовков первого уровня задайте разбивку текста на страницы и включение абзацев данного стиля в оглавление. Если, например, требуется начинать каждую главу с новой страницы, включите это требование в стиль абзаца, для чего установите флажок Page break before (Новая страница) диалогового окна Paragraph Specifications (Параметры абзаца). После этого каждая часть публикации будет автоматически помещаться на новую страницу. Разбивка по страницам будет происходить автоматически. Чтобы абзац был представлен в оглавлении, установите флажок Include in table of contence (Включить в оглавление) того же окна.

Для заголовков всех уровней задайте в поле Keep with next ... lines (Удержать ... строк следующего абзаца) окна Paragraph Specifications (Параметры абзаца) число 2. Тогда заголовки не будут отрываться от последующего текста. Правда, эта опция создаст другие трудности — в таком режиме текстовые блоки на страницах публикации будут иметь неравную длину и их придется выравнивать вручную.

После того как базовые стили определены, создавайте остальные. Для заголовков имеет смысл базировать гарнитуру, тип выключки и другие атрибуты, предполагаемые общими для всех заголовочных абзацев. Это очень удобно для экспериментов в области оформления публикации. Скажем, для изменения гарнитуры всех заголовков достаточно изменить ее в базовом стиле. Не следует базировать атрибуты разбиения на страницы, отступы, включения в оглавление. Все они могут различаться в разных заголовках и задаются отдельно для каждого дочернего стиля.

Элементы оформления типа подписей под рисунками, колонцифр, колонтитулов, как правило, базируются на стиле основного текста. В качестве базового элемента здесь будет выступать гарнитура, иногда кегль и начертание.

Последовательность или наследование стилей целесообразно серьезно продумывать лишь в том случае, если вы собираетесь набирать текст прямо в программе. Режим наследования задают для основного текста, для заголовков первого уровня указывают последующий стиль заголовков второго уровня или основной текст, для подрисуночных подписей — последующий стиль основного текста.

Если вы собираетесь верстать публикации, в которых есть специальное форматирование, например рисунки, таблицы и базы данных, внимательно их изучите при создании каталога стилей. Можно ли вообще сверстать все элементы (таблицы, рисунки) непосредственно в PageMaker? Если это кажется возможным, создайте соответствующие стили. Так, в стиль для форматирования таблиц включите позиции табуляции, отступы и линейки абзацев. То же относится к базам данных. (О форматировании таблиц и баз данных см. гл. 16.) Если вы верстаете периодическое издание и таблицу нужно будет впоследствии редактировать, от верстки с применением позиций табуляции следует отказаться. Чаще всего невозможно оформить графические элементы в стилях, они вводятся потом, при окончательном размещении элементов публикации. Исключением являются графические элементы, выполненные символьными шрифтами, например элементы маркированного списка или виньетки. Для этих элементов можно и нужно задавать стиль, с указанием гарнитуры набора, кегля и разбиения на страницы. (О хранении материалов в палитре библиотеки см. гл. 14.)


Работа с библиотекой стилей

Если созданный стиль или весь каталог стилей получился удачным и его можно использовать в других публикациях, осуществить это можно разными способами.

  • Создание шаблона публикации. Новая публикация создается по шаблону с уже готовыми стилями. Вы также можете импортировать каталог стилей из шаблона в создаваемый документ. О шаблонах и работе с ними рассказывается в гл. 12.
  • Оформление процесса создания стиля в качестве сценария PageMaker. После запуска этого сценария в публикации сформируется описываемый им стиль.
  • Создание библиотеки стилей с помощью палитры библиотеки. Из палитры можно перетаскивать хранящиеся там объекты вместе с их стилями в текущую публикацию.

Примечание

Тем, кто только начинает работать с PageMaker, перед изучением дальнейшего материала советуем прочитать следующую главу, где даются определения текстового блока и размещения текста.

Для сохранения стиля в качестве элемента библиотеки авторы придерживались следующего порядка работы:

  1. Создается пустой текстовый блок, наберите в нем имя и краткую характеристику выбранного стиля. Отформатируйте получившийся абзац этим стилем.
  2. Откройте палитру библиотеки (рис. 6.12). Выберите команду New Library (Новая библиотека) из меню палитры. В открывшемся диалоговом окне задайте имя для новой библиотеки и папку для ее хранения.

Рис. 6.12. Палитра библиотеки с открытым меню палитры. В меню выбрана команда New Library

Инструментом Pointer (Стрелка) выберите созданный текстовый блок и щелкните на кнопке со знаком плюс в нижней части палитры библиотеки. Миниатюра с изображением выбранного фрагмента появится в окне палитры.

Сделайте двойной щелчок на появившейся миниатюре. В диалоговом окне Item information (Информация об объекте) (рис. 6.13) задайте имя объекта, описание и ключевые слова, которые необходимы в дальнейшем для поиска по библиотеке.

Примечание

При установленном в меню палитры переключателе Edit item afer adding (Редактировать новые элементы) диалоговое окно параметров объекта появляется каждый раз при добавлении объекта в библиотеку, так что любому новому объекту необходимо сразу задать имя и прочие характеристики. Если отключить режим редактирования новых элементов, то вновь новый объект будет появляться в библиотеке под именем Untitiled (Без имени) и для редактирования его свойств нужно будет специально вызывать окно параметров объекта.

Рис. 6.13. Окно параметров объекта библиотеки Item information

Если возникнет необходимость в применении стиля из библиотеки, для поиска нужного объекта используют команду Search Library (Найти элементы) меню палитры. Диалоговое окно Search library (Поиск в библиотеке) изображено на рис. 6.14. Поиск можно проводить по одному ключевому слову, по двум, связанным логическими операциями "и", "или", "кроме", по автору и по названию.

Если вы только начали создавать свою библиотеку, команда поиска вам не понадобится, поскольку в библиотеке еще мало объектов и все они хорошо видны в окне палитры. Найденный объект перетащите из палитры в окно документа. В каталоге стилей появятся все стили, использованные в данном фрагменте текста. Объект-контейнер после импорта удаляют. Стили вносятся в каталог публикации только в том случае, если в последнем нет стилей с теми же именами. В случае совпадения имен доминируют собственные стили публикации.

Рис. 6.14. Диалоговое окно поиска в библиотеке

В объектах-контейнерах можно хранить не один стиль, а несколько, и даже весь каталог стилей публикации, если по вашему мнению он может быть использован в других документах. Для этого отформатируете приготовленный для помещения в библиотеку фрагмент теми стилями, Которые вы хотите сохранить.


Резюме

В дальнейших главах мы продолжим изучение системы стилей применительно к различным аспектам верстки в PageMaker.

Использование стилей текстового процессора для последующей замены их стилями PageMaker — это хорошее средство автоматизации работы. Поэтому некоторое внимание будет уделено каталогу стилей в следующей главе.

В гл. 7 также будет рассмотрено применение стилей для работы в редакторе материалов. С помощью механизма поиска и замены и с использованием стилей можно автоматизировать значительную часть корректорской правки набора.

Технология стилей может быть успешно применена при верстке многостраничных документов, более того, при работе такого рода без грамотного применения стилей не обойтись. Эта тема рассмотрена в гл. 17.

Стили применяются и при верстке таблиц, которой уделено внимание в гл. 16.


  • Глава 7. Импорт текста
    • Текстовые блоки и материалы
    • Команда Place
    • Пиктограммы размещения текста
      • Ручное размещение
      • Автозаполнение
      • Полуавтоматическое размещение текста
    • Размещение текста
      • Размещение в границах полосы или колонки
      • Заказной текстовый блок
    • Операции с текстовыми блоками
      • Масштабирование и перемещение
      • Сколько должно быть блоков на странице?
      • Удаление связи между блоками
      • Связывание блоков
    • Импорт текста
      • Типы текстовых файлов
      • Фильтры импорта
      • Импорт файлов
      • Импорт файлов PageMaker
      • Дополнительные возможности фильтров
        • Импорт "сырых" текстовых файлов
        • Импорт файлов текстового процессора: Microsoft Word
      • Импорт в формате RTF
      • Импорт файлов предыдущих версий программы
      • Файлы со стилевой разметкой
    • Экспорт текстовых файлов из PageMaker
    • Установка и обновление фильтров
    • Связывание файлов
      • Разрыв связи
    • Резюме


ГЛАВА 7.

Импорт текста

В настоящей главе рассматриваются следующие вопросы:

  • Текстовые блоки, материалы PageMaker и операции с ними
  • Способы размещения текста
  • Фильтры импорта текстовых файлов
  • Связанные с публикацией внешние файлы и действия с ними

Поскольку основной задачей программы является построение макета публикации, идеология PageMaker основана на текстовых блоках — специальных "единицах хранения", которые вы можете произвольно размещать на странице. Помещение текста в блоки, а не в строки — наверное, самое важное отличие системы верстки от текстового процессора.


Текстовые блоки и материалы

Весь текст в программе, будь то несколько слов или тысячи страниц, размещается в блоках. Текстовый блок становится виден, если выделить текст на странице PageMaker инструментом Pointer (Стрелка). Сверху и снизу выделенного текстового блока (рис. 7.1) появляются горизонтальные линейки (границы блока) с индикаторами состояния текста вне блока. Выделенный блок можно перемещать, изменять размеры, поворачивать, в точности как графический объект. Практически, это контейнер, в который "налит" текст.

На странице может располагаться один или несколько текстовых блоков, изолированных или связанных в цепочку. Один изолированный текстовый блок или последовательность связанных друг с другом блоков образуют материал. В связанных блоках текст размещается подобно жидкости, заполняющей высокий сосуд. Текст наполняет первый текстовый блок целиком, перетекает в следующий, заполнив его — в следующий и т. д. Если изменить размеры текстового блока в цепочке (кроме последнего), текст материала переместится так, чтобы снова максимально заполнить каждый из блоков (рис. 7.2, а). На рисунке представлено три текстовых блока, связанных в единый материал.

а

б

Рис. 7.1. Текст, выделенный инструментом Туре (а), и тот же текст, как текстовый блок (б)

Примечание

При верстке книги последовательность расположения блоков цепочки элементарна; в газетах и журналах размещение связанных блоков одного материала часто весьма прихотливо. Текст может начинаться на третьей странице, потом прерываться и продолжаться на пятой. И в том и в другом случае материал текста перемещается между блоками, заполняя их наиболее компактным образом.

Для изменения числа строк в блоке (вертикального размера) выберите инструмент Pointer (Стрелка) и перетащите индикатор состояния блока вверх или вниз. По мере увеличения или уменьшения текстового блока текст втягивается в него из других материалов или выдавливается в них. Символы внутри индикаторов обозначают состояние текста вне текущего текстового блока.

  • Пустой индикатор — за пределами границы блока нет больше текста.
  • Знак плюс указывает, что данный текстовый блок находится в цепочке связанных блоков.
  • Красная стрелка вниз на нижней границе блока означает, что за его пределами есть неразмещенный текст.

На рис 7.2, б показан результат воздействия на размер текстового блока, входящего в цепочку блоков одного материала. Второй текстовый блок уменьшили перетаскиванием его нижней границы вверх. На первый блок это никак не повлияло. Поскольку второй блок уменьшился, материал перестал в нем помещаться и "выдавился" в следующий блок. В результате материала в третьем блоке сделалось слишком много. Сам текстовый блок не может расти при увеличении объема текста в нем. Поэтому не поместившийся материал уходит за границы текстового блока и становится неразмещенным. На нижней границе последнего блока появляется индикатор с красной стрелкой вниз, говорящей о том, что необходимо создать еще один блок и разместить в нем оставшийся текст.

а

б

Рис. 7.2. Цепочка из трех сцепленных текстовых блоков (а). Перетекание текста в цепочке при изменении размеров блока (б)

Вертикальные линии на рис. 7.2 называются границами колонки. Об этих элементах форматирования подробно рассказывается в гл. 13. При размещении текста он располагается в пространстве, ограниченном границами колонки, если вы не укажете ему другого расположения.


Команда Place

Команда Place (Поместить) находится в меню File (Файл). Она вызывает на экран диалоговое окно импорта файлов Place (Поместить). Это окно открывается также комбинацией клавиш <Ctrl>+<D>. Как вы можете видеть из рис. 7.3, это стандартное диалоговое окно Windows. В нем следует выбрать файл, который необходимо поместить в публикацию.

Весь импортируемый материал помещается в оперативную память. После щелчка указателем в окне документа текст будет размещен. Программа имеет три режима размещения текста — ручной, автоматический и полуавтоматический. Каждому из них соответствует определенный вид курсора

Рис. 7.3. Диалоговое окно Place


Пиктограммы размещения текста

Текст в программе может размещаться при импорте в одном из режимов — автоматическом, полуавтоматическом и ручном. Каждому режиму соответствует свой вид указателя (рис. 7.4).

Рис. 7.4. Пиктограммы размещения текста — ручной режим


Ручное размещение

Размещение текста в ручном режиме наиболее трудоемко. После щелчка на странице весь текст попадает в первый текстовый блок. Для того чтобы разместить его на следующей странице, необходимо щелкнуть на индикаторе избыточного текста, перейти на следующую страницу публикации и снова щелкнуть.

В данном режиме есть возможность размещать текст в блоках произвольного размера. Для этого нужно подвести готовый к размещению указатель к месту на странице или на монтажном столе, где по вашему мнению должен размещаться текстовый блок, и протащить его по странице. После того как вы отпустите кнопку мыши, будет создан текстовый блок, заполненный импортированным текстом.

Если при размещении просто щелкнуть мышью между границами колонки, текст, содержавшийся в пиктограмме ручного размещения, заполняет колонку вниз от места щелчка до нижнего поля страницы или до другого текстового блока. При этом ширина текстового блока будет соответствовать ширине колонки или страницы.

Для того чтобы размещать текст в ручном режиме, снимите флажок Autoflow (Автозаполнение) в меню Layout (Макет). Для временного перехода на ручное заполнение от автоматического нажмите клавишу <Ctrl>.


Автозаполнение

При автоматическом размещении после первого щелчка программа размещает в публикации весь импортированный текст. Он размещается в границах полос набора и автоматически переходит с колонки на колонку и со страницы на страницу. При необходимости в конец публикации добавляются новые страницы.

Режим включается установкой флажка Autoflow (Автозаполнение) в меню Layout (Макет). Для того чтобы временно сменить режим ручного размещения текста на автоматический режим, нажмите и не отпускайте клавишу <Ctrl>. При смене режимов размещения текста меняются и пиктограммы размещения.

Автоматический режим удобен для начального размещения большого материала, занимающего много страниц — например, главы книги или технического отчета. В случае сложного размещения текста на странице (например, в иллюстрированном журнале) такой режим неприменим.


Полуавтоматическое размещение текста

В этом режиме после щелчка мышью в пределах страницы или колонки текст автоматически размещается до ее нижнего края или до границы другого текстового блока. Однако после размещения очередной порции текста программа сразу готова к размещению следующей. Страницы в публикацию сами по себе не добавляются. Полуавтоматическим режимом удобно пользоваться для ускоренного размещения текста в сложных макетах. Для перехода к этому режиму следует в процессе размещения текста нажать и удерживать клавишу <Shift>.

Каждый инструмент пригодится для своих целей. Никто не размещает вручную текст художественной книги без иллюстраций размером в 500 страниц. Однако при верстке небольших публикаций и изданий со сложным размещением текстовых блоков (газет, журналов, каталогов) автоматический режим лишь помешает, поэтому лучше отдать предпочтение ручному или полуавтоматическому.


Размещение текста

Готовый к размещению текст, находящийся в буфере, кладут на страницу одним из двух способов.

  • Щелкните в пространстве между границами колонок. Текст заполнит это пространство.
  • Нажмите левую кнопку мыши и протащите курсор, создавая растущий прямоугольник. Когда вы отпустите кнопку мыши, программа создаст текстовый блок указанного размера и заполнит его текстом.


Размещение в границах полосы или колонки

После импорта текста командой Place (Поместить) и щелчка мышью в пространстве между границами колонки свободное пространство между границами при любом режиме размещения станет заполняться текстом, начиная от уровня щелчка. Когда при размещении PageMaker натыкается на препятствие — поля страницы, графический объект (если для него установлен режим обтекания текстом), другой текстовый блок — его поведение зависит от выбора пиктограммы размещения.

При ручном режиме размещения граница текста доводится до препятствия. Затем размещение текста приостанавливается. Индикатор на нижней границе блока принимает форму красной стрелки вниз (наличие неразмещенного текста), курсор из пиктограммы переходит в режим стрелки. Чтобы продолжить размещение текста, нужно щелкнуть на индикаторе неразмещенного текста и задать точку начала следующего текстового блока цепочки.

При полуавтоматическом режиме (переход в него из любого режима выполняется при удержании клавиши <Shift>) граница текстового блока доходит до препятствия, затем размещение текста приостанавливается, но пиктограмма размещения остается загруженной.

При автозаполнении текст размещается до препятствия, затем текстовый блок обрывается и автоматически создается следующий, ниже препятствия и до конца полосы, потом происходит автоматический переход на следующую полосу или колонку и т. д., пока не будет размещен весь текст. Если при размещении в публикации не хватило страниц, они автоматически добавляются.

Если установить в диалоговом окне More Preferences (Дополнительные установки) флажок Turn pages when autoflowing (Листать страницы при автозаполнении), скорость процесса автоматического размещения будет искусст--венно снижена. Каждая заполняемая страница будет отображаться на экране, что позволит проконтролировать правильность заполнения.

Примечание

Бывают случаи, когда необходимо временно прервать размещение текста. Если хотя бы один текстовый блок уже размещен на соответствующей странице, можно просто выбрать другой инструмент. Для этого щелкните мышью на любой кнопке палитры инструментов — выбранный инструмент заменит пиктограмму размещения текста. При полностью неразмещенном тексте (нет ни одного текстового блока, содержащего импортируемый текст) нужно организовать временный контейнер для хранения текста на монтажном столе. Для этого создайте приемом протаскивания курсора пиктограммы размещения заказной текстовый блок, можно совсем маленький, но не нулевой, в нем должен помещаться хоть один символ импортированного текста. И в том, и в другом случае в индикаторе на нижней границе последнего размещенного текстового блока появится стрелка вниз. Для того чтобы впоследствии возобновить процесс размещения текста, выполните на этой стрелке щелчок мышью.

Если вы только что импортировали новый текст и не успели разместить его ни в одном из текстовых блоков, выбор любого из инструментов программы PageMaker приведет к полной отмене команды Place (Поместить). Импортированный текст будет утрачен, и для возобновления размещения текста придется снова выбирать команду Place (Поместить).


Заказной текстовый блок

Для создания блока заданных размеров протащите курсор мыши из одного угла предполагаемой области размещения в другой. Удобнее всего перетаскивать пиктограмму из левого верхнего угла создаваемого текстового блока в правый нижний угол (рис. 7.5). Границы колонок никак не влияют на процесс протаскивания.

При создании заказного текстового блока любой режим размещения временно переходит в ручной. После построения блока восстанавливается первоначальный режим размещения. Можно использовать заказной блок даже при автозаполнении. Так, например, если вы выкладываете в публикацию текст книги, можно сформировать первый блок вручную — для названия, а затем перейти на другую страницу и начать автозаполнение.

Рис. 7.5. Создание текстового блока заданных размеров

Заказные текстовые блоки можно создавать при помощи инструмента Туре (Текст) для вновь набираемого текста. Методика работы при этом аналогична.


Операции с текстовыми блоками

С текстовыми блоками можно выполнять разнообразные операции — изменять их размеры, перемещать, поворачивать. Отдельные блоки можно связывать в цепочки или разрывать существующие связи. В этом разделе рассмотрены операции изменения размеров блоков, установка и разрыв связи. О вращении и перемещении текстовых блоков читайте в гл. 14.


Масштабирование и перемещение

При изменении размеров блока параметры текста внутри него (кегль, ширина символов и т. д.) никак не меняются. Текст внутри блока лишь перекомпонуется, приспосабливаясь к изменившимся размерам контейнера.

Чтобы изменить вертикальный размер блока, перетащите индикатор заполнения на одной из его сторон по вертикали. Для масштабирования по горизонтали или в обоих измерениях перетащите одну из жирных черных точек на концах верхней и нижней границ блока (рис. 7.6).

а

б

Рис. 7.6. Изменение размеров текстового блока: а — регулировка высоты блока смещением границы текста, б — изменение размеров блока в двух измерениях

Текстовый блок всегда заполнен целиком, поэтому невозможно увеличить его размеры как угодно. Если текста, находящегося внутри блока, не хватает на заполнение в указанных границах, PageMaker создаст блок короче заказанного. Если вы уменьшите блок, текст из него "вытечет", поскольку для его размещения в изменившихся границах не хватит места. В случае уменьшения размеров блока, входящего в цепочку, текст "перетечет" в следующий сцепленный блок. Перетекание затрагивает все блоки цепочки, и последний блок автоматически вырастает. Если изменяемый блок является изолированным или последним в цепочке, нижний индикатор на границе блока принимает вид красной стрелки вниз (неразмещенный текст). При увеличении размеров блока текст втягивается в него из последующих блоков, а последний блок в цепочке становится меньше.

Увеличить размер индивидуального текстового блока или последнего блока цепочки невозможно, поскольку больше нет текста для его заполнения. Передвигая границы такого блока, можно лишь изменить его форму, т. е. соотношение ширины и высоты, или расположение на странице.


Сколько должно быть блоков на странице?

Разбив материал на небольшие текстовые блоки, можно добиться верстки любой сложности. Однако малейшее изменение размеров любого из блоков или просто ввод еще одного символа в текст может привести к перекомпоновке материала и вся верстка "утечет" из нужных блоков. Мелкие блоки трудно устанавливать точно, это приведет к неряшливому виду текста — неодинаковому интерлиньяжу, неровной выключке по вертикали, кривым колонкам. Страшно подумать, что будет с таким текстом при изменении интерлиньяжа или кегля набора.

В идеале блоков на странице должно быть столько же, сколько вертикальных колонок, т. е. в случае однополосной верстки — один. Необходимые эффекты достигаются введением вложенной графики и установок режима обтекания графики текстом. В отдельные блоки при однополосной верстке помещаются только сноски, колонцифры, колонтитулы и врезки (если таковые имеются).

Не размещайте центрированные заголовки ваших публикаций в отдельных маленьких блоках, установленных вручную по центру страницы. Ширину блока для заголовка определяйте равной ширине страницы или колонки. Текст внутри блока выровняйте по центру. Если заголовок находится на той же странице что и дальнейший текст, то не создавайте дополнительного блока вовсе — вместо этого наберите заголовок в основном текстовом блоке и задайте его положение отбивками и перемещением верхней границы блока.

Случаются ситуации, когда хочется, чтобы при изменении размеров текстовых блоков менялись размеры и самих символов. Наиболее простой пример — это изменение параметров полосы набора. Вы сверстали текст, разместили рисунки, публикация готова к печати, но в последний момент выяснилось, что полоса набора имеет немного другие измерения. При переверстке на другой размер полосы все тонкие настройки текста уничтожатся, а рисунки придется размещать заново. В PageMaker нет инструмента для масштабирования текстовых блоков и страниц, но разработчики дополнений предлагают соответствующие программы. Пример — продукт PageScaler, входящий в комплект дополнений PageMaker, выпущенный фирмой Extensis. О масштабировании объектов мы поговорим подробнее в гл. 14.


Удаление связи между блоками

Текстовые блоки одного материала связаны в цепочку, при этом текст свободно "переливается" из одного блока в другой (рис. 7.7). Символы плюса в индикаторах границ блоков говорят о том, что каждый из них входит в состав цепочки, составляющей единый материал.

а

б

Рис. 7.7. а — три блока связаны в цепочку, б — изменение размеров первого блока приводит к смещению текста в остальных блоках

Для разрыва связи между блоками инструментом Pointer (Стрелка) выберите текстовый блок цепочки и вырежьте его командой Cut (Вырезать). При этом блок попадает в общий системный буфер Windows. Комбинация клавиш для этой команды — <Ctrl>+<X>. После этого вклейте данный блок на то же место командой Paste (Вклеить). Комбинация клавиш команды вклеивания — <Ctrl>+<V>. Текстовый блок вновь появится на странице, но не будет входить в состав цепочки, а станет отдельным объектом. Команда Paste (Вклеить) помещает объект со сдвигом относительно его исходного положения. Для того чтобы вклеить вырезанный текстовый блок на то место, откуда он был вырезан, воспользуйтесь командой специальной вклейки (комбинация клавиш <Ctrl>+<Shift>+<V>).

а

б

Рис. 7.8. Отцепленный текстовый блок (а). * Текст перетекает между блоками, оставшимися в цепочке (б)

Если вы вырезаете блок, находящийся между двумя другими (как показано на рис. 7.7), то оставшиеся блоки будут соединены между собой, т. е. целостность цепочки сохранится.

На рис. 7.8 представлены те же три текстовых блока, но теперь текстовый блок, расположенный посередине, "отцеплен" от остальных двух. В индикаторах его верхней и нижней границы отсутствуют какие-либо символы, и это говорит о том, что весь материал размещен в текстовом блоке полностью и что блок не сцеплен с другими текстовыми блоками. Остальные два блока остались сцеплены друг с другом, что видно по плюсам в индикаторах нижней границы левого и верхней границы правого блоков. Такой прием называется выведение блока из материала.


Связывание блоков

Для того чтобы ввести изолированный блок в материал, используют один из двух способов:

  • В текстовом режиме выберите весь материал блока и поместите его в буфер командой Cut (Вырезать), затем установите точку ввода в нужном блоке и вклейте текст из буфера. Если в вырезанном блоке находился неразмещенный текст, он будет вырезан и вклеен так же, как размещенный.
  • Выберите изолированный блок инструментом Pointer (Стрелка) и вырежьте его. После этого перейдите в текстовый режим и вклейте текст в нужный блок. В этом случае копируется только видимый текст, а не размещенный будет утерян.


Импорт текста

Формат — это способ кодирования информации. От формата файла зависит, какую информацию можно хранить в этом файле и каким образом будет осуществляться чтение/запись. В системе Windows судить о формате файла данных можно по его расширению. Все файлы одного формата имеют одинаковое расширение имени.

Каждый разработчик программного обеспечения придумывает свой способ кодирования, свой формат файлов данных, который лучше всего отвечает задачам, выполняемым данной программой. Формат графических файлов TIFF позволяет хранить информацию о цветовых каналах и треппинге, а для файлов, создаваемых в текстовом редакторе, эта информация совершенно не нужна, зато в нем хранятся данные о начертании символов и использованной гарнитуре. Форматы файлов патентованы, например сторонний производитель не может выпустить текстовый редактор, создающий файлы в формате Microsoft Word.


Типы текстовых файлов

Если говорить о форматах текстовых файлов, их можно разделить на два типа. Собственно текстовые файлы, имеющие расширение txt, содержащие только сведения о символах. Каждому символу соответствует стандартный код. Существует несколько таблиц кодировки. В таблице кодировки каждому символу латинского алфавита присвоен уникальный двоичный код. Для символов национальных алфавитов в странах, где они используются (в частности, для кириллицы), применяются расширенные кодовые страницы.

К наиболее распространенным текстовым форматам относятся ASCII (American Standart Code for Information Interchange), ANSI (American National Standart Insitiute) и Unicode-файлы. Они имеют разные кодовые таблицы. Полученный файл будет обладать рядом недостатков. Формат ASCII — это базовый уровень представления текстовой информации, он един для всех программных средств, работающих с текстами. В тексте ASCII нет полужирного и курсивного начертания, отсутствует система гарнитур и кеглей (только один, стандартный). В нем нет отступов, и, как правило, каждая строка в этом документе представляет собой отдельный абзац.

Второй тип, условно относимый к текстовым, — это файлы с форматированием. В формате этих файлов содержится не только информация об их содержании, т. е. о символах, но и о способе представления этих символов, т. е. шрифтах, кеглях, начертаниях, разбивке на абзацы и страницы, размере полосы набора, иногда о стилях абзацев и символов В общем, обо всех элементах форматирования, выполненных в данном тексте. Файлы с форматированием создаются в текстовых процессорах различного класса.

Особое место занимают текстовые файлы со стилевой разметкой — Tagged Format — в них сохраняется стилевая разметка, а полученный файл имеет расширение txt, являясь обычным ASCII-файлом.

Для того чтобы конвертировать файлы из одних форматов в другие, используют фильтры импорта и экспорта.


Фильтры импорта

Фильтр импорта представляет собой программу, осуществляющую перевод файла из формата стороннего приложения во внутреннее представление PageMaker, по возможности сохраняя форматирование, выполненное в исходном процессоре. PageMaker по своей природе предназначен для обработки файлов разных форматов, поэтому у него этих фильтров импорта очень много. Программа выбирает фильтр импорта автоматически, по расширению имени файла с текстом.

Чтобы узнать, какие фильтры импорта установлены на вашем компьютере, выберите команду About PageMaker® (О программе PageMaker®) меню Help (Помощь), удерживая нажатой клавишу <Ctrl>. На экране появится окно, представленное на рис. 7.9. В начале списка перечислены установленные дополнения PageMaker. Прокрутив список далее, вы увидите перечень всех фильтров импорта для текстовых файлов и для графических материалов.

Рис. 7.9. Список установленных фильтров и дополнений PageMaker

В этом списке представлены только установленные фильтры. Чтобы узнать, какие фильтры вообще входят в ваш комплект PageMaker, прочтите текст, расположенный в файле Readme на одном из дистрибутивных дисков. Воспользуйтесь контекстным поиском по словам "формат" или "импорт".


Импорт файлов

Форматирование импортированного текста в большинстве случаев сохраняется удовлетворительно. Так, при наличии в тексте выделений курсивом, подчеркиванием, полужирным они конвертируются в PageMaker без потерь. Обводки и линейки абзацев, элементы предметного указателя, т. е. нестандартные атрибуты форматирования, переходят в PageMaker не из любого текстового процессора. Если в текстовом процессоре есть поддержка механизма стилей, то в большинстве случаев стили абзацев переходят в публикацию PageMaker вместе с импортируемым текстом.

При подготовке файлов для верстки полезно заранее проверить наличие и качество фильтра импорта для файла, отформатированного именно так, как предполагается оформлять все набираемые материалы. Если вы собираетесь верстать большое издание, необходимо договориться с наборщиком о формате представления файлов. Также обсудите, может ли наборщик разметить стили абзацев, сделать выделения курсивом и полужирным, набрать полиграфические кавычки, дефисы и тире, круглые скобки, выполнить другую необходимую подготовительную работу.


Импорт файлов PageMaker

Как уже было отмечено, импорт в PageMaker осуществляется командой Place (Поместить). По этой команде открывается одноименное диалоговое окно. Если перед его открытием был выбран инструмент Туре (Текст), то окно импорта будет ориентировано на импорт текстовых файлов.

В поле Place (Поместить) находится переключатель режима импорта, имеющий три положения: As new story (Как новый материал), Replacing entire story (Вместо целого материала), Inserting text (В существующий текст). В режиме макета можно импортировать текст только как новый материал с последующим размещением, а при импорте в редакторе материалов можно заменять один текст другим или вставлять импортируемый текст в уже существующие блоки. Размещение текста по блокам в двух последних случаях происходит автоматически. На рис. 7.10 представлены два варианта окна импорта файлов — при импорте в режиме макета и в редакторе материалов.

В области Options (Варианты) при импорте текста доступны следующие режимы:

  • Retain format (Импортировать формат) — сохранение форматирования, выполненного в стороннем приложении (при снятом флажке импортируется только текст без форматирования);

Рис. 7.10. Диалоговое окно импорта файлов при импорте в редактор материалов

Рис. 7.10. Диалоговое окно импорта файлов при импорте в макет

  • Convert quotes (Изменить кавычки) — замена прямых кавычек полиграфическими, а двойных минусов — полиграфическими тире (удобно при импорте ASCII-файлов);
  • Read tags (Читать стилевую разметку) — чтение и выполнение инструкций, содержащихся в тэгах. При снятом флажке тэги импортируются как символы текста.


Дополнительные возможности фильтров

При установленном в окне импорта флажке Show filter preferences (Показать установки фильтра) после выбора файла для импорта открывается окно дополнительных возможностей фильтра импорта данного формата. (К тому же эффекту приводит нажатие клавиши <Shift> при открытии импортируемого файла.) Окно дополнительных возможностей импорта, разумеется, будет разным для каждого формата. Установки, сделанные в диалоговом окне настройки фильтра, сохраняются до конца текущего сеанса работы с программой PageMaker.


Импорт "сырых" текстовых файлов

Вообще говоря, это очень неудобный формат для импорта, поскольку при этом придется делать массу работы по предварительному форматированию текста (убирать лишние пробелы, возвраты кареток, заменять тире и кавычки, проставлять начертания символов, стили и др.). Форматом ASCII (и любым текстовым форматом) рекомендуется пользоваться, только если иного выхода нет, например при отсутствии фильтра импорта PageMaker для исходного приложения.

На рис. 7.11 представлено диалоговое окно настройки фильтра импорта текстового файла. Основное достоинство фильтра — возможность работы с различными текстовыми форматами. Установите переключатель Encoding (Кодировка) в положение, соответствующее кодировке вашего файла.

Кроме того, настройки фильтра позволяют в процессе импорта провести подготовительную обработку текста. Например, в большинстве случаев в конце каждой из строк текстового файла стоит символ возврата каретки. При установке соответствующих флажков фильтр удаляет подряд идущие символы возврата каретки, вставленные в текст для разделения абзацев по вертикали, и сохраняет форматирование таблиц и перечней, которые ему удается распознать (форматирование таблиц происходит с помощью табуляции).

Рис. 7.11. Фильтр программы PageMaker для импортирования неотформатированного текста ASCII

Для регулировки положения слов в строке текстового файла часто встречаются смежные пробелы, поскольку этот формат не предусматривает позиций табуляции. Можно задать число смежных пробелов, которые должны заменяться символом табуляции при импортировании текста. По умолчанию это число равно трем, но есть смысл просмотреть исходный файл и сделать его равным абзацному отступу, принятому наборщиком. Скорее всего, это число равно пяти (стандартный абзацный отступ при печати на пишущей машинке).

Если текст в исходном приложении был набран моноширинной гарнитурой и в нем есть разбиение на колонки, необходимо отформатировать текст моноширинной гарнитурой (типа Courier) и в PageMaker. Это позволит сохранить структуру колонок в импортируемом тексте, которые в случае использования пропорциональных шрифтов будут перекошены до неузнаваемости. Если вы хотите, чтобы программа PageMaker назначала для форматирования импортированного текста моноширинную гарнитуру (типа Courier), установите флажок Keep Tables, Lists and Indents as is (Сохранять таблицы, списки и отступы).


Импорт файлов текстового процессора: Microsoft Word

Для предварительной настройки файла в процессе импорта существует следующее диалоговое окно фильтра (рис. 7.12).

Рис. 7.12. Настройка фильтра импорта файла в формате Microsoft Word

В области Include (Включить) определите, какие дополнительные части файла будут импортированы. В любом случае в публикацию помещается основной текст. Переводы названий флажков даны ниже:

  • Table of Contents Text (Текст оглавления);
  • Index Text (Текст предметного указателя);
  • Import Table(s) Text (Импортировать текст таблиц);
  • Footnotes/Endnotes (Сноски/Затекстовые ссылки).

Для замены увеличенных/уменьшенных пробелов, выполненных в Word для организации выключки, при импорте можно пользоваться разными методами — установкой ширины символов, кернингом и трекингом. Для определения способа трансформации служит переключатель Condensed/Expanded Spacing to (Импортировать сжатые/расширенные пробелы как).

Переключатель Page Break Before Paragraph as (Импортировать конец страницы перед абзацем) определяет, следует ли помещать в публикацию сведения о разбиении текста на страницы и каким образом это следует делать. В обеих программах имеется возможность установить при форматировании абзаца переход на новую страницу с помощью команды As page break before (Как атрибут "Новая страница"), но в программе PageMaker имеется также возможность заказать размещение абзаца с начала новой колонки As column break before (Как атрибут "Новая колонка").


Импорт в формате RTF

Считается, что текст в формате RTF уже обладает всеми необходимыми элементами форматирования. Вы не можете воздействовать на процесс с помощью установок фильтра, все действия по импорту такого текста выполняются автоматически с учетом установок импорта, заданных в основном диалоговом окне.


Импорт файлов предыдущих версий программы

Команда Place (Поместить) используется и для импорта отдельных материалов из файлов PageMaker предыдущих версий. При импорте материала сохраняется его форматирование, но не вложенная графика. На рис. 7.13 представлено диалоговое окно этого фильтра.

Рис. 7.13. Установки импорта материалов PageMaker и окно просмотра материала

Здесь перечислены материалы, найденные в публикации PageMaker, выбранной в диалоговом окне команды Place (Поместить). У материалов нет имен, и в список помешается несколько первых слов каждого из обнаруженных материалов. Для того чтобы выделить материал для размещения или просмотра, щелкните мышью на соответствующей ему строке. Для того чтобы выделить все материалы публикации, щелкните на кнопке Select all (Выделить все).

Фильтр импорта материалов программы PageMaker можно настроить так, чтобы он показывал в списке только материалы, превышающие определенную длину. По умолчанию это значение равно 20. Если из большого документа необходимо импортировать несколько материалов, увеличьте это значение, чтобы элементы оформления (колонтитулы, колонцифры и т. д.) не попали в список. После изменения длины материала выполните щелчок мышью на кнопке Relist (Обновить) — список обнаруженных в публикации материалов будет перестроен в соответствии с заданной установкой.

После щелчка на кнопке View (Просмотр) текст материала появится на экране в отдельном окне просмотра. В нем можно выбирать и копировать любую часть или весь текст. При этом форматирование утрачивается.

Примечания

Применение фильтра импорта материалов — это аварийный способ извлечения материалов из поврежденной публикации. Даже в том случае, если поместить материал обычным образом не удается, можно попробовать сохранить хотя бы текст. Для этого выбирайте по очереди нужные материалы и копируйте их из окна просмотра через системный буфер в новый файл. О проблемах, возникающих при работе с PageMaker, и способах их решения с/и. приложение 1.


Файлы со стилевой разметкой

Тэги (стилевая разметка) — это специальные символы, вставляемые в набираемый текст, если набор выполняется в процессоре, не поддерживающем стилей абзацев. В результате получается текстовый файл, но в нем в явном виде, прямо в теле текста, присутствуют команды форматирования. Потом, при импорте, вы включаете флажок Read tags (Читать стилевую разметку) и PageMaker выполняет команды стилевой разметки для файла. В результате в публикации появляется глобальное форматирование. Тэги необходимы, если материал готовится в нестандартном редакторе, и могут быть импортированы только как текстовые файлы. На рис. 7.14 представлен фрагмент текста,

Рис. 7.14. Текст, размеченный тэгами стилей

размеченный тэгами. Действие тэга продолжается до следующего тэга. При наборе имени стиля имеет значение регистр набора.

PageMaker, начиная с версии 6.0, понимает язык тэгов QuarkExpress, очень популярного издательского пакета.


Экспорт текстовых файлов из PageMaker

Вы можете полностью или частично сохранить любой материал программы PageMaker в файле, а затем использовать полученный файл в других программах. Вложенные изображения (за исключением PICT-изображений на платформе Macintosh) не экспортируются вместе с материалом. Экспорт текстовых материалов производится только в текстовом режиме с установленной точкой вставки внутри нужного материала или из окна редактора материалов. Каждый материал экспортируется как отдельный документ. В меню File (Файл) выберите команду Export (Экспорт) и во вложенном меню — команду Text (Текст). На рис. 7.15 представлено диалоговое окно Export Document (Экспортировать документ).

Рис. 7.15. Диалоговое окно Export Document с открытым списком доступных форматов экспорта

В раскрывающемся списке Save as type (Сохранить в формате), расположенном в нижней части диалогового окна, выберите формат, в котором будет представлен экспортированный текст (размеченный стилевой разметкой, RTF, текстовый и пр.). В зависимости от выбранного формата решите, как сохранять форматирование экспортируемого текста (например, вставлять ли в экспортируемый текст тэги стиля).


Установка и обновление фильтров

Если нужный фильтр импорта (экспорта) не установлен, но есть на диске программы, установите дистрибутивный диск и запустите команду Setup (Старт). Затем выберите нужные фильтры, и они автоматически будут установлены в соответствующую папку.

Если фильтр отсутствует на диске, но вы его все же добыли, придется устанавливать его вручную. Перенесите файл фильтра в языковой каталог (его имя будет зависеть от языка, выбранного при установке PageMaker, см. приложение 1) в папку Filters (Фильтры). Для того чтобы установленный фильтр заработал, перезагрузите PageMaker.

При обновлении версий программных продуктов необходимо обновлять и их фильтры импорта в PageMaker, в противном случае он "не поймет" формата файла, сделанного в приложении, которое выпущено позднее, чем текущая версия PageMaker. Для того чтобы быть в курсе последних новостей, прибегайте к услугам Интернета и почаще заходите на сайт фирмы Adobe. Его адрес www.adobe.com. Приобретенный фильтр устанавливается, разумеется, вручную.


Связывание файлов

При импорте текстового файла в публикацию размещенный текст остается связанным с исходным файлом. Эта связь разрушается только принудительно. Казалось бы, хорошо, если размещенный текст можно автоматически приводить в соответствие с новой редакцией текстового файла. К сожалению, поскольку и в PageMaker, и в текстовом процессоре можно осуществлять редактирование и форматирование текста, идея связывания текстовых файлов с материалами публикации не так хороша, как представляется на первый взгляд.

Механизму связывания файлов, типам связей и соответствующим инструментам PageMaker посвящена гл. 11. Отдельные аспекты связывания файлов рассмотрены в гл. 14, поскольку при работе с изображениями связывание публикации с источником материала представляется намного более целесообразным.

Здесь мы рассмотрим только один из инструментов PageMaker, относящихся к этому процессу, — диалоговое окно Link Info (Информация о связи), вызываемое из меню Element (Элемент) при выделенном импортированном фрагменте или установленной в нем точке вставки. Возможность обновления текста с помощью диалогового окна Link Info (Информация о связи) (рис. 7.16) существует только в случае размещения его в изолированном от прочего текста материале. Если материал уже размещен внутри "родного" текста PageMaker, связь автоматически разрывается.

Если предположить, что появилась новая редакция файла текстового процессора, послужившего источником материала в публикации, последний можно автоматически привести в соответствие с новой версией. Для этого достаточно выделить имя файла в списке и щелкнуть мышью на кнопке Open (Открыть). Строго говоря, это приводит к повторному выполнению команды Place (Поместить) с сокращенным выбором имени размещаемого файла и автоматическим размещением материала в уже существующих границах текстовых блоков. Правда, если в помещенном материале уже было выполнено форматирование средствами PageMaker, при попытке обновить связь будет показано предупреждающее окно

Рис. 7.16. Диалоговое окно Link Info

В большинстве случаев обновление текстовых файлов оказывается исключительно опасным и совершенно бесполезным делом, поскольку после обновления утрачиваются все результаты настройки текста (например, стилевое оформление, кернинг), редактирование, выполненное в PageMaker, и вся вложенная в материал графика.


Разрыв связи

Рекомендуется разрывать связи текстовых файлов с материалами публикации сразу после импорта, за исключением некоторых случаев. К последним можно отнести работу в группе, когда несколько человек одновременно работают над сложной публикацией. Итак, для разрыва связи (и для других операций со связями, о которых будет рассказано в других главах) используется диалоговое окно Links Manager (Связанные файлы).

Во-первых, PageMaker может быть задан режим автоматического обновления связи, при котором каждый раз при открытии публикации происходит автоматическая проверка актуальности связанного материала и при необходимости проводится обновление, т. е. повторное вклеивание материала с потерей данных форматирования внутри PageMaker. Если этот режим работы для вас неприемлем, а именно так бывает в большинстве случаев, перед началом работы не забудьте отменить его. Это делается во вложенном диалоговом окне Link Options: Defaults (Установки связи по умолчанию), открываемом нажатием кнопки Options (Режим) диалогового окна Links Manager (Связанные файлы). Откройте его и сбросьте флажок Update automatically (Обновлять автоматически).

Во-вторых, в окне Links Manager (Связанные файлы) можно принудительно разорвать связанные файлы. В большом поле перечислены все файлы, имеющие связь с настоящей публикацией. Для разрыва связи щелкните на имени файла один раз, затем нажмите кнопку Unlink (Исключить). Файл исчезнет из списка и связь между ним и материалом публикации перестанет существовать. Если щелкнуть на имени файла дважды, откроется диалоговое окно Link Info (Информация о связи).


Резюме

Рассмотренные в этой главе сведения об импорте текстовых файлов будут использованы и дополнены при обсуждении верстки публикации (см. гл. 14-17).

Если вы верстаете многостраничные документы, вам также придется пользоваться импортом текста, и в этом случае он имеет свои особенности, которые мы обсудим в гл. 17.

Таблицы и базы данных, строго говоря, не относятся к текстовым файлам, поэтому они не были здесь рассмотрены. Их импорту и последующему форматированию посвящено несколько разделов гл. 16.

При импорте немаловажную роль играет механизм стилей абзацев, поэтому, возможно, вам придется не раз обратиться к предыдущей главе данной книги.


  • Глава 8. Редактирование текста
    • Редактор материалов
    • Просмотр материала
      • Переход в редактор материалов
      • Возврат в режим макета
      • Переключение режимов для нескольких публикаций
      • Неразмещенные материалы
    • Работа с окнами редактора материалов
      • Настройка параметров редактора материалов
    • Перемещение по тексту и выделение текста
      • Клавиши управления в редакторе материалов
      • Выделение текста
      • Операции с выделенными блоками
    • Проверка орфографии
      • Программа проверки орфографии
      • Корректировка словаря при проверке орфографии
      • Редактор словарей
    • Операции поиска и замены
      • Диалоговые окна Find и Change
      • Концепция поиска и замены
    • Работа в диалоговом окне Change
      • Строки ввода образца и замены
      • Управление областью поиска
    • Атрибуты поиска
    • Регулирование процесса поиска и замены
    • Резюме


ГЛАВА 8 .

Редактирование текста

Эта глава посвящена инструменту для редактирования текста в программе — редактору материалов и другим вспомогательным средствам обработки текстового материала. В ней рассматриваются следующие вопросы:

  • Редактор материалов
  • Подготовка текста для верстки
  • Проверка орфографии и словари
  • Поиск и замена по тексту


Редактор материалов

Даже короткого знакомства с PageMaker достаточно, чтобы обнаружить, как тяжело вносить исправления в текст в режиме макета. В нем неудобно перелистывать страницы, отрисовка страниц с графическими материалами занимает много времени, при отображении всей страницы не видно редактируемого текста, нет возможностей поиска и замены символов в тексте, орфографического контроля, есть много других неудобств. Не огорчайтесь — эти недостатки оборачиваются преимуществами при использовании встроенного редактора материалов!

Редактор материалов — простейший текстовый редактор, интегрированный в PageMaker и приспособленный именно для нужд верстки. Вид окна редактора материалов представлен на рис. 8.1.

Как видно из рисунка, в редакторе материалов не отображаются графические элементы, текстовые блоки, колонки, размер и даже гарнитура шрифта, схематически отображаются абзацные отступы и отбивки. При таком максимальном упрощении отображаемого материала, он отрисовывается практически мгновенно. Для редактора материалов нет преград в виде колонок,

а

б

Рис. 8.1. Один и тот же текст в режиме верстки (а) и в редакторе материалов (б)

страниц и текстовых блоков — вы работаете со всем текстом, независимо от того, как он размещен. Практически все операции в редакторе материалов можно выполнять с клавиатуры, что существенно ускоряет работу. В редакторе материалов появляется возможность пользоваться орфографическим контролем и продуманным механизмом поиска и замены символов, их атрибутов и стилей абзацев.

Отображение макета и материала — это только разные способы демонстрации того же самого текста на экране компьютера. Наличие этих двух способов обусловлено разной спецификой работы с текстом и верстки и разным набором требующихся для этого инструментов. PageMaker — единственная из известных нам конкурентоспособных издательских систем, обладающая редактором материалов, и это ее огромное преимущество.


Просмотр материала

Поскольку редактируя текст в режиме макета и в редакторе материалов вы имеете дело с одним и тем же текстом, необходимо научиться переходить от одного режима к другому в его заданном месте.


Переход в редактор материалов

Установите инструмент Type Tool (Текст) в нужной точке текста и выберите команду Edit Story (Текстовый режим) меню Edit (Редактирование) или воспользуйтесь клавиатурным эквивалентом <Ctrl>+<E>. После этого PageMaker откроет окно редактора материалов, в которое будет загружен весь текстовый материал, а на экране будет виден тот его фрагмент, который содержит выбранную в режиме макета точку. Положение курсора в тексте сохранится и в редакторе материалов.

Примечание

Заголовок окна материала состоит из имени публикации и первых двух десятков символов данного материала. Это один из доводов в пользу разбиения всего текста публикации на материалы по разделам. В этом случае заголовок окна материала будет информативен, например "Глава 7. Импорт тек", а не "Как видно из рис. : 1". Цифра, отделенная от заголовка двоеточием, используется для материалов, начинающихся с одинакового текста.

Если выделить инструментом Pointer (Стрелка) блок текста и выбрать команду Edit Story (Текстовый режим), или нажать комбинацию клавиш <Ctrl>+ +<Е>, или сделать тройной щелчок мышью на этом текстовом блоке, также откроется редактор материалов, и в него будет загружен, разумеется, весь данный материал, а на экране будет показано начало выделенного текстового блока.


Возврат в режим макета

Для возвращения в режим верстки существует несколько способов. Самый очевидный — воспользоваться командой Close Story (Закрыть материал) из меню Story (Материал), комбинацией клавиш <Ctrl>+<W> или кнопкой закрытия окна редактора материалов (комбинация клавиш <Ctrl>+<F4>). После того как окно редактора материалов будет закрыто, перед вами откроется окно макета с публикацией с той страницей текста, на которой находился курсор в редакторе материалов перед его закрытием. Активным в окне макета при этом окажется инструмент Туре (Текст).

Примечание

Свойство PageMaker переходить из редактора материалов на соответствующую страницу макета можно использовать для быстрого перемещения по длинной публикации. Если вам нужно, например, перейти на ту страницу макета романа, где говорится о второстепенном герое по фамилии Сидоров, можно перейти в редактор материалов и воспользоваться инструментом поиска текста по слову "Сидоров". Когда такое слово будет найдено, вы только перейдете обратно в режим макета. Публикация окажется открытой на нужной странице. Если в романе действует однофамилец Сидорова или вам требуется не сцена первого его появления, инструмент поиска все равно сделает эту работу, просто на кнопке Find (Найти) в окне поиска придется щелкнуть несколько раз.

Чтобы временно перейти в режим макета и посмотреть, как разместится отредактированный текст, закрывать редактор материалов не имеет смысла. Выберите команду Edit Layout (Режим верстки) из меню Edit (Редактирование) (комбинация клавиш <Ctrl>+<E>). Перед вами окажется окно макета с публикацией, открытой на соответствующем месте, а окно редактора материалов помещается за окно макета. Если открыты оба окна, быстрее всего переключаться между ними с помощью щелчка мыши.


Переключение режимов для нескольких публикаций

Если одновременно открыто несколько окон публикаций, переключаться между ними удобно, нажимая комбинацию клавиш <Ctrl>+<Tab> или выбирая нужное окно из меню Window (Окно). В нем приведен список всех открытых в данный момент публикаций. Вложенное меню каждой публикации содержит список материалов, открытых для нее, и пункт Layout (Макет), соответствующий окну макета (рис. 8.2).

Примечание

Во вложенном меню перечислены только открытые в данный момент окна редактора материалов.

Рис. 8.2. Список открытых публикаций и материалов в меню Window главного меню PageMaker


Неразмещенные материалы

Не размещенный в макете текстовый материал может появиться в публикации двумя путями. Во-первых, вы можете создать новый материал, и пока ему не будет определено место в макете, он имеет статус неразмещенного. Во-вторых, вы можете импортировать текст в виде нового материала и сколь угодно долго откладывать его помещение на страницы публикации.

Для создания нового материала с названием Untitled (Без имени) нажмите комбинацию клавиш <Ctrl>+<E> при отсутствии выделенных текстовых блоков или точки ввода.

Если в момент импорта текста был активен редактор, и в диалоговом окне Place (Поместить), приведенном на рис. 8.3, в поле Place (Поместить) вы установите переключатель As new story (Как новый материал), будет открыто новое окно редактора материалов с импортированным текстом. Если после этого перейти в окно макета или закрыть программу, данному тексту не будет определено место в макете и он также получит статус неразмещенного.

Закрытие окна с неразмещенным материалом не приведет к немедленной потере этого материала. PageMaker запросит подтверждение на его удаление или размещение с помощью диалогового окна. Выбор в данном окне кнопки Place (Поместить) сделает активным режим макета и активизирует операцию размещения текста. При этом курсор примет форму соответствующей пиктограммы. Выбор кнопки Discard (Удалить) повлечет за собой удаление материала, а кнопка Cancel (Отменить) вернет вас в сеанс работы с неразмещенным материалом в редакторе материалов.

Рис. 8.3. Импорт текста как нового материала. Диалоговое окно импорта

При закрытии публикации закрываются и все окна ее материалов. После открытия публикации окна неразмещенных материалов "всплывают" поверх окна макета.

Примечание

Завершение работы с PageMaker с последующим его запуском — удачный способ обнаружения неразмещенных материалов.


Работа с окнами редактора материалов

Ситуация, когда одновременно открыты несколько публикаций и несколько окон редактора материалов для каждой из них, весьма обычна при переносе материалов из одной публикации в другую. В этом случае удобно расположить их на экране рядом таким образом, чтобы они не перекрывали друг друга (мозаикой) или чтобы переход между ними было легко осуществить щелчком мыши (каскадом). Для автоматического размещения окон есть соответствующие команды в меню Window (Окно): Cascade (Каскад) и Tile (Мозаика). Результат первой команды представлен на рис. 8,4, а второй — на рис. 8.5.

Рис. 8.4. Окна редактора материалов, расположенные каскадом

Рис. 8.5. Окна редактора материалов, упорядоченные командой Tile

Эти команды задают расположение открытых окон материалов для текущей публикации. Если же при их выполнении держать нажатой клавишу <Shift>, команда будет выполнена вообще для всех открытых окон редактора материалов для всех публикаций.

При выполнении этих команд для окон редактора материалов текущим окном обязательно должно быть одно из его окон. Если же активно одно из окон макета, размещаться будут окна макетов открытых публикаций.


Настройка параметров редактора материалов

Несмотря на суровую простоту внешнего вида, редактор материалов предусматривает возможность некоторых настроек. Для того чтобы до них добраться, выберите команду Preferences (Установки) меню File (Файл) и в открывшемся окне щелкните на кнопке More (Дополнительные). В окне More Preferences (Дополнительные установки) есть область Story editor (Редактор материалов), управляющая интересующими вас настройками (рис. 8.6).

Рис. 8.6. Диалоговое окно More Preferences

Поля Font (Шрифт) и Size (Кегль) определяют гарнитуру и размер шрифта, используемого в редакторе материалов.

Флажок Display marks (Показать) позволяет отображать в тексте специальные символы (рис. 8.7) — признаки концов абзацев, переходов на новую строку, табуляций и пробелов. Этот флажок рекомендуется устанавливать на стадии подготовки текста к верстке.

При установленном,флажке Display style names (Показать имена стилей) слева от первой строки абзаца показывается стиль этого абзаца (рис. 8.7). Как правило, при первичной обработке текста данный режим активен.

Рис. 8.7. Вид редактора материалов при установленных флажках Display marks и Display style names


Перемещение по тексту и выделение текста

Пора, наконец, перейти и собственно к редактированию текста. При редактировании текста в редакторе материалов вам пригодятся навыки, приобретенные при работе в других текстовых редакторах, например Microsoft Word, где и идеология, и комбинации клавиш очень близки. Сам ввод символов с клавиатуры, скорее всего, не вызовет у вас никаких вопросов. Описания требуют только процедуры перемещения по тексту, выделения и удаления.


Клавиши управления в редакторе материалов

В табл. 8.1 перечислены приемы перемещения точки вставки при помощи клавиш управления курсором, специальных клавиш и клавиш вспомогательной клавиатуры. Обратите внимание — в случае использования в клавиатурном сокращении цифры она вводится со вспомогательной цифровой клавиатуры при выключенной клавише <Num Lock> Разумеется, вы можете воспользоваться и клавишами дополнительной клавиатуры (со стрелками, <Insert>, <Home>, <Page Up>, <Delete>, <End> и <Page Down>), поскольку они дублируют клавиши цифровой клавиатуры.

Таблица 8.1. Комбинации клавиш для перемещения по тексту

Перемещение точки вставки | Комбинация клавиш
Вверх на одну строку | <Стрелка вверх> или <8>
Вниз на одну строку | <Стрелка вниз> или <2>
Вверх на величину окна | <Раде Up> или <9>
Вниз на величину окна | <Раде Down> или <3>
В начало строки | <Ноте> или <7>
В конец строки | <End> или <1>
В начало предложения | <Ctrl>+<Home> или <Ctrl>+<7>
В конец предложения | <Ctrl>+<End> или <Ctrl>+<1>
В начало материала | <Ctrl>+<Page Up> или <Ctrl>+<9>
В конец материала | <Ctrl>+<Page Down> или <Ctrl>+<3>
Влево на один символ | <Стрелка влево> или <4>
Вправо на один символ | <Стрелка вправо> или <6>
Влево на одно слово | <Ctrl>+ <стрелка влево или <Ctrl>+<4>
Вправо на одно слово | <Ctrl>+ -сстрелка вправо или <Ctrl>+<6>
Вверх на один абзац | <Ctrl>+ <стрелка вверх> или <Ctrl>+<8>
Вниз на один абзац | <Ctrl>+ <стрелка вниз> или <Ctrl>+<2>


Выделение текста

Чтобы выделить символы в процессе перемещения по тексту, держите нажатой клавишу <Shift>. Таким образом можно выделить символ, несколько символов, слово, абзац, страницу и весь материал. Так же как можно комбинировать команды перемещения по тексту, можно комбинировать и команды выделения. Например, удерживая клавиши <Ctrl> и <Shift>, несколькими нажатиями <стрелка вправо> выделить ряд слов, а затем, отпустив <Ctrl> и продолжая нажимать <стрелку вправо>, выделить еще несколько символов.

Для того чтобы выделить слово, можно сделать двойной щелчок мышью на любом его символе. Для выделения абзаца требуется тройной щелчок. Произвольное число символов выделяется перемещением указателя мыши при нажатой левой кнопке. Если в редакторе материалов отображаются стили абзацев, для выделения одного абзаца сделайте один щелчок мышью на имени его стиля.

Выделить весь материал проще всего нажатием комбинации клавиш <Ctrl>+<A>. Все приведенные комбинации клавиш действуют и в режиме макета.


Операции с выделенными блоками

Выделенный фрагмент текста (текстовый блок) можно удалять, вырезать и копировать в системный буфер обмена, а также вклеивать оттуда в любое место этого же или другого материала. Данные команды осуществляются-либо через меню Edit (Редактирование) редактора материалов, либо с помощью комбинаций клавиш, приведенных в табл. 8.2.

Таблица 8.2. Комбинации клавиш для текстовых блоков

Команда меню | Комбинация клавиш
Clear (Удалить) | <Del>
Cut (Вырезать) | <Ctrl>+<X> или <Shift>+<Del>
Сору (Скопировать) | <Ctrl>+<C> или <Ctrl>+<Ins>
Paste (Вклеить) | <Ctrl>+<V> или <Ilns>

К сожалению, в редакторе материалов PageMaker не работает технология Drag-and-Drop, т. е. невозможно выделенный мышью текстовый блок переместить или скопировать в другое место текста.


Проверка орфографии

Команда Spelling (Орфография) доступна только из редактора материалов и использует тот же самый словарь, что и при расстановке переносов (см. гл. 5).

PageMaker может использовать одновременно несколько словарей разных языков. Минимальная единица текста, для которой может быть определен свой язык, — абзац. Для каждого абзаца публикации должен быть назначен язык, чтобы PageMaker мог автоматически расставить переносы и проверить орфографию именно для определенного языка. При несовпадении назначенного текста и реального языка текста программы расстановки переносов и орфографии дадут неверный результат.

Назначить язык абзацу можно в диалоговом окне Paragraph Specifications (Параметры абзаца) или в стиле абзаца, что намного удобнее при значительных объемах текста. Язык, присваиваемый абзацам при импорте или при вводе текста, определяется глобальными и локальными умолчаниями. Поэтому следует задать в качестве глобального умолчания язык большинства создаваемых вами публикаций (скажем, русский), а в качестве локально умалчиваемого — основной язык публикации (например, немецкий, если вы сейчас обрабатываете статью на этом языке).


Программа проверки орфографии

Орфографию можно проверять только в режиме редактора материалов. Для запуска программы проверки выберите команду Spelling (Орфография) меню Utilities (Сервис) (комбинация клавиш <Ctrl>+<L>). Внешний вид диалогового окна Spelling (Проверка орфографии) показан на рис. 8.8.

Проверку орфографии можно осуществлять в выделенном текстовом блоке (о выделении блоков текста см. выше), в текущем материале, во всех материалах текущей публикации и во всех материалах всех открытых публикаций. Любой из перечисленных вариантов задается комбинацией переключателей Search document (Поиск документа) и Search story (Зона поиска).

Рис. 8.8. Диалоговое окно Spelling

После установки области проверки приступайте к проверке орфографии щелчком на кнопке Start (Начать). При этом она изменит свое название на Ignore (Пропустить), а кнопка Replace (Заменить) станет доступна. При отсутствии выделения проверка правописания начинается с положения курсора в тексте.

Примечание

Диалоговое окно Spelling (Проверка орфографии) не является модальным (не требует закрытия для перехода к другим окнам приложения). В любой момент можно перейти из него в окно редактора материалов. Для того чтофы продолжить проверку, установите курсор на последнее проверенное слово, перейдите в окно Spelling (Проверка орфографии) и снова щелкните на кнопке Start (Начать). При открытом диалоговом окне проверки можно переходить не только в окно проверяемого материала, но и в окно любого другого материала, а также в окно макета.

Как только программа найдет отсутствующее в ее словаре слово, она выделит это слово, прервет проверку и предложит один из вариантов, определяемых кнопками Ignore (Игнорировать), Add (Добавить в словарь) и Replace (Заменить). Поскольку PageMaker "не интересуется" смыслом проверяемого текста, он не может точно определить, какое слово вы имели в виду. Например, для ошибочно набранного слова "онке" программа предложит такие варианты его истинной орфографии: "оке", "окне", "ноке" (!?), "гонке", "донке", "конке". Все эти варианты будут перечислены в списке в поле ввода Change to (Заменить на). Вам придется исходя из контекста выбрать верный, щелкнув на нем мышью, и произвести замену нажатием кнопки Replace (Заменить). Замену можно осуществить двойным щелчком мыши на одном из предлагаемых вариантов. Если слово изуродовано настолько сильно, что программа контроля орфографии не нашла нужного варианта или вообще не нашла никакого варианта исправления, его придется ввести вручную в поле Change to. Исправленное слово при продолжении проверки не будет принято "на веру" и подвергнется ей еще раз. Это обезопасит вас от повторной ошибки при вводе слова.

Игнорировав отсутствующее в словаре слово, вы тем самым запрещаете программе проверки орфографии останавливаться и на других вхождениях этого слова в текущий материал. Таким образом, игнорировать слово следует только в том случае, если вы абсолютно уверены в правильности его написания, но не рассчитываете его встретить в других публикациях (т. е. заносить его в словарь не стоит). Это могут быть, скажем, названия или фамилии.

Примечание

Любопытный читатель, возможно, удивится предлагавшемуся в нашем примере варианту "ноке". Объяснение тривиально. Словарь программы орфографического контроля, имеющий размер чуть больше мегабайта, не может вмещать все слова русского или английского языка. Программы проверки орфографии пользуются специальными алгоритмами, описывающими словообразование, что позволяет из одного слова получать все возможные формы (падежи, склонения, спряжения и т. п.). Всякая алгоритмизация естественного языка несовершенна, что и приводит к появлению в списке возможных замен слов типа "ноке", которые, по мнению программы, могут существовать в русском языке.

На проверку орфографии влияют положения переключателей Alternate spellings (Альтернативное написание) и Show duplicates (Показать удвоение слов). Первый включает описанный выше поиск вариантов правописания слов, а второй — отслеживание удвоений. Под удвоениями понимаются два одинаковых слова, стоящие непосредственно друг за другом — частая ошибка, возникающая при наборе текста.


Корректировка словаря при проверке орфографии

Диалоговое окно Spelling (Проверка орфографии) позволяет не только осуществлять орфографический контроль, но и модифицировать орфографический словарь и словарь переносов. Для более существенного их редактирования в пакет PageMaker входит специальный Редактор словарей (Dictionary Editor), с помощью которого можно даже импортировать и создавать словари.

PageMaker поддерживает два словаря для каждого языка — основной и пользовательский. Разница между ними заключается не только в названии. Основной словарь, работающий совместно с алгоритмом генерации словоформ, не подлежит изменению и дополнению. Пользовательский словарь не использует этот алгоритм и должен содержать все формы введенного в него слова. Если какая-либо форма имеющегося в словаре слова отсутствует, она будет трактоваться программой проверки орфографии как неизвестная. Такое различие между типами обусловлено сложностью организации основного словаря и необходимостью специальных лингвистических знаний для его корректного пополнения. Таким образом, дополняя словарь с помощью кнопки Add (Добавить) в диалоговом окне Spelling (Проверка орфографии) или используя редактор словарей, вы тем самым дополняете только пользовательский словарь, к которому имеете доступ.

Примечание

При работе в группе имеет смысл создать общий пользовательский словарь, запретив всякие индивидуально вносимые изменения. Такой словарь должен содержать слова, специфические для готовящейся публикации. Для того чтобы каждый мог пользоваться составленным словарем, его необходимо скопировать на все компьютеры в папку <основаня папка PageMaker>\RSRC\LINGUIST \Рrх\<язык>. Разумеется, имя папки, в которой установлен PageMaker, может быть разным в зависимости от предпочтений пользователя, а имя папки <язык> зависит от языка, для которого создается пользовательский словарь.

Если в поле Change to (Заменить на) окна Spelling (Проверка орфографии) находится слово, которое необходимо занести в словарь, нажатие на кнопку Add откроет изображенное на рис. 8.9 диалоговое окно.

Рис. 8.9. Добавление слова в пользовательский словарь PageMaker

Оно уже описано нами в гл. 5, где мы рассматривали пополнение словаря переносов. Поскольку для переносов и проверки орфографии PageMaker использует один и тот же словарь, ввод нового слова в этом окне или окне, открывающемся из диалогового окна Hyphenation (Перенос), приведет к тому же самому результату — появлению нового слова в пользовательском словаре. Естественно, что и при проверке орфографии, добавляя слова в пользовательский словарь, следует со всей внимательностью снабжать их вариантами переноса.

Если в словарь попало ошибочно введенное слово, для того чтобы его удалить, придется набрать это слово в поле ввода окна Add Word to User Dictionary (Добавить слово в словарь пользователя) со всеми ошибками еще раз. Это неудобство может быть обойдено использованием редактора словарей.


Редактор словарей

При установке PageMaker можно поставить и программу Dictionary Editor (Редактор словарей). Ее исполняемый файл Deapp.exe находится по адресу <основная папка PageMaker>\EXTRAS\TEXT. На рис. 8.10 представлено главное окно программы с открытым в ней словарем ALDUSN.UDC. Все файлы пользовательских словарей имеют расширение udc (User Dictionary), характерный ярлык и располагаются в каталоге соответствующего языка.

Меню File (Файл) программы содержит стандартные команды для создания, открытия записи, распечатки словарей.

Рис. 8.10. Редактор словарей Dictionary Editor с загруженным словарем

Для того чтобы начать работу с существующим словарем, следует выбрать команду Open (Открыть) из меню File (Файл) и в стандартном окне указать имя файла пользовательского словаря. После загрузки откроется окно, содержащее список всех обнаруженных в нем слов. Любое слово в этом списке можно выделить. Если в поле Word (Слово) введено новое слово, то кнопкой Add (Добавить) это слово добавляют в словарь, кнопкой Replace (Заменить) заменяют этим словом слово, выделенное в списке, а щелчок на кнопке Clear (Очистить) очищает поле Word (Слово). Формат ввода слов и переносов в поле Word (Слово) совпадает с принятым в PageMaker.

Если слово из словаря нужно отредактировать, для начала необходимо его найти. Проще всего воспользоваться командой Find (Найти) меню Edit (Редактирование) или комбинацией клавиш <Ctrl>+<F>. Эта команда открывает диалоговое окно Find (Найти), показанное на рис. 8.11 и знакомое вам по многим программам Windows (WordPad, Notepad, Internet Explorer и др.). В нем можно ввести слово целиком или его часть. При этом можно учесть регистр, установив флажок Match upper/lower case (Учитывать верхний/нижний регистр), и проводить поиск только целых слов (если ищется словосочетание типа "Stylus Lingvo", "Microsoft Word" и т. п.). Найденное слово будет выделено в списке. После поиска окно Find (Найти) надо закрыть кнопкой закрытия окна. Двойной щелчок на выделенном или найденном слове скопирует его в поле Word (Слово), в котором и проводится его редактирование.

Рис. 8.11. Диалоговое окно Find в редакторе словарей

При редактировании слова важно расставить маркеры переносов. В качестве первого приближения можно "спросить мнение" самого словаря переносов, воспользовавшись командой Hyphenate (Разметить переносы) из меню Edit (Редактирование) или комбинацией клавиш <Ctrl>+<Y>. В большинстве случаев эта подсказка требует коррекции хотя бы для указания предпочтительности различных вариантов.

После того как введено верное правописание и расставлены переносы, можно заменить отредактированным словом выделенное в списке слово, воспользовавшись кнопкой Replace (Заменить). Если введено новое слово или надо оставить и исходный вариант, нажмите кнопку Add (Добавить).

При помощи расположенной в меню File (Файл) команды Import (Импортировать) можно преобразовать список слов в текстовом формате (ASCII) в новый персональный словарь или пополнить ими ранее созданный персональный словарь. После выбора команды Import (Импортировать) на экране появляется диалоговое окно, представленное на рис. 8.12.

Рис. 8.12. Импорт словаря для редактирования или установки

Команда Import (Импортировать) преобразует список слов в словарь или пополняет ими словарь, ранее открытый в сеансе работы с программой Dictionary Editor. При помощи флажка Import words already in dictionary (Импортировать слова, уже присутствующие в словаре) можно разрешить замену слов в процессе импорта. Этот удобный (или опасный — смотря, с какой стороны посмотреть) прием позволяет заменить в процессе импорта слова с тем же написанием, но другой схемой переносов.

Другой флажок — Hyphenate on import using algorithm (Импорт переносов с учетом алгоритма) — включает режим автоматической расстановки переносов с применением алгоритма в словах, вносимых в словарь.

Примечание

Старайтесь избегать автоматической расстановки переносов. Дело в том, что алгоритм расстановки переносов не лишен недостатков. Так что, результаты его работы необходимо проверять. Для некоторых публикаций качество автоматического переноса вполне приемлемо, но если вы или ваш заказчик придерживаетесь строгих взглядов в отношении правильности переноса слов, алгоритм может не оправдать возлагаемых на него надежд.

Структура импортируемых и экспортируемых списков слов предполагает размещение по одному слрву на строке. Это — принятый в рамках программы PageMaker формат. Формат других словарей предполагает разделение слов пробелами или символами табуляции — программа PageMaker может считывать файлы в таком формате, но в результате экспортирования всегда создается текстовый файл, в котором слова отделяются друг от друга символом возврата каретки. Схема переносов в слове задается символами тильды.

После того пополнения новыми словами, необходимой коррекции и сохранения в файл, словарь готов к использованию в PageMaker. Для установки словаря выберите команду Install (Установить). Откроется диалоговое окно, представленное на рис. 8.13. Проверьте корректность размещения файла словаря и щелкните на кнопке Install (Установить).

Рис. 8.13. Установка нового словаря в сеансе работы с Dictionary Editor

В процессе установки нового словаря будет сделан запрос о том, куда поместить словарь, использовавшийся в качестве персонального ранее. Для хранения временно не используемых словарей рекомендуем вам создать специальную папку. Это позволит легко найти словарь в случае необходимости перехода на прежнюю версию и упростит параллельное ведение нескольких словарей.

Для того чтобы импортировать словарь текстового процессора (или любой другой программы для работы с текстами, отличной от PageMaker), его необходимо преобразовать в текстовый формат (ASCII). Если текстовый процессор позволяет, откройте файл словаря и сохраните его при помощи команды Save as (Сохранить как) с новым именем и в текстовом формате (как правило, это форматы ASCII text и Text only). В качестве текстового процессора можно воспользоваться также редактором материалов PageMaker, выполнив затем команду экспорта в формате Text only. Возможно, для того чтобы найти файлы словарей, вам придется покопаться в документации по текстовому процессору.

Во многих форматах словарей схема переносов задается не символами тильды. Если в импортируемом словаре для обозначения места переноса используется другой символ (например, дефис), замените все такие символы в файле на тильды командой контекстной замены.

После того как вы преобразовали словарь в текстовый формат ASCII (с разделением слов символом возврата каретки, пробелом или табулятором), его можно импортировать средствами программы Dictionary Editor.


Операции поиска и замены

При работе в редакторе материалов доступен инструмент поиска и замены. В редакторе материалов можно осуществлять автоматическую "чистку" текста, полученного даже от очень неопытного наборщика, производить глобальные замены одного слова другим (например, при изменении названия описываемого продукта или фирмы), осуществлять расстановку вводов предметного указателя, назначать стили в публикации. И все это можно делать за неправдоподобно короткие сроки.


Диалоговые окна Find и Change

Для операции поиска и замены слов существуют два разных диалоговых окна — Find (Найти) и Change (Заменить). Так же, как и диалоговое окно проверки орфографии, диалоговые окна поиска и замены можно перетаскивать в любое место окна публикации. Это позволяет увидеть, в каком контексте выполняется замена, поскольку заменяемая часть текста выделяется цветом.

Кроме того, эти окна не модальны, вы в любой момент можете выполнить щелчок мышью в окне редактора материалов — при этом окно поиска или замены остается открытым, но неактивным. Поиск всегда производится, начиная от точки вставки.

Рис. 8.14. Окна поиска

Из рис. 8.14 видно, что второе окно включает в себя все элементы первого, относящиеся к поиску последовательности символов и дополнительные, связанные собственно с произведением замены. Таким образом, в окне Change (Заменить) можно производить в том числе и поиск, причем таким же способом, что и в окне Find (Найти). Чтобы не повторяться, рассмотрим в данном разделе более развитое из этих диалоговых окон — Change (Заменить).


Концепция поиска и замены

При выполнении операции поиска и замены пользователь задает два параметра — образец (искомый текст) и замену. При этом операция поиска проводится буквально, т. е. PageMaker находит именно такие последовательности символов и только их. При этом вы можете воздействовать на область поиска, принудительно сужая ее до одного абзаца или расширяя до всех открытых документов.

На операцию замены не действует команда Undo (Отменить), поэтому обязательно сохраняйте документ перед проведением глобальной замены. Внимательно проанализируйте последовательность символов образца и замены, задайте корректную область поиска (см. разд. "Работа в диалоговом окне Change" данной главы). Затем проделайте несколько отдельных замен с этими параметрами. Убедитесь, что все работает правильно. Только после этого приступайте к глобальной замене последовательности символов по всему тексту. После замены посмотрите проделанные изменения в материале — во всех ли случаях замена прошла так, как нужно? Если все же замена была неудачной, не отчаивайтесь — всегда есть возможность вернуться к последней сохраненной версии командой Revert (Восстановить). Если вы забыли сохранить публикацию перед выполнением команды замены, воспользуйтесь мини-восстановлением — операцией, которая восстановит состояние публикации на момент последнего автоматического сохранения, выполненного PageMaker. Для выполнения мини-восстановления удерживайте нажатой клавишу <Shift> при выборе команды Revert (Восстановить), Программа PageMaker выполняет мини-сохранение каждый раз при переходе на новую страницу, при вставке или удалении страницы, печати, переключении режимов верстки и текстового, использовании системного буфера, щелчке мышью на пиктограмме активной страницы, изменении параметров страницы. Вот почему так важно проверять состояние текста после каждой глобальной замены — если пренебречь этим действием и начать работать дальше, то вы уже не сможете вернуться к первоначальной публикации при некорректной замене.


Работа в диалоговом окне Change

Для начала работы в режиме редактора материалов выберите команду Change (Заменить) меню Utilities (Сервис). К слову, окно поиска открывается командой Find (Найти) того же меню. Комбинация клавиш для диалогового окна замены — <Ctrl>+<H>, поиска — <Ctrl>+<F>. Ниже приводится обзор основных элементов диалогового окна Change (Заменить) и вложенных диалоговых окон атрибутов символов и абзацев.


Строки ввода образца и замены

  • Find what (Найти текст). В эту строку вводится последовательность символов, которую будет искать PageMaker.
  • Change to (Заменить на). Здесь указывается последовательность символов для замены. Предметом поиска могут быть обычные буквы, цифры и символы, которые есть на клавиатуре, и служебные символы PageMaker — тонкие и широкие пробелы, полиграфические дефисы, тире, кавычки (елочки), входы предметного указателя, признаки конца абзаца, принудительные разрывы строк и другие элементы набора и форматирования. Подобные элементы называются в PageMaker специальными символами, и их невозможно набрать с клавиатуры в явном виде, а лишь посредством комбинации клавиш. Установите точку вставки в поле Find what (Найти текст) или Change to (Заменить на) щелчком мыши, нажмите клавишу <Alt> и, удерживая ее, введите на вспомогательной цифровой клавиатуре четырехзначный ASCII-код символа. Этот код — четырехзначное число, как правило, начинающееся с нуля, — соответствует каждой из клавиш. Определить, какой именно код соответствует интересующему вас символу, проще всего с помощью утилиты системы Windows — Character Map (Карта символов).

Для ввода специальных символов в строки поиска и замены создана таблица метасимволов, в которой каждому из специальных символов соответствует определенный код, состоящий из набора служебных знаков и букв. В строке ввода с клавиатуры набирается код, a PageMaker определяет соответствующий ему специальный символ и проводит с ним необходимые операции. Таблица метасимволов и специальных символов приведена в приложении 2.

Примечание

С помощью команды поиска и замены легко автоматизировать внесение слова в предметный указатель. Если все вхождения слова в публикацию необходимо отразить в предметном указателе, задайте поиск этого слова при помощи команды Change (Заменить). В поле Change to (Заменить на) введите это слово и маркер элемента предметного указателя Л ; (символы инверсии и точки с запятой). При сборке предметного указателя программа PageMaker поместит в него помеченные слова.


Управление областью поиска

Как.сказано выше, можно управлять областью поиска и замены, по необходимости сужая и расширяя ее. Для этого в диалоговом окне Change представлены следующие элементы управления:

  • Match case (Регистр). Этот флажок влияет на чувствительность поиска к регистру литер. По умолчанию он сброшен, и PageMaker ищет образец, не обращая внимания, на регистр. Так, если в качестве образца введено слово "Ира", будут найдены следующие слова: "Ира", Ираида", "тираж", "Ирак", "миражи", "квартира". Если этот флажок включен, при том же образце в данном тексте будут найдены слова "Ира", "Ираида", "Ирак".
  • Whole word (Целое слово). Флажок определяет чувствительность поиска к целостности слова. Если флажок включен, то образец считается словом и PageMaker не учитывает в процессе поиска части слов, ограничиваясь целыми словами. Предполагается, что слова в тексте разделяются пробелами и знаками пунктуации. Так, если в предыдущем примере ограничить область поиска целым словом, то будут найдены слова "Ира" и "ира" (если данное имя, скажем по ошибке, было написано с маленькой буквы).

Областью поиска может быть любой объем текста — от одного символа до всех открытых документов. Область регулируется переключателями в нижней части диалогового окна.

  • Search document (Документ). Переключатель объема поиска на уровне просматриваемых документов может находиться в одном из двух положений:
    • Current publication (Активная публикация) — поиск ведется только в текущей публикации. Этот режим поиска является умалчиваемым.
    • All publications (Все публикации) — поиск проводится во всех открытых публикациях. Активность автоматически переводится по очереди на каждую из них и каждая просматривается. Данная операция производится довольно редко, обычно при работе над большими проектами (например, книгами), когда материал публикации разделен на несколько файлов.
  • Search story (Зона поиска). Переключатель объема поиска на уровне текущего документа. Предлагаются следующие режимы поиска:
    • Selected text (Выделенный текст). Поиск в пределах выделенной области. Естественно, этот переключатель доступен только при наличии выделения в материале. Если таковое имеется, режим поиска в пределах выделения включен по умолчанию.
    • Current story (Активный материал). В процессе поиска просматривается только текущий материал публикации. Это наиболее часто используемый режим замены.
    • All stories (Все материалы). При работе со сложными публикациями, содержащими несколько, а иногда и множество материалов, есть смысл провести поиск и замену одновременно во всех материалах. Это экономит время, поскольку материалы в данном режиме открываются автоматически и не нужно каждый раз вводить образцы. Кроме того, PageMaker, в отличие от верстальщика, при поиске не забудет ни одного, даже самого маленького материала.


Атрибуты поиска

Кроме поиска по образцу, введенному в строке Find what (Найти текст), PageMaker может осуществлять поиск и замену атрибутов форматирования символов и абзацев, в том числе и стилей. Для того чтобы воспользоваться этими возможностями, щелкните на одной из кнопок — Char attributes (Атрибуты шрифта) или Para attributes (Атрибуты абзаца). В результате откроется одно из диалоговых окон, представленных на рис. 8.15.

В каждом из этих окон есть два поля. В верхнем Find what (Найти текст) указываются атрибуты образца для поиска, в нижнем Change to (Заменить на) — атрибуты замены. При поиске по атрибутам не нужно вводить какое-либо значение в строки ввода главного окна Change to (Заменить на). Например, если вам необходимо заменить все полужирные слова в тексте на курсивные, следует соответствующим образом установить атрибуты в группах Find what и Change to, а затем выполнить команду замены. С другой стороны, можно воспользоваться поиском по атрибутам для дополнительной конкретизации области поиска. В приведенном выше примере, посвященном Ире, при задании в качестве образца слова "Ира", а в качестве атрибута поиска — курсивного начертания, в тексте будут обнаружены слова "Ира" и "Ира", а "Ира" найдено не будет.

Примечание

Поиском по атрибутам можно пользоваться для введения букв национальных алфавитов, математических символов и других специальных символов. Набор с использованием кода символа зачастую отнимает много времени, особенно если для ввода соответствующего знака необходимо временно менять гарнитуру. Придумайте некий уникальный идентификатор для каждого экзотического символа, встречающегося в тексте (например, "@@"). Идентификатор должен быть легко набираем и больше нигде не должен встречаться в тексте. Когда набор завершен, сделайте глобальную замену для каждого из таких символов. В качестве образца поставьте ваш идентификатор, в поле замены — нужный символ, а в окне Char Attributes (Атрибуты шрифты) установите нужную гарнитуру.

Поиск по атрибутам иногда может с успехом компенсировать отсутствие стилей символов в PageMaker (см. гл. 16).

С помощью окна поиска и замены можно быстро размечать стилем большие объемы текста (см. гл. 6).

а

б

Рис. 8.15. Диалоговые окна замены атрибутов форматирования

Если в диалоговом окне Change (Заменить) указаны атрибуты поиска, то названия строк Find what (Найти) и Change to (Заменить на) станут подчеркнутыми. Для того чтобы исключить атрибуты форматирования из критерия поиска, достаточно щелкнуть на соответствующей кнопке атрибутов при нажатой клавише <Alt>.


Регулирование процесса поиска и замены

При заданных критериях поиска доступна кнопка Find (Найти). После щелчка на ней начинается поиск в пределах области: от точки вставки или начала выделения. Найденный образец отмечается в окне редактора материалов инверсным выделением. После этого становятся доступны следующие кнопки диалогового окна:

  • Change (Заменить). Замена образца без перемещения далее по тексту, что позволяет проконтролировать результат. Для возобновления поиска нужно снова нажать верхнюю кнопку в диалоговом окне, которая меняет название на Change & find (Заменить и искать);
  • Change & find (Заменить и искать). Замена найденного образца и автоматический поиск следующего объекта замены;
  • Change all (Заменить все). Замена во всем заданном объеме текста (глобальная замена). Эта операция требует осторожности.

После просмотра всего текста от точки вставки до конца объема поиска демонстрируется диалоговое окно (рис. 8.16) с запросом — следует ли продолжать поиск с начала материала до точки вставки. После просмотра всего материала программа показывает информационное окно (рис. 8.17).

Рис. 8.16. Окно запроса о продолжении поиска с начала материала

Рис. 8.17. Сообщение PageMaker о завершении поиска

Рецепт. Обработка текста, поступившего из набор

В заключение рассмотрим "чистку" текста, поступившего из набора. Перед началом серии замен внимательно просмотрите текст, продумайте и напишите на бумаге план замены, чтобы организовать эту работу как можно успешнее.

В зависимости от привычек наборщика исходного текстового процессора и от характера текста (научный, художественный, стихи и др.) план может очень сильно меняться. Приведенный примерный план работы по чистке текста в основном применим для художественных текстов, т. е. самого простого случая верстки.

Устраните лишние признаки конца абзаца. В правильно оформленном тексте не может быть стоящих рядом возвратов каретки, все расстояния регулируются отбивками. Для этого введите в поле Find what (Найти текст) метасимвол двух признаков конца абзаца (^р^р), а в поле Change to (Заменить на) — метасимвол одного признака конца абзаца (^р). Проделайте глобальную замену. Повторяйте замену с теми же критериями до появления окна, изображенного на рис. 8.18. Появление этого окна означает, что повторяющихся возвратов каретки в тексте больше нет.

Рис. 8.18. Информационное окно с сообщением об отсутствии замен

Проделайте ту же операцию для удаления повторяющихся пробелов. К пробелам также предъявляется требование "не более одного".

Уничтожьте пробелы после точки в конце абзаца. Для этого в качестве образца введите сочетание признака конца абзаца и пробела ( ^р). Замените это сочетание на признак конца (^р) абзаца.

Введите в публикацию типографские символы — длинные тире, дефисы и кавычки-"лапки" вместо прямых. Обычно при наборе длинные тире набираются двойным минусом. Замените его на типографское тире (см. таблицу метасимволов в приложении 2). Для замены открывающих кавычек введите в поле образца сочетание "пробел +^[", а в поле замены — "пробел + ^{". Все открывающие кавычки будут заменены. Ту же операцию проделайте для закрывающих кавычек. Если вы хотите использовать не круглые кавычки, а «елочки», как это принято в русском тексте, то в качестве замены введите их коды (<Alt>+1071 и <Alt>+0187) в поле замены. Если это возможно, замените знаки "минус" на типографские дефисы (конечно, если речь идет не о математических формулах).

Теперь расставьте неделимые пробелы, они помогут вам грамотно разместить текст при верстке. Так, строка не должна начинаться с тире. Поэтому замените сочетание "пробел+тире" на сочетание "тонкий пробел+тире". Такая комбинация лучше смотрится в тексте, при этом разрыв строки по тонкому пробелу не производится. Если в предложении есть короткие слова, состоящие из одной-двух букв, например предлоги — к, о, на, в и др., такое слово не должно быть последним в строке. Для достижения нужного размещения выпишите все предлоги на лист бумаги и проведите серию замен — сочетание "предлог+пробел" замените на "предлог+неделимый пробел шириной вполовину круглой шпации". Еще одно требование относится к сочетаниям типа 1987 г., 234 стр., стр. 234, 5 м, 38 лет и др. Они не должны быть разорваны по пробелу на разные строки, тем более страницы. Для этого проанализируйте текст, найдите в нем часто встречающиеся сочетания этого типа и замените обычные пробелы в них на тонкие. Этим вы добьетесь двойного эффекта, поскольку тонкий пробел в данном случае более уместен, а строка по нему не рвется


Резюме

В настоящей главе мы обсудили вопросы, связанные с обработкой текстового материала публикации. Использование редактора материалов и специальных инструментов позволяет провести подготовку текста к верстке в сжатые сроки и качественно. Наряду с текстовым материалом в публикации важную роль играет графика — рисунки, чертежи, фотографии. Возможностям программы в этой области посвящены следующие две главы.


  • ЧАСТЬ III. ГРАФИКА
    • Глава 9. Рисование средствами PageMaker
      • Инструменты рисования в палитре инструментов
        • Рисование линий
        • Рисование прямоугольников и эллипсов
        • Рисование многоугольников
      • Трансформация графических объектов
        • Перемещение объекта
        • Масштабирование графических объектов
      • Атрибуты линий и фигур
        • Быстрое задание атрибутов линии
        • Быстрое оформление заливки
        • Комбинированная команда задания заливки и линии
      • Резюме


ЧАСТЬ III.

Графика

  • Глава 9. Рисование средствами PageMaker
  • Глава 10. Импорт графики
  • Глава 11 . Связывание файлов


ГЛАВА 9.

Рисование средствами PageMaker

Большинство графических элементов на страницах печатных изданий составляют не фотографии и даже не рисунки, а графические примитивы — линии (линейки), прямоугольники, многоугольники, окружности и эллипсы с разным заполнением и обводками. Они служат для выделения фрагментов текста и отделения их друг от друга. Особенно широко простейшие фигуры применяются там, где нет возможности использовать сложную графику — в газетах, рекламных листовках, простейших афишах, объявлениях, вывесках и т. п.

Возможность рисования графических примитивов включена непосредственно в издательские системы, в том числе и в PageMaker. С помощью встроенных инструментов рисования можно создавать сплошные и штрихпунктирные линии любой толщины и любого цвета, прямоугольники с разнообразными заливками и обводками, многоугольники и эллипсы.

В главе рассматриваются следующие вопросы:

  • Рисование графических примитивов: линий, прямоугольников, эллипсов и многоугольников.
  • Масштабирование и перемещение примитивов.
  • Атрибуты заполнения обводок фигур.


Инструменты рисования в палитре инструментов

Для каждого графического примитива существует специальный инструмент его создания, находящийся в палитре инструментов (см. гл. I).

Для выбора в палитре инструментов можно использовать комбинации клавиш. Не являются исключением инструменты рисованийЦрис. 9.1). Список комбинаций клавиш приведен ниже в табл. 9.1.

Таблица 9.1. Комбинации клавиш для выбора инструментов рисования

Инструмент | Комбинация клавиш
Линия | <Shift>+<F3>
Перпендикуляр | <Shift>+<F3>
Прямоугольник | <Shift>+<F4>
Эллипс | <Shift>+<F5>
Многоугольник | <Shift>+<F3>

Рис. 9.1. Инструменты рисования в палитре инструментов


Рисование линий

Для создания линии выберите одноименный инструмент Line (Линия) или Constrained Line (Перпендикуляр) из палитры, поместите указатель мыши в ту точку на странице, с которой линия должна начинаться, нажмите левую кнопку мыши и перетащите указатель в точку, где линия должна заканчиваться, затем отпустите кнопку. Для всех инструментов рисования указатель имеет форму перекрестия (для более точного позиционирования).

Нарисованная линия будет иметь те параметры (вид, толщину и цвет), кото-рые определены умолчаниями PageMaker для данного документа или глобально (см. гл. 3). Глобальным умолчанием, установленным создателями программы, линиям присваиваются черный цвет, сплошной вид и толщина в 1 пункт.

Инструменты Line (Линия) и Constrained Line (Перпендикуляр) отличаются лишь тем, что первый рисует линии под любым углом, а второй — только под углом, кратным 45° (0, 45, 90, 135, 180, 225, 270 и 315°). Впрочем, с помощью инструмента Line (Линия) также можно рисовать линии под углами, кратными 45°. Для этого в процессе рисования надо держать нажатой клавишу <Shift>.


Рисование прямоугольников и эллипсов

Прямоугольник — второй по частоте использования графический примитив. Для его создания выберите инструмент Rectangle (Прямоугольник) в палитре инструментов, поместите курсор мыши в точку, где должен находиться один из углов, нажмите левую кнопку мыши и перетащите указатель к точке, где должен быть противоположный угол фигуры. Прямоугольник будет построен после того, как вы отпустите кнопку мыши.

Вид нарисованного прямоугольника определяется локальными и глобальными умолчаниями. Если вы не меняли умолчания, то создается фигура без заливки о черной обводкой толщиной в 1 пункт.

Примечание

Если при рисовании прямоугольника держать нажатой клавишу <Shift>, то PageMaker будет поддерживать равенство сторон прямоугольника и таким образом будет нарисован квадрат.

Для скругления углов у выбранного прямоугольника (эта возможность пригодится, например, при создании рамок) воспользуйтесь командой Rounded Corners (Скругленные углы) из меню Element (Элемент). Команда открывает диалоговое окно Rounded Corners (Скругленные углы), в котором представлено несколько вариантов скругленных углов. Выберите подходящий и нажмите кнопку ОК. Результат представлен на рис. 9.2.

а

б

Рис. 9.2. Округление углов прямоугольника

В соответствии с логикой программы, если при выполнении команды не был выделен никакой прямоугольник, создается локальное умолчание. Все вновь создаваемые прямоугольники будут иметь скругленные выбранным образом углы. Открыть диалоговое окно Rounded Corners (Скругленные углы) можно также двойным щелчком на инструменте Rectangle (Прямоугольник) или воспользовавшись командой Rounded Corners (Скругленные углы) из контекстного меню.

Рисование эллипсов ничем не отличается от рисования прямоугольников. Вы задаете габаритный прямоугольник, в который программа вписывает эллипс. Сам габаритный прямоугольник не отображается.


Рисование многоугольников

С помощью инструмента Polygon (Многоугольник) можно создавать как правильные, так и произвольные многоугольники.

Для рисования правильного многоугольника следует сначала определить число его сторон. Диалоговое окно Polygon Settings (Многоугольник) вызывается двойным щелчком мыши на инструменте Polygon (Многоугольник) в палитре инструментов (рис. 9.3), а также одноименной командой меню Element (Элемент) или контекстного меню. Два ползунка этого окна определяют количество сторон многоугольника и степень его "звездообразноcти". Задание ненулевой величины для последнего параметра позволяет рисовать не только выпуклые многоугольники, но и звезды, а численное его значение определяет глубину ее лучей. Для установки параметров передвиньте ползунок или задайте численные значения в полях ввода. Окно просмотра демонстрирует многоугольник с заданными параметрами. Щелчок на кнопке ОК создаст умолчание.

Рисование многоугольников PageMaker организует так же, как и рисование эллипсов: вы задаете габаритный прямоугольник, в который вписывается создаваемый многоугольник. Сам габаритный прямоугольник на экране не отображается (рис. 9.4).

Рис. 9.3. Диалоговое окно Polygon Settings

Рис. 9.4. Рисование многоугольника

Чтобы переопределить параметры уже созданного многоугольника, выберите его, а затем выберите команду Polygon Settings (Многоугольник). В открывшемся окне будут отображены параметры выбранного многоугольника. Измените их по своему желанию.

Таким образом, чтобы создать многоугольник, отличный от принятого локальным умолчанием, можно не менять само умолчание, а просто изменить параметры существующей фигуры.

Рис. 9.5. Многоугольники одного размера с разным количеством сторон

Рис. 9.6. Звезды одного размера с разной глубиной лучей

Если выбрать инструмент Polygon (Многоугольник), поместить указатель на страницу публикации, нажать и отпустить левую кнопку мыши, то инструмент перейдет в режим рисования произвольных многоугольников. Этим действием вы зададите его первый угол. При перемещении мыши за указателем потянется прямая, представляющая собой сторону будущего многоугольника. Подведя указатель к точке расположения второго угла и щелкнув левой кнопкой мыши еще раз, вы зададите второй угол многоугольника и зафиксируете положение его первой стороны. Повторяя эту операцию несколько раз, вы создадите многоугольник с произвольным числом сторон, углов и их расположением (рис. 9.5 и 9.6). Завершается операция создания многоугольника щелчком мыши на первом его углу, т. е. нарисованную ломаную линию нужно замкнуть, чтобы получился многоугольник. Когда вы приблизите курсор мыши на достаточно близкое расстояние к начальной точке ломаной, вокруг нее появится прямоугольник, показывающий, что щелчок мышью создаст многоугольник. Пока этого не будет сделано, PageMaker будет считать операцию создания многоугольника незавершенной и не позволит вам сменить инструмент для выполнения другой операции.

Замкнуть ломаную линию можно и не подводя ее конечную точку к начальной (рис. 9.7). Когда будет определен последний угол многоугольника, нажмите любую клавишу, и программа соединит последнюю установленную точку прямой с исходной точкой.

Особую функцию имеет клавиша <Esc>. Ее нажатие прерывает создание фигуры без ее замыкания. Эту возможность используют для создания незамкнутых ломаных линий (рис. 9.8): инструментом Polygon (Многоугольник) рисуют желаемую ломаную линию, а когда последний отрезок будет создан, нажимают клавишу <Esc>.

Рис. 9.7. Рисование неправильного многоугольника

Рис. 9.8. Ломаная линия

Рис. 9.9. Редактирование многоугольника

После того как неправильный многоугольник создан, вы в... любой момент можете его отредактировать, т. е. изменить расположение углов, добавить новые или убрать лишние (рис. 9.9). Для этого сначала нужно сделать двойной щелчок мышью на границе многоугольника (или в любом месте, если многоугольник имеет заливку) при выбранном инструменте Pointer (Стрелка). В каждом углу многоугольника появятся квадратики. Теперь щелчок мышью на любой стороне многоугольника создаст в этом месте новый угол, а щелчок на любом существующем — удалит его. Перемещают углы, перетаскивая их мышью. Редактировать можно и правильные многоугольники, но после редактирования становится невозможным изменение его параметров в окне Polygon Settings (Многоугольник).

Все сказанное о редактировании многоугольников справедливо и для незамкнутых ломаных линий. Остается только заметить, что ломаные можно превращать в многоугольники (замыкать их начальную и конечную точки) и наоборот (размыкать многоугольник в любом месте). Для того чтобы замкнуть ломаную линию, щелкните мышью на ее начальной точке при нажатой клавише <Ctrl>. Для размыкания многоугольника проделайте такую же операцию с тем углом, в котором вы хотите его разомкнуть.


Трансформация графических объектов

Далеко не всегда при рисовании примитивов вы сможете поручиться за то, что их размер и местоположение не изменятся до самого конца верстки. Подобные случаи, скорее, являются редкими исключениями из общего правила. Разумеется, в PageMaker предусмотрена возможность изменения размеров графических объектов и их перемещения по странице публикации.

Для проведения любых манипуляций объект должен быть выбран (выделен). Выбор производят щелчком инструментом Pointer (Стрелка) на границе объекта, если он не имеет заливки, и в любом его месте, если заливка есть. Также выделить объект можно, "нарисовав" инструментом Pointer (Стрелка) прямоугольную рамку, во внутреннюю область которого объект попадет целиком. Если в определенную таким способом область попадают несколько объектов, то все они будут выделены одновременно.

Каждый объект PageMaker, будь то графический примитив, импортированная графика или текстовый блок, характеризуется одной единственной координатой и значениями высоты и ширины. Координаты объекта определяются по его якорной точке. Для линии якорной точкой могут быть правый, левый концы или середина. Для всех прочих объектов, имеющих площадь (линия как математическое понятие не имеет площади), якорными точками могут быть углы описанного вокруг объекта прямоугольника и середины его сторон. Все они носят общее название активных точек и играют важную роль при масштабировании, повороте, искажении и отражении объекта (см. гл. 14). PageMaker показывает положение активных точек вокруг нарисованного объекта (рис. 9.10).

Рис. 9.10. Активные точки для линии и эллипса

Выбрать якорную из показанных активных точек можно в любой момент, и в любой момент ее можно переопределить. В управляющей палитре для этого предусмотрен специальный переключатель (рис. 9.11).

а

б

Рис. 9.11. Выбор якорной точки для прямоугольника (а) и линии (б) в управляющей палитре


Перемещение объекта

Для перемещения объекта выделите его инструментом Pointer (Стрелка) и перетащите на новое место (перетаскивание, напомним, — это перемещение указателя мыши при нажатой левой кнопке).

Если проделать операцию перемещения достаточно быстро, то объект будет отображаться только его габаритной рамкой, что затрудняет позиционирование непрямоугольных объектов. Чтобы при перемещении объекта он отображался целиком и его движение напоминало мультипликацию, следует после нажатия кнопки мыши и до ее перемещения подождать несколько секунд. При этом курсор примет форму треугольной стрелки (рис. 9.12). В этом режиме при перемещении будет виден сам объект.

Если перемещение объекта следует осуществить строго по вертикали или горизонтали, то перемещая его, держите нажатой клавишу <Shift>.

Рис. 9.12. Перемещение объекта


Масштабирование графических объектов

При масштабировании графических объектов также используется инструмент Pointer (Стрелка). Для начала объект нужно выделить. При этом вокруг него появятся активные точки. Поместите указатель мыши в одну из них, нажмите левую кнопку и перетаскивайте указатель (он имеет форму двунаправленной стрелки), добиваясь требуемого размера объекта (рис. 9.13). Если вы выбрали угловую точку, меняться будут оба измерения объекта, при выборе точки на стороне габаритнго прямоугольника объект масштабируется только по одному измерению.

Если держать нажатой клавишу <Shift>, PageMaker приведет габаритную рамку объекта к квадрату, т. е. масштабирование прямоугольника преобразует его в квадрат, а эллипс — в окружность, многоугольник изменится так, что его ширина и высота станут одинаковыми.

Размеры графических объектов, созданных средствами рисования PageMaker, нельзя изменить инструментом Cropping (Рамка).

Рис. 9.13. Масштабирование объекта


Атрибуты линий и фигур

Все операции масштабирования, перемещения и др. рассчитываются программой без учета толщины линий и фигур. Однако любая линия может иметь обводку. Для упрощения изложения мы в дальнейшем будем говорить о толщине линии, имея в виду толщину ее обводки.

Контуры (граничные линии) всех фигур имеют те же атрибуты, что и отдельные линии, поэтому, все, что будет сказано ниже об атрибутах (обводках и типах) линий, действительно и для обводок фигур.


Быстрое задание атрибутов линии

В программе можно задавать сплошные, пунктирные, штрихпунктирные, одинарные и двойные обводки любой толщины и цвета.

Быстро задать тип и толщину обводки из списка наиболее часто употребляемых можно командой Stroke (Линия) меню Element (Элемент). В списке, открывающемся этой командой, представлены восемь сплошных линий разной толщины, четыре типа двойных линий и пять видов пунктира наиболее часто встречающейся толщины. Этот список представлен на рис. 9.14.

Рис. 9.14. Вложенное меню Stroke

Рис. 9.15. Диалоговое окно Custom Stroke

Если в меню выбран пункт None (Нулевая), то, присутствуя как объект на странице, линия не отображается на экране. Заметьте, что если эта установка попала в умалчиваемые (например, вам приходилось рисовать несколько прямоугольников без обводок, и вы создали такое умолчание), то при рисовании линий вы не увидите плодов своих трудов, пока вслепую не обнаружите эти невидимые линии на листе и не измените их атрибуты. Невидимые фигуры применялись хитроумными верстальщиками в ранних версиях PageMaker для создания на странице областей, свободных от текста, но с появлением в PageMaker непечатаемых объектов (версия 6.0) и фреймов (версия 6.5) появилось более простое решение данной задачи.

С помощью команды Custom (Заказная) этого же меню можно придать линии любую толщину в диапазоне от 0 до 800 пунктов с шагом 0,1 пункта (рис. 9.15).

Атрибуты Reverse (Инверсная) и Transparent background (Прозрачная основа), присутствующие и в меню Stroke (Линия), и в окне Custom Stroke (Заказная линия), позволяют получить, соответственно, ""негатив" заданной линии и придать просветам в пунктирных линиях прозрачность. Более подробно смысл этих атрибутов рассмотрен ниже.

Примечание

Толщина линии Hairline (Визирная) составляет всего 0,2 пункта. При работе с такими тонкими линиями надо учитывать характеристики устройства, на котором они выводятся. Даже хороший монитор не отображает линии тоньше 1 пункта при отображении на экране полной страницы. Для того чтобы позволить вам увидеть более тонкую линию, PageMaker утолщает до этого значения экранные изображения всех более тонких линий. Когда же дело дойдет до печати, визирные линии будут иметь меньшую толщину (в зависимости от разрешения устройства вывода).

Тонкие линии могут также быть неверно напечатаны в типографии по причинам, связанным с низким качеством полиграфического оборудования или особенностями бумаги. Например, при печати на низкосортной бумаге линия расплывется и станет значительно толще задуманной. Устаревшее оборудование для производства офсетных форм, наоборот, может полностью или, что еще хуже, частично "удалить" такие линии с отпечатка.


Быстрое оформление заливки

Для авторов и пользователей PageMaker более традиционным с точки зрения русского языка является использование термина "заливка", тогда как в локализованной версии применяется термин "фон". Поэтому мы, используя в тексте термин "заливка", оставляем в названиях элементов интерфейса термин "фон".

Для быстрого оформления внутренних областей фигур существует команда Fill (Фон) из меню Element (Элемент). В открывающемся вложенном меню можно найти несколько наиболее часто употребляющихся типов заливок: сплошная, цвета бумаги и с разными вариантами штриховки (рис. 9.16).

Рис. 9.16. Вложенное меню Fill

Рис. 9.17. Заливка незамкнутой ломаной

Рис. 9.18. Заливка самопересекающегося многоугольника

Заливка может быть назначена и незамкнутой ломаной линии (рис. 9.17).

Если многоугольник самопересекается, программа заливает все получившиеся таким образом замкнутые контуры (рис. 9.18).


Комбинированная команда задания заливки и линии

Команда Fill and Stroke (Фон и линия) меню Element (Элемент) открывает диалоговое окно, приведенное на рис. 9.19.

Рис. 9.19. Диалоговое окно Fill and Stroke

В этом диалоговом окне находятся те же списки, что и в рассмотренных выше меню Stroke (Линия) и Fill (Фон). Точно так же здесь можно задать типы заливки и линий, атрибуты Transparent background (Прозрачная основа) и Reverse (Инверсная). Кроме того, для заливки и линий можно выбрать цвет из числа определенных в публикации цветов и его оттенок. Процедуры определения и назначения цветов подробно обсуждаются в гл. 19 и 20. С помощью переключателя Overprint (Наложение) для заливки можно также определить, будет она печататься с наложением или нет. Этот прием также описан в гл. 20.

Диалоговое окно Fill and Stroke (Фон и линия) может быть вызвано одноименной командой контекстного меню при выбранном графическом элементе.

Цвета заливки None и Paper

При появлении на странице нового объекта, будь то нарисованная или импортированная графика или текст, PageMaker размещает его поверх других. Таким образом, чем позже элемент создан, тем он выше располагается. Если элементы занимают один и тот же участок страницы, они накладываются друг на друга таким образом, что верхний перекрывает нижний. Какой из элементов будет закрывать другой, определяется очередностью их создания.

Для изменения порядка перекрывания предназначены команды подменю Arrange (Монтаж) меню Element (Элемент) вложенного меню. Это команды Send to Back (На задний план), Bring to Front (На передний план), Bring Forward (Сдвинуть вперед) и Send Backward (Сдвинуть назад). Перечислим комбинации клавиш, соответствующие этим командам:

  • Сдвинуть вперед <Ctrl>+<]>;
  • Сдвинуть назад <Ctrl>+<[>;
  • На передний план <Ctrl>+<Shift>+<]>;
  • На задний план <Ctrl>+<Shift>+<[>.

Если вышележащий объект не прозрачен, через него не виден нижележащий объект. Сделать объект прозрачным можно, отменив заливку этого объекта командой None (Без фона) меню Fill (Фон). Не следует путать этот атрибут с заливкой цвета Paper (Бумага) и инверсной заливкой. Атрибут None (Без фона) означает отсутствие типографской краски во внутренней области объекта. Заливка цвета бумаги это то, что на языке полиграфии называется вывороткой (knockout). Выворотный объект предполагает отсутствие типографской краски в ограничиваемой им области. На рис. 9.20 представлена иллюстрация взаимодействия заливок и вывороток.

Рис. 9.20. Действие "цветов"

На рисунке в качестве цвета бумаги определен светло-желтый. Далее располагается прямоугольник с 50%-ной серой заливкой. Выше него расположен эллипс с атрибутом заливки None (Без фона) и черной обводкой. Поверх этих объектов лежит текст, первая строка которого имеет цвет бумаги; вторая — белую заливку; третья — черную.

Заметьте, что если цветом заливки объекта указан цвет Paper (Бумага) (в нашем примере светло-желтый), PageMaker заставит принтер оставлять "дырку" на месте этого объекта, а не печатать цветом, совпадающим с цветом бумаги (в нашем примере светло-желтым). Если же определить в публикации цвет, идентичный цвету Paper (Бумага), но с другим именем, а затем напечатать объект, заполненный этим цветом, то объект будет напечатан не как выворотный, а просто краской этого, совпадающего с бумагой цвета.

Через внутреннюю незаполненную область эллипса виден прямоугольник. Это иллюстрирует отличие заливки None (Без фона) от Paper (Бумага). Заливка None (Без фона) делает эллипс прозрачным. Если бы он был заполнен цветом Paper (Бумага), то был бы напечатан вывороткой т. е. в его внутренней области краска бы отсутствовала, как отсутствует она в области, ограничиваемой символами шрифта. Если эллипс перенести на передний план, то его обводка будет напечатана поверх выворотного текста.

Все сказанное выше относится не только к заливкам, но и к обводкам. Аналогичный пример приведен для линий на рис. 9.21.

Рис. 9.21. Пунктирные линии с различными цветами обводок и атрибутов Reverse и None

Сброшенный атрибут Reverse (Инверсная) отображает линию черным цветом, а установленный — цветом бумаги (вывороткой). Установленный атрибут прозрачности отображает промежутки пунктира цветом None (Нулевая), а сброшенный — черным (т. е. цветом обводки).


Резюме

Для оживления дизайна публикации используются графические примитивы с разным сочетанием обводок и заливок. Более сложная графика (схемы, диаграммы, рисунки и фотографии) придают публикации дополнительную убедительность и информативность. Сложные графические материалы подготавливаются в специализированных приложениях с тем, чтобы объединиться с текстом уже на стадии верстки в издательской системе. Импорту графических материалов и посвящена следующая глава.


  • ЧАСТЬ VII. ПРИЛОЖЕНИЯ
    • Приложение 1. Работа над ошибками
      • Профилактика неполадок
      • Разбивайте книгу на части
      • Не работайте на пределе ресурсов
      • Выясняйте причины сбоев системы
      • Сохраняйте публикации командой Save As
      • Редактируйте импортированные стили
      • Пользуйтесь технологией PageMaker Links
      • Наконец, создавайте резервные копии!
    • Когда PageMaker почувствует себя плохо
      • Выполнение диагностической сборки
      • Что еще можно попробовать сделать средствами программы PageMaker
      • Операции с файлами на уровне рабочего стола


ЧАСТЬ VII.

Приложения

  • Приложение 1 . Работа над ошибками
  • Приложение 2. Комбинации клавиш в PageMaker


ПРИЛОЖЕНИЕ 1

Работа над ошибками.

Профилактика неполадок .

Легче всего с неприятностями справляться, пока они еще не возникли. Избегайте риска — это лучший способ обезопасить себя. Ниже описывается тактика консервативного применения средств программы PageMaker.


Разбивайте книгу на части

Это справедливо при работе с любым приложением — чем больше размер файлов данных, тем сложнее с ними работать, и тем выше риск возникновения аварийных ситуаций. Если в технических характеристиках сказано, что программа PageMaker в принципе способна построить книгу объемом в 999 страниц, это еще не повод заставлять его делать это. Разбейте книгу на отдельные главы, и пользуйтесь командой Book (Книга). В таком варианте и приложение не работает на пределе возможностей, и вам удобнее ориентироваться в меньшем числе страниц.

Существуют найденные экспериментальным путем пределы на размеры файлов в формате публикации PageMaker. В технических характеристиках сказано, что размер файла ограничен только объемом имеющейся памяти, но опять-таки это — не повод балансировать на краю пропасти. Файлы можно связывать друг с другом, храня их на диске раздельно (особенно это относится к графическим файлам большого размера). Нет никакого смысла сохранять графические изображения дважды — в отдельном файле и в составе публикации.


Не работайте на пределе ресурсов

Итак, первая аксиома — "чем больше файлы, тем сложнее с ними работать". С ней тесно связана и вторая аксиома. Степень риска обратно пропорциональна объему не использующихся ресурсов компьютера. Если вы пытаетесь работать с малым объемом оперативной памяти или при почти полном отсутствии свободного места на диске, можно считать, что вы провоцируете возникновение аварийной ситуации.


Выясняйте причины сбоев системы

Если в системе часто возникают сбои (например, из-за конфликтов резидентных программ или драйверов устройств), с неизбежностью рано или поздно это приведет к порче структуры файлбв публикаций, с которыми вы работаете в момент сбоя. Потратьте время на выяснение причин сбоев — это время окупится спокойной работой без постоянных переделок. Большинство конфликтов связано с программным обеспечением. Обращайте внимания на те программы, которые вызывают сбои и попробуйте переустановить их или отказаться от их использования в процессе верстки. Устанавливайте программное обеспечение в хронологическом порядке его выпуска. Это позволит избежать опасности замещения новых версий общедоступных библиотек динамической компоновки старыми (к сожалению, не все программы установки отслеживают номера версий библиотек).


Сохраняйте публикации командой Save As

Перед окончанием сеанса работы с PageMaker воспользуйтесь командой Save As (Сохранить как). Публикация будет сохранена под новым именем, что автоматически обеспечит вам резервную копию публикации.

Кроме того, команда Save As (Сохранить как) сохраняет публикацию в файле на диске максимально компактным образом, что до некоторой степени уменьшает риск возникновения сбоев из-за чрезмерного размера и усложнения структуры публикации, записанной приемом быстрого сохранения.


Редактируйте импортированные стили

В процессе импортирования текста из файла, подготовленного текстовым процессором, в списке стилей появляются новые стили оформления абзацев. Имена импортированных стилей в списке палитры стилей обозначаются пиктограммой с изображением дискеты. Присутствие ее в имени стиля говорит о том, что PageMaker не считает эти стили "своими" в полной мере. Выполните на имени каждого из импортированных стилей щелчок мышью при нажатой клавише <Ctrl>, а затем щелкните мышью на кнопке ОК, сохраняя стиль в оптимальной для PageMaker форме.


Пользуйтесь технологией PageMaker Links

Пользуйтесь традиционной технологией связывания файлов программы PageMaker. Конечно, технология OLE, столь широко использующаяся в других приложениях, представляется весьма многообещающим средством для организации работы группы или наращивания возможностей отдельного пользователя. Тем не менее рекомендуется пользоваться технологией Place and Link. Эта технология традиционна, проверена многолетней практикой и хорошо изучена. Кроме того, она увеличивает степень независимости публикации и не требует сложной организации рабочей среды.

Опыт авторов показывает, что повреждение объектов OLE — одна из самых частых причин сбоев, особенно при переносе файлов на другие компьютеры.


Наконец, создавайте резервные копии!

Следовало бы поставить этот совет первым пунктом, но ведь вы и так об этом знаете. Если вы создаете резервные копии достаточно часто, то скорее всего, никогда не заглянете в это приложение! Среда Windows позволяет организовать автоматическое резервное копирование. Если вы работаете в сколь-либо крупном издательстве, то, скорее всего, в нем имеется централизованная система резервирования. Если таковая отсутствует, то обратитесь к системному администратору вашей локальной сети и расскажите о необходимости автоматического резервного копирования.


Когда PageMaker почувствует себя плохо

К сожалению, не существует абсолютно свободных от ошибок программ. PageMaker не является исключением из правила, хотя надо отдать должное разработчикам, она весьма надежна. Проблема еще и в том, что сбои могут быть вызваны не самим PageMaker, а другими программами или устройствами. Это сильно затрудняет диагностику сбоев и иногда ставит пользователя в критическое положение, когда срок сдачи публикации уже на носу, а PageMaker начинает работать с ней все более неустойчиво. Особенно скверно, когда PageMaker сообщает о том, что вообще отказывается работать с вашей публикацией, ссылаясь на загадочные ошибки в индексах записей или файловой системе. Хочется еще раз напомнить о необходимости резервного копирования, но всякое бывает... Ниже собраны несколько рекомендаций о том, что делать, если страшное уже произошло.

Это происходит неожиданно. Программа PageMaker выдаст сообщение об аварии, причем — в самый неподходящий момент.

Сохраняйте спокойствие. Помните, что точных рецептов в такой ситуации заранее дать невозможно, очень многое зависит от специфики возникшей проблемы, поэтому подойдите к ней с достаточной гибкостью. Думайте. Если проблему не удается устранить, попробуйте выполнить некоторые из перечисленных ниже приемов повторно. Некоторые аварийные ситуации вызываются не одной, а целым рядом связанных друг с другом причин.

Internal error: Bad Record Index. Cannot lock block. Cannot Open Files.

Такие сообщения об ошибках вызываются порчей индекса записей. Индекс публикации PageMaker, который испортился в этом случае, очень похож на индексные файлы, широко используемые в системах управления базами данных. При ближайшем рассмотрении файлы программы PageMaker оказываются больше похожи по структуре на базы данных, чем на файлы документов текстового процессора. Поэтому в сообщениях об ошибках часто встречаются ссылки на связи, блокировку записей, блоки и записи.

Примечание

Перед запуском программы PageMaker после сбоя обязательно перезапустите компьютер, если он работает под управлением Windows 95. В аварийных случаях система не всегда оказывается способна полностью выгрузить из памяти вызвавшую сбой программу и все занятые ею ресурсы.

Если программу PageMaker удастся запустить заново и открыть файл испорченной структуры, попробуйте в первую очередь выполнить диагностическую сборку публикации.

Примечание

Все меры по "спасению" публикации следует проводить не с неисправным файлом, а с его копией. Таким образом вы застрахуете себя от уже необратимой порчи файла публикации. Наиболее сильнодействующие из приведенных рекомендаций способны не только исправить возникшие ошибки, но и усугубить их. Это возможно потому, что при сбое программы мы знаем только симптомы, но не знаем причин самой болезни.


Выполнение диагностической сборки

В PageMaker входит подпрограмма "чистки" файлов публикаций, выполняющая пять операций. Она восстанавливает структуру списка стилей, а затем "чистит" материалы, индексы и связи. В заключение эта программа повторно собирает публикацию в виде документа — иными словами, пытается исправить испорченные связи, блокировки, индексы и записи.

Перед началом диагностической сборки убедитесь, что активным инструментом является Pointer Tool (Стрелка). Для надежности выполните двойной щелчок мышью на этом инструменте в палитре инструментов. Удерживая нажатой комбинацию клавиш <Shift>+<Ctrl>, выберите команду Pointer Tool (Стрелка) в меню Туре (Текст). Прозвучит звуковой сигнал — один, два или три раза.

  • Один звуковой сигнал означает, что сборка публикации прошла без ошибок, и исправлять было нечего.
  • Два звуковых сигнала означают, что программа обнаружила и благополучно исправила одну или несколько ошибок.
  • Три звуковых сигнала говорят о наличии в файле серьезных нарушений. Ищите резервную копию. Повторную сборку публикации выполнить не удалось из-за неисправимых ошибок. В случае двух или трех звуковых сигналов попробуйте выполнить диагностическую сборку еще один раз — хуже не станет.

По завершении диагностической сборки немедленно сохраните ее результат в новом файле с другим именем при помощи команды Save As (Сохранить как).


Что еще можно попробовать сделать средствами программы PageMaker

Если публикацию удалось открыть, кроме диагностической сборки можно попробовать выполнить следующие действия:

  • Просмотр публикации в режиме слайд-фильма. Просмотрите все страницы публикации при помощи команды Go to Page (Перейти к странице) меню Layout (Макет). Если эту команду выбрать при нажатой клавише <Shift>, программа PageMaker перейдет на первую страницу публикации и начнет последовательно отображать все страницы публикации на экране — одну за другой. Для того чтобы отобразить страницы на экране, программа PageMaker будет отыскивать все элементы каждой страницы, выполняя мини-сохранение после завершения вывода на экран очередной. При этом есть шанс, что все элементы будут найдены. Впрочем, это одна из многочисленных "легенд", ходящих в среде пользователей. Авторам ни разу не приходилось наблюдать действенность этого метода.
  • Поиск аварийного элемента (при помощи команды Links Manager (Связанные файлы)). Откройте диалоговое окно Links Manager (Связанные файлы). Просмотрите весь список связей — нет ли среди них неразрешенных? Такие связи будут помечены признаком UN или вопросительным знаком. Разорвите эти связи и сохраните публикацию при помощи команды Save As (Сохранить как), желательно — в файле с другим именем. Попробуйте удалить внедренные OLE-объекты из публикации.
    Если этот прием не даст желаемых результатов, разорвите все связи, имеющиеся в публикации. Впоследствии, если потребуется, вы сможете заново установить их. Это хлопотно и малоприятно, но, все-таки, намного проще, чем строить всю публикацию заново "от нуля".
  • Поиск аварийного элемента вручную. Откройте публикацию и последовательно выделите при помощи инструмента Pointer Tool (Стрелка) каждый элемент на каждой странице. Для каждого элемента выберите в меню Element (Элемент) команду Link Info (Информация о связи). Если при этом выдается сообщение об ошибке, выделенный элемент может быть причиной аварии. Удалите его, сохраните публикацию при помощи команды Save As (Сохранить как), и замените дефектный элемент. Но не обольщайтесь слишком рано — то, что вы нашли один дефектный элемент, еще не означает, что вы устранили причины аварии. Обязательно проверьте все остальные элементы.
  • Поиск дефектного стиля оформления абзаца. Одним из типов записей, которые могут "испортиться", являются стили оформления абзацев. Проще всего найти дефектный стиль при помощи списка имен стилей, расположенного в палитре стилей. Выполните на имени стиля щелчок мышью, удерживая нажатой клавишу <Ctrl>. Если при этом выдается сообщение об ошибке, то вы нашли дефектный стиль. Так же, как в случае с внешними элементами публикации, дефектных стилей может быть и несколько, поэтому их список следует проверить до конца.

    Если ясно, что в списке имеется дефектный стиль, выберите команду Define Styles (Определить стили) и задайте стиль абзаца с теми же атрибутами, что у дефектного, но с другим именем. Назначьте новый стиль одному из абзацев, ранее отформатированных при помощи дефектного стиля. Затем в редакторе материалов замените все вхождения дефектного стиля на новый стиль. В особо сложных случаях замену стиля после поиска придется выполнить вручную. По окончании замен удалите дефектный стиль из списка.

  • Сохраните файл при помощи команды Save As (Сохранить как). Попробуйте создать новую копию аварийного файла при помощи команды Save As (Сохранить как). Программа PageMaker не сможет скопировать файлы, ссылки на которые оказываются не разрешенными, и это хорошо, поскольку, скорее всего, именно эти файлы являются причиной аварии.
  • Попробуйте импортировать текст дефектной публикации. В качестве последнего средства откройте в программе PageMaker новую, пустую публикацию и попробуйте импортировать в нее текст дефектной публикации при помощи фильтра импортирования текстовых материалов PageMaker, автоматически подключающегося при попытке импортировать публикацию PageMaker. Установите этот фильтр, если он не был установлен ранее (в процессе инсталляции).
  • Попробуйте экспортировать текст. Попробуйте спасти текст дефектной публикации при помощи команды Export (Экспорт). Так же, как в предыдущем случае (с применением фильтра импортирования материалов PageMaker) при этом будет утрачена вся тонкая настройка текста, но все же это лучше, чем перепечатка всего текста публикации заново. В некоторых случаях целесообразнее вместо этого варианта воспользоваться повторным импортированием текста из файла в формате текстового процессора.
  • Копирование элементов страницы. Откройте новую публикацию PageMaker и скопируйте в нее по очереди элементы каждой из страниц дефектной публикации. Для этого расположите рабочие окна обеих публикаций рядом друг с другом. Для ускорения процесса пользуйтесь командой Select All (Выделить все) при активном инструменте Pointer Tool (Стрелка).

Элементы можно просто перетаскивать из одной публикации в другую или копировать в системный буфер и вклеивать из него.


Операции с файлами на уровне рабочего стола

Если публикацию не удается открыть средствами программы PageMaker, попробуйте предпринять следующие действия на рабочем столе:

  • Отыщите временный файл в папке TEMP. Если компьютер "завис" в ходе сеанса работы с программой PageMaker, весьма вероятно, вам удастся отыскать где-нибудь временный файл. PageMaker выполняет мини-сохранение каждый раз при переходе на новую страницу и перед началом печати, причем это сохранение выполняется во временный файл. Поищите в папке, назначенной в системе Windows 95 для хранения временных файлов. Можно также запросить поиск файлов с расширением ТМР. Не исключено, что в одном из найденных временных файлов вам удастся отыскать сохраненную в ходе мини-умолчания работу, которую вы считали безвозвратно утраченной.
  • Скопируйте файл публикации. Иногда открыть файл не удается из-за ошибки на диске. Попробуйте скопировать файл, а затем попытайтесь открыть копию. Воспользуйтесь программами восстановления структуры файлов.

Наиболее известным комплектом программ для восстановления файлов являются утилиты Нортона. Не исключено, что их применение не даст желаемого результата, но попробовать стоит.

  • Попробуйте открыть публикацию командой PageMaker. Если публикацию не удается открыть как документ непосредственно с рабочего стола, запустите программу PageMaker вручную и воспользуйтесь его командой Open (Открыть).
  • Уменьшите размеры окна программы PageMaker. Если причина аварии состоит в поврежденной связи или дефектном графическом файле, иногда публикацию удается открыть, если программа PageMaker не будет отображать страницы на экране. Уменьшите, размеры окна программы PageMaker (скажем, до одного квадратного дюйма). Попробуйте открыть файл. Размеры страниц публикации получаются очень маленькие, и программа PageMaker даже не пытается отображать на них текст и графические элементы. После того как файл удалось открыть, можно воспользоваться описанными выше приемами восстановления его структуры.
  • Удалите файл умолчаний. Переименуйте файл PM65.CNF. (Вы ведь уже сделали его резервную копию?) Новое имя выберите таким образом, чтобы потом было легко вспомнить, что же это за файл. При следующем запуске программа PageMaker автоматически создаст новый файл умолчаний, и, хотя при этом вы потеряете все настройки, их восстановление не покажется чрезмерным трудом, если этот прием поможет сохранить результаты многочасовой работы над публикацией.
  • Откройте файл публикации при помощи текстового процессора. В этом случае текст будет буквально нашпигован специальными символами, и весь этот мусор придется удалять вручную, но все равно, это намного проще, чем перепечатывать все заново.

Примечание

Много полезной технической информации содержится в папке TECHINFO на компакт-диске программы PageMaker. Новая информация регулярно появляется на домашней странице фирмы Adobe http://www.adobe.com .


  • Приложение 2. Комбинации клавиш в PageMaker
    • Работа с макетом
    • Графические и текстовые объекты
    • Просмотр публикации
    • Форматирование текста
    • Редактор материалов
    • Перемещение курсора и кернинг
    • Палитры
    • Специальные символы
    • Метасимволы
    • Выделения
    • Прочие


ПРИЛОЖЕНИЕ 2 .

Комбинации клавиш в PageMaker

Работа с макетом

Общие команды верстки
Открыть диалоговое окно Document Setup | <Ctrl>+<Shift>+<P>
Открыть копию публикации или оригинал шаблона | <Shift>+File > Recent Publications
Восстановить последнюю промежуточную версию документа (мини-сохранение) | <Shift>+File > Revert
Сохранить все открытые публикации | <Shift>+File > Save All
Закрыть все открытые публикации | <Shift>+File > Close All
Закрыть публикацию | <Ctrl>+<W>
Режим верстки | <Ctrl>+<E>
Параметры фильтра импорта | <Shift>+кнопка OK в диалоговом окне Place
Показать установки | <Ctrl>+<K>
Обтекание иллюстраций текстом | <Ctrl>+<Art>+<E>
Вырезать (альтернатива <Ctrl>+<X>) | <Shift>+<Delete>
Скопировать (альтернатива <Ctrl>+<C>) | <Ctrl>+<lnsert>
Связанные файлы | <Ctrl>+<Shift>+<D>
Выровнять по направляющим | <Ctrl>+<Shift>+<;>
Выровнять по линейкам | <Ctrl>+<Alt>+<R>
Закрепить направляющие | <Ctrl>+<Alt>+<;>
Размещение | текста
Автоматическое или ручное размещение | <Сtrl>+щелчок мышью
Полуавтоматическое размещение | <Shift>+щелчок мышью
Добавление | страниц
Вставить страницу или разворот | <Ctrl>+<Alt>+<Shift>+<O>
Масштабирование | изображений
Пропорциональное (изображения и группы) | <Shift>+перемещение ограничителей
С учетом разрешения принтера | <Сtrl>+перемещение ограничителей
Пропорциональное с учетом разрешения | <Сtrl>+<Shift>+перемещение ограничителей
Отмена перерисовки при настройке границы обтекания | Удерживать <пробел>


Графические и текстовые объекты

Настройка графических и текстовых объектов
Маскировать | <Ctrl>+<6>
Сгруппировать | <Ctrl>+<G>
Отменить маскирование | <Ctrl>+<Shift>+<6>
Разгруппировать | <Ctrl>+<Shift>+<G>
Перемещение по вертикали или горизонтали | <Shift>+перетащить
Многократное вклеивание | <Ctrl>+<Alt>+<V>
Редактировать OLE-объект | Двойной щелчок на объекте
Редактировать оригинал | <Аlt>+двойной щелчок на объекте
Настройка выделенных объектов | Клавиши-стрелки
Настройка выделенных объектов 10х | <Shift>+клавиши-стрелки
Выделение нескольких элементов | <Shift>+щелчок на каждом элементе
Выделить элемент позади другого | <Сtrl>+щелчок
Выделить несколько элементов позади других | <Сtrl>+<Shift>+щелчок
Маскировать и сгруппировать | <Shift>+Element > Mask
Отменить маску и разгруппировать | <Shift>+Element > Unmask
Выровнять объекты | <Ctrl>+<Shift>+<E>
Сдвинуть вперед | <Ctrl>+<]>
На передний план | <Ctrl>+<Shift>+<]>
Сдвинуть назад | <Ctrl>+<[>
На задний план | <Ctrl>+<Shift>+<[>
Добавить или отделить содержимое фрейма | <Ctr]>+<F>
Преобразовать во фрейм или примитив | <Shift>+<Ctrl>+<Alt>+<F>
Закрепить или освободить объект | <Ctrl>+<Alt>+<L>
Поворот относительно центра | <Сtrl>+инструмент Rotating
Поворот на углы, кратные 45° | <Shift>+инструмент Rotating


Просмотр публикации

Окно макета
Общий масштаб для всех страниц | <Alt>+ View > Zoom to
Масштаб Fit in Window | <Ctrl>+<O> или двойной щелчок на инструменте Zoom
100% или Fit in Window (переключатель) | <Сtrl>+<Аlt>+щелчок на странице
100 или 200% (переключатель) | <Сtrl>+<Аlt
Масштаб 100% | Двойной щелчок на инструменте Zoom или <Ctrl>+<1>
Масштаб 50% | <Ctrl>+<5>
Масштаб 75% | <Ctrl>+<7>
Масштаб 200% | <Ctrl>+<2>
Масштаб 400% | <Ctrl>+<4>
Масштаб Actual Size | <Ctrl>+<1>
Редактировать материал | Тройной щелчок на текстовом блоке инструментом Pointer
Перерисовка страницы | <Ctrl>+<Shift>+<F12>
Перерисовка с высоким разрешением | <Ctrl>+<Shift>+Bbi6op любого масштаба
Автоматическое листание страниц | <Shift>+Layout > Go to Page
Переход к следующей странице | <Page Down>
Переход к предыдущей странице | <Page Up>
Переход назад по цепочке страниц | <Ctrl>+<Page Up>
Переход вперед по цепочке страниц | <Ctrl>+<Page Down>
Перейти к странице | <Ctrl>+<Att>+<G>
Переход к следующему фрейму | <Ctrl>+<Att>+<]>
Переход к предыдущему фрейму | <Ctrl>+<Att>+<[>
Увеличить | <Ctrl>+<+>
Уменьшить | <Ctrl>+<->
Монтажный стол | <Ctrl>+<Shift>+<O>
Показать непечатные элементы | <Ctrl>+<Alt>+<N>
Показать или спрятать направляющие | <Ctrl>+<;>
Показать или спрятать линейки | <Ctrl>+<R>
Гиперсвязи |
Просмотр гиперсвязей | <F10>


Форматирование текста

Кегль (только в режиме верстки)
Увеличить на 1 пункт | <Ctrl>+<Shift>+<>>
Следующий больший кегль | <Ctrl>+<Alt>+<>>
Уменьшить на 1 пункт | <Ctrl>+<Shift>+<<>
Следующий меньший кегль | <Ctrl>+<Alt>+<<>
Регистр
Все прописные (переключатель) | <Ctrl>+<Shift>+<K>
Позиция |
Надиндекс (переключатель) | <Ctrl>+<\>
Подиндекс (переключатель) | <Ctrl>+<Shift>+<\>
Нормальная | <Ctrl>+<Shift>+<C>
Tрэекинг |
Нормальная ширина | <Ctrl>+<Shift>+<X>
Без трекинга | <Ctrl>+<Shift>+<Q>
Интерлиньяж |
Автоинтерлиньяж | <Ctrl>+<Alt>+<Shift>+<A>
Увеличить/уменьшить 10х | <Shift>+кнопки настройки управляющей палитры
Начертание |
Полужирное | <Ctrl>+<Shift>+<B> или <F6>
Курсивное | <Ctrl>+<Shift>+<1> или <F7>
Нормальное | <Ctrl>+<Shift>+<пробел> или <F5>
Перечеркнутое | <Ctrl>+<Shift>+</>
Подчеркнутое | <Ctrl>+<Shift>+<U>
Инверсное | <Ctrl>+<Shift>+<V>
Параметры шрифта | <Ctrl>+<T>
Форматирование в диалоговом окне Indents/Tabs |
Настроить отступ слева | <Shift>+перемещение маркера
Отступы/Табуляция
Диалоговое окно | Indents/Tabs <Ctrl>+<l>
Выключка текста
По формату | <Ctrl>+<Shift>+<J>
Полная | <Ctrl>+<Shift>+<F>
Влево | <Ctrl>+<Shift>+<L>
Вправо | <Ctrl>+<Shift>+<R>


Редактор материалов

Редактор материалов
Текстовый режим и режим верстки (переключатель) | <Ctrl>+<E>
Закрыть активный материал | <Ctrl>+<W>
Закрыть все материалы публикации | <Shift>+Story > Close Story
Расположить каскадом все открытые окна во всех открытых публикациях | <Shift>+Window > Cascade
Расположить мозаикой все открытые окна во всех открытых публикациях | <Shift>+Window > Tile
Орфография | <Ctrl>+<L>
Заменить | <Ctrl>+<H>
Найти материал | <Ctrl>+<F>
Найти следующий материал | <Ctrl>+<G>
Диалоговое окно Find and Replace в текстовом режиме
Восстановить атрибут шрифта Any | <Аlt>+кнопка Char Attributes
Восстановить атрибут абзаца Any | <Аlt>+кнопка Para Attributes
Восстановить атрибут шрифта и абзаца Any | <Shift>+<Alt>+KHonKa Char Attributes или Para Attributes
Создание указателя
Просмотр указателя в активной публикации | <Ctrl>+Utilities > Show Index
Создать вход указателя | Выделить текст, <Ctrl>+<Y>
Быстро создать вход | Выделить текст, <Ctrl>+<Shift>+<Y>
Создать вход из имени | Выделить текст, <Ctrl>+<Alt>+<V>
Диалоговое окно Show Index
Удалить все входы указателя | <Ctrl>+<Alt>+<Shift>+ Remove
Удалить все перекрестные ссылки | <Ctrl>+<Shift>+Remove
Удалить все входы с адресными ссылками | <Ctrl>+<Alt>+Remove
Удалить все несохраненные входы | <Alt>+Add x-ref...
Восстановить входы, удаленные <Alt>+Remove после сохранения


Перемещение курсора и кернинг

Управление курсором (дополнительная клавиатура выключена)
В начало материала | <Ctrl>+<Page Up>
В конец материала | <Ctrl>+<Page Down>
Вверх/вниз на одну строку | <вверх/вниз>
Влево/вправо на один символ | <<-/->>
Влево на одно слово | <Ctrl>+<4-> или <Ctrl>+ <4> (дополнительная клавиатура)
Вправо на одно слово | <Ctrl>+<->> или <Ctrl>+ <6> (дополнительная клавиатура)
В начало предложения | <Ctrl>+<Home>
В конец предложения | <Ctrl>+<End>
Вверх на один абзац | <Ctrl>+вниз или <Ctrl>+ <S> (дополнительная клавиатура)
Вниз на один абзац | <Ctrl>+<вниз> или <Ctrl>+ <2> (дополнительная клавиатура)
Кернинг (только в режиме верстки)
Удалить ручной кернинг | <Ctrl>+<Alt>+<K>
Увеличить или уменьшить 10х | <Shift>+кнопки настройки в управляющей палитре
Кернинг с помощью клавиш-стрелок
Раздвинуть на 0,01 em | <Alt>+<->>
Сдвинуть на 0,01 em | <Alt>+<<->
Раздвинуть на 0,04 em | <Ctrl>+<Alt>+<->>
Сдвинуть на 0,04 em | <Ctrl>+<Alt>+<<->
Кернинге помощью клавиши <Backspace>
Раздвинуть на 0,04 em | <Ctrl>+<Shift>+<Backspace>
Сдвинуть на 0,04 em | <Ctrl>+<Backspace>
Кернинг c помощью дополнительной клавиатуры
Раздвинуть на 0,01 em | <Сtrl>+<Shift>+ <+>(дополнительная клавиатура)
Сдвинуть на 0,01 em | <Сtrl>+<Shift>+<->(дополнительная клавиатура)
Раздвинуть на 0,04 em | <Сtrl>+<+>(дополнительная клавиатура)
Сдвинуть на 0,04 em | <Сtrl>+<->(дополнительная клавиатура)


Палитры

Управление палитрами
Показать или спрятать все палитры | <Таb>
Показать или спрятать все палитры, кроме палитры инструментов | <Shift>+<Tab>
Минимизировать палитру (переключатель) | Двойной щелчок на закладке
Редактировать объект в палитре | Двойной щелчок на объекте
Палитра Cont rol Palette
Показать или спрятать управляющую палитру | <Ctrl>+<'> (апостроф)
Активизировать управляющую палитру (переключатель) | <Ctrl>+<'> (обратный апостроф)
Режимы Paragraph и Character (переключатель) | <Ctrl>+<Shift>+<~>
Переход к следующему параметру | <Tab>
Возврат к предыдущему параметру | <Shift>+<Tab>
Выбор активной точки на схеме | Дополнительная клавиатура при активной схеме
Показать последнее значение параметра при активной управляющей палитре | <Esc>
Внести изменения и вернуться в публикацию | <Enter>
Внести изменения и сохранить активность текущего поля ввода | <Shift>+<Enter>
Включить или выключить выделенную кнопку | <пробел>
Выбрать другую единицу измерения для текущего параметра | <Ctrl>+<Alt>+<M>
Увеличить шаг настройки в 10 раз | <Shift>+кнопки настройки
Поднять или опустить базовую линию с десятикратным шагом | <Сtrl>+настройки базовых линий
Выбрать стиль начертания | Ввод первых нескольких символов
Выбрать гарнитуру или трекинг | Ввод первых нескольких символов
Перейти к следующий активной точке на схеме | Клавиши-стрелки при активной схеме

Палитра Master Pages

Показать или спрятать палитру Master Pages | <Ctrl>+<Shift>+<8>
Редактировать страницу-шаблон | Двойной щелчок на имени шаблона
Удаление элементов шабл | онов с обычных страниц
Удалить все объекты с одной страницы | Щелчок на элементе [None]
Удалить объекты с обеих страниц | <Аlt>+щелчок на элементе [None]
Удалить объекты и вспомогательные линии с обеих страниц | <Shift>+щелчок на элементе [None]
Удалить объекты и колонки с обеих страниц | <Аlt>+<Shift>+щелчок на элементе [None]
Палитра Colors
Показать или спрятать палитру Colors | <Ctrl>+<J>
Редактировать цвет | Двойной щелчок на имени цвета
Фон и линия | <Ctrl>+<U>
Палитра | Styles
Показать или спрятать палитру Styles | <Ctrl>+<B>
Редактировать стиль | Двойной щелчок на имени стиля
Палитра | Layers
Показать или спрятать палитру Layers | <Ctrl>+<8>
Выделить все на активном слое | <Ctrl>+<Alt>+<A>
Редактировать параметры слоя | Двойной щелчок на имени слоя
Палитра Нyperlinks
Показать или спрятать палитру Hyperlinks | <Ctrl>+<9>
Редактировать гиперсвязь | Двойной щелчок на имени гиперсвязи


Специальные символы

Жирная точка (•) | <Alt>+<S>
Закрывающие одинарные кавычки (') | <Alt>+<]>
Закрывающие двойные кавычки (") | <Alt>+<Shift>+<]>
Знак авторского права (©) - | <Alt>+<G>
Дискреционный (мягкий) перенос | <Ctrl>+<Shift>+<->
Длинное тире | <Alt>+<Shift>+<->
Круглая шпация | <Ctrl>+<Shift>+<M>
Короткое тире | <Alt>+<->
Полукруглая шпация | <Ctrl>+<Shift>+<M>
Футы, минуты | <Ctrl>+<Alt>+<">
Принудительный перенос строки | <Shift>+<Enter>
Дюймы, секунды (") | <Ctrl>+<Alt>+<Shift>+<">
Фиксированный пробел | <Сtrl>+<Аlt>+<пробел>
Фиксированный дефис | <Ctrl>+<Alt>+<->
Фиксированная косая черта | <Ctrl>+<Alt>+</>
Открывающие одиночные кавычки (') | <Alt>+<[>
Открывающие двойные кавычки (") | <Alt>+<Shift>+<[>
Номер страницы | <Ctrl>+<Alt>+<P>
Абзац | <Alt>+<7>
Зарегистрированный товарный знак (®) | <Alt>+<R>
Параграф (§) | <Alt>+<6>
Тонкая шпация (1/4 круглой) | <Ctrl>+<Shift>+<T>


Метасимволы

Коды в диалоговом окне Find and Replace
Жирная точка (•) | ^8
Знак вставки (^) | ^^
Закрывающие двойные кавычки (") | ^}
Закрывающие одинарные кавычки (') | ^]
Компьютерный перенос | ^c
Знак авторского права (©) | ^2
Дискреционный перенос | ^-
Длинное тире | ^_
Круглая шпация | ^m
Короткое тире | ^=
Полукруглая шпация | ^>
Метка гиперсвязи и закладки | ^:
Маркер входа указателя | ^;
Вложенное изображение | ^g
Принудительный перенос строки | ^n
Фиксированный дефис | ^~
Фиксированная косая черта | ^/
Фиксированный пробел | ^s
Открывающие двойные кавычки (") | ^{
Открывающие одинарные кавычки (') | ^[
Маркер номера страницы | ^3
Абзац | ^7
Конец абзаца (возврат каретки) | ^p
Вход указателя (личное имя) | ^z
Зарегистрированный товарный знак (®) | ^y
Параграф (§) | ^6
Табулятор | ^t
Тонкая шпация | ^<
Любой символ | ^?


Выделения

Выделение текста (дополнительная клавиатура выключена)
Выделить предложение слева | <Ctrl>+<Shift>+<7> (дополнительная клавиатура)
Выделить предложение справа | <Ctrl>+<Shift>+<1> (дополнительная клавиатура)
Выделить до начала строки | <Shift>+<7> (дополнительная клавиатура)
Выделить до конца строки | <Shift>+<1> (дополнительная клавиатура)
Выделить до начала материала | <Ctrl>+<Shift>+<9> (дополнительная клавиатура)
Выделить до конца материала | <Ctrl>+<Shift>+<3> (дополнительная клавиатура)
Выделить слово | Двойной щелчок инструментом Text
Выделить слово слева | <Ctrl>+<Shift>+<<<-> или <Ctrl>+<Shift>+<4> (дополнительная клавиатура)
Выделить слово справа | <Ctrl>+<Shift>+<->> или <Ctrl>+<Shift>+<6> (дополнительная клавиатура)
Выделить абзац Тройной щелчок инструментом Text
Выделить абзац сверху | <Ctrl>+<Shift>+<^> или <Ctrl>+<Shift>+<8> (дополнительная клавиатура)
Выделить абзац снизу | <Ctrl>+<Shift>+<4/> или <Ctrl>+<Shift>+<2> (дополнительная клавиатура)
Выделить строку снизу | <Shift>+<Ф> или <Shift>+<2> (дополнительная клавиатура)
Выделить строку сверху | <Shift>+<t v > или <Shift>+<S> (дополнительная клавиатура)
Выделить символ слева | <Shift>+<<-> или <Shift>+<4> (дополнительная клавиатура)
Выделить символ справа | <Shift>+<->> или <Shift>+ <6> (дополнительная клавиатура)


Прочие

ОК или Cancel для вложенных диалоговых окон | <Shift>+кнопка OK или Cancel
Список установленных компонентов | <Ctrl>+About PageMaker
Скопировать структурный список книги во все публикации | <Ctrl>+Utilities > Book
Обновить список PPD-файлов | <Shift>+File > Print
Информация о разработчиках | <Shift>+About PageMaker
Перекомпоновка текста
Полная перекомпоновка | <Shift>+Text > Hyphenation
Диагностическая перекомпоновка | <Shift>+<Ctrl>+Text > Hyphenation
Уплотнение TIFF-файлов при импорте (диалоговое окно Place)
Среднее уплотнение | <Ctrl>+<Alt>+кнопка OK
Максимальное уплотнение | <Ctrl>+<Alt>+<Shift>+кнопкa OK
Разуплотнение | <Ctrl>+кнопка OK
Клавиатурные сокращения в диалоговом окне Print
Сохранить параметры печати, не запуская печать | <Shift>+кнопка Done
Сохранить параметры печати как стиль | <Ctrl>+кнопкa Style


  • Введение
    • О чем эта книга
    • Зачем нужна издательская система?
    • Знания, которые необходимы для освоения этой книп
    • Новые возможности PageMaker 7.0
    • Типы статей в книге
    • Структура книги


Введение

О чем эта книга

Эта книга посвящена уникальной программе — Adobe PageMaker. По существу выход его первой версии в июле 1985 г. ознаменовал собой начало эры настольных издательских систем. Простота, естественность инструментария, широкие возможности на протяжении почти десятилетия делали его бессменным лидером на рынке настольных издательских систем. В начале 90-х PageMaker стал сдавать свои позиции новому лидеру, QuarkXPress. Теперь, когда подавляющее большинство цветных публикаций высокой сложности верстаются в других программах, PageMaker занял новую экологическую нишу программы, ориентированной на деловые публикации. В этой сфере требуется не сложный и дорогой инструмент, а простая, быстрая и недорогая программа, позволяющая непрофессионалам создавать документы профессионального качества. Этим требованиям в полной мере соответствует PageMaker. Ориентируясь на новый круг пользователей, разработчики оснащают новые версии именно теми функциями, которые необходимы для бизнес-публикаций: средствами создания электронных публикаций, поддержкой новых форматов графических приложений, библиотеками шаблонов и графических элементов. Если вы заняты версткой преимущественно деловых документов, несложных рекламных материалов, малотиражной продукцией, то Adobe PageMaker — идеальный выбор.

Немаловажный довод в пользу PageMaker — репутация фирмы Adobe. Adobe Systems Inc. — лидер в мире издательского программного обеспечения. Трудно представить себе издательство, в котором не использовались бы продукты Adobe: Acrobat, Photoshop, PageMaker, InDesign, FrameMaker, Illustrator, Streamline, TypeManager и др. Наконец, именно Adobe был создан первый интерпретатор языка описания страниц PostScript, который находится вне конкуренции в компьютерном издательском деле. С помощью PostScript описываются используемые в издательском деле шрифты в Туре 1. В любом хорошем лазерном принтере содержится (или может быть установлен дополнительно) интерпретатор PostScript. Для обмена файлами между издательскими приложениями также используются форматы, основанные на PostScript: PDF (Adobe Acrobat), AI (Adobe Illustrator), EPS (Encapsulated PostScript). Программы, созданные Adobe, используются и на PC, и на Macintosh, Sun, Silicon Graphics и др.

Выбрав PageMaker в качестве программы верстки, вы фактически сделали выбор в пользу продуктов Adobe, т. к. они особенно успешно работают вместе и обеспечивают переносимость данных между программами подготовки векторной (Adobe Illustrator, Adobe Streamline) и растровой (Adobe Photoshop) графики и издательской системой (PageMaker). Создатели этих программ позаботились о совместимости форматов файлов и унификации интерфейса, не говоря уже о широких возможностях каждой из них в отдельности.

Важная особенность настоящей книги заключается в том, что мы попытались привести в ней не только исчерпывающее описание программы, но и изложить теоретические и практические основы полиграфии и предпечат-ной подготовки оригинал-макета. Вы узнаете о процессах цветоделения, растрирования, треппинга, особенностях воспроизведения цветов и полутонов в типографском процессе и многом другом, чего нет в прилагаемом к программе руководстве. Также мы попытались частично отразить в этом издании наш собственный и чужой опыт создания, дизайна и предпечатной подготовки оригинал-макетов, который позволит вам избежать многочисленных ошибок дизайна и верстки. Мы приводим здесь многочисленные оригинальные приемы и "маленькие хитрости" верстки, которые сэкономят вам долгие часы поиска способа создания того или иного эффекта, или специфической организации макета.


Зачем нужна издательская система?

Если вы до сих пор не работали с издательскими системами, то такой вопрос вполне закономерен. Современные текстовые редакторы обладают весьма широкими возможностями и позволяют управлять такими элементами верстки, какие еще в недавнем прошлом были прерогативой издательских систем. Но, тем не менее, если речь идет именно об издательстве, то для получения высококачественных макетов вам не обойтись без системы верстки. Ниже приведена сравнительная таблица возможностей одной из наиболее популярных издательских систем — PageMaker и одного из наиболее широко применяемых текстовых редакторов — Microsoft Word. Несмотря на общую тенденцию расширения возможностей текстовых редакторов (например, поддержка стилей абзацев, шаблонов, работы с графикой, кернинга и трекинга) и заимствования издательскими системами некоторых удачных находок современных текстовых редакторов (макроопределения и макроязыки, создание электронных публикаций и др.), как такового слияния не происходит. Это обусловлено различной направленностью этих программ. Издательские системы ориентированы на типографское воспроизведение создаваемых документов. Они содержат многие "лишние" для текстовых процессоров функции: поддержку цветоделения и управления цветом, тонкие настройки характеристик шрифта (точный, заказной и ручной кернинг и трекинг), треппинг, высокую точность расположения элементов и др. Но без этих функций при создании полиграфического продукта не обойтись.

Нельзя не упомянуть и об отличии, которое бросается в глаза. Издательские системы ориентированы на работу с текстовыми и графическими блоками, в то время как текстовые процессоры — на работу с одним текстовым блоком, хотя и состоящим из произвольного числа колонок. Эта концепция издательских систем позволяет с абсолютной свободой (вы не приходили в отчаяние от неожиданного поведения рамок в Microsoft Word?) размещать текстовые и графические материалы на страницах. Вы не чувствуете себя скованным ограничениями инструмента, а следуете только своей дизайнерской идее.

Речь идет не о сравнении, что лучше: издательская система или текстовый процессор, а о том, что более соответствует вашим задачам. Мы советуем использовать текстовый процессор для создания небольших документов, рассчитанных на узкий круг читателей. Если же документ предназначен для чтения широкой аудиторией, то лучше обратиться к издательской системе. В случае создания макетов для типографского тиражирования издательская система просто необходима.

Однако не спешите деинсталлировать привычный текстовый процессор. Он пригодится не только как "рабочая лошадка" для создания обыкновенных документов, но и при подготовке текстового материала для верстки. Дело в том, что издательская система предназначена не для набора больших объемов текста, а для "сборки" макета из текстовых и графических блоков. Предполагается, что блоки — набранный текст, фотографии, рисунки — создаются в отдельных приложениях, обладающих специальными функциями для их создания и обработки. Если вы выбрали продукты Adobe, то это Adobe Photoshop и Adobe Illustrator, о которых уже говорилось выше, и конечно, текстовый редактор.


Знания, которые необходимы для освоения этой книги

Мы предполагаем, что читатель данной книги знает графический интерфейс используемой операционной системы. Предполагается, что эта операционная система — Microsoft Windows 95/98/МЕ или Microsoft Windows NT/2000/XP.

Пользователи Macintosh тоже могут изучать PageMaker по этой книге, хотя горячие клавиши и некоторое функции, связанные с системами цветокоррекции, шрифтами, устройствами вывода, имеют на Macintosh свои особенности.

Также предполагается, что читатель умеет работать в каком-либо текстовом редакторе, например Microsoft Word. Если это так, то вам уже знакомы многие возможности обработки текста и, возможно, графики. Эти знания значительно облегчат освоение приводимого материала.

Если вы не уверены в достаточном знании этих программ, мы советуем вам обращаться к соответствующим руководствам в тех случаях, когда какое-либо понятие упомянуто в тексте этой книги без достаточно пространного пояснения. Хотя ее можно использовать и для начального освоения PageMaker, лучше в этих целях приобрести специальное руководство для начинающих, построенное по принципу системы уроков. Тем не менее, действительно исчерпывающее описание программы вам обязательно понадобится и вам не обойтись без этой книги!


Новые возможности PageMaker 7.0

В новой версии программы появилось несколько значительных новшеств и мелких изменений, которые, тем не менее, существенно упрощают работу.

  • Поддержка печати переменных данных.
  • Улучшен модуль экспорта в формат PDF, добавлена поддержка Acrobat 5.0.
  • Добавлен модуль импорта файлов PDF.
  • Поддерживается непосредственный импорт файлов Photoshop и Illustrator.
  • Расширены возможности импорта и экспорта файлов Microsoft Office.
  • Обновлены утилиты конвертирования файлов QuarkXPress 3.3—4.1 и Microsoft Publisher 95—2000 в формат PageMaker.


Типы статей в книге

Теоретические разделы практически целиком посвящены понятиям. Это как понятия полиграфии, так и понятия, связанные с особенностями компьютерной верстки: типы изображений, параметры изображений, форматы файлов и типы их связей, компьютерные шрифты, форматирование текста, стили и т. п.

Без глубокого осознания этих элементов теории невозможно полноценное овладение версткой, т. к. без них вы будете только следовать приведенным рецептам, но не сможете творчески их применить, и эта книга превратится для вас не более чем в "инструкцию по нажиманию клавиш". Верстка — это действительно творческая работа. Окончательный вид издания зависит от верстальщика ничуть не меньше, чем от дизайнера, разрабатывающего макет. Если же вы объединяете в себе обе профессии, то важность этих знаний возрастает несоизмеримо.

Советы по верстке и дизайну

Материалы этих статей содержат советы, связанные с конкретными особенностями как программы PageMaker, так и самой компьютерной верстки. Некоторое внимание уделено вопросам полиграфического дизайна. Даже если оформление публикации и не является вашей непосредственной обязанностью, советы по дизайну страниц помогут вам рациональнее организовать работу. Если же вы сами собираетесь заняться дизайном, то они избавят вас от грубых промахов в организации макета и сэкономят много времени, т. к. позволят сразу отбросить заведомо неприемлемые варианты оформления.

Советы помогут работать быстрее и эффективнее с PageMaker. Мы старались сделать их как можно более полезными в каждодневной работе.

Замечания

Таким образом обозначены дополнительные сведения об особенностях работы PageMaker с другими приложениями, необычных реакциях программы на некоторые команды, потенциально опасных моментах при работе с PageMaker. Указаны пути выхода из подобных затруднительных ситуаций.

Рецепты

Сумма этих статей составит своеобразную "поваренную книгу" верстальщика. Верстка — очень сложный и многоступенчатый процесс, в котором редко можно что-либо опустить. Рецепты в настоящей книге — подробные пошаговые описания наиболее частых процедур, встречающихся при верстке, планировании публикации и работе с сервисными бюро и типографиями. Они помогут вам не упустить ничего существенного в процессе подготовки издания.


Структура книги

Хотя настоящая книга является справочником, в котором вы можете найти сведения о всех возможностях PageMaker 7.0, она построена и с учетом принципа последовательного усложнения материала, принятого в учебной литературе. Мы пытались построить изложение таким образом, чтобы вам

не приходилось часто заглядывать вперед для того, чтобы понять приведенный материал. Ссылки вперед используются лишь для направления читателя к тому разделу, в котором он может получить более подробные сведения.

Часть I. Начала

Данная часть посвящена интерфейсу программы PageMaker, настройке программы для обеспечения максимального удобства, а также обзору процесса подготовки публикации.

В ней вы найдете подробное описание того, что увидите на экране после (и даже до!) запуска PageMaker, и рассказ о том, как управлять отображением страниц публикации на экране компьютера (гл. 1). Важно правильно сделать в программе установки "по умолчанию" с тем, чтобы они соответствовали вашим конкретным задачам (гл. 3).

Обзор пути публикации от идеи до тиража введет вас в сложный многоэтапный издательский процесс, в котором принимаете участие не только вы, но и заказчики, начальники, работники типографии и бюро предпечатной подготовки. Если вы только планируете окунуться в издательскую деятельность, то описание издательского процесса (гл. 2) введет вас в курс дела и, хочется надеяться, не заставит отказаться от задуманного предприятия, а напротив, даст твердые ориентиры и придаст уверенности в его выполнимости.

Часть II. Текст

Эта часть посвящена форматированию и редактированию текста. В большинстве случаев текст — это то, ради чего затевается издание, та информация, которую следует донести до читателя. Профессионально оформленный текстовый материал необходим для выполнения задач, которые поставлены перед изданием. В этой части описаны все богатейшие возможности PageMaker по обработке текста, начиная с ввода и форматирования отдельных символов (гл. 4 и 5) и кончая глобальным форматированием, позволяющим менять стиль всей публикации только несколькими щелчками мыши (гл. 6).

Часть III. Графика

Прошло время, когда уделом маломощных персональных компьютеров была подготовка текста, а иллюстрации отдавались на откуп фотографам. PageMaker позволяет создавать макеты иллюстрированных изданий любой степени сложности. Именно широкое использование рисунков, фотографий и монтажей придаст публикации яркость, выразительность и привлекательность. Кроме того, графическая информация воспринимается лучше, чем текстовая, и надолго запоминается. Наиболее часто используемые графические элементы можно (и нужно!) создавать непосредственно в PageMaker (гл. 9).

Рассмотрен импорт графических материалов в PageMaker и средства работы с ними: перемещение, искажение, масштабирование, кадрирование, обтравка и т. п. (гл. 10). Важную роль при создании публикации играет динамическая связь внешних графических материалов с публикацией (гл. 11). Возможность автоматического и ручного обновления связей является сильной стороной PageMaker и также подвергается пристальному анализу.

Часть IV. Верстка

Самая большая и центральная часть книги посвящена верстке — компоновке текстовых и графических материалов, т. е. собственно созданию публикации. Для соблюдения единства стилей PageMaker предлагает множественные шаблоны, шаблон-страницы, модульные сетки (гл. 12 и 13). Взаимодействие текста и графики для достижения максимального эффекта при сохранении "мобильности" верстки рассмотрено в гл. 14.

Многочисленные специальные эффекты (висячие отступы, "фонарики", заголовки в подбор, буквицы и т. п.) украсят верстку и придадут ей наглядность, оригинальность и профессиональный лоск (гл. 15). Особо рассматриваются специальные и сложные макеты, доставляющие много хлопот верстальщику (гл. 16). Наши рекомендации помогут вам быстро и с минимальными затратами ручного труда оформить разнообразные бланки и таблицы.

Свои особенности имеет работа с многостраничными публикациями — книгами (гл. 17). В этой главе описан процесс верстки объемных изданий, создания оглавлений, алфавитных и предметных указателей.

Развитие Интернета сделало электронные публикации полноправной издательской продукцией. Минимальные затраты на "тираж" и отсутствие территориальных барьеров делают этот способ распространения информации все более и более привлекательным. PageMaker поможет вам быстро адаптировать сверстанное издание для Всемирной паутины (WWW) или создать ее специально для электронного распространения (гл. 18).

Часть V. Цвет

Цветопередача — головная боль всех, принимающих участие в полиграфическом процессе. На вопрос о том, как сделать ее наиболее реалистичной, и отвечает эта часть. Здесь описан весь арсенал средств PageMaker по определению (гл. 19) и использованию (гл. 20) цвета при оформлении публикации. Особое внимание уделено трудностям при работе с цветом и их преодолению — системе цветокоррекции и треппингу (гл. 21).

Часть VI. Оригинал-макет

Часть посвящена завершающей стадии выпуска публикации — выводу оригинал-макета и печати тиража. Она познакомит читателя с основными понятиями полиграфии и их преломлением в настольных издательских системах. Вы узнаете, каким требованиям должна удовлетворять верстка, чтобы ее из электронной формы можно было без потерь перенести на бумагу (гл. 23).

Сотрудничество с бюро предпечатной подготовки и типографией — залог успешного выпуска публикации. Тому, как его организовать и -как добиться легкой, удобной работы и экономии средств при печати, посвящена заключительная глава книги (гл. 24).

Приложения

В приложениях вы найдете полный список комбинаций клавиш PageMaker, а также практически весьма важную информацию о том, как избежать сбоев в работе программы и что делать, если они все-таки происходят.