Дистанционное обучение. Инструментальные средства документалистики. Настольные издательские системы. Программа верстки InDesign.

Настольная издательская система
Adobe InDesign

"Не продается вдохновенье,
Но можно рукопись продать."
 А.С.Пушкин

Программа верстки сложных документов Adobe InDesign достойна особого внимания специалистов, связанных с документалистикой и стремящихся к эффективности своего труда. Это средство относится к лучшим программным продуктам мирового класса DTP ("настольные издательские системы" - НИС)и может выполнять многое из того, что делается в полиграфии, позволяя получать качественные печатные и электронные издания разного рода.

Программу можно скачать на сайте "Методисты", установить и опробовать в живом конкретном деле, сочетая изучение возможностей этого инструментального средства с созданием семейства произведений разного рода, различающихся по сложности, жанру и стилю. Затраты времени на осоение программы оправданы, очевидно, в той мере, в какой она приносит полезную отдачу. А общий эффект определяется совокупностью предстоящих публикаций, имеющих конкретное целевое и функциональное назначение, опрекделенное содержание и ценность. Планирование производства изданий, формируемых программой Indesign является, однако, самостоятельной задачей, решение которой выходит за рамки данной темы и рассматривается в соответствующих сборниках учебных материалов по электронным изданиям и издательскому делу в целом.

Телефон: (3843)74-88-06
Б.Г.Новокрещин
  • Введение
    • Зачем нужна издательская система?
    • Начальная подготовка читателя
    • InDesign-издательская ОС
      • Архитектура InDesign
      • Общие компоненты
      • Макропрограммирование
    • Системные требования
    • Структура книги
  • Глава 1. Общие сведения
    • Начинаем работу
      • Главное окно программы
      • Главное меню
      • Создание документа
      • Окно документа
      • Открытие документа
      • Открытие копии существующего файла
    • Элементы управления публикацией
      • Палитры
      • Палитра инструментов
      • Заливка и обводка в палитре
      • Прочие палитры
      • Контекстное меню
    • Типы объектов в документе
      • Страницы и развороты
      • Фреймы и объекты
      • Размещение текста и графики
      • Способы выделения
      • Взаимосвязь разных типов объектов
      • Вспомогательные линии
    • Просмотр и масштабирование документа
      • Поле масштаба полосы состояния
      • Команды изменения масштаба
      • Инструмент Zoom
    • Перемещение по публикации
      • Полосы прокрутки
      • Навигатор
      • Палитра Pages
      • Инструмент Hand
      • Палитра Navigator
      • Работа в нескольких окнах
    • Сохранение и закрытие документа
      • Закрытие документов
    • Если что-то испортилось
      • Исправление собственных ошибок
      • Восстановление публикации после аварийного закрытия
    • Строение публикации
      • Части книги
      • Модульные сетки
      • Элементы страницы
    • Резюме
  • Глава 2. Обзор процесса подготовки публикации
    • Планирование
      • Определение круга читателей публикации
      • Бюджет издания
      • Концепция издания
      • Утверждение плана издания
      • Выбор типографии и сервис-бюро, сотрудничество с ними
    • Верстка
      • Подготовка компонентов публикации
      • Определение структуры публикации
      • Компоновка текста и графики
      • Доводка, специальные эффекты, цветовое оформление
      • Вывод подписной корректуры
    • Предпечатная подготовка
      • Высококачественное сканирование
      • Треппинг
      • Цветоделение
      • Цветопробы
      • Вывод на фотонаборном автомате
    • Печать в типографии
      • Спуск полос
      • Пробные отпечатки
      • Печать тиража
  • Глава 3. Установки программы
    • Основные понятия InDesign, связанные с умолчаниями
      • Где хранятся умолчания
      • Два вида умолчаний
    • Способы задания умолчании
      • Умолчания, задаваемые в диалоговых окнах
      • Умолчания, задаваемые командами меню
    • Диалоговое окно Preferences
      • Раздел General
      • Раздел Text
      • Раздел Composition
      • Раздел Units & Increments
      • Раздел Grids
      • Раздел Guides
      • Раздел Dictionary
    • Установки Color Settings
    • Редактирование клавиатурных сокращений
    • Служба Adobe Online
    • Задание умолчаний с помощью меню и палитр
      • Меню File
      • Меню Layout
      • Меню Type
      • Меню Object
      • Меню View
      • Меню Window
    • Резюме
  • Глава 4. Цвет и его применение в публикации
    • Описание цвета
      • Цветовой охват
      • Модель RGB
      • Модель CMYK
      • Плашечные цвета
      • Lab — аппаратно-независимая модель
    • Создание цвета в программе
      • Типы заливок и обводок
      • Средства работы с цветом
      • Палитра Color— синтез цветов
      • Какую модель выбрать
      • Палитра Gradient— создание градиента
      • Инструмент Gradient— вектор градиента
      • Градиентная заливка нескольких объектов
    • Назначение и типы цветов
      • Определение цвета в палитре Toolbox
      • Палитра Swatches
      • Создание образца в каталоге
      • Удаление образца
      • Оттенки
      • Особенности определения цветов
    • Обмен палитрами между документами
      • Импорт каталога образцов в публикацию
      • Импорт образцов вместе с файлами
    • Выбор цветового решения публикации
      • Взаимодействие цветов
      • Цвет — полноценный компонент публикации
      • Чуть-чуть о бумаге
      • Цвет и текст
    • Резюме
  • Глава 5. Управление цветом
    • Система управления цветом
      • Принцип работы
      • Профиль сканера
      • Профиль монитора
      • Профиль принтера
    • Технологическая цепочка
    • Управление цветом в InDesign
      • Настройка управления цветом в приложении
      • Настройка управления цветом в документе
      • Индивидуальные настройки для изображений
    • Нужна ли вам CMS?
    • Резюме
  • Глава 6. Форматирование символов
    • Шрифт
      • Гарнитура
      • Группы шрифтов
      • Начертание
    • Метрические параметры шрифта
      • Кегль. Традиционные полиграфические единицы измерения
      • Принципы выбора кегля для публикации
      • Базовая линия
      • Емкость
      • Интерлиньяж
      • Пробел и боковые поля
      • Кернинг
      • Трекинг
      • Ширина и высота символов
    • Шрифт в вашем компьютере
      • Немного о форматах
      • Разметка
      • Шрифты Unicode
      • Шрифты Ореn Туре
      • Шрифты Multiple Master
      • Качество шрифта
      • О похожих шрифтах
    • Общие сведения о форматировании
      • Обсуждение текста в этой книге
      • Текстовый режим
      • Выделение в текстовом режиме
      • Атрибуты текста и наличие выделения
    • Форматирование символов в программе
      • Гарнитура
      • Начертание
      • Кегль
      • Гарнитура, начертание и кегль в меню программы
      • Отсутствующие шрифты
      • Подчеркивание, регистры, специальные символы
      • Кернинг
      • Трекинг
      • Ширина, высота и наклон символов
      • Интерлиньяж
      • Смещение базовой линии
      • Установки языка
      • Запрет разбиения слова и группы слов
    • Резюме
  • Глава 7. Форматирование абзацев
    • Параметры абзаца
      • Признак конца абзаца и непечатаемые символы
      • Разрыв строки
      • Типы выключки
      • Интервалы
      • Подстройка ширины символов
      • Отступы
      • Отбивки
      • Выбор разделения абзацев
      • Линейки
      • Вертикальная выключка строк
      • Размещение абзацев на страницах
      • Параметры переносов слов
      • Табуляции
    • Задание атрибутов абзаца
      • Выключка
      • Отступы
      • Отбивки
      • Выравнивание по сетке базовых линий
      • Буквица — особый атрибут абзаца
      • Интервалы и ширина символов
      • Размещение абзацев и контроль висячих строк
      • Установка переносов
      • Размещение текста
      • Абзацные линейки
    • Позиции табуляции
      • Организация палитры
      • Выравнивание по табуляции
      • Установка маркеров
      • Отточия
      • Установка отступов
    • Настройка текста в реальных публикациях
      • Длина строки и как ее менять
      • Проблема висячих строк
      • Пример настройки выключки
      • О создании таблиц
      • Верстка стихов
    • Резюме
  • Глава 8. Глобальное форматирование
    • Понятие стилей
      • Стили символа и абзаца
      • Применение стилей и локальное форматирование
      • Базирование и автоматическое присвоение стилей
      • Комплекты стилей документа
      • Пути создания нового стиля
    • Создание стиля символов
      • Вкладка Basic Character Formats
      • Вкладка Advanced Character Formats
      • Вкладка Character Color
    • Определение стиля абзаца
      • Вкладка General
      • Вкладки задания атрибутов абзаца
      • Вкладки форматирования символов
    • Операции со стилями
      • Редактирование и переопределение стиля
      • Удаление стилей и отмена стилевого форматирования
      • Очистка стилевого листа от лишних стилей
      • Отмена стилевого форматирования
      • Дублирование стилей
      • Импорт стилей
      • Наложение стилей
    • Создание стилевого листа публикации
      • Разработка списка стилей
      • Система именования стилей
      • Оформление базовых стилей
      • Базирование и последовательность стилей
      • Специальные стили
      • Сохранение стилевого листа и палитра библиотеки
    • Резюме
  • Глава 9. Импорт и размещение текста
    • Размещение текста
      • Отображение фреймов в документе
      • Трансформации фрейма
      • Избыточный текст и цепочки фреймов (Часть I)
      • Избыточный текст и цепочки фреймов (Часть II)
      • Свойства связанных фреймов
      • Атрибуты фрейма и материала (Часть I)
      • Атрибуты фрейма и материала (Часть II)
      • Режимы размещения
      • О верстке с применением фреймов
    • Форматы текстовых файлов
      • Понятие формата
      • Фильтры импорта
      • Форматы, набор и верстка
      • Типы текстовых форматов
      • Установка и обновление фильтров
    • Импорт текста
      • Устройство диалогового окна Place
      • Устройство диалогового окна Place
      • Настройки импорта
      • Что импортируем?
      • Импорт текстовых файлов
      • Импорт файлов DOC и RTF
      • Импорт таблиц Excel
      • Стилевая разметка
      • Файлы систем верстки
      • Процесс импорта
      • Связывание файлов
      • Экспорт текстовых файлов
    • Резюме
  • Глава 10. Работа с текстовым материалом
    • Функция поиска и замены
      • Задание образца и замены
      • Атрибуты поиска
      • Примеры применения атрибутов поиска и замены
      • Область поиска
      • Регулирование процесса поиска и замены
      • Команда повторного поиска
      • Серии замен
    • Проверка орфографии
      • Словари InDesign
      • Команда проверки орфографии
    • Резюме
  • Глава 11. Рисование средствами InDesiqn
    • Определение контуров
      • Точки и сегменты
      • Построение контуров, имеющих точки различного типа
      • Два инструмента выделения
    • Редактирование точек и сегментов
      • Продолжение и замыкание контуров
      • Размыкание контуров
      • Изменение формы контура
      • Изменение типа точки
      • Удаление и добавление точек на контуре
    • Построение фигур
      • Прямые
      • Прямоугольники и эллипсы — фигуры и фреймы
      • Многоугольники и звезды — фреймы и фигуры
      • Порядок наложения объектов
    • Трансформации контуров
      • Перемещение объектов
      • Масштабирование объектов
      • Отражение объектов
      • Вращение объектов
      • Наклон объектов
      • Трансформация нескольких объектов
      • Действие трансформаций на вводимый текст и графику
    • Атрибуты контуров
      • Регулировка толщины
      • Сопряжение
      • Форма окончаний линий
      • Пунктир
      • Создание стрелок и направление линии
      • Обработка углов
      • Комбинированные контуры (Часть I)
      • Комбинированные контуры (Часть II)
    • Резюме
  • Глава 12. Импорт графики
    • Векторная графика
      • Векторные объекты
      • Форматы векторных файлов
    • Точечная графика
      • Структура точечных изображений
      • Размеры и разрешение
      • Глубина цвета
      • Форматы файлов
    • Импортирование изображений
      • Импортирование точечных форматов
      • Импортирование векторных форматов
      • Редкие форматы
    • Размещение импортированных изображений
      • Способы размещения изображений
      • Размещение независимой графики
      • Размещение вложенной графики
    • Графические фреймы
      • Масштабирование (Часть I)
      • Масштабирование (Часть II)
      • Прочие операции трансформирования (Часть I)
      • Прочие операции трансформирования (Часть II)
      • Контуры обтравки (Часть I)
      • Контуры обтравки (Часть II)
    • Использование библиотек
    • Резюме
  • Глава 13. Связывание файлов
    • Для чего используются связи?
      • Экономия места на диске
      • Удобство внесения изменений
      • Верстка в рабочих группах
    • Создание связей
      • Методы связывания
      • Drag and Drop
      • Демонстрация связанных изображений
    • Управление связями
      • Палитра Links
      • Обновление связей
      • Восстановление связей
      • Внедрение изображений
      • Редактирование оригинала
    • Резюме
  • Глава 14. Создание новой публикации
    • Задание установок по умолчанию
    • Новая публикация
      • Разработка шаблонов страниц и модульной сетки
      • Параметры нового документа
    • Работа с шаблонами
      • Создание нового шаблона публикации
      • Редактирование шаблона публикации
    • Изменение параметров документа
      • Параметры существующего документа
      • Автоматическая настройка макета
      • Режим автоматической настройки макета
      • Параметры автоматической настройки макета
      • Изменения элементов макета при настройке
      • Перемещение "привязанных" объектов при автоматической настройке макета
      • Нежелательные изменения параметров документа
    • Резюме
  • Глава 15. Структура публикации
    • Вспомогательные линии InDesign
      • Элементы модульной сетки
      • Границы полей
      • Границы колонок
      • Направляющие линии
      • Установка, перемещение и удаление направляющих
      • Закрепление и режим отображения направляющих
      • Автоматическая расстановка направляющих
    • Шаблоны
      • Палитра Pages
      • Основной шаблон документа
      • Дополнительные шаблон-страницы
      • Выбор и применение шаблона
      • Иерархия шаблонов
      • Создание новой шаблон-страницы и редактирование шаблонов
      • Создание шаблон-страницы на основе ранее подготовленной страницы
      • Копирование шаблон-страниц между документами
      • Удаление шаблонов. Страница без шаблона
    • Стандартные элементы шаблон-страницы
      • Колонки и модульная сетка
      • Колонтитулы и линейки
      • Текстовые и графические фреймы
      • Автоматическая нумерация страниц
    • Страницы
      • Вставка страниц
      • Развороты
      • Перестановка страниц
      • Многостраничные развороты
      • Дублирование страниц
      • Копирование страниц между документами
      • Удаление страниц
      • Редактирование элементов шаблона
    • Разделы
      • Создание разделов
      • Редактирование параметров разделов и их удаление
      • Имена разделов на страницах
    • Слои
      • Для чего придуманы слои документа
      • Что представляют собой слои
      • Палитра слоев
      • Выбор активного слоя
      • Атрибуты слоя
      • Создание нового слоя
      • Удаление и объединение слоев
    • Объекты на слоях
      • Размещение объектов шаблон-страницы
      • Группы объектов
      • Выделение объектов
      • Вырезание, копирование и вклеивание объектов на слои
      • Перемещение и копирование объектов с помощью палитры слоев
    • Применение модульных сеток
      • Одноколоночные сетки
      • Двухколоночные сетки
      • Трехколоночные сетки (Часть I)
      • Трехколоночные сетки (Часть II)
    • Резюме
  • Глава 16. Компоновка текста и графики
    • Координаты объектов
    • Выравнивание объектов
      • Выравнивание по линейкам
      • Выравнивание заданием координат
      • Выравнивание по направляющим и границам колонок (Часть I)
      • Выравнивание по направляющим и границам колонок (Часть II)
      • Выравнивание по координатной сетке
      • Палитра Align
    • Группировка объектов
      • Создание и расформирование групп
      • Группы и слои
      • Вложенные группы
      • Операции с объектами в составе группы
    • Точное трансформирование
      • Масштабирование
      • Наклон
      • Отражение
      • Поворот
    • Обтекание объектов текстом (Часть I)
    • Обтекание объектов текстом (Часть II)
    • Закрепление объектов
    • Вложенные изображения и текст
      • Вложенная графика как символ текста
      • Размещение вложенной графики
      • Закрепление вложенной графики
      • Изображения в висячих отступах
      • Объекты InDesign, вложенные в текст
      • Вложенные текстовые фреймы
    • Маскирование
      • Создание масок
      • Трансформирование маски и маскированного объекта
      • Вложенные маски
      • Контуры обтравки
    • Резюме
  • Глава 17. Электронные публикации
    • Язык описания страниц HTML
    • Проблемы переноса верстки в формат HTML
    • Размер Web-страницы
    • Экспорт публикации в формат HTML
      • Параметры документа
      • Форматирование
      • Макет
      • Графика
    • PDF и HTML
    • Экспорт публикации в формат PDF
      • Настройки PDF
      • Параметры изображений
      • Страницы и метки
      • Защита документов
    • Резюме
  • Глава 18. Корректура
    • Визирование
    • Подготовка текста
      • Стадии подготовки издания
      • Формальная процедура подписания в печать
    • Применение лазерного принтера для вывода контрольных отпечатков
      • Миниатюры
      • Печать композитных оттисков
      • Черновой режим печати
    • Проверка файлов перед передачей материала в сервис-бюро
      • Проверка PostScript-файла
      • Контрольный вывод файла на лазерный принтер
      • Проверка на наличие в макете потенциально аварийных ситуаций
      • Автоматическая проверка публикации в InDesign
    • Корректура цветных изображений
      • Проверка результатов цветоделения при помощи лазерного принтера
      • Пробные оттиски на цветном принтере
      • Критерии оценки качества продукции
      • Композитные и деленные цветные контрольные оттиски
      • Условия для оценки цветовоспроизведения
    • Проверка публикации в типографии
      • Образцы краски и лака
      • Проверка фотоформ в типографии
      • Пробные оттиски с печатной машины
      • Сигнальный экземпляр
    • Резюме
  • Глава 19. Вывод оригинал-макета
    • PostScript или не-PostScript?
    • Драйверы принтеров и InDesign
    • Растрирование
      • Растровые точки
      • Цифровые растры
      • Линиатура и градации серого
      • Линиатура и разрешение растровых изображений
      • Линиатура и качество бумаги
      • Растрирование цветных изображений
    • Треппинг и наложение
      • Треппинг
      • Печать с наложением
      • Треппинг наложением обводок
    • Настройки печати
      • Настройки драйвера принтера
      • Вкладка Advanced Page Control
      • Вкладка Color
      • Вкладка Scale and Fit
      • Вкладка Graphics
      • Вкладка Page Marks
      • Вкладка Trapping
    • Предоставление макета в сервис-бюро
    • Передача верстки в сервис-бюро
      • Какие файлы требуются для печати в сервис-бюро
      • Проверка публикации
      • Сборка файлов публикации
      • Вывод PostScript-файла без дополнительной обработки в сервис-бюро
      • Вывод PostScript-файла для треппинга и спуска полос
      • Создание PDF-файлов для печати
    • Профилактика неполадок на этапе вывода макета
      • Пользуйтесь советами специалистов
      • Устраните избыточную сложность выходного файла
      • Выполняйте масштабирование и кадрирование графических изображений до их размещения в публикации
      • Постарайтесь обойтись без белых прямоугольников
      • Сложные графические изображения могут вызвать аварийное завершение вывода на печать
      • Маскирование может вызывать затруднения при выводе
      • Избегайте вложения текстов в файлы EPS
      • Поворачивайте изображения до импортирования в публикацию
      • При выводе на фотонаборный автомат избегайте использования гарнитур TrueType и объектов в формате WMF
      • Рассчитывайте количество переходов в цветовых растяжках
    • Резюме
  • Глава 20. Сотрудничество с типографией
    • Предварительное совещание в типографии
      • Выбор типографии
      • Что нужно определенно знать к предварительному совещанию
      • Разработка тактики
      • Выбор бумаги
      • Выбор значения линиатуры растра
      • Фальцовка и переплетные работы
    • Проверка качества печати тиража
    • Резюме


Глава 1

Общие сведения

Интерфейс и методы работы в программе InDesign наверняка придутся по душе пользователям, знакомым с другими программами Adobe. Можно сказать, что они будут чувствовать себя как дома, поскольку производители постарались максимально унифицировать команды, палитры, инструменты, клавиатурные сокращения и другие элементы управления. В этой главе, знакомящей с основными элементами интерфейса InDesign, рассматриваются:

  • Главное окно программы и система меню
  • Окна документов. Режимы отображения документов и масштабирование
  • Линейки и направляющие
  • Инструменты InDesign
  • Организация палитр и работа с ними
  • Ускорение работы с помощью клавиатурных сокращений и контекстного меню

При описании программы мы предполагаем, во-первых, что на вашем компьютере программа уже установлена. Во-вторых (если это не оговаривается специально), что вы не вносили изменений в стандартную установку. In-Design позволяет изменять многие элементы управления. Так, можно произвольно менять установки программы и организовать набор клавиатурных сокращений, отличных от стандартных.

Для начала работы необходимо загрузить программу. Это можно сделать различными способами. По умолчанию программа установки помещает ярлыки установленных компонентов пакета InDesign в группу Programs меню Start (Пуск). Среди них непременно будет ярлык InDesign. Выбрав ее, вы загрузите программу.

Как и любое другое приложение, эту программу можно также загрузить непосредственным запуском исполняемого файла, который называется "InDesign" и находится в главной папке InDesign на вашем компьютере. Ярлык, т. е. ссылку на исполняемый файл можно создать в любой папке. При изучении этой книги вам придется постоянно пользоваться InDesign, поэтому рекомендуем создать ее ярлык на рабочем столе.


Начинаем работу

Главное окно программы

После запуска перед вами откроется главное окно программы (рис. 1.1). Как и при работе в других приложениях, вы можете минимизировать его или растянуть на весь экран. Для этого предусмотрены системные кнопки в правом верхнем углу окна (рис. 1.2). Крайняя правая кнопка предназначена для выхода из программы. Если окно занимает не всю площадь экрана, можно изменять его размер и перемещать по экрану с помощью мыши. Заголовок главного окна в отсутствие открытых документов содержит название программы и ссылку на системное меню. В верхней части окна расположена строка меню, в которой размещены группы основных команд и палитры (они дают доступ к элементам управления или служат для получения информации).

Работа в программе обеспечивается командами меню, диалоговыми окнами, палитрами, контекстными меню. Основная площадь окна окрашена в стандартный фоновый цвет и не может быть использована. Для работы нужно : открыть существующий документ или создать новый. Прежде чем перейти к описанию приемов работы, осмотрим основной инструмент программы — главное меню.

Рис. 1.1. Главное окно программы (версия для Windows)

Рис. 1.2. Системные кнопки


Главное меню

Главное меню программы содержит следующие группы команд:

File. Меню операций с файлами. Здесь находятся команды открытия, закрытия, сохранения файлов, импорта и экспорта иллюстраций, подготовки публикации для удаленной печати, управление связями. Также это меню содержит команды вызова диалоговых окон установки параметров по умолчанию и сервиса Internet — службы Adobe Online.

Edit. В этом меню расположены общие команды редактирования (выбор, копирование и вставка объектов), команды дублирования, выделения и его отмены. В этом же меню находятся команды отмены (Undo) и повтора (Redo) последнего действия и инструменты автоматического редактирования текста — поиск и замена по образцу, режимы переноса, проверка орфографии и редактирование словаря.

Layout. Здесь сосредоточены команды организации колонок и управления служебными элементами программы — направляющими и координатной сеткой. Здесь же находятся команды перемещения по публикации, установки номера страницы и автоматической настройки элементов публикации при смене параметров страниц.

Туре. В этом меню собраны команды управления текстом, в том числе выбор шрифта и кегля, показ текстовых палитр, вставка специальных символов, перевод текста в кривые, а также переключатель режима отображения скрытого текста.

Object. Большое меню, содержащее операции с объектами — изменение порядка наложения, блокирование, группировка, управление фреймами, контурами и масками, обтекание объектов текстом и обработка углов графических объектов.

View. К сильным сторонам программы стоит отнести свободу управления отображением публикации на экране. В этом меню собраны команды режима просмотра, масштабирования, отображения направляющих и координатной сетки.

Window. Здесь находятся команды отображения палитр, основного средства управления программы. Для любого документа можно открыть одновременно несколько окон командой этого меню New Window. Внизу расположены

строки с названиями открытых документов. Щелчок на соответствующей строке активизирует выбранный документ.

Help. Как и следовало ожидать, здесь сосредоточены команды помощи по программе. Помощь InDesign организована так же, как системы помощи сотен других программ. Вы можете прочитать краткие обзоры по выбранной теме или осуществить поиск статьи по ключевому слову.


Создание документа

Как вы уже знаете, при загрузке программа не создает чистого документа, в отличие от большинства графических и текстовых редакторов (например, Word или Adobe Illustrator). Чтобы начать работу, необходимо создать новую (чистую) публикацию или открыть существующую. Это логично. В пакетах верстки не производится подготовительная работа, такая как набор текста и подготовка сложных иллюстраций. Когда вы открываете InDesign, все компоненты будущей публикации уже готовы, ваша задача — их верстка и монтаж, т. е. точное размещение текста и иллюстраций в реальном документе. Будущий журнал или газета имеет определенный размер страницы, ширину полей и колонок и пр. Если разместить материалы для какого-то абстрактного издания с произвольными параметрами, то смысл работы теряется — ведь при изменении хотя бы одной характеристики, скажем размера страницы, придется начинать заново всю работу. Данные о физических размерах публикации можете сообщить программе только вы.

  1. Для создания нового документа выберите команду New меню File или нажмите клавиши <Ctrl>+<N>. На рис. 1.3 показано диалоговое окно New Document.Укажите в поле Number of Pages число страниц будущей публикации, скажем, шесть. Впоследствии это значение всегда можно изменить.
  2. Все страницы документа имеют один и тот же формат. Он задается в раскрывающемся списке Page Size. Щелкнув на треугольной стрелке, откройте список. В нем перечислены наиболее распространенные форматы. Выберите пункт А4 (размер писчего листа). Если ваша публикация имеет нестандартные размеры, задайте их в полях Width и Height.
  3. Переключатели группы Orientation определяют ориентацию листов. Первый соответствует книжной, второй — альбомной ориентации. Установите первый переключатель.
  4. Область Margins определяет размер полей страниц документа. Оставьте значения, предложенные программой.
  5. По завершении работы нажмите кнопку ОК и перед вами появится новый, чистый документ InDesign.

Кроме описанных параметров, в области Columns указывается число колонок в документе (поле Number) и промежуток между колонками, средник (поле Gutter). Флажок Facing Pages устанавливается для показа разворотов (пар страниц) на экране (рис. 1.4). Он используется при верстке публикаций для двухсторонней печати. Флажок Master Text Frame устанавливает на шаблон-странице рамку для размещения текста, таким образом легко достичь абсолютно одинакового размещения текста на всех страницах публикации. По мере изучения материала мы будем рассматривать параметры диалогового окна New Document более подробно.

Для создания документа должны быть известны все параметры, описанные в диалоговом окне New Document, т. е. все поля диалогового окна должны быть заполнены. Если вы не вводите какое-либо значение, программа указывает его сама, руководствуясь умолчаниями (см. главу 4).

Рис. 1.3. Диалоговое окно создания документа

а [image] в

Рис. 1.4. Отображение страниц при установленном и снятом флажке Facing Pages


Окно документа

По завершении установки параметров документа, InDesign создает новый документ или публикацию. Новый документ помещен в окно документа, расположенное внутри главного окна программы (рис. 1.5).

Рис. 1.5. Окно нового документа

Правый верхний угол окна документа занят системными кнопками, выполняющими сворачивание/разворачивание окна, закрытие документа и изменение размеров окна. Справа и внизу имеются, соответственно, вертикальная и горизонтальная полосы прокрутки, предназначенные для прокручивания документа в окне (изменения поля зрения). Созданный нами документ по умолчанию получает имя LJntitled и номер, соответствующий количеству новых документов, созданных в данной сессии работы с программой. Имя документа и текущий масштаб отображения показаны в отдельном заголовке окна документа, или в заголовке главного окна, если документ развернут (рис. 1.6).

Одновременно может быть открыто несколько публикаций. Для каждой из них отводится отдельное окно. Для упорядочивания развернутых окон документов в меню Window главного меню InDesign есть команды Tile и Cascade, располагающие окна документов так, чтобы они не перекрывали

друг друга, или наоборот, размещая, их друг за другом так, чтобы были видны только заголовки каждого. Интерфейс InDesign написан в соответствии со спецификацией MDI (Multidocument Interface) и предполагает возможность обмена информацией между окнами документов: через буфер обмена (Clipboard) и методом Drag-and-Drop (перемещение с помощью мыши элементов макета из окна одной публикации в окно другой).

Рис. 1.6. Развернутый новый документ

В окне документа вы видите первую страницу публикации и небольшое пустое пространство вокруг нее — рабочий стол. На площади страницы вы можете размещать элементы макета и временно "выкладывать" их на рабочий стол. Элементы, целиком, располагающиеся на рабочем столе, не являются частью публикации и не выводятся на печать. Рабочий стол удобен в качестве временного места расположения элементов макета. Для каждой страницы документа программа предусматривает свой рабочий стол.

Когда в программе есть открытый документ, в нижней части экрана располагается полоса состояния. В левой ее части — поле изменения масштаба, в правой — навигатор, предназначенный для перехода со страницы на страницу. Более подробно о навигации в пределах документа рассказывается ниже. Вдоль верхней и левой боковой сторон окна документа располагаются линейки (Rulers).


Открытие документа

  1. Для открытия существующей публикации выберите команду Open... меню File или нажмите клавиши <Ctrl>+<0>. InDesign предложит стандартное диалоговое окно выбора файлов (рис. 1.7).

    2. Рис. 1.7. Открытие публикации

  2. В диалоговом окне выберите папку, в которой находится нужный файл публикации. Для примера откройте папку \Learning Adobe InDesign\ Tutorials\ID_02, расположенную в главной папке программы.
  3. В списке Files of type перечислены типы файлов, которые могут быть открыты в профамме (рис. 1.8). Пункт All Files используется для просмотра содержимого папки. Установите значение InDesign Files. В окне просмотра останутся только файлы соответствующего типа.
  4. Выберите среди них файл 02_а. Имя выбранного файла отображается в поле File name.
  5. Переключатель в левой части окна устанавливает режим открытия файла. Если вы собираетесь открыть данный документ для редактирования, установите переключатель Normal и нажмите кнопку ОК.
  6. На рис. 1.9 показан открытый документ. В заголовке главного окна в скобках отображается его имя и текущий масштаб отображения. Можно начинать работу над публикацией.

Рис. 1.8. Список типов открываемых файлов

Поэкспериментируйте с открытым файлом: уменьшите и увеличьте масштаб, переместитесь со страницы на страницу, пользуясь ползунком прокрутки и навигатором.

Рис. 1.9. Открытый документ

При открытии программа проверяет, установлены ли на вашем компьютере шрифты, использованные в документе. Если шрифты не установлены, или имеют другое имя, программа выдаст окно замены шрифта (рис. 1.10). Следует учесть, что разные шрифты могут иметь похожие, но неодинаковые характеристики, и при замене текст смещается. Замены шрифта всегда крайне нежелательны. Если все использованные шрифты установлены, то файл откроется без запроса. Подробно о работе со шрифтами рассказано в главе 4.

Рис. 1.10. Запрос на замену шрифта

Из окна Open a File можно открывать одновременно несколько файлов. Они открываются по одному. Собственные файлы программы (они имеют расширение INDD) можно открывать и двойным щелчком на значке файла в окне программы Explorer. Если InDesign не запущен, он автоматически загружается в момент обращения к файлу. Файлы других приложений — Quark Express или PageMaker при двойном щелчке на соответствующем значке вызывают собственные программы.

Одновременно может быть открыто несколько документов. Их количество лимитируется размером оперативной памяти компьютера. Список всех открытых файлов расположен в нижней части меню Window (рис. 1.11). Имя файла, активного в данный момент, отмечено галочкой (в данном случае это файл 02_a.indd). Чтобы перейти к нужному файлу выберите мышью строчку с его именем.

Рис. 1.11. Список открытых публикаций в меню Window


Открытие копии существующего файла

Допустим, вы хотите создать публикацию на основе существующей. При этом важно, чтобы исходный документ остался в первозданном виде. Для этой работы нужно редактировать не сам документ, а его копию.

  1. Откройте диалоговое окно Open и выберите, например, файл 02_b.
  2. Установите переключатель Copy в правой части диалогового окна. После нажатия кнопки ОК программа создаст копию данного документа с условным именем Untitled и номер по порядку. Если предыдущий документ получил имя Untitled 1, то этот будет назван Untitled 2.

Переключатель окна Open используется также при работе с шаблонами документов, об этом рассказывается в главе 15.


Элементы управления публикацией

Основные действия с документом производятся командами меню, которые описаны выше. По мере изучения материала мы будем рассматривать команды меню и соответствующие им диалоги подробно. Столь же важную роль играют и палитры.

При работе также необходимо выбрать правильный масштаб отображения и научиться свободно переходить от одной части публикации к другой, как в пределах страницы, так и между страницами.


Палитры

Это специальные элементы управления, которые могут постоянно находиться на экране и управляют определенными свойствами объектов. Палитры можно перемещать по экрану, перетаскивая мышью за верхнюю синюю полосу. Некоторые палитры можно сворачивать и изменять их размеры. Все палитры, кроме Toolbox, можно произвольно группировать и стыковать между собой.


9

Палитра инструментов

Эта "главная" палитра содержит инструменты работы с публикацией. Она практически всегда находится на экране (рис. 1.12). Кнопка активного инструмента как бы вдавлена в панель. По умолчанию активен инструмент Selection, расположенный в верхнем левом углу палитры.

Рассмотрим работу с инструментами.

  1. Выберите инструмент Ellipse щелчком мыши. Это инструмент рисования кругов и эллипсов.
  2. Подведите курсор к странице, нажмите левую кнопку мыши и буксируйте курсор. За курсором тянется эллипс. Отпустите кнопку мыши (рис. 1.13), и созданная фигура примет заливку и обводку по умолчанию (белая заливка черная обводка). Вы создали объект.

    3. Рис. 1.12. Палитра инструментов Toolbox (в отдельных панелях показаны скрытые инструменты)

    Рис. 1.13. Активный инструмент Ellipse и рисование эллипса

  3. Щелкните на инструменте Selection. Это инструмент выделения. Он указывает программе, какой объект нужно обрабатывать.
  4. Подведите курсор к созданной фигуре и щелкните на ней. Фигура стала активной, вокруг нее появился габаритный прямоугольник с манипуляторами.
  5. Поместите курсор внутрь или на границу габаритного прямоугольника (не на манипуляторы). Нажмите кнопку мыши и, не отпуская ее, перемещайте курсор. Этот прием мы в дальнейшем будем называть перетаскиванием. Перетащите эллипс на новое место (рис. 1.14).

    6. Рис. 1.14. Активный инструмент Selection и перемещение объекта

  6. На палитре видны не все инструменты, некоторые кнопки скрывают в себе несколько других. Эти кнопки помечены маленьким треугольником справа внизу.
  7. Для того чтобы добраться до скрытых инструментов, щелкните на треугольнике, например, на кнопке инструмента Pen. Кнопка раскроется, и вы увидите все инструменты данной группы (рис. 1.15).

Рис. 1.15. Выбор инструмента в раскрывающейся панели

8. Выберите скрытый инструмент Add Anchor Point и отпустите кнопку. Группа снова исчезнет, а в палитре на месте кнопки появится выбранный инструмент.

На рис. 1.12 панели скрытых инструментов программы изображены рядом с основной палитрой.

Для палитры инструментов есть общие клавиатурные сокращения.

  1. Каждой группе инструментов в палитре Toolbox соответствует одна клавиша латинского алфавита. Первое нажатие данной клавиши переводит фокус на открытый инструмент группы. Нажмите клавишу <Р>. Активным стал инструмент Pen.
  2. Удерживая нажатой клавишу <Shift>, еще раз нажмите клавишу <Р>. Каждое нажатие приводит к последовательной активизации всех инструментов данной группы.

Обратите особое внимание, что все клавиатурные сокращения действуют только в латинской раскладке клавиатуры, а некоторые чувствительны и к регистру символов.

Продукты Adobe ориентированы на использование клавиатурных эквивалентов команд меню и некоторых команд палитр. Производители придерживаются вполне справедливого мнения, что работа мышью обычно медленнее, чем нажатие клавиш на клавиатуре. Поэтому большинству действий в программах этой фирмы соответствуют клавиатурные эквиваленты. Их сотни, и запомнить все могут лишь опытные пользователи. Однако сокращения помогают ускорить работу в профаммах Adobe на порядки. Доли секунд, которые тратятся на перемещение мыши, складываются в часы непроизводительной работы. Мы будем упоминать о клавиатурных сокращениях при рассмотрении всех функций программы. В InDesign возможно изменять клавиатурные сокращения, создавать пользовательские комплекты сокращений.

Для подавляющего большинства программ в клавиатурных сокращениях клавиша <Ctrl> для Windows-версии соответствует клавише <Command> для Мае, a <Alt> — клавише <0ption>.

Специальные сокращения есть для каждого инструмента программы. Выбор инструмента горячей клавишей экономит ценное рабочее время. Кроме того, для часто используемых инструментов есть дополнительные эквиваленты. Некоторые из них приведены в табл. 1.1. Постарайтесь как можно быстрее запомнить клавиатурные эквиваленты инструментов. Это сделает общение с программой более свободным.

Таблица 1.1. Клавиатурные сокращения инструментов InDesign

Группа | Инструмент | Действие | Сокращение
Selection | Selection | Выбор объекта | <V>, временный переход — удерживать клавишу <Ctrl> (<Command>)
Direct Selection | Direct Selection | Выбор опорных точек объекта | <А>, временный переход — удерживать клавишу <Ctrl> (<Command>)
Pen | Pen | Построение контуров по опорным точкам | <Р>, временно, если активен инструмент Convert Anchor Point— <Alt> (<0ption>)
 | Add Anchor Point | Добавление опорной точки на контуре | <Shift>+<P>, <+>, временный переход, если активен инструмент Delete Anchor Point—<Alt> (<0ption>)
 | Delete Anchor Point | Удаление опорной точки на контуре | <Shift>+<P>, <+>, временнный переход, если активен инструмент Add Anchor Point — <Alt>(<0ption>)
 | Convert Anchor Point | Изменение типа опорной точки | <Shift>+<P>, временный переход, если активен инструмент Pen — <Alt> (<0ption>)
Type | Type | Редактирование, набор, форматиро- вание текста | <T>
Ellipse | Ellipse | Построение эллипсов и кругов | <L>, построение круга — удерживать клавишу <Shift> в момент построения
 | Ellipse Frame | Построение фреймов в форме эллипса или круга | <L>
Line | Line | Построение прямых линий | <Е>
Rectangle | Rectangle | Построение прямоугольников | <М>, построение квадрата — удерживать клавишу <Shift> в момент построения
 | Rectangle Frame | Построение фреймов в форме прямоугольников | <М>, построение квадрата — удерживать клавишу <Shift> в момент построения
Polygon | Polygon | Построение многоугольников | <Shift>+<L>
 | Polygon Frame | Построение фреймов в форме многоугольника | <Shift>+<L>, двойной щелчок на инструменте — вывод окна свойств для задания числа сторон многоугольника
Rotate | Rotate | относительно произвольного центра вращения | <R>
Scale | Scale | Масштабирование контура относительно произвольного центра | <S>, пропорциональное масштабирование — удерживать клавиши <Ctrl>+<Shift>
 | Shear | Наклон относительно произвольного центра | <Shift>+<S>
Gradient | Gradient | Создание линейной и эллиптической цветовой растяжки | <G>
Scissors | Scissors | Размыкание контура в выбранной точке | <С>
Hand | Hand | Прокручивание документа в окне | <Н>, временный переход с любого инструмента кроме Text — <Space>
Zoom | Zoom | Смена масштаба отображения документа | <Z>, временный переход для увеличения масштаба — удерживать <Ctrl>+<Space> (<Command>+<Space>), для уменьшения масштаба — удерживать <Alt>+<Ctrl>+ +<Space> (<0ption>+ +<Command>


10

Заливка и обводка в палитре

Кроме собственно инструментов, в палитре Toolbox сосредоточены кнопки индикации и ускоренного задания обводки и заливки объекта. Они принадлежат к числу часто используемых элементов и также имеют клавиатурные сокращения (табл. 1.2).

Таблица 1.2. Элементы управления запивкой и обводкой объектов на палитре Toolbox

Элемент | Описание | Клавиши
Swap Fill and Stroke | Щелчок на значке меняет местами атрибуты заливки и обводки | <Shift>+<X>
Default Fill and Stroke | Щелчок на значке устанавливает атрибуты заливки и обводки по умолчанию | <D>
Color | Нажатие кнопки меняет заливку или обводку на последнюю из выбранных сплошных заливок | <,>
Gradient | Нажатие кнопки меняет заливку на последний из выбранных градиентов | <.>
None | Нажатие кнопки отменяет заливку или обводку объекта | </>
Fill | Образец заливки объекта. Если эта кнопка находится на переднем плане, то выбирается и редактируется заливка. Если выбраны несколько объектов с разными заливками, кнопка помечена знаком "". Если объект не имеет заливки, кнопка помечена косой красной чертой | <Х> (переключение из режима Stroke)
Stroke | Образец обводки объекта. Если эта кнопка находится на переднем плане, то выбирается и редактируется обводка. Если выбраны несколько объектов с разными обводками, кнопка помечена знаком "". Если объект не имеет обводки, кнопка помечена косой красной чертой | <Х> (переключение из режима Fill)

Выполним маленькое упражнение на применение полученных знаний.

  1. Выделите эллипс и посмотрите на кнопки управления цветом. Эллипс по умолчанию имеет черную обводку и отсутствие заливки.
  2. Нажмите кнопку Swap Fill and Stroke. Заливка и обводка поменялись местами. Эллипс стал черным.
  3. Нажмите кнопку Fill палитры Toolbox. Она стала активной. Теперь можно выбирать цвет для заливки объекта.
  4. Нажмите кнопку Gradient. Заливка эллипса стала градиентной.
  5. Нажмите кнопку Default Fill and Stroke. Атрибуты заливки и обводки снова установлены по умолчанию.

В главе 4 мы подробно рассмотрим работу с цветами и градиентными заливками документа, а также специальные свойства обводок.


Прочие палитры

Остальные палитры программы предназначены для задания и редактирования различных атрибутов, а также для получения информации. Палитры могут быть либо отображены в окне документа, либо спрятаны. Для вызова палитры есть команды меню. Многие палитры могут быть вызваны/спрятаны при помощи комбинаций клавиш (см. приложение 1). Каждая палитра имеет заголовок и кнопки закрытия и минимизации. Элементы, общие для большинства палитр, приведены на рис. 1.16.

Если палитра имеет заштрихованный треугольник в нижнем правом углу, ее размеры можно изменить, как размер обычного окна. Палитры без треугольника не масштабируются.

Рис. 1.16. Элементы палитры

Двойной щелчок мышью на синей полосе вверху палитры или одинарный щелчок на кнопке с горизонтальной полосой сворачивает палитру, так что на экране виден только ее заголовок. Если палитра в данный момент не нужна, ее лучше свернуть (рис. 1.17). Так она занимает меньше места на экране и в то же время легко доступна. Если палитра вновь понадобилась, повторный щелчок вернет ее к исходному виду.

а [image] б

Рис. 1.17. Палитра свернута и развернута

Если палитра не нужна в ближайшее время, лучше вовсе закрыть ее. Все палитры, кроме Toolbox, могут быть закрыты щелчком на кнопке с крестом.

Палитры размещаются на экране произвольным образом. Для перемещения щелкните мышью на верхней синей полосе и, не отпуская кнопку мыши, перетаскивайте палитру.

Палитры открываются командами меню Window, кроме текстовых, которые открываются командами меню Type. Например, если выбрать команду Color... меню View, на экране появится палитра Color. При открытой палитре повторный выбор команды Color спрячет соответствующую палитру.

Некоторые из палитр имеют собственное меню. Откройте меню палитры Color щелчком на треугольной стрелке справа. В него входят команды и режимы палитры. Если в меню палитры есть команда-переключатель меню палитры Show Options\Hide Options, то для палитры можно открыть дополнительные, возможности редактирования. Испытайте действие этой команды, например, для палитры Color. На рис. 1.18 представлена палитра Gradient с закрытыми и открытыми дополнительными параметрами.

а [image] б

Рис. 1.18. Дополнительные элементы палитры

а [image] б

Рис. 1.19. Активизация палитры Color

По умолчанию палитры собраны в группы по тематическому принципу. Возможны разные способы организации палитр. Чтобы палитра стала видна в группе, просто щелкните на вкладке с ее названием (рис. 1.19).

а

Рис. 1.20 а. Обособление палитры

б

Рис. 1.20 б. Обособление палитры

Чтобы обособить палитру от группы, щелкните на вкладке с названием и, не отпуская кнопку мыши, перетащите палитру за пределы группы (рис. 1.20).

Тем же способом можно включить палитру в другую группу. Для этого перетащите ее в пределы группы. Когда перемещаемая палитра окажется в нужной области, рамка группы будет подсвечена (рис. 1.21).

а

б

в

Рис. 1.21. Группировка палитр


Контекстное меню

Контекстное меню существует во многих приложениях. В нем собраны команды, которые скорее всего понадобятся вам в данный момент.

  1. Щелкните инструментом Selection на свободном месте документа, отменяя выделение объектов.
  2. Откройте контекстное меню, нажав правую кнопку мыши (рис. 1.22).

    3. Рис. 1.22. Контекстное меню

  3. Не отпуская кнопку мыши, подведите курсор к команде Hide Rulers. Линейки вдоль верхней и левой сторон окна документа исчезли.
  4. Снова откройте контекстное меню. Команда Hide Rulers превратилась в Show Rulers. Выберите ее. Линейки вновь появились. Пункты меню, действующие подобным образом, называются командами-переключателями.

Содержимое контекстного меню меняется в зависимости от области, где выполнен щелчок, от наличия выделения, объекта в буфере, выбранного инструмента. По мере рассмотрения команд и операций программы мы будем упоминать об их наличии в контекстном меню.


Типы объектов в документе

Страницы и развороты

Публикация размещается на страницах (pages). На экране они отображаются прямоугольником с тенью. На странице обычно присутствуют поля (margins), которые также устанавливаются при создании документа. При печати выводится все содержимое страницы, включая объекты, расположенные на полях. Каждая страница снабжена собственным рабочим столом (pasteboard), на котором можно располагать объекты, но на печать они не выводятся. В зависимости от масштаба отображения, одновременно может быть видима одна или несколько страниц, каждая со своим рабочим столом.

Рис. 1.23. Документ с одинарными страницами и с разворотами

Перемещая ползунок вертикальной линейки прокрутки, вы можете "листать" страницы в окне документа. Существуют и другие способы навигации по страницам, которые будут рассмотрены ниже. Страницы на экране могут объединиться в развороты (spreads) и отображаться вместе. Наиболее простой случай — разворот из двух страниц. Такое отображение удобно при подготовке публикации для двухсторонней печати. Для создания документа с разворотами установите флажок Facing Pages в окне New Document. На рис. 1.23 показан внешний вид документа с одинарными страницами и с разворотами.

Размер страниц, их количество и наличие разворотов задается при создании документа в диалоговом окне New Document. Впоследствии эти параметры могут быть произвольно изменены. Для этого служит диалоговое окно Document Setup. Оно открывается одноименной командой меню File (рис. 1.24). При открытии окна в нем указаны текущие параметры документа — число страниц в поле Number of Pages и размеры в области Page Size. Состояние флажка Facing Pages определяет наличие или отсутствие разворотов в публикации. Установите требуемые характеристики документа и щелкните на кнопке ОК. Параметры публикации изменятся соответственно.

Рис. 1.24. Диалоговое окно Document Setup

Кроме того, страница имеет одну или несколько колонок (columns). Число колонок также определяется при создании документа. Если страница имеет только одну колонку, ее границы совпадают с границами правого и левого полей.

Развороты могут состоять из нескольких страниц. Такое устройство публикации необходимо, например, при издании буклетов. Разворот из нескольких страниц в программе называется island spread (архипелаг). Для его создания пользуются палитрой Pages.


Фреймы и объекты

В InDesign условно выделяют три типа объектов:

  • Графические объекты. Они создаются инструментами рисования или импортируются из программ векторной графики, например Illustrator. Инструменты рисования — это Line, Rectangle, Ellipse, Polygon, Path. Создаваемые ими объекты ничем не отличаются от обычной векторной графики. Они могут иметь различные атрибуты обводки и заливки,

трансформироваться и редактироваться по точкам. Испытайте действие инструментов рисования. На рис. 1.25 приведены примеры графических объектов.

Рис. 1.25. Графические объекты в InDesign

  • Графические фреймы. Это тоже объекты, но предназначенные для размещения импортированной или созданной средствами InDesign графики. Объекты этого типа создаются инструментами Rectangle Frame, Ellipse Frame, Polygon Frame. Они тоже способны трансформироваться, иметь заливки и обводки, редактироваться по точкам. Создайте графические фреймы разной конфигурации, пользуясь указанными инструментами. Пустой графический фрейм по умолчанию имеет вид фигуры с косым крестом, без заливки и обводки (рис. 1.26).

а

б

Рис. 1.26. Графический фрейм (пустой): а — невыделенный, б — выделенный

  • Текстовые фреймы. Графические объекты, предназначенные для размещения текста. Текст в программе может располагаться только внутри фрейма. Наиболее общим способом создания текстового фрейма является следующий: выбрав инструмент Type, щелкните мышью в области страницы или на рабочем столе, и протащите курсор по диагонали. Когда вы отпустите кнопку мыши, перед вами окажется прямоугольник с текстовым курсором в начале первой строки (рис. 1.27, о). При отсутствии выделения текстовый фрейм имеет вид, показанный на рис. 1.27, б. Если выделить фрейм инструментом Selection, его вид будет таким, как на рис. 1.27, в.

а

б

в

Рис. 1.27. Текстовый фрейм

а

Рис. 1.28. Документ с видимыми и невидимыми границами фреймов

Как вы уже заметили, в отсутствие выделения фреймы видимы на экране. Их границы по умолчанию помечены условными синими линями. Это удобно, поскольку облегчает структурирование документа и не дает невидимым объектам потеряться на странице. В то же время, служебные линии искажают восприятие готового макета. Поэтому, когда необходимо оценить внешний вид публикации, видимость служебных линий можно отключить (рис. 1.28). Для этого предназначена команда-переключатель Show Frame Edges/Hide Frame Edges.


Размещение текста и графики

Для начала заметим, что данная программа не создана для набора текста. Разумеется, вы можете набирать заголовки, и даже небольшие заметки не выходя из программы. Однако что касается больших объемов текста, набирать их внутри программы не стоит, поскольку это очень неудобно. Поэтому при обсуждении работы с текстом мы будем говорить в основном о размещении готового текста.

Текст в InDesign может быть размещен только во фрейме, и нигде более. Поэкспериментируем с его размещением. Перед началом эксперимента скопируйте в буфер несколько абзацев текста, например из помощи по программе.

Первый способ размещения — создание текстового фрейма инструментом Text (рис. 1.29):

  1. Выбрав инструмент Text, поместите курсор на страницу документа. Нажмите клавишу мыши и, не отпуская ее, протащите курсор по диагонали. Отпустив кнопку мыши, вы получите пустой текстовый блок.
  2. В левом верхнем углу находится текстовый курсор в виде небольшой вертикальной полосы. Вы находитесь в текстовом режиме. Именно в нем можно набирать текст.
  3. Наберите во фрейме несколько слов.

Рис. 1.29. Создание текстового фрейма инструментом Text я

4. Можно также разместить в текущем фрейме текст из буфера обмена. Не выходя из текстового режима, выберите команду Paste. Текст размещен.

Другой способ — размещение текста в пустом фрейме или объекте:

  1. Подведите инструмент Text к пустому графическому фрейму. Когда курсор примет вид, показанный на рис. 1.30, текст может быть набран или размещен в данном объекте.

    2. Рис. 1.30. Размещение текста в существующем фрейме

  2. Щелкните на объекте, и он превратится в текстовый фрейм. Теперь можно набирать или размещать текст. Наберите несколько слов, затем разместите во фрейме текст из буфера.
  3. Точно так же текст может быть помещен в уже существующий текстовый фрейм (не обязательно пустой) или графический объект. Графический объект при размещении текста также станет текстовым фреймом.

Третий способ размещения — автоматическое создание фрейма для размещаемого текста:

  1. Выберите любой инструмент, например Selection. He переходите в текстовый режим и не создавайте фрейм.
  2. Выберите команду Paste меню Edit. Программа автоматически создала фрейм и поместила в него текст из буфера.

Работа с текстом рассматривается в следующих главах. Сейчас вам нужно лишь усвоить, что текст всегда находится во фрейме, хоть и может попадать туда разными способами.

Графика в программе может быть двух типов.

  • Первый тип — это объекты, созданные в программе или импортированные из векторных приложений, совместимых с InDesign (в первую очередь это Illustrator). Графические объекты такого рода могут располагаться сами по себе или во фреймах.
  • Ко второму типу отнесем импортированную растровую графику, иллюстрации в формате EPS, и тому подобный графический материал. Он может находиться только внутри графического фрейма. Для размещения графики такого рода вы можете вначале создать пустой фрейм или графический объект, или предоставить программе сделать это автоматически. Приведем пример помещения графики в программу:
  1. Создайте графический фрейм. Выделите его инструментом Selection.
  2. Откройте папку Explorer и найдите у себя на компьютере любой растровый графический файл.
  3. Перетащите ярлык файла в окно документа программы и поместите его на выделенный фрейм. Отпустите кнопку мыши.
  4. Иллюстрация помещена во фрейм (рис. 1.31). Фрейм для графики выполняет роль маски, скрывая части иллюстрации, которые выходят за его пределы. В дальнейшем вы научитесь оперировать размерами и формой фрейма, добиваясь идеального соответствия или скрывая ненужные области фона.

    5. а

    б

    Рис. 1.31. Помещение иллюстрации в существующий фрейм

  5. Перетащите ярлык того же файла на свободное место окна документа InDesign. Программа снова вклеила в публикацию изображение. Однако на этот раз она автоматически создала новый фрейм, подходящий по размерам вклеенной иллюстрации (рис. 1.32).

Рис. 1.32. Создание фрейма при размещении иллюстрации


Способы выделения

В программе существует несколько инструментов и способов выделения. Инструмент Selection предназначен для .выделения объекта целиком. Если объект сложный, т. е. состоит из нескольких вложенных, например, представляет собой группу или графический фрейм с содержимым, то щелчок инструмента Selection выделяет одновременно все вложенные в сложный объект элементы.

  1. Щелкните активным инструментом Selection на одном из созданных вами графических фреймов. Вокруг фрейма появился габаритный прямоугольник с манипуляторами.
  2. Перетащите выделенный объект, фрейм и его содержимое смещаются вместе.

а

б

Рис. 1.33. Выделение рамкой

Для выделения нескольких объектов можно создать выделительную рамку.

  1. При активном инструменте Selection нажмите кнопку мыши и, не отпуская ее, ведите курсор по диагонали. За курсором тянется растущая выделительная рамка.
  2. Отпустите кнопку мыши. Все объекты, части которых попали в рамку, становятся выделенными (рис. 1.33). Если в выделительную рамку попала часть сложного объекта, он выделяется целиком. Для отмены выделения щелкните в любом месте окна документа.
  3. Перетащите выделенные объекты. Все они смещаются на одинаковое расстояние.

Инструмент Direct Selection предназначен для выбора отдельных элементов внутри сложных объектов и даже отдельных точек контуров.

  1. Выберите инструмент Direct Selection и подведите курсор к графическому фрейму с содержимым. Щелкните на изображении внутри фрейма (рис. 1.34, а).
  2. Контур изображения выделен синей обводкой (рис. 1.34, а).
  3. Перетащите курсор (рис. 1.34, б). Перемещается только изображение, фрейм, в котором оно расположено, остается на месте. Он не выделен.
  4. Нажатием клавиши <Delete> удалите выделенный объект. Фрейм опустел, но остался на месте.

    5. а

    б

    Рис. 1.34. Выделение содержимого фрейма инструментом Direct Selection

  5. Щелкните на границе фрейма (рис. 1.35). Теперь выделен только он, а изображение не выделено. Проверьте это, перетаскивая фрейм. Заметьте, что при выделении инструментом Direct Selection габаритный прямоугольник не появляется, выделяется только контур объекта. Точками отмечены узлы контура.
  6. Увеличьте фрагмент изображения. Как видите, фрейм представляет собой тоже контур и состоит из узлов. Щелкните точно на узле фрейма. Перетаскивая узел, вы изменяете форму фрейма (рис. 1.36).

а

б

в

Рис. 1.35. Выделение фрейма без содержимого инструментом Direct Selection

а

б

Рис. 1.36. Выделение и перетаскивание узла контура

В отличие от инструмента Selection, инструмент Direct Selection и в случае охвата рамкой выделяет элементы сложных объектов по отдельности. Более подробно о способах выделения и типах объектов рассказывается в главах, посвященных рисованию средствами программы In Design. В них же описаны способы работы с контурами.

Текстовый фрейм и содержащийся в нем текст с точки зрения инструментов выделения являются единым объектом. Для выделения текста используется инструмент Type. О работе с ним подробно рассказывается в следующих главах.


Взаимосвязь разных типов объектов

Наличие графических объектов трех разных типов может вас поначалу смутить. Однако это разделение довольно условно, и границы между разными типами объектов размыты. Если вы создали графический объект, а затем поместили в него картинку, то он превратился в графический фрейм. После удаления картинки он останется пустым графическим фреймом (рис. 1.37).

Пустой графический фрейм, в который помещен текст, станет текстовым и сохранит свои свойства после удаления из него текста (рис. 1.38).

Рис. 1.37. Превращения графического объекта

Рис. 1.38. Превращения графического фрейма

Аналогично, возможно помещение графики в пустой текстовый фрейм, который при этом превратится в графический (рис. 1.39). Как видите, тип объекта в первую очередь зависит от его содержимого.

Рис. 1.39. Превращения текстового фрейма


Вспомогательные линии

Кроме основных объектов, которые помещаются в публикацию, т. е. текста и графики, в публикации могут присутствовать несколько вспомогательных. Эти объекты не выводятся на печать. Они предназначены для удобства размещения основных объектов. Это, в первую очередь, рамка страницы, поля, колонки. Кроме того, в документе можно создавать направляющие линии.

Они помогают выровнять элементы публикации, разместить их на равном расстоянии, организовать модульную сетку на странице.

  1. Если вы отключили показ линеек, включите его.
  2. Щелкните на горизонтальной линейке и, не отпуская кнопку мыши, перетащите курсор на страницу документа. Отпустив кнопку, вы увидите тонкую горизонтальную линию голубого цвета. Это горизонтальная направляющая
  3. Вертикальную направляющую, как вы видимо догадались, можно точно так же "вытащить" из вертикальной линейки.


Просмотр и масштабирование документа

Инструменты Zoom и Hand, поле масштаба полосы состояния, команды группы Zoom и палитра Navigator обеспечивают просмотр иллюстрации в различном масштабе и отображение различных частей документа.


Поле масштаба полосы состояния

При создании или открытии масштаб отображения документа автоматически выбирается так, чтобы была видна вся страница иллюстрации (масштаб целой страницы). В левой части полосы состояния находится поле масштаба. Оно отражает текущий масштаб отображения публикации. Щелчок левой кнопкой мыши в поле масштаба переводит это поле в режим ввода — вы можете задать требуемый масштаб с клавиатуры. При щелчке на треугольной стрелке справа от поля перед вами откроется список масштабов, из которых мышью выбирается нужный (рис. 1.40).

Рис. 1.40. Поле масштаба с открытым списком

  1. Создайте документ, содержащий шесть страниц с разворотами. Первая страница отображается в одиночестве, поскольку она уже расположена справа. Для четного числа страниц при сшивке первая страница образует разворот с последней.
  2. Выберите масштаб 50% (рис. 1.41). Масштаб отображения уменьшился, и в окне документа стали видны следующие страницы!
  3. Обратите внимание: для каждой страницы (разворота) в программе определена собственная линейка.

    4. Рис. 1.41. Масштаб документа

    Рис. 1.42. Отображение всех шести страниц документа

  4. Перемещая вертикальный движок прокрутки, убедитесь в этом. Уменьшите масштаб до 12,5%. Теперь на экране видны все шесть страниц документа одновременно (рис. 1.42).
  5. Создайте в центре одной из страниц любой объект, например, вставьте растровое изображение или текст.
  6. Увеличьте масштаб до 200%.


Команды изменения масштаба

Для регулирования масштаба предназначены также верхние шесть команд меню View. Выберите поочередно все эти команды и посмотрите на результат.

Zoom In. Увеличивает масштаб отображения на одно фиксированное значение (эти значения расположены в списке поля масштаба полосы состояния).

Zoom Out. Уменьшает масштаб просмотра на одно фиксированное значение.

Fit Page In Window. Изменяет масштаб до целой страницы.

Fit Spread In Window. Изменяет масштаб до целой страницы.

Actual Size. Приводит масштаб отображения к 100%, т. е. размеры объектов на экране становятся такими же, как на печати.

Entire Pasteboard. Уменьшает масштаб просмотра так, что становится виден весь рабочий стол данной страницы или разворота.


Инструмент Zoom

Этот инструмент позволяет гибко менять масштаб выбранного участка. Активизируется клавишей <Z>.

а

б

в

Рис. 1.43. Одно и то же изображение в разных масштабах

  1. Выберите инструмент Zoom. Его курсор имеет вид лупы со знаком "+" внутри.
  2. Щелкните им на странице документа. Масштаб увеличился.
  3. Каждый щелчок инструментом Zoom на странице документа или монтажном столе увеличивает масштаб отображения на одно фиксированное значение (то, которое указано в списке поля масштаба полосы просмотра). При этом в центре окна документа каждый раз оказывается та область, в которой был выполнен щелчок (рис. 1.43).

Увеличивать масштаб этим инструментом можно и на произвольную величину (рис. 1.44).

а

б

Рис. 1.44. Увеличение с помощью выделительной рамки

  1. Активизируйте любой документ, содержащий изображения, например, Id_01.indd.
  2. Выбранным инструментом Zoom щелкните на странице документа. Не отпуская кнопку мыши, протащите инструмент, из точки щелчка за курсором последует выделительная рамка.
  3. Отпустите кнопку мыши. Область, очерченная выделительной рамкой, займет все окно документа.

Уменьшение масштаба производится тем же инструментом.

  1. При выбранном инструменте Zoom нажмите клавишу <Alt> (<0ption>), то знак курсора <+> изменится на <->.
  2. Щелкните на изображении в окне документа. Масштаб уменьшится. Точка щелчка при уменьшении масштаба также перемещается в центр окна документа. При каждом щелчке в окне документа масштаб будет уменьшаться на одно фиксированное значение.

Переход к инструменту Zoom можно осуществлять временно с любого другого клавиатурным сочетанием <Ctrl>+<Space> (<Command>+<Space>). Инструмент будет активизирован (курсор примет вид лупы со знаком "плюс"). Увеличение может производиться как щелчком, так и рамкой. Если кроме клавиш <Ctrl>+<Space> (<Command>+<Space>) удерживать еще клавишу <Alt> (<0ption>), то курсор станет лупой со знаком "минус", и будет выполнено уменьшение. После масштабирования снова станет активным предыдущий инструмент.

Двойной щелчок на кнопке инструмента в палитре Toolbox или команда Actual Size меню View приводит масштаб документа к 100%.


Перемещение по публикации

Перемещение по открытой публикации необходимо в двух случаях. Во-первых, при увеличенном масштабе в окне документа могут быть видны не все области изображения, чтобы увидеть их, нужно переместить документ в окне. Во-вторых, при наличии в публикации нескольких страниц необходим простой и быстрый способ перехода между ними. Для навигации в пределах публикации существует несколько способов.


Полосы прокрутки

Полосы прокрутки с ползунками справа и внизу документа. Для перемещения по публикации можно просто передвинуть ползунок. Таким образом, можно как перемещать в окне документа страницу в увеличенном масштабе, так и переходить со страницы на страницу.


Навигатор

Рядом с полем масштаба расположен дополнительный элемент управления для перемещения по страницам — навигатор. В среднем поле отображается номер текущей страницы по порядку. Для перехода на другую страницу:

  1. Введите нужный номер прямо в поле.
  2. Нажмите кнопку Next Page или Previous Page для перехода на следующую или предыдущую страницу.
  3. Нажмите кнопку Last Page или First Page для перехода на последнюю или первую страницу документа.


Палитра Pages

Эта палитра, вообще говоря, многофункциональна. В верхней ее части наедятся пиктограммы страниц публикации и их номера. Для того чтобы перейти на какую-либо станицу, выполните двойной щелчок на пиктограмме страницы.

Здесь необходимо сделать одно важное уточнение — в программе есть два определения активности страницы.

Целевой (активной) страницей или разворотом (Target spread) считается та, на которую помещается новый объект. Например, если в окне документа отображены несколько страниц, и вы собираетесь вклеить объект на одну из их. В каждый момент целевой может быть лишь одна страница (разворот). Целевая страница по умолчанию располагается программой посередине окна документа. Она отображается подсвеченным номером страницы (не подсвеченной пиктограммой страницы). Вертикальная линейка целевой страницы имеет черный цвет делений и цифр. Остальные линейки помечены серыми делениями.

Выбранной страницей (Selected spread) считается та, с которой производятся действия (именно со страницей, не с объектами на ней), такие как задание полей, колонок и пр. Выбранных страниц может быть сколько угодно. Они отмечаются подсвеченными пиктограммами (не номерами страниц) в палитре Pages.

С помощью данной палитры можно делать целевой одну страницу, а выбранной — другую. Подробный разговор о палитре Pages пойдет в главе 12, а до этого будем считать, что переходя на страницу вы одновременно делаете ее и целевой и выбранной.


Инструмент Hand

Для точного перемещения по документу в увеличенном масштабе используется инструмент Hand (его курсор имеет вид руки), активизируемый клавишей <Н>).

Нажав левую кнопку мыши, перемещайте курсор. Таким образом, вы легко получаете доступ к областям документа, находящимся за пределами видимости.

Инструмент Hand можно использовать и для перемещения между страницами. Он вполне пригоден, если в публикации немного страниц.

Временный переход на инструмент Hand происходит при нажатии клавиши <Space> и возможен с любого инструмента, кроме входящих в группу Text. Для перехода к инструменту Hand от активного инструмента группы Text нажмите клавишу <Alt>. Сделайте необходимые перемещения, не отпуская ее. Когда вы отпустите <Alt>, активным снова станет инструмент Text.


Палитра Navigator

Эта очень удобная палитра (рис. 1.45) впервые появилась в Adobe Photoshop. Она совмещает в себе функции инструментов Hand и Zoom. Посмотрим, как управляться с этим инструментом.

Рис. 1.45. Палитра Navigator

  1. Вызовите палитру Navigator одноименной командой меню View. Она состоит из поля ввода масштаба (внизу слева). Введите с клавиатуры значение масштаба, например, 200%.
  2. Рядом располагается движок изменения масштаба. Крайняя левая позиция соответствует наименьшему, а правая — наибольшему из возможных масштабов документа. Передвигая регулятор, плавно уменьшите масштаб от 200 до 100%.
  3. Основную часть палитры занимает поле просмотра документа. В нем в уменьшенном виде отображаются объекты документа. Увеличьте масштаб, затем перемещайтесь по окну документа. Соответственно меняется вид поля просмотра. Красной рамкой в нем отображается видимая часть окна документа.

Переместите красную рамку в окне просмотра палитры. Перетаскивание ее соответствует перемещению документа в большом окне. Если масштаб отображения невелик, и все объекты видны на экране, то рамка совпадает с границами поля просмотра.

У этой палитры есть меню. Команда меню View All Spreads — это переключатель режима. Если он не активен (рядом со строкой в меню палитры флажок не установлен), то в поле просмотра виден только активный разворот (страница), показанный на рис. 1.46, а. Если режим View All Spreads включен, то в поле просмотра будут отображены все страницы публикации (рис. 1.46, б).

а [image] б

Рис. 1.46. Поле просмотра палитры Navigator: Режим View All Spreads отключен (а), эежим активен (б)

Команда Palette Options меню палитры Navigator вызывает одноименное диалоговое окно свойств палитры, в раскрывающемся списке Color которого можно выбрать новый цвет для рамки видимой области документа.


Работа в нескольких окнах

В программе может быть открыто одновременно несколько документов. При открытии окно каждого последующего документа закрывает собой окно предыдущего. Для переключения между документами используется список в нижней части меню View. В этом списке каждая строка соответствует открытому окну. Окно, в строке которого установлен флажок, активно. Переключение активных окон осуществляется выбором одной из строк.

Размеры окон документа меняются стандартным образом. При уменьшении окна под ним обнаружится окно другого открытого документа (если таковой имеется). Команды Cascade и Tile организуют просмотр всех окон одновременно (рис. 1.47).

В InDesign возможен просмотр документа одновременно в нескольких окнах. Каждое из окон документа отображается строкой в списке меню View, наряду с окнами других документов. Между этими окнами также можно переключаться, менять их размеры и отображать одновременно на экране. В каждом окне выбирается свой масштаб отображения и режим просмотра (рис. 1.48).

а

б

Рис. 1.47. Просмотр окон: Cascade о(а), Тile (б)

Рис. 1.48. Окна одного документа

Это удобно, например, чтобы при редактировании детали (в одном окне) следить за видом всего изображения (во втором окне).

Несмотря на кажущуюся самостоятельность, все эти окна отображают один и тот же документ. Результаты редактирования в одном из них отражаются в остальных.


Сохранение и закрытие документа

После работы необходимо сохранить сделанные изменения. Для сохранения отредактированного документа предназначена команда Save. Ей соответствует комбинация клавиш <Ctrl>+<S> (<Command>+<S>). Эта команда доступна, только если файл после последнего сохранения подвергался хоть малейшему редактированию. Результат действия команды различен:

  • Если документ уже был сохранен, никакие дополнительные запросы не появляются. Новая редакция документа просто переписывается поверх старой. После сохранения восстановить предыдущую версию невозможно!

При сохранении все же возможны ошибки, например, сохранение файла после удаления фрагмента. Чтобы избежать сохранения нежелательных изменений в документах, регулярно создавайте резервные копии файлов.

  • Если открытый документ еще не был сохранен, т. е. создан в текущем сеансе работы, команда Save для него открывает диалоговое окно Save This Document As, т. е. команда Save аналогична команде Save As.

Команды Save As и Save a Copy в общем случае предназначены для сохранения копии документа под другим именем. Отличие между ними в том, что первая оставляет открытой сохраненную копию, а вторая — первоначальный документ. После выбора одной из этих команд появляется системное окно сохранения файла (Save This Document As в первом случае и Save A Copy As — во втором (рис. .49)). Ваша задача — выбрать папку для сохранения документа, ввести имя файла в поле File name и выбрать формат в списке Save as type. Программа предлагает только два формата для сохранения файла — документ InDesign и шаблон InDesign.

Рис. 1.49. Диалоговое окно сохранения файла

Два способа сохранения документов

В InDesign присутствует механизм быстрого сохранения файла. При выборе команды Save для уже сохраненного документа программа не записывает его содержание целиком. Она оставляет нетронутым предыдущий вариант, хранящийся на диске, и добавляет к нему указания на сделанные изменения. В результате скорость сохранения документа сильно возрастает. Поскольку сохранение само по себе — процесс длительный, возможность быстрого сохранения очень удобна. С другой стороны, при таком методе записи файла постоянно увеличивается его размер, даже при удалении фрагментов. К тому же в таком документе очень велика возможность накопления ошибки. Выбор команды Save As приводит к полному обновлению данных о документе в файле. Сохранение этим способом гораздо дольше, но файл получается более компактным (зачастую в несколько раз) и корректным. Разумно сочетать оба способа сохранения— во время работы сохранять документ командой Save, а в конце рабочего дня или после выполнения важных операций — командой Save As с последующим сохранением под тем же именем.


Закрытие документов

По окончании работы файл закрывают командой Exit меню File. Если файл перед этим был сохранен, то он закрывается без запроса на сохранение.

Если после последнего сохранения документ не был сохранен, то по этой команде откроется диалоговое окно, показанное на рис. 1.50. Если нажать кнопку Save, файл будет сохранен и закрыт, кнопка Cancel отменяет команду, а нажатие кнопки Don't Save приводит к закрытию файла без сохранения последних изменений.

Рис. 1.50. Запрос на сохранение изменений

Выход из файла осуществляется и при выборе команды Revert. В этом случае программа закрывает документ без сохранения изменений, а затем снова открывает его первоначальный вариант. Эта команда не может быть отменена. Перед ее выполнением InDesign открывает окно с запросом подтверждения.

Во избежание потерь периодически сохраняйте текущую работу. Если, скажем, вы будете сохранять изменения каждые 10-15 минут, то даже после неожиданного сбоя или серьезной ошибки вы можете быть уверены, что на переделку не уйдет много времени. Разумно также сохранять файл перед каждым серьезным изменением и запуском другого приложения. Кроме того, имеет смысл хранить резервные копии всех рабочих файлов на дискете, ZIP-дискете, перезаписываемом компакт-диске (CD-RW) или другом носителе. Обновляйте эти резервные копии хотя бы раз в день после работы.

Если вы работаете над групповым проектом, или вашим компьютером может пользоваться кто-то еще, резервное копирование просто необходимо!


Если что-то испортилось

В работе любой, даже самой надежной программы, случаются досадные неприятности. Во-первых, ошибиться можете вы сами. Во-вторых, падение напряжения в сети или другие причины могут вызвать аварийное завершение работы программы или всего компьютера.


Исправление собственных ошибок

Не ошибается лишь тот, кто ничего не делает. В процессе работы вы вполне можете совершить ошибочное действие. Кроме того, вы можете передумать совершать то или иное действие. Для исправления ошибок в программе предусмотрено несколько стандартных ходов:

  • Для отмены продолжительной операции, происходящей прямо сейчас, пока программа ее еще не закончила (например, на экране еще присутствует индикатор выполнения операции), можете нажать клавишу <Esc> (если успеете).
  • Для отмены последнего действия воспользуйтесь клавишами <Ctrl>+<Z> или выберите команду Undo меню Edit. Программа позволяет последовательно отменять сколько угодно действий, их количество лимитируется только доступной памятью компьютера.
  • Чтобы вернуть выполнение действия, выберите команду Redo того же меню Edit. После закрытия или сохранения документа отменить или вернуть действия уже нельзя. Некоторые действия невозможно отменить (например, изменение масштаба).
  • Для отмены всех шагов с момента последнего сохранения публикации выберите команду Revert меню File. Программа закроет документ без сохранения и откроет ранее сохраненный вариант. Само это действие не может быть отменено, поэтому перед его выполнением InDesign просит подтверждения.
  • Для отмены изменений, внесенных в диалоговое окно программы, закройте его нажатием кнопки Cancel.


Восстановление публикации после аварийного закрытия

В сеансе работы InDesign хранит временные файлы с данными о текущем состоянии всех открытых документов. Находятся они в папке \In Design Recovery по адресу: \Windows\Local Settings\Application Data\Adobe\InDesign\ Version 1.0\InDesign Recovery. Временные файлы хранятся не в пользовательском формате программы и открыть их в InDesign нельзя (видимо, разработчики считают эту информацию секретной). После сохранения документа и закрытия программы информация из временных файлов записывается в файлы документов InDesign. Сами временные файлы автоматически удаляются.

При аварийном выходе из программы (например, в случае отключения питания), временные файлы не удаляются. При следующем запуске программа автоматически восстанавливает состояние всех не сохраненных на момент сбоя документов и открывает их в восстановленном виде. Рядом с названием в заголовке окна документа появляется слово "Recovered". Для сохранения восстановленного документа воспользуйтесь командой Save As. Чтобы отменить восстановление и вернуться к ранее сохраненному документу, закройте его без сохранения или выберите команду Revert.

Совет

Если при запуске после сбоя программа не может открыть восстановленные документы, или еще того хуже — сама не открывается, попробуйте перезапустить компьютер и снова открыть InDesign. Если это не помогает, то вероятно, временные файлы содержат ошибку. В этом случае восстановить публикации невозможно. Чтобы сама программа все же загрузилась, войдите в папку, указанную в начале раздела, и удалите из нее все файлы. InDesign "забудет" о сбойных документах и, возможно, заработает как нужно.

Несмотря на хорошее качество восстановления документов, рекомендуем вам все же пользоваться резервным копированием.


Строение публикации

Обсудив основные приемы, неплохо в общих чертах взглянуть на объект работы. InDesign предназначен в первую очередь для верстки печатной продукции — книг, газет, журналов, рекламных листовок и пр. Разумно сразу договориться о терминологии.


Части книги

Каждый элемент книги имеет свое название. Азбука полиграфиста, все эти термины необходимо знать абсолютно твердо. На вас посмотрят косо, если вы случайно перепутаете шмуцтитул с форзацем. В вашем издании необязательно должны присутствовать все перечисленные элементы, особенно если оно не относится к разряду дорогих.


Модульные сетки

Внутри публикации располагаются текст и иллюстрации. Помещены они на странице, разумеется, не как попало, а в строгом порядке. Схема, в соответствии с которой расположены части публикации, называется модульной сеткой (шаблоном, трафаретом). Модульная сетка определяет дизайн страниц и задает расположение заголовков, текста, иллюстраций, украшений, и пр. Она состоит из прямоугольников (модулей), разделенных небольшими промежутками. Элементы располагаются на странице в пределах одного или нескольких модулей. Разработка модульной сетки — очень важный этап создания публикации. Она служит каркасом, определяющим внешний вид будущего макета.

a

б

Рис. 1.51. Модульная сетка документа

На рис. 1.51 показан пример модульной сетки и сверстанного по ней документа. В программах верстки модульную сетку создают из направляющих линий. InDesign имеет хорошие средства для их создания. В главе 15 подробно описывается работа с модульными сетками.


Элементы страницы

Каждый из элементов публикации, расположенный на странице, также имеет свое название. В конце книги приведен краткий словарь терминов. (См. Глава 15)


Резюме

В настоящей главе даны начальные сведения по работе с программой:

  • Программа InDesign имеет оконный интерфейс. В меню программы содержатся основные команды. Палитры также служат для управления программой и располагаются произвольно в главном окне.
  • Документ InDesign имеет произвольный размер страницы. Публикация может содержать одну или несколько страниц. Параметры документа задаются в диалоговом окне Document Setup.
  • Страницы объединяются в развороты, каждая страница может иметь поля и колонки. Для удобства размещения объектов также используются направляющие линии. Каждая страница имеет свой собственный рабочий стол.
  • Основную роль в работе играет палитра Toolbox, содержащая видимые и скрытые инструменты. Как и другие приложения Adobe, программа построена на широком применении клавиатурных комбинаций.
  • В программе текст и импортированная графика могут располагаться только во фреймах. Разделяют графические и текстовые фреймы. Также в программе можно создавать обычные графические объекты.
  • Программа имеет большие возможности просмотра документа, в том числе произвольное точное масштабирование, специальные палитры, навигатор в нижней части окна документа, режимы просмотра, работа с документом в нескольких окнах.
  • Открытие, закрытие и сохранение документов производится стандартным образом. Программа обладает развитыми средствами исправления ошибок и восстановления публикаций.
  • Реальные публикации создаются на основе модульных сеток. Каждая часть книги и страницы имеет название.


Глава 10

Работа с текстовым материалом

Эта небольшая глава посвящена приемам автоматической обработки собственно текста, то есть, практически, возможностям InDesign как текстового процессора. Эти возможности, нужно сказать, невелики. Как вы уже знаете, в программе верстки обычно используется уже готовый текст. Тем не менее, в комплект программы включены несколько полезных функций обработки текста:

  • Поиск и замена
  • Языковые словари
  • Проверка орфографии


Функция поиска и замены

Применять функции поиска и замены приходится почти всегда после импорта материалов в InDesign. Даже самый квалифицированный и дружелюбно к вам настроенный наборщик не сможет проделать работу по окончательному редактированию текста за вас. В эту работу могут входить: расстановка стилей, полиграфических тире, кавычек, пробелов и т. п. Большая часть такой работы может быть выполнена в полуавтоматическом режиме именно с применением инструмента поиска и замены.

Поиск и замена выполняются в диалоговом окне Find/Change (рис. 10.1). Для его вызова предусмотрена одноименная команда меню Edit. Клавиатурное сокращение для диалогового окна замены — <Ctrl>+<F>.

Слово, символ, группу слов, абзац или группу абзацев — в общем, любой фрагмент текста — можно заменить на заданное соответствие, используя это диалоговое окно. Оно не является модальным, что упрощает работу по поиску и замене, поскольку вы в любой момент можете перейти от просмотра публикации к поиску, не тратя времени на повторный вызов окна.

При выполнении операции поиска и замены пользователь задает два параметра — образец (искомый текст) и замену. Как и любая автоматическая операция, поиск и замена проводятся буквально, т. е. программа находит именно данные последовательности символов и только их. Программа выделяет каждое наиденное вхождение образца в тексте цветом. Это удобно, поскольку позволяет сразу видеть, в каком контексте выполняется замена.

Рис. 10.1. Диалоговое окно Find/Change

Во время поиска и замены задается область поиска — она может включать только выделенные символы, абзац, текущий материал, текущий документ, и даже все открытые документы. Область поиска регулируется атрибутами поиска — практически вы можете осуществлять поиск, используя как критерий любой атрибут форматирования, как локального так и глобального, а также регистр и окружение символа.

Процесс поиска также регулируется от ручного (последовательное нахождение образцов и замена вручную), до глобального (нахождение всех образцов и их одновременная автоматическая замена).

Любой мощный инструмент потенциально опасен

Неумелое использование глобальной замены может изуродовать ваш текст до неузнаваемости, и тоже очень быстро. В разделе "Примеры применения атрибутов поиска и замены" описывается подготовка к серии глобальных замен.


Задание образца и замены

Для задания образца и замены используется пара полей ввода в верхней части диалогового окна. Символы в поля вводятся с клавиатуры или через буфер обмена, копированием. Программа хранит в памяти последние пятнадцать образцов. Чтобы выбрать образец, введенный ранее, щелкните на треугольной стрелке, направленной вниз, справа от поля ввода.

  • Find what. В эту строку вводится последовательность символов, которую будет искать InDesign.
  • Change to. Здесь указывается последовательность символов для замены.

Предметом поиска — образцами и заменами — могут быть как обычные буквы, цифры и символы, которые есть на клавиатуре, так и специальные. Щелчком на треугольной стрелке вправо (справа от поля ввода образца и замены) открывается список специальных символов In Design — тонкие и широкие пробелы, полиграфические дефисы, тире, кавычки (елочки), признаки конца абзаца, принудительные разрывы строк и другие элементы набора и форматирования. Подобные элементы называются в In Design специальными символами, и их невозможно набрать с клавиатуры в явном виде. Выберите из списка нужный символ, и его код появится в поле ввода. Зная код, можно набрать его с клавиатуры и вручную. При копировании текста в поля ввода из публикации специальные символы тоже копируются и обрабатываются корректно.

Ввод в поля поиска и замены специальных символов, которые не входят в список (например, математических), производится с использованием ASCI1-кода символа. Определить, какой именно код соответствует интересующему вас символу, проще всего с помощью системной утилиты Character Map. Когда вы это выяснили, установите точку вставки в поле образца или замены и введите на вспомогательной цифровой клавиатуре четырехзначный код символа при нажатой клавише <Alt>.

Предметом поиска могут быть абзацы

Если в окно образца или замены перед и после искомых или заменяемых символов вводится символ абзаца, это означает, что программа ищет не просто последовательность символов, а именно абзац, из них состоящий.


Атрибуты поиска

При поиске и замене можно произвольно задать атрибуты поиска, причем управление атрибутами производится исключительно гибко. Диалоговое окно Find/Change может находиться в двух режимах, переключаемых кнопкой-переключателем More/Less. В минимизированном состоянии приводятся следующие элементы управления атрибутами:

Case Sensitive. Этот флажок влияет на чувствительность поиска к регистру символов образца. По умолчанию он сброшен, и InDesign ищет образец не обращая внимания на регистр. Так, если в качестве образца введено слово "Ира", то будут найдены следующие слова: "Ира", Ираида", "тираж", "Ирак", "миражи", "квартира". Если установить флажок, то при том же образце в данном тексте будут найдены только слова, совпадающие по регистру с образцом: "Ира", "Ираида", "Ирак".

Whole word. Флажок определяет чувствительность поиска к целостности слова. Если флажок включен, то образец считается словом. Тогда InDesign не учитывает в процессе поиска части слов, ограничиваясь целыми словами. При этом предполагается, что слова в тексте разделяются пробелами и знаками пунктуации. Так, если в предыдущем примере ограничить область поиска целым словом, то единственным найденным в тексте словом будет "Ира" (и "ира" с маленькой буквы, если бы такое слово существовало).

Щелчок на кнопке More открывает область дополнительных атрибутов поиска (рис. 10.2). Она состоит из двух небольших областей. Атрибуты образца задаются с помощью элементов управления области Find Style Settings, атрибуты замены — в области Change Style Settings.

Рис. 10.2. Дополнительные атрибуты поиска

Для определения атрибутов нажмите кнопку Format. Перед вами — диалоговое окно Find Format Settings (рис. 10.3). Это большое окно, состоящее из нескольких вкладок. По устройству оно похоже на диалоговые окна редактирования стилей. Выбирая вкладки, задайте те атрибуты, которые вы хотите учитывать при поиске (для области образца) и те, которые вы собираетесь присвоить замененным символам (для области замены). Ниже перечислены вкладки диалогового окна Find Format Settings. Атрибуты, указанные вами в окнах, будут участвовать в процессе, остальные будут проигнорированы.

  • Style Options (см. рис. 10.3). Здесь задается стиль — отдельно символьный отдельно абзаца.

Рис. 10.3. Диалоговое окно Find Format Settings (вкладка Style Options)

  • Indents and Spacing. Отступы, выравнивание по базовым, отбивки, выключка.
  • Drop Caps and Composer. Атрибуты буквицы и режима размещения текста.
  • Justification. Параметры выключки и автоинтерлиньяжа.
  • Keep Options. Размещение абзацев и параметры висячих строк.
  • Basic Character Formats. Шрифт, начертание, кегль, кернинг, трекинг, регистр, индексы, интерлиньяж, подчеркивание, зачеркивание, лигатуры, старинное форматирование чисел Old Style и запрет разбиения слова или группы слов No Break.
  • Advanced Character Formats. Масштабирование по горизонтали и вертикали, наклон и смещение базовой линии, язык набора.
  • Character Color. Цвета символов абзаца — обводки и заливки и толщина обводки.

Если в окнах форматирования заданы какие-нибудь атрибуты, они перечислены в информационном поле слева от кнопки Format. При наличии форматирования рядом с соответствующим полем ввода образца или замены вверху окна появляется красный треугольник. Чтобы отменить задание атрибутов поиска в окнах, нажмите кнопку Clear в соответствующей области.

Следите за наличием форматирования

Если результат поиска получился не таким, как вы ожидали, проверьте, очистили ли вы область задания атрибутов после предыдущего поиска. Если вы поместили текст в поле копированием из публикации, проверьте, не скопированы ли заодно какие-нибудь непечатаемые символы — они тоже вклеиваются в строку поиска. Чаще всего это специальные пробелы. При выборе образцов из списка ранее примененных помните, что программа не хранит их атрибуты форматирования.


Примеры применения атрибутов поиска и замены

При помощи атрибутов можно производить большой спектр замен, например, заменять стили по всему тексту. Для этого не вводите в поля поиска и замены ничего, а только определите стиль в области Find Format Settings и в области Change Format Settings. Все элементы, имеющие стиль, заданный для поиска, будут отформатированы стилем, заданным для замены.

Поиском по атрибутам можно пользоваться и для введения букв национальных алфавитов, математических символов и других специальных символов. Дело в том, что набор с использованием кода символа зачастую отнимает много времени, особенно если для ввода соответствующего знака необходимо временно менять гарнитуру. Для решения этой проблемы есть простой способ: наборщик придумывает некий уникальный идентификатор для каждого экзотического символа (или группы символов), встречающегося в тексте. (например, "$$"). Идентификатор должен быть легко набираемым и не должен больше нигде встречаться в тексте. При каждом вхождении символа или группы символов в текст вместо них набирается идентификатор. По завершении набора организуйте глобальную замену для каждого из таких символов. В качестве образца поставьте ваш идентификатор, в поле замены — нужный символ. В области Change Style Settings установите нужную гарнитуру.

В состав образца и замены могут входить символы-шаблоны, имеющие код ^?. Введенный символ-шаблон означает, что в этом месте находится произвольный символ. Например, если ввести в качестве образца комбинацию "?аша", то программа найдет слова "Саша", "Маша", "ваша", "каша"..., т. е. на месте шаблона может быть любая буква.

Если поле Change to пустое, и атрибуты форматирования не введены, то замена приведет к удалению образцов из текста. Это отличный способ избавиться от нежелательных символов в тексте.

Для глобальной замены отсутствующих шрифтов очень удобно использовать это диалоговое окно. На вкладке задания атрибутов Basic Character Formats отсутствующие шрифты перечислены слитной группой — в скобках в конце списка шрифтов, и их несложно найти. Введите в качестве атрибутов форматирования образца отсутствующий шрифт, а для форматирования замены — шрифт, подобранный вами и существующий на компьютере.


Область поиска

Как сказано выше, можно управлять областью поиска и замены, по необходимости сужая и расширяя ее. Областью поиска может быть любой объем текста — от одного символа до всех открытых документов. Таким образом можно обрабатывать любые объемы текста, делая глобальные замены сразу для всех документов, например глав книги. Область поиска задается в раскрывающемся списке Search. Если в публикации нет текстового выделения, можно выбрать одно из значений списка:

  • Document. Поиск ведется во всей текущей публикации.
  • All documents. Поиск проводится во всех открытых публикациях. Активность автоматически переводится по очереди на каждую из них, и каждая просматривается. Операция, сравнимая по мощности с битвой на Курской дуге. Производится довольно редко, обычно при работе над большими проектами (например, книгами), когда материал публикации разделен на несколько файлов.

Если в публикации есть точка вставки, доступны дополнительные режимы:

  • Story. В процессе поиска просматривается весь материал, в котором установлена точка ввода. Материалом называется текст в изолированном фрейме или в цепочке связанных (см. гл. 9).
  • То End of Story. Поиск производится, от точки ввода до конца текущего материала.
  • Selected text. Поиск в пределах выделенной области. Естественно, этот переключатель доступен только при наличии выделения в материале. Если таковое имеется, то режим поиска в пределах выделения включен по умолчанию.


Регулирование процесса поиска и замены

После того как определены критерии и область поиска, становится доступной кнопка Find Next. При ее нажатии выполняется поиск в пределах области, начиная от точки ввода или начала выделения. Найденный образец отмечается в окне редактора материалов инверсным выделением. Становятся доступными следующие кнопки диалогового окна:

Change. При нажатии кнопки происходит замена образца. Произведенная замена подсвечивается. InDesign не перемещается далее по тексту, позволяя вам проконтролировать результат замены. Для возобновления поиска нужно снова нажать кнопку Find Next.

Change/find. При нажатии кнопки происходит замена найденного образца и автоматический поиск следующего объекта замены.

Change all. Это кнопка глобальной замены. При ее нажатии InDesign сразу начинает выполнять замены во всем заданном объеме текста. Как было отмечено в начале этого раздела, данная операция требует осторожности.

По окончании просмотра заданной области поиска InDesign выводит информационное окно (рис. 10.4) с отчетом о проделанной работе — количестве сделанных замен.

Рис. 10.4. Сообщение о количестве проведенных замен

Закончив работу с окном, закройте его нажатием кнопки Done (см. рис. 10.1, 10.2).

Любая замена может быть отменена

Если вы изменили решение относительно замены, отмените ее командой Undo Replace Text (или Undo Replace All Text) меню Edit. Можно отменять и серии команд замены.


Команда повторного поиска

Если атрибуты поиска не изменились, его можно выполнять и при закрытом диалоговом окне Find/Change. Для повторного поиска с атрибутами, заданными в окне поиска, используется команда Find Next (клавиатурное сокращение <Ctrl>+<Alt>+<F>). Используя ее, можно последовательно находить в тексте вхождения образца.


Серии замен

Получив текст из набора, вы обязательно будете вынуждены устранить в нем различные некорректные сочетания и привести его в соответствие с требованиями, предъявляемыми к набору в полиграфических изданиях. Так, в тексте могут встретиться тире, набранные двумя знаками "минус", отбивки, созданные вводом пустой строки, подчеркивания вместо курсива и другие ошибки, доставшиеся в наследство от набора на пишущей машинке.

Перед началом серии замен внимательно просмотрите текст, продумайте и напишите на бумаге план замены, чтобы организовать эту работу как можно успешнее. Если это возможно, заранее договоритесь с наборщиком обо всех особенностях набора.

При осуществлении глобальной замены, а особенно серии общих замен необходимо проявлять большую осторожность. Внимательно проанализируйте последовательность символов образца и замены, задайте корректную область поиска. Затем проделайте несколько отдельных замен с этими параметрами. Убедитесь, что все работает правильно. Только после этого приступайте к глобальной замене последовательности символов по всему тексту. После замены осмотрите проделанные изменения в материале — во всех ли случаях замена прошла так, как нужно? Дисциплинированный подход к системе замен позволит вам за половину рабочего дня проделать объем работы, на который без использования этого инструмента ушла бы неделя.

В зависимости от привычек наборщика исходного текстового процессора и от характера текста (научный, художественный, стихи и др.) этот план работы может очень сильно меняться. Точно определить, какие некорректные сочетания вам встретятся, не поможет ни один рецепт. Ниже приведен примерный план работы по чистке текста (в основном он применим для художественных текстов, т. е. самого простого случая верстки).

  • Устраните лишние признаки конца абзаца. В правильно оформленном тексте не может быть стоящих рядом возвратов каретки, все расстояния регулируются отбивками. Для этого введите в поле Find what код двух признаков конца абзаца ^р^р), а в поле Change to — код одного признака конца абзаца (^р). Проделайте глобальную замену. Повторяйте замену с теми же критериями до появления информационного окна (рис. 10.5). Появление этого окна означает, что повторяющихся возвратов каретки в тексте больше нет.

Рис. 10.5. Информационное окно с сообщением об отсутствии замен

  • Проделайте ту же операцию для удаления повторяющихся пробелов. К пробелам также предъявляется требование "не более одного".
  • Уничтожьте пробелы после точки в конце абзаца. Для этого в качестве образца введите сочетание признака конца абзаца и пробела (<пpoбeл>^p). Замените это сочетание на признак конца абзаца (^р).
  • Введите в публикацию типографские символы — длинные тире, дефисы и т. д.:
  1. часто при наборе длинные тире набираются двойным минусом. Замените его на типографское тире (код символа — ^_n, он есть в списке спецсимволов диалогового окна);
  2. для замены открывающих кавычек введите в поле Find what сочетание пробел" а в поле замены — пробел^. Все открывающие кавычки будут заменены. Аналогичную операцию проделайте для закрывающих кавычек. Коды открывающих и закрывающих кавычек также доступны в списке спецсимволов;
  3. если вы хотите использовать не круглые кавычки, а "елочки", как это принято в кириллическом тексте, то в качестве замены введите их коды (<Alt>+1071 и <Alt>+0187) в поле Change to;
  4. замените знаки "минус" на типографские дефисы везде, кроме математических формул. Символ дефиса имеет код ^= и тоже может быть введен из списка.
  • Теперь расставьте неделимые пробелы, они помогут вам грамотно разместить текст при верстке:
  1. так, строка не должна начинаться с тире. Поэтому замените сочетание "пробел+тире" на сочетание "тонкий пробел+тире". Такая комбинация лучше смотрится в тексте, при этом разрыв строки по тонкому пробелу не производится;
  2. если в предложении есть короткие слова, состоящие из одной-двух букв, например предлоги — К, О, На, В и др., такое слово не должно быть последним в строке. Для достижения нужного размещения выпишите все предлоги на лист бумаги и проведите серию замен — сочетание "предлог+пробел" замените на "предлог+неделимый пробел шириной в половину круглой шпации";
  3. еще одно требование относится к сочетаниям типа "1987 г.", "234 стр.", "стр. 234", "5 м", "38 лет", "тов. Иванов", "г-жа Иванова", "60 км/ч" и пр. Они не должны быть разорваны по пробелу на разные строки, тем более страницы. Для этого проанализируйте текст, найдите в нем часто встречающиеся сочетания этого типа и замените в них обычные пробелы на тонкие. Этим вы добьетесь двойного эффекта, поскольку тонкий пробел в данном случае более уместен, и строка по нему не рвется.


Проверка орфографии

Отрицать полезность программ орфографического контроля вряд ли придет кому-нибудь в голову, но зачем такая возможность введена в InDesign, куда текст попадает из внешнего текстового редактора, который чаще всего располагает такой программой? Дело в том, что не всякий наборщик пользуется этой функцией текстового редактора, да и зачастую часть текста все равно приходится набирать на стадии верстки. Не лишним шагом будет и проверка орфографии после размещения текста, т. к. при большом количестве операций перемещения фрагментов внутри материала в него могут вкрасться ошибки. После того как текст настроен в InDesign, проверка его во внешнем редакторе или передача через системный буфер обмена неминуемо приведет к утрате тонкой настройки или даже всего форматирования — следовательно, этот путь проверки, мягко говоря, нежелателен. Таким образом, наличие программы орфографического контроля внутри InDesign не только желательно, но даже необходимо.

Кроме правильности набора, для достижения грамотного внешнего вида текста исключительно важны корректные переносы. Вот этого действия верстальщику никак не избежать — ведь текст размещается по фреймам и колонкам в InDesign, а не в исходном редакторе. В главе 7 описаны методы настройки переносов. Функции проверки грамматики и установки переносов осуществляются с помощью словарей InDesign.


Словари InDesign

Словари не относятся к атрибутам абзаца. Это базы данных, содержащие общеупотребительные или специальные слова. Для каждого языка предусмотрен свой словарь, состоящий из двух частей — орфографического и словаря переносов. В зависимости от присвоенного тексту атрибута языка, активизируется соответствующий словарь. Программа пользуется словарями при автоматической расстановке переносов и проверке правописания.

Несовпадение и отсутствие атрибута языка

При несовпадении назначенного текста и реального языка текста, программы расстановки переносов и орфографии дадут непредсказуемый и, безусловно, неверный результат. Если для символа или абзаца вообще не назначать язык (установить атрибут [No Language]), то орфография не проверяется, и переносы устанавливаются только дискреционные.

Архитектура программы позволяет использовать словари сторонних производителей. Собственный комплект словарей InDesign, например, создан фирмой Proximity. Это в основном словари общего назначения для европейских языков. Русский словарь не входит в комплект программы. Словари из комплекта поставки загружаются по выбору пользователя при инсталляции программы.

Словари можно создавать

Если InDesign суждено развиваться, то неизбежно будут появляться все новые словари разных языков и специализированные. Adobe предоставляет такую возможность всем желающим — комплект программ для разработчиков дополнений (Software Development Kit) включает в себя и редактор словарей.

Как и большинство современных программ для обработки текстов, InDesign позволяет создавать пользовательские словари. Для этого предназначено диалоговое окно Dictionary (рис. 10.6), открываемое командой Edit Dictionary меню Edit.

В раскрывающемся списке Language перечислены словари, установленные на вашем компьютере. Выберите из него тот, который вы собираетесь пополнить.

Профамма записывает новые слова в две группы — Added Words и Removed Words. Первая — это собственно добавленные слова. Вторая — это слова, существующие в словаре, которые вы хотите из него изъять (по причинам, известным только вам).

Рис. 10.6. Диалоговое окно Dictionary

Переключение между этими группами производится в списке Dictionary List. В группе Added Words для всех языков уже присутствует группа слов — это названия продуктов Adobe, включенные для примера. Слова, включенные в соответствующую группу, отображаются в поле просмотра внизу окна. Вы можете добавлять собственные слова. Для этого наберите слово в поле ввода Word и нажмите кнопку Add. Для удаления уже имеющегося слова из группы выберите его в поле ввода и нажмите кнопку Remove. В добавляемом слове можно вручную ввести позиции переноса, установив курсор в нужной точке и набрав с клавиатуры знак тильды (~). Одна тильда (~) соответствует наиболее желательному переносу, две (~~) — менее желательному и т. д. На рис. 10.7 показаны позиции переноса слова "Hyphenation". Если позволяет расположение текста, InDesign перенесет слово по первой позиции, если это невозможно—по второй, а если и такой перенос неосуществим — по третьей.

Рис. 10.7. Предпочтительные позиции переноса

Если в поле Word есть слово, доступна кнопка Hyphenate. Если ее нажать, программа автоматически расставит позиции переноса в данном слове. Эти позиции имеют одинаковый приоритет и помечены двойным знаком тильды (~~). После расстановки автоматический перенос можно произвольно изменить.

Запрет переноса с помощью словаря

Предположим, в вашем тексте есть слово, которое вы не желаете переносить вообще. В этом случае откройте окно Dictionary, введите проблемное слово и поставьте знак тильды перед ним. .

Созданные пользовательские словари имеют расширение UDC. На компьютерах, работающих в операционной системе Windows 98, они располагаются по следующему адресу \WINDOWS\Local Settings\Application Data\Adobe\ InDesign\Version 1.0.

О словаре при работе в группе

При работе в группе имеет смысл создать общий пользовательский словарь, запретив индивидуально вносимые изменения.


Команда проверки орфографии

Теперь, когда вы уже представляете себе устройство языковых словарей, перейдем к обсуждению собственно процесса проверки орфографии. По команде Check Spelling меню Edit открывается одноименное диалоговое окно (рис. 10.8). Клавиатурное сокращение команды <Ctrl>+<!>.

Рис. 10.8. Диалоговое окно Check Spelling

В раскрывающемся списке Search задается зона проверки — так же, как в окне поиска и замены.

  • Document. Проверка осуществляется во всей текущей публикации.
  • All documents. Проверка всех открытых публикаций.
  • Story. Проверка всего текущего материала. Режим доступен при наличии точки ввода.
  • То End of Story. Поиск от точки ввода до конца текущего материала.
  • Selected text. Проверка в пределах выделенной области. Этот переключатель доступен только при наличии выделения в материале.

Над списком области проверки расположена информационная строка, в которой указан язык. Если в публикации нет текстового выделения или точки вставки, то это язык по умолчанию. Если точка ввода есть, то отображается язык, заданный в ней. По мере проверки многоязычного текста программа автоматически активизирует соответствующий языковой словарь, что отражается в информационной строке.

При отсутствии выделения проверка правописания начинается с положения курсора в тексте, что позволяет в любой момент ее прервать и продолжить с этого же места. Поскольку диалог Spell Checking не является модальным (не требует закрытия для перехода к другим окнам приложения), можно перейти из него в окно редактора материалов. При этом проверка орфографии прерывается, и вы можете внести любые коррективы непосредственно в редакторе материалов. Для того чтобы продолжить прерванную операцию проверки орфографии, надо установить курсор на последнее проверенное слово, перейти в окно проверки орфографии и снова нажать кнопку Start.

Установив зону проверки, приступите к проверке орфографии нажатием кнопки Start. Программа просматривает материал и находит первое отсутствующее в словаре слово. Она отображает это слово в строке Not in Dictionary диалогового окна, а в публикации неизвестное слово выделяет подсветкой. Программа предлагает замены для неизвестного слова в поле Suggested Corrections. Первое из предлагаемых слов помещается в поле ввода Change to. Выберите нужное слово для замены из списка Suggested Corrections или наберите его в поле Change to с клавиатуры. После установки замены нажмите кнопку Replace, и замена будет осуществлена.

Для перехода к следующему слову без исправления текущего нажмите кнопку Ignore (она заменяет кнопку Start после начала проверки). Игнорировав отсутствующее в словаре слово для всей текущей области проверки кнопкой Ignore All, вы тем самым запрещаете программе проверки орфографии останавливаться и на других вхождениях этого слова в данной области. Игнорировать слово этой командой следует в случае, если вы уверены в правильности его написания, но не рассчитываете его встретить в других публикациях (т. е. заносить его в словарь не стоит). Такими словами могут быть, например, редкие термины и фамилии.

Удвоения слов

Кроме собственно сличения слов публикации со словарем, при проверке производится отслеживание удвоений. Под удвоениями понимаются два одинаковых слова, стоящие непосредственно друг за другом. Эта ошибка часто возникает при наборе текста.

Кроме исправления и игнорирования слова, существует и третья возможность — внесение слова в словарь. Нажмите кнопку Add, и перед вами откроется диалоговое окно редактирования словаря, в которое можно внести слово обычным способом. После редактирования словаря нажмите кнопку Done. Окно словаря будет закрыто, и активным снова станет окно проверки орфографии.


Резюме

В настоящей главе обсуждаются примеры работы с текстовым материалом в рамках InDesign:

  • -После импорта текста из редактора в программу верстки практически всегда возникает необходимость проверки орфографии.
  • InDesign предлагает проверку орфографии с использованием языковых словарей, автоматически подключаемых в процессе проверки. Подключаемый словарь определяется установками языка набора, заданными для символов текста.
  • Для каждого языка предусмотрен собственный словарь. Он включает в себя собственно орфографический словарь и словарь переносов, применяемый при автоматической расстановке переносов для размещаемого текста. Словари можно свободно дополнять, дополнения хранятся в специальных пользовательских словарях.
  • Мощным средством обработки текста является диалоговое окно поиска и замены. Возможность задания образца и заменяющей подстроки, произвольных атрибутов для них, в том числе стилей, ввода в поля поиска и замены специальных символов — все это позволяет использовать команды поиска и замены для глобальной обработки текста — назначения стилей, удаления нежелательных вхождений текста, ввода специальных полиграфических символов и пр.


Глава 11

Рисование средствами InDesiqn

Если вы знакомы с программами объектной графики, в этой главе вы найдете мало новой информации. Как и в объектных программах, рисование в InDesign заключается в создании контуров. Контуры, в отличие от пикселов растрового изображения, сами по себе лишены толщины и цвета (практически, это просто математические формулы). Чтобы контур стал видимым, ему задают обводку определенной толщины и типа, а также заливку — заполнение цветом его внутренней области. Иллюстрация складывается из контуров, как дом из кирпичей (или компьютер из комплектующих). В этой главе мы рассмотрим следующее:

  • Типы контуров, основные определения
  • Опорные точки и сегменты
  • Полное и частичное выделение
  • Редактирование формы контура
  • Преобразования точек
  • Разрезание, дополнение и замыкание контуров
  • Удаление контуров и сегментов
  • Графические примитивы
  • Операции с объектами — перемещение и трансформации

Все операции, описанные в этом разделе, применимы к любым .контурам, в том числе и фреймам — текстовым и графическим. В InDesign контуры унифицированы, что очень удобно.


Определение контуров

Подобно математическим объектам, контуры, создаваемые в программе, сами по себе не имеют толщины. Ему можно придать обводку определенной толщины, стиля и цвета, тогда контур станет виден на экране. Различают два вида контуров — линии (незамкнутые контуры), и фигуры (замкнутые контуры). Характер заливки для фигур и линий различен. Фигуры заполняются заливкой по контуру, заливка линий осуществляется так, словно начальная и конечная точки линии соединены прямой линией.

В рамках InDesign контуры могут быть построены двумя путями:

  • Инструменты группы Pen создают опорные точки и определяют форму сегментов. Эти способом можно построить произвольные контуры с большой точностью.
  • Линии и фигуры предопределенной формы (прямые, прямоугольники, многоугольники, эллипсы) строятся с помощью специальных инструментов — Line, Rectangle, Polygon и Ellipse.


Точки и сегменты

Контуры состоят из опорных точек, или узлов, соединенных между собой сегментами. Если сегменты являются отрезками прямых (рис. 11.1), то форма контура определяется только положением опорных точек.

Рис. 11.1. Прямолинейный контур

В общем случае сегменты контура могут иметь любую форму. Тогда для описания формы недостаточно только задать положение опорных точек — ведь их можно соединить кривыми различной формы (рис. 11.2).

Кроме опорных точек, форму контура задают управляющие линии. Это отрезки касательных в каждой из опорных точек, длина и направление которых определяет форму сегмента. Опорная точка может иметь одну или две управляющих линии. В InDesign различают два типа точек:

  • Гладкая. Точка, имеющая две управляющие линии. Они обязательно находятся на одной прямой и направлены в противоположные стороны от точки. Перемещение одной из них вызовет и перемещение второй, образуя гладкий изгиб (рис. 11.3).

Рис. 11.2. Опорные точки соединены сегментами разной формы

а [image] б

Рис. 11.3. Гладкая точка

а [image] б

в

Рис. 11.4. Угловые точки

  • Угловая. Точка, в которой может образоваться угол. Она может вовсе не иметь управляющих линии, иметь только одну или две. Если у угловой точки две управляющих линии, они могут находиться под любым углом другу к другу (рис. 11.4). Перемещение одной управляющей линии никак не скажется на второй (рис. 11.5).

а [image] б

Рис. 11.5. Перемещение управляющих линий угловой точки


Построение контуров, имеющих точки различного типа

Для построения контуров всех типов используется инструмент Pen (клавиши <Ctrl>+<P>). Контур можно построить как на странице документа, так и на рабочем столе. После построения контуру присваивается заливка и обводка, определенные в палитре Toolbox.

Построение контуров всех типов начинается с определения первой точки щелчком в окне документа. Для построения прямолинейного контура после щелчка отпустите кнопку мыши. Щелчком кнопки мыши задайте следующую точку (рис. 11.6). Таким образом постройте весь контур. Он состоит из точек без управляющих линий.

Действие клавиши <Shift>

Клавиша <Shift> обладает универсальным действием на команды перемещения, ограничивая их фиксированными значениями смещения и углов поворота. Так, если удерживать нажатой эту клавишу при определении опорных точек, то они будут располагаться по вертикали, по горизонтали или под углом 45° друг к другу.

а [image] б [image] в

Рис. 11.6. Построение прямолинейного контура

Для построения криволинейного контура после первого щелчка не отпускайте кнопку мыши. Протащите курсор в сторону от точки. Из опорной точки будут вытянуть! управляющие линии. Установите следующую точку и также вытяните из нее направляющие. Обратите внимание, что каждый раз вы определяете управляющую линию для следующего сегмента, управляющая для текущего сегмента строится автоматически. В зависимости от направления, в котором вы вытягиваете линии, может получиться U-образный или S-образный сегмент разной формы (рис. 11.7). Таким образом определяется гладкая точка. Если при вытягивании управляющих линий держать нажатой клавишу <Shift>, то их направление будет ограничено фиксированными углами.

а [image] б [image] в

Рис. 11.7. Построение криволинейного контура

а [image] б [image] в

Рис. 11.8. Построение контура с угловой точкой

Также просто установить угловую точку и с двумя управляющими линиями. Такая точка соединяет два криволинейных сегмента под углом. Постройте первую точку, вытянув из нее управляющие линии (гладкая точка). Постройте вторую точку и вытяните управляющие из нее. Затем нажмите клавишу <Alt> и перетащите одну из управляющих линий активной точки. Управляющие стали независимыми — создана угловая точка. Постройте еще один сегмент — между созданными сегментами образовался угол (рис. 11.8).

При построении контура может потребоваться чередование сегментов разной формы — прямых и криволинейных. Для этого применяют угловые точки с одной управляющей линией. Например, чтобы построить пару сегментов, первый из которых прямой, а второй криволинейный (рис. 11.9), установите первую точку, не вытягивая из нее линий. Поставьте вторую точку. Отпустите кнопку мыши, затем снова нажмите ее и вытяните из второй точки управляющую. Она будет единственной и определять форму сегмента, следующего за данным. Постройте очередной сегмент — он будет представлять собой кривую, а предыдущий останется прямым.

а [image] б [image] в

Рис. 11.9. Чередование прямого и изогнутого сегмента при создании контура

а [image] б [image] в

Рис. 11.10. Чередование изогнутого и прямого сегмента при создании контура

Обратная операция аналогична. Нарисуйте сначала изогнутый сегмент. Установив вторую точку, отпустите кнопку мыши, а затем снова щелкните на созданной точке. Этим вы удалили управляющую линию, определяющую форму последующего сегмента. Создайте еще одну точку, (управляющие не вытягивайте) и убедитесь, что сегмент прямой (рис. 11.10).


Два инструмента выделения

Как вы уже знаете, любая объектная программа оперирует с выделенными (т. е. активными) объектами. InDesign предлагает два инструмента выделения. С помощью инструмента Selection выделяют объект целиком. При этом вокруг объекта появляется прямоугольник, отмечающий его геометрические размеры и угол наклона (рис. 11.11). Любая операция при таком способе выделения затронет весь объект. Этот способ выделения необходим при трансформировании. Некоторые операции, например масштабирование и перемещение, можно совершать непосредственно с помощью инструмента Selection, используя габаритные прямоугольники. Кроме того, при выделении таким способом сложные объекты (группы и фреймы с вложенной графикой) выделяются как единое целое, и при трансформациях все части такого объекта изменяются пропорционально.

Рис. 11.11. Габаритные прямоугольники объектов

Инструмент Direct Selection незаменим для выделения частей объекта — отдельных опорных точек, элементов групп и фреймов. При выделении с помощью этого инструмента становятся видны опорные точки объекта в виде белых квадратиков (рис. 11.12). Например, при щелчке на границе графического фрейма будет выделен фрейм, а в его центре — само изображение. Таким образом вы сможете независимо менять их атрибуты (например, цвет или размер).

Рис. 11.12. Выделение объектов с помощью инструмента Direct Selection

Можно выделить только одну опорную точку. Она примет вид заполненного квадрата и будут показаны управляющие линии обоих сегментов, сходящихся в этой точке (рис. 11.13).

Рис. 11.13. Выделение одной опорной точки инструментом Direct Selection

Объекты без заливки — особенность выделения

При любом способе важно отметить особенность действия инструментов выделения на контуры, лишенные заливки. Программа считает, что внутри этих контуров действительно ничего нет. Поэтому выделять их следует щелчком на контуре. При выделении фреймов они считаются заполненными в любом случае.


Редактирование точек и сегментов

Положение концов сегмента описывается положением его опорных точек. Форма определяется управляющими линиями. В зависимости от типа точек, линий этих может быть две, одна, или не быть вовсе, если сегмент линейный. Ясно, каким образом можно изменить форму контура: во-первых, смещением опорных точек, во-вторых, изменением длины и наклона управляющих линий, и наконец, изменением типа точки.

Когда вы немного потренируетесь в построении контуров, вы сможете легко предсказать, как изменится форма сегмента при коррекции управляющих линий. Ниже приведен ряд самых общих замечаний.

  • Изгиб сегмента направлен в сторону управляющей линии. Чем она длиннее, тем больше радиус изгиба.
  • S-образный сегмент имеет управляющие линии, расположенные с разных сторон, U-образный — с одной стороны от линии контура.
  • Изменение направления управляющей линии гладкой точки вызывает противоположное смещение второй управляющей линии. В результате искажается форма обоих сегментов, сходящихся в данной точке.
  • Направление управляющей линии угловой точки не влияет на вторую управляющую.
  • Изменение длины управляющей линии любой точки не влияет на длину второй управляющей линии.
  • Точки можно преобразовать из одного типа в другой. В одном контуре могут встречаться точки любого типа.


Продолжение и замыкание контуров

Существующий контур можно удлинить или замкнуть. Из двух маленьких контуров можно создать один большой, соединив их между собой. Все эти операции производятся инструментом Pen. Для продолжения контура подведите курсор к нужной концевой точке (при этом контур можно и не выделять). Когда рядом со значком пера появится горизонтальный отрезок, значит программа распознала концевую точку контура и готова этот контур продолжить. Щелкните на найденной точке и создавайте следующую опорную точку (рис. 11.14). Если вы хотите создать прямолинейный сегмент, то не вытягивайте управляющую линию из первой точки.

а [image] б [image] в

Рис. 11.14. Продолжение контура

Замыкание может понадобиться как при построении нового контура, так и для уже существующего. Для замыкания контура при построении следует подвести курсор к его начальной точке. Рядом с курсором должен появиться кружок. Щелкните на начальной точке, и контур будет замкнут (рис. 11.15).

Замыкание уже существующего контура проводят точно так же. Только сначала нужно выбрать инструментом Pen одну из концевых точек.

Очень похожим образом связывают отдельные контуры в один. Подведите курсор инструмента Pen к концевой точке одного из контуров, щелкните и подведите курсор к концевой точке другого контура. Курсор принимает вид, показанный на рис. 11.16. При щелчке на точке контуры будут связаны в один. Разумеется, в процессе связывания и замыкания вы можете нарисовать между точками любое количество сегментов.

а [image] б

Рис. 11.15. Замыкание контура

а [image] б [image] в

Рис. 11.16. Связывание контуров


Размыкание контуров

Для того чтобы превратить замкнутый контур в открытый, а также для разрезания большого контура на более мелкие, применяется инструмент Scissors. Просто подведите курсор инструмента к контуру (контур можно не выделять). Когда курсор примет вид "прицела", InDesign готов резать контур. Щелкните на контуре и он будет разрезан в точке щелчка (рис. 11.17). Образуются две концевых точки, которые можно перемещать независимо. Если контур был незамкнут, выделите части любым инструментом выделения и убедитесь, что получились совершенно независимые линии.

а [image] б

Рис. 11.17. Размыкание контура


Изменение формы контура

InDesign позволяет выделять опорные точки контуров инструментом Direct Selection только по одной. Выделенная точка принимает вид заполненного квадрата, кроме того, становятся видны все управляющие линии сегментов, сходящихся в ней.

а [image] б

Рис. 11.18. Редактирование управляющей линии

Изменение формы контура по точками проводится двумя путями. Вопервых, точку можно смещать, перетаскивая ее курсором (рис. 11.18). Вовторых, можно смещать управляющие линии, меняя их длину и направление. Для этого нужно подвести курсор к точке на конце линии ("рычагу") и перетащить ее (рис. 11.19). И та и другая операции одинаково часто используются для коррекции формы контура.

а [image] б

Рис. 11.19. Перемещение опорной точки


Изменение типа точки

Коррекция формы контуров путем смещения точек и изменения формы сегментов далеко не всегда приведет к положительному результату. Если, например, в данном месте контура необходим угол, а опорная точка гладкая, то угла вы не получите такими способами. Бывает необходимо преобразовать криволинейный сегмент в отрезок прямой и наоборот. В группе Pen есть инструмент Convert Direction Point. Именно он и используется для изменения типа опорной точки. Инструмент Convert Direction Point может работать только с выделенным контуром. При щелчке на любой опорной точке контура этим инструментом управляющие линии контура уничтожаются (рис. 11.20). Так получается точка без управляющих линий.

Тем же инструментом легко вытянуть из угловой точки управляющие линии, она станет гладкой (рис. 11.21).

Управляющие линии гладкой точки лежат на одной прямой. Чтобы перевести точку в угловую, их можно сместить относительно друг друга только инструментом Convert Direction Point. Так получается угловая точка с двумя управляющими линиями (рис. 11.22). Если одну из управляющих линий сместить так, что ее конец совпадет с опорной точкой, то управляющая исчезнет. Таким образом получают угловую опорную точку с одной управляющей линией.

а [image] б [image] в

Рис. 11.20. Перевод гладкой точки в угловую

а [image] б [image] в

Рис. 11.21. Перевод угловой точки в гладкую

а [image] б [image] в

Рис. 11.22. Создание угловой точки с управляющими линями


Удаление и добавление точек на контуре

Для уточнения формы контура часто приходится удалять лишние опорные точки или добавлять недостающие. Специальные инструменты группы Pen (Delete Anchor Point и Add Anchor Point) позволяют удалять и добавлять опорные точки на контуре.

а [image] б

Рис. 11.23. Добавление опорной точки

Для добавления точки активизируйте инструмент Add Anchor Point (его курсор имеет вид пера со значком "плюс"). Подведите его к объекту и щелкните точно на контуре. Появилась новая опорная точка с управляющими линиями (рис. 11.23). Форма контура при этом не изменяется — управляющие линии располагаются так, чтобы ее сохранить.

Для удаления существующей опорной точки выберите инструмент Delete Anchor Point. Его курсор имеет вид пера со знаком "минус". При щелчке инструментом на опорной точке она исчезает (рис. 11.24), управляющие линии оставшихся точек не смещаются, поэтому форма контура в результате удаления всего одной точки может кардинально измениться. Если удалить концевую точку, она исчезнет вместе с сегментом.

а [image] б

Рис. 11.24. Удаление опорной точки

Работать с этими инструментами удобнее при выделенном контуре, тогда вы можете более точно позиционировать курсор. Однако это необязательно. Выберите инструмент Add Anchor Point и щелкните в нужном месте сегмента неактивного контура. Контур немедленно будет выделен и в нем добавлена опорная точка. Точно так же действует и инструмент Delete Anchor Point.

Оба инструмента по умолчанию выбираются автоматически при активном инструменте Реп. Достаточно подвести курсор инструмента Pen к сегменту выделенного контура (не к опорной точке), и он изменит вид на перо со знаком "плюс" — активным станет инструмент Add Anchor Point. После щелчка им на контуре добавится опорная точка. Если подвести курсор инструмента Pen к опорной точке на выделенном контуре, активным станет инструмент Delete Anchor Point, щелчок им на точке удалит ее.

Отмена автоматического переключения

Для того чтобы отменить автоматическое переключение на время конкретной операции, удерживайте во время создания точки клавишу <Shift>. Тогда созданная точка будет принадлежать новому контуру, а не выделенному. Чтобы эта функция не затрагивала создаваемые управляющие линии точки, отпускайте клавишу <Shift> раньше, чем левую клавишу мыши.


Построение фигур

Используя инструмент Pen, вы можете построить контур любой формы:

правильный и неправильный. Однако для создания самых простых и часто используемых фигур предусмотрены особые инструменты. Этот раздел посвящен построению фигур с помощью специальных инструментов InDesign. В отличие от некоторых других программ, InDesign не предоставляет таким фигурам особых свойств. После построения они превращаются в самые обычные контуры.


Прямые

Инструмент Line предназначен исключительно для построения прямых линий. Чтобы создать линию этим инструментом, нажмите кнопку мыши (этим вы определите начальную точку) и перетаскивайте курсор. Линия тянется следом. Когда вы отпустите кнопку мыши, прямая будет построена. С помощью инструмента Line невозможно продолжать и замыкать контуры. Однако созданная линия является обычным прямым сегментом и легко может быть изменена с помощью других инструментов преобразования контуров.


Прямоугольники и эллипсы — фигуры и фреймы

Для построения прямоугольника и прямоугольного фрейма используются инструменты Rectangle и Rectangle Frame. Эллипсы и эллиптические фреймы создаются инструментами Ellipse и Ellipse Frame. Приемы построения всех этих фигур аналогичны. Сначала нужно выбрать соответствующий инструмент. Интерактивное создание прямоугольника и эллипса начинается со щелчка мышью в рабочей области документа. Затем, не отпуская кнопку мыши, протащите курсор инструмента по диагонали. Курсор задает размеры невидимого габаритного прямоугольника, в который вписана создаваемая фигура (рис. 11.25). Когда вы отпустите кнопку мыши, фигура будет создана. Если при построении нажать клавишу <Shift>, то будет создан квадрат или круг.

Если последним активным инструментом выделения был Selection, то полученная фигура выделена габаритным прямоугольником. Если последним был активен инструмент Direct Selection, будут видны опорные точки фигуры.

Рис. 11.25. Построение прямоугольника и эллипса

Фреймы — графические и текстовые — почти ничем не отличаются по свойствам от фигур, хотя в выделенном состоянии несколько отличаются внешне. На практике, разница между ними принципиальна только при автоматическом размещении текста. Об этом полезном свойстве текстовых фреймов пойдет речь в главе 13. Для перехода между фигурой, графическим и текстовым фреймом используется команда-переключатель Content. Она доступна из меню Object и из контекстного меню при выделенном объекте. Существующему пустому фрейму или фигуре можно определить произвольный характер "наполнения" — Text (образуется текстовый фрейм). Graphic (фрейм становится графическим) или Unassigned (выделенный объект становится фигурой). Для заполненных фреймов эта процедура невозможна. Однако в любом случае и фрейм, и фигуру можно редактировать по точкам, придавать обводки и заливки, размыкать и замыкать и пр.


Многоугольники и звезды — фреймы и фигуры

Инструменты Polygon и Polygon Frame предназначены для рисования многоугольников и звезд с произвольным числом лучей, сторон и глубиной лучей. Разумно перед началом построения определить свойства объекта, который необходимо построить. Для этого двойным щелчком на инструменте Polygon или Polygon Frame откройте окно свойств инструмента (рис. 11.26). В этом окне есть поле Number of Sides, где задается число сторон будущего многоугольника (или лучей звезды). Глубина лучей определяется в поле Star Inset в процентах. Если глубина лучей равна 0, то будет создан многоугольник. Если значение Star Inset равно 50%, то созданная звезда имеет лучи, внутренние точки которых наполовину ближе к центру, чем внешние (рис. 11.27). Чем больше значение Star Inset, тем острее лучи звезды.

Рис. 11.26. Диалоговое окно свойств многоугольника

Рис. 11.27. Значение Star Inset: a — 10%, б — 40%, в — 90%

После задания параметров следует закрыть диалоговое окно, нажав кнопку ОК. Теперь программа будет строить фигуры с заданными параметрами до тех пор, пока вы не измените установки. Установки распространяются на оба инструмента — Polygon и Polygon Frame — вне зависимости от того, какому из них были заданы. Заметьте, что изменение параметров никак не влияет на уже существующие фигуры.

Сам процесс построения многоугольника или звезды не отличается от построения прямоугольника или эллипса. После щелчка, не отпуская кнопку мыши, протащите курсор инструмента по диагонали, обозначая прямоугольник, в который вписывается создаваемый объект. Когда вы отпустите кнопку мыши, фигура будет создана (рис. 11.28). Если при построении нажать клавишу <Shift>, InDesign создает правильные многоугольники и звезды.

а [image] б

Рис. 11.28. Построение многоугольника и звезды


Порядок наложения объектов

При построении и перемещении объектов может случиться так, что два или несколько объектов окажутся на одном участке страницы (монтажного стола). Объекты при этом перекрывают друг друга. Какие-то из них оказываются на поверхности, а какие-то — под ними. Всю страницу можно рассматривать как "стопку", в которой вышележащие объекты частично или полностью закрывают нижележащие. Порядок наложения объектов подчиняется простым правилам, перечисленным ниже.

  • Каждый объект на развороте (страницы и монтажный стол) занимает отдельный уровень. Все объекты на каждом развороте собраны в воображаемую стопку.
  • Чем раньше нарисован объект, тем ниже в этой стопке он расположен. При перекрывании объекты, созданные позже, перекрывают более старые.
  • При вклеивании вырезанных или скопированных объектов они помещаются поверх других, т. е. считаются самыми "свежими". Исключение составляют команды специального вклеивания.
  • При перемещении, наклоне, и других трансформациях в пределах разворота объект остается на том же уровне в стопке.
  • При копировании, перетаскивании на другой разворот, дублировании объектов инструментами трансформации объект или его копия помещается на самый верхний уровень.

Объекты далеко не всегда создаются в том порядке, в котором должны быть расположены на странице. Для изменения порядка следования объектов воспользуйтесь командами подменю Arrange меню Object. Команды Bring Forward и Put Backward перемещают объект, в стопке на один уровень вверх и вниз соответственно (рис. 11.29).

а [image] б

в

Рис. 11.29. Команды Bring Forward и Put Backward

Команды Bring to Front и Put to Back помещают объекты впереди и позади всех объектов (рис. 11.30). Перед тем как выбрать одну из этих команд, перемещаемый объект следует выделить. Одновременно можно перемещать один или несколько объектов. При этом выделенные объекты останутся на том же уровне относительно друг друга.

Поскольку описанные команды используются часто, для них удобно применять клавиатурные комбинации: <Ctrl>+<Shift>+<]> (Bring to Front). <Ctrl>+<Shift>+<[> (Put to Back), <Ctrl>+<]> (Bring Forward) и <Ctrl> +<[> (Put Backward).

В результате наложения одни объекты могут быть частично или практически полностью скрыты под другими. Выделить такой "закопанный" объект — непростая задача. На помощь приходит простое клавиатурное сокращение. При нажатой клавише <Ctrl> первым щелчком кнопкой мыши на верхнем объекте вы выделите его, вторым — объект под курсором, расположенны: ниже, третьим ~ еще ниже и т. д. Таким образом легко выделить даже самые нижние объекты. Эта функция пригодится и для выделения полностью скрытых объектов — их лучше удалять из публикации, чтобы не увеличивать число объектов без необходимости.

а [image] б

в

Рис. 11.30. Команды Bring to Front и Put to Back


Трансформации контуров

Возможности InDesign в области трансформации контуров сравнимы с возможностями настоящей программы векторной графики. Вы можете произвольно перемещать, вращать, наклонять и масштабировать объекты.


Перемещение объектов

Перемещение объектов производится разными способами. Во-первых, можно перетаскивать объект инструментом Selection или Direct Selection. Для этого поместите курсор во внутреннюю область объекта и перетаскивайте его при нажатой кнопке мыши.

Для точного перемещения выделенного объекта удобно пользоваться клавишами управления курсором. Нажатие каждой из них смещает объект на величину шага, указанного в поле Cursor Key вкладки General диалогового окна Preferences. Если при этом держать нажатой клавишу <Shift>, то смещение происходит на десять шагов при каждом нажатии. Вы можете произвольно менять шаг, вводя его величину в поле Cursor Key окна установок.

Разумеется, объекты можно переносить и копировать через буфер обмена. Этот прием чаще всего применяется для переноса объекта с одной страницы на другую.

При любых операциях трансформирования можно одновременно дублировать объект. Для этого нажмите и удерживайте клавишу <Alt> уже после того, как вы начали трансформирование (в данном случае — перемещение объекта). Вид курсора изменится на двойную стрелку. Переместите объект, отпустите кнопку мыши и лишь затем — клавишу <Alt>. Объект останется на прежнем месте, а его точная копия будет перенесена.


Масштабирование объектов

Масштабирование фигур и фреймов имеет несколько более сложный алгоритм. В зависимости от установок и использованного инструмента вы получите разный результат. Для масштабирования применяется инструмент Selection. С его помощью можно изменять вертикальный, горизонтальный размер или оба размера одновременно. Масштабирование производится с использованием манипуляторов габаритного прямоугольника.

Для масштабирования только в одном измерении подведите курсор к боковому манипулятору и перетащите курсор. Следуя за курсором, меняется ширина или высота габаритного прямоугольника и объекта (рис. 11.31).

а [image] б

в

Рис. 11.31. Масштабирование с использованием бокового манипулятора

а [image] б

в

Рис. 11.32. Масштабирование с использованием углового манипулятора

Перетаскивание углового манипулятора изменяет одновременно и ширину и высоту объекта (рис. 11.32). Если при масштабировании держать нажатой клавишу <Shift>, то при перетаскивании любого из манипуляторов происходит пропорциональное масштабирование объекта.

При масштабировании с помощью инструмента Selection не происходит изменений атрибутов текста (не изменяется внешний вид символов, межстрочное расстояние и пр.), текст просто перераспределяется. Если объект имеет градиентную заливку, то длина градиента меняется в зависимости от масштабирования, однако его форма не меняется (так даже при непропорциональном масштабировании радиальный градиент остается круглым, не превращаясь в эллипс). После масштабирования данные о первоначальном размере не сохраняются.

При изменении размеров графического фрейма масштабируется только фрейм. Вложенная графика размера не меняет. Однако, если при масштабировании держать нажатой клавишу <Ctrl>, тогда изображение масштабируется вместе с фреймом. Если нажать еще и <Shift>, то масштабирование происходит пропорционально.

Если объект, который вы масштабируете, имеет обводку, ее толщина остается одинаковой по всему контуру, даже если масштабирование непропорционально. Толщина обводки не изменяется. Дублирование при масштабировании этим способом не производится.

Точка, относительно которой производится трансформация, называется центром трансформации. В случае масштабирования инструментом Selection таким центром является противоположный манипулятор.

Для масштабирования специально предназначен инструмент Scale. Когда он активизирован, становится виден центр трансформации. Объект при этом окружен габаритным прямоугольником или видны его опорные точки, в зависимости от того, каким инструментом объект был выделен. Центр трансформации по умолчанию располагается в верхнем левом углу габаритного прямоугольника объекта. Перетаскивая курсор, вы изменяете размеры объекта относительно центра трансформации. Его можно смещать, для чего нужно поместить курсор точно на центр трансформации и перетащить его в нужную точку. В зависимости от выбора центра, масштабирование происходит по-разному (рис. 11.33).

а [image] б

в [image] г

Рис. 11.33. Масштабирование инструментом Scale

С помощью инструмента Scale масштабируются все части объекта. Например, текст внутри фрейма увеличивается и уменьшается вместе с фреймом. но не перераспределяется, причем все атрибуты в палитрах Character и Paragraph остаются прежними, а в палитре Transform (рис. 11.34) отображается коэффициент масштабирования. Следовательно, если пропорционально увеличить в два раза фрейм, содержащий текст 12-го кегля, он сохранит кегль, но будет считаться масштабированным на 200% по обеим осям. Подробно палитра Transform описана в главе 16.

а [image] б [image] в

Рис. 11.34. Масштабирование текста

Обводка и заливка также масштабируются вместе с объектом, причем могут быть отмасштабированы непропорционально (рис. 11.35).

а [image] б [image] в

Рис. 11.35. Масштабируются заливка и обводка

Наконец, изображения, находящиеся во фреймах (рис. 11.36), масштабируются вместе с фреймами (только внедренные изображения). Коэффициент масштабирования и первоначальные размеры объекта сохраняются в палитре Transform и к ним в любой момент можно вернуться. Для этого достаточно ввести значение 100% в поля размеров палитры Transform. На масштабирование данным способом оказывает влияние нажатие клавиши <Shift> (масштабирование становится пропорциональным). Если при масштабировании держать нажатой клавишу <Alt>, то объект дублируется: копия подвергается трансформации, а исходный объект остается неизменным. Точно так же можно дублировать объект при любой трансформации.

а [image] б

в

Рис. 11.36. Масштабирование изображения в графическом фрейме


Отражение объектов

Частым случаем масштабирования можно считать отражение объектов. Оно выполняется как инструментом Selection, так и инструментом Scale. Технология одинакова — если перетащить курсор на другую сторону от центра трансформации, объект будет отражен (рис. II.37). При отражении действуют те же правила, что и при масштабировании. Есть два исключения — текст и изображения превращаются в зеркальные при любом методе отражения, но при этом не масштабируются, если отражать их инструментом Selection.

а

б [image] в

г

Рис. 11.37. Отражение объектов инструментами Selection и Sc ale


Вращение объектов

Для вращения используется инструмент Rotate. Он действует аналогично инструменту Scale. Когда он активен, виден центр трансформации, относительно которого и производится вращение: просто перетаскивайте курсор, объект поворачивается следом. Центр трансформации можно произвольно менять (рис. 11.38).

а [image] б [image] в

Рис. 11.38. Вращение объектов

При действии инструмента изменяется положение всех элементов объекта, в том числе заливок, текста и изображений во фреймах. Сведения об исходном положении объектов также сохраняются в палитре Transform. При нажатой клавише <Alt> объект дублируется, его копия поворачивается, а исходный объект не изменяется.


Наклон объектов

Еще один инструмент трансформации предназначен для наклона, или перекашивания объектов (рис. 11.39). Это инструмент Shear, он расположен в группе Scale. Наклон объектом производится так же, как вращение. Выбранный объект при активизации инструмента получает центр трансформации, который можно произвольно смещать. Наклон объекта совершается относительно этого центра. Направление и степень наклона регулируется смещением курсора. Данные об этой трансформации также сохраняются в палитре Transform. При наклоне также можно производить дублирование объектов.

а [image] б

в

Рис. 11.39. Наклон объектов


Трансформация нескольких объектов

Инструменты трансформации могут воздействовать сразу на несколько объектов, если их выделить одновременно. Пример подобных трансформаций вы видите на рис. 11.40.

а [image] б

в [image] г

Рис. 11.40. Трансформация нескольких объектов

Инструмент Selection не предназначен для работы с несколькими объектами одновременно. Если выделить им несколько объектов и попробовать, например, начать масштабирование, изменяется размер только одного из объектов.


Действие трансформаций на вводимый текст и графику

Поскольку все операции, выполняемые инструментами Rotate, Scale и Shear, запоминаются программой, они будут действовать и на вновь вводимый текст и импортируемую графику. Если, например, повернуть фигуру на 60°, а затем разместить в ней текст, то он будет располагаться под этим углом. Это же относится к масштабированию (только инструментом Scale) и к наклону объектов.


Атрибуты контуров

InDesign предполагает у контуров два основных свойства — цвет заливки и обводка. От цвета, толщины, а также других характеристик заливки и обводки зависит внешний вид контура.

Контур может иметь сплошную и градиентную обводку и заливку. Цвет и оттенок сплошной заливки можно регулировать. Для градиентной обводки и заливки устанавливаются цвета, оттенки, положение переходов цвета, тип градиента (радиальный и линейный). Линейному градиенту можно определить направление, положение и длину вектора, у радиального меняется длина градиента и размещение центра градиента. Заливка и обводка выделенного контура отображаются в нижней части палитры Toolbox. Градиентные заливки и обводки редактируются в специальной палитре Gradient, a сплошные — в палитрах Swatches и Color. Как обводкам, так и заливкам можно назначать сплошные цвета и градиенты. О выборе и редактировании цветов для обводок и заливок можно прочитать в главе 2.

Кроме цвета обводки, InDesign позволяет регулировать, толщину линий, сопряжение, расположение обводки относительно объекта и другие атрибуты. Кроме того, линии могут получать окончания в виде стрелок различного типа, и им по желанию назначается пунктирное начертание и обрабатываются углы. Задается также направление линий обводки, что важно при построении комбинированных контуров. Работа с атрибутами обводок, кроме уже известных вам палитр Swatches, Color, Toolbox, производится в палитре Stroke и при помощи команд.

Толщина, сопряжение сегментов, форма окончаний линии обводки и наличие пунктира задаются в палитре Stroke (рис. 11.41). Она вызывается на экран командой Show Stroke меню View.

а [image] б

Рис. 11.41. Палитра Stroke: а—в режиме Hide Options, б—в режиме Show Optionsn

Атрибуты и соединение контуров

При соединении контуры наследуют атрибуты того контура, который был присоединен последним. Это касается направления, заливки и всех свойств обводки.


Регулировка толщины

Толщину линий обводки можно указать в поле ввода Weight. Значение отображается в пунктах при любой выбранной пользователем общей единице измерения. Как и атрибуты символов, для толщины линий пункт — традиционная единица измерения. Щелкая на маленьких стрелках слева от поля ввода, можно быстро уменьшать и увеличивать значение, с шагом равным одному пункту. Треугольная стрелка открывает список наиболее часто используемых величин.

При наличии у объекта достаточно толстой обводки становится принципиальным, по какому правилу она строится вокруг контура. Если объект выделен инструментом Selection и вокруг него отображен габаритный прямоугольник, обводка располагается внутри габаритного прямоугольника. При выделении инструментом Direct Selection линия контура делит обводку пополам, если видны опорные точки. Половина толщины обводки располагается по одну сторону линии контура, половина — по другую (рис. 11.42).

а [image] б

Рис. 11.42. Расположение обводки относительно габаритного прямоугольника и относительно контура

В других программах объектной графики изменение толщины обводки влечет за собой изменение общих размеров объекта. Это естественно, но не всегда удобно. InDesign предлагает интересный режим, при котором габаритный прямоугольник (т. е. суммарный размер объекта) остается неизменным, какую бы толщину обводки вы ни задавали. Для задания неизменного размера габаритного прямоугольника снимите флажок Weight Changes Bounding Box, расположенный в меню палитры Stroke. Установленный флажок активизирует режим, переменного габаритного прямоугольника. В первом случае при смене толщины обводки неизмененным остается контур, во втором — общий размер объекта (рис. 11.43).

а

б

Рис. 11.43. Изменение толщины обводки: а — в режиме Weight Changes Bounding Box, б — режим отключен

При масштабировании контура обводка может изменять размер вместе с ним. Для этого следует изменять размер объекта с помощью инструмента Scale. Значение толщины в палитре Stroke остается неизменным при масштабировании. В этом случае оно относится к неизмененному объекту. Если искажение непропорционально, тогда обводка тоже непропорционально масштабируется, ее видимая толщина становится неодинаковой на разных участках контура. Если масштабировать объект инструментом Selection, его обводка остается неизменной.


Сопряжение

В углах между сегментами контура линии обводки сходятся, сопрягаются. Вид сопряжения линий обводки может варьироваться. Доступны три вида. которые задаются кнопками группы Join палитры Stroke (рис. 11.44):

  • Miter— контуры обводки продолжаются до схождения в одной точке, образуя "усы", угловое сопряжение;
  • Round—обводка со скругленными углами;
  • Bevel — линии обводки обрезаются по линии, проходящей через опорную точку, обводка имеет скошенные углы.

Сопряжение задается для всего выделенного контура или сразу нескольких контуров. Нельзя задать этот атрибут для отдельных точек контура.

а [image] б [image] в

Рис. 11.44. Типы сопряжения: Miter (a), Round (б), Bevel (в)

Если выбрать тип сопряжения без выделенных объектов, он будет применяться ко всем вновь создаваемым контурам. Для выбора типа сопряжения предназначены кнопки группы Join. Активная кнопка соответствует типу сопряжения для линии. Для изменения формы сопряжения линий обводки выделите объект и щелкните на нужной кнопке группы Join.

Если типы Round и Bevel применяются обязательно ко всем точкам сопряжения контура, то для типа Miter существует дополнительный параметр. Ведь если угол между сегментами контура мал, то в режиме Miter обводка образует острый длинный "ус", вследствие чего внешний вид контура нарушается. Величина в поле Miter Limit регулирует, при каких характеристиках "уса" угловое сопряжение заменяется на сопряжение со скосом. Вводимое число есть соотношение между толщиной обводки и длиной получающегося "уса". Если значение Miter Limit равно 1, все углы сопрягаются со скосом. По умолчанию установлено значение 4, т. е. если длина "уса" сопряжения в 4 и более раза больше толщины обводки, то данный узел имеет сопряжение со скосом. Если соотношение межцу этими величинами меньше 4, то узел имеет угловое сопряжение. На рис. 11.45 показаны контуры с порогом Miter Limit (а-1,6-2, в-10).

а [image] б [image] в

Рис. 11.45. Контуры с разным порогом Miter Limit


Форма окончаний линий

Форма окончания линии задается кнопками группы Caps. На рис. 11.46 приведены три возможных типа концов линий. Концы определяются для обоих концов незамкнутого контура. Если контур замкнут, то этот параметр также можно задать. Его действие станет видно в случае последующего размыкания контура. Чтобы задать вид окончания линии, щелкните на нужной кнопке.

а [image] б [image] в

Рис. 11.46. Формы концов линий обводки: Butt (a), Round (б.), Projecting (в)


Пунктир

Тип линии определяется в раскрывающемся списке Type. Значение Solid соответствует сплошной. Dashed — пунктирной обводке. Когда выбран тип Dashed, в нижней части палитры появляется область определения шага (элементарной ячейки) пунктирной линии (рис. 11.47). В полях dash вводится размер штрихов, в полях gap — ширина пробелов между ними. Так же как и для толщины линии, можно задавать значения в различных единицах, они будут автоматически переведены в пункты.

Рис. 11.47. Палитра Stroke, содержащая параметры пунктира

Достаточно определить только одно (первое) поле. Тогда InDesign создаст обычный пунктир, в котором длина штриха равна длине пробела. При заполнении большего числа полей разными значениями можно получить более сложные пунктиры (рис. 11.48). Заданные значения можно в любой момент изменить — соответственно меняется и вид линии.

а [image] б [image] в

Рис. 11.48. Пунктиры

Поскольку каждый штрих пунктира представляет собой отрезок обводки, он имеет концы такого типа, который определен кнопками Caps. В зависимоти от типа окончания линии, вид пунктира меняется (рис. 11.49).

а

б

в

Рис. 11.49. Вид пунктира, в зависимости от окончания линий

При масштабировании обводки вместе с объектом внешний вид пунктира меняется (его значения при этом относятся к неизмененному объекту). Если обводка не масштабируется вместе с объектом — ширина штрихов и пробелов пунктира останется постоянной, они перераспределяются по линии обводки.


Создание стрелок и направление линии

Рисование линий со стрелками и наконечниками — частая задача иллюстрирования, особенно технического рисования. Стрелки в In Design являются атрибутом обводки. Вид наконечников определяют значения в раскрывающихся списках Start и End. Каждый из списков содержит несколько образцов наконечников (рис. II.50). Для задания наконечника начальной точке (той, с которой вы начали рисовать контур) выберите одно из значений списка Start, наконечник последней точки задается в списке End. Эти параметры можно выбрать как для открытого, так и для замкнутого контура. В последнем случае они не отобразятся на экране, а будут пребывать в латентном состоянии, пока вы не разомкнете контур. На вид стрелок и наконечников оказывают влияние параметры сопряжения и окончаний линий. Сам наконечник располагается за пределами линии, продолжая ее.

Рис. 11.50. Разные стрелки и наконечники

Чтобы стрелка или наконечник были продолжением контура

Наконечник размещается по управляющей линии последнего сегмента. Чтобы он аккуратно продолжал линию, эта управляющая должна располагаться корректно (рис. 11.51).

Если у контура имеются начальная и конечные точки, то закономерен вопрос о направлении созданного контура — как оно задается, можно ли менять и пр. Действительно, такой атрибут имеется, он относится даже не к обводке, а непосредственно к линии контура. Вот несколько замечаний о том, как определить направление контура.

а [image] б

Рис. 11.51. Зависимость положения стрелки от управляющей линии

Для открытого контура направление очевидно, если задать стрелку в его конечной точке. Замкнутый контур тоже имеет направление. Чтобы его узнать, можно разрезать контур и тоже установить для него стрелку.

  • Если контур создан от руки, он сохраняет направление создания.
  • Контуры, созданные инструментами Rectangle, Ellipse, Polygon, имеют направление против часовой стрелки.
  • При отражении контуров меняется и направление, т. е. конечная и начальная точка остаются теми же.
  • Направление контуров важно при формировании стрелок и создании комбинированных контуров.


Обработка углов

В качестве дополнительного атрибута контуров InDesign предлагает автоматическую обработку углов. Угловые точки контура (и только угловые) можно преобразовать в скругленный или скошенный угол, выемку и даже простейшую виньетку. При этом эффект уголка можно назначать и отменять, изменять его параметры в специальном диалоговом окне Corner Effects (рис. 11.52), которое вызывается одноименной командой меню Object.

С помощью флажка Preview в этом окне устанавливается режим предварительного просмотра. В раскрывающемся списке Effect перечислены способы обработки уголков. Поле Size задает размер области вокруг опорной точки. которую затрагивает эффект. Чем больше значение в этом поле, тем крупнее созданные уголки.

Рис. 11.52. Диалоговое окно Corner Effects

После того как значения уголков подобраны, щелчок на кнопке ОК приведет контур к выбранному виду. Вы в любой момент можете снова открыть окно Corner Effects и изменить введенные значения. Эффект действует на все угловые точки в контуре, гладкие остаются неизменными.


Комбинированные контуры (Часть I)

Для любой векторной программы очень важно наличие возможностей работы с комбинированными контурами. Так называются системы, состоящие из нескольких контуров, ведущих себя как единый объект. Комбинирование контуров чаще всего используется в двух целях: для создания фигур с "дырками" во внутренней области и для уменьшения количества объектов в иллюстрации. Например, именно с помощью слияния графических примитивов проще всего получать такие фигуры, как кольца, рамки и др. Чем меньше объектов содержит иллюстрация, тем легче ее редактировать. Уменьшить количество объектов можно посредством комбинирования.

Если в документе имеется большое количество сложных контуров, могут возникнуть проблемы при выводе изображения на печать.

В отличие от группирования (см. главу 13), при котором объекты, входящие у группу, не утрачивают собственных свойств, при комбинировании создается единый контур из исходных. Этот контур получает заливку и обводку. В терминах программы сложный контур называется Compound Path. Примером комбинированных контуров являются буквы О и В.

Комбинированный контур в InDesigh создается командой Make подменю Compound Path меню Object. Предварительно следует выделить комбинируемые контуры. В результате объекты приобретают атрибуты объекта, лежащего в стопке ниже всех.

При комбинировании в местах наложения объектов образуются лишенные заливки области — дырки. Чтобы наложение контуров дало дырку, их направляющие должны быть противоположны. Расчет дырок производится автоматически, чтобы все внутренние области оказались заполнены, все наружные — пусты. Если контур состоит из двух элементов, то не возникает вопрос о том, какая область должна быть пустой, а какая — заполненной.

InDesign меняет направления контуров так, чтобы они стали противоположными и результат комбинирования достигается автоматически (рис. 11.53).

Рис. 11.53. Автоматическая коррекция направлений контуров при создании комбинированных контуров


Комбинированные контуры (Часть II)

а [image] б

в

г

Рис. 11.54. а — исходные контуры, б — после комбинирования, в, г — после изменения направления контура

Часто встречается более сложный вариант, когда комбинированный контур составляется из нескольких простых, или исходные контуры уже являются комбинированными (например, при создании логотипов на основе шрифтов). При комбинировании InDesign предлагает свое решение проблемы образования дырок, но оно далеко не всегда вас устроит. В этом случае направление простого контура в составе комбинированного можно поменять вручную. Нужно выбрать инструментом Direct Selection одну опорную точку на требуемом простом контуре, а затем выполнить команду Reverse Path.

Меняя направления контуров, вы обязательно добьетесь нужного расположения отверстий, хотя может быть не с первого раза (рис. 11.54).

Комбинированные контуры выделяются и редактируются как единый объект. Градиентные заливки и обводки для них определяются единым вектором (рис. 11.55).

Рис. 11.55. Градиентная заливка комбинированного контура

Рис. 11.56. Отмена комбинирования

Отмена комбинирования производится командой Release подменю Compound Path меню Object. После отмены первоначальные свойства контуров не возвращаются. Дырки в местах наложения объектов, разумеется, пропадают (рис. 11.56).


Резюме

  • Контур описывается опорными точками и сегментами. Точки в InDesign делятся на угловые и гладкие.
  • Контуры произвольной формы создаются инструментом Pen.
  • Для выделения объектов целиком используется инструмент Selection. Отдельные элементы сложных объектов выделяются инструментом Direct Selection.
  • Этим инструментом выделяют и редактируют отдельные опорные точки контуров, а также их управляющие линии. Перемещение точек и управляющих линий — основной способ корректировки формы контура.
  • Опорные точки можно добавлять, удалять и менять их тип. Для этого применяются инструменты группы Pen.
  • Контуры могут быть разрезаны инструментов Scissors, продолжены или соединены между собой.
  • Для построения простых фигур — прямоугольников, эллипсов, многоугольников и фреймов этих форм предназначены специальные инструменты.
  • Созданные объекты образуют на странице документа стопку, перекрывая друг друга. Порядок наложения объектов можно менять.
  • Объекты — контуры и фреймы — можно подвергать различным трансформациям — перемещать, копировать, дублировать, наклонять, вращать и создавать отражения объектов.
  • Чтобы контур был виден в документе, ему присваиваются атрибуты — обводка и заливка. Заливка и обводка может быть простой и градиентной.
  • Обводка может варьироваться по толщине, сопряжению, форме окончания линий. Линии могут иметь стрелки, быть сплошными или пунктирными.
  • Угловые точки контуров можно обработать, придав им скошенный, скругленный вид или даже преобразовав в простую виньетку.
  • InDesign поддерживает операции с комбинированными контурами.
  • При задании стрелок и работе с комбинированными контурами большое значение имеет направление контура. Направление контура можно менять.


Глава 12

Импорт графики

Как мощная программа верстки, InDesign обладает мощными инструментами для верстки насыщенных графикой публикаций: рекламных буклетов, проспектов, альбомов, иллюстрированных журналов, газет и т. п.

Для того чтобы поместить какое-либо изображение на страницу документа InDesign, его необходимо импортировать (как импортируется в страну товар, который в ней не производится) специализированным фильтром импорта. Фильтр представляет собой программу представления графической информации, созданной в стороннем приложении в виде, понятном InDesign.

Самый общий принцип заключается в том, что все, с чем может работать компьютер, в том числе и изображение, должно быть превращено в цифровую форму (закодировано). Цифровая компьютерная графика по способу кодирования может быть разделена на две: векторную и точечную.

В настоящей главе рассматриваются следующие вопросы:

  • Векторная и точечная графика
  • Форматы файлов векторных и точечных изображений
  • Импорт изображений в InDesign
  • Вложенная и свободно размещаемая графика
  • Интеграция продуктов Adobe: InDesign, Illustrator, Photoshop
  • Трансформирование импортированных изображений
  • Обтравленные изображения и маски


Векторная графика

Изучая предыдущую главу, вы получили представление о векторной графике. Именно этому типу принадлежат все графические объекты, которые вы можете создавать средствами InDesign: эллипсы, линии, прямоугольники, кривые. Строго говоря, к векторной графике относится и главный персонаж публикации — текст. Просто его ввод и редактирование осуществляются особыми средствами.


Векторные объекты

Векторные изображения состоят из объектов. Каждый объект строится программой в соответствии с особым математическим описанием. Файлы, содержащие векторные изображения, невелики по размеру, поскольку хранится не само изображение, а только данные о его построении. При открытии файла и любых операциях программа создает объекты заново на основе хранящихся данных. Размеры объектов не играют большой роли, они практически не увеличивают объем информации. Однородная заливка и обводка также не слишком влияют на размер файла изображения. Если в документе присутствуют несложные по форме объекты, если их не слишком много и они имеют сплошные заливки, то файл векторного изображения гораздо меньше по размеру, чем файл, содержащий такое же точно изображение в точечном формате.

В векторной графике большое значение имеет сложность контуров, поскольку в файле хранится информация о построении каждого узла и сегмента. Размер документа увеличивается и при наличии специальных эффектов — описание каждого из них также сохраняется в документе. Файл, содержащий большое число сложных объектов, или много специальных эффектов, может иметь и больший размер, чем файл с таким же точечным изображением.

Объекты, построенные в программах векторной графики, легко трансформируются. Манипуляции с объектами довольно просты. В развитых векторных программах объекты могут быть организованы в группы, слои, и др. Это еще больше облегчает работу с ними. Качество заливок и обводок, эффектов, а также гладкость самих контуров векторных изображений великолепна. Какие бы трансформации ни применялись к объекту, это не оказывает никакого влияния на качество изображения (рис. 12.1). Оно будет иметь качество, максимально возможное для данного устройства вывода (монитора, принтера, фотонаборного автомата).

Векторные программы имеют развитые возможности работы с текстом. После набора текст остается редактируемым. Выбор шрифта, редактирован непрямо на странице документа, свободное размещение символов, тонкая настройка текста — все это возможно. В программы векторной графики могут быть внедрены и точечные изображения.

Высокое качество контуров — основное достоинство векторных изображений. Создание шрифтового и графического дизайна, построение схем и чертежей — все это области применения векторных программ. Работы, в которых есть разнородные элементы (текст, рисунок, линия, точечно изображение), также выполняются в этих программах. Нужно отметить, что такие работы в настоящее время относятся к наиболее распространенным (реклама, иллюстрированные журналы).

Рис. 12.1. Векторное изображение состоит из контуров (справа), а точечное — из цветовых точек

Наиболее популярными являются такие программы для создания и обработки векторной графики, как Adobe Illustrator, Macromedia Freehand, CorelDRAW.

Недостатком данной графики можно считать ограниченность в приемах обработки. Иллюстрации, созданные в этих программах, часто раздражают глаз излишней правильностью, "стерильностью" линий. На электронных выставках, однако, вы можете увидеть векторные изображения, которые выглядят, "как живые". Их реалистичность поражает, но не следует забывать, что для имитации реальных объектов требуется огромное число контуров. Подобная работа необычайно трудоемка. Ее выполняют художники, имеющие большой опыт.

Важно, что принятый в векторной графике принцип описания изображения не позволяет автоматизировать ввод графической информации, а это значит, что для создания сложного изображения оператор должен в определенной мере быть художником-графиком. Заметим, что изобразительные возможности векторной графики возрастают, а вместе с ними ширится и область ее применения.

Существенным недостатком векторной графики в определенной мере является именно ее способ описания. Поскольку каждая программа обладает собственным алгоритмом описания объектов, векторные файлы нельзя свободно открывать в любой векторной программе. Для открытия файла нужно использовать соответствующий фильтр импорта. В подавляющем большинстве программ имеются алгоритмы для описания контуров, обводок, простых заливок и двухцветных линейных градиентов. При импорте файлов, содержащих простые объекты, потерь практически не бывает. Что же касается новых впечатляющих возможностей (прозрачности, градиентные сетки, и т. п.), то они отображаются и редактируются только в программе, с помощью которой созданы. Если вы импортируете, например, файл с прозрачными объектами из CorelDRAW в Illustrator, то после импорта прозрачность исчезнет, т. к. Illustrator не поддерживает эту характеристику объектов. Мало того, эти алгоритмы из-за своей нестандартности могут вызвать затруднения при выводе.


Форматы векторных файлов

Файлы в векторных форматах создаются в программах иллюстрирования. таких как Adobe Illustrator, Macromedia Freehand, CorelDRAW и др. Они могут содержать не только векторные объекты, но и точечные изображения. Поэтому векторные форматы можно использовать и для хранения точечных изображений.

Поскольку технологической основой большинства издательских процессов является PostScript, для хранения векторных изображений предпочтительны форматы, основанные на этом языке описания страниц. InDesign способен работать со следующими из них:

  • EPS. Формат EPS (Encapsulated PostScript), имеет особое значение для полиграфии. Не следует считать его форматом исключительно для точечных изображений. Он основан на языке PostScript, разработанном фирмой Adobe Systems Inc. и предназначенном для описания любой графической и текстовой информации. PostScript широко используется в издательских системах любого уровня: от скромных "домашних типографий" до специализированных рабочих станций. Язык PostScript используется всеми профессиональными и полупрофессиональными устройствами вывода: лазерными принтерами, плоттерами, фотонаборными автоматами. Эти устройства снабжены программным или аппаратным интерпретатором PostScript, осуществляющим растеризацию. Подробно о выводе иллюстраций на печать мы расскажем в главе 19. В рамках этого формата возможно хранение векторной и точечной графики, шрифтов, растрированных изображений и информации о растрировании, контуров обтравки и цветовых профилей. Как и сам язык PostScript, формат EPS является универсальным форматом описания не только точечных, но и векторных изображений, а также текстовой информации и шрифтов. Поддерживается большинство цветовых моделей. дополнительные каналы. Возможно использование сжатия по алгоритмам LZW, JPEG и CCITT.
  • PDF. Как и формат EPS, PDF (Portable Document Format) основан на PostScript, но имеет особое назначение. Он предназначен для перенос; любых сверстанных документов (в т. ч. иллюстраций) между различным: компьютерами любых платформ. Формат позволяет сохранять все особенности макета и шрифтового оформления, организовывать гипертекстовые перекрестные ссылки и элементы навигации, использовать интерактивные формы и мультимедийные материалы. Для создания, редактирования и просмотра файлов формата PDF используется пакет программ Adobe Acrobat, разработанный фирмой Adobe. Adobe Acrobat состоит из набора программ, основными из которых являются Distiller, Acrobat (в старых версиях Exchange), и Reader. Первый предназначен для создания документов в формате PDF из PostScript-файлов. Второй позволяет их редактировать, создавать оглавления, индексы, помещать в PDF-файлы мультимедийные ресурсы и т. п. Acrobat Reader, в отличие от остальных программ пакета, является свободно распространяемой программой, предназначенной для просмотра PDF-документов. Программа Acrobat Reader выпускается для большого числа различных платформ: DOS, Windows, Macintosh, UNIX и др. Это дает гарантию, что документ, созданный с помощью Adobe Acrobat, может быть прочтен практически на любом компьютере. В последнее время, с появлением новой, 4-й версии языка PostScript, формат PDF все шире используется для вывода макетов публикаций на фотонаборных автоматах, поскольку интерпретатором PostScript Level 3 формат PDF поддерживается непосредственно.
  • AI. Собственный формат программы Adobe Illustrator. В его основе также лежит язык PostScript. По существу является особым вариантом формата EPS. Начиная с версии 8.0, Adobe Illustrator поддерживает PostScript Level 3.

Кроме приведенных выше, InDesign поддерживает еще один векторный формат — метафайлы Windows (на компьютерах Macintosh используется аналогичный формат PICT). Формат WMF (Windows MetaFile) мало пригоден при подготовке макетов для типографского тиражирования, поскольку имеет множество ограничений. Например, он не поддерживает именованные цвета, кривые Безье, градиентные заливки.

Если вы используете векторное изображение в формате WMF (например, взятое с компакт-диска с библиотекой иллюстраций), то перед размещением его в публикации отредактируйте цвета в Adobe Illustrator и пересохраните его в формате EPS.


Точечная графика

Точечные изображения, например, фотографии широко используются в самых разнообразных публикациях — от рекламных листовок до иллюстрированных журналов и альбомов. Хотя InDesign не имеет встроенных средств для создания и редактирования точечных изображений, он располагает всеми необходимыми средствами для создания таких макетов. Прежде чем приступить к их подробному рассмотрению, нам потребуются некоторые дополнительные сведения о природе и свойствах точечных изображений.


Структура точечных изображений

Точечные изображения очень похожи на мозаику. В этой технике изображение формируется из мелких одноцветных элементов, стекол. Если отойти от мозаичного панно достаточно далеко, отдельные стекла становятся неразличимо малы, и изображение кажется однородным (continuous tone inrage). Именно таким образом кодируются точечные изображения в компьютерной графике. Все изображение разбивается на мелкие ячейки, каждая из которых получает усредненный по занимаемой площади цвет. Для простоты и скорости обработки разбивка производится, как в таблице — по горизонтальным строкам и вертикальным столбцам (именно поэтому точечные изображения всегда прямоугольные). При работе с изображением компьютер запоминает всю эту таблицу и цвет каждой ее ячейки. Таким образом, в точечных изображениях не существует объектов как таковых.

Такой простой способ кодирования обеспечивает и легкость его автоматизации с помощью сканеров. Основным узлом сканера является светочувствительный элемент. В планшетных сканерах используется линейка светочувствительных приборов с зарядовой связью (ПЗС), а в профессиональных барабанных сканерах — фотоэлектронные умножители (ФЭУ). Светочувствительный элемент измеряет оптические плотности сканируемого оригинала по всей его площади: в отдельных точках с заданным интервалом вдоль и поперек оригинала. Таким образом получается прямоугольная таблица, содержащая измеренные значения цветов оригинала. Она представляется точным снимком оригинала в цифровой форме. Каждая ячейка таблицы называется точкой, а вся таблица — точечным изображением.

Монитор тоже является точечным устройством. Его экран покрыт прямоугольной сеткой из точек люминофора. При демонстрации изображения кодированная информация визуализируется с помощью обратной сканированию операции. Каждой точке изображения ставится в соответствие точка люминофора, называемая пикселом. Пиксел принимает цвет соответствующей ему точки изображения. Поэтому точку цифрового изображения часто отождествляют с пикселом и говорят, что точечное изображение состоит из пикселов.

Широчайшее применение точечной графики обусловлено во-первых, легкостью ее получения и возможностью автоматизации. Во-вторых, для точечных изображений характерна абсолютная свобода редактирования. В сканированной фотографии с помощью программы редактирования точечной графики можно изменить погоду и время суток, превратить фотографию в живописное полотно, изменить резкость различных объектов, изменить тон цвета, убрать или добавить детали... При этом ничего не нужно рисовать, от вас вовсе не требуется талант художника.

Объем файла точечного изображения (в отличие от векторного) пропорционален площади изображения и разрешению. Кроме того, на него влияет тип изображения. Размеры файлов точечной графики огромны. Для цветных изображений высокого разрешения и большой площади (например, обложка журнала) они могут составлять сотни мегабайт. Соответственно, велико вречя их обработки.


Размеры и разрешение

Чем больше стекол составляют мозаику, тем больше деталей может передать художник. Точечные изображения тоже характеризуются количеством составляющих их точек. В силу частого отождествления точек и пикселов размеры изображений измеряют в пикселах. Если изображение предназначено только для демонстрации на мониторе (Web-страницы и прочие документы для электронного распространения), то это представляется удобным. Удобство обусловлено стандартизованным количеством пикселов, которое могут отображать мониторы. Большинство мониторов IBM-совместимых компьютеров могут отображать 640х480, 800х600, 1024х768 пикселов по горизонтали и вертикали, соответственно. Мониторы большого размера способны отображать и большее количество пикселов.

Чтобы представить себе, сколько места на экране монитора займет изображение известного размера, надо знать, сколько пикселов монитора приходится на единицу длины. Такая величина имеет собственное название, разрешение, и измеряется в пикселах на дюйм (pixel per inch, ppi). Чаще всего разрешение мониторов в режиме 800х600 пикселов равно 72 ppi, а в режиме 1024х768 — 96 ppi. Например, изображение размером 100х50 пикселов займет на экране примерно 1х0,5 дюйма = 25х13 мм (100 pix/96 ppi = 1,04 inch; 50 pix/96 ppi == 0,52 inch; 1 дюйм = 25,4 мм). Вместо того чтобы производить такие несложные, но очень частые расчеты, можно само изображение описывать парой характеристик размер/разрешение. В нашем случае можно считать, что изображение имеет размер 25х13 мм и разрешение 96 ppi. Более того, в файлах изображений величина разрешения обязательно сохраняется, и используется программами верстки и подготовки иллюстраций. Размещенные в них точечные изображения сохраняют свое разрешение и отображаются в соответствующем размере.

Все графические программы умеют работать с изображениями, превышающими размер монитора. Для того чтобы показать такое изображение целиком, они производят масштабирование. При этом нескольких точек изображения передаются одним пикселом монитора. Разумеется, цвета точек изображения при масштабировании усредняются и деталировка изображения снижается. Такую ситуацию можно определить как избыточное разрешение изображения, поскольку оно содержит при таком размере слишком много точек на единицу длины. Масштабирование может производиться и для увеличения изображений. При этом одна точка изображения отображается несколькими пикселами монитора, которым присваивается одинаковый цвет. При достаточно сильном увеличении изображение будет напоминать мозаику, рассматриваемую с очень близкого расстояния. Такая ситуация вызвана недостаточным разрешением изображения. Эта особенность растро вых изображений заставляет очень внимательно относиться к их размерам при сканировании и обработке. Очевидно, что разрешение изображения (с учетом размера) должно соответствовать разрешению устройства вывода, которым может быть не только монитор, но и принтер или фотонаборный автомат. В зависимости от технологии печати на том или ином устройстве вывода могут потребоваться различные разрешения изображений (о печати см. главу 19).


Глубина цвета

До сих пор, говоря о переводе изображений в цифровую форму, мы не касались способа кодировки цвета, отделываясь замечанием о том, что компьютер "запоминает цвета". В действительности вопрос кодирования принципиально важен и требует более подробного рассмотрения. Способ кодирования информации о цвете и количество этой информации напрямую определяют место, необходимое для хранения изображений, и скорость их обработки. Максимальное количество цветов, которое может быть использовано в изображении данного типа, получило название глубины цвета.

Самый простой случай — это монохромное или черно-белое изображение (bitmap). Поскольку каждая точка изображения может иметь только два цвета, для кодирования цветовой информации достаточно одного бита. Зная это, нетрудно рассчитать, сколько памяти требуется для хранения любого изображения такого типа. Например, если размер изображения составляет 800х600 пикселов, то оно займет в памяти 800 пикселов бОО пикселов х1 бит = 480000 бит = 58,6 Кбайт.

Биты и байты

Бит— наименьшая единица информации. Может принимать всего 21 = 2 значения (да/нет, 1/0, черное/белое и т. п.). Восемь бит составляют байт. Байтом может кодироваться 28 = 256 состояний. Десятичные приставки, используемые для этих единиц, имеют некоторое отличие от традиционных. В килобайте (Кбайт) 1024 байта, а в мегабайте (Мбайт) — 1024 Кбайт, или 1048576 байт.

Этот самый экономный тип изображений прекрасно подходит для штриховых иллюстраций, чертежей, гравюр, простых логотипов и т. п. Изображения этого типа можно получить, непосредственно сканируя изображения в режиме Black and White или Line Art (в программном обеспечении различных сканеров этот режим может быть назван по-разному). Глубина цвета монохромных изображений равна двум.

Изображения, состоящие из оттенков серого цвета, называют полутоновыми. Каждая точка полутонового изображения может иметь один из 256 оттенков серого: от черного (0) до белого (255). Нетрудно догадаться, что для ее хранения требуется ровно 1 байт памяти компьютера. Таким образом, изображение займет в восемь раз больше места в памяти, чем монохромное. Если вновь обратиться к нашему примеру с изображением 800х600 пикселов, то полутоновое изображение этого размера займет 468,4 Кбайт.

Полутоновые изображения широко используются для хранения черно-белых ^ в традиционном, фотографическом смысле) фотографий и в тех случаях, когда без цвета можно обойтись. Приведенный простой расчет показывает, что использование полутонового типа для хранения штриховых изображений не улучшит их качества, а приведет к пустой трате памяти компьютера и времени. Глубина цвета полутоновых изображений равна 256.

Для полноцветных изображений требуется еще больше ресурсов. Как отмечалось в главе 4, цвета в компьютерных программах задаются указанием количества базовых цветовых компонент для конкретной цветовой модели. Это справедливо и для точечных изображений. Они, как правило, могут быть созданы и сохранены в одной из трех цветовых моделей: RGB, Lab и CMYK. InDesign может импортировать изображения в любой из них. Полноцветное изображение состоит из цветовых каналов, соответствующих базовым цветам модели изображения. Канал представляет собой полутоновое изображение, яркость пикселов которого равна количеству соответствующего базового цвета в изображении. Например, если пиксел цветного изображения имеет оранжевый цвет R:255, G:128, B:0, то соответствующий пиксел в красном канале будет белым (255), в зеленом канале 50%-ным серым (128), а в синем — черным (0).

Объем памяти, занимаемый полноцветным изображением, зависит от количества каналов, которое оно содержит. Изображения RGB и Lab содержат по три канала, каждый из которых является полутоновым, т. е. восьмибитным изображением. Следовательно, такие изображения занимают в три раза больше места в памяти, чем полутоновые того же размера. Изображения CMYK имеют четыре канала, и занимаемая ими память в четыре раза больше, чем память требуемая для полутоновых изображений того же размера. Например, RGB-изображение размером 800х600.пикселов будет занимать 1,37 Мбайт, а CMYK-изображение — 1,83 Мбайт. Поскольку каждый пиксел такого изображения описывается 8х3 = 24 битами, глубина цвета составит 224 = 16,8 млн. цветов.

Изображения всех основных типов широко используются при изготовлении оригинал-макетов, предназначенных для тиражирования любыми способами. Кроме перечисленных, существует еще один тип цветных изображений, который до недавнего времени имел сугубо историческое значение. До широкого распространения видеоадаптеров с большим объемом видеопамяти и SVGA-мониторов, большинство компьютеров были способны одновременно отображать на экране не более 256 цветов одновременно. Более старые мониторы ограничивали это количество до 64 или 16. Наиболее рациональным способом кодировки в таких условиях являлось их индексирование. Идея кодирования состояла в том, что каждому из цветов изображения присваивался порядковый номер, который использовался для описания всех пикселов изображения, имеющих этот цвет. Поскольку для разных изображений оптимален разный набор цветов, этот набор хранился в памяти компьютера вместе с изображением. Набор цветов, использованных в изображении, получил название палитры, а способ кодирования цвета — индексированный цвет (indexed color).

Объем памяти, занимаемый индексированным изображением, зависит от количества цветов в его палитре. Так, для описания 256 цветов требуется 1 байт (восемь бит), для 64 цветов нужно 6 бит, для 16 цветов — 4 бита, и т. д. В худшем случае, для изображения с палитрой из 256 цветов, требуется столько же памяти^ сколько и для полутонового. Очевидно, глубина цвета индексированных изображений совпадает с размером их палитры.

Столь низкое ограничение на количество отображаемых цветов вызвало появление различных способов имитации отсутствующих в палитре цветов за счет имеющихся. Например, расположив рядом пикселы более темного и более светлого оттенков одного цвета, можно передать отсутствующий промежуточный цвет. Это всего лишь один из многочисленных и, порой весьма сложных, приемов сглаживания (dithering) индексированных цветов.

С развитием видеосистем компьютеров индексированные цвета перестали столь широко использоваться. Даже современные офисные компьютеры способны отображать на экране 65536 (режим High Color) или 16,8 млн цветов (режим True Color). Тем не менее, для индексированных изображений тоже нашлась своя экологическая ниша — World Wide Web. Подробное рассмотрение подготовки графики для Internet мы отложим до главы 10, а сейчас перейдем к форматам графических файлов.


Форматы файлов

Описывая кодирование цветовой информации, мы имели в виду скорее принцип, чем непосредственную реализацию. Разумеется, способ хранения изображений в памяти компьютера определяют разработчики конкретных программ. С другой стороны, для того чтобы их хранить, переносить между компьютерами и просто разными приложениями, требуется некоторая стандартизация способа записи — формат файлов. Из-за разнообразия типов изображений и областей их использования существует огромное количество разных форматов графических файлов. Даже исключительно для точечных

графических форматов действует принцип "Больше стандартов хороших и разных!". Если не принимать во внимание узко специализированные форма ты, то останутся несколько наиболее употребительных.

При выборе формата для точечных изображений важны следующие аспекты:

  • Распространенность формата. Многие приложения имеют собственные форматы файлов точечных изображений, и другие программы могут оказаться неспособны работать с ними. Выбирайте наиболее широко распространенные форматы файлов, распознаваемые всеми приложениями, с которыми вы работаете.
  • Поддерживаемые типы точечных изображений. Форматы поддерживающие исключительно индексированные цвета, неприменимы при изготовлении макетов для тиражирования.
  • Поддерживаемые цветовые модели полноцветных изображений. Многие графические форматы не позволяют хранить, например, изображения в цветовой модели CMYK, что делает их непригодными для полиграфии.
  • Возможность хранения дополнительных каналов масок. Многие программы подготовки иллюстраций способны использовать их для создания контуров обтравки (см. ниже в этой главе).
  • Возможность сжатия информации. Как мы уже отмечали, объем памяти (оперативной или дисковой) для хранения точечных изображений весьма велик. Для того чтобы сократить занимаемое графическим файлом место, используются специальные алгоритмы сжатия, уменьшающие размер файлов. Использование сжатых форматов предпочтительнее для экономии дискового пространства. В оперативной памяти изображения всегда находятся в несжатом виде.
  • Способ сжатия. Имеется большое количество алгоритмов сжатия графических файлов. Некоторые форматы могут иметь до десятка вариантов, различающихся по этому признаку. В целом алгоритмы сжатия можно разделить на две неравные группы: сжатие без потери информации и сжатие с потерей информации (lossy compression). Алгоритмы второй группы позволяют достигать огромных коэффициентов сжатия (до пятидесятикратного), но при этом из изображения удаляется часть информации. При небольшом сжатии (степень сжатия, как правило, можно регулировать) эти потери могут быть совершенно незаметны. Сжатие с потерей информации используется для передачи изображений по глобальным сетям и для макетов, не требующих высокого качества. В полиграфии форматы с таким сжатием, как правило, не используются.
  • Возможность хранения объектной (векторной) графики.
  • Возможность хранения калибровочной информации и параметров растрирования. Имеет смысл, только если изображение предназначено для типографской печати.

Ниже приведен список наиболее распространенных форматов файлов для точечных изображений. Все эти форматы могут быть импортированы в любую программу, ориентированную на работу с графикой. InDesign также имеет фильтры импорта для всех этих форматов.

  • PCX. Формат, разработанный фирмой Z-Soft для программы PC PaintBrush, является одним из самых старых, и практически любое приложение, работающее с графикой, легко импортирует его. Он поддерживает исключительно индексированный цвет и имеет преимущественно историческое значение.
  • BMP и DIB. Форматы предназначены для Windows, и поэтому поддерживается всеми приложениями, работающими в этой среде. Используют только индексированные цвета или 24-битные RGB.
  • TIFF. Формат TIFF (Tagged Image File Format) был создан в качестве универсального формата для хранения сканированных изображений с цветовыми каналами (файл с расширением TIF). Он импортируется во всех программах настольных издательских систем, его можно открыть и работать с ним практически в любой программе точечной графики. Этот формат позволяет хранить изображения с любой глубиной цвета и цветовой моделью. Поддерживаются дополнительные каналы масок, калибровочная информация и параметры растрирования. В последней, шестой спецификации позволяет хранить простейшие объектные контуры, в т. ч. обтравочные. Поддерживаются многочисленные алгоритмы сжатия без потери информации. Предпочтительный формат для изготовления макетов, ориентированных на типографскую печать, и другие способы тиражирования.
  • PSD. Этот формат является собственным для самого популярного редактора точечных изображений Adobe Photoshop (PhotoShop Document). Это исключительно емкий формат, поддерживающий все многообразные функции своего приложения: слои, каналы, контуры обтравки, установки печати, системы цветокоррекции. Поддерживает все типы точечных изображений и цветовые модели, многоканальные изображения (включая каналы плашечных цветов) и дуплексы. Популярность Adobe Photoshop заставляет производителей графических приложений включать в свои программы поддержку этого формата.
  • JPEG. Формат JPEG (Joint Photographic Experts Group) предназначен для сохранения точечных файлов со сжатием по алгоритму с потерями информации. Формат поддерживает только полноцветные изображения в моделях RGB и CMYK. Возможно хранение простых объектных контуров. Не поддерживаются дополнительные каналы. Широко используется для верстки страниц WWW.
  • GIF. Другим широко распространенным в Internet форматом является GIF (Graphics Interchange Format). Более того, он был создан компанией CompuServe специально для передачи изображений в глобальных сетях

К моменту создания он обладал самым эффективным методом сжатия без потери информации. "Второе дыхание" формат обрел с появлением версии 89а. В этом варианте он допускает хранение в одном файле нескольких изображений. Чаще всего такая возможность используется на страницах Web. Web-браузер демонстрирует изображения, находящиеся в файле GIF 89а, последовательно. Если каждое изображение представляет собой фазу мультипликации, то вы увидите маленький мультфильм. Другая используемая браузерами особенность формата состоит в определении "прозрачного цвета". Все элементы изображения, заполненные этим цветом, не будут ими выводится на экран. Формат поддерживает только индексированные изображения.

  • PNG. Само название формата, Portable Network Graphics, говорит о его предназначении — использовании при передаче изображений в сетях. Поддерживает полноцветные RGB и индексированные изображения. Возможно использование единственного дополнительного канала для хранения обтравочной маски. Использует эффективный алгоритм сжатия без потери информации.
  • EPS. Формат EPS (Encapsulated PostScript), разработанный фирмой Adobe Systems Inc., имеет особое значение для полиграфии. Этот формат представляет собой описание изображения на языке PostScript, предпочтительном для полиграфических целей. В рамках этого формата возможно хранение векторной и растровой графики, шрифтов, растрированных изображений и информации о растрировании, контуров обтравки и кривых калибровок. Как и сам язык PostScript, формат EPS является универсальным форматом описания не только точечных, но и объектных изображений, текстовой информации. Поддерживает большинство цветовых моделей, дополнительные каналы. Возможно использование сжатия по практически любым алгоритмам.
  • DCS. Формат DCS (Desktop Color Separation) является вариантом Encapsulated PostScript, развитым фирмой Quark для поддержки цветоделения файлов иллюстраций и изображений, помещенных в издательскую систему Quark XPress. Формат имеет две версии — 1.0 и 2.0. В первой версии поддерживается только модель CMYK. Документ DCS 1.0 состоит из пяти файлов. Основной файл содержит композитное цветное изображение низкого разрешения для размещения в публикации и печати цветопроб. Остальные четыре файла содержат цветоделенные триадные компоненты. Вторая версия DCS поддерживает не только триадные краски, но также практически любое количество плашечных цветов и один альфа-канал. Также поддерживаются контура обтравки и все прочие продвинутые возможности формата EPS. Кроме того, DCS 2.0 позволяет записывать все компоненты и композит в один файл. Формат DCS по существу является практически единственным способом включения точечных изображений, цветод еденных с использованием плашечных цветов, в иллюстрацию или публикацию в системе верстки. Изображения в этом формате можно получить сохранением документов Photoshop, предварительно переведя их в формат CMYK или Multichannel.


Импортирование изображений

Для импортирования изображений в InDesign существуют три пути: команда Place меню File, системный буфер обмена Clipboard и перетаскивание мышью из окон других приложений. Вы можете использовать любой из этих вариантов, но с оглядкой на их особенности. Импортирование с помощью команды Place обеспечивает наибольшую свободу управления этой операцией. Команда Place меню File открывает диалоговое окно, изображенное на рис. 12.2. Вам оно уже должно быть знакомым по импортированию текстовых файлов. Из трех флажков, находящихся в этом окне, при импорте графических файлов имеет смысл только Show Import Options. Установив его, вы обеспечите себе полный контроль за ходом импортирования.

Рис. 12.2. Диалоговое окно Place

При импорте каждого формата доступны дополнительные настройки, специфические именно для него. Импортирование перетаскиванием и через системный буфер обмена не позволяет задавать для него какие-либо параметры.


Импортирование точечных форматов

InDesign способен импортировать точечные графические форматы TIFF, PSD. SCT, PNG, JPEG, PCX; GIF и BMP. Часть этих форматов имеют при импортировании особые настройки, но большая часть настроек одинакова для всех. Наиболее типичным примером является импортирование формата TIFF. Если в диалоговом окне Place установлен флажок Show Import Options, то перед размещением изображения на странице публикации вам будет предоставлено диалоговое окно Image Import Options, изображенное на рис. 12.3.

Рис. 12.3. Диалоговое окно Image Import Options

Оно имеет несколько разделов, точное количество которых зависит от выбранного формата. Для формата TIFF в нем имеются два раздела: Image Settings и Color Settings. Первый из них и представлен на рис. 12.3.

В поле Proxy Image Resolution указывается пониженное разрешение, с которым изображение будет показываться InDesign, если в диалоговом окне Preferences установлен режим Display Proxy Images (см. главу 2). Флажок Create Frame from Clipping Path устанавливает импортирование обтравочного контура, сохраненного в файле вместе с изображением. Если изображение не содержит обтравочный контур, то этот флажок будет недоступен. Создание и редактирование обтравочных контуров мы рассмотрим ниже в этой главе.

Элементы управления в разделе Color Settings осуществляют управление цветом для импортируемого изображения. Как отмечалось в главе 2, наряду с установками управления цветом по умолчанию, InDesign позволяет задавать их независимо для отдельных изображений. В списке Profile устанавливается исходный профиль изображения, а в поле Rendering Intent — метод преобразования цветового охвата. Значения этих параметров по умолчанию определены в диалоговом окне Preferences. Если изображение требует иных установок управления цветом (например, смены метода преобразования цветового охвата в зависимости от характера изображения), то вы можете изменить их прямо на стадии импорта. Если вы хотите, чтобы система управления цветом вообще не корректировала импортируемое изображение, сбросьте флажок Enable Color Management.

Аналогичные настройки предоставляются и при импорте остальных форматов, за исключением PNG. Для него диалоговое окно Image Import Options имеет дополнительный раздел PNG Settings (рис. 12.4).

Рис. 12.4. Раздел PNG Settings диалогового окна Image Import Options

Формат PNG позволяет хранить сведения о прозрачности в отдельном альфа-канале изображения. Эта информация может обрабатываться In Design:

  • Use Transparency Information. Если флажок установлен, то InDesign обрабатывает информацию о прозрачности из альфа-канала. Если альфа-канал в изображении отсутствует, то флажок недоступен.
  • White Background/File Defined Background Color. Если цвет фона в PNG-файле не определен, то установка переключателя White Background делает его белым. Если установить переключатель File Background, будут использованы данные о цвете фона, находящиеся в файле изображения.
  • Apply Gamma Correction. Установив этот флажок, вы можете провести коррекцию гаммы изображения (коэффициент контрастности в средних тонах) непосредственно при импорте.
  • Gamma Value. Если установлен флажок Apply Gamma Correction, то в это поле вводится новое значение гаммы. Оно должно лежать в пределах от 0.01 до 3.

Подчеркнем, что при импорте PNG с маской прозрачности вы не получите полупрозрачного изображения на странице публикации. Изображение будет обязательно иметь фон, цвет которого вы и определяете в разделе PNG Settings диалогового окна Image Import Options. Формат GIF, который тоже содержит информацию о прозрачности, обрабатывается аналогичным образом. При его импорте изображение обязательно будет иметь фон. Фон будет иметь тот цвет, который определен как "прозрачный" при создании файла. Если вы хотите получить изображение без фона, то следует воспользоваться редактором точечных изображений для создания контура обтравки или встроенной функцией создания контура обтравки в InDesign.

Если вы готовите изображения для макета, который планируется тиражировать типографским способом, то не применяйте в нем изображения, сохраненные в форматах PNG, GIF, JPEG или PCX. Они не обеспечивают необходимое для таких макетов качество.

Особо рассмотрим импорт формата DCS. Как вы помните, он представляет собой вариант формата EPS, содержащий уже цветоделенное изображение. Формат DCS используется в тех случаях, когда публикация должна быть напечатана с использованием плашечных цветов. DCS — единственный формат точечных изображений, способный хранить информацию о любом количестве произвольных цветовых каналов.

Вообще говоря, каналы с плашечными цветами может хранить и собственный формат Adobe Photoshop — PSD. При попытке импорта таких файлов в InDesign выдается сообщение о том, что из-за наличия каналов с плашечными цветами импорт невозможен.

Диалоговое окно импорта формата DCS изображено на рис. 12.5. Оно общее для импортирования всех вариантов формата EPS. Флажок Create Frame from Clipping Path выполняет ту же функцию, что и в диалоговом окне Image Import Options — включает импортирование контура обтравки. Флажок Read Embedded OPI Links имеет смысл, если вы пользуетесь технологией ОРI(Opened Prepress Interface). Подробнее о ней вы можете узнать в главе 19.

Рис. 12.5. Диалоговое окно EPS Import Options

При импорте изображений в формате DCS все использованные в них плашечные цвета тоже импортируются в документ и попадают в палитру Swatches. Это обеспечивает правильное цветоделение с использованием плашечных цветов. Подробно об определении цветов рассказывается в главе 4.

InDesign не отображает на экране содержимое файла DCS самостоятельно. Для экранного представления изображения он использует миниатюру или композитное изображение, которые уже должны быть в файле. Если же файл не содержит ни композитного изображения, ни миниатюры, то на экране вы увидите фигуру серого цвета, перечеркнутую косыми черными линиями. Поэтому при создании файлов DCS следите за тем, чтобы они были снабжены, как минимум, миниатюрой. Прилагать композитное изображение имеет смысл, если вы собираетесь получать пробные распечатки макета на принтере, не поддерживающем язык PostScript.

Если импортировать файлы точечных форматов перетаскиванием из окон других программ или папок Windows Explorer, то для них принимаются установки по умолчанию. Через системный буфер InDesign точечные изображения в принципе не импортирует (если в буфере обмена находится растровое изображение, то команда Paste закрыта).


Импортирование векторных форматов

InDesign импортирует векторную графику в форматах EPS, AI, PDF, WMF. С параметрами импортирования форматов EPS и AI вы уже знакомы. Импортированные иллюстрации становятся едиными объектами в InDesign и не редактируются его средствами. Вы можете применять к ним только обычные операции трансформирования: перемещение, поворот, масштабирование и наклон.

Импортирование этих форматов через системный буфер или перетаскивание мышью дает иной результат. Объекты, входящие в иллюстрацию, становятся редактируемыми инструментами рисования InDesign. Хотя такой путь представляется более гибким, следует учитывать неполную совместимость объектов InDesign и программ иллюстрирования, даже Adobe Illustrator. Применять импортирование через буфер обмена и перетаскиванием можно только для объектов, не содержащих градиенты и градиентные сетки. Эти типы заливок не поддерживаются при импортировании через буфер обмена. Особые объекты Adobe Illustrator при импорте через буфер обмена преобразуются в простые:

  • Перетекания (blend) разбиваются на отдельные объекты, как это делает команда Expand в Adobe Illustrator.
  • Художественные кисти (brush) преобразуются в группу объектов со сплошной заливкой.
  • Узорные заливки (pattern) преобразуются в отдельные объекты, как это делает команда Expand в Adobe Illustrator.
  • Текстовые блоки импортируются как обычные объекты. К ним можно применять любые операции трансформирования, но нельзя редактировать ни как текст, ни как контуры.

Аналогичным образом импортируются объекты и из Macromedia Freehand. Единственное отличие состоит в том, что градиентные заливки из Freehand автоматически разбиваются на серию фигур со сплошной заливкой. При импорте объектов с градиентной заливкой из Adobe Illustrator заливка меняется на сплошную черную. Если вы все-таки хотите импортировать градиентную заливку из Adobe Illustrator, то примените к ней предварительно команду Expand.

При импорте векторных иллюстраций все использованные в них цвета тоже импортируются в документ и попадают в палитру Swatches. Подробно об определении цветов рассказывается в главе 4.

В силу указанных выше ограничении применяйте импортирование векторных изображений через буфер обмена, только если собираетесь их редактировать и они достаточно просты. В противном случае удобнее пользоваться командой Place. Тогда вы не сможете редактировать контуры инструментами InDesign, но при импорте не потеряете никакие детали иллюстрации.

Изображения в форматах AI и EPS, помещенные в публикацию командой Place, не показываются на экране непосредственно. Вместо самих контуров вы видите всего лишь точечную миниатюру того, что действительно находится в файле. Как правило, этого вполне достаточно для успешной работы с макетом. Точечная миниатюра, как правило, находится в самом файле с иллюстрацией, но если ее нет, то InDesign автоматически создаст экранное представление иллюстрации при импорте. Кроме удобства размещения изображения, это обеспечивает и возможность распечатки макета на принтере, не поддерживающем язык PostScript.

Формат PDF тоже основан на языке PostScript, но, в отличие от EPS и А1, поддерживает многостраничные документы. Это учитывает фильтр импорта, диалоговое окно которого приведено на рис. 12.6. Кнопки, расположенные под областью предварительного просмотра, позволяют выбрать для размещения в публикации нужную страницу документа PDF. В отличие от фильтра импорта PDF в Photoshop, InDesign умеет самостоятельно генерировать изображение страницы для предварительного просмотра. Поэтому вы можете не беспокоиться о фактическом существовании миниатюр страниц в файле документа PDF. Миниатюры страниц показываются в левой части диалогового окна фильтра импорта.

Рис. 12.6. Диалоговое окно Place PDF

Список Crop to в области Options позволяет выбрать ту часть страницы, которая должна быть размещена в публикации:

  • Content. Все, что изображено на странице, включая типографские метки.
  • Art. Только та часть страницы, которая определена как размещаемый рисунок средствами Adobe Acrobat 4.x или Acrobat Exchange 3-х.
  • Crop. Часть страницы, ограниченная метками границ иллюстрации. Такие метки (crop marks) можно создать, например, в Adobe Illustrator.
  • Trim. Часть страницы, ограниченная метками обрезки (trim marks). Их также можно создать в Adobe Illustrator.
  • Bleed. Вся площадь, находящаяся внутри меток обрезки, плюс та, что идет навыпуск.
  • Media. Вся физическая страница документа, включая поля.

Если в области Options установлен флажок Transparent Background, то после размещения документа на странице области, не закрытые объектами, будут прозрачными. В противном случае вся страница документа PDF будет иметь в InDesign сплошной белый фон.

Документ PDF может содержать информацию о растрировании. Сохранить ее в InDesign позволяет флажок Preserve Halftone Screens. Разумеется, эта информация имеет смысл только для принтеров, имеющих интерпретатор PostScript.

Текущая версия InDesign не позволяет импортировать документы в формате PDF с возможностью редактирования. Поэтому вместо векторных объектов вы видите на экране точечное изображение, представляющее содержимое документа.

Единственный не основанный на PostScript формат, который способен импортировать InDesign, это метафайлы Windows. Этот формат широко используется для обмена графической информацией между офисными приложениями в среде этой операционной системы. Еще раз напомним, что формат WMF хорош для офисных приложений, но неприменим при подготовке макетов для полиграфии. Он не поддерживает непосредственно кривые Безье, градиентные заливки, именованные цвета, и пр. Тем не менее. если вы намерены, например, разместить в публикации диаграмму Microsoft Excel, то естественнее всего это сделать именно в формате WMF. Только не забывайте при этом, что вы не можете контролировать цвет с помощью системы управления цветом для графики в этом формате. При размещении в публикации метафайлов Windows InDesign создает точечное изображение. позволяющее видеть их содержимое.


Редкие форматы

Для того чтобы можно было поместить изображение посредством команды Place, InDesign должен располагать фильтром, позволяющим декодировать этот формат. Список всех установленных фильтров для вашей конфигурации InDesign можно получить, выбрав команду About меню Help и удерживая при этом клавиши <Ctrl>+<Alt>. После этого должно открыться окно, представленное на рис. 12.7. Безусловно, содержимое окна зависит от конкретной конфигурации InDesign, и у вас может не быть фильтров и подключаемых модулей, установленных на нашем компьютере, и наоборот.

Рис. 12.7. Окно со списком установленных фильтров импорта и дополнений

Если вы работаете с приложением, для основного формата которого InDesign не имеет фильтра импорта, попробуйте сохранить материал из внешнего приложения в нестандартном формате, но таком, который может быть импортирован InDesign. Например, вы подготовили иллюстрацию в программе Corel Xara 2.0. InDesign не имеет фильтра импорта файлов формата XAR, но можно воспользоваться фильтрами экспорта самой программы Xara, чтобы сохранить иллюстрацию в формате Adobe Illustrator (AI), CorelDRAW Presentation Exchange (CMX) или, на худой конец, в формате метафайла Windows. Для этих форматов InDesign располагает фильтрами импорта. На этом непрямом пути много подводных камней, особенно острых при перекодировках объектных форматов графики. Как мы уже отмечали выше, каждая программа подготовки иллюстраций имеет не только свой собственный формат, но и некоторые особенные возможности. В приведенном выше примере иллюстрация, будучи пересохраненной в формате Adobe Illustrator, изменит свой вид далеко не в лучшую сторону: Adobe Illustrator, не поддерживает атрибут прозрачности для своих объектов, и ультрареалистичные прозрачности Хага превратятся в унылые сплошные заливки. Так что при подготовке иллюстраций обязательно убедитесь, что InDesign располагает фильтром импорта для формата того приложения, в котором вы их создаете. В противном случае не используйте в иллюстрации особые эффекты, которые пропадут при конвертировании файлов InDesign в другой формат.

Проще обстоит дело с импортом текста. Перекодировка файлов, созданных в текстовых процессорах, редко приводит к потере форматирования, да и все равно большую часть форматирования придется осуществлять в InDesign. Фильтры для приложений, появившихся после выхода текущей версии InDesign, можно найти на сайте фирмы Adobe в Internet, http://www.adobe.com. Для получения обновлений программы наиболее удобна служба Adobe Online, интерфейс с которой встроен в InDesign (см. главу 3).


Размещение импортированных изображений

С помощью специализированных фильтров InDesign импортирует изображения в основных точечных и векторных форматах. Немедленно после импорта изображения он предлагает разместить его на странице публикации.


Способы размещения изображений

Импортированное изображение может быть размещено как независимое или вложенное. В первом случае изображение занимает отдельный фрейм, а во втором — находится внутри текстового фрейма.

Независимое изображение можно свободно перемещать по странице публикации. Такие изображения используются как обычные иллюстрации. Их положение на странице не зависит от текстового материала, поскольку они находятся в разных, никак не связанных фреймах.

Вложенные изображения "привязаны" к текстовому материалу. Вы можете разместить их в текстовом фрейме как обычный символ шрифта. Если при верстке размещение текста во фрейме или цепочке связанных фреймов изменится, то вложенное изображение тоже сместится, следуя за текстом, к которому оно "привязано". Вложенную графику используют для оформления буквиц, заголовков, маркеров перечней, и т. п.


Размещение независимой графики

После того как InDesign считает изображение из импортируемого файла, курсор мыши примет вид, изображенный на рис. 12.8. Он указывает, что теперь следует разместить изображение на странице. Процедура размещения зависит от того, где вы хотите разместить изображение: в новом фрейме, приходящемся точно по размеру изображения, новом фрейме заданного размера или в существующем фрейме.

Чтобы отказаться от размещения изображения после того, как закрыто диалоговое окно Place, выберите любой другой инструмент в палитре инструментов.

Рис. 12.8. Размещение изображения на странице

  • Чтобы разместить изображение в новом фрейме, достаточно щелкнуть мышью в той точке страницы, где должен находиться его левый верхний угол. Программа автоматически создаст фрейм точно по размеру изображения.
  • Чтобы разместить изображение во фрейме заданного размера, очертите мышью (при нажатой левой кнопке) прямоугольник, в котором должно располагаться изображение. Этим вы создадите новый фрейм, a InDesign поместит в него изображение.
  • Чтобы поместить изображение в существующий фрейм, можно действовать двумя способами. Согласно первому, достаточно просто выделить этот фрейм перед импортированием изображения (т. е. выбором команды Place) с помощью инструмента Selection. Если целевой фрейм не выделен, то нужно щелкнуть на нем мышью при размещении.

Если импортированное изображение выглядит, как мозаика из цветных квадратов, то это значит, что вы задали слишком низкое разрешение его экранного представления. Вам придется импортировать изображение заново, установив более высокое разрешение. Для этого установите флажок Show Import Options в диалоговом окне Place и нажмите кнопку Open. В открывшемся диалоговом окне Image Import Options установите более высокое разрешение в поле Proxy Image Resolution.


Размещение вложенной графики

Если графическое изображение помещается в публикацию при текущем инструменте Type, то оно будет привязано к точке вставки (месту в тексте, где находился текстовый курсор). В этом случае изображение можно рассматривать как один из символов текста. При перемещении текстового блока или текста внутри текстового блока вложенное изображение тоже перемещается, всегда находясь в положении, заданном при импорте. Прочие варианты помещения изображений не дают такой возможности: при перемещении текста изображение остается на том же месте.

Для того чтобы разместить изображение как вложенное, перед помещением следует выбрать инструмент Type и установить курсор в то место текста, к которому необходимо привязать изображение. Затем вызвать диалог Place.

После этого изображение можно смещать относительно базовой линии строки, в которой оно находится. Для этого выберите инструмент Selection и перемещайте изображение вверх или вниз, как делали это для графики, созданной средствами InDesign (см. главу 11). Курсор при этом принимает вид треугольной стрелки (рис. 12.9).

Рис. 12.9. Смещение вложенного изображения относительно базовой линии текста

Рис. 12.10. Примеры использования вложенной графики

Помещение вложенных изображений, размерами превышающих интерлиньяж текста, вызывает увеличение значения интерлиньяжа для строки, в которой находится место привязки. В данном случае происходит то же, что и при увеличении кегля отдельного символа в строке — автоматический интерлиньяж рассчитывается по нему. Чтобы избежать некрасивого изменения интерлиньяжа, его необходимо задать специально, а не довольствоваться автоматическим (см. главу 6).

Ниже на рис. 12.10 приведены примеры использования вложенной графики.

Для построения выворотного заголовка в примере использовано импортированное из файла TIFF растровое изображение. Изображение помещено на предшествующую заголовку строку, а интерлиньяж между ней и строкой заголовка сделан очень небольшим (2pt). Затем вложенное изображение смещено вниз относительно базовой линии своей строки так, чтобы оно оказалось за текстом заголовка. Кстати, такого же эффекта можно добиться и другими способами, например, использованием текстовых вложенных фреймов (см. главу 16).

Второе и третье вложенные изображения использованы в качестве графического маргинала. Позиции табуляции и абзацные отступы, использованные в этих абзацах, определены в его стиле. Еще один пример использования вложенного изображения представлен на рис. 12.11, где вложенные изображения пиктограмм использованы для удобства читателя.

Рис. 12.11. Пример использования вложенной графики


Графические фреймы

Фрейм, в котором находится исключительно импортированное изображение или несколько изображений, называется графическим. Импортированное изображение находится внутри фрейма и видимо только в его пределах. Области изображения, выходящие за пределы своего фрейма, становятся невидимыми или маскированными. С графическим фреймом и содержащимся в нем изображением можно проделывать любые операции трансформирования. Они могут выполняться независимо или для обоих объектов вместе.

Если у вас есть опыт работы в Adobe Illustrator, то вы сразу заметите сходство между масками Illustrator и фреймами InDesign. По сути они эквивалентны. А импортируемые в InDesign иллюстрации с масками автоматически конвертируются во фреймы.


Масштабирование (Часть I)

Во всех графических программах прежде чем проделать какую-либо манипуляцию с объектом или объектами, их следует выделить. Таким образом вы сообщаете программе, с каким из множества существующих объектов следует выполнять те или иные преобразования. В InDesign есть два инструмента выделения: Selection и Direct Selection. Первый выделяет составные объекты (группы, фреймы и т. д.) целиком, а второй — отдельные объекты внутри составных. Таким образом, для графического фрейма возможны три варианта выделения:

  • Выделение фрейма вместе с находящимся в нем импортированным изображением. Производится щелчком мышью в любой точке фрейма при активном инструменте Selection.
  • Выделение самого фрейма с помощью инструмента Direct Selection щелчком мышью на его контуре.
  • Выделение изображения инструментом Direct Selection щелчком мышью внутри фрейма.

В зависимости от того, каким из этих вариантов вы воспользовались, обычные операции трансформирования будут работать с соответствующим объектом. Операции трансформирования уже рассматривались в главе для объектов, созданных средствами рисования InDesign. Подробно мы рассмотрим только масштабирование.

Если использовать для масштабирования инструмент Direct Selection, то размер фрейма и изображения будут меняться независимо. Иногда это удобно использовать для создания рамок и размещения изображений на цветном фоне (рис. 12.12).

а

б

в

Рис. 12.12. Независимое масштабирование фрейма и импортированного изображения

Гораздо чаще требуется масштабирование изображения вместе с фреймом. Это легко проделать, если при масштабировании удерживать клавишу <Ctrl>. He менее важно при масштабировании соблюдать пропорции изображений (рис. 12.13). Чтобы изображение масштабировалось пропорционально, удерживайте клавишу <Shift>. Эта клавиша устанавливает пропорциональный режим масштабирования независимо от того, работаете ли вы с фреймом, изображением или обоими вместе.

Рис.12.13. Пропорциональное(а) и непропорциональное(б) масштабирование изображения


Масштабирование (Часть II)

Особого внимания заслуживают монохромные (Bitmap) растрированные изображения. Изображения этого формата, будучи уже растрированными, не подвергаются растрированию при выводе на принтер (фотонаборный автомат), а печатаются "как есть". Подобные изображения создаются с учетом разрешения выводного устройства таким образом, чтобы их разрешение совпадало с разрешениями, поддерживаемыми устройства вывода или было кратно им. В противном случае алгоритм растрирования может потребовать присутствия точки изображения в том месте, где она физически не может быть напечатана принтером.

Самым простым из возможных случаев может быть такой. Монохромное изображение, созданное под максимальное разрешение принтера, уменьшается в два раза. При этом точки его растра следуют в два раза чаще, чем может их вывести принтер, что приведет к фатальному искажению растра. Подобные же ситуации возникают при увеличении изображения в некратное число раз или его непропорциональном искажении.

При создании макетов пустыми фреймами удобно размечать на страницах те места, где должны располагаться изображения и текст (в соответствии с модульной сеткой). Затем такой шаблон заполняют, импортируя и размещая в соответствующих фреймах графические и текстовые материалы. Если размер импортированного изображения не совпадает с размером фрейма, т. е. отведенного под него места, то изображение необходимо отмасштабировать по размеру фрейма. Возможно возникновение и обратной ситуации — масштабирование фрейма под изображение. Для решения таких задач InDesign предлагает специальный набор команд, располагающихся в списке Fitting. Он доступен как в меню Object, так и в контекстном меню, открывающемся щелчком правой кнопкой мыши в любой точке фрейма. Вот его команды:

  • Fit Content to Frame. Отмасштабировать изображение по размеру фрейма.
  • Fit Frame to Content. Отмасштабировать фрейм по размеру изображения.
  • Fit Content Proportionally. Отмасштабировать изображение по размеру фрейма с соблюдением пропорции.
  • Center Content. Разместить изображение по центру фрейма.

а [image] б

в [image] г

е

Рис. 12.14. Исходное состояние (а), и полученные после выполнения команд Fit Content to Frame (6), Fit Content Proportionally (в), Fit Frame to Content (г) и Center Content (д)

Обратите внимание на различия команд Fit Content to Frame и Fit Content Proportionally. Первая масштабирует изображение по размеру фрейма таким образом, чтобы оно заполнило всю площадь фрейма. Если при этом соотношение длин сторон фрейма не совпадает с таковыми для изображения, то последнее будет искажено. Вторая команда учитывает пропорции изображения. В результате ее работы изображение может заполнять не всю площадь фрейма (оставляя поля по вертикали или горизонтали), но зато без искажений.

Команду Center Content удобно использовать для создания рамок и цветных подложек для изображений. Примеры работы команд Fitting приведены на рис. 12.14.

Для точного масштабирования изображений и фреймов используйте палитру Transform. В ней имеются поля, задающие размеры объектов: ширину (W) и высоту (Н). Поля позволяют точно определить размеры изображения или фрейма, в зависимости от того, что из них выделено. Вводя в них новые значения, вы отмасштабируете выделенный объект. Иногда удобнее воспользоваться расположенными правее списками с коэффициентами масштабирования.

При масштабировании объектов с помощью палитры Transform помните о правильном выборе якорной точки переключателем Reference Point.

Масштабирование точечных изображений имеет свои ограничения. В отличие от векторных, которые можно свободно масштабировать без ущерба для качества, точечные изображения требуют учета разрешающей способности устройства вывода. Завышенное разрешение изображений приводит к замедлению их обработки программой и принтером, а заниженное — к неудовлетворительному качеству печати. Подробно о том, какое разрешение требуется для различных устройств вывода, читайте в главе 19.

Поскольку фреймы служат для импортированных изображений масками, вы можете использовать их для кадрирования. Чтобы видимым был только какой-то фрагмент изображения, достаточно уменьшить до этого размера графический фрейм. Такой способ кадрирования применяется во многих издательских системах (Quark Xpress, Corel Ventura, Adobe FrameMaker и др.), но только в In Design вы можете делать это без увеличения времени печати. Дело в том, что традиционно обработка масок возлагалась на интерпретатор PostScript. При этом ему передавалось изображение целиком вместе с информацией о кадрировании. Это приводило к неоправданному возрастанию времени печати из-за передачи большого объема бесполезных данных (маскированных областей изображений) и нагрузки на растровый процессор, вынужденный обрабатывать маски. InDesign при печати передает растровому процессору только видимые части изображения, снижая его загрузку и ускоряя печать.


Прочие операции трансформирования (Часть I)

Остальные операции трансформирования: поворот, отражение и наклон. тоже приложимы к импортированным изображениям, графическим фреймам, и им обоим одновременно (рис. 12.15).

а [image] б

в

г

д

Рис. 12.15. Поворот и наклон изображений и графических фреймов

С использованием инструментов Rotate и Shear вы уже познакомились в главе 11. С импортированными изображениями и графическими фреймами они работают точно так же, как и с объектами, созданными при помощи инструментов рисования InDesign. Отражение выполняется выбором соответствующей команды меню палитры (рис. 12.16):

  • Flip Horizontal. Отразить по горизонтали.
  • Flip Vertical. Отразить по вертикали.
  • Flip Both. Отразить по вертикали и горизонтали.

а [image] б

в [image] г

Рис. 12.16. Отражение точечных изображений: исходное изображение (а), отражение по вертикали (б), горизонтали (в) и в обоих направлениях (г)


Прочие операции трансформирования (Часть II)

Точное трансформирование объектов выполняют с помощью палитры Transform. В ней имеются раскрывающиеся списки для ввода углов поворота и наклона. Весьма удобно, что в палитре указываются текущие угол поворота и наклона относительно первоначального состояния объекта. Это позволяет, например, вернуть повернутый объект в горизонтальное состояние или узнать, на какой угол он повернут.

При трансформировании объектов с помощью мыши и с помощью палитры Transform помните о правильном выборе якорной точки переключателем Reference Point.

Заметим, что способом отсчета углов можно управлять. В меню палитры Transform есть команда-переключатель Transformations are Totals. Если он установлен, то угол поворота вращаемого объекта добавляется и к текущему углу всех вложенных объектов. Приведем простой пример. Допустим, мы последовательно повернули изображение, а затем его фрейм на углы по 45°. Если установлен режим Transformations are Totals, то для изображения угол поворота, который показывает палитра Transform, будет равен 90°. Если режим Transformations are Totals не установлен, то угол окажется равным 45° Иными словами, этот режим задает способ измерения величины трансформации вложенных объектов относительно страницы, либо относительно внешнего объекта.

Команды списка Fitting правильно работают для повернутых и наклоненных изображении рис. 12.17. Фрейму автоматически придаются те же форма и положение, что и самому изображению.

а

б

в

г

Рис. 12.17. Работа команды Fit Frame to Content для повернутых (а) и наклоненных(б)изображений

Хотя трансформировать точечные изображения в InDesign легко и удобно. старайтесь делать это до импорта в специализированном приложении, например, Adobe Photoshop. Можно порекомендовать и "промежуточный" вариант: создать черновик макета, трансформируя изображения в InDesign, a потом, когда окончательные параметры трансформирования определятся. воспроизвести их в Photoshop. Разумеется, после этого придется импортировать в InDesign повторно.

Такая рекомендация связана с тем, что трансформирование при печати проделывает не InDesign, а растровый процессор устройства вывода. Чтобы ускорить печать и снизить вероятность сбоев, эти, требующие много памяти и времени операции, лучше выполнять заранее.


Контуры обтравки (Часть I)

В большинстве макетов используются точечные изображения не только прямоугольной формы. Получение таких изображений необходимо при уюнтировании их друг поверх друга или на цветном фоне. Поскольку точечные изображения всегда имеют прямоугольную форму, задача сводится к маскированию фрагментов фона на изображении. Контур такой маски называется обтравочньш. Такое название он получил с тех времен, когда растровые клише фотографий подвергали дополнительному травлению, чтобы удалить с него фрагменты, соответствующие фону.

Один из путей создания таких изображений очевиден. Поскольку графический фрейм по существу является маской, нужно просто создать фрейм нужной формы. В главе вы уже прочли, как это делается. Воспользовавшись инструментами группы Pen, вы можете придать фрейму любую форму. Вы умеете добавлять и удалять узлы, менять их положение и кривизну сегментов. Для изображений с несложной формой обтравочных контуров это вполне приемлемый способ (рис. 12.18).

Рис. 12.18. Обтравленное изображение с простым (эллиптическим) контуром обтравки

Если контур обтравки достаточно сложен, то его обрисовка вручную займет много времени и будет непродуктивна. Работу можно существенно упростить и ускорить, если в программе редактирования точечных изображении поместить точечный объект на монохромный или близкий к монохромному фон. Некоторые библиотеки изображений на Photo CD уже содержат объекты, сфотографированные на белом фоне. Для таких изображений обтравка легко выполняется с помощью инструмента Clipping Path. Его диалоговое окно (рис. 12.19) открывается одноименной командой меню Object.

Два основных элемента управления в этом диалоговом окне — ползунки Treshold и Tolerance. Первым задается пороговая яркость. Пикселы светлее этого значения считаются принадлежащими фону и маскируются, а более темные пикселы остаются видимы (рис. 12.20). Ползунок Tolerance управляет допуском яркостей пикселов относительно порогового значения. На практике он определяет точность контура обтравки. Чем точнее контур, тем больше он имеет узлов, менее гладок и труднее редактируется (рис. 12.21).

Рис.12.21. Обтравка изображения с различными значени

Рис. 12.22. Сжатие обтравочного контура: нулевое, положительное, отрицательное.

В поле Inset Frame указывается величина сжатия обтравочного контура. Небольшое уменьшение размеров обтравочного контура позволяет скрыть его неточности (рис. 12.22). Флажок Invert меняет маскированную область на видимую и наоборот. Используйте его, если объект имеет более однородный цвет, чем фон. В этом случае имеет смысл построить маску для объекта и инвертировать ее установкой флажка Invert. Флажок Include Inside Edges устанавливают, если обтравливаемый объект имеет "дырки", через которые виден фон. Для них создаются такие же "дырки" в маске. Флажок Use High Resolution Image установлен по умолчанию. Если его сбросить, то обтравочный контур будет построен на основании экранного представления изображения с низким разрешением. Такой режим пригоден только для черновой обтравки. В окончательном варианте для изготовления оригинал-макета всегда используйте изображения высокого разрешения.


Контуры обтравки (Часть II)

Далеко не всегда для обтравки используются изображения на белом фоне. Гораздо чаще фон может иметь произвольный цвет или вообще мало отличаться от цвета обтравливаемого объекта. В этом случае инструмент Clipping Path в InDesign окажется бессилен. Обтравка вручную также неудобна, поскольку может занять очень много времени. В таких случаях обтравочные контуры создают в программах редактирования точечной Графики (Adobe Photoshop, Corel PhotoPAINT и т. п.). Они имеют мощные инструменты выделения фрагментов изображения, позволяющие гораздо быстрее создавать очень точные маски. Полученный обтравочный контур сохраняется в файле вместе с изображением. При импорте в InDesign вам предоставляется возможность использовать сохраненный обтравочный контур. Для этого надо только установить флажок Create Frame from Clipping Path в диалоговом окне Image Import Options. Помните, что вы получите доступ к этому диалоговому окну, только если флажок Show Import Options в диалоговом окне Place будет установлен.

Для того чтобы получить такое изображение в Photoshop, необходимо создать в его документе обтравочный контур с помощью инструмента Pen или, конвертировав в контур границу выделенной области (Selection) средствами Photoshop. Далее следует, выбрав команду Save Path меню палитры Paths, сохранить контур., Следующим шагом будет выполнение команды Clipping Paths того же меню, которая позволяет выбрать контур, который требуется определить как обтравочный. И в заключение остается сохранить файл в формате TIFF или Photoshop EPS.

Импортированный обтравочный контур представляется в InDesign графическим фреймом соответствующей формы (рис. 12.23). Вы можете обращаться с ним, как и с созданным средствами InDesign: редактировать его с помощью инструмента Direct Selection, трансформировать, заполнять цветом или градиентом.

а [image] б

Рис. 12.23. Обтравочный контур в Photoshop (а) и InDesign (б)


Использование библиотек

Графические материалы можно помещать в публикацию не только из внешнего приложения, но также из палитры библиотеки. Некоторые аспекты работы с палитрой библиотеки для текстовых материалов уже обсуждались нами в главе 8. Общие принципы работы сохраняются и для изображений. В палитру можно поместить любое имеющееся в публикации изображение и затем снова вставлять его в эту же или любую другую публикацию. Поместить изображение в палитру можно, нажав пиктограмму с изображением страницы в нижней строке палитры при выделенном в публикации изображении (рис. 12.24), а также перетаскиванием объекта мышью в окно палитры или командой Add Item меню палитры. Элементы библиотеки отображаются в палитре в виде миниатюр или списка, в зависимости от выбора, сделанного в меню палитры:

Thumbnail View или List View, соответственно. После того как изображение добавлено в библиотеку, ему можно сопоставить название, тип и описание. Первоначально изображение помещается в палитру с именем "Untitled", с автоматически определенным типом и незаполненным полем описания. Эти данные можно изменить в любой момент, дважды щелкнув мышью на миниатюре элемента в палитре библиотеки (рис. 12.25) или нажатием кнопки с изображением буквы "i" в нижней части палитры.

По этим атрибутам в любой момент можно осуществлять поиск. В результате поиска в палитре остаются только те элементы, которые удовлетворяют критериям поиска. Вслед за этим вы можете дополнительно конкретизировать критерии поиска и осуществить его уже только среди найденных на первом этапе элементов. Такой многоступенчатый последовательный поиск можно производить сколько угодно раз. Чтобы снова вернуться к отображению всех элементов библиотеки, выберите команду Show All меню палитры. Диалог параметров поиска открывается командой Show Subset меню палитры (рис. 12.26) или нажатием кнопки с изображением бинокля в нижней части палитры.

Рис. 12.24. Палитра Library и меню палитры

Рис. 12.25. Окно свойств элемента библиотеки

Область Parameters диалогового окна Subset позволяет задавать от одного до пяти критериев поиска. Каждый критерий вводится выбором из двух списков и заполнением поля ввода, находящихся в одной строке. В первом левом) списке выбирается ключ поиска. Это может быть имя элемента iltem name), дата создания (Creation date), тип элемента (Object type) и его описание (Description). В поле ввода (справа) вводится текст, поиск которого выполняется в заданном ключе. Во втором списке (в центре) выбирается вариант сравнения: искомый текст должен либо входить, либо не входить в заданный ключ для элементов библиотеки.

Рис. 12.26. Диалоговое окно Subset

По умолчанию в диалоговом окне показывается строка только для одного критерия. Каждое нажатие кнопки More Choices открывает строку для еще одного критерия. Пяти таких критериев вполне достаточно для самого сложного поиска. При поиске вы можете задать условия совместного выполнения нескольких критериев. Установка переключателя Match All ставит условием нахождения элемента обязательное сочетание всех критериев поиска. Если установлен переключатель Match Any One, для этого достаточно совпадения любого из критериев. Если вам потребуется более сложное сочетание критериев (например, обязательное одновременное совпадение двух и необязательное еще одного), то вы можете действовать методом последовательных приближений.

И, наконец, ненужные элементы палитры удаляются из нее командой Delete Item(s) меню палитры при выделенном в палитре элементе, подлежащем удалению. Еще быстрее это можно сделать щелчком на кнопке с изображением мусорной корзины в нижней части палитры.

Импортированные изображения не копируются в файл палитры, а только связываются с ее элементами. Если удалить оригинальный файл изображения с диска, перенести его в другую папку или переименовать, то связь с элементом палитры нарушится. Чтобы библиотека работала правильно, следите за тем, чтобы все связанные с ней изображения сохраняли свои имена и положение на диске.

Для создания новых библиотек и открытия существующих имеются команды New Library и Open Library в меню палитры. Библиотека хранится в файле, имя и положение которого вы задаете при создании в стандартном диалоговом окне Windows. Оно предоставляется сразу после выбора команды New Library. Чтобы открыть библиотеку, достаточно указать на любой сохраненный файл библиотеки в аналогичном диалоговом окне. Вы можете открыть одновременно любое количество библиотек (пока не закончится свободная память) и перемещать их элементы из одной в другую перетаскиванием мышью.

Размещение элементов библиотеки на странице публикации осуществляется перетаскиванием из окна палитры в пространство страницы или командой Place Item(s) меню палитры. Библиотеки могут хранить практически все типы объектов InDesign и любые их комбинации:

  • Импортированные изображения. Способ связывания при этом сохраняется (см. главу 13).
  • Объекты, созданные инструментами рисования InDesign.
  • Текстовые блоки. Сохраняется все локальное форматирование и стилевое оформление. При помещении текста из библиотеки в другой документ, все стили текста добавляются к стилям документа.
  • Направляющие линии. Сохраняйте модульные сетки в библиотеке.
  • Координатные сетки и сетки базовых линий.
  • Целые страницы макетов. Добавление страницы осуществляется командой Add All Items on Page меню палитры. Взаимное расположение объектов при этом тоже сохраняется.

При сохранении объектов в библиотеке полностью сохраняется все форматирование, как полученное при импортировании, так и примененное в InDesign. Информация о нахождении объектов на слоях тоже сохраняется и воспроизводится при размещении библиотечных элементов на странице публикации. Наличие тематических библиотек сильно упрощает работу.


Резюме

  • Векторные изображения состоят из объектов. Каждый объект строится программой в соответствии с его математическим описанием. Качество вывода векторных изображений не зависит от устройства вывода. Точечные изображения состоят из цветных точек, пикселов. Количество пикселов на единицу длины называется разрешением. Разрешение точечных изображений должно соответствовать устройству вывода.
  • Точечные изображения имеют различный размер и тип в зависимости от глубины цвета. Глубина цвета определяет количество цветов, доступных для данного типа изображений и определяется количеством бит, которым описывается один пиксел точечного изображения.
  • При хранении изображений в файлах исключительно важен используемый формат. Форматы файлов точечных изображений отличаются компактностью, типами хранимых изображений, доступными цветовыми моделями, возможностью хранения масок, слоев, контуров обтравки.
  • Каждая программа создания и редактирования векторных изображений имеет свой формат файлов. Наиболее стандартизован и популярен формат EPS, основанный на языке PostScript. Он чаще всего и используется для помещения векторных изображений в издательские системы. Наряду с EPS, форматы AI и PDF, также основанные на PostScript, являются "родными" для всех программ производства Adobe (InDesign, Illustrator, Photoshop), и рекомендуются для использования с InDesign.
  • При импортировании командой Place графических файлов в InDesign хранящиеся в них изображения помещаются на страницу внутри графического фрейма. Фрейм представляет собой маску для находящегося в нем изображения. Фрейм и изображение можно независимо или одновременно трансформировать. Изображение, помещенное в существующий текстовый фрейм, становится вложенным. InDesign оно представляется просто символом шрифта.
  • Для получения точечных изображений непрямоугольной формы используются маски, закрывающие фоновую часть изображений. Маску можно создать ручным редактированием формы графического фрейма, специальным инструментом Clipping Path или импортировать вместе с изображением. Чаще всего используется последний способ.
  • Если импортировать векторные изображения через буфер обмена или перетаскиванием, то их можно будет редактировать инструментами InDesign.
  • Библиотеки предоставляют удобный и гибкий способ хранения и повторного использования любых элементов публикации от импортированных изображений до направляющих линий и стилей текста.


Глава 13

Связывание файлов

Импортируя в документ InDesign графическое изображение или текст, вы формируете связь — программно реализованное отношение между исходным материалом и публикацией. Связи позволяют InDesign находить внешние файлы при отображении публикации и выводе ее на принтер, а также следить за их версиями, обновляя сведения о них в публикации всякий раз, когда изменяется содержимое связанных файлов.

Ниже описаны:

  • Понятие связанных файлов
  • Необходимость связывания внешних файлов
  • Управление связанными файлами из InDesign


Для чего используются связи?

Говоря о связях с импортированными в публикацию файлами, мы будем почти всегда иметь в виду связи с графическими файлами. Несмотря на то что InDesign предполагает связывание и текстовых файлов, эти связи используются значительно реже. Это происходит потому, что при обновлении связей с текстовыми файлами происходит их повторный импорт в публикацию, который приводит к потере тех настроек текста, которые были установлены средствами InDesign. Возможно, настройками можно пожертвовать, если текст внутри связанного файла изменился практически полностью. Если же добавилась всего пара абзацев, то затраты времени на повторную настройку всего текста не могут быть оправданы.

Чаще всего, наоборот, верстальщик стремится оградить сверстанный текст от автоматического обновления при изменении связанного текстового файла. Для этого либо он разрывает эту связь сразу после помещения материала в публикацию, либо отказывается от автоматического обновления материала, решая этот вопрос самостоятельно при каждом изменении связанного файла.

В случае связей с графическими файлами, подобные проблемы не возникают, поскольку вся их обработка выполняется во внешних приложениях, и обновление связи не приводит к потере какой-либо настройки. Разумеется. размеры, обрезку и размещение изображений InDesign сохраняет и при обновлении связей.


Экономия места на диске

При импорте изображения в публикацию мы храним его на диске в двух копиях: в исходном файле и внутри публикации. Наличие исходного файла позволяет его редактировать и повторно использовать в другой или той же публикации, а вставленная в публикацию копия необходима для отображения материала в InDesign. Полного дублирования и расточительной траты дискового пространства для хранения двух копий импортированных файлов можно избежать, если использовать механизм связей InDesign. Он позволяет InDesign при печати публикации пользоваться внешним файлом, а для экранного отображения — только хранящейся в публикации миниатюрой изображения, выигрывая при этом место, равное разности размеров полного изображения и миниатюры. Если публикация предназначена для типографской печати (разрешение графических файлов составляет около 300 точек/дюйм), то эта разница настолько велика, что размером миниатюры можно просто пренебречь. Готовые для цветоделения файлы цветных изображений могут занимать от 10 до 60 Мбайт дискового пространства, и если эти, и без того огромные затраты удваивать, то надолго ли хватит свободного места на жестком диске?

Использование связей дает экономию места на диске и при многократном использовании одинаковых изображений. Представьте себе, что в макете 300-страничного тома документации вы используете в качестве фоновой графики для заголовков разделов одинаковые графические текстуры. Нетрудно догадаться, что без использования связей публикация будет содержать эту текстуру в сотне копий. Если сама текстура занимает 250 Кбайт, то ее присутствие в публикации увеличит размер последней на 25 Мбайт! Это пространство экономится благодаря связям, которые позволят вообще не включать полный файл текстуры в публикацию.


Удобство внесения изменений

Содержание многих изданий динамично. Например, при верстке рекламного журнала, каждая страница которого состоит из десятка рекламных модулей, часто приходится "на ходу" производить замены модулей и перестановки. Без использования связей верстальщику пришлось бы постоянно контролировать, последняя ли версия модуля находится в публикации, открывая его в той программе, где он был создан. Если, как в нашем примере, таких модулей сотни, то избежать ошибки просто невозможно.

InDesign с помощью механизмов связывания сам следит за актуальностью ссылок на внешние файлы и автоматически обновляет их при изменении содержания этих файлов. Даже если вы не хотите целиком полагаться на InDesign и "терять контроль" над процессом обновления публикации, InDesign окажет большую услугу, просто показывая те связи, которые требуют обновления. Само обновление вы сможете сделать в любой момент вручную и даже выборочно.


Верстка в рабочих группах

С версткой 200-страничного иллюстрированного журнала не может справиться один человек. Для выполнения подобной работы всегда организуется группа, состоящая из художников, дизайнеров, корреспондентов, фотографов, ретушеров и верстальщиков. Разумеется, можно заставить их всех работать на одном компьютере, но единственный разумный выход — распараллеливание работы с использованием нескольких рабочих мест, связанных локальной сетью. В этом случае очень пригодится способность InDesign поддерживать связи как между публикацией и внешними файлами иллюстраций, так и между частями публикации. Художник может неоднократно изменять вид иллюстраций, а верстальщик всегда будет использовать в макете их последние версии.


Создание связей

Связи с внешними файлами создаются InDesign автоматически в момент импортирования. Импортирование графических файлов описано в главе 12, а текстовых — в главе 9.


Методы связывания

Современные операционные системы имеют стандартные средства обмена графической и текстовой информацией между приложениями. На платформе Windows это технология OLE (Object Linking and Embedding), а на компьютерах Macintosh — Publish and Subscribe. Эти средства достаточно хорошо и устойчиво работают во множестве офисных приложений, но редко используются в графических и издательских программах. Этому есть множество причин:

  1. Внедрение объектов OLE приводит к значительным затратам дискового пространства. OLE не предполагает сжатия информации.
  2. Редактирование OLE-объекта возможно средствами только одного приложения — OLE-сервера. Если вы принесли публикацию на компьютер, где не установлен Adobe Illustrator, то отредактировать внедренный из него в публикацию OLE-объект будет невозможно.
  3. Поскольку OLE работает только с графическим представлением объекта, он не может занимать в публикации более одной страницы/разворота.
  4. Встраивание объектов требует одновременной работы и программы-сервера и программы-клиента, что требует больших затрат оперативной памяти компьютера и вашего терпения. Кроме того, объект при этом находится в оперативной памяти в трех(!) копиях: в приложении-сервере, приложении-клиенте и в буфере обмена. Если изображение достаточно велико, то нехватка памяти может привести не только к очень продолжительному времени внедрения объекта, но и к краху системы.
  5. Изображение не может быть помещено в публикацию при отсутствии программы-сервера. Фильтры же позволяют импортировать изображения и без открытия их в какой-либо другой программе.
  6. Поскольку OLE-объект должен целиком храниться в публикации, при его многократном использовании размеры файла публикации возрастают катастрофически.
  7. Объекты OLE иногда вызывают проблемы при выводе на печать, да и время их обработки принтером (фотонаборным автоматом) существенно больше.
  8. И, наконец, "где тонко, там и рвется". По нашему, и не только нашему опыту, заметим, что документы с внедренными объектами обладают значительно меньшей устойчивостью к программным и аппаратным сбоям. Используя их, вы во много раз увеличиваете риск потерять его полностью.

Из-за перечисленных проблем со стандартными системными средствами связывания и внедрения документов разработчики издательских систем и программ иллюстрирования предлагают собственные технологии. Одной из первых разработок был механизм связывания, реализованный фирмой Aldus в первой издательской системе для персональных компьютеров — PageMaker (ныне, после слияния компаний этот продукт принадлежит Adobe Systems Inc.). Технология связывания PageMaker Links отлично зарекомендовала себя за два десятилетия применения, успешно конкурируя с нововведениями OLE. Пользователи PageMaker (начиная с версии 5.0) имели возможность выбирать между OLE и Links. В InDesign, видимо для того чтобы не вводить падкого на современные технологии пользователя в соблазн, разработчики вообще исключили механизмы связывания OLE и Publish/Subscribe. В подавляющем большинстве случаев пользователям InDesign не придется жалеть об отсутствии этих возможностей: InDesign имеет множество фильтров импорта и поддерживает огромное количество форматов. Это сводит к минимуму единственное преимущество OLE перед технологией Links — совместимость с любыми приложениями.


Drag and Drop

Возможность перетаскивания мышью объектов из окна одного приложения в окно другого стала неотъемлемой чертой любой сколь-либо серьезной программы. InDesign не является исключением. Вы можете перетаскивать не

только связанные объекты из одной публикации в другую (при этом связи с внешними файлами сохраняются), но и объекты из других приложений в окно публикации. Примером такого способа импортирования служит перетаскивание пиктограмм графических файлов из папки (рис. 13.1).

Рис. 13.1. Перетаскивание графических файлов из папки Windows Explorer в InDesign

Поскольку InDesign не поддерживает механизм OLE, перетаскивание эквивалентно использованию соответствующего фильтра импорта.


Демонстрация связанных изображений

Смысл образования связи состоит в том, что в публикацию помещается не сам файл, а лишь данные о его положении на диске, имени и дате последней модификации. Разумеется, ссылка практически не занимает места в публикации. Для графических файлов это дает очень серьезный выигрыш места на диске. Для отображения файла внутри публикации при стандартном методе отрисовки изображений (см. главу 3) используется не сам файл, а его миниатюра, копия файла с низким разрешением. Миниатюра занимает во много раз меньше места, чем исходный файл и во столько же раз быстрее отрисовывается в InDesign при перемещениях, поворотах, масштабировании и искажении. Таким образом достигается компромисс между удобством работы и скоростью. Если вы все-таки захотите увидеть, как будет выглядеть изображение в макете при максимальном разрешении, допускаемом монитором, включите режим отрисовки Full Resolution Images, и InDesign, на основании данных связывания, отрисует изображение в высоком разрешении, используя внешний файл (рис. 13.2).

а

б

в

Рис. 13.2. Режимы демонстрации изображений: Full Resolution Images (a), Proxy Images (б), Gray Out Images (в)

Разрешение, с которым InDesign демонстрирует изображение на странице документа, задается в разделе General диалогового окна Preferences. Варианты отображения представлены в списке Display области Images.

  • Full Resolution Images. Изображения демонстрируются с максимальным разрешением. Если изображения не внедрены в публикацию, а связаны с ней, то для демонстрации используются данные из внешнего файла изображения. Этот способ обеспечивает наилучшее качество, но недостаточно быстр. Его стоит использовать для окончательного просмотра макета, оценки цветопередачи и мелких деталей.
  • Proxy Images. В этом режиме для отображения размешенной на страницах публикации графики используются копии внешних файлов, внедренные в файл документа и выводимые с пониженным разрешением. Режим оптимален для большинства задач верстки.
  • Gray Out Images. Во время работы над текстом верстальщику не обязательно присутствие изображений, ему достаточно знать их точные размеры. Именно в таких случаях устанавливается режим показа габаритов изображений. В нем графика замещена серыми прямоугольниками, точно совпадающими по размеру с оригинальными изображениями.

Выбрав нужный режим в разделе установок, вы создаете глобальное или локальное умолчание. Чтобы быстро переключаться между режимами отображения, используйте клавиатурное сокращение <Ctri>+<Shift>+<F5>.

Приведенные режимы демонстрации действуют не только для связанных, но и для внедренных файлов. Технология Links предполагает возможность включения и полной копии внешнего файла в публикацию. Более того, место хранения изображения (в публикации или во внешнем файле) можно в любой момент изменить как для всех, так и для отдельных связей.


Управление связями

InDesign унаследовал от своего предшественника множество удачных решений, в т. ч. бесценный инструмент управления импортированными файлами. Речь идет о специальной палитре Links, изображенной на рис. 13.3.

Рис. 13.3. Палитра Links


Палитра Links

Палитра Links содержит список всех связанных и внедренных файлов и показывает текущее состояние связей. Если палитры нет на экране, то откройте ее командой Links меню File.

В меню палитры Links имеются три варианта сортировки, действующие совместно с перечисленными выше режимами отображения:

  • Sort by Name. Сортировка по имени файла.
  • Sort by Page. Сортировка по порядку употребления в документе.
  • Sort by Status. Сортировка по состоянию связи с внешним файлом.

При необходимости получить более подробные сведения о помещенном в документ файле достаточно выполнить двойной щелчок мышью на строке с именем файла в палитре Links или выбрать команду Link Information в ее меню. В открывшемся диалоговом окне (рис. 13.4) вы легко найдете следующую информацию:

  • Name. Имя внешнего файла. П Status. Текущее состояние связи (актуальна, устарела, разорвана).
  • Date. Дата и время создания связи, т. е. размещения изображения в документе.
  • Size. Размер внешнего файла.

Рис. 13.4. Информация о помещенном в иллюстрацию файле

  • Page. Страница, на которой находится импортированное изображение.
  • Edited. Был ли связанный текстовый документ отредактирован средствами In Design.
  • Link Needed. Необходим ли связанный документ для правильного вывода публикации. Текстовые материалы всегда внедряются в файл публикации и не требуются для печати.
  • Color Space. Цветовая модель импортированного изображения.
  • Profile. Цветовой профиль, внедренный в импортированное изображение, или присвоенный ему в InDesign.
  • File Type. Тип внешнего файла.
  • Location. Положение файла на диске.

В диалоговом окне Link Information есть кнопки Prev и Next, позволяющие циклически просматривать информацию обо всех изображениях, находящихся в публикации.


Обновление связей

Палитра Links (см. рис. 13.3) позволяет не только локализовать возникающие проблемы, связанные с устареванием связей и их нарушением, но и . успешно их разрешать. Связи устаревают в том случае, если внешний файл был отредактирован уже после помещения его в InDesign. Это типичная и совершенно нормальная ситуация. По ходу верстки часто приходится редактировать графические файлы. Если бы не существовал механизм обновления связей, то после каждого редактирования их снова пришлось бы размещать в публикации.

Устаревшие связи в палитре Links отмечены пиктограммой с восклицательным знаком, как и на рисунке выше. Для обновления устаревшей связи достаточно выделить устаревшие связи в окне палитры и выбрать команду Update Link меню палитры. Также можно просто щелкнуть на соответствующей кнопке в нижней строке окна палитры. Обратите внимание, что InDesign позволяет выделить в палитре несколько файлов одновременно. Для этого следует при щелчке мышью удерживать клавишу <Ctrl>.


Восстановление связей

Если имя внешнего файла изменено, или он перенесен в другую папку, то связь с ним в InDesign будет разорвана. Разорванные связи показаны в палитре Links пиктограммой с изображением вопросительного знака. Если устаревшая связь несет в себе потенциальные проблемы (вы видите на экране совсем не то, что будет напечатано), то разорванная связь приводит к тому, что на печати вместо изображения появится серый прямоугольник.

Восстановить разорванные связи вам помогут команды Go To Link и Re place, находящиеся в меню палитры. Они дублируются пиктограммами в нижней части палитры. Первая команда позволяет быстро найти в иллюстрации выделенный в палитре файл. Команда выделяет заданное изображение в документе. Команда Replace заменяет одно связанное изображение другим. Чаще всего она используется для восстановления разорванных связей. В открываемом этой командой диалоговом окне следует указать новое место расположения и имя перенесенного или переименованного файла, а затем нажать кнопку Open. Связь будет восстановлена.

В принципе, команда годится и для замены изображений. При этом следует учитывать, что новое изображение будет иметь те же размеры, что и замененное. Если их пропорции не совпадают, то новое изображение будет искаженным. Обтравочные контуры при замене изображений не учитываются, а размер нового изображения подгоняется под размер предыдущего.


Внедрение изображений

Палитра Links позволяет контролировать место хранения индивидуально для каждого изображения. Команда Embed Image внедряет связанное изображение в файл иллюстрации. Обратная операция невозможна и требует повторного помещения внешнего файла в документ.

Внедренные изображения хранятся в файлах публикаций в неупакованном виде. Это приводит к существенно большим затратам дискового пространства на хранение файлов. Учтите, что даже если вы предпочли внедрить изображение в документ, следует обязательно оставить его копию для редактирования.

Часто пользователи внедряют изображения в документ перед тем как, перенести его на другой компьютер или отдать в сервис-бюро. При этом они имеют дело не с большим количеством файлов, разбросанным по вложенным папкам, а с одним-единственным. В действительности, и для этой цели внедрение не столь уж необходимо. В InDesign имеется специальная функция Package, автоматически выполняющая сборку всех внешних файлов публикации в одной папке. Связи в публикации она также обновляет и переносит совершенно автоматически. Вам останется только переписать содержимое папки на любой носитель или передать по сети. Этот путь имеет и еще одно важное преимущество. Команда Package включает в "упаковку" и все, использованные в публикации, шрифты. Если вы намерены отдать публикацию для вывода в сервис-бюро или передать заказчику, то это совершенно необходимо.


Редактирование оригинала

И наконец, нажав правую кнопку в палитре Links или выбрав команду Edit Original меню палитры, вы загрузите выделенный файл в программу редактирования. Если программа к этому времени не запущена, то это будет сделано автоматически. Обновление связи после редактирования автоматически не производится и его необходимо выполнить вручную.

Запуск программы по команде Edit Original из палитры Links на платформе Windows производится в соответствии с установленными в системе ассоциациями для типов файлов. Если тип файла не имеет ассоциированного приложения, то команда не будет выполнена.


Резюме

  • При размещении в публикации файлов изображений и текста, InDesign формирует связь.
  • Для управления связями используется палитра Links. Она содержит перечень всех файлов, связанных с публикацией.
  • При связывании внешних файлов с публикацией последняя не хранит копии внешних файлов в оригинальном разрешении. Это сокращает размер публикации и увеличивает скорость работы. Для демонстрации изображений из внешних файлов используются копии изображений с маленьким разрешением, которые хранятся в файле публикации. Разрешение копий, хранящихся в файле публикации, задается при импорте графических файлов.
  • Внешний файл можно внедрить в публикацию целиком с помощью соответствующей команды палитры Links. В большинстве случаев это делать не требуется.
  • InDesign автоматически отслеживает состояние связи. При обновлении внешнего файла он сообщает о том, что экранная копия в публикации устарела. Палитра Links предоставляет средства обновления устаревших связей.
  • Если внешний файл удалить или перенести в другую папку, его связь с публикацией будет нарушена. Для возобновления связи необходимо указать InDesign новое местоположение файла или другой файл.


Глава 14

Создание новой публикации

Итак, подробно обсудив аспекты форматирования всех элементов публикации — символов, абзацев, стилей, графики, импорта текста, перейдем к изучению основного процесса, для которого созданы издательские системы — верстки. Она заключается в построении готовой публикации из "кубиков" — текстовых материалов и графики. К готовому продукту — сверстанной публикации — предъявляются высокие полиграфические требования, для выполнения которых и предназначена InDesign — профессиональная программа подготовки оригинал-макетов. Процесс верстки начинается с создания публикации. В настоящей главе рассматриваются следующие вопросы:

  • Задание параметров публикации в диалоговых окнах Preferences и Document Setup
  • Способы создания публикации — "от нуля" и с использованием шаблонов публикаций
  • Изменение параметров документа. Автоматическая настройка макета. Ее режимы. Диалоговое окно Layout Adjustment Preferences
  • Изменение параметров документа как действие опасное и мало предсказуемое. Некоторые последствия изменения параметров документа


Задание установок по умолчанию

Перед тем как приступать к собственно созданию нового документа, настройте глобальные умолчания программы в окне Preferences и умолчания меню в соответствии с вашими привычками и особенностями публикации. Если вы зададите умолчания InDesign в отсутствие открытых файлов, то действие их распространится на все впоследствии создаваемые публикации (глобальные умолчания). Если же вы сначала создадите документ, а потом зададите умолчания для него. то они будут действовать только на данный документ (локальное умолчание). Итак, в зависимости от того, какой уровень умолчания вы собираетесь задавать, делайте это при открытой или закрытой публикации. Общие принципы организации системы умолчании изложены в главе 3.

В диалоговом окне Preferences вы сможете изменить следующие элементы интерфейса и режимы работы:

Единицы измерения. По поводу системы измерений справедлива пословица о кулике, который хвалит свое болото. Если вы не имеете полиграфического образования или богатого опыта работы, то скорее всего это будут миллиметры. Однако необходимо отметить, что в издательстве вам все равно придется время от времени делать измерения в полиграфических единицах. В этом случае пригодится возможность временной замены системы единиц InDesign (см. главу 3). Если есть необходимость применения невидимой сетки (для выравнивания строк по вертикали), то можно сделать специальную настройку системы измерения по вертикали. Правда, это можно сделать и позже, в процессе работы.

Выделение погрешностей верстки. Если предстоит окончательная верстка, обязательно включите этот режим. Отслеживание дефектов верстки строк станет заметно легче. В случае предварительной верстки выделение дефектных строк является совершенно лишним (не бывает, чтобы после предварительной верстки не возникла необходимость переверстать большую часть текстового материала из-за смещений в результате корректуры).

Разрешение графики на экране. Для начала, вероятно, есть смысл установить стандартный режим отображения, чтобы представлять себе примерный вид публикации. Разместив графику, замените режим на отображение плашками. При окончательной доводке можно включить режим высокого разрешения экранной графики.

Положение направляющих — на переднем или заднем плане рабочего пространства документа. Обычно используется первый режим, но если на странице много объектов, можно переместить направляющие на задний план, чтобы они не мешали работе по размещению.

Шаг смещения параметров объектов при нажатии клавиш курсора. Эта величина зависит от необходимой точности работы и от размера страницы публикации. Чем меньше этот размер, тем меньшее значение должно быть введено в этом поле.

Выравнивание по линейкам и направляющим. Часто изменяемый параметр, для начала установите данный флажок во включенное положение.

Преобразование кавычек из прямых в типографские “” ("лапки"). Если вы верстаете сколь-либо важную работу, этот режим должен быть включен.

Умолчания палитр. Можно задать по умолчанию палитры, которые будут впоследствии выводиться на экран сразу после открытия InDesign, и их расположение. Работа с палитрами повышает скорость верстки, однако то, какие палитры вам понадобятся, зависит от конкретной задачи. Поскольку

палитры закрывают собой часть полезного рабочего пространства, не оставляйте на экране лишних.

Умолчания текста и графики. Разработайте систему стилей для вашего документа. Об этом этапе рассказано в главе 8. Если в публикации вы собираетесь неоднократно пользоваться инструментами рисования, введите умолчания для каждого из них. Разработайте цвета документа, хотя бы приблизительно, и тоже определите их умолчаниями. Определение умолчаний описано в главе 3. Приемы работы с графическими объектами и команды меню Object рассмотрены в главах 11 и 12.


Новая публикация

Когда вам требуется начать работу с новой публикацией, первый вопрос, который нужно решить, — собираетесь ли вы создавать абсолютно новый документ, задавая все параметры с самого начала или воспользуетесь имеющимся шаблоном документа, в котором уже определены параметры форматирования. В первом случае следует выполнить команду New. Во втором — открыть шаблон. Если нужный шаблон публикации создан вами, он открывается командой Open.


Разработка шаблонов страниц и модульной сетки

Обычно на каждой странице публикации есть повторяющиеся элементы:

направляющие, колонки, графика, колонтитулы, колонцифры и др. Они могут и должны быть вынесены на шаблон-страницу. В InDesign есть возможность создавать несколько шаблон-страниц в дополнение к основной, если структура документа этого требует. Кроме того, команда Create Guides позволяет создавать модульные сетки — наборы направляющих, располагающихся под страницами документа. С помощью модульной сетки создается базовая структура страницы и обеспечивается единообразие страниц (например, -одинаковое число, расположение и размеры колонок текста). Такие шаблоны можно сохранять в отдельных файлах и потом применять к любым страницам в любой публикации.

В главе 15 подробно рассмотрены приемы построения модульной сетки и связанные с ними пункты меню Layout. При помощи команд этого меню вы можете управлять режимом показа линеек, а также использованием линеек и направляющих для фиксации положения объектов на странице. С помощью шаблон-страницы действие набора направляющих, размещенных на одной странице, можно распространить на последовательность смежных страниц.


Параметры нового документа

Определившись с глобальными умолчаниями, вызовите команду New меню File. Перед вами откроется диалоговое окно New Document, в котором и задается описание формата страницы будущего документа. Это диалоговое окно изображено на рис. 14.1.

Рис. 14.1. Диалоговое окно New Document

Ниже мы обсудим параметры, определяемые в этом диалоговом окне.

Задание числа страниц в публикации. Число страниц устанавливается в поле Number of pages в самом верхнем поле диалогового окна New Document. Если эта цифра точно известна, проставьте ее в соответствующей строке ввода. С другой стороны, заранее задавать число страниц публикации вроде и ни к чему, поскольку при размещении текста, импортированного из формата текстового процессора, InDesign способен автоматически добавлять в документ новые страницы по мере заполнения их текстом (только в режиме автоматического размещения).

Установка оборотной печати. Если включить и флажок Facing Pages — то на экране отображаются одновременно обе страницы каждого разворота, внешний вид главного окна будет напоминать книгу, раскрытую на определенной паре страниц. Включенный режим Facing Pages позволяет создавать документы типа книги — с печатью на обеих сторонах бумаги.

Фрейм на шаблон-странице. Флажок Master Text Frame создает на шаблон-странице нового документа текстовый фрейм. Размер этого фрейма определяется установленными размерами страниц и полей публикации. Фрейм становится "заготовкой" для последующего автоматического размещения текста. Автоматическое создание фрейма имеет смысл, если верстается преимущественно текстовый материал в одну колонку. В противном случае удобнее задать количество и положение текстовых фреймов на шаблон-странице вручную перед импортом текста.

Формат страницы. В раскрывающемся списке Page Size устанавливается размер страниц публикации. Список содержит набор наиболее часто применяемых стандартных размеров листовой бумаги. Если вы собираетесь верстать публикацию для распечатки на принтере, то, скорее всего, вам подойдет один из стандартных размеров листа. Если вашу публикацию предполагается печатать в типографии, скорее всего, она будет нестандартна с точки зрения InDesign, и для нее нужно создать свой размер бумаги. Для такого случая в области Page Size имеются поля ввода Width и Height. В них указываются ширина и высота страницы, соответственно. Как только в них окажется размер, не совпадающий с выбранным в списке Page Size, вместо стандартного размера в нем появится вариант Custom.

Возможно, вам захочется задать нестандартный размер страницы даже в случае последующей печати на принтере. Параметры рекламной листовки или страницы брошюры сильно влияют на ее восприятие. Так, вы можете легко организовать изящную книжечку, если при брошюровке будете складывать стандартные листы не поперек, а вдоль. В этом случае размер отдельной страницы составит 210х148. В дальнейшем мы будем обращать ваше внимание на создание оригинального дизайна при помощи нестандартного размера страницы.

По поводу размеров страницы публикации. Эта проблема не так проста, как кажется на первый взгляд. Дело в том, что здесь впервые в процессе подготовки публикации вы спускаетесь с творческих небес на грешную землю, где вас уже ждут работники типографии и продавцы бумаги. Перед определением формата будущей книги обязательно свяжитесь с предполагаемой типографией на предмет выяснения их требований к параметрам полосы набора (пространства страницы, отведенного под текст, не считая полей), и точно выясните, возможна ли печать на задуманном вами формате. Бумага для печати, купленная вами, тоже имеет совершенно определенный размер, выясните, может быть, слегка изменив формат публикации, вы сэкономите кучу бумаги, может быть, даже сможете отпечатать тираж на обрезках, оставшихся от предыдущего заказа. Таким образом вы сильно снизите себестоимость издания.

Ориентация страницы. В области Page Size также расположен переключатель Orientation. Левая кнопка соответствует вертикальному расположению длинной стороны страницы (книжная ориентация), а правая — горизонтальному (альбомная ориентация). Обратите внимание, что при переключении с одного режима на другой значения ширины и высоты в полях Width и Height меняются местами. И наоборот, если вы введете в поле Width большее число, чем в Height, то ориентация автоматически изменится на альбомную.

Установка полей. Поле подшивки. Данные о размере полей, т. е. о расстояниях от краев листа до запечатанной области (полосы набора) вводятся в поля области Margins. В ней есть четыре строки ввода, в которые вводятся данные обо всех (внутреннем, внешнем, верхнем и нижнем) полях документа: Inside, Outside, Top, Bottom. Если в параметрах документа указано отображение разворота (установлен флажок Facing Pages), то поля Left и Right заменяются, соответственно, на Inside и Outside.

Колонки и средник. Если документ должен содержать несколько колонок, то их количество можно задать прямо в момент создания. Для ввода количества. колонок предназначено поле Number в области Columns. В поле Gutter указывается размер средника, пробела между соседними колонками. Задав все необходимые параметры, нажмите кнопку ОК (Да). На экране появится чистая страница нового документа. Теперь вы можете задать для него локальные умолчания, которые обсуждались в предыдущем разделе этой главы — и вперед, принимайтесь за верстку!


Работа с шаблонами

Часто в повседневной работе вам приходится создавать похожие публикации, например, стандартные документы, брошюры одной и той же серии, номера журналов и т. д. В этом случае большую помощь может оказать комплект шаблонов на все случаи жизни. При этом не нужно специально готовить элементы вашей библиотеки шаблонов — достаточно просто сохранять публикации, оформление которых еще понадобится, в качестве шаблонов. Таким образом, после работы над документом будет оставаться заготовка для следующего такого же.

Включайте в шаблоны не только основные параметры документа, но и повторяющиеся элементы — например, реквизиты вашей фирмы, логотипы, рамки, графические выделения, фоновые картинки, короче, все, что повторяется во всех публикациях данного типа.


Создание нового шаблона публикации

Для того чтобы создать шаблон публикации и пользоваться плодами своего творчества, нужно удалить из шаблона все лишнее, относящееся только к данной публикации, а затем сохранить полученную "болванку" именно как шаблон, а не как простой документ. Для этого выберите в меню File команду Save As и задайте тип файла InDesign Template. Тем же приемом сохраняются в файле результаты редактирования ранее сохраненного шаблона. Файл шаблона имеет расширение INDT.


Редактирование шаблона публикации

Ранее созданный шаблон публикации не открывается при нажатии кнопки Open диалогового окна Open a File как обычная публикация. Вместо этого создается аналогичная ему публикация без имени, которую затем сохраняют на диске с соответствующим именем. Если вы хотите открыть сам шаблон для редактирования, а не создать на его основе новую публикацию, переведите переключатель в поле Open As диалогового окна Open a File в позицию Original.


Изменение параметров документа

В настоящей главе мы рассмотрим еще один важный вопрос, связанный с параметрами документа, а именно — что случится, если в рассматриваемом диалоговом окне Document Setup изменить то или иное значение. Вообще говоря, сверстанный документ — это зона неустойчивого равновесия, любые вмешательства в него, зачастую даже добавление или изъятие одного слова могут вызвать непредсказуемые последствия для его внешнего вида. Поэтому основной принцип, которым руководствуются дизайнеры после окончательного размещения текстовых и графических объектов на страницах публикации — руками не трогать! Если вы все же решились на подобное действие, обязательно создайте резервную копию файла, чтобы было куда вернуться из созданных вашими действиями руин, или сохраните документ непосредственно перед изменением параметров.

В то же время, зачастую изменение параметров документа вызвано суровой необходимостью. К тому же, жесткие ограничения на изменение параметров сковывают творчество дизайнера, не позволяют экспериментировать. Как хочется, чтобы, скажем, изменение ориентации страницы не приводило к необходимости вручную переверстывать всю публикацию. Для этой проблемы InDesign предлагает неплохое решение. Теперь эксперименты с параметрами страницы уже готовой публикации все еще нежелательны, но возможны.


Параметры существующего документа

Часть параметров документа, которые вы задавали при его создании, доступны в диалоговом окне Document Setup (рис. 142), открывающемся одноименной командой меню File.

В этом диалоговом окне находятся только основные параметры документа:

формат, ориентация и количество страниц. Установки полей и колонок находятся в особом диалоговом окне Margins and Columns (рис. 143), открывающемся соответствующей командой меню Layout.

По существу диалоговое окно New Document объединяет приведенные выше диалоговые окна. Такое разделение параметров документа и колонок совершенно необходимо, поскольку формат страниц задается для всего документа, а количество колонок и размер полей на разных страницах могут быть различными.

Рис. 14.2. Диалоговое окно Document Setup

Рис. 14.3. Диалоговое окно Margins and Columns


Автоматическая настройка макета

В InDesign есть возможности автоматической настройки макета с учетом изменения параметров документа. Применение режима автоматической настройки макета поможет вам изменить структуру отдельных страниц или целой публикации — размер полей, формат и ориентацию страниц, число колонок и т. д. если и не в одно движение, то значительно быстрее, чем просто вручную. В режиме автоматической настройки предусмотрена коррекция расположения и размеров текстовых и графических объектов в соответствии с новыми параметрами страниц или документа. Кроме того, режим автоматической настройки макета дает возможность переоформить существующие страницы с помощью новой шаблон-страницы в автоматическом режиме (о шаблон-страницах см. главу 15).

При оформлении макета следует обратить внимание, насколько легко его можно будет автоматически переверстать с другими параметрами страницы. При настройке макета программа InDesign использует некоторые правила, приведенные ниже, и именно их следует учесть при верстке. В общем случае, чем более структурирован макет и чем меньшее изменение вы производите, тем точнее будет настройка. Чем больше в публикации нестандартных элементов оформления и чем сильнее отличается окончательный макет от предыдущего, тем больше ручной работы по доводке макета вам предстоит. В зависимости от исходных параметров и оформления публикации, можно изменять параметры настройки, добиваясь адекватных результатов.


Режим автоматической настройки макета

Базовой характеристикой при настройке для InDesign является относительное положение направляющих и границ колонок на странице. Положение объектов верстки вычисляется относительно направляющих, границ колонок, полей и границ страницы. То есть, при изменении параметров макета сначала производится вычисление нового положения вспомогательных линий, а затем по образовавшейся сетке строится страница, на которой положение объектов относительно сетки было аналогично исходному. При этом изменениям подвергаются лишь объекты, "привязанные" к элементам сетки. Область, в пределах которой объект считается "привязанным" к направляющей или границе колонки, может быть различной и задается, как и другие параметры настройки, в окне Layout Adjustment, вызываемом одноименной командой меню Layout. Для включения режима настройки нужно установить флажок Enable Layout Adjustment в верхней части этого диалогового окна. Программа InDesign выполняет корректировку макета в зависимости от параметров, установленных в диалоговом окне Layout Adjustment. Для иллюстрации этих правил рассмотрим приведенный на рис. 14.4 пример настройки макета страницы, проведенной при изменении ее ориентации (заданы установки по умолчанию).

а

б

Рис. 14.4. Настройка макета, проведенная при изменении ориентации с книжной (а) на альбомную (б)

До настройки макета (рис. 14.4, а):

  1. Не связанный текстовый объект— заголовок-шапка— размещен в трех колонках.
  2. Связанные текстовые объекты размещены в колонках.
  3. Объект заходит за границу страницы на 20 мм.
  4. Иллюстрация, созданная средствами InDesign (серый эллипс), выровнена по направляющим.
  5. Импортированное изображение выровнено по границам полей страницы и направляющим.
  6. Линейка делит страницу на две равные части.
  7. Повернутый текстовый блок (эпиграф) выровнен по границе поля.

После настройки макета (рис. 14.4, б):

  1. Ширина текстового объекта увеличена, чтобы сохранить выравнивание по границам тех же колонок.
  2. Текст переразмещен в соответствии с новыми размерами колонок.
  3. Объект перемещен, но он по-прежнему заходит за край страницы на 20 мм.
  4. Размеры иллюстрации, созданной в InDesign, изменены без сохранения исходных пропорций; иллюстрация по-прежнему выровнена по тем же вспомогательным линиям.
  5. Импортированное изображение (логотип с человеком в лодке) перемещено, отмасштабировано с сохранением исходных пропорций и выровнено только по направляющим слева и справа.
  6. Линейка, как и прежде, делит страницу на две равные части (ее абсолютное расположение изменилось); вспомогательные линии, выровненные по границам колонок, переместились вместе с колонками.
  7. Повернутый текстовый блок переместился вместе с границей поля.


Параметры автоматической настройки макета

Для определения параметров настройки макета выберите команду Layout Adjustment меню Layout. Описываемое диалоговое окно изображено на рис. 14.5. В этом диалоговом окне можно задать следующие характеристики:

  • Snap Zone. Строка ввода, в которой указывается размер области настройки. В ее пределах объекты считаются "привязанными" к границам страниц и вспомогательным линиям. Чем больше заданный размер, тем больше вероятность перемещения объекта вместе с границами страниц и вспомогательными линиями.

Рис. 14.5. Диалоговое окно Layout Adjustment

Ниже расположена группа флажков, устанавливаемых в зависимости от вида исходной публикации и требовании к ней.
  • Allow Graphics and Groups Resize. Если этот режим включен, то при изменении формата страниц и ширины колонок размеры сгруппированных объектов и изображений меняются. При этом InDesign старается разместить их аналогично исходному варианту, однако изменение размеров программа производит только параметрически, не допуская искажения пропорций.
  • Ignore Object and Layer Locks. В главе 15 мы будем обсуждать прием закрепления объектов на странице и слоев публикации. Пока лишь отметим, что закрепленный объект или слой невозможно перемещать, удалять и изменять его размеры. Чтобы корректировка влияла на объекты, закрепленные командой Lock Position меню Object или расположенные на закрепленных слоях, необходимо предварительно снять закрепление.
  • Ignore Ruler Guide Alignments. По умолчанию объекты при настройке выравниваются по всем элементам модульной сетки — направляющим, границам колонок и полей. Когда включен режим игнорирования выравнивания по направляющим, при корректировке учитывается выравнивание объектов только по границам колонок и полей.
  • Allow Ruler Guides To Move. При включенном режиме направляющие (в том числе и закрепленные) переразмещаются на странице, сохраняя свое положение относительно полей и границ колонок, если этого требуют изменения макета. При этом образуется новая модульная сетка. В противном случае абсолютное положение направляющих остается неизменным, зато их размещение относительно страницы меняется.
  • В следующем разделе мы более подробно обсудим изменения, происходящие в публикации при изменении тех или иных ее параметров.


Изменения элементов макета при настройке

InDesign изменяет элементы макета различным образом, в зависимости от того, какие параметры страницы подвергаются коррекции. Ниже, в табл. 14.1 приведены некоторые изменения макета и последствия их при включенном режиме автоматической настройки макета.

Таблица 14.1. Изменение параметров документа и их влияние на результат автоматической настройки

Изменяемый атрибут, способ управления им | Особенности автоматической настройки
Размер/ориентация страницы Диалоговое окно Document Setup | Поля перемещаются на новое место, но их ширина остается прежней. Ширина и высота колонок изменяется в соответствии с новыми размерами страницы. По умолчанию направляющие перемещаются таким образом, чтобы сохранилось их относительное положение на странице (например, направляющая, проходящая посередине страницы, устанавливается на середине новой страницы). В диалоговом окне Layout Adjustment) можно отменить редактирование направляющих, сбросив флажок Allow Ruler Guides to Move
Поля Диалоговые окна Document Setup и Margins and Columns | В соответствии с новой шириной полей изменяются ширина и высота колонок
Ширина колонки или средника (промежутка между колонками) Диалоговые окна Document Setup и Margins and Columns | Изменяется ширина всех колонок. Автоматическая настройка макета происходит только в том случае, когда размеры колонок изменяются через диалоговые окна. Если направляющие колонок смещены вручную, то автоматическая настройка макета перераспределяет их равномерно. Направляющие, совпадающие с границами колонок и полей, перемещаются вместе с ними
Количество колонок Диалоговые окна Document Setup и Margins and Columns | Колонки добавляются и убираются с правой стороны страницы. Ширина всех колонок перенастраивается. Текст не заполняет вновь образовавшиеся колонки автоматически Все объекты (кроме текста), выровненные по самой правой колонке, остаются выровненными по ней же и перемещаются вместе с ней При удалении колонок, если в предыдущем макете самая правая колонка содержала текстовый фрейм, то он остается на месте и не изменяет своих размеров. Остальные фреймы становятся шире, сохраняя выравнивание по границам колонок. Все остальные объекты, в том числе несвязанные текстовые блоки, выровненные по самой правой колонке, тоже остаются на своих местах относительно границ страницы


Перемещение "привязанных" объектов при автоматической настройке макета

Перемещение "привязанных" объектов вместе с их направляющими при настройке макета включено по умолчанию в диалоговом окне Layout Adjustment. Для отмены привязывания объектов по направляющим при настройке поставьте соответствующий флажок игнорирования выравнивания по направляющим Ignore Ruler Guide Alignments.

Если же режим выравнивания по направляющим активен, то расположение объектов относительно вспомогательных линий после пересмотра макета зависит от количества направляющих, по которым выровнен объект:

  • Выровненные в одну сторону объекты перемещаются вместе со своей вертикальной или горизонтальной направляющей.
  • Объекты, выровненные по соседним сторонам, перемещаются вертикально или горизонтально. Это нужно для того, чтобы сохранить выравнивание по обеим сторонам по направляющим изменившейся модульной сетки.
  • Выровненные по противоположным сторонам объекты (текст и изображения) для сохранения привязки по обеим сторонам перемещаются одновременно с изменением их размеров. Это правило действует только для объектов, созданных в программе InDesign. Размеры групп и импортированных изображений можно изменять без искажения пропорций. Для этого задайте соответствующий параметр в диалоговом окне Layout Adjustment. Размер изображения или группы при этом будет вычисляться исходя из измерения, ограниченного направляющими.
  • Выровненные по 3 или 4 сторонам объекты (текст и изображения, созданные в программе InDesign) перемещаются одновременно с изменением их размеров. При этом сохраняется выравнивание по направляющим. Размеры групп и импортированных изображений изменяются пропорционально и выравниваются по левой и правой сторонам, но только если задан соответствующий параметр в диалоговом окне Layout Adjustment.
  • Не выровненный по направляющим объект перемещается только при изменении формата страницы с сохранением его расположения относительно краев страницы. При этом размеры объекта не меняются.

Если объект не выровнен по направляющей, но находится близко от нее (в зоне настройки, задаваемой в строке ввода Snap Zone в диалоговом окне Layout Adjustment, то при настройке макета объект будет выровнен по ближайшей направляющей и после изменений останется "привязанным" к ней. Вид макета после настройки зависит от величины зоны настройки. В примере на рис. 14.6 поля страницы уменьшены с 20 до 15 мм (рис. 14.6, а и б), а затем увеличены до первоначальных (рис. 14.6, в). В первом случае (сверху) зона настройки была задана равной 1 мм, во втором (снизу) — 4 мм. В первом случае окружность не "прикреплена" ни к одному из элементов модульной сетки и при смене размера полей не подвергается никаким изменениям. Во втором случае зона настройки увеличена, окружность становится привязанной к границе колонки, поскольку ближе никакой направляющей нет. Если увеличить поля до первоначального, окружность не примет исходный вид, а останется "привязанной" к границам колонки.

а

б

Рис. 14.6. Пример зависимости результата автоматической коррекции макета от величины зоны настройки


Нежелательные изменения параметров документа

Режим автоматической настройки макета обеспечивает корректировку при таких изменениях параметров публикации, которые в других программах ведут к ужасающим последствиям для макета. Это, прежде всего, переразмещение объектов верстки при изменении размеров и ориентации страницы. Также крайне опасны в большинстве программ операции по изменению размера полей документа, в частности, замена односторонней печати двусторонней и наоборот, связанная с преобразованием левого и правого полеи документа во внешнее и внутреннее. InDesign автоматически настраивает макет в соответствии с изменившимися границами страницы, полями и колонками. Тем не менее, некоторые операции и в InDesign ведут к нежелательным последствиям. Ниже, в табл. 14.2, представлен список этих действий и их нежелательные последствия.

Таблица 14.2. Нежелательные изменения параметров макета

Если вы измените... | Возможны следующие (чаще, крайне нежелательные) последствия
Число страниц | Изменение этого значения добавляет или убирает страницы только в конце публикации. При удалении сверстанных страниц из конца документа имеется вероятность их безвозвратной утраты
Графика в разворот: четные номера страниц на нечетные, нечетные номера страниц на четные, номер первой страницы, оборотную печать на обычную | Некоторые изменения значений в диалоговом окне Document Setup или изменение числа страниц с помощью палитры Pages могут полностью нарушить воспроизведение графики, размещенной одновременно на двух смежных страницах (графика в разворот). Избегай те любых изменений, приводящих к превращению четных страниц в нечетные и наоборот. Если это происходит, программа InDesign пытается сохранить привязку такого графического объекта к странице с исходно не четным номером (правой в развороте). Но после изменения она становится левой в развороте (четный номер), и графическое изображение примерно наполовину вы ходит за ее левый край, на монтажный стол
Номер первой страницы (при режиме двухсторонней печати) | Если публикация сверстана для режима двухсторонней печати, программа InDesign определяет, левой или правой будет страница в развороте по ее номеру. Если номер первой страницы будет изменен с четного на нечетный или наоборот, все страницы публикации по меняют свое положение в разворотах — левые станут правыми, а правые — левыми
Различные параметры макета, включающего растрированные изображения | Изменение размеров растрированных (монохромных) изображений может привести к проблемам при печати. Поэтому иногда оказывается необходимым повторно выполнить растрирование в программе обработки изображений и импортировать изображения в публикацию


Резюме

  • Перед созданием новой публикации следует хорошо продумать все ее основные параметры и задать необходимые установки программы по умолчанию.
  • Создание серии похожих публикаций ускоряется при использовании шаблонов. Шаблон InDesign можно создать на основе любого документа.
  • Хотя изменений основных параметров макета (формата, полей, числа колонок текста) следует избегать, даже в этом случае InDesign способен сократить объем ручной работы по корректировке макета за счет функции автоматической настройки.


Глава 15

Структура публикации

В настоящей главе рассмотрены следующие вопросы:

  • Вспомогательные линии InDesign — направляющие, границы колонок и полей
  • Модульная сетка страницы
  • Основные элементы модульной сетки
  • Построение модульной сетки
  • Установка полей страницы
  • Задание числа и размера колонок. Диалоговое окно Margins and Columns
  • Работа с направляющими. Режимы выравнивания по вспомогательным линиям и координатной сетке Grid
  • Измерение расстояний в макете: настройка линеек и начала отсчета
  • Точное размещение направляющих в диалоговом окне Create Guides
  • Возможности дополнения Create Guides. Их применение
  • Слои InDesign
  • Страницы-шаблоны
  • Применение модульных сеток

Данная глава описывает построение "скелета публикации" — модульной сетки страниц, шаблон-страниц, сетки интерлиньяжа. Затем, в процессе верстки на него будет наращиваться "плоть" — текстовые блоки, фреймы, графика. Построение модульной сетки можно рассматривать как наиболее творческий аспект верстки. Тщательно продуманная сетка вспомогательных линий определяет внешний вид каждой из страниц будущего документа, сообщая конечному продукту необходимую целостность. Поэтому при построении модульной сетки шаблона документа постарайтесь учесть все особенности страниц публикации. Тогда вы сможете сделать шаблон достаточно гибким для любой страницы. На случай, если в публикации предполагается несколько типов оформления страниц, In Design дает возможность создавать модульную сетку и дополнительные шаблоны для разных страниц публикации. Итак, модульная сетка определяет композицию будущего документа. Если она удачна, то построенный по ней документ, даже очень скромный по графическому и шрифтовому оформлению, будет выглядеть гармонично и профессионально, а выделенные объекты (не вписывающиеся в сетку) привлекут внимание читателя. Если же модульная сетка документа разработана плохо, то в результате получится некрасивая, разваливающаяся страница, производящая впечатление неряшливой работы. Положение не спасут ни оригинальные фотографии, ни броские надписи. Напротив, будучи расположенными "не на месте", они потеряют большую часть своей выразительности.


Вспомогательные линии InDesign

Вспомогательными называют тонкие линии, которые не выводятся на печать, но отображаются на экране. Их положение на странице документа можно изменять. Совокупность вспомогательных линий на странице образует модульную сетку. Она используется для выравнивания и точного размещения объектов верстки на странице. Модульная сетка любой страницы In-Design строится из трех типов вспомогательных линий. Все они уже знакомы вам, и ниже мы лишь обобщим особенности каждого вида.

Границы полей. Ограничивают полосу набора страницы, обозначая поля. Границы полей — наименее подвижные из вспомогательных линии. Их вообще нельзя сдвинуть курсором, изменить их положение можно, лишь задав другие значения полей документа в шаблон-странице. На цветном мониторе границы полей обозначаются тонкими линиями розового цвета, образующими на странице прямоугольник — полосу набора.

Границы колонок. Вертикальные вспомогательные линии, образующие колонки. Особое свойство границ колонок в том, что они направляют текст при размещении по образованным ими колонкам. Границы колонок можно смещать курсором, изменять их количество и положение на странице в соответствующих диалоговых окнах. Границы колонок обозначаются на цветном мониторе тонкими линиями синего цвета.

Направляющие. Специальные линии, произвольно располагаемые на странице. Направляющие перетаскиваются на страницу с линеек и могут быть как вертикальными, так и горизонтальными. Положение направляющих может определяться вручную или в диалоговом окне. На экране они отображаются тонкими линиями бирюзового цвета.

Все вспомогательные линии отображаются только в режиме Макет (Layout), и это вполне логично. Операции с ними также доступны только в режиме макетирования.


Элементы модульной сетки

Все три типа линий образуют модульную сетку, каркас документа. На рис. 15.1 представлена модульная сетка страницы и сверстанный по ней документ.

а

б

Рис. 15.1. Модульная сетка и сверстанный по ней документ

В полиграфии каждый из элементов образовавшейся модульной сетки имеет определенное название и предназначение. На рис. 15.2. представлены следующие элементы сетки:

  1. Рубрика.
  2. Заголовок.
  3. Подзаголовок.
  4. Поднятая буквица.
  5. Элемент под обрез.
  6. Окно под иллюстрацию.
  7. Подрисуночная подпись.
  8. Основной текст.
  9. Отточие.
  10. Средник.
  11. Обтекающий текст.
  12. Колонцифра.
  13. Внутреннее поле.
  14. Растрированный фон.
  15. Рамка.
  16. Нижнее поле.
  17. Нижний колонтитул.
  18. Строка продолжения.
  19. Обрез страницы.
  20. Внешнее поле.
  21. Верхний колонтитул.
  22. Верхнее поле.
  23. Врезка.
  24. Вставка.
  25. Опущенная буквица.
  26. Линейка.

Рис. 15.2. Основные элементы страницы публикации

При подготовке издания вам поневоле придется общаться с редакторами, корректорами и работниками типографии — знание полиграфических терминов вам не повредит.


Границы полей

Основными вспомогательными линиями на странице являются границы полей, образующие полосу набора. Границы полей для отдельных страниц публикации и страниц-шаблонов определяются в диалоговом окне Margins and Columns.

Если вы посмотрите на чистую страницу документа, то обнаружите, что верхняя и нижняя граница колонки отмечены розовой линией, а боковые — почему-то синей, такой же, как границы колонок. В действительности это и есть границы единственной колонки, совпадающей по размерам с полосой. Ухватив синюю линию инструментом Selection Tool, можно перетащить ее на другое место страницы. При этом становится видна розовая граница поля, ранее закрытая границей колонки. Рис. 15.3 иллюстрирует эту операцию.

Рис. 15.3. Смещение границы колонки вручную, инструментом Selection

Границы полей можно установить не только для шаблон-страниц документа, но и отдельных его страниц. Поля нельзя смещать вручную, но можно менять в любой момент работы над документом, обращаясь для этого к необходимым диалоговым окнам. Вместе с размером полей должно изменяться и размещение текстовых и графических блоков. Этот процесс называется настройкой макета и описан в главе 14.


Границы колонок

Границы колонок направляют размещаемый текст в колонку. Если при размещении текста на странице с несколькими колонками щелкнуть курсором с пиктограммой размещения текста в пределах первой колонки, текст сначала заполняет ее, затем переходит на следующую колонку, и так далее до конца страницы. При размещении текста в режиме автозаполнения следующий фрагмент размещается в первой колонке следующей страницы. Границы колонок для каждой страницы можно задавать отдельно. Для этого предназначено диалоговое окно Margins and Columns. Для установки положения и числа колонок в шаблон-странице документа также используется это диалоговое окно.

Для установки числа и положения колонок переидите на нужную страницу публикации или на шаблон-страницу (см. раздел "Шаблоны" этой главы).

Выбрав нужную страницу или основной шаблон, откройте диалоговое окно Margins and Columns соответствующей командой меню Layout. Задайте нужное число колонок в строке ввода Number области Columns. В строке Gutter задается размер средника. Разметку колонок можно задать для любого количества страниц или шаблон-страниц одновременно. Для этого достаточно их предварительно выделить в палитре Pages.

Созданные колонки можно смещать вручную инструментом Selection. При этом смещении средник остается неизменным, как на рис. 15.4.

Рис. 15.4. Смещение границы колонки вручную

Если необходимо настроить макет в соответствии с изменившимися колонками или средником, установите флажок Enable Layout Adjustment в диалоговом окне Layout Adjustment. Изменение числа и положения колонок из диалогового окна влияет на размещение текста только в случае включенного режима настройки макета. Если колонки смещаются вручную, автоматическая настройка макета не производится.


Направляющие линии

Наиболее свободным типом вспомогательных линий являются направляющие. Они никак не влияют на размещение текста и графики, если не включен режим выравнивания по направляющим. В этом случае направляющие наделяются некоторыми "магнитными" свойствами и начинают притягивать объекты, располагаемые вблизи них. Если направляющих на странице много, перемещение объектов становится скачкообразным, от одной направляющей к другой. Такой режим работы пригодится при выравнивании объектов, и подробно рассмотрен в главе 16. Режим выравнивания по направляющим включается командой Snap to Guides меню View. Если этот режим включен, в соответствующей строке меню установлен флажок. Клавиатурное сокращение для включения/выключения выравнивания по направляющим — <Shift>+<Ctrl>+<;> (точка с запятой). Переключение режима выравнивания по направляющим не оказывает никакого воздействия на уже размещенные объекты.


Установка, перемещение и удаление направляющих

Расположение направляющих может быть разным на каждой странице. Расставлять их можно вручную, перетаскивая с линеек, или с помощью команды Create Guides. Направляющие можно задавать для страниц документа или для шаблон-страницы. В последнем случае, прежде чем задавать направляющие, перейдите на шаблон-страницу документа. Для установки вертикальной направляющей щелкните мышью на вертикальной линейке и, не отпуская левую клавишу, переместите курсор в поле страницы документа. За курсором потянется тонкая бирюзовая линия — направляющая. Ориентируясь по отметке положения курсора на горизонтальной линейке, установите направляющую в нужное место страницы. Описанная операция представлена на рис. 15.5. Аналогичным образом расставляются горизонтальные направляющие линии.

Прежде чем расставлять направляющие, рекомендуем вам настроить линейки на привычные единицы измерения. О настройке линеек см. главу 3. Кроме того, необходимо выбрать и закрепить точку отсчета.

Направляющие линии для InDesign представляются особыми объектами. Как и любые другие объекты, направляющие можно перемещать, удалять и копировать. Прежде чем выполнить одну из этих операций, направляющую необходимо выделить щелчком мыши. При этом она изменит свой цвет на цвет слоя, на котором находится. Чтобы переместить направляющую, просто перетащите ее мышью на нужное место. Для удаления нажмите клавишу <Del> или выберите команду Clear меню Edit.

Рис. 15.5. Установка вертикальной направляющей

Копирование направляющих, как и других объектов InDesign, выполняется парой команд Copy и Paste меню Edit. Если, например, вы хотите скопировать направляющие с одной страницы на другую, то сделайте следующее. Сначала выделите копируемые направляющие на исходной странице. При этом вы можете выделять их последовательными щелчками при нажатой клавише <Shift> или выделительной рамкой инструмента Selection. Когда все направляющие будут выделены, выберите команду Сору меню Edit, перейдите на целевую страницу и выберите команду Paste в том же меню. Если вы хотите не скопировать, а перенести направляющие на другую страницу, то вместо команды Copy выбирайте в меню Edit команду Cut.

Если документ предназначен для оборотной печати, то при размещении направляющих у вас есть выбор: установка направляющей для одной полосы или всего разворота. Если "вытащить" из горизонтальной линейки направляющую линию и поместить ее на полосу, то направляющая будет принадлежать только одной полосе. Если же при перемещении направляющей удерживать нажатой клавишу <Ctrl>, то горизонтальная направляющая пересечет обе полосы и будет продолжаться и на рабочем столе. Вертикальная направляющая при нажатой клавише <Ctrl> тоже будет выходить за пределы полосы на рабочий стол. Если же вытаскивать направляющие не из вертикальной или горизонтальной линеек, а из квадрата, образованного их пересечением, и удерживать при этом клавишу <Ctrl>, то InDesign создаст одновременно вертикальную и горизонтальную направляющие, пересекающиеся в точке, где находится курсор (рис. 15.6).

Рис. 15.6. Установка вертикальной и горизонтальной направляющей одновременно


Закрепление и режим отображения направляющих

Когда направляющие (модульная сетка страницы) расставлены надлежащим образом, имеет смысл запретить их перемещение. В противном случае можно по ошибке передвинуть вместо объекта одну из тщательно установленных линий. Для закрепления направляющих существует команда Lock Guides меню View. Если направляющие уже закреплены, рядом с этой командой установлен флажок. При включенном режиме закрепления сместить направляющую мышью становится невозможно. Команда Lock Guides имеется и в контекстном меню, открывающемся щелчком правой кнопкой мыши на направляющей или свободном месте страницы.

Направляющие могут отображаться в двух режимах — впереди и позади объектов. Эти режимы переключаются флажком Guides in Back из раздела Guides диалогового окна Preferences. Подробно см. в главе 3.

Будучи объектами InDesign, направляющие занимают какое-то положение в стопке объектов и расположены на каком-либо слое. Их положение относительно объектов не влияет на режим отображения поверх или позади объектов. Этот режим полностью определяется флажком Guides in Back в диалоговом окне Preferences.

Для верстальщика направляющие могут нести различную смысловую нагрузку. Например, одни образуют модульную сетку, другие задают места размещения особых элементов макета, третьи создаются временно и служат для выравнивания сюжетно важных фрагментов изображений и заголовков, и т. п. В InDesign нет опасности спутать направляющие, несущие разную функцию даже при большом увеличении, когда выровненный по ним объект невидим. Это достигается присвоением направляющим разных цветов. Чтобы задать цвет направляющей, ее надо выделить и выбрать команду Ruler Guides меню Layout или контекстного меню. Она открывает диалоговое окно, изображенное на рис. 15.7. Список Color содержит 27 образцов цвета, которые вы можете использовать для направляющих. Если вас не устраивает ни один из них, выберите в списке вариант Custom или щелкните на образце цвета справа от списка. В результате откроется системная палитра цветов, где вы сможете выбрать произвольный цвет. Изменяйте цвета направляющих и тогда, когда цвет, установленный по умолчанию, совпадает с общим тоном полосы.

Рис. 15.7. Диалоговое окно Ruler Guides

а

б

Рис. 15.8. Влияние параметра View Treshold на вид страницы с направляющими при разных масштабах просмотра

Весьма удобна в InDesign настройка порогового увеличения для демонстрации направляющих. Дело в том, что если направляющие размещены достаточно тесно, то при небольших масштабах отображения они начнут сливаться. Чтобы избежать этого, задайте для направляющих, несущих различную смысловую нагрузку, различные пороговые масштабы в диалоговом окне Ruler Guides. Пороговое увеличение для выделенных направляющих задается в поле View Treshold. На рис. 15.8 приведен пример просмотра документа с такими направляющими при различных увеличениях. На нем для вертикальных направляющих параметр View Treshold равен 5%, а для горизонтальных — 50%. Поэтому при увеличении 49% горизонтальные направляющие не видны.

Часто требуется посмотреть на страницу публикации без вспомогательных линии, искажающих ее внешний вид. Для этого примените команду Hide Guides меню View или контекстного меню. Подробнее см. главу 16. Чтобы направляющие не мешали работе с объектами и их было легко выделять, располагайте их на отдельном слое (о слоях см. ниже).

Работа с применением направляющих линий повышает точность размещения объектов и ускоряет верстку сложных макетов. В InDesign входит великолепное средство автоматизации размещения направляющих линий модульная Сгеаtе Guides. С его помощью можно легко создавать и редактировать сложнейшие модульные сетки, состоящие из направляющих и колонок, причем эта работа производится с высочайшей точностью. Кроме того, вы сможете создавать библиотеки часто используемых модульных сеток при помощи палитры Library. Работа с командой Create Guides описана в следующем разделе.


Автоматическая расстановка направляющих

С помощью команды Create Guides удобно размещать на странице равноотстоящие друг от друга направляющие, создавать вертикальные и горизонтальные секции (своеобразные "псевдоколонки"). При этом вместо перетаскивания направляющих с линеек достаточно ввести значения в поля диалогового окна.

Команда Create Guides находится в меню Layout и открывает диалоговое окно, изображенное на рис. 15.9.

В правой части диалогового окна расположен флажок Preview, дающий возможность предварительного просмотра построенной сетки прямо на странице публикации. InDesign обновляет параметры сетки направляющих в окне документа каждый раз после перевода активности с одного элемента управления диалогового окна на другой.

Верхнюю часть диалогового окна занимают области Rows и Columns, в которых задаются параметры горизонтальной и вертикальной разбивки полосы

направляющими. В каждой из областей имеются поля ввода Number и Gutter. Первое определяет число колонок или рядов, а второе — промежутки между ними.

Рис. 15.9. Диалоговое окно Create Guides

Переключатель Fit Guides to в области Options задает границы, в которых размещаются направляющие: с учетом полей, Page, или без — Margins (рис. 15.10).

а

б

Рис. 15.10. Направляющие размещены по всей странице (а), в области, ограниченной полями (б)

Флажок Remove Existing Ruler Guides заставляет InDesign перед размещением новых направляющих удалить со страницы все существующие.

Чтобы применить сетку направляющих к нескольким страницам публикации, либо воспользуйтесь обсуждаемым в следующем разделе механизмом шаблон-страниц, либо просто предварительно выделите эти страницы в палитре Pages.


Шаблоны

Компьютер призван облегчать жизнь человека, избавляя его от рутинных операций. В InDesign имеются великолепные средства для автоматизации работы верстальщика. Одним из них являются шаблон-страницы документов.

В любом документе есть элементы, повторяющиеся от страницы к странице. К ним, например, относятся границы полей и колонок, сетка направляющих, колонцифры, колонтитулы, повторяющиеся графические элементы (рамки, логотипы и т. д.). Можно, конечно, расставить эти элементы вручную. Если публикация велика, то подобная механическая работа будет занимать много времени. Для того чтобы избежать этого, в InDesign имеется механизм распространения действия модульной сетки и других повторяющихся элементов макета на последовательность страниц публикации — Master Pages (шаблон-страницы). Применение шаблон-страниц, кроме солидной экономии времени, способствует точному размещению элементов на страницах. Упрощается и внесение изменений в оформление — вместо того чтобы вручную изменять дизайн каждой страницы, можно просто внести коррективы в шаблон-страницу, и они будут переданы каждой странице публикации.

При создании шаблона учтите, что все элементы, которые вы поместите на страницу-шаблон, автоматически появятся на всех страницах публикации, связанных с ней, если, конечно, вы не примете специальных мер ручной , настройки макета. Если в публикации есть несколько стилей оформления страниц, для каждой группы можно задать свой шаблон.

Таким образом, шаблон-страницы являются носителями модульных сеток и повторяющихся элементов страницы. С помощью шаблонов создается общий стиль документа. Заметим, что организация шаблон-страниц является сильной стороной InDesign и превосходит возможности наиболее популярных издательских систем. Рассмотрим шаблон-страницы подробнее.


Палитра Pages

Управление страницами и шаблонами в публикации сосредоточено в специальной палитре Pages, изображенной на рис. 15.11. Она выводится на экран командой Show Pages меню Window. Клавиатурное сокращение для этой операции — <F12>. Палитра шаблонов является обычной палитрой InDesign и содержит все стандартные элементы палитр. Мы уже упоминали ее в первой, обзорной главе, но не вдавались в детали, связанные с организацией шаблонов. Теперь рассмотрим палитру Pages подробнее.

Палитра разделена на две части. В верхней части находятся пиктограммы всех страниц публикации, а в нижней — пиктограммы шабон-страниц. Под пиктограммами страниц и разворотов в верхней части палитры Pages приведены порядковые номера этих страниц в разделах (о разделах см. ниже).

Имена шаблонов формируются из двух частей: префикса и собственно имени. Например, имя шаблона A-Master состоит из префикса "А" и имени "Master". Префикс используется для того, чтобы показать принадлежность страницы определенному шаблону и изображается на пиктограмме страницы. Например, на рис. 15.12 страницы 2 и 3 принадлежат шаблону A-Master, что видно по символам "А" на их пиктограммах. По этой причине префикс не может состоять более чем из одного символа: большее их количество просто не поместится на маленькой пиктограмме страницы. Чтобы не спутать принадлежность страниц разным шаблонам, используйте для всех шаблонов разные префиксы.

Рис. 15.11. Палитра Pages

Кнопка с изображением мусорной корзины на панели инструментов палитры удаляет любые выделенные в палитре объекты: страницы или шаблоны. Кнопка с изображением листа бумаги создает новые объекты: страницы или шаблон-страницы.

Все основные манипуляции со страницами и шаблон-страницами можно проделывать, не прибегая к меню или клавиатуре, а используя только перетаскивание мышью. Тем не менее, все эти возможности представлены и в виде довольно длинного списка команд в меню палитры Pages.

При создании нового документа из нескольких страниц палитра Pages имеет как раз такой вид, который представлен на рис. 15.11. В верхней части палитры находятся миниатюры пяти страниц публикации. В нижней части находятся основной шаблон A-Master, создаваемый автоматически, и пиктограмма отсутствия шаблона None.


Основной шаблон документа

Как уже отмечалось, в публикации InDesign может быть использовано несколько шаблон-страниц. Основная шаблон-страница организуется автоматически при создании нового документа. Этому основному шаблону присваиваются атрибуты, заданные в диалоговом окне New Document. Это формат страницы публикации, способ печати (односторонняя или разворот), поля, число колонок по умолчанию. Первая страница вновь созданного документа по умолчанию строится по основной шаблон-странице A-Master. Действие основного шаблона распространяется на все страницы публикации. Если не указывается явно другой вариант, все вновь создаваемые страницы публикации форматируются по умолчанию в соответствии с основным шаблоном (A-Master).

К новым страницам, создаваемым в публикации при помощи диалогового окна команды New Document, автоматически применяется основной шаблон.

Для страниц, добавляемых в публикацию при помощи команды Insert Pages, имеется возможность явным образом выбрать шаблон, который будет применяться ко вновь создаваемым страницам, но и в этом случае основной шаблон выбирается по умолчанию.


Дополнительные шаблон-страницы

В текущей публикации можно создать любое количество дополнительных шаблон-страниц. Для любой страницы документа можно определить любой шаблон — основной или один из дополнительных. Если документ настроен на одностороннюю печать, шаблон-страница изображается в палитре Pages в виде одной странички, в случае двухсторонней печати пиктограмма представляет собой маленький разворот (рис. 15.12, б). Пиктограмма дает доступ к текущему шаблону данной страницы документа.

а [image] б

Рис. 15.12. Пиктограммы страниц-шаблонов для односторонней (а) и двухсторонней (б) печати и соответствующие шаблоны


Выбор и применение шаблона

Список всех имеющихся в публикации страниц-шаблонов всегда у вас перед глазами в палитре Pages. После раскрытия списка в нем можно выбрать любую из страниц-шаблонов публикации. При этом активность переводится на соответствующую шаблон-страницу. Она отображается на экране, и вы можете ее отредактировать (см. раздел "Создание новой шаблон-страницы и редактирование шаблонов" этой главы).

Для того чтобы применить страницу-шаблон к странице документа, перетащите пиктограмму шаблон-страницы (из нижней части палитры Pages) к пиктограмме любой страницы публикации (в верхней части палитры Pages). На этой странице публикации появится все, что вы поместили на соответствующую шаблон-страницу.

Шаблоны можно применять как к отдельным страницам, так и разворотам. В результате страницы разворота могут использовать различные шаблоны. Если в палитре Pages перетаскивать мышью пиктограмму шаблона к пиктограмме отдельной страницы документа, то шаблон будет применен только к этой странице. Если же перетаскивать пиктограмму шаблон-страницы к номерам страниц в развороте, то шаблон будет применен ко всему развороту.

По пиктограммам, представленным на рис. 15.12, видно, что к левой и правой страницам разворота 3—4 применены различные страницы-шаблоны. Правая сторона разворота оформляется в соответствии с дополнительной страницей-шаблоном с именем B-Master.

Для быстрого применения шаблон-страницы ко многим страницам служит команда меню палитры Apply Master to Pages, позволяющая указать список страниц. На рис. 15.13 представлено диалоговое окно Apply Master. В поле То Pages указывается произвольное количество страниц. Список составляется с помощью тире и запятых. Например, список 1-4,6,8- означает применение шаблона к страницам с первой по четвертую, шестой странице и всем страницам, начиная с восьмой и до конца документа.

Рис. 15.13. Диалоговое окно Apply Master

Если необходимо применить шаблон к небольшому количеству страниц публикации, то это удобно сделать без использования команды Apply Master, с помощью мыши. Сначала необходимо выделить в верхней части палитры Pages те страницы, к которым надо применить шаблон. Чтобы выделить несколько страниц, щелкните мышью на их пиктограммах при нажатой клавише <Shift>. Если необходимо выделять развороты, то щелкать следует на номерах страниц под их пиктограммами. Затем нажмите клавишу <Alt> и щелкните на пиктограмме требуемого шаблона в нижней части палитры Pages. Этот шаблон будет применен ко всем выделенным страницам.


Иерархия шаблонов

В InDesign шаблон-страницы организованы иерархически, как, например, стили текста. Вы помните, что один текстовый стиль можно создать на основе другого, базового. В результате редактирование. базового стиля приведет к изменению всех стилей, которые на нем основаны. Точно так же вы можете создать один шаблон на основе другого. Иерархическое построение шаблонов публикации дает существенный выигрыш, если часть страниц публикации отличается от других мелкими деталями. Пример иерархии шаблонов приведен на рис. 15.14.

Рис. 15.14. Иерархия шаблонов

Базовый шаблон изображен в верхней части рисунка. На его основе созданы два шаблона, изображенные посередине. В свою очередь, на основе каждого из них создано еще по одному шаблону, изображенному внизу. На рис. 15.15, а приведен пример серии шаблонов, построенных на той же иерархической структуре. Шаблоны заполнены условным текстом и прямоугольниками, отмечающими места для изображений.

Рис. 15.15. Иерархия шаблонов и результат внесения изменений в базовый шаблон

Иерархия шаблонов строится благодаря возможности редактировать элементы шаблона, определенные в соответствующем ему базовом шаблоне. При этом важно, что редактирование не разрывает связь объекта с базовым шаблоном. Здесь работает аналогия с локальным и глобальным форматированием текста. Возьмем, например, абзац, отформатированный стилем с прямым начертанием. Если вручную присвоить слову из этого абзаца курсивное начертание, то при изменении стиля абзаца, которому принадлежит слово, начертание не изменится. Изменения начертания не произойдет, даже если измененный стиль задает полужирное или полужирное курсивное начертание. С другой стороны, если в стиле изменена гарнитура шрифта или кегль, то выделенное слово примет тот же кегль и гарнитуру шрифта. Короче говоря, на те атрибуты текста, которые заданы вручную, стилевое форматирование не действует. Всеми остальными атрибутами можно управлять при помощи стилей. Поэтому мы и говорили о приоритете локального форматирования (задания атрибутов текста вручную) над глобальным (стилевым).

Базовый шаблон в этом аналогичен стилю. Редактируя объекты на дочерней шаблон-странице, вы выполняете их своеобразное "локальное форматирование". Если вы изменяете какие-либо характеристики (размеры, положение, цвет, угол поворота, и т. п.) объекта на дочерней шаблон-странице, то они становятся независимыми от этих характеристик того же объекта на базовой шаблон-странице. Все остальные характеристики объекта на дочерней шаблон-странице будут изменяться, если они изменены для объекта на базовой шаблон-странице.

Воспринимайте объекты на дочерней шаблон-странице как копии объектов с базовой шаблон-страницы. Эти копии наследуют атрибуты от своих оригиналов, оставшихся на базовой шаблон-странице. Редактирование любого атрибута копии разрывает наследование его от оригинала.

Взгляните, например, на шаблоны A-Master и B-Master на рис. 15.15, а. Шаблон A-Master является базовым, а шаблон B-Master — дочерним. Серый прямоугольник в центре страницы на базовом шаблоне имеет иной размер и повернут на 10° по часовой стрелке. Если на шаблоне A-Master изменить цвет прямоугольника, то и на шаблоне B-Master цвет прямоугольника станет таким же. С другой стороны, если на базовом шаблоне изменить угол поворота прямоугольника, то на дочернем шаблоне никаких изменений не произойдет. Очевидно, это происходит потому, что угол поворота прямоугольника на дочерней странице задан вручную, "отформатирован локально".

Трансформирование считается отдельным атрибутом объекта. Если, например, вы повернете объект на дочерней странице, то изменение его размера на базовой шаблон-странице никак не повлияет на размер на дочерней шаблон-странице. Это связано с тем, что вращение и масштабирование считаются единым атрибутом, трансформированием.

Как локальное форматирование символов текста, так и "локальное форматирование" объектов на дочерних шаблон-страницах можно отменить. В результате объекты примут тот вид, который они имеют на базовых шаблон-страницах. С этого момента изменение любых атрибутов объектов на базовой шаблон-странице будет отражаться и на дочерней. Разумеется, это будет справедливо до тех пор, пока вы снова не отредактируете объект на дочерней шаблон-странице вручную.

Отмена редактирования на дочерней шаблон-странице не тождественна повторному связыванию ее с базовой. В результате повторного связывания дочерней шаблон-страницы с базовой отредактированные объекты не будут удалены. В результате каждый из таких объектов появится на дочерней шаблон-странице в двух копиях: исходной (как на базовой шаблон-странице) и отредактированной.

На рис. 15.15, б показан результат добавления объекта на базовую шаблон-страницу A-Master. Объект появился на всех дочерних шаблон-страницах. Добавление объекта только, например, к шаблон-странице C-Master, сказалось бы исключительно на шаблон-странице Е-Master, для которой она приходится базовой. Для остальных страниц шаблон E-Master базовым не является, поэтому изменение их бы не затронуло.

Вид палитры Pages с шаблонами для приведенного примера изображен на рис. 15.16. Из него видно, что на пиктограммах дочерних шаблон-страниц нарисованы префиксы соответствующих им базовых шаблонов. Например, на пиктограмме шаблона B-Master находится префикс "А", говорящий о том, что базовым для него является шаблон A-Master.

Рис. 15.16. Иерархия шаблонов в палитре Pages


Создание новой шаблон-страницы и редактирование шаблонов

Палитра шаблонов используется не только для применения шаблон-страниц, но также для создания новых шаблонов и редактирования уже имеющихся. Для создания и редактирования шаблон-страниц используются диалоговые окна Master Options и New Master. Кроме того, при создании и редактировании бывает необходимо выполнить некоторые действия непосредственно в открытом шаблоне.

Чтобы открыть это диалоговое окно для новой шаблон-страницы, выберите в меню палитры команду New Master или щелкните на пиктограмме новой страницы на панели инструментов палитры Pages, нажав клавиши <Alt>+<Ctrl>. Откроется диалоговое окно, представленное на рис. 15.17, с помощью которого вы сможете выполнить все основные действия по созданию шаблон-страницы.

В поле Prefix задается префикс имени шаблон-страницы, а в поле Name — само имя. Список Based on Master содержит все существующие в документе шаблон-страницы. Из них вы можете выбрать ту, которую сделаете базовой для создаваемой. Если вы это сделаете, то на созданной шаблон-странице будут присутствовать все элементы базовой. Количество страниц в шаблоне вводится в поле Number of Pages. Одностраничные шаблоны используют для односторонней печати, двухстраничные — для оборотной. Большее число страниц в шаблоне чаще всего используют для складных буклетов, наподобие туристских карт или рекламы. В таких изданиях не используют скрепление, а целиком печатают на одном листе бумаги и фальцуют.

После задания основных характеристик шаблон-страницы в диалоговом окне нажмите кнопку ОК. InDesign автоматически откроет для редактирования вновь созданную страницу-шаблон, чтобы вы сразу могли ввести нужные элементы и создать модульную сетку.

Рис. 15.17. Диалоговое окно New Master

Отредактировать шаблон можно и впоследствии, непосредственно перейдя на шаблон-страницу и выполнив на ней все необходимые действия. Двойной щелчок мышью на пиктограмме шаблон-страницы отобразит ее в окне документа.

При необходимости можно отредактировать все основные параметры шаблона, заданные в диалоговом окне New Master. Для этого выберите команду Master Options for <имя шаблона> меню палитры Pages. Открывшееся диалоговое окно Master Options как две капли воды похоже на диалоговое окно New Master, только заголовок другой.

Редактирование шаблон-страницы ничем не отличается от редактирования обычной страницы. Вы также можете изменять параметры полей и колонок в диалоговом окне Margins and Columns, создавать направляющие линии как вручную, так и с помощью команды Create Guides, размещать на странице фреймы, иллюстрации, фигуры, текст и любые другие объекты InDesign. Результаты редактирования шаблон-страницы проявляются мгновенно. Сразу же по окончании редактирования на всех страницах, к которым применена измененная шаблон-страница, будут воспроизведены внесенные в последнюю изменения.


Создание шаблон-страницы на основе ранее подготовленной страницы

Построить новую шаблон-страницу можно не только "с нуля", но и на основе ранее подготовленной шаблон-страницы. Для этого выберите исходный шаблон, а затем перейдите в меню палитры и выберите команду Duplicate Master <имя шаблоиа>. Такой прием очень удобен для быстрого создания варианта шаблон-страницы. Например, его можно использовать, если потребовалось вставить в текст диаграмму или разместить на странице журнала модуль рекламных объявлений.

Рис. 15.18. Копирование шаблона перетаскиванием мышью

Еще естественнее воспользоваться для копирования шаблонов мышью. Для этого нужно перетащить выделенную пиктограмму шаблона на кнопку с изображением новой страницы в палитре Pages или на свободное место в нижней части палитры при нажатой клавише <Alt> (рис. 15.18). В обоих случая будет создан новый шаблон с тем же содержимым, что и исходный. Его имя будет состоять из имени исходного шаблона с добавлением слова "copy".

Можно создать шаблон-страницу из страницы публикации — для этого служит команда меню палитры Save As Master. Это очень удобно, если, например, вы удачно скомпоновали страницу публикации вручную и хотите распространить ее модульную сетку и другие элементы на другие страницы публикации. Закончите компоновку страницы, затем выберите команду Save As Master. С помощью мыши эта операция выполняется еще проще: достаточно перетащить пиктограмму страницы или разворота из верхней половины палитры Pages в нижнюю.


Копирование шаблон-страниц между документами

Чтобы скопировать шаблон-страницу из одного документа в другой, просто перетащите мышью ее пиктограмму в окно любого другого документа InDesign.


Удаление шаблонов. Страница без шаблона

Для удаления шаблона нужно либо воспользоваться командой меню палитры шаблонов Delete Master <имя шаблона>, либо просто перетащить строку с удаляемым шаблоном к изображению мусорной корзины внизу палитры. InDesign запрашивает подтверждение удаления шаблона. При удалении шаблона со страниц исчезают все графические и текстовые элементы шаблона. Остаются только вспомогательные линии границ полей.

Первая пиктограмма списка шаблонов в палитре Pages, None применяется для отмены действия каких-либо шаблонов на текущую страницу публикации. Для того чтобы страница перестала соответствовать шаблону, примените к ней "псевдошаблон" None. При этом элементы текущего шаблона будут удалены со страницы.


Стандартные элементы шаблон-страницы

Построение шаблон-страницы обычно начинается с формирования модульной сетки. Определив положение всех вспомогательных линий, можно приступить к размещению стандартньсс элементов на шаблон-странице. На рис. 15.19 представлены верхний и нижний колонтитулы, колонцифра (номер страницы) и верхняя линейка (линия, выделяющая страницу сверху) — некоторые из элементов, обычно размещаемых на шаблон-странице.

Рис. 15.19. Стандартные элементы шаблон-страницы, размещенные на своих местах по модульной сетке


Колонки и модульная сетка

Мы уже многократно отмечали, что модульная сетка определяет организацию пространства страниц публикации. Чтобы издание не "разваливалось" на отдельные, выглядящие по-разному страницы, задайте его модульную сетку на шаблон-странице. Используйте для этого команды Margins and Columns, Create Guides и ручное размещение направляющих линий.


Колонтитулы и линейки

В верхней части рис. 15.19 расположены линейка и верхний колонтитул, которые переходят с шаблон-страницы на все страницы публикации. Обычно ширина линейки составляет 8 пунктов. В состав верхнего колонтитула, как правило, входят название книги и заголовок верхнего уровня. Линейка и колонтитул размещаются в верхней части всех страниц публикации, и их введение в состав шаблон-страницы экономит много времени и позволяет обеспечить единообразие. Представьте себе, каково было бы размещать эти элементы вручную на всех 600 страницах книги, — лучше даже не думать об этом и сразу воспользоваться услугами шаблон-страницы. Можно также предусмотреть отдельные колонтитулы для колонок в пределах границ колонки. Всегда удобнее заранее предусмотреть все варианты верстки, сопоставив каждому свою шаблон-страницу. Например, одна шаблон-страница может соответствовать внутренним страницам глав с набором в две колонки, линейкой и колонтитулом, другая — с линейкой и колонтитулом другой структуры и одной колонкой для верстки оглавления, и так далее.


Текстовые и графические фреймы

Пустые текстовые фреймы, расположенные на шаблон-страницах, используются для автоматического и полуавтоматического размещения текста. Размещение текстовых фреймов на шаблон-страницах диктует современный и эффективный стиль верстки. Он заключается в тщательной проработке дизайна страниц при подготовке шаблона. После этого размещение текста на страницах публикации становится легким и большей частью автоматизированным. Создавая шаблон, вы определяете те места на странице, где должен размещаться текст, а стили задают формат текста. В результате после размещения текст оказывается на своем месте и практически полностью отформатированным. Вам останется только ручная доводка.

Сказанное выше относится и к графическим фреймам. Чтобы определить фрейм на шаблон-странице как текстовый или графический, воспользуйтесь списком Content меню Object или контекстного меню. Он содержит варианты Graphics, Text и Unassigned. Последний вариант применяют к фреймам, которые предполагается использовать только как геометрические фигуры, не размещая в них никаких элементов. Этот тип содержимого имеют объекты, создаваемые инструментами Rectangle, Ellipse и инструментами группы Pen. Простые графические формы сейчас широко используются как самостоятельный элемент дизайна.

Резервируя места для текста и графики на шаблон-странице, вы облегчаете себе работу и добиваетесь единства оформления публикации.


Автоматическая нумерация страниц

Размещаемые на шаблон-странице колонтитулы технически представляют из себя обычный текстовый материал. Постройте на шаблон-странице текстовый фрейм. Установите внутри текстового фрейма точку вставки и нажмите клавиши <Ctrl>+<Alt>+<N> — в тексте появится символ колонцифры выбранного шаблона. Этот символ на шаблон-странице выглядит просто как префикс выбранного шаблона. На страницах публикации, соответствующих шаблону, вы, конечно, увидите не префикс шаблона, а саму колонцифру. Колонцифру можно разместить на любой странице публикации, но обычно ее размещают на шаблон-странице. Возможно, перед колонцифрой должен появиться префикс (номер раздела или главы), введенный в соответствующее поле диалогового окна параметров публикации при ее создании. Это — важный момент, поскольку префикс не вставляется перед колонцифрой автоматически, его необходимо ввести с клавиатуры. И префикс и символ колонцифры следует отформатировать требуемыми атрибутами, как обычный текст.

Нумерация страниц тесно связана с разбивкой документа на разделы. Разделы могут иметь различную нумерацию страниц. Подробнее об этом рассказано в следующем разделе настоящей книги.


Страницы

Палитра Pages служит для управления не только шаблон-страницами, но и собственно страницами публикации. Пиктограммы всех страниц публикации находятся в верхней части палитры. С их помощью можно переходить от одной страницы документа к другой, устанавливать посередине окна документа отдельную страницу (двойным щелчком на ее пиктограмме) или разворот (двойным щелчком на номерах страниц разворота). Основное же назначение пиктограмм состоит в управлении страницами: их вставке, удалении, сортировке, организации разворотов.


Вставка страниц

Как правило, шаблоны для публикации, по крайней мере вчерне, создают еще до начала верстки страниц. Поэтому при добавлении новых страниц приходится указывать и шаблон, которому они следуют. В самом общем случае для добавления страниц используют команду Insert Pages из меню палитры Pages. Она открывает диалоговое окно, изображенное на рис. 15.20. К тому же результату приведет щелчок на кнопке создания новой страницы на панели инструментов палитры Pages, если удерживать нажатой клавишу <Alt>.

В поле Pages вводится количество добавляемых страниц. Список и поле ввода Insert определяют положение вставляемых страниц в документе:

  • After Page. После страницы, указанной в расположенном справа поле ввода.
  • Before Page. Перед страницей, указанной в расположенном справа поле ввода.
  • At Start of Document. В начало документа, перед первой страницей.
  • At End of Document. В конец документа, за последней страницей.

Рис. 15.20. Диалоговое окно Insert Pages

Список Master позволяет выбрать любой из существующих шаблонов, на основе которого будет создана новая страница.

При добавлении страниц к документу, предназначенному для оборотной печати, следите за сохранением четности сверстанных страниц. В противном случае правые и левые страницы поменяются местами и верстка разрушится. Если при этом включен режим автоматической настройки макета, то вы можете даже не сразу заметить ошибку, ведь InDesign попытается перестроить страницы в соответствии с новым шаблоном.

Для добавления небольшого числа страниц удобно использовать мышь. Захватите пиктограмму нужного шаблона в нижней части палитры Pages и перетащите ее в верхнюю часть. Там поместите курсор между теми страницами, куда вы собираетесь вставить дополнительную. При этом место вставки новой страницы показано жирной вертикальной линией (рис. 15.21).

Рис. 15.21. Добавление страниц

Быстро добавить новую страницу с параметрами текущей можно щелчком на кнопке создания новой страницы на панели инструментов палитры Pages. Новая страница размещается непосредственно за текущей и имеет тот же самый шаблон.


Развороты

Если в диалоговом окне Document Setup установлен флажок Facing Pages, то вместо отдельных страниц в документе будут находиться развороты. При оборотной печати для правых и левых страниц разворота как правило используются разные, часто зеркально симметричные, шаблон-страницы. Развороты отображаются в палитре Pages сдвоенными пиктограммами страниц.

Нечетные страницы разворотов всегда правые, а четные — левые. Поэтому первая страница оборотной публикации всегда одиночная, правая (нечетная). Если вы хотите, чтобы публикация начиналась с левой страницы, необходимо изменить нумерацию страниц так, чтобы первая страница имела любой четный номер. О том, как этого добиться, сказано ниже, при обсуждении разделов.


Перестановка страниц

Эта операция выполняется при помощи перетаскивания их пиктограмм на нужные места. Для всех манипуляции со страницами требуется их предварительно выделить. Чтобы выделить отдельную страницу, щелкните на ее пиктограмме. Щелчок на номерах страниц разворота выделяет разворот. Если, например, требуется перенести разворот 4-5 так, чтобы он располагался перед разворотом 2 - 3, то выделите его щелчком на номерах страниц и перетащите его пиктограммы в промежуток между пиктограммами страницы 1 и разворота 2-3. Нумерация страниц при этом, разумеется, останется верной.


Многостраничные развороты

InDesign позволяет создавать развороты, состоящие из более, чем двух страниц. Такие развороты используются для печати складных буклетов. Линии фальцовки при этом проходят по границам страниц разворота (рис. 15.22).

Рис. 15.22. Буклет в четыре разворота

Многостраничные развороты в InDesign носят название "island spread" и к ним не применяется характеристика Facing Pages в установках документа. Чтобы создать многостраничный разворот, в палитре Pages выберите отдельную страницу или обычный разворот, а затем, в меню палитры — команду Set as Island Spread. Номер страницы или страниц разворота будет заключен в квадратные скобки, показывающие, что разворот многостраничный.

Если в разворот должно входить большее количество страниц, то их следует добавить. Это могут быть как пустые, так и уже сверстанные страницы. Чтобы добавить сверстанные страницы, перетащите пиктограмму требуемой страницы (из верхней части палитры Pages) к краю пиктограммы многостраничного разворота. Если это будет правый край, то страницы добавятся в конец разворота, а если левый, то в начало (рис. 15.23). Чтобы добавить к многостраничному развороту новую пустую страницу, воспользуйтесь диалоговым окном Insert Pages. Новая страница будет добавлена сразу после текущей страницы разворота.

а [image] б

Рис. 15.23. Добавление сверстанных страниц к многостраничному развороту в начало (а) и в конец (б)

Чтобы снова разбить многостраничный разворот на отдельные страницы или двухстраничные развороты, нужно выбрать в меню палитры Pages команду Clear Island Spread. Результат разбивки зависит от установки Facing Pages в диалоговом окне Document Setup. Перед разбивкой многостраничного разворота тщательно проверьте порядковые номера его страниц. В противном случае четные страницы могут оказаться на правых сторонах разворота, а нечетные — на левых. Это приведет к нарушению верстки, особенно если режим автоматической настройки макета включен.

Для верстки многостраничных разворотов применяются многостраничные же шаблоны. Количество страниц в развороте шаблон-страницы задается при ее создании в поле Number of Pages диалогового окна New Master.


Дублирование страниц

Чтобы создать копию страницы, проще всего перетащить ее пиктограмму в требуемое положение между другими страницами в палитре Pages, удерживая клавишу <Alt>. Если, например, вы хотите вставить копию второй страницы между страницами 5 и 6, то перетащите пиктограмму второй страницы в палитре Pages в промежуток между пиктограммами страниц 5 и 6.

Если копию страницы необходимо поместить в конец документа, либо перетащите пиктограмму дублируемой страницы к кнопке новой страницы на панели инструментов палитры Pages, либо воспользуйтесь командой Duplicate Page (Spread) из ее меню.

Если на копируемой странице есть текстовые фреймы, связанные с фреймами на другой странице, то фреймы копии не будут связаны с ними. Связь останется у фреймов исходной страницы.


Копирование страниц между документами

Чтобы скопировать страницу или разворот из одного документа в другой, перетащите его пиктограмму в окно любого другого документа InDesign.


Удаление страниц

Чтобы удалить страницу из документа, перетащите ее пиктограмму к кнопке удаления на панели инструментов палитры Pages или выберите команду Delete Page (Spread) меню палитры. В последнем случае будет удалена текущая страница или разворот.


Редактирование элементов шаблона

Хотя элементы шаблонов находятся на шаблон-страницах, вы имеете к ним доступ и со всех подчиненных им страницах публикации. Для того чтобы выделить на странице публикации объект, принадлежащий шаблон-странице, следует использовать инструмент Selection при нажатых клавишах <Ctrl>+<Shift>.

Если элемент шаблон-страницы был ранее отредактирован на построенной по нему странице документа, то при его выделении не нужно больше удерживать <Ctrl>+<Shift>. Объект становится уже как бы "своим" для этой страницы.

С выделенным объектом вы можете выполнять любые операции, подходящие для данного типа (форматирование текста, трансформирование фигур, редактирование цветов и т. п.) или вовсе его удалить. Отредактированный объект при этом не теряет связи со своим оригиналом на шаблон-странице. Здесь работает тот же принцип, что и в отношении базовых и дочерних шаблон-страниц. Те атрибуты объекта, которые вы изменили вручную, не наследуются от оригинала на шаблон-странице. Редактирование этих атрибутов объекта на шаблон-странице никак не скажется на странице публикации. Атрибуты объекта, которые не редактировались вручную, наследуются от оригинала на шаблон-странице. Если, например, вы измените размер прямоугольника с шаблон-страницы на построенной по нему странице документа, то никакие последующие изменения его размеров на шаблон-странице не отразятся на его копии с обычной страницы. При этом, отредактировав цвет прямоугольника на шаблон-странице, вы измените и цвет того, что на подчиненной ему обычной странице.

Трансформирование считается отдельным атрибутом объекта. Если повернуть объект на дочерней странице, то изменение его размера на базовой шаблон-странице никак не повлияет на размер на дочерней шаблон-странице. Это связано с тем, что вращение и масштабирование считаются единым атрибутом, трансформированием.

Для того чтобы отменить редактирование элемента шаблона на странице документа, выделите его инструментом Selection и выберите команду Remove Selected Local Overrides меню палитры Pages. В результате объект примет точно тот вид, который он имеет на шаблон-странице, и все его атрибуты снова станут зависимыми от его оригинала на шаблон-странице.

Если вы хотите отменить результат "местного" редактирования всех элементов шаблон-страницы, выберите из меню палитры Pages команду Remove All Local Overrides, не выделяя никаких объектов.

Отмена редактирования элементов шаблон-страницы не тождественна повторному применению к ней шаблона. В результате повторного применения шаблона отредактированные копии элементов шаблона не удаляются. Поэтому каждый из таких объектов появится на странице документа в двух копиях: исходной (как на шаблон-странице) и отредактированной.


Разделы

Верстка изданий большого объема или с развитой структурой часто требует разбивки публикации на разделы с собственной, иногда довольно затейливой нумерацией. InDesign решает эту проблему созданием разделов. Разбивка публикации на разделы возможна в любой момент работы над ней. Вы можете определить структуру разделов заранее, а можете создать ее, уже имея полностью готовую верстку.

Рис. 15.24. Маркер раздела в новом документе

Любой документ состоит хотя бы из одного раздела. Об этом свидетельствует специальный маркер, располагающийся над пиктограммой страницы в палитре Pages. Маркер имеет вид маленькой черной треугольной стрелки, направленной вниз (рис. 15.24). В новом документе он располагается над первой страницей, которая и открывает единственный раздел.


Создание разделов

Чтобы определить раздел, необходимо указать программе страницу, которая его открывает. Для этого сначала выделите страницу в палитре Pages, а затем выберите команду Section Options меню палитры. Команда открывает диалоговое окно, представленное на рис. 15.25.

Рис. 15.25. Диалоговое окно New Section

Чтобы начать новый раздел, установите в диалоговом окне New Section флажок Start Section.

Каждый раздел имеет идентифицирующий его префикс. Префикс должен иметь не более пяти символов. Он вводится в поле Section Prefix. Этот маркер используется в поле Go to Page в окне документа для ввода номера страницы, принадлежащей какому-либо разделу. Кроме того, это поле всегда показывает, к какому разделу относится текущая страница. Из-за ограниченности размера данного поля лимитирована и длина префикса.

Если префикс предназначен в InDesign "для внутреннего использования", то имя раздела часто должно фигурировать на страницах публикации. Чаще всего имя раздела указывают в колонтитуле каждой (или каждой второй) его страницы. Имя раздела не ограничено по длине и вводится в поле Section Marker.

Нумерация страниц в разделе может продолжать нумерацию страниц предыдущего раздела, а может начинаться сначала. В первом случае установите переключатель Continue from Previous Section группы Page Numbering. Во втором случае следует установить переключатель Start at и в имеющееся рядом поле ввести номер первой страницы раздела.

При смене нумерации в разделах внимательно следите за сохранением четности страниц. Если вы, например, объявите началом раздела левую страницу разворота и начнете в нем нумерацию с единицы, то четные и нечетные страницы в этом разделе поменяются местами. Это наверняка приведет к плачевным последствиям для верстки.

В небольших изданиях со сложной структурой, например в руководствах, или для нумерации на вкладках, страницы нумеруют не только арабскими цифрами. В InDesign вы имеете широкий выбор стилей нумерации, задаваемый списком Style. Это арабские цифры, римские цифры (прописные и строчные), буквы латинского алфавита (прописные и строчные).

Как только вы закроете диалоговое окно New Section нажатием кнопки ОК, выделенная страница станет началом раздела, и в палитре Pages над ее пиктограммой появится маркер раздела.


Редактирование параметров разделов и их удаление

Для редактирования параметров раздела используется то же самое окно, что и для их первоначальной установки (оно только имеет иной заголовок. Section Options). Оно открывается той же командой меню палитры Pages. При этом в ней может быть выделена любая страница, принадлежащая разделу, а не обязательно первая.

Если вы решили перенести начало раздела на другую страницу публикации, то вам придется сначала уничтожить существующий раздел, а затем создать новый с другим началом и теми же параметрами. Чтобы удалить раздел, снова воспользуйтесь диалоговым окном Section Options. В нем нужно сбросить флажок Start Section и нажать кнопку ОК. Эта операция никак не отражается на самой верстке (если не изменяется четность страниц).


Имена разделов на страницах

Как мы уже отмечали, имена разделов часто размещают на страницах публикаций, например в колонтитулах. Поскольку колонтитулы создают на шаблон-страницах, имена разделов чаще всего размещают там же. Впрочем, InDesign не ограничивает вашу свободу, и вы можете поместить имя раздела на любой странице публикации сколько угодно раз.

Прежде чем разместить номер раздела на странице или шаблон-странице, создайте для него обычный текстовый блок. Затем поместите текстовый курсор внутрь текстового блока и из списка Insert Special Character контекстного меню выберите опцию Section Marker. Если вы установили маркер на шаблон-странице, то он будет представлен словом "Section" (рис. 15.26, а). Разумеется, на подчиненных этому шаблону страницах документа слово "Section" будет заменено на реальное имя текущего раздела (рис. 15.26, б). Это имя вы должны были предварительно ввести в поле Section Marker диалогового окна Section Options.

а [image] б

Рис. 15.26. Маркер раздела на шаблон-странице (а) и странице (б)


Слои

Для чего придуманы слои документа

Рассмотрим этот продукт интеграции программ компьютерной полиграфии. Слои можно сравнить с листами прозрачной пленки, сложенными в стопку друг на друга. Вы можете видеть сквозь слой другие слои (непрозрачные объекты, расположенные на слое, могут закрывать частично или полностью объекты нижних слоев). Эта технология применяется в растровых графических процессорах для организации псевдообъектной структуры изображения. Фрагменты, находящиеся на разных слоях, можно свободно передвигать, искажать, применять к ним различные эффекты. При этом воздействие будет ограничено только данным "объектом", остальные части изображения останутся незатронутыми. Таким образом на порядок упрощается редактирование растровой графики, особенно компоновка текста с графикой и изготовление коллажей. Слои применяются и в объектных графических процессорах для редактирования сложных изображений, для упрощения работы с многократно наложенными изображениями, для организации сложных систем вспомогательных линий, ремарок и т. д. Теперь идеология слоев проникла в издательскую систему. Что же такое слои в In-Design, и как идеология слоев может облегчить монтаж публикаций?

Программа InDesign орган'! нет публикацию как один или несколько слоев. Слои InDesign, как и в графических процессорах, дают возможность создавать и редактировать отдельные объекты публикации независимо от других объектов. Слои можно применить во многих случаях сложных макетов. Например, разместив, текст на одном слое, а изображения — на другом, вы можете временно сделать слой с изображениями невидимым, что значительно облегчит работу с текстом. При создании публикаций, имеющих несколько языковых версий, слои предоставляют удобный способ размещения каждого варианта перевода на отдельном слое. При наличии наложенных объектов удобно помещать различные их группы на разных слоях для их упорядочения.


Что представляют собой слои

Слои — это части документа InDesign, имеющие следующие особенности:

  • Каждый слой существует на всех страницах документа, в том числе на шаблон-страницах. Слои могут быть видимыми или невидимыми на экране и редактируемыми или закрепленными.
  • На слоях могут находиться любые объекты верстки, включая вспомогательные линии.
  • Слои документа накладываются друг на друга. Для каждого документа можно задать любое количество и порядок следования слоев. Порядок наложения слоев можно свободно менять.
  • Слои можно создавать, переименовывать и удалять. При этом документ обязательно должен иметь хотя бы один слой.
  • По умолчанию все новые публикации InDesign состоят из единственного слоя с именем Layer 1.
  • В любой момент в публикации есть активный или целевой слой, на котором и размещаются все вновь созданные в документе объекты. Одновременно может быть активен только один слой.
  • Объекты можно переносить и копировать с одного слоя на другой по определенным правилам.

Таковы наиболее важные свойства слоев документа. В следующих разделах мы рассмотрим свойства слоев и их редактирование с использованием палитры слоев — основного инструмента для действий со слоями. К операциям со слоями относится создание слоя и определение его параметров, изменение порядка наложения слоев, удаление и объединение слоев, закрепление слоев, режимы отображения слоев, назначение цвета слоям. Далее рассмотрим операции с объектами верстки, находящимися на слоях документа — их размещение, выделение, перемещение, копирование, вклеивание с одного слоя на другой.


Палитра слоев

Все операции со слоями производятся с помощью одного инструмента — палитры Layers. Она используется для создания, редактирования, закрепления, удаления слоев. В палитре Layers помещены элементы управления атрибутами отдельных слоев. С ее помощью определяется порядок их взаимного наложения. Наконец, палитра слоев служит для перемещения объектов между слоями.

Чтобы открыть палитру Layers, выберите команду Show layers меню Window. Клавиатурное сокращение для вызова палитры слоев — <F7>. На экране появится палитра, изображенная на рис. 15.27. О принципах работы и о стандартных элементах палитр можно прочитать в главе 1.

Рис. 15.27. Палитра Layers—основной инструмент при работе со слоями документа. Меню палитры


Выбор активного слоя

Активный (целевой) слой публикации — это тот слой, на котором будут создаваться и редактироваться объекты. Для выбора целевого слоя щелкните мышью на его названии в палитре слоев. Как видно из рисунка, целевой слой при этом выделяется в палитре подсветкой; в строке активного слоя появляется также значок "перо". В нижней части палитры приводится короткая справка об активном слое. Если выбрать объект на странице, то слой, на котором он находится, автоматически станет целевым. Справа от имени слоя при этом появляется цветная точка. На рис. 15.27 активным является слой "Графика".


Атрибуты слоя

В палитре слоев в каждой строке часть атрибутов слоя изображена в виде пиктограмм (рис. 15.28). Если вы щелкнете дважды на строке любого слоя, откроется окно Layer Options, в котором также указаны эти атрибуты. В диалоговое окно параметров можно войти и командой меню палитры Layer Options.

Атрибуты слоя устанавливаются в этом диалоговом окне. Некоторые из них можно менять и непосредственно в строке палитры.

Каждый из слоев документа может иметь следующие атрибуты:

  • Слой может иметь определенное имя. Имя слоя задается при его создании. Оно отображается в средней части строки слоя в палитре. Для изменения имени слоя войдите в диалоговое окно Layer Options и отредактируйте значение в строке Name.

а [image] б

Рис. 15.28. Пиктограммы атрибутов слоя и окно Layer Options

  • П Слой может быть видимым или невидимым. Индикатор видимости слоя представляет собой пиктограмму в крайнем столбце палитры слева от имени слоя. Если на серой кнопке имеется изображение глаза, слой виден на экране. Если изображение глаза отсутствует — данный слой не виден на экране. Сделав слой невидимым, вы не только отмените его отображение на экране, но также сделаете невозможным его редактирование и печать. Чтобы сделать слой видимым или невидимым, щелкните мышью на пиктограмме видимости. Появившийся значок "глаз" будет указывать на то, что слой является видимым. Щелкните мышью еще раз, чтобы спрятать значок и сделать слой невидимым. Этот режим отображения можно изменить и в диалоговом окне Layer Options. Для этого предназначен флажок Show Layer. Если он установлен, слой отображается. Атрибутом видимости можно управлять одновременно для нескольких слоев. Если протащить курсор через несколько строк вверх или вниз по палитре, режим отображения всех слоев, через строки которых прошел курсор, изменится так же, как для того слоя, с которого вы начали протаскивание. Чтобы сделать невидимыми все слои, кроме выбранных, выделите в палитре один или несколько слоев, которые вы хотите оставить на экране, затем выберите из меню палитры Layers команду Hide Others, либо нажмите клавишу <Alt> и щелкните мышью на любом значке "глаз". Если необходимо отменить невидимость для всех слоев документа, выберите команду Show All Layers меню палитры Layers, либо нажмите клавишу <Alt> и щелкните мышью в первом столбце палитры напротив имени любого из слоев. Обратите внимание, что атрибуты слоя существуют одновременно для всех страниц документа. Поэтому, если находясь на странице 4, вы сделали слой 1 невидимым, то объекты, относящиеся к нему, не будут видимы не только на стр. 4, но и на остальных страницах документа.
  • Слой может быть или закрепленным, или нет. Объекты, расположенные на закрепленных слоях, не могут быть выделены или отредактированы. Таким образом, имеет смысл закрепить слой после окончания редактирования находящихся на нем объектов. Если на странице много мелких или перекрывающихся объектов, можно временно вынести те из них, которые пока не нужно редактировать, на отдельный слой и закрепить его. В противном случае бывает трудно выбрать редактируемый объект из "кучи" на странице. Наличие закрепления отображается на кнопке во втором слева столбце напротив имени слоя пиктограммой с изображением перечеркнутого карандаша. Если на этом месте нет пиктограммы, слой не закреплен. Чтобы закрепить слой или отменить его закрепление, щелкните мышью на кнопке закрепления. На ней появится перечеркнутый карандаш — слой закреплен. Щелкните мышью еще раз, чтобы убрать значок и отменить закрепление слоя. Чтобы задать или отменить закрепление нескольких слоев, протащите курсор через несколько строк вверх или вниз по палитре. В диалоговом окне Layer Options режим закрепления переключается флажком Lock Layer. Если флажок установлен, слой закреплен. Чтобы закрепить все слои, кроме одного (целевого), отмените закрепление всех слоев и щелкните мышью на имени нужного слоя. Затем войдите в меню палитры Layers и выберите команду Lock Others или нажмите клавишу <Alt> и щелкните мышью во втором столбце палитры напротив имени любого слоя. Чтобы отменить закрепление всех слоев, выберите команду Unlock All меню палитры Layers, либо нажмите клавишу <Alt> и щелкните мышью на значке "перечеркнутый карандаш" слева от имени любого слоя.
  • Слой может иметь определенный цвет. Цвет слоя — это вспомогательный атрибут. Задав для каждого слоя документа собственный цвет, вы сможете легко определить, на каком слое расположен тот или иной выделенный объект. При выделении объекта его маркеры-ограничители окрашиваются в цвет, назначенный соответствующему слою. Цвет слоя отображается слева от имени слоя в палитре Layers. Чтобы изменить цвет слоя, двойным щелчком выделите имя слоя в палитре Layers. В открывшемся диалоговом окне Layer Options выберите один из вариантов в раскрывающемся списке Color и нажмите кнопку ОК.
  • На любом слое могут находиться направляющие линии. Используя флажки Show Guides и Lock Guides в диалоговом окне Layer Options, вы можете временно спрятать их или закрепить. Закрепление направляющих поможет вам избежать случайного смещения или выделения направляющих вместо объектов. Чаще всего направляющие располагают на отдельных слоях. Слой может располагаться определенным образом относительно других слоев. Как отмечалось во введении к этому разделу, слои можно представить, как прозрачные пленки, содержащие объекты верстки и наложенные один на другой. В такой виртуальной "стопке", как и в реальной, будет определенный порядок наложения слоев. Разумеется, при этом объекты, расположенные на слоях, будут перекрываться в соответствии с расположением слоев, т. е. объекты верхнего слоя будут перекрывать объекты нижнего. Наложение объектов, расположенных на разных слоях, иллюстрирует рис. 15.29.

а [image] б

Рис. 15.29. Наложение объектов, находящихся на разных слоях (а) и список этих слоев в палитре Слои (б)

Порядок наложения слоев в документе может быть произвольным. В палитре Layers отображаются все слои документа; самому верхнему слою соответствует верхняя строка палитры. В любой момент можно изменить этот порядок. Для этого с помощью мыши переместите слой по палитре Layers на новое место. При нажатой клавише <Ctrl> можно выделить одновременно несколько слоев, а затем одновременно переместить их на новую позицию. При этом взаимное расположение перемещенных слоев будет сохранено. После изменения порядка следования слоев изменится порядок наложения объектов, на них находящихся (рис. 15.30, а—до изменения, 15.30, б — после).

а [image] б

Рис. 15.30. Изменение порядка наложения объектов при перестановке слоя

Напомним, что атрибуты слоя едины для всех страниц документа, поэтому при изменении порядка слоев перекрывание объектов изменится на всех страницах, где есть объекты, расположенные на затронутых перестановкой слоях.


Создание нового слоя

Щелкните мышью на пиктограмме (чистая страница) внизу палитры стилей. Откроется окно New Layer, аналогичное окну Layer Options. В нем задается имя слоя, цвет и нужные атрибуты (невидимость и закрепление). Впоследствии все эти атрибуты легко могут быть изменены.


Удаление и объединение слоев

Для удаления слоев из документа вы можете использовать команды меню палитры Layers. При этом объекты, размещенные на удаляемом слое, удаляются.

Поскольку каждый слой существует на всех страницах публикации, а не только на одной определенной странице, рекомендуем вам перед удалением слоя сделать все остальные слои невидимыми и просмотреть каждую страницу публикации. Это позволит вам увидеть все объекты, которые вы собираетесь удалить.

Чтобы удалить слой, выделите имя слоя в палитре и выберите команду Delete Layer <имя слоя> меню палитры. Вместо выбора команды удаления можно щелкнуть мышью на значке "мусорная корзина" в нижней части палитры или просто перетащить удаляемый слой к значку "мусорная корзина". InDesign откроет диалоговое окно с запросом о подтверждении вашего решения.

Если в публикации накопилось много слоев, имеет смысл удалить пустые, т, е. не содержащие никаких объектов. Можно, конечно, сделать это вручную, однако в этом случае велик шанс потерять данные — может оказаться, что на считавшемся пустым слое по ошибке размещены объекты, и при быстром удалении они пропадут. При автоматическом же удалении пустых слоев программа сама анализирует наличие объектов на слоях и удаляет только те, которые действительно являются пустыми.

Автоматическое удаление пустых слоев производится командой Delete Unused Layers меню палитры слоев.

Рис. 15.31. Объединение слоев

При работе вы можете создать временные слои. По окончании работы с ними их нужно либо удалять, либо объединять с основными слоями публикации. Это необходимо для упорядочения структуры публикации и снижения вероятности ошибки программы, которая обусловлена избыточной сложностью документа.

Для объединения слоев применяется команда Merge Layers меню палитры. Перед тем как выполнить эту команду, выберите в палитре те слои, которые вы собираетесь объединять. Для выделения нескольких слоев при выборе удерживайте клавишу <Ctrl>. Слой, который был выделен первым, становится целевым. Объекты будут перемещены на него с остальных слоев. Все остальные выделенные слои будут удалены из публикации. Схема объединения слоев приведена на рис. 15.31.


Объекты на слоях

Объекты могут располагаться либо на одном слое, либо на разных. В пределах одного слоя объекты размещаются в соответствии с порядком наложения. О наложении объектов, находящихся на одном слое, подобнее рассказано в следующей главе. Если объекты расположены на разных слоях, то дополнительно к наложению объектов на странице присутствует наложение слоев. Один или несколько объектов можно выделять, вырезать, копировать и вклеивать независимо от того, находятся они на одном слое или на разных. Особенности операций с объектами на слоях описаны ниже.


Размещение объектов шаблон-страницы

На шаблон-странице, как и на любой странице документа, имеются все созданные слои. На любом из них вы можете расположить объекты шаблон-страницы.

В пределах одного слоя элементы шаблон-страницы всегда оказываются позади объектов, размещенных на построенных по ним страниц документа. Если вам необходимо, чтобы элемент шаблона оказался перед каким-либо объектом на странице, разместите его на слое, находящемся ниже. Рис. 15.32 иллюстрирует порядок перекрывания элементов шаблона и объектов на странице макета в пределах одного слоя и на разных слоях.


Группы объектов

Группа объектов всегда располагается на одном слое. Если выделить несколько объектов на разных слоях и объединить их в группу, все объекты будут перенесены на верхний из задействованных слоев. Если отменить создание группы командой Undo меню Edit, то группа распадется на отдельные

объекты, которые распределятся по исходным слоям. Команда разделения группы не дает такого результата, и объекты, входившие в группу, остаются на том же слое. на котором находилась группа. О группировке объектов читайте в следующей главе.

Рис. 15.32. Шаблон-страница и страница документа. Взаимное расположение объектов на слоях


Выделение объектов

Если на активном слое выделить объект, то справа от имени слоя, на котором он расположен, появляется цветная точка. После перехода на другой слой выделение объекта не снимается.


Вырезание, копирование и вклеивание объектов на слои

Вы можете выделить любое число объектов, находящихся на разных слоях, теми же способами, какие использовали для объектов одного слоя. Выделив, вы можете скопировать или вырезать эти объекты и затем вклеить их на нужное место. Также вы можете переносить объекты с одного слоя на другой. Для вклеивания объектов, скопированных в буфер, существуют два режима:

  • Вклеивание объектов на исходные слои документа. Каждый из скопированных объектов вклеивается на прежний слой.
  • Вклеивание всех скопированных объектов на целевой слой. После копирования выбирается активный слой и командой вклеивания все объекты помешаются на него.

Результат вклеивания объектов из буфера обмена с помощью команды Paste зависит от состояния команды-переключателя Paste Remembers Layers меню палитры слоев. Если в строке этой команды установлен флажок (активна), то все объекты вклеиваются на свои исходные слои. Если команда Paste Remembers Layering неактивна, то все объекты вклеиваются на целевой слой.

Эта закономерность распространяется и на перенос объектов со страницы на страницу. Так, если со слоя 3 первой страницы документа был скопирован объект, и его необходимо вклеить на тот же слой страницы 2, то задайте режим Paste Remembers Layering (Вклеивать на прежние слои). В противном случае объект будет вклеен на активный слой страницы 2.

Если вы вклеиваете изображение во фрейм или помещаете его туда с помощью команды Place, то оно оказывается на том же слое, что и фрейм, а не на текущем.


Перемещение и копирование объектов с помощью палитры слоев

Перемещать и копировать объекты с одного слоя на другой гораздо удобнее и быстрее с помощью палитры Layers. Для этого используется индикатор выделения объектов на строках палитры (цветные точки рядом с именем слоя).

Выделите нужные объекты. В палитре слоев справа от имени слоя, содержащего выделенные объекты, появится цветная точка — индикатор наличия выделения. Щелкните на ней мышью и перетащите к тому слою, на который вы хотите переместить выделенные объекты. Если выделенные объекты расположены на разных слоях, выполните эту операцию для всех задействованных слоев.

Копирование объектов на другой слой выполняется аналогичным образом. Единственное отличие — для выполнения именно копирования, а не перемещения, удерживайте клавишу <Alt> во время перетаскивания индикатора.


Применение модульных сеток

После рассмотрения основы любого документа — модульной сетки и элементов структуры (шаблонов и слоев документа) не будет лишним кратко остановиться на применении всех этих знаний на практике.

В заключение приведены примеры использования модульных сеток и структурированных документов при организации публикаций разного размера, стиля и назначения.


Одноколоночные сетки

Чем меньше колонок расположено на странице, тем легче работать с сеткой. В простом одноколоночном макете работа дизайнера часто вовсе не видна. Простота стиля присуща официальным документам (рис. 15.33), публикациям для распространения внутри фирмы, многостраничным документам — книгам и журналам. В то же время и одноколоночная сетка может быть основой привлекательного макета. Обратите внимание на присутствие горизонтальной структуры в некоторых сетках. Горизонтальное выравнивание элементов для одноколоночных сеток не всегда необходимо, но с увеличением числа колонок горизонтальная структура модульной сетки имеет все большее значение для гармонизации расположения объектов верстки.

Рис. 15.33. Трудовой договор фирмы

На рис. 15.33 представлен абсолютно серьезный документ. Большие поля и широкий интерлиньяж делают эту страницу хорошо читаемой. Строгий шрифт (Arial) сочетается с текстом. Наличие горизонтальных линий внизу и сверху страницы образуют структуру публикации. Такие линии создают иллюзию неизменности макета при изменении объема текста между ними. Текст выключен по формату, поэтому страница выглядит строгой и уравновешенной. Расположение логотипа и заголовка можно свободно менять. Формат — стандартный для документов А4.

Широкое левое поле, текст, выровненный по левому краю, и свободное размещение фотографий и заголовка создают ощущение свободы, которое должно охватывать человека в преддверии выходного дня (рис. 15.34). Свободный интерлиньяж и короткие строки основного текста способствуют легкости чтения — ведь на странице размещена рекламная информация и ваша цель — донести ее даже до самого занятого читателя.

Пример стильного дизайна. Элементарная сетка публикации с широкими полями. Текст левой страницы набран шрифтом Futuris крупного кегля, белым и песочным цветом на черном фоне, выравнивание отсутствует (элемент авангардного дизайна). В правой части приглашения шрифт коричневый и выдержан в классическом духе (Академия), но текст набран шрифтом пяти различных кеглей с расширенным интерлиньяжем. Подложкой служит тонированная в песочный цвет фотография мебельного гарнитура. Таким образом, коричневая гамма объединяет две противоположных тенденции дизайна — классический и авангардный. Традиции качества и современный дизайн — что может быть важнее?!

Как вы могли убедиться, макет красив, когда в нем есть "воздух" — широкие поля, просторный интерлиньяж. Шрифт для одноколоночных макетов не должен быть слишком мелким, т. к. длинные строки неудобочитаемы.

Рис. 15.34. Пригласительный билет на выставку мебели


Двухколоночные сетки

Двухколоночные сетки позволяют создать более сложный и элегантный макет, но и верстка в них сложнее. Они удобны для оформления самых разных изданий — журналов, справочников, каталогов и т. д. (рис. 15.35, а и б). Наличие двух колонок позволяет набирать текст мелким кеглем на большом формате, что очень важно для многостраничных публикаций. Двухколоночный макет более экономичен, чем одноколоночный за счет уменьшения кегля и интерлиньяжа. Страница обычно выглядит более темной и плотной. Однако и здесь важно не перегружать страницу материалом, не сужать до предела поля и средники, не уменьшать интерлиньяж с целью "впихнуть" еще пару абзацев. Такой уплотненный макет будет производить впечатление нехватки бумаги и как следствие, безуспешности вашей фирмы.

а [image] б

Рис. 15.35. Рассказ, помещенный в журнале (а). Страница учебника (б)

Два этих документа (см. рис. 15.35) оформлены по единой сетке, текст размещен в них весьма экономно. Свободное пространство в верхней части страницы и очень простой дизайн позволяют сделать узкие поля и средник. Первый пример (рассказ) должен быть легко читаемым и неофициальным. Поэтому текст выровнен по левому краю (страница при этом становится светлее). Фотография обтекается текстом, слегка повернута, как будто она просто лежит на странице. Это придает материалу убедительность (здесь напечатан биографический очерк).

Рис. 15.36. Авантитул и титульный лист отчета о работе научной лаборатории

Рис. 15.37. Биографии соавторов из предисловия к книге

Шрифт в заголовке аналогичен шрифтовому логотипу группы. Во втором примере дизайн страницы предельно экономичен и функционален. Текст словно свисает с линии под заголовком. Переменная высота колонок позволяет упростить верстку. Все детали макета ориентированы на легкость чтения и ориентировки. Шрифт Academy делает книгу, создает впечатление старого документа или книги.

Пример утонченного и холодного дизайна — рис. 15.36. Здесь и речи нет о симпатии к читателю. Все: и абстрактный рисунок на авантитуле, и расположение текста, и шрифт — направлено на удивление и подавление зрителя. Расположение текста по горизонтальным и вертикальным осям устанавливает равновесие всех текстовых элементов на странице. Мелкий кегль основного текста усиливает впечатление отстраненной элегантности.

Остроумное решение, не правда ли, представлено на рис. 15.37? Расположение текста и фотографий подчеркивает, с одной стороны, факт соавторства этих людей, а с другой — обособляет каждого из них как отдельную личность.


Трехколоночные сетки (Часть I)

Этот тип сеток весьма распространен в полиграфии. Печать в три колонки незаменима при верстке публикаций большого формата — журналах, каталогах и т. д. Популярность трехколоночных сеток вызвана тем, что они обеспечивают большую свободу маневра, позволяя размещать иллюстрации, врезки, небольшие рекламные объявления в пределах одной, двух, трех колонок. Для трехколоночной сетки обязательна горизонтальная структура страницы. Как правило, она определяется параметрами преобладающего шрифта — в каждую ячейку сетки должно помещаться определенное целое число строк. Горизонтальное структурирование страницы весьма облегчает работу дизайнера.

Пример горизонтально-ориентированной публикации (рис. 15.38). В ней основную линию образует ряд строго выровненных по сетке фотографий. Подписи под ними расположены на одном уровне и выполнены шрифтом Arial, легким для чтения и строгим. Однако комментарии к рисункам имеют разную длину и выровнены по левому краю. Эта особенность верстки, а также сочные цвета иллюстраций придают публикации неформальный вид. Широкое нижнее поле разлиновано легкими светло-серыми линиями и предназначено для записей по ходу работы. Ясная последовательность изложения и иллюстрации, мелкий, но легко читаемый шрифт, поля для записи, цветной обрез страницы, пружинный переплет и плотная бумага свидетельствуют о том, что перед нами образец учебного пособия, предназначенного для частого использования учащимся.

На рис. 15.39 представлена страница из научно-популярного журнала.

Рис. 15.38. Страница из учебного пособия

Рис. 15.39. Статья из журнала


Трехколоночные сетки (Часть II)

Выровненный по формату текст, строгий шрифт, скромный иллюстративный материал, простые рамки, черно-белое цветовое решение — все это свидетельствует о некоторой академичности издания. Элементы оформления — рамки, графические выделения заголовков, выворотные колонтитулы и колонцифры повторяются от страницы к странице. Заголовок несколько увеличен и набран шрифтом Bodoni Condensed, изящным и строгим. Осветленный рисунок Российского герба на врезке (его фрагмент повторен в оформлении заголовка) несколько оживляет дизайн страницы и подчеркивает тематику статьи.

Особенность документа, представленного на рис. 15.40 — смешанная сетка, организующая элементы публикации по степени важности для читателя. Текст, набранный в одну колонку, образует шапку. Он имеет теплый коричнево-золотистый цвет, крупный кегль и интерлиньяж и будет прочитан первым. В этом фрагменте текста помещены наиболее привлекательные моменты предвыборной программы кандидата. Выравнивание по формату упорядочило текст. Мелкий текст набран темно-зеленым; он содержит биографию кандидата и другую информацию. Фотография помещена в соответствии с модульной сеткой. Общее впечатление — доступность и надежность.

Рис. 15.40. Рекламный листок

Кроме вышеперечисленных, в газетах, журналах и буклетах встречаются многоколоночные сетки. Многоколоночные сетки допускают изменения в оформлении внутри одной и той же публикации и позволяют применять графические элементы разных размеров. Они хорошо подходят для документов, содержащих много мелких материалов — рубрик, заметок и т. д. Заметку из 30 слов сложно разместить в одноколоночном макете, она будет выглядеть куцей. В узкой же колонке малый материал образует вполне приличный столбик текста. Для узких колонок выбирайте шрифт малого кегля. но удобочитаемый. Если строка состоит из двух-трех слов, следите, чтобы не было лишних переносов. Узкие колонки трудно выравнивать по формату, приходится все время следить, чтобы не было жидких строк. Рваный край также будет менее ровным, чем в широкой колонке. Многоколоночные стеки требуют значительного внимания, так как вам все время нужно будет принимать различные решения при макетировании. Большая свобода действий по размещению объектов должна ограничиваться соображениями равновесия и пропорциональности.


Резюме

  • Для разметки пространства страницы и выравнивания ее элементов в InDesign используются различные вспомогательные линии: поля, колонки и направляющие.
  • Вспомогательные линии не имеют толщины и не выводятся на печать.
  • Вспомогательные линии способны "примагничивать" объекты при размещении, облегчая их выравнивание.
  • Для расстановки направляющих линий с одинаковым интервалом удобно использовать специализированную команду InDesign Create Guides.
  • Разметка страниц публикации облегчается при использовании шаблон-страниц. Шаблон-страницы хранят все элементы дизайна и разметки, повторяющиеся на нескольких страницах публикации. Элементы шаблона присутствуют на каждой странице, построенной на его основе.
  • В одной публикации может быть сколько угодно шаблон-страниц. Обычно их создают по количеству страниц, имеющих различное оформление.
  • Шаблоны в InDesign организованы иерархически. Один шаблон может быть построен на базе другого. Дочерний шаблон может содержать часть элементов базового в их исходном виде или с дополнительным редактированием.
  • Иерархическая организация шаблонов позволяет при создании нового шаблона делать его не "с нуля", а модифицируя имеющийся. Кроме того, при изменении базового шаблона вам не придется корректировать все дочерние — InDesign сделает это автоматически.
  • Элементы шаблона, видимые на страницах публикации, можно свободно редактировать. Те атрибуты элементов шаблона, которые были отредактированы, перестают наследоваться от оригинала на шаблон-странице. Отмена редактирования элементов шаблона восстанавливает наследование всех их атрибутов.
  • Для управления страницами и шаблон-страницами публикации используется палитра Pages. С ее помощью можно создавать, изменять порядок страниц, и удалять страницы публикации и шаблон-страницы.
  • InDesign поддерживает развороты, состоящие из нескольких (не более 10) страниц.
  • Если в публикации необходимо организовать несколько различных способов нумерации страниц, то используйте разделы.
  • Все объекты на страницах и шаблон-страницах располагаются на слоях. Слои позволяют управлять порядком перекрывания объектов, облегчают редактирование.
  • Основу дизайна многостраничных публикаций создает модульная сетка. Она позволяет обеспечить единство оформления, облегчает композицию.


Глава 16

Компоновка текста и графики

Частично вопросы размещения текста и графики уже обсуждались в главах, посвященных импорту соответствующих материалов (см. главы 9 и 12). Кроме размещения "на глазок", которое мы там использовали, InDesign позволяет размещать как текстовые, так и графические материалы с высокой точностью, не доступной при применении первого способа. Для точного размещения графических и текстовых материалов используются: ввод цифровых значений в палитре Transform, направляющие, колонки, линейки, палитра Align. Большинство элементов интерфейса, описываемых в этой главе, уже упомянуто в главе 1. Там же приведена информация о масштабе отображения страниц публикации в окне документа, которая пригодится при чтении этой главы.

В настоящей главе рассмотрены:

  • Координаты объектов
  • Методы выравнивания объектов
  • Операции с объектами — масштабирование, наклон, поворот, отражение
  • Группы объектов
  • Команды вклеивания
  • Обтекание объектов текстом
  • Вложенные изображения
  • Маскирование


Координаты объектов

Любому элементу верстки в InDesign, размещенному на странице или рабочем столе, соответствуют точные координаты. Изменение этих координат приводит к перемещению элемента в заданное ими новое положение.

С помощью линеек или палитры Transform можно определить и изменить координаты объекта.

InDesign использует прямоугольную систему координат, начало которой по умолчанию находится в левом верхнем углу страницы. Положение начала координат можно изменить и заблокировать (см. главу 1). Координату любой точки документа можно визуально определить по измерительным линейкам. Предварительно следует включить их отображение командой Show Rulers меню View. Единицы измерения координат и масштаб линеек пользователь определяет с помощью диалогового окна Preferences (см. главу 3).

Каждому объекту, будь он графический или текстовый, сопоставляется одна координата и линейные размеры — высота и ширина. Для непрямоугольных объектов в качестве высоты и ширины принимаются измерения описывающего объект прямоугольника, т. н. габаритного прямоугольника. При выделении объекта инструментом Selection вокруг объекта появляются черные квадратики, называемые манипуляторами. Манипуляторы располагаются по углам и посередине сторон габаритного прямоугольника. Перемещая манипуляторы с помощью инструмента Selection, можно масштабировать объекты (см. ниже).

Координатой объекта считается координата его якорной точки (reference point). Якорной точкой может быть любой из манипуляторов или центр габаритного прямоугольника. Какую из этих точек считать якорной, можно определить с помощью палитры Transform. В левой части палитры расположен переключатель, символически изображающий габаритный прямоугольник. Белыми квадратами на нем отмечены возможные варианты размещения якорной точки, а черным квадратом — ее текущая позиция. Щелчок на квадрате определяет соответствующую точку как якорную (рис. 16.1). При изменении якорной точки изменяются и цифры, находящиеся в полях Х и Y палитры. Это, соответственно, горизонтальная и вертикальная координаты объекта. При переопределении якорной точки изменяются и координаты объекта.

Рис. 16.1. Определение якорной точки для линии (а) и любого другого объекта (б)

Для отрезка линии, в отличие от всех остальных фигур, существуют всего три варианта расположения якорной точки: концевые и средняя точки.


Выравнивание объектов

InDesign располагает совершенными средствами задания положения объектов, графических материалов и текстовых блоков, обеспечивающими высочайшую точность их размещения как на странице, так и друг относительно друга. Таких средств несколько — выбор остается за вами. Он обусловлен спецификой каждого конкретного случая. В этом разделе мы рассмотрим все способы точного задания положения объекта на странице.


Выравнивание по линейкам

Линейки можно использовать для точного расположения объектов. При перемещении объектов координаты сторон их габаритных прямоугольников отмечаются на линейках пунктирными линиями. Это позволяет точно разместить объект на странице публикации. Точность размещения значительно возрастает при большем увеличении (рис. 16.2).

Рис. 16.2. Выравнивание объекта по линейке

Хотя в принципе выравнивание по линейкам вполне правомерно, на практике оно применяется исключительно редко, поскольку требует постоянной смены масштаба просмотра. Если масштаб мелкий, не обеспечивается необходимая точность.


Выравнивание заданием координат

Кроме позиционирования объектов перетаскиванием, вы можете непосредственно задать их координаты на странице, используя палитру Transform. Координаты объектов в полях Х и Y можно изменять, вводя в поля новые значения. Разумеется, непосредственным заданием координат можно выравнивать объекты друг относительно друга — достаточно задать для них одинаковые координаты. При этом надо постоянно помнить о том, что координата объекта задается положением его якорной точки. Рис. 16.3 иллюстрирует то, что при выборе другой якорной точки изменяются и координаты самого объекта.

а [image] б

Рис. 16.3. Изменение координат объекта при выборе другой якорной точки


Выравнивание по направляющим и границам колонок (Часть I)

Этот способ используется на практике наиболее широко, особенно на первых этапах создания макета. Именно с помощью направляющих и колонок делается "скелет" публикации — модульная сетка (см. главу 12). После того как модульная сетка определена, выравнивание элементов макета по ней производится именно этим способом.

Точность размещения объектов относительно направляющих обеспечивается за счет притяжения объектов к ним. Если объект находится достаточно близко к направляющей или границе колонки, то InDesign автоматически перемещает объект таким образом, чтобы соответствующая сторона габаритного прямоугольника совпала с направляющей. Чтобы использовать выравнивание по направляющим, необходимо включить отображение направляющих командой Show Guides меню View, и режим выравнивания — командой Snap to Guides того же меню.

Направляющие могут быть защищены от случайных перемещений командой Lock Guides и разблокированы повторным выполнением этой команды.

Кроме того, поскольку направляющие всегда принадлежат какому-либо слою, их видимостью и закреплением можно управлять с помощью параметров этого слоя. Как вы уже узнали в предыдущей главе, среди параметров слоя, приведенных в диалоговом окне Layer Options, имеются флажки Show Guides и Lock Gui des. Последний включает закрепление направляющих только на выбранном слое, в то время как на других слоях они остаются подвижными. Первый флажок позволяет спрятать направляющие, принадлежащие исключительно выбранному слою. Используйте управление направляющих с помощью параметров слоя. Если, например, для построения фрагмента макета вам понадобилось много направляющих, то после окончания работы над ним, совершенно не обязательно их удалять. Вынесите эти направляющие на отдельный слой или поместите на слой, содержащий отредактированный фрагмент. Затем просто спрячьте их, сбросив флажок Show Guides в параметрах этого слоя. В результате, во-первых, вы всегда сможете повторно использовать установленные направляющие, а во-вторых, они не будут мешать дальнейшей работе.

Если направляющие расположены слишком часто, они могут помешать восприятию макета. Неудобство можно устранить, переместив направляющие вниз, под все элементы макета. Это нельзя сделать, разместив направляющие на самом нижнем слое. Положение направляющих относительно объектов на странице полностью определяется состоянием флажка Guides in Back в разделе Guides диалогового окна Preferences (см. главу 3). Установите его, если хотите, чтобы направляющие оказались позади объектов страницы (рис. 16.4).

а

Рис. 16.4. Направляющие перед (а) и позади (б) объектов страницы

Для того чтобы изолировать какой-либо узел прибора от действия магнитных полей, его помещают в металлический кожух. При этом говорят, что кожух экранирует магнитное поле. Объекты могут закрывать собой направляющие, но последние все равно притягивают или "примагничивают" другие объекты. Даже если направляющая перекрыта каким-либо объектом и не видна, по ней все равно можно выравнивать другие объекты.

Второй способ избежать "частокола" направляющих на экране, состоит в установке для них разных значений параметра View Threshold в диалоговом окне Ruler Guides. Как вы помните, он задает минимальный масштаб, при котором направляющая видна. При масштабе ниже порогового, направляющая исчезает с экрана. Представьте себе, что вы создали множество направляющих для одного небольшого фрагмента макета, выбрав очень большой масштаб. При просмотре страницы 1:1 на месте этого фрагмента вы увидите сплошную широкую линию направляющих. Если задать направляющим, использовавшимся для построения фрагмента, значение параметра View Threshold примерно 50%, то на странице они будут не видны.

Этот способ управления видимостью направляющих наиболее удобен, поскольку не требует от вас никаких специальных действий: направляющие сами появляются и исчезают с экрана, когда нужно. Помните о нем и используйте совместно с механизмом локальных умолчаний. Начиная работу над очередным мелким фрагментом макета, отмените выделение всех объектов и задайте подходящее значение параметра View Treshold в диалоговом окне Ruler Guides. С этого момента все направляющие, которые вы построите, будут иметь указанный пороговый масштаб видимости. Как только вы закончите работу над фрагментом и перейдете к более мелкому масштабу, снова смените пороговый параметр видимости. Таким образом, все направляющие в макете будут выглядеть наилучшим образом при любом увеличении.

И наконец, если в направляющих отпала необходимость, то их можно удалить. В InDesign есть специальная клавиатурная команда, позволяющая выделить все направляющие линии на текущей странице, — <Alt>+<Ctrl>+<G>. С ее помощью выделяются все незакрепленные видимые направляющие независимо от того, на каком слое они находятся. После того как направляющие выделены, достаточно нажать клавишу <Delete>, чтобы удалить их.


Выравнивание по направляющим и границам колонок (Часть II)

Для удаления со страницы всех направляющих, независимо от слоя, на котором они находятся, и параметров этого слоя, а также закрепления, можно воспользоваться косвенным методом. Если в диалоговом окне Create Guides оставить параметры секций направляющих нулевыми, а только установить флажок Remove Existing Ruler Guides, то после щелчка на кнопке ОК все направляющие со страницы будут удалены.

Не удаляйте направляющие только для того, чтобы посмотреть на макет без мешающей разметки. При необходимости внесения изменений вам придется снова размещать все направляющие. Вместо этого используйте команду Display Master Items (<Ctrl>+<Y>), если направляющие являются элементами шаблона, или Hide Guides, если они нанесены непосредственно на текущую страницу.

Направляющие могут быть помещены на страницу абсолютно точно с помощью команды Create Guides, которая уже обсуждалась в предыдущей главе. Объект, будучи выровнен по таким направляющим, займет на странице строго определенное положение. С помощью направляющих можно так же точно размещать объекты по отношению друг к другу, если выровнять их относительно одной направляющей (рис. 16.5).

Рис. 16.5. Выравнивание объектов по направляющим

Особого внимания заслуживают линии, созданные соответствующим инструментом InDesign. Они могут иметь достаточно толстую обводку, чтобы результат выравнивания зависел от того, с какой стороны линии оно выполняется: по какой-либо из граничных или по центру.

При построении линии вдоль направляющей InDesign автоматически выравнивает ее по центру (рис. 16.6, а). Если вы выравниваете уже построенную горизонтальную или вертикальную линию по соответствующей направляющей, то выравнивание происходит по любой из сторон (рис. 16.6, б). В результате линии, выровненные при построении и после него, оказываются неверно размещенными относительно друг друга. Для точного размещения линий необходимо соблюдать единообразие в их выравнивании по направляющим. Поскольку линия может "прилипнуть" к направляющей любой своей стороной, помещайте их к направляющим все время с одной стороны (например, вертикальные — слева, а горизонтальные — сверху).

Положение еще усугубляется тем, что выравнивание может нарушиться при варьировании толщины обводки, т. к. толщина обводки меняется "от центра", а выравнивание делается по краю (рис. 16.7). По этой причине после изменения толщины обводки линий их выравнивание следует повторить.

а [image] б

Рис. 16.6. Выравнивание линии при построении (а) и после построения (б)

а [image] б [image] в

Рис. 16.7. Нарушение выравнивания при изменении толщины обводки

Сохранение выравнивания при изменении толщины обводки для других фигур зависит от состояния команды-переключателя Weight Changes Bounding Box в меню палитры Stroke. Если этот флажок сброшен, то габаритный прямоугольник, по которому In Design выравнивает объект, остается того же размера и на том же месте (рис. 16.8, а). Если флажок установлен, то на месте остается контур объекта, а габаритный прямоугольник меняет размер (рис. 16.8, б).

а

б

Рис. 16.8. Состояние выравнивания в случае изменения толщины обводки при сброшенном (а) и установленном (б) флажке Weight Changes Bounding Box

В любом случае выравнивание многоугольников по направляющим происходит по внешней стороне с учетом обводки.


Выравнивание по координатной сетке

Если на странице находится очень много объектов, то не имеет смысла создавать для них столько же направляющих. Координатная сетка позволяет разрешить эту проблему, поскольку она аналогична множеству направляющих, проведенных с одинаковым интервалом. Внешне она напоминает наложенную на страницу миллиметровую бумагу. Кроме того, координатная сетка помогает при создании эскизов в тех случаях, когда точное расположение объектов либо невозможно, либо не имеет смысла.

Прежде чем начать выравнивание по координатной сетке, необходимо задать ее параметры. Они устанавливаются в разделе Grids диалогового окна Preferences. Подробно об этом рассказывается в главе 3. Координатная сетка определяется частотой следования линий. При этом основные линии сетки делятся еще на произвольное число более тонких, как и на миллиметровой бумаге (рис. 16.9). Такое деление позволяет легче ориентироваться в большом количестве линий. Чтобы создать, например, эквивалент миллиметровой бумаги, введите в поле Gridline Every 10 мм, а в поле Subdivisions — 1. В результате основные (жирные) линии сетки будут следовать через каждый сантиметр, а тонкие — с интервалом 1 мм.

Рис. 16.9. Координатная сетка

Режим выравнивания по координатной сетке включается командой Snap to Document Grid меню View. Разумеется, предварительно должно быть включено отображение сетки командой Show Document Grid того же меню. При включенном режиме выравнивания по линейкам объект может быть размещен только таким образом, чтобы две стороны его габаритного прямоугольника совпадали с линиями координатной сетки. Координатная сетка помогает и при создании объектов. Любые инструменты InDesign смогут занимать только те положения, которые соответствуют узлам сетки.

Поскольку линии сетки могут располагаться очень часто, InDesign автоматически управляет их видимостью аналогично тому, как это делаете вы при использовании параметра View Treshold для направляющих. Чем больше масштаб отображения документа, тем больше линий сетки становятся видимы (рис. 16.10).

Выравнивание по сетке часто приходится производить при большом увеличении, чтобы ее деления отстояли друг от друга на достаточное расстояние.

В противном случае выравнивание может произойти не по той линии сетки, по которой вы предполагаете.

а [image] б

Рис. 16.10. Вид координатной сетки в зависимости от масштаба демонстрации


Палитра Align

Самым простым и мощным средством выравнивания объектов друг относительно друга является палитра Align. Для ее вызова также можно воспользоваться одноименной командой меню Window или клавишей <F8>. Палитра предлагает все возможные варианты выравнивания и/или распределения (рис. 16.11). Команды палитры становятся доступны только если на странице выделено не менее двух любых объектов, поскольку для одного объекта команда не имеет смысла.

Выравнивание осуществляется верхним рядом кнопок палитры. Левая группа из трех кнопок задает способ выравнивания по вертикали, а правая — по горизонтали. Наборы кнопок для вертикального и горизонтального выравнивания абсолютно одинаковые и выполняют те же функции. Их функции приведены в табл. 16.1.

Рис. 16.11. Палитра Align

Таблица 16.1. Функции кнопок задания выравнивания объектов палитры Align

По левому краю

По средней линии

По правому краю

По верхнему краю

По средней линии

По нижнему краю

Манипулируя этими кнопками, можно задать любой тип выравнивания по вертикали и/или по горизонтали. После нажатия любой из этих кнопок к выделенным объектам применяется заданное выравнивание. К сожалению, при выравнивании по средней линии нет способа задать "верно расположенный" объект, чтобы все остальные выравнивались по нему. Выравнивание происходит по средней линии "всей группы" выделенных объектов. Таким образом, ни один из выравниваемых объектов, как правило, не остается на прежнем месте (если он по редчайшей случайности не оказался на линии выравнивания). При выравнивании по левым или правым границам объектов остается на месте соответственно самый левый или самый правый объект, остальные выравниваются по нему. Аналогично смещаются объекты при выравнивании по вертикали.

Не менее полезной возможностью палитры Align является распределение объектов. Часто возникает задача расположить несколько объектов с равноотстоящими интервалами или с соблюдением одинаковых пробелов между ними. Распределением выделенных объектов управляют кнопки нижнего ряда палитры. В табл. 16.2 приведены их функции.

Таблица 16.2. Функции кнопок задания распределения объектов палитры Align

По промежуткам

По промежуткам

По левым границам

По средним линиям

По правым границам

По верхним границам

По средним линиям

По нижним границам

Объекты распределяются таким образом, чтобы расстояние между заданными их границами или промежутки между ними были одинаковыми. При этом объекты, находящиеся по краям, не изменяют своего положения, а остальные распределяются между ними (рис. 16.12).

Рис. 16.12. Фигуры до (а) и после горизонтального распределения по средним линиям (б) и промежуткам (в)

Одновременное выравнивание и распределение по разным измерениям вполне имеют смысл (например, горизонтальное выравнивание и вертикальное распределение, или наоборот). Выравнивание и распределение по одному измерению не могут быть выполнены для одной группы объектов, т. к. это не имеет смысла.


Группировка объектов

Часто операции, например, перемещения, масштабирования, выравнивания, необходимо проделать не над отдельным объектом, а над группой объектов. В принципе для этого недостаточно выделить все эти объекты, и воспользоваться соответствующим инструментом трансформирования или задать его параметры в палитре Transform. Тем не менее, продолжительная работа с несколькими объектами одновременно исключительно неудобна. Если после выполнения их трансформирования вы что-то сделали с другими объектами, то вам снова придется тратить время на выделение.


Создание и расформирование групп

InDesign имеет команду определения нескольких объектов как группы, которая является единым объектом. Просто такой объект состоит из нескольких. Так как группа является объектом, к ней применимы все операции перемещения, масштабирования, наклона, вращения и т. п. Причем в ходе этих операций относительное положение и размеры объектов, составляющих группу, поддерживаются постоянными.

Группировка осуществляется командой Group меню Object или клавишами <Ctrl>+<G>. Объединение объектов в группу не лишает возможности отдельно редактировать каждый объект. Для этого его нужно предварительно выделить с помощью инструмента Direct Selection. Если надобность в объединении объектов отпала, то группу можно расформировать обратной командой Ungroup или клавишами <Ctrl>+<Shift>+<G>.


Группы и слои

Если объекты, которые вы группируете находятся на разных слоях, то после фуппировки они все окажутся на одном слое. Это тот слой, на котором находился самый верхний из исходных объектов. На рис. 16.13 прямоугольник находится на самом нижнем слое, слоем выше находится логотип, а на верхнем слое — текстовый блок. При группировке прямоугольника с текстовым блоком логотип исчезает. Он оказывается закрытым прямоугольником, который переместился на слой самого верхнего объекта группы, текстового блока. А поскольку этот слой находится выше слоя с логотипом, последний "исчез".

а

б

Рис. 16.13. Группировка изменяет распределение объектов по слоям

Тот же самый эффект имеет место и при группировке объектов, находящихся на одном слое. Все объекты в пределах слоя перекрываются в определенном порядке. При группировке изменяется этот порядок все группируемые объекты помещаются на соседние уровни в "стопке" объектов. Если бы объекты на рис. 16.13 находились даже на одном слое, но в том же порядке пе-рекрывания, то результат группировки оказался бы тем же.


Вложенные группы

Группы объектов могут быть вложенными. Вы можете сгруппировать с любым объектом не только еще один объект, но и другую группу. При этом InDesign отслеживает уровень вложенности каждого объекта в группах и учитывает при операциях выделения и разгруппировки.

а

б

в

г

Рис. 16.14. Выделение вложенных групп инструментом Direct Selection

На рис. 16.14 изображена группа из четырех объектов. Она была создана не одновременной группировкой всех объектов, а последовательным присоединением каждого объекта к группе. Первой была создана группа, включающая круг и прямоугольник. Следующей операцией группировки она была сгруппирована с текстовым блоком. И наконец, получившаяся группа, состоящая из трех объектов, была сгруппирована с импортированным рисунком. Она содержит две вложенные группы. Если применить к ней команду Ungroup, то в результате получатся не 4 отдельных объекта, а рисунок и группа из остальных объектов, т. е. вложенная группа верхнего уровня. Применение к ней команды Ungroup тоже даст отдельный объект (текстовый блок) и очередную вложенную группу. Короче говоря, команда Ungroup расформировывает группы в порядке, обратном их созданию.

Инструмент Direct Selection придает работе с вложенными группами большое удобство. При нажатой клавише <Alt> он превращается в аналог инструмента Group Select, имеющегося в Adobe Illustrator. При этом рядом с белой стрелкой курсора инструмента появляется знак "плюс". Если щелкнуть инструментом Direct Selection, находящемся в этом режиме на прямоугольнике, то будет выделена только эта фигура. Второй щелчок на том же прямоугольнике выделит первую группу, в которую он входит, т. е. прямоугольник и круг. Третий щелчок выделит группу следующего, верхнего, уровня из трех объектов: прямоугольника, круга и текстового блока. Четвертый щелчок выделит группу самого верхнего уровня, включающую все объекты на рисунке. Таким образом, с помощью инструмента Direct Selection вы можете выбрать группу любого уровня вложенности.

Для редактирования текста во фрейме, входящем в группу, его не обязательно предварительно выделять инструментом Direct Selection. Вы можете сразу приступить к редактированию, вооружившись инструментом Type.


Операции с объектами в составе группы

Над объектом или вложенной группой объектов, выделенных внутри группы инструментом Direct Selection, можно выполнять все определенные для них действия, например, трансформировать или изменять заливку и обводку.

Назначение обводки или заливки группе эквивалентно назначению этих атрибутов каждому входящему в нее объекту. Чтобы придать объектам группы различные атрибуты, их нужно выделить поочередно инструментом Direct Selection.

Все операции с объектами, входящими в группу, не удаляют их из ее состава. Вы можете перемещать, поворачивать, масштабировать или искажать в группе любые объекты, но они по-прежнему будут объединены в группу. Если вы создадите копию объекта, входящего в группу, то и копия объекта будет принадлежать той же группе, что и оригинал.

Ниже при описании операций с объектами мы будем подразумевать, что речь может идти не только об отдельных объектах, но и об объектах-группах, если специально не оговорено обратное.


Точное трансформирование

При создании макета совершенно необходимо соблюдать точность размещения его элементов, чтобы макет хорошо выглядел. Если, например, углы поворота изображения и проведенной под ним линейки не совпадают даже на десятую долю градуса, макет кажется неряшливым и непрофессиональным. Если точность размещения элементов макета гарантируется при использовании мощных и многообразных средств выравнивания, то точность трансформирования достигается вводом численных значений ее параметров в палитре Transform.


Масштабирование

Точное масштабирование графических объектов осуществляется с помощью палитры Transform. При этом используются поля Н и W, задающие размеры объекта в абсолютных единицах, или списки Scale percentage, где коэффициент масштабирования указывается в процентах от текущих размеров. Если на странице есть выделенный объект, в этих полях отображаются его текущие размеры, что само по себе является не лишней информацией. Ввод новых значений в них приведет к изменению размеров объекта. На масштабирование оказывает влияние положение якорной точки, а также переключатели Dimensions Include Stroke Weight и Transformations are Totals.

Флажок Transformations are Totals устанавливает способ расчета параметров трансформирования для объектов, находящихся в составе групп. Предположим, что вы повернули один из объектов группы на 10°, а затем и всю группу еще на 20°. Какой угол поворота объекта будет показан в палитре Transform? Если флажок Transformations are Totals установлен, то 30°. Если флажок сброшен, то 10°. Таким образом, в режиме Transformations are Totals параметры трансформирования объекта в группе вычисляются относительно страницы. Если этот режим отключен, то параметры трансформирования вычисляются относительно самой группы. Наличие двух режимов достаточно удобно, поскольку позволяет создавать "местную систему координат" для отдельных фрагментов макета.

При операциях масштабирования объект оказывается как бы "приколотым" к странице в якорной точке. Размеры объекта изменяются таким образом. чтобы положение якорной точки оставалось постоянным (рис. 16.15).

Чтобы при масштабировании соблюдались пропорции объекта, завершите ввод одного из размеров объекта в поле палитры Transform нажатием клавиш <Ctrl>+<Enter>. При изменении размеров объекта будет поддерживаться постоянное соотношение сторон его габаритного прямоугольника.

Рис. 16.15. Масштабирование объекта с помощью палитры Transform

Действие кнопки пропорционального масштабирования идентично действию клавиши <Shift> при изменении размеров объекта с помощью мыши (см. главу 9).

При изменении размеров графического или текстового фреймов важно состояние команды переключателя Scale Content из меню палитры Transform. Если эта команда активна, то при масштабировании фрейма меняет размер и его содержимое. При сброшенном флажке меняется только размер фрейма (рис. 16.16).

Флажок Dimensions Include Stroke Weight позволяет выбрать вариант вычисления размеров объектов, имеющих обводку. Если флажок сброшен, то в полях палитры Transform указываются размеры контура объекта. Толщина обводки при этом не учитывается. Когда фигуры в макете имеют широкую обводку, ею уже нельзя пренебрегать при выравнивании и трансформировании. Установите флажок Dimensions Include Stroke Weight, чтобы InDesign автоматически учитывал толщину обводки, т. е. складывал ее толщину с размерами объекта. Именно эта суммарная величина и будет фигурировать в полях палитры Transform. Все значения масштабов и размеров, которые вы будете вводить в эти поля, тоже будут трактоваться программой, как размеры с учетом толщины обводки.

а

б

Рис. 16.16. Масштабирование фреймов в режиме Scale Content (а) и без него (б)


Наклон

Суть операции наклона наиболее точно проясняет следующая аналогия: при фиксации нижней стороны габаритного прямоугольника объекта смещается вправо или влево его верхняя сторона, после чего объект "наклоняется" соответственно вправо или влево. Габаритный прямоугольник при этом становится параллелограммом.

На рис. 16.17 представлен результат наклона объекта с активной точкой в верхнем левом углу. При наклоне якорная точка остается на месте, как приклеенная к странице, а все остальные точки объекта смещаются относительно нее, формируя в результате наклоненный объект в соответствии с заданным углом.

Рис. 16.17. Наклон объекта с помощью палитры Transform

Отрицательные значения угла наклона соответствуют наклону влево, положительные — вправо.


Отражение

Это преобразование позволяет заменить объект на его зеркальное отражение относительно горизонтальной или вертикальной оси. Отражения строятся с помощью трех команд меню палитры Transform.

  • Flip Horizontal. Отражение по горизонтали.
  • Flip Vertical. Отражение по вертикали.
  • Flip Both. Отражение по обеим осям. Эквивалентно последовательному отражению по каждой из них.

Отражение объектов при выполнении любой из этих команд происходит относительно прямой, проходящей через текущую якорную точку. Если, например, выбрано отражение по горизонтали, то оно происходит относительно горизонтальной линии, проходящей через якорную точку.

На рис. 16.18 показано горизонтальное и вертикальное отражение объекта. Обратите внимание, что отражение объекта не тождественно его повороту на 180°.

Рис. 16.18. Отражение объекта по вертикали (а) и горизонтали (б)


Поворот

Элементы управления поворотом позволяют разворачивать объект на произвольный угол. Угол поворота задается в комбинированном списке Rotation Angle. В списке приведены некоторые наиболее употребительные значения углов поворота, но вы можете задать угол произвольно, воспользовавшись полем ввода.

Углы поворота отсчитываются от начального положения объекта. Начальное положение соответствует моменту его создания. Это гораздо удобнее, чем использование относительных углов, как, например, в PageMaker. В InDesign вы всегда можете вернуть объект в исходное положение, выбрав в списке нулевой угол поворота.

Центром поворота считается текущая якорная точка объекта. С помощью палитры Transform невозможно повернуть объект вокруг произвольного центра вращения, он обязательно должен совпадать с одним из ограничителей на габаритной рамке или находиться в ее центре. Обратите внимание на то, что в процессе поворота объекта синхронно с ним поворачивается и схема на палитре Transform (рис. 16.19).

Рис. 16.19. Поворот объекта


Обтекание объектов текстом (Часть I)

Теперь, когда мы рассмотрели все средства редактирования и размещения текстовых и графических элементов макета, самое время перейти к их компоновке. Простейшей ситуацией является их обособленное размещение. В этом случае графические объекты и текстовые блоки просто располагаются в секциях заранее определенной модульной сетки и по ней же выравниваются (см. главу 14). Этот случай настолько простой, что не требует особого рассмотрения. Существуют также ситуации, когда изображение (или его часть) должны находиться внутри текстового блока и текст должен обтекать изображение. Особенно часты они при верстке многоколоночных документов — журналов и газет. Для задания режима обтекания изображений текстом InDesign предоставляет специальную палитру.

Режим обтекания задается отдельно для каждого изображения публикации. Это позволяет задавать различные варианты обтекания в зависимости от требований макета для любых его элементов. Режим обтекания текстом задается в палитре Text Wrap, вызываемой одноименной командой Object. Разумеется, тот элемент макета, для которого вы хотите задать режим обтекания текстом, должен быть предварительно выделен инструментом Selection. Вид палитры Text Wrap представлен на рис. 16.20.

Рис. 16.20. Палитра Text Wrap

Кнопки в верхней части палитры переключают режим обтекания (табл. 16.3).

Таблица 16.3. Функции кнопок задания обтекания текстом палитры Text Wrap

Отмена обтекания

По габаритной рамке

По форме объекта

Через объект

С новой кнопки

Если щелкнуть на первой кнопке (No Text Wrap), то режим обтекания будет отключен. Текст и объект будут накладываться друг на друга в соответствии со своим положением на слоях или порядком перекрывания в пределах одного слоя (рис. 16.21, а).

В режиме Wrap Around Bounding Box устанавливается обтекание текстом по границе габаритной рамки. Если объект прямоугольный, то этот вариант тождественен следующему — Wrap Around Object Shape. Если же объект имеет более сложную форму, то в первом случае контур обтекания текстом все равно будет прямоугольным (рис. 16.21, б), а во втором повторит контур объекта (рис. 16.21, в).

В режиме Jump Object текст "перепрыгивает" через объект, оставляя пространство справа и слева от него свободным (рис. 16.21, г). Последний режим. Jump to Next Column, размещает текст, следующий ниже объекта с новой колонки (рис. 16.21, д).

а

б

в

г

д

Рис. 16.21. Варианты обтекания текстом:

No Text Wrap (a), Wrap Around Bounding Box (6), Wrap Around Object Shape (в), Jump Object (г) и Jump to Next Column (д)

Если для объекта уже установлен какой-либо из режимов обтекания текстом, то нажатая кнопка в палитре Text Wrap укажет, какой именно.


Обтекание объектов текстом (Часть II)

Для того чтобы текст не касался объекта, который он обтекает, палитра Text Wrap дает возможность определить расстояние от текста до объекта. Это расстояние вводится в поля отступов в нижней части палитры. Поля Left Offset, Right Offset, Top Offset и Bottom Offset дают возможность установить различные расстояния от контура обтекания до текста с любой из его сторон (рис. 16.22). Разумеется, не для всех вариантов обтекания текстом все поля ввода имеют смысл. Все четыре используются только для варианта Wrap Around Bounding Box. В режиме Wrap Around Object Shape контур обтекания отстоит от контура объекта на заданное расстояние. Это единственный параметр для режима и поэтому используется только одно поле ввода. Для режима Jump Object задаются два расстояния — сверху и снизу от объекта, а для Jump to Next Column — только сверху.

Рис. 16.22. Различные расстояния до текста с разных сторон объекта

Флажок Invert инвертирует обтекание текстом так, что текст заполняет объект, а пространство по сторонам от него остается свободным (рис. 16.23).

Рис. 16.23. Инвертированное обтекание текстом

Контур обтекания может быть задан вручную и может отличаться от прямоугольного. Непрямоугольный контур обтекания текстом является мощным средством и выразительным элементом дизайна особенно при использовании обтравленных изображений. Вопросы помещения в публикацию таких изображений уже обсуждались в главе 12. Контур обтекания можно редактировать всеми инструментами InDesign, предназначенными для работы с контурами: инструментами группы Pen и Direct Selection. Пример отредактированного контура изображен на рис. 16.24. В этом примере в качестве исходного был использован прямоугольный контур обтекания. Затем все его узлы с помощью инструмента Convert Direction Point были превращены из угловых в гладкие, и перемещены так, чтобы образовать эллипс вокруг части объекта.

а

б

Рис. 16.24. Редактирование контура обтекания (а) и результат (б)

При необходимости отмены редактирования контура обтекания и приведения его к прямоугольной форме достаточно щелкнуть сначала на кнопке No Text Wrap, а затем снова на кнопке Wrap Around Bounding Box в палитре Text Wrap.

Обычно используются прямоугольные контуры обтекания, а расстояние от объекта до контура обтекания чаще всего бывает одинаковым со всех сторон. В этом случае еще до помещения графики в публикацию имеет смысл установить локальное умолчание для обтекания текстом. Для этого отмените все выделения на странице, щелкните на кнопке Wrap Around Bounding Box в палитре Text Wrap и установите требуемые расстояния от объекта в соответствующих полях ввода. Теперь при помещении изображения в публикацию или при создании графических примитивов средствами InDesign им автоматически будут назначены эти параметры обтекания. Подробнее об умолчаниях см. главу 3.


Закрепление объектов

Когда положение графического объекта или текстового блока на странице окончательно определено, можно закрепить объект в этом месте страницы командой Lock Position меню Object, контекстного меню или клавишами <Ctrl>+<L>. При этом графические и текстовые элементы ведут себя по-разному.

Свободно размещенные закрепленные графические объекты и любые группы обладают следующими свойствами:

  • Не могут быть перемещены в другое место страницы
  • Не могут быть удалены
  • Не могут быть масштабированы
  • Не могут быть сгруппированы с другими объектами; при попытке группировки InDesign выдаст предупредительное сообщение, предлагающее либо разгруппировать объект, либо закрепить получившуюся группу. Могут быть перемещены на другой слой (см. главу 13)
  • Цвета их заливки и обводки могут быть переопределены
  • Контуры можно отредактировать по узлам
  • Некоторые примитивы, созданные в InDesign, могут быть отредактированы его командами: изменение формы углов многоугольников командой Corner Effects и переопределение их числа с сохранением размеров габаритного прямоугольника
  • Для растровых изображений могут быть изменены параметры управления цветом командой Image Color Settings
  • Режимы обтекания этих объектов текстом могут быть переопределены и отредактирован контур
  • Могут быть скопированы в буфер обмена, причем копия не будет закреплена

Закрепленные текстовые фреймы обладают следующими свойствами:

  • Не могут быть перемещены в другое место страницы
  • Не могут быть удалены
  • Не могут быть масштабированы
  • Не могут быть связаны с другими фреймами
  • Не могут быть сгруппированы с другими объектами; при попытке группировки InDesign выдаст предупредительное сообщение, предлагающее либо разгруппировать объект, либо закрепить получившуюся группу
  • Текст внутри закрепленного фрейма может быть отредактирован с помощью инструмента Type
  • При увеличении размеров текста внутри блока его размер остается постоянным, если он связан с незакрепленным текстовым блоком (текст перетекает в него), и увеличивается, если блок не связан ни с какими другими

Отменить закрепление объекта можно командой Unlock Position меню Object, контекстного меню или клавишами <Alt>+<Ctrl>+<L>.


Вложенные изображения и текст

Графические объекты могут быть помещены в публикацию не только как свободно размещаемые, но и как вложенные (см. главу 10).


Вложенная графика как символ текста

Вложенная графика обладает существенным преимуществом перед свободно размещаемой — она всегда находится рядом с текстом, который иллюстрирует, независимо от его перемещений в процессе верстки. С другой стороны, для вложенной графики не может быть определен режим обтекания текстом, что делает необходимым резервирование для нее отдельной строки. Если графический материал занимает колонку с небольшими полями, то использование вложенной графики полностью оправдано. Ее использование обеспечит замечательную легкость корректировки макета при изменении объема и расположения текста. Напомним, что вложенная графика обладает свойствами как свободно размещаемой графики, так и текста. С одной стороны, можно обычным образом изменять ее размеры, вращать, обрезать и т. п., а с другой — настраивать для нее интерлиньяж, кернинг и трекинг.


Размещение вложенной графики

При размещении вложенной графики возможны два случая. В первом — вертикальный размер вложенных графических элементов меньше интерлиньяжа строки, в которой она расположена. Лучше задавать интерлиньяж текста в явном виде, используя локальное форматирование или абзацные стили. За счет этого не произойдет изменения интерлиньяжа для строки, содержащей графику, которое возможно при автоматической установке интерлиньяжа. Подобная же проблема возникает при наличии в строке символов разного кегля и решается тем же способом (см. главу 4). Положение вложенного графического объекта относительно базовой линии, содержащей его строки, можно настроить, используя его "текстовые" и "графические" свойства. Используя первые, выделите его инструментом Type и задайте нужное смещение базовой линии с помощью палитры Character, как описано для символов шрифта в главе 4. "Графические" свойства объекта позволяют перемещать его, применяя инструмент Selection. При этом допускается только вертикальное перемещение (рис. 16.26).

а

б

Рис. 16.26. Изменение положения вложенного графического объекта относительно базовой линии строки

В другом случае вложенное графическое изображение больше интерлиньяжа расположенного вокруг текста. Такая графика требует отвести для нее отдельную строку текста. Удобно при этом создать для вложенной графики специальный стиль, что позволит легко задавать параметры ее размещения. Очевидно, в этом случае задание какого-либо определенного интерлиньяжа для строк с вложенными изображениями нецелесообразно, т. к. они могут иметь разные размеры по вертикали, что требует различного интерлиньяжа. Выход из такой ситуации — установка для таких строк автоматического определения интерлиньяжа. Как вы помните, он рассчитывается исходя из высоты наибольшего по размерам символа в строке. Это свойство, делающее его малопригодным для верстки текста, оформленного символами различного кегля, выручает при использовании вложенных изображений. Вложенные изображения для InDesign — тоже символы текста и для них имеют смысл все характерные для текста параметры: вертикальный размер (тождественен кеглю), интерлиньяж, трекинг, кернинг и т. п. При автоматическом определении интерлиньяжа для строки, содержащей вложенную графику, InDesign возьмет за основу высоту самого большого символа этой строки, т. е. графического элемента, и обеспечит резервирование необходимого для него места независимо от размеров. Дополнительное пространство сверху и снизу графического элемента можно создать отбивками абзаца. Вертикальная выключка текста позволит совместить нижний край изображения (его "базовую линию") с базовыми линиями текста в соседних колонках, что придаст странице профессиональный вид (см. главу 13).


Закрепление вложенной графики

Вложенная графика также может быть закреплена на странице, как и свободно размещаемая. Имеет она и следующие особенности:

  • Не может быть удалена при выделении инструментом Стрелка (Pointer Tool)
  • Удаляется в текстовом режиме при активном инструменте Текст (Text Tool)
  • Не может быть отмасштабирована
  • He может быть смещена относительно базовой линии строки
  • Не может быть сгруппирована с другими объектами
  • Для нее могут быть переопределены цвета заливки и обводки
  • Многоугольники, созданные в InDesign, могут быть отредактированы его командами изменения формы Corner Effects
  • Для растровых изображений могут быть изменены параметры управления цветом командой Image Color Settings
  • Могут быть скопированы в буфер обмена, причем копия не будет закреплена

Закрепление вложенной графики отменяется командой Unlock Position меню Object, контекстного меню или клавишами <Alt>+<Ctrl>+<L>.


Изображения в висячих отступах

Вложенная графика очень часто используется вместе с висячими отступами для создания маргинальных элементов. Термин "висячий" употребляется в издательском деле для обозначения элементов, расположенных слева от основной колонки текста. Элементы такого рода служат великолепным средством выделения и структурирования текста, позволяя читателю легко в нем ориентироваться. К числу висячих элементов относятся отдельные символы (висячие знаки пунктуации и буквицы), маркеры пунктов перечней (bullets), маргинальные заголовки и графические элементы. InDesign имеет простые, но мощные средства создания маргинальных элементов.

Макет, созданный с использованием висячих элементов, производит впечатление многоколоночного, хотя в действительности имеет только одну колонку текста (рис. 16.27).

Рис. 16.27. Одноколоночный макет с маргинальными элементами

Зачем же прибегать к специальным приемам, когда можно сделать две настоящих колонки и разместить маргинальные элементы в левой, а основной текст в правой? Ответ очевиден: маргинальные элементы по смыслу привязаны к определенным строкам основного текста и при изменении размещения основного текста не должны утрачивать этой привязки. Если расположить их в отдельной колонке, то настраивать положение маргинальных элементов относительно основного текста вам пришлось бы вручную и каждый раз заново при малейшем изменении форматирования основного текста. Оформление маргинальных элементов как висячих позволяет не заботиться об их расположении относительно соответствующих строк основного текста, т. к. они включены в эти строки. В этом случае изменение форматирования и добавление или удаление основного текстового материала не приведет к необходимости ручного размещения маргинальных элементов.

После того как висячий отступ создан (см. главу 7), в него может быть помещен любой графический элемент. Очевидно, этот элемент будет вложенным. Такие висячие графические элементы служат великолепным средством выделения и оригинальным элементом дизайна. Они могут использоваться как маркеры элементов перечня или небольших фрагментов текста (рис. 16.28).

Рис. 16.28. Использование висячих графических элементов как маркеров перечней

Как и для любого вложенного графического изображения, положение висячего графического элемента по вертикали может быть настроено смещением базовой линии или просто перемещением мышью при активном инструменте Selection.

Проделывать такую настройку для-каждого висячего изображения в публикации довольно хлопотно. Этот процесс можно в значительной степени автоматизировать, используя команду Find.

В каждый висячий отступ вместо изображения помещается уникальный набор символов, который можно легко обнаружить в публикации посредством команды Find, например $$$, %%% и т. п. Затем требуемое изображение помещается только в один абзац и настраивается его смещение относительно базовой линии строки. Инструментом Type выбирается настроенное изображение и копируется в системный буфер. После этого командой Find отыскиваются все вхождения в текст указанной вами комбинации символов, т. е. те места, где должна располагаться висячая графика. После отыскания очередного вхождения командой Paste в публикацию вставляется содержимое системного буфера. При этом настройка положения базовой линии для вклеенного графического элемента сохраняется.

Для того чтобы прием сработал абсолютно, необходимо выделять копируемое изображение инструментом Type, а не Selection. В последнем случае настройка базовой линии не сохранится, т. к. при этом используется "графическая сущность" вложенного изображения, для которой понятие базовой линии не имеет смысла. При использовании инструмента Type вложенное изображение трактуется как символ текста, для которого могут быть заданы соответствующие атрибуты, в т. ч. и смещение базовой линии.


Объекты InDesign, вложенные в текст

Текущая версия InDesign не располагает встроенным редактором таблиц. Тем не менее, вы можете форматировать табличные данные и средствами InDesign и добиться вполне приемлемого результата. Наибольшую помощь в такой верстке вам окажет именно вложенная графика, созданная инструментами рисования самого InDesign.

Для верстки несложных таблиц, как правило достаточно трех графических элементов: горизонтальные и вертикальные линии, образующие ячейки, и цветные прямоугольники для закрашивания отдельных ячеек. Поскольку таблица может занимать несколько страниц и смещаться при верстке, необходимо, чтобы использованные графические элементы были вложенными.

Проблема с горизонтальными линиями и закраской ячеек достаточно просто решается с помощью линеек абзацев. Пример таблицы, построенной с помощью линеек абзацев, изображен на рис. 16.29. Для разделения строк таблицы использована тонкая линейка под абзацем. Вариант таблицы на рис. 16.30 показывает использование абзацной линейки для "раскрашивания" ячейки таблицы. Для точного позиционирования линеек использованы смещение относительно абзаца и правый отступ. Абзацные линейки всегда расположены "ниже" текста, поэтому, присвоив ему цвет бумаги, мы получили выворотный заголовок.

Задав абзацные линейки в стиле абзаца, вы можете отформатировать таблицу с горизонтальными линейками, просто присвоив ее строкам этот стиль.

Большую проблему представляют вертикальные линии. Их невозможно задать каким-либо стандартным способом. Здесь нас выручит инструмент Line. С его помощью можно создать вертикальные линейки и вложить их в пустой абзац, предваряющий таблицу. Чтобы он не выглядел, как отступ сверху, придайте ему нулевой интерлиньяж (рис. 16.31).

Рис. 16.29. Абзацные линейки разделяют строки таблицы

Рис. 16.30. Абзацные линейки использованы как фон ячеек таблицы

Рис. 16.31.Таблица с вертикальными и горизонтальными линейками

Рис. 16.32. Сочетание абзацных и вертикальных линеек

Совместным использованием приведенных "трюков" можно получить множество интересных вариантов оформления таблиц (рис. 16.32). Обратите внимание на пробелы между строками таблицы. Они тоже получены с помощью абзацных линеек цвета бумаги, заданных в стиле. Эти линейки закрывают фрагменты вложенной вертикальной линейки.


Вложенные текстовые фреймы

В InDesign вложенными могут быть не только изображения, но и текстовые фреймы. Их удобно использовать для создания заголовков-фонариков и других специальных эффектов верстки. На рис. 16.33 изображен макет, в котором для создания заголовков использованы текстовые фреймы, размещенные в висячих отступах.

Рис. 16.33. Заголовки-фонарики


Маскирование

Любая из геометрических фигур и любой графический фрейм, построенные инструментами программы InDesign, могут использоваться для маскирования других объектов. В качестве маскируемого объекта может выступать текстовый блок InDesign, другой графический объект или импортированное графическое изображение.


Создание масок

Маскирование реализовано в InDesign просто и естественно. Оно является в нем столь же неотъемлемой функцией, как и в программах иллюстрирования. Некоторые объекты программы вообще не могут существовать без масок, например, импортированные изображения. Любое изображение, которое вы помещаете на страницу публикации командой Place, обязательно оказывается внутри графического фрейма. Графический фрейм служит маской для импортированного изображения и позволяет его кадрировать по произвольному контуру. Как бы вы ни пытались, вы не сможете получить изображение от маски. Если, например, выделить изображение инструментом Direct Selection, скопировать в буфер обмена и снова вклеить на страницу, то InDesign автоматически создаст для него графический фрейм-маску.

Объекты, созданные инструментами рисования InDesign, могут обходиться без масок. Чтобы их маскировать, с вашей стороны потребуются специальные действия. Для создания масок используется команда Paste Into. Она вставляет объект, находящийся в буфере обмена, внутрь выделенного объекта. Буфер обмена может содержать любой объект InDesign. Заметьте, что текст сам по себе не является объектом, — объектом является текстовый фрейм. Поэтому операция маскирования не сработает, если вы поместили в буфер текст, выделенный инструментом Type. Если же в буфер поместить текстовый фрейм, выделенный инструментом Selection или Direct Selection, то маскирование вполне возможно.

Маской может служить любая фигура, графический фрейм или контур. На рис. 16.34 изображены эти объекты, маскирующие импортированное изображение. Текст не может служить маской. Если вы, тем не менее, хотите использовать шрифт как маску, то его необходимо предварительно преобразовать в кривые командой Create Outlines меню Type.

а [image] б

Рис. 16.34. Маска, созданная на основе фрейма или примитива (а), произвольного контура (б)

а [image] б

в

Рис. 16.35. Маскирование графического примитива (а),.изображения (б), произвольного контура (в) и текста (г)

На рис. 16.35 приведен пример маскирования окружностью, созданной инструментом Ellipse, объектов разных типов: примитива, созданного в InDesign, импортированного изображения, контура InDesign и текста.

Каждая маска может маскировать только один объект. Если вам требуется маскировать несколько объектов, предварительно сгруппируйте их. Как вы помните, группа для InDesign является единым объектом.


Трансформирование маски и маскированного объекта

Маскированный объект можно переместить независимо от маски или подвергнуть любым операциям трансформирования. Разумеется, перед трансформированием его необходимо выделить. Поскольку инструмент Selection выделяет маску и маскированный объект одновременно, он для этой цели непригоден. Чтобы отдельно выделить маску или маскированный объект, используйте инструмент Direct Selection.

Выделенную маску или ее содержимое можно перемещать друг относительно друга с помощью того же инструмента Direct Selection. К ним также можно применить такие инструменты трансформирования, как Rotate, Scale и Shear. Работа этими инструментами с масками ничем не отличается от обычных объектов.

Примеры трансформирования маскированных объектов приведены на рис. 16.36.

а [image] б [image] в

г

Рис. 16.36. Трансформирование маскированных объектов


Вложенные маски

Маски могут быть вложенными друг в друга. Создаются они повторным маскированием уже маскированного объекта или размещением изображений в маскированных объектах (рис. 16.37). Многократно маскированные объекты также можно выделить инструментом Direct Selection и выполнить с ними любые необходимые преобразования.

Рис. 16.37. Вложенная маска


Контуры обтравки

Контуры обтравки, импортируемые вместе с точечными изображениями, программа InDesign тоже трактует как маски. При импорте изображении с контурами обтравки InDesign преобразует их во фреймы. Таким образом обеспечивается единый подход к размещению изображений. В любом случае изображение находится во фрейме. Если использован контур обтравки, этот фрейм просто имеет непрямоугольную форму. С помощью инструмента Direct Selection вы можете извлечь изображение из контура обтравки. Инструментами работы с контурами можно свободно отредактировать контур обтравки, как если бы он был создан непосредственно в InDesign (рис. 16.38).

Рис. 16.38. Редактирование импортированного контура обтравки

Команда Clipping Path меню Object тоже выполняет маскирование путем создания контура обтравки. Полученный с ее помощью контур ничем не отличается от импортированного и представляет собой графический фрейм-маску.

Применяйте эту команду для изображений на одноцветном фоне. Команда Clipping Path подробно рассматривалась в главе 12.


Резюме

  • Каждый объект, размещенный на странице InDesign, имеет строго определенную координату. Она задается координатой якорной точки объекта. Якорную точку можно установить на месте любого из ограничителей габаритной рамки объекта или в его центре.
  • Точное размещение объектов на странице и относительно друг друга называется выравниванием. Для выравнивания используются линейки, направляющие, координатная сетка и палитра Align.
  • Для удобства работы с несколькими объектами одновременно используют группировку. Группа объектов становится для программы одним объектом. Тем не менее, при помощи инструмента Direct Selection можно получить доступ к отдельным объектам внутри группы.
  • Группы могут иметь несколько уровней вложенности. Инструмент Direct Selection позволяет манипулировать группами любой степени вложенности.
  • Выравнивание объектов обеспечивается и с помощью точного трансформирования. Для точного трансформирования используется ввод численных параметров в палитре Transform.
  • Палитра Text Wrap позволяет задавать режимы обтекания текстом графических объектов. Контур, по которому текст обтекает графические объекты, можно редактировать с помощью любых инструментов групп Pen и Direct Selection.
  • Графические объекты могут быть помещены в текстовый блок. После этого они приобретают часть свойств символов шрифта: кернинг, трекинг, положение базовой линии, и т. п. Вложенные графические объекты "привязаны" к определенному месту текста и не смещаются относительно него при верстке.
  • Применяя маскирование, можно закрыть часть графического объекта с помощью маски: любой контур, фрейм InDesign или импортированный контур обтравки. Впрочем, при импорте контуры обтравки автоматически преобразуются программой во фреймы.


Глава 17

Электронные публикации

Сеть Internet в последние годы стала одной из основных тем публикаций в самых разнообразных средствах массовой информации — от специализированных компьютерных изданий до журналов для домохозяек. Эта тема становится близка всем, т. к. стало ясно, что Internet — не просто игрушка для небольшого количества посвященных, а именно то, что реально меняет нашу жизнь.

Совсем не далеки те времена, когда отсутствие у частного лица доступа к Internet будет восприниматься как отсутствие телефона или телевизора сейчас. Уже отчетливо видно, что еще 10 лет назад только угадывалось самыми прозорливыми специалистами: сеть становится самым популярным средством поставки всех информационных услуг. Под информационными услугами понимаются в первую очередь средства массовой информации (телевидение, радио, печать), телекоммуникации (почта, телефония), а также обеспечение доступа к базам данных и знаний (библиотеки, гуманитарная, техническая и финансовая информация). Internet объединяет эти разобщенные источники, позволяя легко находить и быстро получать доступ к интересующей информации. Связь со средствами телекоммуникации обеспечивает наиболее быстрое, надежное и удобное общение. Более того, присущая Internet интерактивность придает информационным услугам новое качество (интерактивное телевидение, Internet-телефония, IRC и т. п.).

В настоящее время из стадии экспериментов выходит система финансовых операций, осуществляемых с помощью сети. Большинство крупных банков уже сейчас поддерживают операции со счетами и оплату услуг через Internet. Это не только дает значительное удобство, но и обеспечивает само развитие Internet, составляя его экономическую базу, Internet никому не принадлежит, поскольку является объединением огромного числа независимых глобальных и корпоративных сетей. Internet не имеет ни политических, ни территориальных границ, что делает информацию доступной вне зависимости от того, где вы находитесь, живете, какова ваша национальность и каких взглядов вы придерживаетесь.

Разумеется, первыми оценили перспективы развития этой области те, кто так или иначе связан с информационными технологиями: производители компьютеров, программного обеспечения, телекоммуникационные компании. Хотя большая часть из сказанного выше еще только становится реальностью, они непременно включают в свою продукцию поддержку Internet. Все современные операционные системы поддерживают Internet, в том числе операционные системы корпорации Microsoft: Windows NT и Windows 95/98/2000. Для этих систем существует множество программ, позволяющих не только получать информацию из Internet, но и публиковать ее в сети.

Основной язык публикаций в Internet ~ HTML (Hypertext Markup Language, язык разметки гипертекста). Он используется наиболее популярным сервисом Internet — WWW (World Wide Web). Для просмотра публикаций в WWW используются специальные программы просмотра — браузеры (от английского browse — просматривать).

Поддержка "перевода" электронной публикации на язык HTML стала серьезным критерием выбора при покупке программного обеспечения. Существует почти неисчерпаемое количество специализированных программ для создания WWW-страниц — от простейших текстовых редакторов, которые адаптированы для удобного ввода управляющих кодов HTML, до сложнейших систем поддержки огромных сайтов с изощренными средствами верстки, программирования, доступа к локальным и глобальным базам данных. Их чаще всего используют для создания публикаций, которые предназначены для распространения в Internet. Однако, кроме них, существует множество публикаций, которые должны существовать в обеих формах: бумажной и электронной.

Очень часто уже после выхода издания, отпечатанного типографским способом, появляется необходимость подготовить его для электронного распространения как через Internet, так и на дискетах, компакт-дисках и т. п. Эта необходимость заставляет разработчиков издательских систем включать в свои продукты инструменты, позволяющие преобразовать сверстанную публикацию в электронную форму. Последняя предполагает возможность просмотра публикации на компьютере, где не установлена издательская система, в которой она сверстана. Это требование может быть реализовано двумя принципиально разными способами.

Первый способ состоит в переводе макета публикации в формат HTML. В этом случае любой пользователь, располагающий программой просмотра WWW-страниц (т. е. практически все пользователи Internet), имеет возможность познакомиться с публикацией. Главный недостаток такого способа заключается в ограниченных возможностях описания макета средствами HTML — при преобразовании макет неминуемо будет "упрощен". Это может полностью разрушить дизайн публикации, сделав его унылым и непривлекательным. Таким образом, данный способ предполагает перевод либо достаточно простых публикаций, либо ручной "доводки" полученного макета.

Второй способ — перевод публикации в специальный формат, который, позволяя использовать "электронные возможности" (гипертекст, мультимедиа и т. п.), полностью сохраняет вид макета, но требует специального средства его просмотра. В электронных публикациях этого вида также используется гипертекстовое представление материала. Недостаток такого метода очевиден — для просмотра публикации вам надо предварительно раздобыть и установить программу просмотра. Далеко не все пользователи настолько упорны, чтобы только ради просмотра вашей публикации размером в десяток килобайт, искать и перекачивать трехмегабайтную программу просмотра. Поэтому при представлении публикации в таком виде вы должны быть уверены, что большинство читателей, на которых вы рассчитываете, уже имеют эту программу, или прилагать ее к публикации при распространении на CD-ROM. Таких форматов существует несколько, но наиболее популярен разработанный Adobe Systems формат PDF (Portable Document Format). Пользователям InDesign этот формат наиболее близок еще и потому, что он непосредственно им поддерживается. Кроме того, в его комплект поставки входят программы создания и просмотра таких файлов, что избавляет от необходимости их покупать.

Оба эти способа можно реализовать, используя InDesign. Более того, разработчики обратили пристальное внимание на возможность создания электронных публикаций. Это заставляет и нас обсудить создание электронных публикаций средствами InDesign самым подробным образом.

В главе рассматриваются вопросы, связанные с электронным распространением публикаций, сверстанных в InDesign:

  • Язык описания страниц HTML
  • Подготовка к переводу верстки в формат HTML и соответствующий фильтр экспорта
  • Отличия дизайна Web-страниц от полиграфического дизайна
  • Формат переносимых документов PDF
  • Экспорт публикации в формат PDF
  • Особые возможности и ограничения электронных публикаций


Язык описания страниц HTML

Описание языка HTML, который используется для разметки Web-страниц. выходит за рамки настоящей книги. Если вы хотите получить дополнительную информацию, о его возможностях, рекомендуем обратиться к многочисленной специальной литературе или не менее многочисленным публикациям в Internet.

Здесь мы только отметим, что с момента создания WWW Тимом Бернерсом-Ли в 1992 г. HTML очень быстро развивался. Если первые его версии включали, кроме средств разметки гипертекстовых ссылок, только элементарное форматирование, то ныне ситуация значительно изменилась. В язык введено множество средств размещения, выравнивания и форматирования символов.

Главными двигателями прогресса в этой области стали два основных производителя браузеров: корпорации Microsoft, производящая Internet Explorer, и Netscape Communications, разработавшая браузер Netscape Navigator. Обе фирмы, в каждой новой версии своих браузеров вводят все новые расширения возможностей языка HTML. К сожалению, решение проблемы стандартизации языка не успевает за создателями браузеров и каждая из этих программ предоставляет очень много таких возможностей, которые не поддерживаются конкурентом. Пока в этой “битве гигантов” нет однозначного победителя, в проигрыше оказывается Web-мастер, вынужденный прибегать к различным уловкам, чтобы его сайт могли смотреть пользователи обоих браузеров. Чаще всего ему приходится ограничиться использованием только той части HTML, которая достаточно стандартизирована.

До недавнего времени последним действующим стандартом, утвержденным консорциумом W3C, был HTML 3.2, реализованный в версиях 3.0 обоих браузеров. Сейчас можно считать, что практически все браузеры поддерживают этот стандарт. Версии 4.0 двух основных браузеров ввели новую спецификацию HTML 4.0. Консорциум W3C выдвинул свои рекомендации относительно стандартизации языковых средств этой версии (www.w3c.org), тем самым открыв Web-дизайнерам возможность пользоваться расширениями версии 4.0.

Поскольку основную часть рынка браузеров прочно удерживают Internet Explorer и Netscape Navigator, вы можете ориентироваться преимущественно на них. Тем не менее, на ряде платформ есть браузеры, не поддерживающие HTML 4.0, да и некоторые устаревшие версии браузеров еще используются до сих пор. По этой причине перед переводом публикации на язык HTML следует определить круг потенциальных читателей вашей страницы. Если рассчитывать на то, что он будет очень широким, вам придется отказаться от таких расширений HTML 4.0, как стилевые листы CSS (Cascading Style Sheets). В зависимости от этого выбора, вы будете устанавливать параметры экспорта публикации в HTML.


Проблемы переноса верстки в формат HTML

Даже поверхностного знания HTML достаточно, чтобы понять, сколь прост должен быть макет, который не пострадает при переводе в HTML версии 3.2. Более того, единственный мощный инструмент размещения элементов макета, имеющийся в этой версии (таблицы), не используется InDesign. В результате даже многоколонная верстка не может быть экспортирована адекватно.

Даже при использовании CSS, входящих в спецификацию 4.0, значительная часть элементов макета не может быть перенесена на Web-страницу:

  • Язык HTML не позволяет вам задавать гарнитуру, интерлиньяж, трекинг, кернинг, позиции табуляции и другие характеристики текста, поэтому при экспорте в формат HTML эти настройки теряются.
  • HTML поддерживает только графические форматы GIF и JPEG. Программа InDesign автоматически преобразует копии импортированных изображений (как вложенных, так и независимых) в формат GIF или JPEG, Объекты, построенные с помощью рисующих инструментов InDesign (за исключением горизонтальных линий) не экспортируются в формат HTML.
  • Объекты, трансформированные (повернутые, наклоненные или зеркально отраженные) в программе InDesign, экспортируются в формат HTML в виде точечных изображений.
  • Объекты, накладывающиеся друг на друга в программе InDesign, при экспорте в HTML без использования CSS разделяются, что может дать неудовлетворительный результат.
  • Формат HTML не позволяет даже приблизительно повторить обтекание текста вокруг непрямоугольных границ объектов. Поэтому текст, обтекающий любые объекты, переводится в точечное изображение.
  • Непрямоугольные текстовые фреймы экспортируются как точечные изображения.

Особой оговорки заслуживает первый пункт этого списка. HTML имеет тэг, позволяющий в явном виде задать гарнитуру шрифта, и InDesign использует эту возможность. Тем не менее, не стоит на нее слишком полагаться. При электронном распространении документов возникают проблемы, связанные со шрифтом. Во-первых, далеко не у всех пользователей есть те шрифты, которыми располагаете вы. Во-вторых, большинство гарнитур имеют множество "близнецов" (особенно на других платформах) с другими названиями, что не позволит браузеру подставить даже установленный шрифт, но имеющий другое имя. В-третьих, вы не имеете права свободно распространять коммерческие шрифты. Единственный способ обойти эти проблемы — не употреблять прямое задание гарнитуры в HTML-документе.


Размер Web-страницы

Самое коренное для верстальщика отличие Web-страницы от бумажной состоит в том, что Web-страница не имеет строго определенных размеров. Экран браузера может прокручиваться вниз и вправо, просматривать сколь угодно длинную и/или широкую страницу. Кроме того, количество материала, помещающегося на экран, напрямую зависит от разрешения экрана монитора, установленного у посетителя страницы. Такая "неопределенность" главного параметра публикации — ее формата, — крайне непривычна для верстальщика и дизайнера бумажных изданий. Это и неудивительно, поскольку Web-страница обладает своими, только ей присущими средствами выразительности, и ее дизайн вследствие этого в значительной степени отличается от книжного. При переводе публикации в HTML вам наверняка придется ее адаптировать не только для того, чтобы удалить или преобразовать непереводимые элементы, но и дополнить ее специфическими "электронными" элементами дизайна.

Несмотря на неопределенность формата Web-страницы, все-таки существуют размеры, на которые следует ориентироваться. Ширина страницы не должна превышать размеров экрана компьютера пользователя. Поскольку вы работаете с издательскими системами, наверняка установленный на вашем компьютере монитор имеет большую диагональ (17" или 21"), но далеко не все пользователи так "удачливы". Еще достаточно велик парк 14-дюймовых мониторов, на которых невозможно или неудобно устанавливать разрешение больше 800х600 пикселов. Это разрешение сейчас используется часто, поэтому рассчитывать лучше на него.

Поскольку при просмотре неудобно разворачивать окно браузера во весь экран, даже при ориентации на разрешение 800х600, мы рекомендуем ограничить горизонтальный размер для Web-страницы 600-ми пикселами. Длина страницы не должна превышать больше двух-трех экранов, т. к. это затрудняет ориентацию в ней.

Если вы не создаете публикацию "с нуля", то можете управлять размером страницы, получаемой в результате экспорта. Разработчики InDesign решили, что хорошим соотношением размеров страницы публикации и получаемой из нее Web-страницы является следующее: 1 пункт=1 пиксел. Таким образом, если вы хотите задать для Web-страницы размер 640х480 пикселов, то установите формат документа InDesign 640х480пунктов. Если вы хотите, чтобы в браузере высота шрифта была 12 пикселов, то установите в документе кегль шрифта 12 пт.


Экспорт публикации в формат HTML

Перевод публикации в формат HTML осуществляется соответствующим фильтром экспорта, вызываемым по команде Export меню File. Она открывает стандартное диалоговое окно сохранения файла. В списке Save as type выберите формат HTML, а в поле File name введите имя HTML-файла. Как только вы нажмете кнопку Save, вам будет представлено диалоговое окно с настройками фильтра экспорта, изображенное на рис. 17.1.

Устройство этого диалогового окна вам уже должно быть знакомо: так устроены многие диалоговые окна программы InDesign, например, Preferences или New Character Style. В верхней его части находится список, содержащий разделы диалогового окна. Вы также можете переходить от раздела к разделу с помощью кнопок Previous и Next. Рассмотрим разделы этого диалогового окна.

а

б

Рис. 17.1. Диалоговое окно Export HTML, раздел Documents для экспорта одной (а) и нескольких (б) Web-страниц


Параметры документа

В окне (см. рис. 17.1) можно определить, сколько отдельных HTML-документов создавать из файла публикации и какие ее страницы должны войти в каждый документ. Если переключатель Export As находится в положении A Single HTML Document, то все страницы публикации будут экспортированы на одну страницу HTML и отделены тонкими горизонтальными линиями (тэг <hr>).

Если переключатель Export As перевести в положение Multiple HTML Documents, то в области Multiple Document Options станет доступным список страниц публикации и отдельных HTML-файлов, в которые они будут экспортированы. Список документов состоит из полей, перечисленных ниже.

  • Флажок экспортирования. Только страницы, отмеченные этим флажком, будут экспортированы в формат HTML.
  • Номер страницы публикации. Страницы пронумерованы по порядку вне зависимости от разбивки по разделам.
  • Имя HTML-файла, в который будет экспортирована страница. О Название HTML-документа. Подставляется в тэг <title> заголовка.

Имя любого из файлов, перечисленных в списке, и название соответствующего HTML-документа можно отредактировать. Для этого следует щелчком выделить строку требуемой страницы в списке страниц, а затем отредактировать содержимое полей Filename и Title. В них будут находиться текущие имя HTML-файла и название документа соответственно.

По умолчанию имена документов генерируются программой InDesign автоматически на основе имени файла, введенного в диалоговом окне экспорта. К имени файла прибавляется номер экспортируемой страницы.

Если вы захотите сразу посмотреть на результат экспортирования, установите флажок View HTML Using и в расположенном по соседству списке выберите один из установленных на вашем компьютере браузеров. Сразу после завершения экспорта InDesign откроет получившийся документ в выбранном браузере.


Форматирование

В разделе Formatting (рис. 17.2) находятся элементы управления форматированием текста и выбором фонового изображения или сплошной заливки.

Флажок Override Color в области Text заставляет InDesign использовать для текста на Web-странице только выбранный цвет, независимо от его цвета в публикации. Флажок очень удобен, если в публикации для текста использованы плашечные цвета или оттенки серого. Цвет текста можно выбрать в списке или палитре цветов Windows/Macintosh, которая открывается щелчком на расположенном справа образце цвета.

Рис. 17.2. Диалоговое окно Export HTML, раздел Formatting

Список Maintain Non-Standard Text позволяет выбрать между сохранением форматирования текста и его редактируемостью. Если в списке выбран вариант Appearance, то нестандартный текст будет представлен точечным изображением. Вариант Editability оставляет текст редактируемым, но пропадают нестандартные элементы форматирования. Несколько примеров экспорта текста с разными установками Maintain Non-Standard приведены на рис. 17.3.

Будьте исключительно осторожны при выборе режима Maintain Non-Standard Text. Перед установкой варианта Appearance убедитесь в том, что нестандартное форматирование не применено к большому объему текста. Иначе весь этот текст будет преобразован в растровые изображения, увеличив размер страницы до неприемлемых размеров. К сожалению, это требование, как правило, не выполняется для хорошо сверстанного текста. В нем наверняка использованы настройки кернинга и трекинга для вгонки висячих строк, которые невозможно передать средствами HTML. В таком случае вам либо придется использовать вариант Editability, что может нанести макету непоправимый ущерб, либо подумать о переводе документа в формат PDF, поддерживающий любые атрибуты форматирования.

В области Background выбирают фон, общий для всех экспортируемых страниц. Он может отсутствовать (None), быть сплошным (Color) или текстурным (Image) в зависимости от положения единственного переключателя, размещенного в этой области. Если он находится в положении Color, то становится доступным список именованных цветов, которые вы можете использовать в качестве фонового цвета Web-страниц. Другие цвета выбирают в диалоговом окне Color, открывающемся двойным щелчком на прямоугольном образце цвета справа от списка.

Для того чтобы использовать для фона Web-страницы фоновую текстуру, переведите переключатель в положение Image и нажмите кнопку Choose. Она открывает стандартное диалоговое окно открытия файла, в котором вы можете выбрать произвольный графический файл, содержащий заранее приготовленную фоновую текстуру. В качестве фоновьк текстур можно использовать только изображения в форматах GIF или JPEG, принятых в WWW.


Макет

В разделе Layout (рис. 17.4) находятся всего три списка, управляющие размещением элементов публикации на странице. Наиболее важен список Positioning, определяющий, по существу, используемую спецификацию HTML. Вариант None соответствует спецификации HTML 3.0. В ней отсутствуют любые средства позиционирования объектов, поэтому на Web-странице они будут расположены подряд сверху вниз. При этом взаимное расположение объектов утрачивается. Многоколоночный текст размещается в одну колонку.

Рис. 17.4. Диалоговое окно Export HTML, раздел Layout

Вариант Best (CSS-1) устанавливает спецификацию HTML 4.0, использующую для позиционирования элементов макета слои и стилевые листы (CSS, Cascading Style Sheets). CSS позволяют хорошо воспроизводить размещение элементов макета, включая наложение объектов. Примеры Web-страниц, полученных при разных установках в списке Positioning, приведены на рис. 17.5.

Сгенерированные стилевые листы размещают каждый объект на своем слое, используя свойство z-index.

К сожалению, фильтр экспорта HTML не анализирует стилевое оформление публикации в целом и внедряет стилевые листы в каждый HTML-файл со страницей, а не связывает один стилевой лист со всеми файлами.

Список InDesign Margins определяет, будут ли при экспорте в HTML сохранены размеры полей, заданные на странице публикации. Вариант Maintain сохраняет поля, a None удаляет их полностью.

а

б

в

Рис. 17.5. Страница (а)

При экспорте нескольких страниц в разные файлы необходимо создание хотя бы простейшего способа перемещения между ними. В противном случае вы не сможете прочитать документ целиком. InDesign может создать на каждой странице гипертекстовые ссылки на предыдущую и следующую страницы публикации (рис. 17.6). Список Navigation Bar содержит варианты размещения ссылок на Web-странице: только сверху или снизу, как сверху, так и снизу. Выбор None запрещает создание ссылок. Используйте последний вариант, если намерены сделать солидную навигационную панель.

Рис. 17.6. Простейший инструмент навигации на экспортированной Web-странице


Графика

Без специальных подключаемых модулей браузеры способны работать только с точечными изображениями в форматах GIF и JPEG. Большинство новых версий браузеров также способны работать и с форматом PNG. Чтобы браузер смог отобразить экспортируемую из InDesign страницу, необходимо перевести все связанные и внедренные изображения в эти форматы и разместить в отдельных файлах. В разделе Graphics (рис. 17.7) диалогового окна Export HTML находятся настройки алгоритма преобразования.

Список Save Images As определяет формат, в который переводятся изображения при экспорте. Чаще всего наилучший результат дает вариант Automatic. При этом InDesign использует формат GIF для индексированных и обтравленных изображений, а также для текста. В остальных случаях применяется формат JPEG. Если вы твердо уверены, что потребуется строго определенный формат, выберите его в этом списке.

По старой и разумной традиции изображения размещают на Web-серверах в отдельных каталогах. Как правило, для них используется стандартное имя \IMAGES. Это помогает Web-мастеру ориентироваться в своем хозяйстве и писать сценарии. Установив флажок Use Images Sub-Folder, вы заставите InDesign следовать этой традиции. В папке, которую вы определили для экспортируемых HTML-документов, InDesign создаст вложенную папку \IMAGES и поместит туда все графические файлы. Вам останется только перенести HTML-файлы и папку \IMAGES на сервер, сохраняя структуру каталогов. Если вы переименуете эту папку или перенесете из нее изображения в папку, содержащую HTML-файлы, то графика на Web-странице исчезнет, поскольку ссылки из HTML-документов на изображения в папке IMAGES окажутся неверными.

Рис. 17.7. Диалоговое окно Export HTML, раздел Graphics

В области GIF Settings находятся параметры формата GIF. Как вы помните, это индексированный формат, позволяющий использовать не более 256 цветов одновременно. Чтобы перевести в него изображение, нужно уменьшить количество цветов, имеющихся в изображении, до минимально допустимого. Это количество определяется в поле Color Depth. В списке Palette выбирайте алгоритм сокращения количества цветов или готовую цветовую палитру.

  • Exact. Эта палитра доступна только если изображение уже содержит менее 256 цветов. В этом случае все цвета изображения попадут в индексированную палитру GIF.
  • System (Win). В качестве палитры изображения будет использована системная палитра Windows, а цвета, отсутствующие в системной палитре, —имитированы за счет сглаживания, т. е. соседними пикселами близких цветов, входящих в палитру.
  • System (Mac). В качестве палитры изображения будет использована системная палитра Macintosh, а цвета, отсутствующие в системной палитре, — имитированы за счет сглаживания.
  • Web. В качестве палитры изображения будет использована палитра браузеров, состоящая из системных цветов как Windows, так и MacOS. Обеспечивает правильную передачу цветов разными браузерами на компьютерах многих платформ. Цвета, отсутствующие в системной палитре, будут имитированы за счет сглаживания.
  • Adaptive (no dither). Палитра генерируется на основе наиболее характерных цветов изображения. Как правило, обеспечивает наилучший результат, поскольку подбирается для каждого изображения индивидуально. Могут быть нарушения цветопередачи на видеосистемах, не поддерживающих более 256 цветов.

Флажок Interlace устанавливает чересстрочную развертку GIF. Браузеры демонстрируют такие изображения с постепенно повышающейся деталировкой. Это позволяет посетителю сайта оценить содержание изображения, не дожидаясь окончания его загрузки.

В области JPEG Settings находятся параметры сжатия JPEG. В списке Image Quality выберите требуемое качество изображения. Как вы помните, при сжатии JPEG удаляется из изображения часть информации. Более высокое качество снижает эффективность сжатия. С другой стороны, при высокой степени сжатия может произойти значительное снижение качества изображения.

Список Format Method содержит варианты развертки изображений JPEG: Progressive или Baseline. В первом случае изображение демонстрируется браузерами с постепенно улучшающейся деталировкой, а во втором — просто построчно.

Особенности форматов изображений подробно рассмотрены в главе 12.


PDF и HTML

Изначально формат PDF был предназначен для переноса любых сверстанных документов между различными компьютерами любых платформ для последующей их распечатки (т. н. print on demand — печать по требованию). Подобный метод распространения технической информации очень удобен и дешев как для ее производителя, так и потребителей.

Второй жизни пакета программ Adobe Acrobat способствовало развитие Internet, где перенос сверстанных документов является задачей номер один. WWW с его скромными возможностями HTML не в состоянии решить эту задачу удовлетворительно. С ростом скоростей на магистральных каналах Internet, развитием цифровых каналов (в первую очередь ISDN) и совершенствованием модемов конечных пользователей, внешний вид передаваемых документов стал не роскошью, а информативной частью самого документа.

С недавним выходом Acrobat 4.0 и появлением PostScript 3 документы в формате PDF становятся стандартом и в полиграфических технологиях. • В результате формат PDF претендует на роль универсального способа передачи документов. Вы можете создать один PDF-документ, а затем использовать его для электронной публикации в Internet, распространения на CD-ROM, вывода на принтер, вывода цветоделенных типографских форм.

Средствами Adobe Acrobat пользуется все больше профессиональных коммерческих поставщиков информации. Если вы относите себя к таковым, то Adobe Acrobat — ваш выбор.

PDF-документ значительно ближе к бумажной публикации, чем документ HTML. Он сохраняет практически все ее особенности: формат страницы, любую (в т. ч. и векторную) графику, гарнитуры, обтравки, обтекание изображений текстом, маски, фреймы, типографику (настройки трекинга, кернинга, переносов, цветов, цветовых моделей, параметры цветоделения и растрирования и т. п.). Кроме бережного отношения к дизайну публикации, PDF дополняет его чисто "электронными" возможностями: гипертекстом, закладками, аудио- и видеоматериалами, интерактивными формами, инструментами навигации, кроме того, можно изменять масштаб отображения. При использовании совершенных методов сжатия данных, предоставляющих возможность выбора наиболее подходящего алгоритма, файлы в этом формате зачастую более компактны, чем аналогичные HTML-документы. Всем этим формат PDF обязан PostScript, который лежит в его основе. Уже этот факт показывает, насколько близок он к издательским программам.

То, что Acrobat Reader не превратился в браузер Internet, обусловлено и историческими и техническими причинами. Тем не менее в процессе установки Acrobat Reader помещает свои модули (plugins) в соответствующие каталоги двух наиболее популярных браузеров: Microsoft Internet Explorer и Netscape Navigator/Communicator. Эти модули позволяют просматривать PDF-документы прямо в окне браузера. При этом оно дополняется палитрой инструментов Adobe Acrobat Reader, обеспечивающей навигацию в PDF-документах (рис. 17.8).

Важным достоинством формата HTML является загрузка документов "по требованию". Чтобы просмотреть несколько страниц на сайте, вам не потребуется загружать его как целый документ. Начиная с версии 3.0, Adobe Acrobat позволяет также создавать PDF-документы, страницы которых загружаются только в том случае, когда они выбраны для просмотра. Для такой оптимизации готовых PDF-документов необходима программа Adobe Acrobat Exchange 3.0 или Adobe Acrobat 4.0, которая имеется только в отдельной "коробочной" версии Adobe Acrobat. Используя InDesign, вы сможете сразу создавать оптимизированные документы.

Для создания, редактирования и просмотра файлов формата PDF используется пакет программ Adobe Acrobat, разработанный фирмой Adobe Systems. Основными приложениями, входящими в этот пакет, являются Adobe Acrobat Distiller, Adobe Acrobat (в ранних версиях он называется Exchange) и Adobe Acrobat Reader. Первый предназначен для создания документов в формате PDF из PostScript-файлов. Второй позволяет их редактировать, создавать оглавления, индексы, помещать в PDF-файлы мультимедийные ресурсы и т. п.

Acrobat Reader, в отличие от остальных программ пакета, распространяется свободно. Он предназначен для просмотра PDF-документов. Программа Acrobat Reader выпускается для большого числа различных платформ: DOS,

Windows, Macintosh, UNIX и др. Это дает гарантию того, что документ, созданный с помощью Adobe Acrobat, может быть прочтен практически на любом компьютере. Если у вас нет программы Acrobat Reader, то она может быть свободно получена с сайта Adobe в Internet по адресу http://www.adobe.com/acrobat/.

Adobe InDesign способен импортировать и экспортировать файлы в формате Adobe Acrobat, но в текущей версии не поддерживает их редактирование. Если вам понадобится отредактировать готовый PDF-документ, то воспользуйтесь Adobe Acrobat 4.0 или Adobe Illustrator. Импорт PDF-документов рассмотрен в главе 12.


Экспорт публикации в формат PDF

InDesign, как и все новые программы Adobe Systems, способен создавать документы в формате PDF, не используя Acrobat Distiller. Он поддерживает последнюю спецификацию формата PDF 1.3, реализованную в пакете Adobe Acrobat 4.0.

Для того чтобы экспортировать текущий документ InDesign, необходимо выбрать команду Export меню File. В открывшемся диалоговом окне выбрать в списке форматов — вариант Acrobat PDF, а в поле File name указать имя PDF-доку мента. Щелчок на кнопке Save открывает диалоговое окно Export PDF с настройками фильтра экспорта (рис. 17.9).

Рис. 17.9. Раздел PDF Options диалогового окна Export PDF

Диалоговое окно Export PDF также содержит разделы, между которыми можно переходить с помощью кнопок Previous и Next или, сразу выбирая нужный раздел в списке, находящемся в верхней части диалогового окна.

В этой главе мы предполагаем, что электронная публикация рассчитана на распространение в Internet и предполагается только просмотр на экране или распечатка на офисном принтере. Параметры экспорта, которые задействуются только при использовании PDF-документа для предпечатной подготовки, рассматриваются в главе 19. Рисунки, изображающие разделы диалогового окна Export PDF, приведенные в этом разделе, показывают настройки экспорта, оптимальные именно для экранного просмотра PDF-документов.


Настройки PDF

Чтобы сохранить шрифтовое оформление публикации при переносе документов с одного компьютера на другой, формат PDF предполагает внедрение шрифтов в файл документа. Поскольку полное включение шрифтов может потребовать достаточно много места в PDF-файле, Adobe InDesign позволяет включать в файл только используемые в документе символы. Это произойдет при ненулевом значении в поле Subset Fonts below. Введенное в это поле число указывает программе, какой процент символов шрифта должен быть использован, чтобы шрифт был все-таки внедрен в документ целиком. Установка нуля соответствует внедрению всех шрифтов целиком, а 100% — внедрению только их используемых символов. Заметьте, что если шрифт включен в документ частично, то редактировать текст средствами Adobe Acrobat будет невозможно.

Список Color предназначен для автоматического перевода всех растровых изображений документа в одну из цветовых моделей: CMYK или RGB. Если изображения уже имеют требуемые цветовые модели, выберите вариант Leave Unchanged.

Если в документе используется управление цветом, т. е. в диалоговом окне Dociiment Color Settings установлен флажок Enable Color Management, тогда управление цветом можно сохранить и в PDF-документе. Флажок Include ICC Profiles управляет внедрением цветовых профилей элементов макета в PDF-документ. Если документ содержит цветовые профили, то он будет правильно отображаться на любой платформе, поддерживающей управление цветом. Особенно важно внедрение профилей, если документ планируется использовать для печати по требованию или создания типографских оригиналов.

Список Images определяет, какие версии точечных изображений в документе будут использованы в PDF-документе: внешние файлы с высоким разрешением или их копии с пониженным разрешением, предназначенные для просмотра. Выбирайте вариант Low Resolution только тогда, когда документ предназначен исключительно для просмотра на экране.

Флажки в области Omit позволяют избирательно исключать из PDF-документа связанные EPS-, PDF-файлы и растровые файлы. По существу, эта возможность используется только в технологии OPI (см. главу 19) и вне сферы предпечатной подготовки бесполезна.

Установленный флажок Crop Image Data to Frames может существенно сократить размер PDF-документа. Обычно при использовании масок, маскированное изображение попадает в PDF-документ целиком. Фильтр экспорта InDesign умеет обрезать маскированное изображение по границам маски. Таким образом в PDF-документе оказывается только видимая часть изображения, и лишняя (невидимая его часть) удаляется.

Каждая страница или разворот в PDF-документе может быть снабжена небольшими растровыми миниатюрами. Это даст возможность фильтрам им- -у порта PDF в Adobe InDesign, Photoshop и Illustrator показывать их в области -предварительного просмотра. Видя эти миниатюры вы сможете выбрать требуемую страницу PDF-документа, не открывая его. Миниатюры несколько увеличивают размер файла PDF-документа и их не стоит использовать, если документ предназначен для распространения через Internet. В остальных случаях не пренебрегайте возможностью автоматической генерации миниатюр, включающейся при установке флажка Generate Thumbnails.

Если вы располагаете полным пакетом Adobe Acrobat, то сможете сгенерировать миниатюры и для любого готового PDF-документа.

Флажок Optimize PDF включает оптимизацию PDF-документа, за счет чего документы будут ориентированы на просмотр в браузере. Такие документы не требуют для просмотра одной страницы предварительной загрузки всего документа. Страницы загружаются только по мере обращения к ним. При создании документов, предназначенных для распространения в Internet, обязательно установите этот флажок.

После экспорта документа вам наверняка захочется сразу убедиться, что все в порядке, и просмотреть его внимательно. Установите флажок View PDF after Exporting, тогда вам не придется разыскивать документ на диске и открывать его в Acrobat Reader. Сразу после завершения экспорта в формат PDF InDesign автоматически запустит Acrobat Reader (или Acrobat, если на вашем компьютере установлен этот пакет) и загрузит в него полученный документ.


Параметры изображений

Документы Adobe Acrobat компактны, поскольку используют мощные и хорошо вам знакомые алгоритмы сжатия точечных изображений и векторных объектов. Тем не менее, никакие алгоритмы сжатия не позволят уменьшить размер PDF-документа, если размер изображений в нем избыточен. Поэтому фильтр экспорта позволяет не только задавать алгоритмы сжатия, но и требуемое разрешение точечных изображений. Это очень удобно еще и потому, что, задавая различные разрешения для точечных изображений, вы можете на основе одного и того же документа InDesign получить серию PDF-файлов, ориентированных на экранный просмотр, печать на принтере или типографское тиражирование.

Разрешение и параметры сжатия точечных изображений задаются независимо для их разных типов. В области Color Bitmap Images раздела Compression (рис. 17.10) устанавливаются параметры цветных изображений в моделях RGB, CMYK и LAB. Для полутоновых изображений предусмотрена область Grayscale Bitmap Images, а для монохромных — Monochrome Bitmap Images. В каждой из перечисленных областей есть список (первый), задающий алгоритм пересчета разрешения, и соседнее поле, в которое вводится целевое разрешение.

Рис. 17.10. Раздел Compression диалогового окна Export PDF

Для экранного просмотра оптимальным является разрешение экрана монитора 72 dpi- Именно это число и следует ввести в поля областей Color Bitmap Images и Grayscale Bitmap Images. Для монохромных изображений требуется более высокое разрешение, 300 dpi (почему это так, читайте в главе 19).

Выбор между алгоритмами пересчета разрешения Downsampling и Subsam-pling лучше остановить на первом, поскольку он обеспечивает более высокое качество. На современных компьютерах более длительное время пересчета разрешения по этому алгоритму практически неощутимо.

Если изображения в документе уже оптимизированы под экранное разрешение, отмените пересчет разрешений. Для этого в списке алгоритмов выберите вариант No sampling change.

Для сжатия полутоновых и цветных изображений в PDF-документах применяются алгоритмы JPEG и LZW. Как вы помните, первый из них снижает качество изображений, но достигает значительно более высокой степени сжатия, чем второй.

Выбор алгоритма зависит от характера изображений в публикации и ее назначения. Если публикация рассчитана на экранный просмотр и содержит в основном фотографии, то выбирайте алгоритм JPEG. Во всех остальных случаях наилучшие результаты дает алгоритм LZW. Выбирайте алгоритм сжатия в списке Compression. Кроме вариантов JPEG и LZW, в нем присутствуют также Automatic и None. Первый из них доверяет выбор подходящего алгоритма фильтру экспорта, а последний помещает изображения в PDF-документ вообще без сжатия. Автоматическое определение алгоритма сжатия происходит на основании приблизительно тех же соображений, что приведены выше. При отсутствии сжатия объем документов становится большим, а это для электронных публикаций неприемлемо.

Список Quality задает качество изображений. Для алгоритма JPEG предлагаются градации Minimum, Low, Medium, High и Maximum в порядке возрастания качества. Выбирайте ту, которая обеспечивает компромисс между размером документа и качеством изображений. Подобрать ее можно только опытным путем. Если вы уже имеете опыт создания электронных публикаций в формате PDF или для WWW, то этот выбор не будет для вас проблемой. По характеру изображений вы сразу сможете предположить, какое качество окажется для них приемлемым.

Монохромные изображения требуют явного задания алгоритма уплотнения. Алгоритм влияет на размер сжатых файлов и на скорость их распаковки в программе просмотра. По плотности упаковки алгоритмы располагаются в таком порядке: CCITT Group 4 > LZW > CCITT Group 3 ” RunLength.

Векторные объекты и шрифты в PDF-документах никогда не растрируются, что обеспечивает идеальное соответствие документа макету, его небольшой размер, а также наивысшее качество при просмотре и печати. Еще большая компактность PDF-файлов обеспечивается сжатием векторных объектов и шрифтов. Она включается флажком Compress Text and Line Art. В общем случае этот флажок должен быть установлен.


Страницы и метки

Фильтр экспорта в формат PDF позволяет выбрать только ту часть документа InDesign, которую вы хотите экспортировать. Она задается путем ввода либо диапазона страниц, либо имен разделов. Эти и другие параметры задаются в разделе Pages and Page Marks (рис. 17.11) диалогового окна Export PDF.

Рис. 17.11. Раздел Pages and Page Marks диалогового окна Export PDF

По умолчанию документ экспортируется целиком, что соответствует положению All Pages переключателя, находящегося в верхней части диалогового окна. Если установить флажок Reader's Spreads, то в PDF-документе окажутся не отдельные страницы публикации, а развороты. Флажок действует только в том случае, если документ рассчитан на оборотную печать (в диалоговом окне Document Setup установлен флажок Facing Pages).

В положении переключателя Ranges становится доступным соседнее поле ввода. В него через запятую можно ввести номера экспортируемых страниц или их диапазонов. Например, при вводе 1-6,8,12- будут экспортированы страницы: с первой по шестую, восьмая и с двенадцатой до конца документа.

Если в документе определено несколько разделов, то их можно экспортировать в формат PDF выборочно. Для этого следует перевести переключатель в положение By Section. В расположенном ниже списке разделов щелчком кнопкой мыши выделите только требующиеся разделы. Смежные разделы можно выбрать щелчком на первом и последнем разделах при нажатой клавише <Shift>. Для выделения несмежных разделов удерживайте нажатой клавишу <Ctrl>.

Поле Bleed и элементы управления области Page Marks используются только при подготовке документа для типографской печати. Они задают соответственно выступ для печати навыпуск и простановку типографских меток. Подробное обсуждение этих установок отложим до главы 19.


Защита документов

При электронном распространении документов часто возникает проблема их защиты от несанкционированного использования. Формат PDF имеет средства запрета или ограничения доступа к содержимому документа. Защита PDF-документов имеет два уровня. Первый уровень защиты допускает ограничения на следующие действия:

  • Printing. Распечатка документа.
  • Changing the Document. Редактирование документа.
  • Copying Text and Graphics. Копирование текста и графики в буфер обмена.
  • Adding or Changing Notes and Form Fields. Добавление и редактирование аннотаций и полей форм.

Применяя этот уровень защиты, вы можете строго задать сферу использования документа. Например, установив запрет на редактирование документа, вы защитите его от злонамеренного искажения содержания. Если добавите защиту на печать и копирование в буфер обмена, то защитите содержание документа и от несанкционированного использования в других документах.

Прежде чем воспользоваться любой из запрещенных функций, вам, или иному лицу, потребуется снять защиту. Adobe Acrobat или Acrobat Reader потребуют для изменения установок защиты ввести пароль, который устанавливается при создании документа. Он вводится в поле Change Security в разделе Security (рис. 17.12) диалогового окна Export PDF. Поле становится доступным только в том случае, если установлен флажок Use Security Features. Сами варианты защиты устанавливаются в том же разделе с помощью соответствующих флажков области Do Not Allow.

Второй уровень защиты предполагает запрет открытия документа без знания пароля, который вводится в поле Open Document при создании документа. Защита этого уровня гораздо более надежна, чем первого. При такой защите используется криптостойкое шифрование. Это не позволит открыть документ без знания пароля, независимо от того, какие программы чтения будут использованы. Первый уровень защиты обеспечивается кодом самой программы Adobe Acrobat, который может быть изменен. Поэтому для документов, предназначенных для узкого круга читателей, предпочтительнее устанавливать пароль на открытие документов.

Рис. 17.12. Раздел Security диалогового окна Export PDF


Резюме

  • В последнее время все больше документов предназначается только для просмотра на экране (без получения промежуточной твердой копии). Один из основных каналов электронного распространения документов — Internet.
  • Для публикации в Internet часто используется самый его популярный сервис — World Wide Web (WWW). Документы, публикуемые в WWW, описываются с помощью специального языка HTML. Для просмотра документов применяются специальные программы — браузеры. Каждая новая версия HTML допускает все более тонкое управление форматированием документов. Последняя спецификация HTML 4 использует для свободного позиционирования стилевые листы (CSS).
  • Web-страница имеет неограниченный размер по вертикали и горизонтали. Тем не менее, если страница слишком длинная или широкая, пользователь должен прокручивать окно браузера, что не очень удобно при ее просмотре.
  • InDesign имеет специализированный фильтр экспорта публикации в формат HTML. Несовершенство этого языка описания страниц делает невозможным абсолютно точный перевод макета в InDesign на Web-страницу. Наилучший результат достигается при использовании стилевых листов.
  • Хорошим альтернативным вариантом для электронной публикации является формат PDF. Он позволяет сохранить все нюансы макета, включая шрифтовое оформление и векторные объекты, причем документ будет даже более компактен, чем документ HTML. Для просмотра PDF-документов используется Adobe Acrobat.
  • InDesign способен непосредственно экспортировать документы в формате PDF.


Глава 18

Корректура

В настоящей главе рассматриваются следующие вопросы:

  • Необходимость своевременной корректуры. Визирование
  • Редакторская правка и корректура текстов. Виды корректуры
  • Проверка правильности размещения текстов и графики на страницах публикации. Вывод пробных отпечатков на композитном принтере, особенности отпечатков на принтере. Формальная процедура подписания в печать
  • Проба цветоделения на лазерном принтере. Проверка PostScript-файла в программе Adobe Acrobat. Использование специального программного обеспечения для проверки цветоделения
  • Проверка фотоформ, полученных из сервис-бюро. Пробные отпечатки на цветопробном автомате и оценка необходимости проведения цветопроб. Анализ образцов печатных красок
  • Пробный оттиск в типографии, его анализ. Наиболее распространенные виды брака при печати

Этап подготовки издания, рассматриваемый в этой главе, необходим при издании абсолютно любых публикаций — от офисной документации до газет и книг. Каждый документ должен быть тщательно и неоднократно проверен. Чем дальше продвигается процесс издания, тем сложнее и дороже сделать исправления. Исправление вовремя не замеченной опечатки после вывода форм на фотоавтомате зачастую приводит к колоссальным временным и финансовым затратам.


Визирование

Здесь уместно подчеркнуть важность организации работы с заказчиком. Предъявление пробных отпечатков на лазерном принтере, предназначенных для целей корректуры, во многих случаях не влечет за собой никаких попы-

ток проверки и исправления неточностей со стороны клиента. Он бывает очень доволен и "благословляет" публикацию в тираж. Однако увидев пробные оттиски из типографии, а иногда и готовый тираж, этот же самый человек начинает тщательно проверять публикацию, а найдя в ней опечатки, погрешности верстки, другие ошибки, сделанные по вашей или по его вине, объявляет о необходимости их исправления. Последнее может быть проведено только путем перепечатки тиража за ВАШ СЧЕТ. Описанной ситуации можно и нужно избегать. Сделать это, как ни странно, в большинстве случае весьма просто. Организуйте систему визирования любого пробного отпечатка заказчиком. Каждый пробный оттиск, от корректуры текста до цветопроб, должен иметь подпись клиента на каждой странице. На каждом оттиске должна стоять пометка вашей рукой, что именно заказчик утверждает — текст, расположение элементов верстки (макет), цветовое решение, оригинал-макет в целом. Заказчик должен быть ознакомлен с возможностями легкой погрешности цвета в типографии и с тем, что отпечаток на цветном принтере и даже цвето-проба не дают абсолютно точной цветопередачи. .Лучше, если это тоже будет где-то записано и подписано клиентом, например, на конверте, куда вкладываются цветопробы и фотоформы. На первых порах работы по выпуску публикаций не делайте исключений ни для одного заказчика, требуйте визы даже со своих знакомых. Если вас обвиняют в педантизме, можно сослаться на порядок, заведенный руководством фирмы. Вероятность того, что эти визы вам пригодятся, крайне низка. Зато в случае конфликта вы будете обладать оружием, по мощности сравнимым с ядерным. Как убедились авторы книги, факт подписания пробного оттиска весьма полезен и для общего дела — печати качественной публикации, поскольку заставляет клиента более ответственно отнестись к корректуре. А лишняя пара глаз, да еще таких заинтересованных, в любом случае не повредит.


Подготовка текста

В годы перестройки, когда внезапно "стало можно", издание книг было весьма быстрым способом обогащения. Спрос на книги был колоссален. еще бы — в советские времена только материалы пленумов и первоисточники были в изобилии. Голодный рынок мог проглотить любое количество книжной продукции, которую лишь приблизительно можно назвать литературой. Разумеется, в наиболее выгодном положении оказывался тот, кто издавал быстро. Изданные в это время книги не проходили никакой стилистической правки и корректуры. Их переводили, набирали, прогоняли через программы проверки орфографии и грамматики (весьма не совершенные) н отправляли в печать. Все дело занимало несколько дней. Занимались изданием книг далеко не профессиональные полиграфисты и редакторы. Если вы возьмете с полки книгу, изданную в это время негосударственным издательством, вы поразитесь, как трудно ее читать — каждый элемент ее, с перевода и орфографии до иллюстраций и верстки, оставляет желать лучшего. Читая такое издание, вы испытываете раздражение. Времена изменились. Оформлению книги снова оказывается должное внимание. И снова даже очень маленькое издательство при подготовке ответственной публикации прибегает к услугам корректора.

Набранный в текстовом процессоре текст публикации обработайте программой проверки грамматики. Такие программы есть в локализованных версиях текстовых процессоров, например, Microsoft Word. Они несовершенны, однако обратят ваше внимание на грубые ошибки и явные ляпсусы. Проверку орфографии также можно организовать в текстовом процессоре. В InDesign имеется встроенная программа проверки орфографии, а значит проверить правописание можно и после импорта текста в InDesign. Разумеется, проверка правописания должна предшествовать верстке, поскольку при исправлении ошибок возможны подвижки текста.

Наличие корректора не снимает необходимость проверки орфографии, а может быть и грамматики. Если публикация велика, то такая проверка устранит грубые ошибки и впоследствии будет легче разобраться в первой корректуре. А если размер документа невелик или он не очень ответственный (документы для использования внутри фирмы, мелкая полиграфия — этикетки, открытки, визитки, брошюры и другие небольшие публикации), то вычитка текста корректором не производится, и самостоятельная вычитка будет единственным методом подготовки текста перед выпуском. При вычитке придерживайтесь следующих правил:

  • Проверка текста делается по бумажному отпечатку. На бумаге опечатки и ошибки видны гораздо лучше, чем на экране. Для корректуры распечатайте публикацию.
  • Тот, кто делает набор, обязательно пропустит ошибки при вычитке. Для проверки текста нужен "свежий глаз". Подготовьте макет для проверки и отдайте его другому человеку, пусть почитает. Если публикация ответственная, лучше, если проверяющих будет два, и они проверят текст по очереди. Не забудьте о проверке оттиска клиентом и подписании в печать.
  • Другой способ проверки важных данных в публикации (например, таблиц) — проверка вдвоем, один из проверяющих читает оригинал вслух, а другой вносит исправления.


Стадии подготовки издания

После представления авторского оригинала в издательство и его рецензирования и положительного решения о его издании рукопись должна проделать длинный путь до готовой книги. Раньше, при традиционной технике печа-- ти, число стадий, проходимых публикацией, было много больше. В первую очередь это было обусловлено необходимостью многократного набора текста

и сложностью работы с иллюстрациями. Теперь с помощью прикладных программ процесс издания заметно сокращен. В разных издательствах принят различный порядок подготовки публикации. Однако в общем случае эта процедура такова:

  1. Сначала автор представляет рукопись редактору. Редактор производит наиболее серьезные изменения в произведении, относящиеся к структуре, методам изложения и другим основополагающим моментам публикации. Эти изменения он обсуждает с автором, который осуществляет авторскую правку в соответствии с рекомендациями редактора.
  2. Затем рукопись приходит в набор, и профессиональные машинистки набирают текст в текстовом редакторе. Так возникает текст публикации, заметьте, что в отличие от традиционного полиграфического процесса эту тяжелую механическую работу нужно сделать только один раз. Часто стадия набора в издательстве вообще отсутствует, поскольку автор представляет рукопись в электронном варианте.
  3. Набор поступает на первую корректуру. Эта корректура представляет собой сверку набора с оригиналом и исправление замеченных опечаток.
  4. На следующей стадии технический редактор тщательно проверяет текст публикации на отсутствие противоречий, сверяет ссылки, исправляет погрешности стиля, составляет список личных имен, названий и сложных слов для корректора. Сам редактор или верстальщик вносит исправления в набор по согласованию с автором.
  5. Набор отправляется на корректуру. Для редакторской правки и корректуры чаще всего необходимы бумажные отпечатки всех страниц публикации. Она делается до макетирования. Для первой и второй корректуры качество печати публикации роли не играет. Корректор делает стилистическое редактирование (если эта работа не выполнялась редактором) и исправляет ошибки.

    6. Для корректуры нужно нанять работника — профессионального корректора. Наем такого человека можно осуществить в машинописных бюро, крупных издательствах и типографиях. Профессионализм корректора очень важен для качества публикации, хороших корректоров не так уж много. С корректором обычно заключается договор, в котором обязательно нужно указать сроки, подробно описать вид работы и ее стоимость. Стоимость корректуры колеблется в зависимости от типа и срочности. Различают простейшую корректуру — исправление орфографических и грамматических ошибок, стилистическую правку и сверку— сличение набора с оригиналом. Сверка обязательна в случае издания художественных, особенно классических произведений

  6. После корректуры рукопись возвращается для внесения исправлений. В первый момент может показаться, что все эти скобочки, стрелочки. кружочки и крючки, которыми корректор в изобилии снабдил каждую страницу, — чужой язык, который никогда не освоить, однако на самом деле, для того чтобы разобраться в знаках корректуры, необходимо лишь немного терпения.
  7. После внесения исправлений верстается макет. Текст и верстка публикации, в общем, определились. Если работа заказная, самое время показать ее клиенту и утвердить текст будущей публикации.
  8. После этого публикацию печатают для второй корректуры (в случае обычного, не сокращенного процесса подготовки издания). Обратно возвращаются две пачки листочков — первая из них чистая, без исправлений, вторая требует внесения не замеченных или не внесенных в прошлый раз исправлений. Обратите внимание, что макет уже существует, и исправления желательно проводить без подвижек текста.
  9. Далее макет печатается целиком и отсылается на подписную корректуру. Подписная корректура должна быть отпечатана качественно. Обратно возвращаются чистые листы макета, без исправлений, и на каждом листе есть подпись корректора. Это значит, что корректор проверил каждую букву публикации и гарантирует ее высокое качество с точки зрения русского языка. Изменения в макете после подписной корректуры нежелательны.


Формальная процедура подписания в печать

О необходимости утверждения работы заказчиком было сказано в начале главы. Позаботьтесь о том, чтобы на каждой странице подписной корректуры публикации стояла подпись клиента. Обязательно сообщите ему о важности этого этапа подготовки издания и о том, что в дальнейшем внести исправления в публикацию будет очень трудно и что ему придется это оплатить. Вообще, чем более формализована будет процедура подписания в печать, тем лучше. В разделе, посвященном выпуску цветных публикаций, мы остановимся на особенностях утверждения пробных отпечатков в случае цветной печати.


Применение лазерного принтера для вывода контрольных отпечатков

В вашем распоряжении уже имеется недорогой и надежный инструмент для изготовления контрольных оттисков макета — лазерный принтер. В следующих разделах рассматриваются различные способы его применения для получения контрольных оттисков.


Миниатюры

Контрольный оттиск, на котором страницы издания представлены в уменьшенном виде по несколько штук на листе, дает возможность оценить внешний вид публикации в целом. Если вы воспользовались оборотной печатью, то на одну страницу пробного оттиска можно выводить разворот с двумя смежными страницами.


Печать композитных оттисков

Для получения общего представления о макете, даже многоцветном, можно отпечатать публикацию совмещенным оттиском на лазерном принтере.


Черновой режим печати

Если контрольный оттиск выпускается для корректуры текстовой части макета (переносов, кернинга, разбиения на строки), установите в диалоговом окне Print флажок Proof. В таком режиме вывода InDesign заменяет все импортированные графические изображения перечеркнутыми косым крестом прямоугольниками, что значительно сокращает время вывода на печать (особенно — сложных макетов и объемных публикаций).


Проверка файлов перед передачей материала в сервис-бюро

При подготовке файла к передаче в сервисное бюро вам, разумеется, хочется посмотреть, каким образом будет выглядеть страница публикации на пленках, полученных на фотонаборном автомате. Такая информация может быть получена различными способами, с разной степенью достоверности. ?


Проверка PostScript-файла

Приблизительное представление о результатах может дать просмотр генерированного InDesign PostScript-файла публикации с помощью пакета Adobe Acrobat. Полученный после генерации файл обработайте программой Adobe Acrobat Distiller, а затем просмотрите полученный PDF-файл в программе просмотра Acrobat Reader. Непременно просмотрите полученный PostScript-файл на предмет правильности цветоделения, корректности макета, наличия служебной информации — меток обрезки, приводных крестов, сведений о форме и др.

Этой цели служат приемы, описанные в последующих разделах.

Для проверки готовых файлов печати можно использовать и специализированные программы, такие как Marksware FlightCheck или Enfocus Dou-blecheck. Они позволяют автоматически отслеживать типичные проблемы и создавать индивидуальный список проверяемых параметров. Вторая программа имеет клиентскую и серверные части, которые позволяют организовать поточную проверку файлов печати. Если ваше издательство достаточно крупное, то выигрыш от централизованной тщательной проверки "готовой продукции" будет очевиден.


Контрольный вывод файла на лазерный принтер

Вывод PostScript-файла на лазерный принтер преследует две цели. Во-первых, это дополнительная проверка качества цветоделения и правильности макета. Во-вторых, с помощью вывода на лазерный принтер производится проверка принципиальной возможности вывода файла на печать. Макет, который не печатается на вашем лазерном принтере, необходимо переработать. Найдите причину отказа и добейтесь, чтобы макет выводился без ошибок. Если макет публикации не удается вывести на лазерный принтер с разрешением 300 или 600 dpi, можно почти с полной уверенностью утверждать, что точно так же, аварийно, закончится и его вывод на фотонаборный автомат с разрешением 2450 dpi.


Проверка на наличие в макете потенциально аварийных ситуаций

В главе приведен перечень нежелательных ситуаций, которые могут привести к аварийному завершению вывода на печать. Проверьте макет публикации на экране в соответствии с этим перечнем, отыскивая в нем сложные графические изображения, маски обрезки, вложенные описания гарнитур, вложенные файлы в формате EPS, злоупотребления приемом поворота объектов средствами InDesign и так далее. По мере возможности устраните эти "мины замедленного действия" до передачи материалов в сервисное бюро.


Автоматическая проверка публикации в InDesign

InDesign имеет встроенный инструмент проверки грубых ошибок макета. Он запускается командой Preflight меню File. Программа проверки публикации отыскивает такие типичные проблемы, как отсутствующие шрифты, связанные изображения, лишние плашечные цвета, и др. Обязательно проверяйте публикацию перед выводом файла печати или сдачей в сервис-бюро.

Эта же программа позволяет автоматизировать, и, следовательно, снизить вероятность ошибок, при комплектовании макета для передачи в сервис-бюро. Она автоматически сохранит в отдельной папке готовую публикацию, все использованные в ней шрифты и все связанные с ней внешние файлы. Подробное обсуждение команды Preflight мы отложим до главы 19.


Корректура цветных изображений

Корректура цветных изображений до настоящего времени остается одной из самых сложных задач в издании публикации. Дело в том, что внешний вид будущей цветной публикации остается загадкой вплоть до пробных оттисков на офсетной машине. Любые пробные отпечатки дают лишь приблизительное представление о том. что вы увидите в тираже. Однако кроме сюрпризов цветопередачи и приводки цветов, которыми вас может "порадовать" типография, возможны сбои и ошибки, которые вы можете и должны предотвратить. Очень важна корректность фотоформ, по которым будет осуществляться процесс печати. Для того чтобы формы были корректными, вы должны правильно осуществить цветоделение и создать верный PostScript-файл. Для того чтобы публикация была правильно поделена на формы, необходимо верно задать атрибуты цвета каждого из цветных элементов публикации. Итак, начнем проверку публикации.


Проверка результатов цветоделения при помощи лазерного принтера

Выведите цветоделенные формы прямо из публикации на обычном лазерном принтере. Не забудьте включить отображение типографских меток и информации о странице. Установите режим цветоделения. Все эти параметры задаются в диалоговых окнах команды Печатать... (Print...). О печати документа рассказывается в главе 19. По отпечаткам можно судить:

  • О правильности распределения объектов, окрашенных плашечными цветами, по соответствующим формам.
  • О наличии цветоделения объектов, окрашенных составными цветами и импортированных объектов.
  • О корректности расположения элементов макета при выводе.
  • О наличии правильных углов растра для составных цветов.

Если элементы простых цветов расположены неправильно, проверьте присвоение цветов еще раз. Об углах растра читайте в главе 19.


Пробные оттиски на цветном принтере

Ваша работа может быть выведена совмещенным оттиском на цветном принтере. Оттиск стоит недорого, может быть сделан на разных этапах работы и очень быстро — в присутствии заказчика. Отпечаток может быть выполнен на качественной бумаге и выглядит очень привлекательно. Это немаловажно, если вы работаете по заказу. Такой оттиск, конечно, не будет полностью передавать цвета настоящей публикации. Это связано, прежде всего, с отличиями типографских красок от тех, что используются в принтерах. Как правило, отпечатки на принтере выглядят лучше, т. к. принтер обеспечивает больший цветовой охват, чем офсетный станок. Цвета на типографском оттиске будут "приглушенными" и менее контрастными. Тем не менее оттиск на цветном принтере весьма полезен для получения общего представления о том, как публикация будет выглядеть после печати. Авторы пользовались для получения пробных оттисков и относительно дешевыми струйными принтерами. Качество печати на них поражает (особенно, если сравнить с ценой). Для того чтобы цветопередача была точнее, пользуйтесь бумагой со специальным покрытием и программными интерпретаторами PostScript, поддерживающими управление цветом (Adobe PressReady, Birmy PowerRIP, и др.)

Демонстрация пробного отпечатка на принтере должна завершать подготовку макета и предшествовать выводу PostScript-файла. Попросите клиента завизировать каждую страницу публикации. При демонстрации отпечатка клиенту помните, что цветопередача при выводе нарушена, и вы показываете лишь примерный вид издания. Не забудьте донести эту информацию до клиента, во избежание недоразумений можно даже написать ее на первой странице отпечатка и дать заказчику на подпись.


Критерии оценки качества продукции

Обязательно вьысните, по каким критериям будет оцениваться публикация. Необходима ли максимально точная цветопередача, или достаточно добиться приятного для глаза сочетания цветов? В первом случае вам придется уделить публикации большее внимание, начиная от сканирования и заканчивая печатью. Обязательно проведите цветопробы в сервис-бюро.

При оценке результатов сканирования цветных фотографий уделите особое внимание хорошо знакомым цветам. Они настолько хорошо известны всем, что погрешность в их воспроизведении сразу бросается в глаза.

Важнейшими из цветов этой категории являются телесные цвета. Они традиционно считаются наиболее трудными для полиграфии. Особого внимания передача телесных цветов требует в тех случаях, когда на одной фотографии изображены представители различных рас. Не забудьте об этой особенности фотографии при сканировании и обработке. Обязательно присутствие заказчика при печати в типографии. Например, вы или печатники неверно отрегулировали цвета, а в результате лица на фотографии приобретут совершенно невероятную окраску. Представляете, какого цвета в данном случае будут лица у клиентов?...

Кроме телесных, существует множество других хорошо знакомых цветов. Каждому известно, как выглядят ясное небо, апельсин, яблоко, банан, этикетка кока-колы. Такие предметы будут выглядеть реалистично только при точном цве-товоспроизведении.


Композитные и деленные цветные контрольные оттиски

В сервис-бюро вам могут предложить два типа пробных отпечатков — композитные, выведенные из файла на высококачественном цветном принтере — лазерном, термодиффузионном, струйном, и деленные, которые выполняются на цветопробном аппарате с выведенных фотоформ.

Первые гораздо дешевле, однако дают лишь приблизительное представление о конечном результате. Цветопередача профессиональных цветных принтеров, разумеется, гораздо точнее, чем "домашних", дешевых. В этом смысле на них чаще всего можно положиться. Однако принтер для цветопроб печатает, как любой принтер, из файла. Полученный отпечаток никак не оценивает качество выведенных пленок, они просто не участвуют в образовании изображения.

К весьма важным проблемам качества пленок относятся:

  • Качество треппинга. Поскольку на композитном оттиске не используется разделение цветов по слоям, границы цветовых объектов всегда стыкуются идеально, и цветовые растяжки также воспроизводятся без погрешностей. Отсутствие смешивания красок на листе не позволяет выявить на композитном оттиске некоторые вызываемые этим явлением нежелательные эффекты.
  • Правильность углов растра и отсутствие муара. Муар (см. главу 19) — это регулярный рисунок на растрированном изображении, возникающий из-за некорректного цветоделения. Это распространенный и типографский брак. Возникновение муара на цветных изображениях связано с наложением цветных растров при офсетной печати. Печать на принтере осуществляется другими методами, и проследить возникновение муара невозможно.

Ниже перечислены основные три типа цветных принтеров, на которых получают композитные оттиски:

  • Устройства цветного светокопирования, оснащенные специальными контроллерами. Например, совместно с устройствами для светокопирования фирмы Canon используются контроллеры Fiery Unit фирмы EFI и ColourQ фирмы ColourAge.
  • Термодиффузионные принтеры (например, ЗМ Rainbow, Tektronix Phaser) наносят краску на специальную глянцевую бумагу.
  • Высококачественные струйные принтеры распыляют цветную краску на бумагу микроскопическими каплями (точно так же, как недорогие струйные принтеры). В сервисных бюро чаще других используются модели Iris и Stork Bedford.

Принтеры двух типов, а именно — устройства цветного светокопирования и струйные — могут печатать на любой бумаге, в частности, на той, которую вы выбрали для печати тиража (что положительно характеризует точность цвето-пробы). Для термодиффузионных принтеров требуется специальная бумага.

Проба с готовых пленок дает более точное представление о результате, т. к. позволяет выявить перечисленные выше проблемы, имеющие отношение именно к пленкам. Такая цветопроба основана на послойном наложении прозрачных цветных пленок, копирующих изображение с фотоформ. Типичными представителями такой технологии можно назвать Fuji и ЗМ Matchprint.

Наиболее адекватную цветопробу вам могут предложить не в сервис-бюро, а в типографии. Это не только наиболее точный, но и весьма дорогой вид цветопробы. Он выполняется с ваших фотоформ на очень дорогом и сложном оборудовании — пробопечатном станке. Оттиск производится офсетными красками на заказанной вами бумаге с ваших рабочих фотоформ. Таким образом, по отпечатку можно судить обо всех особенностях форм — цветопередаче, треппинге, качестве растрирования, величине растискивания точки и всех остальных характеристиках. Именно так, как отпечатана цветопроба, должен быть отпечатан тираж, если в типографии ответственно отнесутся к обязанностям и не произойдет сбоя печатной машины. В принципе, вы получаете первую "настоящую" копию вашей публикации. Вот так она и будет выглядеть. (

Далеко не во всякой типографии есть пробопечатный станок.

Эта технология очень дорога. Советуем вам делать цветопробы на первых порах работы с сервис-бюро и типографией, пока вы не уверены в качестве их работы. Также можно сделать цветопробу в очень ответственном случае.


Условия для оценки цветовоспроизведения

Цветовосприятие очень сильно зависит от освещения. Оценивать качество цветовоспроизведения следует при хорошем освещении, в некоторых сервис-бюро и типографиях имеются специальные колориметрические кабины со стандартным освещением. Как правило, условия освещения в колориметрической кабине соответствуют естественному свету в полдень.


Проверка публикации в типографии

Когда публикация "выходит из-под контроля", и ею начинают заниматься печатники, не следует опускать руки и ждать тиража. Кое-что вы можете сделать для проверки подготовки публикации даже на этом заключительном этапе.


Образцы краски и лака

Да простят нас типографы, еще раз подчеркнем необходимость дополнительной проверки их действий. Для полной уверенности в правильном подборе красок (особенно плашечных) для публикации соберите их образцы. Вначале попросите нанести образец краски на лист бумаги, подготовленной для печати тиража. Это делается при помощи специального ножа или резинового валика. Такой образец дает полное представление о том, как краска сочетается с бумагой.

Рекомендуем подобрать сорта бумаги, которыми вы постоянно пользуетесь в издательской деятельности, и выполнить такие пробы краски в типографии — они дадут гораздо более достоверное представление о результатах цветной печати, чем стандартные веерные образцы плашечных цветов. Можно специально для этого составить публикацию InDesign, использующую все цвета и оттенки, с которыми вам приходится чаще всего работать, и пропустите через сервисное бюро, получив фотоформы. Затем напечатайте эту специальную публикацию. Это не будет стоить слишком много, иногда ее можно напечатать совместно с какой-либо другой, на свободных краях типографских печатных форм. Обязательно проверьте, каким образом нанесение лака на оттиск меняет его внешний вид. Если вы применяете лак для глянцевания издания, проверьте, насколько темнее смотрятся под лаком образцы краски.


Проверка фотоформ в типографии

Технолог типографии обладает самой высокой квалификацией и всеми знаниями, необходимыми для компетентной проверки фотоформ, изготовленных в сервисном бюро. Даже если фотоформы уже проходили выходной контроль в сервисном бюро, в типографии их могут проверить люди, сотни, а может быть, тысячи раз сравнивавшие фотоформы с полученными по ним на данной печатной машине оттисками.


Пробные оттиски с печатной машины

Даже если вам не приходится работать с публикациями, предъявляющими особые требования к качеству воспроизведения цвета, постарайтесь хотя бы однажды присутствовать на выдаче пробного оттиска печатной машиной. Во-первых; это очень волнующий момент, а во-вторых, это лучший способ познакомиться с процессом переноса изображений на бумагу печатной машиной.

Постарайтесь заранее настроиться на сотрудничество с бригадой, обслуживающей печатную машину: ваша общая цель — получение наилучшего возможного результата.

Вас приглашают в печатный цех к тому времени, когда подготовка машины должна быть завершена, поэтому постарайтесь не опаздывать. После запуска машины обычно выполняются технологические оттиски, по которым производится окончательная настройка. Внешне это выглядит, как выбрасывание в брак листа за листом (при работе с машиной с листовой подачей) или метра за метром (машины с рулонной подачей) бумаги.

По завершении настройки машина закрывается и выпускается пробный оттиск. Нет времени пытаться найти в нем опечатки — это должно быть сделано давным-давно. На данном этапе вам необходимо убедиться, что все цвета воспроизведены точно и на оттиске отсутствуют очевидные дефекты. Вы должны завизировать контрольный оттиск, и в дальнейшем по нему будут выполняться все последующие настройки при печати тиража.

Как следует работать с контрольным оттиском? Задавайте вопросы технологу типографии и внимательно (очень внимательно!) рассматривайте лист, сошедший с печатной машины.

Попросите бригаду, обслуживающую печатную машину, поделиться с вами своим опытом. Полученные знания помогут вам в работе над будущими проектами.

Каким образом определяется растискивание точек по звездообразным мишеням?

Как используются прибор для определения нейтральной оптической плотности и контрольные шкалы — цветовая и монохромная?

Несмотря на то что технолог уже проверил приводку цветов, проверьте еще раз совмещение соответствующих типографских меток.

Внимательно просмотрите весь контрольный оттиск и убедитесь, что цвето-воспроизведение соответствует ранее утвержденному критерию точности. Если на оттиске имеются объекты, цвет которых должен быть воспроизведен с высокой точностью (логотипы компаний, образцы цвета для каталога системы цветов), сравните их с эталонами в условиях стандартного освещения. Не доверяйте собственной памяти.

Постарайтесь отыскать физические дефекты, возникшие в процессе печати. Морщины на оттиске, просачивание краски с противоположной стороны страницы, смазанные места, вызванные попаданием волос или грязи на печатные формы, кляксы, следы не до конца высохшей краски, перешедшей в стопке оттисков с соседнего листа — наиболее распространенные дефекты.

К проверке контрольного оттиска следует подходить со всей ответственностью, но не впадая в священный трепет. Постарайтесь максимально сконцентрироваться, чтобы не пропустить какие-либо ошибки. Помните, что грубая ошибка на этом этапе вполне может загубить весь тираж.

Имейте при себе образцы цвета для сравнения с контрольным оттиском. Если публикация предъявляет повышенные требования к качеству цветовоспроиз-ведения, не полагайтесь на свою память. Принесите с собой оригинал. Если на оттиске имеется фотография какого-либо изделия, лучше сравнивать его непосредственно с самим изделием. Принесите с собой ранее сделанные образцы красок. Если проверяется не первый контрольный оттиск, принесите ранее сделанные и завизированные контрольные оттиски.

Лучше всего, когда оригиналы или образцы предъявляются в типографию с самого начала сотрудничества с ней. На этапе передачи фотоформ и контрольных оттисков в типографию их предъявление просто обязательно. В идеальном варианте типография должна располагать собственным набором образцов.


Сигнальный экземпляр

При работе с многостраничными документами типографии выпускают сигнальные экземпляры — сфальцованные контрольные оттиски, позволяющие проверить спусковые макеты после фальцовки и обрезки. Это уже настоящая книжка, именно такой вид будет иметь весь тираж. Сигнальные экземпляры присылают в издательство. После последней проверки на них ставится печать типографии и подпись ответственного за выпуск. После выпуска и утверждения сигнальных экземпляров печатается тираж книги.


Резюме

Более подробно с технологией выпуска печатной продукции вы можете ознакомиться в главах 19 и 20. Разумеется, для проведения качественной корректуры цветных изданий необходимо ознакомиться с основами теории цвета, рассмотренными в главах 4 и 5.

Важность этапа корректуры для публикации невозможно переоценить. При тщательно организованной системе всесторонней проверки качества продукции вы сэкономите массу времени, нервов и денег — своих, своего начальника и своего клиента.


Глава 19

ВЫВОД

оригинал-макета

Одна из самых больших глав этой книги посвящена выводу оригинал-макета. И не случайно: это ответственная стадия подготовки публикации. На этапе вывода оригинал-макета необходимо учитывать множество технологических аспектов типографской печати и фотонабора. Здесь мы обсудим следующие проблемы:

  • Возможности языка PostScript
  • Установка драйверов PostScript и их использование InDesign
  • Линейные растры и параметры растрирования
  • Вывод макета на лазерный принтер и фотонаборный автомат
  • Профилактика брака на стадии вывода макета
  • Спусковые макеты

Невнимание к этим вопросам может катастрофически повлиять на выпуск публикации. Если вы новичок в издательском деле, то материал главы поможет избежать таких дорогостоящих ошибок, как повторный вывод макета или переделка тиража.

Прежде чем приступить к описанию многочисленных настроек печати в InDesign, мы посвятим первые разделы этой главы краткому описанию технологии вывода полифафических оригиналов.


PostScript или не-PostScript?

Поскольку данная глава целиком посвящена выводу оригинал-макета, стоит сделать общие замечания относительно "главного действующего лица" в этом процессе — принтера. (Мы подразумеваем любые принтеры и фотонаборные автоматы.) В сущности, фотонаборный автомат является очень сложным "интеллектуальным" принтером, и вывод на него ничем не отличается от вывода на офисный лазерный PostScript-принтер.

Как мы уже неоднократно отмечали, с точки зрения издательских систем принтеры подразделяются на две неравных категории — PostScript и не-PostScript. Во вторую попадают все матричные и струйные принтеры, а также лазерные и термодиффузионные принтеры и плоттеры, не имеющие поддержки PostScript. Они составляют большую часть парка принтеров, используемых сегодня.

Речь при этом идет об аппаратной поддержке PostScript, т. е. в этих принтерах отсутствует интерпретатор PostScript, реализованный в виде электронной схемы. В последнее время с ростом вычислительной мощности персональных компьютеров происходит постепенный переход от аппаратной реализации интерпретаторов PostScript к программной. Наиболее часто программная интерпретация используется в фотонаборных автоматах. Это связано с очень высокой стоимостью аппаратного интерпретатора для устройств, обеспечивающих такое огромное разрешение при печати. Значительно дешевле оказывается приобрести отдельный мощный компьютер и запустить на нем программу растрового процессора (RIP — Raster Image Processor). Кроме того, программная реализация позволяет включить в RIP такие дополнительные возможности, как предварительный просмотр PostScript-файлов на экране монитора, организация сетевых интерфейсов и очередей печати. Типичными примерами подобных растровых процессоров для фотонаборных автоматов служат RIP, построенные на технологии Harlequin (Ultre RIP, ECRM RIP, Express RIP, и др.).

Программные растровые процессоры имеются и для не-PostScript-принтеров, например, интерпретаторы ZScript (Zenographics Inc.), Image Alchemy PS (Handmade Software) и др. Стоимость аппаратного PostScript-интерпретатора для лазерных принтеров пока не на много выше стоимости программных, что обуславливает их популярность. Аппаратная поддержка для обыкновенных лазерных принтеров имеет и ряд преимуществ: скорость работы, использование оригинальной технологии Adobe, освобождение процессора компьютера от решения задачи интерпретации PostScript.

В издательском деле PostScript-принтеры составляют большинство используемых устройств печати. PostScript предоставляет такие важные для издательских нужд возможности, как задание параметров растрирования, печать импортированных EPS-изображений, поддержка PostScript-шрифтов, точная обработка развернутых, кадрированных изображений и т. п. Если у вас нет PostScript-принтера, вы не сможете использовать значительную часть возможностей любых издательских программ, в том числе и InDesign. Поэтому, если ваш принтер не оборудован интерпретатором PostScript, мы настоятельно рекомендуем его купить. Как правило, интерпретаторы PostScript поставляются и отдельно в виде модуля (печатной платы с разъемами) с набором микросхем. Модуль может быть вставлен в слот расширения принтера. За более подробными инструкциями обратитесь к руководству пользователя. входящему в комплект поставки принтера, или к его продавцу.

Еще раз перечислим те достоинства, которыми обладают только PostScript-принтеры:

  • Можно задавать параметры растрирования при печати: линеатуры и углы растрирования для каждой выводимой формы. PCL (Printer Control Language) позволяет задавать параметры растрирования только для композитной печати и не позволяет вывести цветоделенные формы. Все цвето-деленные формы будут иметь одинаковые линеатуры и углы растра.
  • Непосредственная загрузка в принтер шрифтов Type 1. При печати на прочих принтерах шрифты будут преобразованы в контуры.
  • Адекватное отображение инверсного текста. Для прочих принтеров требуется установить режим печати шрифтов как графики, что значительно увеличивает время печати и требует больших ресурсов принтера.
  • Высокая точность и отсутствие погрешностей при выводе на печать повернутых и искаженных изображений. PCL-принтеры редко столь успешно справляются с выводом таких изображений.
  • Высокое качество печати импортированных EPS-изображений. Прочие принтеры, будучи не способны использовать информацию из внешних PostScript-файлов, печатают лишь ту же миниатюру, которую вы видите на экране. Чтобы обеспечить хорошее качество при печати такой графики на He-PostScript-принтере, нет иного выхода, как создать миниатюру с более высоким разрешением. InDesign позволяет сделать это при импорте файлов формата EPS (см. главу 10).
  • Можно печатать в произвольным масштабе, зеркально, и по несколько сверстанных страниц на одном листе.

Язык PostScript развивается параллельно с развитием всей компьютерной отрасли. К настоящему моменту существуют три его версии, называемые уровнями: Level I, Level 2 и появившаяся недавно PostScript 3. В каждой новой версии интерпретатора PostScript добавляются новые возможности: поддержка новых форматов, объектов и способов их трансформации, параметров растрирования. управления цветом, и многое другое. Все версии PostScript совместимы снизу вверх, т. е. PostScript новой версии способен интерпретировать все команды языка более старой версии. Обязательно выясните, какая версия интерпретатора PostScript находится в используемых вами принтере и фотонаборном автомате. Чем новее версия PostScript, тем быстрее будет печать и выше ее качество. Правда, сама по себе версия интерпретатора не гарантирует ни того, ни другого.

Чтобы использовать все преимущества расширений языка, необходимо создавать файлы печати из расчета на ту же версию PostScript. Драйвер PostScript, поставляемый с InDesign, не поддерживает устройства вывода PostScript Level 1. Поэтому вам придется позаботиться о том, чтобы и ваш принтер и фотонаборный автомат имели старшую версию интерпретатора, или заменить драйвер PostScript на младшую версию (об этом написано ниже).


Драйверы принтеров и InDesign

He-PostScript-принтеры используют свои особые драйверы. Если вы — обладатель популярной модели принтера, то, скорее всего, вам не понадобится прилагаемый к нему драйвер, т. к подходящий найдется в системе Windows. В противном случае, установите прилагаемый к принтеру драйвер согласно руководству пользователя. Поскольку аппаратные возможности разных принтеров и их конструкция значительно отличаются, драйверы также имеют различные настройки.

Драйвер PostScript в Windows (PSCRIPT.DRV) является универсальным. Он используется любым PostScript-принтером, будь то офисный принтер, или фотонаборный автомат. Мы, как и фирма Adobe, не рекомендуем использовать драйвер, входящий в Windows 95/98 и Windows NT. Он допускает довольно много коварных ошибок, которые могут привести к неожиданным результатам при выводе публикации. Microsoft Corporation в сотрудничестве с Adobe Systems выпустили новый драйвер PostScript 4.x.x для Windows. Версии 4.00—4.1.1 обеспечивают поддержку PostScript Level 1 и Level 2. Версии выше 4.2.3 не поддерживают Level 1, но включают поддержку недавно разработанного Level 3. На дистрибутивном CD-ROM InDesign в папке \Print Drivers находится драйвер Adobe PostScript версии 4.3.1. для Windows 95/98 и версии 5.1 для Windows NT.

Приобретенный вами принтер или фотонаборный автомат должны комплектоваться файлом или файлами описания .PPD (PostScript Printer Definition). PPD-файлы необходимы драйверу Adobe PostScript для того, чтобы учесть аппаратные особенности вашей модели принтера. Для печати на PostScript-принтер InDesign требует обязательного наличия соответствующего ему PPD-файла в каталоге \<каталог InDesign>\RSRC\<языкoвoй каталог>\ PPD4. После установки драйвера принтера обязательно поместите файл описания PPD в этот каталог.

Драйвер Adobe PostScript не использует SPD-файлы описаний принтеров, поставляемые с Windows 95 и Windows NT. PPD-файлы представляют более развернутое описание PostScript-принтера, необходимое для работы издательских программ. Издательские программы, в т. ч. InDesign также изначально ориентированы именно на описания PPD. Они использовали эти описания еще в эпоху Windows З.хх.

На сайте Adobe Systems в Internet имеется множество файлов описаний принтеров. Среди них наверняка найдется файл описания и вашего принтера. Если вы — обладатель редкостного или совсем нового принтера (поздравляем!), то обратитесь на сайт производителя принтера.

Полученные PPD-файлы используются при установке принтера. Программа установки Adobe PostScript 4.3.1 запрашивает имена PPD-файлов принтеров, которые необходимо установить. На основе этой информации она определяет в стандартной папке Windows (Printers) новые принтеры, обращение к которым производится стандартным для Windows способом — выбором нужного принтера из их списка в окне Print любого приложения. Издательские приложения, кроме выбора соответствующего принтера, требуют также указания PPD-файла, в котором хранится его описание. Это сделано с целью хранения в PPD-файлах разных настроек для одного устройства вывода.


Растрирование

Большинство выпускающихся сейчас изданий содержат иллюстрации. Развитие компьютерного способа подготовки публикации делает легким и доступным очень сложный и трудоемкий процесс подготовки иллюстрированных изданий. Такая легкость имеет и свою оборотную сторону. Если раньше этим делом занимались типографии, содержащие в штате опытных профессионалов, то теперь для того чтобы создать иллюстрированный макет, нужно только знать соответствующую компьютерную программу. Но сделать красивый макет — это только половина дела. Что толку в таком макете, если он все равно не может быть напечатан или будет напечатан с искажениями? Отделение процесса подготовки публикаций от типографий заставляет верстальщиков осваивать азы полиграфии. Одним из самых сложных аспектов создания технологичного оригинал-макета является подготовка иллюстраций. Процессы типографской печати требуют наличия в макете иллюстраций, обработанных специальным образом. Полутоновые одноцветные иллюстрации должны быть растрированы, а цветные еще и цветоделены.

С линейными растрами вы уже неоднократно сталкивались. Растрирование применяется практически для всех цифровых устройств вывода (от мониторов до принтеров). Суть растрирования заключается в разбиении изображения на маленькие ячейки так называемой растровой сеткой. При этом каждая ячейка имеет сплошную заливку. Растровая сетка монитора разбивает изображение на пикселы, представляющие собой группу точек люминофора. Лазерный принтер или фотонаборный автомат делит изображение на черные точки разного размера. Цветные принтеры и офсетные машины оперируют с несколькими монохромными растрами одновременно. Параметры растрирования имеют решающее значение при выводе на эти устройства, поскольку параметры определяются их аппаратными возможностями.


Растровые точки

Способы передачи полутонов в аналоговых (фотография) и цифровых (принтеры, типографские машины) процессах принципиально различаются. Хотя в обоих случаях изображение все равно состоит из очень маленьких элементов, разница заключается как в самих элементах, так и в их расположении.

Черно-белая фотография строится из расположенных в случайном порядке точек, образованных разным количеством молекулярного серебра в слое эмульсии. Эти точки могут иметь различную оптическую плотность, т. е. каждая точка окрашивается в серый цвет какого-либо оттенка. В цифровых методах печати использование отдельных красок для передачи каждого оттенка серого невозможно. Представьте себе, сколько труда понадобилось бы для настройки приводки и печати двухсот с лишним красок и какой вид имела бы бумага уже после первых десяти! На практике для такой печати используется всего одна краска — черная. Полутона при этом передаются за счет растра. Если посмотреть на отпечатанное в типографии или на лазерном принтере изображение, то нетрудно заметить, что оно состоит из множества мелких точек, которые называются растровыми точками. Обычно точки располагаются регулярно, на одинаковом расстоянии друг от друга, формируя линейный растр или растровую сетку. Иногда применяется нерегулярное расположение растровых точек. Формируемый ими растр называется нерегулярным или стохастическим. На рис. 19.1 приведено растрированное изображение.

Рис. 19.1. Растрированное изображение

В отличие от фотографии, растровая точка не может иметь какой-либо оттенок — она может быть только черной. Для передачи оттенков в процессе растрирования формируются растровые точки разного размера. При печати более "жирных" точек в соседних ячейках растровой сетки остается между ними мало белого пространства, за счет чего создается иллюзия темного оттенка цвета такой области. Наоборот, при печати с тем же интервалом небольших точек большая часть бумаги между ними остается белой. Это создает ощущение светлого оттенка (рис. 19.2).

Таким образом, воспроизведение полутонов серого типографским способом, дающим возможность печатать фотографии, построено на оптическом обмане. Глаз воспринимает градации серого на изображении, при печати которого использовалась только черная краска, но не сплошной заливкой, а в виде отдельных точек.

Рис. 19.2. Имитация темных и светлых оттенков серого с помощью растра.


Цифровые растры

Изображение в лазерных принтерах и фотонаборных автоматах создается лазерным лучом. Луч не может создавать растровые точки разного размера, поскольку его диаметр фиксирован. Поэтому процесс растрирования заключается в объединении "реальных" точек, создаваемых лазерным лучом, в группы, образующие растровые точки.

Растр представляет собой совокупность квадратных ячеек, на которые разбито изображение. Каждая ячейка отводится для одной растровой точки. Растровая точка состоит из группы "реальных" точек одинакового размера, создаваемых устройством вывода. Чем большая часть такой ячейки заполнена точками, тем больший размер имеет формируемая ими растровая точка и ^ более темный оттенок серого она передает. Например, для того чтобы добиться заливки участка изображения 50-процентным серым, программа растрирования (растеризатор) заполнит этот участок растровыми точками, каждая из которых будет представлять собой наполовину заполненную ячейку растра. Для передачи 25-процентного серого ячейки растра будут заполнены черным только на четверть (рис. 19.3).

Рис. 19.3. 50- и 25-процентные растры под увеличением

Точки принтера в ячейке растра могут занимать различные положения. От этого будет зависеть форма растровой точки. В полиграфии используются различные формы растровых точек, но наиболее традиционная, и широко распространенная — круглая. Для того чтобы приблизить форму растровой точки к кругу, при заполнении ячейки растра растеризатор пытается наносить "реальные" точки как можно ближе к центру ячейки. Результат представлен на рис. 19.4. Там же приведены примеры других форм растровых точек. InDesign не может управлять формой растровых точек, как, например, Photoshop. Поэтому при необходимости использовать нерегулярные растры или отличные от круглых растровые точки, вам придется помещать в макет уже растрированное нужным образом изображение.

Рис. 19.4. Растровые точки различной формы

Какое же устройство выполняет функции растеризатора? В подавляющем большинстве случаев задача растрирования возлагается на само устройство вывода: принтер или фотонаборный автомат. Растеризатор "встроен" в интерпретатор языка описания страниц, используемого принтером. Наиболее совершенным растеризатором, используемым во всех высококачественных устройствах вывода, является интерпретатор PostScript. Второй популярный язык описания страниц, созданный Hewlett Packard для своих принтеров, PCL (Printer Control Language), не позволяет в требуемой для полиграфии мере тонко управлять параметрами растрирования.

Заметьте, что цифра, указываемая в паспорте принтера как разрешение (например, 600 dpi), представляет собой количество "реальных" точек, которое может напечатать принтер на единичном отрезке длиной 1 см или 1 дюйм. Количество растровых точек, приходящихся на единицу длины

(т. е. шаг сетки растра), также имеет свою единицу измерения, называемую линиатуроч. Линиатура измеряется в т. н. линиях/дюйм или линиях/см. Поскольку для формирования растровой точки требуются несколько реальных точек, линиатура растрового изображения всегда оказывается ниже разрешения принтера.

Линиатура растра для печати полутоновых изображений может быть задана произвольно. Ограничено при этом только ее верхнее значение. Разумеется, им является разрешение принтера. О том, какое значение линиатуры нужно устанавливать, мы и поговорим в следующем разделе.


Линиатура и градации серого

Отношение разрешающей способности устройства вывода к линиатуре растра дает размер стороны ячейки растра в точках принтера. Максимальное количество точек принтера, образующих растровую точку, равно квадрату стороны ячейки. Например, если линиатура растра установлена в 100 Ipi, a разрешение принтера составляет 600 dpi, то сторона ячейки растра равна 600/100 = 6 точек. При этих условиях растровая точка формируется из 6х6 =36 точек принтера. Это важно для адекватной передачи фотографического изображения, т. к. определяется количество оттенков серого, которое способен передать растр с заданными параметрами. В общем случае количество оттенков (N), передаваемое растром, определяется так:

N == (dpi/lpi)2 + 1, где dpi — разрешение устройства вывода, а lpi — линиатура печати.

Прибавленная единица соответствует белому цвету, когда растровая ячейка вообще не заполнена.

Практика показывает, что адекватность передачи полутонов зависит от тонального диапазона изображения, но даже в самом благоприятном случае для этого необходимо, как минимум, 150 оттенков серого. Для обеспечения высокого качества печати требуется еще больше полутонов. Как правило, параметры растрирования рассчитываются исходя из необходимости передачи всех оттенков, которые дает компьютерный оригинал, т. е. 256 оттенков при 8-битных полутоновых каналах.

Для примера попробуем рассчитать линиатуру растра, которая требуется для передачи 150 оттенков серого на офисном лазерном принтере, имеющем разрешение 600 dpi. Если преобразовать приведенную выше формулу, то получится:

lpi=dpi / sqrt(N-1)

Если подставить в него цифры, фигурирующие в нашей задаче:

600 / sqrt(150-1) = 50 линий/дюйм.

Большая или маленькая это величина? Чтобы было с чем сравнивать, скажем, что большинство газетных иллюстраций печатается растром в 75 Ipi, журнальных — 133 Ipi, а иллюстрации в хороших альбомах могут иметь ли-ниатуру 170 Ipi и выше. От линиатуры растра также зависит видимое качество иллюстраций. Чем выше линиатура, тем менее заметны образующие растр точки, и отпечаток ближе к фотографическому оригиналу. Как видите, полученные нами 50 Ipi — очень небольшое значение. Если отпечатать с такой линиатурой иллюстрацию размером с почтовую марку, то вряд ли вы сможете определить что же на ней изображено. Ведь каждая строка растровой сетки будет состоять всего из 50-ти точек.

Печатая на офисном принтере, приходится жертвовать количеством передаваемых оттенков серого для увеличения линиатуры растра. В большинстве 600-точечных принтеров значение линиатуры растра равно по умолчанию 85 Ipi. При такой линиатуре количество оттенков серого на изображениях не превышает (600/85)2 + 1 = 50. Это в три раза меньше минимума, который составляет 150 оттенков. Таким образом, объясняется невысокое качество печати изображений на офисных лазерных принтерах (рис. 19.5).

Рис. 19.5. Изображение, отпечатанное с линиатурами 50, 85 и 100 линий/дюйм

Если вы разобрались в материале этого раздела, то для вас должен быть очевидным тот факт, что фотонаборные автоматы, обеспечивающие качественную печать, обязаны иметь высокое разрешение. Это обуславливается механизмом цифрового растрирования и необходимостью передачи большого количества полутонов. Не составляет труда рассчитать, что для передачи всех 256-ти оттенков серого на обложке книги, отпечатанной с линиатурой в 150 линий/дюйм, требуется разрешение фотонаборного автомата в

150 * sqrt(256-1) =2395 точек/дюйм.


Линиатура и разрешение растровых изображений

После рассмотрения линейных растров правомерен вопрос о том, какое же разрешение должно иметь сканированное изображение для получения хорошего отпечатка. Выбор разрешения, необходимого для сканированных изображений, определяется не столько с разрешающей способностью устройства вывода, сколько линиатурой печати. Так получается потому, что на отпечатке глаз видит не "реальные" точки принтера, а растровые. Вопреки ожиданиям, для получения одной растровой точки требуется не одна полутоновая точка (т. е. точка сканированного изображения), а полторы-две. Например, если вы планируете печатать изображение с линиатурой 150 линий/дюйм, то разрешение исходного изображения должно находиться в интервале 225— 300 точек/дюйм. Если изображение имеет большее разрешение, то растеризатор сам отбросит лишнюю информацию, содержащуюся в нем. Разумеется, для этого понадобится время, иногда весьма значительное. Использовать завышенное разрешение не только бесполезно, но и вредно, т. к. приводит к увеличению времени печати, не повышая качества отпечатка.

Строго говоря, соотношение разрешения изображения и линиатуры печати зависит от характера изображения. Изображения, на которых нет мелких деталей, можно сканировать с разрешением вблизи нижнего предела указанного диапазона. Если же на изображении есть мелкие, и особенно повторяющиеся детали (например, текстура ткани, сетка тонких линий), то разрешение следует повысить.


Линиатура и качество бумаги

Если в вашем распоряжении есть фотонаборный автомат с разрешающей способностью в 3600 точек/дюйм, то вы практически свободны в выборе линиатуры. Как мы уже говорили, отпечаток, сделанный с высокой линиатурой, смотрится лучше, чем отпечаток с низкой. Может быть, стоит все время использовать линиатуру 3600 sqrt(256-1) = 255 линий/дюйм?

К сожалению, качество отпечатка определяется не только оригинал-макетом, но и технологией печати. Бумага не является столь "хорошим" носителем, как фотопленка. При печати реальными красками имеет место т. н. "растискивание" точек. Растискивание (dot gain) — это расплывание точек, из-за впитывания офсетной краски бумагой. Для получения качественного отпечатка необходимо, чтобы точки растра не накладывались друг на друга. Если линиатура растра велика, то растискивание приведет именно к этому, и вопреки ожиданию качество отпечатка ухудшится: появится "грязь" в тех местах иллюстрации, где есть локальные уменьшения плотности бумаги, ведь даже самая качественная бумага не абсолютно однородна.

Графические редакторы имеют специальный параметр настройки, призванный компенсировать этот эффект. Компенсация сводится к тому, что изображение печатается более светлым, чем требуется, и размер растровых точек уменьшается. Компенсация имеет и отрицательный эффект — ухудшается передача полутонов в светлых областях.

Чем выше качество бумаги и более плотен ее верхний слой, тем большую линиатуру растра можно использовать при печати. Высококачественную печать с линиатурой 170 линий/дюйм вообще можно вести только на специально обработанной, мелованной бумаге. Разумеется, чем лучше бумага, тем она дороже. Этот фактор также приходится учитывать при ее выборе. Для выбора правильной линиатуры растра обязательно проконсультируйтесь с представителем типографии. Работники типографии укажут ее оптимальное значение, исходя из сорта применяемой бумаги и возможностей оборудования. Более подробно вопросы выбора бумаги и сотрудничества с типографией обсуждается в главе 20.


Растрирование цветных изображений

Концепция полутонового растра позволяет пользоваться оттенками, работая с плашечными цветами. При определении оттенка фактически выполняется растрирование, когда интенсивность цвета уменьшается пропорционально размерам точек полутонового растра. Математически процентный параметр оттенка соответствует проценту заполнения растровой ячейки, а следовательно, размеру точек растра.

При горизонтальном или вертикальном расположении линий растра подчеркивается линейная структура последнего, поэтому растр становится лучше виден. Традиционно угол наклона при печати монохромных публикаций и печати плашечными цветами составляет 45°. Такое значение обеспечивает наилучшую маскировку линейной структуры растра, что и проверено временем.

Почему приходится обсуждать углы наклона растра? Во-первых, из-за того, что этот параметр может быть изменен при помощи одного из элементов управления в диалоговом окне Print программы InDesign. Наличие этого элемента управления прямо-таки провоцирует изменить наклон растра и посмотреть, что получится.

Да, действительно, наклон растра можно изменить, но делать этого не следует. Углы наклона, установленные по умолчанию, определены путем многолетних экспериментов с цветной печатью и монохромной печатью полутоновых изображений. Кроме того, оптимальный угол наклона растра указан в файле описания выбранного вами принтера (PPD).

Еще раз повторим: если у вас нет веских оснований для изменения наклона растра (и в типографии не возражают), не меняйте принятые по умолчанию значения. Если вы работаете с цветной публикацией, то, скорее всего, вывод окончательного оригинал-макета, деленных полос и фотоформ будет выполняться не вами, а в сервисном бюро. Изменив принятые по умолчанию углы наклона, вы готовите для его сотрудников и работников типографии хорошо замаскированную западню.

С корректировкой угла наклона растра приходится иметь дело почти исключительно при печати триадными цветами. На это имеются две причины. Во-первых, нанести на лист триадные краски без изменения угла наклона растра просто невозможно — в противном случае точки, соответствующие базовым цветам, будут печататься поверх друг друга. Углы наклона растров для базовых цветов должны быть подобраны таким образом, чтобы были видны все точки. Конечно, и в этом случае не обойтись без частичного перекрывания точек друг другом, но, поскольку триадные краски полупрозрачны, в этом нет большой беды. Тем не менее, принятые по умолчанию углы наклона растров, соответствующих базовым триадным цветам, подобраны на основе многолетнего опыта, и для их изменения нужны очень веские причины.

Рис. 19.6. Углы наклона растров базовых цветов при печати триадными красками, и схема возникновения муара

В конечном итоге углы наклона растров должны быть выбраны так, чтобы точки базовых цветов группировались в виде розеток (см. верхнее левое изображение на рис. 19.6). Каждую такую розетку можно рассматривать как некую метаточку цветного растра, образующую цвет в данной точке изображения.

Правое верхнее изображение на рис. 19.6 иллюстрирует еще одну причину, по которой углам наклона растров базовых цветов при печати триадными цветами приходится уделять столь существенное внимание. Если эти углы не согласованы, на изображении появляется муар — грязноватые волны. Муар — часто встречающийся брак цветовоспроизведения. Неверное задание углов растрирования красок, — пожалуй, самая экзотическая причина его появления. Гораздо чаще муар проявляется из за наложения растра, оставшегося на изображении после сканирования, на растр печати. Эффект муара при невысокой линиатуре могут дать и повторяющиеся мелкие детали самого изображения.


Треппинг и наложение

Треппинг и наложение используются для компенсации погрешностей печатного станка, являющегося несовершенным механическим устройством.


Треппинг

Треппинг — это вынужденная мера, применяемая для улучшения качества печати даже на несовершенных печатных машинах. Печатный лист в машине растягивается. де4юрмируется при нанесении краски, может двигаться неравномерно и смещаться в стороны. Поскольку печатная машина — обычное механическое устройство, в ней возможны сбои, что отразится на качестве публикации. В каждом конкретном случае искажения при печати могут быть иными. Если вы проведете треппинг публикации, то возникающие дефекты не будут так заметны.

При печати в две и более красок абсолютно необходимо, чтобы цвета располагались относительно друг друга точно, т. е. были приведены. Если этого не произошло, то в местах, где объекты разных цветов касаются друг друга, возникают нитевидные пробелы. Если же публикация напечатана составными цветами, погрешности выражаются в сдвиге цветовых компонентов объектов. В этом случае тоже возможно возникновение нитевидных пробелов на растрированном изображении. На рис. 19.7 показан результат неточного приведения цветов — нитевидные просветы (белый контур). Чтобы этих просветов не было, собственно и делается треппинг — незначительное растягивание одного из смежных объектов разного цвета так, что граничащие цвета слегка накладываются. Возникающий при наложении третий цвет будет ближе к более темному из них, причем форма объекта может слегка исказиться.

Рис. 19.7. Неточная приводка цветов — основная причина треппинга

Рис. 19.8. Виды треппинга— внешний и внутренний

Самыми простыми приемами треппинга являются сжатие (choking), или внутренний треппинг, и растяжение (spreading), или внешний треппинг (рис. 19.8). Сжимается или растягивается, как правило, цветовой объект, более светлый в смысле меньшей нейтральной плотности. Нейтральная плотность — характеристика яркости цвета, и именно по ее значению следует принимать решение о том, какой цвет распространять при треппинге. Если перекрывающий объект светлее фона, делается внешний треппинг, а если фон светлее объекта, в фоновом цвете цвета немного стягиваются внутрь — внутренний треппинг. В некоторых случаях используется треппинг по средней линии, представляющий собой комбинацию внутреннего и внешнего. Полоса треп-пинга в последнем случае размещается точно по границе соприкасающихся объектов.

В результате, во-первых, возникает третий цвет, а во-вторых, вокруг объекта появляется обводка. Иногда результат получается еще хуже, чем с нитевидным зазором. Однако, если для перекрывания выбран более светлый цвет, чаще всего эта обводка малозаметна.

Поскольку треппинг относится скорее к типографскому процессу, чем к компьютерному дизайну, его характеристики определяются чисто производственными параметрами: нейтральной оптической плотностью красок, ли-ниатурой растра, величиной растискивания точек растра, определяемой в основном сортом бумаги и другими. Ваша задача — узнать все эти данные в типографии перед тем, как начинать треппинг.

Самая важная характеристика треппинга — ширина полосы. Она зависит от линиатуры растра, сорта бумаги, погрешностей печатной машины и других факторов. Табл. 19.1 иллюстрирует зависимость полосы треппинга от линиатуры. Меньшее из чисел соответствует более высокому качеству печати и очень точной приводке.

Таблица 19.1. Зависимость шиоины полосы тоеппинга отлиниатуоы растоа

Линиатура растра, Ipi | Ширина линии треппинга, пт
65 | 0,55-2,20
100 | 0,36-1,44
133 | 0,27-1,08
150 | 0,24-0,96
200 | 0,18-0,72

Полоса треппинга указана для хроматических цветов. Для черного цвета полоса обычно в полтора-два раза шире.

Как и прочие издательские системы, InDesign поддерживает треппинг только на уровне объектов. Более сложные случаи треппинга, например, треппинг по растру, с ее помощью выполнить невозможно. Прежде чем браться за треппинг самостоятельно, оцените объем предстоящей работы и возможности типографии. Может быть, несложная модификация макета позволит вам вообще избежать треппинга или свести его к минимуму. Если нет, то вы можете поручить треппинг сервис-бюро, где его сделают с помощью специальных программ, высокоточных и очень дорогих (например, Luminous Trap Wise). Они способны выполнять все виды треппинга, включая такие сложные, как треппинг по растру. Но даже если сервис-бюро располагает программами треппинга, вы должны быть готовы к тому, что там не возьмутся за кропотливую работу с вашим документом, а используют установки треппинга по умолчанию.

Новейшее поколение фотонаборных автоматов, поддерживающих язык PostScript Level 3, может выполнять треппинг автоматически при выводе (In-RIP Trapping). Чаще всего это и есть самый простой и дешевый способ выполнения треппинга, поскольку интерпретатор PostScript берет всю работу на себя. В InDesign вы можете самостоятельно включить и настроить параметры треппинга средствами RIP. Настройки треппинга растровым процессором рассмотрены ниже в этой главе.

Поскольку треппинг делается не "от хорошей жизни", старайтесь всячески избегать его на стадиях подготовки макета и продумывания цветового решения. Используйте следующие варианты, не требующие треппинга:

  • Любые пары чистых цветов, разделенных белым зазором, т. е. объект с белой обводкой.
  • Треппинг общим цветом. Пара цветов, один из которых полностью содержится внутри другого, например, сочетание желтого и красного.
  • Печать черного с наложением (см. ниже).
  • Запечатывание границы цветов черной линией достаточной ширины.
  • Печать белым (вывороткой) по чистым цветам.
  • Использование цветов, имеющих в своем составе большое количество хотя бы одной общей краски. Например, светло-синий и светло-зеленый имеют значительное количество общей голубой краски. Пробел между ними будет не белым, что бросалось бы в глаза, а голубым.

Применяя перечисленные методы, избегайте следующего:

  • Выворотный (белый) текст или тонкие линии на фоне, состоящем из смеси двух и более чистых цветов.
  • Выворотный текст на "глубоком черном", состоящем из нескольких цветов.
  • Тонкие линии и надписи, выполненные "составными" цветами (синим, зеленым, красным, "глубоким черным").
  • Выворотный текст или тонкие линии на фоне точечных изображений.

Часто треппинга позволяет избежать печать с наложением, применяющаяся также и в других целях.


Печать с наложением

Типографские краски наносятся растровой сеткой под различными углами, чтобы предотвратить их смешивание, губительное для хорошей цветопередачи. На первый взгляд печать с наложением идет против этого правила. На практике все правила имеют ограниченную сферу действия. Печать с наложением используется преимущественно для плашечных цветов или черной краски при использовании триадных цветов.

Например, при печати черного текста мелкого кегля по цветному фону выворотка не делается и текст печатается поверх. Если бы выворотка была сделана (на месте текста отсутствовали бы прочие краски), то при малейшем нарушении приводки цветов текст стал бы абсолютно нечитаемым. С другой стороны, черная краска легко "запечатывает" остальные краски без образования дополнительного смешанного цвета. Обратите внимание, что применение треппинга в такой ситуации создаст больше проблем, чем решит. Во-первых, треппинг большого объема текста создаст очень сложные объекты, увеличивающие время вывода или вообще делающие вывод невозможным. Во-вторых, растяжение фона сделает выворотные области столь мелкими, что фактически печать все равно пойдет с наложением. Если кегль текста достаточно велик, чтобы треппинг все-таки оставил выворотные области, форма символов будет сильно искажена.

К печати с наложением следует подходить с осторожностью и помнить об ограниченной области ее применения. Наложение черной краски на большой площади может вызвать нанесение чрезмерного ее количества и опасное переувлажнение бумаги. Применяйте печать с наложением только для небольших областей.

С наложением можно печатать не только черный, но и любые темные пла-шечные цвета. InDesign позволяет задать печать с наложением для любого объекта публикации, созданного его собственными средствами.

Для задания режима печати с наложением используется палитра Attributes (рис. 19.9). В ней находятся всего два флажка: Overprint Fill и Overprint Stroke. Первый соответствует печати с наложением заливки выделенного объекта публикации, а второй — обводки. О том, что для объекта назначен атрибут или атрибуты печати с наложением, вы можете узнать только из палитры Attributes, поскольку на мониторе они никак не отображаются.

Рис. 19.9. Палитра Attributes


Треппинг наложением обводок

В программе InDesign нет специализированной команды треппинга, как ;

PageMaker или Quark XPress. Для качественного треппинга она предлагае использовать технологию In-RIP Trapping, реализованную в современнырастровых процессорах с интерпретатором PostScript 3. В диалоговом окне Print находятся все необходимые настройки для проведения такого треппинга. Он действительно является наилучшим возможным решением, совмещающим качество, гибкость и простоту выполнения. По этой причине выбирайте для размещения заказов те сервис-бюро, которые могут предложить треппинг по этой технологии.

Если объем треппинга невелик, вы можете проделать его вручную, используя печать обводок с наложением. Для того чтобы выполнить треппинг объекта, следует:

  1. Придать верхнему объекту обводку, совпадающую по цвету с заливкой верхнего или нижнего объектов, а для обводки выбрать цвет, имеющий меньшую нейтральную плотность.
  2. Установить ширину обводки равную удвоенной ширине зоны треппинга.
  3. Если используются плашечные цвета, установить для обводки атрибут печати с наложением с помощью палитры Attributes.
  4. Если используются триадные цвета, назначить обводке цвет, имеющий максимальные значения компонентов цветов объектов. Например, если один объект окрашен в цвет COM30Y60KO, а второй — в C50M5YOK10, то установите цвет обводки C50M30Y60K10. Явное назначение цвета обводки предпочтительнее печати с наложением, т. к. результат виден на экране.

В результате этих действий обводка верхнего объекта будет печататься поверх нижнего, что и нужно для треппинга.

При близких нейтральных плотностях цветов объектов треппинг может дать слишком явную темную кайму, неприемлемо ухудшающую вид отпечатка. Чтобы избавиться от каймы, сделайте оттенок обводки более светлым, сохраняя соотношение компонентов.


Настройки печати

Печать из InDesign мало чем отличается от печати из любого приложения Windows. Но все просто до тех пор, пока дело не доходит до печати оригинал-макета. В этом случае существует множество тонкостей, знание которых необходимо для успешного вывода и тонкого управления устройством печати. Любой фотонаборный автомат является PostScript-устройством и далее (если прямо не указано противоположное) мы будем говорить именно о выводе на устройства, поддерживающие PostScript. На рис. 19.10 представлено диалоговое окно Print, которое открывается при выборе одноименной команды меню File.

Рис. 19.10. Диалоговое окно Print

В верхней части диалогового окна Print находится список установленных принтеров и кнопка Properties, открывающая диалоговое окно драйвера выбранного принтера. Расположенные в той же области информационные поля показывают:

  • Status. Состояние принтера (готов, недоступен, нет бумаги, и т. п.).
  • Type. Драйвер, используемый принтером.
  • Where. Локальный или сетевой порт, к которому подключен принтер.
  • Comment. Описание принтера, введенное при его установке.

Флажок Print to file задает печать не на физически подключенный принтер. а в файл. Этот режим используется при предоставлении в сервис-бюро готового файла печати (см. ниже).

В поле Number of copies указывается число копий публикации, подлежащих выводу. Напечатать за один прием можно до 9 999 копий (если, конечно. емкость вашего картриджа позволяет засыпать в него столько тонера, и вь. не против израсходовать несколько ящиков бумаги).

Когда вы печатаете за один прием несколько копий публикации, программа InDesign печатает их в неразобранном виде — сначала печатается 10 копий первой страницы, затем — 10 копий второй и т. д. Установите флажок Collate. В этом случае последовательность страниц копий будет правильной. Правда, потребуется значительно больше времени, что сведет на нет его экономию на разборке копий на автоматическом деколлаторе. Произойдет это потому, что каждая страница будет загружаться в память принтера столько раз, сколько копий печатается.

Диалоговое окно имеет ряд вкладок, на которых выбираются разделы параметров настройки устройства вывода и где открываются соответствующие диалоги или выполняются действия:

  • Advanced Page Control. Определяет, какую часть публикации следует вывести на печать, количество требуемых копий и последовательность печати страниц, ориентацию страницы на листе бумаги, а также устройство вывода.
  • Color. Предназначена для настройки системы управления цветом, режима вывода композитных цветных изображений на черно-белых принтерах, важнейшие настройки печати цветоделенных полос, параметры растри-рования.
  • Scale and Fit. Задает масштаб вывода страниц и их позиционирование на отпечатке.
  • Graphics. Определяет режимы печати шрифтов и графики: пересчет разрешений точечных изображений, использование OPI, загрузку шрифтов, представление градиентов, пропуск заданных типов изображений.
  • Page Marks. Управляет расстановкой типографских меток и размером выпуска.
  • Trapping. Задает параметры треппинга средствами RIP (In-RIP Trapping).

Ниже мы подробно рассмотрим каждый элемент всех разделов диалогового окна печати.


Настройки драйвера принтера

Хотя большинство настроек печати сосредоточено в диалоговом окне Print, некоторые важнейшие установки необходимо предварительно сделать в диалоговом окне драйвера принтера (рис. 19.11). Оно открывается нажатием кнопки Properties, расположенной рядом со списком принтеров Name в верхней части диалогового окна Print.

Самый главный параметр, задаваемый при печати — формат бумаги. Если вы печатаете на настольном или цветопробном принтере, то выбор очевиден. Необходимо выбрать тот формат бумаги, которая находится в лотке принтера. Фотонаборные автоматы печатают не на бумаге, а на фотопленке.

Чтобы сэкономить пленку, размер "бумаги" для вывода на фотонаборные автоматы задают в точности равным размеру страницы с учетом типографских меток (см. ниже). Для этого надо воспользоваться диалоговым окном Custom-Defined Size (рис. 19.12), открывающемся нажатием кнопки Custom на вкладке Paper. Кнопка становится доступной, если в списке форматов выбран один из форматов с именем Custom. Введите в поля Width и Length размеры страницы с учетом типографских меток, а в поле Paper name — произвольное имя, которое вы дадите новому формату. Когда формат определен, он станет доступен в общем списке форматов и вам не придется задавать его снова для другой публикации того же формата.

Рис. 19.11. Настройки драйвера PostScript-принтера, вкладка Paper

Рис. 19.12. Диалоговое окно Custom-Defined Size

На вкладке Paper также задается книжная или альбомная ориентация листов бумаги при печати.

Флажок Transverse меняет ориентацию страницы при печати и используется для экономии пленки. Как правило, вы можете не слишком об этом заботиться, поскольку поворот страницы могут сделать работники сервис-бюро с помощью растрового процессора.

На вкладке Graphics (рис. 19.13) имеется список Resolution, в котором приведены разрешения печати. Выбор в этом списке не влияет на разрешение вывода, поскольку перекрывается установками на вкладке Color диалогового окна Print. В отличие от разрешения, коэффициент масштабирования, вводимый в поле Scaling, не перекрывается настройками в области Scale and Fit. To же самое относится и к настройкам области Paper Handling. Если в ней установлена печать с уменьшением нескольких страниц на одном листе, то In Design не перекроет этой установки.

Рис. 19.13. Настройки драйвера PostScript-принтера, вкладка Graphics

На той же вкладке Graphics в области Special находятся два важнейших флажка настройки печати: Print as a negative image и Print as a mirror image.

С помощью них подготавливаются оригиналы для вывода на фотонаборный автомат. Различные фотоавтоматы требуют по-разному подготовленных оригиналов, кроме того, и фотоформы, передаваемые в типографию, могут принципиально отличаться друг от друга. Чтобы не запутаться, воспользуйтесь табл. 19.2, но лучше проконсультируйтесь в типографии. Попросите технолога типографии четко определить характеристики фотоформ, необходимых для изготовления печатных форм. Получив от него указания, придерживайтесь их.

Таблица 19.2. Состояние флажка Print as a mirror image при различных сочетаниях типа изображения и положения светочувствительной эмульсии

Тип изображения | Положение эмульсии | Состояние флажка Print as a mirror image
Прямое | Вверх | Сброшен
 | Вниз | Установлен
Зеркальное | Вверх | Установлен
 | Вниз | Сброшен

При установленном флажке Print as a negative image изображение выводится в инвертированном виде, оно выглядит как негатив черно-белой фотографии. Если установлен флажок Print as a mirror image, выводится зеркальное отражение изображения. Термины прямое изображение и зеркальное изображение следует понимать буквально. Если на пленку выведено прямое изображение текста, вы можете легко прочесть его. Зеркальное изображение текста трудно читать без помощи зеркала. Изменяя состояние флажка Print as mirror image, вы одновременно изменяете положение пленки фотоформы по отношению к заготовке печатной формы — светочувствительной эмульсией вверх или эмульсией вниз.

Ознакомьтесь с табл. 19.2 и пользуйтесь ею как шпаргалкой. Например, в типографии запросили изготовить фотооригиналы прямого изображения эмульсией вверх. В первой графе таблицы отыскиваем строку, соответствующую прямому изображению. В той же строке второй графы выбираем вариант положения эмульсии "Вверх". В последней графе той же строки будет указано состояние флажка Print as a mirror image (в рассмотренном случае — сброшен).

Самое важное, что нужно запомнить в отношении флажков Print as a negative image и Print as a mirror image: их никогда не следует устанавливать без предварительной консультации с типографией и сервисным бюро.

Невозможно подсчитать, сколько дорогой пленки загублено из-за неправильного выбора этих режимов. Часто сервисные бюро самостоятельно устанавливают их. Если вы передаете публикацию в сервисное бюро в виде PostScript-файла, оператор фотонаборного автомата выберет режимы в соответствии с вашими требованиями. Если публикация передается в форме файла в формате InDesign, специалисты сервисного бюро сами установят необходимые флажки.


Вкладка Advanced Page Control

На рис. 19.10 изображено окно диалога Print, где выбрана вкладка Advanced Page Control. Настройки, имеющиеся в этом окне, определяют, какую часть документа следует вывести на печать.

В большинстве случаев печатаются все страницы публикации (когда выбран переключатель All). Если требуется отпечатать лишь некоторые страницы, введите в соответствующее поле список номеров этих страниц. Переключатель диапазона-автоматически займет положение Ranges. Номера отдельных страниц и группы смежных страниц в этом списке разделяются запятыми, а номера начальной и конечной страницы группы — дефисом (например 1,3-5,8,7-20,3). Меньший номер страниц должен быть указан перед дефисом. Обратите внимание: номера страниц могут входить в список более одного раза (в этом случае будут напечатаны копии).

Флажок View Section Numbering определяет, как нумеровать страницы — сплошная нумерация или по разделам (см. гл. 15). Если выбрана сплошная нумерация, то в поле Ranges следует вводить абсолютные номера страниц вне зависимости от разбивки по разделам.

Если в палитре Pages и поле Go to Page в нижней части окна документа (см. главу 1) отображаются номера страниц по разделам, а вам надо узнать абсолютные номера, откройте диалоговое окно Preferences. В разделе General этого окна находится список View, задающий режим отображения номеров страниц. Вместо варианта Section Numbering установите Absolute Numbering.

Если выбрана нумерация страниц по разделам, то в поле Ranges следует перед каждым номером страницы указывать, какому разделу она принадлежит (например, Sec2:3, Sec3:15-Sec4:2). Это означает печать третьей страницы в разделе Scc2, и с 15-й страницы раздела Sec3 по 2-ю страницу раздела Sec4 Имя раздела задается его префиксом.

При установке флажка Reader's Spreads на одном листе печатаются сразу две смежные страницы публикации. Можно оценивать качество верстки разворотов без утомительной возни с липкой лентой для склеивания отдельных страниц. Очень часто этот режим в 2 раза экономит бумагу при выводе публикаций небольшого формата. Режим масштабирования Reduce to Fit автоматически не включается и ориентация листа бумаги тоже не изменяется. Поэтому все необходимые установки для того, чтобы разворот помещался на листе бумаги, вам нужно будет сделать самостоятельно.

Выбрав переключатель By Section, вы можете печатать публикацию по разделам. В расположенном ниже списке приведены имена разделов, и номера страниц, которые они включают. Если флажок View Section 'Numbering сброшен, номера страниц приводятся как в пораздельней нумерации так и в сплошной. Чтобы напечатать раздел, выделите его в списке щелчком на соответствующей строке. Если требуется напечатать несколько разделов выделите их, удерживая клавишу <Shift> или <Ctrl> для последовательных и произвольных разделов соответственно.

Раскрывающийся список Options используется для оборотной печати. С его помощью можно определить, следует ли печатать страницы подряд только четные или нечетные страницы. Чтобы распечатать документ на обеих сторонах бумаги, сначала выберите в списке Options вариант Odd и напечатай те все нечетные страницы. Затем переверните вышедшую из принтера пачку бумаги, снова положите ее в лоток и, выбрав в том же списке вариант Even отпечатайте на ней четные страницы.


Вкладка Color

В сложившейся практике издательского дела с режимом Color диалогового окна команды Print (рис. 19.14) работают, в основном, сотрудники сервисного бюро: вы передаете в сервисное бюро файл публикации в формате программы InDesign для цветоделения и вывода фотоформ на фотонаборный автомат или деленных полос на репрографическую пленку.

Рис. 19.14. Диалоговое окно команды Print, вкладка Color

Однако до передачи публикации в сервисное бюро вы можете воспользоваться этим диалоговым окном, чтобы вывести пробные отпечатки цветных рисунков.

Кроме того, если вы передаете публикацию в сервисное бюро в формате PostScript, при выводе публикации в файл кое-какие установки, касающиеся режимов воспроизведения цвета, придется сделать.

В режиме Composite на принтер выводятся композитные (цветные) отпечатки. Композитный отпечаток дает возможность получить представление о публикации в целом, поскольку на нем совмещены в единое изображение все деленные полосы. Если выбранный принтер черно-белый, то в режиме Composite на него выводится полутоновой вариант публикации, причем все цвета представлены оттенками серого с учетом их нейтральной плотности. Второе применение композитной печати — создание PostScript- или PDF-файла, предназначенного для цветоделения средствами растрового процессора фотонаборного автомата. Для этого RIP фотонаборного автомата должен поддерживать цветоделение композитных файлов (In-RIP Color Separations). Прежде чем передавать в сервис-бюро композитные файлы, узнайте, 'поддерживается ли эта возможность используемым для вывода, фотонаборным автоматом. Если да, то установите флажок In-RIP на вкладке Color.

Рис. 19.15. Параметры фотонаборного автомата

О том, поддерживает ли RIP цветоделение, вы можете узнать у его сотрудников или на вкладке Device Options окна драйвера фотонаборного автомата. Если цветоделение поддерживается, то в списке Printer Features будет фигурировать строка InRIP Color Separation (рис. 19.15). Учтите, что включениеэтой функции в диалоговом окне драйвера принтера не даст ожидаемого результата. Некоторые из установок драйвера перекрываются установками в диалоговом окне Print InDesign. Для цветоделения средствами RIP установите флажок In-RIP на вкладке Color диалогового окна Print.

Необходимо, чтобы PostScript 3 поддерживал цветоделение дуплексов Рпо-toshop 5.xx средствами RIP.

Переключатель Separations используется при выводе деленных полос или фотоформ цветных оттисков в типографии. В этом режиме готовятся и файлы PostScript, предназначенные для передачи публикации в сервисное бюро. В этом режиме проверяется результат цветоделения на принтере, в ходе которой выясняется, правильно ли были назначены цвета различным объектам.

Диалоговое окно содержит список всех цветов, определенных в публикации. Любой из этих цветов может быть выведен на отдельную страницу. Кроме цветов, которые вы определили сами, список обязательно содержит стандартные триадные цвета: голубой, пурпурный, желтый и черный. Это дает возможность выводить формы для печати триадными красками.

Чтобы определить, какие цвета из приведенных в списке следует печатать, нужно выделить цвет щелчком на его имени в списке и установить расположенный ниже флажок Print this ink или просто сделать двойной щелчок на строке краски. У красок, которые не выводятся на печать, пиктограмма принтера будет перечеркнута.

Кнопки Print all inks и Print no inks позволяют быстро вносить изменения в перечень цветов, выбранных для вывода на печать. Например, для того чтобы печатать только одной краской, проще отменить выбор всех красок с помощью кнопки Print no inks, а затем выбрать требуемую.

Необдуманный щелчок на кнопке All to process при работе над публикацией, в которой важно точное цветовоспроизведение, может поставить вас в затруднительное положение. Как уже описывалось в главе 4, при преобразовании плашечных цветов в триадные вы доверяете качество цветовоспроизведения публикации алгоритмам преобразования цветовых моделей, встроенным в программу InDesign. В большинстве случаев преобразование будет выполнено вполне удовлетворительно. Однако преобразование цветовых моделей в принципе не может быть совершенным, и к оценке его результатов следует подходить критически. С другой стороны, это самый простой способ свести множество цветов, определенных в публикации, к триадным. Во всяком случае. после преобразования плашечных цветов в триадные обязательно следует сделать пробный отпечаток в цвете перед передачей публикации в типографию.

Список Screening определяет параметры растрирования при выводе. Если страницы печатаются композитом, то в списке есть два варианта — значение Default, заданное в драйвере принтера, и настраиваемые параметры растрирования Custom. Если значения в соседних с этим списком полях Frequency и Angle, заданы вами вручную, то автоматически активным в списке становится элемент Custom.

Если печатается цветоделение, то список содержит несколько стандартных, а значит, и наиболее удачных, сочетаний разрешение/линиатура для выбранного устройства вывода. Эти значения InDesign считывает из PPD-файла описания принтера. Оттуда же считываются линиатуры (соответствующие выбранной базовой) и углы растрирования для отдельных красок. При высоких разрешениях устройств вывода линиатуры для отдельных компонентов совпадают с базовой, а углы растрирования имеют типичные значения: голубой — 15°, пурпурный — 75°, желтый — 0°, черный — 45°. Для устройств с низким разрешением рекомендуемые линиатуры и углы для некоторых красок отличаются от приведенных. Чтобы просмотреть умалчиваемые параметры растрирования для каждой краски, достаточно щелкнуть на ее имени в списке цветов. При этом в полях Frequency и An gle появятся соответствующие значения. Вводя в данные поля новые значения, вы можете сами определить эти параметры для выбранных красок. Вы будете вынуждены воспользоваться этой возможностью при цветоделении по плашечным цветам. На этот случай PPD-файл не содержит рекомендуемых значений, и в поля параметров растрирования помещаются значения, совпадающие с таковыми для черной составляющей.

Параметры растрирования зависят от многих факторов, и если вы недостаточно опытны, то не устанавливайте их без предварительной консультации с представителями типографии или бюро предпечатной подготовки. Суть этих параметров объяснена выше.


Вкладка Scale and Fit

В области предварительного просмотра на вкладке Scale and Fit диалогового окна Print, представленной на рис. 19.16, можно увидеть, как страница публикации вместе с типографскими метками и описанием страницы размещается на листе бумаги. Изображение строится на основе данных PPD-файла. Ниже области предварительного просмотра расположены численные значения форматов бумаги и отступов.

Вычисление отступов (L, R, Т, В) производится в зависимости от размера печатной области (Paper Size) с учетом полей, обусловленных аппаратными ограничениями устройства печати. Например, многие принтеры не способны наносить краску или тонер по всей площади страницы из-за конструкции механизма захвата и протяжки бумаги. Если размеры доступной для печати части листа меньше размера страницы (Page Size), то значения отступов будут вьщелены красным цветом.

При необходимости печатать страницы таких размеров, которые превышают размеры бумаги, заложенной в принтер, можно воспользоваться раскрывающимся списком Tiling. Впоследствии страница публикации большого размера может быть собрана из фрагментов. Список содержит три варианта:

None (отсутствие разбиения на фрагменты). Auto (автоматическое разбиение) и Manual (ручное разбиение).

Рис. 19.16. Диалоговое окно Print, вкладка Scale and Fit

Вариант Auto предоставляет программе InDesign автоматически выбирать вариант разбиения страницы публикации на фрагменты. Выбрав этот вариант, вы можете задать величину перекрывания фрагментов в поле Overlap.

При ручном разбиении страницы на фрагменты для вывода у пользователя есть возможность управлять процессом разбиения. Чаще всего применяется именно такой способ для того, чтобы избежать пересечения фрагментов на сюжетно важном месте страницы. В этом режиме при нажатии кнопки Print программа InDesign выводит один фрагмент страницы. Верхний левый угол фрагмента определяется положением начала координат, а размер — форматом печатной области. Для печати очередного фрагмента следует переместить начало координат в его верхний левый угол. При ручном разбиении ответственность за создание перекрывающихся областей фрагментов полностью ложится на ваши плечи.

Второй вариант печати публикации, страницы которой превышают размеры листов бумаги, — масштабирование. В процессе печати можно увеличить или уменьшить размер страницы публикации, задав коэффициент масштабирования в пределах 1—1000%. Масштабирование с произвольным коэффициентом включается перемещением переключателя[А22] Scale в положение Х and Y. Коэффициенты масштабирования по вертикали и горизонтали в процентах вводятся в расположенные ниже поля Width и Heigh t. Чтобы масштабирование было пропорциональным, установите флажок Constrain Proportions. Когда этот флажок установлен, достаточно ввести коэффициент в любое из полей ввода, а значение во втором поле будет выставлено программой автоматически, исходя из пропорции. В большинстве случаев используется именно пропорциональное масштабирование, но иногда все-таки требуется и небольшое искажение, например, для компенсации растягивания формы при флексографиче-ской печати или офсетной печати с бумажных форм.

Если при печати страницы, не умещающейся на бумаге, вам не важен масштаб, а важно лишь получить отпечаток, то вы можете поручить InDesign вычислить минимальное масштабирование, необходимое для того, чтобы страница поместилась на бумаге целиком. Именно такую команду дает положение переключателя Scale to Fit. Рядом с переключателем указывается автоматически вычисленный коэффициент масштабирования.


Вкладка Graphics

Используя настройки вкладки Graphics (рис. 19.17), вы экономите время на выводе макета для корректуры и пробопечати.

Рис. 19.17. Диалоговое окно команды Print, вкладка Graphics

Список Send Image Data определяет разрешение изображений, передаваемых устройству вывода. В положении All на принтер поступают изображения максимального разрешения. Используйте этот режим для вывода публикации на фотонаборный автомат. Вариант Optimized Subsampling применяется для вывода макета на принтер, не требующий такого же высокого разрешения изображений, как фотонаборный автомат. InDesign автоматически пересчитывает разрешение изображений, исходя из выбранной ли-ниатуры печати. Это значительно экономит время печати, поскольку компьютер в состоянии выполнить пересчет изображений гораздо быстрее, чем принтер. В режиме Low Resolution изображения печатаются с разрешением экрана 72 dpi.

Для вывода корректуры можно вообще отключить печать изображений, установив флажок Proof Print, тогда графические изображения выводятся в виде серых перечеркнутых прямоугольников. За счет этого можно сэкономить много времени при выводе корректуры. Размеры прямоугольников совпадают с габаритами замещаемых ими изображений.

Режим Proof Print очень удобен для диагностирования причины сбоев при печати страницы. Чтобы выяснить, почему страница не выводится на печать (из-за текста или из-за графики), достаточно включить этот режим. Если после этого страница публикации отпечаталась нормально, "виноваты" импортированные графические изображения. Если страницу не отпечатать и в таком режиме, уделите внимание гарнитурам, используемым в публикации.

Флажок OPI/DCS Image Replacement включает замену помещенных в публикацию изображений низкого разрешения оригиналами с высоким разрешением. Верстальщику редко бывают нужны оригиналы изображений. Их присутствие в публикации замедляет работу программы и увеличивает размер файлов. Проблему решает использование OPI (Opened Prepress Interface). По этой технологии сканирование выполняется на профессиональном сканере в сервис-бюро или в самом издательстве. Сканированные изображения высокого разрешения не используются верстальщиком, а ожидают вывода на фотонаборный автомат. Верстальщик работает с их копиями низкого разрешения, которые размещает в публикации. Кроме этих изображений, в публикации присутствуют ссылки на оригиналы изображений высокого разрешения (OPI links или OPI comments). Подстановка их в публикацию происходит автоматически в процессе печати по прилагающимся ссылкам. Технология OPI позволяет уменьшить размер файлов, передаваемых сервис-бюро, и избавить верстальщика от потери времени при работе с большими изображениями.

InDesign всегда сохраняет в публикации комментарии OPI вне зависимости от состояния флажка OPI/DCS Image Replacement. Если вы используете технологию OPI (изображения в высоком разрешении остаются после сканирования в сервис-бюро) и передаете в сервис-бюро файл печати, то сбросьте этот флажок. В результате файл печати не будет содержать изображений высокого разрешения и они не потребуются программе InDesign при создании файла печати. Оригиналы высокого разрешения будут автоматически подставлены уже при выводе на фотонаборный автомат в сервис-бюро благодаря имеющимся в файле печати комментариям OPI.

Если не используется технология OPI (изображения высокого разрешения находятся у вас), обязательно проследите за тем, чтобы флажок OPI/DCS Image Replacement был установлен. В противном случае изображений высокого разрешения не окажется ни в файле печати, ни в сервис-бюро.

С помощью флажков области Omit вы можете избирательно использовать технологию OPI для EPS, PDF и точечных изображений. Например, установив флажок Bitmap Images и сбросив флажок EPS, вы поместите в файл печати все EPS-изображения, а вместо точечных изображений в нем будут только ссылки OPI. Такая комбинация чаще всего и используется, поскольку иллюстрации в формате EPS занимают очень мало места и нецелесообразно использовать для них OPI.

Все сказанное относительно технологии OPI справедливо и для цветоделенных изображений в формате DCS. Как вы помните, DCS-файлы содержат несколько полутоновых форм для каждой краски и композитное изображение, используемое для просмотра. Поэтому для верстки не обязательно наличие полутоновых файлов высокого разрешения, и они могут оставаться в сервис-бюро. Таким образом, формат DCS сам по себе предполагает технологию, аналогичную OPI.

На момент написания книги OPI-серверов, способных работать с PDF-файла-ми, не существовало. Поэтому прежде чем использовать флажок PDF в области Omit, выясните в сервис-бюро, поддерживает ли их программное обеспечение технологию ОР1 для PDF-файлов.

Переключатель в области Font Downloading управляет загрузкой шрифтов в устройство вывода:

  • Complete. В файл печати или устройство вывода загружаются все шрифты, использованные в публикации загружаются полностью.
  • Subset. В файл печати или устройство вывода загружаются только те символы, которые используются в публикации. За счет этого уменьшается размер файла печати и сокращается время вывода. По умолчанию используется именно такой режим загрузки шрифтов.
  • None. Шрифты вообще не загружаются в принтер или не внедряются в файл печати. Публикация будет правильно напечатана только в том случае, если используются шрифты, резидентные для данного принтера, или они были предварительно загружены. Как правило, все устройства вывода, поддерживающие PostScript, имеют стандартный минимальный набор из 35 резидентных шрифтов, которые не требуется включать в файл печати или загружать в память принтера. Тем не менее, они используются исключительно редко. Даже если в вашей публикации используются только Helvetica и Times, не отключайте загрузку шрифтов: резидентные шрифты имеют не кириллическую кодовую таблицу и буквы русского языка не будут напечатаны. Кроме того, метрика ваших шрифтов может несколько отличаться от тех, что резидентны в памяти принтера. Это может катастрофически отразиться на внешнем виде текста.

Флажок Download PPD Fonts включает загрузку в принтер или помещение в файл печати всех использованных в публикации шрифтов, в том числе и резидентные шрифты принтера. Это предотвращает опасность конфликта кодировок и рекомендуется для печати русскоязычных публикаций.

В области Gradient Options находятся .флажки, влияющие на режим печати градиентных заливок. Установите флажок Force Continuous Tone Behavior при печати на сублимационном принтере или цветном лазерном принтере непрерывного тона, которые не используют линейного или стохастического растрирования. Флажок PostScript Level I Compatibility сделан только для обеспечения совместимости с устройствами вывода PostScript Level 1. Интерпретатор этой версии требует представлять градиентные заливки серией фигур со сплошной заливкой.


Вкладка Page Marks

Типографские метки— приводные и обрезные кресты, шкал ки — изображены на рис. 19.18.

Рис. 19.18. Типографские метки

Для печати типографских меток требуется дополнительное пространство шириной 8,5 мм с каждой стороны страницы. Это означает, что на стандартном листе формата А4 можно будет напечатать с типографскими метками страницу, имеющую размеры, не превышающие 193х280 мм. На вкладке Page Marks (рис. 19.19) есть область предварительного просмотра, где вы можете непосредственно увидеть размещение страницы с типографскими метками на печатном листе. Это дает гарантию того, что вы не ошибетесь при выборе формата печати и отведете место под типографские метки.

Рис. 19.19. Диалоговое окно команды Print, вкладка Page Marks

Простановка всех типографских меток включается флажком All Printer's Marks. Если требуются только некоторые метки, то установите их отдельными флажками:

  • Crop Marks. Метки обрезки используются в типографиях для резки страниц публикации из листов бумаги более крупных размеров, на которых производилась печать.
  • Color Bars. Шкала цветов дает возможность проверить качество цветовоспроизведения при печати в цвете, а шкала плотности — правильность воспроизведения полутонов серого цвета фотонаборным автоматом или печатной машиной, измерить величину растискивания точек.
  • Registration Marks. Метки приводки представляют собой миниатюрные круглые мишени, по которым в типографии выполняют приводку цветоделенных форм при многокрасочной печати.
  • Page information. Установка этого флажка включает режим печати на каждой странице имени файла, номера страницы, название цвета и даты вывода на печать. Для печати используется шрифт Ariai кеглем 8 пт.
  • Bleed. Marks. Метки, похожие на обрезные, показывающие величину выпуска.

Часто изображения на странице размещают таким образом, чтобы его края совпадали с краями бумаги. Для этого недостаточно разместить изображение просто впритык к краю страницы публикации. Малейшая погрешность при обрезке оттисков (а они неминуемы) "отодвинет" изображение от края бумаги. По этой причине изображение размещают не впритык краю страницы, а навыпуск (bleed). При этом часть изображения оказывается за пределами страницы, но при печати выводится на принтер. Этой частью изображения сознательно жертвуют, поскольку она будет обрезана. Зато выпуск за край страницы дает гарантию, что при обрезке края изображения не будут видны. Величина выпуска зависит от оборудования для резки, применяемого в типографии, но, как правило, не превышает 5—7 мм (14—20 пт).

Чтобы метки обрезки и шкалки были проставлены правильно, необходимо указать InDesign размер выпуска. Он вводится в поле Bleed на вкладке Page Marks диалогового окна Print. При печати навыпуск вы можете установить флажок Bleed Marks. Он включает простановку меток обрезки без учета выпуска. В результате на отпечатке оказываются два комплекта меток обрезки:

Crop Marks, по которым и надо обрезать бумагу, и Bleed Marks, показывающие размер страницы вместе с выпуском. Мы не рекомендуем устанавливать флажок Bleed Marks, чтобы не запутать работников типографии, — они могут обрезать страницы не по тем меткам.


Вкладка Trapping

Настройки вкладки Trapping задают параметры треппинга публикации (рис. 19.20). Подчеркнем, что они относятся только к треппингу, выполняемому средствами RIP (In-RIP Trapping). 0 ручном треппинге средствами наложения обводок уже ^ыло рассказано выше. Чтобы включить треппинг растровым процессором, установите на вкладке Trapping диалогового окна Print флажок Enable Adobe in-RIP Trapping. До тех пор пока флажок не установлен, треппинг выполняться не будет.

Рис. 19.20. Диалоговое окно Print, вкладка Trapping

При выполнении треппинга важнейшими данными для интерпретатора PostScript являются нейтральные плотности красок, которые будут использоваться при печати публикации. На основе нейтральных плотностей (видимой яркости цветов) чистых красок RIP решает, к какому виду треппинга (внешнему или внутреннему) следует прибегнуть. Оптические плотности триадных красок стандартизированы и сразу приведены в диалоговом окне Inks (рис. 19.21), открывающемся нажатием одноименной кнопки на вкладке Trapping. Впрочем, даже для триадных красок существуют несколько стандартов нейтральной плотности. Те значения, что приведены в диалоговом окне Inks, соответствуют американскому стандарту рулонной офсетной печати SWOP (Standard Web Onset Printing). Наилучший результат треппинга обеспечит подстановка вместо стандартных значений результатов измерения нейтральной плотности с помощью денситометра. Как правило, в типографиях есть такой прибор, используемый для контроля процесса печати. Узнайте в типографии значения нейтральных оптических плотностей для используемых красок и типов бумаги.

Рис. 19.21. Диалоговое окно Inks

Если в публикации есть плашечныс цвета, то InDesign автоматически проставит их нейтральные плотности, рассчитанные на основе CMYK-эквивалентов этих цветов. Более точные значения можно также получить непосредственным измерением, хотя и расчетные значения практически всегда работают удовлетворительно.

Все используемые краски приведены в списке, занимающем верхнюю часть диалогового окна Inks. В нем также указаны нейтральные плотности красок, их тип и порядок печати. При печати триадными красками, как правило, используется тот порядок, который фигурирует и в названии цветовой модели CMYK. Первой на бумагу наносится голубая краска, затем пурпурная, желтая и черная. Не изменяйте порядок печати триадных красок, пока не будете уверены, что в типографии используется иной порядок.

Порядок печати плашечными цветами определяется на основе оптической плотности красок и их кроющей способности (непрозрачности). Более светлые краски с меньшей кроющей способностью печатаются первыми. Определить порядок печати и задать оптические плотности для обычных плашечных красок не составляет труда. Сложнее обстоит дело со специальными красками: металлизированными, флуоресцентными, флексографическими, пастельными, лаками и т. п. Для таких красок значение нейтральной плотности лучше измерить. Впрочем, иногда достаточно знать их характерные свойства:

  • Металлизированные и флексографические краски обладают очень высокой кроющей способностью. Поэтому при треппинге можно считать, что они запечатывают все краски, нанесенные ранее. Установите для этих красок нейтральную оптическую плотность выше, чем для черного цвета. Металлизированные краски всегда наносятся в последнюю очередь.
  • Оптическая плотность пастельных красок ниже, чем у их CMYK-эквивалентов.
  • Лаки следует исключить из треппинга.

Алгоритм треппинга позволяет обработать все специальные краски и особые случаи треппинга, если вы верно зададите тип краски:

  • Normal. Этот тип соответствует большинству обычных плашечных красок. Например таких, которые находятся в каталоге \PANTONE Coated, Uncoated и Process.
  • Transparent. Используется для полностью прозрачных красок (лаков) и форм для вырубки. Эти краски не подвергаются треппингу.
  • Opaque. Тип включает краски с высокой кроющей способностью, например металлизированные. Из треппинга исключаются области, запечатанные этими красками, но их края подвергаются внешнему треппингу.
  • Opaque Ignore. Аналогичен предыдущему типу, но не допускает треппинга краев объектов, заполненных кроющими красками. Используется для красок, при наложении которых на соседние происходит нежелательная химическая реакция.

Нейтральная плотность, тип краски и порядок ее нанесения также задаются в диалоговом окне Inks. Эти параметры находятся в полях Neutral Density, Type и Ink Sequence в области Current Ink для краски, выделенной в расположенном выше списке. При необходимости скорректируйте любой из этих параметров и перейдите к другой краске или закройте диалоговое окно нажатием кнопки ОК. Новые параметры вступят в силу.

На вкладке Trapping основное пространство занимает список зон треппинга. В терминах InDesign зоной называется диапазон страниц со специфическими настройками параметров треппинга. Набор параметров треппинга объединен в стиль треппинга. Благодаря стилям треппинга вам не придется устанавливать многочисленные настройки для каждой зоны. Достаточно будет создать несколько типичных стилей треппинга и назначать их зонам.

Список уже определенных стилей треппинга (рис. 19.22) открывается нажатием кнопки Styles. Кроме списка стилей Styles, в этом диалоговом окне находятся кнопки New Style, Edit Style и Remove Style. Они позволяют соответственно создавать, редактировать и удалять стили треппинга. В списке стилей всегда присутствует по крайней мере один стиль, принятый по умолчанию, — Default.

Рис. 19.22. Диалоговое окно Trapping Styles

Создание нового стиля заключается в задании параметров треппинга. Нажатие кнопки New Style открывает диалоговое окно, приведенное на рис. 19.23. В поле Name необходимо ввести имя создаваемого стиля. Старайтесь выбирать для стилей емкие имена, ведь вы будете их использовать не только для текущей публикации.

Рис. 19.23. Диалоговое окно New Trapping Style

В области Trap Width задается ширина полосы треппинга для хроматических цветов и черного цвета в полях Default и Black Width соответственно. Обычно для черного цвета ширина устанавливается в полтора-два раза больше, чем для остальных цветов. Не опасайтесь, что столь широкая полоса треппинга испортит тонкие линии в публикации. RIP автоматически отслеживает толщину линий и устанавливает ширину треппинга, не превышающую половину ширины линий.

Часто для получения глубокого черного цвета объектам присваивают не чисто черный цвет (COMOYOK100), а с добавлением остальных красок. Теоретически использование глубокого черного чревато появлением радужной каймы на границе черного объекта с выворотным или светлым объектом. И вы с этим действительно столкнетесь при выполнении треппинга вручную. Алгоритм треппинга в интерпретаторе PostScript 3 применяет для глубокого черного особый способ треппинга. Он заключается в том, что кромка объекта окрашивается в чисто черный цвет, а вся остальная его площадь остается заполненной глубоким черным (рис. 19.24). Это позволяет избежать появления радужной кромки при нарушении приводки красок. Какой цвет считается глубоким черным, задается числом, введенным в поле Black Color Limit диалогового окна New Trapping Style.

Рис. 19.24. Треппинг глубокого черного

Настройки области Trapping Threshold определяют, в каких случаях будет делаться треппинг:

  • Step Limit. Задает минимальное различие между цветами смежных красок, достаточное для того, чтобы RIP стал делать на их границе треппипг. Различие задается в процентах 0—100%. Меньшие значения соответствуют большей чувствительности алгоритма треппинга и, соответственно, приводят к большему количеству ловушек. Наилучшие результаты достигаются при значениях, лежащих в пределах 8—20%.
  • Black Color Limit. Задает минимальное количество черной компоненты в триадном цвете-, необходимое, чтобы RIP считал этот цвет черным. Для черного цвета, как сказано выше, размер полосы треппинга устанавливается большим. Поэтому до величины, введенной в это поле, для ширины полосы треппинга используется величина из поля Default, а после — из поля Black Width. Чаще всего это поле используют для компенсации рас-'тискивания точек на бумаге низкого качества. Даже для печати на газетной бумаге не стоит проставлять в поле Black Color Limit значение, меньшее 70%.
  • Black Density Limit. Задает минимальную плотность краски, необходимую для того, чтобы RIP считал ее черной. По умолчанию в этом поле установлена плотность 1,6 (94% стандартной плотности черной краски). Варьируйте этот параметр для темных плашечных цветов, чтобы к ним применялся треппинг с большей шириной (равной значению поля Black Width), чем к остальным краскам.
  • Sliding Trap Limit. Скользящая ловушка (sliding trap) предотвращает появление ступенчатости при треппинге градиентных заливок (рис. 19.25). "Ступенька" при треппинге возникает на том участке градиентной заливки, где ее нейтральная плотность сравнивается с нейтральной плотностью фона. При использовании скользящей ловушки, на указанном участке не происходит смены внешнего треппинга на внутренний и наоборот. Вместо этого полоса треппинга постепенно смещается (скользит) от положения, соответствующего одному типу треппинга, к другому.

Рис. 19.25. Обычная ловушка (а) и скользящая (б) для градиентной заливки

Число, введенное в поле Sliding Trap Limit, задает в процентах минимальное различие нейтральных оптических плотностей фона и градиента, при котором полоса треппинга начинает смещаться. 0% соответствует треппингу только по центральной линии; 100% вовсе отключает создание скользящих ловушек.

Поле Trap Color Reduction снижает плотность полосы треппинга на заданную в процентах величину. Снижение плотности полосы треппинга может потребоваться для светлых объектов, на границе которых треппинг даст сильно заметный темный контур.

Возможность треппинга с участием точечных изображений — бесценное преимущество треппинга средствами RIP перед ручным. Настройки треппинга по растру собраны в области Image Settings диалогового окна Edit Trapping Style. Список Image Trap Placement задает размещение полосы треппинга относительно границы участвующих в нем объекта InDesign и изображения:

  • Choke. Внутренний треппинг изображения. Полоса треппинга размещается на изображении.
  • Spread. Внешний треппинг изображения. Полоса треппинга размещается на объекте.
  • Center. Треппинг по средней линии. Половина полосы треппинга находится на объекте, а половина на изображении. Середина полосы треппинга находится точно на границе изображения и объекта.
  • Neutral Density. Треппинг с учетом нейтральных плотностей на границе объекта и изображения. Это тот же самый вариант треппинга, который используется для объектов InDesign. В случае изображений он может дать неудовлетворительный результат (ступенчатую кайму) из-за частой смены внутреннего и внешнего треппинга вдоль границы объектов.

При установке флажка Trap Object to Images гарантируется выполнение треппинга между точечными изображениями и объектами InDesign. Сбросьте этот флажок, если в макете объекты не перекрывают точечные изображения. Это существенно ускорит треппинг.

Средствами RIP можно выполнить и треппинг самих точечных изображений, как вы это делаете с помощью Photoshop. Он включается установкой флажка Internal Images Trapping. В большинстве случаев не стоит устанавливать этот флажок, т. к. сами изображения редко требуют треппинга. Исключения составляют только очень контрастные изображения, например рисунки.

Флажок Trap I Bit Images включает треппинг монохромных изображений. Поскольку они имеют только один цвет на всей площади, варианты размещения полосы треппинга для них не используются. Сбросьте этот флажок при печати растрированных или штриховых изображений с редкими и тонкими штрихами. Треппинг таких изображений приведет к увеличению размеров точек и затемнению всего изображения на отпечатке.

Очевидно, что для разных страниц публикации могут потребоваться разные настройки треппинга. Именно по этой причине настройки и объединены в стиль. Созданный стиль всегда можно отредактировать, нажав кнопку Edit Style в диалоговом окне Trapping Styles. При этом в списке Styles должна быть выделена строка с именем редактируемого стиля. Чтобы при создании стилей не начинать работу над каждым новым стилем "с нуля", создавайте новые стили на основе аналошчных существующих. Выберите стиль-основу в списке Styles и нажмите кнопку New Style. В диалоговом окне New Trapping Style все параметры треппинга будут автоматически выставлены такими, какие они есть в стиле-основе.

Рис. 19.26. Диалоговое окно New Trapping Zone

Когда все необходимые стили треппинга созданы, следует назначить их страницам публикации, сформировав зоны треппинга. Чтобы создать новую зону, нажмите кнопку Create на вкладке Trapping. Она открывает диалоговое окно New Trapping Zone, изображенное на рис. 19.26. Основная функция этого диалогового окна — задание диапазона страниц публикации для создаваемой зоны треппинга. Оно практически идентично вкладке Advanced Page Control диалогового окна Print, в котором выбирают страницы публикации для печати. Единственное отличие — поле Name и список Trapping Style. В поле Name задается имя зоны треппинга, а в списке Trapping Style — имя стиля треппинга, который следует использовать для выбранных страниц.

Все созданные зоны треппинга будут приведены в списке Trapping Zones на ; вкладке Trapping диалогового окна Print. Если все зоны вы снабдили знача-' щими именами, то одного взгляда на эту вкладку будет достаточно, чтобы ; проверить правильность установок треппинга для публикации.

Получив из типографии готовые оттиски, внимательно проверьте правильность треппинга. Если на какой-то из страниц вы заметили ошибку, сразу исправьте соответствующий стиль треппинга. Тогда при повторном использовании этого стиля в другой публикации вы не повторите и допущенную ошибку. Вскоре у вас обязательно составится библиотека из надежных, проверенных на практике стилей треппинга.


Предоставление макета в сервис-бюро

До сих пор мы говорили просто о передаче макета в сервис-бюро для вывода на фотонаборном автомате. На практике существенным является вопрос о том, в какой форме следует передавать макет. Для верстальщика макет — это набор файлов. Какие следует взять с собой в сервис-бюро? Можно ли подобрать их автоматически? Как проверить, все ли необходимые файлы имеются в публикации? На эти и многие другие вопросы вы найдете ответ в этом разделе.

Для начала скажем, что макет может быть предоставлен в бюро предпечатной подготовки в трех формах: в виде верстки, в виде готового для вывода PostScript-файла или в виде PDF-файла. Первый вариант предполагает передачу всех файлов InDesign, на которые разбита публикация, всех связанных файлов, шрифтов и т. п. Во втором и третьем случае передается всего лишь один, но большой файл, который работникам сервис-бюро остается только поставить в очередь печати фотонаборного автомата. Все три способа имеют свои преимущества и недостатки. Ниже мы рассмотрим их только с позиции удобств для верстальщика, но предварительно сделаем одно немаловажное замечание. Если бюджет ограничен, а полос для фотонабора много, то вы можете сэкономить средства,. если принесете в сервис-бюро готовые PostScript- или PDF-файлы. Обычно работники сервис-бюро предоставляют в этом случае весьма существенную (до 30%) скидку.


Передача верстки в сервис-бюро

Передавая в сервис-бюро верстку, вы несете ответственность только за нее. Все настройки фотонаборного автомата работники сервис-бюро выполняют сами, что гарантирует их правильность. Это является основным и существенным преимуществом такого способа предоставления макета. При выполнении в сервис-бюро дополнительной предпечатной подготовки (треппинг, создание спускового макета) верстка обеспечивает ему дополнительную свободу и является предпочтительной формой. На вашей совести остается только сборка и проверка всех внешних файлов макета для передачи. Работа по сборке может быть упрощена и автоматизирована использованием команды Package меню File.


Какие файлы требуются для печати в сервис-бюро

При передаче верстки в сервис-бюро необходимо предоставить все файлы, требующиеся для удаленной печати:

  • Файл публикации.
  • Связанные внешние файлы, не хранящиеся внутри публикации. Во избежание путаницы мы вообще рекомендуем не хранить файлы внутри публикации, или, по крайней мере, подходить к этому единообразно: либо все не хранить, либо, напротив — хранить все. О связывании файлов и о том, как изменить место хранения для всех файлов публикации одновременно, написано в главе 13.
  • Использованные шрифты.

Все эти компоненты являются необходимым условием правильного вывода пленок. Если вы забудете что-либо из этого списка, то практически наверняка получите испорченные пленки, за которые сервис-бюро не будет нести никакой ответственности.

Не менее важным условием правильной печати публикации является актуальность связей с внешними файлами. Выполнение всех перечисленных требований упрощается, если воспользоваться командами Package и Preflight меню File. Первая из них автоматически собирает все файлы, необходимые для предоставления верстки, а вторая проверяет публикацию на типичные ошибки. Они применяются в паре; одна из команд может автоматически или по вашему желанию запустить другую.


Проверка публикации

Проверка большой публикации с множеством связанных файлов может оказаться сложной и кропотливой. К счастью, InDesign имеет встроенное средство проверки, позволяющее исключить грубые ошибки. Речь идет о команде Preflight меню File.

Выбор этой команды меню запускает программу проверки публикации на предмет связанных файлов и использованных шрифтов. После некоторого "размышления", продолжительность которого зависит от длины и сложности публикации, InDesign откроет диалоговое окно (рис. 19.27), содержащее результаты проверки. Диалоговое окно Preflight организовано типичным для InDesign образом: оно содержит пять разделов, переключающихся выбором в списке в верхней части окна или кнопками Next и Prev. Разделы диалогового окна содержат следующую информацию:

  • Summary. Краткий отчет о проблемах, обнаруженных программой проверки: отсутствующих шрифтах, нарушенных и устаревших связях, количестве и типе использованных красок.
  • Fonts. Список использованных шрифтов с указанием отсутствующих, внедренных и включенных в публикацию частично.
  • Links and Images. Список внешних файлов публикации с указанием состояния связей.
  • Colors and Inks. Список использованных красок и параметров их растрирования.
  • Print Settings. Полный набор установок печати.

Рис. 19.27. Диалоговое окно Preflight

Рассмотрим разделы этого диалогового окна подробнее.

Раздел Fonts (рис. 19.28) открывает список использованных в публикации шрифтов. Если какой-либо шрифт недоступен, то в графе Status появляется слово Missing. В этом случае следует открыть Adobe Type Manager или папку шрифтов Windows и установить эти шрифты. При повторной проверке публикации в графе Status должно появиться ОК. В графе Type содержится информация о типе использованного шрифта. Это облегчает его поиск или напоминает, что в публикации использованы шрифты разных типов. О предпочтительности использования шрифтов Type Г рассказано в главе 6. Может оказаться полезной и информация о странице, на которой обнаружен неустановленный шрифт. Она отображается в информационной области Current Font, содержащей подробности относительно шрифта, выделенною в списке, находящемся выше. Скорее всего, это погрешность верстки, и ее необходимо устранить, изменив гарнитуру, которой отформатирован фрагмент текста.

Рис. 19.28. Диалоговое окно Preflight, раздел Fonts

Рис. 19.29. Диалоговое окно Preflight, раздел Links and Images

Раздел Links and Images (рис. 19.29) содержит список всех связанных файлов публикации (наподобие палитры Links), об актуальности связи, типе файла и первом его местонахождении в публикации. Опираясь на эту информацию, легко идентифицировать утраченные и необновленные связи. Отметка Missing в графе Status говорит о том, что соответствующий файл отсутствует и его надо отыскать. Метка Out of Date в графе Status говорит о том, что элемент требует обновления связи. Обе ошибки могут быть исправлены нажатием кнопки в области Current Link/Image. Если связь, выделенная в списке, нуждается в обновлении, то она будет обновлена, а если разорвана, то откроется стандартный файловый диалог Windows, который позволит указать новое местоположение файла. Для устаревших связей кнопка называется Update. Если в списке выделена разорванная связь, то имя кнопки меняется на Relink. Чтобы исправить все имеющиеся проблемы со связями, не выделяя их по одной, нажмите кнопку Repair All.

Весьма полезно наличие в списке связанных файлов наличие графы ICC Profile. Она позволит вам быстро отыскать изображения, для которых неверно заданы установки управления цветом (см. главу 5).

Оба упомянутых раздела содержат флажок Show Problems Only, который предотвращает вывод избыточной во время проверки информации об элементах, с которыми все в порядке.

Раздел Print Settings (рис. 19.30) содержит перечень всех установок, сделанных в диалогах команды Print. Будучи собранными вместе, они значительно легче контролируются.

Рис. 19.30. Диалоговое окно Pref light, раздел Print Settings

Столь же легкими для восприятия делает установки цветоделения и растрирования раздел Colors and Inks (рис. 19.31). Одним взглядом вы можете проверить публикацию на использование лишних плашечньгх цветов и совпадающих параметров растрироьания.

Рис. 19.31. Диалоговое окно Preflight, раздел Colors and Inks

Вся информация, отображаемая в диалоговом окне Preflight, может быть сохранена в текстовом файле в виде отчета кнопкой Report. Этот текстовый файл можно приложить к публикации при предоставлении ее в сервис-бюро. Впрочем, если вы предоставляете в сервис-бюро верстку и пользуетесь командой Package, то делать это не нужно: данная команда сама создаст файл отчета.


Сборка файлов публикации

После того как публикация еще раз проверена и ошибки не обнаружены, самое время "собрать в кучку" все файлы публикации для передачи в сервис-бюро. Для этих целей служит диалог, открываемый кнопкой Package в диалоговом окне Preflight или отдельной командой меню File (рис. 19.32, а). Он позволяет записать в отдельную папку все файлы, требующиеся для печати (пакет). Установив флажок Copy Fonts, вы даете указание скопировать в эту папку все шрифты, использующиеся в публикации. Флажок Update Graphic Links полезен при сохранении публикации, уже проверенной в прошлом сеансе работы. Если установлен флажок Copy Linked Graphics, в пакет автоматически помещаются все связанные внешние файлы.

а

б

Рис. 19.32. Диалоговые окна команд Package Publication (а) и Printing Instructions (б)

Также в пакет может быть помещен файл отчета в текстовом формате Кнопка Instructions открывает диалог Printing Instructions (рис. 19.32, б), позволяющий ввести в отчет дополнительную информацию о требованиях к выводу макета: установках ориентации эмульсии и негативного/позитивного отпечатков, ориентации бумаги и типе носителя (пленка/бумага/заказнои тип), заказчике работ.

Нажатие кнопки Package запускает формирование и сохранение пакета. Если был установлен флажок View Report в окне на рис. 19.32, а, то по завершении этого будет открыт файл отчета для распечатки или редактирования. Флажок Include Fonts and Links from Hidden Layers заставляет In Design учитывать и те элементы публикации, которые находятся на скрытых слоях многослойной публикации (см. главу 15).


Вывод PostScript-файла без дополнительной обработки в сервис-бюро

При печати на PostScript-принтер, его драйвер формирует описание страниц публикации на этом языке и посылает в принтер. Операционная система и InDesign позволяют перенаправить данную информацию в файл, вместо принтера. Впоследствии можно в любой момент послать такой файл на принтер, и он напечатает требуемые страницы публикации.

При непосредственной печати на подключенный к вашему компьютеру принтер, эта промежуточная операция не имеет смысла. Важной она становится при печати по сети на удаленном принтере (по сети передается уже готовый файл печати) или при передаче публикации в сервис-бюро. Поскольку на принтер посылается вся информация о страницах публикации (в том числе настройки текста, изображения, шрифты), в файле также оказывается вся информация для последующей печати. Следовательно, достаточно создать такой файл печати, и послать его на фотонаборный автомат, чтобы получить готовые пленки для печати в типографии.

Если вы намерены передавать в сервис-бюро файл печати, то берете на себя некоторую часть их работы. Вам придется сделать все установки режимов печати на фотонаборном автомате, не имея опыта работы с ним. Но не стоит пугаться. Последовав приведенному ниже рецепту, вы обязательно сможете создать файл печати и даже частично удостовериться в его правильности.

  1. Проверьте публикацию на наличие грубых ошибок командой Preflight. Если вы используете систему управления цветом, проверьте ее установки и профили каждого графического файла. Исправьте найденные ошибки.
  2. Установите драйвер фотонаборного автомата. Необходимо учитывать, что как и принтеры, фотонаборные автоматы обладают различными особенностями, которые необходимо учитывать при создании файла печати. Информация о них находится в PPD-файле описания PostScript-принтера. Следовательно, вам предварительно необходимо связаться с сервис-бюро и получить у них этот файл, поставляемый производителями фотонаборного автомата. Затем с помощью программы установки драйверов Adobe PostScript, находящейся на компакт-диске InDesign, установите драйвер этого автомата, указав ей на полученный PPD-файл. При печати из InDesign, в поле Printer обязательно должен быть указан драйвер фотонаборного автомата.
  3. Установите флажок Print to file.
  4. Откройте диалоговое окно драйвера принтера и проделайте в нем следующие настройки. Проставьте ту же ориентацию страницы, что и в публикации. Если вы выводили корректуру разворотами, а фотонабор — отдельными страницами, то потребуется изменить ориентацию страницы . InDesign не сделает этого автоматически.
  5. В диалоговом окне драйвера отключите масштабирование и разбиение. Эти установки могут оказаться включенными, если они использовались при выводе корректуры на принтере. Вывод на фотонабор, разумеется, производится в натуральную величину и в поле Scale должно находиться значение 100%.
  6. Установите формат "бумаги". Фотонаборные автоматы поддерживают произвольный формат в пределах максимальной ширины пленки, а также набор предопределенных значений, используемых наиболее часто. Устанавливая формат бумаги, не забывайте о дополнительном пространстве, занимаемом типографскими метками. Формат должен быть достаточно большим, чтобы вместить страницу с метками. На каждый фиксированный формат бумаги драйвер фотонаборного автомата имеет соответствующий формат Extra, позволяющий разместить за пределами страницы типографские метки. Если публикация сверстана не на стандартный формат, выберите из списка форматов вариант Custom.
  7. Задайте параметры вывода компонентов. Значения параметров Print as a mirror image и Print as a negative image определяются как требованиями типографии, так и правилами сервис-бюро. Очень часто эти параметры задаются работниками сервис-бюро, исходя из переданной им спецификации. От вас требуется прямое (флажок Print as a mirror image сброшен) и позитивное (флажок Print as a mirror image сброшен) изображение. В противном случае, установите эти флажки, учитывая требования типографии. Чаще всего для изготовления офсетных форм используются зеркальные позитивные пленки.
  8. Установите в свойствах принтера на вкладке Device Options значения по умолчанию. Внимательно ознакомьтесь со специальными свойствами фотонаборного автомата, на котором будете осуществлять цветоделение. Если какое-либо свойство, указанное в этом диалоге, имеет установку тип! "параметры принтера по умолчанию", то выберите именно этот вариант. Это позволит работникам сервис-бюро проставить конкретные значения этих настроек при выводе. Если в списке не предлагается такого варианта, то обязательно проконсультируйтесь в сервис-бюро относительно его значения. При установке неверного значения RIP не сможет перекрыть своими настройками сделанных вами установок. В результате плен могут быть либо испорчены, либо вообще не выведены.
  9. Вернитесь в диалоговое окно Print. На вкладке Advanced Page Control определите, какую часть публикации необходимо вывести на фотонаборный автомат. Часто на фотонаборный автомат выводится не вся публикация, а лишь несколько ее страниц. Определите номера этих страниц и введите их в поле Ranges диалога Print или выберите отдельные разделы в списке By Section. В поле Copies введите 1. Из списка Options выберите вариант Both Pages.
  10. Проверьте, сброшен ли флажок Reader's Spreads. Он включается только для вывода корректуры, а при выводе оригинал-макета не используется. Если публикация требует фальцовки и сшивки, то на страницах разворота будут находиться не соседние страницы спускового макета, и их придется все равно разрезать при монтаже.
  11. На вкладке Page Marks включите печать типографских меток. Для приводки форм и обрезки отпечатков на пленках обязательно должны быть приводные и обрезные метки ("кресты" и "мишени"). Работники типографии ориентируются также на шкалы с градациями цветов и серого. По шкалам можно судить о правильности установок подачи краски, равномерности протяжки бумаги, величине растискивания и проч. Все эти типографские метки автоматически выводятся на лист при включенном переключателе All Printer's Marks. Типографские метки помещаются вне площади страниц и требуют дополнительного пространства при выводе.
  12. Установите печать служебной информации флажком Page Information. Служебная информация необходима печатнику для идентификации форм. Она содержит имена компонентов или плашечных цветов и параметры растрирования. Не лишней она будет и для вас, т. к. включает имя файла публикации и номер выводимой страницы. Это облегчит проверку выведенных пленок. Отсутствие служебной информации в худшем случае может привести к порче тиряжя
  13. Если в публикации имеются объекты, печатаемые навыпуск, установите достаточный размер выпуска в поле Bleed. Как правило, он составляет 14—20 пт (5—7 мм), но может оказаться большим. Согласуйте величину выпуска с типографией. Сбросьте флажок Bleed Marks.
  14. На вкладке Scale and Fit установите печать без разбивки в списке Tiling. Установите флажок Constrain Proportions. Отключите масштабирование, переведите переключатель Scale в положение Х and Y и установите в полях Width и Height масштаб 100%. Посмотрев в область предварительного просмотра, убедитесь, что страница публикации вместе с типографскими метками помещается на выбранный формат целиком и не остается больших полей. Величина полей приводится в информационном поле L, R, Т, В ниже области просмотра. Если требуется, измените формат бумаги в диалоговом окне драйвера принтера.
  15. Выводите графику без оптимизации. На вкладке Graphics в списке Send Image Data выберите вариант All. Сбросьте флажок Proof Print. Если в сервис-бюро нет файлов с высоким разрешением для печатаемой публикации, установите флажок OPI/DCS Image Replacement. При использовании технологии OPI сбросьте этот флажок и флажок EPS в области Omit, а флажок Bitmap Images установите.
  16. Включите загрузку шрифтов, переведя переключатель Font Downloading в положение Subset. Установите флажок Download PPD Fonts.
  17. Сбросьте флажки в области Gradient Options.
  18. Если цветоделение публикации будет выполняться в сервис-бюро, то на вкладке Color установите переключатель в положение Composite. В этом случае все параметры цветоделения будут устанавливаться оператором фотонаборного автомата. Если вы хотите самостоятельно задать параметры цветоделения, то переведите переключатель в положение Separation и установите флажок In-RIP. Установка этого флажка предпочтительнее, чем установка переключателя в положение Composite, т. к. в последнем случае выбирать компоненты для цветоделения будут работники сервис-бюро, и вам придется документировать и передавать им эту информацию. Особенно нежелательны в этом случае избыточные определения цветов в публикации, которые могут внести путаницу при выборе компонентов цветоделения.
  19. Если вы задаете параметры цветоделения самостоятельно (переключатель находится в положении Separation), выберите краски, выводимые на отдельных формах. В списке Inks выберите цвета, по которым будет осуществляться цветоделение. Заблаговременно удалите из публикации все избыточные определения цветов. Если в публикации определены плашечные цвета, которые не выводятся на отдельных формах, преобразуйте их в триадные нажатием кнопки All to Process, но помните о погрешностях подобного преобразования. В идеале на момент печати список цветов должен содержать только названия цветов, предназначенных для вывода на отдельные формы.
  20. Определите параметры растрирования компонентов. В поле Screening выберите требуемое соотношение линиатура/разрешение печати. Значение линиатуры зависит от способа печати и сорта применяемой бумаги Разрешение печати должно в 16 раз превосходить линиатуру. Это обеспечит передачу всех имеющихся в изображении оттенков.
  21. Углы растрирования при печати триадными красками изменять не стой: без особого требования со стороны типографии. При печати плашечными цветами значения углов следует установить, проконсультировавшие: в типографии.
  22. Проверьте правильность определения зон треппинга на вкладке Trapping
  23. Нажмите кнопку ОК и сохраните файл печати на диске. Перед печатью убедитесь в наличии достаточного свободного места на диске. PostScript-файл в кодировке ASCII занимает очень много дискового пространства. Чтобы очень приблизительно оценить, сколько места потребуется, умножьте суммарный размер всех файлов публикации на четыре. Впрочем, если вы не располагаете носителем такого размера для переноски файла печати в сервис-бюро, воспользуйтесь любым архиватором для его сжатия. В сжатом виде файл печати займет примерно столько же места, сколько и верстка.
  24. Для визуального просмотра содержимого файла печати и проверки правильности установок обработайте его программой Adobe Acrobat Distiller. В результате будет создан PDF-файл, который может быть просмотрен программой Adobe Acrobat Reader. В нем вы увидите содержимое "черного ящика". О программах пакета Adobe Acrobat рассказано в главе 17. Заметим лишь, что отказ программы Acrobat Distiller интерпретировать файл печати является грозным предупреждением о проблемах, которые могут возникнуть при выводе публикации на фотонаборном автомате. Используйте Adobe Acrobat как простое диагностическое средство правильности файла печати. По его сообщениям об ошибках часто можно идентифицировать объект, создающий трудности при выводе.

Проблемы с выводом оригинал-макета на фотонаборном автомате могут возникнуть не только в результате неверных установок, сделанных вами при создании файла печати. Их возникновение столь же вероятно из-за погрешностей самого макета. Зачастую дают о себе знать и ошибки в самих программах верстки и подготовки изображений и иллюстраций. Напоминает о себе и проблема их совместимости. Подобные ошибки очень сложно идентифицировать и устранить. Приведенные в следующем разделе советы помогут вам избежать наиболее распространенных ошибок верстки, затрудняющих или делающих невозможным успешный вывод пленок на фотонаборном автомате.


Вывод PostScript-файла для треппинга и спуска полос

Этот режим используется также при подготовке исходных данных для специализированных программ предпечатной обработки, работающих с PostScript-файлами. Это могут быть программы цветоделения, обладающие более широкими, чем InDesign, возможностями, или программы спуска полос, формирующие из страниц публикации спусковой макет. Необходимость предпечатной обработки определяется сотрудниками сервисного бюро.

PostScript-файл, подходящий для обработки, не должен содержать никаких зависимостей от аппаратуры конкретного фотонаборного автомата. Поэтому для создания таких файлов используется не драйвер принтера, а особый фильтр экспорта InDesign.

Чтобы создать PostScript-файл для последующей обработки, выполните команду Export меню File. В открывшемся диалоговом окне Export выберите формат Prepress File и нажмите кнопку Save. InDesign откроет диалоговое окно с настройками фильтра Export Prepress File (рис. 19.33).

Рис. 19.33. Диалоговое окно Export Prepress File, раздел Prepress Options

Диалоговое окно устроено привычным образом. Оно содержит два раздела. между которыми можно переходить, выбирая требуемый из списка в верхней части окна, или с помощью кнопок Next и Previous. Настройки экспорта похожи на настройки печати, которые подробно обсуждались выше.

  1. В разделе Pages and Page Marks находятся элементы управления, похожие на те, что вы видели на вкладках Advanced page Control и Page Marks

    2. диалогового окна Print; Установите диапазон страниц публикации, экспортируемый в PostScript-файл, введите величину выпуска и проставьте флажки для требуемых типографских меток. О том, как это сделать, рассказано выше при обсуждении диалогового окна Print.

  2. В разделе Prepress Options установите кодировку PostScript-файла. Д; обеспечения совместимости предпочтительнее кодировка ASCII, хотя В: nary и обеспечивает большую компактность файлов. Если вы не уверен в том, что сервис-бюро сможет обработать двоичные файлы, выбирайте вариант ASCII.
  3. В списке PostScript выберите ту версию языка, которая будет использована для окончательного вывода.
  4. В списке Embed Fonts выберите вариант Complete.
  5. В списке Color выберите цветовую модель для всех цветов в публикации. Если в документе включено управление цветом, то преобразование цветовых моделей выполняется с использованием установленных цветовых профилей (см. главу 5).
  6. Выбор в области Imported Graphics зависит от того, используете ли вы технологию OPI. Если технология OPI не используется, то в списке Images выберите вариант High resolution и установите флажок Perform OPI Replacement. В противном случае поступите наоборот, а в области Omit установите флажок Bitmap Images и сбросьте флажок EPS.
  7. После нажатия кнопки Export публикация сохранится в заданном ранее файле. Этот файл готов для передачи в сервис-бюро.


Создание PDF-файлов для печати

В последнее время, с распространением растровых процессоров на базе PostScript 3, все шире применяется предоставление файлов печати в формате PDF. Формат PDF не столь аппаратно-зависим, как PostScript в файлах печати, позволяет просмотреть выводимый документ на экране, провести несложное редактирование непосредственно перед выводом. Он также позволяет использовать для окончательной обработки публикации (треппинг, спуск полос, цветоделение, и т. п.) специализированные программы и подключаемые модули к Adobe Acrobat.

Фильтр экспорта d формат PDF уже рассматривался нами в главе 17 в контексте подготовки публикации для просмотра на экране. Поэтому ниже мы приведем только настройки фильтра экспорта, необходимые для создания PDF-файла, ориентированного на типографскую печать. На рисунках, приведенных ниже, все настройки сделаны исходя из этой задачи.

  1. В разделе Pages and Page Marks выберите диапазон страниц или разделы публикации, предназначенные для вывода. Выбор осуществляется точно так же, как и при печати или экспорте PostScript-файлов для последующей обработки. Если какие-либо элементы макета должны печататься навыпуск, .задайте его величину в поле Bleed. Чтобы типографские метки не оказались наложенными на эти элементы, задайте в поле Offset значение отступа, превышающее величину выпуска в поле Bleed. Установите флажки для тех типографских меток, которые потребуются при выводе.
  2. Не устанавливайте защиту в разделе Security. Вам все равно не удастся скрыть содержание публикации от сотрудников сервис-бюро.
  3. В разделе PDF Options (рис. 19.34) установите в поле Subset Fonts Below 100%. Это сделает возможным финальное редактирование файла.

    4. Рис. 19.34. Диалоговое окно Export PDF, раздел PDF Options

  4. В списке Color выберите вариант Leave Unchanged. Если вы используете систему управления цветом, то установите флажок Include ICC Profiles.
  5. Установите флажок Crop Image Data to Frames. Это позволит сэкономить на размере обрабатываемого файла и сократит время печати, поскольку выводиться будут кадрированные изображения.
  6. Выбор в области Imported Graphics зависит от того, используете ли вы технологию OPI. Если технология OPI не используется, то в списке Images выберите вариант High Resolution и установите флажок Perform OPI Replacement. В противном случае поступите наоборот, а в области Omit установите флажок Bitmap Images и сбросьте флажок EPS.
  7. Установите флажки Generate Thumbnails и Optimize PDF.
  8. В разделе Compression (рис. 19.35) задайте для цветных и полутоновых , изображений в соответствующих списках алгоритм пересчета разрешения Downsaniple to и разрешение, в два раза превышающее предполагаемую линиатуру печати. Для монохромных изображений установите разрешение 800—900 dpi.
  9. Установите алгоритм сжатия LZW для цветных и полутоновых изображении, а для монохромных — ССГГГ Group 4.
  10. Установите флажок Compress Text and Line Art.

Рис. 19.35. Диалоговое окно Export PDF, раздел Compression


Профилактика неполадок на этапе вывода макета

Этап вывода публикации на фотонаборном автомате тоже таит в себе множество подводных камней. Вам наверняка случалось наблюдать странности в поведении своего PostScript-принтера. Если вы были при этом достаточно настойчивы, чтобы выяснить причину его "безобразного поведения", то легко представите себе, какие сложные проблемы могут возникнуть при печати на таком "супер-принтере", как фотонаборная машина.

К сожалению, для неудачи при выводе макета существует неисчислимое множество причин, в то время как для успеха только одна — хорошая верстка, учитывающая особенности работы PostScript-интерпретаторов и использованных программ. Ниже приведем несколько достаточно общих рекомендаций, позволяющих избежать проблем на стадии вывода оригинал-макета.


Пользуйтесь советами специалистов

Большинство сервисных бюро и типографий выпускают всевозможные памятки и инструкции для своих заказчиков. Очень важно точно следовать им. В них, как правило, указаны программы, которые рекомендуется использовать для верстки и подготовки иллюстраций. Приводятся и настройки фотонаборного автомата, которые придется проставлять вам, если вы предоставляете готовый файл печати.


Устраните избыточную сложность выходного файла

По мере работы над макетом вы выполняете массу действий, многие из которых носят сугубо экспериментальный характер. В результате получается перегруженный всевозможными преобразованиями файл, который замечательно смотрится на экране монитора, но выводится на печать крайне медленно или вовсе не печатается. Причина — те скрытые "мины замедленного действия", которые накопились в файле публикации и взрываются в процессе печати, приводя в бесчувственное состояние фотонаборный автомат или ваш собственный лазерный принтер. Публикацию следует "отшлифовать". Просмотрите весь макет и устраните потенциально опасные ситуации, которые вполне могут сорвать сроки завершения работы над публикацией.

Вот основные причины возникновения избыточной сложности выходного файла.

Когда вы работаете с графическим изображением средствами программы InDesign, само изображение при этом не меняется. Программа InDesign импортирует изображение не повернутым, без изменения масштаба и размеров, без кадрирования и без наклона — все эти преобразования применяются лишь к экранной версии графики. Само же исходное изображение при этом остается неизменным. Во время вывода InDesign пересылает в принтер не только исходное изображение, но и составленные в процессе верстки инструкции по его преобразованию, закодированные на языке PostScript, который интерпретируется фотонаборным автоматом или лазерным принтером. При этом в памяти устройства вывода должны поместиться и изображение, и инструкции по его преобразованию. Процедура преобразования может продолжаться довольно долго и израсходовать все доступные ресурсы устройства вывода, приводя к аварийному завершению печати. В лучшем случае файлы, содержащие в себе преобразованные графические изображения, просто медленнее печатаются.

Перед передачей файла PostScript в сервисное бюро рекомендуется вывести его на печать на собственном лазерном принтере. Если принтер не справляется с поставленной задачей, есть веские основания задуматься о возможностях упрощения файла. Конечно, встроенный в фотонаборный автомат компьютер намного мощнее встроенного компьютера лазерного принтера, но из этого вовсе не следует, что он обязательно справится с файлом, которым "захлебнулся" лазерный принтер — ведь ему приходится выполнять намного больше вычислений. Объем вычислений, которые необходимо выполнить для вывода на печать страницы с разрешением 2400 dpi, на несколько порядков больше, чем при выводе той же страницы с разрешением лазерного принтера — 300 dpi- Процессор фотонаборного автомата намного больше загружен, чем его коллега в лазерном принтере, и его работа — намного сложнее.

Кроме того, необходимо проверить все определения цветов и добиться их единообразия в рамках публикации. Если вы печатаете издание в два цвета, в палитре цветов должно быть ровно два определения (лишние можно удалить при помощи команды Select All Unused. Более подробно эта процедура описана в главе 4.


Выполняйте масштабирование и кадрирование графических изображений до их размещения в публикации

По мере возможности выполняйте изменение размеров и кадрирование изображений до их импортирования в публикацию программы InDesign. Если вам необходимо уменьшить размер отсканированной фотографии, сделайте это до импортирования ее в публикацию. Проверьте разрешение всех импортированных изображений и пересчитайте те, в которых оно слишком велико. Не забывайте о том, что разрешение при сканировании не должно превышать линиатуру растра печати более чем в 2 раза, а многие специалисты считают, что вполне достаточно и 1,5.


Постарайтесь обойтись без белых прямоугольников

Казалось бы — вполне естественный прием: если вам не нужна какая-либо часть изображения, просто постройте поверх нее прямоугольник и назначьте его фону белый цвет. Но опять приходится вспомнить о том, что устройство, интерпретирующее язык PostScript, "вычисляет" изображение, перемещаясь от нижних слоев к верхним. Несмотря на то, что вам не видно, что скрыто за белым прямоугольником, фотонаборный автомат или лазерный принтер обрабатывают все слои изображения и выполняют все необходимые вычисления — пусть даже при обработке следующего слоя только что построенное изображение будет целиком закрыто.

Ситуаций, в которых без белого прямоугольника не обойтись, не бывает. Неопытные верстальщики часто пользуются этим приемом для маскировки нежелательных элементов, перенесенных на страницу со страницы-шаблона.

Правильным решением этой задачи будет либо создание дополнительной шаблон-страницы, где нежелательные элементы отсутствуют, либо просто удаление их на отдельных страницах публикации.


Сложные графические изображения могут вызвать аварийное завершение вывода на печать

Многократное вложение графических файлов EPS друг в друга — верный способ увеличить нагрузку на лазерный принтер или фотонаборный автомат. По мере возможности такой ситуации следует избегать.

Размещая на одной странице десяток цветовых растяжек, вы определенно напрашиваетесь на неприятности при выводе макета.

Если причиной аварийного завершения вывода на печать оказывается графическое изображение, откройте его в сеансе графического приложения, с помощью которого оно было создано, и попробуйте упростить кривые и маски. В графическом приложении можно уменьшить количество узлов кривой или повысить степень ее плавности — это приведет к снижению сложности графического элемента. Adobe Illustrator даже выдает предупреждение, если объект, получившийся в результате какой-либо операции, имеет слишком большое количество узлов и может вызвать проблемы при выводе. Не пренебрегайте этим предупреждением. Пользуйтесь соответствующими функциями упрощения объектов после трассирования в программе Adobe Streamline.


Маскирование может вызывать затруднения при выводе

При использовании в импортированном изображении маскирования лазерному принтеру или фотонаборному автомату приходится вначале обрабатывать все изображение, а затем выполнять обрезку. Это достаточно продолжительный процесс, и он требует выполнения множества вычислений, что может привести к аварийному завершению вывода на печать. Из этого не следует. что подобным приемом нельзя пользоваться ни при каких обстоятельствах — просто необходимо рассматривать и возможные альтернативы для достижения того же эффекта, или варианты упрощения эффекта. В любом случае перед передачей файла PostScript с контурами обтравки в сервисное бюро следует проверить надежность его вывода на лазерный принтер.

Кстати, в отличие от других программ, InDesign умеет обрезать маскированные части изображения при выводе, сокращая время печати и снижая нагрузку на RIP.


Избегайте вложения текстов в файлы EPS

Одна из форм вложения EPS-файлов — вставка в них текстов. Иногда при выводе на печать принтер или фотонаборный автомат не могут распознать гарнитуру текста лишь потому, что он вложен в файл формата EPS, и текст выводится в выбираемой по умолчанию моноширинной гарнитуре Courier.

Конечно, избежать вложения текста в файл формата EPS удается не всегда, В таких случаях следует преобразовывать текст в совокупность кривых, после чего он рассматривается как графический объект. Такое преобразование целесообразно по двум причинам. Во-первых, отпадает проблема с отсутствием в сервис-бюро использованной вами редкой гарнитуры. Поскольку символы текста стали частью изображения, они перестали зависеть от описания гарнитуры. Во-вторых, все преобразования, которые вы выполняете над изображением и входящим в его состав текстом, выполняются заранее, упрощая вычисления в процессе вывода на печать. Правда, когда объем преобразованного текста велик, это преимущество утрачивается. Поэтому большой объем текста малого кегля (например, 12 пунктов) преобразовывать нецелесообразно, а заголовки крупным кеглем — можно и нужно.

Применение преобразования текста в кривые может дать эффект, прямо противоположный желаемому. Такое наблюдается при преобразовании в кривые большого объема текста или текста мелкого кегля. Дело в том, что подобное преобразование может несколько увеличивать толщину штрихов символов и искажать межсимвольные интервалы. Кроме того, преобразование в кривые целой страницы текста — надежный способ повысить сложность страницы до уровня, неприемлемого для любого принтера и фотонаборного автомата.

Если это не противоречит вашему замыслу, размещайте текст поверх графического изображения, объединяя его с ним в группу.


Поворачивайте изображения до импортирования в публикацию

В InDesign имеются мощные инструменты для поворота текстов и графических объектов, но все-таки, если эти операции выполнять вне InDesign, сложность выходного файла существенно снижается- Если в публикации задан поворот графического изображения, то на принтер или фотонаборный автомат оно передается не в развернутом, а в исходном положении. Устройство вывода самостоятельно пересчитывает местоположение всех точек изображения при обработке страницы во встроенном компьютере. Как упоминалось выше, фактически, поворот приходится выполнять два раза — так устроена технология PostScript. Особенно заметна разница во времени вывода для изображений в формате TIFF. Если изображение очень большое, необходимость его поворота в процессе печати может привести к аварийному завершению этого процесса. Постарайтесь выполнять повороты изображении в формате TIFF при помощи графических приложений, предназначенных для работы с точечными изображениями (например, Adobe Photoshop). Это касается также и файлов в формате EPS с вложенными изображениями в формате TIFF.


При выводе на фотонаборный автомат избегайте использования гарнитур TrueType и объектов в формате WMF

И то и другое — чужеродные объекты для технологии PostScript. В издательствах наблюдается постепенный рост применения гарнитур TrueType, но в большинстве сервисных бюро ими практически не пользуются.


Рассчитывайте количество переходов в цветовых растяжках

Создавая цветовую растяжку, вы предполагаете, что на отпечатке будет сделан плавный переход от начального полутона серого (или хроматического цвета) к конечному. Но из-за того, что переход полутонов реализуется механическими средствами, вместо плавного перехода получается ступенчатый. Это может быть практически не заметно, но может и сильно бросаться в глаза. Степень ступенчатости зависит от линиатуры используемого растра, разрешения лазерного принтера или фотонаборного автомата, различия начального и конечного значения растяжки и длины растяжки. Вполне возможно такое сочетание значений этих параметров, при котором количество переходов тона будет явно недостаточным.

Рис. 19.36. Зависимость "полосатости" цветовой растяжки от линиатуры растра и разрешения печатающего устройства

В этом случае каждый из переходов становится отчетливо отличим от соседних, как показано на рис. 19.36 — появляется "полосатость". На рисунке начальное и конечное значения цветовой растяжки одинаково. Рис. 19.36, а отпечатан с разрешением 600dpi, а рис. 19.36, б— 300dpi с одинаковой линиатурой (75 Ipi). При уменьшении разрешения растр той же линиатуры способен передать меньше оттенков серого. Поэтому во втором случае "полосатость" растяжки больше. Увеличивается она и при повышении ли-ниатуры, о чем свидетельствует сравнение рис. 19.36, б и 19.36, в. Оба напечатаны с одинаковым разрешением (300 dpi), но с разной линиатурой растра — 75 и 120 Ipi соответственно.

К счастью, теперь большинство графических приложений автоматически рассчитывают необходимое количество переходов, поэтому "полосатость" растяжек стала менее распространенным дефектом. Однако понимание механизма образования цветовых растяжек поможет вам полностью избежать этого нежелательного эффекта.

Следует иметь в виду, что "полосатость", проявляющаяся на цветовых растяжках в контрольных отпечатках, полученных на лазерном принтере, может пропасть при выводе на фотонаборный автомат с высоким разрешением. С другой стороны, если окончательный оригинал-макет выпускается на лазерном принтере с разрешением 300 или 600 dpi, забывать о возможности возникновения "полосатости" нельзя.

"Полосатость" возникает, если количество оттенков передаваемых устройством вывода ограничено. В этом случае растяжка представляет собой набор полос, каждая из которых соответствует следующей промежуточной градации. Если длина растяжки такова, что полосы, соответствующие градациям, имеют заметную ширину, то гладкой растяжки не получается и полосы становятся заметны. Особенно явно видны полосы на растяжках при печати на лазерном принтере. В разделе "Теория. Растрирование" данной главы мы рассчитывали количество оттенков, передаваемых растром в 85 Ipi на 600-точечном лазерном принтере. Оно составляет 50 оттенков. Если страница содержит растяжку от черного к белому длиной 200 мм, то на один передаваемый растром оттенок приходится 200/50 == 4 мм. Таким образом, растяжка будет напечатана не в виде плавного перехода, а в виде пятидесяти четырехмилли метровых полос. При выводе этой же страницы на фотонаборном автомате с разрешением 2400 dpi количество оттенков, передаваемых растром 85 Ipi, составит (2400/85)2 + 1 = 798. На один оттенок в этом случае придется 200/798 = 0,25 мм. Полосы такой толщины близкого оттенка не будут заметны и растяжка будет производить впечатление плавной.

В общем случае количество градаций в растяжке определяется по формуле:

N = (dpi/lpi)^2*(D2-D1)

где dpi — разрешение устройства вывода; Ipi — линиатура печати; D2 — конечное значение плотности растяжки, выраженное в долях; D1 — начальное значение оптической плотности.

Первый множитель представляет собой количество оттенков, передаваемое растром, а второй — доля использованных в растяжке градаций цвета от общего их количества.

Важным шагом в борьбе с описанным дефектом стала новая версия интерпретатора PostScript 3. Она позволяет использовать до 4000 оттенков одного цвета, практически сводя к нулю проявления полос на отпечатках.


Резюме

  • С точки зрения возможностей управления печатью, устройства печати делятся на PostScript и не-PostScript. Только язык PostScript обеспечивает профессиональное качество и широкие возможности печати. Все фотонаборные автоматы являются PostScript-принтерами. Для офисных приложений наличие PostScript излишне.
  • Оттенки цвета при печати на цифровые устройства передаются за счет растрирования. Мерой частоты растровой сетки служит линиатура. Линиатура печати выбирается исходя из разрешения принтера и требуемого количества оттенков на отпечатке. Фотонаборные автоматы обладают достаточным разрешением печати, чтобы передать весь тоновый диапазон при любом используемом значении линиатуры.
  • Цвет передается цифровыми устройствами печати за счет наложения четырех растровых сеток, окрашенных в цвета CMYK или с помощью плашечных (смесовых) красок. Растровые сетки повернуты относительно друг друга, чтобы избежать наложения красок.
  • Неточности приводки цветов компенсируются с помощью треппинга и печати с наложением. InDesign допускает ручной треппинг средствами печати обводок объектов с наложением. Наилучшие результаты обеспечивает треппинг с помощью растрового процессора (In-RIP Trapping). InDesign позволяет задавать параметры треппинга растровым процессором.
  • Материалы для вывода на фотонаборном автомате можно предоставлять в виде файла верстки (indd), файла печати или PDF-документа. Также возможно создание файла печати для последующей обработки в сервис-бюро (prepress file): треппинга, цветоделения, спуска полос. При предоставлении верстки следует прилагать к документу InDesign все использованные шрифты, внешние связанные файлы и описание требований к пленкам.
  • InDesign способен задавать параметры цветоделения средствами растрового процессора (In-RIP Color Separation).
  • InDesign имеет встроенные средства проверки публикации на наличие всех ее компонентов (шрифтов и связанных файлов) и создания пакета файлов для предоставления в сервис-бюро.


Глава 2

Обзор процесса подготовки публикации

В этой главе вы получите представление о тех шагах, которые необходимо предпринять при подготовке публикации от первоначальной идеи до отпечатанного тиража:

  • Планирование публикации
  • Выбор партнеров — типографии и сервис-бюро
  • Создание концепции публикации
  • Предпечатная подготовка
  • Печать в типографии

Поскольку это всего лишь обзор, то его небольшой объем может создать впечатление исключительной простоты всей цепочки. Это верно, к сожалению, лишь отчасти. Действительно, будучи даже средне знакомым с издательской системой, можно сделать макет. Сервисное бюро изготовит пленки для типографии, которая отпечатает тираж. На вас лежит только первый этап подготовки издания, а остальное, как правило, делается сторонними подрядчиками, которые являются профессионалами. Почему же так много полиграфического брака в изданиях, которые мы видим на книжных полках или вынимаем из почтового ящика?

Говорят, что научиться фотографировать легко — трудно научиться хорошо фотографировать. То же самое можно сказать и о подготовке публикации. Для успешного ее выпуска необходимо правильно организовать работу на каждом этапе. Итак, что же это за этапы?


Планирование

Верстка при помощи издательской системы является отнюдь не первым шагом при подготовке публикации. Началом этого многоэтапного процесса можно считать возникновение собственно идеи ее создания. Далее планируется бюджет и сроки, выбираются сторонние подрядчики, вырабатывается концепция издания. Трудно переоценить важность этого первого и решающего этапа. Именно им закладывается успешность дальнейшей работы и прибыль, получаемая вами от издания.


Определение круга читателей публикации

Любое печатное издание представляет собой средство распространения информации, и самым главным моментом является определение цели ее распространения и круга лиц, которым она адресована. Определение адресатов информации — очень существенная задача, и заслуживает оформления на бумаге. Это может быть сделано и неформально. Бумагой может оказаться даже салфетка, позаимствованная в кафе, где и происходило обсуждение замысла публикации. В крупном издательстве или при работе над большим проектом, конечно, необходимо наличие официальной бумаги, завизированной руководством издательства и заказчиком.

От того, кому адресовано издание, зависит и его тираж, и исполнение, и художественная концепция. Естественно, что рекламный буклет нового стирального порошка будет иметь иной вид и тираж, чем буклет, посвященный элитным сортам французских вин.

Особенно важно на этом этапе сосредоточиться на цели издания. Если, например, это рекламный буклет, то надо определить, какую цель он будет преследовать: реклама имиджа производителя продукции, информирование розничных покупателей о ее свойствах, броское напоминание покупателям о ее выдающихся положительных качествах, информация для мелкооптовых покупателей о чертах, отличающих именно эту марку и т. п. В каждом из этих случаев вы наверняка примете разные решения о содержании и внешнем виде буклета. То, насколько точно воплощение вашего замысла в издании будет соответствовать поставленной цели, определит успех издания и, в конечном счете, вашу прибыль вместе с видами на сотрудничество с заказчиком.

Нельзя останавливаться на первоначальной, "неформальной" стадии определения задач. Эта тема требует очень глубокой проработки и конкретизации. Если над созданием публикации вы работаете в группе, то при постановке задачи необходимо добиться полного согласия между всеми участниками проекта. Без этого бесполезно садиться за верстку, и работа обернется в лучшем случае лишь потерей времени.

После того как вы убедились в необходимости издания и определили круг его читателей, можно перейти к финансовой стороне дела.


Бюджет издания

Оценив важность проекта согласно информации, полученной на предыдущем этапе планирования, вы или ваш начальник должны определить, какие

человеческие и технические ресурсы можно привлечь для реализации проекта. Исходить, разумеется, следует из необходимости обеспечения адекватной важности и масштабам проекта прибыли. Нет смысла полгода заниматься изданием собрания сочинений в 20-ти томах, если прибыли хватит лишь на покрытие затрат.

В свете приведенного примера не менее важен вопрос о сроках реализации проекта. Часто обеспечить прибыльность проекта можно только при соблюдении строгих временных рамок, определяемых самой идеей проекта (не стоит затягивать выпуск рождественских открыток до февраля) или заказчиком (ради вас не перенесут сроки выставки его продукции). Определите, реальны ли поставленные условия по срокам реализации и не потребуют ли они излишней занятости сотрудников в ущерб другим, не менее важным проектам.

Если бюджет издания, определенный заказчиком, нереален или требует слишком больших затрат ресурсов, следует склонить заказчика либо к его увеличению, либо к снижению самих затрат. Затраты могут быть снижены за счет уменьшения объема издания, уменьшения количества цветных листов, выбора бумаги и типографии и т. п. Если заказчика не удается склонить к этим шагам, то браться за издание просто не стоит.


Концепция издания

Как мы уже говорили, творческая реализация зависит от идеи, целей и предполагаемой читательской аудитории планируемой публикации. Если в этих вопросах имеется абсолютная ясность, то не составит труда найти ответы и на вопросы, касающиеся художественной концепции издания:

  • Какие материалы публикации будут зрительным центром?
  • Как выдержать единый стиль оформления публикации? Что будет связующей нитью графических и текстовых материалов?
  • Какой тип материалов, текстовый или графический, будет играть главную роль в публикации?
  • Соответствуют ли предлагаемые материалы целям публикации?
  • Нет ли у освещаемой темы какого-то броского графического выражения?

Отвечая на эти вопросы, вы скорее всего, наткнетесь на интересную творческую идею, которую захочется немедленно воплотить. Подождите. Попробуйте взглянуть на свои идеи с другой стороны (лучше всего со стороны читателя), обсудите их с другими участниками проекта. Попробуйте найти альтернативные реализации этой творческой задачи — может быть первое решение — не самое удачное из возможных.


Утверждение плана издания

Теперь необходимо убедиться, что ваша работа понравится предполагаемым читателям.

Для этого сделайте эскизный набросок публикации и покажите его нескольким людям, которые могут стать потенциальными читателями вашего издания. Соберите их мнения и внесите соответствующие коррективы в эскиз.

Далее следует очень важная процедура предварительного утверждения. Утверждающим лицом может быть ваш начальник или сам заказчик. Вам необходимо добиться подписи утверждающего лица на каждом эскизе с тем, чтобы по их капризу не пришлось переделывать уже почти готовую работу и, следовательно, терпеть убытки. В любом случае это должна быть официальная процедура, проводимая принятым в издательстве порядком. Полученные утвержденные эскизы становятся официальным документом — вашим техническим заданием.


Выбор типографии и сервис-бюро, сотрудничество с ними

Еще до того как вы принялись за верстку, необходимо точно определить затраты на издание. Вам предстоит выбрать типографию, в которой будет производиться печать, и сервис-бюро, которому вы закажете предпечатную подготовку публикации. Критериями выбора, безусловно, будут являться не только цены на предоставляемые ими услуги. Необходимо определить, могут ли они удовлетворить ваши технические требования. Особенно высокими они будут при необходимости цветной печати. В типографии следует выяснить:

  • Какой тип печати предложит вам типография? Зачастую при печати книг с черно-белыми иллюстрациями или без иллюстраций и простых рекламных материалов можно отдать предпочтение более дешевому, хотя и менее качественному, чем офсет, методу высокой печати.
  • Сколько красок использует офсетная машина? Не стоит пытаться печатать многокрасочные издания на однокрасочном офсетном станке. В этом случае потребуется несколько прогонов, что значительно снизит качество печати и увеличит ее сроки. Если ваша публикация предполагает четырехцветную печать и наличие дополнительного плашечного цвета (например, надпечатка золотом), то преимущество следует отдать типографии, имеющей пятикрасочный станок.
  • Каковы сроки изготовления тиража?
  • Имеет ли типография значительный опыт работы с компьютерными оригинал-макетами?

Попросите в типографии показать вам образцы их печати и убедитесь, что их качество удовлетворит вас и вашего заказчика.

В сервис-бюро выясните, в какой форме вам надо предоставить макет: в виде верстки или готового файла PostScript. Поговорите с ними о предпочтительных форматах графических файлов, шрифтах, приложениях, в которых следует подготавливать графические материалы, формате фотонаборного автомата. Если вам понадобится высококачественное сканирование фотографических материалов, то определите, может ли сервис-бюро вам его предложить. Делает ли сервис-бюро цветопробные отпечатки?

Один из главных вопросов, которые следует поднять при выборе сервис-бюро, — это вопрос о том, могут ли они произвести треппинг публикации, если в нем есть необходимость.

Выбрав типографию и сервис-бюро, не пожалейте времени на проведение совещания в типографии. К этому времени вы должны быть готовы ответить на следующие вопросы:

  • Какой тип бумаги будет выбран для печати тиража?
  • Сколько цветов будет использовано?
  • В какой форме будут предоставляться пленки для изготовления офсетных форм и какой монтаж потребуется от типографии?
  • Каковы размеры полосы набора?
  • Кто будет выполнять проверку правильности цветопередачи?

Совещание надо проводить с теми сотрудниками типографии, которые непосредственно работают на полиграфическом оборудовании или осуществляют монтаж. Их советы зачастую позволяют более эффективно организовать печать, снизить затраты или облегчить изготовление макета. Обсудите с ними вопросы контроля качества и ответственности за брак.

На этом этапе определяются ключевые технические параметры макета: размеры издания, цветность и используемые краски, линиатура растра для растровых графических изображений, параметры треппинга, учет растискива-ния точек и т. п. Эти параметры зависят именно от типографии, их технических возможностей и типа бумаги.

Например, бесполезно выводить оригинал-макет с линиатурой 175 линий/дюйм для последующей печати на газетной бумаге. Это не только не приведет к увеличению качества, но и катастрофически его снизит. Бесполезной обернется и работа по сканированию и обработке изображений с разрешением 350 точек/дюйм.

Некоторые вопросы, такие как треппинг или цветопередача, могут потребовать и трехстороннего совещания работников издательства, типографии и сервис-бюро. Технические детали, посвященные треппингу и затруднениям при работе с цветом, освещены в главе 19. (Более подробное обсуждение вопросов, связанных с типографиями, можно найти в главе 20.)


Верстка

Когда завершены все хлопоты с планированием и кончилась беготня по типографиям и сервис-бюро, наступает новый "тихий" этап подготовки публикации — верстка. К сожалению, "тихим" он является только в идеале. Редкая публикация готовится не в режиме жестокого цейтнота, вызванного и недостатками планирования (вспомните закон Мерфи: "Всякая работа занимает больше времени, чем вы запланировали"), и отвлечением сотрудников на другие проекты, и несвоевременной подачей материала ответственными за это людьми и многими другими причинами.


Подготовка компонентов публикации

Издательская система, как уже говорилось в предыдущей главе, не позволяет создавать только с ее помощью все элементы публикации. Для верстки вам понадобятся и текстовые и графические материалы, подготовленные в других приложениях. Очень важно перед началом верстки договориться со всеми готовящими материалы сотрудниками о форме их представления для окончательной верстки.

С наборщиками текста необходимо согласовать формат файлов, в котором будет предоставляться текст. Заранее убедитесь, что этот тип файлов может быть импортирован InDesign без искажений. Особенно это касается служебных символов и символов национальных алфавитов. Заранее договоритесь о том, какое предварительное форматирование должен осуществлять наборщик, а какое останется за вами.

С сотрудниками, готовящими иллюстрации, также необходимо согласовать форматы графических файлов. Заранее убедитесь, что эти форматы импортируются InDesign и поддерживают четырехцветные изображения (CMYK). He менее важно задать требуемое разрешение изображений и предполагаемые размеры. Если иллюстрация берется из готовых пленок, то вам необходимо иметь ее точные размеры, чтобы зарезервировать в публикации соответствующее место.

Выполните корректуру текстовых материалов. С помощью специальных приложений отсканируйте фотографии, проделайте их коррекцию и смонтируйте коллажи; подготовьте рисунки; сформируйте таблицы и графики.


Определение структуры публикации

Наконец, начинается собственно работа с InDesign. Если аналогичные публикации вам уже доводилось выпускать (например, выпуск очередного номера журнала или квартального отчета), то можно воспользоваться готовыми шаблонами. В противном случае вам придется выполнить всю работу с нуля:

задать размеры страниц и полей (см. главу 14), создать модульную сетку, определить элементы шаблона, выбрать шрифты (см. главу 15) и определить систему стилей абзацев (см. главу 8), задать палитру цветов (см. главу 4).

Для этих стандартных задач в книге приводятся пошаговые процедуры, которые сэкономят ваше время и не дадут упустить ничего существенного на этом этапе.


Компоновка текста и графики

Пользуясь средствами InDesign, разместите текст и импортируйте графические изображения. После бесконечных перемещений и подгонок вы получите приемлемый результат, который будет забракован начальством или заказчиком. После некоторого количества переделок вы, наконец, получите результат, удовлетворяющий всех.

Если над версткой публикации работают несколько человек, то особенно важно наладить их эффективное сотрудничество: разделение задач, очередность подготовки материалов (чтобы никто не тормозил работу других), договориться о единых параметрах публикации и пользоваться единой модульной сеткой, шаблонами, системой стилей. В противном случае ваша публикация не будет производить впечатление единого издания.

В главах 9, 12 вы найдете массу полезных сведений об импорте и размещении текста и графики, а в главе 16 — методы верстки специфических макетов.


Доводка, специальные эффекты, цветовое оформление

На данном этапе верстки делается кернинг, уточняется разбиение текста на страницы и колонки, обтекание текстом изображений, поворот и искажение изображений, создание буквиц, колонтитулов и т. п. Этим завершается основная работа по созданию макета.


Вывод подписной корректуры

Теперь, когда верстка закончена, пора представить ее результат заказчику. Для этого необходимо вывести макет публикации на лазерный или цветной принтер и представить заказчику на утверждение. В этом случае, как и при утверждении эскиза, необходимо обязательно добиться от заказчика его подписи на подписной корректуре. Получение официального согласия заказчика на выпуск публикации особенно важно, поскольку дальнейший ход подготовки публикации покидает стены издательства и передается в сервис-бюро.


Предпечатная подготовка

Предпечатная подготовка макета производится в сервис-бюро и может включать разнообразные этапы: сканирование, треппинг, цветоделение, вывод пленок на фотонаборном автомате, цветопробы и т. п. Если выпускаемое издание включает иллюстрации, более качественные, чем газетные, то стадии предпечатной подготовки не миновать. Дело в том, что технология изготовления форм для офсетной машины требует представления оригинал-макета в виде отпечатков на фотографической пленке (чаще всего позитивной) в натуральную величину. Если издание не предъявляет существенных требований к качеству, то этому условию удовлетворяют и пленки, отпечатанные на приличном лазерном принтере. В случае более высоких требований к качеству, и особенно для цветных публикаций, вам обязательно потребуется фотонаборный автомат. Фотонаборный автомат, по сути, является очень сложным лазерным принтером, но печатающим не на бумаге, а засвечивающим рулонную или листовую фотопленку. Такие машины, как впрочем, профессиональные сканеры и цветопробные принтеры, очень дороги и не всякое издательство может их полностью загрузить, поэтому существуют сервис-бюро, которые получают на подобную работу заказы от издательств.


Высококачественное сканирование

Если ваше издательство не располагает качественными сканерами или заказчик предъявляет повышенные требования к качеству, сканирование лучше поручить сервис-бюро, которое располагает профессиональными сканерами, стоящими десятки тысяч долларов. Для обработки полученных гигабайтных файлов в сервис-бюро также имеются мощные компьютеры.


Треппинг

При подготовке цветных изданий в большинстве случаев возникает необходимость треппинга. Упростив определение до предела можно сказать, что треппинг — взаимное перекрывание элементов на странице, необходимое для компенсации погрешностей совмещения (приводки) печатных форм и клише на типографском станке. При отсутствии треппинга между смежными цветами могут возникать белые или цветные зазоры.

Кто же должен делать треппинг? В простых случаях эту задачу можно решить самостоятельно. В InDesign встроены средства автоматизации треппинга, но не забывайте об ответственности, которую вы в этом случае берете на себя. Если вы не имеете соответствующего опыта, или в публикации имеются сложные для треппинга элементы (см. главу 19), то эту работу можно заказать в некоторых сервисных бюро, которые располагают квалифицированными сотрудниками и специальными, очень сложными и дорогостоящими, программами растрового треппинга (типа TrapWise). Впрочем, работники сервис-бюро вряд ли будут производить настройку параметров треппинга именно на вашу публикацию, а воспользуются некими "средними" значениями. Поэтому результат треппинга в сервис-бюро не всегда оправдывает ожидания.


Цветоделение

В процессе цветоделения цветное изображение разбивается на цветные слои, соответствующие отдельным краскам. Каждому слою соответствует отдельная пленка, вышедшая из фотонаборного автомата и отдельная форма для печатной машины. С появлением компьютерных издательских систем процесс цветоделения стал исключительно прост, но только имея значительный опыт, или посоветовавшись с опытными работниками сервис-бюро и типографии вы можете взяться за цветоделение сами. О цветоделении см. главу 19.


Цветопробы

Услуги по изготовлению цветопроб предлагают большинство сервис-бюро и некоторые типографии, имеющие пробопечатное оборудование. Цветопробы могут изготавливаться по различным технологиям (из электронного варианта верстки, с уже выведенных пленок и т. п.) и позволяют с большой степенью достоверности судить о правильности подготовки макета и цветоделения. При печати сколько-нибудь ответственного тиража мы рекомендуем не пропускать эту стадию. Если требования заказчика к соблюдению цветов высоки, то цветопроба просто необходима. Кроме того, обязательно утвердите полученные цветопробы у заказчика официально. Не лишними будут цветопробы и в типографии в качестве образца цвета для печати на офсетной машине. В случае типографского брака при наличии цветопроб вы скорее сможете убедить типографию в необходимости доработок или перепечаток.


Вывод на фотонаборном автомате

Как мы уже говорили, фотонаборный автомат позволяет выводить не бумажные оригиналы, а фотографические пленки. Это не единственное его отличие от лазерного принтера. Даже самый хороший лазерный принтер не позволяет выдать отпечаток с разрешением 3600 точек/дюйм. Столь высокое разрешение необходимо для адекватной передачи полутонов и оттенков цвета (см. главу 19). На этом этапе вам также понадобятся сведения, приведенные в главах 5, 17.


Печать в типографии

Спуск полос

Спуском полос называется операция сборки страниц публикации в т. н. монтажные листы. Ее смысл в том, чтобы за один проход типографского листа через печатную машину отпечатывалось сразу несколько страниц публикации. Способ переплета публикации определяет размещение страниц на монтажных листах. Операция спуска полос весьма сложна и без соответствующего опыта в ней легко запутаться. Обычно спуск полос делается в типографии.


Пробные отпечатки

После спуска полос и изготовления форм печатаются пробные отпечатки. Они дают точное представление о том, как будет выглядеть основной тираж, т. к. их выпуск предназначен не только для утверждения вами или заказчиком, но и для настройки типографской машины (подача краски, приводка форм и т. п.). Просмотр пробных отпечатков лично вами особенно важен — ведь вы видите практически часть готового тиража. Если вы находите что-либо неудовлетворительное (плохое совмещение цветов, нарушение цветопередачи, "грязную" печать и т. п.), что может быть исправлено в типографии, то об этом нужно обязательно сообщить ее работникам и настоять на исправлении, поскольку это последний шанс что-либо скорректировать.

После того как вы останетесь, довольны пробными отпечатками, вам предложат подписать их в печать для изготовления тиража. Это делается самым официальным образом, и подписывающей стороной можете являться вы, ваш начальник или заказчик, в общем, тот, кто оплачивает счета или его представитель.


Печать тиража

Тираж печатается немедленно после подписания его в печать, поскольку машина настроена и не может быть использована для других работ без риска ее сбить.

Нелишним представляется и выборочный просмотр готового тиража на предмет соответствия пробным оттискам. Если соответствие неудовлетворительно, то вы имеете право требовать перепечатки тиража, поскольку брак был допущен именно типографией. Если вы уже достаточно долго работаете с этой типографией, то риск таких катастрофических ошибок ничтожно мал.

После печати тиража типография может произвести и прочие работы, необходимые для конкретного издания: фальцовку, обрезку, переплет и т. п. Результат этих работ, как и любых типографских работ, желательно тщательно контролировать и сообщать работникам типографии о любом обнаруженном браке: коробление переплета, складки при фальцовке, неровный обрез и т. п.

И вот, после длительной подготовки издания вы, наконец, держите его в руках. На первых порах вы часто будете не абсолютно им довольны. Вы обнаружите и некоторые ошибки верстки, и неиспользованные возможности улучшения самого макета или повышения его технологичности. Это неизбежно, но не расстраивайтесь — издание состоялось и получена прибыль. Обязательно анализируйте причины неудач и отмечайте упущенные возможности. Анализ поможет вам избежать таких накладок и в следующий раз подойти к выпуску публикации более рационально.


Глава 20

Сотрудничество с типографией

Вот, наконец, процесс создания публикации вышел на финишную прямую — изготовление тиража. Скоро в свежих, пахнущих типографской краской, отпечатках воплотится труд многих людей, занимавшихся подготовкой материалов — фотографов, верстальщиков, редакторов, корректоров, технологов, работников студии предпечатной подготовки и типографии. Теперь, казалось бы, публикация выходит из сферы вашей деятельности, и вам остается только со стороны наблюдать за чудесным превращением бестелесной информации в книгу, брошюру, журнал.

В действительности дело обстоит не совсем так. Эту завершающую стадию было необходимо учитывать на всем протяжении подготовки издания. Очень много раз в этой книге мы говорили: "проконсультируйтесь в типографии", "это решает технолог типографии", "возьмите образцы в типографии" и т. п. Высокий уровень издания зависит от правильной работы с типографией в не меньшей мере, чем живописное полотно от техники художника. В типографии даже удачный макет может обернуться испорченным тиражом, и, наоборот, неудачный макет — вполне приличным изданием. Огромную роль в этом играет не только качество оборудования, но и профессионализм типографов, который легко оценить по чужим изданиям. Большинство проблем возникает из-за недоговоренности и несогласованности в работе издательств и типографий. Избежать проблем вам поможет постоянный контакт с сотрудниками типографии. С одной стороны, они подскажут вам, как изготовить технологичный макет, а с другой — с пониманием и готовностью встретят ваши требования. В главе рассматриваются следующие вопросы:

  • Выбор типографии
  • Стратегия и тактика работы с типографией
  • Выбор бумаги и способа печати
  • Требования, предъявляемые к макету
  • Контроль качества печати


Предварительное совещание в типографии

В идеальном варианте подготовки издания такой разговор должен быть предусмотрен. К сожалению, в реальности это происходит не всегда, и даже не всегда возможно. В случае подготовки несложной публикации (рекламного листка, черно-белой брошюры и т. п.) он вовсе необязателен. При наличии же у вас опыта и налаженных связей с этой типографией вам будет явно не о чем говорить. Если же публикация сложна и потребует больших затрат труда как с вашей стороны, так и со стороны типографии, ранний визит туда может сэкономить много времени и средств издательству, а то и вообще убережет вас от потерь и срыва сроков заказчика.


Выбор типографии

Разумеется, проводить подробный разговор в типографии имеет смысл после того, как вы определили, в какой типографии будет печататься издание. В свете сказанного выше важно определить это как можно раньше. Выбор может осуществляться не вами, а вашим начальством, но многие технические вопросы все равно лягут на ваши плечи. Выбирать типографию следует не по дешевизне печати, а исходя из требований заказчика к готовой продукции. Часто "дешевые" типографии располагают технически несовершенным или сильно изношенным оборудованием, которое не позволяет отпечатать тираж с требуемым качеством. Случается, что для привлечения клиентов типографы не торопятся сообщить им об этом. Поэтому оценивайте качество печати типографии по их продукции. Посмотрите не только те образцы печати, которые показывает вам администрация, но и те, которые только что сошли со станка.

Выясните, предоставляет ли типография полный цикл услуг, необходимых для печати вашей публикации. Возможно, вам понадобятся фальцовка, брошюровка, переплет, вырубка, печать на специальных носителях или специальными красками. Если что-либо из требуемого типография обеспечить не может, то вам придется подумать о поисках другой типографии или производстве этих работ у другого подрядчика. Нелишне и подумать о том, насколько обязательны эти работы для выполнения заказа. Не исключено, что хорошего результата можно достичь средствами макета. При печати плашечными цветами ознакомьтесь с каталогом цветов, имеющихся в типографии. Убедитесь, что в нем присутствуют необходимые цвета.


Что нужно определенно знать к предварительному совещанию

Перед тем как отправиться на предварительное совещание, необходимо проделать значительную подготовительную работу. В противном случае разговор окажется бесполезным.

К этому моменту вы должны уже очень четко представлять себе цель издания и его потенциального читателя. Хорошо также иметь предварительные эскизы и макеты. Они должны давать представление о формате издания, способах сшивки или фальцовки, используемых цветах.

Создавая макет, вы вряд ли изобретете что-то новое. Собирайте характерные образцы печатной продукции. Они пригодятся вам в разговоре с работниками типографии. Он будет гораздо предметнее, если у вас в руках окажется образец бумаги, на которой вы хотели бы печатать публикацию, образец формата или фальцовки, образцы специальных красок или вида вырубки.

Как мы уже отмечали, качество является одним из главнейших критериев выбора типографии, наряду со стоимостью услуг. При выборе типографии необходимо найти устраивающий вас и заказчика компромисс между стоимостью тиража и его качеством. Когда типография уже выбрана, предполагается, что вы его уже нашли. Возможно, потребуются дополнительные переговоры, направленные на уменьшение типографских расходов путем упрощения макета. Может быть, удастся обойтись плашечными цветами вместо триадньгх или избежать ламинирования подбором сорта бумаги для обложки.

Большое влияние на смету издания и качество печати оказывает выбор бумаги. Бумага выбирается, в первую очередь, исходя из способа использования издания. Если вы издаете учебное пособие, то стоит позаботиться о том, чтобы оно прослужило не один год при самых жестких условиях эксплуатации. Рекламные листовки, раздаваемые у метро и рассылаемые по почте, напротив, не требуют такого "долголетия". Выбор напрямую зависит и от требуемого качества публикации. Даже великолепный макет, отпечатанный в лучшей типографии, не позволит вам издать качественный иллюстрированный журнал ня гячртнпн бумаге.

Как правило, заказчик хочет получить тираж в очень сжатые сроки. Для того чтобы их не сорвать, следует заранее выяснить в типографии, за какой срок они могут изготовить тираж. Исходя из этого можно планировать работу по изготовлению макета. Можно сократить сроки выпуска, проделав часть работы заранее, например, загодя отпечатав обложку.

Разумеется, решающим при выпуске издания всегда остается финансовый вопрос. Все расходы по печати и верстке вместе с прибылью издательства должны умещаться в бюджет издания. Размер бюджета оказывает непосредственное влияние на все аспекты издания: на выбор типографии, бумаги, красок, способов печати, а также на сложность верстки, размер тиража и сроки выпуска. Размер тиража не должен быть слишком мал, т. к. различие в стоимости 1000 отпечатков и 2000 невелико, и малый тираж, отпечатанный обычным способом, будет нерентабелен. На предварительном совещании в типографии самое время поднять вопрос о способах снижения стоимости тиража. Практически наверняка работники типографии смогут дать вам несколько дельных советов на этот счет. Попробуйте обойтись меньшим количеством красок, использовать бумагу другого сорта, печатать малоформатные издания на обрезках другого тиража, изменить формат печатного листа с тем, чтобы получить эффективный спусковой макет и т. п.

Уже на предварительном совещании хорошо сообщить типографам о всех особых требованиях, предъявляемых к изданию. Иногда требуется повышенная точность воспроизведения, особая фальцовка или вырубка. Может быть, вы или заказчик имеете предубеждение против каких-либо технических приемов печати, связанное с предыдущим опытом. Раннее выяснение этих вопросов позволит избежать ситуации, когда при печати обнаруживается, что ваши требования технически не могут быть выполнены.

Не стесняйтесь высказать перед работниками типографии свои, пусть "безумные" идеи. Может быть, они кажутся вам "безумными" потому, что вы не знаете, как их реализовать. Не исключено, что вместе с работниками типографии вы сможете найти способ перевести их в разряд исполнимых. Попросите типографов указать вам на узкие места в проекте, которые будет сложно реализовать при печати. Даже незначительное изменение может предотвратить потенциальные проблемы.


Разработка тактики

Это — самый важный момент предварительного совещания в типографии. Не уходите из типографии, не договорившись с ее сотрудниками о путях дальнейшего сотрудничества. Обязательно добейтесь договоренности по следующим вопросам:

  • Управление цветом и стратегия выбора красок. Если вы собираетесь воспользоваться плашечными цветами, согласуйте с типографией используемую систему цветов. Если для вашей публикации необходима высокая верность передачи цвета, убедитесь, что в типографии имеется необходимое для этого оборудование. После выбора совместно с типографией системы цветов необходимо выбрать бумагу. Для обычной бумаги и бумаги с покрытием выпускаются различные веерные образцы цветов. Договоритесь с типографией о схеме применения красок. Например, если в вашей публикации совместно применяются триадные и плашечные цвета, целесообразно применить систему плашечных цветов, получаемых в результате смешивания базовых триадных цветов. Попросите технолога типографии рассказать о том, как и в каком порядке краски будут наноситься на бумагу. Это поможет вам выбрать правильную стратегию оформления издания в плане использования таких приемов, как выворотка, подавление подлежащего цвета и печать с наложением.
  • Линиатура растра. Располагая сведениями о печатном оборудовании, на котором будет отпечатан тираж, и образцами бумаги, можно выбрать оптимальную линиатуру растра. Эта величина будет играть определяющую роль при сканировании фотографий и выполнении цветовых растяжек (и еще во множестве случаев). Есть ли у технолога типографии какие-либо пожелания или рекомендации по режиму сканирования фотографии? Обсудите также вопросы компенсации растискивания точек, а для цветных фотографий — удаление перекрытого цвета и замену серого компонента.
  • Треппинг. Не подскажут ли вам в типографии, как при минимальных изменениях оригинал-макета вообще избавиться от необходимости заниматься треппингом? Спусковые макеты. На предварительном совещании обязательно решите, кто будет выполнять подготовку спускового макета. В сервисном бюро фотоформы крупного формата выпускают при помощи приложений типа Adobe PressWise. В большинстве типографий, где имеются собственные фотонаборные автоматы, сборка спусковых макетов вручную на монтажном столе постепенно уходит в прошлое, поскольку с помощью компьютеров это обходится намного дешевле. Однако теперь возникает новый вопрос — об ответственности за неправильную разработку спускового макета. Кто должен платить за выполнение дополнительных операций по разрезке и подборке экземпляров издания, без которых не обойтись, если сигнатуры оказываются подобранными иеперно?
  • Требования к оригинал-макету. В каком виде типография хотела бы получить оригинал-макет? Будет ли достаточно отпечатать его на лазерном принтере с высоким разрешением или потребуется вывод на фотонаборный автомат? В последнем случае отпечатки должны быть представлены в виде позитивов на фотобумаге со специальным покрытием или в виде негативов на пленке? При линиатуре растра свыше 100 Ipi и для однокрасочных макетов вывод на фотонаборный автомат становится практически обязателен. Если фотоформы будут выпускаться в сервисном бюро, какие указания по их выпуску следует передать вместе с публикацией? Каким должно быть изображение на фотоматериале — негативным или позитивным, прямым или зеркальным, эмульсией вверх или эмульсией вниз? Если сервис-бюро находится при типографии, смогут ли они без вашего посредничества договориться по поводу треппинга, компенсации растискивания и спусковых макетов? Может быть, эти операции возьмет на себя типография, ликвидируя источник возможных нестыковок? Подробнее о выпуске оригинал-макетов рассказывается в главе 19.
  • Контрольные оттиски. Необходимость и порядок подготовки контрольных оттисков также обсуждаются на предварительном совещании. Будет ли выпускаться контрольный оттиск перед началом печати тиража? Примет ли типография цветопробы, выпущенные сервисным бюро? Необходимы ли контрольные оттиски для настройки печатных машин в типографии?


Выбор бумаги

Выбор бумаги для печати тиража — очень важный аспект сотрудничества с типографией. Выбор бумаги — основной фактор, определяющий линиатуру растра, и, конечно, себестоимость экземпляра издания.

Лучше всего выбрать бумагу для печати тиража уже на предварительном совещании. Обычно бумага выбирается по образцам (примерно так, как выбирают обои или плашечные цвета Pantone). Однако бумагу нельзя выбирать по принципу "нравится — не нравится". Бумага — носитель любой публикации, и она должна обеспечить все физические и эстетические параметры, необходимые для достижения целей публикации.

Вот факторы, которые следует иметь в виду при выборе бумаги:

  • Впитывание краски. Это — одна из важнейших характеристик сорта бумаги, определяющая величину растискивания точек. На плотной бумаге со специальным покрытием типографская краска расплывается несравнимо меньше, чем, скажем, на газетной бумаге.
  • Тип бумаги. В целлюлозно-бумажной промышленности и полиграфии принято достаточно традиционное деление бумаг на категории. Существуют четыре основные категории бумаги, внутри которых может насчитываться более десятка типов, технологические характеристики которых сильно меняются в зависимости от производителей.
  1. Типографской или писчей называется бумага, применяющаяся для письма, текстовых изданий, ксерокопирования. Такая бумага ориентирована, в основном, на письмо и печать с одной стороны листа.
  2. Книжная или офсетная бумага специально приспособлена для прохождения через печатные машины.
  3. Мелованная бумага покрывается специальным составом, повышающим ее плотность и придающим глянец. Хорошие механические и физические свойства такой бумаги обеспечивают ей наиболее широкое применение для цветной печати. Ее повышенная плотность делает ее менее прозрачной, и, следовательно, лучше приспособленной для оборотной печати.
  4. Полукартон имеет увеличенную толщину, что позволяет использовать его, помимо прочего, для печати обложек брошюр.
  5. Существует также бесчисленное множество специальных типов бумаг, перечислить которые здесь просто невозможно. В качестве примеров назовем лишь картографическую бумагу повышенной прочности и бумагу, допускающую воспроизведение копий на пишущих машинках, принтерах и при письме от руки без прокладки копировальной бумаги. Кроме того, существует более тридцати способов дополнительной обработки поверхности бумаги с целью придания ей необходимых физико-механических характеристик. Для некоторых специальных типов изданий (например, воспроизведения графических художественных произведений) выпускается бумага с ворсистой поверхностью, напоминающей войлок. При производстве офсетной бумаги часто применяют дополнительные технологические операции выравнивания поверхности. Чем ровнее поверхность бумаги, тем выше ее плотность. Наиболее распространен технологический процесс каландрирования, при котором поверхность листа бумаги разглаживается каландрами — металлическими цилиндрами. В результате других технологических процессов получают пергаментную и веленевую бумагу.
  • Цвет. На сегодняшний день производится цветная бумага всех мыслимых цветов, и при выпуске некоторых изданий применение цветной бумаги может сократить число используемых цветов на единицу (если, конечно, цветная бумага не будет стоить чересчур дорого). Но и при печати на неокрашенной бумаге нельзя считать, что эта бумага — белая. Практически у каждого из сортов бумаги имеются свой специфический нацвет и своя характеристика яркости, которые приходится учитывать при работе с системой управления цветом.
  • Вес и размер листов. Для определения веса бумаги в типографиях используются несколько достаточно сложных систем расчета по размерам листов и сортности. Для дизайнера гораздо важнее влияние веса и размера бумаги на параметры издания. Как следует продумайте назначение издания. Для некоторых из них нужна более плотная, и, соответственно, более тяжелая бумага. Но если тираж издания предполагается рассылать по почте, может оказаться необходимым выбрать более легкую бумагу во избежание перерасхода средств, запланированных на почтовую рассылку. Размер листов, на которых будет печататься тираж, сильно влияет на производственные затраты. Обязательно обсудите выбор плотности и размеров листов бумаги в типографии — возможно, вам предложат совершенно неочевидные для вас варианты, которые позволят добиться существенной экономии.
  • Непрозрачность. Положите лист выбранного вами сорта бумаги поверх книжной страницы. Если сквозь него видно хоть что-нибудь, то такая бумага, скорее всего, не годится для оборотной печати. В этом вопросе можете довериться опыту технолога типографии.
  • Волокна. Бумага неоднородна, ее волокна обычно идут в одном направлении. Для вас это может показаться неважным, но при фальцовке это играет определенную роль. Сгиб поперек волокон редко бывает ровным, поэтому и в данном вопросе имеет смысл прислушаться к специалистам типографии.


Выбор значения линиатуры растра

Величина растискивания точек растра зависит от используемой краски, сорта бумаги и печатной машины. Сочетание этих факторов лучше всех может оценить технолог типографии, хорошо изучивший имеющееся в ней оборудование. Но в качестве отправной точки можно воспользоваться данными, приведенными в табл. 20.1.

Таблица 20.1. Выбор линиатуры растра в зависимости от сорта бумаги и состояния печатной машины

Бумага/Печатная машина | Линиатура, линий на дюйм
Газетная Стандартная с покрытием Высококачественная с покрытием на более совершенной печатной машине Высшие сорта бумаги с покрытием на самом совершенном оборудовании | от 65 до 85 от 85 до 133 от 133 до 175 175 и выше


Фальцовка и переплетные работы

В большинстве случаев все операции по фальцовке, обрезке и переплетению изданий выполняются в той же типографии, где печатается тираж. Сегодня такой сервис предоставляют даже салоны оперативной полиграфии, используя собственное оборудование или услуги контрагентов.

В процессе фальцовки соответствующие сигнатурам листы складываются и обрезаются, образуя брошюру целиком или одну из составляющих ее тетрадок. Возможно скрепление отдельных листов в брошюре прошивкой тетрадей нитью, при помощи металлических скрепок или клея. Отдельные листы или тетради издания могут склеиваться в книжный блок с последующей насадкой мягкого или твердого переплета, или скрепляться спиралью после нанесения перфорации.

В процессе переплетения в издание вкладываются вкладки (как правило. выпадающие из него по пути из магазина или от почтового ящика домой) вклеиваются вклейки.

Последней операцией переплетного цикла является упаковка изданий.


Проверка качества печати тиража

При проверке качества печати тиража выполняются практически те же операции, что и при проверке контрольного типографского оттиска, описанной в главе 2:

  • Проверьте соответствие цветов в издании контрольному типографскому оттиску (если он ранее выпускался) или образцам и оригиналам.
  • Выберите наугад несколько экземпляров из различных частей тиража. Проверьте их на соответствие контрольному оттиску, оригинал-макету и друг другу.
  • Проверьте отсутствие складок, просачивания краски сквозь страницы, грязи, клякс, смазывания изображения и пятен смазки, которые могут возникать при неаккуратном обслуживании механических частей печатной машины.
  • Проверьте выравнивание элементов на страницах. Это не ограничивается проверкой приводки цветов — в монохромных изданиях, например, должны совпадать линейки, отделяющие верхние и нижние колонтитулы (на обеих сторонах страницы и на страницах разворота).
  • Проверьте правильность и качество упаковки тиража на соответствие спецификации (в коробки или пачки). Попробуйте оценить, весь ли тираж был напечатан.


Резюме

Типографская печать завершила процесс подготовки издания, и дальнейшая его жизнь уже не зависит от вашей воли. Тем не менее не теряйте его из вида, если такая возможность существует. Сведения о том, как издание было принято читателем, поможет вам сделать макет более емким, броским, эффективным. Нс менее важны уроки, которые можно извлечь из самого процесса создания публикации. Теперь, когда уже все позади, поразмышляйте о том, с какими проблемами вы столкнулись, и как они были решены. Каких из них можно было избежать, и что для этого требовалось? Достаточно ли согласована была работа всех принимавших участие в создании макета, что было при этом лимитирующим фактором? В достаточно ли тесном контакте работали вы с сервис-бюро и типографией?

Даже если вы испытываете неудовлетворенность проделанной работой, постарайтесь перевести ее в конструктивное русло. Накопление опыта позволит вам избегать грубых ошибок, и вы все больше будете сосредоточиваться на творческом аспекте издания, а не на техническом.

Надеемся, что первый опыт принес вам не только заботы и разочарования. Вспомните те, ни с чем не сравнимые чувства, которые вы испытали, держа в руках только что сошедшую со станка книжку. Ведь ее создали вы!


Глава 3

Установки программы

Практически все элементы интерфейса InDesign можно изменять в соответствии с требованиями к создаваемой публикации и вашими привычками в работе. Когда вы входите в InDesign, эти элементы уже имеют какое-то значение, принятое по умолчанию. Изменив атрибуты форматирования или элементы интерфейса, вы не должны будете повторять эти действия при переходе от публикации к публикации и при каждом открытии InDesign. Вместо этого можно задать свою систему умолчаний, и тогда программа, как подогнанный по руке инструмент мастера, будет полностью соответствовать именно вашему стилю работы и требованиям текущей публикации, вплоть до самых мелких особенностей. Настоящая глава посвящена умолчаниям, в ней обсуждаются следующие темы:

  • Основные понятия InDesign, связанные с умолчаниями, области действия умолчаний и способы их задания
  • Глобальные и локальные умолчания, как две основные группы умолчаний, имеющие различную область действия
  • Установки умолчаний InDesign командой Preferences
  • Диалоговые окна команды Preferences
  • Организация работы программы InDesign при помощи мини-умолчаний
  • Приоритеты умолчаний локального и глобального форматирования
  • Работа с наборами умолчаний

Если вы читаете книгу последовательно и не имеете опыта работы с издательскими системами, то большинство настроек, обсуждаемых в этой главе, будут вам непонятны. Не беспокойтесь, самое главное — понять механизм создания умолчаний и иметь общее представление о том, что можно настроить. Все инструменты программы будут в дальнейшем обсуждаться очень подробно, включая возможности их настройки. Настоящая глава носит характер справочной.


Основные понятия InDesign, связанные с умолчаниями

Умолчание в InDesign — неизменный или условно-неизменный набор значений параметров, управляющих функционированием программы. Умолчания форматирования не имеют обратной силы, т. е. распространяются только на действия, которые будут выполнены с публикациями в дальнейшем и никак не изменяют форматирование уже существующих символов.


Где хранятся умолчания

Все параметры, заданные вами в качестве умолчаний, программа InDesign записывает в специальные файлы: InDesign Defaults и InDesign SavedData в папке \WINDOWS\Local Settings\Application Data\Adobe\InDesign\Version 1.0\. Каждая пара файлов умолчаний может существовать только в единственном числе. Поэтому, если вы хотите создать несколько наборов умолчаний для работы с разными проектами, копируйте их по мере создания в каталоги соответствующих-проектов, а, начиная работу с одним из них, перенесите файл умолчаний обратно в указанную выше папку. Если вы испортили умолчания и хотите вернуться к комплексу умолчаний InDesign в том виде, в котором он был после инсталляции, закройте InDesign и удалите файлы InDesign Defaults и InDesign SavedData. В начале следующего сеанса работы с программой они будут автоматически созданы, причем будут содержать первоначальные умолчания, встроенные в программу.

Установка дополнительных подключаемых модулей может изменить установки по умолчанию, например, положение палитр, и т. п,


Два вида умолчаний

По области действия умолчания InDesign делятся на локальные (действующие в пределах документа) и глобальные (действующие на все публикации). Тип задаваемого умолчания, в конечном счете, определяется тем, что находится на экране в момент его задания.

Локальные умолчания (уровень публикации). Если в момент задания умолчания открыта публикация, то действия, задаваемые умолчанием, будут распространяться только на эту публикацию. Заданное умолчание никак не повлияет на другие публикации — как созданные ранее, так и те, которые вы создадите впоследствии. Иногда подобные умолчания называют временными, поскольку они действуют только во время работы с конкретной публикацией.

Глобальные умолчания (уровень программы). Если в момент задания умолчания не была открыта ни одна публикация, то образуется глобальное умолчание, которое впоследствии будет оказывать воздействие на все публикации, с которыми вы будете работать. Глобальные умолчания называют также постоянными, поскольку их действие продолжается во всех последующих сеансах работы с любыми публикациями. Впрочем, любое умолчание, в том числе и глобальное, можно отменить в любой момент, когда это потребуется.

Локальные умолчания имеют приоритет перед глобальными умолчаниями. Если, например, для документа (локальное умолчание) принят иной шрифт, чем для всех новых документов (глобальное умолчание), то использован будет первый.


Способы задания умолчании

Установки по умолчанию создаются либо с помощью специализированных диалоговых окон, либо обычными командами меню.


Умолчания, задаваемые в диалоговых окнах

Для многих элементов интерфейса и некоторых режимов работы задание умолчаний производится с помощью диалогового окна Preferences, созданного специально для этой цели. Если команда Preferences выбирается в меню при наличии открытой публикации, то задается локальное умолчание. Если команда выбирается в отсутствие открытой публикации, задается глобальное умолчание.

Вложенное меню Preferences, находящееся в меню File, включает несколько пунктов. Каждый из них открывает соответствующее диалоговое окно Preferences на соответствующем разделе:

  • General. Общие установки программы, включающие режим демонстрации изображений, нумерации страниц, подсказок.
  • Text. Установки, касающиеся текста: относительные размеры индексов и капители, режим сглаживания при отображении на экране, использование типографских кавычек, режим оптически верного подбора размера и рисунка символов. Последний имеет смысл только для шрифтов MultileMaster с осью оптического размера.
  • Composition. Настройки выключки абзацев. В InDesign впервые появился многострочный алгоритм выключки с оптическим выравниванием. Установки этого раздела позволяют настроить алгоритм выключки, управляют режимом подсветки жидких строк и нарушений правил переноса.
  • Units & Increments. Здесь задаются единицы измерения для всех диалоговых окон программы и величина изменения параметров текста при пошаговом подборе.
  • Grids. Настройки параметров координатной сетки и сетки базовых линий документа: цвета, шага, положения, и т. п.
  • Guides. Назначение цвета направляющим линиям и границам колонок, установка зоны выравнивания по направляющим.
  • Dictionary. Выбор основного языка документов и соответствующих словарей переносов и орфографии.

Отдельное диалоговое окно отведено установкам службы Adobe Online, с помощью которой вы можете получить бесплатные обновления программы и дополнительную информацию. Установки Adobe Online вызываются командой Online Settings меню Preferences.

Настройки системы управления цветом сосредоточены во вложенном меню Color Settings, находящемся в меню File. В нем также имеются две команды, открывающие диалоговые окна Application Color Settings и Document Color

Settings. В первом устанавливается система управления цветом (если их установлено несколько) и цветовые профили устройств. В последнем устанавливаются профили для различных цветовых моделей и варианты преобразования цветовых пространств. Более подробно системы управления цветом и их использование в InDesign рассмотрены в главе 5.

InDesign — первый продукт Adobe Systems, который поддерживает свободную настройку клавиатурных сокращений. Для этого предусмотрено специальное диалоговое окно Edit Shortcuts, открываемое одноименной командой меню File.


Умолчания, задаваемые командами меню

Для того чтобы создать умолчание, задаваемое командой меню, достаточно включить или выключить любой из доступных в меню InDesign режимов в управляющих меню и диалоговых окнах. При этом должно быть отменено выделение каких-либо объектов. Элементы управления меню и подчиненных им диалоговых окон, для которых возможно задать умолчание, можно назвать способными к умолчанию или зависимыми от умолчаний.

Предварительная отмена выбора всех объектов — главное условие для задания умолчаний меню и палитр. Если выбран хоть один объект, то действия выполняются с этим объектом, и никакое умолчание не устанавливается. Манипуляции с зависимыми от умолчаний элементами управления меню и диалоговых окон приводят к установке новых умолчаний только в отсутствие выбора. Именно так в большинстве случаев и устанавливаются ошибочные умолчания — перед выполнением операции форматирования случайно

отменяется выбор объекта, который предполагалось отформатировать. В результате объект не изменяется, но зато задается новое умолчание. Простота установки умолчаний иногда приводит к удивительным, с точки зрения пользователя, результатам, например, набираемый текст почему-то имеет зеленый цвет, буквы размером вполовину страницы, а начало строки при этом смешено к правому краю. Если InDesign начинает выполнять подобные удивительные действия, проверьте, не задано ли случайно вами (или кем-то еще) такое умолчание для текстового материала.

Если вы собираетесь задать локальное умолчание, при открытой публикации выполните щелчок текущим инструментом на любом месте рабочего окна, свободном от объектов. Таким образом вы отмените выбор всех ранее выбранных объектов. Выделение объектов можно также отменить, выбрав пункт Deselect All меню Edit. Клавиатурное сокращение для этого действия <Ctrl>+<Shift>+<A>. Если необходимо распространить задаваемое умолчание на все публикации, закройте все редактируемые документы. Вызовите нужные диалоговые окна или пункты меню и выполните необходимые изменения режимов.


Диалоговое окно Preferences

Большинство установок программы собрано в диалоговом окне Preferences, имеющем 7 разделов (рис. 3.1).

Рис. 3.1. Диалоговое окно Preferences, раздел General

Нужный раздел диалогового окна выбирается одним из следующих способов:

  • В списке Preferences меню File. В этом случае диалоговое окно Preferences сразу откроется на выбранном разделе.
  • Открыв диалоговое окно Preferences на любом разделе, выбрать в списке, расположенном в верхней части окна, требуемый раздел.
  • Открыв диалоговое окно Preferences на любом разделе, перейти к требуемому нажатием кнопок Next и Prev. Первая кнопка открывает следующий раздел диалогового окна, а вторая — предыдущий. Вместо кнопок диалогового окна можно использовать клавиши <Ctrl>+<вверх> и <Ctrl>+<вниз>.

Теперь перейдем к более подробному рассмотрению каждого раздела.


Раздел General

Диалоговое окно Preferences, открытое на этом разделе, приведено на рис. 3.1. При верстке иллюстрированных изданий в составе публикации присутствует импортированная графика. По умолчанию InDesign прорисовывает изображения с низким разрешением. Переключатель режима отображения позволяет выбрать подходящий компромисс между скоростью прорисовки и качеством отображения.

Список Display в области Images позволяет установить режим перерисовки графики на экране (рис. 3.2). Вы можете переключать их в любой момент работы в зависимости от конкретной задачи.

Рис. 3.2. Режимы показа импортированных изображений: Gray Out Images, Proxy Images и Full Resolution Images

  • Gray Out Image. Если включить в этом режиме, то вместо графики изображается только серый треугольник, совпадающий с ней по размерам и местоположению. Этой опцией можно воспользоваться при работе с текстом, когда вы занимаетесь изображениями а файле. Иногда в таком режиме можно просмотрен, уже готовый документ на предмет корректности композиции.
  • Proxy Images. По умолчанию включен именно этот режим, он наиболее чисто используется при подготовке публикации. Вывод графического изображения в этом случае производится на экран монитора с пониженной разрешающей способностью. Снижение разрешения ухудшает качество, но повышает скорость вывода. Величина разрешения, использует мою InDesign в этом режиме, задается при импорте изображений в публикацию. Более подробно об импорте изображении см. главу 12.
  • Full Resolution Images. В этом режиме на экран выводится оригинал импортированного файла растрового графического изображения, например, к формате TIFF. В некоторых случаях размеры такого файла могут быть очень большими, что приводит к большим затратам времени на их отображение. Правда, при этом качество изображения получается высоким.

Несмотря на то что это прописная истина, отметим еще раз, что печать InDesign осуществляет из графических файлов, а не с экрана монитора, потому качество экранного изображения и режим отображения никоим образом нс пеняют на качество печати!

Быстро изменить качество отрисовки изображений в публикации, не тратя времени на манипуляции с диалоговым окном Preferences, можно нажатием клавиш <Ctrl>+<Shift>+<F5>. Если, например, текущим был режим Proxy Images, то первое нажатие этой комбинации клавиш установит режим Gray Out Images, второе переключит режим на Full Resolution Images, а третье — снова вернет его к Proxy Images.

Список View в области Page Numbering переключает режим показа нумерации страниц в палитре Pages (рис. 3.3):

  • Absolute Numbering. Все страницы публикации нумеруются в палитре Pages по порядку.
  • Section Numbering. Страницы в палитре нумеруются в соответствии с разбивкой на разделы. Нумерация страниц в каждом разделе устанавливается независимо с помощью команды Section Options меню палитры Pages.

Подчеркнем, что выбор в списке View влияет только на то, что вы видите в палитре Pages. В окне документа нумерация всегда отображается согласно разбивке на разделы. Подробнее о разбивке публикации на разделы см. главу 15.

а [image] б

Рис. 3.3. Варианты показа нумерации страниц в палитре Pages: Absolute Numbering (а) и Section Numbering (б)

Флажок Show Tool Tips переключает показ подсказок по всем элементам интерфейса InDesign. Начинающим установка флажка облегчит ориентацию в множестве полей и кнопок, которые приходится использовать и повседневной работе.

Флажок Overprint Black включает печать черной краской с наложением вcex объектов, имеющихся в публикации. Печать черной краской с наложением используют в подавляющем большинстве случаев, хотя не обходится и без исключений. Не сбрасывайте флажок, если не имеете для этого веских причин. Подробнее о печати с наложением см. главу 19.


Раздел Text

Размеры и положение верхних и нижних индексов, а также величина строчных символов капители вычисляется исходя из кегля шрифта. Размер символов в процентах от кегля основного шрифта задается в полях области Character Settings раздела Text диалогового окна Preferences (рис. 3.4). В поле Size указываются размеры верхних (Superscript) и нижних (Subscript) индексов. На рис. 3.5 приведены примеры индексов разного размера.

Положение базовой линии индекса относительно базовой линии строки он определяется значением полей Position для верхних и нижних индексов. По умолчанию индексы смещены на 1/3 кегля шрифта вверх и вниз. Положительное число в поле Superscript соответствует смещению индекса вверх, и и поле Subscript — вниз. На рис. 3.6 приведены примеры различного положения верхних и нижних индексов.

Относительный размер строчных символов капители устанавливается в поле Size строки Small Cap. На рис. 3.7 приведены примеры капители с различным размером строчных символов.

Рис. 3.4. Диалоговое окно Preferences, раздел Text

Рис. 3.5. Примеры индексов разного размера

Рис. 3.6. Примеры различного положения верхних и нижних индексов а), б), и в) — верхний индекс; г), д), е) — нижний индекс; значение в поле Position: 33%, 0% и 50%, соответственно

Рис. 3.7. Примеры капители с различным размером строчных символов

Перечисленные установки имеют достаточно "хорошие" значения по умолчанию и в большинстве случаев не требуют корректировки.

В области Type Options находятся три флажка, задающие следующие режимы:

  • Anti-alias Type. Сглаживание шрифтов при отображении на экране. Чтобы края символов казались гладкими, они представляются не только черными пикселами, но и серыми. Сглаживание шрифтов происходит только на экране и никак не сказывается на печати. Оно несколько замедляет отрисовку текста, но делает его более привлекательным на вид и соответствующим тому, что получится на печати.
  • Use Typographer Quotes. Если этот флажок установлен, то прямые кавычки при наборе текста автоматически заменяются на типографские (в просторечии "лапки").
  • Automatically Use Correct Optical Size. Режим оптически точной автоматической регулировки размеров отдельных символов шрифтов. Работает только со шрифтами MultipleMaster, имеющими ось оптического размера. Шрифты MultipleMaster вместе с новой технологией InDesign обеспечивают идеальное качество шрифтового оформления. К сожалению, создание таких шрифтов пока исключительно трудоемко, и на рынке кириллических шрифтов они не представлены.


Раздел Composition

Выключка текста — это способ размещения слов в строках (посередине, по правому краю, растягивание по формату колонки и т. д.). Понятие выключки и связанные с ней параметры InDesign обсуждаются в главе 7.

Если в строке нарушены заданные значения пробелов между словами и символами, она превращается в жидкую или излишне плотную.

Чтобы избежать неравномерного размещения текста в строках при выключке по формату, а этот тип встречается чаще всего, издательские системы используют изощренные алгоритмы. Чаще всего применяется однострочный

алгоритм выключки. Программа, обрабатывая строку, определяет наиболее "выгодные" точки переносов и старается равномерно распределить на ней слова и символы. Затем она переходит к следующей строке и повторяет эти операции. Такой алгоритм обеспечивает в большинстве случаев вполне приемлемый результат, но практически всегда требует коррекции наиболее сложных ситуаций вручную.

В InDesign используется многострочный алгоритм выключки, дающий гораздо более качественный результат. Программа ищет наилучший вариант выключки не для одной строки, а сразу для нескольких, как бы "забегая вперед". Настройки алгоритма выключки собраны в области Adobe Multi-line Composer раздела Composition (рис. 3.8):

Рис. 3.8. Диалоговое окно Preferences, раздел Composition

  • Look ahead 0 lines. В этом поле задается число одновременно обрабатываемых строк. По умолчанию предлагается обработка шести строк, что дает хороший компромисс между качеством выключки и скоростью обработки.
  • Consider up to 0 alternatives. Поле определяет количество вариантов переноса указанного выше количества строк, которые рассматриваются при поиске оптимума. По умолчанию предлагается рассмотрение шести вариантов выключки.

Даже идеальные алгоритмы переноса и выключки требуют вмешательства верстальщика в особо сложных случаях. Если алгоритм выключки не может справиться со строкой, то появляются упомянутые выше плотные или жидкие строки, неправильные переносы. Чтобы вам было легче их обнаружить, установите флажок H&J Violations в области Highlight. Строки с дефектами выключки будут подсвечены желтым. Пороговые значения, определяющие степень плотности слов в пределах строки и условия разбиения абзацев с переходом на новую страницу, задаются в диалоговом окне Justification (или одноименном разделе диалогового окна Modify Paragraph Style Options при стилевой разметке). Включение флажка H&J Violations позволяет сразу же увидеть строки, при автоматической верстке которых InDesign не смог выполнить условия, заданные пороговыми значениями. Подробнее этот вопрос описан в главе 7.

Дефектом верстки считаются также т. н. висячие строки. Если колонка завершается первой строкой абзаца или начинается с последней строки абзаца, то эти строки считаются висячими. Чтобы исправить этот дефект, необходимо изменить значения пробелов в предыдущих абзацах так, чтобы в колонке появилась еще одна строка или одна строка исчезла. Быстро локализовать висячие строки помогает их подсветка, включающаяся флажком Keep Violations в области Highlight.

При импорте текста в InDesign из какого-либо текстового редактора может обнаружиться, что не все использованные в тексте шрифты установлены на компьютере верстальщика. При импорте InDesign выдаст предупреждение об отсутствии шрифтов, но в публикации на их месте окажутся пробелы или символы другого шрифта. Чтобы локализовать символы отсутствующих шрифтов в публикации, установите флажок Substituted Fonts в области Highlight, и они будут подсвечены розовым цветом.


Раздел Units & Increments

Для измерения размеров объектов и их координат на странице публикации используется единая система измерения, задаваемая в разделе Units & Increments диалогового окна Preferences (рис. 3.9). В области Ruler Units имеются два списка, независимо задающие единицы измерения по вертикали и горизонтали. Именно в этих единицах и будут отградуированы измерительные линейки, в этих единицах будут трактоваться числа, вводимые в поля ввода палитр и диалоговых окон. Чаще всего для обоих измерений выбирают одинаковые единицы измерения, но иногда может быть полезной и установка разных единиц. Если, например, вы верстаете чисто текстовый материал с изобилием заголовков разного уровня, то удобно установить в качестве вертикальной единицы пункты. Это облегчит отслеживание отбивок и попадание в сетку базовых линий.

В списке Horizontal задается единица измерения по горизонтали, а в списке Vertical — по вертикали. Вы можете выбрать любой из семи предлагаемых вариантов. Если вас не устроит ни один из них, выберите Custom и в расположенное правее списка поле введите величину требуемой единицы измерения в PostScript-пунктах.

Рис. 3.9. Диалоговое окно Preferences, раздел Units & Increments

Объекты, размещенные на странице публикации, можно перемещать, либо перетаскивая их мышью, либо нажимая клавиши управления курсором. В последнем случае достигается более высокая точность перемещения, если установленный в поле Cursor Key шаг достаточно мал. По умолчанию он равен 1 пункту. Поэтому каждое нажатие клавиши <4'> перемещает выделенный объект вверх на расстояние, заданное в поле Cursor Key. Если вы предпочитаете десятичную систему, то можете установить шаг равным, например, 0,5 мм или 0,25 мм.

С помощью клавиатурных сокращений можно изменять не только положение объектов, но и настраивать параметры текста: кегль, интерлиньяж, смещение базовой линии, кернинг и трекинг. Шаг изменения этих параметров текста также задается в области Keyboard Increments диалогового окна Preferences. Поле Size/Leading задает шаг изменения кегля и интерлиньяжа в пунктах, поле Baseline Shift содержит шаг изменения смещения базовой линии в пунктах, а поле Kerning — шаг изменения кернинга в тысячных долях круглой шпации.


Раздел Grids

При размещении объектов на странице публикации большую помощь оказывают вспомогательные линии: сетки и направляющие. Настройке параветров сеток и посвящен раздел Grids диалогового окна Preferences (рис. 3.10). В InDesign используются сетки двух типов: координатная сетка и сетка базовых линий (рис. 3.11), Первая используется для выравнивания элементов публикации на странице, а вторая — для выравнивания строк текста в колонках.

Рис. 3.10. Диалоговое окно Preferences, раздел Grids

а

б

Рис. 3.11. Координатная сетка (а) и сетка базовых линий (б)

Для точного выравнивания вспомогательные линии обладают свойством "примагничивать" те размещаемые объекты, которые приближаются к ним на определенное расстояние. Координатная сетка представляет собой регулярно распределенные вертикальные и горизонтальные вспомогательные линии, напоминающие миллиметровую бумагу. В области Document Grid задаются параметры сетки:

  • Color. Цвет линий сетки. По умолчанию он принят серым, но вы можете выбрать из раскрывающегося списка любой из 27 именованных цветов. Вариант Other в этом списке открывает палитру цветов Windows, в которой вы можете выбрать для линий сетки произвольный цвет.
  • Gridline every. Шаг больших делений сетки. По умолчанию он равен одному дюйму.
  • Subdivisions. Количество маленьких делений сетки. По умолчанию 8.

По умолчанию настройки координатной сетки ориентированы на американскую систему мер. Если вы предпочитаете метрическую, то можете легко получить полный аналог привычной миллиметровой бумаги. Для этого достаточно ввести в поле Gridline every 10 mm, а в поле Subdivisions — 10.

Сетка базовых линий имеет аналогичные настройки цвета в поле Color и шага в поле Increment every. В отличие от координатной сетки, для сетки базовых линий определяется начало, необходимое для точного выравнивания строк относительно полей страницы. Оно задается в поле Start.

Линии сетки базовых линий расположены достаточно часто и при мелком масштабе просмотра практически могут сделать макет совершенно нечитаемым. Чтобы избежать этого, в списке View Threshold области Baseline Grid раздела Grids, можно задать минимальный масштаб отображения документа, при котором показывается сетка базовых линий. По умолчанию величина порогового масштаба равна 75%. Таким образом, если вы рассматриваете, например, текст в масштабе 50%, сетка базовых линий не видна, а в масштабе 100% — видима.


Раздел Guides

Направляющие линии (или просто направляющие), настройкам которых посвящен этот раздел диалогового окна Preferences, тоже являются вспомогательными линиями (рис. 3.12). Они не выводятся на печать и предназначены для выравнивания объектов на странице публикации. Если при перемещении любой объект окажется недалеко от направляющей линии, то "примагнитится" к ней. Расстояние, на котором действуют "магнитные" свойства направляющих, задается в поле Snap to Zone в пикселах. То, что зона выравнивания указывается в пикселах, гарантирует ее постоянство независимо от масштаба просмотра документа.

Направляющие линии для InDesign тоже являются объектами и размещаются на заданном слое документа. Несмотря на это они всегда отображаются либо впереди, либо позади остальных объектов, в зависимости от состояния флажка Guides in Back в области Guide Options. Если флажок установлен, то направляющие показываются позади всех объектов публикации: импортированной и созданной в InDesign графики, текстовых блоков. При снятом флажке направляющие показываются поверх всех этих объектов.

Рис. 3.12. Диалоговое окно Preferences, раздел Guides

Даже если направляющие располагаются позади объектов и перекрыты ими, они сохраняют свои магнитные свойства. Иными словами, вы можете выровнять по направляющей объект, даже если эта направляющая полностью закрыта другим объектом.

В InDesign различаются два особых вида направляющих: направляющие полей и колонок. Их цвет задается в списках Color областей Margins и Columns соответственно. Цвет остальных направляющих задается произвольным образом в диалоговом окне Ruler Guides, открывающемся одноименной командой меню Layout. Более подробно все вопросы, связанные с выравниванием, рассмотрены в главе 16.


Раздел Dictionary

В стандартную поставку InDesign нходят словари переноса и орфографии для 21 языка (к сожалению, за исключением русского). Раздел Dictionary диалогового окна Preferences позволяет выбрать для каждого из языков словарь, используемый программой (рис. 3.13). Разумеется, этот выбор имеет смысл, если для каких-либо языков у вас имеется несколько разных словарей, например, от разных производителей.

Рис. 3.13. Диалоговое окно Preferences, раздел Dictionary


Установки Color Settings

Меню File содержит вложенное меню Color Settings, команды которого открывают диалоговые окна настройки системы управления цветом InDesign. Система управления цветом ( Color Management System, CMS) не осуществляет цветокоррекцию: она не может из "плохого" изображения сделать "хорошее". Задача системы управления цветом состоит в точной передаче цветов между всеми устройствами, занятыми в подготовке и печати публикаций (сканеров, мониторов, принтеров, типографских станков, и т. п.). Чтобы решить эту задачу, системе управления цветом требуются точные описания всех параметров цветопередачи для каждого устройства. Процесс получения таких описаний называется калибровкой, а сами описания представляются в виде цветовых профилей. Таким образом, система управления цветом работает только с калиброванными устройствами.

В поставку InDesign входят системы управления цветом Adobe (Adobe CMS) и Kodak (Kodak Precision CMS). Вы можете работать с любой из них или установить CMS другого производителя. Выбор системы управления цветом, используемой по умолчанию, осуществляется в диалоговом окне Application Color Settings, открывающемся одноименной командой вложенного меню Color Settings (рис. 3.14).

Раскрывающийся список Engine содержит перечень всех установленных на вашем компьютере CMS. Ниже, в области System Profiles находятся три

списка, в которых следует выбрать профили для используемого оборудования:

  • Monitor. Профиль монитора обеспечивает правильное отображение цветов публикации на экране. Профиль монитора можно приблизительно построить с помощью специальной утилиты Adobe Gamma, входящей в поставку InDesign. Для более точного построения профиля монитора используют спектрофотометры.
  • Composite. Профиль цветного принтера, на который выводится предварительный макет или цветопроба. Для построения профиля композитного принтера необходим денситометр.
  • Separations. Профиль устройства, печатающего цветоделение: цветопробного принтера или печатной машины. Этот профиль может использоваться для цветоделения публикации при печати (см. ниже).

Рис. 3.14. Диалоговое окно Application Color Settings

Флажки в области Options управляют преобразованием профилей при выводе:

  • Simulate Separation Printer on Monitor. Имитировать на экране цвета, которые получатся после печати цветоделенной публикации.
  • Simulate Separation Printer on Composite Printer. Имитировать цвета, получающиеся при печати цветоделенной публикации на цветном принтере.
  • Use Device Independent Color when Printing. Если этот флажок установлен,то управление цветом при печати осуществляется не InDesign, а интерпретатором PostScript принтера. InDesign только передает интерпретатору дополнительную информацию о профилях изображений, использованных в публикации (исходные профили) и профиль устройства, на котором осуществляется печать (целевой профиль). При таком способе управления цветом становится доступным флажок Download CRDs to Printer. Если он установлен, то данные о целевом профиле (Color Rendering Dictionary, CRD) — так называется эквивалент цветового профиля в языке PostScript) — принтеру не передаются. При этом предполагается, что он сам "знает" свой цветовой профиль и может его использовать для преобразования цветов из исходных профилей.

Не все изображения, которые размешены в публикации, могут иметь цветовые профили. Если информация об исходном профиле объекта отсутствует, то вы можете использовать для него любой профиль. Профили по умолчанию задаются в диалоговом окне Document Color Settings, открывающемся одноименной командой вложенного меню Color Settings (рис. 3.15).

Рис. 3.15. Диалоговое окно Document Color Settings

В верхней части диалогового окна Document Color Settings находится флажок Enable Color Management. Если его не установить, то система управления цветом будет отключена!

В области Source Profiles находятся три списка. В них вы можете выбрать исходные цветовые профили для объектов, которые ими не располагают. Разумеется, для объектов в разных цветовых моделях используются разные профили: CMYK, LAB, и RGB.

Устройства, занятые в полиграфическом процессе, имеют различные цветовые охваты. Иными словами, не все цвета, передаваемые одним устройством, могут быть переданы на другом. Наиболее типичный пример — монитор и принтер. На принтере невозможно полупить, например, тот ярко-зеленый цвет, который вы видите на мониторе. Для цветов, которые выходят за пределы цветового охвата целевого устройства, система управления цветом выбирает

гот вариант преобразования, который указан в области Rendering. Intent диалогового окна Document Color Settings. Для точечных изображений и векторной графики можно использовать различные схемы. Вот они:

  • Perceptual. Сохраняются относительные значения цветов. Цветовой охват одного устройства проецируется на охват другого. Этот метод вызывает сдвиг всех цветов, даже если они имеют точное представление в другом модели. Способ хорошо работает преимущественно для точечных изображений.
  • Saturation. Система управления цветом старается сохранить насыщенность цветов. Если преобразуемый цвет выходит за пределы охвата новой цветовой модели, то он заменяется близким по насыщенности.
  • Relative Colorimetric. Ориентирован на точное преобразование цветов, попадающих в цветовой охват обоих устройств. Цвета, для которых точное преобразование невозможно, заменяются менее яркими.
  • Absolute Colorimetric. Аналогичен Relative Colorimetric, но не осуществляет поправку на новые значения черного и белого цветов. Используется для точной передачи отдельных цветов, например желтого цвета Kodak или красного цвета логотипа Coca Cola. В других случаях не рекомендуется.

Исходные профили и метод преобразования цветового охвата задаются в диалоговом окне Document Color Settings по умолчанию. Если вы хотите назначить отдельным импортированным объектам индивидуальные исходные профили, то это легко сделать с помощью диалогового окна Image Color Settings. Это диалоговое окно и системы управления цветом более подробно освещены в главе 5.


Редактирование клавиатурных сокращений

Используя вместо команд меню и палитр их клавиатурные эквиваленты, вы можете очень существенно повысить скорость работы. В InDesign разработчики Adobe впервые предоставили пользователю возможность редактирования клавиатурных сокращений всех команд. Наборы определений клавиатурных сокращений можно сохранить в файл и перенести на другой компьютер или использовать на своем повторно. Вы можете создать несколько наборов определений и менять их при необходимости.

Разработчики создали два предопределенных набора определений клавиатурных сокращений: для пользователей продуктов Adobe и для пользователей QuarkXpress. Если вы имеете опыт работы в Adobe Illustrator или Adobe Photoshop, то оставьте набор, принятый по умолчанию. Подавляющее большинство клавиатурных сокращений в InDesign будут аналогичны тем, к которым вы привыкли, используя другие продукты Adobe. Если же вы переходите на InDesign с QuarkXPress, то установите второй предопределенный набор. Он содержит клавиатурные сокращения, которые используются для аналогичных команд в QuarkXРress.

Редактирование наборов клавиатурных сокращений осуществляется в диалоговом окне Edit Shortcuts, открывающемся одноименной командой меню File (рис. 3.16).

Рис. 3.16. Диалоговое окно Edit Shortcuts

Верхний раскрывающийся список Set в диалоговом окне Edit Shortcuts содержит перечень наборов клавиатурных сокращений. Если вы еще не определили собственные наборы, то он содержит два варианта, о которых мы говорили выше: Default и QuarkXPress 4.0. Кнопка New Set, расположенная правее, открывает одноименное диалоговое окно создания нового набора (рис. 3.17). Поле Name этого диалогового окна должно содержать имя нового набора клавиатурных сокращений. Вы можете ввести в него произвольное имя. Список Based on Set позволяет выбрать любой из уже определенных наборов, который будет скопирован во вновь создаваемый. Это позволит вам не назначать все команды заново, а только корректировать отдельные. Нажатие кнопки ОК завершит создание нового набора и вернет вас в диалоговое окно Edit Shortcuts.

Список Product Area, расположенный под списком Set, перечисляет все элементы интерфейса InDesign, которым можно назначить клавиатурные эквиваленты. Конкретные команды, которые поддерживаются этими элементами интерфейса, перечислены в списке Commands. Итак, чтобы определить или переопределить клавиатурное сокращение, следует:

  1. Выбрать созданный вами набор клавиатурных сокращений в списке Set. Заметьте, что InDesign не даст вам отредактировать наборы Default или QuarkXPress 4.0, а вместо этого предложит создать новый набор на основе одного из предопределенных.
  2. Выбрать элемент интерфейса; который реализует команду, в списке Product Area.
  3. Выбрать команду списка Commands щелчком на ее строке. В списке Current Shortcuts появится перечень клавиатурных эквивалентов выделенной команды. Если команда не имеет клавиатурного эквивалента, то список Current Shortcuts будет пуст.
  4. Активизировав поле Press New Shortcut, нажать клавиши, которые вы намерены ассоциировать с командой.
  5. Нажать кнопку Assign или Replace. Она имеет первое название, если с командой не ассоциировано ни одно клавиатурное сокращение, и второе — если ассоциировано.

Рис. 3.17. Диалоговое окно New Set

Лишние клавиатурные сокращения для команды легко удалить. Для этого надо выделить их в списке Current Shortcuts и нажать кнопку Remove, которая появляется на месте кнопки Assign или Replace.

Созданный набор команд сохраняется в файл кнопкой Save. Вы можете нажимать ее не только по завершении работы, но и в любой момент редактирования.

Полезная команда ShowSet открывает редактор Notepad (Блокнот) со списком всех определенных и не определенных клавиатурных сокращений. Распечатав его на принтере, вы получите отличное пособие, которым можете пользоваться при изучении клавиатурных сокращений, пока не запомните их.

Наборы клавиатурных сокращений хранятся в файлах папки \Shortcut Sets, вложенной в папку InDesign, и имеют расширение indk. Вы можете переписать их на другой компьютер и таким образом перенести созданный вами набор. При переустановке программного обеспечения или для страховки от сбоев заархивируйте файлы с наборами на какой-либо носитель (дискету, CDR, магнитооптический диск, и т. п.).


Служба Adobe Online

Служба Adobe Online обеспечивает поддержку пользователей InDesign через Internet. Используя ее, вы можете получить доступ к обновлениям программы, дополнительной информации о ее возможностях, подписаться на периодическую рассылку.

В меню Preferences имеется особая команда Online Settings, открывающая установки службы Adobe Online (рис. 3.18).

Рис. 3.18. Диалоговое окно Adobe Online Preferences, вкладка General

На вкладке General находятся установки соединения с Internet и получения автоматических обновлений. Если параметры соединения с Internet на вашем компьютере правильно указаны в конфигурации Windows (апплет Internet Options в Control Panel), то достаточно установить флажок Use system default Internet settings, и InDesign сможет соединиться с сайтом Adobe Systems (http://www.adobe.com). Если ваша сеть имеет брандмауэр (firewall), то введите его адрес в поля HTTP и FTP, а в поля справа введите номера портов брандмауэра, поддерживающие эти сервисы (типичное значение номера порта брандмауэра 3128). В поле Bypass proxies for these hosts введите имена компьютеров вашей сети, обращение к которым должно происходить минуя брандмауэр.

В области Update Options сосредоточен контроль за обновлениями службы Adobe Online. Список Refresh предлагает несколько вариантов отслеживания обновлений:

  • Manually. Перечень обновлений загружается нажатием кнопки Refresh в диалоговом окне Adobe Online Preferences.
  • Once a Day. InDesign автоматически ежедневно соединяется с сервером Adobe и проверяет наличие обновлений.
  • Once a Week. InDesign автоматически еженедельно соединяется с сервером Adobe и проверяет наличие обновлений.
  • Once a Month. InDesign автоматически ежемесячно соединяется с сервером Adobe и проверяет наличие обновлений.

Рис. 3.19. Диалоговое окно Adobe Online Preferences, вкладка Application

Флажок Download Hies in background устанавливает загрузку обновлений в фоновом режиме. Вы сможете получать обновления программы, не прерывая работу в ней. Automatically install download files включает автоматическую установку загруженных обновлений. И, наконец, флажок Automatically download updates to Adobe Online задает автоматическую загрузку обновлений самой программы соединения со службой Adobe Online.

Вкладка Application (рис. 3.19) предоставляет контроль над уведомлениями об обновлениях Adobe Online. Вы можете установить выдачу сообщений о найденных обновлениях по двум разделам:

  • New downloadable files found. Уведомления об обновлениях программы InDesign или новой документации (рис. 3.20).
  • New Adobe corporate news found. Последние новости о программном обеспечении фирмы Adobe Systems.

Рис. 3.20. Диалоговое окно Downloadables

Флажок Downloads are complete устанавливает уведомление об окончании загрузки файлов службы Adobe Online.

Если вам удобнее получать информацию от Adobe Online по электронной почте, то подпишитесь на периодическую рассылку, установив переключатель Yes в области Subscription Options. При этом необходимо убедиться, что вы ввели ваш адрес электронной почты и имя пользователя в поля E-mail и User Name на вкладке General диалогового окна Adobe Online Preferences.


Задание умолчаний с помощью меню и палитр

Как уже упоминалось выше, умолчания можно задавать и для элементов меню InDesign. Пункты меню, доступные в отсутствие открытого документа, позволяют задавать соответствующие умолчания. Далее приведен полный перечень позиций меню, которым можно задавать значения по умолчанию. Не забывайте, что с помощью этих позиций вы можете задавать не только локальные, но и глобальные умолчания (которые распространятся на все создаваемые впоследствии публикации).


Меню File

  • Все управляющие элементы в диалоговых окнах, вызываемых из вложенного меню Preferences, Color Settings, Edit Shortcuts, рассмотренного выше.
  • Все управляющие элементы диалогового окна Document Setup. Они задают параметры страниц документа: их количество, размер и ориентацию.


Меню Layout

  • Элементы управления диалогового окна команды Margins and Columns. Устанавливают размеры полей, количество и ширину колонок для всех страниц документа по умолчанию.
  • Элементы управления диалогового окна команды Ruler Guides. Задают цвет направляющих линий и их порог видимости по умолчанию.
  • Диалоговое окно Layout Adjustment. Задает параметры автоматической коррекции макета при изменении параметров страницы-


Меню Type

Все элементы меню Type, кроме Create Outlines и Insert Character, поскольку эти команды имеют смысл только для объектов, уже существующих в документе.

  • Средства быстрого форматирования — команды Font и Size.
  • Переключатель режима отображения скрытых символов (символов абзаца, новой строки и табуляции) Show Hidden Characters.

Остальные команды меню Type открывают или активизируют различные палитры, связанные с форматированием текста. Используя элементы управ-ления этих палитр, вы создадите умолчания:

  • -Character. Умолчания, касающиеся формата вводимых символов: гарнитура шрифта, начертание, кегль, интерлиньяж, кернинг, трекинг, ширина, высота, наклон, смещение базовой линии и язык.
  • Paragraph. Умолчания, касающиеся форматирования абзацев: тип выключки, абзацный отступ, отбивки, параметры буквиц, расстановка переносов.
  • Tabs. Положение позиций табуляции и их тип по умолчанию.
  • Story. Управление оптическим выравниванием текста по границам колонок и "вывешиванием" знаков препинания.
  • Character Styles. Символьные стили, включаемые в каждый новый документ по умолчанию. С помощью палитры вы можете создать такой набор стилей и задать все параметры каждого из них.
  • Paragraph Styles. Абзацные стили, включаемые в каждый новый документ по умолчанию. С помощью палитры вы можете создать такой набор стилей и задать все параметры каждого из них.


Меню Object

  • Диалоговое окно Text Frame Options, задающее все параметры текстовых фреймов по умолчанию.
  • Форма углов прямоугольников, задаваемая в диалоговом окне Corner Effects, открывающемся одноименной командой.
  • Параметры создания обтравочных контуров в диалоговом окне, открывающемся командой Clipping Paths.
  • Параметры обтекания текстом, задаваемые в палитре Text Wrap. Она открывается одноименной командой меню Object.


Меню View

  • Показ размещения текста по фреймам командой Show/Hide Text Threads.
  • Показ границ фреймов командой Show/Hide Frame Edges.
  • Показ координатных линеек командой-переключателем Show Rulers.

Режимы направляющих:

  • Показ направляющих командой Show/Hide Guides.
  • Привязка к направляющим командой-переключателем Snap to Guides.
  • Блокировка направляющих командой-переключателем Lock Guides.

Режимы координатной сетки и сетки базовых линии:

  • Показ линий координатной сетки командой Show/Hide Document Grid.
  • Показ линий сетки базовых линий командой Show/Hide Baseline Grid.
  • Привязка к координатной сетке командой-переключателем Snap to Document Grid.


Меню Window

Команды меню Window управляют показом большинства палитр InDesign. Только для некоторых из них возможно создание умолчаний:

  • Палитра Colors позволяет задать основной и фоновый цвета по умолчанию.
  • С помощью палитры Gradient задаются тип и цвета градиентных заливок или обводок по умолчанию.
  • Палитра Swatches включает те образцы цветов и градиентов, которые будут присутствовать в каждом вновь создаваемом документе.
  • Атрибуты обводок по умолчанию задаются в палитре Stroke.


Резюме

  • Параметры вновь создаваемых объектов и документов в InDesign определяются умолчаниями.
  • В TnDesign имеются два вида умолчаний: локальные и глобальные. Локальные умолчания действуют в пределах открытого документа, а глобальные — для всех вновь создаваемых документов.
  • Умолчания создаются непосредственным указанием требуемых параметров в специализированных диалоговых окнах, командами меню и палитр. Не для всех меню и палитр возможно создание умолчаний.
  • Точность передачи цветов всеми компонентами оборудования, используемого при подготовке и печати публикации, обеспечивается системами управления цветом. InDesign поддерживает множество систем управления цветом и поставляется с двумя из них: Adobe CMS и Kodak Precision CMS. Установки параметров и профилей CMS являются глобальными умолчаниями InDesign.
  • В InDesign имеется возможность настройки клавиатурных сокращений любых команд. По умолчанию используются сокращения, принятые по всей линейке издательских программ Adobe Systems: PageMaker, Illustrator, Photoshop. Альтернативный набор клавиатурных сокращений аналогичен применяемым в издательской системе QuarkXPress.


Глава 4

Цвет и его применение в публикации

Основной характеристикой любого объекта на странице документа, наряду с размером и положением, является его цвет. Цветовая гамма определяет внешний вид публикации. Кроме того, объект вообще можно увидеть, только если ему присвоен какой-нибудь цвет.

InDesign вполне способен работать с цветом на современном уровне. Для большинства объектов (векторная графика, фреймы, текст, монохромные и полутоновые растровые изображения) он позволяет произвольно назначать и редактировать цвета. Цвета цветных растровых изображений не определяются и не редактируются в InDesign.

В этой главе мы рассмотрим следующие вопросы:

  • Математическое описание цветов и цветовые модели
  • Определение цветов в InDesign — смешивание и каталог готовых образцов
  • Назначение заливок и обводок элементам публикации
  • Градиентная заливка и обводка — присвоение объектам переходов цвета.


Описание цвета

Цвет в понимании физика — это синоним длины волны света в видимой области. Однако для художника или полиграфиста этот гипотетический цвет совершенно не важен. Для нас принципиально, как будет выглядеть цвет для наблюдателя, т. е. физическая величина становится связана с биологическим процессом цветного зрения. В глазу человека есть цветочувствительные элементы, воспринимающие отдельные компоненты цвета объектов. Затем в головном мозге данные обрабатываются и синтезируется цвет. У разных людей чувствительность этих элементов различна. Обработка также происходит по-разному.

Однако задача точного описания цвета тем не менее существует. В производстве полиграфической продукции, при выпуске фильмов и телепередач, вообще везде, где конечный продукт имеет окраску, необходимо соответствие этого цвета неким образцам. Во многих случаях к корректности цветопередачи предъявляются жесткие требования, например в высококачественной полиграфии. Для того чтобы использовать цвет в процессе работы над изображениями и публикациями, необходимо его описать в цифровом виде, т. е. кодировать. Ведь только в этом случае программа графического приложения поймет, в какой цвет вы хотите раскрасить данный объект.

Кодирование цвета — очень непростая задача. В каких единицах измерить цвет? Что взять за точку отсчета? Как выразить бесконечное число видимых цветов с помощью небольшого числа переменных? Существует несколько способов математического описания цвета, называемых цветовыми моделями. Описание цвета на основе цветовой модели основано на следующем положении: путем смешивания нескольких базовых или основных цветов можно получить остальные цвета, называемые составными. Таким образом, цвет можно математически описать как соотношение базовых компонентов (создать модель цвета).

Примером составления сложного цвета на основе базовых является рисование красками. Из тюбиков выдавливаются краски базовых цветов (например, синий и желтый). После смешения их на палитре или на бумаге образуется краска смешанного (зеленого) цвета. В зависимости от соотношения базовых компонентов варьируются оттенки зеленого.

Параметры цвета могут быть выражены с помощью многих цветовых моделей, в зависимости от того, какие компоненты цвета считать базовыми. Наиболее часто для работы в графических пакетах и для передачи данных используются цветовые модели RGB, CMYK, Lab. Иногда в процессе создания цветов используется и приблизительное описание цвета HSB.


Цветовой охват

Диапазон цветов, который может быть воспроизведен, зафиксирован или описан каким-либо способом, называется цветовым охватом. Определенный цветовой охват имеют электронно-лучевые трубки мониторов и полиграфические краски (диапазон цветов, который они могут воспроизвести), цветовые модели (диапазон цветов, который они могут описать) и, конечно, человеческий глаз (диапазон воспринимаемых им цветов). Многое из того, что воспринимает глаз, может передать монитор (на экране нельзя точно передать, например, чистый голубой и чистый желтый цвет). Часть того, что передает монитор, можно напечатать (например, при полиграфическом исполнении совсем не передаются цвета, составляющие которых имеют очень низкую плотность). Разность цветовых охватов представлена схемой на рис. 4.1, На этом рисунке показан охват человеческого глаза (соответствует модели цвета Lab), монитора, отображающего цвета в модели RGB, и офсетного станка, являющегося CMYK-устройством.

Рис. 4.1. Цветовой охват

Цвета образуются в природе по-разному. С одной стороны, источники света (солнце, лампочки, экраны компьютеров и телевизоров) излучают световые волны различной длины, воспринимаемые глазом как цветной свет. Попадая на поверхности несветящихся предметов, свет частично поглощается, а частично отражается. Отраженное излучение воспринимается глазом как окраска предметов. Таким образом, цвет объекта возникает в результате излучения или отражения. В первом и во втором случае описание цвета объекта отличается, т. е. для его описания применяются разные модели цвета.

Увидеть и определить цвет и параметры моделей можно на палитре Color.


Модель RGB

Эта модель описывает излучаемые цвета. Модель RGB основана на трех базовых цветах — Red (Красный), Green (Зеленый), Blue (Синий). Остальные цвета образуются при смешивании этих трех основных. При сложении (смешении) двух лучей основных цветов результат светлее составляющих. Цвета этого типа называются аддитивными (рис. 4.2).

Рис. 4.2. Аддитивная цветовая модель: RGB

При смешении красного и зеленого получается желтый, при смешении зеленого и синего получается голубой, синий и красный дают пурпурный. Заметим, что речь идет именно о цветных лучах света, а не о привычных нам отраженных цветах. Смешение лучей обязательно даст в результате более светлый луч, чем исходные лучи (усиливается освещение). Если смешиваются все три цвета, в результате образуется белый. Смешав три базовых цвета в разных пропорциях, можно получить все многообразие оттенков. Базовые цвета иначе называются компонентами или каналами. RGB — трехканальная цветовая модель. В модели RGB кодирует изображение сканер, отображает монитор и воспринимает человеческий глаз, поэтому можно считать ее основной моделью.

Модель RGB можно представить себе в виде трехмерного куба, по трем осям которого откладываются значения компонентов (рис. 4.3). В начале координат все составляющие равны нулю, излучение отсутствует (черный цвет). В точке, противоположной началу координат, все составляющие имеют максимальное значение (белый цвет). На линии, соединяющей эти точки по диагонали, три составляющих одинаковы и располагаются в диапазоне от нуля до максимального значения. Они образуют серые оттенки от черного до белого — серую шкалу. Три вершины куба отображают чистые исходные цвета, остальные три — двойные смешения исходных цветов.

Рис. 4.3. Модель RGB

Количество каждого компонента RGB выражается либо в процентах (реже), либо числами от 0 до 255. Всего получается 256 оттенков каждого компонента и 256 оттенков серого.

Почему 256 оттенков?

На каждый канал изображения в памяти компьютера отводится какое-то количество бит. Для монохромного достаточно 1 бита, в этом случае максимально возможное число цветов 2 (21=2). Для описания полутонового изображения от-

водится 8 бит. 256 — максимально возможное число значений восьми битного канала (28=256). Этого достаточно, чтобы передать оттенки серого. Каждый канал полноцветного изображения представляет собой восьми битное полутоновое изображение; максимальное число градаций канала, таким образом, составляет те же 256.

Модель RGB аппаратно зависима. Когда цвет в модели RGB отображается на экране монитора, значения компонентов — это, практически, напряжение, подаваемое на каждую из лучевых трубок. Результат зависит от характеристик устройства. На цвет, который вы увидите, оказывают влияние оттенки люминофора, его яркость и пр. Цвета, имеющие одни и те же характеристики, будут выглядеть по-разному на двух мониторах. При сканировании наблюдается та же ситуация — один и тот же цветной оригинал при сканировании разными сканерами дает цвета с различающимися характеристиками.

Чтобы убедиться в аппаратной зависимости модели RGB, подкрутите движок яркости вашего монитора. Не правда ли, цвета изменились? А между тем, вы не меняли их характеристики!


Модель CMYK

Несветящиеся объекты поглощают часть спектра белого света, освещающего их, и отражают оставшееся излучение. В зависимости от того, в какой области спектра происходит поглощение, объекты отражают разные цвета и представляются ими окрашенными. Цвета, которые образуются отражением части спектра белого цвета, называются субтрактивными ("вычитательными") (рис. 4.4).

Для их описания используется модель CMY. В этой модели основные цвета образуются путем вычитания из белого цвета основных аддитивных цветов модели RGB. Понятно, что в таком случае и основных субтрактивных цветов будет три: голубой (белый минус красный), пурпурный (белый минус зеленый), желтый (белый минус синий). При смешениях двух субтрактивных составляющих результирующий цвет затемняется (поглощено больше света, положено больше краски). Таким образом, при смешении максимальных значений всех трех компонентов должен получиться черный цвет. При полном отсутствии краски (нулевые значения составляющих) получится белый цвет (белая бумага). Смешение трех компонентов в равных количествах даст оттенки серого. Модель CMY (рис. 4.5) можно представить себе в виде трехмерного куба, аналогичного представлению RGB с перемещенным началом координат.

Данная модель используется для печати цветных изображений. Пурпурный, голубой, желтый цвета составляют так называемую полиграфическую триаду.

При печати этими красками довольно большая часть видимого цветового спектра может быть репродуцирована на бумаге. Ясно, что модель CMY аппаратно зависима — ведь в образовании цвета, участвуют краски и бумага. В зависимости от их свойств, цвет, имеющий одни и те же характеристики, будет выглядеть по-разному.

Рис. 4.4. Субтрактивные цвета. Модель CMY

Рис. 4.5. Цветовая модель CMY

Описание цвета с помощью CMY приводит к возникновению нескольких серьезных проблем.

Во-первых, реальные краски имеют примеси и оттенки посторонних цветов. Смешение трех основных красок в результате дает неопределенный грязно-коричневый, а не черный цвет. Кроме того, для получения интенсивного черного необходимо положить на бумагу большое количество краски каждого цвета. Это приведет к переувлажнению бумаги, причем качество печати снизится. К тому же неэкономно расходуется краска. Для улучшения качества отпечатка в число основных полиграфических красок (и в модель) внесена черная. Именно по этой причине добавлена последняя буква в название модели CMYK, хотя и не совсем обычно: С — это Cyan (Голубой), М — это Magenta (Пурпурный), Y — Yellow (Желтый). Название черного компонента сокращено до буквы К (BlacK или Key — ключевая). Число компонентов (каналов) увеличилось до четырех. CMYK — четырехканальная цветовая модель. Как и для модели RGB, количество компонента может быть выражено в градациях от 0 до 255 или, реже, в процентах. Иллюстрации, содержащие большое количество цветов, печатаются четырьмя красками базовых цветов модели CMYK. Цвета, печатаемые таким способом, называются триадными.

Другая проблема заключается в узости цветового охвата CMYK. При печати этим способом невозможно адекватно передать оттенки яркого синего, оранжевого, зеленого цвета. Если изображение содержит описанные цвета, тогда часто используются другие цветовые модели, с большим числом компонентов, например, модель Hexachrome, в которую кроме описанной триады и черного, входят зеленый и оранжевый цвета. Цветовой охват при печати в шесть красок значительно шире.


Плашечные цвета

Для передачи особых цветов (пастельные тона, бронза, серебро, светящиеся краски) используется плашечная печать — кроме базовых четырех красок, накладывается пятая (шестая, седьмая...). Оттенок этой краски подобран заранее, и она накладывается там, где встречается в публикации. Плашечные цвета обеспечивают довольно высокую точность воспроизведения, поэтому используются и тогда, когда нужно получить очень точный цвет (например, в логотипе компании). Плашечные цвета иначе называют простыми. Плашечные цвета широко используются и для печати публикаций, содержащих небольшое количество (до четырех, включая черный) отдельных цветов (визитки, бланки, прайс-листы, газеты и пр.). Это делается из соображений экономии.

С точки зрения печатника различие между плашечными и триадными цветами очень существенно. Краски для плашечных цветов поставляются уже смешанными (в отдельных банках), а триадные цвета получаются смешением красок на листе отпечатка. Соответственно и в компьютерных издательских системах краски для плашечных цветов выбираются из каталога, а триадные задаются пропорцией базовых компонентов. С помощью триадных красок можно передать любые цвета, а с помощью плашечных — только оттенки их собственного цвета. С другой стороны, плашечные цвета обеспечивают довольно высокую точность воспроизведения, поэтому используются и тогда, когда нужно получить очень точный цвет. Плашечные цвета иначе называют простыми.


Lab — аппаратно-независимая модель

В процессе подготовки изображения поневоле приходится конвертировать изображение из одной модели в другую (сканер — RGB-устройство; печатный станок работает с моделью CMYK). Чтобы уменьшить потери до приемлемого уровня, необходимо откалибровать все аппаратные средства от сканера (осуществляет ввод изображения), монитора (по нему судят о цвете), выводного устройства (создает оригиналы для печати), до печатного станка (конечная стадия печати). Модели RGB и CMYK связаны друг с другом, однако их взаимные переходы друг в друга (конвертирование) не происходят без потерь, поскольку две эти модели имеют разный цветовой охват. Калибровка лишь несколько сглаживает проблему. Кроме того, RGB и CMYK аппаратпо зависимы. Если речь идет о RGB, то в зависимости от примененного в вашем мониторе люминофора будут различаться базовые цвета. Точка белого также зависит от устройства монитора. В результате на разных мониторах одно и то же изображение выглядит по-разному. Если обратиться к CMYK, то здесь различие еще более ощутимо, поскольку речь идет о реальных типографских красках, особенностях как самого печатного процесса, так и носителя.

Из этого можно сделать неутешительный вывод: оригинал, сканированное изображение и отпечаток могут очень сильно различаться между собой. Мало того, цвет двух отпечатков одного и того же изображения, полученных на разных принтерах, может быть совершенно разным.

Одной из основных задач при работе с цветными изображениями становится достижения предсказуемого цвета. Для этого создана система управления цветом (CMS). Это программная система, цель которой — достижение одинаковых цветов отпечатков на всех этапах полиграфического процесса, от сканера до печатного станка. Заметим, что в полиграфический процесс входят системы, работающие на основе аппаратно-зависимых цветовых моделей — RGB (сканер, монитор) и CMYK (фотонаборная и печатная машины). Это значит, что необходим некий стандарт, к которому бы приводились цвета на всех этапах процесса.

В качестве стандарта используется цветовая модель Lab. Она была создана как аппаратно-независимая и соответствующая особенностям восприятия цвета глазом человека. Любой цвет данной модели определяется яркостью (L) и двумя хроматическими компонентами: параметром а, который изменяется в диапазоне от зеленого до красного, и параметром Ь, изменяющимся в диапазоне от синего до желтого (рис. 4.6). При изменении оба хроматических кпм-

понента проходят через серую точку, расположенную в середине шкалы. Параметры Lab изменяются от 0 до 255. Это также трехканальная модель.

Рис. 4.6. Модель Lab

Яркость в модели Lab полностью отделена от цвета. Это делает модель удобной для регулирования контраста, резкости и других тоновых характеристик изображения. Она является трехканальной. Цветовой охват модели Lab чрезвычайно широк. Он включает в себя охваты всех других цветовых моделей, используемых в полиграфическом процессе.

Суть процесса управления цветом заключается в следующем: для каждого устройства, участвующего в процессе, создается профиль, описывающий его цветовой охват. Изображение обрабатывается устройством ввода (сканером) и переводится в цветовую модель Lab. При этом программа делает поправку на особенности цветового охвата сканера (учитывает его профиль). Таким образом получаются стандартные цвета изображения. Затем изображение передается устройству вывода (монитору или принтеру). При выводе оно снова переводится в цветовую модель устройства вывода таким образом, чтобы с учетом профиля устройства получить результат, как можно более близкий к идеальному, хранящемуся в Lab.

Цветовая модель Lab очень важна для полиграфии. Именно она используется при переводе изображений из одной цветовой модели в другую, между устройствами и даже между различными платформами. Можно сказать, что Lab является переводчиком, без которого взаимопонимание систем, участвующих в процессе подготовки цветной публикации, невозможно.


Создание цвета в программе

InDesign предоставляет широкие возможности для управления цветами документа. В рамках программы осуществляется назначение и редактирование цвета, работа с градиентами, создание и редактирование каталогов цветов, выбор цветов из коммерческих каталогов. Возможен импорт цветов вместе с изображениями в формате EPS.


Типы заливок и обводок

Заливки и обводки могут быть сплошными и градиентными. Обводка, кроме цвета, имеет произвольную толщину и другие атрибуты (например, сопряжение, тип пунктира). Цвета для обводок и заливок можно выбирать в любой модели. Цвета и градиенты можно задавать произвольно и редактировать. Они хранятся вместе с документом и могут быть перенесены в другие документы и приложения. Также вместе с программой поставляются каталоги стандартных цветов для полиграфии и WWW.

InDesign позволяет задавать заливку как замкнутым, так и незамкнутым контурам, т. е. и фигурам, и линиям. Фигуры заполняются цветом целиком, а линии заливаются так, как будто их концы соединены отрезком прямой (рис. 4.7). Линии, фигуры, фреймы, текст могут иметь заливки и обводки, а. растровые изображения (полутоновые и монохромные) — заливку цветом.

Рис. 4.7. Заливки и обводки


Средства работы с цветом

Для работы с цветом в InDesign предусмотрены следующие средства:

  • Кнопки на панели инструментов (см. рис. 2.4). Большие кнопки отображают текущую заливку и обводку, с помощью маленьких кнопок к объекту применяется заливка и обводка.
  • Палитра Color. В ней из базовых компонентов смешивается нужный цвет, причем можно выбрать цветовую модель.
  • Палитра Gradient. В ней определяется вид и цвета переходов для градиентных заливок и обводок.
  • Палитра Swatches. Содержит служебные и часто используемые образцы цветов и градиентов. Они хранятся вместе с документом. Объекту можно присваивать атрибут цвета, используя эту палитру. Для этого достаточно один раз щелкнуть на необходимом образце.
  • Палитры Swatch Libraries. Библиотеки цветов хранят стандартные наборы цветов PANTONE, FOCOLTONE и др., а также позволяют импортировать цвета из других документов.

При задании цветов объектам используются инструменты выделения. Специально для определения градиентов предусмотрен инструмент Gradient.

Средства управления цветом рассмотрены подробно ниже в данной главе. Работа с ними описана на примерах — это наиболее понятный и краткий способ изложения чисто практических действий, которые нужно совершить, чтобы задать цвет объекта.


Палитра Color— синтез цветов

Собственно создание цвета производится в палитре Color. Она вызывается командой Show Color меню Window. Палитра может находиться в двух состояниях, переключаемых командой Show/Hide Options меню палитры (рис. 4.8). В состоянии (я) отображается только цветовая шкала. Справа в ней расположены кнопки черного и белого цвета, слева — кнопка None, отменяющая заливку или обводку. Остальная часть шкалы окрашена в цвета спектра различной насыщенности и яркости или в оттенки одного цвета (в зависимости от установок). Удобнее работать в раскрытой палитре (б). В ней цветовая шкала смещена вниз, а в центральной части находятся ползунки цветов и образцы цвета.

а [image] б

Рис. 4.8. Палитра Color

В палитре можно редактировать цвет в моделях RGB, CMYK и Lab. Переключение между моделями производится в меню палитры. В отличие от некоторых других программ, переключение на соответствующую модель цвета в палитре означает задание данной модели цвета в публикации. Поясним процесс создания цвета на примере.

  1. Нарисуйте любой объект, например эллипс. Пока он выделен — вы будете задавать цвет именно для этого объекта.
  2. Активизируйте палитру Colors и откройте ее меню. В этом меню выберите модель RGB. Цвет выделенного объекта будет иметь модель RGB. После выбора модели палитра приняла вид (см. рис. 4.8, б).
  3. Слева в палитре размещаются образцы обводки и заливки. Из этих двух атрибутов активен один. Именно его цвет будет редактироваться. Чтобы активизировать поле, щелкните на нем, оно переместится вперед. Щелкните попеременно на образцах заливки и обводки. Они меняются местами. Активизируйте образец заливки. Мы будем создавать цвет для заливки эллипса.
  4. Посмотрим на цветовую шкалу. Справа в ней расположены кнопки черного и белого цветов, слева — кнопка None, отменяющая цвет. Щелкните по очереди на каждой кнопке. Эллипс меняет цвет.
  5. В средней области цветовой шкалы представлен весь охват RGB. Чтобы приблизительно выбрать цвет, подведите курсор мыши в нужную область цвета и сделайте щелчок. Выбранный цвет будет присвоен выделенному объекту. Окрасьте эллипс в зеленый цвет.
  6. Теперь активизируйте образец обводки и снова выберите в меню палитры модель RGB. Увеличьте масштаб отображения, чтобы обводка была хорошо видна. Задайте эллипсу красную обводку.
  7. Для точного определения лучше воспользоваться ползунками цветов. Положение ползунков на шкалах соответствует содержанию данного компонента. Перемещая, ползунок, вы изменяете это значение. В полях справа от ползунков отмечается в численном виде содержание каждого базового компонента. Его можно ввести с клавиатуры. Поупражняйтесь в создании цветов.
  8. Если в публикации нет выделенных объектов, цвет задается по умолчанию. Отменив выделение, активизируйте заливку и задайте для нее цветовую модель CMYK. Вид палитры изменится (рис. 4.9). Теперь в ней представлены компоненты CMYK. Создайте оранжевый цвет. Активизировав обводку, щелкните на кнопке None.

    9. Рис. 4.9. Палитра Color в режиме CMYK

  9. Теперь выберите инструмент Rectangle и нарисуйте .прямоугольник. Он имеет характеристики, которые вы выбрали по умолчанию. Такую заливку и такую обводку будут иметь все вновь создаваемые контуры и фигуры, пока вы их не измените.
  10. Выберите зеленый эллипс. В палитре Colors сразу отобразятся его цветовые характеристики. Заметьте, что цвета эллипса имеют модель RGB, в то время как по умолчанию вы только что задали модель CMYK.
  11. Поменяйте модель цвета заливки на Lab. Теперь в палитре представлены шкалы компонентов А, В, и L (рис. 4.10).

Рис. 4.10. Палитра Color в режиме Lab

Таким образом, палитра Color позволяет выбрать цвет для обводки и заливки выделенного объекта и задавать цвета по умолчанию. Выбор модели в палитре присваивает эту модель созданному цвету. Интересно, что создание умолчаний цвета производится только для контуров. Текст по умолчанию — черный, без обводки, фреймы лишены и обводки, и заливки.


Какую модель выбрать

В зависимости от назначения будущей публикации мы рекомендуем создавать цвета в соответствующей цветовой модели. Если вы создаете публикацию для печати на бумаге, — это модель CMYK. Предполагаете использовать ее только для электронного распространения — определяйте цветам модель RGB. Если публикация будет распространяться на разных носителях (и на бумаге, и в электронном виде), то лучшим решением будет модель Lab.

Но какую бы модель вы ни выбрали — настоятельно рекомендуем не пользоваться в пределах одного документа цветами разных цветовых моделей Все цвета должны иметь одну и ту же модель. Оправдано лишь применение плашечных цветов совместно с составными.

Лучше определить модель цвета в палитре Color без открытых документов Она станет моделью по умолчанию. Можно определить и умолчания обводки и заливки — для этого нужно также задать их в палитре Color или Gradient при закрытых документах. Тогда все открываемые впоследствии публикации будут иметь заданные умолчания модели цвета, обводки и заливки.


Палитра Gradient— создание градиента

Заливки и обводки цветовыми переходами (градиентами) — красивый и несложный прием. Управление градиентами осуществляется в палитре Gradient. Она вызывается на экран командой Show Gradient меню Window. Так же как и Color, палитра может находиться в двух состояниях, переключаемых командой меню палитры Show Options/Hide Options (рис. 4.11).

а [image] б

Рис. 4.11. Палитра Gradient

В минимальное отображение — только схема градиента. Он управляется ползунками сверху и снизу. Нижние ползунки, похожие на короткие карандаши, — это цвета градиента. Верхние ползунки находятся между нижними и отмечают степень резкости перехода. Положение каждого их них соответствует смешению соседних цветов в соотношении 1:1. Чем ближе ползунок находится к данному компоненту градиента, тем меньше его участие в переходе и граница градиента более резкая. Если не выбран ни один объект, то на схеме отображается градиент по умолчанию. Обычно это переход от черного цвета к белому. Для редактирования цветов градиента также используется палитра Color. Ползунок цвета следует выбирать (его кончик станет черным). Выбранный цвет станет текущим в палитре Color, где его можно откорректировать.

Число цветов градиента можно менять. Для этого щелкните между нижними ползунками, в месте щелчка появится третий ползунок (рис. 4.12). После установки откорректируйте цвет ползунка в палитре Color.

Рис. 4.12. Градиент с тремя цветами переходов в палитре Gradient

При создании градиента активный образец палитры Color окрашивается этим градиентом. Если при этом был выбран объект, то градиент применяется к его обводке или заливке (смотря по тому, какой из образцов был активен). Если же активного объекта нет, то градиент создается по умолчанию для всех новых контуров.

Ползунки отмечают не только цвет, но и положение переходов. Их можно смещать, и даже менять местами. Внешний вид градиента меняется соответственно (рис. 4.13). Если ползунки совместить, то вместо плавного перехода получится резкая граница цвета.

а

б

в

Рис. 4.13. Градиенты с разным положением переходов цветов

Верхние ползунки регулируют соотношение цветов в переходе. Их смещение тоже сильно влияет на вид градиента (рис. 4.14).

Рассмотрим теперь дополнительные параметры градиента, открываемые командой Show Options меню палитры. В левой части палитры теперь расположен образец градиента в качестве обводки или заливки. Если данный образец активен, то ниже появляется маленький квадрат, окрашенный в предыдущий выбранный сплошной цвет. При щелчке на этом квадратике образцу присваивается цвет вместо градиента. Список Type позволяет выбрать тип градиента — линейный или радиальный (рис. 4.15).

а [image] б

в

Рис. 4.14. Градиент с разным соотношением цветов перехода

а

б

Рис. 4.15. Радиальный и линейный градиенты

Если выбран линейный градиент, то можно задать угол его наклона (рис. 4.16).

Поле Location становится доступным при активизации одного из верхних ползунков шкалы. Значение 50% соответствует расположению ползунка точно посередине между соседними компонентами. При увеличении значения ползунок сдвигается вправо, при уменьшении — влево, изменяя соотношение цветов в переходе.

Рис. 4.16. Угол наклона линейного градиента


Инструмент Gradient— вектор градиента

Если задавать линейный градиент с помощью палитры, его вектор по умолчанию располагается горизонтально и тянется от одной стороны габаритного прямоугольника объекта до другой его стороны. Центр радиального градиента совпадает с центром габаритного прямоугольника, а его длина равна половине длинной стороны этого прямоугольника. Для задания произвольного вектора градиента используйте инструмент Gradient. Работать с ним очень просто (рис. 4.17): нужно выбрать объект с обводкой или заливкой градиентом, щелкнуть там, где бы вы хотели видеть начальную точку линейного градиента или центра радиального, и протащить курсор, создавая прямую линию. Длина линии соответствует длине линейного или радиусу радиального градиента, а ее направление — углу наклона линейного градиента. Точно регулировать угол удобнее в поле Angle палитры Gradient.

а

б

Рис. 4.17. Создание градиентов: а — линейного, б — радиального

Для радиального градиента можно создать очень интересный эффект: если щелкнуть инструментом Gradient на периферии построенного радиального градиента, то точка щелчка станет началом цветового перехода, а расположение и радиус градиента останутся прежними. Возникающий эффект похож на свет прожектора (рис. 4.18).

Рис. 4.18. Смещение центра градиента


Градиентная заливка нескольких объектов

Можно определить градиентную заливку (обводку) нескольким одновременно выделенным объектам. В зависимости от способа задания градиента заливка будет различной. Если задать градиент из палитры, то каждый объект получает "отдельный" градиент одного типа с начальной точкой в центре и радиусом, равным половине ширины объекта (рис. 4.19).

Рис. 4.19. Градиент задан из палитры

Если провести линию градиента для объектов, обработанных таким образом, то их заливка (обводка) расположится так, словно они все представляют собой единый объект (рис. 4.20).

Полосатость градиента

Если заполнить градиентом длинный объект, на печати вместо гладкой растяжки могут появиться полосы. Это связано с ограничениями устройства вывода.

Рис. 4.20. Вектор градиента создан инструментом Gradient

При создании градиента рекомендуем подбирать цвета переходов в одной цветовой модели. Это избавит вас от неожиданностей на этапе вывода.


Назначение и типы цветов

Создание цветов и градиентов с помощью палитры Color — не самый быстрый способ присвоить цвет объекту. Ведь каждый раз после выделения приходится смешивать цвет заново. Чтобы ускорить работу и стандартизировать цветовое решение публикации, используют палитры Toolbox и Swatches.


Определение цвета в палитре Toolbox

Нижняя часть палитры инструментов используется для отслеживания обводки и заливки объекта, выбора и удаления этих атрибутов, а также приведения их к значениям по умолчанию.

Текущая обводка и заливка показаны в квадратах (полях) Fill и Stroke (рис. 4.21). Активное поле находится впереди, так же как в палитре Color, и активизируется щелчком. Если в публикации объект выделен, то показаны его заливка и обводка. Если нет выделенного объекта, отображаются заливка и обводка по умолчанию. Следующий создаваемый объект будет иметь именно такие обводку и заливку. Если выделено несколько объектов с разными атрибутами заливки и обводки, в соответствующем поле отображается вопросительный знак.

Изогнутая двунаправленная стрелка в правом верхнем углу — это кнопка обмена атрибутов заливки и обводки (Swap Fill and Stroke). При щелчке на ней поля Fill и Stroke обменялись свойствами. Если в данный момент выделен объект, он изменится соответственно. По умолчанию объекты имеют черную обводку и заливка отсутствует. Для приведения цветов к умолчаниям щелкните на кнопке Default Fill and Stroke.

Рис. 4.21. Область работы с цветом палитры Toolbox

Кнопки, расположенные ниже полей Fill и Stroke предназначены для присвоения и редактирования атрибутов обводки и заливки. Кнопка Color окрашена в последний из выбранных сплошных цветов. Если щелкнуть на ней, то активное поле приобретет этот цвет. Соответственно изменится цвет заливки или обводки выделенного объекта. Если выделенных объектов нет, то данный цвет устанавливается по умолчанию. Ту же функцию выполняет кнопка Gradient— при щелчке на ней объекту будет присвоена заливка или обводка последним из использованных градиентов. Ясно, что если объект и так имеет атрибут, указанный на кнопке, то ее нажатие не приведет к изменениям.

Кнопка None, имеющая вид перечеркнутого квадрата, удаляет тот атрибут объекта, поле которого активно (обводку или заливку).

Быстрая смена цвета

Для смены цвета с помощью описанных кнопок предназначены следующие клавиатурные комбинации: <Shift>+<X> для перемены местами заливки и обводки, <D> для присвоения им значений исходного умолчания, <>> (больше) для кнопки Gradient, <<> (меньше) для кнопки Color и </> (обратная косая черта) для кнопки None.


Палитра Swatches

Обычно в публикации один и тот же цвет или градиент применяется несколько раз. Чтобы каждый раз не смешивать цвет в палитре Color или Gradient, удобно хранить образцы в специальном каталоге и присваивать их объектам по необходимости. Кроме того, в документе часто используются плашечные цвета, особенно если в нем всего один-два цвета. Эти возможности предоставляет палитра Swatches (рис. 4.22). На рисунке показана палитра в том виде, который установлен для нее по умолчанию, и ее меню.

Для открытия меню щелкните на треугольной стрелке вверху справа. В меню сосредоточены команды управления образцами. Наиболее часто используемые команды вынесены в нижнюю часть палитры. Первые три кнопки — режимы показа образцов. Если нажата кнопка Show All Swatches, то демонстрируются все образцы, которые есть в каталоге. При нажатой кнопке Show Color Swatches в палитре показаны только образцы сплошных цветов, если нажата кнопка Show Gradient Swatches, то видны только образцы градиентов. Кнопка New Swatch предназначена для определения нового образца. Кнопка Delete Swatch удаляет выделенные образцы. Для присвоения цвета объекту нужно выделить его и один раз щелкнуть на образце.

Рис. 4.22. Палитра Swatches

В этой палитре (каталоге образцов) располагаются образцы цветов и градиентов документа. Слева показан сам образец, затем его имя, тип цвета и его модель. Если образец нельзя редактировать, после имени отображается значок перечеркнутого карандаша. В табл. 4.1 приведены значения пиктограмм палитры.

Таблица 4.1. Значения пиктограмм типов и моделей цветов

Пиктограмма | Значение
 | Образец не редактируется
 | None, отсутствие атрибута
 | Registration, цвет приводимых меток
 | Модель RGB
 | Модель CMYK
 |  | Process Color, составной цвет

По умолчанию в палитре содержится лишь несколько служебных цветов: None. Условный "прозрачный цвет". Отмена заливки или обводки. Присвоение этого цвета объекту делает его прозрачным. Сквозь него видна бумага или находящиеся под ним другие объекты (рис. 4.23) Этот образец не имеет типа, кроме того, его нельзя отредактировать. В области модели показан перечеркнутый квадрат.

Рис. 4.23. Звезда имеет заливку цветом None

Рис. 4.24. Звезда имеет заливку цветом Paper

Paper. Цвет бумаги. Если, скажем, заливке объекта присвоен этот цвет, то заливка отменяется и видна бумага, на которой объект печатается. Если присвоить цвет Paper объекту, который перекрывает другой объект, то в области перекрытия не видны все нижележащие объекты (рис. 4.24). Это тоже условный цвет. Он не имеет модели и типа и не выводится на печать. Однако цвет бумаги можно редактировать. Эта возможность предусмотрена для передачи на экране публикаций на тонированной бумаге. Однако какой бы цвет вы ни присвоили образцу Paper, он будет отображаться только на экране.

Black. Черный цвет в модели CMYK. Установите курсор на образец и программа покажет содержание компонентов (COMOYOK100). Черный цвет нельзя редактировать.

Registration. Цвет приводных меток. При печати несколькими цветами очень важно точное совмещение красок. Для этого на каждой печатной форме в одном и том же месте должны быть проставлены специальные метки (крестики, кружочки и пр.). При печати они должны точно накладываться друг на друга. Таким образом цвет для меток должен содержать все печатаемые краски. Там, где дело касается триадных красок, нужно просто задать меткам 100% каждого компонента. Сложнее с плашечными цветами, ведь они не подвергаются цветоделению. Цвет Registration автоматически содержит 100% каждой из печатных красок, как составных, так и плашечных. При автоматическом подборе цвета меток снижается вероятность ошибок. Цвет Registration можно отредактировать, произвольно изменить содержание компонентов цвета и модель. Это изменение касается только композитных отпечатков и экранного изображения объекта, окрашенного этим цветом. При печати форм метки будут иметь 100%-ю заливку вне зависимости от выбранного соотношения компонентов.


Создание образца в каталоге

Для помещения образца в каталог определите его в палитре Colors или Gradient. Затем щелкните на кнопке New Swatch внизу палитры Swatches (аналогично действие команд New Color Swatch и New Gradient Swatch меню палитры). Образец будет помещен в палитру и присвоены имена New Color Swatch для образца цвета и New Gradient Swatch для образца градиента. Следующие образцы помещаются в палитру под теми же именами с индексами 2, 3 и т. д. Для образца цвета помечается модель и тип (при создании — составной, см. табл. 4.1), для образца градиента показано только имя.

Чтобы создать образец на основе уже имеющегося образца палитры, выделите его и щелкните на кнопке New Swatch. Будет создана независимая копия образца. Автоматически копии присваивается то же имя, что и образцу, с добавлением индекса Copy.

Пока цвета (градиенты) не помещены в палитру Swatches, они являются локальными. Редактирование их производится в тех же палитрах Color и Gradient, в которых они созданы. При редактировании локального цвета объекта другие объекты, окрашенные в те же цвета, не изменяются.

Когда образец цвета или градиент помещен в палитру, он становится глобальным (именованным). Между образцом цвета и окрашенными в тот же цвет объектами устанавливается связь. При изменении свойств образца соответствующим образом изменяется цвет всех объектов, в обводке или заливке которых он участвует.

Редактирование образца цвета производится в диалоговом окне Swatch Oрtions (рис. 4.25).

Рис. 4.25. Диалоговое окно Swatch Options

Чтобы открыть это диалоговое окно, щелкните дважды на образце или выберите команду Swatch Options меню палитры. В поле Swatch Name вы можете произвольно изменить имя. Ниже расположен раскрывающийся список С olоr Type, в котором выбирается тип цвета - Process (Составной) или Spot (Плашечныи). Напомним, что эти типы различаются по способу печати - составные печатаются красками базовых цветов, а плашечные - собственным, смесовым цветом. Если для цвета выбрать тип Spot он будет помещен при печати на отдельную форму. Для электронных публикаций понятие "плашечный цвет" лишено смысла. В списке Color Mode выбирают модель цвета.

Нижняя часть палитры отведена для редактирования образца. Здесь вы видите уже знакомые вам ползунки, поля ввода компонентов и поле образца Флажок Preview устанавливает режим предварительного просмотра.

Редактировать можно и образцы градиентов. При двойном щелчке на градиентном образце также открывается окно Gradient Options (рис. 4.26).

Список Type позволяет выбрать тип градиента: линейный или радиальный Внизу располагается схема градиента. Если вы выберете на ней один из цветовых ползунков, для него активизируется раскрывающийся список Stop Color. Для перехода можно выбрать произвольную модель цвета и откорректировать цвет. Если установить в списке значение Named Color, то откроется список образцов палитры. Вы можете выбрать один из них в качестве цвета образца. Если это сделать, то цвет градиента окажется связан с образцом палитры.

Рис. 4.26. Диалоговое окно Gradient Options


Удаление образца

Для удаления образца выделите его (одновременно можно выбрать несколько образцов, если держать нажатой клавишу <Ctrl>) и щелкните на кнопке Delete Swatch, или выберите одноименную команду из меню палитры. InDesign выдаст окно запроса (рис. 4.27) о том, что делать с объектами, которые окрашены в цвета удаляемых образцов.

Рис. 4.27. Запрос при удалении образца

Выбрав первое положение переключателя, вы с помощью раскрывающегося списка сможете определить, в какой цвет необходимо окрасить объекты после удаления образца. Если выбрать второе положение переключателя, то заливка и обводка объектов будет прежней, но станет локальной.


Оттенки

Для именованных цветов InDesign предлагает создать оттенки. Это цвета того же тона, что и базовый, но более светлые. Например, градиент от черного до белого представляет собой оттенки серого цвета. Оттенки остаются связаны со своим базовым цветом. Если базовый цвет — плашечный, его оттенки передаются растром этого же цвета (рис. 4.28). Оттенки составных цветов передаются цветным растром.

Рис. 4.28. Оттенки плашечного цвета

Чтобы определить для объекта оттенок данного цвета, выберите объект, присвойте ему базовый цвет и откройте палитру Color. Единственная шкала с ползунком регулирует оттенок данного цвета (Tint) от исходного до белого (рис. 4.29). Рядом находится поле ввода, где можно указать точное значение оттенка. Оттенки, заданные в палитре Color, не отображаются отдельными строками в палитре Swatches. Оттенок придется каждый раз определять в палитре Color.

Рис. 4.29. Палитра Color при задании оттенков

Если данный оттенок встречается в публикации часто, его стоит определить как отдельный образец. Для этого выберите базовый цвет и выполните команду New Tint Swatch меню палитры Swatches. В диалоговом окне Swatch Options (рис. 4.30) можно поменять только степень осветления оттенка по сравнению с базовым цветом. Образец оттенка остается связан с базовым цветом.

Рис. 4.30. Редактирование именованного оттенка

Редактирование образца в палитрах Color и Gradient

Если вы выберете объект, имеющий именованный цвет, оттенок или градиент, и переопределите его модель в палитре Color, цвет объекта станет локальным, не связанным с образцом в палитре Swatches.

Использование возможности определения образцов и оттенков окажет вам неоценимую помощь при создании иллюстраций с оттенками (изображения объемных предметов, схемы, портреты и др.). Достаточно слегка изменить основной глобальный цвет, и его оттенки изменятся также. Цветовое решение публикации можно изменить буквально несколькими щелчками.


Особенности определения цветов

InDesign предлагает очень логичную систему определения атрибутов. Суть ее такова: атрибут присваивается только тому объекту, который выделен. Если выделен фрейм с текстом, то атрибуты обводки и заливки присваиваются фрейму. При выделении текста фрейма в текстовом режиме обводка и заливка определяются для текста.

Так же обстоит дело и с изображениями, помещенными в графические фреймы. Если выделить только фрейм (для этого щелкните на нем инструментом Selection), то для него можно задать как обводку, так и заливку. Выделив только изображение (щелчком внутри фрейма инструментом Direct Selection), можно задать для него произвольную заливку сплошным цветом. Обводка и градиентная заливка для растрового изображения не задаются. Заливка растрового изображения в InDesign осуществляется только для полутоновых и монохромных изображений, внедренных в документ. Цветным изображениям и изображениям в формате EPS невозможно задавать заливку внутри InDesign.


Обмен палитрами между документами

В каждом документе вы можете создавать любые каталоги цветов и градиентов. В работе часто приходится оперировать с одними и теми же цветами и градиентами в разных публикациях. Например, серия документов для одной и той же фирмы, скорее всего, будет иметь сходную цветовую палитру. Создавать одинаковые каталоги для разных публикаций — значит дважды выполнять одну и ту же работу. InDesign позволяет импортировать в документ каталоги цветов (палитры Swatches) из любого документа в следующих форматах:

  • Собственные файлы InDesign (INDD)
  • Шаблоны InDesign (INDT)
  • Файлы Adobe Illustrator (AI)
  • Файлы Adobe Illustrator EPS (EPS)

Функция импорта очень важна, если вы применяете в публикации стандартные цвета из коммерческих каталогов. Каталоги выпускаются производителями красок для полиграфии. Наиболее известным каталогом цветов является Pantone Matching System (PANTONE) — образцы всех цветов для матовой и глянцевой бумаги (цвета на матовой бумаге выглядят менее яркими), специальные цвета (пастельные тона, металлизированные и флуоресцентные краски). Поскольку перевод плашечных цветов в триадные на практике осуществляется достаточно часто, в каталоге PANTONE имеются триадные эквиваленты плашечных цветов. Все цвета нанесены именно красками, поставляемыми заказчику. Кроме PANTONE, есть много и других каталогов: например, TOYO, FOCOLTONE. Цвета для электронных публикаций также стандартизированы, например, палитра Web, используемая для Интернет, содержит 216 цветов, отображаемых стандартным образом на большинстве платформ и браузеров.

Электронные версии каталогов совершенно незаменимы, если вы используете в публикации плашечные цвета. Во-первых, они дают представление о внешнем виде цвета, а во-вторых — и это самое главное — при использовании стандартного цвета на форме указывается его уникальный номер. При печати вероятность ошибки цвета значительно снижается.

Импорт стандартных каталогов производится точно так же, как и каталогов пользовательских файлов. Каталоги представляют собой обычные файлы в формате Adobe Illustrator. На странице файла каталога располагается только краткая справка о каталоге и предупреждение о необходимости резервного

копирования. Набор образцов помещен в палитру Swatches каждого из них. В комплект InDesign входит довольно много фирменных каталогов. Все они хранятся в папке \Swatch Libraries главной папки InDesign. Ни в коем случае не изменяйте палитры Swatches этих файлов — иначе каталоги цветов будут неправильными.


Импорт каталога образцов в публикацию

Для импорта каталога образцов выберите команду Swatch Libraries меню Window. Откроется список каталогов. В верхней его части располагаются названия стандартных каталогов. Для импорта любого из них щелкните на нужной строке. InDesign немедленно откроет каталог (рис. 4.31). В нем видны всего несколько образцов, но если вы прокрутите его дальше, то сможете убедиться, что в нем содержатся все цвета данного каталога.

Рис. 4.31. Каталог PANTONE, помещенный в InDesign

Для импорта каталога образцов из произвольного файла выберите пункт списка Other library. Откроется окно Select a Library to open, в котором вы сможете выбрать папку и интересующий вас файл. После щелчка на кнопке ОК сам файл не открывается, а появляется только его палитра Swatches.

Хранение ссылок на каталоги

Если хоть раз открыть пользовательский каталог в программе, то ссылка на него появится в нижней части списка, под строкой Other library. Щелчком на ссылке вы сможете открыть нужный каталог без выбора файла в диалоговом окне.

Одновременно можно открыть несколько каталогов. Это обычные палитры, которые можно масштабировать, группировать, закрывать кнопкой с изображением косого креста в правом верхнем углу. Если сгруппировать вместе два (или более) каталога и закрыть их, то при обращении к любому из этих каталогов открывается вся группа.

Каталоги не принадлежат документу и не хранятся вместе с файлом. Поэтому, несмотря на то что каждый каталог похож на палитру Swatches документа, его образцы нельзя редактировать и применять к объектам. Чтобы ипользовать их в документе, выберите нужный образец (можно выбрать несколько образцов, если протащить курсор по их строкам) и, открыв меню палитры, выберите его единственную команду — Add to Swatches. Выбранный образец помещается в палитру Swatches документа под своим именем. Теперь его можно редактировать, как и обычные образцы.

Поиск в каталоге

Поиск нужного образца в любом из каталогов может производиться по имени. Для этого нажмите клавиши <Alt>+<Ctrl> и щелкните на каталоге. Вокруг окна появится серая рамочка. Теперь введите код нужного цвета. Оцениваются цифры кода, или любые две буквы, если название цвета состоит только из букв. Так, для цвета Pantone 246 CVC (оттенок фиолетового) вводятся цифры 246, а для цвета Pantone Process Blue CVC — буквы BL (Blue); Так же можно производить поиск и в собственной палитре Swatches документа.

Обычно импортированные образцы не редактируют, иначе они перестанут быть стандартными. Для цветов каталогов редактирование вообще не имеет смысла и не рекомендуется, поскольку цвет краски предопределен номером образца, а изменившийся на экране вид образца может ввести вас в заблуждение.

Если образец каталога используется как отправная точка для создания произвольного образца, то его, конечно, можно и нужно отредактировать. В таком случае советуем переименовать редактируемый образец.


Импорт образцов вместе с файлами

Когда вы открываете каталог и переносите из него образцы в палитру Swatches документа, тем самым вы пополняете палитру образцов сознательно. Однако пополнение палитры новыми образцами может происходить и вместе с импортом файлов. При импорте файлов в форматах EPS, DCS, AI с содержимым файла импортируются также и образцы плашечных цветов, использованных в документе. Образцы помещаются в палитру под собственным именем. Редактировать их нельзя.

Импортированным объектам невозможно присваивать цвет в рамках InDesign. При выделении такого объекта палитры редактирования и выбора цвета становятся недоступными.

Импорт плашечных цветов вместе с объектами происходит и при копировании объектов Adobe Illustrator через буфер обмена. Импортированный образец в этом случае будет полноценным образцом палитры и его можно редактировать.


Выбор цветового решения публикации

В этом разделе мы позволим себе дать несколько советов относительно общего направления работы над цветом в вашей публикации. К сожалению, в данной книге невозможно было сделать цветные вклейки, а рассказывать о цветовом решении конкретных публикаций без цветных иллюстраций — неблагодарное занятие.


Взаимодействие цветов

Цвета, находясь в реальной публикации, могут усиливать и ослаблять друг друга, вступать в конфликт или гармонировать. Как же предсказать гармоничные или броские сочетания цветов? Каждый реальный цвет можно охарактеризовать цветовым тоном, т. е. его положением на круге, насыщенностью, или степенью разбавления цвета белой краской и яркостью и степенью затемнения цвета.

  • Дополнительные цвета находятся напротив друг друга. При их смешивании образуется черный (если это краски) или белый (если это световые лучи) цвет. Это максимально контрастные цвета. Сочетание их действует на глаз раздражающе (красный и зеленый, желтый и фиолетовый, синий и оранжевый). Такие сочетания применяются для создания сильного эффекта.
  • Цвета, смежные с дополнительными. В такой палитре один цвет сочетается с двумя другими, смежными дополнительному к нему (зеленый, темно-оранжевый, бордовый). Такое сочетание цветов более мягкое, но достаточно контрастное.
  • Триады. Цвета, равноотстоящие друг от друга на цветовом круге, образуют триады, гармоничные сочетания (желтый, пурпурный, голубой или оранжевый, изумрудный, бордовый). Их сочетание создает палитру насыщенных цветов и оттенков.
  • Смежные цвета. Малоконтрастное сочетание смежных цветов придает рисунку строгий вид, например, на схемах или на бланках солидной компании.

Кроме цветового тона, на восприятие объектов иллюстрации всегда влияют насыщенность и яркость цвета. В общем случае, чем чище тон, т. е. чем больше значение обоих этих параметров, тем сильнее объект привлечет внимание. Если на рисунке имеется особенно важная деталь, а остальные фигуры — лишь фон для нее, то разумно снизить их яркость и/или насыщенность. Снижение насыщенности приведет к осветлению рисунка, он будет окрашен в пастельные тона. При уменьшении яркости цвета, напротив, иллюстрация будет затемнена. Предельный случай цветового акцента за счет разницы яркости и насыщенности — сочетание черного или белого цвета со спектральными, что производит сильный эффект.


Цвет — полноценный компонент публикации

Каждый цвет несет эмоциональную нагрузку. Они могут быть теплыми (красные и желтые) и холодными (синие и зеленые). Одни сочетания считаются детскими (оранжевый, ярко-зеленый) или младенческими (розовый, голубой), другие — мужественными (коричневый, темно-синий) или женственными (сиреневый, салатный). При выборе цветов предполагайте, что можно вызвать желательные эмоции у зрителя. Всегда помните, что многие цвета имеют устойчивую ассоциативную связь с каким-то явлением, и их количество с течением времени растет. Это не значит, что эти цвета нельзя употреблять. Наоборот, примененные к месту, они усилят впечатление от материала статьи. Например, статья о победах "Зенита" в сине-бело-голубых тонах будет более привлекательна для болельщика. Рекламная листовка магазина дубленок привлечет коричневыми и синеватыми цветами, по ассоциации с кожей и снегом. Однако цвет может придать публикации негативное звучание или двусмысленность. Вряд ли юбилейная, праздничная статья будет воспринята адекватно, если в ее оформлении преобладают мрачные тона.

Выбор цветов зависит от типа публикации. В публикациях неофициального характера можно использовать яркие, насыщенные цвета, если же публикация имеет академический характер, ее гамма должна быть более сдержанной, цвета — приглушенными, очень темными либо, наоборот, совсем светлыми и малозаметными. Статья о политическом лидере, оформленная с применением больших областей контрастных ярких тонов вызовет ассоциацию с клоуном и здоровый смех. Но те же цвета в статье о популярной дискотеке будут смотреться великолепно. В изданиях рекламного характера существует неписаное правило — чем шикарнее вещь, тем спокойнее цветовое решение рекламного материала.

Чем больше цветов использовано в публикации, тем труднее добиться стройности композиции. Не увлекайтесь назначением множества контрастных цветов. В большинстве случаев более чем достаточно двух контрастных цветов и их оттенков. Исключения составляют детские издания. Но и в них избегайте аляповатого сочетания цветов. Ошибаются те издатели, которые думают, что для детей следует делать книги чем ярче, тем лучше. Ведь книги для детей выбирают родители, а они руководствуются своим вкусом.


Чуть-чуть о бумаге

Кроме цветной печати, цветовое решение публикации может быть создано с помощью тонированной бумаги. Материалы на тонированной бумаге производят совершенно иное впечатление, чем те же материалы на белой бумаге. Обязательно учитывайте цвет и оттенок бумаги при подготовке макета.

Поразительный эффект наблюдается при использовании бумаги розовых и желтых оттенков в качестве носителя при производстве дешевой рекламной продукции. При печати на ризографе качество полученных копий будет очень скромным. И контрастность печати, и качество печати оставляют желать лучшего. Цветная бумага заметно скрадывает эти недостатки, в результате отпечатки выглядят намного лучше.

Дешевая бумага обычно имеет желтоватый оттенок. При печати на ней голубым цветом результирующим оказывается грязноватый зелено-голубой. Поэтому при выпуске дешевых изданий на плохой бумаге лучше выдерживать гамму в теплых тонах. В этом случае влияние фона будет не столь заметно. В подобных изданиях лучше применять темные цвета, выделяя логотипы, буквицы и т. д. Темные краски лучше перекрывают фон и смотрятся чище. На плохой бумаге равномерные заливки большой площади, и светлые, и темные, выглядят грязными, и их следует избегать, отдавая предпочтение графическим рисункам. Рекомендации по выбору бумаги приведены в главе 24.


Цвет и текст

При работе с текстом в цветных публикациях придерживайтесь следующих правил:

  • Назначайте фону и тексту контрастные цвета. Речь идет о контрастности именно цвета, а не просто о различной яркости. Например, черные буквы на красном фоне читаются с большим трудом, так что такого сочетания следует, по возможности, избегать.

  • Проверяйте контрастность в монохромном изображении. Для проверки контрастности двух цветов переключите монитор в монохромный режим воспроизведения. Хотя этот прием срабатывает не всегда, но в большинстве случаев, когда два цвета выглядят контрастно в монохромном изображении, они будут выглядеть контрастно и при цветной печати.

  • Обводите буквы. Если в силу тех или иных причин вам приходится пользоваться слабо контрастирующими цветами фона и букв, воспользуйтесь для улучшения удобочитаемости обводкой символов текста. Обводку можно выполнить в графических приложениях, таких как Illustrator или FreeHand, преобразуя символы текста в последовательности кривых и назначая каждой из них свои атрибуты обводки и заливки фона. Другой вариант предполагает применение программы, предназначенной для для работы с растровыми изображениями (типа Photoshop), и фильтров для усиления резкости контуров со сглаживанием — приемом, позволяющим впоследствии не выполнять треппинг цветных штрихов.

  • Избегайте раздражающего сочетания цветовых тонов для печати содержательного текста. Например, сочетание желтого с красным раздражает глаз. Это сочетание очень действенно, когда нужно "за уши" подтащить зрителя к данной полиграфической продукции, предварительно оглушив его. Не случайно ярлыки "New!" имеют такое цветовое решение. Существуют и другие неприятные до боли в зубах цветовые сочетания.

  • Умеренно используйте специальные цветовые эффекты — текст-маску, выворотку и пр. Изображения для текста-маски подбирайте не слишком контрастным, иначе контуры букв перестанут восприниматься.

  • Помните о треппинге. При печати цветными буквами по цветному фону может возникнуть искажение символов за счет треппинга, при котором размеры символов могут несколько меняться. Человеческий глаз очень чувствителен к искажениям формы литер шрифта, поэтому везде, где это возможно, откажитесь от совмещения по тексту с применением треппинга. Черный текст меньше 27 пт всегда печатается с наложением. Если при треппинге размеры надпечатываемых объектов увеличиваются, засечки (серифы) и другие закругленные элементы литер сохраняют форму только в шрифте большого кегля. При большом кегле эффект расширения штрихов меньше воздействует на сокращение внутренних просветов в литерах (например, в буквах О и В). Общее правило состоит в том, что при треппинге гарнитуры без засечек лучше сохраняют форму, чем гарнитуры с засечками. О треппинге речь пойдет в главе, посвященной печати.

  • Избегайте слишком светлых и плохо различимых оттенков. Точные рекомендации по поводу воспроизведения оттенков при печати сможет дать только технолог типографии. Оттенки светлее 20% могут быть неудобны для воспроизведения при печати, вне зависимости от того, хорошо или плохо такой оттенок смотрится на фотоформе, выведенной на фотонаборной машине с высоким разрешением. Плохо воспроизводятся тонкие линии, для которых выбран светлый оттенок цвета. Может получиться даже так, что такой цвет будет выглядеть просто как грязь на бумаге.

  • Печатные машины не могут воспроизводить разницу в оттенках в 1%. Как правило, минимальное расстояние между смежными оттенками одного цвета не должно быть менее 5%.


Резюме

Эта глава посвящена рассмотрению различных аспектов применения цвета в документе:

  • Устройства ввода и вывода изображений характеризуются различным цветовым охватом, т. е. диапазоном цветов, который они могут воспринять и воспроизвести.

  • Для математического описания цвета используются цветовые модели, каждая из которых также имеет конечный цветовой охват, т. е. описывает определенный диапазон цветов.

  • Модель RGB служит для описания излучаемых цветов. Эта модель основана на трех базовых цветах — красном, синем, зеленом. Цвета модели аддитивны, т. е. при наложении результирующий цвет будет светлее исходных.

  • В модели RGB работают монитор и сканер. Характеристики RGB-устройств различны, модель является аппаратно-зависимой.

  • Модель CMY описывает отраженные цвета. С помощью трех базовых компонентов (голубого, пурпурного, желтого) можно отобразить на печати довольно большую часть реальных цветов. Из-за ограничений CMY при передаче темных оттенков основой цветной полиграфии является CMYK — модель CMY, в которую введен дополнительный черный базовый компонент. Цвета, создаваемые на бумаге с помощью базовых красок, называются триадными или составными.

  • Для расширения цветового охвата печатных изображений используются расширенные полиграфические модели, состоящие из пяти, шести и более компонентов. Все полиграфические модели аппаратно-зависимы.

  • Для передачи особых цветов (например, серебро и флуоресцентные цвета), а также при печати небольшим числом цветов используется специальный метод печати — с применением плашечных цветов. В отличие от триадных, они печатаются не базовыми, а отдельными заранее смешанными цветами.

  • В связи с необходимостью получения точного цвета на различных устройствах была создана аппратно-независимая модель Lab. Цвет Lab состоит из трех компонентов — светлоты, определяющей яркость, и двух хроматических, определяющих цвет.

  • В InDesign существует два типа обводок и заливок — сплошные и градиентные.

  • Сплошные цвета создаются в палитре Color в одной из трех моделей.

  • Градиенты определяются в палитре Gradient. Они могут быть линейными и радиальными.

  • Для назначения цветов используются кнопки палитры Toolbox.

  • Хранение образцов цветов и градиентов осуществляется в палитре Swatches. Образец, помещенный в палитру, остается связан с объектами, к которым применен. При изменении образца палитры соответственно меняются и объекты.

  • Цвета, не определенные в палитре, называются локальными.

  • Образцам палитры можно назначать оттенки. Оттенки также связаны с базовым цветом.

  • Палитра Swatches, т. е. каталог образцов документа, хранится вместе с ним. Она может быть использована не только в своем документе, но и в других. Для этого предусмотрены команды импорта каталогов.

  • В комплект программы входят каталоги полиграфических красок и цветов Web.

  • При удалении образцов из палитры заливка или обводка объектов переводится в черный или они остаются окрашены локальными цветами.

  • Образцы плашечных цветов импортируются в документ вместе с файлами в разновидностях формата EPS.


Глава 5

Управление цветом

Процесс производства цветного издания связан с репродуцированием изображений множеством различных машин, каждая из которых имеет свои характеристики. Если бы все эти устройства, от сканера до офсетной машины, воспроизводили цвета правильно, а на печати совмещали офсетные краски идеально, то никакого управления цветом бы не понадобилось. Однако, несмотря на бурное развитие технологии цветной полиграфии, она все еще очень несовершенна. Так, все устройства, задействованные на этапах подготовки тиража издания, имеют разный цветовой охват, они работают исходя из разных цветовых моделей, а цвета, отображаемые ими, являются аппаратно-зависимыми. Как следствие, необходима система согласования цветопередачи для всех этапов производства.

В этой главе будут рассмотрены:

  • Принцип действия систем управления цветом
  • Получение цветовых профилей устройств
  • Организация технологической цепочки, включающей управление цветом
  • Установки системы управления цветом в InDesign
  • Управление цветом объектов публикации.


Система управления цветом

Система управления цветом Color Management System (CMS) учитывает, во-первых, принципиальное различие воспроизведения и восприятия цветов различными устройствами, а во-вторых, конкретные характеристики оборудования (сканера, монитора, фотонабора, принтера). Полностью устранить различия не удается, однако в результате действия программы цвета одного и того же изображения в представлении разных устройств очень похожи на оригинал.


Принцип работы

В компьютерах Macintosh управление цветом уже давно поддерживается на системном уровне. На платформе PC управление цветом включено в операционные системы Windows 98 и Windows 2000. Система управления цветом ColorSync, используемая на Macintosh, и ICM 2.0, реализованная в последних версиях Windows, с точки зрения InDesign ничем не отличаются,

Системы управления цветом работают только с калиброванными устройствами. Под калибровкой понимается математическое описание цветопередачи устройства. Такое описание в терминах управления цветом называется цветовым профилем или просто профилем устройства. Профиль устройства представляет собой таблицу, по которой цвета, зарегистрированные устройством ввода (сканеры, цифровые камеры, видеоплаты и т. п.) или отображаемые устройством вывода (монитор, принтер), преобразуются в одну цветовую модель. Эта аппаратно-независимая модель представления цветов (Profile Connection Space, PCS) является ядром любой системы управления цветом. Название метко выражает сущность этого понятия. PCS служит тем цветовым пространством, которое вмещает цветовые пространства всех устройств, их "общим знаменателем". В системе ICC используется CIE L*a*b (Comission Internationale L'Enclairage). Это международный аппаратно-независимый стандарт измерения цветов. Она обеспечивает однозначное представление цветов независимо от конкретного устройства, используемого для создания или вывода изображения.

Таким образом, систему управления цветом формируют:

  • Аппаратно-независимую цветовую модель, PCS (Profile Connection Space), по отношению к которой строятся профили конкретных устройств.

  • Профили устройств, в которых указаны все характеристики представления цвета конкретным устройством. Различают профили устройств ввода (сканера, цифровой камеры), профили монитора и профили выводных устройств — принтера, фотонаборного автомата, печатной машины. Каждое устройство имеет собственный профиль. Кроме того, профили имеют и различные типы файлов, а также программы и операционные системы.

  • Модули управления цветом (Color Management Modules, CMM), которые собственно интерпретируют данные о цвете и информацию профилей и формируют инструкции по коррекции для каждого из устройств.

Управление цветом можно выразить простой схемой (рис. 5.1). Система получает данные из устройства ввода в модели RGB. Данные преобразуются CMM в аппаратно-независимый формат в модели Lab с учетом поправок, получаемых из профиля устройства ввода. При выводе на монитор данные в независимой модели преобразуются модулем CMM снова в RGB с учетом профиля монитора. Вывод на принтер предполагает преобразование в CMYK с учетом профиля принтера.

Рис. 5.1. Управление цветом

Профиль устройства описывает то, как оно представляет цвета. Цветопередача не одинакова для всех устройств каждого типа. Она различается не только в пределах конкретной модели устройства, но даже для отдельных экземпляров данной модели. По этой причине, строго говоря, следует строить индивидуальный цветовой профиль для каждого отдельного устройства, задействованного в технологической цепочке. Более того, цветовые параметры каждого экземпляра меняются со временем: стареет люминофор электронно-лучевой трубки, меняется спектральный состав источника света в сканерах. Поэтому профиль нельзя построить "раз и навсегда", его необходимо периодически обновлять.

Построение индивидуальных профилей требует специальной измерительной аппаратуры (спектрофотометров, денситометров и колориметров) и специального программного обеспечения. Эти приборы используются для измерения цветов, отображаемых монитором и получаемых на печати. Программное обеспечение (обычно прилагается к аппаратуре) на основе данных измерений осуществляет построение цветовых профилей. К наиболее популярным из них можно отнести:

  • Heidelberg ScanOpen, ViewOpen и PrintOpen
  • Agfa Color-Time
  • Kodak ColorMatch
  • Candela ColorSynergy

Перечисленные программы могут строить цветовые профили всех типов при наличии необходимой аппаратуры.

Профиль сохраняется в файле с расширением IСМ, который затем следует установить в систему управления цветом. Например, чтобы установить цветовой профиль в Microsoft Windows 98, достаточно щелкнуть на его файле правой кнопкой мыши и в открывшемся контекстном меню выбрать команду Install. Файл профиля будет установлен и размещен в папке \Соlоr, находящейся в системной папке Windows.


Профиль сканера

Сканеры являются RGB-устройствами. Профиль сканера характеризует преобразование его RGB-пространства в пространство PCS. Для создания профиля сканера вам потребуется стандартный эталон IT-8 и программа калибровки. Многие производители сканеров включают оба (или только последний) этих компонента в стандартную поставку сканера. Эталон для сканирования можно приобрести отдельно у дилеров Agfa или Kodak.

Эталон представляет собой сетку цветных образцов, которые имеют точно известный цвет. В зависимости от типа сканера, эталон может быть выполнен в виде отпечатка на фотобумаге или слайда. Цвета образцов измерены их производителями на высококачественной аппаратуре и помещены в справочный файл, прилагаемый к эталону.

Построение профиля сканера сводится к сканированию эталона. На основе полученного изображения и справочного файла специальной программой строится профиль сканера. Современные программы сканирования могут внедрять этот профиль в сканируемые изображения, обеспечивая точное отображение цветов.

Обновлять профиль сканера при его интенсивном использовании рекомендуется не реже, чем раз в месяц.


Профиль монитора

Прежде чем приступить к калибровке, необходимо стандартизировать освещение в рабочем помещении. Окружающая обстановка весьма сильно влияет на восприятие цветов. Для наилучшего цветовосприятия советуем вам придерживаться следующих принципов организации рабочей среды.

Отрегулируйте освещение. Оно должно иметь приблизительно ту же интенсивность, что и световой поток монитора. Благодаря этому вы сможете рассматривать отпечатки и изображения на экране в одном и том же режиме. Свет должен быть рассеянным. Цвет освещения должен быть настолько белым, насколько это возможно. Избегайте освещения комнаты прямыми лучами, особенно солнцем, поскольку солнечный свет имеет большую интенсивность, и его сила и цвет постоянно меняются. Люминесцентные лампы придают печатным образцам оттенок — голубой или розовый, в зависимости от цвета лампы. В свете лампы накаливания образцы приобретают желтый цвет. Строго говоря, для освещения следует использовать специальные лампы, соответствующие стандартному источнику освещения D50.

Как бы вы ни старались, отпечатки все равно будут более тусклыми, чем изображение на мониторе. Когда вы показываете неосведомленному в полиграфии клиенту иллюстрацию на мониторе, включите имитацию цветов печати и постарайтесь объяснить, что он никогда не получит таких ярких зеленых и синих оттенков, потому что люминофор светится, а краска на бумаге лишь отражает свет. В противном случае ожидания клиента будут обмануты. Еще более убедительной будет цветопроба или хотя бы отпечаток на струйном цветном принтере.

На восприятие цвета большое влияние оказывает окружение. Чем оно более нейтрально, тем более объективно ваше восприятие цветов изображения. В соответствии с этим оборудуйте рабочее место. Отмените заставки (Wallpaper) и узоры (Pattern) на экране — они могут существенно исказить восприятие и понапрасну утомляют глаза. Задайте для основного стола нейтральный цвет (например серый, как фон в программе InDesign). Постарайтесь не использовать в помещении для работы яркие занавески, обои и мебель. Не зря мониторы и компьютеры красят в серый цвет — он считается самым подходящим, потому что не искажает восприятие и не утомляет глаза. В помещении, лишенном ярких красок, вы сможете правильно оценить цветовую гамму изображения на всех стадиях работы.

Для построения профиля монитора используются колориметры, выполненное обычно в виде датчика-присоски, который крепится к экрану монитора. С помощью перечисленного выше или другого программного обеспечения, демонстрирующего на мониторе образцы цветов, строится цветовой профиль монитора. После получения файла ICM с профилем монитора его надо, как обычно, установить.

Если при калибровке сканера вам не обойтись без эталона, а для калибровки принтера вам обязательно потребуется денситометр, то выполнить грубую калибровку монитора можно и без специальной аппаратуры. В комплект Adobe InDesign входит специальная программа Adobe Gamma позволяющая строить профили монитора. Построим профиль монитора с помощью Adobe Gamma.

Если вы располагаете аппаратным калибратором (колориметром) ни в коем случае не используйте Adobe Gamma. Устройство нельзя калибровать двумя способами одновременно.

  1. Откройте панель управления Windows (Control Panel) и дважды щелкните на пиктограмме апплета Adobe Gamma. Перед вами появится диалоговое окно. В нем предлагается выбрать режим настройки: свободной установкой параметров в диалоговом окне или с помощью мастера. Первый раз советуем использовать мастер калибровки. Поэтому переведите переключатель Which version do you like to use? в положение Step by Step (Wizard) и щелкните на кнопке Next.

  2. В следующем окне мастера вам предлагается загрузить готовый профиль монитора. Многие производители мониторов предоставляют покупателям усредненные профили для каждой модели. Мы не рекомендуем использовать эти профили. Откалибруйте монитор с помощью Adobe Gamma, дающей гораздо более точный результат. Если вы уже успели установить усредненный профиль монитора, то перед запуском Adobe Gamma его следует непременно удалить. При этом в поле Description должна оказаться строка "Adobe Monitor Profile". Также не пытайтесь загрузить усредненный профиль нажатием кнопки Load.

  3. Следующее окно мастера позволяет установить черную точку для вашего монитора. Черная точка характеризует полное отсутствие свечения люминофора. Во-первых, регулировками монитора выведите контраст на максимальное значение. Во-вторых, также регулировками монитора, уменьшите яркость до минимума. Увеличивайте яркость до тех пор, пока в центре черного квадрата на образце не проступит более светлый квадрат. Увеличивайте яркость очень медленно, чтобы точно зафиксировать момент появления светлого квадрата. Затем нажмите кнопку Next.

  4. Следующее окно мастера содержит список люминофоров, используемых в видеосистемах. Тип люминофора определяет хроматические характеристики монитора. Если вы знаете точные хроматические координаты х и у для RGB-люминофоров вашего монитора, то выберите в списке Phosphors вариант Custom и введите их в открывшееся диалоговое окно Custom Phosphors. В мониторах компьютеров используется либо модель Trinitron, либо Р22. Установите один из них, если хроматические характеристики люминофора вам не известны. Затем нажмите кнопку Next.

    5. Хроматические характеристики люминофора записаны в ПЗУ любого современного монитора. Вы можете прочесть эту информацию с помощью специальной утилиты, предлагаемой некоторыми производителями мониторов, например, DDC Test для мониторов ViewSonic.

  5. Следующее окно мастера Adobe Gamma характеризует собственно гамму. Это характеристика монитора, определяющая его яркость. Черной точке соответствует минимальное, белой — наибольшее напряжение. Чем больше поданное напряжение, тем светлее точка. Однако зависимость яркости от напряжения не линейная, а логарифмическая. Основание логарифма и есть гамма. Она зависит от самого оборудования. На гамму также могут оказывать влияние программное обеспечение — операционная система компьютера. Величина Gamma изменяется для разных мониторов от 0.75 до 3.75. Для определения гаммы пользуются сравнением 50% растра из черных и белых точек с участком серого, добиваясь его 50% яркости. Обычно гамма для некалиброванных мониторов в среде Windows составляет 2.2, для Mac — 1.8.

  6. Во-первых, вам предстоит определить текущую гамму вашего монитора. Для этого перемещайте ползунок под образцом с двумя серыми квадратами. Добейтесь такого положения ползунка, при котором разница между внешним и внутренним квадратом минимальна. Чтобы полоски на внешнем квадрате не мешали, отодвиньтесь от монитора на метр-полтора.

  7. Сбросьте флажок View Single Gamma Only, и вместо одного серого образца появятся три цветных (RGB). Убедитесь, что гамма для отдельных компонент получилась верной. Если на каком-либо из образцов внутренний квадрат слишком отличается от внешнего, скорректируйте для него гамму с помощью расположенного под ним ползунка.

  8. Сообщив программе текущую гамму монитора, вы можете выбрать для работы любую другую. Выберите вариант (Windows или Macintosh) из списка Now choose the desired gamma или установите иное значение в поле справа. После установки желаемой гаммы монитора нажмите кнопку Next.

    9. Желаемое значение гаммы, которое вы устанавливаете в апплете Adobe Gamma, будет записано в профиль монитора. Чтобы выбранное значение гаммы устанавливалось автоматически, в группе автозапуска (Startup) Windows должен быть ярлык программы Adobe Gamma Loader. Эта маленькая программа нерезидентная. Она только изменяет значения в CLUT (Color Look Up Table) монитора, устанавливая нужную гамму. Adobe Gamma Loader не может работать на Windows NT, т. к. ядро операционной системы не позволяет писать что-либо в CLUT монитора. Поэтому для калибровки Windows NT требуется калибруемая видеокарта, позволяющая вводить значения гаммы в драйвере.

  9. Следующее окно мастера Adobe Gamma предназначено для установки цветовой температуры монитора или его белой точки. Это точка, в которой максимально интенсивные лучи всех трех цветов монитора образуют самый яркий для данного монитора белый цвет. Белой точке соответствует максимальное напряжение, поданное на электронно-лучевую трубку монитора. Устанавливаемое значение в Кельвинах и есть цветовая температура. Для большинства некалиброванных мониторов ее значение составляет от 6300 К до 9300 К. Современные мониторы имеют регулировку цветовой температуры. Выберите в списке установленное значение этого параметра.

    10. Странное словосочетание "цветовая температура" обязано своим происхождением физикам. Спектральный максимум излучения абсолютно черного тела (абстрактная физическая модель) при заданной температуре и называется цветовой температурой. Цветовая температура измеряется по абсолютной шкале температур. Например, белый свет, излучаемый абсолютно черным телом, имеющим температуру 5000 К, соответствует дневному свету.

  10. В принципе вы можете визуально оценить цветовую температуру монитора, если нажмете кнопку Measure (Измерить). Вам будут представлены три серых образца, из которых средний задает текущую цветовую температуру. Он должен иметь нейтральный серый цвет. Если он имеет более "теплый" тон, то щелкните мышью на образце слева. Если тон слишком "холодный", то справа. Повторяйте этот шаг до тех пор, пока средний образец не станет нейтральным серым. После этого щелкните на нем мышью, затем нажмите кнопку Next в окне мастера Adobe Gamma.

    11. Хроматические значения х и у белой точки можно ввести в численном виде в " диалоговом окне Custom Hardware Point. Если ваш монитор не имеет регулировки цветовой температуры, то вы можете узнать его хроматические характеристики из документации или ПЗУ.

  11. Следующее окно мастера Adobe Gamma предлагает выбрать желаемую цветовую температуру. Оставьте в списке вариант Same as Hardware. Выбор целевой цветовой температуры вы сделаете позже.

  12. Последнее окно мастера предлагает сравнить вид экрана до и после калибровки. Если вас это интересует, установите переключатель в этом окне. В противном случае щелкните на кнопке Finish.

  13. Эта кнопка открывает стандартное окно сохранения файла. В данном случае вы сохраняете готовый профиль монитора. Выберите для него имя и сохраните в папке \Со1ог.

Все те же установки, но не по шагам, можно сделать в панели управления, если в первом окне мастера Adobe Gamma установить переключатель Control Panel.

Профиль, сгенерированный Adobe Gamma, автоматически устанавливается в качестве активного профиля монитора в операционной системе. Таким образом, он становится текущим для всех приложений. Если вы работаете с Windows NT, то профиль монитора автоматически устанавливается и для других приложений Adobe (Illustrator, InDesign).

Еще раз подчеркнем, что профиль, построенный Adobe Gamma, очень грубый. Для того чтобы получить точный профиль, следует воспользоваться аппаратным калибратором.


Профиль принтера

Для построения профиля принтера или печатной машины необходимо напечатать на нем специальный эталон IT-873 (рис. 5.2). Как и эталон для сканирования, он состоит из цветных образцов известного цвета.

Рис. 5.2. Эталон IT-873

Отпечатав эталон на принтере, измерьте цвета цветных образцов на отпечатке с помощью денситометра (довольно нудное занятие) и введите результаты измерения в программу. На основании этих данных она построит цветовой профиль, который следует установить обычным способом.

Учтите, что построенный профиль справедлив только для установленного в момент печати режима принтера и использованного типа бумаги. Если для печати используются различные сорта бумаги и режимы печати, то нужно строить профили для каждого из них. Все это справедливо и для типографской печати. Профиль можно построить только для строго определенных красок, бумаги и настроек машины.

Если у вас нет денситометра, то используйте усредненный профиль, которым поставщики комплектуют большинство принтеров.

В большинстве случаев тщательной калибровке подвергают цветопробные принтеры, но хорошо откалиброванный струйный принтер тоже можно использовать для цифровой цветопробы. Наилучшие результаты для недорогих принтеров дает использование программных интерпретаторов PostScript, поддерживающих управление цветом, например, Adobe PressReady или Birmy PowerRIP.


Технологическая цепочка

Если вы решили использовать возможности управления цветом в InDesign, то это означает, что вы сделали выбор в пользу управления цветом на всей технологической цепочке. Управление цветом дает существенное преимущество только в том случае, если оно распространяется на все стадии подготовки издания, от сканирования изображений до типографской печати. Тем не менее, в рамках выбранной стратегии у вас тоже имеется выбор. В зависимости от используемого оборудования и специфики публикаций можно представить три достаточно общих модели управления цветом.

Традиционно вся обработка данных о цветах в публикации производится издательской системой. Она объединяет все элементы публикации, полученные в других программах: текст, растровые изображения, иллюстрации. Поскольку цветоделение также выполняется в издательской системе, именно она определяет окончательные цвета. Растровый процессор (Raster Image Processor, RIP) при этом выполняет только растрирование уже цветоделенных полос. Недостаток такого подхода лежит на поверхности: он аппаратно-зависим. Стоит измениться устройству вывода или источнику изображений, и всю цепочку приходится переналаживать с учетом нового оборудования. Новые технологии Adobe решают проблему с помощью системы управления цветом, встроенной в интерпретатор PostScript. Для того чтобы ею воспользоваться, требуется поддержка всеми задействованными устройствами PostScript Level 2 (версии 2017 и выше) или PostScript 3. Итак, модели управления цветом:

  • Аппаратно-зависимая, управляемая программой. Это та самая, традиционная модель, суть которой изложена выше. В соответствии с ней InDesign осуществляет все управление цветом в публикации на основании цветовых профилей, внедренных в импортированные изображения и собственными установками для объектов, созданных в нем. При таком подходе цвета публикации ориентированы на конкретное устройство вывода. Используйте эту модель, если устройство вывода не поддерживает управление цветом.

  • Аппаратно-зависимая, управляемая устройством вывода. В рамках аппаратно-независимой модели InDesign посылает публикацию на устройство вывода (RIP) без всякой коррекции, но снабженную цветовыми профилями всех ее элементов и самого устройства вывода. Коррекция осуществляется устройством вывода на основании полученных данных, включающих как исходные цветовые профили, так и конечный.

  • Аппаратно-независимая, управляемая устройством вывода. Аналогична предыдущей модели, но имеет важное отличие: конечный цветовой профиль не посылается устройству вывода. При этом предполагается, что оно само "знает" свой цветовой профиль. В этом случае при подготовке публикации нет необходимости учитывать профиль устройства вывода. Таким образом достигается аппаратная независимость.

Разумеется, профили устройств передаются устройству вывода не в формате ICM, а в виде его эквивалентов на языке PostScript: CSA (Color Space Array, исходные профили) и CRD (Color Rendering Dictionary, профиль устройства вывода).


Управление цветом в InDesign

Установки управления цветом в InDesign разделены на два уровня: уровень приложения и уровень документа. Установки, сделанные на уровне приложения, действуют на все документы и задаются в диалоговом окне Application Color Settings. В другом диалоговом окне, Document Color Settings, настраиваются параметры управления цветом в рамках текущего документа.


Настройка управления цветом в приложении

В диалоговом окне Application Color Settings находятся общие установки системы управления цветом (рис. 5.3).

Рис. 5.3. Диалоговое окно Application Color Settings

В списке Engine устанавливается активный модуль управления цветом (СММ), который и осуществляет преобразование цветовых пространств задействованных устройств. При установке InDesign автоматически устанавливается модуль Adobe CMS, используемый и в других приложениях Adobe. До тех пор пока вы не будете твердо уверены в необходимости применения других модулей, работайте с этим. В принципе InDesign способен использовать любой установленный СММ. В поставку программы входит и СММ производства фирмы Kodak, называющийся Precision Color. Если его нет в списке Engine, значит вы не выбрали его при установке InDesign. Его установка не обязательна, если вы намерены использовать Adobe CMS или какую-либо иную систему управления цветом. Повторим, что если вы используете издательские программы Adobe System, то не имеет смысла использовать иные СММ.

Примечание

Для того чтобы управление цветом было сквозным во всех используемых приложениях, проверьте установки CMS, сделанные в Photoshop и/или Illustrator. В них должен быть активен тот же СММ.

В области System Profiles находятся списки, в которых необходимо выбрать цветовые профили, характеризующие монитор, цветопробный принтер и типографскую машину. В списке Monitor выберите профиль монитора, который вы получили с помощью колориметра или программы Adobe Gamma. В списке Composite выберите профиль цветопробного принтера. Если в качестве цветопробного принтера вы используете недорогой струйный аппарат, не поддерживающий PostScript, но располагаете его цветовыми профилями, — выберите в списке эти профили. В списке Separations выберите профиль, соответствующий стандарту печати, например Eurostandard Un-coated (если вы намерены печатать на немелованной офсетной бумаге), Eurostandard Coated (если бумага мелованная) или Eurostandard Newsprint (если бумага газетная).

В разделе Options находятся флажки, демонстрирующие все прелести управления цветом. Флажок Simulate Separation Printer on Monitor включает имитацию на мониторе цветов, которые получатся на типографских оттисках. Это так называемый режим "экранной цветопробы". В идеале он должен сделать излишней привычную цветопробу. На практике, к сожалению, это не так, но точной настройкой системы управления цветом можно добиться впечатляющего соответствия.

Учтите, что режим "экранной цветопробы" работает только при просмотре изображений в максимальном разрешении. Если установлен режим просмотра точечных изображений с пониженным разрешением, то для ускорения работы они не корректируются системой управления цветом. Для смены режима демонстрации точечных изображений воспользуйтесь списком Display из раздела General диалогового окна Preferences или клавишами <Ctrl>+<Shift>+<F5>. Подробнее о режимах демонстрации изображений см. главы 3 и 7.

Флажок Simulate Separations Printer on Composite Printer позволяет использовать принтер для цветопробы. Он включает имитацию на принтере цветов, которые будут на типографском оттиске.

Если устройство вывода удовлетворяет приведенным выше требованиям и поддерживает управление цветом PostScript, то можно использовать вторую и третью схемы управления цветом. Режим использования аппаратно-независимого цвета устанавливается флажком Use Device Independent Color when Printing. В этом случае InDesign не осуществляет цветоделение, а использует модели RGB или LAB, имеющие более широкий цветовой охват, чем CMYK. Цветоделение, т. е. преобразование в модель CMYK осуществляет RIP, интерпретатор PostScript устройства печати. Если вы решили использовать аппаратно-зависимый вариант, то установите флажок Download CRDs to Printer. В этом случае профиль устройства вывода будет загружен в него вместе с публикацией. Даже если устройство вывода "знает" собственный профиль, будет использован загруженный. Для реализации аппаратно-независимого варианта флажок Download CRDs to Printer должен быть сброшен.


Настройка управления цветом в документе

По умолчанию во вновь создаваемом документе система управления цветом отключена. Это сделано разработчиками не случайно, поскольку прежде чем использовать систему управления цветом, необходимо выполнить множество действий, описанных выше. Построив все необходимые профили устройств и установив параметры системы управления цветом в диалоговом окне Application Color Settings, откройте диалоговое окно Document Color Settings (рис. 5.4). Флажок Enable Color Management включает управление цветом для текущего документа. Если вы хотите применять управление цветом для всех вновь создаваемых документов, воспользуйтесь механизмом умолчаний InDesign. Откройте диалоговое окно Document Color Settings в отсутствии открытых документов и сделайте необходимые установки. С этого момента установки будут приняты по умолчанию для всех вновь создаваемых документов.

В разделе Source Profiles находятся три списка, соответствующие цветовым моделям, поддерживаемым InDesign. В списках устанавливаются цветовые профили, которые используются в двух случаях. Во-первых, эти профили применяются автоматически ко всем объектам, создаваемым средствами рисования InDesign. Во-вторых, они используются для импортированных изображений, в которых отсутствуют внедренные профили.

Рис. 5.4. Диалоговое окно Document Color Settings

Обычно в качестве профиля RGB выбирают профиль монитора, полученный в результате калибровки. Это дает возможность работать с цветом объектов InDesign, используя их экранное представление. Вы можете быть уверены, что те цвета, которые вы видите на экране, являются хорошим приближением к тому, что получится на печати.

Поскольку профили, устанавливаемые в области Source Profiles, используются и для импортированных изображений без внедренных профилей, вы можете установить вместо профиля монитора профиль для таких изображений. Мы не рекомендуем этот способ определения профилей для импортированных изображений. Вместо этого предпочтительнее применить для внедрения профилей программу редактирования растровых изображений или задавать для них профили индивидуально. О том, каким образом это сделать, рассказано ниже.

Профиль CMYK обычно устанавливают таким же, который указан в установках системы управления цветом, в списке Separations диалогового окна Application Color Settings. Это означает, что цвета импортированных изображений не подвергнутся никакой коррекции и будут выведены на печать "как есть". В большинстве случаев именно это и требуется. Вместо того чтобы устанавливать конкретный профиль, вы можете выбрать вариант Use Separation Profile. В этом случае профили CMYK в обоих диалоговых окнах всегда будут идентичны независимо от того, какую установку вы сделаете в диалоговом окне Application Color Settings.

Наибольший цветовой охват из перечисленных цветовых моделей имеет LAB. Не меньшее ее достоинство в том, что она аппаратно-независима. Если вы работаете с аппаратно-независимой схемой управления цветом, то оцените возможность использования в верстке изображений в этой цветовой модели. По умолчанию для изображений и объектов в цветовой модели LAB применяется профиль Adobe InDesign Default LAB. Этот профиль в точности соответствует профилям, принятым для данной модели в Photoshop и Illustrator. Вам может понадобиться изменить профиль LAB только в том случае, если .ваша аппаратура откалибрована под строго определенный источник света.

Еще раз подчеркнем, что все приведенные профили распространяются на импортированные изображения, только если отсутствуют внедренные. При грамотно организованной технологической цепочке изображения без внедренных профилей должны быть редкостью. Отсутствие внедренного профиля говорит о неопределенности цветов изображения и не позволяет гарантировать адекватную цветопередачу. Внедренный профиль снимает с ваших плеч заботу о точности цветопередачи — InDesign и система управления цветом сами позаботятся об этом.

Если цветовой охват исходного изображения отличается от цветового охвата основного цветового пространства, то не все цвета изображения найдут точный эквивалент в рабочем цветовом пространстве. Параметр Rendering Intent как раз и определяет, что CMS должна делать с такими цветами.

  • Perceptual. Если в изображении есть цвета, выходящие за цветовой охват целевого пространства, то весь диапазон цветов пропорционально сокращается (включая и входящие в цветовой охват). В результате соотношение цветов сохраняется близким к исходному (поскольку все цвета меняются одинаково).

  • Saturation. При переводе сохраняется насыщенность цветов исходного изображения. Этот способ применим для сохранения ярких цветов, но их точность от такой коррекции сильно страдает.

  • Relative Colorimetric. Если данный цвет лежит вне охвата целевого пространства, он заменяется ближайшим из находящихся внутри. Цвета, изначально находящиеся в цветовом охвате, не изменяются. Этот способ может привести к тому, что цвета, изначально разные, после коррекции станут одинаковыми, а соотношение цветов изменится.

  • Absolute Colorimetric. Цвета передаются "как есть" в исходном изображении без поправки черной и белой точек. Это может привести к изменению яркости, и оправдано для изображений, содержащих точные цвета, такие, скажем, как красный цвет Coca Cola или желтый цвет Kodak.

Поскольку для векторных объектов и растровых изображений наилучшие результаты достигаются с различными способами преобразования цветового охвата, в InDesign они задаются независимо. В области Rendering Intent находятся два списка с перечисленными выше вариантами. Первый список, Solid Color, задает метод преобразования цветового охвата для объектов InDesign и импортированной векторной графики, а список Images — для растровых изображений. В подавляющем большинстве случаев можно оставить варианты, предлагаемые по умолчанию: Relative Colorimetric в списке Solid Color и Prceptual в списке Images.


Индивидуальные настройки для изображений

Если отдельные импортированные в публикацию изображения взяты из иных источников, чем основная масса или для них требуется другой способ преобразования цветовых охватов, настройте для них параметры управления цветом индивидуально.

Удобнее всего задавать индивидуальные параметры управления цветом непосредственно при импорте. Если в диалоговом окне Place установить флажок Show Import Options, то вам будет представлено диалоговое окно Image Import Options, включающее и настройки управления цветом (рис. 5.5). В нем вы можете задать для изображения индивидуальный профиль, выбрав его в списке Profile и способ преобразования цветового охвата в списке Rendering Intent. Если изображение уже содержит внедренный профиль, то в списке Profile будет автоматически установлен вариант Use Embedded Profile, а если профиля нет, то Use Document Default. Таким образом, при наличии внедренного профиля InDesign предлагает использовать именно его, а при отсутствии — профиль, установленный для изображений данной цветовой модели по умолчанию в диалоговом окне Document Color Settings. Если вы намерены сделать индивидуальную настройку профиля изображения, то выберите в списке требуемый профиль.

Обратите внимание, что для отдельного изображения можно вовсе отключить управление цветом, если сбросить флажок Enable Color Management. При отключенном управлении цветом InDesign не корректирует изображение ни при демонстрации на мониторе, ни на печати.

Рис. 5.5. Диалоговое окно Image Import Options

Индивидуальную настройку управления цветом для импортированных изображений можно выполнить и после их размещения в публикации. В меню Object и контекстном меню есть команда Image Color Settings, открывающая одноименное диалоговое окно (рис. 5.6). Оно практически идентично разделу Color Settings диалогового окна Image Import Options. В нем также ус-

танавливаются индивидуальный цветовой профиль изображения и способ преобразования цветового охвата.

Рис. 5.6. Диалоговое окно Image Color Settings


Нужна ли вам CMS?

Зачем вам вообще возиться с системой управления цветом? Она занимает большой объем оперативной памяти, замедляет работу системы и требует настройки. Не стоит использовать CMS, поскольку это не даст никакого выигрыша в работе, в следующих случаях:

  • Вы готовите черно-белые публикации и работаете с полутоновыми изображениями.

  • Вы работаете с плашечными цветами. Для выбора цветов пользуйтесь каталогами на бумаге. Точность отражения цветов на мониторе не принципиальна. Любой плашечный цвет можно подредактировать на мониторе для большей точности воспроизведения, на процесс печати это не повлияет.

  • Вы не печатаете публикации на бумаге, а готовите их для распространения в электронном варианте. В этом случае вас совсем не интересует процесс печати. Впрочем, в последнее время наметилась тенденция к проникновению управления цветом и в "электронные" издания. Возможно, "глядя в будущее", даже в этом случае стоит воспользоваться управлением цветом.

  • Вы не можете получить достаточно точные профили для всех задействованных в технологической цепочке устройств.

Если же вы работаете в основном с составными цветами (RGB, CMYK, Hexahrome), использование CMS действительно необходимо. Ведь в этом случае вы делаете цветокоррекцию фотографий и выбираете цвета, исходя из внешнего вида публикации на экране. Система управления цветом позволит вам добиться хорошего соответствия типографского оттиска тому, что вы видите на мониторе.

Учтите, что система управления цветом не делает чудес. Если исходные изображения публикации имеют плохое качество или неверную цветопередачу, то система управления цветом не исправит ситуацию. Она только лишь позволяет добиться одинакового воспроизведения цветов всеми устройствами, задействованными при подготовке публикации. Если исходные изображения плохи, то система управления цветом позаботится только о том, чтобы они были одинаково плохи как на мониторе, так и на принтере или типографской машине. Система управления цветом не снимает с вас ответственности за качество исходных материалов публикации.


Резюме

  • Для обеспечения одинаковой передачи цветов всеми задействованными при создании публикации устройствами используются системы управления цветом.

  • Система управления цветом способна работать только с калиброванными устройствами, параметры цветопередачи которых известны и приведены в файле профиля *.IСМ. "Зная" параметры всех устройств, система управления цветом может вносить поправки в цвета изображения при передаче его разными устройствами. Для получения профилей используются специальные измерительные устройства и образцы цветов.

  • Технология PostScript способна обеспечить управление цветом как на уровне приложений, так и средствами растрового процессора.

  • InDesign может работать с любыми системами управления цветом, установленными на компьютере. Чтобы осуществлять управление цветом, необходимо установить профили устройств в диалоговом окне Application Color Settings в InDesign.

  • При размещении изображений InDesign получает данные об их цветах из внедренных профилей. Внедренные профили характеризуют цветопередачу изображений и создаются при их получении (программным обеспечением сканера, цифровой камеры, и т. д.) или редактировании в редакторах точечных изображений (таких, как Photoshop).

  • В диалоговом окне Document Color Settings устанавливаются профили применяемые к объектам, создаваемым средствами InDesign и импортированным изображениям, лишенным внедренных профилей.

  • Параметры управления цветом можно настроить для импортированных изображений индивидуально.


Глава 6

Форматирование символов

Основное отличие пакета верстки от текстового процессора — возможность достижения очень высокого качества публикации. Разместить картинки и набрать текст можно и в текстовом редакторе. Но часто бывает так — публикация напечатана в цвете, на хорошей бумаге и с красивыми иллюстрациями. А выглядит небрежно, неряшливо. Бывает (реже) и обратная ситуация — несмотря на скромное оформление и недорогую бумагу издание смотрится профессионально и красиво. Скорее всего, дело здесь в качестве верстки. Это прежде всего правильное размещение текста набора. Шрифт и размеры букв и символов подбираются в соответствии с целями публикации и параметрами страницы. Интервалы между символами и словами устанавливаются так, чтобы текст выглядел как можно более равномерно, заполнял отведенную ему площадь и легко читался. То же касается и других параметров — расстояний между строками, оформления таблиц, специальных текстовых эффектов и пр. Все они должны быть выверены до десятых долей миллиметра. Если ваша публикация отлично сверстана, она уже будет смотреться профессионально.

Данная часть книги посвящена как раз тексту. Она очень важна для последующей работы. Здесь будут освещены следующие темы:

  • Шрифты и гарнитуры
  • Атрибуты и способы форматирования символов
  • Кегль
  • Интерлиньяж
  • Межсимвольные и межсловные интервалы
  • Кернинг и трекинг
  • Базовая линия строки


Шрифт

Основной целью любого документа, будь это учебник, записка, рекламный плакат, является передача информации — от учителя к ученику, от автора к читателю, от производителя к покупателю и др. Ее носителем в данном случае выступает текст, написанный от руки или напечатанный. При передаче информации в письменном виде принято, чтобы все буквы были чем-то похожи друг на друга, поскольку это облегчает восприятие текста. Если мы пишем послание от руки, то стиль начертания букв называется почерком. В случае печатного слова характер изображения символов текста мы назовем шрифтом.

Каждый из шрифтов имеет свои художественные особенности. Несмотря на большое разнообразие, практически во всех шрифтах можно выделить общие элементы. На рис. 6.1 представлены основные элементы шрифтов.

Рис. 6.1. Основные элементы шрифта


Гарнитура

В настоящее время шрифтом называют набор символов данного рисунка. Шрифты объединяются в гарнитуры.

Раньше в шрифте определялся и размер символов. В настоящее время слово шрифт обозначает более широкое понятие. Однако употребление терминов "шрифт" и "гарнитура" в качестве синонимов все же некорректно.

Гарнитура — это шрифт или группа шрифтов, имеющих одинаковый стиль и дизайн. Шрифты в гарнитуре могут различаться по толщине штрихов, наклону, соотношению ширины и высоты. Они могут быть светлыми и жирными, широкими и узкими, прямыми, наклонными и курсивными. Каждая гарнитура имеет имя. Например, AvantGarde, к которой относятся такие шрифты: Avan+Garde, AvantGarde, AvantGarde, AvantGarde.


Группы шрифтов

В какой-то мере шрифты являются произведениями искусства. Поэтому их невозможно строго классифицировать. Многие из ныне используемых гарнитур созданы давно (например, "Академия", "Баскервиль", "Тайме", "Авангард"), другие придуманы недавно. Все элементы в качественном шрифте гармонично сочетаются, образуя настоящее произведение искусства, выполненное художником-графиком.

По применению шрифты условно делятся на наборные, заголовочные и декоративные (акцидентные). Первые применяются для набора больших объемов текста — книг, статен и др. Это шрифты с тонкими штрихами, простым рисунком и засечками (серифами). Страница, напечатанная таким шрифтом, легко читается даже если размер символов (кегль) очень мал. Заголовочные шрифты обычно имеют более толстые штрихи, не имеют засечек и хорошо смотрятся в крупном кегле. Декоративные шрифты имеют произвольный рисунок символов, применяются только для коротких заголовков, которые можно рассматривать скорее как элементы дизайна. Кроме того, есть еще символьные шрифты. Они вместо букв содержат различные символы, рисунки и т. д. и применяются, разумеется, не для набора текста, а для создания графических объектов, формул, чертежей и т. д. Примеры шрифтов всех этих типов приведены в табл. 6.1. Разумеется, эта простейшая классификация не является строгой и исчерпывающей. Многие шрифты, в том числе и распространенные, нельзя отнести ни к одному из типов. Есть шрифты универсальные, такие как "Гельветика", они применяются как в крупном кегле (заголовки), так и в мелком (набор).

Существует множество классификаций шрифтов. Каждая из них делит шрифты на много классов и подклассов. Примеры классификаций — ГОСТ, Windows, PANOSE.

Таблица 6.1. Типы шрифтов

Рубленые (Sans Serif) | С засечками (Serif) | Акцидентные (декоративные) | Символьные (Symbol)
Arial | Times New Roman |  |

Засечки (серифы) — это горизонтальные штрихи, располагающиеся сверху и снизу основного штриха (см. рис. 6.1). Серифы оттеняют силуэт буквы, делая шрифт более читаемым и менее "суровым", чем рубленый шрифт.

Кроме прямого назначения — передачи информации — шрифты, использованные в публикации, являются элементом дизайна. Большинство гарнитур, особенно те, рисунок которых необычен, имеют стиль и настроение. Так, "Итальянская узкая" напомнит о салунах Дикого Запада (или о революционных плакатах 1917 года), "Европа" придаст тексту уверенный и современный вид, Lithos стилизует надпись под греческие письмена, высеченные в камне. Allegro придаст публикации вид дамского альбома, Plain Script сделает страницу неформальной, словно написанной от руки. Для текста детской книжки подойдет шрифт SchoolBook (он хорошо читается), а для заголовков — Dolores ("веселая" гарнитура). Для финансового отчета фирмы вы воспользуетесь абсолютно строгим Times в сочетании с несколько претенциозным Optima. Для заголовков туристского рекламного буклета по Москве подойдет Izhitsa (откровенный псевдорусский шрифт, похож на московский ГУМ) или Slavianic, а по Петербургу — Academy и Baltica.

Теперь, с развитием технологии PostScript, появился огромный выбор гарнитур на все случаи жизни, и число их быстро растет. Дизайнер стал абсолютно свободным в выборе шрифтового оформления и связан лишь собственным (и клиента) вкусом и здравым смыслом. В такой ситуации можно подбирать гарнитуры по характеру публикации. Гарнитуры не только должны соответствовать типу издания, но и гармонично сочетаться между собой. Со вкусом выбранное сочетание гарнитур придает даже скромной публикации профессиональный вид, и наоборот, неподходящие или несовместимые шрифты вызывают у читателя раздражение.

Декоративный шрифт запоминается, становится легко узнаваемым и если используется в изданиях постоянно - надоедает. При выборе шрифта для заголовка избегайте тех, которые вы постоянно видите на рекламных щитах, газетных объявлениях и пр. Если они стали раздражать вас, они так же будут действовать на потенциальных читателей.

Для достижения хорошего качества текста опытным путем выработаны правила выбора гарнитур. Так, рубленые обычно используются для заголовков, с засечками — для основного текста. Рубленые шрифты хуже читаются в мелком кегле, чем шрифты с серифами (исключения составляют такие шрифты, как News Gothics и Franklin Gothics, специально предназначенные для набора в мелком кегле).

Кегль — вертикальный размер символов шрифта, включает в себя высоту литеры и свободного пространства над и под ней (оплечиков). О кегле подробнее см. далее в этой главе.

Для основного текста следует использовать наиболее читаемый, а именно прямой светлый шрифт. Заголовок, занимающий менее трех строк, лучше набрать пожирнее, чем основной текст, если заголовок имеет три и более строки, то он и основной текст могут быть одинаковой жирности. Гарнитуры заголовка и основного текста должны быть совместимы, часто хорошо смотрится сочетание похожих гарнитур, но одинаковых гарнитур одного начертания для текста и заголовка лучше избегать.

При работе над публикацией не теряйте из виду главную цель любого документа — он должен служить средством общения. Публикация должна быть легко читаемой. Перед тем как принимать решение об окончательном дизайне, сделайте пробный отпечаток одной страницы и попробуйте прочитать его с расстояния вытянутой руки. Если это сделать трудно, то, возможно, придется изменить гарнитуры на более читаемые, или поработать с интерлиньяжем, кеглем, трекингом текста. Учтите, что лазерный принтер печатает с разрешением в 5—10 раз меньшим, чем разрешение фотонабора. Поэтому при печати на принтере штрихи будут гораздо толще, чем на пленках, выводимых на фотонаборном автомате. Чем меньше разрешение принтера, тем толще будут буквы.

Интерлиньяж— межстрочное расстояние, кернинг и трекинг определяют межбуквенные пробелы. Подробнее об этих параметрах см. далее в этой главе.

И, наконец, о чувстве меры. Принято, чтобы на каждой странице использовалось не более трех (а лучше двух) наборных гарнитур и не более одной декоративной. В противном случае, вместо привлечения внимания читателя достигается обратный эффект — глаза разбегаются от пестроты, и читать не хочется.


Начертание

Начертание — это один из вариантов шрифтов в гарнитуре. Оно однозначно определяет вид шрифта. Начертания имеют стандартные названия, например курсивное начертание, полужирное, светлое, наклонное. Название начертания состоит из нескольких слов. Первое определяет насыщенность шрифта, второе — степень наклона, третье — дополняет определение начертания.

Компьютерные шрифты создаются самыми разными производителями, живущими в разных странах. Они могут и не придерживаться общего стандарта именования шрифтов.

В табл. 6.2 приведены примеры некоторых начертаний. Начертание включает в себя различные характеристики. Приведем некоторые из них:

Насыщенность — относительная толщина штрихов символов. Чем более насыщен шрифт, тем темнее будет выглядеть текст, им набранный (рис. 6.2). Начертания могут быть светлыми, полужирными, жирными, обычными

Сравнив несколько шрифтов с одинаковыми параметрами насыщенности, но принадлежащих к разным гарнитурам, вы увидите, что некоторые из них темнее, а некоторые светлее. Поэтому можно говорить о насыщенности и как общей характеристике гарнитуры.

Рис. 6.2. Насыщенность различных шрифтов

Пропорциональность — относительная ширина знаков шрифта. Гарнитура может включать обычное, широкое, узкое начертания. Встречается и более тонкое деление начертаний по пропорциональности.

Наклон. Если шрифт не имеет наклона, он называется прямым. Наклонный шрифт образуется наклоном символов обычного начертания шрифта.

Курсив. Особое начертание, характерное для наборных шрифтов с засечками. Буквы в курсивном начертании имеют лишь сходство с прямыми по стилю, рисунок их совсем другой и напоминает рукописный шрифт.

Производители гарнитур могут включать в их комплект любые, самые экзотические начертания, например, инверсный, искаженный, снабженный тенью, лишенный заливки и пр. Наиболее распространенные начертания Normal (Обычный), Bold (Полужирный), Italic (Курсив).

Таблица 6.2. Начертания

Пример | Насыщенность | Наклон | Особенность
AaBbCcDd | Regular (Нормальный) |  |
AaBbCcDd | Regular | Italic (Курсивный) |
AaBbCcDd | Regular |  |
AaBbCcDd | Regular |  | Extended (Широкий)
AaBbCcDd | SemiBold (Полужирный) | Italic | Extended
AaRbCcDd | SemiBold |  |
AaBbCcDd | Bold (Жирный) | Italic |
AaBbCcD d | Bold |  |

Немаловажными характеристиками шрифта являются также высота строчной буквы (называемая также х-высотой), соотношение прописной и строчной букв (рис. 6.3) и ширина цифры (обычно все цифры шрифта имеют одну ширину, что особенно удобно при наборе таблиц).

Рис. 6.3. Шрифты с разным соотношением прописной и строчной букв


Метрические параметры шрифта

Кроме шрифта и начертания, символы в тексте характеризуются различными размерами. Ниже приводится обзор наиболее важных метрических параметров. Изменяя их соотношение, вы регулируете внешний вид и объем текста.

На приведенном рисунке показаны основные метрические параметры наборного шрифта (рис. 6.4).

Рис. 6.4. Параметры шрифта


Кегль. Традиционные полиграфические единицы измерения

Компьютерные издательские системы появились сравнительно недавно, как и сами персональные компьютеры. С другой стороны, книгопечатный станок изобретен Гутенбергом в 40-х годах XV века, а после изобретения в 1814 году офсетной машины полиграфический процесс, можно сказать, приобрел современные очертания. В полиграфии, как и в любой традиционной отрасли, сохраняется исторически сложившаяся терминология, а также система измерений, основанная на числах типа 72 или 1/1440. Использование традиционных единиц измерения оправдано, поскольку дает возможность сопоставить размеры всех элементов публикации — шрифта, полей, страницы и полосы набора и др. Для того чтобы контакты с типографией и издательствами были дружескими и плодотворными, дизайнеру, несмотря на то что всю сознательную жизнь он старался пользоваться десятичной системой счисления, придется выучить полиграфические единицы.

Пункт — традиционная полиграфическая единица измерения. В пунктах измеряются величина символов шрифта, интерлиньяж (расстояние между строками текста), толщина линий и некоторые другие параметры страницы. Пункт равен 1/72 дюйма или 0,352 мм. Использование особой единицы в данном случае оправдано — стандартные для публикаций кегли (10, 12, 8 пунктов) и обводки (0,25, 0,5, 1 пункт), выраженные в миллиметрах — это нецелые значения и работать с ними неудобно.

Кроме пунктов, в полиграфии используются пики. В них выражается ширина и высота колонок, полос и страниц. В одной пике 12 пунктов, значит в дюйме 6 пик. В десятичных единицах пика равна 4,236 мм. Величина символов шрифта и интерлиньяж оцениваются в пунктах. Одна пика равна шести пунктам. Использование пик и пунктов дает возможность сопоставить величину шрифта с остальными элементами публикации — полями, размером страницы и полосы набора и др. На рис. 6.5 даются сравнительные линейки, размеченные описанными единицами по отношению к миллиметровой шкале.

Рис. 6.5. Сравнение миллиметров, дюймов и полиграфических единиц измерения

Из-за исторически сложившейся разницы в размере дюйма в Европе и Америке, пункт как единица, производная от дюйма, тоже бывает разным. Описанный пункт, равный 0,352 мм — пункт PostScript (производное американского дюйма) Шесть пунктов PostScript равны одной пике. Описанные единицы измерения характерны для США и, в связи с распространением языка описания страниц PostScript и систем верстки американского производства стали стандартом и в других странах.

В европейских странах до сих пор принята несколько отличающаяся система измерений — в качестве основной единицы у них используются пункты Дидо, 1/72 часть европейского дюйма. Один пункт Дидо равен 0,376 мм, или 1,07 пункта PostScript. 12 пунктов Дидо составляют цицеро.

Кегль — это высота строки символов, т. е. расстояние от нижнего до верхнего выносного элемента (см. рис. 6.4) плюс поля над и под литерой. Это свободное пространство (оплечики) определяется в самом шрифте и нужно для того, чтобы символы верхней и нижней строк не сливались. Все это вместе составляет кегль, задаваемый в программе.

Если набрать разными гарнитурами одного кегля строчку текста (как на рис. 6.6), очевидно, что видимая величина символов сильно разнится. Это происходит потому, что кегль задает не размер собственно букв, а высоту строки текста. Символы разных гарнитур могут иметь разное начертание, а конечный продукт (текст) должен смотреться гармонично. Поэтому величина символов сбалансирована художником, создавшим шрифт так, чтобы они красиво заполняли строку размером, в данном случае, 24 пункта. Скажем, в шрифте Torhok очень маленькие строчные литеры потому, что создатель решил сделать изящный, очень легкий и светлый шрифт, с акцентом на прописные. Если набрать этим шрифтом страницу, то на ней будет слишком пусто, поскольку большая часть строки не заполнена символами, но никто и не собирается этого делать, поскольку Torhok плохо читается и используется лишь для украшения публикации.

Рис. 6.6. Текст, набранный разными гарнитурами одного кегля

С кеглем тесно связан еще один параметр — высота строки (рис. 6.7). Если строка символов набрана единым кеглем, ее высота совпадает с кеглем набора. Если же кегль в пределах строки разный, то высота строки считается по наибольшему значению.

Рис. 6.7. Высота строки

В полиграфии иногда используются исторические названия некоторых кеглей: бриллиант (3 пункта), диамант (4 пункта), перл (5 пунктов), нонпарель (6 пунктов), миньон (7 пунктов), петит (8 пунктов), боргес (9 пунктов), корпус (10 пунктов), цицеро (12 пунктов), миттель (14 пунктов), терция (16 пунктов), текст (20 пунктов).


Принципы выбора кегля для публикации

Выбор кегля зависит от ширины блока (полосы), в которой он должен разместиться, т. е. от длины строки. На строке должно быть расположено не более 60 символов. Причем снижение их числа до 50 только улучшает внешний вид текста. Величина наборного шрифта обычно равна 10 пунктам. Кегль 9 можно использовать в справочниках, особенно если несколько увеличить междустрочный пробел.

Таблицы, сноски и за текстовые комментарии набираются меньшим кеглем. чем обычный текст (для набора 10-м кеглем текст таблицы имеет кегль 8).

В полиграфии также используются относительные единицы измерения — шпации. Они характеризуют горизонтальные размеры шрифта. Круглая шпация равна кеглю шрифта, полукруглая шпация — половине кегля, тонкая шпация — четверти. Шпации применяются при измерениях абзацных отступов, кернинга и других перемещениях символов. Эти перемещения (в первую очередь кернинг) совершаются для улучшения зрительного восприятия текста, поэтому важны не точные значения смещений, а их отношение к величине символов. Применение относительной единицы измерения автоматически делает эти смещения пропорциональными размеру шрифта.

В классической полиграфии шпации рассчитываются по отношению к ширине заглавных букв М, N и строчной буквы t данного шрифта. Круглая шпация равнялась ширине заглавной буквы М, полукруглая — ширине заглавной буквы N, а тонкая шпация равна ширине строчной буквы t. Все шрифты разные, и ширина букв у них тоже разная. Такой метод расчета ставил величину шпации в зависимость не только от кегля, но и от шрифта набора, что вообще говоря, более корректно. В программах фирмы Adobe в настоящее время определение шпации упрощено.


Базовая линия

Базовая линия — это воображаемая линия, проходящая по основаниям символов текста (рис. 6.8). Получается, что в строке текста сами символы стоят на базовой линии, а нижние выносные элементы текста как бы свисают с нее. Кроме нижних выносных элементов, в обычном наборе базовые линии символов совпадают, однако они могут быть смещены для каждого символа отдельно. Смещение базовой линии отдельных символов применяется чаще всего для набора индексов.

Рис. 6.8. Базовые линии строки и индексов

Рис. 6.9. Смещение базовой линии

Индексы встречаются, в основном, в технической и научно-популярной литературе. Они оформляются путем смещения базовой линии в сочетании с уменьшением кегля. Так, в специальных текстах (математические, химические статьи и книги) ниже базовой линии располагаются подстрочные индексы. Базовая линия верхних индексов (их можно увидеть в любых изданиях в качестве номеров примечаний или комментариев) расположена значительно выше базовой линии остальной строки.

Смещение базовой линии применяется и для достижения специальных эффектов (рис. 6.9), например, в заголовках и логотипах.


Емкость

Как мы уже выяснили, кегль шрифта не определяет однозначно его размеры. В зависимости от других метрических параметров (пропорциональности, соотношения прописной и строчной, размера полей и пр.), текст, набранный разными шрифтами, занимает разный объем. Для удобства введено понятие емкости шрифта. Чем больше символов данного кегля помещается в строку данной длины, тем более емким является шрифт. На рис. 6.10 представлены примеры одинакового текста, набранного шрифтами разной емкости. При подготовке к верстке больших документов (например, книг) обязательно подбирается шрифт подходящей емкости, поскольку этот параметр сильно влияет на конечный объем публикации.

Рис. 6.10. Шрифты разной емкости


Интерлиньяж

Плотность строк на странице публикации характеризуется значением интерлиньяжа. Раньше, когда набор текстов производился вручную, для увеличения расстояния между строками текста по вертикали между строками прокладывались тонкие латунные полоски шириной в 2 пункта — шпоны. В традиционной полиграфии интерлиньяж (междустрочный пробел) означал количество пунктов между строками в наборе (рис. 6.11, а). Так, если между строками набора прокладывались два шпона, толщина каждого из которых составляла 2 пункта, общий интерлиньяж составлял 4 пункта.

В настоящее время в понятие интерлиньяжа вкладывается несколько иной смысл. Интерлиньяж в большинстве издательских пакетов определяет расстояние между базовыми линиями смежных строк (рис. 6.11, б). Если текст набран кеглем 11/13, это значит, что кегль составляет 11, а интерлиньяж — 13 пунктов. Следовательно, расстояние между смежными строками составляет 2 пункта.

а [image] б

Рис. 6.11. Традиционное (а) и современное (б) определение интерлиньяжа

Интерлиньяж является атрибутом символа и теоретически задается для каждого символа текста отдельно. Однако в тексте буквы обычно расположены на единой базовой линии. Поэтому если в пределах строки интерлиньяж символов имеет различные значения, то интерлиньяж всей строки устанавливается по наибольшей величине.

Для обычного (наборного) текста интерлиньяж принято устанавливать на 1/5 часть больше кегля. Так, при наборе 10-м кеглем интерлиньяж составляет 12 пунктов, при наборе 8-м — 9,6 пункта. Однако практика, как всегда, сильно отличается от теории.

Интерлиньяж сильно влияет на внешний вид и читаемость текста. Для мелкого кегля он может быть несколько больше номинального значения, тогда текст будет легче читать. В некоторых изданиях небольшое уменьшение кегля и расширение интерлиньяжа используют как художественный прием. Страница, набранная таким образом, выглядит очень светлой, воздушной, особенно если имеет широкие поля. Текст крупного кегля требует меньшего интерлиньяжа. Интерлиньяж в заголовках обычно устанавливается равным кеглю и даже меньше. Если интерлиньяж меньше, чем кегль текста, он называется отрицательным. В наборном тексте отрицательный или даже равный кеглю интерлиньяж применять нельзя — это приводит к слиянию выносных элементов букв в соседних строках и текст станет не читаем. Отрицательный интерлиньяж с очень малыми значениями применяется как художественный прием (рис. 6.12) для оформления заставок, заголовков, логотипов.

Рис. 6.12. Отрицательный интерлиньяж

Установка интерлиньяжа также зависит от соотношения высоты прописных и строчных букв. В разных шрифтах это соотношение может быть совершенно различным. Если оно мало, то интерлиньяж выбирается несколько большим, если велико — меньшим, по сравнению со стандартным.


Пробел и боковые поля

Пробел между словами, вводимый нажатием клавиши <Space> — это тоже символ шрифта. В разных шрифтах ширина пробела различна. В программах верстки есть способы регулирования этого параметра. Пробел оказывает влияние на легкость чтения и объем текста. Чем шире пробел, тем больший объем займет один и тот же текст. Текст с очень узкими пробелами плохо читается, поскольку слова в нем сливаются. Если пробел слишком широкий, легкость чтения тоже снижается, поскольку текст "разваливается" на несвязанные между собой слова. Величина пробела может варьироваться в пределах текста при его выравнивании.

Кроме пробела, определяемого в шрифте, в программе InDesign предусмотрено еще несколько видов специальных пробелов. Все они являются неделимыми, т. е. по месту этих пробелов текст не переходи! на другую строку. В отличие от обычного пробела, размер которого определяется в шрифте, неделимые пробелы зависят только от кегля.

  • Em-space — пробел шириной в одну круглую шпацию, т. е. равный кеглю.
  • En-space — пробел шириной в одну полукруглую шпацию, т. е. равный половине кегля.
  • Thin Space — пробел шириной в одну тонкую шпацию, т. е. равный четверти кегля.
  • Flush Space — в общем случае — обычный пробел, также зависит от шрифта и кегля. Если стоит перед последним символом абзаца полностью выключенного текста, то последний символ смещается в крайнюю правую позицию, а весь дополнительный интервал помещается в данный символ.
  • Hair Space — пробел, равный 1/12 кегля.
  • Em-dash — дефис. - En-dash — тире.

В шрифте также задается величина просвета между символами внутри слова. В состав каждой литеры, кроме рисунка самого символа входят поля. Верхнее и нижнее поле уже упомянуты в разделе о кегле. Боковые поля (их называют полуапроши) определяют расстояние между символами в тексте. В шрифте задаются стандартные для данного шрифта поля. Программы верстки позволяют менять межбуквенные интервалы в широких пределах. Чем они больше, тем больший объем занимает текст и тем более светлым и рыхлым он выглядит. Межсимвольные интервалы должны быть заметно меньше пробелов, иначе слова сольются в одно большое слово, и текст невозможно будет прочитать. Меняя размеры пробелов и межсимвольных интервалов можно в широких пределах менять объем текста. Приемы регулирования объема текста описаны в главе 7.


Кернинг

Несмотря на то что размер боковых полей является характеристикой шрифта, его значение не должно быть всегда одинаковым. Форма символов шрифта различна, и для некоторых сочетаний он выглядит увеличенным (реже — уменьшенным) по сравнению с другими. Следовательно, межсимвольные пробелы не должны быть одинаковы для всех сочетаний букв в тексте. Так, на рис. 6.13 пробел между буквами "Г" и "А" выглядит шире, чем между буквами "И" и "Г". Создается ощущение, что они принадлежат к разным словам. От этого легкость чтения и привлекательность текста снижаются. Если немного изменить величину межсимвольного расстояния для этой пары так, чтобы выступающие части одного символа пары заходили в пространство второго символа, текст станет более равномерным, и читать его будет легче.

Рис. 6.13. Текст с кернингом

Настройка интервалов между некоторыми парами символов шрифта называется кернингом пар. Соответственно, пары, для которых необходимо изменять межсимвольный пробел, называют кернинговыми парами. Кернинг может быть применен к буквам, знакам препинания и к пробелам. На рис. 6.13 представлены символы с выполненным кернингом. Результат — размещение символов становится зрительно более равномерным. Кернинг, т. е. перемещение символов в паре производится на весьма малые расстояния и измеряется в тысячных долях круглой шпации.

Обычно шрифты имеют таблицы кернинга, т. е. список пар символов, между которыми нужно сокращать пробел при наборе текста и инструкциями, на какую величину следует производить кернинг в каждом случае. Это, например, пары "ГО", "ГА", "АУ", "Ст" и другие. Если в шрифте есть большая таблица пар кернинга, он будет хорошо, равномерно смотреться в разном кегле. Программы верстки снабжены возможностью автоматического кернинга, они имеют собственные таблицы пар.

В такой программе можно организовать автоматическую корректировку пробелов в кернинговых парах в тексте любой длины. Чем крупнее текст, тем большее значение для его внешнего вида имеет хороший кернинг, тем более тщательно он должен быть отформатирован, ведь любой достаточно большой промежуток сразу бросается в глаза. Даже после обработки текста автоматическим кернингом в заголовках и другом крупном тексте дополнительно проводят ручной кернинг, т. е. символы сближают вручную, произвольно. Текст мелкого кегля можно вообще не подвергать кернингу, поскольку при уменьшении букв уменьшаются и межсимвольные промежутки.


Трекинг

Трекинг, в отличие от кернинга, задается не для пары, а для группы символов и характеризует величину межсимвольного пробела в группе. Пробелы меняются одинаково для всех выделенных символов. Трекинг также измеряется в тысячных долях круглой шпации. Уменьшение трекинга отнимает, а увеличение прибавляет к межсимвольному расстоянию определенную величину. Трекинг может быть проведен для любого количества символов (рис. 6.14).

Рис. 6.14. Трекинг


Ширина и высота символов

При использовании расширенного и суженного начертания шрифта, рисунок букв изменяется в соответствии с меняющейся шириной так, чтобы получился гармоничный шрифт с выверенным соотношением ширины штрихов и межбуквенных просветов. Ширина и высота символа в принципе могут изменяться простым сжатием и растяжением. На рис. 6.15 представлены результаты изменения ширины символов разных шрифтов. Значение

ширины символов меняется и при масштабировании текстового объекта. Значение высоты в поле Vertical Scale не меняется при масштабировании — вместо этого увеличивается или уменьшается кегль.

Рис. 6.15. Ширина символов

При сжатии и растяжении нарушаются соотношение толщин между горизонтальными и вертикальными штрихами символов, пробелы в очках букв "Б", "О", "Q" и т. д, внешний вид и читаемость шрифта ухудшаются. Особенно к этому чувствительны шрифты с засечками, поэтому для них ширину менять нежелательно. Рубленые шрифты меньше искажаются при смене ширины, но и для них эту величину не стоит менять более чем на 10—20%.


Шрифт в вашем компьютере

Компьютерный шрифт представляет собой программу, которая может быть использована во всех Windows-приложениях. Шрифты входят в комплект системы Windows. Они разрабатываются производителями приложений (особенно графических векторных программ) и поставляются вместе с ними. Наконец, есть фирмы, занятые исключительно производством шрифтов на все случаи жизни.

Программа шрифта включает в себя описание входящих в него символов, их метрических параметров, и прочих особенностей шрифта. Форматом шрифта называется способ представления этой информации в цифровом виде. Исторически сложилось так, что в мире существует несколько форматов шрифтов для персональных компьютеров. Наиболее популярны шрифты корпорации Adobe Systems, разработавшей стандарт Typel, и Microsoft Corp., создавшей формат TrueType. Оба стандарта имеют свои достоинства, что привело к их параллельному сосуществованию, а шрифты стали производить и в том и в другом.

Программа шрифта в любом формате представляет собой один или несколько файлов, которые можно копировать, удалять, переименовывать, как обычные файлы. Для того чтобы вы могли использовать шрифт в работе, он должен быть установлен на вашем компьютере.

Однако это далеко не все. Цифровой шрифт состоит из контура, который описывается с помощью кривых, векторов и заполнения. Поэтому он может быть произвольно масштабирован и искажен без ухудшения качества. В то же время при выводе на любое устройство (монитор, принтер) символ шрифта отображается точками, т. е. происходит его растеризация. Программа, выполняющая этот процесс, называется растеризатором. В применении к шрифту ее называют также шрифтовой машиной. Она понимает данный формат шрифта и делает его доступным для отображения на экране и других устройствах вывода. Шрифты TrueType имеют шрифтовую машину, встроенную в операционную систему Windows. Шрифты Type 1 обеспечиваются шрифтовой машиной Adobe Type Manager (ATM).

При выводе текста на принтер PostScript растеризация осуществляется встроенными программными средствами принтера. Если вы пользуетесь не PostScript-устройством для вывода, то растеризацию выполняет шрифтовая машина.


Немного о форматах

Каждое начертание шрифта — это самостоятельный файл. На компьютер можно установить как начертания (по одному или группой), так и всю гарнитуру сразу. В файлах шрифта хранится весьма обширная информация. В том числе:

  • Рабочее и полное имя шрифта, имя гарнитуры, к которой принадлежит шрифт, и название начертания.
  • Сведения об авторах шрифта. - Уникальный регистрационный номер шрифта.
  • Сведения о метрических размерах символов — ширина символов, стандартный размер полей и оплечиков.
  • Информация о парном кернинге. Чем больше таблица кернинговых пар в шрифте, тем более качественно он будет форматироваться. Если в самом шрифте нет информации о кернинге, эту функцию берет на себя программа верстки (если она обладает возможностью автоматического кернинга).
  • Таблицы трекинга шрифта. Главным достоинством шрифта (особенно наборного) является легкость чтения. Она обеспечивается в большой степени правильно подобранным размером полей символов. В зависимости от кегля шрифта, для улучшения восприятия нужны разные поля. Мелкий текст будет лучше смотреться со слегка увеличенными полями, в очень крупном поля лучше сильно уменьшить. Таблицы трекинга содержат информацию о зависимости ширины полей от кегля.
  • Описание общих элементов. Если символы шрифта содержат общие элементы, то для экономии места все они описываются в особой области, а в области описания каждого символа дается ссылка на общий элемент.
  • Кодовые таблицы — таблицы соответствия между кодом в таблице ANSI и именем символа шрифта.
  • Описание разметки символов. Разметка необходима для качественного воспроизведения символов на устройствах вывода — растеризации.
  • Описание формы каждого символа. Это основная часть файла шрифта.


Разметка

Разметка — это средство улучшения растеризации. Дело в том, что при выводе шрифта на экран или принтер производится превращение его из векторного формата в растровое изображение с конечным разрешением. Чем меньше размер символов и чем меньше разрешение выводного устройства, тем больше вероятность искажения формы символа. На рис. 6.16 приведены некоторые примеры.

Рис. 6.16. Искажение формы символа при выводе

Если в состав шрифта ввести описание его элементов (толщины штрихов, углы наклона, радиусы округлых штрихов и пр.), и передавать эти данные устройству вывода, то с учетом этих параметров качество ввода улучшится.

В шрифтах Type l разметка производится декларативно. При загрузке шрифта в растеризатор отправляются отдельно описание контура шрифта и отдельно — набор команд по его построению. Команды содержат сравнение элементов шрифтов. Так, декларативная разметка определяет, что горизонтальные штрихи должны быть равны вертикальным, засечки должны иметь равную длину, средняя линия шрифта должна проходить на одинаковой высоте, равным должен быть оптический наплыв и высота и пр. Растеризатор такого шрифта — это сложнейшая программа, которая и выполняет связывание формы символов с командами разметки. Шрифты Type l гораздо проще, чем TrueType. Качество их вывода зависит прежде всего от качества растеризатора.

В TrueType используется программируемая или жесткая разметка. Для символов точно указываются все действия, которые должен выполнить растеризатор. Дается исчерпывающее описание символов — толщины вертикальных штрихов, горизонтальных штрихов, ширины и высоты символов, указываются угол наклона засечек, поля, величина оптического наплыва и прочие характеристики. Когда шрифт поступает на обработку растеризатором, все его параметры определены, и поэтому растеризатор TrueType имеет очень простое устройство. Шрифты в этом формате, напротив, имеют большой размер файла и сложное строение. Такой шрифт теоретически может обеспечить очень высокое качество вывода. Оно прежде всего зависит от качества разметки в шрифте.

Поскольку написать TrueType шрифт с хорошей разметкой оказывается сложным делом, многие производители используют программы автоматической разметки шрифта. Эти программы не способны обеспечить хорошее качество качество. В то же время производство шрифтов Type 1 приемлемого качества не связано сложностями разметки, поскольку большую и самую сложную часть работы берет на себя растеризатор, а он один для всех шрифтов. В результате при выводе на принтер (а тем более на фотонаборный автомат) шрифты Туре 1 имеют значительный перевес в качестве над TrueType. Чем больше разрешение выводного устройства, тем больше заметна разница в качестве.

Если вы готовите публикацию к печати на PostScript-устройстве, мы советуем вообще отказаться от использования шрифтов TrueType. Кроме более низкого качества, есть и еще один довод. Шрифты Type I — это программы на языке PostScript. При передаче их на принтер (программное обеспечение которого использует тот же язык описания страниц) интерпретация происходит без проблем. Формат шрифтов TrueType не может быть интерпретирован напрямую. Предварительно он преобразуется в PostSsript драйвером принтера. Это дополнительное действие таит в себе возможность ошибки.

Если вы готовите публикации для распечатки на не-PostScript-принтере (например, струйном) или вообще работаете для Web, то в принципе безразлично, каким шрифтом пользоваться, поскольку разрешение в этих случаях невелико, и перекодировка не требуется.

К положительным сторонам шрифтов TrueType относится то, что они поддерживаются системой Windows и являются "родными" для офисных приложений. В то время как для шрифтов Typel необходима установка отдельной шрифтовой машины. Поэтому при работе в офисных приложениях лучше пользоваться шрифтами TrueType.


Шрифты Unicode

Стандартное 8-битное кодирование (ANSI) позволяет использовать одновременно 256 различных символов. На первый взгляд этого достаточно для хранения текстовых символов и знаков пунктуации. Однако шрифты могут содержать огромное число дополнительных символов — лигатуры, разные пробелы, символы с акцентами, символы других языков, специальные знаки и пр. Если использовать ANSI-таблицу, то для каждого языка приходится создавать отдельный шрифт, и вдобавок дополнительные шрифты для хранения специальных символов, например лигатур. Это неудобно, поскольку при наборе на нескольких языках придется переключаться между несколькими шрифтами. Иероглифические языки имеют не десятки, а тысячи разных знаков, значит они в любом случае "не поместятся" в стандартную таблицу.

Стандарт Unicode использует 16-битное кодирование. В такой таблице могут храниться коды 65356 символов. Этого более чем достаточно для воспроизведения символа любого языка. Unicode-шрифт, таким образом, может иметь в своем составе гораздо больше символов, чем обычный ANSI-шрифт. В настоящее время шрифты в этом формате производятся Microsoft, Adobe и другими производителями. InDesign работает со шрифтами в этом формате.


Шрифты Оре n Туре

Формат шрифтов ОрепТуре был разработан совместно Microsoft и Adobe. Они поддерживают оба стандартных формата (Type 1 и TrueType), объединяя их. Это шрифты в кодировке Unicode, они содержат расширенные комплекты символов, являясь многоязыковыми. Шрифты ОрепТуре обладают большими возможностями в плане типографики. InDesign имеет средства работы с новым форматом. Сами ОрепТуре-шрифты поддерживаются операционной системой-Windows 2000.


Шрифты Multiple Master

В не очень далекие времена, когда набор и верстка проводились без компьютеров, шрифт представлял собой металлические бруски с нанесенными на них зеркальными изображениями символов. Эти пластинки назывались литерами. В состав литеры входил сам контур буквы, ее боковые поля (полуапроши) и оплечики. Литеры шрифта собирались в слова, строки и страницы набора — сначала вручную, потом автоматически. Разумеется, при таком методе работы возможности подгонки шрифтов были минимальными. Разные кегли, начертания, регулировка полей при кернинге и трекинге — каждая такая операция требовала использования других литер. Процесс набора был очень трудоемким и негибким.

С появлением компьютерных технологий подготовки публикаций возникли контурные компьютерные шрифты. Их использование многократно увеличило гибкость набора. Теперь нет проблем с плавным регулированием любых метрических параметров шрифта. Оба распространенных формата, TrueType и Type 1 позволяют как угодно варьировать кегль, поля, интерлиньяж и пр. Однако в этих шрифтах (для Туре 1 они называются Single Master) гарнитура имеет несколько стабильных начертаний (обычно это Bold, Italic, иногда Extended, Light и т. д.). Можно выбирать между предопределенными начертаниями, но их невозможно менять плавно. InDesign, как и другие программы верстки и графические редакторы, предлагает в качестве альтернативы расширение, сужение и наклон символов. Однако эти операции применимы в очень ограниченных пределах, поскольку вызывают искажение рисунка символов.

Новые шрифты Type 1 стандарта Multiple Master (MM) могут плавно изменять различные атрибуты, сохраняя сбалансированный рисунок символов. В каждом из шрифтов этого типа существует особый переменный параметр, например, толщина штрихов, или ширина символов. Этот переменный параметр называют осью шрифта. Программы, поддерживающие ММ-технологию, позволяют менять шрифт по данной оси в большом интервале значений. Для любого значения осей формируется сбалансированный символ. Так, на рис. 6.17 в верхней строке шрифт Tekton MM сжат по горизонтали заданием значения ширины символов в палитре Character, а на том же рисунке в нижней строке — настройкой ширины с использованием технологии ММ. В первом случае ширина горизонтальных и вертикальных линий в символах искажена, во втором — нет.

Рис. 6.17. Масштабирование SM и ММ-шрифта (внизу)

Для редактирования параметров ММ-шрифтов используется шрифтовая машина Type 1 — Adobe Type Manager Deluxe (рис. 6.18). После подгонки параметров вы добавляете новый шрифт с измененными значениями осей в общий список.

InDesign не способен самостоятельно редактировать ММ-шрифты. Для этой цели нужно использовать АТМ. Однако созданные начертания можно свободно применять в программе.

Если вы разработали начертание шрифта ММ в программе Adobe Illustrator (скажем для заголовка), то при импорте отформатированного этим шрифтом текста в InDesign текст будет помещен как графический объект (см. главу, посвященную импорту текста), но при этом созданное начертание не сохранится. Для того чтобы все-таки добиться нужного вида текста, переведите его в редактируемые контуры средствами Illustrator или создайте начертание ММ-шрифта в АТМ.

Однако InDesign все же умеет управлять некоторыми характеристиками ММ-шрифтов. Он автоматически организует соответствие шрифтов по оси оптических размеров.

Рис. 6.18. Трансформации шрифта в Adobe Type Manager

Ось оптических размеров характерна для наборных шрифтов. Это зависимость между оптическими параметрами шрифта и его кеглем. Программа шрифта плавно изменяет внешний вид символа, так чтобы он выглядел идеально именно для данного кегля. Так, при уменьшении кегля до наборного шрифта (скажем, 10 пунктов) для достижения лучшей читаемости обычно увеличивают толщину засечек и высоту строчных букв, сами буквы делаются более широкими и менее контрастными, увеличивается ширина боковых полей. Использование этой возможности приводит к отличному качеству набора.

InDesign позволяет применять ось оптических размеров к документу. В режиме Automatically Use Correct Font Size (он устанавливается одноименным флажком вкладки Туре окна Preferences) программа автоматически подбирает наилучшие оптические характеристики для каждого кегля, использованного в наборе. Разумеется, что подбор может быть проведен только для ММ-шрифта, в котором есть ось оптических размеров.


Качество шрифта

Какой бы шрифт вы ни использовали в работе — он должен быть фирменным. Во-первых, зарегистрированные шрифты имеют уникальное имя и идентификационный код, не позволяющий спутать их с "однофамильцами". Во-вторых, пиратские шрифты слишком часто содержат ошибки, приводящие к непредсказуемым последствиям. Наконец, они часто имеют неправильное расположение и безобразные контуры отдельных букв.

Если вы не знаете качества шрифта — устройте ему проверку. Перед началом работы отформатируйте этим шрифтом текст, состоящий из всех букв — строчных и прописных, цифр и символов (скобки, кавычки, знаки препинания и др.). Все ли символы присутствуют и соответствуют тому, что вы набирали? Равномерно ли размещены символы? У всех ли букв есть прописной и строчный вариант? Нет ли букв, форма которых режет глаз? Отформатируйте тем же шрифтом небольшую заметку. Равномерно ли смотрится текст? Распечатайте тестовую страницу (желательно на PostScript-принтере). Ничего не пропало, не искажено? Если вы выяснили, что шрифт плохой, обязательно замените его похожим. Не работайте с некачественным шрифтом, это грозит потерей вашей верстки.

Шрифтовой логотип

Если логотип или повторяющаяся виньетка выполнены некорректным шрифтом, разумно перевести его в кривые и в таком виде сохранить на диске.

Поскольку шрифт является отдельной программой, открытие файлов иллюстраций на другом компьютере осложняется — ведь шрифт, использованный в документе, совсем не обязательно установлен на компьютере, где этот файл открывается. Значит, для корректного открытия файла нужно прикладывать к нему все файлы шрифтов.


О похожих шрифтах

Ситуация на рынке шрифтов сложилась так, что практически идентичные шрифты выпускаются под разными именами. Иногда имена очень похожи (например, Times и Times DL), иногда различаются (Helvetica и Arial). Когда вы готовите документ для работы на чужом компьютере (самая частая задача — вывод форм на фотонаборном автомате), никогда не полагайтесь на то, что на удаленном компьютере будут нужные шрифты. Сплошь и рядом случается следующая неприятная ситуация: точно таких же шрифтов нет, но есть очень похожие. Партнер производит замену, а потом оказывается, что оригинальный шрифт имел чуть-чуть другие параметры, например ширину пробела. Это было незаметно при анализе символов, а в сверстанном документе расположение текста кардинально изменилось. Всегда прилагайте шрифты к документу, предназначенному для удаленной печати! Для сбора всех частей документа, необходимых для удаленной печати, в InDesign cy- ществует специальная команда Package меню File. Она будет рассмотрена в главе 19, посвященной печати документов.


Общие сведения о форматировании

Обсуждение текста в этой книге

InDesign располагает развитыми средствами работы с текстом. Прежде чем перейти к рассмотрению конкретных функций, бегло осмотрим аппарат, предлагаемый программой.

  • Доступ к функциям форматирования текста (как символов, так и абзацев и текстовых стилей) производится из меню Type. Здесь находятся команды вывода на экран палитр управления атрибутами текста и раскрывающиеся списки шрифтов и кеглей. Ниже расположены специальные команды: Create Outlines, которая переводит выделенный текст в редактируемые контуры, команда-переключатель Show Hidden Characters. Последняя в активном состоянии делает видимыми скрытые символы текста — пробелы, концы абзацев, переходы на новую строку, табуляции.
  • В меню Edit расположены средства автоматизации работы с текстом. Это команды поиска, поиска и замены, редактирования словаря и проверки орфографии.
  • Текстовый фрейм с содержащимся в нем текстом представляет собой объект. Его можно трансформировать, как обычный графический объект, задавать для текста и самого фрейма различные заливки и обводки. Для этого используются те же команды и средства, что и для графических объектов.
  • Для размещения текстовых и графических фреймов программа предлагает широкий набор вспомогательных средств — построение направляющих и модульных сеток, координатную сетку, команды специального вклеивания, шаблоны, слои и пр.

При работе над публикацией один из основных вопросов — выбор шрифте вого оформления. В зависимости от назначения и характера публикации, оно может сильно различаться. Например, вы хотите, чтобы текст был набран гарнитурой Bookman, имел кегль 10, был размещен на страницах с интерлиньяжем 12,5. Заголовки статей вы решили набрать шрифтом Avantgarde, кегль14, причем хотите, чтобы первые буквы каждого заголовка имели инверсное написание (белым по черному). Все эти характеристики относятся к атрибутам символа. Они могут быть заданы для каждого знака текста отдельно. Работу с атрибутами символов мы рассмотрим в этой главе.

Следующая глава посвящена заданию атрибутов абзаца — параметров, определяемых для всего абзаца как целого. Именно параметры абзаца во многом определяют качество верстки и внешний вид текста. Это абзацные отступы и отбивки, подгонка интервалов, параметры переноса.

В главе 8 рассмотрены глобальные атрибуты, задаваемые для всего текста целиком. Это прежде всего текстовые стили. Операции с текстом как с объектом упоминаются в главе 11, посвященной операциям с графическими объектами. Редактированию и импорту текстовых файлов посвящена глава 9. Наконец, размещение текстовых фреймов на странице, их взаимодействие, колонки, модули и прочие аспекты сложной верстки будут обсуждаться в главе 16.


Текстовый режим

Когда вы выбираете инструмент Type, вы готовы начать работать с текстом. Как вы уже знаете, текст в программе может располагаться только в текстовом фрейме. После создания нового текстового фрейма или щелчка на существующем программа переходит в текстовый режим работы. В активном фрейме появляется текстовый курсор в форме мерцающей вертикальной черты. Текстовый курсор (I-курсор) перемещается клавишами управления курсором; он отмечает точку вставки (точку ввода). Именно в том месте, где располагается текстовый курсор, и появятся символы, если их ввести с клавиатуры или вклеить (вставить из буфера). В программе текстовый курсор всегда находится в режиме вставки.

Вы можете перемещаться по тексту, т. е. смещать точку вставки. Приемы работы такие же, как в простейшем текстовом редакторе. Точка вставки может быть перенесена с помощью клавиш текстового курсора или щелчком мышью на требуемом месте. В табл. 6.3 приводятся клавиатурные сокращения для перемещения курсора в фигурном тексте.

Таблица 6.3. Управление перемещением курсора

Клавиши | Перемещение курсора
<Ctr]>+<вправо>\<влево> | На одно слово влево /вправо
<Ctrl>+<Home> или <Ctrl>+<вверх> |  | В начало текста
<Ctrl>+<End> или <Ctrl>+<вниз> |  | В конец текста
<Ctrl>+<вверх> |  | В начало предыдущего абзаца
<Ctrl>+<вниз> |  | В начало последующего абзаца
<вверх>\<вниз> |  | На строку выше/ниже


Выделение в текстовом режиме

Выделение символов в текстовом режиме производится по правилам, принятым для большинства текстовых процессоров. Выделить нужный фрагмент можно несколькими способами:

  1. Щелкните мышью в том месте текста, откуда нужно начать выделение (курсор должен быть текстовым). Затем, не отпуская кнопку мыши, протащите 1-курсор до окончания интересующего вас фрагмента. Таким образом можно выделять и отдельные символы, и большие объемы текста.
  2. Выберите начало выделения, нажмите клавишу <Shift> и, удерживая ее, щелкните мышью в месте окончания выделения. Весь текст между этими двумя точками окажется выбранным.
  3. Используйте клавиши управления курсором при нажатой клавише <Shift>. Перемещая курсор клавишами со стрелками, можно выбрать текст сверху, снизу, слева или справа от точки вставки. Клавиатурные эквиваленты для выделения текста приведены в табл. 6.4.

Таблица 6.4. Клавиатурные эквиваленты для выделения текста

Клавиши | Выделение
<Ctrl>+<A> | Весь текст
<Shift>+<вправо>\<влево> | Один символ слева \справа от курсора
<Shift>+<вниз> | Символы от точки вставки до конца строки и часть следующей строки до уровня исходной точки вставки
<Shift>+<вверх> | От точки вставки до начала строки и часть предыдущей строки до уровня точки вставки
<Shift>+<Home> | От точки вставки до начала строки
<Shifl>+<End> | От точки вставки до конца строки
<Shift>+<Ctгl>+<влево> | Одно слово слева от курсора
<Shift>+<Ctгt>+<вправо> | Одно слово справа от курсора
<Shifl>+<Ctrl>+<вверх>\<вниз> | Один абзац сверху /снизу от курсора
<Shiti>+<Ctrl>+<Home> | От точки вставки до начала текста
<Shift>+<Ctrl>+<End> | От точки вставки до конца текста

Рис. 6.19. Выделенные символы в текстовом режиме

Пример выделенных символов в текстовом режиме приведен на рис. 6.19.

Выделенные символы можно удалить, скопировать, вырезать, а также менять их атрибуты.

Удаляются символы клавишами <Backspace> (нажатие на нее удаляет символ слева от курсора) и <Del> (удаляет символ справа точки ввода). Нажатие клавиш удаления при наличии выделенных символов в тексте удаляет эти символы. Для копирования символов используется команда Copy меню Edit или сочетание клавиш <Ctrl>+<0.


Атрибуты текста и наличие выделения

В зависимости от наличия выделенных объектов при задании атрибутов текста возможно следующее:

  • Параметры текста определяются при отсутствии выделенных объектов и точки вставки (инструмент Type вообще может не быть активным). Заданные значения атрибутов станут значениями по умолчанию для данного документа. Весь вновь набираемый текст будет иметь эти параметры до тех пор, пока вы снова не измените их. Пользуясь этим режимом форматирования, заранее задайте атрибуты форматирования (гарнитура, кегль, начертание и другие характеристики) по умолчанию именно такими, какими вы хотите их видеть в готовом документе.
  • Если в документе есть точка вставки, но нет выделенных символов, то изменение атрибутов затронет только вновь вводимые символы в точке вставки, т. е. вновь вводимый текст будет иметь другие атрибуты форматирования, чем уже существующий. При смене точки вставки атрибуты вновь вводимых .символов будут такими же, как у символов слева от новой точки ввода. Такой режим удобен, например, если нужно ввести заголовок в уже существующий текст.
  • Если в активном текстовом блоке есть выделение, то атрибуты меняются только для выделенных символов. Обратите внимание! Для изменения атрибутов существующего текста выделение должно быть выполнено в текстовом режиме.


Форматирование символов в программе

Основным средством форматирования символов в InDesign является палитра Character. Она выводится на экран командой Character меню Type (клавиатурное сокращение <Ctrl>+<T>). Если палитра уже присутствует на экране, эта команда активизирует ее. Палитра позволяет задавать все возможные атрибуты символов (рис. 6.20). Как бы ни был отформатирован тот или иной символ, сам текст, при этом остается свободно редактируемым. Если в документе есть выделенные объекты, доступ к палитре осуществляется, только если установлена точка вставки или выделены символы текста. Если выделения нет, палитра доступна для задания атрибутов по умолчанию.

Рис. 6.20. Палитра Character

Как видно из рисунка, палитра располагает собственным меню. Выбрав команду-переключатель Show Options, вы увеличите количество доступных для редактирования атрибутов. Если палитра полностью раскрыта, эта команда меняет вид на Hide Options, и при ее выборе часть полей становится не вид на. Последняя команда меню — также переключатель, он изменяет ориентацию палитры.

Некоторые поля ввода палитры снабжены всплывающими подсказками. Мы будем называть эти поля в тексте именно так, как они названы в подсказках.


Гарнитура

Чтобы задать атрибуты в палитре Character, нужно активизировать ее. Для этого щелкните на ее названии или нажмите комбинацию клавиш <Ctrl>+ <Т>. Для перехода от одного элемента списка к другому нажимайте клавишу <Таb>.

Активизируйте первый элемент палитры — в этом раскрывающемся списке выбирается гарнитура (Font Family). В поле списка показано название гарнитуры, активной в данный момент. Чтобы выбрать из списка нужную гарнитуру, нажмите треугольную стрелку справа от поля. Список раскроется, и вы сможете выбрать нужное значение щелчком мыши. Если на вашем компьютере установлено много шрифтов, то список будет очень длинным. В этом случае он имеет ползунок прокрутки для просмотра всех установленных гарнитур. Затем щелкните на списке шрифтов.

Если вы пользуетесь клавиатурой, то активизируйте список шрифтов клавишей <ТаЬ>, а затем начните набирать имя нужной гарнитуры- По мере набора, InDesign подставляет подходящее значение в окошко списка. Введя одну-две буквы имени шрифта, вы увидите, что InDesign уже подставил в окошко списка гарнитур нужное значение. Для того чтобы ваша установка начала действовать, активизируйте другое поле палитры или нажмите клавишу <Enter>.


Начертание

Рядом расположен список начертаний, доступных для данной гарнитуры (Font Style). Значения из списка можно выбирать аналогично выбору гарнитуры. Для каждой из гарнитур список начертаний включает те, которые вы установили на ваш компьютер. Например, если вы установили для гарнитуры Bodoni начертания Bold, Semibold, Italic, Regular, то именно эти пункты будут в списке Font Style. Если же для шрифта Courier установлено только одно начертание, обычное, то список начертаний для него будет включать лишь один пункт, Regular.

Если гарнитура содержит необычные начертания, например Narrow (Узкий), Outline (Контурный) и пр., каждое из них располагается в списке гарнитур отдельной строкой.

При изменении гарнитуры выделенного фрагмента программа старается сохранить начертание. Отделение гарнитуры от начертания очень удобно для верстальщика. Вот один пример: допустим, основной текст набран гарнитурой Times, некоторые символы в нем, имеют курсивное начертание, а заголовки отформатированы полужирным шрифтом Arial. Если вы выделите весь массив указанного текста и измените его гарнитуру на Pragmatica, то изменение гарнитуры коснется всех выделенных символов. При этом заголовки останутся полужирными, а выделения в тексте — курсивными.

Если в заменяющем шрифте отсутствуют начертания, встречающиеся в выделенном тексте, то данные символы получают обычное начертание и помечаются розовым цветом, как отформатированные отсутствующим шрифтом. В палитре Character для этих символов в поле Font Style название отсутствующего начертания дается в квадратных скобках.


Кегль

В поле Font Size задается кегль символов. Он определяется произвольно в точке вставки, для выделенных символов или по умолчанию (если нет точки вставки и текстового выделения). Кегль задается в пунктах. Если требуется ввести значение, вьфаженное в других единицах, то после набора числа введите сокращенное обозначение единицы измерения. Например, если вам требуется ввести значение отбивки 0,5 дюйма, введите в поле Font Size число 0,5 и без пробела букву "i". Введенное значение будет автоматически пересчитано в миллиметры сразу после нажатия клавиши табуляции. В табл. 6.5 указаны сокращенные обозначения для единиц измерения, используемых в In Design.

Таблица 6.5. Сокращенные обозначения единиц измерения InDesign

Чтобы временно задать... |  | Введите...
Дюймы |  | i после числового значения (5.25i означает 51/4 дюйма)
Миллиметры | m после числового значения (25m означает 25 мм)
Пики | р после числового значения (18р означает 18 пик)
Пункты | р перед числовым значением (р6 означает 6 пунктов)
Пики и пункты | р между числовыми значениями (18р6 означает 18 пик и 6 пунктов)
Цицеро | с после числового значения (5с означает 5 цицеро)

Кроме возможности ввода других единиц измерения, в поля ввода программы можно вводить и математические выражения. Например, ввод выражения "5р-р2" расценивается программой как "пять пик минус два пункта". После нажатия клавиши <Таb> немедленно будет предъявлен результат — 10 pt (10 пунктов).

Справа от поля ввода расположены треугольные стрелки, с помощью которых вы можете быстро уменьшать и увеличивать кегль. Описанные приемы работы действительны для любого поля ввода программы.


Гарнитура, начертание и кегль в меню программы

Иногда удобно для определения характеристик шрифта пользоваться командами меню Type.

Команда Font раскрывает список установленных шрифтов. Скорее всего, их набор на вашем компьютере будет отличаться от приведенного на рис. 6.21. Если установлено много шрифтов, и этот список очень длинный, то в верхней части есть пункт More, перейдя к которому вы откроете следующую "страницу" шрифтов. Если гарнитура имеет несколько начертаний, они перечислены во вложенных списках. Справа от строки гарнитуры, имеющей несколько начертаний, есть треугольная стрелка. Когда вы подведете курсор к нужной строке, список начертаний откроется (рис. 6.21).

Рис. 6.21. Выбор гарнитуры и начертания в списке Fonts...

Кегль шрифта также можно установить командой Size меню Type. Эта команда открывает список наиболее часто используемых кеглей. Вы можете выбрать значение из списка, или, установив курсор на строку Other, перейти к палитре Character, в поле определения кегля.


Отсутствующие шрифты

Если на вашем компьютере не установлены какие-либо шрифты, использованные в документе, то при его открытии вы увидите информационное окно, в котором перечислены отсутствующие шрифты.

После нажатия кнопки ОК документ будет открыт. Отсутствующие шрифты программа заменяет на Adobe Sans MM (рубленые шрифты) и Adobe Serif

MM (шрифты с засечками и другие). По умолчанию символы, отформатированные отсутствующими шрифтами, подсвечены розовым цветом. Управление подсветкой производится флажком Substituted Fonts вкладки Composition окна установок. Если он установлен, отсутствующие шрифты подсвечены, если снят — подсветки нет.

Если в документе есть символы, отформатированные отсутствующим шрифтом, в верхней части списка Fonts появляется строка Missing.... Подведите к ней курсор, и перед вами откроется список отсутствующих на компьютере шрифтов, встречающихся в данном документе. Отсутствующие шрифты могут быть установлены с помощью АТМ, или заменены на доступные.


Подчеркивание, регистры, специальные символы

Команды меню палитры позволяют задавать дополнительные атрибуты для символов. Это команды-переключатели. Когда обозначенный ими режим активен, в строке команды устанавливается флажок.

  • All Caps. Режим "Прописные". При выборе этого режима все буквы форматируемого текста становятся прописными. На рис. 6.22 показан текст в режиме прописных.

Рис. 6.22. Режим прописных букв

Рис. 6.23. Применение капители

  • Small Caps. Режим "Капитель". Капитель — это особый способ набора текста, при котором прописные буквы не меняют вид, а все строчные печатаются прописными уменьшенного кегля. Набор капителью применяется для заголовков, колонтитулов, реже для текстовых выделений. На рис. 6.23 показано применение капители в публикации. Строчные буквы капители могут иметь различный размер. Для его задания выберите команду Text... списка Preferences меню File. Откроется вкладка диалогового окна установок, посвященная заданию умолчании текста. В поле Small Caps введите относительную величину строчных букв капители в процентах от кегля символов. По умолчанию это значение равно 70%. Влияние значения в поле Small Caps на внешний вид капители показано на рис. 6.24.

Рис. 6.24. Капитель с разным размером строчных букв

  • Superscript (Верхний индекс) и Subscript (Нижний индекс). Активизация этих режимов переводит символы в верхние или нижние индексы. Данные команды уменьшают кегль символа и перемещают его в соответствующее положение по вертикали, поднимая или опуская его базовую линию (рис. 6.25). Вертикальное расположение и размер индексов также регулируются на вкладке Text диалогового окна Preferences. В поле Size области Superscript задаются размеры (в процентах от кегля) символов верхнего индекса и его положение на строке (в процентах смещения базовой линии от исходной). В области Subscript те же значения определяются для нижнего индекса.

Рис. 6.25. Индексы, выполненные средствами InDesign

  • Underline (Подчеркивание) и Strikethrough (Зачеркивание). В этих режимах символы подчеркиваются линией в '/ю кегля толщиной и зачеркиваются линией постоянной толщины (1 пункт). Цвет линий совпадает с цветом символов. На рис. 6.26 показаны результаты применения этих режимов.

Рис. 6.26. Подчеркнутый и зачеркнутый текст

  • Ligatures (Лигатуры). Лигатуры — это участки текста, содержащие несколько символов, своеобразная сборная буква. Они создаются разработчиками шрифта для определенных сочетаний букв. Например, если в слове соседствуют буквы "f " и "i", для некоторых шрифтов верхняя часть "f " и точка над "i" перекрываются, что портит вид текста. Если же заменить это сочетание лигатурой, в которой рисунок символов слегка изменен, внешний вид текста улучшится. Лигатуры есть не для всех, а лишь для некоторых шрифтов. К ним относятся, например, шрифты производства Adobe и шрифты в кодировке Unicode. Шрифты с лигатурами применяются при наборе высококачественных изданий, стихов и т. д. Установка режима Ligatures заменяет некоторые комбинации символов на лигатуры (рис. 6.27).

Рис. 6.27. Лигатуры

  • Old Style (Старинный набор). Если шрифт выполнен в формате ОреnТуре, и в нем присутствуют специальные символы для имитации старинного набора чисел, то установка этого режима приводит числа к показанному на рис. 6.28 стилизованному виду.

Рис. 6.28. Набор Old Style


Кернинг

Новые разработки Adobe в области кернинга пар существенно повышают качество набора и упрощают процесс кернинга, особенно в больших объемах текста. Управление кернингом производится в раскрывающемся списке Kerning палитры Character. Этот атрибут задается только в точке вставки и применяется к существующим символам текста, между которыми находится курсор.

В рамках программы возможно проведение кернинга тремя способами:

  • Ручной кернинг. Регулировка расстояния между символами вручную. Это наиболее точный и самый трудоемкий способ. Кернинг вручную используется для достижения наилучшего вида заголовков и других текстов в крупном кегле. Для его проведения поместите курсор между теми символами, расстояние между которыми вы собираетесь изменить. Введите значение в поле Kerning или выберите одно из значений в раскрывающемся списке. Напомним, что кернинг изменяется в тысячных долях круглой шпации (ет). Нажимая кнопки с треугольными стрелками слева от списка, вы изменяете кернинг с шагом 0,0001 em. Для управления этой операцией есть клавиатурные сокращения. При нажатой клавише <Alt> каждое нажатие клавиш <влево> или <вправо>, соответственно, уменьшает или увеличивает кернинг на один шаг. Шаг кернинга определяется в поле Kerning вкладки Units & Increments диалогового окна установок программы. При одновременно нажатых клавишах <Ctrl> и <Alt> каждое нажатие клавиш < влево > или <вправо> изменяет кернинг на пять шагов.
  • Метрический кернинг — автоматический кернинг, параметры которого программа берет из самого шрифта. В программе шрифта содержатся инструкции, каким образом изменять расстояние между определенными парами символов, если они встречаются в тексте. По умолчанию для текста используется именно метрический кернинг. Для его установки выберите опцию Metrics в раскрывающемся списке. При перемещении текстового курсора в поле Kerning палитры отображается значение <0>, если курсор находится между символами, и Metrics, если он помещен в область пробела, в конце или начале строки. Качество метрического кернинга зависит от качества таблиц кернинга в шрифте. Если она неполная или отсутствует, этот вид кернинга дает некачественный результат.
  • Оптический кернинг. Новый вид кернинга, разработанный специально для InDesign. Это исключительно точный способ установки межсимвольного интервала. Для его задания выберите опцию Optical в списке Kerning. В активном режиме оптического кернинга программа анализирует форму каждой пары соседних букв и подбирает идеальное расстояние между ними. Поскольку оптический кернинг производится "на лету", а не хранится в программе шрифта или приложения, он великолепно выполняется для любого шрифта на любом языке. По качеству этот тип кернинга сравним с ручным, а зачастую ничуть не хуже. После применения оптического кернинга к тексту при помещении курсора между символами текста в поле Kerning демонстрируется величина кернинга, рассчитанная программой в точке вставки. Если курсор находится в области пробела или в концах строки, то в поле Kerning видно значение Optical.

Во всех трех случаях при кернинге пары символ слева всегда остается на месте, а символ справа перемещается в соответствии с заданным кернингом.


Трекинг

Трекинг, в отличие от кернинга, может быть проведен для любого количества символов. Регулируя трекинг, вы изменяете интервалы между всеми символами на равную величину. Трекинг измеряется в тысячных долях круглой шпации (0,001 em). Он задается для выделенных символов и по умолчанию. В точке вставки трекинг определяется для вновь вводимых символов.

Трекинг задается в поле Tracking и может быть как положительным, так и отрицательным. При положительных значениях межсимвольные пробелы растут, при отрицательных сужаются.

Клавиатурные сокращения для трекинга такие же, как для кернинга:

<Alt>+<вправо> увеличивает, <Alt>+<влево> уменьшает его на один шаг. При каждом нажатии <Alt>+<Ctrl>+<влево>, <Alt>+<Ctrl>+<вправо> значения кернинга соответственно уменьшаются/ увеличиваются на пять шагов.


Ширина, высота и наклон символов

Палитра Character содержит элементы управления шириной, высотой и наклоном символов текста. Несмотря на то что изменение рисунка литер относится к "запрещенным приемам" верстки, время от времени эта возможность вам весьма пригодится. Вполне допустимо изменить на 5—10% ширину или высоту крупного заголовка, чтобы достичь наилучшего размещения на листе. Если изменяемые символы набраны рубленым или рукописным шрифтом, то искажение просто не будет заметно. Соотношение ширины и высоты символа данного начертания может быть изменено вводом значений ширины в процентах в полях Vertical Scale и Horizontal Scale. Исходная ширина и высота принимаются за 100%.

Изменение высоты символа практически увеличивает его кегль. Однако программа считает кегль увеличенных букв исходным и не меняет метрические параметры, связанные с кеглем. Это очень удобно, если нужно использовать в наборе некоторые символы большего размера. Если вы не будете задавать для них увеличенный кегль, а увеличите высоту и ширину, вы сможете без проблем пользоваться автоматическим интерлиньяжем. Если же увеличение размера единичного символа строки произойдет за счет кегля, автоматический интерлиньяж массива текста будет выполнен некорректно (см. далее).

Вы также можете изменять наклон шрифта, вводя угол отклонения от вертикали в поле Skew (Наклон). Эта возможность используется чаще всего для имитации наклонного начертания, если оно отсутствует в комплекте шрифта.


Интерлиньяж

Существует несколько способов определения интерлиньяжа. InDesign считает интерлиньяжем расстояние между базовыми линиями соседних строк (см. рис. 6.11). Этот параметр, как вы уже знаете, задается отдельно для каждого символа. Если в строке присутствуют символы с различным интерлиньяжем, целостность базовой линии не нарушается. Интерлиньяж строки определяется равным наибольшему из значений для символов, входящих в эту строку. Интерлиньяж может быть определен как непосредственно вводом числового значения (точный), так и автоматически рассчитываться программой на основе кегля символов строки.

Числовое значение задается вводом в поле или выбором в раскрывающемся списке Leading палитры Character. Если для массива текста задан точный интерлиньяж, то его значение остается неизменным при изменении других атрибутов символов. Если в наборе присутствуют буквы, цифры или символы разного кегля или шрифта, для сохранения единого интерлиньяжа по всему тексту необходимо ввести точные значения.

Рис. 6.29. Автоматический интерлиньяж при разном кегле символов строки

Автоматический интерлиньяж рассчитывается программой как процент от кегля самого крупного символа в строке. По умолчанию он равен 120% кегля. Это означает, что при изменении кегля символов меняется и интерлиньяж. Этот метод имеет свои удобства: если вы внезапно решили изменить кегль набора, то можете быть уверены, что интерлиньяж будет автоматически приведен к оптимальному значению. Однако если в наборе присутствуют символы разного кегля, то применение автоматического интерлиньяжа приведет к разному интерлиньяжу для строк в тексте (рис. 6.29).

В отличие от точных значений интерлиньяжа, величина автоматического интерлиньяжа является атрибутом абзаца, т. е. определяется только для всего абзаца текста целиком. Он задается в диалоговом окне Justification, открываемом одноименной командой меню палитры Paragraph.

Еще одним способом изменения интерлиньяжа является привязка базовых линий текста к базовой сетке. Привязка к сетке осуществляется для всего абзаца. Этот прием будет рассмотрен в следующей главе.


Смещение базовой линии

В обычном случае базовые линии символов строки находятся на одном уровне. Однако положение базовой линии каждого символа можно свободно менять, вводя соответствующие значения в поле Baseline shift. По умолчанию смещение базовой линии равно 0. Оно измеряется в пунктах, однако вы можете вводить значения в любых единицах, они будут автоматически переведены в пункты. Положительное значение смещения соответствует подъему символа относительно остальных, отрицательное — опусканию.

Этот прием очень удобен, если нужно набрать дроби (рис. 6.30), а также регулировать положение вложенных в текст иллюстраций.

Рис. 6.30. Смещение базовой при наборе дробей


Установки языка

В раскрывающемся списке Language палитры Character задается язык для выделенных символов, в точке вставки или по умолчанию. В списке находятся только языки, установленные в процессе инсталляции InDesign. Выбор языка определяет словарь переносов и проверки орфографии. Установка языка для каждого символа облегчает набор текста на нескольких языках. Вы можете редактировать словарь, включая в него термины, встречающиеся в ваших текстах (например, при верстке специальных книг и журналов). О проверке орфографии, установке переносов и редактировании словарей см. главу 8.


Запрет разбиения слова и группы слов

Часто перед верстальщиком встает задача размещения текста именно данным образом, на заданном числе строк. Для ее решения пользуются кернингом, трекингом, установкой ширины символов. Этого же эффекта можно достичь с помощью функции предотвращения разбивки строк. К ней также прибегают, если в тексте встречается группа слов, разбивать которую нежелательно. Такой группой может быть короткое название (журнала, телепередачи, книги, фильма), обозначение года (1995 г.) и пр. Для того чтобы запретить разбивку группы слов на строки, нужно сначала ее выбрать. После этого воспользуйтесь командой-переключателем No Break для выделенного текста.

Другая задача, решаемая с помощью режима No Break — запрет переноса слова. Эта возможность очень полезна при форматировании аббревиатур, Web-адресов, и пр. Другой способ запрета переноса конкретного слова — введение знака мягкого переноса перед ним- Клавиатурное сокращение для мягкого переноса — <Ctrl>+<Shift>+</>.


Резюме

В настоящей главе рассмотрена работа с символами. Освещаются следующие вопросы:

  • Атрибуты текста подразделяются на атрибуты символов и абзаца. - К атрибутам символа относится гарнитура и начертание.
  • Шрифты характеризуются метрическими параметрами. Это кегль, кернинг, трекинг, интерлиньяж, положение базовой линии. Большинство параметров шрифтов задаются в программе обычным образом.
  • Наличие оптического кернинга позволяет значительно повысить качество верстки.
  • Шрифты представляют собой отдельные программы. Наиболее распространенные форматы шрифтов — Type 1 и TrueType.
  • Программа предназначена для размещения, а не для набора текста.
  • Текст можно получить импортом. Непосредственным набором в программе получают только небольшие объемы текста.
  • Работа с текстом производится в специальных палитрах, командами меню Type и Edit.
  • Текст может размещаться только в текстовом фрейме. Он может рассматриваться как графический объект с ограниченными возможностями редактирования.
  • В текстовом режиме перемещение по тексту и выделение символов производится стандартным образом, как в текстовом процессоре.
  • Управление атрибутами символа производится в палитре Character.


Глава 7

Форматирование абзацев

Настоящая глава посвящена определению атрибутов абзаца. Это свойства текста, которые задаются для всего абзаца целиком и остаются неизменными на всем его протяжении.


Параметры абзаца

Атрибуты абзаца, в отличие от атрибутов символов, могут несколько отличаться по способу задания и по сути в различных программах работы с текстом. Однако можно выделить несколько общепринятых атрибутов, а именно:

  • Тип выключки — по правому краю полная, по левому краю, по центру - Размер межсимвольных интервалов - Величина пробелов между словами
  • Параметры переноса абзаца на другую страницу — минимальное число остающихся и переносимых строк, запрет и разрешение на разбиение абзаца
  • Установки переносов: зона переноса, разрешенное число смежных переносов, минимальное число букв, остающихся на предыдущей строке и переходящих на следующую.
  • Величина автоинтерлиньяжа, расстояние между строками, определяемое программой автоматически
  • Отбивки, расстояния между абзацами - Линейки над и под абзацем
  • Отступы, сдвиг первой или всех строк абзаца влево или вправо от границы текстового фрейма
  • Позиции табуляции, задание положения табуляторов в данном абзаце
  • Выравнивание по базовым линиям страницы. Приведение базовых линий строк в координатной сетке с произвольным шагом


Признак конца абзаца и непечатаемые символы

Если вы хотя бы немного знакомы с набором текстов в любом редакторе, понятие абзаца для вас интуитивно ясно. Это последовательность символов, которая заканчивается особым служебным символом — признаком конца абзаца. Каждый раз, когда вы нажимаете клавишу <Enter>, в текст вставляется признак конца абзаца. Текущая строка на нем обрывается, и весь текст, лежащий справа от места ввода (Enter), перемещается на новую строку. Абзац является минимальной структурной единицей, к которой могут быть применены многие атрибуты форматирования, такие как"* выключка (выравнивание текста по горизонтали), красная строка, метод расчета интерлиньяжа, установка позиций табуляции, управление переносами, линейки, отбивки и многие другие. Элементы форматирования абзаца нельзя задать для одного символа или группы символов, не составляющих абзац, они задаются для всего абзаца в целом. В отличие от атрибутов форматирования абзаца, атрибуты форматирования символа (такие как начертание, кегль или кернинг) можно задать для любого числа литер. Такая система форматирования часто затрудняет работу, но, с другой стороны, облегчает верстку. Не нужно следить за аккуратным выбором всего форматируемого текста — достаточно поместить текстовый курсор внутрь абзаца и задать требуемые значения в управляющей палитре и диалоговых окнах.

В InDesign невозможно выделить или отредактировать этот символ. Однако увидеть его можно. Для этого выберите команду Show Hidden Characters меню Type. В текущем документе станут видны скрытые символы: признаки конца абзаца, признаки конца строки (переход на новую строку без начала нового абзаца), табуляторы и пробелы разных видов (рис. 7.1)

Рис. 7.1. Скрытые символы


Разрыв строки

Иногда бывает необходимо принудительно распределить текст по строкам в пределах одного абзаца. Проще всего это сделать с помощью признака разрыва строки (принудительный перенос строки). Он вводится в текст клавиатурным сокращением <Shift>+<Enter>. Признак разрыва строки не виден в главном окне публикации, но в окне редактора материалов он становится виден при включении режима отображения табуляции и признаков конца абзаца. Признак разрыва строки отображается в виде сломанной стрелки в режиме показа непечатаемых символов. Разрыв строки и конец абзаца похожи, но путать их не следует — первый просто прерывает строку, второй — начинает новый абзац, атрибуты которого могут отличаться от предыдущего.


Типы выключки

Выключкой строк называется характер размещения текста на странице. Скорее всего, вы уже знакомы с этим атрибутом форматирования по работе с текстовым редактором. InDesign, способен выполнять как вертикальную, так и горизонтальную выключку строк. Тип выключки определяет вид текста.

Рис. 7.2. Выключка строк

Как и во многих текстовых процессорах, в InDesign применяются следующие типы выключки по горизонтали (рис. 7.2):

  • Выключка по левому краю. Массив текста выравнивается по левой границе колонки с учетом отступов и отбивок. Первые символы каждой строки выравниваются по вертикали, последние символы в строке располагаются свободно, образуя рваный правый край.
  • Выключка по правому краю. Зеркальное отражение выключки по левому краю. Символы выравниваются.
  • Выключка по центру. Текст располагается в середине строки. Программа вычисляет общую ширину всех символов данной строки с учетом пробелов и межсимвольных интервалов, делит эту величину пополам, и совмещает найденную середину строки со средней линией текстового блока.
  • Выключка по формату. Крайние символы в правой и левой части строки располагаются по границам блока (с учетом отступов и отбивок), а текст строки равномерно распределяется между этими крайними точками. Последняя строка абзаца не растягивается.
  • Полная выключка. Все строки абзаца, включая последнюю, растягиваются по формату. При этом межсимвольные пробелы в отдельных строках могут возрасти до нескольких сантиметров. Полную выключку называют принудительной.

Из этих типов только первые два — по левому краю и по формату обеспечивают нормальную читаемость. Они и используются для набора массива текста.

Какой из типов выключки предпочесть, зависит от жанра и цели публикации. Выключка по левому краю придает тексту неформальный вид, разные просветы в конце строк создают ощущение рукописи. Такой тип форматирования принят в технической документации, журнальных статьях. Приверженцы форматирования по левому краю говорят о том, что рваный край строки создает естественные опорные точки, своеобразные "ступеньки" для глаза читающего, упрощая ориентацию. Их противники утверждают, что при таком расположении текста глаз каждый раз в конце строки сталкивается с неожиданностью (ведь каждая строка заканчивается в другом месте), что замедляет чтение.

Текст, выключенный по формату, смотрится однородным и более темным. Ровные края колонки придают такой публикации традиционный вид. Это наиболее распространенный способ верстки книг, газет и журналов. Сторонники этого способа выравнивания настаивают, что в тексте, выключенном по формату, где есть ровная граница колонки, схема движения глаза упрощается и скорость чтения повышается.

Все остальные типы выключки снижают удобочитаемость и в основном тексте применяются редко. Выключка по центру и полная используются для оформления заголовков, шмуцтитулов, плакатов, открыток. Выключкой по правому краю иногда набирают небольшие вспомогательные объемы текста, например пояснения на полях, предисловия. Этот тип выключки общепринят для набора эпиграфов и посвящений. Полная выключка используется в оформлении текста очень крупного кегля, набранного шрифтом без засечек. Она используется довольно часто, и иногда очень удачно. Эта же выключка применяется в создании логотипов, когда текст превращается в элемент графического дизайна.

Выключки по центру, по формату и по правому краю украшают массив текста, однако пользоваться ими следует умеренно. Избегайте набирать таким способом длинные абзацы и текст мелкого кегля. Что толку от оригинальной публикации, если ее трудно прочесть?


Интервалы

Размер символа пробела является таким же полноправным атрибутом гарнитуры, как и рисунок букв. Однако в современных программах для работы с текстом пользователь может изменить это значение. При верстке, в зависимости от целей, вы вправе задавать различные параметры пробела. Чем больше пробел, тем более светлым, просторным будет массив текста, и тем больше места на странице он займет (рис. 7.3). Обычно для наборного текста оптимальной является исходная, не измененная ширина пробела. В заголовках же и в других фрагментах, набранных крупным кеглем, пробел может потребовать регулировки.

Рис. 7.3. Пробелы в первом отрывке больше, чем во втором

При разработке шрифта кроме рисунка литеры и ширины пробела задается и межсимвольное расстояние. Оно определяется величиной оптического поля буквы. Оптическое поле состоит из ширины собственно символа и боковых полей, примыкающих к нему. Величина бокового поля входит в состав шрифта, а не проявляется при наборе как кернинг и трекинг. Межсимвольное расстояние складывается из боковых полей соседних букв. В программах верстки оно также может быть изменено. Этот параметр меняют обычно незначительно, в пределах 5—10%, однако его влияние на внешний вид и объем текста весьма велико (рис. 7.4). Многие специалисты советуют избегать самостоятельной регулировки межсимвольного расстояния, говоря, что это искажает оптическое поле литер и приводит к порче внешнего вида текста.

Определенные пользователем параметры интервалов точно соблюдаются лишь для текста с рваным краем. Для выключенного по формату текста ширина пробела колеблется в зависимости от плотности заполнения строки. В этом случае задается уже не один параметр пробела, а три — минимальный, желаемый и максимальный. Руководствуясь этими значениями, программа увеличивает или уменьшает расстояния между символами и пробелы между словами, чтобы уложить текст в отведенные рамки. Стараясь соблюсти желаемые значения, она при необходимости увеличивает или уменьшает интервалы, но не более, чем на заданные допустимые отклонения. Для соблюдения интервалов используются автоматические переносы слов и в редких случаях — также автоматически — производится подстройка ширины символов. Случается, однако, что выполнить корректировку межсимвольных интервалов с учетом заданных значений в данной строке невозможно. Так бывает, например, если в тексте много слов, которых нет в словаре переносов, или в случае выбора слишком крупного кегля для данной длины строки. В этом случае программа верстки выполняет выключку как может. В результате на строке может быть расположено слишком мало символов, расстояния между ними становятся гораздо больше, чем в остальном тексте. Такая строка называется жидкой. Если символов слишком много, то образуется плотная строка. В InDesign, как и в других современных пакетах обработки текста, такие строки выделяются подсветкой. При взгляде на страницу пользователь сразу видит, где требуется его вмешательство — в какой строке требуется вставить ручной перенос, изменить кернинг или трекинг и пр.

Рис. 7.4. Межсимвольные расстояния в первом фрагменте больше, чем во втором


Подстройка ширины символов

Абсолютное значение ширины символов задается отдельно для каждого символа текста. Однако при размещении выключенного по формату текста имеется принципиальная возможность задания интервала колебания ширины символов для абзаца. Задается желаемая, максимальная и минимальная ширина. Изменение значения желаемой ширины приводит к согласованной корректировке ширины в пределах абзаца. Далее при размещении программа руководствуется этим значением, при необходимости уменьшает или увеличивает ширину символов, но не более, чем на значения, заданные для минимальной и максимальной ширины.


Отступы

В подавляющем большинстве программ обработки текстов отдельно задаются расстояние от левого края колонки до начала строк текста (отступ слева), расстояние от правого края до конца строки (отступ справа) и расстояние от левого края до начала первой строки каждого абзаца (абзацный отступ) (рис. 7.5). Все три типа отступов являются атрибутами абзаца. Кроме того, существует понятие оптического отступа.

Рис. 7.5. Три типа отступов

Отступы слева и справа применяются для верстки заголовков, стихов, эпиграфов. Иногда верстка с отступом используется и в основном тексте, в этом случае на образовавшемся поле можно расположить иллюстрации, заголовки-форточки и прочие элементы оформления (рис. 7.6). Такая верстка уместна при оформлении учебников и журнальных статей.

Рис. 7.6. Вложенная графика в отступе. Текст набран с отбивками

а

б

Рис. 7.7. Структура текста подчеркнута отступами

С помощью абзацного отступа оформляются красные строки (рис. 7.7, а). Кроме того, хорошим средством выделения является висячий отступ (рис. 7.7, б), также создаваемый средствами абзацного отступа.

С помощью красных строк абзацы текста отделяются друг от друга. Глаз читателя использует красные строки как опорные точки и легче воспринимает такой текст. Величина красной строки в публикациях разных издательств и особенно разных лет издания сильно меняется, в более старых изданиях красная строка была больше, ее величина доходила до двух круглых шпаций. В настоящее время стандартная величина абзацного отступа (красной строки) равна круглой шпации.

Красная строка не нужна для первого абзаца

Избегайте применения красной строки в двух случаях — в многострочном заголовке и в первой строке после заголовка. И то, и другое некрасиво.

Висячий отступ — другой способ отделения абзацев. Его можно применить для создания эффектного макета или просто верстки с подчеркнутой структурой. Текст, смещенный за границу колонки, привлекает внимание, даже если его цвет и кегль остались неизменными. При этом он ненавязчив, не "лезет в глаза". Прием выделения с висячим отступом поэтому очень хорош в учебниках, технической документации. Если поместить в начало каждого абзаца его основную мысль, тезис, или подзаголовок, то такой страницей можно пользоваться как опорным конспектом — основные положения темы будут сразу бросаться в глаза. Висячий отступ также очень широко используется при оформлении нумерованных списков (совместно с табуляцией).

Особый тип отступов — оптический. Поскольку знаки и буквы текста имеют разную конфигурацию, то границы колонок реального текста выглядят неровными. "Вмятины" образуются в местах переносов, кавычек и других знаков препинания, а также символов "A", "W" и других — т. е. там, где символ занимает только небольшую часть строки по вертикали. Для устранения этого дефекта некоторые символы в тексте делают висячими, т. е. выдвигают за край колонки. InDesign способен отслеживать необходимость вывешивания знаков пунктуации и символов автоматически. В результате края колонки текста становятся гораздо более ровными. Оптический отступ не является атрибутом абзаца. Он задается для всего материала, поэтому мы рассмотрим этот вид отступа в главе 9, где обсуждаются понятия фреймов, материалов и другие, связанные с размещением текста и графики в программе.


Отбивки

Отбивки — это дополнительное к интерлиньяжу свободное пространство над и под абзацем. Отбивками выделяются заголовки, подписи под рисунками. Иногда выделение отбивками используется вместо красной строки, т. е. все строки абзаца начинаются без отступов, одинаково, но каждый из них отделен от других отбивкой с двух сторон. Система верстки с отбивками более молодая, чем верстка с красными строками. Она принята в большинстве стран при составлении технической литературы. Распространено мнение, что система верстки с использованием отбивок придает более элегантный вид документу, и текст его легче читается (см. рис. 7.6).


Выбор разделения абзацев

Разумеется, при верстке вам придется придерживаться какого-то одного способа разделения абзацев основного текста — либо красной строкой, либо отбивкой. Выбор разделителя в большой степени определяет вид полосы набора (рис. 7.8, ср. также рис. 7.6 и рис. 7.7). При выборе рекомендуем вам исходить из целей публикации. Публикация, сверстанная с использованием красных строк, смотрится более привычно для русскоязычного читателя, обычно, таким образом, верстают в настоящее время художественные книги. Это придает книге солидный, респектабельный вид, особенно, если не полениться и подобрать подходящий шрифт (очень хорошо в таком случае пользоваться гарнитурами, принятыми в советской полиграфии — Академической, Литературной, Тайме). Тогда покупатель или клиент (потенциальный читатель), открыв книгу, увидит картину, знакомую с детства, когда все книги были интересными. Может быть, это обстоятельство дополнительно привлечет его и он купит выбранный экземпляр.

Рис. 7.8. Верстка с отбивками и красными строками

В учебниках очень уместен способ верстки с отбивками. Даже если способ верстки непривычен для читателя, он быстро освоится, и будет вознагражден легкостью отыскивания нужного абзаца (ведь учебник — не роман, его иногда читают и не подряд). Иногда верстка с применением отбивок между всеми абзацами основного текста актуальна в дорогих изданиях (например, в альбомах по искусству). Непривычное расположение абзацев может вызвать ощущение претенциозности, шика — в данном случае это то, что надо. "Пижонство" тоже можно усилить выбором соответствующей гарнитуры


Линейки

К атоибутам абзаца относятся линии над и под ним. Они поименяются для

отделения заголовков и при верстке структурированного текста, например таблиц или тезисов. Варьируя ширину линии, ее цвет и цвет текста, расстояние от линии до первой или последней строки абзаца, добиваются различных эффектов (рис. 7.9).

Рис. 7.9. Линейки использованы в оформлении заголовков


Вертикальная выключка строк

Внешний вид публикаций очень чувствителен к вертикальной выключке. Одним из требований к публикации полиграфического качества является выравнивание строк в колонках и на страницах. На рис. 7.10 представлен текст двух смежных колонок, выровненный по базовым линиям строк. Базовые линии помечены тонкими серыми штрихами. Такое выравнивание в идеальном варианте текста осуществляется автоматически, поскольку все строки текста имеют одинаковую высоту. Таким образом, если выровнять верхние границы текстовых блоков — первые строки, то все остальные должны лечь на одном уровне.

Использование в публикации отбивок и линеек, разные кегли и интерлиньяж для заголовков, наличие иллюстраций — все это приводит к неодинаковому вертикальному расположению строк на соседних страницах или колонках (рис. 7.11).

Добиться вертикальной выключки в большинстве программ верстки весьма непросто. При выравнивании текста в соседних блоках или колонках необходимо, во-первых, выровнять их по верхнему краю. Затем можно применить простой, но действенный способ расчета вертикальных размеров текста: все вертикальные размеры должны быть кратны интерлиньяжу основного текста — размер заголовков (интерлиньяж плюс отбивки), размер иллюстраций (высота плюс отбивки). В этом случае выключка по вертикали будет автоматической, без применения специальных режимов.

Рис. 7.10. Строки соседних колонок выровнены

Рис. 7.11. Строки не выровнены

Прежде всего определитесь с кеглем и интерлиньяжем

Прежде чем задавать размеры отбивок и иллюстраций, отрегулируйте соотношение кегля и основного интерлиньяжа. Кегль обычно является заказной величиной. Интерлиньяж по правилам на 20% превышает кегль. Он является основой расчета. Если абзацы основного текста набраны с отбивками, то они в большинстве случаев составляют половину интерлиньяжа. Тогда смещение абзацев происходит регулярно, т. е. все нечетные абзацы выровнены, все четные смещены. При этом сохраняется четкость размещения текста в колонках.

Этот способ с успехом можно применить для любого текста. Именно так верстали книги без иллюстраций — большие и несложные по структуре публикации. На рис. 7.12 показаны варианты установки кратного интерлиньяжа и отбивок. Это пример для интерлиньяжа 12 пунктов (кегль 10). Обратите внимание на интерлиньяж заголовка (12) в примере (а) — он меньше кегля (16). При наличии двух и более строк в заголовке такой интерлиньяж непригоден. Альтернативой является задание интерлиньяжа 24 (пример (б)), но в этом случае расстояние между строками заголовка излишне велико. Можно также вводить отбивки до и после заголовка, но результирующая строка с отбивками тоже должна быть кратна интерлиньяжу (вариант (в)).

а

б

в

Рис. 7.12. Кратные отбивки и интерлиньяж — средство выравнивания по базовым

Автоматическим способом сохранения кратности размещения является выравнивание по сетке базовых линий. Это сетка горизонтальных линий, расположенных на полосе набора на произвольном расстоянии. Обычно шаг сетки задается равным интерлиньяжу основного текста. Каждому абзацу можно задать выравнивание по координатной сетке, и все базовые линии строк расположатся на линиях сетки (рис. 7.13). Если в публикации встречается увеличенный кегль, интерлиньяж или отбивка, то строка располагается на ближайшей линии сетки. Таким образом выравнивание достигается автоматически.

Рис. 7.13. Абзацы на странице выровнены по базовым линиям


Размещение абзацев на страницах

В готовой публикации существует множество правил размещения текста на странице, уследить за которыми подчас нелегко. Так, некоторые абзацы обязательно начинаются с новой страницы или колонки — например, названия частей книги. Недопустимо наличие висячих строк в конце и начале абзаца (рис. 7.14). Заголовки не могут быть оторваны от последующего текста. Некоторые абзацы (например, подрисуночные подписи, иногда сноски) должны располагаться на одной странице целиком.

Для абзаца в программах верстки предусматриваются соответствующие атрибуты положения на странице. Отрегулируйте значения атрибутов, и программа сама отследит и автоматически исправит недочеты размещения.

  • Неразрывный абзац. Абзац с таким атрибутом в любом случае будет располагаться целиком на одной странице.
  • Число строк абзаца, которые могут быть отделены от него при разрыве. Для предотвращения висячих строк это значение должно быть не меньше двух.
  • Совместное расположение с частью последующего абзаца. На той же странице, что и заголовок, по правилам должно разместиться не менее двух строк основного текста.

Рис. 7.14. Висячие строки

Выполнение этих требований чрезвычайно затрудняет верстку. Ведь принудительные переносы абзацев оказывают влияние на длину полосы, уменьшая число строк на ней. А неизменность длины полосы набора — это очень серьезное требование верстки. Для сохранения должного числа строк приходится "вгонять" лишние строки, уплотняя текст, или "выгонять" их, разреживая текст предыдущих абзацев. Эти операции по большей части приходится совершать вручную.


Параметры переносов слов

Корректные переносы слов в массиве текста очень важны. Неправильные переносы оскорбляют глаз, отсутствие переносов неоправданно увеличивает объем текста, делает его рыхлым и неравномерным. Параметры переноса — это атрибут абзаца.

Абзац может вовсе не подвергаться переносу, как например, многострочные заголовки. Если переносы разрешены, то современные программы осуществляют анализ текста и автоматически переносят слова, включенные в словарь переносов. Такие словари имеются для всех языков, поддерживаемых программой, Включение соответствующего словаря производится автоматически — ведь язык текста задается как атрибут символа. Словари переносов можно дополнять и видоизменять.

В разных программах предусмотрены различные дополнительные приемы управления переносами. Чем более гибким является управление переносом слов, тем выше качество текста.


Табуляции

Каждому пользователю текстового процессора знакомо понятие табулятора (символа табуляции). Этот непечатаемый символ вставляется в текст клавишей <ТаЬ>. В режиме показа непечатаемых символов его можно увидеть так же, как признак конца абзаца (см. рис. 7.1). Табулятор смещает весь текст за ним в положение позиции табуляции. По умолчанию позиции табуляции располагаются по всей ширине полосы набора, на равном расстоянии друг от друга. Это значит, что при каждом вводе символа табуляции следующие за ним символы будут смещаться на это расстояние. Позиции табуляции можно свободно менять. Они относятся к атрибутам абзаца и едины для всех его строк. Это обстоятельство позволяет верстать с использованием позиций табуляции небольшие таблицы, разделяя строки таблицы символом перехода на новую строку.


Задание атрибутов абзаца

Как и для символов, для абзаца возможно задание атрибутов по умолчанию. Для этого необходимо, чтобы активен был инструмент Type, и в тексте не было точки вставки. Если точка вставки установлена, то изменение атрибутов распространяется на весь абзац, в котором эта точка находится. Чтобы изменить параметры нескольких абзацев одновременно, их нужно выделить.

Основные настройки абзаца собраны в палитре Paragraph. Эта палитра имеет два режима — с уменьшенным и полным набором управляющих элементов (рис. 7.15). Для перехода между режимами используется команда-переключатель Show/Hide Options верхней части.

С помощью кнопок и полей ввода палитры задается большинство параметров абзаца. Остальные атрибуты определяются с помощью диалоговых окон, открываемых командами меню палитры Paragraph.

а [image] б

Рис. 7.15. Палитра Paragraph с уменьшенным и полным набором параметров и меню палитры


Выключка

Задание выключки производится кнопками в верхней части палитры. Ширина полосы в любом случае рассчитывается с учетом отступов. Наиболее распространенные типы выключки по умолчанию снабжены клавиатурными сокращениями.

  1. Выключка с рваным краем:
  • Align left (<Ctrl>+<Shift>+<L>) — выравнивание по левому краю;
  • Align center (<Ctrl>+<Shift>+<0) — выравнивание по центру;
  • Align right (<Ctrl>+<Shift>+<R>) — выравнивание по правому краю.
  1. Варианты выключки по формату:
    • Justify with last line aligned left (<Ctrl>+<Shift>+<J>) — выключка по формату с последней строкой, выровненной по левому краю;
    • Justify with last line aligned center — выключка по формату с последней строкой, выровненной по центру;
    • Justify with last line aligned right — выключка по формату с последней строкой, выровненной по правому краю;
    • Justify all lines (<Ctrl>+<Shift>+<F>) — полная выключка.

    При задании полной выключки действует особый тип пробела — Flush Space (пробел со смещением). Это нововведение InDesign позволяет выравнивать по формату последний символ абзаца.

    Пробел со смещением вводится клавиатурным сокращением (<Ctrl>+<Shift>+<Alt>+<J>) в конце абзаца, после точки. Затем вводится тот символ, который требуется выровнять, например виньетка, как на рис. 7.16. При задании полной выключки последняя строка абзаца остается выровненной по левому краю, а пробел увеличивается так, чтобы символ, следующий за ним, стал выровнен по правому краю.

    Рис. 7.16. Пробел со смещением


Отступы

В палитре Paragraph задаются отступы — слева, справа и абзацный.

Left indent. Отступ слева. Он принимает только положительные значения, задавая расстояние от левого края текстового фрейма до начала строки.

Right indent. Отступ справа. Принимает только положительные значения и определяет расстояние от правого края фрейма до конца строки (этот отступ действует на любой тип выравнивания, но особенно заметен при выключке по формату).

First line left indent. Абзацный отступ. Он определяет расстояние от начала всех строк абзаца до начала первой строки. Положительные значения — это красная строка, отрицательные — висячий отступ. Разница между отступом слева и абзацным отступом не должна быть меньше нуля: строка не может выходить за пределы текстового фрейма.

Обычный висячий отступ

Чаще всего для создания висячего отступа в поле отступа слева подбирают подходящее значение смещения, и то же значение со знаком "минус" задают для абзацного отступа. Тогда начало каждой строки будет совпадать с левой границей фрейма.


Отбивки

Расстояние над абзацем задается в поле Space Before. Отбивка между текущим абзацем и следующим определяется в поле ввода Space After. Обе отбивки, как и большинство других параметров палитры, измеряются в пиках. Они могут принимать только положительные значения и определяют увеличение расстояния по сравнению с интерлиньяжем. Обычно для основного текста кегля 10 отбивка превышает интерлиньяж на 2 пункта. Следовательно, в поле Space After задается величина Ор2. Если задать ненулевое значение и во втором поле, то между абзацами расстояние будет равно сумме отбивок. Заданная отбивка после абзаца исполняется всегда, перед абзацем — только если он не расположен вверху фрейма. В этом случае отбивка не учитывается, и данный абзац располагается по верхнему краю фрейма, как если бы отбивки не было.


Выравнивание по сетке базовых линий

Для каждого отдельного абзаца задается привязка к координатной сетке. Этот атрибут регулируется парой кнопок Do not align to baseline grid/ Align to baseline grid. По умолчанию активна первая кнопка и выравнивание не производится. Достаточно нажать вторую кнопку, и все базовые линии абзаца выровняются по сетке, шаг которой определен во вкладке Grids диалогового окна Preferences (рис. 7.17). Надо сказать, что этот атрибут имеет приоритет перед другими, определяющими вертикальное расположение строк. Интерлиньяж и отбивки при задании выравнивания становятся кратны размеру сетки. Единственный атрибут, который сохраняется при таком форматировании неизменным, — смещение базовой линии.

Рис. 7.17. Выравнивание по сетке абзаца с заданными отбивками и смещенными базовыми линиями


Буквица — особый атрибут абзаца

В современной полиграфии буквица не относится к часто используемым элементам форматирования. Однако на взгляд авторов это прежде всего связано со сложностью создания такого элемента средствами компьютерной верстки. Раньше же буквицы применялись очень часто. Ян Чихольд (автор классических книг по верстке) рекомендует использовать ее в начале каждой главы книги в обязательном порядке. Буквицы действительно придают тексту ярко выраженную структуру, и очень украшают его. Шрифт буквицы может совпадать со шрифтом основного текста, или заголовка, в некоторых случаях уместны буквицы, выполненные рукописным или декоративным шрифтом (рис. 7.18).

Рис. 7.18. Буквицы — это красиво

InDesign предлагает очень быстрый и гибкий способ создания буквиц. В палитре Paragraph в поле ввода Drop Cap Number of Lines задается количество строк абзаца для буквицы. Буквица будет иметь соответствующую высоту, а указанное количество строк будет смещено. Базовая линия буквицы совпадает с базовой линией нижней смещенной строки (рис. 7.19). Ее кегль пропорционально увеличивается.

Рис. 7.19. Базовая линия буквицы

В виде буквицы может быть выполнена не только первая буква, но и несколько начальных символов. Количество символов абзаца, превращаемых в буквицу, задается в поле ввода Drop Cap One or More Characters. На рис. 7.20 приведен пример буквицы, состоящей из четырех символов.

Рис. 7.20. Буквица из нескольких символов

Для того чтобы изменить количество символов или число строк буквицы, просто введите другие значения в описанные поля ввода. Отменить буквицу абзаца тоже просто — нужно определить в этих полях ввода нулевые значения.

Внешний вид самой буквицы легко изменить. Для этого выделите ее и задайте нужные параметры символа в палитре Character. Например, вам может понадобиться сместить базовую линию, буквицы вверх, чтобы она выглядела более симметричной. Изменить размер буквицы, не меняя число строк, ею смещенных, тоже вполне можно. Для этого задайте масштабирование символа в полях Vertical Scale и Horizontal Scale. Разумеется, произвольно выбирается шрифт и начертание.

Смещение строк относительно буквицы

Регулировка кернинга между буквицей следующей буквой приводит к одинаковому смещению всех затронутых буквицей строк. Это позволяет произвольно менять расстояние от буквицы до текста.


Интервалы и ширина символов

В диалоговом окне Justification, открываемом одноименной командой меню палитры Paragraph, задаются атрибуты, влияющие на плотность текста:

  • Word Spacing. Ширина пробелов. Она задается в процентах от стандартной ширины пробела для данного шрифта. Стандартное значение пробела принимается за 100%.
  • Letter Spacing. Расстояние между символами. Межсимвольный просвет, принятый в шрифте, принимается за 0. Изменение расстояния задается в процентах от величины стандартного пробела. Величина -5% означает, что все межсимвольные расстояния сокращаются на пять процентов от символа пробела по сравнению со стандартными межсимвольными расстояниями.
  • Glyph Scaling. Ширина символов. Этот атрибут задает ширину символов для всего абзаца одновременно. Это значение также измеряется в процентах. Исходная ширина, заданная в шрифте, принимается за 100%. При этом форматирование ширины отдельных символов в палитре Character имеет приоритет над форматированием ширины всего абзаца.

Для каждого из атрибутов задаются три параметра — Maximum, Desired и Minimum. Для текста с рваным краем (не выключенного по формату), значение имеет только параметр Desired. Он определяет желаемую величину интервалов и ширину символов. Эти значения неизменны для всего абзаца текста.

В тексте, выключенном по формату, работают все три параметра. Интервал и ширина символов колеблются от минимальной до максимальной, при этом программа старается придерживаться желаемых значений.

Если выдержать должные параметры интервалов невозможно, то образуется жидкая, реже — плотная строка. Установка флажка Show H&J Violations на вкладке Composition диалогового окна Preferences делает эти дефекты очевидными — жидкие и плотные строки подсвечиваются желтым. Причем, яркость подсветки прямо пропорциональна степени погрешности — строки с небольшими отступлениями от заданных значений InDesign подсвечивает светло-желтым, а те, значения интервалов в которых сильно отличаются от заданных, — ярко-желтым.

Кроме определения интервалов в этом диалоговом окне задается еще один очень важный для текста атрибут: величина автоматического интерлиньяжа. Сам по себе интерлиньяж является параметром символа. Он может быть задан в пунктах для каждого символа текста. Однако, если вы задаете для символов текста автоматический интерлиньяж, программа рассчитывает это значение как заданный вами процент от кегля символа. Этот процент (т. е. способ расчета автоматического интерлиньяжа) является атрибутом абзаца и задается в поле ввода Auto Leading. Например, если задать автоинтерлиньяж равным 200%, то для кегля 10 он будет составлять 20 пунктов, а для кегля 12 — 24 пункта. По умолчанию интерлиньяж равен 120% от кегля.


Размещение абзацев и контроль висячих строк

Диалоговое окно Keep Options предназначено для определения расположения абзацев на странице (рис. 7.21).

Keep with next Olines. В этом поле задается число строк следующего абзаца, которые следует располагать на одной странице с данным. Эта возможность полезна для форматирования заголовков. Если, например, задать для заголовка эту величину равной 2, то в верстке заголовок будет всегда располагаться так, чтобы за ним на странице поместилось еще 2 строки основного текста. Если при этом превышается размер фрейма, то заголовок вместе с текстом переносится в следующий фрейм. Это очень полезный режим — он предотвращает появление "одиноких" заголовков в конце полосы.

Установка флажка Keep Lines Together делает доступными переключатели разрыва текущего абзаца:

  • All Lines in Paragraph. Все строки данного абзаца располагаются на одной странице. Этот режим применяется для подрисуночных подписей, многострочных заголовков и сносок и в других случаях, когда разрыв абзаца нежелателен. Если абзац не помещается целиком на данной странице, он весь переносится на следующую.

Рис. 7.21. Диалоговое окно Keep Options

  • At Start/End of Paragraph. В данном положении задается минимальное число строк в начале и в конце абзаца, которые должны располагаться на одной странице. Эта функция служит для предотвращения образования висячих строк. Так называются строки, располагающиеся в отрыве от "своего" абзаца в начале и в конце полосы. Висячие строки являются браком верстки. По общепринятым нормам, число строк в отрыве от основного абзаца не должно быть меньше двух. Если ввести в поля Start и End значения 2, то программа будет отслеживать и исправлять расположение строк автоматически. Например, для абзаца установлено минимально допустимое число начальных строк 2, тогда при размещении текста, если этот абзац оказался в конце фрейма (колонки), InDesign пытается разместить в этом фрейме (колонке) хотя бы две строки этого абзаца. Если размер фрейма этого не позволяет, то весь абзац помещается в следующий фрейм.

Раскрывающийся список Start Paragraph устанавливает режим размещения данного абзаца по отношению к предыдущему. В случае выбора опции Anywhere, применяемой по умолчанию, абзац начинается сразу вслед за предыдущим. Значение In Next Column перемещает абзац на следующую колонку или фрейм. In Next Page — перемещает абзац на следующую страницу.

Автоматический контроль висячих строк меняет размер полосы набора

Разумеется, при автоматическом перемещении абзацев для ликвидации висячих строк InDesign оставляет на страницах свободное место, уменьшая полосу набора. Если объем текста велик, то непредсказуемое колебание размера полосы становится трудно решаемой проблемой — ведь одинаковая длина полос во всем документе, а тем более на развороте — одно из основных требований верстки.

В диалоговом окне установок на вкладке Composition предусмотрен флажок режима подсветки висячих строк, с которыми программа не смогла справиться. Такие проблемные строки становятся легко видны и могут быть отредактированы вручную. Нужно сказать, что мы не смогли добиться подобной ситуации. При задании любой комбинации атрибутов программа размешала строки с указанными изменениями.


Установка переносов

Регулирование режима переноса производится флажком Hyphenate палитры Paragraph. Если этот флажок снят, то слова, которые не помещаются на строке, целиком переносятся строкой ниже, без всяких переносов. В этом случае единственным возможным приемом является вставка дискреционного, "мягкого" переноса. Это специальный символ, имеющий вид дефиса и вставляемый клавиатурной комбинацией <Ctrl>+<Shift>+<-> (минус). Если слово выходит за границу текстового блока, и в нем есть дискреционный перенос, то оно будет перенесено в соответствующем месте. Если дискреционного переноса нет, слово целиком переходит на следующую строку. При редактировании текста или изменении атрибутов символов и абзаца, слово, в котором есть позиция мягкого переноса, смещается, и необходимость в его переносе может отпасть. В таком случае мягкий перенос перестает быть виден. Если слово опять переместится таким образом, что его необходимо будет переносить, оно вновь будет разорвано по указанной точке переноса. Переносы вручную производятся для небольших объемов текста и для текстов на языках, которые не входят в поставку программы.

Рис.7.22. Диалоговое окно Hyphenation

Если флажок Hyphenate установлен, программа анализирует абзац на предмет необходимости переноса. Для слова, которое не помещается целиком на строке, она определяет язык символов текста (язык относится к атрибутам символов и задается в палитре Character) и активизирует соответствующий языковой словарь. Если данное слово есть в словаре, и в нем указаны точки переноса, то InDesign разрывает слово по точке переноса, ставит в конце строки короткий дефис и переносит часть слова на следующую строку. При этом программа руководствуется значениями, задаваемыми в диалоговом окне Hyphenation (рис. 7.22). Оно открывается командой Hyphenation меню палитры Paragraph.

Флажок Hyphenate этого окна дублирует одноименный флажок палитры. Если автоматические переносы включены (флажок установлен), становятся . доступными поля ввода атрибутов.

Words Longer than 0 letters. В этом поле задается минимальное число букв в слове, начиная с которого слова переносятся. По правилам русского языка можно переносить слова начиная с четырех букв.

After First О letters и Before Last <> letters. Поля ввода минимального количества переносимых и остающихся символов. В тексте на русском языке разрешается оставлять на строке и переносить на следующую строку не менее двух символов.

Hyphen Limit <> hyphens. Допустимое количество переносов на соседних строках, "лестниц". Для качественных публикаций с обычной полосой набора лучше установить значение 1, максимум 2, поскольку переносы на соседних строках являются браком верстки. В то же время чем уже колонка и больше кегль, тем труднее избежать смежных переносов. Кроме того, чем больше переносов, тем меньше места занимает массив текста. Если для вас особенно важна компактность текста, или длина строки очень мала, значение в этом поле можно и увеличить, но устанавливать больше трех смежных переносов все-таки нежелательно.

Hyphenation Zone. Этот атрибут действует только на текст с равным краем и только при использовании однострочной компоновки Single Line Composer (см. раздел "Настройка текста в реальных публикациях" данной главы). Зона переноса — это вертикальная полоса, примыкающая к правой границе колонки. Если слово находится левее зоны переноса, оно не переносится. Если часть слова попадает в эту зону, то происходит перенос. Если слово целиком находится в зоне переноса, оно полностью переходит на следующую строку. В первом фрагменте рис. 7.23 установлена нулевая зона переноса, во втором она широкая. Как видите, во втором случае слова переносятся чаще.

Hyphenate Capitalized Words. Если этот флажок установлен, автоматический перенос применяется и к словам, напечатанным с большой буквы. При снятом флажке все подобные слова игнорируются при автоматической расстановке переносов.

Во время подбора параметров можно сразу отслеживать их влияние на текст, установив флажок Preview. Когда вы закончите редактирование атрибутов

переноса, щелчок на кнопке ОК закроет окно. Программа применит измен-ненные атрибуты к абзацу.

Рис. 7.23. Зона переноса

Разумеется, и при включенном автоматическом переносе разумно при необходимости вставлять дискреционные переносы от руки. Дискреционный перенос имеет приоритет перед автоматическим, поэтому его можно вставить в нужном месте слова, если автоматический перенос был сделан неудачно. InDesign разорвет слово по месту введенного пользователем дискреционного переноса.

Встречаются ситуации, в которых перенос конкретного слова нежелателен. Для запрета переноса воспользуйтесь параметром No Break меню палитры Character. Есть и другой путь — просто введите знак мягкого переноса перед проблемным словом.

Не используйте для переноса символ "минус"

Если разбить слово обычным дефисом (минусом), на первый взгляд результат будет таким же, как при использовании мягкого переноса. Однако при любом смещении текста позиции переноса сместятся. Дефисы при этом не исчезнут, а будут разбросаны по всему тексту, превратившись в раздражающие глаз опечатки.

Словари InDesign можно отредактировать, используя специальное диалоговое окно Edit Dictionary. О редактировании словарей читайте в главе 10.


Размещение текста

Но вот, наконец, пробелы, межсимвольные расстояния и ширина символов в пределах абзаца определены и установлены параметры переносов. Теперь текст автоматически размещается в отведенных ему рамках. Происходит это не как Бог на душу положит, а по строгому алгоритму. InDesign имеет два режима размещения текста, переключаемые командами меню Paragraph. Как вы помните, в атрибуты абзаца в числе прочих входят параметры максимальных, минимальных и желаемых пробелов, межсимвольных расстояний и ширины символов. При размещении текста программа использует эти значения для достижения максимально равномерного распределения символов. Кроме того, при размещении важную роль играют параметры переноса. При активном режиме Single Line Composer программа анализирует каждую строку абзаца. При этом каждый последующий шаг выполняется только в том случае, если предыдущий не привел к успешному размещению символов.

  1. В соответствии со значениями, заданными для символов в палитре Character, строка заполняется до тех пор, пока последнее слово не выйдет за границу текстового блока. Режим переносов при этом отключается. Параметры пробелов, ширины символов и межсимвольных расстояний устанавливаются желаемыми (значение из поля Desired).
  2. Пробелы уменьшаются с целью вогнать последнее слово в строку целиком. Значение пробела меняется от желаемого до минимального малыми шагами. Как только результат достигнут — последнее слово помещено в строке — уменьшение пробелов прекращается. Если же этого не происходит, они уменьшаются до заданного минимума. При неудаче пробелы увеличиваются также постепенно, от желаемого до максимального, для того чтобы выгнать последнее слово из строки.
  3. Восстанавливается режим переносов. Находятся точки переноса — одна справа, другая слева от правой границы фрейма или колонки.
  4. Пробелы уменьшаются до минимума, чтобы вогнать часть слова, оставшуюся на строке после переноса по точке за границей фрейма или колонки. Если это не удалось, пробелы увеличиваются для переноса проблемного слова по точке слева от границы фрейма (внутри полосы).
  5. Если предыдущий шаг оказался неэффективным, InDesign повторяет сжатие и растяжение частей слова, при этом выполняя корректировку межсимвольных интервалов в дополнение к пробелам.
  6. В последнюю очередь программа прибегает к корректировке ширины символов. Алгоритм композиции тот же самый.

Если не удался ни один из описанных шагов, проблемное слово помещается на следующую строку по точке переноса внутри границы фрейма или целиком, если точка переноса отсутствует, а оставшиеся слова располагаются с максимальными межсимвольными интервалами. При необходимости пробелы возрастают сверх заданного максимального значения. Таким образом получается жидкая строка. Нижний лимит нарушается только в одном случае — если в строке есть последовательность символов, отформатированная с запретом разбиения, а длина ее превышает ширину колонки. В этом неприятном случае образуется излишне плотная строка. Оба типа дефектных строк помечаются желтой подсветкой.

Нельзя не видеть недостатки метода коррекции каждой строки по отдельности — прежде всего он очень негибок. Ведь если при размещении все логические операции производятся с каждой строкой отдельно, то нет возможности слегка подвинуть символы на одной строке, чтобы правильно разместилась следующая. В InDesign предусмотрен и гораздо более развитый алгоритм размещения — Multiline Composer. Он работает также на основе регулирования интервалов и ширины малыми приращениями, но оперирует одновременно с несколькими строками текста. Чем больше число одновременно анализируемых строк, тем выше качество размещения, но и тем медленнее работает программа. Кроме того, в этом режиме программа отыскивает несколько альтернативных вариантов размещения и выбирает из них лучший. Количество исследуемых одновременно строк и максимальное число альтернативных способов размещения задается в полях Look Ahead и Consider Up To. Эти поля расположены на вкладке Composition диалогового окна Preferences. На рис. 7.24 показан результат размещения текста в первом и втором режимах. Как говорится, результат налицо.

Рис. 7.24. Режимы Single Line Composer и Multiline Composer

Единственным недостатком метода Multiline Composer можно считать его сложность — он очень сильно замедляет обработку публикации. Поэтому применять этот метод при простой верстке не рекомендуется. А вот если верстка сложная, особенно при наличии узкой полосы набора, он поистине незаменим.


Абзацные линейки

Следующий атрибут абзаца относится к остальным, как галстук к костюму — это украшение, но иногда без него просто не обойтись. Гибкий и простой инструмент задания линеек абзаца — диалоговое окно Paragraph Rules — вам наверняка понравится. Линейки — простои и эффектный прием отделения заголовка. Кроме того, они широко применяются для верстки таблиц.

Диалоговое окно (рис. 7.25) открывается одноименной командой меню палитры Paragraph. Оно состоит из двух вкладок, переключаемых в списке в верхней части — Rule Above, в которой задаются свойства верхней линейки, и Rule Below, вкладка свойств нижней линейки.

Рис. 7.25. Диалоговое окно Paragraph Rules

Для того чтобы сразу видеть результаты редактирования линеек, предусмотрен флажок предварительного просмотра Preview. В каждой из вкладок задаются следующие параметры:

  • Для включения линейки следует установить флажок Rule On. - Поле Weight определяет толщину линейки (по умолчанию — в пунктах).
  • Если установить флажок Overprint Stroke, то линейка печатается с наложением в случае цветного фона под текстом. Сам текст и его обводка, если она есть, всегда располагаются поверх линейки.
  • В списке Color устанавливается цвет линейки. В этом списке содержатся все определенные цвета документа и отдельным пунктом — цвет текста Text Color. Об организации цветов подробно рассказано в главе 4.
  • Список Width устанавливает принцип расчета длины линейки. В этом списке два пункта. Если активен пункт Column, то длина линейки рассчитывается исходя из ширины колонки (фрейма). Если же выбрать пункт Text, то InDesign считает длину линейки исходя из спины соответствующей (первой или последней) текстовой строки.
  • Left Indent и Right Indent. Поля ввода, в которых определяется смещение линейки влево (по сравнению с левым краем колонки или началом строки) и вправо (по сравнению с правым краем колонки или концом строки). В этих полях можно задавать как положительные, так и отрицательные значения. Положительные значения соответствуют смещению линейки к середине, т. е. ее укорочению, отрицательные — удлинению. При этом линейка может и выходить за пределы текстового фрейма (рис. 7.26).

Рис. 7.26. Линейка за пределами фрейма

  • Offset. В этом поле задается смещение линейки по вертикали. Этот параметр отсчитывается от базовой линии строки. Положительные значения соответствуют смещению вверх для верхней линейки и смещению вниз — для нижней (рис. 7.27).

Рис. 7.27. Отсчет смещения линейки

Заголовок на цветном фоне

С помощью линеек удобно оформлять заголовки на цветном фоне. Для этого задайте толщину нижней линейки, равную интерлиньяжу, выберите для нее подходящий цвет и задайте в поле Offset такое смещение, чтобы все выносные элементы попали в зону линейки.


Позиции табуляции

InDesign позволяет произвольно менять положение и тип позиций табуляции. Этот раздел стоит несколько особняком от других тем главы. Прежде всего потому, что задание и редактирование позиций табуляции используется в основном для верстки таблиц и в обычном тексте применяется довольно редко. Тем не менее, расположение и свойства позиций табуляции относятся к атрибутам абзаца, и поэтому обсуждаются именно в данной главе.

Для управления табуляцией предназначен совершенно отдельный инструмент — палитра Tabs (линейка табуляции). Она очень похожа по приемам работы на аналогичный инструмент текстовых процессоров, с той разницей, что может располагаться в любом месте экрана и имеет регулируемую длину.

Кроме позиций табуляции с ее помощью задаются отступы — слева, справа и абзацный.

В InDesign верстают лишь простые небольшие таблицы

Как и в большинстве программ, работающих с текстами, основным структурным элементом в программе является строка. Таким образом, в нем невозможно выделить столбец символов шириной меньше строки. Это неудобно для форматирования таблиц и баз данных, основным структурным элементом которых является ячейка. Сверстанную таким образом таблицу будет трудно обновлять. Поэтому верстку сложных таблиц лучше производить в специально предназначенных для этого редакторах электронных таблиц.


Организация палитры

Палитра Tabs (рис. 7.28) вызывается одноименной командой меню Type. При ее вызове программа совмещает нулевое значение линейки с левым краем колонки, если он есть на экране. Длина линейки соответствует ширине активной колонки на момент вызова палитры, а ее разметка регулируется автоматически с учетом масштаба отображения. Шаг разметки соответствует разметке верхней линейки.

Для изучения расстановки табуляций рекомендуем набрать табулированный текст. До тех пор пока вы не установили ни одной позиции табуляции, InDesign пользуется позициями по умолчанию. На линейке они не видны, и размещаются на расстоянии 1 пики друг от друга, с выравниванием по левому краю. Обратите внимание, что в режиме показа непечатаемых символов символ табуляции отображается в виде открывающих кавычек (см. рис. 7.1).

Умолчание табуляции можно изменить

Для изменения позиций табуляции по умолчанию для данного документа выберите инструмент Selection или Direct Selection (не Type), перейдите к палитре Tabs и расставьте позиции табуляции, которые станут умолчаниями для данной публикации. Эти значения будут действовать для всех вновь создаваемых абзацев текста. Если требуется задать позиции табуляции по умолчанию для всех публикаций, то те же действия необходимо выполнить, закрыв предварительно все публикации. Удаление позиций табуляции приводит к восстановлению исходных значений (через одну пику).

Рис. 7.28. Палитра Tabs

Для определения позиций табуляции в абзаце установите в нем курсор. Если при установленном курсоре щелкнуть на кнопке с изображением магнита в палитре Tabs, то палитра разместится вверху текущего фрейма и автоматически будет масштабирована по ширине фрейма или колонки. Кнопка выравнивания действует, только если на экране видна верхняя граница фрейма.


Выравнивание по табуляции

В левой части палитры Tabs расположены кнопки типа позиции — способа выравнивания табулированных символов относительно позиции табуляции. Для задания позиции нужно выбрать одну из них.

  • Left-Justified Tab. Выравнивание табулированных символов по левому краю.
  • Center-Justified Tab. Выравнивание по правому краю.
  • Right-Justified Tab. Выравнивание по центру. Все три режима показаны на рис. 7.29.

Рис. 7.29. Три типа выравнивания по табуляции

  • Aligned to Decimal (Or Other Special Character) Tab. Режим выравнивания, обычно применяемый для столбиков чисел. По умолчанию выравнивание производится по десятичной точке. Однако вместо точки можно использовать любой другой символ. Символ для выравнивания задается в поле Aligned to. На рис. 7.30 в этом качестве использована точка, знак доллара и наклонная черта

Рис. 7.30. Выравнивание по произвольному символу


Установка маркеров

Выбрав тип позиции, щелкните на линейке. На ней появится маркер, обозначающий положение и тип новой позиции табуляции. Его можно передвигать по линейке, отредактировать свойства позиции (для этого нужно выделить маркер). Чтобы удалить маркер, просто перетащите его за пределы линейки вверх или вниз. Чтобы удалить все установленные маркеры, выберите команду Clear All меню палитры. Программа вернется к позициям по умолчанию (через одну пику). Позиции табуляции по умолчанию слева от маркера не действуют.

Если необходима точность размещения позиций табуляции, то их положение вводится с клавиатуры в поле ввода X. Прежде чем вводить значение, следует выбрать тип позиции. Новая позиция табуляции появляется на линейке после перехода в другое поле ввода. Численно задать положение можно и для уже существующей позиции — для этого выберите ее маркер и введите нужное значение в поле ввода X.

InDesign позволяет проставить позиции табуляции с равным интервалом с высокой степенью точности. Для расстановки повторяющихся позиций табуляции выберите первый маркер, который будет использоваться в качестве точки отсчета. Введите точное значение и выберите команду Repeat tab меню палитры Tabs. Маркеры позиций табуляции будут расставлены вдоль всего фрейма набора, начиная от исходной позиции с заданным шагом.


Отточия

В некоторых документах типа перечня (оглавления, прайс-листы) между столбцами таблицы оставлен большой пробел. Для удобства чтения в них используются отточия (рис. 7.31).

Для задания отточия перейдите в диалоговое окно Tabs и выберите маркер позиции табуляции, к которой будет вести отточие. В поле Leader задайте вид отточия, набрав нужные символы с клавиатуры. Шрифт, кегль и другие атрибуты символа отточия сначала всегда совпадают с атрибутами текста, в котором оно набрано.

Рис. 7.31. Применение отточий

После появления отточия на странице перейдите к тексту и выделите отточие. Оно выделяется только целиком. Теперь отточие можно отформатировать как любой другой символ — задать для него произвольный шрифт, кегль, трекинг, если нужно — определить кернинг и смещение базовой линий и другие атрибуты.

Так например, первое отточие на рисунке имеет те же атрибуты, что и текст. Второе отточие отформатировано более мелким кеглем, его трекинг увеличен до 200%. Третья строка — пример графического отточия. Для него был задан символ с кодом <Alt>+Ol75. Затем в тексте для отточия был задан шрифт Windings, уменьшены кегль и трекинг, а базовая линия смещена так, чтобы символы отточия расположились на середине строки.

Узнать код символа просто

При работе в системе Windows выяснять соответствие символов в разных гарнитурах, и кодов символов, отсутствующих на клавиатуре, удобно с помощью утилиты Character Map, входящей в комплект Windows.


Установка отступов

Для установки отступов используются специальные маркеры на линейке табуляции (рис. 7.32). Для задания отступа выделите его и перетащите на нужную позицию (можно ввести значение этой позиции в поле X). Отступ слева состоит из двух частей. Верхняя часть соответствует положению абзацного отступа, нижняя — положению отступа слева. Для одновременного перемещения обоих отступов следует выделить нижнюю часть маркера. Можно смещать отдельно абзацный отступ. Для этого выделите верхнюю часть маркера.

Задание отступов на линейке отображается в палитре Paragraph и наоборот. Из этого факта следует вывод, что имеется возможность задавать один и тот же атрибут двумя разными способами — кому как удобнее.

а

б

Рис. 7.32. Установка отступов при помощи маркеров на линейке табуляции


Настройка текста в реальных публикациях

Каждый верстальщик мечтает о публикации, в которой текст сам ложится ровными красивыми строчками на заданные участки, образуя элегантные колонки именно той длины, какую он задумал. К сожалению, так не бывает. Текст нужно настраивать, это операция очень сложная и малопроизводительная. Кроме того, для каждого типа верстки (однополосная, многоколонная, верстка таблиц, стихов и пр.) характерны свои приемы.

Обычно верстальщик имеет заказ на определенную ширину набора, иногда шрифт. Кроме того, точно известно, сколько страниц должна занять публикация. К настройкам текста относится в первую очередь подбор кегля и интерлиньяжа. Две эти характеристики обычно соотносятся как 1 к 1,2. Затем выбирается пробный массив текста и по нему настраиваются атрибуты выключки. После этого текст импортируется в документ, для него устанавливаются атрибуты размещения абзацев на странице. В заключение производится контроль одинаковой длины полосы набора. В этом разделе вашему вниманию предложены субъективные заметки авторов о некоторых аспектах размещения текста.


Длина строки и как ее менять

В тексте с любым типом выключки очень важно равномерное заполнение строк — по возможности одинаковые пробелы, межсимвольные расстояния и длины строк. В реальной верстке так, разумеется, не бывает, поскольку длина слов различна. Тем не менее, в профессиональной верстке необходимо добиваться настолько равномерного текста, насколько это возможно.

Для текста с рваным краем одинаковая величина пробелов соблюдается автоматически. Приходится потрудиться лишь над равномерностью рваного края — чтобы он не был очень уж рваным. При выключке по формату равная длина строк создается автоматически. Однако при этом неизбежны большие колебания в величине пробелов и интервалов. Разнобой интервалов в выключенном тексте и большая разница в длинах строк текста с рваным краем приводят к неоднородности массива текста. В нем появляются некрасивые просветы и излишне темные участки. Такой текст трудно читать.

До начала оформления публикации совершенно необходимо подобрать параметры будущего текста так, чтобы достичь максимально равномерного распределения. Для этого и выполняются регулировка атрибутов символов и настройка параметров абзаца. В табл. 7.1 перечислены параметры текста и. их воздействие на заполнение строк. Параметры, действующие сильнее всего, расположены в верхней части таблицы.

Таблица 7.1. Параметры текста и их воздействие на заполнение строк

Функция | Область задания атрибута | Воздействие на длину строк
Регулировка ширины пробелов | Абзац | Меняет величину пробелов. Величина желаемого пробела учитывается при любой выключке строк, кроме полной, значения максимального и минимального пробелов действуют только для текста с выключкой по формату. Величина пробела оказывает влияние на плотность заполнения строк
Регулировка интервалов | Абзац | Действуют при любой выключке, максимального и минимального кернинга, трекинга и др.
Регулировка Ширины символов | Абзац | Увеличивает и уменьшает ширину символов в пределах абзаца, изменяя ее от максимальной до минимальной. Колебания ширины позволяют автоматически добиваться большей равномерности распределения символов
Трекинг | Символы | Задает значения межсимвольных интервалов для выделенных символов, в том числе и для символа пробела. За счет этого меняется плотность текста и распределение символов по строкам
Автоматический перенос | Абзац | Разбивает слова в пределах абзаца по точкам переноса с установленными параметрами. За счет этого текст становится более компактным, а заполнение более равно мерным. Для текста с рваным краем важна зона переноса
Ручной перенос | Символ | Произвольно вставляемая в слово точка переноса способствует равномерности за полнения, поскольку разбивает длинные и неизвестные программе слова
Регулировка ширины символов | Символы | Произвольно устанавливает ширину выделенных символов, за счет чего несколько меняется длина строки
Кернинг, оптический, метрический и ручной | Символы | Изменяет межсимвольные расстояния в парах символов. Слабо действует на распределение символов в строке

Изменяя атрибуты, не забывайте основного правила — в пределах разворота эти изменения не должны быть заметны. Если, например, вы увеличиваете интервалы одного из абзацев, не уменьшайте интервалы соседнего. Это приведет к видимой неравномерности текста. Редактирование трекинга лучше проводить в пределах всего абзаца, а не для отдельных слов. Во-первых, эффект от редактирования будет выше, а во-вторых, вы не столкнетесь с неравномерным распределением символов внутри одного абзаца.


Проблема висячих строк

Длина строки оказывает влияние и на размещение абзацев на страницах. Автоматический режим предотвращения висячих строк не выдерживает критики, поскольку приводит к разнобою длины полосы набора. Если, скажем, на данной странице образовалась начальная висячая строка, то InDesign поместит весь абзац, к которому она принадлежит, на текущую страницу. В результате на предыдущей полосе появится "дыра", текстовый блок не будет дотянут до конца полосы набора. Нижние края полосы набора должны находиться на одном уровне, если высота смежных полос набора отличается (да еще, как в нашем случае, на десятки миллиметров), то это еще хуже, чем наличие висячей строки. Впрочем, и то и другое — типографский брак.

Иногда автоматический контроль висячих строк полезен

Действительно полезным применением функции контроля висячих строк является верстка качественной технической документации, руководств к программам и другой специальной литературы. В подобных публикациях очень много иллюстраций, они разбиты на множество маленьких разделов, и в них правило об одинаковой длине полос набора соблюдается нестрого.

Поэтому чаще всего в реальной верстке контроль висячих строк средствами программы отключают и производят его вручную. Основные правила настройки висячих строк таковы:

  • Проводите ее после установки окончательного интерлиньяжа, кегля, пробелов и всех остальных атрибутов абзацев и символов — ведь если текст впоследствии сместится, работу придется делать заново.
  • Если последняя строка абзаца занимает по длине менее четверти строки, можно попытаться уплотнить текст с целью уменьшения объема и сокращения числа строк (вгон строки).
  • Если длина последней строки составляет более 3/4 длины колонки, попытайтесь разогнать текст (сделать его более свободным) и таким образом прибавить еще строку к данному абзацу выгонка строки).
  • Задействуйте не только переносимый абзац. Может быть, необходимую строчку можно прибавить или убавить, работая с абзацами, предшествующими проблемному, может быть, нужный абзац найдется даже за пару страниц от данного.


Пример настройки выключки

Начиная работу над новой публикацией, особенно если речь идет о крупном проекте, не пожалейте времени на эксперименты с выключкой. Удачные решения в отношении пробелов, ширины и межсимвольных интервалов положительно влияют на качество макета и удобство работы. В настоящем разделе приведен пример настройки интервалов.

Сначала примите решения относительно основных элементов форматирования, как то: ширина колонок, кегли набора, гарнитуры. Все эти параметры оказывают решающее влияние на размещение текста, и без их точного определения работа по настройке выключки не имеет смысла. Разумеется, все эти параметры могут измениться (хотя коренные изменения крайне нежелательны). В данном случае вы будете использовать сочетание основных атрибутов форматирования как некую отправную точку. Выберите пробный текстовый материал, на котором вы будете проводить эксперименты. Этот блок текста должен быть достаточно длинным (примерно 170—200 слов). Характер текста в пробном материале должен быть таким же, как и в настоящей публикации, особенно это касается длины слов. Если вы верстаете статью для бульварного журнала, слова в ней будут наверняка короче, чем в научной статье такой же длины. Когда материал выбран, импортируйте его в InDesign. Об импорте текстовых файлов рассказывается в главе 9.

Приведите текст в исходный вид, т. е. отключите все атрибуты, влияющие на длину строк, или задайте для них стандартные значения:

  1. Задайте стандартную ширину символов, оптический кернинг, отсутствие трекинга.
  2. Для межсимвольных интервалов, пробелов и ширины символов в диалоговом окне Justification задайте значения 100% во всех полях, отменив колебание атрибутов.
  3. Отключите режим переноса.

Затем задайте для полученного текста нужный тип выключки и сделайте там, где нужно, абзацные отступы. При таком форматировании текст выглядит чересчур свободным, жидким (рис. 7.33).

Рис. 7.33. Текст подготовлен к настройке интервалов

Настройте переносы и интервалы. Это самая важная часть работы. Чем свободнее InDesign сможет переносить слова, тем легче выдерживать желаемую величину интервалов. С другой стороны, если заданы излишне жесткие рамки для интервалов, не обойтись без формирования "лестниц". При настройке важно сбалансировать пробелы и межсимвольные интервалы. На рис. 7.34 представлены два варианта форматирования фрагмента текста. В первом из них текст плотный, в другом — более свободный.

Рис. 7.34. Форматирование текста с разными значениями интервалов

Рассмотрим первый пример. В нем заданы значения межсимвольных интервалов 15/0/0%, и переносов— 65/100/110%. В диалоговом окне, управляющем переносом, задано количество переносов в смежных строках, не превышающее трех. При таких жестких пробелах обязательно появятся "лестницы". Ограничение смежных переносов до двух вполне допустимо. Такие "лестницы" встречаются практически в любой книге. Таким образом, жесткие ограничения интервалов дают темный плотный текст. Такой вариант форматирования дает большую экономию места и может использоваться для вгона строк.

Во втором примере запрещены смежные переносы, атрибуты пробелов равны 85/100/125%, а межсимвольных — 0/0/5%. Таким образом, за счет более свободного интервала значений достигается качественное межсимвольное расстояние и отсутствие смежных переносов. Такой вариант легче читается. Объем текста при этом вырастает по сравнению с первым вариантом.

0ба варианта форматирования далеки от идеала, тем не менее они дают представление о диапазоне возможностей использованных инструментов.

Вообще, приемы форматирования абзацев как таковые применяются довольно редко, в основном для очень небольших публикаций и для заголовков первого уровня. Настраивать каждый абзац в книге из 400 страниц — занятие долгое и утомительное. Кроме того, немаловажным является стандартизация оформления публикаций внутри одного проекта. В InDesign очень удобна, во-первых, возможность задания любых атрибутов в качестве стиля абзаца и символа (о стилях речь пойдет в следующей главе). Одинаковые отформатированные абзацы помечаются признаком стиля. При изменении атрибутов стиля автоматически меняются соответствующие атрибуты всех абзацев этого стиля в публикации, какой бы большой она ни была. Этот мощный инструмент делает возможным верстку книг в соответствующие нашему быстрому времени сроки. Стандартизации оформления очень помогает и то, что при наборе нового текста каждый следующий абзац наследует атрибуты предыдущего.


О создании таблиц

Несложные таблицы вполне можно выполнить в InDesign средствами форматирования абзаца. Рискнем утверждать, что результат может быть просто блестящим.

При верстке такого рода главное — чтобы позиции табуляции для всех абзацев таблицы были выровнены. Добиться этого можно несколькими способами: первый из них наиболее прямолинеен и состоит в выделении всей таблицы и последующей регулировке позиций табуляции. Другой прием — разделение строк таблицы не концом абзаца, а принудительным переносом строки. Тогда вся таблица (или какая-то ее часть) будет представлять собой один абзац. Это очень, удобно, если строки таблицы разделяются линейками или в разных столбцах таблицы насчитывается разное количество строк. Третий способ актуален, только если вы набираете таблицу прямо в InDesign (для небольших таблиц это вполне возможно). В этом случае позиции табуляции лучше всего задать стразу после ввода первой строки. Последующие вновь набираемые абзацы — строки таблицы — сохранят установленные позиции. Если же при дальнейшем наборе ширина последующих абзацев оказалась больше запланированной, то необходимо впоследствии провести корректировку.

Пользуйтесь стилями

Все-таки наиболее элегантным способом является задание позиций табуляции для стиля абзаца и последующее форматирование таблицы этим стилем. Если в публикации несколько таблиц, они автоматически будут иметь одинаковое оформление.

Вот несколько примеров таблиц, выполненных средствами InDesign:

Висячие отступы часто применяются в таблицах с неравномерным размещением текста в колонках (рис. 7.35). Первая колонка образована висячим отступом, а вторая представляет собой единый абзац, разделенный признаками конца строки. Наиболее важное поле выделено линейкой с отступом.

Рис. 7.35. Таблица с висячим отступом

Текст внутри каждой строки таблицы (рис. 7.36) также разбит признаками перехода на новую строку так, что каждая строка таблицы представляет собой единый абзац. Для этого абзаца заданы линейка по ширине колонки и небольшая отбивка. Таким образом, строки таблицы зрительно обособлены с помощью линейки.

Рис. 7.36. Таблица, образованная линейками абзаца

Импорт таблиц рассматривается в главе 9, а форматированию их уделено внимание в главе 16. Для таблиц, как ни для какого другого текста, актуальна настройка длин строк. Для этого в основном применяется редактирование атрибутов символов, прежде всего трекинг и регулирование ширины интервалов.


Верстка стихов

Специфическая верстка, к которой InDesign отлично приспособлен. При верстке стихов используются отбивки, абзацные отступы и принудительный перенос строки. Если стихотворение состоит более чем из одной строфы, необходимо, чтобы строфы отделялись друг от друга отбивкой, кроме того, в некоторых стихах строфы располагаются лесенкой. Рассмотрим верстку стихотворения, приведенного на рис. 7.37. Как первая, так и вторая строфы представляют собой единые абзацы. Внутри строф между строками вставлены признаки перехода на новую строку. Каждому из абзацев-строф приданы значения отбивок до и после абзаца. Второй абзац сверстан с отступом 30 мм от левого края полосы для образования лесенки. Стихотворению предшествует виньетка, составленная из символов декоративного шрифта и представляющая собой абзац с атрибутом On the Next Page. Таким образом достигается автоматическое размещение стихов по одному на странице. Для украшения и придания соответствующего колорита публикации для основного текста выбран классический наборный шрифт Garamond, а первая буква каждого стихотворения отформатирована каллиграфическим шрифтом и превращена в буквицу. Все очень просто, а в результате перед нами вполне профессиональная верстка карманного подарочного сборника стихов.

Рис. 7.37. Стихотворение оформлено с применением атрибутов абзаца


Резюме

В настоящей главе рассмотрены следующие вопросы, связанные с форматированием абзацев:

  • Абзац — это любая последовательность символов, в конце которой установлен признак конца абзаца. Кроме этого непечатаемого символа в программах верстки есть и другие — например, табуляции, специальные пробелы, мягкие переносы.
  • Многие атрибуты могут быть заданы лишь для всего абзаца целиком. Это выключка, настройка интервалов в выключенном тексте, линейки, отступы и отбивки, наличие и тип буквицы, табуляции, размещение абзацев на страницах.
  • Наиболее важен атрибут выключки. InDesign может выключать текст любым способом — влево, вправо, по центру, или по формату.
  • Для каждого абзаца также задаются режимы переноса слов.
  • При размещении абзацев во фреймах программа использует специальные алгоритмы, помогающие расположить символы равномерно.
  • Атрибуты абзаца определяются средствами палитры Paragraph и диалоговых окон, открываемых меню палитры. Позиции табуляции и отступы задаются в палитре Tabs.
  • Весьма важно также выравнивание строк соседних колонок и страниц по базовым линиям. В InDesign есть сетка базовых линий с произвольным шагом. Вы можете задать режим выравнивания строк по этой сетке.
  • Таблицы, списки и прочий структурированный текст готовят с помощью расстановки позиций табуляции. Для этих позиций задается выравнивание, в том числе по произвольному символу, и отточия.
  • Удачным элементом дизайна могут стать абзацные линейки. Их определяют над и под абзацем.
  • Качество верстки сильно зависит от равномерности заполнения строк. На длину строки влияют как атрибуты символов, так и атрибуты абзаца. При верстке строки приходится вгонять (уменьшать объем текста) и выгонять (увеличивать объем текста). Настройку текста следует проводить по определенному плану на пробном фрагменте.

Атрибуты символов и абзацев применяются для определения стилей — основного инструмента любой программы верстки. InDesign располагает великолепными средствами работы со стилями. Им и посвящена следующая глава.


Глава 8

Глобальное форматирование

.InDesign предлагает множество настроек символов и абзацев. Разумеется, было бы напрасной тратой времени задавать их по очереди для каждого абзаца или символа. Как и другие современные программы обработки текстов, InDesign предлагает развитый инструмент стилей — абзацных и символьных. Стили — главный инструмент форматирования текста в издательских системах. Любая публикация, насчитывающая больше пары страниц, выполняется со стилевым форматированием. Стили позволяют легко форматировать любые объемы текста, создают единство оформления публикации. С их помощью удобно выполнять как самую простую, так и сложную верстку.

В настоящей главе рассматриваются следующие вопросы:

  • Система стилей InDesign
  • Выбор стиля
  • Глобальное и локальное форматирование
  • Создание нового стиля. Редактирование стилей
  • Импорт стилей из других публикаций и приложений
  • Создание каталога стилей публикации с помощью палитры библиотеки


Понятие стилей

Совокупность элементов форматирования можно представить себе как элемент форматирования более высокого уровня — стиль. При пользовании стилями, таким образом, вместо последовательного задания десятков атрибутов абзац можно привести к желаемому виду одним щелчком мыши. Это дает огромный выигрыш в скорости и качестве верстки.

Даже если вы оформляете небольшую публикацию, не жалейте времени на создание стилей — эти затраты окупятся легкостью работы — ведь команды форматирования вводятся один только раз, а затем воспроизводятся одним-единственным щелчком мыши на имени стиля — и единообразием публикации одного проекта (удачным каталогом стилей вы сможете пользоваться потом годами). Если же ваша работа состоит в верстке книг, даже не пытайтесь заняться ею без использования стилей.

Стиль и стиль

В InDesign термин Style употребляется в двух совершенно разных значениях, которые не нужно путать. Style— единица глобального форматирования, Туре style — начертание символов (нормальное, курсив, полужирное, подчеркнутое и т. д.).


Стили символа и абзаца

Как символ, так и абзац текста можно описать совокупностью атрибутов форматирования, заданных командами меню. В программе поддерживаются два типа стилей: стиль символов и стиль абзацев. Первый тип стиля определяет атрибуты символа, которому он назначен. Второй определяет атрибуты абзаца. Все операции со стилями символов проводятся в палитре Character Styles (рис. 8.1). Она вызывается одноименной командой меню Type.

а

Рис. 8.1. Палитра Character Styles для документа без символьных стилей

Рис. 8.2. Стили символов в палитре и меню палитры

Основную часть палитры занимают строки стилей. Справа имеется стрелка, открывающая меню палитры, внизу — кнопки создания нового стиля и удаления существующего. В палитре перечислены все стили символов, которые имеются в документе. На рис. 8.1 показана палитра Character Styles для документа, в котором нет ни одного стиля символа. Верхняя строка [No character style] присутствует в палитре в любом случае и активна, если выделенным символам не присвоен ни один из стилей.

На рис 8.2 показана палитра стилей символа, в которой уже имеются несколько стилей. При выделении символов текста в палитре становится активным тот стиль, который им присвоен. Атрибуты для стиля или абзаца данного стиля могут быть изменены местно, локально. Если атрибуты символа отредактированы локально, т. е. в чем-то отличаются от определенных в стиле, то при выборе данного символа рядом с названием стиля появляется значок "плюс".

Аналогичным образом устроена и палитра управления стилями абзаца — Paragraph Styles (рис. 8.3). В ней размещаются стили форматирования абзаца, определенные для данной публикации. Стили абзацев можно импортировать из других приложений. Как видно из рисунка, строка импортированного стиля помечается значком дискеты. Разумеется, вы можете произвольным образом локально менять атрибуты для текста, отформатированного стилями.

Рис. 8.3. Палитра Paragraph Styles и ее меню


Применение стилей и локальное форматирование

Для присвоения стиля нужно щелкнуть на соответствующей строке палитры. Как и для локального форматирования, при определении стилей возможны три варианта задания стиля — для выделенного текста, в точке вставки и по умолчанию.

Применение стилей в InDesign называется глобальным форматированием (оно определяется для всех элементов публикации, которым присвоен данный стиль), в отличие от локального форматирования, выполняемого без применения стилей (оно определяется локально для данной группы символов или абзацев).

Заметим, что один и тот же атрибут (например, шрифт), может быть задан на разных уровнях форматирования — локально, как стиль символа и в составе стиля абзаца. Но ведь во всех трех случаях могут быть заданы совершенно разные значения. Логично задаться вопросом — если слон на кита полезет, кто кого переборет? Ниже мы рассмотрим взаимодействие уровней форматирования.

Стиль абзаца совершенно однозначно описывает внешний вид абзаца текста. В стиле определяются все возможные атрибуты как символов, так и абзаца. Абзац, к которому применен стиль примет строго определенный вид — атрибуты стиля заменят собой (подавят) локально определенные атрибуты (в том числе и определенные в составе стиля символов). Это с одной стороны хорошо, поскольку гарантирует единообразие текста. Однако иногда в тексте встречаются атрибуты форматирования символов (подчеркивание, индексы и пр.), которые ну никак не могут быть одинаковыми для всего абзаца, так как собственно и используются для выделения отдельных символов. Также и в отдельных абзацах могут встретиться подобные атрибуты, например значение интервалов, или параметры переносов — атрибуты, часто варьируемые локально при регулировании строк текста. Если применение стиля абзаца уничтожает такое форматирование — это большая потеря для верстальщика. Поэтому подавление локального форматирования может производиться в трех режимах:

  • При выборе стиля абзаца текста щелчком на строке стиля подавляется большинство локальных атрибутов. Это все атрибуты абзаца, локальное форматирование символов кроме индексов, подчеркивания, зачеркивания, языка набора и смещения базовой линии. Все стили символов при этом остаются нетронутыми.
  • При выборе стиля абзаца для выделенного текста с одновременным нажатием клавиши <Alt> подавляет все атрибуты локального форматирования и уничтожает форматирование стилями символов в пределах этого абзаца.
  • Если щелкнуть на строке стиля абзаца, одновременно нажав клавиши <Alt>+<Shift>, то все локальные установки форматирования останутся неизменными. Стили символов при таком форматировании также сохраняются неизменными.

Поскольку стилям можно назначать клавиатурные сокращения, присвоение стиля производится также набором нужной комбинации клавиш.

Выбор стилей, имеющих порядковые номера

Для стиля публикации можно задать и порядковый номер. Если он есть, то выбирать стили можно еще одним способом. Щелкните в пределах палитры при нажатых клавишах <Ctrl>+<Alt>. В поле палитры появится рамка. В этом режиме наберите номер, и программа активизирует стиль именно с этим номером.

Стиль символов, в отличие от стиля абзаца и локального форматирования, не всегда однозначно определяет вид отформатированных им символов. В нем совершенно не обязательно определять все параметры. Более того, обычно в стиле определяется один-два атрибута символа, остальные поля остаются пустыми. Имеется общее правило: если данный атрибут задан в стиле, то символ, форматируемый этим стилем, меняется соответственно. Если атрибут не задан в стиле, то при форматировании символ сохраняет локальные значения данного атрибута. Поясним этот тезис примером: имеется стиль, в котором задан шрифт, кегль и больше ничего. Применение этого стиля к данному символу изменит его шрифт и кегль на заданные в стиле. Остальные параметры символа (начертание, интерлиньяж, наклон, подчеркивание и пр.) не изменятся. Стиль символа определяет чаще всего лишь некоторые атрибуты. Так, если в стиле заданы шрифт и наклон символов, то при фоматировании символов этим стилем никак не изменятся кегль, начертание и остальные атрибуты.


Базирование и автоматическое присвоение стилей

Одним из основных свойств стилей форматирования является возможность базирования.

Базирование — это удобный способ организации. Он действует как для абзацных, так и для символьных стилей. Изменения в базовом (родительском) стиле автоматически перейдут на редактируемый (порожденный). Он в свою очередь может быть базовым для еще одного стиля и т. д. Так могут возникать сложные иерархические структуры стилей в публикации. В порожденном стиле можно задать отличия его от базового. Эти отличия сохраняются при изменении базового стиля.

Пусть, например, имеются три стиля — "Основной шрифт", "Курсив", "Полужирный курсив", причем первый является базовым для второго, второй — для третьего. Для второго стиля отдельно задано курсивное начертание. Изменение атрибута форматирования стиля "Основной текст" повлечет за собой аналогичные изменения во втором и третьем. Однако если изменить начертание базового стиля, то это изменение не отразится на порожденных, поскольку для них начертание задано отдельно. Изменения в стиле "Курсив" отразятся только на стиле "Полужирный курсив". Последний стиль можно менять как угодно, на первых двух это никак не отразится.

Автоматическое присвоение следующего стиля имеет смысл при наборе текста внутри InDesign и только для стилей абзацев. Возможны три режима автоматического присвоения стиля:

  • Наследование стилей. Форматирование следующего абзаца тем же стилем, что и текущего. Этот режим используется при наборе основного текста.
  • исследование стилей. Следующему абзацу присваивается определенный стиль, отличающийся от стиля текущего абзаца. Например, удобно задать последование стилей заголовка и основного текста. В стиле заголовка указывается стиль основного текста как последующий. По окончании набора заголовка после нажатия клавиши <Enter> образуется новый абзац со стилем основного текста.
  • Отмена присвоения стиля последующему абзацу. Следующий абзац форматируется локально с использованием всех атрибутов стиля предыдущего абзаца, но стиль при этом не присваивается.

Автоматическое присвоение действует только на новый текст

Если в готовом тексте отформатировать один из абзацев стилем с заданным последующим, то с нижележащими абзацами ничего не случится. Также ничего не произойдет, если набрать абзац таким стилем в существующей публикации. Действие атрибута автоматического присвоения распространяется только на абзацы, создаваемые после нажатия клавиши <Enter>.


Комплекты стилей документа

В современных программах обработки текста стили публикации являются ее частью и сохраняются вместе с ней. Перед началом работы с публикацией рекомендуется тщательно разработать структуру стилей — соотношения атрибутов, систему именования, принципы базирования и пр.

Это обеспечит удобство и быстроту работы, когда почти вся верстка делается сама, а верстальщику остается лишь чуть подправить получившуюся в результате глобального форматирования публикацию и навести окончательный глянец. Поверьте, такая организация работы возможна! Удачные комплекты стилей можно использовать постоянно, например, раз определившись со стилями для серийной книги вы можете годами пожинать плоды, издавая все новые проекты данной серии на основе все того же комплекта стилей (иногда его называют стилевым листом).

Темное прошлое стилевых листов

В старых системах верстки, когда идеология стилей только создавалась, стилевые листы представляли собой отдельные файлы. Они хранились в специальном каталоге, все вместе, для всех публикаций. При копировании файла нужно было копировать стилевой лист отдельно. В настоящее время каталоги стилей хранятся в файлах своих публикаций.


Пути создания нового стиля

К созданию нового стиля можно приступить двумя способами: во-первых, организовать его "с нуля", во-вторых — создать стиль по образцу локально отформатированных символов или абзацев.

Для создания стиля "с нуля", т. е. непосредственным заданием атрибутов, отмените выделения в публикации и выберите команду New Style меню палитры Character Styles или Paragraph Styles (или нажмите кнопку New внизу палитры). Откроется диалоговое окна создания стиля — соответственно символьного или абзацного. В окне создания стиля символов поля ввода будут пустыми, в окне создания стиля абзаца в полях и списках будут заданы атрибуты по умолчанию.

Если перед открытием окна создания стиля установить точку ввода или выделить символы в текстовом режиме, в диалоговых окнах атрибуты стиля будут определены программой в соответствии с форматированием выделенных символов. Интересно, что для стиля символов заполняются только те поля, значения в которых отличаются от установок по умолчанию. Если выделенные символы или абзацы имеют разное форматирование, берется первый символ и первый абзац из выделенных. Вам останется только отредактировать атрибуты (по необходимости).


Создание стиля символов

После выбора команды New Style меню палитры Character Styles перед вами откроется диалоговое окно создания стиля. При создании стиля "с нуля", без образца текста, все его поля ввода и списки пусты. Вверху окна расположено поле имени. По умолчанию InDesign предлагает для первого определяемого стиля название Character Style 1, для второго — Character Style 2 и т. д. В поле можно ввести произвольное имя.

Имена для стилей должны быть продуманы

В имени стиля желательно написать его основную особенность или область применения в данном документе. Например, если вы создаете стиль для форматирования математических формул внутри текста, разумно назвать его "Mathematics", а не "Stylel". Осмысленные имена позволят не запутаться даже среди очень большого количества стилей.

Окно создания стиля имеет несколько вкладок, подобно окну установок программы. Вкладки переключаются в раскрывающемся списке вверху окна (под поле ввода имени) или нажатием кнопок Next и Prev. Окно открывается всегда на вкладке General (рис. 8.4). В правой части каждой вкладки расположен флажок предварительного просмотра Prev.

Рис. 8.4. Диалоговое окно New Character Style, вкладка General

В списке Based On задается базовый стиль для создаваемого. Именно со стилем, заданным в этом поле, устанавливается направленная связь по типу "родитель-порожденный".

В поле Shortcut задается клавиатурное сокращение стиля. В этом качестве используются клавиши <Ctrl>, <Shift>, <Alt>+<Ctri>, <Ctrl>+<Shift>, <Alt>+<Shift>, <Alt>+<Ctrl>+<Shift> в сочетании с цифрами, набранными на цифровой клавиатуре. Нажатие любых других клавиш, кроме упомянутых, не приводит ни к какому результату. Например, чтобы задать для стиля клавиатурный эквивалент <Ctrl>+<2> именно эти клавиши и следует нажать (а не набирать слово "Ctrl" буквами). Программа сама следит, чтобы все клавиатурные сокращения для стилей были разными. Если вы попытаетесь задать эквивалент, уже использованный для другого стиля, InDesign выведет сообщение, информирующее о том, что данная комбинация уже зарезервирована (рис. 8.5).

Рис. 8.5. Клавиатурное сокращение уже использовано для другого стиля

Область Style Settings служит не для задания параметров, а для их отображения. В ней перечислены все атрибуты стиля. По мере их определения область автоматически заполняется и обновляется. Мы вернемся к ее рассмотрению после обсуждения всех вкладок диалогового окна New Character Style.


Вкладка Basic Character Formats

В полях ввода этой вкладки (рис. 8.6) окна New Character Style задаются основные атрибуты символов. Обычно в этой, да и в остальных вкладках заполнено всего одно-два поля, остальные атрибуты для символов форматируются вне стиля символов — стилем абзаца или локально.

Рис. 8.6. Диалоговое окно New Character Style, вкладка Basic Character Formats

Поля ввода атрибутов трудностей не представляют. Это обычные атрибуты символов — шрифт, начертание, кегль, кернинг, трекинг, регистр, индексы, интерлиньяж.

Ниже располагаются флажки, которые также задают атрибуты символов — подчеркивание, зачеркивание, лигатуры, старинное форматирование чисел Old Style, запрет разбиения слова или группы слов NoBreak. Каждый из этих флажков может находиться в одном из трех состояний:

  • черный флажок — атрибут включен;
  • серый флажок — атрибут не входит в стиль символа, он остается таким, каким был задан для символов локально или в стиле абзаца;
  • флажок сброшен (пустое поле) — если у символа есть этот атрибут, то он отменяется.
  • форматировании атрибутов символов подробно написано в главе 6.


Вкладка Advanced Character Formats

В этой вкладке (рис. 8.7) продолжается задание атрибутов символов. Здесь собраны атрибуты масштабирования по горизонтали и вертикали, наклона и смещения базовой линии. В нижнем раскрывающемся списке выбирается язык символов. В этом списке присутствует не весь список языков, поддерживаемых программой, а только языки, использованные в публикации, плюс язык программы по умолчанию (тот, который устанавливается при инсталляции, обычно — американский вариант английского языка). Возможен также выбор пункта [No Language], тогда символы, отформатированные этим стилем не будут подвергаться проверке орфографии и переносам. Если оставить поле пустым, сохраняется язык, заданный локально или в стиле абзаца. Все поля и списки этой вкладки также представляют собой обычные атрибуты символов и описаны в главе 6.

Рис. 8.7. Диалоговое окно New Character Style, вкладка Advanced Character Formats


Вкладка Character Color

Здесь задаются атрибуты заливки и обводки символов. Основную площадь занимает список определенных в публикации цветов. Слева расположены образцы заливки и обводки. Активным является верхний образец. Для активизации образца следует выполнить на нем щелчок мышью. Если образец помечен вопросительными знаками, значит данный атрибут в стиле не задается. Для задания цвета нужно щелкнуть на нужной строке списка цветов публикации. Для заливки можно задавать цвет, а в поле Tint — и его оттенок. Обводке могут быть присвоены оба этих атрибута и дополнительно — толщина в поле Weight. Флажки Overprint Fill и Overprint Stroke регулируют печать обводки и заливки с наложением при наличии цветного фона. Если флажок установлен, данный атрибут печатается с наложением, если снят — без наложения. Если в поле находится серый флажок, значит, атрибут наложения не входит в стиль символа.

После того как вы определили все необходимые атрибуты, полезно снова перейти на вкладку General и взглянуть на поле Style Setting. В нем перечислены все определенные величины. Вначале в квадратных скобках указан базовый стиль, затем через запятую указаны параметры, заданные в стиле. Например, стиль на рис. 8.8 имеет такие атрибуты: базовый стиль — "Основной текст", шрифт — Arial, начертание — полужирное, отмена подчеркивания, язык — английский, американский вариант. Остальные атрибуты не входят в данный стиль символа.

Рис. 8.8. Диалоговое окно New Character Style, вкладка Character Color


Определение стиля абзаца

Для задания стиля абзаца InDesign предлагает диалоговое окно New Paragraph Style. Оно открывается командой New Character Styles (можно также нажать кнопку New внизу палитры). Окно создания стиля абзаца имеет несколько вкладок, определяющих все атрибуты текста — как абзацные, так и символьные. Как и для стиля символов, вы задаете имя стиля абзаца и можете просматривать результаты форматирования стиля без закрытия диалогового окна, если установите флажок Preview.


Вкладка General

На этой вкладке (рис. 8.9) определяется клавиатурное сокращение стиля абзаца и базовый стиль. Эти атрибуты уже обсуждались для стиля символа. В поле Next задается стиль форматирования, следующий за данным. Этот атрибут действует только на вновь вводимый текст. В раскрывающемся списке присутствуют пункты [No Paragraph Style], отменяющий форматирование стилем, [Same Style], задающий следующему абзацу тот же стиль, что и данному, и все стили абзаца данной публикации.

Рис. 8.9. Диалоговое окно New Paragraph Style, вкладка General

Как и в окне задания стиля символов, поле Style Settings отведено для описания данного стиля — в нем в квадратных скобках названы базовый и последующий стили, а затем перечислены заданные атрибуты.


Вкладки задания атрибутов абзаца

Вкладки окна, посвященные заданию атрибутов абзаца, содержат те же элементы управления, что и палитра Paragraph при локальном форматировании. Как и в случае задания символьного стиля, если нет текстового выделения или точки вставки, программа проставляет в полях атрибуты по умолчанию. Если есть выделение текста или точка ввода, значения атрибутов соответствуют форматированию выделенного текста. И в том, и в другом случае любые атрибуты абзаца можно произвольно менять.

  • Indents and Spacing (рис. 8.10). Здесь задаются тип выключки, отбивки и отступы. Флажок Align to Baseline Grid определяет наличие выравнивания по сетке базовых линий.
  • Drop Caps and Composer (рис. 8.11). Задание параметров буквицы и режима размещения текста.
  • Justification. Эта вкладка устроена так же, как окно Justification, предназначенное для локального форматирования абзаца (см. главу 7). Здесь задается диапазон пробелов, межсимвольного расстояния и ширины символов, в котором производится автоматическая подстройка при размещении текста с выключкой по формату. В нижней части расположено поле задания значения автоматического интерлиньяжа.

Рис. 8.10. Диалоговое окно New Paragraph Style, вкладка Indents and Spacing

Рис. 8.11. Диалоговое окно New Paragraph Style вкладка Drop Caps and Composer

  • Tabs. Размещение позиций табуляции в документе и их тип Эта вкладка организована так же, как палитра Tabs (см. главу 7, рис 7 28) Тип табуляции задается кнопками со стрелками, размещение позиции - щелчком на соответствующем месте линейки табуляции или вводом в поле Х В поле Leader можно определить отточие, в поле Aligned - символ по которому слеует выравнивать табулированный текст (для типа выравнивания Aligned to Decimal (Or Other Special Character) Tab). Поместив курсор на нижнюю часть линейки (там, где деления), вы можете смещать ее в отведенном окне перетаскиванием курсора. С помощью линейки табуляции задаются и отступы.
  • Hyphenation. Вкладка, аналогичная одноименному диалоговому окну (см. главу 7, рис. 7.22). В ее полях определяются параметры переноса слов.
  • Keep Options. Определение расположения абзацев на страницах и контроль висячих строк производятся так же, как и при локальном задании атрибутов в диалоговом окне Keep Options (см. главу 7, рис. 7.21).
  • Paragraph Rules. Задание положения, толщины, цвета линеек над и под абзацем. О форматировании линеек читайте в главе 7 (рис. 7.25).


Вкладки форматирования символов

Как вы уже знаете, стиль абзаца должен однозначно определять вид текста. Поэтому кроме собственно атрибутов абзаца в стиль входят и все атрибуты символов. Они определяются на трех вкладках:

  • Basic Character Formats. Здесь задаются шрифт, начертание, кегль, кернинг, трекинг, регистр, индексы, интерлиньяж, подчеркивание, зачеркивание, лигатуры, старинное форматирование чисел Old Style и запрет разбиения слова или группы слов No Break.
  • Advanced Character Formats. Определяются атрибуты масштабирования по горизонтали и вертикали, наклона и смещения базовой линии. В нижнем раскрывающемся списке выбирается язык символов.
  • Character Color. Задание цвета символов абзаца — обводки и заливки. Установка толщины обводки.

Все три вкладки одинаковы в окнах определения стиля абзаца и стиля символов (см. раздел "Создание стиля символов" даннои главы).


Операции со стилями

Со стилями можно обращаться вполне свободно — создавать новые, редактировать, удалять, копировать из других файлов и импортировать из других приложений. При редактировании стиля весь текст данной публикации, отформатированный им, принимает переопределенные атрибуты. Какой простор для творческой мысли! Если вы не пользуетесь стилями, то для изменения форматирования публикации (скажем, для смены интерлиньяжа, или гарнитуры) придется переопределять в ней каждый абзац. При наличии стилей достаточно изменить атрибут стиля, и вы увидите результат сразу на всем тексте. Экспериментируйте сколько душе угодно.


Редактирование и переопределение стиля

Раз созданный стиль можно, разумеется, изменить. Для этого нужно предварительно выбрать его в палитре Character Styles или Paragraph Styles (обратите внимание, что если в публикации определена точка вставки или есть выделенный текст, то произойдет форматирование этим стилем текущего абзаца или символов. Выбор команды Style Options меню палитры откроет окно редактирования стиля. Открыть окно редактирования также можно двойным щелчком на имени стиля в палитре.

Окна редактирования аналогичны окнам создания стилей, но отличаются по названию — Modify Character Style Options для символьного стиля и Modify Paragraph Style Options для стиля абзаца. В диалоговом окне вносятся изменения в параметры стиля. После редактирования измененные атрибуты сообщаются всем элементам текста, отформатированным соответствующим стилем.

Как вы уже знаете, при задании стиля абзаца возможно сохранение как некоторых или даже всех атрибутов форматирования символов, так и локального форматирования абзацев. Уже после того, как для символа и абзаца задан стиль, вы вполне можете отформатировать текст локально, "поверх" стиля. В любом случае, если хотя бы один атрибут форматирования для выделенного текста или в точке ввода не совпадает с заданным в стиле, справа от строки стилей появляется значок "плюс". Для того чтобы привести все атрибуты в соответствие со стилем, щелкните на его строке при нажатой клавише <Alt>. Возможна и обратная ситуация: переопределение стиля на основе локально отформатированного текста. Для переопределения выберите текст, форматирование которого вы хотели бы видеть в данном стиле, и выберите команду Redefine Style. Текст будет отформатирован этим стилем, но сам стиль примет атрибуты данного текста.


Удаление стилей и отмена стилевого форматирования

Оговоримся сразу, что удаление стиля не удаляет отформатированный им текст. Следствие удаления неприятно, но не столь фатально: если в публикации есть текст этого стиля, все атрибуты стилевого форматирования становятся локальными, а тексту присваивается атрибут No Character Style или No Paragraph Style, в зависимости от того, какой стиль должен быть удален.

Для удаления стиля следует выбрать его строку в палитре. Одновременно можно выбрать несколько стилей, если щелкать на их строках, одновременно удерживая клавишу <Ctrl> (для выбора стилей в произвольном порядке) или <Shift> (для выбора стилей подряд). Определив, какие стили вы будете удалять, выберите команду Delete Styles меню палитры или перетащите строки стилей к пиктограмме мусорной корзины в нижней части палитры.

Стили удаляются без подтверждения, "молча". Поскольку программа поддерживает список отката, вы сможете вернуться к состоянию до удаления, если потом сообразили, что удаляли стиль зря.

Подтверждение при удалении стилей

Выбранные стили удаляются и при щелчке на пиктограмме корзины. Только в этом случае InDesign просит подтверждение на удаление стилей.


Очистка стилевого листа от лишних стилей

Обычно в реальной публикации список стилей довольно внушителен. Если вы пользуетесь единым шаблоном для разных целей, если в публикации имеются импортированные стили, в случае, если ваши представления о стилевом оформлении эволюционировали с момента начала работы — в этом каталоге могут появиться лишние стили — те, которые не используются в документе. Их следует удалить. InDesign способен автоматически определить, какие стили не использованы в документе. Для этого служит команда Select All Unused, она есть в обеих палитрах стилей. При выборе команды в палитре становятся выделенными все неиспользуемые стили, и их можно удалить за один раз.


Отмена стилевого форматирования

При задании тексту стиля между форматированием данного участка текста и параметрами стилей устанавливается связь — все изменения в стиле сказываются на тексте. В некоторых ситуациях это нежелательно. Для отмены стилевого форматирования выделите текст и выберите в палитре пункт [No Character Style] или [No Paragraph Style]. Все форматирование текста сохраняется, но становится локальным.


Дублирование стилей

В документе часто могут быть два или несколько стилей с очень похожими свойствами, например стиль для основного текста и для нумерованного списка отличаются между собой лишь значениями отступов.

Такие наборы стилей можно создавать дублированием. Для дублирования выберите команду меню палитры Duplicate Style или перетащите строку стиля к пиктограмме чистого листа внизу палитры. По умолчанию программа создает копию стиля с теми же атрибутами, что у исходного, и присваивает копии имя <Исходный стиль> сору 1. Между копией и скопированным стилем связь не устанавливается. Вы можете менять имя и атрибуты каждого из них независимо.


Импорт стилей

Если вы удачно определили стили для публикации, то при переходе к работе над другой подобной публикацией можно не выполнять все назначения заново, а импортировать стили из старой публикации в новую. В общем случае возможность импорта стилей облегчает стандартизацию публикаций. Импорт стилей производится несколькими способами:

  • Копирование текста со стилевым форматированием из другой публикации InDesign. Все стили, использованные в копируемом участке текста при вставке, переходят в текущую публикацию. Они расцениваются InDesign как полноценные стили публикации, а не импортированные. Рядом со строкой стиля нет пиктограммы дискеты.

Выборочное копирование стилей InDesign

Отформатируйте пустые абзацы нужными стилями абзаца, наберите в одном из абзацев символы и отформатируйте их нужными стилями символов. Полученный пустой фрейм скопируйте в InDesign. В публикации появятся все необходимые стили и текстовый блок, состоящий из пробелов. Этот "контейнер" затем можно стереть.
  • Импорт стилей из публикации InDesign. Команда Load All Styles предназначена для импорта всех стилей — и символьных, и абзацных. При выборе этой команды из меню палитры Character Styles или Paragraph Styles открывается системное окно открытия файла. В нем нужно выбрать файл для импорта стилей. Затем нажмите кнопку ОК, и все стили, будут импортированы в текущую публикацию (сам файл при этом не открывается). Помещенные стили также расцениваются программой как полноценные стили публикации.
  • Импорт стилей только одного типа. В палитрах Character Styles или Paragraph Styles предусмотрены команды для импорта только стилей абзаца (Load Paragraph Styles) и символа (Load Character Styles).
  • Импорт стилей из других приложений. При импорте файлов командой Place вместе с текстом импортируются стили, использованные в публикации. Они помечаются значком дискеты. Для того чтобы импортированный стиль стал полноправным стилем InDesign, необходимо открыть окно его редактирования и поменять любой из атрибутов (потом можно сразу поменять его обратно). Какие именно атрибуты можно импортировать, зависит от организации стиля в стороннем приложении и качества фильтра импорта. Обычно импортируются только стили абзацев, причем тонкие настройки текста InDesign игнорирует, импортируя лишь шрифт, начертание, отступы и отбивки. Импорту документов посвящена глава 9.


Наложение стилей

В большинстве публикаций есть заголовок, подзаголовок, основной текст и прочие общие элементы. Поэтому имена стилей в списках могут повторяться для различных публикаций. При наличии среди импортируемого списка стилей, названия которых совпадают с названиями стилей, уже имеющихся в текущей публикации, InDesign поступает очень просто — он не импортирует эти стили, а помещаемый текст форматирует стилем публикации, совпадающим по названию с импортируемым.


Создание стилевого листа публикации

Форматирование публикаций с использованием стилей придает работе верстальщика логику и последовательность. Каталог стилей однозначно определяет все атрибуты форматирования документа. Без стилей трудно, практически невозможно добиться стандартного оформления публикации, единообразия всех элементов оформления. Кроме того, система стилей облегчает эксперименты в области оформления. Используя стили, можно проверить множество вариантов форматирования без утомительного форматирования публикации вручную. Все эти положительные моменты действительны только в случае грамотно разработанной системы стилей.

Как в любой работе, организация работы со стилями зависит от характера и привычек работающего. Одни верстальщики любят еще перед началом работы создать весь каталог стилей, продумав все особенности каждого и связи между ними, а затем уже начинать верстку. Некоторые предпочитают вводить стили в публикацию по одному, по мере надобности. Чаще всего система стилей готовится заранее для минимума стилей абзацев, а затем при необходимости каталог дополняется и изменяется. Например, если вы собрались верстать издание с заголовками двух уровней вложенности, колонцифрами и эпиграфами перед основным текстом, то целесообразно сразу назначить стили всем этим элементам текста. Если вам необходимо будет ввести еще один стиль для подрисуночных подписей, вы сможете сделать это и позже.

Основное правило, которого нужно придерживаться, состоит в том, что если вы работаете с использованием каталога стилей, то необходимо задавать стиль для каждого абзаца публикации и определять символьные стили для всех элементов, которые в этом нуждаются. В этом случае преимущества работы с глобальным форматированием будут наиболее ощутимыми. Вот некоторые этапы подготовки рабочего стилевого листа:

  • Продумайте удобную систему имен стилей.
  • Сформируйте каталог на принципах базирования и последования стилей.
  • На основе каталога стилей создавайте и впоследствии используйте библиотеку стилей.
  • Придерживайтесь придуманных вами правил именования стилей и работы с ними.


Разработка списка стилей

Итак, для начала разработайте и запишите на бумаге список основных стилей для заголовков, определив основные атрибуты форматирования для каждого. Рекомендуем распечатать пример заголовков, отформатированных каждым из заголовочных стилей, чтобы убедиться в их адекватности.

После уточнения форматирования заголовков разместите под ними пример основного текста, продумав атрибуты форматирования для него. Подумайте, стоит ли вводить дополнительные стили для подрисуночных подписей, колонцифр, колонтитулов, таблиц и других специальных элементов, нужны ли символьные стили и какие. Если нужны, то придумайте и их тоже.


Система именования стилей

Затем продумайте систему именования стилей, учитывая следующие пожелания:

В имени стиля должна быть отражена область его применения. Название стиля "Стиль 4" менее удачно, чем "Заголовок 2 уровня". Если не соблюдать это правило, можно запутаться и забыть, для чего предназначался придуманный стиль.

В палитре все имена стилей располагаются в лексикографическом порядке. Чем чаще применяется стиль в публикации, тем выше его нужно поместить в списке палитры стилей. Скажем, стилям форматирования основного текста и подзаголовков следует дать имена, начинающиеся с первых букв алфавита, а редко используемые стили назвать так, чтобы они не мешали при работе, находясь в верхней части списка. Кроме того, можно, например, всем заголовочным стилям предпослать цифру 1, всем стилям списков — 3, стилям, используемым в таблицах, — 7 и т. д. В этом случае стили одной группы будут располагаться в палитре подряд. Кроме того, их будет легко найти при помощи клавиатуры.

Если вы регулярно используете материалы из одного и того же текстового процессора, приведите названия стилей в соответствии со стандартными именами его стилей. В этом случае при импорте файлов из текстового процессора у вас не будет никаких проблем — стандартные стили будут автоматически заменены на одноименные стили InDesign.


Оформление базовых стилей

Пришла пора собственно создания стилей. Вероятно, вам понравилась описанная в этой главе система базирования стилей. В этом случае для начала задайте базовые, основные стили. Скорее всего, это будут стили заголовка первого уровня и основного текста. Создайте эти стили. Наиболее удобен метод создания по образцу выделенного текста.

Для стилей заголовков первого уровня задайте необходимую разбивку текста на страницы. Если, например, требуется начинать каждую главу с новой страницы, включите это требование в стиль абзаца. Для заголовков актуальны и другие стилевые решения — запрет переносов, расположение вместе со строками последующего абзаца, размещение всех строк заголовка на одной странице. Заголовки не принято набирать с красной строки.


Базирование и последовательность стилей

Можно переходить к построению иерархии стилей абзацев. Постройте стили для вс.ех остальных заголовков на основе стиля заголовков верхнего уровня. Базировать имеет смысл гарнитуру, тип выключки и другие атрибуты, предполагаемые общими для всех заголовочных абзацев. Это очень удобно для экспериментов в области оформления публикации. Скажем, для изменения гарнитуры всех заголовков достаточно изменить ее в базовом стиле. Не следует базировать атрибуты разбиения на страницы, отступы, включения в оглавление. Все они могут различаться в разных заголовках.

Инструмент базирования — мощное средство автоматизации работы. Как всяким сильнодействующим средством, им нужно пользоваться осторожно, в противном случае результаты могут быть самыми дикими. В любом случае, если вы верстаете публикацию со множеством стилей, тем более с применением технологии базирования, составьте описание стилей на бумаге и пользуйтесь им при редактировании каталога. Такой список поможет разобраться в содержимом вашего стилевого листа, и у вас не появится несколько лишних стилей, описывающих одинаковые абзацы, или не будет задан неправильный порядок базирования стилей.

Элементы оформления типа подписей под рисунками, колонцифр, колонтитулов также можно базировать, скажем, на стиле основного текста. В качестве базового элемента здесь будет выступать гарнитура и, возможно, особенности начертания. Стили заголовков обычно базируются на заголовке первого уровня, причем базовым атрибутом является гарнитура и изредка — выключка.

Соблюдайте умеренность

Создавая структуру базирования стилей, не впадайте в экстаз от возможностей базирования, проявляйте здоровую осмотрительность. Можно довести каталог с помощью многоуровневого базирования до такого состояния, когда любое изменение стиля ведет к устрашающим изменениям в макете. Ограничьтесь при базировании только самыми необходимыми атрибутами форматирования символов.

Если вы собираетесь создавать новый текст в InDesign, продумайте последовательность стилей. Целесообразно задать режим повторения стиля для абзацев основного текста, для заголовков первого уровня указать последующий стиль заголовков второго уровня, для подрисуночных подписей — последующий стиль основного текста. Продуманная последовательность стилей при наборе сэкономит массу времени. Однако помните, что режим последования стилей действует только на вновь вводимый текст и не изменяет стиль существующих абзацев, поэтому для верстки готового текста он часто бесполезен.


Специальные стили

Если вы собираетесь верстать публикации, в которых есть специальное форматирование, например, рисунки, таблицы и базы данных, внимательно изучите их при создании каталога стилей. Можно ли сверстать все элементы (таблицы, рисунки) непосредственно в InDesign? Если это кажется возможным, создайте соответствующие стили. Так, в стиль для форматирования таблиц, включите позиции табуляции, отступы и линейки абзацев. То же относится к базам данных.

Не верстайте каталоги в InDesign!

Конечно, выбор системы для верстки — дело вкуса, но если вы верстаете периодическое издание в виде таблицы, и его нужно будет часто обновлять, советуем вам отказаться от верстки с применением позиций табуляции.

В стиле можно использовать специальные символы и символы любого, в том числе и графического шрифта. Поскольку графические шрифты уже получили широкое распространение, в состав стиля можно вводить готовые виньетки, символы перечня и пр. Для этих элементов можно и нужно задавать стиль, с указанием гарнитуры набора, кегля, смещения базовой линии, кернинга и разбиения на страницы.


Сохранение стилевого листа и палитра библиотеки

Если созданный стиль или весь каталог стилей получился удачным, и его можно использовать в других публикациях, то сделать это можно разными способами.

  • Создание шаблона публикации. Впоследствии можно будет создать публикацию по шаблону с уже готовыми стилями или импортировать каталог стилей из шаблона в создаваемый документ. О шаблонах и работе с ними рассказывается в главе 15.
  • Создание библиотеки стилей с помощью палитры библиотеки. Из палитры можно будет перетаскивать хранящиеся там объекты вместе с их стилями в текущую публикацию.

Убедившись, что созданный вами стиль хорош и заслуживает длительного хранения, создайте пустой фрейм и наберите в нем имя и краткую характеристику выбранного стиля. Отформатируйте получившийся абзац этим стилем.

Пункт Libraries меню Window открывает список команд для работы с библиотеками программы (рис. 8.12). Внизу списка располагаются названия библиотек, расположение которых известно программе. В этот список попадают все библиотеки, которые создаются или открываются в InDesign на данном компьютере, поэтому если вы пользуетесь библиотеками, то список растет. Рядом с названием каждой из библиотек есть команда Show (Показать) или Hide (Скрыть), смотря по тому, открыта библиотека в данный момент или закрыта. Если вы открываете библиотеку в первый раз, то ее нет списке, и ее следует открыть командой Open.

Рис. 8.12. Команды работы с библиотеками

Команда New предназначена для создания новой библиотеки. При ее выборе открывается диалоговое окно создания файла, в котором вы задаете расположение и имя для новой библиотеки (она может располагаться на любом диске, в том числе и сетевом).

После нажатия кнопки ОК перед вами — новая, пустая палитра библиотеки (рис. 8.13, а). В ней могут храниться любые объекты — текст, рисунки, растровые изображения.

Для помещения в нее элемента (в нашем случае текстового блока) выделите его и перетащите в область палитры или выберите команду New Item. Миниатюра с изображением выбранного фрагмента появится в окне палитры (рис. 8.13, б). Двойной щелчок на миниатюре или команда Item Information открывает одноименное диалоговое окно (рис. 8.14). В нем задается имя объекта, дата создания, из списка Object Type выбирается тип объекта (в нашем случае — текст) и дается краткое описание объекта, содержащее ключевые слова для последующего поиска. Задавайте для объекта значащее имя (в данном случае наиболее логично назвать его по имени стиля) и внятное описание. Это облегчит поиск, если ваша библиотека впоследствии разрастется.

а [image] б

Рис. 8.13.Палитра библиотеки: пустая (а), новый элемент в палитре и открытое меню (б)

Когда возникнет необходимость в применении стиля из библиотеки, выберите нужный объект и перетащите его в окно публикации. В публикации появится фрейм, отформатированный нужным стилем. Одновременно этот стиль появится и в палитре стилей, абзацных или символьных. Фрейм-контейнер удалите. Стили вносятся в каталог публикации только в том случае, когда в последнем нет стилей с теми же именами. В случае совпадения имен доминируют собственные стили публикации.

Рис. 8.14. Диалоговое окно Item Information

Если ваша библиотека велика, для поиска нужного объекта воспользуйтесь диалоговым окно поиска Library Subset. О поиске в библиотеке можно прочитать в главе 12.

Хранение стилевого листа в библиотеке

В объектах-контейнерах можно хранить не один стиль, а несколько, и даже весь стилевой лист публикации, если по вашему мнению он может быть использован в других документах. Для этого отформатируйте приготовленный для помещения в библиотеку фрагмент теми стилями, которые вы хотите сохранить. Разумеется, в этом случае фрагмент должен состоять из нескольких абзацев, их должно быть столько, сколько стилей вы собираетесь хранить в нем.


Резюме

В этой главе мы довольно подробно изучили принципы создания стилей и инструменты работы с ними.

  • Стиль— это атрибут форматирования более высокого уровня. Стиль описывает внешний вид символа (символьный стиль) и абзаца (абзацный стиль). Символьный стиль задает отличия символа от всех остальных, определяя лишь некоторые атрибуты. Абзацный стиль содержит исчерпывающее описание стилей.
  • Форматирование стилями носит название глобального. Форматирование заданием атрибутов называется локальным. Между этими типами форматирования существуют сложные отношения, но в общем случае локальное форматирование имеет приоритет на глобальным.
  • -Один стиль может быть базирован, т. е. связан с другим. Кроме того, между абзацными стилями могут быть отношения последования, когда при наборе текста, отформатированного определенным стилем, автоматически выбирается следующий.
  • Стили назначают в специальных диалоговых окнах. Для каждой группы стилей (символьных и абзацных) предусмотрена своя палитра, с помощью которой выполняются основные операции со стилями — редактирование, дублирование, удаление, импорт.
  • Стили также можно импортировать из другого приложения.
  • Между текстом и его стилем есть связь — при изменении стиля изменяется и отформатированный им текст. Эту связь можно разрушить, присвоив тексту атрибут "Без стиля".
  • Комплект стилей публикации хранится вместе с документом. Его называют стилевым листом. Удачные стилевые листы удобно сохранять на будущее в шаблонах или палитре библиотеки.

В дальнейших главах мы продолжим изучение системы стилей применительно к различным аспектам верстки в InDesign.


Глава 9

Импорт и размещение текста

InDesign предназначается для верстки публикации, т. е. размещения элементов публикации (текстов и изображений) и получения готового оригинал-макета. В этой программе набирают только заголовки, маленькие таблицы, иногда небольшие статьи и заметки. Основной текст готовят в текстовом процессоре и затем размещают в InDesign. Именно поэтому особенности импорта и последующего размещения текста крайне важны для верстальщика.

Вопросы, которые будут освещены в этой главе:

  • текстовые фреймы, материалы InDesign, сцепление текстовых фреймов, границы текстовых фреймов;
  • способы размещения текста — ручной, автоматический, полуавтоматический;
  • операции с текстовыми фреймами — создание, размещение текста, изменение размеров;
  • фильтры импорта программы InDesign.


Размещение текста

Как вы уже знаете, поместить текст в публикации можно тремя путями: импортом, копированием через буфер обмена (в том числе и перетаскиванием из одного окна в другое по методу Drag and Drop) и набором в InDesign. Весь текст (несколько слов или тысячи страниц) размещается в текстовых фреймах. Текст без фрейма в публикации не размещается.


Отображение фреймов в документе

При использовании инструмента Type символы текста выделяются так же, как в текстовом редакторе (рис. 9.1, а). Если при выбранном инструменте Selection щелкнуть на тексте, то будет виден фрейм, в котором текст располагается (рис. 9.1, б). Тонкими линями (по умолчанию они синие) отмечаются границы фрейма. По углам и в середине на каждой границе фрейма имеются манипуляторы, с помощью которых его можно масштабировать. Справа и слева расположены индикаторы связи и состояния текста? не поместившегося в данный фрейм.

а [image] б

Рис. 9.1. Выделение: а — текста, б — фрейма

InDesign позволяет выбрать режим отображения фреймов. Для этого служит команда-переключатель Show Frame Edges/Hide Frame Edges. Выбрав первую команду, вы делаете фреймы видимыми и без выделения (рис. 9.2). Этот режим пригодится для выяснения структуры публикации и во время размещения элементов. Выделенный фрейм отличается от невыделенных только наличием манипуляторов.

а

б

Рис. 9.2. Режимы отображения фреймов в документе: б — Hide Frame Edges

Вторая команда запрещает отображение границ фреймов, если они не выделены. Рекомендуем просматривать готовые страницы в отключенном режиме показа непечатаемых символов — тогда вы сможете увидеть публикацию в том виде, в каком она будет напечатана.


Трансформации фрейма

Текстовый фрейм служит контейнером для текста. Он может иметь любую форму и размер, в том числе быть незамкнутым и самопересекающимся (рис. 9.3). Начальные сведения о фреймах приведены в главе!. Фреймы создаются специальными инструментами Rectangle Frame, Ellipse Frame, Polygon Frame. Кроме того, во фрейм можно превратить любой графический объект. Об этом рассказывается в главе 1.

С фреймами можно обращаться как с графическим объектом: перемещать, изменять размеры, поворачивать, изменять форму, отражать и пр. В любом случае текст размещается в границах фрейма. Программа автоматически формирует строки нужной длины.

Во время трансформации фрейма текст может вести себя по-разному. При искажении с использованием инструментов Selection и Direct Selection в большинстве случаев не меняется внешний вид символов и абзацев текста, но его размещение зависит от размера и формы фрейма. Однако случается так: необходимо, чтобы при изменении размеров текстовых фреймов менялись размеры и самих символов Например удобно воспользоваться этой возможностью при изменении полосы набора. Вы сверстали текст, разместили рисунки, публикация готова к печати, но в последний момент выяснилось, что полоса набора должна быть другого размера. При переверстке все тонкие настройки текста уничтожатся, а рисунки придется размещать заново. Этого вполне можно избежать, если применить инструменты и команды трансформации. При их использовании трансформируется как фрейм, так и сам текст. О трансформации различных объектов, в том числе фреймов, рассказывается в главах 9 и 13. Здесь упомянем о работе с текстовым фреймом с помощью инструмента Selection.

  • Перемещение. Для этого необходимо установить курсор в области фрейма и перетащить его. За курсором следует и фрейм вместе с текстом.
  • Масштабирование (рис. 9.4). Нужно подвести курсор к манипулятору и перетащить его к центру или от центра фрейма. Боковые манипуляторы позволяют масштабировать фрейм по одному измерению, угловые — сразу по двум. При нажатой клавише <Shift> масштабирование производится пропорционально по всем направлениям.
  • Отражение. Если, уменьшая размер фрейма, перетащить курсор до геометрического центра фрейма (уменьшив его тем самым до нуля) и продолжать перетаскивать курсор дальше, то фрейм превратится в свое отражение. Ось отражения проходит через противоположный манипулятор (рис. 9.5). Кроме формы фрейма, зеркально отображается и сам текст (ширина и высота символов не изменяется). Если при этом нажать клавишу <Shift>, то объект будет не отражен, а перемещен.

Рис. 9.3. Примеры фреймов

а [image] б

Рис. 9.4. Масштабирование

Рис. 9.5. Отражение


Избыточный текст и цепочки фреймов (Часть I)

Площадь фрейма может оказаться недостаточной для отображения всего текста, который в него помещен. В этом случае нижний индикатор помечается красным крестиком — это означает, что за пределами фрейма есть текст. Для того чтобы разместить его в публикации, можно увеличить размер фрейма (рис. 9.6). Когда текст размещен полностью в одном фрейме, индикаторы становятся пустыми.

а [image] б

Рис. 9.6. Размещение текста масштабирования

Если речь идет не о нескольких строках, а о нескольких страницах не размещенного текста, этот совет окажется несостоятельным. Текст может располагаться в нескольких текстовых фреймах, связанных в единую систему — цепочку. Чтобы разместить избыточный текст из фрейма в цепочке, следует с помощью инструмента Selection выделить фрейм и щелкнуть на индикаторе избыточного текста. Курсор принимает вид страницы с текстом (курсор размещения) (рис. 9.7).

Избыточный текст готов к размещению. Провести эту операцию можно разными путями. Приведем лишь некоторые из них:

  • Создать новый фрейм, протащив курсор размещения в любом месте публикации (рис. 9.8). Избыточный текст заполняет созданный фрейм.

Рис. 9.7. Избыточный текст в режиме размещения

Рис. 9.8. Размещение избыточного текста путем создания нового фрейма

  • Поместить курсор в область существующего пустого текстового фрейма. Курсор принимает вид звеньев цепи. При щелчке на текстовом фрейме избыточный текст располагается в нем (рис. 9.9).
  • Поместить курсор в область графического фрейма или графического объекта. Курсор принимает вид страницы текста, взятой в скобки. После щелчка объект преобразуется в текстовый фрейм и избыточный текст заполняет его (рис. 9.10). Если фрейм или объект имел заливку или обводку, то они сохраняются.
  • Установить курсор на пустом месте страницы. После щелчка кнопкой мыши будет создан новый фрейм, связанный с предыдущим. Ширина этого фрейма будет совпадать с шириной полосы набора (или колонки, если страница разбита на колонки), верхний край фрейма — находиться в точке щелчка, а нижний — совпадать с нижним полем страницы (рис. 9.11). Если щелчок произвести на рабочем столе, то размеры созданного фрейма совпадут с размерами полосы набора, а его верхний левый угол будет находиться на месте щелчка. Чтобы текст был аккуратно размещен в границах полей, нужно щелкнуть мышью на границе верхнего поля страницы.

Рис. 9.9. Избыточный текст помещен в готовый текстовый фрейм

а

б

Рис. 9.10. Избыточный текст помещен в графический объект


Избыточный текст и цепочки фреймов (Часть II)

Рис. 9.11. Размещение избыточного текста щелчком на странице

Если текст не поместился и в следующем фрейме, то в нем появится индикатор избыточного текста. Вы можете снова щелкнуть на нем и разместить еще часть текста. Таким образом можно создавать цепочки текстовых фреймов (рис. 9.12). Например, если вы создаете журнал, то щелкая на верхней границе поля каждой страницы вы в конце концов разместите материал целиком.

InDesign показывает связи фреймов в цепочке. Если фрейм входит в цепочку первым, то его начальный (левый) индикатор пуст, а в конечном (правом) находится маленькая стрелка. У фрейма, расположенного не первым и не последним в цепочке, маленькие стрелки имеются в обоих индикаторах. У последнего фрейма цепочки есть стрелка в начальном (левом) индикаторе, а конечный (правый) индикатор пустой. Если вы выделите фрейм, то сразу увидите, входит ли он в цепочку.

Этого, однако, бывает недостаточно: ведь вы не видите, к какой цепочке относится текст. Чтобы увидеть, каким образом связаны фреймы, воспользуйтесь командой-переключателем Show Text Threads/Hide Text Threads.

В первом положении при выделении любого фрейма, входящего в цепочку, отображаются связи между всеми фреймами цепочки. Они показаны толстыми линиями, цвет которых такой же, как у границ фреймов. Каждая линия выходит из начального манипулятора и присоединяется к конечному (рис. 9.13). Связи изображаются между фреймами, находящимися как на одной странице, так и на разных.

Рис. 9.12. Цепочка фреймов. Выделенные фреймы имеют индикаторы

Рис. 9.13. Связи в цепочке

Чтобы создавать цепочки, не обязательно иметь неразмещенный текст. Вы можете сделать цепочку и из пустых фреймов. Принцип тот же — щелчок на конечном манипуляторе одного фрейма (курсор принимает вид страницы текста), затем щелчок на фрейме, который будет следующим в цепочке (или его создание) и т. д.

Текст в изолированном текстовом фрейме или в цепочке связанных фреймов называется материалом (story). В публикации может быть один или несколько материалов. Например, в отдельных материалах обычно помещаются врезки, подрисуночные подписи, не связанные друг с другом статьи. Если вы верстаете книгу, то, скорее всего, у вас будут отдельные материалы для титула и оборота титула. Далее текст может представлять собой один материал, распределенный в связанных фреймах — по одному на каждой странице. Иногда в качестве отдельных материалов оформляют каждую главу. Если в книге есть сноски, то, скорее всего, они тоже будут размещены в отдельных материалах.

Для выделения в текстовом режиме границы фреймов не имеют значения. Так например, если выбрать команду Select All при наличии в материале точки вставки, то будет выделен текст всего текущего материала.


Свойства связанных фреймов

В связанных фреймах текст размещается подобно жидкости, заполняющей высокий сосуд. Текст наполняет сначала первый текстовый фрейм "под завязку", перетекает в следующий, и т. д. Все текстовые фреймы цепочки, кроме последнего, целиком заполнены текстом. Текст остается единым материалом. Следовательно, если изменить размер любого фрейма цепочки, кроме последнего, то материал перекомпоновывается. Это будет сделано со всеми фреймами, следующими за измененным.

Расположение фреймов не влияет на их связь

В газетах и журналах размещение связанных фреймов одного материала может быть весьма прихотливо. Текст может начинаться на третьей странице, потом прерываться и продолжаться на пятой. Однако в любом случае текст будет перетекать из одного связанного фрейма в другой, даже если первый фрейм цепочки расположен на пятой странице, а следующий — на третьей.

Приведем пример. Второй фрейм цепочки (рис. 9.14, о) был уменьшен (рис. 9.14, б). На первый фрейм это никак не повлияло. Поскольку второй фрейм уменьшился, текст материала в нем не поместился и "выдавился" в следующий фрейм. Там тоже появился лишний текст, который был перенесен в четвертый фрейм. В результате в четвертом фрейме стало слишком много материала. Сам текстовый фрейм не может расти при увеличении в нем объема текста. Поэтому не поместившийся материал уходит за границы текстового фрейма и становится избыточным. В другом случае (рис. 9.14, в} был увеличен третий фрейм цепочки. Текст из четвертого фрейма был втянут в третий фрейм.

Цепочка фреймов может быть изменена: укорочена, удлинена, из нее могут быть исключены или включены элементы:

  • Разрыв связи между фреймами. Щелкните на конечном индикаторе. Когда курсор перейдет в режим размещения, установите его в область фрейма, следующего за данным в цепочке. Курсор будет выглядеть, как разорванная цепь. После щелчка связь разорвется. Текстовый материал останется целиком во фреймах до точки разрыва (рис. 9.15).

Рис. 9.14. Изменение размеров фреймов в цепочке

а

б

в

Рис. 9.15. Разрыв связи между фреймами

  • Исключение фреймов из цепочки (рис. 9.16). Удалите их командой Clear или Cut. Текст при этом не удаляется, а перераспределяется между оставшимися фреймами. Если вы удалили один фрейм командой Cut, то после вклеивания в публикацию он содержит только тот текст, который в нем был на момент удаления. Склеенный фрейм не связан с исходной цепочкой. Если вы вырезали в буфер одновременно несколько фреймов из одной цепочки (пусть даже не связанных между собой), то после вклеивания в публикацию они окажутся связаны между собой, но независимы от исходной цепочки.

а

б

Рис. 9.16. Исключение фрейма

  • Присоединение фрейма к началу цепочки (рис. 9.17). Щелкните на начальном индикаторе первого фрейма цепочки. Курсор примет вид курсора размещения (страницы с текстом). Щелкните на изолированном фрейме. Текст перетечет в него, присоединенный фрейм станет первым в удлиненной цепочке. Так же можно присоединять цепочки.
  • Присоединение фрейма к концу цепочки. Щелкните на конечном манипуляторе последнего фрейма, курсором размещения щелкните на изолированном фрейме. Если в нем был избыточный текст, он перетечет в присоединенный фрейм.
  • Вставка фрейма (рис. 9.18). Щелкните на конечном манипуляторе того фрейма, к которому вы собираетесь присоединять фрейм, затем на начальном манипуляторе вставляемого фрейма. Таким образом можно присоединять только пустые фреймы.

а

б

в

Рис. 9.17. Присоединение фрейма к началу цепочки

а

б

Рис. 9.18. Вставка фрейма между двумя связанными фреймами

Зная о свойствах текста в цепочке фреймов, вы можете предположить, что будет, если разместить текст в такой цепочке. В любом случае текст будет перетекать по цепочке, пока не заполнит ее до конца. Возможны следующие варианты:

  • Поместить текст в изолированный фрейм, в котором уже есть текст, или в первый фрейм цепочки. В этом случае помещенный текст вставляется в начало имеющегося.
  • Поместить текст в первый фрейм пустой цепочки. Текст распространится по цепочке пока не заполнит цепочку целиком.
  • Поместить текст в средний или в последний фрейм пустой цепочки. Текст перетекает в данный фрейм. Этот фрейм исключается из цепочки, а оставшиеся ее элементы связываются между собой.

Невозможно поместить текст в один из средних или в последний фрейм цепочки, заполненной текстом.


Атрибуты фрейма и материала (Часть I)

Каждый фрейм, кроме размеров и положения на странице, характеризуется атрибутами, задаваемыми в диалоговом окне Frame Options (рис. 9.19) . Это окно вызывается одноименной командой из меню Object или из контекстного меню. Предварительно следует выбрать фрейм с помощью инструмента Selection. Регулируя атрибуты фрейма, можно делить его на произвольное число колонок и задавать отступ для текста.

Рис. 9.19. Диалоговое окно Text Frame Options

В области Columns задается размер и число колонок. До тех пор пока в поле Number установлено значение 1, вы можете задать ширину фрейма в поле Column width. После установки ширины колонок задайте их число в поле Number.

  • Флажок Fixed Column Width определяет режим расчета ширины колонок и поведение колонок при масштабировании фрейма. Если он снят, то колонки образуются делением исходного фрейма на необходимое количество частей. Впоследствии при масштабировании фрейма число колонок сохраняется неизменным, а их размер меняется в соответствии с размером фрейма (рис. 9.20). Если же флажок установлен, то каждая колонка делается равной исходному размеру фрейма, а при масштабировании фрейма установленная ширина колонок сохраняется — может измениться число колонок (рис. 9.21).

а [image] б

Рис. 9.20.Масштабирование: не фиксированная ширина колонок

  • В поле Gutter задается расстояние между колонками, в полиграфии называемое средник (рис. 9.22).

Рис. 9.21. Масштабирование: фиксированная ширина колонок

Рис. 9.21. Масштабирование: фиксированная ширина колонок


Атрибуты фрейма и материала (Часть II)

  • В области Inset Spacing задаются отступы, но не абзацные, а распространяющиеся на данный фрейм. В полях ввода Top, Left, Bottom и Right указывается отступ сверху, слева, снизу и справа от границ фрейма (рис. 9.23). Если фрейм имеет непрямоугольную форму, тогда эти атрибуты не доступны и задается только одно значение отступа — со всех сторон (рис. 9.24).

Рис. 9.22. Разные средники

Рис. 9.23. Отступы в прямоугольном фрейме могут быть разными с разных сторон

Рис. 9.24. Отступы в непрямоугольном фрейме

  • С помощью раскрывающегося списка Offset: группы First Baseline регулируется положение первой базовой линии абзаца. В положении Ascent наиболее высокий символ расположен ниже верхней границы на ширину оплечиков. Если выбрать значение Сар Height, то верхушки прописных букв будут касаться границы фрейма. Последнее положение Leading устанавливает базовую линию первой строки на расстоянии интерлиньяжа от границы фрейма.
  • Флажок Ignore Text Wrap в установленном состоянии заставляет текст при размещении игнорировать обтекание объектов. Об обтекании объектов текстом рассказывается в главе 13.

Атрибут фрейма действует на текст, который в данный момент в нем находится. Если поместить во фрейм какой-нибудь другой текст, заданные атрибуты будут применены к нему. Однако собственный атрибут имеет и сам текстовый материал. Это оптический отступ. Поскольку знаки и буквы текста имеют разную конфигурацию, то границы колонок реального текста выглядят неровными. "Вмятины" образуются в местах переносов, кавычек и других знаков препинания, а также символов A, W и других — т. е. там, где символ занимает только небольшую часть строки по вертикали. Для устранения этого дефекта некоторые символы в тексте делают висячими, т. е. выдвигают за край колонки. InDesign способен автоматически отслеживать необходимость вывешивания знаков пунктуации и символов. В результате края колонки текста становятся более ровными. Для его задания используется палитра Story (рис. 9.25). Она открывается одноименной командой меню Type. В этой палитре задается режим оптического отступа (флажком Optical Margin).

В поле ввода задается кегль шрифта, относительно которого требуется рассчитать отступ. Для достижения лучшего результата вводите в это поле кегль, которым набрана большая часть вашего материала. Результат применения оптического отступа показан на рис. 9.26.

Рис. 9.25. Палитра Story

Рис. 9.26. Оптический отступ


Режимы размещения

Объем расположенного в связанных фреймах текста может быть очень большим (например, при верстке книги). При помещении большого объема текста довольно утомительно каждый раз после размещения текста в очередном фрейме снова щелкать на индикаторе и создавать новый фрейм. Этот процесс часто можно автоматизировать. InDesign предлагает три режима размещения текста — ручной, автоматический и полуавтоматический.

  • Режим ручного размещения включен по умолчанию. Если текст находится в процессе размещения, курсор имеет вид страницы текста. Этот режим уже знаком вам. Он предназначен для однократного размещения текста. Каждый раз после размещения текста в очередном фрейме нужно снова переводить избыточный текст в режим размещения щелчком на соответствующем индикаторе. За один прием текст размещается в одной колонке, или на одной странице. Кроме того, при этом режиме размещения есть возможность размещать текст в заказных текстовых фреймах, которые могут иметь любой размер и располагаться на странице произвольным образом.
  • Режим автозаполнения. Если в режиме размещения текста вы нажмете клавишу <Shift>, то пока она нажата активизируется режим автозаполнения. Вид курсора изменится: он превратится в волнистую кривую со стрелкой. Создайте первый фрейм — и вы увидите маленькое чудо.

Программа автоматически размещает текст, создавая по необходимости фреймы в границах полей (или колонок). Если в процессе автоматического размещения текста программы InDesign достигнет последней страницы публикации, он добавит в нее и новые страницы, чтобы разместить текстовый материал до конца. В автоматическом режиме размещается сразу весь материал.

Когда использовать автозаполнение

Автоматический режим удобен для начального размещения большого материала, занимающего много страниц: например, главы книги или технического отчета. В случае сложного размещения текста на странице (например, в иллюстрированном журнале) такой режим неприменим.
  • Режим полуавтоматического размещения активизируется, если при размещении текста вы держите нажатой клавишу <Alt>. Курсор имеет вид волнистого пунктира. В этом режиме текст размещается в пределах одного текстового фрейма, но, в отличие от режима ручного размещения, после размещения очередной порции текста автоматически активизируется режим размещения (вам не нужно снова щелкать на индикаторе избыточного текста). В полуавтоматическом режиме страницы в публикацию не добавляются.

Во всех режимах после щелчка в пределах страницы или колонки текст автоматически размещается до ее нижнего края по ширине полосы или колонки.

Полуавтоматический режим удобен для размещения текста в заранее определенных текстовых фреймах, расположенных на странице произвольным образом. Он незаменим для ускоренного размещения текста в сложных макетах. Мы рекомендуем использовать режим полуавтоматического размещения вместо ручного везде, где это возможно, чтобы сэкономить время.


О верстке с применением фреймов

Разбивая материал на маленькие текстовые фреймы, можно верстать тексты любой сложности, но пользоваться разбиением текста на фреймы нужно лишь в случае крайней необходимости, поскольку образовавшаяся "лапша" будет неустойчивой к любым изменениям. При малейшем изменении размеров любого из фреймов, или просто вводе еще одного символа в текст, вся верстка "утечет" из нужных фреймов. Кроме того, мелкие фреймы трудно устанавливать точно, это приведет к неряшливому виду текста — разному интерлиньяжу, неровной выключке по вертикали, кривым колонкам. Страшно подумать, что будет с таким текстом при изменении интерлиньяжа или кегля набора. В идеале на странице простой верстки должно быть фреймов столько же, сколько вертикальных колонок, т. е. в случае однополосной верстки — один. Необходимые эффекты достигаются введением вложенной графики и установок режима обтекания графики текстом. В отдельные фреймы при однополосной верстке помешаются только сноски, колонцифры, колонтитулы и врезки (если таковые имеются).

Нецелесообразно размещать центрированные заголовки в маленьких фреймах, установленных вручную по центру страницы. Вместо этого задайте ширину фрейма с текстом заголовка равной ширине страницы или колонки, а затем установите выключку текста по центру. Если заголовок находится на той же странице, что и последующий текст, то не создавайте дополнительного фрейма вовсе — вместо этого наберите заголовок в основном текстовом фрейме и задайте его положение отбивками регулированием положения верхней границы фрейма. Тем самым вы переложите размещение заголовка на программу InDesign — скорее всего, она справится с нею успешнее, чем ваш глазомер.


Форматы текстовых файлов

Любая информация, находящаяся в компьютере, существует внутри него исключительно в двоичном коде, поэтому ее необходимо кодировать, т. е. в случае текста — превратить сами символы, их начертание, расположение на страницах и т. д. в единицы и нули, причем сделать это определенным образом. Так происходит ввод данных в компьютер. Затем, когда вы просматриваете полученный файл, выполняется обратная процедура — компьютер, в соответствии с тем же кодом, превращает двоичный файл в текст, картинку, или базу данных и выводит их на монитор или принтер.


Понятие формата

Формат — это способ кодирования информации. От формата файла зависит, какую информацию можно хранить в этом файле, и каким образом будет осуществляться чтение и запись. Судить о формате файла данных можно по его расширению. Все файлы одного формата имеют одинаковое расширение имени.

Каждый разработчик программного обеспечения создает собственный способ кодирования — формат файлов данных, который лучше всего отвечает задачам, выполняемым данной программой. Например, формат графических файлов TIFF позволяет хранить информацию о масках, цветовых каналах, растрировании, цветоделении и треппинге, но внутри него не могут располагаться данные о шрифтах документа и размещении текста. Файлы, создаваемые в текстовом редакторе, не могут содержать данные о цветоделении, зато в них имеется информация о начертании символов, использованной гарнитуре, формате и числе страниц, размещении текста и графики и пр. Форматов файлов много, поскольку они предназначены для использования в конкретной программе и поддерживают именно ее функции.

Однако в процессе подготовки публикации, скорее всего, потребуется открыть или импортировать файл в программы, иногда даже работающие на разных платформах. Для импорта и экспорта файлов необходимы фильтры — специальные программы-переводчики, которые преобразуют информацию из одного формата в другой. Если у программы есть фильтр импорта для данного формата, значит файлы могут быть импортированы.


Фильтры импорта

Фильтр импорта представляет собой программу, осуществляющую перевод формата файла приложения во внутреннее представление InDesign, по возможности сохраняя форматирование, выполненное в исходном процессоре. InDesign предназначен для обработки файлов разных форматов, поэтому он имеет довольно много фильтров импорта, которые выбираются автоматически в соответствии с расширением имени файла.

Установленные фильтры

Выбор команды About InDesign меню Help при нажатой клавише <Ctrl> откроет окно, содержащее список дополнений и фильтров, установленных в программе.


Форматы, набор и верстка

Самые распространенные стандартные форматы для текстов — ТХТ (текстовый формат) и DOC (формат Microsoft Word). Если вы предпочитаете какой-нибудь экзотический текстовый процессор, сохраняющий файлы в формате, для которого нет фильтра импорта в программе верстки, убедитесь, что он имеет фильтр экспорта в стандартный формат. Только в этом случае вы сможете импортировать набранный текст в программу верстки. Следует отметить, что каждый формат имеет атрибуты, которые в нем сохраняются. Например, в формате ТХТ могут сохраняться только коды символов текста и концы абзацев. Если вы экспортируете текст формата Word в текстовый формат, то атрибуты форматирования (шрифт, начертание, кегль, стили и пр.) не сохранятся вместе с текстовым файлом, и их придется задавать заново. Перед набором текста следует точно договориться, в каком формате следует предоставлять набор, и проверить качество фильтров импорта InDesign для этого формата. Также важно условиться о разделении труда между верстальщиком и наборщиком — какое форматирование осуществляет каждый из них. В принципе, в современном текстовом редакторе можно задавать шрифт, начертание, стили, цвет текста. Эта работа обычно выполняется на этапе набора текста. А вот отбивки, отступы, кернинг, трекинг, настройку выключки и другие тонкие работы следует выполнять уже после импорта текста в систему верстки, поскольку текстовый процессор сделает всю эту работу с неприемлемым для полиграфии качеством. Что касается сугубо полиграфических символов кавычки-елочки, эллипсис (многоточие) и пр., то здесь можно поступать произвольно: если текстовый процессор позволяет вводить эти символы быстро (например, с помощью автозамены при вводе), то лучше делать это на стадии набора. Если ввод затруднен (например, каждый раз нужно набирать код символа), то лучше оставить эту работу до стадии верстки.


Типы текстовых форматов

Собственно текстовые файлы, имеющие расширение ТХТ, хранят только информацию о символах текста, зашифрованную с помощью кодовых таблиц символов. Эти таблицы (их несколько) являются стандартными и их применение определено международными соглашениями. В таблице кодировки каждому символу латинского алфавита присвоен уникальный двоичный код. Для символов национальных алфавитов в странах, где они используются (в частности, для кириллицы), применяются расширенные кодовые страницы.

К наиболее распространенным текстовым форматам относятся ASCII (American Standart Code for Information Interchange), ANSI (American National Standart Insitiute) и UNICODE. Они различаются таблицей кодировки символов. Формат ASCII — базовый уровень представления текстовой информации, он един для всех программных средств, работающих с текстами. В тексте ASCII нет полужирного и курсивного начертания, отсутствует система гарнитур и кеглей. В таком документе нет отступов, и, как правило, каждая строка представляет собой отдельный абзац. Зато у файлов в текстовом формате есть одно очень важное достоинство — они стандартные.

К текстовым в настоящее время относят и файлы, подготовленные в одном из текстовых процессоров и сохраненные в его формате. В состав этих файлов входит не только информация об их содержании (т. е. коды символов), но и о способе представления этих символов. В файлах таких форматов хранятся данные о шрифтах, кеглях, начертаниях, разбивке на абзацы и страницы, размере полосы набора, иногда о стилях абзацев и символов, т. е. обо всех элементах форматирования данного текста.

Файлы с форматированием создаются в текстовых процессорах различного класса. В зависимости от возможностей текстового процессора, отличается и объем информации о форматировании, хранящейся вместе с файлом. Простые процессоры содержат информацию о шрифтах, начертании, кегле, разбиении на абзацы. Развитые текстовые процессоры могут хранить данные о стилях абзацев и символов, отступы и отбивки, таблицы, вложенную графику и пр. К наиболее распространенным текстовым форматам относятся DOC и RTF (Rich Text Format — стандартный формат хранения текстовой информации), созданный для обмена данными между текстовыми процессорами и программами верстки.

Еще больше сведений о форматировании содержится в файлах программ верстки — кроме атрибутов символов, абзацев, в них имеются данные о связанных и внедренных изображениях, о размещении, взаимодействии и свойствах текстовых фреймов, о параметрах цветоделения и пр. К форматам систем верстки относятся, например, Р65, РМ6 — файлы программы PageMaker, QXD — публикации QuarkXpress, VP — документы, подготовленные в программе Ventura Publishing.

Особое место занимают текстовые файлы со стилевой разметкой — Tagged Format — при сохранении в нем создается стилевая разметка — в нужных местах проставляются метки (тэги), указывающие на характер форматирования. Полученный документ является обычным ASCII-файлом. При импорте такого файла в программу, поддерживающую команды стилевой разметки, будет автоматически осуществляться форматирование по разметке.


Установка и обновление фильтров

При инсталляции InDesign все фильтры импорта, входящие в комплект, устанавливаются без запросов. Они находятся по адресу \Plug-ins\Filters главной папки программы.

При обновлении версий программных продуктов необходимо обновлять и их фильтры импорта в InDesign, в противном случае он "не поймет" формата файла, сделанного в приложении, которое выпущено позднее, чем текущая версия InDesign. Для того чтобы быть в курсе последних новостей, обращайтесь к услугам Internet и почаще заходите на сайт фирмы Adobe (его адрес www.adobe.com). Если вы получаете бесплатный фильтр с сайта фирмы Adobe, он устанавливается автоматически. Приобрести фильтры импорта можно и у сторонних производителей. Приобретенный фильтр устанавливается вручную в тот же каталог, где расположены остальные фильтры. Чтобы установленный фильтр заработал, перезагрузите InDesign.


Импорт текста

Текст можно поместить в InDesign двумя способами — через буфер обмена и командой Place:

  • -При помещении текста через буфер обмена из текстовых редакторов программа импортирует только текст, игнорируя все атрибуты форматирования. Этот процесс производится стандартным образом — текст копируется командой Copy в редакторе, а затем вклеивается в InDesign командой Place.
  • При перемещении текста из одного документа, открытого в InDesign, в другой сохраняются все атрибуты форматирования. Вы можете копировать и вклеивать как выделенные символы, так и целые фреймы с текстом.
  • Импорт в диалоговом окне Place меню File производится с помощью соответствующего фильтра импорта. Сохранение и преобразование атрибутов в данном случае зависит от особенностей формата и настроек фильтра.


Устройство диалогового окна Place

Для импорта с помощью фильтра необходимо открыть окно Place (рис. 9.27) и выбрать папку, в которой находится требуемый файл. В раскрывающемся списке Files of type перечислены форматы, которые могут быть импортированы в In Design. Если установлено значение Importable Files, то в поле просмотра показаны все файлы, которые могут быть импортированы. Если выбрать конкретный формат, то в поле просмотра видны лишь файлы этого формата.

Рис. 9.27. Диалоговое окно Place

В нижней части окна расположены флажки преобразования формата. Они позволяют выполнить некоторые элементы форматирования в процессе импорта.

При установке флажка Retain Format можно сохранить форматирование текста, выполненное в стороннем приложении. Если сбросить этот флажок, текст будет импортирован вообще без форматирования (как текстовый файл).

Установка флажка Convert Quotes ведет к автоматической замене прямых кавычек полиграфическими, а двойных минусов — полиграфическими тире. Такая первичная обработка текста очень удобна при импорте ASCII-файлов.

При снятом флажке Show Import Options фильтр импорта работает по умолчанию. Если флажок установить, то при нажатии кнопки Open, или двойном щелчке на имени импортируемого файла откроется окно дополнительных

возможностей фильтра импорта данного формата. К такому же результату приводит открытие импортируемого файла при нажатой клавише <Shift>.


Настройки импорта

В процессе импорта текста есть свои тонкости. В то время как основные символьные атрибуты (шрифт, начертание, кегль) трактуются совершенно однозначно в текстовом процессоре и в программе верстки, то с атрибутами тонкой настройки дело обстоит сложнее. Например, настройка выключки, интервалов, кернинга в Microsoft Word производится не так, как в InDesign. Кроме того, в текстовых процессорах могут встретиться элементы, которым нет аналогов в InDesign (например, таблицы). Поэтому практически каждый фильтр импорта имеет настройки, позволяющие регулировать процесс преобразования документа из одного формата в другой. Они определяются в окнах, предлагаемых программой при открытии файлов в режиме Show Import Options. Окно дополнительных возможностей импорта, разумеется, будет разным для каждого формата.

Установки, сделанные в диалоговом окне настройки фильтра, сохраняются до конца текущего сеанса работы с программой InDesign. Это означает, что после следующего запуска InDesign вам придется заново задать режимы импортирования.


Что импортируем?

Вам, вероятно, интересно, какие атрибуты вообще могут быть импортированы вместе с документом, в InDesign и каким образом это будет проделано? Для удовлетворения любопытства, отнюдь не праздного, разработчики включили в комплект InDesign два текстовых файла, посвященных импортируемым атрибутам. Они находятся в главной папке InDesign и называются Filters ReadMe.DOC (основной файл, посвященный фильтрам) и ReadMe.DOC (дополнения к документации). В документе Filters ReadMe.DOC перечислены все атрибуты, импортируемые в InDesign из документов в следующих форматах:

  • Microsoft Word 97—98
  • Microsoft Excel 4.0—7.0
  • Rich Text Format (RTF)
  • Corel WordPerfect 6.0-8.0

Также в этих документах приведено подробное описание того, каким образом InDesign преобразует атрибуты, если им нет точных соответствий. Относительно весьма распространенного формата Microsoft Word 7.0 (и ниже) такой подробной информации нет. В общем случае текст в этом формате импортируется вполне корректно, и вы можете пользоваться таблицей для Microsoft Word 97/98 (разумеется, функции, которых не было в ранних вереи их, импортироваться не может). Важное неприятное отличие - изжога не импортируются символьные стили.


Импорт текстовых файлов

Вообще говоря, файлы в текстовом формате очень неудобны для импорта поскольку при этом приходится предварительно форматировать текст (убирать лишние пробелы, возвраты кареток, заменять тире и кавычки, проставлятьется пользоваться только в том случае, когда иного выхода нет, например при отсутствии фильтра импорта InDesign для исходного приложения.

Диалоговое окно настройки фильтра импорта текстового файла (рис 9 28) открывается при импорте документа в формате ТХТ. С помощью этого фильтра, если его соответствующим образом настроить, можно выполнить массу операции контекстного поиска и замены (удаление символов возврата каретки, замена пробелов табуляторами и т. д.).

Рис. 9.28. Фильтр импорта текстового документа

В списке Character Set задается кодовая таблица документа. Наиболее распространенными являются ASCII, ANSI и UNICODE (о кодовых таблицах написано в главе 4).

В области Extra Carriage Returns задается режим удаления лишних признаков конца абзаца. В текстовых файлах таким символом оканчивается каждая строка документа. Флажок Remove at End of Every Line удаляет этот символ между строками, оставляя нетронутыми абзацы (абзац в текстовом файле обычно выделяют несколькими пробелами в его начале). При установке флажка Remove Between Paragraphs удаляются все лишние признаки конца абзаца, вставленные между абзацами текста в качестве отбивок.

При установке флажка Keep Tables, Lists and Indents as is производится с помощью табуляции форматирование таблиц и перечней, которые ему удается распознать.

Шрифт таблиц и колонок

Если текст в исходном приложении был набран моноширинной гарнитурой и в нем есть разбиение на колонки (текст в несколько колонок, таблицы), его необходимо отформатировать моноширинной гарнитурой (типа Courier) и в InDesign. Это позволяет сохранить структуру колонок в импортируемом тексте, которые в случае использования пропорциональных шрифтов будут изменены до неузнаваемости.

Для регулировки положения слов в строке текста часто встречаются смежные пробелы, поскольку этот формат не. предусматривает позиции табуляции. Число смежных пробелов, которые должны заменяться символом табуляции при импортировании текста задается в области Extra Spaces. По умолчанию оно равно 3.

Число пробелов, заменяемых табуляцией

Есть смысл просмотреть исходный файл и сделать число пробелов для замены табуляцией равным абзацному отступу, придуманному наборщиком. Скорее всего, это пять пробелов (стандартный абзацный отступ при печати на пишущей машинке).


Импорт файлов DOC и RTF

Формат DOC нуждается в подробном рассмотрении, поскольку текстовый процессор Microsoft Word широко распространен. Этот процессор был создан корпорацией Microsoft очень давно. С тех пор Word постоянно совершенствуется. Продукты Microsoft не имеют конкурентов по распространенности среди офисных программ во всем мире, и большинство текстов набирается именно в Word. InDesign располагает отдельными фильтрами для импорта документов в формате Microsoft Word 97/98 и более поздних и Microsoft Word 7.0 и более ранних.

Для настройки фильтра в процессе импорта файлов формата Microsoft Word 7.0 и более ранних предусмотрено диалоговое окно (рис. 9.29), позволяющее регулировать следующие режимы:

  • Import TOC entries from outline и Import index entry fields. В Word существуют поля и возможна генерация оглавления и индекса. В InDesign эта функция отсутствует. При установленных флажках импортируются оглавление и индекс, при условии, что они были собраны и размещены в текстовом редакторе. И оглавление, и индекс импортируются как обычный текст. Если флажок сброшен, соответственно индекс или оглавление не импортируются.
  • В группе переключателей Import condensed\expanded spacing as устанавливается режим замены увеличенных и уменьшенных пробелов, выполненных в Word в результате выключки текста по формату. Если выбран переключатель Set Width, то изменяется ширина символа пробела, если Kerning — регулируется кернинг, а если Tracking — задается трекинг.
  • Флажок Import page break before paragraph управляет импортом сведений о разбиении текста на страницы. В положении As page break before абзац располагается на новой странице, в положении As column break before — на новой колонке.
  • Флажок Import tables в установленном состоянии позволяет импортировать текст таблицы, разделяя ее ячейки символами табуляции. Если снять флажок, текст таблицы будет проигнорирован при импорте. Данный режим вполне пригоден для импорта однострочных таблиц. Если в ячейках таблицы размещается много текста, ее лучше не импортировать таким образом, поскольку весь текст каждой ячейки после импорта в InDesign располагается на одной строке. Такую таблицу гораздо эффективнее создать с помощью специальных программ или прямо в InDesign.

Рис. 9.29. Настройка фильтра импорта файла в формате Microsoft Word старых версий

Для новых версий Microsoft Word предусмотрен отдельный фильтр импорта. Тот же фильтр используется и при импорте файлов в формате RTF. Диалоговое окно настроек фильтра (рис. 9.30) предлагает выбрать специальные элементы текстового процессора, которые должны быть включены в публикацию InDesign, и способ конвертирования отдельных атрибутов.

Рис. 9.30. Настройки фильтра Microsoft Word 97/98 и RTF

В группе Include расположены флажки, управляющие включением различных частей текстового файла в публикацию. При установке флажка разрешается включать данный элемент в публикацию InDesign:

  • Table of Contents Text — включает в публикацию текст оглавления;
  • Index Text — включает текст предметного указателя, составленного в редакторе;
  • Hyperlink Formatting — сохраняет форматирование гиперссылок (сами гиперссылки превращаются в обычный текст;
  • Table Contents — импортирует содержимое таблиц, разделяя ячейки символами табуляции;
  • Footnotes/Endnotes — помещает в конце импортированного материала все ссылки — как затекстовые, так и сноски.

Ниже расположены переключатели конвертирования атрибутов:

  • Condensed/Expanded Spacing to уменьшает и увеличивает пробелы в положении Tracking с помощью трекинга, в положении Horizontal Scaling — путем горизонтального масштабирования символов пробела;
  • User Defined Page Breaks To определяет, каким образом будут переданы в InDesign определенные пользователем разрывы страниц. Положение Page Breaks соответствует разрыву страниц, положение Column Breaks — разрыву колонок, если установить переключатель в позицию No Break, то разрывы страниц игнорируются.


Импорт таблиц Excel

Если вам действительно необходимо создавать таблицы средствами InDesign (а это не идеальная программа для такой работы), табличные данные лучше

набирать в специальных программах (редакторах электронных таблиц, базах данных, таблицах текстовых процессоров), а затем импортировать их в InDesign.

Проверьте возможность верстки ваших таблиц

Если ваш проект содержит несколько таблиц, проведите подготовительную работу. Рассмотрите все таблицы и выберите самую сложную. Наберите ее и импортируйте в InDesign. Проверьте качество импорта. Затем отформатируйте таблицу. Затем сопоставьте готовый макет с остальными таблицами. На его основе определите средства автоматизации работы и подготовьте стили таблицы. Только после этого наберите, обработайте и импортируйте оставшийся материал.

Рис. 9.31. Диалоговые окна импорта файлов Excel

При подготовке таблиц вы можете использовать различные приложения:

текстовые процессоры, редакторы электронных таблиц. Наконец, данные таблицы могут располагаться в базах данных как универсальных, так и специальных. В результате импорта таблица преобразуется в текст. Столбцы ее разделяются табуляторами, а строки — признаками конца абзаца. Таким образом, для того чтобы упростить верстку таблицы, нужно заранее подготовить импортируемый материал. Это делается, во-первых, с помощью средств порождающего приложения. В нем можно разметить таблицу тэгами для сохранения локального форматирования (см. ниже в этой главе). Иногда нужно произвести преобразование формата данных в приложении. Затем приступайте к импорту. Если приложение имеет фильтр импорта в InDesign, то при импорте можно настроить установки фильтра в соответствии с требованиями, предъявляемыми к таблице.

Текстовые файлы, импорт которых рассмотрен раньше, очень часто используются для импорта таблиц. Текст таблицы может быть набран непосредственно в текстовом формате, или преобразован в него из приложений, которые не имеют фильтра импорта в InDesign. Кроме текстовых форматов, в InDesign можно непосредственно импортировать таблицы Microsoft Word. О фильтре импорта этих файлов рассказано выше.

Единственный редактор электронных таблиц, файлы которого можно сразу поместить в InDesign, — это Microsoft Excel. Программа имеет два фильтра импорта — для файлов версий Microsoft Excel 5.0/95 и Microsoft Excel 97/98 (рис. 9.31).

При импорте вы можете изменять следующие настройки:

  • View (для новых версий) или Personal View (для старых версий). В этом раскрывающемся списке содержатся определенные пользователем виды Excel. Вы можете импортировать один из них или игнорировать виды, выбрав пункт Ignore.
  • Sheet. Список рабочих листов файла Excel. Вы можете выбрать для импорта один из них.
  • Cell Range. В поле задают диапазон ячеек таблицы, которые следует импортировать. Для этого нужно ввести обозначения верхней левой и нижней правой ячеек области, разделив их двоеточием (например, А4:Н10). Если в документе есть именованные диапазоны ячеек, их тоже можно выбрать в этом же списке.
  • Apply Default Spreadsheet Style. Когда этот флажок установлен, импортированный текст сохраняет форматирование, заданное в электронной таблице. Параметры Cell Alignment и Decimal Places в этом случае не доступны. Абзацам, соответствующим импортированным записям, назначается стиль форматирования (в данном случае — с именем XLS). Впоследствии этим стилем можно пользоваться для изменения атрибутов форматирования импортированных данных.
  • Cell alignment override. Список режимов выравнивания ячеек. В большинстве случаев целесообразно импортировать поля таблицы с сохранением типа выравнивания, заданного в электронной таблице (вариант Spreadsheet's), но можно принудительно задать выравнивание всех импортированных полей по левому краю, по центру, по правому краю или по десятичной точке.
  • Decimal Places. При определении режима выравнивания Decimal (по десятичной точке) в этом поле задается количество отображаемых дробных разрядов (например, для денежных сумм это количество задается равным двум).
  • Truncate at Cell Boundary. Если установить этот флажок, InDesign при импорте отбрасывает все символы, выходящие за пределы границ ячейки исходной электронной таблицы. Это удобно, когда в поле примечаний расположены длинные тексты, из которых вам нужны только несколько первых слов.
  • Include Hyperlink Formatting (только для новых версий). Установка этого флажка включает режим импорта форматирования гиперссылок. Сами гиперссылки импортируются как текст.


Стилевая разметка

Тэги (стилевая разметка) — это специальные символы, вставляемые в набираемый текст, если набор выполняется в процессоре, не поддерживающем форматирования. В результате получается текстовый файл ASCII, но в нем в явном виде (непосредственно в теле текста) присутствуют команды форматирования. Потом при импорте InDesign выполняет команды стилевой разметки файла. В результате публикация форматируется. Зачем нужны тэги, если можно сразу задавать форматирование, например, в том же Word? Ответ прост — потому, что не у каждого наборщика есть Word и не каждый им умеет пользоваться. Если ваш наборщик не может разметить текст стилями в процессоре, для которого в InDesign есть подходящий фильтр импорта, попробуйте договориться с ним о включении тэгов в набираемый текст. Тогда вам не придется форматировать текст вручную. Тэги придуманы для того, чтобы вашу работу делал кто-то другой.

Для задания тэга разместите его в треугольных скобках перед текстом, который вы предполагаете набирать этим стилем. Действие тэга продолжается до следующего тэга. При наборе имени стиля имеет значение регистр символов.

InDesign, кроме файлов, размеченных собственными тэгами, корректно импортирует документы, имеющие стилевую разметку, сделанную в PageMaker и Quark Express.


Файлы систем верстки

Внимательно просмотрев список фильтров импорта, вы убедитесь в том, что в нем нет ни одного фильтра для импорта файлов систем верстки. Однако это не означает, что InDesign не может с ними работать, файлы в форматах PaegeMaker 6.5, QuarkExpress, и самого InDesign можно непосредственно открывать в программе командой Open. Если вы просмотрите список форматов открываемых файлов в окне Open, то сами убедитесь в этом.

Если необходимо импортировать фрагмент файла одной из перечисленных систем, то разумно открыть этот файл, а затем скопировать нужный фрагмент через буфер обмена. Форматирование при этом сохраняется.


Процесс импорта

Импортируемый командой Place текст не сразу помещается на страницы публикации. Непосредственно после импорта весь импортируемый материал хранится во временном контейнере. Курсор принимает вид страницы, т. е. вы находитесь в режиме размещения текста. Процесс размещения импортируемого текста ничем не отличается от размещения любого другого текста в InDesign. Для того чтобы отменить размещение импортированного текста, выберите другой инструмент. Даже если вы, не разместив ни одного фрейма с новым текстом, выбрали другой инструмент, и как будто прервали выполнение импорта, все равно остается возможность вернуться к размещению текста, выбрав несколько раз команду Undo.


Связывание файлов

При импортировании текстового файла в публикацию размещенный текст остается связанным с исходным файлом. Эта связь разрушается только принудительно. Казалось бы, хорошо, если размещенный текст можно автоматически приводить в соответствие с новой редакцией текстового файла. К сожалению, поскольку и в InDesign, и в текстовом процессоре можно осуществлять редактирование и форматирование текста, идея связывания текстовых файлов с материалами публикации не так хороша, как представляется на первый взгляд. В большинстве случаев обновление текстовых файлов оказывается исключительно опасным и совершенно бесполезным делом, т. к. после обновления теряются все настройки текста (например, стилевое оформление, кернинг), редактирование текста, выполненное в InDesign, и вся вложенная в материал графика.

Механизму связывания файлов, типам связей и соответствующим инструментам InDesign посвящена глава 11 этого диска. Обязательно ознакомьтесь с ней, а затем уничтожьте связи текста с исходными файлами.

Не оставляйте текстовые файлы связанными

Рекомендуем разрывать связи текстовых файлов с материалами публикации сразу после импорта, за исключением только некоторых случаев. К последним можно отнести работу в группе, когда несколько человек одновременно работают над сложной публикацией.


Экспорт текстовых файлов

Вы можете полностью или частично сохранить любой материал программы InDesign в файле, а затем использовать полученный файл в других программах. Вложенные изображения (за исключением PICT-изображений на платформе Macintosh) не экспортируются вместе с материалом.

Экспорт текстовых материалов производится только в режиме инструмента Type при установленной точке вставки внутри материала, подлежащего экспортированию (или выделенном фрагменте текста), или из окна редактора материалов. За один прием экспортировать можно один текстовый материал — тот, в котором находится точка вставки. Каждый материал экспортируется как отдельный документ. Если в тексте есть выделение, то экспортируются только выделенные символы. В меню File выберите команду Export. Откроется окно экспорта документа (рис. 9.32).

Рис. 9.32. Диалоговое окно экспорта документа

В раскрывающемся списке Save as type, расположенном в нижней части диалогового окна, определяется формат, в котором будет представлен экспортированный текст (размеченный стилевой разметкой, RTF, просто текст, HTML и пр.). Фильтры экспорта RTF и текста не имеют настроек. Об экспорте в HTML рассказывается в главе 19.

При экспорте файлов в формате Adobe InDesign Tagged text появляется окно настроек фильтра экспорта.

В этом окне выберите кодировку, в которой вы собираетесь экспортировать текстовый документ. Переключатель Tag Form определяет вид текстовых тэгов. В положении Verbose программа генерирует полные имена тэгов, в положении Abbreviated — сокращенные(табл. 9.1).

Таблица 9.1. Фрагменты текста, экспортированного с тэгами

В режиме Verbose | В режиме Abbreviated
<ParaStyle: Paragraph Stylel><cColor: Paper>Lorem ipsum <cColor:> dolor sit amet | <pstyle:Paragraph Stylel><cc: Paper>Lorem ipsum <cc:> dolor sit amet


Резюме

В этой главе рассмотрены свойства текстовых фреймов и фильтры импорта текстовых файлов.

  • Текст в программе располагается только во фреймах. Фрейм является контейнером для текста. Его можно трансформировать как обычный объект.
  • Если текст не помещается во фрейме, он не отображается на экране и называется избыточным.
  • Фреймы можно соединять в цепочки, и текст будет перетекать между ними.
  • Каждый фрейм имеет атрибуты — число собственных колонок и отступ.
  • Текст в отдельном фрейме или в цепочке связанных фреймов образует материал.
  • Материалу можно задать оптический отступ, чтобы его боковые границы выглядели более ровными.
  • При помещении текста в документ он размещается в автоматическом, полуавтоматическом и ручном режимах.
  • Существует множество форматов файлов данных. Разные приложения сохраняют данные в различных форматах.
  • Для того чтобы открывать и импортировать файлы разных форматов, в программах предусмотрены фильтры импорта.
  • InDesign располагает фильтрами импорта для текстовых файлов в различных кодировках, файлов Microsoft Word и Excel.
  • При импорте в In Design могут быть помещены различные атрибуты текста. Таблицы и поля, в том числе гиперссылки, импортируются как обычный текст. Настройки фильтра импорта производятся в социальных диалоговых окнах.
  • InDesign поддерживает обработку тэгов стилей PageMaker и QuarkXpress. Файлы этих программ, а также собственные файлы InDesign не импортируются — вместо этого их можно просто открыть в InDesign.

Приведенные в этой главе сведения об импорте текстовых файлов будут использоваться и обогащаться во время обсуждения вопросов верстки публикации. При импорте немаловажную роль играет механизм стилей абзацев, поэтому, возможно, вам придется не раз обратиться к соответствующей главе данной книги.


Введение

О чем этот диск

Если вы держите в руках этот диск, то, очевидно, вы либо уже занимаетесь, либо планируете заняться версткой. Приобретя программу InDesign, вы сделали верный выбор. Adobe Systems Inc. - лидер в мире издательского программного обеспечения. Трудно представить себе издательство, в котором не использовались бы продукты Adobe: Photoshop, InDesign, PageMaker, Illustrator, Streamline, TypeManager и др. Наконец, именно Adobe был создан первый интерпретатор языка описания страниц. PostScript, который находится вне конкуренции в компьютерном издательском деле. С помощью PostScript описываются используемые в издательском деле шрифты "Type 1". В любом хорошем лазерном принтере содержится (или может быть установлен дополнительно) интерпретатор PostScript. Для обмена файлами между издательскими приложениями также используются форматы, основанные на PostScript: Al (Adobe Illustrator), EPS (Encapsulated PostScript). Программы, созданные Adobe, работают и на PC, и на Macintosh, Sun, Silicon Graphics и др.

Выбрав InDesign в качестве программы верстки, вы фактически сделали выбор в пользу продуктов Adobe, которые особенно успешно работают вместе и обеспечивают переносимость данных между программами подготовки векторной (Adobe Illustrator, Adobe Streamline), растровой (Adobe Photoshop) графики и издательской системой (InDesign). Adobe Acrobat и Adobe GoLive открывают для вас мир электронных публикаций самого высокого профессионального уровня. Технология PostScript, применяемая во всех программах издательского пакета Adobe, a Adobe Acrobat и Adobe PressReady обеспечивает столь же высокий уровень подготовки и вывода макетов для полиграфического тиражирования. Создатели этих программ позаботились о совместимости форматов файлов и унификации интерфейса, не говоря уже о широких возможностях каждой из них в отдельности.

Важная особенность этой книги в том, что мы попытались привести в ней не только исчерпывающее описание программы, но также изложить теоретические и практические основы работы настольных издательских систем и предпечатной подготовки оригинал-макета. Вы узнаете о процессах цветоделения, растрирования, треппинга, особенностях воспроизведения цветов и полутонов в типографском процессе и многом другом, чего нет в прилагаемом к программе руководстве. Также мы попытались отразить в этом издании наш собственный и чужой опыт создания, дизайна и предпечатной подготовки оригинал-макетов, который позволит вам избежать многочисленных ошибок дизайна и верстки. Мы приводим также многочисленные оригинальные приемы и "маленькие хитрости" верстки, которые сэкономят вам часы поиска способа создания того или иного эффекта, или специфической организации макета.


Зачем нужна издательская система?

Зачем нужна издательская система? Если вы до сих пор не работали с издательскими системами, то такой вопрос вполне закономерен. Современные текстовые редакторы обладают весьма широкими возможностями и позволяют управлять такими элементами верстки, какие еще в недавнем прошлом были прерогативой издательских систем. Тем не менее, если речь идет именно об издательстве, то для получения высококачественных макетов не обойтись без системы верстки. В табл. В.1. приведено сравнение возможностей программ, входящих в число наиболее популярных: издательской системы InDesign и текстового процессора Microsoft Word. Несмотря на общую тенденцию расширения возможностей текстовых редакторов (например, поддержка стилей абзацев, шаблонов, работы с графикой, кернинга и трекинга) и заимствования издательскими системами некоторых удачных находок современных текстовых редакторов (макроопределения и макроязыки, создание электронных публикаций и др.), слияние как таковое не происходит. Данное обстоятельство обусловлено различной направленностью этих программ. Издатеьские системы ориентированы на типографское воспроизведение создаваемых документов. Они содержат многие "лишние" для текстовых процессоров функции: системы управления цветом, тонкие настройки характеристик шрифта (точный, заказной и ручной кернинг и трекинг), треппинг, высокую точность расположения элементов и др. Но без этих функций не обойтись при создании полиграфического продукта.

Таблица В.1. Сравнение функции Adobe InDesign и Microsoft Word

Функция | Adobe InDesign | Microsoft Word 7.0
Ввод текста | Ввод в режиме макета. Обычно для ввода текста не используется | Мощный редактор с возможностью работы в режиме макета и отображением
Проверка орфографии | Есть | Есть
Проверка грамматики | Нет | Есть
Кернинг | Плавная настройка кернин га для фрагмента текста и ручной кернинг для отдельных символов, оптический кернинг | Автоматический кернинг
Трекинг | Плавная настройка трекинга | Нет
Межсловные интервалы | Настройка максимального, минимального и желаемого значений | Нет
Межсимвольные интервалы | Настройка максимального, минимального и желаемого значений | Три градации интервалов или жесткое задание значения
Выключка | Тонкая настройка выключки за счет как межсловных, так и межсимвольных интервалов | Грубая автоматическая выключка за счет межсловных интервалов
Контроль жидких строк | Есть | Нет
Интерлиньяж | Есть | Есть
Стили символов | Есть | Есть
Стили абзацев | Есть | Есть
Абзацные отступы | Есть | Есть
Табуляции | Есть | Есть
Линейки | Есть | Есть
Монтажный стол | Есть | Нет
Свободное размещение текстовых и графических блоков | Есть | Нет
Колонки | Есть | Есть
Наклон, поворот,отражение текстовых блоков | Есть | Нет
Таблицы | Нет (существует в виде подключаемого модуля) | Есть, поддерживается любое количество страниц
Встроенные инструменты рисования | Есть | Есть
Определение цветов по различным цветовым моделям | Есть | Нет
Импорт графики | Есть | Есть
Связывание импортированной графики | Есть | Есть
Внедрение (OLE) графики | Нет | Есть
Управление цветом | Есть | Нет
Треппинг | Есть | Нет
Задание линиатуры и углов растрирования | Есть Есть | Нет Нет
Поворот, искажение, отражение импортированной графики | Есть | Нет
Обтравка растровых изображений | Есть | Нет
Обтекание графики текстом | Есть, граница текста может иметь произвольную форму | Есть, граница текста может иметь только прямоугольную форму
Свободно размещаемая графика | Есть | Есть
Вложенная (в текст) графика | Есть | Есть
Наложение изображений, текста | Есть | Нет
Фреймы | Есть, возможно связывание текста внутри фреймов | Есть, связывание текста отсутствует
Шаблоны | Есть | Есть
Шаблон-страницы | Есть | Есть
Направляющие и модульная сетка | Есть | Нет
Слои | Есть | Нет
Колонцифры и колонтитулы | Есть | Нет
Сноски | Нет | Есть
Оглавление, предметные указатели | Нет (существуют в виде подключаемых модулей) | Есть
Гипертекст (в т. ч. HTML) | Есть | Есть
Макроязык | Есть | Есть

Нельзя не упомянуть и об отличии, которое бросается в глаза. Издательские системы могут работать с текстовыми и графическими блоками, в то время как текстовые процессоры позволяют создать на странице только один текстовый блок, хотя и состоящий из произвольного числа колонок. Эта возможность издательских систем позволяет с абсолютной свободой размещать текстовые и графические материалы на страницах. Вы не чувствуете себя скованным ограничениями инструмента, а следуете только своей дизайнерской идее.

Речь идет не о сравнении "что лучше?" - издательская система или текстовый процессор, а о том, что более соответствует вашим задачам. Мы советуем обратиться к издательской системе, если ваша задача - выпуск типографского продукта, и к текстовому процессору, если вам необходимо создавать письма, бланки и любые документы, не предназначенные для полиграфии.

Но даже если вам необходима издательская система, не спешите деинсталлировать привычный текстовый процессор. Он пригодится не только как "рабочая лошадка" для создания обыкновенных документов, но и для создания текстового материала для верстки. Дело в том, что издательская система не предназначена для набора больших объемов текста. Издательская система предназначена для "сборки" макета из текстовых и графических блоков. Предполагается, что блоки - набранный текст, фотографии, рисунки - создаются в отдельных приложениях, которые имеют специальные функции их создания и обработки. Если вы выбрали продукты Adobe, то это Adobe Photoshop и Adobe Illustrator, о которых уже говорилось выше, и конечно, текстовый редактор.


Знания, необходимые для освоения материалов этой книги

Мы предполагаем, что читатель этой книги знает графический интерфейс используемой операционной системы. Предполагается, что эта операционная система - Microsoft Windows 95/98, Microsoft Windows NT 4.0 или более поздние их версии. Пользователи Macintosh тоже могут изучать InDesign по этой книге, хотя горячие клавиши и некоторые функции, связанные с системами управления цветом, шрифтами, устройствами вывода, имеют на Macintosh свои особенности.

Также предполагается, что читатель умеет работать в каком-либо текстовом редакторе, например, Microsoft Word. Если это так, то вам уже знакомь! многие возможности обработки текста и, возможно, графики. Эти знания значительно облегчат освоение приводимого материала.

Хотя данную книгу можно использовать и для начального освоения InDesign, лучше в этих целях приобрести специальное руководство для начинающих, построенное по принципу системы уроков. Тем не менее, действительно исчерпывающее описание программы вам все равно понадобится.


InDesign-издательская ОС

В стратегической программе Adobe она призвана заменить морально устаревший PageMaker, модернизация которого перестала оправдывать затраты. Кроме того, InDesign призван стать ядром издательской платформы Adobe, включающей еще Illustrator, Photoshop, Acrobat. Для этого было необходимо создать программу совершенно нового, современного уровня, способную интегрировать новые технологии, появившиеся в последние годы.


Архитектура InDesign

Стратегия программирования претерпела в последнее время колоссальные изменения. Объектно-ориентированный подход стал основой гибкой и расширяемой архитектуры. InDesign - первая издательская система, использующая все преимущества новых технологий программирования и организации взаимодействия программных модулей.

InDesign построен на основе легко заменяемых, обновляемых и дополняемых программных модулей, реализующих его отдельные функции. Идея модульности не нова в среде разработчиков программного обеспечения, включая Adobe. Например, Adobe Photoshop имеет собственный интерфейс подключаемых модулей начиная с версии 2.5. Для того чтобы дополнить программу какими-либо новыми функциями, не нужно изменять ее код - достаточно подключить к ней новый модуль. Модули расширения могут создавать не только разработчики программы, но и любые третьи фирмы. Успех технологии подключаемых модулей убедительно демонстрируется программой Photoshop, для которой существует более полутора сотен модулей, выполняющих разнообразные специализированные задачи.

Архитектура программы, имеющей собственный интерфейс подключаемых модулей графически представлена на рис. В.1, а. Недостатки такой архитектуры очевидны. Во-первых, с помощью подключаемых модулей невозможно изменить или дополнить базовые возможности приложения. Во-вторых, подключаемые модули не в состоянии использовать функции друг друга. В-третьих, приложение не может самостоятельно управлять подключаемыми модулями, например, для нужд макропрограммирования.

a

б

Рис. В.1. Традиционная архитектура приложения (а), архитектура InDesign (б)

Архитектура InDesign изображена на рис. В.1, б. Она лишена перечисленных недостатков традиционной. Все компоненты программы, включая ядро, являются подключаемыми модулями! Модули могут в соответствии с регламентированным интерфейсом взаимодействовать между собой и использовать отдельные функции друг друга. Это дает множество преимуществ разработчикам, а в конечном счете и пользователям программы. Для того чтобы исправить какие-либо ошибки, разработчикам достаточно заменить модуль, в котором они обнаружены. Столь же проста процедура обновления программы. Если разработчики реализовали какую-либо новую функцию, им не нужно переписывать многие фрагменты приложения, достаточно оформить функцию в виде подключаемого модуля. Модульная архитектура облегчает и жизнь пользователя. Чтобы установить обновление, не требуется переустанавливать все приложение. Нужно просто поместить в папку InDesign новый модуль - сразу после этого он готов к использованию.

Все это способно во много раз сократить сроки разработки обновления приложения и поставить на новый уровень поддержку пользователей. Они всегда будут иметь дело с программой, находящейся на переднем крае издательских технологий.

Не забывайте, что и ядро приложения стало мобильным, поскольку само является модулем! Теперь обновление версии программы сводится к изменению гораздо меньшего объема кода. Так, ядро InDesign занимает всего несколько мегабайт.

В отличие от других Приложений, InDesign полностью открыт для сторонних разработчиков. Теперь они получили доступ к внутренним функциям программы и имеют возможность создавать новые реализации практически любых функций InDesign и сколь угодно тесно интегрировать расширения в программу.

Таким образом, InDesign по архитектуре действительно больше напоминает операционную систему, чем традиционную издательскую программу. Подключаемые модули выполняют для нее роль приложений. Adobe сделали ставку на модульную организацию, открытость, мобильность и расширяемость своего детища. И это действительно является сильным доводом в их пользу в борьбе с традиционным конкурентом Quark Inc.


Общие компоненты

Сильная сторона InDesign заключена и в интеграции с другими компонентами издательской платформы Adobe. Photoshop, Illustrator и InDesign настолько похожи по внешнему виду, организации меню, виду палитр и их назначению, что вы не сразу сможете сказать, какое из приложений перед вами. Внешнее сходство интерфейса делает параллельную работу с приложениями исключительно удобной и легкой. Кроме того, это экономит много времени на освоение каждого следующего из них. Так, например, если вы знаете, как работает палитра Layers или Colors в Photoshop, то вы знаете, что с ними делать и в Illustrator и в InDesign.

Интеграция не ограничивается внешним сходством. Все перечисленные приложения используют единый код для большинства компонентов ядра:

  • Adobe Graphics Manager (AGM). Это графическая машина приложений Adobe, которая позволяет выводить на экран любые графические объекты, создаваемые в этих программах. Для этого AGM использует те же алгоритмы, которые использует при растеризации интерпретатор PostScript. Таким образом, при выводе документа будет получено то, что вы видите на экране.
  • СооlTуре. Этот компонент отвечает за растрирование шрифтов Type 1, TrueType и ОреnТуре, позволяя работать с ними напрямую, без Adobe TypeManager. Он также отвечает за кодировки и приведение шрифтов конкретной платформы к кодировке Unicode.
  • Modular Parsing System (MPS). Компонент отвечает за импортирование и преобразование кода PostScript в команды AGM. Благодаря единому коду, выполняющему эту работу, приложения Adobe достигают отличного соответствия при демонстрации EPS во всех своих программах.
  • PDF Library. Осуществляет полную поддержку формата PDF, включая интерпретацию при импортировании и экспортировании документов в этом формате. Приложения, использующие этот модуль, в состоянии напрямую создавать и редактировать PDF-документы (в InDesign эта функция еще не реализована).

Adobe CMS. Поддерживает управление цветом и обеспечивает одинаковое воспроизведение цветов во всех приложениях, задействованных в подготовке публикации.


Макропрограммирование

InDesign имеет развитую поддержку макропрограммирования на языках Ар-pleScript на платформе Macintosh и Visual Basic for Applications на платформе PC. Макроязык обеспечивает возможность автоматизации практически любых задач, выполняемых в InDesign. Поскольку эти макроязыки используются для программирования во всех приложениях на указанных платформах, макроопределения могут задействовать не только сам InDesign, но и другие приложения, например, текстовый редактор или электронные таблицы.

Макропрограммирование дает множество преимуществ, обеспечивая:

  • автоматизацию рутинных, часто выполняемых задач;
  • реализацию сложных действий, которые требуют много времени на выполнение вручную;
  • снижение количества ошибок, за счет автоматического выполнения работы.
  • уменьшение затрат времени на изучение, написание и отладку, по сравнению с подключаемыми модулями.

Кроме того, макропрограммирование доступно всем, а не только профессиональным программистам.


Системные требования

Требования InDesign к компьютеру на сегодняшний день достаточно высоки. Впрочем, при нынешней скорости развития компьютерной техники через полтора года они будут соответствовать вполне заурядному домашнему компьютеру.

Для платформы Windows:

  • Процессор не ниже Intel Pentium II 300 МГц. - Операционная система Windows 98/NT 4.0/2000.
  • Оперативная память 48 Мбайт.
  • 75 Мбайт свободного пространства на жестком диске.
  • Видеоадаптер, поддерживающий не менее 256 цветов при разрешении экрана 800х600 пикселов.
  • Привод CD-ROM.
  • Принтер PostScript Level 2 или выше. Для платформы Macintosh:
  • Процессор не ниже PowerPC 604 (рекомендуется G3). - Операционная система MacOS 8.5 или выше.
  • Оперативная память 48 Мбайт с включенной виртуальной памятью или 96 Мбайт с отключенной.
  • 120 Мбайт свободного пространства на жестком диске.
  • Видеоадаптер, поддерживающий не менее 256 цветов при разрешении экрана 832х624 пиксела.
  • Привод CD-ROM. - Принтер PostScript Level 2 или выше.

Если вы хотите получить более эффективную конфигурацию для работы с InDesign, в первую очередь подумайте об увеличении оперативной памяти . (в идеале не менее 128 Мбайт) и выборе более быстродействующего процессора (Pentium III/G4).


Структура книги

Настоящая книга является справочником, в котором вы можете найти сведения о всех возможностях InDesign, но она построена и с учетом принципа последовательного усложнения материала, принятого в учебной литературе. Мы пытались построить изложение таким образом, чтобы вам не приходилось часто заглядывать вперед для понимания материала. Ссылки вперед используются лишь для направления читателя к тому разделу, в котором он может получить более подробные сведения.

Часть I. Начала

Данная часть посвящена интерфейсу программы InDesign, ее настройке для обеспечения максимального удобства, а также обзору процесса подготовки публикации.

В ней вы найдете подробное описание того, что увидите на экране после (и даже до!) запуска InDesign и сведения об управлении отображением страниц публикации на экране компьютера (глава 1). Важно правильно сделать в программе установки "по умолчанию", с тем, чтобы они соответствовали вашим конкретным задачам.

Обзор пути публикации от идеи до тиража введет вас в сложный многоэтапный издательский процесс, в котором принимаете участие не только вы, но и заказчики, начальники, работники типографии и бюро предпечатной подготовки. Описание издательского процесса (глава 2) будет полезно тем, кто только планирует окунуться в издательскую деятельность, введет их в курс дела и, надеемся, не заставит отказаться от задуманного предприятия, а напротив, даст твердые ориентиры и сообщит уверенность в его выполнимости.

Часть II. Цвет

Цветопередача — головная боль всех принимающих участие в полиграфическом процессе. На вопрос о том, как сделать ее наиболее реалистичной, и отвечает эта часть. Описан весь арсенал средств InDesign по определению и использованию цвета при оформлении публикации (глава 4). Особое внимание уделено трудностям при работе с цветом и их преодолению — системе управления цветом.

Часть III. Текст

Эта часть посвящена форматированию и редактированию текста. В большинстве случаев текст — это то, ради чего затевается издание, та информация, которую следует донести до читателя. Профессионально оформленный текстовый материал необходим для выполнения задач, которые поставлены перед изданием. В этой части описаны все богатейшие возможности InDesign по обработке текста, начиная с ввода и форматирования отдельных символов и кончая глобальным форматированием, позволяющим менять стиль всей публикации несколькими щелчками мыши.

Часть IV. Графика

Прошло время, когда уделом маломощных персоналок была подготовка текста, а иллюстрации отдавались на откуп фотографам. InDesign позволяет создавать макеты иллюстрированных изданий любой степени сложности. Именно широкое использование рисунков, фотографий, монтажей придаст публикации яркость, выразительность и привлекательность. Кроме того, графическая информация воспринимается лучше, чем текстовая, и надолго запоминается. Наиболее часто используемые графические элементы можно (и нужно!) создавать непосредственно в InDesign.

Рассмотрен импорт графических материалов в InDesign и средства работы с ними: перемещение, искажение, масштабирование, кадрирование, обтравка и т. п. . Важную роль при создании публикации играет динамическая связь внешних графических материалов с публикацией (глава 13). Воз-

можность автоматического и ручного обновления связей является сильной стороной InDesign и также подвергнута пристальному анализу.

Часть V. Верстка

Самая большая и центральная часть книги посвящена верстке ~ компоновке текстовых и графических материалов, т. е. собственно созданию публикации. Для соблюдения единства стилей InDesign предлагает множественные шаблоны, шаблон-страницы, модульные сетки (главы 15 и 16). Взаимодействие текста и графики для достижения максимального эффекта при сохранении "мобильности" верстки рассмотрено в главах 1 и 15.

Особо рассмотрены специальные и сложные макеты, доставляющие много хлопот верстальщику (главы 15 и 16). Наши рекомендации помогут вам быстро и с минимальными затратами ручного труда оформить разнообразные бланки и таблицы (глава 16).

Развитие Internet сделало электронные публикации полноправной издательской продукцией. Минимальные затраты на "тираж" и отсутствие территориальных барьеров делают этот способ распространения информации все более и более привлекательным. InDesign поможет вам быстро адаптировать сверстанное издание для Всемирной Паутины (WWW) или создать ее специально для электронного распространения (глава 17).

Часть VI. Оригинал-макет

Часть посвящена завершающей стадии выпуска публикации — выводу оригинал-макета и печати тиража. Она познакомит читателя с основными понятиями полиграфии и их преломлении в настольных издательских системах. Вы узнаете, каким требованиям должна удовлетворять верстка, чтобы из электронной формы без потерь перенестись на бумагу (глава 19).

Сотрудничество с бюро предпечатной подготовки и типографией — залог успешного выпуска публикации. Организации такого взаимодействия и обеспечению легкой, удобной работы и экономии средств при печати, посвящена заключительная глава (глава 20).